Lucene.Net Namespace

Lucene.Net Namespace Lucene.Net Class Library
Classes
 | Class | Description
Public class | LucenePackage | Lucene's package information, including version. *

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)

Send Feedback on this topic.


LucenePackage Class

LucenePackage Class Lucene.Net Class Library
Lucene's package information, including version. *
Inheritance Hierarchy
Online System Object
Lucene.Net LucenePackage

Namespace: Lucene.Net
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LucenePackage
public sealed class LucenePackage
Public NotInheritable Class LucenePackage
Public NotInheritable Class LucenePackage
public ref class LucenePackage sealed
public ref class LucenePackage sealed
See Also
LucenePackage Members
Lucene.Net Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LucenePackage Members

LucenePackage Members Lucene.Net Class Library

The LucenePackage type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LucenePackage Class
Lucene.Net Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LucenePackage Methods

LucenePackage Methods Lucene.Net Class Library
The LucenePackage type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LucenePackage Class
Lucene.Net Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lucene.Net.Analysis Namespace

Lucene.Net.Analysis Namespace Lucene.Net Class Library
Classes
Class | Description
Public class Analyzer
An Analyzer builds TokenStreams, which analyze text. It thus represents a policy for extracting index terms from text.

Typical implementations first build a Tokenizer, which breaks the stream of characters from the Reader into raw Tokens. One or more TokenFilters may then be applied to the output of the Tokenizer.
Public class ASCIIFoldingFilter
This class converts alphabetic, numeric, and symbolic Unicode characters which are not in the first 127 ASCII characters (the "Basic Latin" Unicode block) into their ASCII equivalents, if one exists. Characters from the following Unicode blocks are converted; however, only those characters with reasonable ASCII alternatives are converted:
  • C1 Controls and Latin-1 Supplement: Online http://www.unicode.org/charts/PDF/U0080.pdf
  • Latin Extended-A: Online http://www.unicode.org/charts/PDF/U0100.pdf
  • Latin Extended-B: Online http://www.unicode.org/charts/PDF/U0180.pdf
  • Latin Extended Additional: Online http://www.unicode.org/charts/PDF/U1E00.pdf
  • Latin Extended-C: Online http://www.unicode.org/charts/PDF/U2C60.pdf
  • Latin Extended-D: Online http://www.unicode.org/charts/PDF/UA720.pdf
  • IPA Extensions: Online http://www.unicode.org/charts/PDF/U0250.pdf
  • Phonetic Extensions: Online http://www.unicode.org/charts/PDF/U1D00.pdf
  • Phonetic Extensions Supplement: Online http://www.unicode.org/charts/PDF/U1D80.pdf
  • General Punctuation: Online http://www.unicode.org/charts/PDF/U2000.pdf
  • Superscripts and Subscripts: Online http://www.unicode.org/charts/PDF/U2070.pdf
  • Enclosed Alphanumerics: Online http://www.unicode.org/charts/PDF/U2460.pdf
  • Dingbats: Online http://www.unicode.org/charts/PDF/U2700.pdf
  • Supplemental Punctuation: Online http://www.unicode.org/charts/PDF/U2E00.pdf
  • Alphabetic Presentation Forms: Online http://www.unicode.org/charts/PDF/UFB00.pdf
  • Halfwidth and Fullwidth Forms: Online http://www.unicode.org/charts/PDF/UFF00.pdf
See: Online http://en.wikipedia.org/wiki/Latin_characters_in_Unicode The set of character conversions supported by this class is a superset of those supported by Lucene's ISOLatin1AccentFilter which strips accents from Latin1 characters. For example, 'À' will be replaced by 'a'.
Public class BaseCharFilter
* Base utility class for implementing a CharFilter. * You subclass this, and then record mappings by calling * AddOffCorrectMap(Int32, Int32), and then invoke the correct * method to correct an offset.
Public class CachingTokenFilter
This class can be used if the token attributes of a TokenStream are intended to be consumed more than once. It caches all token attribute states locally in a List.

CachingTokenFilter implements the optional method Reset , which repositions the stream to the first Token.
Public class CharArraySet
A simple class that stores Strings as char[]'s in a hash table. Note that this is not a general purpose class. For example, it cannot remove items from the set, nor does it resize its hash table to be smaller, etc. It is designed to be quick to test if a char[] is in the set without the necessity of converting it to a String first.

Please note: This class implements Online ISet T but does not behave like it should in all cases. The generic type is Online ICollection T , because you can add any object to it, that has a string representation. The add methods will use Online ToString and store the result using a Online Char buffer. The same behaviour have the Contains(Object) methods. The GetEnumerator method returns an Online String IEnumerable. For type safety also {@link #stringIterator()} is provided.
Public class CharArraySet CharArraySetEnumerator
The IEnumerator<String> for this set. Strings are constructed on the fly, so use nextCharArray for more efficient access
Public class CharFilter
Subclasses of CharFilter can be chained to filter CharStream. They can be used as Online TextReader with additional offset correction. Tokenizers will automatically use CorrectOffset(Int32) if a CharFilter/CharStream subclass is used.
Public class CharReader
CharReader is a Reader wrapper. It reads chars from Reader and outputs CharStream, defining an identify function CorrectOffset(Int32) method that simply returns the provided offset.
Public class CharStream
CharStream adds CorrectOffset(Int32) functionality over Online TextReader. All Tokenizers accept a CharStream instead of Online TextReader as input, which enables arbitrary character based filtering before tokenization. The CorrectOffset(Int32) method fixed offsets to account for removal or insertion of characters, so that the offsets reported in the tokens match the character offsets of the original Reader.
Public class CharTokenizer
An abstract base class for simple, character-oriented tokenizers.
Public class ISOLatin1AccentFilter Obsolete.
A filter that replaces accented characters in the ISO Latin 1 character set (ISO-8859-1) by their unaccented equivalent. The case will not be altered.

For instance, 'À' will be replaced by 'a'.

Public class KeywordAnalyzer
"Tokenizes" the entire stream as a single token. This is useful for data like zip codes, ids, and some product names.
Public class KeywordTokenizer
Emits the entire input as a single token.
Public class LengthFilter
Removes words that are too long or too short from the stream.
Public class LetterTokenizer
A LetterTokenizer is a tokenizer that divides text at non-letters. That's to say, it defines tokens as maximal strings of adjacent letters, as defined by java.lang.Character.isLetter() predicate. Note: this does a decent job for most European languages, but does a terrible job for some Asian languages, where words are not separated by spaces.
Public class LowerCaseFilter
Normalizes token text to lower case.
Public class LowerCaseTokenizer
LowerCaseTokenizer performs the function of LetterTokenizer and LowerCaseFilter together. It divides text at non-letters and converts them to lower case. While it is functionally equivalent to the combination of LetterTokenizer and LowerCaseFilter, there is a performance advantage to doing the two tasks at once, hence this (redundant) implementation.

Note: this does a decent job for most European languages, but does a terrible job for some Asian languages, where words are not separated by spaces.
Public class MappingCharFilter
Simplistic CharFilter that applies the mappings contained in a NormalizeCharMap to the character stream, and correcting the resulting changes to the offsets.
Public class NormalizeCharMap
Holds a map of String input to String output, to be used with MappingCharFilter.
Public class NumericTokenStream
Expert: This class provides a TokenStream for indexing numeric values that can be used by NumericRangeQuery T or NumericRangeFilter T .

Note that for simple usage, NumericField is recommended. NumericField disables norms and term freqs, as they are not usually needed during searching. If you need to change these settings, you should use this class.

See NumericField for capabilities of fields indexed numerically.

Here's an example usage, for an int field:
View Colorized Copy to Clipboard Print
Field field = new Field(name, new NumericTokenStream(precisionStep).setIntValue(value));
field.setOmitNorms(true);
field.setOmitTermFreqAndPositions(true);
document.add(field);
Field field = new Field(name, new NumericTokenStream(precisionStep).setIntValue(value));
field.setOmitNorms(true);
field.setOmitTermFreqAndPositions(true);
document.add(field);

For optimal performance, re-use the TokenStream and Field instance for more than one document:
View Colorized Copy to Clipboard Print
NumericTokenStream stream = new NumericTokenStream(precisionStep);
Field field = new Field(name, stream);
field.setOmitNorms(true);
field.setOmitTermFreqAndPositions(true);
Document document = new Document();
document.add(field);

for(all documents) {
  stream.setIntValue(value)
  writer.addDocument(document);
}
NumericTokenStream stream = new NumericTokenStream(precisionStep);
Field field = new Field(name, stream);
field.setOmitNorms(true);
field.setOmitTermFreqAndPositions(true);
Document document = new Document();
document.add(field);

for(all documents) {
  stream.setIntValue(value)
  writer.addDocument(document);
}

This stream is not intended to be used in analyzers; it's more for iterating the different precisions during indexing a specific numeric value.

NOTE: as token streams are only consumed once the document is added to the index, if you index more than one numeric field, use a separate NumericTokenStream instance for each.

See NumericRangeQuery T for more details on the precisionStep parameter as well as how numeric fields work under the hood.

NOTE: This API is experimental and might change in incompatible ways in the next release. Since 2.9
Public class PerFieldAnalyzerWrapper
This analyzer is used to facilitate scenarios where different fields require different analysis techniques. Use AddAnalyzer(String, Analyzer) to add a non-default analyzer on a field name basis.

Example usage:
View Colorized Copy to Clipboard Print
PerFieldAnalyzerWrapper aWrapper =
new PerFieldAnalyzerWrapper(new StandardAnalyzer());
aWrapper.addAnalyzer("firstname", new KeywordAnalyzer());
aWrapper.addAnalyzer("lastname", new KeywordAnalyzer());
PerFieldAnalyzerWrapper aWrapper =
new PerFieldAnalyzerWrapper(new StandardAnalyzer());
aWrapper.addAnalyzer("firstname", new KeywordAnalyzer());
aWrapper.addAnalyzer("lastname", new KeywordAnalyzer());

In this example, StandardAnalyzer will be used for all fields except "firstname" and "lastname", for which KeywordAnalyzer will be used.

A PerFieldAnalyzerWrapper can be used like any other analyzer, for both indexing and query parsing.
Public class PorterStemFilter
Transforms the token stream as per the Porter stemming algorithm. Note: the input to the stemming filter must already be in lower case, so you will need to use LowerCaseFilter or LowerCaseTokenizer farther down the Tokenizer chain in order for this to work properly!

To use this filter with other analyzers, you'll want to write an Analyzer class that sets up the TokenStream chain as you want it. To use this with LowerCaseTokenizer, for example, you'd write an analyzer like this:

View Colorized Copy to Clipboard Print
class MyAnalyzer extends Analyzer {
    public final TokenStream tokenStream(String fieldName, Reader reader) {
         return new PorterStemFilter(new LowerCaseTokenizer(reader));
    }
}
class MyAnalyzer extends Analyzer {
    public final TokenStream tokenStream(String fieldName, Reader reader) {
         return new PorterStemFilter(new LowerCaseTokenizer(reader));
    }
}
Public class SimpleAnalyzer
An Analyzer that filters LetterTokenizer with LowerCaseFilter
Public class StopAnalyzer
Filters LetterTokenizer with LowerCaseFilter and StopFilter.

You must specify the required Version compatibility when creating StopAnalyzer:
  • As of 2.9, position increments are preserved
Public class StopFilter
Removes stop words from a token stream.
Public class TeeSinkTokenFilter
This TokenFilter provides the ability to set aside attribute states that have already been analyzed. This is useful in situations where multiple fields share many common analysis steps and then go their separate ways.

It is also useful for doing things like entity extraction or proper noun analysis as part of the analysis workflow and saving off those tokens for use in another field.
View Colorized Copy to Clipboard Print
TeeSinkTokenFilter source1 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader1));
TeeSinkTokenFilter.SinkTokenStream sink1 = source1.newSinkTokenStream();
TeeSinkTokenFilter.SinkTokenStream sink2 = source1.newSinkTokenStream();
TeeSinkTokenFilter source2 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader2));
source2.addSinkTokenStream(sink1);
source2.addSinkTokenStream(sink2);
TokenStream final1 = new LowerCaseFilter(source1);
TokenStream final2 = source2;
TokenStream final3 = new EntityDetect(sink1);
TokenStream final4 = new URLDetect(sink2);
d.add(new Field("f1", final1));
d.add(new Field("f2", final2));
d.add(new Field("f3", final3));
d.add(new Field("f4", final4));
TeeSinkTokenFilter source1 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader1));
TeeSinkTokenFilter.SinkTokenStream sink1 = source1.newSinkTokenStream();
TeeSinkTokenFilter.SinkTokenStream sink2 = source1.newSinkTokenStream();
TeeSinkTokenFilter source2 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader2));
source2.addSinkTokenStream(sink1);
source2.addSinkTokenStream(sink2);
TokenStream final1 = new LowerCaseFilter(source1);
TokenStream final2 = source2;
TokenStream final3 = new EntityDetect(sink1);
TokenStream final4 = new URLDetect(sink2);
d.add(new Field("f1", final1));
d.add(new Field("f2", final2));
d.add(new Field("f3", final3));
d.add(new Field("f4", final4));
In this example, sink1 and sink2 will both get tokens from both reader1 and reader2 after whitespace tokenizer and now we can further wrap any of these in extra analysis, and more "sources" can be inserted if desired. It is important, that tees are consumed before sinks (in the above example, the field names must be less the sink's field names). If you are not sure, which stream is consumed first, you can simply add another sink and then pass all tokens to the sinks at once using ConsumeAllTokens . This TokenFilter is exhausted after this. In the above example, change the example above to:
View Colorized Copy to Clipboard Print
...
TokenStream final1 = new LowerCaseFilter(source1.newSinkTokenStream());
TokenStream final2 = source2.newSinkTokenStream();
sink1.consumeAllTokens();
sink2.consumeAllTokens();
...
...
TokenStream final1 = new LowerCaseFilter(source1.newSinkTokenStream());
TokenStream final2 = source2.newSinkTokenStream();
sink1.consumeAllTokens();
sink2.consumeAllTokens();
...
In this case, the fields can be added in any order, because the sources are not used anymore and all sinks are ready.

Note, the EntityDetect and URLDetect TokenStreams are for the example and do not currently exist in Lucene.
Public class | TeeSinkTokenFilter AnonymousClassSinkFilter
Public class TeeSinkTokenFilter SinkFilter
A filter that decides which AttributeSource states to store in the sink.
Public class | TeeSinkTokenFilter SinkTokenStream
Public class Token
A Token is an occurrence of a term from the text of a field. It consists of a term's text, the start and end offset of the term in the text of the field, and a type string.

The start and end offsets permit applications to re-associate a token with its source text, e.g., to display highlighted query terms in a document browser, or to show matching text fragments in a KWIC display, etc.

The type is a string, assigned by a lexical analyzer (a.k.a. tokenizer), naming the lexical or syntactic class that the token belongs to. For example an end of sentence marker token might be implemented with type "eos". The default token type is "word".

A Token can optionally have metadata (a.k.a. Payload) in the form of a variable length byte array. Use PayloadLength and GetPayload( Byte , Int32) to retrieve the payloads from the index.
Public class Token TokenAttributeFactory
Expert: Creates an AttributeFactory returning {@link Token} as instance for the basic attributes and for all other attributes calls the given delegate factory.
Public class TokenFilter
A TokenFilter is a TokenStream whose input is another TokenStream.

This is an abstract class; subclasses must override IncrementToken .
Public class Tokenizer
A Tokenizer is a TokenStream whose input is a Reader.

This is an abstract class; subclasses must override IncrementToken

NOTE: Subclasses overriding IncrementToken must call ClearAttributes before setting attributes.
Public class TokenStream
A TokenStream enumerates the sequence of tokens, either from Fields of a Document or from query text.

This is an abstract class. Concrete subclasses are:
  • Tokenizer, a TokenStream whose input is a Reader; and
  • TokenFilter, a TokenStream whose input is another TokenStream.
A new TokenStream API has been introduced with Lucene 2.9. This API has moved from being Token based to IAttribute based. While Token still exists in 2.9 as a convenience class, the preferred way to store the information of a Token is to use Attributes.

TokenStream now extends AttributeSource, which provides access to all of the token IAttributes for the TokenStream. Note that only one instance per Attribute is created and reused for every token. This approach reduces object creation and allows local caching of references to the Attributes. See IncrementToken for further details.

The workflow of the new TokenStream API is as follows:
  • Instantiation of TokenStream/TokenFilters which add/get attributes to/from the AttributeSource.
  • The consumer calls Reset .
  • The consumer retrieves attributes from the stream and stores local references to all attributes it wants to access
  • The consumer calls IncrementToken until it returns false and consumes the attributes after each call.
  • The consumer calls End so that any end-of-stream operations can be performed.
  • The consumer calls Close to release any resource when finished using the TokenStream
To make sure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in IncrementToken .

You can find some example code for the new API in the analysis package level Javadoc.

Sometimes it is desirable to capture a current state of a TokenStream , e. g. for buffering purposes (see CachingTokenFilter, TeeSinkTokenFilter). For this usecase CaptureState and RestoreState(AttributeSource State) can be used.
Public class WhitespaceAnalyzer
An Analyzer that uses WhitespaceTokenizer.
Public class WhitespaceTokenizer
A WhitespaceTokenizer is a tokenizer that divides text at whitespace. Adjacent sequences of non-Whitespace characters form tokens.
Public class WordlistLoader
Loader for text files that represent a list of stopwords.

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Analyzer Class

Analyzer Class Lucene.Net Class Library
An Analyzer builds TokenStreams, which analyze text. It thus represents a policy for extracting index terms from text.

Typical implementations first build a Tokenizer, which breaks the stream of characters from the Reader into raw Tokens. One or more TokenFilters may then be applied to the output of the Tokenizer.
Inheritance Hierarchy
Online System Object
Lucene.Net.Analysis Analyzer
Lucene.Net.Analysis KeywordAnalyzer
Lucene.Net.Analysis PerFieldAnalyzerWrapper
Lucene.Net.Analysis SimpleAnalyzer
Lucene.Net.Analysis.Standard StandardAnalyzer
Lucene.Net.Analysis StopAnalyzer
Lucene.Net.Analysis WhitespaceAnalyzer

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Analyzer : IDisposable
public abstract class Analyzer : IDisposable
Public MustInherit Class Analyzer _
    Implements IDisposable
Public MustInherit Class Analyzer _
    Implements IDisposable
public ref class Analyzer abstract : IDisposable
public ref class Analyzer abstract : IDisposable
See Also
Analyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Analyzer Members

Analyzer Members Lucene.Net Class Library

The Analyzer type exposes the following members.
Constructors
 | Name | Description
Protected method | Analyzer | Initializes a new instance of the Analyzer class
Back to Top
Methods
 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer
Public method | Dispose | Releases all resources used by the Analyzer
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Analyzer and optionally releases the managed resources
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetOffsetGap | Just like GetPositionIncrementGap(String), except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing.
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance.
Protected method | SetOverridesTokenStreamMethod TClass | Obsolete. Java uses Class<? extends Analyer> to constrain TClass to only Types that inherit from Analyzer. C# does not have a generic type class, ie Type<t>. The method signature stays the same, and an exception may still be thrown, if the method doesn't exist.
Public method | TokenStream | Creates a TokenStream which tokenizes all the text in the provided Reader. Must be able to handle null field name for backward compatibility.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | overridesTokenStreamMethod | Obsolete.
Back to Top
Properties
 | Name | Description
Protected property | PreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
Back to Top
See Also
Analyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Analyzer Constructor

Analyzer Constructor Lucene.Net Class Library
Initializes a new instance of the Analyzer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Analyzer()
protected Analyzer()
Protected Sub New
Protected Sub New
protected:
Analyzer()
protected:
Analyzer()
See Also
Analyzer Class
Analyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Analyzer Fields

Analyzer Fields Lucene.Net Class Library
The Analyzer type exposes the following members.
Fields
 | Name | Description
Protected field | overridesTokenStreamMethod | Obsolete.
Back to Top
See Also
Analyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


overridesTokenStreamMethod Field

Analyzer overridesTokenStreamMethod Field Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute]
protected bool overridesTokenStreamMethod
[ObsoleteAttribute]
protected bool overridesTokenStreamMethod
<ObsoleteAttribute> _
Protected overridesTokenStreamMethod As Boolean
<ObsoleteAttribute> _
Protected overridesTokenStreamMethod As Boolean
protected:
[ObsoleteAttribute]
bool overridesTokenStreamMethod
protected:
[ObsoleteAttribute]
bool overridesTokenStreamMethod
See Also
Analyzer Class
Analyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Analyzer Methods

Analyzer Methods Lucene.Net Class Library
The Analyzer type exposes the following members.
Methods
 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetOffsetGap | Just like GetPositionIncrementGap(String), except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing.
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance.
Protected method | SetOverridesTokenStreamMethod TClass | Obsolete. Java uses Class<? extends Analyer> to constrain TClass to only Types that inherit from Analyzer. C# does not have a generic type class, ie Type<t>. The method signature stays the same, and an exception may still be thrown, if the method doesn't exist.
Public method | TokenStream | Creates a TokenStream which tokenizes all the text in the provided Reader. Must be able to handle null field name for backward compatibility.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Analyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

Analyzer Close Method Lucene.Net Class Library
Frees persistent resources used by this Analyzer

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Close()
public void Close()
Public Sub Close
Public Sub Close
public:
void Close()
public:
void Close()
See Also
Analyzer Class
Analyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

Analyzer Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Analyzer
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Analyzer and optionally releases the managed resources
Back to Top
See Also
Analyzer Class
Analyzer Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

Analyzer Dispose Method Lucene.Net Class Library
Releases all resources used by the Analyzer

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Dispose()
public virtual void Dispose()
Public Overridable Sub Dispose
Public Overridable Sub Dispose
public:
virtual void Dispose()
public:
virtual void Dispose()
Implements
  Online IDisposable Dispose
See Also
Analyzer Class
Analyzer Members
Dispose Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

Analyzer Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the Analyzer and optionally releases the managed resources

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void Dispose(
    bool disposing
)
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
)
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
Analyzer Class
Analyzer Members
Dispose Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetOffsetGap Method

Analyzer GetOffsetGap Method Lucene.Net Class Library
Just like GetPositionIncrementGap(String), except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int GetOffsetGap(
    IFieldable field
)
public virtual int GetOffsetGap(
    IFieldable field
)
Public Overridable Function GetOffsetGap ( _
    field As IFieldable _
) As Integer
Public Overridable Function GetOffsetGap ( _
    field As IFieldable _
) As Integer
public:
virtual int GetOffsetGap(
    IFieldable^ field
)
public:
virtual int GetOffsetGap(
    IFieldable^ field
)
Parameters
field
Type: Lucene.Net.Documents IFieldable
the field just indexed

Return Value
 offset gap, added to the next token emitted from TokenStream(String, TextReader)
See Also
Analyzer Class
Analyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPositionIncrementGap Method

Analyzer GetPositionIncrementGap Method Lucene.Net Class Library
Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int GetPositionIncrementGap(
    string fieldName
)
public virtual int GetPositionIncrementGap(
    string fieldName
)
Public Overridable Function GetPositionIncrementGap ( _
    fieldName As String _
) As Integer
Public Overridable Function GetPositionIncrementGap ( _
    fieldName As String _
) As Integer
public:
virtual int GetPositionIncrementGap(
    String^ fieldName
)
public:
virtual int GetPositionIncrementGap(
    String^ fieldName
)
Parameters
fieldName
Type:   Online System String
Fieldable name being indexed.

Return Value
 position increment gap, added to the next token emitted from TokenStream(String, TextReader)
See Also
Analyzer Class
Analyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReusableTokenStream Method

Analyzer ReusableTokenStream Method Lucene.Net Class Library
Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
public virtual TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
Public Overridable Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Public Overridable Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
)
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
)
Parameters
fieldName
Type:   Online System String
reader
Type:   Online System.IO TextReader
See Also
Analyzer Class
Analyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetOverridesTokenStreamMethod(TClass) Method

Analyzer SetOverridesTokenStreamMethod TClass Method Lucene.Net Class Library
Java uses Class<? extends Analyer> to constrain TClass to only Types that inherit from Analyzer. C# does not have a generic type class, ie Type<t>. The method signature stays the same, and an exception may still be thrown, if the method doesn't exist.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("This is only present to preserve back-compat of classes that subclass a core analyzer and override tokenStream but not reusableTokenStream ")]
protected virtual void SetOverridesTokenStreamMethod<TClass>()
where TClass : Analyzer
[ObsoleteAttribute("This is only present to preserve back-compat of classes that subclass a core analyzer and override tokenStream but not reusableTokenStream ")]
protected virtual void SetOverridesTokenStreamMethod<TClass>()
where TClass : Analyzer
<ObsoleteAttribute("This is only present to preserve back-compat of classes that subclass a core analyzer and override tokenStream but not reusableTokenStream ")> _
Protected Overridable Sub SetOverridesTokenStreamMethod(Of TClass As Analyzer)
<ObsoleteAttribute("This is only present to preserve back-compat of classes that subclass a core analyzer and override tokenStream but not reusableTokenStream ")> _
Protected Overridable Sub SetOverridesTokenStreamMethod(Of TClass As Analyzer)
protected:
[ObsoleteAttribute(L"This is only present to preserve back-compat of classes that subclass a core analyzer and override tokenStream but not reusableTokenStream ")]
generic<typename TClass>
where TClass : Analyzer
virtual void SetOverridesTokenStreamMethod()
protected:
[ObsoleteAttribute(L"This is only present to preserve back-compat of classes that subclass a core analyzer and override tokenStream but not reusableTokenStream ")]
generic<typename TClass>
where TClass : Analyzer
virtual void SetOverridesTokenStreamMethod()
Type Parameters
TClass
See Also
Analyzer Class
Analyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStream Method

Analyzer TokenStream Method Lucene.Net Class Library
Creates a TokenStream which tokenizes all the text in the provided Reader. Must be able to handle null field name for backward compatibility.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
public abstract TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Public MustOverride Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Public MustOverride Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) abstract
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) abstract
Parameters
fieldName
Type:   Online System String
reader
Type:   Online System.IO TextReader
See Also
Analyzer Class
Analyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Analyzer Properties

Analyzer Properties Lucene.Net Class Library
The Analyzer type exposes the following members.
Properties
 | Name | Description
Protected property | PreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
Back to Top
See Also
Analyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PreviousTokenStream Property

Analyzer PreviousTokenStream Property Lucene.Net Class Library
Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Object PreviousTokenStream { get; set; }
protected virtual Object PreviousTokenStream { get; set; }
Protected Overridable Property PreviousTokenStream As Object
    Get
    Set
Protected Overridable Property PreviousTokenStream As Object
    Get
    Set
protected:
virtual property Object^ PreviousTokenStream {
    Object^ get ();
    void set (Object^ value);
}
protected:
virtual property Object^ PreviousTokenStream {
    Object^ get ();
    void set (Object^ value);
}
See Also
Analyzer Class
Analyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ASCIIFoldingFilter Class

ASCIIFoldingFilter Class Lucene.Net Class Library
This class converts alphabetic, numeric, and symbolic Unicode characters which are not in the first 127 ASCII characters (the "Basic Latin" Unicode block) into their ASCII equivalents, if one exists. Characters from the following Unicode blocks are converted; however, only those characters with reasonable ASCII alternatives are converted:
  • C1 Controls and Latin-1 Supplement: Online http://www.unicode.org/charts/PDF/U0080.pdf
  • Latin Extended-A: Online http://www.unicode.org/charts/PDF/U0100.pdf
  • Latin Extended-B: Online http://www.unicode.org/charts/PDF/U0180.pdf
  • Latin Extended Additional: Online http://www.unicode.org/charts/PDF/U1E00.pdf
  • Latin Extended-C: Online http://www.unicode.org/charts/PDF/U2C60.pdf
  • Latin Extended-D: Online http://www.unicode.org/charts/PDF/UA720.pdf
  • IPA Extensions: Online http://www.unicode.org/charts/PDF/U0250.pdf
  • Phonetic Extensions: Online http://www.unicode.org/charts/PDF/U1D00.pdf
  • Phonetic Extensions Supplement: Online http://www.unicode.org/charts/PDF/U1D80.pdf
  • General Punctuation: Online http://www.unicode.org/charts/PDF/U2000.pdf
  • Superscripts and Subscripts: Online http://www.unicode.org/charts/PDF/U2070.pdf
  • Enclosed Alphanumerics: Online http://www.unicode.org/charts/PDF/U2460.pdf
  • Dingbats: Online http://www.unicode.org/charts/PDF/U2700.pdf
  • Supplemental Punctuation: Online http://www.unicode.org/charts/PDF/U2E00.pdf
  • Alphabetic Presentation Forms: Online http://www.unicode.org/charts/PDF/UFB00.pdf
  • Halfwidth and Fullwidth Forms: Online http://www.unicode.org/charts/PDF/UFF00.pdf
See: Online http://en.wikipedia.org/wiki/Latin_characters_in_Unicode The set of character conversions supported by this class is a superset of those supported by Lucene's ISOLatin1AccentFilter which strips accents from Latin1 characters. For example, 'À' will be replaced by 'a'.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis TokenFilter
Lucene.Net.Analysis ASCIIFoldingFilter

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ASCIIFoldingFilter : TokenFilter
public sealed class ASCIIFoldingFilter : TokenFilter
Public NotInheritable Class ASCIIFoldingFilter _
    Inherits TokenFilter
Public NotInheritable Class ASCIIFoldingFilter _
    Inherits TokenFilter
public ref class ASCIIFoldingFilter sealed : public TokenFilter
public ref class ASCIIFoldingFilter sealed : public TokenFilter
See Also
ASCIIFoldingFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ASCIIFoldingFilter Members

ASCIIFoldingFilter Members Lucene.Net Class Library

The ASCIIFoldingFilter type exposes the following members.
Constructors
 | Name | Description
Public method | ASCIIFoldingFilter | Initializes a new instance of the ASCIIFoldingFilter class
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | Performs end-of-stream operations, if any, and calls then end() on the input TokenStream. NOTE: Be sure to call super.end() first when overriding this method. (Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FoldToASCII | Converts characters above ASCII to their ASCII equivalents. For example, accents are removed from accented characters.
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Reset the filter as well as the input TokenStream. (Inherited from TokenFilter.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
ASCIIFoldingFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ASCIIFoldingFilter Constructor

ASCIIFoldingFilter Constructor Lucene.Net Class Library
Initializes a new instance of the ASCIIFoldingFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ASCIIFoldingFilter(
    TokenStream input
)
public ASCIIFoldingFilter(
    TokenStream input
)
Public Sub New ( _
    input As TokenStream _
)
Public Sub New ( _
    input As TokenStream _
)
public:
ASCIIFoldingFilter(
    TokenStream^ input
)
public:
ASCIIFoldingFilter(
    TokenStream^ input
)
Parameters
input
Type: Lucene.Net.Analysis TokenStream
See Also
ASCIIFoldingFilter Class
ASCIIFoldingFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ASCIIFoldingFilter Fields

ASCIIFoldingFilter Fields Lucene.Net Class Library
The ASCIIFoldingFilter type exposes the following members.
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
See Also
ASCIIFoldingFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ASCIIFoldingFilter Methods

ASCIIFoldingFilter Methods Lucene.Net Class Library
The ASCIIFoldingFilter type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | Performs end-of-stream operations, if any, and calls then end() on the input TokenStream. NOTE: Be sure to call super.end() first when overriding this method. (Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FoldToASCII | Converts characters above ASCII to their ASCII equivalents. For example, accents are removed from accented characters.
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Reset the filter as well as the input TokenStream. (Inherited from TokenFilter.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
ASCIIFoldingFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FoldToASCII Method

ASCIIFoldingFilter FoldToASCII Method Lucene.Net Class Library
Converts characters above ASCII to their ASCII equivalents. For example, accents are removed from accented characters.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void FoldToASCII(
    char[] input,
    int length
)
public void FoldToASCII(
    char[] input,
    int length
)
Public Sub FoldToASCII ( _
    input As Char(), _
    length As Integer _
)
Public Sub FoldToASCII ( _
    input As Char(), _
    length As Integer _
)
public:
void FoldToASCII(
    array<wchar_t>^ input,
    int length
)
public:
void FoldToASCII(
    array<wchar_t>^ input,
    int length
)
Parameters
input
Type:    Online System Char
The string to fold

length
Type:   Online System Int32
The number of characters in the input string

See Also
ASCIIFoldingFilter Class
ASCIIFoldingFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncrementToken Method

ASCIIFoldingFilter IncrementToken Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IncrementToken()
public override bool IncrementToken()
Public Overrides Function IncrementToken As Boolean
Public Overrides Function IncrementToken As Boolean
public:
virtual bool IncrementToken() override
public:
virtual bool IncrementToken() override
See Also
ASCIIFoldingFilter Class
ASCIIFoldingFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ASCIIFoldingFilter Properties

ASCIIFoldingFilter Properties Lucene.Net Class Library
The ASCIIFoldingFilter type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
ASCIIFoldingFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BaseCharFilter Class

BaseCharFilter Class Lucene.Net Class Library
* Base utility class for implementing a CharFilter. * You subclass this, and then record mappings by calling * AddOffCorrectMap(Int32, Int32), and then invoke the correct * method to correct an offset.
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO TextReader
Online System.IO StreamReader
Lucene.Net.Analysis CharStream
Lucene.Net.Analysis CharFilter
Lucene.Net.Analysis BaseCharFilter
Lucene.Net.Analysis MappingCharFilter

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class BaseCharFilter : CharFilter
public abstract class BaseCharFilter : CharFilter
Public MustInherit Class BaseCharFilter _
    Inherits CharFilter
Public MustInherit Class BaseCharFilter _
    Inherits CharFilter
public ref class BaseCharFilter abstract : public CharFilter
public ref class BaseCharFilter abstract : public CharFilter
See Also
BaseCharFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BaseCharFilter Members

BaseCharFilter Members Lucene.Net Class Library

The BaseCharFilter type exposes the following members.
Constructors
 | Name | Description
Protected method | BaseCharFilter | Initializes a new instance of the BaseCharFilter class
Back to Top
Methods
 | Name | Description
Protected method | AddOffCorrectMap |
Public method | Online Close | Closes the Online StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from Online StreamReader.)
Protected method | Correct | (Overrides CharFilter Correct(Int32).)
Public method | CorrectOffset | Chains the corrected offset through the input CharFilter. (Inherited from CharFilter.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online DiscardBufferedData | Allows a Online StreamReader object to discard its current data. (Inherited from Online StreamReader.)
Public method | Online Dispose | Releases all resources used by the Online TextReader object. (Inherited from Online TextReader.)
Protected method | Dispose(Boolean) | (Inherited from CharFilter.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Protected method | GetLastCumulativeDiff | Obsolete.
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Mark | (Inherited from CharFilter.)
Public method | MarkSupported | (Inherited from CharFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online Peek | Returns the next available character but does not consume it. (Inherited from Online StreamReader.)
Public method | Online Read | Reads the next character from the input stream and advances the character position by one character. (Inherited from Online StreamReader.)
Public method | Read( Char , Int32, Int32) | (Inherited from CharFilter.)
Public method | Online ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from Online TextReader.)
Public method | Online ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from Online StreamReader.)
Public method | Online ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from Online StreamReader.)
Public method | Reset | (Inherited from CharFilter.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | input | (Inherited from CharFilter.)
Back to Top
Properties
 | Name | Description
Public property | Online BaseStream | Returns the underlying stream. (Inherited from Online StreamReader.)
Public property | Online CurrentEncoding | Gets the current character encoding that the current Online StreamReader object is using. (Inherited from Online StreamReader.)
Public property | Online EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from Online StreamReader.)
Protected property | LastCumulativeDiff |
Back to Top
See Also
BaseCharFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BaseCharFilter Constructor

BaseCharFilter Constructor Lucene.Net Class Library
Initializes a new instance of the BaseCharFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected BaseCharFilter(
    CharStream in
)
protected BaseCharFilter(
    CharStream in
)
Protected Sub New ( _
    in As CharStream _
)
Protected Sub New ( _
    in As CharStream _
)
protected:
BaseCharFilter(
    CharStream^ in
)
protected:
BaseCharFilter(
    CharStream^ in
)
Parameters
in
Type: Lucene.Net.Analysis CharStream
See Also
BaseCharFilter Class
BaseCharFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BaseCharFilter Fields

BaseCharFilter Fields Lucene.Net Class Library
The BaseCharFilter type exposes the following members.
Fields
 | Name | Description
Protected field | input | (Inherited from CharFilter.)
Back to Top
See Also
BaseCharFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BaseCharFilter Methods

BaseCharFilter Methods Lucene.Net Class Library
The BaseCharFilter type exposes the following members.
Methods
 | Name | Description
Protected method | AddOffCorrectMap |
Public method | Online Close | Closes the Online StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from Online StreamReader.)
Protected method | Correct | (Overrides CharFilter Correct(Int32).)
Public method | CorrectOffset | Chains the corrected offset through the input CharFilter. (Inherited from CharFilter.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online DiscardBufferedData | Allows a Online StreamReader object to discard its current data. (Inherited from Online StreamReader.)
Public method | Online Dispose | Releases all resources used by the Online TextReader object. (Inherited from Online TextReader.)
Protected method | Dispose(Boolean) | (Inherited from CharFilter.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Protected method | GetLastCumulativeDiff | Obsolete.
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Mark | (Inherited from CharFilter.)
Public method | MarkSupported | (Inherited from CharFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online Peek | Returns the next available character but does not consume it. (Inherited from Online StreamReader.)
Public method | Online Read | Reads the next character from the input stream and advances the character position by one character. (Inherited from Online StreamReader.)
Public method | Read( Char , Int32, Int32) | (Inherited from CharFilter.)
Public method | Online ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from Online TextReader.)
Public method | Online ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from Online StreamReader.)
Public method | Online ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from Online StreamReader.)
Public method | Reset | (Inherited from CharFilter.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
BaseCharFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddOffCorrectMap Method

BaseCharFilter AddOffCorrectMap Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void AddOffCorrectMap(
    int off,
    int cumulativeDiff
)
protected void AddOffCorrectMap(
    int off,
    int cumulativeDiff
)
Protected Sub AddOffCorrectMap ( _
    off As Integer, _
    cumulativeDiff As Integer _
)
Protected Sub AddOffCorrectMap ( _
    off As Integer, _
    cumulativeDiff As Integer _
)
protected:
void AddOffCorrectMap(
    int off,
    int cumulativeDiff
)
protected:
void AddOffCorrectMap(
    int off,
    int cumulativeDiff
)
Parameters
off
Type:   Online System Int32
cumulativeDiff
Type:   Online System Int32
See Also
BaseCharFilter Class
BaseCharFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Correct Method

BaseCharFilter Correct Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override int Correct(
    int currentOff
)
protected override int Correct(
    int currentOff
)
Protected Overrides Function Correct ( _
    currentOff As Integer _
) As Integer
Protected Overrides Function Correct ( _
    currentOff As Integer _
) As Integer
protected:
virtual int Correct(
    int currentOff
) override
protected:
virtual int Correct(
    int currentOff
) override
Parameters
currentOff
Type:   Online System Int32
See Also
BaseCharFilter Class
BaseCharFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLastCumulativeDiff Method

BaseCharFilter GetLastCumulativeDiff Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use LastCumulativeDiff property instead")]
protected int GetLastCumulativeDiff()
[ObsoleteAttribute("Use LastCumulativeDiff property instead")]
protected int GetLastCumulativeDiff()
<ObsoleteAttribute("Use LastCumulativeDiff property instead")> _
Protected Function GetLastCumulativeDiff As Integer
<ObsoleteAttribute("Use LastCumulativeDiff property instead")> _
Protected Function GetLastCumulativeDiff As Integer
protected:
[ObsoleteAttribute(L"Use LastCumulativeDiff property instead")]
int GetLastCumulativeDiff()
protected:
[ObsoleteAttribute(L"Use LastCumulativeDiff property instead")]
int GetLastCumulativeDiff()
See Also
BaseCharFilter Class
BaseCharFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BaseCharFilter Properties

BaseCharFilter Properties Lucene.Net Class Library
The BaseCharFilter type exposes the following members.
Properties
 | Name | Description
Public property | Online BaseStream | Returns the underlying stream. (Inherited from Online StreamReader.)
Public property | Online CurrentEncoding | Gets the current character encoding that the current Online StreamReader object is using. (Inherited from Online StreamReader.)
Public property | Online EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from Online StreamReader.)
Protected property | LastCumulativeDiff |
Back to Top
See Also
BaseCharFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LastCumulativeDiff Property

BaseCharFilter LastCumulativeDiff Property Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int LastCumulativeDiff { get; }
protected int LastCumulativeDiff { get; }
Protected ReadOnly Property LastCumulativeDiff As Integer
    Get
Protected ReadOnly Property LastCumulativeDiff As Integer
    Get
protected:
property int LastCumulativeDiff {
    int get ();
}
protected:
property int LastCumulativeDiff {
    int get ();
}
See Also
BaseCharFilter Class
BaseCharFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingTokenFilter Class

CachingTokenFilter Class Lucene.Net Class Library
This class can be used if the token attributes of a TokenStream are intended to be consumed more than once. It caches all token attribute states locally in a List.

CachingTokenFilter implements the optional method Reset , which repositions the stream to the first Token.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis TokenFilter
Lucene.Net.Analysis CachingTokenFilter

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CachingTokenFilter : TokenFilter
public sealed class CachingTokenFilter : TokenFilter
Public NotInheritable Class CachingTokenFilter _
    Inherits TokenFilter
Public NotInheritable Class CachingTokenFilter _
    Inherits TokenFilter
public ref class CachingTokenFilter sealed : public TokenFilter
public ref class CachingTokenFilter sealed : public TokenFilter
See Also
CachingTokenFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingTokenFilter Members

CachingTokenFilter Members Lucene.Net Class Library

The CachingTokenFilter type exposes the following members.
Constructors
 | Name | Description
Public method | CachingTokenFilter | Initializes a new instance of the CachingTokenFilter class
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | (Overrides TokenFilter End .)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | (Overrides TokenFilter Reset .)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
CachingTokenFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingTokenFilter Constructor

CachingTokenFilter Constructor Lucene.Net Class Library
Initializes a new instance of the CachingTokenFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CachingTokenFilter(
    TokenStream input
)
public CachingTokenFilter(
    TokenStream input
)
Public Sub New ( _
    input As TokenStream _
)
Public Sub New ( _
    input As TokenStream _
)
public:
CachingTokenFilter(
    TokenStream^ input
)
public:
CachingTokenFilter(
    TokenStream^ input
)
Parameters
input
Type: Lucene.Net.Analysis TokenStream
See Also
CachingTokenFilter Class
CachingTokenFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingTokenFilter Fields

CachingTokenFilter Fields Lucene.Net Class Library
The CachingTokenFilter type exposes the following members.
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
See Also
CachingTokenFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingTokenFilter Methods

CachingTokenFilter Methods Lucene.Net Class Library
The CachingTokenFilter type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | (Overrides TokenFilter End .)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | (Overrides TokenFilter Reset .)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
CachingTokenFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


End Method

CachingTokenFilter End Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void End()
public override void End()
Public Overrides Sub End
Public Overrides Sub End
public:
virtual void End() override
public:
virtual void End() override
See Also
CachingTokenFilter Class
CachingTokenFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncrementToken Method

CachingTokenFilter IncrementToken Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IncrementToken()
public override bool IncrementToken()
Public Overrides Function IncrementToken As Boolean
Public Overrides Function IncrementToken As Boolean
public:
virtual bool IncrementToken() override
public:
virtual bool IncrementToken() override
See Also
CachingTokenFilter Class
CachingTokenFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method

CachingTokenFilter Reset Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Reset()
public override void Reset()
Public Overrides Sub Reset
Public Overrides Sub Reset
public:
virtual void Reset() override
public:
virtual void Reset() override
See Also
CachingTokenFilter Class
CachingTokenFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingTokenFilter Properties

CachingTokenFilter Properties Lucene.Net Class Library
The CachingTokenFilter type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
CachingTokenFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharArraySet Class

CharArraySet Class Lucene.Net Class Library
A simple class that stores Strings as char[]'s in a hash table. Note that this is not a general purpose class. For example, it cannot remove items from the set, nor does it resize its hash table to be smaller, etc. It is designed to be quick to test if a char[] is in the set without the necessity of converting it to a String first.

Please note: This class implements Online ISet T but does not behave like it should in all cases. The generic type is Online ICollection T , because you can add any object to it, that has a string representation. The add methods will use Online ToString and store the result using a Online Char buffer. The same behaviour have the Contains(Object) methods. The GetEnumerator method returns an Online String IEnumerable. For type safety also {@link #stringIterator()} is provided.
Inheritance Hierarchy
Online System Object
Lucene.Net.Analysis CharArraySet

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CharArraySet : ISet<string>,
    ICollection<string>, IEnumerable<string>, IEnumerable
public class CharArraySet : ISet<string>,
    ICollection<string>, IEnumerable<string>, IEnumerable
Public Class CharArraySet _
    Implements ISet(Of String), ICollection(Of String),  _
    IEnumerable(Of String), IEnumerable
Public Class CharArraySet _
    Implements ISet(Of String), ICollection(Of String),  _
    IEnumerable(Of String), IEnumerable
public ref class CharArraySet : ISet<String^>,
    ICollection<String^>, IEnumerable<String^>, IEnumerable
public ref class CharArraySet : ISet<String^>,
    ICollection<String^>, IEnumerable<String^>, IEnumerable
See Also
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharArraySet Members

CharArraySet Members Lucene.Net Class Library

The CharArraySet type exposes the following members.
Constructors
 | Name | Description
Public method | CharArraySet(IEnumerable Object , Boolean) | Create set from a Collection of char[] or String
Public method | CharArraySet(IEnumerable String , Boolean) | Initializes a new instance of the CharArraySet class
Public method | CharArraySet(Int32, Boolean) | Create set with enough capacity to hold startSize terms
Back to Top
Methods
 | Name | Description
Public method | Add( Char ) | Add this char[] directly to the set. If ignoreCase is true for this Set, the text array will be directly modified. The user should never modify this text array after calling this method.
Public method | Add(Object) |
Public method | Add(String) |
Public method | AddAll | Wrapper that calls UnionWith
Public method | Clear |
Public method | Contains(Object) |
Public method | Contains(String) |
Public method | Contains( Char , Int32, Int32) | true if the len chars of text starting at off are in the set
 | Copy T | returns a copy of the given set as a CharArraySet. If the given set is a CharArraySet the ignoreCase property will be preserved.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RemoveAll |
Public method | RetainAll |
Public method | StringEnumerator |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UnionWith | Adds all of the elements in the specified collection to this collection
 | UnmodifiableSet | Returns an unmodifiable CharArraySet. This allows to provide unmodifiable views of internal sets for "read-only" use
Back to Top
Fields
Name | Description
EMPTY_SET |
Back to Top
Properties
 | Name | Description
Public property | Count |
Public property | IsEmpty |
Public property | IsReadOnly |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICollection String Add | Adds an item to the Online ICollection T .
Explicit interface implemetation | ICollection String CopyTo | Copies the elements of the Online ICollection T to an Online Array, starting at a particular Online Array index.
Explicit interface implemetation | ISet String ExceptWith | Removes all elements in the specified collection from the current set.
Explicit interface implemetation | IEnumerable GetEnumerator | Returns an enumerator that iterates through a collection.
Explicit interface implemetation | ISet String IntersectWith | Modifies the current set so that it contains only elements that are also in a specified collection.
Explicit interface implemetation | ISet String IsProperSubsetOf | Determines whether the current set is a property (strict) subset of a specified collection.
Explicit interface implemetation | ISet String IsProperSupersetOf | Determines whether the current set is a correct superset of a specified collection.
Explicit interface implemetation | ISet String IsSubsetOf | Determines whether a set is a subset of a specified collection.
Explicit interface implemetation | ISet String IsSupersetOf | Determines whether the current set is a superset of a specified collection.
Explicit interface implemetation | ISet String Overlaps | Determines whether the current set overlaps with the specified collection.
Explicit interface implemetation | ICollection String Remove | Removes the first occurrence of a specific object from the Online ICollection T .
Explicit interface implemetation | ISet String SetEquals | Determines whether the current set and the specified collection contain the same elements.
Explicit interface implemetation | ISet String SymmetricExceptWith | Modifies the current set so that it contains only elements that are present either in the current set or in the specified collection, but not both.
Back to Top
See Also
CharArraySet Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharArraySet Constructor

CharArraySet Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | CharArraySet(IEnumerable Object , Boolean) | Create set from a Collection of char[] or String
Public method | CharArraySet(IEnumerable String , Boolean) | Initializes a new instance of the CharArraySet class
Public method | CharArraySet(Int32, Boolean) | Create set with enough capacity to hold startSize terms
Back to Top
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharArraySet Constructor (IEnumerable(Object), Boolean)

CharArraySet Constructor (IEnumerable Object , Boolean) Lucene.Net Class Library
Create set from a Collection of char[] or String

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CharArraySet(
    IEnumerable<Object> c,
    bool ignoreCase
)
public CharArraySet(
    IEnumerable<Object> c,
    bool ignoreCase
)
Public Sub New ( _
    c As IEnumerable(Of Object), _
    ignoreCase As Boolean _
)
Public Sub New ( _
    c As IEnumerable(Of Object), _
    ignoreCase As Boolean _
)
public:
CharArraySet(
    IEnumerable<Object^>^ c,
    bool ignoreCase
)
public:
CharArraySet(
    IEnumerable<Object^>^ c,
    bool ignoreCase
)
Parameters
c
Type:   Online System.Collections.Generic IEnumerable    Online Object
ignoreCase
Type:   Online System Boolean
See Also
CharArraySet Class
CharArraySet Members
CharArraySet Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharArraySet Constructor (IEnumerable(String), Boolean)

CharArraySet Constructor (IEnumerable String , Boolean) Lucene.Net Class Library
Initializes a new instance of the CharArraySet class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CharArraySet(
    IEnumerable<string> c,
    bool ignoreCase
)
public CharArraySet(
    IEnumerable<string> c,
    bool ignoreCase
)
Public Sub New ( _
    c As IEnumerable(Of String), _
    ignoreCase As Boolean _
)
Public Sub New ( _
    c As IEnumerable(Of String), _
    ignoreCase As Boolean _
)
public:
CharArraySet(
    IEnumerable<String^>^ c,
    bool ignoreCase
)
public:
CharArraySet(
    IEnumerable<String^>^ c,
    bool ignoreCase
)
Parameters
c
Type:   Online System.Collections.Generic IEnumerable    Online String
ignoreCase
Type:   Online System Boolean
See Also
CharArraySet Class
CharArraySet Members
CharArraySet Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharArraySet Constructor (Int32, Boolean)

CharArraySet Constructor (Int32, Boolean) Lucene.Net Class Library
Create set with enough capacity to hold startSize terms

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CharArraySet(
    int startSize,
    bool ignoreCase
)
public CharArraySet(
    int startSize,
    bool ignoreCase
)
Public Sub New ( _
    startSize As Integer, _
    ignoreCase As Boolean _
)
Public Sub New ( _
    startSize As Integer, _
    ignoreCase As Boolean _
)
public:
CharArraySet(
    int startSize,
    bool ignoreCase
)
public:
CharArraySet(
    int startSize,
    bool ignoreCase
)
Parameters
startSize
Type:   Online System Int32
ignoreCase
Type:   Online System Boolean
See Also
CharArraySet Class
CharArraySet Members
CharArraySet Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharArraySet Fields

CharArraySet Fields Lucene.Net Class Library
The CharArraySet type exposes the following members.
Fields
Name | Description
EMPTY_SET |
Back to Top
See Also
CharArraySet Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EMPTY_SET Field

CharArraySet EMPTY_SET Field Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CharArraySet EMPTY_SET
public static CharArraySet EMPTY_SET
Public Shared EMPTY_SET As CharArraySet
Public Shared EMPTY_SET As CharArraySet
public:
static CharArraySet^ EMPTY_SET
public:
static CharArraySet^ EMPTY_SET
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharArraySet Methods

CharArraySet Methods Lucene.Net Class Library
The CharArraySet type exposes the following members.
Methods
 | Name | Description
Public method | Add( Char ) | Add this char[] directly to the set. If ignoreCase is true for this Set, the text array will be directly modified. The user should never modify this text array after calling this method.
Public method | Add(Object) |
Public method | Add(String) |
Public method | AddAll | Wrapper that calls UnionWith
Public method | Clear |
Public method | Contains(Object) |
Public method | Contains(String) |
Public method | Contains( Char , Int32, Int32) | true if the len chars of text starting at off are in the set
 | Copy T | returns a copy of the given set as a CharArraySet. If the given set is a CharArraySet the ignoreCase property will be preserved.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RemoveAll |
Public method | RetainAll |
Public method | StringEnumerator |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UnionWith | Adds all of the elements in the specified collection to this collection
 | UnmodifiableSet | Returns an unmodifiable CharArraySet. This allows to provide unmodifiable views of internal sets for "read-only" use
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICollection String Add | Adds an item to the Online ICollection T .
Explicit interface implemetation | ICollection String CopyTo | Copies the elements of the Online ICollection T to an Online Array, starting at a particular Online Array index.
Explicit interface implemetation | ISet String ExceptWith | Removes all elements in the specified collection from the current set.
Explicit interface implemetation | IEnumerable GetEnumerator | Returns an enumerator that iterates through a collection.
Explicit interface implemetation | ISet String IntersectWith | Modifies the current set so that it contains only elements that are also in a specified collection.
Explicit interface implemetation | ISet String IsProperSubsetOf | Determines whether the current set is a property (strict) subset of a specified collection.
Explicit interface implemetation | ISet String IsProperSupersetOf | Determines whether the current set is a correct superset of a specified collection.
Explicit interface implemetation | ISet String IsSubsetOf | Determines whether a set is a subset of a specified collection.
Explicit interface implemetation | ISet String IsSupersetOf | Determines whether the current set is a superset of a specified collection.
Explicit interface implemetation | ISet String Overlaps | Determines whether the current set overlaps with the specified collection.
Explicit interface implemetation | ICollection String Remove | Removes the first occurrence of a specific object from the Online ICollection T .
Explicit interface implemetation | ISet String SetEquals | Determines whether the current set and the specified collection contain the same elements.
Explicit interface implemetation | ISet String SymmetricExceptWith | Modifies the current set so that it contains only elements that are present either in the current set or in the specified collection, but not both.
Back to Top
See Also
CharArraySet Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ICollection(String).Add Method

CharArraySet ICollection String Add Method Lucene.Net Class Library
Adds an item to the Online ICollection T .

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ICollection<string>.Add(
    string item
)
void ICollection<string>.Add(
    string item
)
Private Sub Add ( _
    item As String _
) Implements ICollection(Of String).Add
Private Sub Add ( _
    item As String _
) Implements ICollection(Of String).Add
private:
virtual void Add(
    String^ item
) sealed = ICollection<String^>::Add
private:
virtual void Add(
    String^ item
) sealed = ICollection<String^>::Add
Parameters
item
Type:   Online System String
The object to add to the   Online ICollection T .
Implements
  Online ICollection T  Add(T)
Exceptions
Exception | Condition
Online System NotSupportedException | The Online ICollection T is read-only.
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ICollection(String).CopyTo Method

CharArraySet ICollection String CopyTo Method Lucene.Net Class Library
Copies the elements of the Online ICollection T to an Online Array, starting at a particular Online Array index.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ICollection<string>.CopyTo(
    string[] array,
    int arrayIndex
)
void ICollection<string>.CopyTo(
    string[] array,
    int arrayIndex
)
Private Sub CopyTo ( _
    array As String(), _
    arrayIndex As Integer _
) Implements ICollection(Of String).CopyTo
Private Sub CopyTo ( _
    array As String(), _
    arrayIndex As Integer _
) Implements ICollection(Of String).CopyTo
private:
virtual void CopyTo(
    array<String^>^ array,
    int arrayIndex
) sealed = ICollection<String^>::CopyTo
private:
virtual void CopyTo(
    array<String^>^ array,
    int arrayIndex
) sealed = ICollection<String^>::CopyTo
Parameters
array
Type:    Online System String
The one-dimensional   Online Array that is the destination of the elements copied from   Online ICollection T . The   Online Array must have zero-based indexing.
arrayIndex
Type:   Online System Int32
The zero-based index in array at which copying begins.
Implements
  Online ICollection T  CopyTo( T , Int32)
Exceptions
Exception | Condition
Online System ArgumentNullException | array is null.
Online System ArgumentOutOfRangeException | arrayIndex is less than 0.
Online System ArgumentException | array is multidimensional.-or-The number of elements in the source Online ICollection T is greater than the available space from arrayIndex to the end of the destination array.-or-Type T cannot be cast automatically to the type of the destination array.
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ISet(String).ExceptWith Method

CharArraySet ISet String ExceptWith Method Lucene.Net Class Library
Removes all elements in the specified collection from the current set.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ISet<string>.ExceptWith(
    IEnumerable<string> other
)
void ISet<string>.ExceptWith(
    IEnumerable<string> other
)
Private Sub ExceptWith ( _
    other As IEnumerable(Of String) _
) Implements ISet(Of String).ExceptWith
Private Sub ExceptWith ( _
    other As IEnumerable(Of String) _
) Implements ISet(Of String).ExceptWith
private:
virtual void ExceptWith(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::ExceptWith
private:
virtual void ExceptWith(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::ExceptWith
Parameters
other
Type:   Online System.Collections.Generic IEnumerable    Online String
The collection of items to remove from the set.
Implements
  Online ISet T  ExceptWith(IEnumerable T )
Exceptions
Exception | Condition
Online System ArgumentNullException | other is null.
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IEnumerable.GetEnumerator Method

CharArraySet IEnumerable GetEnumerator Method Lucene.Net Class Library
Returns an enumerator that iterates through a collection.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
Return Value
An   Online IEnumerator object that can be used to iterate through the collection.
Implements
  Online IEnumerable GetEnumerator
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ISet(String).IntersectWith Method

CharArraySet ISet String IntersectWith Method Lucene.Net Class Library
Modifies the current set so that it contains only elements that are also in a specified collection.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ISet<string>.IntersectWith(
    IEnumerable<string> other
)
void ISet<string>.IntersectWith(
    IEnumerable<string> other
)
Private Sub IntersectWith ( _
    other As IEnumerable(Of String) _
) Implements ISet(Of String).IntersectWith
Private Sub IntersectWith ( _
    other As IEnumerable(Of String) _
) Implements ISet(Of String).IntersectWith
private:
virtual void IntersectWith(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::IntersectWith
private:
virtual void IntersectWith(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::IntersectWith
Parameters
other
Type:   Online System.Collections.Generic IEnumerable    Online String
The collection to compare to the current set.
Implements
  Online ISet T  IntersectWith(IEnumerable T )
Exceptions
Exception | Condition
Online System ArgumentNullException | other is null.
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ISet(String).IsProperSubsetOf Method

CharArraySet ISet String IsProperSubsetOf Method Lucene.Net Class Library
Determines whether the current set is a property (strict) subset of a specified collection.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ISet<string>.IsProperSubsetOf(
    IEnumerable<string> other
)
bool ISet<string>.IsProperSubsetOf(
    IEnumerable<string> other
)
Private Function IsProperSubsetOf ( _
    other As IEnumerable(Of String) _
) As Boolean Implements ISet(Of String).IsProperSubsetOf
Private Function IsProperSubsetOf ( _
    other As IEnumerable(Of String) _
) As Boolean Implements ISet(Of String).IsProperSubsetOf
private:
virtual bool IsProperSubsetOf(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::IsProperSubsetOf
private:
virtual bool IsProperSubsetOf(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::IsProperSubsetOf
Parameters
other
Type:   Online System.Collections.Generic IEnumerable    Online String
The collection to compare to the current set.
Return Value
true if the current set is a correct subset of other; otherwise, false.
Implements
  Online ISet T  IsProperSubsetOf(IEnumerable T )
Exceptions
Exception | Condition
Online System ArgumentNullException | other is null.
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ISet(String).IsProperSupersetOf Method

CharArraySet ISet String IsProperSupersetOf Method Lucene.Net Class Library
Determines whether the current set is a correct superset of a specified collection.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ISet<string>.IsProperSupersetOf(
    IEnumerable<string> other
)
bool ISet<string>.IsProperSupersetOf(
    IEnumerable<string> other
)
Private Function IsProperSupersetOf ( _
    other As IEnumerable(Of String) _
) As Boolean Implements ISet(Of String).IsProperSupersetOf
Private Function IsProperSupersetOf ( _
    other As IEnumerable(Of String) _
) As Boolean Implements ISet(Of String).IsProperSupersetOf
private:
virtual bool IsProperSupersetOf(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::IsProperSupersetOf
private:
virtual bool IsProperSupersetOf(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::IsProperSupersetOf
Parameters
other
Type:   Online System.Collections.Generic IEnumerable    Online String
The collection to compare to the current set.
Return Value
true if the   Online ISet T  object is a correct superset of other; otherwise, false.
Implements
  Online ISet T  IsProperSupersetOf(IEnumerable T )
Exceptions
Exception | Condition
Online System ArgumentNullException | other is null.
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ISet(String).IsSubsetOf Method

CharArraySet ISet String IsSubsetOf Method Lucene.Net Class Library
Determines whether a set is a subset of a specified collection.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ISet<string>.IsSubsetOf(
    IEnumerable<string> other
)
bool ISet<string>.IsSubsetOf(
    IEnumerable<string> other
)
Private Function IsSubsetOf ( _
    other As IEnumerable(Of String) _
) As Boolean Implements ISet(Of String).IsSubsetOf
Private Function IsSubsetOf ( _
    other As IEnumerable(Of String) _
) As Boolean Implements ISet(Of String).IsSubsetOf
private:
virtual bool IsSubsetOf(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::IsSubsetOf
private:
virtual bool IsSubsetOf(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::IsSubsetOf
Parameters
other
Type:   Online System.Collections.Generic IEnumerable    Online String
The collection to compare to the current set.
Return Value
true if the current set is a subset of other; otherwise, false.
Implements
  Online ISet T  IsSubsetOf(IEnumerable T )
Exceptions
Exception | Condition
Online System ArgumentNullException | other is null.
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ISet(String).IsSupersetOf Method

CharArraySet ISet String IsSupersetOf Method Lucene.Net Class Library
Determines whether the current set is a superset of a specified collection.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ISet<string>.IsSupersetOf(
    IEnumerable<string> other
)
bool ISet<string>.IsSupersetOf(
    IEnumerable<string> other
)
Private Function IsSupersetOf ( _
    other As IEnumerable(Of String) _
) As Boolean Implements ISet(Of String).IsSupersetOf
Private Function IsSupersetOf ( _
    other As IEnumerable(Of String) _
) As Boolean Implements ISet(Of String).IsSupersetOf
private:
virtual bool IsSupersetOf(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::IsSupersetOf
private:
virtual bool IsSupersetOf(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::IsSupersetOf
Parameters
other
Type:   Online System.Collections.Generic IEnumerable    Online String
The collection to compare to the current set.
Return Value
true if the current set is a superset of other; otherwise, false.
Implements
  Online ISet T  IsSupersetOf(IEnumerable T )
Exceptions
Exception | Condition
Online System ArgumentNullException | other is null.
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ISet(String).Overlaps Method

CharArraySet ISet String Overlaps Method Lucene.Net Class Library
Determines whether the current set overlaps with the specified collection.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ISet<string>.Overlaps(
    IEnumerable<string> other
)
bool ISet<string>.Overlaps(
    IEnumerable<string> other
)
Private Function Overlaps ( _
    other As IEnumerable(Of String) _
) As Boolean Implements ISet(Of String).Overlaps
Private Function Overlaps ( _
    other As IEnumerable(Of String) _
) As Boolean Implements ISet(Of String).Overlaps
private:
virtual bool Overlaps(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::Overlaps
private:
virtual bool Overlaps(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::Overlaps
Parameters
other
Type:   Online System.Collections.Generic IEnumerable    Online String
The collection to compare to the current set.
Return Value
true if the current set and other share at least one common element; otherwise, false.
Implements
  Online ISet T  Overlaps(IEnumerable T )
Exceptions
Exception | Condition
Online System ArgumentNullException | other is null.
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ICollection(String).Remove Method

CharArraySet ICollection String Remove Method Lucene.Net Class Library
Removes the first occurrence of a specific object from the Online ICollection T .

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ICollection<string>.Remove(
    string item
)
bool ICollection<string>.Remove(
    string item
)
Private Function Remove ( _
    item As String _
) As Boolean Implements ICollection(Of String).Remove
Private Function Remove ( _
    item As String _
) As Boolean Implements ICollection(Of String).Remove
private:
virtual bool Remove(
    String^ item
) sealed = ICollection<String^>::Remove
private:
virtual bool Remove(
    String^ item
) sealed = ICollection<String^>::Remove
Parameters
item
Type:   Online System String
The object to remove from the   Online ICollection T .
Return Value
true if item was successfully removed from the   Online ICollection T ; otherwise, false. This method also returns false if item is not found in the original   Online ICollection T .
Implements
  Online ICollection T  Remove(T)
Exceptions
Exception | Condition
Online System NotSupportedException | The Online ICollection T is read-only.
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ISet(String).SetEquals Method

CharArraySet ISet String SetEquals Method Lucene.Net Class Library
Determines whether the current set and the specified collection contain the same elements.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ISet<string>.SetEquals(
    IEnumerable<string> other
)
bool ISet<string>.SetEquals(
    IEnumerable<string> other
)
Private Function SetEquals ( _
    other As IEnumerable(Of String) _
) As Boolean Implements ISet(Of String).SetEquals
Private Function SetEquals ( _
    other As IEnumerable(Of String) _
) As Boolean Implements ISet(Of String).SetEquals
private:
virtual bool SetEquals(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::SetEquals
private:
virtual bool SetEquals(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::SetEquals
Parameters
other
Type:   Online System.Collections.Generic IEnumerable    Online String
The collection to compare to the current set.
Return Value
true if the current set is equal to other; otherwise, false.
Implements
  Online ISet T  SetEquals(IEnumerable T )
Exceptions
Exception | Condition
Online System ArgumentNullException | other is null.
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ISet(String).SymmetricExceptWith Method

CharArraySet ISet String SymmetricExceptWith Method Lucene.Net Class Library
Modifies the current set so that it contains only elements that are present either in the current set or in the specified collection, but not both.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ISet<string>.SymmetricExceptWith(
    IEnumerable<string> other
)
void ISet<string>.SymmetricExceptWith(
    IEnumerable<string> other
)
Private Sub SymmetricExceptWith ( _
    other As IEnumerable(Of String) _
) Implements ISet(Of String).SymmetricExceptWith
Private Sub SymmetricExceptWith ( _
    other As IEnumerable(Of String) _
) Implements ISet(Of String).SymmetricExceptWith
private:
virtual void SymmetricExceptWith(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::SymmetricExceptWith
private:
virtual void SymmetricExceptWith(
    IEnumerable<String^>^ other
) sealed = ISet<String^>::SymmetricExceptWith
Parameters
other
Type:   Online System.Collections.Generic IEnumerable    Online String
The collection to compare to the current set.
Implements
  Online ISet T  SymmetricExceptWith(IEnumerable T )
Exceptions
Exception | Condition
Online System ArgumentNullException | other is null.
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method

CharArraySet Add Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Add( Char ) | Add this char[] directly to the set. If ignoreCase is true for this Set, the text array will be directly modified. The user should never modify this text array after calling this method.
Public method | Add(Object) |
Public method | Add(String) |
Back to Top
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (Char[])

CharArraySet Add Method ( Char ) Lucene.Net Class Library
Add this char[] directly to the set. If ignoreCase is true for this Set, the text array will be directly modified. The user should never modify this text array after calling this method.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Add(
    char[] text
)
public bool Add(
    char[] text
)
Public Function Add ( _
    text As Char() _
) As Boolean
Public Function Add ( _
    text As Char() _
) As Boolean
public:
bool Add(
    array<wchar_t>^ text
)
public:
bool Add(
    array<wchar_t>^ text
)
Parameters
text
Type:    Online System Char
See Also
CharArraySet Class
CharArraySet Members
Add Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (Object)

CharArraySet Add Method (Object) Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Add(
    Object item
)
public bool Add(
    Object item
)
Public Function Add ( _
    item As Object _
) As Boolean
Public Function Add ( _
    item As Object _
) As Boolean
public:
bool Add(
    Object^ item
)
public:
bool Add(
    Object^ item
)
Parameters
item
Type:   Online System Object
See Also
CharArraySet Class
CharArraySet Members
Add Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (String)

CharArraySet Add Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Add(
    string text
)
public bool Add(
    string text
)
Public Function Add ( _
    text As String _
) As Boolean
Public Function Add ( _
    text As String _
) As Boolean
public:
virtual bool Add(
    String^ text
) sealed
public:
virtual bool Add(
    String^ text
) sealed
Parameters
text
Type:   Online System String
Implements
  Online ISet T  Add(T)
See Also
CharArraySet Class
CharArraySet Members
Add Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddAll Method

CharArraySet AddAll Method Lucene.Net Class Library
Wrapper that calls UnionWith

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddAll(
    IEnumerable<string> coll
)
public void AddAll(
    IEnumerable<string> coll
)
Public Sub AddAll ( _
    coll As IEnumerable(Of String) _
)
Public Sub AddAll ( _
    coll As IEnumerable(Of String) _
)
public:
void AddAll(
    IEnumerable<String^>^ coll
)
public:
void AddAll(
    IEnumerable<String^>^ coll
)
Parameters
coll
Type:   Online System.Collections.Generic IEnumerable    Online String
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method

CharArraySet Clear Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
virtual void Clear() sealed
public:
virtual void Clear() sealed
Implements
  Online ICollection T  Clear
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Contains Method

CharArraySet Contains Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Contains(Object) |
Public method | Contains(String) |
Public method | Contains( Char , Int32, Int32) | true if the len chars of text starting at off are in the set
Back to Top
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Contains Method (Object)

CharArraySet Contains Method (Object) Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Contains(
    Object item
)
public bool Contains(
    Object item
)
Public Function Contains ( _
    item As Object _
) As Boolean
Public Function Contains ( _
    item As Object _
) As Boolean
public:
bool Contains(
    Object^ item
)
public:
bool Contains(
    Object^ item
)
Parameters
item
Type:   Online System Object
See Also
CharArraySet Class
CharArraySet Members
Contains Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Contains Method (String)

CharArraySet Contains Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Contains(
    string text
)
public virtual bool Contains(
    string text
)
Public Overridable Function Contains ( _
    text As String _
) As Boolean
Public Overridable Function Contains ( _
    text As String _
) As Boolean
public:
virtual bool Contains(
    String^ text
)
public:
virtual bool Contains(
    String^ text
)
Parameters
text
Type:   Online System String
Implements
  Online ICollection T  Contains(T)
See Also
CharArraySet Class
CharArraySet Members
Contains Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Contains Method (Char[], Int32, Int32)

CharArraySet Contains Method ( Char , Int32, Int32) Lucene.Net Class Library
true if the len chars of text starting at off are in the set

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Contains(
    char[] text,
    int off,
    int len
)
public virtual bool Contains(
    char[] text,
    int off,
    int len
)
Public Overridable Function Contains ( _
    text As Char(), _
    off As Integer, _
    len As Integer _
) As Boolean
Public Overridable Function Contains ( _
    text As Char(), _
    off As Integer, _
    len As Integer _
) As Boolean
public:
virtual bool Contains(
    array<wchar_t>^ text,
    int off,
    int len
)
public:
virtual bool Contains(
    array<wchar_t>^ text,
    int off,
    int len
)
Parameters
text
Type:    Online System Char
off
Type:   Online System Int32
len
Type:   Online System Int32
See Also
CharArraySet Class
CharArraySet Members
Contains Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Copy(T) Method

CharArraySet Copy T Method Lucene.Net Class Library
returns a copy of the given set as a CharArraySet. If the given set is a CharArraySet the ignoreCase property will be preserved.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CharArraySet Copy<T>(
    ISet<T> set
)
public static CharArraySet Copy<T>(
    ISet<T> set
)
Public Shared Function Copy(Of T) ( _
    set As ISet(Of T) _
) As CharArraySet
Public Shared Function Copy(Of T) ( _
    set As ISet(Of T) _
) As CharArraySet
public:
generic<typename T>
static CharArraySet^ Copy(
    ISet<T>^ set
)
public:
generic<typename T>
static CharArraySet^ Copy(
    ISet<T>^ set
)
Parameters
set
Type:   Online System.Collections.Generic ISet  T
A set to copy
Type Parameters
T
Return Value
a copy of the given set as a CharArraySet.  If the given set
            is a CharArraySet the ignoreCase property will be preserved.
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetEnumerator Method

CharArraySet GetEnumerator Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<string> GetEnumerator()
public IEnumerator<string> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of String)
Public Function GetEnumerator As IEnumerator(Of String)
public:
virtual IEnumerator<String^>^ GetEnumerator() sealed
public:
virtual IEnumerator<String^>^ GetEnumerator() sealed
Implements
  Online IEnumerable T  GetEnumerator
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RemoveAll Method

CharArraySet RemoveAll Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RemoveAll(
    ICollection<string> c
)
public void RemoveAll(
    ICollection<string> c
)
Public Sub RemoveAll ( _
    c As ICollection(Of String) _
)
Public Sub RemoveAll ( _
    c As ICollection(Of String) _
)
public:
void RemoveAll(
    ICollection<String^>^ c
)
public:
void RemoveAll(
    ICollection<String^>^ c
)
Parameters
c
Type:   Online System.Collections.Generic ICollection    Online String
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RetainAll Method

CharArraySet RetainAll Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RetainAll(
    ICollection<string> c
)
public void RetainAll(
    ICollection<string> c
)
Public Sub RetainAll ( _
    c As ICollection(Of String) _
)
Public Sub RetainAll ( _
    c As ICollection(Of String) _
)
public:
void RetainAll(
    ICollection<String^>^ c
)
public:
void RetainAll(
    ICollection<String^>^ c
)
Parameters
c
Type:   Online System.Collections.Generic ICollection    Online String
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringEnumerator Method

CharArraySet StringEnumerator Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<string> StringEnumerator()
public IEnumerator<string> StringEnumerator()
Public Function StringEnumerator As IEnumerator(Of String)
Public Function StringEnumerator As IEnumerator(Of String)
public:
IEnumerator<String^>^ StringEnumerator()
public:
IEnumerator<String^>^ StringEnumerator()
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UnionWith Method

CharArraySet UnionWith Method Lucene.Net Class Library
Adds all of the elements in the specified collection to this collection

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void UnionWith(
    IEnumerable<string> other
)
public void UnionWith(
    IEnumerable<string> other
)
Public Sub UnionWith ( _
    other As IEnumerable(Of String) _
)
Public Sub UnionWith ( _
    other As IEnumerable(Of String) _
)
public:
virtual void UnionWith(
    IEnumerable<String^>^ other
) sealed
public:
virtual void UnionWith(
    IEnumerable<String^>^ other
) sealed
Parameters
other
Type:   Online System.Collections.Generic IEnumerable    Online String
Implements
  Online ISet T  UnionWith(IEnumerable T )
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UnmodifiableSet Method

CharArraySet UnmodifiableSet Method Lucene.Net Class Library
Returns an unmodifiable CharArraySet. This allows to provide unmodifiable views of internal sets for "read-only" use

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CharArraySet UnmodifiableSet(
    CharArraySet set
)
public static CharArraySet UnmodifiableSet(
    CharArraySet set
)
Public Shared Function UnmodifiableSet ( _
    set As CharArraySet _
) As CharArraySet
Public Shared Function UnmodifiableSet ( _
    set As CharArraySet _
) As CharArraySet
public:
static CharArraySet^ UnmodifiableSet(
    CharArraySet^ set
)
public:
static CharArraySet^ UnmodifiableSet(
    CharArraySet^ set
)
Parameters
set
Type: Lucene.Net.Analysis CharArraySet
A Set for which the unmodifiable set it returns.
Return Value
A new unmodifiable CharArraySet
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharArraySet Properties

CharArraySet Properties Lucene.Net Class Library
The CharArraySet type exposes the following members.
Properties
 | Name | Description
Public property | Count |
Public property | IsEmpty |
Public property | IsReadOnly |
Back to Top
See Also
CharArraySet Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Count Property

CharArraySet Count Property Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
public:
virtual property int Count {
    int get () sealed;
}
Implements
  Online ICollection T  Count
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsEmpty Property

CharArraySet IsEmpty Property Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
public:
property bool IsEmpty {
    bool get ();
}
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsReadOnly Property

CharArraySet IsReadOnly Property Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsReadOnly { get; private set; }
public bool IsReadOnly { get; private set; }
Public Property IsReadOnly As Boolean
    Get
    Private Set
Public Property IsReadOnly As Boolean
    Get
    Private Set
public:
virtual property bool IsReadOnly {
    bool get () sealed;
    private: void set (bool value) sealed;
}
public:
virtual property bool IsReadOnly {
    bool get () sealed;
    private: void set (bool value) sealed;
}
Implements
  Online ICollection T  IsReadOnly
See Also
CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharArraySet.CharArraySetEnumerator Class

CharArraySet CharArraySetEnumerator Class Lucene.Net Class Library
The IEnumerator<String> for this set. Strings are constructed on the fly, so use nextCharArray for more efficient access
Inheritance Hierarchy
Online System Object
Lucene.Net.Analysis CharArraySet CharArraySetEnumerator

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CharArraySetEnumerator : IEnumerator<string>,
    IDisposable, IEnumerator
public class CharArraySetEnumerator : IEnumerator<string>,
    IDisposable, IEnumerator
Public Class CharArraySetEnumerator _
    Implements IEnumerator(Of String), IDisposable,  _
    IEnumerator
Public Class CharArraySetEnumerator _
    Implements IEnumerator(Of String), IDisposable,  _
    IEnumerator
public ref class CharArraySetEnumerator : IEnumerator<String^>,
    IDisposable, IEnumerator
public ref class CharArraySetEnumerator : IEnumerator<String^>,
    IDisposable, IEnumerator
See Also
CharArraySet CharArraySetEnumerator Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharArraySet.CharArraySetEnumerator Members

CharArraySet CharArraySetEnumerator Members Lucene.Net Class Library

A simple class that stores Strings as char[]'s in a hash table. Note that this is not a general purpose class. For example, it cannot remove items from the set, nor does it resize its hash table to be smaller, etc. It is designed to be quick to test if a char[] is in the set without the necessity of converting it to a String first.

Please note: This class implements Online ISet T but does not behave like it should in all cases. The generic type is Online ICollection T , because you can add any object to it, that has a string representation. The add methods will use Online ToString and store the result using a Online Char buffer. The same behaviour have the Contains(Object) methods. The GetEnumerator method returns an Online String IEnumerable. For type safety also {@link #stringIterator()} is provided.

The CharArraySet CharArraySetEnumerator type exposes the following members.
Constructors
 | Name | Description
Protected method | CharArraySet CharArraySetEnumerator | Initializes a new instance of the CharArraySet CharArraySetEnumerator class
Back to Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the CharArraySet CharArraySetEnumerator
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MoveNext |
Public method | NextCharArray | do not modify the returned char[]
Public method | Reset |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Current |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerator Current | Gets the current element in the collection.
Back to Top
See Also
CharArraySet CharArraySetEnumerator Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharArraySet.CharArraySetEnumerator Constructor

CharArraySet CharArraySetEnumerator Constructor Lucene.Net Class Library
Initializes a new instance of the CharArraySet CharArraySetEnumerator class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CharArraySetEnumerator(
    CharArraySet creator
)
protected CharArraySetEnumerator(
    CharArraySet creator
)
Protected Sub New ( _
    creator As CharArraySet _
)
Protected Sub New ( _
    creator As CharArraySet _
)
protected:
CharArraySetEnumerator(
    CharArraySet^ creator
)
protected:
CharArraySetEnumerator(
    CharArraySet^ creator
)
Parameters
creator
Type: Lucene.Net.Analysis CharArraySet
See Also
CharArraySet CharArraySetEnumerator Class
CharArraySet CharArraySetEnumerator Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharArraySet.CharArraySetEnumerator Methods

CharArraySet CharArraySetEnumerator Methods Lucene.Net Class Library
The CharArraySet CharArraySetEnumerator type exposes the following members.
Methods
 | Name | Description
Public method | Dispose |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MoveNext |
Public method | NextCharArray | do not modify the returned char[]
Public method | Reset |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CharArraySet CharArraySetEnumerator Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

CharArraySet CharArraySetEnumerator Dispose Method Lucene.Net Class Library
Releases all resources used by the CharArraySet CharArraySetEnumerator

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
CharArraySet CharArraySetEnumerator Class
CharArraySet CharArraySetEnumerator Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MoveNext Method

CharArraySet CharArraySetEnumerator MoveNext Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MoveNext()
public bool MoveNext()
Public Function MoveNext As Boolean
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed
public:
virtual bool MoveNext() sealed
Implements
  Online IEnumerator MoveNext
See Also
CharArraySet CharArraySetEnumerator Class
CharArraySet CharArraySetEnumerator Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextCharArray Method

CharArraySet CharArraySetEnumerator NextCharArray Method Lucene.Net Class Library
do not modify the returned char[]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char[] NextCharArray()
public char[] NextCharArray()
Public Function NextCharArray As Char()
Public Function NextCharArray As Char()
public:
array<wchar_t>^ NextCharArray()
public:
array<wchar_t>^ NextCharArray()
See Also
CharArraySet CharArraySetEnumerator Class
CharArraySet CharArraySetEnumerator Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method

CharArraySet CharArraySetEnumerator Reset Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset()
public void Reset()
Public Sub Reset
Public Sub Reset
public:
virtual void Reset() sealed
public:
virtual void Reset() sealed
Implements
  Online IEnumerator Reset
See Also
CharArraySet CharArraySetEnumerator Class
CharArraySet CharArraySetEnumerator Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharArraySet.CharArraySetEnumerator Properties

CharArraySet CharArraySetEnumerator Properties Lucene.Net Class Library
The CharArraySet CharArraySetEnumerator type exposes the following members.
Properties
 | Name | Description
Public property | Current |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerator Current | Gets the current element in the collection.
Back to Top
See Also
CharArraySet CharArraySetEnumerator Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IEnumerator.Current Property

CharArraySet CharArraySetEnumerator IEnumerator Current Property Lucene.Net Class Library
Gets the current element in the collection.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object IEnumerator.Current { get; }
Object IEnumerator.Current { get; }
Private ReadOnly Property Current As Object
    Implements IEnumerator.Current
    Get
Private ReadOnly Property Current As Object
    Implements IEnumerator.Current
    Get
private:
virtual property Object^ Current {
    Object^ get () sealed = IEnumerator::Current::get;
}
private:
virtual property Object^ Current {
    Object^ get () sealed = IEnumerator::Current::get;
}
Return Value
The current element in the collection.
Implements
  Online IEnumerator Current
Exceptions
Exception | Condition
Online System InvalidOperationException | The enumerator is positioned before the first element of the collection or after the last element.
See Also
CharArraySet CharArraySetEnumerator Class
CharArraySet CharArraySetEnumerator Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Current Property

CharArraySet CharArraySetEnumerator Current Property Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Current { get; }
public string Current { get; }
Public ReadOnly Property Current As String
    Get
Public ReadOnly Property Current As String
    Get
public:
virtual property String^ Current {
    String^ get () sealed;
}
public:
virtual property String^ Current {
    String^ get () sealed;
}
Implements
  Online IEnumerator T  Current
See Also
CharArraySet CharArraySetEnumerator Class
CharArraySet CharArraySetEnumerator Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharFilter Class

CharFilter Class Lucene.Net Class Library
Subclasses of CharFilter can be chained to filter CharStream. They can be used as Online TextReader with additional offset correction. Tokenizers will automatically use CorrectOffset(Int32) if a CharFilter/CharStream subclass is used.
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO TextReader
Online System.IO StreamReader
Lucene.Net.Analysis CharStream
Lucene.Net.Analysis CharFilter
Lucene.Net.Analysis BaseCharFilter

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class CharFilter : CharStream
public abstract class CharFilter : CharStream
Public MustInherit Class CharFilter _
    Inherits CharStream
Public MustInherit Class CharFilter _
    Inherits CharStream
public ref class CharFilter abstract : public CharStream
public ref class CharFilter abstract : public CharStream
See Also
CharFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharFilter Members

CharFilter Members Lucene.Net Class Library

The CharFilter type exposes the following members.
Constructors
 | Name | Description
Protected method | CharFilter | Initializes a new instance of the CharFilter class
Back to Top
Methods
 | Name | Description
Public method | Online Close | Closes the Online StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from Online StreamReader.)
Protected method | Correct | Subclass may want to override to correct the current offset.
Public method | CorrectOffset | Chains the corrected offset through the input CharFilter. (Overrides CharStream CorrectOffset(Int32).)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online DiscardBufferedData | Allows a Online StreamReader object to discard its current data. (Inherited from Online StreamReader.)
Public method | Online Dispose | Releases all resources used by the Online TextReader object. (Inherited from Online TextReader.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CharFilter and optionally releases the managed resources (Overrides Online StreamReader Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Mark |
Public method | MarkSupported |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online Peek | Returns the next available character but does not consume it. (Inherited from Online StreamReader.)
Public method | Online Read | Reads the next character from the input stream and advances the character position by one character. (Inherited from Online StreamReader.)
Public method | Read( Char , Int32, Int32) | (Overrides Online StreamReader Read( Char , Int32, Int32).)
Public method | Online ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from Online TextReader.)
Public method | Online ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from Online StreamReader.)
Public method | Online ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from Online StreamReader.)
Public method | Reset |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | input |
Back to Top
Properties
 | Name | Description
Public property | Online BaseStream | Returns the underlying stream. (Inherited from Online StreamReader.)
Public property | Online CurrentEncoding | Gets the current character encoding that the current Online StreamReader object is using. (Inherited from Online StreamReader.)
Public property | Online EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from Online StreamReader.)
Back to Top
See Also
CharFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharFilter Constructor

CharFilter Constructor Lucene.Net Class Library
Initializes a new instance of the CharFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CharFilter(
    CharStream in_Renamed
)
protected CharFilter(
    CharStream in_Renamed
)
Protected Sub New ( _
    in_Renamed As CharStream _
)
Protected Sub New ( _
    in_Renamed As CharStream _
)
protected:
CharFilter(
    CharStream^ in_Renamed
)
protected:
CharFilter(
    CharStream^ in_Renamed
)
Parameters
in_Renamed
Type: Lucene.Net.Analysis CharStream
See Also
CharFilter Class
CharFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharFilter Fields

CharFilter Fields Lucene.Net Class Library
The CharFilter type exposes the following members.
Fields
 | Name | Description
Protected field | input |
Back to Top
See Also
CharFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


input Field

CharFilter input Field Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CharStream input
protected CharStream input
Protected input As CharStream
Protected input As CharStream
protected:
CharStream^ input
protected:
CharStream^ input
See Also
CharFilter Class
CharFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharFilter Methods

CharFilter Methods Lucene.Net Class Library
The CharFilter type exposes the following members.
Methods
 | Name | Description
Public method | Online Close | Closes the Online StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from Online StreamReader.)
Protected method | Correct | Subclass may want to override to correct the current offset.
Public method | CorrectOffset | Chains the corrected offset through the input CharFilter. (Overrides CharStream CorrectOffset(Int32).)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online DiscardBufferedData | Allows a Online StreamReader object to discard its current data. (Inherited from Online StreamReader.)
Public method | Online Dispose | Releases all resources used by the Online TextReader object. (Inherited from Online TextReader.)
Protected method | Dispose(Boolean) | (Overrides Online StreamReader Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Mark |
Public method | MarkSupported |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online Peek | Returns the next available character but does not consume it. (Inherited from Online StreamReader.)
Public method | Online Read | Reads the next character from the input stream and advances the character position by one character. (Inherited from Online StreamReader.)
Public method | Read( Char , Int32, Int32) | (Overrides Online StreamReader Read( Char , Int32, Int32).)
Public method | Online ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from Online TextReader.)
Public method | Online ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from Online StreamReader.)
Public method | Online ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from Online StreamReader.)
Public method | Reset |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CharFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Correct Method

CharFilter Correct Method Lucene.Net Class Library
Subclass may want to override to correct the current offset.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual int Correct(
    int currentOff
)
protected virtual int Correct(
    int currentOff
)
Protected Overridable Function Correct ( _
    currentOff As Integer _
) As Integer
Protected Overridable Function Correct ( _
    currentOff As Integer _
) As Integer
protected:
virtual int Correct(
    int currentOff
)
protected:
virtual int Correct(
    int currentOff
)
Parameters
currentOff
Type:   Online System Int32
current offset
Return Value
corrected offset
See Also
CharFilter Class
CharFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CorrectOffset Method

CharFilter CorrectOffset Method Lucene.Net Class Library
Chains the corrected offset through the input CharFilter.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int CorrectOffset(
    int currentOff
)
public override int CorrectOffset(
    int currentOff
)
Public Overrides Function CorrectOffset ( _
    currentOff As Integer _
) As Integer
Public Overrides Function CorrectOffset ( _
    currentOff As Integer _
) As Integer
public:
virtual int CorrectOffset(
    int currentOff
) override
public:
virtual int CorrectOffset(
    int currentOff
) override
Parameters
currentOff
Type:   Online System Int32
See Also
CharFilter Class
CharFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

CharFilter Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Online Dispose | Releases all resources used by the Online TextReader object. (Inherited from Online TextReader.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CharFilter and optionally releases the managed resources (Overrides Online StreamReader Dispose(Boolean).)
Back to Top
See Also
CharFilter Class
CharFilter Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

CharFilter Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the CharFilter and optionally releases the managed resources

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
CharFilter Class
CharFilter Members
Dispose Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Mark Method

CharFilter Mark Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Mark(
    int readAheadLimit
)
public void Mark(
    int readAheadLimit
)
Public Sub Mark ( _
    readAheadLimit As Integer _
)
Public Sub Mark ( _
    readAheadLimit As Integer _
)
public:
void Mark(
    int readAheadLimit
)
public:
void Mark(
    int readAheadLimit
)
Parameters
readAheadLimit
Type:   Online System Int32
See Also
CharFilter Class
CharFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MarkSupported Method

CharFilter MarkSupported Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MarkSupported()
public bool MarkSupported()
Public Function MarkSupported As Boolean
Public Function MarkSupported As Boolean
public:
bool MarkSupported()
public:
bool MarkSupported()
See Also
CharFilter Class
CharFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Read Method

CharFilter Read Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Online Read | Reads the next character from the input stream and advances the character position by one character. (Inherited from Online StreamReader.)
Public method | Read( Char , Int32, Int32) | (Overrides Online StreamReader Read( Char , Int32, Int32).)
Back to Top
See Also
CharFilter Class
CharFilter Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Read Method (Char[], Int32, Int32)

CharFilter Read Method ( Char , Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Read(
    char[] cbuf,
    int off,
    int len
)
public override int Read(
    char[] cbuf,
    int off,
    int len
)
Public Overrides Function Read ( _
    cbuf As Char(), _
    off As Integer, _
    len As Integer _
) As Integer
Public Overrides Function Read ( _
    cbuf As Char(), _
    off As Integer, _
    len As Integer _
) As Integer
public:
virtual int Read(
    array<wchar_t>^ cbuf,
    int off,
    int len
) override
public:
virtual int Read(
    array<wchar_t>^ cbuf,
    int off,
    int len
) override
Parameters
cbuf
Type:    Online System Char
off
Type:   Online System Int32
len
Type:   Online System Int32
See Also
CharFilter Class
CharFilter Members
Read Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method

CharFilter Reset Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset()
public void Reset()
Public Sub Reset
Public Sub Reset
public:
void Reset()
public:
void Reset()
See Also
CharFilter Class
CharFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharFilter Properties

CharFilter Properties Lucene.Net Class Library
The CharFilter type exposes the following members.
Properties
 | Name | Description
Public property | Online BaseStream | Returns the underlying stream. (Inherited from Online StreamReader.)
Public property | Online CurrentEncoding | Gets the current character encoding that the current Online StreamReader object is using. (Inherited from Online StreamReader.)
Public property | Online EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from Online StreamReader.)
Back to Top
See Also
CharFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharReader Class

CharReader Class Lucene.Net Class Library
CharReader is a Reader wrapper. It reads chars from Reader and outputs CharStream, defining an identify function CorrectOffset(Int32) method that simply returns the provided offset.
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO TextReader
Online System.IO StreamReader
Lucene.Net.Analysis CharStream
Lucene.Net.Analysis CharReader

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CharReader : CharStream
public sealed class CharReader : CharStream
Public NotInheritable Class CharReader _
    Inherits CharStream
Public NotInheritable Class CharReader _
    Inherits CharStream
public ref class CharReader sealed : public CharStream
public ref class CharReader sealed : public CharStream
See Also
CharReader Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharReader Members

CharReader Members Lucene.Net Class Library

The CharReader type exposes the following members.
Methods
 | Name | Description
Public method | Online Close | Closes the Online StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from Online StreamReader.)
Public method | CorrectOffset | (Overrides CharStream CorrectOffset(Int32).)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online DiscardBufferedData | Allows a Online StreamReader object to discard its current data. (Inherited from Online StreamReader.)
Public method | Online Dispose | Releases all resources used by the Online TextReader object. (Inherited from Online TextReader.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CharReader and optionally releases the managed resources (Overrides Online StreamReader Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | Get |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Mark |
Public method | MarkSupported |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online Peek | Returns the next available character but does not consume it. (Inherited from Online StreamReader.)
Public method | Online Read | Reads the next character from the input stream and advances the character position by one character. (Inherited from Online StreamReader.)
Public method | Read( Char , Int32, Int32) | (Overrides Online StreamReader Read( Char , Int32, Int32).)
Public method | Online ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from Online TextReader.)
Public method | Online ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from Online StreamReader.)
Public method | Online ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from Online StreamReader.)
Public method | Reset |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Online BaseStream | Returns the underlying stream. (Inherited from Online StreamReader.)
Public property | Online CurrentEncoding | Gets the current character encoding that the current Online StreamReader object is using. (Inherited from Online StreamReader.)
Public property | Online EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from Online StreamReader.)
Back to Top
See Also
CharReader Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharReader Methods

CharReader Methods Lucene.Net Class Library
The CharReader type exposes the following members.
Methods
 | Name | Description
Public method | Online Close | Closes the Online StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from Online StreamReader.)
Public method | CorrectOffset | (Overrides CharStream CorrectOffset(Int32).)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online DiscardBufferedData | Allows a Online StreamReader object to discard its current data. (Inherited from Online StreamReader.)
Public method | Online Dispose | Releases all resources used by the Online TextReader object. (Inherited from Online TextReader.)
Protected method | Dispose(Boolean) | (Overrides Online StreamReader Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | Get |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Mark |
Public method | MarkSupported |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online Peek | Returns the next available character but does not consume it. (Inherited from Online StreamReader.)
Public method | Online Read | Reads the next character from the input stream and advances the character position by one character. (Inherited from Online StreamReader.)
Public method | Read( Char , Int32, Int32) | (Overrides Online StreamReader Read( Char , Int32, Int32).)
Public method | Online ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from Online TextReader.)
Public method | Online ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from Online StreamReader.)
Public method | Online ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from Online StreamReader.)
Public method | Reset |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CharReader Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CorrectOffset Method

CharReader CorrectOffset Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int CorrectOffset(
    int currentOff
)
public override int CorrectOffset(
    int currentOff
)
Public Overrides Function CorrectOffset ( _
    currentOff As Integer _
) As Integer
Public Overrides Function CorrectOffset ( _
    currentOff As Integer _
) As Integer
public:
virtual int CorrectOffset(
    int currentOff
) override
public:
virtual int CorrectOffset(
    int currentOff
) override
Parameters
currentOff
Type:   Online System Int32
See Also
CharReader Class
CharReader Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

CharReader Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Online Dispose | Releases all resources used by the Online TextReader object. (Inherited from Online TextReader.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CharReader and optionally releases the managed resources (Overrides Online StreamReader Dispose(Boolean).)
Back to Top
See Also
CharReader Class
CharReader Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

CharReader Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the CharReader and optionally releases the managed resources

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
CharReader Class
CharReader Members
Dispose Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method

CharReader Get Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CharStream Get(
    TextReader input
)
public static CharStream Get(
    TextReader input
)
Public Shared Function Get ( _
    input As TextReader _
) As CharStream
Public Shared Function Get ( _
    input As TextReader _
) As CharStream
public:
static CharStream^ Get(
    TextReader^ input
)
public:
static CharStream^ Get(
    TextReader^ input
)
Parameters
input
Type:   Online System.IO TextReader
See Also
CharReader Class
CharReader Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Mark Method

CharReader Mark Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Mark(
    int readAheadLimit
)
public void Mark(
    int readAheadLimit
)
Public Sub Mark ( _
    readAheadLimit As Integer _
)
Public Sub Mark ( _
    readAheadLimit As Integer _
)
public:
void Mark(
    int readAheadLimit
)
public:
void Mark(
    int readAheadLimit
)
Parameters
readAheadLimit
Type:   Online System Int32
See Also
CharReader Class
CharReader Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MarkSupported Method

CharReader MarkSupported Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MarkSupported()
public bool MarkSupported()
Public Function MarkSupported As Boolean
Public Function MarkSupported As Boolean
public:
bool MarkSupported()
public:
bool MarkSupported()
See Also
CharReader Class
CharReader Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Read Method

CharReader Read Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Online Read | Reads the next character from the input stream and advances the character position by one character. (Inherited from Online StreamReader.)
Public method | Read( Char , Int32, Int32) | (Overrides Online StreamReader Read( Char , Int32, Int32).)
Back to Top
See Also
CharReader Class
CharReader Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Read Method (Char[], Int32, Int32)

CharReader Read Method ( Char , Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Read(
    char[] cbuf,
    int off,
    int len
)
public override int Read(
    char[] cbuf,
    int off,
    int len
)
Public Overrides Function Read ( _
    cbuf As Char(), _
    off As Integer, _
    len As Integer _
) As Integer
Public Overrides Function Read ( _
    cbuf As Char(), _
    off As Integer, _
    len As Integer _
) As Integer
public:
virtual int Read(
    array<wchar_t>^ cbuf,
    int off,
    int len
) override
public:
virtual int Read(
    array<wchar_t>^ cbuf,
    int off,
    int len
) override
Parameters
cbuf
Type:    Online System Char
off
Type:   Online System Int32
len
Type:   Online System Int32
See Also
CharReader Class
CharReader Members
Read Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method

CharReader Reset Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset()
public void Reset()
Public Sub Reset
Public Sub Reset
public:
void Reset()
public:
void Reset()
See Also
CharReader Class
CharReader Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharReader Properties

CharReader Properties Lucene.Net Class Library
The CharReader type exposes the following members.
Properties
 | Name | Description
Public property | Online BaseStream | Returns the underlying stream. (Inherited from Online StreamReader.)
Public property | Online CurrentEncoding | Gets the current character encoding that the current Online StreamReader object is using. (Inherited from Online StreamReader.)
Public property | Online EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from Online StreamReader.)
Back to Top
See Also
CharReader Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharStream Class

CharStream Class Lucene.Net Class Library
CharStream adds CorrectOffset(Int32) functionality over Online TextReader. All Tokenizers accept a CharStream instead of Online TextReader as input, which enables arbitrary character based filtering before tokenization. The CorrectOffset(Int32) method fixed offsets to account for removal or insertion of characters, so that the offsets reported in the tokens match the character offsets of the original Reader.
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO TextReader
Online System.IO StreamReader
Lucene.Net.Analysis CharStream
Lucene.Net.Analysis CharFilter
Lucene.Net.Analysis CharReader

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class CharStream : StreamReader
public abstract class CharStream : StreamReader
Public MustInherit Class CharStream _
    Inherits StreamReader
Public MustInherit Class CharStream _
    Inherits StreamReader
public ref class CharStream abstract : public StreamReader
public ref class CharStream abstract : public StreamReader
See Also
CharStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharStream Members

CharStream Members Lucene.Net Class Library

The CharStream type exposes the following members.
Constructors
 | Name | Description
Protected method | CharStream | Initializes a new instance of the CharStream class
Back to Top
Methods
 | Name | Description
Public method | Online Close | Closes the Online StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from Online StreamReader.)
Public method | CorrectOffset | Called by CharFilter(s) and Tokenizer to correct token offset.
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online DiscardBufferedData | Allows a Online StreamReader object to discard its current data. (Inherited from Online StreamReader.)
Public method | Online Dispose | Releases all resources used by the Online TextReader object. (Inherited from Online TextReader.)
Protected method | Online Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the Online StreamReader, and optionally releases the managed resources. (Inherited from Online StreamReader.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online Peek | Returns the next available character but does not consume it. (Inherited from Online StreamReader.)
Public method | Online Read | Reads the next character from the input stream and advances the character position by one character. (Inherited from Online StreamReader.)
Public method | Online Read( Char , Int32, Int32) | Reads a maximum of count characters from the current stream into buffer, beginning at index. (Inherited from Online StreamReader.)
Public method | Online ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from Online TextReader.)
Public method | Online ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from Online StreamReader.)
Public method | Online ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from Online StreamReader.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Online BaseStream | Returns the underlying stream. (Inherited from Online StreamReader.)
Public property | Online CurrentEncoding | Gets the current character encoding that the current Online StreamReader object is using. (Inherited from Online StreamReader.)
Public property | Online EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from Online StreamReader.)
Back to Top
See Also
CharStream Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharStream Constructor

CharStream Constructor Lucene.Net Class Library
Initializes a new instance of the CharStream class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CharStream(
    StreamReader reader
)
protected CharStream(
    StreamReader reader
)
Protected Sub New ( _
    reader As StreamReader _
)
Protected Sub New ( _
    reader As StreamReader _
)
protected:
CharStream(
    StreamReader^ reader
)
protected:
CharStream(
    StreamReader^ reader
)
Parameters
reader
Type:   Online System.IO StreamReader
See Also
CharStream Class
CharStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharStream Methods

CharStream Methods Lucene.Net Class Library
The CharStream type exposes the following members.
Methods
 | Name | Description
Public method | Online Close | Closes the Online StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from Online StreamReader.)
Public method | CorrectOffset | Called by CharFilter(s) and Tokenizer to correct token offset.
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online DiscardBufferedData | Allows a Online StreamReader object to discard its current data. (Inherited from Online StreamReader.)
Public method | Online Dispose | Releases all resources used by the Online TextReader object. (Inherited from Online TextReader.)
Protected method | Online Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the Online StreamReader, and optionally releases the managed resources. (Inherited from Online StreamReader.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online Peek | Returns the next available character but does not consume it. (Inherited from Online StreamReader.)
Public method | Online Read | Reads the next character from the input stream and advances the character position by one character. (Inherited from Online StreamReader.)
Public method | Online Read( Char , Int32, Int32) | Reads a maximum of count characters from the current stream into buffer, beginning at index. (Inherited from Online StreamReader.)
Public method | Online ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from Online TextReader.)
Public method | Online ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from Online StreamReader.)
Public method | Online ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from Online StreamReader.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CharStream Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CorrectOffset Method

CharStream CorrectOffset Method Lucene.Net Class Library
Called by CharFilter(s) and Tokenizer to correct token offset.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int CorrectOffset(
    int currentOff
)
public abstract int CorrectOffset(
    int currentOff
)
Public MustOverride Function CorrectOffset ( _
    currentOff As Integer _
) As Integer
Public MustOverride Function CorrectOffset ( _
    currentOff As Integer _
) As Integer
public:
virtual int CorrectOffset(
    int currentOff
) abstract
public:
virtual int CorrectOffset(
    int currentOff
) abstract
Parameters
currentOff
Type:   Online System Int32
offset as seen in the output

Return Value
 corrected offset based on the input

See Also
CharStream Class
CharStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharStream Properties

CharStream Properties Lucene.Net Class Library
The CharStream type exposes the following members.
Properties
 | Name | Description
Public property | Online BaseStream | Returns the underlying stream. (Inherited from Online StreamReader.)
Public property | Online CurrentEncoding | Gets the current character encoding that the current Online StreamReader object is using. (Inherited from Online StreamReader.)
Public property | Online EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from Online StreamReader.)
Back to Top
See Also
CharStream Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharTokenizer Class

CharTokenizer Class Lucene.Net Class Library
An abstract base class for simple, character-oriented tokenizers.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis Tokenizer
Lucene.Net.Analysis CharTokenizer
Lucene.Net.Analysis LetterTokenizer
Lucene.Net.Analysis WhitespaceTokenizer

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class CharTokenizer : Tokenizer
public abstract class CharTokenizer : Tokenizer
Public MustInherit Class CharTokenizer _
    Inherits Tokenizer
Public MustInherit Class CharTokenizer _
    Inherits Tokenizer
public ref class CharTokenizer abstract : public Tokenizer
public ref class CharTokenizer abstract : public Tokenizer
See Also
CharTokenizer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharTokenizer Members

CharTokenizer Members Lucene.Net Class Library

The CharTokenizer type exposes the following members.
Constructors
 | Name | Description
Protected method | CharTokenizer(TextReader) | Initializes a new instance of the CharTokenizer class
Protected method | CharTokenizer(AttributeSource, TextReader) | Initializes a new instance of the CharTokenizer class
Protected method | CharTokenizer(AttributeSource AttributeFactory, TextReader) | Initializes a new instance of the CharTokenizer class
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Protected method | CorrectOffset | Return the corrected offset. If input is a CharStream subclass this method calls CorrectOffset(Int32), else returns currentOff. (Inherited from Tokenizer.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from Tokenizer.)
Public method | End | (Overrides TokenStream End .)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | IsTokenChar | Returns true iff a character should be included in a token. This tokenizer generates as tokens adjacent sequences of characters which satisfy this predicate. Characters for which this is false are used to define token boundaries and are not included in tokens.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Normalize | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ). (Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer Reset(TextReader).)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Fields
 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
CharTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharTokenizer Constructor

CharTokenizer Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Protected method | CharTokenizer(TextReader) | Initializes a new instance of the CharTokenizer class
Protected method | CharTokenizer(AttributeSource, TextReader) | Initializes a new instance of the CharTokenizer class
Protected method | CharTokenizer(AttributeSource AttributeFactory, TextReader) | Initializes a new instance of the CharTokenizer class
Back to Top
See Also
CharTokenizer Class
CharTokenizer Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharTokenizer Constructor (TextReader)

CharTokenizer Constructor (TextReader) Lucene.Net Class Library
Initializes a new instance of the CharTokenizer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CharTokenizer(
    TextReader input
)
protected CharTokenizer(
    TextReader input
)
Protected Sub New ( _
    input As TextReader _
)
Protected Sub New ( _
    input As TextReader _
)
protected:
CharTokenizer(
    TextReader^ input
)
protected:
CharTokenizer(
    TextReader^ input
)
Parameters
input
Type:   Online System.IO TextReader
See Also
CharTokenizer Class
CharTokenizer Members
CharTokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharTokenizer Constructor (AttributeSource, TextReader)

CharTokenizer Constructor (AttributeSource, TextReader) Lucene.Net Class Library
Initializes a new instance of the CharTokenizer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CharTokenizer(
    AttributeSource source,
    TextReader input
)
protected CharTokenizer(
    AttributeSource source,
    TextReader input
)
Protected Sub New ( _
    source As AttributeSource, _
    input As TextReader _
)
Protected Sub New ( _
    source As AttributeSource, _
    input As TextReader _
)
protected:
CharTokenizer(
    AttributeSource^ source,
    TextReader^ input
)
protected:
CharTokenizer(
    AttributeSource^ source,
    TextReader^ input
)
Parameters
source
Type: Lucene.Net.Util AttributeSource
input
Type:   Online System.IO TextReader
See Also
CharTokenizer Class
CharTokenizer Members
CharTokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharTokenizer Constructor (AttributeSource.AttributeFactory, TextReader)

CharTokenizer Constructor (AttributeSource AttributeFactory, TextReader) Lucene.Net Class Library
Initializes a new instance of the CharTokenizer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CharTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader input
)
protected CharTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader input
)
Protected Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    input As TextReader _
)
Protected Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    input As TextReader _
)
protected:
CharTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ input
)
protected:
CharTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ input
)
Parameters
factory
Type: Lucene.Net.Util AttributeSource AttributeFactory
input
Type:   Online System.IO TextReader
See Also
CharTokenizer Class
CharTokenizer Members
CharTokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharTokenizer Fields

CharTokenizer Fields Lucene.Net Class Library
The CharTokenizer type exposes the following members.
Fields
 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)
Back to Top
See Also
CharTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharTokenizer Methods

CharTokenizer Methods Lucene.Net Class Library
The CharTokenizer type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Protected method | CorrectOffset | Return the corrected offset. If input is a CharStream subclass this method calls CorrectOffset(Int32), else returns currentOff. (Inherited from Tokenizer.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from Tokenizer.)
Public method | End | (Overrides TokenStream End .)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | IsTokenChar | Returns true iff a character should be included in a token. This tokenizer generates as tokens adjacent sequences of characters which satisfy this predicate. Characters for which this is false are used to define token boundaries and are not included in tokens.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Normalize | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ). (Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer Reset(TextReader).)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
CharTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


End Method

CharTokenizer End Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void End()
public override void End()
Public Overrides Sub End
Public Overrides Sub End
public:
virtual void End() override
public:
virtual void End() override
See Also
CharTokenizer Class
CharTokenizer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncrementToken Method

CharTokenizer IncrementToken Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IncrementToken()
public override bool IncrementToken()
Public Overrides Function IncrementToken As Boolean
Public Overrides Function IncrementToken As Boolean
public:
virtual bool IncrementToken() override
public:
virtual bool IncrementToken() override
See Also
CharTokenizer Class
CharTokenizer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsTokenChar Method

CharTokenizer IsTokenChar Method Lucene.Net Class Library
Returns true iff a character should be included in a token. This tokenizer generates as tokens adjacent sequences of characters which satisfy this predicate. Characters for which this is false are used to define token boundaries and are not included in tokens.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract bool IsTokenChar(
    char c
)
protected abstract bool IsTokenChar(
    char c
)
Protected MustOverride Function IsTokenChar ( _
    c As Char _
) As Boolean
Protected MustOverride Function IsTokenChar ( _
    c As Char _
) As Boolean
protected:
virtual bool IsTokenChar(
    wchar_t c
) abstract
protected:
virtual bool IsTokenChar(
    wchar_t c
) abstract
Parameters
c
Type:   Online System Char
See Also
CharTokenizer Class
CharTokenizer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Normalize Method

CharTokenizer Normalize Method Lucene.Net Class Library
Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual char Normalize(
    char c
)
protected virtual char Normalize(
    char c
)
Protected Overridable Function Normalize ( _
    c As Char _
) As Char
Protected Overridable Function Normalize ( _
    c As Char _
) As Char
protected:
virtual wchar_t Normalize(
    wchar_t c
)
protected:
virtual wchar_t Normalize(
    wchar_t c
)
Parameters
c
Type:   Online System Char
See Also
CharTokenizer Class
CharTokenizer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method

CharTokenizer Reset Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ). (Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer Reset(TextReader).)
Back to Top
See Also
CharTokenizer Class
CharTokenizer Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method (TextReader)

CharTokenizer Reset Method (TextReader) Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Reset(
    TextReader input
)
public override void Reset(
    TextReader input
)
Public Overrides Sub Reset ( _
    input As TextReader _
)
Public Overrides Sub Reset ( _
    input As TextReader _
)
public:
virtual void Reset(
    TextReader^ input
) override
public:
virtual void Reset(
    TextReader^ input
) override
Parameters
input
Type:   Online System.IO TextReader
See Also
CharTokenizer Class
CharTokenizer Members
Reset Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CharTokenizer Properties

CharTokenizer Properties Lucene.Net Class Library
The CharTokenizer type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
CharTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ISOLatin1AccentFilter Class

ISOLatin1AccentFilter Class Lucene.Net Class Library
A filter that replaces accented characters in the ISO Latin 1 character set (ISO-8859-1) by their unaccented equivalent. The case will not be altered.

For instance, 'À' will be replaced by 'a'.

Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis TokenFilter
Lucene.Net.Analysis ISOLatin1AccentFilter

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("If you build a new index, use ASCIIFoldingFilter which covers a superset of Latin 1.  This class is included for use with existing indexes and will be removed in a future release (possible Lucene 4.0).")]
public class ISOLatin1AccentFilter : TokenFilter
[ObsoleteAttribute("If you build a new index, use ASCIIFoldingFilter which covers a superset of Latin 1.  This class is included for use with existing indexes and will be removed in a future release (possible Lucene 4.0).")]
public class ISOLatin1AccentFilter : TokenFilter
<ObsoleteAttribute("If you build a new index, use ASCIIFoldingFilter which covers a superset of Latin 1.  This class is included for use with existing indexes and will be removed in a future release (possible Lucene 4.0).")> _
Public Class ISOLatin1AccentFilter _
    Inherits TokenFilter
<ObsoleteAttribute("If you build a new index, use ASCIIFoldingFilter which covers a superset of Latin 1.  This class is included for use with existing indexes and will be removed in a future release (possible Lucene 4.0).")> _
Public Class ISOLatin1AccentFilter _
    Inherits TokenFilter
[ObsoleteAttribute(L"If you build a new index, use ASCIIFoldingFilter which covers a superset of Latin 1.  This class is included for use with existing indexes and will be removed in a future release (possible Lucene 4.0).")]
public ref class ISOLatin1AccentFilter : public TokenFilter
[ObsoleteAttribute(L"If you build a new index, use ASCIIFoldingFilter which covers a superset of Latin 1.  This class is included for use with existing indexes and will be removed in a future release (possible Lucene 4.0).")]
public ref class ISOLatin1AccentFilter : public TokenFilter
See Also
ISOLatin1AccentFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ISOLatin1AccentFilter Members

ISOLatin1AccentFilter Members Lucene.Net Class Library

The ISOLatin1AccentFilter type exposes the following members.
Constructors
 | Name | Description
Public method | ISOLatin1AccentFilter | Initializes a new instance of the ISOLatin1AccentFilter class
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | Performs end-of-stream operations, if any, and calls then end() on the input TokenStream. NOTE: Be sure to call super.end() first when overriding this method. (Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RemoveAccents | To replace accented characters in a String by unaccented equivalents.
Public method | Reset | Reset the filter as well as the input TokenStream. (Inherited from TokenFilter.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
ISOLatin1AccentFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ISOLatin1AccentFilter Constructor

ISOLatin1AccentFilter Constructor Lucene.Net Class Library
Initializes a new instance of the ISOLatin1AccentFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ISOLatin1AccentFilter(
    TokenStream input
)
public ISOLatin1AccentFilter(
    TokenStream input
)
Public Sub New ( _
    input As TokenStream _
)
Public Sub New ( _
    input As TokenStream _
)
public:
ISOLatin1AccentFilter(
    TokenStream^ input
)
public:
ISOLatin1AccentFilter(
    TokenStream^ input
)
Parameters
input
Type: Lucene.Net.Analysis TokenStream
See Also
ISOLatin1AccentFilter Class
ISOLatin1AccentFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ISOLatin1AccentFilter Fields

ISOLatin1AccentFilter Fields Lucene.Net Class Library
The ISOLatin1AccentFilter type exposes the following members.
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
See Also
ISOLatin1AccentFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ISOLatin1AccentFilter Methods

ISOLatin1AccentFilter Methods Lucene.Net Class Library
The ISOLatin1AccentFilter type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | Performs end-of-stream operations, if any, and calls then end() on the input TokenStream. NOTE: Be sure to call super.end() first when overriding this method. (Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RemoveAccents | To replace accented characters in a String by unaccented equivalents.
Public method | Reset | Reset the filter as well as the input TokenStream. (Inherited from TokenFilter.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
ISOLatin1AccentFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncrementToken Method

ISOLatin1AccentFilter IncrementToken Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IncrementToken()
public override bool IncrementToken()
Public Overrides Function IncrementToken As Boolean
Public Overrides Function IncrementToken As Boolean
public:
virtual bool IncrementToken() override
public:
virtual bool IncrementToken() override
See Also
ISOLatin1AccentFilter Class
ISOLatin1AccentFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RemoveAccents Method

ISOLatin1AccentFilter RemoveAccents Method Lucene.Net Class Library
To replace accented characters in a String by unaccented equivalents.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RemoveAccents(
    char[] input,
    int length
)
public void RemoveAccents(
    char[] input,
    int length
)
Public Sub RemoveAccents ( _
    input As Char(), _
    length As Integer _
)
Public Sub RemoveAccents ( _
    input As Char(), _
    length As Integer _
)
public:
void RemoveAccents(
    array<wchar_t>^ input,
    int length
)
public:
void RemoveAccents(
    array<wchar_t>^ input,
    int length
)
Parameters
input
Type:    Online System Char
length
Type:   Online System Int32
See Also
ISOLatin1AccentFilter Class
ISOLatin1AccentFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ISOLatin1AccentFilter Properties

ISOLatin1AccentFilter Properties Lucene.Net Class Library
The ISOLatin1AccentFilter type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
ISOLatin1AccentFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeywordAnalyzer Class

KeywordAnalyzer Class Lucene.Net Class Library
"Tokenizes" the entire stream as a single token. This is useful for data like zip codes, ids, and some product names.
Inheritance Hierarchy
Online System Object
Lucene.Net.Analysis Analyzer
Lucene.Net.Analysis KeywordAnalyzer

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class KeywordAnalyzer : Analyzer
public class KeywordAnalyzer : Analyzer
Public Class KeywordAnalyzer _
    Inherits Analyzer
Public Class KeywordAnalyzer _
    Inherits Analyzer
public ref class KeywordAnalyzer : public Analyzer
public ref class KeywordAnalyzer : public Analyzer
See Also
KeywordAnalyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeywordAnalyzer Members

KeywordAnalyzer Members Lucene.Net Class Library

The KeywordAnalyzer type exposes the following members.
Constructors
 | Name | Description
Public method | KeywordAnalyzer | Initializes a new instance of the KeywordAnalyzer class
Back to Top
Methods
 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Dispose | (Inherited from Analyzer.)
Protected method | Dispose(Boolean) | (Inherited from Analyzer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetOffsetGap | Just like GetPositionIncrementGap(String), except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReusableTokenStream | (Overrides Analyzer ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod TClass | Obsolete. Java uses Class<? extends Analyer> to constrain TClass to only Types that inherit from Analyzer. C# does not have a generic type class, ie Type<t>. The method signature stays the same, and an exception may still be thrown, if the method doesn't exist. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer TokenStream(String, TextReader).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | overridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Back to Top
Properties
 | Name | Description
Protected property | PreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Back to Top
See Also
KeywordAnalyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeywordAnalyzer Constructor

KeywordAnalyzer Constructor Lucene.Net Class Library
Initializes a new instance of the KeywordAnalyzer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public KeywordAnalyzer()
public KeywordAnalyzer()
Public Sub New
Public Sub New
public:
KeywordAnalyzer()
public:
KeywordAnalyzer()
See Also
KeywordAnalyzer Class
KeywordAnalyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeywordAnalyzer Fields

KeywordAnalyzer Fields Lucene.Net Class Library
The KeywordAnalyzer type exposes the following members.
Fields
 | Name | Description
Protected field | overridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Back to Top
See Also
KeywordAnalyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeywordAnalyzer Methods

KeywordAnalyzer Methods Lucene.Net Class Library
The KeywordAnalyzer type exposes the following members.
Methods
 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Dispose | (Inherited from Analyzer.)
Protected method | Dispose(Boolean) | (Inherited from Analyzer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetOffsetGap | Just like GetPositionIncrementGap(String), except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReusableTokenStream | (Overrides Analyzer ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod TClass | Obsolete. Java uses Class<? extends Analyer> to constrain TClass to only Types that inherit from Analyzer. C# does not have a generic type class, ie Type<t>. The method signature stays the same, and an exception may still be thrown, if the method doesn't exist. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer TokenStream(String, TextReader).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
KeywordAnalyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReusableTokenStream Method

KeywordAnalyzer ReusableTokenStream Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override
Parameters
fieldName
Type:   Online System String
reader
Type:   Online System.IO TextReader
See Also
KeywordAnalyzer Class
KeywordAnalyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStream Method

KeywordAnalyzer TokenStream Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override
Parameters
fieldName
Type:   Online System String
reader
Type:   Online System.IO TextReader
See Also
KeywordAnalyzer Class
KeywordAnalyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeywordAnalyzer Properties

KeywordAnalyzer Properties Lucene.Net Class Library
The KeywordAnalyzer type exposes the following members.
Properties
 | Name | Description
Protected property | PreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Back to Top
See Also
KeywordAnalyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeywordTokenizer Class

KeywordTokenizer Class Lucene.Net Class Library
Emits the entire input as a single token.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis Tokenizer
Lucene.Net.Analysis KeywordTokenizer

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class KeywordTokenizer : Tokenizer
public sealed class KeywordTokenizer : Tokenizer
Public NotInheritable Class KeywordTokenizer _
    Inherits Tokenizer
Public NotInheritable Class KeywordTokenizer _
    Inherits Tokenizer
public ref class KeywordTokenizer sealed : public Tokenizer
public ref class KeywordTokenizer sealed : public Tokenizer
See Also
KeywordTokenizer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeywordTokenizer Members

KeywordTokenizer Members Lucene.Net Class Library

The KeywordTokenizer type exposes the following members.
Constructors
 | Name | Description
Public method | KeywordTokenizer(TextReader) | Initializes a new instance of the KeywordTokenizer class
Public method | KeywordTokenizer(TextReader, Int32) | Initializes a new instance of the KeywordTokenizer class
Public method | KeywordTokenizer(AttributeSource, TextReader, Int32) | Initializes a new instance of the KeywordTokenizer class
Public method | KeywordTokenizer(AttributeSource AttributeFactory, TextReader, Int32) | Initializes a new instance of the KeywordTokenizer class
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Protected method | CorrectOffset | Return the corrected offset. If input is a CharStream subclass this method calls CorrectOffset(Int32), else returns currentOff. (Inherited from Tokenizer.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from Tokenizer.)
Public method | End | (Overrides TokenStream End .)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ). (Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer Reset(TextReader).)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Fields
 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
KeywordTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeywordTokenizer Constructor

KeywordTokenizer Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | KeywordTokenizer(TextReader) | Initializes a new instance of the KeywordTokenizer class
Public method | KeywordTokenizer(TextReader, Int32) | Initializes a new instance of the KeywordTokenizer class
Public method | KeywordTokenizer(AttributeSource, TextReader, Int32) | Initializes a new instance of the KeywordTokenizer class
Public method | KeywordTokenizer(AttributeSource AttributeFactory, TextReader, Int32) | Initializes a new instance of the KeywordTokenizer class
Back to Top
See Also
KeywordTokenizer Class
KeywordTokenizer Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeywordTokenizer Constructor (TextReader)

KeywordTokenizer Constructor (TextReader) Lucene.Net Class Library
Initializes a new instance of the KeywordTokenizer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public KeywordTokenizer(
    TextReader input
)
public KeywordTokenizer(
    TextReader input
)
Public Sub New ( _
    input As TextReader _
)
Public Sub New ( _
    input As TextReader _
)
public:
KeywordTokenizer(
    TextReader^ input
)
public:
KeywordTokenizer(
    TextReader^ input
)
Parameters
input
Type:   Online System.IO TextReader
See Also
KeywordTokenizer Class
KeywordTokenizer Members
KeywordTokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeywordTokenizer Constructor (TextReader, Int32)

KeywordTokenizer Constructor (TextReader, Int32) Lucene.Net Class Library
Initializes a new instance of the KeywordTokenizer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public KeywordTokenizer(
    TextReader input,
    int bufferSize
)
public KeywordTokenizer(
    TextReader input,
    int bufferSize
)
Public Sub New ( _
    input As TextReader, _
    bufferSize As Integer _
)
Public Sub New ( _
    input As TextReader, _
    bufferSize As Integer _
)
public:
KeywordTokenizer(
    TextReader^ input,
    int bufferSize
)
public:
KeywordTokenizer(
    TextReader^ input,
    int bufferSize
)
Parameters
input
Type:   Online System.IO TextReader
bufferSize
Type:   Online System Int32
See Also
KeywordTokenizer Class
KeywordTokenizer Members
KeywordTokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeywordTokenizer Constructor (AttributeSource, TextReader, Int32)

KeywordTokenizer Constructor (AttributeSource, TextReader, Int32) Lucene.Net Class Library
Initializes a new instance of the KeywordTokenizer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public KeywordTokenizer(
    AttributeSource source,
    TextReader input,
    int bufferSize
)
public KeywordTokenizer(
    AttributeSource source,
    TextReader input,
    int bufferSize
)
Public Sub New ( _
    source As AttributeSource, _
    input As TextReader, _
    bufferSize As Integer _
)
Public Sub New ( _
    source As AttributeSource, _
    input As TextReader, _
    bufferSize As Integer _
)
public:
KeywordTokenizer(
    AttributeSource^ source,
    TextReader^ input,
    int bufferSize
)
public:
KeywordTokenizer(
    AttributeSource^ source,
    TextReader^ input,
    int bufferSize
)
Parameters
source
Type: Lucene.Net.Util AttributeSource
input
Type:   Online System.IO TextReader
bufferSize
Type:   Online System Int32
See Also
KeywordTokenizer Class
KeywordTokenizer Members
KeywordTokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeywordTokenizer Constructor (AttributeSource.AttributeFactory, TextReader, Int32)

KeywordTokenizer Constructor (AttributeSource AttributeFactory, TextReader, Int32) Lucene.Net Class Library
Initializes a new instance of the KeywordTokenizer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public KeywordTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader input,
    int bufferSize
)
public KeywordTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader input,
    int bufferSize
)
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    input As TextReader, _
    bufferSize As Integer _
)
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    input As TextReader, _
    bufferSize As Integer _
)
public:
KeywordTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ input,
    int bufferSize
)
public:
KeywordTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ input,
    int bufferSize
)
Parameters
factory
Type: Lucene.Net.Util AttributeSource AttributeFactory
input
Type:   Online System.IO TextReader
bufferSize
Type:   Online System Int32
See Also
KeywordTokenizer Class
KeywordTokenizer Members
KeywordTokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeywordTokenizer Fields

KeywordTokenizer Fields Lucene.Net Class Library
The KeywordTokenizer type exposes the following members.
Fields
 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)
Back to Top
See Also
KeywordTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeywordTokenizer Methods

KeywordTokenizer Methods Lucene.Net Class Library
The KeywordTokenizer type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Protected method | CorrectOffset | Return the corrected offset. If input is a CharStream subclass this method calls CorrectOffset(Int32), else returns currentOff. (Inherited from Tokenizer.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from Tokenizer.)
Public method | End | (Overrides TokenStream End .)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ). (Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer Reset(TextReader).)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
KeywordTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


End Method

KeywordTokenizer End Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void End()
public override void End()
Public Overrides Sub End
Public Overrides Sub End
public:
virtual void End() override
public:
virtual void End() override
See Also
KeywordTokenizer Class
KeywordTokenizer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncrementToken Method

KeywordTokenizer IncrementToken Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IncrementToken()
public override bool IncrementToken()
Public Overrides Function IncrementToken As Boolean
Public Overrides Function IncrementToken As Boolean
public:
virtual bool IncrementToken() override
public:
virtual bool IncrementToken() override
See Also
KeywordTokenizer Class
KeywordTokenizer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method

KeywordTokenizer Reset Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ). (Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer Reset(TextReader).)
Back to Top
See Also
KeywordTokenizer Class
KeywordTokenizer Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method (TextReader)

KeywordTokenizer Reset Method (TextReader) Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Reset(
    TextReader input
)
public override void Reset(
    TextReader input
)
Public Overrides Sub Reset ( _
    input As TextReader _
)
Public Overrides Sub Reset ( _
    input As TextReader _
)
public:
virtual void Reset(
    TextReader^ input
) override
public:
virtual void Reset(
    TextReader^ input
) override
Parameters
input
Type:   Online System.IO TextReader
See Also
KeywordTokenizer Class
KeywordTokenizer Members
Reset Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeywordTokenizer Properties

KeywordTokenizer Properties Lucene.Net Class Library
The KeywordTokenizer type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
KeywordTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LengthFilter Class

LengthFilter Class Lucene.Net Class Library
Removes words that are too long or too short from the stream.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis TokenFilter
Lucene.Net.Analysis LengthFilter

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LengthFilter : TokenFilter
public sealed class LengthFilter : TokenFilter
Public NotInheritable Class LengthFilter _
    Inherits TokenFilter
Public NotInheritable Class LengthFilter _
    Inherits TokenFilter
public ref class LengthFilter sealed : public TokenFilter
public ref class LengthFilter sealed : public TokenFilter
See Also
LengthFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LengthFilter Members

LengthFilter Members Lucene.Net Class Library

The LengthFilter type exposes the following members.
Constructors
 | Name | Description
Public method | LengthFilter | Build a filter that removes words that are too long or too short from the text.
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | Performs end-of-stream operations, if any, and calls then end() on the input TokenStream. NOTE: Be sure to call super.end() first when overriding this method. (Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | Returns the next input Token whose term() is the right len (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Reset the filter as well as the input TokenStream. (Inherited from TokenFilter.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
LengthFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LengthFilter Constructor

LengthFilter Constructor Lucene.Net Class Library
Build a filter that removes words that are too long or too short from the text.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LengthFilter(
    TokenStream in_Renamed,
    int min,
    int max
)
public LengthFilter(
    TokenStream in_Renamed,
    int min,
    int max
)
Public Sub New ( _
    in_Renamed As TokenStream, _
    min As Integer, _
    max As Integer _
)
Public Sub New ( _
    in_Renamed As TokenStream, _
    min As Integer, _
    max As Integer _
)
public:
LengthFilter(
    TokenStream^ in_Renamed,
    int min,
    int max
)
public:
LengthFilter(
    TokenStream^ in_Renamed,
    int min,
    int max
)
Parameters
in_Renamed
Type: Lucene.Net.Analysis TokenStream
min
Type:   Online System Int32
max
Type:   Online System Int32
See Also
LengthFilter Class
LengthFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LengthFilter Fields

LengthFilter Fields Lucene.Net Class Library
The LengthFilter type exposes the following members.
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
See Also
LengthFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LengthFilter Methods

LengthFilter Methods Lucene.Net Class Library
The LengthFilter type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | Performs end-of-stream operations, if any, and calls then end() on the input TokenStream. NOTE: Be sure to call super.end() first when overriding this method. (Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | Returns the next input Token whose term() is the right len (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Reset the filter as well as the input TokenStream. (Inherited from TokenFilter.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
LengthFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncrementToken Method

LengthFilter IncrementToken Method Lucene.Net Class Library
Returns the next input Token whose term() is the right len

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IncrementToken()
public override bool IncrementToken()
Public Overrides Function IncrementToken As Boolean
Public Overrides Function IncrementToken As Boolean
public:
virtual bool IncrementToken() override
public:
virtual bool IncrementToken() override
See Also
LengthFilter Class
LengthFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LengthFilter Properties

LengthFilter Properties Lucene.Net Class Library
The LengthFilter type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
LengthFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LetterTokenizer Class

LetterTokenizer Class Lucene.Net Class Library
A LetterTokenizer is a tokenizer that divides text at non-letters. That's to say, it defines tokens as maximal strings of adjacent letters, as defined by java.lang.Character.isLetter() predicate. Note: this does a decent job for most European languages, but does a terrible job for some Asian languages, where words are not separated by spaces.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis Tokenizer
Lucene.Net.Analysis CharTokenizer
Lucene.Net.Analysis LetterTokenizer
Lucene.Net.Analysis LowerCaseTokenizer

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LetterTokenizer : CharTokenizer
public class LetterTokenizer : CharTokenizer
Public Class LetterTokenizer _
    Inherits CharTokenizer
Public Class LetterTokenizer _
    Inherits CharTokenizer
public ref class LetterTokenizer : public CharTokenizer
public ref class LetterTokenizer : public CharTokenizer
See Also
LetterTokenizer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LetterTokenizer Members

LetterTokenizer Members Lucene.Net Class Library

The LetterTokenizer type exposes the following members.
Constructors
 | Name | Description
Public method | LetterTokenizer(TextReader) | Construct a new LetterTokenizer.
Public method | LetterTokenizer(AttributeSource, TextReader) | Construct a new LetterTokenizer using a given AttributeSource.
Public method | LetterTokenizer(AttributeSource AttributeFactory, TextReader) | Construct a new LetterTokenizer using a given AttributeSource AttributeFactory.
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Protected method | CorrectOffset | Return the corrected offset. If input is a CharStream subclass this method calls CorrectOffset(Int32), else returns currentOff. (Inherited from Tokenizer.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method | IsTokenChar | Collects only characters which satisfy Online IsLetter(Char). (Overrides CharTokenizer IsTokenChar(Char).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Normalize | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens. (Inherited from CharTokenizer.)
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ). (Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Fields
 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
LetterTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LetterTokenizer Constructor

LetterTokenizer Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | LetterTokenizer(TextReader) | Construct a new LetterTokenizer.
Public method | LetterTokenizer(AttributeSource, TextReader) | Construct a new LetterTokenizer using a given AttributeSource.
Public method | LetterTokenizer(AttributeSource AttributeFactory, TextReader) | Construct a new LetterTokenizer using a given AttributeSource AttributeFactory.
Back to Top
See Also
LetterTokenizer Class
LetterTokenizer Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LetterTokenizer Constructor (TextReader)

LetterTokenizer Constructor (TextReader) Lucene.Net Class Library
Construct a new LetterTokenizer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LetterTokenizer(
    TextReader in
)
public LetterTokenizer(
    TextReader in
)
Public Sub New ( _
    in As TextReader _
)
Public Sub New ( _
    in As TextReader _
)
public:
LetterTokenizer(
    TextReader^ in
)
public:
LetterTokenizer(
    TextReader^ in
)
Parameters
in
Type:   Online System.IO TextReader
See Also
LetterTokenizer Class
LetterTokenizer Members
LetterTokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LetterTokenizer Constructor (AttributeSource, TextReader)

LetterTokenizer Constructor (AttributeSource, TextReader) Lucene.Net Class Library
Construct a new LetterTokenizer using a given AttributeSource.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LetterTokenizer(
    AttributeSource source,
    TextReader in
)
public LetterTokenizer(
    AttributeSource source,
    TextReader in
)
Public Sub New ( _
    source As AttributeSource, _
    in As TextReader _
)
Public Sub New ( _
    source As AttributeSource, _
    in As TextReader _
)
public:
LetterTokenizer(
    AttributeSource^ source,
    TextReader^ in
)
public:
LetterTokenizer(
    AttributeSource^ source,
    TextReader^ in
)
Parameters
source
Type: Lucene.Net.Util AttributeSource
in
Type:   Online System.IO TextReader
See Also
LetterTokenizer Class
LetterTokenizer Members
LetterTokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LetterTokenizer Constructor (AttributeSource.AttributeFactory, TextReader)

LetterTokenizer Constructor (AttributeSource AttributeFactory, TextReader) Lucene.Net Class Library
Construct a new LetterTokenizer using a given AttributeSource AttributeFactory.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LetterTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader in
)
public LetterTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader in
)
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    in As TextReader _
)
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    in As TextReader _
)
public:
LetterTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ in
)
public:
LetterTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ in
)
Parameters
factory
Type: Lucene.Net.Util AttributeSource AttributeFactory
in
Type:   Online System.IO TextReader
See Also
LetterTokenizer Class
LetterTokenizer Members
LetterTokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LetterTokenizer Fields

LetterTokenizer Fields Lucene.Net Class Library
The LetterTokenizer type exposes the following members.
Fields
 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)
Back to Top
See Also
LetterTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LetterTokenizer Methods

LetterTokenizer Methods Lucene.Net Class Library
The LetterTokenizer type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Protected method | CorrectOffset | Return the corrected offset. If input is a CharStream subclass this method calls CorrectOffset(Int32), else returns currentOff. (Inherited from Tokenizer.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method | IsTokenChar | Collects only characters which satisfy Online IsLetter(Char). (Overrides CharTokenizer IsTokenChar(Char).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Normalize | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens. (Inherited from CharTokenizer.)
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ). (Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
LetterTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsTokenChar Method

LetterTokenizer IsTokenChar Method Lucene.Net Class Library
Collects only characters which satisfy Online IsLetter(Char).

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool IsTokenChar(
    char c
)
protected override bool IsTokenChar(
    char c
)
Protected Overrides Function IsTokenChar ( _
    c As Char _
) As Boolean
Protected Overrides Function IsTokenChar ( _
    c As Char _
) As Boolean
protected:
virtual bool IsTokenChar(
    wchar_t c
) override
protected:
virtual bool IsTokenChar(
    wchar_t c
) override
Parameters
c
Type:   Online System Char
See Also
LetterTokenizer Class
LetterTokenizer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LetterTokenizer Properties

LetterTokenizer Properties Lucene.Net Class Library
The LetterTokenizer type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
LetterTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerCaseFilter Class

LowerCaseFilter Class Lucene.Net Class Library
Normalizes token text to lower case.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis TokenFilter
Lucene.Net.Analysis LowerCaseFilter

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LowerCaseFilter : TokenFilter
public sealed class LowerCaseFilter : TokenFilter
Public NotInheritable Class LowerCaseFilter _
    Inherits TokenFilter
Public NotInheritable Class LowerCaseFilter _
    Inherits TokenFilter
public ref class LowerCaseFilter sealed : public TokenFilter
public ref class LowerCaseFilter sealed : public TokenFilter
See Also
LowerCaseFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerCaseFilter Members

LowerCaseFilter Members Lucene.Net Class Library

The LowerCaseFilter type exposes the following members.
Constructors
 | Name | Description
Public method | LowerCaseFilter | Initializes a new instance of the LowerCaseFilter class
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | Performs end-of-stream operations, if any, and calls then end() on the input TokenStream. NOTE: Be sure to call super.end() first when overriding this method. (Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Reset the filter as well as the input TokenStream. (Inherited from TokenFilter.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
LowerCaseFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerCaseFilter Constructor

LowerCaseFilter Constructor Lucene.Net Class Library
Initializes a new instance of the LowerCaseFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LowerCaseFilter(
    TokenStream in
)
public LowerCaseFilter(
    TokenStream in
)
Public Sub New ( _
    in As TokenStream _
)
Public Sub New ( _
    in As TokenStream _
)
public:
LowerCaseFilter(
    TokenStream^ in
)
public:
LowerCaseFilter(
    TokenStream^ in
)
Parameters
in
Type: Lucene.Net.Analysis TokenStream
See Also
LowerCaseFilter Class
LowerCaseFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerCaseFilter Fields

LowerCaseFilter Fields Lucene.Net Class Library
The LowerCaseFilter type exposes the following members.
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
See Also
LowerCaseFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerCaseFilter Methods

LowerCaseFilter Methods Lucene.Net Class Library
The LowerCaseFilter type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | Performs end-of-stream operations, if any, and calls then end() on the input TokenStream. NOTE: Be sure to call super.end() first when overriding this method. (Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Reset the filter as well as the input TokenStream. (Inherited from TokenFilter.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
LowerCaseFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncrementToken Method

LowerCaseFilter IncrementToken Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IncrementToken()
public override bool IncrementToken()
Public Overrides Function IncrementToken As Boolean
Public Overrides Function IncrementToken As Boolean
public:
virtual bool IncrementToken() override
public:
virtual bool IncrementToken() override
See Also
LowerCaseFilter Class
LowerCaseFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerCaseFilter Properties

LowerCaseFilter Properties Lucene.Net Class Library
The LowerCaseFilter type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
LowerCaseFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerCaseTokenizer Class

LowerCaseTokenizer Class Lucene.Net Class Library
LowerCaseTokenizer performs the function of LetterTokenizer and LowerCaseFilter together. It divides text at non-letters and converts them to lower case. While it is functionally equivalent to the combination of LetterTokenizer and LowerCaseFilter, there is a performance advantage to doing the two tasks at once, hence this (redundant) implementation.

Note: this does a decent job for most European languages, but does a terrible job for some Asian languages, where words are not separated by spaces.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis Tokenizer
Lucene.Net.Analysis CharTokenizer
Lucene.Net.Analysis LetterTokenizer
Lucene.Net.Analysis LowerCaseTokenizer

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LowerCaseTokenizer : LetterTokenizer
public sealed class LowerCaseTokenizer : LetterTokenizer
Public NotInheritable Class LowerCaseTokenizer _
    Inherits LetterTokenizer
Public NotInheritable Class LowerCaseTokenizer _
    Inherits LetterTokenizer
public ref class LowerCaseTokenizer sealed : public LetterTokenizer
public ref class LowerCaseTokenizer sealed : public LetterTokenizer
See Also
LowerCaseTokenizer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerCaseTokenizer Members

LowerCaseTokenizer Members Lucene.Net Class Library

The LowerCaseTokenizer type exposes the following members.
Constructors
 | Name | Description
Public method | LowerCaseTokenizer(TextReader) | Construct a new LowerCaseTokenizer.
Public method | LowerCaseTokenizer(AttributeSource, TextReader) | Construct a new LowerCaseTokenizer using a given AttributeSource.
Public method | LowerCaseTokenizer(AttributeSource AttributeFactory, TextReader) | Construct a new LowerCaseTokenizer using a given AttributeSource AttributeFactory.
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Protected method | CorrectOffset | Return the corrected offset. If input is a CharStream subclass this method calls CorrectOffset(Int32), else returns currentOff. (Inherited from Tokenizer.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method | IsTokenChar | Collects only characters which satisfy Online IsLetter(Char). (Inherited from LetterTokenizer.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Normalize | Converts char to lower case Online ToLower(Char). (Overrides CharTokenizer Normalize(Char).)
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ). (Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Fields
 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
LowerCaseTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerCaseTokenizer Constructor

LowerCaseTokenizer Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | LowerCaseTokenizer(TextReader) | Construct a new LowerCaseTokenizer.
Public method | LowerCaseTokenizer(AttributeSource, TextReader) | Construct a new LowerCaseTokenizer using a given AttributeSource.
Public method | LowerCaseTokenizer(AttributeSource AttributeFactory, TextReader) | Construct a new LowerCaseTokenizer using a given AttributeSource AttributeFactory.
Back to Top
See Also
LowerCaseTokenizer Class
LowerCaseTokenizer Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerCaseTokenizer Constructor (TextReader)

LowerCaseTokenizer Constructor (TextReader) Lucene.Net Class Library
Construct a new LowerCaseTokenizer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LowerCaseTokenizer(
    TextReader in
)
public LowerCaseTokenizer(
    TextReader in
)
Public Sub New ( _
    in As TextReader _
)
Public Sub New ( _
    in As TextReader _
)
public:
LowerCaseTokenizer(
    TextReader^ in
)
public:
LowerCaseTokenizer(
    TextReader^ in
)
Parameters
in
Type:   Online System.IO TextReader
See Also
LowerCaseTokenizer Class
LowerCaseTokenizer Members
LowerCaseTokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerCaseTokenizer Constructor (AttributeSource, TextReader)

LowerCaseTokenizer Constructor (AttributeSource, TextReader) Lucene.Net Class Library
Construct a new LowerCaseTokenizer using a given AttributeSource.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LowerCaseTokenizer(
    AttributeSource source,
    TextReader in
)
public LowerCaseTokenizer(
    AttributeSource source,
    TextReader in
)
Public Sub New ( _
    source As AttributeSource, _
    in As TextReader _
)
Public Sub New ( _
    source As AttributeSource, _
    in As TextReader _
)
public:
LowerCaseTokenizer(
    AttributeSource^ source,
    TextReader^ in
)
public:
LowerCaseTokenizer(
    AttributeSource^ source,
    TextReader^ in
)
Parameters
source
Type: Lucene.Net.Util AttributeSource
in
Type:   Online System.IO TextReader
See Also
LowerCaseTokenizer Class
LowerCaseTokenizer Members
LowerCaseTokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerCaseTokenizer Constructor (AttributeSource.AttributeFactory, TextReader)

LowerCaseTokenizer Constructor (AttributeSource AttributeFactory, TextReader) Lucene.Net Class Library
Construct a new LowerCaseTokenizer using a given AttributeSource AttributeFactory.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LowerCaseTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader in
)
public LowerCaseTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader in
)
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    in As TextReader _
)
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    in As TextReader _
)
public:
LowerCaseTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ in
)
public:
LowerCaseTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ in
)
Parameters
factory
Type: Lucene.Net.Util AttributeSource AttributeFactory
in
Type:   Online System.IO TextReader
See Also
LowerCaseTokenizer Class
LowerCaseTokenizer Members
LowerCaseTokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerCaseTokenizer Fields

LowerCaseTokenizer Fields Lucene.Net Class Library
The LowerCaseTokenizer type exposes the following members.
Fields
 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)
Back to Top
See Also
LowerCaseTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerCaseTokenizer Methods

LowerCaseTokenizer Methods Lucene.Net Class Library
The LowerCaseTokenizer type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Protected method | CorrectOffset | Return the corrected offset. If input is a CharStream subclass this method calls CorrectOffset(Int32), else returns currentOff. (Inherited from Tokenizer.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method | IsTokenChar | Collects only characters which satisfy Online IsLetter(Char). (Inherited from LetterTokenizer.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Normalize | Converts char to lower case Online ToLower(Char). (Overrides CharTokenizer Normalize(Char).)
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ). (Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
LowerCaseTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Normalize Method

LowerCaseTokenizer Normalize Method Lucene.Net Class Library
Converts char to lower case Online ToLower(Char).

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override char Normalize(
    char c
)
protected override char Normalize(
    char c
)
Protected Overrides Function Normalize ( _
    c As Char _
) As Char
Protected Overrides Function Normalize ( _
    c As Char _
) As Char
protected:
virtual wchar_t Normalize(
    wchar_t c
) override
protected:
virtual wchar_t Normalize(
    wchar_t c
) override
Parameters
c
Type:   Online System Char
See Also
LowerCaseTokenizer Class
LowerCaseTokenizer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerCaseTokenizer Properties

LowerCaseTokenizer Properties Lucene.Net Class Library
The LowerCaseTokenizer type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
LowerCaseTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MappingCharFilter Class

MappingCharFilter Class Lucene.Net Class Library
Simplistic CharFilter that applies the mappings contained in a NormalizeCharMap to the character stream, and correcting the resulting changes to the offsets.
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO TextReader
Online System.IO StreamReader
Lucene.Net.Analysis CharStream
Lucene.Net.Analysis CharFilter
Lucene.Net.Analysis BaseCharFilter
Lucene.Net.Analysis MappingCharFilter

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MappingCharFilter : BaseCharFilter
public class MappingCharFilter : BaseCharFilter
Public Class MappingCharFilter _
    Inherits BaseCharFilter
Public Class MappingCharFilter _
    Inherits BaseCharFilter
public ref class MappingCharFilter : public BaseCharFilter
public ref class MappingCharFilter : public BaseCharFilter
See Also
MappingCharFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MappingCharFilter Members

MappingCharFilter Members Lucene.Net Class Library

The MappingCharFilter type exposes the following members.
Constructors
 | Name | Description
Public method | MappingCharFilter(NormalizeCharMap, CharStream) | Initializes a new instance of the MappingCharFilter class
Public method | MappingCharFilter(NormalizeCharMap, TextReader) | Initializes a new instance of the MappingCharFilter class
Back to Top
Methods
 | Name | Description
Protected method | AddOffCorrectMap | (Inherited from BaseCharFilter.)
Public method | Online Close | Closes the Online StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from Online StreamReader.)
Protected method | Correct | (Inherited from BaseCharFilter.)
Public method | CorrectOffset | Chains the corrected offset through the input CharFilter. (Inherited from CharFilter.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online DiscardBufferedData | Allows a Online StreamReader object to discard its current data. (Inherited from Online StreamReader.)
Public method | Online Dispose | Releases all resources used by the Online TextReader object. (Inherited from Online TextReader.)
Protected method | Dispose(Boolean) | (Inherited from CharFilter.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Protected method | GetLastCumulativeDiff | Obsolete. (Inherited from BaseCharFilter.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Mark | (Inherited from CharFilter.)
Public method | MarkSupported | (Inherited from CharFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online Peek | Returns the next available character but does not consume it. (Inherited from Online StreamReader.)
Public method | Read | (Overrides Online StreamReader Read .)
Public method | Read( Char , Int32, Int32) | (Overrides CharFilter Read( Char , Int32, Int32).)
Public method | Online ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from Online TextReader.)
Public method | Online ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from Online StreamReader.)
Public method | Online ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from Online StreamReader.)
Public method | Reset | (Inherited from CharFilter.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | input | (Inherited from CharFilter.)
Back to Top
Properties
 | Name | Description
Public property | Online BaseStream | Returns the underlying stream. (Inherited from Online StreamReader.)
Public property | Online CurrentEncoding | Gets the current character encoding that the current Online StreamReader object is using. (Inherited from Online StreamReader.)
Public property | Online EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from Online StreamReader.)
Protected property | LastCumulativeDiff | (Inherited from BaseCharFilter.)
Back to Top
See Also
MappingCharFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MappingCharFilter Constructor

MappingCharFilter Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | MappingCharFilter(NormalizeCharMap, CharStream) | Initializes a new instance of the MappingCharFilter class
Public method | MappingCharFilter(NormalizeCharMap, TextReader) | Initializes a new instance of the MappingCharFilter class
Back to Top
See Also
MappingCharFilter Class
MappingCharFilter Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MappingCharFilter Constructor (NormalizeCharMap, CharStream)

MappingCharFilter Constructor (NormalizeCharMap, CharStream) Lucene.Net Class Library
Initializes a new instance of the MappingCharFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MappingCharFilter(
    NormalizeCharMap normMap,
    CharStream in
)
public MappingCharFilter(
    NormalizeCharMap normMap,
    CharStream in
)
Public Sub New ( _
    normMap As NormalizeCharMap, _
    in As CharStream _
)
Public Sub New ( _
    normMap As NormalizeCharMap, _
    in As CharStream _
)
public:
MappingCharFilter(
    NormalizeCharMap^ normMap,
    CharStream^ in
)
public:
MappingCharFilter(
    NormalizeCharMap^ normMap,
    CharStream^ in
)
Parameters
normMap
Type: Lucene.Net.Analysis NormalizeCharMap
in
Type: Lucene.Net.Analysis CharStream
See Also
MappingCharFilter Class
MappingCharFilter Members
MappingCharFilter Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MappingCharFilter Constructor (NormalizeCharMap, TextReader)

MappingCharFilter Constructor (NormalizeCharMap, TextReader) Lucene.Net Class Library
Initializes a new instance of the MappingCharFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MappingCharFilter(
    NormalizeCharMap normMap,
    TextReader in
)
public MappingCharFilter(
    NormalizeCharMap normMap,
    TextReader in
)
Public Sub New ( _
    normMap As NormalizeCharMap, _
    in As TextReader _
)
Public Sub New ( _
    normMap As NormalizeCharMap, _
    in As TextReader _
)
public:
MappingCharFilter(
    NormalizeCharMap^ normMap,
    TextReader^ in
)
public:
MappingCharFilter(
    NormalizeCharMap^ normMap,
    TextReader^ in
)
Parameters
normMap
Type: Lucene.Net.Analysis NormalizeCharMap
in
Type:   Online System.IO TextReader
See Also
MappingCharFilter Class
MappingCharFilter Members
MappingCharFilter Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MappingCharFilter Fields

MappingCharFilter Fields Lucene.Net Class Library
The MappingCharFilter type exposes the following members.
Fields
 | Name | Description
Protected field | input | (Inherited from CharFilter.)
Back to Top
See Also
MappingCharFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MappingCharFilter Methods

MappingCharFilter Methods Lucene.Net Class Library
The MappingCharFilter type exposes the following members.
Methods
 | Name | Description
Protected method | AddOffCorrectMap | (Inherited from BaseCharFilter.)
Public method | Online Close | Closes the Online StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from Online StreamReader.)
Protected method | Correct | (Inherited from BaseCharFilter.)
Public method | CorrectOffset | Chains the corrected offset through the input CharFilter. (Inherited from CharFilter.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online DiscardBufferedData | Allows a Online StreamReader object to discard its current data. (Inherited from Online StreamReader.)
Public method | Online Dispose | Releases all resources used by the Online TextReader object. (Inherited from Online TextReader.)
Protected method | Dispose(Boolean) | (Inherited from CharFilter.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Protected method | GetLastCumulativeDiff | Obsolete. (Inherited from BaseCharFilter.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Mark | (Inherited from CharFilter.)
Public method | MarkSupported | (Inherited from CharFilter.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online Peek | Returns the next available character but does not consume it. (Inherited from Online StreamReader.)
Public method | Read | (Overrides Online StreamReader Read .)
Public method | Read( Char , Int32, Int32) | (Overrides CharFilter Read( Char , Int32, Int32).)
Public method | Online ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from Online TextReader.)
Public method | Online ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from Online StreamReader.)
Public method | Online ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from Online StreamReader.)
Public method | Reset | (Inherited from CharFilter.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MappingCharFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Read Method

MappingCharFilter Read Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Read | (Overrides Online StreamReader Read .)
Public method | Read( Char , Int32, Int32) | (Overrides CharFilter Read( Char , Int32, Int32).)
Back to Top
See Also
MappingCharFilter Class
MappingCharFilter Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Read Method

MappingCharFilter Read Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Read()
public override int Read()
Public Overrides Function Read As Integer
Public Overrides Function Read As Integer
public:
virtual int Read() override
public:
virtual int Read() override
See Also
MappingCharFilter Class
MappingCharFilter Members
Read Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Read Method (Char[], Int32, Int32)

MappingCharFilter Read Method ( Char , Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Read(
    char[] cbuf,
    int off,
    int len
)
public override int Read(
    char[] cbuf,
    int off,
    int len
)
Public Overrides Function Read ( _
    cbuf As Char(), _
    off As Integer, _
    len As Integer _
) As Integer
Public Overrides Function Read ( _
    cbuf As Char(), _
    off As Integer, _
    len As Integer _
) As Integer
public:
virtual int Read(
    array<wchar_t>^ cbuf,
    int off,
    int len
) override
public:
virtual int Read(
    array<wchar_t>^ cbuf,
    int off,
    int len
) override
Parameters
cbuf
Type:    Online System Char
off
Type:   Online System Int32
len
Type:   Online System Int32
See Also
MappingCharFilter Class
MappingCharFilter Members
Read Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MappingCharFilter Properties

MappingCharFilter Properties Lucene.Net Class Library
The MappingCharFilter type exposes the following members.
Properties
 | Name | Description
Public property | Online BaseStream | Returns the underlying stream. (Inherited from Online StreamReader.)
Public property | Online CurrentEncoding | Gets the current character encoding that the current Online StreamReader object is using. (Inherited from Online StreamReader.)
Public property | Online EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from Online StreamReader.)
Protected property | LastCumulativeDiff | (Inherited from BaseCharFilter.)
Back to Top
See Also
MappingCharFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NormalizeCharMap Class

NormalizeCharMap Class Lucene.Net Class Library
Holds a map of String input to String output, to be used with MappingCharFilter.
Inheritance Hierarchy
Online System Object
Lucene.Net.Analysis NormalizeCharMap

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NormalizeCharMap
public class NormalizeCharMap
Public Class NormalizeCharMap
Public Class NormalizeCharMap
public ref class NormalizeCharMap
public ref class NormalizeCharMap
See Also
NormalizeCharMap Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NormalizeCharMap Members

NormalizeCharMap Members Lucene.Net Class Library

The NormalizeCharMap type exposes the following members.
Constructors
 | Name | Description
Public method | NormalizeCharMap | Initializes a new instance of the NormalizeCharMap class
Back to Top
Methods
 | Name | Description
Public method | Add | Records a replacement to be applied to the inputs stream. Whenever singleMatch occurs in the input, it will be replaced with replacement.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NormalizeCharMap Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NormalizeCharMap Constructor

NormalizeCharMap Constructor Lucene.Net Class Library
Initializes a new instance of the NormalizeCharMap class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NormalizeCharMap()
public NormalizeCharMap()
Public Sub New
Public Sub New
public:
NormalizeCharMap()
public:
NormalizeCharMap()
See Also
NormalizeCharMap Class
NormalizeCharMap Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NormalizeCharMap Methods

NormalizeCharMap Methods Lucene.Net Class Library
The NormalizeCharMap type exposes the following members.
Methods
 | Name | Description
Public method | Add | Records a replacement to be applied to the inputs stream. Whenever singleMatch occurs in the input, it will be replaced with replacement.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NormalizeCharMap Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method

NormalizeCharMap Add Method Lucene.Net Class Library
Records a replacement to be applied to the inputs stream. Whenever singleMatch occurs in the input, it will be replaced with replacement.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Add(
    string singleMatch,
    string replacement
)
public virtual void Add(
    string singleMatch,
    string replacement
)
Public Overridable Sub Add ( _
    singleMatch As String, _
    replacement As String _
)
Public Overridable Sub Add ( _
    singleMatch As String, _
    replacement As String _
)
public:
virtual void Add(
    String^ singleMatch,
    String^ replacement
)
public:
virtual void Add(
    String^ singleMatch,
    String^ replacement
)
Parameters
singleMatch
Type:   Online System String
input String to be replaced

replacement
Type:   Online System String
output String

See Also
NormalizeCharMap Class
NormalizeCharMap Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericTokenStream Class

NumericTokenStream Class Lucene.Net Class Library
Expert: This class provides a TokenStream for indexing numeric values that can be used by NumericRangeQuery T or NumericRangeFilter T .

Note that for simple usage, NumericField is recommended. NumericField disables norms and term freqs, as they are not usually needed during searching. If you need to change these settings, you should use this class.

See NumericField for capabilities of fields indexed numerically.

Here's an example usage, for an int field:
View Colorized Copy to Clipboard Print
Field field = new Field(name, new NumericTokenStream(precisionStep).setIntValue(value));
field.setOmitNorms(true);
field.setOmitTermFreqAndPositions(true);
document.add(field);
Field field = new Field(name, new NumericTokenStream(precisionStep).setIntValue(value));
field.setOmitNorms(true);
field.setOmitTermFreqAndPositions(true);
document.add(field);

For optimal performance, re-use the TokenStream and Field instance for more than one document:
View Colorized Copy to Clipboard Print
NumericTokenStream stream = new NumericTokenStream(precisionStep);
Field field = new Field(name, stream);
field.setOmitNorms(true);
field.setOmitTermFreqAndPositions(true);
Document document = new Document();
document.add(field);

for(all documents) {
  stream.setIntValue(value)
  writer.addDocument(document);
}
NumericTokenStream stream = new NumericTokenStream(precisionStep);
Field field = new Field(name, stream);
field.setOmitNorms(true);
field.setOmitTermFreqAndPositions(true);
Document document = new Document();
document.add(field);

for(all documents) {
  stream.setIntValue(value)
  writer.addDocument(document);
}

This stream is not intended to be used in analyzers; it's more for iterating the different precisions during indexing a specific numeric value.

NOTE: as token streams are only consumed once the document is added to the index, if you index more than one numeric field, use a separate NumericTokenStream instance for each.

See NumericRangeQuery T for more details on the precisionStep parameter as well as how numeric fields work under the hood.

NOTE: This API is experimental and might change in incompatible ways in the next release. Since 2.9
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis NumericTokenStream

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NumericTokenStream : TokenStream
public sealed class NumericTokenStream : TokenStream
Public NotInheritable Class NumericTokenStream _
    Inherits TokenStream
Public NotInheritable Class NumericTokenStream _
    Inherits TokenStream
public ref class NumericTokenStream sealed : public TokenStream
public ref class NumericTokenStream sealed : public TokenStream
See Also
NumericTokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericTokenStream Members

NumericTokenStream Members Lucene.Net Class Library

The NumericTokenStream type exposes the following members.
Constructors
 | Name | Description
Public method | NumericTokenStream | Creates a token stream for numeric values using the default precisionStep PRECISION_STEP_DEFAULT (4). The stream is not yet initialized, before using set a value using the various set???Value() methods.
Public method | NumericTokenStream(Int32) | Creates a token stream for numeric values with the specified precisionStep. The stream is not yet initialized, before using set a value using the various set???Value() methods.
Public method | NumericTokenStream(AttributeSource, Int32) | Expert: Creates a token stream for numeric values with the specified precisionStep using the given AttributeSource. The stream is not yet initialized, before using set a value using the various set???Value() methods.
Public method | NumericTokenStream(AttributeSource AttributeFactory, Int32) | Expert: Creates a token stream for numeric values with the specified precisionStep using the given AttributeSource AttributeFactory. The stream is not yet initialized, before using set a value using the various set???Value() methods.
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the NumericTokenStream and optionally releases the managed resources (Overrides TokenStream Dispose(Boolean).)
Public method | End | This method is called by the consumer after the last token has been consumed, after IncrementToken returned false (using the new TokenStream API). Streams implementing the old API should upgrade to use this feature. This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a WhitespaceTokenizer was used. (Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | (Overrides TokenStream Reset .)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | SetDoubleValue | Initializes the token stream with the supplied double value.
Public method | SetFloatValue | Initializes the token stream with the supplied float value.
Public method | SetIntValue | Initializes the token stream with the supplied int value.
Public method | SetLongValue | Initializes the token stream with the supplied long value.
Public method | ToString | (Overrides AttributeSource ToString .)
Back to Top
Fields
Name | Description
TOKEN_TYPE_FULL_PREC | The full precision token gets this token type assigned.
TOKEN_TYPE_LOWER_PREC | The lower precision tokens gets this token type assigned.
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
NumericTokenStream Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericTokenStream Constructor

NumericTokenStream Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | NumericTokenStream | Creates a token stream for numeric values using the default precisionStep PRECISION_STEP_DEFAULT (4). The stream is not yet initialized, before using set a value using the various set???Value() methods.
Public method | NumericTokenStream(Int32) | Creates a token stream for numeric values with the specified precisionStep. The stream is not yet initialized, before using set a value using the various set???Value() methods.
Public method | NumericTokenStream(AttributeSource, Int32) | Expert: Creates a token stream for numeric values with the specified precisionStep using the given AttributeSource. The stream is not yet initialized, before using set a value using the various set???Value() methods.
Public method | NumericTokenStream(AttributeSource AttributeFactory, Int32) | Expert: Creates a token stream for numeric values with the specified precisionStep using the given AttributeSource AttributeFactory. The stream is not yet initialized, before using set a value using the various set???Value() methods.
Back to Top
See Also
NumericTokenStream Class
NumericTokenStream Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericTokenStream Constructor

NumericTokenStream Constructor Lucene.Net Class Library
Creates a token stream for numeric values using the default precisionStep PRECISION_STEP_DEFAULT (4). The stream is not yet initialized, before using set a value using the various set???Value() methods.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumericTokenStream()
public NumericTokenStream()
Public Sub New
Public Sub New
public:
NumericTokenStream()
public:
NumericTokenStream()
See Also
NumericTokenStream Class
NumericTokenStream Members
NumericTokenStream Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericTokenStream Constructor (Int32)

NumericTokenStream Constructor (Int32) Lucene.Net Class Library
Creates a token stream for numeric values with the specified precisionStep. The stream is not yet initialized, before using set a value using the various set???Value() methods.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumericTokenStream(
    int precisionStep
)
public NumericTokenStream(
    int precisionStep
)
Public Sub New ( _
    precisionStep As Integer _
)
Public Sub New ( _
    precisionStep As Integer _
)
public:
NumericTokenStream(
    int precisionStep
)
public:
NumericTokenStream(
    int precisionStep
)
Parameters
precisionStep
Type:   Online System Int32
See Also
NumericTokenStream Class
NumericTokenStream Members
NumericTokenStream Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericTokenStream Constructor (AttributeSource, Int32)

NumericTokenStream Constructor (AttributeSource, Int32) Lucene.Net Class Library
Expert: Creates a token stream for numeric values with the specified precisionStep using the given AttributeSource. The stream is not yet initialized, before using set a value using the various set???Value() methods.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumericTokenStream(
    AttributeSource source,
    int precisionStep
)
public NumericTokenStream(
    AttributeSource source,
    int precisionStep
)
Public Sub New ( _
    source As AttributeSource, _
    precisionStep As Integer _
)
Public Sub New ( _
    source As AttributeSource, _
    precisionStep As Integer _
)
public:
NumericTokenStream(
    AttributeSource^ source,
    int precisionStep
)
public:
NumericTokenStream(
    AttributeSource^ source,
    int precisionStep
)
Parameters
source
Type: Lucene.Net.Util AttributeSource
precisionStep
Type:   Online System Int32
See Also
NumericTokenStream Class
NumericTokenStream Members
NumericTokenStream Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericTokenStream Constructor (AttributeSource.AttributeFactory, Int32)

NumericTokenStream Constructor (AttributeSource AttributeFactory, Int32) Lucene.Net Class Library
Expert: Creates a token stream for numeric values with the specified precisionStep using the given AttributeSource AttributeFactory. The stream is not yet initialized, before using set a value using the various set???Value() methods.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumericTokenStream(
    AttributeSource..::..AttributeFactory factory,
    int precisionStep
)
public NumericTokenStream(
    AttributeSource..::..AttributeFactory factory,
    int precisionStep
)
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    precisionStep As Integer _
)
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    precisionStep As Integer _
)
public:
NumericTokenStream(
    AttributeSource..::..AttributeFactory^ factory,
    int precisionStep
)
public:
NumericTokenStream(
    AttributeSource..::..AttributeFactory^ factory,
    int precisionStep
)
Parameters
factory
Type: Lucene.Net.Util AttributeSource AttributeFactory
precisionStep
Type:   Online System Int32
See Also
NumericTokenStream Class
NumericTokenStream Members
NumericTokenStream Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericTokenStream Fields

NumericTokenStream Fields Lucene.Net Class Library
The NumericTokenStream type exposes the following members.
Fields
Name | Description
TOKEN_TYPE_FULL_PREC | The full precision token gets this token type assigned.
TOKEN_TYPE_LOWER_PREC | The lower precision tokens gets this token type assigned.
Back to Top
See Also
NumericTokenStream Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TOKEN_TYPE_FULL_PREC Field

NumericTokenStream TOKEN_TYPE_FULL_PREC Field Lucene.Net Class Library
The full precision token gets this token type assigned.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TOKEN_TYPE_FULL_PREC
public const string TOKEN_TYPE_FULL_PREC
Public Const TOKEN_TYPE_FULL_PREC As String
Public Const TOKEN_TYPE_FULL_PREC As String
public:
literal String^ TOKEN_TYPE_FULL_PREC
public:
literal String^ TOKEN_TYPE_FULL_PREC
See Also
NumericTokenStream Class
NumericTokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TOKEN_TYPE_LOWER_PREC Field

NumericTokenStream TOKEN_TYPE_LOWER_PREC Field Lucene.Net Class Library
The lower precision tokens gets this token type assigned.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TOKEN_TYPE_LOWER_PREC
public const string TOKEN_TYPE_LOWER_PREC
Public Const TOKEN_TYPE_LOWER_PREC As String
Public Const TOKEN_TYPE_LOWER_PREC As String
public:
literal String^ TOKEN_TYPE_LOWER_PREC
public:
literal String^ TOKEN_TYPE_LOWER_PREC
See Also
NumericTokenStream Class
NumericTokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericTokenStream Methods

NumericTokenStream Methods Lucene.Net Class Library
The NumericTokenStream type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Overrides TokenStream Dispose(Boolean).)
Public method | End | This method is called by the consumer after the last token has been consumed, after IncrementToken returned false (using the new TokenStream API). Streams implementing the old API should upgrade to use this feature. This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a WhitespaceTokenizer was used. (Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | (Overrides TokenStream Reset .)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | SetDoubleValue | Initializes the token stream with the supplied double value.
Public method | SetFloatValue | Initializes the token stream with the supplied float value.
Public method | SetIntValue | Initializes the token stream with the supplied int value.
Public method | SetLongValue | Initializes the token stream with the supplied long value.
Public method | ToString | (Overrides AttributeSource ToString .)
Back to Top
See Also
NumericTokenStream Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

NumericTokenStream Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the NumericTokenStream and optionally releases the managed resources (Overrides TokenStream Dispose(Boolean).)
Back to Top
See Also
NumericTokenStream Class
NumericTokenStream Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

NumericTokenStream Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the NumericTokenStream and optionally releases the managed resources

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
NumericTokenStream Class
NumericTokenStream Members
Dispose Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncrementToken Method

NumericTokenStream IncrementToken Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IncrementToken()
public override bool IncrementToken()
Public Overrides Function IncrementToken As Boolean
Public Overrides Function IncrementToken As Boolean
public:
virtual bool IncrementToken() override
public:
virtual bool IncrementToken() override
See Also
NumericTokenStream Class
NumericTokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method

NumericTokenStream Reset Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Reset()
public override void Reset()
Public Overrides Sub Reset
Public Overrides Sub Reset
public:
virtual void Reset() override
public:
virtual void Reset() override
See Also
NumericTokenStream Class
NumericTokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetDoubleValue Method

NumericTokenStream SetDoubleValue Method Lucene.Net Class Library
Initializes the token stream with the supplied double value.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumericTokenStream SetDoubleValue(
    double value_Renamed
)
public NumericTokenStream SetDoubleValue(
    double value_Renamed
)
Public Function SetDoubleValue ( _
    value_Renamed As Double _
) As NumericTokenStream
Public Function SetDoubleValue ( _
    value_Renamed As Double _
) As NumericTokenStream
public:
NumericTokenStream^ SetDoubleValue(
    double value_Renamed
)
public:
NumericTokenStream^ SetDoubleValue(
    double value_Renamed
)
Parameters
value_Renamed
Type:   Online System Double
the value, for which this TokenStream should enumerate tokens.

Return Value
 this instance, because of this you can use it the following way:
            new Field(name, new NumericTokenStream(precisionStep).SetDoubleValue(value))
See Also
NumericTokenStream Class
NumericTokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetFloatValue Method

NumericTokenStream SetFloatValue Method Lucene.Net Class Library
Initializes the token stream with the supplied float value.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumericTokenStream SetFloatValue(
    float value_Renamed
)
public NumericTokenStream SetFloatValue(
    float value_Renamed
)
Public Function SetFloatValue ( _
    value_Renamed As Single _
) As NumericTokenStream
Public Function SetFloatValue ( _
    value_Renamed As Single _
) As NumericTokenStream
public:
NumericTokenStream^ SetFloatValue(
    float value_Renamed
)
public:
NumericTokenStream^ SetFloatValue(
    float value_Renamed
)
Parameters
value_Renamed
Type:   Online System Single
the value, for which this TokenStream should enumerate tokens.

Return Value
 this instance, because of this you can use it the following way:
            new Field(name, new NumericTokenStream(precisionStep).SetFloatValue(value))
See Also
NumericTokenStream Class
NumericTokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetIntValue Method

NumericTokenStream SetIntValue Method Lucene.Net Class Library
Initializes the token stream with the supplied int value.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumericTokenStream SetIntValue(
    int value_Renamed
)
public NumericTokenStream SetIntValue(
    int value_Renamed
)
Public Function SetIntValue ( _
    value_Renamed As Integer _
) As NumericTokenStream
Public Function SetIntValue ( _
    value_Renamed As Integer _
) As NumericTokenStream
public:
NumericTokenStream^ SetIntValue(
    int value_Renamed
)
public:
NumericTokenStream^ SetIntValue(
    int value_Renamed
)
Parameters
value_Renamed
Type:   Online System Int32
the value, for which this TokenStream should enumerate tokens.

Return Value
 this instance, because of this you can use it the following way:
            new Field(name, new NumericTokenStream(precisionStep).SetIntValue(value))
See Also
NumericTokenStream Class
NumericTokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetLongValue Method

NumericTokenStream SetLongValue Method Lucene.Net Class Library
Initializes the token stream with the supplied long value.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumericTokenStream SetLongValue(
    long value_Renamed
)
public NumericTokenStream SetLongValue(
    long value_Renamed
)
Public Function SetLongValue ( _
    value_Renamed As Long _
) As NumericTokenStream
Public Function SetLongValue ( _
    value_Renamed As Long _
) As NumericTokenStream
public:
NumericTokenStream^ SetLongValue(
    long long value_Renamed
)
public:
NumericTokenStream^ SetLongValue(
    long long value_Renamed
)
Parameters
value_Renamed
Type:   Online System Int64
the value, for which this TokenStream should enumerate tokens.

Return Value
 this instance, because of this you can use it the following way:
            new Field(name, new NumericTokenStream(precisionStep).SetLongValue(value))
See Also
NumericTokenStream Class
NumericTokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

NumericTokenStream ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
NumericTokenStream Class
NumericTokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericTokenStream Properties

NumericTokenStream Properties Lucene.Net Class Library
The NumericTokenStream type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
NumericTokenStream Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PerFieldAnalyzerWrapper Class

PerFieldAnalyzerWrapper Class Lucene.Net Class Library
This analyzer is used to facilitate scenarios where different fields require different analysis techniques. Use AddAnalyzer(String, Analyzer) to add a non-default analyzer on a field name basis.

Example usage:
View Colorized Copy to Clipboard Print
PerFieldAnalyzerWrapper aWrapper =
new PerFieldAnalyzerWrapper(new StandardAnalyzer());
aWrapper.addAnalyzer("firstname", new KeywordAnalyzer());
aWrapper.addAnalyzer("lastname", new KeywordAnalyzer());
PerFieldAnalyzerWrapper aWrapper =
new PerFieldAnalyzerWrapper(new StandardAnalyzer());
aWrapper.addAnalyzer("firstname", new KeywordAnalyzer());
aWrapper.addAnalyzer("lastname", new KeywordAnalyzer());

In this example, StandardAnalyzer will be used for all fields except "firstname" and "lastname", for which KeywordAnalyzer will be used.

A PerFieldAnalyzerWrapper can be used like any other analyzer, for both indexing and query parsing.
Inheritance Hierarchy
Online System Object
Lucene.Net.Analysis Analyzer
Lucene.Net.Analysis PerFieldAnalyzerWrapper

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PerFieldAnalyzerWrapper : Analyzer
public class PerFieldAnalyzerWrapper : Analyzer
Public Class PerFieldAnalyzerWrapper _
    Inherits Analyzer
Public Class PerFieldAnalyzerWrapper _
    Inherits Analyzer
public ref class PerFieldAnalyzerWrapper : public Analyzer
public ref class PerFieldAnalyzerWrapper : public Analyzer
See Also
PerFieldAnalyzerWrapper Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PerFieldAnalyzerWrapper Members

PerFieldAnalyzerWrapper Members Lucene.Net Class Library

The PerFieldAnalyzerWrapper type exposes the following members.
Constructors
 | Name | Description
Public method | PerFieldAnalyzerWrapper(Analyzer) | Constructs with default analyzer.
Public method | PerFieldAnalyzerWrapper(Analyzer, IEnumerable KeyValuePair String, Analyzer ) | Constructs with default analyzer and a map of analyzers to use for specific fields.
Back to Top
Methods
 | Name | Description
Public method | AddAnalyzer | Defines an analyzer to use for the specified field.
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Dispose | (Inherited from Analyzer.)
Protected method | Dispose(Boolean) | (Inherited from Analyzer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetOffsetGap | Return the offsetGap from the analyzer assigned to field (Overrides Analyzer GetOffsetGap(IFieldable).)
Public method | GetPositionIncrementGap | Return the positionIncrementGap from the analyzer assigned to fieldName (Overrides Analyzer GetPositionIncrementGap(String).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReusableTokenStream | (Overrides Analyzer ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod TClass | Obsolete. Java uses Class<? extends Analyer> to constrain TClass to only Types that inherit from Analyzer. C# does not have a generic type class, ie Type<t>. The method signature stays the same, and an exception may still be thrown, if the method doesn't exist. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer TokenStream(String, TextReader).)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Fields
 | Name | Description
Protected field | overridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Back to Top
Properties
 | Name | Description
Protected property | PreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Back to Top
See Also
PerFieldAnalyzerWrapper Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PerFieldAnalyzerWrapper Constructor

PerFieldAnalyzerWrapper Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | PerFieldAnalyzerWrapper(Analyzer) | Constructs with default analyzer.
Public method | PerFieldAnalyzerWrapper(Analyzer, IEnumerable KeyValuePair String, Analyzer ) | Constructs with default analyzer and a map of analyzers to use for specific fields.
Back to Top
See Also
PerFieldAnalyzerWrapper Class
PerFieldAnalyzerWrapper Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PerFieldAnalyzerWrapper Constructor (Analyzer)

PerFieldAnalyzerWrapper Constructor (Analyzer) Lucene.Net Class Library
Constructs with default analyzer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PerFieldAnalyzerWrapper(
    Analyzer defaultAnalyzer
)
public PerFieldAnalyzerWrapper(
    Analyzer defaultAnalyzer
)
Public Sub New ( _
    defaultAnalyzer As Analyzer _
)
Public Sub New ( _
    defaultAnalyzer As Analyzer _
)
public:
PerFieldAnalyzerWrapper(
    Analyzer^ defaultAnalyzer
)
public:
PerFieldAnalyzerWrapper(
    Analyzer^ defaultAnalyzer
)
Parameters
defaultAnalyzer
Type: Lucene.Net.Analysis Analyzer
Any fields not specifically
            defined to use a different analyzer will use the one provided here.

See Also
PerFieldAnalyzerWrapper Class
PerFieldAnalyzerWrapper Members
PerFieldAnalyzerWrapper Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PerFieldAnalyzerWrapper Constructor (Analyzer, IEnumerable(KeyValuePair(String, Analyzer)))

PerFieldAnalyzerWrapper Constructor (Analyzer, IEnumerable KeyValuePair String, Analyzer ) Lucene.Net Class Library
Constructs with default analyzer and a map of analyzers to use for specific fields.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PerFieldAnalyzerWrapper(
    Analyzer defaultAnalyzer,
    IEnumerable<KeyValuePair<string, Analyzer>> fieldAnalyzers
)
public PerFieldAnalyzerWrapper(
    Analyzer defaultAnalyzer,
    IEnumerable<KeyValuePair<string, Analyzer>> fieldAnalyzers
)
Public Sub New ( _
    defaultAnalyzer As Analyzer, _
    fieldAnalyzers As IEnumerable(Of KeyValuePair(Of String, Analyzer)) _
)
Public Sub New ( _
    defaultAnalyzer As Analyzer, _
    fieldAnalyzers As IEnumerable(Of KeyValuePair(Of String, Analyzer)) _
)
public:
PerFieldAnalyzerWrapper(
    Analyzer^ defaultAnalyzer,
    IEnumerable<KeyValuePair<String^, Analyzer^>>^ fieldAnalyzers
)
public:
PerFieldAnalyzerWrapper(
    Analyzer^ defaultAnalyzer,
    IEnumerable<KeyValuePair<String^, Analyzer^>>^ fieldAnalyzers
)
Parameters
defaultAnalyzer
Type: Lucene.Net.Analysis Analyzer
Any fields not specifically
            defined to use a different analyzer will use the one provided here.

fieldAnalyzers
Type:   Online System.Collections.Generic IEnumerable    Online KeyValuePair    Online String, Analyzer
a Map (String field name to the Analyzer) to be
            used for those fields

See Also
PerFieldAnalyzerWrapper Class
PerFieldAnalyzerWrapper Members
PerFieldAnalyzerWrapper Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PerFieldAnalyzerWrapper Fields

PerFieldAnalyzerWrapper Fields Lucene.Net Class Library
The PerFieldAnalyzerWrapper type exposes the following members.
Fields
 | Name | Description
Protected field | overridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Back to Top
See Also
PerFieldAnalyzerWrapper Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PerFieldAnalyzerWrapper Methods

PerFieldAnalyzerWrapper Methods Lucene.Net Class Library
The PerFieldAnalyzerWrapper type exposes the following members.
Methods
 | Name | Description
Public method | AddAnalyzer | Defines an analyzer to use for the specified field.
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Dispose | (Inherited from Analyzer.)
Protected method | Dispose(Boolean) | (Inherited from Analyzer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetOffsetGap | Return the offsetGap from the analyzer assigned to field (Overrides Analyzer GetOffsetGap(IFieldable).)
Public method | GetPositionIncrementGap | Return the positionIncrementGap from the analyzer assigned to fieldName (Overrides Analyzer GetPositionIncrementGap(String).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReusableTokenStream | (Overrides Analyzer ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod TClass | Obsolete. Java uses Class<? extends Analyer> to constrain TClass to only Types that inherit from Analyzer. C# does not have a generic type class, ie Type<t>. The method signature stays the same, and an exception may still be thrown, if the method doesn't exist. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer TokenStream(String, TextReader).)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
PerFieldAnalyzerWrapper Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddAnalyzer Method

PerFieldAnalyzerWrapper AddAnalyzer Method Lucene.Net Class Library
Defines an analyzer to use for the specified field.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AddAnalyzer(
    string fieldName,
    Analyzer analyzer
)
public virtual void AddAnalyzer(
    string fieldName,
    Analyzer analyzer
)
Public Overridable Sub AddAnalyzer ( _
    fieldName As String, _
    analyzer As Analyzer _
)
Public Overridable Sub AddAnalyzer ( _
    fieldName As String, _
    analyzer As Analyzer _
)
public:
virtual void AddAnalyzer(
    String^ fieldName,
    Analyzer^ analyzer
)
public:
virtual void AddAnalyzer(
    String^ fieldName,
    Analyzer^ analyzer
)
Parameters
fieldName
Type:   Online System String
field name requiring a non-default analyzer

analyzer
Type: Lucene.Net.Analysis Analyzer
non-default analyzer to use for field

See Also
PerFieldAnalyzerWrapper Class
PerFieldAnalyzerWrapper Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetOffsetGap Method

PerFieldAnalyzerWrapper GetOffsetGap Method Lucene.Net Class Library
Return the offsetGap from the analyzer assigned to field

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetOffsetGap(
    IFieldable field
)
public override int GetOffsetGap(
    IFieldable field
)
Public Overrides Function GetOffsetGap ( _
    field As IFieldable _
) As Integer
Public Overrides Function GetOffsetGap ( _
    field As IFieldable _
) As Integer
public:
virtual int GetOffsetGap(
    IFieldable^ field
) override
public:
virtual int GetOffsetGap(
    IFieldable^ field
) override
Parameters
field
Type: Lucene.Net.Documents IFieldable
See Also
PerFieldAnalyzerWrapper Class
PerFieldAnalyzerWrapper Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPositionIncrementGap Method

PerFieldAnalyzerWrapper GetPositionIncrementGap Method Lucene.Net Class Library
Return the positionIncrementGap from the analyzer assigned to fieldName

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetPositionIncrementGap(
    string fieldName
)
public override int GetPositionIncrementGap(
    string fieldName
)
Public Overrides Function GetPositionIncrementGap ( _
    fieldName As String _
) As Integer
Public Overrides Function GetPositionIncrementGap ( _
    fieldName As String _
) As Integer
public:
virtual int GetPositionIncrementGap(
    String^ fieldName
) override
public:
virtual int GetPositionIncrementGap(
    String^ fieldName
) override
Parameters
fieldName
Type:   Online System String
See Also
PerFieldAnalyzerWrapper Class
PerFieldAnalyzerWrapper Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReusableTokenStream Method

PerFieldAnalyzerWrapper ReusableTokenStream Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override
Parameters
fieldName
Type:   Online System String
reader
Type:   Online System.IO TextReader
See Also
PerFieldAnalyzerWrapper Class
PerFieldAnalyzerWrapper Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStream Method

PerFieldAnalyzerWrapper TokenStream Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override
Parameters
fieldName
Type:   Online System String
reader
Type:   Online System.IO TextReader
See Also
PerFieldAnalyzerWrapper Class
PerFieldAnalyzerWrapper Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

PerFieldAnalyzerWrapper ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
PerFieldAnalyzerWrapper Class
PerFieldAnalyzerWrapper Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PerFieldAnalyzerWrapper Properties

PerFieldAnalyzerWrapper Properties Lucene.Net Class Library
The PerFieldAnalyzerWrapper type exposes the following members.
Properties
 | Name | Description
Protected property | PreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Back to Top
See Also
PerFieldAnalyzerWrapper Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PorterStemFilter Class

PorterStemFilter Class Lucene.Net Class Library
Transforms the token stream as per the Porter stemming algorithm. Note: the input to the stemming filter must already be in lower case, so you will need to use LowerCaseFilter or LowerCaseTokenizer farther down the Tokenizer chain in order for this to work properly!

To use this filter with other analyzers, you'll want to write an Analyzer class that sets up the TokenStream chain as you want it. To use this with LowerCaseTokenizer, for example, you'd write an analyzer like this:

View Colorized Copy to Clipboard Print
class MyAnalyzer extends Analyzer {
    public final TokenStream tokenStream(String fieldName, Reader reader) {
         return new PorterStemFilter(new LowerCaseTokenizer(reader));
    }
}
class MyAnalyzer extends Analyzer {
    public final TokenStream tokenStream(String fieldName, Reader reader) {
         return new PorterStemFilter(new LowerCaseTokenizer(reader));
    }
}
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis TokenFilter
Lucene.Net.Analysis PorterStemFilter

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class PorterStemFilter : TokenFilter
public sealed class PorterStemFilter : TokenFilter
Public NotInheritable Class PorterStemFilter _
    Inherits TokenFilter
Public NotInheritable Class PorterStemFilter _
    Inherits TokenFilter
public ref class PorterStemFilter sealed : public TokenFilter
public ref class PorterStemFilter sealed : public TokenFilter
See Also
PorterStemFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PorterStemFilter Members

PorterStemFilter Members Lucene.Net Class Library

The PorterStemFilter type exposes the following members.
Constructors
 | Name | Description
Public method | PorterStemFilter | Initializes a new instance of the PorterStemFilter class
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | Performs end-of-stream operations, if any, and calls then end() on the input TokenStream. NOTE: Be sure to call super.end() first when overriding this method. (Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Reset the filter as well as the input TokenStream. (Inherited from TokenFilter.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
PorterStemFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PorterStemFilter Constructor

PorterStemFilter Constructor Lucene.Net Class Library
Initializes a new instance of the PorterStemFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PorterStemFilter(
    TokenStream in_Renamed
)
public PorterStemFilter(
    TokenStream in_Renamed
)
Public Sub New ( _
    in_Renamed As TokenStream _
)
Public Sub New ( _
    in_Renamed As TokenStream _
)
public:
PorterStemFilter(
    TokenStream^ in_Renamed
)
public:
PorterStemFilter(
    TokenStream^ in_Renamed
)
Parameters
in_Renamed
Type: Lucene.Net.Analysis TokenStream
See Also
PorterStemFilter Class
PorterStemFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PorterStemFilter Fields

PorterStemFilter Fields Lucene.Net Class Library
The PorterStemFilter type exposes the following members.
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
See Also
PorterStemFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PorterStemFilter Methods

PorterStemFilter Methods Lucene.Net Class Library
The PorterStemFilter type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | Performs end-of-stream operations, if any, and calls then end() on the input TokenStream. NOTE: Be sure to call super.end() first when overriding this method. (Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Reset the filter as well as the input TokenStream. (Inherited from TokenFilter.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
PorterStemFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncrementToken Method

PorterStemFilter IncrementToken Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IncrementToken()
public override bool IncrementToken()
Public Overrides Function IncrementToken As Boolean
Public Overrides Function IncrementToken As Boolean
public:
virtual bool IncrementToken() override
public:
virtual bool IncrementToken() override
See Also
PorterStemFilter Class
PorterStemFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PorterStemFilter Properties

PorterStemFilter Properties Lucene.Net Class Library
The PorterStemFilter type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
PorterStemFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleAnalyzer Class

SimpleAnalyzer Class Lucene.Net Class Library
An Analyzer that filters LetterTokenizer with LowerCaseFilter
Inheritance Hierarchy
Online System Object
Lucene.Net.Analysis Analyzer
Lucene.Net.Analysis SimpleAnalyzer

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class SimpleAnalyzer : Analyzer
public sealed class SimpleAnalyzer : Analyzer
Public NotInheritable Class SimpleAnalyzer _
    Inherits Analyzer
Public NotInheritable Class SimpleAnalyzer _
    Inherits Analyzer
public ref class SimpleAnalyzer sealed : public Analyzer
public ref class SimpleAnalyzer sealed : public Analyzer
See Also
SimpleAnalyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleAnalyzer Members

SimpleAnalyzer Members Lucene.Net Class Library

The SimpleAnalyzer type exposes the following members.
Constructors
 | Name | Description
Public method | SimpleAnalyzer | Initializes a new instance of the SimpleAnalyzer class
Back to Top
Methods
 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Dispose | (Inherited from Analyzer.)
Protected method | Dispose(Boolean) | (Inherited from Analyzer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetOffsetGap | Just like GetPositionIncrementGap(String), except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReusableTokenStream | (Overrides Analyzer ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod TClass | Obsolete. Java uses Class<? extends Analyer> to constrain TClass to only Types that inherit from Analyzer. C# does not have a generic type class, ie Type<t>. The method signature stays the same, and an exception may still be thrown, if the method doesn't exist. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer TokenStream(String, TextReader).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | overridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Back to Top
Properties
 | Name | Description
Protected property | PreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Back to Top
See Also
SimpleAnalyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleAnalyzer Constructor

SimpleAnalyzer Constructor Lucene.Net Class Library
Initializes a new instance of the SimpleAnalyzer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SimpleAnalyzer()
public SimpleAnalyzer()
Public Sub New
Public Sub New
public:
SimpleAnalyzer()
public:
SimpleAnalyzer()
See Also
SimpleAnalyzer Class
SimpleAnalyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleAnalyzer Fields

SimpleAnalyzer Fields Lucene.Net Class Library
The SimpleAnalyzer type exposes the following members.
Fields
 | Name | Description
Protected field | overridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Back to Top
See Also
SimpleAnalyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleAnalyzer Methods

SimpleAnalyzer Methods Lucene.Net Class Library
The SimpleAnalyzer type exposes the following members.
Methods
 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Dispose | (Inherited from Analyzer.)
Protected method | Dispose(Boolean) | (Inherited from Analyzer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetOffsetGap | Just like GetPositionIncrementGap(String), except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReusableTokenStream | (Overrides Analyzer ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod TClass | Obsolete. Java uses Class<? extends Analyer> to constrain TClass to only Types that inherit from Analyzer. C# does not have a generic type class, ie Type<t>. The method signature stays the same, and an exception may still be thrown, if the method doesn't exist. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer TokenStream(String, TextReader).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SimpleAnalyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReusableTokenStream Method

SimpleAnalyzer ReusableTokenStream Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override
Parameters
fieldName
Type:   Online System String
reader
Type:   Online System.IO TextReader
See Also
SimpleAnalyzer Class
SimpleAnalyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStream Method

SimpleAnalyzer TokenStream Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override
Parameters
fieldName
Type:   Online System String
reader
Type:   Online System.IO TextReader
See Also
SimpleAnalyzer Class
SimpleAnalyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleAnalyzer Properties

SimpleAnalyzer Properties Lucene.Net Class Library
The SimpleAnalyzer type exposes the following members.
Properties
 | Name | Description
Protected property | PreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Back to Top
See Also
SimpleAnalyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopAnalyzer Class

StopAnalyzer Class Lucene.Net Class Library
Filters LetterTokenizer with LowerCaseFilter and StopFilter.

You must specify the required Version compatibility when creating StopAnalyzer:
  • As of 2.9, position increments are preserved
Inheritance Hierarchy
Online System Object
Lucene.Net.Analysis Analyzer
Lucene.Net.Analysis StopAnalyzer

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class StopAnalyzer : Analyzer
public sealed class StopAnalyzer : Analyzer
Public NotInheritable Class StopAnalyzer _
    Inherits Analyzer
Public NotInheritable Class StopAnalyzer _
    Inherits Analyzer
public ref class StopAnalyzer sealed : public Analyzer
public ref class StopAnalyzer sealed : public Analyzer
See Also
StopAnalyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopAnalyzer Members

StopAnalyzer Members Lucene.Net Class Library

The StopAnalyzer type exposes the following members.
Constructors
 | Name | Description
Public method | StopAnalyzer(Version) | Builds an analyzer which removes words in ENGLISH_STOP_WORDS.
Public method | StopAnalyzer(Version, ISet String ) | Builds an analyzer with the stop words from the given set.
Public method | StopAnalyzer(Version, FileInfo) | Builds an analyzer with the stop words from the given file.
Public method | StopAnalyzer(Version, TextReader) | Builds an analyzer with the stop words from the given reader.
Back to Top
Methods
 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Dispose | (Inherited from Analyzer.)
Protected method | Dispose(Boolean) | (Inherited from Analyzer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetOffsetGap | Just like GetPositionIncrementGap(String), except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReusableTokenStream | (Overrides Analyzer ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod TClass | Obsolete. Java uses Class<? extends Analyer> to constrain TClass to only Types that inherit from Analyzer. C# does not have a generic type class, ie Type<t>. The method signature stays the same, and an exception may still be thrown, if the method doesn't exist. (Inherited from Analyzer.)
Public method | TokenStream | Filters LowerCaseTokenizer with StopFilter. (Overrides Analyzer TokenStream(String, TextReader).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
 | ENGLISH_STOP_WORDS_SET | An unmodifiable set containing some common English words that are not usually useful for searching.
Protected field | overridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Back to Top
Properties
 | Name | Description
Protected property | PreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Back to Top
See Also
StopAnalyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopAnalyzer Constructor

StopAnalyzer Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | StopAnalyzer(Version) | Builds an analyzer which removes words in ENGLISH_STOP_WORDS.
Public method | StopAnalyzer(Version, ISet String ) | Builds an analyzer with the stop words from the given set.
Public method | StopAnalyzer(Version, FileInfo) | Builds an analyzer with the stop words from the given file.
Public method | StopAnalyzer(Version, TextReader) | Builds an analyzer with the stop words from the given reader.
Back to Top
See Also
StopAnalyzer Class
StopAnalyzer Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopAnalyzer Constructor (Version)

StopAnalyzer Constructor (Version) Lucene.Net Class Library
Builds an analyzer which removes words in ENGLISH_STOP_WORDS.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StopAnalyzer(
    Version matchVersion
)
public StopAnalyzer(
    Version matchVersion
)
Public Sub New ( _
    matchVersion As Version _
)
Public Sub New ( _
    matchVersion As Version _
)
public:
StopAnalyzer(
    Version matchVersion
)
public:
StopAnalyzer(
    Version matchVersion
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
See Also
StopAnalyzer Class
StopAnalyzer Members
StopAnalyzer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopAnalyzer Constructor (Version, ISet(String))

StopAnalyzer Constructor (Version, ISet String ) Lucene.Net Class Library
Builds an analyzer with the stop words from the given set.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StopAnalyzer(
    Version matchVersion,
    ISet<string> stopWords
)
public StopAnalyzer(
    Version matchVersion,
    ISet<string> stopWords
)
Public Sub New ( _
    matchVersion As Version, _
    stopWords As ISet(Of String) _
)
Public Sub New ( _
    matchVersion As Version, _
    stopWords As ISet(Of String) _
)
public:
StopAnalyzer(
    Version matchVersion,
    ISet<String^>^ stopWords
)
public:
StopAnalyzer(
    Version matchVersion,
    ISet<String^>^ stopWords
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
stopWords
Type:   Online System.Collections.Generic ISet    Online String
See Also
StopAnalyzer Class
StopAnalyzer Members
StopAnalyzer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopAnalyzer Constructor (Version, FileInfo)

StopAnalyzer Constructor (Version, FileInfo) Lucene.Net Class Library
Builds an analyzer with the stop words from the given file.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StopAnalyzer(
    Version matchVersion,
    FileInfo stopwordsFile
)
public StopAnalyzer(
    Version matchVersion,
    FileInfo stopwordsFile
)
Public Sub New ( _
    matchVersion As Version, _
    stopwordsFile As FileInfo _
)
Public Sub New ( _
    matchVersion As Version, _
    stopwordsFile As FileInfo _
)
public:
StopAnalyzer(
    Version matchVersion,
    FileInfo^ stopwordsFile
)
public:
StopAnalyzer(
    Version matchVersion,
    FileInfo^ stopwordsFile
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
See above
stopwordsFile
Type:   Online System.IO FileInfo
File to load stop words from

See Also
StopAnalyzer Class
StopAnalyzer Members
StopAnalyzer Overload
Lucene.Net.Analysis Namespace
WordlistLoader GetWordSet(FileInfo)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopAnalyzer Constructor (Version, TextReader)

StopAnalyzer Constructor (Version, TextReader) Lucene.Net Class Library
Builds an analyzer with the stop words from the given reader.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StopAnalyzer(
    Version matchVersion,
    TextReader stopwords
)
public StopAnalyzer(
    Version matchVersion,
    TextReader stopwords
)
Public Sub New ( _
    matchVersion As Version, _
    stopwords As TextReader _
)
Public Sub New ( _
    matchVersion As Version, _
    stopwords As TextReader _
)
public:
StopAnalyzer(
    Version matchVersion,
    TextReader^ stopwords
)
public:
StopAnalyzer(
    Version matchVersion,
    TextReader^ stopwords
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
See above
stopwords
Type:   Online System.IO TextReader
Reader to load stop words from

See Also
StopAnalyzer Class
StopAnalyzer Members
StopAnalyzer Overload
Lucene.Net.Analysis Namespace
WordlistLoader GetWordSet(TextReader)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopAnalyzer Fields

StopAnalyzer Fields Lucene.Net Class Library
The StopAnalyzer type exposes the following members.
Fields
 | Name | Description
 | ENGLISH_STOP_WORDS_SET | An unmodifiable set containing some common English words that are not usually useful for searching.
Protected field | overridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Back to Top
See Also
StopAnalyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ENGLISH_STOP_WORDS_SET Field

StopAnalyzer ENGLISH_STOP_WORDS_SET Field Lucene.Net Class Library
An unmodifiable set containing some common English words that are not usually useful for searching.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ISet<string> ENGLISH_STOP_WORDS_SET
public static ISet<string> ENGLISH_STOP_WORDS_SET
Public Shared ENGLISH_STOP_WORDS_SET As ISet(Of String)
Public Shared ENGLISH_STOP_WORDS_SET As ISet(Of String)
public:
static ISet<String^>^ ENGLISH_STOP_WORDS_SET
public:
static ISet<String^>^ ENGLISH_STOP_WORDS_SET
See Also
StopAnalyzer Class
StopAnalyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopAnalyzer Methods

StopAnalyzer Methods Lucene.Net Class Library
The StopAnalyzer type exposes the following members.
Methods
 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Dispose | (Inherited from Analyzer.)
Protected method | Dispose(Boolean) | (Inherited from Analyzer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetOffsetGap | Just like GetPositionIncrementGap(String), except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReusableTokenStream | (Overrides Analyzer ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod TClass | Obsolete. Java uses Class<? extends Analyer> to constrain TClass to only Types that inherit from Analyzer. C# does not have a generic type class, ie Type<t>. The method signature stays the same, and an exception may still be thrown, if the method doesn't exist. (Inherited from Analyzer.)
Public method | TokenStream | Filters LowerCaseTokenizer with StopFilter. (Overrides Analyzer TokenStream(String, TextReader).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
StopAnalyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReusableTokenStream Method

StopAnalyzer ReusableTokenStream Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override
Parameters
fieldName
Type:   Online System String
reader
Type:   Online System.IO TextReader
See Also
StopAnalyzer Class
StopAnalyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStream Method

StopAnalyzer TokenStream Method Lucene.Net Class Library
Filters LowerCaseTokenizer with StopFilter.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override
Parameters
fieldName
Type:   Online System String
reader
Type:   Online System.IO TextReader
See Also
StopAnalyzer Class
StopAnalyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopAnalyzer Properties

StopAnalyzer Properties Lucene.Net Class Library
The StopAnalyzer type exposes the following members.
Properties
 | Name | Description
Protected property | PreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Back to Top
See Also
StopAnalyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopFilter Class

StopFilter Class Lucene.Net Class Library
Removes stop words from a token stream.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis TokenFilter
Lucene.Net.Analysis StopFilter

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class StopFilter : TokenFilter
public sealed class StopFilter : TokenFilter
Public NotInheritable Class StopFilter _
    Inherits TokenFilter
Public NotInheritable Class StopFilter _
    Inherits TokenFilter
public ref class StopFilter sealed : public TokenFilter
public ref class StopFilter sealed : public TokenFilter
See Also
StopFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopFilter Members

StopFilter Members Lucene.Net Class Library

The StopFilter type exposes the following members.
Constructors
 | Name | Description
Public method | StopFilter(Boolean, TokenStream, ISet String ) | Constructs a filter which removes words from the input TokenStream that are named in the Set.
Public method | StopFilter(Boolean, TokenStream, ISet String , Boolean) | Construct a token stream filtering the given input. If stopWords is an instance of CharArraySet (true if makeStopSet() was used to construct the set) it will be directly used and ignoreCase will be ignored since CharArraySet directly controls case sensitivity. If stopWords is not an instance of CharArraySet, a new CharArraySet will be constructed and ignoreCase will be used to specify the case sensitivity of that set.
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | Performs end-of-stream operations, if any, and calls then end() on the input TokenStream. NOTE: Be sure to call super.end() first when overriding this method. (Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
 | GetEnablePositionIncrementsVersionDefault | Returns version-dependent default for enablePositionIncrements. Analyzers that embed StopFilter use this method when creating the StopFilter. Prior to 2.9, this returns false. On 2.9 or later, it returns true.
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | Returns the next input Token whose term() is not a stop word. (Overrides TokenStream IncrementToken .)
 | MakeStopSet(IList Object ) | Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.
 | MakeStopSet( String ) | Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.
 | MakeStopSet(IList Object , Boolean) |
 | MakeStopSet( String , Boolean) |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Reset the filter as well as the input TokenStream. (Inherited from TokenFilter.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
Properties
 | Name | Description
Public property | EnablePositionIncrements | If true, this StopFilter will preserve positions of the incoming tokens (ie, accumulate and set position increments of the removed stop tokens). Generally, true is best as it does not lose information (positions of the original tokens) during indexing. When set, when a token is stopped (omitted), the position increment of the following token is incremented. NOTE: be sure to also set EnablePositionIncrements if you use QueryParser to create queries.
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
StopFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopFilter Constructor

StopFilter Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | StopFilter(Boolean, TokenStream, ISet String ) | Constructs a filter which removes words from the input TokenStream that are named in the Set.
Public method | StopFilter(Boolean, TokenStream, ISet String , Boolean) | Construct a token stream filtering the given input. If stopWords is an instance of CharArraySet (true if makeStopSet() was used to construct the set) it will be directly used and ignoreCase will be ignored since CharArraySet directly controls case sensitivity. If stopWords is not an instance of CharArraySet, a new CharArraySet will be constructed and ignoreCase will be used to specify the case sensitivity of that set.
Back to Top
See Also
StopFilter Class
StopFilter Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopFilter Constructor (Boolean, TokenStream, ISet(String))

StopFilter Constructor (Boolean, TokenStream, ISet String ) Lucene.Net Class Library
Constructs a filter which removes words from the input TokenStream that are named in the Set.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StopFilter(
    bool enablePositionIncrements,
    TokenStream in,
    ISet<string> stopWords
)
public StopFilter(
    bool enablePositionIncrements,
    TokenStream in,
    ISet<string> stopWords
)
Public Sub New ( _
    enablePositionIncrements As Boolean, _
    in As TokenStream, _
    stopWords As ISet(Of String) _
)
Public Sub New ( _
    enablePositionIncrements As Boolean, _
    in As TokenStream, _
    stopWords As ISet(Of String) _
)
public:
StopFilter(
    bool enablePositionIncrements,
    TokenStream^ in,
    ISet<String^>^ stopWords
)
public:
StopFilter(
    bool enablePositionIncrements,
    TokenStream^ in,
    ISet<String^>^ stopWords
)
Parameters
enablePositionIncrements
Type:   Online System Boolean
true if token positions should record the removed stop words
in
Type: Lucene.Net.Analysis TokenStream
Input stream
stopWords
Type:   Online System.Collections.Generic ISet    Online String
A Set of strings or char[] or any other ToString()-able set representing the stopwords
See Also
StopFilter Class
StopFilter Members
StopFilter Overload
Lucene.Net.Analysis Namespace
StopFilter MakeStopSet( String )
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopFilter Constructor (Boolean, TokenStream, ISet(String), Boolean)

StopFilter Constructor (Boolean, TokenStream, ISet String , Boolean) Lucene.Net Class Library
Construct a token stream filtering the given input. If stopWords is an instance of CharArraySet (true if makeStopSet() was used to construct the set) it will be directly used and ignoreCase will be ignored since CharArraySet directly controls case sensitivity.

If stopWords is not an instance of CharArraySet, a new CharArraySet will be constructed and ignoreCase will be used to specify the case sensitivity of that set.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StopFilter(
    bool enablePositionIncrements,
    TokenStream input,
    ISet<string> stopWords,
    bool ignoreCase
)
public StopFilter(
    bool enablePositionIncrements,
    TokenStream input,
    ISet<string> stopWords,
    bool ignoreCase
)
Public Sub New ( _
    enablePositionIncrements As Boolean, _
    input As TokenStream, _
    stopWords As ISet(Of String), _
    ignoreCase As Boolean _
)
Public Sub New ( _
    enablePositionIncrements As Boolean, _
    input As TokenStream, _
    stopWords As ISet(Of String), _
    ignoreCase As Boolean _
)
public:
StopFilter(
    bool enablePositionIncrements,
    TokenStream^ input,
    ISet<String^>^ stopWords,
    bool ignoreCase
)
public:
StopFilter(
    bool enablePositionIncrements,
    TokenStream^ input,
    ISet<String^>^ stopWords,
    bool ignoreCase
)
Parameters
enablePositionIncrements
Type:   Online System Boolean
true if token positions should record the removed stop words
input
Type: Lucene.Net.Analysis TokenStream
Input TokenStream
stopWords
Type:   Online System.Collections.Generic ISet    Online String
A Set of strings or strings or char[] or any other ToString()-able set representing the stopwords
ignoreCase
Type:   Online System Boolean
if true, all words are lower cased first
See Also
StopFilter Class
StopFilter Members
StopFilter Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopFilter Fields

StopFilter Fields Lucene.Net Class Library
The StopFilter type exposes the following members.
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
See Also
StopFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopFilter Methods

StopFilter Methods Lucene.Net Class Library
The StopFilter type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | Performs end-of-stream operations, if any, and calls then end() on the input TokenStream. NOTE: Be sure to call super.end() first when overriding this method. (Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
 | GetEnablePositionIncrementsVersionDefault | Returns version-dependent default for enablePositionIncrements. Analyzers that embed StopFilter use this method when creating the StopFilter. Prior to 2.9, this returns false. On 2.9 or later, it returns true.
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | Returns the next input Token whose term() is not a stop word. (Overrides TokenStream IncrementToken .)
 | MakeStopSet(IList Object ) | Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.
 | MakeStopSet( String ) | Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.
 | MakeStopSet(IList Object , Boolean) |
 | MakeStopSet( String , Boolean) |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Reset the filter as well as the input TokenStream. (Inherited from TokenFilter.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
StopFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetEnablePositionIncrementsVersionDefault Method

StopFilter GetEnablePositionIncrementsVersionDefault Method Lucene.Net Class Library
Returns version-dependent default for enablePositionIncrements. Analyzers that embed StopFilter use this method when creating the StopFilter. Prior to 2.9, this returns false. On 2.9 or later, it returns true.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool GetEnablePositionIncrementsVersionDefault(
    Version matchVersion
)
public static bool GetEnablePositionIncrementsVersionDefault(
    Version matchVersion
)
Public Shared Function GetEnablePositionIncrementsVersionDefault ( _
    matchVersion As Version _
) As Boolean
Public Shared Function GetEnablePositionIncrementsVersionDefault ( _
    matchVersion As Version _
) As Boolean
public:
static bool GetEnablePositionIncrementsVersionDefault(
    Version matchVersion
)
public:
static bool GetEnablePositionIncrementsVersionDefault(
    Version matchVersion
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
See Also
StopFilter Class
StopFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncrementToken Method

StopFilter IncrementToken Method Lucene.Net Class Library
Returns the next input Token whose term() is not a stop word.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IncrementToken()
public override bool IncrementToken()
Public Overrides Function IncrementToken As Boolean
Public Overrides Function IncrementToken As Boolean
public:
virtual bool IncrementToken() override
public:
virtual bool IncrementToken() override
See Also
StopFilter Class
StopFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MakeStopSet Method

StopFilter MakeStopSet Method Lucene.Net Class Library
Overload List
Name | Description
MakeStopSet(IList Object ) | Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.
MakeStopSet( String ) | Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.
MakeStopSet(IList Object , Boolean) |
MakeStopSet( String , Boolean) |
Back to Top
See Also
StopFilter Class
StopFilter Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MakeStopSet Method (IList(Object))

StopFilter MakeStopSet Method (IList Object ) Lucene.Net Class Library
Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ISet<string> MakeStopSet(
    IList<Object> stopWords
)
public static ISet<string> MakeStopSet(
    IList<Object> stopWords
)
Public Shared Function MakeStopSet ( _
    stopWords As IList(Of Object) _
) As ISet(Of String)
Public Shared Function MakeStopSet ( _
    stopWords As IList(Of Object) _
) As ISet(Of String)
public:
static ISet<String^>^ MakeStopSet(
    IList<Object^>^ stopWords
)
public:
static ISet<String^>^ MakeStopSet(
    IList<Object^>^ stopWords
)
Parameters
stopWords
Type:   Online System.Collections.Generic IList    Online Object
A list of strings or char[] or any other ToString()-able list representing the stop words
See Also
StopFilter Class
StopFilter Members
MakeStopSet Overload
Lucene.Net.Analysis Namespace
passing false to ignoreCase
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MakeStopSet Method (String[])

StopFilter MakeStopSet Method ( String ) Lucene.Net Class Library
Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ISet<string> MakeStopSet(
    params string[] stopWords
)
public static ISet<string> MakeStopSet(
    params string[] stopWords
)
Public Shared Function MakeStopSet ( _
    ParamArray stopWords As String() _
) As ISet(Of String)
Public Shared Function MakeStopSet ( _
    ParamArray stopWords As String() _
) As ISet(Of String)
public:
static ISet<String^>^ MakeStopSet(
    ... array<String^>^ stopWords
)
public:
static ISet<String^>^ MakeStopSet(
    ... array<String^>^ stopWords
)
Parameters
stopWords
Type:    Online System String
See Also
StopFilter Class
StopFilter Members
MakeStopSet Overload
Lucene.Net.Analysis Namespace
passing false to ignoreCase
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MakeStopSet Method (IList(Object), Boolean)

StopFilter MakeStopSet Method (IList Object , Boolean) Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ISet<string> MakeStopSet(
    IList<Object> stopWords,
    bool ignoreCase
)
public static ISet<string> MakeStopSet(
    IList<Object> stopWords,
    bool ignoreCase
)
Public Shared Function MakeStopSet ( _
    stopWords As IList(Of Object), _
    ignoreCase As Boolean _
) As ISet(Of String)
Public Shared Function MakeStopSet ( _
    stopWords As IList(Of Object), _
    ignoreCase As Boolean _
) As ISet(Of String)
public:
static ISet<String^>^ MakeStopSet(
    IList<Object^>^ stopWords,
    bool ignoreCase
)
public:
static ISet<String^>^ MakeStopSet(
    IList<Object^>^ stopWords,
    bool ignoreCase
)
Parameters
stopWords
Type:   Online System.Collections.Generic IList    Online Object
A List of Strings or char[] or any other toString()-able list representing the stopwords
ignoreCase
Type:   Online System Boolean
if true, all words are lower cased first
Return Value
A Set (CharArraySet)containing the words
See Also
StopFilter Class
StopFilter Members
MakeStopSet Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MakeStopSet Method (String[], Boolean)

StopFilter MakeStopSet Method ( String , Boolean) Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ISet<string> MakeStopSet(
    string[] stopWords,
    bool ignoreCase
)
public static ISet<string> MakeStopSet(
    string[] stopWords,
    bool ignoreCase
)
Public Shared Function MakeStopSet ( _
    stopWords As String(), _
    ignoreCase As Boolean _
) As ISet(Of String)
Public Shared Function MakeStopSet ( _
    stopWords As String(), _
    ignoreCase As Boolean _
) As ISet(Of String)
public:
static ISet<String^>^ MakeStopSet(
    array<String^>^ stopWords,
    bool ignoreCase
)
public:
static ISet<String^>^ MakeStopSet(
    array<String^>^ stopWords,
    bool ignoreCase
)
Parameters
stopWords
Type:    Online System String
An array of stopwords
ignoreCase
Type:   Online System Boolean
If true, all words are lower cased first.
Return Value
 a Set containing the words
See Also
StopFilter Class
StopFilter Members
MakeStopSet Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StopFilter Properties

StopFilter Properties Lucene.Net Class Library
The StopFilter type exposes the following members.
Properties
 | Name | Description
Public property | EnablePositionIncrements | If true, this StopFilter will preserve positions of the incoming tokens (ie, accumulate and set position increments of the removed stop tokens). Generally, true is best as it does not lose information (positions of the original tokens) during indexing. When set, when a token is stopped (omitted), the position increment of the following token is incremented. NOTE: be sure to also set EnablePositionIncrements if you use QueryParser to create queries.
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
StopFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EnablePositionIncrements Property

StopFilter EnablePositionIncrements Property Lucene.Net Class Library
If true, this StopFilter will preserve positions of the incoming tokens (ie, accumulate and set position increments of the removed stop tokens). Generally, true is best as it does not lose information (positions of the original tokens) during indexing.

When set, when a token is stopped (omitted), the position increment of the following token is incremented.

NOTE: be sure to also set EnablePositionIncrements if you use QueryParser to create queries.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool EnablePositionIncrements { get; set; }
public bool EnablePositionIncrements { get; set; }
Public Property EnablePositionIncrements As Boolean
    Get
    Set
Public Property EnablePositionIncrements As Boolean
    Get
    Set
public:
property bool EnablePositionIncrements {
    bool get ();
    void set (bool value);
}
public:
property bool EnablePositionIncrements {
    bool get ();
    void set (bool value);
}
See Also
StopFilter Class
StopFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter Class

TeeSinkTokenFilter Class Lucene.Net Class Library
This TokenFilter provides the ability to set aside attribute states that have already been analyzed. This is useful in situations where multiple fields share many common analysis steps and then go their separate ways.

It is also useful for doing things like entity extraction or proper noun analysis as part of the analysis workflow and saving off those tokens for use in another field.
View Colorized Copy to Clipboard Print
TeeSinkTokenFilter source1 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader1));
TeeSinkTokenFilter.SinkTokenStream sink1 = source1.newSinkTokenStream();
TeeSinkTokenFilter.SinkTokenStream sink2 = source1.newSinkTokenStream();
TeeSinkTokenFilter source2 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader2));
source2.addSinkTokenStream(sink1);
source2.addSinkTokenStream(sink2);
TokenStream final1 = new LowerCaseFilter(source1);
TokenStream final2 = source2;
TokenStream final3 = new EntityDetect(sink1);
TokenStream final4 = new URLDetect(sink2);
d.add(new Field("f1", final1));
d.add(new Field("f2", final2));
d.add(new Field("f3", final3));
d.add(new Field("f4", final4));
TeeSinkTokenFilter source1 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader1));
TeeSinkTokenFilter.SinkTokenStream sink1 = source1.newSinkTokenStream();
TeeSinkTokenFilter.SinkTokenStream sink2 = source1.newSinkTokenStream();
TeeSinkTokenFilter source2 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader2));
source2.addSinkTokenStream(sink1);
source2.addSinkTokenStream(sink2);
TokenStream final1 = new LowerCaseFilter(source1);
TokenStream final2 = source2;
TokenStream final3 = new EntityDetect(sink1);
TokenStream final4 = new URLDetect(sink2);
d.add(new Field("f1", final1));
d.add(new Field("f2", final2));
d.add(new Field("f3", final3));
d.add(new Field("f4", final4));
In this example, sink1 and sink2 will both get tokens from both reader1 and reader2 after whitespace tokenizer and now we can further wrap any of these in extra analysis, and more "sources" can be inserted if desired. It is important, that tees are consumed before sinks (in the above example, the field names must be less the sink's field names). If you are not sure, which stream is consumed first, you can simply add another sink and then pass all tokens to the sinks at once using ConsumeAllTokens . This TokenFilter is exhausted after this. In the above example, change the example above to:
View Colorized Copy to Clipboard Print
...
TokenStream final1 = new LowerCaseFilter(source1.newSinkTokenStream());
TokenStream final2 = source2.newSinkTokenStream();
sink1.consumeAllTokens();
sink2.consumeAllTokens();
...
...
TokenStream final1 = new LowerCaseFilter(source1.newSinkTokenStream());
TokenStream final2 = source2.newSinkTokenStream();
sink1.consumeAllTokens();
sink2.consumeAllTokens();
...
In this case, the fields can be added in any order, because the sources are not used anymore and all sinks are ready.

Note, the EntityDetect and URLDetect TokenStreams are for the example and do not currently exist in Lucene.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis TokenFilter
Lucene.Net.Analysis TeeSinkTokenFilter

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class TeeSinkTokenFilter : TokenFilter
public sealed class TeeSinkTokenFilter : TokenFilter
Public NotInheritable Class TeeSinkTokenFilter _
    Inherits TokenFilter
Public NotInheritable Class TeeSinkTokenFilter _
    Inherits TokenFilter
public ref class TeeSinkTokenFilter sealed : public TokenFilter
public ref class TeeSinkTokenFilter sealed : public TokenFilter
See Also
TeeSinkTokenFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter Members

TeeSinkTokenFilter Members Lucene.Net Class Library

The TeeSinkTokenFilter type exposes the following members.
Constructors
 | Name | Description
Public method | TeeSinkTokenFilter | Instantiates a new TeeSinkTokenFilter.
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | AddSinkTokenStream | Adds a TeeSinkTokenFilter SinkTokenStream created by another TeeSinkTokenFilter to this one. The supplied stream will also receive all consumed tokens. This method can be used to pass tokens from two different tees to one sink.
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | ConsumeAllTokens | TeeSinkTokenFilter passes all tokens to the added sinks when itself is consumed. To be sure, that all tokens from the input stream are passed to the sinks, you can call this methods. This instance is exhausted after this, but all sinks are instant available.
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | (Overrides TokenFilter End .)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NewSinkTokenStream | Returns a new TeeSinkTokenFilter SinkTokenStream that receives all tokens consumed by this stream.
Public method | NewSinkTokenStream(TeeSinkTokenFilter SinkFilter) | Returns a new TeeSinkTokenFilter SinkTokenStream that receives all tokens consumed by this stream that pass the supplied filter.
Public method | Reset | Reset the filter as well as the input TokenStream. (Inherited from TokenFilter.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
TeeSinkTokenFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter Constructor

TeeSinkTokenFilter Constructor Lucene.Net Class Library
Instantiates a new TeeSinkTokenFilter.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TeeSinkTokenFilter(
    TokenStream input
)
public TeeSinkTokenFilter(
    TokenStream input
)
Public Sub New ( _
    input As TokenStream _
)
Public Sub New ( _
    input As TokenStream _
)
public:
TeeSinkTokenFilter(
    TokenStream^ input
)
public:
TeeSinkTokenFilter(
    TokenStream^ input
)
Parameters
input
Type: Lucene.Net.Analysis TokenStream
See Also
TeeSinkTokenFilter Class
TeeSinkTokenFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter Fields

TeeSinkTokenFilter Fields Lucene.Net Class Library
The TeeSinkTokenFilter type exposes the following members.
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
See Also
TeeSinkTokenFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter Methods

TeeSinkTokenFilter Methods Lucene.Net Class Library
The TeeSinkTokenFilter type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | AddSinkTokenStream | Adds a TeeSinkTokenFilter SinkTokenStream created by another TeeSinkTokenFilter to this one. The supplied stream will also receive all consumed tokens. This method can be used to pass tokens from two different tees to one sink.
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | ConsumeAllTokens | TeeSinkTokenFilter passes all tokens to the added sinks when itself is consumed. To be sure, that all tokens from the input stream are passed to the sinks, you can call this methods. This instance is exhausted after this, but all sinks are instant available.
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | (Overrides TokenFilter End .)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NewSinkTokenStream | Returns a new TeeSinkTokenFilter SinkTokenStream that receives all tokens consumed by this stream.
Public method | NewSinkTokenStream(TeeSinkTokenFilter SinkFilter) | Returns a new TeeSinkTokenFilter SinkTokenStream that receives all tokens consumed by this stream that pass the supplied filter.
Public method | Reset | Reset the filter as well as the input TokenStream. (Inherited from TokenFilter.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
TeeSinkTokenFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddSinkTokenStream Method

TeeSinkTokenFilter AddSinkTokenStream Method Lucene.Net Class Library
Adds a TeeSinkTokenFilter SinkTokenStream created by another TeeSinkTokenFilter to this one. The supplied stream will also receive all consumed tokens. This method can be used to pass tokens from two different tees to one sink.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddSinkTokenStream(
    TeeSinkTokenFilter..::..SinkTokenStream sink
)
public void AddSinkTokenStream(
    TeeSinkTokenFilter..::..SinkTokenStream sink
)
Public Sub AddSinkTokenStream ( _
    sink As TeeSinkTokenFilter..::..SinkTokenStream _
)
Public Sub AddSinkTokenStream ( _
    sink As TeeSinkTokenFilter..::..SinkTokenStream _
)
public:
void AddSinkTokenStream(
    TeeSinkTokenFilter..::..SinkTokenStream^ sink
)
public:
void AddSinkTokenStream(
    TeeSinkTokenFilter..::..SinkTokenStream^ sink
)
Parameters
sink
Type: Lucene.Net.Analysis TeeSinkTokenFilter SinkTokenStream
See Also
TeeSinkTokenFilter Class
TeeSinkTokenFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConsumeAllTokens Method

TeeSinkTokenFilter ConsumeAllTokens Method Lucene.Net Class Library
TeeSinkTokenFilter passes all tokens to the added sinks when itself is consumed. To be sure, that all tokens from the input stream are passed to the sinks, you can call this methods. This instance is exhausted after this, but all sinks are instant available.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ConsumeAllTokens()
public void ConsumeAllTokens()
Public Sub ConsumeAllTokens
Public Sub ConsumeAllTokens
public:
void ConsumeAllTokens()
public:
void ConsumeAllTokens()
See Also
TeeSinkTokenFilter Class
TeeSinkTokenFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


End Method

TeeSinkTokenFilter End Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void End()
public override void End()
Public Overrides Sub End
Public Overrides Sub End
public:
virtual void End() override
public:
virtual void End() override
See Also
TeeSinkTokenFilter Class
TeeSinkTokenFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncrementToken Method

TeeSinkTokenFilter IncrementToken Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IncrementToken()
public override bool IncrementToken()
Public Overrides Function IncrementToken As Boolean
Public Overrides Function IncrementToken As Boolean
public:
virtual bool IncrementToken() override
public:
virtual bool IncrementToken() override
See Also
TeeSinkTokenFilter Class
TeeSinkTokenFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewSinkTokenStream Method

TeeSinkTokenFilter NewSinkTokenStream Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | NewSinkTokenStream | Returns a new TeeSinkTokenFilter SinkTokenStream that receives all tokens consumed by this stream.
Public method | NewSinkTokenStream(TeeSinkTokenFilter SinkFilter) | Returns a new TeeSinkTokenFilter SinkTokenStream that receives all tokens consumed by this stream that pass the supplied filter.
Back to Top
See Also
TeeSinkTokenFilter Class
TeeSinkTokenFilter Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewSinkTokenStream Method

TeeSinkTokenFilter NewSinkTokenStream Method Lucene.Net Class Library
Returns a new TeeSinkTokenFilter SinkTokenStream that receives all tokens consumed by this stream.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TeeSinkTokenFilter..::..SinkTokenStream NewSinkTokenStream()
public TeeSinkTokenFilter..::..SinkTokenStream NewSinkTokenStream()
Public Function NewSinkTokenStream As TeeSinkTokenFilter..::..SinkTokenStream
Public Function NewSinkTokenStream As TeeSinkTokenFilter..::..SinkTokenStream
public:
TeeSinkTokenFilter..::..SinkTokenStream^ NewSinkTokenStream()
public:
TeeSinkTokenFilter..::..SinkTokenStream^ NewSinkTokenStream()
See Also
TeeSinkTokenFilter Class
TeeSinkTokenFilter Members
NewSinkTokenStream Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewSinkTokenStream Method (TeeSinkTokenFilter.SinkFilter)

TeeSinkTokenFilter NewSinkTokenStream Method (TeeSinkTokenFilter SinkFilter) Lucene.Net Class Library
Returns a new TeeSinkTokenFilter SinkTokenStream that receives all tokens consumed by this stream that pass the supplied filter.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TeeSinkTokenFilter..::..SinkTokenStream NewSinkTokenStream(
    TeeSinkTokenFilter..::..SinkFilter filter
)
public TeeSinkTokenFilter..::..SinkTokenStream NewSinkTokenStream(
    TeeSinkTokenFilter..::..SinkFilter filter
)
Public Function NewSinkTokenStream ( _
    filter As TeeSinkTokenFilter..::..SinkFilter _
) As TeeSinkTokenFilter..::..SinkTokenStream
Public Function NewSinkTokenStream ( _
    filter As TeeSinkTokenFilter..::..SinkFilter _
) As TeeSinkTokenFilter..::..SinkTokenStream
public:
TeeSinkTokenFilter..::..SinkTokenStream^ NewSinkTokenStream(
    TeeSinkTokenFilter..::..SinkFilter^ filter
)
public:
TeeSinkTokenFilter..::..SinkTokenStream^ NewSinkTokenStream(
    TeeSinkTokenFilter..::..SinkFilter^ filter
)
Parameters
filter
Type: Lucene.Net.Analysis TeeSinkTokenFilter SinkFilter
See Also
TeeSinkTokenFilter Class
TeeSinkTokenFilter Members
NewSinkTokenStream Overload
Lucene.Net.Analysis Namespace
Lucene.Net.Analysis TeeSinkTokenFilter SinkFilter
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter Properties

TeeSinkTokenFilter Properties Lucene.Net Class Library
The TeeSinkTokenFilter type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
TeeSinkTokenFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter.AnonymousClassSinkFilter Class

TeeSinkTokenFilter AnonymousClassSinkFilter Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Analysis TeeSinkTokenFilter SinkFilter
Lucene.Net.Analysis TeeSinkTokenFilter AnonymousClassSinkFilter

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AnonymousClassSinkFilter : TeeSinkTokenFilter..::..SinkFilter
public class AnonymousClassSinkFilter : TeeSinkTokenFilter..::..SinkFilter
Public Class AnonymousClassSinkFilter _
    Inherits TeeSinkTokenFilter..::..SinkFilter
Public Class AnonymousClassSinkFilter _
    Inherits TeeSinkTokenFilter..::..SinkFilter
public ref class AnonymousClassSinkFilter : public TeeSinkTokenFilter..::..SinkFilter
public ref class AnonymousClassSinkFilter : public TeeSinkTokenFilter..::..SinkFilter
See Also
TeeSinkTokenFilter AnonymousClassSinkFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter.AnonymousClassSinkFilter Members

TeeSinkTokenFilter AnonymousClassSinkFilter Members Lucene.Net Class Library

This TokenFilter provides the ability to set aside attribute states that have already been analyzed. This is useful in situations where multiple fields share many common analysis steps and then go their separate ways.

It is also useful for doing things like entity extraction or proper noun analysis as part of the analysis workflow and saving off those tokens for use in another field.
View Colorized Copy to Clipboard Print
TeeSinkTokenFilter source1 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader1));
TeeSinkTokenFilter.SinkTokenStream sink1 = source1.newSinkTokenStream();
TeeSinkTokenFilter.SinkTokenStream sink2 = source1.newSinkTokenStream();
TeeSinkTokenFilter source2 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader2));
source2.addSinkTokenStream(sink1);
source2.addSinkTokenStream(sink2);
TokenStream final1 = new LowerCaseFilter(source1);
TokenStream final2 = source2;
TokenStream final3 = new EntityDetect(sink1);
TokenStream final4 = new URLDetect(sink2);
d.add(new Field("f1", final1));
d.add(new Field("f2", final2));
d.add(new Field("f3", final3));
d.add(new Field("f4", final4));
TeeSinkTokenFilter source1 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader1));
TeeSinkTokenFilter.SinkTokenStream sink1 = source1.newSinkTokenStream();
TeeSinkTokenFilter.SinkTokenStream sink2 = source1.newSinkTokenStream();
TeeSinkTokenFilter source2 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader2));
source2.addSinkTokenStream(sink1);
source2.addSinkTokenStream(sink2);
TokenStream final1 = new LowerCaseFilter(source1);
TokenStream final2 = source2;
TokenStream final3 = new EntityDetect(sink1);
TokenStream final4 = new URLDetect(sink2);
d.add(new Field("f1", final1));
d.add(new Field("f2", final2));
d.add(new Field("f3", final3));
d.add(new Field("f4", final4));
In this example, sink1 and sink2 will both get tokens from both reader1 and reader2 after whitespace tokenizer and now we can further wrap any of these in extra analysis, and more "sources" can be inserted if desired. It is important, that tees are consumed before sinks (in the above example, the field names must be less the sink's field names). If you are not sure, which stream is consumed first, you can simply add another sink and then pass all tokens to the sinks at once using ConsumeAllTokens . This TokenFilter is exhausted after this. In the above example, change the example above to:
View Colorized Copy to Clipboard Print
...
TokenStream final1 = new LowerCaseFilter(source1.newSinkTokenStream());
TokenStream final2 = source2.newSinkTokenStream();
sink1.consumeAllTokens();
sink2.consumeAllTokens();
...
...
TokenStream final1 = new LowerCaseFilter(source1.newSinkTokenStream());
TokenStream final2 = source2.newSinkTokenStream();
sink1.consumeAllTokens();
sink2.consumeAllTokens();
...
In this case, the fields can be added in any order, because the sources are not used anymore and all sinks are ready.

Note, the EntityDetect and URLDetect TokenStreams are for the example and do not currently exist in Lucene.

The TeeSinkTokenFilter AnonymousClassSinkFilter type exposes the following members.
Constructors
 | Name | Description
Public method | TeeSinkTokenFilter AnonymousClassSinkFilter | Initializes a new instance of the TeeSinkTokenFilter AnonymousClassSinkFilter class
Back to Top
Methods
 | Name | Description
Public method | Accept | (Overrides TeeSinkTokenFilter SinkFilter Accept(AttributeSource).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Called by Reset . This method does nothing by default and can optionally be overridden. (Inherited from TeeSinkTokenFilter SinkFilter.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TeeSinkTokenFilter AnonymousClassSinkFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter.AnonymousClassSinkFilter Constructor

TeeSinkTokenFilter AnonymousClassSinkFilter Constructor Lucene.Net Class Library
Initializes a new instance of the TeeSinkTokenFilter AnonymousClassSinkFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AnonymousClassSinkFilter()
public AnonymousClassSinkFilter()
Public Sub New
Public Sub New
public:
AnonymousClassSinkFilter()
public:
AnonymousClassSinkFilter()
See Also
TeeSinkTokenFilter AnonymousClassSinkFilter Class
TeeSinkTokenFilter AnonymousClassSinkFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter.AnonymousClassSinkFilter Methods

TeeSinkTokenFilter AnonymousClassSinkFilter Methods Lucene.Net Class Library
The TeeSinkTokenFilter AnonymousClassSinkFilter type exposes the following members.
Methods
 | Name | Description
Public method | Accept | (Overrides TeeSinkTokenFilter SinkFilter Accept(AttributeSource).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Called by Reset . This method does nothing by default and can optionally be overridden. (Inherited from TeeSinkTokenFilter SinkFilter.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TeeSinkTokenFilter AnonymousClassSinkFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Accept Method

TeeSinkTokenFilter AnonymousClassSinkFilter Accept Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Accept(
    AttributeSource source
)
public override bool Accept(
    AttributeSource source
)
Public Overrides Function Accept ( _
    source As AttributeSource _
) As Boolean
Public Overrides Function Accept ( _
    source As AttributeSource _
) As Boolean
public:
virtual bool Accept(
    AttributeSource^ source
) override
public:
virtual bool Accept(
    AttributeSource^ source
) override
Parameters
source
Type: Lucene.Net.Util AttributeSource
See Also
TeeSinkTokenFilter AnonymousClassSinkFilter Class
TeeSinkTokenFilter AnonymousClassSinkFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter.SinkFilter Class

TeeSinkTokenFilter SinkFilter Class Lucene.Net Class Library
A filter that decides which AttributeSource states to store in the sink.
Inheritance Hierarchy
Online System Object
Lucene.Net.Analysis TeeSinkTokenFilter SinkFilter
Lucene.Net.Analysis TeeSinkTokenFilter AnonymousClassSinkFilter

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class SinkFilter
public abstract class SinkFilter
Public MustInherit Class SinkFilter
Public MustInherit Class SinkFilter
public ref class SinkFilter abstract
public ref class SinkFilter abstract
See Also
TeeSinkTokenFilter SinkFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter.SinkFilter Members

TeeSinkTokenFilter SinkFilter Members Lucene.Net Class Library

This TokenFilter provides the ability to set aside attribute states that have already been analyzed. This is useful in situations where multiple fields share many common analysis steps and then go their separate ways.

It is also useful for doing things like entity extraction or proper noun analysis as part of the analysis workflow and saving off those tokens for use in another field.
View Colorized Copy to Clipboard Print
TeeSinkTokenFilter source1 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader1));
TeeSinkTokenFilter.SinkTokenStream sink1 = source1.newSinkTokenStream();
TeeSinkTokenFilter.SinkTokenStream sink2 = source1.newSinkTokenStream();
TeeSinkTokenFilter source2 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader2));
source2.addSinkTokenStream(sink1);
source2.addSinkTokenStream(sink2);
TokenStream final1 = new LowerCaseFilter(source1);
TokenStream final2 = source2;
TokenStream final3 = new EntityDetect(sink1);
TokenStream final4 = new URLDetect(sink2);
d.add(new Field("f1", final1));
d.add(new Field("f2", final2));
d.add(new Field("f3", final3));
d.add(new Field("f4", final4));
TeeSinkTokenFilter source1 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader1));
TeeSinkTokenFilter.SinkTokenStream sink1 = source1.newSinkTokenStream();
TeeSinkTokenFilter.SinkTokenStream sink2 = source1.newSinkTokenStream();
TeeSinkTokenFilter source2 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader2));
source2.addSinkTokenStream(sink1);
source2.addSinkTokenStream(sink2);
TokenStream final1 = new LowerCaseFilter(source1);
TokenStream final2 = source2;
TokenStream final3 = new EntityDetect(sink1);
TokenStream final4 = new URLDetect(sink2);
d.add(new Field("f1", final1));
d.add(new Field("f2", final2));
d.add(new Field("f3", final3));
d.add(new Field("f4", final4));
In this example, sink1 and sink2 will both get tokens from both reader1 and reader2 after whitespace tokenizer and now we can further wrap any of these in extra analysis, and more "sources" can be inserted if desired. It is important, that tees are consumed before sinks (in the above example, the field names must be less the sink's field names). If you are not sure, which stream is consumed first, you can simply add another sink and then pass all tokens to the sinks at once using ConsumeAllTokens . This TokenFilter is exhausted after this. In the above example, change the example above to:
View Colorized Copy to Clipboard Print
...
TokenStream final1 = new LowerCaseFilter(source1.newSinkTokenStream());
TokenStream final2 = source2.newSinkTokenStream();
sink1.consumeAllTokens();
sink2.consumeAllTokens();
...
...
TokenStream final1 = new LowerCaseFilter(source1.newSinkTokenStream());
TokenStream final2 = source2.newSinkTokenStream();
sink1.consumeAllTokens();
sink2.consumeAllTokens();
...
In this case, the fields can be added in any order, because the sources are not used anymore and all sinks are ready.

Note, the EntityDetect and URLDetect TokenStreams are for the example and do not currently exist in Lucene.

The TeeSinkTokenFilter SinkFilter type exposes the following members.
Constructors
 | Name | Description
Protected method | TeeSinkTokenFilter SinkFilter | Initializes a new instance of the TeeSinkTokenFilter SinkFilter class
Back to Top
Methods
 | Name | Description
Public method | Accept | Returns true, iff the current state of the passed-in AttributeSource shall be stored in the sink.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Called by Reset . This method does nothing by default and can optionally be overridden.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TeeSinkTokenFilter SinkFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter.SinkFilter Constructor

TeeSinkTokenFilter SinkFilter Constructor Lucene.Net Class Library
Initializes a new instance of the TeeSinkTokenFilter SinkFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SinkFilter()
protected SinkFilter()
Protected Sub New
Protected Sub New
protected:
SinkFilter()
protected:
SinkFilter()
See Also
TeeSinkTokenFilter SinkFilter Class
TeeSinkTokenFilter SinkFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter.SinkFilter Methods

TeeSinkTokenFilter SinkFilter Methods Lucene.Net Class Library
The TeeSinkTokenFilter SinkFilter type exposes the following members.
Methods
 | Name | Description
Public method | Accept | Returns true, iff the current state of the passed-in AttributeSource shall be stored in the sink.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Called by Reset . This method does nothing by default and can optionally be overridden.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TeeSinkTokenFilter SinkFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Accept Method

TeeSinkTokenFilter SinkFilter Accept Method Lucene.Net Class Library
Returns true, iff the current state of the passed-in AttributeSource shall be stored in the sink.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool Accept(
    AttributeSource source
)
public abstract bool Accept(
    AttributeSource source
)
Public MustOverride Function Accept ( _
    source As AttributeSource _
) As Boolean
Public MustOverride Function Accept ( _
    source As AttributeSource _
) As Boolean
public:
virtual bool Accept(
    AttributeSource^ source
) abstract
public:
virtual bool Accept(
    AttributeSource^ source
) abstract
Parameters
source
Type: Lucene.Net.Util AttributeSource
See Also
TeeSinkTokenFilter SinkFilter Class
TeeSinkTokenFilter SinkFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method

TeeSinkTokenFilter SinkFilter Reset Method Lucene.Net Class Library
Called by Reset . This method does nothing by default and can optionally be overridden.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Reset()
public virtual void Reset()
Public Overridable Sub Reset
Public Overridable Sub Reset
public:
virtual void Reset()
public:
virtual void Reset()
See Also
TeeSinkTokenFilter SinkFilter Class
TeeSinkTokenFilter SinkFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter.SinkTokenStream Class

TeeSinkTokenFilter SinkTokenStream Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis TeeSinkTokenFilter SinkTokenStream

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class SinkTokenStream : TokenStream
public sealed class SinkTokenStream : TokenStream
Public NotInheritable Class SinkTokenStream _
    Inherits TokenStream
Public NotInheritable Class SinkTokenStream _
    Inherits TokenStream
public ref class SinkTokenStream sealed : public TokenStream
public ref class SinkTokenStream sealed : public TokenStream
See Also
TeeSinkTokenFilter SinkTokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter.SinkTokenStream Members

TeeSinkTokenFilter SinkTokenStream Members Lucene.Net Class Library

This TokenFilter provides the ability to set aside attribute states that have already been analyzed. This is useful in situations where multiple fields share many common analysis steps and then go their separate ways.

It is also useful for doing things like entity extraction or proper noun analysis as part of the analysis workflow and saving off those tokens for use in another field.
View Colorized Copy to Clipboard Print
TeeSinkTokenFilter source1 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader1));
TeeSinkTokenFilter.SinkTokenStream sink1 = source1.newSinkTokenStream();
TeeSinkTokenFilter.SinkTokenStream sink2 = source1.newSinkTokenStream();
TeeSinkTokenFilter source2 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader2));
source2.addSinkTokenStream(sink1);
source2.addSinkTokenStream(sink2);
TokenStream final1 = new LowerCaseFilter(source1);
TokenStream final2 = source2;
TokenStream final3 = new EntityDetect(sink1);
TokenStream final4 = new URLDetect(sink2);
d.add(new Field("f1", final1));
d.add(new Field("f2", final2));
d.add(new Field("f3", final3));
d.add(new Field("f4", final4));
TeeSinkTokenFilter source1 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader1));
TeeSinkTokenFilter.SinkTokenStream sink1 = source1.newSinkTokenStream();
TeeSinkTokenFilter.SinkTokenStream sink2 = source1.newSinkTokenStream();
TeeSinkTokenFilter source2 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader2));
source2.addSinkTokenStream(sink1);
source2.addSinkTokenStream(sink2);
TokenStream final1 = new LowerCaseFilter(source1);
TokenStream final2 = source2;
TokenStream final3 = new EntityDetect(sink1);
TokenStream final4 = new URLDetect(sink2);
d.add(new Field("f1", final1));
d.add(new Field("f2", final2));
d.add(new Field("f3", final3));
d.add(new Field("f4", final4));
In this example, sink1 and sink2 will both get tokens from both reader1 and reader2 after whitespace tokenizer and now we can further wrap any of these in extra analysis, and more "sources" can be inserted if desired. It is important, that tees are consumed before sinks (in the above example, the field names must be less the sink's field names). If you are not sure, which stream is consumed first, you can simply add another sink and then pass all tokens to the sinks at once using ConsumeAllTokens . This TokenFilter is exhausted after this. In the above example, change the example above to:
View Colorized Copy to Clipboard Print
...
TokenStream final1 = new LowerCaseFilter(source1.newSinkTokenStream());
TokenStream final2 = source2.newSinkTokenStream();
sink1.consumeAllTokens();
sink2.consumeAllTokens();
...
...
TokenStream final1 = new LowerCaseFilter(source1.newSinkTokenStream());
TokenStream final2 = source2.newSinkTokenStream();
sink1.consumeAllTokens();
sink2.consumeAllTokens();
...
In this case, the fields can be added in any order, because the sources are not used anymore and all sinks are ready.

Note, the EntityDetect and URLDetect TokenStreams are for the example and do not currently exist in Lucene.

The TeeSinkTokenFilter SinkTokenStream type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TeeSinkTokenFilter SinkTokenStream and optionally releases the managed resources (Overrides TokenStream Dispose(Boolean).)
Public method | End | (Overrides TokenStream End .)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | (Overrides TokenStream Reset .)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
TeeSinkTokenFilter SinkTokenStream Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter.SinkTokenStream Methods

TeeSinkTokenFilter SinkTokenStream Methods Lucene.Net Class Library
The TeeSinkTokenFilter SinkTokenStream type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Overrides TokenStream Dispose(Boolean).)
Public method | End | (Overrides TokenStream End .)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | (Overrides TokenStream Reset .)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
TeeSinkTokenFilter SinkTokenStream Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

TeeSinkTokenFilter SinkTokenStream Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TeeSinkTokenFilter SinkTokenStream and optionally releases the managed resources (Overrides TokenStream Dispose(Boolean).)
Back to Top
See Also
TeeSinkTokenFilter SinkTokenStream Class
TeeSinkTokenFilter SinkTokenStream Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

TeeSinkTokenFilter SinkTokenStream Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the TeeSinkTokenFilter SinkTokenStream and optionally releases the managed resources

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
TeeSinkTokenFilter SinkTokenStream Class
TeeSinkTokenFilter SinkTokenStream Members
Dispose Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


End Method

TeeSinkTokenFilter SinkTokenStream End Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void End()
public override void End()
Public Overrides Sub End
Public Overrides Sub End
public:
virtual void End() override
public:
virtual void End() override
See Also
TeeSinkTokenFilter SinkTokenStream Class
TeeSinkTokenFilter SinkTokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncrementToken Method

TeeSinkTokenFilter SinkTokenStream IncrementToken Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IncrementToken()
public override bool IncrementToken()
Public Overrides Function IncrementToken As Boolean
Public Overrides Function IncrementToken As Boolean
public:
virtual bool IncrementToken() override
public:
virtual bool IncrementToken() override
See Also
TeeSinkTokenFilter SinkTokenStream Class
TeeSinkTokenFilter SinkTokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method

TeeSinkTokenFilter SinkTokenStream Reset Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Reset()
public override void Reset()
Public Overrides Sub Reset
Public Overrides Sub Reset
public:
virtual void Reset() override
public:
virtual void Reset() override
See Also
TeeSinkTokenFilter SinkTokenStream Class
TeeSinkTokenFilter SinkTokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TeeSinkTokenFilter.SinkTokenStream Properties

TeeSinkTokenFilter SinkTokenStream Properties Lucene.Net Class Library
The TeeSinkTokenFilter SinkTokenStream type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
TeeSinkTokenFilter SinkTokenStream Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Class

Token Class Lucene.Net Class Library
A Token is an occurrence of a term from the text of a field. It consists of a term's text, the start and end offset of the term in the text of the field, and a type string.

The start and end offsets permit applications to re-associate a token with its source text, e.g., to display highlighted query terms in a document browser, or to show matching text fragments in a KWIC display, etc.

The type is a string, assigned by a lexical analyzer (a.k.a. tokenizer), naming the lexical or syntactic class that the token belongs to. For example an end of sentence marker token might be implemented with type "eos". The default token type is "word".

A Token can optionally have metadata (a.k.a. Payload) in the form of a variable length byte array. Use PayloadLength and GetPayload( Byte , Int32) to retrieve the payloads from the index.

NOTE: As of 2.9, Token implements all IAttribute interfaces that are part of core Lucene and can be found in the Lucene.Net.Analysis.Tokenattributes namespace. Even though it is not necessary to use Token anymore, with the new TokenStream API it can be used as convenience class that implements all IAttributes, which is especially useful to easily switch from the old to the new TokenStream API.

Tokenizers and TokenFilters should try to re-use a Token instance when possible for best performance, by implementing the IncrementToken API. Failing that, to create a new Token you should first use one of the constructors that starts with null text. To load the token from a char[] use SetTermBuffer( Char , Int32, Int32). To load from a String use SetTermBuffer(String) or SetTermBuffer(String, Int32, Int32). Alternatively you can get the Token's termBuffer by calling either TermBuffer , if you know that your text is shorter than the capacity of the termBuffer or ResizeTermBuffer(Int32), if there is any possibility that you may need to grow the buffer. Fill in the characters of your term into this buffer, with Online ToCharArray(Int32, Int32) if loading from a string, or with Online Copy(Array, Int64, Array, Int64, Int64), and finally call SetTermLength(Int32) to set the length of the term text. See Online LUCENE-969 for details.

Typical Token reuse patterns:
  • Copying text from a string (type is reset to DEFAULT_TYPE if not specified):
    View Colorized Copy to Clipboard Print
    return reusableToken.reinit(string, startOffset, endOffset[, type]);
    return reusableToken.reinit(string, startOffset, endOffset[, type]);
  • Copying some text from a string (type is reset to DEFAULT_TYPE if not specified):
    View Colorized Copy to Clipboard Print
    return reusableToken.reinit(string, 0, string.length(), startOffset, endOffset[, type]);
    return reusableToken.reinit(string, 0, string.length(), startOffset, endOffset[, type]);
  • Copying text from char[] buffer (type is reset to DEFAULT_TYPE if not specified):
    View Colorized Copy to Clipboard Print
    return reusableToken.reinit(buffer, 0, buffer.length, startOffset, endOffset[, type]);
    return reusableToken.reinit(buffer, 0, buffer.length, startOffset, endOffset[, type]);
  • Copying some text from a char[] buffer (type is reset to DEFAULT_TYPE if not specified):
    View Colorized Copy to Clipboard Print
    return reusableToken.reinit(buffer, start, end - start, startOffset, endOffset[, type]);
    return reusableToken.reinit(buffer, start, end - start, startOffset, endOffset[, type]);
  • Copying from one one Token to another (type is reset to DEFAULT_TYPE if not specified):
    View Colorized Copy to Clipboard Print
    return reusableToken.reinit(source.termBuffer(), 0, source.termLength(), source.startOffset(), source.endOffset()[, source.type()]);
    return reusableToken.reinit(source.termBuffer(), 0, source.termLength(), source.startOffset(), source.endOffset()[, source.type()]);
A few things to note:
  • clear() initializes all of the fields to default values. This was changed in contrast to Lucene 2.4, but should affect no one.
  • Because TokenStreams can be chained, one cannot assume that the Token's current type is correct.
  • The startOffset and endOffset represent the start and offset in the source text, so be careful in adjusting them.
  • When caching a reusable token, clone it. When injecting a cached token into a stream that can be reset, clone it again.

Inheritance Hierarchy
Online System Object
Lucene.Net.Util Attribute
Lucene.Net.Analysis Token

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class Token : Attribute, ITermAttribute,
    ITypeAttribute, IPositionIncrementAttribute, IFlagsAttribute, IOffsetAttribute, IPayloadAttribute,
    IAttribute
[SerializableAttribute]
public class Token : Attribute, ITermAttribute,
    ITypeAttribute, IPositionIncrementAttribute, IFlagsAttribute, IOffsetAttribute, IPayloadAttribute,
    IAttribute
<SerializableAttribute> _
Public Class Token _
    Inherits Attribute _
    Implements ITermAttribute, ITypeAttribute, IPositionIncrementAttribute, IFlagsAttribute,  _
    IOffsetAttribute, IPayloadAttribute, IAttribute
<SerializableAttribute> _
Public Class Token _
    Inherits Attribute _
    Implements ITermAttribute, ITypeAttribute, IPositionIncrementAttribute, IFlagsAttribute,  _
    IOffsetAttribute, IPayloadAttribute, IAttribute
[SerializableAttribute]
public ref class Token : public Attribute,
    ITermAttribute, ITypeAttribute, IPositionIncrementAttribute, IFlagsAttribute, IOffsetAttribute,
    IPayloadAttribute, IAttribute
[SerializableAttribute]
public ref class Token : public Attribute,
    ITermAttribute, ITypeAttribute, IPositionIncrementAttribute, IFlagsAttribute, IOffsetAttribute,
    IPayloadAttribute, IAttribute
See Also
Token Members
Lucene.Net.Analysis Namespace
Lucene.Net.Index Payload
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Members

Token Members Lucene.Net Class Library

The Token type exposes the following members.
Constructors
 | Name | Description
Public method | Token | Constructs a Token will null text.
Public method | Token(Int32, Int32) | Constructs a Token with null text and start & end offsets.
Public method | Token(Int32, Int32, Int32) | Constructs a Token with null text and start & end offsets plus flags. NOTE: flags is EXPERIMENTAL.
Public method | Token(Int32, Int32, String) | Constructs a Token with null text and start & end offsets plus the Token type.
Public method | Token(String, Int32, Int32) | Constructs a Token with the given term text, and start & end offsets. The type defaults to "word." NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.
Public method | Token(String, Int32, Int32, Int32) | Constructs a Token with the given text, start and end offsets, & type. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.
Public method | Token(String, Int32, Int32, String) | Constructs a Token with the given text, start and end offsets, & type. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.
Public method | Token( Char , Int32, Int32, Int32, Int32) | Constructs a Token with the given term buffer (offset & length), start and end offsets
Back to Top
Methods
 | Name | Description
Public method | Clear | Resets the term text, payload, flags, and positionIncrement, startOffset, endOffset and token type to default. (Overrides Attribute Clear .)
Public method | Clone | (Overrides Attribute Clone .)
Public method | Clone( Char , Int32, Int32, Int32, Int32) | Makes a clone, but replaces the term buffer & start/end offset in the process. This is more efficient than doing a full clone (and then calling setTermBuffer) because it saves a wasted copy of the old termBuffer.
Public method | CopyTo | (Overrides Attribute CopyTo(Attribute).)
Public method | Equals | (Overrides Attribute Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Attribute GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reinit(Token) | Copy the prototype token's fields into this one. Note: Payloads are shared.
Public method | Reinit(Token, String) | Copy the prototype token's fields into this one, with a different term. Note: Payloads are shared.
Public method | Reinit(String, Int32, Int32) | Shorthand for calling Clear , SetTermBuffer(String), StartOffset, EndOffset Type on Token.DEFAULT_TYPE
Public method | Reinit(String, Int32, Int32, String) | Shorthand for calling Clear , SetTermBuffer(String), StartOffset, EndOffset Type
Public method | Reinit(Token, Char , Int32, Int32) | Copy the prototype token's fields into this one, with a different term. Note: Payloads are shared.
Public method | Reinit( Char , Int32, Int32, Int32, Int32) | Shorthand for calling Clear , SetTermBuffer( Char , Int32, Int32), StartOffset, EndOffset Type on Token.DEFAULT_TYPE
Public method | Reinit(String, Int32, Int32, Int32, Int32) | Shorthand for calling Clear , SetTermBuffer(String, Int32, Int32), StartOffset, EndOffset Type on Token.DEFAULT_TYPE
Public method | Reinit( Char , Int32, Int32, Int32, Int32, String) | Shorthand for calling Clear , SetTermBuffer( Char , Int32, Int32), StartOffset, EndOffset, Type
Public method | Reinit(String, Int32, Int32, Int32, Int32, String) | Shorthand for calling Clear , SetTermBuffer(String, Int32, Int32), StartOffset, EndOffset Type
Public method | ResizeTermBuffer | Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use SetTermBuffer( Char , Int32, Int32), SetTermBuffer(String), or SetTermBuffer(String, Int32, Int32) to optimally combine the resize with the setting of the termBuffer.
Public method | SetOffset | Set the starting and ending offset. See StartOffset() and EndOffset()
Public method | SetTermBuffer(String) | Copies the contents of buffer into the termBuffer array.
Public method | SetTermBuffer( Char , Int32, Int32) | Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method | SetTermBuffer(String, Int32, Int32) | Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.
Public method | SetTermLength | Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use ResizeTermBuffer(Int32) first.
Public method | TermBuffer | Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use ResizeTermBuffer(Int32) to increase it. After altering the buffer be sure to call SetTermLength(Int32) to record the number of valid characters that were placed into the termBuffer.
Public method | TermLength | Return number of valid characters (length of the term) in the termBuffer array.
Public method | ToString | (Overrides Attribute ToString .)
Back to Top
Fields
Name | Description
DEFAULT_TYPE |
TOKEN_ATTRIBUTE_FACTORY | Convenience factory that returns Token as implementation for the basic attributes and return the default impl (with "Impl" appended) for all other attributes. @since 3.0
Back to Top
Properties
 | Name | Description
Public property | EndOffset | Gets or sets this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).
Public property | Flags | EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long. Get the bitset for any bits that have been set. This is completely distinct from Type, although they do share similar purposes. The flags can be used to encode information about the token for use by other TokenFilters.
Public property | Payload | Returns this Token's payload.
Public property | PositionIncrement | Set the position increment. This determines the position of this token relative to the previous Token in a TokenStream, used in phrase searching. The default value is one. Some common uses for this are:Set it to zero to put multiple terms in the same position. This is useful if, e.g., a word has multiple stems. Searches for phrases including either stem will match. In this case, all but the first stem's increment should be set to zero: the increment of the first instance should be one. Repeating a token with an increment of zero can also be used to boost the scores of matches on that token.Set it to values greater than one to inhibit exact phrase matches. If, for example, one does not want phrases to match across removed stop words, then one could build a stop word filter that removes stop words and also sets the increment to the number of stop words removed before each non-stop word. Then exact phrase queries will only match when the terms occur with no intervening stop words.
Public property | StartOffset | Gets or sets this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to TermLength , as the term text may have been altered by a stemmer or some other filter.
Public property | Term | Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use TermBuffer and TermLength directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())
Public property | Type | Returns this Token's lexical type. Defaults to "word".
Back to Top
See Also
Token Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Constructor

Token Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Token | Constructs a Token will null text.
Public method | Token(Int32, Int32) | Constructs a Token with null text and start & end offsets.
Public method | Token(Int32, Int32, Int32) | Constructs a Token with null text and start & end offsets plus flags. NOTE: flags is EXPERIMENTAL.
Public method | Token(Int32, Int32, String) | Constructs a Token with null text and start & end offsets plus the Token type.
Public method | Token(String, Int32, Int32) | Constructs a Token with the given term text, and start & end offsets. The type defaults to "word." NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.
Public method | Token(String, Int32, Int32, Int32) | Constructs a Token with the given text, start and end offsets, & type. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.
Public method | Token(String, Int32, Int32, String) | Constructs a Token with the given text, start and end offsets, & type. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.
Public method | Token( Char , Int32, Int32, Int32, Int32) | Constructs a Token with the given term buffer (offset & length), start and end offsets
Back to Top
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Constructor

Token Constructor Lucene.Net Class Library
Constructs a Token will null text.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token()
public Token()
Public Sub New
Public Sub New
public:
Token()
public:
Token()
See Also
Token Class
Token Members
Token Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Constructor (Int32, Int32)

Token Constructor (Int32, Int32) Lucene.Net Class Library
Constructs a Token with null text and start & end offsets.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token(
    int start,
    int end
)
public Token(
    int start,
    int end
)
Public Sub New ( _
    start As Integer, _
    end As Integer _
)
Public Sub New ( _
    start As Integer, _
    end As Integer _
)
public:
Token(
    int start,
    int end
)
public:
Token(
    int start,
    int end
)
Parameters
start
Type:   Online System Int32
start offset in the source text
end
Type:   Online System Int32
end offset in the source text
See Also
Token Class
Token Members
Token Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Constructor (Int32, Int32, Int32)

Token Constructor (Int32, Int32, Int32) Lucene.Net Class Library
Constructs a Token with null text and start & end offsets plus flags. NOTE: flags is EXPERIMENTAL.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token(
    int start,
    int end,
    int flags
)
public Token(
    int start,
    int end,
    int flags
)
Public Sub New ( _
    start As Integer, _
    end As Integer, _
    flags As Integer _
)
Public Sub New ( _
    start As Integer, _
    end As Integer, _
    flags As Integer _
)
public:
Token(
    int start,
    int end,
    int flags
)
public:
Token(
    int start,
    int end,
    int flags
)
Parameters
start
Type:   Online System Int32
start offset in the source text
end
Type:   Online System Int32
end offset in the source text
flags
Type:   Online System Int32
The bits to set for this token
See Also
Token Class
Token Members
Token Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Constructor (Int32, Int32, String)

Token Constructor (Int32, Int32, String) Lucene.Net Class Library
Constructs a Token with null text and start & end offsets plus the Token type.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token(
    int start,
    int end,
    string typ
)
public Token(
    int start,
    int end,
    string typ
)
Public Sub New ( _
    start As Integer, _
    end As Integer, _
    typ As String _
)
Public Sub New ( _
    start As Integer, _
    end As Integer, _
    typ As String _
)
public:
Token(
    int start,
    int end,
    String^ typ
)
public:
Token(
    int start,
    int end,
    String^ typ
)
Parameters
start
Type:   Online System Int32
start offset in the source text
end
Type:   Online System Int32
end offset in the source text
typ
Type:   Online System String
the lexical type of this Token
See Also
Token Class
Token Members
Token Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Constructor (String, Int32, Int32)

Token Constructor (String, Int32, Int32) Lucene.Net Class Library
Constructs a Token with the given term text, and start & end offsets. The type defaults to "word." NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token(
    string text,
    int start,
    int end
)
public Token(
    string text,
    int start,
    int end
)
Public Sub New ( _
    text As String, _
    start As Integer, _
    end As Integer _
)
Public Sub New ( _
    text As String, _
    start As Integer, _
    end As Integer _
)
public:
Token(
    String^ text,
    int start,
    int end
)
public:
Token(
    String^ text,
    int start,
    int end
)
Parameters
text
Type:   Online System String
term text
start
Type:   Online System Int32
start offset
end
Type:   Online System Int32
end offset
See Also
Token Class
Token Members
Token Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Constructor (String, Int32, Int32, Int32)

Token Constructor (String, Int32, Int32, Int32) Lucene.Net Class Library
Constructs a Token with the given text, start and end offsets, & type. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token(
    string text,
    int start,
    int end,
    int flags
)
public Token(
    string text,
    int start,
    int end,
    int flags
)
Public Sub New ( _
    text As String, _
    start As Integer, _
    end As Integer, _
    flags As Integer _
)
Public Sub New ( _
    text As String, _
    start As Integer, _
    end As Integer, _
    flags As Integer _
)
public:
Token(
    String^ text,
    int start,
    int end,
    int flags
)
public:
Token(
    String^ text,
    int start,
    int end,
    int flags
)
Parameters
text
Type:   Online System String
start
Type:   Online System Int32
end
Type:   Online System Int32
flags
Type:   Online System Int32
token type bits
See Also
Token Class
Token Members
Token Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Constructor (String, Int32, Int32, String)

Token Constructor (String, Int32, Int32, String) Lucene.Net Class Library
Constructs a Token with the given text, start and end offsets, & type. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token(
    string text,
    int start,
    int end,
    string typ
)
public Token(
    string text,
    int start,
    int end,
    string typ
)
Public Sub New ( _
    text As String, _
    start As Integer, _
    end As Integer, _
    typ As String _
)
Public Sub New ( _
    text As String, _
    start As Integer, _
    end As Integer, _
    typ As String _
)
public:
Token(
    String^ text,
    int start,
    int end,
    String^ typ
)
public:
Token(
    String^ text,
    int start,
    int end,
    String^ typ
)
Parameters
text
Type:   Online System String
term text
start
Type:   Online System Int32
start offset
end
Type:   Online System Int32
end offset
typ
Type:   Online System String
token type
See Also
Token Class
Token Members
Token Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Constructor (Char[], Int32, Int32, Int32, Int32)

Token Constructor ( Char , Int32, Int32, Int32, Int32) Lucene.Net Class Library
Constructs a Token with the given term buffer (offset & length), start and end offsets

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token(
    char[] startTermBuffer,
    int termBufferOffset,
    int termBufferLength,
    int start,
    int end
)
public Token(
    char[] startTermBuffer,
    int termBufferOffset,
    int termBufferLength,
    int start,
    int end
)
Public Sub New ( _
    startTermBuffer As Char(), _
    termBufferOffset As Integer, _
    termBufferLength As Integer, _
    start As Integer, _
    end As Integer _
)
Public Sub New ( _
    startTermBuffer As Char(), _
    termBufferOffset As Integer, _
    termBufferLength As Integer, _
    start As Integer, _
    end As Integer _
)
public:
Token(
    array<wchar_t>^ startTermBuffer,
    int termBufferOffset,
    int termBufferLength,
    int start,
    int end
)
public:
Token(
    array<wchar_t>^ startTermBuffer,
    int termBufferOffset,
    int termBufferLength,
    int start,
    int end
)
Parameters
startTermBuffer
Type:    Online System Char
termBufferOffset
Type:   Online System Int32
termBufferLength
Type:   Online System Int32
start
Type:   Online System Int32
end
Type:   Online System Int32
See Also
Token Class
Token Members
Token Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Fields

Token Fields Lucene.Net Class Library
The Token type exposes the following members.
Fields
Name | Description
DEFAULT_TYPE |
TOKEN_ATTRIBUTE_FACTORY | Convenience factory that returns Token as implementation for the basic attributes and return the default impl (with "Impl" appended) for all other attributes. @since 3.0
Back to Top
See Also
Token Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_TYPE Field

Token DEFAULT_TYPE Field Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_TYPE
public const string DEFAULT_TYPE
Public Const DEFAULT_TYPE As String
Public Const DEFAULT_TYPE As String
public:
literal String^ DEFAULT_TYPE
public:
literal String^ DEFAULT_TYPE
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TOKEN_ATTRIBUTE_FACTORY Field

Token TOKEN_ATTRIBUTE_FACTORY Field Lucene.Net Class Library
Convenience factory that returns Token as implementation for the basic attributes and return the default impl (with "Impl" appended) for all other attributes. @since 3.0

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static AttributeSource..::..AttributeFactory TOKEN_ATTRIBUTE_FACTORY
public static AttributeSource..::..AttributeFactory TOKEN_ATTRIBUTE_FACTORY
Public Shared TOKEN_ATTRIBUTE_FACTORY As AttributeSource..::..AttributeFactory
Public Shared TOKEN_ATTRIBUTE_FACTORY As AttributeSource..::..AttributeFactory
public:
static AttributeSource..::..AttributeFactory^ TOKEN_ATTRIBUTE_FACTORY
public:
static AttributeSource..::..AttributeFactory^ TOKEN_ATTRIBUTE_FACTORY
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Methods

Token Methods Lucene.Net Class Library
The Token type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Resets the term text, payload, flags, and positionIncrement, startOffset, endOffset and token type to default. (Overrides Attribute Clear .)
Public method | Clone | (Overrides Attribute Clone .)
Public method | Clone( Char , Int32, Int32, Int32, Int32) | Makes a clone, but replaces the term buffer & start/end offset in the process. This is more efficient than doing a full clone (and then calling setTermBuffer) because it saves a wasted copy of the old termBuffer.
Public method | CopyTo | (Overrides Attribute CopyTo(Attribute).)
Public method | Equals | (Overrides Attribute Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Attribute GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reinit(Token) | Copy the prototype token's fields into this one. Note: Payloads are shared.
Public method | Reinit(Token, String) | Copy the prototype token's fields into this one, with a different term. Note: Payloads are shared.
Public method | Reinit(String, Int32, Int32) | Shorthand for calling Clear , SetTermBuffer(String), StartOffset, EndOffset Type on Token.DEFAULT_TYPE
Public method | Reinit(String, Int32, Int32, String) | Shorthand for calling Clear , SetTermBuffer(String), StartOffset, EndOffset Type
Public method | Reinit(Token, Char , Int32, Int32) | Copy the prototype token's fields into this one, with a different term. Note: Payloads are shared.
Public method | Reinit( Char , Int32, Int32, Int32, Int32) | Shorthand for calling Clear , SetTermBuffer( Char , Int32, Int32), StartOffset, EndOffset Type on Token.DEFAULT_TYPE
Public method | Reinit(String, Int32, Int32, Int32, Int32) | Shorthand for calling Clear , SetTermBuffer(String, Int32, Int32), StartOffset, EndOffset Type on Token.DEFAULT_TYPE
Public method | Reinit( Char , Int32, Int32, Int32, Int32, String) | Shorthand for calling Clear , SetTermBuffer( Char , Int32, Int32), StartOffset, EndOffset, Type
Public method | Reinit(String, Int32, Int32, Int32, Int32, String) | Shorthand for calling Clear , SetTermBuffer(String, Int32, Int32), StartOffset, EndOffset Type
Public method | ResizeTermBuffer | Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use SetTermBuffer( Char , Int32, Int32), SetTermBuffer(String), or SetTermBuffer(String, Int32, Int32) to optimally combine the resize with the setting of the termBuffer.
Public method | SetOffset | Set the starting and ending offset. See StartOffset() and EndOffset()
Public method | SetTermBuffer(String) | Copies the contents of buffer into the termBuffer array.
Public method | SetTermBuffer( Char , Int32, Int32) | Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method | SetTermBuffer(String, Int32, Int32) | Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.
Public method | SetTermLength | Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use ResizeTermBuffer(Int32) first.
Public method | TermBuffer | Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use ResizeTermBuffer(Int32) to increase it. After altering the buffer be sure to call SetTermLength(Int32) to record the number of valid characters that were placed into the termBuffer.
Public method | TermLength | Return number of valid characters (length of the term) in the termBuffer array.
Public method | ToString | (Overrides Attribute ToString .)
Back to Top
See Also
Token Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method

Token Clear Method Lucene.Net Class Library
Resets the term text, payload, flags, and positionIncrement, startOffset, endOffset and token type to default.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Clear()
public override void Clear()
Public Overrides Sub Clear
Public Overrides Sub Clear
public:
virtual void Clear() override
public:
virtual void Clear() override
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

Token Clone Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Clone | (Overrides Attribute Clone .)
Public method | Clone( Char , Int32, Int32, Int32, Int32) | Makes a clone, but replaces the term buffer & start/end offset in the process. This is more efficient than doing a full clone (and then calling setTermBuffer) because it saves a wasted copy of the old termBuffer.
Back to Top
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

Token Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
See Also
Token Class
Token Members
Clone Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method (Char[], Int32, Int32, Int32, Int32)

Token Clone Method ( Char , Int32, Int32, Int32, Int32) Lucene.Net Class Library
Makes a clone, but replaces the term buffer & start/end offset in the process. This is more efficient than doing a full clone (and then calling setTermBuffer) because it saves a wasted copy of the old termBuffer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Token Clone(
    char[] newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)
public virtual Token Clone(
    char[] newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)
Public Overridable Function Clone ( _
    newTermBuffer As Char(), _
    newTermOffset As Integer, _
    newTermLength As Integer, _
    newStartOffset As Integer, _
    newEndOffset As Integer _
) As Token
Public Overridable Function Clone ( _
    newTermBuffer As Char(), _
    newTermOffset As Integer, _
    newTermLength As Integer, _
    newStartOffset As Integer, _
    newEndOffset As Integer _
) As Token
public:
virtual Token^ Clone(
    array<wchar_t>^ newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)
public:
virtual Token^ Clone(
    array<wchar_t>^ newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)
Parameters
newTermBuffer
Type:    Online System Char
newTermOffset
Type:   Online System Int32
newTermLength
Type:   Online System Int32
newStartOffset
Type:   Online System Int32
newEndOffset
Type:   Online System Int32
See Also
Token Class
Token Members
Clone Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CopyTo Method

Token CopyTo Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void CopyTo(
    Attribute target
)
public override void CopyTo(
    Attribute target
)
Public Overrides Sub CopyTo ( _
    target As Attribute _
)
Public Overrides Sub CopyTo ( _
    target As Attribute _
)
public:
virtual void CopyTo(
    Attribute^ target
) override
public:
virtual void CopyTo(
    Attribute^ target
) override
Parameters
target
Type: Lucene.Net.Util Attribute
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

Token Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

Token GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reinit Method

Token Reinit Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Reinit(Token) | Copy the prototype token's fields into this one. Note: Payloads are shared.
Public method | Reinit(Token, String) | Copy the prototype token's fields into this one, with a different term. Note: Payloads are shared.
Public method | Reinit(String, Int32, Int32) | Shorthand for calling Clear , SetTermBuffer(String), StartOffset, EndOffset Type on Token.DEFAULT_TYPE
Public method | Reinit(String, Int32, Int32, String) | Shorthand for calling Clear , SetTermBuffer(String), StartOffset, EndOffset Type
Public method | Reinit(Token, Char , Int32, Int32) | Copy the prototype token's fields into this one, with a different term. Note: Payloads are shared.
Public method | Reinit( Char , Int32, Int32, Int32, Int32) | Shorthand for calling Clear , SetTermBuffer( Char , Int32, Int32), StartOffset, EndOffset Type on Token.DEFAULT_TYPE
Public method | Reinit(String, Int32, Int32, Int32, Int32) | Shorthand for calling Clear , SetTermBuffer(String, Int32, Int32), StartOffset, EndOffset Type on Token.DEFAULT_TYPE
Public method | Reinit( Char , Int32, Int32, Int32, Int32, String) | Shorthand for calling Clear , SetTermBuffer( Char , Int32, Int32), StartOffset, EndOffset, Type
Public method | Reinit(String, Int32, Int32, Int32, Int32, String) | Shorthand for calling Clear , SetTermBuffer(String, Int32, Int32), StartOffset, EndOffset Type
Back to Top
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reinit Method (Token)

Token Reinit Method (Token) Lucene.Net Class Library
Copy the prototype token's fields into this one. Note: Payloads are shared.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Reinit(
    Token prototype
)
public virtual void Reinit(
    Token prototype
)
Public Overridable Sub Reinit ( _
    prototype As Token _
)
Public Overridable Sub Reinit ( _
    prototype As Token _
)
public:
virtual void Reinit(
    Token^ prototype
)
public:
virtual void Reinit(
    Token^ prototype
)
Parameters
prototype
Type: Lucene.Net.Analysis Token
See Also
Token Class
Token Members
Reinit Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reinit Method (Token, String)

Token Reinit Method (Token, String) Lucene.Net Class Library
Copy the prototype token's fields into this one, with a different term. Note: Payloads are shared.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Reinit(
    Token prototype,
    string newTerm
)
public virtual void Reinit(
    Token prototype,
    string newTerm
)
Public Overridable Sub Reinit ( _
    prototype As Token, _
    newTerm As String _
)
Public Overridable Sub Reinit ( _
    prototype As Token, _
    newTerm As String _
)
public:
virtual void Reinit(
    Token^ prototype,
    String^ newTerm
)
public:
virtual void Reinit(
    Token^ prototype,
    String^ newTerm
)
Parameters
prototype
Type: Lucene.Net.Analysis Token
newTerm
Type:   Online System String
See Also
Token Class
Token Members
Reinit Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reinit Method (String, Int32, Int32)

Token Reinit Method (String, Int32, Int32) Lucene.Net Class Library
Shorthand for calling Clear , SetTermBuffer(String), StartOffset, EndOffset Type on Token.DEFAULT_TYPE

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Token Reinit(
    string newTerm,
    int newStartOffset,
    int newEndOffset
)
public virtual Token Reinit(
    string newTerm,
    int newStartOffset,
    int newEndOffset
)
Public Overridable Function Reinit ( _
    newTerm As String, _
    newStartOffset As Integer, _
    newEndOffset As Integer _
) As Token
Public Overridable Function Reinit ( _
    newTerm As String, _
    newStartOffset As Integer, _
    newEndOffset As Integer _
) As Token
public:
virtual Token^ Reinit(
    String^ newTerm,
    int newStartOffset,
    int newEndOffset
)
public:
virtual Token^ Reinit(
    String^ newTerm,
    int newStartOffset,
    int newEndOffset
)
Parameters
newTerm
Type:   Online System String
newStartOffset
Type:   Online System Int32
newEndOffset
Type:   Online System Int32
Return Value
 this Token instance

See Also
Token Class
Token Members
Reinit Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reinit Method (String, Int32, Int32, String)

Token Reinit Method (String, Int32, Int32, String) Lucene.Net Class Library
Shorthand for calling Clear , SetTermBuffer(String), StartOffset, EndOffset Type

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Token Reinit(
    string newTerm,
    int newStartOffset,
    int newEndOffset,
    string newType
)
public virtual Token Reinit(
    string newTerm,
    int newStartOffset,
    int newEndOffset,
    string newType
)
Public Overridable Function Reinit ( _
    newTerm As String, _
    newStartOffset As Integer, _
    newEndOffset As Integer, _
    newType As String _
) As Token
Public Overridable Function Reinit ( _
    newTerm As String, _
    newStartOffset As Integer, _
    newEndOffset As Integer, _
    newType As String _
) As Token
public:
virtual Token^ Reinit(
    String^ newTerm,
    int newStartOffset,
    int newEndOffset,
    String^ newType
)
public:
virtual Token^ Reinit(
    String^ newTerm,
    int newStartOffset,
    int newEndOffset,
    String^ newType
)
Parameters
newTerm
Type:   Online System String
newStartOffset
Type:   Online System Int32
newEndOffset
Type:   Online System Int32
newType
Type:   Online System String
Return Value
 this Token instance

See Also
Token Class
Token Members
Reinit Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reinit Method (Token, Char[], Int32, Int32)

Token Reinit Method (Token, Char , Int32, Int32) Lucene.Net Class Library
Copy the prototype token's fields into this one, with a different term. Note: Payloads are shared.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Reinit(
    Token prototype,
    char[] newTermBuffer,
    int offset,
    int length
)
public virtual void Reinit(
    Token prototype,
    char[] newTermBuffer,
    int offset,
    int length
)
Public Overridable Sub Reinit ( _
    prototype As Token, _
    newTermBuffer As Char(), _
    offset As Integer, _
    length As Integer _
)
Public Overridable Sub Reinit ( _
    prototype As Token, _
    newTermBuffer As Char(), _
    offset As Integer, _
    length As Integer _
)
public:
virtual void Reinit(
    Token^ prototype,
    array<wchar_t>^ newTermBuffer,
    int offset,
    int length
)
public:
virtual void Reinit(
    Token^ prototype,
    array<wchar_t>^ newTermBuffer,
    int offset,
    int length
)
Parameters
prototype
Type: Lucene.Net.Analysis Token
newTermBuffer
Type:    Online System Char
offset
Type:   Online System Int32
length
Type:   Online System Int32
See Also
Token Class
Token Members
Reinit Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reinit Method (Char[], Int32, Int32, Int32, Int32)

Token Reinit Method ( Char , Int32, Int32, Int32, Int32) Lucene.Net Class Library
Shorthand for calling Clear , SetTermBuffer( Char , Int32, Int32), StartOffset, EndOffset Type on Token.DEFAULT_TYPE

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Token Reinit(
    char[] newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)
public virtual Token Reinit(
    char[] newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)
Public Overridable Function Reinit ( _
    newTermBuffer As Char(), _
    newTermOffset As Integer, _
    newTermLength As Integer, _
    newStartOffset As Integer, _
    newEndOffset As Integer _
) As Token
Public Overridable Function Reinit ( _
    newTermBuffer As Char(), _
    newTermOffset As Integer, _
    newTermLength As Integer, _
    newStartOffset As Integer, _
    newEndOffset As Integer _
) As Token
public:
virtual Token^ Reinit(
    array<wchar_t>^ newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)
public:
virtual Token^ Reinit(
    array<wchar_t>^ newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)
Parameters
newTermBuffer
Type:    Online System Char
newTermOffset
Type:   Online System Int32
newTermLength
Type:   Online System Int32
newStartOffset
Type:   Online System Int32
newEndOffset
Type:   Online System Int32
Return Value
 this Token instance

See Also
Token Class
Token Members
Reinit Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reinit Method (String, Int32, Int32, Int32, Int32)

Token Reinit Method (String, Int32, Int32, Int32, Int32) Lucene.Net Class Library
Shorthand for calling Clear , SetTermBuffer(String, Int32, Int32), StartOffset, EndOffset Type on Token.DEFAULT_TYPE

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Token Reinit(
    string newTerm,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)
public virtual Token Reinit(
    string newTerm,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)
Public Overridable Function Reinit ( _
    newTerm As String, _
    newTermOffset As Integer, _
    newTermLength As Integer, _
    newStartOffset As Integer, _
    newEndOffset As Integer _
) As Token
Public Overridable Function Reinit ( _
    newTerm As String, _
    newTermOffset As Integer, _
    newTermLength As Integer, _
    newStartOffset As Integer, _
    newEndOffset As Integer _
) As Token
public:
virtual Token^ Reinit(
    String^ newTerm,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)
public:
virtual Token^ Reinit(
    String^ newTerm,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)
Parameters
newTerm
Type:   Online System String
newTermOffset
Type:   Online System Int32
newTermLength
Type:   Online System Int32
newStartOffset
Type:   Online System Int32
newEndOffset
Type:   Online System Int32
Return Value
 this Token instance

See Also
Token Class
Token Members
Reinit Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reinit Method (Char[], Int32, Int32, Int32, Int32, String)

Token Reinit Method ( Char , Int32, Int32, Int32, Int32, String) Lucene.Net Class Library
Shorthand for calling Clear , SetTermBuffer( Char , Int32, Int32), StartOffset, EndOffset, Type

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Token Reinit(
    char[] newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset,
    string newType
)
public virtual Token Reinit(
    char[] newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset,
    string newType
)
Public Overridable Function Reinit ( _
    newTermBuffer As Char(), _
    newTermOffset As Integer, _
    newTermLength As Integer, _
    newStartOffset As Integer, _
    newEndOffset As Integer, _
    newType As String _
) As Token
Public Overridable Function Reinit ( _
    newTermBuffer As Char(), _
    newTermOffset As Integer, _
    newTermLength As Integer, _
    newStartOffset As Integer, _
    newEndOffset As Integer, _
    newType As String _
) As Token
public:
virtual Token^ Reinit(
    array<wchar_t>^ newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset,
    String^ newType
)
public:
virtual Token^ Reinit(
    array<wchar_t>^ newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset,
    String^ newType
)
Parameters
newTermBuffer
Type:    Online System Char
newTermOffset
Type:   Online System Int32
newTermLength
Type:   Online System Int32
newStartOffset
Type:   Online System Int32
newEndOffset
Type:   Online System Int32
newType
Type:   Online System String
Return Value
 this Token instance

See Also
Token Class
Token Members
Reinit Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reinit Method (String, Int32, Int32, Int32, Int32, String)

Token Reinit Method (String, Int32, Int32, Int32, Int32, String) Lucene.Net Class Library
Shorthand for calling Clear , SetTermBuffer(String, Int32, Int32), StartOffset, EndOffset Type

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Token Reinit(
    string newTerm,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset,
    string newType
)
public virtual Token Reinit(
    string newTerm,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset,
    string newType
)
Public Overridable Function Reinit ( _
    newTerm As String, _
    newTermOffset As Integer, _
    newTermLength As Integer, _
    newStartOffset As Integer, _
    newEndOffset As Integer, _
    newType As String _
) As Token
Public Overridable Function Reinit ( _
    newTerm As String, _
    newTermOffset As Integer, _
    newTermLength As Integer, _
    newStartOffset As Integer, _
    newEndOffset As Integer, _
    newType As String _
) As Token
public:
virtual Token^ Reinit(
    String^ newTerm,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset,
    String^ newType
)
public:
virtual Token^ Reinit(
    String^ newTerm,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset,
    String^ newType
)
Parameters
newTerm
Type:   Online System String
newTermOffset
Type:   Online System Int32
newTermLength
Type:   Online System Int32
newStartOffset
Type:   Online System Int32
newEndOffset
Type:   Online System Int32
newType
Type:   Online System String
Return Value
 this Token instance

See Also
Token Class
Token Members
Reinit Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ResizeTermBuffer Method

Token ResizeTermBuffer Method Lucene.Net Class Library
Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use SetTermBuffer( Char , Int32, Int32), SetTermBuffer(String), or SetTermBuffer(String, Int32, Int32) to optimally combine the resize with the setting of the termBuffer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual char[] ResizeTermBuffer(
    int newSize
)
public virtual char[] ResizeTermBuffer(
    int newSize
)
Public Overridable Function ResizeTermBuffer ( _
    newSize As Integer _
) As Char()
Public Overridable Function ResizeTermBuffer ( _
    newSize As Integer _
) As Char()
public:
virtual array<wchar_t>^ ResizeTermBuffer(
    int newSize
)
public:
virtual array<wchar_t>^ ResizeTermBuffer(
    int newSize
)
Parameters
newSize
Type:   Online System Int32
minimum size of the new termBuffer

Return Value
 newly created termBuffer with length >= newSize

Implements
ITermAttribute ResizeTermBuffer(Int32)
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetOffset Method

Token SetOffset Method Lucene.Net Class Library
Set the starting and ending offset. See StartOffset() and EndOffset()

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetOffset(
    int startOffset,
    int endOffset
)
public virtual void SetOffset(
    int startOffset,
    int endOffset
)
Public Overridable Sub SetOffset ( _
    startOffset As Integer, _
    endOffset As Integer _
)
Public Overridable Sub SetOffset ( _
    startOffset As Integer, _
    endOffset As Integer _
)
public:
virtual void SetOffset(
    int startOffset,
    int endOffset
)
public:
virtual void SetOffset(
    int startOffset,
    int endOffset
)
Parameters
startOffset
Type:   Online System Int32
endOffset
Type:   Online System Int32
Implements
IOffsetAttribute SetOffset(Int32, Int32)
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetTermBuffer Method

Token SetTermBuffer Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | SetTermBuffer(String) | Copies the contents of buffer into the termBuffer array.
Public method | SetTermBuffer( Char , Int32, Int32) | Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method | SetTermBuffer(String, Int32, Int32) | Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.
Back to Top
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetTermBuffer Method (String)

Token SetTermBuffer Method (String) Lucene.Net Class Library
Copies the contents of buffer into the termBuffer array.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetTermBuffer(
    string buffer
)
public void SetTermBuffer(
    string buffer
)
Public Sub SetTermBuffer ( _
    buffer As String _
)
Public Sub SetTermBuffer ( _
    buffer As String _
)
public:
virtual void SetTermBuffer(
    String^ buffer
) sealed
public:
virtual void SetTermBuffer(
    String^ buffer
) sealed
Parameters
buffer
Type:   Online System String
the buffer to copy

Implements
ITermAttribute SetTermBuffer(String)
See Also
Token Class
Token Members
SetTermBuffer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetTermBuffer Method (Char[], Int32, Int32)

Token SetTermBuffer Method ( Char , Int32, Int32) Lucene.Net Class Library
Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetTermBuffer(
    char[] buffer,
    int offset,
    int length
)
public void SetTermBuffer(
    char[] buffer,
    int offset,
    int length
)
Public Sub SetTermBuffer ( _
    buffer As Char(), _
    offset As Integer, _
    length As Integer _
)
Public Sub SetTermBuffer ( _
    buffer As Char(), _
    offset As Integer, _
    length As Integer _
)
public:
virtual void SetTermBuffer(
    array<wchar_t>^ buffer,
    int offset,
    int length
) sealed
public:
virtual void SetTermBuffer(
    array<wchar_t>^ buffer,
    int offset,
    int length
) sealed
Parameters
buffer
Type:    Online System Char
the buffer to copy
offset
Type:   Online System Int32
the index in the buffer of the first character to copy
length
Type:   Online System Int32
the number of characters to copy
Implements
ITermAttribute SetTermBuffer( Char , Int32, Int32)
See Also
Token Class
Token Members
SetTermBuffer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetTermBuffer Method (String, Int32, Int32)

Token SetTermBuffer Method (String, Int32, Int32) Lucene.Net Class Library
Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetTermBuffer(
    string buffer,
    int offset,
    int length
)
public void SetTermBuffer(
    string buffer,
    int offset,
    int length
)
Public Sub SetTermBuffer ( _
    buffer As String, _
    offset As Integer, _
    length As Integer _
)
Public Sub SetTermBuffer ( _
    buffer As String, _
    offset As Integer, _
    length As Integer _
)
public:
virtual void SetTermBuffer(
    String^ buffer,
    int offset,
    int length
) sealed
public:
virtual void SetTermBuffer(
    String^ buffer,
    int offset,
    int length
) sealed
Parameters
buffer
Type:   Online System String
the buffer to copy

offset
Type:   Online System Int32
the index in the buffer of the first character to copy

length
Type:   Online System Int32
the number of characters to copy

Implements
ITermAttribute SetTermBuffer(String, Int32, Int32)
See Also
Token Class
Token Members
SetTermBuffer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetTermLength Method

Token SetTermLength Method Lucene.Net Class Library
Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use ResizeTermBuffer(Int32) first.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetTermLength(
    int length
)
public void SetTermLength(
    int length
)
Public Sub SetTermLength ( _
    length As Integer _
)
Public Sub SetTermLength ( _
    length As Integer _
)
public:
virtual void SetTermLength(
    int length
) sealed
public:
virtual void SetTermLength(
    int length
) sealed
Parameters
length
Type:   Online System Int32
the truncated length

Implements
ITermAttribute SetTermLength(Int32)
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermBuffer Method

Token TermBuffer Method Lucene.Net Class Library
Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use ResizeTermBuffer(Int32) to increase it. After altering the buffer be sure to call SetTermLength(Int32) to record the number of valid characters that were placed into the termBuffer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char[] TermBuffer()
public char[] TermBuffer()
Public Function TermBuffer As Char()
Public Function TermBuffer As Char()
public:
virtual array<wchar_t>^ TermBuffer() sealed
public:
virtual array<wchar_t>^ TermBuffer() sealed
Implements
ITermAttribute TermBuffer
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermLength Method

Token TermLength Method Lucene.Net Class Library
Return number of valid characters (length of the term) in the termBuffer array.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int TermLength()
public int TermLength()
Public Function TermLength As Integer
Public Function TermLength As Integer
public:
virtual int TermLength() sealed
public:
virtual int TermLength() sealed
Implements
ITermAttribute TermLength
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

Token ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Properties

Token Properties Lucene.Net Class Library
The Token type exposes the following members.
Properties
 | Name | Description
Public property | EndOffset | Gets or sets this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).
Public property | Flags | EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long. Get the bitset for any bits that have been set. This is completely distinct from Type, although they do share similar purposes. The flags can be used to encode information about the token for use by other TokenFilters.
Public property | Payload | Returns this Token's payload.
Public property | PositionIncrement | Set the position increment. This determines the position of this token relative to the previous Token in a TokenStream, used in phrase searching. The default value is one. Some common uses for this are:Set it to zero to put multiple terms in the same position. This is useful if, e.g., a word has multiple stems. Searches for phrases including either stem will match. In this case, all but the first stem's increment should be set to zero: the increment of the first instance should be one. Repeating a token with an increment of zero can also be used to boost the scores of matches on that token.Set it to values greater than one to inhibit exact phrase matches. If, for example, one does not want phrases to match across removed stop words, then one could build a stop word filter that removes stop words and also sets the increment to the number of stop words removed before each non-stop word. Then exact phrase queries will only match when the terms occur with no intervening stop words.
Public property | StartOffset | Gets or sets this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to TermLength , as the term text may have been altered by a stemmer or some other filter.
Public property | Term | Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use TermBuffer and TermLength directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())
Public property | Type | Returns this Token's lexical type. Defaults to "word".
Back to Top
See Also
Token Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EndOffset Property

Token EndOffset Property Lucene.Net Class Library
Gets or sets this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int EndOffset { get; set; }
public virtual int EndOffset { get; set; }
Public Overridable Property EndOffset As Integer
    Get
    Set
Public Overridable Property EndOffset As Integer
    Get
    Set
public:
virtual property int EndOffset {
    int get ();
    void set (int value);
}
public:
virtual property int EndOffset {
    int get ();
    void set (int value);
}
Implements
IOffsetAttribute EndOffset
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Flags Property

Token Flags Property Lucene.Net Class Library
EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long.

Get the bitset for any bits that have been set. This is completely distinct from Type, although they do share similar purposes. The flags can be used to encode information about the token for use by other TokenFilters.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Flags { get; set; }
public virtual int Flags { get; set; }
Public Overridable Property Flags As Integer
    Get
    Set
Public Overridable Property Flags As Integer
    Get
    Set
public:
virtual property int Flags {
    int get ();
    void set (int value);
}
public:
virtual property int Flags {
    int get ();
    void set (int value);
}
Field Value
 The bits
Implements
IFlagsAttribute Flags
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Payload Property

Token Payload Property Lucene.Net Class Library
Returns this Token's payload.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Payload Payload { get; set; }
public virtual Payload Payload { get; set; }
Public Overridable Property Payload As Payload
    Get
    Set
Public Overridable Property Payload As Payload
    Get
    Set
public:
virtual property Payload^ Payload {
    Payload^ get ();
    void set (Payload^ value);
}
public:
virtual property Payload^ Payload {
    Payload^ get ();
    void set (Payload^ value);
}
Implements
IPayloadAttribute Payload
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionIncrement Property

Token PositionIncrement Property Lucene.Net Class Library
Set the position increment. This determines the position of this token relative to the previous Token in a TokenStream, used in phrase searching.

The default value is one.

Some common uses for this are:Set it to zero to put multiple terms in the same position. This is useful if, e.g., a word has multiple stems. Searches for phrases including either stem will match. In this case, all but the first stem's increment should be set to zero: the increment of the first instance should be one. Repeating a token with an increment of zero can also be used to boost the scores of matches on that token.Set it to values greater than one to inhibit exact phrase matches. If, for example, one does not want phrases to match across removed stop words, then one could build a stop word filter that removes stop words and also sets the increment to the number of stop words removed before each non-stop word. Then exact phrase queries will only match when the terms occur with no intervening stop words.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int PositionIncrement { get; set; }
public virtual int PositionIncrement { get; set; }
Public Overridable Property PositionIncrement As Integer
    Get
    Set
Public Overridable Property PositionIncrement As Integer
    Get
    Set
public:
virtual property int PositionIncrement {
    int get ();
    void set (int value);
}
public:
virtual property int PositionIncrement {
    int get ();
    void set (int value);
}
Field Value
 the distance from the prior term
Implements
IPositionIncrementAttribute PositionIncrement
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Lucene.Net.Index TermPositions
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StartOffset Property

Token StartOffset Property Lucene.Net Class Library
Gets or sets this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to TermLength , as the term text may have been altered by a stemmer or some other filter.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int StartOffset { get; set; }
public virtual int StartOffset { get; set; }
Public Overridable Property StartOffset As Integer
    Get
    Set
Public Overridable Property StartOffset As Integer
    Get
    Set
public:
virtual property int StartOffset {
    int get ();
    void set (int value);
}
public:
virtual property int StartOffset {
    int get ();
    void set (int value);
}
Implements
IOffsetAttribute StartOffset
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Property

Token Term Property Lucene.Net Class Library
Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use TermBuffer and TermLength directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Term { get; }
public string Term { get; }
Public ReadOnly Property Term As String
    Get
Public ReadOnly Property Term As String
    Get
public:
virtual property String^ Term {
    String^ get () sealed;
}
public:
virtual property String^ Term {
    String^ get () sealed;
}
Implements
ITermAttribute Term
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Type Property

Token Type Property Lucene.Net Class Library
Returns this Token's lexical type. Defaults to "word".

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Type { get; set; }
public string Type { get; set; }
Public Property Type As String
    Get
    Set
Public Property Type As String
    Get
    Set
public:
virtual property String^ Type {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Type {
    String^ get () sealed;
    void set (String^ value) sealed;
}
Implements
ITypeAttribute Type
See Also
Token Class
Token Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token.TokenAttributeFactory Class

Token TokenAttributeFactory Class Lucene.Net Class Library
Expert: Creates an AttributeFactory returning {@link Token} as instance for the basic attributes and for all other attributes calls the given delegate factory.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource AttributeFactory
Lucene.Net.Analysis Token TokenAttributeFactory

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TokenAttributeFactory : AttributeSource..::..AttributeFactory
public class TokenAttributeFactory : AttributeSource..::..AttributeFactory
Public Class TokenAttributeFactory _
    Inherits AttributeSource..::..AttributeFactory
Public Class TokenAttributeFactory _
    Inherits AttributeSource..::..AttributeFactory
public ref class TokenAttributeFactory : public AttributeSource..::..AttributeFactory
public ref class TokenAttributeFactory : public AttributeSource..::..AttributeFactory
See Also
Token TokenAttributeFactory Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token.TokenAttributeFactory Members

Token TokenAttributeFactory Members Lucene.Net Class Library

A Token is an occurrence of a term from the text of a field. It consists of a term's text, the start and end offset of the term in the text of the field, and a type string.

The start and end offsets permit applications to re-associate a token with its source text, e.g., to display highlighted query terms in a document browser, or to show matching text fragments in a KWIC display, etc.

The type is a string, assigned by a lexical analyzer (a.k.a. tokenizer), naming the lexical or syntactic class that the token belongs to. For example an end of sentence marker token might be implemented with type "eos". The default token type is "word".

A Token can optionally have metadata (a.k.a. Payload) in the form of a variable length byte array. Use PayloadLength and GetPayload( Byte , Int32) to retrieve the payloads from the index.

NOTE: As of 2.9, Token implements all IAttribute interfaces that are part of core Lucene and can be found in the Lucene.Net.Analysis.Tokenattributes namespace. Even though it is not necessary to use Token anymore, with the new TokenStream API it can be used as convenience class that implements all IAttributes, which is especially useful to easily switch from the old to the new TokenStream API.

Tokenizers and TokenFilters should try to re-use a Token instance when possible for best performance, by implementing the IncrementToken API. Failing that, to create a new Token you should first use one of the constructors that starts with null text. To load the token from a char[] use SetTermBuffer( Char , Int32, Int32). To load from a String use SetTermBuffer(String) or SetTermBuffer(String, Int32, Int32). Alternatively you can get the Token's termBuffer by calling either TermBuffer , if you know that your text is shorter than the capacity of the termBuffer or ResizeTermBuffer(Int32), if there is any possibility that you may need to grow the buffer. Fill in the characters of your term into this buffer, with Online ToCharArray(Int32, Int32) if loading from a string, or with Online Copy(Array, Int64, Array, Int64, Int64), and finally call SetTermLength(Int32) to set the length of the term text. See Online LUCENE-969 for details.

Typical Token reuse patterns:
  • Copying text from a string (type is reset to DEFAULT_TYPE if not specified):
    View Colorized Copy to Clipboard Print
    return reusableToken.reinit(string, startOffset, endOffset[, type]);
    return reusableToken.reinit(string, startOffset, endOffset[, type]);
  • Copying some text from a string (type is reset to DEFAULT_TYPE if not specified):
    View Colorized Copy to Clipboard Print
    return reusableToken.reinit(string, 0, string.length(), startOffset, endOffset[, type]);
    return reusableToken.reinit(string, 0, string.length(), startOffset, endOffset[, type]);
  • Copying text from char[] buffer (type is reset to DEFAULT_TYPE if not specified):
    View Colorized Copy to Clipboard Print
    return reusableToken.reinit(buffer, 0, buffer.length, startOffset, endOffset[, type]);
    return reusableToken.reinit(buffer, 0, buffer.length, startOffset, endOffset[, type]);
  • Copying some text from a char[] buffer (type is reset to DEFAULT_TYPE if not specified):
    View Colorized Copy to Clipboard Print
    return reusableToken.reinit(buffer, start, end - start, startOffset, endOffset[, type]);
    return reusableToken.reinit(buffer, start, end - start, startOffset, endOffset[, type]);
  • Copying from one one Token to another (type is reset to DEFAULT_TYPE if not specified):
    View Colorized Copy to Clipboard Print
    return reusableToken.reinit(source.termBuffer(), 0, source.termLength(), source.startOffset(), source.endOffset()[, source.type()]);
    return reusableToken.reinit(source.termBuffer(), 0, source.termLength(), source.startOffset(), source.endOffset()[, source.type()]);
A few things to note:
  • clear() initializes all of the fields to default values. This was changed in contrast to Lucene 2.4, but should affect no one.
  • Because TokenStreams can be chained, one cannot assume that the Token's current type is correct.
  • The startOffset and endOffset represent the start and offset in the source text, so be careful in adjusting them.
  • When caching a reusable token, clone it. When injecting a cached token into a stream that can be reset, clone it again.

The Token TokenAttributeFactory type exposes the following members.
Constructors
 | Name | Description
Public method | Token TokenAttributeFactory | Expert: Creates an AttributeFactory returning {@link Token} as instance for the basic attributes and for all other attributes calls the given delegate factory.
Back to Top
Methods
 | Name | Description
Public method | CreateAttributeInstance T | (Overrides AttributeSource AttributeFactory CreateAttributeInstance T .)
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Token TokenAttributeFactory Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token.TokenAttributeFactory Constructor

Token TokenAttributeFactory Constructor Lucene.Net Class Library
Expert: Creates an AttributeFactory returning {@link Token} as instance for the basic attributes and for all other attributes calls the given delegate factory.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TokenAttributeFactory(
    AttributeSource..::..AttributeFactory delegateFactory
)
public TokenAttributeFactory(
    AttributeSource..::..AttributeFactory delegateFactory
)
Public Sub New ( _
    delegateFactory As AttributeSource..::..AttributeFactory _
)
Public Sub New ( _
    delegateFactory As AttributeSource..::..AttributeFactory _
)
public:
TokenAttributeFactory(
    AttributeSource..::..AttributeFactory^ delegateFactory
)
public:
TokenAttributeFactory(
    AttributeSource..::..AttributeFactory^ delegateFactory
)
Parameters
delegateFactory
Type: Lucene.Net.Util AttributeSource AttributeFactory
See Also
Token TokenAttributeFactory Class
Token TokenAttributeFactory Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token.TokenAttributeFactory Methods

Token TokenAttributeFactory Methods Lucene.Net Class Library
The Token TokenAttributeFactory type exposes the following members.
Methods
 | Name | Description
Public method | CreateAttributeInstance T | (Overrides AttributeSource AttributeFactory CreateAttributeInstance T .)
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Token TokenAttributeFactory Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateAttributeInstance(T) Method

Token TokenAttributeFactory CreateAttributeInstance T Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Attribute CreateAttributeInstance<T>()
where T : IAttribute
public override Attribute CreateAttributeInstance<T>()
where T : IAttribute
Public Overrides Function CreateAttributeInstance(Of T As IAttribute) As Attribute
Public Overrides Function CreateAttributeInstance(Of T As IAttribute) As Attribute
public:
generic<typename T>
where T : IAttribute
virtual Attribute^ CreateAttributeInstance() override
public:
generic<typename T>
where T : IAttribute
virtual Attribute^ CreateAttributeInstance() override
Type Parameters
T
See Also
Token TokenAttributeFactory Class
Token TokenAttributeFactory Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

Token TokenAttributeFactory Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object other
)
public override bool Equals(
    Object other
)
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ other
) override
public:
virtual bool Equals(
    Object^ other
) override
Parameters
other
Type:   Online System Object
See Also
Token TokenAttributeFactory Class
Token TokenAttributeFactory Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

Token TokenAttributeFactory GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
Token TokenAttributeFactory Class
Token TokenAttributeFactory Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenFilter Class

TokenFilter Class Lucene.Net Class Library
A TokenFilter is a TokenStream whose input is another TokenStream.

This is an abstract class; subclasses must override IncrementToken .
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis TokenFilter
Lucene.Net.Analysis ASCIIFoldingFilter
Lucene.Net.Analysis CachingTokenFilter
Lucene.Net.Analysis ISOLatin1AccentFilter
Lucene.Net.Analysis LengthFilter
Lucene.Net.Analysis LowerCaseFilter
Lucene.Net.Analysis PorterStemFilter
Lucene.Net.Analysis.Standard StandardFilter
Lucene.Net.Analysis StopFilter
Lucene.Net.Analysis TeeSinkTokenFilter

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class TokenFilter : TokenStream
public abstract class TokenFilter : TokenStream
Public MustInherit Class TokenFilter _
    Inherits TokenStream
Public MustInherit Class TokenFilter _
    Inherits TokenStream
public ref class TokenFilter abstract : public TokenStream
public ref class TokenFilter abstract : public TokenStream
See Also
TokenFilter Members
Lucene.Net.Analysis Namespace
Lucene.Net.Analysis TokenStream
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenFilter Members

TokenFilter Members Lucene.Net Class Library

The TokenFilter type exposes the following members.
Constructors
 | Name | Description
Protected method | TokenFilter | Construct a token stream filtering the given input.
Back to Top
Methods
Name | Description
Public method AddAttribute T
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned.
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces.

Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory

(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource))
(Inherited from AttributeSource.)
Public method Close Obsolete.
Releases resources associated with this stream.
(Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method Dispose(Boolean)
Releases the unmanaged resources used by the TokenFilter and optionally releases the managed resources
(Overrides TokenStream Dispose(Boolean).)
Public method End
Performs end-of-stream operations, if any, and calls then end() on the input TokenStream.

NOTE: Be sure to call super.end() first when overriding this method.
(Overrides TokenStream End .)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method GetAttribute T
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method GetAttributeTypesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method HasAttribute T
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute.
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., IndexWriter) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate Attributes with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use CaptureState to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to AddAttribute T and GetAttribute T , references to all Attributes that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in IncrementToken .
(Inherited from TokenStream.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Overrides TokenStream Reset .)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter.
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
TokenFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenFilter Constructor

TokenFilter Constructor Lucene.Net Class Library
Construct a token stream filtering the given input.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TokenFilter(
    TokenStream input
)
protected TokenFilter(
    TokenStream input
)
Protected Sub New ( _
    input As TokenStream _
)
Protected Sub New ( _
    input As TokenStream _
)
protected:
TokenFilter(
    TokenStream^ input
)
protected:
TokenFilter(
    TokenStream^ input
)
Parameters
input
Type: Lucene.Net.Analysis TokenStream
See Also
TokenFilter Class
TokenFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenFilter Fields

TokenFilter Fields Lucene.Net Class Library
The TokenFilter type exposes the following members.
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter.
Back to Top
See Also
TokenFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


input Field

TokenFilter input Field Lucene.Net Class Library
The source of tokens for this filter.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TokenStream input
protected TokenStream input
Protected input As TokenStream
Protected input As TokenStream
protected:
TokenStream^ input
protected:
TokenStream^ input
See Also
TokenFilter Class
TokenFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenFilter Methods

TokenFilter Methods Lucene.Net Class Library
The TokenFilter type exposes the following members.
Methods
Name | Description
Public method AddAttribute T
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned.
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces.

Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory

(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource))
(Inherited from AttributeSource.)
Public method Close Obsolete.
Releases resources associated with this stream.
(Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Overrides TokenStream Dispose(Boolean).)
Public method End
Performs end-of-stream operations, if any, and calls then end() on the input TokenStream.

NOTE: Be sure to call super.end() first when overriding this method.
(Overrides TokenStream End .)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method GetAttribute T
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method GetAttributeTypesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method HasAttribute T
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute.
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., IndexWriter) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate Attributes with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use CaptureState to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to AddAttribute T and GetAttribute T , references to all Attributes that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in IncrementToken .
(Inherited from TokenStream.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Overrides TokenStream Reset .)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
TokenFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

TokenFilter Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TokenFilter and optionally releases the managed resources (Overrides TokenStream Dispose(Boolean).)
Back to Top
See Also
TokenFilter Class
TokenFilter Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

TokenFilter Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the TokenFilter and optionally releases the managed resources

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
TokenFilter Class
TokenFilter Members
Dispose Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


End Method

TokenFilter End Method Lucene.Net Class Library
Performs end-of-stream operations, if any, and calls then end() on the input TokenStream.

NOTE: Be sure to call super.end() first when overriding this method.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void End()
public override void End()
Public Overrides Sub End
Public Overrides Sub End
public:
virtual void End() override
public:
virtual void End() override
See Also
TokenFilter Class
TokenFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method

TokenFilter Reset Method Lucene.Net Class Library
Reset the filter as well as the input TokenStream.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Reset()
public override void Reset()
Public Overrides Sub Reset
Public Overrides Sub Reset
public:
virtual void Reset() override
public:
virtual void Reset() override
See Also
TokenFilter Class
TokenFilter Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenFilter Properties

TokenFilter Properties Lucene.Net Class Library
The TokenFilter type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
TokenFilter Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tokenizer Class

Tokenizer Class Lucene.Net Class Library
A Tokenizer is a TokenStream whose input is a Reader.

This is an abstract class; subclasses must override IncrementToken

NOTE: Subclasses overriding IncrementToken must call ClearAttributes before setting attributes.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis Tokenizer
Lucene.Net.Analysis CharTokenizer
Lucene.Net.Analysis KeywordTokenizer
Lucene.Net.Analysis.Standard StandardTokenizer

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Tokenizer : TokenStream
public abstract class Tokenizer : TokenStream
Public MustInherit Class Tokenizer _
    Inherits TokenStream
Public MustInherit Class Tokenizer _
    Inherits TokenStream
public ref class Tokenizer abstract : public TokenStream
public ref class Tokenizer abstract : public TokenStream
See Also
Tokenizer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tokenizer Members

Tokenizer Members Lucene.Net Class Library

The Tokenizer type exposes the following members.
Constructors
 | Name | Description
Protected method | Tokenizer | Construct a tokenizer with null input.
Protected method | Tokenizer(TextReader) | Construct a token stream processing the given input.
Protected method | Tokenizer(AttributeSource) | Construct a token stream processing the given input using the given AttributeSource.
Protected method | Tokenizer(AttributeSource AttributeFactory) | Construct a tokenizer with null input using the given AttributeFactory.
Protected method | Tokenizer(AttributeSource, TextReader) | Construct a token stream processing the given input using the given AttributeSource.
Protected method | Tokenizer(AttributeSource AttributeFactory, TextReader) | Construct a token stream processing the given input using the given AttributeFactory.
Back to Top
Methods
Name | Description
Public method AddAttribute T
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned.
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces.

Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory

(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource))
(Inherited from AttributeSource.)
Public method Close Obsolete.
Releases resources associated with this stream.
(Inherited from TokenStream.)
Protected method CorrectOffset
Return the corrected offset. If input is a CharStream subclass this method calls CorrectOffset(Int32), else returns currentOff.
Public method | Dispose | (Inherited from TokenStream.)
Protected method Dispose(Boolean)
Releases the unmanaged resources used by the Tokenizer and optionally releases the managed resources
(Overrides TokenStream Dispose(Boolean).)
Public method End
This method is called by the consumer after the last token has been consumed, after IncrementToken returned false (using the new TokenStream API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a WhitespaceTokenizer was used.
(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method GetAttribute T
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method GetAttributeTypesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method HasAttribute T
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute.
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., IndexWriter) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate Attributes with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use CaptureState to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to AddAttribute T and GetAttribute T , references to all Attributes that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in IncrementToken .
(Inherited from TokenStream.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Reset
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ).
(Inherited from TokenStream.)
Public method Reset(TextReader)
Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Fields
 | Name | Description
Protected field | input | The text source for this Tokenizer.
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
Tokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tokenizer Constructor

Tokenizer Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Protected method | Tokenizer | Construct a tokenizer with null input.
Protected method | Tokenizer(TextReader) | Construct a token stream processing the given input.
Protected method | Tokenizer(AttributeSource) | Construct a token stream processing the given input using the given AttributeSource.
Protected method | Tokenizer(AttributeSource AttributeFactory) | Construct a tokenizer with null input using the given AttributeFactory.
Protected method | Tokenizer(AttributeSource, TextReader) | Construct a token stream processing the given input using the given AttributeSource.
Protected method | Tokenizer(AttributeSource AttributeFactory, TextReader) | Construct a token stream processing the given input using the given AttributeFactory.
Back to Top
See Also
Tokenizer Class
Tokenizer Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tokenizer Constructor

Tokenizer Constructor Lucene.Net Class Library
Construct a tokenizer with null input.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Tokenizer()
protected Tokenizer()
Protected Sub New
Protected Sub New
protected:
Tokenizer()
protected:
Tokenizer()
See Also
Tokenizer Class
Tokenizer Members
Tokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tokenizer Constructor (TextReader)

Tokenizer Constructor (TextReader) Lucene.Net Class Library
Construct a token stream processing the given input.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Tokenizer(
    TextReader input
)
protected Tokenizer(
    TextReader input
)
Protected Sub New ( _
    input As TextReader _
)
Protected Sub New ( _
    input As TextReader _
)
protected:
Tokenizer(
    TextReader^ input
)
protected:
Tokenizer(
    TextReader^ input
)
Parameters
input
Type:   Online System.IO TextReader
See Also
Tokenizer Class
Tokenizer Members
Tokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tokenizer Constructor (AttributeSource)

Tokenizer Constructor (AttributeSource) Lucene.Net Class Library
Construct a token stream processing the given input using the given AttributeSource.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Tokenizer(
    AttributeSource source
)
protected Tokenizer(
    AttributeSource source
)
Protected Sub New ( _
    source As AttributeSource _
)
Protected Sub New ( _
    source As AttributeSource _
)
protected:
Tokenizer(
    AttributeSource^ source
)
protected:
Tokenizer(
    AttributeSource^ source
)
Parameters
source
Type: Lucene.Net.Util AttributeSource
See Also
Tokenizer Class
Tokenizer Members
Tokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tokenizer Constructor (AttributeSource.AttributeFactory)

Tokenizer Constructor (AttributeSource AttributeFactory) Lucene.Net Class Library
Construct a tokenizer with null input using the given AttributeFactory.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Tokenizer(
    AttributeSource..::..AttributeFactory factory
)
protected Tokenizer(
    AttributeSource..::..AttributeFactory factory
)
Protected Sub New ( _
    factory As AttributeSource..::..AttributeFactory _
)
Protected Sub New ( _
    factory As AttributeSource..::..AttributeFactory _
)
protected:
Tokenizer(
    AttributeSource..::..AttributeFactory^ factory
)
protected:
Tokenizer(
    AttributeSource..::..AttributeFactory^ factory
)
Parameters
factory
Type: Lucene.Net.Util AttributeSource AttributeFactory
See Also
Tokenizer Class
Tokenizer Members
Tokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tokenizer Constructor (AttributeSource, TextReader)

Tokenizer Constructor (AttributeSource, TextReader) Lucene.Net Class Library
Construct a token stream processing the given input using the given AttributeSource.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Tokenizer(
    AttributeSource source,
    TextReader input
)
protected Tokenizer(
    AttributeSource source,
    TextReader input
)
Protected Sub New ( _
    source As AttributeSource, _
    input As TextReader _
)
Protected Sub New ( _
    source As AttributeSource, _
    input As TextReader _
)
protected:
Tokenizer(
    AttributeSource^ source,
    TextReader^ input
)
protected:
Tokenizer(
    AttributeSource^ source,
    TextReader^ input
)
Parameters
source
Type: Lucene.Net.Util AttributeSource
input
Type:   Online System.IO TextReader
See Also
Tokenizer Class
Tokenizer Members
Tokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tokenizer Constructor (AttributeSource.AttributeFactory, TextReader)

Tokenizer Constructor (AttributeSource AttributeFactory, TextReader) Lucene.Net Class Library
Construct a token stream processing the given input using the given AttributeFactory.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Tokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader input
)
protected Tokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader input
)
Protected Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    input As TextReader _
)
Protected Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    input As TextReader _
)
protected:
Tokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ input
)
protected:
Tokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ input
)
Parameters
factory
Type: Lucene.Net.Util AttributeSource AttributeFactory
input
Type:   Online System.IO TextReader
See Also
Tokenizer Class
Tokenizer Members
Tokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tokenizer Fields

Tokenizer Fields Lucene.Net Class Library
The Tokenizer type exposes the following members.
Fields
 | Name | Description
Protected field | input | The text source for this Tokenizer.
Back to Top
See Also
Tokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


input Field

Tokenizer input Field Lucene.Net Class Library
The text source for this Tokenizer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TextReader input
protected TextReader input
Protected input As TextReader
Protected input As TextReader
protected:
TextReader^ input
protected:
TextReader^ input
See Also
Tokenizer Class
Tokenizer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tokenizer Methods

Tokenizer Methods Lucene.Net Class Library
The Tokenizer type exposes the following members.
Methods
Name | Description
Public method AddAttribute T
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned.
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces.

Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory

(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource))
(Inherited from AttributeSource.)
Public method Close Obsolete.
Releases resources associated with this stream.
(Inherited from TokenStream.)
Protected method CorrectOffset
Return the corrected offset. If input is a CharStream subclass this method calls CorrectOffset(Int32), else returns currentOff.
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Overrides TokenStream Dispose(Boolean).)
Public method End
This method is called by the consumer after the last token has been consumed, after IncrementToken returned false (using the new TokenStream API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a WhitespaceTokenizer was used.
(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method GetAttribute T
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method GetAttributeTypesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method HasAttribute T
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute.
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., IndexWriter) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate Attributes with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use CaptureState to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to AddAttribute T and GetAttribute T , references to all Attributes that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in IncrementToken .
(Inherited from TokenStream.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Reset
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ).
(Inherited from TokenStream.)
Public method Reset(TextReader)
Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
Tokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CorrectOffset Method

Tokenizer CorrectOffset Method Lucene.Net Class Library
Return the corrected offset. If input is a CharStream subclass this method calls CorrectOffset(Int32), else returns currentOff.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int CorrectOffset(
    int currentOff
)
protected int CorrectOffset(
    int currentOff
)
Protected Function CorrectOffset ( _
    currentOff As Integer _
) As Integer
Protected Function CorrectOffset ( _
    currentOff As Integer _
) As Integer
protected:
int CorrectOffset(
    int currentOff
)
protected:
int CorrectOffset(
    int currentOff
)
Parameters
currentOff
Type:   Online System Int32
offset as seen in the output

Return Value
 corrected offset based on the input

See Also
Tokenizer Class
Tokenizer Members
Lucene.Net.Analysis Namespace
CharStream CorrectOffset(Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

Tokenizer Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Tokenizer and optionally releases the managed resources (Overrides TokenStream Dispose(Boolean).)
Back to Top
See Also
Tokenizer Class
Tokenizer Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

Tokenizer Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the Tokenizer and optionally releases the managed resources

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
Tokenizer Class
Tokenizer Members
Dispose Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method

Tokenizer Reset Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ). (Inherited from TokenStream.)
Public method | Reset(TextReader) | Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.
Back to Top
See Also
Tokenizer Class
Tokenizer Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method (TextReader)

Tokenizer Reset Method (TextReader) Lucene.Net Class Library
Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Reset(
    TextReader input
)
public virtual void Reset(
    TextReader input
)
Public Overridable Sub Reset ( _
    input As TextReader _
)
Public Overridable Sub Reset ( _
    input As TextReader _
)
public:
virtual void Reset(
    TextReader^ input
)
public:
virtual void Reset(
    TextReader^ input
)
Parameters
input
Type:   Online System.IO TextReader
See Also
Tokenizer Class
Tokenizer Members
Reset Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tokenizer Properties

Tokenizer Properties Lucene.Net Class Library
The Tokenizer type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
Tokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStream Class

TokenStream Class Lucene.Net Class Library
A TokenStream enumerates the sequence of tokens, either from Fields of a Document or from query text.

This is an abstract class. Concrete subclasses are:
  • Tokenizer, a TokenStream whose input is a Reader; and
  • TokenFilter, a TokenStream whose input is another TokenStream.
A new TokenStream API has been introduced with Lucene 2.9. This API has moved from being Token based to IAttribute based. While Token still exists in 2.9 as a convenience class, the preferred way to store the information of a Token is to use Attributes.

TokenStream now extends AttributeSource, which provides access to all of the token IAttributes for the TokenStream. Note that only one instance per Attribute is created and reused for every token. This approach reduces object creation and allows local caching of references to the Attributes. See IncrementToken for further details.

The workflow of the new TokenStream API is as follows:
  • Instantiation of TokenStream/TokenFilters which add/get attributes to/from the AttributeSource.
  • The consumer calls Reset .
  • The consumer retrieves attributes from the stream and stores local references to all attributes it wants to access
  • The consumer calls IncrementToken until it returns false and consumes the attributes after each call.
  • The consumer calls End so that any end-of-stream operations can be performed.
  • The consumer calls Close to release any resource when finished using the TokenStream
To make sure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in IncrementToken .

You can find some example code for the new API in the analysis package level Javadoc.

Sometimes it is desirable to capture a current state of a TokenStream , e. g. for buffering purposes (see CachingTokenFilter, TeeSinkTokenFilter). For this usecase CaptureState and RestoreState(AttributeSource State) can be used.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis NumericTokenStream
Lucene.Net.Analysis TeeSinkTokenFilter SinkTokenStream
Lucene.Net.Analysis TokenFilter
Lucene.Net.Analysis Tokenizer

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class TokenStream : AttributeSource,
    IDisposable
public abstract class TokenStream : AttributeSource,
    IDisposable
Public MustInherit Class TokenStream _
    Inherits AttributeSource _
    Implements IDisposable
Public MustInherit Class TokenStream _
    Inherits AttributeSource _
    Implements IDisposable
public ref class TokenStream abstract : public AttributeSource,
    IDisposable
public ref class TokenStream abstract : public AttributeSource,
    IDisposable
See Also
TokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStream Members

TokenStream Members Lucene.Net Class Library

The TokenStream type exposes the following members.
Constructors
 | Name | Description
Protected method | TokenStream | A TokenStream using the default attribute factory.
Protected method | TokenStream(AttributeSource) | A TokenStream that uses the same attributes as the supplied one.
Protected method | TokenStream(AttributeSource AttributeFactory) | A TokenStream using the supplied AttributeFactory for creating new IAttribute instances.
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream.
Public method | Dispose | Releases all resources used by the TokenStream
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TokenStream and optionally releases the managed resources
Public method | End | This method is called by the consumer after the last token has been consumed, after IncrementToken returned false (using the new TokenStream API). Streams implementing the old API should upgrade to use this feature. This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a WhitespaceTokenizer was used.
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | Consumers (i.e., IndexWriter) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate Attributes with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use CaptureState to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to AddAttribute T and GetAttribute T , references to all Attributes that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in IncrementToken .
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ).
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
TokenStream Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStream Constructor

TokenStream Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Protected method | TokenStream | A TokenStream using the default attribute factory.
Protected method | TokenStream(AttributeSource) | A TokenStream that uses the same attributes as the supplied one.
Protected method | TokenStream(AttributeSource AttributeFactory) | A TokenStream using the supplied AttributeFactory for creating new IAttribute instances.
Back to Top
See Also
TokenStream Class
TokenStream Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStream Constructor

TokenStream Constructor Lucene.Net Class Library
A TokenStream using the default attribute factory.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TokenStream()
protected TokenStream()
Protected Sub New
Protected Sub New
protected:
TokenStream()
protected:
TokenStream()
See Also
TokenStream Class
TokenStream Members
TokenStream Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStream Constructor (AttributeSource)

TokenStream Constructor (AttributeSource) Lucene.Net Class Library
A TokenStream that uses the same attributes as the supplied one.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TokenStream(
    AttributeSource input
)
protected TokenStream(
    AttributeSource input
)
Protected Sub New ( _
    input As AttributeSource _
)
Protected Sub New ( _
    input As AttributeSource _
)
protected:
TokenStream(
    AttributeSource^ input
)
protected:
TokenStream(
    AttributeSource^ input
)
Parameters
input
Type: Lucene.Net.Util AttributeSource
See Also
TokenStream Class
TokenStream Members
TokenStream Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStream Constructor (AttributeSource.AttributeFactory)

TokenStream Constructor (AttributeSource AttributeFactory) Lucene.Net Class Library
A TokenStream using the supplied AttributeFactory for creating new IAttribute instances.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TokenStream(
    AttributeSource..::..AttributeFactory factory
)
protected TokenStream(
    AttributeSource..::..AttributeFactory factory
)
Protected Sub New ( _
    factory As AttributeSource..::..AttributeFactory _
)
Protected Sub New ( _
    factory As AttributeSource..::..AttributeFactory _
)
protected:
TokenStream(
    AttributeSource..::..AttributeFactory^ factory
)
protected:
TokenStream(
    AttributeSource..::..AttributeFactory^ factory
)
Parameters
factory
Type: Lucene.Net.Util AttributeSource AttributeFactory
See Also
TokenStream Class
TokenStream Members
TokenStream Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStream Methods

TokenStream Methods Lucene.Net Class Library
The TokenStream type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream.
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | End | This method is called by the consumer after the last token has been consumed, after IncrementToken returned false (using the new TokenStream API). Streams implementing the old API should upgrade to use this feature. This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a WhitespaceTokenizer was used.
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | Consumers (i.e., IndexWriter) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate Attributes with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use CaptureState to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to AddAttribute T and GetAttribute T , references to all Attributes that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in IncrementToken .
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ).
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
TokenStream Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

TokenStream Close Method Lucene.Net Class Library
Releases resources associated with this stream.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
See Also
TokenStream Class
TokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

TokenStream Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the TokenStream
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TokenStream and optionally releases the managed resources
Back to Top
See Also
TokenStream Class
TokenStream Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

TokenStream Dispose Method Lucene.Net Class Library
Releases all resources used by the TokenStream

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
TokenStream Class
TokenStream Members
Dispose Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

TokenStream Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the TokenStream and optionally releases the managed resources

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void Dispose(
    bool disposing
)
protected abstract void Dispose(
    bool disposing
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) abstract
protected:
virtual void Dispose(
    bool disposing
) abstract
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
TokenStream Class
TokenStream Members
Dispose Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


End Method

TokenStream End Method Lucene.Net Class Library
This method is called by the consumer after the last token has been consumed, after IncrementToken returned false (using the new TokenStream API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a WhitespaceTokenizer was used.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void End()
public virtual void End()
Public Overridable Sub End
Public Overridable Sub End
public:
virtual void End()
public:
virtual void End()
See Also
TokenStream Class
TokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncrementToken Method

TokenStream IncrementToken Method Lucene.Net Class Library
Consumers (i.e., IndexWriter) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate Attributes with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use CaptureState to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to AddAttribute T and GetAttribute T , references to all Attributes that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in IncrementToken .

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool IncrementToken()
public abstract bool IncrementToken()
Public MustOverride Function IncrementToken As Boolean
Public MustOverride Function IncrementToken As Boolean
public:
virtual bool IncrementToken() abstract
public:
virtual bool IncrementToken() abstract
Return Value
 false for end of stream; true otherwise
See Also
TokenStream Class
TokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method

TokenStream Reset Method Lucene.Net Class Library
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ).

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Reset()
public virtual void Reset()
Public Overridable Sub Reset
Public Overridable Sub Reset
public:
virtual void Reset()
public:
virtual void Reset()
See Also
TokenStream Class
TokenStream Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStream Properties

TokenStream Properties Lucene.Net Class Library
The TokenStream type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
TokenStream Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WhitespaceAnalyzer Class

WhitespaceAnalyzer Class Lucene.Net Class Library
An Analyzer that uses WhitespaceTokenizer.
Inheritance Hierarchy
Online System Object
Lucene.Net.Analysis Analyzer
Lucene.Net.Analysis WhitespaceAnalyzer

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class WhitespaceAnalyzer : Analyzer
public sealed class WhitespaceAnalyzer : Analyzer
Public NotInheritable Class WhitespaceAnalyzer _
    Inherits Analyzer
Public NotInheritable Class WhitespaceAnalyzer _
    Inherits Analyzer
public ref class WhitespaceAnalyzer sealed : public Analyzer
public ref class WhitespaceAnalyzer sealed : public Analyzer
See Also
WhitespaceAnalyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WhitespaceAnalyzer Members

WhitespaceAnalyzer Members Lucene.Net Class Library

The WhitespaceAnalyzer type exposes the following members.
Constructors
 | Name | Description
Public method | WhitespaceAnalyzer | Initializes a new instance of the WhitespaceAnalyzer class
Back to Top
Methods
 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Dispose | (Inherited from Analyzer.)
Protected method | Dispose(Boolean) | (Inherited from Analyzer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetOffsetGap | Just like GetPositionIncrementGap(String), except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReusableTokenStream | (Overrides Analyzer ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod TClass | Obsolete. Java uses Class<? extends Analyer> to constrain TClass to only Types that inherit from Analyzer. C# does not have a generic type class, ie Type<t>. The method signature stays the same, and an exception may still be thrown, if the method doesn't exist. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer TokenStream(String, TextReader).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | overridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Back to Top
Properties
 | Name | Description
Protected property | PreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Back to Top
See Also
WhitespaceAnalyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WhitespaceAnalyzer Constructor

WhitespaceAnalyzer Constructor Lucene.Net Class Library
Initializes a new instance of the WhitespaceAnalyzer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WhitespaceAnalyzer()
public WhitespaceAnalyzer()
Public Sub New
Public Sub New
public:
WhitespaceAnalyzer()
public:
WhitespaceAnalyzer()
See Also
WhitespaceAnalyzer Class
WhitespaceAnalyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WhitespaceAnalyzer Fields

WhitespaceAnalyzer Fields Lucene.Net Class Library
The WhitespaceAnalyzer type exposes the following members.
Fields
 | Name | Description
Protected field | overridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Back to Top
See Also
WhitespaceAnalyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WhitespaceAnalyzer Methods

WhitespaceAnalyzer Methods Lucene.Net Class Library
The WhitespaceAnalyzer type exposes the following members.
Methods
 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Dispose | (Inherited from Analyzer.)
Protected method | Dispose(Boolean) | (Inherited from Analyzer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetOffsetGap | Just like GetPositionIncrementGap(String), except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReusableTokenStream | (Overrides Analyzer ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod TClass | Obsolete. Java uses Class<? extends Analyer> to constrain TClass to only Types that inherit from Analyzer. C# does not have a generic type class, ie Type<t>. The method signature stays the same, and an exception may still be thrown, if the method doesn't exist. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer TokenStream(String, TextReader).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
WhitespaceAnalyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReusableTokenStream Method

WhitespaceAnalyzer ReusableTokenStream Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override
Parameters
fieldName
Type:   Online System String
reader
Type:   Online System.IO TextReader
See Also
WhitespaceAnalyzer Class
WhitespaceAnalyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStream Method

WhitespaceAnalyzer TokenStream Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override
Parameters
fieldName
Type:   Online System String
reader
Type:   Online System.IO TextReader
See Also
WhitespaceAnalyzer Class
WhitespaceAnalyzer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WhitespaceAnalyzer Properties

WhitespaceAnalyzer Properties Lucene.Net Class Library
The WhitespaceAnalyzer type exposes the following members.
Properties
 | Name | Description
Protected property | PreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Back to Top
See Also
WhitespaceAnalyzer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WhitespaceTokenizer Class

WhitespaceTokenizer Class Lucene.Net Class Library
A WhitespaceTokenizer is a tokenizer that divides text at whitespace. Adjacent sequences of non-Whitespace characters form tokens.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis Tokenizer
Lucene.Net.Analysis CharTokenizer
Lucene.Net.Analysis WhitespaceTokenizer

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class WhitespaceTokenizer : CharTokenizer
public class WhitespaceTokenizer : CharTokenizer
Public Class WhitespaceTokenizer _
    Inherits CharTokenizer
Public Class WhitespaceTokenizer _
    Inherits CharTokenizer
public ref class WhitespaceTokenizer : public CharTokenizer
public ref class WhitespaceTokenizer : public CharTokenizer
See Also
WhitespaceTokenizer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WhitespaceTokenizer Members

WhitespaceTokenizer Members Lucene.Net Class Library

The WhitespaceTokenizer type exposes the following members.
Constructors
 | Name | Description
Public method | WhitespaceTokenizer(TextReader) | Construct a new WhitespaceTokenizer.
Public method | WhitespaceTokenizer(AttributeSource, TextReader) | Construct a new WhitespaceTokenizer using a given AttributeSource.
Public method | WhitespaceTokenizer(AttributeSource AttributeFactory, TextReader) | Construct a new WhitespaceTokenizer using a given AttributeSource AttributeFactory.
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Protected method | CorrectOffset | Return the corrected offset. If input is a CharStream subclass this method calls CorrectOffset(Int32), else returns currentOff. (Inherited from Tokenizer.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method | IsTokenChar | Collects only characters which do not satisfy Online IsWhiteSpace(Char). (Overrides CharTokenizer IsTokenChar(Char).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Normalize | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens. (Inherited from CharTokenizer.)
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ). (Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Fields
 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
WhitespaceTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WhitespaceTokenizer Constructor

WhitespaceTokenizer Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | WhitespaceTokenizer(TextReader) | Construct a new WhitespaceTokenizer.
Public method | WhitespaceTokenizer(AttributeSource, TextReader) | Construct a new WhitespaceTokenizer using a given AttributeSource.
Public method | WhitespaceTokenizer(AttributeSource AttributeFactory, TextReader) | Construct a new WhitespaceTokenizer using a given AttributeSource AttributeFactory.
Back to Top
See Also
WhitespaceTokenizer Class
WhitespaceTokenizer Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WhitespaceTokenizer Constructor (TextReader)

WhitespaceTokenizer Constructor (TextReader) Lucene.Net Class Library
Construct a new WhitespaceTokenizer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WhitespaceTokenizer(
    TextReader in
)
public WhitespaceTokenizer(
    TextReader in
)
Public Sub New ( _
    in As TextReader _
)
Public Sub New ( _
    in As TextReader _
)
public:
WhitespaceTokenizer(
    TextReader^ in
)
public:
WhitespaceTokenizer(
    TextReader^ in
)
Parameters
in
Type:   Online System.IO TextReader
See Also
WhitespaceTokenizer Class
WhitespaceTokenizer Members
WhitespaceTokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WhitespaceTokenizer Constructor (AttributeSource, TextReader)

WhitespaceTokenizer Constructor (AttributeSource, TextReader) Lucene.Net Class Library
Construct a new WhitespaceTokenizer using a given AttributeSource.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WhitespaceTokenizer(
    AttributeSource source,
    TextReader in
)
public WhitespaceTokenizer(
    AttributeSource source,
    TextReader in
)
Public Sub New ( _
    source As AttributeSource, _
    in As TextReader _
)
Public Sub New ( _
    source As AttributeSource, _
    in As TextReader _
)
public:
WhitespaceTokenizer(
    AttributeSource^ source,
    TextReader^ in
)
public:
WhitespaceTokenizer(
    AttributeSource^ source,
    TextReader^ in
)
Parameters
source
Type: Lucene.Net.Util AttributeSource
in
Type:   Online System.IO TextReader
See Also
WhitespaceTokenizer Class
WhitespaceTokenizer Members
WhitespaceTokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WhitespaceTokenizer Constructor (AttributeSource.AttributeFactory, TextReader)

WhitespaceTokenizer Constructor (AttributeSource AttributeFactory, TextReader) Lucene.Net Class Library
Construct a new WhitespaceTokenizer using a given AttributeSource AttributeFactory.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WhitespaceTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader in
)
public WhitespaceTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader in
)
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    in As TextReader _
)
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    in As TextReader _
)
public:
WhitespaceTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ in
)
public:
WhitespaceTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ in
)
Parameters
factory
Type: Lucene.Net.Util AttributeSource AttributeFactory
in
Type:   Online System.IO TextReader
See Also
WhitespaceTokenizer Class
WhitespaceTokenizer Members
WhitespaceTokenizer Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WhitespaceTokenizer Fields

WhitespaceTokenizer Fields Lucene.Net Class Library
The WhitespaceTokenizer type exposes the following members.
Fields
 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)
Back to Top
See Also
WhitespaceTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WhitespaceTokenizer Methods

WhitespaceTokenizer Methods Lucene.Net Class Library
The WhitespaceTokenizer type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Protected method | CorrectOffset | Return the corrected offset. If input is a CharStream subclass this method calls CorrectOffset(Int32), else returns currentOff. (Inherited from Tokenizer.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method | IsTokenChar | Collects only characters which do not satisfy Online IsWhiteSpace(Char). (Overrides CharTokenizer IsTokenChar(Char).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Normalize | Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens. (Inherited from CharTokenizer.)
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ). (Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
WhitespaceTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsTokenChar Method

WhitespaceTokenizer IsTokenChar Method Lucene.Net Class Library
Collects only characters which do not satisfy Online IsWhiteSpace(Char).

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool IsTokenChar(
    char c
)
protected override bool IsTokenChar(
    char c
)
Protected Overrides Function IsTokenChar ( _
    c As Char _
) As Boolean
Protected Overrides Function IsTokenChar ( _
    c As Char _
) As Boolean
protected:
virtual bool IsTokenChar(
    wchar_t c
) override
protected:
virtual bool IsTokenChar(
    wchar_t c
) override
Parameters
c
Type:   Online System Char
See Also
WhitespaceTokenizer Class
WhitespaceTokenizer Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WhitespaceTokenizer Properties

WhitespaceTokenizer Properties Lucene.Net Class Library
The WhitespaceTokenizer type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
WhitespaceTokenizer Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WordlistLoader Class

WordlistLoader Class Lucene.Net Class Library
Loader for text files that represent a list of stopwords.
Inheritance Hierarchy
Online System Object
Lucene.Net.Analysis WordlistLoader

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class WordlistLoader
public class WordlistLoader
Public Class WordlistLoader
Public Class WordlistLoader
public ref class WordlistLoader
public ref class WordlistLoader
See Also
WordlistLoader Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WordlistLoader Members

WordlistLoader Members Lucene.Net Class Library

The WordlistLoader type exposes the following members.
Constructors
 | Name | Description
Public method | WordlistLoader | Initializes a new instance of the WordlistLoader class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
 | GetStemDict | Reads a stem dictionary. Each line contains: word\tstem (i.e. two tab seperated words)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GetWordSet(FileInfo) | Loads a text file and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
 | GetWordSet(TextReader) | Reads lines from a Reader and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
 | GetWordSet(FileInfo, String) | Loads a text file and adds every non-comment line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
 | GetWordSet(TextReader, String) | Reads lines from a Reader and adds every non-comment line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
WordlistLoader Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WordlistLoader Constructor

WordlistLoader Constructor Lucene.Net Class Library
Initializes a new instance of the WordlistLoader class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WordlistLoader()
public WordlistLoader()
Public Sub New
Public Sub New
public:
WordlistLoader()
public:
WordlistLoader()
See Also
WordlistLoader Class
WordlistLoader Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WordlistLoader Methods

WordlistLoader Methods Lucene.Net Class Library
The WordlistLoader type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
 | GetStemDict | Reads a stem dictionary. Each line contains: word\tstem (i.e. two tab seperated words)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GetWordSet(FileInfo) | Loads a text file and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
 | GetWordSet(TextReader) | Reads lines from a Reader and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
 | GetWordSet(FileInfo, String) | Loads a text file and adds every non-comment line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
 | GetWordSet(TextReader, String) | Reads lines from a Reader and adds every non-comment line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
WordlistLoader Class
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetStemDict Method

WordlistLoader GetStemDict Method Lucene.Net Class Library
Reads a stem dictionary. Each line contains: word\tstem (i.e. two tab seperated words)

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Dictionary<string, string> GetStemDict(
    FileInfo wordstemfile
)
public static Dictionary<string, string> GetStemDict(
    FileInfo wordstemfile
)
Public Shared Function GetStemDict ( _
    wordstemfile As FileInfo _
) As Dictionary(Of String, String)
Public Shared Function GetStemDict ( _
    wordstemfile As FileInfo _
) As Dictionary(Of String, String)
public:
static Dictionary<String^, String^>^ GetStemDict(
    FileInfo^ wordstemfile
)
public:
static Dictionary<String^, String^>^ GetStemDict(
    FileInfo^ wordstemfile
)
Parameters
wordstemfile
Type:   Online System.IO FileInfo
Return Value
 stem dictionary that overrules the stemming algorithm

See Also
WordlistLoader Class
WordlistLoader Members
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetWordSet Method

WordlistLoader GetWordSet Method Lucene.Net Class Library
Overload List
Name | Description
GetWordSet(FileInfo) | Loads a text file and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
GetWordSet(TextReader) | Reads lines from a Reader and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
GetWordSet(FileInfo, String) | Loads a text file and adds every non-comment line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
GetWordSet(TextReader, String) | Reads lines from a Reader and adds every non-comment line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
Back to Top
See Also
WordlistLoader Class
WordlistLoader Members
Lucene.Net.Analysis Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetWordSet Method (FileInfo)

WordlistLoader GetWordSet Method (FileInfo) Lucene.Net Class Library
Loads a text file and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ISet<string> GetWordSet(
    FileInfo wordfile
)
public static ISet<string> GetWordSet(
    FileInfo wordfile
)
Public Shared Function GetWordSet ( _
    wordfile As FileInfo _
) As ISet(Of String)
Public Shared Function GetWordSet ( _
    wordfile As FileInfo _
) As ISet(Of String)
public:
static ISet<String^>^ GetWordSet(
    FileInfo^ wordfile
)
public:
static ISet<String^>^ GetWordSet(
    FileInfo^ wordfile
)
Parameters
wordfile
Type:   Online System.IO FileInfo
File containing the wordlist
Return Value
 A HashSet with the file's words
See Also
WordlistLoader Class
WordlistLoader Members
GetWordSet Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetWordSet Method (TextReader)

WordlistLoader GetWordSet Method (TextReader) Lucene.Net Class Library
Reads lines from a Reader and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ISet<string> GetWordSet(
    TextReader reader
)
public static ISet<string> GetWordSet(
    TextReader reader
)
Public Shared Function GetWordSet ( _
    reader As TextReader _
) As ISet(Of String)
Public Shared Function GetWordSet ( _
    reader As TextReader _
) As ISet(Of String)
public:
static ISet<String^>^ GetWordSet(
    TextReader^ reader
)
public:
static ISet<String^>^ GetWordSet(
    TextReader^ reader
)
Parameters
reader
Type:   Online System.IO TextReader
Reader containing the wordlist
Return Value
A HashSet with the reader's words
See Also
WordlistLoader Class
WordlistLoader Members
GetWordSet Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetWordSet Method (FileInfo, String)

WordlistLoader GetWordSet Method (FileInfo, String) Lucene.Net Class Library
Loads a text file and adds every non-comment line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ISet<string> GetWordSet(
    FileInfo wordfile,
    string comment
)
public static ISet<string> GetWordSet(
    FileInfo wordfile,
    string comment
)
Public Shared Function GetWordSet ( _
    wordfile As FileInfo, _
    comment As String _
) As ISet(Of String)
Public Shared Function GetWordSet ( _
    wordfile As FileInfo, _
    comment As String _
) As ISet(Of String)
public:
static ISet<String^>^ GetWordSet(
    FileInfo^ wordfile,
    String^ comment
)
public:
static ISet<String^>^ GetWordSet(
    FileInfo^ wordfile,
    String^ comment
)
Parameters
wordfile
Type:   Online System.IO FileInfo
File containing the wordlist
comment
Type:   Online System String
The comment string to ignore
Return Value
 A HashSet with the file's words
See Also
WordlistLoader Class
WordlistLoader Members
GetWordSet Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetWordSet Method (TextReader, String)

WordlistLoader GetWordSet Method (TextReader, String) Lucene.Net Class Library
Reads lines from a Reader and adds every non-comment line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ISet<string> GetWordSet(
    TextReader reader,
    string comment
)
public static ISet<string> GetWordSet(
    TextReader reader,
    string comment
)
Public Shared Function GetWordSet ( _
    reader As TextReader, _
    comment As String _
) As ISet(Of String)
Public Shared Function GetWordSet ( _
    reader As TextReader, _
    comment As String _
) As ISet(Of String)
public:
static ISet<String^>^ GetWordSet(
    TextReader^ reader,
    String^ comment
)
public:
static ISet<String^>^ GetWordSet(
    TextReader^ reader,
    String^ comment
)
Parameters
reader
Type:   Online System.IO TextReader
Reader containing the wordlist

comment
Type:   Online System String
The string representing a comment.

Return Value
 A HashSet with the reader's words

See Also
WordlistLoader Class
WordlistLoader Members
GetWordSet Overload
Lucene.Net.Analysis Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lucene.Net.Analysis.Standard Namespace

Lucene.Net.Analysis.Standard Namespace Lucene.Net Class Library
Classes
Class Description
Public class StandardAnalyzer
Filters StandardTokenizer with StandardFilter, LowerCaseFilter and StopFilter, using a list of English stop words.

You must specify the required Version compatibility when creating StandardAnalyzer:
  • As of 2.9, StopFilter preserves position increments
  • As of 2.4, Tokens incorrectly identified as acronyms are corrected (see Online LUCENE-1608)
Public class StandardFilter
Normalizes tokens extracted with StandardTokenizer.
Public class StandardTokenizer
A grammar-based tokenizer constructed with JFlex

This should be a good tokenizer for most European-language documents:
  • Splits words at punctuation characters, removing punctuation. However, a dot that's not followed by whitespace is considered part of a token.
  • Splits words at hyphens, unless there's a number in the token, in which case the whole token is interpreted as a product number and is not split.
  • Recognizes email addresses and internet hostnames as one token.

Many applications have specific tokenizer needs. If this tokenizer does not suit your application, please consider copying this source code directory to your project and maintaining your own grammar-based tokenizer.

You must specify the required Version compatibility when creating StandardAnalyzer:
  • As of 2.4, Tokens incorrectly identified as acronyms are corrected (see Online LUCENE-1608

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardAnalyzer Class

StandardAnalyzer Class Lucene.Net Class Library
Filters StandardTokenizer with StandardFilter, LowerCaseFilter and StopFilter, using a list of English stop words.

You must specify the required Version compatibility when creating StandardAnalyzer:
  • As of 2.9, StopFilter preserves position increments
  • As of 2.4, Tokens incorrectly identified as acronyms are corrected (see Online LUCENE-1608)
Inheritance Hierarchy
Online System Object
Lucene.Net.Analysis Analyzer
Lucene.Net.Analysis.Standard StandardAnalyzer

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class StandardAnalyzer : Analyzer
public class StandardAnalyzer : Analyzer
Public Class StandardAnalyzer _
    Inherits Analyzer
Public Class StandardAnalyzer _
    Inherits Analyzer
public ref class StandardAnalyzer : public Analyzer
public ref class StandardAnalyzer : public Analyzer
See Also
StandardAnalyzer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardAnalyzer Members

StandardAnalyzer Members Lucene.Net Class Library

The StandardAnalyzer type exposes the following members.
Constructors
 | Name | Description
Public method | StandardAnalyzer(Version) | Builds an analyzer with the default stop words (STOP_WORDS_SET).
Public method | StandardAnalyzer(Version, ISet String ) | Builds an analyzer with the given stop words.
Public method | StandardAnalyzer(Version, FileInfo) | Builds an analyzer with the stop words from the given file.
Public method | StandardAnalyzer(Version, TextReader) | Builds an analyzer with the stop words from the given reader.
Back to Top
Methods
 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Dispose | (Inherited from Analyzer.)
Protected method | Dispose(Boolean) | (Inherited from Analyzer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetOffsetGap | Just like GetPositionIncrementGap(String), except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReusableTokenStream | (Overrides Analyzer ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod TClass | Obsolete. Java uses Class<? extends Analyer> to constrain TClass to only Types that inherit from Analyzer. C# does not have a generic type class, ie Type<t>. The method signature stays the same, and an exception may still be thrown, if the method doesn't exist. (Inherited from Analyzer.)
Public method | TokenStream | Constructs a StandardTokenizer filtered by a StandardFilter , a LowerCaseFilter and a StopFilter. (Overrides Analyzer TokenStream(String, TextReader).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
 | DEFAULT_MAX_TOKEN_LENGTH | Default maximum allowed token length
Protected field | overridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
 | STOP_WORDS_SET | An unmodifiable set containing some common English words that are usually not useful for searching.
Back to Top
Properties
 | Name | Description
Public property | MaxTokenLength | Set maximum allowed token length. If a token is seen that exceeds this length then it is discarded. This setting only takes effect the next time tokenStream or reusableTokenStream is called.
Protected property | PreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Back to Top
See Also
StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardAnalyzer Constructor

StandardAnalyzer Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | StandardAnalyzer(Version) | Builds an analyzer with the default stop words (STOP_WORDS_SET).
Public method | StandardAnalyzer(Version, ISet String ) | Builds an analyzer with the given stop words.
Public method | StandardAnalyzer(Version, FileInfo) | Builds an analyzer with the stop words from the given file.
Public method | StandardAnalyzer(Version, TextReader) | Builds an analyzer with the stop words from the given reader.
Back to Top
See Also
StandardAnalyzer Class
StandardAnalyzer Members
Lucene.Net.Analysis.Standard Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardAnalyzer Constructor (Version)

StandardAnalyzer Constructor (Version) Lucene.Net Class Library
Builds an analyzer with the default stop words (STOP_WORDS_SET).

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StandardAnalyzer(
    Version matchVersion
)
public StandardAnalyzer(
    Version matchVersion
)
Public Sub New ( _
    matchVersion As Version _
)
Public Sub New ( _
    matchVersion As Version _
)
public:
StandardAnalyzer(
    Version matchVersion
)
public:
StandardAnalyzer(
    Version matchVersion
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
Lucene version to match see above
See Also
StandardAnalyzer Class
StandardAnalyzer Members
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardAnalyzer Constructor (Version, ISet(String))

StandardAnalyzer Constructor (Version, ISet String ) Lucene.Net Class Library
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StandardAnalyzer(
    Version matchVersion,
    ISet<string> stopWords
)
public StandardAnalyzer(
    Version matchVersion,
    ISet<string> stopWords
)
Public Sub New ( _
    matchVersion As Version, _
    stopWords As ISet(Of String) _
)
Public Sub New ( _
    matchVersion As Version, _
    stopWords As ISet(Of String) _
)
public:
StandardAnalyzer(
    Version matchVersion,
    ISet<String^>^ stopWords
)
public:
StandardAnalyzer(
    Version matchVersion,
    ISet<String^>^ stopWords
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
Lucene version to match See above />

stopWords
Type:   Online System.Collections.Generic ISet    Online String
stop words

See Also
StandardAnalyzer Class
StandardAnalyzer Members
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardAnalyzer Constructor (Version, FileInfo)

StandardAnalyzer Constructor (Version, FileInfo) Lucene.Net Class Library
Builds an analyzer with the stop words from the given file.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StandardAnalyzer(
    Version matchVersion,
    FileInfo stopwords
)
public StandardAnalyzer(
    Version matchVersion,
    FileInfo stopwords
)
Public Sub New ( _
    matchVersion As Version, _
    stopwords As FileInfo _
)
Public Sub New ( _
    matchVersion As Version, _
    stopwords As FileInfo _
)
public:
StandardAnalyzer(
    Version matchVersion,
    FileInfo^ stopwords
)
public:
StandardAnalyzer(
    Version matchVersion,
    FileInfo^ stopwords
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
Lucene version to match See above />

stopwords
Type:   Online System.IO FileInfo
File to read stop words from

See Also
StandardAnalyzer Class
StandardAnalyzer Members
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace
WordlistLoader GetWordSet(FileInfo)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardAnalyzer Constructor (Version, TextReader)

StandardAnalyzer Constructor (Version, TextReader) Lucene.Net Class Library
Builds an analyzer with the stop words from the given reader.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StandardAnalyzer(
    Version matchVersion,
    TextReader stopwords
)
public StandardAnalyzer(
    Version matchVersion,
    TextReader stopwords
)
Public Sub New ( _
    matchVersion As Version, _
    stopwords As TextReader _
)
Public Sub New ( _
    matchVersion As Version, _
    stopwords As TextReader _
)
public:
StandardAnalyzer(
    Version matchVersion,
    TextReader^ stopwords
)
public:
StandardAnalyzer(
    Version matchVersion,
    TextReader^ stopwords
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
Lucene version to match See above />

stopwords
Type:   Online System.IO TextReader
Reader to read stop words from

See Also
StandardAnalyzer Class
StandardAnalyzer Members
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace
WordlistLoader GetWordSet(TextReader)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardAnalyzer Fields

StandardAnalyzer Fields Lucene.Net Class Library
The StandardAnalyzer type exposes the following members.
Fields
 | Name | Description
 | DEFAULT_MAX_TOKEN_LENGTH | Default maximum allowed token length
Protected field | overridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
 | STOP_WORDS_SET | An unmodifiable set containing some common English words that are usually not useful for searching.
Back to Top
See Also
StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_MAX_TOKEN_LENGTH Field

StandardAnalyzer DEFAULT_MAX_TOKEN_LENGTH Field Lucene.Net Class Library
Default maximum allowed token length

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_MAX_TOKEN_LENGTH
public const int DEFAULT_MAX_TOKEN_LENGTH
Public Const DEFAULT_MAX_TOKEN_LENGTH As Integer
Public Const DEFAULT_MAX_TOKEN_LENGTH As Integer
public:
literal int DEFAULT_MAX_TOKEN_LENGTH
public:
literal int DEFAULT_MAX_TOKEN_LENGTH
See Also
StandardAnalyzer Class
StandardAnalyzer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


STOP_WORDS_SET Field

StandardAnalyzer STOP_WORDS_SET Field Lucene.Net Class Library
An unmodifiable set containing some common English words that are usually not useful for searching.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ISet<string> STOP_WORDS_SET
public static readonly ISet<string> STOP_WORDS_SET
Public Shared ReadOnly STOP_WORDS_SET As ISet(Of String)
Public Shared ReadOnly STOP_WORDS_SET As ISet(Of String)
public:
static initonly ISet<String^>^ STOP_WORDS_SET
public:
static initonly ISet<String^>^ STOP_WORDS_SET
See Also
StandardAnalyzer Class
StandardAnalyzer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardAnalyzer Methods

StandardAnalyzer Methods Lucene.Net Class Library
The StandardAnalyzer type exposes the following members.
Methods
 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Dispose | (Inherited from Analyzer.)
Protected method | Dispose(Boolean) | (Inherited from Analyzer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetOffsetGap | Just like GetPositionIncrementGap(String), except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReusableTokenStream | (Overrides Analyzer ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod TClass | Obsolete. Java uses Class<? extends Analyer> to constrain TClass to only Types that inherit from Analyzer. C# does not have a generic type class, ie Type<t>. The method signature stays the same, and an exception may still be thrown, if the method doesn't exist. (Inherited from Analyzer.)
Public method | TokenStream | Constructs a StandardTokenizer filtered by a StandardFilter , a LowerCaseFilter and a StopFilter. (Overrides Analyzer TokenStream(String, TextReader).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReusableTokenStream Method

StandardAnalyzer ReusableTokenStream Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override
Parameters
fieldName
Type:   Online System String
reader
Type:   Online System.IO TextReader
See Also
StandardAnalyzer Class
StandardAnalyzer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStream Method

StandardAnalyzer TokenStream Method Lucene.Net Class Library
Constructs a StandardTokenizer filtered by a StandardFilter , a LowerCaseFilter and a StopFilter.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override
Parameters
fieldName
Type:   Online System String
reader
Type:   Online System.IO TextReader
See Also
StandardAnalyzer Class
StandardAnalyzer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardAnalyzer Properties

StandardAnalyzer Properties Lucene.Net Class Library
The StandardAnalyzer type exposes the following members.
Properties
 | Name | Description
Public property | MaxTokenLength | Set maximum allowed token length. If a token is seen that exceeds this length then it is discarded. This setting only takes effect the next time tokenStream or reusableTokenStream is called.
Protected property | PreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Back to Top
See Also
StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxTokenLength Property

StandardAnalyzer MaxTokenLength Property Lucene.Net Class Library
Set maximum allowed token length. If a token is seen that exceeds this length then it is discarded. This setting only takes effect the next time tokenStream or reusableTokenStream is called.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int MaxTokenLength { get; set; }
public virtual int MaxTokenLength { get; set; }
Public Overridable Property MaxTokenLength As Integer
    Get
    Set
Public Overridable Property MaxTokenLength As Integer
    Get
    Set
public:
virtual property int MaxTokenLength {
    int get ();
    void set (int value);
}
public:
virtual property int MaxTokenLength {
    int get ();
    void set (int value);
}
See Also
StandardAnalyzer Class
StandardAnalyzer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardFilter Class

StandardFilter Class Lucene.Net Class Library
Normalizes tokens extracted with StandardTokenizer.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis TokenFilter
Lucene.Net.Analysis.Standard StandardFilter

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class StandardFilter : TokenFilter
public sealed class StandardFilter : TokenFilter
Public NotInheritable Class StandardFilter _
    Inherits TokenFilter
Public NotInheritable Class StandardFilter _
    Inherits TokenFilter
public ref class StandardFilter sealed : public TokenFilter
public ref class StandardFilter sealed : public TokenFilter
See Also
StandardFilter Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardFilter Members

StandardFilter Members Lucene.Net Class Library

The StandardFilter type exposes the following members.
Constructors
 | Name | Description
Public method | StandardFilter | Construct filtering in.
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | Performs end-of-stream operations, if any, and calls then end() on the input TokenStream. NOTE: Be sure to call super.end() first when overriding this method. (Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | Returns the next token in the stream, or null at EOS. Removes 's from the end of words. Removes dots from acronyms. (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Reset the filter as well as the input TokenStream. (Inherited from TokenFilter.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
StandardFilter Class
Lucene.Net.Analysis.Standard Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardFilter Constructor

StandardFilter Constructor Lucene.Net Class Library
Construct filtering in.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StandardFilter(
    TokenStream in_Renamed
)
public StandardFilter(
    TokenStream in_Renamed
)
Public Sub New ( _
    in_Renamed As TokenStream _
)
Public Sub New ( _
    in_Renamed As TokenStream _
)
public:
StandardFilter(
    TokenStream^ in_Renamed
)
public:
StandardFilter(
    TokenStream^ in_Renamed
)
Parameters
in_Renamed
Type: Lucene.Net.Analysis TokenStream
See Also
StandardFilter Class
StandardFilter Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardFilter Fields

StandardFilter Fields Lucene.Net Class Library
The StandardFilter type exposes the following members.
Fields
 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Back to Top
See Also
StandardFilter Class
Lucene.Net.Analysis.Standard Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardFilter Methods

StandardFilter Methods Lucene.Net Class Library
The StandardFilter type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from TokenFilter.)
Public method | End | Performs end-of-stream operations, if any, and calls then end() on the input TokenStream. NOTE: Be sure to call super.end() first when overriding this method. (Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | Returns the next token in the stream, or null at EOS. Removes 's from the end of words. Removes dots from acronyms. (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Reset the filter as well as the input TokenStream. (Inherited from TokenFilter.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
StandardFilter Class
Lucene.Net.Analysis.Standard Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncrementToken Method

StandardFilter IncrementToken Method Lucene.Net Class Library
Returns the next token in the stream, or null at EOS.

Removes 's from the end of words.

Removes dots from acronyms.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IncrementToken()
public override bool IncrementToken()
Public Overrides Function IncrementToken As Boolean
Public Overrides Function IncrementToken As Boolean
public:
virtual bool IncrementToken() override
public:
virtual bool IncrementToken() override
See Also
StandardFilter Class
StandardFilter Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardFilter Properties

StandardFilter Properties Lucene.Net Class Library
The StandardFilter type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Back to Top
See Also
StandardFilter Class
Lucene.Net.Analysis.Standard Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardTokenizer Class

StandardTokenizer Class Lucene.Net Class Library
A grammar-based tokenizer constructed with JFlex

This should be a good tokenizer for most European-language documents:
  • Splits words at punctuation characters, removing punctuation. However, a dot that's not followed by whitespace is considered part of a token.
  • Splits words at hyphens, unless there's a number in the token, in which case the whole token is interpreted as a product number and is not split.
  • Recognizes email addresses and internet hostnames as one token.

Many applications have specific tokenizer needs. If this tokenizer does not suit your application, please consider copying this source code directory to your project and maintaining your own grammar-based tokenizer.

You must specify the required Version compatibility when creating StandardAnalyzer:
  • As of 2.4, Tokens incorrectly identified as acronyms are corrected (see Online LUCENE-1608
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream
Lucene.Net.Analysis Tokenizer
Lucene.Net.Analysis.Standard StandardTokenizer

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class StandardTokenizer : Tokenizer
public sealed class StandardTokenizer : Tokenizer
Public NotInheritable Class StandardTokenizer _
    Inherits Tokenizer
Public NotInheritable Class StandardTokenizer _
    Inherits Tokenizer
public ref class StandardTokenizer sealed : public Tokenizer
public ref class StandardTokenizer sealed : public Tokenizer
See Also
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardTokenizer Members

StandardTokenizer Members Lucene.Net Class Library

The StandardTokenizer type exposes the following members.
Constructors
 | Name | Description
Public method | StandardTokenizer(Version, TextReader) | Creates a new instance of the StandardTokenizer. Attaches the input to the newly created JFlex scanner.
Public method | StandardTokenizer(Version, AttributeSource, TextReader) | Creates a new StandardTokenizer with a given AttributeSource.
Public method | StandardTokenizer(Version, AttributeSource AttributeFactory, TextReader) | Creates a new StandardTokenizer with a given AttributeSource AttributeFactory
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Protected method | CorrectOffset | Return the corrected offset. If input is a CharStream subclass this method calls CorrectOffset(Int32), else returns currentOff. (Inherited from Tokenizer.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from Tokenizer.)
Public method | End | (Overrides TokenStream End .)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (non-Javadoc) IncrementToken (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ). (Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer Reset(TextReader).)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | SetReplaceInvalidAcronym | Obsolete. Remove in 3.X and make true the only valid value See https://issues.apache.org/jira/browse/LUCENE-1068
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
Fields
 | Name | Description
 | ACRONYM |
 | ACRONYM_DEP | Obsolete.
 | ALPHANUM |
 | APOSTROPHE |
 | CJ |
 | COMPANY |
 | EMAIL |
 | HOST |
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)
 | NUM |
 | TOKEN_TYPES | String token types that correspond to token type int constants
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Public property | MaxTokenLength | Set the max allowed token length. Any token longer than this is skipped.
Back to Top
See Also
StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardTokenizer Constructor

StandardTokenizer Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | StandardTokenizer(Version, TextReader) | Creates a new instance of the StandardTokenizer. Attaches the input to the newly created JFlex scanner.
Public method | StandardTokenizer(Version, AttributeSource, TextReader) | Creates a new StandardTokenizer with a given AttributeSource.
Public method | StandardTokenizer(Version, AttributeSource AttributeFactory, TextReader) | Creates a new StandardTokenizer with a given AttributeSource AttributeFactory
Back to Top
See Also
StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardTokenizer Constructor (Version, TextReader)

StandardTokenizer Constructor (Version, TextReader) Lucene.Net Class Library
Creates a new instance of the StandardTokenizer. Attaches the input to the newly created JFlex scanner.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StandardTokenizer(
    Version matchVersion,
    TextReader input
)
public StandardTokenizer(
    Version matchVersion,
    TextReader input
)
Public Sub New ( _
    matchVersion As Version, _
    input As TextReader _
)
Public Sub New ( _
    matchVersion As Version, _
    input As TextReader _
)
public:
StandardTokenizer(
    Version matchVersion,
    TextReader^ input
)
public:
StandardTokenizer(
    Version matchVersion,
    TextReader^ input
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
input
Type:   Online System.IO TextReader
The input reader

            See http://issues.apache.org/jira/browse/LUCENE-1068

See Also
StandardTokenizer Class
StandardTokenizer Members
StandardTokenizer Overload
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardTokenizer Constructor (Version, AttributeSource, TextReader)

StandardTokenizer Constructor (Version, AttributeSource, TextReader) Lucene.Net Class Library
Creates a new StandardTokenizer with a given AttributeSource.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StandardTokenizer(
    Version matchVersion,
    AttributeSource source,
    TextReader input
)
public StandardTokenizer(
    Version matchVersion,
    AttributeSource source,
    TextReader input
)
Public Sub New ( _
    matchVersion As Version, _
    source As AttributeSource, _
    input As TextReader _
)
Public Sub New ( _
    matchVersion As Version, _
    source As AttributeSource, _
    input As TextReader _
)
public:
StandardTokenizer(
    Version matchVersion,
    AttributeSource^ source,
    TextReader^ input
)
public:
StandardTokenizer(
    Version matchVersion,
    AttributeSource^ source,
    TextReader^ input
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
source
Type: Lucene.Net.Util AttributeSource
input
Type:   Online System.IO TextReader
See Also
StandardTokenizer Class
StandardTokenizer Members
StandardTokenizer Overload
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardTokenizer Constructor (Version, AttributeSource.AttributeFactory, TextReader)

StandardTokenizer Constructor (Version, AttributeSource AttributeFactory, TextReader) Lucene.Net Class Library
Creates a new StandardTokenizer with a given AttributeSource AttributeFactory

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StandardTokenizer(
    Version matchVersion,
    AttributeSource..::..AttributeFactory factory,
    TextReader input
)
public StandardTokenizer(
    Version matchVersion,
    AttributeSource..::..AttributeFactory factory,
    TextReader input
)
Public Sub New ( _
    matchVersion As Version, _
    factory As AttributeSource..::..AttributeFactory, _
    input As TextReader _
)
Public Sub New ( _
    matchVersion As Version, _
    factory As AttributeSource..::..AttributeFactory, _
    input As TextReader _
)
public:
StandardTokenizer(
    Version matchVersion,
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ input
)
public:
StandardTokenizer(
    Version matchVersion,
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ input
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
factory
Type: Lucene.Net.Util AttributeSource AttributeFactory
input
Type:   Online System.IO TextReader
See Also
StandardTokenizer Class
StandardTokenizer Members
StandardTokenizer Overload
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardTokenizer Fields

StandardTokenizer Fields Lucene.Net Class Library
The StandardTokenizer type exposes the following members.
Fields
 | Name | Description
 | ACRONYM |
 | ACRONYM_DEP | Obsolete.
 | ALPHANUM |
 | APOSTROPHE |
 | CJ |
 | COMPANY |
 | EMAIL |
 | HOST |
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)
 | NUM |
 | TOKEN_TYPES | String token types that correspond to token type int constants
Back to Top
See Also
StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ACRONYM Field

StandardTokenizer ACRONYM Field Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int ACRONYM
public const int ACRONYM
Public Const ACRONYM As Integer
Public Const ACRONYM As Integer
public:
literal int ACRONYM
public:
literal int ACRONYM
See Also
StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ACRONYM_DEP Field

StandardTokenizer ACRONYM_DEP Field Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("this solves a bug where HOSTs that end with '.' are identified as ACRONYMs.")]
public const int ACRONYM_DEP
[ObsoleteAttribute("this solves a bug where HOSTs that end with '.' are identified as ACRONYMs.")]
public const int ACRONYM_DEP
<ObsoleteAttribute("this solves a bug where HOSTs that end with '.' are identified as ACRONYMs.")> _
Public Const ACRONYM_DEP As Integer
<ObsoleteAttribute("this solves a bug where HOSTs that end with '.' are identified as ACRONYMs.")> _
Public Const ACRONYM_DEP As Integer
public:
[ObsoleteAttribute(L"this solves a bug where HOSTs that end with '.' are identified as ACRONYMs.")]
literal int ACRONYM_DEP
public:
[ObsoleteAttribute(L"this solves a bug where HOSTs that end with '.' are identified as ACRONYMs.")]
literal int ACRONYM_DEP
See Also
StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ALPHANUM Field

StandardTokenizer ALPHANUM Field Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int ALPHANUM
public const int ALPHANUM
Public Const ALPHANUM As Integer
Public Const ALPHANUM As Integer
public:
literal int ALPHANUM
public:
literal int ALPHANUM
See Also
StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


APOSTROPHE Field

StandardTokenizer APOSTROPHE Field Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int APOSTROPHE
public const int APOSTROPHE
Public Const APOSTROPHE As Integer
Public Const APOSTROPHE As Integer
public:
literal int APOSTROPHE
public:
literal int APOSTROPHE
See Also
StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CJ Field

StandardTokenizer CJ Field Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int CJ
public const int CJ
Public Const CJ As Integer
Public Const CJ As Integer
public:
literal int CJ
public:
literal int CJ
See Also
StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


COMPANY Field

StandardTokenizer COMPANY Field Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int COMPANY
public const int COMPANY
Public Const COMPANY As Integer
Public Const COMPANY As Integer
public:
literal int COMPANY
public:
literal int COMPANY
See Also
StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EMAIL Field

StandardTokenizer EMAIL Field Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int EMAIL
public const int EMAIL
Public Const EMAIL As Integer
Public Const EMAIL As Integer
public:
literal int EMAIL
public:
literal int EMAIL
See Also
StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HOST Field

StandardTokenizer HOST Field Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int HOST
public const int HOST
Public Const HOST As Integer
Public Const HOST As Integer
public:
literal int HOST
public:
literal int HOST
See Also
StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NUM Field

StandardTokenizer NUM Field Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int NUM
public const int NUM
Public Const NUM As Integer
Public Const NUM As Integer
public:
literal int NUM
public:
literal int NUM
See Also
StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TOKEN_TYPES Field

StandardTokenizer TOKEN_TYPES Field Lucene.Net Class Library
String token types that correspond to token type int constants

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] TOKEN_TYPES
public static readonly string[] TOKEN_TYPES
Public Shared ReadOnly TOKEN_TYPES As String()
Public Shared ReadOnly TOKEN_TYPES As String()
public:
static initonly array<String^>^ TOKEN_TYPES
public:
static initonly array<String^>^ TOKEN_TYPES
See Also
StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardTokenizer Methods

StandardTokenizer Methods Lucene.Net Class Library
The StandardTokenizer type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. (Inherited from AttributeSource.)
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory (Inherited from AttributeSource.)
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource. (Inherited from AttributeSource.)
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation. (Inherited from AttributeSource.)
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource)) (Inherited from AttributeSource.)
Public method | Close | Obsolete. Releases resources associated with this stream. (Inherited from TokenStream.)
Protected method | CorrectOffset | Return the corrected offset. If input is a CharStream subclass this method calls CorrectOffset(Int32), else returns currentOff. (Inherited from Tokenizer.)
Public method | Dispose | (Inherited from TokenStream.)
Protected method | Dispose(Boolean) | (Inherited from Tokenizer.)
Public method | End | (Overrides TokenStream End .)
Public method | Equals | (Inherited from AttributeSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource (Inherited from AttributeSource.)
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator() (Inherited from AttributeSource.)
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys (Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. (Inherited from AttributeSource.)
Public method | IncrementToken | (non-Javadoc) IncrementToken (Overrides TokenStream IncrementToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ). (Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer Reset(TextReader).)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream. (Inherited from AttributeSource.)
Public method | SetReplaceInvalidAcronym | Obsolete. Remove in 3.X and make true the only valid value See https://issues.apache.org/jira/browse/LUCENE-1068
Public method | ToString | (Inherited from AttributeSource.)
Back to Top
See Also
StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


End Method

StandardTokenizer End Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void End()
public override void End()
Public Overrides Sub End
Public Overrides Sub End
public:
virtual void End() override
public:
virtual void End() override
See Also
StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncrementToken Method

StandardTokenizer IncrementToken Method Lucene.Net Class Library
(non-Javadoc) IncrementToken

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IncrementToken()
public override bool IncrementToken()
Public Overrides Function IncrementToken As Boolean
Public Overrides Function IncrementToken As Boolean
public:
virtual bool IncrementToken() override
public:
virtual bool IncrementToken() override
See Also
StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method

StandardTokenizer Reset Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Reset | Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. Reset is not needed for the standard indexing process. However, if the tokens of a TokenStream are intended to be consumed more than once, it is necessary to implement Reset . Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after Reset ). (Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer Reset(TextReader).)
Back to Top
See Also
StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method (TextReader)

StandardTokenizer Reset Method (TextReader) Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Reset(
    TextReader reader
)
public override void Reset(
    TextReader reader
)
Public Overrides Sub Reset ( _
    reader As TextReader _
)
Public Overrides Sub Reset ( _
    reader As TextReader _
)
public:
virtual void Reset(
    TextReader^ reader
) override
public:
virtual void Reset(
    TextReader^ reader
) override
Parameters
reader
Type:   Online System.IO TextReader
See Also
StandardTokenizer Class
StandardTokenizer Members
Reset Overload
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetReplaceInvalidAcronym Method

StandardTokenizer SetReplaceInvalidAcronym Method Lucene.Net Class Library
Remove in 3.X and make true the only valid value See https://issues.apache.org/jira/browse/LUCENE-1068

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Remove in 3.X and make true the only valid value. See https://issues.apache.org/jira/browse/LUCENE-1068")]
public void SetReplaceInvalidAcronym(
    bool replaceInvalidAcronym
)
[ObsoleteAttribute("Remove in 3.X and make true the only valid value. See https://issues.apache.org/jira/browse/LUCENE-1068")]
public void SetReplaceInvalidAcronym(
    bool replaceInvalidAcronym
)
<ObsoleteAttribute("Remove in 3.X and make true the only valid value. See https://issues.apache.org/jira/browse/LUCENE-1068")> _
Public Sub SetReplaceInvalidAcronym ( _
    replaceInvalidAcronym As Boolean _
)
<ObsoleteAttribute("Remove in 3.X and make true the only valid value. See https://issues.apache.org/jira/browse/LUCENE-1068")> _
Public Sub SetReplaceInvalidAcronym ( _
    replaceInvalidAcronym As Boolean _
)
public:
[ObsoleteAttribute(L"Remove in 3.X and make true the only valid value. See https://issues.apache.org/jira/browse/LUCENE-1068")]
void SetReplaceInvalidAcronym(
    bool replaceInvalidAcronym
)
public:
[ObsoleteAttribute(L"Remove in 3.X and make true the only valid value. See https://issues.apache.org/jira/browse/LUCENE-1068")]
void SetReplaceInvalidAcronym(
    bool replaceInvalidAcronym
)
Parameters
replaceInvalidAcronym
Type:   Online System Boolean
Set to true to replace mischaracterized acronyms as HOST.

See Also
StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StandardTokenizer Properties

StandardTokenizer Properties Lucene.Net Class Library
The StandardTokenizer type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory. (Inherited from AttributeSource.)
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes (Inherited from AttributeSource.)
Public property | MaxTokenLength | Set the max allowed token length. Any token longer than this is skipped.
Back to Top
See Also
StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxTokenLength Property

StandardTokenizer MaxTokenLength Property Lucene.Net Class Library
Set the max allowed token length. Any token longer than this is skipped.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxTokenLength { get; set; }
public int MaxTokenLength { get; set; }
Public Property MaxTokenLength As Integer
    Get
    Set
Public Property MaxTokenLength As Integer
    Get
    Set
public:
property int MaxTokenLength {
    int get ();
    void set (int value);
}
public:
property int MaxTokenLength {
    int get ();
    void set (int value);
}
See Also
StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lucene.Net.Analysis.Tokenattributes Namespace

Lucene.Net.Analysis.Tokenattributes Namespace Lucene.Net Class Library
Classes
 | Class | Description
Public class | FlagsAttribute | This attribute can be used to pass different flags down the tokenizer chain, eg from one TokenFilter to another one.
Public class | OffsetAttribute | The start and end character offset of a Token.
Public class | PayloadAttribute | The payload of a Token. See also Payload.
Public class | PositionIncrementAttribute | The positionIncrement determines the position of this token relative to the previous Token in a TokenStream, used in phrase searching. The default value is one. Some common uses for this are:Set it to zero to put multiple terms in the same position. This is useful if, e.g., a word has multiple stems. Searches for phrases including either stem will match. In this case, all but the first stem's increment should be set to zero: the increment of the first instance should be one. Repeating a token with an increment of zero can also be used to boost the scores of matches on that token.Set it to values greater than one to inhibit exact phrase matches. If, for example, one does not want phrases to match across removed stop words, then one could build a stop word filter that removes stop words and also sets the increment to the number of stop words removed before each non-stop word. Then exact phrase queries will only match when the terms occur with no intervening stop words.
Public class | TermAttribute | The term text of a Token.
Public class | TypeAttribute | A Token's lexical type. The Default value is "word".
Interfaces
 | Interface | Description
Public interface | IFlagsAttribute | This attribute can be used to pass different flags down the Tokenizer chain, eg from one TokenFilter to another one.
Public interface | IOffsetAttribute | The start and end character offset of a Token.
Public interface | IPayloadAttribute | The payload of a Token. See also Payload.
Public interface | IPositionIncrementAttribute | The positionIncrement determines the position of this token relative to the previous Token in a TokenStream, used in phrase searching. The default value is one. Some common uses for this are:Set it to zero to put multiple terms in the same position. This is useful if, e.g., a word has multiple stems. Searches for phrases including either stem will match. In this case, all but the first stem's increment should be set to zero: the increment of the first instance should be one. Repeating a token with an increment of zero can also be used to boost the scores of matches on that token.Set it to values greater than one to inhibit exact phrase matches. If, for example, one does not want phrases to match across removed stop words, then one could build a stop word filter that removes stop words and also sets the increment to the number of stop words removed before each non-stop word. Then exact phrase queries will only match when the terms occur with no intervening stop words.
Public interface | ITermAttribute | The term text of a Token.
Public interface | ITypeAttribute | A Token's lexical type. The Default value is "word".

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FlagsAttribute Class

FlagsAttribute Class Lucene.Net Class Library
This attribute can be used to pass different flags down the tokenizer chain, eg from one TokenFilter to another one.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util Attribute
Lucene.Net.Analysis.Tokenattributes FlagsAttribute

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FlagsAttribute : Attribute,
    IFlagsAttribute, IAttribute, ICloneable
[SerializableAttribute]
public class FlagsAttribute : Attribute,
    IFlagsAttribute, IAttribute, ICloneable
<SerializableAttribute> _
Public Class FlagsAttribute _
    Inherits Attribute _
    Implements IFlagsAttribute, IAttribute, ICloneable
<SerializableAttribute> _
Public Class FlagsAttribute _
    Inherits Attribute _
    Implements IFlagsAttribute, IAttribute, ICloneable
[SerializableAttribute]
public ref class FlagsAttribute : public Attribute,
    IFlagsAttribute, IAttribute, ICloneable
[SerializableAttribute]
public ref class FlagsAttribute : public Attribute,
    IFlagsAttribute, IAttribute, ICloneable
See Also
FlagsAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FlagsAttribute Members

FlagsAttribute Members Lucene.Net Class Library

The FlagsAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | FlagsAttribute | Initializes a new instance of the FlagsAttribute class
Back to Top
Methods
Name | Description
Public method | Clear | (Overrides Attribute Clear .)
Public method | Clone | (Overrides Attribute Clone .)
Public method | CopyTo | (Overrides Attribute CopyTo(Attribute).)
Public method | Equals | (Overrides Attribute Equals(Object).)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method | GetHashCode | (Overrides Attribute GetHashCode .)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
View Colorized Copy to Clipboard Print
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
This method may be overridden by subclasses.
(Inherited from Attribute.)
Back to Top
Properties
 | Name | Description
Public property | Flags | EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long. Get the bitset for any bits that have been set. This is completely distinct from Type, although they do share similar purposes. The flags can be used to encode information about the token for use by other TokenFilters.
Back to Top
See Also
FlagsAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FlagsAttribute Constructor

FlagsAttribute Constructor Lucene.Net Class Library
Initializes a new instance of the FlagsAttribute class

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FlagsAttribute()
public FlagsAttribute()
Public Sub New
Public Sub New
public:
FlagsAttribute()
public:
FlagsAttribute()
See Also
FlagsAttribute Class
FlagsAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FlagsAttribute Methods

FlagsAttribute Methods Lucene.Net Class Library
The FlagsAttribute type exposes the following members.
Methods
Name | Description
Public method | Clear | (Overrides Attribute Clear .)
Public method | Clone | (Overrides Attribute Clone .)
Public method | CopyTo | (Overrides Attribute CopyTo(Attribute).)
Public method | Equals | (Overrides Attribute Equals(Object).)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method | GetHashCode | (Overrides Attribute GetHashCode .)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
View Colorized Copy to Clipboard Print
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
This method may be overridden by subclasses.
(Inherited from Attribute.)
Back to Top
See Also
FlagsAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method

FlagsAttribute Clear Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Clear()
public override void Clear()
Public Overrides Sub Clear
Public Overrides Sub Clear
public:
virtual void Clear() override
public:
virtual void Clear() override
See Also
FlagsAttribute Class
FlagsAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

FlagsAttribute Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
FlagsAttribute Class
FlagsAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CopyTo Method

FlagsAttribute CopyTo Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void CopyTo(
    Attribute target
)
public override void CopyTo(
    Attribute target
)
Public Overrides Sub CopyTo ( _
    target As Attribute _
)
Public Overrides Sub CopyTo ( _
    target As Attribute _
)
public:
virtual void CopyTo(
    Attribute^ target
) override
public:
virtual void CopyTo(
    Attribute^ target
) override
Parameters
target
Type: Lucene.Net.Util Attribute
See Also
FlagsAttribute Class
FlagsAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

FlagsAttribute Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object other
)
public override bool Equals(
    Object other
)
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ other
) override
public:
virtual bool Equals(
    Object^ other
) override
Parameters
other
Type:   Online System Object
See Also
FlagsAttribute Class
FlagsAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

FlagsAttribute GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
FlagsAttribute Class
FlagsAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FlagsAttribute Properties

FlagsAttribute Properties Lucene.Net Class Library
The FlagsAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Flags | EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long. Get the bitset for any bits that have been set. This is completely distinct from Type, although they do share similar purposes. The flags can be used to encode information about the token for use by other TokenFilters.
Back to Top
See Also
FlagsAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Flags Property

FlagsAttribute Flags Property Lucene.Net Class Library
EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long.

Get the bitset for any bits that have been set. This is completely distinct from Type, although they do share similar purposes. The flags can be used to encode information about the token for use by other TokenFilters.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Flags { get; set; }
public virtual int Flags { get; set; }
Public Overridable Property Flags As Integer
    Get
    Set
Public Overridable Property Flags As Integer
    Get
    Set
public:
virtual property int Flags {
    int get ();
    void set (int value);
}
public:
virtual property int Flags {
    int get ();
    void set (int value);
}
Field Value
 The bits
Implements
IFlagsAttribute Flags
See Also
FlagsAttribute Class
FlagsAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IFlagsAttribute Interface

IFlagsAttribute Interface Lucene.Net Class Library
This attribute can be used to pass different flags down the Tokenizer chain, eg from one TokenFilter to another one.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IFlagsAttribute : IAttribute
public interface IFlagsAttribute : IAttribute
Public Interface IFlagsAttribute _
    Inherits IAttribute
Public Interface IFlagsAttribute _
    Inherits IAttribute
public interface class IFlagsAttribute : IAttribute
public interface class IFlagsAttribute : IAttribute
See Also
IFlagsAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IFlagsAttribute Members

IFlagsAttribute Members Lucene.Net Class Library

The IFlagsAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Flags | EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long. Get the bitset for any bits that have been set. This is completely distinct from Type, although they do share similar purposes. The flags can be used to encode information about the token for use by other TokenFilters.
Back to Top
See Also
IFlagsAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IFlagsAttribute Properties

IFlagsAttribute Properties Lucene.Net Class Library
The IFlagsAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Flags | EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long. Get the bitset for any bits that have been set. This is completely distinct from Type, although they do share similar purposes. The flags can be used to encode information about the token for use by other TokenFilters.
Back to Top
See Also
IFlagsAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Flags Property

IFlagsAttribute Flags Property Lucene.Net Class Library
EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long.

Get the bitset for any bits that have been set. This is completely distinct from Type, although they do share similar purposes. The flags can be used to encode information about the token for use by other TokenFilters.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int Flags { get; set; }
int Flags { get; set; }
Property Flags As Integer
    Get
    Set
Property Flags As Integer
    Get
    Set
property int Flags {
    int get ();
    void set (int value);
}
property int Flags {
    int get ();
    void set (int value);
}
Field Value
 The bits
See Also
IFlagsAttribute Interface
IFlagsAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IOffsetAttribute Interface

IOffsetAttribute Interface Lucene.Net Class Library
The start and end character offset of a Token.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IOffsetAttribute : IAttribute
public interface IOffsetAttribute : IAttribute
Public Interface IOffsetAttribute _
    Inherits IAttribute
Public Interface IOffsetAttribute _
    Inherits IAttribute
public interface class IOffsetAttribute : IAttribute
public interface class IOffsetAttribute : IAttribute
See Also
IOffsetAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IOffsetAttribute Members

IOffsetAttribute Members Lucene.Net Class Library

The IOffsetAttribute type exposes the following members.
Methods
 | Name | Description
Public method | SetOffset | Set the starting and ending offset. See StartOffset() and EndOffset()
Back to Top
Properties
 | Name | Description
Public property | EndOffset | Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).
Public property | StartOffset | Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.
Back to Top
See Also
IOffsetAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IOffsetAttribute Methods

IOffsetAttribute Methods Lucene.Net Class Library
The IOffsetAttribute type exposes the following members.
Methods
 | Name | Description
Public method | SetOffset | Set the starting and ending offset. See StartOffset() and EndOffset()
Back to Top
See Also
IOffsetAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetOffset Method

IOffsetAttribute SetOffset Method Lucene.Net Class Library
Set the starting and ending offset. See StartOffset() and EndOffset()

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void SetOffset(
    int startOffset,
    int endOffset
)
void SetOffset(
    int startOffset,
    int endOffset
)
Sub SetOffset ( _
    startOffset As Integer, _
    endOffset As Integer _
)
Sub SetOffset ( _
    startOffset As Integer, _
    endOffset As Integer _
)
void SetOffset(
    int startOffset,
    int endOffset
)
void SetOffset(
    int startOffset,
    int endOffset
)
Parameters
startOffset
Type:   Online System Int32
endOffset
Type:   Online System Int32
See Also
IOffsetAttribute Interface
IOffsetAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IOffsetAttribute Properties

IOffsetAttribute Properties Lucene.Net Class Library
The IOffsetAttribute type exposes the following members.
Properties
 | Name | Description
Public property | EndOffset | Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).
Public property | StartOffset | Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.
Back to Top
See Also
IOffsetAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EndOffset Property

IOffsetAttribute EndOffset Property Lucene.Net Class Library
Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int EndOffset { get; }
int EndOffset { get; }
ReadOnly Property EndOffset As Integer
    Get
ReadOnly Property EndOffset As Integer
    Get
property int EndOffset {
    int get ();
}
property int EndOffset {
    int get ();
}
See Also
IOffsetAttribute Interface
IOffsetAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StartOffset Property

IOffsetAttribute StartOffset Property Lucene.Net Class Library
Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int StartOffset { get; }
int StartOffset { get; }
ReadOnly Property StartOffset As Integer
    Get
ReadOnly Property StartOffset As Integer
    Get
property int StartOffset {
    int get ();
}
property int StartOffset {
    int get ();
}
See Also
IOffsetAttribute Interface
IOffsetAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IPayloadAttribute Interface

IPayloadAttribute Interface Lucene.Net Class Library
The payload of a Token. See also Payload.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPayloadAttribute : IAttribute
public interface IPayloadAttribute : IAttribute
Public Interface IPayloadAttribute _
    Inherits IAttribute
Public Interface IPayloadAttribute _
    Inherits IAttribute
public interface class IPayloadAttribute : IAttribute
public interface class IPayloadAttribute : IAttribute
See Also
IPayloadAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IPayloadAttribute Members

IPayloadAttribute Members Lucene.Net Class Library

The IPayloadAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Payload | Returns this Token's payload.
Back to Top
See Also
IPayloadAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IPayloadAttribute Properties

IPayloadAttribute Properties Lucene.Net Class Library
The IPayloadAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Payload | Returns this Token's payload.
Back to Top
See Also
IPayloadAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Payload Property

IPayloadAttribute Payload Property Lucene.Net Class Library
Returns this Token's payload.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Payload Payload { get; set; }
Payload Payload { get; set; }
Property Payload As Payload
    Get
    Set
Property Payload As Payload
    Get
    Set
property Payload^ Payload {
    Payload^ get ();
    void set (Payload^ value);
}
property Payload^ Payload {
    Payload^ get ();
    void set (Payload^ value);
}
See Also
IPayloadAttribute Interface
IPayloadAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IPositionIncrementAttribute Interface

IPositionIncrementAttribute Interface Lucene.Net Class Library
The positionIncrement determines the position of this token relative to the previous Token in a TokenStream, used in phrase searching.

The default value is one.

Some common uses for this are:Set it to zero to put multiple terms in the same position. This is useful if, e.g., a word has multiple stems. Searches for phrases including either stem will match. In this case, all but the first stem's increment should be set to zero: the increment of the first instance should be one. Repeating a token with an increment of zero can also be used to boost the scores of matches on that token.Set it to values greater than one to inhibit exact phrase matches. If, for example, one does not want phrases to match across removed stop words, then one could build a stop word filter that removes stop words and also sets the increment to the number of stop words removed before each non-stop word. Then exact phrase queries will only match when the terms occur with no intervening stop words.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPositionIncrementAttribute : IAttribute
public interface IPositionIncrementAttribute : IAttribute
Public Interface IPositionIncrementAttribute _
    Inherits IAttribute
Public Interface IPositionIncrementAttribute _
    Inherits IAttribute
public interface class IPositionIncrementAttribute : IAttribute
public interface class IPositionIncrementAttribute : IAttribute
See Also
IPositionIncrementAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Lucene.Net.Index TermPositions
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IPositionIncrementAttribute Members

IPositionIncrementAttribute Members Lucene.Net Class Library

The IPositionIncrementAttribute type exposes the following members.
Properties
 | Name | Description
Public property | PositionIncrement | Gets or sets the position increment. The default value is one.
Back to Top
See Also
IPositionIncrementAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IPositionIncrementAttribute Properties

IPositionIncrementAttribute Properties Lucene.Net Class Library
The IPositionIncrementAttribute type exposes the following members.
Properties
 | Name | Description
Public property | PositionIncrement | Gets or sets the position increment. The default value is one.
Back to Top
See Also
IPositionIncrementAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionIncrement Property

IPositionIncrementAttribute PositionIncrement Property Lucene.Net Class Library
Gets or sets the position increment. The default value is one.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int PositionIncrement { get; set; }
int PositionIncrement { get; set; }
Property PositionIncrement As Integer
    Get
    Set
Property PositionIncrement As Integer
    Get
    Set
property int PositionIncrement {
    int get ();
    void set (int value);
}
property int PositionIncrement {
    int get ();
    void set (int value);
}
Field Value
 the distance from the prior term
See Also
IPositionIncrementAttribute Interface
IPositionIncrementAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ITermAttribute Interface

ITermAttribute Interface Lucene.Net Class Library
The term text of a Token.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITermAttribute : IAttribute
public interface ITermAttribute : IAttribute
Public Interface ITermAttribute _
    Inherits IAttribute
Public Interface ITermAttribute _
    Inherits IAttribute
public interface class ITermAttribute : IAttribute
public interface class ITermAttribute : IAttribute
See Also
ITermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ITermAttribute Members

ITermAttribute Members Lucene.Net Class Library

The ITermAttribute type exposes the following members.
Methods
 | Name | Description
Public method | ResizeTermBuffer | Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use SetTermBuffer( Char , Int32, Int32), SetTermBuffer(String), or SetTermBuffer(String, Int32, Int32) to optimally combine the resize with the setting of the termBuffer.
Public method | SetTermBuffer(String) | Copies the contents of buffer into the termBuffer array.
Public method | SetTermBuffer( Char , Int32, Int32) | Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method | SetTermBuffer(String, Int32, Int32) | Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.
Public method | SetTermLength | Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use ResizeTermBuffer(Int32) first.
Public method | TermBuffer | Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use ResizeTermBuffer(Int32) to increase it. After altering the buffer be sure to call SetTermLength(Int32) to record the number of valid characters that were placed into the termBuffer.
Public method | TermLength | Return number of valid characters (length of the term) in the termBuffer array.
Back to Top
Properties
 | Name | Description
Public property | Term | Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use TermBuffer and TermLength directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())
Back to Top
See Also
ITermAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ITermAttribute Methods

ITermAttribute Methods Lucene.Net Class Library
The ITermAttribute type exposes the following members.
Methods
 | Name | Description
Public method | ResizeTermBuffer | Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use SetTermBuffer( Char , Int32, Int32), SetTermBuffer(String), or SetTermBuffer(String, Int32, Int32) to optimally combine the resize with the setting of the termBuffer.
Public method | SetTermBuffer(String) | Copies the contents of buffer into the termBuffer array.
Public method | SetTermBuffer( Char , Int32, Int32) | Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method | SetTermBuffer(String, Int32, Int32) | Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.
Public method | SetTermLength | Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use ResizeTermBuffer(Int32) first.
Public method | TermBuffer | Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use ResizeTermBuffer(Int32) to increase it. After altering the buffer be sure to call SetTermLength(Int32) to record the number of valid characters that were placed into the termBuffer.
Public method | TermLength | Return number of valid characters (length of the term) in the termBuffer array.
Back to Top
See Also
ITermAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ResizeTermBuffer Method

ITermAttribute ResizeTermBuffer Method Lucene.Net Class Library
Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use SetTermBuffer( Char , Int32, Int32), SetTermBuffer(String), or SetTermBuffer(String, Int32, Int32) to optimally combine the resize with the setting of the termBuffer.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
char[] ResizeTermBuffer(
    int newSize
)
char[] ResizeTermBuffer(
    int newSize
)
Function ResizeTermBuffer ( _
    newSize As Integer _
) As Char()
Function ResizeTermBuffer ( _
    newSize As Integer _
) As Char()
array<wchar_t>^ ResizeTermBuffer(
    int newSize
)
array<wchar_t>^ ResizeTermBuffer(
    int newSize
)
Parameters
newSize
Type:   Online System Int32
minimum size of the new termBuffer

Return Value
 newly created termBuffer with length >= newSize

See Also
ITermAttribute Interface
ITermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetTermBuffer Method

ITermAttribute SetTermBuffer Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | SetTermBuffer(String) | Copies the contents of buffer into the termBuffer array.
Public method | SetTermBuffer( Char , Int32, Int32) | Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method | SetTermBuffer(String, Int32, Int32) | Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.
Back to Top
See Also
ITermAttribute Interface
ITermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetTermBuffer Method (String)

ITermAttribute SetTermBuffer Method (String) Lucene.Net Class Library
Copies the contents of buffer into the termBuffer array.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void SetTermBuffer(
    string buffer
)
void SetTermBuffer(
    string buffer
)
Sub SetTermBuffer ( _
    buffer As String _
)
Sub SetTermBuffer ( _
    buffer As String _
)
void SetTermBuffer(
    String^ buffer
)
void SetTermBuffer(
    String^ buffer
)
Parameters
buffer
Type:   Online System String
the buffer to copy

See Also
ITermAttribute Interface
ITermAttribute Members
SetTermBuffer Overload
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetTermBuffer Method (Char[], Int32, Int32)

ITermAttribute SetTermBuffer Method ( Char , Int32, Int32) Lucene.Net Class Library
Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void SetTermBuffer(
    char[] buffer,
    int offset,
    int length
)
void SetTermBuffer(
    char[] buffer,
    int offset,
    int length
)
Sub SetTermBuffer ( _
    buffer As Char(), _
    offset As Integer, _
    length As Integer _
)
Sub SetTermBuffer ( _
    buffer As Char(), _
    offset As Integer, _
    length As Integer _
)
void SetTermBuffer(
    array<wchar_t>^ buffer,
    int offset,
    int length
)
void SetTermBuffer(
    array<wchar_t>^ buffer,
    int offset,
    int length
)
Parameters
buffer
Type:    Online System Char
the buffer to copy

offset
Type:   Online System Int32
the index in the buffer of the first character to copy

length
Type:   Online System Int32
the number of characters to copy

See Also
ITermAttribute Interface
ITermAttribute Members
SetTermBuffer Overload
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetTermBuffer Method (String, Int32, Int32)

ITermAttribute SetTermBuffer Method (String, Int32, Int32) Lucene.Net Class Library
Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void SetTermBuffer(
    string buffer,
    int offset,
    int length
)
void SetTermBuffer(
    string buffer,
    int offset,
    int length
)
Sub SetTermBuffer ( _
    buffer As String, _
    offset As Integer, _
    length As Integer _
)
Sub SetTermBuffer ( _
    buffer As String, _
    offset As Integer, _
    length As Integer _
)
void SetTermBuffer(
    String^ buffer,
    int offset,
    int length
)
void SetTermBuffer(
    String^ buffer,
    int offset,
    int length
)
Parameters
buffer
Type:   Online System String
the buffer to copy

offset
Type:   Online System Int32
the index in the buffer of the first character to copy

length
Type:   Online System Int32
the number of characters to copy

See Also
ITermAttribute Interface
ITermAttribute Members
SetTermBuffer Overload
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetTermLength Method

ITermAttribute SetTermLength Method Lucene.Net Class Library
Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use ResizeTermBuffer(Int32) first.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void SetTermLength(
    int length
)
void SetTermLength(
    int length
)
Sub SetTermLength ( _
    length As Integer _
)
Sub SetTermLength ( _
    length As Integer _
)
void SetTermLength(
    int length
)
void SetTermLength(
    int length
)
Parameters
length
Type:   Online System Int32
the truncated length

See Also
ITermAttribute Interface
ITermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermBuffer Method

ITermAttribute TermBuffer Method Lucene.Net Class Library
Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use ResizeTermBuffer(Int32) to increase it. After altering the buffer be sure to call SetTermLength(Int32) to record the number of valid characters that were placed into the termBuffer.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
char[] TermBuffer()
char[] TermBuffer()
Function TermBuffer As Char()
Function TermBuffer As Char()
array<wchar_t>^ TermBuffer()
array<wchar_t>^ TermBuffer()
See Also
ITermAttribute Interface
ITermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermLength Method

ITermAttribute TermLength Method Lucene.Net Class Library
Return number of valid characters (length of the term) in the termBuffer array.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int TermLength()
int TermLength()
Function TermLength As Integer
Function TermLength As Integer
int TermLength()
int TermLength()
See Also
ITermAttribute Interface
ITermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ITermAttribute Properties

ITermAttribute Properties Lucene.Net Class Library
The ITermAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Term | Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use TermBuffer and TermLength directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())
Back to Top
See Also
ITermAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Property

ITermAttribute Term Property Lucene.Net Class Library
Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use TermBuffer and TermLength directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Term { get; }
string Term { get; }
ReadOnly Property Term As String
    Get
ReadOnly Property Term As String
    Get
property String^ Term {
    String^ get ();
}
property String^ Term {
    String^ get ();
}
See Also
ITermAttribute Interface
ITermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ITypeAttribute Interface

ITypeAttribute Interface Lucene.Net Class Library
A Token's lexical type. The Default value is "word".

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITypeAttribute : IAttribute
public interface ITypeAttribute : IAttribute
Public Interface ITypeAttribute _
    Inherits IAttribute
Public Interface ITypeAttribute _
    Inherits IAttribute
public interface class ITypeAttribute : IAttribute
public interface class ITypeAttribute : IAttribute
See Also
ITypeAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ITypeAttribute Members

ITypeAttribute Members Lucene.Net Class Library

The ITypeAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Type | Gets or sets this Token's lexical type. Defaults to "word".
Back to Top
See Also
ITypeAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ITypeAttribute Properties

ITypeAttribute Properties Lucene.Net Class Library
The ITypeAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Type | Gets or sets this Token's lexical type. Defaults to "word".
Back to Top
See Also
ITypeAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Type Property

ITypeAttribute Type Property Lucene.Net Class Library
Gets or sets this Token's lexical type. Defaults to "word".

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Type { get; set; }
string Type { get; set; }
Property Type As String
    Get
    Set
Property Type As String
    Get
    Set
property String^ Type {
    String^ get ();
    void set (String^ value);
}
property String^ Type {
    String^ get ();
    void set (String^ value);
}
See Also
ITypeAttribute Interface
ITypeAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OffsetAttribute Class

OffsetAttribute Class Lucene.Net Class Library
The start and end character offset of a Token.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util Attribute
Lucene.Net.Analysis.Tokenattributes OffsetAttribute

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class OffsetAttribute : Attribute,
    IOffsetAttribute, IAttribute, ICloneable
[SerializableAttribute]
public class OffsetAttribute : Attribute,
    IOffsetAttribute, IAttribute, ICloneable
<SerializableAttribute> _
Public Class OffsetAttribute _
    Inherits Attribute _
    Implements IOffsetAttribute, IAttribute, ICloneable
<SerializableAttribute> _
Public Class OffsetAttribute _
    Inherits Attribute _
    Implements IOffsetAttribute, IAttribute, ICloneable
[SerializableAttribute]
public ref class OffsetAttribute : public Attribute,
    IOffsetAttribute, IAttribute, ICloneable
[SerializableAttribute]
public ref class OffsetAttribute : public Attribute,
    IOffsetAttribute, IAttribute, ICloneable
See Also
OffsetAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OffsetAttribute Members

OffsetAttribute Members Lucene.Net Class Library

The OffsetAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | OffsetAttribute | Initializes a new instance of the OffsetAttribute class
Back to Top
Methods
Name | Description
Public method | Clear | (Overrides Attribute Clear .)
Public method | Clone | (Overrides Attribute Clone .)
Public method | CopyTo | (Overrides Attribute CopyTo(Attribute).)
Public method | Equals | (Overrides Attribute Equals(Object).)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method | GetHashCode | (Overrides Attribute GetHashCode .)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method SetOffset
Set the starting and ending offset. See StartOffset() and EndOffset()
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
View Colorized Copy to Clipboard Print
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
This method may be overridden by subclasses.
(Inherited from Attribute.)
Back to Top
Properties
 | Name | Description
Public property | EndOffset | Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).
Public property | StartOffset | Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.
Back to Top
See Also
OffsetAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OffsetAttribute Constructor

OffsetAttribute Constructor Lucene.Net Class Library
Initializes a new instance of the OffsetAttribute class

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OffsetAttribute()
public OffsetAttribute()
Public Sub New
Public Sub New
public:
OffsetAttribute()
public:
OffsetAttribute()
See Also
OffsetAttribute Class
OffsetAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OffsetAttribute Methods

OffsetAttribute Methods Lucene.Net Class Library
The OffsetAttribute type exposes the following members.
Methods
Name | Description
Public method | Clear | (Overrides Attribute Clear .)
Public method | Clone | (Overrides Attribute Clone .)
Public method | CopyTo | (Overrides Attribute CopyTo(Attribute).)
Public method | Equals | (Overrides Attribute Equals(Object).)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method | GetHashCode | (Overrides Attribute GetHashCode .)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method SetOffset
Set the starting and ending offset. See StartOffset() and EndOffset()
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
View Colorized Copy to Clipboard Print
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
This method may be overridden by subclasses.
(Inherited from Attribute.)
Back to Top
See Also
OffsetAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method

OffsetAttribute Clear Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Clear()
public override void Clear()
Public Overrides Sub Clear
Public Overrides Sub Clear
public:
virtual void Clear() override
public:
virtual void Clear() override
See Also
OffsetAttribute Class
OffsetAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

OffsetAttribute Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
OffsetAttribute Class
OffsetAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CopyTo Method

OffsetAttribute CopyTo Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void CopyTo(
    Attribute target
)
public override void CopyTo(
    Attribute target
)
Public Overrides Sub CopyTo ( _
    target As Attribute _
)
Public Overrides Sub CopyTo ( _
    target As Attribute _
)
public:
virtual void CopyTo(
    Attribute^ target
) override
public:
virtual void CopyTo(
    Attribute^ target
) override
Parameters
target
Type: Lucene.Net.Util Attribute
See Also
OffsetAttribute Class
OffsetAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

OffsetAttribute Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object other
)
public override bool Equals(
    Object other
)
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ other
) override
public:
virtual bool Equals(
    Object^ other
) override
Parameters
other
Type:   Online System Object
See Also
OffsetAttribute Class
OffsetAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

OffsetAttribute GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
OffsetAttribute Class
OffsetAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetOffset Method

OffsetAttribute SetOffset Method Lucene.Net Class Library
Set the starting and ending offset. See StartOffset() and EndOffset()

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetOffset(
    int startOffset,
    int endOffset
)
public virtual void SetOffset(
    int startOffset,
    int endOffset
)
Public Overridable Sub SetOffset ( _
    startOffset As Integer, _
    endOffset As Integer _
)
Public Overridable Sub SetOffset ( _
    startOffset As Integer, _
    endOffset As Integer _
)
public:
virtual void SetOffset(
    int startOffset,
    int endOffset
)
public:
virtual void SetOffset(
    int startOffset,
    int endOffset
)
Parameters
startOffset
Type:   Online System Int32
endOffset
Type:   Online System Int32
Implements
IOffsetAttribute SetOffset(Int32, Int32)
See Also
OffsetAttribute Class
OffsetAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OffsetAttribute Properties

OffsetAttribute Properties Lucene.Net Class Library
The OffsetAttribute type exposes the following members.
Properties
 | Name | Description
Public property | EndOffset | Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).
Public property | StartOffset | Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.
Back to Top
See Also
OffsetAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EndOffset Property

OffsetAttribute EndOffset Property Lucene.Net Class Library
Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int EndOffset { get; }
public virtual int EndOffset { get; }
Public Overridable ReadOnly Property EndOffset As Integer
    Get
Public Overridable ReadOnly Property EndOffset As Integer
    Get
public:
virtual property int EndOffset {
    int get ();
}
public:
virtual property int EndOffset {
    int get ();
}
Implements
IOffsetAttribute EndOffset
See Also
OffsetAttribute Class
OffsetAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StartOffset Property

OffsetAttribute StartOffset Property Lucene.Net Class Library
Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int StartOffset { get; }
public virtual int StartOffset { get; }
Public Overridable ReadOnly Property StartOffset As Integer
    Get
Public Overridable ReadOnly Property StartOffset As Integer
    Get
public:
virtual property int StartOffset {
    int get ();
}
public:
virtual property int StartOffset {
    int get ();
}
Implements
IOffsetAttribute StartOffset
See Also
OffsetAttribute Class
OffsetAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadAttribute Class

PayloadAttribute Class Lucene.Net Class Library
The payload of a Token. See also Payload.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util Attribute
Lucene.Net.Analysis.Tokenattributes PayloadAttribute

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PayloadAttribute : Attribute,
    IPayloadAttribute, IAttribute, ICloneable
[SerializableAttribute]
public class PayloadAttribute : Attribute,
    IPayloadAttribute, IAttribute, ICloneable
<SerializableAttribute> _
Public Class PayloadAttribute _
    Inherits Attribute _
    Implements IPayloadAttribute, IAttribute, ICloneable
<SerializableAttribute> _
Public Class PayloadAttribute _
    Inherits Attribute _
    Implements IPayloadAttribute, IAttribute, ICloneable
[SerializableAttribute]
public ref class PayloadAttribute : public Attribute,
    IPayloadAttribute, IAttribute, ICloneable
[SerializableAttribute]
public ref class PayloadAttribute : public Attribute,
    IPayloadAttribute, IAttribute, ICloneable
See Also
PayloadAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadAttribute Members

PayloadAttribute Members Lucene.Net Class Library

The PayloadAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | PayloadAttribute | Initialize this attribute with no payload.
Public method | PayloadAttribute(Payload) | Initialize this attribute with the given payload.
Back to Top
Methods
Name | Description
Public method | Clear | (Overrides Attribute Clear .)
Public method | Clone | (Overrides Attribute Clone .)
Public method | CopyTo | (Overrides Attribute CopyTo(Attribute).)
Public method | Equals | (Overrides Attribute Equals(Object).)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method | GetHashCode | (Overrides Attribute GetHashCode .)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
View Colorized Copy to Clipboard Print
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
This method may be overridden by subclasses.
(Inherited from Attribute.)
Back to Top
Properties
 | Name | Description
Public property | Payload | Returns this Token's payload.
Back to Top
See Also
PayloadAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadAttribute Constructor

PayloadAttribute Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | PayloadAttribute | Initialize this attribute with no payload.
Public method | PayloadAttribute(Payload) | Initialize this attribute with the given payload.
Back to Top
See Also
PayloadAttribute Class
PayloadAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadAttribute Constructor

PayloadAttribute Constructor Lucene.Net Class Library
Initialize this attribute with no payload.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PayloadAttribute()
public PayloadAttribute()
Public Sub New
Public Sub New
public:
PayloadAttribute()
public:
PayloadAttribute()
See Also
PayloadAttribute Class
PayloadAttribute Members
PayloadAttribute Overload
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadAttribute Constructor (Payload)

PayloadAttribute Constructor (Payload) Lucene.Net Class Library
Initialize this attribute with the given payload.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PayloadAttribute(
    Payload payload
)
public PayloadAttribute(
    Payload payload
)
Public Sub New ( _
    payload As Payload _
)
Public Sub New ( _
    payload As Payload _
)
public:
PayloadAttribute(
    Payload^ payload
)
public:
PayloadAttribute(
    Payload^ payload
)
Parameters
payload
Type: Lucene.Net.Index Payload
See Also
PayloadAttribute Class
PayloadAttribute Members
PayloadAttribute Overload
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadAttribute Methods

PayloadAttribute Methods Lucene.Net Class Library
The PayloadAttribute type exposes the following members.
Methods
Name | Description
Public method | Clear | (Overrides Attribute Clear .)
Public method | Clone | (Overrides Attribute Clone .)
Public method | CopyTo | (Overrides Attribute CopyTo(Attribute).)
Public method | Equals | (Overrides Attribute Equals(Object).)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method | GetHashCode | (Overrides Attribute GetHashCode .)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
View Colorized Copy to Clipboard Print
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
This method may be overridden by subclasses.
(Inherited from Attribute.)
Back to Top
See Also
PayloadAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method

PayloadAttribute Clear Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Clear()
public override void Clear()
Public Overrides Sub Clear
Public Overrides Sub Clear
public:
virtual void Clear() override
public:
virtual void Clear() override
See Also
PayloadAttribute Class
PayloadAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

PayloadAttribute Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
PayloadAttribute Class
PayloadAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CopyTo Method

PayloadAttribute CopyTo Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void CopyTo(
    Attribute target
)
public override void CopyTo(
    Attribute target
)
Public Overrides Sub CopyTo ( _
    target As Attribute _
)
Public Overrides Sub CopyTo ( _
    target As Attribute _
)
public:
virtual void CopyTo(
    Attribute^ target
) override
public:
virtual void CopyTo(
    Attribute^ target
) override
Parameters
target
Type: Lucene.Net.Util Attribute
See Also
PayloadAttribute Class
PayloadAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

PayloadAttribute Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object other
)
public override bool Equals(
    Object other
)
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ other
) override
public:
virtual bool Equals(
    Object^ other
) override
Parameters
other
Type:   Online System Object
See Also
PayloadAttribute Class
PayloadAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

PayloadAttribute GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
PayloadAttribute Class
PayloadAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadAttribute Properties

PayloadAttribute Properties Lucene.Net Class Library
The PayloadAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Payload | Returns this Token's payload.
Back to Top
See Also
PayloadAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Payload Property

PayloadAttribute Payload Property Lucene.Net Class Library
Returns this Token's payload.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Payload Payload { get; set; }
public virtual Payload Payload { get; set; }
Public Overridable Property Payload As Payload
    Get
    Set
Public Overridable Property Payload As Payload
    Get
    Set
public:
virtual property Payload^ Payload {
    Payload^ get ();
    void set (Payload^ value);
}
public:
virtual property Payload^ Payload {
    Payload^ get ();
    void set (Payload^ value);
}
Implements
IPayloadAttribute Payload
See Also
PayloadAttribute Class
PayloadAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionIncrementAttribute Class

PositionIncrementAttribute Class Lucene.Net Class Library
The positionIncrement determines the position of this token relative to the previous Token in a TokenStream, used in phrase searching.

The default value is one.

Some common uses for this are:Set it to zero to put multiple terms in the same position. This is useful if, e.g., a word has multiple stems. Searches for phrases including either stem will match. In this case, all but the first stem's increment should be set to zero: the increment of the first instance should be one. Repeating a token with an increment of zero can also be used to boost the scores of matches on that token.Set it to values greater than one to inhibit exact phrase matches. If, for example, one does not want phrases to match across removed stop words, then one could build a stop word filter that removes stop words and also sets the increment to the number of stop words removed before each non-stop word. Then exact phrase queries will only match when the terms occur with no intervening stop words.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util Attribute
Lucene.Net.Analysis.Tokenattributes PositionIncrementAttribute

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PositionIncrementAttribute : Attribute,
    IPositionIncrementAttribute, IAttribute, ICloneable
[SerializableAttribute]
public class PositionIncrementAttribute : Attribute,
    IPositionIncrementAttribute, IAttribute, ICloneable
<SerializableAttribute> _
Public Class PositionIncrementAttribute _
    Inherits Attribute _
    Implements IPositionIncrementAttribute, IAttribute, ICloneable
<SerializableAttribute> _
Public Class PositionIncrementAttribute _
    Inherits Attribute _
    Implements IPositionIncrementAttribute, IAttribute, ICloneable
[SerializableAttribute]
public ref class PositionIncrementAttribute : public Attribute,
    IPositionIncrementAttribute, IAttribute, ICloneable
[SerializableAttribute]
public ref class PositionIncrementAttribute : public Attribute,
    IPositionIncrementAttribute, IAttribute, ICloneable
See Also
PositionIncrementAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionIncrementAttribute Members

PositionIncrementAttribute Members Lucene.Net Class Library

The PositionIncrementAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | PositionIncrementAttribute | Initializes a new instance of the PositionIncrementAttribute class
Back to Top
Methods
Name | Description
Public method | Clear | (Overrides Attribute Clear .)
Public method | Clone | (Overrides Attribute Clone .)
Public method | CopyTo | (Overrides Attribute CopyTo(Attribute).)
Public method | Equals | (Overrides Attribute Equals(Object).)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method | GetHashCode | (Overrides Attribute GetHashCode .)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
View Colorized Copy to Clipboard Print
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
This method may be overridden by subclasses.
(Inherited from Attribute.)
Back to Top
Properties
 | Name | Description
Public property | PositionIncrement | Set the position increment. The default value is one.
Back to Top
See Also
PositionIncrementAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionIncrementAttribute Constructor

PositionIncrementAttribute Constructor Lucene.Net Class Library
Initializes a new instance of the PositionIncrementAttribute class

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PositionIncrementAttribute()
public PositionIncrementAttribute()
Public Sub New
Public Sub New
public:
PositionIncrementAttribute()
public:
PositionIncrementAttribute()
See Also
PositionIncrementAttribute Class
PositionIncrementAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionIncrementAttribute Methods

PositionIncrementAttribute Methods Lucene.Net Class Library
The PositionIncrementAttribute type exposes the following members.
Methods
Name | Description
Public method | Clear | (Overrides Attribute Clear .)
Public method | Clone | (Overrides Attribute Clone .)
Public method | CopyTo | (Overrides Attribute CopyTo(Attribute).)
Public method | Equals | (Overrides Attribute Equals(Object).)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method | GetHashCode | (Overrides Attribute GetHashCode .)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
View Colorized Copy to Clipboard Print
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
This method may be overridden by subclasses.
(Inherited from Attribute.)
Back to Top
See Also
PositionIncrementAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method

PositionIncrementAttribute Clear Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Clear()
public override void Clear()
Public Overrides Sub Clear
Public Overrides Sub Clear
public:
virtual void Clear() override
public:
virtual void Clear() override
See Also
PositionIncrementAttribute Class
PositionIncrementAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

PositionIncrementAttribute Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
PositionIncrementAttribute Class
PositionIncrementAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CopyTo Method

PositionIncrementAttribute CopyTo Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void CopyTo(
    Attribute target
)
public override void CopyTo(
    Attribute target
)
Public Overrides Sub CopyTo ( _
    target As Attribute _
)
Public Overrides Sub CopyTo ( _
    target As Attribute _
)
public:
virtual void CopyTo(
    Attribute^ target
) override
public:
virtual void CopyTo(
    Attribute^ target
) override
Parameters
target
Type: Lucene.Net.Util Attribute
See Also
PositionIncrementAttribute Class
PositionIncrementAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

PositionIncrementAttribute Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object other
)
public override bool Equals(
    Object other
)
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ other
) override
public:
virtual bool Equals(
    Object^ other
) override
Parameters
other
Type:   Online System Object
See Also
PositionIncrementAttribute Class
PositionIncrementAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

PositionIncrementAttribute GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
PositionIncrementAttribute Class
PositionIncrementAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionIncrementAttribute Properties

PositionIncrementAttribute Properties Lucene.Net Class Library
The PositionIncrementAttribute type exposes the following members.
Properties
 | Name | Description
Public property | PositionIncrement | Set the position increment. The default value is one.
Back to Top
See Also
PositionIncrementAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionIncrement Property

PositionIncrementAttribute PositionIncrement Property Lucene.Net Class Library
Set the position increment. The default value is one.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int PositionIncrement { get; set; }
public virtual int PositionIncrement { get; set; }
Public Overridable Property PositionIncrement As Integer
    Get
    Set
Public Overridable Property PositionIncrement As Integer
    Get
    Set
public:
virtual property int PositionIncrement {
    int get ();
    void set (int value);
}
public:
virtual property int PositionIncrement {
    int get ();
    void set (int value);
}
Field Value
 the distance from the prior term
Implements
IPositionIncrementAttribute PositionIncrement
See Also
PositionIncrementAttribute Class
PositionIncrementAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermAttribute Class

TermAttribute Class Lucene.Net Class Library
The term text of a Token.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util Attribute
Lucene.Net.Analysis.Tokenattributes TermAttribute

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TermAttribute : Attribute,
    ITermAttribute, IAttribute, ICloneable
[SerializableAttribute]
public class TermAttribute : Attribute,
    ITermAttribute, IAttribute, ICloneable
<SerializableAttribute> _
Public Class TermAttribute _
    Inherits Attribute _
    Implements ITermAttribute, IAttribute, ICloneable
<SerializableAttribute> _
Public Class TermAttribute _
    Inherits Attribute _
    Implements ITermAttribute, IAttribute, ICloneable
[SerializableAttribute]
public ref class TermAttribute : public Attribute,
    ITermAttribute, IAttribute, ICloneable
[SerializableAttribute]
public ref class TermAttribute : public Attribute,
    ITermAttribute, IAttribute, ICloneable
See Also
TermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermAttribute Members

TermAttribute Members Lucene.Net Class Library

The TermAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | TermAttribute | Initializes a new instance of the TermAttribute class
Back to Top
Methods
 | Name | Description
Public method | Clear | (Overrides Attribute Clear .)
Public method | Clone | (Overrides Attribute Clone .)
Public method | CopyTo | (Overrides Attribute CopyTo(Attribute).)
Public method | Equals | (Overrides Attribute Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Attribute GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResizeTermBuffer | Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use SetTermBuffer( Char , Int32, Int32), SetTermBuffer(String), or SetTermBuffer(String, Int32, Int32) to optimally combine the resize with the setting of the termBuffer.
Public method | SetTermBuffer(String) | Copies the contents of buffer into the termBuffer array.
Public method | SetTermBuffer( Char , Int32, Int32) | Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method | SetTermBuffer(String, Int32, Int32) | Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.
Public method | SetTermLength | Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use ResizeTermBuffer(Int32) first.
Public method | TermBuffer | Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use ResizeTermBuffer(Int32) to increase it. After altering the buffer be sure to call SetTermLength(Int32) to record the number of valid characters that were placed into the termBuffer.
Public method | TermLength | Return number of valid characters (length of the term) in the termBuffer array.
Public method | ToString | (Overrides Attribute ToString .)
Back to Top
Properties
 | Name | Description
Public property | Term | Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use TermBuffer and TermLength directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())
Back to Top
See Also
TermAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermAttribute Constructor

TermAttribute Constructor Lucene.Net Class Library
Initializes a new instance of the TermAttribute class

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TermAttribute()
public TermAttribute()
Public Sub New
Public Sub New
public:
TermAttribute()
public:
TermAttribute()
See Also
TermAttribute Class
TermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermAttribute Methods

TermAttribute Methods Lucene.Net Class Library
The TermAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Clear | (Overrides Attribute Clear .)
Public method | Clone | (Overrides Attribute Clone .)
Public method | CopyTo | (Overrides Attribute CopyTo(Attribute).)
Public method | Equals | (Overrides Attribute Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Attribute GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResizeTermBuffer | Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use SetTermBuffer( Char , Int32, Int32), SetTermBuffer(String), or SetTermBuffer(String, Int32, Int32) to optimally combine the resize with the setting of the termBuffer.
Public method | SetTermBuffer(String) | Copies the contents of buffer into the termBuffer array.
Public method | SetTermBuffer( Char , Int32, Int32) | Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method | SetTermBuffer(String, Int32, Int32) | Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.
Public method | SetTermLength | Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use ResizeTermBuffer(Int32) first.
Public method | TermBuffer | Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use ResizeTermBuffer(Int32) to increase it. After altering the buffer be sure to call SetTermLength(Int32) to record the number of valid characters that were placed into the termBuffer.
Public method | TermLength | Return number of valid characters (length of the term) in the termBuffer array.
Public method | ToString | (Overrides Attribute ToString .)
Back to Top
See Also
TermAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method

TermAttribute Clear Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Clear()
public override void Clear()
Public Overrides Sub Clear
Public Overrides Sub Clear
public:
virtual void Clear() override
public:
virtual void Clear() override
See Also
TermAttribute Class
TermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

TermAttribute Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
TermAttribute Class
TermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CopyTo Method

TermAttribute CopyTo Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void CopyTo(
    Attribute target
)
public override void CopyTo(
    Attribute target
)
Public Overrides Sub CopyTo ( _
    target As Attribute _
)
Public Overrides Sub CopyTo ( _
    target As Attribute _
)
public:
virtual void CopyTo(
    Attribute^ target
) override
public:
virtual void CopyTo(
    Attribute^ target
) override
Parameters
target
Type: Lucene.Net.Util Attribute
See Also
TermAttribute Class
TermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

TermAttribute Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object other
)
public override bool Equals(
    Object other
)
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ other
) override
public:
virtual bool Equals(
    Object^ other
) override
Parameters
other
Type:   Online System Object
See Also
TermAttribute Class
TermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

TermAttribute GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
TermAttribute Class
TermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ResizeTermBuffer Method

TermAttribute ResizeTermBuffer Method Lucene.Net Class Library
Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use SetTermBuffer( Char , Int32, Int32), SetTermBuffer(String), or SetTermBuffer(String, Int32, Int32) to optimally combine the resize with the setting of the termBuffer.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual char[] ResizeTermBuffer(
    int newSize
)
public virtual char[] ResizeTermBuffer(
    int newSize
)
Public Overridable Function ResizeTermBuffer ( _
    newSize As Integer _
) As Char()
Public Overridable Function ResizeTermBuffer ( _
    newSize As Integer _
) As Char()
public:
virtual array<wchar_t>^ ResizeTermBuffer(
    int newSize
)
public:
virtual array<wchar_t>^ ResizeTermBuffer(
    int newSize
)
Parameters
newSize
Type:   Online System Int32
minimum size of the new termBuffer

Return Value
 newly created termBuffer with length >= newSize

Implements
ITermAttribute ResizeTermBuffer(Int32)
See Also
TermAttribute Class
TermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetTermBuffer Method

TermAttribute SetTermBuffer Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | SetTermBuffer(String) | Copies the contents of buffer into the termBuffer array.
Public method | SetTermBuffer( Char , Int32, Int32) | Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method | SetTermBuffer(String, Int32, Int32) | Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.
Back to Top
See Also
TermAttribute Class
TermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetTermBuffer Method (String)

TermAttribute SetTermBuffer Method (String) Lucene.Net Class Library
Copies the contents of buffer into the termBuffer array.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetTermBuffer(
    string buffer
)
public virtual void SetTermBuffer(
    string buffer
)
Public Overridable Sub SetTermBuffer ( _
    buffer As String _
)
Public Overridable Sub SetTermBuffer ( _
    buffer As String _
)
public:
virtual void SetTermBuffer(
    String^ buffer
)
public:
virtual void SetTermBuffer(
    String^ buffer
)
Parameters
buffer
Type:   Online System String
the buffer to copy

Implements
ITermAttribute SetTermBuffer(String)
See Also
TermAttribute Class
TermAttribute Members
SetTermBuffer Overload
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetTermBuffer Method (Char[], Int32, Int32)

TermAttribute SetTermBuffer Method ( Char , Int32, Int32) Lucene.Net Class Library
Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetTermBuffer(
    char[] buffer,
    int offset,
    int length
)
public virtual void SetTermBuffer(
    char[] buffer,
    int offset,
    int length
)
Public Overridable Sub SetTermBuffer ( _
    buffer As Char(), _
    offset As Integer, _
    length As Integer _
)
Public Overridable Sub SetTermBuffer ( _
    buffer As Char(), _
    offset As Integer, _
    length As Integer _
)
public:
virtual void SetTermBuffer(
    array<wchar_t>^ buffer,
    int offset,
    int length
)
public:
virtual void SetTermBuffer(
    array<wchar_t>^ buffer,
    int offset,
    int length
)
Parameters
buffer
Type:    Online System Char
the buffer to copy

offset
Type:   Online System Int32
the index in the buffer of the first character to copy

length
Type:   Online System Int32
the number of characters to copy

Implements
ITermAttribute SetTermBuffer( Char , Int32, Int32)
See Also
TermAttribute Class
TermAttribute Members
SetTermBuffer Overload
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetTermBuffer Method (String, Int32, Int32)

TermAttribute SetTermBuffer Method (String, Int32, Int32) Lucene.Net Class Library
Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetTermBuffer(
    string buffer,
    int offset,
    int length
)
public virtual void SetTermBuffer(
    string buffer,
    int offset,
    int length
)
Public Overridable Sub SetTermBuffer ( _
    buffer As String, _
    offset As Integer, _
    length As Integer _
)
Public Overridable Sub SetTermBuffer ( _
    buffer As String, _
    offset As Integer, _
    length As Integer _
)
public:
virtual void SetTermBuffer(
    String^ buffer,
    int offset,
    int length
)
public:
virtual void SetTermBuffer(
    String^ buffer,
    int offset,
    int length
)
Parameters
buffer
Type:   Online System String
the buffer to copy

offset
Type:   Online System Int32
the index in the buffer of the first character to copy

length
Type:   Online System Int32
the number of characters to copy

Implements
ITermAttribute SetTermBuffer(String, Int32, Int32)
See Also
TermAttribute Class
TermAttribute Members
SetTermBuffer Overload
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetTermLength Method

TermAttribute SetTermLength Method Lucene.Net Class Library
Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use ResizeTermBuffer(Int32) first.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetTermLength(
    int length
)
public virtual void SetTermLength(
    int length
)
Public Overridable Sub SetTermLength ( _
    length As Integer _
)
Public Overridable Sub SetTermLength ( _
    length As Integer _
)
public:
virtual void SetTermLength(
    int length
)
public:
virtual void SetTermLength(
    int length
)
Parameters
length
Type:   Online System Int32
the truncated length

Implements
ITermAttribute SetTermLength(Int32)
See Also
TermAttribute Class
TermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermBuffer Method

TermAttribute TermBuffer Method Lucene.Net Class Library
Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use ResizeTermBuffer(Int32) to increase it. After altering the buffer be sure to call SetTermLength(Int32) to record the number of valid characters that were placed into the termBuffer.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual char[] TermBuffer()
public virtual char[] TermBuffer()
Public Overridable Function TermBuffer As Char()
Public Overridable Function TermBuffer As Char()
public:
virtual array<wchar_t>^ TermBuffer()
public:
virtual array<wchar_t>^ TermBuffer()
Implements
ITermAttribute TermBuffer
See Also
TermAttribute Class
TermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermLength Method

TermAttribute TermLength Method Lucene.Net Class Library
Return number of valid characters (length of the term) in the termBuffer array.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int TermLength()
public virtual int TermLength()
Public Overridable Function TermLength As Integer
Public Overridable Function TermLength As Integer
public:
virtual int TermLength()
public:
virtual int TermLength()
Implements
ITermAttribute TermLength
See Also
TermAttribute Class
TermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

TermAttribute ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
TermAttribute Class
TermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermAttribute Properties

TermAttribute Properties Lucene.Net Class Library
The TermAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Term | Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use TermBuffer and TermLength directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())
Back to Top
See Also
TermAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Property

TermAttribute Term Property Lucene.Net Class Library
Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use TermBuffer and TermLength directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Term { get; }
public virtual string Term { get; }
Public Overridable ReadOnly Property Term As String
    Get
Public Overridable ReadOnly Property Term As String
    Get
public:
virtual property String^ Term {
    String^ get ();
}
public:
virtual property String^ Term {
    String^ get ();
}
Implements
ITermAttribute Term
See Also
TermAttribute Class
TermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TypeAttribute Class

TypeAttribute Class Lucene.Net Class Library
A Token's lexical type. The Default value is "word".
Inheritance Hierarchy
Online System Object
Lucene.Net.Util Attribute
Lucene.Net.Analysis.Tokenattributes TypeAttribute

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TypeAttribute : Attribute,
    ITypeAttribute, IAttribute, ICloneable
[SerializableAttribute]
public class TypeAttribute : Attribute,
    ITypeAttribute, IAttribute, ICloneable
<SerializableAttribute> _
Public Class TypeAttribute _
    Inherits Attribute _
    Implements ITypeAttribute, IAttribute, ICloneable
<SerializableAttribute> _
Public Class TypeAttribute _
    Inherits Attribute _
    Implements ITypeAttribute, IAttribute, ICloneable
[SerializableAttribute]
public ref class TypeAttribute : public Attribute,
    ITypeAttribute, IAttribute, ICloneable
[SerializableAttribute]
public ref class TypeAttribute : public Attribute,
    ITypeAttribute, IAttribute, ICloneable
See Also
TypeAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TypeAttribute Members

TypeAttribute Members Lucene.Net Class Library

The TypeAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | TypeAttribute | Initializes a new instance of the TypeAttribute class
Public method | TypeAttribute(String) | Initializes a new instance of the TypeAttribute class
Back to Top
Methods
Name | Description
Public method | Clear | (Overrides Attribute Clear .)
Public method | Clone | (Overrides Attribute Clone .)
Public method | CopyTo | (Overrides Attribute CopyTo(Attribute).)
Public method | Equals | (Overrides Attribute Equals(Object).)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method | GetHashCode | (Overrides Attribute GetHashCode .)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
View Colorized Copy to Clipboard Print
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
This method may be overridden by subclasses.
(Inherited from Attribute.)
Back to Top
Fields
Name | Description
DEFAULT_TYPE |
Back to Top
Properties
 | Name | Description
Public property | Type | Returns this Token's lexical type. Defaults to "word".
Back to Top
See Also
TypeAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TypeAttribute Constructor

TypeAttribute Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TypeAttribute | Initializes a new instance of the TypeAttribute class
Public method | TypeAttribute(String) | Initializes a new instance of the TypeAttribute class
Back to Top
See Also
TypeAttribute Class
TypeAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TypeAttribute Constructor

TypeAttribute Constructor Lucene.Net Class Library
Initializes a new instance of the TypeAttribute class

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeAttribute()
public TypeAttribute()
Public Sub New
Public Sub New
public:
TypeAttribute()
public:
TypeAttribute()
See Also
TypeAttribute Class
TypeAttribute Members
TypeAttribute Overload
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TypeAttribute Constructor (String)

TypeAttribute Constructor (String) Lucene.Net Class Library
Initializes a new instance of the TypeAttribute class

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeAttribute(
    string type
)
public TypeAttribute(
    string type
)
Public Sub New ( _
    type As String _
)
Public Sub New ( _
    type As String _
)
public:
TypeAttribute(
    String^ type
)
public:
TypeAttribute(
    String^ type
)
Parameters
type
Type:   Online System String
See Also
TypeAttribute Class
TypeAttribute Members
TypeAttribute Overload
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TypeAttribute Fields

TypeAttribute Fields Lucene.Net Class Library
The TypeAttribute type exposes the following members.
Fields
Name | Description
DEFAULT_TYPE |
Back to Top
See Also
TypeAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_TYPE Field

TypeAttribute DEFAULT_TYPE Field Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_TYPE
public const string DEFAULT_TYPE
Public Const DEFAULT_TYPE As String
Public Const DEFAULT_TYPE As String
public:
literal String^ DEFAULT_TYPE
public:
literal String^ DEFAULT_TYPE
See Also
TypeAttribute Class
TypeAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TypeAttribute Methods

TypeAttribute Methods Lucene.Net Class Library
The TypeAttribute type exposes the following members.
Methods
Name | Description
Public method | Clear | (Overrides Attribute Clear .)
Public method | Clone | (Overrides Attribute Clone .)
Public method | CopyTo | (Overrides Attribute CopyTo(Attribute).)
Public method | Equals | (Overrides Attribute Equals(Object).)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method | GetHashCode | (Overrides Attribute GetHashCode .)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
View Colorized Copy to Clipboard Print
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
This method may be overridden by subclasses.
(Inherited from Attribute.)
Back to Top
See Also
TypeAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method

TypeAttribute Clear Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Clear()
public override void Clear()
Public Overrides Sub Clear
Public Overrides Sub Clear
public:
virtual void Clear() override
public:
virtual void Clear() override
See Also
TypeAttribute Class
TypeAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

TypeAttribute Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
TypeAttribute Class
TypeAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CopyTo Method

TypeAttribute CopyTo Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void CopyTo(
    Attribute target
)
public override void CopyTo(
    Attribute target
)
Public Overrides Sub CopyTo ( _
    target As Attribute _
)
Public Overrides Sub CopyTo ( _
    target As Attribute _
)
public:
virtual void CopyTo(
    Attribute^ target
) override
public:
virtual void CopyTo(
    Attribute^ target
) override
Parameters
target
Type: Lucene.Net.Util Attribute
See Also
TypeAttribute Class
TypeAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

TypeAttribute Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object other
)
public override bool Equals(
    Object other
)
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ other
) override
public:
virtual bool Equals(
    Object^ other
) override
Parameters
other
Type:   Online System Object
See Also
TypeAttribute Class
TypeAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

TypeAttribute GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
TypeAttribute Class
TypeAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TypeAttribute Properties

TypeAttribute Properties Lucene.Net Class Library
The TypeAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Type | Returns this Token's lexical type. Defaults to "word".
Back to Top
See Also
TypeAttribute Class
Lucene.Net.Analysis.Tokenattributes Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Type Property

TypeAttribute Type Property Lucene.Net Class Library
Returns this Token's lexical type. Defaults to "word".

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Type { get; set; }
public virtual string Type { get; set; }
Public Overridable Property Type As String
    Get
    Set
Public Overridable Property Type As String
    Get
    Set
public:
virtual property String^ Type {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ Type {
    String^ get ();
    void set (String^ value);
}
Implements
ITypeAttribute Type
See Also
TypeAttribute Class
TypeAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lucene.Net.Documents Namespace

Lucene.Net.Documents Namespace Lucene.Net Class Library
Classes
Class | Description
Public class AbstractField
Public class CompressionTools
Simple utility class providing static methods to compress and decompress binary data for stored fields. This class uses java.util.zip.Deflater and Inflater classes to compress and decompress.
Public class DateField Obsolete.
Provides support for converting dates to strings and vice-versa. The strings are structured so that lexicographic sorting orders by date, which makes them suitable for use as field values and search terms.

Note that this class saves dates with millisecond granularity, which is bad for TermRangeQuery and PrefixQuery, as those queries are expanded to a BooleanQuery with a potentially large number of terms when searching. Thus you might want to use DateTools instead.

Note: dates before 1970 cannot be used, and therefore cannot be indexed when using this class. See DateTools for an alternative without such a limitation.

Another approach is NumericUtils, which provides a sortable binary representation (prefix encoded) of numeric values, which date/time are. For indexing a Online DateTime, convert it to unix timestamp as long and index this as a numeric value with NumericField and use NumericRangeQuery T to query it.
Public class DateTools
Provides support for converting dates to strings and vice-versa. The strings are structured so that lexicographic sorting orders them by date, which makes them suitable for use as field values and search terms.

This class also helps you to limit the resolution of your dates. Do not save dates with a finer resolution than you really need, as then RangeQuery and PrefixQuery will require more memory and become slower.

Compared to DateField the strings generated by the methods in this class take slightly more space, unless your selected resolution is set to Resolution.DAY or lower.

Another approach is NumericUtils, which provides a sortable binary representation (prefix encoded) of numeric values, which date/time are. For indexing a Online DateTime, convert it to unix timestamp as long and index this as a numeric value with NumericField and use NumericRangeQuery T to query it.
Public class DateTools Resolution
Specifies the time granularity.
Public class Document
Documents are the unit of indexing and search. A Document is a set of fields. Each field has a name and a textual value. A field may be stored with the document, in which case it is returned with search hits on the document. Thus each document should typically contain one or more stored fields which uniquely identify it.

Note that fields which are not stored are not available in documents retrieved from the index, e.g. with Doc, Doc(Int32) or Document(Int32).
Public class Field
A field is a section of a Document. Each field has two parts, a name and a value. Values may be free text, provided as a String or as a Reader, or they may be atomic keywords, which are not further processed. Such keywords may be used to represent dates, urls, etc. Fields are optionally stored in the index, so that they may be returned with hits on the document.
Public class | FieldExtensions
Public class LoadFirstFieldSelector
Load the First field and break.

See LOAD_AND_BREAK
Public class MapFieldSelector
A FieldSelector based on a Map of field names to FieldSelectorResults
Public class NumberTools Obsolete.
Provides support for converting longs to Strings, and back again. The strings are structured so that lexicographic sorting order is preserved.

That is, if l1 is less than l2 for any two longs l1 and l2, then NumberTools.longToString(l1) is lexicographically less than NumberTools.longToString(l2). (Similarly for "greater than" and "equals".)

This class handles all long values (unlike DateField).
Public class NumericField

This class provides a Field that enables indexing of numeric values for efficient range filtering and sorting. Here's an example usage, adding an int value:
View Colorized Copy to Clipboard Print
document.add(new NumericField(name).setIntValue(value));
document.add(new NumericField(name).setIntValue(value));
For optimal performance, re-use the NumericField and Document instance for more than one document:
View Colorized Copy to Clipboard Print
NumericField field = new NumericField(name);
Document document = new Document();
document.add(field);

for(all documents) {
...
field.setIntValue(value)
writer.addDocument(document);
...
}
NumericField field = new NumericField(name);
Document document = new Document();
document.add(field);

for(all documents) {
...
field.setIntValue(value)
writer.addDocument(document);
...
}

The .Net native types int, long, float and double are directly supported. However, any value that can be converted into these native types can also be indexed. For example, date/time values represented by a Online DateTime can be translated into a long value using the java.util.Date.getTime method. If you don't need millisecond precision, you can quantize the value, either by dividing the result of java.util.Date.getTime or using the separate getters (for year, month, etc.) to construct an int or long value.

To perform range querying or filtering against a NumericField, use NumericRangeQuery T or NumericRangeFilter T . To sort according to a NumericField, use the normal numeric sort types, eg INT NumericField values can also be loaded directly from FieldCache.

By default, a NumericField's value is not stored but is indexed for range filtering and sorting. You can use the NumericField(String, Field Store, Boolean) constructor if you need to change these defaults.

You may add the same field name as a NumericField to the same document more than once. Range querying and filtering will be the logical OR of all values; so a range query will hit all documents that have at least one value in the range. However sort behavior is not defined. If you need to sort, you should separately index a single-valued NumericField.

A NumericField will consume somewhat more disk space in the index than an ordinary single-valued field. However, for a typical index that includes substantial textual content per document, this increase will likely be in the noise.

Within Lucene, each numeric value is indexed as a trie structure, where each term is logically assigned to larger and larger pre-defined brackets (which are simply lower-precision representations of the value). The step size between each successive bracket is called the precisionStep, measured in bits. Smaller precisionStep values result in larger number of brackets, which consumes more disk space in the index but may result in faster range search performance. The default value, 4, was selected for a reasonable tradeoff of disk space consumption versus performance. You can use the expert constructor NumericField(String, Int32, Field Store, Boolean) if you'd like to change the value. Note that you must also specify a congruent value when creating NumericRangeQuery T or NumericRangeFilter T . For low cardinality fields larger precision steps are good. If the cardinality is < 100, it is fair to use Online MaxValue, which produces one term per value.

For more information on the internals of numeric trie indexing, including the precisionStep configuration, see NumericRangeQuery T . The format of indexed values is described in NumericUtils.

If you only need to sort by numeric value, and never run range querying/filtering, you can index using a precisionStep of Online MaxValue. This will minimize disk space consumed.

More advanced users can instead use NumericTokenStream directly, when indexing numbers. This class is a wrapper around this token stream type for easier, more intuitive usage.

NOTE: This class is only used during indexing. When retrieving the stored field value from a Document instance after search, you will get a conventional IFieldable instance where the numeric values are returned as Online Strings (according to toString(value) of the used data type).

NOTE: This API is experimental and might change in incompatible ways in the next release.
Public class SetBasedFieldSelector
Declare what fields to load normally and what fields to load lazily
Interfaces
 | Interface | Description
Public interface | FieldSelector | Similar to a Online java.io.FileFilter, the FieldSelector allows one to make decisions about what Fields get loaded on a Document by Document(Int32, FieldSelector)
Public interface | IFieldable | Synonymous with Field. WARNING: This interface may change within minor versions, despite Lucene's backward compatibility requirements. This means new methods may be added from version to version. This change only affects the Fieldable API; other backwards compatibility promises remain intact. For example, Lucene can still read and write indices created within the same major version.
Enumerations
 | Enumeration | Description
Public enumeration | Field Index | Specifies whether and how a field should be indexed.
Public enumeration | Field Store | Specifies whether and how a field should be stored.
Public enumeration | Field TermVector | Specifies whether and how a field should have term vectors.
Public enumeration | FieldSelectorResult | Provides information about what should be done with this Field

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AbstractField Class

AbstractField Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Documents AbstractField
Lucene.Net.Documents Field
Lucene.Net.Documents NumericField

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class AbstractField : IFieldable
[SerializableAttribute]
public abstract class AbstractField : IFieldable
<SerializableAttribute> _
Public MustInherit Class AbstractField _
    Implements IFieldable
<SerializableAttribute> _
Public MustInherit Class AbstractField _
    Implements IFieldable
[SerializableAttribute]
public ref class AbstractField abstract : IFieldable
[SerializableAttribute]
public ref class AbstractField abstract : IFieldable
See Also
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AbstractField Members

AbstractField Members Lucene.Net Class Library

The AbstractField type exposes the following members.
Constructors
 | Name | Description
Protected method | AbstractField | Initializes a new instance of the AbstractField class
Protected method | AbstractField(String, Field Store, Field Index, Field TermVector) | Initializes a new instance of the AbstractField class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBinaryValue | Return the raw byte[] for the binary field. Note that you must also call BinaryLength and BinaryOffset to know which range of bytes in this returned array belong to the field.
Public method | GetBinaryValue( Byte ) |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | SetStoreTermVector |
Public method | ToString | Prints a Field for human consumption. (Overrides Online Object ToString .)
Back to Top
Fields
 | Name | Description
Protected field | fieldsData |
Protected field | internalBinaryLength |
Protected field | internalbinaryOffset |
Protected field | internalBoost |
Protected field | internalIsBinary |
Protected field | internalIsIndexed |
Protected field | internalIsStored |
Protected field | internalIsTokenized |
Protected field | internalName |
Protected field | internalOmitNorms |
Protected field | internalOmitTermFreqAndPositions |
Protected field | lazy |
Protected field | storeOffsetWithTermVector |
Protected field | storePositionWithTermVector |
Protected field | storeTermVector |
Protected field | tokenStream |
Back to Top
Properties
 | Name | Description
Public property | BinaryLength | Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined
Public property | BinaryOffset | Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined
Public property | Boost | Gets or sets the boost factor for hits for this field. The default value is 1.0. Note: this value is not stored directly with the document in the index. Documents returned from Document(Int32) and Doc(Int32) may thus not have the same value present as when this field was indexed.
Public property | IsBinary | True iff the value of the filed is stored as binary
Public property | IsIndexed | True iff the value of the field is to be indexed, so that it may be searched on.
Public property | IsLazy |
Public property | IsStored | True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.
Public property | IsStoreOffsetWithTermVector | True iff terms are stored as term vector together with their offsets (start and end position in source text).
Public property | IsStorePositionWithTermVector | True iff terms are stored as term vector together with their token positions.
Public property | IsTermVectorStored | True iff the term or terms used to index this field are stored as a term vector, available from GetTermFreqVector(Int32, String). These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the stored attribute instead.
Public property | IsTokenized | True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Public property | Name | Returns the name of the field as an interned string. For example "date", "title", "body", ...
Public property | OmitNorms | True if norms are omitted for this indexed field
Public property | OmitTermFreqAndPositions | Expert: If set, omit term freq, positions and payloads from postings for this field. NOTE: While this option reduces storage space required in the index, it also means any query requiring positional information, such as PhraseQuery or SpanQuery subclasses will silently fail to find results.
Public property | ReaderValue |
Public property | StringValue |
Public property | TokenStreamValue |
Back to Top
See Also
AbstractField Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AbstractField Constructor

AbstractField Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Protected method | AbstractField | Initializes a new instance of the AbstractField class
Protected method | AbstractField(String, Field Store, Field Index, Field TermVector) | Initializes a new instance of the AbstractField class
Back to Top
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AbstractField Constructor

AbstractField Constructor Lucene.Net Class Library
Initializes a new instance of the AbstractField class

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected AbstractField()
protected AbstractField()
Protected Sub New
Protected Sub New
protected:
AbstractField()
protected:
AbstractField()
See Also
AbstractField Class
AbstractField Members
AbstractField Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AbstractField Constructor (String, Field.Store, Field.Index, Field.TermVector)

AbstractField Constructor (String, Field Store, Field Index, Field TermVector) Lucene.Net Class Library
Initializes a new instance of the AbstractField class

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected AbstractField(
    string name,
    Field..::..Store store,
    Field..::..Index index,
    Field..::..TermVector termVector
)
protected AbstractField(
    string name,
    Field..::..Store store,
    Field..::..Index index,
    Field..::..TermVector termVector
)
Protected Sub New ( _
    name As String, _
    store As Field..::..Store, _
    index As Field..::..Index, _
    termVector As Field..::..TermVector _
)
Protected Sub New ( _
    name As String, _
    store As Field..::..Store, _
    index As Field..::..Index, _
    termVector As Field..::..TermVector _
)
protected:
AbstractField(
    String^ name,
    Field..::..Store store,
    Field..::..Index index,
    Field..::..TermVector termVector
)
protected:
AbstractField(
    String^ name,
    Field..::..Store store,
    Field..::..Index index,
    Field..::..TermVector termVector
)
Parameters
name
Type:   Online System String
store
Type: Lucene.Net.Documents Field Store
index
Type: Lucene.Net.Documents Field Index
termVector
Type: Lucene.Net.Documents Field TermVector
See Also
AbstractField Class
AbstractField Members
AbstractField Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AbstractField Fields

AbstractField Fields Lucene.Net Class Library
The AbstractField type exposes the following members.
Fields
 | Name | Description
Protected field | fieldsData |
Protected field | internalBinaryLength |
Protected field | internalbinaryOffset |
Protected field | internalBoost |
Protected field | internalIsBinary |
Protected field | internalIsIndexed |
Protected field | internalIsStored |
Protected field | internalIsTokenized |
Protected field | internalName |
Protected field | internalOmitNorms |
Protected field | internalOmitTermFreqAndPositions |
Protected field | lazy |
Protected field | storeOffsetWithTermVector |
Protected field | storePositionWithTermVector |
Protected field | storeTermVector |
Protected field | tokenStream |
Back to Top
See Also
AbstractField Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


fieldsData Field

AbstractField fieldsData Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Object fieldsData
protected Object fieldsData
Protected fieldsData As Object
Protected fieldsData As Object
protected:
Object^ fieldsData
protected:
Object^ fieldsData
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalBinaryLength Field

AbstractField internalBinaryLength Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int internalBinaryLength
protected int internalBinaryLength
Protected internalBinaryLength As Integer
Protected internalBinaryLength As Integer
protected:
int internalBinaryLength
protected:
int internalBinaryLength
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalbinaryOffset Field

AbstractField internalbinaryOffset Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int internalbinaryOffset
protected int internalbinaryOffset
Protected internalbinaryOffset As Integer
Protected internalbinaryOffset As Integer
protected:
int internalbinaryOffset
protected:
int internalbinaryOffset
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalBoost Field

AbstractField internalBoost Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected float internalBoost
protected float internalBoost
Protected internalBoost As Single
Protected internalBoost As Single
protected:
float internalBoost
protected:
float internalBoost
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalIsBinary Field

AbstractField internalIsBinary Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool internalIsBinary
protected bool internalIsBinary
Protected internalIsBinary As Boolean
Protected internalIsBinary As Boolean
protected:
bool internalIsBinary
protected:
bool internalIsBinary
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalIsIndexed Field

AbstractField internalIsIndexed Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool internalIsIndexed
protected bool internalIsIndexed
Protected internalIsIndexed As Boolean
Protected internalIsIndexed As Boolean
protected:
bool internalIsIndexed
protected:
bool internalIsIndexed
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalIsStored Field

AbstractField internalIsStored Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool internalIsStored
protected bool internalIsStored
Protected internalIsStored As Boolean
Protected internalIsStored As Boolean
protected:
bool internalIsStored
protected:
bool internalIsStored
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalIsTokenized Field

AbstractField internalIsTokenized Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool internalIsTokenized
protected bool internalIsTokenized
Protected internalIsTokenized As Boolean
Protected internalIsTokenized As Boolean
protected:
bool internalIsTokenized
protected:
bool internalIsTokenized
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalName Field

AbstractField internalName Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string internalName
protected string internalName
Protected internalName As String
Protected internalName As String
protected:
String^ internalName
protected:
String^ internalName
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalOmitNorms Field

AbstractField internalOmitNorms Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool internalOmitNorms
protected bool internalOmitNorms
Protected internalOmitNorms As Boolean
Protected internalOmitNorms As Boolean
protected:
bool internalOmitNorms
protected:
bool internalOmitNorms
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalOmitTermFreqAndPositions Field

AbstractField internalOmitTermFreqAndPositions Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool internalOmitTermFreqAndPositions
protected bool internalOmitTermFreqAndPositions
Protected internalOmitTermFreqAndPositions As Boolean
Protected internalOmitTermFreqAndPositions As Boolean
protected:
bool internalOmitTermFreqAndPositions
protected:
bool internalOmitTermFreqAndPositions
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


lazy Field

AbstractField lazy Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool lazy
protected bool lazy
Protected lazy As Boolean
Protected lazy As Boolean
protected:
bool lazy
protected:
bool lazy
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


storeOffsetWithTermVector Field

AbstractField storeOffsetWithTermVector Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool storeOffsetWithTermVector
protected bool storeOffsetWithTermVector
Protected storeOffsetWithTermVector As Boolean
Protected storeOffsetWithTermVector As Boolean
protected:
bool storeOffsetWithTermVector
protected:
bool storeOffsetWithTermVector
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


storePositionWithTermVector Field

AbstractField storePositionWithTermVector Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool storePositionWithTermVector
protected bool storePositionWithTermVector
Protected storePositionWithTermVector As Boolean
Protected storePositionWithTermVector As Boolean
protected:
bool storePositionWithTermVector
protected:
bool storePositionWithTermVector
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


storeTermVector Field

AbstractField storeTermVector Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool storeTermVector
protected bool storeTermVector
Protected storeTermVector As Boolean
Protected storeTermVector As Boolean
protected:
bool storeTermVector
protected:
bool storeTermVector
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


tokenStream Field

AbstractField tokenStream Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TokenStream tokenStream
protected TokenStream tokenStream
Protected tokenStream As TokenStream
Protected tokenStream As TokenStream
protected:
TokenStream^ tokenStream
protected:
TokenStream^ tokenStream
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AbstractField Methods

AbstractField Methods Lucene.Net Class Library
The AbstractField type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBinaryValue | Return the raw byte[] for the binary field. Note that you must also call BinaryLength and BinaryOffset to know which range of bytes in this returned array belong to the field.
Public method | GetBinaryValue( Byte ) |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | SetStoreTermVector |
Public method | ToString | Prints a Field for human consumption. (Overrides Online Object ToString .)
Back to Top
See Also
AbstractField Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBinaryValue Method

AbstractField GetBinaryValue Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetBinaryValue | Return the raw byte[] for the binary field. Note that you must also call BinaryLength and BinaryOffset to know which range of bytes in this returned array belong to the field.
Public method | GetBinaryValue( Byte ) |
Back to Top
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBinaryValue Method

AbstractField GetBinaryValue Method Lucene.Net Class Library
Return the raw byte[] for the binary field. Note that you must also call BinaryLength and BinaryOffset to know which range of bytes in this returned array belong to the field.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual byte[] GetBinaryValue()
public virtual byte[] GetBinaryValue()
Public Overridable Function GetBinaryValue As Byte()
Public Overridable Function GetBinaryValue As Byte()
public:
virtual array<unsigned char>^ GetBinaryValue()
public:
virtual array<unsigned char>^ GetBinaryValue()
Return Value
 reference to the Field value as byte[].
Implements
IFieldable GetBinaryValue
See Also
AbstractField Class
AbstractField Members
GetBinaryValue Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBinaryValue Method (Byte[])

AbstractField GetBinaryValue Method ( Byte ) Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual byte[] GetBinaryValue(
    byte[] result
)
public virtual byte[] GetBinaryValue(
    byte[] result
)
Public Overridable Function GetBinaryValue ( _
    result As Byte() _
) As Byte()
Public Overridable Function GetBinaryValue ( _
    result As Byte() _
) As Byte()
public:
virtual array<unsigned char>^ GetBinaryValue(
    array<unsigned char>^ result
)
public:
virtual array<unsigned char>^ GetBinaryValue(
    array<unsigned char>^ result
)
Parameters
result
Type:    Online System Byte
Implements
IFieldable GetBinaryValue( Byte )
See Also
AbstractField Class
AbstractField Members
GetBinaryValue Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetStoreTermVector Method

AbstractField SetStoreTermVector Method Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void SetStoreTermVector(
    Field..::..TermVector termVector
)
protected virtual void SetStoreTermVector(
    Field..::..TermVector termVector
)
Protected Overridable Sub SetStoreTermVector ( _
    termVector As Field..::..TermVector _
)
Protected Overridable Sub SetStoreTermVector ( _
    termVector As Field..::..TermVector _
)
protected:
virtual void SetStoreTermVector(
    Field..::..TermVector termVector
)
protected:
virtual void SetStoreTermVector(
    Field..::..TermVector termVector
)
Parameters
termVector
Type: Lucene.Net.Documents Field TermVector
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

AbstractField ToString Method Lucene.Net Class Library
Prints a Field for human consumption.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AbstractField Properties

AbstractField Properties Lucene.Net Class Library
The AbstractField type exposes the following members.
Properties
 | Name | Description
Public property | BinaryLength | Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined
Public property | BinaryOffset | Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined
Public property | Boost | Gets or sets the boost factor for hits for this field. The default value is 1.0. Note: this value is not stored directly with the document in the index. Documents returned from Document(Int32) and Doc(Int32) may thus not have the same value present as when this field was indexed.
Public property | IsBinary | True iff the value of the filed is stored as binary
Public property | IsIndexed | True iff the value of the field is to be indexed, so that it may be searched on.
Public property | IsLazy |
Public property | IsStored | True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.
Public property | IsStoreOffsetWithTermVector | True iff terms are stored as term vector together with their offsets (start and end position in source text).
Public property | IsStorePositionWithTermVector | True iff terms are stored as term vector together with their token positions.
Public property | IsTermVectorStored | True iff the term or terms used to index this field are stored as a term vector, available from GetTermFreqVector(Int32, String). These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the stored attribute instead.
Public property | IsTokenized | True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Public property | Name | Returns the name of the field as an interned string. For example "date", "title", "body", ...
Public property | OmitNorms | True if norms are omitted for this indexed field
Public property | OmitTermFreqAndPositions | Expert: If set, omit term freq, positions and payloads from postings for this field. NOTE: While this option reduces storage space required in the index, it also means any query requiring positional information, such as PhraseQuery or SpanQuery subclasses will silently fail to find results.
Public property | ReaderValue |
Public property | StringValue |
Public property | TokenStreamValue |
Back to Top
See Also
AbstractField Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BinaryLength Property

AbstractField BinaryLength Property Lucene.Net Class Library
Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int BinaryLength { get; }
public virtual int BinaryLength { get; }
Public Overridable ReadOnly Property BinaryLength As Integer
    Get
Public Overridable ReadOnly Property BinaryLength As Integer
    Get
public:
virtual property int BinaryLength {
    int get ();
}
public:
virtual property int BinaryLength {
    int get ();
}
Field Value
 length of byte[] segment that represents this Field value
Implements
IFieldable BinaryLength
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BinaryOffset Property

AbstractField BinaryOffset Property Lucene.Net Class Library
Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int BinaryOffset { get; }
public virtual int BinaryOffset { get; }
Public Overridable ReadOnly Property BinaryOffset As Integer
    Get
Public Overridable ReadOnly Property BinaryOffset As Integer
    Get
public:
virtual property int BinaryOffset {
    int get ();
}
public:
virtual property int BinaryOffset {
    int get ();
}
Field Value
 index of the first character in byte[] segment that represents this Field value
Implements
IFieldable BinaryOffset
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Boost Property

AbstractField Boost Property Lucene.Net Class Library
Gets or sets the boost factor for hits for this field.

The default value is 1.0.

Note: this value is not stored directly with the document in the index. Documents returned from Document(Int32) and Doc(Int32) may thus not have the same value present as when this field was indexed.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual float Boost { get; set; }
public virtual float Boost { get; set; }
Public Overridable Property Boost As Single
    Get
    Set
Public Overridable Property Boost As Single
    Get
    Set
public:
virtual property float Boost {
    float get ();
    void set (float value);
}
public:
virtual property float Boost {
    float get ();
    void set (float value);
}
Implements
IFieldable Boost
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsBinary Property

AbstractField IsBinary Property Lucene.Net Class Library
True iff the value of the filed is stored as binary

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsBinary { get; }
public bool IsBinary { get; }
Public ReadOnly Property IsBinary As Boolean
    Get
Public ReadOnly Property IsBinary As Boolean
    Get
public:
virtual property bool IsBinary {
    bool get () sealed;
}
public:
virtual property bool IsBinary {
    bool get () sealed;
}
Implements
IFieldable IsBinary
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsIndexed Property

AbstractField IsIndexed Property Lucene.Net Class Library
True iff the value of the field is to be indexed, so that it may be searched on.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsIndexed { get; }
public bool IsIndexed { get; }
Public ReadOnly Property IsIndexed As Boolean
    Get
Public ReadOnly Property IsIndexed As Boolean
    Get
public:
virtual property bool IsIndexed {
    bool get () sealed;
}
public:
virtual property bool IsIndexed {
    bool get () sealed;
}
Implements
IFieldable IsIndexed
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsLazy Property

AbstractField IsLazy Property Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsLazy { get; }
public virtual bool IsLazy { get; }
Public Overridable ReadOnly Property IsLazy As Boolean
    Get
Public Overridable ReadOnly Property IsLazy As Boolean
    Get
public:
virtual property bool IsLazy {
    bool get ();
}
public:
virtual property bool IsLazy {
    bool get ();
}
Implements
IFieldable IsLazy
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsStored Property

AbstractField IsStored Property Lucene.Net Class Library
True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsStored { get; }
public bool IsStored { get; }
Public ReadOnly Property IsStored As Boolean
    Get
Public ReadOnly Property IsStored As Boolean
    Get
public:
virtual property bool IsStored {
    bool get () sealed;
}
public:
virtual property bool IsStored {
    bool get () sealed;
}
Implements
IFieldable IsStored
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsStoreOffsetWithTermVector Property

AbstractField IsStoreOffsetWithTermVector Property Lucene.Net Class Library
True iff terms are stored as term vector together with their offsets (start and end position in source text).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsStoreOffsetWithTermVector { get; }
public virtual bool IsStoreOffsetWithTermVector { get; }
Public Overridable ReadOnly Property IsStoreOffsetWithTermVector As Boolean
    Get
Public Overridable ReadOnly Property IsStoreOffsetWithTermVector As Boolean
    Get
public:
virtual property bool IsStoreOffsetWithTermVector {
    bool get ();
}
public:
virtual property bool IsStoreOffsetWithTermVector {
    bool get ();
}
Implements
IFieldable IsStoreOffsetWithTermVector
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsStorePositionWithTermVector Property

AbstractField IsStorePositionWithTermVector Property Lucene.Net Class Library
True iff terms are stored as term vector together with their token positions.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsStorePositionWithTermVector { get; }
public virtual bool IsStorePositionWithTermVector { get; }
Public Overridable ReadOnly Property IsStorePositionWithTermVector As Boolean
    Get
Public Overridable ReadOnly Property IsStorePositionWithTermVector As Boolean
    Get
public:
virtual property bool IsStorePositionWithTermVector {
    bool get ();
}
public:
virtual property bool IsStorePositionWithTermVector {
    bool get ();
}
Implements
IFieldable IsStorePositionWithTermVector
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsTermVectorStored Property

AbstractField IsTermVectorStored Property Lucene.Net Class Library
True iff the term or terms used to index this field are stored as a term vector, available from GetTermFreqVector(Int32, String). These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the stored attribute instead.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsTermVectorStored { get; }
public bool IsTermVectorStored { get; }
Public ReadOnly Property IsTermVectorStored As Boolean
    Get
Public ReadOnly Property IsTermVectorStored As Boolean
    Get
public:
virtual property bool IsTermVectorStored {
    bool get () sealed;
}
public:
virtual property bool IsTermVectorStored {
    bool get () sealed;
}
Implements
IFieldable IsTermVectorStored
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
IndexReader GetTermFreqVector(Int32, String)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsTokenized Property

AbstractField IsTokenized Property Lucene.Net Class Library
True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsTokenized { get; }
public bool IsTokenized { get; }
Public ReadOnly Property IsTokenized As Boolean
    Get
Public ReadOnly Property IsTokenized As Boolean
    Get
public:
virtual property bool IsTokenized {
    bool get () sealed;
}
public:
virtual property bool IsTokenized {
    bool get () sealed;
}
Implements
IFieldable IsTokenized
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Name Property

AbstractField Name Property Lucene.Net Class Library
Returns the name of the field as an interned string. For example "date", "title", "body", ...

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Name { get; }
public virtual string Name { get; }
Public Overridable ReadOnly Property Name As String
    Get
Public Overridable ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get ();
}
public:
virtual property String^ Name {
    String^ get ();
}
Implements
IFieldable Name
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OmitNorms Property

AbstractField OmitNorms Property Lucene.Net Class Library
True if norms are omitted for this indexed field

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool OmitNorms { get; set; }
public virtual bool OmitNorms { get; set; }
Public Overridable Property OmitNorms As Boolean
    Get
    Set
Public Overridable Property OmitNorms As Boolean
    Get
    Set
public:
virtual property bool OmitNorms {
    bool get ();
    void set (bool value);
}
public:
virtual property bool OmitNorms {
    bool get ();
    void set (bool value);
}
Implements
IFieldable OmitNorms
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OmitTermFreqAndPositions Property

AbstractField OmitTermFreqAndPositions Property Lucene.Net Class Library
Expert: If set, omit term freq, positions and payloads from postings for this field.

NOTE: While this option reduces storage space required in the index, it also means any query requiring positional information, such as PhraseQuery or SpanQuery subclasses will silently fail to find results.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool OmitTermFreqAndPositions { get; set; }
public virtual bool OmitTermFreqAndPositions { get; set; }
Public Overridable Property OmitTermFreqAndPositions As Boolean
    Get
    Set
Public Overridable Property OmitTermFreqAndPositions As Boolean
    Get
    Set
public:
virtual property bool OmitTermFreqAndPositions {
    bool get ();
    void set (bool value);
}
public:
virtual property bool OmitTermFreqAndPositions {
    bool get ();
    void set (bool value);
}
Implements
IFieldable OmitTermFreqAndPositions
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReaderValue Property

AbstractField ReaderValue Property Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract TextReader ReaderValue { get; }
public abstract TextReader ReaderValue { get; }
Public MustOverride ReadOnly Property ReaderValue As TextReader
    Get
Public MustOverride ReadOnly Property ReaderValue As TextReader
    Get
public:
virtual property TextReader^ ReaderValue {
    TextReader^ get () abstract;
}
public:
virtual property TextReader^ ReaderValue {
    TextReader^ get () abstract;
}
Implements
IFieldable ReaderValue
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringValue Property

AbstractField StringValue Property Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string StringValue { get; }
public abstract string StringValue { get; }
Public MustOverride ReadOnly Property StringValue As String
    Get
Public MustOverride ReadOnly Property StringValue As String
    Get
public:
virtual property String^ StringValue {
    String^ get () abstract;
}
public:
virtual property String^ StringValue {
    String^ get () abstract;
}
Implements
IFieldable StringValue
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStreamValue Property

AbstractField TokenStreamValue Property Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract TokenStream TokenStreamValue { get; }
public abstract TokenStream TokenStreamValue { get; }
Public MustOverride ReadOnly Property TokenStreamValue As TokenStream
    Get
Public MustOverride ReadOnly Property TokenStreamValue As TokenStream
    Get
public:
virtual property TokenStream^ TokenStreamValue {
    TokenStream^ get () abstract;
}
public:
virtual property TokenStream^ TokenStreamValue {
    TokenStream^ get () abstract;
}
Implements
IFieldable TokenStreamValue
See Also
AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompressionTools Class

CompressionTools Class Lucene.Net Class Library
Simple utility class providing static methods to compress and decompress binary data for stored fields. This class uses java.util.zip.Deflater and Inflater classes to compress and decompress.
Inheritance Hierarchy
Online System Object
Lucene.Net.Documents CompressionTools

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CompressionTools
public class CompressionTools
Public Class CompressionTools
Public Class CompressionTools
public ref class CompressionTools
public ref class CompressionTools
See Also
CompressionTools Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompressionTools Members

CompressionTools Members Lucene.Net Class Library

The CompressionTools type exposes the following members.
Methods
 | Name | Description
 | Compress( Byte ) | Compresses all bytes in the array, with default BEST_COMPRESSION level
 | Compress( Byte , Int32, Int32) | Compresses the specified byte range, with default BEST_COMPRESSION level
 | Compress( Byte , Int32, Int32, Int32) | Compresses the specified byte range using the specified compressionLevel (constants are defined in java.util.zip.Deflater).
 | CompressString(String) | Compresses the String value, with default BEST_COMPRESSION level
 | CompressString(String, Int32) | Compresses the String value using the specified compressionLevel (constants are defined in java.util.zip.Deflater).
 | Decompress | Decompress the byte array previously returned by compress
 | DecompressString | Decompress the byte array previously returned by compressString back into a String
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CompressionTools Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompressionTools Methods

CompressionTools Methods Lucene.Net Class Library
The CompressionTools type exposes the following members.
Methods
 | Name | Description
 | Compress( Byte ) | Compresses all bytes in the array, with default BEST_COMPRESSION level
 | Compress( Byte , Int32, Int32) | Compresses the specified byte range, with default BEST_COMPRESSION level
 | Compress( Byte , Int32, Int32, Int32) | Compresses the specified byte range using the specified compressionLevel (constants are defined in java.util.zip.Deflater).
 | CompressString(String) | Compresses the String value, with default BEST_COMPRESSION level
 | CompressString(String, Int32) | Compresses the String value using the specified compressionLevel (constants are defined in java.util.zip.Deflater).
 | Decompress | Decompress the byte array previously returned by compress
 | DecompressString | Decompress the byte array previously returned by compressString back into a String
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CompressionTools Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compress Method

CompressionTools Compress Method Lucene.Net Class Library
Overload List
Name | Description
Compress( Byte ) | Compresses all bytes in the array, with default BEST_COMPRESSION level
Compress( Byte , Int32, Int32) | Compresses the specified byte range, with default BEST_COMPRESSION level
Compress( Byte , Int32, Int32, Int32) | Compresses the specified byte range using the specified compressionLevel (constants are defined in java.util.zip.Deflater).
Back to Top
See Also
CompressionTools Class
CompressionTools Members
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compress Method (Byte[])

CompressionTools Compress Method ( Byte ) Lucene.Net Class Library
Compresses all bytes in the array, with default BEST_COMPRESSION level

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] Compress(
    byte[] value_Renamed
)
public static byte[] Compress(
    byte[] value_Renamed
)
Public Shared Function Compress ( _
    value_Renamed As Byte() _
) As Byte()
Public Shared Function Compress ( _
    value_Renamed As Byte() _
) As Byte()
public:
static array<unsigned char>^ Compress(
    array<unsigned char>^ value_Renamed
)
public:
static array<unsigned char>^ Compress(
    array<unsigned char>^ value_Renamed
)
Parameters
value_Renamed
Type:    Online System Byte
See Also
CompressionTools Class
CompressionTools Members
Compress Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compress Method (Byte[], Int32, Int32)

CompressionTools Compress Method ( Byte , Int32, Int32) Lucene.Net Class Library
Compresses the specified byte range, with default BEST_COMPRESSION level

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] Compress(
    byte[] value_Renamed,
    int offset,
    int length
)
public static byte[] Compress(
    byte[] value_Renamed,
    int offset,
    int length
)
Public Shared Function Compress ( _
    value_Renamed As Byte(), _
    offset As Integer, _
    length As Integer _
) As Byte()
Public Shared Function Compress ( _
    value_Renamed As Byte(), _
    offset As Integer, _
    length As Integer _
) As Byte()
public:
static array<unsigned char>^ Compress(
    array<unsigned char>^ value_Renamed,
    int offset,
    int length
)
public:
static array<unsigned char>^ Compress(
    array<unsigned char>^ value_Renamed,
    int offset,
    int length
)
Parameters
value_Renamed
Type:    Online System Byte
offset
Type:   Online System Int32
length
Type:   Online System Int32
See Also
CompressionTools Class
CompressionTools Members
Compress Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compress Method (Byte[], Int32, Int32, Int32)

CompressionTools Compress Method ( Byte , Int32, Int32, Int32) Lucene.Net Class Library
Compresses the specified byte range using the specified compressionLevel (constants are defined in java.util.zip.Deflater).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] Compress(
    byte[] value_Renamed,
    int offset,
    int length,
    int compressionLevel
)
public static byte[] Compress(
    byte[] value_Renamed,
    int offset,
    int length,
    int compressionLevel
)
Public Shared Function Compress ( _
    value_Renamed As Byte(), _
    offset As Integer, _
    length As Integer, _
    compressionLevel As Integer _
) As Byte()
Public Shared Function Compress ( _
    value_Renamed As Byte(), _
    offset As Integer, _
    length As Integer, _
    compressionLevel As Integer _
) As Byte()
public:
static array<unsigned char>^ Compress(
    array<unsigned char>^ value_Renamed,
    int offset,
    int length,
    int compressionLevel
)
public:
static array<unsigned char>^ Compress(
    array<unsigned char>^ value_Renamed,
    int offset,
    int length,
    int compressionLevel
)
Parameters
value_Renamed
Type:    Online System Byte
offset
Type:   Online System Int32
length
Type:   Online System Int32
compressionLevel
Type:   Online System Int32
See Also
CompressionTools Class
CompressionTools Members
Compress Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompressString Method

CompressionTools CompressString Method Lucene.Net Class Library
Overload List
Name | Description
CompressString(String) | Compresses the String value, with default BEST_COMPRESSION level
CompressString(String, Int32) | Compresses the String value using the specified compressionLevel (constants are defined in java.util.zip.Deflater).
Back to Top
See Also
CompressionTools Class
CompressionTools Members
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompressString Method (String)

CompressionTools CompressString Method (String) Lucene.Net Class Library
Compresses the String value, with default BEST_COMPRESSION level

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] CompressString(
    string value_Renamed
)
public static byte[] CompressString(
    string value_Renamed
)
Public Shared Function CompressString ( _
    value_Renamed As String _
) As Byte()
Public Shared Function CompressString ( _
    value_Renamed As String _
) As Byte()
public:
static array<unsigned char>^ CompressString(
    String^ value_Renamed
)
public:
static array<unsigned char>^ CompressString(
    String^ value_Renamed
)
Parameters
value_Renamed
Type:   Online System String
See Also
CompressionTools Class
CompressionTools Members
CompressString Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompressString Method (String, Int32)

CompressionTools CompressString Method (String, Int32) Lucene.Net Class Library
Compresses the String value using the specified compressionLevel (constants are defined in java.util.zip.Deflater).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] CompressString(
    string value_Renamed,
    int compressionLevel
)
public static byte[] CompressString(
    string value_Renamed,
    int compressionLevel
)
Public Shared Function CompressString ( _
    value_Renamed As String, _
    compressionLevel As Integer _
) As Byte()
Public Shared Function CompressString ( _
    value_Renamed As String, _
    compressionLevel As Integer _
) As Byte()
public:
static array<unsigned char>^ CompressString(
    String^ value_Renamed,
    int compressionLevel
)
public:
static array<unsigned char>^ CompressString(
    String^ value_Renamed,
    int compressionLevel
)
Parameters
value_Renamed
Type:   Online System String
compressionLevel
Type:   Online System Int32
See Also
CompressionTools Class
CompressionTools Members
CompressString Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Decompress Method

CompressionTools Decompress Method Lucene.Net Class Library
Decompress the byte array previously returned by compress

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] Decompress(
    byte[] value_Renamed
)
public static byte[] Decompress(
    byte[] value_Renamed
)
Public Shared Function Decompress ( _
    value_Renamed As Byte() _
) As Byte()
Public Shared Function Decompress ( _
    value_Renamed As Byte() _
) As Byte()
public:
static array<unsigned char>^ Decompress(
    array<unsigned char>^ value_Renamed
)
public:
static array<unsigned char>^ Decompress(
    array<unsigned char>^ value_Renamed
)
Parameters
value_Renamed
Type:    Online System Byte
See Also
CompressionTools Class
CompressionTools Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DecompressString Method

CompressionTools DecompressString Method Lucene.Net Class Library
Decompress the byte array previously returned by compressString back into a String

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string DecompressString(
    byte[] value_Renamed
)
public static string DecompressString(
    byte[] value_Renamed
)
Public Shared Function DecompressString ( _
    value_Renamed As Byte() _
) As String
Public Shared Function DecompressString ( _
    value_Renamed As Byte() _
) As String
public:
static String^ DecompressString(
    array<unsigned char>^ value_Renamed
)
public:
static String^ DecompressString(
    array<unsigned char>^ value_Renamed
)
Parameters
value_Renamed
Type:    Online System Byte
See Also
CompressionTools Class
CompressionTools Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DateField Class

DateField Class Lucene.Net Class Library
Provides support for converting dates to strings and vice-versa. The strings are structured so that lexicographic sorting orders by date, which makes them suitable for use as field values and search terms.

Note that this class saves dates with millisecond granularity, which is bad for TermRangeQuery and PrefixQuery, as those queries are expanded to a BooleanQuery with a potentially large number of terms when searching. Thus you might want to use DateTools instead.

Note: dates before 1970 cannot be used, and therefore cannot be indexed when using this class. See DateTools for an alternative without such a limitation.

Another approach is NumericUtils, which provides a sortable binary representation (prefix encoded) of numeric values, which date/time are. For indexing a Online DateTime, convert it to unix timestamp as long and index this as a numeric value with NumericField and use NumericRangeQuery T to query it.
Inheritance Hierarchy
Online System Object
Lucene.Net.Documents DateField

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("If you build a new index, use DateTools or NumericField instead.This class is included for use with existing indices and will be removed in a future release (possibly Lucene 4.0).")]
public class DateField
[ObsoleteAttribute("If you build a new index, use DateTools or NumericField instead.This class is included for use with existing indices and will be removed in a future release (possibly Lucene 4.0).")]
public class DateField
<ObsoleteAttribute("If you build a new index, use DateTools or NumericField instead.This class is included for use with existing indices and will be removed in a future release (possibly Lucene 4.0).")> _
Public Class DateField
<ObsoleteAttribute("If you build a new index, use DateTools or NumericField instead.This class is included for use with existing indices and will be removed in a future release (possibly Lucene 4.0).")> _
Public Class DateField
[ObsoleteAttribute(L"If you build a new index, use DateTools or NumericField instead.This class is included for use with existing indices and will be removed in a future release (possibly Lucene 4.0).")]
public ref class DateField
[ObsoleteAttribute(L"If you build a new index, use DateTools or NumericField instead.This class is included for use with existing indices and will be removed in a future release (possibly Lucene 4.0).")]
public ref class DateField
See Also
DateField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DateField Members

DateField Members Lucene.Net Class Library

The DateField type exposes the following members.
Methods
 | Name | Description
 | DateToString | Converts a Date to a string suitable for indexing.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | MAX_DATE_STRING |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | MIN_DATE_STRING |
 | StringToDate | Converts a string-encoded date into a Date object.
 | StringToTime | Converts a string-encoded date into a millisecond time.
 | TimeToString | Converts a millisecond time to a string suitable for indexing.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DateField Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DateField Methods

DateField Methods Lucene.Net Class Library
The DateField type exposes the following members.
Methods
 | Name | Description
 | DateToString | Converts a Date to a string suitable for indexing.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | MAX_DATE_STRING |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | MIN_DATE_STRING |
 | StringToDate | Converts a string-encoded date into a Date object.
 | StringToTime | Converts a string-encoded date into a millisecond time.
 | TimeToString | Converts a millisecond time to a string suitable for indexing.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DateField Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DateToString Method

DateField DateToString Method Lucene.Net Class Library
Converts a Date to a string suitable for indexing.
method argument is before 1970

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string DateToString(
    DateTime date
)
public static string DateToString(
    DateTime date
)
Public Shared Function DateToString ( _
    date As DateTime _
) As String
Public Shared Function DateToString ( _
    date As DateTime _
) As String
public:
static String^ DateToString(
    DateTime date
)
public:
static String^ DateToString(
    DateTime date
)
Parameters
date
Type:   Online System DateTime
See Also
DateField Class
DateField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MAX_DATE_STRING Method

DateField MAX_DATE_STRING Method Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string MAX_DATE_STRING()
public static string MAX_DATE_STRING()
Public Shared Function MAX_DATE_STRING As String
Public Shared Function MAX_DATE_STRING As String
public:
static String^ MAX_DATE_STRING()
public:
static String^ MAX_DATE_STRING()
See Also
DateField Class
DateField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MIN_DATE_STRING Method

DateField MIN_DATE_STRING Method Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string MIN_DATE_STRING()
public static string MIN_DATE_STRING()
Public Shared Function MIN_DATE_STRING As String
Public Shared Function MIN_DATE_STRING As String
public:
static String^ MIN_DATE_STRING()
public:
static String^ MIN_DATE_STRING()
See Also
DateField Class
DateField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringToDate Method

DateField StringToDate Method Lucene.Net Class Library
Converts a string-encoded date into a Date object.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime StringToDate(
    string s
)
public static DateTime StringToDate(
    string s
)
Public Shared Function StringToDate ( _
    s As String _
) As DateTime
Public Shared Function StringToDate ( _
    s As String _
) As DateTime
public:
static DateTime StringToDate(
    String^ s
)
public:
static DateTime StringToDate(
    String^ s
)
Parameters
s
Type:   Online System String
See Also
DateField Class
DateField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringToTime Method

DateField StringToTime Method Lucene.Net Class Library
Converts a string-encoded date into a millisecond time.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long StringToTime(
    string s
)
public static long StringToTime(
    string s
)
Public Shared Function StringToTime ( _
    s As String _
) As Long
Public Shared Function StringToTime ( _
    s As String _
) As Long
public:
static long long StringToTime(
    String^ s
)
public:
static long long StringToTime(
    String^ s
)
Parameters
s
Type:   Online System String
See Also
DateField Class
DateField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TimeToString Method

DateField TimeToString Method Lucene.Net Class Library
Converts a millisecond time to a string suitable for indexing.
method argument is negative, that is, before 1970

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string TimeToString(
    long time
)
public static string TimeToString(
    long time
)
Public Shared Function TimeToString ( _
    time As Long _
) As String
Public Shared Function TimeToString ( _
    time As Long _
) As String
public:
static String^ TimeToString(
    long long time
)
public:
static String^ TimeToString(
    long long time
)
Parameters
time
Type:   Online System Int64
See Also
DateField Class
DateField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DateTools Class

DateTools Class Lucene.Net Class Library
Provides support for converting dates to strings and vice-versa. The strings are structured so that lexicographic sorting orders them by date, which makes them suitable for use as field values and search terms.

This class also helps you to limit the resolution of your dates. Do not save dates with a finer resolution than you really need, as then RangeQuery and PrefixQuery will require more memory and become slower.

Compared to DateField the strings generated by the methods in this class take slightly more space, unless your selected resolution is set to Resolution.DAY or lower.

Another approach is NumericUtils, which provides a sortable binary representation (prefix encoded) of numeric values, which date/time are. For indexing a Online DateTime, convert it to unix timestamp as long and index this as a numeric value with NumericField and use NumericRangeQuery T to query it.
Inheritance Hierarchy
Online System Object
Lucene.Net.Documents DateTools

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DateTools
public class DateTools
Public Class DateTools
Public Class DateTools
public ref class DateTools
public ref class DateTools
See Also
DateTools Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DateTools Members

DateTools Members Lucene.Net Class Library

The DateTools type exposes the following members.
Methods
 | Name | Description
 | DateToString | Converts a Date to a string suitable for indexing.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Round(DateTime, DateTools Resolution) | Limit a date's resolution. For example, the date 2004-09-21 13:50:11 will be changed to 2004-09-01 00:00:00 when using Resolution.MONTH.
 | Round(Int64, DateTools Resolution) | Limit a date's resolution. For example, the date 1095767411000 (which represents 2004-09-21 13:50:11) will be changed to 1093989600000 (2004-09-01 00:00:00) when using Resolution.MONTH.
 | StringToDate | Converts a string produced by timeToString or DateToString back to a time, represented as a Date object.
 | StringToTime | Converts a string produced by timeToString or DateToString back to a time, represented as the number of milliseconds since January 1, 1970, 00:00:00 GMT.
 | TimeToString | Converts a millisecond time to a string suitable for indexing.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DateTools Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DateTools Methods

DateTools Methods Lucene.Net Class Library
The DateTools type exposes the following members.
Methods
 | Name | Description
 | DateToString | Converts a Date to a string suitable for indexing.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Round(DateTime, DateTools Resolution) | Limit a date's resolution. For example, the date 2004-09-21 13:50:11 will be changed to 2004-09-01 00:00:00 when using Resolution.MONTH.
 | Round(Int64, DateTools Resolution) | Limit a date's resolution. For example, the date 1095767411000 (which represents 2004-09-21 13:50:11) will be changed to 1093989600000 (2004-09-01 00:00:00) when using Resolution.MONTH.
 | StringToDate | Converts a string produced by timeToString or DateToString back to a time, represented as a Date object.
 | StringToTime | Converts a string produced by timeToString or DateToString back to a time, represented as the number of milliseconds since January 1, 1970, 00:00:00 GMT.
 | TimeToString | Converts a millisecond time to a string suitable for indexing.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DateTools Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DateToString Method

DateTools DateToString Method Lucene.Net Class Library
Converts a Date to a string suitable for indexing.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string DateToString(
    DateTime date,
    DateTools..::..Resolution resolution
)
public static string DateToString(
    DateTime date,
    DateTools..::..Resolution resolution
)
Public Shared Function DateToString ( _
    date As DateTime, _
    resolution As DateTools..::..Resolution _
) As String
Public Shared Function DateToString ( _
    date As DateTime, _
    resolution As DateTools..::..Resolution _
) As String
public:
static String^ DateToString(
    DateTime date,
    DateTools..::..Resolution^ resolution
)
public:
static String^ DateToString(
    DateTime date,
    DateTools..::..Resolution^ resolution
)
Parameters
date
Type:   Online System DateTime
the date to be converted

resolution
Type: Lucene.Net.Documents DateTools Resolution
the desired resolution, see
            Round(DateTime, DateTools Resolution)
Return Value
 a string in format yyyyMMddHHmmssSSS or shorter,
            depending on resolution; using GMT as timezone

See Also
DateTools Class
DateTools Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Round Method

DateTools Round Method Lucene.Net Class Library
Overload List
Name | Description
Round(DateTime, DateTools Resolution) | Limit a date's resolution. For example, the date 2004-09-21 13:50:11 will be changed to 2004-09-01 00:00:00 when using Resolution.MONTH.
Round(Int64, DateTools Resolution) | Limit a date's resolution. For example, the date 1095767411000 (which represents 2004-09-21 13:50:11) will be changed to 1093989600000 (2004-09-01 00:00:00) when using Resolution.MONTH.
Back to Top
See Also
DateTools Class
DateTools Members
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Round Method (DateTime, DateTools.Resolution)

DateTools Round Method (DateTime, DateTools Resolution) Lucene.Net Class Library
Limit a date's resolution. For example, the date 2004-09-21 13:50:11 will be changed to 2004-09-01 00:00:00 when using Resolution.MONTH.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime Round(
    DateTime date,
    DateTools..::..Resolution resolution
)
public static DateTime Round(
    DateTime date,
    DateTools..::..Resolution resolution
)
Public Shared Function Round ( _
    date As DateTime, _
    resolution As DateTools..::..Resolution _
) As DateTime
Public Shared Function Round ( _
    date As DateTime, _
    resolution As DateTools..::..Resolution _
) As DateTime
public:
static DateTime Round(
    DateTime date,
    DateTools..::..Resolution^ resolution
)
public:
static DateTime Round(
    DateTime date,
    DateTools..::..Resolution^ resolution
)
Parameters
date
Type:   Online System DateTime
resolution
Type: Lucene.Net.Documents DateTools Resolution
The desired resolution of the date to be returned

Return Value
 the date with all values more precise than resolution
            set to 0 or 1

See Also
DateTools Class
DateTools Members
Round Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Round Method (Int64, DateTools.Resolution)

DateTools Round Method (Int64, DateTools Resolution) Lucene.Net Class Library
Limit a date's resolution. For example, the date 1095767411000 (which represents 2004-09-21 13:50:11) will be changed to 1093989600000 (2004-09-01 00:00:00) when using Resolution.MONTH.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long Round(
    long time,
    DateTools..::..Resolution resolution
)
public static long Round(
    long time,
    DateTools..::..Resolution resolution
)
Public Shared Function Round ( _
    time As Long, _
    resolution As DateTools..::..Resolution _
) As Long
Public Shared Function Round ( _
    time As Long, _
    resolution As DateTools..::..Resolution _
) As Long
public:
static long long Round(
    long long time,
    DateTools..::..Resolution^ resolution
)
public:
static long long Round(
    long long time,
    DateTools..::..Resolution^ resolution
)
Parameters
time
Type:   Online System Int64
The time in milliseconds (not ticks).
resolution
Type: Lucene.Net.Documents DateTools Resolution
The desired resolution of the date to be returned

Return Value
 the date with all values more precise than resolution
            set to 0 or 1, expressed as milliseconds since January 1, 1970, 00:00:00 GMT

See Also
DateTools Class
DateTools Members
Round Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringToDate Method

DateTools StringToDate Method Lucene.Net Class Library
Converts a string produced by timeToString or DateToString back to a time, represented as a Date object.
expected format

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime StringToDate(
    string dateString
)
public static DateTime StringToDate(
    string dateString
)
Public Shared Function StringToDate ( _
    dateString As String _
) As DateTime
Public Shared Function StringToDate ( _
    dateString As String _
) As DateTime
public:
static DateTime StringToDate(
    String^ dateString
)
public:
static DateTime StringToDate(
    String^ dateString
)
Parameters
dateString
Type:   Online System String
the date string to be converted

Return Value
 the parsed time as a Date object

See Also
DateTools Class
DateTools Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringToTime Method

DateTools StringToTime Method Lucene.Net Class Library
Converts a string produced by timeToString or DateToString back to a time, represented as the number of milliseconds since January 1, 1970, 00:00:00 GMT.
expected format

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long StringToTime(
    string dateString
)
public static long StringToTime(
    string dateString
)
Public Shared Function StringToTime ( _
    dateString As String _
) As Long
Public Shared Function StringToTime ( _
    dateString As String _
) As Long
public:
static long long StringToTime(
    String^ dateString
)
public:
static long long StringToTime(
    String^ dateString
)
Parameters
dateString
Type:   Online System String
the date string to be converted

Return Value
 the number of milliseconds since January 1, 1970, 00:00:00 GMT

See Also
DateTools Class
DateTools Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TimeToString Method

DateTools TimeToString Method Lucene.Net Class Library
Converts a millisecond time to a string suitable for indexing.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string TimeToString(
    long time,
    DateTools..::..Resolution resolution
)
public static string TimeToString(
    long time,
    DateTools..::..Resolution resolution
)
Public Shared Function TimeToString ( _
    time As Long, _
    resolution As DateTools..::..Resolution _
) As String
Public Shared Function TimeToString ( _
    time As Long, _
    resolution As DateTools..::..Resolution _
) As String
public:
static String^ TimeToString(
    long long time,
    DateTools..::..Resolution^ resolution
)
public:
static String^ TimeToString(
    long long time,
    DateTools..::..Resolution^ resolution
)
Parameters
time
Type:   Online System Int64
the date expressed as milliseconds since January 1, 1970, 00:00:00 GMT

resolution
Type: Lucene.Net.Documents DateTools Resolution
the desired resolution, see
            Round(Int64, DateTools Resolution)
Return Value
 a string in format yyyyMMddHHmmssSSS or shorter,
            depending on resolution; using GMT as timezone

See Also
DateTools Class
DateTools Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DateTools.Resolution Class

DateTools Resolution Class Lucene.Net Class Library
Specifies the time granularity.
Inheritance Hierarchy
Online System Object
Lucene.Net.Documents DateTools Resolution

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Resolution
public class Resolution
Public Class Resolution
Public Class Resolution
public ref class Resolution
public ref class Resolution
See Also
DateTools Resolution Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DateTools.Resolution Members

DateTools Resolution Members Lucene.Net Class Library

Provides support for converting dates to strings and vice-versa. The strings are structured so that lexicographic sorting orders them by date, which makes them suitable for use as field values and search terms.

This class also helps you to limit the resolution of your dates. Do not save dates with a finer resolution than you really need, as then RangeQuery and PrefixQuery will require more memory and become slower.

Compared to DateField the strings generated by the methods in this class take slightly more space, unless your selected resolution is set to Resolution.DAY or lower.

Another approach is NumericUtils, which provides a sortable binary representation (prefix encoded) of numeric values, which date/time are. For indexing a Online DateTime, convert it to unix timestamp as long and index this as a numeric value with NumericField and use NumericRangeQuery T to query it.

The DateTools Resolution type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Fields
Name | Description
DAY |
HOUR |
MILLISECOND |
MINUTE |
MONTH |
SECOND |
YEAR |
Back to Top
See Also
DateTools Resolution Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DateTools.Resolution Fields

DateTools Resolution Fields Lucene.Net Class Library
The DateTools Resolution type exposes the following members.
Fields
Name | Description
DAY |
HOUR |
MILLISECOND |
MINUTE |
MONTH |
SECOND |
YEAR |
Back to Top
See Also
DateTools Resolution Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DAY Field

DateTools Resolution DAY Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly DateTools..::..Resolution DAY
public static readonly DateTools..::..Resolution DAY
Public Shared ReadOnly DAY As DateTools..::..Resolution
Public Shared ReadOnly DAY As DateTools..::..Resolution
public:
static initonly DateTools..::..Resolution^ DAY
public:
static initonly DateTools..::..Resolution^ DAY
See Also
DateTools Resolution Class
DateTools Resolution Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HOUR Field

DateTools Resolution HOUR Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly DateTools..::..Resolution HOUR
public static readonly DateTools..::..Resolution HOUR
Public Shared ReadOnly HOUR As DateTools..::..Resolution
Public Shared ReadOnly HOUR As DateTools..::..Resolution
public:
static initonly DateTools..::..Resolution^ HOUR
public:
static initonly DateTools..::..Resolution^ HOUR
See Also
DateTools Resolution Class
DateTools Resolution Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MILLISECOND Field

DateTools Resolution MILLISECOND Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly DateTools..::..Resolution MILLISECOND
public static readonly DateTools..::..Resolution MILLISECOND
Public Shared ReadOnly MILLISECOND As DateTools..::..Resolution
Public Shared ReadOnly MILLISECOND As DateTools..::..Resolution
public:
static initonly DateTools..::..Resolution^ MILLISECOND
public:
static initonly DateTools..::..Resolution^ MILLISECOND
See Also
DateTools Resolution Class
DateTools Resolution Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MINUTE Field

DateTools Resolution MINUTE Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly DateTools..::..Resolution MINUTE
public static readonly DateTools..::..Resolution MINUTE
Public Shared ReadOnly MINUTE As DateTools..::..Resolution
Public Shared ReadOnly MINUTE As DateTools..::..Resolution
public:
static initonly DateTools..::..Resolution^ MINUTE
public:
static initonly DateTools..::..Resolution^ MINUTE
See Also
DateTools Resolution Class
DateTools Resolution Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MONTH Field

DateTools Resolution MONTH Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly DateTools..::..Resolution MONTH
public static readonly DateTools..::..Resolution MONTH
Public Shared ReadOnly MONTH As DateTools..::..Resolution
Public Shared ReadOnly MONTH As DateTools..::..Resolution
public:
static initonly DateTools..::..Resolution^ MONTH
public:
static initonly DateTools..::..Resolution^ MONTH
See Also
DateTools Resolution Class
DateTools Resolution Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SECOND Field

DateTools Resolution SECOND Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly DateTools..::..Resolution SECOND
public static readonly DateTools..::..Resolution SECOND
Public Shared ReadOnly SECOND As DateTools..::..Resolution
Public Shared ReadOnly SECOND As DateTools..::..Resolution
public:
static initonly DateTools..::..Resolution^ SECOND
public:
static initonly DateTools..::..Resolution^ SECOND
See Also
DateTools Resolution Class
DateTools Resolution Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


YEAR Field

DateTools Resolution YEAR Field Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly DateTools..::..Resolution YEAR
public static readonly DateTools..::..Resolution YEAR
Public Shared ReadOnly YEAR As DateTools..::..Resolution
Public Shared ReadOnly YEAR As DateTools..::..Resolution
public:
static initonly DateTools..::..Resolution^ YEAR
public:
static initonly DateTools..::..Resolution^ YEAR
See Also
DateTools Resolution Class
DateTools Resolution Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DateTools.Resolution Methods

DateTools Resolution Methods Lucene.Net Class Library
The DateTools Resolution type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
DateTools Resolution Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

DateTools Resolution ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
DateTools Resolution Class
DateTools Resolution Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Class

Document Class Lucene.Net Class Library
Documents are the unit of indexing and search. A Document is a set of fields. Each field has a name and a textual value. A field may be stored with the document, in which case it is returned with search hits on the document. Thus each document should typically contain one or more stored fields which uniquely identify it.

Note that fields which are not stored are not available in documents retrieved from the index, e.g. with Doc, Doc(Int32) or Document(Int32).
Inheritance Hierarchy
Online System Object
Lucene.Net.Documents Document

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class Document
[SerializableAttribute]
public sealed class Document
<SerializableAttribute> _
Public NotInheritable Class Document
<SerializableAttribute> _
Public NotInheritable Class Document
[SerializableAttribute]
public ref class Document sealed
[SerializableAttribute]
public ref class Document sealed
See Also
Document Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Members

Document Members Lucene.Net Class Library

The Document type exposes the following members.
Constructors
 | Name | Description
Public method | Document | Constructs a new document with no fields.
Back to Top
Methods
 | Name | Description
Public method | Add | Adds a field to a document. Several fields may be added with the same name. In this case, if the fields are indexed, their text is treated as though appended for the purposes of search. Note that add like the removeField(s) methods only makes sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | Returns the string value of the field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added. If only binary fields with this name exist, returns null.
Public method | GetBinaryValue | Returns an array of bytes for the first (or only) field that has the name specified as the method parameter. This method will return null if no binary fields with the specified name are available. There may be non-binary fields with the same name.
Public method | GetBinaryValues | Returns an array of byte arrays for of the fields that have the name specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.
Public method | GetField | Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added. Do not use this method with lazy loaded fields.
Public method | GetFieldable | Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added.
Public method | GetFieldables | Returns an array of IFieldables with the given name. This method returns an empty array when there are no matching fields. It never returns null.
Public method | GetFields | Returns a List of all the fields in a document. Note that fields which are not stored are not available in documents retrieved from the index, e.g. Doc(Int32) or Document(Int32).
Public method | GetFields(String) | Returns an array of Fields with the given name. Do not use with lazy loaded fields. This method returns an empty array when there are no matching fields. It never returns null.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | Returns an array of values of the field specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RemoveField | Removes field with the specified name from the document. If multiple fields exist with this name, this method removes the first field that has been added. If there is no field with the specified name, the document remains unchanged. Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
Public method | RemoveFields | Removes all fields with the given name from the document. If there is no field with the specified name, the document remains unchanged. Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
Public method | ToString | Prints the fields of a document for human consumption. (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets, at indexing time, the boost factor. The default is 1.0 Note that once a document is indexed this value is no longer available from the index. At search time, for retrieved documents, this method always returns 1. This however does not mean that the boost value set at indexing time was ignored - it was just combined with other indexing time factors and stored elsewhere, for better indexing and search performance. (For more information see the "norm(t,d)" part of the scoring formula in Similarity.)
Public property | fields_ForNUnit |
Back to Top
See Also
Document Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Constructor

Document Constructor Lucene.Net Class Library
Constructs a new document with no fields.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Document()
public Document()
Public Sub New
Public Sub New
public:
Document()
public:
Document()
See Also
Document Class
Document Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Methods

Document Methods Lucene.Net Class Library
The Document type exposes the following members.
Methods
 | Name | Description
Public method | Add | Adds a field to a document. Several fields may be added with the same name. In this case, if the fields are indexed, their text is treated as though appended for the purposes of search. Note that add like the removeField(s) methods only makes sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | Returns the string value of the field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added. If only binary fields with this name exist, returns null.
Public method | GetBinaryValue | Returns an array of bytes for the first (or only) field that has the name specified as the method parameter. This method will return null if no binary fields with the specified name are available. There may be non-binary fields with the same name.
Public method | GetBinaryValues | Returns an array of byte arrays for of the fields that have the name specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.
Public method | GetField | Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added. Do not use this method with lazy loaded fields.
Public method | GetFieldable | Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added.
Public method | GetFieldables | Returns an array of IFieldables with the given name. This method returns an empty array when there are no matching fields. It never returns null.
Public method | GetFields | Returns a List of all the fields in a document. Note that fields which are not stored are not available in documents retrieved from the index, e.g. Doc(Int32) or Document(Int32).
Public method | GetFields(String) | Returns an array of Fields with the given name. Do not use with lazy loaded fields. This method returns an empty array when there are no matching fields. It never returns null.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | Returns an array of values of the field specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RemoveField | Removes field with the specified name from the document. If multiple fields exist with this name, this method removes the first field that has been added. If there is no field with the specified name, the document remains unchanged. Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
Public method | RemoveFields | Removes all fields with the given name from the document. If there is no field with the specified name, the document remains unchanged. Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.
Public method | ToString | Prints the fields of a document for human consumption. (Overrides Online Object ToString .)
Back to Top
See Also
Document Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method

Document Add Method Lucene.Net Class Library

Adds a field to a document. Several fields may be added with the same name. In this case, if the fields are indexed, their text is treated as though appended for the purposes of search.

Note that add like the removeField(s) methods only makes sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    IFieldable field
)
public void Add(
    IFieldable field
)
Public Sub Add ( _
    field As IFieldable _
)
Public Sub Add ( _
    field As IFieldable _
)
public:
void Add(
    IFieldable^ field
)
public:
void Add(
    IFieldable^ field
)
Parameters
field
Type: Lucene.Net.Documents IFieldable
See Also
Document Class
Document Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method

Document Get Method Lucene.Net Class Library
Returns the string value of the field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added. If only binary fields with this name exist, returns null.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Get(
    string name
)
public string Get(
    string name
)
Public Function Get ( _
    name As String _
) As String
Public Function Get ( _
    name As String _
) As String
public:
String^ Get(
    String^ name
)
public:
String^ Get(
    String^ name
)
Parameters
name
Type:   Online System String
See Also
Document Class
Document Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBinaryValue Method

Document GetBinaryValue Method Lucene.Net Class Library
Returns an array of bytes for the first (or only) field that has the name specified as the method parameter. This method will return null if no binary fields with the specified name are available. There may be non-binary fields with the same name.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] GetBinaryValue(
    string name
)
public byte[] GetBinaryValue(
    string name
)
Public Function GetBinaryValue ( _
    name As String _
) As Byte()
Public Function GetBinaryValue ( _
    name As String _
) As Byte()
public:
array<unsigned char>^ GetBinaryValue(
    String^ name
)
public:
array<unsigned char>^ GetBinaryValue(
    String^ name
)
Parameters
name
Type:   Online System String
the name of the field.

Return Value
 a byte[] containing the binary field value or null
See Also
Document Class
Document Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBinaryValues Method

Document GetBinaryValues Method Lucene.Net Class Library
Returns an array of byte arrays for of the fields that have the name specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[][] GetBinaryValues(
    string name
)
public byte[][] GetBinaryValues(
    string name
)
Public Function GetBinaryValues ( _
    name As String _
) As Byte()()
Public Function GetBinaryValues ( _
    name As String _
) As Byte()()
public:
array<array<unsigned char>^>^ GetBinaryValues(
    String^ name
)
public:
array<array<unsigned char>^>^ GetBinaryValues(
    String^ name
)
Parameters
name
Type:   Online System String
the name of the field

Return Value
 a byte[][] of binary field values

See Also
Document Class
Document Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetField Method

Document GetField Method Lucene.Net Class Library
Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added. Do not use this method with lazy loaded fields.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Field GetField(
    string name
)
public Field GetField(
    string name
)
Public Function GetField ( _
    name As String _
) As Field
Public Function GetField ( _
    name As String _
) As Field
public:
Field^ GetField(
    String^ name
)
public:
Field^ GetField(
    String^ name
)
Parameters
name
Type:   Online System String
See Also
Document Class
Document Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFieldable Method

Document GetFieldable Method Lucene.Net Class Library
Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IFieldable GetFieldable(
    string name
)
public IFieldable GetFieldable(
    string name
)
Public Function GetFieldable ( _
    name As String _
) As IFieldable
Public Function GetFieldable ( _
    name As String _
) As IFieldable
public:
IFieldable^ GetFieldable(
    String^ name
)
public:
IFieldable^ GetFieldable(
    String^ name
)
Parameters
name
Type:   Online System String
See Also
Document Class
Document Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFieldables Method

Document GetFieldables Method Lucene.Net Class Library
Returns an array of IFieldables with the given name. This method returns an empty array when there are no matching fields. It never returns null.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IFieldable[] GetFieldables(
    string name
)
public IFieldable[] GetFieldables(
    string name
)
Public Function GetFieldables ( _
    name As String _
) As IFieldable()
Public Function GetFieldables ( _
    name As String _
) As IFieldable()
public:
array<IFieldable^>^ GetFieldables(
    String^ name
)
public:
array<IFieldable^>^ GetFieldables(
    String^ name
)
Parameters
name
Type:   Online System String
the name of the field

Return Value
 a Fieldable[] array

See Also
Document Class
Document Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFields Method

Document GetFields Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetFields | Returns a List of all the fields in a document. Note that fields which are not stored are not available in documents retrieved from the index, e.g. Doc(Int32) or Document(Int32).
Public method | GetFields(String) | Returns an array of Fields with the given name. Do not use with lazy loaded fields. This method returns an empty array when there are no matching fields. It never returns null.
Back to Top
See Also
Document Class
Document Members
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFields Method

Document GetFields Method Lucene.Net Class Library
Returns a List of all the fields in a document.

Note that fields which are not stored are not available in documents retrieved from the index, e.g. Doc(Int32) or Document(Int32).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList<IFieldable> GetFields()
public IList<IFieldable> GetFields()
Public Function GetFields As IList(Of IFieldable)
Public Function GetFields As IList(Of IFieldable)
public:
IList<IFieldable^>^ GetFields()
public:
IList<IFieldable^>^ GetFields()
See Also
Document Class
Document Members
GetFields Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFields Method (String)

Document GetFields Method (String) Lucene.Net Class Library
Returns an array of Fields with the given name. Do not use with lazy loaded fields. This method returns an empty array when there are no matching fields. It never returns null.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Field[] GetFields(
    string name
)
public Field[] GetFields(
    string name
)
Public Function GetFields ( _
    name As String _
) As Field()
Public Function GetFields ( _
    name As String _
) As Field()
public:
array<Field^>^ GetFields(
    String^ name
)
public:
array<Field^>^ GetFields(
    String^ name
)
Parameters
name
Type:   Online System String
the name of the field

Return Value
 a Field[] array

See Also
Document Class
Document Members
GetFields Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetValues Method

Document GetValues Method Lucene.Net Class Library
Returns an array of values of the field specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string[] GetValues(
    string name
)
public string[] GetValues(
    string name
)
Public Function GetValues ( _
    name As String _
) As String()
Public Function GetValues ( _
    name As String _
) As String()
public:
array<String^>^ GetValues(
    String^ name
)
public:
array<String^>^ GetValues(
    String^ name
)
Parameters
name
Type:   Online System String
the name of the field

Return Value
 a String[] of field values

See Also
Document Class
Document Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RemoveField Method

Document RemoveField Method Lucene.Net Class Library

Removes field with the specified name from the document. If multiple fields exist with this name, this method removes the first field that has been added. If there is no field with the specified name, the document remains unchanged.

Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RemoveField(
    string name
)
public void RemoveField(
    string name
)
Public Sub RemoveField ( _
    name As String _
)
Public Sub RemoveField ( _
    name As String _
)
public:
void RemoveField(
    String^ name
)
public:
void RemoveField(
    String^ name
)
Parameters
name
Type:   Online System String
See Also
Document Class
Document Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RemoveFields Method

Document RemoveFields Method Lucene.Net Class Library

Removes all fields with the given name from the document. If there is no field with the specified name, the document remains unchanged.

Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RemoveFields(
    string name
)
public void RemoveFields(
    string name
)
Public Sub RemoveFields ( _
    name As String _
)
Public Sub RemoveFields ( _
    name As String _
)
public:
void RemoveFields(
    String^ name
)
public:
void RemoveFields(
    String^ name
)
Parameters
name
Type:   Online System String
See Also
Document Class
Document Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

Document ToString Method Lucene.Net Class Library
Prints the fields of a document for human consumption.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
Document Class
Document Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Properties

Document Properties Lucene.Net Class Library
The Document type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets, at indexing time, the boost factor. The default is 1.0 Note that once a document is indexed this value is no longer available from the index. At search time, for retrieved documents, this method always returns 1. This however does not mean that the boost value set at indexing time was ignored - it was just combined with other indexing time factors and stored elsewhere, for better indexing and search performance. (For more information see the "norm(t,d)" part of the scoring formula in Similarity.)
Public property | fields_ForNUnit |
Back to Top
See Also
Document Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Boost Property

Document Boost Property Lucene.Net Class Library
Gets or sets, at indexing time, the boost factor.

The default is 1.0

Note that once a document is indexed this value is no longer available from the index. At search time, for retrieved documents, this method always returns 1. This however does not mean that the boost value set at indexing time was ignored - it was just combined with other indexing time factors and stored elsewhere, for better indexing and search performance. (For more information see the "norm(t,d)" part of the scoring formula in Similarity.)

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Boost { get; set; }
public float Boost { get; set; }
Public Property Boost As Single
    Get
    Set
Public Property Boost As Single
    Get
    Set
public:
property float Boost {
    float get ();
    void set (float value);
}
public:
property float Boost {
    float get ();
    void set (float value);
}
See Also
Document Class
Document Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


fields_ForNUnit Property

Document fields_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList<IFieldable> fields_ForNUnit { get; }
public IList<IFieldable> fields_ForNUnit { get; }
Public ReadOnly Property fields_ForNUnit As IList(Of IFieldable)
    Get
Public ReadOnly Property fields_ForNUnit As IList(Of IFieldable)
    Get
public:
property IList<IFieldable^>^ fields_ForNUnit {
    IList<IFieldable^>^ get ();
}
public:
property IList<IFieldable^>^ fields_ForNUnit {
    IList<IFieldable^>^ get ();
}
See Also
Document Class
Document Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Class

Field Class Lucene.Net Class Library
A field is a section of a Document. Each field has two parts, a name and a value. Values may be free text, provided as a String or as a Reader, or they may be atomic keywords, which are not further processed. Such keywords may be used to represent dates, urls, etc. Fields are optionally stored in the index, so that they may be returned with hits on the document.
Inheritance Hierarchy
Online System Object
Lucene.Net.Documents AbstractField
Lucene.Net.Documents Field

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class Field : AbstractField,
    IFieldable
[SerializableAttribute]
public sealed class Field : AbstractField,
    IFieldable
<SerializableAttribute> _
Public NotInheritable Class Field _
    Inherits AbstractField _
    Implements IFieldable
<SerializableAttribute> _
Public NotInheritable Class Field _
    Inherits AbstractField _
    Implements IFieldable
[SerializableAttribute]
public ref class Field sealed : public AbstractField,
    IFieldable
[SerializableAttribute]
public ref class Field sealed : public AbstractField,
    IFieldable
See Also
Field Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Members

Field Members Lucene.Net Class Library

The Field type exposes the following members.
Constructors
 | Name | Description
Public method | Field(String, TokenStream) | Create a tokenized and indexed field that is not stored. Term vectors will not be stored. This is useful for pre-analyzed fields. The TokenStream is read only when the Document is added to the index, i.e. you may not close the TokenStream until AddDocument(Document) has been called.
Public method | Field(String, TextReader) | Create a tokenized and indexed field that is not stored. Term vectors will not be stored. The Reader is read only when the Document is added to the index, i.e. you may not close the Reader until AddDocument(Document) has been called.
Public method | Field(String, TokenStream, Field TermVector) | Create a tokenized and indexed field that is not stored, optionally with storing term vectors. This is useful for pre-analyzed fields. The TokenStream is read only when the Document is added to the index, i.e. you may not close the TokenStream until AddDocument(Document) has been called.
Public method | Field(String, Byte , Field Store) | Create a stored field with binary value. Optionally the value may be compressed.
Public method | Field(String, TextReader, Field TermVector) | Create a tokenized and indexed field that is not stored, optionally with storing term vectors. The Reader is read only when the Document is added to the index, i.e. you may not close the Reader until AddDocument(Document) has been called.
Public method | Field(String, String, Field Store, Field Index) | Create a field by specifying its name, value and how it will be saved in the index. Term vectors will not be stored in the index.
Public method | Field(String, Byte , Int32, Int32, Field Store) | Create a stored field with binary value. Optionally the value may be compressed.
Public method | Field(String, String, Field Store, Field Index, Field TermVector) | Create a field by specifying its name, value and how it will be saved in the index.
Public method | Field(String, Boolean, String, Field Store, Field Index, Field TermVector) | Create a field by specifying its name, value and how it will be saved in the index.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBinaryValue | Return the raw byte[] for the binary field. Note that you must also call BinaryLength and BinaryOffset to know which range of bytes in this returned array belong to the field. (Inherited from AbstractField.)
Public method | GetBinaryValue( Byte ) | (Inherited from AbstractField.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | SetStoreTermVector | (Inherited from AbstractField.)
Public method | SetTokenStream | Expert: sets the token stream to be used for indexing and causes isIndexed() and isTokenized() to return true. May be combined with stored values from stringValue() or GetBinaryValue()
Public method | SetValue( Byte ) | Expert: change the value of this field. See setValue(String).
Public method | SetValue(TextReader) | Expert: change the value of this field. See setValue(String).
Public method | SetValue(String) | Expert: change the value of this field. This can be used during indexing to re-use a single Field instance to improve indexing speed by avoiding GC cost of new'ing and reclaiming Field instances. Typically a single Document instance is re-used as well. This helps most on small documents. Each Field instance should only be used once within a single Document instance. See Online ImproveIndexingSpeed for details.
Public method | SetValue( Byte , Int32, Int32) | Expert: change the value of this field. See setValue(String).
Public method | ToString | Prints a Field for human consumption. (Inherited from AbstractField.)
Back to Top
Fields
 | Name | Description
Protected field | fieldsData | (Inherited from AbstractField.)
Protected field | internalBinaryLength | (Inherited from AbstractField.)
Protected field | internalbinaryOffset | (Inherited from AbstractField.)
Protected field | internalBoost | (Inherited from AbstractField.)
Protected field | internalIsBinary | (Inherited from AbstractField.)
Protected field | internalIsIndexed | (Inherited from AbstractField.)
Protected field | internalIsStored | (Inherited from AbstractField.)
Protected field | internalIsTokenized | (Inherited from AbstractField.)
Protected field | internalName | (Inherited from AbstractField.)
Protected field | internalOmitNorms | (Inherited from AbstractField.)
Protected field | internalOmitTermFreqAndPositions | (Inherited from AbstractField.)
Protected field | lazy | (Inherited from AbstractField.)
Protected field | storeOffsetWithTermVector | (Inherited from AbstractField.)
Protected field | storePositionWithTermVector | (Inherited from AbstractField.)
Protected field | storeTermVector | (Inherited from AbstractField.)
Protected field | tokenStream | (Inherited from AbstractField.)
Back to Top
Properties
 | Name | Description
Public property | BinaryLength | Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined (Inherited from AbstractField.)
Public property | BinaryOffset | Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined (Inherited from AbstractField.)
Public property | Boost | Gets or sets the boost factor for hits for this field. The default value is 1.0. Note: this value is not stored directly with the document in the index. Documents returned from Document(Int32) and Doc(Int32) may thus not have the same value present as when this field was indexed. (Inherited from AbstractField.)
Public property | IsBinary | True iff the value of the filed is stored as binary (Inherited from AbstractField.)
Public property | IsIndexed | True iff the value of the field is to be indexed, so that it may be searched on. (Inherited from AbstractField.)
Public property | IsLazy | (Inherited from AbstractField.)
Public property | IsStored | True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued. (Inherited from AbstractField.)
Public property | IsStoreOffsetWithTermVector | True iff terms are stored as term vector together with their offsets (start and end position in source text). (Inherited from AbstractField.)
Public property | IsStorePositionWithTermVector | True iff terms are stored as term vector together with their token positions. (Inherited from AbstractField.)
Public property | IsTermVectorStored | True iff the term or terms used to index this field are stored as a term vector, available from GetTermFreqVector(Int32, String). These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the stored attribute instead. (Inherited from AbstractField.)
Public property | IsTokenized | True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued. (Inherited from AbstractField.)
Public property | Name | Returns the name of the field as an interned string. For example "date", "title", "body", ... (Inherited from AbstractField.)
Public property | OmitNorms | True if norms are omitted for this indexed field (Inherited from AbstractField.)
Public property | OmitTermFreqAndPositions | Expert: If set, omit term freq, positions and payloads from postings for this field. NOTE: While this option reduces storage space required in the index, it also means any query requiring positional information, such as PhraseQuery or SpanQuery subclasses will silently fail to find results. (Inherited from AbstractField.)
Public property | ReaderValue | The value of the field as a Reader, or null. If null, the String value or binary value is used. Exactly one of stringValue(), readerValue(), and getBinaryValue() must be set. (Overrides AbstractField ReaderValue.)
Public property | StringValue | The value of the field as a String, or null. If null, the Reader value or binary value is used. Exactly one of stringValue(), readerValue(), and getBinaryValue() must be set. (Overrides AbstractField StringValue.)
Public property | TokenStreamValue | The TokesStream for this field to be used when indexing, or null. If null, the Reader value or String value is analyzed to produce the indexed tokens. (Overrides AbstractField TokenStreamValue.)
Back to Top
See Also
Field Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Constructor

Field Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Field(String, TokenStream) | Create a tokenized and indexed field that is not stored. Term vectors will not be stored. This is useful for pre-analyzed fields. The TokenStream is read only when the Document is added to the index, i.e. you may not close the TokenStream until AddDocument(Document) has been called.
Public method | Field(String, TextReader) | Create a tokenized and indexed field that is not stored. Term vectors will not be stored. The Reader is read only when the Document is added to the index, i.e. you may not close the Reader until AddDocument(Document) has been called.
Public method | Field(String, TokenStream, Field TermVector) | Create a tokenized and indexed field that is not stored, optionally with storing term vectors. This is useful for pre-analyzed fields. The TokenStream is read only when the Document is added to the index, i.e. you may not close the TokenStream until AddDocument(Document) has been called.
Public method | Field(String, Byte , Field Store) | Create a stored field with binary value. Optionally the value may be compressed.
Public method | Field(String, TextReader, Field TermVector) | Create a tokenized and indexed field that is not stored, optionally with storing term vectors. The Reader is read only when the Document is added to the index, i.e. you may not close the Reader until AddDocument(Document) has been called.
Public method | Field(String, String, Field Store, Field Index) | Create a field by specifying its name, value and how it will be saved in the index. Term vectors will not be stored in the index.
Public method | Field(String, Byte , Int32, Int32, Field Store) | Create a stored field with binary value. Optionally the value may be compressed.
Public method | Field(String, String, Field Store, Field Index, Field TermVector) | Create a field by specifying its name, value and how it will be saved in the index.
Public method | Field(String, Boolean, String, Field Store, Field Index, Field TermVector) | Create a field by specifying its name, value and how it will be saved in the index.
Back to Top
See Also
Field Class
Field Members
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Constructor (String, TokenStream)

Field Constructor (String, TokenStream) Lucene.Net Class Library
Create a tokenized and indexed field that is not stored. Term vectors will not be stored. This is useful for pre-analyzed fields. The TokenStream is read only when the Document is added to the index, i.e. you may not close the TokenStream until AddDocument(Document) has been called.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Field(
    string name,
    TokenStream tokenStream
)
public Field(
    string name,
    TokenStream tokenStream
)
Public Sub New ( _
    name As String, _
    tokenStream As TokenStream _
)
Public Sub New ( _
    name As String, _
    tokenStream As TokenStream _
)
public:
Field(
    String^ name,
    TokenStream^ tokenStream
)
public:
Field(
    String^ name,
    TokenStream^ tokenStream
)
Parameters
name
Type:   Online System String
The name of the field

tokenStream
Type: Lucene.Net.Analysis TokenStream
The TokenStream with the content

See Also
Field Class
Field Members
Field Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Constructor (String, TextReader)

Field Constructor (String, TextReader) Lucene.Net Class Library
Create a tokenized and indexed field that is not stored. Term vectors will not be stored. The Reader is read only when the Document is added to the index, i.e. you may not close the Reader until AddDocument(Document) has been called.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Field(
    string name,
    TextReader reader
)
public Field(
    string name,
    TextReader reader
)
Public Sub New ( _
    name As String, _
    reader As TextReader _
)
Public Sub New ( _
    name As String, _
    reader As TextReader _
)
public:
Field(
    String^ name,
    TextReader^ reader
)
public:
Field(
    String^ name,
    TextReader^ reader
)
Parameters
name
Type:   Online System String
The name of the field

reader
Type:   Online System.IO TextReader
The reader with the content

See Also
Field Class
Field Members
Field Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Constructor (String, TokenStream, Field.TermVector)

Field Constructor (String, TokenStream, Field TermVector) Lucene.Net Class Library
Create a tokenized and indexed field that is not stored, optionally with storing term vectors. This is useful for pre-analyzed fields. The TokenStream is read only when the Document is added to the index, i.e. you may not close the TokenStream until AddDocument(Document) has been called.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Field(
    string name,
    TokenStream tokenStream,
    Field..::..TermVector termVector
)
public Field(
    string name,
    TokenStream tokenStream,
    Field..::..TermVector termVector
)
Public Sub New ( _
    name As String, _
    tokenStream As TokenStream, _
    termVector As Field..::..TermVector _
)
Public Sub New ( _
    name As String, _
    tokenStream As TokenStream, _
    termVector As Field..::..TermVector _
)
public:
Field(
    String^ name,
    TokenStream^ tokenStream,
    Field..::..TermVector termVector
)
public:
Field(
    String^ name,
    TokenStream^ tokenStream,
    Field..::..TermVector termVector
)
Parameters
name
Type:   Online System String
The name of the field

tokenStream
Type: Lucene.Net.Analysis TokenStream
The TokenStream with the content

termVector
Type: Lucene.Net.Documents Field TermVector
Whether term vector should be stored

See Also
Field Class
Field Members
Field Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Constructor (String, Byte[], Field.Store)

Field Constructor (String, Byte , Field Store) Lucene.Net Class Library
Create a stored field with binary value. Optionally the value may be compressed.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Field(
    string name,
    byte[] value_Renamed,
    Field..::..Store store
)
public Field(
    string name,
    byte[] value_Renamed,
    Field..::..Store store
)
Public Sub New ( _
    name As String, _
    value_Renamed As Byte(), _
    store As Field..::..Store _
)
Public Sub New ( _
    name As String, _
    value_Renamed As Byte(), _
    store As Field..::..Store _
)
public:
Field(
    String^ name,
    array<unsigned char>^ value_Renamed,
    Field..::..Store store
)
public:
Field(
    String^ name,
    array<unsigned char>^ value_Renamed,
    Field..::..Store store
)
Parameters
name
Type:   Online System String
The name of the field

value_Renamed
Type:    Online System Byte
The binary value

store
Type: Lucene.Net.Documents Field Store
How value should be stored (compressed or not)

See Also
Field Class
Field Members
Field Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Constructor (String, TextReader, Field.TermVector)

Field Constructor (String, TextReader, Field TermVector) Lucene.Net Class Library
Create a tokenized and indexed field that is not stored, optionally with storing term vectors. The Reader is read only when the Document is added to the index, i.e. you may not close the Reader until AddDocument(Document) has been called.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Field(
    string name,
    TextReader reader,
    Field..::..TermVector termVector
)
public Field(
    string name,
    TextReader reader,
    Field..::..TermVector termVector
)
Public Sub New ( _
    name As String, _
    reader As TextReader, _
    termVector As Field..::..TermVector _
)
Public Sub New ( _
    name As String, _
    reader As TextReader, _
    termVector As Field..::..TermVector _
)
public:
Field(
    String^ name,
    TextReader^ reader,
    Field..::..TermVector termVector
)
public:
Field(
    String^ name,
    TextReader^ reader,
    Field..::..TermVector termVector
)
Parameters
name
Type:   Online System String
The name of the field

reader
Type:   Online System.IO TextReader
The reader with the content

termVector
Type: Lucene.Net.Documents Field TermVector
Whether term vector should be stored

See Also
Field Class
Field Members
Field Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Constructor (String, String, Field.Store, Field.Index)

Field Constructor (String, String, Field Store, Field Index) Lucene.Net Class Library
Create a field by specifying its name, value and how it will be saved in the index. Term vectors will not be stored in the index.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Field(
    string name,
    string value,
    Field..::..Store store,
    Field..::..Index index
)
public Field(
    string name,
    string value,
    Field..::..Store store,
    Field..::..Index index
)
Public Sub New ( _
    name As String, _
    value As String, _
    store As Field..::..Store, _
    index As Field..::..Index _
)
Public Sub New ( _
    name As String, _
    value As String, _
    store As Field..::..Store, _
    index As Field..::..Index _
)
public:
Field(
    String^ name,
    String^ value,
    Field..::..Store store,
    Field..::..Index index
)
public:
Field(
    String^ name,
    String^ value,
    Field..::..Store store,
    Field..::..Index index
)
Parameters
name
Type:   Online System String
The name of the field

value
Type:   Online System String
The string to process

store
Type: Lucene.Net.Documents Field Store
Whether value should be stored in the index

index
Type: Lucene.Net.Documents Field Index
Whether the field should be indexed, and if so, if it should
            be tokenized before indexing

See Also
Field Class
Field Members
Field Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Constructor (String, Byte[], Int32, Int32, Field.Store)

Field Constructor (String, Byte , Int32, Int32, Field Store) Lucene.Net Class Library
Create a stored field with binary value. Optionally the value may be compressed.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Field(
    string name,
    byte[] value_Renamed,
    int offset,
    int length,
    Field..::..Store store
)
public Field(
    string name,
    byte[] value_Renamed,
    int offset,
    int length,
    Field..::..Store store
)
Public Sub New ( _
    name As String, _
    value_Renamed As Byte(), _
    offset As Integer, _
    length As Integer, _
    store As Field..::..Store _
)
Public Sub New ( _
    name As String, _
    value_Renamed As Byte(), _
    offset As Integer, _
    length As Integer, _
    store As Field..::..Store _
)
public:
Field(
    String^ name,
    array<unsigned char>^ value_Renamed,
    int offset,
    int length,
    Field..::..Store store
)
public:
Field(
    String^ name,
    array<unsigned char>^ value_Renamed,
    int offset,
    int length,
    Field..::..Store store
)
Parameters
name
Type:   Online System String
The name of the field

value_Renamed
Type:    Online System Byte
The binary value

offset
Type:   Online System Int32
Starting offset in value where this Field's bytes are

length
Type:   Online System Int32
Number of bytes to use for this Field, starting at offset

store
Type: Lucene.Net.Documents Field Store
How value should be stored (compressed or not)

See Also
Field Class
Field Members
Field Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Constructor (String, String, Field.Store, Field.Index, Field.TermVector)

Field Constructor (String, String, Field Store, Field Index, Field TermVector) Lucene.Net Class Library
Create a field by specifying its name, value and how it will be saved in the index.
the field is neither stored nor indexedthe field is not indexed but termVector is TermVector.YES

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Field(
    string name,
    string value,
    Field..::..Store store,
    Field..::..Index index,
    Field..::..TermVector termVector
)
public Field(
    string name,
    string value,
    Field..::..Store store,
    Field..::..Index index,
    Field..::..TermVector termVector
)
Public Sub New ( _
    name As String, _
    value As String, _
    store As Field..::..Store, _
    index As Field..::..Index, _
    termVector As Field..::..TermVector _
)
Public Sub New ( _
    name As String, _
    value As String, _
    store As Field..::..Store, _
    index As Field..::..Index, _
    termVector As Field..::..TermVector _
)
public:
Field(
    String^ name,
    String^ value,
    Field..::..Store store,
    Field..::..Index index,
    Field..::..TermVector termVector
)
public:
Field(
    String^ name,
    String^ value,
    Field..::..Store store,
    Field..::..Index index,
    Field..::..TermVector termVector
)
Parameters
name
Type:   Online System String
The name of the field

value
Type:   Online System String
The string to process

store
Type: Lucene.Net.Documents Field Store
Whether value should be stored in the index

index
Type: Lucene.Net.Documents Field Index
Whether the field should be indexed, and if so, if it should
            be tokenized before indexing

termVector
Type: Lucene.Net.Documents Field TermVector
Whether term vector should be stored

See Also
Field Class
Field Members
Field Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Constructor (String, Boolean, String, Field.Store, Field.Index, Field.TermVector)

Field Constructor (String, Boolean, String, Field Store, Field Index, Field TermVector) Lucene.Net Class Library
Create a field by specifying its name, value and how it will be saved in the index.
the field is neither stored nor indexedthe field is not indexed but termVector is TermVector.YES

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Field(
    string name,
    bool internName,
    string value,
    Field..::..Store store,
    Field..::..Index index,
    Field..::..TermVector termVector
)
public Field(
    string name,
    bool internName,
    string value,
    Field..::..Store store,
    Field..::..Index index,
    Field..::..TermVector termVector
)
Public Sub New ( _
    name As String, _
    internName As Boolean, _
    value As String, _
    store As Field..::..Store, _
    index As Field..::..Index, _
    termVector As Field..::..TermVector _
)
Public Sub New ( _
    name As String, _
    internName As Boolean, _
    value As String, _
    store As Field..::..Store, _
    index As Field..::..Index, _
    termVector As Field..::..TermVector _
)
public:
Field(
    String^ name,
    bool internName,
    String^ value,
    Field..::..Store store,
    Field..::..Index index,
    Field..::..TermVector termVector
)
public:
Field(
    String^ name,
    bool internName,
    String^ value,
    Field..::..Store store,
    Field..::..Index index,
    Field..::..TermVector termVector
)
Parameters
name
Type:   Online System String
The name of the field

internName
Type:   Online System Boolean
Whether to .intern() name or not

value
Type:   Online System String
The string to process

store
Type: Lucene.Net.Documents Field Store
Whether value should be stored in the index

index
Type: Lucene.Net.Documents Field Index
Whether the field should be indexed, and if so, if it should
            be tokenized before indexing

termVector
Type: Lucene.Net.Documents Field TermVector
Whether term vector should be stored

See Also
Field Class
Field Members
Field Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Fields

Field Fields Lucene.Net Class Library
The Field type exposes the following members.
Fields
 | Name | Description
Protected field | fieldsData | (Inherited from AbstractField.)
Protected field | internalBinaryLength | (Inherited from AbstractField.)
Protected field | internalbinaryOffset | (Inherited from AbstractField.)
Protected field | internalBoost | (Inherited from AbstractField.)
Protected field | internalIsBinary | (Inherited from AbstractField.)
Protected field | internalIsIndexed | (Inherited from AbstractField.)
Protected field | internalIsStored | (Inherited from AbstractField.)
Protected field | internalIsTokenized | (Inherited from AbstractField.)
Protected field | internalName | (Inherited from AbstractField.)
Protected field | internalOmitNorms | (Inherited from AbstractField.)
Protected field | internalOmitTermFreqAndPositions | (Inherited from AbstractField.)
Protected field | lazy | (Inherited from AbstractField.)
Protected field | storeOffsetWithTermVector | (Inherited from AbstractField.)
Protected field | storePositionWithTermVector | (Inherited from AbstractField.)
Protected field | storeTermVector | (Inherited from AbstractField.)
Protected field | tokenStream | (Inherited from AbstractField.)
Back to Top
See Also
Field Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Methods

Field Methods Lucene.Net Class Library
The Field type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBinaryValue | Return the raw byte[] for the binary field. Note that you must also call BinaryLength and BinaryOffset to know which range of bytes in this returned array belong to the field. (Inherited from AbstractField.)
Public method | GetBinaryValue( Byte ) | (Inherited from AbstractField.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | SetStoreTermVector | (Inherited from AbstractField.)
Public method | SetTokenStream | Expert: sets the token stream to be used for indexing and causes isIndexed() and isTokenized() to return true. May be combined with stored values from stringValue() or GetBinaryValue()
Public method | SetValue( Byte ) | Expert: change the value of this field. See setValue(String).
Public method | SetValue(TextReader) | Expert: change the value of this field. See setValue(String).
Public method | SetValue(String) | Expert: change the value of this field. This can be used during indexing to re-use a single Field instance to improve indexing speed by avoiding GC cost of new'ing and reclaiming Field instances. Typically a single Document instance is re-used as well. This helps most on small documents. Each Field instance should only be used once within a single Document instance. See Online ImproveIndexingSpeed for details.
Public method | SetValue( Byte , Int32, Int32) | Expert: change the value of this field. See setValue(String).
Public method | ToString | Prints a Field for human consumption. (Inherited from AbstractField.)
Back to Top
See Also
Field Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetTokenStream Method

Field SetTokenStream Method Lucene.Net Class Library
Expert: sets the token stream to be used for indexing and causes isIndexed() and isTokenized() to return true. May be combined with stored values from stringValue() or GetBinaryValue()

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetTokenStream(
    TokenStream tokenStream
)
public void SetTokenStream(
    TokenStream tokenStream
)
Public Sub SetTokenStream ( _
    tokenStream As TokenStream _
)
Public Sub SetTokenStream ( _
    tokenStream As TokenStream _
)
public:
void SetTokenStream(
    TokenStream^ tokenStream
)
public:
void SetTokenStream(
    TokenStream^ tokenStream
)
Parameters
tokenStream
Type: Lucene.Net.Analysis TokenStream
See Also
Field Class
Field Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetValue Method

Field SetValue Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | SetValue( Byte ) | Expert: change the value of this field. See setValue(String).
Public method | SetValue(TextReader) | Expert: change the value of this field. See setValue(String).
Public method | SetValue(String) | Expert: change the value of this field. This can be used during indexing to re-use a single Field instance to improve indexing speed by avoiding GC cost of new'ing and reclaiming Field instances. Typically a single Document instance is re-used as well. This helps most on small documents. Each Field instance should only be used once within a single Document instance. See Online ImproveIndexingSpeed for details.
Public method | SetValue( Byte , Int32, Int32) | Expert: change the value of this field. See setValue(String).
Back to Top
See Also
Field Class
Field Members
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetValue Method (Byte[])

Field SetValue Method ( Byte ) Lucene.Net Class Library
Expert: change the value of this field. See setValue(String).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetValue(
    byte[] value
)
public void SetValue(
    byte[] value
)
Public Sub SetValue ( _
    value As Byte() _
)
Public Sub SetValue ( _
    value As Byte() _
)
public:
void SetValue(
    array<unsigned char>^ value
)
public:
void SetValue(
    array<unsigned char>^ value
)
Parameters
value
Type:    Online System Byte
See Also
Field Class
Field Members
SetValue Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetValue Method (TextReader)

Field SetValue Method (TextReader) Lucene.Net Class Library
Expert: change the value of this field. See setValue(String).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetValue(
    TextReader value
)
public void SetValue(
    TextReader value
)
Public Sub SetValue ( _
    value As TextReader _
)
Public Sub SetValue ( _
    value As TextReader _
)
public:
void SetValue(
    TextReader^ value
)
public:
void SetValue(
    TextReader^ value
)
Parameters
value
Type:   Online System.IO TextReader
See Also
Field Class
Field Members
SetValue Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetValue Method (String)

Field SetValue Method (String) Lucene.Net Class Library

Expert: change the value of this field. This can be used during indexing to re-use a single Field instance to improve indexing speed by avoiding GC cost of new'ing and reclaiming Field instances. Typically a single Document instance is re-used as well. This helps most on small documents.

Each Field instance should only be used once within a single Document instance. See Online ImproveIndexingSpeed for details.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetValue(
    string value
)
public void SetValue(
    string value
)
Public Sub SetValue ( _
    value As String _
)
Public Sub SetValue ( _
    value As String _
)
public:
void SetValue(
    String^ value
)
public:
void SetValue(
    String^ value
)
Parameters
value
Type:   Online System String
See Also
Field Class
Field Members
SetValue Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetValue Method (Byte[], Int32, Int32)

Field SetValue Method ( Byte , Int32, Int32) Lucene.Net Class Library
Expert: change the value of this field. See setValue(String).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetValue(
    byte[] value,
    int offset,
    int length
)
public void SetValue(
    byte[] value,
    int offset,
    int length
)
Public Sub SetValue ( _
    value As Byte(), _
    offset As Integer, _
    length As Integer _
)
Public Sub SetValue ( _
    value As Byte(), _
    offset As Integer, _
    length As Integer _
)
public:
void SetValue(
    array<unsigned char>^ value,
    int offset,
    int length
)
public:
void SetValue(
    array<unsigned char>^ value,
    int offset,
    int length
)
Parameters
value
Type:    Online System Byte
offset
Type:   Online System Int32
length
Type:   Online System Int32
See Also
Field Class
Field Members
SetValue Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Properties

Field Properties Lucene.Net Class Library
The Field type exposes the following members.
Properties
 | Name | Description
Public property | BinaryLength | Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined (Inherited from AbstractField.)
Public property | BinaryOffset | Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined (Inherited from AbstractField.)
Public property | Boost | Gets or sets the boost factor for hits for this field. The default value is 1.0. Note: this value is not stored directly with the document in the index. Documents returned from Document(Int32) and Doc(Int32) may thus not have the same value present as when this field was indexed. (Inherited from AbstractField.)
Public property | IsBinary | True iff the value of the filed is stored as binary (Inherited from AbstractField.)
Public property | IsIndexed | True iff the value of the field is to be indexed, so that it may be searched on. (Inherited from AbstractField.)
Public property | IsLazy | (Inherited from AbstractField.)
Public property | IsStored | True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued. (Inherited from AbstractField.)
Public property | IsStoreOffsetWithTermVector | True iff terms are stored as term vector together with their offsets (start and end position in source text). (Inherited from AbstractField.)
Public property | IsStorePositionWithTermVector | True iff terms are stored as term vector together with their token positions. (Inherited from AbstractField.)
Public property | IsTermVectorStored | True iff the term or terms used to index this field are stored as a term vector, available from GetTermFreqVector(Int32, String). These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the stored attribute instead. (Inherited from AbstractField.)
Public property | IsTokenized | True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued. (Inherited from AbstractField.)
Public property | Name | Returns the name of the field as an interned string. For example "date", "title", "body", ... (Inherited from AbstractField.)
Public property | OmitNorms | True if norms are omitted for this indexed field (Inherited from AbstractField.)
Public property | OmitTermFreqAndPositions | Expert: If set, omit term freq, positions and payloads from postings for this field. NOTE: While this option reduces storage space required in the index, it also means any query requiring positional information, such as PhraseQuery or SpanQuery subclasses will silently fail to find results. (Inherited from AbstractField.)
Public property | ReaderValue | The value of the field as a Reader, or null. If null, the String value or binary value is used. Exactly one of stringValue(), readerValue(), and getBinaryValue() must be set. (Overrides AbstractField ReaderValue.)
Public property | StringValue | The value of the field as a String, or null. If null, the Reader value or binary value is used. Exactly one of stringValue(), readerValue(), and getBinaryValue() must be set. (Overrides AbstractField StringValue.)
Public property | TokenStreamValue | The TokesStream for this field to be used when indexing, or null. If null, the Reader value or String value is analyzed to produce the indexed tokens. (Overrides AbstractField TokenStreamValue.)
Back to Top
See Also
Field Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReaderValue Property

Field ReaderValue Property Lucene.Net Class Library
The value of the field as a Reader, or null. If null, the String value or binary value is used. Exactly one of stringValue(), readerValue(), and getBinaryValue() must be set.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TextReader ReaderValue { get; }
public override TextReader ReaderValue { get; }
Public Overrides ReadOnly Property ReaderValue As TextReader
    Get
Public Overrides ReadOnly Property ReaderValue As TextReader
    Get
public:
virtual property TextReader^ ReaderValue {
    TextReader^ get () override;
}
public:
virtual property TextReader^ ReaderValue {
    TextReader^ get () override;
}
Implements
IFieldable ReaderValue
IFieldable ReaderValue
See Also
Field Class
Field Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringValue Property

Field StringValue Property Lucene.Net Class Library
The value of the field as a String, or null. If null, the Reader value or binary value is used. Exactly one of stringValue(), readerValue(), and getBinaryValue() must be set.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string StringValue { get; }
public override string StringValue { get; }
Public Overrides ReadOnly Property StringValue As String
    Get
Public Overrides ReadOnly Property StringValue As String
    Get
public:
virtual property String^ StringValue {
    String^ get () override;
}
public:
virtual property String^ StringValue {
    String^ get () override;
}
Implements
IFieldable StringValue
IFieldable StringValue
See Also
Field Class
Field Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStreamValue Property

Field TokenStreamValue Property Lucene.Net Class Library
The TokesStream for this field to be used when indexing, or null. If null, the Reader value or String value is analyzed to produce the indexed tokens.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TokenStream TokenStreamValue { get; }
public override TokenStream TokenStreamValue { get; }
Public Overrides ReadOnly Property TokenStreamValue As TokenStream
    Get
Public Overrides ReadOnly Property TokenStreamValue As TokenStream
    Get
public:
virtual property TokenStream^ TokenStreamValue {
    TokenStream^ get () override;
}
public:
virtual property TokenStream^ TokenStreamValue {
    TokenStream^ get () override;
}
Implements
IFieldable TokenStreamValue
IFieldable TokenStreamValue
See Also
Field Class
Field Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field.Index Enumeration

Field Index Enumeration Lucene.Net Class Library
Specifies whether and how a field should be indexed.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Index
public enum Index
Public Enumeration Index
Public Enumeration Index
public enum class Index
public enum class Index
Members
Member name | Value | Description
NO | 0 | Do not index the field value. This field can thus not be searched, but one can still access its contents provided it is stored.
ANALYZED | 1 | Index the tokens produced by running the field's value through an Analyzer. This is useful for common text.
NOT_ANALYZED | 2 | Index the field's value without using an Analyzer, so it can be searched. As no analyzer is used the value will be stored as a single term. This is useful for unique Ids like product numbers.
NOT_ANALYZED_NO_NORMS | 3 | Expert: Index the field's value without an Analyzer, and also disable the storing of norms. Note that you can also separately enable/disable norms by setting OmitNorms. No norms means that index-time field and document boosting and field length normalization are disabled. The benefit is less memory usage as norms take up one byte of RAM per indexed field for every document in the index, during searching. Note that once you index a given field with norms enabled, disabling norms will have no effect. In other words, for this to have the above described effect on a field, all instances of that field must be indexed with NOT_ANALYZED_NO_NORMS from the beginning.
ANALYZED_NO_NORMS | 4 | Expert: Index the tokens produced by running the field's value through an Analyzer, and also separately disable the storing of norms. See NOT_ANALYZED_NO_NORMS for what norms are and why you may want to disable them.
See Also
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field.Store Enumeration

Field Store Enumeration Lucene.Net Class Library
Specifies whether and how a field should be stored.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Store
public enum Store
Public Enumeration Store
Public Enumeration Store
public enum class Store
public enum class Store
Members
Member name | Value | Description
YES | 0 | Store the original field value in the index. This is useful for short texts like a document's title which should be displayed with the results. The value is stored in its original form, i.e. no analyzer is used before it is stored.
NO | 1 | Do not store the field value in the index.
See Also
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field.TermVector Enumeration

Field TermVector Enumeration Lucene.Net Class Library
Specifies whether and how a field should have term vectors.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum TermVector
public enum TermVector
Public Enumeration TermVector
Public Enumeration TermVector
public enum class TermVector
public enum class TermVector
Members
Member name | Value | Description
NO | 0 | Do not store term vectors.
YES | 1 | Store the term vectors of each document. A term vector is a list of the document's terms and their number of occurrences in that document.
WITH_POSITIONS | 2 | Store the term vector + token position information
WITH_OFFSETS | 3 | Store the term vector + Token offset information
WITH_POSITIONS_OFFSETS | 4 | Store the term vector + Token position and offset information
See Also
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldExtensions Class

FieldExtensions Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Documents FieldExtensions

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class FieldExtensions
public static class FieldExtensions
<ExtensionAttribute> _
Public NotInheritable Class FieldExtensions
<ExtensionAttribute> _
Public NotInheritable Class FieldExtensions
[ExtensionAttribute]
public ref class FieldExtensions abstract sealed
[ExtensionAttribute]
public ref class FieldExtensions abstract sealed
See Also
FieldExtensions Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldExtensions Members

FieldExtensions Members Lucene.Net Class Library

The FieldExtensions type exposes the following members.
Methods
Name | Description
IsAnalyzed |
IsIndexed |
IsStored(Field Store) |
IsStored(Field TermVector) |
OmitNorms |
ToIndex(Boolean, Boolean) |
ToIndex(Boolean, Boolean, Boolean) |
ToTermVector | Get the best representation of a TermVector given the flags.
WithOffsets |
WithPositions |
Back to Top
See Also
FieldExtensions Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldExtensions Methods

FieldExtensions Methods Lucene.Net Class Library
The FieldExtensions type exposes the following members.
Methods
Name | Description
IsAnalyzed |
IsIndexed |
IsStored(Field Store) |
IsStored(Field TermVector) |
OmitNorms |
ToIndex(Boolean, Boolean) |
ToIndex(Boolean, Boolean, Boolean) |
ToTermVector | Get the best representation of a TermVector given the flags.
WithOffsets |
WithPositions |
Back to Top
See Also
FieldExtensions Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsAnalyzed Method

FieldExtensions IsAnalyzed Method Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsAnalyzed(
    this Field..::..Index index
)
public static bool IsAnalyzed(
    this Field..::..Index index
)
<ExtensionAttribute> _
Public Shared Function IsAnalyzed ( _
    index As Field..::..Index _
) As Boolean
<ExtensionAttribute> _
Public Shared Function IsAnalyzed ( _
    index As Field..::..Index _
) As Boolean
public:
[ExtensionAttribute]
static bool IsAnalyzed(
    Field..::..Index index
)
public:
[ExtensionAttribute]
static bool IsAnalyzed(
    Field..::..Index index
)
Parameters
index
Type: Lucene.Net.Documents Field Index
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type Field Index. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
FieldExtensions Class
FieldExtensions Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsIndexed Method

FieldExtensions IsIndexed Method Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsIndexed(
    this Field..::..Index index
)
public static bool IsIndexed(
    this Field..::..Index index
)
<ExtensionAttribute> _
Public Shared Function IsIndexed ( _
    index As Field..::..Index _
) As Boolean
<ExtensionAttribute> _
Public Shared Function IsIndexed ( _
    index As Field..::..Index _
) As Boolean
public:
[ExtensionAttribute]
static bool IsIndexed(
    Field..::..Index index
)
public:
[ExtensionAttribute]
static bool IsIndexed(
    Field..::..Index index
)
Parameters
index
Type: Lucene.Net.Documents Field Index
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type Field Index. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
FieldExtensions Class
FieldExtensions Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsStored Method

FieldExtensions IsStored Method Lucene.Net Class Library
Overload List
Name | Description
IsStored(Field Store) |
IsStored(Field TermVector) |
Back to Top
See Also
FieldExtensions Class
FieldExtensions Members
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsStored Method (Field.Store)

FieldExtensions IsStored Method (Field Store) Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsStored(
    this Field..::..Store store
)
public static bool IsStored(
    this Field..::..Store store
)
<ExtensionAttribute> _
Public Shared Function IsStored ( _
    store As Field..::..Store _
) As Boolean
<ExtensionAttribute> _
Public Shared Function IsStored ( _
    store As Field..::..Store _
) As Boolean
public:
[ExtensionAttribute]
static bool IsStored(
    Field..::..Store store
)
public:
[ExtensionAttribute]
static bool IsStored(
    Field..::..Store store
)
Parameters
store
Type: Lucene.Net.Documents Field Store
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type Field Store. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
FieldExtensions Class
FieldExtensions Members
IsStored Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsStored Method (Field.TermVector)

FieldExtensions IsStored Method (Field TermVector) Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsStored(
    this Field..::..TermVector tv
)
public static bool IsStored(
    this Field..::..TermVector tv
)
<ExtensionAttribute> _
Public Shared Function IsStored ( _
    tv As Field..::..TermVector _
) As Boolean
<ExtensionAttribute> _
Public Shared Function IsStored ( _
    tv As Field..::..TermVector _
) As Boolean
public:
[ExtensionAttribute]
static bool IsStored(
    Field..::..TermVector tv
)
public:
[ExtensionAttribute]
static bool IsStored(
    Field..::..TermVector tv
)
Parameters
tv
Type: Lucene.Net.Documents Field TermVector
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type Field TermVector. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
FieldExtensions Class
FieldExtensions Members
IsStored Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OmitNorms Method

FieldExtensions OmitNorms Method Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool OmitNorms(
    this Field..::..Index index
)
public static bool OmitNorms(
    this Field..::..Index index
)
<ExtensionAttribute> _
Public Shared Function OmitNorms ( _
    index As Field..::..Index _
) As Boolean
<ExtensionAttribute> _
Public Shared Function OmitNorms ( _
    index As Field..::..Index _
) As Boolean
public:
[ExtensionAttribute]
static bool OmitNorms(
    Field..::..Index index
)
public:
[ExtensionAttribute]
static bool OmitNorms(
    Field..::..Index index
)
Parameters
index
Type: Lucene.Net.Documents Field Index
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type Field Index. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
FieldExtensions Class
FieldExtensions Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToIndex Method

FieldExtensions ToIndex Method Lucene.Net Class Library
Overload List
Name | Description
ToIndex(Boolean, Boolean) |
ToIndex(Boolean, Boolean, Boolean) |
Back to Top
See Also
FieldExtensions Class
FieldExtensions Members
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToIndex Method (Boolean, Boolean)

FieldExtensions ToIndex Method (Boolean, Boolean) Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Field..::..Index ToIndex(
    bool indexed,
    bool analyed
)
public static Field..::..Index ToIndex(
    bool indexed,
    bool analyed
)
Public Shared Function ToIndex ( _
    indexed As Boolean, _
    analyed As Boolean _
) As Field..::..Index
Public Shared Function ToIndex ( _
    indexed As Boolean, _
    analyed As Boolean _
) As Field..::..Index
public:
static Field..::..Index ToIndex(
    bool indexed,
    bool analyed
)
public:
static Field..::..Index ToIndex(
    bool indexed,
    bool analyed
)
Parameters
indexed
Type:   Online System Boolean
analyed
Type:   Online System Boolean
See Also
FieldExtensions Class
FieldExtensions Members
ToIndex Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToIndex Method (Boolean, Boolean, Boolean)

FieldExtensions ToIndex Method (Boolean, Boolean, Boolean) Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Field..::..Index ToIndex(
    bool indexed,
    bool analyzed,
    bool omitNorms
)
public static Field..::..Index ToIndex(
    bool indexed,
    bool analyzed,
    bool omitNorms
)
Public Shared Function ToIndex ( _
    indexed As Boolean, _
    analyzed As Boolean, _
    omitNorms As Boolean _
) As Field..::..Index
Public Shared Function ToIndex ( _
    indexed As Boolean, _
    analyzed As Boolean, _
    omitNorms As Boolean _
) As Field..::..Index
public:
static Field..::..Index ToIndex(
    bool indexed,
    bool analyzed,
    bool omitNorms
)
public:
static Field..::..Index ToIndex(
    bool indexed,
    bool analyzed,
    bool omitNorms
)
Parameters
indexed
Type:   Online System Boolean
analyzed
Type:   Online System Boolean
omitNorms
Type:   Online System Boolean
See Also
FieldExtensions Class
FieldExtensions Members
ToIndex Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToTermVector Method

FieldExtensions ToTermVector Method Lucene.Net Class Library
Get the best representation of a TermVector given the flags.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Field..::..TermVector ToTermVector(
    bool stored,
    bool withOffsets,
    bool withPositions
)
public static Field..::..TermVector ToTermVector(
    bool stored,
    bool withOffsets,
    bool withPositions
)
Public Shared Function ToTermVector ( _
    stored As Boolean, _
    withOffsets As Boolean, _
    withPositions As Boolean _
) As Field..::..TermVector
Public Shared Function ToTermVector ( _
    stored As Boolean, _
    withOffsets As Boolean, _
    withPositions As Boolean _
) As Field..::..TermVector
public:
static Field..::..TermVector ToTermVector(
    bool stored,
    bool withOffsets,
    bool withPositions
)
public:
static Field..::..TermVector ToTermVector(
    bool stored,
    bool withOffsets,
    bool withPositions
)
Parameters
stored
Type:   Online System Boolean
withOffsets
Type:   Online System Boolean
withPositions
Type:   Online System Boolean
See Also
FieldExtensions Class
FieldExtensions Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WithOffsets Method

FieldExtensions WithOffsets Method Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool WithOffsets(
    this Field..::..TermVector tv
)
public static bool WithOffsets(
    this Field..::..TermVector tv
)
<ExtensionAttribute> _
Public Shared Function WithOffsets ( _
    tv As Field..::..TermVector _
) As Boolean
<ExtensionAttribute> _
Public Shared Function WithOffsets ( _
    tv As Field..::..TermVector _
) As Boolean
public:
[ExtensionAttribute]
static bool WithOffsets(
    Field..::..TermVector tv
)
public:
[ExtensionAttribute]
static bool WithOffsets(
    Field..::..TermVector tv
)
Parameters
tv
Type: Lucene.Net.Documents Field TermVector
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type Field TermVector. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
FieldExtensions Class
FieldExtensions Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WithPositions Method

FieldExtensions WithPositions Method Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool WithPositions(
    this Field..::..TermVector tv
)
public static bool WithPositions(
    this Field..::..TermVector tv
)
<ExtensionAttribute> _
Public Shared Function WithPositions ( _
    tv As Field..::..TermVector _
) As Boolean
<ExtensionAttribute> _
Public Shared Function WithPositions ( _
    tv As Field..::..TermVector _
) As Boolean
public:
[ExtensionAttribute]
static bool WithPositions(
    Field..::..TermVector tv
)
public:
[ExtensionAttribute]
static bool WithPositions(
    Field..::..TermVector tv
)
Parameters
tv
Type: Lucene.Net.Documents Field TermVector
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type Field TermVector. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
FieldExtensions Class
FieldExtensions Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldSelector Interface

FieldSelector Interface Lucene.Net Class Library
Similar to a Online java.io.FileFilter, the FieldSelector allows one to make decisions about what Fields get loaded on a Document by Document(Int32, FieldSelector)

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface FieldSelector
public interface FieldSelector
Public Interface FieldSelector
Public Interface FieldSelector
public interface class FieldSelector
public interface class FieldSelector
See Also
FieldSelector Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldSelector Members

FieldSelector Members Lucene.Net Class Library

The FieldSelector type exposes the following members.
Methods
 | Name | Description
Public method | Accept |
Back to Top
See Also
FieldSelector Interface
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldSelector Methods

FieldSelector Methods Lucene.Net Class Library
The FieldSelector type exposes the following members.
Methods
 | Name | Description
Public method | Accept |
Back to Top
See Also
FieldSelector Interface
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Accept Method

FieldSelector Accept Method Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
FieldSelectorResult Accept(
    string fieldName
)
FieldSelectorResult Accept(
    string fieldName
)
Function Accept ( _
    fieldName As String _
) As FieldSelectorResult
Function Accept ( _
    fieldName As String _
) As FieldSelectorResult
FieldSelectorResult Accept(
    String^ fieldName
)
FieldSelectorResult Accept(
    String^ fieldName
)
Parameters
fieldName
Type:   Online System String
the field to accept or reject

Return Value
 an instance of FieldSelectorResult
            if the Field named fieldName should be loaded.

See Also
FieldSelector Interface
FieldSelector Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldSelectorResult Enumeration

FieldSelectorResult Enumeration Lucene.Net Class Library
Provides information about what should be done with this Field

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum FieldSelectorResult
public enum FieldSelectorResult
Public Enumeration FieldSelectorResult
Public Enumeration FieldSelectorResult
public enum class FieldSelectorResult
public enum class FieldSelectorResult
Members
Member name | Value | Description
INVALID | 0 |
LOAD | 1 | Load this Field every time the Document is loaded, reading in the data as it is encountered. GetField(String) and GetFieldable(String) should not return null. Add(IFieldable) should be called by the Reader.
LAZY_LOAD | 2 | Lazily load this Field. This means the Field is valid, but it may not actually contain its data until invoked. GetField(String) SHOULD NOT BE USED. GetFieldable(String) is safe to use and should return a valid instance of a IFieldable. Add(IFieldable) should be called by the Reader.
NO_LOAD | 3 | Do not load the Field. GetField(String) and GetFieldable(String) should return null. Add(IFieldable) is not called. Add(IFieldable) should not be called by the Reader.
LOAD_AND_BREAK | 4 | Load this field as in the LOAD case, but immediately return from Field loading for the Document. Thus, the Document may not have its complete set of Fields. GetField(String) and GetFieldable(String) should both be valid for this Field Add(IFieldable) should be called by the Reader.
SIZE | 5 | Expert: Load the size of this Field rather than its value. Size is measured as number of bytes required to store the field == bytes for a binary or any compressed value, and 2*chars for a String value. The size is stored as a binary value, represented as an int in a byte[], with the higher order byte first in [0]
SIZE_AND_BREAK | 6 | Expert: Like SIZE but immediately break from the field loading loop, i.e., stop loading further fields, after the size is loaded
See Also
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IFieldable Interface

IFieldable Interface Lucene.Net Class Library
Synonymous with Field.

WARNING: This interface may change within minor versions, despite Lucene's backward compatibility requirements. This means new methods may be added from version to version. This change only affects the Fieldable API; other backwards compatibility promises remain intact. For example, Lucene can still read and write indices created within the same major version.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IFieldable
public interface IFieldable
Public Interface IFieldable
Public Interface IFieldable
public interface class IFieldable
public interface class IFieldable
See Also
IFieldable Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IFieldable Members

IFieldable Members Lucene.Net Class Library

The IFieldable type exposes the following members.
Methods
 | Name | Description
Public method | GetBinaryValue | Return the raw byte[] for the binary field. Note that you must also call BinaryLength and BinaryOffset to know which range of bytes in this returned array belong to the field.
Public method | GetBinaryValue( Byte ) | Return the raw byte[] for the binary field. Note that you must also call BinaryLength and BinaryOffset to know which range of bytes in this returned array belong to the field. About reuse: if you pass in the result byte[] and it is used, likely the underlying implementation will hold onto this byte[] and return it in future calls to GetBinaryValue or GetBinaryValue . So if you subsequently re-use the same byte[] elsewhere it will alter this Fieldable's value.
Back to Top
Properties
 | Name | Description
Public property | BinaryLength | Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined
Public property | BinaryOffset | Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined
Public property | Boost | Gets or sets the boost factor for hits for this field. This value will be multiplied into the score of all hits on this this field of this document. The boost is multiplied by Boost of the document containing this field. If a document has multiple fields with the same name, all such values are multiplied together. This product is then used to compute the norm factor for the field. By default, in the ComputeNorm(String, FieldInvertState) method, the boost value is multiplied by the LengthNorm(String, Int32) and then rounded by EncodeNorm(Single) before it is stored in the index. One should attempt to ensure that this product does not overflow the range of that encoding. The default value is 1.0. Note: this value is not stored directly with the document in the index. Documents returned from Document(Int32) and Doc(Int32) may thus not have the same value present as when this field was indexed.
Public property | IsBinary | True if the value of the field is stored as binary
Public property | IsIndexed | True if the value of the field is to be indexed, so that it may be searched on.
Public property | IsLazy | Indicates whether a Field is Lazy or not. The semantics of Lazy loading are such that if a Field is lazily loaded, retrieving it's values via StringValue or GetBinaryValue is only valid as long as the IndexReader that retrieved the Document is still open.
Public property | IsStored | True if the value of the field is to be stored in the index for return with search hits.
Public property | IsStoreOffsetWithTermVector | True if terms are stored as term vector together with their offsets (start and end positon in source text).
Public property | IsStorePositionWithTermVector | True if terms are stored as term vector together with their token positions.
Public property | IsTermVectorStored | True if the term or terms used to index this field are stored as a term vector, available from GetTermFreqVector(Int32, String). These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the stored attribute instead.
Public property | IsTokenized | True if the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Public property | Name | Returns the name of the field as an interned string. For example "date", "title", "body", ...
Public property | OmitNorms | True if norms are omitted for this indexed field. Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
Public property | OmitTermFreqAndPositions |
Public property | ReaderValue | The value of the field as a Reader, which can be used at index time to generate indexed tokens.
Public property | StringValue | The value of the field as a String, or null. For indexing, if isStored()==true, the stringValue() will be used as the stored field value unless isBinary()==true, in which case GetBinaryValue() will be used. If isIndexed()==true and isTokenized()==false, this String value will be indexed as a single token. If isIndexed()==true and isTokenized()==true, then tokenStreamValue() will be used to generate indexed tokens if not null, else readerValue() will be used to generate indexed tokens if not null, else stringValue() will be used to generate tokens.
Public property | TokenStreamValue | The TokenStream for this field to be used when indexing, or null.
Back to Top
See Also
IFieldable Interface
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IFieldable Methods

IFieldable Methods Lucene.Net Class Library
Methods
 | Name | Description
Public method | GetBinaryValue | Return the raw byte[] for the binary field. Note that you must also call BinaryLength and BinaryOffset to know which range of bytes in this returned array belong to the field.
Public method | GetBinaryValue( Byte ) | Return the raw byte[] for the binary field. Note that you must also call BinaryLength and BinaryOffset to know which range of bytes in this returned array belong to the field. About reuse: if you pass in the result byte[] and it is used, likely the underlying implementation will hold onto this byte[] and return it in future calls to GetBinaryValue or GetBinaryValue . So if you subsequently re-use the same byte[] elsewhere it will alter this Fieldable's value.
Back to Top
See Also
IFieldable Interface
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBinaryValue Method

IFieldable GetBinaryValue Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetBinaryValue | Return the raw byte[] for the binary field. Note that you must also call BinaryLength and BinaryOffset to know which range of bytes in this returned array belong to the field.
Public method | GetBinaryValue( Byte ) | Return the raw byte[] for the binary field. Note that you must also call BinaryLength and BinaryOffset to know which range of bytes in this returned array belong to the field. About reuse: if you pass in the result byte[] and it is used, likely the underlying implementation will hold onto this byte[] and return it in future calls to GetBinaryValue or GetBinaryValue . So if you subsequently re-use the same byte[] elsewhere it will alter this Fieldable's value.
Back to Top
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBinaryValue Method

IFieldable GetBinaryValue Method Lucene.Net Class Library
Return the raw byte[] for the binary field. Note that you must also call BinaryLength and BinaryOffset to know which range of bytes in this returned array belong to the field.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
byte[] GetBinaryValue()
byte[] GetBinaryValue()
Function GetBinaryValue As Byte()
Function GetBinaryValue As Byte()
array<unsigned char>^ GetBinaryValue()
array<unsigned char>^ GetBinaryValue()
Return Value
 reference to the Field value as byte[].
See Also
IFieldable Interface
IFieldable Members
GetBinaryValue Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBinaryValue Method (Byte[])

IFieldable GetBinaryValue Method ( Byte ) Lucene.Net Class Library
Return the raw byte[] for the binary field. Note that you must also call BinaryLength and BinaryOffset to know which range of bytes in this returned array belong to the field.

About reuse: if you pass in the result byte[] and it is used, likely the underlying implementation will hold onto this byte[] and return it in future calls to GetBinaryValue or GetBinaryValue . So if you subsequently re-use the same byte[] elsewhere it will alter this Fieldable's value.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
byte[] GetBinaryValue(
    byte[] result
)
byte[] GetBinaryValue(
    byte[] result
)
Function GetBinaryValue ( _
    result As Byte() _
) As Byte()
Function GetBinaryValue ( _
    result As Byte() _
) As Byte()
array<unsigned char>^ GetBinaryValue(
    array<unsigned char>^ result
)
array<unsigned char>^ GetBinaryValue(
    array<unsigned char>^ result
)
Parameters
result
Type:    Online System Byte
 User defined buffer that will be used if
            possible.  If this is null or not large enough, a new
            buffer is allocated

Return Value
 reference to the Field value as byte[].

See Also
IFieldable Interface
IFieldable Members
GetBinaryValue Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IFieldable Properties

IFieldable Properties Lucene.Net Class Library
The IFieldable type exposes the following members.
Properties
 | Name | Description
Public property | BinaryLength | Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined
Public property | BinaryOffset | Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined
Public property | Boost | Gets or sets the boost factor for hits for this field. This value will be multiplied into the score of all hits on this this field of this document. The boost is multiplied by Boost of the document containing this field. If a document has multiple fields with the same name, all such values are multiplied together. This product is then used to compute the norm factor for the field. By default, in the ComputeNorm(String, FieldInvertState) method, the boost value is multiplied by the LengthNorm(String, Int32) and then rounded by EncodeNorm(Single) before it is stored in the index. One should attempt to ensure that this product does not overflow the range of that encoding. The default value is 1.0. Note: this value is not stored directly with the document in the index. Documents returned from Document(Int32) and Doc(Int32) may thus not have the same value present as when this field was indexed.
Public property | IsBinary | True if the value of the field is stored as binary
Public property | IsIndexed | True if the value of the field is to be indexed, so that it may be searched on.
Public property | IsLazy | Indicates whether a Field is Lazy or not. The semantics of Lazy loading are such that if a Field is lazily loaded, retrieving it's values via StringValue or GetBinaryValue is only valid as long as the IndexReader that retrieved the Document is still open.
Public property | IsStored | True if the value of the field is to be stored in the index for return with search hits.
Public property | IsStoreOffsetWithTermVector | True if terms are stored as term vector together with their offsets (start and end positon in source text).
Public property | IsStorePositionWithTermVector | True if terms are stored as term vector together with their token positions.
Public property | IsTermVectorStored | True if the term or terms used to index this field are stored as a term vector, available from GetTermFreqVector(Int32, String). These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the stored attribute instead.
Public property | IsTokenized | True if the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Public property | Name | Returns the name of the field as an interned string. For example "date", "title", "body", ...
Public property | OmitNorms | True if norms are omitted for this indexed field. Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
Public property | OmitTermFreqAndPositions |
Public property | ReaderValue | The value of the field as a Reader, which can be used at index time to generate indexed tokens.
Public property | StringValue | The value of the field as a String, or null. For indexing, if isStored()==true, the stringValue() will be used as the stored field value unless isBinary()==true, in which case GetBinaryValue() will be used. If isIndexed()==true and isTokenized()==false, this String value will be indexed as a single token. If isIndexed()==true and isTokenized()==true, then tokenStreamValue() will be used to generate indexed tokens if not null, else readerValue() will be used to generate indexed tokens if not null, else stringValue() will be used to generate tokens.
Public property | TokenStreamValue | The TokenStream for this field to be used when indexing, or null.
Back to Top
See Also
IFieldable Interface
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BinaryLength Property

IFieldable BinaryLength Property Lucene.Net Class Library
Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int BinaryLength { get; }
int BinaryLength { get; }
ReadOnly Property BinaryLength As Integer
    Get
ReadOnly Property BinaryLength As Integer
    Get
property int BinaryLength {
    int get ();
}
property int BinaryLength {
    int get ();
}
Field Value
 length of byte[] segment that represents this Field value
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BinaryOffset Property

IFieldable BinaryOffset Property Lucene.Net Class Library
Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int BinaryOffset { get; }
int BinaryOffset { get; }
ReadOnly Property BinaryOffset As Integer
    Get
ReadOnly Property BinaryOffset As Integer
    Get
property int BinaryOffset {
    int get ();
}
property int BinaryOffset {
    int get ();
}
Field Value
 index of the first character in byte[] segment that represents this Field value
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Boost Property

IFieldable Boost Property Lucene.Net Class Library
Gets or sets the boost factor for hits for this field. This value will be multiplied into the score of all hits on this this field of this document.

The boost is multiplied by Boost of the document containing this field. If a document has multiple fields with the same name, all such values are multiplied together. This product is then used to compute the norm factor for the field. By default, in the ComputeNorm(String, FieldInvertState) method, the boost value is multiplied by the LengthNorm(String, Int32) and then rounded by EncodeNorm(Single) before it is stored in the index. One should attempt to ensure that this product does not overflow the range of that encoding.

The default value is 1.0.

Note: this value is not stored directly with the document in the index. Documents returned from Document(Int32) and Doc(Int32) may thus not have the same value present as when this field was indexed.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
float Boost { get; set; }
float Boost { get; set; }
Property Boost As Single
    Get
    Set
Property Boost As Single
    Get
    Set
property float Boost {
    float get ();
    void set (float value);
}
property float Boost {
    float get ();
    void set (float value);
}
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace
Document Boost
Similarity ComputeNorm(String, FieldInvertState)
Similarity EncodeNorm(Single)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsBinary Property

IFieldable IsBinary Property Lucene.Net Class Library
True if the value of the field is stored as binary

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsBinary { get; }
bool IsBinary { get; }
ReadOnly Property IsBinary As Boolean
    Get
ReadOnly Property IsBinary As Boolean
    Get
property bool IsBinary {
    bool get ();
}
property bool IsBinary {
    bool get ();
}
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsIndexed Property

IFieldable IsIndexed Property Lucene.Net Class Library
True if the value of the field is to be indexed, so that it may be searched on.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsIndexed { get; }
bool IsIndexed { get; }
ReadOnly Property IsIndexed As Boolean
    Get
ReadOnly Property IsIndexed As Boolean
    Get
property bool IsIndexed {
    bool get ();
}
property bool IsIndexed {
    bool get ();
}
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsLazy Property

IFieldable IsLazy Property Lucene.Net Class Library
Indicates whether a Field is Lazy or not. The semantics of Lazy loading are such that if a Field is lazily loaded, retrieving it's values via StringValue or GetBinaryValue is only valid as long as the IndexReader that retrieved the Document is still open.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsLazy { get; }
bool IsLazy { get; }
ReadOnly Property IsLazy As Boolean
    Get
ReadOnly Property IsLazy As Boolean
    Get
property bool IsLazy {
    bool get ();
}
property bool IsLazy {
    bool get ();
}
Field Value
 true if this field can be loaded lazily
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsStored Property

IFieldable IsStored Property Lucene.Net Class Library
True if the value of the field is to be stored in the index for return with search hits.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsStored { get; }
bool IsStored { get; }
ReadOnly Property IsStored As Boolean
    Get
ReadOnly Property IsStored As Boolean
    Get
property bool IsStored {
    bool get ();
}
property bool IsStored {
    bool get ();
}
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsStoreOffsetWithTermVector Property

IFieldable IsStoreOffsetWithTermVector Property Lucene.Net Class Library
True if terms are stored as term vector together with their offsets (start and end positon in source text).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsStoreOffsetWithTermVector { get; }
bool IsStoreOffsetWithTermVector { get; }
ReadOnly Property IsStoreOffsetWithTermVector As Boolean
    Get
ReadOnly Property IsStoreOffsetWithTermVector As Boolean
    Get
property bool IsStoreOffsetWithTermVector {
    bool get ();
}
property bool IsStoreOffsetWithTermVector {
    bool get ();
}
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsStorePositionWithTermVector Property

IFieldable IsStorePositionWithTermVector Property Lucene.Net Class Library
True if terms are stored as term vector together with their token positions.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsStorePositionWithTermVector { get; }
bool IsStorePositionWithTermVector { get; }
ReadOnly Property IsStorePositionWithTermVector As Boolean
    Get
ReadOnly Property IsStorePositionWithTermVector As Boolean
    Get
property bool IsStorePositionWithTermVector {
    bool get ();
}
property bool IsStorePositionWithTermVector {
    bool get ();
}
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsTermVectorStored Property

IFieldable IsTermVectorStored Property Lucene.Net Class Library
True if the term or terms used to index this field are stored as a term vector, available from GetTermFreqVector(Int32, String). These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the stored attribute instead.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsTermVectorStored { get; }
bool IsTermVectorStored { get; }
ReadOnly Property IsTermVectorStored As Boolean
    Get
ReadOnly Property IsTermVectorStored As Boolean
    Get
property bool IsTermVectorStored {
    bool get ();
}
property bool IsTermVectorStored {
    bool get ();
}
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace
IndexReader GetTermFreqVector(Int32, String)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsTokenized Property

IFieldable IsTokenized Property Lucene.Net Class Library
True if the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsTokenized { get; }
bool IsTokenized { get; }
ReadOnly Property IsTokenized As Boolean
    Get
ReadOnly Property IsTokenized As Boolean
    Get
property bool IsTokenized {
    bool get ();
}
property bool IsTokenized {
    bool get ();
}
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Name Property

IFieldable Name Property Lucene.Net Class Library
Returns the name of the field as an interned string. For example "date", "title", "body", ...

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Name { get; }
string Name { get; }
ReadOnly Property Name As String
    Get
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
property String^ Name {
    String^ get ();
}
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OmitNorms Property

IFieldable OmitNorms Property Lucene.Net Class Library
True if norms are omitted for this indexed field.

Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool OmitNorms { get; set; }
bool OmitNorms { get; set; }
Property OmitNorms As Boolean
    Get
    Set
Property OmitNorms As Boolean
    Get
    Set
property bool OmitNorms {
    bool get ();
    void set (bool value);
}
property bool OmitNorms {
    bool get ();
    void set (bool value);
}
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OmitTermFreqAndPositions Property

IFieldable OmitTermFreqAndPositions Property Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool OmitTermFreqAndPositions { get; set; }
bool OmitTermFreqAndPositions { get; set; }
Property OmitTermFreqAndPositions As Boolean
    Get
    Set
Property OmitTermFreqAndPositions As Boolean
    Get
    Set
property bool OmitTermFreqAndPositions {
    bool get ();
    void set (bool value);
}
property bool OmitTermFreqAndPositions {
    bool get ();
    void set (bool value);
}
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReaderValue Property

IFieldable ReaderValue Property Lucene.Net Class Library
The value of the field as a Reader, which can be used at index time to generate indexed tokens.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TextReader ReaderValue { get; }
TextReader ReaderValue { get; }
ReadOnly Property ReaderValue As TextReader
    Get
ReadOnly Property ReaderValue As TextReader
    Get
property TextReader^ ReaderValue {
    TextReader^ get ();
}
property TextReader^ ReaderValue {
    TextReader^ get ();
}
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace
IFieldable StringValue
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringValue Property

IFieldable StringValue Property Lucene.Net Class Library
The value of the field as a String, or null.

For indexing, if isStored()==true, the stringValue() will be used as the stored field value unless isBinary()==true, in which case GetBinaryValue() will be used. If isIndexed()==true and isTokenized()==false, this String value will be indexed as a single token. If isIndexed()==true and isTokenized()==true, then tokenStreamValue() will be used to generate indexed tokens if not null, else readerValue() will be used to generate indexed tokens if not null, else stringValue() will be used to generate tokens.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string StringValue { get; }
string StringValue { get; }
ReadOnly Property StringValue As String
    Get
ReadOnly Property StringValue As String
    Get
property String^ StringValue {
    String^ get ();
}
property String^ StringValue {
    String^ get ();
}
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStreamValue Property

IFieldable TokenStreamValue Property Lucene.Net Class Library
The TokenStream for this field to be used when indexing, or null.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TokenStream TokenStreamValue { get; }
TokenStream TokenStreamValue { get; }
ReadOnly Property TokenStreamValue As TokenStream
    Get
ReadOnly Property TokenStreamValue As TokenStream
    Get
property TokenStream^ TokenStreamValue {
    TokenStream^ get ();
}
property TokenStream^ TokenStreamValue {
    TokenStream^ get ();
}
See Also
IFieldable Interface
IFieldable Members
Lucene.Net.Documents Namespace
IFieldable StringValue
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LoadFirstFieldSelector Class

LoadFirstFieldSelector Class Lucene.Net Class Library
Load the First field and break.

See LOAD_AND_BREAK
Inheritance Hierarchy
Online System Object
Lucene.Net.Documents LoadFirstFieldSelector

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class LoadFirstFieldSelector : FieldSelector
[SerializableAttribute]
public class LoadFirstFieldSelector : FieldSelector
<SerializableAttribute> _
Public Class LoadFirstFieldSelector _
    Implements FieldSelector
<SerializableAttribute> _
Public Class LoadFirstFieldSelector _
    Implements FieldSelector
[SerializableAttribute]
public ref class LoadFirstFieldSelector : FieldSelector
[SerializableAttribute]
public ref class LoadFirstFieldSelector : FieldSelector
See Also
LoadFirstFieldSelector Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LoadFirstFieldSelector Members

LoadFirstFieldSelector Members Lucene.Net Class Library

The LoadFirstFieldSelector type exposes the following members.
Constructors
 | Name | Description
Public method | LoadFirstFieldSelector | Initializes a new instance of the LoadFirstFieldSelector class
Back to Top
Methods
 | Name | Description
Public method | Accept |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LoadFirstFieldSelector Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LoadFirstFieldSelector Constructor

LoadFirstFieldSelector Constructor Lucene.Net Class Library
Initializes a new instance of the LoadFirstFieldSelector class

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoadFirstFieldSelector()
public LoadFirstFieldSelector()
Public Sub New
Public Sub New
public:
LoadFirstFieldSelector()
public:
LoadFirstFieldSelector()
See Also
LoadFirstFieldSelector Class
LoadFirstFieldSelector Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LoadFirstFieldSelector Methods

LoadFirstFieldSelector Methods Lucene.Net Class Library
The LoadFirstFieldSelector type exposes the following members.
Methods
 | Name | Description
Public method | Accept |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LoadFirstFieldSelector Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Accept Method

LoadFirstFieldSelector Accept Method Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual FieldSelectorResult Accept(
    string fieldName
)
public virtual FieldSelectorResult Accept(
    string fieldName
)
Public Overridable Function Accept ( _
    fieldName As String _
) As FieldSelectorResult
Public Overridable Function Accept ( _
    fieldName As String _
) As FieldSelectorResult
public:
virtual FieldSelectorResult Accept(
    String^ fieldName
)
public:
virtual FieldSelectorResult Accept(
    String^ fieldName
)
Parameters
fieldName
Type:   Online System String
Implements
FieldSelector Accept(String)
See Also
LoadFirstFieldSelector Class
LoadFirstFieldSelector Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MapFieldSelector Class

MapFieldSelector Class Lucene.Net Class Library
A FieldSelector based on a Map of field names to FieldSelectorResults
Inheritance Hierarchy
Online System Object
Lucene.Net.Documents MapFieldSelector

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MapFieldSelector : FieldSelector
[SerializableAttribute]
public class MapFieldSelector : FieldSelector
<SerializableAttribute> _
Public Class MapFieldSelector _
    Implements FieldSelector
<SerializableAttribute> _
Public Class MapFieldSelector _
    Implements FieldSelector
[SerializableAttribute]
public ref class MapFieldSelector : FieldSelector
[SerializableAttribute]
public ref class MapFieldSelector : FieldSelector
See Also
MapFieldSelector Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MapFieldSelector Members

MapFieldSelector Members Lucene.Net Class Library

The MapFieldSelector type exposes the following members.
Constructors
 | Name | Description
Public method | MapFieldSelector(IDictionary String, FieldSelectorResult ) | Create a a MapFieldSelector
Public method | MapFieldSelector(IList String ) | Create a a MapFieldSelector
Public method | MapFieldSelector( String ) | Create a a MapFieldSelector
Back to Top
Methods
 | Name | Description
Public method | Accept | Load field according to its associated value in fieldSelections
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MapFieldSelector Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MapFieldSelector Constructor

MapFieldSelector Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | MapFieldSelector(IDictionary String, FieldSelectorResult ) | Create a a MapFieldSelector
Public method | MapFieldSelector(IList String ) | Create a a MapFieldSelector
Public method | MapFieldSelector( String ) | Create a a MapFieldSelector
Back to Top
See Also
MapFieldSelector Class
MapFieldSelector Members
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MapFieldSelector Constructor (IDictionary(String, FieldSelectorResult))

MapFieldSelector Constructor (IDictionary String, FieldSelectorResult ) Lucene.Net Class Library
Create a a MapFieldSelector

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MapFieldSelector(
    IDictionary<string, FieldSelectorResult> fieldSelections
)
public MapFieldSelector(
    IDictionary<string, FieldSelectorResult> fieldSelections
)
Public Sub New ( _
    fieldSelections As IDictionary(Of String, FieldSelectorResult) _
)
Public Sub New ( _
    fieldSelections As IDictionary(Of String, FieldSelectorResult) _
)
public:
MapFieldSelector(
    IDictionary<String^, FieldSelectorResult>^ fieldSelections
)
public:
MapFieldSelector(
    IDictionary<String^, FieldSelectorResult>^ fieldSelections
)
Parameters
fieldSelections
Type:   Online System.Collections.Generic IDictionary    Online String, FieldSelectorResult
maps from field names (String) to FieldSelectorResults

See Also
MapFieldSelector Class
MapFieldSelector Members
MapFieldSelector Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MapFieldSelector Constructor (IList(String))

MapFieldSelector Constructor (IList String ) Lucene.Net Class Library
Create a a MapFieldSelector

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MapFieldSelector(
    IList<string> fields
)
public MapFieldSelector(
    IList<string> fields
)
Public Sub New ( _
    fields As IList(Of String) _
)
Public Sub New ( _
    fields As IList(Of String) _
)
public:
MapFieldSelector(
    IList<String^>^ fields
)
public:
MapFieldSelector(
    IList<String^>^ fields
)
Parameters
fields
Type:   Online System.Collections.Generic IList    Online String
fields to LOAD.  List of Strings.  All other fields are NO_LOAD.

See Also
MapFieldSelector Class
MapFieldSelector Members
MapFieldSelector Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MapFieldSelector Constructor (String[])

MapFieldSelector Constructor ( String ) Lucene.Net Class Library
Create a a MapFieldSelector

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MapFieldSelector(
    params string[] fields
)
public MapFieldSelector(
    params string[] fields
)
Public Sub New ( _
    ParamArray fields As String() _
)
Public Sub New ( _
    ParamArray fields As String() _
)
public:
MapFieldSelector(
    ... array<String^>^ fields
)
public:
MapFieldSelector(
    ... array<String^>^ fields
)
Parameters
fields
Type:    Online System String
fields to LOAD.  All other fields are NO_LOAD.

See Also
MapFieldSelector Class
MapFieldSelector Members
MapFieldSelector Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MapFieldSelector Methods

MapFieldSelector Methods Lucene.Net Class Library
The MapFieldSelector type exposes the following members.
Methods
 | Name | Description
Public method | Accept | Load field according to its associated value in fieldSelections
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MapFieldSelector Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Accept Method

MapFieldSelector Accept Method Lucene.Net Class Library
Load field according to its associated value in fieldSelections

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual FieldSelectorResult Accept(
    string field
)
public virtual FieldSelectorResult Accept(
    string field
)
Public Overridable Function Accept ( _
    field As String _
) As FieldSelectorResult
Public Overridable Function Accept ( _
    field As String _
) As FieldSelectorResult
public:
virtual FieldSelectorResult Accept(
    String^ field
)
public:
virtual FieldSelectorResult Accept(
    String^ field
)
Parameters
field
Type:   Online System String
a field name

Return Value
 the fieldSelections value that field maps to or NO_LOAD if none.

Implements
FieldSelector Accept(String)
See Also
MapFieldSelector Class
MapFieldSelector Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumberTools Class

NumberTools Class Lucene.Net Class Library
Provides support for converting longs to Strings, and back again. The strings are structured so that lexicographic sorting order is preserved.

That is, if l1 is less than l2 for any two longs l1 and l2, then NumberTools.longToString(l1) is lexicographically less than NumberTools.longToString(l2). (Similarly for "greater than" and "equals".)

This class handles all long values (unlike DateField).
Inheritance Hierarchy
Online System Object
Lucene.Net.Documents NumberTools

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("For new indexes use NumericUtils instead, which provides a sortable binary representation (prefix encoded) of numeric values. To index and efficiently query numeric values use NumericField and NumericRangeQuery. This class is included for use with existing indices and will be removed in a future release (possibly Lucene 4.0).")]
public class NumberTools
[ObsoleteAttribute("For new indexes use NumericUtils instead, which provides a sortable binary representation (prefix encoded) of numeric values. To index and efficiently query numeric values use NumericField and NumericRangeQuery. This class is included for use with existing indices and will be removed in a future release (possibly Lucene 4.0).")]
public class NumberTools
<ObsoleteAttribute("For new indexes use NumericUtils instead, which provides a sortable binary representation (prefix encoded) of numeric values. To index and efficiently query numeric values use NumericField and NumericRangeQuery. This class is included for use with existing indices and will be removed in a future release (possibly Lucene 4.0).")> _
Public Class NumberTools
<ObsoleteAttribute("For new indexes use NumericUtils instead, which provides a sortable binary representation (prefix encoded) of numeric values. To index and efficiently query numeric values use NumericField and NumericRangeQuery. This class is included for use with existing indices and will be removed in a future release (possibly Lucene 4.0).")> _
Public Class NumberTools
[ObsoleteAttribute(L"For new indexes use NumericUtils instead, which provides a sortable binary representation (prefix encoded) of numeric values. To index and efficiently query numeric values use NumericField and NumericRangeQuery. This class is included for use with existing indices and will be removed in a future release (possibly Lucene 4.0).")]
public ref class NumberTools
[ObsoleteAttribute(L"For new indexes use NumericUtils instead, which provides a sortable binary representation (prefix encoded) of numeric values. To index and efficiently query numeric values use NumericField and NumericRangeQuery. This class is included for use with existing indices and will be removed in a future release (possibly Lucene 4.0).")]
public ref class NumberTools
See Also
NumberTools Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumberTools Members

NumberTools Members Lucene.Net Class Library

The NumberTools type exposes the following members.
Constructors
 | Name | Description
Public method | NumberTools | Initializes a new instance of the NumberTools class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | LongToString | Converts a long to a String suitable for indexing.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | StringToLong | Converts a String that was returned by LongToString(Int64) back to a long.
 | ToLong |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
 | ToString(Int64) |
Back to Top
Fields
Name | Description
MAX_STRING_VALUE | Equivalent to longToString(Long.MAX_VALUE)
MIN_STRING_VALUE | Equivalent to longToString(Long.MIN_VALUE)
STR_SIZE | The length of (all) strings returned by LongToString(Int64)
Back to Top
See Also
NumberTools Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumberTools Constructor

NumberTools Constructor Lucene.Net Class Library
Initializes a new instance of the NumberTools class

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumberTools()
public NumberTools()
Public Sub New
Public Sub New
public:
NumberTools()
public:
NumberTools()
See Also
NumberTools Class
NumberTools Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumberTools Fields

NumberTools Fields Lucene.Net Class Library
The NumberTools type exposes the following members.
Fields
Name | Description
MAX_STRING_VALUE | Equivalent to longToString(Long.MAX_VALUE)
MIN_STRING_VALUE | Equivalent to longToString(Long.MIN_VALUE)
STR_SIZE | The length of (all) strings returned by LongToString(Int64)
Back to Top
See Also
NumberTools Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MAX_STRING_VALUE Field

NumberTools MAX_STRING_VALUE Field Lucene.Net Class Library
Equivalent to longToString(Long.MAX_VALUE)

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string MAX_STRING_VALUE
public static readonly string MAX_STRING_VALUE
Public Shared ReadOnly MAX_STRING_VALUE As String
Public Shared ReadOnly MAX_STRING_VALUE As String
public:
static initonly String^ MAX_STRING_VALUE
public:
static initonly String^ MAX_STRING_VALUE
See Also
NumberTools Class
NumberTools Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MIN_STRING_VALUE Field

NumberTools MIN_STRING_VALUE Field Lucene.Net Class Library
Equivalent to longToString(Long.MIN_VALUE)

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string MIN_STRING_VALUE
public static readonly string MIN_STRING_VALUE
Public Shared ReadOnly MIN_STRING_VALUE As String
Public Shared ReadOnly MIN_STRING_VALUE As String
public:
static initonly String^ MIN_STRING_VALUE
public:
static initonly String^ MIN_STRING_VALUE
See Also
NumberTools Class
NumberTools Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


STR_SIZE Field

NumberTools STR_SIZE Field Lucene.Net Class Library
The length of (all) strings returned by LongToString(Int64)

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly int STR_SIZE
public static readonly int STR_SIZE
Public Shared ReadOnly STR_SIZE As Integer
Public Shared ReadOnly STR_SIZE As Integer
public:
static initonly int STR_SIZE
public:
static initonly int STR_SIZE
See Also
NumberTools Class
NumberTools Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumberTools Methods

NumberTools Methods Lucene.Net Class Library
The NumberTools type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | LongToString | Converts a long to a String suitable for indexing.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | StringToLong | Converts a String that was returned by LongToString(Int64) back to a long.
 | ToLong |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
 | ToString(Int64) |
Back to Top
See Also
NumberTools Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LongToString Method

NumberTools LongToString Method Lucene.Net Class Library
Converts a long to a String suitable for indexing.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string LongToString(
    long l
)
public static string LongToString(
    long l
)
Public Shared Function LongToString ( _
    l As Long _
) As String
Public Shared Function LongToString ( _
    l As Long _
) As String
public:
static String^ LongToString(
    long long l
)
public:
static String^ LongToString(
    long long l
)
Parameters
l
Type:   Online System Int64
See Also
NumberTools Class
NumberTools Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringToLong Method

NumberTools StringToLong Method Lucene.Net Class Library
Converts a String that was returned by LongToString(Int64) back to a long.
if the input is null
if the input does not parse (it was not a String returned by longToString()).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long StringToLong(
    string str
)
public static long StringToLong(
    string str
)
Public Shared Function StringToLong ( _
    str As String _
) As Long
Public Shared Function StringToLong ( _
    str As String _
) As Long
public:
static long long StringToLong(
    String^ str
)
public:
static long long StringToLong(
    String^ str
)
Parameters
str
Type:   Online System String
See Also
NumberTools Class
NumberTools Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToLong Method

NumberTools ToLong Method Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long ToLong(
    string t
)
public static long ToLong(
    string t
)
Public Shared Function ToLong ( _
    t As String _
) As Long
Public Shared Function ToLong ( _
    t As String _
) As Long
public:
static long long ToLong(
    String^ t
)
public:
static long long ToLong(
    String^ t
)
Parameters
t
Type:   Online System String
See Also
NumberTools Class
NumberTools Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

NumberTools ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
 | ToString(Int64) |
Back to Top
See Also
NumberTools Class
NumberTools Members
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (Int64)

NumberTools ToString Method (Int64) Lucene.Net Class Library

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToString(
    long lval
)
public static string ToString(
    long lval
)
Public Shared Function ToString ( _
    lval As Long _
) As String
Public Shared Function ToString ( _
    lval As Long _
) As String
public:
static String^ ToString(
    long long lval
)
public:
static String^ ToString(
    long long lval
)
Parameters
lval
Type:   Online System Int64
See Also
NumberTools Class
NumberTools Members
ToString Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericField Class

NumericField Class Lucene.Net Class Library

This class provides a Field that enables indexing of numeric values for efficient range filtering and sorting. Here's an example usage, adding an int value:
View Colorized Copy to Clipboard Print
document.add(new NumericField(name).setIntValue(value));
document.add(new NumericField(name).setIntValue(value));
For optimal performance, re-use the NumericField and Document instance for more than one document:
View Colorized Copy to Clipboard Print
NumericField field = new NumericField(name);
Document document = new Document();
document.add(field);

for(all documents) {
...
field.setIntValue(value)
writer.addDocument(document);
...
}
NumericField field = new NumericField(name);
Document document = new Document();
document.add(field);

for(all documents) {
...
field.setIntValue(value)
writer.addDocument(document);
...
}

The .Net native types int, long, float and double are directly supported. However, any value that can be converted into these native types can also be indexed. For example, date/time values represented by a Online DateTime can be translated into a long value using the java.util.Date.getTime method. If you don't need millisecond precision, you can quantize the value, either by dividing the result of java.util.Date.getTime or using the separate getters (for year, month, etc.) to construct an int or long value.

To perform range querying or filtering against a NumericField, use NumericRangeQuery T or NumericRangeFilter T . To sort according to a NumericField, use the normal numeric sort types, eg INT NumericField values can also be loaded directly from FieldCache.

By default, a NumericField's value is not stored but is indexed for range filtering and sorting. You can use the NumericField(String, Field Store, Boolean) constructor if you need to change these defaults.

You may add the same field name as a NumericField to the same document more than once. Range querying and filtering will be the logical OR of all values; so a range query will hit all documents that have at least one value in the range. However sort behavior is not defined. If you need to sort, you should separately index a single-valued NumericField.

A NumericField will consume somewhat more disk space in the index than an ordinary single-valued field. However, for a typical index that includes substantial textual content per document, this increase will likely be in the noise.

Within Lucene, each numeric value is indexed as a trie structure, where each term is logically assigned to larger and larger pre-defined brackets (which are simply lower-precision representations of the value). The step size between each successive bracket is called the precisionStep, measured in bits. Smaller precisionStep values result in larger number of brackets, which consumes more disk space in the index but may result in faster range search performance. The default value, 4, was selected for a reasonable tradeoff of disk space consumption versus performance. You can use the expert constructor NumericField(String, Int32, Field Store, Boolean) if you'd like to change the value. Note that you must also specify a congruent value when creating NumericRangeQuery T or NumericRangeFilter T . For low cardinality fields larger precision steps are good. If the cardinality is < 100, it is fair to use Online MaxValue, which produces one term per value.

For more information on the internals of numeric trie indexing, including the precisionStep configuration, see NumericRangeQuery T . The format of indexed values is described in NumericUtils.

If you only need to sort by numeric value, and never run range querying/filtering, you can index using a precisionStep of Online MaxValue. This will minimize disk space consumed.

More advanced users can instead use NumericTokenStream directly, when indexing numbers. This class is a wrapper around this token stream type for easier, more intuitive usage.

NOTE: This class is only used during indexing. When retrieving the stored field value from a Document instance after search, you will get a conventional IFieldable instance where the numeric values are returned as Online Strings (according to toString(value) of the used data type).

NOTE: This API is experimental and might change in incompatible ways in the next release.
Inheritance Hierarchy
Online System Object
Lucene.Net.Documents AbstractField
Lucene.Net.Documents NumericField

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class NumericField : AbstractField
[SerializableAttribute]
public sealed class NumericField : AbstractField
<SerializableAttribute> _
Public NotInheritable Class NumericField _
    Inherits AbstractField
<SerializableAttribute> _
Public NotInheritable Class NumericField _
    Inherits AbstractField
[SerializableAttribute]
public ref class NumericField sealed : public AbstractField
[SerializableAttribute]
public ref class NumericField sealed : public AbstractField
See Also
NumericField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericField Members

NumericField Members Lucene.Net Class Library

The NumericField type exposes the following members.
Constructors
 | Name | Description
Public method | NumericField(String) | Creates a field for numeric values using the default precisionStep PRECISION_STEP_DEFAULT (4). The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods. This constructor creates an indexed, but not stored field.
Public method | NumericField(String, Int32) | Creates a field for numeric values with the specified precisionStep. The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods. This constructor creates an indexed, but not stored field.
Public method | NumericField(String, Field Store, Boolean) | Creates a field for numeric values using the default precisionStep PRECISION_STEP_DEFAULT (4). The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods.
Public method | NumericField(String, Int32, Field Store, Boolean) | Creates a field for numeric values with the specified precisionStep. The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBinaryValue | Return the raw byte[] for the binary field. Note that you must also call BinaryLength and BinaryOffset to know which range of bytes in this returned array belong to the field. (Inherited from AbstractField.)
Public method | GetBinaryValue( Byte ) | Returns always null for numeric fields (Overrides AbstractField GetBinaryValue( Byte ).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetDoubleValue | Initializes the field with the supplied double value.
Public method | SetFloatValue | Initializes the field with the supplied float value.
Public method | SetIntValue | Initializes the field with the supplied int value.
Public method | SetLongValue | Initializes the field with the supplied long value.
Protected method | SetStoreTermVector | (Inherited from AbstractField.)
Public method | ToString | Prints a Field for human consumption. (Inherited from AbstractField.)
Back to Top
Fields
 | Name | Description
Protected field | fieldsData | (Inherited from AbstractField.)
Protected field | internalBinaryLength | (Inherited from AbstractField.)
Protected field | internalbinaryOffset | (Inherited from AbstractField.)
Protected field | internalBoost | (Inherited from AbstractField.)
Protected field | internalIsBinary | (Inherited from AbstractField.)
Protected field | internalIsIndexed | (Inherited from AbstractField.)
Protected field | internalIsStored | (Inherited from AbstractField.)
Protected field | internalIsTokenized | (Inherited from AbstractField.)
Protected field | internalName | (Inherited from AbstractField.)
Protected field | internalOmitNorms | (Inherited from AbstractField.)
Protected field | internalOmitTermFreqAndPositions | (Inherited from AbstractField.)
Protected field | lazy | (Inherited from AbstractField.)
Protected field | storeOffsetWithTermVector | (Inherited from AbstractField.)
Protected field | storePositionWithTermVector | (Inherited from AbstractField.)
Protected field | storeTermVector | (Inherited from AbstractField.)
Protected field | tokenStream | (Inherited from AbstractField.)
Back to Top
Properties
 | Name | Description
Public property | BinaryLength | Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined (Inherited from AbstractField.)
Public property | BinaryOffset | Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined (Inherited from AbstractField.)
Public property | Boost | Gets or sets the boost factor for hits for this field. The default value is 1.0. Note: this value is not stored directly with the document in the index. Documents returned from Document(Int32) and Doc(Int32) may thus not have the same value present as when this field was indexed. (Inherited from AbstractField.)
Public property | IsBinary | True iff the value of the filed is stored as binary (Inherited from AbstractField.)
Public property | IsIndexed | True iff the value of the field is to be indexed, so that it may be searched on. (Inherited from AbstractField.)
Public property | IsLazy | (Inherited from AbstractField.)
Public property | IsStored | True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued. (Inherited from AbstractField.)
Public property | IsStoreOffsetWithTermVector | True iff terms are stored as term vector together with their offsets (start and end position in source text). (Inherited from AbstractField.)
Public property | IsStorePositionWithTermVector | True iff terms are stored as term vector together with their token positions. (Inherited from AbstractField.)
Public property | IsTermVectorStored | True iff the term or terms used to index this field are stored as a term vector, available from GetTermFreqVector(Int32, String). These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the stored attribute instead. (Inherited from AbstractField.)
Public property | IsTokenized | True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued. (Inherited from AbstractField.)
Public property | Name | Returns the name of the field as an interned string. For example "date", "title", "body", ... (Inherited from AbstractField.)
Public property | NumericValue | Returns the current numeric value as a subclass of Number, null if not yet initialized.
Public property | OmitNorms | True if norms are omitted for this indexed field (Inherited from AbstractField.)
Public property | OmitTermFreqAndPositions | Expert: If set, omit term freq, positions and payloads from postings for this field. NOTE: While this option reduces storage space required in the index, it also means any query requiring positional information, such as PhraseQuery or SpanQuery subclasses will silently fail to find results. (Inherited from AbstractField.)
Public property | ReaderValue | Returns always null for numeric fields (Overrides AbstractField ReaderValue.)
Public property | StringValue | Returns the numeric value as a string (how it is stored, when YES is chosen). (Overrides AbstractField StringValue.)
Public property | TokenStreamValue | Returns a NumericTokenStream for indexing the numeric value. (Overrides AbstractField TokenStreamValue.)
Back to Top
See Also
NumericField Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericField Constructor

NumericField Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | NumericField(String) | Creates a field for numeric values using the default precisionStep PRECISION_STEP_DEFAULT (4). The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods. This constructor creates an indexed, but not stored field.
Public method | NumericField(String, Int32) | Creates a field for numeric values with the specified precisionStep. The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods. This constructor creates an indexed, but not stored field.
Public method | NumericField(String, Field Store, Boolean) | Creates a field for numeric values using the default precisionStep PRECISION_STEP_DEFAULT (4). The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods.
Public method | NumericField(String, Int32, Field Store, Boolean) | Creates a field for numeric values with the specified precisionStep. The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods.
Back to Top
See Also
NumericField Class
NumericField Members
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericField Constructor (String)

NumericField Constructor (String) Lucene.Net Class Library
Creates a field for numeric values using the default precisionStep PRECISION_STEP_DEFAULT (4). The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods. This constructor creates an indexed, but not stored field.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumericField(
    string name
)
public NumericField(
    string name
)
Public Sub New ( _
    name As String _
)
Public Sub New ( _
    name As String _
)
public:
NumericField(
    String^ name
)
public:
NumericField(
    String^ name
)
Parameters
name
Type:   Online System String
the field name

See Also
NumericField Class
NumericField Members
NumericField Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericField Constructor (String, Int32)

NumericField Constructor (String, Int32) Lucene.Net Class Library
Creates a field for numeric values with the specified precisionStep. The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods. This constructor creates an indexed, but not stored field.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumericField(
    string name,
    int precisionStep
)
public NumericField(
    string name,
    int precisionStep
)
Public Sub New ( _
    name As String, _
    precisionStep As Integer _
)
Public Sub New ( _
    name As String, _
    precisionStep As Integer _
)
public:
NumericField(
    String^ name,
    int precisionStep
)
public:
NumericField(
    String^ name,
    int precisionStep
)
Parameters
name
Type:   Online System String
the field name

precisionStep
Type:   Online System Int32
the used precision step
See Also
NumericField Class
NumericField Members
NumericField Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericField Constructor (String, Field.Store, Boolean)

NumericField Constructor (String, Field Store, Boolean) Lucene.Net Class Library
Creates a field for numeric values using the default precisionStep PRECISION_STEP_DEFAULT (4). The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumericField(
    string name,
    Field..::..Store store,
    bool index
)
public NumericField(
    string name,
    Field..::..Store store,
    bool index
)
Public Sub New ( _
    name As String, _
    store As Field..::..Store, _
    index As Boolean _
)
Public Sub New ( _
    name As String, _
    store As Field..::..Store, _
    index As Boolean _
)
public:
NumericField(
    String^ name,
    Field..::..Store store,
    bool index
)
public:
NumericField(
    String^ name,
    Field..::..Store store,
    bool index
)
Parameters
name
Type:   Online System String
the field name

store
Type: Lucene.Net.Documents Field Store
if the field should be stored in plain text form
            (according to toString(value) of the used data type)

index
Type:   Online System Boolean
if the field should be indexed using NumericTokenStream
See Also
NumericField Class
NumericField Members
NumericField Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericField Constructor (String, Int32, Field.Store, Boolean)

NumericField Constructor (String, Int32, Field Store, Boolean) Lucene.Net Class Library
Creates a field for numeric values with the specified precisionStep. The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumericField(
    string name,
    int precisionStep,
    Field..::..Store store,
    bool index
)
public NumericField(
    string name,
    int precisionStep,
    Field..::..Store store,
    bool index
)
Public Sub New ( _
    name As String, _
    precisionStep As Integer, _
    store As Field..::..Store, _
    index As Boolean _
)
Public Sub New ( _
    name As String, _
    precisionStep As Integer, _
    store As Field..::..Store, _
    index As Boolean _
)
public:
NumericField(
    String^ name,
    int precisionStep,
    Field..::..Store store,
    bool index
)
public:
NumericField(
    String^ name,
    int precisionStep,
    Field..::..Store store,
    bool index
)
Parameters
name
Type:   Online System String
the field name

precisionStep
Type:   Online System Int32
the used precision step
store
Type: Lucene.Net.Documents Field Store
if the field should be stored in plain text form
            (according to toString(value) of the used data type)

index
Type:   Online System Boolean
if the field should be indexed using NumericTokenStream
See Also
NumericField Class
NumericField Members
NumericField Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericField Fields

NumericField Fields Lucene.Net Class Library
The NumericField type exposes the following members.
Fields
 | Name | Description
Protected field | fieldsData | (Inherited from AbstractField.)
Protected field | internalBinaryLength | (Inherited from AbstractField.)
Protected field | internalbinaryOffset | (Inherited from AbstractField.)
Protected field | internalBoost | (Inherited from AbstractField.)
Protected field | internalIsBinary | (Inherited from AbstractField.)
Protected field | internalIsIndexed | (Inherited from AbstractField.)
Protected field | internalIsStored | (Inherited from AbstractField.)
Protected field | internalIsTokenized | (Inherited from AbstractField.)
Protected field | internalName | (Inherited from AbstractField.)
Protected field | internalOmitNorms | (Inherited from AbstractField.)
Protected field | internalOmitTermFreqAndPositions | (Inherited from AbstractField.)
Protected field | lazy | (Inherited from AbstractField.)
Protected field | storeOffsetWithTermVector | (Inherited from AbstractField.)
Protected field | storePositionWithTermVector | (Inherited from AbstractField.)
Protected field | storeTermVector | (Inherited from AbstractField.)
Protected field | tokenStream | (Inherited from AbstractField.)
Back to Top
See Also
NumericField Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericField Methods

NumericField Methods Lucene.Net Class Library
The NumericField type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBinaryValue | Return the raw byte[] for the binary field. Note that you must also call BinaryLength and BinaryOffset to know which range of bytes in this returned array belong to the field. (Inherited from AbstractField.)
Public method | GetBinaryValue( Byte ) | Returns always null for numeric fields (Overrides AbstractField GetBinaryValue( Byte ).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetDoubleValue | Initializes the field with the supplied double value.
Public method | SetFloatValue | Initializes the field with the supplied float value.
Public method | SetIntValue | Initializes the field with the supplied int value.
Public method | SetLongValue | Initializes the field with the supplied long value.
Protected method | SetStoreTermVector | (Inherited from AbstractField.)
Public method | ToString | Prints a Field for human consumption. (Inherited from AbstractField.)
Back to Top
See Also
NumericField Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBinaryValue Method

NumericField GetBinaryValue Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetBinaryValue | Return the raw byte[] for the binary field. Note that you must also call BinaryLength and BinaryOffset to know which range of bytes in this returned array belong to the field. (Inherited from AbstractField.)
Public method | GetBinaryValue( Byte ) | Returns always null for numeric fields (Overrides AbstractField GetBinaryValue( Byte ).)
Back to Top
See Also
NumericField Class
NumericField Members
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBinaryValue Method (Byte[])

NumericField GetBinaryValue Method ( Byte ) Lucene.Net Class Library
Returns always null for numeric fields

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override byte[] GetBinaryValue(
    byte[] result
)
public override byte[] GetBinaryValue(
    byte[] result
)
Public Overrides Function GetBinaryValue ( _
    result As Byte() _
) As Byte()
Public Overrides Function GetBinaryValue ( _
    result As Byte() _
) As Byte()
public:
virtual array<unsigned char>^ GetBinaryValue(
    array<unsigned char>^ result
) override
public:
virtual array<unsigned char>^ GetBinaryValue(
    array<unsigned char>^ result
) override
Parameters
result
Type:    Online System Byte
Implements
IFieldable GetBinaryValue( Byte )
See Also
NumericField Class
NumericField Members
GetBinaryValue Overload
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetDoubleValue Method

NumericField SetDoubleValue Method Lucene.Net Class Library
Initializes the field with the supplied double value.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumericField SetDoubleValue(
    double value_Renamed
)
public NumericField SetDoubleValue(
    double value_Renamed
)
Public Function SetDoubleValue ( _
    value_Renamed As Double _
) As NumericField
Public Function SetDoubleValue ( _
    value_Renamed As Double _
) As NumericField
public:
NumericField^ SetDoubleValue(
    double value_Renamed
)
public:
NumericField^ SetDoubleValue(
    double value_Renamed
)
Parameters
value_Renamed
Type:   Online System Double
the numeric value

Return Value
 this instance, because of this you can use it the following way:
            document.add(new NumericField(name, precisionStep).setDoubleValue(value))
See Also
NumericField Class
NumericField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetFloatValue Method

NumericField SetFloatValue Method Lucene.Net Class Library
Initializes the field with the supplied float value.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumericField SetFloatValue(
    float value_Renamed
)
public NumericField SetFloatValue(
    float value_Renamed
)
Public Function SetFloatValue ( _
    value_Renamed As Single _
) As NumericField
Public Function SetFloatValue ( _
    value_Renamed As Single _
) As NumericField
public:
NumericField^ SetFloatValue(
    float value_Renamed
)
public:
NumericField^ SetFloatValue(
    float value_Renamed
)
Parameters
value_Renamed
Type:   Online System Single
the numeric value

Return Value
 this instance, because of this you can use it the following way:
            document.add(new NumericField(name, precisionStep).setFloatValue(value))
See Also
NumericField Class
NumericField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetIntValue Method

NumericField SetIntValue Method Lucene.Net Class Library
Initializes the field with the supplied int value.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumericField SetIntValue(
    int value_Renamed
)
public NumericField SetIntValue(
    int value_Renamed
)
Public Function SetIntValue ( _
    value_Renamed As Integer _
) As NumericField
Public Function SetIntValue ( _
    value_Renamed As Integer _
) As NumericField
public:
NumericField^ SetIntValue(
    int value_Renamed
)
public:
NumericField^ SetIntValue(
    int value_Renamed
)
Parameters
value_Renamed
Type:   Online System Int32
the numeric value

Return Value
 this instance, because of this you can use it the following way:
            document.add(new NumericField(name, precisionStep).setIntValue(value))
See Also
NumericField Class
NumericField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetLongValue Method

NumericField SetLongValue Method Lucene.Net Class Library
Initializes the field with the supplied long value.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NumericField SetLongValue(
    long value_Renamed
)
public NumericField SetLongValue(
    long value_Renamed
)
Public Function SetLongValue ( _
    value_Renamed As Long _
) As NumericField
Public Function SetLongValue ( _
    value_Renamed As Long _
) As NumericField
public:
NumericField^ SetLongValue(
    long long value_Renamed
)
public:
NumericField^ SetLongValue(
    long long value_Renamed
)
Parameters
value_Renamed
Type:   Online System Int64
the numeric value

Return Value
 this instance, because of this you can use it the following way:
            document.add(new NumericField(name, precisionStep).SetLongValue(value))
See Also
NumericField Class
NumericField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericField Properties

NumericField Properties Lucene.Net Class Library
The NumericField type exposes the following members.
Properties
 | Name | Description
Public property | BinaryLength | Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined (Inherited from AbstractField.)
Public property | BinaryOffset | Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined (Inherited from AbstractField.)
Public property | Boost | Gets or sets the boost factor for hits for this field. The default value is 1.0. Note: this value is not stored directly with the document in the index. Documents returned from Document(Int32) and Doc(Int32) may thus not have the same value present as when this field was indexed. (Inherited from AbstractField.)
Public property | IsBinary | True iff the value of the filed is stored as binary (Inherited from AbstractField.)
Public property | IsIndexed | True iff the value of the field is to be indexed, so that it may be searched on. (Inherited from AbstractField.)
Public property | IsLazy | (Inherited from AbstractField.)
Public property | IsStored | True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued. (Inherited from AbstractField.)
Public property | IsStoreOffsetWithTermVector | True iff terms are stored as term vector together with their offsets (start and end position in source text). (Inherited from AbstractField.)
Public property | IsStorePositionWithTermVector | True iff terms are stored as term vector together with their token positions. (Inherited from AbstractField.)
Public property | IsTermVectorStored | True iff the term or terms used to index this field are stored as a term vector, available from GetTermFreqVector(Int32, String). These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the stored attribute instead. (Inherited from AbstractField.)
Public property | IsTokenized | True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued. (Inherited from AbstractField.)
Public property | Name | Returns the name of the field as an interned string. For example "date", "title", "body", ... (Inherited from AbstractField.)
Public property | NumericValue | Returns the current numeric value as a subclass of Number, null if not yet initialized.
Public property | OmitNorms | True if norms are omitted for this indexed field (Inherited from AbstractField.)
Public property | OmitTermFreqAndPositions | Expert: If set, omit term freq, positions and payloads from postings for this field. NOTE: While this option reduces storage space required in the index, it also means any query requiring positional information, such as PhraseQuery or SpanQuery subclasses will silently fail to find results. (Inherited from AbstractField.)
Public property | ReaderValue | Returns always null for numeric fields (Overrides AbstractField ReaderValue.)
Public property | StringValue | Returns the numeric value as a string (how it is stored, when YES is chosen). (Overrides AbstractField StringValue.)
Public property | TokenStreamValue | Returns a NumericTokenStream for indexing the numeric value. (Overrides AbstractField TokenStreamValue.)
Back to Top
See Also
NumericField Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericValue Property

NumericField NumericValue Property Lucene.Net Class Library
Returns the current numeric value as a subclass of Number, null if not yet initialized.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ValueType NumericValue { get; }
public ValueType NumericValue { get; }
Public ReadOnly Property NumericValue As ValueType
    Get
Public ReadOnly Property NumericValue As ValueType
    Get
public:
property ValueType^ NumericValue {
    ValueType^ get ();
}
public:
property ValueType^ NumericValue {
    ValueType^ get ();
}
See Also
NumericField Class
NumericField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReaderValue Property

NumericField ReaderValue Property Lucene.Net Class Library
Returns always null for numeric fields

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TextReader ReaderValue { get; }
public override TextReader ReaderValue { get; }
Public Overrides ReadOnly Property ReaderValue As TextReader
    Get
Public Overrides ReadOnly Property ReaderValue As TextReader
    Get
public:
virtual property TextReader^ ReaderValue {
    TextReader^ get () override;
}
public:
virtual property TextReader^ ReaderValue {
    TextReader^ get () override;
}
Implements
IFieldable ReaderValue
See Also
NumericField Class
NumericField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringValue Property

NumericField StringValue Property Lucene.Net Class Library
Returns the numeric value as a string (how it is stored, when YES is chosen).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string StringValue { get; }
public override string StringValue { get; }
Public Overrides ReadOnly Property StringValue As String
    Get
Public Overrides ReadOnly Property StringValue As String
    Get
public:
virtual property String^ StringValue {
    String^ get () override;
}
public:
virtual property String^ StringValue {
    String^ get () override;
}
Implements
IFieldable StringValue
See Also
NumericField Class
NumericField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenStreamValue Property

NumericField TokenStreamValue Property Lucene.Net Class Library
Returns a NumericTokenStream for indexing the numeric value.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TokenStream TokenStreamValue { get; }
public override TokenStream TokenStreamValue { get; }
Public Overrides ReadOnly Property TokenStreamValue As TokenStream
    Get
Public Overrides ReadOnly Property TokenStreamValue As TokenStream
    Get
public:
virtual property TokenStream^ TokenStreamValue {
    TokenStream^ get () override;
}
public:
virtual property TokenStream^ TokenStreamValue {
    TokenStream^ get () override;
}
Implements
IFieldable TokenStreamValue
See Also
NumericField Class
NumericField Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetBasedFieldSelector Class

SetBasedFieldSelector Class Lucene.Net Class Library
Declare what fields to load normally and what fields to load lazily
Inheritance Hierarchy
Online System Object
Lucene.Net.Documents SetBasedFieldSelector

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SetBasedFieldSelector : FieldSelector
[SerializableAttribute]
public class SetBasedFieldSelector : FieldSelector
<SerializableAttribute> _
Public Class SetBasedFieldSelector _
    Implements FieldSelector
<SerializableAttribute> _
Public Class SetBasedFieldSelector _
    Implements FieldSelector
[SerializableAttribute]
public ref class SetBasedFieldSelector : FieldSelector
[SerializableAttribute]
public ref class SetBasedFieldSelector : FieldSelector
See Also
SetBasedFieldSelector Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetBasedFieldSelector Members

SetBasedFieldSelector Members Lucene.Net Class Library

The SetBasedFieldSelector type exposes the following members.
Constructors
 | Name | Description
Public method | SetBasedFieldSelector | Pass in the Set of Field names to load and the Set of Field names to load lazily. If both are null, the Document will not have any Field on it.
Back to Top
Methods
 | Name | Description
Public method | Accept | Indicate whether to load the field with the given name or not. If the Name is not in either of the initializing Sets, then NO_LOAD is returned. If a Field name is in both fieldsToLoad and lazyFieldsToLoad, lazy has precedence.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SetBasedFieldSelector Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetBasedFieldSelector Constructor

SetBasedFieldSelector Constructor Lucene.Net Class Library
Pass in the Set of Field names to load and the Set of Field names to load lazily. If both are null, the Document will not have any Field on it.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SetBasedFieldSelector(
    ISet<string> fieldsToLoad,
    ISet<string> lazyFieldsToLoad
)
public SetBasedFieldSelector(
    ISet<string> fieldsToLoad,
    ISet<string> lazyFieldsToLoad
)
Public Sub New ( _
    fieldsToLoad As ISet(Of String), _
    lazyFieldsToLoad As ISet(Of String) _
)
Public Sub New ( _
    fieldsToLoad As ISet(Of String), _
    lazyFieldsToLoad As ISet(Of String) _
)
public:
SetBasedFieldSelector(
    ISet<String^>^ fieldsToLoad,
    ISet<String^>^ lazyFieldsToLoad
)
public:
SetBasedFieldSelector(
    ISet<String^>^ fieldsToLoad,
    ISet<String^>^ lazyFieldsToLoad
)
Parameters
fieldsToLoad
Type:   Online System.Collections.Generic ISet    Online String
A Set of   Online String field names to load.  May be empty, but not null

lazyFieldsToLoad
Type:   Online System.Collections.Generic ISet    Online String
A Set of   Online String field names to load lazily.  May be empty, but not null

See Also
SetBasedFieldSelector Class
SetBasedFieldSelector Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetBasedFieldSelector Methods

SetBasedFieldSelector Methods Lucene.Net Class Library
The SetBasedFieldSelector type exposes the following members.
Methods
 | Name | Description
Public method | Accept | Indicate whether to load the field with the given name or not. If the Name is not in either of the initializing Sets, then NO_LOAD is returned. If a Field name is in both fieldsToLoad and lazyFieldsToLoad, lazy has precedence.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SetBasedFieldSelector Class
Lucene.Net.Documents Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Accept Method

SetBasedFieldSelector Accept Method Lucene.Net Class Library
Indicate whether to load the field with the given name or not. If the Name is not in either of the initializing Sets, then NO_LOAD is returned. If a Field name is in both fieldsToLoad and lazyFieldsToLoad, lazy has precedence.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual FieldSelectorResult Accept(
    string fieldName
)
public virtual FieldSelectorResult Accept(
    string fieldName
)
Public Overridable Function Accept ( _
    fieldName As String _
) As FieldSelectorResult
Public Overridable Function Accept ( _
    fieldName As String _
) As FieldSelectorResult
public:
virtual FieldSelectorResult Accept(
    String^ fieldName
)
public:
virtual FieldSelectorResult Accept(
    String^ fieldName
)
Parameters
fieldName
Type:   Online System String
The Field name to check

Return Value
 The FieldSelectorResult
Implements
FieldSelector Accept(String)
See Also
SetBasedFieldSelector Class
SetBasedFieldSelector Members
Lucene.Net.Documents Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lucene.Net.Index Namespace

Lucene.Net.Index Namespace Lucene.Net Class Library
Classes
Class | Description
Public class AbstractAllTermDocs
Base class for enumerating all but deleted docs.

NOTE: this class is meant only to be used internally by Lucene; it's only public so it can be shared across packages. This means the API is freely subject to change, and, the class could be removed entirely, in any Lucene release. Use directly at your own risk! */
Public class | ByteBlockPool
Public class | ByteBlockPool Allocator
Public class | ByteSliceReader
Public class ByteSliceWriter
Class to write byte streams into slices of shared byte[]. This is used by DocumentsWriter to hold the posting list for many terms in RAM.
Public class CheckIndex
Basic tool and API to check the health of an index and write a new segments file that removes reference to problematic segments.

As this tool checks every byte in the index, on a large index it can take quite a long time to run.

WARNING: this tool and API is new and experimental and is subject to suddenly change in the next release. Please make a complete backup of your index before using this to fix your index!
Public class CheckIndex Status
Returned from CheckIndex_Renamed_Method detailing the health and status of the index.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.
Public class CheckIndex Status FieldNormStatus
Status from testing field norms.
Public class CheckIndex Status SegmentInfoStatus
Holds the status of each segment in the index. See SegmentInfos.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.
Public class CheckIndex Status StoredFieldStatus
Status from testing stored fields.
Public class CheckIndex Status TermIndexStatus
Status from testing term index.
Public class CheckIndex Status TermVectorStatus
Status from testing stored fields.
Public class CompoundFileReader
Class for accessing a compound stream. This class implements a directory, but is limited to only read operations. Directory methods that would normally modify data throw an exception.
Public class CompoundFileReader CSIndexInput
Implementation of an IndexInput that reads from a portion of the compound file. The visibility is left as "package" *only* because this helps with testing since JUnit test cases in a different class can then access package fields of this class.
Public class CompoundFileWriter
Combines multiple files into a single compound file. The file format:
  • VInt fileCount
  • {Directory} fileCount entries with the following structure:
  • {File Data} fileCount entries with the raw data of the corresponding file
The fileCount integer indicates how many files are contained in this compound file. The {directory} that follows has that many entries. Each directory entry contains a long pointer to the start of this file's data section, and a String with that file's name.
Public class ConcurrentMergeScheduler
A MergeScheduler that runs each merge using a separate thread, up until a maximum number of threads (MaxThreadCount) at which when a merge is needed, the thread(s) that are updating the index will pause until one or more merges completes. This is a simple way to use concurrency in the indexing process without having to create and manage application level threads.
Public class | ConcurrentMergeScheduler MergeThread
Public class CorruptIndexException
This exception is thrown when Lucene detects an inconsistency in the index.
Public class DirectoryReader
An IndexReader which reads indexes with multiple segments.
Public class DocumentsWriter
This class accepts multiple added documents and directly writes a single segment file. It does this more efficiently than creating a single segment per document (with DocumentWriter) and doing standard merges on those segments. Each added document is passed to the DocConsumer, which in turn processes the document and interacts with other consumers in the indexing chain. Certain consumers, like StoredFieldsWriter and TermVectorsTermsWriter , digest a document and immediately write bytes to the "doc store" files (ie, they do not consume RAM per document, except while they are processing the document). Other consumers, eg FreqProxTermsWriter and NormsWriter, buffer bytes in RAM and flush only when a new segment is produced. Once we have used our allowed RAM buffer, or the number of added docs is large enough (in the case we are flushing by doc count instead of RAM usage), we create a real segment and flush it to the Directory. Threads: Multiple threads are allowed into addDocument at once. There is an initial synchronized call to getThreadState which allocates a ThreadState for this thread. The same thread will get the same ThreadState over time (thread affinity) so that if there are consistent patterns (for example each thread is indexing a different content source) then we make better use of RAM. Then processDocument is called on that ThreadState without synchronization (most of the "heavy lifting" is in this call). Finally the synchronized "finishDocument" is called to flush changes to the directory. When flush is called by IndexWriter we forcefully idle all threads and flush only once they are all idle. This means you can call flush with a given thread even while other threads are actively adding/deleting documents. Exceptions: Because this class directly updates in-memory posting lists, and flushes stored fields and term vectors directly to files in the directory, there are certain limited times when an exception can corrupt this state. For example, a disk full while flushing stored fields leaves this file in a corrupt state. Or, an OOM exception while appending to the in-memory posting lists can corrupt that posting list. We call such exceptions "aborting exceptions". In these cases we must call abort() to discard all docs added since the last flush. All other exceptions ("non-aborting exceptions") can still partially update the index structures. These updates are consistent, but, they represent only a part of the document seen up until the exception was hit. When this happens, we immediately mark the document as deleted so that the document is always atomically ("all or none") added to the index.
Public class | FieldInfo
Public class FieldInfos
Access to the Fieldable Info file that describes document fields and whether or not they are indexed. Each segment has a separate Fieldable Info file. Objects of this class are thread-safe for multiple readers, but only one thread can be adding documents at a time, with no other reader or writer threads accessing this object.
Public class FieldInvertState
This class tracks the number and position / offset parameters of terms being added to the index. The information collected in this class is also used to calculate the normalization factor for a field.

WARNING: This API is new and experimental, and may suddenly change.

Public class FieldReaderException
Public class FieldSortedTermVectorMapper
For each Field, store a sorted collection of TermVectorEntrys

This is not thread-safe.
Public class FieldsReader
Class responsible for access to stored document fields.

It uses <segment>.fdt and <segment>.fdx; files.
Public class FilterIndexReader
A FilterIndexReader contains another IndexReader, which it uses as its basic source of data, possibly transforming the data along the way or providing additional functionality. The class FilterIndexReader itself simply implements all abstract methods of IndexReader with versions that pass all requests to the contained index reader. Subclasses of FilterIndexReader may further override some of these methods and may also provide additional methods and fields.
Public class FilterIndexReader FilterTermDocs
Base class for filtering TermDocs implementations.
Public class FilterIndexReader FilterTermEnum
Base class for filtering TermEnum implementations.
Public class FilterIndexReader FilterTermPositions
Base class for filtering TermPositions implementations.
Public class IndexCommit

Expert: represents a single commit into an index as seen by the IndexDeletionPolicy or IndexReader.

Changes to the content of an index are made visible only after the writer who made that change commits by writing a new segments file (segments_N). This point in time, when the action of writing of a new segments file to the directory is completed, is an index commit.

Each index commit point has a unique segments file associated with it. The segments file associated with a later index commit point would have a larger N.

WARNING: This API is a new and experimental and may suddenly change.

Public class IndexFileDeleter

This class keeps track of each SegmentInfos instance that is still "live", either because it corresponds to a segments_N file in the Directory (a "commit", i.e. a committed SegmentInfos) or because it's an in-memory SegmentInfos that a writer is actively updating but has not yet committed. This class uses simple reference counting to map the live SegmentInfos instances to individual files in the Directory.

The same directory file may be referenced by more than one IndexCommit, i.e. more than one SegmentInfos. Therefore we count how many commits reference each file. When all the commits referencing a certain file have been deleted, the refcount for that file becomes zero, and the file is deleted.

A separate deletion policy interface (IndexDeletionPolicy) is consulted on creation (onInit) and once per commit (onCommit), to decide when a commit should be removed.

It is the business of the IndexDeletionPolicy to choose when to delete commit points. The actual mechanics of file deletion, retrying, etc, derived from the deletion of commit points is the business of the IndexFileDeleter.

The current default deletion policy is KeepOnlyLastCommitDeletionPolicy, which removes all prior commits when a new commit has completed. This matches the behavior before 2.2.

Note that you must hold the write.lock before instantiating this class. It opens segments_N file(s) directly with no retry logic.

Public class IndexFileNameFilter
Filename filter that accept filenames and extensions only created by Lucene.
Public class IndexFileNames
Useful constants representing filenames and extensions used by lucene
Public class IndexReader
IndexReader is an abstract class, providing an interface for accessing an index. Search of an index is done entirely through this abstract interface, so that any subclass which implements it is searchable.

Concrete subclasses of IndexReader are usually constructed with a call to one of the static open() methods, e.g. Open(Directory, Boolean) .

For efficiency, in this API documents are often referred to via document numbers, non-negative integers which each name a unique document in the index. These document numbers are ephemeral--they may change as documents are added to and deleted from an index. Clients should thus not rely on a given document having the same number between sessions.

An IndexReader can be opened on a directory for which an IndexWriter is opened already, but it cannot be used to delete documents from the index then.

NOTE: for backwards API compatibility, several methods are not listed as abstract, but have no useful implementations in this base class and instead always throw UnsupportedOperationException. Subclasses are strongly encouraged to override these methods, but in many cases may not need to.

NOTE: as of 2.4, it's possible to open a read-only IndexReader using the static open methods that accepts the boolean readOnly parameter. Such a reader has better better concurrency as it's not necessary to synchronize on the isDeleted method. You must explicitly specify false if you want to make changes with the resulting IndexReader.

NOTE: IndexReader instances are completely thread safe, meaning multiple threads can call any of its methods, concurrently. If your application requires external synchronization, you should not synchronize on the IndexReader instance; use your own (non-Lucene) objects instead.
Public class IndexReader FieldOption
Constants describing field properties, for example used for GetFieldNames(IndexReader FieldOption).
Public class IndexWriter
An IndexWriter creates and maintains an index.

The create argument to the constructor determines whether a new index is created, or whether an existing index is opened. Note that you can open an index with create=true even while readers are using the index. The old readers will continue to search the "point in time" snapshot they had opened, and won't see the newly created index until they re-open. There are also constructors with no create argument which will create a new index if there is not already an index at the provided path and otherwise open the existing index.

In either case, documents are added with AddDocument(Document) and removed with DeleteDocuments(Term) or DeleteDocuments(Query). A document can be updated with UpdateDocument(Term, Document) (which just deletes and then adds the entire document). When finished adding, deleting and updating documents, Close should be called.

These changes are buffered in memory and periodically flushed to the Directory (during the above method calls). A flush is triggered when there are enough buffered deletes (see SetMaxBufferedDeleteTerms(Int32)) or enough added documents since the last flush, whichever is sooner. For the added documents, flushing is triggered either by RAM usage of the documents (see SetRAMBufferSizeMB(Double)) or the number of added documents. The default is to flush when RAM usage hits 16 MB. For best indexing speed you should flush by RAM usage with a large RAM buffer. Note that flushing just moves the internal buffered state in IndexWriter into the index, but these changes are not visible to IndexReader until either Commit or Close is called. A flush may also trigger one or more segment merges which by default run with a background thread so as not to block the addDocument calls (see below for changing the MergeScheduler).

If an index will not have more documents added for a while and optimal search performance is desired, then either the full Optimize method or partial Optimize(Int32) method should be called before the index is closed.

Opening an IndexWriter creates a lock file for the directory in use. Trying to open another IndexWriter on the same directory will lead to a LockObtainFailedException. The LockObtainFailedException is also thrown if an IndexReader on the same directory is used to delete documents from the index.

Public class IndexWriter IndexReaderWarmer
If GetReader has been called (ie, this writer is in near real-time mode), then after a merge completes, this class can be invoked to warm the reader on the newly merged segment, before the merge commits. This is not required for near real-time search, but will reduce search latency on opening a new near real-time reader after a merge completes.

NOTE: This API is experimental and might change in incompatible ways in the next release.

NOTE: warm is called before any deletes have been carried over to the merged segment.
Public class IndexWriter MaxFieldLength
Specifies maximum field length (in number of tokens/terms) in IndexWriter constructors. SetMaxFieldLength(Int32) overrides the value set by the constructor.
Public class KeepOnlyLastCommitDeletionPolicy
This IndexDeletionPolicy implementation that keeps only the most recent commit and immediately removes all prior commits after a new commit is done. This is the default deletion policy.
Public class LogByteSizeMergePolicy
This is a LogMergePolicy that measures size of a segment as the total byte size of the segment's files.
Public class LogDocMergePolicy
This is a LogMergePolicy that measures size of a segment as the number of documents (not taking deletions into account).
Public class LogMergePolicy

This class implements a MergePolicy that tries to merge segments into levels of exponentially increasing size, where each level has fewer segments than the value of the merge factor. Whenever extra segments (beyond the merge factor upper bound) are encountered, all segments within the level are merged. You can get or set the merge factor using MergeFactor and MergeFactor respectively.

This class is abstract and requires a subclass to define the Size(SegmentInfo) method which specifies how a segment's size is determined. LogDocMergePolicy is one subclass that measures size by document count in the segment. LogByteSizeMergePolicy is another subclass that measures size as the total byte size of the file(s) for the segment.

Public class MergePolicy

Expert: a MergePolicy determines the sequence of primitive merge operations to be used for overall merge and optimize operations.

Whenever the segments in an index have been altered by IndexWriter, either the addition of a newly flushed segment, addition of many segments from addIndexes* calls, or a previous merge that may now need to cascade, IndexWriter invokes FindMerges(SegmentInfos) to give the MergePolicy a chance to pick merges that are now required. This method returns a MergePolicy MergeSpecification instance describing the set of merges that should be done, or null if no merges are necessary. When IndexWriter.optimize is called, it calls FindMergesForOptimize(SegmentInfos, Int32, ISet SegmentInfo ) and the MergePolicy should then return the necessary merges.

Note that the policy can return more than one merge at a time. In this case, if the writer is using SerialMergeScheduler , the merges will be run sequentially but if it is using ConcurrentMergeScheduler they will be run concurrently.

The default MergePolicy is LogByteSizeMergePolicy .

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

NOTE: This class typically requires access to package-private APIs (e.g. SegmentInfos) to do its job; if you implement your own MergePolicy, you'll need to put it in package Lucene.Net.Index in order to use these APIs.
Public class | MergePolicy MergeAbortedException
Public class MergePolicy MergeException
Exception thrown if there are any problems while executing a merge.
Public class MergePolicy MergeSpecification
A MergeSpecification instance provides the information necessary to perform multiple merges. It simply contains a list of MergePolicy OneMerge instances.
Public class MergePolicy OneMerge
OneMerge provides the information necessary to perform an individual primitive merge operation, resulting in a single new segment. The merge spec includes the subset of segments to be merged as well as whether the new segment should use the compound file format.
Public class MergeScheduler

Expert: IndexWriter uses an instance implementing this interface to execute the merges selected by a MergePolicy. The default MergeScheduler is ConcurrentMergeScheduler.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

NOTE: This class typically requires access to package-private APIs (eg, SegmentInfos) to do its job; if you implement your own MergePolicy, you'll need to put it in package Lucene.Net.Index in order to use these APIs.
Public class MultipleTermPositions
Allows you to iterate over the TermPositions for multiple Terms as a single TermPositions.
Public class MultiReader
An IndexReader which reads multiple indexes, appending their content.
Public class ParallelReader
An IndexReader which reads multiple, parallel indexes. Each index added must have the same number of documents, but typically each contains different fields. Each document contains the union of the fields of all documents with the same document number. When searching, matches for a query term are from the first index added that has the field.

This is useful, e.g., with collections that have large fields which change rarely and small fields that change more frequently. The smaller fields may be re-indexed in a new index and both indexes may be searched together.

Warning: It is up to you to make sure all indexes are created and modified the same way. For example, if you add documents to one index, you need to add the same documents in the same order to the other indexes. Failure to do so will result in undefined behavior.
Public class Payload
A Payload is metadata that can be stored together with each occurrence of a term. This metadata is stored inline in the posting list of the specific term.

To store payloads in the index a TokenStream has to be used that produces payload data.

Use PayloadLength and GetPayload( Byte , Int32) to retrieve the payloads from the index.
Public class PositionBasedTermVectorMapper
For each Field, store position by position information. It ignores frequency information

This is not thread-safe.
Public class PositionBasedTermVectorMapper TVPositionInfo
Container for a term at a position
Public class | ReadOnlyDirectoryReader
Public class | ReadOnlySegmentReader
Public class SegmentInfo
Information about a segment such as it's name, directory, and files related to the segment. *

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

Public class SegmentInfos
A collection of segmentInfo objects with methods for operating on those segments in relation to the file system.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

Public class SegmentInfos FindSegmentsFile
Utility class for executing code that needs to do something with the current segments file. This is necessary with lock-less commits because from the time you locate the current segments file name, until you actually open it, read its contents, or check modified time, etc., it could have been deleted due to a writer commit finishing.
Public class SegmentMerger
The SegmentMerger class combines two or more Segments, represented by an IndexReader (Add(IndexReader), into a single Segment. After adding the appropriate readers, call the merge method to combine the segments.

If the compoundFile flag is set, then the segments will be merged into a compound file.
Public class SegmentReader

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

Public class | SegmentReader CoreReaders
Public class SegmentReader Norm
Byte[] referencing is used because a new norm object needs to be created for each clone, and the byte array is all that is needed for sharing between cloned readers. The current norm referencing is for sharing between readers whereas the byte[] referencing is for copy on write which is independent of reader references (i.e. incRef, decRef).
Public class | SegmentReader Ref
Public class SerialMergeScheduler
A MergeScheduler that simply does each merge sequentially, using the current thread.
Public class SnapshotDeletionPolicy
A IndexDeletionPolicy that wraps around any other IndexDeletionPolicy and adds the ability to hold and later release a single "snapshot" of an index. While the snapshot is held, the IndexWriter will not remove any files associated with it even if the index is otherwise being actively, arbitrarily changed. Because we wrap another arbitrary IndexDeletionPolicy, this gives you the freedom to continue using whatever IndexDeletionPolicy you would normally want to use with your index. Note that you can re-use a single instance of SnapshotDeletionPolicy across multiple writers as long as they are against the same index Directory. Any snapshot held when a writer is closed will "survive" when the next writer is opened.

WARNING: This API is a new and experimental and may suddenly change.

Public class SortedTermVectorMapper
Store a sorted collection of TermVectorEntrys. Collects all term information into a single, SortedSet.
NOTE: This Mapper ignores all Field information for the Document. This means that if you are using offset/positions you will not know what Fields they correlate with.
This is not thread-safe
Public class StaleReaderException
This exception is thrown when an IndexReader tries to make changes to the index (via DeleteDocument(Int32) , UndeleteAll or SetNorm(Int32, String, Single)) but changes have already been committed to the index since this reader was instantiated. When this happens you must open a new reader on the current index to make the changes.
Public class Term
A Term represents a word from text. This is the unit of search. It is composed of two elements, the text of the word, as a string, and the name of the field that the text occured in, an interned string. Note that terms may represent more than words from text fields, but also things like dates, email addresses, urls, etc.
Public class TermEnum
Abstract class for enumerating terms.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.
Public class TermVectorEntry
Convenience class for holding TermVector information.
Public class TermVectorEntryFreqSortedComparator
Compares TermVectorEntrys first by frequency and then by the term (case-sensitive)
Public class TermVectorMapper
The TermVectorMapper can be used to map Term Vectors into your own structure instead of the parallel array structure used by GetTermFreqVector(Int32, String).

It is up to the implementation to make sure it is thread-safe.
Structures
 | Structure | Description
Public structure | TermVectorOffsetInfo | The TermVectorOffsetInfo class holds information pertaining to a Term in a TermPositionVector's offset information. This offset information is the character offset as set during the Analysis phase (and thus may not be the actual offset in the original content).
Interfaces
Interface Description
Public interface IndexDeletionPolicy

Expert: policy for deletion of stale index commits.

Implement this interface, and pass it to one of the IndexWriter or IndexReader constructors, to customize when older point-in-time commits are deleted from the index directory. The default deletion policy is KeepOnlyLastCommitDeletionPolicy, which always removes old commits as soon as a new commit is done (this matches the behavior before 2.2).

One expected use case for this (and the reason why it was first created) is to work around problems with an index directory accessed via filesystems like NFS because NFS does not provide the "delete on last close" semantics that Lucene's "point in time" search normally relies on. By implementing a custom deletion policy, such as "a commit is only removed once it has been stale for more than X minutes", you can give your readers time to refresh to the new commit before IndexWriter removes the old commits. Note that doing so will increase the storage requirements of the index. See Online LUCENE-710 for details.

Public interface ITermFreqVector
Provides access to stored term vector of a document field. The vector consists of the name of the field, an array of the terms tha occur in the field of the Document and a parallel array of frequencies. Thus, getTermFrequencies()[5] corresponds with the frequency of getTerms()[5], assuming there are at least 5 terms in the Document.
Public interface TermDocs
TermDocs provides an interface for enumerating <document, frequency> pairs for a term.

The document portion names each document containing the term. Documents are indicated by number. The frequency portion gives the number of times the term occurred in each document.

The pairs are ordered by document number.
Public interface TermPositions
TermPositions provides an interface for enumerating the <document, frequency, <position>* > tuples for a term.

The document and frequency are the same as for a TermDocs. The positions portion lists the ordinal positions of each occurrence of a term in a document.
Public interface TermPositionVector
Extends TermFreqVector to provide additional information about positions in which each of the terms is found. A TermPositionVector not necessarily contains both positions and offsets, but at least one of these arrays exists.

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AbstractAllTermDocs Class

AbstractAllTermDocs Class Lucene.Net Class Library
Base class for enumerating all but deleted docs.

NOTE: this class is meant only to be used internally by Lucene; it's only public so it can be shared across packages. This means the API is freely subject to change, and, the class could be removed entirely, in any Lucene release. Use directly at your own risk! */
Inheritance Hierarchy
Online System Object
Lucene.Net.Index AbstractAllTermDocs

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class AbstractAllTermDocs : TermDocs,
    IDisposable
public abstract class AbstractAllTermDocs : TermDocs,
    IDisposable
Public MustInherit Class AbstractAllTermDocs _
    Implements TermDocs, IDisposable
Public MustInherit Class AbstractAllTermDocs _
    Implements TermDocs, IDisposable
public ref class AbstractAllTermDocs abstract : TermDocs,
    IDisposable
public ref class AbstractAllTermDocs abstract : TermDocs,
    IDisposable
See Also
AbstractAllTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AbstractAllTermDocs Members

AbstractAllTermDocs Members Lucene.Net Class Library

The AbstractAllTermDocs type exposes the following members.
Constructors
 | Name | Description
Protected method | AbstractAllTermDocs | Initializes a new instance of the AbstractAllTermDocs class
Back to Top
Methods
 | Name | Description
Public method | Close |
Public method | Dispose | Releases all resources used by the AbstractAllTermDocs
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AbstractAllTermDocs and optionally releases the managed resources
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsDeleted |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next |
Public method | Read |
Public method | Seek(Term) |
Public method | Seek(TermEnum) |
Public method | SkipTo |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | internalDoc |
Protected field | maxDoc |
Back to Top
Properties
 | Name | Description
Public property | Doc |
Public property | Freq |
Back to Top
See Also
AbstractAllTermDocs Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AbstractAllTermDocs Constructor

AbstractAllTermDocs Constructor Lucene.Net Class Library
Initializes a new instance of the AbstractAllTermDocs class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected AbstractAllTermDocs(
    int maxDoc
)
protected AbstractAllTermDocs(
    int maxDoc
)
Protected Sub New ( _
    maxDoc As Integer _
)
Protected Sub New ( _
    maxDoc As Integer _
)
protected:
AbstractAllTermDocs(
    int maxDoc
)
protected:
AbstractAllTermDocs(
    int maxDoc
)
Parameters
maxDoc
Type:   Online System Int32
See Also
AbstractAllTermDocs Class
AbstractAllTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AbstractAllTermDocs Fields

AbstractAllTermDocs Fields Lucene.Net Class Library
The AbstractAllTermDocs type exposes the following members.
Fields
 | Name | Description
Protected field | internalDoc |
Protected field | maxDoc |
Back to Top
See Also
AbstractAllTermDocs Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalDoc Field

AbstractAllTermDocs internalDoc Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int internalDoc
protected int internalDoc
Protected internalDoc As Integer
Protected internalDoc As Integer
protected:
int internalDoc
protected:
int internalDoc
See Also
AbstractAllTermDocs Class
AbstractAllTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


maxDoc Field

AbstractAllTermDocs maxDoc Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int maxDoc
protected int maxDoc
Protected maxDoc As Integer
Protected maxDoc As Integer
protected:
int maxDoc
protected:
int maxDoc
See Also
AbstractAllTermDocs Class
AbstractAllTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AbstractAllTermDocs Methods

AbstractAllTermDocs Methods Lucene.Net Class Library
The AbstractAllTermDocs type exposes the following members.
Methods
 | Name | Description
Public method | Close |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsDeleted |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next |
Public method | Read |
Public method | Seek(Term) |
Public method | Seek(TermEnum) |
Public method | SkipTo |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AbstractAllTermDocs Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

AbstractAllTermDocs Close Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Close()
public void Close()
Public Sub Close
Public Sub Close
public:
virtual void Close() sealed
public:
virtual void Close() sealed
Implements
TermDocs Close
See Also
AbstractAllTermDocs Class
AbstractAllTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

AbstractAllTermDocs Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the AbstractAllTermDocs
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AbstractAllTermDocs and optionally releases the managed resources
Back to Top
See Also
AbstractAllTermDocs Class
AbstractAllTermDocs Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

AbstractAllTermDocs Dispose Method Lucene.Net Class Library
Releases all resources used by the AbstractAllTermDocs

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
AbstractAllTermDocs Class
AbstractAllTermDocs Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

AbstractAllTermDocs Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the AbstractAllTermDocs and optionally releases the managed resources

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void Dispose(
    bool disposing
)
protected abstract void Dispose(
    bool disposing
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) abstract
protected:
virtual void Dispose(
    bool disposing
) abstract
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
AbstractAllTermDocs Class
AbstractAllTermDocs Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsDeleted Method

AbstractAllTermDocs IsDeleted Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool IsDeleted(
    int doc
)
public abstract bool IsDeleted(
    int doc
)
Public MustOverride Function IsDeleted ( _
    doc As Integer _
) As Boolean
Public MustOverride Function IsDeleted ( _
    doc As Integer _
) As Boolean
public:
virtual bool IsDeleted(
    int doc
) abstract
public:
virtual bool IsDeleted(
    int doc
) abstract
Parameters
doc
Type:   Online System Int32
See Also
AbstractAllTermDocs Class
AbstractAllTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Next Method

AbstractAllTermDocs Next Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Next()
public bool Next()
Public Function Next As Boolean
Public Function Next As Boolean
public:
virtual bool Next() sealed
public:
virtual bool Next() sealed
Implements
TermDocs Next
See Also
AbstractAllTermDocs Class
AbstractAllTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Read Method

AbstractAllTermDocs Read Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Read(
    int[] docs,
    int[] freqs
)
public int Read(
    int[] docs,
    int[] freqs
)
Public Function Read ( _
    docs As Integer(), _
    freqs As Integer() _
) As Integer
Public Function Read ( _
    docs As Integer(), _
    freqs As Integer() _
) As Integer
public:
virtual int Read(
    array<int>^ docs,
    array<int>^ freqs
) sealed
public:
virtual int Read(
    array<int>^ docs,
    array<int>^ freqs
) sealed
Parameters
docs
Type:    Online System Int32
freqs
Type:    Online System Int32
Implements
TermDocs Read( Int32 ,  Int32 )
See Also
AbstractAllTermDocs Class
AbstractAllTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method

AbstractAllTermDocs Seek Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Seek(Term) |
Public method | Seek(TermEnum) |
Back to Top
See Also
AbstractAllTermDocs Class
AbstractAllTermDocs Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method (Term)

AbstractAllTermDocs Seek Method (Term) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Seek(
    Term term
)
public void Seek(
    Term term
)
Public Sub Seek ( _
    term As Term _
)
Public Sub Seek ( _
    term As Term _
)
public:
virtual void Seek(
    Term^ term
) sealed
public:
virtual void Seek(
    Term^ term
) sealed
Parameters
term
Type: Lucene.Net.Index Term
Implements
TermDocs Seek(Term)
See Also
AbstractAllTermDocs Class
AbstractAllTermDocs Members
Seek Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method (TermEnum)

AbstractAllTermDocs Seek Method (TermEnum) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Seek(
    TermEnum termEnum
)
public void Seek(
    TermEnum termEnum
)
Public Sub Seek ( _
    termEnum As TermEnum _
)
Public Sub Seek ( _
    termEnum As TermEnum _
)
public:
virtual void Seek(
    TermEnum^ termEnum
) sealed
public:
virtual void Seek(
    TermEnum^ termEnum
) sealed
Parameters
termEnum
Type: Lucene.Net.Index TermEnum
Implements
TermDocs Seek(TermEnum)
See Also
AbstractAllTermDocs Class
AbstractAllTermDocs Members
Seek Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SkipTo Method

AbstractAllTermDocs SkipTo Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SkipTo(
    int target
)
public bool SkipTo(
    int target
)
Public Function SkipTo ( _
    target As Integer _
) As Boolean
Public Function SkipTo ( _
    target As Integer _
) As Boolean
public:
virtual bool SkipTo(
    int target
) sealed
public:
virtual bool SkipTo(
    int target
) sealed
Parameters
target
Type:   Online System Int32
Implements
TermDocs SkipTo(Int32)
See Also
AbstractAllTermDocs Class
AbstractAllTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AbstractAllTermDocs Properties

AbstractAllTermDocs Properties Lucene.Net Class Library
The AbstractAllTermDocs type exposes the following members.
Properties
 | Name | Description
Public property | Doc |
Public property | Freq |
Back to Top
See Also
AbstractAllTermDocs Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Property

AbstractAllTermDocs Doc Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Doc { get; }
public int Doc { get; }
Public ReadOnly Property Doc As Integer
    Get
Public ReadOnly Property Doc As Integer
    Get
public:
virtual property int Doc {
    int get () sealed;
}
public:
virtual property int Doc {
    int get () sealed;
}
Implements
TermDocs Doc
See Also
AbstractAllTermDocs Class
AbstractAllTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Freq Property

AbstractAllTermDocs Freq Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Freq { get; }
public int Freq { get; }
Public ReadOnly Property Freq As Integer
    Get
Public ReadOnly Property Freq As Integer
    Get
public:
virtual property int Freq {
    int get () sealed;
}
public:
virtual property int Freq {
    int get () sealed;
}
Implements
TermDocs Freq
See Also
AbstractAllTermDocs Class
AbstractAllTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteBlockPool Class

ByteBlockPool Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Index ByteBlockPool

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ByteBlockPool
public sealed class ByteBlockPool
Public NotInheritable Class ByteBlockPool
Public NotInheritable Class ByteBlockPool
public ref class ByteBlockPool sealed
public ref class ByteBlockPool sealed
See Also
ByteBlockPool Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteBlockPool Members

ByteBlockPool Members Lucene.Net Class Library

The ByteBlockPool type exposes the following members.
Constructors
 | Name | Description
Public method | ByteBlockPool | Initializes a new instance of the ByteBlockPool class
Back to Top
Methods
 | Name | Description
Public method | AllocSlice |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NewSlice |
Public method | NextBuffer |
Public method | Reset |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Public field | buffer |
Public field | buffers |
Public field | byteOffset |
Public field | byteUpto |
 | FIRST_LEVEL_SIZE_For_NUnit_Test |
Back to Top
Properties
Name | Description
FIRST_LEVEL_SIZE_ForNUnit |
Back to Top
See Also
ByteBlockPool Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteBlockPool Constructor

ByteBlockPool Constructor Lucene.Net Class Library
Initializes a new instance of the ByteBlockPool class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ByteBlockPool(
    ByteBlockPool..::..Allocator allocator,
    bool trackAllocations
)
public ByteBlockPool(
    ByteBlockPool..::..Allocator allocator,
    bool trackAllocations
)
Public Sub New ( _
    allocator As ByteBlockPool..::..Allocator, _
    trackAllocations As Boolean _
)
Public Sub New ( _
    allocator As ByteBlockPool..::..Allocator, _
    trackAllocations As Boolean _
)
public:
ByteBlockPool(
    ByteBlockPool..::..Allocator^ allocator,
    bool trackAllocations
)
public:
ByteBlockPool(
    ByteBlockPool..::..Allocator^ allocator,
    bool trackAllocations
)
Parameters
allocator
Type: Lucene.Net.Index ByteBlockPool Allocator
trackAllocations
Type:   Online System Boolean
See Also
ByteBlockPool Class
ByteBlockPool Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteBlockPool Fields

ByteBlockPool Fields Lucene.Net Class Library
The ByteBlockPool type exposes the following members.
Fields
 | Name | Description
Public field | buffer |
Public field | buffers |
Public field | byteOffset |
Public field | byteUpto |
 | FIRST_LEVEL_SIZE_For_NUnit_Test |
Back to Top
See Also
ByteBlockPool Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


buffer Field

ByteBlockPool buffer Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] buffer
public byte[] buffer
Public buffer As Byte()
Public buffer As Byte()
public:
array<unsigned char>^ buffer
public:
array<unsigned char>^ buffer
See Also
ByteBlockPool Class
ByteBlockPool Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


buffers Field

ByteBlockPool buffers Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[][] buffers
public byte[][] buffers
Public buffers As Byte()()
Public buffers As Byte()()
public:
array<array<unsigned char>^>^ buffers
public:
array<array<unsigned char>^>^ buffers
See Also
ByteBlockPool Class
ByteBlockPool Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


byteOffset Field

ByteBlockPool byteOffset Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int byteOffset
public int byteOffset
Public byteOffset As Integer
Public byteOffset As Integer
public:
int byteOffset
public:
int byteOffset
See Also
ByteBlockPool Class
ByteBlockPool Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


byteUpto Field

ByteBlockPool byteUpto Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int byteUpto
public int byteUpto
Public byteUpto As Integer
Public byteUpto As Integer
public:
int byteUpto
public:
int byteUpto
See Also
ByteBlockPool Class
ByteBlockPool Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FIRST_LEVEL_SIZE_For_NUnit_Test Field

ByteBlockPool FIRST_LEVEL_SIZE_For_NUnit_Test Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly int FIRST_LEVEL_SIZE_For_NUnit_Test
public static readonly int FIRST_LEVEL_SIZE_For_NUnit_Test
Public Shared ReadOnly FIRST_LEVEL_SIZE_For_NUnit_Test As Integer
Public Shared ReadOnly FIRST_LEVEL_SIZE_For_NUnit_Test As Integer
public:
static initonly int FIRST_LEVEL_SIZE_For_NUnit_Test
public:
static initonly int FIRST_LEVEL_SIZE_For_NUnit_Test
See Also
ByteBlockPool Class
ByteBlockPool Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteBlockPool Methods

ByteBlockPool Methods Lucene.Net Class Library
The ByteBlockPool type exposes the following members.
Methods
 | Name | Description
Public method | AllocSlice |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NewSlice |
Public method | NextBuffer |
Public method | Reset |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ByteBlockPool Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AllocSlice Method

ByteBlockPool AllocSlice Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int AllocSlice(
    byte[] slice,
    int upto
)
public int AllocSlice(
    byte[] slice,
    int upto
)
Public Function AllocSlice ( _
    slice As Byte(), _
    upto As Integer _
) As Integer
Public Function AllocSlice ( _
    slice As Byte(), _
    upto As Integer _
) As Integer
public:
int AllocSlice(
    array<unsigned char>^ slice,
    int upto
)
public:
int AllocSlice(
    array<unsigned char>^ slice,
    int upto
)
Parameters
slice
Type:    Online System Byte
upto
Type:   Online System Int32
See Also
ByteBlockPool Class
ByteBlockPool Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewSlice Method

ByteBlockPool NewSlice Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int NewSlice(
    int size
)
public int NewSlice(
    int size
)
Public Function NewSlice ( _
    size As Integer _
) As Integer
Public Function NewSlice ( _
    size As Integer _
) As Integer
public:
int NewSlice(
    int size
)
public:
int NewSlice(
    int size
)
Parameters
size
Type:   Online System Int32
See Also
ByteBlockPool Class
ByteBlockPool Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextBuffer Method

ByteBlockPool NextBuffer Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void NextBuffer()
public void NextBuffer()
Public Sub NextBuffer
Public Sub NextBuffer
public:
void NextBuffer()
public:
void NextBuffer()
See Also
ByteBlockPool Class
ByteBlockPool Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method

ByteBlockPool Reset Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset()
public void Reset()
Public Sub Reset
Public Sub Reset
public:
void Reset()
public:
void Reset()
See Also
ByteBlockPool Class
ByteBlockPool Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteBlockPool Properties

ByteBlockPool Properties Lucene.Net Class Library
The ByteBlockPool type exposes the following members.
Properties
Name | Description
FIRST_LEVEL_SIZE_ForNUnit |
Back to Top
See Also
ByteBlockPool Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FIRST_LEVEL_SIZE_ForNUnit Property

ByteBlockPool FIRST_LEVEL_SIZE_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int FIRST_LEVEL_SIZE_ForNUnit { get; }
public static int FIRST_LEVEL_SIZE_ForNUnit { get; }
Public Shared ReadOnly Property FIRST_LEVEL_SIZE_ForNUnit As Integer
    Get
Public Shared ReadOnly Property FIRST_LEVEL_SIZE_ForNUnit As Integer
    Get
public:
static property int FIRST_LEVEL_SIZE_ForNUnit {
    int get ();
}
public:
static property int FIRST_LEVEL_SIZE_ForNUnit {
    int get ();
}
See Also
ByteBlockPool Class
ByteBlockPool Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteBlockPool.Allocator Class

ByteBlockPool Allocator Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Index ByteBlockPool Allocator

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Allocator
public abstract class Allocator
Public MustInherit Class Allocator
Public MustInherit Class Allocator
public ref class Allocator abstract
public ref class Allocator abstract
See Also
ByteBlockPool Allocator Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteBlockPool.Allocator Members

ByteBlockPool Allocator Members Lucene.Net Class Library

The ByteBlockPool Allocator type exposes the following members.
Constructors
 | Name | Description
Protected method | ByteBlockPool Allocator | Initializes a new instance of the ByteBlockPool Allocator class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetByteBlock |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RecycleByteBlocks(IList Byte ) |
Public method | RecycleByteBlocks( Byte , Int32, Int32) |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ByteBlockPool Allocator Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteBlockPool.Allocator Constructor

ByteBlockPool Allocator Constructor Lucene.Net Class Library
Initializes a new instance of the ByteBlockPool Allocator class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Allocator()
protected Allocator()
Protected Sub New
Protected Sub New
protected:
Allocator()
protected:
Allocator()
See Also
ByteBlockPool Allocator Class
ByteBlockPool Allocator Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteBlockPool.Allocator Methods

ByteBlockPool Allocator Methods Lucene.Net Class Library
The ByteBlockPool Allocator type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetByteBlock |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RecycleByteBlocks(IList Byte ) |
Public method | RecycleByteBlocks( Byte , Int32, Int32) |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ByteBlockPool Allocator Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetByteBlock Method

ByteBlockPool Allocator GetByteBlock Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract byte[] GetByteBlock(
    bool trackAllocations
)
public abstract byte[] GetByteBlock(
    bool trackAllocations
)
Public MustOverride Function GetByteBlock ( _
    trackAllocations As Boolean _
) As Byte()
Public MustOverride Function GetByteBlock ( _
    trackAllocations As Boolean _
) As Byte()
public:
virtual array<unsigned char>^ GetByteBlock(
    bool trackAllocations
) abstract
public:
virtual array<unsigned char>^ GetByteBlock(
    bool trackAllocations
) abstract
Parameters
trackAllocations
Type:   Online System Boolean
See Also
ByteBlockPool Allocator Class
ByteBlockPool Allocator Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RecycleByteBlocks Method

ByteBlockPool Allocator RecycleByteBlocks Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | RecycleByteBlocks(IList Byte ) |
Public method | RecycleByteBlocks( Byte , Int32, Int32) |
Back to Top
See Also
ByteBlockPool Allocator Class
ByteBlockPool Allocator Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RecycleByteBlocks Method (IList(Byte[]))

ByteBlockPool Allocator RecycleByteBlocks Method (IList Byte ) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void RecycleByteBlocks(
    IList<byte[]> blocks
)
public abstract void RecycleByteBlocks(
    IList<byte[]> blocks
)
Public MustOverride Sub RecycleByteBlocks ( _
    blocks As IList(Of Byte()) _
)
Public MustOverride Sub RecycleByteBlocks ( _
    blocks As IList(Of Byte()) _
)
public:
virtual void RecycleByteBlocks(
    IList<array<unsigned char>^>^ blocks
) abstract
public:
virtual void RecycleByteBlocks(
    IList<array<unsigned char>^>^ blocks
) abstract
Parameters
blocks
Type:   Online System.Collections.Generic IList     Online Byte
See Also
ByteBlockPool Allocator Class
ByteBlockPool Allocator Members
RecycleByteBlocks Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RecycleByteBlocks Method (Byte[][], Int32, Int32)

ByteBlockPool Allocator RecycleByteBlocks Method ( Byte , Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void RecycleByteBlocks(
    byte[][] blocks,
    int start,
    int end
)
public abstract void RecycleByteBlocks(
    byte[][] blocks,
    int start,
    int end
)
Public MustOverride Sub RecycleByteBlocks ( _
    blocks As Byte()(), _
    start As Integer, _
    end As Integer _
)
Public MustOverride Sub RecycleByteBlocks ( _
    blocks As Byte()(), _
    start As Integer, _
    end As Integer _
)
public:
virtual void RecycleByteBlocks(
    array<array<unsigned char>^>^ blocks,
    int start,
    int end
) abstract
public:
virtual void RecycleByteBlocks(
    array<array<unsigned char>^>^ blocks,
    int start,
    int end
) abstract
Parameters
blocks
Type:     Online System Byte
start
Type:   Online System Int32
end
Type:   Online System Int32
See Also
ByteBlockPool Allocator Class
ByteBlockPool Allocator Members
RecycleByteBlocks Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteSliceReader Class

ByteSliceReader Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Store IndexInput
Lucene.Net.Index ByteSliceReader

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ByteSliceReader : IndexInput
public sealed class ByteSliceReader : IndexInput
Public NotInheritable Class ByteSliceReader _
    Inherits IndexInput
Public NotInheritable Class ByteSliceReader _
    Inherits IndexInput
public ref class ByteSliceReader sealed : public IndexInput
public ref class ByteSliceReader sealed : public IndexInput
See Also
ByteSliceReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteSliceReader Members

ByteSliceReader Members Lucene.Net Class Library

The ByteSliceReader type exposes the following members.
Constructors
 | Name | Description
Public method | ByteSliceReader | Initializes a new instance of the ByteSliceReader class
Back to Top
Methods
 | Name | Description
Public method | Clone | (Overrides IndexInput Clone .)
Public method | Close | Obsolete. (Inherited from IndexInput.)
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ByteSliceReader and optionally releases the managed resources (Overrides IndexInput Dispose(Boolean).)
Public method | Eof |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Init |
Public method | Length | (Overrides IndexInput Length .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextSlice |
Public method | ReadByte | (Overrides IndexInput ReadByte .)
Public method | ReadBytes( Byte , Int32, Int32) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32).)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only BufferedIndexInput respects this parameter. (Inherited from IndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput Seek(Int64).)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to ReadChars( Char , Int32, Int32) but does not do any conversion operations on the bytes it is reading in. It still has to invoke ReadByte just as ReadChars( Char , Int32, Int32) does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteTo |
Back to Top
Fields
 | Name | Description
Public field | bufferOffset |
Public field | endIndex |
Public field | upto |
Back to Top
Properties
 | Name | Description
Public property | FilePointer | (Overrides IndexInput FilePointer.)
Back to Top
See Also
ByteSliceReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteSliceReader Constructor

ByteSliceReader Constructor Lucene.Net Class Library
Initializes a new instance of the ByteSliceReader class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ByteSliceReader()
public ByteSliceReader()
Public Sub New
Public Sub New
public:
ByteSliceReader()
public:
ByteSliceReader()
See Also
ByteSliceReader Class
ByteSliceReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteSliceReader Fields

ByteSliceReader Fields Lucene.Net Class Library
The ByteSliceReader type exposes the following members.
Fields
 | Name | Description
Public field | bufferOffset |
Public field | endIndex |
Public field | upto |
Back to Top
See Also
ByteSliceReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


bufferOffset Field

ByteSliceReader bufferOffset Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int bufferOffset
public int bufferOffset
Public bufferOffset As Integer
Public bufferOffset As Integer
public:
int bufferOffset
public:
int bufferOffset
See Also
ByteSliceReader Class
ByteSliceReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


endIndex Field

ByteSliceReader endIndex Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int endIndex
public int endIndex
Public endIndex As Integer
Public endIndex As Integer
public:
int endIndex
public:
int endIndex
See Also
ByteSliceReader Class
ByteSliceReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


upto Field

ByteSliceReader upto Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int upto
public int upto
Public upto As Integer
Public upto As Integer
public:
int upto
public:
int upto
See Also
ByteSliceReader Class
ByteSliceReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteSliceReader Methods

ByteSliceReader Methods Lucene.Net Class Library
The ByteSliceReader type exposes the following members.
Methods
 | Name | Description
Public method | Clone | (Overrides IndexInput Clone .)
Public method | Close | Obsolete. (Inherited from IndexInput.)
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | (Overrides IndexInput Dispose(Boolean).)
Public method | Eof |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Init |
Public method | Length | (Overrides IndexInput Length .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextSlice |
Public method | ReadByte | (Overrides IndexInput ReadByte .)
Public method | ReadBytes( Byte , Int32, Int32) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32).)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only BufferedIndexInput respects this parameter. (Inherited from IndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput Seek(Int64).)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to ReadChars( Char , Int32, Int32) but does not do any conversion operations on the bytes it is reading in. It still has to invoke ReadByte just as ReadChars( Char , Int32, Int32) does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteTo |
Back to Top
See Also
ByteSliceReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

ByteSliceReader Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
See Also
ByteSliceReader Class
ByteSliceReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

ByteSliceReader Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ByteSliceReader and optionally releases the managed resources (Overrides IndexInput Dispose(Boolean).)
Back to Top
See Also
ByteSliceReader Class
ByteSliceReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

ByteSliceReader Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the ByteSliceReader and optionally releases the managed resources

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
ByteSliceReader Class
ByteSliceReader Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Eof Method

ByteSliceReader Eof Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Eof()
public bool Eof()
Public Function Eof As Boolean
Public Function Eof As Boolean
public:
bool Eof()
public:
bool Eof()
See Also
ByteSliceReader Class
ByteSliceReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Init Method

ByteSliceReader Init Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Init(
    ByteBlockPool pool,
    int startIndex,
    int endIndex
)
public void Init(
    ByteBlockPool pool,
    int startIndex,
    int endIndex
)
Public Sub Init ( _
    pool As ByteBlockPool, _
    startIndex As Integer, _
    endIndex As Integer _
)
Public Sub Init ( _
    pool As ByteBlockPool, _
    startIndex As Integer, _
    endIndex As Integer _
)
public:
void Init(
    ByteBlockPool^ pool,
    int startIndex,
    int endIndex
)
public:
void Init(
    ByteBlockPool^ pool,
    int startIndex,
    int endIndex
)
Parameters
pool
Type: Lucene.Net.Index ByteBlockPool
startIndex
Type:   Online System Int32
endIndex
Type:   Online System Int32
See Also
ByteSliceReader Class
ByteSliceReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Length Method

ByteSliceReader Length Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Length()
public override long Length()
Public Overrides Function Length As Long
Public Overrides Function Length As Long
public:
virtual long long Length() override
public:
virtual long long Length() override
See Also
ByteSliceReader Class
ByteSliceReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextSlice Method

ByteSliceReader NextSlice Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void NextSlice()
public void NextSlice()
Public Sub NextSlice
Public Sub NextSlice
public:
void NextSlice()
public:
void NextSlice()
See Also
ByteSliceReader Class
ByteSliceReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadByte Method

ByteSliceReader ReadByte Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override byte ReadByte()
public override byte ReadByte()
Public Overrides Function ReadByte As Byte
Public Overrides Function ReadByte As Byte
public:
virtual unsigned char ReadByte() override
public:
virtual unsigned char ReadByte() override
See Also
ByteSliceReader Class
ByteSliceReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadBytes Method

ByteSliceReader ReadBytes Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ReadBytes( Byte , Int32, Int32) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32).)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only BufferedIndexInput respects this parameter. (Inherited from IndexInput.)
Back to Top
See Also
ByteSliceReader Class
ByteSliceReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadBytes Method (Byte[], Int32, Int32)

ByteSliceReader ReadBytes Method ( Byte , Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ReadBytes(
    byte[] b,
    int offset,
    int len
)
public override void ReadBytes(
    byte[] b,
    int offset,
    int len
)
Public Overrides Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Public Overrides Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) override
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) override
Parameters
b
Type:    Online System Byte
offset
Type:   Online System Int32
len
Type:   Online System Int32
See Also
ByteSliceReader Class
ByteSliceReader Members
ReadBytes Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method

ByteSliceReader Seek Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Seek(
    long pos
)
public override void Seek(
    long pos
)
Public Overrides Sub Seek ( _
    pos As Long _
)
Public Overrides Sub Seek ( _
    pos As Long _
)
public:
virtual void Seek(
    long long pos
) override
public:
virtual void Seek(
    long long pos
) override
Parameters
pos
Type:   Online System Int64
See Also
ByteSliceReader Class
ByteSliceReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteTo Method

ByteSliceReader WriteTo Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long WriteTo(
    IndexOutput out
)
public long WriteTo(
    IndexOutput out
)
Public Function WriteTo ( _
    out As IndexOutput _
) As Long
Public Function WriteTo ( _
    out As IndexOutput _
) As Long
public:
long long WriteTo(
    IndexOutput^ out
)
public:
long long WriteTo(
    IndexOutput^ out
)
Parameters
out
Type: Lucene.Net.Store IndexOutput
See Also
ByteSliceReader Class
ByteSliceReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteSliceReader Properties

ByteSliceReader Properties Lucene.Net Class Library
The ByteSliceReader type exposes the following members.
Properties
 | Name | Description
Public property | FilePointer | (Overrides IndexInput FilePointer.)
Back to Top
See Also
ByteSliceReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilePointer Property

ByteSliceReader FilePointer Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long FilePointer { get; }
public override long FilePointer { get; }
Public Overrides ReadOnly Property FilePointer As Long
    Get
Public Overrides ReadOnly Property FilePointer As Long
    Get
public:
virtual property long long FilePointer {
    long long get () override;
}
public:
virtual property long long FilePointer {
    long long get () override;
}
See Also
ByteSliceReader Class
ByteSliceReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteSliceWriter Class

ByteSliceWriter Class Lucene.Net Class Library
Class to write byte streams into slices of shared byte[]. This is used by DocumentsWriter to hold the posting list for many terms in RAM.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index ByteSliceWriter

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ByteSliceWriter
public sealed class ByteSliceWriter
Public NotInheritable Class ByteSliceWriter
Public NotInheritable Class ByteSliceWriter
public ref class ByteSliceWriter sealed
public ref class ByteSliceWriter sealed
See Also
ByteSliceWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteSliceWriter Members

ByteSliceWriter Members Lucene.Net Class Library

The ByteSliceWriter type exposes the following members.
Constructors
 | Name | Description
Public method | ByteSliceWriter | Initializes a new instance of the ByteSliceWriter class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Init | Set up the writer to write at address.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteByte | Write byte into byte slice stream
Public method | WriteBytes |
Public method | WriteVInt |
Back to Top
Properties
 | Name | Description
Public property | Address |
Back to Top
See Also
ByteSliceWriter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteSliceWriter Constructor

ByteSliceWriter Constructor Lucene.Net Class Library
Initializes a new instance of the ByteSliceWriter class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ByteSliceWriter(
    ByteBlockPool pool
)
public ByteSliceWriter(
    ByteBlockPool pool
)
Public Sub New ( _
    pool As ByteBlockPool _
)
Public Sub New ( _
    pool As ByteBlockPool _
)
public:
ByteSliceWriter(
    ByteBlockPool^ pool
)
public:
ByteSliceWriter(
    ByteBlockPool^ pool
)
Parameters
pool
Type: Lucene.Net.Index ByteBlockPool
See Also
ByteSliceWriter Class
ByteSliceWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteSliceWriter Methods

ByteSliceWriter Methods Lucene.Net Class Library
The ByteSliceWriter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Init | Set up the writer to write at address.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteByte | Write byte into byte slice stream
Public method | WriteBytes |
Public method | WriteVInt |
Back to Top
See Also
ByteSliceWriter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Init Method

ByteSliceWriter Init Method Lucene.Net Class Library
Set up the writer to write at address.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Init(
    int address
)
public void Init(
    int address
)
Public Sub Init ( _
    address As Integer _
)
Public Sub Init ( _
    address As Integer _
)
public:
void Init(
    int address
)
public:
void Init(
    int address
)
Parameters
address
Type:   Online System Int32
See Also
ByteSliceWriter Class
ByteSliceWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteByte Method

ByteSliceWriter WriteByte Method Lucene.Net Class Library
Write byte into byte slice stream

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteByte(
    byte b
)
public void WriteByte(
    byte b
)
Public Sub WriteByte ( _
    b As Byte _
)
Public Sub WriteByte ( _
    b As Byte _
)
public:
void WriteByte(
    unsigned char b
)
public:
void WriteByte(
    unsigned char b
)
Parameters
b
Type:   Online System Byte
See Also
ByteSliceWriter Class
ByteSliceWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteBytes Method

ByteSliceWriter WriteBytes Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteBytes(
    byte[] b,
    int offset,
    int len
)
public void WriteBytes(
    byte[] b,
    int offset,
    int len
)
Public Sub WriteBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Public Sub WriteBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
public:
void WriteBytes(
    array<unsigned char>^ b,
    int offset,
    int len
)
public:
void WriteBytes(
    array<unsigned char>^ b,
    int offset,
    int len
)
Parameters
b
Type:    Online System Byte
offset
Type:   Online System Int32
len
Type:   Online System Int32
See Also
ByteSliceWriter Class
ByteSliceWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteVInt Method

ByteSliceWriter WriteVInt Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteVInt(
    int i
)
public void WriteVInt(
    int i
)
Public Sub WriteVInt ( _
    i As Integer _
)
Public Sub WriteVInt ( _
    i As Integer _
)
public:
void WriteVInt(
    int i
)
public:
void WriteVInt(
    int i
)
Parameters
i
Type:   Online System Int32
See Also
ByteSliceWriter Class
ByteSliceWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteSliceWriter Properties

ByteSliceWriter Properties Lucene.Net Class Library
The ByteSliceWriter type exposes the following members.
Properties
 | Name | Description
Public property | Address |
Back to Top
See Also
ByteSliceWriter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Address Property

ByteSliceWriter Address Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Address { get; }
public int Address { get; }
Public ReadOnly Property Address As Integer
    Get
Public ReadOnly Property Address As Integer
    Get
public:
property int Address {
    int get ();
}
public:
property int Address {
    int get ();
}
See Also
ByteSliceWriter Class
ByteSliceWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex Class

CheckIndex Class Lucene.Net Class Library
Basic tool and API to check the health of an index and write a new segments file that removes reference to problematic segments.

As this tool checks every byte in the index, on a large index it can take quite a long time to run.

WARNING: this tool and API is new and experimental and is subject to suddenly change in the next release. Please make a complete backup of your index before using this to fix your index!
Inheritance Hierarchy
Online System Object
Lucene.Net.Index CheckIndex

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CheckIndex
public class CheckIndex
Public Class CheckIndex
Public Class CheckIndex
public ref class CheckIndex
public ref class CheckIndex
See Also
CheckIndex Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex Members

CheckIndex Members Lucene.Net Class Library

The CheckIndex type exposes the following members.
Constructors
 | Name | Description
Public method | CheckIndex | Create a new CheckIndex on the directory.
Back to Top
Methods
Name Description
Public method CheckIndex_Renamed_Method
Returns a CheckIndex Status instance detailing the state of the index.

As this method checks every byte in the index, on a large index it can take quite a long time to run.

WARNING: make sure you only call this when the index is not opened by any writer.
Public method CheckIndex_Renamed_Method(List String )
Returns a CheckIndex Status instance detailing the state of the index.
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method FixIndex
Repairs the index using previously returned result from CheckIndex. Note that this does not remove any of the unreferenced files after it's done; you must separately open an IndexWriter, which deletes unreferenced files when it's created.

WARNING: this writes a new segments file into the index, effectively removing all documents in broken segments from the index. BE CAREFUL.

WARNING: Make sure you only call this when the index is not opened by any writer.
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Main
Command-line interface to check and fix an index.

Run it like this:
View Colorized Copy to Clipboard Print
java -ea:Lucene.Net... Lucene.Net.Index.CheckIndex pathToIndex [-fix] [-segment X] [-segment Y]
java -ea:Lucene.Net... Lucene.Net.Index.CheckIndex pathToIndex [-fix] [-segment X] [-segment Y]
  • -fix: actually write a new segments_N file, removing any problematic segments
  • -segment X: only check the specified segment(s). This can be specified multiple times, to check more than one segment, eg -segment _2 -segment _a. You can't use this with the -fix option.

WARNING: -fix should only be used on an emergency basis as it will cause documents (perhaps many) to be permanently removed from the index. Always make a backup copy of your index before running this! Do not run this tool on an index that is actively being written to. You have been warned!

Run without -fix, this tool will open the index, report version information and report any exceptions it hits and what action it would take if -fix were specified. With -fix, this tool will remove any segments that have issues and write a new segments_N file. This means all documents contained in the affected segments will be removed.

This tool exits with exit code 1 if the index cannot be opened or has any corruption, else 0.
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method SetInfoStream
Set infoStream where messages should go. If null, no messages are printed
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
See Also
CheckIndex Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex Constructor

CheckIndex Constructor Lucene.Net Class Library
Create a new CheckIndex on the directory.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CheckIndex(
    Directory dir
)
public CheckIndex(
    Directory dir
)
Public Sub New ( _
    dir As Directory _
)
Public Sub New ( _
    dir As Directory _
)
public:
CheckIndex(
    Directory^ dir
)
public:
CheckIndex(
    Directory^ dir
)
Parameters
dir
Type: Lucene.Net.Store Directory
See Also
CheckIndex Class
CheckIndex Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex Methods

CheckIndex Methods Lucene.Net Class Library
The CheckIndex type exposes the following members.
Methods
Name Description
Public method CheckIndex_Renamed_Method
Returns a CheckIndex Status instance detailing the state of the index.

As this method checks every byte in the index, on a large index it can take quite a long time to run.

WARNING: make sure you only call this when the index is not opened by any writer.
Public method CheckIndex_Renamed_Method(List String )
Returns a CheckIndex Status instance detailing the state of the index.
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method FixIndex
Repairs the index using previously returned result from CheckIndex. Note that this does not remove any of the unreferenced files after it's done; you must separately open an IndexWriter, which deletes unreferenced files when it's created.

WARNING: this writes a new segments file into the index, effectively removing all documents in broken segments from the index. BE CAREFUL.

WARNING: Make sure you only call this when the index is not opened by any writer.
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Main
Command-line interface to check and fix an index.

Run it like this:
View Colorized Copy to Clipboard Print
java -ea:Lucene.Net... Lucene.Net.Index.CheckIndex pathToIndex [-fix] [-segment X] [-segment Y]
java -ea:Lucene.Net... Lucene.Net.Index.CheckIndex pathToIndex [-fix] [-segment X] [-segment Y]
  • -fix: actually write a new segments_N file, removing any problematic segments
  • -segment X: only check the specified segment(s). This can be specified multiple times, to check more than one segment, eg -segment _2 -segment _a. You can't use this with the -fix option.

WARNING: -fix should only be used on an emergency basis as it will cause documents (perhaps many) to be permanently removed from the index. Always make a backup copy of your index before running this! Do not run this tool on an index that is actively being written to. You have been warned!

Run without -fix, this tool will open the index, report version information and report any exceptions it hits and what action it would take if -fix were specified. With -fix, this tool will remove any segments that have issues and write a new segments_N file. This means all documents contained in the affected segments will be removed.

This tool exits with exit code 1 if the index cannot be opened or has any corruption, else 0.
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method SetInfoStream
Set infoStream where messages should go. If null, no messages are printed
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
See Also
CheckIndex Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex_Renamed_Method Method

CheckIndex CheckIndex_Renamed_Method Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | CheckIndex_Renamed_Method | Returns a CheckIndex Status instance detailing the state of the index. As this method checks every byte in the index, on a large index it can take quite a long time to run. WARNING: make sure you only call this when the index is not opened by any writer.
Public method | CheckIndex_Renamed_Method(List String ) | Returns a CheckIndex Status instance detailing the state of the index.
Back to Top
See Also
CheckIndex Class
CheckIndex Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex_Renamed_Method Method

CheckIndex CheckIndex_Renamed_Method Method Lucene.Net Class Library
Returns a CheckIndex Status instance detailing the state of the index.

As this method checks every byte in the index, on a large index it can take quite a long time to run.

WARNING: make sure you only call this when the index is not opened by any writer.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual CheckIndex..::..Status CheckIndex_Renamed_Method()
public virtual CheckIndex..::..Status CheckIndex_Renamed_Method()
Public Overridable Function CheckIndex_Renamed_Method As CheckIndex..::..Status
Public Overridable Function CheckIndex_Renamed_Method As CheckIndex..::..Status
public:
virtual CheckIndex..::..Status^ CheckIndex_Renamed_Method()
public:
virtual CheckIndex..::..Status^ CheckIndex_Renamed_Method()
See Also
CheckIndex Class
CheckIndex Members
CheckIndex_Renamed_Method Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex_Renamed_Method Method (List(String))

CheckIndex CheckIndex_Renamed_Method Method (List String ) Lucene.Net Class Library
Returns a CheckIndex Status instance detailing the state of the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual CheckIndex..::..Status CheckIndex_Renamed_Method(
    List<string> onlySegments
)
public virtual CheckIndex..::..Status CheckIndex_Renamed_Method(
    List<string> onlySegments
)
Public Overridable Function CheckIndex_Renamed_Method ( _
    onlySegments As List(Of String) _
) As CheckIndex..::..Status
Public Overridable Function CheckIndex_Renamed_Method ( _
    onlySegments As List(Of String) _
) As CheckIndex..::..Status
public:
virtual CheckIndex..::..Status^ CheckIndex_Renamed_Method(
    List<String^>^ onlySegments
)
public:
virtual CheckIndex..::..Status^ CheckIndex_Renamed_Method(
    List<String^>^ onlySegments
)
Parameters
onlySegments
Type:   Online System.Collections.Generic List    Online String
list of specific segment names to check

As this method checks every byte in the specified
            segments, on a large index it can take quite a long
            time to run.

WARNING: make sure
            you only call this when the index is not opened by any
            writer.

See Also
CheckIndex Class
CheckIndex Members
CheckIndex_Renamed_Method Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FixIndex Method

CheckIndex FixIndex Method Lucene.Net Class Library
Repairs the index using previously returned result from CheckIndex. Note that this does not remove any of the unreferenced files after it's done; you must separately open an IndexWriter, which deletes unreferenced files when it's created.

WARNING: this writes a new segments file into the index, effectively removing all documents in broken segments from the index. BE CAREFUL.

WARNING: Make sure you only call this when the index is not opened by any writer.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void FixIndex(
    CheckIndex..::..Status result
)
public virtual void FixIndex(
    CheckIndex..::..Status result
)
Public Overridable Sub FixIndex ( _
    result As CheckIndex..::..Status _
)
Public Overridable Sub FixIndex ( _
    result As CheckIndex..::..Status _
)
public:
virtual void FixIndex(
    CheckIndex..::..Status^ result
)
public:
virtual void FixIndex(
    CheckIndex..::..Status^ result
)
Parameters
result
Type: Lucene.Net.Index CheckIndex Status
See Also
CheckIndex Class
CheckIndex Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Main Method

CheckIndex Main Method Lucene.Net Class Library
Command-line interface to check and fix an index.

Run it like this:
View Colorized Copy to Clipboard Print
java -ea:Lucene.Net... Lucene.Net.Index.CheckIndex pathToIndex [-fix] [-segment X] [-segment Y]
java -ea:Lucene.Net... Lucene.Net.Index.CheckIndex pathToIndex [-fix] [-segment X] [-segment Y]
  • -fix: actually write a new segments_N file, removing any problematic segments
  • -segment X: only check the specified segment(s). This can be specified multiple times, to check more than one segment, eg -segment _2 -segment _a. You can't use this with the -fix option.

WARNING: -fix should only be used on an emergency basis as it will cause documents (perhaps many) to be permanently removed from the index. Always make a backup copy of your index before running this! Do not run this tool on an index that is actively being written to. You have been warned!

Run without -fix, this tool will open the index, report version information and report any exceptions it hits and what action it would take if -fix were specified. With -fix, this tool will remove any segments that have issues and write a new segments_N file. This means all documents contained in the affected segments will be removed.

This tool exits with exit code 1 if the index cannot be opened or has any corruption, else 0.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[STAThreadAttribute]
public static void Main(
    string[] args
)
[STAThreadAttribute]
public static void Main(
    string[] args
)
<STAThreadAttribute> _
Public Shared Sub Main ( _
    args As String() _
)
<STAThreadAttribute> _
Public Shared Sub Main ( _
    args As String() _
)
public:
[STAThreadAttribute]
static void Main(
    array<String^>^ args
)
public:
[STAThreadAttribute]
static void Main(
    array<String^>^ args
)
Parameters
args
Type:    Online System String
See Also
CheckIndex Class
CheckIndex Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetInfoStream Method

CheckIndex SetInfoStream Method Lucene.Net Class Library
Set infoStream where messages should go. If null, no messages are printed

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetInfoStream(
    StreamWriter out
)
public virtual void SetInfoStream(
    StreamWriter out
)
Public Overridable Sub SetInfoStream ( _
    out As StreamWriter _
)
Public Overridable Sub SetInfoStream ( _
    out As StreamWriter _
)
public:
virtual void SetInfoStream(
    StreamWriter^ out
)
public:
virtual void SetInfoStream(
    StreamWriter^ out
)
Parameters
out
Type:   Online System.IO StreamWriter
See Also
CheckIndex Class
CheckIndex Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status Class

CheckIndex Status Class Lucene.Net Class Library
Returned from CheckIndex_Renamed_Method detailing the health and status of the index.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index CheckIndex Status

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Status
public class Status
Public Class Status
Public Class Status
public ref class Status
public ref class Status
See Also
CheckIndex Status Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status Members

CheckIndex Status Members Lucene.Net Class Library

Basic tool and API to check the health of an index and write a new segments file that removes reference to problematic segments.

As this tool checks every byte in the index, on a large index it can take quite a long time to run.

WARNING: this tool and API is new and experimental and is subject to suddenly change in the next release. Please make a complete backup of your index before using this to fix your index!

The CheckIndex Status type exposes the following members.
Constructors
 | Name | Description
Public method | CheckIndex Status | Initializes a new instance of the CheckIndex Status class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Public field | cantOpenSegments | True if we were unable to open the segments_N file.
Public field | clean | True if no problems were found with the index.
Public field | dir | Directory index is in.
Public field | missingSegments | True if we were unable to locate and load the segments_N file.
Public field | missingSegmentVersion | True if we were unable to read the version number from segments_N file.
Public field | numBadSegments | How many bad segments were found.
Public field | numSegments | Number of segments in the index.
Public field | partial | True if we checked only specific segments (CheckIndex_Renamed_Method(List String )) was called with non-null argument).
Public field | segmentFormat | String description of the version of the index.
Public field | segmentInfos | List of CheckIndex Status SegmentInfoStatus instances, detailing status of each segment.
Public field | segmentsChecked | Empty unless you passed specific segments list to check as optional 3rd argument.
Public field | segmentsFileName | Name of latest segments_N file in the index.
Public field | toolOutOfDate | True if the index was created with a newer version of Lucene than the CheckIndex tool.
Public field | totLoseDocCount | How many documents will be lost to bad segments.
Public field | userData | Holds the userData of the last commit in the index
Back to Top
See Also
CheckIndex Status Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status Constructor

CheckIndex Status Constructor Lucene.Net Class Library
Initializes a new instance of the CheckIndex Status class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Status()
public Status()
Public Sub New
Public Sub New
public:
Status()
public:
Status()
See Also
CheckIndex Status Class
CheckIndex Status Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status Fields

CheckIndex Status Fields Lucene.Net Class Library
The CheckIndex Status type exposes the following members.
Fields
 | Name | Description
Public field | cantOpenSegments | True if we were unable to open the segments_N file.
Public field | clean | True if no problems were found with the index.
Public field | dir | Directory index is in.
Public field | missingSegments | True if we were unable to locate and load the segments_N file.
Public field | missingSegmentVersion | True if we were unable to read the version number from segments_N file.
Public field | numBadSegments | How many bad segments were found.
Public field | numSegments | Number of segments in the index.
Public field | partial | True if we checked only specific segments (CheckIndex_Renamed_Method(List String )) was called with non-null argument).
Public field | segmentFormat | String description of the version of the index.
Public field | segmentInfos | List of CheckIndex Status SegmentInfoStatus instances, detailing status of each segment.
Public field | segmentsChecked | Empty unless you passed specific segments list to check as optional 3rd argument.
Public field | segmentsFileName | Name of latest segments_N file in the index.
Public field | toolOutOfDate | True if the index was created with a newer version of Lucene than the CheckIndex tool.
Public field | totLoseDocCount | How many documents will be lost to bad segments.
Public field | userData | Holds the userData of the last commit in the index
Back to Top
See Also
CheckIndex Status Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


cantOpenSegments Field

CheckIndex Status cantOpenSegments Field Lucene.Net Class Library
True if we were unable to open the segments_N file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool cantOpenSegments
public bool cantOpenSegments
Public cantOpenSegments As Boolean
Public cantOpenSegments As Boolean
public:
bool cantOpenSegments
public:
bool cantOpenSegments
See Also
CheckIndex Status Class
CheckIndex Status Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


clean Field

CheckIndex Status clean Field Lucene.Net Class Library
True if no problems were found with the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool clean
public bool clean
Public clean As Boolean
Public clean As Boolean
public:
bool clean
public:
bool clean
See Also
CheckIndex Status Class
CheckIndex Status Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


dir Field

CheckIndex Status dir Field Lucene.Net Class Library
Directory index is in.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Directory dir
public Directory dir
Public dir As Directory
Public dir As Directory
public:
Directory^ dir
public:
Directory^ dir
See Also
CheckIndex Status Class
CheckIndex Status Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


missingSegments Field

CheckIndex Status missingSegments Field Lucene.Net Class Library
True if we were unable to locate and load the segments_N file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool missingSegments
public bool missingSegments
Public missingSegments As Boolean
Public missingSegments As Boolean
public:
bool missingSegments
public:
bool missingSegments
See Also
CheckIndex Status Class
CheckIndex Status Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


missingSegmentVersion Field

CheckIndex Status missingSegmentVersion Field Lucene.Net Class Library
True if we were unable to read the version number from segments_N file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool missingSegmentVersion
public bool missingSegmentVersion
Public missingSegmentVersion As Boolean
Public missingSegmentVersion As Boolean
public:
bool missingSegmentVersion
public:
bool missingSegmentVersion
See Also
CheckIndex Status Class
CheckIndex Status Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


numBadSegments Field

CheckIndex Status numBadSegments Field Lucene.Net Class Library
How many bad segments were found.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int numBadSegments
public int numBadSegments
Public numBadSegments As Integer
Public numBadSegments As Integer
public:
int numBadSegments
public:
int numBadSegments
See Also
CheckIndex Status Class
CheckIndex Status Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


numSegments Field

CheckIndex Status numSegments Field Lucene.Net Class Library
Number of segments in the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int numSegments
public int numSegments
Public numSegments As Integer
Public numSegments As Integer
public:
int numSegments
public:
int numSegments
See Also
CheckIndex Status Class
CheckIndex Status Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


partial Field

CheckIndex Status partial Field Lucene.Net Class Library
True if we checked only specific segments (CheckIndex_Renamed_Method(List String )) was called with non-null argument).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool partial
public bool partial
Public partial As Boolean
Public partial As Boolean
public:
bool partial
public:
bool partial
See Also
CheckIndex Status Class
CheckIndex Status Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


segmentFormat Field

CheckIndex Status segmentFormat Field Lucene.Net Class Library
String description of the version of the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string segmentFormat
public string segmentFormat
Public segmentFormat As String
Public segmentFormat As String
public:
String^ segmentFormat
public:
String^ segmentFormat
See Also
CheckIndex Status Class
CheckIndex Status Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


segmentInfos Field

CheckIndex Status segmentInfos Field Lucene.Net Class Library
List of CheckIndex Status SegmentInfoStatus instances, detailing status of each segment.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList<CheckIndex..::..Status..::..SegmentInfoStatus> segmentInfos
public IList<CheckIndex..::..Status..::..SegmentInfoStatus> segmentInfos
Public segmentInfos As IList(Of CheckIndex..::..Status..::..SegmentInfoStatus)
Public segmentInfos As IList(Of CheckIndex..::..Status..::..SegmentInfoStatus)
public:
IList<CheckIndex..::..Status..::..SegmentInfoStatus^>^ segmentInfos
public:
IList<CheckIndex..::..Status..::..SegmentInfoStatus^>^ segmentInfos
See Also
CheckIndex Status Class
CheckIndex Status Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


segmentsChecked Field

CheckIndex Status segmentsChecked Field Lucene.Net Class Library
Empty unless you passed specific segments list to check as optional 3rd argument.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> segmentsChecked
public List<string> segmentsChecked
Public segmentsChecked As List(Of String)
Public segmentsChecked As List(Of String)
public:
List<String^>^ segmentsChecked
public:
List<String^>^ segmentsChecked
See Also
CheckIndex Status Class
CheckIndex Status Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


segmentsFileName Field

CheckIndex Status segmentsFileName Field Lucene.Net Class Library
Name of latest segments_N file in the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string segmentsFileName
public string segmentsFileName
Public segmentsFileName As String
Public segmentsFileName As String
public:
String^ segmentsFileName
public:
String^ segmentsFileName
See Also
CheckIndex Status Class
CheckIndex Status Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


toolOutOfDate Field

CheckIndex Status toolOutOfDate Field Lucene.Net Class Library
True if the index was created with a newer version of Lucene than the CheckIndex tool.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool toolOutOfDate
public bool toolOutOfDate
Public toolOutOfDate As Boolean
Public toolOutOfDate As Boolean
public:
bool toolOutOfDate
public:
bool toolOutOfDate
See Also
CheckIndex Status Class
CheckIndex Status Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


totLoseDocCount Field

CheckIndex Status totLoseDocCount Field Lucene.Net Class Library
How many documents will be lost to bad segments.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int totLoseDocCount
public int totLoseDocCount
Public totLoseDocCount As Integer
Public totLoseDocCount As Integer
public:
int totLoseDocCount
public:
int totLoseDocCount
See Also
CheckIndex Status Class
CheckIndex Status Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


userData Field

CheckIndex Status userData Field Lucene.Net Class Library
Holds the userData of the last commit in the index

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, string> userData
public IDictionary<string, string> userData
Public userData As IDictionary(Of String, String)
Public userData As IDictionary(Of String, String)
public:
IDictionary<String^, String^>^ userData
public:
IDictionary<String^, String^>^ userData
See Also
CheckIndex Status Class
CheckIndex Status Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status Methods

CheckIndex Status Methods Lucene.Net Class Library
The CheckIndex Status type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CheckIndex Status Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.FieldNormStatus Class

CheckIndex Status FieldNormStatus Class Lucene.Net Class Library
Status from testing field norms.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index CheckIndex Status FieldNormStatus

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class FieldNormStatus
public sealed class FieldNormStatus
Public NotInheritable Class FieldNormStatus
Public NotInheritable Class FieldNormStatus
public ref class FieldNormStatus sealed
public ref class FieldNormStatus sealed
See Also
CheckIndex Status FieldNormStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.FieldNormStatus Members

CheckIndex Status FieldNormStatus Members Lucene.Net Class Library

Returned from CheckIndex_Renamed_Method detailing the health and status of the index.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.

The CheckIndex Status FieldNormStatus type exposes the following members.
Constructors
 | Name | Description
Public method | CheckIndex Status FieldNormStatus | Initializes a new instance of the CheckIndex Status FieldNormStatus class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Public field | error | Exception thrown during term index test (null on success)
Public field | totFields | Number of fields successfully tested
Back to Top
See Also
CheckIndex Status FieldNormStatus Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.FieldNormStatus Constructor

CheckIndex Status FieldNormStatus Constructor Lucene.Net Class Library
Initializes a new instance of the CheckIndex Status FieldNormStatus class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldNormStatus()
public FieldNormStatus()
Public Sub New
Public Sub New
public:
FieldNormStatus()
public:
FieldNormStatus()
See Also
CheckIndex Status FieldNormStatus Class
CheckIndex Status FieldNormStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.FieldNormStatus Fields

CheckIndex Status FieldNormStatus Fields Lucene.Net Class Library
The CheckIndex Status FieldNormStatus type exposes the following members.
Fields
 | Name | Description
Public field | error | Exception thrown during term index test (null on success)
Public field | totFields | Number of fields successfully tested
Back to Top
See Also
CheckIndex Status FieldNormStatus Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


error Field

CheckIndex Status FieldNormStatus error Field Lucene.Net Class Library
Exception thrown during term index test (null on success)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception error
public Exception error
Public error As Exception
Public error As Exception
public:
Exception^ error
public:
Exception^ error
See Also
CheckIndex Status FieldNormStatus Class
CheckIndex Status FieldNormStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


totFields Field

CheckIndex Status FieldNormStatus totFields Field Lucene.Net Class Library
Number of fields successfully tested

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long totFields
public long totFields
Public totFields As Long
Public totFields As Long
public:
long long totFields
public:
long long totFields
See Also
CheckIndex Status FieldNormStatus Class
CheckIndex Status FieldNormStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.FieldNormStatus Methods

CheckIndex Status FieldNormStatus Methods Lucene.Net Class Library
The CheckIndex Status FieldNormStatus type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CheckIndex Status FieldNormStatus Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.SegmentInfoStatus Class

CheckIndex Status SegmentInfoStatus Class Lucene.Net Class Library
Holds the status of each segment in the index. See SegmentInfos.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index CheckIndex Status SegmentInfoStatus

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SegmentInfoStatus
public class SegmentInfoStatus
Public Class SegmentInfoStatus
Public Class SegmentInfoStatus
public ref class SegmentInfoStatus
public ref class SegmentInfoStatus
See Also
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.SegmentInfoStatus Members

CheckIndex Status SegmentInfoStatus Members Lucene.Net Class Library

Returned from CheckIndex_Renamed_Method detailing the health and status of the index.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.

The CheckIndex Status SegmentInfoStatus type exposes the following members.
Constructors
 | Name | Description
Public method | CheckIndex Status SegmentInfoStatus | Initializes a new instance of the CheckIndex Status SegmentInfoStatus class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Public field | compound | True if segment is compound file format.
Public field | deletionsFileName | Name of the current deletions file name.
Public field | diagnostics | Map<String, String> that includes certain debugging details that IndexWriter records into each segment it creates
Public field | docCount | Document count (does not take deletions into account).
Public field | docStoreCompoundFile | True if the shared doc store files are compound file format.
Public field | docStoreOffset | Doc store offset, if this segment shares the doc store files (stored fields and term vectors) with other segments. This is -1 if it does not share.
Public field | docStoreSegment | String of the shared doc store segment, or null if this segment does not share the doc store files.
Public field | fieldNormStatus | Status for testing of field norms (null if field norms could not be tested).
Public field | hasDeletions | True if this segment has pending deletions.
Public field | hasProx | True if at least one of the fields in this segment does not omitTermFreqAndPositions.
Public field | name | Name of the segment.
Public field | numDeleted | Number of deleted documents.
Public field | numFiles | Number of files referenced by this segment.
Public field | openReaderPassed | True if we were able to open a SegmentReader on this segment.
Public field | sizeMB | Net size (MB) of the files referenced by this segment.
Public field | storedFieldStatus | Status for testing of stored fields (null if stored fields could not be tested).
Public field | termIndexStatus | Status for testing of indexed terms (null if indexed terms could not be tested).
Public field | termVectorStatus | Status for testing of term vectors (null if term vectors could not be tested).
Back to Top
See Also
CheckIndex Status SegmentInfoStatus Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.SegmentInfoStatus Constructor

CheckIndex Status SegmentInfoStatus Constructor Lucene.Net Class Library
Initializes a new instance of the CheckIndex Status SegmentInfoStatus class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SegmentInfoStatus()
public SegmentInfoStatus()
Public Sub New
Public Sub New
public:
SegmentInfoStatus()
public:
SegmentInfoStatus()
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.SegmentInfoStatus Fields

CheckIndex Status SegmentInfoStatus Fields Lucene.Net Class Library
The CheckIndex Status SegmentInfoStatus type exposes the following members.
Fields
 | Name | Description
Public field | compound | True if segment is compound file format.
Public field | deletionsFileName | Name of the current deletions file name.
Public field | diagnostics | Map<String, String> that includes certain debugging details that IndexWriter records into each segment it creates
Public field | docCount | Document count (does not take deletions into account).
Public field | docStoreCompoundFile | True if the shared doc store files are compound file format.
Public field | docStoreOffset | Doc store offset, if this segment shares the doc store files (stored fields and term vectors) with other segments. This is -1 if it does not share.
Public field | docStoreSegment | String of the shared doc store segment, or null if this segment does not share the doc store files.
Public field | fieldNormStatus | Status for testing of field norms (null if field norms could not be tested).
Public field | hasDeletions | True if this segment has pending deletions.
Public field | hasProx | True if at least one of the fields in this segment does not omitTermFreqAndPositions.
Public field | name | Name of the segment.
Public field | numDeleted | Number of deleted documents.
Public field | numFiles | Number of files referenced by this segment.
Public field | openReaderPassed | True if we were able to open a SegmentReader on this segment.
Public field | sizeMB | Net size (MB) of the files referenced by this segment.
Public field | storedFieldStatus | Status for testing of stored fields (null if stored fields could not be tested).
Public field | termIndexStatus | Status for testing of indexed terms (null if indexed terms could not be tested).
Public field | termVectorStatus | Status for testing of term vectors (null if term vectors could not be tested).
Back to Top
See Also
CheckIndex Status SegmentInfoStatus Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


compound Field

CheckIndex Status SegmentInfoStatus compound Field Lucene.Net Class Library
True if segment is compound file format.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool compound
public bool compound
Public compound As Boolean
Public compound As Boolean
public:
bool compound
public:
bool compound
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


deletionsFileName Field

CheckIndex Status SegmentInfoStatus deletionsFileName Field Lucene.Net Class Library
Name of the current deletions file name.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string deletionsFileName
public string deletionsFileName
Public deletionsFileName As String
Public deletionsFileName As String
public:
String^ deletionsFileName
public:
String^ deletionsFileName
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


diagnostics Field

CheckIndex Status SegmentInfoStatus diagnostics Field Lucene.Net Class Library
Map<String, String> that includes certain debugging details that IndexWriter records into each segment it creates

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, string> diagnostics
public IDictionary<string, string> diagnostics
Public diagnostics As IDictionary(Of String, String)
Public diagnostics As IDictionary(Of String, String)
public:
IDictionary<String^, String^>^ diagnostics
public:
IDictionary<String^, String^>^ diagnostics
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


docCount Field

CheckIndex Status SegmentInfoStatus docCount Field Lucene.Net Class Library
Document count (does not take deletions into account).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int docCount
public int docCount
Public docCount As Integer
Public docCount As Integer
public:
int docCount
public:
int docCount
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


docStoreCompoundFile Field

CheckIndex Status SegmentInfoStatus docStoreCompoundFile Field Lucene.Net Class Library
True if the shared doc store files are compound file format.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool docStoreCompoundFile
public bool docStoreCompoundFile
Public docStoreCompoundFile As Boolean
Public docStoreCompoundFile As Boolean
public:
bool docStoreCompoundFile
public:
bool docStoreCompoundFile
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


docStoreOffset Field

CheckIndex Status SegmentInfoStatus docStoreOffset Field Lucene.Net Class Library
Doc store offset, if this segment shares the doc store files (stored fields and term vectors) with other segments. This is -1 if it does not share.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int docStoreOffset
public int docStoreOffset
Public docStoreOffset As Integer
Public docStoreOffset As Integer
public:
int docStoreOffset
public:
int docStoreOffset
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


docStoreSegment Field

CheckIndex Status SegmentInfoStatus docStoreSegment Field Lucene.Net Class Library
String of the shared doc store segment, or null if this segment does not share the doc store files.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string docStoreSegment
public string docStoreSegment
Public docStoreSegment As String
Public docStoreSegment As String
public:
String^ docStoreSegment
public:
String^ docStoreSegment
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


fieldNormStatus Field

CheckIndex Status SegmentInfoStatus fieldNormStatus Field Lucene.Net Class Library
Status for testing of field norms (null if field norms could not be tested).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CheckIndex..::..Status..::..FieldNormStatus fieldNormStatus
public CheckIndex..::..Status..::..FieldNormStatus fieldNormStatus
Public fieldNormStatus As CheckIndex..::..Status..::..FieldNormStatus
Public fieldNormStatus As CheckIndex..::..Status..::..FieldNormStatus
public:
CheckIndex..::..Status..::..FieldNormStatus^ fieldNormStatus
public:
CheckIndex..::..Status..::..FieldNormStatus^ fieldNormStatus
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


hasDeletions Field

CheckIndex Status SegmentInfoStatus hasDeletions Field Lucene.Net Class Library
True if this segment has pending deletions.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool hasDeletions
public bool hasDeletions
Public hasDeletions As Boolean
Public hasDeletions As Boolean
public:
bool hasDeletions
public:
bool hasDeletions
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


hasProx Field

CheckIndex Status SegmentInfoStatus hasProx Field Lucene.Net Class Library
True if at least one of the fields in this segment does not omitTermFreqAndPositions.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool hasProx
public bool hasProx
Public hasProx As Boolean
Public hasProx As Boolean
public:
bool hasProx
public:
bool hasProx
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
AbstractField OmitTermFreqAndPositions
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


name Field

CheckIndex Status SegmentInfoStatus name Field Lucene.Net Class Library
Name of the segment.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string name
public string name
Public name As String
Public name As String
public:
String^ name
public:
String^ name
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


numDeleted Field

CheckIndex Status SegmentInfoStatus numDeleted Field Lucene.Net Class Library
Number of deleted documents.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int numDeleted
public int numDeleted
Public numDeleted As Integer
Public numDeleted As Integer
public:
int numDeleted
public:
int numDeleted
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


numFiles Field

CheckIndex Status SegmentInfoStatus numFiles Field Lucene.Net Class Library
Number of files referenced by this segment.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int numFiles
public int numFiles
Public numFiles As Integer
Public numFiles As Integer
public:
int numFiles
public:
int numFiles
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


openReaderPassed Field

CheckIndex Status SegmentInfoStatus openReaderPassed Field Lucene.Net Class Library
True if we were able to open a SegmentReader on this segment.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool openReaderPassed
public bool openReaderPassed
Public openReaderPassed As Boolean
Public openReaderPassed As Boolean
public:
bool openReaderPassed
public:
bool openReaderPassed
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


sizeMB Field

CheckIndex Status SegmentInfoStatus sizeMB Field Lucene.Net Class Library
Net size (MB) of the files referenced by this segment.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double sizeMB
public double sizeMB
Public sizeMB As Double
Public sizeMB As Double
public:
double sizeMB
public:
double sizeMB
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


storedFieldStatus Field

CheckIndex Status SegmentInfoStatus storedFieldStatus Field Lucene.Net Class Library
Status for testing of stored fields (null if stored fields could not be tested).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CheckIndex..::..Status..::..StoredFieldStatus storedFieldStatus
public CheckIndex..::..Status..::..StoredFieldStatus storedFieldStatus
Public storedFieldStatus As CheckIndex..::..Status..::..StoredFieldStatus
Public storedFieldStatus As CheckIndex..::..Status..::..StoredFieldStatus
public:
CheckIndex..::..Status..::..StoredFieldStatus^ storedFieldStatus
public:
CheckIndex..::..Status..::..StoredFieldStatus^ storedFieldStatus
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


termIndexStatus Field

CheckIndex Status SegmentInfoStatus termIndexStatus Field Lucene.Net Class Library
Status for testing of indexed terms (null if indexed terms could not be tested).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CheckIndex..::..Status..::..TermIndexStatus termIndexStatus
public CheckIndex..::..Status..::..TermIndexStatus termIndexStatus
Public termIndexStatus As CheckIndex..::..Status..::..TermIndexStatus
Public termIndexStatus As CheckIndex..::..Status..::..TermIndexStatus
public:
CheckIndex..::..Status..::..TermIndexStatus^ termIndexStatus
public:
CheckIndex..::..Status..::..TermIndexStatus^ termIndexStatus
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


termVectorStatus Field

CheckIndex Status SegmentInfoStatus termVectorStatus Field Lucene.Net Class Library
Status for testing of term vectors (null if term vectors could not be tested).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CheckIndex..::..Status..::..TermVectorStatus termVectorStatus
public CheckIndex..::..Status..::..TermVectorStatus termVectorStatus
Public termVectorStatus As CheckIndex..::..Status..::..TermVectorStatus
Public termVectorStatus As CheckIndex..::..Status..::..TermVectorStatus
public:
CheckIndex..::..Status..::..TermVectorStatus^ termVectorStatus
public:
CheckIndex..::..Status..::..TermVectorStatus^ termVectorStatus
See Also
CheckIndex Status SegmentInfoStatus Class
CheckIndex Status SegmentInfoStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.SegmentInfoStatus Methods

CheckIndex Status SegmentInfoStatus Methods Lucene.Net Class Library
The CheckIndex Status SegmentInfoStatus type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CheckIndex Status SegmentInfoStatus Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.StoredFieldStatus Class

CheckIndex Status StoredFieldStatus Class Lucene.Net Class Library
Status from testing stored fields.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index CheckIndex Status StoredFieldStatus

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class StoredFieldStatus
public sealed class StoredFieldStatus
Public NotInheritable Class StoredFieldStatus
Public NotInheritable Class StoredFieldStatus
public ref class StoredFieldStatus sealed
public ref class StoredFieldStatus sealed
See Also
CheckIndex Status StoredFieldStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.StoredFieldStatus Members

CheckIndex Status StoredFieldStatus Members Lucene.Net Class Library

Returned from CheckIndex_Renamed_Method detailing the health and status of the index.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.

The CheckIndex Status StoredFieldStatus type exposes the following members.
Constructors
 | Name | Description
Public method | CheckIndex Status StoredFieldStatus | Initializes a new instance of the CheckIndex Status StoredFieldStatus class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Public field | docCount | Number of documents tested.
Public field | error | Exception thrown during stored fields test (null on success)
Public field | totFields | Total number of stored fields tested.
Back to Top
See Also
CheckIndex Status StoredFieldStatus Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.StoredFieldStatus Constructor

CheckIndex Status StoredFieldStatus Constructor Lucene.Net Class Library
Initializes a new instance of the CheckIndex Status StoredFieldStatus class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StoredFieldStatus()
public StoredFieldStatus()
Public Sub New
Public Sub New
public:
StoredFieldStatus()
public:
StoredFieldStatus()
See Also
CheckIndex Status StoredFieldStatus Class
CheckIndex Status StoredFieldStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.StoredFieldStatus Fields

CheckIndex Status StoredFieldStatus Fields Lucene.Net Class Library
The CheckIndex Status StoredFieldStatus type exposes the following members.
Fields
 | Name | Description
Public field | docCount | Number of documents tested.
Public field | error | Exception thrown during stored fields test (null on success)
Public field | totFields | Total number of stored fields tested.
Back to Top
See Also
CheckIndex Status StoredFieldStatus Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


docCount Field

CheckIndex Status StoredFieldStatus docCount Field Lucene.Net Class Library
Number of documents tested.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int docCount
public int docCount
Public docCount As Integer
Public docCount As Integer
public:
int docCount
public:
int docCount
See Also
CheckIndex Status StoredFieldStatus Class
CheckIndex Status StoredFieldStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


error Field

CheckIndex Status StoredFieldStatus error Field Lucene.Net Class Library
Exception thrown during stored fields test (null on success)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception error
public Exception error
Public error As Exception
Public error As Exception
public:
Exception^ error
public:
Exception^ error
See Also
CheckIndex Status StoredFieldStatus Class
CheckIndex Status StoredFieldStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


totFields Field

CheckIndex Status StoredFieldStatus totFields Field Lucene.Net Class Library
Total number of stored fields tested.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long totFields
public long totFields
Public totFields As Long
Public totFields As Long
public:
long long totFields
public:
long long totFields
See Also
CheckIndex Status StoredFieldStatus Class
CheckIndex Status StoredFieldStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.StoredFieldStatus Methods

CheckIndex Status StoredFieldStatus Methods Lucene.Net Class Library
The CheckIndex Status StoredFieldStatus type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CheckIndex Status StoredFieldStatus Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.TermIndexStatus Class

CheckIndex Status TermIndexStatus Class Lucene.Net Class Library
Status from testing term index.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index CheckIndex Status TermIndexStatus

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class TermIndexStatus
public sealed class TermIndexStatus
Public NotInheritable Class TermIndexStatus
Public NotInheritable Class TermIndexStatus
public ref class TermIndexStatus sealed
public ref class TermIndexStatus sealed
See Also
CheckIndex Status TermIndexStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.TermIndexStatus Members

CheckIndex Status TermIndexStatus Members Lucene.Net Class Library

Returned from CheckIndex_Renamed_Method detailing the health and status of the index.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.

The CheckIndex Status TermIndexStatus type exposes the following members.
Constructors
 | Name | Description
Public method | CheckIndex Status TermIndexStatus | Initializes a new instance of the CheckIndex Status TermIndexStatus class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Public field | error | Exception thrown during term index test (null on success)
Public field | termCount | Total term count
Public field | totFreq | Total frequency across all terms.
Public field | totPos | Total number of positions.
Back to Top
See Also
CheckIndex Status TermIndexStatus Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.TermIndexStatus Constructor

CheckIndex Status TermIndexStatus Constructor Lucene.Net Class Library
Initializes a new instance of the CheckIndex Status TermIndexStatus class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TermIndexStatus()
public TermIndexStatus()
Public Sub New
Public Sub New
public:
TermIndexStatus()
public:
TermIndexStatus()
See Also
CheckIndex Status TermIndexStatus Class
CheckIndex Status TermIndexStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.TermIndexStatus Fields

CheckIndex Status TermIndexStatus Fields Lucene.Net Class Library
The CheckIndex Status TermIndexStatus type exposes the following members.
Fields
 | Name | Description
Public field | error | Exception thrown during term index test (null on success)
Public field | termCount | Total term count
Public field | totFreq | Total frequency across all terms.
Public field | totPos | Total number of positions.
Back to Top
See Also
CheckIndex Status TermIndexStatus Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


error Field

CheckIndex Status TermIndexStatus error Field Lucene.Net Class Library
Exception thrown during term index test (null on success)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception error
public Exception error
Public error As Exception
Public error As Exception
public:
Exception^ error
public:
Exception^ error
See Also
CheckIndex Status TermIndexStatus Class
CheckIndex Status TermIndexStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


termCount Field

CheckIndex Status TermIndexStatus termCount Field Lucene.Net Class Library
Total term count

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long termCount
public long termCount
Public termCount As Long
Public termCount As Long
public:
long long termCount
public:
long long termCount
See Also
CheckIndex Status TermIndexStatus Class
CheckIndex Status TermIndexStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


totFreq Field

CheckIndex Status TermIndexStatus totFreq Field Lucene.Net Class Library
Total frequency across all terms.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long totFreq
public long totFreq
Public totFreq As Long
Public totFreq As Long
public:
long long totFreq
public:
long long totFreq
See Also
CheckIndex Status TermIndexStatus Class
CheckIndex Status TermIndexStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


totPos Field

CheckIndex Status TermIndexStatus totPos Field Lucene.Net Class Library
Total number of positions.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long totPos
public long totPos
Public totPos As Long
Public totPos As Long
public:
long long totPos
public:
long long totPos
See Also
CheckIndex Status TermIndexStatus Class
CheckIndex Status TermIndexStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.TermIndexStatus Methods

CheckIndex Status TermIndexStatus Methods Lucene.Net Class Library
The CheckIndex Status TermIndexStatus type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CheckIndex Status TermIndexStatus Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.TermVectorStatus Class

CheckIndex Status TermVectorStatus Class Lucene.Net Class Library
Status from testing stored fields.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index CheckIndex Status TermVectorStatus

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class TermVectorStatus
public sealed class TermVectorStatus
Public NotInheritable Class TermVectorStatus
Public NotInheritable Class TermVectorStatus
public ref class TermVectorStatus sealed
public ref class TermVectorStatus sealed
See Also
CheckIndex Status TermVectorStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.TermVectorStatus Members

CheckIndex Status TermVectorStatus Members Lucene.Net Class Library

Returned from CheckIndex_Renamed_Method detailing the health and status of the index.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.

The CheckIndex Status TermVectorStatus type exposes the following members.
Constructors
 | Name | Description
Public method | CheckIndex Status TermVectorStatus | Initializes a new instance of the CheckIndex Status TermVectorStatus class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Public field | docCount | Number of documents tested.
Public field | error | Exception thrown during term vector test (null on success)
Public field | totVectors | Total number of term vectors tested.
Back to Top
See Also
CheckIndex Status TermVectorStatus Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.TermVectorStatus Constructor

CheckIndex Status TermVectorStatus Constructor Lucene.Net Class Library
Initializes a new instance of the CheckIndex Status TermVectorStatus class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TermVectorStatus()
public TermVectorStatus()
Public Sub New
Public Sub New
public:
TermVectorStatus()
public:
TermVectorStatus()
See Also
CheckIndex Status TermVectorStatus Class
CheckIndex Status TermVectorStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.TermVectorStatus Fields

CheckIndex Status TermVectorStatus Fields Lucene.Net Class Library
The CheckIndex Status TermVectorStatus type exposes the following members.
Fields
 | Name | Description
Public field | docCount | Number of documents tested.
Public field | error | Exception thrown during term vector test (null on success)
Public field | totVectors | Total number of term vectors tested.
Back to Top
See Also
CheckIndex Status TermVectorStatus Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


docCount Field

CheckIndex Status TermVectorStatus docCount Field Lucene.Net Class Library
Number of documents tested.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int docCount
public int docCount
Public docCount As Integer
Public docCount As Integer
public:
int docCount
public:
int docCount
See Also
CheckIndex Status TermVectorStatus Class
CheckIndex Status TermVectorStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


error Field

CheckIndex Status TermVectorStatus error Field Lucene.Net Class Library
Exception thrown during term vector test (null on success)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception error
public Exception error
Public error As Exception
Public error As Exception
public:
Exception^ error
public:
Exception^ error
See Also
CheckIndex Status TermVectorStatus Class
CheckIndex Status TermVectorStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


totVectors Field

CheckIndex Status TermVectorStatus totVectors Field Lucene.Net Class Library
Total number of term vectors tested.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long totVectors
public long totVectors
Public totVectors As Long
Public totVectors As Long
public:
long long totVectors
public:
long long totVectors
See Also
CheckIndex Status TermVectorStatus Class
CheckIndex Status TermVectorStatus Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckIndex.Status.TermVectorStatus Methods

CheckIndex Status TermVectorStatus Methods Lucene.Net Class Library
The CheckIndex Status TermVectorStatus type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CheckIndex Status TermVectorStatus Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileReader Class

CompoundFileReader Class Lucene.Net Class Library
Class for accessing a compound stream. This class implements a directory, but is limited to only read operations. Directory methods that would normally modify data throw an exception.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store Directory
Lucene.Net.Index CompoundFileReader

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CompoundFileReader : Directory
public class CompoundFileReader : Directory
Public Class CompoundFileReader _
    Inherits Directory
Public Class CompoundFileReader _
    Inherits Directory
public ref class CompoundFileReader : public Directory
public ref class CompoundFileReader : public Directory
See Also
CompoundFileReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileReader Members

CompoundFileReader Members Lucene.Net Class Library

The CompoundFileReader type exposes the following members.
Constructors
 | Name | Description
Public method | CompoundFileReader(Directory, String) | Initializes a new instance of the CompoundFileReader class
Public method | CompoundFileReader(Directory, String, Int32) | Initializes a new instance of the CompoundFileReader class
Back to Top
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Obsolete. (Inherited from Directory.)
Public method | CreateOutput | Not implemented (Overrides Directory CreateOutput(String).)
Public method | DeleteFile | Not implemented (Overrides Directory DeleteFile(String).)
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CompoundFileReader and optionally releases the managed resources (Overrides Directory Dispose(Boolean).)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Overrides Directory FileExists(String).)
Public method | FileLength | Returns the length of a file in the directory. (Overrides Directory FileLength(String).)
Public method | FileModified | Returns the time the compound file was last modified. (Overrides Directory FileModified(String).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLockId | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index. (Inherited from Directory.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | ListAll | Returns an array of strings, one for each file in the directory. (Overrides Directory ListAll .)
Public method | MakeLock | Not implemented (Overrides Directory MakeLock(String).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenInput(String) | (Overrides Directory OpenInput(String).)
Public method | OpenInput(String, Int32) | (Overrides Directory OpenInput(String, Int32).)
Public method | RenameFile | Not implemented
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | Sync | Ensure that any writes to this file are moved to stable storage. Lucene uses this to properly commit changes to the index, to prevent a machine/OS crash from corrupting the index. (Inherited from Directory.)
Public method | ToString | (Inherited from Directory.)
Public method | TouchFile | Set the modified time of the compound file to now. (Overrides Directory TouchFile(String).)
Back to Top
Fields
 | Name | Description
Protected field | interalLockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)
Protected field | isOpen | (Inherited from Directory.)
Back to Top
Properties
 | Name | Description
Public property | Directory |
Public property | isOpen_ForNUnit | (Inherited from Directory.)
Public property | LockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public property | Name |
Back to Top
See Also
CompoundFileReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileReader Constructor

CompoundFileReader Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | CompoundFileReader(Directory, String) | Initializes a new instance of the CompoundFileReader class
Public method | CompoundFileReader(Directory, String, Int32) | Initializes a new instance of the CompoundFileReader class
Back to Top
See Also
CompoundFileReader Class
CompoundFileReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileReader Constructor (Directory, String)

CompoundFileReader Constructor (Directory, String) Lucene.Net Class Library
Initializes a new instance of the CompoundFileReader class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CompoundFileReader(
    Directory dir,
    string name
)
public CompoundFileReader(
    Directory dir,
    string name
)
Public Sub New ( _
    dir As Directory, _
    name As String _
)
Public Sub New ( _
    dir As Directory, _
    name As String _
)
public:
CompoundFileReader(
    Directory^ dir,
    String^ name
)
public:
CompoundFileReader(
    Directory^ dir,
    String^ name
)
Parameters
dir
Type: Lucene.Net.Store Directory
name
Type:   Online System String
See Also
CompoundFileReader Class
CompoundFileReader Members
CompoundFileReader Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileReader Constructor (Directory, String, Int32)

CompoundFileReader Constructor (Directory, String, Int32) Lucene.Net Class Library
Initializes a new instance of the CompoundFileReader class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CompoundFileReader(
    Directory dir,
    string name,
    int readBufferSize
)
public CompoundFileReader(
    Directory dir,
    string name,
    int readBufferSize
)
Public Sub New ( _
    dir As Directory, _
    name As String, _
    readBufferSize As Integer _
)
Public Sub New ( _
    dir As Directory, _
    name As String, _
    readBufferSize As Integer _
)
public:
CompoundFileReader(
    Directory^ dir,
    String^ name,
    int readBufferSize
)
public:
CompoundFileReader(
    Directory^ dir,
    String^ name,
    int readBufferSize
)
Parameters
dir
Type: Lucene.Net.Store Directory
name
Type:   Online System String
readBufferSize
Type:   Online System Int32
See Also
CompoundFileReader Class
CompoundFileReader Members
CompoundFileReader Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileReader Fields

CompoundFileReader Fields Lucene.Net Class Library
The CompoundFileReader type exposes the following members.
Fields
 | Name | Description
Protected field | interalLockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)
Protected field | isOpen | (Inherited from Directory.)
Back to Top
See Also
CompoundFileReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileReader Methods

CompoundFileReader Methods Lucene.Net Class Library
The CompoundFileReader type exposes the following members.
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Obsolete. (Inherited from Directory.)
Public method | CreateOutput | Not implemented (Overrides Directory CreateOutput(String).)
Public method | DeleteFile | Not implemented (Overrides Directory DeleteFile(String).)
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | (Overrides Directory Dispose(Boolean).)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Overrides Directory FileExists(String).)
Public method | FileLength | Returns the length of a file in the directory. (Overrides Directory FileLength(String).)
Public method | FileModified | Returns the time the compound file was last modified. (Overrides Directory FileModified(String).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLockId | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index. (Inherited from Directory.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | ListAll | Returns an array of strings, one for each file in the directory. (Overrides Directory ListAll .)
Public method | MakeLock | Not implemented (Overrides Directory MakeLock(String).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenInput(String) | (Overrides Directory OpenInput(String).)
Public method | OpenInput(String, Int32) | (Overrides Directory OpenInput(String, Int32).)
Public method | RenameFile | Not implemented
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | Sync | Ensure that any writes to this file are moved to stable storage. Lucene uses this to properly commit changes to the index, to prevent a machine/OS crash from corrupting the index. (Inherited from Directory.)
Public method | ToString | (Inherited from Directory.)
Public method | TouchFile | Set the modified time of the compound file to now. (Overrides Directory TouchFile(String).)
Back to Top
See Also
CompoundFileReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateOutput Method

CompoundFileReader CreateOutput Method Lucene.Net Class Library
Not implemented

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexOutput CreateOutput(
    string name
)
public override IndexOutput CreateOutput(
    string name
)
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
CompoundFileReader Class
CompoundFileReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DeleteFile Method

CompoundFileReader DeleteFile Method Lucene.Net Class Library
Not implemented

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void DeleteFile(
    string name
)
public override void DeleteFile(
    string name
)
Public Overrides Sub DeleteFile ( _
    name As String _
)
Public Overrides Sub DeleteFile ( _
    name As String _
)
public:
virtual void DeleteFile(
    String^ name
) override
public:
virtual void DeleteFile(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
CompoundFileReader Class
CompoundFileReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

CompoundFileReader Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CompoundFileReader and optionally releases the managed resources (Overrides Directory Dispose(Boolean).)
Back to Top
See Also
CompoundFileReader Class
CompoundFileReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

CompoundFileReader Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the CompoundFileReader and optionally releases the managed resources

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
CompoundFileReader Class
CompoundFileReader Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileExists Method

CompoundFileReader FileExists Method Lucene.Net Class Library
Returns true iff a file with the given name exists.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool FileExists(
    string name
)
public override bool FileExists(
    string name
)
Public Overrides Function FileExists ( _
    name As String _
) As Boolean
Public Overrides Function FileExists ( _
    name As String _
) As Boolean
public:
virtual bool FileExists(
    String^ name
) override
public:
virtual bool FileExists(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
CompoundFileReader Class
CompoundFileReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileLength Method

CompoundFileReader FileLength Method Lucene.Net Class Library
Returns the length of a file in the directory.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long FileLength(
    string name
)
public override long FileLength(
    string name
)
Public Overrides Function FileLength ( _
    name As String _
) As Long
Public Overrides Function FileLength ( _
    name As String _
) As Long
public:
virtual long long FileLength(
    String^ name
) override
public:
virtual long long FileLength(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
CompoundFileReader Class
CompoundFileReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileModified Method

CompoundFileReader FileModified Method Lucene.Net Class Library
Returns the time the compound file was last modified.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long FileModified(
    string name
)
public override long FileModified(
    string name
)
Public Overrides Function FileModified ( _
    name As String _
) As Long
Public Overrides Function FileModified ( _
    name As String _
) As Long
public:
virtual long long FileModified(
    String^ name
) override
public:
virtual long long FileModified(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
CompoundFileReader Class
CompoundFileReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ListAll Method

CompoundFileReader ListAll Method Lucene.Net Class Library
Returns an array of strings, one for each file in the directory.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string[] ListAll()
public override string[] ListAll()
Public Overrides Function ListAll As String()
Public Overrides Function ListAll As String()
public:
virtual array<String^>^ ListAll() override
public:
virtual array<String^>^ ListAll() override
See Also
CompoundFileReader Class
CompoundFileReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MakeLock Method

CompoundFileReader MakeLock Method Lucene.Net Class Library
Not implemented

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Lock MakeLock(
    string name
)
public override Lock MakeLock(
    string name
)
Public Overrides Function MakeLock ( _
    name As String _
) As Lock
Public Overrides Function MakeLock ( _
    name As String _
) As Lock
public:
virtual Lock^ MakeLock(
    String^ name
) override
public:
virtual Lock^ MakeLock(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
CompoundFileReader Class
CompoundFileReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenInput Method

CompoundFileReader OpenInput Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | OpenInput(String) | (Overrides Directory OpenInput(String).)
Public method | OpenInput(String, Int32) | (Overrides Directory OpenInput(String, Int32).)
Back to Top
See Also
CompoundFileReader Class
CompoundFileReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenInput Method (String)

CompoundFileReader OpenInput Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexInput OpenInput(
    string id
)
public override IndexInput OpenInput(
    string id
)
Public Overrides Function OpenInput ( _
    id As String _
) As IndexInput
Public Overrides Function OpenInput ( _
    id As String _
) As IndexInput
public:
virtual IndexInput^ OpenInput(
    String^ id
) override
public:
virtual IndexInput^ OpenInput(
    String^ id
) override
Parameters
id
Type:   Online System String
See Also
CompoundFileReader Class
CompoundFileReader Members
OpenInput Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenInput Method (String, Int32)

CompoundFileReader OpenInput Method (String, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexInput OpenInput(
    string id,
    int readBufferSize
)
public override IndexInput OpenInput(
    string id,
    int readBufferSize
)
Public Overrides Function OpenInput ( _
    id As String, _
    readBufferSize As Integer _
) As IndexInput
Public Overrides Function OpenInput ( _
    id As String, _
    readBufferSize As Integer _
) As IndexInput
public:
virtual IndexInput^ OpenInput(
    String^ id,
    int readBufferSize
) override
public:
virtual IndexInput^ OpenInput(
    String^ id,
    int readBufferSize
) override
Parameters
id
Type:   Online System String
readBufferSize
Type:   Online System Int32
See Also
CompoundFileReader Class
CompoundFileReader Members
OpenInput Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RenameFile Method

CompoundFileReader RenameFile Method Lucene.Net Class Library
Not implemented

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RenameFile(
    string from,
    string to
)
public void RenameFile(
    string from,
    string to
)
Public Sub RenameFile ( _
    from As String, _
    to As String _
)
Public Sub RenameFile ( _
    from As String, _
    to As String _
)
public:
void RenameFile(
    String^ from,
    String^ to
)
public:
void RenameFile(
    String^ from,
    String^ to
)
Parameters
from
Type:   Online System String
to
Type:   Online System String
See Also
CompoundFileReader Class
CompoundFileReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TouchFile Method

CompoundFileReader TouchFile Method Lucene.Net Class Library
Set the modified time of the compound file to now.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void TouchFile(
    string name
)
public override void TouchFile(
    string name
)
Public Overrides Sub TouchFile ( _
    name As String _
)
Public Overrides Sub TouchFile ( _
    name As String _
)
public:
virtual void TouchFile(
    String^ name
) override
public:
virtual void TouchFile(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
CompoundFileReader Class
CompoundFileReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileReader Properties

CompoundFileReader Properties Lucene.Net Class Library
The CompoundFileReader type exposes the following members.
Properties
 | Name | Description
Public property | Directory |
Public property | isOpen_ForNUnit | (Inherited from Directory.)
Public property | LockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public property | Name |
Back to Top
See Also
CompoundFileReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Directory Property

CompoundFileReader Directory Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Directory Directory { get; }
public virtual Directory Directory { get; }
Public Overridable ReadOnly Property Directory As Directory
    Get
Public Overridable ReadOnly Property Directory As Directory
    Get
public:
virtual property Directory^ Directory {
    Directory^ get ();
}
public:
virtual property Directory^ Directory {
    Directory^ get ();
}
See Also
CompoundFileReader Class
CompoundFileReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Name Property

CompoundFileReader Name Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Name { get; }
public virtual string Name { get; }
Public Overridable ReadOnly Property Name As String
    Get
Public Overridable ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get ();
}
public:
virtual property String^ Name {
    String^ get ();
}
See Also
CompoundFileReader Class
CompoundFileReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileReader.CSIndexInput Class

CompoundFileReader CSIndexInput Class Lucene.Net Class Library
Implementation of an IndexInput that reads from a portion of the compound file. The visibility is left as "package" *only* because this helps with testing since JUnit test cases in a different class can then access package fields of this class.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store IndexInput
Lucene.Net.Store BufferedIndexInput
Lucene.Net.Index CompoundFileReader CSIndexInput

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CSIndexInput : BufferedIndexInput
public sealed class CSIndexInput : BufferedIndexInput
Public NotInheritable Class CSIndexInput _
    Inherits BufferedIndexInput
Public NotInheritable Class CSIndexInput _
    Inherits BufferedIndexInput
public ref class CSIndexInput sealed : public BufferedIndexInput
public ref class CSIndexInput sealed : public BufferedIndexInput
See Also
CompoundFileReader CSIndexInput Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileReader.CSIndexInput Members

CompoundFileReader CSIndexInput Members Lucene.Net Class Library

Class for accessing a compound stream. This class implements a directory, but is limited to only read operations. Directory methods that would normally modify data throw an exception.

The CompoundFileReader CSIndexInput type exposes the following members.
Methods
 | Name | Description
Public method | Clone | (Overrides BufferedIndexInput Clone .)
Public method | Close | Obsolete. (Inherited from IndexInput.)
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CompoundFileReader CSIndexInput and optionally releases the managed resources (Overrides IndexInput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Length | (Overrides IndexInput Length .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | NewBuffer | (Inherited from BufferedIndexInput.)
Public method | ReadByte | (Inherited from BufferedIndexInput.)
Public method | ReadBytes( Byte , Int32, Int32) | (Inherited from BufferedIndexInput.)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | (Inherited from BufferedIndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadInternal | Expert: implements buffer refill. Reads bytes from the current position in the input. (Overrides BufferedIndexInput ReadInternal( Byte , Int32, Int32).)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Inherited from BufferedIndexInput.)
Public method | SeekInternal | Expert: implements seek. Sets current position in this file, where the next ReadInternal( Byte , Int32, Int32) will occur. (Overrides BufferedIndexInput SeekInternal(Int64).)
Public method | SetBufferSize | Change the buffer size used by this IndexInput (Inherited from BufferedIndexInput.)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to ReadChars( Char , Int32, Int32) but does not do any conversion operations on the bytes it is reading in. It still has to invoke ReadByte just as ReadChars( Char , Int32, Int32) does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | buffer | (Inherited from BufferedIndexInput.)
Back to Top
Properties
 | Name | Description
Public property | base_Renamed_ForNUnit |
Public property | BufferSize | (Inherited from BufferedIndexInput.)
Public property | FilePointer | (Inherited from BufferedIndexInput.)
Back to Top
See Also
CompoundFileReader CSIndexInput Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileReader.CSIndexInput Fields

CompoundFileReader CSIndexInput Fields Lucene.Net Class Library
The CompoundFileReader CSIndexInput type exposes the following members.
Fields
 | Name | Description
Protected field | buffer | (Inherited from BufferedIndexInput.)
Back to Top
See Also
CompoundFileReader CSIndexInput Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileReader.CSIndexInput Methods

CompoundFileReader CSIndexInput Methods Lucene.Net Class Library
The CompoundFileReader CSIndexInput type exposes the following members.
Methods
 | Name | Description
Public method | Clone | (Overrides BufferedIndexInput Clone .)
Public method | Close | Obsolete. (Inherited from IndexInput.)
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | (Overrides IndexInput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Length | (Overrides IndexInput Length .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | NewBuffer | (Inherited from BufferedIndexInput.)
Public method | ReadByte | (Inherited from BufferedIndexInput.)
Public method | ReadBytes( Byte , Int32, Int32) | (Inherited from BufferedIndexInput.)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | (Inherited from BufferedIndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadInternal | Expert: implements buffer refill. Reads bytes from the current position in the input. (Overrides BufferedIndexInput ReadInternal( Byte , Int32, Int32).)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Inherited from BufferedIndexInput.)
Public method | SeekInternal | Expert: implements seek. Sets current position in this file, where the next ReadInternal( Byte , Int32, Int32) will occur. (Overrides BufferedIndexInput SeekInternal(Int64).)
Public method | SetBufferSize | Change the buffer size used by this IndexInput (Inherited from BufferedIndexInput.)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to ReadChars( Char , Int32, Int32) but does not do any conversion operations on the bytes it is reading in. It still has to invoke ReadByte just as ReadChars( Char , Int32, Int32) does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CompoundFileReader CSIndexInput Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

CompoundFileReader CSIndexInput Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
CompoundFileReader CSIndexInput Class
CompoundFileReader CSIndexInput Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

CompoundFileReader CSIndexInput Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CompoundFileReader CSIndexInput and optionally releases the managed resources (Overrides IndexInput Dispose(Boolean).)
Back to Top
See Also
CompoundFileReader CSIndexInput Class
CompoundFileReader CSIndexInput Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

CompoundFileReader CSIndexInput Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the CompoundFileReader CSIndexInput and optionally releases the managed resources

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
CompoundFileReader CSIndexInput Class
CompoundFileReader CSIndexInput Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Length Method

CompoundFileReader CSIndexInput Length Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Length()
public override long Length()
Public Overrides Function Length As Long
Public Overrides Function Length As Long
public:
virtual long long Length() override
public:
virtual long long Length() override
See Also
CompoundFileReader CSIndexInput Class
CompoundFileReader CSIndexInput Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadInternal Method

CompoundFileReader CSIndexInput ReadInternal Method Lucene.Net Class Library
Expert: implements buffer refill. Reads bytes from the current position in the input.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ReadInternal(
    byte[] b,
    int offset,
    int len
)
public override void ReadInternal(
    byte[] b,
    int offset,
    int len
)
Public Overrides Sub ReadInternal ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Public Overrides Sub ReadInternal ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
public:
virtual void ReadInternal(
    array<unsigned char>^ b,
    int offset,
    int len
) override
public:
virtual void ReadInternal(
    array<unsigned char>^ b,
    int offset,
    int len
) override
Parameters
b
Type:    Online System Byte
the array to read bytes into

offset
Type:   Online System Int32
the offset in the array to start storing bytes

len
Type:   Online System Int32
the number of bytes to read

See Also
CompoundFileReader CSIndexInput Class
CompoundFileReader CSIndexInput Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SeekInternal Method

CompoundFileReader CSIndexInput SeekInternal Method Lucene.Net Class Library
Expert: implements seek. Sets current position in this file, where the next ReadInternal( Byte , Int32, Int32) will occur.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SeekInternal(
    long pos
)
public override void SeekInternal(
    long pos
)
Public Overrides Sub SeekInternal ( _
    pos As Long _
)
Public Overrides Sub SeekInternal ( _
    pos As Long _
)
public:
virtual void SeekInternal(
    long long pos
) override
public:
virtual void SeekInternal(
    long long pos
) override
Parameters
pos
Type:   Online System Int64
See Also
CompoundFileReader CSIndexInput Class
CompoundFileReader CSIndexInput Members
Lucene.Net.Index Namespace
CompoundFileReader CSIndexInput ReadInternal( Byte , Int32, Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileReader.CSIndexInput Properties

CompoundFileReader CSIndexInput Properties Lucene.Net Class Library
The CompoundFileReader CSIndexInput type exposes the following members.
Properties
 | Name | Description
Public property | base_Renamed_ForNUnit |
Public property | BufferSize | (Inherited from BufferedIndexInput.)
Public property | FilePointer | (Inherited from BufferedIndexInput.)
Back to Top
See Also
CompoundFileReader CSIndexInput Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


base_Renamed_ForNUnit Property

CompoundFileReader CSIndexInput base_Renamed_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexInput base_Renamed_ForNUnit { get; }
public IndexInput base_Renamed_ForNUnit { get; }
Public ReadOnly Property base_Renamed_ForNUnit As IndexInput
    Get
Public ReadOnly Property base_Renamed_ForNUnit As IndexInput
    Get
public:
property IndexInput^ base_Renamed_ForNUnit {
    IndexInput^ get ();
}
public:
property IndexInput^ base_Renamed_ForNUnit {
    IndexInput^ get ();
}
See Also
CompoundFileReader CSIndexInput Class
CompoundFileReader CSIndexInput Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileWriter Class

CompoundFileWriter Class Lucene.Net Class Library
Combines multiple files into a single compound file. The file format:
  • VInt fileCount
  • {Directory} fileCount entries with the following structure:
  • {File Data} fileCount entries with the raw data of the corresponding file
The fileCount integer indicates how many files are contained in this compound file. The {directory} that follows has that many entries. Each directory entry contains a long pointer to the start of this file's data section, and a String with that file's name.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index CompoundFileWriter

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CompoundFileWriter : IDisposable
public sealed class CompoundFileWriter : IDisposable
Public NotInheritable Class CompoundFileWriter _
    Implements IDisposable
Public NotInheritable Class CompoundFileWriter _
    Implements IDisposable
public ref class CompoundFileWriter sealed : IDisposable
public ref class CompoundFileWriter sealed : IDisposable
See Also
CompoundFileWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileWriter Members

CompoundFileWriter Members Lucene.Net Class Library

The CompoundFileWriter type exposes the following members.
Constructors
 | Name | Description
Public method | CompoundFileWriter | Create the compound stream in the specified file. The file name is the entire name (no extensions are added).
Back to Top
Methods
 | Name | Description
Public method | AddFile | Add a source stream. file is the string by which the sub-stream will be known in the compound stream.
Public method | Close | Obsolete.
Public method | Dispose | Merge files with the extensions added up to now. All files with these extensions are combined sequentially into the compound stream. After successful merge, the source files are deleted.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Directory | Returns the directory of the compound file.
Public property | Name | Returns the name of the compound file.
Back to Top
See Also
CompoundFileWriter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileWriter Constructor

CompoundFileWriter Constructor Lucene.Net Class Library
Create the compound stream in the specified file. The file name is the entire name (no extensions are added).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CompoundFileWriter(
    Directory dir,
    string name
)
public CompoundFileWriter(
    Directory dir,
    string name
)
Public Sub New ( _
    dir As Directory, _
    name As String _
)
Public Sub New ( _
    dir As Directory, _
    name As String _
)
public:
CompoundFileWriter(
    Directory^ dir,
    String^ name
)
public:
CompoundFileWriter(
    Directory^ dir,
    String^ name
)
Parameters
dir
Type: Lucene.Net.Store Directory
name
Type:   Online System String
See Also
CompoundFileWriter Class
CompoundFileWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileWriter Methods

CompoundFileWriter Methods Lucene.Net Class Library
The CompoundFileWriter type exposes the following members.
Methods
 | Name | Description
Public method | AddFile | Add a source stream. file is the string by which the sub-stream will be known in the compound stream.
Public method | Close | Obsolete.
Public method | Dispose | Merge files with the extensions added up to now. All files with these extensions are combined sequentially into the compound stream. After successful merge, the source files are deleted.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CompoundFileWriter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddFile Method

CompoundFileWriter AddFile Method Lucene.Net Class Library
Add a source stream. file is the string by which the sub-stream will be known in the compound stream.
has been added already

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddFile(
    string file
)
public void AddFile(
    string file
)
Public Sub AddFile ( _
    file As String _
)
Public Sub AddFile ( _
    file As String _
)
public:
void AddFile(
    String^ file
)
public:
void AddFile(
    String^ file
)
Parameters
file
Type:   Online System String
See Also
CompoundFileWriter Class
CompoundFileWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

CompoundFileWriter Close Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
See Also
CompoundFileWriter Class
CompoundFileWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

CompoundFileWriter Dispose Method Lucene.Net Class Library
Merge files with the extensions added up to now. All files with these extensions are combined sequentially into the compound stream. After successful merge, the source files are deleted.
if no file has been added to this object

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
CompoundFileWriter Class
CompoundFileWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompoundFileWriter Properties

CompoundFileWriter Properties Lucene.Net Class Library
The CompoundFileWriter type exposes the following members.
Properties
 | Name | Description
Public property | Directory | Returns the directory of the compound file.
Public property | Name | Returns the name of the compound file.
Back to Top
See Also
CompoundFileWriter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Directory Property

CompoundFileWriter Directory Property Lucene.Net Class Library
Returns the directory of the compound file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Directory Directory { get; }
public Directory Directory { get; }
Public ReadOnly Property Directory As Directory
    Get
Public ReadOnly Property Directory As Directory
    Get
public:
property Directory^ Directory {
    Directory^ get ();
}
public:
property Directory^ Directory {
    Directory^ get ();
}
See Also
CompoundFileWriter Class
CompoundFileWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Name Property

CompoundFileWriter Name Property Lucene.Net Class Library
Returns the name of the compound file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
public:
property String^ Name {
    String^ get ();
}
See Also
CompoundFileWriter Class
CompoundFileWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConcurrentMergeScheduler Class

ConcurrentMergeScheduler Class Lucene.Net Class Library
A MergeScheduler that runs each merge using a separate thread, up until a maximum number of threads (MaxThreadCount) at which when a merge is needed, the thread(s) that are updating the index will pause until one or more merges completes. This is a simple way to use concurrency in the indexing process without having to create and manage application level threads.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index MergeScheduler
Lucene.Net.Index ConcurrentMergeScheduler

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ConcurrentMergeScheduler : MergeScheduler
public class ConcurrentMergeScheduler : MergeScheduler
Public Class ConcurrentMergeScheduler _
    Inherits MergeScheduler
Public Class ConcurrentMergeScheduler _
    Inherits MergeScheduler
public ref class ConcurrentMergeScheduler : public MergeScheduler
public ref class ConcurrentMergeScheduler : public MergeScheduler
See Also
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConcurrentMergeScheduler Members

ConcurrentMergeScheduler Members Lucene.Net Class Library

The ConcurrentMergeScheduler type exposes the following members.
Constructors
 | Name | Description
Public method | ConcurrentMergeScheduler | Initializes a new instance of the ConcurrentMergeScheduler class
Back to Top
Methods
 | Name | Description
 | AnyUnhandledExceptions | Used for testing
Public method | ClearSuppressExceptions | Used for testing
 | ClearUnhandledExceptions |
Public method | Close | Obsolete. (Inherited from MergeScheduler.)
Public method | Dispose | (Inherited from MergeScheduler.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ConcurrentMergeScheduler and optionally releases the managed resources (Overrides MergeScheduler Dispose(Boolean).)
Protected method | DoMerge | Does the actual merge, by calling Merge(MergePolicy OneMerge)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Protected method | GetMergeThread | Create and return a new MergeThread
Public method | GetMergeThreadPriority | Return the priority that merge threads run at. By default the priority is 1 plus the priority of (ie, slightly higher priority than) the first thread that calls merge.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | HandleMergeException | Called when an exception is hit in a background merge thread
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Merge | (Overrides MergeScheduler Merge(IndexWriter).)
Public method | SetMergeThreadPriority | Set the priority that merge threads run at.
Public method | SetSuppressExceptions | Used for testing
 | SetTestMode |
Public method | Sync |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | dir |
Protected field | mergeThreadCount |
Protected field | mergeThreads |
Protected field | writer |
Back to Top
Properties
 | Name | Description
Public property | MaxThreadCount | Gets or sets the max # simultaneous threads that may be running. If a merge is necessary yet we already have this many threads running, the incoming thread (that is calling add/updateDocument) will block until a merge thread has completed.
Back to Top
See Also
ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConcurrentMergeScheduler Constructor

ConcurrentMergeScheduler Constructor Lucene.Net Class Library
Initializes a new instance of the ConcurrentMergeScheduler class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConcurrentMergeScheduler()
public ConcurrentMergeScheduler()
Public Sub New
Public Sub New
public:
ConcurrentMergeScheduler()
public:
ConcurrentMergeScheduler()
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConcurrentMergeScheduler Fields

ConcurrentMergeScheduler Fields Lucene.Net Class Library
The ConcurrentMergeScheduler type exposes the following members.
Fields
 | Name | Description
Protected field | dir |
Protected field | mergeThreadCount |
Protected field | mergeThreads |
Protected field | writer |
Back to Top
See Also
ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


dir Field

ConcurrentMergeScheduler dir Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Directory dir
protected Directory dir
Protected dir As Directory
Protected dir As Directory
protected:
Directory^ dir
protected:
Directory^ dir
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


mergeThreadCount Field

ConcurrentMergeScheduler mergeThreadCount Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int mergeThreadCount
protected int mergeThreadCount
Protected mergeThreadCount As Integer
Protected mergeThreadCount As Integer
protected:
int mergeThreadCount
protected:
int mergeThreadCount
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


mergeThreads Field

ConcurrentMergeScheduler mergeThreads Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IList<ConcurrentMergeScheduler..::..MergeThread> mergeThreads
protected IList<ConcurrentMergeScheduler..::..MergeThread> mergeThreads
Protected mergeThreads As IList(Of ConcurrentMergeScheduler..::..MergeThread)
Protected mergeThreads As IList(Of ConcurrentMergeScheduler..::..MergeThread)
protected:
IList<ConcurrentMergeScheduler..::..MergeThread^>^ mergeThreads
protected:
IList<ConcurrentMergeScheduler..::..MergeThread^>^ mergeThreads
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


writer Field

ConcurrentMergeScheduler writer Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IndexWriter writer
protected IndexWriter writer
Protected writer As IndexWriter
Protected writer As IndexWriter
protected:
IndexWriter^ writer
protected:
IndexWriter^ writer
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConcurrentMergeScheduler Methods

ConcurrentMergeScheduler Methods Lucene.Net Class Library
The ConcurrentMergeScheduler type exposes the following members.
Methods
 | Name | Description
 | AnyUnhandledExceptions | Used for testing
Public method | ClearSuppressExceptions | Used for testing
 | ClearUnhandledExceptions |
Public method | Close | Obsolete. (Inherited from MergeScheduler.)
Public method | Dispose | (Inherited from MergeScheduler.)
Protected method | Dispose(Boolean) | (Overrides MergeScheduler Dispose(Boolean).)
Protected method | DoMerge | Does the actual merge, by calling Merge(MergePolicy OneMerge)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Protected method | GetMergeThread | Create and return a new MergeThread
Public method | GetMergeThreadPriority | Return the priority that merge threads run at. By default the priority is 1 plus the priority of (ie, slightly higher priority than) the first thread that calls merge.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | HandleMergeException | Called when an exception is hit in a background merge thread
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Merge | (Overrides MergeScheduler Merge(IndexWriter).)
Public method | SetMergeThreadPriority | Set the priority that merge threads run at.
Public method | SetSuppressExceptions | Used for testing
 | SetTestMode |
Public method | Sync |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AnyUnhandledExceptions Method

ConcurrentMergeScheduler AnyUnhandledExceptions Method Lucene.Net Class Library
Used for testing

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool AnyUnhandledExceptions()
public static bool AnyUnhandledExceptions()
Public Shared Function AnyUnhandledExceptions As Boolean
Public Shared Function AnyUnhandledExceptions As Boolean
public:
static bool AnyUnhandledExceptions()
public:
static bool AnyUnhandledExceptions()
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ClearSuppressExceptions Method

ConcurrentMergeScheduler ClearSuppressExceptions Method Lucene.Net Class Library
Used for testing

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ClearSuppressExceptions()
public virtual void ClearSuppressExceptions()
Public Overridable Sub ClearSuppressExceptions
Public Overridable Sub ClearSuppressExceptions
public:
virtual void ClearSuppressExceptions()
public:
virtual void ClearSuppressExceptions()
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ClearUnhandledExceptions Method

ConcurrentMergeScheduler ClearUnhandledExceptions Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ClearUnhandledExceptions()
public static void ClearUnhandledExceptions()
Public Shared Sub ClearUnhandledExceptions
Public Shared Sub ClearUnhandledExceptions
public:
static void ClearUnhandledExceptions()
public:
static void ClearUnhandledExceptions()
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

ConcurrentMergeScheduler Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | (Inherited from MergeScheduler.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ConcurrentMergeScheduler and optionally releases the managed resources (Overrides MergeScheduler Dispose(Boolean).)
Back to Top
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

ConcurrentMergeScheduler Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the ConcurrentMergeScheduler and optionally releases the managed resources

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoMerge Method

ConcurrentMergeScheduler DoMerge Method Lucene.Net Class Library
Does the actual merge, by calling Merge(MergePolicy OneMerge)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoMerge(
    MergePolicy..::..OneMerge merge
)
protected virtual void DoMerge(
    MergePolicy..::..OneMerge merge
)
Protected Overridable Sub DoMerge ( _
    merge As MergePolicy..::..OneMerge _
)
Protected Overridable Sub DoMerge ( _
    merge As MergePolicy..::..OneMerge _
)
protected:
virtual void DoMerge(
    MergePolicy..::..OneMerge^ merge
)
protected:
virtual void DoMerge(
    MergePolicy..::..OneMerge^ merge
)
Parameters
merge
Type: Lucene.Net.Index MergePolicy OneMerge
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetMergeThread Method

ConcurrentMergeScheduler GetMergeThread Method Lucene.Net Class Library
Create and return a new MergeThread

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual ConcurrentMergeScheduler..::..MergeThread GetMergeThread(
    IndexWriter writer,
    MergePolicy..::..OneMerge merge
)
protected virtual ConcurrentMergeScheduler..::..MergeThread GetMergeThread(
    IndexWriter writer,
    MergePolicy..::..OneMerge merge
)
Protected Overridable Function GetMergeThread ( _
    writer As IndexWriter, _
    merge As MergePolicy..::..OneMerge _
) As ConcurrentMergeScheduler..::..MergeThread
Protected Overridable Function GetMergeThread ( _
    writer As IndexWriter, _
    merge As MergePolicy..::..OneMerge _
) As ConcurrentMergeScheduler..::..MergeThread
protected:
virtual ConcurrentMergeScheduler..::..MergeThread^ GetMergeThread(
    IndexWriter^ writer,
    MergePolicy..::..OneMerge^ merge
)
protected:
virtual ConcurrentMergeScheduler..::..MergeThread^ GetMergeThread(
    IndexWriter^ writer,
    MergePolicy..::..OneMerge^ merge
)
Parameters
writer
Type: Lucene.Net.Index IndexWriter
merge
Type: Lucene.Net.Index MergePolicy OneMerge
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetMergeThreadPriority Method

ConcurrentMergeScheduler GetMergeThreadPriority Method Lucene.Net Class Library
Return the priority that merge threads run at. By default the priority is 1 plus the priority of (ie, slightly higher priority than) the first thread that calls merge.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int GetMergeThreadPriority()
public virtual int GetMergeThreadPriority()
Public Overridable Function GetMergeThreadPriority As Integer
Public Overridable Function GetMergeThreadPriority As Integer
public:
virtual int GetMergeThreadPriority()
public:
virtual int GetMergeThreadPriority()
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HandleMergeException Method

ConcurrentMergeScheduler HandleMergeException Method Lucene.Net Class Library
Called when an exception is hit in a background merge thread

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void HandleMergeException(
    Exception exc
)
protected virtual void HandleMergeException(
    Exception exc
)
Protected Overridable Sub HandleMergeException ( _
    exc As Exception _
)
Protected Overridable Sub HandleMergeException ( _
    exc As Exception _
)
protected:
virtual void HandleMergeException(
    Exception^ exc
)
protected:
virtual void HandleMergeException(
    Exception^ exc
)
Parameters
exc
Type:   Online System Exception
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Merge Method

ConcurrentMergeScheduler Merge Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Merge(
    IndexWriter writer
)
public override void Merge(
    IndexWriter writer
)
Public Overrides Sub Merge ( _
    writer As IndexWriter _
)
Public Overrides Sub Merge ( _
    writer As IndexWriter _
)
public:
virtual void Merge(
    IndexWriter^ writer
) override
public:
virtual void Merge(
    IndexWriter^ writer
) override
Parameters
writer
Type: Lucene.Net.Index IndexWriter
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetMergeThreadPriority Method

ConcurrentMergeScheduler SetMergeThreadPriority Method Lucene.Net Class Library
Set the priority that merge threads run at.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetMergeThreadPriority(
    int pri
)
public virtual void SetMergeThreadPriority(
    int pri
)
Public Overridable Sub SetMergeThreadPriority ( _
    pri As Integer _
)
Public Overridable Sub SetMergeThreadPriority ( _
    pri As Integer _
)
public:
virtual void SetMergeThreadPriority(
    int pri
)
public:
virtual void SetMergeThreadPriority(
    int pri
)
Parameters
pri
Type:   Online System Int32
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetSuppressExceptions Method

ConcurrentMergeScheduler SetSuppressExceptions Method Lucene.Net Class Library
Used for testing

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetSuppressExceptions()
public virtual void SetSuppressExceptions()
Public Overridable Sub SetSuppressExceptions
Public Overridable Sub SetSuppressExceptions
public:
virtual void SetSuppressExceptions()
public:
virtual void SetSuppressExceptions()
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetTestMode Method

ConcurrentMergeScheduler SetTestMode Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void SetTestMode()
public static void SetTestMode()
Public Shared Sub SetTestMode
Public Shared Sub SetTestMode
public:
static void SetTestMode()
public:
static void SetTestMode()
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Sync Method

ConcurrentMergeScheduler Sync Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Sync()
public virtual void Sync()
Public Overridable Sub Sync
Public Overridable Sub Sync
public:
virtual void Sync()
public:
virtual void Sync()
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConcurrentMergeScheduler Properties

ConcurrentMergeScheduler Properties Lucene.Net Class Library
The ConcurrentMergeScheduler type exposes the following members.
Properties
 | Name | Description
Public property | MaxThreadCount | Gets or sets the max # simultaneous threads that may be running. If a merge is necessary yet we already have this many threads running, the incoming thread (that is calling add/updateDocument) will block until a merge thread has completed.
Back to Top
See Also
ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxThreadCount Property

ConcurrentMergeScheduler MaxThreadCount Property Lucene.Net Class Library
Gets or sets the max # simultaneous threads that may be running. If a merge is necessary yet we already have this many threads running, the incoming thread (that is calling add/updateDocument) will block until a merge thread has completed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int MaxThreadCount { get; set; }
public virtual int MaxThreadCount { get; set; }
Public Overridable Property MaxThreadCount As Integer
    Get
    Set
Public Overridable Property MaxThreadCount As Integer
    Get
    Set
public:
virtual property int MaxThreadCount {
    int get ();
    void set (int value);
}
public:
virtual property int MaxThreadCount {
    int get ();
    void set (int value);
}
See Also
ConcurrentMergeScheduler Class
ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConcurrentMergeScheduler.MergeThread Class

ConcurrentMergeScheduler MergeThread Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Support ThreadClass
Lucene.Net.Index ConcurrentMergeScheduler MergeThread

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MergeThread : ThreadClass
public class MergeThread : ThreadClass
Public Class MergeThread _
    Inherits ThreadClass
Public Class MergeThread _
    Inherits ThreadClass
public ref class MergeThread : public ThreadClass
public ref class MergeThread : public ThreadClass
See Also
ConcurrentMergeScheduler MergeThread Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConcurrentMergeScheduler.MergeThread Members

ConcurrentMergeScheduler MergeThread Members Lucene.Net Class Library

A MergeScheduler that runs each merge using a separate thread, up until a maximum number of threads (MaxThreadCount) at which when a merge is needed, the thread(s) that are updating the index will pause until one or more merges completes. This is a simple way to use concurrency in the indexing process without having to create and manage application level threads.

The ConcurrentMergeScheduler MergeThread type exposes the following members.
Constructors
 | Name | Description
Public method | ConcurrentMergeScheduler MergeThread | Initializes a new instance of the ConcurrentMergeScheduler MergeThread class
Back to Top
Methods
 | Name | Description
Public method | Abort | Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread (Inherited from ThreadClass.)
Public method | Abort(Object) | Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread while also providing exception information about the thread termination. Calling this method usually terminates the thread. (Inherited from ThreadClass.)
Public method | Equals | (Inherited from ThreadClass.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Inherited from ThreadClass.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Interrupt | Interrupts a thread that is in the WaitSleepJoin thread state (Inherited from ThreadClass.)
Public method | Join | Blocks the calling thread until a thread terminates (Inherited from ThreadClass.)
Public method | Join(Int64) | Blocks the calling thread until a thread terminates or the specified time elapses (Inherited from ThreadClass.)
Public method | Join(Int64, Int32) | Blocks the calling thread until a thread terminates or the specified time elapses (Inherited from ThreadClass.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Resume | Resumes a thread that has been suspended (Inherited from ThreadClass.)
Public method | Run | (Overrides ThreadClass Run .)
Public method | SetDaemon | (Inherited from ThreadClass.)
Public method | SetRunningMerge |
Public method | SetThreadPriority |
Public method | Start | Causes the operating system to change the state of the current thread instance to ThreadState.Running (Inherited from ThreadClass.)
Public method | Suspend | Suspends the thread, if the thread is already suspended it has no effect (Inherited from ThreadClass.)
Public method | ToString | (Overrides ThreadClass ToString .)
Back to Top
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Instance | Gets the current thread instance (Inherited from ThreadClass.)
Public property | IsAlive | Gets a value indicating the execution status of the current thread (Inherited from ThreadClass.)
Public property | IsBackground | Gets or sets a value indicating whether or not a thread is a background thread. (Inherited from ThreadClass.)
Public property | Name | Gets or sets the name of the thread (Inherited from ThreadClass.)
Public property | Priority | Gets or sets a value indicating the scheduling priority of a thread (Inherited from ThreadClass.)
Public property | RunningMerge |
Back to Top
See Also
ConcurrentMergeScheduler MergeThread Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConcurrentMergeScheduler.MergeThread Constructor

ConcurrentMergeScheduler MergeThread Constructor Lucene.Net Class Library
Initializes a new instance of the ConcurrentMergeScheduler MergeThread class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MergeThread(
    ConcurrentMergeScheduler enclosingInstance,
    IndexWriter writer,
    MergePolicy..::..OneMerge startMerge
)
public MergeThread(
    ConcurrentMergeScheduler enclosingInstance,
    IndexWriter writer,
    MergePolicy..::..OneMerge startMerge
)
Public Sub New ( _
    enclosingInstance As ConcurrentMergeScheduler, _
    writer As IndexWriter, _
    startMerge As MergePolicy..::..OneMerge _
)
Public Sub New ( _
    enclosingInstance As ConcurrentMergeScheduler, _
    writer As IndexWriter, _
    startMerge As MergePolicy..::..OneMerge _
)
public:
MergeThread(
    ConcurrentMergeScheduler^ enclosingInstance,
    IndexWriter^ writer,
    MergePolicy..::..OneMerge^ startMerge
)
public:
MergeThread(
    ConcurrentMergeScheduler^ enclosingInstance,
    IndexWriter^ writer,
    MergePolicy..::..OneMerge^ startMerge
)
Parameters
enclosingInstance
Type: Lucene.Net.Index ConcurrentMergeScheduler
writer
Type: Lucene.Net.Index IndexWriter
startMerge
Type: Lucene.Net.Index MergePolicy OneMerge
See Also
ConcurrentMergeScheduler MergeThread Class
ConcurrentMergeScheduler MergeThread Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConcurrentMergeScheduler.MergeThread Methods

ConcurrentMergeScheduler MergeThread Methods Lucene.Net Class Library
The ConcurrentMergeScheduler MergeThread type exposes the following members.
Methods
 | Name | Description
Public method | Abort | Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread (Inherited from ThreadClass.)
Public method | Abort(Object) | Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread while also providing exception information about the thread termination. Calling this method usually terminates the thread. (Inherited from ThreadClass.)
Public method | Equals | (Inherited from ThreadClass.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Inherited from ThreadClass.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Interrupt | Interrupts a thread that is in the WaitSleepJoin thread state (Inherited from ThreadClass.)
Public method | Join | Blocks the calling thread until a thread terminates (Inherited from ThreadClass.)
Public method | Join(Int64) | Blocks the calling thread until a thread terminates or the specified time elapses (Inherited from ThreadClass.)
Public method | Join(Int64, Int32) | Blocks the calling thread until a thread terminates or the specified time elapses (Inherited from ThreadClass.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Resume | Resumes a thread that has been suspended (Inherited from ThreadClass.)
Public method | Run | (Overrides ThreadClass Run .)
Public method | SetDaemon | (Inherited from ThreadClass.)
Public method | SetRunningMerge |
Public method | SetThreadPriority |
Public method | Start | Causes the operating system to change the state of the current thread instance to ThreadState.Running (Inherited from ThreadClass.)
Public method | Suspend | Suspends the thread, if the thread is already suspended it has no effect (Inherited from ThreadClass.)
Public method | ToString | (Overrides ThreadClass ToString .)
Back to Top
See Also
ConcurrentMergeScheduler MergeThread Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Run Method

ConcurrentMergeScheduler MergeThread Run Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Run()
public override void Run()
Public Overrides Sub Run
Public Overrides Sub Run
public:
virtual void Run() override
public:
virtual void Run() override
Implements
IThreadRunnable Run
See Also
ConcurrentMergeScheduler MergeThread Class
ConcurrentMergeScheduler MergeThread Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetRunningMerge Method

ConcurrentMergeScheduler MergeThread SetRunningMerge Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetRunningMerge(
    MergePolicy..::..OneMerge merge
)
public virtual void SetRunningMerge(
    MergePolicy..::..OneMerge merge
)
Public Overridable Sub SetRunningMerge ( _
    merge As MergePolicy..::..OneMerge _
)
Public Overridable Sub SetRunningMerge ( _
    merge As MergePolicy..::..OneMerge _
)
public:
virtual void SetRunningMerge(
    MergePolicy..::..OneMerge^ merge
)
public:
virtual void SetRunningMerge(
    MergePolicy..::..OneMerge^ merge
)
Parameters
merge
Type: Lucene.Net.Index MergePolicy OneMerge
See Also
ConcurrentMergeScheduler MergeThread Class
ConcurrentMergeScheduler MergeThread Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetThreadPriority Method

ConcurrentMergeScheduler MergeThread SetThreadPriority Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetThreadPriority(
    int pri
)
public virtual void SetThreadPriority(
    int pri
)
Public Overridable Sub SetThreadPriority ( _
    pri As Integer _
)
Public Overridable Sub SetThreadPriority ( _
    pri As Integer _
)
public:
virtual void SetThreadPriority(
    int pri
)
public:
virtual void SetThreadPriority(
    int pri
)
Parameters
pri
Type:   Online System Int32
See Also
ConcurrentMergeScheduler MergeThread Class
ConcurrentMergeScheduler MergeThread Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

ConcurrentMergeScheduler MergeThread ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
ConcurrentMergeScheduler MergeThread Class
ConcurrentMergeScheduler MergeThread Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConcurrentMergeScheduler.MergeThread Properties

ConcurrentMergeScheduler MergeThread Properties Lucene.Net Class Library
The ConcurrentMergeScheduler MergeThread type exposes the following members.
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Instance | Gets the current thread instance (Inherited from ThreadClass.)
Public property | IsAlive | Gets a value indicating the execution status of the current thread (Inherited from ThreadClass.)
Public property | IsBackground | Gets or sets a value indicating whether or not a thread is a background thread. (Inherited from ThreadClass.)
Public property | Name | Gets or sets the name of the thread (Inherited from ThreadClass.)
Public property | Priority | Gets or sets a value indicating the scheduling priority of a thread (Inherited from ThreadClass.)
Public property | RunningMerge |
Back to Top
See Also
ConcurrentMergeScheduler MergeThread Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Enclosing_Instance Property

ConcurrentMergeScheduler MergeThread Enclosing_Instance Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConcurrentMergeScheduler Enclosing_Instance { get; }
public ConcurrentMergeScheduler Enclosing_Instance { get; }
Public ReadOnly Property Enclosing_Instance As ConcurrentMergeScheduler
    Get
Public ReadOnly Property Enclosing_Instance As ConcurrentMergeScheduler
    Get
public:
property ConcurrentMergeScheduler^ Enclosing_Instance {
    ConcurrentMergeScheduler^ get ();
}
public:
property ConcurrentMergeScheduler^ Enclosing_Instance {
    ConcurrentMergeScheduler^ get ();
}
See Also
ConcurrentMergeScheduler MergeThread Class
ConcurrentMergeScheduler MergeThread Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RunningMerge Property

ConcurrentMergeScheduler MergeThread RunningMerge Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual MergePolicy..::..OneMerge RunningMerge { get; }
public virtual MergePolicy..::..OneMerge RunningMerge { get; }
Public Overridable ReadOnly Property RunningMerge As MergePolicy..::..OneMerge
    Get
Public Overridable ReadOnly Property RunningMerge As MergePolicy..::..OneMerge
    Get
public:
virtual property MergePolicy..::..OneMerge^ RunningMerge {
    MergePolicy..::..OneMerge^ get ();
}
public:
virtual property MergePolicy..::..OneMerge^ RunningMerge {
    MergePolicy..::..OneMerge^ get ();
}
See Also
ConcurrentMergeScheduler MergeThread Class
ConcurrentMergeScheduler MergeThread Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CorruptIndexException Class

CorruptIndexException Class Lucene.Net Class Library
This exception is thrown when Lucene detects an inconsistency in the index.
Inheritance Hierarchy
Online System Object
Online System Exception
Online System SystemException
Online System.IO IOException
Lucene.Net.Index CorruptIndexException

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CorruptIndexException : IOException
[SerializableAttribute]
public class CorruptIndexException : IOException
<SerializableAttribute> _
Public Class CorruptIndexException _
    Inherits IOException
<SerializableAttribute> _
Public Class CorruptIndexException _
    Inherits IOException
[SerializableAttribute]
public ref class CorruptIndexException : public IOException
[SerializableAttribute]
public ref class CorruptIndexException : public IOException
See Also
CorruptIndexException Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CorruptIndexException Members

CorruptIndexException Members Lucene.Net Class Library

The CorruptIndexException type exposes the following members.
Constructors
 | Name | Description
Public method | CorruptIndexException(String) | Initializes a new instance of the CorruptIndexException class
Public method | CorruptIndexException(String, Exception) | Initializes a new instance of the CorruptIndexException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CorruptIndexException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CorruptIndexException Constructor

CorruptIndexException Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | CorruptIndexException(String) | Initializes a new instance of the CorruptIndexException class
Public method | CorruptIndexException(String, Exception) | Initializes a new instance of the CorruptIndexException class
Back to Top
See Also
CorruptIndexException Class
CorruptIndexException Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CorruptIndexException Constructor (String)

CorruptIndexException Constructor (String) Lucene.Net Class Library
Initializes a new instance of the CorruptIndexException class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CorruptIndexException(
    string message
)
public CorruptIndexException(
    string message
)
Public Sub New ( _
    message As String _
)
Public Sub New ( _
    message As String _
)
public:
CorruptIndexException(
    String^ message
)
public:
CorruptIndexException(
    String^ message
)
Parameters
message
Type:   Online System String
See Also
CorruptIndexException Class
CorruptIndexException Members
CorruptIndexException Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CorruptIndexException Constructor (String, Exception)

CorruptIndexException Constructor (String, Exception) Lucene.Net Class Library
Initializes a new instance of the CorruptIndexException class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CorruptIndexException(
    string message,
    Exception exp
)
public CorruptIndexException(
    string message,
    Exception exp
)
Public Sub New ( _
    message As String, _
    exp As Exception _
)
Public Sub New ( _
    message As String, _
    exp As Exception _
)
public:
CorruptIndexException(
    String^ message,
    Exception^ exp
)
public:
CorruptIndexException(
    String^ message,
    Exception^ exp
)
Parameters
message
Type:   Online System String
exp
Type:   Online System Exception
See Also
CorruptIndexException Class
CorruptIndexException Members
CorruptIndexException Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CorruptIndexException Methods

CorruptIndexException Methods Lucene.Net Class Library
The CorruptIndexException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
CorruptIndexException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CorruptIndexException Properties

CorruptIndexException Properties Lucene.Net Class Library
The CorruptIndexException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
CorruptIndexException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CorruptIndexException Events

CorruptIndexException Events Lucene.Net Class Library
The CorruptIndexException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CorruptIndexException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DirectoryReader Class

DirectoryReader Class Lucene.Net Class Library
An IndexReader which reads indexes with multiple segments.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index IndexReader
Lucene.Net.Index DirectoryReader
Lucene.Net.Index ReadOnlyDirectoryReader

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DirectoryReader : IndexReader
public class DirectoryReader : IndexReader
Public Class DirectoryReader _
    Inherits IndexReader
Public Class DirectoryReader _
    Inherits IndexReader
public ref class DirectoryReader : public IndexReader
public ref class DirectoryReader : public IndexReader
See Also
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DirectoryReader Members

DirectoryReader Members Lucene.Net Class Library

The DirectoryReader type exposes the following members.
Methods
 | Name | Description
Protected method | AcquireWriteLock | Tries to acquire the WriteLock on this directory. this method is only valid if this IndexReader is directory owner. (Overrides IndexReader AcquireWriteLock .)
Public method | Clone | (Overrides IndexReader Clone .)
Public method | Clone(Boolean) | (Overrides IndexReader Clone(Boolean).)
Public method | Close | Obsolete. (Inherited from IndexReader.)
Public method | Commit | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | Commit(IDictionary String, String ) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | DecRef | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed. (Inherited from IndexReader.)
Public method | DeleteDocument | Deletes the document numbered docNum. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the Document(Int32) method will result in an error. The presence of this document may still be reflected in the DocFreq(Term) statistic, though this will be corrected eventually as the index is further modified. (Inherited from IndexReader.)
Public method | DeleteDocuments | Deletes all documents that have a given term indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See DeleteDocument(Int32) for information about when this deletion will become effective. (Inherited from IndexReader.)
Public method | Directory | Returns the directory this index resides in. (Overrides IndexReader Directory .)
Public method | Dispose | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called. (Inherited from IndexReader.)
Protected method | Dispose(Boolean) | (Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader DoClose .)
Protected method | DoCommit | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Overrides IndexReader DoCommit(IDictionary String, String ).)
Public method | Document(Int32) | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader DoDelete(Int32).)
Protected method | DoSetNorm | (Overrides IndexReader DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader DoUndeleteAll .)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Inherited from IndexReader.)
Public method | Flush(IDictionary String, String ) | (Inherited from IndexReader.)
Public method | GetFieldNames | (Overrides IndexReader GetFieldNames(IndexReader FieldOption).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSequentialSubReaders | (Overrides IndexReader GetSequentialSubReaders .)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method | GetTermFreqVectors | (Overrides IndexReader GetTermFreqVectors(Int32).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasNorms | (Overrides IndexReader HasNorms(String).)
Public method | IncRef | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding DecRef , in a finally clause; otherwise the reader may never be closed. Note that Close simply calls decRef(), which means that the IndexReader will not really be closed until DecRef has been called for all outstanding references. (Inherited from IndexReader.)
Public method | IsCurrent | (Overrides IndexReader IsCurrent .)
Public method | IsDeleted | (Overrides IndexReader IsDeleted(Int32).)
Public method | IsOptimized | Checks is the index is optimized (if it has a single segment and no deletions) (Overrides IndexReader IsOptimized .)
 | ListCommits |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Norms(String) | (Overrides IndexReader Norms(String).)
Public method | Norms(String, Byte , Int32) | (Overrides IndexReader Norms(String, Byte , Int32).)
Public method | NumDocs | (Overrides IndexReader NumDocs .)
Public method | Reopen | (Overrides IndexReader Reopen .)
Public method | Reopen(Boolean) | (Overrides IndexReader Reopen(Boolean).)
Public method | Reopen(IndexCommit) | (Overrides IndexReader Reopen(IndexCommit).)
Public method | SetNorm(Int32, String, Byte) | Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Single) | Expert: Resets the normalization factor for the named field of the named document. (Inherited from IndexReader.)
Public method | TermDocs | (Overrides IndexReader TermDocs .)
Public method | TermDocs(Term) | Returns an enumeration of all the documents which contain term. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping: Term => <docNum, freq>* The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Public method | TermPositions | (Overrides IndexReader TermPositions .)
Public method | TermPositions(Term) | Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping: Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >* This positional information facilitates phrase and proximity searching. The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Public method | Terms | (Overrides IndexReader Terms .)
Public method | Terms(Term) | (Overrides IndexReader Terms(Term).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UndeleteAll | Undeletes all documents currently marked as deleted in this index. (Inherited from IndexReader.)
Back to Top
Fields
 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | internalDirectory |
Protected field | readOnly |
Back to Top
Properties
 | Name | Description
Public property | CommitUserData | (Overrides IndexReader CommitUserData.)
Public property | DeletesCacheKey | (Inherited from IndexReader.)
Public property | FieldCacheKey | Expert (Inherited from IndexReader.)
Public property | HasDeletions | (Overrides IndexReader HasDeletions.)
Public property | IndexCommit | Expert: return the IndexCommit that this reader has opened. WARNING: this API is new and experimental and may suddenly change. (Overrides IndexReader IndexCommit.)
Public property | Item | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public property | MaxDoc | (Overrides IndexReader MaxDoc.)
Public property | NumDeletedDocs | Returns the number of deleted documents. (Inherited from IndexReader.)
Public property | RefCount | Expert: returns the current refCount for this reader (Inherited from IndexReader.)
Public property | TermInfosIndexDivisor | (Overrides IndexReader TermInfosIndexDivisor.)
Public property | UniqueTermCount | Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed. (Inherited from IndexReader.)
Public property | Version | Version number when this IndexReader was opened. (Overrides IndexReader Version.)
Back to Top
See Also
DirectoryReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DirectoryReader Fields

DirectoryReader Fields Lucene.Net Class Library
The DirectoryReader type exposes the following members.
Fields
 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | internalDirectory |
Protected field | readOnly |
Back to Top
See Also
DirectoryReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalDirectory Field

DirectoryReader internalDirectory Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Directory internalDirectory
protected Directory internalDirectory
Protected internalDirectory As Directory
Protected internalDirectory As Directory
protected:
Directory^ internalDirectory
protected:
Directory^ internalDirectory
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


readOnly Field

DirectoryReader readOnly Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool readOnly
protected bool readOnly
Protected readOnly As Boolean
Protected readOnly As Boolean
protected:
bool readOnly
protected:
bool readOnly
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DirectoryReader Methods

DirectoryReader Methods Lucene.Net Class Library
The DirectoryReader type exposes the following members.
Methods
 | Name | Description
Protected method | AcquireWriteLock | Tries to acquire the WriteLock on this directory. this method is only valid if this IndexReader is directory owner. (Overrides IndexReader AcquireWriteLock .)
Public method | Clone | (Overrides IndexReader Clone .)
Public method | Clone(Boolean) | (Overrides IndexReader Clone(Boolean).)
Public method | Close | Obsolete. (Inherited from IndexReader.)
Public method | Commit | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | Commit(IDictionary String, String ) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | DecRef | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed. (Inherited from IndexReader.)
Public method | DeleteDocument | Deletes the document numbered docNum. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the Document(Int32) method will result in an error. The presence of this document may still be reflected in the DocFreq(Term) statistic, though this will be corrected eventually as the index is further modified. (Inherited from IndexReader.)
Public method | DeleteDocuments | Deletes all documents that have a given term indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See DeleteDocument(Int32) for information about when this deletion will become effective. (Inherited from IndexReader.)
Public method | Directory | Returns the directory this index resides in. (Overrides IndexReader Directory .)
Public method | Dispose | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called. (Inherited from IndexReader.)
Protected method | Dispose(Boolean) | (Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader DoClose .)
Protected method | DoCommit | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Overrides IndexReader DoCommit(IDictionary String, String ).)
Public method | Document(Int32) | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader DoDelete(Int32).)
Protected method | DoSetNorm | (Overrides IndexReader DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader DoUndeleteAll .)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Inherited from IndexReader.)
Public method | Flush(IDictionary String, String ) | (Inherited from IndexReader.)
Public method | GetFieldNames | (Overrides IndexReader GetFieldNames(IndexReader FieldOption).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSequentialSubReaders | (Overrides IndexReader GetSequentialSubReaders .)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method | GetTermFreqVectors | (Overrides IndexReader GetTermFreqVectors(Int32).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasNorms | (Overrides IndexReader HasNorms(String).)
Public method | IncRef | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding DecRef , in a finally clause; otherwise the reader may never be closed. Note that Close simply calls decRef(), which means that the IndexReader will not really be closed until DecRef has been called for all outstanding references. (Inherited from IndexReader.)
Public method | IsCurrent | (Overrides IndexReader IsCurrent .)
Public method | IsDeleted | (Overrides IndexReader IsDeleted(Int32).)
Public method | IsOptimized | Checks is the index is optimized (if it has a single segment and no deletions) (Overrides IndexReader IsOptimized .)
 | ListCommits |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Norms(String) | (Overrides IndexReader Norms(String).)
Public method | Norms(String, Byte , Int32) | (Overrides IndexReader Norms(String, Byte , Int32).)
Public method | NumDocs | (Overrides IndexReader NumDocs .)
Public method | Reopen | (Overrides IndexReader Reopen .)
Public method | Reopen(Boolean) | (Overrides IndexReader Reopen(Boolean).)
Public method | Reopen(IndexCommit) | (Overrides IndexReader Reopen(IndexCommit).)
Public method | SetNorm(Int32, String, Byte) | Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Single) | Expert: Resets the normalization factor for the named field of the named document. (Inherited from IndexReader.)
Public method | TermDocs | (Overrides IndexReader TermDocs .)
Public method | TermDocs(Term) | Returns an enumeration of all the documents which contain term. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping: Term => <docNum, freq>* The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Public method | TermPositions | (Overrides IndexReader TermPositions .)
Public method | TermPositions(Term) | Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping: Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >* This positional information facilitates phrase and proximity searching. The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Public method | Terms | (Overrides IndexReader Terms .)
Public method | Terms(Term) | (Overrides IndexReader Terms(Term).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UndeleteAll | Undeletes all documents currently marked as deleted in this index. (Inherited from IndexReader.)
Back to Top
See Also
DirectoryReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AcquireWriteLock Method

DirectoryReader AcquireWriteLock Method Lucene.Net Class Library
Tries to acquire the WriteLock on this directory. this method is only valid if this IndexReader is directory owner.
if another writer has this index open (write.lock could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void AcquireWriteLock()
protected override void AcquireWriteLock()
Protected Overrides Sub AcquireWriteLock
Protected Overrides Sub AcquireWriteLock
protected:
virtual void AcquireWriteLock() override
protected:
virtual void AcquireWriteLock() override
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

DirectoryReader Clone Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Clone | (Overrides IndexReader Clone .)
Public method | Clone(Boolean) | (Overrides IndexReader Clone(Boolean).)
Back to Top
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

DirectoryReader Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
See Also
DirectoryReader Class
DirectoryReader Members
Clone Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method (Boolean)

DirectoryReader Clone Method (Boolean) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexReader Clone(
    bool openReadOnly
)
public override IndexReader Clone(
    bool openReadOnly
)
Public Overrides Function Clone ( _
    openReadOnly As Boolean _
) As IndexReader
Public Overrides Function Clone ( _
    openReadOnly As Boolean _
) As IndexReader
public:
virtual IndexReader^ Clone(
    bool openReadOnly
) override
public:
virtual IndexReader^ Clone(
    bool openReadOnly
) override
Parameters
openReadOnly
Type:   Online System Boolean
See Also
DirectoryReader Class
DirectoryReader Members
Clone Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Directory Method

DirectoryReader Directory Method Lucene.Net Class Library
Returns the directory this index resides in.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Directory Directory()
public override Directory Directory()
Public Overrides Function Directory As Directory
Public Overrides Function Directory As Directory
public:
virtual Directory^ Directory() override
public:
virtual Directory^ Directory() override
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocFreq Method

DirectoryReader DocFreq Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocFreq(
    Term t
)
public override int DocFreq(
    Term t
)
Public Overrides Function DocFreq ( _
    t As Term _
) As Integer
Public Overrides Function DocFreq ( _
    t As Term _
) As Integer
public:
virtual int DocFreq(
    Term^ t
) override
public:
virtual int DocFreq(
    Term^ t
) override
Parameters
t
Type: Lucene.Net.Index Term
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoClose Method

DirectoryReader DoClose Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoClose()
protected override void DoClose()
Protected Overrides Sub DoClose
Protected Overrides Sub DoClose
protected:
virtual void DoClose() override
protected:
virtual void DoClose() override
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoCommit Method

DirectoryReader DoCommit Method Lucene.Net Class Library
Commit changes resulting from delete, undeleteAll, or setNorm operations

If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoCommit(
    IDictionary<string, string> commitUserData
)
protected override void DoCommit(
    IDictionary<string, string> commitUserData
)
Protected Overrides Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
Protected Overrides Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
protected:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
) override
protected:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
) override
Parameters
commitUserData
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Method

DirectoryReader Document Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Document(Int32) | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader Document(Int32, FieldSelector).)
Back to Top
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Method (Int32, FieldSelector)

DirectoryReader Document Method (Int32, FieldSelector) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Document Document(
    int n,
    FieldSelector fieldSelector
)
public override Document Document(
    int n,
    FieldSelector fieldSelector
)
Public Overrides Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Public Overrides Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) override
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) override
Parameters
n
Type:   Online System Int32
fieldSelector
Type: Lucene.Net.Documents FieldSelector
See Also
DirectoryReader Class
DirectoryReader Members
Document Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoDelete Method

DirectoryReader DoDelete Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoDelete(
    int n
)
protected override void DoDelete(
    int n
)
Protected Overrides Sub DoDelete ( _
    n As Integer _
)
Protected Overrides Sub DoDelete ( _
    n As Integer _
)
protected:
virtual void DoDelete(
    int n
) override
protected:
virtual void DoDelete(
    int n
) override
Parameters
n
Type:   Online System Int32
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoSetNorm Method

DirectoryReader DoSetNorm Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSetNorm(
    int n,
    string field,
    byte value_Renamed
)
protected override void DoSetNorm(
    int n,
    string field,
    byte value_Renamed
)
Protected Overrides Sub DoSetNorm ( _
    n As Integer, _
    field As String, _
    value_Renamed As Byte _
)
Protected Overrides Sub DoSetNorm ( _
    n As Integer, _
    field As String, _
    value_Renamed As Byte _
)
protected:
virtual void DoSetNorm(
    int n,
    String^ field,
    unsigned char value_Renamed
) override
protected:
virtual void DoSetNorm(
    int n,
    String^ field,
    unsigned char value_Renamed
) override
Parameters
n
Type:   Online System Int32
field
Type:   Online System String
value_Renamed
Type:   Online System Byte
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoUndeleteAll Method

DirectoryReader DoUndeleteAll Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoUndeleteAll()
protected override void DoUndeleteAll()
Protected Overrides Sub DoUndeleteAll
Protected Overrides Sub DoUndeleteAll
protected:
virtual void DoUndeleteAll() override
protected:
virtual void DoUndeleteAll() override
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFieldNames Method

DirectoryReader GetFieldNames Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fieldNames
)
public override ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fieldNames
)
Public Overrides Function GetFieldNames ( _
    fieldNames As IndexReader..::..FieldOption _
) As ICollection(Of String)
Public Overrides Function GetFieldNames ( _
    fieldNames As IndexReader..::..FieldOption _
) As ICollection(Of String)
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fieldNames
) override
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fieldNames
) override
Parameters
fieldNames
Type: Lucene.Net.Index IndexReader FieldOption
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSequentialSubReaders Method

DirectoryReader GetSequentialSubReaders Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexReader[] GetSequentialSubReaders()
public override IndexReader[] GetSequentialSubReaders()
Public Overrides Function GetSequentialSubReaders As IndexReader()
Public Overrides Function GetSequentialSubReaders As IndexReader()
public:
virtual array<IndexReader^>^ GetSequentialSubReaders() override
public:
virtual array<IndexReader^>^ GetSequentialSubReaders() override
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method

DirectoryReader GetTermFreqVector Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, String, TermVectorMapper).)
Back to Top
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, TermVectorMapper)

DirectoryReader GetTermFreqVector Method (Int32, TermVectorMapper) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
public override void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) override
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) override
Parameters
docNumber
Type:   Online System Int32
mapper
Type: Lucene.Net.Index TermVectorMapper
See Also
DirectoryReader Class
DirectoryReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, String)

DirectoryReader GetTermFreqVector Method (Int32, String) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ITermFreqVector GetTermFreqVector(
    int n,
    string field
)
public override ITermFreqVector GetTermFreqVector(
    int n,
    string field
)
Public Overrides Function GetTermFreqVector ( _
    n As Integer, _
    field As String _
) As ITermFreqVector
Public Overrides Function GetTermFreqVector ( _
    n As Integer, _
    field As String _
) As ITermFreqVector
public:
virtual ITermFreqVector^ GetTermFreqVector(
    int n,
    String^ field
) override
public:
virtual ITermFreqVector^ GetTermFreqVector(
    int n,
    String^ field
) override
Parameters
n
Type:   Online System Int32
field
Type:   Online System String
See Also
DirectoryReader Class
DirectoryReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, String, TermVectorMapper)

DirectoryReader GetTermFreqVector Method (Int32, String, TermVectorMapper) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
public override void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) override
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) override
Parameters
docNumber
Type:   Online System Int32
field
Type:   Online System String
mapper
Type: Lucene.Net.Index TermVectorMapper
See Also
DirectoryReader Class
DirectoryReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVectors Method

DirectoryReader GetTermFreqVectors Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ITermFreqVector[] GetTermFreqVectors(
    int n
)
public override ITermFreqVector[] GetTermFreqVectors(
    int n
)
Public Overrides Function GetTermFreqVectors ( _
    n As Integer _
) As ITermFreqVector()
Public Overrides Function GetTermFreqVectors ( _
    n As Integer _
) As ITermFreqVector()
public:
virtual array<ITermFreqVector^>^ GetTermFreqVectors(
    int n
) override
public:
virtual array<ITermFreqVector^>^ GetTermFreqVectors(
    int n
) override
Parameters
n
Type:   Online System Int32
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasNorms Method

DirectoryReader HasNorms Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool HasNorms(
    string field
)
public override bool HasNorms(
    string field
)
Public Overrides Function HasNorms ( _
    field As String _
) As Boolean
Public Overrides Function HasNorms ( _
    field As String _
) As Boolean
public:
virtual bool HasNorms(
    String^ field
) override
public:
virtual bool HasNorms(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsCurrent Method

DirectoryReader IsCurrent Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsCurrent()
public override bool IsCurrent()
Public Overrides Function IsCurrent As Boolean
Public Overrides Function IsCurrent As Boolean
public:
virtual bool IsCurrent() override
public:
virtual bool IsCurrent() override
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsDeleted Method

DirectoryReader IsDeleted Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsDeleted(
    int n
)
public override bool IsDeleted(
    int n
)
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
public:
virtual bool IsDeleted(
    int n
) override
public:
virtual bool IsDeleted(
    int n
) override
Parameters
n
Type:   Online System Int32
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsOptimized Method

DirectoryReader IsOptimized Method Lucene.Net Class Library
Checks is the index is optimized (if it has a single segment and no deletions)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsOptimized()
public override bool IsOptimized()
Public Overrides Function IsOptimized As Boolean
Public Overrides Function IsOptimized As Boolean
public:
virtual bool IsOptimized() override
public:
virtual bool IsOptimized() override
Return Value
 &lt;c&gt;true&lt;/c&gt; if the index is optimized; &lt;c&gt;false&lt;/c&gt; otherwise
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ListCommits Method

DirectoryReader ListCommits Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection<IndexCommit> ListCommits(
    Directory dir
)
public static ICollection<IndexCommit> ListCommits(
    Directory dir
)
Public Shared Function ListCommits ( _
    dir As Directory _
) As ICollection(Of IndexCommit)
Public Shared Function ListCommits ( _
    dir As Directory _
) As ICollection(Of IndexCommit)
public:
static ICollection<IndexCommit^>^ ListCommits(
    Directory^ dir
)
public:
static ICollection<IndexCommit^>^ ListCommits(
    Directory^ dir
)
Parameters
dir
Type: Lucene.Net.Store Directory
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
IndexReader ListCommits(Directory)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method

DirectoryReader Norms Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Norms(String) | (Overrides IndexReader Norms(String).)
Public method | Norms(String, Byte , Int32) | (Overrides IndexReader Norms(String, Byte , Int32).)
Back to Top
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method (String)

DirectoryReader Norms Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override byte[] Norms(
    string field
)
public override byte[] Norms(
    string field
)
Public Overrides Function Norms ( _
    field As String _
) As Byte()
Public Overrides Function Norms ( _
    field As String _
) As Byte()
public:
virtual array<unsigned char>^ Norms(
    String^ field
) override
public:
virtual array<unsigned char>^ Norms(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
DirectoryReader Class
DirectoryReader Members
Norms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method (String, Byte[], Int32)

DirectoryReader Norms Method (String, Byte , Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Norms(
    string field,
    byte[] result,
    int offset
)
public override void Norms(
    string field,
    byte[] result,
    int offset
)
Public Overrides Sub Norms ( _
    field As String, _
    result As Byte(), _
    offset As Integer _
)
Public Overrides Sub Norms ( _
    field As String, _
    result As Byte(), _
    offset As Integer _
)
public:
virtual void Norms(
    String^ field,
    array<unsigned char>^ result,
    int offset
) override
public:
virtual void Norms(
    String^ field,
    array<unsigned char>^ result,
    int offset
) override
Parameters
field
Type:   Online System String
result
Type:    Online System Byte
offset
Type:   Online System Int32
See Also
DirectoryReader Class
DirectoryReader Members
Norms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumDocs Method

DirectoryReader NumDocs Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int NumDocs()
public override int NumDocs()
Public Overrides Function NumDocs As Integer
Public Overrides Function NumDocs As Integer
public:
virtual int NumDocs() override
public:
virtual int NumDocs() override
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reopen Method

DirectoryReader Reopen Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Reopen | (Overrides IndexReader Reopen .)
Public method | Reopen(Boolean) | (Overrides IndexReader Reopen(Boolean).)
Public method | Reopen(IndexCommit) | (Overrides IndexReader Reopen(IndexCommit).)
Back to Top
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reopen Method

DirectoryReader Reopen Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexReader Reopen()
public override IndexReader Reopen()
Public Overrides Function Reopen As IndexReader
Public Overrides Function Reopen As IndexReader
public:
virtual IndexReader^ Reopen() override
public:
virtual IndexReader^ Reopen() override
See Also
DirectoryReader Class
DirectoryReader Members
Reopen Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reopen Method (Boolean)

DirectoryReader Reopen Method (Boolean) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexReader Reopen(
    bool openReadOnly
)
public override IndexReader Reopen(
    bool openReadOnly
)
Public Overrides Function Reopen ( _
    openReadOnly As Boolean _
) As IndexReader
Public Overrides Function Reopen ( _
    openReadOnly As Boolean _
) As IndexReader
public:
virtual IndexReader^ Reopen(
    bool openReadOnly
) override
public:
virtual IndexReader^ Reopen(
    bool openReadOnly
) override
Parameters
openReadOnly
Type:   Online System Boolean
See Also
DirectoryReader Class
DirectoryReader Members
Reopen Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reopen Method (IndexCommit)

DirectoryReader Reopen Method (IndexCommit) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexReader Reopen(
    IndexCommit commit
)
public override IndexReader Reopen(
    IndexCommit commit
)
Public Overrides Function Reopen ( _
    commit As IndexCommit _
) As IndexReader
Public Overrides Function Reopen ( _
    commit As IndexCommit _
) As IndexReader
public:
virtual IndexReader^ Reopen(
    IndexCommit^ commit
) override
public:
virtual IndexReader^ Reopen(
    IndexCommit^ commit
) override
Parameters
commit
Type: Lucene.Net.Index IndexCommit
See Also
DirectoryReader Class
DirectoryReader Members
Reopen Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Method

DirectoryReader TermDocs Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TermDocs | (Overrides IndexReader TermDocs .)
Public method | TermDocs(Term) | Returns an enumeration of all the documents which contain term. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping: Term => <docNum, freq>* The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Back to Top
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Method

DirectoryReader TermDocs Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermDocs TermDocs()
public override TermDocs TermDocs()
Public Overrides Function TermDocs As TermDocs
Public Overrides Function TermDocs As TermDocs
public:
virtual TermDocs^ TermDocs() override
public:
virtual TermDocs^ TermDocs() override
See Also
DirectoryReader Class
DirectoryReader Members
TermDocs Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Method

DirectoryReader TermPositions Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TermPositions | (Overrides IndexReader TermPositions .)
Public method | TermPositions(Term) | Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping: Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >* This positional information facilitates phrase and proximity searching. The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Back to Top
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Method

DirectoryReader TermPositions Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermPositions TermPositions()
public override TermPositions TermPositions()
Public Overrides Function TermPositions As TermPositions
Public Overrides Function TermPositions As TermPositions
public:
virtual TermPositions^ TermPositions() override
public:
virtual TermPositions^ TermPositions() override
See Also
DirectoryReader Class
DirectoryReader Members
TermPositions Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method

DirectoryReader Terms Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Terms | (Overrides IndexReader Terms .)
Public method | Terms(Term) | (Overrides IndexReader Terms(Term).)
Back to Top
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method

DirectoryReader Terms Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermEnum Terms()
public override TermEnum Terms()
Public Overrides Function Terms As TermEnum
Public Overrides Function Terms As TermEnum
public:
virtual TermEnum^ Terms() override
public:
virtual TermEnum^ Terms() override
See Also
DirectoryReader Class
DirectoryReader Members
Terms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method (Term)

DirectoryReader Terms Method (Term) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermEnum Terms(
    Term term
)
public override TermEnum Terms(
    Term term
)
Public Overrides Function Terms ( _
    term As Term _
) As TermEnum
Public Overrides Function Terms ( _
    term As Term _
) As TermEnum
public:
virtual TermEnum^ Terms(
    Term^ term
) override
public:
virtual TermEnum^ Terms(
    Term^ term
) override
Parameters
term
Type: Lucene.Net.Index Term
See Also
DirectoryReader Class
DirectoryReader Members
Terms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DirectoryReader Properties

DirectoryReader Properties Lucene.Net Class Library
The DirectoryReader type exposes the following members.
Properties
 | Name | Description
Public property | CommitUserData | (Overrides IndexReader CommitUserData.)
Public property | DeletesCacheKey | (Inherited from IndexReader.)
Public property | FieldCacheKey | Expert (Inherited from IndexReader.)
Public property | HasDeletions | (Overrides IndexReader HasDeletions.)
Public property | IndexCommit | Expert: return the IndexCommit that this reader has opened. WARNING: this API is new and experimental and may suddenly change. (Overrides IndexReader IndexCommit.)
Public property | Item | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public property | MaxDoc | (Overrides IndexReader MaxDoc.)
Public property | NumDeletedDocs | Returns the number of deleted documents. (Inherited from IndexReader.)
Public property | RefCount | Expert: returns the current refCount for this reader (Inherited from IndexReader.)
Public property | TermInfosIndexDivisor | (Overrides IndexReader TermInfosIndexDivisor.)
Public property | UniqueTermCount | Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed. (Inherited from IndexReader.)
Public property | Version | Version number when this IndexReader was opened. (Overrides IndexReader Version.)
Back to Top
See Also
DirectoryReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CommitUserData Property

DirectoryReader CommitUserData Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IDictionary<string, string> CommitUserData { get; }
public override IDictionary<string, string> CommitUserData { get; }
Public Overrides ReadOnly Property CommitUserData As IDictionary(Of String, String)
    Get
Public Overrides ReadOnly Property CommitUserData As IDictionary(Of String, String)
    Get
public:
virtual property IDictionary<String^, String^>^ CommitUserData {
    IDictionary<String^, String^>^ get () override;
}
public:
virtual property IDictionary<String^, String^>^ CommitUserData {
    IDictionary<String^, String^>^ get () override;
}
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasDeletions Property

DirectoryReader HasDeletions Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool HasDeletions { get; }
public override bool HasDeletions { get; }
Public Overrides ReadOnly Property HasDeletions As Boolean
    Get
Public Overrides ReadOnly Property HasDeletions As Boolean
    Get
public:
virtual property bool HasDeletions {
    bool get () override;
}
public:
virtual property bool HasDeletions {
    bool get () override;
}
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexCommit Property

DirectoryReader IndexCommit Property Lucene.Net Class Library
Expert: return the IndexCommit that this reader has opened.

WARNING: this API is new and experimental and may suddenly change.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexCommit IndexCommit { get; }
public override IndexCommit IndexCommit { get; }
Public Overrides ReadOnly Property IndexCommit As IndexCommit
    Get
Public Overrides ReadOnly Property IndexCommit As IndexCommit
    Get
public:
virtual property IndexCommit^ IndexCommit {
    IndexCommit^ get () override;
}
public:
virtual property IndexCommit^ IndexCommit {
    IndexCommit^ get () override;
}
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxDoc Property

DirectoryReader MaxDoc Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int MaxDoc { get; }
public override int MaxDoc { get; }
Public Overrides ReadOnly Property MaxDoc As Integer
    Get
Public Overrides ReadOnly Property MaxDoc As Integer
    Get
public:
virtual property int MaxDoc {
    int get () override;
}
public:
virtual property int MaxDoc {
    int get () override;
}
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermInfosIndexDivisor Property

DirectoryReader TermInfosIndexDivisor Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int TermInfosIndexDivisor { get; }
public override int TermInfosIndexDivisor { get; }
Public Overrides ReadOnly Property TermInfosIndexDivisor As Integer
    Get
Public Overrides ReadOnly Property TermInfosIndexDivisor As Integer
    Get
public:
virtual property int TermInfosIndexDivisor {
    int get () override;
}
public:
virtual property int TermInfosIndexDivisor {
    int get () override;
}
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Version Property

DirectoryReader Version Property Lucene.Net Class Library
Version number when this IndexReader was opened.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Version { get; }
public override long Version { get; }
Public Overrides ReadOnly Property Version As Long
    Get
Public Overrides ReadOnly Property Version As Long
    Get
public:
virtual property long long Version {
    long long get () override;
}
public:
virtual property long long Version {
    long long get () override;
}
See Also
DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocumentsWriter Class

DocumentsWriter Class Lucene.Net Class Library
This class accepts multiple added documents and directly writes a single segment file. It does this more efficiently than creating a single segment per document (with DocumentWriter) and doing standard merges on those segments. Each added document is passed to the DocConsumer, which in turn processes the document and interacts with other consumers in the indexing chain. Certain consumers, like StoredFieldsWriter and TermVectorsTermsWriter , digest a document and immediately write bytes to the "doc store" files (ie, they do not consume RAM per document, except while they are processing the document). Other consumers, eg FreqProxTermsWriter and NormsWriter, buffer bytes in RAM and flush only when a new segment is produced. Once we have used our allowed RAM buffer, or the number of added docs is large enough (in the case we are flushing by doc count instead of RAM usage), we create a real segment and flush it to the Directory. Threads: Multiple threads are allowed into addDocument at once. There is an initial synchronized call to getThreadState which allocates a ThreadState for this thread. The same thread will get the same ThreadState over time (thread affinity) so that if there are consistent patterns (for example each thread is indexing a different content source) then we make better use of RAM. Then processDocument is called on that ThreadState without synchronization (most of the "heavy lifting" is in this call). Finally the synchronized "finishDocument" is called to flush changes to the directory. When flush is called by IndexWriter we forcefully idle all threads and flush only once they are all idle. This means you can call flush with a given thread even while other threads are actively adding/deleting documents. Exceptions: Because this class directly updates in-memory posting lists, and flushes stored fields and term vectors directly to files in the directory, there are certain limited times when an exception can corrupt this state. For example, a disk full while flushing stored fields leaves this file in a corrupt state. Or, an OOM exception while appending to the in-memory posting lists can corrupt that posting list. We call such exceptions "aborting exceptions". In these cases we must call abort() to discard all docs added since the last flush. All other exceptions ("non-aborting exceptions") can still partially update the index structures. These updates are consistent, but, they represent only a part of the document seen up until the exception was hit. When this happens, we immediately mark the document as deleted so that the document is always atomically ("all or none") added to the index.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index DocumentsWriter

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class DocumentsWriter : IDisposable
public sealed class DocumentsWriter : IDisposable
Public NotInheritable Class DocumentsWriter _
    Implements IDisposable
Public NotInheritable Class DocumentsWriter _
    Implements IDisposable
public ref class DocumentsWriter sealed : IDisposable
public ref class DocumentsWriter sealed : IDisposable
See Also
DocumentsWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocumentsWriter Members

DocumentsWriter Members Lucene.Net Class Library

The DocumentsWriter type exposes the following members.
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DocumentsWriter
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
Name | Description
BYTE_BLOCK_SIZE_ForNUnit |
CHAR_BLOCK_SIZE_ForNUnit |
Back to Top
See Also
DocumentsWriter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocumentsWriter Methods

DocumentsWriter Methods Lucene.Net Class Library
The DocumentsWriter type exposes the following members.
Methods
 | Name | Description
Public method | Dispose |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DocumentsWriter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

DocumentsWriter Dispose Method Lucene.Net Class Library
Releases all resources used by the DocumentsWriter

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
DocumentsWriter Class
DocumentsWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocumentsWriter Properties

DocumentsWriter Properties Lucene.Net Class Library
The DocumentsWriter type exposes the following members.
Properties
Name | Description
BYTE_BLOCK_SIZE_ForNUnit |
CHAR_BLOCK_SIZE_ForNUnit |
Back to Top
See Also
DocumentsWriter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BYTE_BLOCK_SIZE_ForNUnit Property

DocumentsWriter BYTE_BLOCK_SIZE_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int BYTE_BLOCK_SIZE_ForNUnit { get; }
public static int BYTE_BLOCK_SIZE_ForNUnit { get; }
Public Shared ReadOnly Property BYTE_BLOCK_SIZE_ForNUnit As Integer
    Get
Public Shared ReadOnly Property BYTE_BLOCK_SIZE_ForNUnit As Integer
    Get
public:
static property int BYTE_BLOCK_SIZE_ForNUnit {
    int get ();
}
public:
static property int BYTE_BLOCK_SIZE_ForNUnit {
    int get ();
}
See Also
DocumentsWriter Class
DocumentsWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CHAR_BLOCK_SIZE_ForNUnit Property

DocumentsWriter CHAR_BLOCK_SIZE_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int CHAR_BLOCK_SIZE_ForNUnit { get; }
public static int CHAR_BLOCK_SIZE_ForNUnit { get; }
Public Shared ReadOnly Property CHAR_BLOCK_SIZE_ForNUnit As Integer
    Get
Public Shared ReadOnly Property CHAR_BLOCK_SIZE_ForNUnit As Integer
    Get
public:
static property int CHAR_BLOCK_SIZE_ForNUnit {
    int get ();
}
public:
static property int CHAR_BLOCK_SIZE_ForNUnit {
    int get ();
}
See Also
DocumentsWriter Class
DocumentsWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInfo Class

FieldInfo Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Index FieldInfo

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class FieldInfo : ICloneable
public sealed class FieldInfo : ICloneable
Public NotInheritable Class FieldInfo _
    Implements ICloneable
Public NotInheritable Class FieldInfo _
    Implements ICloneable
public ref class FieldInfo sealed : ICloneable
public ref class FieldInfo sealed : ICloneable
See Also
FieldInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInfo Members

FieldInfo Members Lucene.Net Class Library

The FieldInfo type exposes the following members.
Methods
 | Name | Description
Public method | Clone |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | isIndexed_ForNUnit |
Public property | name_ForNUnit |
Public property | omitNorms_ForNUnit |
Public property | omitTermFreqAndPositions_ForNUnit |
Public property | storePayloads_ForNUnit |
Public property | storeTermVector_ForNUnit |
Back to Top
See Also
FieldInfo Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInfo Methods

FieldInfo Methods Lucene.Net Class Library
The FieldInfo type exposes the following members.
Methods
 | Name | Description
Public method | Clone |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldInfo Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

FieldInfo Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Clone()
public Object Clone()
Public Function Clone As Object
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
public:
virtual Object^ Clone() sealed
Implements
  Online ICloneable Clone
See Also
FieldInfo Class
FieldInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInfo Properties

FieldInfo Properties Lucene.Net Class Library
The FieldInfo type exposes the following members.
Properties
 | Name | Description
Public property | isIndexed_ForNUnit |
Public property | name_ForNUnit |
Public property | omitNorms_ForNUnit |
Public property | omitTermFreqAndPositions_ForNUnit |
Public property | storePayloads_ForNUnit |
Public property | storeTermVector_ForNUnit |
Back to Top
See Also
FieldInfo Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


isIndexed_ForNUnit Property

FieldInfo isIndexed_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool isIndexed_ForNUnit { get; }
public bool isIndexed_ForNUnit { get; }
Public ReadOnly Property isIndexed_ForNUnit As Boolean
    Get
Public ReadOnly Property isIndexed_ForNUnit As Boolean
    Get
public:
property bool isIndexed_ForNUnit {
    bool get ();
}
public:
property bool isIndexed_ForNUnit {
    bool get ();
}
See Also
FieldInfo Class
FieldInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


name_ForNUnit Property

FieldInfo name_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string name_ForNUnit { get; }
public string name_ForNUnit { get; }
Public ReadOnly Property name_ForNUnit As String
    Get
Public ReadOnly Property name_ForNUnit As String
    Get
public:
property String^ name_ForNUnit {
    String^ get ();
}
public:
property String^ name_ForNUnit {
    String^ get ();
}
See Also
FieldInfo Class
FieldInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


omitNorms_ForNUnit Property

FieldInfo omitNorms_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool omitNorms_ForNUnit { get; }
public bool omitNorms_ForNUnit { get; }
Public ReadOnly Property omitNorms_ForNUnit As Boolean
    Get
Public ReadOnly Property omitNorms_ForNUnit As Boolean
    Get
public:
property bool omitNorms_ForNUnit {
    bool get ();
}
public:
property bool omitNorms_ForNUnit {
    bool get ();
}
See Also
FieldInfo Class
FieldInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


omitTermFreqAndPositions_ForNUnit Property

FieldInfo omitTermFreqAndPositions_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool omitTermFreqAndPositions_ForNUnit { get; }
public bool omitTermFreqAndPositions_ForNUnit { get; }
Public ReadOnly Property omitTermFreqAndPositions_ForNUnit As Boolean
    Get
Public ReadOnly Property omitTermFreqAndPositions_ForNUnit As Boolean
    Get
public:
property bool omitTermFreqAndPositions_ForNUnit {
    bool get ();
}
public:
property bool omitTermFreqAndPositions_ForNUnit {
    bool get ();
}
See Also
FieldInfo Class
FieldInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


storePayloads_ForNUnit Property

FieldInfo storePayloads_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool storePayloads_ForNUnit { get; }
public bool storePayloads_ForNUnit { get; }
Public ReadOnly Property storePayloads_ForNUnit As Boolean
    Get
Public ReadOnly Property storePayloads_ForNUnit As Boolean
    Get
public:
property bool storePayloads_ForNUnit {
    bool get ();
}
public:
property bool storePayloads_ForNUnit {
    bool get ();
}
See Also
FieldInfo Class
FieldInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


storeTermVector_ForNUnit Property

FieldInfo storeTermVector_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool storeTermVector_ForNUnit { get; }
public bool storeTermVector_ForNUnit { get; }
Public ReadOnly Property storeTermVector_ForNUnit As Boolean
    Get
Public ReadOnly Property storeTermVector_ForNUnit As Boolean
    Get
public:
property bool storeTermVector_ForNUnit {
    bool get ();
}
public:
property bool storeTermVector_ForNUnit {
    bool get ();
}
See Also
FieldInfo Class
FieldInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInfos Class

FieldInfos Class Lucene.Net Class Library
Access to the Fieldable Info file that describes document fields and whether or not they are indexed. Each segment has a separate Fieldable Info file. Objects of this class are thread-safe for multiple readers, but only one thread can be adding documents at a time, with no other reader or writer threads accessing this object.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index FieldInfos

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class FieldInfos : ICloneable
public sealed class FieldInfos : ICloneable
Public NotInheritable Class FieldInfos _
    Implements ICloneable
Public NotInheritable Class FieldInfos _
    Implements ICloneable
public ref class FieldInfos sealed : ICloneable
public ref class FieldInfos sealed : ICloneable
See Also
FieldInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInfos Members

FieldInfos Members Lucene.Net Class Library

The FieldInfos type exposes the following members.
Constructors
 | Name | Description
Public method | FieldInfos | Initializes a new instance of the FieldInfos class
Public method | FieldInfos(Directory, String) | Construct a FieldInfos object using the directory and the name of the file IndexInput
Back to Top
Methods
 | Name | Description
Public method | Add(Document) | Adds field info for a Document.
Public method | Add(ICollection String , Boolean) | Assumes the fields are not storing term vectors.
Public method | Add(String, Boolean) | Calls 5 parameter add with false for all TermVector parameters.
Public method | Add(String, Boolean, Boolean) | Calls 5 parameter add with false for term vector positions and offsets.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.
Public method | AddIndexed | Add fields that are indexed. Whether they have termvectors has to be specified.
Public method | Clone | Returns a deep clone of this FieldInfos instance.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FieldInfo(Int32) | Return the fieldinfo object referenced by the fieldNumber.
Public method | FieldInfo(String) |
Public method | FieldName | Return the fieldName identified by its number.
Public method | FieldNumber |
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasVectors |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Size |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Write(IndexOutput) |
Public method | Write(Directory, String) |
Back to Top
Fields
Name | Description
FORMAT_PRE |
FORMAT_START |
Back to Top
See Also
FieldInfos Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInfos Constructor

FieldInfos Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | FieldInfos | Initializes a new instance of the FieldInfos class
Public method | FieldInfos(Directory, String) | Construct a FieldInfos object using the directory and the name of the file IndexInput
Back to Top
See Also
FieldInfos Class
FieldInfos Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInfos Constructor

FieldInfos Constructor Lucene.Net Class Library
Initializes a new instance of the FieldInfos class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldInfos()
public FieldInfos()
Public Sub New
Public Sub New
public:
FieldInfos()
public:
FieldInfos()
See Also
FieldInfos Class
FieldInfos Members
FieldInfos Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInfos Constructor (Directory, String)

FieldInfos Constructor (Directory, String) Lucene.Net Class Library
Construct a FieldInfos object using the directory and the name of the file IndexInput

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldInfos(
    Directory d,
    string name
)
public FieldInfos(
    Directory d,
    string name
)
Public Sub New ( _
    d As Directory, _
    name As String _
)
Public Sub New ( _
    d As Directory, _
    name As String _
)
public:
FieldInfos(
    Directory^ d,
    String^ name
)
public:
FieldInfos(
    Directory^ d,
    String^ name
)
Parameters
d
Type: Lucene.Net.Store Directory
The directory to open the IndexInput from

name
Type:   Online System String
The name of the file to open the IndexInput from in the Directory

See Also
FieldInfos Class
FieldInfos Members
FieldInfos Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInfos Fields

FieldInfos Fields Lucene.Net Class Library
The FieldInfos type exposes the following members.
Fields
Name | Description
FORMAT_PRE |
FORMAT_START |
Back to Top
See Also
FieldInfos Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FORMAT_PRE Field

FieldInfos FORMAT_PRE Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int FORMAT_PRE
public const int FORMAT_PRE
Public Const FORMAT_PRE As Integer
Public Const FORMAT_PRE As Integer
public:
literal int FORMAT_PRE
public:
literal int FORMAT_PRE
See Also
FieldInfos Class
FieldInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FORMAT_START Field

FieldInfos FORMAT_START Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int FORMAT_START
public const int FORMAT_START
Public Const FORMAT_START As Integer
Public Const FORMAT_START As Integer
public:
literal int FORMAT_START
public:
literal int FORMAT_START
See Also
FieldInfos Class
FieldInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInfos Methods

FieldInfos Methods Lucene.Net Class Library
The FieldInfos type exposes the following members.
Methods
 | Name | Description
Public method | Add(Document) | Adds field info for a Document.
Public method | Add(ICollection String , Boolean) | Assumes the fields are not storing term vectors.
Public method | Add(String, Boolean) | Calls 5 parameter add with false for all TermVector parameters.
Public method | Add(String, Boolean, Boolean) | Calls 5 parameter add with false for term vector positions and offsets.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.
Public method | AddIndexed | Add fields that are indexed. Whether they have termvectors has to be specified.
Public method | Clone | Returns a deep clone of this FieldInfos instance.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FieldInfo(Int32) | Return the fieldinfo object referenced by the fieldNumber.
Public method | FieldInfo(String) |
Public method | FieldName | Return the fieldName identified by its number.
Public method | FieldNumber |
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasVectors |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Size |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Write(IndexOutput) |
Public method | Write(Directory, String) |
Back to Top
See Also
FieldInfos Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method

FieldInfos Add Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Add(Document) | Adds field info for a Document.
Public method | Add(ICollection String , Boolean) | Assumes the fields are not storing term vectors.
Public method | Add(String, Boolean) | Calls 5 parameter add with false for all TermVector parameters.
Public method | Add(String, Boolean, Boolean) | Calls 5 parameter add with false for term vector positions and offsets.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.
Back to Top
See Also
FieldInfos Class
FieldInfos Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (Document)

FieldInfos Add Method (Document) Lucene.Net Class Library
Adds field info for a Document.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    Document doc
)
public void Add(
    Document doc
)
Public Sub Add ( _
    doc As Document _
)
Public Sub Add ( _
    doc As Document _
)
public:
void Add(
    Document^ doc
)
public:
void Add(
    Document^ doc
)
Parameters
doc
Type: Lucene.Net.Documents Document
See Also
FieldInfos Class
FieldInfos Members
Add Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (ICollection(String), Boolean)

FieldInfos Add Method (ICollection String , Boolean) Lucene.Net Class Library
Assumes the fields are not storing term vectors.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    ICollection<string> names,
    bool isIndexed
)
public void Add(
    ICollection<string> names,
    bool isIndexed
)
Public Sub Add ( _
    names As ICollection(Of String), _
    isIndexed As Boolean _
)
Public Sub Add ( _
    names As ICollection(Of String), _
    isIndexed As Boolean _
)
public:
void Add(
    ICollection<String^>^ names,
    bool isIndexed
)
public:
void Add(
    ICollection<String^>^ names,
    bool isIndexed
)
Parameters
names
Type:   Online System.Collections.Generic ICollection    Online String
The names of the fields

isIndexed
Type:   Online System Boolean
Whether the fields are indexed or not

See Also
FieldInfos Class
FieldInfos Members
Add Overload
Lucene.Net.Index Namespace
FieldInfos Add(String, Boolean)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (String, Boolean)

FieldInfos Add Method (String, Boolean) Lucene.Net Class Library
Calls 5 parameter add with false for all TermVector parameters.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    string name,
    bool isIndexed
)
public void Add(
    string name,
    bool isIndexed
)
Public Sub Add ( _
    name As String, _
    isIndexed As Boolean _
)
Public Sub Add ( _
    name As String, _
    isIndexed As Boolean _
)
public:
void Add(
    String^ name,
    bool isIndexed
)
public:
void Add(
    String^ name,
    bool isIndexed
)
Parameters
name
Type:   Online System String
The name of the Fieldable

isIndexed
Type:   Online System Boolean
true if the field is indexed

See Also
FieldInfos Class
FieldInfos Members
Add Overload
Lucene.Net.Index Namespace
FieldInfos Add(String, Boolean, Boolean, Boolean, Boolean)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (String, Boolean, Boolean)

FieldInfos Add Method (String, Boolean, Boolean) Lucene.Net Class Library
Calls 5 parameter add with false for term vector positions and offsets.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    string name,
    bool isIndexed,
    bool storeTermVector
)
public void Add(
    string name,
    bool isIndexed,
    bool storeTermVector
)
Public Sub Add ( _
    name As String, _
    isIndexed As Boolean, _
    storeTermVector As Boolean _
)
Public Sub Add ( _
    name As String, _
    isIndexed As Boolean, _
    storeTermVector As Boolean _
)
public:
void Add(
    String^ name,
    bool isIndexed,
    bool storeTermVector
)
public:
void Add(
    String^ name,
    bool isIndexed,
    bool storeTermVector
)
Parameters
name
Type:   Online System String
The name of the field

isIndexed
Type:   Online System Boolean
 true if the field is indexed

storeTermVector
Type:   Online System Boolean
true if the term vector should be stored

See Also
FieldInfos Class
FieldInfos Members
Add Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (String, Boolean, Boolean, Boolean, Boolean)

FieldInfos Add Method (String, Boolean, Boolean, Boolean, Boolean) Lucene.Net Class Library
If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    string name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector
)
public void Add(
    string name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector
)
Public Sub Add ( _
    name As String, _
    isIndexed As Boolean, _
    storeTermVector As Boolean, _
    storePositionWithTermVector As Boolean, _
    storeOffsetWithTermVector As Boolean _
)
Public Sub Add ( _
    name As String, _
    isIndexed As Boolean, _
    storeTermVector As Boolean, _
    storePositionWithTermVector As Boolean, _
    storeOffsetWithTermVector As Boolean _
)
public:
void Add(
    String^ name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector
)
public:
void Add(
    String^ name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector
)
Parameters
name
Type:   Online System String
The name of the field

isIndexed
Type:   Online System Boolean
true if the field is indexed

storeTermVector
Type:   Online System Boolean
true if the term vector should be stored

storePositionWithTermVector
Type:   Online System Boolean
true if the term vector with positions should be stored

storeOffsetWithTermVector
Type:   Online System Boolean
true if the term vector with offsets should be stored

See Also
FieldInfos Class
FieldInfos Members
Add Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (String, Boolean, Boolean, Boolean, Boolean, Boolean)

FieldInfos Add Method (String, Boolean, Boolean, Boolean, Boolean, Boolean) Lucene.Net Class Library
If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    string name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector,
    bool omitNorms
)
public void Add(
    string name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector,
    bool omitNorms
)
Public Sub Add ( _
    name As String, _
    isIndexed As Boolean, _
    storeTermVector As Boolean, _
    storePositionWithTermVector As Boolean, _
    storeOffsetWithTermVector As Boolean, _
    omitNorms As Boolean _
)
Public Sub Add ( _
    name As String, _
    isIndexed As Boolean, _
    storeTermVector As Boolean, _
    storePositionWithTermVector As Boolean, _
    storeOffsetWithTermVector As Boolean, _
    omitNorms As Boolean _
)
public:
void Add(
    String^ name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector,
    bool omitNorms
)
public:
void Add(
    String^ name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector,
    bool omitNorms
)
Parameters
name
Type:   Online System String
The name of the field

isIndexed
Type:   Online System Boolean
true if the field is indexed

storeTermVector
Type:   Online System Boolean
true if the term vector should be stored

storePositionWithTermVector
Type:   Online System Boolean
true if the term vector with positions should be stored

storeOffsetWithTermVector
Type:   Online System Boolean
true if the term vector with offsets should be stored

omitNorms
Type:   Online System Boolean
true if the norms for the indexed field should be omitted

See Also
FieldInfos Class
FieldInfos Members
Add Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (String, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

FieldInfos Add Method (String, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) Lucene.Net Class Library
If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldInfo Add(
    string name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector,
    bool omitNorms,
    bool storePayloads,
    bool omitTermFreqAndPositions
)
public FieldInfo Add(
    string name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector,
    bool omitNorms,
    bool storePayloads,
    bool omitTermFreqAndPositions
)
Public Function Add ( _
    name As String, _
    isIndexed As Boolean, _
    storeTermVector As Boolean, _
    storePositionWithTermVector As Boolean, _
    storeOffsetWithTermVector As Boolean, _
    omitNorms As Boolean, _
    storePayloads As Boolean, _
    omitTermFreqAndPositions As Boolean _
) As FieldInfo
Public Function Add ( _
    name As String, _
    isIndexed As Boolean, _
    storeTermVector As Boolean, _
    storePositionWithTermVector As Boolean, _
    storeOffsetWithTermVector As Boolean, _
    omitNorms As Boolean, _
    storePayloads As Boolean, _
    omitTermFreqAndPositions As Boolean _
) As FieldInfo
public:
FieldInfo^ Add(
    String^ name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector,
    bool omitNorms,
    bool storePayloads,
    bool omitTermFreqAndPositions
)
public:
FieldInfo^ Add(
    String^ name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector,
    bool omitNorms,
    bool storePayloads,
    bool omitTermFreqAndPositions
)
Parameters
name
Type:   Online System String
The name of the field

isIndexed
Type:   Online System Boolean
true if the field is indexed

storeTermVector
Type:   Online System Boolean
true if the term vector should be stored

storePositionWithTermVector
Type:   Online System Boolean
true if the term vector with positions should be stored

storeOffsetWithTermVector
Type:   Online System Boolean
true if the term vector with offsets should be stored

omitNorms
Type:   Online System Boolean
true if the norms for the indexed field should be omitted

storePayloads
Type:   Online System Boolean
true if payloads should be stored for this field

omitTermFreqAndPositions
Type:   Online System Boolean
true if term freqs should be omitted for this field

See Also
FieldInfos Class
FieldInfos Members
Add Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddIndexed Method

FieldInfos AddIndexed Method Lucene.Net Class Library
Add fields that are indexed. Whether they have termvectors has to be specified.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddIndexed(
    ICollection<string> names,
    bool storeTermVectors,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector
)
public void AddIndexed(
    ICollection<string> names,
    bool storeTermVectors,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector
)
Public Sub AddIndexed ( _
    names As ICollection(Of String), _
    storeTermVectors As Boolean, _
    storePositionWithTermVector As Boolean, _
    storeOffsetWithTermVector As Boolean _
)
Public Sub AddIndexed ( _
    names As ICollection(Of String), _
    storeTermVectors As Boolean, _
    storePositionWithTermVector As Boolean, _
    storeOffsetWithTermVector As Boolean _
)
public:
void AddIndexed(
    ICollection<String^>^ names,
    bool storeTermVectors,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector
)
public:
void AddIndexed(
    ICollection<String^>^ names,
    bool storeTermVectors,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector
)
Parameters
names
Type:   Online System.Collections.Generic ICollection    Online String
The names of the fields

storeTermVectors
Type:   Online System Boolean
Whether the fields store term vectors or not

storePositionWithTermVector
Type:   Online System Boolean
true if positions should be stored.

storeOffsetWithTermVector
Type:   Online System Boolean
true if offsets should be stored

See Also
FieldInfos Class
FieldInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

FieldInfos Clone Method Lucene.Net Class Library
Returns a deep clone of this FieldInfos instance.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Clone()
public Object Clone()
Public Function Clone As Object
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
public:
virtual Object^ Clone() sealed
Implements
  Online ICloneable Clone
See Also
FieldInfos Class
FieldInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInfo Method

FieldInfos FieldInfo Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | FieldInfo(Int32) | Return the fieldinfo object referenced by the fieldNumber.
Public method | FieldInfo(String) |
Back to Top
See Also
FieldInfos Class
FieldInfos Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInfo Method (Int32)

FieldInfos FieldInfo Method (Int32) Lucene.Net Class Library
Return the fieldinfo object referenced by the fieldNumber.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldInfo FieldInfo(
    int fieldNumber
)
public FieldInfo FieldInfo(
    int fieldNumber
)
Public Function FieldInfo ( _
    fieldNumber As Integer _
) As FieldInfo
Public Function FieldInfo ( _
    fieldNumber As Integer _
) As FieldInfo
public:
FieldInfo^ FieldInfo(
    int fieldNumber
)
public:
FieldInfo^ FieldInfo(
    int fieldNumber
)
Parameters
fieldNumber
Type:   Online System Int32
Return Value
 the FieldInfo object or null when the given fieldNumber
            doesn't exist.

See Also
FieldInfos Class
FieldInfos Members
FieldInfo Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInfo Method (String)

FieldInfos FieldInfo Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldInfo FieldInfo(
    string fieldName
)
public FieldInfo FieldInfo(
    string fieldName
)
Public Function FieldInfo ( _
    fieldName As String _
) As FieldInfo
Public Function FieldInfo ( _
    fieldName As String _
) As FieldInfo
public:
FieldInfo^ FieldInfo(
    String^ fieldName
)
public:
FieldInfo^ FieldInfo(
    String^ fieldName
)
Parameters
fieldName
Type:   Online System String
See Also
FieldInfos Class
FieldInfos Members
FieldInfo Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldName Method

FieldInfos FieldName Method Lucene.Net Class Library
Return the fieldName identified by its number.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FieldName(
    int fieldNumber
)
public string FieldName(
    int fieldNumber
)
Public Function FieldName ( _
    fieldNumber As Integer _
) As String
Public Function FieldName ( _
    fieldNumber As Integer _
) As String
public:
String^ FieldName(
    int fieldNumber
)
public:
String^ FieldName(
    int fieldNumber
)
Parameters
fieldNumber
Type:   Online System Int32
Return Value
 the fieldName or an empty string when the field
            with the given number doesn't exist.

See Also
FieldInfos Class
FieldInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldNumber Method

FieldInfos FieldNumber Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int FieldNumber(
    string fieldName
)
public int FieldNumber(
    string fieldName
)
Public Function FieldNumber ( _
    fieldName As String _
) As Integer
Public Function FieldNumber ( _
    fieldName As String _
) As Integer
public:
int FieldNumber(
    String^ fieldName
)
public:
int FieldNumber(
    String^ fieldName
)
Parameters
fieldName
Type:   Online System String
See Also
FieldInfos Class
FieldInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasVectors Method

FieldInfos HasVectors Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasVectors()
public bool HasVectors()
Public Function HasVectors As Boolean
Public Function HasVectors As Boolean
public:
bool HasVectors()
public:
bool HasVectors()
See Also
FieldInfos Class
FieldInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Size Method

FieldInfos Size Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Size()
public int Size()
Public Function Size As Integer
Public Function Size As Integer
public:
int Size()
public:
int Size()
See Also
FieldInfos Class
FieldInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Write Method

FieldInfos Write Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Write(IndexOutput) |
Public method | Write(Directory, String) |
Back to Top
See Also
FieldInfos Class
FieldInfos Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Write Method (IndexOutput)

FieldInfos Write Method (IndexOutput) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    IndexOutput output
)
public void Write(
    IndexOutput output
)
Public Sub Write ( _
    output As IndexOutput _
)
Public Sub Write ( _
    output As IndexOutput _
)
public:
void Write(
    IndexOutput^ output
)
public:
void Write(
    IndexOutput^ output
)
Parameters
output
Type: Lucene.Net.Store IndexOutput
See Also
FieldInfos Class
FieldInfos Members
Write Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Write Method (Directory, String)

FieldInfos Write Method (Directory, String) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    Directory d,
    string name
)
public void Write(
    Directory d,
    string name
)
Public Sub Write ( _
    d As Directory, _
    name As String _
)
Public Sub Write ( _
    d As Directory, _
    name As String _
)
public:
void Write(
    Directory^ d,
    String^ name
)
public:
void Write(
    Directory^ d,
    String^ name
)
Parameters
d
Type: Lucene.Net.Store Directory
name
Type:   Online System String
See Also
FieldInfos Class
FieldInfos Members
Write Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInvertState Class

FieldInvertState Class Lucene.Net Class Library
This class tracks the number and position / offset parameters of terms being added to the index. The information collected in this class is also used to calculate the normalization factor for a field.

WARNING: This API is new and experimental, and may suddenly change.

Inheritance Hierarchy
Online System Object
Lucene.Net.Index FieldInvertState

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class FieldInvertState
public sealed class FieldInvertState
Public NotInheritable Class FieldInvertState
Public NotInheritable Class FieldInvertState
public ref class FieldInvertState sealed
public ref class FieldInvertState sealed
See Also
FieldInvertState Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInvertState Members

FieldInvertState Members Lucene.Net Class Library

The FieldInvertState type exposes the following members.
Constructors
 | Name | Description
Public method | FieldInvertState | Initializes a new instance of the FieldInvertState class
Public method | FieldInvertState(Int32, Int32, Int32, Int32, Single) | Initializes a new instance of the FieldInvertState class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | AttributeSource |
Public property | Boost | Get boost value. This is the cumulative product of document boost and field boost for all field instances sharing the same field name.
Public property | Length | Get total number of terms in this field.
Public property | NumOverlap | Get the number of terms with positionIncrement == 0.
Public property | Offset | Get end offset of the last processed term.
Public property | Position | Get the last processed term position.
Back to Top
See Also
FieldInvertState Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInvertState Constructor

FieldInvertState Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | FieldInvertState | Initializes a new instance of the FieldInvertState class
Public method | FieldInvertState(Int32, Int32, Int32, Int32, Single) | Initializes a new instance of the FieldInvertState class
Back to Top
See Also
FieldInvertState Class
FieldInvertState Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInvertState Constructor

FieldInvertState Constructor Lucene.Net Class Library
Initializes a new instance of the FieldInvertState class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldInvertState()
public FieldInvertState()
Public Sub New
Public Sub New
public:
FieldInvertState()
public:
FieldInvertState()
See Also
FieldInvertState Class
FieldInvertState Members
FieldInvertState Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInvertState Constructor (Int32, Int32, Int32, Int32, Single)

FieldInvertState Constructor (Int32, Int32, Int32, Int32, Single) Lucene.Net Class Library
Initializes a new instance of the FieldInvertState class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldInvertState(
    int position,
    int length,
    int numOverlap,
    int offset,
    float boost
)
public FieldInvertState(
    int position,
    int length,
    int numOverlap,
    int offset,
    float boost
)
Public Sub New ( _
    position As Integer, _
    length As Integer, _
    numOverlap As Integer, _
    offset As Integer, _
    boost As Single _
)
Public Sub New ( _
    position As Integer, _
    length As Integer, _
    numOverlap As Integer, _
    offset As Integer, _
    boost As Single _
)
public:
FieldInvertState(
    int position,
    int length,
    int numOverlap,
    int offset,
    float boost
)
public:
FieldInvertState(
    int position,
    int length,
    int numOverlap,
    int offset,
    float boost
)
Parameters
position
Type:   Online System Int32
length
Type:   Online System Int32
numOverlap
Type:   Online System Int32
offset
Type:   Online System Int32
boost
Type:   Online System Single
See Also
FieldInvertState Class
FieldInvertState Members
FieldInvertState Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInvertState Methods

FieldInvertState Methods Lucene.Net Class Library
The FieldInvertState type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldInvertState Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInvertState Properties

FieldInvertState Properties Lucene.Net Class Library
The FieldInvertState type exposes the following members.
Properties
 | Name | Description
Public property | AttributeSource |
Public property | Boost | Get boost value. This is the cumulative product of document boost and field boost for all field instances sharing the same field name.
Public property | Length | Get total number of terms in this field.
Public property | NumOverlap | Get the number of terms with positionIncrement == 0.
Public property | Offset | Get end offset of the last processed term.
Public property | Position | Get the last processed term position.
Back to Top
See Also
FieldInvertState Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource Property

FieldInvertState AttributeSource Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AttributeSource AttributeSource { get; }
public AttributeSource AttributeSource { get; }
Public ReadOnly Property AttributeSource As AttributeSource
    Get
Public ReadOnly Property AttributeSource As AttributeSource
    Get
public:
property AttributeSource^ AttributeSource {
    AttributeSource^ get ();
}
public:
property AttributeSource^ AttributeSource {
    AttributeSource^ get ();
}
See Also
FieldInvertState Class
FieldInvertState Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Boost Property

FieldInvertState Boost Property Lucene.Net Class Library
Get boost value. This is the cumulative product of document boost and field boost for all field instances sharing the same field name.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Boost { get; }
public float Boost { get; }
Public ReadOnly Property Boost As Single
    Get
Public ReadOnly Property Boost As Single
    Get
public:
property float Boost {
    float get ();
}
public:
property float Boost {
    float get ();
}
Field Value
 the boost
See Also
FieldInvertState Class
FieldInvertState Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Length Property

FieldInvertState Length Property Lucene.Net Class Library
Get total number of terms in this field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Length { get; }
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get
Public ReadOnly Property Length As Integer
    Get
public:
property int Length {
    int get ();
}
public:
property int Length {
    int get ();
}
Field Value
 the length
See Also
FieldInvertState Class
FieldInvertState Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumOverlap Property

FieldInvertState NumOverlap Property Lucene.Net Class Library
Get the number of terms with positionIncrement == 0.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int NumOverlap { get; }
public int NumOverlap { get; }
Public ReadOnly Property NumOverlap As Integer
    Get
Public ReadOnly Property NumOverlap As Integer
    Get
public:
property int NumOverlap {
    int get ();
}
public:
property int NumOverlap {
    int get ();
}
Field Value
 the numOverlap
See Also
FieldInvertState Class
FieldInvertState Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Offset Property

FieldInvertState Offset Property Lucene.Net Class Library
Get end offset of the last processed term.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Offset { get; }
public int Offset { get; }
Public ReadOnly Property Offset As Integer
    Get
Public ReadOnly Property Offset As Integer
    Get
public:
property int Offset {
    int get ();
}
public:
property int Offset {
    int get ();
}
Field Value
 the offset
See Also
FieldInvertState Class
FieldInvertState Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Position Property

FieldInvertState Position Property Lucene.Net Class Library
Get the last processed term position.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Position { get; }
public int Position { get; }
Public ReadOnly Property Position As Integer
    Get
Public ReadOnly Property Position As Integer
    Get
public:
property int Position {
    int get ();
}
public:
property int Position {
    int get ();
}
Field Value
 the position
See Also
FieldInvertState Class
FieldInvertState Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldReaderException Class

FieldReaderException Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Online System Exception
Online System SystemException
Lucene.Net.Index FieldReaderException

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FieldReaderException : SystemException
[SerializableAttribute]
public class FieldReaderException : SystemException
<SerializableAttribute> _
Public Class FieldReaderException _
    Inherits SystemException
<SerializableAttribute> _
Public Class FieldReaderException _
    Inherits SystemException
[SerializableAttribute]
public ref class FieldReaderException : public SystemException
[SerializableAttribute]
public ref class FieldReaderException : public SystemException
See Also
FieldReaderException Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldReaderException Members

FieldReaderException Members Lucene.Net Class Library

The FieldReaderException type exposes the following members.
Constructors
 | Name | Description
Public method | FieldReaderException | Constructs a new runtime exception with null as its detail message. The cause is not initialized, and may subsequently be initialized by a call to Online InnerException.
Public method | FieldReaderException(Exception) | Constructs a new runtime exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause). This constructor is useful for runtime exceptions that are little more than wrappers for other throwables.
Public method | FieldReaderException(String) | Constructs a new runtime exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to Online InnerException.
Public method | FieldReaderException(String, Exception) | Constructs a new runtime exception with the specified detail message and cause. Note that the detail message associated with cause is not automatically incorporated in this runtime exception's detail message.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
FieldReaderException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldReaderException Constructor

FieldReaderException Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | FieldReaderException | Constructs a new runtime exception with null as its detail message. The cause is not initialized, and may subsequently be initialized by a call to Online InnerException.
Public method | FieldReaderException(Exception) | Constructs a new runtime exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause). This constructor is useful for runtime exceptions that are little more than wrappers for other throwables.
Public method | FieldReaderException(String) | Constructs a new runtime exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to Online InnerException.
Public method | FieldReaderException(String, Exception) | Constructs a new runtime exception with the specified detail message and cause. Note that the detail message associated with cause is not automatically incorporated in this runtime exception's detail message.
Back to Top
See Also
FieldReaderException Class
FieldReaderException Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldReaderException Constructor

FieldReaderException Constructor Lucene.Net Class Library
Constructs a new runtime exception with null as its detail message. The cause is not initialized, and may subsequently be initialized by a call to Online InnerException.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldReaderException()
public FieldReaderException()
Public Sub New
Public Sub New
public:
FieldReaderException()
public:
FieldReaderException()
See Also
FieldReaderException Class
FieldReaderException Members
FieldReaderException Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldReaderException Constructor (Exception)

FieldReaderException Constructor (Exception) Lucene.Net Class Library
Constructs a new runtime exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

This constructor is useful for runtime exceptions that are little more than wrappers for other throwables.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldReaderException(
    Exception cause
)
public FieldReaderException(
    Exception cause
)
Public Sub New ( _
    cause As Exception _
)
Public Sub New ( _
    cause As Exception _
)
public:
FieldReaderException(
    Exception^ cause
)
public:
FieldReaderException(
    Exception^ cause
)
Parameters
cause
Type:   Online System Exception
the cause (which is saved for later retrieval by the
              Online InnerException).  (A null value is
            permitted, and indicates that the cause is nonexistent or
            unknown.)

See Also
FieldReaderException Class
FieldReaderException Members
FieldReaderException Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldReaderException Constructor (String)

FieldReaderException Constructor (String) Lucene.Net Class Library
Constructs a new runtime exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to Online InnerException.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldReaderException(
    string message
)
public FieldReaderException(
    string message
)
Public Sub New ( _
    message As String _
)
Public Sub New ( _
    message As String _
)
public:
FieldReaderException(
    String^ message
)
public:
FieldReaderException(
    String^ message
)
Parameters
message
Type:   Online System String
the detail message. The detail message is saved for
            later retrieval by the   Online Message method.

See Also
FieldReaderException Class
FieldReaderException Members
FieldReaderException Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldReaderException Constructor (String, Exception)

FieldReaderException Constructor (String, Exception) Lucene.Net Class Library
Constructs a new runtime exception with the specified detail message and cause.

Note that the detail message associated with cause is not automatically incorporated in this runtime exception's detail message.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldReaderException(
    string message,
    Exception cause
)
public FieldReaderException(
    string message,
    Exception cause
)
Public Sub New ( _
    message As String, _
    cause As Exception _
)
Public Sub New ( _
    message As String, _
    cause As Exception _
)
public:
FieldReaderException(
    String^ message,
    Exception^ cause
)
public:
FieldReaderException(
    String^ message,
    Exception^ cause
)
Parameters
message
Type:   Online System String
the detail message (which is saved for later retrieval
            by the   Online Message method).

cause
Type:   Online System Exception
  the cause (which is saved for later retrieval by the
              Online InnerException method).  (A null value is
            permitted, and indicates that the cause is nonexistent or
            unknown.)

See Also
FieldReaderException Class
FieldReaderException Members
FieldReaderException Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldReaderException Methods

FieldReaderException Methods Lucene.Net Class Library
The FieldReaderException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
FieldReaderException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldReaderException Properties

FieldReaderException Properties Lucene.Net Class Library
The FieldReaderException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
FieldReaderException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldReaderException Events

FieldReaderException Events Lucene.Net Class Library
The FieldReaderException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
FieldReaderException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldSortedTermVectorMapper Class

FieldSortedTermVectorMapper Class Lucene.Net Class Library
For each Field, store a sorted collection of TermVectorEntrys

This is not thread-safe.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index TermVectorMapper
Lucene.Net.Index FieldSortedTermVectorMapper

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FieldSortedTermVectorMapper : TermVectorMapper
public class FieldSortedTermVectorMapper : TermVectorMapper
Public Class FieldSortedTermVectorMapper _
    Inherits TermVectorMapper
Public Class FieldSortedTermVectorMapper _
    Inherits TermVectorMapper
public ref class FieldSortedTermVectorMapper : public TermVectorMapper
public ref class FieldSortedTermVectorMapper : public TermVectorMapper
See Also
FieldSortedTermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldSortedTermVectorMapper Members

FieldSortedTermVectorMapper Members Lucene.Net Class Library

The FieldSortedTermVectorMapper type exposes the following members.
Constructors
 | Name | Description
Public method | FieldSortedTermVectorMapper(IComparer TermVectorEntry ) | Initializes a new instance of the FieldSortedTermVectorMapper class
Public method | FieldSortedTermVectorMapper(Boolean, Boolean, IComparer TermVectorEntry ) | Initializes a new instance of the FieldSortedTermVectorMapper class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Map | (Overrides TermVectorMapper Map(String, Int32, TermVectorOffsetInfo , Int32 ).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations. (Inherited from TermVectorMapper.)
Public method | SetExpectations | (Overrides TermVectorMapper SetExpectations(String, Int32, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Comparator |
Public property | FieldToTerms | Get the mapping between fields and terms, sorted by the comparator
Public property | IsIgnoringOffsets | (Inherited from TermVectorMapper.)
Public property | IsIgnoringPositions | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored. (Inherited from TermVectorMapper.)
Back to Top
See Also
FieldSortedTermVectorMapper Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldSortedTermVectorMapper Constructor

FieldSortedTermVectorMapper Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | FieldSortedTermVectorMapper(IComparer TermVectorEntry ) | Initializes a new instance of the FieldSortedTermVectorMapper class
Public method | FieldSortedTermVectorMapper(Boolean, Boolean, IComparer TermVectorEntry ) | Initializes a new instance of the FieldSortedTermVectorMapper class
Back to Top
See Also
FieldSortedTermVectorMapper Class
FieldSortedTermVectorMapper Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldSortedTermVectorMapper Constructor (IComparer(TermVectorEntry))

FieldSortedTermVectorMapper Constructor (IComparer TermVectorEntry ) Lucene.Net Class Library
Initializes a new instance of the FieldSortedTermVectorMapper class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldSortedTermVectorMapper(
    IComparer<TermVectorEntry> comparator
)
public FieldSortedTermVectorMapper(
    IComparer<TermVectorEntry> comparator
)
Public Sub New ( _
    comparator As IComparer(Of TermVectorEntry) _
)
Public Sub New ( _
    comparator As IComparer(Of TermVectorEntry) _
)
public:
FieldSortedTermVectorMapper(
    IComparer<TermVectorEntry^>^ comparator
)
public:
FieldSortedTermVectorMapper(
    IComparer<TermVectorEntry^>^ comparator
)
Parameters
comparator
Type:   Online System.Collections.Generic IComparer  TermVectorEntry
A Comparator for sorting TermVectorEntrys

See Also
FieldSortedTermVectorMapper Class
FieldSortedTermVectorMapper Members
FieldSortedTermVectorMapper Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldSortedTermVectorMapper Constructor (Boolean, Boolean, IComparer(TermVectorEntry))

FieldSortedTermVectorMapper Constructor (Boolean, Boolean, IComparer TermVectorEntry ) Lucene.Net Class Library
Initializes a new instance of the FieldSortedTermVectorMapper class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldSortedTermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets,
    IComparer<TermVectorEntry> comparator
)
public FieldSortedTermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets,
    IComparer<TermVectorEntry> comparator
)
Public Sub New ( _
    ignoringPositions As Boolean, _
    ignoringOffsets As Boolean, _
    comparator As IComparer(Of TermVectorEntry) _
)
Public Sub New ( _
    ignoringPositions As Boolean, _
    ignoringOffsets As Boolean, _
    comparator As IComparer(Of TermVectorEntry) _
)
public:
FieldSortedTermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets,
    IComparer<TermVectorEntry^>^ comparator
)
public:
FieldSortedTermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets,
    IComparer<TermVectorEntry^>^ comparator
)
Parameters
ignoringPositions
Type:   Online System Boolean
ignoringOffsets
Type:   Online System Boolean
comparator
Type:   Online System.Collections.Generic IComparer  TermVectorEntry
See Also
FieldSortedTermVectorMapper Class
FieldSortedTermVectorMapper Members
FieldSortedTermVectorMapper Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldSortedTermVectorMapper Methods

FieldSortedTermVectorMapper Methods Lucene.Net Class Library
The FieldSortedTermVectorMapper type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Map | (Overrides TermVectorMapper Map(String, Int32, TermVectorOffsetInfo , Int32 ).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations. (Inherited from TermVectorMapper.)
Public method | SetExpectations | (Overrides TermVectorMapper SetExpectations(String, Int32, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldSortedTermVectorMapper Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Map Method

FieldSortedTermVectorMapper Map Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Map(
    string term,
    int frequency,
    TermVectorOffsetInfo[] offsets,
    int[] positions
)
public override void Map(
    string term,
    int frequency,
    TermVectorOffsetInfo[] offsets,
    int[] positions
)
Public Overrides Sub Map ( _
    term As String, _
    frequency As Integer, _
    offsets As TermVectorOffsetInfo(), _
    positions As Integer() _
)
Public Overrides Sub Map ( _
    term As String, _
    frequency As Integer, _
    offsets As TermVectorOffsetInfo(), _
    positions As Integer() _
)
public:
virtual void Map(
    String^ term,
    int frequency,
    array<TermVectorOffsetInfo>^ offsets,
    array<int>^ positions
) override
public:
virtual void Map(
    String^ term,
    int frequency,
    array<TermVectorOffsetInfo>^ offsets,
    array<int>^ positions
) override
Parameters
term
Type:   Online System String
frequency
Type:   Online System Int32
offsets
Type:  Lucene.Net.Index TermVectorOffsetInfo
positions
Type:    Online System Int32
See Also
FieldSortedTermVectorMapper Class
FieldSortedTermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetExpectations Method

FieldSortedTermVectorMapper SetExpectations Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetExpectations(
    string field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
)
public override void SetExpectations(
    string field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
)
Public Overrides Sub SetExpectations ( _
    field As String, _
    numTerms As Integer, _
    storeOffsets As Boolean, _
    storePositions As Boolean _
)
Public Overrides Sub SetExpectations ( _
    field As String, _
    numTerms As Integer, _
    storeOffsets As Boolean, _
    storePositions As Boolean _
)
public:
virtual void SetExpectations(
    String^ field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
) override
public:
virtual void SetExpectations(
    String^ field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
) override
Parameters
field
Type:   Online System String
numTerms
Type:   Online System Int32
storeOffsets
Type:   Online System Boolean
storePositions
Type:   Online System Boolean
See Also
FieldSortedTermVectorMapper Class
FieldSortedTermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldSortedTermVectorMapper Properties

FieldSortedTermVectorMapper Properties Lucene.Net Class Library
The FieldSortedTermVectorMapper type exposes the following members.
Properties
 | Name | Description
Public property | Comparator |
Public property | FieldToTerms | Get the mapping between fields and terms, sorted by the comparator
Public property | IsIgnoringOffsets | (Inherited from TermVectorMapper.)
Public property | IsIgnoringPositions | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored. (Inherited from TermVectorMapper.)
Back to Top
See Also
FieldSortedTermVectorMapper Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Comparator Property

FieldSortedTermVectorMapper Comparator Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IComparer<TermVectorEntry> Comparator { get; }
public virtual IComparer<TermVectorEntry> Comparator { get; }
Public Overridable ReadOnly Property Comparator As IComparer(Of TermVectorEntry)
    Get
Public Overridable ReadOnly Property Comparator As IComparer(Of TermVectorEntry)
    Get
public:
virtual property IComparer<TermVectorEntry^>^ Comparator {
    IComparer<TermVectorEntry^>^ get ();
}
public:
virtual property IComparer<TermVectorEntry^>^ Comparator {
    IComparer<TermVectorEntry^>^ get ();
}
See Also
FieldSortedTermVectorMapper Class
FieldSortedTermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldToTerms Property

FieldSortedTermVectorMapper FieldToTerms Property Lucene.Net Class Library
Get the mapping between fields and terms, sorted by the comparator

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IDictionary<string, SortedSet<TermVectorEntry>> FieldToTerms { get; }
public virtual IDictionary<string, SortedSet<TermVectorEntry>> FieldToTerms { get; }
Public Overridable ReadOnly Property FieldToTerms As IDictionary(Of String, SortedSet(Of TermVectorEntry))
    Get
Public Overridable ReadOnly Property FieldToTerms As IDictionary(Of String, SortedSet(Of TermVectorEntry))
    Get
public:
virtual property IDictionary<String^, SortedSet<TermVectorEntry^>^>^ FieldToTerms {
    IDictionary<String^, SortedSet<TermVectorEntry^>^>^ get ();
}
public:
virtual property IDictionary<String^, SortedSet<TermVectorEntry^>^>^ FieldToTerms {
    IDictionary<String^, SortedSet<TermVectorEntry^>^>^ get ();
}
Field Value
 A map between field names and <see cref="System.Collections.Generic.SortedDictionary{Object,Object}" />s per field. SortedSet entries are <see cref="TermVectorEntry" />
See Also
FieldSortedTermVectorMapper Class
FieldSortedTermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldsReader Class

FieldsReader Class Lucene.Net Class Library
Class responsible for access to stored document fields.

It uses <segment>.fdt and <segment>.fdx; files.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index FieldsReader

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class FieldsReader : ICloneable,
    IDisposable
public sealed class FieldsReader : ICloneable,
    IDisposable
Public NotInheritable Class FieldsReader _
    Implements ICloneable, IDisposable
Public NotInheritable Class FieldsReader _
    Implements ICloneable, IDisposable
public ref class FieldsReader sealed : ICloneable,
    IDisposable
public ref class FieldsReader sealed : ICloneable,
    IDisposable
See Also
FieldsReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldsReader Members

FieldsReader Members Lucene.Net Class Library

The FieldsReader type exposes the following members.
Constructors
 | Name | Description
Public method | FieldsReader | Initializes a new instance of the FieldsReader class
Back to Top
Methods
 | Name | Description
Public method | Clone | Returns a cloned FieldsReader that shares open IndexInputs with the original one. It is the caller's job not to close the original FieldsReader until all clones are called (eg, currently SegmentReader manages this logic).
Public method | Dispose | Closes the underlying IndexInput streams, including any ones associated with a lazy implementation of a Field. This means that the Fields values will not be accessible.
Public method | Doc |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Size |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldsReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldsReader Constructor

FieldsReader Constructor Lucene.Net Class Library
Initializes a new instance of the FieldsReader class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldsReader(
    Directory d,
    string segment,
    FieldInfos fn
)
public FieldsReader(
    Directory d,
    string segment,
    FieldInfos fn
)
Public Sub New ( _
    d As Directory, _
    segment As String, _
    fn As FieldInfos _
)
Public Sub New ( _
    d As Directory, _
    segment As String, _
    fn As FieldInfos _
)
public:
FieldsReader(
    Directory^ d,
    String^ segment,
    FieldInfos^ fn
)
public:
FieldsReader(
    Directory^ d,
    String^ segment,
    FieldInfos^ fn
)
Parameters
d
Type: Lucene.Net.Store Directory
segment
Type:   Online System String
fn
Type: Lucene.Net.Index FieldInfos
See Also
FieldsReader Class
FieldsReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldsReader Methods

FieldsReader Methods Lucene.Net Class Library
The FieldsReader type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Returns a cloned FieldsReader that shares open IndexInputs with the original one. It is the caller's job not to close the original FieldsReader until all clones are called (eg, currently SegmentReader manages this logic).
Public method | Dispose | Closes the underlying IndexInput streams, including any ones associated with a lazy implementation of a Field. This means that the Fields values will not be accessible.
Public method | Doc |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Size |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldsReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

FieldsReader Clone Method Lucene.Net Class Library
Returns a cloned FieldsReader that shares open IndexInputs with the original one. It is the caller's job not to close the original FieldsReader until all clones are called (eg, currently SegmentReader manages this logic).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Clone()
public Object Clone()
Public Function Clone As Object
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
public:
virtual Object^ Clone() sealed
Implements
  Online ICloneable Clone
See Also
FieldsReader Class
FieldsReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

FieldsReader Dispose Method Lucene.Net Class Library
Closes the underlying IndexInput streams, including any ones associated with a lazy implementation of a Field. This means that the Fields values will not be accessible.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
FieldsReader Class
FieldsReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Method

FieldsReader Doc Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Document Doc(
    int n,
    FieldSelector fieldSelector
)
public Document Doc(
    int n,
    FieldSelector fieldSelector
)
Public Function Doc ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Public Function Doc ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
public:
Document^ Doc(
    int n,
    FieldSelector^ fieldSelector
)
public:
Document^ Doc(
    int n,
    FieldSelector^ fieldSelector
)
Parameters
n
Type:   Online System Int32
fieldSelector
Type: Lucene.Net.Documents FieldSelector
See Also
FieldsReader Class
FieldsReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Size Method

FieldsReader Size Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Size()
public int Size()
Public Function Size As Integer
Public Function Size As Integer
public:
int Size()
public:
int Size()
See Also
FieldsReader Class
FieldsReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader Class

FilterIndexReader Class Lucene.Net Class Library
A FilterIndexReader contains another IndexReader, which it uses as its basic source of data, possibly transforming the data along the way or providing additional functionality. The class FilterIndexReader itself simply implements all abstract methods of IndexReader with versions that pass all requests to the contained index reader. Subclasses of FilterIndexReader may further override some of these methods and may also provide additional methods and fields.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index IndexReader
Lucene.Net.Index FilterIndexReader

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FilterIndexReader : IndexReader
public class FilterIndexReader : IndexReader
Public Class FilterIndexReader _
    Inherits IndexReader
Public Class FilterIndexReader _
    Inherits IndexReader
public ref class FilterIndexReader : public IndexReader
public ref class FilterIndexReader : public IndexReader
See Also
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader Members

FilterIndexReader Members Lucene.Net Class Library

The FilterIndexReader type exposes the following members.
Constructors
 | Name | Description
Public method | FilterIndexReader | Construct a FilterIndexReader based on the specified base reader. Directory locking for delete, undeleteAll, and setNorm operations is left to the base reader. Note that base reader is closed if this FilterIndexReader is closed.
Back to Top
Methods
Name | Description
Protected method AcquireWriteLock
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
(Inherited from IndexReader.)
Public method | Clone | (Overrides IndexReader Clone .)
Public method Clone(Boolean)
Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader.
(Inherited from IndexReader.)
Public method | Close | Obsolete. (Inherited from IndexReader.)
Public method Commit
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary String, String )
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered docNum. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the Document(Int32) method will result in an error. The presence of this document may still be reflected in the DocFreq(Term) statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given term indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See DeleteDocument(Int32) for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method | Directory | (Overrides IndexReader Directory .)
Public method Dispose
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Protected method | Dispose(Boolean) | (Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader DoClose .)
Protected method | DoCommit | (Overrides IndexReader DoCommit(IDictionary String, String ).)
Public method Document(Int32)
Returns the stored fields of the nthDocument in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted.
(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader DoDelete(Int32).)
Protected method | DoSetNorm | (Overrides IndexReader DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader DoUndeleteAll .)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Flush
(Inherited from IndexReader.)
Public method | Flush(IDictionary String, String ) | (Inherited from IndexReader.)
Public method | GetFieldNames | (Overrides IndexReader GetFieldNames(IndexReader FieldOption).)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method | GetSequentialSubReaders | (Overrides IndexReader GetSequentialSubReaders .)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method | GetTermFreqVectors | (Overrides IndexReader GetTermFreqVectors(Int32).)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method | HasNorms | (Overrides IndexReader HasNorms(String).)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding DecRef , in a finally clause; otherwise the reader may never be closed. Note that Close simply calls decRef(), which means that the IndexReader will not really be closed until DecRef has been called for all outstanding references.
(Inherited from IndexReader.)
Public method | IsCurrent | (Overrides IndexReader IsCurrent .)
Public method | IsDeleted | (Overrides IndexReader IsDeleted(Int32).)
Public method | IsOptimized | (Overrides IndexReader IsOptimized .)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method | Norms(String) | (Overrides IndexReader Norms(String).)
Public method | Norms(String, Byte , Int32) | (Overrides IndexReader Norms(String, Byte , Int32).)
Public method | NumDocs | (Overrides IndexReader NumDocs .)
Public method Reopen
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:
View Colorized Copy to Clipboard Print
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from GetReader , reopen() will simply call writer.getReader() again for you, though this may change in the future.
(Inherited from IndexReader.)
Public method Reopen(Boolean)
Just like Reopen , except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method | TermDocs | (Overrides IndexReader TermDocs .)
Public method | TermDocs(Term) | (Overrides IndexReader TermDocs(Term).)
Public method | TermPositions | (Overrides IndexReader TermPositions .)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.
(Inherited from IndexReader.)
Public method | Terms | (Overrides IndexReader Terms .)
Public method | Terms(Term) | (Overrides IndexReader Terms(Term).)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)
Back to Top
Fields
 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | in_Renamed |
Back to Top
Properties
 | Name | Description
Public property | CommitUserData | Retrieve the String userData optionally passed to Commit(IDictionary String, String ). This will return null if Commit(IDictionary String, String ) has never been called for this index. (Inherited from IndexReader.)
Public property | DeletesCacheKey | If the subclass of FilteredIndexReader modifies the deleted docs, you must override this method to provide a different key */ (Overrides IndexReader DeletesCacheKey.)
Public property | FieldCacheKey | If the subclass of FilteredIndexReader modifies the contents of the FieldCache, you must override this method to provide a different key */ (Overrides IndexReader FieldCacheKey.)
Public property | HasDeletions | (Overrides IndexReader HasDeletions.)
Public property | IndexCommit | Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: this API is new and experimental and may suddenly change. (Inherited from IndexReader.)
Public property | Item | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public property | MaxDoc | (Overrides IndexReader MaxDoc.)
Public property | NumDeletedDocs | Returns the number of deleted documents. (Inherited from IndexReader.)
Public property | RefCount | Expert: returns the current refCount for this reader (Inherited from IndexReader.)
Public property | TermInfosIndexDivisor | For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened. (Inherited from IndexReader.)
Public property | UniqueTermCount | Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed. (Inherited from IndexReader.)
Public property | Version | (Overrides IndexReader Version.)
Back to Top
See Also
FilterIndexReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader Constructor

FilterIndexReader Constructor Lucene.Net Class Library

Construct a FilterIndexReader based on the specified base reader. Directory locking for delete, undeleteAll, and setNorm operations is left to the base reader.

Note that base reader is closed if this FilterIndexReader is closed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FilterIndexReader(
    IndexReader in_Renamed
)
public FilterIndexReader(
    IndexReader in_Renamed
)
Public Sub New ( _
    in_Renamed As IndexReader _
)
Public Sub New ( _
    in_Renamed As IndexReader _
)
public:
FilterIndexReader(
    IndexReader^ in_Renamed
)
public:
FilterIndexReader(
    IndexReader^ in_Renamed
)
Parameters
in_Renamed
Type: Lucene.Net.Index IndexReader
specified base reader.

See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader Fields

FilterIndexReader Fields Lucene.Net Class Library
The FilterIndexReader type exposes the following members.
Fields
 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | in_Renamed |
Back to Top
See Also
FilterIndexReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


in_Renamed Field

FilterIndexReader in_Renamed Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IndexReader in_Renamed
protected IndexReader in_Renamed
Protected in_Renamed As IndexReader
Protected in_Renamed As IndexReader
protected:
IndexReader^ in_Renamed
protected:
IndexReader^ in_Renamed
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader Methods

FilterIndexReader Methods Lucene.Net Class Library
The FilterIndexReader type exposes the following members.
Methods
Name | Description
Protected method AcquireWriteLock
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
(Inherited from IndexReader.)
Public method | Clone | (Overrides IndexReader Clone .)
Public method Clone(Boolean)
Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader.
(Inherited from IndexReader.)
Public method | Close | Obsolete. (Inherited from IndexReader.)
Public method Commit
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary String, String )
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered docNum. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the Document(Int32) method will result in an error. The presence of this document may still be reflected in the DocFreq(Term) statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given term indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See DeleteDocument(Int32) for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method | Directory | (Overrides IndexReader Directory .)
Public method Dispose
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Protected method | Dispose(Boolean) | (Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader DoClose .)
Protected method | DoCommit | (Overrides IndexReader DoCommit(IDictionary String, String ).)
Public method Document(Int32)
Returns the stored fields of the nthDocument in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted.
(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader DoDelete(Int32).)
Protected method | DoSetNorm | (Overrides IndexReader DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader DoUndeleteAll .)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Flush
(Inherited from IndexReader.)
Public method | Flush(IDictionary String, String ) | (Inherited from IndexReader.)
Public method | GetFieldNames | (Overrides IndexReader GetFieldNames(IndexReader FieldOption).)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method | GetSequentialSubReaders | (Overrides IndexReader GetSequentialSubReaders .)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method | GetTermFreqVectors | (Overrides IndexReader GetTermFreqVectors(Int32).)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method | HasNorms | (Overrides IndexReader HasNorms(String).)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding DecRef , in a finally clause; otherwise the reader may never be closed. Note that Close simply calls decRef(), which means that the IndexReader will not really be closed until DecRef has been called for all outstanding references.
(Inherited from IndexReader.)
Public method | IsCurrent | (Overrides IndexReader IsCurrent .)
Public method | IsDeleted | (Overrides IndexReader IsDeleted(Int32).)
Public method | IsOptimized | (Overrides IndexReader IsOptimized .)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method | Norms(String) | (Overrides IndexReader Norms(String).)
Public method | Norms(String, Byte , Int32) | (Overrides IndexReader Norms(String, Byte , Int32).)
Public method | NumDocs | (Overrides IndexReader NumDocs .)
Public method Reopen
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:
View Colorized Copy to Clipboard Print
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from GetReader , reopen() will simply call writer.getReader() again for you, though this may change in the future.
(Inherited from IndexReader.)
Public method Reopen(Boolean)
Just like Reopen , except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method | TermDocs | (Overrides IndexReader TermDocs .)
Public method | TermDocs(Term) | (Overrides IndexReader TermDocs(Term).)
Public method | TermPositions | (Overrides IndexReader TermPositions .)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.
(Inherited from IndexReader.)
Public method | Terms | (Overrides IndexReader Terms .)
Public method | Terms(Term) | (Overrides IndexReader Terms(Term).)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)
Back to Top
See Also
FilterIndexReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

FilterIndexReader Clone Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Clone | (Overrides IndexReader Clone .)
Public method | Clone(Boolean) | Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader. (Inherited from IndexReader.)
Back to Top
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

FilterIndexReader Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
See Also
FilterIndexReader Class
FilterIndexReader Members
Clone Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Directory Method

FilterIndexReader Directory Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Directory Directory()
public override Directory Directory()
Public Overrides Function Directory As Directory
Public Overrides Function Directory As Directory
public:
virtual Directory^ Directory() override
public:
virtual Directory^ Directory() override
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocFreq Method

FilterIndexReader DocFreq Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocFreq(
    Term t
)
public override int DocFreq(
    Term t
)
Public Overrides Function DocFreq ( _
    t As Term _
) As Integer
Public Overrides Function DocFreq ( _
    t As Term _
) As Integer
public:
virtual int DocFreq(
    Term^ t
) override
public:
virtual int DocFreq(
    Term^ t
) override
Parameters
t
Type: Lucene.Net.Index Term
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoClose Method

FilterIndexReader DoClose Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoClose()
protected override void DoClose()
Protected Overrides Sub DoClose
Protected Overrides Sub DoClose
protected:
virtual void DoClose() override
protected:
virtual void DoClose() override
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoCommit Method

FilterIndexReader DoCommit Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoCommit(
    IDictionary<string, string> commitUserData
)
protected override void DoCommit(
    IDictionary<string, string> commitUserData
)
Protected Overrides Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
Protected Overrides Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
protected:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
) override
protected:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
) override
Parameters
commitUserData
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Method

FilterIndexReader Document Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Document(Int32) | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader Document(Int32, FieldSelector).)
Back to Top
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Method (Int32, FieldSelector)

FilterIndexReader Document Method (Int32, FieldSelector) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Document Document(
    int n,
    FieldSelector fieldSelector
)
public override Document Document(
    int n,
    FieldSelector fieldSelector
)
Public Overrides Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Public Overrides Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) override
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) override
Parameters
n
Type:   Online System Int32
fieldSelector
Type: Lucene.Net.Documents FieldSelector
See Also
FilterIndexReader Class
FilterIndexReader Members
Document Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoDelete Method

FilterIndexReader DoDelete Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoDelete(
    int n
)
protected override void DoDelete(
    int n
)
Protected Overrides Sub DoDelete ( _
    n As Integer _
)
Protected Overrides Sub DoDelete ( _
    n As Integer _
)
protected:
virtual void DoDelete(
    int n
) override
protected:
virtual void DoDelete(
    int n
) override
Parameters
n
Type:   Online System Int32
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoSetNorm Method

FilterIndexReader DoSetNorm Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSetNorm(
    int d,
    string f,
    byte b
)
protected override void DoSetNorm(
    int d,
    string f,
    byte b
)
Protected Overrides Sub DoSetNorm ( _
    d As Integer, _
    f As String, _
    b As Byte _
)
Protected Overrides Sub DoSetNorm ( _
    d As Integer, _
    f As String, _
    b As Byte _
)
protected:
virtual void DoSetNorm(
    int d,
    String^ f,
    unsigned char b
) override
protected:
virtual void DoSetNorm(
    int d,
    String^ f,
    unsigned char b
) override
Parameters
d
Type:   Online System Int32
f
Type:   Online System String
b
Type:   Online System Byte
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoUndeleteAll Method

FilterIndexReader DoUndeleteAll Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoUndeleteAll()
protected override void DoUndeleteAll()
Protected Overrides Sub DoUndeleteAll
Protected Overrides Sub DoUndeleteAll
protected:
virtual void DoUndeleteAll() override
protected:
virtual void DoUndeleteAll() override
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFieldNames Method

FilterIndexReader GetFieldNames Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fieldNames
)
public override ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fieldNames
)
Public Overrides Function GetFieldNames ( _
    fieldNames As IndexReader..::..FieldOption _
) As ICollection(Of String)
Public Overrides Function GetFieldNames ( _
    fieldNames As IndexReader..::..FieldOption _
) As ICollection(Of String)
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fieldNames
) override
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fieldNames
) override
Parameters
fieldNames
Type: Lucene.Net.Index IndexReader FieldOption
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSequentialSubReaders Method

FilterIndexReader GetSequentialSubReaders Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexReader[] GetSequentialSubReaders()
public override IndexReader[] GetSequentialSubReaders()
Public Overrides Function GetSequentialSubReaders As IndexReader()
Public Overrides Function GetSequentialSubReaders As IndexReader()
public:
virtual array<IndexReader^>^ GetSequentialSubReaders() override
public:
virtual array<IndexReader^>^ GetSequentialSubReaders() override
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method

FilterIndexReader GetTermFreqVector Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, String, TermVectorMapper).)
Back to Top
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, TermVectorMapper)

FilterIndexReader GetTermFreqVector Method (Int32, TermVectorMapper) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
public override void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) override
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) override
Parameters
docNumber
Type:   Online System Int32
mapper
Type: Lucene.Net.Index TermVectorMapper
See Also
FilterIndexReader Class
FilterIndexReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, String)

FilterIndexReader GetTermFreqVector Method (Int32, String) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ITermFreqVector GetTermFreqVector(
    int docNumber,
    string field
)
public override ITermFreqVector GetTermFreqVector(
    int docNumber,
    string field
)
Public Overrides Function GetTermFreqVector ( _
    docNumber As Integer, _
    field As String _
) As ITermFreqVector
Public Overrides Function GetTermFreqVector ( _
    docNumber As Integer, _
    field As String _
) As ITermFreqVector
public:
virtual ITermFreqVector^ GetTermFreqVector(
    int docNumber,
    String^ field
) override
public:
virtual ITermFreqVector^ GetTermFreqVector(
    int docNumber,
    String^ field
) override
Parameters
docNumber
Type:   Online System Int32
field
Type:   Online System String
See Also
FilterIndexReader Class
FilterIndexReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, String, TermVectorMapper)

FilterIndexReader GetTermFreqVector Method (Int32, String, TermVectorMapper) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
public override void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) override
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) override
Parameters
docNumber
Type:   Online System Int32
field
Type:   Online System String
mapper
Type: Lucene.Net.Index TermVectorMapper
See Also
FilterIndexReader Class
FilterIndexReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVectors Method

FilterIndexReader GetTermFreqVectors Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ITermFreqVector[] GetTermFreqVectors(
    int docNumber
)
public override ITermFreqVector[] GetTermFreqVectors(
    int docNumber
)
Public Overrides Function GetTermFreqVectors ( _
    docNumber As Integer _
) As ITermFreqVector()
Public Overrides Function GetTermFreqVectors ( _
    docNumber As Integer _
) As ITermFreqVector()
public:
virtual array<ITermFreqVector^>^ GetTermFreqVectors(
    int docNumber
) override
public:
virtual array<ITermFreqVector^>^ GetTermFreqVectors(
    int docNumber
) override
Parameters
docNumber
Type:   Online System Int32
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasNorms Method

FilterIndexReader HasNorms Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool HasNorms(
    string field
)
public override bool HasNorms(
    string field
)
Public Overrides Function HasNorms ( _
    field As String _
) As Boolean
Public Overrides Function HasNorms ( _
    field As String _
) As Boolean
public:
virtual bool HasNorms(
    String^ field
) override
public:
virtual bool HasNorms(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsCurrent Method

FilterIndexReader IsCurrent Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsCurrent()
public override bool IsCurrent()
Public Overrides Function IsCurrent As Boolean
Public Overrides Function IsCurrent As Boolean
public:
virtual bool IsCurrent() override
public:
virtual bool IsCurrent() override
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsDeleted Method

FilterIndexReader IsDeleted Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsDeleted(
    int n
)
public override bool IsDeleted(
    int n
)
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
public:
virtual bool IsDeleted(
    int n
) override
public:
virtual bool IsDeleted(
    int n
) override
Parameters
n
Type:   Online System Int32
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsOptimized Method

FilterIndexReader IsOptimized Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsOptimized()
public override bool IsOptimized()
Public Overrides Function IsOptimized As Boolean
Public Overrides Function IsOptimized As Boolean
public:
virtual bool IsOptimized() override
public:
virtual bool IsOptimized() override
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method

FilterIndexReader Norms Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Norms(String) | (Overrides IndexReader Norms(String).)
Public method | Norms(String, Byte , Int32) | (Overrides IndexReader Norms(String, Byte , Int32).)
Back to Top
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method (String)

FilterIndexReader Norms Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override byte[] Norms(
    string f
)
public override byte[] Norms(
    string f
)
Public Overrides Function Norms ( _
    f As String _
) As Byte()
Public Overrides Function Norms ( _
    f As String _
) As Byte()
public:
virtual array<unsigned char>^ Norms(
    String^ f
) override
public:
virtual array<unsigned char>^ Norms(
    String^ f
) override
Parameters
f
Type:   Online System String
See Also
FilterIndexReader Class
FilterIndexReader Members
Norms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method (String, Byte[], Int32)

FilterIndexReader Norms Method (String, Byte , Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Norms(
    string f,
    byte[] bytes,
    int offset
)
public override void Norms(
    string f,
    byte[] bytes,
    int offset
)
Public Overrides Sub Norms ( _
    f As String, _
    bytes As Byte(), _
    offset As Integer _
)
Public Overrides Sub Norms ( _
    f As String, _
    bytes As Byte(), _
    offset As Integer _
)
public:
virtual void Norms(
    String^ f,
    array<unsigned char>^ bytes,
    int offset
) override
public:
virtual void Norms(
    String^ f,
    array<unsigned char>^ bytes,
    int offset
) override
Parameters
f
Type:   Online System String
bytes
Type:    Online System Byte
offset
Type:   Online System Int32
See Also
FilterIndexReader Class
FilterIndexReader Members
Norms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumDocs Method

FilterIndexReader NumDocs Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int NumDocs()
public override int NumDocs()
Public Overrides Function NumDocs As Integer
Public Overrides Function NumDocs As Integer
public:
virtual int NumDocs() override
public:
virtual int NumDocs() override
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Method

FilterIndexReader TermDocs Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TermDocs | (Overrides IndexReader TermDocs .)
Public method | TermDocs(Term) | (Overrides IndexReader TermDocs(Term).)
Back to Top
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Method

FilterIndexReader TermDocs Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermDocs TermDocs()
public override TermDocs TermDocs()
Public Overrides Function TermDocs As TermDocs
Public Overrides Function TermDocs As TermDocs
public:
virtual TermDocs^ TermDocs() override
public:
virtual TermDocs^ TermDocs() override
See Also
FilterIndexReader Class
FilterIndexReader Members
TermDocs Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Method (Term)

FilterIndexReader TermDocs Method (Term) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermDocs TermDocs(
    Term term
)
public override TermDocs TermDocs(
    Term term
)
Public Overrides Function TermDocs ( _
    term As Term _
) As TermDocs
Public Overrides Function TermDocs ( _
    term As Term _
) As TermDocs
public:
virtual TermDocs^ TermDocs(
    Term^ term
) override
public:
virtual TermDocs^ TermDocs(
    Term^ term
) override
Parameters
term
Type: Lucene.Net.Index Term
See Also
FilterIndexReader Class
FilterIndexReader Members
TermDocs Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Method

FilterIndexReader TermPositions Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TermPositions | (Overrides IndexReader TermPositions .)
Public method | TermPositions(Term) | Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping: Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >* This positional information facilitates phrase and proximity searching. The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Back to Top
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Method

FilterIndexReader TermPositions Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermPositions TermPositions()
public override TermPositions TermPositions()
Public Overrides Function TermPositions As TermPositions
Public Overrides Function TermPositions As TermPositions
public:
virtual TermPositions^ TermPositions() override
public:
virtual TermPositions^ TermPositions() override
See Also
FilterIndexReader Class
FilterIndexReader Members
TermPositions Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method

FilterIndexReader Terms Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Terms | (Overrides IndexReader Terms .)
Public method | Terms(Term) | (Overrides IndexReader Terms(Term).)
Back to Top
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method

FilterIndexReader Terms Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermEnum Terms()
public override TermEnum Terms()
Public Overrides Function Terms As TermEnum
Public Overrides Function Terms As TermEnum
public:
virtual TermEnum^ Terms() override
public:
virtual TermEnum^ Terms() override
See Also
FilterIndexReader Class
FilterIndexReader Members
Terms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method (Term)

FilterIndexReader Terms Method (Term) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermEnum Terms(
    Term t
)
public override TermEnum Terms(
    Term t
)
Public Overrides Function Terms ( _
    t As Term _
) As TermEnum
Public Overrides Function Terms ( _
    t As Term _
) As TermEnum
public:
virtual TermEnum^ Terms(
    Term^ t
) override
public:
virtual TermEnum^ Terms(
    Term^ t
) override
Parameters
t
Type: Lucene.Net.Index Term
See Also
FilterIndexReader Class
FilterIndexReader Members
Terms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader Properties

FilterIndexReader Properties Lucene.Net Class Library
The FilterIndexReader type exposes the following members.
Properties
 | Name | Description
Public property | CommitUserData | Retrieve the String userData optionally passed to Commit(IDictionary String, String ). This will return null if Commit(IDictionary String, String ) has never been called for this index. (Inherited from IndexReader.)
Public property | DeletesCacheKey | If the subclass of FilteredIndexReader modifies the deleted docs, you must override this method to provide a different key */ (Overrides IndexReader DeletesCacheKey.)
Public property | FieldCacheKey | If the subclass of FilteredIndexReader modifies the contents of the FieldCache, you must override this method to provide a different key */ (Overrides IndexReader FieldCacheKey.)
Public property | HasDeletions | (Overrides IndexReader HasDeletions.)
Public property | IndexCommit | Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: this API is new and experimental and may suddenly change. (Inherited from IndexReader.)
Public property | Item | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public property | MaxDoc | (Overrides IndexReader MaxDoc.)
Public property | NumDeletedDocs | Returns the number of deleted documents. (Inherited from IndexReader.)
Public property | RefCount | Expert: returns the current refCount for this reader (Inherited from IndexReader.)
Public property | TermInfosIndexDivisor | For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened. (Inherited from IndexReader.)
Public property | UniqueTermCount | Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed. (Inherited from IndexReader.)
Public property | Version | (Overrides IndexReader Version.)
Back to Top
See Also
FilterIndexReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DeletesCacheKey Property

FilterIndexReader DeletesCacheKey Property Lucene.Net Class Library
If the subclass of FilteredIndexReader modifies the deleted docs, you must override this method to provide a different key */

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object DeletesCacheKey { get; }
public override Object DeletesCacheKey { get; }
Public Overrides ReadOnly Property DeletesCacheKey As Object
    Get
Public Overrides ReadOnly Property DeletesCacheKey As Object
    Get
public:
virtual property Object^ DeletesCacheKey {
    Object^ get () override;
}
public:
virtual property Object^ DeletesCacheKey {
    Object^ get () override;
}
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheKey Property

FilterIndexReader FieldCacheKey Property Lucene.Net Class Library
If the subclass of FilteredIndexReader modifies the contents of the FieldCache, you must override this method to provide a different key */

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object FieldCacheKey { get; }
public override Object FieldCacheKey { get; }
Public Overrides ReadOnly Property FieldCacheKey As Object
    Get
Public Overrides ReadOnly Property FieldCacheKey As Object
    Get
public:
virtual property Object^ FieldCacheKey {
    Object^ get () override;
}
public:
virtual property Object^ FieldCacheKey {
    Object^ get () override;
}
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasDeletions Property

FilterIndexReader HasDeletions Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool HasDeletions { get; }
public override bool HasDeletions { get; }
Public Overrides ReadOnly Property HasDeletions As Boolean
    Get
Public Overrides ReadOnly Property HasDeletions As Boolean
    Get
public:
virtual property bool HasDeletions {
    bool get () override;
}
public:
virtual property bool HasDeletions {
    bool get () override;
}
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxDoc Property

FilterIndexReader MaxDoc Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int MaxDoc { get; }
public override int MaxDoc { get; }
Public Overrides ReadOnly Property MaxDoc As Integer
    Get
Public Overrides ReadOnly Property MaxDoc As Integer
    Get
public:
virtual property int MaxDoc {
    int get () override;
}
public:
virtual property int MaxDoc {
    int get () override;
}
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Version Property

FilterIndexReader Version Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Version { get; }
public override long Version { get; }
Public Overrides ReadOnly Property Version As Long
    Get
Public Overrides ReadOnly Property Version As Long
    Get
public:
virtual property long long Version {
    long long get () override;
}
public:
virtual property long long Version {
    long long get () override;
}
See Also
FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermDocs Class

FilterIndexReader FilterTermDocs Class Lucene.Net Class Library
Base class for filtering TermDocs implementations.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index FilterIndexReader FilterTermDocs
Lucene.Net.Index FilterIndexReader FilterTermPositions

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FilterTermDocs : TermDocs,
    IDisposable
public class FilterTermDocs : TermDocs,
    IDisposable
Public Class FilterTermDocs _
    Implements TermDocs, IDisposable
Public Class FilterTermDocs _
    Implements TermDocs, IDisposable
public ref class FilterTermDocs : TermDocs,
    IDisposable
public ref class FilterTermDocs : TermDocs,
    IDisposable
See Also
FilterIndexReader FilterTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermDocs Members

FilterIndexReader FilterTermDocs Members Lucene.Net Class Library

A FilterIndexReader contains another IndexReader, which it uses as its basic source of data, possibly transforming the data along the way or providing additional functionality. The class FilterIndexReader itself simply implements all abstract methods of IndexReader with versions that pass all requests to the contained index reader. Subclasses of FilterIndexReader may further override some of these methods and may also provide additional methods and fields.

The FilterIndexReader FilterTermDocs type exposes the following members.
Constructors
 | Name | Description
Public method | FilterIndexReader FilterTermDocs | Initializes a new instance of the FilterIndexReader FilterTermDocs class
Back to Top
Methods
 | Name | Description
Public method | Close |
Public method | Dispose | Releases all resources used by the FilterIndexReader FilterTermDocs
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FilterIndexReader FilterTermDocs and optionally releases the managed resources
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next |
Public method | Read |
Public method | Seek(Term) |
Public method | Seek(TermEnum) |
Public method | SkipTo |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | in_Renamed |
Back to Top
Properties
 | Name | Description
Public property | Doc |
Public property | Freq |
Back to Top
See Also
FilterIndexReader FilterTermDocs Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermDocs Constructor

FilterIndexReader FilterTermDocs Constructor Lucene.Net Class Library
Initializes a new instance of the FilterIndexReader FilterTermDocs class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FilterTermDocs(
    TermDocs in_Renamed
)
public FilterTermDocs(
    TermDocs in_Renamed
)
Public Sub New ( _
    in_Renamed As TermDocs _
)
Public Sub New ( _
    in_Renamed As TermDocs _
)
public:
FilterTermDocs(
    TermDocs^ in_Renamed
)
public:
FilterTermDocs(
    TermDocs^ in_Renamed
)
Parameters
in_Renamed
Type: Lucene.Net.Index TermDocs
See Also
FilterIndexReader FilterTermDocs Class
FilterIndexReader FilterTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermDocs Fields

FilterIndexReader FilterTermDocs Fields Lucene.Net Class Library
The FilterIndexReader FilterTermDocs type exposes the following members.
Fields
 | Name | Description
Protected field | in_Renamed |
Back to Top
See Also
FilterIndexReader FilterTermDocs Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


in_Renamed Field

FilterIndexReader FilterTermDocs in_Renamed Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TermDocs in_Renamed
protected TermDocs in_Renamed
Protected in_Renamed As TermDocs
Protected in_Renamed As TermDocs
protected:
TermDocs^ in_Renamed
protected:
TermDocs^ in_Renamed
See Also
FilterIndexReader FilterTermDocs Class
FilterIndexReader FilterTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermDocs Methods

FilterIndexReader FilterTermDocs Methods Lucene.Net Class Library
The FilterIndexReader FilterTermDocs type exposes the following members.
Methods
 | Name | Description
Public method | Close |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next |
Public method | Read |
Public method | Seek(Term) |
Public method | Seek(TermEnum) |
Public method | SkipTo |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FilterIndexReader FilterTermDocs Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

FilterIndexReader FilterTermDocs Close Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Close()
public void Close()
Public Sub Close
Public Sub Close
public:
virtual void Close() sealed
public:
virtual void Close() sealed
Implements
TermDocs Close
See Also
FilterIndexReader FilterTermDocs Class
FilterIndexReader FilterTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

FilterIndexReader FilterTermDocs Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the FilterIndexReader FilterTermDocs
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FilterIndexReader FilterTermDocs and optionally releases the managed resources
Back to Top
See Also
FilterIndexReader FilterTermDocs Class
FilterIndexReader FilterTermDocs Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

FilterIndexReader FilterTermDocs Dispose Method Lucene.Net Class Library
Releases all resources used by the FilterIndexReader FilterTermDocs

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
FilterIndexReader FilterTermDocs Class
FilterIndexReader FilterTermDocs Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

FilterIndexReader FilterTermDocs Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the FilterIndexReader FilterTermDocs and optionally releases the managed resources

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void Dispose(
    bool disposing
)
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
)
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
FilterIndexReader FilterTermDocs Class
FilterIndexReader FilterTermDocs Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Next Method

FilterIndexReader FilterTermDocs Next Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Next()
public virtual bool Next()
Public Overridable Function Next As Boolean
Public Overridable Function Next As Boolean
public:
virtual bool Next()
public:
virtual bool Next()
Implements
TermDocs Next
See Also
FilterIndexReader FilterTermDocs Class
FilterIndexReader FilterTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Read Method

FilterIndexReader FilterTermDocs Read Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Read(
    int[] docs,
    int[] freqs
)
public virtual int Read(
    int[] docs,
    int[] freqs
)
Public Overridable Function Read ( _
    docs As Integer(), _
    freqs As Integer() _
) As Integer
Public Overridable Function Read ( _
    docs As Integer(), _
    freqs As Integer() _
) As Integer
public:
virtual int Read(
    array<int>^ docs,
    array<int>^ freqs
)
public:
virtual int Read(
    array<int>^ docs,
    array<int>^ freqs
)
Parameters
docs
Type:    Online System Int32
freqs
Type:    Online System Int32
Implements
TermDocs Read( Int32 ,  Int32 )
See Also
FilterIndexReader FilterTermDocs Class
FilterIndexReader FilterTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method

FilterIndexReader FilterTermDocs Seek Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Seek(Term) |
Public method | Seek(TermEnum) |
Back to Top
See Also
FilterIndexReader FilterTermDocs Class
FilterIndexReader FilterTermDocs Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method (Term)

FilterIndexReader FilterTermDocs Seek Method (Term) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Seek(
    Term term
)
public virtual void Seek(
    Term term
)
Public Overridable Sub Seek ( _
    term As Term _
)
Public Overridable Sub Seek ( _
    term As Term _
)
public:
virtual void Seek(
    Term^ term
)
public:
virtual void Seek(
    Term^ term
)
Parameters
term
Type: Lucene.Net.Index Term
Implements
TermDocs Seek(Term)
See Also
FilterIndexReader FilterTermDocs Class
FilterIndexReader FilterTermDocs Members
Seek Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method (TermEnum)

FilterIndexReader FilterTermDocs Seek Method (TermEnum) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Seek(
    TermEnum termEnum
)
public virtual void Seek(
    TermEnum termEnum
)
Public Overridable Sub Seek ( _
    termEnum As TermEnum _
)
Public Overridable Sub Seek ( _
    termEnum As TermEnum _
)
public:
virtual void Seek(
    TermEnum^ termEnum
)
public:
virtual void Seek(
    TermEnum^ termEnum
)
Parameters
termEnum
Type: Lucene.Net.Index TermEnum
Implements
TermDocs Seek(TermEnum)
See Also
FilterIndexReader FilterTermDocs Class
FilterIndexReader FilterTermDocs Members
Seek Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SkipTo Method

FilterIndexReader FilterTermDocs SkipTo Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool SkipTo(
    int i
)
public virtual bool SkipTo(
    int i
)
Public Overridable Function SkipTo ( _
    i As Integer _
) As Boolean
Public Overridable Function SkipTo ( _
    i As Integer _
) As Boolean
public:
virtual bool SkipTo(
    int i
)
public:
virtual bool SkipTo(
    int i
)
Parameters
i
Type:   Online System Int32
Implements
TermDocs SkipTo(Int32)
See Also
FilterIndexReader FilterTermDocs Class
FilterIndexReader FilterTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermDocs Properties

FilterIndexReader FilterTermDocs Properties Lucene.Net Class Library
The FilterIndexReader FilterTermDocs type exposes the following members.
Properties
 | Name | Description
Public property | Doc |
Public property | Freq |
Back to Top
See Also
FilterIndexReader FilterTermDocs Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Property

FilterIndexReader FilterTermDocs Doc Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Doc { get; }
public virtual int Doc { get; }
Public Overridable ReadOnly Property Doc As Integer
    Get
Public Overridable ReadOnly Property Doc As Integer
    Get
public:
virtual property int Doc {
    int get ();
}
public:
virtual property int Doc {
    int get ();
}
Implements
TermDocs Doc
See Also
FilterIndexReader FilterTermDocs Class
FilterIndexReader FilterTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Freq Property

FilterIndexReader FilterTermDocs Freq Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Freq { get; }
public virtual int Freq { get; }
Public Overridable ReadOnly Property Freq As Integer
    Get
Public Overridable ReadOnly Property Freq As Integer
    Get
public:
virtual property int Freq {
    int get ();
}
public:
virtual property int Freq {
    int get ();
}
Implements
TermDocs Freq
See Also
FilterIndexReader FilterTermDocs Class
FilterIndexReader FilterTermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermEnum Class

FilterIndexReader FilterTermEnum Class Lucene.Net Class Library
Base class for filtering TermEnum implementations.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index TermEnum
Lucene.Net.Index FilterIndexReader FilterTermEnum

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FilterTermEnum : TermEnum
public class FilterTermEnum : TermEnum
Public Class FilterTermEnum _
    Inherits TermEnum
Public Class FilterTermEnum _
    Inherits TermEnum
public ref class FilterTermEnum : public TermEnum
public ref class FilterTermEnum : public TermEnum
See Also
FilterIndexReader FilterTermEnum Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermEnum Members

FilterIndexReader FilterTermEnum Members Lucene.Net Class Library

A FilterIndexReader contains another IndexReader, which it uses as its basic source of data, possibly transforming the data along the way or providing additional functionality. The class FilterIndexReader itself simply implements all abstract methods of IndexReader with versions that pass all requests to the contained index reader. Subclasses of FilterIndexReader may further override some of these methods and may also provide additional methods and fields.

The FilterIndexReader FilterTermEnum type exposes the following members.
Constructors
 | Name | Description
Public method | FilterIndexReader FilterTermEnum | Initializes a new instance of the FilterIndexReader FilterTermEnum class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Public method | Dispose | Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FilterIndexReader FilterTermEnum and optionally releases the managed resources (Overrides TermEnum Dispose(Boolean).)
Public method | DocFreq | (Overrides TermEnum DocFreq .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | (Overrides TermEnum Next .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | in_Renamed |
Back to Top
Properties
 | Name | Description
Public property | Term | (Overrides TermEnum Term.)
Back to Top
See Also
FilterIndexReader FilterTermEnum Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermEnum Constructor

FilterIndexReader FilterTermEnum Constructor Lucene.Net Class Library
Initializes a new instance of the FilterIndexReader FilterTermEnum class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FilterTermEnum(
    TermEnum in_Renamed
)
public FilterTermEnum(
    TermEnum in_Renamed
)
Public Sub New ( _
    in_Renamed As TermEnum _
)
Public Sub New ( _
    in_Renamed As TermEnum _
)
public:
FilterTermEnum(
    TermEnum^ in_Renamed
)
public:
FilterTermEnum(
    TermEnum^ in_Renamed
)
Parameters
in_Renamed
Type: Lucene.Net.Index TermEnum
See Also
FilterIndexReader FilterTermEnum Class
FilterIndexReader FilterTermEnum Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermEnum Fields

FilterIndexReader FilterTermEnum Fields Lucene.Net Class Library
The FilterIndexReader FilterTermEnum type exposes the following members.
Fields
 | Name | Description
Protected field | in_Renamed |
Back to Top
See Also
FilterIndexReader FilterTermEnum Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


in_Renamed Field

FilterIndexReader FilterTermEnum in_Renamed Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TermEnum in_Renamed
protected TermEnum in_Renamed
Protected in_Renamed As TermEnum
Protected in_Renamed As TermEnum
protected:
TermEnum^ in_Renamed
protected:
TermEnum^ in_Renamed
See Also
FilterIndexReader FilterTermEnum Class
FilterIndexReader FilterTermEnum Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermEnum Methods

FilterIndexReader FilterTermEnum Methods Lucene.Net Class Library
The FilterIndexReader FilterTermEnum type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Public method | Dispose | Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Protected method | Dispose(Boolean) | (Overrides TermEnum Dispose(Boolean).)
Public method | DocFreq | (Overrides TermEnum DocFreq .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | (Overrides TermEnum Next .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FilterIndexReader FilterTermEnum Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

FilterIndexReader FilterTermEnum Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FilterIndexReader FilterTermEnum and optionally releases the managed resources (Overrides TermEnum Dispose(Boolean).)
Back to Top
See Also
FilterIndexReader FilterTermEnum Class
FilterIndexReader FilterTermEnum Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

FilterIndexReader FilterTermEnum Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the FilterIndexReader FilterTermEnum and optionally releases the managed resources

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
FilterIndexReader FilterTermEnum Class
FilterIndexReader FilterTermEnum Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocFreq Method

FilterIndexReader FilterTermEnum DocFreq Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocFreq()
public override int DocFreq()
Public Overrides Function DocFreq As Integer
Public Overrides Function DocFreq As Integer
public:
virtual int DocFreq() override
public:
virtual int DocFreq() override
See Also
FilterIndexReader FilterTermEnum Class
FilterIndexReader FilterTermEnum Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Next Method

FilterIndexReader FilterTermEnum Next Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Next()
public override bool Next()
Public Overrides Function Next As Boolean
Public Overrides Function Next As Boolean
public:
virtual bool Next() override
public:
virtual bool Next() override
See Also
FilterIndexReader FilterTermEnum Class
FilterIndexReader FilterTermEnum Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermEnum Properties

FilterIndexReader FilterTermEnum Properties Lucene.Net Class Library
The FilterIndexReader FilterTermEnum type exposes the following members.
Properties
 | Name | Description
Public property | Term | (Overrides TermEnum Term.)
Back to Top
See Also
FilterIndexReader FilterTermEnum Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Property

FilterIndexReader FilterTermEnum Term Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Term Term { get; }
public override Term Term { get; }
Public Overrides ReadOnly Property Term As Term
    Get
Public Overrides ReadOnly Property Term As Term
    Get
public:
virtual property Term^ Term {
    Term^ get () override;
}
public:
virtual property Term^ Term {
    Term^ get () override;
}
See Also
FilterIndexReader FilterTermEnum Class
FilterIndexReader FilterTermEnum Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermPositions Class

FilterIndexReader FilterTermPositions Class Lucene.Net Class Library
Base class for filtering TermPositions implementations.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index FilterIndexReader FilterTermDocs
Lucene.Net.Index FilterIndexReader FilterTermPositions

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FilterTermPositions : FilterIndexReader..::..FilterTermDocs,
    TermPositions, TermDocs, IDisposable
public class FilterTermPositions : FilterIndexReader..::..FilterTermDocs,
    TermPositions, TermDocs, IDisposable
Public Class FilterTermPositions _
    Inherits FilterIndexReader..::..FilterTermDocs _
    Implements TermPositions, TermDocs, IDisposable
Public Class FilterTermPositions _
    Inherits FilterIndexReader..::..FilterTermDocs _
    Implements TermPositions, TermDocs, IDisposable
public ref class FilterTermPositions : public FilterIndexReader..::..FilterTermDocs,
    TermPositions, TermDocs, IDisposable
public ref class FilterTermPositions : public FilterIndexReader..::..FilterTermDocs,
    TermPositions, TermDocs, IDisposable
See Also
FilterIndexReader FilterTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermPositions Members

FilterIndexReader FilterTermPositions Members Lucene.Net Class Library

A FilterIndexReader contains another IndexReader, which it uses as its basic source of data, possibly transforming the data along the way or providing additional functionality. The class FilterIndexReader itself simply implements all abstract methods of IndexReader with versions that pass all requests to the contained index reader. Subclasses of FilterIndexReader may further override some of these methods and may also provide additional methods and fields.

The FilterIndexReader FilterTermPositions type exposes the following members.
Constructors
 | Name | Description
Public method | FilterIndexReader FilterTermPositions | Initializes a new instance of the FilterIndexReader FilterTermPositions class
Back to Top
Methods
 | Name | Description
Public method | Close | (Inherited from FilterIndexReader FilterTermDocs.)
Public method | Dispose | (Inherited from FilterIndexReader FilterTermDocs.)
Protected method | Dispose(Boolean) | (Inherited from FilterIndexReader FilterTermDocs.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPayload |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | (Inherited from FilterIndexReader FilterTermDocs.)
Public method | NextPosition |
Public method | Read | (Inherited from FilterIndexReader FilterTermDocs.)
Public method | Seek(Term) | (Inherited from FilterIndexReader FilterTermDocs.)
Public method | Seek(TermEnum) | (Inherited from FilterIndexReader FilterTermDocs.)
Public method | SkipTo | (Inherited from FilterIndexReader FilterTermDocs.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | in_Renamed | (Inherited from FilterIndexReader FilterTermDocs.)
Back to Top
Properties
 | Name | Description
Public property | Doc | (Inherited from FilterIndexReader FilterTermDocs.)
Public property | Freq | (Inherited from FilterIndexReader FilterTermDocs.)
Public property | IsPayloadAvailable |
Public property | PayloadLength |
Back to Top
See Also
FilterIndexReader FilterTermPositions Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermPositions Constructor

FilterIndexReader FilterTermPositions Constructor Lucene.Net Class Library
Initializes a new instance of the FilterIndexReader FilterTermPositions class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FilterTermPositions(
    TermPositions in_Renamed
)
public FilterTermPositions(
    TermPositions in_Renamed
)
Public Sub New ( _
    in_Renamed As TermPositions _
)
Public Sub New ( _
    in_Renamed As TermPositions _
)
public:
FilterTermPositions(
    TermPositions^ in_Renamed
)
public:
FilterTermPositions(
    TermPositions^ in_Renamed
)
Parameters
in_Renamed
Type: Lucene.Net.Index TermPositions
See Also
FilterIndexReader FilterTermPositions Class
FilterIndexReader FilterTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermPositions Fields

FilterIndexReader FilterTermPositions Fields Lucene.Net Class Library
The FilterIndexReader FilterTermPositions type exposes the following members.
Fields
 | Name | Description
Protected field | in_Renamed | (Inherited from FilterIndexReader FilterTermDocs.)
Back to Top
See Also
FilterIndexReader FilterTermPositions Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermPositions Methods

FilterIndexReader FilterTermPositions Methods Lucene.Net Class Library
The FilterIndexReader FilterTermPositions type exposes the following members.
Methods
 | Name | Description
Public method | Close | (Inherited from FilterIndexReader FilterTermDocs.)
Public method | Dispose | (Inherited from FilterIndexReader FilterTermDocs.)
Protected method | Dispose(Boolean) | (Inherited from FilterIndexReader FilterTermDocs.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPayload |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | (Inherited from FilterIndexReader FilterTermDocs.)
Public method | NextPosition |
Public method | Read | (Inherited from FilterIndexReader FilterTermDocs.)
Public method | Seek(Term) | (Inherited from FilterIndexReader FilterTermDocs.)
Public method | Seek(TermEnum) | (Inherited from FilterIndexReader FilterTermDocs.)
Public method | SkipTo | (Inherited from FilterIndexReader FilterTermDocs.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FilterIndexReader FilterTermPositions Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPayload Method

FilterIndexReader FilterTermPositions GetPayload Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual byte[] GetPayload(
    byte[] data,
    int offset
)
public virtual byte[] GetPayload(
    byte[] data,
    int offset
)
Public Overridable Function GetPayload ( _
    data As Byte(), _
    offset As Integer _
) As Byte()
Public Overridable Function GetPayload ( _
    data As Byte(), _
    offset As Integer _
) As Byte()
public:
virtual array<unsigned char>^ GetPayload(
    array<unsigned char>^ data,
    int offset
)
public:
virtual array<unsigned char>^ GetPayload(
    array<unsigned char>^ data,
    int offset
)
Parameters
data
Type:    Online System Byte
offset
Type:   Online System Int32
Implements
TermPositions GetPayload( Byte , Int32)
See Also
FilterIndexReader FilterTermPositions Class
FilterIndexReader FilterTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextPosition Method

FilterIndexReader FilterTermPositions NextPosition Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int NextPosition()
public virtual int NextPosition()
Public Overridable Function NextPosition As Integer
Public Overridable Function NextPosition As Integer
public:
virtual int NextPosition()
public:
virtual int NextPosition()
Implements
TermPositions NextPosition
See Also
FilterIndexReader FilterTermPositions Class
FilterIndexReader FilterTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterIndexReader.FilterTermPositions Properties

FilterIndexReader FilterTermPositions Properties Lucene.Net Class Library
The FilterIndexReader FilterTermPositions type exposes the following members.
Properties
 | Name | Description
Public property | Doc | (Inherited from FilterIndexReader FilterTermDocs.)
Public property | Freq | (Inherited from FilterIndexReader FilterTermDocs.)
Public property | IsPayloadAvailable |
Public property | PayloadLength |
Back to Top
See Also
FilterIndexReader FilterTermPositions Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsPayloadAvailable Property

FilterIndexReader FilterTermPositions IsPayloadAvailable Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsPayloadAvailable { get; }
public virtual bool IsPayloadAvailable { get; }
Public Overridable ReadOnly Property IsPayloadAvailable As Boolean
    Get
Public Overridable ReadOnly Property IsPayloadAvailable As Boolean
    Get
public:
virtual property bool IsPayloadAvailable {
    bool get ();
}
public:
virtual property bool IsPayloadAvailable {
    bool get ();
}
Implements
TermPositions IsPayloadAvailable
See Also
FilterIndexReader FilterTermPositions Class
FilterIndexReader FilterTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadLength Property

FilterIndexReader FilterTermPositions PayloadLength Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int PayloadLength { get; }
public virtual int PayloadLength { get; }
Public Overridable ReadOnly Property PayloadLength As Integer
    Get
Public Overridable ReadOnly Property PayloadLength As Integer
    Get
public:
virtual property int PayloadLength {
    int get ();
}
public:
virtual property int PayloadLength {
    int get ();
}
Implements
TermPositions PayloadLength
See Also
FilterIndexReader FilterTermPositions Class
FilterIndexReader FilterTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexCommit Class

IndexCommit Class Lucene.Net Class Library

Expert: represents a single commit into an index as seen by the IndexDeletionPolicy or IndexReader.

Changes to the content of an index are made visible only after the writer who made that change commits by writing a new segments file (segments_N). This point in time, when the action of writing of a new segments file to the directory is completed, is an index commit.

Each index commit point has a unique segments file associated with it. The segments file associated with a later index commit point would have a larger N.

WARNING: This API is a new and experimental and may suddenly change.

Inheritance Hierarchy
Online System Object
Lucene.Net.Index IndexCommit

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class IndexCommit
public abstract class IndexCommit
Public MustInherit Class IndexCommit
Public MustInherit Class IndexCommit
public ref class IndexCommit abstract
public ref class IndexCommit abstract
See Also
IndexCommit Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexCommit Members

IndexCommit Members Lucene.Net Class Library

The IndexCommit type exposes the following members.
Constructors
 | Name | Description
Protected method | IndexCommit | Initializes a new instance of the IndexCommit class
Back to Top
Methods
 | Name | Description
Public method | Delete | Delete this commit point. This only applies when using the commit point in the context of IndexWriter's IndexDeletionPolicy. Upon calling this, the writer is notified that this commit point should be deleted. Decision that a commit-point should be deleted is taken by the IndexDeletionPolicy in effect and therefore this should only be called by its OnInit T (IList T ) or OnCommit T (IList T ) methods.
Public method | Equals | Two IndexCommits are equal if both their Directory and versions are equal. (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Directory | Returns the Directory for the index.
Public property | FileNames | Returns all index files referenced by this commit point.
Public property | Generation | Returns the generation (the _N in segments_N) for this IndexCommit
Public property | IsDeleted |
Public property | IsOptimized | Returns true if this commit is an optimized index.
Public property | SegmentsFileName | Get the segments file (segments_N) associated with this commit point.
Public property | Timestamp | Convenience method that returns the last modified time of the segments_N file corresponding to this index commit, equivalent to getDirectory().fileModified(getSegmentsFileName()).
Public property | UserData | Returns userData, previously passed to Commit(IDictionary String, String ) for this commit. IDictionary is String -> String.
Public property | Version | Returns the version for this IndexCommit. This is the same value that Version would return if it were opened on this commit.
Back to Top
See Also
IndexCommit Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexCommit Constructor

IndexCommit Constructor Lucene.Net Class Library
Initializes a new instance of the IndexCommit class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IndexCommit()
protected IndexCommit()
Protected Sub New
Protected Sub New
protected:
IndexCommit()
protected:
IndexCommit()
See Also
IndexCommit Class
IndexCommit Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexCommit Methods

IndexCommit Methods Lucene.Net Class Library
The IndexCommit type exposes the following members.
Methods
 | Name | Description
Public method | Delete | Delete this commit point. This only applies when using the commit point in the context of IndexWriter's IndexDeletionPolicy. Upon calling this, the writer is notified that this commit point should be deleted. Decision that a commit-point should be deleted is taken by the IndexDeletionPolicy in effect and therefore this should only be called by its OnInit T (IList T ) or OnCommit T (IList T ) methods.
Public method | Equals | Two IndexCommits are equal if both their Directory and versions are equal. (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
IndexCommit Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Delete Method

IndexCommit Delete Method Lucene.Net Class Library
Delete this commit point. This only applies when using the commit point in the context of IndexWriter's IndexDeletionPolicy.

Upon calling this, the writer is notified that this commit point should be deleted.

Decision that a commit-point should be deleted is taken by the IndexDeletionPolicy in effect and therefore this should only be called by its OnInit T (IList T ) or OnCommit T (IList T ) methods.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Delete()
public abstract void Delete()
Public MustOverride Sub Delete
Public MustOverride Sub Delete
public:
virtual void Delete() abstract
public:
virtual void Delete() abstract
See Also
IndexCommit Class
IndexCommit Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

IndexCommit Equals Method Lucene.Net Class Library
Two IndexCommits are equal if both their Directory and versions are equal.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object other
)
public override bool Equals(
    Object other
)
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ other
) override
public:
virtual bool Equals(
    Object^ other
) override
Parameters
other
Type:   Online System Object
See Also
IndexCommit Class
IndexCommit Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

IndexCommit GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
IndexCommit Class
IndexCommit Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexCommit Properties

IndexCommit Properties Lucene.Net Class Library
The IndexCommit type exposes the following members.
Properties
 | Name | Description
Public property | Directory | Returns the Directory for the index.
Public property | FileNames | Returns all index files referenced by this commit point.
Public property | Generation | Returns the generation (the _N in segments_N) for this IndexCommit
Public property | IsDeleted |
Public property | IsOptimized | Returns true if this commit is an optimized index.
Public property | SegmentsFileName | Get the segments file (segments_N) associated with this commit point.
Public property | Timestamp | Convenience method that returns the last modified time of the segments_N file corresponding to this index commit, equivalent to getDirectory().fileModified(getSegmentsFileName()).
Public property | UserData | Returns userData, previously passed to Commit(IDictionary String, String ) for this commit. IDictionary is String -> String.
Public property | Version | Returns the version for this IndexCommit. This is the same value that Version would return if it were opened on this commit.
Back to Top
See Also
IndexCommit Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Directory Property

IndexCommit Directory Property Lucene.Net Class Library
Returns the Directory for the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Directory Directory { get; }
public abstract Directory Directory { get; }
Public MustOverride ReadOnly Property Directory As Directory
    Get
Public MustOverride ReadOnly Property Directory As Directory
    Get
public:
virtual property Directory^ Directory {
    Directory^ get () abstract;
}
public:
virtual property Directory^ Directory {
    Directory^ get () abstract;
}
See Also
IndexCommit Class
IndexCommit Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileNames Property

IndexCommit FileNames Property Lucene.Net Class Library
Returns all index files referenced by this commit point.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract ICollection<string> FileNames { get; }
public abstract ICollection<string> FileNames { get; }
Public MustOverride ReadOnly Property FileNames As ICollection(Of String)
    Get
Public MustOverride ReadOnly Property FileNames As ICollection(Of String)
    Get
public:
virtual property ICollection<String^>^ FileNames {
    ICollection<String^>^ get () abstract;
}
public:
virtual property ICollection<String^>^ FileNames {
    ICollection<String^>^ get () abstract;
}
See Also
IndexCommit Class
IndexCommit Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Generation Property

IndexCommit Generation Property Lucene.Net Class Library
Returns the generation (the _N in segments_N) for this IndexCommit

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract long Generation { get; }
public abstract long Generation { get; }
Public MustOverride ReadOnly Property Generation As Long
    Get
Public MustOverride ReadOnly Property Generation As Long
    Get
public:
virtual property long long Generation {
    long long get () abstract;
}
public:
virtual property long long Generation {
    long long get () abstract;
}
See Also
IndexCommit Class
IndexCommit Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsDeleted Property

IndexCommit IsDeleted Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool IsDeleted { get; }
public abstract bool IsDeleted { get; }
Public MustOverride ReadOnly Property IsDeleted As Boolean
    Get
Public MustOverride ReadOnly Property IsDeleted As Boolean
    Get
public:
virtual property bool IsDeleted {
    bool get () abstract;
}
public:
virtual property bool IsDeleted {
    bool get () abstract;
}
See Also
IndexCommit Class
IndexCommit Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsOptimized Property

IndexCommit IsOptimized Property Lucene.Net Class Library
Returns true if this commit is an optimized index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool IsOptimized { get; }
public abstract bool IsOptimized { get; }
Public MustOverride ReadOnly Property IsOptimized As Boolean
    Get
Public MustOverride ReadOnly Property IsOptimized As Boolean
    Get
public:
virtual property bool IsOptimized {
    bool get () abstract;
}
public:
virtual property bool IsOptimized {
    bool get () abstract;
}
See Also
IndexCommit Class
IndexCommit Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentsFileName Property

IndexCommit SegmentsFileName Property Lucene.Net Class Library
Get the segments file (segments_N) associated with this commit point.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string SegmentsFileName { get; }
public abstract string SegmentsFileName { get; }
Public MustOverride ReadOnly Property SegmentsFileName As String
    Get
Public MustOverride ReadOnly Property SegmentsFileName As String
    Get
public:
virtual property String^ SegmentsFileName {
    String^ get () abstract;
}
public:
virtual property String^ SegmentsFileName {
    String^ get () abstract;
}
See Also
IndexCommit Class
IndexCommit Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Timestamp Property

IndexCommit Timestamp Property Lucene.Net Class Library
Convenience method that returns the last modified time of the segments_N file corresponding to this index commit, equivalent to getDirectory().fileModified(getSegmentsFileName()).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long Timestamp { get; }
public virtual long Timestamp { get; }
Public Overridable ReadOnly Property Timestamp As Long
    Get
Public Overridable ReadOnly Property Timestamp As Long
    Get
public:
virtual property long long Timestamp {
    long long get ();
}
public:
virtual property long long Timestamp {
    long long get ();
}
See Also
IndexCommit Class
IndexCommit Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UserData Property

IndexCommit UserData Property Lucene.Net Class Library
Returns userData, previously passed to Commit(IDictionary String, String ) for this commit. IDictionary is String -> String.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract IDictionary<string, string> UserData { get; }
public abstract IDictionary<string, string> UserData { get; }
Public MustOverride ReadOnly Property UserData As IDictionary(Of String, String)
    Get
Public MustOverride ReadOnly Property UserData As IDictionary(Of String, String)
    Get
public:
virtual property IDictionary<String^, String^>^ UserData {
    IDictionary<String^, String^>^ get () abstract;
}
public:
virtual property IDictionary<String^, String^>^ UserData {
    IDictionary<String^, String^>^ get () abstract;
}
See Also
IndexCommit Class
IndexCommit Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Version Property

IndexCommit Version Property Lucene.Net Class Library
Returns the version for this IndexCommit. This is the same value that Version would return if it were opened on this commit.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract long Version { get; }
public abstract long Version { get; }
Public MustOverride ReadOnly Property Version As Long
    Get
Public MustOverride ReadOnly Property Version As Long
    Get
public:
virtual property long long Version {
    long long get () abstract;
}
public:
virtual property long long Version {
    long long get () abstract;
}
See Also
IndexCommit Class
IndexCommit Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexDeletionPolicy Interface

IndexDeletionPolicy Interface Lucene.Net Class Library

Expert: policy for deletion of stale index commits.

Implement this interface, and pass it to one of the IndexWriter or IndexReader constructors, to customize when older point-in-time commits are deleted from the index directory. The default deletion policy is KeepOnlyLastCommitDeletionPolicy, which always removes old commits as soon as a new commit is done (this matches the behavior before 2.2).

One expected use case for this (and the reason why it was first created) is to work around problems with an index directory accessed via filesystems like NFS because NFS does not provide the "delete on last close" semantics that Lucene's "point in time" search normally relies on. By implementing a custom deletion policy, such as "a commit is only removed once it has been stale for more than X minutes", you can give your readers time to refresh to the new commit before IndexWriter removes the old commits. Note that doing so will increase the storage requirements of the index. See Online LUCENE-710 for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IndexDeletionPolicy
public interface IndexDeletionPolicy
Public Interface IndexDeletionPolicy
Public Interface IndexDeletionPolicy
public interface class IndexDeletionPolicy
public interface class IndexDeletionPolicy
See Also
IndexDeletionPolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexDeletionPolicy Members

IndexDeletionPolicy Members Lucene.Net Class Library

The IndexDeletionPolicy type exposes the following members.
Methods
 | Name | Description
Public method | OnCommit T | This is called each time the writer completed a commit. This gives the policy a chance to remove old commit points with each commit. The policy may now choose to delete old commit points by calling method Delete of IndexCommit. This method is only called when Commit or Close is called, or possibly not at all if the Rollback is called. Note: the last CommitPoint is the most recent one, i.e. the "front index state". Be careful not to delete it, unless you know for sure what you are doing, and unless you can afford to lose the index content while doing that.
Public method | OnInit T | This is called once when a writer is first instantiated to give the policy a chance to remove old commit points. The writer locates all index commits present in the index directory and calls this method. The policy may choose to delete some of the commit points, doing so by calling method Delete of IndexCommit. Note: the last CommitPoint is the most recent one, i.e. the "front index state". Be careful not to delete it, unless you know for sure what you are doing, and unless you can afford to lose the index content while doing that.
Back to Top
See Also
IndexDeletionPolicy Interface
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexDeletionPolicy Methods

IndexDeletionPolicy Methods Lucene.Net Class Library
The IndexDeletionPolicy type exposes the following members.
Methods
 | Name | Description
Public method | OnCommit T | This is called each time the writer completed a commit. This gives the policy a chance to remove old commit points with each commit. The policy may now choose to delete old commit points by calling method Delete of IndexCommit. This method is only called when Commit or Close is called, or possibly not at all if the Rollback is called. Note: the last CommitPoint is the most recent one, i.e. the "front index state". Be careful not to delete it, unless you know for sure what you are doing, and unless you can afford to lose the index content while doing that.
Public method | OnInit T | This is called once when a writer is first instantiated to give the policy a chance to remove old commit points. The writer locates all index commits present in the index directory and calls this method. The policy may choose to delete some of the commit points, doing so by calling method Delete of IndexCommit. Note: the last CommitPoint is the most recent one, i.e. the "front index state". Be careful not to delete it, unless you know for sure what you are doing, and unless you can afford to lose the index content while doing that.
Back to Top
See Also
IndexDeletionPolicy Interface
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OnCommit(T) Method

IndexDeletionPolicy OnCommit T Method Lucene.Net Class Library

This is called each time the writer completed a commit. This gives the policy a chance to remove old commit points with each commit.

The policy may now choose to delete old commit points by calling method Delete of IndexCommit.

This method is only called when Commit or Close is called, or possibly not at all if the Rollback is called.

Note: the last CommitPoint is the most recent one, i.e. the "front index state". Be careful not to delete it, unless you know for sure what you are doing, and unless you can afford to lose the index content while doing that.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void OnCommit<T>(
    IList<T> commits
)
where T : IndexCommit
void OnCommit<T>(
    IList<T> commits
)
where T : IndexCommit
Sub OnCommit(Of T As IndexCommit) ( _
    commits As IList(Of T) _
)
Sub OnCommit(Of T As IndexCommit) ( _
    commits As IList(Of T) _
)
generic<typename T>
where T : IndexCommit
void OnCommit(
    IList<T>^ commits
)
generic<typename T>
where T : IndexCommit
void OnCommit(
    IList<T>^ commits
)
Parameters
commits
Type:   Online System.Collections.Generic IList  T

             List of IndexCommit, sorted by age (the 0th one is the oldest commit).

Type Parameters
T
See Also
IndexDeletionPolicy Interface
IndexDeletionPolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OnInit(T) Method

IndexDeletionPolicy OnInit T Method Lucene.Net Class Library

This is called once when a writer is first instantiated to give the policy a chance to remove old commit points.

The writer locates all index commits present in the index directory and calls this method. The policy may choose to delete some of the commit points, doing so by calling method Delete of IndexCommit.

Note: the last CommitPoint is the most recent one, i.e. the "front index state". Be careful not to delete it, unless you know for sure what you are doing, and unless you can afford to lose the index content while doing that.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void OnInit<T>(
    IList<T> commits
)
where T : IndexCommit
void OnInit<T>(
    IList<T> commits
)
where T : IndexCommit
Sub OnInit(Of T As IndexCommit) ( _
    commits As IList(Of T) _
)
Sub OnInit(Of T As IndexCommit) ( _
    commits As IList(Of T) _
)
generic<typename T>
where T : IndexCommit
void OnInit(
    IList<T>^ commits
)
generic<typename T>
where T : IndexCommit
void OnInit(
    IList<T>^ commits
)
Parameters
commits
Type:   Online System.Collections.Generic IList  T
List of current
            point-in-time commits,
            sorted by age (the 0th one is the oldest commit).

Type Parameters
T
See Also
IndexDeletionPolicy Interface
IndexDeletionPolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexFileDeleter Class

IndexFileDeleter Class Lucene.Net Class Library

This class keeps track of each SegmentInfos instance that is still "live", either because it corresponds to a segments_N file in the Directory (a "commit", i.e. a committed SegmentInfos) or because it's an in-memory SegmentInfos that a writer is actively updating but has not yet committed. This class uses simple reference counting to map the live SegmentInfos instances to individual files in the Directory.

The same directory file may be referenced by more than one IndexCommit, i.e. more than one SegmentInfos. Therefore we count how many commits reference each file. When all the commits referencing a certain file have been deleted, the refcount for that file becomes zero, and the file is deleted.

A separate deletion policy interface (IndexDeletionPolicy) is consulted on creation (onInit) and once per commit (onCommit), to decide when a commit should be removed.

It is the business of the IndexDeletionPolicy to choose when to delete commit points. The actual mechanics of file deletion, retrying, etc, derived from the deletion of commit points is the business of the IndexFileDeleter.

The current default deletion policy is KeepOnlyLastCommitDeletionPolicy, which removes all prior commits when a new commit has completed. This matches the behavior before 2.2.

Note that you must hold the write.lock before instantiating this class. It opens segments_N file(s) directly with no retry logic.

Inheritance Hierarchy
Online System Object
Lucene.Net.Index IndexFileDeleter

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class IndexFileDeleter : IDisposable
public sealed class IndexFileDeleter : IDisposable
Public NotInheritable Class IndexFileDeleter _
    Implements IDisposable
Public NotInheritable Class IndexFileDeleter _
    Implements IDisposable
public ref class IndexFileDeleter sealed : IDisposable
public ref class IndexFileDeleter sealed : IDisposable
See Also
IndexFileDeleter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexFileDeleter Members

IndexFileDeleter Members Lucene.Net Class Library

The IndexFileDeleter type exposes the following members.
Constructors
 | Name | Description
Public method | IndexFileDeleter | Initialize the deleter: find all previous commits in the Directory, incref the files they reference, call the policy to let it delete commits. This will remove any files not referenced by any of the commits.
Back to Top
Methods
 | Name | Description
Public method | Checkpoint | For definition of "check point" see IndexWriter comments: "Clarification: Check Points (and commits)". Writer calls this when it has made a "consistent change" to the index, meaning new files are written to the index and the in-memory SegmentInfos have been modified to point to those files. This may or may not be a commit (segments_N may or may not have been written). We simply incref the files referenced by the new SegmentInfos and decref the files we had previously seen (if any). If this is a commit, we also call the policy to give it a chance to remove other commits. If any commits are removed, we decref their files as well.
Public method | Dispose | Releases all resources used by the IndexFileDeleter
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Exists |
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh |
Public method | Refresh(String) | Writer calls this when it has hit an error and had to roll back, to tell us that there may now be unreferenced files in the filesystem. So we re-list the filesystem and delete such files. If segmentName is non-null, we will only delete files corresponding to that segment.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
VERBOSE_REF_COUNTS | Change to true to see details of reference counts when infoStream != null
Back to Top
Properties
 | Name | Description
Public property | LastSegmentInfos |
Back to Top
See Also
IndexFileDeleter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexFileDeleter Constructor

IndexFileDeleter Constructor Lucene.Net Class Library
Initialize the deleter: find all previous commits in the Directory, incref the files they reference, call the policy to let it delete commits. This will remove any files not referenced by any of the commits.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexFileDeleter(
    Directory directory,
    IndexDeletionPolicy policy,
    SegmentInfos segmentInfos,
    StreamWriter infoStream,
    DocumentsWriter docWriter,
    HashSet<string> synced
)
public IndexFileDeleter(
    Directory directory,
    IndexDeletionPolicy policy,
    SegmentInfos segmentInfos,
    StreamWriter infoStream,
    DocumentsWriter docWriter,
    HashSet<string> synced
)
Public Sub New ( _
    directory As Directory, _
    policy As IndexDeletionPolicy, _
    segmentInfos As SegmentInfos, _
    infoStream As StreamWriter, _
    docWriter As DocumentsWriter, _
    synced As HashSet(Of String) _
)
Public Sub New ( _
    directory As Directory, _
    policy As IndexDeletionPolicy, _
    segmentInfos As SegmentInfos, _
    infoStream As StreamWriter, _
    docWriter As DocumentsWriter, _
    synced As HashSet(Of String) _
)
public:
IndexFileDeleter(
    Directory^ directory,
    IndexDeletionPolicy^ policy,
    SegmentInfos^ segmentInfos,
    StreamWriter^ infoStream,
    DocumentsWriter^ docWriter,
    HashSet<String^>^ synced
)
public:
IndexFileDeleter(
    Directory^ directory,
    IndexDeletionPolicy^ policy,
    SegmentInfos^ segmentInfos,
    StreamWriter^ infoStream,
    DocumentsWriter^ docWriter,
    HashSet<String^>^ synced
)
Parameters
directory
Type: Lucene.Net.Store Directory
policy
Type: Lucene.Net.Index IndexDeletionPolicy
segmentInfos
Type: Lucene.Net.Index SegmentInfos
infoStream
Type:   Online System.IO StreamWriter
docWriter
Type: Lucene.Net.Index DocumentsWriter
synced
Type:   Online System.Collections.Generic HashSet    Online String
See Also
IndexFileDeleter Class
IndexFileDeleter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexFileDeleter Fields

IndexFileDeleter Fields Lucene.Net Class Library
The IndexFileDeleter type exposes the following members.
Fields
Name | Description
VERBOSE_REF_COUNTS | Change to true to see details of reference counts when infoStream != null
Back to Top
See Also
IndexFileDeleter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


VERBOSE_REF_COUNTS Field

IndexFileDeleter VERBOSE_REF_COUNTS Field Lucene.Net Class Library
Change to true to see details of reference counts when infoStream != null

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool VERBOSE_REF_COUNTS
public static bool VERBOSE_REF_COUNTS
Public Shared VERBOSE_REF_COUNTS As Boolean
Public Shared VERBOSE_REF_COUNTS As Boolean
public:
static bool VERBOSE_REF_COUNTS
public:
static bool VERBOSE_REF_COUNTS
See Also
IndexFileDeleter Class
IndexFileDeleter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexFileDeleter Methods

IndexFileDeleter Methods Lucene.Net Class Library
The IndexFileDeleter type exposes the following members.
Methods
 | Name | Description
Public method | Checkpoint | For definition of "check point" see IndexWriter comments: "Clarification: Check Points (and commits)". Writer calls this when it has made a "consistent change" to the index, meaning new files are written to the index and the in-memory SegmentInfos have been modified to point to those files. This may or may not be a commit (segments_N may or may not have been written). We simply incref the files referenced by the new SegmentInfos and decref the files we had previously seen (if any). If this is a commit, we also call the policy to give it a chance to remove other commits. If any commits are removed, we decref their files as well.
Public method | Dispose |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Exists |
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh |
Public method | Refresh(String) | Writer calls this when it has hit an error and had to roll back, to tell us that there may now be unreferenced files in the filesystem. So we re-list the filesystem and delete such files. If segmentName is non-null, we will only delete files corresponding to that segment.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
IndexFileDeleter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Checkpoint Method

IndexFileDeleter Checkpoint Method Lucene.Net Class Library
For definition of "check point" see IndexWriter comments: "Clarification: Check Points (and commits)". Writer calls this when it has made a "consistent change" to the index, meaning new files are written to the index and the in-memory SegmentInfos have been modified to point to those files. This may or may not be a commit (segments_N may or may not have been written). We simply incref the files referenced by the new SegmentInfos and decref the files we had previously seen (if any). If this is a commit, we also call the policy to give it a chance to remove other commits. If any commits are removed, we decref their files as well.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Checkpoint(
    SegmentInfos segmentInfos,
    bool isCommit
)
public void Checkpoint(
    SegmentInfos segmentInfos,
    bool isCommit
)
Public Sub Checkpoint ( _
    segmentInfos As SegmentInfos, _
    isCommit As Boolean _
)
Public Sub Checkpoint ( _
    segmentInfos As SegmentInfos, _
    isCommit As Boolean _
)
public:
void Checkpoint(
    SegmentInfos^ segmentInfos,
    bool isCommit
)
public:
void Checkpoint(
    SegmentInfos^ segmentInfos,
    bool isCommit
)
Parameters
segmentInfos
Type: Lucene.Net.Index SegmentInfos
isCommit
Type:   Online System Boolean
See Also
IndexFileDeleter Class
IndexFileDeleter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

IndexFileDeleter Dispose Method Lucene.Net Class Library
Releases all resources used by the IndexFileDeleter

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
IndexFileDeleter Class
IndexFileDeleter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Exists Method

IndexFileDeleter Exists Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Exists(
    string fileName
)
public bool Exists(
    string fileName
)
Public Function Exists ( _
    fileName As String _
) As Boolean
Public Function Exists ( _
    fileName As String _
) As Boolean
public:
bool Exists(
    String^ fileName
)
public:
bool Exists(
    String^ fileName
)
Parameters
fileName
Type:   Online System String
See Also
IndexFileDeleter Class
IndexFileDeleter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Refresh Method

IndexFileDeleter Refresh Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Refresh |
Public method | Refresh(String) | Writer calls this when it has hit an error and had to roll back, to tell us that there may now be unreferenced files in the filesystem. So we re-list the filesystem and delete such files. If segmentName is non-null, we will only delete files corresponding to that segment.
Back to Top
See Also
IndexFileDeleter Class
IndexFileDeleter Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Refresh Method

IndexFileDeleter Refresh Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Refresh()
public void Refresh()
Public Sub Refresh
Public Sub Refresh
public:
void Refresh()
public:
void Refresh()
See Also
IndexFileDeleter Class
IndexFileDeleter Members
Refresh Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Refresh Method (String)

IndexFileDeleter Refresh Method (String) Lucene.Net Class Library
Writer calls this when it has hit an error and had to roll back, to tell us that there may now be unreferenced files in the filesystem. So we re-list the filesystem and delete such files. If segmentName is non-null, we will only delete files corresponding to that segment.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Refresh(
    string segmentName
)
public void Refresh(
    string segmentName
)
Public Sub Refresh ( _
    segmentName As String _
)
Public Sub Refresh ( _
    segmentName As String _
)
public:
void Refresh(
    String^ segmentName
)
public:
void Refresh(
    String^ segmentName
)
Parameters
segmentName
Type:   Online System String
See Also
IndexFileDeleter Class
IndexFileDeleter Members
Refresh Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexFileDeleter Properties

IndexFileDeleter Properties Lucene.Net Class Library
The IndexFileDeleter type exposes the following members.
Properties
 | Name | Description
Public property | LastSegmentInfos |
Back to Top
See Also
IndexFileDeleter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LastSegmentInfos Property

IndexFileDeleter LastSegmentInfos Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SegmentInfos LastSegmentInfos { get; }
public SegmentInfos LastSegmentInfos { get; }
Public ReadOnly Property LastSegmentInfos As SegmentInfos
    Get
Public ReadOnly Property LastSegmentInfos As SegmentInfos
    Get
public:
property SegmentInfos^ LastSegmentInfos {
    SegmentInfos^ get ();
}
public:
property SegmentInfos^ LastSegmentInfos {
    SegmentInfos^ get ();
}
See Also
IndexFileDeleter Class
IndexFileDeleter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexFileNameFilter Class

IndexFileNameFilter Class Lucene.Net Class Library
Filename filter that accept filenames and extensions only created by Lucene.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index IndexFileNameFilter

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class IndexFileNameFilter
public class IndexFileNameFilter
Public Class IndexFileNameFilter
Public Class IndexFileNameFilter
public ref class IndexFileNameFilter
public ref class IndexFileNameFilter
See Also
IndexFileNameFilter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexFileNameFilter Members

IndexFileNameFilter Members Lucene.Net Class Library

The IndexFileNameFilter type exposes the following members.
Methods
 | Name | Description
Public method | Accept |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsCFSFile | Returns true if this is a file that would be contained in a CFS file. This function should only be called on files that pass the above "accept" (ie, are already known to be a Lucene index file).
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
Name | Description
Filter |
Back to Top
See Also
IndexFileNameFilter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexFileNameFilter Methods

IndexFileNameFilter Methods Lucene.Net Class Library
The IndexFileNameFilter type exposes the following members.
Methods
 | Name | Description
Public method | Accept |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsCFSFile | Returns true if this is a file that would be contained in a CFS file. This function should only be called on files that pass the above "accept" (ie, are already known to be a Lucene index file).
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
IndexFileNameFilter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Accept Method

IndexFileNameFilter Accept Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Accept(
    FileInfo dir,
    string name
)
public virtual bool Accept(
    FileInfo dir,
    string name
)
Public Overridable Function Accept ( _
    dir As FileInfo, _
    name As String _
) As Boolean
Public Overridable Function Accept ( _
    dir As FileInfo, _
    name As String _
) As Boolean
public:
virtual bool Accept(
    FileInfo^ dir,
    String^ name
)
public:
virtual bool Accept(
    FileInfo^ dir,
    String^ name
)
Parameters
dir
Type:   Online System.IO FileInfo
name
Type:   Online System String
See Also
IndexFileNameFilter Class
IndexFileNameFilter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsCFSFile Method

IndexFileNameFilter IsCFSFile Method Lucene.Net Class Library
Returns true if this is a file that would be contained in a CFS file. This function should only be called on files that pass the above "accept" (ie, are already known to be a Lucene index file).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsCFSFile(
    string name
)
public virtual bool IsCFSFile(
    string name
)
Public Overridable Function IsCFSFile ( _
    name As String _
) As Boolean
Public Overridable Function IsCFSFile ( _
    name As String _
) As Boolean
public:
virtual bool IsCFSFile(
    String^ name
)
public:
virtual bool IsCFSFile(
    String^ name
)
Parameters
name
Type:   Online System String
See Also
IndexFileNameFilter Class
IndexFileNameFilter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexFileNameFilter Properties

IndexFileNameFilter Properties Lucene.Net Class Library
The IndexFileNameFilter type exposes the following members.
Properties
Name | Description
Filter |
Back to Top
See Also
IndexFileNameFilter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Filter Property

IndexFileNameFilter Filter Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IndexFileNameFilter Filter { get; }
public static IndexFileNameFilter Filter { get; }
Public Shared ReadOnly Property Filter As IndexFileNameFilter
    Get
Public Shared ReadOnly Property Filter As IndexFileNameFilter
    Get
public:
static property IndexFileNameFilter^ Filter {
    IndexFileNameFilter^ get ();
}
public:
static property IndexFileNameFilter^ Filter {
    IndexFileNameFilter^ get ();
}
See Also
IndexFileNameFilter Class
IndexFileNameFilter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexFileNames Class

IndexFileNames Class Lucene.Net Class Library
Useful constants representing filenames and extensions used by lucene
Inheritance Hierarchy
Online System Object
Lucene.Net.Index IndexFileNames

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class IndexFileNames
public sealed class IndexFileNames
Public NotInheritable Class IndexFileNames
Public NotInheritable Class IndexFileNames
public ref class IndexFileNames sealed
public ref class IndexFileNames sealed
See Also
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexFileNames Members

IndexFileNames Members Lucene.Net Class Library

The IndexFileNames type exposes the following members.
Constructors
 | Name | Description
Public method | IndexFileNames | Initializes a new instance of the IndexFileNames class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
 | FileNameFromGeneration | Computes the full file name from base, extension and generation. If the generation is -1, the file name is null. If it's 0, the file name is If it's > 0, the file name is
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
COMPOUND_EXTENSIONS | File extensions of old-style index files
COMPOUND_FILE_EXTENSION | Extension of compound file
COMPOUND_FILE_STORE_EXTENSION | Extension of compound file for doc store files
DELETABLE | Name of the index deletable file (only used in pre-lockless indices)
FIELD_INFOS_EXTENSION | Extension of field infos
FIELDS_EXTENSION | Extension of stored fields file
FIELDS_INDEX_EXTENSION | Extension of stored fields index file
FREQ_EXTENSION | Extension of freq postings file
GEN_EXTENSION | Extension of gen file
INDEX_EXTENSIONS | This array contains all filename extensions used by Lucene's index files, with two exceptions, namely the extension made up from .f + a number and from .s + a number. Also note that Lucene's segments_N files do not have any filename extension.
INDEX_EXTENSIONS_IN_COMPOUND_FILE | File extensions that are added to a compound file (same as above, minus "del", "gen", "cfs").
NON_STORE_INDEX_EXTENSIONS |
NORMS_EXTENSION | Extension of norms file
PLAIN_NORMS_EXTENSION | Extension of plain norms
PROX_EXTENSION | Extension of prox postings file
SEGMENTS | Name of the index segment file
SEGMENTS_GEN | Name of the generation reference file name
SEPARATE_NORMS_EXTENSION | Extension of separate norms
STORE_INDEX_EXTENSIONS |
TERMS_EXTENSION | Extension of terms file
TERMS_INDEX_EXTENSION | Extension of terms index file
VECTOR_EXTENSIONS | File extensions for term vector support
VECTORS_DOCUMENTS_EXTENSION | Extension of vectors documents file
VECTORS_FIELDS_EXTENSION | Extension of vectors fields file
VECTORS_INDEX_EXTENSION | Extension of vectors index file
Back to Top
See Also
IndexFileNames Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexFileNames Constructor

IndexFileNames Constructor Lucene.Net Class Library
Initializes a new instance of the IndexFileNames class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexFileNames()
public IndexFileNames()
Public Sub New
Public Sub New
public:
IndexFileNames()
public:
IndexFileNames()
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexFileNames Fields

IndexFileNames Fields Lucene.Net Class Library
The IndexFileNames type exposes the following members.
Fields
Name | Description
COMPOUND_EXTENSIONS | File extensions of old-style index files
COMPOUND_FILE_EXTENSION | Extension of compound file
COMPOUND_FILE_STORE_EXTENSION | Extension of compound file for doc store files
DELETABLE | Name of the index deletable file (only used in pre-lockless indices)
FIELD_INFOS_EXTENSION | Extension of field infos
FIELDS_EXTENSION | Extension of stored fields file
FIELDS_INDEX_EXTENSION | Extension of stored fields index file
FREQ_EXTENSION | Extension of freq postings file
GEN_EXTENSION | Extension of gen file
INDEX_EXTENSIONS | This array contains all filename extensions used by Lucene's index files, with two exceptions, namely the extension made up from .f + a number and from .s + a number. Also note that Lucene's segments_N files do not have any filename extension.
INDEX_EXTENSIONS_IN_COMPOUND_FILE | File extensions that are added to a compound file (same as above, minus "del", "gen", "cfs").
NON_STORE_INDEX_EXTENSIONS |
NORMS_EXTENSION | Extension of norms file
PLAIN_NORMS_EXTENSION | Extension of plain norms
PROX_EXTENSION | Extension of prox postings file
SEGMENTS | Name of the index segment file
SEGMENTS_GEN | Name of the generation reference file name
SEPARATE_NORMS_EXTENSION | Extension of separate norms
STORE_INDEX_EXTENSIONS |
TERMS_EXTENSION | Extension of terms file
TERMS_INDEX_EXTENSION | Extension of terms index file
VECTOR_EXTENSIONS | File extensions for term vector support
VECTORS_DOCUMENTS_EXTENSION | Extension of vectors documents file
VECTORS_FIELDS_EXTENSION | Extension of vectors fields file
VECTORS_INDEX_EXTENSION | Extension of vectors index file
Back to Top
See Also
IndexFileNames Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


COMPOUND_EXTENSIONS Field

IndexFileNames COMPOUND_EXTENSIONS Field Lucene.Net Class Library
File extensions of old-style index files

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] COMPOUND_EXTENSIONS
public static readonly string[] COMPOUND_EXTENSIONS
Public Shared ReadOnly COMPOUND_EXTENSIONS As String()
Public Shared ReadOnly COMPOUND_EXTENSIONS As String()
public:
static initonly array<String^>^ COMPOUND_EXTENSIONS
public:
static initonly array<String^>^ COMPOUND_EXTENSIONS
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


COMPOUND_FILE_EXTENSION Field

IndexFileNames COMPOUND_FILE_EXTENSION Field Lucene.Net Class Library
Extension of compound file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string COMPOUND_FILE_EXTENSION
public const string COMPOUND_FILE_EXTENSION
Public Const COMPOUND_FILE_EXTENSION As String
Public Const COMPOUND_FILE_EXTENSION As String
public:
literal String^ COMPOUND_FILE_EXTENSION
public:
literal String^ COMPOUND_FILE_EXTENSION
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


COMPOUND_FILE_STORE_EXTENSION Field

IndexFileNames COMPOUND_FILE_STORE_EXTENSION Field Lucene.Net Class Library
Extension of compound file for doc store files

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string COMPOUND_FILE_STORE_EXTENSION
public const string COMPOUND_FILE_STORE_EXTENSION
Public Const COMPOUND_FILE_STORE_EXTENSION As String
Public Const COMPOUND_FILE_STORE_EXTENSION As String
public:
literal String^ COMPOUND_FILE_STORE_EXTENSION
public:
literal String^ COMPOUND_FILE_STORE_EXTENSION
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DELETABLE Field

IndexFileNames DELETABLE Field Lucene.Net Class Library
Name of the index deletable file (only used in pre-lockless indices)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DELETABLE
public const string DELETABLE
Public Const DELETABLE As String
Public Const DELETABLE As String
public:
literal String^ DELETABLE
public:
literal String^ DELETABLE
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FIELD_INFOS_EXTENSION Field

IndexFileNames FIELD_INFOS_EXTENSION Field Lucene.Net Class Library
Extension of field infos

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FIELD_INFOS_EXTENSION
public const string FIELD_INFOS_EXTENSION
Public Const FIELD_INFOS_EXTENSION As String
Public Const FIELD_INFOS_EXTENSION As String
public:
literal String^ FIELD_INFOS_EXTENSION
public:
literal String^ FIELD_INFOS_EXTENSION
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FIELDS_EXTENSION Field

IndexFileNames FIELDS_EXTENSION Field Lucene.Net Class Library
Extension of stored fields file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FIELDS_EXTENSION
public const string FIELDS_EXTENSION
Public Const FIELDS_EXTENSION As String
Public Const FIELDS_EXTENSION As String
public:
literal String^ FIELDS_EXTENSION
public:
literal String^ FIELDS_EXTENSION
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FIELDS_INDEX_EXTENSION Field

IndexFileNames FIELDS_INDEX_EXTENSION Field Lucene.Net Class Library
Extension of stored fields index file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FIELDS_INDEX_EXTENSION
public const string FIELDS_INDEX_EXTENSION
Public Const FIELDS_INDEX_EXTENSION As String
Public Const FIELDS_INDEX_EXTENSION As String
public:
literal String^ FIELDS_INDEX_EXTENSION
public:
literal String^ FIELDS_INDEX_EXTENSION
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FREQ_EXTENSION Field

IndexFileNames FREQ_EXTENSION Field Lucene.Net Class Library
Extension of freq postings file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FREQ_EXTENSION
public const string FREQ_EXTENSION
Public Const FREQ_EXTENSION As String
Public Const FREQ_EXTENSION As String
public:
literal String^ FREQ_EXTENSION
public:
literal String^ FREQ_EXTENSION
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GEN_EXTENSION Field

IndexFileNames GEN_EXTENSION Field Lucene.Net Class Library
Extension of gen file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GEN_EXTENSION
public const string GEN_EXTENSION
Public Const GEN_EXTENSION As String
Public Const GEN_EXTENSION As String
public:
literal String^ GEN_EXTENSION
public:
literal String^ GEN_EXTENSION
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


INDEX_EXTENSIONS Field

IndexFileNames INDEX_EXTENSIONS Field Lucene.Net Class Library
This array contains all filename extensions used by Lucene's index files, with two exceptions, namely the extension made up from .f + a number and from .s + a number. Also note that Lucene's segments_N files do not have any filename extension.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] INDEX_EXTENSIONS
public static readonly string[] INDEX_EXTENSIONS
Public Shared ReadOnly INDEX_EXTENSIONS As String()
Public Shared ReadOnly INDEX_EXTENSIONS As String()
public:
static initonly array<String^>^ INDEX_EXTENSIONS
public:
static initonly array<String^>^ INDEX_EXTENSIONS
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


INDEX_EXTENSIONS_IN_COMPOUND_FILE Field

IndexFileNames INDEX_EXTENSIONS_IN_COMPOUND_FILE Field Lucene.Net Class Library
File extensions that are added to a compound file (same as above, minus "del", "gen", "cfs").

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] INDEX_EXTENSIONS_IN_COMPOUND_FILE
public static readonly string[] INDEX_EXTENSIONS_IN_COMPOUND_FILE
Public Shared ReadOnly INDEX_EXTENSIONS_IN_COMPOUND_FILE As String()
Public Shared ReadOnly INDEX_EXTENSIONS_IN_COMPOUND_FILE As String()
public:
static initonly array<String^>^ INDEX_EXTENSIONS_IN_COMPOUND_FILE
public:
static initonly array<String^>^ INDEX_EXTENSIONS_IN_COMPOUND_FILE
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NON_STORE_INDEX_EXTENSIONS Field

IndexFileNames NON_STORE_INDEX_EXTENSIONS Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] NON_STORE_INDEX_EXTENSIONS
public static readonly string[] NON_STORE_INDEX_EXTENSIONS
Public Shared ReadOnly NON_STORE_INDEX_EXTENSIONS As String()
Public Shared ReadOnly NON_STORE_INDEX_EXTENSIONS As String()
public:
static initonly array<String^>^ NON_STORE_INDEX_EXTENSIONS
public:
static initonly array<String^>^ NON_STORE_INDEX_EXTENSIONS
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NORMS_EXTENSION Field

IndexFileNames NORMS_EXTENSION Field Lucene.Net Class Library
Extension of norms file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NORMS_EXTENSION
public const string NORMS_EXTENSION
Public Const NORMS_EXTENSION As String
Public Const NORMS_EXTENSION As String
public:
literal String^ NORMS_EXTENSION
public:
literal String^ NORMS_EXTENSION
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PLAIN_NORMS_EXTENSION Field

IndexFileNames PLAIN_NORMS_EXTENSION Field Lucene.Net Class Library
Extension of plain norms

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PLAIN_NORMS_EXTENSION
public const string PLAIN_NORMS_EXTENSION
Public Const PLAIN_NORMS_EXTENSION As String
Public Const PLAIN_NORMS_EXTENSION As String
public:
literal String^ PLAIN_NORMS_EXTENSION
public:
literal String^ PLAIN_NORMS_EXTENSION
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PROX_EXTENSION Field

IndexFileNames PROX_EXTENSION Field Lucene.Net Class Library
Extension of prox postings file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PROX_EXTENSION
public const string PROX_EXTENSION
Public Const PROX_EXTENSION As String
Public Const PROX_EXTENSION As String
public:
literal String^ PROX_EXTENSION
public:
literal String^ PROX_EXTENSION
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SEGMENTS Field

IndexFileNames SEGMENTS Field Lucene.Net Class Library
Name of the index segment file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SEGMENTS
public const string SEGMENTS
Public Const SEGMENTS As String
Public Const SEGMENTS As String
public:
literal String^ SEGMENTS
public:
literal String^ SEGMENTS
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SEGMENTS_GEN Field

IndexFileNames SEGMENTS_GEN Field Lucene.Net Class Library
Name of the generation reference file name

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SEGMENTS_GEN
public const string SEGMENTS_GEN
Public Const SEGMENTS_GEN As String
Public Const SEGMENTS_GEN As String
public:
literal String^ SEGMENTS_GEN
public:
literal String^ SEGMENTS_GEN
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SEPARATE_NORMS_EXTENSION Field

IndexFileNames SEPARATE_NORMS_EXTENSION Field Lucene.Net Class Library
Extension of separate norms

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SEPARATE_NORMS_EXTENSION
public const string SEPARATE_NORMS_EXTENSION
Public Const SEPARATE_NORMS_EXTENSION As String
Public Const SEPARATE_NORMS_EXTENSION As String
public:
literal String^ SEPARATE_NORMS_EXTENSION
public:
literal String^ SEPARATE_NORMS_EXTENSION
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


STORE_INDEX_EXTENSIONS Field

IndexFileNames STORE_INDEX_EXTENSIONS Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] STORE_INDEX_EXTENSIONS
public static readonly string[] STORE_INDEX_EXTENSIONS
Public Shared ReadOnly STORE_INDEX_EXTENSIONS As String()
Public Shared ReadOnly STORE_INDEX_EXTENSIONS As String()
public:
static initonly array<String^>^ STORE_INDEX_EXTENSIONS
public:
static initonly array<String^>^ STORE_INDEX_EXTENSIONS
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TERMS_EXTENSION Field

IndexFileNames TERMS_EXTENSION Field Lucene.Net Class Library
Extension of terms file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TERMS_EXTENSION
public const string TERMS_EXTENSION
Public Const TERMS_EXTENSION As String
Public Const TERMS_EXTENSION As String
public:
literal String^ TERMS_EXTENSION
public:
literal String^ TERMS_EXTENSION
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TERMS_INDEX_EXTENSION Field

IndexFileNames TERMS_INDEX_EXTENSION Field Lucene.Net Class Library
Extension of terms index file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TERMS_INDEX_EXTENSION
public const string TERMS_INDEX_EXTENSION
Public Const TERMS_INDEX_EXTENSION As String
Public Const TERMS_INDEX_EXTENSION As String
public:
literal String^ TERMS_INDEX_EXTENSION
public:
literal String^ TERMS_INDEX_EXTENSION
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


VECTOR_EXTENSIONS Field

IndexFileNames VECTOR_EXTENSIONS Field Lucene.Net Class Library
File extensions for term vector support

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] VECTOR_EXTENSIONS
public static readonly string[] VECTOR_EXTENSIONS
Public Shared ReadOnly VECTOR_EXTENSIONS As String()
Public Shared ReadOnly VECTOR_EXTENSIONS As String()
public:
static initonly array<String^>^ VECTOR_EXTENSIONS
public:
static initonly array<String^>^ VECTOR_EXTENSIONS
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


VECTORS_DOCUMENTS_EXTENSION Field

IndexFileNames VECTORS_DOCUMENTS_EXTENSION Field Lucene.Net Class Library
Extension of vectors documents file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VECTORS_DOCUMENTS_EXTENSION
public const string VECTORS_DOCUMENTS_EXTENSION
Public Const VECTORS_DOCUMENTS_EXTENSION As String
Public Const VECTORS_DOCUMENTS_EXTENSION As String
public:
literal String^ VECTORS_DOCUMENTS_EXTENSION
public:
literal String^ VECTORS_DOCUMENTS_EXTENSION
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


VECTORS_FIELDS_EXTENSION Field

IndexFileNames VECTORS_FIELDS_EXTENSION Field Lucene.Net Class Library
Extension of vectors fields file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VECTORS_FIELDS_EXTENSION
public const string VECTORS_FIELDS_EXTENSION
Public Const VECTORS_FIELDS_EXTENSION As String
Public Const VECTORS_FIELDS_EXTENSION As String
public:
literal String^ VECTORS_FIELDS_EXTENSION
public:
literal String^ VECTORS_FIELDS_EXTENSION
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


VECTORS_INDEX_EXTENSION Field

IndexFileNames VECTORS_INDEX_EXTENSION Field Lucene.Net Class Library
Extension of vectors index file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VECTORS_INDEX_EXTENSION
public const string VECTORS_INDEX_EXTENSION
Public Const VECTORS_INDEX_EXTENSION As String
Public Const VECTORS_INDEX_EXTENSION As String
public:
literal String^ VECTORS_INDEX_EXTENSION
public:
literal String^ VECTORS_INDEX_EXTENSION
See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexFileNames Methods

IndexFileNames Methods Lucene.Net Class Library
The IndexFileNames type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
 | FileNameFromGeneration | Computes the full file name from base, extension and generation. If the generation is -1, the file name is null. If it's 0, the file name is If it's > 0, the file name is
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
IndexFileNames Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileNameFromGeneration Method

IndexFileNames FileNameFromGeneration Method Lucene.Net Class Library
Computes the full file name from base, extension and generation. If the generation is -1, the file name is null. If it's 0, the file name is If it's > 0, the file name is

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string FileNameFromGeneration(
    string base_Renamed,
    string extension,
    long gen
)
public static string FileNameFromGeneration(
    string base_Renamed,
    string extension,
    long gen
)
Public Shared Function FileNameFromGeneration ( _
    base_Renamed As String, _
    extension As String, _
    gen As Long _
) As String
Public Shared Function FileNameFromGeneration ( _
    base_Renamed As String, _
    extension As String, _
    gen As Long _
) As String
public:
static String^ FileNameFromGeneration(
    String^ base_Renamed,
    String^ extension,
    long long gen
)
public:
static String^ FileNameFromGeneration(
    String^ base_Renamed,
    String^ extension,
    long long gen
)
Parameters
base_Renamed
Type:   Online System String
-- main part of the file name

extension
Type:   Online System String
-- extension of the filename (including .)

gen
Type:   Online System Int64
-- generation

See Also
IndexFileNames Class
IndexFileNames Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexReader Class

IndexReader Class Lucene.Net Class Library
IndexReader is an abstract class, providing an interface for accessing an index. Search of an index is done entirely through this abstract interface, so that any subclass which implements it is searchable.

Concrete subclasses of IndexReader are usually constructed with a call to one of the static open() methods, e.g. Open(Directory, Boolean) .

For efficiency, in this API documents are often referred to via document numbers, non-negative integers which each name a unique document in the index. These document numbers are ephemeral--they may change as documents are added to and deleted from an index. Clients should thus not rely on a given document having the same number between sessions.

An IndexReader can be opened on a directory for which an IndexWriter is opened already, but it cannot be used to delete documents from the index then.

NOTE: for backwards API compatibility, several methods are not listed as abstract, but have no useful implementations in this base class and instead always throw UnsupportedOperationException. Subclasses are strongly encouraged to override these methods, but in many cases may not need to.

NOTE: as of 2.4, it's possible to open a read-only IndexReader using the static open methods that accepts the boolean readOnly parameter. Such a reader has better better concurrency as it's not necessary to synchronize on the isDeleted method. You must explicitly specify false if you want to make changes with the resulting IndexReader.

NOTE: IndexReader instances are completely thread safe, meaning multiple threads can call any of its methods, concurrently. If your application requires external synchronization, you should not synchronize on the IndexReader instance; use your own (non-Lucene) objects instead.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index IndexReader
Lucene.Net.Index DirectoryReader
Lucene.Net.Index FilterIndexReader
Lucene.Net.Index MultiReader
Lucene.Net.Index ParallelReader
Lucene.Net.Index SegmentReader

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class IndexReader : ICloneable,
    IDisposable
public abstract class IndexReader : ICloneable,
    IDisposable
Public MustInherit Class IndexReader _
    Implements ICloneable, IDisposable
Public MustInherit Class IndexReader _
    Implements ICloneable, IDisposable
public ref class IndexReader abstract : ICloneable,
    IDisposable
public ref class IndexReader abstract : ICloneable,
    IDisposable
See Also
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexReader Members

IndexReader Members Lucene.Net Class Library

The IndexReader type exposes the following members.
Constructors
 | Name | Description
Protected method | IndexReader | Initializes a new instance of the IndexReader class
Back to Top
Methods
Name | Description
Protected method AcquireWriteLock
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
Public method Clone
Efficiently clones the IndexReader (sharing most internal state).

On cloning a reader with pending changes (deletions, norms), the original reader transfers its write lock to the cloned reader. This means only the cloned reader may make further changes to the index, and commit the changes to the index on close, but the old reader still reflects all changes made up until it was cloned.

Like Reopen , it's safe to make changes to either the original or the cloned reader: all shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

Public method Clone(Boolean)
Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader.
Public method | Close | Obsolete.
Public method Commit
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
Public method Commit(IDictionary String, String )
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
Public method DeleteDocument
Deletes the document numbered docNum. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the Document(Int32) method will result in an error. The presence of this document may still be reflected in the DocFreq(Term) statistic, though this will be corrected eventually as the index is further modified.
Public method DeleteDocuments
Deletes all documents that have a given term indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See DeleteDocument(Int32) for information about when this deletion will become effective.
Public method Directory
Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified.
Public method Dispose
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Protected method Dispose(Boolean)
Releases the unmanaged resources used by the IndexReader and optionally releases the managed resources
Public method DocFreq
Returns the number of documents containing the term t.
Protected method DoClose
Implements close.
Protected method DoCommit
Implements commit.
Public method Document(Int32)
Returns the stored fields of the nthDocument in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted.
Public method Document(Int32, FieldSelector)
Get the Document at the nth position. The FieldSelector may be used to determine what Fields to load and how they should be loaded. NOTE: If this Reader (more specifically, the underlying FieldsReader) is closed before the lazy Field is loaded an exception may be thrown. If you want the value of a lazy Field to be available after closing you must explicitly load it or fetch the Document again with a new loader.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted.
Protected method DoDelete
Implements deletion of the document numbered docNum. Applications should call DeleteDocument(Int32) or DeleteDocuments(Term).
Protected method DoSetNorm
Implements setNorm in subclass.
Protected method DoUndeleteAll
Implements actual undeleteAll() in subclass.
Protected method | EnsureOpen
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Flush
Public method | Flush(IDictionary String, String )
GetCommitUserData
Reads commitUserData, previously passed to Commit(IDictionary String, String ), from current index segments file. This will return null if Commit(IDictionary String, String ) has never been called for this index.
GetCurrentVersion
Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.
Public method GetFieldNames
Get a list of unique field names that exist in this index and have the specified field option information.
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method GetSequentialSubReaders
Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers).

NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through Open(Directory, Boolean). Use the parent reader directly.
Public method GetTermFreqVector(Int32, TermVectorMapper)
Map all the term vectors for all fields in a Document
Public method GetTermFreqVector(Int32, String)
Return a term frequency vector for the specified document and field. The returned vector contains terms and frequencies for the terms in the specified field of this document, if the field had the storeTermVector flag set. If termvectors had been stored with positions or offsets, a TermPositionVector is returned.
Public method GetTermFreqVector(Int32, String, TermVectorMapper)
Load the Term Vector into a user-defined data structure instead of relying on the parallel arrays of the ITermFreqVector.
Public method GetTermFreqVectors
Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector contains terms and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null. The term vectors that are returned may either be of type ITermFreqVector or of type TermPositionVector if positions or offsets have been stored.
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method HasNorms
Returns true if there are norms stored for this field.
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding DecRef , in a finally clause; otherwise the reader may never be closed. Note that Close simply calls decRef(), which means that the IndexReader will not really be closed until DecRef has been called for all outstanding references.
IndexExists
Returns true if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
Public method IsCurrent
Check whether any new changes have occurred to the index since this reader was opened.

If this reader is based on a Directory (ie, was created by calling Open(Store.Directory) , or Reopen on a reader based on a Directory), then this method checks if any further commits (see Commit have occurred in that directory).

If instead this reader is a near real-time reader (ie, obtained by a call to GetReader , or by calling Reopen on a near real-time reader), then this method checks if either a new commmit has occurred, or any new uncommitted changes have taken place via the writer. Note that even if the writer has only performed merging, this method will still return false.

In any event, if this returns false, you should call Reopen to get a new reader that sees the changes.

Public method IsDeleted
Returns true if document n has been deleted
Public method IsOptimized
Checks is the index is optimized (if it has a single segment and no deletions). Not implemented in the IndexReader base class.
LastModified
Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use IsCurrent instead.
ListCommits
Returns all commit points that exist in the Directory. Normally, because the default is KeepOnlyLastCommitDeletionPolicy , there would be only one commit point. But if you're using a custom IndexDeletionPolicy then there could be many commits. Once you have a given commit, you can open a reader on it by calling Open(IndexCommit, Boolean) There must be at least one commit in the Directory, else this method throws Online IOException. Note that if a commit is in progress while this method is running, that commit may or may not be returned array.
Main
Prints the filename and size of each file within a given compound file. Add the -extract flag to extract files to the current working directory. In order to make the extracted version of the index work, you have to copy the segments file from the compound index into the directory where the extracted files are stored.
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Norms(String)
Returns the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.
Public method Norms(String, Byte , Int32)
Reads the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.
Public method NumDocs
Returns the number of documents in this index.
Open(Directory, Boolean)
Returns an IndexReader reading the index in the given Directory. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, Boolean)
Expert: returns an IndexReader reading the index in the given IndexCommit. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(Directory, IndexDeletionPolicy, Boolean)
Expert: returns an IndexReader reading the index in the given Directory, with a custom IndexDeletionPolicy . You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, IndexDeletionPolicy, Boolean)
Expert: returns an IndexReader reading the index in the given Directory, using a specific commit and with a custom IndexDeletionPolicy. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(Directory, IndexDeletionPolicy, Boolean, Int32)
Expert: returns an IndexReader reading the index in the given Directory, with a custom IndexDeletionPolicy . You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, IndexDeletionPolicy, Boolean, Int32)
Expert: returns an IndexReader reading the index in the given Directory, using a specific commit and with a custom IndexDeletionPolicy. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Public method Reopen
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:
View Colorized Copy to Clipboard Print
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from GetReader , reopen() will simply call writer.getReader() again for you, though this may change in the future.
Public method Reopen(Boolean)
Just like Reopen , except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
Public method TermDocs
Returns an unpositioned TermDocs enumerator.
Public method TermDocs(Term)
Returns an enumeration of all the documents which contain term. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping:

Term => <docNum, freq>*

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.
Public method TermPositions
Returns an unpositioned TermPositions enumerator.
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.
Public method Terms
Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration. Note that after calling terms(), Next must be called on the resulting enumeration before calling other methods such as Term.
Public method Terms(Term)
Returns an enumeration of all terms starting at a given term. If the given term does not exist, the enumeration is positioned at the first term greater than the supplied term. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration.
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
Back to Top
Fields
 | Name | Description
 | DEFAULT_TERMS_INDEX_DIVISOR |
Protected field | hasChanges |
Back to Top
Properties
 | Name | Description
Public property | CommitUserData | Retrieve the String userData optionally passed to Commit(IDictionary String, String ). This will return null if Commit(IDictionary String, String ) has never been called for this index.
Public property | DeletesCacheKey |
Public property | FieldCacheKey | Expert
Public property | HasDeletions | Returns true if any documents have been deleted
Public property | IndexCommit | Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: this API is new and experimental and may suddenly change.
Public property | Item | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted.
Public property | MaxDoc | Returns one greater than the largest possible document number. This may be used to, e.g., determine how big to allocate an array which will have an element for every document number in an index.
Public property | NumDeletedDocs | Returns the number of deleted documents.
Public property | RefCount | Expert: returns the current refCount for this reader
Public property | TermInfosIndexDivisor | For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened.
Public property | UniqueTermCount | Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed.
Public property | Version | Version number when this IndexReader was opened. Not implemented in the IndexReader base class. If this reader is based on a Directory (ie, was created by calling Open(Directory, Boolean), or Reopen on a reader based on a Directory), then this method returns the version recorded in the commit that the reader opened. This version is advanced every time Commit is called. If instead this reader is a near real-time reader (ie, obtained by a call to GetReader , or by calling Reopen on a near real-time reader), then this method returns the version of the last commit done by the writer. Note that even as further changes are made with the writer, the version will not changed until a commit is completed. Thus, you should not rely on this method to determine when a near real-time reader should be opened. Use IsCurrent instead.
Back to Top
See Also
IndexReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexReader Constructor

IndexReader Constructor Lucene.Net Class Library
Initializes a new instance of the IndexReader class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IndexReader()
protected IndexReader()
Protected Sub New
Protected Sub New
protected:
IndexReader()
protected:
IndexReader()
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexReader Fields

IndexReader Fields Lucene.Net Class Library
The IndexReader type exposes the following members.
Fields
 | Name | Description
 | DEFAULT_TERMS_INDEX_DIVISOR |
Protected field | hasChanges |
Back to Top
See Also
IndexReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_TERMS_INDEX_DIVISOR Field

IndexReader DEFAULT_TERMS_INDEX_DIVISOR Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static int DEFAULT_TERMS_INDEX_DIVISOR
protected static int DEFAULT_TERMS_INDEX_DIVISOR
Protected Shared DEFAULT_TERMS_INDEX_DIVISOR As Integer
Protected Shared DEFAULT_TERMS_INDEX_DIVISOR As Integer
protected:
static int DEFAULT_TERMS_INDEX_DIVISOR
protected:
static int DEFAULT_TERMS_INDEX_DIVISOR
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


hasChanges Field

IndexReader hasChanges Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool hasChanges
protected bool hasChanges
Protected hasChanges As Boolean
Protected hasChanges As Boolean
protected:
bool hasChanges
protected:
bool hasChanges
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexReader Methods

IndexReader Methods Lucene.Net Class Library
The IndexReader type exposes the following members.
Methods
Name | Description
Protected method AcquireWriteLock
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
Public method Clone
Efficiently clones the IndexReader (sharing most internal state).

On cloning a reader with pending changes (deletions, norms), the original reader transfers its write lock to the cloned reader. This means only the cloned reader may make further changes to the index, and commit the changes to the index on close, but the old reader still reflects all changes made up until it was cloned.

Like Reopen , it's safe to make changes to either the original or the cloned reader: all shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

Public method Clone(Boolean)
Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader.
Public method | Close | Obsolete.
Public method Commit
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
Public method Commit(IDictionary String, String )
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
Public method DeleteDocument
Deletes the document numbered docNum. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the Document(Int32) method will result in an error. The presence of this document may still be reflected in the DocFreq(Term) statistic, though this will be corrected eventually as the index is further modified.
Public method DeleteDocuments
Deletes all documents that have a given term indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See DeleteDocument(Int32) for information about when this deletion will become effective.
Public method Directory
Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified.
Public method Dispose
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Protected method | Dispose(Boolean)
Public method DocFreq
Returns the number of documents containing the term t.
Protected method DoClose
Implements close.
Protected method DoCommit
Implements commit.
Public method Document(Int32)
Returns the stored fields of the nthDocument in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted.
Public method Document(Int32, FieldSelector)
Get the Document at the nth position. The FieldSelector may be used to determine what Fields to load and how they should be loaded. NOTE: If this Reader (more specifically, the underlying FieldsReader) is closed before the lazy Field is loaded an exception may be thrown. If you want the value of a lazy Field to be available after closing you must explicitly load it or fetch the Document again with a new loader.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted.
Protected method DoDelete
Implements deletion of the document numbered docNum. Applications should call DeleteDocument(Int32) or DeleteDocuments(Term).
Protected method DoSetNorm
Implements setNorm in subclass.
Protected method DoUndeleteAll
Implements actual undeleteAll() in subclass.
Protected method | EnsureOpen
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Flush
Public method | Flush(IDictionary String, String )
GetCommitUserData
Reads commitUserData, previously passed to Commit(IDictionary String, String ), from current index segments file. This will return null if Commit(IDictionary String, String ) has never been called for this index.
GetCurrentVersion
Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.
Public method GetFieldNames
Get a list of unique field names that exist in this index and have the specified field option information.
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method GetSequentialSubReaders
Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers).

NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through Open(Directory, Boolean). Use the parent reader directly.
Public method GetTermFreqVector(Int32, TermVectorMapper)
Map all the term vectors for all fields in a Document
Public method GetTermFreqVector(Int32, String)
Return a term frequency vector for the specified document and field. The returned vector contains terms and frequencies for the terms in the specified field of this document, if the field had the storeTermVector flag set. If termvectors had been stored with positions or offsets, a TermPositionVector is returned.
Public method GetTermFreqVector(Int32, String, TermVectorMapper)
Load the Term Vector into a user-defined data structure instead of relying on the parallel arrays of the ITermFreqVector.
Public method GetTermFreqVectors
Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector contains terms and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null. The term vectors that are returned may either be of type ITermFreqVector or of type TermPositionVector if positions or offsets have been stored.
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method HasNorms
Returns true if there are norms stored for this field.
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding DecRef , in a finally clause; otherwise the reader may never be closed. Note that Close simply calls decRef(), which means that the IndexReader will not really be closed until DecRef has been called for all outstanding references.
IndexExists
Returns true if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
Public method IsCurrent
Check whether any new changes have occurred to the index since this reader was opened.

If this reader is based on a Directory (ie, was created by calling Open(Store.Directory) , or Reopen on a reader based on a Directory), then this method checks if any further commits (see Commit have occurred in that directory).

If instead this reader is a near real-time reader (ie, obtained by a call to GetReader , or by calling Reopen on a near real-time reader), then this method checks if either a new commmit has occurred, or any new uncommitted changes have taken place via the writer. Note that even if the writer has only performed merging, this method will still return false.

In any event, if this returns false, you should call Reopen to get a new reader that sees the changes.

Public method IsDeleted
Returns true if document n has been deleted
Public method IsOptimized
Checks is the index is optimized (if it has a single segment and no deletions). Not implemented in the IndexReader base class.
LastModified
Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use IsCurrent instead.
ListCommits
Returns all commit points that exist in the Directory. Normally, because the default is KeepOnlyLastCommitDeletionPolicy , there would be only one commit point. But if you're using a custom IndexDeletionPolicy then there could be many commits. Once you have a given commit, you can open a reader on it by calling Open(IndexCommit, Boolean) There must be at least one commit in the Directory, else this method throws Online IOException. Note that if a commit is in progress while this method is running, that commit may or may not be returned array.
Main
Prints the filename and size of each file within a given compound file. Add the -extract flag to extract files to the current working directory. In order to make the extracted version of the index work, you have to copy the segments file from the compound index into the directory where the extracted files are stored.
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Norms(String)
Returns the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.
Public method Norms(String, Byte , Int32)
Reads the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.
Public method NumDocs
Returns the number of documents in this index.
Open(Directory, Boolean)
Returns an IndexReader reading the index in the given Directory. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, Boolean)
Expert: returns an IndexReader reading the index in the given IndexCommit. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(Directory, IndexDeletionPolicy, Boolean)
Expert: returns an IndexReader reading the index in the given Directory, with a custom IndexDeletionPolicy . You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, IndexDeletionPolicy, Boolean)
Expert: returns an IndexReader reading the index in the given Directory, using a specific commit and with a custom IndexDeletionPolicy. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(Directory, IndexDeletionPolicy, Boolean, Int32)
Expert: returns an IndexReader reading the index in the given Directory, with a custom IndexDeletionPolicy . You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, IndexDeletionPolicy, Boolean, Int32)
Expert: returns an IndexReader reading the index in the given Directory, using a specific commit and with a custom IndexDeletionPolicy. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Public method Reopen
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:
View Colorized Copy to Clipboard Print
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from GetReader , reopen() will simply call writer.getReader() again for you, though this may change in the future.
Public method Reopen(Boolean)
Just like Reopen , except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
Public method TermDocs
Returns an unpositioned TermDocs enumerator.
Public method TermDocs(Term)
Returns an enumeration of all the documents which contain term. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping:

Term => <docNum, freq>*

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.
Public method TermPositions
Returns an unpositioned TermPositions enumerator.
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.
Public method Terms
Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration. Note that after calling terms(), Next must be called on the resulting enumeration before calling other methods such as Term.
Public method Terms(Term)
Returns an enumeration of all terms starting at a given term. If the given term does not exist, the enumeration is positioned at the first term greater than the supplied term. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration.
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
Back to Top
See Also
IndexReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AcquireWriteLock Method

IndexReader AcquireWriteLock Method Lucene.Net Class Library
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void AcquireWriteLock()
protected virtual void AcquireWriteLock()
Protected Overridable Sub AcquireWriteLock
Protected Overridable Sub AcquireWriteLock
protected:
virtual void AcquireWriteLock()
protected:
virtual void AcquireWriteLock()
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

IndexReader Clone Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Clone | Efficiently clones the IndexReader (sharing most internal state). On cloning a reader with pending changes (deletions, norms), the original reader transfers its write lock to the cloned reader. This means only the cloned reader may make further changes to the index, and commit the changes to the index on close, but the old reader still reflects all changes made up until it was cloned. Like Reopen , it's safe to make changes to either the original or the cloned reader: all shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.
Public method | Clone(Boolean) | Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader.
Back to Top
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

IndexReader Clone Method Lucene.Net Class Library
Efficiently clones the IndexReader (sharing most internal state).

On cloning a reader with pending changes (deletions, norms), the original reader transfers its write lock to the cloned reader. This means only the cloned reader may make further changes to the index, and commit the changes to the index on close, but the old reader still reflects all changes made up until it was cloned.

Like Reopen , it's safe to make changes to either the original or the cloned reader: all shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object Clone()
public virtual Object Clone()
Public Overridable Function Clone As Object
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
public:
virtual Object^ Clone()
Implements
  Online ICloneable Clone
Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Clone Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method (Boolean)

IndexReader Clone Method (Boolean) Lucene.Net Class Library
Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IndexReader Clone(
    bool openReadOnly
)
public virtual IndexReader Clone(
    bool openReadOnly
)
Public Overridable Function Clone ( _
    openReadOnly As Boolean _
) As IndexReader
Public Overridable Function Clone ( _
    openReadOnly As Boolean _
) As IndexReader
public:
virtual IndexReader^ Clone(
    bool openReadOnly
)
public:
virtual IndexReader^ Clone(
    bool openReadOnly
)
Parameters
openReadOnly
Type:   Online System Boolean
Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Clone Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

IndexReader Close Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Commit Method

IndexReader Commit Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Commit | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
Public method | Commit(IDictionary String, String ) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
Back to Top
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Commit Method

IndexReader Commit Method Lucene.Net Class Library
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Commit()
public void Commit()
Public Sub Commit
Public Sub Commit
public:
void Commit()
public:
void Commit()
Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Commit Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Commit Method (IDictionary(String, String))

IndexReader Commit Method (IDictionary String, String ) Lucene.Net Class Library
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Commit(
    IDictionary<string, string> commitUserData
)
public void Commit(
    IDictionary<string, string> commitUserData
)
Public Sub Commit ( _
    commitUserData As IDictionary(Of String, String) _
)
Public Sub Commit ( _
    commitUserData As IDictionary(Of String, String) _
)
public:
void Commit(
    IDictionary<String^, String^>^ commitUserData
)
public:
void Commit(
    IDictionary<String^, String^>^ commitUserData
)
Parameters
commitUserData
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Commit Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DecRef Method

IndexReader DecRef Method Lucene.Net Class Library
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void DecRef()
public virtual void DecRef()
Public Overridable Sub DecRef
Public Overridable Sub DecRef
public:
virtual void DecRef()
public:
virtual void DecRef()
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
IndexReader IncRef
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DeleteDocument Method

IndexReader DeleteDocument Method Lucene.Net Class Library
Deletes the document numbered docNum. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the Document(Int32) method will result in an error. The presence of this document may still be reflected in the DocFreq(Term) statistic, though this will be corrected eventually as the index is further modified.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void DeleteDocument(
    int docNum
)
public virtual void DeleteDocument(
    int docNum
)
Public Overridable Sub DeleteDocument ( _
    docNum As Integer _
)
Public Overridable Sub DeleteDocument ( _
    docNum As Integer _
)
public:
virtual void DeleteDocument(
    int docNum
)
public:
virtual void DeleteDocument(
    int docNum
)
Parameters
docNum
Type:   Online System Int32
Exceptions
Exception | Condition
Lucene.Net.Index StaleReaderException | If the index has changed since this reader was opened
Lucene.Net.Index CorruptIndexException | If the index is corrupt
Lucene.Net.Store LockObtainFailedException | If another writer has this index open (write.lock could not be obtained)
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DeleteDocuments Method

IndexReader DeleteDocuments Method Lucene.Net Class Library
Deletes all documents that have a given term indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See DeleteDocument(Int32) for information about when this deletion will become effective.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int DeleteDocuments(
    Term term
)
public virtual int DeleteDocuments(
    Term term
)
Public Overridable Function DeleteDocuments ( _
    term As Term _
) As Integer
Public Overridable Function DeleteDocuments ( _
    term As Term _
) As Integer
public:
virtual int DeleteDocuments(
    Term^ term
)
public:
virtual int DeleteDocuments(
    Term^ term
)
Parameters
term
Type: Lucene.Net.Index Term
Return Value
The number of documents deleted
Exceptions
Exception | Condition
Lucene.Net.Index StaleReaderException | If the index has changed since this reader was opened
Lucene.Net.Index CorruptIndexException | If the index is corrupt
Lucene.Net.Store LockObtainFailedException | If another writer has this index open (write.lock could not be obtained)
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Directory Method

IndexReader Directory Method Lucene.Net Class Library
Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Directory Directory()
public virtual Directory Directory()
Public Overridable Function Directory As Directory
Public Overridable Function Directory As Directory
public:
virtual Directory^ Directory()
public:
virtual Directory^ Directory()
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

IndexReader Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the IndexReader and optionally releases the managed resources
Back to Top
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

IndexReader Dispose Method Lucene.Net Class Library
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

IndexReader Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the IndexReader and optionally releases the managed resources

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void Dispose(
    bool disposing
)
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
)
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
IndexReader Class
IndexReader Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocFreq Method

IndexReader DocFreq Method Lucene.Net Class Library
Returns the number of documents containing the term t.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int DocFreq(
    Term t
)
public abstract int DocFreq(
    Term t
)
Public MustOverride Function DocFreq ( _
    t As Term _
) As Integer
Public MustOverride Function DocFreq ( _
    t As Term _
) As Integer
public:
virtual int DocFreq(
    Term^ t
) abstract
public:
virtual int DocFreq(
    Term^ t
) abstract
Parameters
t
Type: Lucene.Net.Index Term
Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoClose Method

IndexReader DoClose Method Lucene.Net Class Library
Implements close.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoClose()
protected abstract void DoClose()
Protected MustOverride Sub DoClose
Protected MustOverride Sub DoClose
protected:
virtual void DoClose() abstract
protected:
virtual void DoClose() abstract
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoCommit Method

IndexReader DoCommit Method Lucene.Net Class Library
Implements commit.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoCommit(
    IDictionary<string, string> commitUserData
)
protected abstract void DoCommit(
    IDictionary<string, string> commitUserData
)
Protected MustOverride Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
Protected MustOverride Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
protected:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
) abstract
protected:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
) abstract
Parameters
commitUserData
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Method

IndexReader Document Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Document(Int32) | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted.
Public method | Document(Int32, FieldSelector) | Get the Document at the nth position. The FieldSelector may be used to determine what Fields to load and how they should be loaded. NOTE: If this Reader (more specifically, the underlying FieldsReader) is closed before the lazy Field is loaded an exception may be thrown. If you want the value of a lazy Field to be available after closing you must explicitly load it or fetch the Document again with a new loader. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted.
Back to Top
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Method (Int32)

IndexReader Document Method (Int32) Lucene.Net Class Library
Returns the stored fields of the nthDocument in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Document Document(
    int n
)
public virtual Document Document(
    int n
)
Public Overridable Function Document ( _
    n As Integer _
) As Document
Public Overridable Function Document ( _
    n As Integer _
) As Document
public:
virtual Document^ Document(
    int n
)
public:
virtual Document^ Document(
    int n
)
Parameters
n
Type:   Online System Int32
Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Document Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Method (Int32, FieldSelector)

IndexReader Document Method (Int32, FieldSelector) Lucene.Net Class Library
Get the Document at the nth position. The FieldSelector may be used to determine what Fields to load and how they should be loaded. NOTE: If this Reader (more specifically, the underlying FieldsReader) is closed before the lazy Field is loaded an exception may be thrown. If you want the value of a lazy Field to be available after closing you must explicitly load it or fetch the Document again with a new loader.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Document Document(
    int n,
    FieldSelector fieldSelector
)
public abstract Document Document(
    int n,
    FieldSelector fieldSelector
)
Public MustOverride Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Public MustOverride Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) abstract
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) abstract
Parameters
n
Type:   Online System Int32
Get the document at the nth position

fieldSelector
Type: Lucene.Net.Documents FieldSelector
The FieldSelector to use to determine what
            Fields should be loaded on the Document. May be null, in which case
            all Fields will be loaded.

Return Value
 The stored fields of the
            Document at the nth position

Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Document Overload
Lucene.Net.Index Namespace
Lucene.Net.Documents IFieldable
Lucene.Net.Documents FieldSelector
Lucene.Net.Documents SetBasedFieldSelector
Lucene.Net.Documents LoadFirstFieldSelector
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoDelete Method

IndexReader DoDelete Method Lucene.Net Class Library
Implements deletion of the document numbered docNum. Applications should call DeleteDocument(Int32) or DeleteDocuments(Term).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoDelete(
    int docNum
)
protected abstract void DoDelete(
    int docNum
)
Protected MustOverride Sub DoDelete ( _
    docNum As Integer _
)
Protected MustOverride Sub DoDelete ( _
    docNum As Integer _
)
protected:
virtual void DoDelete(
    int docNum
) abstract
protected:
virtual void DoDelete(
    int docNum
) abstract
Parameters
docNum
Type:   Online System Int32
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoSetNorm Method

IndexReader DoSetNorm Method Lucene.Net Class Library
Implements setNorm in subclass.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoSetNorm(
    int doc,
    string field,
    byte value_Renamed
)
protected abstract void DoSetNorm(
    int doc,
    string field,
    byte value_Renamed
)
Protected MustOverride Sub DoSetNorm ( _
    doc As Integer, _
    field As String, _
    value_Renamed As Byte _
)
Protected MustOverride Sub DoSetNorm ( _
    doc As Integer, _
    field As String, _
    value_Renamed As Byte _
)
protected:
virtual void DoSetNorm(
    int doc,
    String^ field,
    unsigned char value_Renamed
) abstract
protected:
virtual void DoSetNorm(
    int doc,
    String^ field,
    unsigned char value_Renamed
) abstract
Parameters
doc
Type:   Online System Int32
field
Type:   Online System String
value_Renamed
Type:   Online System Byte
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoUndeleteAll Method

IndexReader DoUndeleteAll Method Lucene.Net Class Library
Implements actual undeleteAll() in subclass.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoUndeleteAll()
protected abstract void DoUndeleteAll()
Protected MustOverride Sub DoUndeleteAll
Protected MustOverride Sub DoUndeleteAll
protected:
virtual void DoUndeleteAll() abstract
protected:
virtual void DoUndeleteAll() abstract
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EnsureOpen Method

IndexReader EnsureOpen Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void EnsureOpen()
protected void EnsureOpen()
Protected Sub EnsureOpen
Protected Sub EnsureOpen
protected:
void EnsureOpen()
protected:
void EnsureOpen()
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Flush Method

IndexReader Flush Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Flush |
Public method | Flush(IDictionary String, String ) |
Back to Top
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Flush Method

IndexReader Flush Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Flush()
public void Flush()
Public Sub Flush
Public Sub Flush
public:
void Flush()
public:
void Flush()
Exceptions
Exception | Condition
Online System.IO IOException |
See Also
IndexReader Class
IndexReader Members
Flush Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Flush Method (IDictionary(String, String))

IndexReader Flush Method (IDictionary String, String ) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Flush(
    IDictionary<string, string> commitUserData
)
public void Flush(
    IDictionary<string, string> commitUserData
)
Public Sub Flush ( _
    commitUserData As IDictionary(Of String, String) _
)
Public Sub Flush ( _
    commitUserData As IDictionary(Of String, String) _
)
public:
void Flush(
    IDictionary<String^, String^>^ commitUserData
)
public:
void Flush(
    IDictionary<String^, String^>^ commitUserData
)
Parameters
commitUserData
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
Opaque Map (String -> String)
            that's recorded into the segments file in the index,
            and retrievable by GetCommitUserData(Directory)
Exceptions
Exception | Condition
Online System.IO IOException |
See Also
IndexReader Class
IndexReader Members
Flush Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCommitUserData Method

IndexReader GetCommitUserData Method Lucene.Net Class Library
Reads commitUserData, previously passed to Commit(IDictionary String, String ), from current index segments file. This will return null if Commit(IDictionary String, String ) has never been called for this index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IDictionary<string, string> GetCommitUserData(
    Directory directory
)
public static IDictionary<string, string> GetCommitUserData(
    Directory directory
)
Public Shared Function GetCommitUserData ( _
    directory As Directory _
) As IDictionary(Of String, String)
Public Shared Function GetCommitUserData ( _
    directory As Directory _
) As IDictionary(Of String, String)
public:
static IDictionary<String^, String^>^ GetCommitUserData(
    Directory^ directory
)
public:
static IDictionary<String^, String^>^ GetCommitUserData(
    Directory^ directory
)
Parameters
directory
Type: Lucene.Net.Store Directory
where the index resides.

Return Value
 commit userData.

Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
IndexReader GetCommitUserData(Directory)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCurrentVersion Method

IndexReader GetCurrentVersion Method Lucene.Net Class Library
Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long GetCurrentVersion(
    Directory directory
)
public static long GetCurrentVersion(
    Directory directory
)
Public Shared Function GetCurrentVersion ( _
    directory As Directory _
) As Long
Public Shared Function GetCurrentVersion ( _
    directory As Directory _
) As Long
public:
static long long GetCurrentVersion(
    Directory^ directory
)
public:
static long long GetCurrentVersion(
    Directory^ directory
)
Parameters
directory
Type: Lucene.Net.Store Directory
where the index resides.

Return Value
 version number.

Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFieldNames Method

IndexReader GetFieldNames Method Lucene.Net Class Library
Get a list of unique field names that exist in this index and have the specified field option information.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fldOption
)
public abstract ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fldOption
)
Public MustOverride Function GetFieldNames ( _
    fldOption As IndexReader..::..FieldOption _
) As ICollection(Of String)
Public MustOverride Function GetFieldNames ( _
    fldOption As IndexReader..::..FieldOption _
) As ICollection(Of String)
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fldOption
) abstract
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fldOption
) abstract
Parameters
fldOption
Type: Lucene.Net.Index IndexReader FieldOption
specifies which field option should be available for the returned fields

Return Value
 Collection of Strings indicating the names of the fields.

See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Lucene.Net.Index IndexReader FieldOption
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSequentialSubReaders Method

IndexReader GetSequentialSubReaders Method Lucene.Net Class Library
Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers).

NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through Open(Directory, Boolean). Use the parent reader directly.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IndexReader[] GetSequentialSubReaders()
public virtual IndexReader[] GetSequentialSubReaders()
Public Overridable Function GetSequentialSubReaders As IndexReader()
Public Overridable Function GetSequentialSubReaders As IndexReader()
public:
virtual array<IndexReader^>^ GetSequentialSubReaders()
public:
virtual array<IndexReader^>^ GetSequentialSubReaders()
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method

IndexReader GetTermFreqVector Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetTermFreqVector(Int32, TermVectorMapper) | Map all the term vectors for all fields in a Document
Public method | GetTermFreqVector(Int32, String) | Return a term frequency vector for the specified document and field. The returned vector contains terms and frequencies for the terms in the specified field of this document, if the field had the storeTermVector flag set. If termvectors had been stored with positions or offsets, a TermPositionVector is returned.
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | Load the Term Vector into a user-defined data structure instead of relying on the parallel arrays of the ITermFreqVector.
Back to Top
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, TermVectorMapper)

IndexReader GetTermFreqVector Method (Int32, TermVectorMapper) Lucene.Net Class Library
Map all the term vectors for all fields in a Document

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
public abstract void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
Public MustOverride Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
Public MustOverride Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) abstract
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) abstract
Parameters
docNumber
Type:   Online System Int32
The number of the document to load the vector for

mapper
Type: Lucene.Net.Index TermVectorMapper
The TermVectorMapper to process the vector.  Must not be null

See Also
IndexReader Class
IndexReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, String)

IndexReader GetTermFreqVector Method (Int32, String) Lucene.Net Class Library
Return a term frequency vector for the specified document and field. The returned vector contains terms and frequencies for the terms in the specified field of this document, if the field had the storeTermVector flag set. If termvectors had been stored with positions or offsets, a TermPositionVector is returned.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract ITermFreqVector GetTermFreqVector(
    int docNumber,
    string field
)
public abstract ITermFreqVector GetTermFreqVector(
    int docNumber,
    string field
)
Public MustOverride Function GetTermFreqVector ( _
    docNumber As Integer, _
    field As String _
) As ITermFreqVector
Public MustOverride Function GetTermFreqVector ( _
    docNumber As Integer, _
    field As String _
) As ITermFreqVector
public:
virtual ITermFreqVector^ GetTermFreqVector(
    int docNumber,
    String^ field
) abstract
public:
virtual ITermFreqVector^ GetTermFreqVector(
    int docNumber,
    String^ field
) abstract
Parameters
docNumber
Type:   Online System Int32
document for which the term frequency vector is returned

field
Type:   Online System String
field for which the term frequency vector is returned.

Return Value
 term frequency vector May be null if field does not exist in the specified
            document or term vector was not stored.

See Also
IndexReader Class
IndexReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Lucene.Net.Documents Field TermVector
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, String, TermVectorMapper)

IndexReader GetTermFreqVector Method (Int32, String, TermVectorMapper) Lucene.Net Class Library
Load the Term Vector into a user-defined data structure instead of relying on the parallel arrays of the ITermFreqVector.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
public abstract void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
Public MustOverride Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
Public MustOverride Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) abstract
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) abstract
Parameters
docNumber
Type:   Online System Int32
The number of the document to load the vector for

field
Type:   Online System String
The name of the field to load

mapper
Type: Lucene.Net.Index TermVectorMapper
The TermVectorMapper to process the vector.  Must not be null

See Also
IndexReader Class
IndexReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVectors Method

IndexReader GetTermFreqVectors Method Lucene.Net Class Library
Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector contains terms and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null. The term vectors that are returned may either be of type ITermFreqVector or of type TermPositionVector if positions or offsets have been stored.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract ITermFreqVector[] GetTermFreqVectors(
    int docNumber
)
public abstract ITermFreqVector[] GetTermFreqVectors(
    int docNumber
)
Public MustOverride Function GetTermFreqVectors ( _
    docNumber As Integer _
) As ITermFreqVector()
Public MustOverride Function GetTermFreqVectors ( _
    docNumber As Integer _
) As ITermFreqVector()
public:
virtual array<ITermFreqVector^>^ GetTermFreqVectors(
    int docNumber
) abstract
public:
virtual array<ITermFreqVector^>^ GetTermFreqVectors(
    int docNumber
) abstract
Parameters
docNumber
Type:   Online System Int32
document for which term frequency vectors are returned

Return Value
 array of term frequency vectors. May be null if no term vectors have been
            stored for the specified document.

See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Lucene.Net.Documents Field TermVector
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasNorms Method

IndexReader HasNorms Method Lucene.Net Class Library
Returns true if there are norms stored for this field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool HasNorms(
    string field
)
public virtual bool HasNorms(
    string field
)
Public Overridable Function HasNorms ( _
    field As String _
) As Boolean
Public Overridable Function HasNorms ( _
    field As String _
) As Boolean
public:
virtual bool HasNorms(
    String^ field
)
public:
virtual bool HasNorms(
    String^ field
)
Parameters
field
Type:   Online System String
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncRef Method

IndexReader IncRef Method Lucene.Net Class Library
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding DecRef , in a finally clause; otherwise the reader may never be closed. Note that Close simply calls decRef(), which means that the IndexReader will not really be closed until DecRef has been called for all outstanding references.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void IncRef()
public virtual void IncRef()
Public Overridable Sub IncRef
Public Overridable Sub IncRef
public:
virtual void IncRef()
public:
virtual void IncRef()
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
IndexReader DecRef
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexExists Method

IndexReader IndexExists Method Lucene.Net Class Library
Returns true if an index exists at the specified directory. If the directory does not exist or if there is no index in it.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IndexExists(
    Directory directory
)
public static bool IndexExists(
    Directory directory
)
Public Shared Function IndexExists ( _
    directory As Directory _
) As Boolean
Public Shared Function IndexExists ( _
    directory As Directory _
) As Boolean
public:
static bool IndexExists(
    Directory^ directory
)
public:
static bool IndexExists(
    Directory^ directory
)
Parameters
directory
Type: Lucene.Net.Store Directory
the directory to check for an index

Return Value
true if an index exists; false otherwise

See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsCurrent Method

IndexReader IsCurrent Method Lucene.Net Class Library
Check whether any new changes have occurred to the index since this reader was opened.

If this reader is based on a Directory (ie, was created by calling Open(Store.Directory) , or Reopen on a reader based on a Directory), then this method checks if any further commits (see Commit have occurred in that directory).

If instead this reader is a near real-time reader (ie, obtained by a call to GetReader , or by calling Reopen on a near real-time reader), then this method checks if either a new commmit has occurred, or any new uncommitted changes have taken place via the writer. Note that even if the writer has only performed merging, this method will still return false.

In any event, if this returns false, you should call Reopen to get a new reader that sees the changes.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsCurrent()
public virtual bool IsCurrent()
Public Overridable Function IsCurrent As Boolean
Public Overridable Function IsCurrent As Boolean
public:
virtual bool IsCurrent()
public:
virtual bool IsCurrent()
Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsDeleted Method

IndexReader IsDeleted Method Lucene.Net Class Library
Returns true if document n has been deleted

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool IsDeleted(
    int n
)
public abstract bool IsDeleted(
    int n
)
Public MustOverride Function IsDeleted ( _
    n As Integer _
) As Boolean
Public MustOverride Function IsDeleted ( _
    n As Integer _
) As Boolean
public:
virtual bool IsDeleted(
    int n
) abstract
public:
virtual bool IsDeleted(
    int n
) abstract
Parameters
n
Type:   Online System Int32
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsOptimized Method

IndexReader IsOptimized Method Lucene.Net Class Library
Checks is the index is optimized (if it has a single segment and no deletions). Not implemented in the IndexReader base class.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsOptimized()
public virtual bool IsOptimized()
Public Overridable Function IsOptimized As Boolean
Public Overridable Function IsOptimized As Boolean
public:
virtual bool IsOptimized()
public:
virtual bool IsOptimized()
Return Value
 &lt;c&gt;true&lt;/c&gt; if the index is optimized; &lt;c&gt;false&lt;/c&gt; otherwise
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LastModified Method

IndexReader LastModified Method Lucene.Net Class Library
Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use IsCurrent instead.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long LastModified(
    Directory directory2
)
public static long LastModified(
    Directory directory2
)
Public Shared Function LastModified ( _
    directory2 As Directory _
) As Long
Public Shared Function LastModified ( _
    directory2 As Directory _
) As Long
public:
static long long LastModified(
    Directory^ directory2
)
public:
static long long LastModified(
    Directory^ directory2
)
Parameters
directory2
Type: Lucene.Net.Store Directory
Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ListCommits Method

IndexReader ListCommits Method Lucene.Net Class Library
Returns all commit points that exist in the Directory. Normally, because the default is KeepOnlyLastCommitDeletionPolicy , there would be only one commit point. But if you're using a custom IndexDeletionPolicy then there could be many commits. Once you have a given commit, you can open a reader on it by calling Open(IndexCommit, Boolean) There must be at least one commit in the Directory, else this method throws Online IOException. Note that if a commit is in progress while this method is running, that commit may or may not be returned array.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ICollection<IndexCommit> ListCommits(
    Directory dir
)
public static ICollection<IndexCommit> ListCommits(
    Directory dir
)
Public Shared Function ListCommits ( _
    dir As Directory _
) As ICollection(Of IndexCommit)
Public Shared Function ListCommits ( _
    dir As Directory _
) As ICollection(Of IndexCommit)
public:
static ICollection<IndexCommit^>^ ListCommits(
    Directory^ dir
)
public:
static ICollection<IndexCommit^>^ ListCommits(
    Directory^ dir
)
Parameters
dir
Type: Lucene.Net.Store Directory
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Main Method

IndexReader Main Method Lucene.Net Class Library
Prints the filename and size of each file within a given compound file. Add the -extract flag to extract files to the current working directory. In order to make the extracted version of the index work, you have to copy the segments file from the compound index into the directory where the extracted files are stored.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[STAThreadAttribute]
public static void Main(
    string[] args
)
[STAThreadAttribute]
public static void Main(
    string[] args
)
<STAThreadAttribute> _
Public Shared Sub Main ( _
    args As String() _
)
<STAThreadAttribute> _
Public Shared Sub Main ( _
    args As String() _
)
public:
[STAThreadAttribute]
static void Main(
    array<String^>^ args
)
public:
[STAThreadAttribute]
static void Main(
    array<String^>^ args
)
Parameters
args
Type:    Online System String
Usage: Lucene.Net.Index.IndexReader [-extract] <cfsfile>

See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method

IndexReader Norms Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Norms(String) | Returns the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.
Public method | Norms(String, Byte , Int32) | Reads the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.
Back to Top
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method (String)

IndexReader Norms Method (String) Lucene.Net Class Library
Returns the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract byte[] Norms(
    string field
)
public abstract byte[] Norms(
    string field
)
Public MustOverride Function Norms ( _
    field As String _
) As Byte()
Public MustOverride Function Norms ( _
    field As String _
) As Byte()
public:
virtual array<unsigned char>^ Norms(
    String^ field
) abstract
public:
virtual array<unsigned char>^ Norms(
    String^ field
) abstract
Parameters
field
Type:   Online System String
See Also
IndexReader Class
IndexReader Members
Norms Overload
Lucene.Net.Index Namespace
AbstractField Boost
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method (String, Byte[], Int32)

IndexReader Norms Method (String, Byte , Int32) Lucene.Net Class Library
Reads the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Norms(
    string field,
    byte[] bytes,
    int offset
)
public abstract void Norms(
    string field,
    byte[] bytes,
    int offset
)
Public MustOverride Sub Norms ( _
    field As String, _
    bytes As Byte(), _
    offset As Integer _
)
Public MustOverride Sub Norms ( _
    field As String, _
    bytes As Byte(), _
    offset As Integer _
)
public:
virtual void Norms(
    String^ field,
    array<unsigned char>^ bytes,
    int offset
) abstract
public:
virtual void Norms(
    String^ field,
    array<unsigned char>^ bytes,
    int offset
) abstract
Parameters
field
Type:   Online System String
bytes
Type:    Online System Byte
offset
Type:   Online System Int32
See Also
IndexReader Class
IndexReader Members
Norms Overload
Lucene.Net.Index Namespace
AbstractField Boost
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumDocs Method

IndexReader NumDocs Method Lucene.Net Class Library
Returns the number of documents in this index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int NumDocs()
public abstract int NumDocs()
Public MustOverride Function NumDocs As Integer
Public MustOverride Function NumDocs As Integer
public:
virtual int NumDocs() abstract
public:
virtual int NumDocs() abstract
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Open Method

IndexReader Open Method Lucene.Net Class Library
Overload List
Name | Description
Open(Directory, Boolean) | Returns an IndexReader reading the index in the given Directory. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, Boolean) | Expert: returns an IndexReader reading the index in the given IndexCommit. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(Directory, IndexDeletionPolicy, Boolean) | Expert: returns an IndexReader reading the index in the given Directory, with a custom IndexDeletionPolicy . You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, IndexDeletionPolicy, Boolean) | Expert: returns an IndexReader reading the index in the given Directory, using a specific commit and with a custom IndexDeletionPolicy. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(Directory, IndexDeletionPolicy, Boolean, Int32) | Expert: returns an IndexReader reading the index in the given Directory, with a custom IndexDeletionPolicy . You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, IndexDeletionPolicy, Boolean, Int32) | Expert: returns an IndexReader reading the index in the given Directory, using a specific commit and with a custom IndexDeletionPolicy. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Back to Top
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Open Method (Directory, Boolean)

IndexReader Open Method (Directory, Boolean) Lucene.Net Class Library
Returns an IndexReader reading the index in the given Directory. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IndexReader Open(
    Directory directory,
    bool readOnly
)
public static IndexReader Open(
    Directory directory,
    bool readOnly
)
Public Shared Function Open ( _
    directory As Directory, _
    readOnly As Boolean _
) As IndexReader
Public Shared Function Open ( _
    directory As Directory, _
    readOnly As Boolean _
) As IndexReader
public:
static IndexReader^ Open(
    Directory^ directory,
    bool readOnly
)
public:
static IndexReader^ Open(
    Directory^ directory,
    bool readOnly
)
Parameters
directory
Type: Lucene.Net.Store Directory
the index directory
readOnly
Type:   Online System Boolean
true if no changes (deletions, norms) will be made with this IndexReader
Exceptions
Exception | Condition
Lucene.Net.Index CorruptIndexException | CorruptIndexException if the index is corrupt
Online System.IO IOException | IOException if there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Open Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Open Method (IndexCommit, Boolean)

IndexReader Open Method (IndexCommit, Boolean) Lucene.Net Class Library
Expert: returns an IndexReader reading the index in the given IndexCommit. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IndexReader Open(
    IndexCommit commit,
    bool readOnly
)
public static IndexReader Open(
    IndexCommit commit,
    bool readOnly
)
Public Shared Function Open ( _
    commit As IndexCommit, _
    readOnly As Boolean _
) As IndexReader
Public Shared Function Open ( _
    commit As IndexCommit, _
    readOnly As Boolean _
) As IndexReader
public:
static IndexReader^ Open(
    IndexCommit^ commit,
    bool readOnly
)
public:
static IndexReader^ Open(
    IndexCommit^ commit,
    bool readOnly
)
Parameters
commit
Type: Lucene.Net.Index IndexCommit
the commit point to open

readOnly
Type:   Online System Boolean
true if no changes (deletions, norms) will be made with this IndexReader

Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Open Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Open Method (Directory, IndexDeletionPolicy, Boolean)

IndexReader Open Method (Directory, IndexDeletionPolicy, Boolean) Lucene.Net Class Library
Expert: returns an IndexReader reading the index in the given Directory, with a custom IndexDeletionPolicy . You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IndexReader Open(
    Directory directory,
    IndexDeletionPolicy deletionPolicy,
    bool readOnly
)
public static IndexReader Open(
    Directory directory,
    IndexDeletionPolicy deletionPolicy,
    bool readOnly
)
Public Shared Function Open ( _
    directory As Directory, _
    deletionPolicy As IndexDeletionPolicy, _
    readOnly As Boolean _
) As IndexReader
Public Shared Function Open ( _
    directory As Directory, _
    deletionPolicy As IndexDeletionPolicy, _
    readOnly As Boolean _
) As IndexReader
public:
static IndexReader^ Open(
    Directory^ directory,
    IndexDeletionPolicy^ deletionPolicy,
    bool readOnly
)
public:
static IndexReader^ Open(
    Directory^ directory,
    IndexDeletionPolicy^ deletionPolicy,
    bool readOnly
)
Parameters
directory
Type: Lucene.Net.Store Directory
the index directory

deletionPolicy
Type: Lucene.Net.Index IndexDeletionPolicy
a custom deletion policy (only used
             if you use this reader to perform deletes or to set
             norms); see IndexWriter for details.

readOnly
Type:   Online System Boolean
true if no changes (deletions, norms) will be made with this IndexReader

Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Open Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Open Method (IndexCommit, IndexDeletionPolicy, Boolean)

IndexReader Open Method (IndexCommit, IndexDeletionPolicy, Boolean) Lucene.Net Class Library
Expert: returns an IndexReader reading the index in the given Directory, using a specific commit and with a custom IndexDeletionPolicy. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IndexReader Open(
    IndexCommit commit,
    IndexDeletionPolicy deletionPolicy,
    bool readOnly
)
public static IndexReader Open(
    IndexCommit commit,
    IndexDeletionPolicy deletionPolicy,
    bool readOnly
)
Public Shared Function Open ( _
    commit As IndexCommit, _
    deletionPolicy As IndexDeletionPolicy, _
    readOnly As Boolean _
) As IndexReader
Public Shared Function Open ( _
    commit As IndexCommit, _
    deletionPolicy As IndexDeletionPolicy, _
    readOnly As Boolean _
) As IndexReader
public:
static IndexReader^ Open(
    IndexCommit^ commit,
    IndexDeletionPolicy^ deletionPolicy,
    bool readOnly
)
public:
static IndexReader^ Open(
    IndexCommit^ commit,
    IndexDeletionPolicy^ deletionPolicy,
    bool readOnly
)
Parameters
commit
Type: Lucene.Net.Index IndexCommit
the specific IndexCommit to open;
            see ListCommits(Directory) to list all commits
            in a directory

deletionPolicy
Type: Lucene.Net.Index IndexDeletionPolicy
a custom deletion policy (only used
            if you use this reader to perform deletes or to set
            norms); see IndexWriter for details.

readOnly
Type:   Online System Boolean
true if no changes (deletions, norms) will be made with this IndexReader

Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Open Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Open Method (Directory, IndexDeletionPolicy, Boolean, Int32)

IndexReader Open Method (Directory, IndexDeletionPolicy, Boolean, Int32) Lucene.Net Class Library
Expert: returns an IndexReader reading the index in the given Directory, with a custom IndexDeletionPolicy . You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IndexReader Open(
    Directory directory,
    IndexDeletionPolicy deletionPolicy,
    bool readOnly,
    int termInfosIndexDivisor
)
public static IndexReader Open(
    Directory directory,
    IndexDeletionPolicy deletionPolicy,
    bool readOnly,
    int termInfosIndexDivisor
)
Public Shared Function Open ( _
    directory As Directory, _
    deletionPolicy As IndexDeletionPolicy, _
    readOnly As Boolean, _
    termInfosIndexDivisor As Integer _
) As IndexReader
Public Shared Function Open ( _
    directory As Directory, _
    deletionPolicy As IndexDeletionPolicy, _
    readOnly As Boolean, _
    termInfosIndexDivisor As Integer _
) As IndexReader
public:
static IndexReader^ Open(
    Directory^ directory,
    IndexDeletionPolicy^ deletionPolicy,
    bool readOnly,
    int termInfosIndexDivisor
)
public:
static IndexReader^ Open(
    Directory^ directory,
    IndexDeletionPolicy^ deletionPolicy,
    bool readOnly,
    int termInfosIndexDivisor
)
Parameters
directory
Type: Lucene.Net.Store Directory
the index directory

deletionPolicy
Type: Lucene.Net.Index IndexDeletionPolicy
a custom deletion policy (only used
             if you use this reader to perform deletes or to set
             norms); see IndexWriter for details.

readOnly
Type:   Online System Boolean
true if no changes (deletions, norms) will be made with this IndexReader

termInfosIndexDivisor
Type:   Online System Int32
Subsamples which indexed
             terms are loaded into RAM. This has the same effect as IndexWriter.SetTermIndexInterval except that setting
             must be done at indexing time while this setting can be
             set per reader.  When set to N, then one in every
             N*termIndexInterval terms in the index is loaded into
             memory.  By setting this to a value > 1 you can reduce
             memory usage, at the expense of higher latency when
             loading a TermInfo.  The default value is 1.  Set this
             to -1 to skip loading the terms index entirely.

Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Open Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Open Method (IndexCommit, IndexDeletionPolicy, Boolean, Int32)

IndexReader Open Method (IndexCommit, IndexDeletionPolicy, Boolean, Int32) Lucene.Net Class Library
Expert: returns an IndexReader reading the index in the given Directory, using a specific commit and with a custom IndexDeletionPolicy. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IndexReader Open(
    IndexCommit commit,
    IndexDeletionPolicy deletionPolicy,
    bool readOnly,
    int termInfosIndexDivisor
)
public static IndexReader Open(
    IndexCommit commit,
    IndexDeletionPolicy deletionPolicy,
    bool readOnly,
    int termInfosIndexDivisor
)
Public Shared Function Open ( _
    commit As IndexCommit, _
    deletionPolicy As IndexDeletionPolicy, _
    readOnly As Boolean, _
    termInfosIndexDivisor As Integer _
) As IndexReader
Public Shared Function Open ( _
    commit As IndexCommit, _
    deletionPolicy As IndexDeletionPolicy, _
    readOnly As Boolean, _
    termInfosIndexDivisor As Integer _
) As IndexReader
public:
static IndexReader^ Open(
    IndexCommit^ commit,
    IndexDeletionPolicy^ deletionPolicy,
    bool readOnly,
    int termInfosIndexDivisor
)
public:
static IndexReader^ Open(
    IndexCommit^ commit,
    IndexDeletionPolicy^ deletionPolicy,
    bool readOnly,
    int termInfosIndexDivisor
)
Parameters
commit
Type: Lucene.Net.Index IndexCommit
the specific IndexCommit to open;
            see ListCommits(Directory) to list all commits
            in a directory

deletionPolicy
Type: Lucene.Net.Index IndexDeletionPolicy
a custom deletion policy (only used
            if you use this reader to perform deletes or to set
            norms); see IndexWriter for details.

readOnly
Type:   Online System Boolean
true if no changes (deletions, norms) will be made with this IndexReader

termInfosIndexDivisor
Type:   Online System Int32
Subsambles which indexed
            terms are loaded into RAM. This has the same effect as IndexWriter.SetTermIndexInterval except that setting
            must be done at indexing time while this setting can be
            set per reader.  When set to N, then one in every
            N*termIndexInterval terms in the index is loaded into
            memory.  By setting this to a value > 1 you can reduce
            memory usage, at the expense of higher latency when
            loading a TermInfo.  The default value is 1.  Set this
            to -1 to skip loading the terms index entirely.

Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Open Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reopen Method

IndexReader Reopen Method Lucene.Net Class Library
Overload List
Name Description
Public method Reopen
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:
View Colorized Copy to Clipboard Print
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from GetReader , reopen() will simply call writer.getReader() again for you, though this may change in the future.
Public method Reopen(Boolean)
Just like Reopen , except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
Back to Top
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reopen Method

IndexReader Reopen Method Lucene.Net Class Library
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:
View Colorized Copy to Clipboard Print
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from GetReader , reopen() will simply call writer.getReader() again for you, though this may change in the future.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IndexReader Reopen()
public virtual IndexReader Reopen()
Public Overridable Function Reopen As IndexReader
Public Overridable Function Reopen As IndexReader
public:
virtual IndexReader^ Reopen()
public:
virtual IndexReader^ Reopen()
Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Reopen Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reopen Method (Boolean)

IndexReader Reopen Method (Boolean) Lucene.Net Class Library
Just like Reopen , except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IndexReader Reopen(
    bool openReadOnly
)
public virtual IndexReader Reopen(
    bool openReadOnly
)
Public Overridable Function Reopen ( _
    openReadOnly As Boolean _
) As IndexReader
Public Overridable Function Reopen ( _
    openReadOnly As Boolean _
) As IndexReader
public:
virtual IndexReader^ Reopen(
    bool openReadOnly
)
public:
virtual IndexReader^ Reopen(
    bool openReadOnly
)
Parameters
openReadOnly
Type:   Online System Boolean
See Also
IndexReader Class
IndexReader Members
Reopen Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reopen Method (IndexCommit)

IndexReader Reopen Method (IndexCommit) Lucene.Net Class Library
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IndexReader Reopen(
    IndexCommit commit
)
public virtual IndexReader Reopen(
    IndexCommit commit
)
Public Overridable Function Reopen ( _
    commit As IndexCommit _
) As IndexReader
Public Overridable Function Reopen ( _
    commit As IndexCommit _
) As IndexReader
public:
virtual IndexReader^ Reopen(
    IndexCommit^ commit
)
public:
virtual IndexReader^ Reopen(
    IndexCommit^ commit
)
Parameters
commit
Type: Lucene.Net.Index IndexCommit
See Also
IndexReader Class
IndexReader Members
Reopen Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNorm Method

IndexReader SetNorm Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | SetNorm(Int32, String, Byte) | Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
Public method | SetNorm(Int32, String, Single) | Expert: Resets the normalization factor for the named field of the named document.
Back to Top
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNorm Method (Int32, String, Byte)

IndexReader SetNorm Method (Int32, String, Byte) Lucene.Net Class Library
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetNorm(
    int doc,
    string field,
    byte value
)
public virtual void SetNorm(
    int doc,
    string field,
    byte value
)
Public Overridable Sub SetNorm ( _
    doc As Integer, _
    field As String, _
    value As Byte _
)
Public Overridable Sub SetNorm ( _
    doc As Integer, _
    field As String, _
    value As Byte _
)
public:
virtual void SetNorm(
    int doc,
    String^ field,
    unsigned char value
)
public:
virtual void SetNorm(
    int doc,
    String^ field,
    unsigned char value
)
Parameters
doc
Type:   Online System Int32
field
Type:   Online System String
value
Type:   Online System Byte
Exceptions
Exception | Condition
Lucene.Net.Index StaleReaderException | If the index has changed since this reader was opened
Lucene.Net.Index CorruptIndexException | If the index is corrupt
Lucene.Net.Store LockObtainFailedException | If another writer has this index open (write.lock could not be obtained)
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
SetNorm Overload
Lucene.Net.Index Namespace
IndexReader Norms(String)
Similarity DecodeNorm(Byte)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNorm Method (Int32, String, Single)

IndexReader SetNorm Method (Int32, String, Single) Lucene.Net Class Library
Expert: Resets the normalization factor for the named field of the named document.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetNorm(
    int doc,
    string field,
    float value
)
public virtual void SetNorm(
    int doc,
    string field,
    float value
)
Public Overridable Sub SetNorm ( _
    doc As Integer, _
    field As String, _
    value As Single _
)
Public Overridable Sub SetNorm ( _
    doc As Integer, _
    field As String, _
    value As Single _
)
public:
virtual void SetNorm(
    int doc,
    String^ field,
    float value
)
public:
virtual void SetNorm(
    int doc,
    String^ field,
    float value
)
Parameters
doc
Type:   Online System Int32
field
Type:   Online System String
value
Type:   Online System Single
Exceptions
Exception | Condition
Lucene.Net.Index StaleReaderException | If the index has changed since this reader was opened
Lucene.Net.Index CorruptIndexException | If the index is corrupt
Lucene.Net.Store LockObtainFailedException | If another writer has this index open (write.lock could not be obtained)
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
SetNorm Overload
Lucene.Net.Index Namespace
IndexReader Norms(String)
Similarity DecodeNorm(Byte)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Method

IndexReader TermDocs Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TermDocs | Returns an unpositioned TermDocs enumerator.
Public method | TermDocs(Term) | Returns an enumeration of all the documents which contain term. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping: Term => <docNum, freq>* The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.
Back to Top
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Method

IndexReader TermDocs Method Lucene.Net Class Library
Returns an unpositioned TermDocs enumerator.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract TermDocs TermDocs()
public abstract TermDocs TermDocs()
Public MustOverride Function TermDocs As TermDocs
Public MustOverride Function TermDocs As TermDocs
public:
virtual TermDocs^ TermDocs() abstract
public:
virtual TermDocs^ TermDocs() abstract
Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
TermDocs Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Method (Term)

IndexReader TermDocs Method (Term) Lucene.Net Class Library
Returns an enumeration of all the documents which contain term. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping:

Term => <docNum, freq>*

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual TermDocs TermDocs(
    Term term
)
public virtual TermDocs TermDocs(
    Term term
)
Public Overridable Function TermDocs ( _
    term As Term _
) As TermDocs
Public Overridable Function TermDocs ( _
    term As Term _
) As TermDocs
public:
virtual TermDocs^ TermDocs(
    Term^ term
)
public:
virtual TermDocs^ TermDocs(
    Term^ term
)
Parameters
term
Type: Lucene.Net.Index Term
Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
TermDocs Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Method

IndexReader TermPositions Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TermPositions | Returns an unpositioned TermPositions enumerator.
Public method | TermPositions(Term) | Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping: Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >* This positional information facilitates phrase and proximity searching. The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.
Back to Top
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Method

IndexReader TermPositions Method Lucene.Net Class Library
Returns an unpositioned TermPositions enumerator.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract TermPositions TermPositions()
public abstract TermPositions TermPositions()
Public MustOverride Function TermPositions As TermPositions
Public MustOverride Function TermPositions As TermPositions
public:
virtual TermPositions^ TermPositions() abstract
public:
virtual TermPositions^ TermPositions() abstract
Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
TermPositions Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Method (Term)

IndexReader TermPositions Method (Term) Lucene.Net Class Library
Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual TermPositions TermPositions(
    Term term
)
public virtual TermPositions TermPositions(
    Term term
)
Public Overridable Function TermPositions ( _
    term As Term _
) As TermPositions
Public Overridable Function TermPositions ( _
    term As Term _
) As TermPositions
public:
virtual TermPositions^ TermPositions(
    Term^ term
)
public:
virtual TermPositions^ TermPositions(
    Term^ term
)
Parameters
term
Type: Lucene.Net.Index Term
Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
TermPositions Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method

IndexReader Terms Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Terms | Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration. Note that after calling terms(), Next must be called on the resulting enumeration before calling other methods such as Term.
Public method | Terms(Term) | Returns an enumeration of all terms starting at a given term. If the given term does not exist, the enumeration is positioned at the first term greater than the supplied term. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration.
Back to Top
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method

IndexReader Terms Method Lucene.Net Class Library
Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration. Note that after calling terms(), Next must be called on the resulting enumeration before calling other methods such as Term.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract TermEnum Terms()
public abstract TermEnum Terms()
Public MustOverride Function Terms As TermEnum
Public MustOverride Function Terms As TermEnum
public:
virtual TermEnum^ Terms() abstract
public:
virtual TermEnum^ Terms() abstract
Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Terms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method (Term)

IndexReader Terms Method (Term) Lucene.Net Class Library
Returns an enumeration of all terms starting at a given term. If the given term does not exist, the enumeration is positioned at the first term greater than the supplied term. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract TermEnum Terms(
    Term t
)
public abstract TermEnum Terms(
    Term t
)
Public MustOverride Function Terms ( _
    t As Term _
) As TermEnum
Public MustOverride Function Terms ( _
    t As Term _
) As TermEnum
public:
virtual TermEnum^ Terms(
    Term^ t
) abstract
public:
virtual TermEnum^ Terms(
    Term^ t
) abstract
Parameters
t
Type: Lucene.Net.Index Term
Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Terms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UndeleteAll Method

IndexReader UndeleteAll Method Lucene.Net Class Library
Undeletes all documents currently marked as deleted in this index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void UndeleteAll()
public virtual void UndeleteAll()
Public Overridable Sub UndeleteAll
Public Overridable Sub UndeleteAll
public:
virtual void UndeleteAll()
public:
virtual void UndeleteAll()
Exceptions
Exception | Condition
Lucene.Net.Index StaleReaderException | If the index has changed since this reader was opened
Lucene.Net.Index CorruptIndexException | If the index is corrupt
Lucene.Net.Store LockObtainFailedException | If another writer has this index open (write.lock could not be obtained)
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexReader Properties

IndexReader Properties Lucene.Net Class Library
The IndexReader type exposes the following members.
Properties
 | Name | Description
Public property | CommitUserData | Retrieve the String userData optionally passed to Commit(IDictionary String, String ). This will return null if Commit(IDictionary String, String ) has never been called for this index.
Public property | DeletesCacheKey |
Public property | FieldCacheKey | Expert
Public property | HasDeletions | Returns true if any documents have been deleted
Public property | IndexCommit | Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: this API is new and experimental and may suddenly change.
Public property | Item | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted.
Public property | MaxDoc | Returns one greater than the largest possible document number. This may be used to, e.g., determine how big to allocate an array which will have an element for every document number in an index.
Public property | NumDeletedDocs | Returns the number of deleted documents.
Public property | RefCount | Expert: returns the current refCount for this reader
Public property | TermInfosIndexDivisor | For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened.
Public property | UniqueTermCount | Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed.
Public property | Version | Version number when this IndexReader was opened. Not implemented in the IndexReader base class. If this reader is based on a Directory (ie, was created by calling Open(Directory, Boolean), or Reopen on a reader based on a Directory), then this method returns the version recorded in the commit that the reader opened. This version is advanced every time Commit is called. If instead this reader is a near real-time reader (ie, obtained by a call to GetReader , or by calling Reopen on a near real-time reader), then this method returns the version of the last commit done by the writer. Note that even as further changes are made with the writer, the version will not changed until a commit is completed. Thus, you should not rely on this method to determine when a near real-time reader should be opened. Use IsCurrent instead.
Back to Top
See Also
IndexReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CommitUserData Property

IndexReader CommitUserData Property Lucene.Net Class Library
Retrieve the String userData optionally passed to Commit(IDictionary String, String ). This will return null if Commit(IDictionary String, String ) has never been called for this index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IDictionary<string, string> CommitUserData { get; }
public virtual IDictionary<string, string> CommitUserData { get; }
Public Overridable ReadOnly Property CommitUserData As IDictionary(Of String, String)
    Get
Public Overridable ReadOnly Property CommitUserData As IDictionary(Of String, String)
    Get
public:
virtual property IDictionary<String^, String^>^ CommitUserData {
    IDictionary<String^, String^>^ get ();
}
public:
virtual property IDictionary<String^, String^>^ CommitUserData {
    IDictionary<String^, String^>^ get ();
}
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
IndexReader GetCommitUserData(Directory)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DeletesCacheKey Property

IndexReader DeletesCacheKey Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object DeletesCacheKey { get; }
public virtual Object DeletesCacheKey { get; }
Public Overridable ReadOnly Property DeletesCacheKey As Object
    Get
Public Overridable ReadOnly Property DeletesCacheKey As Object
    Get
public:
virtual property Object^ DeletesCacheKey {
    Object^ get ();
}
public:
virtual property Object^ DeletesCacheKey {
    Object^ get ();
}
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheKey Property

IndexReader FieldCacheKey Property Lucene.Net Class Library
Expert

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object FieldCacheKey { get; }
public virtual Object FieldCacheKey { get; }
Public Overridable ReadOnly Property FieldCacheKey As Object
    Get
Public Overridable ReadOnly Property FieldCacheKey As Object
    Get
public:
virtual property Object^ FieldCacheKey {
    Object^ get ();
}
public:
virtual property Object^ FieldCacheKey {
    Object^ get ();
}
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasDeletions Property

IndexReader HasDeletions Property Lucene.Net Class Library
Returns true if any documents have been deleted

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool HasDeletions { get; }
public abstract bool HasDeletions { get; }
Public MustOverride ReadOnly Property HasDeletions As Boolean
    Get
Public MustOverride ReadOnly Property HasDeletions As Boolean
    Get
public:
virtual property bool HasDeletions {
    bool get () abstract;
}
public:
virtual property bool HasDeletions {
    bool get () abstract;
}
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexCommit Property

IndexReader IndexCommit Property Lucene.Net Class Library
Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file.

WARNING: this API is new and experimental and may suddenly change.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IndexCommit IndexCommit { get; }
public virtual IndexCommit IndexCommit { get; }
Public Overridable ReadOnly Property IndexCommit As IndexCommit
    Get
Public Overridable ReadOnly Property IndexCommit As IndexCommit
    Get
public:
virtual property IndexCommit^ IndexCommit {
    IndexCommit^ get ();
}
public:
virtual property IndexCommit^ IndexCommit {
    IndexCommit^ get ();
}
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Item Property

IndexReader Item Property Lucene.Net Class Library
Returns the stored fields of the nthDocument in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Document this[
    int doc
] { get; }
public Document this[
    int doc
] { get; }
Public ReadOnly Default Property Item ( _
    doc As Integer _
) As Document
    Get
Public ReadOnly Default Property Item ( _
    doc As Integer _
) As Document
    Get
public:
property Document^ default[int doc] {
    Document^ get (int doc);
}
public:
property Document^ default[int doc] {
    Document^ get (int doc);
}
Parameters
doc
Type:   Online System Int32
Exceptions
Exception | Condition
Online System.IO IOException | If there is a low-level IO error
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxDoc Property

IndexReader MaxDoc Property Lucene.Net Class Library
Returns one greater than the largest possible document number. This may be used to, e.g., determine how big to allocate an array which will have an element for every document number in an index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int MaxDoc { get; }
public abstract int MaxDoc { get; }
Public MustOverride ReadOnly Property MaxDoc As Integer
    Get
Public MustOverride ReadOnly Property MaxDoc As Integer
    Get
public:
virtual property int MaxDoc {
    int get () abstract;
}
public:
virtual property int MaxDoc {
    int get () abstract;
}
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumDeletedDocs Property

IndexReader NumDeletedDocs Property Lucene.Net Class Library
Returns the number of deleted documents.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int NumDeletedDocs { get; }
public virtual int NumDeletedDocs { get; }
Public Overridable ReadOnly Property NumDeletedDocs As Integer
    Get
Public Overridable ReadOnly Property NumDeletedDocs As Integer
    Get
public:
virtual property int NumDeletedDocs {
    int get ();
}
public:
virtual property int NumDeletedDocs {
    int get ();
}
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RefCount Property

IndexReader RefCount Property Lucene.Net Class Library
Expert: returns the current refCount for this reader

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int RefCount { get; }
public virtual int RefCount { get; }
Public Overridable ReadOnly Property RefCount As Integer
    Get
Public Overridable ReadOnly Property RefCount As Integer
    Get
public:
virtual property int RefCount {
    int get ();
}
public:
virtual property int RefCount {
    int get ();
}
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermInfosIndexDivisor Property

IndexReader TermInfosIndexDivisor Property Lucene.Net Class Library
For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int TermInfosIndexDivisor { get; }
public virtual int TermInfosIndexDivisor { get; }
Public Overridable ReadOnly Property TermInfosIndexDivisor As Integer
    Get
Public Overridable ReadOnly Property TermInfosIndexDivisor As Integer
    Get
public:
virtual property int TermInfosIndexDivisor {
    int get ();
}
public:
virtual property int TermInfosIndexDivisor {
    int get ();
}
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UniqueTermCount Property

IndexReader UniqueTermCount Property Lucene.Net Class Library
Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed.
cannot be easily determined (eg Multi*Readers). Instead, you should call GetSequentialSubReaders and ask each sub reader for its unique term count.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long UniqueTermCount { get; }
public virtual long UniqueTermCount { get; }
Public Overridable ReadOnly Property UniqueTermCount As Long
    Get
Public Overridable ReadOnly Property UniqueTermCount As Long
    Get
public:
virtual property long long UniqueTermCount {
    long long get ();
}
public:
virtual property long long UniqueTermCount {
    long long get ();
}
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Version Property

IndexReader Version Property Lucene.Net Class Library
Version number when this IndexReader was opened. Not implemented in the IndexReader base class.

If this reader is based on a Directory (ie, was created by calling Open(Directory, Boolean), or Reopen on a reader based on a Directory), then this method returns the version recorded in the commit that the reader opened. This version is advanced every time Commit is called.

If instead this reader is a near real-time reader (ie, obtained by a call to GetReader , or by calling Reopen on a near real-time reader), then this method returns the version of the last commit done by the writer. Note that even as further changes are made with the writer, the version will not changed until a commit is completed. Thus, you should not rely on this method to determine when a near real-time reader should be opened. Use IsCurrent instead.

unless overridden in subclass

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long Version { get; }
public virtual long Version { get; }
Public Overridable ReadOnly Property Version As Long
    Get
Public Overridable ReadOnly Property Version As Long
    Get
public:
virtual property long long Version {
    long long get ();
}
public:
virtual property long long Version {
    long long get ();
}
See Also
IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexReader.FieldOption Class

IndexReader FieldOption Class Lucene.Net Class Library
Constants describing field properties, for example used for GetFieldNames(IndexReader FieldOption).
Inheritance Hierarchy
Online System Object
Lucene.Net.Index IndexReader FieldOption

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class FieldOption
public sealed class FieldOption
Public NotInheritable Class FieldOption
Public NotInheritable Class FieldOption
public ref class FieldOption sealed
public ref class FieldOption sealed
See Also
IndexReader FieldOption Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexReader.FieldOption Members

IndexReader FieldOption Members Lucene.Net Class Library

IndexReader is an abstract class, providing an interface for accessing an index. Search of an index is done entirely through this abstract interface, so that any subclass which implements it is searchable.

Concrete subclasses of IndexReader are usually constructed with a call to one of the static open() methods, e.g. Open(Directory, Boolean) .

For efficiency, in this API documents are often referred to via document numbers, non-negative integers which each name a unique document in the index. These document numbers are ephemeral--they may change as documents are added to and deleted from an index. Clients should thus not rely on a given document having the same number between sessions.

An IndexReader can be opened on a directory for which an IndexWriter is opened already, but it cannot be used to delete documents from the index then.

NOTE: for backwards API compatibility, several methods are not listed as abstract, but have no useful implementations in this base class and instead always throw UnsupportedOperationException. Subclasses are strongly encouraged to override these methods, but in many cases may not need to.

NOTE: as of 2.4, it's possible to open a read-only IndexReader using the static open methods that accepts the boolean readOnly parameter. Such a reader has better better concurrency as it's not necessary to synchronize on the isDeleted method. You must explicitly specify false if you want to make changes with the resulting IndexReader.

NOTE: IndexReader instances are completely thread safe, meaning multiple threads can call any of its methods, concurrently. If your application requires external synchronization, you should not synchronize on the IndexReader instance; use your own (non-Lucene) objects instead.

The IndexReader FieldOption type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Fields
Name | Description
ALL | All fields
INDEXED | All indexed fields
INDEXED_NO_TERMVECTOR | All fields which are indexed but don't have termvectors enabled
INDEXED_WITH_TERMVECTOR | All fields which are indexed with termvectors enabled
OMIT_TERM_FREQ_AND_POSITIONS | All fields that omit tf
STORES_PAYLOADS | All fields that store payloads
TERMVECTOR | All fields with termvectors enabled. Please note that only standard termvector fields are returned
TERMVECTOR_WITH_OFFSET | All fields with termvectors with offset values enabled
TERMVECTOR_WITH_POSITION | All fields with termvectors with position values enabled
TERMVECTOR_WITH_POSITION_OFFSET | All fields with termvectors with offset values and position values enabled
UNINDEXED | All fields which are not indexed
Back to Top
See Also
IndexReader FieldOption Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexReader.FieldOption Fields

IndexReader FieldOption Fields Lucene.Net Class Library
The IndexReader FieldOption type exposes the following members.
Fields
Name | Description
ALL | All fields
INDEXED | All indexed fields
INDEXED_NO_TERMVECTOR | All fields which are indexed but don't have termvectors enabled
INDEXED_WITH_TERMVECTOR | All fields which are indexed with termvectors enabled
OMIT_TERM_FREQ_AND_POSITIONS | All fields that omit tf
STORES_PAYLOADS | All fields that store payloads
TERMVECTOR | All fields with termvectors enabled. Please note that only standard termvector fields are returned
TERMVECTOR_WITH_OFFSET | All fields with termvectors with offset values enabled
TERMVECTOR_WITH_POSITION | All fields with termvectors with position values enabled
TERMVECTOR_WITH_POSITION_OFFSET | All fields with termvectors with offset values and position values enabled
UNINDEXED | All fields which are not indexed
Back to Top
See Also
IndexReader FieldOption Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ALL Field

IndexReader FieldOption ALL Field Lucene.Net Class Library
All fields

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IndexReader..::..FieldOption ALL
public static readonly IndexReader..::..FieldOption ALL
Public Shared ReadOnly ALL As IndexReader..::..FieldOption
Public Shared ReadOnly ALL As IndexReader..::..FieldOption
public:
static initonly IndexReader..::..FieldOption^ ALL
public:
static initonly IndexReader..::..FieldOption^ ALL
See Also
IndexReader FieldOption Class
IndexReader FieldOption Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


INDEXED Field

IndexReader FieldOption INDEXED Field Lucene.Net Class Library
All indexed fields

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IndexReader..::..FieldOption INDEXED
public static readonly IndexReader..::..FieldOption INDEXED
Public Shared ReadOnly INDEXED As IndexReader..::..FieldOption
Public Shared ReadOnly INDEXED As IndexReader..::..FieldOption
public:
static initonly IndexReader..::..FieldOption^ INDEXED
public:
static initonly IndexReader..::..FieldOption^ INDEXED
See Also
IndexReader FieldOption Class
IndexReader FieldOption Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


INDEXED_NO_TERMVECTOR Field

IndexReader FieldOption INDEXED_NO_TERMVECTOR Field Lucene.Net Class Library
All fields which are indexed but don't have termvectors enabled

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IndexReader..::..FieldOption INDEXED_NO_TERMVECTOR
public static readonly IndexReader..::..FieldOption INDEXED_NO_TERMVECTOR
Public Shared ReadOnly INDEXED_NO_TERMVECTOR As IndexReader..::..FieldOption
Public Shared ReadOnly INDEXED_NO_TERMVECTOR As IndexReader..::..FieldOption
public:
static initonly IndexReader..::..FieldOption^ INDEXED_NO_TERMVECTOR
public:
static initonly IndexReader..::..FieldOption^ INDEXED_NO_TERMVECTOR
See Also
IndexReader FieldOption Class
IndexReader FieldOption Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


INDEXED_WITH_TERMVECTOR Field

IndexReader FieldOption INDEXED_WITH_TERMVECTOR Field Lucene.Net Class Library
All fields which are indexed with termvectors enabled

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IndexReader..::..FieldOption INDEXED_WITH_TERMVECTOR
public static readonly IndexReader..::..FieldOption INDEXED_WITH_TERMVECTOR
Public Shared ReadOnly INDEXED_WITH_TERMVECTOR As IndexReader..::..FieldOption
Public Shared ReadOnly INDEXED_WITH_TERMVECTOR As IndexReader..::..FieldOption
public:
static initonly IndexReader..::..FieldOption^ INDEXED_WITH_TERMVECTOR
public:
static initonly IndexReader..::..FieldOption^ INDEXED_WITH_TERMVECTOR
See Also
IndexReader FieldOption Class
IndexReader FieldOption Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OMIT_TERM_FREQ_AND_POSITIONS Field

IndexReader FieldOption OMIT_TERM_FREQ_AND_POSITIONS Field Lucene.Net Class Library
All fields that omit tf

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IndexReader..::..FieldOption OMIT_TERM_FREQ_AND_POSITIONS
public static readonly IndexReader..::..FieldOption OMIT_TERM_FREQ_AND_POSITIONS
Public Shared ReadOnly OMIT_TERM_FREQ_AND_POSITIONS As IndexReader..::..FieldOption
Public Shared ReadOnly OMIT_TERM_FREQ_AND_POSITIONS As IndexReader..::..FieldOption
public:
static initonly IndexReader..::..FieldOption^ OMIT_TERM_FREQ_AND_POSITIONS
public:
static initonly IndexReader..::..FieldOption^ OMIT_TERM_FREQ_AND_POSITIONS
See Also
IndexReader FieldOption Class
IndexReader FieldOption Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


STORES_PAYLOADS Field

IndexReader FieldOption STORES_PAYLOADS Field Lucene.Net Class Library
All fields that store payloads

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IndexReader..::..FieldOption STORES_PAYLOADS
public static readonly IndexReader..::..FieldOption STORES_PAYLOADS
Public Shared ReadOnly STORES_PAYLOADS As IndexReader..::..FieldOption
Public Shared ReadOnly STORES_PAYLOADS As IndexReader..::..FieldOption
public:
static initonly IndexReader..::..FieldOption^ STORES_PAYLOADS
public:
static initonly IndexReader..::..FieldOption^ STORES_PAYLOADS
See Also
IndexReader FieldOption Class
IndexReader FieldOption Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TERMVECTOR Field

IndexReader FieldOption TERMVECTOR Field Lucene.Net Class Library
All fields with termvectors enabled. Please note that only standard termvector fields are returned

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IndexReader..::..FieldOption TERMVECTOR
public static readonly IndexReader..::..FieldOption TERMVECTOR
Public Shared ReadOnly TERMVECTOR As IndexReader..::..FieldOption
Public Shared ReadOnly TERMVECTOR As IndexReader..::..FieldOption
public:
static initonly IndexReader..::..FieldOption^ TERMVECTOR
public:
static initonly IndexReader..::..FieldOption^ TERMVECTOR
See Also
IndexReader FieldOption Class
IndexReader FieldOption Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TERMVECTOR_WITH_OFFSET Field

IndexReader FieldOption TERMVECTOR_WITH_OFFSET Field Lucene.Net Class Library
All fields with termvectors with offset values enabled

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IndexReader..::..FieldOption TERMVECTOR_WITH_OFFSET
public static readonly IndexReader..::..FieldOption TERMVECTOR_WITH_OFFSET
Public Shared ReadOnly TERMVECTOR_WITH_OFFSET As IndexReader..::..FieldOption
Public Shared ReadOnly TERMVECTOR_WITH_OFFSET As IndexReader..::..FieldOption
public:
static initonly IndexReader..::..FieldOption^ TERMVECTOR_WITH_OFFSET
public:
static initonly IndexReader..::..FieldOption^ TERMVECTOR_WITH_OFFSET
See Also
IndexReader FieldOption Class
IndexReader FieldOption Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TERMVECTOR_WITH_POSITION Field

IndexReader FieldOption TERMVECTOR_WITH_POSITION Field Lucene.Net Class Library
All fields with termvectors with position values enabled

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IndexReader..::..FieldOption TERMVECTOR_WITH_POSITION
public static readonly IndexReader..::..FieldOption TERMVECTOR_WITH_POSITION
Public Shared ReadOnly TERMVECTOR_WITH_POSITION As IndexReader..::..FieldOption
Public Shared ReadOnly TERMVECTOR_WITH_POSITION As IndexReader..::..FieldOption
public:
static initonly IndexReader..::..FieldOption^ TERMVECTOR_WITH_POSITION
public:
static initonly IndexReader..::..FieldOption^ TERMVECTOR_WITH_POSITION
See Also
IndexReader FieldOption Class
IndexReader FieldOption Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TERMVECTOR_WITH_POSITION_OFFSET Field

IndexReader FieldOption TERMVECTOR_WITH_POSITION_OFFSET Field Lucene.Net Class Library
All fields with termvectors with offset values and position values enabled

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IndexReader..::..FieldOption TERMVECTOR_WITH_POSITION_OFFSET
public static readonly IndexReader..::..FieldOption TERMVECTOR_WITH_POSITION_OFFSET
Public Shared ReadOnly TERMVECTOR_WITH_POSITION_OFFSET As IndexReader..::..FieldOption
Public Shared ReadOnly TERMVECTOR_WITH_POSITION_OFFSET As IndexReader..::..FieldOption
public:
static initonly IndexReader..::..FieldOption^ TERMVECTOR_WITH_POSITION_OFFSET
public:
static initonly IndexReader..::..FieldOption^ TERMVECTOR_WITH_POSITION_OFFSET
See Also
IndexReader FieldOption Class
IndexReader FieldOption Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UNINDEXED Field

IndexReader FieldOption UNINDEXED Field Lucene.Net Class Library
All fields which are not indexed

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IndexReader..::..FieldOption UNINDEXED
public static readonly IndexReader..::..FieldOption UNINDEXED
Public Shared ReadOnly UNINDEXED As IndexReader..::..FieldOption
Public Shared ReadOnly UNINDEXED As IndexReader..::..FieldOption
public:
static initonly IndexReader..::..FieldOption^ UNINDEXED
public:
static initonly IndexReader..::..FieldOption^ UNINDEXED
See Also
IndexReader FieldOption Class
IndexReader FieldOption Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexReader.FieldOption Methods

IndexReader FieldOption Methods Lucene.Net Class Library
The IndexReader FieldOption type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
IndexReader FieldOption Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

IndexReader FieldOption ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
IndexReader FieldOption Class
IndexReader FieldOption Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter Class

IndexWriter Class Lucene.Net Class Library
An IndexWriter creates and maintains an index.

The create argument to the constructor determines whether a new index is created, or whether an existing index is opened. Note that you can open an index with create=true even while readers are using the index. The old readers will continue to search the "point in time" snapshot they had opened, and won't see the newly created index until they re-open. There are also constructors with no create argument which will create a new index if there is not already an index at the provided path and otherwise open the existing index.

In either case, documents are added with AddDocument(Document) and removed with DeleteDocuments(Term) or DeleteDocuments(Query). A document can be updated with UpdateDocument(Term, Document) (which just deletes and then adds the entire document). When finished adding, deleting and updating documents, Close should be called.

These changes are buffered in memory and periodically flushed to the Directory (during the above method calls). A flush is triggered when there are enough buffered deletes (see SetMaxBufferedDeleteTerms(Int32)) or enough added documents since the last flush, whichever is sooner. For the added documents, flushing is triggered either by RAM usage of the documents (see SetRAMBufferSizeMB(Double)) or the number of added documents. The default is to flush when RAM usage hits 16 MB. For best indexing speed you should flush by RAM usage with a large RAM buffer. Note that flushing just moves the internal buffered state in IndexWriter into the index, but these changes are not visible to IndexReader until either Commit or Close is called. A flush may also trigger one or more segment merges which by default run with a background thread so as not to block the addDocument calls (see below for changing the MergeScheduler).

If an index will not have more documents added for a while and optimal search performance is desired, then either the full Optimize method or partial Optimize(Int32) method should be called before the index is closed.

Opening an IndexWriter creates a lock file for the directory in use. Trying to open another IndexWriter on the same directory will lead to a LockObtainFailedException. The LockObtainFailedException is also thrown if an IndexReader on the same directory is used to delete documents from the index.

Expert: IndexWriter allows an optional IndexDeletionPolicy implementation to be specified. You can use this to control when prior commits are deleted from the index. The default policy is KeepOnlyLastCommitDeletionPolicy which removes all prior commits as soon as a new commit is done (this matches behavior before 2.2). Creating your own policy can allow you to explicitly keep previous "point in time" commits alive in the index for some time, to allow readers to refresh to the new commit without having the old commit deleted out from under them. This is necessary on filesystems like NFS that do not support "delete on last close" semantics, which Lucene's "point in time" search normally relies on.

Expert: IndexWriter allows you to separately change the MergePolicy and the MergeScheduler. The MergePolicy is invoked whenever there are changes to the segments in the index. Its role is to select which merges to do, if any, and return a MergePolicy MergeSpecification describing the merges. It also selects merges to do for optimize(). (The default is LogByteSizeMergePolicy. Then, the MergeScheduler is invoked with the requested merges and it decides when and how to run the merges. The default is ConcurrentMergeScheduler.

NOTE: if you hit an OutOfMemoryError then IndexWriter will quietly record this fact and block all future segment commits. This is a defensive measure in case any internal state (buffered documents and deletions) were corrupted. Any subsequent calls to Commit will throw an IllegalStateException. The only course of action is to call Close , which internally will call Rollback , to undo any changes to the index since the last commit. You can also just call Rollback directly.

NOTE: IndexWriter instances are completely thread safe, meaning multiple threads can call any of its methods, concurrently. If your application requires external synchronization, you should not synchronize on the IndexWriter instance as this may cause deadlock; use your own (non-Lucene) objects instead.

NOTE: if you call Thread.Interrupt() on a thread that's within IndexWriter, IndexWriter will try to catch this (eg, if it's in a Wait() or Thread.Sleep()), and will then throw the unchecked exception Online ThreadInterruptedException and clear the interrupt status on the thread

Inheritance Hierarchy
Online System Object
Lucene.Net.Index IndexWriter

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class IndexWriter : IDisposable
public class IndexWriter : IDisposable
Public Class IndexWriter _
    Implements IDisposable
Public Class IndexWriter _
    Implements IDisposable
public ref class IndexWriter : IDisposable
public ref class IndexWriter : IDisposable
See Also
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter Members

IndexWriter Members Lucene.Net Class Library

The IndexWriter type exposes the following members.
Constructors
 | Name | Description
Public method | IndexWriter(Directory, Analyzer, IndexWriter MaxFieldLength) | Constructs an IndexWriter for the index in d, first creating it if it does not already exist.
Public method | IndexWriter(Directory, Analyzer, IndexDeletionPolicy, IndexWriter MaxFieldLength) | Expert: constructs an IndexWriter with a custom IndexDeletionPolicy , for the index in d, first creating it if it does not already exist. Text will be analyzed with a.
Public method | IndexWriter(Directory, Analyzer, Boolean, IndexWriter MaxFieldLength) | Constructs an IndexWriter for the index in d. Text will be analyzed with a. If create is true, then a new, empty index will be created in d, replacing the index already there, if any.
Public method | IndexWriter(Directory, Analyzer, IndexDeletionPolicy, IndexWriter MaxFieldLength, IndexCommit) | Expert: constructs an IndexWriter on specific commit point, with a custom IndexDeletionPolicy, for the index in d. Text will be analyzed with a. This is only meaningful if you've used a IndexDeletionPolicy in that past that keeps more than just the last commit. This operation is similar to Rollback , except that method can only rollback what's been done with the current instance of IndexWriter since its last commit, whereas this method can rollback to an arbitrary commit point from the past, assuming the IndexDeletionPolicy has preserved past commits.
Public method | IndexWriter(Directory, Analyzer, Boolean, IndexDeletionPolicy, IndexWriter MaxFieldLength) | Expert: constructs an IndexWriter with a custom IndexDeletionPolicy , for the index in d. Text will be analyzed with a. If create is true, then a new, empty index will be created in d, replacing the index already there, if any.
Back to Top
Methods
Name | Description
Public method AddDocument(Document)
Adds a document to this index. If the document contains more than SetMaxFieldLength(Int32) terms for a given field, the remainder are discarded.

Note that if an Exception is hit (for example disk full) then the index will be consistent, but this document may not have been added. Furthermore, it's possible the index will have one segment in non-compound format even when using compound files (when a merge has partially succeeded).

This method periodically flushes pending documents to the Directory (see above), and also periodically triggers segment merges in the index according to the MergePolicy in use.

Merges temporarily consume space in the directory. The amount of space required is up to 1X the size of all segments being merged, when no readers/searchers are open against the index, and up to 2X the size of all segments being merged when readers/searchers are open against the index (see Optimize for details). The sequence of primitive merge operations performed is governed by the merge policy.

Note that each term in the document can be no longer than 16383 characters, otherwise an IllegalArgumentException will be thrown.

Note that it's possible to create an invalid Unicode string in java if a UTF16 surrogate pair is malformed. In this case, the invalid characters are silently replaced with the Unicode replacement character U+FFFD.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method AddDocument(Document, Analyzer)
Adds a document to this index, using the provided analyzer instead of the value of Analyzer. If the document contains more than SetMaxFieldLength(Int32) terms for a given field, the remainder are discarded.

See AddDocument(Document) for details on index and IndexWriter state after an Exception, and flushing/merging temporary free space requirements.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method AddIndexes
Merges the provided indexes into this index.

After this completes, the index is optimized.

The provided IndexReaders are not closed.

NOTE: while this is running, any attempts to add or delete documents (with another thread) will be paused until this method completes.

See AddIndexesNoOptimize( Directory ) for details on transactional semantics, temporary free space required in the Directory, and non-CFS segments on an Exception.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method AddIndexesNoOptimize
Merges all segments from an array of indexes into this index.

This may be used to parallelize batch indexing. A large document collection can be broken into sub-collections. Each sub-collection can be indexed in parallel, on a different thread, process or machine. The complete index can then be created by merging sub-collection indexes with this method.

NOTE: the index in each Directory must not be changed (opened by a writer) while this method is running. This method does not acquire a write lock in each input Directory, so it is up to the caller to enforce this.

NOTE: while this is running, any attempts to add or delete documents (with another thread) will be paused until this method completes.

This method is transactional in how Exceptions are handled: it does not commit a new segments_N file until all indexes are added. This means if an Exception occurs (for example disk full), then either no indexes will have been added or they all will have been.

Note that this requires temporary free space in the Directory up to 2X the sum of all input indexes (including the starting index). If readers/searchers are open against the starting index, then temporary free space required will be higher by the size of the starting index (see Optimize for details).

Once this completes, the final size of the index will be less than the sum of all input index sizes (including the starting index). It could be quite a bit smaller (if there were many pending deletes) or just slightly smaller.

This requires this index not be among those to be added.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Close Obsolete.
Commits all changes to an index and closes all associated files. Note that this may be a costly operation, so, try to re-use a single writer instead of closing and opening a new one. See Commit for caveats about write caching done by some IO devices.

If an Exception is hit during close, eg due to disk full or some other reason, then both the on-disk index and the internal state of the IndexWriter instance will be consistent. However, the close will not be complete even though part of it (flushing buffered documents) may have succeeded, so the write lock will still be held.

If you can correct the underlying cause (eg free up some disk space) then you can call close() again. Failing that, if you want to force the write lock to be released (dangerous, because you may then lose buffered docs in the IndexWriter instance) then you can do something like this:

View Colorized Copy to Clipboard Print
try {
    writer.close();
} finally {
    if (IndexWriter.isLocked(directory)) {
        IndexWriter.unlock(directory);
    }
}
try {
    writer.close();
} finally {
    if (IndexWriter.isLocked(directory)) {
        IndexWriter.unlock(directory);
    }
}
after which, you must be certain not to use the writer instance anymore.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

Public method Close(Boolean) Obsolete.
Closes the index with or without waiting for currently running merges to finish. This is only meaningful when using a MergeScheduler that runs merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

NOTE: it is dangerous to always call close(false), especially when IndexWriter is not open for very long, because this can result in "merge starvation" whereby long merges will never have a chance to finish. This will cause too many segments in your index over time.

Public method Commit

Commits all pending changes (added & deleted documents, optimizations, segment merges, added indexes, etc.) to the index, and syncs all referenced index files, such that a reader will see the changes and the index updates will survive an OS or machine crash or power loss. Note that this does not wait for any running background merges to finish. This may be a costly operation, so you should test the cost in your application and do it only when really necessary.

Note that this operation calls Directory.sync on the index files. That call should not return until the file contents & metadata are on stable storage. For FSDirectory, this calls the OS's fsync. But, beware: some hardware devices may in fact cache writes even during fsync, and return before the bits are actually on stable storage, to give the appearance of faster performance. If you have such a device, and it does not have a battery backup (for example) then on power loss it may still lose data. Lucene cannot guarantee consistency on such devices.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Commit(IDictionary String, String )
Commits all changes to the index, specifying a commitUserData Map (String -> String). This just calls PrepareCommit(IDictionary String, String ) (if you didn't already call it) and then FinishCommit .

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteAll
Delete all documents in the index.

This method will drop all buffered documents and will remove all segments from the index. This change will not be visible until a Commit has been called. This method can be rolled back using Rollback .

NOTE: this method is much faster than using deleteDocuments( new MatchAllDocsQuery() ).

NOTE: this method will forcefully abort all merges in progress. If other threads are running Optimize or any of the addIndexes methods, they will receive MergePolicy MergeAbortedExceptions.
Public method DeleteDocuments(Query)
Deletes the document(s) matching the provided query.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteDocuments( Query )
Deletes the document(s) matching any of the provided queries. All deletes are flushed at the same time.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteDocuments(Term)
Deletes the document(s) containing term.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteDocuments( Term )
Deletes the document(s) containing any of the terms. All deletes are flushed at the same time.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Dispose
Commits all changes to an index and closes all associated files. Note that this may be a costly operation, so, try to re-use a single writer instead of closing and opening a new one. See Commit for caveats about write caching done by some IO devices.

If an Exception is hit during close, eg due to disk full or some other reason, then both the on-disk index and the internal state of the IndexWriter instance will be consistent. However, the close will not be complete even though part of it (flushing buffered documents) may have succeeded, so the write lock will still be held.

If you can correct the underlying cause (eg free up some disk space) then you can call close() again. Failing that, if you want to force the write lock to be released (dangerous, because you may then lose buffered docs in the IndexWriter instance) then you can do something like this:

View Colorized Copy to Clipboard Print
try {
    writer.close();
} finally {
    if (IndexWriter.isLocked(directory)) {
        IndexWriter.unlock(directory);
    }
}
try {
    writer.close();
} finally {
    if (IndexWriter.isLocked(directory)) {
        IndexWriter.unlock(directory);
    }
}
after which, you must be certain not to use the writer instance anymore.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

Public method Dispose(Boolean)
Closes the index with or without waiting for currently running merges to finish. This is only meaningful when using a MergeScheduler that runs merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

NOTE: it is dangerous to always call close(false), especially when IndexWriter is not open for very long, because this can result in "merge starvation" whereby long merges will never have a chance to finish. This will cause too many segments in your index over time.

Protected method | Dispose(Boolean, Boolean)
Protected method DoAfterFlush
A hook for extending classes to execute operations after pending added and deleted documents have been flushed to the Directory but before the change is committed (new segments_N file written).
Protected method DoBeforeFlush
A hook for extending classes to execute operations before pending added and deleted documents are flushed to the Directory.
Protected method | EnsureOpen
Protected method EnsureOpen(Boolean)
Used internally to throw an AlreadyClosedException if this IndexWriter has been closed.
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Public method ExpungeDeletes
Expunges all deletes from the index. When an index has many document deletions (or updates to existing documents), it's best to either call optimize or expungeDeletes to remove all unused data in the index associated with the deleted documents. To see how many deletions you have pending in your index, call NumDeletedDocs This saves disk space and memory usage while searching. expungeDeletes should be somewhat faster than optimize since it does not insist on reducing the index to a single segment (though, this depends on the MergePolicy; see FindMergesToExpungeDeletes(SegmentInfos).). Note that this call does not first commit any buffered documents, so you must do so yourself if necessary. See also

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method ExpungeDeletes(Boolean)
Just like ExpungeDeletes , except you can specify whether the call should block until the operation completes. This is only meaningful with a MergeScheduler that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Flush
Flush all in-memory buffered udpates (adds and deletes) to the Directory.
Public method | GetDocCount
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method GetMaxBufferedDeleteTerms
Returns the number of buffered deleted terms that will trigger a flush if enabled.
Public method GetMaxBufferedDocs
Returns the number of buffered added documents that will trigger a flush if enabled.
Public method GetMaxFieldLength
Returns the maximum number of terms that will be indexed for a single field in a document.
Public method GetRAMBufferSizeMB
Returns the value set by SetRAMBufferSizeMB(Double) if enabled.
Public method GetReader
Expert: returns a readonly reader, covering all committed as well as un-committed changes to the index. This provides "near real-time" searching, in that changes made during an IndexWriter session can be quickly made available for searching without closing the writer nor calling Commit .

Note that this is functionally equivalent to calling {#commit} and then using Open(Directory, Boolean) to open a new reader. But the turarnound time of this method should be faster since it avoids the potentially costly Commit .

You must close the IndexReader returned by this method once you are done using it.

It's near real-time because there is no hard guarantee on how quickly you can get a new reader after making changes with IndexWriter. You'll have to experiment in your situation to determine if it's faster enough. As this is a new and experimental feature, please report back on your findings so we can learn, improve and iterate.

The resulting reader suppports Reopen , but that call will simply forward back to this method (though this may change in the future).

The very first time this method is called, this writer instance will make every effort to pool the readers that it opens for doing merges, applying deletes, etc. This means additional resources (RAM, file descriptors, CPU time) will be consumed.

For lower latency on reopening a reader, you should call MergedSegmentWarmer to call MergedSegmentWarmer to pre-warm a newly merged segment before it's committed to the index. This is important for minimizing index-to-search delay after a large merge.

If an addIndexes* call is running in another thread, then this reader will only search those segments from the foreign index that have been successfully copied over, so far

.

NOTE: Once the writer is closed, any outstanding readers may continue to be used. However, if you attempt to reopen any of those readers, you'll hit an AlreadyClosedException.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Public method GetReader(Int32)
Expert: like GetReader , except you can specify which termInfosIndexDivisor should be used for any newly opened readers.
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method | HasDeletions
IsLocked
Returns true iff the index in the named directory is currently locked.
Public method MaxDoc
Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), not counting deletions.
Public method MaybeMerge
Expert: asks the mergePolicy whether any merges are necessary now and if so, runs the requested merges and then iterate (test again if merges are needed) until no more merges are returned by the mergePolicy. Explicit calls to maybeMerge() are usually not necessary. The most common case is when merge policy parameters have changed.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method | Merge_ForNUnit
Public method Message
Prints a message to the infoStream (if non-null), prefixed with the identifying information for this writer and the thread that's calling it.
Public method | NewestSegment
Public method NumDeletedDocs
Obtain the number of deleted docs for a pooled reader. If the reader isn't being pooled, the segmentInfo's delCount is returned.
Public method NumDocs
Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), and including deletions. NOTE: buffered deletions are not counted. If you really need these to be counted you should call Commit first.
Public method NumRamDocs
Expert: Return the number of documents currently buffered in RAM.
Public method Optimize
Requests an "optimize" operation on an index, priming the index for the fastest available search. Traditionally this has meant merging all segments into a single segment as is done in the default merge policy, but individaul merge policies may implement optimize in different ways.

It is recommended that this method be called upon completion of indexing. In environments with frequent updates, optimize is best done during low volume times, if at all.

See http://www.gossamer-threads.com/lists/lucene/java-dev/47895 for more discussion.

Note that optimize requires 2X the index size free space in your Directory (3X if you're using compound file format). For example, if your index size is 10 MB then you need 20 MB free for optimize to complete (30 MB if you're using compound fiel format).

If some but not all readers re-open while an optimize is underway, this will cause > 2X temporary space to be consumed as those new readers will then hold open the partially optimized segments at that time. It is best not to re-open readers while optimize is running.

The actual temporary usage could be much less than these figures (it depends on many factors).

In general, once the optimize completes, the total size of the index will be less than the size of the starting index. It could be quite a bit smaller (if there were many pending deletes) or just slightly smaller.

If an Exception is hit during optimize(), for example due to disk full, the index will not be corrupt and no documents will have been lost. However, it may have been partially optimized (some segments were merged but not all), and it's possible that one of the segments in the index will be in non-compound format even when using compound file format. This will occur when the Exception is hit during conversion of the segment into compound format.

This call will optimize those segments present in the index when the call started. If other threads are still adding documents and flushing segments, those newly created segments will not be optimized unless you call optimize again.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Boolean)
Just like Optimize , except you can specify whether the call should block until the optimize completes. This is only meaningful with a MergeScheduler that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Int32)
Optimize the index down to <= maxNumSegments. If maxNumSegments==1 then this is the same as Optimize .

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Int32, Boolean)
Just like Optimize(Int32), except you can specify whether the call should block until the optimize completes. This is only meaningful with a MergeScheduler that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method PrepareCommit
Expert: prepare for commit.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method RamSizeInBytes
Expert: Return the total size of all index files currently cached in memory. Useful for size management with flushRamDocs()
Public method Rollback
Close the IndexWriter without committing any changes that have occurred since the last commit (or since it was opened, if commit hasn't been called). This removes any temporary files that had been created, after which the state of the index will be the same as it was when commit() was last called or when this writer was first opened. This also clears a previous call to PrepareCommit .
Public method | SegString
Public method SetInfoStream
If non-null, information about merges, deletes and a message when maxFieldLength is reached will be printed to this.
Public method SetMaxBufferedDeleteTerms

Determines the minimal number of delete terms required before the buffered in-memory delete terms are applied and flushed. If there are documents buffered in memory at the time, they are merged and a new segment is created.

Disabled by default (writer flushes by RAM usage).

Public method SetMaxBufferedDocs
Determines the minimal number of documents required before the buffered in-memory documents are flushed as a new Segment. Large values generally gives faster indexing.

When this is set, the writer will flush every maxBufferedDocs added documents. Pass in DISABLE_AUTO_FLUSH to prevent triggering a flush due to number of buffered documents. Note that if flushing by RAM usage is also enabled, then the flush will be triggered by whichever comes first.

Disabled by default (writer flushes by RAM usage).

Public method SetMaxFieldLength
The maximum number of terms that will be indexed for a single field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory. This setting refers to the number of running terms, not to the number of different terms.

Note: this silently truncates large documents, excluding from the index all terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accomodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an OutOfMemoryError.

By default, no more than DEFAULT_MAX_FIELD_LENGTH terms will be indexed for a field.
Public method SetMergePolicy
Expert: set the merge policy used by this writer.
Public method SetMergeScheduler
Expert: set the merge scheduler used by this writer.
Public method SetRAMBufferSizeMB
Determines the amount of RAM that may be used for buffering added documents and deletions before they are flushed to the Directory. Generally for faster indexing performance it's best to flush by RAM usage instead of document count and use as large a RAM buffer as you can.

When this is set, the writer will flush whenever buffered documents and deletions use this much RAM. Pass in DISABLE_AUTO_FLUSH to prevent triggering a flush due to RAM usage. Note that if flushing by document count is also enabled, then the flush will be triggered by whichever comes first.

NOTE: the account of RAM usage for pending deletions is only approximate. Specifically, if you delete by Query, Lucene currently has no way to measure the RAM usage if individual Queries so the accounting will under-estimate and you should compensate by either calling commit() periodically yourself, or by using SetMaxBufferedDeleteTerms(Int32) to flush by count instead of RAM usage (each buffered delete Query counts as one).

NOTE: because IndexWriter uses ints when managing its internal storage, the absolute maximum value for this setting is somewhat less than 2048 MB. The precise limit depends on various factors, such as how large your documents are, how many fields have norms, etc., so it's best to set this value comfortably under 2048.

The default value is DEFAULT_RAM_BUFFER_SIZE_MB.

Public method SetSimilarity
Expert: Set the Similarity implementation used by this IndexWriter.
Public method | TestPoint
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Unlock
Forcibly unlocks the index in the named directory.

Caution: this should only be used by failure recovery code, when it is known that no other process nor thread is in fact currently accessing this index.
Public method UpdateDocument(Term, Document)
Updates a document by first deleting the document(s) containing term and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method UpdateDocument(Term, Document, Analyzer)
Updates a document by first deleting the document(s) containing term and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method WaitForMerges
Wait for any currently outstanding merges to finish.

It is guaranteed that any merges started prior to calling this method will have completed once this method completes.

Back to Top
Fields
Name | Description
DEFAULT_MAX_BUFFERED_DELETE_TERMS | Disabled by default (because IndexWriter flushes by RAM usage by default). Change using SetMaxBufferedDeleteTerms(Int32).
DEFAULT_MAX_BUFFERED_DOCS | Disabled by default (because IndexWriter flushes by RAM usage by default). Change using SetMaxBufferedDocs(Int32).
DEFAULT_MAX_FIELD_LENGTH | Default value is 10,000. Change using SetMaxFieldLength(Int32).
DEFAULT_RAM_BUFFER_SIZE_MB | Default value is 16 MB (which means flush when buffered docs consume 16 MB RAM). Change using SetRAMBufferSizeMB(Double).
DEFAULT_TERM_INDEX_INTERVAL | Default value is 128. Change using TermIndexInterval.
DISABLE_AUTO_FLUSH | Value to denote a flush trigger is disabled
MAX_TERM_LENGTH | Absolute hard maximum length for a term. If a term arrives from the analyzer longer than this length, it is skipped and a message is printed to infoStream, if set (see SetInfoStream(StreamWriter)).
WRITE_LOCK_NAME | Name of the write lock in the index.
WRITE_LOCK_TIMEOUT | Default value for the write lock timeout (1,000).
Back to Top
Properties
Name | Description
Public property Analyzer
Returns the analyzer used by this index.
DefaultInfoStream
Gets or sets the default info stream. If non-null, this will be the default infoStream used by a newly instantiated IndexWriter.
DefaultWriteLockTimeout
Gets or sets the default (for any instance of IndexWriter) maximum time to wait for a write lock (in milliseconds).
Public property Directory
Returns the Directory used by this index.
Public property InfoStream
Returns the current infoStream in use by this writer.
Public property MaxMergeDocs

Gets or sets the largest segment (measured by document count) that may be merged with other segments.

Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches.

The default value is Online MaxValue.

Note that this method is a convenience method: it just calls mergePolicy.getMaxMergeDocs as long as mergePolicy is an instance of LogMergePolicy. Otherwise an IllegalArgumentException is thrown.

The default merge policy (LogByteSizeMergePolicy) also allows you to set this limit by net size (in MB) of the segment, using MaxMergeMB.

Public property MergedSegmentWarmer
Gets or sets the merged segment warmer. See IndexWriter IndexReaderWarmer .
Public property MergeFactor
Gets or sets the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index.

Determines how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained.

Note that this method is a convenience method: it just calls mergePolicy.setMergeFactor as long as mergePolicy is an instance of LogMergePolicy. Otherwise an IllegalArgumentException is thrown.

This must never be less than 2. The default value is 10.
Public property MergePolicy
Expert: returns the current MergePolicy in use by this writer.
Public property MergeScheduler
Expert: returns the current MergePolicy in use by this writer.
Public property | ReaderTermsIndexDivisor
Public property Similarity
Expert: Return the Similarity implementation used by this IndexWriter.

This defaults to the current value of Default.
Public property TermIndexInterval
Expert: Gets or sets the interval between indexed terms. Large values cause less memory to be used by IndexReader, but slow random-access to terms. Small values cause more memory to be used by an IndexReader, and speed random-access to terms. This parameter determines the amount of computation required per query term, regardless of the number of documents that contain that term. In particular, it is the maximum number of other terms that must be scanned before a term is located and its frequency and position information may be processed. In a large index with user-entered query terms, query processing time is likely to be dominated not by term lookup but rather by the processing of frequency and positional data. In a small index or when many uncommon query terms are generated (e.g., by wildcard queries) term lookup may become a dominant cost. In particular, numUniqueTerms/interval terms are read into memory by an IndexReader, and, on average, interval/2 terms must be scanned for each random term access.
Public property UseCompoundFile

Gets or sets the current setting of whether newly flushed segments will use the compound file format. Note that this just returns the value previously set with setUseCompoundFile(boolean), or the default value (true). You cannot use this to query the status of previously flushed segments.

Note that this method is a convenience method: it just calls mergePolicy.getUseCompoundFile as long as mergePolicy is an instance of LogMergePolicy. Otherwise an IllegalArgumentException is thrown.

Public property Verbose
Returns true if verbosing is enabled (i.e., infoStream != null).
Public property WriteLockTimeout
Gets or sets allowed timeout when acquiring the write lock.
Back to Top
See Also
IndexWriter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter Constructor

IndexWriter Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | IndexWriter(Directory, Analyzer, IndexWriter MaxFieldLength) | Constructs an IndexWriter for the index in d, first creating it if it does not already exist.
Public method | IndexWriter(Directory, Analyzer, IndexDeletionPolicy, IndexWriter MaxFieldLength) | Expert: constructs an IndexWriter with a custom IndexDeletionPolicy , for the index in d, first creating it if it does not already exist. Text will be analyzed with a.
Public method | IndexWriter(Directory, Analyzer, Boolean, IndexWriter MaxFieldLength) | Constructs an IndexWriter for the index in d. Text will be analyzed with a. If create is true, then a new, empty index will be created in d, replacing the index already there, if any.
Public method | IndexWriter(Directory, Analyzer, IndexDeletionPolicy, IndexWriter MaxFieldLength, IndexCommit) | Expert: constructs an IndexWriter on specific commit point, with a custom IndexDeletionPolicy, for the index in d. Text will be analyzed with a. This is only meaningful if you've used a IndexDeletionPolicy in that past that keeps more than just the last commit. This operation is similar to Rollback , except that method can only rollback what's been done with the current instance of IndexWriter since its last commit, whereas this method can rollback to an arbitrary commit point from the past, assuming the IndexDeletionPolicy has preserved past commits.
Public method | IndexWriter(Directory, Analyzer, Boolean, IndexDeletionPolicy, IndexWriter MaxFieldLength) | Expert: constructs an IndexWriter with a custom IndexDeletionPolicy , for the index in d. Text will be analyzed with a. If create is true, then a new, empty index will be created in d, replacing the index already there, if any.
Back to Top
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter Constructor (Directory, Analyzer, IndexWriter.MaxFieldLength)

IndexWriter Constructor (Directory, Analyzer, IndexWriter MaxFieldLength) Lucene.Net Class Library
Constructs an IndexWriter for the index in d, first creating it if it does not already exist.
has this index open (write.lock could not be obtained)
read/written to or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexWriter(
    Directory d,
    Analyzer a,
    IndexWriter..::..MaxFieldLength mfl
)
public IndexWriter(
    Directory d,
    Analyzer a,
    IndexWriter..::..MaxFieldLength mfl
)
Public Sub New ( _
    d As Directory, _
    a As Analyzer, _
    mfl As IndexWriter..::..MaxFieldLength _
)
Public Sub New ( _
    d As Directory, _
    a As Analyzer, _
    mfl As IndexWriter..::..MaxFieldLength _
)
public:
IndexWriter(
    Directory^ d,
    Analyzer^ a,
    IndexWriter..::..MaxFieldLength^ mfl
)
public:
IndexWriter(
    Directory^ d,
    Analyzer^ a,
    IndexWriter..::..MaxFieldLength^ mfl
)
Parameters
d
Type: Lucene.Net.Store Directory
the index directory

a
Type: Lucene.Net.Analysis Analyzer
the analyzer to use

mfl
Type: Lucene.Net.Index IndexWriter MaxFieldLength
Maximum field length in number of terms/tokens: LIMITED, UNLIMITED, or user-specified
            via the MaxFieldLength constructor.

See Also
IndexWriter Class
IndexWriter Members
IndexWriter Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter Constructor (Directory, Analyzer, IndexDeletionPolicy, IndexWriter.MaxFieldLength)

IndexWriter Constructor (Directory, Analyzer, IndexDeletionPolicy, IndexWriter MaxFieldLength) Lucene.Net Class Library
Expert: constructs an IndexWriter with a custom IndexDeletionPolicy , for the index in d, first creating it if it does not already exist. Text will be analyzed with a.
has this index open (write.lock could not be obtained)
read/written to or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexWriter(
    Directory d,
    Analyzer a,
    IndexDeletionPolicy deletionPolicy,
    IndexWriter..::..MaxFieldLength mfl
)
public IndexWriter(
    Directory d,
    Analyzer a,
    IndexDeletionPolicy deletionPolicy,
    IndexWriter..::..MaxFieldLength mfl
)
Public Sub New ( _
    d As Directory, _
    a As Analyzer, _
    deletionPolicy As IndexDeletionPolicy, _
    mfl As IndexWriter..::..MaxFieldLength _
)
Public Sub New ( _
    d As Directory, _
    a As Analyzer, _
    deletionPolicy As IndexDeletionPolicy, _
    mfl As IndexWriter..::..MaxFieldLength _
)
public:
IndexWriter(
    Directory^ d,
    Analyzer^ a,
    IndexDeletionPolicy^ deletionPolicy,
    IndexWriter..::..MaxFieldLength^ mfl
)
public:
IndexWriter(
    Directory^ d,
    Analyzer^ a,
    IndexDeletionPolicy^ deletionPolicy,
    IndexWriter..::..MaxFieldLength^ mfl
)
Parameters
d
Type: Lucene.Net.Store Directory
the index directory

a
Type: Lucene.Net.Analysis Analyzer
the analyzer to use

deletionPolicy
Type: Lucene.Net.Index IndexDeletionPolicy
see above
mfl
Type: Lucene.Net.Index IndexWriter MaxFieldLength
whether or not to limit field lengths

See Also
IndexWriter Class
IndexWriter Members
IndexWriter Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter Constructor (Directory, Analyzer, Boolean, IndexWriter.MaxFieldLength)

IndexWriter Constructor (Directory, Analyzer, Boolean, IndexWriter MaxFieldLength) Lucene.Net Class Library
Constructs an IndexWriter for the index in d. Text will be analyzed with a. If create is true, then a new, empty index will be created in d, replacing the index already there, if any.
has this index open (write.lock could not be obtained)
if it does not exist and create is false or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexWriter(
    Directory d,
    Analyzer a,
    bool create,
    IndexWriter..::..MaxFieldLength mfl
)
public IndexWriter(
    Directory d,
    Analyzer a,
    bool create,
    IndexWriter..::..MaxFieldLength mfl
)
Public Sub New ( _
    d As Directory, _
    a As Analyzer, _
    create As Boolean, _
    mfl As IndexWriter..::..MaxFieldLength _
)
Public Sub New ( _
    d As Directory, _
    a As Analyzer, _
    create As Boolean, _
    mfl As IndexWriter..::..MaxFieldLength _
)
public:
IndexWriter(
    Directory^ d,
    Analyzer^ a,
    bool create,
    IndexWriter..::..MaxFieldLength^ mfl
)
public:
IndexWriter(
    Directory^ d,
    Analyzer^ a,
    bool create,
    IndexWriter..::..MaxFieldLength^ mfl
)
Parameters
d
Type: Lucene.Net.Store Directory
the index directory

a
Type: Lucene.Net.Analysis Analyzer
the analyzer to use

create
Type:   Online System Boolean
true to create the index or overwrite
            the existing one; false to append to the existing
            index

mfl
Type: Lucene.Net.Index IndexWriter MaxFieldLength
Maximum field length in number of terms/tokens: LIMITED, UNLIMITED, or user-specified
            via the MaxFieldLength constructor.

See Also
IndexWriter Class
IndexWriter Members
IndexWriter Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter Constructor (Directory, Analyzer, IndexDeletionPolicy, IndexWriter.MaxFieldLength, IndexCommit)

IndexWriter Constructor (Directory, Analyzer, IndexDeletionPolicy, IndexWriter MaxFieldLength, IndexCommit) Lucene.Net Class Library
Expert: constructs an IndexWriter on specific commit point, with a custom IndexDeletionPolicy, for the index in d. Text will be analyzed with a.

This is only meaningful if you've used a IndexDeletionPolicy in that past that keeps more than just the last commit.

This operation is similar to Rollback , except that method can only rollback what's been done with the current instance of IndexWriter since its last commit, whereas this method can rollback to an arbitrary commit point from the past, assuming the IndexDeletionPolicy has preserved past commits.
has this index open (write.lock could not be obtained)
if it does not exist and create is false or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexWriter(
    Directory d,
    Analyzer a,
    IndexDeletionPolicy deletionPolicy,
    IndexWriter..::..MaxFieldLength mfl,
    IndexCommit commit
)
public IndexWriter(
    Directory d,
    Analyzer a,
    IndexDeletionPolicy deletionPolicy,
    IndexWriter..::..MaxFieldLength mfl,
    IndexCommit commit
)
Public Sub New ( _
    d As Directory, _
    a As Analyzer, _
    deletionPolicy As IndexDeletionPolicy, _
    mfl As IndexWriter..::..MaxFieldLength, _
    commit As IndexCommit _
)
Public Sub New ( _
    d As Directory, _
    a As Analyzer, _
    deletionPolicy As IndexDeletionPolicy, _
    mfl As IndexWriter..::..MaxFieldLength, _
    commit As IndexCommit _
)
public:
IndexWriter(
    Directory^ d,
    Analyzer^ a,
    IndexDeletionPolicy^ deletionPolicy,
    IndexWriter..::..MaxFieldLength^ mfl,
    IndexCommit^ commit
)
public:
IndexWriter(
    Directory^ d,
    Analyzer^ a,
    IndexDeletionPolicy^ deletionPolicy,
    IndexWriter..::..MaxFieldLength^ mfl,
    IndexCommit^ commit
)
Parameters
d
Type: Lucene.Net.Store Directory
the index directory

a
Type: Lucene.Net.Analysis Analyzer
the analyzer to use

deletionPolicy
Type: Lucene.Net.Index IndexDeletionPolicy
see above
mfl
Type: Lucene.Net.Index IndexWriter MaxFieldLength
whether or not to limit field lengths, value is in number of terms/tokens.  See IndexWriter MaxFieldLength.

commit
Type: Lucene.Net.Index IndexCommit
which commit to open

See Also
IndexWriter Class
IndexWriter Members
IndexWriter Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter Constructor (Directory, Analyzer, Boolean, IndexDeletionPolicy, IndexWriter.MaxFieldLength)

IndexWriter Constructor (Directory, Analyzer, Boolean, IndexDeletionPolicy, IndexWriter MaxFieldLength) Lucene.Net Class Library
Expert: constructs an IndexWriter with a custom IndexDeletionPolicy , for the index in d. Text will be analyzed with a. If create is true, then a new, empty index will be created in d, replacing the index already there, if any.
has this index open (write.lock could not be obtained)
if it does not exist and create is false or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexWriter(
    Directory d,
    Analyzer a,
    bool create,
    IndexDeletionPolicy deletionPolicy,
    IndexWriter..::..MaxFieldLength mfl
)
public IndexWriter(
    Directory d,
    Analyzer a,
    bool create,
    IndexDeletionPolicy deletionPolicy,
    IndexWriter..::..MaxFieldLength mfl
)
Public Sub New ( _
    d As Directory, _
    a As Analyzer, _
    create As Boolean, _
    deletionPolicy As IndexDeletionPolicy, _
    mfl As IndexWriter..::..MaxFieldLength _
)
Public Sub New ( _
    d As Directory, _
    a As Analyzer, _
    create As Boolean, _
    deletionPolicy As IndexDeletionPolicy, _
    mfl As IndexWriter..::..MaxFieldLength _
)
public:
IndexWriter(
    Directory^ d,
    Analyzer^ a,
    bool create,
    IndexDeletionPolicy^ deletionPolicy,
    IndexWriter..::..MaxFieldLength^ mfl
)
public:
IndexWriter(
    Directory^ d,
    Analyzer^ a,
    bool create,
    IndexDeletionPolicy^ deletionPolicy,
    IndexWriter..::..MaxFieldLength^ mfl
)
Parameters
d
Type: Lucene.Net.Store Directory
the index directory

a
Type: Lucene.Net.Analysis Analyzer
the analyzer to use

create
Type:   Online System Boolean
true to create the index or overwrite
             the existing one; false to append to the existing
             index

deletionPolicy
Type: Lucene.Net.Index IndexDeletionPolicy
see above
mfl
Type: Lucene.Net.Index IndexWriter MaxFieldLength
IndexWriter MaxFieldLength, whether or not to limit field lengths.  Value is in number of terms/tokens

See Also
IndexWriter Class
IndexWriter Members
IndexWriter Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter Fields

IndexWriter Fields Lucene.Net Class Library
The IndexWriter type exposes the following members.
Fields
Name | Description
DEFAULT_MAX_BUFFERED_DELETE_TERMS | Disabled by default (because IndexWriter flushes by RAM usage by default). Change using SetMaxBufferedDeleteTerms(Int32).
DEFAULT_MAX_BUFFERED_DOCS | Disabled by default (because IndexWriter flushes by RAM usage by default). Change using SetMaxBufferedDocs(Int32).
DEFAULT_MAX_FIELD_LENGTH | Default value is 10,000. Change using SetMaxFieldLength(Int32).
DEFAULT_RAM_BUFFER_SIZE_MB | Default value is 16 MB (which means flush when buffered docs consume 16 MB RAM). Change using SetRAMBufferSizeMB(Double).
DEFAULT_TERM_INDEX_INTERVAL | Default value is 128. Change using TermIndexInterval.
DISABLE_AUTO_FLUSH | Value to denote a flush trigger is disabled
MAX_TERM_LENGTH | Absolute hard maximum length for a term. If a term arrives from the analyzer longer than this length, it is skipped and a message is printed to infoStream, if set (see SetInfoStream(StreamWriter)).
WRITE_LOCK_NAME | Name of the write lock in the index.
WRITE_LOCK_TIMEOUT | Default value for the write lock timeout (1,000).
Back to Top
See Also
IndexWriter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_MAX_BUFFERED_DELETE_TERMS Field

IndexWriter DEFAULT_MAX_BUFFERED_DELETE_TERMS Field Lucene.Net Class Library
Disabled by default (because IndexWriter flushes by RAM usage by default). Change using SetMaxBufferedDeleteTerms(Int32).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly int DEFAULT_MAX_BUFFERED_DELETE_TERMS
public static readonly int DEFAULT_MAX_BUFFERED_DELETE_TERMS
Public Shared ReadOnly DEFAULT_MAX_BUFFERED_DELETE_TERMS As Integer
Public Shared ReadOnly DEFAULT_MAX_BUFFERED_DELETE_TERMS As Integer
public:
static initonly int DEFAULT_MAX_BUFFERED_DELETE_TERMS
public:
static initonly int DEFAULT_MAX_BUFFERED_DELETE_TERMS
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_MAX_BUFFERED_DOCS Field

IndexWriter DEFAULT_MAX_BUFFERED_DOCS Field Lucene.Net Class Library
Disabled by default (because IndexWriter flushes by RAM usage by default). Change using SetMaxBufferedDocs(Int32).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly int DEFAULT_MAX_BUFFERED_DOCS
public static readonly int DEFAULT_MAX_BUFFERED_DOCS
Public Shared ReadOnly DEFAULT_MAX_BUFFERED_DOCS As Integer
Public Shared ReadOnly DEFAULT_MAX_BUFFERED_DOCS As Integer
public:
static initonly int DEFAULT_MAX_BUFFERED_DOCS
public:
static initonly int DEFAULT_MAX_BUFFERED_DOCS
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_MAX_FIELD_LENGTH Field

IndexWriter DEFAULT_MAX_FIELD_LENGTH Field Lucene.Net Class Library
Default value is 10,000. Change using SetMaxFieldLength(Int32).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_MAX_FIELD_LENGTH
public const int DEFAULT_MAX_FIELD_LENGTH
Public Const DEFAULT_MAX_FIELD_LENGTH As Integer
Public Const DEFAULT_MAX_FIELD_LENGTH As Integer
public:
literal int DEFAULT_MAX_FIELD_LENGTH
public:
literal int DEFAULT_MAX_FIELD_LENGTH
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_RAM_BUFFER_SIZE_MB Field

IndexWriter DEFAULT_RAM_BUFFER_SIZE_MB Field Lucene.Net Class Library
Default value is 16 MB (which means flush when buffered docs consume 16 MB RAM). Change using SetRAMBufferSizeMB(Double).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double DEFAULT_RAM_BUFFER_SIZE_MB
public const double DEFAULT_RAM_BUFFER_SIZE_MB
Public Const DEFAULT_RAM_BUFFER_SIZE_MB As Double
Public Const DEFAULT_RAM_BUFFER_SIZE_MB As Double
public:
literal double DEFAULT_RAM_BUFFER_SIZE_MB
public:
literal double DEFAULT_RAM_BUFFER_SIZE_MB
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_TERM_INDEX_INTERVAL Field

IndexWriter DEFAULT_TERM_INDEX_INTERVAL Field Lucene.Net Class Library
Default value is 128. Change using TermIndexInterval.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_TERM_INDEX_INTERVAL
public const int DEFAULT_TERM_INDEX_INTERVAL
Public Const DEFAULT_TERM_INDEX_INTERVAL As Integer
Public Const DEFAULT_TERM_INDEX_INTERVAL As Integer
public:
literal int DEFAULT_TERM_INDEX_INTERVAL
public:
literal int DEFAULT_TERM_INDEX_INTERVAL
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DISABLE_AUTO_FLUSH Field

IndexWriter DISABLE_AUTO_FLUSH Field Lucene.Net Class Library
Value to denote a flush trigger is disabled

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DISABLE_AUTO_FLUSH
public const int DISABLE_AUTO_FLUSH
Public Const DISABLE_AUTO_FLUSH As Integer
Public Const DISABLE_AUTO_FLUSH As Integer
public:
literal int DISABLE_AUTO_FLUSH
public:
literal int DISABLE_AUTO_FLUSH
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MAX_TERM_LENGTH Field

IndexWriter MAX_TERM_LENGTH Field Lucene.Net Class Library
Absolute hard maximum length for a term. If a term arrives from the analyzer longer than this length, it is skipped and a message is printed to infoStream, if set (see SetInfoStream(StreamWriter)).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly int MAX_TERM_LENGTH
public static readonly int MAX_TERM_LENGTH
Public Shared ReadOnly MAX_TERM_LENGTH As Integer
Public Shared ReadOnly MAX_TERM_LENGTH As Integer
public:
static initonly int MAX_TERM_LENGTH
public:
static initonly int MAX_TERM_LENGTH
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WRITE_LOCK_NAME Field

IndexWriter WRITE_LOCK_NAME Field Lucene.Net Class Library
Name of the write lock in the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string WRITE_LOCK_NAME
public const string WRITE_LOCK_NAME
Public Const WRITE_LOCK_NAME As String
Public Const WRITE_LOCK_NAME As String
public:
literal String^ WRITE_LOCK_NAME
public:
literal String^ WRITE_LOCK_NAME
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WRITE_LOCK_TIMEOUT Field

IndexWriter WRITE_LOCK_TIMEOUT Field Lucene.Net Class Library
Default value for the write lock timeout (1,000).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long WRITE_LOCK_TIMEOUT
public static long WRITE_LOCK_TIMEOUT
Public Shared WRITE_LOCK_TIMEOUT As Long
Public Shared WRITE_LOCK_TIMEOUT As Long
public:
static long long WRITE_LOCK_TIMEOUT
public:
static long long WRITE_LOCK_TIMEOUT
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
IndexWriter DefaultWriteLockTimeout
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter Methods

IndexWriter Methods Lucene.Net Class Library
The IndexWriter type exposes the following members.
Methods
Name | Description
Public method AddDocument(Document)
Adds a document to this index. If the document contains more than SetMaxFieldLength(Int32) terms for a given field, the remainder are discarded.

Note that if an Exception is hit (for example disk full) then the index will be consistent, but this document may not have been added. Furthermore, it's possible the index will have one segment in non-compound format even when using compound files (when a merge has partially succeeded).

This method periodically flushes pending documents to the Directory (see above), and also periodically triggers segment merges in the index according to the MergePolicy in use.

Merges temporarily consume space in the directory. The amount of space required is up to 1X the size of all segments being merged, when no readers/searchers are open against the index, and up to 2X the size of all segments being merged when readers/searchers are open against the index (see Optimize for details). The sequence of primitive merge operations performed is governed by the merge policy.

Note that each term in the document can be no longer than 16383 characters, otherwise an IllegalArgumentException will be thrown.

Note that it's possible to create an invalid Unicode string in java if a UTF16 surrogate pair is malformed. In this case, the invalid characters are silently replaced with the Unicode replacement character U+FFFD.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method AddDocument(Document, Analyzer)
Adds a document to this index, using the provided analyzer instead of the value of Analyzer. If the document contains more than SetMaxFieldLength(Int32) terms for a given field, the remainder are discarded.

See AddDocument(Document) for details on index and IndexWriter state after an Exception, and flushing/merging temporary free space requirements.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method AddIndexes
Merges the provided indexes into this index.

After this completes, the index is optimized.

The provided IndexReaders are not closed.

NOTE: while this is running, any attempts to add or delete documents (with another thread) will be paused until this method completes.

See AddIndexesNoOptimize( Directory ) for details on transactional semantics, temporary free space required in the Directory, and non-CFS segments on an Exception.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method AddIndexesNoOptimize
Merges all segments from an array of indexes into this index.

This may be used to parallelize batch indexing. A large document collection can be broken into sub-collections. Each sub-collection can be indexed in parallel, on a different thread, process or machine. The complete index can then be created by merging sub-collection indexes with this method.

NOTE: the index in each Directory must not be changed (opened by a writer) while this method is running. This method does not acquire a write lock in each input Directory, so it is up to the caller to enforce this.

NOTE: while this is running, any attempts to add or delete documents (with another thread) will be paused until this method completes.

This method is transactional in how Exceptions are handled: it does not commit a new segments_N file until all indexes are added. This means if an Exception occurs (for example disk full), then either no indexes will have been added or they all will have been.

Note that this requires temporary free space in the Directory up to 2X the sum of all input indexes (including the starting index). If readers/searchers are open against the starting index, then temporary free space required will be higher by the size of the starting index (see Optimize for details).

Once this completes, the final size of the index will be less than the sum of all input index sizes (including the starting index). It could be quite a bit smaller (if there were many pending deletes) or just slightly smaller.

This requires this index not be among those to be added.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Close Obsolete.
Commits all changes to an index and closes all associated files. Note that this may be a costly operation, so, try to re-use a single writer instead of closing and opening a new one. See Commit for caveats about write caching done by some IO devices.

If an Exception is hit during close, eg due to disk full or some other reason, then both the on-disk index and the internal state of the IndexWriter instance will be consistent. However, the close will not be complete even though part of it (flushing buffered documents) may have succeeded, so the write lock will still be held.

If you can correct the underlying cause (eg free up some disk space) then you can call close() again. Failing that, if you want to force the write lock to be released (dangerous, because you may then lose buffered docs in the IndexWriter instance) then you can do something like this:

View Colorized Copy to Clipboard Print
try {
    writer.close();
} finally {
    if (IndexWriter.isLocked(directory)) {
        IndexWriter.unlock(directory);
    }
}
try {
    writer.close();
} finally {
    if (IndexWriter.isLocked(directory)) {
        IndexWriter.unlock(directory);
    }
}
after which, you must be certain not to use the writer instance anymore.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

Public method Close(Boolean) Obsolete.
Closes the index with or without waiting for currently running merges to finish. This is only meaningful when using a MergeScheduler that runs merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

NOTE: it is dangerous to always call close(false), especially when IndexWriter is not open for very long, because this can result in "merge starvation" whereby long merges will never have a chance to finish. This will cause too many segments in your index over time.

Public method Commit

Commits all pending changes (added & deleted documents, optimizations, segment merges, added indexes, etc.) to the index, and syncs all referenced index files, such that a reader will see the changes and the index updates will survive an OS or machine crash or power loss. Note that this does not wait for any running background merges to finish. This may be a costly operation, so you should test the cost in your application and do it only when really necessary.

Note that this operation calls Directory.sync on the index files. That call should not return until the file contents & metadata are on stable storage. For FSDirectory, this calls the OS's fsync. But, beware: some hardware devices may in fact cache writes even during fsync, and return before the bits are actually on stable storage, to give the appearance of faster performance. If you have such a device, and it does not have a battery backup (for example) then on power loss it may still lose data. Lucene cannot guarantee consistency on such devices.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Commit(IDictionary String, String )
Commits all changes to the index, specifying a commitUserData Map (String -> String). This just calls PrepareCommit(IDictionary String, String ) (if you didn't already call it) and then FinishCommit .

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteAll
Delete all documents in the index.

This method will drop all buffered documents and will remove all segments from the index. This change will not be visible until a Commit has been called. This method can be rolled back using Rollback .

NOTE: this method is much faster than using deleteDocuments( new MatchAllDocsQuery() ).

NOTE: this method will forcefully abort all merges in progress. If other threads are running Optimize or any of the addIndexes methods, they will receive MergePolicy MergeAbortedExceptions.
Public method DeleteDocuments(Query)
Deletes the document(s) matching the provided query.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteDocuments( Query )
Deletes the document(s) matching any of the provided queries. All deletes are flushed at the same time.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteDocuments(Term)
Deletes the document(s) containing term.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteDocuments( Term )
Deletes the document(s) containing any of the terms. All deletes are flushed at the same time.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Dispose
Commits all changes to an index and closes all associated files. Note that this may be a costly operation, so, try to re-use a single writer instead of closing and opening a new one. See Commit for caveats about write caching done by some IO devices.

If an Exception is hit during close, eg due to disk full or some other reason, then both the on-disk index and the internal state of the IndexWriter instance will be consistent. However, the close will not be complete even though part of it (flushing buffered documents) may have succeeded, so the write lock will still be held.

If you can correct the underlying cause (eg free up some disk space) then you can call close() again. Failing that, if you want to force the write lock to be released (dangerous, because you may then lose buffered docs in the IndexWriter instance) then you can do something like this:

View Colorized Copy to Clipboard Print
try {
    writer.close();
} finally {
    if (IndexWriter.isLocked(directory)) {
        IndexWriter.unlock(directory);
    }
}
try {
    writer.close();
} finally {
    if (IndexWriter.isLocked(directory)) {
        IndexWriter.unlock(directory);
    }
}
after which, you must be certain not to use the writer instance anymore.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

Public method Dispose(Boolean)
Closes the index with or without waiting for currently running merges to finish. This is only meaningful when using a MergeScheduler that runs merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

NOTE: it is dangerous to always call close(false), especially when IndexWriter is not open for very long, because this can result in "merge starvation" whereby long merges will never have a chance to finish. This will cause too many segments in your index over time.

Protected method | Dispose(Boolean, Boolean)
Protected method DoAfterFlush
A hook for extending classes to execute operations after pending added and deleted documents have been flushed to the Directory but before the change is committed (new segments_N file written).
Protected method DoBeforeFlush
A hook for extending classes to execute operations before pending added and deleted documents are flushed to the Directory.
Protected method | EnsureOpen
Protected method EnsureOpen(Boolean)
Used internally to throw an AlreadyClosedException if this IndexWriter has been closed.
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Public method ExpungeDeletes
Expunges all deletes from the index. When an index has many document deletions (or updates to existing documents), it's best to either call optimize or expungeDeletes to remove all unused data in the index associated with the deleted documents. To see how many deletions you have pending in your index, call NumDeletedDocs This saves disk space and memory usage while searching. expungeDeletes should be somewhat faster than optimize since it does not insist on reducing the index to a single segment (though, this depends on the MergePolicy; see FindMergesToExpungeDeletes(SegmentInfos).). Note that this call does not first commit any buffered documents, so you must do so yourself if necessary. See also

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method ExpungeDeletes(Boolean)
Just like ExpungeDeletes , except you can specify whether the call should block until the operation completes. This is only meaningful with a MergeScheduler that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Flush
Flush all in-memory buffered udpates (adds and deletes) to the Directory.
Public method | GetDocCount
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method GetMaxBufferedDeleteTerms
Returns the number of buffered deleted terms that will trigger a flush if enabled.
Public method GetMaxBufferedDocs
Returns the number of buffered added documents that will trigger a flush if enabled.
Public method GetMaxFieldLength
Returns the maximum number of terms that will be indexed for a single field in a document.
Public method GetRAMBufferSizeMB
Returns the value set by SetRAMBufferSizeMB(Double) if enabled.
Public method GetReader
Expert: returns a readonly reader, covering all committed as well as un-committed changes to the index. This provides "near real-time" searching, in that changes made during an IndexWriter session can be quickly made available for searching without closing the writer nor calling Commit .

Note that this is functionally equivalent to calling {#commit} and then using Open(Directory, Boolean) to open a new reader. But the turarnound time of this method should be faster since it avoids the potentially costly Commit .

You must close the IndexReader returned by this method once you are done using it.

It's near real-time because there is no hard guarantee on how quickly you can get a new reader after making changes with IndexWriter. You'll have to experiment in your situation to determine if it's faster enough. As this is a new and experimental feature, please report back on your findings so we can learn, improve and iterate.

The resulting reader suppports Reopen , but that call will simply forward back to this method (though this may change in the future).

The very first time this method is called, this writer instance will make every effort to pool the readers that it opens for doing merges, applying deletes, etc. This means additional resources (RAM, file descriptors, CPU time) will be consumed.

For lower latency on reopening a reader, you should call MergedSegmentWarmer to call MergedSegmentWarmer to pre-warm a newly merged segment before it's committed to the index. This is important for minimizing index-to-search delay after a large merge.

If an addIndexes* call is running in another thread, then this reader will only search those segments from the foreign index that have been successfully copied over, so far

.

NOTE: Once the writer is closed, any outstanding readers may continue to be used. However, if you attempt to reopen any of those readers, you'll hit an AlreadyClosedException.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Public method GetReader(Int32)
Expert: like GetReader , except you can specify which termInfosIndexDivisor should be used for any newly opened readers.
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method | HasDeletions
IsLocked
Returns true iff the index in the named directory is currently locked.
Public method MaxDoc
Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), not counting deletions.
Public method MaybeMerge
Expert: asks the mergePolicy whether any merges are necessary now and if so, runs the requested merges and then iterate (test again if merges are needed) until no more merges are returned by the mergePolicy. Explicit calls to maybeMerge() are usually not necessary. The most common case is when merge policy parameters have changed.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method | Merge_ForNUnit
Public method Message
Prints a message to the infoStream (if non-null), prefixed with the identifying information for this writer and the thread that's calling it.
Public method | NewestSegment
Public method NumDeletedDocs
Obtain the number of deleted docs for a pooled reader. If the reader isn't being pooled, the segmentInfo's delCount is returned.
Public method NumDocs
Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), and including deletions. NOTE: buffered deletions are not counted. If you really need these to be counted you should call Commit first.
Public method NumRamDocs
Expert: Return the number of documents currently buffered in RAM.
Public method Optimize
Requests an "optimize" operation on an index, priming the index for the fastest available search. Traditionally this has meant merging all segments into a single segment as is done in the default merge policy, but individaul merge policies may implement optimize in different ways.

It is recommended that this method be called upon completion of indexing. In environments with frequent updates, optimize is best done during low volume times, if at all.

See http://www.gossamer-threads.com/lists/lucene/java-dev/47895 for more discussion.

Note that optimize requires 2X the index size free space in your Directory (3X if you're using compound file format). For example, if your index size is 10 MB then you need 20 MB free for optimize to complete (30 MB if you're using compound fiel format).

If some but not all readers re-open while an optimize is underway, this will cause > 2X temporary space to be consumed as those new readers will then hold open the partially optimized segments at that time. It is best not to re-open readers while optimize is running.

The actual temporary usage could be much less than these figures (it depends on many factors).

In general, once the optimize completes, the total size of the index will be less than the size of the starting index. It could be quite a bit smaller (if there were many pending deletes) or just slightly smaller.

If an Exception is hit during optimize(), for example due to disk full, the index will not be corrupt and no documents will have been lost. However, it may have been partially optimized (some segments were merged but not all), and it's possible that one of the segments in the index will be in non-compound format even when using compound file format. This will occur when the Exception is hit during conversion of the segment into compound format.

This call will optimize those segments present in the index when the call started. If other threads are still adding documents and flushing segments, those newly created segments will not be optimized unless you call optimize again.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Boolean)
Just like Optimize , except you can specify whether the call should block until the optimize completes. This is only meaningful with a MergeScheduler that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Int32)
Optimize the index down to <= maxNumSegments. If maxNumSegments==1 then this is the same as Optimize .

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Int32, Boolean)
Just like Optimize(Int32), except you can specify whether the call should block until the optimize completes. This is only meaningful with a MergeScheduler that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method PrepareCommit
Expert: prepare for commit.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method RamSizeInBytes
Expert: Return the total size of all index files currently cached in memory. Useful for size management with flushRamDocs()
Public method Rollback
Close the IndexWriter without committing any changes that have occurred since the last commit (or since it was opened, if commit hasn't been called). This removes any temporary files that had been created, after which the state of the index will be the same as it was when commit() was last called or when this writer was first opened. This also clears a previous call to PrepareCommit .
Public method | SegString
Public method SetInfoStream
If non-null, information about merges, deletes and a message when maxFieldLength is reached will be printed to this.
Public method SetMaxBufferedDeleteTerms

Determines the minimal number of delete terms required before the buffered in-memory delete terms are applied and flushed. If there are documents buffered in memory at the time, they are merged and a new segment is created.

Disabled by default (writer flushes by RAM usage).

Public method SetMaxBufferedDocs
Determines the minimal number of documents required before the buffered in-memory documents are flushed as a new Segment. Large values generally gives faster indexing.

When this is set, the writer will flush every maxBufferedDocs added documents. Pass in DISABLE_AUTO_FLUSH to prevent triggering a flush due to number of buffered documents. Note that if flushing by RAM usage is also enabled, then the flush will be triggered by whichever comes first.

Disabled by default (writer flushes by RAM usage).

Public method SetMaxFieldLength
The maximum number of terms that will be indexed for a single field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory. This setting refers to the number of running terms, not to the number of different terms.

Note: this silently truncates large documents, excluding from the index all terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accomodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an OutOfMemoryError.

By default, no more than DEFAULT_MAX_FIELD_LENGTH terms will be indexed for a field.
Public method SetMergePolicy
Expert: set the merge policy used by this writer.
Public method SetMergeScheduler
Expert: set the merge scheduler used by this writer.
Public method SetRAMBufferSizeMB
Determines the amount of RAM that may be used for buffering added documents and deletions before they are flushed to the Directory. Generally for faster indexing performance it's best to flush by RAM usage instead of document count and use as large a RAM buffer as you can.

When this is set, the writer will flush whenever buffered documents and deletions use this much RAM. Pass in DISABLE_AUTO_FLUSH to prevent triggering a flush due to RAM usage. Note that if flushing by document count is also enabled, then the flush will be triggered by whichever comes first.

NOTE: the account of RAM usage for pending deletions is only approximate. Specifically, if you delete by Query, Lucene currently has no way to measure the RAM usage if individual Queries so the accounting will under-estimate and you should compensate by either calling commit() periodically yourself, or by using SetMaxBufferedDeleteTerms(Int32) to flush by count instead of RAM usage (each buffered delete Query counts as one).

NOTE: because IndexWriter uses ints when managing its internal storage, the absolute maximum value for this setting is somewhat less than 2048 MB. The precise limit depends on various factors, such as how large your documents are, how many fields have norms, etc., so it's best to set this value comfortably under 2048.

The default value is DEFAULT_RAM_BUFFER_SIZE_MB.

Public method SetSimilarity
Expert: Set the Similarity implementation used by this IndexWriter.
Public method | TestPoint
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Unlock
Forcibly unlocks the index in the named directory.

Caution: this should only be used by failure recovery code, when it is known that no other process nor thread is in fact currently accessing this index.
Public method UpdateDocument(Term, Document)
Updates a document by first deleting the document(s) containing term and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method UpdateDocument(Term, Document, Analyzer)
Updates a document by first deleting the document(s) containing term and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method WaitForMerges
Wait for any currently outstanding merges to finish.

It is guaranteed that any merges started prior to calling this method will have completed once this method completes.

Back to Top
See Also
IndexWriter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddDocument Method

IndexWriter AddDocument Method Lucene.Net Class Library
Overload List
Name Description
Public method AddDocument(Document)
Adds a document to this index. If the document contains more than SetMaxFieldLength(Int32) terms for a given field, the remainder are discarded.

Note that if an Exception is hit (for example disk full) then the index will be consistent, but this document may not have been added. Furthermore, it's possible the index will have one segment in non-compound format even when using compound files (when a merge has partially succeeded).

This method periodically flushes pending documents to the Directory (see above), and also periodically triggers segment merges in the index according to the MergePolicy in use.

Merges temporarily consume space in the directory. The amount of space required is up to 1X the size of all segments being merged, when no readers/searchers are open against the index, and up to 2X the size of all segments being merged when readers/searchers are open against the index (see Optimize for details). The sequence of primitive merge operations performed is governed by the merge policy.

Note that each term in the document can be no longer than 16383 characters, otherwise an IllegalArgumentException will be thrown.

Note that it's possible to create an invalid Unicode string in java if a UTF16 surrogate pair is malformed. In this case, the invalid characters are silently replaced with the Unicode replacement character U+FFFD.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method AddDocument(Document, Analyzer)
Adds a document to this index, using the provided analyzer instead of the value of Analyzer. If the document contains more than SetMaxFieldLength(Int32) terms for a given field, the remainder are discarded.

See AddDocument(Document) for details on index and IndexWriter state after an Exception, and flushing/merging temporary free space requirements.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Back to Top
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddDocument Method (Document)

IndexWriter AddDocument Method (Document) Lucene.Net Class Library
Adds a document to this index. If the document contains more than SetMaxFieldLength(Int32) terms for a given field, the remainder are discarded.

Note that if an Exception is hit (for example disk full) then the index will be consistent, but this document may not have been added. Furthermore, it's possible the index will have one segment in non-compound format even when using compound files (when a merge has partially succeeded).

This method periodically flushes pending documents to the Directory (see above), and also periodically triggers segment merges in the index according to the MergePolicy in use.

Merges temporarily consume space in the directory. The amount of space required is up to 1X the size of all segments being merged, when no readers/searchers are open against the index, and up to 2X the size of all segments being merged when readers/searchers are open against the index (see Optimize for details). The sequence of primitive merge operations performed is governed by the merge policy.

Note that each term in the document can be no longer than 16383 characters, otherwise an IllegalArgumentException will be thrown.

Note that it's possible to create an invalid Unicode string in java if a UTF16 surrogate pair is malformed. In this case, the invalid characters are silently replaced with the Unicode replacement character U+FFFD.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AddDocument(
    Document doc
)
public virtual void AddDocument(
    Document doc
)
Public Overridable Sub AddDocument ( _
    doc As Document _
)
Public Overridable Sub AddDocument ( _
    doc As Document _
)
public:
virtual void AddDocument(
    Document^ doc
)
public:
virtual void AddDocument(
    Document^ doc
)
Parameters
doc
Type: Lucene.Net.Documents Document
See Also
IndexWriter Class
IndexWriter Members
AddDocument Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddDocument Method (Document, Analyzer)

IndexWriter AddDocument Method (Document, Analyzer) Lucene.Net Class Library
Adds a document to this index, using the provided analyzer instead of the value of Analyzer. If the document contains more than SetMaxFieldLength(Int32) terms for a given field, the remainder are discarded.

See AddDocument(Document) for details on index and IndexWriter state after an Exception, and flushing/merging temporary free space requirements.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AddDocument(
    Document doc,
    Analyzer analyzer
)
public virtual void AddDocument(
    Document doc,
    Analyzer analyzer
)
Public Overridable Sub AddDocument ( _
    doc As Document, _
    analyzer As Analyzer _
)
Public Overridable Sub AddDocument ( _
    doc As Document, _
    analyzer As Analyzer _
)
public:
virtual void AddDocument(
    Document^ doc,
    Analyzer^ analyzer
)
public:
virtual void AddDocument(
    Document^ doc,
    Analyzer^ analyzer
)
Parameters
doc
Type: Lucene.Net.Documents Document
analyzer
Type: Lucene.Net.Analysis Analyzer
See Also
IndexWriter Class
IndexWriter Members
AddDocument Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddIndexes Method

IndexWriter AddIndexes Method Lucene.Net Class Library
Merges the provided indexes into this index.

After this completes, the index is optimized.

The provided IndexReaders are not closed.

NOTE: while this is running, any attempts to add or delete documents (with another thread) will be paused until this method completes.

See AddIndexesNoOptimize( Directory ) for details on transactional semantics, temporary free space required in the Directory, and non-CFS segments on an Exception.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AddIndexes(
    params IndexReader[] readers
)
public virtual void AddIndexes(
    params IndexReader[] readers
)
Public Overridable Sub AddIndexes ( _
    ParamArray readers As IndexReader() _
)
Public Overridable Sub AddIndexes ( _
    ParamArray readers As IndexReader() _
)
public:
virtual void AddIndexes(
    ... array<IndexReader^>^ readers
)
public:
virtual void AddIndexes(
    ... array<IndexReader^>^ readers
)
Parameters
readers
Type:  Lucene.Net.Index IndexReader
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddIndexesNoOptimize Method

IndexWriter AddIndexesNoOptimize Method Lucene.Net Class Library
Merges all segments from an array of indexes into this index.

This may be used to parallelize batch indexing. A large document collection can be broken into sub-collections. Each sub-collection can be indexed in parallel, on a different thread, process or machine. The complete index can then be created by merging sub-collection indexes with this method.

NOTE: the index in each Directory must not be changed (opened by a writer) while this method is running. This method does not acquire a write lock in each input Directory, so it is up to the caller to enforce this.

NOTE: while this is running, any attempts to add or delete documents (with another thread) will be paused until this method completes.

This method is transactional in how Exceptions are handled: it does not commit a new segments_N file until all indexes are added. This means if an Exception occurs (for example disk full), then either no indexes will have been added or they all will have been.

Note that this requires temporary free space in the Directory up to 2X the sum of all input indexes (including the starting index). If readers/searchers are open against the starting index, then temporary free space required will be higher by the size of the starting index (see Optimize for details).

Once this completes, the final size of the index will be less than the sum of all input index sizes (including the starting index). It could be quite a bit smaller (if there were many pending deletes) or just slightly smaller.

This requires this index not be among those to be added.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AddIndexesNoOptimize(
    params Directory[] dirs
)
public virtual void AddIndexesNoOptimize(
    params Directory[] dirs
)
Public Overridable Sub AddIndexesNoOptimize ( _
    ParamArray dirs As Directory() _
)
Public Overridable Sub AddIndexesNoOptimize ( _
    ParamArray dirs As Directory() _
)
public:
virtual void AddIndexesNoOptimize(
    ... array<Directory^>^ dirs
)
public:
virtual void AddIndexesNoOptimize(
    ... array<Directory^>^ dirs
)
Parameters
dirs
Type:  Lucene.Net.Store Directory
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

IndexWriter Close Method Lucene.Net Class Library
Overload List
Name Description
Public method Close Obsolete.
Commits all changes to an index and closes all associated files. Note that this may be a costly operation, so, try to re-use a single writer instead of closing and opening a new one. See Commit for caveats about write caching done by some IO devices.

If an Exception is hit during close, eg due to disk full or some other reason, then both the on-disk index and the internal state of the IndexWriter instance will be consistent. However, the close will not be complete even though part of it (flushing buffered documents) may have succeeded, so the write lock will still be held.

If you can correct the underlying cause (eg free up some disk space) then you can call close() again. Failing that, if you want to force the write lock to be released (dangerous, because you may then lose buffered docs in the IndexWriter instance) then you can do something like this:

View Colorized Copy to Clipboard Print
try {
    writer.close();
} finally {
    if (IndexWriter.isLocked(directory)) {
        IndexWriter.unlock(directory);
    }
}
try {
    writer.close();
} finally {
    if (IndexWriter.isLocked(directory)) {
        IndexWriter.unlock(directory);
    }
}
after which, you must be certain not to use the writer instance anymore.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

Public method Close(Boolean) Obsolete.
Closes the index with or without waiting for currently running merges to finish. This is only meaningful when using a MergeScheduler that runs merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

NOTE: it is dangerous to always call close(false), especially when IndexWriter is not open for very long, because this can result in "merge starvation" whereby long merges will never have a chance to finish. This will cause too many segments in your index over time.

Back to Top
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

IndexWriter Close Method Lucene.Net Class Library
Commits all changes to an index and closes all associated files. Note that this may be a costly operation, so, try to re-use a single writer instead of closing and opening a new one. See Commit for caveats about write caching done by some IO devices.

If an Exception is hit during close, eg due to disk full or some other reason, then both the on-disk index and the internal state of the IndexWriter instance will be consistent. However, the close will not be complete even though part of it (flushing buffered documents) may have succeeded, so the write lock will still be held.

If you can correct the underlying cause (eg free up some disk space) then you can call close() again. Failing that, if you want to force the write lock to be released (dangerous, because you may then lose buffered docs in the IndexWriter instance) then you can do something like this:

View Colorized Copy to Clipboard Print
try {
    writer.close();
} finally {
    if (IndexWriter.isLocked(directory)) {
        IndexWriter.unlock(directory);
    }
}
try {
    writer.close();
} finally {
    if (IndexWriter.isLocked(directory)) {
        IndexWriter.unlock(directory);
    }
}
after which, you must be certain not to use the writer instance anymore.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
See Also
IndexWriter Class
IndexWriter Members
Close Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method (Boolean)

IndexWriter Close Method (Boolean) Lucene.Net Class Library
Closes the index with or without waiting for currently running merges to finish. This is only meaningful when using a MergeScheduler that runs merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

NOTE: it is dangerous to always call close(false), especially when IndexWriter is not open for very long, because this can result in "merge starvation" whereby long merges will never have a chance to finish. This will cause too many segments in your index over time.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Dispose(bool) instead")]
public virtual void Close(
    bool waitForMerges
)
[ObsoleteAttribute("Use Dispose(bool) instead")]
public virtual void Close(
    bool waitForMerges
)
<ObsoleteAttribute("Use Dispose(bool) instead")> _
Public Overridable Sub Close ( _
    waitForMerges As Boolean _
)
<ObsoleteAttribute("Use Dispose(bool) instead")> _
Public Overridable Sub Close ( _
    waitForMerges As Boolean _
)
public:
[ObsoleteAttribute(L"Use Dispose(bool) instead")]
virtual void Close(
    bool waitForMerges
)
public:
[ObsoleteAttribute(L"Use Dispose(bool) instead")]
virtual void Close(
    bool waitForMerges
)
Parameters
waitForMerges
Type:   Online System Boolean
if true, this call will block
            until all merges complete; else, it will ask all
            running merges to abort, wait until those merges have
            finished (which should be at most a few seconds), and
            then return.

See Also
IndexWriter Class
IndexWriter Members
Close Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Commit Method

IndexWriter Commit Method Lucene.Net Class Library
Overload List
Name Description
Public method Commit

Commits all pending changes (added & deleted documents, optimizations, segment merges, added indexes, etc.) to the index, and syncs all referenced index files, such that a reader will see the changes and the index updates will survive an OS or machine crash or power loss. Note that this does not wait for any running background merges to finish. This may be a costly operation, so you should test the cost in your application and do it only when really necessary.

Note that this operation calls Directory.sync on the index files. That call should not return until the file contents & metadata are on stable storage. For FSDirectory, this calls the OS's fsync. But, beware: some hardware devices may in fact cache writes even during fsync, and return before the bits are actually on stable storage, to give the appearance of faster performance. If you have such a device, and it does not have a battery backup (for example) then on power loss it may still lose data. Lucene cannot guarantee consistency on such devices.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Commit(IDictionary String, String )
Commits all changes to the index, specifying a commitUserData Map (String -> String). This just calls PrepareCommit(IDictionary String, String ) (if you didn't already call it) and then FinishCommit .

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Back to Top
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Commit Method

IndexWriter Commit Method Lucene.Net Class Library

Commits all pending changes (added & deleted documents, optimizations, segment merges, added indexes, etc.) to the index, and syncs all referenced index files, such that a reader will see the changes and the index updates will survive an OS or machine crash or power loss. Note that this does not wait for any running background merges to finish. This may be a costly operation, so you should test the cost in your application and do it only when really necessary.

Note that this operation calls Directory.sync on the index files. That call should not return until the file contents & metadata are on stable storage. For FSDirectory, this calls the OS's fsync. But, beware: some hardware devices may in fact cache writes even during fsync, and return before the bits are actually on stable storage, to give the appearance of faster performance. If you have such a device, and it does not have a battery backup (for example) then on power loss it may still lose data. Lucene cannot guarantee consistency on such devices.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Commit()
public void Commit()
Public Sub Commit
Public Sub Commit
public:
void Commit()
public:
void Commit()
See Also
IndexWriter Class
IndexWriter Members
Commit Overload
Lucene.Net.Index Namespace
IndexWriter PrepareCommit
IndexWriter Commit(IDictionary String, String )
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Commit Method (IDictionary(String, String))

IndexWriter Commit Method (IDictionary String, String ) Lucene.Net Class Library
Commits all changes to the index, specifying a commitUserData Map (String -> String). This just calls PrepareCommit(IDictionary String, String ) (if you didn't already call it) and then FinishCommit .

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Commit(
    IDictionary<string, string> commitUserData
)
public void Commit(
    IDictionary<string, string> commitUserData
)
Public Sub Commit ( _
    commitUserData As IDictionary(Of String, String) _
)
Public Sub Commit ( _
    commitUserData As IDictionary(Of String, String) _
)
public:
void Commit(
    IDictionary<String^, String^>^ commitUserData
)
public:
void Commit(
    IDictionary<String^, String^>^ commitUserData
)
Parameters
commitUserData
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
See Also
IndexWriter Class
IndexWriter Members
Commit Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DeleteAll Method

IndexWriter DeleteAll Method Lucene.Net Class Library
Delete all documents in the index.

This method will drop all buffered documents and will remove all segments from the index. This change will not be visible until a Commit has been called. This method can be rolled back using Rollback .

NOTE: this method is much faster than using deleteDocuments( new MatchAllDocsQuery() ).

NOTE: this method will forcefully abort all merges in progress. If other threads are running Optimize or any of the addIndexes methods, they will receive MergePolicy MergeAbortedExceptions.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void DeleteAll()
public virtual void DeleteAll()
Public Overridable Sub DeleteAll
Public Overridable Sub DeleteAll
public:
virtual void DeleteAll()
public:
virtual void DeleteAll()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DeleteDocuments Method

IndexWriter DeleteDocuments Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | DeleteDocuments(Query) | Deletes the document(s) matching the provided query. NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.
Public method | DeleteDocuments( Query ) | Deletes the document(s) matching any of the provided queries. All deletes are flushed at the same time. NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.
Public method | DeleteDocuments(Term) | Deletes the document(s) containing term. NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.
Public method | DeleteDocuments( Term ) | Deletes the document(s) containing any of the terms. All deletes are flushed at the same time. NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.
Back to Top
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DeleteDocuments Method (Query)

IndexWriter DeleteDocuments Method (Query) Lucene.Net Class Library
Deletes the document(s) matching the provided query.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void DeleteDocuments(
    Query query
)
public virtual void DeleteDocuments(
    Query query
)
Public Overridable Sub DeleteDocuments ( _
    query As Query _
)
Public Overridable Sub DeleteDocuments ( _
    query As Query _
)
public:
virtual void DeleteDocuments(
    Query^ query
)
public:
virtual void DeleteDocuments(
    Query^ query
)
Parameters
query
Type: Lucene.Net.Search Query
the query to identify the documents to be deleted

See Also
IndexWriter Class
IndexWriter Members
DeleteDocuments Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DeleteDocuments Method (Query[])

IndexWriter DeleteDocuments Method ( Query ) Lucene.Net Class Library
Deletes the document(s) matching any of the provided queries. All deletes are flushed at the same time.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void DeleteDocuments(
    params Query[] queries
)
public virtual void DeleteDocuments(
    params Query[] queries
)
Public Overridable Sub DeleteDocuments ( _
    ParamArray queries As Query() _
)
Public Overridable Sub DeleteDocuments ( _
    ParamArray queries As Query() _
)
public:
virtual void DeleteDocuments(
    ... array<Query^>^ queries
)
public:
virtual void DeleteDocuments(
    ... array<Query^>^ queries
)
Parameters
queries
Type:  Lucene.Net.Search Query
array of queries to identify the documents
            to be deleted

See Also
IndexWriter Class
IndexWriter Members
DeleteDocuments Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DeleteDocuments Method (Term)

IndexWriter DeleteDocuments Method (Term) Lucene.Net Class Library
Deletes the document(s) containing term.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void DeleteDocuments(
    Term term
)
public virtual void DeleteDocuments(
    Term term
)
Public Overridable Sub DeleteDocuments ( _
    term As Term _
)
Public Overridable Sub DeleteDocuments ( _
    term As Term _
)
public:
virtual void DeleteDocuments(
    Term^ term
)
public:
virtual void DeleteDocuments(
    Term^ term
)
Parameters
term
Type: Lucene.Net.Index Term
the term to identify the documents to be deleted

See Also
IndexWriter Class
IndexWriter Members
DeleteDocuments Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DeleteDocuments Method (Term[])

IndexWriter DeleteDocuments Method ( Term ) Lucene.Net Class Library
Deletes the document(s) containing any of the terms. All deletes are flushed at the same time.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void DeleteDocuments(
    params Term[] terms
)
public virtual void DeleteDocuments(
    params Term[] terms
)
Public Overridable Sub DeleteDocuments ( _
    ParamArray terms As Term() _
)
Public Overridable Sub DeleteDocuments ( _
    ParamArray terms As Term() _
)
public:
virtual void DeleteDocuments(
    ... array<Term^>^ terms
)
public:
virtual void DeleteDocuments(
    ... array<Term^>^ terms
)
Parameters
terms
Type:  Lucene.Net.Index Term
array of terms to identify the documents
            to be deleted

See Also
IndexWriter Class
IndexWriter Members
DeleteDocuments Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

IndexWriter Dispose Method Lucene.Net Class Library
Overload List
Name | Description
Public method Dispose
Commits all changes to an index and closes all associated files. Note that this may be a costly operation, so, try to re-use a single writer instead of closing and opening a new one. See Commit for caveats about write caching done by some IO devices.

If an Exception is hit during close, eg due to disk full or some other reason, then both the on-disk index and the internal state of the IndexWriter instance will be consistent. However, the close will not be complete even though part of it (flushing buffered documents) may have succeeded, so the write lock will still be held.

If you can correct the underlying cause (eg free up some disk space) then you can call close() again. Failing that, if you want to force the write lock to be released (dangerous, because you may then lose buffered docs in the IndexWriter instance) then you can do something like this:

View Colorized Copy to Clipboard Print
try {
    writer.close();
} finally {
    if (IndexWriter.isLocked(directory)) {
        IndexWriter.unlock(directory);
    }
}
try {
    writer.close();
} finally {
    if (IndexWriter.isLocked(directory)) {
        IndexWriter.unlock(directory);
    }
}
after which, you must be certain not to use the writer instance anymore.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

Public method Dispose(Boolean)
Closes the index with or without waiting for currently running merges to finish. This is only meaningful when using a MergeScheduler that runs merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

NOTE: it is dangerous to always call close(false), especially when IndexWriter is not open for very long, because this can result in "merge starvation" whereby long merges will never have a chance to finish. This will cause too many segments in your index over time.

Protected method | Dispose(Boolean, Boolean)
Back to Top
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

IndexWriter Dispose Method Lucene.Net Class Library
Commits all changes to an index and closes all associated files. Note that this may be a costly operation, so, try to re-use a single writer instead of closing and opening a new one. See Commit for caveats about write caching done by some IO devices.

If an Exception is hit during close, eg due to disk full or some other reason, then both the on-disk index and the internal state of the IndexWriter instance will be consistent. However, the close will not be complete even though part of it (flushing buffered documents) may have succeeded, so the write lock will still be held.

If you can correct the underlying cause (eg free up some disk space) then you can call close() again. Failing that, if you want to force the write lock to be released (dangerous, because you may then lose buffered docs in the IndexWriter instance) then you can do something like this:

View Colorized Copy to Clipboard Print
try {
    writer.close();
} finally {
    if (IndexWriter.isLocked(directory)) {
        IndexWriter.unlock(directory);
    }
}
try {
    writer.close();
} finally {
    if (IndexWriter.isLocked(directory)) {
        IndexWriter.unlock(directory);
    }
}
after which, you must be certain not to use the writer instance anymore.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Dispose()
public virtual void Dispose()
Public Overridable Sub Dispose
Public Overridable Sub Dispose
public:
virtual void Dispose()
public:
virtual void Dispose()
Implements
  Online IDisposable Dispose
See Also
IndexWriter Class
IndexWriter Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

IndexWriter Dispose Method (Boolean) Lucene.Net Class Library
Closes the index with or without waiting for currently running merges to finish. This is only meaningful when using a MergeScheduler that runs merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

NOTE: it is dangerous to always call close(false), especially when IndexWriter is not open for very long, because this can result in "merge starvation" whereby long merges will never have a chance to finish. This will cause too many segments in your index over time.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Dispose(
    bool waitForMerges
)
public virtual void Dispose(
    bool waitForMerges
)
Public Overridable Sub Dispose ( _
    waitForMerges As Boolean _
)
Public Overridable Sub Dispose ( _
    waitForMerges As Boolean _
)
public:
virtual void Dispose(
    bool waitForMerges
)
public:
virtual void Dispose(
    bool waitForMerges
)
Parameters
waitForMerges
Type:   Online System Boolean
if true, this call will block
            until all merges complete; else, it will ask all
            running merges to abort, wait until those merges have
            finished (which should be at most a few seconds), and
            then return.

See Also
IndexWriter Class
IndexWriter Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean, Boolean)

IndexWriter Dispose Method (Boolean, Boolean) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void Dispose(
    bool disposing,
    bool waitForMerges
)
protected virtual void Dispose(
    bool disposing,
    bool waitForMerges
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean, _
    waitForMerges As Boolean _
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean, _
    waitForMerges As Boolean _
)
protected:
virtual void Dispose(
    bool disposing,
    bool waitForMerges
)
protected:
virtual void Dispose(
    bool disposing,
    bool waitForMerges
)
Parameters
disposing
Type:   Online System Boolean
waitForMerges
Type:   Online System Boolean
See Also
IndexWriter Class
IndexWriter Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoAfterFlush Method

IndexWriter DoAfterFlush Method Lucene.Net Class Library
A hook for extending classes to execute operations after pending added and deleted documents have been flushed to the Directory but before the change is committed (new segments_N file written).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoAfterFlush()
protected virtual void DoAfterFlush()
Protected Overridable Sub DoAfterFlush
Protected Overridable Sub DoAfterFlush
protected:
virtual void DoAfterFlush()
protected:
virtual void DoAfterFlush()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoBeforeFlush Method

IndexWriter DoBeforeFlush Method Lucene.Net Class Library
A hook for extending classes to execute operations before pending added and deleted documents are flushed to the Directory.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoBeforeFlush()
protected virtual void DoBeforeFlush()
Protected Overridable Sub DoBeforeFlush
Protected Overridable Sub DoBeforeFlush
protected:
virtual void DoBeforeFlush()
protected:
virtual void DoBeforeFlush()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EnsureOpen Method

IndexWriter EnsureOpen Method Lucene.Net Class Library
Overload List
 | Name | Description
Protected method | EnsureOpen |
Protected method | EnsureOpen(Boolean) | Used internally to throw an AlreadyClosedException if this IndexWriter has been closed.
Back to Top
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EnsureOpen Method

IndexWriter EnsureOpen Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void EnsureOpen()
protected void EnsureOpen()
Protected Sub EnsureOpen
Protected Sub EnsureOpen
protected:
void EnsureOpen()
protected:
void EnsureOpen()
See Also
IndexWriter Class
IndexWriter Members
EnsureOpen Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EnsureOpen Method (Boolean)

IndexWriter EnsureOpen Method (Boolean) Lucene.Net Class Library
Used internally to throw an AlreadyClosedException if this IndexWriter has been closed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void EnsureOpen(
    bool includePendingClose
)
protected void EnsureOpen(
    bool includePendingClose
)
Protected Sub EnsureOpen ( _
    includePendingClose As Boolean _
)
Protected Sub EnsureOpen ( _
    includePendingClose As Boolean _
)
protected:
void EnsureOpen(
    bool includePendingClose
)
protected:
void EnsureOpen(
    bool includePendingClose
)
Parameters
includePendingClose
Type:   Online System Boolean
See Also
IndexWriter Class
IndexWriter Members
EnsureOpen Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExpungeDeletes Method

IndexWriter ExpungeDeletes Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ExpungeDeletes | Expunges all deletes from the index. When an index has many document deletions (or updates to existing documents), it's best to either call optimize or expungeDeletes to remove all unused data in the index associated with the deleted documents. To see how many deletions you have pending in your index, call NumDeletedDocs This saves disk space and memory usage while searching. expungeDeletes should be somewhat faster than optimize since it does not insist on reducing the index to a single segment (though, this depends on the MergePolicy; see FindMergesToExpungeDeletes(SegmentInfos).). Note that this call does not first commit any buffered documents, so you must do so yourself if necessary. See also NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.
Public method | ExpungeDeletes(Boolean) | Just like ExpungeDeletes , except you can specify whether the call should block until the operation completes. This is only meaningful with a MergeScheduler that is able to run merges in background threads. NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.
Back to Top
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExpungeDeletes Method

IndexWriter ExpungeDeletes Method Lucene.Net Class Library
Expunges all deletes from the index. When an index has many document deletions (or updates to existing documents), it's best to either call optimize or expungeDeletes to remove all unused data in the index associated with the deleted documents. To see how many deletions you have pending in your index, call NumDeletedDocs This saves disk space and memory usage while searching. expungeDeletes should be somewhat faster than optimize since it does not insist on reducing the index to a single segment (though, this depends on the MergePolicy; see FindMergesToExpungeDeletes(SegmentInfos).). Note that this call does not first commit any buffered documents, so you must do so yourself if necessary. See also

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ExpungeDeletes()
public virtual void ExpungeDeletes()
Public Overridable Sub ExpungeDeletes
Public Overridable Sub ExpungeDeletes
public:
virtual void ExpungeDeletes()
public:
virtual void ExpungeDeletes()
See Also
IndexWriter Class
IndexWriter Members
ExpungeDeletes Overload
Lucene.Net.Index Namespace
IndexWriter ExpungeDeletes(Boolean)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExpungeDeletes Method (Boolean)

IndexWriter ExpungeDeletes Method (Boolean) Lucene.Net Class Library
Just like ExpungeDeletes , except you can specify whether the call should block until the operation completes. This is only meaningful with a MergeScheduler that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ExpungeDeletes(
    bool doWait
)
public virtual void ExpungeDeletes(
    bool doWait
)
Public Overridable Sub ExpungeDeletes ( _
    doWait As Boolean _
)
Public Overridable Sub ExpungeDeletes ( _
    doWait As Boolean _
)
public:
virtual void ExpungeDeletes(
    bool doWait
)
public:
virtual void ExpungeDeletes(
    bool doWait
)
Parameters
doWait
Type:   Online System Boolean
See Also
IndexWriter Class
IndexWriter Members
ExpungeDeletes Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Flush Method

IndexWriter Flush Method Lucene.Net Class Library
Flush all in-memory buffered udpates (adds and deletes) to the Directory.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Flush(
    bool triggerMerge,
    bool flushDocStores,
    bool flushDeletes
)
public void Flush(
    bool triggerMerge,
    bool flushDocStores,
    bool flushDeletes
)
Public Sub Flush ( _
    triggerMerge As Boolean, _
    flushDocStores As Boolean, _
    flushDeletes As Boolean _
)
Public Sub Flush ( _
    triggerMerge As Boolean, _
    flushDocStores As Boolean, _
    flushDeletes As Boolean _
)
public:
void Flush(
    bool triggerMerge,
    bool flushDocStores,
    bool flushDeletes
)
public:
void Flush(
    bool triggerMerge,
    bool flushDocStores,
    bool flushDeletes
)
Parameters
triggerMerge
Type:   Online System Boolean
if true, we may merge segments (if
            deletes or docs were flushed) if necessary

flushDocStores
Type:   Online System Boolean
if false we are allowed to keep
            doc stores open to share with the next segment

flushDeletes
Type:   Online System Boolean
whether pending deletes should also
            be flushed

See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetDocCount Method

IndexWriter GetDocCount Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int GetDocCount(
    int i
)
public int GetDocCount(
    int i
)
Public Function GetDocCount ( _
    i As Integer _
) As Integer
Public Function GetDocCount ( _
    i As Integer _
) As Integer
public:
int GetDocCount(
    int i
)
public:
int GetDocCount(
    int i
)
Parameters
i
Type:   Online System Int32
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetMaxBufferedDeleteTerms Method

IndexWriter GetMaxBufferedDeleteTerms Method Lucene.Net Class Library
Returns the number of buffered deleted terms that will trigger a flush if enabled.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int GetMaxBufferedDeleteTerms()
public virtual int GetMaxBufferedDeleteTerms()
Public Overridable Function GetMaxBufferedDeleteTerms As Integer
Public Overridable Function GetMaxBufferedDeleteTerms As Integer
public:
virtual int GetMaxBufferedDeleteTerms()
public:
virtual int GetMaxBufferedDeleteTerms()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
IndexWriter SetMaxBufferedDeleteTerms(Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetMaxBufferedDocs Method

IndexWriter GetMaxBufferedDocs Method Lucene.Net Class Library
Returns the number of buffered added documents that will trigger a flush if enabled.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int GetMaxBufferedDocs()
public virtual int GetMaxBufferedDocs()
Public Overridable Function GetMaxBufferedDocs As Integer
Public Overridable Function GetMaxBufferedDocs As Integer
public:
virtual int GetMaxBufferedDocs()
public:
virtual int GetMaxBufferedDocs()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
IndexWriter SetMaxBufferedDocs(Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetMaxFieldLength Method

IndexWriter GetMaxFieldLength Method Lucene.Net Class Library
Returns the maximum number of terms that will be indexed for a single field in a document.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int GetMaxFieldLength()
public virtual int GetMaxFieldLength()
Public Overridable Function GetMaxFieldLength As Integer
Public Overridable Function GetMaxFieldLength As Integer
public:
virtual int GetMaxFieldLength()
public:
virtual int GetMaxFieldLength()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
IndexWriter SetMaxFieldLength(Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetRAMBufferSizeMB Method

IndexWriter GetRAMBufferSizeMB Method Lucene.Net Class Library
Returns the value set by SetRAMBufferSizeMB(Double) if enabled.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual double GetRAMBufferSizeMB()
public virtual double GetRAMBufferSizeMB()
Public Overridable Function GetRAMBufferSizeMB As Double
Public Overridable Function GetRAMBufferSizeMB As Double
public:
virtual double GetRAMBufferSizeMB()
public:
virtual double GetRAMBufferSizeMB()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetReader Method

IndexWriter GetReader Method Lucene.Net Class Library
Overload List
Name Description
Public method GetReader
Expert: returns a readonly reader, covering all committed as well as un-committed changes to the index. This provides "near real-time" searching, in that changes made during an IndexWriter session can be quickly made available for searching without closing the writer nor calling Commit .

Note that this is functionally equivalent to calling {#commit} and then using Open(Directory, Boolean) to open a new reader. But the turarnound time of this method should be faster since it avoids the potentially costly Commit .

You must close the IndexReader returned by this method once you are done using it.

It's near real-time because there is no hard guarantee on how quickly you can get a new reader after making changes with IndexWriter. You'll have to experiment in your situation to determine if it's faster enough. As this is a new and experimental feature, please report back on your findings so we can learn, improve and iterate.

The resulting reader suppports Reopen , but that call will simply forward back to this method (though this may change in the future).

The very first time this method is called, this writer instance will make every effort to pool the readers that it opens for doing merges, applying deletes, etc. This means additional resources (RAM, file descriptors, CPU time) will be consumed.

For lower latency on reopening a reader, you should call MergedSegmentWarmer to call MergedSegmentWarmer to pre-warm a newly merged segment before it's committed to the index. This is important for minimizing index-to-search delay after a large merge.

If an addIndexes* call is running in another thread, then this reader will only search those segments from the foreign index that have been successfully copied over, so far

.

NOTE: Once the writer is closed, any outstanding readers may continue to be used. However, if you attempt to reopen any of those readers, you'll hit an AlreadyClosedException.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Public method GetReader(Int32)
Expert: like GetReader , except you can specify which termInfosIndexDivisor should be used for any newly opened readers.
Back to Top
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetReader Method

IndexWriter GetReader Method Lucene.Net Class Library
Expert: returns a readonly reader, covering all committed as well as un-committed changes to the index. This provides "near real-time" searching, in that changes made during an IndexWriter session can be quickly made available for searching without closing the writer nor calling Commit .

Note that this is functionally equivalent to calling {#commit} and then using Open(Directory, Boolean) to open a new reader. But the turarnound time of this method should be faster since it avoids the potentially costly Commit .

You must close the IndexReader returned by this method once you are done using it.

It's near real-time because there is no hard guarantee on how quickly you can get a new reader after making changes with IndexWriter. You'll have to experiment in your situation to determine if it's faster enough. As this is a new and experimental feature, please report back on your findings so we can learn, improve and iterate.

The resulting reader suppports Reopen , but that call will simply forward back to this method (though this may change in the future).

The very first time this method is called, this writer instance will make every effort to pool the readers that it opens for doing merges, applying deletes, etc. This means additional resources (RAM, file descriptors, CPU time) will be consumed.

For lower latency on reopening a reader, you should call MergedSegmentWarmer to call MergedSegmentWarmer to pre-warm a newly merged segment before it's committed to the index. This is important for minimizing index-to-search delay after a large merge.

If an addIndexes* call is running in another thread, then this reader will only search those segments from the foreign index that have been successfully copied over, so far

.

NOTE: Once the writer is closed, any outstanding readers may continue to be used. However, if you attempt to reopen any of those readers, you'll hit an AlreadyClosedException.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IndexReader GetReader()
public virtual IndexReader GetReader()
Public Overridable Function GetReader As IndexReader
Public Overridable Function GetReader As IndexReader
public:
virtual IndexReader^ GetReader()
public:
virtual IndexReader^ GetReader()
Return Value
 IndexReader that covers entire index plus all
             changes made so far by this IndexWriter instance

See Also
IndexWriter Class
IndexWriter Members
GetReader Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetReader Method (Int32)

IndexWriter GetReader Method (Int32) Lucene.Net Class Library
Expert: like GetReader , except you can specify which termInfosIndexDivisor should be used for any newly opened readers.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IndexReader GetReader(
    int termInfosIndexDivisor
)
public virtual IndexReader GetReader(
    int termInfosIndexDivisor
)
Public Overridable Function GetReader ( _
    termInfosIndexDivisor As Integer _
) As IndexReader
Public Overridable Function GetReader ( _
    termInfosIndexDivisor As Integer _
) As IndexReader
public:
virtual IndexReader^ GetReader(
    int termInfosIndexDivisor
)
public:
virtual IndexReader^ GetReader(
    int termInfosIndexDivisor
)
Parameters
termInfosIndexDivisor
Type:   Online System Int32
Subsambles which indexed
            terms are loaded into RAM. This has the same effect as TermIndexInterval
            except that setting
            must be done at indexing time while this setting can be
            set per reader.  When set to N, then one in every
            N*termIndexInterval terms in the index is loaded into
            memory.  By setting this to a value > 1 you can reduce
            memory usage, at the expense of higher latency when
            loading a TermInfo.  The default value is 1.  Set this
            to -1 to skip loading the terms index entirely.

See Also
IndexWriter Class
IndexWriter Members
GetReader Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasDeletions Method

IndexWriter HasDeletions Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool HasDeletions()
public virtual bool HasDeletions()
Public Overridable Function HasDeletions As Boolean
Public Overridable Function HasDeletions As Boolean
public:
virtual bool HasDeletions()
public:
virtual bool HasDeletions()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsLocked Method

IndexWriter IsLocked Method Lucene.Net Class Library
Returns true iff the index in the named directory is currently locked.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsLocked(
    Directory directory
)
public static bool IsLocked(
    Directory directory
)
Public Shared Function IsLocked ( _
    directory As Directory _
) As Boolean
Public Shared Function IsLocked ( _
    directory As Directory _
) As Boolean
public:
static bool IsLocked(
    Directory^ directory
)
public:
static bool IsLocked(
    Directory^ directory
)
Parameters
directory
Type: Lucene.Net.Store Directory
the directory to check for a lock

See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxDoc Method

IndexWriter MaxDoc Method Lucene.Net Class Library
Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), not counting deletions.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int MaxDoc()
public virtual int MaxDoc()
Public Overridable Function MaxDoc As Integer
Public Overridable Function MaxDoc As Integer
public:
virtual int MaxDoc()
public:
virtual int MaxDoc()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
IndexWriter NumDocs
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaybeMerge Method

IndexWriter MaybeMerge Method Lucene.Net Class Library
Expert: asks the mergePolicy whether any merges are necessary now and if so, runs the requested merges and then iterate (test again if merges are needed) until no more merges are returned by the mergePolicy. Explicit calls to maybeMerge() are usually not necessary. The most common case is when merge policy parameters have changed.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void MaybeMerge()
public void MaybeMerge()
Public Sub MaybeMerge
Public Sub MaybeMerge
public:
void MaybeMerge()
public:
void MaybeMerge()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Merge_ForNUnit Method

IndexWriter Merge_ForNUnit Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Merge_ForNUnit(
    MergePolicy..::..OneMerge merge
)
public void Merge_ForNUnit(
    MergePolicy..::..OneMerge merge
)
Public Sub Merge_ForNUnit ( _
    merge As MergePolicy..::..OneMerge _
)
Public Sub Merge_ForNUnit ( _
    merge As MergePolicy..::..OneMerge _
)
public:
void Merge_ForNUnit(
    MergePolicy..::..OneMerge^ merge
)
public:
void Merge_ForNUnit(
    MergePolicy..::..OneMerge^ merge
)
Parameters
merge
Type: Lucene.Net.Index MergePolicy OneMerge
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Message Method

IndexWriter Message Method Lucene.Net Class Library
Prints a message to the infoStream (if non-null), prefixed with the identifying information for this writer and the thread that's calling it.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Message(
    string message
)
public virtual void Message(
    string message
)
Public Overridable Sub Message ( _
    message As String _
)
Public Overridable Sub Message ( _
    message As String _
)
public:
virtual void Message(
    String^ message
)
public:
virtual void Message(
    String^ message
)
Parameters
message
Type:   Online System String
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewestSegment Method

IndexWriter NewestSegment Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual SegmentInfo NewestSegment()
public virtual SegmentInfo NewestSegment()
Public Overridable Function NewestSegment As SegmentInfo
Public Overridable Function NewestSegment As SegmentInfo
public:
virtual SegmentInfo^ NewestSegment()
public:
virtual SegmentInfo^ NewestSegment()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumDeletedDocs Method

IndexWriter NumDeletedDocs Method Lucene.Net Class Library
Obtain the number of deleted docs for a pooled reader. If the reader isn't being pooled, the segmentInfo's delCount is returned.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int NumDeletedDocs(
    SegmentInfo info
)
public virtual int NumDeletedDocs(
    SegmentInfo info
)
Public Overridable Function NumDeletedDocs ( _
    info As SegmentInfo _
) As Integer
Public Overridable Function NumDeletedDocs ( _
    info As SegmentInfo _
) As Integer
public:
virtual int NumDeletedDocs(
    SegmentInfo^ info
)
public:
virtual int NumDeletedDocs(
    SegmentInfo^ info
)
Parameters
info
Type: Lucene.Net.Index SegmentInfo
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumDocs Method

IndexWriter NumDocs Method Lucene.Net Class Library
Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), and including deletions. NOTE: buffered deletions are not counted. If you really need these to be counted you should call Commit first.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int NumDocs()
public virtual int NumDocs()
Public Overridable Function NumDocs As Integer
Public Overridable Function NumDocs As Integer
public:
virtual int NumDocs()
public:
virtual int NumDocs()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
IndexWriter NumDocs
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumRamDocs Method

IndexWriter NumRamDocs Method Lucene.Net Class Library
Expert: Return the number of documents currently buffered in RAM.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int NumRamDocs()
public int NumRamDocs()
Public Function NumRamDocs As Integer
Public Function NumRamDocs As Integer
public:
int NumRamDocs()
public:
int NumRamDocs()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Optimize Method

IndexWriter Optimize Method Lucene.Net Class Library
Overload List
Name Description
Public method Optimize
Requests an "optimize" operation on an index, priming the index for the fastest available search. Traditionally this has meant merging all segments into a single segment as is done in the default merge policy, but individaul merge policies may implement optimize in different ways.

It is recommended that this method be called upon completion of indexing. In environments with frequent updates, optimize is best done during low volume times, if at all.

See http://www.gossamer-threads.com/lists/lucene/java-dev/47895 for more discussion.

Note that optimize requires 2X the index size free space in your Directory (3X if you're using compound file format). For example, if your index size is 10 MB then you need 20 MB free for optimize to complete (30 MB if you're using compound fiel format).

If some but not all readers re-open while an optimize is underway, this will cause > 2X temporary space to be consumed as those new readers will then hold open the partially optimized segments at that time. It is best not to re-open readers while optimize is running.

The actual temporary usage could be much less than these figures (it depends on many factors).

In general, once the optimize completes, the total size of the index will be less than the size of the starting index. It could be quite a bit smaller (if there were many pending deletes) or just slightly smaller.

If an Exception is hit during optimize(), for example due to disk full, the index will not be corrupt and no documents will have been lost. However, it may have been partially optimized (some segments were merged but not all), and it's possible that one of the segments in the index will be in non-compound format even when using compound file format. This will occur when the Exception is hit during conversion of the segment into compound format.

This call will optimize those segments present in the index when the call started. If other threads are still adding documents and flushing segments, those newly created segments will not be optimized unless you call optimize again.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Boolean)
Just like Optimize , except you can specify whether the call should block until the optimize completes. This is only meaningful with a MergeScheduler that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Int32)
Optimize the index down to <= maxNumSegments. If maxNumSegments==1 then this is the same as Optimize .

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Int32, Boolean)
Just like Optimize(Int32), except you can specify whether the call should block until the optimize completes. This is only meaningful with a MergeScheduler that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Back to Top
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Optimize Method

IndexWriter Optimize Method Lucene.Net Class Library
Requests an "optimize" operation on an index, priming the index for the fastest available search. Traditionally this has meant merging all segments into a single segment as is done in the default merge policy, but individaul merge policies may implement optimize in different ways.

It is recommended that this method be called upon completion of indexing. In environments with frequent updates, optimize is best done during low volume times, if at all.

See http://www.gossamer-threads.com/lists/lucene/java-dev/47895 for more discussion.

Note that optimize requires 2X the index size free space in your Directory (3X if you're using compound file format). For example, if your index size is 10 MB then you need 20 MB free for optimize to complete (30 MB if you're using compound fiel format).

If some but not all readers re-open while an optimize is underway, this will cause > 2X temporary space to be consumed as those new readers will then hold open the partially optimized segments at that time. It is best not to re-open readers while optimize is running.

The actual temporary usage could be much less than these figures (it depends on many factors).

In general, once the optimize completes, the total size of the index will be less than the size of the starting index. It could be quite a bit smaller (if there were many pending deletes) or just slightly smaller.

If an Exception is hit during optimize(), for example due to disk full, the index will not be corrupt and no documents will have been lost. However, it may have been partially optimized (some segments were merged but not all), and it's possible that one of the segments in the index will be in non-compound format even when using compound file format. This will occur when the Exception is hit during conversion of the segment into compound format.

This call will optimize those segments present in the index when the call started. If other threads are still adding documents and flushing segments, those newly created segments will not be optimized unless you call optimize again.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Optimize()
public virtual void Optimize()
Public Overridable Sub Optimize
Public Overridable Sub Optimize
public:
virtual void Optimize()
public:
virtual void Optimize()
See Also
IndexWriter Class
IndexWriter Members
Optimize Overload
Lucene.Net.Index Namespace
LogMergePolicy FindMergesForOptimize(SegmentInfos, Int32, ISet SegmentInfo )
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Optimize Method (Boolean)

IndexWriter Optimize Method (Boolean) Lucene.Net Class Library
Just like Optimize , except you can specify whether the call should block until the optimize completes. This is only meaningful with a MergeScheduler that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Optimize(
    bool doWait
)
public virtual void Optimize(
    bool doWait
)
Public Overridable Sub Optimize ( _
    doWait As Boolean _
)
Public Overridable Sub Optimize ( _
    doWait As Boolean _
)
public:
virtual void Optimize(
    bool doWait
)
public:
virtual void Optimize(
    bool doWait
)
Parameters
doWait
Type:   Online System Boolean
See Also
IndexWriter Class
IndexWriter Members
Optimize Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Optimize Method (Int32)

IndexWriter Optimize Method (Int32) Lucene.Net Class Library
Optimize the index down to <= maxNumSegments. If maxNumSegments==1 then this is the same as Optimize .

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Optimize(
    int maxNumSegments
)
public virtual void Optimize(
    int maxNumSegments
)
Public Overridable Sub Optimize ( _
    maxNumSegments As Integer _
)
Public Overridable Sub Optimize ( _
    maxNumSegments As Integer _
)
public:
virtual void Optimize(
    int maxNumSegments
)
public:
virtual void Optimize(
    int maxNumSegments
)
Parameters
maxNumSegments
Type:   Online System Int32
maximum number of segments left
             in the index after optimization finishes

See Also
IndexWriter Class
IndexWriter Members
Optimize Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Optimize Method (Int32, Boolean)

IndexWriter Optimize Method (Int32, Boolean) Lucene.Net Class Library
Just like Optimize(Int32), except you can specify whether the call should block until the optimize completes. This is only meaningful with a MergeScheduler that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Optimize(
    int maxNumSegments,
    bool doWait
)
public virtual void Optimize(
    int maxNumSegments,
    bool doWait
)
Public Overridable Sub Optimize ( _
    maxNumSegments As Integer, _
    doWait As Boolean _
)
Public Overridable Sub Optimize ( _
    maxNumSegments As Integer, _
    doWait As Boolean _
)
public:
virtual void Optimize(
    int maxNumSegments,
    bool doWait
)
public:
virtual void Optimize(
    int maxNumSegments,
    bool doWait
)
Parameters
maxNumSegments
Type:   Online System Int32
doWait
Type:   Online System Boolean
See Also
IndexWriter Class
IndexWriter Members
Optimize Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrepareCommit Method

IndexWriter PrepareCommit Method Lucene.Net Class Library
Expert: prepare for commit.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void PrepareCommit()
public void PrepareCommit()
Public Sub PrepareCommit
Public Sub PrepareCommit
public:
void PrepareCommit()
public:
void PrepareCommit()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
IndexWriterPrepareCommit(IDictionary String, String )
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RamSizeInBytes Method

IndexWriter RamSizeInBytes Method Lucene.Net Class Library
Expert: Return the total size of all index files currently cached in memory. Useful for size management with flushRamDocs()

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long RamSizeInBytes()
public long RamSizeInBytes()
Public Function RamSizeInBytes As Long
Public Function RamSizeInBytes As Long
public:
long long RamSizeInBytes()
public:
long long RamSizeInBytes()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rollback Method

IndexWriter Rollback Method Lucene.Net Class Library
Close the IndexWriter without committing any changes that have occurred since the last commit (or since it was opened, if commit hasn't been called). This removes any temporary files that had been created, after which the state of the index will be the same as it was when commit() was last called or when this writer was first opened. This also clears a previous call to PrepareCommit .

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Rollback()
public virtual void Rollback()
Public Overridable Sub Rollback
Public Overridable Sub Rollback
public:
virtual void Rollback()
public:
virtual void Rollback()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegString Method

IndexWriter SegString Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string SegString()
public virtual string SegString()
Public Overridable Function SegString As String
Public Overridable Function SegString As String
public:
virtual String^ SegString()
public:
virtual String^ SegString()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetInfoStream Method

IndexWriter SetInfoStream Method Lucene.Net Class Library
If non-null, information about merges, deletes and a message when maxFieldLength is reached will be printed to this.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetInfoStream(
    StreamWriter infoStream
)
public virtual void SetInfoStream(
    StreamWriter infoStream
)
Public Overridable Sub SetInfoStream ( _
    infoStream As StreamWriter _
)
Public Overridable Sub SetInfoStream ( _
    infoStream As StreamWriter _
)
public:
virtual void SetInfoStream(
    StreamWriter^ infoStream
)
public:
virtual void SetInfoStream(
    StreamWriter^ infoStream
)
Parameters
infoStream
Type:   Online System.IO StreamWriter
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetMaxBufferedDeleteTerms Method

IndexWriter SetMaxBufferedDeleteTerms Method Lucene.Net Class Library

Determines the minimal number of delete terms required before the buffered in-memory delete terms are applied and flushed. If there are documents buffered in memory at the time, they are merged and a new segment is created.

Disabled by default (writer flushes by RAM usage).

is enabled but smaller than 1

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetMaxBufferedDeleteTerms(
    int maxBufferedDeleteTerms
)
public virtual void SetMaxBufferedDeleteTerms(
    int maxBufferedDeleteTerms
)
Public Overridable Sub SetMaxBufferedDeleteTerms ( _
    maxBufferedDeleteTerms As Integer _
)
Public Overridable Sub SetMaxBufferedDeleteTerms ( _
    maxBufferedDeleteTerms As Integer _
)
public:
virtual void SetMaxBufferedDeleteTerms(
    int maxBufferedDeleteTerms
)
public:
virtual void SetMaxBufferedDeleteTerms(
    int maxBufferedDeleteTerms
)
Parameters
maxBufferedDeleteTerms
Type:   Online System Int32
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
IndexWriter SetRAMBufferSizeMB(Double)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetMaxBufferedDocs Method

IndexWriter SetMaxBufferedDocs Method Lucene.Net Class Library
Determines the minimal number of documents required before the buffered in-memory documents are flushed as a new Segment. Large values generally gives faster indexing.

When this is set, the writer will flush every maxBufferedDocs added documents. Pass in DISABLE_AUTO_FLUSH to prevent triggering a flush due to number of buffered documents. Note that if flushing by RAM usage is also enabled, then the flush will be triggered by whichever comes first.

Disabled by default (writer flushes by RAM usage).

enabled but smaller than 2, or it disables maxBufferedDocs when ramBufferSize is already disabled

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetMaxBufferedDocs(
    int maxBufferedDocs
)
public virtual void SetMaxBufferedDocs(
    int maxBufferedDocs
)
Public Overridable Sub SetMaxBufferedDocs ( _
    maxBufferedDocs As Integer _
)
Public Overridable Sub SetMaxBufferedDocs ( _
    maxBufferedDocs As Integer _
)
public:
virtual void SetMaxBufferedDocs(
    int maxBufferedDocs
)
public:
virtual void SetMaxBufferedDocs(
    int maxBufferedDocs
)
Parameters
maxBufferedDocs
Type:   Online System Int32
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
IndexWriter SetRAMBufferSizeMB(Double)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetMaxFieldLength Method

IndexWriter SetMaxFieldLength Method Lucene.Net Class Library
The maximum number of terms that will be indexed for a single field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory. This setting refers to the number of running terms, not to the number of different terms.

Note: this silently truncates large documents, excluding from the index all terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accomodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an OutOfMemoryError.

By default, no more than DEFAULT_MAX_FIELD_LENGTH terms will be indexed for a field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetMaxFieldLength(
    int maxFieldLength
)
public virtual void SetMaxFieldLength(
    int maxFieldLength
)
Public Overridable Sub SetMaxFieldLength ( _
    maxFieldLength As Integer _
)
Public Overridable Sub SetMaxFieldLength ( _
    maxFieldLength As Integer _
)
public:
virtual void SetMaxFieldLength(
    int maxFieldLength
)
public:
virtual void SetMaxFieldLength(
    int maxFieldLength
)
Parameters
maxFieldLength
Type:   Online System Int32
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetMergePolicy Method

IndexWriter SetMergePolicy Method Lucene.Net Class Library
Expert: set the merge policy used by this writer.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetMergePolicy(
    MergePolicy mp
)
public virtual void SetMergePolicy(
    MergePolicy mp
)
Public Overridable Sub SetMergePolicy ( _
    mp As MergePolicy _
)
Public Overridable Sub SetMergePolicy ( _
    mp As MergePolicy _
)
public:
virtual void SetMergePolicy(
    MergePolicy^ mp
)
public:
virtual void SetMergePolicy(
    MergePolicy^ mp
)
Parameters
mp
Type: Lucene.Net.Index MergePolicy
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetMergeScheduler Method

IndexWriter SetMergeScheduler Method Lucene.Net Class Library
Expert: set the merge scheduler used by this writer.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetMergeScheduler(
    MergeScheduler mergeScheduler
)
public virtual void SetMergeScheduler(
    MergeScheduler mergeScheduler
)
Public Overridable Sub SetMergeScheduler ( _
    mergeScheduler As MergeScheduler _
)
Public Overridable Sub SetMergeScheduler ( _
    mergeScheduler As MergeScheduler _
)
public:
virtual void SetMergeScheduler(
    MergeScheduler^ mergeScheduler
)
public:
virtual void SetMergeScheduler(
    MergeScheduler^ mergeScheduler
)
Parameters
mergeScheduler
Type: Lucene.Net.Index MergeScheduler
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetRAMBufferSizeMB Method

IndexWriter SetRAMBufferSizeMB Method Lucene.Net Class Library
Determines the amount of RAM that may be used for buffering added documents and deletions before they are flushed to the Directory. Generally for faster indexing performance it's best to flush by RAM usage instead of document count and use as large a RAM buffer as you can.

When this is set, the writer will flush whenever buffered documents and deletions use this much RAM. Pass in DISABLE_AUTO_FLUSH to prevent triggering a flush due to RAM usage. Note that if flushing by document count is also enabled, then the flush will be triggered by whichever comes first.

NOTE: the account of RAM usage for pending deletions is only approximate. Specifically, if you delete by Query, Lucene currently has no way to measure the RAM usage if individual Queries so the accounting will under-estimate and you should compensate by either calling commit() periodically yourself, or by using SetMaxBufferedDeleteTerms(Int32) to flush by count instead of RAM usage (each buffered delete Query counts as one).

NOTE: because IndexWriter uses ints when managing its internal storage, the absolute maximum value for this setting is somewhat less than 2048 MB. The precise limit depends on various factors, such as how large your documents are, how many fields have norms, etc., so it's best to set this value comfortably under 2048.

The default value is DEFAULT_RAM_BUFFER_SIZE_MB.

enabled but non-positive, or it disables ramBufferSize when maxBufferedDocs is already disabled

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetRAMBufferSizeMB(
    double mb
)
public virtual void SetRAMBufferSizeMB(
    double mb
)
Public Overridable Sub SetRAMBufferSizeMB ( _
    mb As Double _
)
Public Overridable Sub SetRAMBufferSizeMB ( _
    mb As Double _
)
public:
virtual void SetRAMBufferSizeMB(
    double mb
)
public:
virtual void SetRAMBufferSizeMB(
    double mb
)
Parameters
mb
Type:   Online System Double
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetSimilarity Method

IndexWriter SetSimilarity Method Lucene.Net Class Library
Expert: Set the Similarity implementation used by this IndexWriter.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetSimilarity(
    Similarity similarity
)
public virtual void SetSimilarity(
    Similarity similarity
)
Public Overridable Sub SetSimilarity ( _
    similarity As Similarity _
)
Public Overridable Sub SetSimilarity ( _
    similarity As Similarity _
)
public:
virtual void SetSimilarity(
    Similarity^ similarity
)
public:
virtual void SetSimilarity(
    Similarity^ similarity
)
Parameters
similarity
Type: Lucene.Net.Search Similarity
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TestPoint Method

IndexWriter TestPoint Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool TestPoint(
    string name
)
public virtual bool TestPoint(
    string name
)
Public Overridable Function TestPoint ( _
    name As String _
) As Boolean
Public Overridable Function TestPoint ( _
    name As String _
) As Boolean
public:
virtual bool TestPoint(
    String^ name
)
public:
virtual bool TestPoint(
    String^ name
)
Parameters
name
Type:   Online System String
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Unlock Method

IndexWriter Unlock Method Lucene.Net Class Library
Forcibly unlocks the index in the named directory.

Caution: this should only be used by failure recovery code, when it is known that no other process nor thread is in fact currently accessing this index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Unlock(
    Directory directory
)
public static void Unlock(
    Directory directory
)
Public Shared Sub Unlock ( _
    directory As Directory _
)
Public Shared Sub Unlock ( _
    directory As Directory _
)
public:
static void Unlock(
    Directory^ directory
)
public:
static void Unlock(
    Directory^ directory
)
Parameters
directory
Type: Lucene.Net.Store Directory
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UpdateDocument Method

IndexWriter UpdateDocument Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | UpdateDocument(Term, Document) | Updates a document by first deleting the document(s) containing term and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add). NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.
Public method | UpdateDocument(Term, Document, Analyzer) | Updates a document by first deleting the document(s) containing term and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add). NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.
Back to Top
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UpdateDocument Method (Term, Document)

IndexWriter UpdateDocument Method (Term, Document) Lucene.Net Class Library
Updates a document by first deleting the document(s) containing term and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void UpdateDocument(
    Term term,
    Document doc
)
public virtual void UpdateDocument(
    Term term,
    Document doc
)
Public Overridable Sub UpdateDocument ( _
    term As Term, _
    doc As Document _
)
Public Overridable Sub UpdateDocument ( _
    term As Term, _
    doc As Document _
)
public:
virtual void UpdateDocument(
    Term^ term,
    Document^ doc
)
public:
virtual void UpdateDocument(
    Term^ term,
    Document^ doc
)
Parameters
term
Type: Lucene.Net.Index Term
the term to identify the document(s) to be
            deleted

doc
Type: Lucene.Net.Documents Document
the document to be added

See Also
IndexWriter Class
IndexWriter Members
UpdateDocument Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UpdateDocument Method (Term, Document, Analyzer)

IndexWriter UpdateDocument Method (Term, Document, Analyzer) Lucene.Net Class Library
Updates a document by first deleting the document(s) containing term and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void UpdateDocument(
    Term term,
    Document doc,
    Analyzer analyzer
)
public virtual void UpdateDocument(
    Term term,
    Document doc,
    Analyzer analyzer
)
Public Overridable Sub UpdateDocument ( _
    term As Term, _
    doc As Document, _
    analyzer As Analyzer _
)
Public Overridable Sub UpdateDocument ( _
    term As Term, _
    doc As Document, _
    analyzer As Analyzer _
)
public:
virtual void UpdateDocument(
    Term^ term,
    Document^ doc,
    Analyzer^ analyzer
)
public:
virtual void UpdateDocument(
    Term^ term,
    Document^ doc,
    Analyzer^ analyzer
)
Parameters
term
Type: Lucene.Net.Index Term
the term to identify the document(s) to be
            deleted

doc
Type: Lucene.Net.Documents Document
the document to be added

analyzer
Type: Lucene.Net.Analysis Analyzer
the analyzer to use when analyzing the document

See Also
IndexWriter Class
IndexWriter Members
UpdateDocument Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WaitForMerges Method

IndexWriter WaitForMerges Method Lucene.Net Class Library
Wait for any currently outstanding merges to finish.

It is guaranteed that any merges started prior to calling this method will have completed once this method completes.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void WaitForMerges()
public virtual void WaitForMerges()
Public Overridable Sub WaitForMerges
Public Overridable Sub WaitForMerges
public:
virtual void WaitForMerges()
public:
virtual void WaitForMerges()
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter Properties

IndexWriter Properties Lucene.Net Class Library
The IndexWriter type exposes the following members.
Properties
Name | Description
Public property Analyzer
Returns the analyzer used by this index.
DefaultInfoStream
Gets or sets the default info stream. If non-null, this will be the default infoStream used by a newly instantiated IndexWriter.
DefaultWriteLockTimeout
Gets or sets the default (for any instance of IndexWriter) maximum time to wait for a write lock (in milliseconds).
Public property Directory
Returns the Directory used by this index.
Public property InfoStream
Returns the current infoStream in use by this writer.
Public property MaxMergeDocs

Gets or sets the largest segment (measured by document count) that may be merged with other segments.

Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches.

The default value is Online MaxValue.

Note that this method is a convenience method: it just calls mergePolicy.getMaxMergeDocs as long as mergePolicy is an instance of LogMergePolicy. Otherwise an IllegalArgumentException is thrown.

The default merge policy (LogByteSizeMergePolicy) also allows you to set this limit by net size (in MB) of the segment, using MaxMergeMB.

Public property MergedSegmentWarmer
Gets or sets the merged segment warmer. See IndexWriter IndexReaderWarmer .
Public property MergeFactor
Gets or sets the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index.

Determines how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained.

Note that this method is a convenience method: it just calls mergePolicy.setMergeFactor as long as mergePolicy is an instance of LogMergePolicy. Otherwise an IllegalArgumentException is thrown.

This must never be less than 2. The default value is 10.
Public property MergePolicy
Expert: returns the current MergePolicy in use by this writer.
Public property MergeScheduler
Expert: returns the current MergePolicy in use by this writer.
Public property | ReaderTermsIndexDivisor
Public property Similarity
Expert: Return the Similarity implementation used by this IndexWriter.

This defaults to the current value of Default.
Public property TermIndexInterval
Expert: Gets or sets the interval between indexed terms. Large values cause less memory to be used by IndexReader, but slow random-access to terms. Small values cause more memory to be used by an IndexReader, and speed random-access to terms. This parameter determines the amount of computation required per query term, regardless of the number of documents that contain that term. In particular, it is the maximum number of other terms that must be scanned before a term is located and its frequency and position information may be processed. In a large index with user-entered query terms, query processing time is likely to be dominated not by term lookup but rather by the processing of frequency and positional data. In a small index or when many uncommon query terms are generated (e.g., by wildcard queries) term lookup may become a dominant cost. In particular, numUniqueTerms/interval terms are read into memory by an IndexReader, and, on average, interval/2 terms must be scanned for each random term access.
Public property UseCompoundFile

Gets or sets the current setting of whether newly flushed segments will use the compound file format. Note that this just returns the value previously set with setUseCompoundFile(boolean), or the default value (true). You cannot use this to query the status of previously flushed segments.

Note that this method is a convenience method: it just calls mergePolicy.getUseCompoundFile as long as mergePolicy is an instance of LogMergePolicy. Otherwise an IllegalArgumentException is thrown.

Public property Verbose
Returns true if verbosing is enabled (i.e., infoStream != null).
Public property WriteLockTimeout
Gets or sets allowed timeout when acquiring the write lock.
Back to Top
See Also
IndexWriter Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Analyzer Property

IndexWriter Analyzer Property Lucene.Net Class Library
Returns the analyzer used by this index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Analyzer Analyzer { get; }
public virtual Analyzer Analyzer { get; }
Public Overridable ReadOnly Property Analyzer As Analyzer
    Get
Public Overridable ReadOnly Property Analyzer As Analyzer
    Get
public:
virtual property Analyzer^ Analyzer {
    Analyzer^ get ();
}
public:
virtual property Analyzer^ Analyzer {
    Analyzer^ get ();
}
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DefaultInfoStream Property

IndexWriter DefaultInfoStream Property Lucene.Net Class Library
Gets or sets the default info stream. If non-null, this will be the default infoStream used by a newly instantiated IndexWriter.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static StreamWriter DefaultInfoStream { get; set; }
public static StreamWriter DefaultInfoStream { get; set; }
Public Shared Property DefaultInfoStream As StreamWriter
    Get
    Set
Public Shared Property DefaultInfoStream As StreamWriter
    Get
    Set
public:
static property StreamWriter^ DefaultInfoStream {
    StreamWriter^ get ();
    void set (StreamWriter^ value);
}
public:
static property StreamWriter^ DefaultInfoStream {
    StreamWriter^ get ();
    void set (StreamWriter^ value);
}
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
IndexWriter SetInfoStream(StreamWriter)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DefaultWriteLockTimeout Property

IndexWriter DefaultWriteLockTimeout Property Lucene.Net Class Library
Gets or sets the default (for any instance of IndexWriter) maximum time to wait for a write lock (in milliseconds).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long DefaultWriteLockTimeout { get; set; }
public static long DefaultWriteLockTimeout { get; set; }
Public Shared Property DefaultWriteLockTimeout As Long
    Get
    Set
Public Shared Property DefaultWriteLockTimeout As Long
    Get
    Set
public:
static property long long DefaultWriteLockTimeout {
    long long get ();
    void set (long long value);
}
public:
static property long long DefaultWriteLockTimeout {
    long long get ();
    void set (long long value);
}
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Directory Property

IndexWriter Directory Property Lucene.Net Class Library
Returns the Directory used by this index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Directory Directory { get; }
public virtual Directory Directory { get; }
Public Overridable ReadOnly Property Directory As Directory
    Get
Public Overridable ReadOnly Property Directory As Directory
    Get
public:
virtual property Directory^ Directory {
    Directory^ get ();
}
public:
virtual property Directory^ Directory {
    Directory^ get ();
}
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


InfoStream Property

IndexWriter InfoStream Property Lucene.Net Class Library
Returns the current infoStream in use by this writer.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual StreamWriter InfoStream { get; }
public virtual StreamWriter InfoStream { get; }
Public Overridable ReadOnly Property InfoStream As StreamWriter
    Get
Public Overridable ReadOnly Property InfoStream As StreamWriter
    Get
public:
virtual property StreamWriter^ InfoStream {
    StreamWriter^ get ();
}
public:
virtual property StreamWriter^ InfoStream {
    StreamWriter^ get ();
}
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
IndexWriter SetInfoStream(StreamWriter)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxMergeDocs Property

IndexWriter MaxMergeDocs Property Lucene.Net Class Library

Gets or sets the largest segment (measured by document count) that may be merged with other segments.

Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches.

The default value is Online MaxValue.

Note that this method is a convenience method: it just calls mergePolicy.getMaxMergeDocs as long as mergePolicy is an instance of LogMergePolicy. Otherwise an IllegalArgumentException is thrown.

The default merge policy (LogByteSizeMergePolicy) also allows you to set this limit by net size (in MB) of the segment, using MaxMergeMB.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int MaxMergeDocs { get; set; }
public virtual int MaxMergeDocs { get; set; }
Public Overridable Property MaxMergeDocs As Integer
    Get
    Set
Public Overridable Property MaxMergeDocs As Integer
    Get
    Set
public:
virtual property int MaxMergeDocs {
    int get ();
    void set (int value);
}
public:
virtual property int MaxMergeDocs {
    int get ();
    void set (int value);
}
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
IndexWriter MaxMergeDocs
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergedSegmentWarmer Property

IndexWriter MergedSegmentWarmer Property Lucene.Net Class Library
Gets or sets the merged segment warmer. See IndexWriter IndexReaderWarmer .

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IndexWriter..::..IndexReaderWarmer MergedSegmentWarmer { get; set; }
public virtual IndexWriter..::..IndexReaderWarmer MergedSegmentWarmer { get; set; }
Public Overridable Property MergedSegmentWarmer As IndexWriter..::..IndexReaderWarmer
    Get
    Set
Public Overridable Property MergedSegmentWarmer As IndexWriter..::..IndexReaderWarmer
    Get
    Set
public:
virtual property IndexWriter..::..IndexReaderWarmer^ MergedSegmentWarmer {
    IndexWriter..::..IndexReaderWarmer^ get ();
    void set (IndexWriter..::..IndexReaderWarmer^ value);
}
public:
virtual property IndexWriter..::..IndexReaderWarmer^ MergedSegmentWarmer {
    IndexWriter..::..IndexReaderWarmer^ get ();
    void set (IndexWriter..::..IndexReaderWarmer^ value);
}
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergeFactor Property

IndexWriter MergeFactor Property Lucene.Net Class Library
Gets or sets the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index.

Determines how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained.

Note that this method is a convenience method: it just calls mergePolicy.setMergeFactor as long as mergePolicy is an instance of LogMergePolicy. Otherwise an IllegalArgumentException is thrown.

This must never be less than 2. The default value is 10.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int MergeFactor { get; set; }
public virtual int MergeFactor { get; set; }
Public Overridable Property MergeFactor As Integer
    Get
    Set
Public Overridable Property MergeFactor As Integer
    Get
    Set
public:
virtual property int MergeFactor {
    int get ();
    void set (int value);
}
public:
virtual property int MergeFactor {
    int get ();
    void set (int value);
}
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy Property

IndexWriter MergePolicy Property Lucene.Net Class Library
Expert: returns the current MergePolicy in use by this writer.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual MergePolicy MergePolicy { get; }
public virtual MergePolicy MergePolicy { get; }
Public Overridable ReadOnly Property MergePolicy As MergePolicy
    Get
Public Overridable ReadOnly Property MergePolicy As MergePolicy
    Get
public:
virtual property MergePolicy^ MergePolicy {
    MergePolicy^ get ();
}
public:
virtual property MergePolicy^ MergePolicy {
    MergePolicy^ get ();
}
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
IndexWriter SetMergePolicy(MergePolicy)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergeScheduler Property

IndexWriter MergeScheduler Property Lucene.Net Class Library
Expert: returns the current MergePolicy in use by this writer.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual MergeScheduler MergeScheduler { get; }
public virtual MergeScheduler MergeScheduler { get; }
Public Overridable ReadOnly Property MergeScheduler As MergeScheduler
    Get
Public Overridable ReadOnly Property MergeScheduler As MergeScheduler
    Get
public:
virtual property MergeScheduler^ MergeScheduler {
    MergeScheduler^ get ();
}
public:
virtual property MergeScheduler^ MergeScheduler {
    MergeScheduler^ get ();
}
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
IndexWriter SetMergePolicy(MergePolicy)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReaderTermsIndexDivisor Property

IndexWriter ReaderTermsIndexDivisor Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ReaderTermsIndexDivisor { get; set; }
public int ReaderTermsIndexDivisor { get; set; }
Public Property ReaderTermsIndexDivisor As Integer
    Get
    Set
Public Property ReaderTermsIndexDivisor As Integer
    Get
    Set
public:
property int ReaderTermsIndexDivisor {
    int get ();
    void set (int value);
}
public:
property int ReaderTermsIndexDivisor {
    int get ();
    void set (int value);
}
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Similarity Property

IndexWriter Similarity Property Lucene.Net Class Library
Expert: Return the Similarity implementation used by this IndexWriter.

This defaults to the current value of Default.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Similarity Similarity { get; }
public virtual Similarity Similarity { get; }
Public Overridable ReadOnly Property Similarity As Similarity
    Get
Public Overridable ReadOnly Property Similarity As Similarity
    Get
public:
virtual property Similarity^ Similarity {
    Similarity^ get ();
}
public:
virtual property Similarity^ Similarity {
    Similarity^ get ();
}
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermIndexInterval Property

IndexWriter TermIndexInterval Property Lucene.Net Class Library
Expert: Gets or sets the interval between indexed terms. Large values cause less memory to be used by IndexReader, but slow random-access to terms. Small values cause more memory to be used by an IndexReader, and speed random-access to terms. This parameter determines the amount of computation required per query term, regardless of the number of documents that contain that term. In particular, it is the maximum number of other terms that must be scanned before a term is located and its frequency and position information may be processed. In a large index with user-entered query terms, query processing time is likely to be dominated not by term lookup but rather by the processing of frequency and positional data. In a small index or when many uncommon query terms are generated (e.g., by wildcard queries) term lookup may become a dominant cost. In particular, numUniqueTerms/interval terms are read into memory by an IndexReader, and, on average, interval/2 terms must be scanned for each random term access.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int TermIndexInterval { get; set; }
public virtual int TermIndexInterval { get; set; }
Public Overridable Property TermIndexInterval As Integer
    Get
    Set
Public Overridable Property TermIndexInterval As Integer
    Get
    Set
public:
virtual property int TermIndexInterval {
    int get ();
    void set (int value);
}
public:
virtual property int TermIndexInterval {
    int get ();
    void set (int value);
}
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
IndexWriter DEFAULT_TERM_INDEX_INTERVAL
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UseCompoundFile Property

IndexWriter UseCompoundFile Property Lucene.Net Class Library

Gets or sets the current setting of whether newly flushed segments will use the compound file format. Note that this just returns the value previously set with setUseCompoundFile(boolean), or the default value (true). You cannot use this to query the status of previously flushed segments.

Note that this method is a convenience method: it just calls mergePolicy.getUseCompoundFile as long as mergePolicy is an instance of LogMergePolicy. Otherwise an IllegalArgumentException is thrown.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool UseCompoundFile { get; set; }
public virtual bool UseCompoundFile { get; set; }
Public Overridable Property UseCompoundFile As Boolean
    Get
    Set
Public Overridable Property UseCompoundFile As Boolean
    Get
    Set
public:
virtual property bool UseCompoundFile {
    bool get ();
    void set (bool value);
}
public:
virtual property bool UseCompoundFile {
    bool get ();
    void set (bool value);
}
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Verbose Property

IndexWriter Verbose Property Lucene.Net Class Library
Returns true if verbosing is enabled (i.e., infoStream != null).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Verbose { get; }
public virtual bool Verbose { get; }
Public Overridable ReadOnly Property Verbose As Boolean
    Get
Public Overridable ReadOnly Property Verbose As Boolean
    Get
public:
virtual property bool Verbose {
    bool get ();
}
public:
virtual property bool Verbose {
    bool get ();
}
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteLockTimeout Property

IndexWriter WriteLockTimeout Property Lucene.Net Class Library
Gets or sets allowed timeout when acquiring the write lock.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long WriteLockTimeout { get; set; }
public virtual long WriteLockTimeout { get; set; }
Public Overridable Property WriteLockTimeout As Long
    Get
    Set
Public Overridable Property WriteLockTimeout As Long
    Get
    Set
public:
virtual property long long WriteLockTimeout {
    long long get ();
    void set (long long value);
}
public:
virtual property long long WriteLockTimeout {
    long long get ();
    void set (long long value);
}
See Also
IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter.IndexReaderWarmer Class

IndexWriter IndexReaderWarmer Class Lucene.Net Class Library
If GetReader has been called (ie, this writer is in near real-time mode), then after a merge completes, this class can be invoked to warm the reader on the newly merged segment, before the merge commits. This is not required for near real-time search, but will reduce search latency on opening a new near real-time reader after a merge completes.

NOTE: This API is experimental and might change in incompatible ways in the next release.

NOTE: warm is called before any deletes have been carried over to the merged segment.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index IndexWriter IndexReaderWarmer

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class IndexReaderWarmer
public abstract class IndexReaderWarmer
Public MustInherit Class IndexReaderWarmer
Public MustInherit Class IndexReaderWarmer
public ref class IndexReaderWarmer abstract
public ref class IndexReaderWarmer abstract
See Also
IndexWriter IndexReaderWarmer Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter.IndexReaderWarmer Members

IndexWriter IndexReaderWarmer Members Lucene.Net Class Library

An IndexWriter creates and maintains an index.

The create argument to the constructor determines whether a new index is created, or whether an existing index is opened. Note that you can open an index with create=true even while readers are using the index. The old readers will continue to search the "point in time" snapshot they had opened, and won't see the newly created index until they re-open. There are also constructors with no create argument which will create a new index if there is not already an index at the provided path and otherwise open the existing index.

In either case, documents are added with AddDocument(Document) and removed with DeleteDocuments(Term) or DeleteDocuments(Query). A document can be updated with UpdateDocument(Term, Document) (which just deletes and then adds the entire document). When finished adding, deleting and updating documents, Close should be called.

These changes are buffered in memory and periodically flushed to the Directory (during the above method calls). A flush is triggered when there are enough buffered deletes (see SetMaxBufferedDeleteTerms(Int32)) or enough added documents since the last flush, whichever is sooner. For the added documents, flushing is triggered either by RAM usage of the documents (see SetRAMBufferSizeMB(Double)) or the number of added documents. The default is to flush when RAM usage hits 16 MB. For best indexing speed you should flush by RAM usage with a large RAM buffer. Note that flushing just moves the internal buffered state in IndexWriter into the index, but these changes are not visible to IndexReader until either Commit or Close is called. A flush may also trigger one or more segment merges which by default run with a background thread so as not to block the addDocument calls (see below for changing the MergeScheduler).

If an index will not have more documents added for a while and optimal search performance is desired, then either the full Optimize method or partial Optimize(Int32) method should be called before the index is closed.

Opening an IndexWriter creates a lock file for the directory in use. Trying to open another IndexWriter on the same directory will lead to a LockObtainFailedException. The LockObtainFailedException is also thrown if an IndexReader on the same directory is used to delete documents from the index.

Expert: IndexWriter allows an optional IndexDeletionPolicy implementation to be specified. You can use this to control when prior commits are deleted from the index. The default policy is KeepOnlyLastCommitDeletionPolicy which removes all prior commits as soon as a new commit is done (this matches behavior before 2.2). Creating your own policy can allow you to explicitly keep previous "point in time" commits alive in the index for some time, to allow readers to refresh to the new commit without having the old commit deleted out from under them. This is necessary on filesystems like NFS that do not support "delete on last close" semantics, which Lucene's "point in time" search normally relies on.

Expert: IndexWriter allows you to separately change the MergePolicy and the MergeScheduler. The MergePolicy is invoked whenever there are changes to the segments in the index. Its role is to select which merges to do, if any, and return a MergePolicy MergeSpecification describing the merges. It also selects merges to do for optimize(). (The default is LogByteSizeMergePolicy. Then, the MergeScheduler is invoked with the requested merges and it decides when and how to run the merges. The default is ConcurrentMergeScheduler.

NOTE: if you hit an OutOfMemoryError then IndexWriter will quietly record this fact and block all future segment commits. This is a defensive measure in case any internal state (buffered documents and deletions) were corrupted. Any subsequent calls to Commit will throw an IllegalStateException. The only course of action is to call Close , which internally will call Rollback , to undo any changes to the index since the last commit. You can also just call Rollback directly.

NOTE: IndexWriter instances are completely thread safe, meaning multiple threads can call any of its methods, concurrently. If your application requires external synchronization, you should not synchronize on the IndexWriter instance as this may cause deadlock; use your own (non-Lucene) objects instead.

NOTE: if you call Thread.Interrupt() on a thread that's within IndexWriter, IndexWriter will try to catch this (eg, if it's in a Wait() or Thread.Sleep()), and will then throw the unchecked exception Online ThreadInterruptedException and clear the interrupt status on the thread

The IndexWriter IndexReaderWarmer type exposes the following members.
Constructors
 | Name | Description
Protected method | IndexWriter IndexReaderWarmer | Initializes a new instance of the IndexWriter IndexReaderWarmer class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Warm |
Back to Top
See Also
IndexWriter IndexReaderWarmer Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter.IndexReaderWarmer Constructor

IndexWriter IndexReaderWarmer Constructor Lucene.Net Class Library
Initializes a new instance of the IndexWriter IndexReaderWarmer class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IndexReaderWarmer()
protected IndexReaderWarmer()
Protected Sub New
Protected Sub New
protected:
IndexReaderWarmer()
protected:
IndexReaderWarmer()
See Also
IndexWriter IndexReaderWarmer Class
IndexWriter IndexReaderWarmer Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter.IndexReaderWarmer Methods

IndexWriter IndexReaderWarmer Methods Lucene.Net Class Library
The IndexWriter IndexReaderWarmer type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Warm |
Back to Top
See Also
IndexWriter IndexReaderWarmer Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Warm Method

IndexWriter IndexReaderWarmer Warm Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Warm(
    IndexReader reader
)
public abstract void Warm(
    IndexReader reader
)
Public MustOverride Sub Warm ( _
    reader As IndexReader _
)
Public MustOverride Sub Warm ( _
    reader As IndexReader _
)
public:
virtual void Warm(
    IndexReader^ reader
) abstract
public:
virtual void Warm(
    IndexReader^ reader
) abstract
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
IndexWriter IndexReaderWarmer Class
IndexWriter IndexReaderWarmer Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter.MaxFieldLength Class

IndexWriter MaxFieldLength Class Lucene.Net Class Library
Specifies maximum field length (in number of tokens/terms) in IndexWriter constructors. SetMaxFieldLength(Int32) overrides the value set by the constructor.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index IndexWriter MaxFieldLength

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MaxFieldLength
public sealed class MaxFieldLength
Public NotInheritable Class MaxFieldLength
Public NotInheritable Class MaxFieldLength
public ref class MaxFieldLength sealed
public ref class MaxFieldLength sealed
See Also
IndexWriter MaxFieldLength Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter.MaxFieldLength Members

IndexWriter MaxFieldLength Members Lucene.Net Class Library

An IndexWriter creates and maintains an index.

The create argument to the constructor determines whether a new index is created, or whether an existing index is opened. Note that you can open an index with create=true even while readers are using the index. The old readers will continue to search the "point in time" snapshot they had opened, and won't see the newly created index until they re-open. There are also constructors with no create argument which will create a new index if there is not already an index at the provided path and otherwise open the existing index.

In either case, documents are added with AddDocument(Document) and removed with DeleteDocuments(Term) or DeleteDocuments(Query). A document can be updated with UpdateDocument(Term, Document) (which just deletes and then adds the entire document). When finished adding, deleting and updating documents, Close should be called.

These changes are buffered in memory and periodically flushed to the Directory (during the above method calls). A flush is triggered when there are enough buffered deletes (see SetMaxBufferedDeleteTerms(Int32)) or enough added documents since the last flush, whichever is sooner. For the added documents, flushing is triggered either by RAM usage of the documents (see SetRAMBufferSizeMB(Double)) or the number of added documents. The default is to flush when RAM usage hits 16 MB. For best indexing speed you should flush by RAM usage with a large RAM buffer. Note that flushing just moves the internal buffered state in IndexWriter into the index, but these changes are not visible to IndexReader until either Commit or Close is called. A flush may also trigger one or more segment merges which by default run with a background thread so as not to block the addDocument calls (see below for changing the MergeScheduler).

If an index will not have more documents added for a while and optimal search performance is desired, then either the full Optimize method or partial Optimize(Int32) method should be called before the index is closed.

Opening an IndexWriter creates a lock file for the directory in use. Trying to open another IndexWriter on the same directory will lead to a LockObtainFailedException. The LockObtainFailedException is also thrown if an IndexReader on the same directory is used to delete documents from the index.

Expert: IndexWriter allows an optional IndexDeletionPolicy implementation to be specified. You can use this to control when prior commits are deleted from the index. The default policy is KeepOnlyLastCommitDeletionPolicy which removes all prior commits as soon as a new commit is done (this matches behavior before 2.2). Creating your own policy can allow you to explicitly keep previous "point in time" commits alive in the index for some time, to allow readers to refresh to the new commit without having the old commit deleted out from under them. This is necessary on filesystems like NFS that do not support "delete on last close" semantics, which Lucene's "point in time" search normally relies on.

Expert: IndexWriter allows you to separately change the MergePolicy and the MergeScheduler. The MergePolicy is invoked whenever there are changes to the segments in the index. Its role is to select which merges to do, if any, and return a MergePolicy MergeSpecification describing the merges. It also selects merges to do for optimize(). (The default is LogByteSizeMergePolicy. Then, the MergeScheduler is invoked with the requested merges and it decides when and how to run the merges. The default is ConcurrentMergeScheduler.

NOTE: if you hit an OutOfMemoryError then IndexWriter will quietly record this fact and block all future segment commits. This is a defensive measure in case any internal state (buffered documents and deletions) were corrupted. Any subsequent calls to Commit will throw an IllegalStateException. The only course of action is to call Close , which internally will call Rollback , to undo any changes to the index since the last commit. You can also just call Rollback directly.

NOTE: IndexWriter instances are completely thread safe, meaning multiple threads can call any of its methods, concurrently. If your application requires external synchronization, you should not synchronize on the IndexWriter instance as this may cause deadlock; use your own (non-Lucene) objects instead.

NOTE: if you call Thread.Interrupt() on a thread that's within IndexWriter, IndexWriter will try to catch this (eg, if it's in a Wait() or Thread.Sleep()), and will then throw the unchecked exception Online ThreadInterruptedException and clear the interrupt status on the thread

The IndexWriter MaxFieldLength type exposes the following members.
Constructors
 | Name | Description
Public method | IndexWriter MaxFieldLength | Public constructor to allow users to specify the maximum field size limit.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Fields
Name | Description
LIMITED | Sets the maximum field length to DEFAULT_MAX_FIELD_LENGTH
UNLIMITED | Sets the maximum field length to Online MaxValue.
Back to Top
Properties
 | Name | Description
Public property | Limit |
Back to Top
See Also
IndexWriter MaxFieldLength Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter.MaxFieldLength Constructor

IndexWriter MaxFieldLength Constructor Lucene.Net Class Library
Public constructor to allow users to specify the maximum field size limit.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MaxFieldLength(
    int limit
)
public MaxFieldLength(
    int limit
)
Public Sub New ( _
    limit As Integer _
)
Public Sub New ( _
    limit As Integer _
)
public:
MaxFieldLength(
    int limit
)
public:
MaxFieldLength(
    int limit
)
Parameters
limit
Type:   Online System Int32
The maximum field length

See Also
IndexWriter MaxFieldLength Class
IndexWriter MaxFieldLength Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter.MaxFieldLength Fields

IndexWriter MaxFieldLength Fields Lucene.Net Class Library
The IndexWriter MaxFieldLength type exposes the following members.
Fields
Name | Description
LIMITED | Sets the maximum field length to DEFAULT_MAX_FIELD_LENGTH
UNLIMITED | Sets the maximum field length to Online MaxValue.
Back to Top
See Also
IndexWriter MaxFieldLength Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LIMITED Field

IndexWriter MaxFieldLength LIMITED Field Lucene.Net Class Library
Sets the maximum field length to DEFAULT_MAX_FIELD_LENGTH

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IndexWriter..::..MaxFieldLength LIMITED
public static readonly IndexWriter..::..MaxFieldLength LIMITED
Public Shared ReadOnly LIMITED As IndexWriter..::..MaxFieldLength
Public Shared ReadOnly LIMITED As IndexWriter..::..MaxFieldLength
public:
static initonly IndexWriter..::..MaxFieldLength^ LIMITED
public:
static initonly IndexWriter..::..MaxFieldLength^ LIMITED
See Also
IndexWriter MaxFieldLength Class
IndexWriter MaxFieldLength Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UNLIMITED Field

IndexWriter MaxFieldLength UNLIMITED Field Lucene.Net Class Library
Sets the maximum field length to Online MaxValue.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IndexWriter..::..MaxFieldLength UNLIMITED
public static readonly IndexWriter..::..MaxFieldLength UNLIMITED
Public Shared ReadOnly UNLIMITED As IndexWriter..::..MaxFieldLength
Public Shared ReadOnly UNLIMITED As IndexWriter..::..MaxFieldLength
public:
static initonly IndexWriter..::..MaxFieldLength^ UNLIMITED
public:
static initonly IndexWriter..::..MaxFieldLength^ UNLIMITED
See Also
IndexWriter MaxFieldLength Class
IndexWriter MaxFieldLength Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter.MaxFieldLength Methods

IndexWriter MaxFieldLength Methods Lucene.Net Class Library
The IndexWriter MaxFieldLength type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
IndexWriter MaxFieldLength Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

IndexWriter MaxFieldLength ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
IndexWriter MaxFieldLength Class
IndexWriter MaxFieldLength Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexWriter.MaxFieldLength Properties

IndexWriter MaxFieldLength Properties Lucene.Net Class Library
The IndexWriter MaxFieldLength type exposes the following members.
Properties
 | Name | Description
Public property | Limit |
Back to Top
See Also
IndexWriter MaxFieldLength Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Limit Property

IndexWriter MaxFieldLength Limit Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Limit { get; }
public int Limit { get; }
Public ReadOnly Property Limit As Integer
    Get
Public ReadOnly Property Limit As Integer
    Get
public:
property int Limit {
    int get ();
}
public:
property int Limit {
    int get ();
}
See Also
IndexWriter MaxFieldLength Class
IndexWriter MaxFieldLength Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ITermFreqVector Interface

ITermFreqVector Interface Lucene.Net Class Library
Provides access to stored term vector of a document field. The vector consists of the name of the field, an array of the terms tha occur in the field of the Document and a parallel array of frequencies. Thus, getTermFrequencies()[5] corresponds with the frequency of getTerms()[5], assuming there are at least 5 terms in the Document.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITermFreqVector
public interface ITermFreqVector
Public Interface ITermFreqVector
Public Interface ITermFreqVector
public interface class ITermFreqVector
public interface class ITermFreqVector
See Also
ITermFreqVector Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ITermFreqVector Members

ITermFreqVector Members Lucene.Net Class Library

The ITermFreqVector type exposes the following members.
Methods
 | Name | Description
Public method | GetTermFrequencies | Array of term frequencies. Locations of the array correspond one to one to the terms in the array obtained from getTerms method. Each location in the array contains the number of times this term occurs in the document or the document field.
Public method | GetTerms |
Public method | IndexesOf | Just like indexOf(int) but searches for a number of terms at the same time. Returns an array that has the same size as the number of terms searched for, each slot containing the result of searching for that term number.
Public method | IndexOf | Return an index in the term numbers array returned from getTerms at which the term with the specified term appears. If this term does not appear in the array, return -1.
Back to Top
Properties
 | Name | Description
Public property | Field | The IFieldable name.
Public property | Size |
Back to Top
See Also
ITermFreqVector Interface
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ITermFreqVector Methods

ITermFreqVector Methods Lucene.Net Class Library
The ITermFreqVector type exposes the following members.
Methods
 | Name | Description
Public method | GetTermFrequencies | Array of term frequencies. Locations of the array correspond one to one to the terms in the array obtained from getTerms method. Each location in the array contains the number of times this term occurs in the document or the document field.
Public method | GetTerms |
Public method | IndexesOf | Just like indexOf(int) but searches for a number of terms at the same time. Returns an array that has the same size as the number of terms searched for, each slot containing the result of searching for that term number.
Public method | IndexOf | Return an index in the term numbers array returned from getTerms at which the term with the specified term appears. If this term does not appear in the array, return -1.
Back to Top
See Also
ITermFreqVector Interface
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFrequencies Method

ITermFreqVector GetTermFrequencies Method Lucene.Net Class Library
Array of term frequencies. Locations of the array correspond one to one to the terms in the array obtained from getTerms method. Each location in the array contains the number of times this term occurs in the document or the document field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int[] GetTermFrequencies()
int[] GetTermFrequencies()
Function GetTermFrequencies As Integer()
Function GetTermFrequencies As Integer()
array<int>^ GetTermFrequencies()
array<int>^ GetTermFrequencies()
See Also
ITermFreqVector Interface
ITermFreqVector Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTerms Method

ITermFreqVector GetTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string[] GetTerms()
string[] GetTerms()
Function GetTerms As String()
Function GetTerms As String()
array<String^>^ GetTerms()
array<String^>^ GetTerms()
Return Value
 An Array of term texts in ascending order.

See Also
ITermFreqVector Interface
ITermFreqVector Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexesOf Method

ITermFreqVector IndexesOf Method Lucene.Net Class Library
Just like indexOf(int) but searches for a number of terms at the same time. Returns an array that has the same size as the number of terms searched for, each slot containing the result of searching for that term number.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int[] IndexesOf(
    string[] terms,
    int start,
    int len
)
int[] IndexesOf(
    string[] terms,
    int start,
    int len
)
Function IndexesOf ( _
    terms As String(), _
    start As Integer, _
    len As Integer _
) As Integer()
Function IndexesOf ( _
    terms As String(), _
    start As Integer, _
    len As Integer _
) As Integer()
array<int>^ IndexesOf(
    array<String^>^ terms,
    int start,
    int len
)
array<int>^ IndexesOf(
    array<String^>^ terms,
    int start,
    int len
)
Parameters
terms
Type:    Online System String
array containing terms to look for

start
Type:   Online System Int32
index in the array where the list of terms starts

len
Type:   Online System Int32
the number of terms in the list

See Also
ITermFreqVector Interface
ITermFreqVector Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexOf Method

ITermFreqVector IndexOf Method Lucene.Net Class Library
Return an index in the term numbers array returned from getTerms at which the term with the specified term appears. If this term does not appear in the array, return -1.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int IndexOf(
    string term
)
int IndexOf(
    string term
)
Function IndexOf ( _
    term As String _
) As Integer
Function IndexOf ( _
    term As String _
) As Integer
int IndexOf(
    String^ term
)
int IndexOf(
    String^ term
)
Parameters
term
Type:   Online System String
See Also
ITermFreqVector Interface
ITermFreqVector Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ITermFreqVector Properties

ITermFreqVector Properties Lucene.Net Class Library
The ITermFreqVector type exposes the following members.
Properties
 | Name | Description
Public property | Field | The IFieldable name.
Public property | Size |
Back to Top
See Also
ITermFreqVector Interface
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

ITermFreqVector Field Property Lucene.Net Class Library
The IFieldable name.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Field { get; }
string Field { get; }
ReadOnly Property Field As String
    Get
ReadOnly Property Field As String
    Get
property String^ Field {
    String^ get ();
}
property String^ Field {
    String^ get ();
}
Field Value
 The name of the field this vector is associated with.
See Also
ITermFreqVector Interface
ITermFreqVector Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Size Property

ITermFreqVector Size Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int Size { get; }
int Size { get; }
ReadOnly Property Size As Integer
    Get
ReadOnly Property Size As Integer
    Get
property int Size {
    int get ();
}
property int Size {
    int get ();
}
Field Value
 The number of terms in the term vector.
See Also
ITermFreqVector Interface
ITermFreqVector Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeepOnlyLastCommitDeletionPolicy Class

KeepOnlyLastCommitDeletionPolicy Class Lucene.Net Class Library
This IndexDeletionPolicy implementation that keeps only the most recent commit and immediately removes all prior commits after a new commit is done. This is the default deletion policy.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index KeepOnlyLastCommitDeletionPolicy

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class KeepOnlyLastCommitDeletionPolicy : IndexDeletionPolicy
public sealed class KeepOnlyLastCommitDeletionPolicy : IndexDeletionPolicy
Public NotInheritable Class KeepOnlyLastCommitDeletionPolicy _
    Implements IndexDeletionPolicy
Public NotInheritable Class KeepOnlyLastCommitDeletionPolicy _
    Implements IndexDeletionPolicy
public ref class KeepOnlyLastCommitDeletionPolicy sealed : IndexDeletionPolicy
public ref class KeepOnlyLastCommitDeletionPolicy sealed : IndexDeletionPolicy
See Also
KeepOnlyLastCommitDeletionPolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeepOnlyLastCommitDeletionPolicy Members

KeepOnlyLastCommitDeletionPolicy Members Lucene.Net Class Library

The KeepOnlyLastCommitDeletionPolicy type exposes the following members.
Constructors
 | Name | Description
Public method | KeepOnlyLastCommitDeletionPolicy | Initializes a new instance of the KeepOnlyLastCommitDeletionPolicy class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OnCommit T | Deletes all commits except the most recent one.
Public method | OnInit T | Deletes all commits except the most recent one.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
KeepOnlyLastCommitDeletionPolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeepOnlyLastCommitDeletionPolicy Constructor

KeepOnlyLastCommitDeletionPolicy Constructor Lucene.Net Class Library
Initializes a new instance of the KeepOnlyLastCommitDeletionPolicy class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public KeepOnlyLastCommitDeletionPolicy()
public KeepOnlyLastCommitDeletionPolicy()
Public Sub New
Public Sub New
public:
KeepOnlyLastCommitDeletionPolicy()
public:
KeepOnlyLastCommitDeletionPolicy()
See Also
KeepOnlyLastCommitDeletionPolicy Class
KeepOnlyLastCommitDeletionPolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeepOnlyLastCommitDeletionPolicy Methods

KeepOnlyLastCommitDeletionPolicy Methods Lucene.Net Class Library
The KeepOnlyLastCommitDeletionPolicy type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OnCommit T | Deletes all commits except the most recent one.
Public method | OnInit T | Deletes all commits except the most recent one.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
KeepOnlyLastCommitDeletionPolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OnCommit(T) Method

KeepOnlyLastCommitDeletionPolicy OnCommit T Method Lucene.Net Class Library
Deletes all commits except the most recent one.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void OnCommit<T>(
    IList<T> commits
)
where T : IndexCommit
public void OnCommit<T>(
    IList<T> commits
)
where T : IndexCommit
Public Sub OnCommit(Of T As IndexCommit) ( _
    commits As IList(Of T) _
)
Public Sub OnCommit(Of T As IndexCommit) ( _
    commits As IList(Of T) _
)
public:
generic<typename T>
where T : IndexCommit
virtual void OnCommit(
    IList<T>^ commits
) sealed
public:
generic<typename T>
where T : IndexCommit
virtual void OnCommit(
    IList<T>^ commits
) sealed
Parameters
commits
Type:   Online System.Collections.Generic IList  T
Type Parameters
T
Implements
IndexDeletionPolicy OnCommit T (IList T )
See Also
KeepOnlyLastCommitDeletionPolicy Class
KeepOnlyLastCommitDeletionPolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OnInit(T) Method

KeepOnlyLastCommitDeletionPolicy OnInit T Method Lucene.Net Class Library
Deletes all commits except the most recent one.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void OnInit<T>(
    IList<T> commits
)
where T : IndexCommit
public void OnInit<T>(
    IList<T> commits
)
where T : IndexCommit
Public Sub OnInit(Of T As IndexCommit) ( _
    commits As IList(Of T) _
)
Public Sub OnInit(Of T As IndexCommit) ( _
    commits As IList(Of T) _
)
public:
generic<typename T>
where T : IndexCommit
virtual void OnInit(
    IList<T>^ commits
) sealed
public:
generic<typename T>
where T : IndexCommit
virtual void OnInit(
    IList<T>^ commits
) sealed
Parameters
commits
Type:   Online System.Collections.Generic IList  T
Type Parameters
T
Implements
IndexDeletionPolicy OnInit T (IList T )
See Also
KeepOnlyLastCommitDeletionPolicy Class
KeepOnlyLastCommitDeletionPolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogByteSizeMergePolicy Class

LogByteSizeMergePolicy Class Lucene.Net Class Library
This is a LogMergePolicy that measures size of a segment as the total byte size of the segment's files.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index MergePolicy
Lucene.Net.Index LogMergePolicy
Lucene.Net.Index LogByteSizeMergePolicy

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LogByteSizeMergePolicy : LogMergePolicy
public class LogByteSizeMergePolicy : LogMergePolicy
Public Class LogByteSizeMergePolicy _
    Inherits LogMergePolicy
Public Class LogByteSizeMergePolicy _
    Inherits LogMergePolicy
public ref class LogByteSizeMergePolicy : public LogMergePolicy
public ref class LogByteSizeMergePolicy : public LogMergePolicy
See Also
LogByteSizeMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogByteSizeMergePolicy Members

LogByteSizeMergePolicy Members Lucene.Net Class Library

The LogByteSizeMergePolicy type exposes the following members.
Constructors
 | Name | Description
Public method | LogByteSizeMergePolicy | Initializes a new instance of the LogByteSizeMergePolicy class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Release all resources for the policy. (Inherited from MergePolicy.)
Public method | Dispose | Release all resources for the policy. (Inherited from MergePolicy.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the LogByteSizeMergePolicy and optionally releases the managed resources (Overrides MergePolicy Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindMerges | Checks if any merges are now necessary and returns a MergePolicy MergeSpecification if so. A merge is necessary when there are more than MergeFactor segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the MergeScheduler to use concurrency. (Inherited from LogMergePolicy.)
Public method | FindMergesForOptimize | Returns the merges necessary to optimize the index. This merge policy defines "optimized" to mean only one segment in the index, where that segment has no deletions pending nor separate norms, and it is in compound file format if the current useCompoundFile setting is true. This method returns multiple merges (mergeFactor at a time) so the MergeScheduler in use may make use of concurrency. (Inherited from LogMergePolicy.)
Public method | FindMergesToExpungeDeletes | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time. (Inherited from LogMergePolicy.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUseCompoundDocStore | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields) (Inherited from LogMergePolicy.)
Public method | GetUseCompoundFile | (Inherited from LogMergePolicy.)
Protected method | MakeOneMerge | (Inherited from LogMergePolicy.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetUseCompoundDocStore | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields). (Inherited from LogMergePolicy.)
Public method | SetUseCompoundFile | Gets or sets whether compound file format should be used for newly flushed and newly merged segments. (Inherited from LogMergePolicy.)
Protected method | Size | (Overrides LogMergePolicy Size(SegmentInfo).)
Protected method | SizeBytes | (Inherited from LogMergePolicy.)
Protected method | SizeDocs | (Inherited from LogMergePolicy.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UseCompoundDocStore | (Inherited from LogMergePolicy.)
Public method | UseCompoundFile | (Inherited from LogMergePolicy.)
Protected method | Verbose | (Inherited from LogMergePolicy.)
Back to Top
Fields
 | Name | Description
 | DEFAULT_MAX_MERGE_MB | Default maximum segment size. A segment of this size
 | DEFAULT_MIN_MERGE_MB |
Protected field | internalCalibrateSizeByDeletes | (Inherited from LogMergePolicy.)
Protected field | internalNoCFSRatio | (Inherited from LogMergePolicy.)
Protected field | writer | (Inherited from MergePolicy.)
Back to Top
Properties
 | Name | Description
Public property | CalibrateSizeByDeletes | Gets or sets whether the segment size should be calibrated by the number of deletes when choosing segments for merge. (Inherited from LogMergePolicy.)
Public property | MaxMergeDocs | Gets or sets the largest segment (measured by document count) that may be merged with other segments. Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is Online MaxValue. The default merge policy (LogByteSizeMergePolicy) also allows you to set this limit by net size (in MB) of the segment, using MaxMergeMB. (Inherited from LogMergePolicy.)
Public property | MaxMergeMB | Gets or sets the largest segment (measured by total byte size of the segment's files, in MB) that may be merged with other segments. Small values (e.g., less than 50 MB) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. Note that MaxMergeDocs is also used to check whether a segment is too large for merging (it's either or).
Public property | MergeFactor | Gets or sets how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained. (Inherited from LogMergePolicy.)
Public property | MinMergeMB | Gets or sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).
Public property | NoCFSRatio | (Inherited from LogMergePolicy.)
Back to Top
See Also
LogByteSizeMergePolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogByteSizeMergePolicy Constructor

LogByteSizeMergePolicy Constructor Lucene.Net Class Library
Initializes a new instance of the LogByteSizeMergePolicy class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogByteSizeMergePolicy(
    IndexWriter writer
)
public LogByteSizeMergePolicy(
    IndexWriter writer
)
Public Sub New ( _
    writer As IndexWriter _
)
Public Sub New ( _
    writer As IndexWriter _
)
public:
LogByteSizeMergePolicy(
    IndexWriter^ writer
)
public:
LogByteSizeMergePolicy(
    IndexWriter^ writer
)
Parameters
writer
Type: Lucene.Net.Index IndexWriter
See Also
LogByteSizeMergePolicy Class
LogByteSizeMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogByteSizeMergePolicy Fields

LogByteSizeMergePolicy Fields Lucene.Net Class Library
The LogByteSizeMergePolicy type exposes the following members.
Fields
 | Name | Description
 | DEFAULT_MAX_MERGE_MB | Default maximum segment size. A segment of this size
 | DEFAULT_MIN_MERGE_MB |
Protected field | internalCalibrateSizeByDeletes | (Inherited from LogMergePolicy.)
Protected field | internalNoCFSRatio | (Inherited from LogMergePolicy.)
Protected field | writer | (Inherited from MergePolicy.)
Back to Top
See Also
LogByteSizeMergePolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_MAX_MERGE_MB Field

LogByteSizeMergePolicy DEFAULT_MAX_MERGE_MB Field Lucene.Net Class Library
Default maximum segment size. A segment of this size

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly long DEFAULT_MAX_MERGE_MB
public static readonly long DEFAULT_MAX_MERGE_MB
Public Shared ReadOnly DEFAULT_MAX_MERGE_MB As Long
Public Shared ReadOnly DEFAULT_MAX_MERGE_MB As Long
public:
static initonly long long DEFAULT_MAX_MERGE_MB
public:
static initonly long long DEFAULT_MAX_MERGE_MB
See Also
LogByteSizeMergePolicy Class
LogByteSizeMergePolicy Members
Lucene.Net.Index Namespace
LogByteSizeMergePolicy MaxMergeMB
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_MIN_MERGE_MB Field

LogByteSizeMergePolicy DEFAULT_MIN_MERGE_MB Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double DEFAULT_MIN_MERGE_MB
public const double DEFAULT_MIN_MERGE_MB
Public Const DEFAULT_MIN_MERGE_MB As Double
Public Const DEFAULT_MIN_MERGE_MB As Double
public:
literal double DEFAULT_MIN_MERGE_MB
public:
literal double DEFAULT_MIN_MERGE_MB
See Also
LogByteSizeMergePolicy Class
LogByteSizeMergePolicy Members
Lucene.Net.Index Namespace
LogByteSizeMergePolicy MinMergeMB
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogByteSizeMergePolicy Methods

LogByteSizeMergePolicy Methods Lucene.Net Class Library
The LogByteSizeMergePolicy type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Release all resources for the policy. (Inherited from MergePolicy.)
Public method | Dispose | Release all resources for the policy. (Inherited from MergePolicy.)
Protected method | Dispose(Boolean) | (Overrides MergePolicy Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindMerges | Checks if any merges are now necessary and returns a MergePolicy MergeSpecification if so. A merge is necessary when there are more than MergeFactor segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the MergeScheduler to use concurrency. (Inherited from LogMergePolicy.)
Public method | FindMergesForOptimize | Returns the merges necessary to optimize the index. This merge policy defines "optimized" to mean only one segment in the index, where that segment has no deletions pending nor separate norms, and it is in compound file format if the current useCompoundFile setting is true. This method returns multiple merges (mergeFactor at a time) so the MergeScheduler in use may make use of concurrency. (Inherited from LogMergePolicy.)
Public method | FindMergesToExpungeDeletes | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time. (Inherited from LogMergePolicy.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUseCompoundDocStore | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields) (Inherited from LogMergePolicy.)
Public method | GetUseCompoundFile | (Inherited from LogMergePolicy.)
Protected method | MakeOneMerge | (Inherited from LogMergePolicy.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetUseCompoundDocStore | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields). (Inherited from LogMergePolicy.)
Public method | SetUseCompoundFile | Gets or sets whether compound file format should be used for newly flushed and newly merged segments. (Inherited from LogMergePolicy.)
Protected method | Size | (Overrides LogMergePolicy Size(SegmentInfo).)
Protected method | SizeBytes | (Inherited from LogMergePolicy.)
Protected method | SizeDocs | (Inherited from LogMergePolicy.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UseCompoundDocStore | (Inherited from LogMergePolicy.)
Public method | UseCompoundFile | (Inherited from LogMergePolicy.)
Protected method | Verbose | (Inherited from LogMergePolicy.)
Back to Top
See Also
LogByteSizeMergePolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

LogByteSizeMergePolicy Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Release all resources for the policy. (Inherited from MergePolicy.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the LogByteSizeMergePolicy and optionally releases the managed resources (Overrides MergePolicy Dispose(Boolean).)
Back to Top
See Also
LogByteSizeMergePolicy Class
LogByteSizeMergePolicy Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

LogByteSizeMergePolicy Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the LogByteSizeMergePolicy and optionally releases the managed resources

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
LogByteSizeMergePolicy Class
LogByteSizeMergePolicy Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Size Method

LogByteSizeMergePolicy Size Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override long Size(
    SegmentInfo info
)
protected override long Size(
    SegmentInfo info
)
Protected Overrides Function Size ( _
    info As SegmentInfo _
) As Long
Protected Overrides Function Size ( _
    info As SegmentInfo _
) As Long
protected:
virtual long long Size(
    SegmentInfo^ info
) override
protected:
virtual long long Size(
    SegmentInfo^ info
) override
Parameters
info
Type: Lucene.Net.Index SegmentInfo
See Also
LogByteSizeMergePolicy Class
LogByteSizeMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogByteSizeMergePolicy Properties

LogByteSizeMergePolicy Properties Lucene.Net Class Library
The LogByteSizeMergePolicy type exposes the following members.
Properties
 | Name | Description
Public property | CalibrateSizeByDeletes | Gets or sets whether the segment size should be calibrated by the number of deletes when choosing segments for merge. (Inherited from LogMergePolicy.)
Public property | MaxMergeDocs | Gets or sets the largest segment (measured by document count) that may be merged with other segments. Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is Online MaxValue. The default merge policy (LogByteSizeMergePolicy) also allows you to set this limit by net size (in MB) of the segment, using MaxMergeMB. (Inherited from LogMergePolicy.)
Public property | MaxMergeMB | Gets or sets the largest segment (measured by total byte size of the segment's files, in MB) that may be merged with other segments. Small values (e.g., less than 50 MB) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. Note that MaxMergeDocs is also used to check whether a segment is too large for merging (it's either or).
Public property | MergeFactor | Gets or sets how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained. (Inherited from LogMergePolicy.)
Public property | MinMergeMB | Gets or sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).
Public property | NoCFSRatio | (Inherited from LogMergePolicy.)
Back to Top
See Also
LogByteSizeMergePolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxMergeMB Property

LogByteSizeMergePolicy MaxMergeMB Property Lucene.Net Class Library

Gets or sets the largest segment (measured by total byte size of the segment's files, in MB) that may be merged with other segments. Small values (e.g., less than 50 MB) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches.

Note that MaxMergeDocs is also used to check whether a segment is too large for merging (it's either or).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual double MaxMergeMB { get; set; }
public virtual double MaxMergeMB { get; set; }
Public Overridable Property MaxMergeMB As Double
    Get
    Set
Public Overridable Property MaxMergeMB As Double
    Get
    Set
public:
virtual property double MaxMergeMB {
    double get ();
    void set (double value);
}
public:
virtual property double MaxMergeMB {
    double get ();
    void set (double value);
}
See Also
LogByteSizeMergePolicy Class
LogByteSizeMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MinMergeMB Property

LogByteSizeMergePolicy MinMergeMB Property Lucene.Net Class Library
Gets or sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual double MinMergeMB { get; set; }
public virtual double MinMergeMB { get; set; }
Public Overridable Property MinMergeMB As Double
    Get
    Set
Public Overridable Property MinMergeMB As Double
    Get
    Set
public:
virtual property double MinMergeMB {
    double get ();
    void set (double value);
}
public:
virtual property double MinMergeMB {
    double get ();
    void set (double value);
}
See Also
LogByteSizeMergePolicy Class
LogByteSizeMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogDocMergePolicy Class

LogDocMergePolicy Class Lucene.Net Class Library
This is a LogMergePolicy that measures size of a segment as the number of documents (not taking deletions into account).
Inheritance Hierarchy
Online System Object
Lucene.Net.Index MergePolicy
Lucene.Net.Index LogMergePolicy
Lucene.Net.Index LogDocMergePolicy

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LogDocMergePolicy : LogMergePolicy
public class LogDocMergePolicy : LogMergePolicy
Public Class LogDocMergePolicy _
    Inherits LogMergePolicy
Public Class LogDocMergePolicy _
    Inherits LogMergePolicy
public ref class LogDocMergePolicy : public LogMergePolicy
public ref class LogDocMergePolicy : public LogMergePolicy
See Also
LogDocMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogDocMergePolicy Members

LogDocMergePolicy Members Lucene.Net Class Library

The LogDocMergePolicy type exposes the following members.
Constructors
 | Name | Description
Public method | LogDocMergePolicy | Initializes a new instance of the LogDocMergePolicy class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Release all resources for the policy. (Inherited from MergePolicy.)
Public method | Dispose | Release all resources for the policy. (Inherited from MergePolicy.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the LogDocMergePolicy and optionally releases the managed resources (Overrides MergePolicy Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindMerges | Checks if any merges are now necessary and returns a MergePolicy MergeSpecification if so. A merge is necessary when there are more than MergeFactor segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the MergeScheduler to use concurrency. (Inherited from LogMergePolicy.)
Public method | FindMergesForOptimize | Returns the merges necessary to optimize the index. This merge policy defines "optimized" to mean only one segment in the index, where that segment has no deletions pending nor separate norms, and it is in compound file format if the current useCompoundFile setting is true. This method returns multiple merges (mergeFactor at a time) so the MergeScheduler in use may make use of concurrency. (Inherited from LogMergePolicy.)
Public method | FindMergesToExpungeDeletes | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time. (Inherited from LogMergePolicy.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUseCompoundDocStore | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields) (Inherited from LogMergePolicy.)
Public method | GetUseCompoundFile | (Inherited from LogMergePolicy.)
Protected method | MakeOneMerge | (Inherited from LogMergePolicy.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetUseCompoundDocStore | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields). (Inherited from LogMergePolicy.)
Public method | SetUseCompoundFile | Gets or sets whether compound file format should be used for newly flushed and newly merged segments. (Inherited from LogMergePolicy.)
Protected method | Size | (Overrides LogMergePolicy Size(SegmentInfo).)
Protected method | SizeBytes | (Inherited from LogMergePolicy.)
Protected method | SizeDocs | (Inherited from LogMergePolicy.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UseCompoundDocStore | (Inherited from LogMergePolicy.)
Public method | UseCompoundFile | (Inherited from LogMergePolicy.)
Protected method | Verbose | (Inherited from LogMergePolicy.)
Back to Top
Fields
 | Name | Description
 | DEFAULT_MIN_MERGE_DOCS |
Protected field | internalCalibrateSizeByDeletes | (Inherited from LogMergePolicy.)
Protected field | internalNoCFSRatio | (Inherited from LogMergePolicy.)
Protected field | writer | (Inherited from MergePolicy.)
Back to Top
Properties
 | Name | Description
Public property | CalibrateSizeByDeletes | Gets or sets whether the segment size should be calibrated by the number of deletes when choosing segments for merge. (Inherited from LogMergePolicy.)
Public property | MaxMergeDocs | Gets or sets the largest segment (measured by document count) that may be merged with other segments. Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is Online MaxValue. The default merge policy (LogByteSizeMergePolicy) also allows you to set this limit by net size (in MB) of the segment, using MaxMergeMB. (Inherited from LogMergePolicy.)
Public property | MergeFactor | Gets or sets how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained. (Inherited from LogMergePolicy.)
Public property | MinMergeDocs | Gets or sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).
Public property | NoCFSRatio | (Inherited from LogMergePolicy.)
Back to Top
See Also
LogDocMergePolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogDocMergePolicy Constructor

LogDocMergePolicy Constructor Lucene.Net Class Library
Initializes a new instance of the LogDocMergePolicy class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogDocMergePolicy(
    IndexWriter writer
)
public LogDocMergePolicy(
    IndexWriter writer
)
Public Sub New ( _
    writer As IndexWriter _
)
Public Sub New ( _
    writer As IndexWriter _
)
public:
LogDocMergePolicy(
    IndexWriter^ writer
)
public:
LogDocMergePolicy(
    IndexWriter^ writer
)
Parameters
writer
Type: Lucene.Net.Index IndexWriter
See Also
LogDocMergePolicy Class
LogDocMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogDocMergePolicy Fields

LogDocMergePolicy Fields Lucene.Net Class Library
The LogDocMergePolicy type exposes the following members.
Fields
 | Name | Description
 | DEFAULT_MIN_MERGE_DOCS |
Protected field | internalCalibrateSizeByDeletes | (Inherited from LogMergePolicy.)
Protected field | internalNoCFSRatio | (Inherited from LogMergePolicy.)
Protected field | writer | (Inherited from MergePolicy.)
Back to Top
See Also
LogDocMergePolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_MIN_MERGE_DOCS Field

LogDocMergePolicy DEFAULT_MIN_MERGE_DOCS Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_MIN_MERGE_DOCS
public const int DEFAULT_MIN_MERGE_DOCS
Public Const DEFAULT_MIN_MERGE_DOCS As Integer
Public Const DEFAULT_MIN_MERGE_DOCS As Integer
public:
literal int DEFAULT_MIN_MERGE_DOCS
public:
literal int DEFAULT_MIN_MERGE_DOCS
See Also
LogDocMergePolicy Class
LogDocMergePolicy Members
Lucene.Net.Index Namespace
LogDocMergePolicy MinMergeDocs
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogDocMergePolicy Methods

LogDocMergePolicy Methods Lucene.Net Class Library
The LogDocMergePolicy type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Release all resources for the policy. (Inherited from MergePolicy.)
Public method | Dispose | Release all resources for the policy. (Inherited from MergePolicy.)
Protected method | Dispose(Boolean) | (Overrides MergePolicy Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindMerges | Checks if any merges are now necessary and returns a MergePolicy MergeSpecification if so. A merge is necessary when there are more than MergeFactor segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the MergeScheduler to use concurrency. (Inherited from LogMergePolicy.)
Public method | FindMergesForOptimize | Returns the merges necessary to optimize the index. This merge policy defines "optimized" to mean only one segment in the index, where that segment has no deletions pending nor separate norms, and it is in compound file format if the current useCompoundFile setting is true. This method returns multiple merges (mergeFactor at a time) so the MergeScheduler in use may make use of concurrency. (Inherited from LogMergePolicy.)
Public method | FindMergesToExpungeDeletes | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time. (Inherited from LogMergePolicy.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUseCompoundDocStore | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields) (Inherited from LogMergePolicy.)
Public method | GetUseCompoundFile | (Inherited from LogMergePolicy.)
Protected method | MakeOneMerge | (Inherited from LogMergePolicy.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetUseCompoundDocStore | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields). (Inherited from LogMergePolicy.)
Public method | SetUseCompoundFile | Gets or sets whether compound file format should be used for newly flushed and newly merged segments. (Inherited from LogMergePolicy.)
Protected method | Size | (Overrides LogMergePolicy Size(SegmentInfo).)
Protected method | SizeBytes | (Inherited from LogMergePolicy.)
Protected method | SizeDocs | (Inherited from LogMergePolicy.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UseCompoundDocStore | (Inherited from LogMergePolicy.)
Public method | UseCompoundFile | (Inherited from LogMergePolicy.)
Protected method | Verbose | (Inherited from LogMergePolicy.)
Back to Top
See Also
LogDocMergePolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

LogDocMergePolicy Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Release all resources for the policy. (Inherited from MergePolicy.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the LogDocMergePolicy and optionally releases the managed resources (Overrides MergePolicy Dispose(Boolean).)
Back to Top
See Also
LogDocMergePolicy Class
LogDocMergePolicy Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

LogDocMergePolicy Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the LogDocMergePolicy and optionally releases the managed resources

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
LogDocMergePolicy Class
LogDocMergePolicy Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Size Method

LogDocMergePolicy Size Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override long Size(
    SegmentInfo info
)
protected override long Size(
    SegmentInfo info
)
Protected Overrides Function Size ( _
    info As SegmentInfo _
) As Long
Protected Overrides Function Size ( _
    info As SegmentInfo _
) As Long
protected:
virtual long long Size(
    SegmentInfo^ info
) override
protected:
virtual long long Size(
    SegmentInfo^ info
) override
Parameters
info
Type: Lucene.Net.Index SegmentInfo
See Also
LogDocMergePolicy Class
LogDocMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogDocMergePolicy Properties

LogDocMergePolicy Properties Lucene.Net Class Library
The LogDocMergePolicy type exposes the following members.
Properties
 | Name | Description
Public property | CalibrateSizeByDeletes | Gets or sets whether the segment size should be calibrated by the number of deletes when choosing segments for merge. (Inherited from LogMergePolicy.)
Public property | MaxMergeDocs | Gets or sets the largest segment (measured by document count) that may be merged with other segments. Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is Online MaxValue. The default merge policy (LogByteSizeMergePolicy) also allows you to set this limit by net size (in MB) of the segment, using MaxMergeMB. (Inherited from LogMergePolicy.)
Public property | MergeFactor | Gets or sets how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained. (Inherited from LogMergePolicy.)
Public property | MinMergeDocs | Gets or sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).
Public property | NoCFSRatio | (Inherited from LogMergePolicy.)
Back to Top
See Also
LogDocMergePolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MinMergeDocs Property

LogDocMergePolicy MinMergeDocs Property Lucene.Net Class Library
Gets or sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int MinMergeDocs { get; set; }
public virtual int MinMergeDocs { get; set; }
Public Overridable Property MinMergeDocs As Integer
    Get
    Set
Public Overridable Property MinMergeDocs As Integer
    Get
    Set
public:
virtual property int MinMergeDocs {
    int get ();
    void set (int value);
}
public:
virtual property int MinMergeDocs {
    int get ();
    void set (int value);
}
See Also
LogDocMergePolicy Class
LogDocMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogMergePolicy Class

LogMergePolicy Class Lucene.Net Class Library

This class implements a MergePolicy that tries to merge segments into levels of exponentially increasing size, where each level has fewer segments than the value of the merge factor. Whenever extra segments (beyond the merge factor upper bound) are encountered, all segments within the level are merged. You can get or set the merge factor using MergeFactor and MergeFactor respectively.

This class is abstract and requires a subclass to define the Size(SegmentInfo) method which specifies how a segment's size is determined. LogDocMergePolicy is one subclass that measures size by document count in the segment. LogByteSizeMergePolicy is another subclass that measures size as the total byte size of the file(s) for the segment.

Inheritance Hierarchy
Online System Object
Lucene.Net.Index MergePolicy
Lucene.Net.Index LogMergePolicy
Lucene.Net.Index LogByteSizeMergePolicy
Lucene.Net.Index LogDocMergePolicy

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class LogMergePolicy : MergePolicy
public abstract class LogMergePolicy : MergePolicy
Public MustInherit Class LogMergePolicy _
    Inherits MergePolicy
Public MustInherit Class LogMergePolicy _
    Inherits MergePolicy
public ref class LogMergePolicy abstract : public MergePolicy
public ref class LogMergePolicy abstract : public MergePolicy
See Also
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogMergePolicy Members

LogMergePolicy Members Lucene.Net Class Library

The LogMergePolicy type exposes the following members.
Constructors
 | Name | Description
Protected method | LogMergePolicy | Initializes a new instance of the LogMergePolicy class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Release all resources for the policy. (Inherited from MergePolicy.)
Public method | Dispose | Release all resources for the policy. (Inherited from MergePolicy.)
Protected method | Dispose(Boolean) | (Inherited from MergePolicy.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindMerges | Checks if any merges are now necessary and returns a MergePolicy MergeSpecification if so. A merge is necessary when there are more than MergeFactor segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the MergeScheduler to use concurrency. (Overrides MergePolicy FindMerges(SegmentInfos).)
Public method | FindMergesForOptimize | Returns the merges necessary to optimize the index. This merge policy defines "optimized" to mean only one segment in the index, where that segment has no deletions pending nor separate norms, and it is in compound file format if the current useCompoundFile setting is true. This method returns multiple merges (mergeFactor at a time) so the MergeScheduler in use may make use of concurrency. (Overrides MergePolicy FindMergesForOptimize(SegmentInfos, Int32, ISet SegmentInfo ).)
Public method | FindMergesToExpungeDeletes | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time. (Overrides MergePolicy FindMergesToExpungeDeletes(SegmentInfos).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUseCompoundDocStore | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields)
Public method | GetUseCompoundFile |
Protected method | MakeOneMerge |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetUseCompoundDocStore | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields).
Public method | SetUseCompoundFile | Gets or sets whether compound file format should be used for newly flushed and newly merged segments.
Protected method | Size |
Protected method | SizeBytes |
Protected method | SizeDocs |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UseCompoundDocStore | (Overrides MergePolicy UseCompoundDocStore(SegmentInfos).)
Public method | UseCompoundFile | (Overrides MergePolicy UseCompoundFile(SegmentInfos, SegmentInfo).)
Protected method | Verbose |
Back to Top
Fields
 | Name | Description
 | DEFAULT_MAX_MERGE_DOCS | Default maximum segment size. A segment of this size
 | DEFAULT_MERGE_FACTOR | Default merge factor, which is how many segments are merged at a time
 | DEFAULT_NO_CFS_RATIO | Default noCFSRatio. If a merge's size is >= 10% of the index, then we disable compound file for it. See NoCFSRatio
Protected field | internalCalibrateSizeByDeletes |
Protected field | internalNoCFSRatio |
 | LEVEL_LOG_SPAN | Defines the allowed range of log(size) for each level. A level is computed by taking the max segment log size, minus LEVEL_LOG_SPAN, and finding all segments falling within that range.
Protected field | writer | (Inherited from MergePolicy.)
Back to Top
Properties
 | Name | Description
Public property | CalibrateSizeByDeletes | Gets or sets whether the segment size should be calibrated by the number of deletes when choosing segments for merge.
Public property | MaxMergeDocs | Gets or sets the largest segment (measured by document count) that may be merged with other segments. Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is Online MaxValue. The default merge policy (LogByteSizeMergePolicy) also allows you to set this limit by net size (in MB) of the segment, using MaxMergeMB.
Public property | MergeFactor | Gets or sets how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained.
Public property | NoCFSRatio |
Back to Top
See Also
LogMergePolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogMergePolicy Constructor

LogMergePolicy Constructor Lucene.Net Class Library
Initializes a new instance of the LogMergePolicy class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LogMergePolicy(
    IndexWriter writer
)
protected LogMergePolicy(
    IndexWriter writer
)
Protected Sub New ( _
    writer As IndexWriter _
)
Protected Sub New ( _
    writer As IndexWriter _
)
protected:
LogMergePolicy(
    IndexWriter^ writer
)
protected:
LogMergePolicy(
    IndexWriter^ writer
)
Parameters
writer
Type: Lucene.Net.Index IndexWriter
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogMergePolicy Fields

LogMergePolicy Fields Lucene.Net Class Library
The LogMergePolicy type exposes the following members.
Fields
 | Name | Description
 | DEFAULT_MAX_MERGE_DOCS | Default maximum segment size. A segment of this size
 | DEFAULT_MERGE_FACTOR | Default merge factor, which is how many segments are merged at a time
 | DEFAULT_NO_CFS_RATIO | Default noCFSRatio. If a merge's size is >= 10% of the index, then we disable compound file for it. See NoCFSRatio
Protected field | internalCalibrateSizeByDeletes |
Protected field | internalNoCFSRatio |
 | LEVEL_LOG_SPAN | Defines the allowed range of log(size) for each level. A level is computed by taking the max segment log size, minus LEVEL_LOG_SPAN, and finding all segments falling within that range.
Protected field | writer | (Inherited from MergePolicy.)
Back to Top
See Also
LogMergePolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_MAX_MERGE_DOCS Field

LogMergePolicy DEFAULT_MAX_MERGE_DOCS Field Lucene.Net Class Library
Default maximum segment size. A segment of this size

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly int DEFAULT_MAX_MERGE_DOCS
public static readonly int DEFAULT_MAX_MERGE_DOCS
Public Shared ReadOnly DEFAULT_MAX_MERGE_DOCS As Integer
Public Shared ReadOnly DEFAULT_MAX_MERGE_DOCS As Integer
public:
static initonly int DEFAULT_MAX_MERGE_DOCS
public:
static initonly int DEFAULT_MAX_MERGE_DOCS
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
LogMergePolicy MaxMergeDocs
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_MERGE_FACTOR Field

LogMergePolicy DEFAULT_MERGE_FACTOR Field Lucene.Net Class Library
Default merge factor, which is how many segments are merged at a time

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_MERGE_FACTOR
public const int DEFAULT_MERGE_FACTOR
Public Const DEFAULT_MERGE_FACTOR As Integer
Public Const DEFAULT_MERGE_FACTOR As Integer
public:
literal int DEFAULT_MERGE_FACTOR
public:
literal int DEFAULT_MERGE_FACTOR
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_NO_CFS_RATIO Field

LogMergePolicy DEFAULT_NO_CFS_RATIO Field Lucene.Net Class Library
Default noCFSRatio. If a merge's size is >= 10% of the index, then we disable compound file for it. See NoCFSRatio

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double DEFAULT_NO_CFS_RATIO
public static double DEFAULT_NO_CFS_RATIO
Public Shared DEFAULT_NO_CFS_RATIO As Double
Public Shared DEFAULT_NO_CFS_RATIO As Double
public:
static double DEFAULT_NO_CFS_RATIO
public:
static double DEFAULT_NO_CFS_RATIO
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalCalibrateSizeByDeletes Field

LogMergePolicy internalCalibrateSizeByDeletes Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool internalCalibrateSizeByDeletes
protected bool internalCalibrateSizeByDeletes
Protected internalCalibrateSizeByDeletes As Boolean
Protected internalCalibrateSizeByDeletes As Boolean
protected:
bool internalCalibrateSizeByDeletes
protected:
bool internalCalibrateSizeByDeletes
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalNoCFSRatio Field

LogMergePolicy internalNoCFSRatio Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected double internalNoCFSRatio
protected double internalNoCFSRatio
Protected internalNoCFSRatio As Double
Protected internalNoCFSRatio As Double
protected:
double internalNoCFSRatio
protected:
double internalNoCFSRatio
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LEVEL_LOG_SPAN Field

LogMergePolicy LEVEL_LOG_SPAN Field Lucene.Net Class Library
Defines the allowed range of log(size) for each level. A level is computed by taking the max segment log size, minus LEVEL_LOG_SPAN, and finding all segments falling within that range.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double LEVEL_LOG_SPAN
public const double LEVEL_LOG_SPAN
Public Const LEVEL_LOG_SPAN As Double
Public Const LEVEL_LOG_SPAN As Double
public:
literal double LEVEL_LOG_SPAN
public:
literal double LEVEL_LOG_SPAN
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogMergePolicy Methods

LogMergePolicy Methods Lucene.Net Class Library
The LogMergePolicy type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Release all resources for the policy. (Inherited from MergePolicy.)
Public method | Dispose | Release all resources for the policy. (Inherited from MergePolicy.)
Protected method | Dispose(Boolean) | (Inherited from MergePolicy.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindMerges | Checks if any merges are now necessary and returns a MergePolicy MergeSpecification if so. A merge is necessary when there are more than MergeFactor segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the MergeScheduler to use concurrency. (Overrides MergePolicy FindMerges(SegmentInfos).)
Public method | FindMergesForOptimize | Returns the merges necessary to optimize the index. This merge policy defines "optimized" to mean only one segment in the index, where that segment has no deletions pending nor separate norms, and it is in compound file format if the current useCompoundFile setting is true. This method returns multiple merges (mergeFactor at a time) so the MergeScheduler in use may make use of concurrency. (Overrides MergePolicy FindMergesForOptimize(SegmentInfos, Int32, ISet SegmentInfo ).)
Public method | FindMergesToExpungeDeletes | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time. (Overrides MergePolicy FindMergesToExpungeDeletes(SegmentInfos).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUseCompoundDocStore | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields)
Public method | GetUseCompoundFile |
Protected method | MakeOneMerge |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetUseCompoundDocStore | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields).
Public method | SetUseCompoundFile | Gets or sets whether compound file format should be used for newly flushed and newly merged segments.
Protected method | Size |
Protected method | SizeBytes |
Protected method | SizeDocs |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UseCompoundDocStore | (Overrides MergePolicy UseCompoundDocStore(SegmentInfos).)
Public method | UseCompoundFile | (Overrides MergePolicy UseCompoundFile(SegmentInfos, SegmentInfo).)
Protected method | Verbose |
Back to Top
See Also
LogMergePolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FindMerges Method

LogMergePolicy FindMerges Method Lucene.Net Class Library
Checks if any merges are now necessary and returns a MergePolicy MergeSpecification if so. A merge is necessary when there are more than MergeFactor segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the MergeScheduler to use concurrency.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override MergePolicy..::..MergeSpecification FindMerges(
    SegmentInfos infos
)
public override MergePolicy..::..MergeSpecification FindMerges(
    SegmentInfos infos
)
Public Overrides Function FindMerges ( _
    infos As SegmentInfos _
) As MergePolicy..::..MergeSpecification
Public Overrides Function FindMerges ( _
    infos As SegmentInfos _
) As MergePolicy..::..MergeSpecification
public:
virtual MergePolicy..::..MergeSpecification^ FindMerges(
    SegmentInfos^ infos
) override
public:
virtual MergePolicy..::..MergeSpecification^ FindMerges(
    SegmentInfos^ infos
) override
Parameters
infos
Type: Lucene.Net.Index SegmentInfos
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FindMergesForOptimize Method

LogMergePolicy FindMergesForOptimize Method Lucene.Net Class Library
Returns the merges necessary to optimize the index. This merge policy defines "optimized" to mean only one segment in the index, where that segment has no deletions pending nor separate norms, and it is in compound file format if the current useCompoundFile setting is true. This method returns multiple merges (mergeFactor at a time) so the MergeScheduler in use may make use of concurrency.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override MergePolicy..::..MergeSpecification FindMergesForOptimize(
    SegmentInfos infos,
    int maxNumSegments,
    ISet<SegmentInfo> segmentsToOptimize
)
public override MergePolicy..::..MergeSpecification FindMergesForOptimize(
    SegmentInfos infos,
    int maxNumSegments,
    ISet<SegmentInfo> segmentsToOptimize
)
Public Overrides Function FindMergesForOptimize ( _
    infos As SegmentInfos, _
    maxNumSegments As Integer, _
    segmentsToOptimize As ISet(Of SegmentInfo) _
) As MergePolicy..::..MergeSpecification
Public Overrides Function FindMergesForOptimize ( _
    infos As SegmentInfos, _
    maxNumSegments As Integer, _
    segmentsToOptimize As ISet(Of SegmentInfo) _
) As MergePolicy..::..MergeSpecification
public:
virtual MergePolicy..::..MergeSpecification^ FindMergesForOptimize(
    SegmentInfos^ infos,
    int maxNumSegments,
    ISet<SegmentInfo^>^ segmentsToOptimize
) override
public:
virtual MergePolicy..::..MergeSpecification^ FindMergesForOptimize(
    SegmentInfos^ infos,
    int maxNumSegments,
    ISet<SegmentInfo^>^ segmentsToOptimize
) override
Parameters
infos
Type: Lucene.Net.Index SegmentInfos
maxNumSegments
Type:   Online System Int32
segmentsToOptimize
Type:   Online System.Collections.Generic ISet  SegmentInfo
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FindMergesToExpungeDeletes Method

LogMergePolicy FindMergesToExpungeDeletes Method Lucene.Net Class Library
Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override MergePolicy..::..MergeSpecification FindMergesToExpungeDeletes(
    SegmentInfos segmentInfos
)
public override MergePolicy..::..MergeSpecification FindMergesToExpungeDeletes(
    SegmentInfos segmentInfos
)
Public Overrides Function FindMergesToExpungeDeletes ( _
    segmentInfos As SegmentInfos _
) As MergePolicy..::..MergeSpecification
Public Overrides Function FindMergesToExpungeDeletes ( _
    segmentInfos As SegmentInfos _
) As MergePolicy..::..MergeSpecification
public:
virtual MergePolicy..::..MergeSpecification^ FindMergesToExpungeDeletes(
    SegmentInfos^ segmentInfos
) override
public:
virtual MergePolicy..::..MergeSpecification^ FindMergesToExpungeDeletes(
    SegmentInfos^ segmentInfos
) override
Parameters
segmentInfos
Type: Lucene.Net.Index SegmentInfos
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetUseCompoundDocStore Method

LogMergePolicy GetUseCompoundDocStore Method Lucene.Net Class Library
Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool GetUseCompoundDocStore()
public virtual bool GetUseCompoundDocStore()
Public Overridable Function GetUseCompoundDocStore As Boolean
Public Overridable Function GetUseCompoundDocStore As Boolean
public:
virtual bool GetUseCompoundDocStore()
public:
virtual bool GetUseCompoundDocStore()
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
LogMergePolicy SetUseCompoundDocStore(Boolean)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetUseCompoundFile Method

LogMergePolicy GetUseCompoundFile Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool GetUseCompoundFile()
public virtual bool GetUseCompoundFile()
Public Overridable Function GetUseCompoundFile As Boolean
Public Overridable Function GetUseCompoundFile As Boolean
public:
virtual bool GetUseCompoundFile()
public:
virtual bool GetUseCompoundFile()
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MakeOneMerge Method

LogMergePolicy MakeOneMerge Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MergePolicy..::..OneMerge MakeOneMerge(
    SegmentInfos infos,
    SegmentInfos infosToMerge
)
protected MergePolicy..::..OneMerge MakeOneMerge(
    SegmentInfos infos,
    SegmentInfos infosToMerge
)
Protected Function MakeOneMerge ( _
    infos As SegmentInfos, _
    infosToMerge As SegmentInfos _
) As MergePolicy..::..OneMerge
Protected Function MakeOneMerge ( _
    infos As SegmentInfos, _
    infosToMerge As SegmentInfos _
) As MergePolicy..::..OneMerge
protected:
MergePolicy..::..OneMerge^ MakeOneMerge(
    SegmentInfos^ infos,
    SegmentInfos^ infosToMerge
)
protected:
MergePolicy..::..OneMerge^ MakeOneMerge(
    SegmentInfos^ infos,
    SegmentInfos^ infosToMerge
)
Parameters
infos
Type: Lucene.Net.Index SegmentInfos
infosToMerge
Type: Lucene.Net.Index SegmentInfos
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetUseCompoundDocStore Method

LogMergePolicy SetUseCompoundDocStore Method Lucene.Net Class Library
Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetUseCompoundDocStore(
    bool useCompoundDocStore
)
public virtual void SetUseCompoundDocStore(
    bool useCompoundDocStore
)
Public Overridable Sub SetUseCompoundDocStore ( _
    useCompoundDocStore As Boolean _
)
Public Overridable Sub SetUseCompoundDocStore ( _
    useCompoundDocStore As Boolean _
)
public:
virtual void SetUseCompoundDocStore(
    bool useCompoundDocStore
)
public:
virtual void SetUseCompoundDocStore(
    bool useCompoundDocStore
)
Parameters
useCompoundDocStore
Type:   Online System Boolean
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetUseCompoundFile Method

LogMergePolicy SetUseCompoundFile Method Lucene.Net Class Library
Gets or sets whether compound file format should be used for newly flushed and newly merged segments.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetUseCompoundFile(
    bool useCompoundFile
)
public virtual void SetUseCompoundFile(
    bool useCompoundFile
)
Public Overridable Sub SetUseCompoundFile ( _
    useCompoundFile As Boolean _
)
Public Overridable Sub SetUseCompoundFile ( _
    useCompoundFile As Boolean _
)
public:
virtual void SetUseCompoundFile(
    bool useCompoundFile
)
public:
virtual void SetUseCompoundFile(
    bool useCompoundFile
)
Parameters
useCompoundFile
Type:   Online System Boolean
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Size Method

LogMergePolicy Size Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract long Size(
    SegmentInfo info
)
protected abstract long Size(
    SegmentInfo info
)
Protected MustOverride Function Size ( _
    info As SegmentInfo _
) As Long
Protected MustOverride Function Size ( _
    info As SegmentInfo _
) As Long
protected:
virtual long long Size(
    SegmentInfo^ info
) abstract
protected:
virtual long long Size(
    SegmentInfo^ info
) abstract
Parameters
info
Type: Lucene.Net.Index SegmentInfo
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SizeBytes Method

LogMergePolicy SizeBytes Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual long SizeBytes(
    SegmentInfo info
)
protected virtual long SizeBytes(
    SegmentInfo info
)
Protected Overridable Function SizeBytes ( _
    info As SegmentInfo _
) As Long
Protected Overridable Function SizeBytes ( _
    info As SegmentInfo _
) As Long
protected:
virtual long long SizeBytes(
    SegmentInfo^ info
)
protected:
virtual long long SizeBytes(
    SegmentInfo^ info
)
Parameters
info
Type: Lucene.Net.Index SegmentInfo
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SizeDocs Method

LogMergePolicy SizeDocs Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual long SizeDocs(
    SegmentInfo info
)
protected virtual long SizeDocs(
    SegmentInfo info
)
Protected Overridable Function SizeDocs ( _
    info As SegmentInfo _
) As Long
Protected Overridable Function SizeDocs ( _
    info As SegmentInfo _
) As Long
protected:
virtual long long SizeDocs(
    SegmentInfo^ info
)
protected:
virtual long long SizeDocs(
    SegmentInfo^ info
)
Parameters
info
Type: Lucene.Net.Index SegmentInfo
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UseCompoundDocStore Method

LogMergePolicy UseCompoundDocStore Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool UseCompoundDocStore(
    SegmentInfos infos
)
public override bool UseCompoundDocStore(
    SegmentInfos infos
)
Public Overrides Function UseCompoundDocStore ( _
    infos As SegmentInfos _
) As Boolean
Public Overrides Function UseCompoundDocStore ( _
    infos As SegmentInfos _
) As Boolean
public:
virtual bool UseCompoundDocStore(
    SegmentInfos^ infos
) override
public:
virtual bool UseCompoundDocStore(
    SegmentInfos^ infos
) override
Parameters
infos
Type: Lucene.Net.Index SegmentInfos
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UseCompoundFile Method

LogMergePolicy UseCompoundFile Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool UseCompoundFile(
    SegmentInfos infos,
    SegmentInfo info
)
public override bool UseCompoundFile(
    SegmentInfos infos,
    SegmentInfo info
)
Public Overrides Function UseCompoundFile ( _
    infos As SegmentInfos, _
    info As SegmentInfo _
) As Boolean
Public Overrides Function UseCompoundFile ( _
    infos As SegmentInfos, _
    info As SegmentInfo _
) As Boolean
public:
virtual bool UseCompoundFile(
    SegmentInfos^ infos,
    SegmentInfo^ info
) override
public:
virtual bool UseCompoundFile(
    SegmentInfos^ infos,
    SegmentInfo^ info
) override
Parameters
infos
Type: Lucene.Net.Index SegmentInfos
info
Type: Lucene.Net.Index SegmentInfo
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Verbose Method

LogMergePolicy Verbose Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Verbose()
protected virtual bool Verbose()
Protected Overridable Function Verbose As Boolean
Protected Overridable Function Verbose As Boolean
protected:
virtual bool Verbose()
protected:
virtual bool Verbose()
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LogMergePolicy Properties

LogMergePolicy Properties Lucene.Net Class Library
The LogMergePolicy type exposes the following members.
Properties
 | Name | Description
Public property | CalibrateSizeByDeletes | Gets or sets whether the segment size should be calibrated by the number of deletes when choosing segments for merge.
Public property | MaxMergeDocs | Gets or sets the largest segment (measured by document count) that may be merged with other segments. Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is Online MaxValue. The default merge policy (LogByteSizeMergePolicy) also allows you to set this limit by net size (in MB) of the segment, using MaxMergeMB.
Public property | MergeFactor | Gets or sets how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained.
Public property | NoCFSRatio |
Back to Top
See Also
LogMergePolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CalibrateSizeByDeletes Property

LogMergePolicy CalibrateSizeByDeletes Property Lucene.Net Class Library
Gets or sets whether the segment size should be calibrated by the number of deletes when choosing segments for merge.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool CalibrateSizeByDeletes { get; set; }
public virtual bool CalibrateSizeByDeletes { get; set; }
Public Overridable Property CalibrateSizeByDeletes As Boolean
    Get
    Set
Public Overridable Property CalibrateSizeByDeletes As Boolean
    Get
    Set
public:
virtual property bool CalibrateSizeByDeletes {
    bool get ();
    void set (bool value);
}
public:
virtual property bool CalibrateSizeByDeletes {
    bool get ();
    void set (bool value);
}
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxMergeDocs Property

LogMergePolicy MaxMergeDocs Property Lucene.Net Class Library
Gets or sets the largest segment (measured by document count) that may be merged with other segments.

Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches.

The default value is Online MaxValue.

The default merge policy (LogByteSizeMergePolicy) also allows you to set this limit by net size (in MB) of the segment, using MaxMergeMB.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int MaxMergeDocs { get; set; }
public virtual int MaxMergeDocs { get; set; }
Public Overridable Property MaxMergeDocs As Integer
    Get
    Set
Public Overridable Property MaxMergeDocs As Integer
    Get
    Set
public:
virtual property int MaxMergeDocs {
    int get ();
    void set (int value);
}
public:
virtual property int MaxMergeDocs {
    int get ();
    void set (int value);
}
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergeFactor Property

LogMergePolicy MergeFactor Property Lucene.Net Class Library
Gets or sets how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int MergeFactor { get; set; }
public virtual int MergeFactor { get; set; }
Public Overridable Property MergeFactor As Integer
    Get
    Set
Public Overridable Property MergeFactor As Integer
    Get
    Set
public:
virtual property int MergeFactor {
    int get ();
    void set (int value);
}
public:
virtual property int MergeFactor {
    int get ();
    void set (int value);
}
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NoCFSRatio Property

LogMergePolicy NoCFSRatio Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double NoCFSRatio { get; set; }
public double NoCFSRatio { get; set; }
Public Property NoCFSRatio As Double
    Get
    Set
Public Property NoCFSRatio As Double
    Get
    Set
public:
property double NoCFSRatio {
    double get ();
    void set (double value);
}
public:
property double NoCFSRatio {
    double get ();
    void set (double value);
}
See Also
LogMergePolicy Class
LogMergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy Class

MergePolicy Class Lucene.Net Class Library

Expert: a MergePolicy determines the sequence of primitive merge operations to be used for overall merge and optimize operations.

Whenever the segments in an index have been altered by IndexWriter, either the addition of a newly flushed segment, addition of many segments from addIndexes* calls, or a previous merge that may now need to cascade, IndexWriter invokes FindMerges(SegmentInfos) to give the MergePolicy a chance to pick merges that are now required. This method returns a MergePolicy MergeSpecification instance describing the set of merges that should be done, or null if no merges are necessary. When IndexWriter.optimize is called, it calls FindMergesForOptimize(SegmentInfos, Int32, ISet SegmentInfo ) and the MergePolicy should then return the necessary merges.

Note that the policy can return more than one merge at a time. In this case, if the writer is using SerialMergeScheduler , the merges will be run sequentially but if it is using ConcurrentMergeScheduler they will be run concurrently.

The default MergePolicy is LogByteSizeMergePolicy .

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

NOTE: This class typically requires access to package-private APIs (e.g. SegmentInfos) to do its job; if you implement your own MergePolicy, you'll need to put it in package Lucene.Net.Index in order to use these APIs.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index MergePolicy
Lucene.Net.Index LogMergePolicy

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class MergePolicy : IDisposable
public abstract class MergePolicy : IDisposable
Public MustInherit Class MergePolicy _
    Implements IDisposable
Public MustInherit Class MergePolicy _
    Implements IDisposable
public ref class MergePolicy abstract : IDisposable
public ref class MergePolicy abstract : IDisposable
See Also
MergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy Members

MergePolicy Members Lucene.Net Class Library

The MergePolicy type exposes the following members.
Constructors
 | Name | Description
Protected method | MergePolicy | Initializes a new instance of the MergePolicy class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Release all resources for the policy.
Public method | Dispose | Release all resources for the policy.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the MergePolicy and optionally releases the managed resources
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindMerges | Determine what set of merge operations are now necessary on the index. IndexWriter calls this whenever there is a change to the segments. This call is always synchronized on the IndexWriter instance so only one thread at a time will call this method.
Public method | FindMergesForOptimize | Determine what set of merge operations is necessary in order to optimize the index. IndexWriter calls this when its Optimize method is called. This call is always synchronized on the IndexWriter instance so only one thread at a time will call this method.
Public method | FindMergesToExpungeDeletes | Determine what set of merge operations is necessary in order to expunge all deletes from the index.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UseCompoundDocStore | Returns true if the doc store files should use the compound file format.
Public method | UseCompoundFile | Returns true if a newly flushed (not from merge) segment should use the compound file format.
Back to Top
Fields
 | Name | Description
Protected field | writer |
Back to Top
See Also
MergePolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy Constructor

MergePolicy Constructor Lucene.Net Class Library
Initializes a new instance of the MergePolicy class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MergePolicy(
    IndexWriter writer
)
protected MergePolicy(
    IndexWriter writer
)
Protected Sub New ( _
    writer As IndexWriter _
)
Protected Sub New ( _
    writer As IndexWriter _
)
protected:
MergePolicy(
    IndexWriter^ writer
)
protected:
MergePolicy(
    IndexWriter^ writer
)
Parameters
writer
Type: Lucene.Net.Index IndexWriter
See Also
MergePolicy Class
MergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy Fields

MergePolicy Fields Lucene.Net Class Library
The MergePolicy type exposes the following members.
Fields
 | Name | Description
Protected field | writer |
Back to Top
See Also
MergePolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


writer Field

MergePolicy writer Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IndexWriter writer
protected IndexWriter writer
Protected writer As IndexWriter
Protected writer As IndexWriter
protected:
IndexWriter^ writer
protected:
IndexWriter^ writer
See Also
MergePolicy Class
MergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy Methods

MergePolicy Methods Lucene.Net Class Library
The MergePolicy type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Release all resources for the policy.
Public method | Dispose | Release all resources for the policy.
Protected method | Dispose(Boolean) |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindMerges | Determine what set of merge operations are now necessary on the index. IndexWriter calls this whenever there is a change to the segments. This call is always synchronized on the IndexWriter instance so only one thread at a time will call this method.
Public method | FindMergesForOptimize | Determine what set of merge operations is necessary in order to optimize the index. IndexWriter calls this when its Optimize method is called. This call is always synchronized on the IndexWriter instance so only one thread at a time will call this method.
Public method | FindMergesToExpungeDeletes | Determine what set of merge operations is necessary in order to expunge all deletes from the index.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UseCompoundDocStore | Returns true if the doc store files should use the compound file format.
Public method | UseCompoundFile | Returns true if a newly flushed (not from merge) segment should use the compound file format.
Back to Top
See Also
MergePolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

MergePolicy Close Method Lucene.Net Class Library
Release all resources for the policy.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
See Also
MergePolicy Class
MergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

MergePolicy Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Release all resources for the policy.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the MergePolicy and optionally releases the managed resources
Back to Top
See Also
MergePolicy Class
MergePolicy Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

MergePolicy Dispose Method Lucene.Net Class Library
Release all resources for the policy.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
MergePolicy Class
MergePolicy Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

MergePolicy Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the MergePolicy and optionally releases the managed resources

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void Dispose(
    bool disposing
)
protected abstract void Dispose(
    bool disposing
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) abstract
protected:
virtual void Dispose(
    bool disposing
) abstract
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
MergePolicy Class
MergePolicy Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FindMerges Method

MergePolicy FindMerges Method Lucene.Net Class Library
Determine what set of merge operations are now necessary on the index. IndexWriter calls this whenever there is a change to the segments. This call is always synchronized on the IndexWriter instance so only one thread at a time will call this method.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract MergePolicy..::..MergeSpecification FindMerges(
    SegmentInfos segmentInfos
)
public abstract MergePolicy..::..MergeSpecification FindMerges(
    SegmentInfos segmentInfos
)
Public MustOverride Function FindMerges ( _
    segmentInfos As SegmentInfos _
) As MergePolicy..::..MergeSpecification
Public MustOverride Function FindMerges ( _
    segmentInfos As SegmentInfos _
) As MergePolicy..::..MergeSpecification
public:
virtual MergePolicy..::..MergeSpecification^ FindMerges(
    SegmentInfos^ segmentInfos
) abstract
public:
virtual MergePolicy..::..MergeSpecification^ FindMerges(
    SegmentInfos^ segmentInfos
) abstract
Parameters
segmentInfos
Type: Lucene.Net.Index SegmentInfos
the total set of segments in the index

See Also
MergePolicy Class
MergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FindMergesForOptimize Method

MergePolicy FindMergesForOptimize Method Lucene.Net Class Library
Determine what set of merge operations is necessary in order to optimize the index. IndexWriter calls this when its Optimize method is called. This call is always synchronized on the IndexWriter instance so only one thread at a time will call this method.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract MergePolicy..::..MergeSpecification FindMergesForOptimize(
    SegmentInfos segmentInfos,
    int maxSegmentCount,
    ISet<SegmentInfo> segmentsToOptimize
)
public abstract MergePolicy..::..MergeSpecification FindMergesForOptimize(
    SegmentInfos segmentInfos,
    int maxSegmentCount,
    ISet<SegmentInfo> segmentsToOptimize
)
Public MustOverride Function FindMergesForOptimize ( _
    segmentInfos As SegmentInfos, _
    maxSegmentCount As Integer, _
    segmentsToOptimize As ISet(Of SegmentInfo) _
) As MergePolicy..::..MergeSpecification
Public MustOverride Function FindMergesForOptimize ( _
    segmentInfos As SegmentInfos, _
    maxSegmentCount As Integer, _
    segmentsToOptimize As ISet(Of SegmentInfo) _
) As MergePolicy..::..MergeSpecification
public:
virtual MergePolicy..::..MergeSpecification^ FindMergesForOptimize(
    SegmentInfos^ segmentInfos,
    int maxSegmentCount,
    ISet<SegmentInfo^>^ segmentsToOptimize
) abstract
public:
virtual MergePolicy..::..MergeSpecification^ FindMergesForOptimize(
    SegmentInfos^ segmentInfos,
    int maxSegmentCount,
    ISet<SegmentInfo^>^ segmentsToOptimize
) abstract
Parameters
segmentInfos
Type: Lucene.Net.Index SegmentInfos
the total set of segments in the index

maxSegmentCount
Type:   Online System Int32
requested maximum number of segments in the index (currently this
            is always 1)

segmentsToOptimize
Type:   Online System.Collections.Generic ISet  SegmentInfo
contains the specific SegmentInfo instances that must be merged
            away. This may be a subset of all SegmentInfos.

See Also
MergePolicy Class
MergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FindMergesToExpungeDeletes Method

MergePolicy FindMergesToExpungeDeletes Method Lucene.Net Class Library
Determine what set of merge operations is necessary in order to expunge all deletes from the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract MergePolicy..::..MergeSpecification FindMergesToExpungeDeletes(
    SegmentInfos segmentInfos
)
public abstract MergePolicy..::..MergeSpecification FindMergesToExpungeDeletes(
    SegmentInfos segmentInfos
)
Public MustOverride Function FindMergesToExpungeDeletes ( _
    segmentInfos As SegmentInfos _
) As MergePolicy..::..MergeSpecification
Public MustOverride Function FindMergesToExpungeDeletes ( _
    segmentInfos As SegmentInfos _
) As MergePolicy..::..MergeSpecification
public:
virtual MergePolicy..::..MergeSpecification^ FindMergesToExpungeDeletes(
    SegmentInfos^ segmentInfos
) abstract
public:
virtual MergePolicy..::..MergeSpecification^ FindMergesToExpungeDeletes(
    SegmentInfos^ segmentInfos
) abstract
Parameters
segmentInfos
Type: Lucene.Net.Index SegmentInfos
the total set of segments in the index

See Also
MergePolicy Class
MergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UseCompoundDocStore Method

MergePolicy UseCompoundDocStore Method Lucene.Net Class Library
Returns true if the doc store files should use the compound file format.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool UseCompoundDocStore(
    SegmentInfos segments
)
public abstract bool UseCompoundDocStore(
    SegmentInfos segments
)
Public MustOverride Function UseCompoundDocStore ( _
    segments As SegmentInfos _
) As Boolean
Public MustOverride Function UseCompoundDocStore ( _
    segments As SegmentInfos _
) As Boolean
public:
virtual bool UseCompoundDocStore(
    SegmentInfos^ segments
) abstract
public:
virtual bool UseCompoundDocStore(
    SegmentInfos^ segments
) abstract
Parameters
segments
Type: Lucene.Net.Index SegmentInfos
See Also
MergePolicy Class
MergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UseCompoundFile Method

MergePolicy UseCompoundFile Method Lucene.Net Class Library
Returns true if a newly flushed (not from merge) segment should use the compound file format.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool UseCompoundFile(
    SegmentInfos segments,
    SegmentInfo newSegment
)
public abstract bool UseCompoundFile(
    SegmentInfos segments,
    SegmentInfo newSegment
)
Public MustOverride Function UseCompoundFile ( _
    segments As SegmentInfos, _
    newSegment As SegmentInfo _
) As Boolean
Public MustOverride Function UseCompoundFile ( _
    segments As SegmentInfos, _
    newSegment As SegmentInfo _
) As Boolean
public:
virtual bool UseCompoundFile(
    SegmentInfos^ segments,
    SegmentInfo^ newSegment
) abstract
public:
virtual bool UseCompoundFile(
    SegmentInfos^ segments,
    SegmentInfo^ newSegment
) abstract
Parameters
segments
Type: Lucene.Net.Index SegmentInfos
newSegment
Type: Lucene.Net.Index SegmentInfo
See Also
MergePolicy Class
MergePolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeAbortedException Class

MergePolicy MergeAbortedException Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Online System Exception
Online System SystemException
Online System.IO IOException
Lucene.Net.Index MergePolicy MergeAbortedException

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MergeAbortedException : IOException
[SerializableAttribute]
public class MergeAbortedException : IOException
<SerializableAttribute> _
Public Class MergeAbortedException _
    Inherits IOException
<SerializableAttribute> _
Public Class MergeAbortedException _
    Inherits IOException
[SerializableAttribute]
public ref class MergeAbortedException : public IOException
[SerializableAttribute]
public ref class MergeAbortedException : public IOException
See Also
MergePolicy MergeAbortedException Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeAbortedException Members

MergePolicy MergeAbortedException Members Lucene.Net Class Library

Expert: a MergePolicy determines the sequence of primitive merge operations to be used for overall merge and optimize operations.

Whenever the segments in an index have been altered by IndexWriter, either the addition of a newly flushed segment, addition of many segments from addIndexes* calls, or a previous merge that may now need to cascade, IndexWriter invokes FindMerges(SegmentInfos) to give the MergePolicy a chance to pick merges that are now required. This method returns a MergePolicy MergeSpecification instance describing the set of merges that should be done, or null if no merges are necessary. When IndexWriter.optimize is called, it calls FindMergesForOptimize(SegmentInfos, Int32, ISet SegmentInfo ) and the MergePolicy should then return the necessary merges.

Note that the policy can return more than one merge at a time. In this case, if the writer is using SerialMergeScheduler , the merges will be run sequentially but if it is using ConcurrentMergeScheduler they will be run concurrently.

The default MergePolicy is LogByteSizeMergePolicy .

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

NOTE: This class typically requires access to package-private APIs (e.g. SegmentInfos) to do its job; if you implement your own MergePolicy, you'll need to put it in package Lucene.Net.Index in order to use these APIs.

The MergePolicy MergeAbortedException type exposes the following members.
Constructors
 | Name | Description
Public method | MergePolicy MergeAbortedException | Initializes a new instance of the MergePolicy MergeAbortedException class
Public method | MergePolicy MergeAbortedException(String) | Initializes a new instance of the MergePolicy MergeAbortedException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MergePolicy MergeAbortedException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeAbortedException Constructor

MergePolicy MergeAbortedException Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | MergePolicy MergeAbortedException | Initializes a new instance of the MergePolicy MergeAbortedException class
Public method | MergePolicy MergeAbortedException(String) | Initializes a new instance of the MergePolicy MergeAbortedException class
Back to Top
See Also
MergePolicy MergeAbortedException Class
MergePolicy MergeAbortedException Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeAbortedException Constructor

MergePolicy MergeAbortedException Constructor Lucene.Net Class Library
Initializes a new instance of the MergePolicy MergeAbortedException class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MergeAbortedException()
public MergeAbortedException()
Public Sub New
Public Sub New
public:
MergeAbortedException()
public:
MergeAbortedException()
See Also
MergePolicy MergeAbortedException Class
MergePolicy MergeAbortedException Members
MergePolicy MergeAbortedException Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeAbortedException Constructor (String)

MergePolicy MergeAbortedException Constructor (String) Lucene.Net Class Library
Initializes a new instance of the MergePolicy MergeAbortedException class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MergeAbortedException(
    string message
)
public MergeAbortedException(
    string message
)
Public Sub New ( _
    message As String _
)
Public Sub New ( _
    message As String _
)
public:
MergeAbortedException(
    String^ message
)
public:
MergeAbortedException(
    String^ message
)
Parameters
message
Type:   Online System String
See Also
MergePolicy MergeAbortedException Class
MergePolicy MergeAbortedException Members
MergePolicy MergeAbortedException Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeAbortedException Methods

MergePolicy MergeAbortedException Methods Lucene.Net Class Library
The MergePolicy MergeAbortedException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
MergePolicy MergeAbortedException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeAbortedException Properties

MergePolicy MergeAbortedException Properties Lucene.Net Class Library
The MergePolicy MergeAbortedException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
MergePolicy MergeAbortedException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeAbortedException Events

MergePolicy MergeAbortedException Events Lucene.Net Class Library
The MergePolicy MergeAbortedException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MergePolicy MergeAbortedException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeException Class

MergePolicy MergeException Class Lucene.Net Class Library
Exception thrown if there are any problems while executing a merge.
Inheritance Hierarchy
Online System Object
Online System Exception
Online System SystemException
Lucene.Net.Index MergePolicy MergeException

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MergeException : SystemException
[SerializableAttribute]
public class MergeException : SystemException
<SerializableAttribute> _
Public Class MergeException _
    Inherits SystemException
<SerializableAttribute> _
Public Class MergeException _
    Inherits SystemException
[SerializableAttribute]
public ref class MergeException : public SystemException
[SerializableAttribute]
public ref class MergeException : public SystemException
See Also
MergePolicy MergeException Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeException Members

MergePolicy MergeException Members Lucene.Net Class Library

Expert: a MergePolicy determines the sequence of primitive merge operations to be used for overall merge and optimize operations.

Whenever the segments in an index have been altered by IndexWriter, either the addition of a newly flushed segment, addition of many segments from addIndexes* calls, or a previous merge that may now need to cascade, IndexWriter invokes FindMerges(SegmentInfos) to give the MergePolicy a chance to pick merges that are now required. This method returns a MergePolicy MergeSpecification instance describing the set of merges that should be done, or null if no merges are necessary. When IndexWriter.optimize is called, it calls FindMergesForOptimize(SegmentInfos, Int32, ISet SegmentInfo ) and the MergePolicy should then return the necessary merges.

Note that the policy can return more than one merge at a time. In this case, if the writer is using SerialMergeScheduler , the merges will be run sequentially but if it is using ConcurrentMergeScheduler they will be run concurrently.

The default MergePolicy is LogByteSizeMergePolicy .

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

NOTE: This class typically requires access to package-private APIs (e.g. SegmentInfos) to do its job; if you implement your own MergePolicy, you'll need to put it in package Lucene.Net.Index in order to use these APIs.

The MergePolicy MergeException type exposes the following members.
Constructors
 | Name | Description
Public method | MergePolicy MergeException(Exception, Directory) | Initializes a new instance of the MergePolicy MergeException class
Public method | MergePolicy MergeException(String, Directory) | Initializes a new instance of the MergePolicy MergeException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Directory | Returns the Directory of the index that hit the exception.
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MergePolicy MergeException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeException Constructor

MergePolicy MergeException Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | MergePolicy MergeException(Exception, Directory) | Initializes a new instance of the MergePolicy MergeException class
Public method | MergePolicy MergeException(String, Directory) | Initializes a new instance of the MergePolicy MergeException class
Back to Top
See Also
MergePolicy MergeException Class
MergePolicy MergeException Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeException Constructor (Exception, Directory)

MergePolicy MergeException Constructor (Exception, Directory) Lucene.Net Class Library
Initializes a new instance of the MergePolicy MergeException class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MergeException(
    Exception exc,
    Directory dir
)
public MergeException(
    Exception exc,
    Directory dir
)
Public Sub New ( _
    exc As Exception, _
    dir As Directory _
)
Public Sub New ( _
    exc As Exception, _
    dir As Directory _
)
public:
MergeException(
    Exception^ exc,
    Directory^ dir
)
public:
MergeException(
    Exception^ exc,
    Directory^ dir
)
Parameters
exc
Type:   Online System Exception
dir
Type: Lucene.Net.Store Directory
See Also
MergePolicy MergeException Class
MergePolicy MergeException Members
MergePolicy MergeException Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeException Constructor (String, Directory)

MergePolicy MergeException Constructor (String, Directory) Lucene.Net Class Library
Initializes a new instance of the MergePolicy MergeException class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MergeException(
    string message,
    Directory dir
)
public MergeException(
    string message,
    Directory dir
)
Public Sub New ( _
    message As String, _
    dir As Directory _
)
Public Sub New ( _
    message As String, _
    dir As Directory _
)
public:
MergeException(
    String^ message,
    Directory^ dir
)
public:
MergeException(
    String^ message,
    Directory^ dir
)
Parameters
message
Type:   Online System String
dir
Type: Lucene.Net.Store Directory
See Also
MergePolicy MergeException Class
MergePolicy MergeException Members
MergePolicy MergeException Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeException Methods

MergePolicy MergeException Methods Lucene.Net Class Library
The MergePolicy MergeException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
MergePolicy MergeException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeException Properties

MergePolicy MergeException Properties Lucene.Net Class Library
The MergePolicy MergeException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Directory | Returns the Directory of the index that hit the exception.
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
MergePolicy MergeException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Directory Property

MergePolicy MergeException Directory Property Lucene.Net Class Library
Returns the Directory of the index that hit the exception.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Directory Directory { get; }
public virtual Directory Directory { get; }
Public Overridable ReadOnly Property Directory As Directory
    Get
Public Overridable ReadOnly Property Directory As Directory
    Get
public:
virtual property Directory^ Directory {
    Directory^ get ();
}
public:
virtual property Directory^ Directory {
    Directory^ get ();
}
See Also
MergePolicy MergeException Class
MergePolicy MergeException Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeException Events

MergePolicy MergeException Events Lucene.Net Class Library
The MergePolicy MergeException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MergePolicy MergeException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeSpecification Class

MergePolicy MergeSpecification Class Lucene.Net Class Library
A MergeSpecification instance provides the information necessary to perform multiple merges. It simply contains a list of MergePolicy OneMerge instances.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index MergePolicy MergeSpecification

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MergeSpecification
public class MergeSpecification
Public Class MergeSpecification
Public Class MergeSpecification
public ref class MergeSpecification
public ref class MergeSpecification
See Also
MergePolicy MergeSpecification Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeSpecification Members

MergePolicy MergeSpecification Members Lucene.Net Class Library

Expert: a MergePolicy determines the sequence of primitive merge operations to be used for overall merge and optimize operations.

Whenever the segments in an index have been altered by IndexWriter, either the addition of a newly flushed segment, addition of many segments from addIndexes* calls, or a previous merge that may now need to cascade, IndexWriter invokes FindMerges(SegmentInfos) to give the MergePolicy a chance to pick merges that are now required. This method returns a MergePolicy MergeSpecification instance describing the set of merges that should be done, or null if no merges are necessary. When IndexWriter.optimize is called, it calls FindMergesForOptimize(SegmentInfos, Int32, ISet SegmentInfo ) and the MergePolicy should then return the necessary merges.

Note that the policy can return more than one merge at a time. In this case, if the writer is using SerialMergeScheduler , the merges will be run sequentially but if it is using ConcurrentMergeScheduler they will be run concurrently.

The default MergePolicy is LogByteSizeMergePolicy .

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

NOTE: This class typically requires access to package-private APIs (e.g. SegmentInfos) to do its job; if you implement your own MergePolicy, you'll need to put it in package Lucene.Net.Index in order to use these APIs.

The MergePolicy MergeSpecification type exposes the following members.
Constructors
 | Name | Description
Public method | MergePolicy MergeSpecification | Initializes a new instance of the MergePolicy MergeSpecification class
Back to Top
Methods
 | Name | Description
Public method | Add |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SegString |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Public field | merges | The subset of segments to be included in the primitive merge.
Back to Top
See Also
MergePolicy MergeSpecification Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeSpecification Constructor

MergePolicy MergeSpecification Constructor Lucene.Net Class Library
Initializes a new instance of the MergePolicy MergeSpecification class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MergeSpecification()
public MergeSpecification()
Public Sub New
Public Sub New
public:
MergeSpecification()
public:
MergeSpecification()
See Also
MergePolicy MergeSpecification Class
MergePolicy MergeSpecification Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeSpecification Fields

MergePolicy MergeSpecification Fields Lucene.Net Class Library
The MergePolicy MergeSpecification type exposes the following members.
Fields
 | Name | Description
Public field | merges | The subset of segments to be included in the primitive merge.
Back to Top
See Also
MergePolicy MergeSpecification Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


merges Field

MergePolicy MergeSpecification merges Field Lucene.Net Class Library
The subset of segments to be included in the primitive merge.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList<MergePolicy..::..OneMerge> merges
public IList<MergePolicy..::..OneMerge> merges
Public merges As IList(Of MergePolicy..::..OneMerge)
Public merges As IList(Of MergePolicy..::..OneMerge)
public:
IList<MergePolicy..::..OneMerge^>^ merges
public:
IList<MergePolicy..::..OneMerge^>^ merges
See Also
MergePolicy MergeSpecification Class
MergePolicy MergeSpecification Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.MergeSpecification Methods

MergePolicy MergeSpecification Methods Lucene.Net Class Library
The MergePolicy MergeSpecification type exposes the following members.
Methods
 | Name | Description
Public method | Add |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SegString |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MergePolicy MergeSpecification Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method

MergePolicy MergeSpecification Add Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Add(
    MergePolicy..::..OneMerge merge
)
public virtual void Add(
    MergePolicy..::..OneMerge merge
)
Public Overridable Sub Add ( _
    merge As MergePolicy..::..OneMerge _
)
Public Overridable Sub Add ( _
    merge As MergePolicy..::..OneMerge _
)
public:
virtual void Add(
    MergePolicy..::..OneMerge^ merge
)
public:
virtual void Add(
    MergePolicy..::..OneMerge^ merge
)
Parameters
merge
Type: Lucene.Net.Index MergePolicy OneMerge
See Also
MergePolicy MergeSpecification Class
MergePolicy MergeSpecification Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegString Method

MergePolicy MergeSpecification SegString Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string SegString(
    Directory dir
)
public virtual string SegString(
    Directory dir
)
Public Overridable Function SegString ( _
    dir As Directory _
) As String
Public Overridable Function SegString ( _
    dir As Directory _
) As String
public:
virtual String^ SegString(
    Directory^ dir
)
public:
virtual String^ SegString(
    Directory^ dir
)
Parameters
dir
Type: Lucene.Net.Store Directory
See Also
MergePolicy MergeSpecification Class
MergePolicy MergeSpecification Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.OneMerge Class

MergePolicy OneMerge Class Lucene.Net Class Library
OneMerge provides the information necessary to perform an individual primitive merge operation, resulting in a single new segment. The merge spec includes the subset of segments to be merged as well as whether the new segment should use the compound file format.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index MergePolicy OneMerge

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class OneMerge
public class OneMerge
Public Class OneMerge
Public Class OneMerge
public ref class OneMerge
public ref class OneMerge
See Also
MergePolicy OneMerge Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.OneMerge Members

MergePolicy OneMerge Members Lucene.Net Class Library

Expert: a MergePolicy determines the sequence of primitive merge operations to be used for overall merge and optimize operations.

Whenever the segments in an index have been altered by IndexWriter, either the addition of a newly flushed segment, addition of many segments from addIndexes* calls, or a previous merge that may now need to cascade, IndexWriter invokes FindMerges(SegmentInfos) to give the MergePolicy a chance to pick merges that are now required. This method returns a MergePolicy MergeSpecification instance describing the set of merges that should be done, or null if no merges are necessary. When IndexWriter.optimize is called, it calls FindMergesForOptimize(SegmentInfos, Int32, ISet SegmentInfo ) and the MergePolicy should then return the necessary merges.

Note that the policy can return more than one merge at a time. In this case, if the writer is using SerialMergeScheduler , the merges will be run sequentially but if it is using ConcurrentMergeScheduler they will be run concurrently.

The default MergePolicy is LogByteSizeMergePolicy .

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

NOTE: This class typically requires access to package-private APIs (e.g. SegmentInfos) to do its job; if you implement your own MergePolicy, you'll need to put it in package Lucene.Net.Index in order to use these APIs.

The MergePolicy OneMerge type exposes the following members.
Constructors
 | Name | Description
Public method | MergePolicy OneMerge | Initializes a new instance of the MergePolicy OneMerge class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | segments_ForNUnit |
Back to Top
See Also
MergePolicy OneMerge Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.OneMerge Constructor

MergePolicy OneMerge Constructor Lucene.Net Class Library
Initializes a new instance of the MergePolicy OneMerge class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OneMerge(
    SegmentInfos segments,
    bool useCompoundFile
)
public OneMerge(
    SegmentInfos segments,
    bool useCompoundFile
)
Public Sub New ( _
    segments As SegmentInfos, _
    useCompoundFile As Boolean _
)
Public Sub New ( _
    segments As SegmentInfos, _
    useCompoundFile As Boolean _
)
public:
OneMerge(
    SegmentInfos^ segments,
    bool useCompoundFile
)
public:
OneMerge(
    SegmentInfos^ segments,
    bool useCompoundFile
)
Parameters
segments
Type: Lucene.Net.Index SegmentInfos
useCompoundFile
Type:   Online System Boolean
See Also
MergePolicy OneMerge Class
MergePolicy OneMerge Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.OneMerge Methods

MergePolicy OneMerge Methods Lucene.Net Class Library
The MergePolicy OneMerge type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MergePolicy OneMerge Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergePolicy.OneMerge Properties

MergePolicy OneMerge Properties Lucene.Net Class Library
The MergePolicy OneMerge type exposes the following members.
Properties
 | Name | Description
Public property | segments_ForNUnit |
Back to Top
See Also
MergePolicy OneMerge Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


segments_ForNUnit Property

MergePolicy OneMerge segments_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SegmentInfos segments_ForNUnit { get; }
public SegmentInfos segments_ForNUnit { get; }
Public ReadOnly Property segments_ForNUnit As SegmentInfos
    Get
Public ReadOnly Property segments_ForNUnit As SegmentInfos
    Get
public:
property SegmentInfos^ segments_ForNUnit {
    SegmentInfos^ get ();
}
public:
property SegmentInfos^ segments_ForNUnit {
    SegmentInfos^ get ();
}
See Also
MergePolicy OneMerge Class
MergePolicy OneMerge Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergeScheduler Class

MergeScheduler Class Lucene.Net Class Library

Expert: IndexWriter uses an instance implementing this interface to execute the merges selected by a MergePolicy. The default MergeScheduler is ConcurrentMergeScheduler.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

NOTE: This class typically requires access to package-private APIs (eg, SegmentInfos) to do its job; if you implement your own MergePolicy, you'll need to put it in package Lucene.Net.Index in order to use these APIs.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index MergeScheduler
Lucene.Net.Index ConcurrentMergeScheduler
Lucene.Net.Index SerialMergeScheduler

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class MergeScheduler : IDisposable
public abstract class MergeScheduler : IDisposable
Public MustInherit Class MergeScheduler _
    Implements IDisposable
Public MustInherit Class MergeScheduler _
    Implements IDisposable
public ref class MergeScheduler abstract : IDisposable
public ref class MergeScheduler abstract : IDisposable
See Also
MergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergeScheduler Members

MergeScheduler Members Lucene.Net Class Library

The MergeScheduler type exposes the following members.
Constructors
 | Name | Description
Protected method | MergeScheduler | Initializes a new instance of the MergeScheduler class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete.
Public method | Dispose | Releases all resources used by the MergeScheduler
Protected method | Dispose(Boolean) | Close this MergeScheduler.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Merge | Run the merges provided by GetNextMerge .
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MergeScheduler Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergeScheduler Constructor

MergeScheduler Constructor Lucene.Net Class Library
Initializes a new instance of the MergeScheduler class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MergeScheduler()
protected MergeScheduler()
Protected Sub New
Protected Sub New
protected:
MergeScheduler()
protected:
MergeScheduler()
See Also
MergeScheduler Class
MergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergeScheduler Methods

MergeScheduler Methods Lucene.Net Class Library
The MergeScheduler type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete.
Public method | Dispose |
Protected method | Dispose(Boolean) | Close this MergeScheduler.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Merge | Run the merges provided by GetNextMerge .
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MergeScheduler Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

MergeScheduler Close Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
See Also
MergeScheduler Class
MergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

MergeScheduler Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the MergeScheduler
Protected method | Dispose(Boolean) | Close this MergeScheduler.
Back to Top
See Also
MergeScheduler Class
MergeScheduler Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

MergeScheduler Dispose Method Lucene.Net Class Library
Releases all resources used by the MergeScheduler

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
MergeScheduler Class
MergeScheduler Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

MergeScheduler Dispose Method (Boolean) Lucene.Net Class Library
Close this MergeScheduler.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void Dispose(
    bool disposing
)
protected abstract void Dispose(
    bool disposing
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) abstract
protected:
virtual void Dispose(
    bool disposing
) abstract
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
MergeScheduler Class
MergeScheduler Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Merge Method

MergeScheduler Merge Method Lucene.Net Class Library
Run the merges provided by GetNextMerge .

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Merge(
    IndexWriter writer
)
public abstract void Merge(
    IndexWriter writer
)
Public MustOverride Sub Merge ( _
    writer As IndexWriter _
)
Public MustOverride Sub Merge ( _
    writer As IndexWriter _
)
public:
virtual void Merge(
    IndexWriter^ writer
) abstract
public:
virtual void Merge(
    IndexWriter^ writer
) abstract
Parameters
writer
Type: Lucene.Net.Index IndexWriter
See Also
MergeScheduler Class
MergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultipleTermPositions Class

MultipleTermPositions Class Lucene.Net Class Library
Allows you to iterate over the TermPositions for multiple Terms as a single TermPositions.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index MultipleTermPositions

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MultipleTermPositions : TermPositions,
    TermDocs, IDisposable
public class MultipleTermPositions : TermPositions,
    TermDocs, IDisposable
Public Class MultipleTermPositions _
    Implements TermPositions, TermDocs, IDisposable
Public Class MultipleTermPositions _
    Implements TermPositions, TermDocs, IDisposable
public ref class MultipleTermPositions : TermPositions,
    TermDocs, IDisposable
public ref class MultipleTermPositions : TermPositions,
    TermDocs, IDisposable
See Also
MultipleTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultipleTermPositions Members

MultipleTermPositions Members Lucene.Net Class Library

The MultipleTermPositions type exposes the following members.
Constructors
 | Name | Description
Public method | MultipleTermPositions | Creates a new MultipleTermPositions instance.
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete.
Public method | Dispose | Releases all resources used by the MultipleTermPositions
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the MultipleTermPositions and optionally releases the managed resources
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPayload | Not implemented.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next |
Public method | NextPosition |
Public method | Read | Not implemented.
Public method | Seek(Term) | Not implemented.
Public method | Seek(TermEnum) | Not implemented.
Public method | SkipTo |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Doc |
Public property | Freq |
Public property | IsPayloadAvailable |
Public property | PayloadLength | Not implemented.
Back to Top
See Also
MultipleTermPositions Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultipleTermPositions Constructor

MultipleTermPositions Constructor Lucene.Net Class Library
Creates a new MultipleTermPositions instance.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MultipleTermPositions(
    IndexReader indexReader,
    Term[] terms
)
public MultipleTermPositions(
    IndexReader indexReader,
    Term[] terms
)
Public Sub New ( _
    indexReader As IndexReader, _
    terms As Term() _
)
Public Sub New ( _
    indexReader As IndexReader, _
    terms As Term() _
)
public:
MultipleTermPositions(
    IndexReader^ indexReader,
    array<Term^>^ terms
)
public:
MultipleTermPositions(
    IndexReader^ indexReader,
    array<Term^>^ terms
)
Parameters
indexReader
Type: Lucene.Net.Index IndexReader
terms
Type:  Lucene.Net.Index Term
Exceptions
Exception | Condition
Online System.IO IOException |
See Also
MultipleTermPositions Class
MultipleTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultipleTermPositions Methods

MultipleTermPositions Methods Lucene.Net Class Library
The MultipleTermPositions type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete.
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPayload | Not implemented.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next |
Public method | NextPosition |
Public method | Read | Not implemented.
Public method | Seek(Term) | Not implemented.
Public method | Seek(TermEnum) | Not implemented.
Public method | SkipTo |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MultipleTermPositions Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

MultipleTermPositions Close Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
virtual void Close() sealed
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
virtual void Close() sealed
Implements
TermDocs Close
See Also
MultipleTermPositions Class
MultipleTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

MultipleTermPositions Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the MultipleTermPositions
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the MultipleTermPositions and optionally releases the managed resources
Back to Top
See Also
MultipleTermPositions Class
MultipleTermPositions Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

MultipleTermPositions Dispose Method Lucene.Net Class Library
Releases all resources used by the MultipleTermPositions

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
MultipleTermPositions Class
MultipleTermPositions Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

MultipleTermPositions Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the MultipleTermPositions and optionally releases the managed resources

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void Dispose(
    bool disposing
)
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
)
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
MultipleTermPositions Class
MultipleTermPositions Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPayload Method

MultipleTermPositions GetPayload Method Lucene.Net Class Library
Not implemented.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual byte[] GetPayload(
    byte[] data,
    int offset
)
public virtual byte[] GetPayload(
    byte[] data,
    int offset
)
Public Overridable Function GetPayload ( _
    data As Byte(), _
    offset As Integer _
) As Byte()
Public Overridable Function GetPayload ( _
    data As Byte(), _
    offset As Integer _
) As Byte()
public:
virtual array<unsigned char>^ GetPayload(
    array<unsigned char>^ data,
    int offset
)
public:
virtual array<unsigned char>^ GetPayload(
    array<unsigned char>^ data,
    int offset
)
Parameters
data
Type:    Online System Byte
offset
Type:   Online System Int32
Implements
TermPositions GetPayload( Byte , Int32)
See Also
MultipleTermPositions Class
MultipleTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Next Method

MultipleTermPositions Next Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Next()
public bool Next()
Public Function Next As Boolean
Public Function Next As Boolean
public:
virtual bool Next() sealed
public:
virtual bool Next() sealed
Implements
TermDocs Next
See Also
MultipleTermPositions Class
MultipleTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextPosition Method

MultipleTermPositions NextPosition Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int NextPosition()
public int NextPosition()
Public Function NextPosition As Integer
Public Function NextPosition As Integer
public:
virtual int NextPosition() sealed
public:
virtual int NextPosition() sealed
Implements
TermPositions NextPosition
See Also
MultipleTermPositions Class
MultipleTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Read Method

MultipleTermPositions Read Method Lucene.Net Class Library
Not implemented.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Read(
    int[] arg0,
    int[] arg1
)
public virtual int Read(
    int[] arg0,
    int[] arg1
)
Public Overridable Function Read ( _
    arg0 As Integer(), _
    arg1 As Integer() _
) As Integer
Public Overridable Function Read ( _
    arg0 As Integer(), _
    arg1 As Integer() _
) As Integer
public:
virtual int Read(
    array<int>^ arg0,
    array<int>^ arg1
)
public:
virtual int Read(
    array<int>^ arg0,
    array<int>^ arg1
)
Parameters
arg0
Type:    Online System Int32
arg1
Type:    Online System Int32
Implements
TermDocs Read( Int32 ,  Int32 )
See Also
MultipleTermPositions Class
MultipleTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method

MultipleTermPositions Seek Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Seek(Term) | Not implemented.
Public method | Seek(TermEnum) | Not implemented.
Back to Top
See Also
MultipleTermPositions Class
MultipleTermPositions Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method (Term)

MultipleTermPositions Seek Method (Term) Lucene.Net Class Library
Not implemented.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Seek(
    Term arg0
)
public virtual void Seek(
    Term arg0
)
Public Overridable Sub Seek ( _
    arg0 As Term _
)
Public Overridable Sub Seek ( _
    arg0 As Term _
)
public:
virtual void Seek(
    Term^ arg0
)
public:
virtual void Seek(
    Term^ arg0
)
Parameters
arg0
Type: Lucene.Net.Index Term
Implements
TermDocs Seek(Term)
See Also
MultipleTermPositions Class
MultipleTermPositions Members
Seek Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method (TermEnum)

MultipleTermPositions Seek Method (TermEnum) Lucene.Net Class Library
Not implemented.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Seek(
    TermEnum termEnum
)
public virtual void Seek(
    TermEnum termEnum
)
Public Overridable Sub Seek ( _
    termEnum As TermEnum _
)
Public Overridable Sub Seek ( _
    termEnum As TermEnum _
)
public:
virtual void Seek(
    TermEnum^ termEnum
)
public:
virtual void Seek(
    TermEnum^ termEnum
)
Parameters
termEnum
Type: Lucene.Net.Index TermEnum
Implements
TermDocs Seek(TermEnum)
See Also
MultipleTermPositions Class
MultipleTermPositions Members
Seek Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SkipTo Method

MultipleTermPositions SkipTo Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SkipTo(
    int target
)
public bool SkipTo(
    int target
)
Public Function SkipTo ( _
    target As Integer _
) As Boolean
Public Function SkipTo ( _
    target As Integer _
) As Boolean
public:
virtual bool SkipTo(
    int target
) sealed
public:
virtual bool SkipTo(
    int target
) sealed
Parameters
target
Type:   Online System Int32
Implements
TermDocs SkipTo(Int32)
See Also
MultipleTermPositions Class
MultipleTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultipleTermPositions Properties

MultipleTermPositions Properties Lucene.Net Class Library
The MultipleTermPositions type exposes the following members.
Properties
 | Name | Description
Public property | Doc |
Public property | Freq |
Public property | IsPayloadAvailable |
Public property | PayloadLength | Not implemented.
Back to Top
See Also
MultipleTermPositions Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Property

MultipleTermPositions Doc Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Doc { get; }
public int Doc { get; }
Public ReadOnly Property Doc As Integer
    Get
Public ReadOnly Property Doc As Integer
    Get
public:
virtual property int Doc {
    int get () sealed;
}
public:
virtual property int Doc {
    int get () sealed;
}
Implements
TermDocs Doc
See Also
MultipleTermPositions Class
MultipleTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Freq Property

MultipleTermPositions Freq Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Freq { get; }
public int Freq { get; }
Public ReadOnly Property Freq As Integer
    Get
Public ReadOnly Property Freq As Integer
    Get
public:
virtual property int Freq {
    int get () sealed;
}
public:
virtual property int Freq {
    int get () sealed;
}
Implements
TermDocs Freq
See Also
MultipleTermPositions Class
MultipleTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsPayloadAvailable Property

MultipleTermPositions IsPayloadAvailable Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsPayloadAvailable { get; }
public virtual bool IsPayloadAvailable { get; }
Public Overridable ReadOnly Property IsPayloadAvailable As Boolean
    Get
Public Overridable ReadOnly Property IsPayloadAvailable As Boolean
    Get
public:
virtual property bool IsPayloadAvailable {
    bool get ();
}
public:
virtual property bool IsPayloadAvailable {
    bool get ();
}
Field Value
 false
Implements
TermPositions IsPayloadAvailable
See Also
MultipleTermPositions Class
MultipleTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadLength Property

MultipleTermPositions PayloadLength Property Lucene.Net Class Library
Not implemented.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int PayloadLength { get; }
public virtual int PayloadLength { get; }
Public Overridable ReadOnly Property PayloadLength As Integer
    Get
Public Overridable ReadOnly Property PayloadLength As Integer
    Get
public:
virtual property int PayloadLength {
    int get ();
}
public:
virtual property int PayloadLength {
    int get ();
}
Implements
TermPositions PayloadLength
See Also
MultipleTermPositions Class
MultipleTermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiReader Class

MultiReader Class Lucene.Net Class Library
An IndexReader which reads multiple indexes, appending their content.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index IndexReader
Lucene.Net.Index MultiReader

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MultiReader : IndexReader,
    ICloneable
public class MultiReader : IndexReader,
    ICloneable
Public Class MultiReader _
    Inherits IndexReader _
    Implements ICloneable
Public Class MultiReader _
    Inherits IndexReader _
    Implements ICloneable
public ref class MultiReader : public IndexReader,
    ICloneable
public ref class MultiReader : public IndexReader,
    ICloneable
See Also
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiReader Members

MultiReader Members Lucene.Net Class Library

The MultiReader type exposes the following members.
Constructors
 | Name | Description
Public method | MultiReader( IndexReader ) | Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders. Note that all subreaders are closed if this Multireader is closed.
Public method | MultiReader( IndexReader , Boolean) | Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders.
Back to Top
Methods
 | Name | Description
Protected method | AcquireWriteLock | Does nothing by default. Subclasses that require a write lock for index modifications must implement this method. (Inherited from IndexReader.)
Public method | Clone | Clones the subreaders. (see Clone ). If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed. (Overrides IndexReader Clone .)
Public method | Clone(Boolean) | Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader. (Inherited from IndexReader.)
Public method | Close | Obsolete. (Inherited from IndexReader.)
Public method | Commit | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | Commit(IDictionary String, String ) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | DecRef | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed. (Inherited from IndexReader.)
Public method | DeleteDocument | Deletes the document numbered docNum. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the Document(Int32) method will result in an error. The presence of this document may still be reflected in the DocFreq(Term) statistic, though this will be corrected eventually as the index is further modified. (Inherited from IndexReader.)
Public method | DeleteDocuments | Deletes all documents that have a given term indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See DeleteDocument(Int32) for information about when this deletion will become effective. (Inherited from IndexReader.)
Public method | Directory | Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified. (Inherited from IndexReader.)
Public method | Dispose | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called. (Inherited from IndexReader.)
Protected method | Dispose(Boolean) | (Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader DoClose .)
Protected method | DoCommit | (Overrides IndexReader DoCommit(IDictionary String, String ).)
Public method | Document(Int32) | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader DoDelete(Int32).)
Protected method | DoReopen | If clone is true then we clone each of the subreaders
Protected method | DoSetNorm | (Overrides IndexReader DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader DoUndeleteAll .)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Inherited from IndexReader.)
Public method | Flush(IDictionary String, String ) | (Inherited from IndexReader.)
Public method | GetFieldNames | (Overrides IndexReader GetFieldNames(IndexReader FieldOption).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSequentialSubReaders | (Overrides IndexReader GetSequentialSubReaders .)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method | GetTermFreqVectors | (Overrides IndexReader GetTermFreqVectors(Int32).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasNorms | (Overrides IndexReader HasNorms(String).)
Public method | IncRef | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding DecRef , in a finally clause; otherwise the reader may never be closed. Note that Close simply calls decRef(), which means that the IndexReader will not really be closed until DecRef has been called for all outstanding references. (Inherited from IndexReader.)
Public method | IsCurrent | Checks recursively if all subreaders are up to date. (Overrides IndexReader IsCurrent .)
Public method | IsDeleted | (Overrides IndexReader IsDeleted(Int32).)
Public method | IsOptimized | (Overrides IndexReader IsOptimized .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Norms(String) | (Overrides IndexReader Norms(String).)
Public method | Norms(String, Byte , Int32) | (Overrides IndexReader Norms(String, Byte , Int32).)
Public method | NumDocs | (Overrides IndexReader NumDocs .)
Public method | Reopen | Tries to reopen the subreaders. If one or more subreaders could be re-opened (i. e. subReader.reopen() returned a new instance != subReader), then a new MultiReader instance is returned, otherwise this instance is returned. A re-opened instance might share one or more subreaders with the old instance. Index modification operations result in undefined behavior when performed before the old instance is closed. (see Reopen ). If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed. (Overrides IndexReader Reopen .)
Public method | Reopen(Boolean) | Just like Reopen , except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned. (Inherited from IndexReader.)
Public method | Reopen(IndexCommit) | Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Byte) | Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Single) | Expert: Resets the normalization factor for the named field of the named document. (Inherited from IndexReader.)
Public method | TermDocs | (Overrides IndexReader TermDocs .)
Public method | TermDocs(Term) | Returns an enumeration of all the documents which contain term. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping: Term => <docNum, freq>* The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Public method | TermPositions | (Overrides IndexReader TermPositions .)
Public method | TermPositions(Term) | Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping: Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >* This positional information facilitates phrase and proximity searching. The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Public method | Terms | (Overrides IndexReader Terms .)
Public method | Terms(Term) | (Overrides IndexReader Terms(Term).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UndeleteAll | Undeletes all documents currently marked as deleted in this index. (Inherited from IndexReader.)
Back to Top
Fields
 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | subReaders |
Back to Top
Properties
 | Name | Description
Public property | CommitUserData | Retrieve the String userData optionally passed to Commit(IDictionary String, String ). This will return null if Commit(IDictionary String, String ) has never been called for this index. (Inherited from IndexReader.)
Public property | DeletesCacheKey | (Inherited from IndexReader.)
Public property | FieldCacheKey | Expert (Inherited from IndexReader.)
Public property | HasDeletions | (Overrides IndexReader HasDeletions.)
Public property | IndexCommit | Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: this API is new and experimental and may suddenly change. (Inherited from IndexReader.)
Public property | Item | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public property | MaxDoc | (Overrides IndexReader MaxDoc.)
Public property | NumDeletedDocs | Returns the number of deleted documents. (Inherited from IndexReader.)
Public property | RefCount | Expert: returns the current refCount for this reader (Inherited from IndexReader.)
Public property | TermInfosIndexDivisor | For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened. (Inherited from IndexReader.)
Public property | UniqueTermCount | Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed. (Inherited from IndexReader.)
Public property | Version | Not implemented. (Overrides IndexReader Version.)
Back to Top
See Also
MultiReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiReader Constructor

MultiReader Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | MultiReader( IndexReader ) | Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders. Note that all subreaders are closed if this Multireader is closed.
Public method | MultiReader( IndexReader , Boolean) | Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders.
Back to Top
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiReader Constructor (IndexReader[])

MultiReader Constructor ( IndexReader ) Lucene.Net Class Library

Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders.

Note that all subreaders are closed if this Multireader is closed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MultiReader(
    params IndexReader[] subReaders
)
public MultiReader(
    params IndexReader[] subReaders
)
Public Sub New ( _
    ParamArray subReaders As IndexReader() _
)
Public Sub New ( _
    ParamArray subReaders As IndexReader() _
)
public:
MultiReader(
    ... array<IndexReader^>^ subReaders
)
public:
MultiReader(
    ... array<IndexReader^>^ subReaders
)
Parameters
subReaders
Type:  Lucene.Net.Index IndexReader
set of (sub)readers

See Also
MultiReader Class
MultiReader Members
MultiReader Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiReader Constructor (IndexReader[], Boolean)

MultiReader Constructor ( IndexReader , Boolean) Lucene.Net Class Library

Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MultiReader(
    IndexReader[] subReaders,
    bool closeSubReaders
)
public MultiReader(
    IndexReader[] subReaders,
    bool closeSubReaders
)
Public Sub New ( _
    subReaders As IndexReader(), _
    closeSubReaders As Boolean _
)
Public Sub New ( _
    subReaders As IndexReader(), _
    closeSubReaders As Boolean _
)
public:
MultiReader(
    array<IndexReader^>^ subReaders,
    bool closeSubReaders
)
public:
MultiReader(
    array<IndexReader^>^ subReaders,
    bool closeSubReaders
)
Parameters
subReaders
Type:  Lucene.Net.Index IndexReader
set of (sub)readers

closeSubReaders
Type:   Online System Boolean
indicates whether the subreaders should be closed
            when this MultiReader is closed

See Also
MultiReader Class
MultiReader Members
MultiReader Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiReader Fields

MultiReader Fields Lucene.Net Class Library
The MultiReader type exposes the following members.
Fields
 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | subReaders |
Back to Top
See Also
MultiReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


subReaders Field

MultiReader subReaders Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IndexReader[] subReaders
protected IndexReader[] subReaders
Protected subReaders As IndexReader()
Protected subReaders As IndexReader()
protected:
array<IndexReader^>^ subReaders
protected:
array<IndexReader^>^ subReaders
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiReader Methods

MultiReader Methods Lucene.Net Class Library
The MultiReader type exposes the following members.
Methods
 | Name | Description
Protected method | AcquireWriteLock | Does nothing by default. Subclasses that require a write lock for index modifications must implement this method. (Inherited from IndexReader.)
Public method | Clone | Clones the subreaders. (see Clone ). If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed. (Overrides IndexReader Clone .)
Public method | Clone(Boolean) | Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader. (Inherited from IndexReader.)
Public method | Close | Obsolete. (Inherited from IndexReader.)
Public method | Commit | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | Commit(IDictionary String, String ) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | DecRef | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed. (Inherited from IndexReader.)
Public method | DeleteDocument | Deletes the document numbered docNum. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the Document(Int32) method will result in an error. The presence of this document may still be reflected in the DocFreq(Term) statistic, though this will be corrected eventually as the index is further modified. (Inherited from IndexReader.)
Public method | DeleteDocuments | Deletes all documents that have a given term indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See DeleteDocument(Int32) for information about when this deletion will become effective. (Inherited from IndexReader.)
Public method | Directory | Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified. (Inherited from IndexReader.)
Public method | Dispose | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called. (Inherited from IndexReader.)
Protected method | Dispose(Boolean) | (Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader DoClose .)
Protected method | DoCommit | (Overrides IndexReader DoCommit(IDictionary String, String ).)
Public method | Document(Int32) | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader DoDelete(Int32).)
Protected method | DoReopen | If clone is true then we clone each of the subreaders
Protected method | DoSetNorm | (Overrides IndexReader DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader DoUndeleteAll .)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Inherited from IndexReader.)
Public method | Flush(IDictionary String, String ) | (Inherited from IndexReader.)
Public method | GetFieldNames | (Overrides IndexReader GetFieldNames(IndexReader FieldOption).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSequentialSubReaders | (Overrides IndexReader GetSequentialSubReaders .)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method | GetTermFreqVectors | (Overrides IndexReader GetTermFreqVectors(Int32).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasNorms | (Overrides IndexReader HasNorms(String).)
Public method | IncRef | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding DecRef , in a finally clause; otherwise the reader may never be closed. Note that Close simply calls decRef(), which means that the IndexReader will not really be closed until DecRef has been called for all outstanding references. (Inherited from IndexReader.)
Public method | IsCurrent | Checks recursively if all subreaders are up to date. (Overrides IndexReader IsCurrent .)
Public method | IsDeleted | (Overrides IndexReader IsDeleted(Int32).)
Public method | IsOptimized | (Overrides IndexReader IsOptimized .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Norms(String) | (Overrides IndexReader Norms(String).)
Public method | Norms(String, Byte , Int32) | (Overrides IndexReader Norms(String, Byte , Int32).)
Public method | NumDocs | (Overrides IndexReader NumDocs .)
Public method | Reopen | Tries to reopen the subreaders. If one or more subreaders could be re-opened (i. e. subReader.reopen() returned a new instance != subReader), then a new MultiReader instance is returned, otherwise this instance is returned. A re-opened instance might share one or more subreaders with the old instance. Index modification operations result in undefined behavior when performed before the old instance is closed. (see Reopen ). If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed. (Overrides IndexReader Reopen .)
Public method | Reopen(Boolean) | Just like Reopen , except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned. (Inherited from IndexReader.)
Public method | Reopen(IndexCommit) | Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Byte) | Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Single) | Expert: Resets the normalization factor for the named field of the named document. (Inherited from IndexReader.)
Public method | TermDocs | (Overrides IndexReader TermDocs .)
Public method | TermDocs(Term) | Returns an enumeration of all the documents which contain term. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping: Term => <docNum, freq>* The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Public method | TermPositions | (Overrides IndexReader TermPositions .)
Public method | TermPositions(Term) | Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping: Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >* This positional information facilitates phrase and proximity searching. The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Public method | Terms | (Overrides IndexReader Terms .)
Public method | Terms(Term) | (Overrides IndexReader Terms(Term).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UndeleteAll | Undeletes all documents currently marked as deleted in this index. (Inherited from IndexReader.)
Back to Top
See Also
MultiReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

MultiReader Clone Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Clone | Clones the subreaders. (see Clone ). If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed. (Overrides IndexReader Clone .)
Public method | Clone(Boolean) | Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader. (Inherited from IndexReader.)
Back to Top
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

MultiReader Clone Method Lucene.Net Class Library
Clones the subreaders. (see Clone ).

If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
MultiReader Class
MultiReader Members
Clone Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocFreq Method

MultiReader DocFreq Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocFreq(
    Term t
)
public override int DocFreq(
    Term t
)
Public Overrides Function DocFreq ( _
    t As Term _
) As Integer
Public Overrides Function DocFreq ( _
    t As Term _
) As Integer
public:
virtual int DocFreq(
    Term^ t
) override
public:
virtual int DocFreq(
    Term^ t
) override
Parameters
t
Type: Lucene.Net.Index Term
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoClose Method

MultiReader DoClose Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoClose()
protected override void DoClose()
Protected Overrides Sub DoClose
Protected Overrides Sub DoClose
protected:
virtual void DoClose() override
protected:
virtual void DoClose() override
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoCommit Method

MultiReader DoCommit Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoCommit(
    IDictionary<string, string> commitUserData
)
protected override void DoCommit(
    IDictionary<string, string> commitUserData
)
Protected Overrides Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
Protected Overrides Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
protected:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
) override
protected:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
) override
Parameters
commitUserData
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Method

MultiReader Document Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Document(Int32) | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader Document(Int32, FieldSelector).)
Back to Top
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Method (Int32, FieldSelector)

MultiReader Document Method (Int32, FieldSelector) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Document Document(
    int n,
    FieldSelector fieldSelector
)
public override Document Document(
    int n,
    FieldSelector fieldSelector
)
Public Overrides Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Public Overrides Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) override
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) override
Parameters
n
Type:   Online System Int32
fieldSelector
Type: Lucene.Net.Documents FieldSelector
See Also
MultiReader Class
MultiReader Members
Document Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoDelete Method

MultiReader DoDelete Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoDelete(
    int n
)
protected override void DoDelete(
    int n
)
Protected Overrides Sub DoDelete ( _
    n As Integer _
)
Protected Overrides Sub DoDelete ( _
    n As Integer _
)
protected:
virtual void DoDelete(
    int n
) override
protected:
virtual void DoDelete(
    int n
) override
Parameters
n
Type:   Online System Int32
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoReopen Method

MultiReader DoReopen Method Lucene.Net Class Library
If clone is true then we clone each of the subreaders

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual IndexReader DoReopen(
    bool doClone
)
protected virtual IndexReader DoReopen(
    bool doClone
)
Protected Overridable Function DoReopen ( _
    doClone As Boolean _
) As IndexReader
Protected Overridable Function DoReopen ( _
    doClone As Boolean _
) As IndexReader
protected:
virtual IndexReader^ DoReopen(
    bool doClone
)
protected:
virtual IndexReader^ DoReopen(
    bool doClone
)
Parameters
doClone
Type:   Online System Boolean
Return Value
 New IndexReader, or same one (this) if
            reopen/clone is not necessary

See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoSetNorm Method

MultiReader DoSetNorm Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSetNorm(
    int n,
    string field,
    byte value_Renamed
)
protected override void DoSetNorm(
    int n,
    string field,
    byte value_Renamed
)
Protected Overrides Sub DoSetNorm ( _
    n As Integer, _
    field As String, _
    value_Renamed As Byte _
)
Protected Overrides Sub DoSetNorm ( _
    n As Integer, _
    field As String, _
    value_Renamed As Byte _
)
protected:
virtual void DoSetNorm(
    int n,
    String^ field,
    unsigned char value_Renamed
) override
protected:
virtual void DoSetNorm(
    int n,
    String^ field,
    unsigned char value_Renamed
) override
Parameters
n
Type:   Online System Int32
field
Type:   Online System String
value_Renamed
Type:   Online System Byte
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoUndeleteAll Method

MultiReader DoUndeleteAll Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoUndeleteAll()
protected override void DoUndeleteAll()
Protected Overrides Sub DoUndeleteAll
Protected Overrides Sub DoUndeleteAll
protected:
virtual void DoUndeleteAll() override
protected:
virtual void DoUndeleteAll() override
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFieldNames Method

MultiReader GetFieldNames Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fieldNames
)
public override ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fieldNames
)
Public Overrides Function GetFieldNames ( _
    fieldNames As IndexReader..::..FieldOption _
) As ICollection(Of String)
Public Overrides Function GetFieldNames ( _
    fieldNames As IndexReader..::..FieldOption _
) As ICollection(Of String)
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fieldNames
) override
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fieldNames
) override
Parameters
fieldNames
Type: Lucene.Net.Index IndexReader FieldOption
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSequentialSubReaders Method

MultiReader GetSequentialSubReaders Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexReader[] GetSequentialSubReaders()
public override IndexReader[] GetSequentialSubReaders()
Public Overrides Function GetSequentialSubReaders As IndexReader()
Public Overrides Function GetSequentialSubReaders As IndexReader()
public:
virtual array<IndexReader^>^ GetSequentialSubReaders() override
public:
virtual array<IndexReader^>^ GetSequentialSubReaders() override
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method

MultiReader GetTermFreqVector Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, String, TermVectorMapper).)
Back to Top
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, TermVectorMapper)

MultiReader GetTermFreqVector Method (Int32, TermVectorMapper) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
public override void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) override
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) override
Parameters
docNumber
Type:   Online System Int32
mapper
Type: Lucene.Net.Index TermVectorMapper
See Also
MultiReader Class
MultiReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, String)

MultiReader GetTermFreqVector Method (Int32, String) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ITermFreqVector GetTermFreqVector(
    int n,
    string field
)
public override ITermFreqVector GetTermFreqVector(
    int n,
    string field
)
Public Overrides Function GetTermFreqVector ( _
    n As Integer, _
    field As String _
) As ITermFreqVector
Public Overrides Function GetTermFreqVector ( _
    n As Integer, _
    field As String _
) As ITermFreqVector
public:
virtual ITermFreqVector^ GetTermFreqVector(
    int n,
    String^ field
) override
public:
virtual ITermFreqVector^ GetTermFreqVector(
    int n,
    String^ field
) override
Parameters
n
Type:   Online System Int32
field
Type:   Online System String
See Also
MultiReader Class
MultiReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, String, TermVectorMapper)

MultiReader GetTermFreqVector Method (Int32, String, TermVectorMapper) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
public override void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) override
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) override
Parameters
docNumber
Type:   Online System Int32
field
Type:   Online System String
mapper
Type: Lucene.Net.Index TermVectorMapper
See Also
MultiReader Class
MultiReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVectors Method

MultiReader GetTermFreqVectors Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ITermFreqVector[] GetTermFreqVectors(
    int n
)
public override ITermFreqVector[] GetTermFreqVectors(
    int n
)
Public Overrides Function GetTermFreqVectors ( _
    n As Integer _
) As ITermFreqVector()
Public Overrides Function GetTermFreqVectors ( _
    n As Integer _
) As ITermFreqVector()
public:
virtual array<ITermFreqVector^>^ GetTermFreqVectors(
    int n
) override
public:
virtual array<ITermFreqVector^>^ GetTermFreqVectors(
    int n
) override
Parameters
n
Type:   Online System Int32
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasNorms Method

MultiReader HasNorms Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool HasNorms(
    string field
)
public override bool HasNorms(
    string field
)
Public Overrides Function HasNorms ( _
    field As String _
) As Boolean
Public Overrides Function HasNorms ( _
    field As String _
) As Boolean
public:
virtual bool HasNorms(
    String^ field
) override
public:
virtual bool HasNorms(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsCurrent Method

MultiReader IsCurrent Method Lucene.Net Class Library
Checks recursively if all subreaders are up to date.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsCurrent()
public override bool IsCurrent()
Public Overrides Function IsCurrent As Boolean
Public Overrides Function IsCurrent As Boolean
public:
virtual bool IsCurrent() override
public:
virtual bool IsCurrent() override
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsDeleted Method

MultiReader IsDeleted Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsDeleted(
    int n
)
public override bool IsDeleted(
    int n
)
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
public:
virtual bool IsDeleted(
    int n
) override
public:
virtual bool IsDeleted(
    int n
) override
Parameters
n
Type:   Online System Int32
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsOptimized Method

MultiReader IsOptimized Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsOptimized()
public override bool IsOptimized()
Public Overrides Function IsOptimized As Boolean
Public Overrides Function IsOptimized As Boolean
public:
virtual bool IsOptimized() override
public:
virtual bool IsOptimized() override
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method

MultiReader Norms Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Norms(String) | (Overrides IndexReader Norms(String).)
Public method | Norms(String, Byte , Int32) | (Overrides IndexReader Norms(String, Byte , Int32).)
Back to Top
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method (String)

MultiReader Norms Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override byte[] Norms(
    string field
)
public override byte[] Norms(
    string field
)
Public Overrides Function Norms ( _
    field As String _
) As Byte()
Public Overrides Function Norms ( _
    field As String _
) As Byte()
public:
virtual array<unsigned char>^ Norms(
    String^ field
) override
public:
virtual array<unsigned char>^ Norms(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
MultiReader Class
MultiReader Members
Norms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method (String, Byte[], Int32)

MultiReader Norms Method (String, Byte , Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Norms(
    string field,
    byte[] result,
    int offset
)
public override void Norms(
    string field,
    byte[] result,
    int offset
)
Public Overrides Sub Norms ( _
    field As String, _
    result As Byte(), _
    offset As Integer _
)
Public Overrides Sub Norms ( _
    field As String, _
    result As Byte(), _
    offset As Integer _
)
public:
virtual void Norms(
    String^ field,
    array<unsigned char>^ result,
    int offset
) override
public:
virtual void Norms(
    String^ field,
    array<unsigned char>^ result,
    int offset
) override
Parameters
field
Type:   Online System String
result
Type:    Online System Byte
offset
Type:   Online System Int32
See Also
MultiReader Class
MultiReader Members
Norms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumDocs Method

MultiReader NumDocs Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int NumDocs()
public override int NumDocs()
Public Overrides Function NumDocs As Integer
Public Overrides Function NumDocs As Integer
public:
virtual int NumDocs() override
public:
virtual int NumDocs() override
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reopen Method

MultiReader Reopen Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Reopen | Tries to reopen the subreaders. If one or more subreaders could be re-opened (i. e. subReader.reopen() returned a new instance != subReader), then a new MultiReader instance is returned, otherwise this instance is returned. A re-opened instance might share one or more subreaders with the old instance. Index modification operations result in undefined behavior when performed before the old instance is closed. (see Reopen ). If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed. (Overrides IndexReader Reopen .)
Public method | Reopen(Boolean) | Just like Reopen , except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned. (Inherited from IndexReader.)
Public method | Reopen(IndexCommit) | Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned. (Inherited from IndexReader.)
Back to Top
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reopen Method

MultiReader Reopen Method Lucene.Net Class Library
Tries to reopen the subreaders.
If one or more subreaders could be re-opened (i. e. subReader.reopen() returned a new instance != subReader), then a new MultiReader instance is returned, otherwise this instance is returned.

A re-opened instance might share one or more subreaders with the old instance. Index modification operations result in undefined behavior when performed before the old instance is closed. (see Reopen ).

If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexReader Reopen()
public override IndexReader Reopen()
Public Overrides Function Reopen As IndexReader
Public Overrides Function Reopen As IndexReader
public:
virtual IndexReader^ Reopen() override
public:
virtual IndexReader^ Reopen() override
See Also
MultiReader Class
MultiReader Members
Reopen Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Method

MultiReader TermDocs Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TermDocs | (Overrides IndexReader TermDocs .)
Public method | TermDocs(Term) | Returns an enumeration of all the documents which contain term. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping: Term => <docNum, freq>* The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Back to Top
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Method

MultiReader TermDocs Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermDocs TermDocs()
public override TermDocs TermDocs()
Public Overrides Function TermDocs As TermDocs
Public Overrides Function TermDocs As TermDocs
public:
virtual TermDocs^ TermDocs() override
public:
virtual TermDocs^ TermDocs() override
See Also
MultiReader Class
MultiReader Members
TermDocs Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Method

MultiReader TermPositions Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TermPositions | (Overrides IndexReader TermPositions .)
Public method | TermPositions(Term) | Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping: Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >* This positional information facilitates phrase and proximity searching. The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Back to Top
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Method

MultiReader TermPositions Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermPositions TermPositions()
public override TermPositions TermPositions()
Public Overrides Function TermPositions As TermPositions
Public Overrides Function TermPositions As TermPositions
public:
virtual TermPositions^ TermPositions() override
public:
virtual TermPositions^ TermPositions() override
See Also
MultiReader Class
MultiReader Members
TermPositions Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method

MultiReader Terms Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Terms | (Overrides IndexReader Terms .)
Public method | Terms(Term) | (Overrides IndexReader Terms(Term).)
Back to Top
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method

MultiReader Terms Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermEnum Terms()
public override TermEnum Terms()
Public Overrides Function Terms As TermEnum
Public Overrides Function Terms As TermEnum
public:
virtual TermEnum^ Terms() override
public:
virtual TermEnum^ Terms() override
See Also
MultiReader Class
MultiReader Members
Terms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method (Term)

MultiReader Terms Method (Term) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermEnum Terms(
    Term term
)
public override TermEnum Terms(
    Term term
)
Public Overrides Function Terms ( _
    term As Term _
) As TermEnum
Public Overrides Function Terms ( _
    term As Term _
) As TermEnum
public:
virtual TermEnum^ Terms(
    Term^ term
) override
public:
virtual TermEnum^ Terms(
    Term^ term
) override
Parameters
term
Type: Lucene.Net.Index Term
See Also
MultiReader Class
MultiReader Members
Terms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiReader Properties

MultiReader Properties Lucene.Net Class Library
The MultiReader type exposes the following members.
Properties
 | Name | Description
Public property | CommitUserData | Retrieve the String userData optionally passed to Commit(IDictionary String, String ). This will return null if Commit(IDictionary String, String ) has never been called for this index. (Inherited from IndexReader.)
Public property | DeletesCacheKey | (Inherited from IndexReader.)
Public property | FieldCacheKey | Expert (Inherited from IndexReader.)
Public property | HasDeletions | (Overrides IndexReader HasDeletions.)
Public property | IndexCommit | Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: this API is new and experimental and may suddenly change. (Inherited from IndexReader.)
Public property | Item | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public property | MaxDoc | (Overrides IndexReader MaxDoc.)
Public property | NumDeletedDocs | Returns the number of deleted documents. (Inherited from IndexReader.)
Public property | RefCount | Expert: returns the current refCount for this reader (Inherited from IndexReader.)
Public property | TermInfosIndexDivisor | For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened. (Inherited from IndexReader.)
Public property | UniqueTermCount | Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed. (Inherited from IndexReader.)
Public property | Version | Not implemented. (Overrides IndexReader Version.)
Back to Top
See Also
MultiReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasDeletions Property

MultiReader HasDeletions Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool HasDeletions { get; }
public override bool HasDeletions { get; }
Public Overrides ReadOnly Property HasDeletions As Boolean
    Get
Public Overrides ReadOnly Property HasDeletions As Boolean
    Get
public:
virtual property bool HasDeletions {
    bool get () override;
}
public:
virtual property bool HasDeletions {
    bool get () override;
}
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxDoc Property

MultiReader MaxDoc Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int MaxDoc { get; }
public override int MaxDoc { get; }
Public Overrides ReadOnly Property MaxDoc As Integer
    Get
Public Overrides ReadOnly Property MaxDoc As Integer
    Get
public:
virtual property int MaxDoc {
    int get () override;
}
public:
virtual property int MaxDoc {
    int get () override;
}
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Version Property

MultiReader Version Property Lucene.Net Class Library
Not implemented.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Version { get; }
public override long Version { get; }
Public Overrides ReadOnly Property Version As Long
    Get
Public Overrides ReadOnly Property Version As Long
    Get
public:
virtual property long long Version {
    long long get () override;
}
public:
virtual property long long Version {
    long long get () override;
}
See Also
MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParallelReader Class

ParallelReader Class Lucene.Net Class Library
An IndexReader which reads multiple, parallel indexes. Each index added must have the same number of documents, but typically each contains different fields. Each document contains the union of the fields of all documents with the same document number. When searching, matches for a query term are from the first index added that has the field.

This is useful, e.g., with collections that have large fields which change rarely and small fields that change more frequently. The smaller fields may be re-indexed in a new index and both indexes may be searched together.

Warning: It is up to you to make sure all indexes are created and modified the same way. For example, if you add documents to one index, you need to add the same documents in the same order to the other indexes. Failure to do so will result in undefined behavior.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index IndexReader
Lucene.Net.Index ParallelReader

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ParallelReader : IndexReader,
    ICloneable
public class ParallelReader : IndexReader,
    ICloneable
Public Class ParallelReader _
    Inherits IndexReader _
    Implements ICloneable
Public Class ParallelReader _
    Inherits IndexReader _
    Implements ICloneable
public ref class ParallelReader : public IndexReader,
    ICloneable
public ref class ParallelReader : public IndexReader,
    ICloneable
See Also
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParallelReader Members

ParallelReader Members Lucene.Net Class Library

The ParallelReader type exposes the following members.
Constructors
 | Name | Description
Public method | ParallelReader | Construct a ParallelReader. Note that all subreaders are closed if this ParallelReader is closed.
Public method | ParallelReader(Boolean) | Construct a ParallelReader.
Back to Top
Methods
 | Name | Description
Protected method | AcquireWriteLock | Does nothing by default. Subclasses that require a write lock for index modifications must implement this method. (Inherited from IndexReader.)
Public method | Add(IndexReader) | Add an IndexReader.
Public method | Add(IndexReader, Boolean) | Add an IndexReader whose stored fields will not be returned. This can accellerate search when stored fields are only needed from a subset of the IndexReaders.
Public method | Clone | (Overrides IndexReader Clone .)
Public method | Clone(Boolean) | Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader. (Inherited from IndexReader.)
Public method | Close | Obsolete. (Inherited from IndexReader.)
Public method | Commit | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | Commit(IDictionary String, String ) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | DecRef | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed. (Inherited from IndexReader.)
Public method | DeleteDocument | Deletes the document numbered docNum. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the Document(Int32) method will result in an error. The presence of this document may still be reflected in the DocFreq(Term) statistic, though this will be corrected eventually as the index is further modified. (Inherited from IndexReader.)
Public method | DeleteDocuments | Deletes all documents that have a given term indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See DeleteDocument(Int32) for information about when this deletion will become effective. (Inherited from IndexReader.)
Public method | Directory | Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified. (Inherited from IndexReader.)
Public method | Dispose | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called. (Inherited from IndexReader.)
Protected method | Dispose(Boolean) | (Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader DoClose .)
Protected method | DoCommit | (Overrides IndexReader DoCommit(IDictionary String, String ).)
Public method | Document(Int32) | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader DoDelete(Int32).)
Protected method | DoReopen |
Protected method | DoSetNorm | (Overrides IndexReader DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader DoUndeleteAll .)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Inherited from IndexReader.)
Public method | Flush(IDictionary String, String ) | (Inherited from IndexReader.)
Public method | GetFieldNames | (Overrides IndexReader GetFieldNames(IndexReader FieldOption).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSequentialSubReaders | Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers). NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through Open(Directory, Boolean). Use the parent reader directly. (Inherited from IndexReader.)
Public method | GetSubReaders |
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method | GetTermFreqVectors | (Overrides IndexReader GetTermFreqVectors(Int32).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasNorms | (Overrides IndexReader HasNorms(String).)
Public method | IncRef | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding DecRef , in a finally clause; otherwise the reader may never be closed. Note that Close simply calls decRef(), which means that the IndexReader will not really be closed until DecRef has been called for all outstanding references. (Inherited from IndexReader.)
Public method | IsCurrent | Checks recursively if all subreaders are up to date. (Overrides IndexReader IsCurrent .)
Public method | IsDeleted | (Overrides IndexReader IsDeleted(Int32).)
Public method | IsOptimized | Checks recursively if all subindexes are optimized (Overrides IndexReader IsOptimized .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Norms(String) | (Overrides IndexReader Norms(String).)
Public method | Norms(String, Byte , Int32) | (Overrides IndexReader Norms(String, Byte , Int32).)
Public method | NumDocs | (Overrides IndexReader NumDocs .)
Public method | Reopen | Tries to reopen the subreaders. If one or more subreaders could be re-opened (i. e. subReader.reopen() returned a new instance != subReader), then a new ParallelReader instance is returned, otherwise this instance is returned. A re-opened instance might share one or more subreaders with the old instance. Index modification operations result in undefined behavior when performed before the old instance is closed. (see Reopen ). If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed. (Overrides IndexReader Reopen .)
Public method | Reopen(Boolean) | Just like Reopen , except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned. (Inherited from IndexReader.)
Public method | Reopen(IndexCommit) | Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Byte) | Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Single) | Expert: Resets the normalization factor for the named field of the named document. (Inherited from IndexReader.)
Public method | TermDocs | (Overrides IndexReader TermDocs .)
Public method | TermDocs(Term) | (Overrides IndexReader TermDocs(Term).)
Public method | TermPositions | (Overrides IndexReader TermPositions .)
Public method | TermPositions(Term) | (Overrides IndexReader TermPositions(Term).)
Public method | Terms | (Overrides IndexReader Terms .)
Public method | Terms(Term) | (Overrides IndexReader Terms(Term).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UndeleteAll | Undeletes all documents currently marked as deleted in this index. (Inherited from IndexReader.)
Back to Top
Fields
 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Back to Top
Properties
 | Name | Description
Public property | CommitUserData | Retrieve the String userData optionally passed to Commit(IDictionary String, String ). This will return null if Commit(IDictionary String, String ) has never been called for this index. (Inherited from IndexReader.)
Public property | DeletesCacheKey | (Inherited from IndexReader.)
Public property | FieldCacheKey | Expert (Inherited from IndexReader.)
Public property | HasDeletions | (Overrides IndexReader HasDeletions.)
Public property | IndexCommit | Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: this API is new and experimental and may suddenly change. (Inherited from IndexReader.)
Public property | Item | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public property | MaxDoc | (Overrides IndexReader MaxDoc.)
Public property | NumDeletedDocs | Returns the number of deleted documents. (Inherited from IndexReader.)
Public property | RefCount | Expert: returns the current refCount for this reader (Inherited from IndexReader.)
Public property | TermInfosIndexDivisor | For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened. (Inherited from IndexReader.)
Public property | UniqueTermCount | Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed. (Inherited from IndexReader.)
Public property | Version | Not implemented. (Overrides IndexReader Version.)
Back to Top
See Also
ParallelReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParallelReader Constructor

ParallelReader Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ParallelReader | Construct a ParallelReader. Note that all subreaders are closed if this ParallelReader is closed.
Public method | ParallelReader(Boolean) | Construct a ParallelReader.
Back to Top
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParallelReader Constructor

ParallelReader Constructor Lucene.Net Class Library
Construct a ParallelReader.

Note that all subreaders are closed if this ParallelReader is closed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ParallelReader()
public ParallelReader()
Public Sub New
Public Sub New
public:
ParallelReader()
public:
ParallelReader()
See Also
ParallelReader Class
ParallelReader Members
ParallelReader Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParallelReader Constructor (Boolean)

ParallelReader Constructor (Boolean) Lucene.Net Class Library
Construct a ParallelReader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ParallelReader(
    bool closeSubReaders
)
public ParallelReader(
    bool closeSubReaders
)
Public Sub New ( _
    closeSubReaders As Boolean _
)
Public Sub New ( _
    closeSubReaders As Boolean _
)
public:
ParallelReader(
    bool closeSubReaders
)
public:
ParallelReader(
    bool closeSubReaders
)
Parameters
closeSubReaders
Type:   Online System Boolean
indicates whether the subreaders should be closed
            when this ParallelReader is closed

See Also
ParallelReader Class
ParallelReader Members
ParallelReader Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParallelReader Fields

ParallelReader Fields Lucene.Net Class Library
The ParallelReader type exposes the following members.
Fields
 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Back to Top
See Also
ParallelReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParallelReader Methods

ParallelReader Methods Lucene.Net Class Library
The ParallelReader type exposes the following members.
Methods
 | Name | Description
Protected method | AcquireWriteLock | Does nothing by default. Subclasses that require a write lock for index modifications must implement this method. (Inherited from IndexReader.)
Public method | Add(IndexReader) | Add an IndexReader.
Public method | Add(IndexReader, Boolean) | Add an IndexReader whose stored fields will not be returned. This can accellerate search when stored fields are only needed from a subset of the IndexReaders.
Public method | Clone | (Overrides IndexReader Clone .)
Public method | Clone(Boolean) | Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader. (Inherited from IndexReader.)
Public method | Close | Obsolete. (Inherited from IndexReader.)
Public method | Commit | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | Commit(IDictionary String, String ) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | DecRef | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed. (Inherited from IndexReader.)
Public method | DeleteDocument | Deletes the document numbered docNum. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the Document(Int32) method will result in an error. The presence of this document may still be reflected in the DocFreq(Term) statistic, though this will be corrected eventually as the index is further modified. (Inherited from IndexReader.)
Public method | DeleteDocuments | Deletes all documents that have a given term indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See DeleteDocument(Int32) for information about when this deletion will become effective. (Inherited from IndexReader.)
Public method | Directory | Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified. (Inherited from IndexReader.)
Public method | Dispose | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called. (Inherited from IndexReader.)
Protected method | Dispose(Boolean) | (Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader DoClose .)
Protected method | DoCommit | (Overrides IndexReader DoCommit(IDictionary String, String ).)
Public method | Document(Int32) | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader DoDelete(Int32).)
Protected method | DoReopen |
Protected method | DoSetNorm | (Overrides IndexReader DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader DoUndeleteAll .)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Inherited from IndexReader.)
Public method | Flush(IDictionary String, String ) | (Inherited from IndexReader.)
Public method | GetFieldNames | (Overrides IndexReader GetFieldNames(IndexReader FieldOption).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSequentialSubReaders | Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers). NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through Open(Directory, Boolean). Use the parent reader directly. (Inherited from IndexReader.)
Public method | GetSubReaders |
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method | GetTermFreqVectors | (Overrides IndexReader GetTermFreqVectors(Int32).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasNorms | (Overrides IndexReader HasNorms(String).)
Public method | IncRef | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding DecRef , in a finally clause; otherwise the reader may never be closed. Note that Close simply calls decRef(), which means that the IndexReader will not really be closed until DecRef has been called for all outstanding references. (Inherited from IndexReader.)
Public method | IsCurrent | Checks recursively if all subreaders are up to date. (Overrides IndexReader IsCurrent .)
Public method | IsDeleted | (Overrides IndexReader IsDeleted(Int32).)
Public method | IsOptimized | Checks recursively if all subindexes are optimized (Overrides IndexReader IsOptimized .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Norms(String) | (Overrides IndexReader Norms(String).)
Public method | Norms(String, Byte , Int32) | (Overrides IndexReader Norms(String, Byte , Int32).)
Public method | NumDocs | (Overrides IndexReader NumDocs .)
Public method | Reopen | Tries to reopen the subreaders. If one or more subreaders could be re-opened (i. e. subReader.reopen() returned a new instance != subReader), then a new ParallelReader instance is returned, otherwise this instance is returned. A re-opened instance might share one or more subreaders with the old instance. Index modification operations result in undefined behavior when performed before the old instance is closed. (see Reopen ). If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed. (Overrides IndexReader Reopen .)
Public method | Reopen(Boolean) | Just like Reopen , except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned. (Inherited from IndexReader.)
Public method | Reopen(IndexCommit) | Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Byte) | Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Single) | Expert: Resets the normalization factor for the named field of the named document. (Inherited from IndexReader.)
Public method | TermDocs | (Overrides IndexReader TermDocs .)
Public method | TermDocs(Term) | (Overrides IndexReader TermDocs(Term).)
Public method | TermPositions | (Overrides IndexReader TermPositions .)
Public method | TermPositions(Term) | (Overrides IndexReader TermPositions(Term).)
Public method | Terms | (Overrides IndexReader Terms .)
Public method | Terms(Term) | (Overrides IndexReader Terms(Term).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UndeleteAll | Undeletes all documents currently marked as deleted in this index. (Inherited from IndexReader.)
Back to Top
See Also
ParallelReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method

ParallelReader Add Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Add(IndexReader) | Add an IndexReader.
Public method | Add(IndexReader, Boolean) | Add an IndexReader whose stored fields will not be returned. This can accellerate search when stored fields are only needed from a subset of the IndexReaders.
Back to Top
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (IndexReader)

ParallelReader Add Method (IndexReader) Lucene.Net Class Library
Add an IndexReader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Add(
    IndexReader reader
)
public virtual void Add(
    IndexReader reader
)
Public Overridable Sub Add ( _
    reader As IndexReader _
)
Public Overridable Sub Add ( _
    reader As IndexReader _
)
public:
virtual void Add(
    IndexReader^ reader
)
public:
virtual void Add(
    IndexReader^ reader
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
ParallelReader Class
ParallelReader Members
Add Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (IndexReader, Boolean)

ParallelReader Add Method (IndexReader, Boolean) Lucene.Net Class Library
Add an IndexReader whose stored fields will not be returned. This can accellerate search when stored fields are only needed from a subset of the IndexReaders.
of documents
of MaxDoc

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Add(
    IndexReader reader,
    bool ignoreStoredFields
)
public virtual void Add(
    IndexReader reader,
    bool ignoreStoredFields
)
Public Overridable Sub Add ( _
    reader As IndexReader, _
    ignoreStoredFields As Boolean _
)
Public Overridable Sub Add ( _
    reader As IndexReader, _
    ignoreStoredFields As Boolean _
)
public:
virtual void Add(
    IndexReader^ reader,
    bool ignoreStoredFields
)
public:
virtual void Add(
    IndexReader^ reader,
    bool ignoreStoredFields
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
ignoreStoredFields
Type:   Online System Boolean
See Also
ParallelReader Class
ParallelReader Members
Add Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

ParallelReader Clone Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Clone | (Overrides IndexReader Clone .)
Public method | Clone(Boolean) | Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader. (Inherited from IndexReader.)
Back to Top
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

ParallelReader Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
ParallelReader Class
ParallelReader Members
Clone Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocFreq Method

ParallelReader DocFreq Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocFreq(
    Term term
)
public override int DocFreq(
    Term term
)
Public Overrides Function DocFreq ( _
    term As Term _
) As Integer
Public Overrides Function DocFreq ( _
    term As Term _
) As Integer
public:
virtual int DocFreq(
    Term^ term
) override
public:
virtual int DocFreq(
    Term^ term
) override
Parameters
term
Type: Lucene.Net.Index Term
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoClose Method

ParallelReader DoClose Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoClose()
protected override void DoClose()
Protected Overrides Sub DoClose
Protected Overrides Sub DoClose
protected:
virtual void DoClose() override
protected:
virtual void DoClose() override
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoCommit Method

ParallelReader DoCommit Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoCommit(
    IDictionary<string, string> commitUserData
)
protected override void DoCommit(
    IDictionary<string, string> commitUserData
)
Protected Overrides Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
Protected Overrides Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
protected:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
) override
protected:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
) override
Parameters
commitUserData
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Method

ParallelReader Document Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Document(Int32) | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader Document(Int32, FieldSelector).)
Back to Top
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Method (Int32, FieldSelector)

ParallelReader Document Method (Int32, FieldSelector) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Document Document(
    int n,
    FieldSelector fieldSelector
)
public override Document Document(
    int n,
    FieldSelector fieldSelector
)
Public Overrides Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Public Overrides Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) override
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) override
Parameters
n
Type:   Online System Int32
fieldSelector
Type: Lucene.Net.Documents FieldSelector
See Also
ParallelReader Class
ParallelReader Members
Document Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoDelete Method

ParallelReader DoDelete Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoDelete(
    int n
)
protected override void DoDelete(
    int n
)
Protected Overrides Sub DoDelete ( _
    n As Integer _
)
Protected Overrides Sub DoDelete ( _
    n As Integer _
)
protected:
virtual void DoDelete(
    int n
) override
protected:
virtual void DoDelete(
    int n
) override
Parameters
n
Type:   Online System Int32
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoReopen Method

ParallelReader DoReopen Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual IndexReader DoReopen(
    bool doClone
)
protected virtual IndexReader DoReopen(
    bool doClone
)
Protected Overridable Function DoReopen ( _
    doClone As Boolean _
) As IndexReader
Protected Overridable Function DoReopen ( _
    doClone As Boolean _
) As IndexReader
protected:
virtual IndexReader^ DoReopen(
    bool doClone
)
protected:
virtual IndexReader^ DoReopen(
    bool doClone
)
Parameters
doClone
Type:   Online System Boolean
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoSetNorm Method

ParallelReader DoSetNorm Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSetNorm(
    int n,
    string field,
    byte value_Renamed
)
protected override void DoSetNorm(
    int n,
    string field,
    byte value_Renamed
)
Protected Overrides Sub DoSetNorm ( _
    n As Integer, _
    field As String, _
    value_Renamed As Byte _
)
Protected Overrides Sub DoSetNorm ( _
    n As Integer, _
    field As String, _
    value_Renamed As Byte _
)
protected:
virtual void DoSetNorm(
    int n,
    String^ field,
    unsigned char value_Renamed
) override
protected:
virtual void DoSetNorm(
    int n,
    String^ field,
    unsigned char value_Renamed
) override
Parameters
n
Type:   Online System Int32
field
Type:   Online System String
value_Renamed
Type:   Online System Byte
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoUndeleteAll Method

ParallelReader DoUndeleteAll Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoUndeleteAll()
protected override void DoUndeleteAll()
Protected Overrides Sub DoUndeleteAll
Protected Overrides Sub DoUndeleteAll
protected:
virtual void DoUndeleteAll() override
protected:
virtual void DoUndeleteAll() override
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFieldNames Method

ParallelReader GetFieldNames Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fieldNames
)
public override ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fieldNames
)
Public Overrides Function GetFieldNames ( _
    fieldNames As IndexReader..::..FieldOption _
) As ICollection(Of String)
Public Overrides Function GetFieldNames ( _
    fieldNames As IndexReader..::..FieldOption _
) As ICollection(Of String)
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fieldNames
) override
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fieldNames
) override
Parameters
fieldNames
Type: Lucene.Net.Index IndexReader FieldOption
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSubReaders Method

ParallelReader GetSubReaders Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IndexReader[] GetSubReaders()
public virtual IndexReader[] GetSubReaders()
Public Overridable Function GetSubReaders As IndexReader()
Public Overridable Function GetSubReaders As IndexReader()
public:
virtual array<IndexReader^>^ GetSubReaders()
public:
virtual array<IndexReader^>^ GetSubReaders()
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method

ParallelReader GetTermFreqVector Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, String, TermVectorMapper).)
Back to Top
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, TermVectorMapper)

ParallelReader GetTermFreqVector Method (Int32, TermVectorMapper) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
public override void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) override
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) override
Parameters
docNumber
Type:   Online System Int32
mapper
Type: Lucene.Net.Index TermVectorMapper
See Also
ParallelReader Class
ParallelReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, String)

ParallelReader GetTermFreqVector Method (Int32, String) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ITermFreqVector GetTermFreqVector(
    int n,
    string field
)
public override ITermFreqVector GetTermFreqVector(
    int n,
    string field
)
Public Overrides Function GetTermFreqVector ( _
    n As Integer, _
    field As String _
) As ITermFreqVector
Public Overrides Function GetTermFreqVector ( _
    n As Integer, _
    field As String _
) As ITermFreqVector
public:
virtual ITermFreqVector^ GetTermFreqVector(
    int n,
    String^ field
) override
public:
virtual ITermFreqVector^ GetTermFreqVector(
    int n,
    String^ field
) override
Parameters
n
Type:   Online System Int32
field
Type:   Online System String
See Also
ParallelReader Class
ParallelReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, String, TermVectorMapper)

ParallelReader GetTermFreqVector Method (Int32, String, TermVectorMapper) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
public override void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) override
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) override
Parameters
docNumber
Type:   Online System Int32
field
Type:   Online System String
mapper
Type: Lucene.Net.Index TermVectorMapper
See Also
ParallelReader Class
ParallelReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVectors Method

ParallelReader GetTermFreqVectors Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ITermFreqVector[] GetTermFreqVectors(
    int n
)
public override ITermFreqVector[] GetTermFreqVectors(
    int n
)
Public Overrides Function GetTermFreqVectors ( _
    n As Integer _
) As ITermFreqVector()
Public Overrides Function GetTermFreqVectors ( _
    n As Integer _
) As ITermFreqVector()
public:
virtual array<ITermFreqVector^>^ GetTermFreqVectors(
    int n
) override
public:
virtual array<ITermFreqVector^>^ GetTermFreqVectors(
    int n
) override
Parameters
n
Type:   Online System Int32
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasNorms Method

ParallelReader HasNorms Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool HasNorms(
    string field
)
public override bool HasNorms(
    string field
)
Public Overrides Function HasNorms ( _
    field As String _
) As Boolean
Public Overrides Function HasNorms ( _
    field As String _
) As Boolean
public:
virtual bool HasNorms(
    String^ field
) override
public:
virtual bool HasNorms(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsCurrent Method

ParallelReader IsCurrent Method Lucene.Net Class Library
Checks recursively if all subreaders are up to date.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsCurrent()
public override bool IsCurrent()
Public Overrides Function IsCurrent As Boolean
Public Overrides Function IsCurrent As Boolean
public:
virtual bool IsCurrent() override
public:
virtual bool IsCurrent() override
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsDeleted Method

ParallelReader IsDeleted Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsDeleted(
    int n
)
public override bool IsDeleted(
    int n
)
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
public:
virtual bool IsDeleted(
    int n
) override
public:
virtual bool IsDeleted(
    int n
) override
Parameters
n
Type:   Online System Int32
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsOptimized Method

ParallelReader IsOptimized Method Lucene.Net Class Library
Checks recursively if all subindexes are optimized

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsOptimized()
public override bool IsOptimized()
Public Overrides Function IsOptimized As Boolean
Public Overrides Function IsOptimized As Boolean
public:
virtual bool IsOptimized() override
public:
virtual bool IsOptimized() override
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method

ParallelReader Norms Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Norms(String) | (Overrides IndexReader Norms(String).)
Public method | Norms(String, Byte , Int32) | (Overrides IndexReader Norms(String, Byte , Int32).)
Back to Top
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method (String)

ParallelReader Norms Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override byte[] Norms(
    string field
)
public override byte[] Norms(
    string field
)
Public Overrides Function Norms ( _
    field As String _
) As Byte()
Public Overrides Function Norms ( _
    field As String _
) As Byte()
public:
virtual array<unsigned char>^ Norms(
    String^ field
) override
public:
virtual array<unsigned char>^ Norms(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
ParallelReader Class
ParallelReader Members
Norms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method (String, Byte[], Int32)

ParallelReader Norms Method (String, Byte , Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Norms(
    string field,
    byte[] result,
    int offset
)
public override void Norms(
    string field,
    byte[] result,
    int offset
)
Public Overrides Sub Norms ( _
    field As String, _
    result As Byte(), _
    offset As Integer _
)
Public Overrides Sub Norms ( _
    field As String, _
    result As Byte(), _
    offset As Integer _
)
public:
virtual void Norms(
    String^ field,
    array<unsigned char>^ result,
    int offset
) override
public:
virtual void Norms(
    String^ field,
    array<unsigned char>^ result,
    int offset
) override
Parameters
field
Type:   Online System String
result
Type:    Online System Byte
offset
Type:   Online System Int32
See Also
ParallelReader Class
ParallelReader Members
Norms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumDocs Method

ParallelReader NumDocs Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int NumDocs()
public override int NumDocs()
Public Overrides Function NumDocs As Integer
Public Overrides Function NumDocs As Integer
public:
virtual int NumDocs() override
public:
virtual int NumDocs() override
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reopen Method

ParallelReader Reopen Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Reopen | Tries to reopen the subreaders. If one or more subreaders could be re-opened (i. e. subReader.reopen() returned a new instance != subReader), then a new ParallelReader instance is returned, otherwise this instance is returned. A re-opened instance might share one or more subreaders with the old instance. Index modification operations result in undefined behavior when performed before the old instance is closed. (see Reopen ). If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed. (Overrides IndexReader Reopen .)
Public method | Reopen(Boolean) | Just like Reopen , except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned. (Inherited from IndexReader.)
Public method | Reopen(IndexCommit) | Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned. (Inherited from IndexReader.)
Back to Top
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reopen Method

ParallelReader Reopen Method Lucene.Net Class Library
Tries to reopen the subreaders.
If one or more subreaders could be re-opened (i. e. subReader.reopen() returned a new instance != subReader), then a new ParallelReader instance is returned, otherwise this instance is returned.

A re-opened instance might share one or more subreaders with the old instance. Index modification operations result in undefined behavior when performed before the old instance is closed. (see Reopen ).

If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexReader Reopen()
public override IndexReader Reopen()
Public Overrides Function Reopen As IndexReader
Public Overrides Function Reopen As IndexReader
public:
virtual IndexReader^ Reopen() override
public:
virtual IndexReader^ Reopen() override
See Also
ParallelReader Class
ParallelReader Members
Reopen Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Method

ParallelReader TermDocs Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TermDocs | (Overrides IndexReader TermDocs .)
Public method | TermDocs(Term) | (Overrides IndexReader TermDocs(Term).)
Back to Top
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Method

ParallelReader TermDocs Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermDocs TermDocs()
public override TermDocs TermDocs()
Public Overrides Function TermDocs As TermDocs
Public Overrides Function TermDocs As TermDocs
public:
virtual TermDocs^ TermDocs() override
public:
virtual TermDocs^ TermDocs() override
See Also
ParallelReader Class
ParallelReader Members
TermDocs Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Method (Term)

ParallelReader TermDocs Method (Term) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermDocs TermDocs(
    Term term
)
public override TermDocs TermDocs(
    Term term
)
Public Overrides Function TermDocs ( _
    term As Term _
) As TermDocs
Public Overrides Function TermDocs ( _
    term As Term _
) As TermDocs
public:
virtual TermDocs^ TermDocs(
    Term^ term
) override
public:
virtual TermDocs^ TermDocs(
    Term^ term
) override
Parameters
term
Type: Lucene.Net.Index Term
See Also
ParallelReader Class
ParallelReader Members
TermDocs Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Method

ParallelReader TermPositions Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TermPositions | (Overrides IndexReader TermPositions .)
Public method | TermPositions(Term) | (Overrides IndexReader TermPositions(Term).)
Back to Top
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Method

ParallelReader TermPositions Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermPositions TermPositions()
public override TermPositions TermPositions()
Public Overrides Function TermPositions As TermPositions
Public Overrides Function TermPositions As TermPositions
public:
virtual TermPositions^ TermPositions() override
public:
virtual TermPositions^ TermPositions() override
See Also
ParallelReader Class
ParallelReader Members
TermPositions Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Method (Term)

ParallelReader TermPositions Method (Term) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermPositions TermPositions(
    Term term
)
public override TermPositions TermPositions(
    Term term
)
Public Overrides Function TermPositions ( _
    term As Term _
) As TermPositions
Public Overrides Function TermPositions ( _
    term As Term _
) As TermPositions
public:
virtual TermPositions^ TermPositions(
    Term^ term
) override
public:
virtual TermPositions^ TermPositions(
    Term^ term
) override
Parameters
term
Type: Lucene.Net.Index Term
See Also
ParallelReader Class
ParallelReader Members
TermPositions Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method

ParallelReader Terms Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Terms | (Overrides IndexReader Terms .)
Public method | Terms(Term) | (Overrides IndexReader Terms(Term).)
Back to Top
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method

ParallelReader Terms Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermEnum Terms()
public override TermEnum Terms()
Public Overrides Function Terms As TermEnum
Public Overrides Function Terms As TermEnum
public:
virtual TermEnum^ Terms() override
public:
virtual TermEnum^ Terms() override
See Also
ParallelReader Class
ParallelReader Members
Terms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method (Term)

ParallelReader Terms Method (Term) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermEnum Terms(
    Term term
)
public override TermEnum Terms(
    Term term
)
Public Overrides Function Terms ( _
    term As Term _
) As TermEnum
Public Overrides Function Terms ( _
    term As Term _
) As TermEnum
public:
virtual TermEnum^ Terms(
    Term^ term
) override
public:
virtual TermEnum^ Terms(
    Term^ term
) override
Parameters
term
Type: Lucene.Net.Index Term
See Also
ParallelReader Class
ParallelReader Members
Terms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParallelReader Properties

ParallelReader Properties Lucene.Net Class Library
The ParallelReader type exposes the following members.
Properties
 | Name | Description
Public property | CommitUserData | Retrieve the String userData optionally passed to Commit(IDictionary String, String ). This will return null if Commit(IDictionary String, String ) has never been called for this index. (Inherited from IndexReader.)
Public property | DeletesCacheKey | (Inherited from IndexReader.)
Public property | FieldCacheKey | Expert (Inherited from IndexReader.)
Public property | HasDeletions | (Overrides IndexReader HasDeletions.)
Public property | IndexCommit | Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: this API is new and experimental and may suddenly change. (Inherited from IndexReader.)
Public property | Item | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public property | MaxDoc | (Overrides IndexReader MaxDoc.)
Public property | NumDeletedDocs | Returns the number of deleted documents. (Inherited from IndexReader.)
Public property | RefCount | Expert: returns the current refCount for this reader (Inherited from IndexReader.)
Public property | TermInfosIndexDivisor | For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened. (Inherited from IndexReader.)
Public property | UniqueTermCount | Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed. (Inherited from IndexReader.)
Public property | Version | Not implemented. (Overrides IndexReader Version.)
Back to Top
See Also
ParallelReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasDeletions Property

ParallelReader HasDeletions Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool HasDeletions { get; }
public override bool HasDeletions { get; }
Public Overrides ReadOnly Property HasDeletions As Boolean
    Get
Public Overrides ReadOnly Property HasDeletions As Boolean
    Get
public:
virtual property bool HasDeletions {
    bool get () override;
}
public:
virtual property bool HasDeletions {
    bool get () override;
}
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxDoc Property

ParallelReader MaxDoc Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int MaxDoc { get; }
public override int MaxDoc { get; }
Public Overrides ReadOnly Property MaxDoc As Integer
    Get
Public Overrides ReadOnly Property MaxDoc As Integer
    Get
public:
virtual property int MaxDoc {
    int get () override;
}
public:
virtual property int MaxDoc {
    int get () override;
}
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Version Property

ParallelReader Version Property Lucene.Net Class Library
Not implemented.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Version { get; }
public override long Version { get; }
Public Overrides ReadOnly Property Version As Long
    Get
Public Overrides ReadOnly Property Version As Long
    Get
public:
virtual property long long Version {
    long long get () override;
}
public:
virtual property long long Version {
    long long get () override;
}
See Also
ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Payload Class

Payload Class Lucene.Net Class Library
A Payload is metadata that can be stored together with each occurrence of a term. This metadata is stored inline in the posting list of the specific term.

To store payloads in the index a TokenStream has to be used that produces payload data.

Use PayloadLength and GetPayload( Byte , Int32) to retrieve the payloads from the index.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index Payload

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class Payload : ICloneable
[SerializableAttribute]
public class Payload : ICloneable
<SerializableAttribute> _
Public Class Payload _
    Implements ICloneable
<SerializableAttribute> _
Public Class Payload _
    Implements ICloneable
[SerializableAttribute]
public ref class Payload : ICloneable
[SerializableAttribute]
public ref class Payload : ICloneable
See Also
Payload Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Payload Members

Payload Members Lucene.Net Class Library

The Payload type exposes the following members.
Constructors
 | Name | Description
Public method | Payload | Creates an empty payload and does not allocate a byte array.
Public method | Payload( Byte ) | Creates a new payload with the the given array as data. A reference to the passed-in array is held, i. e. no copy is made.
Public method | Payload( Byte , Int32, Int32) | Creates a new payload with the the given array as data. A reference to the passed-in array is held, i. e. no copy is made.
Back to Top
Methods
 | Name | Description
Public method | ByteAt | Returns the byte at the given index.
Public method | Clone | Clones this payload by creating a copy of the underlying byte array.
Public method | CopyTo | Copies the payload data to a byte array.
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetData | Gets or sets a reference to the underlying byte array that holds this payloads data. Data is not copied.
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetData( Byte ) | Gets or sets a reference to the underlying byte array that holds this payloads data. Data is not copied.
Public method | SetData( Byte , Int32, Int32) | Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.
Public method | ToByteArray | Allocates a new byte array, copies the payload data into it and returns it.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | data | the byte array containing the payload data
Protected field | internalLength | the length of the payload data
Protected field | internalOffset | the offset within the byte array
Back to Top
Properties
 | Name | Description
Public property | Length | Returns the length of the payload data.
Public property | Offset | Returns the offset in the underlying byte array
Back to Top
See Also
Payload Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Payload Constructor

Payload Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Payload | Creates an empty payload and does not allocate a byte array.
Public method | Payload( Byte ) | Creates a new payload with the the given array as data. A reference to the passed-in array is held, i. e. no copy is made.
Public method | Payload( Byte , Int32, Int32) | Creates a new payload with the the given array as data. A reference to the passed-in array is held, i. e. no copy is made.
Back to Top
See Also
Payload Class
Payload Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Payload Constructor

Payload Constructor Lucene.Net Class Library
Creates an empty payload and does not allocate a byte array.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Payload()
public Payload()
Public Sub New
Public Sub New
public:
Payload()
public:
Payload()
See Also
Payload Class
Payload Members
Payload Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Payload Constructor (Byte[])

Payload Constructor ( Byte ) Lucene.Net Class Library
Creates a new payload with the the given array as data. A reference to the passed-in array is held, i. e. no copy is made.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Payload(
    byte[] data
)
public Payload(
    byte[] data
)
Public Sub New ( _
    data As Byte() _
)
Public Sub New ( _
    data As Byte() _
)
public:
Payload(
    array<unsigned char>^ data
)
public:
Payload(
    array<unsigned char>^ data
)
Parameters
data
Type:    Online System Byte
the data of this payload

See Also
Payload Class
Payload Members
Payload Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Payload Constructor (Byte[], Int32, Int32)

Payload Constructor ( Byte , Int32, Int32) Lucene.Net Class Library
Creates a new payload with the the given array as data. A reference to the passed-in array is held, i. e. no copy is made.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Payload(
    byte[] data,
    int offset,
    int length
)
public Payload(
    byte[] data,
    int offset,
    int length
)
Public Sub New ( _
    data As Byte(), _
    offset As Integer, _
    length As Integer _
)
Public Sub New ( _
    data As Byte(), _
    offset As Integer, _
    length As Integer _
)
public:
Payload(
    array<unsigned char>^ data,
    int offset,
    int length
)
public:
Payload(
    array<unsigned char>^ data,
    int offset,
    int length
)
Parameters
data
Type:    Online System Byte
the data of this payload

offset
Type:   Online System Int32
the offset in the data byte array

length
Type:   Online System Int32
the length of the data

See Also
Payload Class
Payload Members
Payload Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Payload Fields

Payload Fields Lucene.Net Class Library
The Payload type exposes the following members.
Fields
 | Name | Description
Protected field | data | the byte array containing the payload data
Protected field | internalLength | the length of the payload data
Protected field | internalOffset | the offset within the byte array
Back to Top
See Also
Payload Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


data Field

Payload data Field Lucene.Net Class Library
the byte array containing the payload data

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected byte[] data
protected byte[] data
Protected data As Byte()
Protected data As Byte()
protected:
array<unsigned char>^ data
protected:
array<unsigned char>^ data
See Also
Payload Class
Payload Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalLength Field

Payload internalLength Field Lucene.Net Class Library
the length of the payload data

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int internalLength
protected int internalLength
Protected internalLength As Integer
Protected internalLength As Integer
protected:
int internalLength
protected:
int internalLength
See Also
Payload Class
Payload Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalOffset Field

Payload internalOffset Field Lucene.Net Class Library
the offset within the byte array

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int internalOffset
protected int internalOffset
Protected internalOffset As Integer
Protected internalOffset As Integer
protected:
int internalOffset
protected:
int internalOffset
See Also
Payload Class
Payload Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Payload Methods

Payload Methods Lucene.Net Class Library
The Payload type exposes the following members.
Methods
 | Name | Description
Public method | ByteAt | Returns the byte at the given index.
Public method | Clone | Clones this payload by creating a copy of the underlying byte array.
Public method | CopyTo | Copies the payload data to a byte array.
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetData | Gets or sets a reference to the underlying byte array that holds this payloads data. Data is not copied.
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetData( Byte ) | Gets or sets a reference to the underlying byte array that holds this payloads data. Data is not copied.
Public method | SetData( Byte , Int32, Int32) | Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.
Public method | ToByteArray | Allocates a new byte array, copies the payload data into it and returns it.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Payload Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteAt Method

Payload ByteAt Method Lucene.Net Class Library
Returns the byte at the given index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual byte ByteAt(
    int index
)
public virtual byte ByteAt(
    int index
)
Public Overridable Function ByteAt ( _
    index As Integer _
) As Byte
Public Overridable Function ByteAt ( _
    index As Integer _
) As Byte
public:
virtual unsigned char ByteAt(
    int index
)
public:
virtual unsigned char ByteAt(
    int index
)
Parameters
index
Type:   Online System Int32
See Also
Payload Class
Payload Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

Payload Clone Method Lucene.Net Class Library
Clones this payload by creating a copy of the underlying byte array.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object Clone()
public virtual Object Clone()
Public Overridable Function Clone As Object
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
public:
virtual Object^ Clone()
Implements
  Online ICloneable Clone
See Also
Payload Class
Payload Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CopyTo Method

Payload CopyTo Method Lucene.Net Class Library
Copies the payload data to a byte array.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void CopyTo(
    byte[] target,
    int targetOffset
)
public virtual void CopyTo(
    byte[] target,
    int targetOffset
)
Public Overridable Sub CopyTo ( _
    target As Byte(), _
    targetOffset As Integer _
)
Public Overridable Sub CopyTo ( _
    target As Byte(), _
    targetOffset As Integer _
)
public:
virtual void CopyTo(
    array<unsigned char>^ target,
    int targetOffset
)
public:
virtual void CopyTo(
    array<unsigned char>^ target,
    int targetOffset
)
Parameters
target
Type:    Online System Byte
the target byte array

targetOffset
Type:   Online System Int32
the offset in the target byte array

See Also
Payload Class
Payload Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

Payload Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
Payload Class
Payload Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetData Method

Payload GetData Method Lucene.Net Class Library
Gets or sets a reference to the underlying byte array that holds this payloads data. Data is not copied.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual byte[] GetData()
public virtual byte[] GetData()
Public Overridable Function GetData As Byte()
Public Overridable Function GetData As Byte()
public:
virtual array<unsigned char>^ GetData()
public:
virtual array<unsigned char>^ GetData()
See Also
Payload Class
Payload Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

Payload GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
Payload Class
Payload Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetData Method

Payload SetData Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | SetData( Byte ) | Gets or sets a reference to the underlying byte array that holds this payloads data. Data is not copied.
Public method | SetData( Byte , Int32, Int32) | Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.
Back to Top
See Also
Payload Class
Payload Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetData Method (Byte[])

Payload SetData Method ( Byte ) Lucene.Net Class Library
Gets or sets a reference to the underlying byte array that holds this payloads data. Data is not copied.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetData(
    byte[] value
)
public virtual void SetData(
    byte[] value
)
Public Overridable Sub SetData ( _
    value As Byte() _
)
Public Overridable Sub SetData ( _
    value As Byte() _
)
public:
virtual void SetData(
    array<unsigned char>^ value
)
public:
virtual void SetData(
    array<unsigned char>^ value
)
Parameters
value
Type:    Online System Byte
See Also
Payload Class
Payload Members
SetData Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetData Method (Byte[], Int32, Int32)

Payload SetData Method ( Byte , Int32, Int32) Lucene.Net Class Library
Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetData(
    byte[] value,
    int offset,
    int length
)
public virtual void SetData(
    byte[] value,
    int offset,
    int length
)
Public Overridable Sub SetData ( _
    value As Byte(), _
    offset As Integer, _
    length As Integer _
)
Public Overridable Sub SetData ( _
    value As Byte(), _
    offset As Integer, _
    length As Integer _
)
public:
virtual void SetData(
    array<unsigned char>^ value,
    int offset,
    int length
)
public:
virtual void SetData(
    array<unsigned char>^ value,
    int offset,
    int length
)
Parameters
value
Type:    Online System Byte
offset
Type:   Online System Int32
length
Type:   Online System Int32
See Also
Payload Class
Payload Members
SetData Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToByteArray Method

Payload ToByteArray Method Lucene.Net Class Library
Allocates a new byte array, copies the payload data into it and returns it.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual byte[] ToByteArray()
public virtual byte[] ToByteArray()
Public Overridable Function ToByteArray As Byte()
Public Overridable Function ToByteArray As Byte()
public:
virtual array<unsigned char>^ ToByteArray()
public:
virtual array<unsigned char>^ ToByteArray()
See Also
Payload Class
Payload Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Payload Properties

Payload Properties Lucene.Net Class Library
The Payload type exposes the following members.
Properties
 | Name | Description
Public property | Length | Returns the length of the payload data.
Public property | Offset | Returns the offset in the underlying byte array
Back to Top
See Also
Payload Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Length Property

Payload Length Property Lucene.Net Class Library
Returns the length of the payload data.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Length { get; }
public virtual int Length { get; }
Public Overridable ReadOnly Property Length As Integer
    Get
Public Overridable ReadOnly Property Length As Integer
    Get
public:
virtual property int Length {
    int get ();
}
public:
virtual property int Length {
    int get ();
}
See Also
Payload Class
Payload Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Offset Property

Payload Offset Property Lucene.Net Class Library
Returns the offset in the underlying byte array

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Offset { get; }
public virtual int Offset { get; }
Public Overridable ReadOnly Property Offset As Integer
    Get
Public Overridable ReadOnly Property Offset As Integer
    Get
public:
virtual property int Offset {
    int get ();
}
public:
virtual property int Offset {
    int get ();
}
See Also
Payload Class
Payload Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionBasedTermVectorMapper Class

PositionBasedTermVectorMapper Class Lucene.Net Class Library
For each Field, store position by position information. It ignores frequency information

This is not thread-safe.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index TermVectorMapper
Lucene.Net.Index PositionBasedTermVectorMapper

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PositionBasedTermVectorMapper : TermVectorMapper
public class PositionBasedTermVectorMapper : TermVectorMapper
Public Class PositionBasedTermVectorMapper _
    Inherits TermVectorMapper
Public Class PositionBasedTermVectorMapper _
    Inherits TermVectorMapper
public ref class PositionBasedTermVectorMapper : public TermVectorMapper
public ref class PositionBasedTermVectorMapper : public TermVectorMapper
See Also
PositionBasedTermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionBasedTermVectorMapper Members

PositionBasedTermVectorMapper Members Lucene.Net Class Library

The PositionBasedTermVectorMapper type exposes the following members.
Constructors
 | Name | Description
Public method | PositionBasedTermVectorMapper | Initializes a new instance of the PositionBasedTermVectorMapper class
Public method | PositionBasedTermVectorMapper(Boolean) | Initializes a new instance of the PositionBasedTermVectorMapper class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Map | Callback for the TermVectorReader. (Overrides TermVectorMapper Map(String, Int32, TermVectorOffsetInfo , Int32 ).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations. (Inherited from TermVectorMapper.)
Public method | SetExpectations | Callback mechanism used by the TermVectorReader (Overrides TermVectorMapper SetExpectations(String, Int32, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | FieldToTerms | Get the mapping between fields and terms, sorted by the comparator
Public property | IsIgnoringOffsets | (Inherited from TermVectorMapper.)
Public property | IsIgnoringPositions | Never ignores positions. This mapper doesn't make much sense unless there are positions (Overrides TermVectorMapper IsIgnoringPositions.)
Back to Top
See Also
PositionBasedTermVectorMapper Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionBasedTermVectorMapper Constructor

PositionBasedTermVectorMapper Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | PositionBasedTermVectorMapper | Initializes a new instance of the PositionBasedTermVectorMapper class
Public method | PositionBasedTermVectorMapper(Boolean) | Initializes a new instance of the PositionBasedTermVectorMapper class
Back to Top
See Also
PositionBasedTermVectorMapper Class
PositionBasedTermVectorMapper Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionBasedTermVectorMapper Constructor

PositionBasedTermVectorMapper Constructor Lucene.Net Class Library
Initializes a new instance of the PositionBasedTermVectorMapper class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PositionBasedTermVectorMapper()
public PositionBasedTermVectorMapper()
Public Sub New
Public Sub New
public:
PositionBasedTermVectorMapper()
public:
PositionBasedTermVectorMapper()
See Also
PositionBasedTermVectorMapper Class
PositionBasedTermVectorMapper Members
PositionBasedTermVectorMapper Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionBasedTermVectorMapper Constructor (Boolean)

PositionBasedTermVectorMapper Constructor (Boolean) Lucene.Net Class Library
Initializes a new instance of the PositionBasedTermVectorMapper class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PositionBasedTermVectorMapper(
    bool ignoringOffsets
)
public PositionBasedTermVectorMapper(
    bool ignoringOffsets
)
Public Sub New ( _
    ignoringOffsets As Boolean _
)
Public Sub New ( _
    ignoringOffsets As Boolean _
)
public:
PositionBasedTermVectorMapper(
    bool ignoringOffsets
)
public:
PositionBasedTermVectorMapper(
    bool ignoringOffsets
)
Parameters
ignoringOffsets
Type:   Online System Boolean
See Also
PositionBasedTermVectorMapper Class
PositionBasedTermVectorMapper Members
PositionBasedTermVectorMapper Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionBasedTermVectorMapper Methods

PositionBasedTermVectorMapper Methods Lucene.Net Class Library
The PositionBasedTermVectorMapper type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Map | Callback for the TermVectorReader. (Overrides TermVectorMapper Map(String, Int32, TermVectorOffsetInfo , Int32 ).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations. (Inherited from TermVectorMapper.)
Public method | SetExpectations | Callback mechanism used by the TermVectorReader (Overrides TermVectorMapper SetExpectations(String, Int32, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PositionBasedTermVectorMapper Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Map Method

PositionBasedTermVectorMapper Map Method Lucene.Net Class Library
Callback for the TermVectorReader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Map(
    string term,
    int frequency,
    TermVectorOffsetInfo[] offsets,
    int[] positions
)
public override void Map(
    string term,
    int frequency,
    TermVectorOffsetInfo[] offsets,
    int[] positions
)
Public Overrides Sub Map ( _
    term As String, _
    frequency As Integer, _
    offsets As TermVectorOffsetInfo(), _
    positions As Integer() _
)
Public Overrides Sub Map ( _
    term As String, _
    frequency As Integer, _
    offsets As TermVectorOffsetInfo(), _
    positions As Integer() _
)
public:
virtual void Map(
    String^ term,
    int frequency,
    array<TermVectorOffsetInfo>^ offsets,
    array<int>^ positions
) override
public:
virtual void Map(
    String^ term,
    int frequency,
    array<TermVectorOffsetInfo>^ offsets,
    array<int>^ positions
) override
Parameters
term
Type:   Online System String
frequency
Type:   Online System Int32
offsets
Type:  Lucene.Net.Index TermVectorOffsetInfo
positions
Type:    Online System Int32
See Also
PositionBasedTermVectorMapper Class
PositionBasedTermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetExpectations Method

PositionBasedTermVectorMapper SetExpectations Method Lucene.Net Class Library
Callback mechanism used by the TermVectorReader

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetExpectations(
    string field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
)
public override void SetExpectations(
    string field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
)
Public Overrides Sub SetExpectations ( _
    field As String, _
    numTerms As Integer, _
    storeOffsets As Boolean, _
    storePositions As Boolean _
)
Public Overrides Sub SetExpectations ( _
    field As String, _
    numTerms As Integer, _
    storeOffsets As Boolean, _
    storePositions As Boolean _
)
public:
virtual void SetExpectations(
    String^ field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
) override
public:
virtual void SetExpectations(
    String^ field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
) override
Parameters
field
Type:   Online System String
 The field being read

numTerms
Type:   Online System Int32
The number of terms in the vector

storeOffsets
Type:   Online System Boolean
Whether offsets are available

storePositions
Type:   Online System Boolean
Whether positions are available

See Also
PositionBasedTermVectorMapper Class
PositionBasedTermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionBasedTermVectorMapper Properties

PositionBasedTermVectorMapper Properties Lucene.Net Class Library
The PositionBasedTermVectorMapper type exposes the following members.
Properties
 | Name | Description
Public property | FieldToTerms | Get the mapping between fields and terms, sorted by the comparator
Public property | IsIgnoringOffsets | (Inherited from TermVectorMapper.)
Public property | IsIgnoringPositions | Never ignores positions. This mapper doesn't make much sense unless there are positions (Overrides TermVectorMapper IsIgnoringPositions.)
Back to Top
See Also
PositionBasedTermVectorMapper Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldToTerms Property

PositionBasedTermVectorMapper FieldToTerms Property Lucene.Net Class Library
Get the mapping between fields and terms, sorted by the comparator

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IDictionary<string, IDictionary<int, PositionBasedTermVectorMapper..::..TVPositionInfo>> FieldToTerms { get; }
public virtual IDictionary<string, IDictionary<int, PositionBasedTermVectorMapper..::..TVPositionInfo>> FieldToTerms { get; }
Public Overridable ReadOnly Property FieldToTerms As IDictionary(Of String, IDictionary(Of Integer, PositionBasedTermVectorMapper..::..TVPositionInfo))
    Get
Public Overridable ReadOnly Property FieldToTerms As IDictionary(Of String, IDictionary(Of Integer, PositionBasedTermVectorMapper..::..TVPositionInfo))
    Get
public:
virtual property IDictionary<String^, IDictionary<int, PositionBasedTermVectorMapper..::..TVPositionInfo^>^>^ FieldToTerms {
    IDictionary<String^, IDictionary<int, PositionBasedTermVectorMapper..::..TVPositionInfo^>^>^ get ();
}
public:
virtual property IDictionary<String^, IDictionary<int, PositionBasedTermVectorMapper..::..TVPositionInfo^>^>^ FieldToTerms {
    IDictionary<String^, IDictionary<int, PositionBasedTermVectorMapper..::..TVPositionInfo^>^>^ get ();
}
Field Value
 A map between field names and a Map. The sub-Map key is the position as the integer, the value is <see cref="Lucene.Net.Index.PositionBasedTermVectorMapper.TVPositionInfo" />.
See Also
PositionBasedTermVectorMapper Class
PositionBasedTermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsIgnoringPositions Property

PositionBasedTermVectorMapper IsIgnoringPositions Property Lucene.Net Class Library
Never ignores positions. This mapper doesn't make much sense unless there are positions

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsIgnoringPositions { get; }
public override bool IsIgnoringPositions { get; }
Public Overrides ReadOnly Property IsIgnoringPositions As Boolean
    Get
Public Overrides ReadOnly Property IsIgnoringPositions As Boolean
    Get
public:
virtual property bool IsIgnoringPositions {
    bool get () override;
}
public:
virtual property bool IsIgnoringPositions {
    bool get () override;
}
Field Value
 false
See Also
PositionBasedTermVectorMapper Class
PositionBasedTermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionBasedTermVectorMapper.TVPositionInfo Class

PositionBasedTermVectorMapper TVPositionInfo Class Lucene.Net Class Library
Container for a term at a position
Inheritance Hierarchy
Online System Object
Lucene.Net.Index PositionBasedTermVectorMapper TVPositionInfo

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TVPositionInfo
public class TVPositionInfo
Public Class TVPositionInfo
Public Class TVPositionInfo
public ref class TVPositionInfo
public ref class TVPositionInfo
See Also
PositionBasedTermVectorMapper TVPositionInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionBasedTermVectorMapper.TVPositionInfo Members

PositionBasedTermVectorMapper TVPositionInfo Members Lucene.Net Class Library

For each Field, store position by position information. It ignores frequency information

This is not thread-safe.

The PositionBasedTermVectorMapper TVPositionInfo type exposes the following members.
Constructors
 | Name | Description
Public method | PositionBasedTermVectorMapper TVPositionInfo | Initializes a new instance of the PositionBasedTermVectorMapper TVPositionInfo class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Offsets | Parallel list (to Terms) of TermVectorOffsetInfo objects. There may be multiple entries since there may be multiple terms at a position
Public property | Position |
Public property | Terms | Note, there may be multiple terms at the same position
Back to Top
See Also
PositionBasedTermVectorMapper TVPositionInfo Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionBasedTermVectorMapper.TVPositionInfo Constructor

PositionBasedTermVectorMapper TVPositionInfo Constructor Lucene.Net Class Library
Initializes a new instance of the PositionBasedTermVectorMapper TVPositionInfo class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TVPositionInfo(
    int position,
    bool storeOffsets
)
public TVPositionInfo(
    int position,
    bool storeOffsets
)
Public Sub New ( _
    position As Integer, _
    storeOffsets As Boolean _
)
Public Sub New ( _
    position As Integer, _
    storeOffsets As Boolean _
)
public:
TVPositionInfo(
    int position,
    bool storeOffsets
)
public:
TVPositionInfo(
    int position,
    bool storeOffsets
)
Parameters
position
Type:   Online System Int32
storeOffsets
Type:   Online System Boolean
See Also
PositionBasedTermVectorMapper TVPositionInfo Class
PositionBasedTermVectorMapper TVPositionInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionBasedTermVectorMapper.TVPositionInfo Methods

PositionBasedTermVectorMapper TVPositionInfo Methods Lucene.Net Class Library
The PositionBasedTermVectorMapper TVPositionInfo type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PositionBasedTermVectorMapper TVPositionInfo Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositionBasedTermVectorMapper.TVPositionInfo Properties

PositionBasedTermVectorMapper TVPositionInfo Properties Lucene.Net Class Library
The PositionBasedTermVectorMapper TVPositionInfo type exposes the following members.
Properties
 | Name | Description
Public property | Offsets | Parallel list (to Terms) of TermVectorOffsetInfo objects. There may be multiple entries since there may be multiple terms at a position
Public property | Position |
Public property | Terms | Note, there may be multiple terms at the same position
Back to Top
See Also
PositionBasedTermVectorMapper TVPositionInfo Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Offsets Property

PositionBasedTermVectorMapper TVPositionInfo Offsets Property Lucene.Net Class Library
Parallel list (to Terms) of TermVectorOffsetInfo objects. There may be multiple entries since there may be multiple terms at a position

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IList<TermVectorOffsetInfo> Offsets { get; }
public virtual IList<TermVectorOffsetInfo> Offsets { get; }
Public Overridable ReadOnly Property Offsets As IList(Of TermVectorOffsetInfo)
    Get
Public Overridable ReadOnly Property Offsets As IList(Of TermVectorOffsetInfo)
    Get
public:
virtual property IList<TermVectorOffsetInfo>^ Offsets {
    IList<TermVectorOffsetInfo>^ get ();
}
public:
virtual property IList<TermVectorOffsetInfo>^ Offsets {
    IList<TermVectorOffsetInfo>^ get ();
}
Return Value
 A List of TermVectorOffsetInfo objects, if offsets are store.

See Also
PositionBasedTermVectorMapper TVPositionInfo Class
PositionBasedTermVectorMapper TVPositionInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Position Property

PositionBasedTermVectorMapper TVPositionInfo Position Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Position { get; }
public virtual int Position { get; }
Public Overridable ReadOnly Property Position As Integer
    Get
Public Overridable ReadOnly Property Position As Integer
    Get
public:
virtual property int Position {
    int get ();
}
public:
virtual property int Position {
    int get ();
}
Return Value
 The position of the term

See Also
PositionBasedTermVectorMapper TVPositionInfo Class
PositionBasedTermVectorMapper TVPositionInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Property

PositionBasedTermVectorMapper TVPositionInfo Terms Property Lucene.Net Class Library
Note, there may be multiple terms at the same position

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IList<string> Terms { get; }
public virtual IList<string> Terms { get; }
Public Overridable ReadOnly Property Terms As IList(Of String)
    Get
Public Overridable ReadOnly Property Terms As IList(Of String)
    Get
public:
virtual property IList<String^>^ Terms {
    IList<String^>^ get ();
}
public:
virtual property IList<String^>^ Terms {
    IList<String^>^ get ();
}
Return Value
 A List of Strings

See Also
PositionBasedTermVectorMapper TVPositionInfo Class
PositionBasedTermVectorMapper TVPositionInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadOnlyDirectoryReader Class

ReadOnlyDirectoryReader Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Index IndexReader
Lucene.Net.Index DirectoryReader
Lucene.Net.Index ReadOnlyDirectoryReader

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ReadOnlyDirectoryReader : DirectoryReader
public class ReadOnlyDirectoryReader : DirectoryReader
Public Class ReadOnlyDirectoryReader _
    Inherits DirectoryReader
Public Class ReadOnlyDirectoryReader _
    Inherits DirectoryReader
public ref class ReadOnlyDirectoryReader : public DirectoryReader
public ref class ReadOnlyDirectoryReader : public DirectoryReader
See Also
ReadOnlyDirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadOnlyDirectoryReader Members

ReadOnlyDirectoryReader Members Lucene.Net Class Library

The ReadOnlyDirectoryReader type exposes the following members.
Methods
 | Name | Description
Protected method | AcquireWriteLock | (Overrides DirectoryReader AcquireWriteLock .)
Public method | Clone | (Inherited from DirectoryReader.)
Public method | Clone(Boolean) | (Inherited from DirectoryReader.)
Public method | Close | Obsolete. (Inherited from IndexReader.)
Public method | Commit | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | Commit(IDictionary String, String ) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | DecRef | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed. (Inherited from IndexReader.)
Public method | DeleteDocument | Deletes the document numbered docNum. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the Document(Int32) method will result in an error. The presence of this document may still be reflected in the DocFreq(Term) statistic, though this will be corrected eventually as the index is further modified. (Inherited from IndexReader.)
Public method | DeleteDocuments | Deletes all documents that have a given term indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See DeleteDocument(Int32) for information about when this deletion will become effective. (Inherited from IndexReader.)
Public method | Directory | Returns the directory this index resides in. (Inherited from DirectoryReader.)
Public method | Dispose | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called. (Inherited from IndexReader.)
Protected method | Dispose(Boolean) | (Inherited from IndexReader.)
Public method | DocFreq | (Inherited from DirectoryReader.)
Protected method | DoClose | (Inherited from DirectoryReader.)
Protected method | DoCommit | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from DirectoryReader.)
Public method | Document(Int32) | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Inherited from DirectoryReader.)
Protected method | DoDelete | (Inherited from DirectoryReader.)
Protected method | DoSetNorm | (Inherited from DirectoryReader.)
Protected method | DoUndeleteAll | (Inherited from DirectoryReader.)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Inherited from IndexReader.)
Public method | Flush(IDictionary String, String ) | (Inherited from IndexReader.)
Public method | GetFieldNames | (Inherited from DirectoryReader.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSequentialSubReaders | (Inherited from DirectoryReader.)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Inherited from DirectoryReader.)
Public method | GetTermFreqVector(Int32, String) | (Inherited from DirectoryReader.)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Inherited from DirectoryReader.)
Public method | GetTermFreqVectors | (Inherited from DirectoryReader.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasNorms | (Inherited from DirectoryReader.)
Public method | IncRef | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding DecRef , in a finally clause; otherwise the reader may never be closed. Note that Close simply calls decRef(), which means that the IndexReader will not really be closed until DecRef has been called for all outstanding references. (Inherited from IndexReader.)
Public method | IsCurrent | (Inherited from DirectoryReader.)
Public method | IsDeleted | (Inherited from DirectoryReader.)
Public method | IsOptimized | Checks is the index is optimized (if it has a single segment and no deletions) (Inherited from DirectoryReader.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Norms(String) | (Inherited from DirectoryReader.)
Public method | Norms(String, Byte , Int32) | (Inherited from DirectoryReader.)
Public method | NumDocs | (Inherited from DirectoryReader.)
Public method | Reopen | (Inherited from DirectoryReader.)
Public method | Reopen(Boolean) | (Inherited from DirectoryReader.)
Public method | Reopen(IndexCommit) | (Inherited from DirectoryReader.)
Public method | SetNorm(Int32, String, Byte) | Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Single) | Expert: Resets the normalization factor for the named field of the named document. (Inherited from IndexReader.)
Public method | TermDocs | (Inherited from DirectoryReader.)
Public method | TermDocs(Term) | Returns an enumeration of all the documents which contain term. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping: Term => <docNum, freq>* The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Public method | TermPositions | (Inherited from DirectoryReader.)
Public method | TermPositions(Term) | Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping: Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >* This positional information facilitates phrase and proximity searching. The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Public method | Terms | (Inherited from DirectoryReader.)
Public method | Terms(Term) | (Inherited from DirectoryReader.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UndeleteAll | Undeletes all documents currently marked as deleted in this index. (Inherited from IndexReader.)
Back to Top
Fields
 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | internalDirectory | (Inherited from DirectoryReader.)
Protected field | readOnly | (Inherited from DirectoryReader.)
Back to Top
Properties
 | Name | Description
Public property | CommitUserData | (Inherited from DirectoryReader.)
Public property | DeletesCacheKey | (Inherited from IndexReader.)
Public property | FieldCacheKey | Expert (Inherited from IndexReader.)
Public property | HasDeletions | (Inherited from DirectoryReader.)
Public property | IndexCommit | Expert: return the IndexCommit that this reader has opened. WARNING: this API is new and experimental and may suddenly change. (Inherited from DirectoryReader.)
Public property | Item | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public property | MaxDoc | (Inherited from DirectoryReader.)
Public property | NumDeletedDocs | Returns the number of deleted documents. (Inherited from IndexReader.)
Public property | RefCount | Expert: returns the current refCount for this reader (Inherited from IndexReader.)
Public property | TermInfosIndexDivisor | (Inherited from DirectoryReader.)
Public property | UniqueTermCount | Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed. (Inherited from IndexReader.)
Public property | Version | Version number when this IndexReader was opened. (Inherited from DirectoryReader.)
Back to Top
See Also
ReadOnlyDirectoryReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadOnlyDirectoryReader Fields

ReadOnlyDirectoryReader Fields Lucene.Net Class Library
The ReadOnlyDirectoryReader type exposes the following members.
Fields
 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | internalDirectory | (Inherited from DirectoryReader.)
Protected field | readOnly | (Inherited from DirectoryReader.)
Back to Top
See Also
ReadOnlyDirectoryReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadOnlyDirectoryReader Methods

ReadOnlyDirectoryReader Methods Lucene.Net Class Library
The ReadOnlyDirectoryReader type exposes the following members.
Methods
 | Name | Description
Protected method | AcquireWriteLock | (Overrides DirectoryReader AcquireWriteLock .)
Public method | Clone | (Inherited from DirectoryReader.)
Public method | Clone(Boolean) | (Inherited from DirectoryReader.)
Public method | Close | Obsolete. (Inherited from IndexReader.)
Public method | Commit | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | Commit(IDictionary String, String ) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | DecRef | Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed. (Inherited from IndexReader.)
Public method | DeleteDocument | Deletes the document numbered docNum. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the Document(Int32) method will result in an error. The presence of this document may still be reflected in the DocFreq(Term) statistic, though this will be corrected eventually as the index is further modified. (Inherited from IndexReader.)
Public method | DeleteDocuments | Deletes all documents that have a given term indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See DeleteDocument(Int32) for information about when this deletion will become effective. (Inherited from IndexReader.)
Public method | Directory | Returns the directory this index resides in. (Inherited from DirectoryReader.)
Public method | Dispose | Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called. (Inherited from IndexReader.)
Protected method | Dispose(Boolean) | (Inherited from IndexReader.)
Public method | DocFreq | (Inherited from DirectoryReader.)
Protected method | DoClose | (Inherited from DirectoryReader.)
Protected method | DoCommit | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from DirectoryReader.)
Public method | Document(Int32) | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Inherited from DirectoryReader.)
Protected method | DoDelete | (Inherited from DirectoryReader.)
Protected method | DoSetNorm | (Inherited from DirectoryReader.)
Protected method | DoUndeleteAll | (Inherited from DirectoryReader.)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Inherited from IndexReader.)
Public method | Flush(IDictionary String, String ) | (Inherited from IndexReader.)
Public method | GetFieldNames | (Inherited from DirectoryReader.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSequentialSubReaders | (Inherited from DirectoryReader.)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Inherited from DirectoryReader.)
Public method | GetTermFreqVector(Int32, String) | (Inherited from DirectoryReader.)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Inherited from DirectoryReader.)
Public method | GetTermFreqVectors | (Inherited from DirectoryReader.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasNorms | (Inherited from DirectoryReader.)
Public method | IncRef | Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding DecRef , in a finally clause; otherwise the reader may never be closed. Note that Close simply calls decRef(), which means that the IndexReader will not really be closed until DecRef has been called for all outstanding references. (Inherited from IndexReader.)
Public method | IsCurrent | (Inherited from DirectoryReader.)
Public method | IsDeleted | (Inherited from DirectoryReader.)
Public method | IsOptimized | Checks is the index is optimized (if it has a single segment and no deletions) (Inherited from DirectoryReader.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Norms(String) | (Inherited from DirectoryReader.)
Public method | Norms(String, Byte , Int32) | (Inherited from DirectoryReader.)
Public method | NumDocs | (Inherited from DirectoryReader.)
Public method | Reopen | (Inherited from DirectoryReader.)
Public method | Reopen(Boolean) | (Inherited from DirectoryReader.)
Public method | Reopen(IndexCommit) | (Inherited from DirectoryReader.)
Public method | SetNorm(Int32, String, Byte) | Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Single) | Expert: Resets the normalization factor for the named field of the named document. (Inherited from IndexReader.)
Public method | TermDocs | (Inherited from DirectoryReader.)
Public method | TermDocs(Term) | Returns an enumeration of all the documents which contain term. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping: Term => <docNum, freq>* The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Public method | TermPositions | (Inherited from DirectoryReader.)
Public method | TermPositions(Term) | Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping: Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >* This positional information facilitates phrase and proximity searching. The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Public method | Terms | (Inherited from DirectoryReader.)
Public method | Terms(Term) | (Inherited from DirectoryReader.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | UndeleteAll | Undeletes all documents currently marked as deleted in this index. (Inherited from IndexReader.)
Back to Top
See Also
ReadOnlyDirectoryReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AcquireWriteLock Method

ReadOnlyDirectoryReader AcquireWriteLock Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void AcquireWriteLock()
protected override void AcquireWriteLock()
Protected Overrides Sub AcquireWriteLock
Protected Overrides Sub AcquireWriteLock
protected:
virtual void AcquireWriteLock() override
protected:
virtual void AcquireWriteLock() override
See Also
ReadOnlyDirectoryReader Class
ReadOnlyDirectoryReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadOnlyDirectoryReader Properties

ReadOnlyDirectoryReader Properties Lucene.Net Class Library
The ReadOnlyDirectoryReader type exposes the following members.
Properties
 | Name | Description
Public property | CommitUserData | (Inherited from DirectoryReader.)
Public property | DeletesCacheKey | (Inherited from IndexReader.)
Public property | FieldCacheKey | Expert (Inherited from IndexReader.)
Public property | HasDeletions | (Inherited from DirectoryReader.)
Public property | IndexCommit | Expert: return the IndexCommit that this reader has opened. WARNING: this API is new and experimental and may suddenly change. (Inherited from DirectoryReader.)
Public property | Item | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public property | MaxDoc | (Inherited from DirectoryReader.)
Public property | NumDeletedDocs | Returns the number of deleted documents. (Inherited from IndexReader.)
Public property | RefCount | Expert: returns the current refCount for this reader (Inherited from IndexReader.)
Public property | TermInfosIndexDivisor | (Inherited from DirectoryReader.)
Public property | UniqueTermCount | Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed. (Inherited from IndexReader.)
Public property | Version | Version number when this IndexReader was opened. (Inherited from DirectoryReader.)
Back to Top
See Also
ReadOnlyDirectoryReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadOnlySegmentReader Class

ReadOnlySegmentReader Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Index IndexReader
Lucene.Net.Index SegmentReader
Lucene.Net.Index ReadOnlySegmentReader

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ReadOnlySegmentReader : SegmentReader
public class ReadOnlySegmentReader : SegmentReader
Public Class ReadOnlySegmentReader _
    Inherits SegmentReader
Public Class ReadOnlySegmentReader _
    Inherits SegmentReader
public ref class ReadOnlySegmentReader : public SegmentReader
public ref class ReadOnlySegmentReader : public SegmentReader
See Also
ReadOnlySegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadOnlySegmentReader Members

ReadOnlySegmentReader Members Lucene.Net Class Library

The ReadOnlySegmentReader type exposes the following members.
Constructors
 | Name | Description
Public method | ReadOnlySegmentReader | Initializes a new instance of the ReadOnlySegmentReader class
Back to Top
Methods
Name | Description
Protected method | AcquireWriteLock | (Overrides IndexReader AcquireWriteLock .)
Public method | Clone | (Inherited from SegmentReader.)
Public method | Clone(Boolean) | (Inherited from SegmentReader.)
Protected method CloneDeletedDocs
Clones the deleteDocs BitVector. May be overridden by subclasses. New and experimental.
(Inherited from SegmentReader.)
Protected method CloneNormBytes
Clones the norm bytes. May be overridden by subclasses. New and experimental.
(Inherited from SegmentReader.)
Public method | Close | Obsolete. (Inherited from IndexReader.)
Public method Commit
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary String, String )
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered docNum. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the Document(Int32) method will result in an error. The presence of this document may still be reflected in the DocFreq(Term) statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given term indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See DeleteDocument(Int32) for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method Directory
Returns the directory this index resides in.
(Inherited from SegmentReader.)
Public method Dispose
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Protected method | Dispose(Boolean) | (Inherited from IndexReader.)
Public method | DocFreq | (Inherited from SegmentReader.)
Protected method | DoClose | (Inherited from SegmentReader.)
Protected method | DoCommit | (Inherited from SegmentReader.)
Public method Document(Int32)
Returns the stored fields of the nthDocument in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted.
(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Inherited from SegmentReader.)
Protected method | DoDelete | (Inherited from SegmentReader.)
Protected method | DoSetNorm | (Inherited from SegmentReader.)
Protected method | DoUndeleteAll | (Inherited from SegmentReader.)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Public method | FieldInfos | (Inherited from SegmentReader.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Flush
(Inherited from IndexReader.)
Public method | Flush(IDictionary String, String ) | (Inherited from IndexReader.)
Public method | GetFieldNames | (Inherited from SegmentReader.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Protected method | GetNorms | (Inherited from SegmentReader.)
Public method GetSequentialSubReaders
Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers).

NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through Open(Directory, Boolean). Use the parent reader directly.
(Inherited from IndexReader.)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Inherited from SegmentReader.)
Public method GetTermFreqVector(Int32, String)
Return a term frequency vector for the specified document and field. The vector returned contains term numbers and frequencies for all terms in the specified field of this document, if the field had storeTermVector flag set. If the flag was not set, the method returns null.
(Inherited from SegmentReader.)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Inherited from SegmentReader.)
Public method GetTermFreqVectors
Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null.
(Inherited from SegmentReader.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method | HasNorms | (Inherited from SegmentReader.)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding DecRef , in a finally clause; otherwise the reader may never be closed. Note that Close simply calls decRef(), which means that the IndexReader will not really be closed until DecRef has been called for all outstanding references.
(Inherited from IndexReader.)
Public method IsCurrent
Check whether any new changes have occurred to the index since this reader was opened.

If this reader is based on a Directory (ie, was created by calling Open(Store.Directory) , or Reopen on a reader based on a Directory), then this method checks if any further commits (see Commit have occurred in that directory).

If instead this reader is a near real-time reader (ie, obtained by a call to GetReader , or by calling Reopen on a near real-time reader), then this method checks if either a new commmit has occurred, or any new uncommitted changes have taken place via the writer. Note that even if the writer has only performed merging, this method will still return false.

In any event, if this returns false, you should call Reopen to get a new reader that sees the changes.

(Inherited from IndexReader.)
Public method | IsDeleted | (Overrides SegmentReader IsDeleted(Int32).)
Public method IsOptimized
Checks is the index is optimized (if it has a single segment and no deletions). Not implemented in the IndexReader base class.
(Inherited from IndexReader.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method | Norms(String) | (Inherited from SegmentReader.)
Public method Norms(String, Byte , Int32)
Read norms into a pre-allocated array.
(Inherited from SegmentReader.)
Public method | NormsClosed | (Inherited from SegmentReader.)
Public method | NormsClosed(String) | (Inherited from SegmentReader.)
Public method | NumDocs | (Inherited from SegmentReader.)
Public method Reopen
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:
View Colorized Copy to Clipboard Print
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from GetReader , reopen() will simply call writer.getReader() again for you, though this may change in the future.
(Inherited from IndexReader.)
Public method Reopen(Boolean)
Just like Reopen , except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method | TermDocs | (Inherited from SegmentReader.)
Public method | TermDocs(Term) | (Inherited from SegmentReader.)
Public method | TermPositions | (Inherited from SegmentReader.)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.
(Inherited from IndexReader.)
Public method | Terms | (Inherited from SegmentReader.)
Public method | Terms(Term) | (Inherited from SegmentReader.)
Public method | TermsIndexLoaded | (Inherited from SegmentReader.)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)
Back to Top
Fields
 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | readOnly | (Inherited from SegmentReader.)
Back to Top
Properties
 | Name | Description
Public property | CommitUserData | Retrieve the String userData optionally passed to Commit(IDictionary String, String ). This will return null if Commit(IDictionary String, String ) has never been called for this index. (Inherited from IndexReader.)
Public property | core_ForNUnit | (Inherited from SegmentReader.)
Public property | deletedDocs_ForNUnit | (Inherited from SegmentReader.)
Public property | deletedDocsRef_ForNUnit | (Inherited from SegmentReader.)
Public property | DeletesCacheKey | (Inherited from SegmentReader.)
Public property | FieldCacheKey | (Inherited from SegmentReader.)
Public property | HasDeletions | (Inherited from SegmentReader.)
Public property | IndexCommit | Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: this API is new and experimental and may suddenly change. (Inherited from IndexReader.)
Public property | Item | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public property | MaxDoc | (Inherited from SegmentReader.)
Public property | norms_ForNUnit | (Inherited from SegmentReader.)
Public property | NumDeletedDocs | Returns the number of deleted documents. (Inherited from IndexReader.)
Public property | RefCount | Expert: returns the current refCount for this reader (Inherited from IndexReader.)
Public property | SegmentName | Return the name of the segment this reader is reading. (Inherited from SegmentReader.)
Public property | TermInfosIndexDivisor | (Inherited from SegmentReader.)
Public property | UniqueTermCount | (Inherited from SegmentReader.)
Public property | Version | Version number when this IndexReader was opened. Not implemented in the IndexReader base class. If this reader is based on a Directory (ie, was created by calling Open(Directory, Boolean), or Reopen on a reader based on a Directory), then this method returns the version recorded in the commit that the reader opened. This version is advanced every time Commit is called. If instead this reader is a near real-time reader (ie, obtained by a call to GetReader , or by calling Reopen on a near real-time reader), then this method returns the version of the last commit done by the writer. Note that even as further changes are made with the writer, the version will not changed until a commit is completed. Thus, you should not rely on this method to determine when a near real-time reader should be opened. Use IsCurrent instead. (Inherited from IndexReader.)
Back to Top
See Also
ReadOnlySegmentReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadOnlySegmentReader Constructor

ReadOnlySegmentReader Constructor Lucene.Net Class Library
Initializes a new instance of the ReadOnlySegmentReader class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReadOnlySegmentReader()
public ReadOnlySegmentReader()
Public Sub New
Public Sub New
public:
ReadOnlySegmentReader()
public:
ReadOnlySegmentReader()
See Also
ReadOnlySegmentReader Class
ReadOnlySegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadOnlySegmentReader Fields

ReadOnlySegmentReader Fields Lucene.Net Class Library
The ReadOnlySegmentReader type exposes the following members.
Fields
 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | readOnly | (Inherited from SegmentReader.)
Back to Top
See Also
ReadOnlySegmentReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadOnlySegmentReader Methods

ReadOnlySegmentReader Methods Lucene.Net Class Library
The ReadOnlySegmentReader type exposes the following members.
Methods
Name | Description
Protected method | AcquireWriteLock | (Overrides IndexReader AcquireWriteLock .)
Public method | Clone | (Inherited from SegmentReader.)
Public method | Clone(Boolean) | (Inherited from SegmentReader.)
Protected method CloneDeletedDocs
Clones the deleteDocs BitVector. May be overridden by subclasses. New and experimental.
(Inherited from SegmentReader.)
Protected method CloneNormBytes
Clones the norm bytes. May be overridden by subclasses. New and experimental.
(Inherited from SegmentReader.)
Public method | Close | Obsolete. (Inherited from IndexReader.)
Public method Commit
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary String, String )
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered docNum. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the Document(Int32) method will result in an error. The presence of this document may still be reflected in the DocFreq(Term) statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given term indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See DeleteDocument(Int32) for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method Directory
Returns the directory this index resides in.
(Inherited from SegmentReader.)
Public method Dispose
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Protected method | Dispose(Boolean) | (Inherited from IndexReader.)
Public method | DocFreq | (Inherited from SegmentReader.)
Protected method | DoClose | (Inherited from SegmentReader.)
Protected method | DoCommit | (Inherited from SegmentReader.)
Public method Document(Int32)
Returns the stored fields of the nthDocument in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted.
(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Inherited from SegmentReader.)
Protected method | DoDelete | (Inherited from SegmentReader.)
Protected method | DoSetNorm | (Inherited from SegmentReader.)
Protected method | DoUndeleteAll | (Inherited from SegmentReader.)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Public method | FieldInfos | (Inherited from SegmentReader.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Flush
(Inherited from IndexReader.)
Public method | Flush(IDictionary String, String ) | (Inherited from IndexReader.)
Public method | GetFieldNames | (Inherited from SegmentReader.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Protected method | GetNorms | (Inherited from SegmentReader.)
Public method GetSequentialSubReaders
Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers).

NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through Open(Directory, Boolean). Use the parent reader directly.
(Inherited from IndexReader.)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Inherited from SegmentReader.)
Public method GetTermFreqVector(Int32, String)
Return a term frequency vector for the specified document and field. The vector returned contains term numbers and frequencies for all terms in the specified field of this document, if the field had storeTermVector flag set. If the flag was not set, the method returns null.
(Inherited from SegmentReader.)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Inherited from SegmentReader.)
Public method GetTermFreqVectors
Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null.
(Inherited from SegmentReader.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method | HasNorms | (Inherited from SegmentReader.)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding DecRef , in a finally clause; otherwise the reader may never be closed. Note that Close simply calls decRef(), which means that the IndexReader will not really be closed until DecRef has been called for all outstanding references.
(Inherited from IndexReader.)
Public method IsCurrent
Check whether any new changes have occurred to the index since this reader was opened.

If this reader is based on a Directory (ie, was created by calling Open(Store.Directory) , or Reopen on a reader based on a Directory), then this method checks if any further commits (see Commit have occurred in that directory).

If instead this reader is a near real-time reader (ie, obtained by a call to GetReader , or by calling Reopen on a near real-time reader), then this method checks if either a new commmit has occurred, or any new uncommitted changes have taken place via the writer. Note that even if the writer has only performed merging, this method will still return false.

In any event, if this returns false, you should call Reopen to get a new reader that sees the changes.

(Inherited from IndexReader.)
Public method | IsDeleted | (Overrides SegmentReader IsDeleted(Int32).)
Public method IsOptimized
Checks is the index is optimized (if it has a single segment and no deletions). Not implemented in the IndexReader base class.
(Inherited from IndexReader.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method | Norms(String) | (Inherited from SegmentReader.)
Public method Norms(String, Byte , Int32)
Read norms into a pre-allocated array.
(Inherited from SegmentReader.)
Public method | NormsClosed | (Inherited from SegmentReader.)
Public method | NormsClosed(String) | (Inherited from SegmentReader.)
Public method | NumDocs | (Inherited from SegmentReader.)
Public method Reopen
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:
View Colorized Copy to Clipboard Print
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from GetReader , reopen() will simply call writer.getReader() again for you, though this may change in the future.
(Inherited from IndexReader.)
Public method Reopen(Boolean)
Just like Reopen , except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method | TermDocs | (Inherited from SegmentReader.)
Public method | TermDocs(Term) | (Inherited from SegmentReader.)
Public method | TermPositions | (Inherited from SegmentReader.)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.
(Inherited from IndexReader.)
Public method | Terms | (Inherited from SegmentReader.)
Public method | Terms(Term) | (Inherited from SegmentReader.)
Public method | TermsIndexLoaded | (Inherited from SegmentReader.)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)
Back to Top
See Also
ReadOnlySegmentReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AcquireWriteLock Method

ReadOnlySegmentReader AcquireWriteLock Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void AcquireWriteLock()
protected override void AcquireWriteLock()
Protected Overrides Sub AcquireWriteLock
Protected Overrides Sub AcquireWriteLock
protected:
virtual void AcquireWriteLock() override
protected:
virtual void AcquireWriteLock() override
See Also
ReadOnlySegmentReader Class
ReadOnlySegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsDeleted Method

ReadOnlySegmentReader IsDeleted Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsDeleted(
    int n
)
public override bool IsDeleted(
    int n
)
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
public:
virtual bool IsDeleted(
    int n
) override
public:
virtual bool IsDeleted(
    int n
) override
Parameters
n
Type:   Online System Int32
See Also
ReadOnlySegmentReader Class
ReadOnlySegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadOnlySegmentReader Properties

ReadOnlySegmentReader Properties Lucene.Net Class Library
The ReadOnlySegmentReader type exposes the following members.
Properties
 | Name | Description
Public property | CommitUserData | Retrieve the String userData optionally passed to Commit(IDictionary String, String ). This will return null if Commit(IDictionary String, String ) has never been called for this index. (Inherited from IndexReader.)
Public property | core_ForNUnit | (Inherited from SegmentReader.)
Public property | deletedDocs_ForNUnit | (Inherited from SegmentReader.)
Public property | deletedDocsRef_ForNUnit | (Inherited from SegmentReader.)
Public property | DeletesCacheKey | (Inherited from SegmentReader.)
Public property | FieldCacheKey | (Inherited from SegmentReader.)
Public property | HasDeletions | (Inherited from SegmentReader.)
Public property | IndexCommit | Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: this API is new and experimental and may suddenly change. (Inherited from IndexReader.)
Public property | Item | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public property | MaxDoc | (Inherited from SegmentReader.)
Public property | norms_ForNUnit | (Inherited from SegmentReader.)
Public property | NumDeletedDocs | Returns the number of deleted documents. (Inherited from IndexReader.)
Public property | RefCount | Expert: returns the current refCount for this reader (Inherited from IndexReader.)
Public property | SegmentName | Return the name of the segment this reader is reading. (Inherited from SegmentReader.)
Public property | TermInfosIndexDivisor | (Inherited from SegmentReader.)
Public property | UniqueTermCount | (Inherited from SegmentReader.)
Public property | Version | Version number when this IndexReader was opened. Not implemented in the IndexReader base class. If this reader is based on a Directory (ie, was created by calling Open(Directory, Boolean), or Reopen on a reader based on a Directory), then this method returns the version recorded in the commit that the reader opened. This version is advanced every time Commit is called. If instead this reader is a near real-time reader (ie, obtained by a call to GetReader , or by calling Reopen on a near real-time reader), then this method returns the version of the last commit done by the writer. Note that even as further changes are made with the writer, the version will not changed until a commit is completed. Thus, you should not rely on this method to determine when a near real-time reader should be opened. Use IsCurrent instead. (Inherited from IndexReader.)
Back to Top
See Also
ReadOnlySegmentReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfo Class

SegmentInfo Class Lucene.Net Class Library
Information about a segment such as it's name, directory, and files related to the segment. *

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

Inheritance Hierarchy
Online System Object
Lucene.Net.Index SegmentInfo

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class SegmentInfo : ICloneable
public sealed class SegmentInfo : ICloneable
Public NotInheritable Class SegmentInfo _
    Implements ICloneable
Public NotInheritable Class SegmentInfo _
    Implements ICloneable
public ref class SegmentInfo sealed : ICloneable
public ref class SegmentInfo sealed : ICloneable
See Also
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfo Members

SegmentInfo Members Lucene.Net Class Library

The SegmentInfo type exposes the following members.
Constructors
 | Name | Description
Public method | SegmentInfo(String, Int32, Directory) | Initializes a new instance of the SegmentInfo class
Public method | SegmentInfo(String, Int32, Directory, Boolean, Boolean) | Initializes a new instance of the SegmentInfo class
Public method | SegmentInfo(String, Int32, Directory, Boolean, Boolean, Int32, String, Boolean, Boolean) | Initializes a new instance of the SegmentInfo class
Back to Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | We consider another SegmentInfo instance equal if it has the same dir and same name. (Overrides Online Object Equals(Object).)
Public method | Files |
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDelCount |
Public method | GetDelFileName |
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetNormFileName | Get the file name for the norms file for this field.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUseCompoundFile | Returns true if this segment is stored as a compound file; else, false.
Public method | HasDeletions |
Public method | HasSeparateNorms | Returns true if any fields in this segment have separate norms.
Public method | HasSeparateNorms(Int32) | Returns true if this field for this segment has saved a separate norms file (_<segment>_N.sX).
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SegString | Used for debugging
Public method | SizeInBytes | Returns total size in bytes of all of files used by this segment.
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Fields
 | Name | Description
Public field | dir |
Public field | docCount |
Public field | name |
Back to Top
Properties
 | Name | Description
Public property | Diagnostics |
Public property | DocStoreIsCompoundFile |
Public property | DocStoreOffset |
Public property | DocStoreSegment |
Public property | HasProx |
Back to Top
See Also
SegmentInfo Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfo Constructor

SegmentInfo Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | SegmentInfo(String, Int32, Directory) | Initializes a new instance of the SegmentInfo class
Public method | SegmentInfo(String, Int32, Directory, Boolean, Boolean) | Initializes a new instance of the SegmentInfo class
Public method | SegmentInfo(String, Int32, Directory, Boolean, Boolean, Int32, String, Boolean, Boolean) | Initializes a new instance of the SegmentInfo class
Back to Top
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfo Constructor (String, Int32, Directory)

SegmentInfo Constructor (String, Int32, Directory) Lucene.Net Class Library
Initializes a new instance of the SegmentInfo class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SegmentInfo(
    string name,
    int docCount,
    Directory dir
)
public SegmentInfo(
    string name,
    int docCount,
    Directory dir
)
Public Sub New ( _
    name As String, _
    docCount As Integer, _
    dir As Directory _
)
Public Sub New ( _
    name As String, _
    docCount As Integer, _
    dir As Directory _
)
public:
SegmentInfo(
    String^ name,
    int docCount,
    Directory^ dir
)
public:
SegmentInfo(
    String^ name,
    int docCount,
    Directory^ dir
)
Parameters
name
Type:   Online System String
docCount
Type:   Online System Int32
dir
Type: Lucene.Net.Store Directory
See Also
SegmentInfo Class
SegmentInfo Members
SegmentInfo Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfo Constructor (String, Int32, Directory, Boolean, Boolean)

SegmentInfo Constructor (String, Int32, Directory, Boolean, Boolean) Lucene.Net Class Library
Initializes a new instance of the SegmentInfo class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SegmentInfo(
    string name,
    int docCount,
    Directory dir,
    bool isCompoundFile,
    bool hasSingleNormFile
)
public SegmentInfo(
    string name,
    int docCount,
    Directory dir,
    bool isCompoundFile,
    bool hasSingleNormFile
)
Public Sub New ( _
    name As String, _
    docCount As Integer, _
    dir As Directory, _
    isCompoundFile As Boolean, _
    hasSingleNormFile As Boolean _
)
Public Sub New ( _
    name As String, _
    docCount As Integer, _
    dir As Directory, _
    isCompoundFile As Boolean, _
    hasSingleNormFile As Boolean _
)
public:
SegmentInfo(
    String^ name,
    int docCount,
    Directory^ dir,
    bool isCompoundFile,
    bool hasSingleNormFile
)
public:
SegmentInfo(
    String^ name,
    int docCount,
    Directory^ dir,
    bool isCompoundFile,
    bool hasSingleNormFile
)
Parameters
name
Type:   Online System String
docCount
Type:   Online System Int32
dir
Type: Lucene.Net.Store Directory
isCompoundFile
Type:   Online System Boolean
hasSingleNormFile
Type:   Online System Boolean
See Also
SegmentInfo Class
SegmentInfo Members
SegmentInfo Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfo Constructor (String, Int32, Directory, Boolean, Boolean, Int32, String, Boolean, Boolean)

SegmentInfo Constructor (String, Int32, Directory, Boolean, Boolean, Int32, String, Boolean, Boolean) Lucene.Net Class Library
Initializes a new instance of the SegmentInfo class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SegmentInfo(
    string name,
    int docCount,
    Directory dir,
    bool isCompoundFile,
    bool hasSingleNormFile,
    int docStoreOffset,
    string docStoreSegment,
    bool docStoreIsCompoundFile,
    bool hasProx
)
public SegmentInfo(
    string name,
    int docCount,
    Directory dir,
    bool isCompoundFile,
    bool hasSingleNormFile,
    int docStoreOffset,
    string docStoreSegment,
    bool docStoreIsCompoundFile,
    bool hasProx
)
Public Sub New ( _
    name As String, _
    docCount As Integer, _
    dir As Directory, _
    isCompoundFile As Boolean, _
    hasSingleNormFile As Boolean, _
    docStoreOffset As Integer, _
    docStoreSegment As String, _
    docStoreIsCompoundFile As Boolean, _
    hasProx As Boolean _
)
Public Sub New ( _
    name As String, _
    docCount As Integer, _
    dir As Directory, _
    isCompoundFile As Boolean, _
    hasSingleNormFile As Boolean, _
    docStoreOffset As Integer, _
    docStoreSegment As String, _
    docStoreIsCompoundFile As Boolean, _
    hasProx As Boolean _
)
public:
SegmentInfo(
    String^ name,
    int docCount,
    Directory^ dir,
    bool isCompoundFile,
    bool hasSingleNormFile,
    int docStoreOffset,
    String^ docStoreSegment,
    bool docStoreIsCompoundFile,
    bool hasProx
)
public:
SegmentInfo(
    String^ name,
    int docCount,
    Directory^ dir,
    bool isCompoundFile,
    bool hasSingleNormFile,
    int docStoreOffset,
    String^ docStoreSegment,
    bool docStoreIsCompoundFile,
    bool hasProx
)
Parameters
name
Type:   Online System String
docCount
Type:   Online System Int32
dir
Type: Lucene.Net.Store Directory
isCompoundFile
Type:   Online System Boolean
hasSingleNormFile
Type:   Online System Boolean
docStoreOffset
Type:   Online System Int32
docStoreSegment
Type:   Online System String
docStoreIsCompoundFile
Type:   Online System Boolean
hasProx
Type:   Online System Boolean
See Also
SegmentInfo Class
SegmentInfo Members
SegmentInfo Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfo Fields

SegmentInfo Fields Lucene.Net Class Library
The SegmentInfo type exposes the following members.
Fields
 | Name | Description
Public field | dir |
Public field | docCount |
Public field | name |
Back to Top
See Also
SegmentInfo Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


dir Field

SegmentInfo dir Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Directory dir
public Directory dir
Public dir As Directory
Public dir As Directory
public:
Directory^ dir
public:
Directory^ dir
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


docCount Field

SegmentInfo docCount Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int docCount
public int docCount
Public docCount As Integer
Public docCount As Integer
public:
int docCount
public:
int docCount
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


name Field

SegmentInfo name Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string name
public string name
Public name As String
Public name As String
public:
String^ name
public:
String^ name
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfo Methods

SegmentInfo Methods Lucene.Net Class Library
The SegmentInfo type exposes the following members.
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | We consider another SegmentInfo instance equal if it has the same dir and same name. (Overrides Online Object Equals(Object).)
Public method | Files |
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDelCount |
Public method | GetDelFileName |
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetNormFileName | Get the file name for the norms file for this field.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUseCompoundFile | Returns true if this segment is stored as a compound file; else, false.
Public method | HasDeletions |
Public method | HasSeparateNorms | Returns true if any fields in this segment have separate norms.
Public method | HasSeparateNorms(Int32) | Returns true if this field for this segment has saved a separate norms file (_<segment>_N.sX).
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SegString | Used for debugging
Public method | SizeInBytes | Returns total size in bytes of all of files used by this segment.
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
SegmentInfo Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

SegmentInfo Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Clone()
public Object Clone()
Public Function Clone As Object
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
public:
virtual Object^ Clone() sealed
Implements
  Online ICloneable Clone
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

SegmentInfo Equals Method Lucene.Net Class Library
We consider another SegmentInfo instance equal if it has the same dir and same name.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Files Method

SegmentInfo Files Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList<string> Files()
public IList<string> Files()
Public Function Files As IList(Of String)
Public Function Files As IList(Of String)
public:
IList<String^>^ Files()
public:
IList<String^>^ Files()
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetDelCount Method

SegmentInfo GetDelCount Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int GetDelCount()
public int GetDelCount()
Public Function GetDelCount As Integer
Public Function GetDelCount As Integer
public:
int GetDelCount()
public:
int GetDelCount()
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetDelFileName Method

SegmentInfo GetDelFileName Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetDelFileName()
public string GetDelFileName()
Public Function GetDelFileName As String
Public Function GetDelFileName As String
public:
String^ GetDelFileName()
public:
String^ GetDelFileName()
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

SegmentInfo GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetNormFileName Method

SegmentInfo GetNormFileName Method Lucene.Net Class Library
Get the file name for the norms file for this field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetNormFileName(
    int number
)
public string GetNormFileName(
    int number
)
Public Function GetNormFileName ( _
    number As Integer _
) As String
Public Function GetNormFileName ( _
    number As Integer _
) As String
public:
String^ GetNormFileName(
    int number
)
public:
String^ GetNormFileName(
    int number
)
Parameters
number
Type:   Online System Int32
field index

See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetUseCompoundFile Method

SegmentInfo GetUseCompoundFile Method Lucene.Net Class Library
Returns true if this segment is stored as a compound file; else, false.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool GetUseCompoundFile()
public bool GetUseCompoundFile()
Public Function GetUseCompoundFile As Boolean
Public Function GetUseCompoundFile As Boolean
public:
bool GetUseCompoundFile()
public:
bool GetUseCompoundFile()
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasDeletions Method

SegmentInfo HasDeletions Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasDeletions()
public bool HasDeletions()
Public Function HasDeletions As Boolean
Public Function HasDeletions As Boolean
public:
bool HasDeletions()
public:
bool HasDeletions()
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasSeparateNorms Method

SegmentInfo HasSeparateNorms Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | HasSeparateNorms | Returns true if any fields in this segment have separate norms.
Public method | HasSeparateNorms(Int32) | Returns true if this field for this segment has saved a separate norms file (_<segment>_N.sX).
Back to Top
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasSeparateNorms Method

SegmentInfo HasSeparateNorms Method Lucene.Net Class Library
Returns true if any fields in this segment have separate norms.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasSeparateNorms()
public bool HasSeparateNorms()
Public Function HasSeparateNorms As Boolean
Public Function HasSeparateNorms As Boolean
public:
bool HasSeparateNorms()
public:
bool HasSeparateNorms()
See Also
SegmentInfo Class
SegmentInfo Members
HasSeparateNorms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasSeparateNorms Method (Int32)

SegmentInfo HasSeparateNorms Method (Int32) Lucene.Net Class Library
Returns true if this field for this segment has saved a separate norms file (_<segment>_N.sX).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasSeparateNorms(
    int fieldNumber
)
public bool HasSeparateNorms(
    int fieldNumber
)
Public Function HasSeparateNorms ( _
    fieldNumber As Integer _
) As Boolean
Public Function HasSeparateNorms ( _
    fieldNumber As Integer _
) As Boolean
public:
bool HasSeparateNorms(
    int fieldNumber
)
public:
bool HasSeparateNorms(
    int fieldNumber
)
Parameters
fieldNumber
Type:   Online System Int32
the field index to check

See Also
SegmentInfo Class
SegmentInfo Members
HasSeparateNorms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegString Method

SegmentInfo SegString Method Lucene.Net Class Library
Used for debugging

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SegString(
    Directory dir
)
public string SegString(
    Directory dir
)
Public Function SegString ( _
    dir As Directory _
) As String
Public Function SegString ( _
    dir As Directory _
) As String
public:
String^ SegString(
    Directory^ dir
)
public:
String^ SegString(
    Directory^ dir
)
Parameters
dir
Type: Lucene.Net.Store Directory
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SizeInBytes Method

SegmentInfo SizeInBytes Method Lucene.Net Class Library
Returns total size in bytes of all of files used by this segment.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long SizeInBytes()
public long SizeInBytes()
Public Function SizeInBytes As Long
Public Function SizeInBytes As Long
public:
long long SizeInBytes()
public:
long long SizeInBytes()
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

SegmentInfo ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfo Properties

SegmentInfo Properties Lucene.Net Class Library
The SegmentInfo type exposes the following members.
Properties
 | Name | Description
Public property | Diagnostics |
Public property | DocStoreIsCompoundFile |
Public property | DocStoreOffset |
Public property | DocStoreSegment |
Public property | HasProx |
Back to Top
See Also
SegmentInfo Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Diagnostics Property

SegmentInfo Diagnostics Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, string> Diagnostics { get; internal set; }
public IDictionary<string, string> Diagnostics { get; internal set; }
Public Property Diagnostics As IDictionary(Of String, String)
    Get
    Friend Set
Public Property Diagnostics As IDictionary(Of String, String)
    Get
    Friend Set
public:
property IDictionary<String^, String^>^ Diagnostics {
    IDictionary<String^, String^>^ get ();
    internal: void set (IDictionary<String^, String^>^ value);
}
public:
property IDictionary<String^, String^>^ Diagnostics {
    IDictionary<String^, String^>^ get ();
    internal: void set (IDictionary<String^, String^>^ value);
}
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocStoreIsCompoundFile Property

SegmentInfo DocStoreIsCompoundFile Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DocStoreIsCompoundFile { get; internal set; }
public bool DocStoreIsCompoundFile { get; internal set; }
Public Property DocStoreIsCompoundFile As Boolean
    Get
    Friend Set
Public Property DocStoreIsCompoundFile As Boolean
    Get
    Friend Set
public:
property bool DocStoreIsCompoundFile {
    bool get ();
    internal: void set (bool value);
}
public:
property bool DocStoreIsCompoundFile {
    bool get ();
    internal: void set (bool value);
}
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocStoreOffset Property

SegmentInfo DocStoreOffset Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DocStoreOffset { get; internal set; }
public int DocStoreOffset { get; internal set; }
Public Property DocStoreOffset As Integer
    Get
    Friend Set
Public Property DocStoreOffset As Integer
    Get
    Friend Set
public:
property int DocStoreOffset {
    int get ();
    internal: void set (int value);
}
public:
property int DocStoreOffset {
    int get ();
    internal: void set (int value);
}
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocStoreSegment Property

SegmentInfo DocStoreSegment Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DocStoreSegment { get; }
public string DocStoreSegment { get; }
Public ReadOnly Property DocStoreSegment As String
    Get
Public ReadOnly Property DocStoreSegment As String
    Get
public:
property String^ DocStoreSegment {
    String^ get ();
}
public:
property String^ DocStoreSegment {
    String^ get ();
}
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasProx Property

SegmentInfo HasProx Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasProx { get; internal set; }
public bool HasProx { get; internal set; }
Public Property HasProx As Boolean
    Get
    Friend Set
Public Property HasProx As Boolean
    Get
    Friend Set
public:
property bool HasProx {
    bool get ();
    internal: void set (bool value);
}
public:
property bool HasProx {
    bool get ();
    internal: void set (bool value);
}
See Also
SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfos Class

SegmentInfos Class Lucene.Net Class Library
A collection of segmentInfo objects with methods for operating on those segments in relation to the file system.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List SegmentInfo
Lucene.Net.Index SegmentInfos

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class SegmentInfos : List<SegmentInfo>,
    ICloneable
[SerializableAttribute]
public sealed class SegmentInfos : List<SegmentInfo>,
    ICloneable
<SerializableAttribute> _
Public NotInheritable Class SegmentInfos _
    Inherits List(Of SegmentInfo) _
    Implements ICloneable
<SerializableAttribute> _
Public NotInheritable Class SegmentInfos _
    Inherits List(Of SegmentInfo) _
    Implements ICloneable
[SerializableAttribute]
public ref class SegmentInfos sealed : public List<SegmentInfo^>,
    ICloneable
[SerializableAttribute]
public ref class SegmentInfos sealed : public List<SegmentInfo^>,
    ICloneable
See Also
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfos Members

SegmentInfos Members Lucene.Net Class Library

The SegmentInfos type exposes the following members.
Constructors
 | Name | Description
Public method | SegmentInfos | Initializes a new instance of the SegmentInfos class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List SegmentInfo .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List SegmentInfo .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List SegmentInfo .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List SegmentInfo .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List SegmentInfo .)
Public method | Clone | Returns a copy of this instance, also copying each SegmentInfo.
Public method | Commit | Writes & syncs to the Directory dir, taking care to remove the segments file on exception
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List SegmentInfo .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List SegmentInfo .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List SegmentInfo .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List SegmentInfo .)
Public method | Equals | Simple brute force implementation. If size is equal, compare items one by one. (Overrides Online Object Equals(Object).)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List SegmentInfo .)
Public method | Files | Returns all file names referenced by SegmentInfo instances matching the provided Directory (ie files associated with any "external" segments are skipped). The returned collection is recomputed on each invocation.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List SegmentInfo .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List SegmentInfo .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List SegmentInfo .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List SegmentInfo .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List SegmentInfo .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List SegmentInfo .)
 | GenerationFromSegmentsFileName | Parse the generation off the segments file name and return it.
Public method | GetCurrentSegmentFileName | Get the segments_N filename in use by this segment infos.
 | GetCurrentSegmentFileName( String ) | Get the filename of the current segments_N file from a list of files.
 | GetCurrentSegmentFileName(Directory) | Get the filename of the current segments_N file in the directory.
 | GetCurrentSegmentGeneration( String ) | Get the generation (N) of the current segments_N file from a list of files.
 | GetCurrentSegmentGeneration(Directory) | Get the generation (N) of the current segments_N file in the directory.
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List SegmentInfo .)
Public method | GetHashCode | Calculate hash code of SegmentInfos (Overrides Online Object GetHashCode .)
Public method | GetNextSegmentFileName | Get the next segments_N filename that will be written.
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasExternalSegments |
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List SegmentInfo .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List SegmentInfo .)
Public method | Info |
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List SegmentInfo .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List SegmentInfo .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List SegmentInfo .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List SegmentInfo .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Range | Returns a new SegmentInfos containg the SegmentInfo instances in the specified range first (inclusive) to last (exclusive), so total number of segments returned is last-first.
Public method | Read(Directory) | This version of read uses the retry logic (for lock-less commits) to find the right segments file to load.
Public method | Read(Directory, String) | Read a particular segmentFileName. Note that this may throw an IOException if a commit is in process.
 | ReadCurrentUserData | Returns userData from latest segments file
 | ReadCurrentVersion | Current version number from segments file.
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from Online List SegmentInfo .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List SegmentInfo .)
Public method | SegString |
 | SetInfoStream | If non-null, information about retries when loading the segments file will be printed to this.
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List SegmentInfo .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List SegmentInfo .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List SegmentInfo .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List SegmentInfo .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List SegmentInfo .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List SegmentInfo .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List SegmentInfo .)
Back to Top
Fields
 | Name | Description
Public field | counter |
 | FORMAT | The file format version, a negative number.
 | FORMAT_CHECKSUM | This format adds a checksum at the end of the file to ensure all bytes were successfully written.
 | FORMAT_DEL_COUNT | This format adds the deletion count for each segment. This way IndexWriter can efficiently report numDocs().
 | FORMAT_DIAGNOSTICS | This format adds optional per-segment String dianostics storage, and switches userData to Map
 | FORMAT_HAS_PROX | This format adds the boolean hasProx to record if any fields in the segment store prox information (ie, have omitTermFreqAndPositions==false)
 | FORMAT_LOCKLESS | This format adds details used for lockless commits. It differs slightly from the previous format in that file names are never re-used (write once). Instead, each file is written to the next generation. For example, segments_1, segments_2, etc. This allows us to not use a commit lock. See Online file formats for details.
 | FORMAT_SHARED_DOC_STORE | This format allows multiple segments to share a single vectors and stored fields file.
 | FORMAT_SINGLE_NORM_FILE | This format adds a "hasSingleNormFile" flag into each segment info. See Online LUCENE-756 for details.
 | FORMAT_USER_DATA | This format adds optional commit userData (String) storage.
Back to Top
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List SegmentInfo .)
Public property | Online Count | Gets the number of elements actually contained in the Online List T . (Inherited from Online List SegmentInfo .)
 | DefaultGenFileRetryCount | Advanced: Gets or sets how many times to try loading the segments.gen file contents to determine current segment generation. This file is only referenced when the primary method (listing the directory) fails.
 | DefaultGenFileRetryPauseMsec |
 | DefaultGenLookaheadCount | Advanced: set how many times to try incrementing the gen when loading the segments file. This only runs if the primary (listing directory) and secondary (opening segments.gen file) methods fail to find the segments file.
Public property | Generation |
 | InfoStream |
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List SegmentInfo .)
Public property | LastGeneration |
Public property | UserData |
Public property | Version | version number when this SegmentInfos was generated.
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | Online IList Add | Adds an item to the Online IList. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online IList Contains | Determines whether the Online IList contains a specific value. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online ICollection CopyTo | Copies the elements of the Online ICollection to an Online Array, starting at a particular Online Array index. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online IEnumerable T GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online IEnumerable GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online IList IndexOf | Determines the index of a specific item in the Online IList. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online IList Insert | Inserts an item to the Online IList at the specified index. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online IList IsFixedSize | Gets a value indicating whether the Online IList has a fixed size. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online ICollection T IsReadOnly | Gets a value indicating whether the Online ICollection T is read-only. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online IList IsReadOnly | Gets a value indicating whether the Online IList is read-only. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online ICollection IsSynchronized | Gets a value indicating whether access to the Online ICollection is synchronized (thread safe). (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online IList Item | Gets or sets the element at the specified index. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online IList Remove | Removes the first occurrence of a specific object from the Online IList. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online ICollection SyncRoot | Gets an object that can be used to synchronize access to the Online ICollection. (Inherited from Online List SegmentInfo .)
Back to Top
See Also
SegmentInfos Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfos Constructor

SegmentInfos Constructor Lucene.Net Class Library
Initializes a new instance of the SegmentInfos class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SegmentInfos()
public SegmentInfos()
Public Sub New
Public Sub New
public:
SegmentInfos()
public:
SegmentInfos()
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfos Fields

SegmentInfos Fields Lucene.Net Class Library
The SegmentInfos type exposes the following members.
Fields
 | Name | Description
Public field | counter |
 | FORMAT | The file format version, a negative number.
 | FORMAT_CHECKSUM | This format adds a checksum at the end of the file to ensure all bytes were successfully written.
 | FORMAT_DEL_COUNT | This format adds the deletion count for each segment. This way IndexWriter can efficiently report numDocs().
 | FORMAT_DIAGNOSTICS | This format adds optional per-segment String dianostics storage, and switches userData to Map
 | FORMAT_HAS_PROX | This format adds the boolean hasProx to record if any fields in the segment store prox information (ie, have omitTermFreqAndPositions==false)
 | FORMAT_LOCKLESS | This format adds details used for lockless commits. It differs slightly from the previous format in that file names are never re-used (write once). Instead, each file is written to the next generation. For example, segments_1, segments_2, etc. This allows us to not use a commit lock. See Online file formats for details.
 | FORMAT_SHARED_DOC_STORE | This format allows multiple segments to share a single vectors and stored fields file.
 | FORMAT_SINGLE_NORM_FILE | This format adds a "hasSingleNormFile" flag into each segment info. See Online LUCENE-756 for details.
 | FORMAT_USER_DATA | This format adds optional commit userData (String) storage.
Back to Top
See Also
SegmentInfos Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


counter Field

SegmentInfos counter Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int counter
public int counter
Public counter As Integer
Public counter As Integer
public:
int counter
public:
int counter
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FORMAT Field

SegmentInfos FORMAT Field Lucene.Net Class Library
The file format version, a negative number.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int FORMAT
public const int FORMAT
Public Const FORMAT As Integer
Public Const FORMAT As Integer
public:
literal int FORMAT
public:
literal int FORMAT
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FORMAT_CHECKSUM Field

SegmentInfos FORMAT_CHECKSUM Field Lucene.Net Class Library
This format adds a checksum at the end of the file to ensure all bytes were successfully written.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int FORMAT_CHECKSUM
public const int FORMAT_CHECKSUM
Public Const FORMAT_CHECKSUM As Integer
Public Const FORMAT_CHECKSUM As Integer
public:
literal int FORMAT_CHECKSUM
public:
literal int FORMAT_CHECKSUM
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FORMAT_DEL_COUNT Field

SegmentInfos FORMAT_DEL_COUNT Field Lucene.Net Class Library
This format adds the deletion count for each segment. This way IndexWriter can efficiently report numDocs().

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int FORMAT_DEL_COUNT
public const int FORMAT_DEL_COUNT
Public Const FORMAT_DEL_COUNT As Integer
Public Const FORMAT_DEL_COUNT As Integer
public:
literal int FORMAT_DEL_COUNT
public:
literal int FORMAT_DEL_COUNT
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FORMAT_DIAGNOSTICS Field

SegmentInfos FORMAT_DIAGNOSTICS Field Lucene.Net Class Library
This format adds optional per-segment String dianostics storage, and switches userData to Map

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int FORMAT_DIAGNOSTICS
public const int FORMAT_DIAGNOSTICS
Public Const FORMAT_DIAGNOSTICS As Integer
Public Const FORMAT_DIAGNOSTICS As Integer
public:
literal int FORMAT_DIAGNOSTICS
public:
literal int FORMAT_DIAGNOSTICS
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FORMAT_HAS_PROX Field

SegmentInfos FORMAT_HAS_PROX Field Lucene.Net Class Library
This format adds the boolean hasProx to record if any fields in the segment store prox information (ie, have omitTermFreqAndPositions==false)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int FORMAT_HAS_PROX
public const int FORMAT_HAS_PROX
Public Const FORMAT_HAS_PROX As Integer
Public Const FORMAT_HAS_PROX As Integer
public:
literal int FORMAT_HAS_PROX
public:
literal int FORMAT_HAS_PROX
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FORMAT_LOCKLESS Field

SegmentInfos FORMAT_LOCKLESS Field Lucene.Net Class Library
This format adds details used for lockless commits. It differs slightly from the previous format in that file names are never re-used (write once). Instead, each file is written to the next generation. For example, segments_1, segments_2, etc. This allows us to not use a commit lock. See Online file formats for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int FORMAT_LOCKLESS
public const int FORMAT_LOCKLESS
Public Const FORMAT_LOCKLESS As Integer
Public Const FORMAT_LOCKLESS As Integer
public:
literal int FORMAT_LOCKLESS
public:
literal int FORMAT_LOCKLESS
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FORMAT_SHARED_DOC_STORE Field

SegmentInfos FORMAT_SHARED_DOC_STORE Field Lucene.Net Class Library
This format allows multiple segments to share a single vectors and stored fields file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int FORMAT_SHARED_DOC_STORE
public const int FORMAT_SHARED_DOC_STORE
Public Const FORMAT_SHARED_DOC_STORE As Integer
Public Const FORMAT_SHARED_DOC_STORE As Integer
public:
literal int FORMAT_SHARED_DOC_STORE
public:
literal int FORMAT_SHARED_DOC_STORE
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FORMAT_SINGLE_NORM_FILE Field

SegmentInfos FORMAT_SINGLE_NORM_FILE Field Lucene.Net Class Library
This format adds a "hasSingleNormFile" flag into each segment info. See Online LUCENE-756 for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int FORMAT_SINGLE_NORM_FILE
public const int FORMAT_SINGLE_NORM_FILE
Public Const FORMAT_SINGLE_NORM_FILE As Integer
Public Const FORMAT_SINGLE_NORM_FILE As Integer
public:
literal int FORMAT_SINGLE_NORM_FILE
public:
literal int FORMAT_SINGLE_NORM_FILE
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FORMAT_USER_DATA Field

SegmentInfos FORMAT_USER_DATA Field Lucene.Net Class Library
This format adds optional commit userData (String) storage.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int FORMAT_USER_DATA
public const int FORMAT_USER_DATA
Public Const FORMAT_USER_DATA As Integer
Public Const FORMAT_USER_DATA As Integer
public:
literal int FORMAT_USER_DATA
public:
literal int FORMAT_USER_DATA
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfos Methods

SegmentInfos Methods Lucene.Net Class Library
The SegmentInfos type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List SegmentInfo .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List SegmentInfo .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List SegmentInfo .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List SegmentInfo .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List SegmentInfo .)
Public method | Clone | Returns a copy of this instance, also copying each SegmentInfo.
Public method | Commit | Writes & syncs to the Directory dir, taking care to remove the segments file on exception
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List SegmentInfo .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List SegmentInfo .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List SegmentInfo .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List SegmentInfo .)
Public method | Equals | Simple brute force implementation. If size is equal, compare items one by one. (Overrides Online Object Equals(Object).)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List SegmentInfo .)
Public method | Files | Returns all file names referenced by SegmentInfo instances matching the provided Directory (ie files associated with any "external" segments are skipped). The returned collection is recomputed on each invocation.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List SegmentInfo .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List SegmentInfo .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List SegmentInfo .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List SegmentInfo .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List SegmentInfo .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List SegmentInfo .)
 | GenerationFromSegmentsFileName | Parse the generation off the segments file name and return it.
Public method | GetCurrentSegmentFileName | Get the segments_N filename in use by this segment infos.
 | GetCurrentSegmentFileName( String ) | Get the filename of the current segments_N file from a list of files.
 | GetCurrentSegmentFileName(Directory) | Get the filename of the current segments_N file in the directory.
 | GetCurrentSegmentGeneration( String ) | Get the generation (N) of the current segments_N file from a list of files.
 | GetCurrentSegmentGeneration(Directory) | Get the generation (N) of the current segments_N file in the directory.
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List SegmentInfo .)
Public method | GetHashCode | Calculate hash code of SegmentInfos (Overrides Online Object GetHashCode .)
Public method | GetNextSegmentFileName | Get the next segments_N filename that will be written.
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasExternalSegments |
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List SegmentInfo .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List SegmentInfo .)
Public method | Info |
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List SegmentInfo .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List SegmentInfo .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List SegmentInfo .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List SegmentInfo .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Range | Returns a new SegmentInfos containg the SegmentInfo instances in the specified range first (inclusive) to last (exclusive), so total number of segments returned is last-first.
Public method | Read(Directory) | This version of read uses the retry logic (for lock-less commits) to find the right segments file to load.
Public method | Read(Directory, String) | Read a particular segmentFileName. Note that this may throw an IOException if a commit is in process.
 | ReadCurrentUserData | Returns userData from latest segments file
 | ReadCurrentVersion | Current version number from segments file.
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from Online List SegmentInfo .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List SegmentInfo .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List SegmentInfo .)
Public method | SegString |
 | SetInfoStream | If non-null, information about retries when loading the segments file will be printed to this.
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List SegmentInfo .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List SegmentInfo .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List SegmentInfo .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List SegmentInfo .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List SegmentInfo .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List SegmentInfo .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List SegmentInfo .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | Online IList Add | Adds an item to the Online IList. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online IList Contains | Determines whether the Online IList contains a specific value. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online ICollection CopyTo | Copies the elements of the Online ICollection to an Online Array, starting at a particular Online Array index. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online IEnumerable T GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online IEnumerable GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online IList IndexOf | Determines the index of a specific item in the Online IList. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online IList Insert | Inserts an item to the Online IList at the specified index. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online IList Remove | Removes the first occurrence of a specific object from the Online IList. (Inherited from Online List SegmentInfo .)
Back to Top
See Also
SegmentInfos Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

SegmentInfos Clone Method Lucene.Net Class Library
Returns a copy of this instance, also copying each SegmentInfo.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Clone()
public Object Clone()
Public Function Clone As Object
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
public:
virtual Object^ Clone() sealed
Implements
  Online ICloneable Clone
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Commit Method

SegmentInfos Commit Method Lucene.Net Class Library
Writes & syncs to the Directory dir, taking care to remove the segments file on exception

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Commit(
    Directory dir
)
public void Commit(
    Directory dir
)
Public Sub Commit ( _
    dir As Directory _
)
Public Sub Commit ( _
    dir As Directory _
)
public:
void Commit(
    Directory^ dir
)
public:
void Commit(
    Directory^ dir
)
Parameters
dir
Type: Lucene.Net.Store Directory
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

SegmentInfos Equals Method Lucene.Net Class Library
Simple brute force implementation. If size is equal, compare items one by one.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
SegmentInfos object to check equality for
Return Value
true if lists are equal, false otherwise
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Files Method

SegmentInfos Files Method Lucene.Net Class Library
Returns all file names referenced by SegmentInfo instances matching the provided Directory (ie files associated with any "external" segments are skipped). The returned collection is recomputed on each invocation.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<string> Files(
    Directory dir,
    bool includeSegmentsFile
)
public ICollection<string> Files(
    Directory dir,
    bool includeSegmentsFile
)
Public Function Files ( _
    dir As Directory, _
    includeSegmentsFile As Boolean _
) As ICollection(Of String)
Public Function Files ( _
    dir As Directory, _
    includeSegmentsFile As Boolean _
) As ICollection(Of String)
public:
ICollection<String^>^ Files(
    Directory^ dir,
    bool includeSegmentsFile
)
public:
ICollection<String^>^ Files(
    Directory^ dir,
    bool includeSegmentsFile
)
Parameters
dir
Type: Lucene.Net.Store Directory
includeSegmentsFile
Type:   Online System Boolean
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GenerationFromSegmentsFileName Method

SegmentInfos GenerationFromSegmentsFileName Method Lucene.Net Class Library
Parse the generation off the segments file name and return it.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long GenerationFromSegmentsFileName(
    string fileName
)
public static long GenerationFromSegmentsFileName(
    string fileName
)
Public Shared Function GenerationFromSegmentsFileName ( _
    fileName As String _
) As Long
Public Shared Function GenerationFromSegmentsFileName ( _
    fileName As String _
) As Long
public:
static long long GenerationFromSegmentsFileName(
    String^ fileName
)
public:
static long long GenerationFromSegmentsFileName(
    String^ fileName
)
Parameters
fileName
Type:   Online System String
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCurrentSegmentFileName Method

SegmentInfos GetCurrentSegmentFileName Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetCurrentSegmentFileName | Get the segments_N filename in use by this segment infos.
 | GetCurrentSegmentFileName( String ) | Get the filename of the current segments_N file from a list of files.
 | GetCurrentSegmentFileName(Directory) | Get the filename of the current segments_N file in the directory.
Back to Top
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCurrentSegmentFileName Method

SegmentInfos GetCurrentSegmentFileName Method Lucene.Net Class Library
Get the segments_N filename in use by this segment infos.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetCurrentSegmentFileName()
public string GetCurrentSegmentFileName()
Public Function GetCurrentSegmentFileName As String
Public Function GetCurrentSegmentFileName As String
public:
String^ GetCurrentSegmentFileName()
public:
String^ GetCurrentSegmentFileName()
See Also
SegmentInfos Class
SegmentInfos Members
GetCurrentSegmentFileName Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCurrentSegmentFileName Method (String[])

SegmentInfos GetCurrentSegmentFileName Method ( String ) Lucene.Net Class Library
Get the filename of the current segments_N file from a list of files.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetCurrentSegmentFileName(
    string[] files
)
public static string GetCurrentSegmentFileName(
    string[] files
)
Public Shared Function GetCurrentSegmentFileName ( _
    files As String() _
) As String
Public Shared Function GetCurrentSegmentFileName ( _
    files As String() _
) As String
public:
static String^ GetCurrentSegmentFileName(
    array<String^>^ files
)
public:
static String^ GetCurrentSegmentFileName(
    array<String^>^ files
)
Parameters
files
Type:    Online System String
-- array of file names to check

See Also
SegmentInfos Class
SegmentInfos Members
GetCurrentSegmentFileName Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCurrentSegmentFileName Method (Directory)

SegmentInfos GetCurrentSegmentFileName Method (Directory) Lucene.Net Class Library
Get the filename of the current segments_N file in the directory.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetCurrentSegmentFileName(
    Directory directory
)
public static string GetCurrentSegmentFileName(
    Directory directory
)
Public Shared Function GetCurrentSegmentFileName ( _
    directory As Directory _
) As String
Public Shared Function GetCurrentSegmentFileName ( _
    directory As Directory _
) As String
public:
static String^ GetCurrentSegmentFileName(
    Directory^ directory
)
public:
static String^ GetCurrentSegmentFileName(
    Directory^ directory
)
Parameters
directory
Type: Lucene.Net.Store Directory
-- directory to search for the latest segments_N file

See Also
SegmentInfos Class
SegmentInfos Members
GetCurrentSegmentFileName Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCurrentSegmentGeneration Method

SegmentInfos GetCurrentSegmentGeneration Method Lucene.Net Class Library
Overload List
Name | Description
GetCurrentSegmentGeneration( String ) | Get the generation (N) of the current segments_N file from a list of files.
GetCurrentSegmentGeneration(Directory) | Get the generation (N) of the current segments_N file in the directory.
Back to Top
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCurrentSegmentGeneration Method (String[])

SegmentInfos GetCurrentSegmentGeneration Method ( String ) Lucene.Net Class Library
Get the generation (N) of the current segments_N file from a list of files.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long GetCurrentSegmentGeneration(
    string[] files
)
public static long GetCurrentSegmentGeneration(
    string[] files
)
Public Shared Function GetCurrentSegmentGeneration ( _
    files As String() _
) As Long
Public Shared Function GetCurrentSegmentGeneration ( _
    files As String() _
) As Long
public:
static long long GetCurrentSegmentGeneration(
    array<String^>^ files
)
public:
static long long GetCurrentSegmentGeneration(
    array<String^>^ files
)
Parameters
files
Type:    Online System String
-- array of file names to check

See Also
SegmentInfos Class
SegmentInfos Members
GetCurrentSegmentGeneration Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCurrentSegmentGeneration Method (Directory)

SegmentInfos GetCurrentSegmentGeneration Method (Directory) Lucene.Net Class Library
Get the generation (N) of the current segments_N file in the directory.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long GetCurrentSegmentGeneration(
    Directory directory
)
public static long GetCurrentSegmentGeneration(
    Directory directory
)
Public Shared Function GetCurrentSegmentGeneration ( _
    directory As Directory _
) As Long
Public Shared Function GetCurrentSegmentGeneration ( _
    directory As Directory _
) As Long
public:
static long long GetCurrentSegmentGeneration(
    Directory^ directory
)
public:
static long long GetCurrentSegmentGeneration(
    Directory^ directory
)
Parameters
directory
Type: Lucene.Net.Store Directory
-- directory to search for the latest segments_N file

See Also
SegmentInfos Class
SegmentInfos Members
GetCurrentSegmentGeneration Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

SegmentInfos GetHashCode Method Lucene.Net Class Library
Calculate hash code of SegmentInfos

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
Return Value
hash code as in java version of ArrayList
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetNextSegmentFileName Method

SegmentInfos GetNextSegmentFileName Method Lucene.Net Class Library
Get the next segments_N filename that will be written.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetNextSegmentFileName()
public string GetNextSegmentFileName()
Public Function GetNextSegmentFileName As String
Public Function GetNextSegmentFileName As String
public:
String^ GetNextSegmentFileName()
public:
String^ GetNextSegmentFileName()
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasExternalSegments Method

SegmentInfos HasExternalSegments Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasExternalSegments(
    Directory dir
)
public bool HasExternalSegments(
    Directory dir
)
Public Function HasExternalSegments ( _
    dir As Directory _
) As Boolean
Public Function HasExternalSegments ( _
    dir As Directory _
) As Boolean
public:
bool HasExternalSegments(
    Directory^ dir
)
public:
bool HasExternalSegments(
    Directory^ dir
)
Parameters
dir
Type: Lucene.Net.Store Directory
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Info Method

SegmentInfos Info Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SegmentInfo Info(
    int i
)
public SegmentInfo Info(
    int i
)
Public Function Info ( _
    i As Integer _
) As SegmentInfo
Public Function Info ( _
    i As Integer _
) As SegmentInfo
public:
SegmentInfo^ Info(
    int i
)
public:
SegmentInfo^ Info(
    int i
)
Parameters
i
Type:   Online System Int32
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Range Method

SegmentInfos Range Method Lucene.Net Class Library
Returns a new SegmentInfos containg the SegmentInfo instances in the specified range first (inclusive) to last (exclusive), so total number of segments returned is last-first.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SegmentInfos Range(
    int first,
    int last
)
public SegmentInfos Range(
    int first,
    int last
)
Public Function Range ( _
    first As Integer, _
    last As Integer _
) As SegmentInfos
Public Function Range ( _
    first As Integer, _
    last As Integer _
) As SegmentInfos
public:
SegmentInfos^ Range(
    int first,
    int last
)
public:
SegmentInfos^ Range(
    int first,
    int last
)
Parameters
first
Type:   Online System Int32
last
Type:   Online System Int32
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Read Method

SegmentInfos Read Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Read(Directory) | This version of read uses the retry logic (for lock-less commits) to find the right segments file to load.
Public method | Read(Directory, String) | Read a particular segmentFileName. Note that this may throw an IOException if a commit is in process.
Back to Top
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Read Method (Directory)

SegmentInfos Read Method (Directory) Lucene.Net Class Library
This version of read uses the retry logic (for lock-less commits) to find the right segments file to load.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Read(
    Directory directory
)
public void Read(
    Directory directory
)
Public Sub Read ( _
    directory As Directory _
)
Public Sub Read ( _
    directory As Directory _
)
public:
void Read(
    Directory^ directory
)
public:
void Read(
    Directory^ directory
)
Parameters
directory
Type: Lucene.Net.Store Directory
See Also
SegmentInfos Class
SegmentInfos Members
Read Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Read Method (Directory, String)

SegmentInfos Read Method (Directory, String) Lucene.Net Class Library
Read a particular segmentFileName. Note that this may throw an IOException if a commit is in process.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Read(
    Directory directory,
    string segmentFileName
)
public void Read(
    Directory directory,
    string segmentFileName
)
Public Sub Read ( _
    directory As Directory, _
    segmentFileName As String _
)
Public Sub Read ( _
    directory As Directory, _
    segmentFileName As String _
)
public:
void Read(
    Directory^ directory,
    String^ segmentFileName
)
public:
void Read(
    Directory^ directory,
    String^ segmentFileName
)
Parameters
directory
Type: Lucene.Net.Store Directory
-- directory containing the segments file

segmentFileName
Type:   Online System String
-- segment file to load

See Also
SegmentInfos Class
SegmentInfos Members
Read Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadCurrentUserData Method

SegmentInfos ReadCurrentUserData Method Lucene.Net Class Library
Returns userData from latest segments file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IDictionary<string, string> ReadCurrentUserData(
    Directory directory
)
public static IDictionary<string, string> ReadCurrentUserData(
    Directory directory
)
Public Shared Function ReadCurrentUserData ( _
    directory As Directory _
) As IDictionary(Of String, String)
Public Shared Function ReadCurrentUserData ( _
    directory As Directory _
) As IDictionary(Of String, String)
public:
static IDictionary<String^, String^>^ ReadCurrentUserData(
    Directory^ directory
)
public:
static IDictionary<String^, String^>^ ReadCurrentUserData(
    Directory^ directory
)
Parameters
directory
Type: Lucene.Net.Store Directory
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadCurrentVersion Method

SegmentInfos ReadCurrentVersion Method Lucene.Net Class Library
Current version number from segments file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long ReadCurrentVersion(
    Directory directory
)
public static long ReadCurrentVersion(
    Directory directory
)
Public Shared Function ReadCurrentVersion ( _
    directory As Directory _
) As Long
Public Shared Function ReadCurrentVersion ( _
    directory As Directory _
) As Long
public:
static long long ReadCurrentVersion(
    Directory^ directory
)
public:
static long long ReadCurrentVersion(
    Directory^ directory
)
Parameters
directory
Type: Lucene.Net.Store Directory
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegString Method

SegmentInfos SegString Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SegString(
    Directory directory
)
public string SegString(
    Directory directory
)
Public Function SegString ( _
    directory As Directory _
) As String
Public Function SegString ( _
    directory As Directory _
) As String
public:
String^ SegString(
    Directory^ directory
)
public:
String^ SegString(
    Directory^ directory
)
Parameters
directory
Type: Lucene.Net.Store Directory
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetInfoStream Method

SegmentInfos SetInfoStream Method Lucene.Net Class Library
If non-null, information about retries when loading the segments file will be printed to this.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void SetInfoStream(
    StreamWriter infoStream
)
public static void SetInfoStream(
    StreamWriter infoStream
)
Public Shared Sub SetInfoStream ( _
    infoStream As StreamWriter _
)
Public Shared Sub SetInfoStream ( _
    infoStream As StreamWriter _
)
public:
static void SetInfoStream(
    StreamWriter^ infoStream
)
public:
static void SetInfoStream(
    StreamWriter^ infoStream
)
Parameters
infoStream
Type:   Online System.IO StreamWriter
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfos Properties

SegmentInfos Properties Lucene.Net Class Library
The SegmentInfos type exposes the following members.
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List SegmentInfo .)
Public property | Online Count | Gets the number of elements actually contained in the Online List T . (Inherited from Online List SegmentInfo .)
 | DefaultGenFileRetryCount | Advanced: Gets or sets how many times to try loading the segments.gen file contents to determine current segment generation. This file is only referenced when the primary method (listing the directory) fails.
 | DefaultGenFileRetryPauseMsec |
 | DefaultGenLookaheadCount | Advanced: set how many times to try incrementing the gen when loading the segments file. This only runs if the primary (listing directory) and secondary (opening segments.gen file) methods fail to find the segments file.
Public property | Generation |
 | InfoStream |
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List SegmentInfo .)
Public property | LastGeneration |
Public property | UserData |
Public property | Version | version number when this SegmentInfos was generated.
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | Online IList IsFixedSize | Gets a value indicating whether the Online IList has a fixed size. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online ICollection T IsReadOnly | Gets a value indicating whether the Online ICollection T is read-only. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online IList IsReadOnly | Gets a value indicating whether the Online IList is read-only. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online ICollection IsSynchronized | Gets a value indicating whether access to the Online ICollection is synchronized (thread safe). (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online IList Item | Gets or sets the element at the specified index. (Inherited from Online List SegmentInfo .)
Explicit interface implemetation | Online ICollection SyncRoot | Gets an object that can be used to synchronize access to the Online ICollection. (Inherited from Online List SegmentInfo .)
Back to Top
See Also
SegmentInfos Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DefaultGenFileRetryCount Property

SegmentInfos DefaultGenFileRetryCount Property Lucene.Net Class Library
Advanced: Gets or sets how many times to try loading the segments.gen file contents to determine current segment generation. This file is only referenced when the primary method (listing the directory) fails.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int DefaultGenFileRetryCount { get; set; }
public static int DefaultGenFileRetryCount { get; set; }
Public Shared Property DefaultGenFileRetryCount As Integer
    Get
    Set
Public Shared Property DefaultGenFileRetryCount As Integer
    Get
    Set
public:
static property int DefaultGenFileRetryCount {
    int get ();
    void set (int value);
}
public:
static property int DefaultGenFileRetryCount {
    int get ();
    void set (int value);
}
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DefaultGenFileRetryPauseMsec Property

SegmentInfos DefaultGenFileRetryPauseMsec Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int DefaultGenFileRetryPauseMsec { get; set; }
public static int DefaultGenFileRetryPauseMsec { get; set; }
Public Shared Property DefaultGenFileRetryPauseMsec As Integer
    Get
    Set
Public Shared Property DefaultGenFileRetryPauseMsec As Integer
    Get
    Set
public:
static property int DefaultGenFileRetryPauseMsec {
    int get ();
    void set (int value);
}
public:
static property int DefaultGenFileRetryPauseMsec {
    int get ();
    void set (int value);
}
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DefaultGenLookaheadCount Property

SegmentInfos DefaultGenLookaheadCount Property Lucene.Net Class Library
Advanced: set how many times to try incrementing the gen when loading the segments file. This only runs if the primary (listing directory) and secondary (opening segments.gen file) methods fail to find the segments file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int DefaultGenLookaheadCount { get; set; }
public static int DefaultGenLookaheadCount { get; set; }
Public Shared Property DefaultGenLookaheadCount As Integer
    Get
    Set
Public Shared Property DefaultGenLookaheadCount As Integer
    Get
    Set
public:
static property int DefaultGenLookaheadCount {
    int get ();
    void set (int value);
}
public:
static property int DefaultGenLookaheadCount {
    int get ();
    void set (int value);
}
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Generation Property

SegmentInfos Generation Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long Generation { get; }
public long Generation { get; }
Public ReadOnly Property Generation As Long
    Get
Public ReadOnly Property Generation As Long
    Get
public:
property long long Generation {
    long long get ();
}
public:
property long long Generation {
    long long get ();
}
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


InfoStream Property

SegmentInfos InfoStream Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static StreamWriter InfoStream { get; }
public static StreamWriter InfoStream { get; }
Public Shared ReadOnly Property InfoStream As StreamWriter
    Get
Public Shared ReadOnly Property InfoStream As StreamWriter
    Get
public:
static property StreamWriter^ InfoStream {
    StreamWriter^ get ();
}
public:
static property StreamWriter^ InfoStream {
    StreamWriter^ get ();
}
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
SegmentInfos SetInfoStream(StreamWriter)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LastGeneration Property

SegmentInfos LastGeneration Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long LastGeneration { get; }
public long LastGeneration { get; }
Public ReadOnly Property LastGeneration As Long
    Get
Public ReadOnly Property LastGeneration As Long
    Get
public:
property long long LastGeneration {
    long long get ();
}
public:
property long long LastGeneration {
    long long get ();
}
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UserData Property

SegmentInfos UserData Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, string> UserData { get; internal set; }
public IDictionary<string, string> UserData { get; internal set; }
Public Property UserData As IDictionary(Of String, String)
    Get
    Friend Set
Public Property UserData As IDictionary(Of String, String)
    Get
    Friend Set
public:
property IDictionary<String^, String^>^ UserData {
    IDictionary<String^, String^>^ get ();
    internal: void set (IDictionary<String^, String^>^ value);
}
public:
property IDictionary<String^, String^>^ UserData {
    IDictionary<String^, String^>^ get ();
    internal: void set (IDictionary<String^, String^>^ value);
}
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Version Property

SegmentInfos Version Property Lucene.Net Class Library
version number when this SegmentInfos was generated.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long Version { get; }
public long Version { get; }
Public ReadOnly Property Version As Long
    Get
Public ReadOnly Property Version As Long
    Get
public:
property long long Version {
    long long get ();
}
public:
property long long Version {
    long long get ();
}
See Also
SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfos.FindSegmentsFile Class

SegmentInfos FindSegmentsFile Class Lucene.Net Class Library
Utility class for executing code that needs to do something with the current segments file. This is necessary with lock-less commits because from the time you locate the current segments file name, until you actually open it, read its contents, or check modified time, etc., it could have been deleted due to a writer commit finishing.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index SegmentInfos FindSegmentsFile

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class FindSegmentsFile
public abstract class FindSegmentsFile
Public MustInherit Class FindSegmentsFile
Public MustInherit Class FindSegmentsFile
public ref class FindSegmentsFile abstract
public ref class FindSegmentsFile abstract
See Also
SegmentInfos FindSegmentsFile Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfos.FindSegmentsFile Members

SegmentInfos FindSegmentsFile Members Lucene.Net Class Library

A collection of segmentInfo objects with methods for operating on those segments in relation to the file system.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

The SegmentInfos FindSegmentsFile type exposes the following members.
Constructors
 | Name | Description
Protected method | SegmentInfos FindSegmentsFile | Initializes a new instance of the SegmentInfos FindSegmentsFile class
Back to Top
Methods
 | Name | Description
Public method | DoBody | Subclass must implement this. The assumption is an IOException will be thrown if something goes wrong during the processing that could have been caused by a writer committing.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Run |
Public method | Run(IndexCommit) |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SegmentInfos FindSegmentsFile Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfos.FindSegmentsFile Constructor

SegmentInfos FindSegmentsFile Constructor Lucene.Net Class Library
Initializes a new instance of the SegmentInfos FindSegmentsFile class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FindSegmentsFile(
    Directory directory
)
protected FindSegmentsFile(
    Directory directory
)
Protected Sub New ( _
    directory As Directory _
)
Protected Sub New ( _
    directory As Directory _
)
protected:
FindSegmentsFile(
    Directory^ directory
)
protected:
FindSegmentsFile(
    Directory^ directory
)
Parameters
directory
Type: Lucene.Net.Store Directory
See Also
SegmentInfos FindSegmentsFile Class
SegmentInfos FindSegmentsFile Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentInfos.FindSegmentsFile Methods

SegmentInfos FindSegmentsFile Methods Lucene.Net Class Library
The SegmentInfos FindSegmentsFile type exposes the following members.
Methods
 | Name | Description
Public method | DoBody | Subclass must implement this. The assumption is an IOException will be thrown if something goes wrong during the processing that could have been caused by a writer committing.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Run |
Public method | Run(IndexCommit) |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SegmentInfos FindSegmentsFile Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoBody Method

SegmentInfos FindSegmentsFile DoBody Method Lucene.Net Class Library
Subclass must implement this. The assumption is an IOException will be thrown if something goes wrong during the processing that could have been caused by a writer committing.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Object DoBody(
    string segmentFileName
)
public abstract Object DoBody(
    string segmentFileName
)
Public MustOverride Function DoBody ( _
    segmentFileName As String _
) As Object
Public MustOverride Function DoBody ( _
    segmentFileName As String _
) As Object
public:
virtual Object^ DoBody(
    String^ segmentFileName
) abstract
public:
virtual Object^ DoBody(
    String^ segmentFileName
) abstract
Parameters
segmentFileName
Type:   Online System String
See Also
SegmentInfos FindSegmentsFile Class
SegmentInfos FindSegmentsFile Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Run Method

SegmentInfos FindSegmentsFile Run Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Run |
Public method | Run(IndexCommit) |
Back to Top
See Also
SegmentInfos FindSegmentsFile Class
SegmentInfos FindSegmentsFile Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Run Method

SegmentInfos FindSegmentsFile Run Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Run()
public Object Run()
Public Function Run As Object
Public Function Run As Object
public:
Object^ Run()
public:
Object^ Run()
See Also
SegmentInfos FindSegmentsFile Class
SegmentInfos FindSegmentsFile Members
Run Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Run Method (IndexCommit)

SegmentInfos FindSegmentsFile Run Method (IndexCommit) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Run(
    IndexCommit commit
)
public Object Run(
    IndexCommit commit
)
Public Function Run ( _
    commit As IndexCommit _
) As Object
Public Function Run ( _
    commit As IndexCommit _
) As Object
public:
Object^ Run(
    IndexCommit^ commit
)
public:
Object^ Run(
    IndexCommit^ commit
)
Parameters
commit
Type: Lucene.Net.Index IndexCommit
See Also
SegmentInfos FindSegmentsFile Class
SegmentInfos FindSegmentsFile Members
Run Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentMerger Class

SegmentMerger Class Lucene.Net Class Library
The SegmentMerger class combines two or more Segments, represented by an IndexReader (Add(IndexReader), into a single Segment. After adding the appropriate readers, call the merge method to combine the segments.

If the compoundFile flag is set, then the segments will be merged into a compound file.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index SegmentMerger

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class SegmentMerger
public sealed class SegmentMerger
Public NotInheritable Class SegmentMerger
Public NotInheritable Class SegmentMerger
public ref class SegmentMerger sealed
public ref class SegmentMerger sealed
See Also
SegmentMerger Members
Lucene.Net.Index Namespace
SegmentMerger Merge
SegmentMerger Add(IndexReader)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentMerger Members

SegmentMerger Members Lucene.Net Class Library

The SegmentMerger type exposes the following members.
Constructors
 | Name | Description
Public method | SegmentMerger | This ctor used only by test code.
Back to Top
Methods
 | Name | Description
Public method | Add | Add an IndexReader to the collection of readers that are to be merged
Public method | CreateCompoundFile |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Merge | Merges the readers specified by the Add(IndexReader) method into the directory passed to the constructor
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SegmentMerger Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentMerger Constructor

SegmentMerger Constructor Lucene.Net Class Library
This ctor used only by test code.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SegmentMerger(
    Directory dir,
    string name
)
public SegmentMerger(
    Directory dir,
    string name
)
Public Sub New ( _
    dir As Directory, _
    name As String _
)
Public Sub New ( _
    dir As Directory, _
    name As String _
)
public:
SegmentMerger(
    Directory^ dir,
    String^ name
)
public:
SegmentMerger(
    Directory^ dir,
    String^ name
)
Parameters
dir
Type: Lucene.Net.Store Directory
The Directory to merge the other segments into

name
Type:   Online System String
The name of the new segment

See Also
SegmentMerger Class
SegmentMerger Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentMerger Methods

SegmentMerger Methods Lucene.Net Class Library
The SegmentMerger type exposes the following members.
Methods
 | Name | Description
Public method | Add | Add an IndexReader to the collection of readers that are to be merged
Public method | CreateCompoundFile |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Merge | Merges the readers specified by the Add(IndexReader) method into the directory passed to the constructor
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SegmentMerger Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method

SegmentMerger Add Method Lucene.Net Class Library
Add an IndexReader to the collection of readers that are to be merged

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    IndexReader reader
)
public void Add(
    IndexReader reader
)
Public Sub Add ( _
    reader As IndexReader _
)
Public Sub Add ( _
    reader As IndexReader _
)
public:
void Add(
    IndexReader^ reader
)
public:
void Add(
    IndexReader^ reader
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
SegmentMerger Class
SegmentMerger Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateCompoundFile Method

SegmentMerger CreateCompoundFile Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<string> CreateCompoundFile(
    string fileName
)
public ICollection<string> CreateCompoundFile(
    string fileName
)
Public Function CreateCompoundFile ( _
    fileName As String _
) As ICollection(Of String)
Public Function CreateCompoundFile ( _
    fileName As String _
) As ICollection(Of String)
public:
ICollection<String^>^ CreateCompoundFile(
    String^ fileName
)
public:
ICollection<String^>^ CreateCompoundFile(
    String^ fileName
)
Parameters
fileName
Type:   Online System String
See Also
SegmentMerger Class
SegmentMerger Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Merge Method

SegmentMerger Merge Method Lucene.Net Class Library
Merges the readers specified by the Add(IndexReader) method into the directory passed to the constructor

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Merge()
public int Merge()
Public Function Merge As Integer
Public Function Merge As Integer
public:
int Merge()
public:
int Merge()
Return Value
 The number of documents that were merged

See Also
SegmentMerger Class
SegmentMerger Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader Class

SegmentReader Class Lucene.Net Class Library

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

Inheritance Hierarchy
Online System Object
Lucene.Net.Index IndexReader
Lucene.Net.Index SegmentReader
Lucene.Net.Index ReadOnlySegmentReader

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SegmentReader : IndexReader
public class SegmentReader : IndexReader
Public Class SegmentReader _
    Inherits IndexReader
Public Class SegmentReader _
    Inherits IndexReader
public ref class SegmentReader : public IndexReader
public ref class SegmentReader : public IndexReader
See Also
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader Members

SegmentReader Members Lucene.Net Class Library

The SegmentReader type exposes the following members.
Constructors
 | Name | Description
Public method | SegmentReader | Initializes a new instance of the SegmentReader class
Back to Top
Methods
Name | Description
Protected method AcquireWriteLock
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
(Inherited from IndexReader.)
Public method | Clone | (Overrides IndexReader Clone .)
Public method | Clone(Boolean) | (Overrides IndexReader Clone(Boolean).)
Protected method CloneDeletedDocs
Clones the deleteDocs BitVector. May be overridden by subclasses. New and experimental.
Protected method CloneNormBytes
Clones the norm bytes. May be overridden by subclasses. New and experimental.
Public method | Close | Obsolete. (Inherited from IndexReader.)
Public method Commit
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary String, String )
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered docNum. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the Document(Int32) method will result in an error. The presence of this document may still be reflected in the DocFreq(Term) statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given term indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See DeleteDocument(Int32) for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method Directory
Returns the directory this index resides in.
(Overrides IndexReader Directory .)
Public method Dispose
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Protected method | Dispose(Boolean) | (Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader DoClose .)
Protected method | DoCommit | (Overrides IndexReader DoCommit(IDictionary String, String ).)
Public method Document(Int32)
Returns the stored fields of the nthDocument in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted.
(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader DoDelete(Int32).)
Protected method | DoSetNorm | (Overrides IndexReader DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader DoUndeleteAll .)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Public method | FieldInfos
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Flush
(Inherited from IndexReader.)
Public method | Flush(IDictionary String, String ) | (Inherited from IndexReader.)
Get(Boolean, SegmentInfo, Int32)
Get(Boolean, Directory, SegmentInfo, Int32, Boolean, Int32)
Public method | GetFieldNames | (Overrides IndexReader GetFieldNames(IndexReader FieldOption).)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Protected method | GetNorms
GetOnlySegmentReader(Directory) Obsolete.
Lotsa tests did hacks like:
SegmentReader reader = (SegmentReader) IndexReader.open(dir);
They broke. This method serves as a hack to keep hacks working We do it with R/W access for the tests (BW compatibility)
GetOnlySegmentReader(IndexReader)
Public method GetSequentialSubReaders
Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers).

NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through Open(Directory, Boolean). Use the parent reader directly.
(Inherited from IndexReader.)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, TermVectorMapper).)
Public method GetTermFreqVector(Int32, String)
Return a term frequency vector for the specified document and field. The vector returned contains term numbers and frequencies for all terms in the specified field of this document, if the field had storeTermVector flag set. If the flag was not set, the method returns null.
(Overrides IndexReader GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method GetTermFreqVectors
Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null.
(Overrides IndexReader GetTermFreqVectors(Int32).)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method | HasNorms | (Overrides IndexReader HasNorms(String).)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding DecRef , in a finally clause; otherwise the reader may never be closed. Note that Close simply calls decRef(), which means that the IndexReader will not really be closed until DecRef has been called for all outstanding references.
(Inherited from IndexReader.)
Public method IsCurrent
Check whether any new changes have occurred to the index since this reader was opened.

If this reader is based on a Directory (ie, was created by calling Open(Store.Directory) , or Reopen on a reader based on a Directory), then this method checks if any further commits (see Commit have occurred in that directory).

If instead this reader is a near real-time reader (ie, obtained by a call to GetReader , or by calling Reopen on a near real-time reader), then this method checks if either a new commmit has occurred, or any new uncommitted changes have taken place via the writer. Note that even if the writer has only performed merging, this method will still return false.

In any event, if this returns false, you should call Reopen to get a new reader that sees the changes.

(Inherited from IndexReader.)
Public method | IsDeleted | (Overrides IndexReader IsDeleted(Int32).)
Public method IsOptimized
Checks is the index is optimized (if it has a single segment and no deletions). Not implemented in the IndexReader base class.
(Inherited from IndexReader.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method | Norms(String) | (Overrides IndexReader Norms(String).)
Public method Norms(String, Byte , Int32)
Read norms into a pre-allocated array.
(Overrides IndexReader Norms(String, Byte , Int32).)
Public method | NormsClosed
Public method | NormsClosed(String)
Public method | NumDocs | (Overrides IndexReader NumDocs .)
Public method Reopen
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:
View Colorized Copy to Clipboard Print
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from GetReader , reopen() will simply call writer.getReader() again for you, though this may change in the future.
(Inherited from IndexReader.)
Public method Reopen(Boolean)
Just like Reopen , except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method | TermDocs | (Overrides IndexReader TermDocs .)
Public method | TermDocs(Term) | (Overrides IndexReader TermDocs(Term).)
Public method | TermPositions | (Overrides IndexReader TermPositions .)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.
(Inherited from IndexReader.)
Public method | Terms | (Overrides IndexReader Terms .)
Public method | Terms(Term) | (Overrides IndexReader Terms(Term).)
Public method | TermsIndexLoaded
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)
Back to Top
Fields
 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | readOnly |
Back to Top
Properties
 | Name | Description
Public property | CommitUserData | Retrieve the String userData optionally passed to Commit(IDictionary String, String ). This will return null if Commit(IDictionary String, String ) has never been called for this index. (Inherited from IndexReader.)
Public property | core_ForNUnit |
Public property | deletedDocs_ForNUnit |
Public property | deletedDocsRef_ForNUnit |
Public property | DeletesCacheKey | (Overrides IndexReader DeletesCacheKey.)
Public property | FieldCacheKey | (Overrides IndexReader FieldCacheKey.)
Public property | HasDeletions | (Overrides IndexReader HasDeletions.)
Public property | IndexCommit | Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: this API is new and experimental and may suddenly change. (Inherited from IndexReader.)
Public property | Item | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public property | MaxDoc | (Overrides IndexReader MaxDoc.)
Public property | norms_ForNUnit |
Public property | NumDeletedDocs | Returns the number of deleted documents. (Inherited from IndexReader.)
Public property | RefCount | Expert: returns the current refCount for this reader (Inherited from IndexReader.)
Public property | SegmentName | Return the name of the segment this reader is reading.
Public property | TermInfosIndexDivisor | (Overrides IndexReader TermInfosIndexDivisor.)
Public property | UniqueTermCount | (Overrides IndexReader UniqueTermCount.)
Public property | Version | Version number when this IndexReader was opened. Not implemented in the IndexReader base class. If this reader is based on a Directory (ie, was created by calling Open(Directory, Boolean), or Reopen on a reader based on a Directory), then this method returns the version recorded in the commit that the reader opened. This version is advanced every time Commit is called. If instead this reader is a near real-time reader (ie, obtained by a call to GetReader , or by calling Reopen on a near real-time reader), then this method returns the version of the last commit done by the writer. Note that even as further changes are made with the writer, the version will not changed until a commit is completed. Thus, you should not rely on this method to determine when a near real-time reader should be opened. Use IsCurrent instead. (Inherited from IndexReader.)
Back to Top
See Also
SegmentReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader Constructor

SegmentReader Constructor Lucene.Net Class Library
Initializes a new instance of the SegmentReader class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SegmentReader()
public SegmentReader()
Public Sub New
Public Sub New
public:
SegmentReader()
public:
SegmentReader()
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader Fields

SegmentReader Fields Lucene.Net Class Library
The SegmentReader type exposes the following members.
Fields
 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | readOnly |
Back to Top
See Also
SegmentReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


readOnly Field

SegmentReader readOnly Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool readOnly
protected bool readOnly
Protected readOnly As Boolean
Protected readOnly As Boolean
protected:
bool readOnly
protected:
bool readOnly
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader Methods

SegmentReader Methods Lucene.Net Class Library
The SegmentReader type exposes the following members.
Methods
Name | Description
Protected method AcquireWriteLock
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
(Inherited from IndexReader.)
Public method | Clone | (Overrides IndexReader Clone .)
Public method | Clone(Boolean) | (Overrides IndexReader Clone(Boolean).)
Protected method CloneDeletedDocs
Clones the deleteDocs BitVector. May be overridden by subclasses. New and experimental.
Protected method CloneNormBytes
Clones the norm bytes. May be overridden by subclasses. New and experimental.
Public method | Close | Obsolete. (Inherited from IndexReader.)
Public method Commit
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary String, String )
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered docNum. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the Document(Int32) method will result in an error. The presence of this document may still be reflected in the DocFreq(Term) statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given term indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See DeleteDocument(Int32) for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method Directory
Returns the directory this index resides in.
(Overrides IndexReader Directory .)
Public method Dispose
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Protected method | Dispose(Boolean) | (Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader DoClose .)
Protected method | DoCommit | (Overrides IndexReader DoCommit(IDictionary String, String ).)
Public method Document(Int32)
Returns the stored fields of the nthDocument in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted.
(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader DoDelete(Int32).)
Protected method | DoSetNorm | (Overrides IndexReader DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader DoUndeleteAll .)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Public method | FieldInfos
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Flush
(Inherited from IndexReader.)
Public method | Flush(IDictionary String, String ) | (Inherited from IndexReader.)
Get(Boolean, SegmentInfo, Int32)
Get(Boolean, Directory, SegmentInfo, Int32, Boolean, Int32)
Public method | GetFieldNames | (Overrides IndexReader GetFieldNames(IndexReader FieldOption).)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Protected method | GetNorms
GetOnlySegmentReader(Directory) Obsolete.
Lotsa tests did hacks like:
SegmentReader reader = (SegmentReader) IndexReader.open(dir);
They broke. This method serves as a hack to keep hacks working We do it with R/W access for the tests (BW compatibility)
GetOnlySegmentReader(IndexReader)
Public method GetSequentialSubReaders
Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers).

NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through Open(Directory, Boolean). Use the parent reader directly.
(Inherited from IndexReader.)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, TermVectorMapper).)
Public method GetTermFreqVector(Int32, String)
Return a term frequency vector for the specified document and field. The vector returned contains term numbers and frequencies for all terms in the specified field of this document, if the field had storeTermVector flag set. If the flag was not set, the method returns null.
(Overrides IndexReader GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method GetTermFreqVectors
Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null.
(Overrides IndexReader GetTermFreqVectors(Int32).)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method | HasNorms | (Overrides IndexReader HasNorms(String).)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding DecRef , in a finally clause; otherwise the reader may never be closed. Note that Close simply calls decRef(), which means that the IndexReader will not really be closed until DecRef has been called for all outstanding references.
(Inherited from IndexReader.)
Public method IsCurrent
Check whether any new changes have occurred to the index since this reader was opened.

If this reader is based on a Directory (ie, was created by calling Open(Store.Directory) , or Reopen on a reader based on a Directory), then this method checks if any further commits (see Commit have occurred in that directory).

If instead this reader is a near real-time reader (ie, obtained by a call to GetReader , or by calling Reopen on a near real-time reader), then this method checks if either a new commmit has occurred, or any new uncommitted changes have taken place via the writer. Note that even if the writer has only performed merging, this method will still return false.

In any event, if this returns false, you should call Reopen to get a new reader that sees the changes.

(Inherited from IndexReader.)
Public method | IsDeleted | (Overrides IndexReader IsDeleted(Int32).)
Public method IsOptimized
Checks is the index is optimized (if it has a single segment and no deletions). Not implemented in the IndexReader base class.
(Inherited from IndexReader.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method | Norms(String) | (Overrides IndexReader Norms(String).)
Public method Norms(String, Byte , Int32)
Read norms into a pre-allocated array.
(Overrides IndexReader Norms(String, Byte , Int32).)
Public method | NormsClosed
Public method | NormsClosed(String)
Public method | NumDocs | (Overrides IndexReader NumDocs .)
Public method Reopen
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:
View Colorized Copy to Clipboard Print
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
IndexReader reader = ...
...
IndexReader newReader = r.reopen();
if (newReader != reader) {
...     // reader was reopened
reader.close();
}
reader = newReader;
...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from GetReader , reopen() will simply call writer.getReader() again for you, though this may change in the future.
(Inherited from IndexReader.)
Public method Reopen(Boolean)
Just like Reopen , except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's boost and its length normalization. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method | TermDocs | (Overrides IndexReader TermDocs .)
Public method | TermDocs(Term) | (Overrides IndexReader TermDocs(Term).)
Public method | TermPositions | (Overrides IndexReader TermPositions .)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.
(Inherited from IndexReader.)
Public method | Terms | (Overrides IndexReader Terms .)
Public method | Terms(Term) | (Overrides IndexReader Terms(Term).)
Public method | TermsIndexLoaded
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)
Back to Top
See Also
SegmentReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

SegmentReader Clone Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Clone | (Overrides IndexReader Clone .)
Public method | Clone(Boolean) | (Overrides IndexReader Clone(Boolean).)
Back to Top
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

SegmentReader Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
See Also
SegmentReader Class
SegmentReader Members
Clone Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method (Boolean)

SegmentReader Clone Method (Boolean) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexReader Clone(
    bool openReadOnly
)
public override IndexReader Clone(
    bool openReadOnly
)
Public Overrides Function Clone ( _
    openReadOnly As Boolean _
) As IndexReader
Public Overrides Function Clone ( _
    openReadOnly As Boolean _
) As IndexReader
public:
virtual IndexReader^ Clone(
    bool openReadOnly
) override
public:
virtual IndexReader^ Clone(
    bool openReadOnly
) override
Parameters
openReadOnly
Type:   Online System Boolean
See Also
SegmentReader Class
SegmentReader Members
Clone Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CloneDeletedDocs Method

SegmentReader CloneDeletedDocs Method Lucene.Net Class Library
Clones the deleteDocs BitVector. May be overridden by subclasses. New and experimental.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual BitVector CloneDeletedDocs(
    BitVector bv
)
protected virtual BitVector CloneDeletedDocs(
    BitVector bv
)
Protected Overridable Function CloneDeletedDocs ( _
    bv As BitVector _
) As BitVector
Protected Overridable Function CloneDeletedDocs ( _
    bv As BitVector _
) As BitVector
protected:
virtual BitVector^ CloneDeletedDocs(
    BitVector^ bv
)
protected:
virtual BitVector^ CloneDeletedDocs(
    BitVector^ bv
)
Parameters
bv
Type: Lucene.Net.Util BitVector
BitVector to clone

Return Value
 New BitVector

See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CloneNormBytes Method

SegmentReader CloneNormBytes Method Lucene.Net Class Library
Clones the norm bytes. May be overridden by subclasses. New and experimental.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual byte[] CloneNormBytes(
    byte[] bytes
)
protected virtual byte[] CloneNormBytes(
    byte[] bytes
)
Protected Overridable Function CloneNormBytes ( _
    bytes As Byte() _
) As Byte()
Protected Overridable Function CloneNormBytes ( _
    bytes As Byte() _
) As Byte()
protected:
virtual array<unsigned char>^ CloneNormBytes(
    array<unsigned char>^ bytes
)
protected:
virtual array<unsigned char>^ CloneNormBytes(
    array<unsigned char>^ bytes
)
Parameters
bytes
Type:    Online System Byte
Byte array to clone

Return Value
 New BitVector

See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Directory Method

SegmentReader Directory Method Lucene.Net Class Library
Returns the directory this index resides in.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Directory Directory()
public override Directory Directory()
Public Overrides Function Directory As Directory
Public Overrides Function Directory As Directory
public:
virtual Directory^ Directory() override
public:
virtual Directory^ Directory() override
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocFreq Method

SegmentReader DocFreq Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocFreq(
    Term t
)
public override int DocFreq(
    Term t
)
Public Overrides Function DocFreq ( _
    t As Term _
) As Integer
Public Overrides Function DocFreq ( _
    t As Term _
) As Integer
public:
virtual int DocFreq(
    Term^ t
) override
public:
virtual int DocFreq(
    Term^ t
) override
Parameters
t
Type: Lucene.Net.Index Term
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoClose Method

SegmentReader DoClose Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoClose()
protected override void DoClose()
Protected Overrides Sub DoClose
Protected Overrides Sub DoClose
protected:
virtual void DoClose() override
protected:
virtual void DoClose() override
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoCommit Method

SegmentReader DoCommit Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoCommit(
    IDictionary<string, string> commitUserData
)
protected override void DoCommit(
    IDictionary<string, string> commitUserData
)
Protected Overrides Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
Protected Overrides Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
protected:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
) override
protected:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
) override
Parameters
commitUserData
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Method

SegmentReader Document Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Document(Int32) | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader Document(Int32, FieldSelector).)
Back to Top
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Document Method (Int32, FieldSelector)

SegmentReader Document Method (Int32, FieldSelector) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Document Document(
    int n,
    FieldSelector fieldSelector
)
public override Document Document(
    int n,
    FieldSelector fieldSelector
)
Public Overrides Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Public Overrides Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) override
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) override
Parameters
n
Type:   Online System Int32
fieldSelector
Type: Lucene.Net.Documents FieldSelector
See Also
SegmentReader Class
SegmentReader Members
Document Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoDelete Method

SegmentReader DoDelete Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoDelete(
    int docNum
)
protected override void DoDelete(
    int docNum
)
Protected Overrides Sub DoDelete ( _
    docNum As Integer _
)
Protected Overrides Sub DoDelete ( _
    docNum As Integer _
)
protected:
virtual void DoDelete(
    int docNum
) override
protected:
virtual void DoDelete(
    int docNum
) override
Parameters
docNum
Type:   Online System Int32
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoSetNorm Method

SegmentReader DoSetNorm Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSetNorm(
    int doc,
    string field,
    byte value_Renamed
)
protected override void DoSetNorm(
    int doc,
    string field,
    byte value_Renamed
)
Protected Overrides Sub DoSetNorm ( _
    doc As Integer, _
    field As String, _
    value_Renamed As Byte _
)
Protected Overrides Sub DoSetNorm ( _
    doc As Integer, _
    field As String, _
    value_Renamed As Byte _
)
protected:
virtual void DoSetNorm(
    int doc,
    String^ field,
    unsigned char value_Renamed
) override
protected:
virtual void DoSetNorm(
    int doc,
    String^ field,
    unsigned char value_Renamed
) override
Parameters
doc
Type:   Online System Int32
field
Type:   Online System String
value_Renamed
Type:   Online System Byte
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoUndeleteAll Method

SegmentReader DoUndeleteAll Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoUndeleteAll()
protected override void DoUndeleteAll()
Protected Overrides Sub DoUndeleteAll
Protected Overrides Sub DoUndeleteAll
protected:
virtual void DoUndeleteAll() override
protected:
virtual void DoUndeleteAll() override
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldInfos Method

SegmentReader FieldInfos Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual FieldInfos FieldInfos()
public virtual FieldInfos FieldInfos()
Public Overridable Function FieldInfos As FieldInfos
Public Overridable Function FieldInfos As FieldInfos
public:
virtual FieldInfos^ FieldInfos()
public:
virtual FieldInfos^ FieldInfos()
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method

SegmentReader Get Method Lucene.Net Class Library
Overload List
Name | Description
Get(Boolean, SegmentInfo, Int32) |
Get(Boolean, Directory, SegmentInfo, Int32, Boolean, Int32) |
Back to Top
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method (Boolean, SegmentInfo, Int32)

SegmentReader Get Method (Boolean, SegmentInfo, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static SegmentReader Get(
    bool readOnly,
    SegmentInfo si,
    int termInfosIndexDivisor
)
public static SegmentReader Get(
    bool readOnly,
    SegmentInfo si,
    int termInfosIndexDivisor
)
Public Shared Function Get ( _
    readOnly As Boolean, _
    si As SegmentInfo, _
    termInfosIndexDivisor As Integer _
) As SegmentReader
Public Shared Function Get ( _
    readOnly As Boolean, _
    si As SegmentInfo, _
    termInfosIndexDivisor As Integer _
) As SegmentReader
public:
static SegmentReader^ Get(
    bool readOnly,
    SegmentInfo^ si,
    int termInfosIndexDivisor
)
public:
static SegmentReader^ Get(
    bool readOnly,
    SegmentInfo^ si,
    int termInfosIndexDivisor
)
Parameters
readOnly
Type:   Online System Boolean
si
Type: Lucene.Net.Index SegmentInfo
termInfosIndexDivisor
Type:   Online System Int32
See Also
SegmentReader Class
SegmentReader Members
Get Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method (Boolean, Directory, SegmentInfo, Int32, Boolean, Int32)

SegmentReader Get Method (Boolean, Directory, SegmentInfo, Int32, Boolean, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static SegmentReader Get(
    bool readOnly,
    Directory dir,
    SegmentInfo si,
    int readBufferSize,
    bool doOpenStores,
    int termInfosIndexDivisor
)
public static SegmentReader Get(
    bool readOnly,
    Directory dir,
    SegmentInfo si,
    int readBufferSize,
    bool doOpenStores,
    int termInfosIndexDivisor
)
Public Shared Function Get ( _
    readOnly As Boolean, _
    dir As Directory, _
    si As SegmentInfo, _
    readBufferSize As Integer, _
    doOpenStores As Boolean, _
    termInfosIndexDivisor As Integer _
) As SegmentReader
Public Shared Function Get ( _
    readOnly As Boolean, _
    dir As Directory, _
    si As SegmentInfo, _
    readBufferSize As Integer, _
    doOpenStores As Boolean, _
    termInfosIndexDivisor As Integer _
) As SegmentReader
public:
static SegmentReader^ Get(
    bool readOnly,
    Directory^ dir,
    SegmentInfo^ si,
    int readBufferSize,
    bool doOpenStores,
    int termInfosIndexDivisor
)
public:
static SegmentReader^ Get(
    bool readOnly,
    Directory^ dir,
    SegmentInfo^ si,
    int readBufferSize,
    bool doOpenStores,
    int termInfosIndexDivisor
)
Parameters
readOnly
Type:   Online System Boolean
dir
Type: Lucene.Net.Store Directory
si
Type: Lucene.Net.Index SegmentInfo
readBufferSize
Type:   Online System Int32
doOpenStores
Type:   Online System Boolean
termInfosIndexDivisor
Type:   Online System Int32
See Also
SegmentReader Class
SegmentReader Members
Get Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFieldNames Method

SegmentReader GetFieldNames Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fieldOption
)
public override ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fieldOption
)
Public Overrides Function GetFieldNames ( _
    fieldOption As IndexReader..::..FieldOption _
) As ICollection(Of String)
Public Overrides Function GetFieldNames ( _
    fieldOption As IndexReader..::..FieldOption _
) As ICollection(Of String)
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fieldOption
) override
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fieldOption
) override
Parameters
fieldOption
Type: Lucene.Net.Index IndexReader FieldOption
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
IndexReader GetFieldNames(IndexReader FieldOption)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetNorms Method

SegmentReader GetNorms Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual byte[] GetNorms(
    string field
)
protected virtual byte[] GetNorms(
    string field
)
Protected Overridable Function GetNorms ( _
    field As String _
) As Byte()
Protected Overridable Function GetNorms ( _
    field As String _
) As Byte()
protected:
virtual array<unsigned char>^ GetNorms(
    String^ field
)
protected:
virtual array<unsigned char>^ GetNorms(
    String^ field
)
Parameters
field
Type:   Online System String
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetOnlySegmentReader Method

SegmentReader GetOnlySegmentReader Method Lucene.Net Class Library
Overload List
Name | Description
GetOnlySegmentReader(Directory) | Obsolete. Lotsa tests did hacks like: SegmentReader reader = (SegmentReader) IndexReader.open(dir); They broke. This method serves as a hack to keep hacks working We do it with R/W access for the tests (BW compatibility)
GetOnlySegmentReader(IndexReader) |
Back to Top
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetOnlySegmentReader Method (Directory)

SegmentReader GetOnlySegmentReader Method (Directory) Lucene.Net Class Library
Lotsa tests did hacks like:
SegmentReader reader = (SegmentReader) IndexReader.open(dir);
They broke. This method serves as a hack to keep hacks working We do it with R/W access for the tests (BW compatibility)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Remove this when tests are fixed!")]
public static SegmentReader GetOnlySegmentReader(
    Directory dir
)
[ObsoleteAttribute("Remove this when tests are fixed!")]
public static SegmentReader GetOnlySegmentReader(
    Directory dir
)
<ObsoleteAttribute("Remove this when tests are fixed!")> _
Public Shared Function GetOnlySegmentReader ( _
    dir As Directory _
) As SegmentReader
<ObsoleteAttribute("Remove this when tests are fixed!")> _
Public Shared Function GetOnlySegmentReader ( _
    dir As Directory _
) As SegmentReader
public:
[ObsoleteAttribute(L"Remove this when tests are fixed!")]
static SegmentReader^ GetOnlySegmentReader(
    Directory^ dir
)
public:
[ObsoleteAttribute(L"Remove this when tests are fixed!")]
static SegmentReader^ GetOnlySegmentReader(
    Directory^ dir
)
Parameters
dir
Type: Lucene.Net.Store Directory
See Also
SegmentReader Class
SegmentReader Members
GetOnlySegmentReader Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetOnlySegmentReader Method (IndexReader)

SegmentReader GetOnlySegmentReader Method (IndexReader) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static SegmentReader GetOnlySegmentReader(
    IndexReader reader
)
public static SegmentReader GetOnlySegmentReader(
    IndexReader reader
)
Public Shared Function GetOnlySegmentReader ( _
    reader As IndexReader _
) As SegmentReader
Public Shared Function GetOnlySegmentReader ( _
    reader As IndexReader _
) As SegmentReader
public:
static SegmentReader^ GetOnlySegmentReader(
    IndexReader^ reader
)
public:
static SegmentReader^ GetOnlySegmentReader(
    IndexReader^ reader
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
SegmentReader Class
SegmentReader Members
GetOnlySegmentReader Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method

SegmentReader GetTermFreqVector Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | Return a term frequency vector for the specified document and field. The vector returned contains term numbers and frequencies for all terms in the specified field of this document, if the field had storeTermVector flag set. If the flag was not set, the method returns null. (Overrides IndexReader GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader GetTermFreqVector(Int32, String, TermVectorMapper).)
Back to Top
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, TermVectorMapper)

SegmentReader GetTermFreqVector Method (Int32, TermVectorMapper) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
public override void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) override
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) override
Parameters
docNumber
Type:   Online System Int32
mapper
Type: Lucene.Net.Index TermVectorMapper
See Also
SegmentReader Class
SegmentReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, String)

SegmentReader GetTermFreqVector Method (Int32, String) Lucene.Net Class Library
Return a term frequency vector for the specified document and field. The vector returned contains term numbers and frequencies for all terms in the specified field of this document, if the field had storeTermVector flag set. If the flag was not set, the method returns null.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ITermFreqVector GetTermFreqVector(
    int docNumber,
    string field
)
public override ITermFreqVector GetTermFreqVector(
    int docNumber,
    string field
)
Public Overrides Function GetTermFreqVector ( _
    docNumber As Integer, _
    field As String _
) As ITermFreqVector
Public Overrides Function GetTermFreqVector ( _
    docNumber As Integer, _
    field As String _
) As ITermFreqVector
public:
virtual ITermFreqVector^ GetTermFreqVector(
    int docNumber,
    String^ field
) override
public:
virtual ITermFreqVector^ GetTermFreqVector(
    int docNumber,
    String^ field
) override
Parameters
docNumber
Type:   Online System Int32
field
Type:   Online System String
See Also
SegmentReader Class
SegmentReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVector Method (Int32, String, TermVectorMapper)

SegmentReader GetTermFreqVector Method (Int32, String, TermVectorMapper) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
public override void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) override
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) override
Parameters
docNumber
Type:   Online System Int32
field
Type:   Online System String
mapper
Type: Lucene.Net.Index TermVectorMapper
See Also
SegmentReader Class
SegmentReader Members
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFreqVectors Method

SegmentReader GetTermFreqVectors Method Lucene.Net Class Library
Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ITermFreqVector[] GetTermFreqVectors(
    int docNumber
)
public override ITermFreqVector[] GetTermFreqVectors(
    int docNumber
)
Public Overrides Function GetTermFreqVectors ( _
    docNumber As Integer _
) As ITermFreqVector()
Public Overrides Function GetTermFreqVectors ( _
    docNumber As Integer _
) As ITermFreqVector()
public:
virtual array<ITermFreqVector^>^ GetTermFreqVectors(
    int docNumber
) override
public:
virtual array<ITermFreqVector^>^ GetTermFreqVectors(
    int docNumber
) override
Parameters
docNumber
Type:   Online System Int32
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasNorms Method

SegmentReader HasNorms Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool HasNorms(
    string field
)
public override bool HasNorms(
    string field
)
Public Overrides Function HasNorms ( _
    field As String _
) As Boolean
Public Overrides Function HasNorms ( _
    field As String _
) As Boolean
public:
virtual bool HasNorms(
    String^ field
) override
public:
virtual bool HasNorms(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsDeleted Method

SegmentReader IsDeleted Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsDeleted(
    int n
)
public override bool IsDeleted(
    int n
)
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
public:
virtual bool IsDeleted(
    int n
) override
public:
virtual bool IsDeleted(
    int n
) override
Parameters
n
Type:   Online System Int32
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method

SegmentReader Norms Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Norms(String) | (Overrides IndexReader Norms(String).)
Public method | Norms(String, Byte , Int32) | Read norms into a pre-allocated array. (Overrides IndexReader Norms(String, Byte , Int32).)
Back to Top
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method (String)

SegmentReader Norms Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override byte[] Norms(
    string field
)
public override byte[] Norms(
    string field
)
Public Overrides Function Norms ( _
    field As String _
) As Byte()
Public Overrides Function Norms ( _
    field As String _
) As Byte()
public:
virtual array<unsigned char>^ Norms(
    String^ field
) override
public:
virtual array<unsigned char>^ Norms(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
SegmentReader Class
SegmentReader Members
Norms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Norms Method (String, Byte[], Int32)

SegmentReader Norms Method (String, Byte , Int32) Lucene.Net Class Library
Read norms into a pre-allocated array.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Norms(
    string field,
    byte[] bytes,
    int offset
)
public override void Norms(
    string field,
    byte[] bytes,
    int offset
)
Public Overrides Sub Norms ( _
    field As String, _
    bytes As Byte(), _
    offset As Integer _
)
Public Overrides Sub Norms ( _
    field As String, _
    bytes As Byte(), _
    offset As Integer _
)
public:
virtual void Norms(
    String^ field,
    array<unsigned char>^ bytes,
    int offset
) override
public:
virtual void Norms(
    String^ field,
    array<unsigned char>^ bytes,
    int offset
) override
Parameters
field
Type:   Online System String
bytes
Type:    Online System Byte
offset
Type:   Online System Int32
See Also
SegmentReader Class
SegmentReader Members
Norms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NormsClosed Method

SegmentReader NormsClosed Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | NormsClosed |
Public method | NormsClosed(String) |
Back to Top
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NormsClosed Method

SegmentReader NormsClosed Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool NormsClosed()
public virtual bool NormsClosed()
Public Overridable Function NormsClosed As Boolean
Public Overridable Function NormsClosed As Boolean
public:
virtual bool NormsClosed()
public:
virtual bool NormsClosed()
See Also
SegmentReader Class
SegmentReader Members
NormsClosed Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NormsClosed Method (String)

SegmentReader NormsClosed Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool NormsClosed(
    string field
)
public virtual bool NormsClosed(
    string field
)
Public Overridable Function NormsClosed ( _
    field As String _
) As Boolean
Public Overridable Function NormsClosed ( _
    field As String _
) As Boolean
public:
virtual bool NormsClosed(
    String^ field
)
public:
virtual bool NormsClosed(
    String^ field
)
Parameters
field
Type:   Online System String
See Also
SegmentReader Class
SegmentReader Members
NormsClosed Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumDocs Method

SegmentReader NumDocs Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int NumDocs()
public override int NumDocs()
Public Overrides Function NumDocs As Integer
Public Overrides Function NumDocs As Integer
public:
virtual int NumDocs() override
public:
virtual int NumDocs() override
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Method

SegmentReader TermDocs Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TermDocs | (Overrides IndexReader TermDocs .)
Public method | TermDocs(Term) | (Overrides IndexReader TermDocs(Term).)
Back to Top
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Method

SegmentReader TermDocs Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermDocs TermDocs()
public override TermDocs TermDocs()
Public Overrides Function TermDocs As TermDocs
Public Overrides Function TermDocs As TermDocs
public:
virtual TermDocs^ TermDocs() override
public:
virtual TermDocs^ TermDocs() override
See Also
SegmentReader Class
SegmentReader Members
TermDocs Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Method (Term)

SegmentReader TermDocs Method (Term) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermDocs TermDocs(
    Term term
)
public override TermDocs TermDocs(
    Term term
)
Public Overrides Function TermDocs ( _
    term As Term _
) As TermDocs
Public Overrides Function TermDocs ( _
    term As Term _
) As TermDocs
public:
virtual TermDocs^ TermDocs(
    Term^ term
) override
public:
virtual TermDocs^ TermDocs(
    Term^ term
) override
Parameters
term
Type: Lucene.Net.Index Term
See Also
SegmentReader Class
SegmentReader Members
TermDocs Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Method

SegmentReader TermPositions Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TermPositions | (Overrides IndexReader TermPositions .)
Public method | TermPositions(Term) | Returns an enumeration of all the documents which contain term. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping: Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >* This positional information facilitates phrase and proximity searching. The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration. (Inherited from IndexReader.)
Back to Top
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Method

SegmentReader TermPositions Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermPositions TermPositions()
public override TermPositions TermPositions()
Public Overrides Function TermPositions As TermPositions
Public Overrides Function TermPositions As TermPositions
public:
virtual TermPositions^ TermPositions() override
public:
virtual TermPositions^ TermPositions() override
See Also
SegmentReader Class
SegmentReader Members
TermPositions Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method

SegmentReader Terms Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Terms | (Overrides IndexReader Terms .)
Public method | Terms(Term) | (Overrides IndexReader Terms(Term).)
Back to Top
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method

SegmentReader Terms Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermEnum Terms()
public override TermEnum Terms()
Public Overrides Function Terms As TermEnum
Public Overrides Function Terms As TermEnum
public:
virtual TermEnum^ Terms() override
public:
virtual TermEnum^ Terms() override
See Also
SegmentReader Class
SegmentReader Members
Terms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Terms Method (Term)

SegmentReader Terms Method (Term) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TermEnum Terms(
    Term t
)
public override TermEnum Terms(
    Term t
)
Public Overrides Function Terms ( _
    t As Term _
) As TermEnum
Public Overrides Function Terms ( _
    t As Term _
) As TermEnum
public:
virtual TermEnum^ Terms(
    Term^ t
) override
public:
virtual TermEnum^ Terms(
    Term^ t
) override
Parameters
t
Type: Lucene.Net.Index Term
See Also
SegmentReader Class
SegmentReader Members
Terms Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermsIndexLoaded Method

SegmentReader TermsIndexLoaded Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool TermsIndexLoaded()
public virtual bool TermsIndexLoaded()
Public Overridable Function TermsIndexLoaded As Boolean
Public Overridable Function TermsIndexLoaded As Boolean
public:
virtual bool TermsIndexLoaded()
public:
virtual bool TermsIndexLoaded()
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader Properties

SegmentReader Properties Lucene.Net Class Library
The SegmentReader type exposes the following members.
Properties
 | Name | Description
Public property | CommitUserData | Retrieve the String userData optionally passed to Commit(IDictionary String, String ). This will return null if Commit(IDictionary String, String ) has never been called for this index. (Inherited from IndexReader.)
Public property | core_ForNUnit |
Public property | deletedDocs_ForNUnit |
Public property | deletedDocsRef_ForNUnit |
Public property | DeletesCacheKey | (Overrides IndexReader DeletesCacheKey.)
Public property | FieldCacheKey | (Overrides IndexReader FieldCacheKey.)
Public property | HasDeletions | (Overrides IndexReader HasDeletions.)
Public property | IndexCommit | Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file. WARNING: this API is new and experimental and may suddenly change. (Inherited from IndexReader.)
Public property | Item | Returns the stored fields of the nthDocument in this index. NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call IsDeleted(Int32) with the requested document ID to verify the document is not deleted. (Inherited from IndexReader.)
Public property | MaxDoc | (Overrides IndexReader MaxDoc.)
Public property | norms_ForNUnit |
Public property | NumDeletedDocs | Returns the number of deleted documents. (Inherited from IndexReader.)
Public property | RefCount | Expert: returns the current refCount for this reader (Inherited from IndexReader.)
Public property | SegmentName | Return the name of the segment this reader is reading.
Public property | TermInfosIndexDivisor | (Overrides IndexReader TermInfosIndexDivisor.)
Public property | UniqueTermCount | (Overrides IndexReader UniqueTermCount.)
Public property | Version | Version number when this IndexReader was opened. Not implemented in the IndexReader base class. If this reader is based on a Directory (ie, was created by calling Open(Directory, Boolean), or Reopen on a reader based on a Directory), then this method returns the version recorded in the commit that the reader opened. This version is advanced every time Commit is called. If instead this reader is a near real-time reader (ie, obtained by a call to GetReader , or by calling Reopen on a near real-time reader), then this method returns the version of the last commit done by the writer. Note that even as further changes are made with the writer, the version will not changed until a commit is completed. Thus, you should not rely on this method to determine when a near real-time reader should be opened. Use IsCurrent instead. (Inherited from IndexReader.)
Back to Top
See Also
SegmentReader Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


core_ForNUnit Property

SegmentReader core_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SegmentReader..::..CoreReaders core_ForNUnit { get; }
public SegmentReader..::..CoreReaders core_ForNUnit { get; }
Public ReadOnly Property core_ForNUnit As SegmentReader..::..CoreReaders
    Get
Public ReadOnly Property core_ForNUnit As SegmentReader..::..CoreReaders
    Get
public:
property SegmentReader..::..CoreReaders^ core_ForNUnit {
    SegmentReader..::..CoreReaders^ get ();
}
public:
property SegmentReader..::..CoreReaders^ core_ForNUnit {
    SegmentReader..::..CoreReaders^ get ();
}
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


deletedDocs_ForNUnit Property

SegmentReader deletedDocs_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BitVector deletedDocs_ForNUnit { get; }
public BitVector deletedDocs_ForNUnit { get; }
Public ReadOnly Property deletedDocs_ForNUnit As BitVector
    Get
Public ReadOnly Property deletedDocs_ForNUnit As BitVector
    Get
public:
property BitVector^ deletedDocs_ForNUnit {
    BitVector^ get ();
}
public:
property BitVector^ deletedDocs_ForNUnit {
    BitVector^ get ();
}
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


deletedDocsRef_ForNUnit Property

SegmentReader deletedDocsRef_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SegmentReader..::..Ref deletedDocsRef_ForNUnit { get; }
public SegmentReader..::..Ref deletedDocsRef_ForNUnit { get; }
Public ReadOnly Property deletedDocsRef_ForNUnit As SegmentReader..::..Ref
    Get
Public ReadOnly Property deletedDocsRef_ForNUnit As SegmentReader..::..Ref
    Get
public:
property SegmentReader..::..Ref^ deletedDocsRef_ForNUnit {
    SegmentReader..::..Ref^ get ();
}
public:
property SegmentReader..::..Ref^ deletedDocsRef_ForNUnit {
    SegmentReader..::..Ref^ get ();
}
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DeletesCacheKey Property

SegmentReader DeletesCacheKey Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object DeletesCacheKey { get; }
public override Object DeletesCacheKey { get; }
Public Overrides ReadOnly Property DeletesCacheKey As Object
    Get
Public Overrides ReadOnly Property DeletesCacheKey As Object
    Get
public:
virtual property Object^ DeletesCacheKey {
    Object^ get () override;
}
public:
virtual property Object^ DeletesCacheKey {
    Object^ get () override;
}
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheKey Property

SegmentReader FieldCacheKey Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object FieldCacheKey { get; }
public override Object FieldCacheKey { get; }
Public Overrides ReadOnly Property FieldCacheKey As Object
    Get
Public Overrides ReadOnly Property FieldCacheKey As Object
    Get
public:
virtual property Object^ FieldCacheKey {
    Object^ get () override;
}
public:
virtual property Object^ FieldCacheKey {
    Object^ get () override;
}
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasDeletions Property

SegmentReader HasDeletions Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool HasDeletions { get; }
public override bool HasDeletions { get; }
Public Overrides ReadOnly Property HasDeletions As Boolean
    Get
Public Overrides ReadOnly Property HasDeletions As Boolean
    Get
public:
virtual property bool HasDeletions {
    bool get () override;
}
public:
virtual property bool HasDeletions {
    bool get () override;
}
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxDoc Property

SegmentReader MaxDoc Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int MaxDoc { get; }
public override int MaxDoc { get; }
Public Overrides ReadOnly Property MaxDoc As Integer
    Get
Public Overrides ReadOnly Property MaxDoc As Integer
    Get
public:
virtual property int MaxDoc {
    int get () override;
}
public:
virtual property int MaxDoc {
    int get () override;
}
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


norms_ForNUnit Property

SegmentReader norms_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, SegmentReader..::..Norm> norms_ForNUnit { get; }
public IDictionary<string, SegmentReader..::..Norm> norms_ForNUnit { get; }
Public ReadOnly Property norms_ForNUnit As IDictionary(Of String, SegmentReader..::..Norm)
    Get
Public ReadOnly Property norms_ForNUnit As IDictionary(Of String, SegmentReader..::..Norm)
    Get
public:
property IDictionary<String^, SegmentReader..::..Norm^>^ norms_ForNUnit {
    IDictionary<String^, SegmentReader..::..Norm^>^ get ();
}
public:
property IDictionary<String^, SegmentReader..::..Norm^>^ norms_ForNUnit {
    IDictionary<String^, SegmentReader..::..Norm^>^ get ();
}
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentName Property

SegmentReader SegmentName Property Lucene.Net Class Library
Return the name of the segment this reader is reading.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string SegmentName { get; }
public virtual string SegmentName { get; }
Public Overridable ReadOnly Property SegmentName As String
    Get
Public Overridable ReadOnly Property SegmentName As String
    Get
public:
virtual property String^ SegmentName {
    String^ get ();
}
public:
virtual property String^ SegmentName {
    String^ get ();
}
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermInfosIndexDivisor Property

SegmentReader TermInfosIndexDivisor Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int TermInfosIndexDivisor { get; }
public override int TermInfosIndexDivisor { get; }
Public Overrides ReadOnly Property TermInfosIndexDivisor As Integer
    Get
Public Overrides ReadOnly Property TermInfosIndexDivisor As Integer
    Get
public:
virtual property int TermInfosIndexDivisor {
    int get () override;
}
public:
virtual property int TermInfosIndexDivisor {
    int get () override;
}
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UniqueTermCount Property

SegmentReader UniqueTermCount Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long UniqueTermCount { get; }
public override long UniqueTermCount { get; }
Public Overrides ReadOnly Property UniqueTermCount As Long
    Get
Public Overrides ReadOnly Property UniqueTermCount As Long
    Get
public:
virtual property long long UniqueTermCount {
    long long get () override;
}
public:
virtual property long long UniqueTermCount {
    long long get () override;
}
See Also
SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader.CoreReaders Class

SegmentReader CoreReaders Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Index SegmentReader CoreReaders

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CoreReaders
public sealed class CoreReaders
Public NotInheritable Class CoreReaders
Public NotInheritable Class CoreReaders
public ref class CoreReaders sealed
public ref class CoreReaders sealed
See Also
SegmentReader CoreReaders Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader.CoreReaders Members

SegmentReader CoreReaders Members Lucene.Net Class Library

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

The SegmentReader CoreReaders type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | fieldInfos_ForNUnit |
Back to Top
See Also
SegmentReader CoreReaders Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader.CoreReaders Methods

SegmentReader CoreReaders Methods Lucene.Net Class Library
The SegmentReader CoreReaders type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SegmentReader CoreReaders Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader.CoreReaders Properties

SegmentReader CoreReaders Properties Lucene.Net Class Library
The SegmentReader CoreReaders type exposes the following members.
Properties
 | Name | Description
Public property | fieldInfos_ForNUnit |
Back to Top
See Also
SegmentReader CoreReaders Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


fieldInfos_ForNUnit Property

SegmentReader CoreReaders fieldInfos_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldInfos fieldInfos_ForNUnit { get; }
public FieldInfos fieldInfos_ForNUnit { get; }
Public ReadOnly Property fieldInfos_ForNUnit As FieldInfos
    Get
Public ReadOnly Property fieldInfos_ForNUnit As FieldInfos
    Get
public:
property FieldInfos^ fieldInfos_ForNUnit {
    FieldInfos^ get ();
}
public:
property FieldInfos^ fieldInfos_ForNUnit {
    FieldInfos^ get ();
}
See Also
SegmentReader CoreReaders Class
SegmentReader CoreReaders Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader.Norm Class

SegmentReader Norm Class Lucene.Net Class Library
Byte[] referencing is used because a new norm object needs to be created for each clone, and the byte array is all that is needed for sharing between cloned readers. The current norm referencing is for sharing between readers whereas the byte[] referencing is for copy on write which is independent of reader references (i.e. incRef, decRef).
Inheritance Hierarchy
Online System Object
Lucene.Net.Index SegmentReader Norm

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Norm : ICloneable
public sealed class Norm : ICloneable
Public NotInheritable Class Norm _
    Implements ICloneable
Public NotInheritable Class Norm _
    Implements ICloneable
public ref class Norm sealed : ICloneable
public ref class Norm sealed : ICloneable
See Also
SegmentReader Norm Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader.Norm Members

SegmentReader Norm Members Lucene.Net Class Library

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

The SegmentReader Norm type exposes the following members.
Constructors
 | Name | Description
Public method | SegmentReader Norm | Initializes a new instance of the SegmentReader Norm class
Back to Top
Methods
 | Name | Description
Public method | Bytes |
Public method | Bytes( Byte , Int32, Int32) |
Public method | BytesRef |
Public method | Clone |
Public method | CopyOnWrite |
Public method | DecRef |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IncRef |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReWrite |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Enclosing_Instance |
Back to Top
See Also
SegmentReader Norm Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader.Norm Constructor

SegmentReader Norm Constructor Lucene.Net Class Library
Initializes a new instance of the SegmentReader Norm class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Norm(
    SegmentReader enclosingInstance,
    IndexInput in_Renamed,
    int number,
    long normSeek
)
public Norm(
    SegmentReader enclosingInstance,
    IndexInput in_Renamed,
    int number,
    long normSeek
)
Public Sub New ( _
    enclosingInstance As SegmentReader, _
    in_Renamed As IndexInput, _
    number As Integer, _
    normSeek As Long _
)
Public Sub New ( _
    enclosingInstance As SegmentReader, _
    in_Renamed As IndexInput, _
    number As Integer, _
    normSeek As Long _
)
public:
Norm(
    SegmentReader^ enclosingInstance,
    IndexInput^ in_Renamed,
    int number,
    long long normSeek
)
public:
Norm(
    SegmentReader^ enclosingInstance,
    IndexInput^ in_Renamed,
    int number,
    long long normSeek
)
Parameters
enclosingInstance
Type: Lucene.Net.Index SegmentReader
in_Renamed
Type: Lucene.Net.Store IndexInput
number
Type:   Online System Int32
normSeek
Type:   Online System Int64
See Also
SegmentReader Norm Class
SegmentReader Norm Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader.Norm Methods

SegmentReader Norm Methods Lucene.Net Class Library
The SegmentReader Norm type exposes the following members.
Methods
 | Name | Description
Public method | Bytes |
Public method | Bytes( Byte , Int32, Int32) |
Public method | BytesRef |
Public method | Clone |
Public method | CopyOnWrite |
Public method | DecRef |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IncRef |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReWrite |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SegmentReader Norm Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Bytes Method

SegmentReader Norm Bytes Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Bytes |
Public method | Bytes( Byte , Int32, Int32) |
Back to Top
See Also
SegmentReader Norm Class
SegmentReader Norm Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Bytes Method

SegmentReader Norm Bytes Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] Bytes()
public byte[] Bytes()
Public Function Bytes As Byte()
Public Function Bytes As Byte()
public:
array<unsigned char>^ Bytes()
public:
array<unsigned char>^ Bytes()
See Also
SegmentReader Norm Class
SegmentReader Norm Members
Bytes Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Bytes Method (Byte[], Int32, Int32)

SegmentReader Norm Bytes Method ( Byte , Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Bytes(
    byte[] bytesOut,
    int offset,
    int len
)
public void Bytes(
    byte[] bytesOut,
    int offset,
    int len
)
Public Sub Bytes ( _
    bytesOut As Byte(), _
    offset As Integer, _
    len As Integer _
)
Public Sub Bytes ( _
    bytesOut As Byte(), _
    offset As Integer, _
    len As Integer _
)
public:
void Bytes(
    array<unsigned char>^ bytesOut,
    int offset,
    int len
)
public:
void Bytes(
    array<unsigned char>^ bytesOut,
    int offset,
    int len
)
Parameters
bytesOut
Type:    Online System Byte
offset
Type:   Online System Int32
len
Type:   Online System Int32
See Also
SegmentReader Norm Class
SegmentReader Norm Members
Bytes Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BytesRef Method

SegmentReader Norm BytesRef Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SegmentReader..::..Ref BytesRef()
public SegmentReader..::..Ref BytesRef()
Public Function BytesRef As SegmentReader..::..Ref
Public Function BytesRef As SegmentReader..::..Ref
public:
SegmentReader..::..Ref^ BytesRef()
public:
SegmentReader..::..Ref^ BytesRef()
See Also
SegmentReader Norm Class
SegmentReader Norm Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

SegmentReader Norm Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Clone()
public Object Clone()
Public Function Clone As Object
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
public:
virtual Object^ Clone() sealed
Implements
  Online ICloneable Clone
See Also
SegmentReader Norm Class
SegmentReader Norm Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CopyOnWrite Method

SegmentReader Norm CopyOnWrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] CopyOnWrite()
public byte[] CopyOnWrite()
Public Function CopyOnWrite As Byte()
Public Function CopyOnWrite As Byte()
public:
array<unsigned char>^ CopyOnWrite()
public:
array<unsigned char>^ CopyOnWrite()
See Also
SegmentReader Norm Class
SegmentReader Norm Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DecRef Method

SegmentReader Norm DecRef Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DecRef()
public void DecRef()
Public Sub DecRef
Public Sub DecRef
public:
void DecRef()
public:
void DecRef()
See Also
SegmentReader Norm Class
SegmentReader Norm Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncRef Method

SegmentReader Norm IncRef Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void IncRef()
public void IncRef()
Public Sub IncRef
Public Sub IncRef
public:
void IncRef()
public:
void IncRef()
See Also
SegmentReader Norm Class
SegmentReader Norm Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReWrite Method

SegmentReader Norm ReWrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ReWrite(
    SegmentInfo si
)
public void ReWrite(
    SegmentInfo si
)
Public Sub ReWrite ( _
    si As SegmentInfo _
)
Public Sub ReWrite ( _
    si As SegmentInfo _
)
public:
void ReWrite(
    SegmentInfo^ si
)
public:
void ReWrite(
    SegmentInfo^ si
)
Parameters
si
Type: Lucene.Net.Index SegmentInfo
See Also
SegmentReader Norm Class
SegmentReader Norm Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader.Norm Properties

SegmentReader Norm Properties Lucene.Net Class Library
The SegmentReader Norm type exposes the following members.
Properties
 | Name | Description
Public property | Enclosing_Instance |
Back to Top
See Also
SegmentReader Norm Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Enclosing_Instance Property

SegmentReader Norm Enclosing_Instance Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SegmentReader Enclosing_Instance { get; }
public SegmentReader Enclosing_Instance { get; }
Public ReadOnly Property Enclosing_Instance As SegmentReader
    Get
Public ReadOnly Property Enclosing_Instance As SegmentReader
    Get
public:
property SegmentReader^ Enclosing_Instance {
    SegmentReader^ get ();
}
public:
property SegmentReader^ Enclosing_Instance {
    SegmentReader^ get ();
}
See Also
SegmentReader Norm Class
SegmentReader Norm Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader.Ref Class

SegmentReader Ref Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Index SegmentReader Ref

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Ref
public class Ref
Public Class Ref
Public Class Ref
public ref class Ref
public ref class Ref
See Also
SegmentReader Ref Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader.Ref Members

SegmentReader Ref Members Lucene.Net Class Library

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

The SegmentReader Ref type exposes the following members.
Constructors
 | Name | Description
Public method | SegmentReader Ref | Initializes a new instance of the SegmentReader Ref class
Back to Top
Methods
 | Name | Description
Public method | DecRef |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IncRef |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RefCount |
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
SegmentReader Ref Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader.Ref Constructor

SegmentReader Ref Constructor Lucene.Net Class Library
Initializes a new instance of the SegmentReader Ref class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Ref()
public Ref()
Public Sub New
Public Sub New
public:
Ref()
public:
Ref()
See Also
SegmentReader Ref Class
SegmentReader Ref Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SegmentReader.Ref Methods

SegmentReader Ref Methods Lucene.Net Class Library
The SegmentReader Ref type exposes the following members.
Methods
 | Name | Description
Public method | DecRef |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IncRef |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RefCount |
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
SegmentReader Ref Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DecRef Method

SegmentReader Ref DecRef Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int DecRef()
public virtual int DecRef()
Public Overridable Function DecRef As Integer
Public Overridable Function DecRef As Integer
public:
virtual int DecRef()
public:
virtual int DecRef()
See Also
SegmentReader Ref Class
SegmentReader Ref Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncRef Method

SegmentReader Ref IncRef Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int IncRef()
public virtual int IncRef()
Public Overridable Function IncRef As Integer
Public Overridable Function IncRef As Integer
public:
virtual int IncRef()
public:
virtual int IncRef()
See Also
SegmentReader Ref Class
SegmentReader Ref Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RefCount Method

SegmentReader Ref RefCount Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int RefCount()
public virtual int RefCount()
Public Overridable Function RefCount As Integer
Public Overridable Function RefCount As Integer
public:
virtual int RefCount()
public:
virtual int RefCount()
See Also
SegmentReader Ref Class
SegmentReader Ref Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

SegmentReader Ref ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
SegmentReader Ref Class
SegmentReader Ref Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SerialMergeScheduler Class

SerialMergeScheduler Class Lucene.Net Class Library
A MergeScheduler that simply does each merge sequentially, using the current thread.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index MergeScheduler
Lucene.Net.Index SerialMergeScheduler

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SerialMergeScheduler : MergeScheduler
public class SerialMergeScheduler : MergeScheduler
Public Class SerialMergeScheduler _
    Inherits MergeScheduler
Public Class SerialMergeScheduler _
    Inherits MergeScheduler
public ref class SerialMergeScheduler : public MergeScheduler
public ref class SerialMergeScheduler : public MergeScheduler
See Also
SerialMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SerialMergeScheduler Members

SerialMergeScheduler Members Lucene.Net Class Library

The SerialMergeScheduler type exposes the following members.
Constructors
 | Name | Description
Public method | SerialMergeScheduler | Initializes a new instance of the SerialMergeScheduler class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. (Inherited from MergeScheduler.)
Public method | Dispose | (Inherited from MergeScheduler.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SerialMergeScheduler and optionally releases the managed resources (Overrides MergeScheduler Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Merge | Just do the merges in sequence. We do this "synchronized" so that even if the application is using multiple threads, only one merge may run at a time. (Overrides MergeScheduler Merge(IndexWriter).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SerialMergeScheduler Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SerialMergeScheduler Constructor

SerialMergeScheduler Constructor Lucene.Net Class Library
Initializes a new instance of the SerialMergeScheduler class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SerialMergeScheduler()
public SerialMergeScheduler()
Public Sub New
Public Sub New
public:
SerialMergeScheduler()
public:
SerialMergeScheduler()
See Also
SerialMergeScheduler Class
SerialMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SerialMergeScheduler Methods

SerialMergeScheduler Methods Lucene.Net Class Library
The SerialMergeScheduler type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. (Inherited from MergeScheduler.)
Public method | Dispose | (Inherited from MergeScheduler.)
Protected method | Dispose(Boolean) | (Overrides MergeScheduler Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Merge | Just do the merges in sequence. We do this "synchronized" so that even if the application is using multiple threads, only one merge may run at a time. (Overrides MergeScheduler Merge(IndexWriter).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SerialMergeScheduler Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

SerialMergeScheduler Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | (Inherited from MergeScheduler.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SerialMergeScheduler and optionally releases the managed resources (Overrides MergeScheduler Dispose(Boolean).)
Back to Top
See Also
SerialMergeScheduler Class
SerialMergeScheduler Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

SerialMergeScheduler Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the SerialMergeScheduler and optionally releases the managed resources

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
SerialMergeScheduler Class
SerialMergeScheduler Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Merge Method

SerialMergeScheduler Merge Method Lucene.Net Class Library
Just do the merges in sequence. We do this "synchronized" so that even if the application is using multiple threads, only one merge may run at a time.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Merge(
    IndexWriter writer
)
public override void Merge(
    IndexWriter writer
)
Public Overrides Sub Merge ( _
    writer As IndexWriter _
)
Public Overrides Sub Merge ( _
    writer As IndexWriter _
)
public:
virtual void Merge(
    IndexWriter^ writer
) override
public:
virtual void Merge(
    IndexWriter^ writer
) override
Parameters
writer
Type: Lucene.Net.Index IndexWriter
See Also
SerialMergeScheduler Class
SerialMergeScheduler Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SnapshotDeletionPolicy Class

SnapshotDeletionPolicy Class Lucene.Net Class Library
A IndexDeletionPolicy that wraps around any other IndexDeletionPolicy and adds the ability to hold and later release a single "snapshot" of an index. While the snapshot is held, the IndexWriter will not remove any files associated with it even if the index is otherwise being actively, arbitrarily changed. Because we wrap another arbitrary IndexDeletionPolicy, this gives you the freedom to continue using whatever IndexDeletionPolicy you would normally want to use with your index. Note that you can re-use a single instance of SnapshotDeletionPolicy across multiple writers as long as they are against the same index Directory. Any snapshot held when a writer is closed will "survive" when the next writer is opened.

WARNING: This API is a new and experimental and may suddenly change.

Inheritance Hierarchy
Online System Object
Lucene.Net.Index SnapshotDeletionPolicy

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SnapshotDeletionPolicy : IndexDeletionPolicy
public class SnapshotDeletionPolicy : IndexDeletionPolicy
Public Class SnapshotDeletionPolicy _
    Implements IndexDeletionPolicy
Public Class SnapshotDeletionPolicy _
    Implements IndexDeletionPolicy
public ref class SnapshotDeletionPolicy : IndexDeletionPolicy
public ref class SnapshotDeletionPolicy : IndexDeletionPolicy
See Also
SnapshotDeletionPolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SnapshotDeletionPolicy Members

SnapshotDeletionPolicy Members Lucene.Net Class Library

The SnapshotDeletionPolicy type exposes the following members.
Constructors
 | Name | Description
Public method | SnapshotDeletionPolicy | Initializes a new instance of the SnapshotDeletionPolicy class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OnCommit T |
Public method | OnInit T |
Public method | Release | Release the currently held snapshot.
Public method | Snapshot | Take a snapshot of the most recent commit to the index. You must call release() to free this snapshot. Note that while the snapshot is held, the files it references will not be deleted, which will consume additional disk space in your index. If you take a snapshot at a particularly bad time (say just before you call optimize()) then in the worst case this could consume an extra 1X of your total index size, until you release the snapshot.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SnapshotDeletionPolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SnapshotDeletionPolicy Constructor

SnapshotDeletionPolicy Constructor Lucene.Net Class Library
Initializes a new instance of the SnapshotDeletionPolicy class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SnapshotDeletionPolicy(
    IndexDeletionPolicy primary
)
public SnapshotDeletionPolicy(
    IndexDeletionPolicy primary
)
Public Sub New ( _
    primary As IndexDeletionPolicy _
)
Public Sub New ( _
    primary As IndexDeletionPolicy _
)
public:
SnapshotDeletionPolicy(
    IndexDeletionPolicy^ primary
)
public:
SnapshotDeletionPolicy(
    IndexDeletionPolicy^ primary
)
Parameters
primary
Type: Lucene.Net.Index IndexDeletionPolicy
See Also
SnapshotDeletionPolicy Class
SnapshotDeletionPolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SnapshotDeletionPolicy Methods

SnapshotDeletionPolicy Methods Lucene.Net Class Library
The SnapshotDeletionPolicy type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OnCommit T |
Public method | OnInit T |
Public method | Release | Release the currently held snapshot.
Public method | Snapshot | Take a snapshot of the most recent commit to the index. You must call release() to free this snapshot. Note that while the snapshot is held, the files it references will not be deleted, which will consume additional disk space in your index. If you take a snapshot at a particularly bad time (say just before you call optimize()) then in the worst case this could consume an extra 1X of your total index size, until you release the snapshot.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SnapshotDeletionPolicy Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OnCommit(T) Method

SnapshotDeletionPolicy OnCommit T Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void OnCommit<T>(
    IList<T> commits
)
where T : IndexCommit
public virtual void OnCommit<T>(
    IList<T> commits
)
where T : IndexCommit
Public Overridable Sub OnCommit(Of T As IndexCommit) ( _
    commits As IList(Of T) _
)
Public Overridable Sub OnCommit(Of T As IndexCommit) ( _
    commits As IList(Of T) _
)
public:
generic<typename T>
where T : IndexCommit
virtual void OnCommit(
    IList<T>^ commits
)
public:
generic<typename T>
where T : IndexCommit
virtual void OnCommit(
    IList<T>^ commits
)
Parameters
commits
Type:   Online System.Collections.Generic IList  T
Type Parameters
T
Implements
IndexDeletionPolicy OnCommit T (IList T )
See Also
SnapshotDeletionPolicy Class
SnapshotDeletionPolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OnInit(T) Method

SnapshotDeletionPolicy OnInit T Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void OnInit<T>(
    IList<T> commits
)
where T : IndexCommit
public virtual void OnInit<T>(
    IList<T> commits
)
where T : IndexCommit
Public Overridable Sub OnInit(Of T As IndexCommit) ( _
    commits As IList(Of T) _
)
Public Overridable Sub OnInit(Of T As IndexCommit) ( _
    commits As IList(Of T) _
)
public:
generic<typename T>
where T : IndexCommit
virtual void OnInit(
    IList<T>^ commits
)
public:
generic<typename T>
where T : IndexCommit
virtual void OnInit(
    IList<T>^ commits
)
Parameters
commits
Type:   Online System.Collections.Generic IList  T
Type Parameters
T
Implements
IndexDeletionPolicy OnInit T (IList T )
See Also
SnapshotDeletionPolicy Class
SnapshotDeletionPolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Release Method

SnapshotDeletionPolicy Release Method Lucene.Net Class Library
Release the currently held snapshot.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Release()
public virtual void Release()
Public Overridable Sub Release
Public Overridable Sub Release
public:
virtual void Release()
public:
virtual void Release()
See Also
SnapshotDeletionPolicy Class
SnapshotDeletionPolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Snapshot Method

SnapshotDeletionPolicy Snapshot Method Lucene.Net Class Library
Take a snapshot of the most recent commit to the index. You must call release() to free this snapshot. Note that while the snapshot is held, the files it references will not be deleted, which will consume additional disk space in your index. If you take a snapshot at a particularly bad time (say just before you call optimize()) then in the worst case this could consume an extra 1X of your total index size, until you release the snapshot.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IndexCommit Snapshot()
public virtual IndexCommit Snapshot()
Public Overridable Function Snapshot As IndexCommit
Public Overridable Function Snapshot As IndexCommit
public:
virtual IndexCommit^ Snapshot()
public:
virtual IndexCommit^ Snapshot()
See Also
SnapshotDeletionPolicy Class
SnapshotDeletionPolicy Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedTermVectorMapper Class

SortedTermVectorMapper Class Lucene.Net Class Library
Store a sorted collection of TermVectorEntrys. Collects all term information into a single, SortedSet.
NOTE: This Mapper ignores all Field information for the Document. This means that if you are using offset/positions you will not know what Fields they correlate with.
This is not thread-safe
Inheritance Hierarchy
Online System Object
Lucene.Net.Index TermVectorMapper
Lucene.Net.Index SortedTermVectorMapper

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SortedTermVectorMapper : TermVectorMapper
public class SortedTermVectorMapper : TermVectorMapper
Public Class SortedTermVectorMapper _
    Inherits TermVectorMapper
Public Class SortedTermVectorMapper _
    Inherits TermVectorMapper
public ref class SortedTermVectorMapper : public TermVectorMapper
public ref class SortedTermVectorMapper : public TermVectorMapper
See Also
SortedTermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedTermVectorMapper Members

SortedTermVectorMapper Members Lucene.Net Class Library

The SortedTermVectorMapper type exposes the following members.
Constructors
 | Name | Description
Public method | SortedTermVectorMapper(IComparer TermVectorEntry ) | Initializes a new instance of the SortedTermVectorMapper class
Public method | SortedTermVectorMapper(Boolean, Boolean, IComparer TermVectorEntry ) | Initializes a new instance of the SortedTermVectorMapper class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Map | (Overrides TermVectorMapper Map(String, Int32, TermVectorOffsetInfo , Int32 ).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations. (Inherited from TermVectorMapper.)
Public method | SetExpectations | (Overrides TermVectorMapper SetExpectations(String, Int32, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
ALL | Stand-in name for the field in TermVectorEntry.
Back to Top
Properties
 | Name | Description
Public property | IsIgnoringOffsets | (Inherited from TermVectorMapper.)
Public property | IsIgnoringPositions | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored. (Inherited from TermVectorMapper.)
Public property | TermVectorEntrySet | The TermVectorEntrySet. A SortedSet of TermVectorEntry objects. Sort is by the comparator passed into the constructor. This set will be empty until after the mapping process takes place.
Back to Top
See Also
SortedTermVectorMapper Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedTermVectorMapper Constructor

SortedTermVectorMapper Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | SortedTermVectorMapper(IComparer TermVectorEntry ) | Initializes a new instance of the SortedTermVectorMapper class
Public method | SortedTermVectorMapper(Boolean, Boolean, IComparer TermVectorEntry ) | Initializes a new instance of the SortedTermVectorMapper class
Back to Top
See Also
SortedTermVectorMapper Class
SortedTermVectorMapper Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedTermVectorMapper Constructor (IComparer(TermVectorEntry))

SortedTermVectorMapper Constructor (IComparer TermVectorEntry ) Lucene.Net Class Library
Initializes a new instance of the SortedTermVectorMapper class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortedTermVectorMapper(
    IComparer<TermVectorEntry> comparator
)
public SortedTermVectorMapper(
    IComparer<TermVectorEntry> comparator
)
Public Sub New ( _
    comparator As IComparer(Of TermVectorEntry) _
)
Public Sub New ( _
    comparator As IComparer(Of TermVectorEntry) _
)
public:
SortedTermVectorMapper(
    IComparer<TermVectorEntry^>^ comparator
)
public:
SortedTermVectorMapper(
    IComparer<TermVectorEntry^>^ comparator
)
Parameters
comparator
Type:   Online System.Collections.Generic IComparer  TermVectorEntry
A Comparator for sorting TermVectorEntrys

See Also
SortedTermVectorMapper Class
SortedTermVectorMapper Members
SortedTermVectorMapper Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedTermVectorMapper Constructor (Boolean, Boolean, IComparer(TermVectorEntry))

SortedTermVectorMapper Constructor (Boolean, Boolean, IComparer TermVectorEntry ) Lucene.Net Class Library
Initializes a new instance of the SortedTermVectorMapper class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortedTermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets,
    IComparer<TermVectorEntry> comparator
)
public SortedTermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets,
    IComparer<TermVectorEntry> comparator
)
Public Sub New ( _
    ignoringPositions As Boolean, _
    ignoringOffsets As Boolean, _
    comparator As IComparer(Of TermVectorEntry) _
)
Public Sub New ( _
    ignoringPositions As Boolean, _
    ignoringOffsets As Boolean, _
    comparator As IComparer(Of TermVectorEntry) _
)
public:
SortedTermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets,
    IComparer<TermVectorEntry^>^ comparator
)
public:
SortedTermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets,
    IComparer<TermVectorEntry^>^ comparator
)
Parameters
ignoringPositions
Type:   Online System Boolean
ignoringOffsets
Type:   Online System Boolean
comparator
Type:   Online System.Collections.Generic IComparer  TermVectorEntry
See Also
SortedTermVectorMapper Class
SortedTermVectorMapper Members
SortedTermVectorMapper Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedTermVectorMapper Fields

SortedTermVectorMapper Fields Lucene.Net Class Library
The SortedTermVectorMapper type exposes the following members.
Fields
Name | Description
ALL | Stand-in name for the field in TermVectorEntry.
Back to Top
See Also
SortedTermVectorMapper Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ALL Field

SortedTermVectorMapper ALL Field Lucene.Net Class Library
Stand-in name for the field in TermVectorEntry.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ALL
public const string ALL
Public Const ALL As String
Public Const ALL As String
public:
literal String^ ALL
public:
literal String^ ALL
See Also
SortedTermVectorMapper Class
SortedTermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedTermVectorMapper Methods

SortedTermVectorMapper Methods Lucene.Net Class Library
The SortedTermVectorMapper type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Map | (Overrides TermVectorMapper Map(String, Int32, TermVectorOffsetInfo , Int32 ).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations. (Inherited from TermVectorMapper.)
Public method | SetExpectations | (Overrides TermVectorMapper SetExpectations(String, Int32, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SortedTermVectorMapper Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Map Method

SortedTermVectorMapper Map Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Map(
    string term,
    int frequency,
    TermVectorOffsetInfo[] offsets,
    int[] positions
)
public override void Map(
    string term,
    int frequency,
    TermVectorOffsetInfo[] offsets,
    int[] positions
)
Public Overrides Sub Map ( _
    term As String, _
    frequency As Integer, _
    offsets As TermVectorOffsetInfo(), _
    positions As Integer() _
)
Public Overrides Sub Map ( _
    term As String, _
    frequency As Integer, _
    offsets As TermVectorOffsetInfo(), _
    positions As Integer() _
)
public:
virtual void Map(
    String^ term,
    int frequency,
    array<TermVectorOffsetInfo>^ offsets,
    array<int>^ positions
) override
public:
virtual void Map(
    String^ term,
    int frequency,
    array<TermVectorOffsetInfo>^ offsets,
    array<int>^ positions
) override
Parameters
term
Type:   Online System String
The term to map

frequency
Type:   Online System Int32
The frequency of the term

offsets
Type:  Lucene.Net.Index TermVectorOffsetInfo
Offset information, may be null

positions
Type:    Online System Int32
Position information, may be null

See Also
SortedTermVectorMapper Class
SortedTermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetExpectations Method

SortedTermVectorMapper SetExpectations Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetExpectations(
    string field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
)
public override void SetExpectations(
    string field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
)
Public Overrides Sub SetExpectations ( _
    field As String, _
    numTerms As Integer, _
    storeOffsets As Boolean, _
    storePositions As Boolean _
)
Public Overrides Sub SetExpectations ( _
    field As String, _
    numTerms As Integer, _
    storeOffsets As Boolean, _
    storePositions As Boolean _
)
public:
virtual void SetExpectations(
    String^ field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
) override
public:
virtual void SetExpectations(
    String^ field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
) override
Parameters
field
Type:   Online System String
numTerms
Type:   Online System Int32
storeOffsets
Type:   Online System Boolean
storePositions
Type:   Online System Boolean
See Also
SortedTermVectorMapper Class
SortedTermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedTermVectorMapper Properties

SortedTermVectorMapper Properties Lucene.Net Class Library
The SortedTermVectorMapper type exposes the following members.
Properties
 | Name | Description
Public property | IsIgnoringOffsets | (Inherited from TermVectorMapper.)
Public property | IsIgnoringPositions | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored. (Inherited from TermVectorMapper.)
Public property | TermVectorEntrySet | The TermVectorEntrySet. A SortedSet of TermVectorEntry objects. Sort is by the comparator passed into the constructor. This set will be empty until after the mapping process takes place.
Back to Top
See Also
SortedTermVectorMapper Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorEntrySet Property

SortedTermVectorMapper TermVectorEntrySet Property Lucene.Net Class Library
The TermVectorEntrySet. A SortedSet of TermVectorEntry objects. Sort is by the comparator passed into the constructor.
This set will be empty until after the mapping process takes place.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual SortedSet<TermVectorEntry> TermVectorEntrySet { get; }
public virtual SortedSet<TermVectorEntry> TermVectorEntrySet { get; }
Public Overridable ReadOnly Property TermVectorEntrySet As SortedSet(Of TermVectorEntry)
    Get
Public Overridable ReadOnly Property TermVectorEntrySet As SortedSet(Of TermVectorEntry)
    Get
public:
virtual property SortedSet<TermVectorEntry^>^ TermVectorEntrySet {
    SortedSet<TermVectorEntry^>^ get ();
}
public:
virtual property SortedSet<TermVectorEntry^>^ TermVectorEntrySet {
    SortedSet<TermVectorEntry^>^ get ();
}
Field Value
 The SortedSet of <see cref="TermVectorEntry" />.
See Also
SortedTermVectorMapper Class
SortedTermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StaleReaderException Class

StaleReaderException Class Lucene.Net Class Library
This exception is thrown when an IndexReader tries to make changes to the index (via DeleteDocument(Int32) , UndeleteAll or SetNorm(Int32, String, Single)) but changes have already been committed to the index since this reader was instantiated. When this happens you must open a new reader on the current index to make the changes.
Inheritance Hierarchy
Online System Object
Online System Exception
Online System SystemException
Online System.IO IOException
Lucene.Net.Index StaleReaderException

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class StaleReaderException : IOException
[SerializableAttribute]
public class StaleReaderException : IOException
<SerializableAttribute> _
Public Class StaleReaderException _
    Inherits IOException
<SerializableAttribute> _
Public Class StaleReaderException _
    Inherits IOException
[SerializableAttribute]
public ref class StaleReaderException : public IOException
[SerializableAttribute]
public ref class StaleReaderException : public IOException
See Also
StaleReaderException Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StaleReaderException Members

StaleReaderException Members Lucene.Net Class Library

The StaleReaderException type exposes the following members.
Constructors
 | Name | Description
Public method | StaleReaderException | Initializes a new instance of the StaleReaderException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
StaleReaderException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StaleReaderException Constructor

StaleReaderException Constructor Lucene.Net Class Library
Initializes a new instance of the StaleReaderException class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StaleReaderException(
    string message
)
public StaleReaderException(
    string message
)
Public Sub New ( _
    message As String _
)
Public Sub New ( _
    message As String _
)
public:
StaleReaderException(
    String^ message
)
public:
StaleReaderException(
    String^ message
)
Parameters
message
Type:   Online System String
See Also
StaleReaderException Class
StaleReaderException Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StaleReaderException Methods

StaleReaderException Methods Lucene.Net Class Library
The StaleReaderException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
StaleReaderException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StaleReaderException Properties

StaleReaderException Properties Lucene.Net Class Library
The StaleReaderException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
StaleReaderException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StaleReaderException Events

StaleReaderException Events Lucene.Net Class Library
The StaleReaderException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
StaleReaderException Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Class

Term Class Lucene.Net Class Library
A Term represents a word from text. This is the unit of search. It is composed of two elements, the text of the word, as a string, and the name of the field that the text occured in, an interned string. Note that terms may represent more than words from text fields, but also things like dates, email addresses, urls, etc.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index Term

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class Term : IComparable<Term>
[SerializableAttribute]
public sealed class Term : IComparable<Term>
<SerializableAttribute> _
Public NotInheritable Class Term _
    Implements IComparable(Of Term)
<SerializableAttribute> _
Public NotInheritable Class Term _
    Implements IComparable(Of Term)
[SerializableAttribute]
public ref class Term sealed : IComparable<Term^>
[SerializableAttribute]
public ref class Term sealed : IComparable<Term^>
See Also
Term Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Members

Term Members Lucene.Net Class Library

The Term type exposes the following members.
Constructors
 | Name | Description
Public method | Term(String) | Constructs a Term with the given field and empty text. This serves two purposes: 1) reuse of a Term with the same field. 2) pattern for a query.
Public method | Term(String, String) | Constructs a Term with the given field and text. Note that a null field or null text value results in undefined behavior for most Lucene APIs that accept a Term parameter.
Back to Top
Methods
 | Name | Description
Public method | CompareTo | Compares two terms, returning a negative integer if this term belongs before the argument, zero if this term is equal to the argument, and a positive integer if this term belongs after the argument. The ordering of terms is first by field, then by text.
Public method | CreateTerm | Optimized construction of new Terms by reusing same field as this Term - avoids field.intern() overhead
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | Field | Returns the field of this term, an interned string. The field indicates the part of a document which this term came from.
Public property | Text | Returns the text of this term. In the case of words, this is simply the text of the word. In the case of dates and other types, this is an encoding of the object as a string.
Back to Top
See Also
Term Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Constructor

Term Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Term(String) | Constructs a Term with the given field and empty text. This serves two purposes: 1) reuse of a Term with the same field. 2) pattern for a query.
Public method | Term(String, String) | Constructs a Term with the given field and text. Note that a null field or null text value results in undefined behavior for most Lucene APIs that accept a Term parameter.
Back to Top
See Also
Term Class
Term Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Constructor (String)

Term Constructor (String) Lucene.Net Class Library
Constructs a Term with the given field and empty text. This serves two purposes: 1) reuse of a Term with the same field. 2) pattern for a query.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Term(
    string fld
)
public Term(
    string fld
)
Public Sub New ( _
    fld As String _
)
Public Sub New ( _
    fld As String _
)
public:
Term(
    String^ fld
)
public:
Term(
    String^ fld
)
Parameters
fld
Type:   Online System String
See Also
Term Class
Term Members
Term Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Constructor (String, String)

Term Constructor (String, String) Lucene.Net Class Library
Constructs a Term with the given field and text.

Note that a null field or null text value results in undefined behavior for most Lucene APIs that accept a Term parameter.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Term(
    string fld,
    string txt
)
public Term(
    string fld,
    string txt
)
Public Sub New ( _
    fld As String, _
    txt As String _
)
Public Sub New ( _
    fld As String, _
    txt As String _
)
public:
Term(
    String^ fld,
    String^ txt
)
public:
Term(
    String^ fld,
    String^ txt
)
Parameters
fld
Type:   Online System String
txt
Type:   Online System String
See Also
Term Class
Term Members
Term Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Methods

Term Methods Lucene.Net Class Library
The Term type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo | Compares two terms, returning a negative integer if this term belongs before the argument, zero if this term is equal to the argument, and a positive integer if this term belongs after the argument. The ordering of terms is first by field, then by text.
Public method | CreateTerm | Optimized construction of new Terms by reusing same field as this Term - avoids field.intern() overhead
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
Term Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompareTo Method

Term CompareTo Method Lucene.Net Class Library
Compares two terms, returning a negative integer if this term belongs before the argument, zero if this term is equal to the argument, and a positive integer if this term belongs after the argument. The ordering of terms is first by field, then by text.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Term other
)
public int CompareTo(
    Term other
)
Public Function CompareTo ( _
    other As Term _
) As Integer
Public Function CompareTo ( _
    other As Term _
) As Integer
public:
virtual int CompareTo(
    Term^ other
) sealed
public:
virtual int CompareTo(
    Term^ other
) sealed
Parameters
other
Type: Lucene.Net.Index Term
Implements
  Online IComparable T  CompareTo(T)
See Also
Term Class
Term Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateTerm Method

Term CreateTerm Method Lucene.Net Class Library
Optimized construction of new Terms by reusing same field as this Term - avoids field.intern() overhead

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Term CreateTerm(
    string text
)
public Term CreateTerm(
    string text
)
Public Function CreateTerm ( _
    text As String _
) As Term
Public Function CreateTerm ( _
    text As String _
) As Term
public:
Term^ CreateTerm(
    String^ text
)
public:
Term^ CreateTerm(
    String^ text
)
Parameters
text
Type:   Online System String
The text of the new term (field is implicitly same as this Term instance)

Return Value
 A new Term

See Also
Term Class
Term Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

Term Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
Term Class
Term Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

Term GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
Term Class
Term Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

Term ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
Term Class
Term Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Properties

Term Properties Lucene.Net Class Library
The Term type exposes the following members.
Properties
 | Name | Description
Public property | Field | Returns the field of this term, an interned string. The field indicates the part of a document which this term came from.
Public property | Text | Returns the text of this term. In the case of words, this is simply the text of the word. In the case of dates and other types, this is an encoding of the object as a string.
Back to Top
See Also
Term Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

Term Field Property Lucene.Net Class Library
Returns the field of this term, an interned string. The field indicates the part of a document which this term came from.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Field { get; }
public string Field { get; }
Public ReadOnly Property Field As String
    Get
Public ReadOnly Property Field As String
    Get
public:
property String^ Field {
    String^ get ();
}
public:
property String^ Field {
    String^ get ();
}
See Also
Term Class
Term Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Text Property

Term Text Property Lucene.Net Class Library
Returns the text of this term. In the case of words, this is simply the text of the word. In the case of dates and other types, this is an encoding of the object as a string.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Text { get; }
public string Text { get; }
Public ReadOnly Property Text As String
    Get
Public ReadOnly Property Text As String
    Get
public:
property String^ Text {
    String^ get ();
}
public:
property String^ Text {
    String^ get ();
}
See Also
Term Class
Term Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Interface

TermDocs Interface Lucene.Net Class Library
TermDocs provides an interface for enumerating <document, frequency> pairs for a term.

The document portion names each document containing the term. Documents are indicated by number. The frequency portion gives the number of times the term occurred in each document.

The pairs are ordered by document number.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface TermDocs : IDisposable
public interface TermDocs : IDisposable
Public Interface TermDocs _
    Inherits IDisposable
Public Interface TermDocs _
    Inherits IDisposable
public interface class TermDocs : IDisposable
public interface class TermDocs : IDisposable
See Also
TermDocs Members
Lucene.Net.Index Namespace
IndexReader TermDocs
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Members

TermDocs Members Lucene.Net Class Library

The TermDocs type exposes the following members.
Methods
Name Description
Public method Close Obsolete.
Frees associated resources.
Public method Online Dispose
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
(Inherited from Online IDisposable.)
Public method Next
Moves to the next pair in the enumeration.

Returns true iff there is such a next pair in the enumeration.
Public method Read
Attempts to read multiple entries from the enumeration, up to length of docs. Document numbers are stored in docs, and term frequencies are stored in freqs. The freqs array must be as long as the docs array.

Returns the number of entries read. Zero is only returned when the stream has been exhausted.
Public method Seek(Term)
Sets this to the data for a term. The enumeration is reset to the start of the data for this term.
Public method Seek(TermEnum)
Sets this to the data for the current term in a TermEnum. This may be optimized in some implementations.
Public method SkipTo
Skips entries to the first beyond the current whose document number is greater than or equal to target.

Returns true iff there is such an entry.

Behaves as if written:
View Colorized Copy to Clipboard Print
boolean skipTo(int target) {
    do {
        if (!next())
            return false;
    } while (target > doc());
        return true;
}
boolean skipTo(int target) {
    do {
        if (!next())
            return false;
    } while (target > doc());
        return true;
}
Some implementations are considerably more efficient than that.
Back to Top
Properties
 | Name | Description
Public property | Doc | Returns the current document number. This is invalid until Next is called for the first time.
Public property | Freq | Returns the frequency of the term within the current document. This is invalid until Next is called for the first time.
Back to Top
See Also
TermDocs Interface
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Methods

TermDocs Methods Lucene.Net Class Library
The TermDocs type exposes the following members.
Methods
Name Description
Public method Close Obsolete.
Frees associated resources.
Public method Online Dispose
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
(Inherited from Online IDisposable.)
Public method Next
Moves to the next pair in the enumeration.

Returns true iff there is such a next pair in the enumeration.
Public method Read
Attempts to read multiple entries from the enumeration, up to length of docs. Document numbers are stored in docs, and term frequencies are stored in freqs. The freqs array must be as long as the docs array.

Returns the number of entries read. Zero is only returned when the stream has been exhausted.
Public method Seek(Term)
Sets this to the data for a term. The enumeration is reset to the start of the data for this term.
Public method Seek(TermEnum)
Sets this to the data for the current term in a TermEnum. This may be optimized in some implementations.
Public method SkipTo
Skips entries to the first beyond the current whose document number is greater than or equal to target.

Returns true iff there is such an entry.

Behaves as if written:
View Colorized Copy to Clipboard Print
boolean skipTo(int target) {
    do {
        if (!next())
            return false;
    } while (target > doc());
        return true;
}
boolean skipTo(int target) {
    do {
        if (!next())
            return false;
    } while (target > doc());
        return true;
}
Some implementations are considerably more efficient than that.
Back to Top
See Also
TermDocs Interface
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

TermDocs Close Method Lucene.Net Class Library
Frees associated resources.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Dispose() instead")]
void Close()
[ObsoleteAttribute("Use Dispose() instead")]
void Close()
<ObsoleteAttribute("Use Dispose() instead")> _
Sub Close
<ObsoleteAttribute("Use Dispose() instead")> _
Sub Close
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
See Also
TermDocs Interface
TermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Next Method

TermDocs Next Method Lucene.Net Class Library
Moves to the next pair in the enumeration.

Returns true iff there is such a next pair in the enumeration.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Next()
bool Next()
Function Next As Boolean
Function Next As Boolean
bool Next()
bool Next()
See Also
TermDocs Interface
TermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Read Method

TermDocs Read Method Lucene.Net Class Library
Attempts to read multiple entries from the enumeration, up to length of docs. Document numbers are stored in docs, and term frequencies are stored in freqs. The freqs array must be as long as the docs array.

Returns the number of entries read. Zero is only returned when the stream has been exhausted.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int Read(
    int[] docs,
    int[] freqs
)
int Read(
    int[] docs,
    int[] freqs
)
Function Read ( _
    docs As Integer(), _
    freqs As Integer() _
) As Integer
Function Read ( _
    docs As Integer(), _
    freqs As Integer() _
) As Integer
int Read(
    array<int>^ docs,
    array<int>^ freqs
)
int Read(
    array<int>^ docs,
    array<int>^ freqs
)
Parameters
docs
Type:    Online System Int32
freqs
Type:    Online System Int32
See Also
TermDocs Interface
TermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method

TermDocs Seek Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Seek(Term) | Sets this to the data for a term. The enumeration is reset to the start of the data for this term.
Public method | Seek(TermEnum) | Sets this to the data for the current term in a TermEnum. This may be optimized in some implementations.
Back to Top
See Also
TermDocs Interface
TermDocs Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method (Term)

TermDocs Seek Method (Term) Lucene.Net Class Library
Sets this to the data for a term. The enumeration is reset to the start of the data for this term.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Seek(
    Term term
)
void Seek(
    Term term
)
Sub Seek ( _
    term As Term _
)
Sub Seek ( _
    term As Term _
)
void Seek(
    Term^ term
)
void Seek(
    Term^ term
)
Parameters
term
Type: Lucene.Net.Index Term
See Also
TermDocs Interface
TermDocs Members
Seek Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method (TermEnum)

TermDocs Seek Method (TermEnum) Lucene.Net Class Library
Sets this to the data for the current term in a TermEnum. This may be optimized in some implementations.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Seek(
    TermEnum termEnum
)
void Seek(
    TermEnum termEnum
)
Sub Seek ( _
    termEnum As TermEnum _
)
Sub Seek ( _
    termEnum As TermEnum _
)
void Seek(
    TermEnum^ termEnum
)
void Seek(
    TermEnum^ termEnum
)
Parameters
termEnum
Type: Lucene.Net.Index TermEnum
See Also
TermDocs Interface
TermDocs Members
Seek Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SkipTo Method

TermDocs SkipTo Method Lucene.Net Class Library
Skips entries to the first beyond the current whose document number is greater than or equal to target.

Returns true iff there is such an entry.

Behaves as if written:
View Colorized Copy to Clipboard Print
boolean skipTo(int target) {
    do {
        if (!next())
            return false;
    } while (target > doc());
        return true;
}
boolean skipTo(int target) {
    do {
        if (!next())
            return false;
    } while (target > doc());
        return true;
}
Some implementations are considerably more efficient than that.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SkipTo(
    int target
)
bool SkipTo(
    int target
)
Function SkipTo ( _
    target As Integer _
) As Boolean
Function SkipTo ( _
    target As Integer _
) As Boolean
bool SkipTo(
    int target
)
bool SkipTo(
    int target
)
Parameters
target
Type:   Online System Int32
See Also
TermDocs Interface
TermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermDocs Properties

TermDocs Properties Lucene.Net Class Library
The TermDocs type exposes the following members.
Properties
 | Name | Description
Public property | Doc | Returns the current document number. This is invalid until Next is called for the first time.
Public property | Freq | Returns the frequency of the term within the current document. This is invalid until Next is called for the first time.
Back to Top
See Also
TermDocs Interface
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Property

TermDocs Doc Property Lucene.Net Class Library
Returns the current document number.

This is invalid until Next is called for the first time.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int Doc { get; }
int Doc { get; }
ReadOnly Property Doc As Integer
    Get
ReadOnly Property Doc As Integer
    Get
property int Doc {
    int get ();
}
property int Doc {
    int get ();
}
See Also
TermDocs Interface
TermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Freq Property

TermDocs Freq Property Lucene.Net Class Library
Returns the frequency of the term within the current document.

This is invalid until Next is called for the first time.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int Freq { get; }
int Freq { get; }
ReadOnly Property Freq As Integer
    Get
ReadOnly Property Freq As Integer
    Get
property int Freq {
    int get ();
}
property int Freq {
    int get ();
}
See Also
TermDocs Interface
TermDocs Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermEnum Class

TermEnum Class Lucene.Net Class Library
Abstract class for enumerating terms.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index TermEnum
Lucene.Net.Index FilterIndexReader FilterTermEnum
Lucene.Net.Search FilteredTermEnum

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class TermEnum : IDisposable
public abstract class TermEnum : IDisposable
Public MustInherit Class TermEnum _
    Implements IDisposable
Public MustInherit Class TermEnum _
    Implements IDisposable
public ref class TermEnum abstract : IDisposable
public ref class TermEnum abstract : IDisposable
See Also
TermEnum Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermEnum Members

TermEnum Members Lucene.Net Class Library

The TermEnum type exposes the following members.
Constructors
 | Name | Description
Protected method | TermEnum | Initializes a new instance of the TermEnum class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the enumeration to further activity, freeing resources.
Public method | Dispose | Closes the enumeration to further activity, freeing resources.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TermEnum and optionally releases the managed resources
Public method | DocFreq | Returns the docFreq of the current Term in the enumeration.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | Increments the enumeration to the next element. True if one exists.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Term | Returns the current Term in the enumeration.
Back to Top
See Also
TermEnum Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermEnum Constructor

TermEnum Constructor Lucene.Net Class Library
Initializes a new instance of the TermEnum class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TermEnum()
protected TermEnum()
Protected Sub New
Protected Sub New
protected:
TermEnum()
protected:
TermEnum()
See Also
TermEnum Class
TermEnum Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermEnum Methods

TermEnum Methods Lucene.Net Class Library
The TermEnum type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the enumeration to further activity, freeing resources.
Public method | Dispose | Closes the enumeration to further activity, freeing resources.
Protected method | Dispose(Boolean) |
Public method | DocFreq | Returns the docFreq of the current Term in the enumeration.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | Increments the enumeration to the next element. True if one exists.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TermEnum Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

TermEnum Close Method Lucene.Net Class Library
Closes the enumeration to further activity, freeing resources.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
See Also
TermEnum Class
TermEnum Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

TermEnum Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes the enumeration to further activity, freeing resources.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TermEnum and optionally releases the managed resources
Back to Top
See Also
TermEnum Class
TermEnum Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

TermEnum Dispose Method Lucene.Net Class Library
Closes the enumeration to further activity, freeing resources.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
TermEnum Class
TermEnum Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

TermEnum Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the TermEnum and optionally releases the managed resources

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void Dispose(
    bool disposing
)
protected abstract void Dispose(
    bool disposing
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) abstract
protected:
virtual void Dispose(
    bool disposing
) abstract
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
TermEnum Class
TermEnum Members
Dispose Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocFreq Method

TermEnum DocFreq Method Lucene.Net Class Library
Returns the docFreq of the current Term in the enumeration.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int DocFreq()
public abstract int DocFreq()
Public MustOverride Function DocFreq As Integer
Public MustOverride Function DocFreq As Integer
public:
virtual int DocFreq() abstract
public:
virtual int DocFreq() abstract
See Also
TermEnum Class
TermEnum Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Next Method

TermEnum Next Method Lucene.Net Class Library
Increments the enumeration to the next element. True if one exists.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool Next()
public abstract bool Next()
Public MustOverride Function Next As Boolean
Public MustOverride Function Next As Boolean
public:
virtual bool Next() abstract
public:
virtual bool Next() abstract
See Also
TermEnum Class
TermEnum Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermEnum Properties

TermEnum Properties Lucene.Net Class Library
The TermEnum type exposes the following members.
Properties
 | Name | Description
Public property | Term | Returns the current Term in the enumeration.
Back to Top
See Also
TermEnum Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Property

TermEnum Term Property Lucene.Net Class Library
Returns the current Term in the enumeration.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Term Term { get; }
public abstract Term Term { get; }
Public MustOverride ReadOnly Property Term As Term
    Get
Public MustOverride ReadOnly Property Term As Term
    Get
public:
virtual property Term^ Term {
    Term^ get () abstract;
}
public:
virtual property Term^ Term {
    Term^ get () abstract;
}
See Also
TermEnum Class
TermEnum Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Interface

TermPositions Interface Lucene.Net Class Library
TermPositions provides an interface for enumerating the <document, frequency, <position>* > tuples for a term.

The document and frequency are the same as for a TermDocs. The positions portion lists the ordinal positions of each occurrence of a term in a document.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface TermPositions : TermDocs,
    IDisposable
public interface TermPositions : TermDocs,
    IDisposable
Public Interface TermPositions _
    Inherits TermDocs, IDisposable
Public Interface TermPositions _
    Inherits TermDocs, IDisposable
public interface class TermPositions : TermDocs,
    IDisposable
public interface class TermPositions : TermDocs,
    IDisposable
See Also
TermPositions Members
Lucene.Net.Index Namespace
IndexReader TermPositions
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Members

TermPositions Members Lucene.Net Class Library

The TermPositions type exposes the following members.
Methods
Name Description
Public method Close Obsolete.
Frees associated resources.
(Inherited from TermDocs.)
Public method Online Dispose
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
(Inherited from Online IDisposable.)
Public method GetPayload
Returns the payload data at the current term position. This is invalid until NextPosition is called for the first time. This method must not be called more than once after each call of NextPosition . However, payloads are loaded lazily, so if the payload data for the current position is not needed, this method may not be called at all for performance reasons.
Public method Next
Moves to the next pair in the enumeration.

Returns true iff there is such a next pair in the enumeration.
(Inherited from TermDocs.)
Public method NextPosition
Returns next position in the current document. It is an error to call this more than Freq times without calling Next

This is invalid until Next is called for the first time.
Public method Read
Attempts to read multiple entries from the enumeration, up to length of docs. Document numbers are stored in docs, and term frequencies are stored in freqs. The freqs array must be as long as the docs array.

Returns the number of entries read. Zero is only returned when the stream has been exhausted.
(Inherited from TermDocs.)
Public method Seek(Term)
Sets this to the data for a term. The enumeration is reset to the start of the data for this term.
(Inherited from TermDocs.)
Public method Seek(TermEnum)
Sets this to the data for the current term in a TermEnum. This may be optimized in some implementations.
(Inherited from TermDocs.)
Public method SkipTo
Skips entries to the first beyond the current whose document number is greater than or equal to target.

Returns true iff there is such an entry.

Behaves as if written:
View Colorized Copy to Clipboard Print
boolean skipTo(int target) {
    do {
        if (!next())
            return false;
    } while (target > doc());
        return true;
}
boolean skipTo(int target) {
    do {
        if (!next())
            return false;
    } while (target > doc());
        return true;
}
Some implementations are considerably more efficient than that.
(Inherited from TermDocs.)
Back to Top
Properties
 | Name | Description
Public property | Doc | Returns the current document number. This is invalid until Next is called for the first time. (Inherited from TermDocs.)
Public property | Freq | Returns the frequency of the term within the current document. This is invalid until Next is called for the first time. (Inherited from TermDocs.)
Public property | IsPayloadAvailable | Checks if a payload can be loaded at this position. Payloads can only be loaded once per call to NextPosition .
Public property | PayloadLength | Returns the length of the payload at the current term position. This is invalid until NextPosition is called for the first time.
Back to Top
See Also
TermPositions Interface
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Methods

TermPositions Methods Lucene.Net Class Library
The TermPositions type exposes the following members.
Methods
Name Description
Public method Close Obsolete.
Frees associated resources.
(Inherited from TermDocs.)
Public method Online Dispose
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
(Inherited from Online IDisposable.)
Public method GetPayload
Returns the payload data at the current term position. This is invalid until NextPosition is called for the first time. This method must not be called more than once after each call of NextPosition . However, payloads are loaded lazily, so if the payload data for the current position is not needed, this method may not be called at all for performance reasons.
Public method Next
Moves to the next pair in the enumeration.

Returns true iff there is such a next pair in the enumeration.
(Inherited from TermDocs.)
Public method NextPosition
Returns next position in the current document. It is an error to call this more than Freq times without calling Next

This is invalid until Next is called for the first time.
Public method Read
Attempts to read multiple entries from the enumeration, up to length of docs. Document numbers are stored in docs, and term frequencies are stored in freqs. The freqs array must be as long as the docs array.

Returns the number of entries read. Zero is only returned when the stream has been exhausted.
(Inherited from TermDocs.)
Public method Seek(Term)
Sets this to the data for a term. The enumeration is reset to the start of the data for this term.
(Inherited from TermDocs.)
Public method Seek(TermEnum)
Sets this to the data for the current term in a TermEnum. This may be optimized in some implementations.
(Inherited from TermDocs.)
Public method SkipTo
Skips entries to the first beyond the current whose document number is greater than or equal to target.

Returns true iff there is such an entry.

Behaves as if written:
View Colorized Copy to Clipboard Print
boolean skipTo(int target) {
    do {
        if (!next())
            return false;
    } while (target > doc());
        return true;
}
boolean skipTo(int target) {
    do {
        if (!next())
            return false;
    } while (target > doc());
        return true;
}
Some implementations are considerably more efficient than that.
(Inherited from TermDocs.)
Back to Top
See Also
TermPositions Interface
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPayload Method

TermPositions GetPayload Method Lucene.Net Class Library
Returns the payload data at the current term position. This is invalid until NextPosition is called for the first time. This method must not be called more than once after each call of NextPosition . However, payloads are loaded lazily, so if the payload data for the current position is not needed, this method may not be called at all for performance reasons.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
byte[] GetPayload(
    byte[] data,
    int offset
)
byte[] GetPayload(
    byte[] data,
    int offset
)
Function GetPayload ( _
    data As Byte(), _
    offset As Integer _
) As Byte()
Function GetPayload ( _
    data As Byte(), _
    offset As Integer _
) As Byte()
array<unsigned char>^ GetPayload(
    array<unsigned char>^ data,
    int offset
)
array<unsigned char>^ GetPayload(
    array<unsigned char>^ data,
    int offset
)
Parameters
data
Type:    Online System Byte
the array into which the data of this payload is to be
            stored, if it is big enough; otherwise, a new byte[] array
            is allocated for this purpose.

offset
Type:   Online System Int32
the offset in the array into which the data of this payload
            is to be stored.

Return Value
 a byte[] array containing the data of this payload

See Also
TermPositions Interface
TermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextPosition Method

TermPositions NextPosition Method Lucene.Net Class Library
Returns next position in the current document. It is an error to call this more than Freq times without calling Next

This is invalid until Next is called for the first time.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int NextPosition()
int NextPosition()
Function NextPosition As Integer
Function NextPosition As Integer
int NextPosition()
int NextPosition()
See Also
TermPositions Interface
TermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositions Properties

TermPositions Properties Lucene.Net Class Library
The TermPositions type exposes the following members.
Properties
 | Name | Description
Public property | Doc | Returns the current document number. This is invalid until Next is called for the first time. (Inherited from TermDocs.)
Public property | Freq | Returns the frequency of the term within the current document. This is invalid until Next is called for the first time. (Inherited from TermDocs.)
Public property | IsPayloadAvailable | Checks if a payload can be loaded at this position. Payloads can only be loaded once per call to NextPosition .
Public property | PayloadLength | Returns the length of the payload at the current term position. This is invalid until NextPosition is called for the first time.
Back to Top
See Also
TermPositions Interface
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsPayloadAvailable Property

TermPositions IsPayloadAvailable Property Lucene.Net Class Library
Checks if a payload can be loaded at this position.

Payloads can only be loaded once per call to NextPosition .

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsPayloadAvailable { get; }
bool IsPayloadAvailable { get; }
ReadOnly Property IsPayloadAvailable As Boolean
    Get
ReadOnly Property IsPayloadAvailable As Boolean
    Get
property bool IsPayloadAvailable {
    bool get ();
}
property bool IsPayloadAvailable {
    bool get ();
}
Field Value
 true if there is a payload available at this position that can be loaded
See Also
TermPositions Interface
TermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadLength Property

TermPositions PayloadLength Property Lucene.Net Class Library
Returns the length of the payload at the current term position. This is invalid until NextPosition is called for the first time.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int PayloadLength { get; }
int PayloadLength { get; }
ReadOnly Property PayloadLength As Integer
    Get
ReadOnly Property PayloadLength As Integer
    Get
property int PayloadLength {
    int get ();
}
property int PayloadLength {
    int get ();
}
Field Value
 length of the current payload in number of bytes
See Also
TermPositions Interface
TermPositions Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositionVector Interface

TermPositionVector Interface Lucene.Net Class Library
Extends TermFreqVector to provide additional information about positions in which each of the terms is found. A TermPositionVector not necessarily contains both positions and offsets, but at least one of these arrays exists.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface TermPositionVector : ITermFreqVector
public interface TermPositionVector : ITermFreqVector
Public Interface TermPositionVector _
    Inherits ITermFreqVector
Public Interface TermPositionVector _
    Inherits ITermFreqVector
public interface class TermPositionVector : ITermFreqVector
public interface class TermPositionVector : ITermFreqVector
See Also
TermPositionVector Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositionVector Members

TermPositionVector Members Lucene.Net Class Library

The TermPositionVector type exposes the following members.
Methods
 | Name | Description
Public method | GetOffsets | Returns an array of TermVectorOffsetInfo in which the term is found. May return null if offsets have not been stored.
Public method | GetTermFrequencies | Array of term frequencies. Locations of the array correspond one to one to the terms in the array obtained from getTerms method. Each location in the array contains the number of times this term occurs in the document or the document field. (Inherited from ITermFreqVector.)
Public method | GetTermPositions | Returns an array of positions in which the term is found. Terms are identified by the index at which its number appears in the term String array obtained from the indexOf method. May return null if positions have not been stored.
Public method | GetTerms | (Inherited from ITermFreqVector.)
Public method | IndexesOf | Just like indexOf(int) but searches for a number of terms at the same time. Returns an array that has the same size as the number of terms searched for, each slot containing the result of searching for that term number. (Inherited from ITermFreqVector.)
Public method | IndexOf | Return an index in the term numbers array returned from getTerms at which the term with the specified term appears. If this term does not appear in the array, return -1. (Inherited from ITermFreqVector.)
Back to Top
Properties
 | Name | Description
Public property | Field | The IFieldable name. (Inherited from ITermFreqVector.)
Public property | Size | (Inherited from ITermFreqVector.)
Back to Top
See Also
TermPositionVector Interface
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositionVector Methods

TermPositionVector Methods Lucene.Net Class Library
The TermPositionVector type exposes the following members.
Methods
 | Name | Description
Public method | GetOffsets | Returns an array of TermVectorOffsetInfo in which the term is found. May return null if offsets have not been stored.
Public method | GetTermFrequencies | Array of term frequencies. Locations of the array correspond one to one to the terms in the array obtained from getTerms method. Each location in the array contains the number of times this term occurs in the document or the document field. (Inherited from ITermFreqVector.)
Public method | GetTermPositions | Returns an array of positions in which the term is found. Terms are identified by the index at which its number appears in the term String array obtained from the indexOf method. May return null if positions have not been stored.
Public method | GetTerms | (Inherited from ITermFreqVector.)
Public method | IndexesOf | Just like indexOf(int) but searches for a number of terms at the same time. Returns an array that has the same size as the number of terms searched for, each slot containing the result of searching for that term number. (Inherited from ITermFreqVector.)
Public method | IndexOf | Return an index in the term numbers array returned from getTerms at which the term with the specified term appears. If this term does not appear in the array, return -1. (Inherited from ITermFreqVector.)
Back to Top
See Also
TermPositionVector Interface
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetOffsets Method

TermPositionVector GetOffsets Method Lucene.Net Class Library
Returns an array of TermVectorOffsetInfo in which the term is found. May return null if offsets have not been stored.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TermVectorOffsetInfo[] GetOffsets(
    int index
)
TermVectorOffsetInfo[] GetOffsets(
    int index
)
Function GetOffsets ( _
    index As Integer _
) As TermVectorOffsetInfo()
Function GetOffsets ( _
    index As Integer _
) As TermVectorOffsetInfo()
array<TermVectorOffsetInfo>^ GetOffsets(
    int index
)
array<TermVectorOffsetInfo>^ GetOffsets(
    int index
)
Parameters
index
Type:   Online System Int32
The position in the array to get the offsets from

Return Value
 An array of TermVectorOffsetInfo objects or the empty list

See Also
TermPositionVector Interface
TermPositionVector Members
Lucene.Net.Index Namespace
Lucene.Net.Analysis Token
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermPositions Method

TermPositionVector GetTermPositions Method Lucene.Net Class Library
Returns an array of positions in which the term is found. Terms are identified by the index at which its number appears in the term String array obtained from the indexOf method. May return null if positions have not been stored.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int[] GetTermPositions(
    int index
)
int[] GetTermPositions(
    int index
)
Function GetTermPositions ( _
    index As Integer _
) As Integer()
Function GetTermPositions ( _
    index As Integer _
) As Integer()
array<int>^ GetTermPositions(
    int index
)
array<int>^ GetTermPositions(
    int index
)
Parameters
index
Type:   Online System Int32
See Also
TermPositionVector Interface
TermPositionVector Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermPositionVector Properties

TermPositionVector Properties Lucene.Net Class Library
The TermPositionVector type exposes the following members.
Properties
 | Name | Description
Public property | Field | The IFieldable name. (Inherited from ITermFreqVector.)
Public property | Size | (Inherited from ITermFreqVector.)
Back to Top
See Also
TermPositionVector Interface
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorEntry Class

TermVectorEntry Class Lucene.Net Class Library
Convenience class for holding TermVector information.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index TermVectorEntry

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TermVectorEntry
public class TermVectorEntry
Public Class TermVectorEntry
Public Class TermVectorEntry
public ref class TermVectorEntry
public ref class TermVectorEntry
See Also
TermVectorEntry Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorEntry Members

TermVectorEntry Members Lucene.Net Class Library

The TermVectorEntry type exposes the following members.
Constructors
 | Name | Description
Public method | TermVectorEntry | Initializes a new instance of the TermVectorEntry class
Public method | TermVectorEntry(String, String, Int32, TermVectorOffsetInfo , Int32 ) | Initializes a new instance of the TermVectorEntry class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetOffsets |
Public method | GetPositions |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | Field |
Public property | Frequency |
Public property | Term |
Back to Top
See Also
TermVectorEntry Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorEntry Constructor

TermVectorEntry Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TermVectorEntry | Initializes a new instance of the TermVectorEntry class
Public method | TermVectorEntry(String, String, Int32, TermVectorOffsetInfo , Int32 ) | Initializes a new instance of the TermVectorEntry class
Back to Top
See Also
TermVectorEntry Class
TermVectorEntry Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorEntry Constructor

TermVectorEntry Constructor Lucene.Net Class Library
Initializes a new instance of the TermVectorEntry class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TermVectorEntry()
public TermVectorEntry()
Public Sub New
Public Sub New
public:
TermVectorEntry()
public:
TermVectorEntry()
See Also
TermVectorEntry Class
TermVectorEntry Members
TermVectorEntry Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorEntry Constructor (String, String, Int32, TermVectorOffsetInfo[], Int32[])

TermVectorEntry Constructor (String, String, Int32, TermVectorOffsetInfo , Int32 ) Lucene.Net Class Library
Initializes a new instance of the TermVectorEntry class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TermVectorEntry(
    string field,
    string term,
    int frequency,
    TermVectorOffsetInfo[] offsets,
    int[] positions
)
public TermVectorEntry(
    string field,
    string term,
    int frequency,
    TermVectorOffsetInfo[] offsets,
    int[] positions
)
Public Sub New ( _
    field As String, _
    term As String, _
    frequency As Integer, _
    offsets As TermVectorOffsetInfo(), _
    positions As Integer() _
)
Public Sub New ( _
    field As String, _
    term As String, _
    frequency As Integer, _
    offsets As TermVectorOffsetInfo(), _
    positions As Integer() _
)
public:
TermVectorEntry(
    String^ field,
    String^ term,
    int frequency,
    array<TermVectorOffsetInfo>^ offsets,
    array<int>^ positions
)
public:
TermVectorEntry(
    String^ field,
    String^ term,
    int frequency,
    array<TermVectorOffsetInfo>^ offsets,
    array<int>^ positions
)
Parameters
field
Type:   Online System String
term
Type:   Online System String
frequency
Type:   Online System Int32
offsets
Type:  Lucene.Net.Index TermVectorOffsetInfo
positions
Type:    Online System Int32
See Also
TermVectorEntry Class
TermVectorEntry Members
TermVectorEntry Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorEntry Methods

TermVectorEntry Methods Lucene.Net Class Library
The TermVectorEntry type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetOffsets |
Public method | GetPositions |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
TermVectorEntry Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

TermVectorEntry Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
TermVectorEntry Class
TermVectorEntry Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

TermVectorEntry GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
TermVectorEntry Class
TermVectorEntry Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetOffsets Method

TermVectorEntry GetOffsets Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual TermVectorOffsetInfo[] GetOffsets()
public virtual TermVectorOffsetInfo[] GetOffsets()
Public Overridable Function GetOffsets As TermVectorOffsetInfo()
Public Overridable Function GetOffsets As TermVectorOffsetInfo()
public:
virtual array<TermVectorOffsetInfo>^ GetOffsets()
public:
virtual array<TermVectorOffsetInfo>^ GetOffsets()
See Also
TermVectorEntry Class
TermVectorEntry Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPositions Method

TermVectorEntry GetPositions Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int[] GetPositions()
public virtual int[] GetPositions()
Public Overridable Function GetPositions As Integer()
Public Overridable Function GetPositions As Integer()
public:
virtual array<int>^ GetPositions()
public:
virtual array<int>^ GetPositions()
See Also
TermVectorEntry Class
TermVectorEntry Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

TermVectorEntry ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
TermVectorEntry Class
TermVectorEntry Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorEntry Properties

TermVectorEntry Properties Lucene.Net Class Library
The TermVectorEntry type exposes the following members.
Properties
 | Name | Description
Public property | Field |
Public property | Frequency |
Public property | Term |
Back to Top
See Also
TermVectorEntry Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

TermVectorEntry Field Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Field { get; }
public virtual string Field { get; }
Public Overridable ReadOnly Property Field As String
    Get
Public Overridable ReadOnly Property Field As String
    Get
public:
virtual property String^ Field {
    String^ get ();
}
public:
virtual property String^ Field {
    String^ get ();
}
See Also
TermVectorEntry Class
TermVectorEntry Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Frequency Property

TermVectorEntry Frequency Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Frequency { get; internal set; }
public virtual int Frequency { get; internal set; }
Public Overridable Property Frequency As Integer
    Get
    Friend Set
Public Overridable Property Frequency As Integer
    Get
    Friend Set
public:
virtual property int Frequency {
    int get ();
    internal: void set (int value);
}
public:
virtual property int Frequency {
    int get ();
    internal: void set (int value);
}
See Also
TermVectorEntry Class
TermVectorEntry Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Property

TermVectorEntry Term Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Term { get; }
public virtual string Term { get; }
Public Overridable ReadOnly Property Term As String
    Get
Public Overridable ReadOnly Property Term As String
    Get
public:
virtual property String^ Term {
    String^ get ();
}
public:
virtual property String^ Term {
    String^ get ();
}
See Also
TermVectorEntry Class
TermVectorEntry Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorEntryFreqSortedComparator Class

TermVectorEntryFreqSortedComparator Class Lucene.Net Class Library
Compares TermVectorEntrys first by frequency and then by the term (case-sensitive)
Inheritance Hierarchy
Online System Object
Lucene.Net.Index TermVectorEntryFreqSortedComparator

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TermVectorEntryFreqSortedComparator : IComparer<TermVectorEntry>
public class TermVectorEntryFreqSortedComparator : IComparer<TermVectorEntry>
Public Class TermVectorEntryFreqSortedComparator _
    Implements IComparer(Of TermVectorEntry)
Public Class TermVectorEntryFreqSortedComparator _
    Implements IComparer(Of TermVectorEntry)
public ref class TermVectorEntryFreqSortedComparator : IComparer<TermVectorEntry^>
public ref class TermVectorEntryFreqSortedComparator : IComparer<TermVectorEntry^>
See Also
TermVectorEntryFreqSortedComparator Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorEntryFreqSortedComparator Members

TermVectorEntryFreqSortedComparator Members Lucene.Net Class Library

The TermVectorEntryFreqSortedComparator type exposes the following members.
Constructors
 | Name | Description
Public method | TermVectorEntryFreqSortedComparator | Initializes a new instance of the TermVectorEntryFreqSortedComparator class
Back to Top
Methods
 | Name | Description
Public method | Compare |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TermVectorEntryFreqSortedComparator Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorEntryFreqSortedComparator Constructor

TermVectorEntryFreqSortedComparator Constructor Lucene.Net Class Library
Initializes a new instance of the TermVectorEntryFreqSortedComparator class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TermVectorEntryFreqSortedComparator()
public TermVectorEntryFreqSortedComparator()
Public Sub New
Public Sub New
public:
TermVectorEntryFreqSortedComparator()
public:
TermVectorEntryFreqSortedComparator()
See Also
TermVectorEntryFreqSortedComparator Class
TermVectorEntryFreqSortedComparator Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorEntryFreqSortedComparator Methods

TermVectorEntryFreqSortedComparator Methods Lucene.Net Class Library
The TermVectorEntryFreqSortedComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TermVectorEntryFreqSortedComparator Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Method

TermVectorEntryFreqSortedComparator Compare Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Compare(
    TermVectorEntry entry,
    TermVectorEntry entry1
)
public virtual int Compare(
    TermVectorEntry entry,
    TermVectorEntry entry1
)
Public Overridable Function Compare ( _
    entry As TermVectorEntry, _
    entry1 As TermVectorEntry _
) As Integer
Public Overridable Function Compare ( _
    entry As TermVectorEntry, _
    entry1 As TermVectorEntry _
) As Integer
public:
virtual int Compare(
    TermVectorEntry^ entry,
    TermVectorEntry^ entry1
)
public:
virtual int Compare(
    TermVectorEntry^ entry,
    TermVectorEntry^ entry1
)
Parameters
entry
Type: Lucene.Net.Index TermVectorEntry
entry1
Type: Lucene.Net.Index TermVectorEntry
Implements
  Online IComparer T  Compare(T, T)
See Also
TermVectorEntryFreqSortedComparator Class
TermVectorEntryFreqSortedComparator Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorMapper Class

TermVectorMapper Class Lucene.Net Class Library
The TermVectorMapper can be used to map Term Vectors into your own structure instead of the parallel array structure used by GetTermFreqVector(Int32, String).

It is up to the implementation to make sure it is thread-safe.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index TermVectorMapper
Lucene.Net.Index FieldSortedTermVectorMapper
Lucene.Net.Index PositionBasedTermVectorMapper
Lucene.Net.Index SortedTermVectorMapper

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class TermVectorMapper
public abstract class TermVectorMapper
Public MustInherit Class TermVectorMapper
Public MustInherit Class TermVectorMapper
public ref class TermVectorMapper abstract
public ref class TermVectorMapper abstract
See Also
TermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorMapper Members

TermVectorMapper Members Lucene.Net Class Library

The TermVectorMapper type exposes the following members.
Constructors
 | Name | Description
Protected method | TermVectorMapper | Initializes a new instance of the TermVectorMapper class
Protected method | TermVectorMapper(Boolean, Boolean) | Initializes a new instance of the TermVectorMapper class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Map | Map the Term Vector information into your own structure
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations.
Public method | SetExpectations | Tell the mapper what to expect in regards to field, number of terms, offset and position storage. This method will be called once before retrieving the vector for a field. This method will be called before Map(String, Int32, TermVectorOffsetInfo , Int32 ).
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | IsIgnoringOffsets |
Public property | IsIgnoringPositions | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored.
Back to Top
See Also
TermVectorMapper Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorMapper Constructor

TermVectorMapper Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Protected method | TermVectorMapper | Initializes a new instance of the TermVectorMapper class
Protected method | TermVectorMapper(Boolean, Boolean) | Initializes a new instance of the TermVectorMapper class
Back to Top
See Also
TermVectorMapper Class
TermVectorMapper Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorMapper Constructor

TermVectorMapper Constructor Lucene.Net Class Library
Initializes a new instance of the TermVectorMapper class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TermVectorMapper()
protected TermVectorMapper()
Protected Sub New
Protected Sub New
protected:
TermVectorMapper()
protected:
TermVectorMapper()
See Also
TermVectorMapper Class
TermVectorMapper Members
TermVectorMapper Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorMapper Constructor (Boolean, Boolean)

TermVectorMapper Constructor (Boolean, Boolean) Lucene.Net Class Library
Initializes a new instance of the TermVectorMapper class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets
)
protected TermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets
)
Protected Sub New ( _
    ignoringPositions As Boolean, _
    ignoringOffsets As Boolean _
)
Protected Sub New ( _
    ignoringPositions As Boolean, _
    ignoringOffsets As Boolean _
)
protected:
TermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets
)
protected:
TermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets
)
Parameters
ignoringPositions
Type:   Online System Boolean
true if this mapper should tell Lucene to ignore positions even if they are stored

ignoringOffsets
Type:   Online System Boolean
similar to ignoringPositions

See Also
TermVectorMapper Class
TermVectorMapper Members
TermVectorMapper Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorMapper Methods

TermVectorMapper Methods Lucene.Net Class Library
The TermVectorMapper type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Map | Map the Term Vector information into your own structure
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations.
Public method | SetExpectations | Tell the mapper what to expect in regards to field, number of terms, offset and position storage. This method will be called once before retrieving the vector for a field. This method will be called before Map(String, Int32, TermVectorOffsetInfo , Int32 ).
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TermVectorMapper Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Map Method

TermVectorMapper Map Method Lucene.Net Class Library
Map the Term Vector information into your own structure

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Map(
    string term,
    int frequency,
    TermVectorOffsetInfo[] offsets,
    int[] positions
)
public abstract void Map(
    string term,
    int frequency,
    TermVectorOffsetInfo[] offsets,
    int[] positions
)
Public MustOverride Sub Map ( _
    term As String, _
    frequency As Integer, _
    offsets As TermVectorOffsetInfo(), _
    positions As Integer() _
)
Public MustOverride Sub Map ( _
    term As String, _
    frequency As Integer, _
    offsets As TermVectorOffsetInfo(), _
    positions As Integer() _
)
public:
virtual void Map(
    String^ term,
    int frequency,
    array<TermVectorOffsetInfo>^ offsets,
    array<int>^ positions
) abstract
public:
virtual void Map(
    String^ term,
    int frequency,
    array<TermVectorOffsetInfo>^ offsets,
    array<int>^ positions
) abstract
Parameters
term
Type:   Online System String
The term to add to the vector

frequency
Type:   Online System Int32
The frequency of the term in the document

offsets
Type:  Lucene.Net.Index TermVectorOffsetInfo
null if the offset is not specified, otherwise the offset into the field of the term

positions
Type:    Online System Int32
null if the position is not specified, otherwise the position in the field of the term

See Also
TermVectorMapper Class
TermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetDocumentNumber Method

TermVectorMapper SetDocumentNumber Method Lucene.Net Class Library
Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader.

Default implementation IGNORES the document number. Override if your implementation needs the document number.

NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetDocumentNumber(
    int documentNumber
)
public virtual void SetDocumentNumber(
    int documentNumber
)
Public Overridable Sub SetDocumentNumber ( _
    documentNumber As Integer _
)
Public Overridable Sub SetDocumentNumber ( _
    documentNumber As Integer _
)
public:
virtual void SetDocumentNumber(
    int documentNumber
)
public:
virtual void SetDocumentNumber(
    int documentNumber
)
Parameters
documentNumber
Type:   Online System Int32
index of document currently being mapped

See Also
TermVectorMapper Class
TermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetExpectations Method

TermVectorMapper SetExpectations Method Lucene.Net Class Library
Tell the mapper what to expect in regards to field, number of terms, offset and position storage. This method will be called once before retrieving the vector for a field. This method will be called before Map(String, Int32, TermVectorOffsetInfo , Int32 ).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void SetExpectations(
    string field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
)
public abstract void SetExpectations(
    string field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
)
Public MustOverride Sub SetExpectations ( _
    field As String, _
    numTerms As Integer, _
    storeOffsets As Boolean, _
    storePositions As Boolean _
)
Public MustOverride Sub SetExpectations ( _
    field As String, _
    numTerms As Integer, _
    storeOffsets As Boolean, _
    storePositions As Boolean _
)
public:
virtual void SetExpectations(
    String^ field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
) abstract
public:
virtual void SetExpectations(
    String^ field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
) abstract
Parameters
field
Type:   Online System String
The field the vector is for

numTerms
Type:   Online System Int32
The number of terms that need to be mapped

storeOffsets
Type:   Online System Boolean
true if the mapper should expect offset information

storePositions
Type:   Online System Boolean
true if the mapper should expect positions info

See Also
TermVectorMapper Class
TermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorMapper Properties

TermVectorMapper Properties Lucene.Net Class Library
The TermVectorMapper type exposes the following members.
Properties
 | Name | Description
Public property | IsIgnoringOffsets |
Public property | IsIgnoringPositions | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored.
Back to Top
See Also
TermVectorMapper Class
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsIgnoringOffsets Property

TermVectorMapper IsIgnoringOffsets Property Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsIgnoringOffsets { get; }
public virtual bool IsIgnoringOffsets { get; }
Public Overridable ReadOnly Property IsIgnoringOffsets As Boolean
    Get
Public Overridable ReadOnly Property IsIgnoringOffsets As Boolean
    Get
public:
virtual property bool IsIgnoringOffsets {
    bool get ();
}
public:
virtual property bool IsIgnoringOffsets {
    bool get ();
}
Field Value
 false
See Also
TermVectorMapper Class
TermVectorMapper Members
Lucene.Net.Index Namespace
 Same principal as , but applied to offsets.  false by default.

Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsIgnoringPositions Property

TermVectorMapper IsIgnoringPositions Property Lucene.Net Class Library
Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsIgnoringPositions { get; }
public virtual bool IsIgnoringPositions { get; }
Public Overridable ReadOnly Property IsIgnoringPositions As Boolean
    Get
Public Overridable ReadOnly Property IsIgnoringPositions As Boolean
    Get
public:
virtual property bool IsIgnoringPositions {
    bool get ();
}
public:
virtual property bool IsIgnoringPositions {
    bool get ();
}
Field Value
 false
See Also
TermVectorMapper Class
TermVectorMapper Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorOffsetInfo Structure

TermVectorOffsetInfo Structure Lucene.Net Class Library
The TermVectorOffsetInfo class holds information pertaining to a Term in a TermPositionVector's offset information. This offset information is the character offset as set during the Analysis phase (and thus may not be the actual offset in the original content).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct TermVectorOffsetInfo : IEquatable<TermVectorOffsetInfo>
[SerializableAttribute]
public struct TermVectorOffsetInfo : IEquatable<TermVectorOffsetInfo>
<SerializableAttribute> _
Public Structure TermVectorOffsetInfo _
    Implements IEquatable(Of TermVectorOffsetInfo)
<SerializableAttribute> _
Public Structure TermVectorOffsetInfo _
    Implements IEquatable(Of TermVectorOffsetInfo)
[SerializableAttribute]
public value class TermVectorOffsetInfo : IEquatable<TermVectorOffsetInfo>
[SerializableAttribute]
public value class TermVectorOffsetInfo : IEquatable<TermVectorOffsetInfo>
See Also
TermVectorOffsetInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorOffsetInfo Members

TermVectorOffsetInfo Members Lucene.Net Class Library

The TermVectorOffsetInfo type exposes the following members.
Constructors
 | Name | Description
Public method | TermVectorOffsetInfo | Initializes a new instance of the TermVectorOffsetInfo class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(TermVectorOffsetInfo) |
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Operators
Name | Description
Equality |
Inequality |
Back to Top
Fields
Name | Description
EMPTY_OFFSET_INFO | Convenience declaration when creating a TermPositionVector that stores only position information.
Null |
Back to Top
Properties
 | Name | Description
Public property | EndOffset | The accessor for the ending offset for the term
Public property | StartOffset | The accessor for the starting offset of the term.
Back to Top
See Also
TermVectorOffsetInfo Structure
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorOffsetInfo Constructor

TermVectorOffsetInfo Constructor Lucene.Net Class Library
Initializes a new instance of the TermVectorOffsetInfo class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TermVectorOffsetInfo(
    int startOffset,
    int endOffset
)
public TermVectorOffsetInfo(
    int startOffset,
    int endOffset
)
Public Sub New ( _
    startOffset As Integer, _
    endOffset As Integer _
)
Public Sub New ( _
    startOffset As Integer, _
    endOffset As Integer _
)
public:
TermVectorOffsetInfo(
    int startOffset,
    int endOffset
)
public:
TermVectorOffsetInfo(
    int startOffset,
    int endOffset
)
Parameters
startOffset
Type:   Online System Int32
endOffset
Type:   Online System Int32
See Also
TermVectorOffsetInfo Structure
TermVectorOffsetInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorOffsetInfo Fields

TermVectorOffsetInfo Fields Lucene.Net Class Library
The TermVectorOffsetInfo type exposes the following members.
Fields
Name | Description
EMPTY_OFFSET_INFO | Convenience declaration when creating a TermPositionVector that stores only position information.
Null |
Back to Top
See Also
TermVectorOffsetInfo Structure
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EMPTY_OFFSET_INFO Field

TermVectorOffsetInfo EMPTY_OFFSET_INFO Field Lucene.Net Class Library
Convenience declaration when creating a TermPositionVector that stores only position information.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
public static readonly TermVectorOffsetInfo[] EMPTY_OFFSET_INFO
[NonSerializedAttribute]
public static readonly TermVectorOffsetInfo[] EMPTY_OFFSET_INFO
<NonSerializedAttribute> _
Public Shared ReadOnly EMPTY_OFFSET_INFO As TermVectorOffsetInfo()
<NonSerializedAttribute> _
Public Shared ReadOnly EMPTY_OFFSET_INFO As TermVectorOffsetInfo()
public:
[NonSerializedAttribute]
static initonly array<TermVectorOffsetInfo>^ EMPTY_OFFSET_INFO
public:
[NonSerializedAttribute]
static initonly array<TermVectorOffsetInfo>^ EMPTY_OFFSET_INFO
See Also
TermVectorOffsetInfo Structure
TermVectorOffsetInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Null Field

TermVectorOffsetInfo Null Field Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
public static readonly TermVectorOffsetInfo Null
[NonSerializedAttribute]
public static readonly TermVectorOffsetInfo Null
<NonSerializedAttribute> _
Public Shared ReadOnly Null As TermVectorOffsetInfo
<NonSerializedAttribute> _
Public Shared ReadOnly Null As TermVectorOffsetInfo
public:
[NonSerializedAttribute]
static initonly TermVectorOffsetInfo Null
public:
[NonSerializedAttribute]
static initonly TermVectorOffsetInfo Null
See Also
TermVectorOffsetInfo Structure
TermVectorOffsetInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorOffsetInfo Methods

TermVectorOffsetInfo Methods Lucene.Net Class Library
The TermVectorOffsetInfo type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(TermVectorOffsetInfo) |
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
See Also
TermVectorOffsetInfo Structure
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

TermVectorOffsetInfo Equals Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(TermVectorOffsetInfo) |
Back to Top
See Also
TermVectorOffsetInfo Structure
TermVectorOffsetInfo Members
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method (Object)

TermVectorOffsetInfo Equals Method (Object) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
TermVectorOffsetInfo Structure
TermVectorOffsetInfo Members
Equals Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method (TermVectorOffsetInfo)

TermVectorOffsetInfo Equals Method (TermVectorOffsetInfo) Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    TermVectorOffsetInfo other
)
public bool Equals(
    TermVectorOffsetInfo other
)
Public Function Equals ( _
    other As TermVectorOffsetInfo _
) As Boolean
Public Function Equals ( _
    other As TermVectorOffsetInfo _
) As Boolean
public:
virtual bool Equals(
    TermVectorOffsetInfo other
) sealed
public:
virtual bool Equals(
    TermVectorOffsetInfo other
) sealed
Parameters
other
Type: Lucene.Net.Index TermVectorOffsetInfo
Implements
  Online IEquatable T  Equals(T)
See Also
TermVectorOffsetInfo Structure
TermVectorOffsetInfo Members
Equals Overload
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

TermVectorOffsetInfo GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
TermVectorOffsetInfo Structure
TermVectorOffsetInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorOffsetInfo Operators

TermVectorOffsetInfo Operators Lucene.Net Class Library
The TermVectorOffsetInfo type exposes the following members.
Operators
Name | Description
Equality |
Inequality |
Back to Top
See Also
TermVectorOffsetInfo Structure
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equality Operator

TermVectorOffsetInfo Equality Operator Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    TermVectorOffsetInfo left,
    Object right
)
public static bool operator ==(
    TermVectorOffsetInfo left,
    Object right
)
Public Shared Operator = ( _
    left As TermVectorOffsetInfo, _
    right As Object _
) As Boolean
Public Shared Operator = ( _
    left As TermVectorOffsetInfo, _
    right As Object _
) As Boolean
public:
static bool operator ==(
    TermVectorOffsetInfo left,
    Object^ right
)
public:
static bool operator ==(
    TermVectorOffsetInfo left,
    Object^ right
)
Parameters
left
Type: Lucene.Net.Index TermVectorOffsetInfo
right
Type:   Online System Object
See Also
TermVectorOffsetInfo Structure
TermVectorOffsetInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Inequality Operator

TermVectorOffsetInfo Inequality Operator Lucene.Net Class Library

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    TermVectorOffsetInfo left,
    Object right
)
public static bool operator !=(
    TermVectorOffsetInfo left,
    Object right
)
Public Shared Operator <> ( _
    left As TermVectorOffsetInfo, _
    right As Object _
) As Boolean
Public Shared Operator <> ( _
    left As TermVectorOffsetInfo, _
    right As Object _
) As Boolean
public:
static bool operator !=(
    TermVectorOffsetInfo left,
    Object^ right
)
public:
static bool operator !=(
    TermVectorOffsetInfo left,
    Object^ right
)
Parameters
left
Type: Lucene.Net.Index TermVectorOffsetInfo
right
Type:   Online System Object
See Also
TermVectorOffsetInfo Structure
TermVectorOffsetInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermVectorOffsetInfo Properties

TermVectorOffsetInfo Properties Lucene.Net Class Library
The TermVectorOffsetInfo type exposes the following members.
Properties
 | Name | Description
Public property | EndOffset | The accessor for the ending offset for the term
Public property | StartOffset | The accessor for the starting offset of the term.
Back to Top
See Also
TermVectorOffsetInfo Structure
Lucene.Net.Index Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EndOffset Property

TermVectorOffsetInfo EndOffset Property Lucene.Net Class Library
The accessor for the ending offset for the term

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int EndOffset { get; set; }
public int EndOffset { get; set; }
Public Property EndOffset As Integer
    Get
    Set
Public Property EndOffset As Integer
    Get
    Set
public:
property int EndOffset {
    int get ();
    void set (int value);
}
public:
property int EndOffset {
    int get ();
    void set (int value);
}
Field Value
 The offset
See Also
TermVectorOffsetInfo Structure
TermVectorOffsetInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StartOffset Property

TermVectorOffsetInfo StartOffset Property Lucene.Net Class Library
The accessor for the starting offset of the term.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int StartOffset { get; set; }
public int StartOffset { get; set; }
Public Property StartOffset As Integer
    Get
    Set
Public Property StartOffset As Integer
    Get
    Set
public:
property int StartOffset {
    int get ();
    void set (int value);
}
public:
property int StartOffset {
    int get ();
    void set (int value);
}
Field Value
 The offset
See Also
TermVectorOffsetInfo Structure
TermVectorOffsetInfo Members
Lucene.Net.Index Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lucene.Net.Messages Namespace

Lucene.Net.Messages Namespace Lucene.Net Class Library
Classes
 | Class | Description
Public class | MessageImpl | Default implementation of Message interface. For Native Language Support (NLS), system of software internationalization.
Public class | NLS | MessageBundles classes extend this class, to implement a bundle. For Native Language Support (NLS), system of software internationalization. This interface is similar to the NLS class in eclipse.osgi.util.NLS class - initializeMessages() method resets the values of all static strings, should only be called by classes that extend from NLS (see TestMessages.java for reference) - performs validation of all message in a bundle, at class load time - performs per message validation at runtime - see NLSTest.java for usage reference MessageBundle classes may subclass this type.
Interfaces
 | Interface | Description
Public interface | INLSException | Interface that exceptions should implement to support lazy loading of messages. For Native Language Support (NLS), system of software internationalization. This Interface should be implemented by all exceptions that require translation
Public interface | Message | Message Interface for a lazy loading. For Native Language Support (NLS), system of software internationalization.
Public interface | NLS IPriviligedAction |

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


INLSException Interface

INLSException Interface Lucene.Net Class Library
Interface that exceptions should implement to support lazy loading of messages. For Native Language Support (NLS), system of software internationalization. This Interface should be implemented by all exceptions that require translation

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface INLSException
public interface INLSException
Public Interface INLSException
Public Interface INLSException
public interface class INLSException
public interface class INLSException
See Also
INLSException Members
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


INLSException Members

INLSException Members Lucene.Net Class Library

The INLSException type exposes the following members.
Properties
 | Name | Description
Public property | MessageObject |
Back to Top
See Also
INLSException Interface
Lucene.Net.Messages Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


INLSException Properties

INLSException Properties Lucene.Net Class Library
The INLSException type exposes the following members.
Properties
 | Name | Description
Public property | MessageObject |
Back to Top
See Also
INLSException Interface
Lucene.Net.Messages Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MessageObject Property

INLSException MessageObject Property Lucene.Net Class Library

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Message MessageObject { get; }
Message MessageObject { get; }
ReadOnly Property MessageObject As Message
    Get
ReadOnly Property MessageObject As Message
    Get
property Message^ MessageObject {
    Message^ get ();
}
property Message^ MessageObject {
    Message^ get ();
}
Field Value
 a instance of a class that implements the Message interface
See Also
INLSException Interface
INLSException Members
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Message Interface

Message Interface Lucene.Net Class Library
Message Interface for a lazy loading. For Native Language Support (NLS), system of software internationalization.

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface Message
public interface Message
Public Interface Message
Public Interface Message
public interface class Message
public interface class Message
See Also
Message Members
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Message Members

Message Members Lucene.Net Class Library

The Message type exposes the following members.
Methods
 | Name | Description
Public method | GetArguments |
Public method | GetLocalizedMessage |
Public method | GetLocalizedMessage(CultureInfo) |
Back to Top
Properties
 | Name | Description
Public property | Key |
Back to Top
See Also
Message Interface
Lucene.Net.Messages Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Message Methods

Message Methods Lucene.Net Class Library
The Message type exposes the following members.
Methods
 | Name | Description
Public method | GetArguments |
Public method | GetLocalizedMessage |
Public method | GetLocalizedMessage(CultureInfo) |
Back to Top
See Also
Message Interface
Lucene.Net.Messages Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetArguments Method

Message GetArguments Method Lucene.Net Class Library

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object[] GetArguments()
Object[] GetArguments()
Function GetArguments As Object()
Function GetArguments As Object()
array<Object^>^ GetArguments()
array<Object^>^ GetArguments()
See Also
Message Interface
Message Members
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLocalizedMessage Method

Message GetLocalizedMessage Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetLocalizedMessage |
Public method | GetLocalizedMessage(CultureInfo) |
Back to Top
See Also
Message Interface
Message Members
Lucene.Net.Messages Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLocalizedMessage Method

Message GetLocalizedMessage Method Lucene.Net Class Library

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string GetLocalizedMessage()
string GetLocalizedMessage()
Function GetLocalizedMessage As String
Function GetLocalizedMessage As String
String^ GetLocalizedMessage()
String^ GetLocalizedMessage()
See Also
Message Interface
Message Members
GetLocalizedMessage Overload
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLocalizedMessage Method (CultureInfo)

Message GetLocalizedMessage Method (CultureInfo) Lucene.Net Class Library

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string GetLocalizedMessage(
    CultureInfo locale
)
string GetLocalizedMessage(
    CultureInfo locale
)
Function GetLocalizedMessage ( _
    locale As CultureInfo _
) As String
Function GetLocalizedMessage ( _
    locale As CultureInfo _
) As String
String^ GetLocalizedMessage(
    CultureInfo^ locale
)
String^ GetLocalizedMessage(
    CultureInfo^ locale
)
Parameters
locale
Type:   Online System.Globalization CultureInfo
See Also
Message Interface
Message Members
GetLocalizedMessage Overload
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Message Properties

Message Properties Lucene.Net Class Library
The Message type exposes the following members.
Properties
 | Name | Description
Public property | Key |
Back to Top
See Also
Message Interface
Lucene.Net.Messages Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Key Property

Message Key Property Lucene.Net Class Library

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Key { get; }
string Key { get; }
ReadOnly Property Key As String
    Get
ReadOnly Property Key As String
    Get
property String^ Key {
    String^ get ();
}
property String^ Key {
    String^ get ();
}
See Also
Message Interface
Message Members
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MessageImpl Class

MessageImpl Class Lucene.Net Class Library
Default implementation of Message interface. For Native Language Support (NLS), system of software internationalization.
Inheritance Hierarchy
Online System Object
Lucene.Net.Messages MessageImpl

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MessageImpl : Message
[SerializableAttribute]
public class MessageImpl : Message
<SerializableAttribute> _
Public Class MessageImpl _
    Implements Message
<SerializableAttribute> _
Public Class MessageImpl _
    Implements Message
[SerializableAttribute]
public ref class MessageImpl : Message
[SerializableAttribute]
public ref class MessageImpl : Message
See Also
MessageImpl Members
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MessageImpl Members

MessageImpl Members Lucene.Net Class Library

The MessageImpl type exposes the following members.
Constructors
 | Name | Description
Public method | MessageImpl(String) | Initializes a new instance of the MessageImpl class
Public method | MessageImpl(String, Object ) | Initializes a new instance of the MessageImpl class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetArguments |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLocalizedMessage |
Public method | GetLocalizedMessage(CultureInfo) |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | Key |
Back to Top
See Also
MessageImpl Class
Lucene.Net.Messages Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MessageImpl Constructor

MessageImpl Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | MessageImpl(String) | Initializes a new instance of the MessageImpl class
Public method | MessageImpl(String, Object ) | Initializes a new instance of the MessageImpl class
Back to Top
See Also
MessageImpl Class
MessageImpl Members
Lucene.Net.Messages Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MessageImpl Constructor (String)

MessageImpl Constructor (String) Lucene.Net Class Library
Initializes a new instance of the MessageImpl class

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageImpl(
    string key
)
public MessageImpl(
    string key
)
Public Sub New ( _
    key As String _
)
Public Sub New ( _
    key As String _
)
public:
MessageImpl(
    String^ key
)
public:
MessageImpl(
    String^ key
)
Parameters
key
Type:   Online System String
See Also
MessageImpl Class
MessageImpl Members
MessageImpl Overload
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MessageImpl Constructor (String, Object[])

MessageImpl Constructor (String, Object ) Lucene.Net Class Library
Initializes a new instance of the MessageImpl class

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageImpl(
    string key,
    params Object[] args
)
public MessageImpl(
    string key,
    params Object[] args
)
Public Sub New ( _
    key As String, _
    ParamArray args As Object() _
)
Public Sub New ( _
    key As String, _
    ParamArray args As Object() _
)
public:
MessageImpl(
    String^ key,
    ... array<Object^>^ args
)
public:
MessageImpl(
    String^ key,
    ... array<Object^>^ args
)
Parameters
key
Type:   Online System String
args
Type:    Online System Object
See Also
MessageImpl Class
MessageImpl Members
MessageImpl Overload
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MessageImpl Methods

MessageImpl Methods Lucene.Net Class Library
The MessageImpl type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetArguments |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLocalizedMessage |
Public method | GetLocalizedMessage(CultureInfo) |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
MessageImpl Class
Lucene.Net.Messages Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetArguments Method

MessageImpl GetArguments Method Lucene.Net Class Library

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object[] GetArguments()
public virtual Object[] GetArguments()
Public Overridable Function GetArguments As Object()
Public Overridable Function GetArguments As Object()
public:
virtual array<Object^>^ GetArguments()
public:
virtual array<Object^>^ GetArguments()
Implements
Message GetArguments
See Also
MessageImpl Class
MessageImpl Members
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLocalizedMessage Method

MessageImpl GetLocalizedMessage Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetLocalizedMessage |
Public method | GetLocalizedMessage(CultureInfo) |
Back to Top
See Also
MessageImpl Class
MessageImpl Members
Lucene.Net.Messages Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLocalizedMessage Method

MessageImpl GetLocalizedMessage Method Lucene.Net Class Library

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string GetLocalizedMessage()
public virtual string GetLocalizedMessage()
Public Overridable Function GetLocalizedMessage As String
Public Overridable Function GetLocalizedMessage As String
public:
virtual String^ GetLocalizedMessage()
public:
virtual String^ GetLocalizedMessage()
Implements
Message GetLocalizedMessage
See Also
MessageImpl Class
MessageImpl Members
GetLocalizedMessage Overload
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLocalizedMessage Method (CultureInfo)

MessageImpl GetLocalizedMessage Method (CultureInfo) Lucene.Net Class Library

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string GetLocalizedMessage(
    CultureInfo locale
)
public virtual string GetLocalizedMessage(
    CultureInfo locale
)
Public Overridable Function GetLocalizedMessage ( _
    locale As CultureInfo _
) As String
Public Overridable Function GetLocalizedMessage ( _
    locale As CultureInfo _
) As String
public:
virtual String^ GetLocalizedMessage(
    CultureInfo^ locale
)
public:
virtual String^ GetLocalizedMessage(
    CultureInfo^ locale
)
Parameters
locale
Type:   Online System.Globalization CultureInfo
Implements
Message GetLocalizedMessage(CultureInfo)
See Also
MessageImpl Class
MessageImpl Members
GetLocalizedMessage Overload
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

MessageImpl ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
MessageImpl Class
MessageImpl Members
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MessageImpl Properties

MessageImpl Properties Lucene.Net Class Library
The MessageImpl type exposes the following members.
Properties
 | Name | Description
Public property | Key |
Back to Top
See Also
MessageImpl Class
Lucene.Net.Messages Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Key Property

MessageImpl Key Property Lucene.Net Class Library

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Key { get; }
public virtual string Key { get; }
Public Overridable ReadOnly Property Key As String
    Get
Public Overridable ReadOnly Property Key As String
    Get
public:
virtual property String^ Key {
    String^ get ();
}
public:
virtual property String^ Key {
    String^ get ();
}
Implements
Message Key
See Also
MessageImpl Class
MessageImpl Members
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NLS Class

NLS Class Lucene.Net Class Library
MessageBundles classes extend this class, to implement a bundle. For Native Language Support (NLS), system of software internationalization. This interface is similar to the NLS class in eclipse.osgi.util.NLS class - initializeMessages() method resets the values of all static strings, should only be called by classes that extend from NLS (see TestMessages.java for reference) - performs validation of all message in a bundle, at class load time - performs per message validation at runtime - see NLSTest.java for usage reference MessageBundle classes may subclass this type.
Inheritance Hierarchy
Online System Object
Lucene.Net.Messages NLS

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NLS
public class NLS
Public Class NLS
Public Class NLS
public ref class NLS
public ref class NLS
See Also
NLS Members
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NLS Members

NLS Members Lucene.Net Class Library

The NLS type exposes the following members.
Constructors
 | Name | Description
Protected method | NLS | Initializes a new instance of the NLS class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
 | GetLocalizedMessage(String) |
 | GetLocalizedMessage(String, CultureInfo) |
 | GetLocalizedMessage(String, Object ) |
 | GetLocalizedMessage(String, CultureInfo, Object ) |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | InitializeMessages T | Initialize a given class with the message bundle Keys Should be called from a class that extends NLS in a static block at class load time.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NLS Class
Lucene.Net.Messages Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NLS Constructor

NLS Constructor Lucene.Net Class Library
Initializes a new instance of the NLS class

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected NLS()
protected NLS()
Protected Sub New
Protected Sub New
protected:
NLS()
protected:
NLS()
See Also
NLS Class
NLS Members
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NLS Methods

NLS Methods Lucene.Net Class Library
The NLS type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
 | GetLocalizedMessage(String) |
 | GetLocalizedMessage(String, CultureInfo) |
 | GetLocalizedMessage(String, Object ) |
 | GetLocalizedMessage(String, CultureInfo, Object ) |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | InitializeMessages T | Initialize a given class with the message bundle Keys Should be called from a class that extends NLS in a static block at class load time.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NLS Class
Lucene.Net.Messages Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLocalizedMessage Method

NLS GetLocalizedMessage Method Lucene.Net Class Library
Overload List
Name | Description
GetLocalizedMessage(String) |
GetLocalizedMessage(String, CultureInfo) |
GetLocalizedMessage(String, Object ) |
GetLocalizedMessage(String, CultureInfo, Object ) |
Back to Top
See Also
NLS Class
NLS Members
Lucene.Net.Messages Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLocalizedMessage Method (String)

NLS GetLocalizedMessage Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetLocalizedMessage(
    string key
)
public static string GetLocalizedMessage(
    string key
)
Public Shared Function GetLocalizedMessage ( _
    key As String _
) As String
Public Shared Function GetLocalizedMessage ( _
    key As String _
) As String
public:
static String^ GetLocalizedMessage(
    String^ key
)
public:
static String^ GetLocalizedMessage(
    String^ key
)
Parameters
key
Type:   Online System String
See Also
NLS Class
NLS Members
GetLocalizedMessage Overload
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLocalizedMessage Method (String, CultureInfo)

NLS GetLocalizedMessage Method (String, CultureInfo) Lucene.Net Class Library

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetLocalizedMessage(
    string key,
    CultureInfo locale
)
public static string GetLocalizedMessage(
    string key,
    CultureInfo locale
)
Public Shared Function GetLocalizedMessage ( _
    key As String, _
    locale As CultureInfo _
) As String
Public Shared Function GetLocalizedMessage ( _
    key As String, _
    locale As CultureInfo _
) As String
public:
static String^ GetLocalizedMessage(
    String^ key,
    CultureInfo^ locale
)
public:
static String^ GetLocalizedMessage(
    String^ key,
    CultureInfo^ locale
)
Parameters
key
Type:   Online System String
locale
Type:   Online System.Globalization CultureInfo
See Also
NLS Class
NLS Members
GetLocalizedMessage Overload
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLocalizedMessage Method (String, Object[])

NLS GetLocalizedMessage Method (String, Object ) Lucene.Net Class Library

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetLocalizedMessage(
    string key,
    params Object[] args
)
public static string GetLocalizedMessage(
    string key,
    params Object[] args
)
Public Shared Function GetLocalizedMessage ( _
    key As String, _
    ParamArray args As Object() _
) As String
Public Shared Function GetLocalizedMessage ( _
    key As String, _
    ParamArray args As Object() _
) As String
public:
static String^ GetLocalizedMessage(
    String^ key,
    ... array<Object^>^ args
)
public:
static String^ GetLocalizedMessage(
    String^ key,
    ... array<Object^>^ args
)
Parameters
key
Type:   Online System String
args
Type:    Online System Object
See Also
NLS Class
NLS Members
GetLocalizedMessage Overload
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLocalizedMessage Method (String, CultureInfo, Object[])

NLS GetLocalizedMessage Method (String, CultureInfo, Object ) Lucene.Net Class Library

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetLocalizedMessage(
    string key,
    CultureInfo locale,
    params Object[] args
)
public static string GetLocalizedMessage(
    string key,
    CultureInfo locale,
    params Object[] args
)
Public Shared Function GetLocalizedMessage ( _
    key As String, _
    locale As CultureInfo, _
    ParamArray args As Object() _
) As String
Public Shared Function GetLocalizedMessage ( _
    key As String, _
    locale As CultureInfo, _
    ParamArray args As Object() _
) As String
public:
static String^ GetLocalizedMessage(
    String^ key,
    CultureInfo^ locale,
    ... array<Object^>^ args
)
public:
static String^ GetLocalizedMessage(
    String^ key,
    CultureInfo^ locale,
    ... array<Object^>^ args
)
Parameters
key
Type:   Online System String
locale
Type:   Online System.Globalization CultureInfo
args
Type:    Online System Object
See Also
NLS Class
NLS Members
GetLocalizedMessage Overload
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


InitializeMessages(T) Method

NLS InitializeMessages T Method Lucene.Net Class Library
Initialize a given class with the message bundle Keys Should be called from a class that extends NLS in a static block at class load time.

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static void InitializeMessages<T>(
    string bundleName
)
protected static void InitializeMessages<T>(
    string bundleName
)
Protected Shared Sub InitializeMessages(Of T) ( _
    bundleName As String _
)
Protected Shared Sub InitializeMessages(Of T) ( _
    bundleName As String _
)
protected:
generic<typename T>
static void InitializeMessages(
    String^ bundleName
)
protected:
generic<typename T>
static void InitializeMessages(
    String^ bundleName
)
Parameters
bundleName
Type:   Online System String
Property file with that contains the message bundle

Type Parameters
T
See Also
NLS Class
NLS Members
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NLS.IPriviligedAction Interface

NLS IPriviligedAction Interface Lucene.Net Class Library

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPriviligedAction
public interface IPriviligedAction
Public Interface IPriviligedAction
Public Interface IPriviligedAction
public interface class IPriviligedAction
public interface class IPriviligedAction
See Also
NLS IPriviligedAction Members
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NLS.IPriviligedAction Members

NLS IPriviligedAction Members Lucene.Net Class Library

MessageBundles classes extend this class, to implement a bundle. For Native Language Support (NLS), system of software internationalization. This interface is similar to the NLS class in eclipse.osgi.util.NLS class - initializeMessages() method resets the values of all static strings, should only be called by classes that extend from NLS (see TestMessages.java for reference) - performs validation of all message in a bundle, at class load time - performs per message validation at runtime - see NLSTest.java for usage reference MessageBundle classes may subclass this type.

The NLS IPriviligedAction type exposes the following members.
Methods
 | Name | Description
Public method | Run | Performs the priviliged action.
Back to Top
See Also
NLS IPriviligedAction Interface
Lucene.Net.Messages Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NLS.IPriviligedAction Methods

NLS IPriviligedAction Methods Lucene.Net Class Library
The NLS IPriviligedAction type exposes the following members.
Methods
 | Name | Description
Public method | Run | Performs the priviliged action.
Back to Top
See Also
NLS IPriviligedAction Interface
Lucene.Net.Messages Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Run Method

NLS IPriviligedAction Run Method Lucene.Net Class Library
Performs the priviliged action.

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object Run()
Object Run()
Function Run As Object
Function Run As Object
Object^ Run()
Object^ Run()
Return Value
A value that may represent the result of the action.
See Also
NLS IPriviligedAction Interface
NLS IPriviligedAction Members
Lucene.Net.Messages Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lucene.Net.QueryParsers Namespace

Lucene.Net.QueryParsers Namespace Lucene.Net Class Library
Classes
Class Description
Public class FastCharStream
An efficient implementation of JavaCC's CharStream interface.

Note that this does not do line-number counting, but instead keeps track of the character position of the token in the input, as required by Lucene's Token API.
Public class MultiFieldQueryParser
A QueryParser which constructs queries to search multiple fields.
Public class ParseException
This exception is thrown when parse errors are encountered. You can explicitly create objects of this exception type by calling the method generateParseException in the generated parser. You can modify this class to customize your error reporting mechanisms so long as you retain the public fields.
Public class QueryParser
This class is generated by JavaCC. The most important method is Parse(String). The syntax for query strings is as follows: A Query is a series of clauses. A clause may be prefixed by:
  • a plus (+) or a minus (-) sign, indicating that the clause is required or prohibited respectively; or
  • a term followed by a colon, indicating the field to be searched. This enables one to construct queries which search multiple fields.
A clause may be either:
  • a term, indicating all the documents that contain this term; or
  • a nested query, enclosed in parentheses. Note that this may be used with a +/- prefix to require any of a set of terms.
Thus, in BNF, the query grammar is:
View Colorized Copy to Clipboard Print
Query  ::= ( Clause )*
Clause ::= ["+", "-"] [<TERM> ":"] ( <TERM> | "(" Query ")" )
Query  ::= ( Clause )*
Clause ::= ["+", "-"] [<TERM> ":"] ( <TERM> | "(" Query ")" )

Examples of appropriately formatted queries can be found in the query syntax documentation.

In TermRangeQuerys, QueryParser tries to detect date values, e.g. date:[6/1/2005 TO 6/4/2005] produces a range query that searches for "date" fields between 2005-06-01 and 2005-06-04. Note that the format of the accepted input depends on the Locale. By default a date is converted into a search term using the deprecated DateField for compatibility reasons. To use the new DateTools to convert dates, a DateTools Resolution has to be set.

The date resolution that shall be used for RangeQueries can be set using SetDateResolution(DateTools Resolution) or SetDateResolution(String, DateTools Resolution). The former sets the default date resolution for all fields, whereas the latter can be used to set field specific date resolutions. Field specific date resolutions take, if set, precedence over the default date resolution.

If you use neither DateField nor DateTools in your index, you can create your own query parser that inherits QueryParser and overwrites GetRangeQuery(String, String, String, Boolean) to use a different method for date conversion.

Note that QueryParser is not thread-safe.

NOTE: there is a new QueryParser in contrib, which matches the same syntax as this class, but is more modular, enabling substantial customization to how a query is created.

NOTE: there is a new QueryParser in contrib, which matches the same syntax as this class, but is more modular, enabling substantial customization to how a query is created. NOTE: You must specify the required Version compatibility when creating QueryParser:
  • As of 2.9, EnablePositionIncrements is true by default.
Public class QueryParserConstants
Token literal values and constants. Generated by org.javacc.parser.OtherFilesGen#start()
Public class QueryParserTokenManager
Token Manager.
Public class Token
Describes the input token stream.
Public class TokenMgrError
Token Manager Error.
Interfaces
 | Interface | Description
Public interface | ICharStream | This interface describes a character stream that maintains line and column number positions of the characters. It also has the capability to backup the stream to some extent. An implementation of this interface is used in the TokenManager implementation generated by JavaCCParser. All the methods except backup can be implemented in any fashion. backup needs to be implemented correctly for the correct operation of the lexer. Rest of the methods are all used to get information like line number, column number and the String that constitutes a token and are not used by the lexer. Hence their implementation won't affect the generated lexer's operation.
Enumerations
 | Enumeration | Description
Public enumeration | QueryParser Operator |

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FastCharStream Class

FastCharStream Class Lucene.Net Class Library
An efficient implementation of JavaCC's CharStream interface.

Note that this does not do line-number counting, but instead keeps track of the character position of the token in the input, as required by Lucene's Token API.
Inheritance Hierarchy
Online System Object
Lucene.Net.QueryParsers FastCharStream

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class FastCharStream : ICharStream
public sealed class FastCharStream : ICharStream
Public NotInheritable Class FastCharStream _
    Implements ICharStream
Public NotInheritable Class FastCharStream _
    Implements ICharStream
public ref class FastCharStream sealed : ICharStream
public ref class FastCharStream sealed : ICharStream
See Also
FastCharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FastCharStream Members

FastCharStream Members Lucene.Net Class Library

The FastCharStream type exposes the following members.
Constructors
 | Name | Description
Public method | FastCharStream | Constructs from a Reader.
Back to Top
Methods
 | Name | Description
Public method | Backup |
Public method | BeginToken |
Public method | Done |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSuffix |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadChar |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | BeginColumn |
Public property | BeginLine |
Public property | Column |
Public property | EndColumn |
Public property | EndLine |
Public property | Image |
Public property | Line |
Back to Top
See Also
FastCharStream Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FastCharStream Constructor

FastCharStream Constructor Lucene.Net Class Library
Constructs from a Reader.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FastCharStream(
    TextReader r
)
public FastCharStream(
    TextReader r
)
Public Sub New ( _
    r As TextReader _
)
Public Sub New ( _
    r As TextReader _
)
public:
FastCharStream(
    TextReader^ r
)
public:
FastCharStream(
    TextReader^ r
)
Parameters
r
Type:   Online System.IO TextReader
See Also
FastCharStream Class
FastCharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FastCharStream Methods

FastCharStream Methods Lucene.Net Class Library
The FastCharStream type exposes the following members.
Methods
 | Name | Description
Public method | Backup |
Public method | BeginToken |
Public method | Done |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSuffix |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadChar |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FastCharStream Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Backup Method

FastCharStream Backup Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Backup(
    int amount
)
public void Backup(
    int amount
)
Public Sub Backup ( _
    amount As Integer _
)
Public Sub Backup ( _
    amount As Integer _
)
public:
virtual void Backup(
    int amount
) sealed
public:
virtual void Backup(
    int amount
) sealed
Parameters
amount
Type:   Online System Int32
Implements
ICharStream Backup(Int32)
See Also
FastCharStream Class
FastCharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BeginToken Method

FastCharStream BeginToken Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char BeginToken()
public char BeginToken()
Public Function BeginToken As Char
Public Function BeginToken As Char
public:
virtual wchar_t BeginToken() sealed
public:
virtual wchar_t BeginToken() sealed
Implements
ICharStream BeginToken
See Also
FastCharStream Class
FastCharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Done Method

FastCharStream Done Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Done()
public void Done()
Public Sub Done
Public Sub Done
public:
virtual void Done() sealed
public:
virtual void Done() sealed
Implements
ICharStream Done
See Also
FastCharStream Class
FastCharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSuffix Method

FastCharStream GetSuffix Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char[] GetSuffix(
    int len
)
public char[] GetSuffix(
    int len
)
Public Function GetSuffix ( _
    len As Integer _
) As Char()
Public Function GetSuffix ( _
    len As Integer _
) As Char()
public:
virtual array<wchar_t>^ GetSuffix(
    int len
) sealed
public:
virtual array<wchar_t>^ GetSuffix(
    int len
) sealed
Parameters
len
Type:   Online System Int32
Implements
ICharStream GetSuffix(Int32)
See Also
FastCharStream Class
FastCharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadChar Method

FastCharStream ReadChar Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char ReadChar()
public char ReadChar()
Public Function ReadChar As Char
Public Function ReadChar As Char
public:
virtual wchar_t ReadChar() sealed
public:
virtual wchar_t ReadChar() sealed
Implements
ICharStream ReadChar
See Also
FastCharStream Class
FastCharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FastCharStream Properties

FastCharStream Properties Lucene.Net Class Library
The FastCharStream type exposes the following members.
Properties
 | Name | Description
Public property | BeginColumn |
Public property | BeginLine |
Public property | Column |
Public property | EndColumn |
Public property | EndLine |
Public property | Image |
Public property | Line |
Back to Top
See Also
FastCharStream Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BeginColumn Property

FastCharStream BeginColumn Property Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int BeginColumn { get; }
public int BeginColumn { get; }
Public ReadOnly Property BeginColumn As Integer
    Get
Public ReadOnly Property BeginColumn As Integer
    Get
public:
virtual property int BeginColumn {
    int get () sealed;
}
public:
virtual property int BeginColumn {
    int get () sealed;
}
Implements
ICharStream BeginColumn
See Also
FastCharStream Class
FastCharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BeginLine Property

FastCharStream BeginLine Property Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int BeginLine { get; }
public int BeginLine { get; }
Public ReadOnly Property BeginLine As Integer
    Get
Public ReadOnly Property BeginLine As Integer
    Get
public:
virtual property int BeginLine {
    int get () sealed;
}
public:
virtual property int BeginLine {
    int get () sealed;
}
Implements
ICharStream BeginLine
See Also
FastCharStream Class
FastCharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Column Property

FastCharStream Column Property Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Column { get; }
public int Column { get; }
Public ReadOnly Property Column As Integer
    Get
Public ReadOnly Property Column As Integer
    Get
public:
virtual property int Column {
    int get () sealed;
}
public:
virtual property int Column {
    int get () sealed;
}
Implements
ICharStream Column
See Also
FastCharStream Class
FastCharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EndColumn Property

FastCharStream EndColumn Property Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int EndColumn { get; }
public int EndColumn { get; }
Public ReadOnly Property EndColumn As Integer
    Get
Public ReadOnly Property EndColumn As Integer
    Get
public:
virtual property int EndColumn {
    int get () sealed;
}
public:
virtual property int EndColumn {
    int get () sealed;
}
Implements
ICharStream EndColumn
See Also
FastCharStream Class
FastCharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EndLine Property

FastCharStream EndLine Property Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int EndLine { get; }
public int EndLine { get; }
Public ReadOnly Property EndLine As Integer
    Get
Public ReadOnly Property EndLine As Integer
    Get
public:
virtual property int EndLine {
    int get () sealed;
}
public:
virtual property int EndLine {
    int get () sealed;
}
Implements
ICharStream EndLine
See Also
FastCharStream Class
FastCharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Image Property

FastCharStream Image Property Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Image { get; }
public string Image { get; }
Public ReadOnly Property Image As String
    Get
Public ReadOnly Property Image As String
    Get
public:
virtual property String^ Image {
    String^ get () sealed;
}
public:
virtual property String^ Image {
    String^ get () sealed;
}
Implements
ICharStream Image
See Also
FastCharStream Class
FastCharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Line Property

FastCharStream Line Property Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Line { get; }
public int Line { get; }
Public ReadOnly Property Line As Integer
    Get
Public ReadOnly Property Line As Integer
    Get
public:
virtual property int Line {
    int get () sealed;
}
public:
virtual property int Line {
    int get () sealed;
}
Implements
ICharStream Line
See Also
FastCharStream Class
FastCharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ICharStream Interface

ICharStream Interface Lucene.Net Class Library
This interface describes a character stream that maintains line and column number positions of the characters. It also has the capability to backup the stream to some extent. An implementation of this interface is used in the TokenManager implementation generated by JavaCCParser. All the methods except backup can be implemented in any fashion. backup needs to be implemented correctly for the correct operation of the lexer. Rest of the methods are all used to get information like line number, column number and the String that constitutes a token and are not used by the lexer. Hence their implementation won't affect the generated lexer's operation.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICharStream
public interface ICharStream
Public Interface ICharStream
Public Interface ICharStream
public interface class ICharStream
public interface class ICharStream
See Also
ICharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ICharStream Members

ICharStream Members Lucene.Net Class Library

The ICharStream type exposes the following members.
Methods
 | Name | Description
Public method | Backup | Backs up the input stream by amount steps. Lexer calls this method if it had already read some characters, but could not use them to match a (longer) token. So, they will be used again as the prefix of the next token and it is the implemetation's responsibility to do this right.
Public method | BeginToken | Returns the next character that marks the beginning of the next token. All characters must remain in the buffer between two successive calls to this method to implement backup correctly.
Public method | Done | The lexer calls this function to indicate that it is done with the stream and hence implementations can free any resources held by this class. Again, the body of this function can be just empty and it will not affect the lexer's operation.
Public method | GetSuffix | Returns an array of characters that make up the suffix of length 'len' for the currently matched token. This is used to build up the matched string for use in actions in the case of MORE. A simple and inefficient implementation of this is as follows : { String t = GetImage(); return t.substring(t.length() - len, t.length()).toCharArray(); }
Public method | ReadChar | Returns the next character from the selected input. The method of selecting the input is the responsibility of the class implementing this interface. Can throw any java.io.IOException.
Back to Top
Properties
 | Name | Description
Public property | BeginColumn | Returns the column number of the first character for current token (being matched after the last call to BeginTOken).
Public property | BeginLine | Returns the line number of the first character for current token (being matched after the last call to BeginTOken).
Public property | Column | Obsolete. Returns the column position of the character last read.
Public property | EndColumn | Returns the column number of the last character for current token (being matched after the last call to BeginTOken).
Public property | EndLine | Returns the line number of the last character for current token (being matched after the last call to BeginTOken).
Public property | Image | Returns a string made up of characters from the marked token beginning to the current buffer position. Implementations have the choice of returning anything that they want to. For example, for efficiency, one might decide to just return null, which is a valid implementation.
Public property | Line | Obsolete. Returns the line number of the character last read.
Back to Top
See Also
ICharStream Interface
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ICharStream Methods

ICharStream Methods Lucene.Net Class Library
The ICharStream type exposes the following members.
Methods
 | Name | Description
Public method | Backup | Backs up the input stream by amount steps. Lexer calls this method if it had already read some characters, but could not use them to match a (longer) token. So, they will be used again as the prefix of the next token and it is the implemetation's responsibility to do this right.
Public method | BeginToken | Returns the next character that marks the beginning of the next token. All characters must remain in the buffer between two successive calls to this method to implement backup correctly.
Public method | Done | The lexer calls this function to indicate that it is done with the stream and hence implementations can free any resources held by this class. Again, the body of this function can be just empty and it will not affect the lexer's operation.
Public method | GetSuffix | Returns an array of characters that make up the suffix of length 'len' for the currently matched token. This is used to build up the matched string for use in actions in the case of MORE. A simple and inefficient implementation of this is as follows : { String t = GetImage(); return t.substring(t.length() - len, t.length()).toCharArray(); }
Public method | ReadChar | Returns the next character from the selected input. The method of selecting the input is the responsibility of the class implementing this interface. Can throw any java.io.IOException.
Back to Top
See Also
ICharStream Interface
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Backup Method

ICharStream Backup Method Lucene.Net Class Library
Backs up the input stream by amount steps. Lexer calls this method if it had already read some characters, but could not use them to match a (longer) token. So, they will be used again as the prefix of the next token and it is the implemetation's responsibility to do this right.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Backup(
    int amount
)
void Backup(
    int amount
)
Sub Backup ( _
    amount As Integer _
)
Sub Backup ( _
    amount As Integer _
)
void Backup(
    int amount
)
void Backup(
    int amount
)
Parameters
amount
Type:   Online System Int32
See Also
ICharStream Interface
ICharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BeginToken Method

ICharStream BeginToken Method Lucene.Net Class Library
Returns the next character that marks the beginning of the next token. All characters must remain in the buffer between two successive calls to this method to implement backup correctly.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
char BeginToken()
char BeginToken()
Function BeginToken As Char
Function BeginToken As Char
wchar_t BeginToken()
wchar_t BeginToken()
See Also
ICharStream Interface
ICharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Done Method

ICharStream Done Method Lucene.Net Class Library
The lexer calls this function to indicate that it is done with the stream and hence implementations can free any resources held by this class. Again, the body of this function can be just empty and it will not affect the lexer's operation.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Done()
void Done()
Sub Done
Sub Done
void Done()
void Done()
See Also
ICharStream Interface
ICharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSuffix Method

ICharStream GetSuffix Method Lucene.Net Class Library
Returns an array of characters that make up the suffix of length 'len' for the currently matched token. This is used to build up the matched string for use in actions in the case of MORE. A simple and inefficient implementation of this is as follows : { String t = GetImage(); return t.substring(t.length() - len, t.length()).toCharArray(); }

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
char[] GetSuffix(
    int len
)
char[] GetSuffix(
    int len
)
Function GetSuffix ( _
    len As Integer _
) As Char()
Function GetSuffix ( _
    len As Integer _
) As Char()
array<wchar_t>^ GetSuffix(
    int len
)
array<wchar_t>^ GetSuffix(
    int len
)
Parameters
len
Type:   Online System Int32
See Also
ICharStream Interface
ICharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadChar Method

ICharStream ReadChar Method Lucene.Net Class Library
Returns the next character from the selected input. The method of selecting the input is the responsibility of the class implementing this interface. Can throw any java.io.IOException.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
char ReadChar()
char ReadChar()
Function ReadChar As Char
Function ReadChar As Char
wchar_t ReadChar()
wchar_t ReadChar()
See Also
ICharStream Interface
ICharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ICharStream Properties

ICharStream Properties Lucene.Net Class Library
The ICharStream type exposes the following members.
Properties
 | Name | Description
Public property | BeginColumn | Returns the column number of the first character for current token (being matched after the last call to BeginTOken).
Public property | BeginLine | Returns the line number of the first character for current token (being matched after the last call to BeginTOken).
Public property | Column | Obsolete. Returns the column position of the character last read.
Public property | EndColumn | Returns the column number of the last character for current token (being matched after the last call to BeginTOken).
Public property | EndLine | Returns the line number of the last character for current token (being matched after the last call to BeginTOken).
Public property | Image | Returns a string made up of characters from the marked token beginning to the current buffer position. Implementations have the choice of returning anything that they want to. For example, for efficiency, one might decide to just return null, which is a valid implementation.
Public property | Line | Obsolete. Returns the line number of the character last read.
Back to Top
See Also
ICharStream Interface
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BeginColumn Property

ICharStream BeginColumn Property Lucene.Net Class Library
Returns the column number of the first character for current token (being matched after the last call to BeginTOken).

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int BeginColumn { get; }
int BeginColumn { get; }
ReadOnly Property BeginColumn As Integer
    Get
ReadOnly Property BeginColumn As Integer
    Get
property int BeginColumn {
    int get ();
}
property int BeginColumn {
    int get ();
}
See Also
ICharStream Interface
ICharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BeginLine Property

ICharStream BeginLine Property Lucene.Net Class Library
Returns the line number of the first character for current token (being matched after the last call to BeginTOken).

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int BeginLine { get; }
int BeginLine { get; }
ReadOnly Property BeginLine As Integer
    Get
ReadOnly Property BeginLine As Integer
    Get
property int BeginLine {
    int get ();
}
property int BeginLine {
    int get ();
}
See Also
ICharStream Interface
ICharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Column Property

ICharStream Column Property Lucene.Net Class Library
Returns the column position of the character last read.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute]
int Column { get; }
[ObsoleteAttribute]
int Column { get; }
<ObsoleteAttribute> _
ReadOnly Property Column As Integer
    Get
<ObsoleteAttribute> _
ReadOnly Property Column As Integer
    Get
[ObsoleteAttribute]
property int Column {
    int get ();
}
[ObsoleteAttribute]
property int Column {
    int get ();
}
See Also
ICharStream Interface
ICharStream Members
Lucene.Net.QueryParsers Namespace
ICharStream EndColumn
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EndColumn Property

ICharStream EndColumn Property Lucene.Net Class Library
Returns the column number of the last character for current token (being matched after the last call to BeginTOken).

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int EndColumn { get; }
int EndColumn { get; }
ReadOnly Property EndColumn As Integer
    Get
ReadOnly Property EndColumn As Integer
    Get
property int EndColumn {
    int get ();
}
property int EndColumn {
    int get ();
}
See Also
ICharStream Interface
ICharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EndLine Property

ICharStream EndLine Property Lucene.Net Class Library
Returns the line number of the last character for current token (being matched after the last call to BeginTOken).

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int EndLine { get; }
int EndLine { get; }
ReadOnly Property EndLine As Integer
    Get
ReadOnly Property EndLine As Integer
    Get
property int EndLine {
    int get ();
}
property int EndLine {
    int get ();
}
See Also
ICharStream Interface
ICharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Image Property

ICharStream Image Property Lucene.Net Class Library
Returns a string made up of characters from the marked token beginning to the current buffer position. Implementations have the choice of returning anything that they want to. For example, for efficiency, one might decide to just return null, which is a valid implementation.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Image { get; }
string Image { get; }
ReadOnly Property Image As String
    Get
ReadOnly Property Image As String
    Get
property String^ Image {
    String^ get ();
}
property String^ Image {
    String^ get ();
}
See Also
ICharStream Interface
ICharStream Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Line Property

ICharStream Line Property Lucene.Net Class Library
Returns the line number of the character last read.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute]
int Line { get; }
[ObsoleteAttribute]
int Line { get; }
<ObsoleteAttribute> _
ReadOnly Property Line As Integer
    Get
<ObsoleteAttribute> _
ReadOnly Property Line As Integer
    Get
[ObsoleteAttribute]
property int Line {
    int get ();
}
[ObsoleteAttribute]
property int Line {
    int get ();
}
See Also
ICharStream Interface
ICharStream Members
Lucene.Net.QueryParsers Namespace
ICharStream EndLine
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiFieldQueryParser Class

MultiFieldQueryParser Class Lucene.Net Class Library
A QueryParser which constructs queries to search multiple fields.
Inheritance Hierarchy
Online System Object
Lucene.Net.QueryParsers QueryParserConstants
Lucene.Net.QueryParsers QueryParser
Lucene.Net.QueryParsers MultiFieldQueryParser

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MultiFieldQueryParser : QueryParser
public class MultiFieldQueryParser : QueryParser
Public Class MultiFieldQueryParser _
    Inherits QueryParser
Public Class MultiFieldQueryParser _
    Inherits QueryParser
public ref class MultiFieldQueryParser : public QueryParser
public ref class MultiFieldQueryParser : public QueryParser
See Also
MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiFieldQueryParser Members

MultiFieldQueryParser Members Lucene.Net Class Library

The MultiFieldQueryParser type exposes the following members.
Constructors
Name Description
Public method MultiFieldQueryParser(Version, String , Analyzer)
Creates a MultiFieldQueryParser.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields title and body):

View Colorized Copy to Clipboard Print
(title:term1 body:term1) (title:term2 body:term2)
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

View Colorized Copy to Clipboard Print
+(title:term1 body:term1) +(title:term2 body:term2)
+(title:term1 body:term1) +(title:term2 body:term2)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Public method MultiFieldQueryParser(Version, String , Analyzer, IDictionary String, Single )
Creates a MultiFieldQueryParser. Allows passing of a map with term to Boost, and the boost to apply to each term.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields title and body):

View Colorized Copy to Clipboard Print
(title:term1 body:term1) (title:term2 body:term2)
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

View Colorized Copy to Clipboard Print
+(title:term1 body:term1) +(title:term2 body:term2)
+(title:term1 body:term1) +(title:term2 body:term2)

When you pass a boost (title=>5 body=>10) you can get

View Colorized Copy to Clipboard Print
+(title:term1^5.0 body:term1^10.0) +(title:term2^5.0 body:term2^10.0)
+(title:term1^5.0 body:term1^10.0) +(title:term2^5.0 body:term2^10.0)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Back to Top
Methods
Name | Description
Protected method | AddClause | (Inherited from QueryParser.)
Public method | Clause | (Inherited from QueryParser.)
Public method | Conjunction | (Inherited from QueryParser.)
Public method Disable_tracing
Disable tracing.
(Inherited from QueryParser.)
Public method Enable_tracing
Enable tracing.
(Inherited from QueryParser.)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method GenerateParseException
Generate ParseException.
(Inherited from QueryParser.)
Protected method GetBooleanQuery(IList BooleanClause )
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
(Inherited from QueryParser.)
Protected method GetBooleanQuery(IList BooleanClause , Boolean)
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
(Inherited from QueryParser.)
Public method getDateResolution
Returns the date resolution that is used by RangeQueries for the given field. Returns null, if no default or field specific date resolution has been set for the given field.
(Inherited from QueryParser.)
Protected method | GetFieldQuery(String, String) | (Overrides QueryParser GetFieldQuery(String, String).)
Protected method | GetFieldQuery(String, String, Int32) | (Overrides QueryParser GetFieldQuery(String, String, Int32).)
Protected method | GetFuzzyQuery | (Overrides QueryParser GetFuzzyQuery(String, String, Single).)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method GetNextToken
Get the next Token.
(Inherited from QueryParser.)
Protected method | GetPrefixQuery | (Overrides QueryParser GetPrefixQuery(String, String).)
Protected method | GetRangeQuery | (Overrides QueryParser GetRangeQuery(String, String, String, Boolean).)
Public method getToken
Get the specific Token.
(Inherited from QueryParser.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method | GetWildcardQuery | (Overrides QueryParser GetWildcardQuery(String, String).)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method | Modifiers | (Inherited from QueryParser.)
Protected method NewBooleanClause
Builds a new BooleanClause instance
(Inherited from QueryParser.)
Protected method NewBooleanQuery
Builds a new BooleanQuery instance
(Inherited from QueryParser.)
Protected method NewFuzzyQuery
Builds a new FuzzyQuery instance
(Inherited from QueryParser.)
Protected method NewMatchAllDocsQuery
Builds a new MatchAllDocsQuery instance
(Inherited from QueryParser.)
Protected method NewMultiPhraseQuery
Builds a new MultiPhraseQuery instance
(Inherited from QueryParser.)
Protected method NewPhraseQuery
Builds a new PhraseQuery instance
(Inherited from QueryParser.)
Protected method NewPrefixQuery
Builds a new PrefixQuery instance
(Inherited from QueryParser.)
Protected method NewRangeQuery
Builds a new TermRangeQuery instance
(Inherited from QueryParser.)
Protected method NewTermQuery
Builds a new TermQuery instance
(Inherited from QueryParser.)
Protected method NewWildcardQuery
Builds a new WildcardQuery instance
(Inherited from QueryParser.)
Public method Parse(String)
Parses a query string, returning a {@link Lucene.Net.Search.Query}.
(Inherited from QueryParser.)
Parse(Version, String , String , Analyzer)
Parses a query which searches on the fields specified.

If x fields are specified, this effectively constructs:
View Colorized Copy to Clipboard Print
(field1:query1) (field2:query2) (field3:query3)...(fieldx:queryx)
(field1:query1) (field2:query2) (field3:query3)...(fieldx:queryx)
Parse(Version, String, String , Occur , Analyzer)
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

Uasge:
View Colorized Copy to Clipboard Print
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse("query", fields, flags, analyzer);
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse("query", fields, flags, analyzer);

The code above would construct a query:
View Colorized Copy to Clipboard Print
(filename:query) +(contents:query) -(description:query)
(filename:query) +(contents:query) -(description:query)
Parse(Version, String , String , Occur , Analyzer)
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

Usage:
View Colorized Copy to Clipboard Print
String[] query = {"query1", "query2", "query3"};
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse(query, fields, flags, analyzer);
String[] query = {"query1", "query2", "query3"};
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse(query, fields, flags, analyzer);

The code above would construct a query:
View Colorized Copy to Clipboard Print
(filename:query1) +(contents:query2) -(description:query3)
(filename:query1) +(contents:query2) -(description:query3)
Public method | Query | (Inherited from QueryParser.)
Public method ReInit(ICharStream)
Reinitialise.
(Inherited from QueryParser.)
Public method ReInit(QueryParserTokenManager)
Reinitialise.
(Inherited from QueryParser.)
Public method SetDateResolution(DateTools Resolution)
Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.
(Inherited from QueryParser.)
Public method SetDateResolution(String, DateTools Resolution)
Sets the date resolution used by RangeQueries for a specific field.
(Inherited from QueryParser.)
Public method | Term | (Inherited from QueryParser.)
Public method | TopLevelQuery | (Inherited from QueryParser.)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | boosts |
Protected field | fields |
Public field | jj_nt | (Inherited from QueryParser.)
Public field | token | (Inherited from QueryParser.)
Public field | token_source | (Inherited from QueryParser.)
Back to Top
Properties
 | Name | Description
Public property | AllowLeadingWildcard | Set to true to allow leading wildcard characters. When set, * or ? are allowed as the first character of a PrefixQuery and WildcardQuery. Note that this can produce very slow queries on big indexes. Default: false. (Inherited from QueryParser.)
Public property | Analyzer | (Inherited from QueryParser.)
Public property | DefaultOperator | Gets or sets the boolean operator of the QueryParser. In default mode (OR_OPERATOR) terms without any modifiers are considered optional: for example capital of Hungary is equal to capital OR of OR Hungary. In AND_OPERATOR mode terms are considered to be in conjunction: the above mentioned query is parsed as capital AND of AND Hungary (Inherited from QueryParser.)
Public property | EnablePositionIncrements | Set to true to enable position increments in result query. When set, result phrase and multi-phrase queries will be aware of position increments. Useful when e.g. a StopFilter increases the position increment of the token that follows an omitted token. Default: false. (Inherited from QueryParser.)
Public property | Field | (Inherited from QueryParser.)
Public property | FuzzyMinSim | Gets or sets the minimal similarity for fuzzy queries. Default is 0.5f. (Inherited from QueryParser.)
Public property | FuzzyPrefixLength | Gets or sets the prefix length for fuzzy queries. (Inherited from QueryParser.)
Public property | Locale | Gets or sets locale used by date range parsing. (Inherited from QueryParser.)
Public property | LowercaseExpandedTerms | Whether terms of wildcard, prefix, fuzzy and range queries are to be automatically lower-cased or not. Default is true. (Inherited from QueryParser.)
Public property | MultiTermRewriteMethod | By default QueryParser uses CONSTANT_SCORE_AUTO_REWRITE_DEFAULT when creating a PrefixQuery, WildcardQuery or RangeQuery. This implementation is generally preferable because it a) Runs faster b) Does not have the scarcity of terms unduly influence score c) avoids any "TooManyBooleanClauses" exception. However, if your application really needs to use the old-fashioned BooleanQuery expansion rewriting and the above points are not relevant then use this to change the rewrite method. (Inherited from QueryParser.)
Public property | PhraseSlop | Gets or sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero. (Inherited from QueryParser.)
Public property | RangeCollator | Gets or sets the collator used to determine index term inclusion in ranges for RangeQuerys. WARNING: Setting the rangeCollator to a non-null collator using this method will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow. (Inherited from QueryParser.)
Back to Top
See Also
MultiFieldQueryParser Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiFieldQueryParser Constructor

MultiFieldQueryParser Constructor Lucene.Net Class Library
Overload List
Name Description
Public method MultiFieldQueryParser(Version, String , Analyzer)
Creates a MultiFieldQueryParser.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields title and body):

View Colorized Copy to Clipboard Print
(title:term1 body:term1) (title:term2 body:term2)
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

View Colorized Copy to Clipboard Print
+(title:term1 body:term1) +(title:term2 body:term2)
+(title:term1 body:term1) +(title:term2 body:term2)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Public method MultiFieldQueryParser(Version, String , Analyzer, IDictionary String, Single )
Creates a MultiFieldQueryParser. Allows passing of a map with term to Boost, and the boost to apply to each term.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields title and body):

View Colorized Copy to Clipboard Print
(title:term1 body:term1) (title:term2 body:term2)
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

View Colorized Copy to Clipboard Print
+(title:term1 body:term1) +(title:term2 body:term2)
+(title:term1 body:term1) +(title:term2 body:term2)

When you pass a boost (title=>5 body=>10) you can get

View Colorized Copy to Clipboard Print
+(title:term1^5.0 body:term1^10.0) +(title:term2^5.0 body:term2^10.0)
+(title:term1^5.0 body:term1^10.0) +(title:term2^5.0 body:term2^10.0)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Back to Top
See Also
MultiFieldQueryParser Class
MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiFieldQueryParser Constructor (Version, String[], Analyzer)

MultiFieldQueryParser Constructor (Version, String , Analyzer) Lucene.Net Class Library
Creates a MultiFieldQueryParser.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields title and body):

View Colorized Copy to Clipboard Print
(title:term1 body:term1) (title:term2 body:term2)
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

View Colorized Copy to Clipboard Print
+(title:term1 body:term1) +(title:term2 body:term2)
+(title:term1 body:term1) +(title:term2 body:term2)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MultiFieldQueryParser(
    Version matchVersion,
    string[] fields,
    Analyzer analyzer
)
public MultiFieldQueryParser(
    Version matchVersion,
    string[] fields,
    Analyzer analyzer
)
Public Sub New ( _
    matchVersion As Version, _
    fields As String(), _
    analyzer As Analyzer _
)
Public Sub New ( _
    matchVersion As Version, _
    fields As String(), _
    analyzer As Analyzer _
)
public:
MultiFieldQueryParser(
    Version matchVersion,
    array<String^>^ fields,
    Analyzer^ analyzer
)
public:
MultiFieldQueryParser(
    Version matchVersion,
    array<String^>^ fields,
    Analyzer^ analyzer
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
fields
Type:    Online System String
analyzer
Type: Lucene.Net.Analysis Analyzer
See Also
MultiFieldQueryParser Class
MultiFieldQueryParser Members
MultiFieldQueryParser Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiFieldQueryParser Constructor (Version, String[], Analyzer, IDictionary(String, Single))

MultiFieldQueryParser Constructor (Version, String , Analyzer, IDictionary String, Single ) Lucene.Net Class Library
Creates a MultiFieldQueryParser. Allows passing of a map with term to Boost, and the boost to apply to each term.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields title and body):

View Colorized Copy to Clipboard Print
(title:term1 body:term1) (title:term2 body:term2)
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

View Colorized Copy to Clipboard Print
+(title:term1 body:term1) +(title:term2 body:term2)
+(title:term1 body:term1) +(title:term2 body:term2)

When you pass a boost (title=>5 body=>10) you can get

View Colorized Copy to Clipboard Print
+(title:term1^5.0 body:term1^10.0) +(title:term2^5.0 body:term2^10.0)
+(title:term1^5.0 body:term1^10.0) +(title:term2^5.0 body:term2^10.0)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MultiFieldQueryParser(
    Version matchVersion,
    string[] fields,
    Analyzer analyzer,
    IDictionary<string, float> boosts
)
public MultiFieldQueryParser(
    Version matchVersion,
    string[] fields,
    Analyzer analyzer,
    IDictionary<string, float> boosts
)
Public Sub New ( _
    matchVersion As Version, _
    fields As String(), _
    analyzer As Analyzer, _
    boosts As IDictionary(Of String, Single) _
)
Public Sub New ( _
    matchVersion As Version, _
    fields As String(), _
    analyzer As Analyzer, _
    boosts As IDictionary(Of String, Single) _
)
public:
MultiFieldQueryParser(
    Version matchVersion,
    array<String^>^ fields,
    Analyzer^ analyzer,
    IDictionary<String^, float>^ boosts
)
public:
MultiFieldQueryParser(
    Version matchVersion,
    array<String^>^ fields,
    Analyzer^ analyzer,
    IDictionary<String^, float>^ boosts
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
fields
Type:    Online System String
analyzer
Type: Lucene.Net.Analysis Analyzer
boosts
Type:   Online System.Collections.Generic IDictionary    Online String,   Online Single
See Also
MultiFieldQueryParser Class
MultiFieldQueryParser Members
MultiFieldQueryParser Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiFieldQueryParser Fields

MultiFieldQueryParser Fields Lucene.Net Class Library
The MultiFieldQueryParser type exposes the following members.
Fields
 | Name | Description
Protected field | boosts |
Protected field | fields |
Public field | jj_nt | (Inherited from QueryParser.)
Public field | token | (Inherited from QueryParser.)
Public field | token_source | (Inherited from QueryParser.)
Back to Top
See Also
MultiFieldQueryParser Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


boosts Field

MultiFieldQueryParser boosts Field Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IDictionary<string, float> boosts
protected IDictionary<string, float> boosts
Protected boosts As IDictionary(Of String, Single)
Protected boosts As IDictionary(Of String, Single)
protected:
IDictionary<String^, float>^ boosts
protected:
IDictionary<String^, float>^ boosts
See Also
MultiFieldQueryParser Class
MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


fields Field

MultiFieldQueryParser fields Field Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string[] fields
protected string[] fields
Protected fields As String()
Protected fields As String()
protected:
array<String^>^ fields
protected:
array<String^>^ fields
See Also
MultiFieldQueryParser Class
MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiFieldQueryParser Methods

MultiFieldQueryParser Methods Lucene.Net Class Library
The MultiFieldQueryParser type exposes the following members.
Methods
Name | Description
Protected method | AddClause | (Inherited from QueryParser.)
Public method | Clause | (Inherited from QueryParser.)
Public method | Conjunction | (Inherited from QueryParser.)
Public method Disable_tracing
Disable tracing.
(Inherited from QueryParser.)
Public method Enable_tracing
Enable tracing.
(Inherited from QueryParser.)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method GenerateParseException
Generate ParseException.
(Inherited from QueryParser.)
Protected method GetBooleanQuery(IList BooleanClause )
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
(Inherited from QueryParser.)
Protected method GetBooleanQuery(IList BooleanClause , Boolean)
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
(Inherited from QueryParser.)
Public method getDateResolution
Returns the date resolution that is used by RangeQueries for the given field. Returns null, if no default or field specific date resolution has been set for the given field.
(Inherited from QueryParser.)
Protected method | GetFieldQuery(String, String) | (Overrides QueryParser GetFieldQuery(String, String).)
Protected method | GetFieldQuery(String, String, Int32) | (Overrides QueryParser GetFieldQuery(String, String, Int32).)
Protected method | GetFuzzyQuery | (Overrides QueryParser GetFuzzyQuery(String, String, Single).)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method GetNextToken
Get the next Token.
(Inherited from QueryParser.)
Protected method | GetPrefixQuery | (Overrides QueryParser GetPrefixQuery(String, String).)
Protected method | GetRangeQuery | (Overrides QueryParser GetRangeQuery(String, String, String, Boolean).)
Public method getToken
Get the specific Token.
(Inherited from QueryParser.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method | GetWildcardQuery | (Overrides QueryParser GetWildcardQuery(String, String).)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method | Modifiers | (Inherited from QueryParser.)
Protected method NewBooleanClause
Builds a new BooleanClause instance
(Inherited from QueryParser.)
Protected method NewBooleanQuery
Builds a new BooleanQuery instance
(Inherited from QueryParser.)
Protected method NewFuzzyQuery
Builds a new FuzzyQuery instance
(Inherited from QueryParser.)
Protected method NewMatchAllDocsQuery
Builds a new MatchAllDocsQuery instance
(Inherited from QueryParser.)
Protected method NewMultiPhraseQuery
Builds a new MultiPhraseQuery instance
(Inherited from QueryParser.)
Protected method NewPhraseQuery
Builds a new PhraseQuery instance
(Inherited from QueryParser.)
Protected method NewPrefixQuery
Builds a new PrefixQuery instance
(Inherited from QueryParser.)
Protected method NewRangeQuery
Builds a new TermRangeQuery instance
(Inherited from QueryParser.)
Protected method NewTermQuery
Builds a new TermQuery instance
(Inherited from QueryParser.)
Protected method NewWildcardQuery
Builds a new WildcardQuery instance
(Inherited from QueryParser.)
Public method Parse(String)
Parses a query string, returning a {@link Lucene.Net.Search.Query}.
(Inherited from QueryParser.)
Parse(Version, String , String , Analyzer)
Parses a query which searches on the fields specified.

If x fields are specified, this effectively constructs:
View Colorized Copy to Clipboard Print
(field1:query1) (field2:query2) (field3:query3)...(fieldx:queryx)
(field1:query1) (field2:query2) (field3:query3)...(fieldx:queryx)
Parse(Version, String, String , Occur , Analyzer)
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

Uasge:
View Colorized Copy to Clipboard Print
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse("query", fields, flags, analyzer);
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse("query", fields, flags, analyzer);

The code above would construct a query:
View Colorized Copy to Clipboard Print
(filename:query) +(contents:query) -(description:query)
(filename:query) +(contents:query) -(description:query)
Parse(Version, String , String , Occur , Analyzer)
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

Usage:
View Colorized Copy to Clipboard Print
String[] query = {"query1", "query2", "query3"};
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse(query, fields, flags, analyzer);
String[] query = {"query1", "query2", "query3"};
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse(query, fields, flags, analyzer);

The code above would construct a query:
View Colorized Copy to Clipboard Print
(filename:query1) +(contents:query2) -(description:query3)
(filename:query1) +(contents:query2) -(description:query3)
Public method | Query | (Inherited from QueryParser.)
Public method ReInit(ICharStream)
Reinitialise.
(Inherited from QueryParser.)
Public method ReInit(QueryParserTokenManager)
Reinitialise.
(Inherited from QueryParser.)
Public method SetDateResolution(DateTools Resolution)
Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.
(Inherited from QueryParser.)
Public method SetDateResolution(String, DateTools Resolution)
Sets the date resolution used by RangeQueries for a specific field.
(Inherited from QueryParser.)
Public method | Term | (Inherited from QueryParser.)
Public method | TopLevelQuery | (Inherited from QueryParser.)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
See Also
MultiFieldQueryParser Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFieldQuery Method

MultiFieldQueryParser GetFieldQuery Method Lucene.Net Class Library
Overload List
 | Name | Description
Protected method | GetFieldQuery(String, String) | (Overrides QueryParser GetFieldQuery(String, String).)
Protected method | GetFieldQuery(String, String, Int32) | (Overrides QueryParser GetFieldQuery(String, String, Int32).)
Back to Top
See Also
MultiFieldQueryParser Class
MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFieldQuery Method (String, String)

MultiFieldQueryParser GetFieldQuery Method (String, String) Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Query GetFieldQuery(
    string field,
    string queryText
)
protected override Query GetFieldQuery(
    string field,
    string queryText
)
Protected Overrides Function GetFieldQuery ( _
    field As String, _
    queryText As String _
) As Query
Protected Overrides Function GetFieldQuery ( _
    field As String, _
    queryText As String _
) As Query
protected:
virtual Query^ GetFieldQuery(
    String^ field,
    String^ queryText
) override
protected:
virtual Query^ GetFieldQuery(
    String^ field,
    String^ queryText
) override
Parameters
field
Type:   Online System String
queryText
Type:   Online System String
See Also
MultiFieldQueryParser Class
MultiFieldQueryParser Members
GetFieldQuery Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFieldQuery Method (String, String, Int32)

MultiFieldQueryParser GetFieldQuery Method (String, String, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Query GetFieldQuery(
    string field,
    string queryText,
    int slop
)
protected override Query GetFieldQuery(
    string field,
    string queryText,
    int slop
)
Protected Overrides Function GetFieldQuery ( _
    field As String, _
    queryText As String, _
    slop As Integer _
) As Query
Protected Overrides Function GetFieldQuery ( _
    field As String, _
    queryText As String, _
    slop As Integer _
) As Query
protected:
virtual Query^ GetFieldQuery(
    String^ field,
    String^ queryText,
    int slop
) override
protected:
virtual Query^ GetFieldQuery(
    String^ field,
    String^ queryText,
    int slop
) override
Parameters
field
Type:   Online System String
queryText
Type:   Online System String
slop
Type:   Online System Int32
See Also
MultiFieldQueryParser Class
MultiFieldQueryParser Members
GetFieldQuery Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFuzzyQuery Method

MultiFieldQueryParser GetFuzzyQuery Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Query GetFuzzyQuery(
    string field,
    string termStr,
    float minSimilarity
)
protected override Query GetFuzzyQuery(
    string field,
    string termStr,
    float minSimilarity
)
Protected Overrides Function GetFuzzyQuery ( _
    field As String, _
    termStr As String, _
    minSimilarity As Single _
) As Query
Protected Overrides Function GetFuzzyQuery ( _
    field As String, _
    termStr As String, _
    minSimilarity As Single _
) As Query
protected:
virtual Query^ GetFuzzyQuery(
    String^ field,
    String^ termStr,
    float minSimilarity
) override
protected:
virtual Query^ GetFuzzyQuery(
    String^ field,
    String^ termStr,
    float minSimilarity
) override
Parameters
field
Type:   Online System String
termStr
Type:   Online System String
minSimilarity
Type:   Online System Single
See Also
MultiFieldQueryParser Class
MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPrefixQuery Method

MultiFieldQueryParser GetPrefixQuery Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Query GetPrefixQuery(
    string field,
    string termStr
)
protected override Query GetPrefixQuery(
    string field,
    string termStr
)
Protected Overrides Function GetPrefixQuery ( _
    field As String, _
    termStr As String _
) As Query
Protected Overrides Function GetPrefixQuery ( _
    field As String, _
    termStr As String _
) As Query
protected:
virtual Query^ GetPrefixQuery(
    String^ field,
    String^ termStr
) override
protected:
virtual Query^ GetPrefixQuery(
    String^ field,
    String^ termStr
) override
Parameters
field
Type:   Online System String
termStr
Type:   Online System String
See Also
MultiFieldQueryParser Class
MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetRangeQuery Method

MultiFieldQueryParser GetRangeQuery Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Query GetRangeQuery(
    string field,
    string part1,
    string part2,
    bool inclusive
)
protected override Query GetRangeQuery(
    string field,
    string part1,
    string part2,
    bool inclusive
)
Protected Overrides Function GetRangeQuery ( _
    field As String, _
    part1 As String, _
    part2 As String, _
    inclusive As Boolean _
) As Query
Protected Overrides Function GetRangeQuery ( _
    field As String, _
    part1 As String, _
    part2 As String, _
    inclusive As Boolean _
) As Query
protected:
virtual Query^ GetRangeQuery(
    String^ field,
    String^ part1,
    String^ part2,
    bool inclusive
) override
protected:
virtual Query^ GetRangeQuery(
    String^ field,
    String^ part1,
    String^ part2,
    bool inclusive
) override
Parameters
field
Type:   Online System String
part1
Type:   Online System String
part2
Type:   Online System String
inclusive
Type:   Online System Boolean
See Also
MultiFieldQueryParser Class
MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetWildcardQuery Method

MultiFieldQueryParser GetWildcardQuery Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Query GetWildcardQuery(
    string field,
    string termStr
)
protected override Query GetWildcardQuery(
    string field,
    string termStr
)
Protected Overrides Function GetWildcardQuery ( _
    field As String, _
    termStr As String _
) As Query
Protected Overrides Function GetWildcardQuery ( _
    field As String, _
    termStr As String _
) As Query
protected:
virtual Query^ GetWildcardQuery(
    String^ field,
    String^ termStr
) override
protected:
virtual Query^ GetWildcardQuery(
    String^ field,
    String^ termStr
) override
Parameters
field
Type:   Online System String
termStr
Type:   Online System String
See Also
MultiFieldQueryParser Class
MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Parse Method

MultiFieldQueryParser Parse Method Lucene.Net Class Library
Overload List
Name Description
Public method Parse(String)
Parses a query string, returning a {@link Lucene.Net.Search.Query}.
(Inherited from QueryParser.)
Parse(Version, String , String , Analyzer)
Parses a query which searches on the fields specified.

If x fields are specified, this effectively constructs:
View Colorized Copy to Clipboard Print
(field1:query1) (field2:query2) (field3:query3)...(fieldx:queryx)
(field1:query1) (field2:query2) (field3:query3)...(fieldx:queryx)
Parse(Version, String, String , Occur , Analyzer)
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

Uasge:
View Colorized Copy to Clipboard Print
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse("query", fields, flags, analyzer);
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse("query", fields, flags, analyzer);

The code above would construct a query:
View Colorized Copy to Clipboard Print
(filename:query) +(contents:query) -(description:query)
(filename:query) +(contents:query) -(description:query)
Parse(Version, String , String , Occur , Analyzer)
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

Usage:
View Colorized Copy to Clipboard Print
String[] query = {"query1", "query2", "query3"};
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse(query, fields, flags, analyzer);
String[] query = {"query1", "query2", "query3"};
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse(query, fields, flags, analyzer);

The code above would construct a query:
View Colorized Copy to Clipboard Print
(filename:query1) +(contents:query2) -(description:query3)
(filename:query1) +(contents:query2) -(description:query3)
Back to Top
See Also
MultiFieldQueryParser Class
MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Parse Method (Version, String[], String[], Analyzer)

MultiFieldQueryParser Parse Method (Version, String , String , Analyzer) Lucene.Net Class Library
Parses a query which searches on the fields specified.

If x fields are specified, this effectively constructs:
View Colorized Copy to Clipboard Print
(field1:query1) (field2:query2) (field3:query3)...(fieldx:queryx)
(field1:query1) (field2:query2) (field3:query3)...(fieldx:queryx)
if query parsing fails
if the length of the queries array differs from the length of the fields array

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Query Parse(
    Version matchVersion,
    string[] queries,
    string[] fields,
    Analyzer analyzer
)
public static Query Parse(
    Version matchVersion,
    string[] queries,
    string[] fields,
    Analyzer analyzer
)
Public Shared Function Parse ( _
    matchVersion As Version, _
    queries As String(), _
    fields As String(), _
    analyzer As Analyzer _
) As Query
Public Shared Function Parse ( _
    matchVersion As Version, _
    queries As String(), _
    fields As String(), _
    analyzer As Analyzer _
) As Query
public:
static Query^ Parse(
    Version matchVersion,
    array<String^>^ queries,
    array<String^>^ fields,
    Analyzer^ analyzer
)
public:
static Query^ Parse(
    Version matchVersion,
    array<String^>^ queries,
    array<String^>^ fields,
    Analyzer^ analyzer
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
Lucene version to match; this is passed through to
            QueryParser.

queries
Type:    Online System String
Queries strings to parse

fields
Type:    Online System String
Fields to search on

analyzer
Type: Lucene.Net.Analysis Analyzer
Analyzer to use

See Also
MultiFieldQueryParser Class
MultiFieldQueryParser Members
Parse Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Parse Method (Version, String, String[], Occur[], Analyzer)

MultiFieldQueryParser Parse Method (Version, String, String , Occur , Analyzer) Lucene.Net Class Library
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

Uasge:
View Colorized Copy to Clipboard Print
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse("query", fields, flags, analyzer);
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse("query", fields, flags, analyzer);

The code above would construct a query:
View Colorized Copy to Clipboard Print
(filename:query) +(contents:query) -(description:query)
(filename:query) +(contents:query) -(description:query)
if query parsing fails
if the length of the fields array differs from the length of the flags array

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Query Parse(
    Version matchVersion,
    string query,
    string[] fields,
    Occur[] flags,
    Analyzer analyzer
)
public static Query Parse(
    Version matchVersion,
    string query,
    string[] fields,
    Occur[] flags,
    Analyzer analyzer
)
Public Shared Function Parse ( _
    matchVersion As Version, _
    query As String, _
    fields As String(), _
    flags As Occur(), _
    analyzer As Analyzer _
) As Query
Public Shared Function Parse ( _
    matchVersion As Version, _
    query As String, _
    fields As String(), _
    flags As Occur(), _
    analyzer As Analyzer _
) As Query
public:
static Query^ Parse(
    Version matchVersion,
    String^ query,
    array<String^>^ fields,
    array<Occur>^ flags,
    Analyzer^ analyzer
)
public:
static Query^ Parse(
    Version matchVersion,
    String^ query,
    array<String^>^ fields,
    array<Occur>^ flags,
    Analyzer^ analyzer
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
Lucene version to match; this is passed through to
            QueryParser.

query
Type:   Online System String
Query string to parse

fields
Type:    Online System String
Fields to search on

flags
Type:  Lucene.Net.Search Occur
Flags describing the fields

analyzer
Type: Lucene.Net.Analysis Analyzer
Analyzer to use

See Also
MultiFieldQueryParser Class
MultiFieldQueryParser Members
Parse Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Parse Method (Version, String[], String[], Occur[], Analyzer)

MultiFieldQueryParser Parse Method (Version, String , String , Occur , Analyzer) Lucene.Net Class Library
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

Usage:
View Colorized Copy to Clipboard Print
String[] query = {"query1", "query2", "query3"};
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse(query, fields, flags, analyzer);
String[] query = {"query1", "query2", "query3"};
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse(query, fields, flags, analyzer);

The code above would construct a query:
View Colorized Copy to Clipboard Print
(filename:query1) +(contents:query2) -(description:query3)
(filename:query1) +(contents:query2) -(description:query3)
if query parsing fails
if the length of the queries, fields, and flags array differ

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Query Parse(
    Version matchVersion,
    string[] queries,
    string[] fields,
    Occur[] flags,
    Analyzer analyzer
)
public static Query Parse(
    Version matchVersion,
    string[] queries,
    string[] fields,
    Occur[] flags,
    Analyzer analyzer
)
Public Shared Function Parse ( _
    matchVersion As Version, _
    queries As String(), _
    fields As String(), _
    flags As Occur(), _
    analyzer As Analyzer _
) As Query
Public Shared Function Parse ( _
    matchVersion As Version, _
    queries As String(), _
    fields As String(), _
    flags As Occur(), _
    analyzer As Analyzer _
) As Query
public:
static Query^ Parse(
    Version matchVersion,
    array<String^>^ queries,
    array<String^>^ fields,
    array<Occur>^ flags,
    Analyzer^ analyzer
)
public:
static Query^ Parse(
    Version matchVersion,
    array<String^>^ queries,
    array<String^>^ fields,
    array<Occur>^ flags,
    Analyzer^ analyzer
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
Lucene version to match; this is passed through to
            QueryParser.

queries
Type:    Online System String
Queries string to parse

fields
Type:    Online System String
Fields to search on

flags
Type:  Lucene.Net.Search Occur
Flags describing the fields

analyzer
Type: Lucene.Net.Analysis Analyzer
Analyzer to use

See Also
MultiFieldQueryParser Class
MultiFieldQueryParser Members
Parse Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiFieldQueryParser Properties

MultiFieldQueryParser Properties Lucene.Net Class Library
The MultiFieldQueryParser type exposes the following members.
Properties
 | Name | Description
Public property | AllowLeadingWildcard | Set to true to allow leading wildcard characters. When set, * or ? are allowed as the first character of a PrefixQuery and WildcardQuery. Note that this can produce very slow queries on big indexes. Default: false. (Inherited from QueryParser.)
Public property | Analyzer | (Inherited from QueryParser.)
Public property | DefaultOperator | Gets or sets the boolean operator of the QueryParser. In default mode (OR_OPERATOR) terms without any modifiers are considered optional: for example capital of Hungary is equal to capital OR of OR Hungary. In AND_OPERATOR mode terms are considered to be in conjunction: the above mentioned query is parsed as capital AND of AND Hungary (Inherited from QueryParser.)
Public property | EnablePositionIncrements | Set to true to enable position increments in result query. When set, result phrase and multi-phrase queries will be aware of position increments. Useful when e.g. a StopFilter increases the position increment of the token that follows an omitted token. Default: false. (Inherited from QueryParser.)
Public property | Field | (Inherited from QueryParser.)
Public property | FuzzyMinSim | Gets or sets the minimal similarity for fuzzy queries. Default is 0.5f. (Inherited from QueryParser.)
Public property | FuzzyPrefixLength | Gets or sets the prefix length for fuzzy queries. (Inherited from QueryParser.)
Public property | Locale | Gets or sets locale used by date range parsing. (Inherited from QueryParser.)
Public property | LowercaseExpandedTerms | Whether terms of wildcard, prefix, fuzzy and range queries are to be automatically lower-cased or not. Default is true. (Inherited from QueryParser.)
Public property | MultiTermRewriteMethod | By default QueryParser uses CONSTANT_SCORE_AUTO_REWRITE_DEFAULT when creating a PrefixQuery, WildcardQuery or RangeQuery. This implementation is generally preferable because it a) Runs faster b) Does not have the scarcity of terms unduly influence score c) avoids any "TooManyBooleanClauses" exception. However, if your application really needs to use the old-fashioned BooleanQuery expansion rewriting and the above points are not relevant then use this to change the rewrite method. (Inherited from QueryParser.)
Public property | PhraseSlop | Gets or sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero. (Inherited from QueryParser.)
Public property | RangeCollator | Gets or sets the collator used to determine index term inclusion in ranges for RangeQuerys. WARNING: Setting the rangeCollator to a non-null collator using this method will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow. (Inherited from QueryParser.)
Back to Top
See Also
MultiFieldQueryParser Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseException Class

ParseException Class Lucene.Net Class Library
This exception is thrown when parse errors are encountered. You can explicitly create objects of this exception type by calling the method generateParseException in the generated parser. You can modify this class to customize your error reporting mechanisms so long as you retain the public fields.
Inheritance Hierarchy
Online System Object
Online System Exception
Lucene.Net.QueryParsers ParseException

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ParseException : Exception
[SerializableAttribute]
public class ParseException : Exception
<SerializableAttribute> _
Public Class ParseException _
    Inherits Exception
<SerializableAttribute> _
Public Class ParseException _
    Inherits Exception
[SerializableAttribute]
public ref class ParseException : public Exception
[SerializableAttribute]
public ref class ParseException : public Exception
See Also
ParseException Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseException Members

ParseException Members Lucene.Net Class Library

The ParseException type exposes the following members.
Constructors
 | Name | Description
Public method | ParseException | The following constructors are for use by you for whatever purpose you can think of. Constructing the exception in this manner makes the exception behave in the normal way - i.e., as documented in the class "Throwable". The fields "errorToken", "expectedTokenSequences", and "tokenImage" do not contain relevant information. The JavaCC generated code does not use these constructors.
Public method | ParseException(String) | Constructor with message.
Public method | ParseException(String, Exception) | Constructor with message.
Public method | ParseException(Token, Int32 , String ) | This constructor is used by the method "generateParseException" in the generated parser. Calling this constructor generates a new object of this type with the fields "currentToken", "expectedTokenSequences", and "tokenImage" set. The boolean flag "specialConstructor" is also set to true to indicate that this constructor was used to create this object. This constructor calls its super class with the empty string to force the "toString" method of parent class "Throwable" to print the error message in the form: ParseException: <result of getMessage>
Back to Top
Methods
 | Name | Description
Protected method | Add_escapes | Used to convert raw characters to their escaped version when these raw version cannot be used as part of an ASCII string literal.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Fields
 | Name | Description
Public field | currentToken | This is the last token that has been consumed successfully. If this object has been created due to a parse error, the token followng this token will (therefore) be the first error token.
Protected field | eol | The end of line string for this machine.
Public field | expectedTokenSequences | Each entry in this array is an array of integers. Each array of integers represents a sequence of tokens (by their ordinal values) that is expected at this point of the parse.
Protected field | specialConstructor | This variable determines which constructor was used to create this object and thereby affects the semantics of the "getMessage" method (see below).
Public field | tokenImage | This is a reference to the "tokenImage" array of the generated parser within which the parse error occurred. This array is defined in the generated ...Constants interface.
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | This method has the standard behavior when this object has been created using the standard constructors. Otherwise, it uses "currentToken" and "expectedTokenSequences" to generate a parse error message and returns it. If this object has been created due to a parse error, and you do not catch it (it gets thrown from the parser), then this method is called during the printing of the final stack trace, and hence the correct error message gets displayed. (Overrides Online Exception Message.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ParseException Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseException Constructor

ParseException Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ParseException | The following constructors are for use by you for whatever purpose you can think of. Constructing the exception in this manner makes the exception behave in the normal way - i.e., as documented in the class "Throwable". The fields "errorToken", "expectedTokenSequences", and "tokenImage" do not contain relevant information. The JavaCC generated code does not use these constructors.
Public method | ParseException(String) | Constructor with message.
Public method | ParseException(String, Exception) | Constructor with message.
Public method | ParseException(Token, Int32 , String ) | This constructor is used by the method "generateParseException" in the generated parser. Calling this constructor generates a new object of this type with the fields "currentToken", "expectedTokenSequences", and "tokenImage" set. The boolean flag "specialConstructor" is also set to true to indicate that this constructor was used to create this object. This constructor calls its super class with the empty string to force the "toString" method of parent class "Throwable" to print the error message in the form: ParseException: <result of getMessage>
Back to Top
See Also
ParseException Class
ParseException Members
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseException Constructor

ParseException Constructor Lucene.Net Class Library
The following constructors are for use by you for whatever purpose you can think of. Constructing the exception in this manner makes the exception behave in the normal way - i.e., as documented in the class "Throwable". The fields "errorToken", "expectedTokenSequences", and "tokenImage" do not contain relevant information. The JavaCC generated code does not use these constructors.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ParseException()
public ParseException()
Public Sub New
Public Sub New
public:
ParseException()
public:
ParseException()
See Also
ParseException Class
ParseException Members
ParseException Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseException Constructor (String)

ParseException Constructor (String) Lucene.Net Class Library
Constructor with message.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ParseException(
    string message
)
public ParseException(
    string message
)
Public Sub New ( _
    message As String _
)
Public Sub New ( _
    message As String _
)
public:
ParseException(
    String^ message
)
public:
ParseException(
    String^ message
)
Parameters
message
Type:   Online System String
See Also
ParseException Class
ParseException Members
ParseException Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseException Constructor (String, Exception)

ParseException Constructor (String, Exception) Lucene.Net Class Library
Constructor with message.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ParseException(
    string message,
    Exception ex
)
public ParseException(
    string message,
    Exception ex
)
Public Sub New ( _
    message As String, _
    ex As Exception _
)
Public Sub New ( _
    message As String, _
    ex As Exception _
)
public:
ParseException(
    String^ message,
    Exception^ ex
)
public:
ParseException(
    String^ message,
    Exception^ ex
)
Parameters
message
Type:   Online System String
ex
Type:   Online System Exception
See Also
ParseException Class
ParseException Members
ParseException Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseException Constructor (Token, Int32[][], String[])

ParseException Constructor (Token, Int32 , String ) Lucene.Net Class Library
This constructor is used by the method "generateParseException" in the generated parser. Calling this constructor generates a new object of this type with the fields "currentToken", "expectedTokenSequences", and "tokenImage" set. The boolean flag "specialConstructor" is also set to true to indicate that this constructor was used to create this object. This constructor calls its super class with the empty string to force the "toString" method of parent class "Throwable" to print the error message in the form: ParseException: <result of getMessage>

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ParseException(
    Token currentTokenVal,
    int[][] expectedTokenSequencesVal,
    string[] tokenImageVal
)
public ParseException(
    Token currentTokenVal,
    int[][] expectedTokenSequencesVal,
    string[] tokenImageVal
)
Public Sub New ( _
    currentTokenVal As Token, _
    expectedTokenSequencesVal As Integer()(), _
    tokenImageVal As String() _
)
Public Sub New ( _
    currentTokenVal As Token, _
    expectedTokenSequencesVal As Integer()(), _
    tokenImageVal As String() _
)
public:
ParseException(
    Token^ currentTokenVal,
    array<array<int>^>^ expectedTokenSequencesVal,
    array<String^>^ tokenImageVal
)
public:
ParseException(
    Token^ currentTokenVal,
    array<array<int>^>^ expectedTokenSequencesVal,
    array<String^>^ tokenImageVal
)
Parameters
currentTokenVal
Type: Lucene.Net.QueryParsers Token
expectedTokenSequencesVal
Type:     Online System Int32
tokenImageVal
Type:    Online System String
See Also
ParseException Class
ParseException Members
ParseException Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseException Fields

ParseException Fields Lucene.Net Class Library
The ParseException type exposes the following members.
Fields
 | Name | Description
Public field | currentToken | This is the last token that has been consumed successfully. If this object has been created due to a parse error, the token followng this token will (therefore) be the first error token.
Protected field | eol | The end of line string for this machine.
Public field | expectedTokenSequences | Each entry in this array is an array of integers. Each array of integers represents a sequence of tokens (by their ordinal values) that is expected at this point of the parse.
Protected field | specialConstructor | This variable determines which constructor was used to create this object and thereby affects the semantics of the "getMessage" method (see below).
Public field | tokenImage | This is a reference to the "tokenImage" array of the generated parser within which the parse error occurred. This array is defined in the generated ...Constants interface.
Back to Top
See Also
ParseException Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


currentToken Field

ParseException currentToken Field Lucene.Net Class Library
This is the last token that has been consumed successfully. If this object has been created due to a parse error, the token followng this token will (therefore) be the first error token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token currentToken
public Token currentToken
Public currentToken As Token
Public currentToken As Token
public:
Token^ currentToken
public:
Token^ currentToken
See Also
ParseException Class
ParseException Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


eol Field

ParseException eol Field Lucene.Net Class Library
The end of line string for this machine.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string eol
protected string eol
Protected eol As String
Protected eol As String
protected:
String^ eol
protected:
String^ eol
See Also
ParseException Class
ParseException Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


expectedTokenSequences Field

ParseException expectedTokenSequences Field Lucene.Net Class Library
Each entry in this array is an array of integers. Each array of integers represents a sequence of tokens (by their ordinal values) that is expected at this point of the parse.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int[][] expectedTokenSequences
public int[][] expectedTokenSequences
Public expectedTokenSequences As Integer()()
Public expectedTokenSequences As Integer()()
public:
array<array<int>^>^ expectedTokenSequences
public:
array<array<int>^>^ expectedTokenSequences
See Also
ParseException Class
ParseException Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


specialConstructor Field

ParseException specialConstructor Field Lucene.Net Class Library
This variable determines which constructor was used to create this object and thereby affects the semantics of the "getMessage" method (see below).

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool specialConstructor
protected bool specialConstructor
Protected specialConstructor As Boolean
Protected specialConstructor As Boolean
protected:
bool specialConstructor
protected:
bool specialConstructor
See Also
ParseException Class
ParseException Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


tokenImage Field

ParseException tokenImage Field Lucene.Net Class Library
This is a reference to the "tokenImage" array of the generated parser within which the parse error occurred. This array is defined in the generated ...Constants interface.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string[] tokenImage
public string[] tokenImage
Public tokenImage As String()
Public tokenImage As String()
public:
array<String^>^ tokenImage
public:
array<String^>^ tokenImage
See Also
ParseException Class
ParseException Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseException Methods

ParseException Methods Lucene.Net Class Library
The ParseException type exposes the following members.
Methods
 | Name | Description
Protected method | Add_escapes | Used to convert raw characters to their escaped version when these raw version cannot be used as part of an ASCII string literal.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ParseException Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add_escapes Method

ParseException Add_escapes Method Lucene.Net Class Library
Used to convert raw characters to their escaped version when these raw version cannot be used as part of an ASCII string literal.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string Add_escapes(
    string str
)
protected virtual string Add_escapes(
    string str
)
Protected Overridable Function Add_escapes ( _
    str As String _
) As String
Protected Overridable Function Add_escapes ( _
    str As String _
) As String
protected:
virtual String^ Add_escapes(
    String^ str
)
protected:
virtual String^ Add_escapes(
    String^ str
)
Parameters
str
Type:   Online System String
See Also
ParseException Class
ParseException Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseException Properties

ParseException Properties Lucene.Net Class Library
The ParseException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | This method has the standard behavior when this object has been created using the standard constructors. Otherwise, it uses "currentToken" and "expectedTokenSequences" to generate a parse error message and returns it. If this object has been created due to a parse error, and you do not catch it (it gets thrown from the parser), then this method is called during the printing of the final stack trace, and hence the correct error message gets displayed. (Overrides Online Exception Message.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ParseException Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Message Property

ParseException Message Property Lucene.Net Class Library
This method has the standard behavior when this object has been created using the standard constructors. Otherwise, it uses "currentToken" and "expectedTokenSequences" to generate a parse error message and returns it. If this object has been created due to a parse error, and you do not catch it (it gets thrown from the parser), then this method is called during the printing of the final stack trace, and hence the correct error message gets displayed.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Message { get; }
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
Public Overrides ReadOnly Property Message As String
    Get
public:
virtual property String^ Message {
    String^ get () override;
}
public:
virtual property String^ Message {
    String^ get () override;
}
Implements
  Online _Exception Message
See Also
ParseException Class
ParseException Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseException Events

ParseException Events Lucene.Net Class Library
The ParseException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ParseException Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParser Class

QueryParser Class Lucene.Net Class Library
This class is generated by JavaCC. The most important method is Parse(String). The syntax for query strings is as follows: A Query is a series of clauses. A clause may be prefixed by:
  • a plus (+) or a minus (-) sign, indicating that the clause is required or prohibited respectively; or
  • a term followed by a colon, indicating the field to be searched. This enables one to construct queries which search multiple fields.
A clause may be either:
  • a term, indicating all the documents that contain this term; or
  • a nested query, enclosed in parentheses. Note that this may be used with a +/- prefix to require any of a set of terms.
Thus, in BNF, the query grammar is:
View Colorized Copy to Clipboard Print
Query  ::= ( Clause )*
Clause ::= ["+", "-"] [<TERM> ":"] ( <TERM> | "(" Query ")" )
Query  ::= ( Clause )*
Clause ::= ["+", "-"] [<TERM> ":"] ( <TERM> | "(" Query ")" )

Examples of appropriately formatted queries can be found in the query syntax documentation.

In TermRangeQuerys, QueryParser tries to detect date values, e.g. date:[6/1/2005 TO 6/4/2005] produces a range query that searches for "date" fields between 2005-06-01 and 2005-06-04. Note that the format of the accepted input depends on the Locale. By default a date is converted into a search term using the deprecated DateField for compatibility reasons. To use the new DateTools to convert dates, a DateTools Resolution has to be set.

The date resolution that shall be used for RangeQueries can be set using SetDateResolution(DateTools Resolution) or SetDateResolution(String, DateTools Resolution). The former sets the default date resolution for all fields, whereas the latter can be used to set field specific date resolutions. Field specific date resolutions take, if set, precedence over the default date resolution.

If you use neither DateField nor DateTools in your index, you can create your own query parser that inherits QueryParser and overwrites GetRangeQuery(String, String, String, Boolean) to use a different method for date conversion.

Note that QueryParser is not thread-safe.

NOTE: there is a new QueryParser in contrib, which matches the same syntax as this class, but is more modular, enabling substantial customization to how a query is created.

NOTE: there is a new QueryParser in contrib, which matches the same syntax as this class, but is more modular, enabling substantial customization to how a query is created. NOTE: You must specify the required Version compatibility when creating QueryParser:
  • As of 2.9, EnablePositionIncrements is true by default.
Inheritance Hierarchy
Online System Object
Lucene.Net.QueryParsers QueryParserConstants
Lucene.Net.QueryParsers QueryParser
Lucene.Net.QueryParsers MultiFieldQueryParser

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class QueryParser : QueryParserConstants
public class QueryParser : QueryParserConstants
Public Class QueryParser _
    Inherits QueryParserConstants
Public Class QueryParser _
    Inherits QueryParserConstants
public ref class QueryParser : public QueryParserConstants
public ref class QueryParser : public QueryParserConstants
See Also
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParser Members

QueryParser Members Lucene.Net Class Library

The QueryParser type exposes the following members.
Constructors
 | Name | Description
Protected method | QueryParser(ICharStream) | Constructor with user supplied CharStream.
Protected method | QueryParser(QueryParserTokenManager) | Constructor with generated Token Manager.
Public method | QueryParser(Version, String, Analyzer) | Initializes a new instance of the QueryParser class
Back to Top
Methods
 | Name | Description
Protected method | AddClause |
Public method | Clause |
Public method | Conjunction |
Public method | Disable_tracing | Disable tracing.
Public method | Enable_tracing | Enable tracing.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
 | Escape | Returns a String where those characters that QueryParser expects to be escaped are escaped by a preceding \.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GenerateParseException | Generate ParseException.
Protected method | GetBooleanQuery(IList BooleanClause ) | Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
Protected method | GetBooleanQuery(IList BooleanClause , Boolean) | Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
Public method | getDateResolution | Returns the date resolution that is used by RangeQueries for the given field. Returns null, if no default or field specific date resolution has been set for the given field.
Protected method | GetFieldQuery(String, String) |
Protected method | GetFieldQuery(String, String, Int32) | Base implementation delegates to {@link #GetFieldQuery(String,String)}. This method may be overridden, for example, to return a SpanNearQuery instead of a PhraseQuery.
Protected method | GetFuzzyQuery | Factory method for generating a query (similar to {@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~) appended.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetNextToken | Get the next Token.
Protected method | GetPrefixQuery | Factory method for generating a query (similar to {@link #getWildcardQuery}). Called when parser parses an input term token that uses prefix notation; that is, contains a single '*' wildcard character as its last character. Since this is a special case of generic wildcard term, and such a query can be optimized easily, this usually results in a different query object. Depending on settings, a prefix term may be lower-cased automatically. It will not go through the default Analyzer, however, since normal Analyzers are unlikely to work properly with wildcard templates. Can be overridden by extending classes, to provide custom handling for wild card queries, which may be necessary due to missing analyzer calls.
Protected method | GetRangeQuery |
Public method | getToken | Get the specific Token.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | GetWildcardQuery | Factory method for generating a query. Called when parser parses an input term token that contains one or more wildcard characters (? and *), but is not a prefix term token (one that has just a single * character at the end) Depending on settings, prefix term may be lower-cased automatically. It will not go through the default Analyzer, however, since normal Analyzers are unlikely to work properly with wildcard templates. Can be overridden by extending classes, to provide custom handling for wildcard queries, which may be necessary due to missing analyzer calls.
 | Main | Command line tool to test QueryParser, using {@link Lucene.Net.Analysis.SimpleAnalyzer}. Usage: java Lucene.Net.QueryParsers.QueryParser <input>
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Modifiers |
Protected method | NewBooleanClause | Builds a new BooleanClause instance
Protected method | NewBooleanQuery | Builds a new BooleanQuery instance
Protected method | NewFuzzyQuery | Builds a new FuzzyQuery instance
Protected method | NewMatchAllDocsQuery | Builds a new MatchAllDocsQuery instance
Protected method | NewMultiPhraseQuery | Builds a new MultiPhraseQuery instance
Protected method | NewPhraseQuery | Builds a new PhraseQuery instance
Protected method | NewPrefixQuery | Builds a new PrefixQuery instance
Protected method | NewRangeQuery | Builds a new TermRangeQuery instance
Protected method | NewTermQuery | Builds a new TermQuery instance
Protected method | NewWildcardQuery | Builds a new WildcardQuery instance
Public method | Parse | Parses a query string, returning a {@link Lucene.Net.Search.Query}.
Public method | Query |
Public method | ReInit(ICharStream) | Reinitialise.
Public method | ReInit(QueryParserTokenManager) | Reinitialise.
Public method | SetDateResolution(DateTools Resolution) | Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.
Public method | SetDateResolution(String, DateTools Resolution) | Sets the date resolution used by RangeQueries for a specific field.
Public method | Term |
Public method | TopLevelQuery |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
 | AND_OPERATOR | Alternative form of QueryParser.Operator.AND
Public field | jj_nt |
 | OR_OPERATOR | Alternative form of QueryParser.Operator.OR
Public field | token |
Public field | token_source |
Back to Top
Properties
 | Name | Description
Public property | AllowLeadingWildcard | Set to true to allow leading wildcard characters. When set, * or ? are allowed as the first character of a PrefixQuery and WildcardQuery. Note that this can produce very slow queries on big indexes. Default: false.
Public property | Analyzer |
Public property | DefaultOperator | Gets or sets the boolean operator of the QueryParser. In default mode (OR_OPERATOR) terms without any modifiers are considered optional: for example capital of Hungary is equal to capital OR of OR Hungary. In AND_OPERATOR mode terms are considered to be in conjunction: the above mentioned query is parsed as capital AND of AND Hungary
Public property | EnablePositionIncrements | Set to true to enable position increments in result query. When set, result phrase and multi-phrase queries will be aware of position increments. Useful when e.g. a StopFilter increases the position increment of the token that follows an omitted token. Default: false.
Public property | Field |
Public property | FuzzyMinSim | Gets or sets the minimal similarity for fuzzy queries. Default is 0.5f.
Public property | FuzzyPrefixLength | Gets or sets the prefix length for fuzzy queries.
Public property | Locale | Gets or sets locale used by date range parsing.
Public property | LowercaseExpandedTerms | Whether terms of wildcard, prefix, fuzzy and range queries are to be automatically lower-cased or not. Default is true.
Public property | MultiTermRewriteMethod | By default QueryParser uses CONSTANT_SCORE_AUTO_REWRITE_DEFAULT when creating a PrefixQuery, WildcardQuery or RangeQuery. This implementation is generally preferable because it a) Runs faster b) Does not have the scarcity of terms unduly influence score c) avoids any "TooManyBooleanClauses" exception. However, if your application really needs to use the old-fashioned BooleanQuery expansion rewriting and the above points are not relevant then use this to change the rewrite method.
Public property | PhraseSlop | Gets or sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.
Public property | RangeCollator | Gets or sets the collator used to determine index term inclusion in ranges for RangeQuerys. WARNING: Setting the rangeCollator to a non-null collator using this method will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.
Back to Top
See Also
QueryParser Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParser Constructor

QueryParser Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Protected method | QueryParser(ICharStream) | Constructor with user supplied CharStream.
Protected method | QueryParser(QueryParserTokenManager) | Constructor with generated Token Manager.
Public method | QueryParser(Version, String, Analyzer) | Initializes a new instance of the QueryParser class
Back to Top
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParser Constructor (ICharStream)

QueryParser Constructor (ICharStream) Lucene.Net Class Library
Constructor with user supplied CharStream.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected QueryParser(
    ICharStream stream
)
protected QueryParser(
    ICharStream stream
)
Protected Sub New ( _
    stream As ICharStream _
)
Protected Sub New ( _
    stream As ICharStream _
)
protected:
QueryParser(
    ICharStream^ stream
)
protected:
QueryParser(
    ICharStream^ stream
)
Parameters
stream
Type: Lucene.Net.QueryParsers ICharStream
See Also
QueryParser Class
QueryParser Members
QueryParser Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParser Constructor (QueryParserTokenManager)

QueryParser Constructor (QueryParserTokenManager) Lucene.Net Class Library
Constructor with generated Token Manager.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected QueryParser(
    QueryParserTokenManager tm
)
protected QueryParser(
    QueryParserTokenManager tm
)
Protected Sub New ( _
    tm As QueryParserTokenManager _
)
Protected Sub New ( _
    tm As QueryParserTokenManager _
)
protected:
QueryParser(
    QueryParserTokenManager^ tm
)
protected:
QueryParser(
    QueryParserTokenManager^ tm
)
Parameters
tm
Type: Lucene.Net.QueryParsers QueryParserTokenManager
See Also
QueryParser Class
QueryParser Members
QueryParser Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParser Constructor (Version, String, Analyzer)

QueryParser Constructor (Version, String, Analyzer) Lucene.Net Class Library
Initializes a new instance of the QueryParser class

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QueryParser(
    Version matchVersion,
    string f,
    Analyzer a
)
public QueryParser(
    Version matchVersion,
    string f,
    Analyzer a
)
Public Sub New ( _
    matchVersion As Version, _
    f As String, _
    a As Analyzer _
)
Public Sub New ( _
    matchVersion As Version, _
    f As String, _
    a As Analyzer _
)
public:
QueryParser(
    Version matchVersion,
    String^ f,
    Analyzer^ a
)
public:
QueryParser(
    Version matchVersion,
    String^ f,
    Analyzer^ a
)
Parameters
matchVersion
Type: Lucene.Net.Util Version
f
Type:   Online System String
a
Type: Lucene.Net.Analysis Analyzer
See Also
QueryParser Class
QueryParser Members
QueryParser Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParser Fields

QueryParser Fields Lucene.Net Class Library
The QueryParser type exposes the following members.
Fields
 | Name | Description
 | AND_OPERATOR | Alternative form of QueryParser.Operator.AND
Public field | jj_nt |
 | OR_OPERATOR | Alternative form of QueryParser.Operator.OR
Public field | token |
Public field | token_source |
Back to Top
See Also
QueryParser Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AND_OPERATOR Field

QueryParser AND_OPERATOR Field Lucene.Net Class Library
Alternative form of QueryParser.Operator.AND

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static QueryParser..::..Operator AND_OPERATOR
public static QueryParser..::..Operator AND_OPERATOR
Public Shared AND_OPERATOR As QueryParser..::..Operator
Public Shared AND_OPERATOR As QueryParser..::..Operator
public:
static QueryParser..::..Operator AND_OPERATOR
public:
static QueryParser..::..Operator AND_OPERATOR
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


jj_nt Field

QueryParser jj_nt Field Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token jj_nt
public Token jj_nt
Public jj_nt As Token
Public jj_nt As Token
public:
Token^ jj_nt
public:
Token^ jj_nt
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OR_OPERATOR Field

QueryParser OR_OPERATOR Field Lucene.Net Class Library
Alternative form of QueryParser.Operator.OR

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static QueryParser..::..Operator OR_OPERATOR
public static QueryParser..::..Operator OR_OPERATOR
Public Shared OR_OPERATOR As QueryParser..::..Operator
Public Shared OR_OPERATOR As QueryParser..::..Operator
public:
static QueryParser..::..Operator OR_OPERATOR
public:
static QueryParser..::..Operator OR_OPERATOR
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


token Field

QueryParser token Field Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token token
public Token token
Public token As Token
Public token As Token
public:
Token^ token
public:
Token^ token
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


token_source Field

QueryParser token_source Field Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QueryParserTokenManager token_source
public QueryParserTokenManager token_source
Public token_source As QueryParserTokenManager
Public token_source As QueryParserTokenManager
public:
QueryParserTokenManager^ token_source
public:
QueryParserTokenManager^ token_source
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParser Methods

QueryParser Methods Lucene.Net Class Library
The QueryParser type exposes the following members.
Methods
 | Name | Description
Protected method | AddClause |
Public method | Clause |
Public method | Conjunction |
Public method | Disable_tracing | Disable tracing.
Public method | Enable_tracing | Enable tracing.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
 | Escape | Returns a String where those characters that QueryParser expects to be escaped are escaped by a preceding \.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GenerateParseException | Generate ParseException.
Protected method | GetBooleanQuery(IList BooleanClause ) | Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
Protected method | GetBooleanQuery(IList BooleanClause , Boolean) | Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
Public method | getDateResolution | Returns the date resolution that is used by RangeQueries for the given field. Returns null, if no default or field specific date resolution has been set for the given field.
Protected method | GetFieldQuery(String, String) |
Protected method | GetFieldQuery(String, String, Int32) | Base implementation delegates to {@link #GetFieldQuery(String,String)}. This method may be overridden, for example, to return a SpanNearQuery instead of a PhraseQuery.
Protected method | GetFuzzyQuery | Factory method for generating a query (similar to {@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~) appended.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetNextToken | Get the next Token.
Protected method | GetPrefixQuery | Factory method for generating a query (similar to {@link #getWildcardQuery}). Called when parser parses an input term token that uses prefix notation; that is, contains a single '*' wildcard character as its last character. Since this is a special case of generic wildcard term, and such a query can be optimized easily, this usually results in a different query object. Depending on settings, a prefix term may be lower-cased automatically. It will not go through the default Analyzer, however, since normal Analyzers are unlikely to work properly with wildcard templates. Can be overridden by extending classes, to provide custom handling for wild card queries, which may be necessary due to missing analyzer calls.
Protected method | GetRangeQuery |
Public method | getToken | Get the specific Token.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | GetWildcardQuery | Factory method for generating a query. Called when parser parses an input term token that contains one or more wildcard characters (? and *), but is not a prefix term token (one that has just a single * character at the end) Depending on settings, prefix term may be lower-cased automatically. It will not go through the default Analyzer, however, since normal Analyzers are unlikely to work properly with wildcard templates. Can be overridden by extending classes, to provide custom handling for wildcard queries, which may be necessary due to missing analyzer calls.
 | Main | Command line tool to test QueryParser, using {@link Lucene.Net.Analysis.SimpleAnalyzer}. Usage: java Lucene.Net.QueryParsers.QueryParser <input>
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Modifiers |
Protected method | NewBooleanClause | Builds a new BooleanClause instance
Protected method | NewBooleanQuery | Builds a new BooleanQuery instance
Protected method | NewFuzzyQuery | Builds a new FuzzyQuery instance
Protected method | NewMatchAllDocsQuery | Builds a new MatchAllDocsQuery instance
Protected method | NewMultiPhraseQuery | Builds a new MultiPhraseQuery instance
Protected method | NewPhraseQuery | Builds a new PhraseQuery instance
Protected method | NewPrefixQuery | Builds a new PrefixQuery instance
Protected method | NewRangeQuery | Builds a new TermRangeQuery instance
Protected method | NewTermQuery | Builds a new TermQuery instance
Protected method | NewWildcardQuery | Builds a new WildcardQuery instance
Public method | Parse | Parses a query string, returning a {@link Lucene.Net.Search.Query}.
Public method | Query |
Public method | ReInit(ICharStream) | Reinitialise.
Public method | ReInit(QueryParserTokenManager) | Reinitialise.
Public method | SetDateResolution(DateTools Resolution) | Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.
Public method | SetDateResolution(String, DateTools Resolution) | Sets the date resolution used by RangeQueries for a specific field.
Public method | Term |
Public method | TopLevelQuery |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
QueryParser Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddClause Method

QueryParser AddClause Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void AddClause(
    List<BooleanClause> clauses,
    int conj,
    int mods,
    Query q
)
protected virtual void AddClause(
    List<BooleanClause> clauses,
    int conj,
    int mods,
    Query q
)
Protected Overridable Sub AddClause ( _
    clauses As List(Of BooleanClause), _
    conj As Integer, _
    mods As Integer, _
    q As Query _
)
Protected Overridable Sub AddClause ( _
    clauses As List(Of BooleanClause), _
    conj As Integer, _
    mods As Integer, _
    q As Query _
)
protected:
virtual void AddClause(
    List<BooleanClause^>^ clauses,
    int conj,
    int mods,
    Query^ q
)
protected:
virtual void AddClause(
    List<BooleanClause^>^ clauses,
    int conj,
    int mods,
    Query^ q
)
Parameters
clauses
Type:   Online System.Collections.Generic List  BooleanClause
conj
Type:   Online System Int32
mods
Type:   Online System Int32
q
Type: Lucene.Net.Search Query
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clause Method

QueryParser Clause Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query Clause(
    string field
)
public Query Clause(
    string field
)
Public Function Clause ( _
    field As String _
) As Query
Public Function Clause ( _
    field As String _
) As Query
public:
Query^ Clause(
    String^ field
)
public:
Query^ Clause(
    String^ field
)
Parameters
field
Type:   Online System String
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Conjunction Method

QueryParser Conjunction Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Conjunction()
public int Conjunction()
Public Function Conjunction As Integer
Public Function Conjunction As Integer
public:
int Conjunction()
public:
int Conjunction()
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Disable_tracing Method

QueryParser Disable_tracing Method Lucene.Net Class Library
Disable tracing.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Disable_tracing()
public void Disable_tracing()
Public Sub Disable_tracing
Public Sub Disable_tracing
public:
void Disable_tracing()
public:
void Disable_tracing()
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Enable_tracing Method

QueryParser Enable_tracing Method Lucene.Net Class Library
Enable tracing.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Enable_tracing()
public void Enable_tracing()
Public Sub Enable_tracing
Public Sub Enable_tracing
public:
void Enable_tracing()
public:
void Enable_tracing()
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Escape Method

QueryParser Escape Method Lucene.Net Class Library
Returns a String where those characters that QueryParser expects to be escaped are escaped by a preceding \.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Escape(
    string s
)
public static string Escape(
    string s
)
Public Shared Function Escape ( _
    s As String _
) As String
Public Shared Function Escape ( _
    s As String _
) As String
public:
static String^ Escape(
    String^ s
)
public:
static String^ Escape(
    String^ s
)
Parameters
s
Type:   Online System String
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GenerateParseException Method

QueryParser GenerateParseException Method Lucene.Net Class Library
Generate ParseException.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual ParseException GenerateParseException()
public virtual ParseException GenerateParseException()
Public Overridable Function GenerateParseException As ParseException
Public Overridable Function GenerateParseException As ParseException
public:
virtual ParseException^ GenerateParseException()
public:
virtual ParseException^ GenerateParseException()
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBooleanQuery Method

QueryParser GetBooleanQuery Method Lucene.Net Class Library
Overload List
 | Name | Description
Protected method | GetBooleanQuery(IList BooleanClause ) | Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
Protected method | GetBooleanQuery(IList BooleanClause , Boolean) | Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
Back to Top
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBooleanQuery Method (IList(BooleanClause))

QueryParser GetBooleanQuery Method (IList BooleanClause ) Lucene.Net Class Library
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Query GetBooleanQuery(
    IList<BooleanClause> clauses
)
protected virtual Query GetBooleanQuery(
    IList<BooleanClause> clauses
)
Protected Overridable Function GetBooleanQuery ( _
    clauses As IList(Of BooleanClause) _
) As Query
Protected Overridable Function GetBooleanQuery ( _
    clauses As IList(Of BooleanClause) _
) As Query
protected:
virtual Query^ GetBooleanQuery(
    IList<BooleanClause^>^ clauses
)
protected:
virtual Query^ GetBooleanQuery(
    IList<BooleanClause^>^ clauses
)
Parameters
clauses
Type:   Online System.Collections.Generic IList  BooleanClause
List that contains {@link BooleanClause} instances
            to join.

Return Value
 Resulting {@link Query} object.

Exceptions
Exception | Condition
Lucene.Net.QueryParsers ParseException | throw in overridden method to disallow
See Also
QueryParser Class
QueryParser Members
GetBooleanQuery Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBooleanQuery Method (IList(BooleanClause), Boolean)

QueryParser GetBooleanQuery Method (IList BooleanClause , Boolean) Lucene.Net Class Library
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Query GetBooleanQuery(
    IList<BooleanClause> clauses,
    bool disableCoord
)
protected virtual Query GetBooleanQuery(
    IList<BooleanClause> clauses,
    bool disableCoord
)
Protected Overridable Function GetBooleanQuery ( _
    clauses As IList(Of BooleanClause), _
    disableCoord As Boolean _
) As Query
Protected Overridable Function GetBooleanQuery ( _
    clauses As IList(Of BooleanClause), _
    disableCoord As Boolean _
) As Query
protected:
virtual Query^ GetBooleanQuery(
    IList<BooleanClause^>^ clauses,
    bool disableCoord
)
protected:
virtual Query^ GetBooleanQuery(
    IList<BooleanClause^>^ clauses,
    bool disableCoord
)
Parameters
clauses
Type:   Online System.Collections.Generic IList  BooleanClause
List that contains {@link BooleanClause} instances
            to join.

disableCoord
Type:   Online System Boolean
true if coord scoring should be disabled.

Return Value
 Resulting {@link Query} object.

Exceptions
Exception | Condition
Lucene.Net.QueryParsers ParseException | throw in overridden method to disallow
See Also
QueryParser Class
QueryParser Members
GetBooleanQuery Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


getDateResolution Method

QueryParser getDateResolution Method Lucene.Net Class Library
Returns the date resolution that is used by RangeQueries for the given field. Returns null, if no default or field specific date resolution has been set for the given field.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual DateTools..::..Resolution getDateResolution(
    string fieldName
)
public virtual DateTools..::..Resolution getDateResolution(
    string fieldName
)
Public Overridable Function getDateResolution ( _
    fieldName As String _
) As DateTools..::..Resolution
Public Overridable Function getDateResolution ( _
    fieldName As String _
) As DateTools..::..Resolution
public:
virtual DateTools..::..Resolution^ getDateResolution(
    String^ fieldName
)
public:
virtual DateTools..::..Resolution^ getDateResolution(
    String^ fieldName
)
Parameters
fieldName
Type:   Online System String
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFieldQuery Method

QueryParser GetFieldQuery Method Lucene.Net Class Library
Overload List
 | Name | Description
Protected method | GetFieldQuery(String, String) |
Protected method | GetFieldQuery(String, String, Int32) | Base implementation delegates to {@link #GetFieldQuery(String,String)}. This method may be overridden, for example, to return a SpanNearQuery instead of a PhraseQuery.
Back to Top
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFieldQuery Method (String, String)

QueryParser GetFieldQuery Method (String, String) Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Query GetFieldQuery(
    string field,
    string queryText
)
protected virtual Query GetFieldQuery(
    string field,
    string queryText
)
Protected Overridable Function GetFieldQuery ( _
    field As String, _
    queryText As String _
) As Query
Protected Overridable Function GetFieldQuery ( _
    field As String, _
    queryText As String _
) As Query
protected:
virtual Query^ GetFieldQuery(
    String^ field,
    String^ queryText
)
protected:
virtual Query^ GetFieldQuery(
    String^ field,
    String^ queryText
)
Parameters
field
Type:   Online System String
queryText
Type:   Online System String
Exceptions
Exception | Condition
Lucene.Net.QueryParsers ParseException | throw in overridden method to disallow
See Also
QueryParser Class
QueryParser Members
GetFieldQuery Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFieldQuery Method (String, String, Int32)

QueryParser GetFieldQuery Method (String, String, Int32) Lucene.Net Class Library
Base implementation delegates to {@link #GetFieldQuery(String,String)}. This method may be overridden, for example, to return a SpanNearQuery instead of a PhraseQuery.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Query GetFieldQuery(
    string field,
    string queryText,
    int slop
)
protected virtual Query GetFieldQuery(
    string field,
    string queryText,
    int slop
)
Protected Overridable Function GetFieldQuery ( _
    field As String, _
    queryText As String, _
    slop As Integer _
) As Query
Protected Overridable Function GetFieldQuery ( _
    field As String, _
    queryText As String, _
    slop As Integer _
) As Query
protected:
virtual Query^ GetFieldQuery(
    String^ field,
    String^ queryText,
    int slop
)
protected:
virtual Query^ GetFieldQuery(
    String^ field,
    String^ queryText,
    int slop
)
Parameters
field
Type:   Online System String
queryText
Type:   Online System String
slop
Type:   Online System Int32
Exceptions
Exception | Condition
Lucene.Net.QueryParsers ParseException | throw in overridden method to disallow
See Also
QueryParser Class
QueryParser Members
GetFieldQuery Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFuzzyQuery Method

QueryParser GetFuzzyQuery Method Lucene.Net Class Library
Factory method for generating a query (similar to {@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~) appended.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Query GetFuzzyQuery(
    string field,
    string termStr,
    float minSimilarity
)
protected virtual Query GetFuzzyQuery(
    string field,
    string termStr,
    float minSimilarity
)
Protected Overridable Function GetFuzzyQuery ( _
    field As String, _
    termStr As String, _
    minSimilarity As Single _
) As Query
Protected Overridable Function GetFuzzyQuery ( _
    field As String, _
    termStr As String, _
    minSimilarity As Single _
) As Query
protected:
virtual Query^ GetFuzzyQuery(
    String^ field,
    String^ termStr,
    float minSimilarity
)
protected:
virtual Query^ GetFuzzyQuery(
    String^ field,
    String^ termStr,
    float minSimilarity
)
Parameters
field
Type:   Online System String
Name of the field query will use.

termStr
Type:   Online System String
Term token to use for building term for the query

minSimilarity
Type:   Online System Single
Return Value
 Resulting {@link Query} built for the term

Exceptions
Exception | Condition
Lucene.Net.QueryParsers ParseException | throw in overridden method to disallow
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetNextToken Method

QueryParser GetNextToken Method Lucene.Net Class Library
Get the next Token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token GetNextToken()
public Token GetNextToken()
Public Function GetNextToken As Token
Public Function GetNextToken As Token
public:
Token^ GetNextToken()
public:
Token^ GetNextToken()
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPrefixQuery Method

QueryParser GetPrefixQuery Method Lucene.Net Class Library
Factory method for generating a query (similar to {@link #getWildcardQuery}). Called when parser parses an input term token that uses prefix notation; that is, contains a single '*' wildcard character as its last character. Since this is a special case of generic wildcard term, and such a query can be optimized easily, this usually results in a different query object.

Depending on settings, a prefix term may be lower-cased automatically. It will not go through the default Analyzer, however, since normal Analyzers are unlikely to work properly with wildcard templates.

Can be overridden by extending classes, to provide custom handling for wild card queries, which may be necessary due to missing analyzer calls.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Query GetPrefixQuery(
    string field,
    string termStr
)
protected virtual Query GetPrefixQuery(
    string field,
    string termStr
)
Protected Overridable Function GetPrefixQuery ( _
    field As String, _
    termStr As String _
) As Query
Protected Overridable Function GetPrefixQuery ( _
    field As String, _
    termStr As String _
) As Query
protected:
virtual Query^ GetPrefixQuery(
    String^ field,
    String^ termStr
)
protected:
virtual Query^ GetPrefixQuery(
    String^ field,
    String^ termStr
)
Parameters
field
Type:   Online System String
Name of the field query will use.

termStr
Type:   Online System String
Term token to use for building term for the query
            (without trailing '*' character!)

Return Value
 Resulting {@link Query} built for the term

Exceptions
Exception | Condition
Lucene.Net.QueryParsers ParseException | throw in overridden method to disallow
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetRangeQuery Method

QueryParser GetRangeQuery Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Query GetRangeQuery(
    string field,
    string part1,
    string part2,
    bool inclusive
)
protected virtual Query GetRangeQuery(
    string field,
    string part1,
    string part2,
    bool inclusive
)
Protected Overridable Function GetRangeQuery ( _
    field As String, _
    part1 As String, _
    part2 As String, _
    inclusive As Boolean _
) As Query
Protected Overridable Function GetRangeQuery ( _
    field As String, _
    part1 As String, _
    part2 As String, _
    inclusive As Boolean _
) As Query
protected:
virtual Query^ GetRangeQuery(
    String^ field,
    String^ part1,
    String^ part2,
    bool inclusive
)
protected:
virtual Query^ GetRangeQuery(
    String^ field,
    String^ part1,
    String^ part2,
    bool inclusive
)
Parameters
field
Type:   Online System String
part1
Type:   Online System String
part2
Type:   Online System String
inclusive
Type:   Online System Boolean
Exceptions
Exception | Condition
Lucene.Net.QueryParsers ParseException | throw in overridden method to disallow
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


getToken Method

QueryParser getToken Method Lucene.Net Class Library
Get the specific Token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token getToken(
    int index
)
public Token getToken(
    int index
)
Public Function getToken ( _
    index As Integer _
) As Token
Public Function getToken ( _
    index As Integer _
) As Token
public:
Token^ getToken(
    int index
)
public:
Token^ getToken(
    int index
)
Parameters
index
Type:   Online System Int32
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetWildcardQuery Method

QueryParser GetWildcardQuery Method Lucene.Net Class Library
Factory method for generating a query. Called when parser parses an input term token that contains one or more wildcard characters (? and *), but is not a prefix term token (one that has just a single * character at the end)

Depending on settings, prefix term may be lower-cased automatically. It will not go through the default Analyzer, however, since normal Analyzers are unlikely to work properly with wildcard templates.

Can be overridden by extending classes, to provide custom handling for wildcard queries, which may be necessary due to missing analyzer calls.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Query GetWildcardQuery(
    string field,
    string termStr
)
protected virtual Query GetWildcardQuery(
    string field,
    string termStr
)
Protected Overridable Function GetWildcardQuery ( _
    field As String, _
    termStr As String _
) As Query
Protected Overridable Function GetWildcardQuery ( _
    field As String, _
    termStr As String _
) As Query
protected:
virtual Query^ GetWildcardQuery(
    String^ field,
    String^ termStr
)
protected:
virtual Query^ GetWildcardQuery(
    String^ field,
    String^ termStr
)
Parameters
field
Type:   Online System String
Name of the field query will use.

termStr
Type:   Online System String
Term token that contains one or more wild card
            characters (? or *), but is not simple prefix term

Return Value
 Resulting {@link Query} built for the term

Exceptions
Exception | Condition
Lucene.Net.QueryParsers ParseException | throw in overridden method to disallow
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Main Method

QueryParser Main Method Lucene.Net Class Library
Command line tool to test QueryParser, using {@link Lucene.Net.Analysis.SimpleAnalyzer}. Usage:
java Lucene.Net.QueryParsers.QueryParser <input>

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[STAThreadAttribute]
public static void Main(
    string[] args
)
[STAThreadAttribute]
public static void Main(
    string[] args
)
<STAThreadAttribute> _
Public Shared Sub Main ( _
    args As String() _
)
<STAThreadAttribute> _
Public Shared Sub Main ( _
    args As String() _
)
public:
[STAThreadAttribute]
static void Main(
    array<String^>^ args
)
public:
[STAThreadAttribute]
static void Main(
    array<String^>^ args
)
Parameters
args
Type:    Online System String
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Modifiers Method

QueryParser Modifiers Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Modifiers()
public int Modifiers()
Public Function Modifiers As Integer
Public Function Modifiers As Integer
public:
int Modifiers()
public:
int Modifiers()
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewBooleanClause Method

QueryParser NewBooleanClause Method Lucene.Net Class Library
Builds a new BooleanClause instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual BooleanClause NewBooleanClause(
    Query q,
    Occur occur
)
protected virtual BooleanClause NewBooleanClause(
    Query q,
    Occur occur
)
Protected Overridable Function NewBooleanClause ( _
    q As Query, _
    occur As Occur _
) As BooleanClause
Protected Overridable Function NewBooleanClause ( _
    q As Query, _
    occur As Occur _
) As BooleanClause
protected:
virtual BooleanClause^ NewBooleanClause(
    Query^ q,
    Occur occur
)
protected:
virtual BooleanClause^ NewBooleanClause(
    Query^ q,
    Occur occur
)
Parameters
q
Type: Lucene.Net.Search Query
sub query

occur
Type: Lucene.Net.Search Occur
how this clause should occur when matching documents

Return Value
 new BooleanClause instance

See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewBooleanQuery Method

QueryParser NewBooleanQuery Method Lucene.Net Class Library
Builds a new BooleanQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual BooleanQuery NewBooleanQuery(
    bool disableCoord
)
protected virtual BooleanQuery NewBooleanQuery(
    bool disableCoord
)
Protected Overridable Function NewBooleanQuery ( _
    disableCoord As Boolean _
) As BooleanQuery
Protected Overridable Function NewBooleanQuery ( _
    disableCoord As Boolean _
) As BooleanQuery
protected:
virtual BooleanQuery^ NewBooleanQuery(
    bool disableCoord
)
protected:
virtual BooleanQuery^ NewBooleanQuery(
    bool disableCoord
)
Parameters
disableCoord
Type:   Online System Boolean
disable coord

Return Value
 new BooleanQuery instance

See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewFuzzyQuery Method

QueryParser NewFuzzyQuery Method Lucene.Net Class Library
Builds a new FuzzyQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Query NewFuzzyQuery(
    Term term,
    float minimumSimilarity,
    int prefixLength
)
protected virtual Query NewFuzzyQuery(
    Term term,
    float minimumSimilarity,
    int prefixLength
)
Protected Overridable Function NewFuzzyQuery ( _
    term As Term, _
    minimumSimilarity As Single, _
    prefixLength As Integer _
) As Query
Protected Overridable Function NewFuzzyQuery ( _
    term As Term, _
    minimumSimilarity As Single, _
    prefixLength As Integer _
) As Query
protected:
virtual Query^ NewFuzzyQuery(
    Term^ term,
    float minimumSimilarity,
    int prefixLength
)
protected:
virtual Query^ NewFuzzyQuery(
    Term^ term,
    float minimumSimilarity,
    int prefixLength
)
Parameters
term
Type: Lucene.Net.Index Term
Term

minimumSimilarity
Type:   Online System Single
minimum similarity

prefixLength
Type:   Online System Int32
prefix length

Return Value
 new FuzzyQuery Instance

See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewMatchAllDocsQuery Method

QueryParser NewMatchAllDocsQuery Method Lucene.Net Class Library
Builds a new MatchAllDocsQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Query NewMatchAllDocsQuery()
protected virtual Query NewMatchAllDocsQuery()
Protected Overridable Function NewMatchAllDocsQuery As Query
Protected Overridable Function NewMatchAllDocsQuery As Query
protected:
virtual Query^ NewMatchAllDocsQuery()
protected:
virtual Query^ NewMatchAllDocsQuery()
Return Value
 new MatchAllDocsQuery instance

See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewMultiPhraseQuery Method

QueryParser NewMultiPhraseQuery Method Lucene.Net Class Library
Builds a new MultiPhraseQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual MultiPhraseQuery NewMultiPhraseQuery()
protected virtual MultiPhraseQuery NewMultiPhraseQuery()
Protected Overridable Function NewMultiPhraseQuery As MultiPhraseQuery
Protected Overridable Function NewMultiPhraseQuery As MultiPhraseQuery
protected:
virtual MultiPhraseQuery^ NewMultiPhraseQuery()
protected:
virtual MultiPhraseQuery^ NewMultiPhraseQuery()
Return Value
 new MultiPhraseQuery instance

See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewPhraseQuery Method

QueryParser NewPhraseQuery Method Lucene.Net Class Library
Builds a new PhraseQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual PhraseQuery NewPhraseQuery()
protected virtual PhraseQuery NewPhraseQuery()
Protected Overridable Function NewPhraseQuery As PhraseQuery
Protected Overridable Function NewPhraseQuery As PhraseQuery
protected:
virtual PhraseQuery^ NewPhraseQuery()
protected:
virtual PhraseQuery^ NewPhraseQuery()
Return Value
 new PhraseQuery instance

See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewPrefixQuery Method

QueryParser NewPrefixQuery Method Lucene.Net Class Library
Builds a new PrefixQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Query NewPrefixQuery(
    Term prefix
)
protected virtual Query NewPrefixQuery(
    Term prefix
)
Protected Overridable Function NewPrefixQuery ( _
    prefix As Term _
) As Query
Protected Overridable Function NewPrefixQuery ( _
    prefix As Term _
) As Query
protected:
virtual Query^ NewPrefixQuery(
    Term^ prefix
)
protected:
virtual Query^ NewPrefixQuery(
    Term^ prefix
)
Parameters
prefix
Type: Lucene.Net.Index Term
Prefix term

Return Value
 new PrefixQuery instance

See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewRangeQuery Method

QueryParser NewRangeQuery Method Lucene.Net Class Library
Builds a new TermRangeQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Query NewRangeQuery(
    string field,
    string part1,
    string part2,
    bool inclusive
)
protected virtual Query NewRangeQuery(
    string field,
    string part1,
    string part2,
    bool inclusive
)
Protected Overridable Function NewRangeQuery ( _
    field As String, _
    part1 As String, _
    part2 As String, _
    inclusive As Boolean _
) As Query
Protected Overridable Function NewRangeQuery ( _
    field As String, _
    part1 As String, _
    part2 As String, _
    inclusive As Boolean _
) As Query
protected:
virtual Query^ NewRangeQuery(
    String^ field,
    String^ part1,
    String^ part2,
    bool inclusive
)
protected:
virtual Query^ NewRangeQuery(
    String^ field,
    String^ part1,
    String^ part2,
    bool inclusive
)
Parameters
field
Type:   Online System String
Field

part1
Type:   Online System String
min

part2
Type:   Online System String
max

inclusive
Type:   Online System Boolean
true if range is inclusive

Return Value
 new TermRangeQuery instance

See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewTermQuery Method

QueryParser NewTermQuery Method Lucene.Net Class Library
Builds a new TermQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Query NewTermQuery(
    Term term
)
protected virtual Query NewTermQuery(
    Term term
)
Protected Overridable Function NewTermQuery ( _
    term As Term _
) As Query
Protected Overridable Function NewTermQuery ( _
    term As Term _
) As Query
protected:
virtual Query^ NewTermQuery(
    Term^ term
)
protected:
virtual Query^ NewTermQuery(
    Term^ term
)
Parameters
term
Type: Lucene.Net.Index Term
term

Return Value
 new TermQuery instance

See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewWildcardQuery Method

QueryParser NewWildcardQuery Method Lucene.Net Class Library
Builds a new WildcardQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Query NewWildcardQuery(
    Term t
)
protected virtual Query NewWildcardQuery(
    Term t
)
Protected Overridable Function NewWildcardQuery ( _
    t As Term _
) As Query
Protected Overridable Function NewWildcardQuery ( _
    t As Term _
) As Query
protected:
virtual Query^ NewWildcardQuery(
    Term^ t
)
protected:
virtual Query^ NewWildcardQuery(
    Term^ t
)
Parameters
t
Type: Lucene.Net.Index Term
wildcard term

Return Value
 new WildcardQuery instance

See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Parse Method

QueryParser Parse Method Lucene.Net Class Library
Parses a query string, returning a {@link Lucene.Net.Search.Query}.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Query Parse(
    string query
)
public virtual Query Parse(
    string query
)
Public Overridable Function Parse ( _
    query As String _
) As Query
Public Overridable Function Parse ( _
    query As String _
) As Query
public:
virtual Query^ Parse(
    String^ query
)
public:
virtual Query^ Parse(
    String^ query
)
Parameters
query
Type:   Online System String
 the query string to be parsed.

See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Query Method

QueryParser Query Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query Query(
    string field
)
public Query Query(
    string field
)
Public Function Query ( _
    field As String _
) As Query
Public Function Query ( _
    field As String _
) As Query
public:
Query^ Query(
    String^ field
)
public:
Query^ Query(
    String^ field
)
Parameters
field
Type:   Online System String
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReInit Method

QueryParser ReInit Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ReInit(ICharStream) | Reinitialise.
Public method | ReInit(QueryParserTokenManager) | Reinitialise.
Back to Top
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReInit Method (ICharStream)

QueryParser ReInit Method (ICharStream) Lucene.Net Class Library
Reinitialise.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ReInit(
    ICharStream stream
)
public void ReInit(
    ICharStream stream
)
Public Sub ReInit ( _
    stream As ICharStream _
)
Public Sub ReInit ( _
    stream As ICharStream _
)
public:
void ReInit(
    ICharStream^ stream
)
public:
void ReInit(
    ICharStream^ stream
)
Parameters
stream
Type: Lucene.Net.QueryParsers ICharStream
See Also
QueryParser Class
QueryParser Members
ReInit Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReInit Method (QueryParserTokenManager)

QueryParser ReInit Method (QueryParserTokenManager) Lucene.Net Class Library
Reinitialise.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ReInit(
    QueryParserTokenManager tm
)
public void ReInit(
    QueryParserTokenManager tm
)
Public Sub ReInit ( _
    tm As QueryParserTokenManager _
)
Public Sub ReInit ( _
    tm As QueryParserTokenManager _
)
public:
void ReInit(
    QueryParserTokenManager^ tm
)
public:
void ReInit(
    QueryParserTokenManager^ tm
)
Parameters
tm
Type: Lucene.Net.QueryParsers QueryParserTokenManager
See Also
QueryParser Class
QueryParser Members
ReInit Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetDateResolution Method

QueryParser SetDateResolution Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | SetDateResolution(DateTools Resolution) | Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.
Public method | SetDateResolution(String, DateTools Resolution) | Sets the date resolution used by RangeQueries for a specific field.
Back to Top
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetDateResolution Method (DateTools.Resolution)

QueryParser SetDateResolution Method (DateTools Resolution) Lucene.Net Class Library
Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetDateResolution(
    DateTools..::..Resolution dateResolution
)
public virtual void SetDateResolution(
    DateTools..::..Resolution dateResolution
)
Public Overridable Sub SetDateResolution ( _
    dateResolution As DateTools..::..Resolution _
)
Public Overridable Sub SetDateResolution ( _
    dateResolution As DateTools..::..Resolution _
)
public:
virtual void SetDateResolution(
    DateTools..::..Resolution^ dateResolution
)
public:
virtual void SetDateResolution(
    DateTools..::..Resolution^ dateResolution
)
Parameters
dateResolution
Type: Lucene.Net.Documents DateTools Resolution
the default date resolution to set

See Also
QueryParser Class
QueryParser Members
SetDateResolution Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetDateResolution Method (String, DateTools.Resolution)

QueryParser SetDateResolution Method (String, DateTools Resolution) Lucene.Net Class Library
Sets the date resolution used by RangeQueries for a specific field.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetDateResolution(
    string fieldName,
    DateTools..::..Resolution dateResolution
)
public virtual void SetDateResolution(
    string fieldName,
    DateTools..::..Resolution dateResolution
)
Public Overridable Sub SetDateResolution ( _
    fieldName As String, _
    dateResolution As DateTools..::..Resolution _
)
Public Overridable Sub SetDateResolution ( _
    fieldName As String, _
    dateResolution As DateTools..::..Resolution _
)
public:
virtual void SetDateResolution(
    String^ fieldName,
    DateTools..::..Resolution^ dateResolution
)
public:
virtual void SetDateResolution(
    String^ fieldName,
    DateTools..::..Resolution^ dateResolution
)
Parameters
fieldName
Type:   Online System String
field for which the date resolution is to be set

dateResolution
Type: Lucene.Net.Documents DateTools Resolution
date resolution to set

See Also
QueryParser Class
QueryParser Members
SetDateResolution Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Method

QueryParser Term Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query Term(
    string field
)
public Query Term(
    string field
)
Public Function Term ( _
    field As String _
) As Query
Public Function Term ( _
    field As String _
) As Query
public:
Query^ Term(
    String^ field
)
public:
Query^ Term(
    String^ field
)
Parameters
field
Type:   Online System String
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopLevelQuery Method

QueryParser TopLevelQuery Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query TopLevelQuery(
    string field
)
public Query TopLevelQuery(
    string field
)
Public Function TopLevelQuery ( _
    field As String _
) As Query
Public Function TopLevelQuery ( _
    field As String _
) As Query
public:
Query^ TopLevelQuery(
    String^ field
)
public:
Query^ TopLevelQuery(
    String^ field
)
Parameters
field
Type:   Online System String
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParser Properties

QueryParser Properties Lucene.Net Class Library
The QueryParser type exposes the following members.
Properties
 | Name | Description
Public property | AllowLeadingWildcard | Set to true to allow leading wildcard characters. When set, * or ? are allowed as the first character of a PrefixQuery and WildcardQuery. Note that this can produce very slow queries on big indexes. Default: false.
Public property | Analyzer |
Public property | DefaultOperator | Gets or sets the boolean operator of the QueryParser. In default mode (OR_OPERATOR) terms without any modifiers are considered optional: for example capital of Hungary is equal to capital OR of OR Hungary. In AND_OPERATOR mode terms are considered to be in conjunction: the above mentioned query is parsed as capital AND of AND Hungary
Public property | EnablePositionIncrements | Set to true to enable position increments in result query. When set, result phrase and multi-phrase queries will be aware of position increments. Useful when e.g. a StopFilter increases the position increment of the token that follows an omitted token. Default: false.
Public property | Field |
Public property | FuzzyMinSim | Gets or sets the minimal similarity for fuzzy queries. Default is 0.5f.
Public property | FuzzyPrefixLength | Gets or sets the prefix length for fuzzy queries.
Public property | Locale | Gets or sets locale used by date range parsing.
Public property | LowercaseExpandedTerms | Whether terms of wildcard, prefix, fuzzy and range queries are to be automatically lower-cased or not. Default is true.
Public property | MultiTermRewriteMethod | By default QueryParser uses CONSTANT_SCORE_AUTO_REWRITE_DEFAULT when creating a PrefixQuery, WildcardQuery or RangeQuery. This implementation is generally preferable because it a) Runs faster b) Does not have the scarcity of terms unduly influence score c) avoids any "TooManyBooleanClauses" exception. However, if your application really needs to use the old-fashioned BooleanQuery expansion rewriting and the above points are not relevant then use this to change the rewrite method.
Public property | PhraseSlop | Gets or sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.
Public property | RangeCollator | Gets or sets the collator used to determine index term inclusion in ranges for RangeQuerys. WARNING: Setting the rangeCollator to a non-null collator using this method will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.
Back to Top
See Also
QueryParser Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AllowLeadingWildcard Property

QueryParser AllowLeadingWildcard Property Lucene.Net Class Library
Set to true to allow leading wildcard characters.

When set, * or ? are allowed as the first character of a PrefixQuery and WildcardQuery. Note that this can produce very slow queries on big indexes.

Default: false.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool AllowLeadingWildcard { get; set; }
public virtual bool AllowLeadingWildcard { get; set; }
Public Overridable Property AllowLeadingWildcard As Boolean
    Get
    Set
Public Overridable Property AllowLeadingWildcard As Boolean
    Get
    Set
public:
virtual property bool AllowLeadingWildcard {
    bool get ();
    void set (bool value);
}
public:
virtual property bool AllowLeadingWildcard {
    bool get ();
    void set (bool value);
}
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Analyzer Property

QueryParser Analyzer Property Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Analyzer Analyzer { get; }
public virtual Analyzer Analyzer { get; }
Public Overridable ReadOnly Property Analyzer As Analyzer
    Get
Public Overridable ReadOnly Property Analyzer As Analyzer
    Get
public:
virtual property Analyzer^ Analyzer {
    Analyzer^ get ();
}
public:
virtual property Analyzer^ Analyzer {
    Analyzer^ get ();
}
Field Value
 Returns the analyzer.
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DefaultOperator Property

QueryParser DefaultOperator Property Lucene.Net Class Library
Gets or sets the boolean operator of the QueryParser. In default mode (OR_OPERATOR) terms without any modifiers are considered optional: for example capital of Hungary is equal to capital OR of OR Hungary.
In AND_OPERATOR mode terms are considered to be in conjunction: the above mentioned query is parsed as capital AND of AND Hungary

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual QueryParser..::..Operator DefaultOperator { get; set; }
public virtual QueryParser..::..Operator DefaultOperator { get; set; }
Public Overridable Property DefaultOperator As QueryParser..::..Operator
    Get
    Set
Public Overridable Property DefaultOperator As QueryParser..::..Operator
    Get
    Set
public:
virtual property QueryParser..::..Operator DefaultOperator {
    QueryParser..::..Operator get ();
    void set (QueryParser..::..Operator value);
}
public:
virtual property QueryParser..::..Operator DefaultOperator {
    QueryParser..::..Operator get ();
    void set (QueryParser..::..Operator value);
}
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EnablePositionIncrements Property

QueryParser EnablePositionIncrements Property Lucene.Net Class Library
Set to true to enable position increments in result query.

When set, result phrase and multi-phrase queries will be aware of position increments. Useful when e.g. a StopFilter increases the position increment of the token that follows an omitted token.

Default: false.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool EnablePositionIncrements { get; set; }
public virtual bool EnablePositionIncrements { get; set; }
Public Overridable Property EnablePositionIncrements As Boolean
    Get
    Set
Public Overridable Property EnablePositionIncrements As Boolean
    Get
    Set
public:
virtual property bool EnablePositionIncrements {
    bool get ();
    void set (bool value);
}
public:
virtual property bool EnablePositionIncrements {
    bool get ();
    void set (bool value);
}
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

QueryParser Field Property Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Field { get; }
public virtual string Field { get; }
Public Overridable ReadOnly Property Field As String
    Get
Public Overridable ReadOnly Property Field As String
    Get
public:
virtual property String^ Field {
    String^ get ();
}
public:
virtual property String^ Field {
    String^ get ();
}
Field Value
 Returns the field.
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyMinSim Property

QueryParser FuzzyMinSim Property Lucene.Net Class Library
Gets or sets the minimal similarity for fuzzy queries. Default is 0.5f.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual float FuzzyMinSim { get; set; }
public virtual float FuzzyMinSim { get; set; }
Public Overridable Property FuzzyMinSim As Single
    Get
    Set
Public Overridable Property FuzzyMinSim As Single
    Get
    Set
public:
virtual property float FuzzyMinSim {
    float get ();
    void set (float value);
}
public:
virtual property float FuzzyMinSim {
    float get ();
    void set (float value);
}
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyPrefixLength Property

QueryParser FuzzyPrefixLength Property Lucene.Net Class Library
Gets or sets the prefix length for fuzzy queries.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int FuzzyPrefixLength { get; set; }
public virtual int FuzzyPrefixLength { get; set; }
Public Overridable Property FuzzyPrefixLength As Integer
    Get
    Set
Public Overridable Property FuzzyPrefixLength As Integer
    Get
    Set
public:
virtual property int FuzzyPrefixLength {
    int get ();
    void set (int value);
}
public:
virtual property int FuzzyPrefixLength {
    int get ();
    void set (int value);
}
Field Value
 Returns the fuzzyPrefixLength.
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Locale Property

QueryParser Locale Property Lucene.Net Class Library
Gets or sets locale used by date range parsing.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual CultureInfo Locale { get; set; }
public virtual CultureInfo Locale { get; set; }
Public Overridable Property Locale As CultureInfo
    Get
    Set
Public Overridable Property Locale As CultureInfo
    Get
    Set
public:
virtual property CultureInfo^ Locale {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}
public:
virtual property CultureInfo^ Locale {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowercaseExpandedTerms Property

QueryParser LowercaseExpandedTerms Property Lucene.Net Class Library
Whether terms of wildcard, prefix, fuzzy and range queries are to be automatically lower-cased or not. Default is true.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool LowercaseExpandedTerms { get; set; }
public virtual bool LowercaseExpandedTerms { get; set; }
Public Overridable Property LowercaseExpandedTerms As Boolean
    Get
    Set
Public Overridable Property LowercaseExpandedTerms As Boolean
    Get
    Set
public:
virtual property bool LowercaseExpandedTerms {
    bool get ();
    void set (bool value);
}
public:
virtual property bool LowercaseExpandedTerms {
    bool get ();
    void set (bool value);
}
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermRewriteMethod Property

QueryParser MultiTermRewriteMethod Property Lucene.Net Class Library
By default QueryParser uses CONSTANT_SCORE_AUTO_REWRITE_DEFAULT when creating a PrefixQuery, WildcardQuery or RangeQuery. This implementation is generally preferable because it a) Runs faster b) Does not have the scarcity of terms unduly influence score c) avoids any "TooManyBooleanClauses" exception. However, if your application really needs to use the old-fashioned BooleanQuery expansion rewriting and the above points are not relevant then use this to change the rewrite method.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual RewriteMethod MultiTermRewriteMethod { get; set; }
public virtual RewriteMethod MultiTermRewriteMethod { get; set; }
Public Overridable Property MultiTermRewriteMethod As RewriteMethod
    Get
    Set
Public Overridable Property MultiTermRewriteMethod As RewriteMethod
    Get
    Set
public:
virtual property RewriteMethod^ MultiTermRewriteMethod {
    RewriteMethod^ get ();
    void set (RewriteMethod^ value);
}
public:
virtual property RewriteMethod^ MultiTermRewriteMethod {
    RewriteMethod^ get ();
    void set (RewriteMethod^ value);
}
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PhraseSlop Property

QueryParser PhraseSlop Property Lucene.Net Class Library
Gets or sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int PhraseSlop { get; set; }
public virtual int PhraseSlop { get; set; }
Public Overridable Property PhraseSlop As Integer
    Get
    Set
Public Overridable Property PhraseSlop As Integer
    Get
    Set
public:
virtual property int PhraseSlop {
    int get ();
    void set (int value);
}
public:
virtual property int PhraseSlop {
    int get ();
    void set (int value);
}
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RangeCollator Property

QueryParser RangeCollator Property Lucene.Net Class Library
Gets or sets the collator used to determine index term inclusion in ranges for RangeQuerys.

WARNING: Setting the rangeCollator to a non-null collator using this method will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual CompareInfo RangeCollator { get; set; }
public virtual CompareInfo RangeCollator { get; set; }
Public Overridable Property RangeCollator As CompareInfo
    Get
    Set
Public Overridable Property RangeCollator As CompareInfo
    Get
    Set
public:
virtual property CompareInfo^ RangeCollator {
    CompareInfo^ get ();
    void set (CompareInfo^ value);
}
public:
virtual property CompareInfo^ RangeCollator {
    CompareInfo^ get ();
    void set (CompareInfo^ value);
}
Field Value
 the collator to use when constructing RangeQuerys
See Also
QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParser.Operator Enumeration

QueryParser Operator Enumeration Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Operator
public enum Operator
Public Enumeration Operator
Public Enumeration Operator
public enum class Operator
public enum class Operator
Members
Member name | Value | Description
OR | 0 |
AND | 1 |
See Also
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParserConstants Class

QueryParserConstants Class Lucene.Net Class Library
Token literal values and constants. Generated by org.javacc.parser.OtherFilesGen#start()
Inheritance Hierarchy
Online System Object
Lucene.Net.QueryParsers QueryParserConstants
Lucene.Net.QueryParsers QueryParser
Lucene.Net.QueryParsers QueryParserTokenManager

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class QueryParserConstants
public class QueryParserConstants
Public Class QueryParserConstants
Public Class QueryParserConstants
public ref class QueryParserConstants
public ref class QueryParserConstants
See Also
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParserConstants Members

QueryParserConstants Members Lucene.Net Class Library

The QueryParserConstants type exposes the following members.
Constructors
 | Name | Description
Public method | QueryParserConstants | Initializes a new instance of the QueryParserConstants class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
AndToken | RegularExpression Id.
BoostToken | Lexical state.
CaratToken | RegularExpression Id.
ColonToken | RegularExpression Id.
DefaultToken | Lexical state.
EndOfFileToken | End of File.
EscapedCharToken | RegularExpression Id.
FuzzySlopToken | RegularExpression Id.
LParanToken | RegularExpression Id.
MinusToken | RegularExpression Id.
NotToken | RegularExpression Id.
NumberToken | RegularExpression Id.
NumCharToken | RegularExpression Id.
OrToken | RegularExpression Id.
PlusToken | RegularExpression Id.
PrefixTermToken | RegularExpression Id.
QuotedCharToken | RegularExpression Id.
QuotedToken | RegularExpression Id.
RangeExEndToken | RegularExpression Id.
RangeExGoopToken | RegularExpression Id.
RangeExQuotedToken | RegularExpression Id.
RangeExStartToken | RegularExpression Id.
RangeExToken | Lexical state.
RangeExToToken | RegularExpression Id.
RangeInEndToken | RegularExpression Id.
RangeInGoopToken | RegularExpression Id.
RangeInQuotedToken | RegularExpression Id.
RangeInStartToken | RegularExpression Id.
RangeInToken | Lexical state.
RangeInToToken | RegularExpression Id.
RParenToken | RegularExpression Id.
StarToken | RegularExpression Id.
TermCharToken | RegularExpression Id.
TermStartCharToken | RegularExpression Id.
TermToken | RegularExpression Id.
tokenImage | Literal token values.
WhitespaceToken | RegularExpression Id.
WildTermToken | RegularExpression Id.
Back to Top
See Also
QueryParserConstants Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParserConstants Constructor

QueryParserConstants Constructor Lucene.Net Class Library
Initializes a new instance of the QueryParserConstants class

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QueryParserConstants()
public QueryParserConstants()
Public Sub New
Public Sub New
public:
QueryParserConstants()
public:
QueryParserConstants()
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParserConstants Fields

QueryParserConstants Fields Lucene.Net Class Library
The QueryParserConstants type exposes the following members.
Fields
Name | Description
AndToken | RegularExpression Id.
BoostToken | Lexical state.
CaratToken | RegularExpression Id.
ColonToken | RegularExpression Id.
DefaultToken | Lexical state.
EndOfFileToken | End of File.
EscapedCharToken | RegularExpression Id.
FuzzySlopToken | RegularExpression Id.
LParanToken | RegularExpression Id.
MinusToken | RegularExpression Id.
NotToken | RegularExpression Id.
NumberToken | RegularExpression Id.
NumCharToken | RegularExpression Id.
OrToken | RegularExpression Id.
PlusToken | RegularExpression Id.
PrefixTermToken | RegularExpression Id.
QuotedCharToken | RegularExpression Id.
QuotedToken | RegularExpression Id.
RangeExEndToken | RegularExpression Id.
RangeExGoopToken | RegularExpression Id.
RangeExQuotedToken | RegularExpression Id.
RangeExStartToken | RegularExpression Id.
RangeExToken | Lexical state.
RangeExToToken | RegularExpression Id.
RangeInEndToken | RegularExpression Id.
RangeInGoopToken | RegularExpression Id.
RangeInQuotedToken | RegularExpression Id.
RangeInStartToken | RegularExpression Id.
RangeInToken | Lexical state.
RangeInToToken | RegularExpression Id.
RParenToken | RegularExpression Id.
StarToken | RegularExpression Id.
TermCharToken | RegularExpression Id.
TermStartCharToken | RegularExpression Id.
TermToken | RegularExpression Id.
tokenImage | Literal token values.
WhitespaceToken | RegularExpression Id.
WildTermToken | RegularExpression Id.
Back to Top
See Also
QueryParserConstants Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AndToken Field

QueryParserConstants AndToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int AndToken
protected const int AndToken
Protected Const AndToken As Integer
Protected Const AndToken As Integer
protected:
literal int AndToken
protected:
literal int AndToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BoostToken Field

QueryParserConstants BoostToken Field Lucene.Net Class Library
Lexical state.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int BoostToken
protected const int BoostToken
Protected Const BoostToken As Integer
Protected Const BoostToken As Integer
protected:
literal int BoostToken
protected:
literal int BoostToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CaratToken Field

QueryParserConstants CaratToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int CaratToken
protected const int CaratToken
Protected Const CaratToken As Integer
Protected Const CaratToken As Integer
protected:
literal int CaratToken
protected:
literal int CaratToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ColonToken Field

QueryParserConstants ColonToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int ColonToken
protected const int ColonToken
Protected Const ColonToken As Integer
Protected Const ColonToken As Integer
protected:
literal int ColonToken
protected:
literal int ColonToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DefaultToken Field

QueryParserConstants DefaultToken Field Lucene.Net Class Library
Lexical state.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int DefaultToken
protected const int DefaultToken
Protected Const DefaultToken As Integer
Protected Const DefaultToken As Integer
protected:
literal int DefaultToken
protected:
literal int DefaultToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EndOfFileToken Field

QueryParserConstants EndOfFileToken Field Lucene.Net Class Library
End of File.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int EndOfFileToken
protected const int EndOfFileToken
Protected Const EndOfFileToken As Integer
Protected Const EndOfFileToken As Integer
protected:
literal int EndOfFileToken
protected:
literal int EndOfFileToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EscapedCharToken Field

QueryParserConstants EscapedCharToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int EscapedCharToken
protected const int EscapedCharToken
Protected Const EscapedCharToken As Integer
Protected Const EscapedCharToken As Integer
protected:
literal int EscapedCharToken
protected:
literal int EscapedCharToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzySlopToken Field

QueryParserConstants FuzzySlopToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int FuzzySlopToken
protected const int FuzzySlopToken
Protected Const FuzzySlopToken As Integer
Protected Const FuzzySlopToken As Integer
protected:
literal int FuzzySlopToken
protected:
literal int FuzzySlopToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LParanToken Field

QueryParserConstants LParanToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int LParanToken
protected const int LParanToken
Protected Const LParanToken As Integer
Protected Const LParanToken As Integer
protected:
literal int LParanToken
protected:
literal int LParanToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MinusToken Field

QueryParserConstants MinusToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int MinusToken
protected const int MinusToken
Protected Const MinusToken As Integer
Protected Const MinusToken As Integer
protected:
literal int MinusToken
protected:
literal int MinusToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NotToken Field

QueryParserConstants NotToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int NotToken
protected const int NotToken
Protected Const NotToken As Integer
Protected Const NotToken As Integer
protected:
literal int NotToken
protected:
literal int NotToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumberToken Field

QueryParserConstants NumberToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int NumberToken
protected const int NumberToken
Protected Const NumberToken As Integer
Protected Const NumberToken As Integer
protected:
literal int NumberToken
protected:
literal int NumberToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumCharToken Field

QueryParserConstants NumCharToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int NumCharToken
protected const int NumCharToken
Protected Const NumCharToken As Integer
Protected Const NumCharToken As Integer
protected:
literal int NumCharToken
protected:
literal int NumCharToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OrToken Field

QueryParserConstants OrToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int OrToken
protected const int OrToken
Protected Const OrToken As Integer
Protected Const OrToken As Integer
protected:
literal int OrToken
protected:
literal int OrToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PlusToken Field

QueryParserConstants PlusToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int PlusToken
protected const int PlusToken
Protected Const PlusToken As Integer
Protected Const PlusToken As Integer
protected:
literal int PlusToken
protected:
literal int PlusToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixTermToken Field

QueryParserConstants PrefixTermToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int PrefixTermToken
protected const int PrefixTermToken
Protected Const PrefixTermToken As Integer
Protected Const PrefixTermToken As Integer
protected:
literal int PrefixTermToken
protected:
literal int PrefixTermToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QuotedCharToken Field

QueryParserConstants QuotedCharToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int QuotedCharToken
protected const int QuotedCharToken
Protected Const QuotedCharToken As Integer
Protected Const QuotedCharToken As Integer
protected:
literal int QuotedCharToken
protected:
literal int QuotedCharToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QuotedToken Field

QueryParserConstants QuotedToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int QuotedToken
protected const int QuotedToken
Protected Const QuotedToken As Integer
Protected Const QuotedToken As Integer
protected:
literal int QuotedToken
protected:
literal int QuotedToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RangeExEndToken Field

QueryParserConstants RangeExEndToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int RangeExEndToken
protected const int RangeExEndToken
Protected Const RangeExEndToken As Integer
Protected Const RangeExEndToken As Integer
protected:
literal int RangeExEndToken
protected:
literal int RangeExEndToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RangeExGoopToken Field

QueryParserConstants RangeExGoopToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int RangeExGoopToken
protected const int RangeExGoopToken
Protected Const RangeExGoopToken As Integer
Protected Const RangeExGoopToken As Integer
protected:
literal int RangeExGoopToken
protected:
literal int RangeExGoopToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RangeExQuotedToken Field

QueryParserConstants RangeExQuotedToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int RangeExQuotedToken
protected const int RangeExQuotedToken
Protected Const RangeExQuotedToken As Integer
Protected Const RangeExQuotedToken As Integer
protected:
literal int RangeExQuotedToken
protected:
literal int RangeExQuotedToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RangeExStartToken Field

QueryParserConstants RangeExStartToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int RangeExStartToken
protected const int RangeExStartToken
Protected Const RangeExStartToken As Integer
Protected Const RangeExStartToken As Integer
protected:
literal int RangeExStartToken
protected:
literal int RangeExStartToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RangeExToken Field

QueryParserConstants RangeExToken Field Lucene.Net Class Library
Lexical state.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int RangeExToken
protected const int RangeExToken
Protected Const RangeExToken As Integer
Protected Const RangeExToken As Integer
protected:
literal int RangeExToken
protected:
literal int RangeExToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RangeExToToken Field

QueryParserConstants RangeExToToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int RangeExToToken
protected const int RangeExToToken
Protected Const RangeExToToken As Integer
Protected Const RangeExToToken As Integer
protected:
literal int RangeExToToken
protected:
literal int RangeExToToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RangeInEndToken Field

QueryParserConstants RangeInEndToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int RangeInEndToken
protected const int RangeInEndToken
Protected Const RangeInEndToken As Integer
Protected Const RangeInEndToken As Integer
protected:
literal int RangeInEndToken
protected:
literal int RangeInEndToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RangeInGoopToken Field

QueryParserConstants RangeInGoopToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int RangeInGoopToken
protected const int RangeInGoopToken
Protected Const RangeInGoopToken As Integer
Protected Const RangeInGoopToken As Integer
protected:
literal int RangeInGoopToken
protected:
literal int RangeInGoopToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RangeInQuotedToken Field

QueryParserConstants RangeInQuotedToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int RangeInQuotedToken
protected const int RangeInQuotedToken
Protected Const RangeInQuotedToken As Integer
Protected Const RangeInQuotedToken As Integer
protected:
literal int RangeInQuotedToken
protected:
literal int RangeInQuotedToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RangeInStartToken Field

QueryParserConstants RangeInStartToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int RangeInStartToken
protected const int RangeInStartToken
Protected Const RangeInStartToken As Integer
Protected Const RangeInStartToken As Integer
protected:
literal int RangeInStartToken
protected:
literal int RangeInStartToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RangeInToken Field

QueryParserConstants RangeInToken Field Lucene.Net Class Library
Lexical state.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int RangeInToken
protected const int RangeInToken
Protected Const RangeInToken As Integer
Protected Const RangeInToken As Integer
protected:
literal int RangeInToken
protected:
literal int RangeInToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RangeInToToken Field

QueryParserConstants RangeInToToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int RangeInToToken
protected const int RangeInToToken
Protected Const RangeInToToken As Integer
Protected Const RangeInToToken As Integer
protected:
literal int RangeInToToken
protected:
literal int RangeInToToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RParenToken Field

QueryParserConstants RParenToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int RParenToken
protected const int RParenToken
Protected Const RParenToken As Integer
Protected Const RParenToken As Integer
protected:
literal int RParenToken
protected:
literal int RParenToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StarToken Field

QueryParserConstants StarToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int StarToken
protected const int StarToken
Protected Const StarToken As Integer
Protected Const StarToken As Integer
protected:
literal int StarToken
protected:
literal int StarToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermCharToken Field

QueryParserConstants TermCharToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int TermCharToken
protected const int TermCharToken
Protected Const TermCharToken As Integer
Protected Const TermCharToken As Integer
protected:
literal int TermCharToken
protected:
literal int TermCharToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermStartCharToken Field

QueryParserConstants TermStartCharToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int TermStartCharToken
protected const int TermStartCharToken
Protected Const TermStartCharToken As Integer
Protected Const TermStartCharToken As Integer
protected:
literal int TermStartCharToken
protected:
literal int TermStartCharToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermToken Field

QueryParserConstants TermToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int TermToken
protected const int TermToken
Protected Const TermToken As Integer
Protected Const TermToken As Integer
protected:
literal int TermToken
protected:
literal int TermToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


tokenImage Field

QueryParserConstants tokenImage Field Lucene.Net Class Library
Literal token values.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static string[] tokenImage
protected static string[] tokenImage
Protected Shared tokenImage As String()
Protected Shared tokenImage As String()
protected:
static array<String^>^ tokenImage
protected:
static array<String^>^ tokenImage
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WhitespaceToken Field

QueryParserConstants WhitespaceToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int WhitespaceToken
protected const int WhitespaceToken
Protected Const WhitespaceToken As Integer
Protected Const WhitespaceToken As Integer
protected:
literal int WhitespaceToken
protected:
literal int WhitespaceToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WildTermToken Field

QueryParserConstants WildTermToken Field Lucene.Net Class Library
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int WildTermToken
protected const int WildTermToken
Protected Const WildTermToken As Integer
Protected Const WildTermToken As Integer
protected:
literal int WildTermToken
protected:
literal int WildTermToken
See Also
QueryParserConstants Class
QueryParserConstants Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParserConstants Methods

QueryParserConstants Methods Lucene.Net Class Library
The QueryParserConstants type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
QueryParserConstants Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParserTokenManager Class

QueryParserTokenManager Class Lucene.Net Class Library
Token Manager.
Inheritance Hierarchy
Online System Object
Lucene.Net.QueryParsers QueryParserConstants
Lucene.Net.QueryParsers QueryParserTokenManager

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class QueryParserTokenManager : QueryParserConstants
public class QueryParserTokenManager : QueryParserConstants
Public Class QueryParserTokenManager _
    Inherits QueryParserConstants
Public Class QueryParserTokenManager _
    Inherits QueryParserConstants
public ref class QueryParserTokenManager : public QueryParserConstants
public ref class QueryParserTokenManager : public QueryParserConstants
See Also
QueryParserTokenManager Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParserTokenManager Members

QueryParserTokenManager Members Lucene.Net Class Library

The QueryParserTokenManager type exposes the following members.
Constructors
 | Name | Description
Public method | QueryParserTokenManager(ICharStream) | Constructor.
Public method | QueryParserTokenManager(ICharStream, Int32) | Constructor.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetNextToken | Get the next Token.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | JjFillToken |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReInit(ICharStream) | Reinitialise parser.
Public method | ReInit(ICharStream, Int32) | Reinitialise parser.
Public method | SetDebugStream | Set debug output.
Public method | SwitchTo | Switch to specified lex state.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | curChar |
Public field | debugStream | Debug output.
Protected field | input_stream |
 | jjnewLexState | Lex State array.
 | jjstrLiteralImages | Token literal values.
 | lexStateNames | Lexer state names.
Back to Top
See Also
QueryParserTokenManager Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParserTokenManager Constructor

QueryParserTokenManager Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | QueryParserTokenManager(ICharStream) | Constructor.
Public method | QueryParserTokenManager(ICharStream, Int32) | Constructor.
Back to Top
See Also
QueryParserTokenManager Class
QueryParserTokenManager Members
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParserTokenManager Constructor (ICharStream)

QueryParserTokenManager Constructor (ICharStream) Lucene.Net Class Library
Constructor.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QueryParserTokenManager(
    ICharStream stream
)
public QueryParserTokenManager(
    ICharStream stream
)
Public Sub New ( _
    stream As ICharStream _
)
Public Sub New ( _
    stream As ICharStream _
)
public:
QueryParserTokenManager(
    ICharStream^ stream
)
public:
QueryParserTokenManager(
    ICharStream^ stream
)
Parameters
stream
Type: Lucene.Net.QueryParsers ICharStream
See Also
QueryParserTokenManager Class
QueryParserTokenManager Members
QueryParserTokenManager Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParserTokenManager Constructor (ICharStream, Int32)

QueryParserTokenManager Constructor (ICharStream, Int32) Lucene.Net Class Library
Constructor.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QueryParserTokenManager(
    ICharStream stream,
    int lexState
)
public QueryParserTokenManager(
    ICharStream stream,
    int lexState
)
Public Sub New ( _
    stream As ICharStream, _
    lexState As Integer _
)
Public Sub New ( _
    stream As ICharStream, _
    lexState As Integer _
)
public:
QueryParserTokenManager(
    ICharStream^ stream,
    int lexState
)
public:
QueryParserTokenManager(
    ICharStream^ stream,
    int lexState
)
Parameters
stream
Type: Lucene.Net.QueryParsers ICharStream
lexState
Type:   Online System Int32
See Also
QueryParserTokenManager Class
QueryParserTokenManager Members
QueryParserTokenManager Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParserTokenManager Fields

QueryParserTokenManager Fields Lucene.Net Class Library
The QueryParserTokenManager type exposes the following members.
Fields
 | Name | Description
Protected field | curChar |
Public field | debugStream | Debug output.
Protected field | input_stream |
 | jjnewLexState | Lex State array.
 | jjstrLiteralImages | Token literal values.
 | lexStateNames | Lexer state names.
Back to Top
See Also
QueryParserTokenManager Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


curChar Field

QueryParserTokenManager curChar Field Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected char curChar
protected char curChar
Protected curChar As Char
Protected curChar As Char
protected:
wchar_t curChar
protected:
wchar_t curChar
See Also
QueryParserTokenManager Class
QueryParserTokenManager Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


debugStream Field

QueryParserTokenManager debugStream Field Lucene.Net Class Library
Debug output.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StreamWriter debugStream
public StreamWriter debugStream
Public debugStream As StreamWriter
Public debugStream As StreamWriter
public:
StreamWriter^ debugStream
public:
StreamWriter^ debugStream
See Also
QueryParserTokenManager Class
QueryParserTokenManager Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


input_stream Field

QueryParserTokenManager input_stream Field Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ICharStream input_stream
protected ICharStream input_stream
Protected input_stream As ICharStream
Protected input_stream As ICharStream
protected:
ICharStream^ input_stream
protected:
ICharStream^ input_stream
See Also
QueryParserTokenManager Class
QueryParserTokenManager Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


jjnewLexState Field

QueryParserTokenManager jjnewLexState Field Lucene.Net Class Library
Lex State array.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly int[] jjnewLexState
public static readonly int[] jjnewLexState
Public Shared ReadOnly jjnewLexState As Integer()
Public Shared ReadOnly jjnewLexState As Integer()
public:
static initonly array<int>^ jjnewLexState
public:
static initonly array<int>^ jjnewLexState
See Also
QueryParserTokenManager Class
QueryParserTokenManager Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


jjstrLiteralImages Field

QueryParserTokenManager jjstrLiteralImages Field Lucene.Net Class Library
Token literal values.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] jjstrLiteralImages
public static readonly string[] jjstrLiteralImages
Public Shared ReadOnly jjstrLiteralImages As String()
Public Shared ReadOnly jjstrLiteralImages As String()
public:
static initonly array<String^>^ jjstrLiteralImages
public:
static initonly array<String^>^ jjstrLiteralImages
See Also
QueryParserTokenManager Class
QueryParserTokenManager Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


lexStateNames Field

QueryParserTokenManager lexStateNames Field Lucene.Net Class Library
Lexer state names.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] lexStateNames
public static readonly string[] lexStateNames
Public Shared ReadOnly lexStateNames As String()
Public Shared ReadOnly lexStateNames As String()
public:
static initonly array<String^>^ lexStateNames
public:
static initonly array<String^>^ lexStateNames
See Also
QueryParserTokenManager Class
QueryParserTokenManager Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryParserTokenManager Methods

QueryParserTokenManager Methods Lucene.Net Class Library
The QueryParserTokenManager type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetNextToken | Get the next Token.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | JjFillToken |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReInit(ICharStream) | Reinitialise parser.
Public method | ReInit(ICharStream, Int32) | Reinitialise parser.
Public method | SetDebugStream | Set debug output.
Public method | SwitchTo | Switch to specified lex state.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
QueryParserTokenManager Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetNextToken Method

QueryParserTokenManager GetNextToken Method Lucene.Net Class Library
Get the next Token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Token GetNextToken()
public virtual Token GetNextToken()
Public Overridable Function GetNextToken As Token
Public Overridable Function GetNextToken As Token
public:
virtual Token^ GetNextToken()
public:
virtual Token^ GetNextToken()
See Also
QueryParserTokenManager Class
QueryParserTokenManager Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


JjFillToken Method

QueryParserTokenManager JjFillToken Method Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Token JjFillToken()
protected virtual Token JjFillToken()
Protected Overridable Function JjFillToken As Token
Protected Overridable Function JjFillToken As Token
protected:
virtual Token^ JjFillToken()
protected:
virtual Token^ JjFillToken()
See Also
QueryParserTokenManager Class
QueryParserTokenManager Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReInit Method

QueryParserTokenManager ReInit Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ReInit(ICharStream) | Reinitialise parser.
Public method | ReInit(ICharStream, Int32) | Reinitialise parser.
Back to Top
See Also
QueryParserTokenManager Class
QueryParserTokenManager Members
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReInit Method (ICharStream)

QueryParserTokenManager ReInit Method (ICharStream) Lucene.Net Class Library
Reinitialise parser.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ReInit(
    ICharStream stream
)
public virtual void ReInit(
    ICharStream stream
)
Public Overridable Sub ReInit ( _
    stream As ICharStream _
)
Public Overridable Sub ReInit ( _
    stream As ICharStream _
)
public:
virtual void ReInit(
    ICharStream^ stream
)
public:
virtual void ReInit(
    ICharStream^ stream
)
Parameters
stream
Type: Lucene.Net.QueryParsers ICharStream
See Also
QueryParserTokenManager Class
QueryParserTokenManager Members
ReInit Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReInit Method (ICharStream, Int32)

QueryParserTokenManager ReInit Method (ICharStream, Int32) Lucene.Net Class Library
Reinitialise parser.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ReInit(
    ICharStream stream,
    int lexState
)
public virtual void ReInit(
    ICharStream stream,
    int lexState
)
Public Overridable Sub ReInit ( _
    stream As ICharStream, _
    lexState As Integer _
)
Public Overridable Sub ReInit ( _
    stream As ICharStream, _
    lexState As Integer _
)
public:
virtual void ReInit(
    ICharStream^ stream,
    int lexState
)
public:
virtual void ReInit(
    ICharStream^ stream,
    int lexState
)
Parameters
stream
Type: Lucene.Net.QueryParsers ICharStream
lexState
Type:   Online System Int32
See Also
QueryParserTokenManager Class
QueryParserTokenManager Members
ReInit Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetDebugStream Method

QueryParserTokenManager SetDebugStream Method Lucene.Net Class Library
Set debug output.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetDebugStream(
    StreamWriter ds
)
public virtual void SetDebugStream(
    StreamWriter ds
)
Public Overridable Sub SetDebugStream ( _
    ds As StreamWriter _
)
Public Overridable Sub SetDebugStream ( _
    ds As StreamWriter _
)
public:
virtual void SetDebugStream(
    StreamWriter^ ds
)
public:
virtual void SetDebugStream(
    StreamWriter^ ds
)
Parameters
ds
Type:   Online System.IO StreamWriter
See Also
QueryParserTokenManager Class
QueryParserTokenManager Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SwitchTo Method

QueryParserTokenManager SwitchTo Method Lucene.Net Class Library
Switch to specified lex state.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SwitchTo(
    int lexState
)
public virtual void SwitchTo(
    int lexState
)
Public Overridable Sub SwitchTo ( _
    lexState As Integer _
)
Public Overridable Sub SwitchTo ( _
    lexState As Integer _
)
public:
virtual void SwitchTo(
    int lexState
)
public:
virtual void SwitchTo(
    int lexState
)
Parameters
lexState
Type:   Online System Int32
See Also
QueryParserTokenManager Class
QueryParserTokenManager Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Class

Token Class Lucene.Net Class Library
Describes the input token stream.
Inheritance Hierarchy
Online System Object
Lucene.Net.QueryParsers Token

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Token
public class Token
Public Class Token
Public Class Token
public ref class Token
public ref class Token
See Also
Token Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Members

Token Members Lucene.Net Class Library

The Token type exposes the following members.
Constructors
 | Name | Description
Public method | Token | No-argument constructor
Public method | Token(Int32) | Constructs a new token for the specified Image.
Public method | Token(Int32, String) | Constructs a new token for the specified Image and Kind.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | NewToken(Int32) |
 | NewToken(Int32, String) | Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simply add something like : case MyParserConstants.ID : return new IDToken(ofKind, image); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use sit in your lexical actions.
Public method | ToString | Returns the image. (Overrides Online Object ToString .)
Back to Top
Fields
 | Name | Description
Public field | beginColumn | The column number of the first character of this Token.
Public field | beginLine | The line number of the first character of this Token.
Public field | endColumn | The column number of the last character of this Token.
Public field | endLine | The line number of the last character of this Token.
Public field | image | The string image of the token.
Public field | kind | An integer that describes the kind of this token. This numbering system is determined by JavaCCParser, and a table of these numbers is stored in the file ...Constants.java.
Public field | next | A reference to the next regular (non-special) token from the input stream. If this is the last token from the input stream, or if the token manager has not read tokens beyond this one, this field is set to null. This is true only if this token is also a regular token. Otherwise, see below for a description of the contents of this field.
Public field | specialToken | This field is used to access special tokens that occur prior to this token, but after the immediately preceding regular (non-special) token. If there are no such special tokens, this field is set to null. When there are more than one such special token, this field refers to the last of these special tokens, which in turn refers to the next previous special token through its specialToken field, and so on until the first special token (whose specialToken field is null). The next fields of special tokens refer to other special tokens that immediately follow it (without an intervening regular token). If there is no such token, this field is null.
Back to Top
Properties
 | Name | Description
Public property | Value | An optional attribute value of the Token. Tokens which are not used as syntactic sugar will often contain meaningful values that will be used later on by the compiler or interpreter. This attribute value is often different from the image. Any subclass of Token that actually wants to return a non-null value can override this method as appropriate.
Back to Top
See Also
Token Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Constructor

Token Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Token | No-argument constructor
Public method | Token(Int32) | Constructs a new token for the specified Image.
Public method | Token(Int32, String) | Constructs a new token for the specified Image and Kind.
Back to Top
See Also
Token Class
Token Members
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Constructor

Token Constructor Lucene.Net Class Library
No-argument constructor

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token()
public Token()
Public Sub New
Public Sub New
public:
Token()
public:
Token()
See Also
Token Class
Token Members
Token Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Constructor (Int32)

Token Constructor (Int32) Lucene.Net Class Library
Constructs a new token for the specified Image.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token(
    int kind
)
public Token(
    int kind
)
Public Sub New ( _
    kind As Integer _
)
Public Sub New ( _
    kind As Integer _
)
public:
Token(
    int kind
)
public:
Token(
    int kind
)
Parameters
kind
Type:   Online System Int32
See Also
Token Class
Token Members
Token Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Constructor (Int32, String)

Token Constructor (Int32, String) Lucene.Net Class Library
Constructs a new token for the specified Image and Kind.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token(
    int kind,
    string image
)
public Token(
    int kind,
    string image
)
Public Sub New ( _
    kind As Integer, _
    image As String _
)
Public Sub New ( _
    kind As Integer, _
    image As String _
)
public:
Token(
    int kind,
    String^ image
)
public:
Token(
    int kind,
    String^ image
)
Parameters
kind
Type:   Online System Int32
image
Type:   Online System String
See Also
Token Class
Token Members
Token Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Fields

Token Fields Lucene.Net Class Library
The Token type exposes the following members.
Fields
 | Name | Description
Public field | beginColumn | The column number of the first character of this Token.
Public field | beginLine | The line number of the first character of this Token.
Public field | endColumn | The column number of the last character of this Token.
Public field | endLine | The line number of the last character of this Token.
Public field | image | The string image of the token.
Public field | kind | An integer that describes the kind of this token. This numbering system is determined by JavaCCParser, and a table of these numbers is stored in the file ...Constants.java.
Public field | next | A reference to the next regular (non-special) token from the input stream. If this is the last token from the input stream, or if the token manager has not read tokens beyond this one, this field is set to null. This is true only if this token is also a regular token. Otherwise, see below for a description of the contents of this field.
Public field | specialToken | This field is used to access special tokens that occur prior to this token, but after the immediately preceding regular (non-special) token. If there are no such special tokens, this field is set to null. When there are more than one such special token, this field refers to the last of these special tokens, which in turn refers to the next previous special token through its specialToken field, and so on until the first special token (whose specialToken field is null). The next fields of special tokens refer to other special tokens that immediately follow it (without an intervening regular token). If there is no such token, this field is null.
Back to Top
See Also
Token Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


beginColumn Field

Token beginColumn Field Lucene.Net Class Library
The column number of the first character of this Token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int beginColumn
public int beginColumn
Public beginColumn As Integer
Public beginColumn As Integer
public:
int beginColumn
public:
int beginColumn
See Also
Token Class
Token Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


beginLine Field

Token beginLine Field Lucene.Net Class Library
The line number of the first character of this Token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int beginLine
public int beginLine
Public beginLine As Integer
Public beginLine As Integer
public:
int beginLine
public:
int beginLine
See Also
Token Class
Token Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


endColumn Field

Token endColumn Field Lucene.Net Class Library
The column number of the last character of this Token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int endColumn
public int endColumn
Public endColumn As Integer
Public endColumn As Integer
public:
int endColumn
public:
int endColumn
See Also
Token Class
Token Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


endLine Field

Token endLine Field Lucene.Net Class Library
The line number of the last character of this Token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int endLine
public int endLine
Public endLine As Integer
Public endLine As Integer
public:
int endLine
public:
int endLine
See Also
Token Class
Token Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


image Field

Token image Field Lucene.Net Class Library
The string image of the token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string image
public string image
Public image As String
Public image As String
public:
String^ image
public:
String^ image
See Also
Token Class
Token Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


kind Field

Token kind Field Lucene.Net Class Library
An integer that describes the kind of this token. This numbering system is determined by JavaCCParser, and a table of these numbers is stored in the file ...Constants.java.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int kind
public int kind
Public kind As Integer
Public kind As Integer
public:
int kind
public:
int kind
See Also
Token Class
Token Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


next Field

Token next Field Lucene.Net Class Library
A reference to the next regular (non-special) token from the input stream. If this is the last token from the input stream, or if the token manager has not read tokens beyond this one, this field is set to null. This is true only if this token is also a regular token. Otherwise, see below for a description of the contents of this field.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token next
public Token next
Public next As Token
Public next As Token
public:
Token^ next
public:
Token^ next
See Also
Token Class
Token Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


specialToken Field

Token specialToken Field Lucene.Net Class Library
This field is used to access special tokens that occur prior to this token, but after the immediately preceding regular (non-special) token. If there are no such special tokens, this field is set to null. When there are more than one such special token, this field refers to the last of these special tokens, which in turn refers to the next previous special token through its specialToken field, and so on until the first special token (whose specialToken field is null). The next fields of special tokens refer to other special tokens that immediately follow it (without an intervening regular token). If there is no such token, this field is null.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token specialToken
public Token specialToken
Public specialToken As Token
Public specialToken As Token
public:
Token^ specialToken
public:
Token^ specialToken
See Also
Token Class
Token Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Methods

Token Methods Lucene.Net Class Library
The Token type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | NewToken(Int32) |
 | NewToken(Int32, String) | Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simply add something like : case MyParserConstants.ID : return new IDToken(ofKind, image); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use sit in your lexical actions.
Public method | ToString | Returns the image. (Overrides Online Object ToString .)
Back to Top
See Also
Token Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewToken Method

Token NewToken Method Lucene.Net Class Library
Overload List
Name | Description
NewToken(Int32) |
NewToken(Int32, String) | Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simply add something like : case MyParserConstants.ID : return new IDToken(ofKind, image); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use sit in your lexical actions.
Back to Top
See Also
Token Class
Token Members
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewToken Method (Int32)

Token NewToken Method (Int32) Lucene.Net Class Library

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Token NewToken(
    int ofKind
)
public static Token NewToken(
    int ofKind
)
Public Shared Function NewToken ( _
    ofKind As Integer _
) As Token
Public Shared Function NewToken ( _
    ofKind As Integer _
) As Token
public:
static Token^ NewToken(
    int ofKind
)
public:
static Token^ NewToken(
    int ofKind
)
Parameters
ofKind
Type:   Online System Int32
See Also
Token Class
Token Members
NewToken Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewToken Method (Int32, String)

Token NewToken Method (Int32, String) Lucene.Net Class Library
Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simply add something like : case MyParserConstants.ID : return new IDToken(ofKind, image); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use sit in your lexical actions.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Token NewToken(
    int ofKind,
    string image
)
public static Token NewToken(
    int ofKind,
    string image
)
Public Shared Function NewToken ( _
    ofKind As Integer, _
    image As String _
) As Token
Public Shared Function NewToken ( _
    ofKind As Integer, _
    image As String _
) As Token
public:
static Token^ NewToken(
    int ofKind,
    String^ image
)
public:
static Token^ NewToken(
    int ofKind,
    String^ image
)
Parameters
ofKind
Type:   Online System Int32
image
Type:   Online System String
See Also
Token Class
Token Members
NewToken Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

Token ToString Method Lucene.Net Class Library
Returns the image.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
Token Class
Token Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Token Properties

Token Properties Lucene.Net Class Library
The Token type exposes the following members.
Properties
 | Name | Description
Public property | Value | An optional attribute value of the Token. Tokens which are not used as syntactic sugar will often contain meaningful values that will be used later on by the compiler or interpreter. This attribute value is often different from the image. Any subclass of Token that actually wants to return a non-null value can override this method as appropriate.
Back to Top
See Also
Token Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Value Property

Token Value Property Lucene.Net Class Library
An optional attribute value of the Token. Tokens which are not used as syntactic sugar will often contain meaningful values that will be used later on by the compiler or interpreter. This attribute value is often different from the image. Any subclass of Token that actually wants to return a non-null value can override this method as appropriate.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object Value { get; }
public virtual Object Value { get; }
Public Overridable ReadOnly Property Value As Object
    Get
Public Overridable ReadOnly Property Value As Object
    Get
public:
virtual property Object^ Value {
    Object^ get ();
}
public:
virtual property Object^ Value {
    Object^ get ();
}
See Also
Token Class
Token Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenMgrError Class

TokenMgrError Class Lucene.Net Class Library
Token Manager Error.
Inheritance Hierarchy
Online System Object
Online System Exception
Online System ApplicationException
Lucene.Net.QueryParsers TokenMgrError

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TokenMgrError : ApplicationException
[SerializableAttribute]
public class TokenMgrError : ApplicationException
<SerializableAttribute> _
Public Class TokenMgrError _
    Inherits ApplicationException
<SerializableAttribute> _
Public Class TokenMgrError _
    Inherits ApplicationException
[SerializableAttribute]
public ref class TokenMgrError : public ApplicationException
[SerializableAttribute]
public ref class TokenMgrError : public ApplicationException
See Also
TokenMgrError Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenMgrError Members

TokenMgrError Members Lucene.Net Class Library

The TokenMgrError type exposes the following members.
Constructors
 | Name | Description
Public method | TokenMgrError | No arg constructor.
Public method | TokenMgrError(String, Int32) | Constructor with message and reason.
Public method | TokenMgrError(Boolean, Int32, Int32, Int32, String, Char, Int32) | Full Constructor.
Back to Top
Methods
 | Name | Description
 | addEscapes | Replaces unprintable characters by their escaped (or unicode escaped) equivalents in the given string
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
 | LexicalError | Returns a detailed message for the Error when it is thrown by the token manager to indicate a lexical error. Parameters : EOFSeen : indicates if EOF caused the lexical error curLexState : lexical state in which this error occurred errorLine : line number when the error occurred errorColumn : column number when the error occurred errorAfter : prefix that was seen before this error occurred curchar : the offending character Note: You can customize the lexical error message by modifying this method.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | You can also modify the body of this method to customize your error messages. For example, cases like LOOP_DETECTED and INVALID_LEXICAL_STATE are not of end-users concern, so you can return something like : "Internal Error : Please file a bug report .... " from this method for such cases in the release version of your parser. (Overrides Online Exception Message.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
TokenMgrError Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenMgrError Constructor

TokenMgrError Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TokenMgrError | No arg constructor.
Public method | TokenMgrError(String, Int32) | Constructor with message and reason.
Public method | TokenMgrError(Boolean, Int32, Int32, Int32, String, Char, Int32) | Full Constructor.
Back to Top
See Also
TokenMgrError Class
TokenMgrError Members
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenMgrError Constructor

TokenMgrError Constructor Lucene.Net Class Library
No arg constructor.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TokenMgrError()
public TokenMgrError()
Public Sub New
Public Sub New
public:
TokenMgrError()
public:
TokenMgrError()
See Also
TokenMgrError Class
TokenMgrError Members
TokenMgrError Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenMgrError Constructor (String, Int32)

TokenMgrError Constructor (String, Int32) Lucene.Net Class Library
Constructor with message and reason.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TokenMgrError(
    string message,
    int reason
)
public TokenMgrError(
    string message,
    int reason
)
Public Sub New ( _
    message As String, _
    reason As Integer _
)
Public Sub New ( _
    message As String, _
    reason As Integer _
)
public:
TokenMgrError(
    String^ message,
    int reason
)
public:
TokenMgrError(
    String^ message,
    int reason
)
Parameters
message
Type:   Online System String
reason
Type:   Online System Int32
See Also
TokenMgrError Class
TokenMgrError Members
TokenMgrError Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenMgrError Constructor (Boolean, Int32, Int32, Int32, String, Char, Int32)

TokenMgrError Constructor (Boolean, Int32, Int32, Int32, String, Char, Int32) Lucene.Net Class Library
Full Constructor.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TokenMgrError(
    bool EOFSeen,
    int lexState,
    int errorLine,
    int errorColumn,
    string errorAfter,
    char curChar,
    int reason
)
public TokenMgrError(
    bool EOFSeen,
    int lexState,
    int errorLine,
    int errorColumn,
    string errorAfter,
    char curChar,
    int reason
)
Public Sub New ( _
    EOFSeen As Boolean, _
    lexState As Integer, _
    errorLine As Integer, _
    errorColumn As Integer, _
    errorAfter As String, _
    curChar As Char, _
    reason As Integer _
)
Public Sub New ( _
    EOFSeen As Boolean, _
    lexState As Integer, _
    errorLine As Integer, _
    errorColumn As Integer, _
    errorAfter As String, _
    curChar As Char, _
    reason As Integer _
)
public:
TokenMgrError(
    bool EOFSeen,
    int lexState,
    int errorLine,
    int errorColumn,
    String^ errorAfter,
    wchar_t curChar,
    int reason
)
public:
TokenMgrError(
    bool EOFSeen,
    int lexState,
    int errorLine,
    int errorColumn,
    String^ errorAfter,
    wchar_t curChar,
    int reason
)
Parameters
EOFSeen
Type:   Online System Boolean
lexState
Type:   Online System Int32
errorLine
Type:   Online System Int32
errorColumn
Type:   Online System Int32
errorAfter
Type:   Online System String
curChar
Type:   Online System Char
reason
Type:   Online System Int32
See Also
TokenMgrError Class
TokenMgrError Members
TokenMgrError Overload
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenMgrError Methods

TokenMgrError Methods Lucene.Net Class Library
The TokenMgrError type exposes the following members.
Methods
 | Name | Description
 | addEscapes | Replaces unprintable characters by their escaped (or unicode escaped) equivalents in the given string
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
 | LexicalError | Returns a detailed message for the Error when it is thrown by the token manager to indicate a lexical error. Parameters : EOFSeen : indicates if EOF caused the lexical error curLexState : lexical state in which this error occurred errorLine : line number when the error occurred errorColumn : column number when the error occurred errorAfter : prefix that was seen before this error occurred curchar : the offending character Note: You can customize the lexical error message by modifying this method.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
TokenMgrError Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


addEscapes Method

TokenMgrError addEscapes Method Lucene.Net Class Library
Replaces unprintable characters by their escaped (or unicode escaped) equivalents in the given string

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static string addEscapes(
    string str
)
protected static string addEscapes(
    string str
)
Protected Shared Function addEscapes ( _
    str As String _
) As String
Protected Shared Function addEscapes ( _
    str As String _
) As String
protected:
static String^ addEscapes(
    String^ str
)
protected:
static String^ addEscapes(
    String^ str
)
Parameters
str
Type:   Online System String
See Also
TokenMgrError Class
TokenMgrError Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LexicalError Method

TokenMgrError LexicalError Method Lucene.Net Class Library
Returns a detailed message for the Error when it is thrown by the token manager to indicate a lexical error. Parameters : EOFSeen : indicates if EOF caused the lexical error curLexState : lexical state in which this error occurred errorLine : line number when the error occurred errorColumn : column number when the error occurred errorAfter : prefix that was seen before this error occurred curchar : the offending character Note: You can customize the lexical error message by modifying this method.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static string LexicalError(
    bool EOFSeen,
    int lexState,
    int errorLine,
    int errorColumn,
    string errorAfter,
    char curChar
)
protected static string LexicalError(
    bool EOFSeen,
    int lexState,
    int errorLine,
    int errorColumn,
    string errorAfter,
    char curChar
)
Protected Shared Function LexicalError ( _
    EOFSeen As Boolean, _
    lexState As Integer, _
    errorLine As Integer, _
    errorColumn As Integer, _
    errorAfter As String, _
    curChar As Char _
) As String
Protected Shared Function LexicalError ( _
    EOFSeen As Boolean, _
    lexState As Integer, _
    errorLine As Integer, _
    errorColumn As Integer, _
    errorAfter As String, _
    curChar As Char _
) As String
protected:
static String^ LexicalError(
    bool EOFSeen,
    int lexState,
    int errorLine,
    int errorColumn,
    String^ errorAfter,
    wchar_t curChar
)
protected:
static String^ LexicalError(
    bool EOFSeen,
    int lexState,
    int errorLine,
    int errorColumn,
    String^ errorAfter,
    wchar_t curChar
)
Parameters
EOFSeen
Type:   Online System Boolean
lexState
Type:   Online System Int32
errorLine
Type:   Online System Int32
errorColumn
Type:   Online System Int32
errorAfter
Type:   Online System String
curChar
Type:   Online System Char
See Also
TokenMgrError Class
TokenMgrError Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenMgrError Properties

TokenMgrError Properties Lucene.Net Class Library
The TokenMgrError type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | You can also modify the body of this method to customize your error messages. For example, cases like LOOP_DETECTED and INVALID_LEXICAL_STATE are not of end-users concern, so you can return something like : "Internal Error : Please file a bug report .... " from this method for such cases in the release version of your parser. (Overrides Online Exception Message.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
TokenMgrError Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Message Property

TokenMgrError Message Property Lucene.Net Class Library
You can also modify the body of this method to customize your error messages. For example, cases like LOOP_DETECTED and INVALID_LEXICAL_STATE are not of end-users concern, so you can return something like : "Internal Error : Please file a bug report .... " from this method for such cases in the release version of your parser.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Message { get; }
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
Public Overrides ReadOnly Property Message As String
    Get
public:
virtual property String^ Message {
    String^ get () override;
}
public:
virtual property String^ Message {
    String^ get () override;
}
Implements
  Online _Exception Message
See Also
TokenMgrError Class
TokenMgrError Members
Lucene.Net.QueryParsers Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TokenMgrError Events

TokenMgrError Events Lucene.Net Class Library
The TokenMgrError type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
TokenMgrError Class
Lucene.Net.QueryParsers Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lucene.Net.Search Namespace

Lucene.Net.Search Namespace Lucene.Net Class Library
Classes
Class | Description
Public class BooleanClause
A clause in a BooleanQuery.
Public class BooleanQuery
A Query that matches documents matching boolean combinations of other queries, e.g. TermQuerys, PhraseQuerys or other BooleanQuerys.
Protected class BooleanQuery BooleanWeight
Expert: the Weight for BooleanQuery, used to normalize, score and explain these queries.

NOTE: this API and implementation is subject to change suddenly in the next release.

Public class BooleanQuery TooManyClauses
Thrown when an attempt is made to add more than MaxClauseCount clauses. This typically happens if a PrefixQuery, FuzzyQuery, WildcardQuery, or TermRangeQuery is expanded to many terms during search.
Public class | BooleanScorer
Public class CacheEntry
EXPERT: A unique Identifier/Description for each item in the FieldCache. Can be useful for logging/debugging.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

Public class CachingSpanFilter
Wraps another SpanFilter's result and caches it. The purpose is to allow filters to simply filter, and then wrap with this class to add caching.
Public class CachingWrapperFilter
Wraps another filter's result and caches it. The purpose is to allow filters to simply filter, and then wrap with this class to add caching.
Public class Collector

Expert: Collectors are primarily meant to be used to gather raw results from a search, and implement sorting or custom result filtering, collation, etc.

Lucene's core collectors are derived from Collector. Likely your application can use one of these classes, or subclass TopDocsCollector T , instead of implementing Collector directly:
  • TopDocsCollector T is an abstract base class that assumes you will retrieve the top N docs, according to some criteria, after collection is done.
  • TopScoreDocCollector is a concrete subclass TopDocsCollector T and sorts according to score + docID. This is used internally by the IndexSearcher search methods that do not take an explicit Sort. It is likely the most frequently used collector.
  • TopFieldCollector subclasses TopDocsCollector T and sorts according to a specified Sort object (sort by field). This is used internally by the IndexSearcher search methods that take an explicit Sort.
  • TimeLimitingCollector, which wraps any other Collector and aborts the search if it's taken too much time.
  • PositiveScoresOnlyCollector wraps any other Collector and prevents collection of hits whose score is <= 0.0

Collector decouples the score from the collected doc: the score computation is skipped entirely if it's not needed. Collectors that do need the score should implement the SetScorer(Scorer) method, to hold onto the passed Scorer instance, and call Score within the collect method to compute the current hit's score. If your collector may request the score for a single hit multiple times, you should use ScoreCachingWrappingScorer.

NOTE: The doc that is passed to the collect method is relative to the current reader. If your collector needs to resolve this to the docID space of the Multi*Reader, you must re-base it by recording the docBase from the most recent setNextReader call. Here's a simple example showing how to collect docIDs into a BitSet:

View Colorized Copy to Clipboard Print
Searcher searcher = new IndexSearcher(indexReader);
final BitSet bits = new BitSet(indexReader.MaxDoc);
searcher.search(query, new Collector() {
private int docBase;

<em>// ignore scorer</em>
public void setScorer(Scorer scorer) {
}

<em>// accept docs out of order (for a BitSet it doesn't matter)</em>
public boolean acceptsDocsOutOfOrder() {
return true;
}

public void collect(int doc) {
bits.set(doc + docBase);
}

public void setNextReader(IndexReader reader, int docBase) {
this.docBase = docBase;
}
});
Searcher searcher = new IndexSearcher(indexReader);
final BitSet bits = new BitSet(indexReader.MaxDoc);
searcher.search(query, new Collector() {
private int docBase;

<em>// ignore scorer</em>
public void setScorer(Scorer scorer) {
}

<em>// accept docs out of order (for a BitSet it doesn't matter)</em>
public boolean acceptsDocsOutOfOrder() {
return true;
}

public void collect(int doc) {
bits.set(doc + docBase);
}

public void setNextReader(IndexReader reader, int docBase) {
this.docBase = docBase;
}
});

Not all collectors will need to rebase the docID. For example, a collector that simply counts the total number of hits would skip it.

NOTE: Prior to 2.9, Lucene silently filtered out hits with score <= 0. As of 2.9, the core Collectors no longer do that. It's very unusual to have such hits (a negative query boost, or function query returning negative custom scores, could cause it to happen). If you need that behavior, use PositiveScoresOnlyCollector .

NOTE: This API is experimental and might change in incompatible ways in the next release.

Public class ComplexExplanation
Expert: Describes the score computation for document and query, and can distinguish a match independent of a positive value.
Public class ConstantScoreQuery
A query that wraps a filter and simply returns a constant score equal to the query boost for every document in the filter.
Protected class | ConstantScoreQuery ConstantScorer
Protected class | ConstantScoreQuery ConstantWeight
Public class CreationPlaceholder
Expert: Maintains caches of term values.

Created: May 19, 2004 11:13:14 AM
Public class DefaultSimilarity
Expert: Default scoring implementation.
Public class DisjunctionMaxQuery
A query that generates the union of documents produced by its subqueries, and that scores each document with the maximum score for that document as produced by any subquery, plus a tie breaking increment for any additional matching subqueries. This is useful when searching for a word in multiple fields with different boost factors (so that the fields cannot be combined equivalently into a single search field). We want the primary score to be the one associated with the highest boost, not the sum of the field scores (as BooleanQuery would give). If the query is "albino elephant" this ensures that "albino" matching one field and "elephant" matching another gets a higher score than "albino" matching both fields. To get this result, use both BooleanQuery and DisjunctionMaxQuery: for each term a DisjunctionMaxQuery searches for it in each field, while the set of these DisjunctionMaxQuery's is combined into a BooleanQuery. The tie breaker capability allows results that include the same term in multiple fields to be judged better than results that include this term in only the best of those multiple fields, without confusing this with the better case of two different terms in the multiple fields.
Protected class DisjunctionMaxQuery DisjunctionMaxWeight
Expert: the Weight for DisjunctionMaxQuery, used to normalize, score and explain these queries.

NOTE: this API and implementation is subject to change suddenly in the next release.

Public class DocIdSet
A DocIdSet contains a set of doc ids. Implementing classes must only implement Iterator to provide access to the set.
Public class | DocIdSet AnonymousClassDocIdSet
Public class | DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator
Public class DocIdSetIterator
This abstract class defines methods to iterate over a set of non-decreasing doc ids. Note that this class assumes it iterates on doc Ids, and therefore NO_MORE_DOCS is set to Int32.MaxValue in order to be used as a sentinel object. Implementations of this class are expected to consider Online MaxValue as an invalid value.
Public class Explanation
Expert: Describes the score computation for document and query.
Public class Explanation IDFExplanation
Small Util class used to pass both an idf factor as well as an explanation for that factor. This class will likely be held on a Weight, so be aware before storing any large or un-serializable fields.
Public class FieldCacheRangeFilter
A range filter built on top of a cached single term field (in FieldCache).

FieldCacheRangeFilter builds a single cache for the field the first time it is used. Each subsequent FieldCacheRangeFilter on the same field then reuses this cache, even if the range itself changes.

This means that FieldCacheRangeFilter is much faster (sometimes more than 100x as fast) as building a TermRangeFilter if using a NewStringRange(String, String, String, Boolean, Boolean). However, if the range never changes it is slower (around 2x as slow) than building a CachingWrapperFilter on top of a single TermRangeFilter. For numeric data types, this filter may be significantly faster than NumericRangeFilter T . Furthermore, it does not need the numeric values encoded by NumericField. But it has the problem that it only works with exact one value/document (see below).

As with all FieldCache based functionality, FieldCacheRangeFilter is only valid for fields which exact one term for each document (except for NewStringRange(String, String, String, Boolean, Boolean) where 0 terms are also allowed). Due to a restriction of FieldCache, for numeric ranges all terms that do not have a numeric value, 0 is assumed.

Thus it works on dates, prices and other single value fields but will not work on regular text fields. It is preferable to use a NOT_ANALYZED field to ensure that there is only a single term.

This class does not have an constructor, use one of the static factory methods available, that create a correct instance for different data types supported by FieldCache.
Public class | FieldCacheRangeFilter T
Public class FieldCacheTermsFilter
A Filter that only accepts documents whose single term value in the specified field is contained in the provided set of allowed terms.

This is the same functionality as TermsFilter (from contrib/queries), except this filter requires that the field contains only a single term for all documents. Because of drastically different implementations, they also have different performance characteristics, as described below.

The first invocation of this filter on a given field will be slower, since a StringIndex must be created. Subsequent invocations using the same field will re-use this cache. However, as with all functionality based on FieldCache, persistent RAM is consumed to hold the cache, and is not freed until the IndexReader is closed. In contrast, TermsFilter has no persistent RAM consumption.

With each search, this filter translates the specified set of Terms into a private OpenBitSet keyed by term number per unique IndexReader (normally one reader per segment). Then, during matching, the term number for each docID is retrieved from the cache and then checked for inclusion using the OpenBitSet. Since all testing is done using RAM resident data structures, performance should be very fast, most likely fast enough to not require further caching of the DocIdSet for each possible combination of terms. However, because docIDs are simply scanned linearly, an index with a great many small documents may find this linear scan too costly.

In contrast, TermsFilter builds up an OpenBitSet, keyed by docID, every time it's created, by enumerating through all matching docs using TermDocs to seek and scan through each term's docID list. While there is no linear scan of all docIDs, besides the allocation of the underlying array in the OpenBitSet, this approach requires a number of "disk seeks" in proportion to the number of terms, which can be exceptionally costly when there are cache misses in the OS's IO cache.

Generally, this filter will be slower on the first invocation for a given field, but subsequent invocations, even if you change the allowed set of Terms, should be faster than TermsFilter, especially as the number of Terms being matched increases. If you are matching only a very small number of terms, and those terms in turn match a very small number of documents, TermsFilter may perform faster.

Which filter is best is very application dependent.
Protected class | FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet
Protected class | FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator
Public class FieldComparator
Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with TopFieldCollector . The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with FieldValueHitQueue as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The FieldComparator is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • Compare(Int32, Int32) Compare a hit at 'slot a' with hit 'slot b'.
  • SetBottom(Int32) This method is called by FieldValueHitQueue to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • CompareBottom(Int32) Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • Copy(Int32, Int32) Installs a new hit into the priority queue. The FieldValueHitQueue calls this method when a new hit is competitive.
  • SetNextReader(IndexReader, Int32) Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the FieldCache.
  • Item Int32 Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate fields when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.
Public class FieldComparator ByteComparator
Parses field's values as byte (using GetBytes(IndexReader, String) and sorts by ascending value
Public class FieldComparator DocComparator
Sorts by ascending docID
Public class FieldComparator DoubleComparator
Parses field's values as double (using GetDoubles(IndexReader, String) and sorts by ascending value
Public class FieldComparator FloatComparator
Parses field's values as float (using GetFloats(IndexReader, String) and sorts by ascending value
Public class FieldComparator IntComparator
Parses field's values as int (using GetInts(IndexReader, String) and sorts by ascending value
Public class FieldComparator LongComparator
Parses field's values as long (using GetLongs(IndexReader, String) and sorts by ascending value
Public class FieldComparator RelevanceComparator
Sorts by descending relevance. NOTE: if you are sorting only by descending relevance and then secondarily by ascending docID, peformance is faster using TopScoreDocCollector directly (which Search(Query, Int32) uses when no Sort is specified).
Public class FieldComparator ShortComparator
Parses field's values as short (using GetShorts(IndexReader, String)) and sorts by ascending value
Public class FieldComparator StringComparatorLocale
Sorts by a field's value using the Collator for a given Locale.
Public class FieldComparator StringOrdValComparator
Sorts by field's natural String sort order, using ordinals. This is functionally equivalent to FieldComparator StringValComparator , but it first resolves the string to their relative ordinal positions (using the index returned by GetStringIndex(IndexReader, String)), and does most comparisons using the ordinals. For medium to large results, this comparator will be much faster than FieldComparator StringValComparator. For very small result sets it may be slower.
Public class FieldComparator StringValComparator
Sorts by field's natural String sort order. All comparisons are done using String.compareTo, which is slow for medium to large result sets but possibly very fast for very small results sets.
Public class FieldComparatorSource
Provides a FieldComparator for custom field sorting. NOTE: This API is experimental and might change in incompatible ways in the next release.
Public class FieldDoc
Expert: A ScoreDoc which also contains information about how to sort the referenced document. In addition to the document number and score, this object contains an array of values for the document from the field(s) used to sort. For example, if the sort criteria was to sort by fields "a", "b" then "c", the fields object array will have three elements, corresponding respectively to the term values for the document in fields "a", "b" and "c". The class of each element in the array will be either Integer, Float or String depending on the type of values in the terms of each field.

Created: Feb 11, 2004 1:23:38 PM
Public class FieldValueHitQueue
Expert: A hit queue for sorting by hits by terms in more than one field. Uses FieldCache.DEFAULT for maintaining internal term lookup tables. NOTE: This API is experimental and might change in incompatible ways in the next release.
Public class | FieldValueHitQueue Entry
Public class Filter
Abstract base class for restricting which documents may be returned during searching.
Public class FilteredDocIdSet
Abstract decorator class for a DocIdSet implementation that provides on-demand filtering/validation mechanism on a given DocIdSet.

Technically, this same functionality could be achieved with ChainedFilter (under contrib/misc), however the benefit of this class is it never materializes the full bitset for the filter. Instead, the Match(Int32) method is invoked on-demand, per docID visited during searching. If you know few docIDs will be visited, and the logic behind Match(Int32) is relatively costly, this may be a better way to filter than ChainedFilter.
Public class FilteredDocIdSetIterator
Abstract decorator class of a DocIdSetIterator implementation that provides on-demand filter/validation mechanism on an underlying DocIdSetIterator. See FilteredDocIdSet .
Public class FilteredQuery
A query that applies a filter to the results of another query.

Note: the bits are retrieved from the filter each time this query is used in a search - use a CachingWrapperFilter to avoid regenerating the bits every time.

Created: Apr 20, 2004 8:58:29 AM
Public class FilteredTermEnum
Abstract class for enumerating a subset of all terms.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.
Public class FilterManager
Filter caching singleton. It can be used to save filters locally for reuse. This class makes it possble to cache Filters even when using RMI, as it keeps the cache on the seaercher side of the RMI connection. Also could be used as a persistent storage for any filter as long as the filter provides a proper hashCode(), as that is used as the key in the cache. The cache is periodically cleaned up from a separate thread to ensure the cache doesn't exceed the maximum size.
Protected class FilterManager FilterCleaner
Keeps the cache from getting too big. If we were using Java 1.5, we could use LinkedHashMap and we would not need this thread to clean out the cache. The SortedSet sortedFilterItems is used only to sort the items from the cache, so when it's time to clean up we have the TreeSet sort the FilterItems by timestamp. Removes 1.5 * the numbers of items to make the cache smaller. For example: If cache clean size is 10, and the cache is at 15, we would remove (15 - 10) * 1.5 = 7.5 round up to 8. This way we clean the cache a bit more, and avoid having the cache cleaner having to do it frequently.
Protected class FilterManager FilterItem
Holds the filter and the last time the filter was used, to make LRU-based cache cleaning possible. TODO: Clean this up when we switch to Java 1.5
Public class FuzzyQuery
Implements the fuzzy search query. The similarity measurement is based on the Levenshtein (edit distance) algorithm. Warning: this query is not very scalable with its default prefix length of 0 - in this case, *every* term will be enumerated and cause an edit score calculation.
Protected class | FuzzyQuery ScoreTerm
Public class FuzzyTermEnum
Subclass of FilteredTermEnum for enumerating all terms that are similiar to the specified filter term.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.
Public class | HitQueue
Public class IndexSearcher
Implements search over a single IndexReader.

Applications usually need only call the inherited Search(Query, Int32) or Search(Query, Filter, Int32) methods. For performance reasons it is recommended to open only one IndexSearcher and use it for all of your searches.

NOTE: IndexSearcher instances are completely thread safe, meaning multiple threads can call any of its methods, concurrently. If your application requires external synchronization, you should not synchronize on the IndexSearcher instance; use your own (non-Lucene) objects instead.

Public class MatchAllDocsQuery
A query that matches all documents.
Public class MultiPhraseQuery
MultiPhraseQuery is a generalized version of PhraseQuery, with an added method Add( Term ). To use this class, to search for the phrase "Microsoft app*" first use add(Term) on the term "Microsoft", then find all terms that have "app" as prefix using IndexReader.terms(Term), and use MultiPhraseQuery.add(Term[] terms) to add them to the query.
Public class MultiSearcher
Implements search over a set of Searchables.

Applications usually need only call the inherited Search(Query, Int32) or Search(Query, Filter, Int32) methods.
Public class MultiTermQuery
An abstract Query that matches documents containing a subset of terms provided by a FilteredTermEnum enumeration.

This query cannot be used directly; you must subclass it and define GetEnum(IndexReader) to provide a FilteredTermEnum that iterates through the terms to be matched.

NOTE: if RewriteMethod is either CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE or SCORING_BOOLEAN_QUERY_REWRITE , you may encounter a BooleanQuery TooManyClauses exception during searching, which happens when the number of terms to be searched exceeds MaxClauseCount . Setting RewriteMethod to CONSTANT_SCORE_FILTER_REWRITE prevents this.

The recommended rewrite method is CONSTANT_SCORE_AUTO_REWRITE_DEFAULT : it doesn't spend CPU computing unhelpful scores, and it tries to pick the most performant rewrite method given the query. Note that QueryParser produces MultiTermQueries using CONSTANT_SCORE_AUTO_REWRITE_DEFAULT by default.
Public class | MultiTermQuery AnonymousClassConstantScoreAutoRewrite
Public class MultiTermQuery ConstantScoreAutoRewrite
A rewrite method that tries to pick the best constant-score rewrite method based on term and document counts from the query. If both the number of terms and documents is small enough, then CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE is used. Otherwise, CONSTANT_SCORE_FILTER_REWRITE is used.
Public class MultiTermQueryWrapperFilter T
A wrapper for MultiTermQuery, that exposes its functionality as a Filter.

MultiTermQueryWrapperFilter is not designed to be used by itself. Normally you subclass it to provide a Filter counterpart for a MultiTermQuery subclass.

For example, TermRangeFilter and PrefixFilter extend MultiTermQueryWrapperFilter. This class also provides the functionality behind CONSTANT_SCORE_FILTER_REWRITE; this is why it is not abstract.
Public class | NumericRangeFilter
Public class NumericRangeFilter T
A Filter that only accepts numeric values within a specified range. To use this, you must first index the numeric values using NumericField (expert: NumericTokenStream ).

You create a new NumericRangeFilter with the static factory methods, eg:
View Colorized Copy to Clipboard Print
Filter f = NumericRangeFilter.newFloatRange("weight",
            new Float(0.3f), new Float(0.10f),
            true, true);
Filter f = NumericRangeFilter.newFloatRange("weight",
            new Float(0.3f), new Float(0.10f),
            true, true);
accepts all documents whose float valued "weight" field ranges from 0.3 to 0.10, inclusive. See NumericRangeQuery T for details on how Lucene indexes and searches numeric valued fields.

NOTE: This API is experimental and might change in incompatible ways in the next release.
Public class | NumericRangeQuery
Public class NumericRangeQuery T

A Query that matches numeric values within a specified range. To use this, you must first index the numeric values using NumericField (expert: NumericTokenStream ). If your terms are instead textual, you should use TermRangeQuery. NumericRangeFilter T is the filter equivalent of this query.

You create a new NumericRangeQuery with the static factory methods, eg:
View Colorized Copy to Clipboard Print
Query q = NumericRangeQuery.newFloatRange("weight",
new Float(0.3f), new Float(0.10f),
true, true);
Query q = NumericRangeQuery.newFloatRange("weight",
new Float(0.3f), new Float(0.10f),
true, true);
matches all documents whose float valued "weight" field ranges from 0.3 to 0.10, inclusive.

The performance of NumericRangeQuery is much better than the corresponding TermRangeQuery because the number of terms that must be searched is usually far fewer, thanks to trie indexing, described below.

You can optionally specify a precisionStep when creating this query. This is necessary if you've changed this configuration from its default (4) during indexing. Lower values consume more disk space but speed up searching. Suitable values are between 1 and 8. A good starting point to test is 4, which is the default value for all Numeric* classes. See below for details.

This query defaults to CONSTANT_SCORE_AUTO_REWRITE_DEFAULT for 32 bit (int/float) ranges with precisionStep <8 and 64 bit (long/double) ranges with precisionStep <6. Otherwise it uses CONSTANT_SCORE_FILTER_REWRITE as the number of terms is likely to be high. With precision steps of <4, this query can be run with one of the BooleanQuery rewrite methods without changing BooleanQuery's default max clause count.

NOTE: This API is experimental and might change in incompatible ways in the next release.

How it works

See the publication about Online panFMP, where this algorithm was described (referred to as TrieRangeQuery):
Schindler, U, Diepenbroek, M, 2008. Generic XML-based Framework for Metadata Portals. Computers & Geosciences 34 (12), 1947-1955. Online doi:10.1016/j.cageo.2008.02.023

A quote from this paper: Because Apache Lucene is a full-text search engine and not a conventional database, it cannot handle numerical ranges (e.g., field value is inside user defined bounds, even dates are numerical values). We have developed an extension to Apache Lucene that stores the numerical values in a special string-encoded format with variable precision (all numerical values like doubles, longs, floats, and ints are converted to lexicographic sortable string representations and stored with different precisions (for a more detailed description of how the values are stored, see NumericUtils). A range is then divided recursively into multiple intervals for searching: The center of the range is searched only with the lowest possible precision in the trie, while the boundaries are matched more exactly. This reduces the number of terms dramatically.

For the variant that stores long values in 8 different precisions (each reduced by 8 bits) that uses a lowest precision of 1 byte, the index contains only a maximum of 256 distinct values in the lowest precision. Overall, a range could consist of a theoretical maximum of 7*255*2 + 255 = 3825 distinct terms (when there is a term for every distinct value of an 8-byte-number in the index and the range covers almost all of them; a maximum of 255 distinct values is used because it would always be possible to reduce the full 256 values to one term with degraded precision). In practice, we have seen up to 300 terms in most cases (index with 500,000 metadata records and a uniform value distribution).

Precision Step

You can choose any precisionStep when encoding values. Lower step values mean more precisions and so more terms in index (and index gets larger). On the other hand, the maximum number of terms to match reduces, which optimized query speed. The formula to calculate the maximum term count is:
View Colorized Copy to Clipboard Print
n = [ (bitsPerValue/precisionStep - 1) * (2^precisionStep - 1 ) * 2 ] + (2^precisionStep - 1 )
n = [ (bitsPerValue/precisionStep - 1) * (2^precisionStep - 1 ) * 2 ] + (2^precisionStep - 1 )

(this formula is only correct, when bitsPerValue/precisionStep is an integer; in other cases, the value must be rounded up and the last summand must contain the modulo of the division as precision step). For longs stored using a precision step of 4, n = 15*15*2 + 15 = 465, and for a precision step of 2, n = 31*3*2 + 3 = 189. But the faster search speed is reduced by more seeking in the term enum of the index. Because of this, the ideal precisionStep value can only be found out by testing. Important: You can index with a lower precision step value and test search speed using a multiple of the original step value.

Good values for precisionStep are depending on usage and data type:
  • The default for all data types is 4, which is used, when no precisionStep is given.
  • Ideal value in most cases for 64 bit data types (long, double) is 6 or 8.
  • Ideal value in most cases for 32 bit data types (int, float) is 4.
  • Steps >64 for long/double and >32 for int/float produces one token per value in the index and querying is as slow as a conventional TermRangeQuery. But it can be used to produce fields, that are solely used for sorting (in this case simply use Online MaxValue as precisionStep). Using NumericFields for sorting is ideal, because building the field cache is much faster than with text-only numbers. Sorting is also possible with range query optimized fields using one of the above precisionSteps.

Comparisons of the different types of RangeQueries on an index with about 500,000 docs showed that TermRangeQuery in boolean rewrite mode (with raised BooleanQuery clause count) took about 30-40 secs to complete, TermRangeQuery in constant score filter rewrite mode took 5 secs and executing this class took <100ms to complete (on an Opteron64 machine, Java 1.5, 8 bit precision step). This query type was developed for a geographic portal, where the performance for e.g. bounding boxes or exact date/time stamps is important.

Public class | OccurExtensions
Public class ParallelMultiSearcher
Implements parallel search over a set of Searchables.

Applications usually need only call the inherited Search(Query, Int32) or Search(Query, Filter, Int32) methods.
Public class PhraseQuery
A Query that matches documents containing a particular sequence of terms. A PhraseQuery is built by QueryParser for input like "new york".

This query may be combined with other terms or queries with a BooleanQuery.
Public class PositiveScoresOnlyCollector
A Collector implementation which wraps another Collector and makes sure only documents with scores > 0 are collected.
Public class PrefixFilter
A Filter that restricts search results to values that have a matching prefix in a given field.
Public class PrefixQuery
A Query that matches documents containing terms with a specified prefix. A PrefixQuery is built by QueryParser for input like app*.

This query uses the CONSTANT_SCORE_AUTO_REWRITE_DEFAULT rewrite method.
Public class PrefixTermEnum
Subclass of FilteredTermEnum for enumerating all terms that match the specified prefix filter term.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.
Public class Query
The abstract base class for queries.

Instantiable subclasses are:
  • TermQuery
  • MultiTermQuery
  • BooleanQuery
  • WildcardQuery
  • PhraseQuery
  • PrefixQuery
  • MultiPhraseQuery
  • FuzzyQuery
  • TermRangeQuery
  • NumericRangeQuery T
  • SpanQuery

A parser for queries is contained in:
  • QueryParser
Public class QueryTermVector
Public class QueryWrapperFilter
Constrains search results to only match those which also match a provided query.

This could be used, for example, with a TermRangeQuery on a suitably formatted date field to implement date filtering. One could re-use a single QueryFilter that matches, e.g., only documents modified within the last week. The QueryFilter and TermRangeQuery would only need to be reconstructed once per day.
Public class RewriteMethod
Abstract class that defines how the query is rewritten.
Public class ScoreCachingWrappingScorer
A Scorer which wraps another scorer and caches the score of the current document. Successive calls to Score will return the same result and will not invoke the wrapped Scorer's score() method, unless the current document has changed.
This class might be useful due to the changes done to the Collector interface, in which the score is not computed for a document by default, only if the collector requests it. Some collectors may need to use the score in several places, however all they have in hand is a Scorer object, and might end up computing the score of a document more than once.
Public class ScoreDoc
Expert: Returned by low-level search implementations.
Public class Scorer
Expert: Common scoring functionality for different types of queries.

A Scorer iterates over documents matching a query in increasing order of doc Id.

Document scores are computed using a given Similarity implementation.

NOTE: The values Float.Nan, Float.NEGATIVE_INFINITY and Float.POSITIVE_INFINITY are not valid scores. Certain collectors (eg TopScoreDocCollector ) will not properly collect hits with these scores.
Public class Searcher
An abstract base class for search implementations. Implements the main search methods.

Note that you can only access hits from a Searcher as long as it is not yet closed, otherwise an IOException will be thrown.
Public class Similarity
Expert: Scoring API.

Subclasses implement search scoring.

The score of query q for document d correlates to the cosine-distance or dot-product between document and query vectors in a Online Vector Space Model (VSM) of Information Retrieval. A document whose vector is closer to the query vector in that model is scored higher. The score is computed as follows:

score(q,d) = coord(q,d) · queryNorm(q) · | ∑ | (tf(t in d) · idf(t)2 · t.Boost · norm(t,d))
 | t in q |

where
  • tf(t in d) correlates to the term's frequency, defined as the number of times term t appears in the currently scored document d. Documents that have more occurrences of a given term receive a higher score. The default computation for tf(t in d) in DefaultSimilarity is:

    tf(t in d) = frequency½

  • idf(t) stands for Inverse Document Frequency. This value correlates to the inverse of docFreq (the number of documents in which the term t appears). This means rarer terms give higher contribution to the total score. The default computation for idf(t) in DefaultSimilarity is:

    idf(t) = 1 + log (
    numDocs
    –––––––––
    docFreq+1
            )

  • coord(q,d) is a score factor based on how many of the query terms are found in the specified document. Typically, a document that contains more of the query's terms will receive a higher score than another document with fewer query terms. This is a search time factor computed in coord(q,d) by the Similarity in effect at search time.

  • queryNorm(q) is a normalizing factor used to make scores between queries comparable. This factor does not affect document ranking (since all ranked documents are multiplied by the same factor), but rather just attempts to make scores from different queries (or even different indexes) comparable. This is a search time factor computed by the Similarity in effect at search time. The default computation in DefaultSimilarity is:

    queryNorm(q) = queryNorm(sumOfSquaredWeights) =
    1
    ––––––––––––––
    sumOfSquaredWeights½

    The sum of squared weights (of the query terms) is computed by the query Weight object. For example, a boolean query computes this value as:

    GetSumOfSquaredWeights = q.Boost 2 · ∑ (idf(t) · t.Boost) 2
    t in q

  • t.Boost is a search time boost of term t in the query q as specified in the query text (see query syntax), or as set by application calls to Boost. Notice that there is really no direct API for accessing a boost of one term in a multi term query, but rather multi terms are represented in a query as multi TermQuery objects, and so the boost of a term in the query is accessible by calling the sub-query Boost.

  • norm(t,d) encapsulates a few (indexing time) boost and length factors:
    • Document boost - set by calling doc.Boost before adding the document to the index.
    • Field boost - set by calling field.Boost before adding the field to a document.
    • LengthNorm(field) - computed when the document is added to the index in accordance with the number of tokens of this field in the document, so that shorter fields contribute more to the score. LengthNorm is computed by the Similarity class in effect at indexing.

    When a document is added to the index, all the above factors are multiplied. If the document has multiple fields with the same name, all their boosts are multiplied together:

    norm(t,d) = doc.Boost · LengthNorm(field) · ∏ field.Boost
    field f in d named as t

    However the resulted norm value is encoded as a single byte before being stored. At search time, the norm byte value is read from the index directory and decoded back to a float norm value. This encoding/decoding, while reducing index size, comes with the price of precision loss - it is not guaranteed that decode(encode(x)) = x. For instance, decode(encode(0.89)) = 0.75. Also notice that search time is too late to modify this norm part of scoring, e.g. by using a different Similarity for search.

Public class SimilarityDelegator
Expert: Delegating scoring implementation. Useful in GetSimilarity(Searcher) implementations, to override only certain methods of a Searcher's Similiarty implementation..
Public class SingleTermEnum
Subclass of FilteredTermEnum for enumerating a single term.

This can be used by MultiTermQuerys that need only visit one term, but want to preserve MultiTermQuery semantics such as RewriteMethod.
Public class Sort
Encapsulates sort criteria for returned hits.

The fields used to determine sort order must be carefully chosen. Documents must contain a single term in such a field, and the value of the term should indicate the document's relative position in a given sort order. The field must be indexed, but should not be tokenized, and does not need to be stored (unless you happen to want it back with the rest of your document data). In other words:

document.add (new Field ("byNumber", Integer.toString(x), Field.Store.NO, Field.Index.NOT_ANALYZED));

Valid Types of Values

There are four possible kinds of term values which may be put into sorting fields: Integers, Longs, Floats, or Strings. Unless SortField objects are specified, the type of value in the field is determined by parsing the first term in the field.

Integer term values should contain only digits and an optional preceding negative sign. Values must be base 10 and in the range Integer.MIN_VALUE and Integer.MAX_VALUE inclusive. Documents which should appear first in the sort should have low value integers, later documents high values (i.e. the documents should be numbered 1..n where 1 is the first and n the last).

Long term values should contain only digits and an optional preceding negative sign. Values must be base 10 and in the range Long.MIN_VALUE and Long.MAX_VALUE inclusive. Documents which should appear first in the sort should have low value integers, later documents high values.

Float term values should conform to values accepted by Online Parse(String) (except that NaN and Infinity are not supported). Documents which should appear first in the sort should have low values, later documents high values.

String term values can contain any valid String, but should not be tokenized. The values are sorted according to their Online natural order. Note that using this type of term value has higher memory requirements than the other two types.

Object Reuse

One of these objects can be used multiple times and the sort order changed between usages.

This class is thread safe.

Memory Usage

Sorting uses of caches of term values maintained by the internal HitQueue(s). The cache is static and contains an integer or float array of length IndexReader.MaxDoc for each field name for which a sort is performed. In other words, the size of the cache in bytes is:

4 * IndexReader.MaxDoc * (# of different fields actually used to sort)

For String fields, the cache is larger: in addition to the above array, the value of every term in the field is kept in memory. If there are many unique terms in the field, this could be quite large.

Note that the size of the cache is not affected by how many fields are in the index and might be used to sort - only by the ones actually used to sort a result set.

Created: Feb 12, 2004 10:53:57 AM
Public class SortField
Stores information about how to sort documents by terms in an individual field. Fields must be indexed in order to sort by them.

Created: Feb 11, 2004 1:25:29 PM
Public class SpanFilter
Abstract base class providing a mechanism to restrict searches to a subset of an index and also maintains and returns position information. This is useful if you want to compare the positions from a SpanQuery with the positions of items in a filter. For instance, if you had a SpanFilter that marked all the occurrences of the word "foo" in documents, and then you entered a new SpanQuery containing bar, you could not only filter by the word foo, but you could then compare position information for post processing.
Public class SpanFilterResult
The results of a SpanQueryFilter. Wraps the BitSet and the position information from the SpanQuery

NOTE: This API is still experimental and subject to change.
Public class | SpanFilterResult PositionInfo
Public class | SpanFilterResult StartEnd
Public class SpanQueryFilter
Constrains search results to only match those which also match a provided query. Also provides position information about where each document matches at the cost of extra space compared with the QueryWrapperFilter. There is an added cost to this above what is stored in a QueryWrapperFilter. Namely, the position information for each matching document is stored.

This filter does not cache. See the CachingSpanFilter for a wrapper that caches.
Public class StringIndex
Expert: Stores term text values and document ordering data.
Public class TermQuery
A Query that matches documents containing a term. This may be combined with other terms with a BooleanQuery.
Public class TermRangeFilter
A Filter that restricts search results to a range of values in a given field.

This filter matches the documents looking for terms that fall into the supplied range according to Online CompareTo(String). It is not intended for numerical ranges, use NumericRangeFilter T instead.

If you construct a large number of range filters with different ranges but on the same field, FieldCacheRangeFilter may have significantly better performance.
Public class TermRangeQuery
A Query that matches documents within an exclusive range of terms.

This query matches the documents looking for terms that fall into the supplied range according to Online CompareTo(String). It is not intended for numerical ranges, use NumericRangeQuery T instead.

This query uses the CONSTANT_SCORE_AUTO_REWRITE_DEFAULT rewrite method.
Public class TermRangeTermEnum
Subclass of FilteredTermEnum for enumerating all terms that match the specified range parameters.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.
Public class TermScorer
Expert: A Scorer for documents matching a Term.
Public class TimeLimitingCollector
The TimeLimitingCollector is used to timeout search requests that take longer than the maximum allowed search time limit. After this time is exceeded, the search thread is stopped by throwing a TimeLimitingCollector TimeExceededException.
Public class TimeLimitingCollector TimeExceededException
Thrown when elapsed search time exceeds allowed search time.
Public class TopDocs
Represents hits returned by Search(Query, Filter, Int32) and Search(Query, Int32)
Public class TopDocsCollector T
A base class for all collectors that return a TopDocs output. This collector allows easy extension by providing a single constructor which accepts a PriorityQueue T as well as protected members for that priority queue and a counter of the number of total hits.
Extending classes can override TopDocs(Int32, Int32) and TotalHits in order to provide their own implementation.
Public class TopFieldCollector
A Collector that sorts by SortField using FieldComparators.

See the Create(Sort, Int32, Boolean, Boolean, Boolean, Boolean) method for instantiating a TopFieldCollector.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Public class TopFieldDocs
Represents hits returned by Search(Query, Filter, Int32, Sort).
Public class TopScoreDocCollector
A Collector implementation that collects the top-scoring hits, returning them as a TopDocs. This is used by IndexSearcher to implement TopDocs-based search. Hits are sorted by score descending and then (when the scores are tied) docID ascending. When you create an instance of this collector you should know in advance whether documents are going to be collected in doc Id order or not.

NOTE: The values Online NaN and Online NegativeInfinity are not valid scores. This collector will not properly collect hits with such scores.
Public class Weight
Expert: Calculate query weights and build query scorers.

The purpose of Weight is to ensure searching does not modify a Query, so that a Query instance can be reused.
Searcher dependent state of the query should reside in the Weight.
IndexReader dependent state should reside in the Scorer(IndexReader, Boolean, Boolean).

A Weight is used in the following way:
  • A Weight is constructed by a top-level query, given a Searcher (CreateWeight(Searcher)).
  • The GetSumOfSquaredWeights method is called on the Weight to compute the query normalization factor QueryNorm(Single) of the query clauses contained in the query.
  • The query normalization factor is passed to Normalize(Single). At this point the weighting is complete.
  • A Scorer is constructed by Scorer(IndexReader, Boolean, Boolean).
Public class WildcardQuery
Implements the wildcard search query. Supported wildcards are *, which matches any character sequence (including the empty one), and ?, which matches any single character. Note this query can be slow, as it needs to iterate over many terms. In order to prevent extremely slow WildcardQueries, a Wildcard term should not start with one of the wildcards * or ?.

This query uses the CONSTANT_SCORE_AUTO_REWRITE_DEFAULT rewrite method.
Public class WildcardTermEnum
Subclass of FilteredTermEnum for enumerating all terms that match the specified wildcard filter term.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.
Structures
 | Structure | Description
Public structure | FieldCache_Fields |
Interfaces
 | Interface | Description
Public interface | ByteParser | Interface to parse bytes from document fields.
Public interface | DoubleParser | Interface to parse doubles from document fields.
Public interface | FieldCache |
Public interface | FloatParser | Interface to parse floats from document fields.
Public interface | IntParser | Interface to parse ints from document fields.
Public interface | LongParser | Interface to parse long from document fields.
Public interface | Parser | Marker interface as super-interface to all parsers. It is used to specify a custom parser to SortField(String, Parser).
Public interface | Searchable | The interface for search implementations. Searchable is the abstract network protocol for searching. Implementations provide search over a single index, over multiple indices, and over indices on remote servers. Queries, filters and sort criteria are designed to be compact so that they may be efficiently passed to a remote index, with only the top-scoring hits being returned, rather than every matching hit. NOTE: this interface is kept public for convenience. Since it is not expected to be implemented directly, it may be changed unexpectedly between releases.
Public interface | ShortParser | Interface to parse shorts from document fields.
Enumerations
 | Enumeration | Description
Public enumeration | CachingWrapperFilter DeletesMode |
Public enumeration | Occur |

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanClause Class

BooleanClause Class Lucene.Net Class Library
A clause in a BooleanQuery.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search BooleanClause

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class BooleanClause
[SerializableAttribute]
public class BooleanClause
<SerializableAttribute> _
Public Class BooleanClause
<SerializableAttribute> _
Public Class BooleanClause
[SerializableAttribute]
public ref class BooleanClause
[SerializableAttribute]
public ref class BooleanClause
See Also
BooleanClause Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanClause Members

BooleanClause Members Lucene.Net Class Library

The BooleanClause type exposes the following members.
Constructors
 | Name | Description
Public method | BooleanClause | Constructs a BooleanClause.
Back to Top
Methods
 | Name | Description
Public method | Equals | Returns true if o is equal to this. (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | IsProhibited |
Public property | IsRequired |
Public property | Occur |
Public property | Query | The query whose matching documents are combined by the boolean query.
Back to Top
See Also
BooleanClause Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanClause Constructor

BooleanClause Constructor Lucene.Net Class Library
Constructs a BooleanClause.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BooleanClause(
    Query query,
    Occur occur
)
public BooleanClause(
    Query query,
    Occur occur
)
Public Sub New ( _
    query As Query, _
    occur As Occur _
)
Public Sub New ( _
    query As Query, _
    occur As Occur _
)
public:
BooleanClause(
    Query^ query,
    Occur occur
)
public:
BooleanClause(
    Query^ query,
    Occur occur
)
Parameters
query
Type: Lucene.Net.Search Query
occur
Type: Lucene.Net.Search Occur
See Also
BooleanClause Class
BooleanClause Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanClause Methods

BooleanClause Methods Lucene.Net Class Library
The BooleanClause type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Returns true if o is equal to this. (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
BooleanClause Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

BooleanClause Equals Method Lucene.Net Class Library
Returns true if o is equal to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
BooleanClause Class
BooleanClause Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

BooleanClause GetHashCode Method Lucene.Net Class Library
Returns a hash code value for this object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
BooleanClause Class
BooleanClause Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

BooleanClause ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
BooleanClause Class
BooleanClause Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanClause Properties

BooleanClause Properties Lucene.Net Class Library
The BooleanClause type exposes the following members.
Properties
 | Name | Description
Public property | IsProhibited |
Public property | IsRequired |
Public property | Occur |
Public property | Query | The query whose matching documents are combined by the boolean query.
Back to Top
See Also
BooleanClause Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsProhibited Property

BooleanClause IsProhibited Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsProhibited { get; }
public virtual bool IsProhibited { get; }
Public Overridable ReadOnly Property IsProhibited As Boolean
    Get
Public Overridable ReadOnly Property IsProhibited As Boolean
    Get
public:
virtual property bool IsProhibited {
    bool get ();
}
public:
virtual property bool IsProhibited {
    bool get ();
}
See Also
BooleanClause Class
BooleanClause Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsRequired Property

BooleanClause IsRequired Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsRequired { get; }
public virtual bool IsRequired { get; }
Public Overridable ReadOnly Property IsRequired As Boolean
    Get
Public Overridable ReadOnly Property IsRequired As Boolean
    Get
public:
virtual property bool IsRequired {
    bool get ();
}
public:
virtual property bool IsRequired {
    bool get ();
}
See Also
BooleanClause Class
BooleanClause Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Occur Property

BooleanClause Occur Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Occur Occur { get; set; }
public virtual Occur Occur { get; set; }
Public Overridable Property Occur As Occur
    Get
    Set
Public Overridable Property Occur As Occur
    Get
    Set
public:
virtual property Occur Occur {
    Occur get ();
    void set (Occur value);
}
public:
virtual property Occur Occur {
    Occur get ();
    void set (Occur value);
}
See Also
BooleanClause Class
BooleanClause Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Query Property

BooleanClause Query Property Lucene.Net Class Library
The query whose matching documents are combined by the boolean query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Query Query { get; set; }
public virtual Query Query { get; set; }
Public Overridable Property Query As Query
    Get
    Set
Public Overridable Property Query As Query
    Get
    Set
public:
virtual property Query^ Query {
    Query^ get ();
    void set (Query^ value);
}
public:
virtual property Query^ Query {
    Query^ get ();
    void set (Query^ value);
}
See Also
BooleanClause Class
BooleanClause Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery Class

BooleanQuery Class Lucene.Net Class Library
A Query that matches documents matching boolean combinations of other queries, e.g. TermQuerys, PhraseQuerys or other BooleanQuerys.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search BooleanQuery

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class BooleanQuery : Query,
    IEnumerable<BooleanClause>, IEnumerable, ICloneable
[SerializableAttribute]
public class BooleanQuery : Query,
    IEnumerable<BooleanClause>, IEnumerable, ICloneable
<SerializableAttribute> _
Public Class BooleanQuery _
    Inherits Query _
    Implements IEnumerable(Of BooleanClause), IEnumerable,  _
    ICloneable
<SerializableAttribute> _
Public Class BooleanQuery _
    Inherits Query _
    Implements IEnumerable(Of BooleanClause), IEnumerable,  _
    ICloneable
[SerializableAttribute]
public ref class BooleanQuery : public Query,
    IEnumerable<BooleanClause^>, IEnumerable, ICloneable
[SerializableAttribute]
public ref class BooleanQuery : public Query,
    IEnumerable<BooleanClause^>, IEnumerable, ICloneable
See Also
BooleanQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery Members

BooleanQuery Members Lucene.Net Class Library

The BooleanQuery type exposes the following members.
Constructors
 | Name | Description
Public method | BooleanQuery | Constructs an empty boolean query.
Public method | BooleanQuery(Boolean) | Constructs an empty boolean query. Coord(Int32, Int32) may be disabled in scoring, as appropriate. For example, this score factor does not make sense for most automatically generated queries, like WildcardQuery and FuzzyQuery .
Back to Top
Methods
 | Name | Description
Public method | Add(BooleanClause) | Adds a clause to a boolean query.
Public method | Add(Query, Occur) | Adds a clause to a boolean query.
Public method | Clone | (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | Returns true iff o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClauses | Returns the set of clauses in this query.
Public method | GetEnumerator | Returns an iterator on the clauses in this query.
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Query GetHashCode .)
Public method | GetSimilarity | (Overrides Query GetSimilarity(Searcher).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsCoordDisabled | Returns true iff Coord(Int32, Int32) is disabled in scoring for this query instance.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Fields
 | Name | Description
Protected field | minNrShouldMatch |
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Clauses | Returns the list of clauses in this query.
 | MaxClauseCount | Gets or sets the maximum number of clauses permitted, 1024 by default. Attempts to add more than the permitted number of clauses cause BooleanQuery TooManyClauses to be thrown.
Public property | MinimumNumberShouldMatch | Specifies a minimum number of the optional BooleanClauses which must be satisfied. By default no optional clauses are necessary for a match (unless there are no required clauses). If this method is used, then the specified number of clauses is required. Use of this method is totally independent of specifying that any specific clauses are required (or prohibited). This number will only be compared against the number of matching optional clauses.
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | Returns an enumerator that iterates through a collection.
Back to Top
See Also
BooleanQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery Constructor

BooleanQuery Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | BooleanQuery | Constructs an empty boolean query.
Public method | BooleanQuery(Boolean) | Constructs an empty boolean query. Coord(Int32, Int32) may be disabled in scoring, as appropriate. For example, this score factor does not make sense for most automatically generated queries, like WildcardQuery and FuzzyQuery .
Back to Top
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery Constructor

BooleanQuery Constructor Lucene.Net Class Library
Constructs an empty boolean query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BooleanQuery()
public BooleanQuery()
Public Sub New
Public Sub New
public:
BooleanQuery()
public:
BooleanQuery()
See Also
BooleanQuery Class
BooleanQuery Members
BooleanQuery Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery Constructor (Boolean)

BooleanQuery Constructor (Boolean) Lucene.Net Class Library
Constructs an empty boolean query. Coord(Int32, Int32) may be disabled in scoring, as appropriate. For example, this score factor does not make sense for most automatically generated queries, like WildcardQuery and FuzzyQuery .

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BooleanQuery(
    bool disableCoord
)
public BooleanQuery(
    bool disableCoord
)
Public Sub New ( _
    disableCoord As Boolean _
)
Public Sub New ( _
    disableCoord As Boolean _
)
public:
BooleanQuery(
    bool disableCoord
)
public:
BooleanQuery(
    bool disableCoord
)
Parameters
disableCoord
Type:   Online System Boolean
disables Coord(Int32, Int32) in scoring.

See Also
BooleanQuery Class
BooleanQuery Members
BooleanQuery Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery Fields

BooleanQuery Fields Lucene.Net Class Library
The BooleanQuery type exposes the following members.
Fields
 | Name | Description
Protected field | minNrShouldMatch |
Back to Top
See Also
BooleanQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


minNrShouldMatch Field

BooleanQuery minNrShouldMatch Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int minNrShouldMatch
protected int minNrShouldMatch
Protected minNrShouldMatch As Integer
Protected minNrShouldMatch As Integer
protected:
int minNrShouldMatch
protected:
int minNrShouldMatch
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery Methods

BooleanQuery Methods Lucene.Net Class Library
The BooleanQuery type exposes the following members.
Methods
 | Name | Description
Public method | Add(BooleanClause) | Adds a clause to a boolean query.
Public method | Add(Query, Occur) | Adds a clause to a boolean query.
Public method | Clone | (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | Returns true iff o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClauses | Returns the set of clauses in this query.
Public method | GetEnumerator | Returns an iterator on the clauses in this query.
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Query GetHashCode .)
Public method | GetSimilarity | (Overrides Query GetSimilarity(Searcher).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsCoordDisabled | Returns true iff Coord(Int32, Int32) is disabled in scoring for this query instance.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | Returns an enumerator that iterates through a collection.
Back to Top
See Also
BooleanQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IEnumerable.GetEnumerator Method

BooleanQuery IEnumerable GetEnumerator Method Lucene.Net Class Library
Returns an enumerator that iterates through a collection.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
Return Value
An   Online IEnumerator object that can be used to iterate through the collection.
Implements
  Online IEnumerable GetEnumerator
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method

BooleanQuery Add Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Add(BooleanClause) | Adds a clause to a boolean query.
Public method | Add(Query, Occur) | Adds a clause to a boolean query.
Back to Top
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (BooleanClause)

BooleanQuery Add Method (BooleanClause) Lucene.Net Class Library
Adds a clause to a boolean query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Add(
    BooleanClause clause
)
public virtual void Add(
    BooleanClause clause
)
Public Overridable Sub Add ( _
    clause As BooleanClause _
)
Public Overridable Sub Add ( _
    clause As BooleanClause _
)
public:
virtual void Add(
    BooleanClause^ clause
)
public:
virtual void Add(
    BooleanClause^ clause
)
Parameters
clause
Type: Lucene.Net.Search BooleanClause
See Also
BooleanQuery Class
BooleanQuery Members
Add Overload
Lucene.Net.Search Namespace
BooleanQuery MaxClauseCount
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (Query, Occur)

BooleanQuery Add Method (Query, Occur) Lucene.Net Class Library
Adds a clause to a boolean query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Add(
    Query query,
    Occur occur
)
public virtual void Add(
    Query query,
    Occur occur
)
Public Overridable Sub Add ( _
    query As Query, _
    occur As Occur _
)
Public Overridable Sub Add ( _
    query As Query, _
    occur As Occur _
)
public:
virtual void Add(
    Query^ query,
    Occur occur
)
public:
virtual void Add(
    Query^ query,
    Occur occur
)
Parameters
query
Type: Lucene.Net.Search Query
occur
Type: Lucene.Net.Search Occur
See Also
BooleanQuery Class
BooleanQuery Members
Add Overload
Lucene.Net.Search Namespace
BooleanQuery MaxClauseCount
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

BooleanQuery Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateWeight Method

BooleanQuery CreateWeight Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Weight CreateWeight(
    Searcher searcher
)
public override Weight CreateWeight(
    Searcher searcher
)
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

BooleanQuery Equals Method Lucene.Net Class Library
Returns true iff o is equal to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExtractTerms Method

BooleanQuery ExtractTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ExtractTerms(
    ISet<Term> terms
)
public override void ExtractTerms(
    ISet<Term> terms
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
Parameters
terms
Type:   Online System.Collections.Generic ISet  Term
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetClauses Method

BooleanQuery GetClauses Method Lucene.Net Class Library
Returns the set of clauses in this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual BooleanClause[] GetClauses()
public virtual BooleanClause[] GetClauses()
Public Overridable Function GetClauses As BooleanClause()
Public Overridable Function GetClauses As BooleanClause()
public:
virtual array<BooleanClause^>^ GetClauses()
public:
virtual array<BooleanClause^>^ GetClauses()
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetEnumerator Method

BooleanQuery GetEnumerator Method Lucene.Net Class Library
Returns an iterator on the clauses in this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<BooleanClause> GetEnumerator()
public IEnumerator<BooleanClause> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of BooleanClause)
Public Function GetEnumerator As IEnumerator(Of BooleanClause)
public:
virtual IEnumerator<BooleanClause^>^ GetEnumerator() sealed
public:
virtual IEnumerator<BooleanClause^>^ GetEnumerator() sealed
Return Value
Implements
  Online IEnumerable T  GetEnumerator
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

BooleanQuery GetHashCode Method Lucene.Net Class Library
Returns a hash code value for this object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSimilarity Method

BooleanQuery GetSimilarity Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Similarity GetSimilarity(
    Searcher searcher
)
public override Similarity GetSimilarity(
    Searcher searcher
)
Public Overrides Function GetSimilarity ( _
    searcher As Searcher _
) As Similarity
Public Overrides Function GetSimilarity ( _
    searcher As Searcher _
) As Similarity
public:
virtual Similarity^ GetSimilarity(
    Searcher^ searcher
) override
public:
virtual Similarity^ GetSimilarity(
    Searcher^ searcher
) override
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsCoordDisabled Method

BooleanQuery IsCoordDisabled Method Lucene.Net Class Library
Returns true iff Coord(Int32, Int32) is disabled in scoring for this query instance.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsCoordDisabled()
public virtual bool IsCoordDisabled()
Public Overridable Function IsCoordDisabled As Boolean
Public Overridable Function IsCoordDisabled As Boolean
public:
virtual bool IsCoordDisabled()
public:
virtual bool IsCoordDisabled()
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace
BooleanQuery BooleanQuery(Boolean)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

BooleanQuery Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    IndexReader reader
)
public override Query Rewrite(
    IndexReader reader
)
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

BooleanQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Back to Top
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

BooleanQuery ToString Method (String) Lucene.Net Class Library
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
BooleanQuery Class
BooleanQuery Members
ToString Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery Properties

BooleanQuery Properties Lucene.Net Class Library
The BooleanQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Clauses | Returns the list of clauses in this query.
 | MaxClauseCount | Gets or sets the maximum number of clauses permitted, 1024 by default. Attempts to add more than the permitted number of clauses cause BooleanQuery TooManyClauses to be thrown.
Public property | MinimumNumberShouldMatch | Specifies a minimum number of the optional BooleanClauses which must be satisfied. By default no optional clauses are necessary for a match (unless there are no required clauses). If this method is used, then the specified number of clauses is required. Use of this method is totally independent of specifying that any specific clauses are required (or prohibited). This number will only be compared against the number of matching optional clauses.
Back to Top
See Also
BooleanQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clauses Property

BooleanQuery Clauses Property Lucene.Net Class Library
Returns the list of clauses in this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual List<BooleanClause> Clauses { get; }
public virtual List<BooleanClause> Clauses { get; }
Public Overridable ReadOnly Property Clauses As List(Of BooleanClause)
    Get
Public Overridable ReadOnly Property Clauses As List(Of BooleanClause)
    Get
public:
virtual property List<BooleanClause^>^ Clauses {
    List<BooleanClause^>^ get ();
}
public:
virtual property List<BooleanClause^>^ Clauses {
    List<BooleanClause^>^ get ();
}
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxClauseCount Property

BooleanQuery MaxClauseCount Property Lucene.Net Class Library
Gets or sets the maximum number of clauses permitted, 1024 by default. Attempts to add more than the permitted number of clauses cause BooleanQuery TooManyClauses to be thrown.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int MaxClauseCount { get; set; }
public static int MaxClauseCount { get; set; }
Public Shared Property MaxClauseCount As Integer
    Get
    Set
Public Shared Property MaxClauseCount As Integer
    Get
    Set
public:
static property int MaxClauseCount {
    int get ();
    void set (int value);
}
public:
static property int MaxClauseCount {
    int get ();
    void set (int value);
}
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MinimumNumberShouldMatch Property

BooleanQuery MinimumNumberShouldMatch Property Lucene.Net Class Library
Specifies a minimum number of the optional BooleanClauses which must be satisfied.

By default no optional clauses are necessary for a match (unless there are no required clauses). If this method is used, then the specified number of clauses is required.

Use of this method is totally independent of specifying that any specific clauses are required (or prohibited). This number will only be compared against the number of matching optional clauses.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int MinimumNumberShouldMatch { get; set; }
public virtual int MinimumNumberShouldMatch { get; set; }
Public Overridable Property MinimumNumberShouldMatch As Integer
    Get
    Set
Public Overridable Property MinimumNumberShouldMatch As Integer
    Get
    Set
public:
virtual property int MinimumNumberShouldMatch {
    int get ();
    void set (int value);
}
public:
virtual property int MinimumNumberShouldMatch {
    int get ();
    void set (int value);
}
See Also
BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery.BooleanWeight Class

BooleanQuery BooleanWeight Class Lucene.Net Class Library
Expert: the Weight for BooleanQuery, used to normalize, score and explain these queries.

NOTE: this API and implementation is subject to change suddenly in the next release.

Inheritance Hierarchy
Online System Object
Lucene.Net.Search Weight
Lucene.Net.Search BooleanQuery BooleanWeight

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
protected internal class BooleanWeight : Weight
[SerializableAttribute]
protected internal class BooleanWeight : Weight
<SerializableAttribute> _
Protected Friend Class BooleanWeight _
    Inherits Weight
<SerializableAttribute> _
Protected Friend Class BooleanWeight _
    Inherits Weight
[SerializableAttribute]
protected public ref class BooleanWeight : public Weight
[SerializableAttribute]
protected public ref class BooleanWeight : public Weight
See Also
BooleanQuery BooleanWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery.BooleanWeight Members

BooleanQuery BooleanWeight Members Lucene.Net Class Library

A Query that matches documents matching boolean combinations of other queries, e.g. TermQuerys, PhraseQuerys or other BooleanQuerys.

The BooleanQuery BooleanWeight type exposes the following members.
Constructors
 | Name | Description
Public method | BooleanQuery BooleanWeight | Initializes a new instance of the BooleanQuery BooleanWeight class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | (Overrides Weight Explain(IndexReader, Int32).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetScoresDocsOutOfOrder | (Overrides Weight GetScoresDocsOutOfOrder .)
Public method | GetSumOfSquaredWeights | (Overrides Weight GetSumOfSquaredWeights .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Normalize | (Overrides Weight Normalize(Single).)
Public method | Scorer | (Overrides Weight Scorer(IndexReader, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | similarity | The Similarity implementation.
Protected field | weights |
Back to Top
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Query | (Overrides Weight Query.)
Public property | Value | (Overrides Weight Value.)
Back to Top
See Also
BooleanQuery BooleanWeight Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery.BooleanWeight Constructor

BooleanQuery BooleanWeight Constructor Lucene.Net Class Library
Initializes a new instance of the BooleanQuery BooleanWeight class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BooleanWeight(
    BooleanQuery enclosingInstance,
    Searcher searcher
)
public BooleanWeight(
    BooleanQuery enclosingInstance,
    Searcher searcher
)
Public Sub New ( _
    enclosingInstance As BooleanQuery, _
    searcher As Searcher _
)
Public Sub New ( _
    enclosingInstance As BooleanQuery, _
    searcher As Searcher _
)
public:
BooleanWeight(
    BooleanQuery^ enclosingInstance,
    Searcher^ searcher
)
public:
BooleanWeight(
    BooleanQuery^ enclosingInstance,
    Searcher^ searcher
)
Parameters
enclosingInstance
Type: Lucene.Net.Search BooleanQuery
searcher
Type: Lucene.Net.Search Searcher
See Also
BooleanQuery BooleanWeight Class
BooleanQuery BooleanWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery.BooleanWeight Fields

BooleanQuery BooleanWeight Fields Lucene.Net Class Library
The BooleanQuery BooleanWeight type exposes the following members.
Fields
 | Name | Description
Protected field | similarity | The Similarity implementation.
Protected field | weights |
Back to Top
See Also
BooleanQuery BooleanWeight Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


similarity Field

BooleanQuery BooleanWeight similarity Field Lucene.Net Class Library
The Similarity implementation.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Similarity similarity
protected Similarity similarity
Protected similarity As Similarity
Protected similarity As Similarity
protected:
Similarity^ similarity
protected:
Similarity^ similarity
See Also
BooleanQuery BooleanWeight Class
BooleanQuery BooleanWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


weights Field

BooleanQuery BooleanWeight weights Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected List<Weight> weights
protected List<Weight> weights
Protected weights As List(Of Weight)
Protected weights As List(Of Weight)
protected:
List<Weight^>^ weights
protected:
List<Weight^>^ weights
See Also
BooleanQuery BooleanWeight Class
BooleanQuery BooleanWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery.BooleanWeight Methods

BooleanQuery BooleanWeight Methods Lucene.Net Class Library
The BooleanQuery BooleanWeight type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | (Overrides Weight Explain(IndexReader, Int32).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetScoresDocsOutOfOrder | (Overrides Weight GetScoresDocsOutOfOrder .)
Public method | GetSumOfSquaredWeights | (Overrides Weight GetSumOfSquaredWeights .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Normalize | (Overrides Weight Normalize(Single).)
Public method | Scorer | (Overrides Weight Scorer(IndexReader, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
BooleanQuery BooleanWeight Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method

BooleanQuery BooleanWeight Explain Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Explanation Explain(
    IndexReader reader,
    int doc
)
public override Explanation Explain(
    IndexReader reader,
    int doc
)
Public Overrides Function Explain ( _
    reader As IndexReader, _
    doc As Integer _
) As Explanation
Public Overrides Function Explain ( _
    reader As IndexReader, _
    doc As Integer _
) As Explanation
public:
virtual Explanation^ Explain(
    IndexReader^ reader,
    int doc
) override
public:
virtual Explanation^ Explain(
    IndexReader^ reader,
    int doc
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
doc
Type:   Online System Int32
See Also
BooleanQuery BooleanWeight Class
BooleanQuery BooleanWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetScoresDocsOutOfOrder Method

BooleanQuery BooleanWeight GetScoresDocsOutOfOrder Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool GetScoresDocsOutOfOrder()
public override bool GetScoresDocsOutOfOrder()
Public Overrides Function GetScoresDocsOutOfOrder As Boolean
Public Overrides Function GetScoresDocsOutOfOrder As Boolean
public:
virtual bool GetScoresDocsOutOfOrder() override
public:
virtual bool GetScoresDocsOutOfOrder() override
See Also
BooleanQuery BooleanWeight Class
BooleanQuery BooleanWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSumOfSquaredWeights Method

BooleanQuery BooleanWeight GetSumOfSquaredWeights Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float GetSumOfSquaredWeights()
public override float GetSumOfSquaredWeights()
Public Overrides Function GetSumOfSquaredWeights As Single
Public Overrides Function GetSumOfSquaredWeights As Single
public:
virtual float GetSumOfSquaredWeights() override
public:
virtual float GetSumOfSquaredWeights() override
See Also
BooleanQuery BooleanWeight Class
BooleanQuery BooleanWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Normalize Method

BooleanQuery BooleanWeight Normalize Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Normalize(
    float norm
)
public override void Normalize(
    float norm
)
Public Overrides Sub Normalize ( _
    norm As Single _
)
Public Overrides Sub Normalize ( _
    norm As Single _
)
public:
virtual void Normalize(
    float norm
) override
public:
virtual void Normalize(
    float norm
) override
Parameters
norm
Type:   Online System Single
See Also
BooleanQuery BooleanWeight Class
BooleanQuery BooleanWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Scorer Method

BooleanQuery BooleanWeight Scorer Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
scoreDocsInOrder
Type:   Online System Boolean
topScorer
Type:   Online System Boolean
See Also
BooleanQuery BooleanWeight Class
BooleanQuery BooleanWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery.BooleanWeight Properties

BooleanQuery BooleanWeight Properties Lucene.Net Class Library
The BooleanQuery BooleanWeight type exposes the following members.
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Query | (Overrides Weight Query.)
Public property | Value | (Overrides Weight Value.)
Back to Top
See Also
BooleanQuery BooleanWeight Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Enclosing_Instance Property

BooleanQuery BooleanWeight Enclosing_Instance Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BooleanQuery Enclosing_Instance { get; }
public BooleanQuery Enclosing_Instance { get; }
Public ReadOnly Property Enclosing_Instance As BooleanQuery
    Get
Public ReadOnly Property Enclosing_Instance As BooleanQuery
    Get
public:
property BooleanQuery^ Enclosing_Instance {
    BooleanQuery^ get ();
}
public:
property BooleanQuery^ Enclosing_Instance {
    BooleanQuery^ get ();
}
See Also
BooleanQuery BooleanWeight Class
BooleanQuery BooleanWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Query Property

BooleanQuery BooleanWeight Query Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Query { get; }
public override Query Query { get; }
Public Overrides ReadOnly Property Query As Query
    Get
Public Overrides ReadOnly Property Query As Query
    Get
public:
virtual property Query^ Query {
    Query^ get () override;
}
public:
virtual property Query^ Query {
    Query^ get () override;
}
See Also
BooleanQuery BooleanWeight Class
BooleanQuery BooleanWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Value Property

BooleanQuery BooleanWeight Value Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Value { get; }
public override float Value { get; }
Public Overrides ReadOnly Property Value As Single
    Get
Public Overrides ReadOnly Property Value As Single
    Get
public:
virtual property float Value {
    float get () override;
}
public:
virtual property float Value {
    float get () override;
}
See Also
BooleanQuery BooleanWeight Class
BooleanQuery BooleanWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery.TooManyClauses Class

BooleanQuery TooManyClauses Class Lucene.Net Class Library
Thrown when an attempt is made to add more than MaxClauseCount clauses. This typically happens if a PrefixQuery, FuzzyQuery, WildcardQuery, or TermRangeQuery is expanded to many terms during search.
Inheritance Hierarchy
Online System Object
Online System Exception
Online System SystemException
Lucene.Net.Search BooleanQuery TooManyClauses

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TooManyClauses : SystemException
[SerializableAttribute]
public class TooManyClauses : SystemException
<SerializableAttribute> _
Public Class TooManyClauses _
    Inherits SystemException
<SerializableAttribute> _
Public Class TooManyClauses _
    Inherits SystemException
[SerializableAttribute]
public ref class TooManyClauses : public SystemException
[SerializableAttribute]
public ref class TooManyClauses : public SystemException
See Also
BooleanQuery TooManyClauses Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery.TooManyClauses Members

BooleanQuery TooManyClauses Members Lucene.Net Class Library

A Query that matches documents matching boolean combinations of other queries, e.g. TermQuerys, PhraseQuerys or other BooleanQuerys.

The BooleanQuery TooManyClauses type exposes the following members.
Constructors
 | Name | Description
Public method | BooleanQuery TooManyClauses | Initializes a new instance of the BooleanQuery TooManyClauses class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | (Overrides Online Exception Message.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
BooleanQuery TooManyClauses Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery.TooManyClauses Constructor

BooleanQuery TooManyClauses Constructor Lucene.Net Class Library
Initializes a new instance of the BooleanQuery TooManyClauses class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TooManyClauses()
public TooManyClauses()
Public Sub New
Public Sub New
public:
TooManyClauses()
public:
TooManyClauses()
See Also
BooleanQuery TooManyClauses Class
BooleanQuery TooManyClauses Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery.TooManyClauses Methods

BooleanQuery TooManyClauses Methods Lucene.Net Class Library
The BooleanQuery TooManyClauses type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
BooleanQuery TooManyClauses Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery.TooManyClauses Properties

BooleanQuery TooManyClauses Properties Lucene.Net Class Library
The BooleanQuery TooManyClauses type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | (Overrides Online Exception Message.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
BooleanQuery TooManyClauses Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Message Property

BooleanQuery TooManyClauses Message Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Message { get; }
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
Public Overrides ReadOnly Property Message As String
    Get
public:
virtual property String^ Message {
    String^ get () override;
}
public:
virtual property String^ Message {
    String^ get () override;
}
Implements
  Online _Exception Message
See Also
BooleanQuery TooManyClauses Class
BooleanQuery TooManyClauses Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanQuery.TooManyClauses Events

BooleanQuery TooManyClauses Events Lucene.Net Class Library
The BooleanQuery TooManyClauses type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
BooleanQuery TooManyClauses Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanScorer Class

BooleanScorer Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSetIterator
Lucene.Net.Search Scorer
Lucene.Net.Search BooleanScorer

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BooleanScorer : Scorer
public sealed class BooleanScorer : Scorer
Public NotInheritable Class BooleanScorer _
    Inherits Scorer
Public NotInheritable Class BooleanScorer _
    Inherits Scorer
public ref class BooleanScorer sealed : public Scorer
public ref class BooleanScorer sealed : public Scorer
See Also
BooleanScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanScorer Members

BooleanScorer Members Lucene.Net Class Library

The BooleanScorer type exposes the following members.
Constructors
 | Name | Description
Public method | BooleanScorer | Initializes a new instance of the BooleanScorer class
Back to Top
Methods
 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Overrides DocIdSetIterator NextDoc .)
Public method | Score | (Overrides Scorer Score .)
Public method | Score(Collector) | (Overrides Scorer Score(Collector).)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer Score(Collector, Int32, Int32).)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | Similarity | Returns the Similarity implementation used by this scorer. (Inherited from Scorer.)
Back to Top
See Also
BooleanScorer Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanScorer Constructor

BooleanScorer Constructor Lucene.Net Class Library
Initializes a new instance of the BooleanScorer class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BooleanScorer(
    Similarity similarity,
    int minNrShouldMatch,
    List<Scorer> optionalScorers,
    List<Scorer> prohibitedScorers
)
public BooleanScorer(
    Similarity similarity,
    int minNrShouldMatch,
    List<Scorer> optionalScorers,
    List<Scorer> prohibitedScorers
)
Public Sub New ( _
    similarity As Similarity, _
    minNrShouldMatch As Integer, _
    optionalScorers As List(Of Scorer), _
    prohibitedScorers As List(Of Scorer) _
)
Public Sub New ( _
    similarity As Similarity, _
    minNrShouldMatch As Integer, _
    optionalScorers As List(Of Scorer), _
    prohibitedScorers As List(Of Scorer) _
)
public:
BooleanScorer(
    Similarity^ similarity,
    int minNrShouldMatch,
    List<Scorer^>^ optionalScorers,
    List<Scorer^>^ prohibitedScorers
)
public:
BooleanScorer(
    Similarity^ similarity,
    int minNrShouldMatch,
    List<Scorer^>^ optionalScorers,
    List<Scorer^>^ prohibitedScorers
)
Parameters
similarity
Type: Lucene.Net.Search Similarity
minNrShouldMatch
Type:   Online System Int32
optionalScorers
Type:   Online System.Collections.Generic List  Scorer
prohibitedScorers
Type:   Online System.Collections.Generic List  Scorer
See Also
BooleanScorer Class
BooleanScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanScorer Methods

BooleanScorer Methods Lucene.Net Class Library
The BooleanScorer type exposes the following members.
Methods
 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Overrides DocIdSetIterator NextDoc .)
Public method | Score | (Overrides Scorer Score .)
Public method | Score(Collector) | (Overrides Scorer Score(Collector).)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer Score(Collector, Int32, Int32).)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
BooleanScorer Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Advance Method

BooleanScorer Advance Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Advance(
    int target
)
public override int Advance(
    int target
)
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
public:
virtual int Advance(
    int target
) override
public:
virtual int Advance(
    int target
) override
Parameters
target
Type:   Online System Int32
See Also
BooleanScorer Class
BooleanScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocID Method

BooleanScorer DocID Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocID()
public override int DocID()
Public Overrides Function DocID As Integer
Public Overrides Function DocID As Integer
public:
virtual int DocID() override
public:
virtual int DocID() override
See Also
BooleanScorer Class
BooleanScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextDoc Method

BooleanScorer NextDoc Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int NextDoc()
public override int NextDoc()
Public Overrides Function NextDoc As Integer
Public Overrides Function NextDoc As Integer
public:
virtual int NextDoc() override
public:
virtual int NextDoc() override
See Also
BooleanScorer Class
BooleanScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method

BooleanScorer Score Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Score | (Overrides Scorer Score .)
Public method | Score(Collector) | (Overrides Scorer Score(Collector).)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer Score(Collector, Int32, Int32).)
Back to Top
See Also
BooleanScorer Class
BooleanScorer Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method

BooleanScorer Score Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Score()
public override float Score()
Public Overrides Function Score As Single
Public Overrides Function Score As Single
public:
virtual float Score() override
public:
virtual float Score() override
See Also
BooleanScorer Class
BooleanScorer Members
Score Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method (Collector)

BooleanScorer Score Method (Collector) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Score(
    Collector collector
)
public override void Score(
    Collector collector
)
Public Overrides Sub Score ( _
    collector As Collector _
)
Public Overrides Sub Score ( _
    collector As Collector _
)
public:
virtual void Score(
    Collector^ collector
) override
public:
virtual void Score(
    Collector^ collector
) override
Parameters
collector
Type: Lucene.Net.Search Collector
See Also
BooleanScorer Class
BooleanScorer Members
Score Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method (Collector, Int32, Int32)

BooleanScorer Score Method (Collector, Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Score(
    Collector collector,
    int max,
    int firstDocID
)
public override bool Score(
    Collector collector,
    int max,
    int firstDocID
)
Public Overrides Function Score ( _
    collector As Collector, _
    max As Integer, _
    firstDocID As Integer _
) As Boolean
Public Overrides Function Score ( _
    collector As Collector, _
    max As Integer, _
    firstDocID As Integer _
) As Boolean
public:
virtual bool Score(
    Collector^ collector,
    int max,
    int firstDocID
) override
public:
virtual bool Score(
    Collector^ collector,
    int max,
    int firstDocID
) override
Parameters
collector
Type: Lucene.Net.Search Collector
max
Type:   Online System Int32
firstDocID
Type:   Online System Int32
See Also
BooleanScorer Class
BooleanScorer Members
Score Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

BooleanScorer ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
BooleanScorer Class
BooleanScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BooleanScorer Properties

BooleanScorer Properties Lucene.Net Class Library
The BooleanScorer type exposes the following members.
Properties
 | Name | Description
Public property | Similarity | Returns the Similarity implementation used by this scorer. (Inherited from Scorer.)
Back to Top
See Also
BooleanScorer Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteParser Interface

ByteParser Interface Lucene.Net Class Library
Interface to parse bytes from document fields.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ByteParser : Parser
public interface ByteParser : Parser
Public Interface ByteParser _
    Inherits Parser
Public Interface ByteParser _
    Inherits Parser
public interface class ByteParser : Parser
public interface class ByteParser : Parser
See Also
ByteParser Members
Lucene.Net.Search Namespace
FieldCache GetBytes(IndexReader, String, ByteParser)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteParser Members

ByteParser Members Lucene.Net Class Library

The ByteParser type exposes the following members.
Methods
 | Name | Description
Public method | ParseByte | Return a single Byte representation of this field's value.
Back to Top
See Also
ByteParser Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteParser Methods

ByteParser Methods Lucene.Net Class Library
The ByteParser type exposes the following members.
Methods
 | Name | Description
Public method | ParseByte | Return a single Byte representation of this field's value.
Back to Top
See Also
ByteParser Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseByte Method

ByteParser ParseByte Method Lucene.Net Class Library
Return a single Byte representation of this field's value.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
sbyte ParseByte(
    string string_Renamed
)
sbyte ParseByte(
    string string_Renamed
)
Function ParseByte ( _
    string_Renamed As String _
) As SByte
Function ParseByte ( _
    string_Renamed As String _
) As SByte
signed char ParseByte(
    String^ string_Renamed
)
signed char ParseByte(
    String^ string_Renamed
)
Parameters
string_Renamed
Type:   Online System String
See Also
ByteParser Interface
ByteParser Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CacheEntry Class

CacheEntry Class Lucene.Net Class Library
EXPERT: A unique Identifier/Description for each item in the FieldCache. Can be useful for logging/debugging.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

Inheritance Hierarchy
Online System Object
Lucene.Net.Search CacheEntry

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class CacheEntry
public abstract class CacheEntry
Public MustInherit Class CacheEntry
Public MustInherit Class CacheEntry
public ref class CacheEntry abstract
public ref class CacheEntry abstract
See Also
CacheEntry Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CacheEntry Members

CacheEntry Members Lucene.Net Class Library

The CacheEntry type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheEntry | Initializes a new instance of the CacheEntry class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | EstimateSize |
Public method | EstimateSize(RamUsageEstimator) | Computes (and stores) the estimated size of the cache Value
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | CacheType |
Public property | Custom |
Public property | EstimatedSize | The most recently estimated size of the value, null unless estimateSize has been called.
Public property | FieldName |
Public property | ReaderKey |
Public property | Value |
Back to Top
See Also
CacheEntry Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CacheEntry Constructor

CacheEntry Constructor Lucene.Net Class Library
Initializes a new instance of the CacheEntry class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CacheEntry()
protected CacheEntry()
Protected Sub New
Protected Sub New
protected:
CacheEntry()
protected:
CacheEntry()
See Also
CacheEntry Class
CacheEntry Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CacheEntry Methods

CacheEntry Methods Lucene.Net Class Library
The CacheEntry type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | EstimateSize |
Public method | EstimateSize(RamUsageEstimator) | Computes (and stores) the estimated size of the cache Value
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
CacheEntry Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EstimateSize Method

CacheEntry EstimateSize Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | EstimateSize |
Public method | EstimateSize(RamUsageEstimator) | Computes (and stores) the estimated size of the cache Value
Back to Top
See Also
CacheEntry Class
CacheEntry Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EstimateSize Method

CacheEntry EstimateSize Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void EstimateSize()
public virtual void EstimateSize()
Public Overridable Sub EstimateSize
Public Overridable Sub EstimateSize
public:
virtual void EstimateSize()
public:
virtual void EstimateSize()
See Also
CacheEntry Class
CacheEntry Members
EstimateSize Overload
Lucene.Net.Search Namespace
CacheEntry EstimateSize(RamUsageEstimator)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EstimateSize Method (RamUsageEstimator)

CacheEntry EstimateSize Method (RamUsageEstimator) Lucene.Net Class Library
Computes (and stores) the estimated size of the cache Value

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void EstimateSize(
    RamUsageEstimator ramCalc
)
public virtual void EstimateSize(
    RamUsageEstimator ramCalc
)
Public Overridable Sub EstimateSize ( _
    ramCalc As RamUsageEstimator _
)
Public Overridable Sub EstimateSize ( _
    ramCalc As RamUsageEstimator _
)
public:
virtual void EstimateSize(
    RamUsageEstimator^ ramCalc
)
public:
virtual void EstimateSize(
    RamUsageEstimator^ ramCalc
)
Parameters
ramCalc
Type: Lucene.Net.Util RamUsageEstimator
See Also
CacheEntry Class
CacheEntry Members
EstimateSize Overload
Lucene.Net.Search Namespace
CacheEntry EstimatedSize
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

CacheEntry ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
CacheEntry Class
CacheEntry Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CacheEntry Properties

CacheEntry Properties Lucene.Net Class Library
The CacheEntry type exposes the following members.
Properties
 | Name | Description
Public property | CacheType |
Public property | Custom |
Public property | EstimatedSize | The most recently estimated size of the value, null unless estimateSize has been called.
Public property | FieldName |
Public property | ReaderKey |
Public property | Value |
Back to Top
See Also
CacheEntry Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CacheType Property

CacheEntry CacheType Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Type CacheType { get; }
public abstract Type CacheType { get; }
Public MustOverride ReadOnly Property CacheType As Type
    Get
Public MustOverride ReadOnly Property CacheType As Type
    Get
public:
virtual property Type^ CacheType {
    Type^ get () abstract;
}
public:
virtual property Type^ CacheType {
    Type^ get () abstract;
}
See Also
CacheEntry Class
CacheEntry Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Custom Property

CacheEntry Custom Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Object Custom { get; }
public abstract Object Custom { get; }
Public MustOverride ReadOnly Property Custom As Object
    Get
Public MustOverride ReadOnly Property Custom As Object
    Get
public:
virtual property Object^ Custom {
    Object^ get () abstract;
}
public:
virtual property Object^ Custom {
    Object^ get () abstract;
}
See Also
CacheEntry Class
CacheEntry Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EstimatedSize Property

CacheEntry EstimatedSize Property Lucene.Net Class Library
The most recently estimated size of the value, null unless estimateSize has been called.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string EstimatedSize { get; protected internal set; }
public string EstimatedSize { get; protected internal set; }
Public Property EstimatedSize As String
    Get
    Protected Friend Set
Public Property EstimatedSize As String
    Get
    Protected Friend Set
public:
property String^ EstimatedSize {
    String^ get ();
    protected public: void set (String^ value);
}
public:
property String^ EstimatedSize {
    String^ get ();
    protected public: void set (String^ value);
}
See Also
CacheEntry Class
CacheEntry Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldName Property

CacheEntry FieldName Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string FieldName { get; }
public abstract string FieldName { get; }
Public MustOverride ReadOnly Property FieldName As String
    Get
Public MustOverride ReadOnly Property FieldName As String
    Get
public:
virtual property String^ FieldName {
    String^ get () abstract;
}
public:
virtual property String^ FieldName {
    String^ get () abstract;
}
See Also
CacheEntry Class
CacheEntry Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReaderKey Property

CacheEntry ReaderKey Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Object ReaderKey { get; }
public abstract Object ReaderKey { get; }
Public MustOverride ReadOnly Property ReaderKey As Object
    Get
Public MustOverride ReadOnly Property ReaderKey As Object
    Get
public:
virtual property Object^ ReaderKey {
    Object^ get () abstract;
}
public:
virtual property Object^ ReaderKey {
    Object^ get () abstract;
}
See Also
CacheEntry Class
CacheEntry Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Value Property

CacheEntry Value Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Object Value { get; }
public abstract Object Value { get; }
Public MustOverride ReadOnly Property Value As Object
    Get
Public MustOverride ReadOnly Property Value As Object
    Get
public:
virtual property Object^ Value {
    Object^ get () abstract;
}
public:
virtual property Object^ Value {
    Object^ get () abstract;
}
See Also
CacheEntry Class
CacheEntry Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingSpanFilter Class

CachingSpanFilter Class Lucene.Net Class Library
Wraps another SpanFilter's result and caches it. The purpose is to allow filters to simply filter, and then wrap with this class to add caching.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Filter
Lucene.Net.Search SpanFilter
Lucene.Net.Search CachingSpanFilter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CachingSpanFilter : SpanFilter
[SerializableAttribute]
public class CachingSpanFilter : SpanFilter
<SerializableAttribute> _
Public Class CachingSpanFilter _
    Inherits SpanFilter
<SerializableAttribute> _
Public Class CachingSpanFilter _
    Inherits SpanFilter
[SerializableAttribute]
public ref class CachingSpanFilter : public SpanFilter
[SerializableAttribute]
public ref class CachingSpanFilter : public SpanFilter
See Also
CachingSpanFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingSpanFilter Members

CachingSpanFilter Members Lucene.Net Class Library

The CachingSpanFilter type exposes the following members.
Constructors
 | Name | Description
Public method | CachingSpanFilter(SpanFilter) | New deletions always result in a cache miss, by default (RECACHE. Filter to cache results of
Public method | CachingSpanFilter(SpanFilter, CachingWrapperFilter DeletesMode) | New deletions always result in a cache miss, specify the deletesMode
Back to Top
Methods
 | Name | Description
Public method | BitSpans | (Overrides SpanFilter BitSpans(IndexReader).)
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Overrides Filter GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Fields
 | Name | Description
Public field | hitCount |
Public field | missCount |
Back to Top
See Also
CachingSpanFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingSpanFilter Constructor

CachingSpanFilter Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | CachingSpanFilter(SpanFilter) | New deletions always result in a cache miss, by default (RECACHE. Filter to cache results of
Public method | CachingSpanFilter(SpanFilter, CachingWrapperFilter DeletesMode) | New deletions always result in a cache miss, specify the deletesMode
Back to Top
See Also
CachingSpanFilter Class
CachingSpanFilter Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingSpanFilter Constructor (SpanFilter)

CachingSpanFilter Constructor (SpanFilter) Lucene.Net Class Library
New deletions always result in a cache miss, by default (RECACHE. Filter to cache results of

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CachingSpanFilter(
    SpanFilter filter
)
public CachingSpanFilter(
    SpanFilter filter
)
Public Sub New ( _
    filter As SpanFilter _
)
Public Sub New ( _
    filter As SpanFilter _
)
public:
CachingSpanFilter(
    SpanFilter^ filter
)
public:
CachingSpanFilter(
    SpanFilter^ filter
)
Parameters
filter
Type: Lucene.Net.Search SpanFilter
See Also
CachingSpanFilter Class
CachingSpanFilter Members
CachingSpanFilter Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingSpanFilter Constructor (SpanFilter, CachingWrapperFilter.DeletesMode)

CachingSpanFilter Constructor (SpanFilter, CachingWrapperFilter DeletesMode) Lucene.Net Class Library
New deletions always result in a cache miss, specify the deletesMode

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CachingSpanFilter(
    SpanFilter filter,
    CachingWrapperFilter..::..DeletesMode deletesMode
)
public CachingSpanFilter(
    SpanFilter filter,
    CachingWrapperFilter..::..DeletesMode deletesMode
)
Public Sub New ( _
    filter As SpanFilter, _
    deletesMode As CachingWrapperFilter..::..DeletesMode _
)
Public Sub New ( _
    filter As SpanFilter, _
    deletesMode As CachingWrapperFilter..::..DeletesMode _
)
public:
CachingSpanFilter(
    SpanFilter^ filter,
    CachingWrapperFilter..::..DeletesMode deletesMode
)
public:
CachingSpanFilter(
    SpanFilter^ filter,
    CachingWrapperFilter..::..DeletesMode deletesMode
)
Parameters
filter
Type: Lucene.Net.Search SpanFilter
Filter to cache results of
deletesMode
Type: Lucene.Net.Search CachingWrapperFilter DeletesMode
See CachingWrapperFilter DeletesMode
See Also
CachingSpanFilter Class
CachingSpanFilter Members
CachingSpanFilter Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingSpanFilter Fields

CachingSpanFilter Fields Lucene.Net Class Library
The CachingSpanFilter type exposes the following members.
Fields
 | Name | Description
Public field | hitCount |
Public field | missCount |
Back to Top
See Also
CachingSpanFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


hitCount Field

CachingSpanFilter hitCount Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int hitCount
public int hitCount
Public hitCount As Integer
Public hitCount As Integer
public:
int hitCount
public:
int hitCount
See Also
CachingSpanFilter Class
CachingSpanFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


missCount Field

CachingSpanFilter missCount Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int missCount
public int missCount
Public missCount As Integer
Public missCount As Integer
public:
int missCount
public:
int missCount
See Also
CachingSpanFilter Class
CachingSpanFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingSpanFilter Methods

CachingSpanFilter Methods Lucene.Net Class Library
The CachingSpanFilter type exposes the following members.
Methods
 | Name | Description
Public method | BitSpans | (Overrides SpanFilter BitSpans(IndexReader).)
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Overrides Filter GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
CachingSpanFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitSpans Method

CachingSpanFilter BitSpans Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override SpanFilterResult BitSpans(
    IndexReader reader
)
public override SpanFilterResult BitSpans(
    IndexReader reader
)
Public Overrides Function BitSpans ( _
    reader As IndexReader _
) As SpanFilterResult
Public Overrides Function BitSpans ( _
    reader As IndexReader _
) As SpanFilterResult
public:
virtual SpanFilterResult^ BitSpans(
    IndexReader^ reader
) override
public:
virtual SpanFilterResult^ BitSpans(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
CachingSpanFilter Class
CachingSpanFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

CachingSpanFilter Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
CachingSpanFilter Class
CachingSpanFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetDocIdSet Method

CachingSpanFilter GetDocIdSet Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
CachingSpanFilter Class
CachingSpanFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

CachingSpanFilter GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
CachingSpanFilter Class
CachingSpanFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

CachingSpanFilter ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
CachingSpanFilter Class
CachingSpanFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingWrapperFilter Class

CachingWrapperFilter Class Lucene.Net Class Library
Wraps another filter's result and caches it. The purpose is to allow filters to simply filter, and then wrap with this class to add caching.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Filter
Lucene.Net.Search CachingWrapperFilter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CachingWrapperFilter : Filter
[SerializableAttribute]
public class CachingWrapperFilter : Filter
<SerializableAttribute> _
Public Class CachingWrapperFilter _
    Inherits Filter
<SerializableAttribute> _
Public Class CachingWrapperFilter _
    Inherits Filter
[SerializableAttribute]
public ref class CachingWrapperFilter : public Filter
[SerializableAttribute]
public ref class CachingWrapperFilter : public Filter
See Also
CachingWrapperFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingWrapperFilter Members

CachingWrapperFilter Members Lucene.Net Class Library

The CachingWrapperFilter type exposes the following members.
Constructors
 | Name | Description
Public method | CachingWrapperFilter(Filter) | New deletes are ignored by default, which gives higher cache hit rate on reopened readers. Most of the time this is safe, because the filter will be AND'd with a Query that fully enforces deletions. If instead you need this filter to always enforce deletions, pass either RECACHE or DYNAMIC.
Public method | CachingWrapperFilter(Filter, CachingWrapperFilter DeletesMode) | Expert: by default, the cached filter will be shared across reopened segments that only had changes to their deletions.
Back to Top
Methods
 | Name | Description
Protected method | DocIdSetToCache | Provide the DocIdSet to be cached, using the DocIdSet provided by the wrapped Filter. This implementation returns the given DocIdSet.
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Overrides Filter GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Fields
 | Name | Description
Protected field | filter |
Public field | hitCount |
Public field | missCount |
Back to Top
See Also
CachingWrapperFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingWrapperFilter Constructor

CachingWrapperFilter Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | CachingWrapperFilter(Filter) | New deletes are ignored by default, which gives higher cache hit rate on reopened readers. Most of the time this is safe, because the filter will be AND'd with a Query that fully enforces deletions. If instead you need this filter to always enforce deletions, pass either RECACHE or DYNAMIC.
Public method | CachingWrapperFilter(Filter, CachingWrapperFilter DeletesMode) | Expert: by default, the cached filter will be shared across reopened segments that only had changes to their deletions.
Back to Top
See Also
CachingWrapperFilter Class
CachingWrapperFilter Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingWrapperFilter Constructor (Filter)

CachingWrapperFilter Constructor (Filter) Lucene.Net Class Library
New deletes are ignored by default, which gives higher cache hit rate on reopened readers. Most of the time this is safe, because the filter will be AND'd with a Query that fully enforces deletions. If instead you need this filter to always enforce deletions, pass either RECACHE or DYNAMIC.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CachingWrapperFilter(
    Filter filter
)
public CachingWrapperFilter(
    Filter filter
)
Public Sub New ( _
    filter As Filter _
)
Public Sub New ( _
    filter As Filter _
)
public:
CachingWrapperFilter(
    Filter^ filter
)
public:
CachingWrapperFilter(
    Filter^ filter
)
Parameters
filter
Type: Lucene.Net.Search Filter
Filter to cache results of
See Also
CachingWrapperFilter Class
CachingWrapperFilter Members
CachingWrapperFilter Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingWrapperFilter Constructor (Filter, CachingWrapperFilter.DeletesMode)

CachingWrapperFilter Constructor (Filter, CachingWrapperFilter DeletesMode) Lucene.Net Class Library
Expert: by default, the cached filter will be shared across reopened segments that only had changes to their deletions.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CachingWrapperFilter(
    Filter filter,
    CachingWrapperFilter..::..DeletesMode deletesMode
)
public CachingWrapperFilter(
    Filter filter,
    CachingWrapperFilter..::..DeletesMode deletesMode
)
Public Sub New ( _
    filter As Filter, _
    deletesMode As CachingWrapperFilter..::..DeletesMode _
)
Public Sub New ( _
    filter As Filter, _
    deletesMode As CachingWrapperFilter..::..DeletesMode _
)
public:
CachingWrapperFilter(
    Filter^ filter,
    CachingWrapperFilter..::..DeletesMode deletesMode
)
public:
CachingWrapperFilter(
    Filter^ filter,
    CachingWrapperFilter..::..DeletesMode deletesMode
)
Parameters
filter
Type: Lucene.Net.Search Filter
Filter to cache results of
deletesMode
Type: Lucene.Net.Search CachingWrapperFilter DeletesMode
See CachingWrapperFilter DeletesMode
See Also
CachingWrapperFilter Class
CachingWrapperFilter Members
CachingWrapperFilter Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingWrapperFilter Fields

CachingWrapperFilter Fields Lucene.Net Class Library
The CachingWrapperFilter type exposes the following members.
Fields
 | Name | Description
Protected field | filter |
Public field | hitCount |
Public field | missCount |
Back to Top
See Also
CachingWrapperFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


filter Field

CachingWrapperFilter filter Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Filter filter
protected Filter filter
Protected filter As Filter
Protected filter As Filter
protected:
Filter^ filter
protected:
Filter^ filter
See Also
CachingWrapperFilter Class
CachingWrapperFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


hitCount Field

CachingWrapperFilter hitCount Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int hitCount
public int hitCount
Public hitCount As Integer
Public hitCount As Integer
public:
int hitCount
public:
int hitCount
See Also
CachingWrapperFilter Class
CachingWrapperFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


missCount Field

CachingWrapperFilter missCount Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int missCount
public int missCount
Public missCount As Integer
Public missCount As Integer
public:
int missCount
public:
int missCount
See Also
CachingWrapperFilter Class
CachingWrapperFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingWrapperFilter Methods

CachingWrapperFilter Methods Lucene.Net Class Library
The CachingWrapperFilter type exposes the following members.
Methods
 | Name | Description
Protected method | DocIdSetToCache | Provide the DocIdSet to be cached, using the DocIdSet provided by the wrapped Filter. This implementation returns the given DocIdSet.
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Overrides Filter GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
CachingWrapperFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSetToCache Method

CachingWrapperFilter DocIdSetToCache Method Lucene.Net Class Library
Provide the DocIdSet to be cached, using the DocIdSet provided by the wrapped Filter. This implementation returns the given DocIdSet.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual DocIdSet DocIdSetToCache(
    DocIdSet docIdSet,
    IndexReader reader
)
protected virtual DocIdSet DocIdSetToCache(
    DocIdSet docIdSet,
    IndexReader reader
)
Protected Overridable Function DocIdSetToCache ( _
    docIdSet As DocIdSet, _
    reader As IndexReader _
) As DocIdSet
Protected Overridable Function DocIdSetToCache ( _
    docIdSet As DocIdSet, _
    reader As IndexReader _
) As DocIdSet
protected:
virtual DocIdSet^ DocIdSetToCache(
    DocIdSet^ docIdSet,
    IndexReader^ reader
)
protected:
virtual DocIdSet^ DocIdSetToCache(
    DocIdSet^ docIdSet,
    IndexReader^ reader
)
Parameters
docIdSet
Type: Lucene.Net.Search DocIdSet
reader
Type: Lucene.Net.Index IndexReader
See Also
CachingWrapperFilter Class
CachingWrapperFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

CachingWrapperFilter Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
CachingWrapperFilter Class
CachingWrapperFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetDocIdSet Method

CachingWrapperFilter GetDocIdSet Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
CachingWrapperFilter Class
CachingWrapperFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

CachingWrapperFilter GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
CachingWrapperFilter Class
CachingWrapperFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

CachingWrapperFilter ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
CachingWrapperFilter Class
CachingWrapperFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachingWrapperFilter.DeletesMode Enumeration

CachingWrapperFilter DeletesMode Enumeration Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum DeletesMode
public enum DeletesMode
Public Enumeration DeletesMode
Public Enumeration DeletesMode
public enum class DeletesMode
public enum class DeletesMode
Members
Member name | Value | Description
IGNORE | 0 |
RECACHE | 1 |
DYNAMIC | 2 |
See Also
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Collector Class

Collector Class Lucene.Net Class Library

Expert: Collectors are primarily meant to be used to gather raw results from a search, and implement sorting or custom result filtering, collation, etc.

Lucene's core collectors are derived from Collector. Likely your application can use one of these classes, or subclass TopDocsCollector T , instead of implementing Collector directly:
  • TopDocsCollector T is an abstract base class that assumes you will retrieve the top N docs, according to some criteria, after collection is done.
  • TopScoreDocCollector is a concrete subclass TopDocsCollector T and sorts according to score + docID. This is used internally by the IndexSearcher search methods that do not take an explicit Sort. It is likely the most frequently used collector.
  • TopFieldCollector subclasses TopDocsCollector T and sorts according to a specified Sort object (sort by field). This is used internally by the IndexSearcher search methods that take an explicit Sort.
  • TimeLimitingCollector, which wraps any other Collector and aborts the search if it's taken too much time.
  • PositiveScoresOnlyCollector wraps any other Collector and prevents collection of hits whose score is <= 0.0

Collector decouples the score from the collected doc: the score computation is skipped entirely if it's not needed. Collectors that do need the score should implement the SetScorer(Scorer) method, to hold onto the passed Scorer instance, and call Score within the collect method to compute the current hit's score. If your collector may request the score for a single hit multiple times, you should use ScoreCachingWrappingScorer.

NOTE: The doc that is passed to the collect method is relative to the current reader. If your collector needs to resolve this to the docID space of the Multi*Reader, you must re-base it by recording the docBase from the most recent setNextReader call. Here's a simple example showing how to collect docIDs into a BitSet:

View Colorized Copy to Clipboard Print
Searcher searcher = new IndexSearcher(indexReader);
final BitSet bits = new BitSet(indexReader.MaxDoc);
searcher.search(query, new Collector() {
private int docBase;

<em>// ignore scorer</em>
public void setScorer(Scorer scorer) {
}

<em>// accept docs out of order (for a BitSet it doesn't matter)</em>
public boolean acceptsDocsOutOfOrder() {
return true;
}

public void collect(int doc) {
bits.set(doc + docBase);
}

public void setNextReader(IndexReader reader, int docBase) {
this.docBase = docBase;
}
});
Searcher searcher = new IndexSearcher(indexReader);
final BitSet bits = new BitSet(indexReader.MaxDoc);
searcher.search(query, new Collector() {
private int docBase;

<em>// ignore scorer</em>
public void setScorer(Scorer scorer) {
}

<em>// accept docs out of order (for a BitSet it doesn't matter)</em>
public boolean acceptsDocsOutOfOrder() {
return true;
}

public void collect(int doc) {
bits.set(doc + docBase);
}

public void setNextReader(IndexReader reader, int docBase) {
this.docBase = docBase;
}
});

Not all collectors will need to rebase the docID. For example, a collector that simply counts the total number of hits would skip it.

NOTE: Prior to 2.9, Lucene silently filtered out hits with score <= 0. As of 2.9, the core Collectors no longer do that. It's very unusual to have such hits (a negative query boost, or function query returning negative custom scores, could cause it to happen). If you need that behavior, use PositiveScoresOnlyCollector .

NOTE: This API is experimental and might change in incompatible ways in the next release.

Inheritance Hierarchy
Online System Object
Lucene.Net.Search Collector
Lucene.Net.Search PositiveScoresOnlyCollector
Lucene.Net.Search TimeLimitingCollector
Lucene.Net.Search TopDocsCollector T

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Collector
public abstract class Collector
Public MustInherit Class Collector
Public MustInherit Class Collector
public ref class Collector abstract
public ref class Collector abstract
See Also
Collector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Collector Members

Collector Members Lucene.Net Class Library

The Collector type exposes the following members.
Constructors
 | Name | Description
Protected method | Collector | Initializes a new instance of the Collector class
Back to Top
Methods
 | Name | Description
Public method | Collect | Called once for every document matching a query, with the unbased document number. Note: This is called in an inner search loop. For good search performance, implementations of this method should not call Doc(Int32) or Document(Int32) on every hit. Doing so can slow searches by an order of magnitude or more.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetNextReader | Called before collecting from each IndexReader. All doc ids in Collect(Int32) will correspond to reader. Add docBase to the current IndexReaders internal document id to re-base ids in Collect(Int32).
Public method | SetScorer | Called before successive calls to Collect(Int32). Implementations that need the score of the current document (passed-in to Collect(Int32)), should save the passed-in Scorer and call scorer.score() when needed.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | AcceptsDocsOutOfOrder | Return true if this collector does not require the matching docIDs to be delivered in int sort order (smallest to largest) to Collect(Int32). Most Lucene Query implementations will visit matching docIDs in order. However, some queries (currently limited to certain cases of BooleanQuery) can achieve faster searching if the Collector allows them to deliver the docIDs out of order. Many collectors don't mind getting docIDs out of order, so it's important to return true here.
Back to Top
See Also
Collector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Collector Constructor

Collector Constructor Lucene.Net Class Library
Initializes a new instance of the Collector class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Collector()
protected Collector()
Protected Sub New
Protected Sub New
protected:
Collector()
protected:
Collector()
See Also
Collector Class
Collector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Collector Methods

Collector Methods Lucene.Net Class Library
The Collector type exposes the following members.
Methods
 | Name | Description
Public method | Collect | Called once for every document matching a query, with the unbased document number. Note: This is called in an inner search loop. For good search performance, implementations of this method should not call Doc(Int32) or Document(Int32) on every hit. Doing so can slow searches by an order of magnitude or more.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetNextReader | Called before collecting from each IndexReader. All doc ids in Collect(Int32) will correspond to reader. Add docBase to the current IndexReaders internal document id to re-base ids in Collect(Int32).
Public method | SetScorer | Called before successive calls to Collect(Int32). Implementations that need the score of the current document (passed-in to Collect(Int32)), should save the passed-in Scorer and call scorer.score() when needed.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Collector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Collect Method

Collector Collect Method Lucene.Net Class Library
Called once for every document matching a query, with the unbased document number.

Note: This is called in an inner search loop. For good search performance, implementations of this method should not call Doc(Int32) or Document(Int32) on every hit. Doing so can slow searches by an order of magnitude or more.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Collect(
    int doc
)
public abstract void Collect(
    int doc
)
Public MustOverride Sub Collect ( _
    doc As Integer _
)
Public MustOverride Sub Collect ( _
    doc As Integer _
)
public:
virtual void Collect(
    int doc
) abstract
public:
virtual void Collect(
    int doc
) abstract
Parameters
doc
Type:   Online System Int32
See Also
Collector Class
Collector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNextReader Method

Collector SetNextReader Method Lucene.Net Class Library
Called before collecting from each IndexReader. All doc ids in Collect(Int32) will correspond to reader. Add docBase to the current IndexReaders internal document id to re-base ids in Collect(Int32).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void SetNextReader(
    IndexReader reader,
    int docBase
)
public abstract void SetNextReader(
    IndexReader reader,
    int docBase
)
Public MustOverride Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Public MustOverride Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) abstract
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) abstract
Parameters
reader
Type: Lucene.Net.Index IndexReader
next IndexReader

docBase
Type:   Online System Int32
See Also
Collector Class
Collector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetScorer Method

Collector SetScorer Method Lucene.Net Class Library
Called before successive calls to Collect(Int32). Implementations that need the score of the current document (passed-in to Collect(Int32)), should save the passed-in Scorer and call scorer.score() when needed.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void SetScorer(
    Scorer scorer
)
public abstract void SetScorer(
    Scorer scorer
)
Public MustOverride Sub SetScorer ( _
    scorer As Scorer _
)
Public MustOverride Sub SetScorer ( _
    scorer As Scorer _
)
public:
virtual void SetScorer(
    Scorer^ scorer
) abstract
public:
virtual void SetScorer(
    Scorer^ scorer
) abstract
Parameters
scorer
Type: Lucene.Net.Search Scorer
See Also
Collector Class
Collector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Collector Properties

Collector Properties Lucene.Net Class Library
The Collector type exposes the following members.
Properties
 | Name | Description
Public property | AcceptsDocsOutOfOrder | Return true if this collector does not require the matching docIDs to be delivered in int sort order (smallest to largest) to Collect(Int32). Most Lucene Query implementations will visit matching docIDs in order. However, some queries (currently limited to certain cases of BooleanQuery) can achieve faster searching if the Collector allows them to deliver the docIDs out of order. Many collectors don't mind getting docIDs out of order, so it's important to return true here.
Back to Top
See Also
Collector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AcceptsDocsOutOfOrder Property

Collector AcceptsDocsOutOfOrder Property Lucene.Net Class Library
Return true if this collector does not require the matching docIDs to be delivered in int sort order (smallest to largest) to Collect(Int32).

Most Lucene Query implementations will visit matching docIDs in order. However, some queries (currently limited to certain cases of BooleanQuery) can achieve faster searching if the Collector allows them to deliver the docIDs out of order.

Many collectors don't mind getting docIDs out of order, so it's important to return true here.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool AcceptsDocsOutOfOrder { get; }
public abstract bool AcceptsDocsOutOfOrder { get; }
Public MustOverride ReadOnly Property AcceptsDocsOutOfOrder As Boolean
    Get
Public MustOverride ReadOnly Property AcceptsDocsOutOfOrder As Boolean
    Get
public:
virtual property bool AcceptsDocsOutOfOrder {
    bool get () abstract;
}
public:
virtual property bool AcceptsDocsOutOfOrder {
    bool get () abstract;
}
Field Value
See Also
Collector Class
Collector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ComplexExplanation Class

ComplexExplanation Class Lucene.Net Class Library
Expert: Describes the score computation for document and query, and can distinguish a match independent of a positive value.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Explanation
Lucene.Net.Search ComplexExplanation

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ComplexExplanation : Explanation
[SerializableAttribute]
public class ComplexExplanation : Explanation
<SerializableAttribute> _
Public Class ComplexExplanation _
    Inherits Explanation
<SerializableAttribute> _
Public Class ComplexExplanation _
    Inherits Explanation
[SerializableAttribute]
public ref class ComplexExplanation : public Explanation
[SerializableAttribute]
public ref class ComplexExplanation : public Explanation
See Also
ComplexExplanation Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ComplexExplanation Members

ComplexExplanation Members Lucene.Net Class Library

The ComplexExplanation type exposes the following members.
Constructors
 | Name | Description
Public method | ComplexExplanation | Initializes a new instance of the ComplexExplanation class
Public method | ComplexExplanation(Boolean, Single, String) | Initializes a new instance of the ComplexExplanation class
Back to Top
Methods
 | Name | Description
Public method | AddDetail | Adds a sub-node to this explanation node. (Inherited from Explanation.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDetails | The sub-nodes of this explanation node. (Inherited from Explanation.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToHtml | Render an explanation as HTML. (Inherited from Explanation.)
Public method | ToString | Render an explanation as text. (Inherited from Explanation.)
Protected method | ToString(Int32) | (Inherited from Explanation.)
Back to Top
Properties
 | Name | Description
Public property | Description | A description of this explanation node. (Inherited from Explanation.)
Public property | IsMatch | Indicates whether or not this Explanation models a good match. If the match status is explicitly set (i.e.: not null) this method uses it; otherwise it defers to the superclass. (Overrides Explanation IsMatch.)
Public property | Match | The match status of this explanation node.
Protected property | Summary | (Overrides Explanation Summary.)
Public property | Value | The value assigned to this explanation node. (Inherited from Explanation.)
Back to Top
See Also
ComplexExplanation Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ComplexExplanation Constructor

ComplexExplanation Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ComplexExplanation | Initializes a new instance of the ComplexExplanation class
Public method | ComplexExplanation(Boolean, Single, String) | Initializes a new instance of the ComplexExplanation class
Back to Top
See Also
ComplexExplanation Class
ComplexExplanation Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ComplexExplanation Constructor

ComplexExplanation Constructor Lucene.Net Class Library
Initializes a new instance of the ComplexExplanation class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ComplexExplanation()
public ComplexExplanation()
Public Sub New
Public Sub New
public:
ComplexExplanation()
public:
ComplexExplanation()
See Also
ComplexExplanation Class
ComplexExplanation Members
ComplexExplanation Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ComplexExplanation Constructor (Boolean, Single, String)

ComplexExplanation Constructor (Boolean, Single, String) Lucene.Net Class Library
Initializes a new instance of the ComplexExplanation class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ComplexExplanation(
    bool match,
    float value_Renamed,
    string description
)
public ComplexExplanation(
    bool match,
    float value_Renamed,
    string description
)
Public Sub New ( _
    match As Boolean, _
    value_Renamed As Single, _
    description As String _
)
Public Sub New ( _
    match As Boolean, _
    value_Renamed As Single, _
    description As String _
)
public:
ComplexExplanation(
    bool match,
    float value_Renamed,
    String^ description
)
public:
ComplexExplanation(
    bool match,
    float value_Renamed,
    String^ description
)
Parameters
match
Type:   Online System Boolean
value_Renamed
Type:   Online System Single
description
Type:   Online System String
See Also
ComplexExplanation Class
ComplexExplanation Members
ComplexExplanation Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ComplexExplanation Methods

ComplexExplanation Methods Lucene.Net Class Library
The ComplexExplanation type exposes the following members.
Methods
 | Name | Description
Public method | AddDetail | Adds a sub-node to this explanation node. (Inherited from Explanation.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDetails | The sub-nodes of this explanation node. (Inherited from Explanation.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToHtml | Render an explanation as HTML. (Inherited from Explanation.)
Public method | ToString | Render an explanation as text. (Inherited from Explanation.)
Protected method | ToString(Int32) | (Inherited from Explanation.)
Back to Top
See Also
ComplexExplanation Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ComplexExplanation Properties

ComplexExplanation Properties Lucene.Net Class Library
The ComplexExplanation type exposes the following members.
Properties
 | Name | Description
Public property | Description | A description of this explanation node. (Inherited from Explanation.)
Public property | IsMatch | Indicates whether or not this Explanation models a good match. If the match status is explicitly set (i.e.: not null) this method uses it; otherwise it defers to the superclass. (Overrides Explanation IsMatch.)
Public property | Match | The match status of this explanation node.
Protected property | Summary | (Overrides Explanation Summary.)
Public property | Value | The value assigned to this explanation node. (Inherited from Explanation.)
Back to Top
See Also
ComplexExplanation Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsMatch Property

ComplexExplanation IsMatch Property Lucene.Net Class Library
Indicates whether or not this Explanation models a good match.

If the match status is explicitly set (i.e.: not null) this method uses it; otherwise it defers to the superclass.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsMatch { get; }
public override bool IsMatch { get; }
Public Overrides ReadOnly Property IsMatch As Boolean
    Get
Public Overrides ReadOnly Property IsMatch As Boolean
    Get
public:
virtual property bool IsMatch {
    bool get () override;
}
public:
virtual property bool IsMatch {
    bool get () override;
}
See Also
ComplexExplanation Class
ComplexExplanation Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Match Property

ComplexExplanation Match Property Lucene.Net Class Library
The match status of this explanation node.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Nullable<bool> Match { get; set; }
public virtual Nullable<bool> Match { get; set; }
Public Overridable Property Match As Nullable(Of Boolean)
    Get
    Set
Public Overridable Property Match As Nullable(Of Boolean)
    Get
    Set
public:
virtual property Nullable<bool> Match {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
public:
virtual property Nullable<bool> Match {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
Field Value
 May be null if match status is unknown

See Also
ComplexExplanation Class
ComplexExplanation Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Summary Property

ComplexExplanation Summary Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override string Summary { get; }
protected override string Summary { get; }
Protected Overrides ReadOnly Property Summary As String
    Get
Protected Overrides ReadOnly Property Summary As String
    Get
protected:
virtual property String^ Summary {
    String^ get () override;
}
protected:
virtual property String^ Summary {
    String^ get () override;
}
See Also
ComplexExplanation Class
ComplexExplanation Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConstantScoreQuery Class

ConstantScoreQuery Class Lucene.Net Class Library
A query that wraps a filter and simply returns a constant score equal to the query boost for every document in the filter.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search ConstantScoreQuery

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ConstantScoreQuery : Query
[SerializableAttribute]
public class ConstantScoreQuery : Query
<SerializableAttribute> _
Public Class ConstantScoreQuery _
    Inherits Query
<SerializableAttribute> _
Public Class ConstantScoreQuery _
    Inherits Query
[SerializableAttribute]
public ref class ConstantScoreQuery : public Query
[SerializableAttribute]
public ref class ConstantScoreQuery : public Query
See Also
ConstantScoreQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConstantScoreQuery Members

ConstantScoreQuery Members Lucene.Net Class Library

The ConstantScoreQuery type exposes the following members.
Constructors
 | Name | Description
Public method | ConstantScoreQuery | Initializes a new instance of the ConstantScoreQuery class
Back to Top
Methods
 | Name | Description
Public method | Clone | (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | Returns true if o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Fields
 | Name | Description
Protected field | internalFilter |
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Filter | Returns the encapsulated filter
Back to Top
See Also
ConstantScoreQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConstantScoreQuery Constructor

ConstantScoreQuery Constructor Lucene.Net Class Library
Initializes a new instance of the ConstantScoreQuery class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConstantScoreQuery(
    Filter filter
)
public ConstantScoreQuery(
    Filter filter
)
Public Sub New ( _
    filter As Filter _
)
Public Sub New ( _
    filter As Filter _
)
public:
ConstantScoreQuery(
    Filter^ filter
)
public:
ConstantScoreQuery(
    Filter^ filter
)
Parameters
filter
Type: Lucene.Net.Search Filter
See Also
ConstantScoreQuery Class
ConstantScoreQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConstantScoreQuery Fields

ConstantScoreQuery Fields Lucene.Net Class Library
The ConstantScoreQuery type exposes the following members.
Fields
 | Name | Description
Protected field | internalFilter |
Back to Top
See Also
ConstantScoreQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalFilter Field

ConstantScoreQuery internalFilter Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Filter internalFilter
protected Filter internalFilter
Protected internalFilter As Filter
Protected internalFilter As Filter
protected:
Filter^ internalFilter
protected:
Filter^ internalFilter
See Also
ConstantScoreQuery Class
ConstantScoreQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConstantScoreQuery Methods

ConstantScoreQuery Methods Lucene.Net Class Library
The ConstantScoreQuery type exposes the following members.
Methods
 | Name | Description
Public method | Clone | (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | Returns true if o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
ConstantScoreQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

ConstantScoreQuery Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
See Also
ConstantScoreQuery Class
ConstantScoreQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateWeight Method

ConstantScoreQuery CreateWeight Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Weight CreateWeight(
    Searcher searcher
)
public override Weight CreateWeight(
    Searcher searcher
)
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
ConstantScoreQuery Class
ConstantScoreQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

ConstantScoreQuery Equals Method Lucene.Net Class Library
Returns true if o is equal to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
ConstantScoreQuery Class
ConstantScoreQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExtractTerms Method

ConstantScoreQuery ExtractTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ExtractTerms(
    ISet<Term> terms
)
public override void ExtractTerms(
    ISet<Term> terms
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
Parameters
terms
Type:   Online System.Collections.Generic ISet  Term
See Also
ConstantScoreQuery Class
ConstantScoreQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

ConstantScoreQuery GetHashCode Method Lucene.Net Class Library
Returns a hash code value for this object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
ConstantScoreQuery Class
ConstantScoreQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

ConstantScoreQuery Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    IndexReader reader
)
public override Query Rewrite(
    IndexReader reader
)
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
ConstantScoreQuery Class
ConstantScoreQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

ConstantScoreQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Back to Top
See Also
ConstantScoreQuery Class
ConstantScoreQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

ConstantScoreQuery ToString Method (String) Lucene.Net Class Library
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
ConstantScoreQuery Class
ConstantScoreQuery Members
ToString Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConstantScoreQuery Properties

ConstantScoreQuery Properties Lucene.Net Class Library
The ConstantScoreQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Filter | Returns the encapsulated filter
Back to Top
See Also
ConstantScoreQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Filter Property

ConstantScoreQuery Filter Property Lucene.Net Class Library
Returns the encapsulated filter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Filter Filter { get; }
public virtual Filter Filter { get; }
Public Overridable ReadOnly Property Filter As Filter
    Get
Public Overridable ReadOnly Property Filter As Filter
    Get
public:
virtual property Filter^ Filter {
    Filter^ get ();
}
public:
virtual property Filter^ Filter {
    Filter^ get ();
}
See Also
ConstantScoreQuery Class
ConstantScoreQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConstantScoreQuery.ConstantScorer Class

ConstantScoreQuery ConstantScorer Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSetIterator
Lucene.Net.Search Scorer
Lucene.Net.Search ConstantScoreQuery ConstantScorer

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal class ConstantScorer : Scorer
protected internal class ConstantScorer : Scorer
Protected Friend Class ConstantScorer _
    Inherits Scorer
Protected Friend Class ConstantScorer _
    Inherits Scorer
protected public ref class ConstantScorer : public Scorer
protected public ref class ConstantScorer : public Scorer
See Also
ConstantScoreQuery ConstantScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConstantScoreQuery.ConstantScorer Members

ConstantScoreQuery ConstantScorer Members Lucene.Net Class Library

A query that wraps a filter and simply returns a constant score equal to the query boost for every document in the filter.

The ConstantScoreQuery ConstantScorer type exposes the following members.
Constructors
 | Name | Description
Public method | ConstantScoreQuery ConstantScorer | Initializes a new instance of the ConstantScoreQuery ConstantScorer class
Back to Top
Methods
 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Overrides DocIdSetIterator NextDoc .)
Public method | Score | (Overrides Scorer Score .)
Public method | Score(Collector) | Scores and collects all matching documents. (Inherited from Scorer.)
Public method | Score(Collector, Int32, Int32) | Expert: Collects matching documents in a range. Hook for optimization. Note, firstDocID is added to ensure that NextDoc was called before this method. (Inherited from Scorer.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Similarity | Returns the Similarity implementation used by this scorer. (Inherited from Scorer.)
Back to Top
See Also
ConstantScoreQuery ConstantScorer Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConstantScoreQuery.ConstantScorer Constructor

ConstantScoreQuery ConstantScorer Constructor Lucene.Net Class Library
Initializes a new instance of the ConstantScoreQuery ConstantScorer class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConstantScorer(
    ConstantScoreQuery enclosingInstance,
    Similarity similarity,
    IndexReader reader,
    Weight w
)
public ConstantScorer(
    ConstantScoreQuery enclosingInstance,
    Similarity similarity,
    IndexReader reader,
    Weight w
)
Public Sub New ( _
    enclosingInstance As ConstantScoreQuery, _
    similarity As Similarity, _
    reader As IndexReader, _
    w As Weight _
)
Public Sub New ( _
    enclosingInstance As ConstantScoreQuery, _
    similarity As Similarity, _
    reader As IndexReader, _
    w As Weight _
)
public:
ConstantScorer(
    ConstantScoreQuery^ enclosingInstance,
    Similarity^ similarity,
    IndexReader^ reader,
    Weight^ w
)
public:
ConstantScorer(
    ConstantScoreQuery^ enclosingInstance,
    Similarity^ similarity,
    IndexReader^ reader,
    Weight^ w
)
Parameters
enclosingInstance
Type: Lucene.Net.Search ConstantScoreQuery
similarity
Type: Lucene.Net.Search Similarity
reader
Type: Lucene.Net.Index IndexReader
w
Type: Lucene.Net.Search Weight
See Also
ConstantScoreQuery ConstantScorer Class
ConstantScoreQuery ConstantScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConstantScoreQuery.ConstantScorer Methods

ConstantScoreQuery ConstantScorer Methods Lucene.Net Class Library
The ConstantScoreQuery ConstantScorer type exposes the following members.
Methods
 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Overrides DocIdSetIterator NextDoc .)
Public method | Score | (Overrides Scorer Score .)
Public method | Score(Collector) | Scores and collects all matching documents. (Inherited from Scorer.)
Public method | Score(Collector, Int32, Int32) | Expert: Collects matching documents in a range. Hook for optimization. Note, firstDocID is added to ensure that NextDoc was called before this method. (Inherited from Scorer.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ConstantScoreQuery ConstantScorer Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Advance Method

ConstantScoreQuery ConstantScorer Advance Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Advance(
    int target
)
public override int Advance(
    int target
)
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
public:
virtual int Advance(
    int target
) override
public:
virtual int Advance(
    int target
) override
Parameters
target
Type:   Online System Int32
See Also
ConstantScoreQuery ConstantScorer Class
ConstantScoreQuery ConstantScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocID Method

ConstantScoreQuery ConstantScorer DocID Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocID()
public override int DocID()
Public Overrides Function DocID As Integer
Public Overrides Function DocID As Integer
public:
virtual int DocID() override
public:
virtual int DocID() override
See Also
ConstantScoreQuery ConstantScorer Class
ConstantScoreQuery ConstantScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextDoc Method

ConstantScoreQuery ConstantScorer NextDoc Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int NextDoc()
public override int NextDoc()
Public Overrides Function NextDoc As Integer
Public Overrides Function NextDoc As Integer
public:
virtual int NextDoc() override
public:
virtual int NextDoc() override
See Also
ConstantScoreQuery ConstantScorer Class
ConstantScoreQuery ConstantScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method

ConstantScoreQuery ConstantScorer Score Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Score | (Overrides Scorer Score .)
Public method | Score(Collector) | Scores and collects all matching documents. (Inherited from Scorer.)
Public method | Score(Collector, Int32, Int32) | Expert: Collects matching documents in a range. Hook for optimization. Note, firstDocID is added to ensure that NextDoc was called before this method. (Inherited from Scorer.)
Back to Top
See Also
ConstantScoreQuery ConstantScorer Class
ConstantScoreQuery ConstantScorer Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method

ConstantScoreQuery ConstantScorer Score Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Score()
public override float Score()
Public Overrides Function Score As Single
Public Overrides Function Score As Single
public:
virtual float Score() override
public:
virtual float Score() override
See Also
ConstantScoreQuery ConstantScorer Class
ConstantScoreQuery ConstantScorer Members
Score Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConstantScoreQuery.ConstantScorer Properties

ConstantScoreQuery ConstantScorer Properties Lucene.Net Class Library
The ConstantScoreQuery ConstantScorer type exposes the following members.
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Similarity | Returns the Similarity implementation used by this scorer. (Inherited from Scorer.)
Back to Top
See Also
ConstantScoreQuery ConstantScorer Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Enclosing_Instance Property

ConstantScoreQuery ConstantScorer Enclosing_Instance Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConstantScoreQuery Enclosing_Instance { get; }
public ConstantScoreQuery Enclosing_Instance { get; }
Public ReadOnly Property Enclosing_Instance As ConstantScoreQuery
    Get
Public ReadOnly Property Enclosing_Instance As ConstantScoreQuery
    Get
public:
property ConstantScoreQuery^ Enclosing_Instance {
    ConstantScoreQuery^ get ();
}
public:
property ConstantScoreQuery^ Enclosing_Instance {
    ConstantScoreQuery^ get ();
}
See Also
ConstantScoreQuery ConstantScorer Class
ConstantScoreQuery ConstantScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConstantScoreQuery.ConstantWeight Class

ConstantScoreQuery ConstantWeight Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Weight
Lucene.Net.Search ConstantScoreQuery ConstantWeight

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
protected internal class ConstantWeight : Weight
[SerializableAttribute]
protected internal class ConstantWeight : Weight
<SerializableAttribute> _
Protected Friend Class ConstantWeight _
    Inherits Weight
<SerializableAttribute> _
Protected Friend Class ConstantWeight _
    Inherits Weight
[SerializableAttribute]
protected public ref class ConstantWeight : public Weight
[SerializableAttribute]
protected public ref class ConstantWeight : public Weight
See Also
ConstantScoreQuery ConstantWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConstantScoreQuery.ConstantWeight Members

ConstantScoreQuery ConstantWeight Members Lucene.Net Class Library

A query that wraps a filter and simply returns a constant score equal to the query boost for every document in the filter.

The ConstantScoreQuery ConstantWeight type exposes the following members.
Constructors
 | Name | Description
Public method | ConstantScoreQuery ConstantWeight | Initializes a new instance of the ConstantScoreQuery ConstantWeight class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | (Overrides Weight Explain(IndexReader, Int32).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetScoresDocsOutOfOrder | Returns true iff this implementation scores docs only out of order. This method is used in conjunction with Collector's AcceptsDocsOutOfOrder and Scorer(IndexReader, Boolean, Boolean) to create a matching Scorer(IndexReader, Boolean, Boolean) instance for a given Collector, or vice versa. NOTE: the default implementation returns false, i.e. the Scorer scores documents in-order. (Inherited from Weight.)
Public method | GetSumOfSquaredWeights | (Overrides Weight GetSumOfSquaredWeights .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Normalize | (Overrides Weight Normalize(Single).)
Public method | Scorer | (Overrides Weight Scorer(IndexReader, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Query | (Overrides Weight Query.)
Public property | Value | (Overrides Weight Value.)
Back to Top
See Also
ConstantScoreQuery ConstantWeight Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConstantScoreQuery.ConstantWeight Constructor

ConstantScoreQuery ConstantWeight Constructor Lucene.Net Class Library
Initializes a new instance of the ConstantScoreQuery ConstantWeight class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConstantWeight(
    ConstantScoreQuery enclosingInstance,
    Searcher searcher
)
public ConstantWeight(
    ConstantScoreQuery enclosingInstance,
    Searcher searcher
)
Public Sub New ( _
    enclosingInstance As ConstantScoreQuery, _
    searcher As Searcher _
)
Public Sub New ( _
    enclosingInstance As ConstantScoreQuery, _
    searcher As Searcher _
)
public:
ConstantWeight(
    ConstantScoreQuery^ enclosingInstance,
    Searcher^ searcher
)
public:
ConstantWeight(
    ConstantScoreQuery^ enclosingInstance,
    Searcher^ searcher
)
Parameters
enclosingInstance
Type: Lucene.Net.Search ConstantScoreQuery
searcher
Type: Lucene.Net.Search Searcher
See Also
ConstantScoreQuery ConstantWeight Class
ConstantScoreQuery ConstantWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConstantScoreQuery.ConstantWeight Methods

ConstantScoreQuery ConstantWeight Methods Lucene.Net Class Library
The ConstantScoreQuery ConstantWeight type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | (Overrides Weight Explain(IndexReader, Int32).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetScoresDocsOutOfOrder | Returns true iff this implementation scores docs only out of order. This method is used in conjunction with Collector's AcceptsDocsOutOfOrder and Scorer(IndexReader, Boolean, Boolean) to create a matching Scorer(IndexReader, Boolean, Boolean) instance for a given Collector, or vice versa. NOTE: the default implementation returns false, i.e. the Scorer scores documents in-order. (Inherited from Weight.)
Public method | GetSumOfSquaredWeights | (Overrides Weight GetSumOfSquaredWeights .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Normalize | (Overrides Weight Normalize(Single).)
Public method | Scorer | (Overrides Weight Scorer(IndexReader, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ConstantScoreQuery ConstantWeight Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method

ConstantScoreQuery ConstantWeight Explain Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Explanation Explain(
    IndexReader reader,
    int doc
)
public override Explanation Explain(
    IndexReader reader,
    int doc
)
Public Overrides Function Explain ( _
    reader As IndexReader, _
    doc As Integer _
) As Explanation
Public Overrides Function Explain ( _
    reader As IndexReader, _
    doc As Integer _
) As Explanation
public:
virtual Explanation^ Explain(
    IndexReader^ reader,
    int doc
) override
public:
virtual Explanation^ Explain(
    IndexReader^ reader,
    int doc
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
doc
Type:   Online System Int32
See Also
ConstantScoreQuery ConstantWeight Class
ConstantScoreQuery ConstantWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSumOfSquaredWeights Method

ConstantScoreQuery ConstantWeight GetSumOfSquaredWeights Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float GetSumOfSquaredWeights()
public override float GetSumOfSquaredWeights()
Public Overrides Function GetSumOfSquaredWeights As Single
Public Overrides Function GetSumOfSquaredWeights As Single
public:
virtual float GetSumOfSquaredWeights() override
public:
virtual float GetSumOfSquaredWeights() override
See Also
ConstantScoreQuery ConstantWeight Class
ConstantScoreQuery ConstantWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Normalize Method

ConstantScoreQuery ConstantWeight Normalize Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Normalize(
    float norm
)
public override void Normalize(
    float norm
)
Public Overrides Sub Normalize ( _
    norm As Single _
)
Public Overrides Sub Normalize ( _
    norm As Single _
)
public:
virtual void Normalize(
    float norm
) override
public:
virtual void Normalize(
    float norm
) override
Parameters
norm
Type:   Online System Single
See Also
ConstantScoreQuery ConstantWeight Class
ConstantScoreQuery ConstantWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Scorer Method

ConstantScoreQuery ConstantWeight Scorer Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
scoreDocsInOrder
Type:   Online System Boolean
topScorer
Type:   Online System Boolean
See Also
ConstantScoreQuery ConstantWeight Class
ConstantScoreQuery ConstantWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ConstantScoreQuery.ConstantWeight Properties

ConstantScoreQuery ConstantWeight Properties Lucene.Net Class Library
The ConstantScoreQuery ConstantWeight type exposes the following members.
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Query | (Overrides Weight Query.)
Public property | Value | (Overrides Weight Value.)
Back to Top
See Also
ConstantScoreQuery ConstantWeight Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Enclosing_Instance Property

ConstantScoreQuery ConstantWeight Enclosing_Instance Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConstantScoreQuery Enclosing_Instance { get; }
public ConstantScoreQuery Enclosing_Instance { get; }
Public ReadOnly Property Enclosing_Instance As ConstantScoreQuery
    Get
Public ReadOnly Property Enclosing_Instance As ConstantScoreQuery
    Get
public:
property ConstantScoreQuery^ Enclosing_Instance {
    ConstantScoreQuery^ get ();
}
public:
property ConstantScoreQuery^ Enclosing_Instance {
    ConstantScoreQuery^ get ();
}
See Also
ConstantScoreQuery ConstantWeight Class
ConstantScoreQuery ConstantWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Query Property

ConstantScoreQuery ConstantWeight Query Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Query { get; }
public override Query Query { get; }
Public Overrides ReadOnly Property Query As Query
    Get
Public Overrides ReadOnly Property Query As Query
    Get
public:
virtual property Query^ Query {
    Query^ get () override;
}
public:
virtual property Query^ Query {
    Query^ get () override;
}
See Also
ConstantScoreQuery ConstantWeight Class
ConstantScoreQuery ConstantWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Value Property

ConstantScoreQuery ConstantWeight Value Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Value { get; }
public override float Value { get; }
Public Overrides ReadOnly Property Value As Single
    Get
Public Overrides ReadOnly Property Value As Single
    Get
public:
virtual property float Value {
    float get () override;
}
public:
virtual property float Value {
    float get () override;
}
See Also
ConstantScoreQuery ConstantWeight Class
ConstantScoreQuery ConstantWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreationPlaceholder Class

CreationPlaceholder Class Lucene.Net Class Library
Expert: Maintains caches of term values.

Created: May 19, 2004 11:13:14 AM
Inheritance Hierarchy
Online System Object
Lucene.Net.Search CreationPlaceholder

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CreationPlaceholder
public sealed class CreationPlaceholder
Public NotInheritable Class CreationPlaceholder
Public NotInheritable Class CreationPlaceholder
public ref class CreationPlaceholder sealed
public ref class CreationPlaceholder sealed
See Also
CreationPlaceholder Members
Lucene.Net.Search Namespace
Lucene.Net.Util FieldCacheSanityChecker
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreationPlaceholder Members

CreationPlaceholder Members Lucene.Net Class Library

The CreationPlaceholder type exposes the following members.
Constructors
 | Name | Description
Public method | CreationPlaceholder | Initializes a new instance of the CreationPlaceholder class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CreationPlaceholder Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreationPlaceholder Constructor

CreationPlaceholder Constructor Lucene.Net Class Library
Initializes a new instance of the CreationPlaceholder class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CreationPlaceholder()
public CreationPlaceholder()
Public Sub New
Public Sub New
public:
CreationPlaceholder()
public:
CreationPlaceholder()
See Also
CreationPlaceholder Class
CreationPlaceholder Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreationPlaceholder Methods

CreationPlaceholder Methods Lucene.Net Class Library
The CreationPlaceholder type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CreationPlaceholder Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DefaultSimilarity Class

DefaultSimilarity Class Lucene.Net Class Library
Expert: Default scoring implementation.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Similarity
Lucene.Net.Search DefaultSimilarity

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class DefaultSimilarity : Similarity
[SerializableAttribute]
public class DefaultSimilarity : Similarity
<SerializableAttribute> _
Public Class DefaultSimilarity _
    Inherits Similarity
<SerializableAttribute> _
Public Class DefaultSimilarity _
    Inherits Similarity
[SerializableAttribute]
public ref class DefaultSimilarity : public Similarity
[SerializableAttribute]
public ref class DefaultSimilarity : public Similarity
See Also
DefaultSimilarity Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DefaultSimilarity Members

DefaultSimilarity Members Lucene.Net Class Library

The DefaultSimilarity type exposes the following members.
Constructors
 | Name | Description
Public method | DefaultSimilarity | Initializes a new instance of the DefaultSimilarity class
Back to Top
Methods
Name Description
Public method ComputeNorm
Implemented as state.getBoost()*lengthNorm(numTerms), where numTerms is Length if DiscountOverlaps is false, else it's Length - NumOverlap .

WARNING: This API is new and experimental, and may suddenly change.

(Overrides Similarity ComputeNorm(String, FieldInvertState).)
Public method Coord
Implemented as overlap / maxOverlap.
(Overrides Similarity Coord(Int32, Int32).)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method Idf
Implemented as log(numDocs/(docFreq+1)) + 1.
(Overrides Similarity Idf(Int32, Int32).)
Public method IdfExplain(Term, Searcher)
Computes a score factor for a simple term and returns an explanation for that score factor.

The default implementation uses:
View Colorized Copy to Clipboard Print
idf(searcher.docFreq(term), searcher.MaxDoc);
idf(searcher.docFreq(term), searcher.MaxDoc);
Note that MaxDoc is used instead of NumDocs because it is proportional to DocFreq(Term) , i.e., when one is inaccurate, so is the other, and in the same direction.
(Inherited from Similarity.)
Public method IdfExplain(ICollection Term , Searcher)
Computes a score factor for a phrase.

The default implementation sums the idf factor for each term in the phrase.
(Inherited from Similarity.)
Public method LengthNorm
Implemented as 1/sqrt(numTerms).
(Overrides Similarity LengthNorm(String, Int32).)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method QueryNorm
Implemented as 1/sqrt(sumOfSquaredWeights).
(Overrides Similarity QueryNorm(Single).)
Public method ScorePayload
Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array.

The default implementation returns 1.
(Inherited from Similarity.)
Public method SloppyFreq
Implemented as 1 / (distance + 1).
(Overrides Similarity SloppyFreq(Int32).)
Public method Tf(Single)
Implemented as sqrt(freq).
(Overrides Similarity Tf(Single).)
Public method Tf(Int32)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the Idf(Int32, Int32) factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when freq is large, and smaller values when freq is small.

The default implementation calls Tf(Single).
(Inherited from Similarity.)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | internalDiscountOverlaps |
Back to Top
Properties
 | Name | Description
Public property | DiscountOverlaps | Determines whether overlap tokens (Tokens with 0 position increment) are ignored when computing norm. By default this is false, meaning overlap tokens are counted just like non-overlap tokens. WARNING: This API is new and experimental, and may suddenly change.
Back to Top
See Also
DefaultSimilarity Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DefaultSimilarity Constructor

DefaultSimilarity Constructor Lucene.Net Class Library
Initializes a new instance of the DefaultSimilarity class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DefaultSimilarity()
public DefaultSimilarity()
Public Sub New
Public Sub New
public:
DefaultSimilarity()
public:
DefaultSimilarity()
See Also
DefaultSimilarity Class
DefaultSimilarity Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DefaultSimilarity Fields

DefaultSimilarity Fields Lucene.Net Class Library
The DefaultSimilarity type exposes the following members.
Fields
 | Name | Description
Protected field | internalDiscountOverlaps |
Back to Top
See Also
DefaultSimilarity Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalDiscountOverlaps Field

DefaultSimilarity internalDiscountOverlaps Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool internalDiscountOverlaps
protected bool internalDiscountOverlaps
Protected internalDiscountOverlaps As Boolean
Protected internalDiscountOverlaps As Boolean
protected:
bool internalDiscountOverlaps
protected:
bool internalDiscountOverlaps
See Also
DefaultSimilarity Class
DefaultSimilarity Members
Lucene.Net.Search Namespace
DefaultSimilarity DiscountOverlaps
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DefaultSimilarity Methods

DefaultSimilarity Methods Lucene.Net Class Library
The DefaultSimilarity type exposes the following members.
Methods
Name Description
Public method ComputeNorm
Implemented as state.getBoost()*lengthNorm(numTerms), where numTerms is Length if DiscountOverlaps is false, else it's Length - NumOverlap .

WARNING: This API is new and experimental, and may suddenly change.

(Overrides Similarity ComputeNorm(String, FieldInvertState).)
Public method Coord
Implemented as overlap / maxOverlap.
(Overrides Similarity Coord(Int32, Int32).)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method Idf
Implemented as log(numDocs/(docFreq+1)) + 1.
(Overrides Similarity Idf(Int32, Int32).)
Public method IdfExplain(Term, Searcher)
Computes a score factor for a simple term and returns an explanation for that score factor.

The default implementation uses:
View Colorized Copy to Clipboard Print
idf(searcher.docFreq(term), searcher.MaxDoc);
idf(searcher.docFreq(term), searcher.MaxDoc);
Note that MaxDoc is used instead of NumDocs because it is proportional to DocFreq(Term) , i.e., when one is inaccurate, so is the other, and in the same direction.
(Inherited from Similarity.)
Public method IdfExplain(ICollection Term , Searcher)
Computes a score factor for a phrase.

The default implementation sums the idf factor for each term in the phrase.
(Inherited from Similarity.)
Public method LengthNorm
Implemented as 1/sqrt(numTerms).
(Overrides Similarity LengthNorm(String, Int32).)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method QueryNorm
Implemented as 1/sqrt(sumOfSquaredWeights).
(Overrides Similarity QueryNorm(Single).)
Public method ScorePayload
Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array.

The default implementation returns 1.
(Inherited from Similarity.)
Public method SloppyFreq
Implemented as 1 / (distance + 1).
(Overrides Similarity SloppyFreq(Int32).)
Public method Tf(Single)
Implemented as sqrt(freq).
(Overrides Similarity Tf(Single).)
Public method Tf(Int32)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the Idf(Int32, Int32) factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when freq is large, and smaller values when freq is small.

The default implementation calls Tf(Single).
(Inherited from Similarity.)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
See Also
DefaultSimilarity Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ComputeNorm Method

DefaultSimilarity ComputeNorm Method Lucene.Net Class Library
Implemented as state.getBoost()*lengthNorm(numTerms), where numTerms is Length if DiscountOverlaps is false, else it's Length - NumOverlap .

WARNING: This API is new and experimental, and may suddenly change.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float ComputeNorm(
    string field,
    FieldInvertState state
)
public override float ComputeNorm(
    string field,
    FieldInvertState state
)
Public Overrides Function ComputeNorm ( _
    field As String, _
    state As FieldInvertState _
) As Single
Public Overrides Function ComputeNorm ( _
    field As String, _
    state As FieldInvertState _
) As Single
public:
virtual float ComputeNorm(
    String^ field,
    FieldInvertState^ state
) override
public:
virtual float ComputeNorm(
    String^ field,
    FieldInvertState^ state
) override
Parameters
field
Type:   Online System String
state
Type: Lucene.Net.Index FieldInvertState
See Also
DefaultSimilarity Class
DefaultSimilarity Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Coord Method

DefaultSimilarity Coord Method Lucene.Net Class Library
Implemented as overlap / maxOverlap.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Coord(
    int overlap,
    int maxOverlap
)
public override float Coord(
    int overlap,
    int maxOverlap
)
Public Overrides Function Coord ( _
    overlap As Integer, _
    maxOverlap As Integer _
) As Single
Public Overrides Function Coord ( _
    overlap As Integer, _
    maxOverlap As Integer _
) As Single
public:
virtual float Coord(
    int overlap,
    int maxOverlap
) override
public:
virtual float Coord(
    int overlap,
    int maxOverlap
) override
Parameters
overlap
Type:   Online System Int32
maxOverlap
Type:   Online System Int32
See Also
DefaultSimilarity Class
DefaultSimilarity Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Idf Method

DefaultSimilarity Idf Method Lucene.Net Class Library
Implemented as log(numDocs/(docFreq+1)) + 1.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Idf(
    int docFreq,
    int numDocs
)
public override float Idf(
    int docFreq,
    int numDocs
)
Public Overrides Function Idf ( _
    docFreq As Integer, _
    numDocs As Integer _
) As Single
Public Overrides Function Idf ( _
    docFreq As Integer, _
    numDocs As Integer _
) As Single
public:
virtual float Idf(
    int docFreq,
    int numDocs
) override
public:
virtual float Idf(
    int docFreq,
    int numDocs
) override
Parameters
docFreq
Type:   Online System Int32
numDocs
Type:   Online System Int32
See Also
DefaultSimilarity Class
DefaultSimilarity Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LengthNorm Method

DefaultSimilarity LengthNorm Method Lucene.Net Class Library
Implemented as 1/sqrt(numTerms).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float LengthNorm(
    string fieldName,
    int numTerms
)
public override float LengthNorm(
    string fieldName,
    int numTerms
)
Public Overrides Function LengthNorm ( _
    fieldName As String, _
    numTerms As Integer _
) As Single
Public Overrides Function LengthNorm ( _
    fieldName As String, _
    numTerms As Integer _
) As Single
public:
virtual float LengthNorm(
    String^ fieldName,
    int numTerms
) override
public:
virtual float LengthNorm(
    String^ fieldName,
    int numTerms
) override
Parameters
fieldName
Type:   Online System String
numTerms
Type:   Online System Int32
See Also
DefaultSimilarity Class
DefaultSimilarity Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryNorm Method

DefaultSimilarity QueryNorm Method Lucene.Net Class Library
Implemented as 1/sqrt(sumOfSquaredWeights).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float QueryNorm(
    float sumOfSquaredWeights
)
public override float QueryNorm(
    float sumOfSquaredWeights
)
Public Overrides Function QueryNorm ( _
    sumOfSquaredWeights As Single _
) As Single
Public Overrides Function QueryNorm ( _
    sumOfSquaredWeights As Single _
) As Single
public:
virtual float QueryNorm(
    float sumOfSquaredWeights
) override
public:
virtual float QueryNorm(
    float sumOfSquaredWeights
) override
Parameters
sumOfSquaredWeights
Type:   Online System Single
See Also
DefaultSimilarity Class
DefaultSimilarity Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SloppyFreq Method

DefaultSimilarity SloppyFreq Method Lucene.Net Class Library
Implemented as 1 / (distance + 1).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float SloppyFreq(
    int distance
)
public override float SloppyFreq(
    int distance
)
Public Overrides Function SloppyFreq ( _
    distance As Integer _
) As Single
Public Overrides Function SloppyFreq ( _
    distance As Integer _
) As Single
public:
virtual float SloppyFreq(
    int distance
) override
public:
virtual float SloppyFreq(
    int distance
) override
Parameters
distance
Type:   Online System Int32
See Also
DefaultSimilarity Class
DefaultSimilarity Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tf Method

DefaultSimilarity Tf Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Tf(Single) | Implemented as sqrt(freq). (Overrides Similarity Tf(Single).)
Public method | Tf(Int32) | Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the Idf(Int32, Int32) factor for each term in the query and these products are then summed to form the initial score for a document. Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when freq is large, and smaller values when freq is small. The default implementation calls Tf(Single). (Inherited from Similarity.)
Back to Top
See Also
DefaultSimilarity Class
DefaultSimilarity Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tf Method (Single)

DefaultSimilarity Tf Method (Single) Lucene.Net Class Library
Implemented as sqrt(freq).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Tf(
    float freq
)
public override float Tf(
    float freq
)
Public Overrides Function Tf ( _
    freq As Single _
) As Single
Public Overrides Function Tf ( _
    freq As Single _
) As Single
public:
virtual float Tf(
    float freq
) override
public:
virtual float Tf(
    float freq
) override
Parameters
freq
Type:   Online System Single
See Also
DefaultSimilarity Class
DefaultSimilarity Members
Tf Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DefaultSimilarity Properties

DefaultSimilarity Properties Lucene.Net Class Library
The DefaultSimilarity type exposes the following members.
Properties
 | Name | Description
Public property | DiscountOverlaps | Determines whether overlap tokens (Tokens with 0 position increment) are ignored when computing norm. By default this is false, meaning overlap tokens are counted just like non-overlap tokens. WARNING: This API is new and experimental, and may suddenly change.
Back to Top
See Also
DefaultSimilarity Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DiscountOverlaps Property

DefaultSimilarity DiscountOverlaps Property Lucene.Net Class Library
Determines whether overlap tokens (Tokens with 0 position increment) are ignored when computing norm. By default this is false, meaning overlap tokens are counted just like non-overlap tokens.

WARNING: This API is new and experimental, and may suddenly change.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool DiscountOverlaps { get; set; }
public virtual bool DiscountOverlaps { get; set; }
Public Overridable Property DiscountOverlaps As Boolean
    Get
    Set
Public Overridable Property DiscountOverlaps As Boolean
    Get
    Set
public:
virtual property bool DiscountOverlaps {
    bool get ();
    void set (bool value);
}
public:
virtual property bool DiscountOverlaps {
    bool get ();
    void set (bool value);
}
See Also
DefaultSimilarity Class
DefaultSimilarity Members
Lucene.Net.Search Namespace
DefaultSimilarity ComputeNorm(String, FieldInvertState)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DisjunctionMaxQuery Class

DisjunctionMaxQuery Class Lucene.Net Class Library
A query that generates the union of documents produced by its subqueries, and that scores each document with the maximum score for that document as produced by any subquery, plus a tie breaking increment for any additional matching subqueries. This is useful when searching for a word in multiple fields with different boost factors (so that the fields cannot be combined equivalently into a single search field). We want the primary score to be the one associated with the highest boost, not the sum of the field scores (as BooleanQuery would give). If the query is "albino elephant" this ensures that "albino" matching one field and "elephant" matching another gets a higher score than "albino" matching both fields. To get this result, use both BooleanQuery and DisjunctionMaxQuery: for each term a DisjunctionMaxQuery searches for it in each field, while the set of these DisjunctionMaxQuery's is combined into a BooleanQuery. The tie breaker capability allows results that include the same term in multiple fields to be judged better than results that include this term in only the best of those multiple fields, without confusing this with the better case of two different terms in the multiple fields.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search DisjunctionMaxQuery

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class DisjunctionMaxQuery : Query,
    IEnumerable<Query>, IEnumerable, ICloneable
[SerializableAttribute]
public class DisjunctionMaxQuery : Query,
    IEnumerable<Query>, IEnumerable, ICloneable
<SerializableAttribute> _
Public Class DisjunctionMaxQuery _
    Inherits Query _
    Implements IEnumerable(Of Query), IEnumerable,  _
    ICloneable
<SerializableAttribute> _
Public Class DisjunctionMaxQuery _
    Inherits Query _
    Implements IEnumerable(Of Query), IEnumerable,  _
    ICloneable
[SerializableAttribute]
public ref class DisjunctionMaxQuery : public Query,
    IEnumerable<Query^>, IEnumerable, ICloneable
[SerializableAttribute]
public ref class DisjunctionMaxQuery : public Query,
    IEnumerable<Query^>, IEnumerable, ICloneable
See Also
DisjunctionMaxQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DisjunctionMaxQuery Members

DisjunctionMaxQuery Members Lucene.Net Class Library

The DisjunctionMaxQuery type exposes the following members.
Constructors
 | Name | Description
Public method | DisjunctionMaxQuery(Single) | Creates a new empty DisjunctionMaxQuery. Use add() to add the subqueries.
Public method | DisjunctionMaxQuery(ICollection Query , Single) | Creates a new DisjunctionMaxQuery
Back to Top
Methods
 | Name | Description
Public method | Add(Query) | Add a subquery to this disjunction
Public method | Add(ICollection Query ) | Add a collection of disjuncts to this disjunction via Iterable
Public method | Clone | Create a shallow copy of us -- used in rewriting if necessary (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | Return true iff we represent the same query as o (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | An Iterator<Query> over the disjuncts
Public method | GetHashCode | Compute a hash code for hashing us (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | Optimize our representation and our subqueries representations (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prettyprint us. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | Returns an enumerator that iterates through a collection.
Back to Top
See Also
DisjunctionMaxQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DisjunctionMaxQuery Constructor

DisjunctionMaxQuery Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | DisjunctionMaxQuery(Single) | Creates a new empty DisjunctionMaxQuery. Use add() to add the subqueries.
Public method | DisjunctionMaxQuery(ICollection Query , Single) | Creates a new DisjunctionMaxQuery
Back to Top
See Also
DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DisjunctionMaxQuery Constructor (Single)

DisjunctionMaxQuery Constructor (Single) Lucene.Net Class Library
Creates a new empty DisjunctionMaxQuery. Use add() to add the subqueries.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DisjunctionMaxQuery(
    float tieBreakerMultiplier
)
public DisjunctionMaxQuery(
    float tieBreakerMultiplier
)
Public Sub New ( _
    tieBreakerMultiplier As Single _
)
Public Sub New ( _
    tieBreakerMultiplier As Single _
)
public:
DisjunctionMaxQuery(
    float tieBreakerMultiplier
)
public:
DisjunctionMaxQuery(
    float tieBreakerMultiplier
)
Parameters
tieBreakerMultiplier
Type:   Online System Single
the score of each non-maximum disjunct for a document is multiplied by this weight
            and added into the final score.  If non-zero, the value should be small, on the order of 0.1, which says that
            10 occurrences of word in a lower-scored field that is also in a higher scored field is just as good as a unique
            word in the lower scored field (i.e., one that is not in any higher scored field.

See Also
DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
DisjunctionMaxQuery Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DisjunctionMaxQuery Constructor (ICollection(Query), Single)

DisjunctionMaxQuery Constructor (ICollection Query , Single) Lucene.Net Class Library
Creates a new DisjunctionMaxQuery

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DisjunctionMaxQuery(
    ICollection<Query> disjuncts,
    float tieBreakerMultiplier
)
public DisjunctionMaxQuery(
    ICollection<Query> disjuncts,
    float tieBreakerMultiplier
)
Public Sub New ( _
    disjuncts As ICollection(Of Query), _
    tieBreakerMultiplier As Single _
)
Public Sub New ( _
    disjuncts As ICollection(Of Query), _
    tieBreakerMultiplier As Single _
)
public:
DisjunctionMaxQuery(
    ICollection<Query^>^ disjuncts,
    float tieBreakerMultiplier
)
public:
DisjunctionMaxQuery(
    ICollection<Query^>^ disjuncts,
    float tieBreakerMultiplier
)
Parameters
disjuncts
Type:   Online System.Collections.Generic ICollection  Query
a Collection<Query> of all the disjuncts to add

tieBreakerMultiplier
Type:   Online System Single
  the weight to give to each matching non-maximum disjunct

See Also
DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
DisjunctionMaxQuery Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DisjunctionMaxQuery Methods

DisjunctionMaxQuery Methods Lucene.Net Class Library
The DisjunctionMaxQuery type exposes the following members.
Methods
 | Name | Description
Public method | Add(Query) | Add a subquery to this disjunction
Public method | Add(ICollection Query ) | Add a collection of disjuncts to this disjunction via Iterable
Public method | Clone | Create a shallow copy of us -- used in rewriting if necessary (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | Return true iff we represent the same query as o (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | An Iterator<Query> over the disjuncts
Public method | GetHashCode | Compute a hash code for hashing us (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | Optimize our representation and our subqueries representations (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prettyprint us. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | Returns an enumerator that iterates through a collection.
Back to Top
See Also
DisjunctionMaxQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IEnumerable.GetEnumerator Method

DisjunctionMaxQuery IEnumerable GetEnumerator Method Lucene.Net Class Library
Returns an enumerator that iterates through a collection.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
Return Value
An   Online IEnumerator object that can be used to iterate through the collection.
Implements
  Online IEnumerable GetEnumerator
See Also
DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method

DisjunctionMaxQuery Add Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Add(Query) | Add a subquery to this disjunction
Public method | Add(ICollection Query ) | Add a collection of disjuncts to this disjunction via Iterable
Back to Top
See Also
DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (Query)

DisjunctionMaxQuery Add Method (Query) Lucene.Net Class Library
Add a subquery to this disjunction

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Add(
    Query query
)
public virtual void Add(
    Query query
)
Public Overridable Sub Add ( _
    query As Query _
)
Public Overridable Sub Add ( _
    query As Query _
)
public:
virtual void Add(
    Query^ query
)
public:
virtual void Add(
    Query^ query
)
Parameters
query
Type: Lucene.Net.Search Query
the disjunct added

See Also
DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
Add Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (ICollection(Query))

DisjunctionMaxQuery Add Method (ICollection Query ) Lucene.Net Class Library
Add a collection of disjuncts to this disjunction via Iterable

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Add(
    ICollection<Query> disjuncts
)
public virtual void Add(
    ICollection<Query> disjuncts
)
Public Overridable Sub Add ( _
    disjuncts As ICollection(Of Query) _
)
Public Overridable Sub Add ( _
    disjuncts As ICollection(Of Query) _
)
public:
virtual void Add(
    ICollection<Query^>^ disjuncts
)
public:
virtual void Add(
    ICollection<Query^>^ disjuncts
)
Parameters
disjuncts
Type:   Online System.Collections.Generic ICollection  Query
See Also
DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
Add Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

DisjunctionMaxQuery Clone Method Lucene.Net Class Library
Create a shallow copy of us -- used in rewriting if necessary

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Return Value
 a copy of us (but reuse, don't copy, our subqueries)

Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateWeight Method

DisjunctionMaxQuery CreateWeight Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Weight CreateWeight(
    Searcher searcher
)
public override Weight CreateWeight(
    Searcher searcher
)
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

DisjunctionMaxQuery Equals Method Lucene.Net Class Library
Return true iff we represent the same query as o

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
another object

Return Value
 true iff o is a DisjunctionMaxQuery with the same boost and the same subqueries, in the same order, as us

See Also
DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExtractTerms Method

DisjunctionMaxQuery ExtractTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ExtractTerms(
    ISet<Term> terms
)
public override void ExtractTerms(
    ISet<Term> terms
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
Parameters
terms
Type:   Online System.Collections.Generic ISet  Term
See Also
DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetEnumerator Method

DisjunctionMaxQuery GetEnumerator Method Lucene.Net Class Library
An Iterator<Query> over the disjuncts

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerator<Query> GetEnumerator()
public virtual IEnumerator<Query> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of Query)
Public Overridable Function GetEnumerator As IEnumerator(Of Query)
public:
virtual IEnumerator<Query^>^ GetEnumerator()
public:
virtual IEnumerator<Query^>^ GetEnumerator()
Implements
  Online IEnumerable T  GetEnumerator
See Also
DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

DisjunctionMaxQuery GetHashCode Method Lucene.Net Class Library
Compute a hash code for hashing us

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
Return Value
 the hash code

See Also
DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

DisjunctionMaxQuery Rewrite Method Lucene.Net Class Library
Optimize our representation and our subqueries representations

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    IndexReader reader
)
public override Query Rewrite(
    IndexReader reader
)
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
the IndexReader we query

Return Value
 an optimized copy of us (which may not be a copy if there is nothing to optimize)

See Also
DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

DisjunctionMaxQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prettyprint us. (Overrides Query ToString(String).)
Back to Top
See Also
DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

DisjunctionMaxQuery ToString Method (String) Lucene.Net Class Library
Prettyprint us.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
the field to which we are applied

Return Value
 a string that shows what we do, of the form "(disjunct1 | disjunct2 | ... | disjunctn)^boost"

See Also
DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
ToString Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DisjunctionMaxQuery Properties

DisjunctionMaxQuery Properties Lucene.Net Class Library
The DisjunctionMaxQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Back to Top
See Also
DisjunctionMaxQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DisjunctionMaxQuery.DisjunctionMaxWeight Class

DisjunctionMaxQuery DisjunctionMaxWeight Class Lucene.Net Class Library
Expert: the Weight for DisjunctionMaxQuery, used to normalize, score and explain these queries.

NOTE: this API and implementation is subject to change suddenly in the next release.

Inheritance Hierarchy
Online System Object
Lucene.Net.Search Weight
Lucene.Net.Search DisjunctionMaxQuery DisjunctionMaxWeight

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
protected internal class DisjunctionMaxWeight : Weight
[SerializableAttribute]
protected internal class DisjunctionMaxWeight : Weight
<SerializableAttribute> _
Protected Friend Class DisjunctionMaxWeight _
    Inherits Weight
<SerializableAttribute> _
Protected Friend Class DisjunctionMaxWeight _
    Inherits Weight
[SerializableAttribute]
protected public ref class DisjunctionMaxWeight : public Weight
[SerializableAttribute]
protected public ref class DisjunctionMaxWeight : public Weight
See Also
DisjunctionMaxQuery DisjunctionMaxWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DisjunctionMaxQuery.DisjunctionMaxWeight Members

DisjunctionMaxQuery DisjunctionMaxWeight Members Lucene.Net Class Library

A query that generates the union of documents produced by its subqueries, and that scores each document with the maximum score for that document as produced by any subquery, plus a tie breaking increment for any additional matching subqueries. This is useful when searching for a word in multiple fields with different boost factors (so that the fields cannot be combined equivalently into a single search field). We want the primary score to be the one associated with the highest boost, not the sum of the field scores (as BooleanQuery would give). If the query is "albino elephant" this ensures that "albino" matching one field and "elephant" matching another gets a higher score than "albino" matching both fields. To get this result, use both BooleanQuery and DisjunctionMaxQuery: for each term a DisjunctionMaxQuery searches for it in each field, while the set of these DisjunctionMaxQuery's is combined into a BooleanQuery. The tie breaker capability allows results that include the same term in multiple fields to be judged better than results that include this term in only the best of those multiple fields, without confusing this with the better case of two different terms in the multiple fields.

The DisjunctionMaxQuery DisjunctionMaxWeight type exposes the following members.
Constructors
 | Name | Description
Public method | DisjunctionMaxQuery DisjunctionMaxWeight | Initializes a new instance of the DisjunctionMaxQuery DisjunctionMaxWeight class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | (Overrides Weight Explain(IndexReader, Int32).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetScoresDocsOutOfOrder | Returns true iff this implementation scores docs only out of order. This method is used in conjunction with Collector's AcceptsDocsOutOfOrder and Scorer(IndexReader, Boolean, Boolean) to create a matching Scorer(IndexReader, Boolean, Boolean) instance for a given Collector, or vice versa. NOTE: the default implementation returns false, i.e. the Scorer scores documents in-order. (Inherited from Weight.)
Public method | GetSumOfSquaredWeights | (Overrides Weight GetSumOfSquaredWeights .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Normalize | (Overrides Weight Normalize(Single).)
Public method | Scorer | (Overrides Weight Scorer(IndexReader, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | similarity | The Similarity implementation.
Protected field | weights | The Weights for our subqueries, in 1-1 correspondence with disjuncts
Back to Top
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Query | (Overrides Weight Query.)
Public property | Value | (Overrides Weight Value.)
Back to Top
See Also
DisjunctionMaxQuery DisjunctionMaxWeight Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DisjunctionMaxQuery.DisjunctionMaxWeight Constructor

DisjunctionMaxQuery DisjunctionMaxWeight Constructor Lucene.Net Class Library
Initializes a new instance of the DisjunctionMaxQuery DisjunctionMaxWeight class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DisjunctionMaxWeight(
    DisjunctionMaxQuery enclosingInstance,
    Searcher searcher
)
public DisjunctionMaxWeight(
    DisjunctionMaxQuery enclosingInstance,
    Searcher searcher
)
Public Sub New ( _
    enclosingInstance As DisjunctionMaxQuery, _
    searcher As Searcher _
)
Public Sub New ( _
    enclosingInstance As DisjunctionMaxQuery, _
    searcher As Searcher _
)
public:
DisjunctionMaxWeight(
    DisjunctionMaxQuery^ enclosingInstance,
    Searcher^ searcher
)
public:
DisjunctionMaxWeight(
    DisjunctionMaxQuery^ enclosingInstance,
    Searcher^ searcher
)
Parameters
enclosingInstance
Type: Lucene.Net.Search DisjunctionMaxQuery
searcher
Type: Lucene.Net.Search Searcher
See Also
DisjunctionMaxQuery DisjunctionMaxWeight Class
DisjunctionMaxQuery DisjunctionMaxWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DisjunctionMaxQuery.DisjunctionMaxWeight Fields

DisjunctionMaxQuery DisjunctionMaxWeight Fields Lucene.Net Class Library
The DisjunctionMaxQuery DisjunctionMaxWeight type exposes the following members.
Fields
 | Name | Description
Protected field | similarity | The Similarity implementation.
Protected field | weights | The Weights for our subqueries, in 1-1 correspondence with disjuncts
Back to Top
See Also
DisjunctionMaxQuery DisjunctionMaxWeight Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


similarity Field

DisjunctionMaxQuery DisjunctionMaxWeight similarity Field Lucene.Net Class Library
The Similarity implementation.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Similarity similarity
protected Similarity similarity
Protected similarity As Similarity
Protected similarity As Similarity
protected:
Similarity^ similarity
protected:
Similarity^ similarity
See Also
DisjunctionMaxQuery DisjunctionMaxWeight Class
DisjunctionMaxQuery DisjunctionMaxWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


weights Field

DisjunctionMaxQuery DisjunctionMaxWeight weights Field Lucene.Net Class Library
The Weights for our subqueries, in 1-1 correspondence with disjuncts

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected List<Weight> weights
protected List<Weight> weights
Protected weights As List(Of Weight)
Protected weights As List(Of Weight)
protected:
List<Weight^>^ weights
protected:
List<Weight^>^ weights
See Also
DisjunctionMaxQuery DisjunctionMaxWeight Class
DisjunctionMaxQuery DisjunctionMaxWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DisjunctionMaxQuery.DisjunctionMaxWeight Methods

DisjunctionMaxQuery DisjunctionMaxWeight Methods Lucene.Net Class Library
The DisjunctionMaxQuery DisjunctionMaxWeight type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | (Overrides Weight Explain(IndexReader, Int32).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetScoresDocsOutOfOrder | Returns true iff this implementation scores docs only out of order. This method is used in conjunction with Collector's AcceptsDocsOutOfOrder and Scorer(IndexReader, Boolean, Boolean) to create a matching Scorer(IndexReader, Boolean, Boolean) instance for a given Collector, or vice versa. NOTE: the default implementation returns false, i.e. the Scorer scores documents in-order. (Inherited from Weight.)
Public method | GetSumOfSquaredWeights | (Overrides Weight GetSumOfSquaredWeights .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Normalize | (Overrides Weight Normalize(Single).)
Public method | Scorer | (Overrides Weight Scorer(IndexReader, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DisjunctionMaxQuery DisjunctionMaxWeight Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method

DisjunctionMaxQuery DisjunctionMaxWeight Explain Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Explanation Explain(
    IndexReader reader,
    int doc
)
public override Explanation Explain(
    IndexReader reader,
    int doc
)
Public Overrides Function Explain ( _
    reader As IndexReader, _
    doc As Integer _
) As Explanation
Public Overrides Function Explain ( _
    reader As IndexReader, _
    doc As Integer _
) As Explanation
public:
virtual Explanation^ Explain(
    IndexReader^ reader,
    int doc
) override
public:
virtual Explanation^ Explain(
    IndexReader^ reader,
    int doc
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
doc
Type:   Online System Int32
See Also
DisjunctionMaxQuery DisjunctionMaxWeight Class
DisjunctionMaxQuery DisjunctionMaxWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSumOfSquaredWeights Method

DisjunctionMaxQuery DisjunctionMaxWeight GetSumOfSquaredWeights Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float GetSumOfSquaredWeights()
public override float GetSumOfSquaredWeights()
Public Overrides Function GetSumOfSquaredWeights As Single
Public Overrides Function GetSumOfSquaredWeights As Single
public:
virtual float GetSumOfSquaredWeights() override
public:
virtual float GetSumOfSquaredWeights() override
See Also
DisjunctionMaxQuery DisjunctionMaxWeight Class
DisjunctionMaxQuery DisjunctionMaxWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Normalize Method

DisjunctionMaxQuery DisjunctionMaxWeight Normalize Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Normalize(
    float norm
)
public override void Normalize(
    float norm
)
Public Overrides Sub Normalize ( _
    norm As Single _
)
Public Overrides Sub Normalize ( _
    norm As Single _
)
public:
virtual void Normalize(
    float norm
) override
public:
virtual void Normalize(
    float norm
) override
Parameters
norm
Type:   Online System Single
See Also
DisjunctionMaxQuery DisjunctionMaxWeight Class
DisjunctionMaxQuery DisjunctionMaxWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Scorer Method

DisjunctionMaxQuery DisjunctionMaxWeight Scorer Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
scoreDocsInOrder
Type:   Online System Boolean
topScorer
Type:   Online System Boolean
See Also
DisjunctionMaxQuery DisjunctionMaxWeight Class
DisjunctionMaxQuery DisjunctionMaxWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DisjunctionMaxQuery.DisjunctionMaxWeight Properties

DisjunctionMaxQuery DisjunctionMaxWeight Properties Lucene.Net Class Library
The DisjunctionMaxQuery DisjunctionMaxWeight type exposes the following members.
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Query | (Overrides Weight Query.)
Public property | Value | (Overrides Weight Value.)
Back to Top
See Also
DisjunctionMaxQuery DisjunctionMaxWeight Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Enclosing_Instance Property

DisjunctionMaxQuery DisjunctionMaxWeight Enclosing_Instance Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DisjunctionMaxQuery Enclosing_Instance { get; }
public DisjunctionMaxQuery Enclosing_Instance { get; }
Public ReadOnly Property Enclosing_Instance As DisjunctionMaxQuery
    Get
Public ReadOnly Property Enclosing_Instance As DisjunctionMaxQuery
    Get
public:
property DisjunctionMaxQuery^ Enclosing_Instance {
    DisjunctionMaxQuery^ get ();
}
public:
property DisjunctionMaxQuery^ Enclosing_Instance {
    DisjunctionMaxQuery^ get ();
}
See Also
DisjunctionMaxQuery DisjunctionMaxWeight Class
DisjunctionMaxQuery DisjunctionMaxWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Query Property

DisjunctionMaxQuery DisjunctionMaxWeight Query Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Query { get; }
public override Query Query { get; }
Public Overrides ReadOnly Property Query As Query
    Get
Public Overrides ReadOnly Property Query As Query
    Get
public:
virtual property Query^ Query {
    Query^ get () override;
}
public:
virtual property Query^ Query {
    Query^ get () override;
}
See Also
DisjunctionMaxQuery DisjunctionMaxWeight Class
DisjunctionMaxQuery DisjunctionMaxWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Value Property

DisjunctionMaxQuery DisjunctionMaxWeight Value Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Value { get; }
public override float Value { get; }
Public Overrides ReadOnly Property Value As Single
    Get
Public Overrides ReadOnly Property Value As Single
    Get
public:
virtual property float Value {
    float get () override;
}
public:
virtual property float Value {
    float get () override;
}
See Also
DisjunctionMaxQuery DisjunctionMaxWeight Class
DisjunctionMaxQuery DisjunctionMaxWeight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSet Class

DocIdSet Class Lucene.Net Class Library
A DocIdSet contains a set of doc ids. Implementing classes must only implement Iterator to provide access to the set.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSet
Lucene.Net.Search DocIdSet AnonymousClassDocIdSet
Lucene.Net.Search FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet
Lucene.Net.Search FilteredDocIdSet
Lucene.Net.Util DocIdBitSet
Lucene.Net.Util OpenBitSet
Lucene.Net.Util SortedVIntList

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class DocIdSet
[SerializableAttribute]
public abstract class DocIdSet
<SerializableAttribute> _
Public MustInherit Class DocIdSet
<SerializableAttribute> _
Public MustInherit Class DocIdSet
[SerializableAttribute]
public ref class DocIdSet abstract
[SerializableAttribute]
public ref class DocIdSet abstract
See Also
DocIdSet Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSet Members

DocIdSet Members Lucene.Net Class Library

The DocIdSet type exposes the following members.
Constructors
 | Name | Description
Protected method | DocIdSet | Initializes a new instance of the DocIdSet class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Iterator | Provides a DocIdSetIterator to access the set. This implementation can return null or EMPTY_DOCIDSET.Iterator() if there are no docs that match.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
EMPTY_DOCIDSET | An empty DocIdSet instance for easy use, e.g. in Filters that hit no documents.
Back to Top
Properties
 | Name | Description
Public property | IsCacheable | This method is a hint for CachingWrapperFilter, if this DocIdSet should be cached without copying it into a BitSet. The default is to return false. If you have an own DocIdSet implementation that does its iteration very effective and fast without doing disk I/O, override this method and return true.
Back to Top
See Also
DocIdSet Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSet Constructor

DocIdSet Constructor Lucene.Net Class Library
Initializes a new instance of the DocIdSet class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DocIdSet()
protected DocIdSet()
Protected Sub New
Protected Sub New
protected:
DocIdSet()
protected:
DocIdSet()
See Also
DocIdSet Class
DocIdSet Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSet Fields

DocIdSet Fields Lucene.Net Class Library
The DocIdSet type exposes the following members.
Fields
Name | Description
EMPTY_DOCIDSET | An empty DocIdSet instance for easy use, e.g. in Filters that hit no documents.
Back to Top
See Also
DocIdSet Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EMPTY_DOCIDSET Field

DocIdSet EMPTY_DOCIDSET Field Lucene.Net Class Library
An empty DocIdSet instance for easy use, e.g. in Filters that hit no documents.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
public static readonly DocIdSet EMPTY_DOCIDSET
[NonSerializedAttribute]
public static readonly DocIdSet EMPTY_DOCIDSET
<NonSerializedAttribute> _
Public Shared ReadOnly EMPTY_DOCIDSET As DocIdSet
<NonSerializedAttribute> _
Public Shared ReadOnly EMPTY_DOCIDSET As DocIdSet
public:
[NonSerializedAttribute]
static initonly DocIdSet^ EMPTY_DOCIDSET
public:
[NonSerializedAttribute]
static initonly DocIdSet^ EMPTY_DOCIDSET
See Also
DocIdSet Class
DocIdSet Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSet Methods

DocIdSet Methods Lucene.Net Class Library
The DocIdSet type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Iterator | Provides a DocIdSetIterator to access the set. This implementation can return null or EMPTY_DOCIDSET.Iterator() if there are no docs that match.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DocIdSet Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Iterator Method

DocIdSet Iterator Method Lucene.Net Class Library
Provides a DocIdSetIterator to access the set. This implementation can return null or EMPTY_DOCIDSET.Iterator() if there are no docs that match.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract DocIdSetIterator Iterator()
public abstract DocIdSetIterator Iterator()
Public MustOverride Function Iterator As DocIdSetIterator
Public MustOverride Function Iterator As DocIdSetIterator
public:
virtual DocIdSetIterator^ Iterator() abstract
public:
virtual DocIdSetIterator^ Iterator() abstract
See Also
DocIdSet Class
DocIdSet Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSet Properties

DocIdSet Properties Lucene.Net Class Library
The DocIdSet type exposes the following members.
Properties
 | Name | Description
Public property | IsCacheable | This method is a hint for CachingWrapperFilter, if this DocIdSet should be cached without copying it into a BitSet. The default is to return false. If you have an own DocIdSet implementation that does its iteration very effective and fast without doing disk I/O, override this method and return true.
Back to Top
See Also
DocIdSet Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsCacheable Property

DocIdSet IsCacheable Property Lucene.Net Class Library
This method is a hint for CachingWrapperFilter, if this DocIdSet should be cached without copying it into a BitSet. The default is to return false. If you have an own DocIdSet implementation that does its iteration very effective and fast without doing disk I/O, override this method and return true.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsCacheable { get; }
public virtual bool IsCacheable { get; }
Public Overridable ReadOnly Property IsCacheable As Boolean
    Get
Public Overridable ReadOnly Property IsCacheable As Boolean
    Get
public:
virtual property bool IsCacheable {
    bool get ();
}
public:
virtual property bool IsCacheable {
    bool get ();
}
See Also
DocIdSet Class
DocIdSet Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSet.AnonymousClassDocIdSet Class

DocIdSet AnonymousClassDocIdSet Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSet
Lucene.Net.Search DocIdSet AnonymousClassDocIdSet

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AnonymousClassDocIdSet : DocIdSet
public class AnonymousClassDocIdSet : DocIdSet
Public Class AnonymousClassDocIdSet _
    Inherits DocIdSet
Public Class AnonymousClassDocIdSet _
    Inherits DocIdSet
public ref class AnonymousClassDocIdSet : public DocIdSet
public ref class AnonymousClassDocIdSet : public DocIdSet
See Also
DocIdSet AnonymousClassDocIdSet Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSet.AnonymousClassDocIdSet Members

DocIdSet AnonymousClassDocIdSet Members Lucene.Net Class Library

A DocIdSet contains a set of doc ids. Implementing classes must only implement Iterator to provide access to the set.

The DocIdSet AnonymousClassDocIdSet type exposes the following members.
Constructors
 | Name | Description
Public method | DocIdSet AnonymousClassDocIdSet | Initializes a new instance of the DocIdSet AnonymousClassDocIdSet class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Iterator | (Overrides DocIdSet Iterator .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | IsCacheable | (Overrides DocIdSet IsCacheable.)
Back to Top
See Also
DocIdSet AnonymousClassDocIdSet Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSet.AnonymousClassDocIdSet Constructor

DocIdSet AnonymousClassDocIdSet Constructor Lucene.Net Class Library
Initializes a new instance of the DocIdSet AnonymousClassDocIdSet class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AnonymousClassDocIdSet()
public AnonymousClassDocIdSet()
Public Sub New
Public Sub New
public:
AnonymousClassDocIdSet()
public:
AnonymousClassDocIdSet()
See Also
DocIdSet AnonymousClassDocIdSet Class
DocIdSet AnonymousClassDocIdSet Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSet.AnonymousClassDocIdSet Methods

DocIdSet AnonymousClassDocIdSet Methods Lucene.Net Class Library
The DocIdSet AnonymousClassDocIdSet type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Iterator | (Overrides DocIdSet Iterator .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DocIdSet AnonymousClassDocIdSet Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Iterator Method

DocIdSet AnonymousClassDocIdSet Iterator Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocIdSetIterator Iterator()
public override DocIdSetIterator Iterator()
Public Overrides Function Iterator As DocIdSetIterator
Public Overrides Function Iterator As DocIdSetIterator
public:
virtual DocIdSetIterator^ Iterator() override
public:
virtual DocIdSetIterator^ Iterator() override
See Also
DocIdSet AnonymousClassDocIdSet Class
DocIdSet AnonymousClassDocIdSet Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSet.AnonymousClassDocIdSet Properties

DocIdSet AnonymousClassDocIdSet Properties Lucene.Net Class Library
The DocIdSet AnonymousClassDocIdSet type exposes the following members.
Properties
 | Name | Description
Public property | IsCacheable | (Overrides DocIdSet IsCacheable.)
Back to Top
See Also
DocIdSet AnonymousClassDocIdSet Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsCacheable Property

DocIdSet AnonymousClassDocIdSet IsCacheable Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsCacheable { get; }
public override bool IsCacheable { get; }
Public Overrides ReadOnly Property IsCacheable As Boolean
    Get
Public Overrides ReadOnly Property IsCacheable As Boolean
    Get
public:
virtual property bool IsCacheable {
    bool get () override;
}
public:
virtual property bool IsCacheable {
    bool get () override;
}
See Also
DocIdSet AnonymousClassDocIdSet Class
DocIdSet AnonymousClassDocIdSet Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator Class

DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSetIterator
Lucene.Net.Search DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AnonymousClassDocIdSetIterator : DocIdSetIterator
public class AnonymousClassDocIdSetIterator : DocIdSetIterator
Public Class AnonymousClassDocIdSetIterator _
    Inherits DocIdSetIterator
Public Class AnonymousClassDocIdSetIterator _
    Inherits DocIdSetIterator
public ref class AnonymousClassDocIdSetIterator : public DocIdSetIterator
public ref class AnonymousClassDocIdSetIterator : public DocIdSetIterator
See Also
DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator Members

DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Members Lucene.Net Class Library

The DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator type exposes the following members.
Constructors
 | Name | Description
Public method | DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator | Initializes a new instance of the DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator class
Back to Top
Methods
 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Overrides DocIdSetIterator NextDoc .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Enclosing_Instance |
Back to Top
See Also
DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator Constructor

DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Constructor Lucene.Net Class Library
Initializes a new instance of the DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AnonymousClassDocIdSetIterator(
    DocIdSet..::..AnonymousClassDocIdSet enclosingInstance
)
public AnonymousClassDocIdSetIterator(
    DocIdSet..::..AnonymousClassDocIdSet enclosingInstance
)
Public Sub New ( _
    enclosingInstance As DocIdSet..::..AnonymousClassDocIdSet _
)
Public Sub New ( _
    enclosingInstance As DocIdSet..::..AnonymousClassDocIdSet _
)
public:
AnonymousClassDocIdSetIterator(
    DocIdSet..::..AnonymousClassDocIdSet^ enclosingInstance
)
public:
AnonymousClassDocIdSetIterator(
    DocIdSet..::..AnonymousClassDocIdSet^ enclosingInstance
)
Parameters
enclosingInstance
Type: Lucene.Net.Search DocIdSet AnonymousClassDocIdSet
See Also
DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Class
DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator Methods

DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Methods Lucene.Net Class Library
The DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator type exposes the following members.
Methods
 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Overrides DocIdSetIterator NextDoc .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Advance Method

DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Advance Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Advance(
    int target
)
public override int Advance(
    int target
)
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
public:
virtual int Advance(
    int target
) override
public:
virtual int Advance(
    int target
) override
Parameters
target
Type:   Online System Int32
See Also
DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Class
DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocID Method

DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator DocID Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocID()
public override int DocID()
Public Overrides Function DocID As Integer
Public Overrides Function DocID As Integer
public:
virtual int DocID() override
public:
virtual int DocID() override
See Also
DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Class
DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextDoc Method

DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator NextDoc Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int NextDoc()
public override int NextDoc()
Public Overrides Function NextDoc As Integer
Public Overrides Function NextDoc As Integer
public:
virtual int NextDoc() override
public:
virtual int NextDoc() override
See Also
DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Class
DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator Properties

DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Properties Lucene.Net Class Library
The DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator type exposes the following members.
Properties
 | Name | Description
Public property | Enclosing_Instance |
Back to Top
See Also
DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Enclosing_Instance Property

DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Enclosing_Instance Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DocIdSet..::..AnonymousClassDocIdSet Enclosing_Instance { get; }
public DocIdSet..::..AnonymousClassDocIdSet Enclosing_Instance { get; }
Public ReadOnly Property Enclosing_Instance As DocIdSet..::..AnonymousClassDocIdSet
    Get
Public ReadOnly Property Enclosing_Instance As DocIdSet..::..AnonymousClassDocIdSet
    Get
public:
property DocIdSet..::..AnonymousClassDocIdSet^ Enclosing_Instance {
    DocIdSet..::..AnonymousClassDocIdSet^ get ();
}
public:
property DocIdSet..::..AnonymousClassDocIdSet^ Enclosing_Instance {
    DocIdSet..::..AnonymousClassDocIdSet^ get ();
}
See Also
DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Class
DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSetIterator Class

DocIdSetIterator Class Lucene.Net Class Library
This abstract class defines methods to iterate over a set of non-decreasing doc ids. Note that this class assumes it iterates on doc Ids, and therefore NO_MORE_DOCS is set to Int32.MaxValue in order to be used as a sentinel object. Implementations of this class are expected to consider Online MaxValue as an invalid value.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSetIterator
Lucene.Net.Search DocIdSet AnonymousClassDocIdSet AnonymousClassDocIdSetIterator
Lucene.Net.Search FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator
Lucene.Net.Search FilteredDocIdSetIterator
Lucene.Net.Search Scorer
Lucene.Net.Util OpenBitSetIterator

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class DocIdSetIterator
public abstract class DocIdSetIterator
Public MustInherit Class DocIdSetIterator
Public MustInherit Class DocIdSetIterator
public ref class DocIdSetIterator abstract
public ref class DocIdSetIterator abstract
See Also
DocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSetIterator Members

DocIdSetIterator Members Lucene.Net Class Library

The DocIdSetIterator type exposes the following members.
Constructors
 | Name | Description
Protected method | DocIdSetIterator | Initializes a new instance of the DocIdSetIterator class
Back to Top
Methods
Name Description
Public method Advance
Advances to the first beyond the current whose document number is greater than or equal to target. Returns the current document number or NO_MORE_DOCS if there are no more docs in the set.

Behaves as if written:
View Colorized Copy to Clipboard Print
int advance(int target) {
    int doc;
    while ((doc = nextDoc()) < target) {
    }
    return doc;
}
int advance(int target) {
    int doc;
    while ((doc = nextDoc()) < target) {
    }
    return doc;
}
Some implementations are considerably more efficient than that.

NOTE: certain implemenations may return a different value (each time) if called several times in a row with the same target.

NOTE: this method may be called with NO_MORE_DOCS for efficiency by some Scorers. If your implementation cannot efficiently determine that it should exhaust, it is recommended that you check for that value in each call to this method.

NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.

Public method DocID
Returns the following:
  • -1 or NO_MORE_DOCS if NextDoc or Advance(Int32) were not called yet.
  • NO_MORE_DOCS if the iterator has exhausted.
  • Otherwise it should return the doc ID it is currently on.

Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method NextDoc
Advances to the next document in the set and returns the doc it is currently on, or NO_MORE_DOCS if there are no more docs in the set.
NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
Fields
Name | Description
NO_MORE_DOCS | When returned by NextDoc , Advance(Int32) and DocID it means there are no more docs in the iterator.
Back to Top
See Also
DocIdSetIterator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSetIterator Constructor

DocIdSetIterator Constructor Lucene.Net Class Library
Initializes a new instance of the DocIdSetIterator class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DocIdSetIterator()
protected DocIdSetIterator()
Protected Sub New
Protected Sub New
protected:
DocIdSetIterator()
protected:
DocIdSetIterator()
See Also
DocIdSetIterator Class
DocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSetIterator Fields

DocIdSetIterator Fields Lucene.Net Class Library
The DocIdSetIterator type exposes the following members.
Fields
Name | Description
NO_MORE_DOCS | When returned by NextDoc , Advance(Int32) and DocID it means there are no more docs in the iterator.
Back to Top
See Also
DocIdSetIterator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NO_MORE_DOCS Field

DocIdSetIterator NO_MORE_DOCS Field Lucene.Net Class Library
When returned by NextDoc , Advance(Int32) and DocID it means there are no more docs in the iterator.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly int NO_MORE_DOCS
public static readonly int NO_MORE_DOCS
Public Shared ReadOnly NO_MORE_DOCS As Integer
Public Shared ReadOnly NO_MORE_DOCS As Integer
public:
static initonly int NO_MORE_DOCS
public:
static initonly int NO_MORE_DOCS
See Also
DocIdSetIterator Class
DocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSetIterator Methods

DocIdSetIterator Methods Lucene.Net Class Library
The DocIdSetIterator type exposes the following members.
Methods
Name Description
Public method Advance
Advances to the first beyond the current whose document number is greater than or equal to target. Returns the current document number or NO_MORE_DOCS if there are no more docs in the set.

Behaves as if written:
View Colorized Copy to Clipboard Print
int advance(int target) {
    int doc;
    while ((doc = nextDoc()) < target) {
    }
    return doc;
}
int advance(int target) {
    int doc;
    while ((doc = nextDoc()) < target) {
    }
    return doc;
}
Some implementations are considerably more efficient than that.

NOTE: certain implemenations may return a different value (each time) if called several times in a row with the same target.

NOTE: this method may be called with NO_MORE_DOCS for efficiency by some Scorers. If your implementation cannot efficiently determine that it should exhaust, it is recommended that you check for that value in each call to this method.

NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.

Public method DocID
Returns the following:
  • -1 or NO_MORE_DOCS if NextDoc or Advance(Int32) were not called yet.
  • NO_MORE_DOCS if the iterator has exhausted.
  • Otherwise it should return the doc ID it is currently on.

Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method NextDoc
Advances to the next document in the set and returns the doc it is currently on, or NO_MORE_DOCS if there are no more docs in the set.
NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
See Also
DocIdSetIterator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Advance Method

DocIdSetIterator Advance Method Lucene.Net Class Library
Advances to the first beyond the current whose document number is greater than or equal to target. Returns the current document number or NO_MORE_DOCS if there are no more docs in the set.

Behaves as if written:
View Colorized Copy to Clipboard Print
int advance(int target) {
    int doc;
    while ((doc = nextDoc()) < target) {
    }
    return doc;
}
int advance(int target) {
    int doc;
    while ((doc = nextDoc()) < target) {
    }
    return doc;
}
Some implementations are considerably more efficient than that.

NOTE: certain implemenations may return a different value (each time) if called several times in a row with the same target.

NOTE: this method may be called with NO_MORE_DOCS for efficiency by some Scorers. If your implementation cannot efficiently determine that it should exhaust, it is recommended that you check for that value in each call to this method.

NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int Advance(
    int target
)
public abstract int Advance(
    int target
)
Public MustOverride Function Advance ( _
    target As Integer _
) As Integer
Public MustOverride Function Advance ( _
    target As Integer _
) As Integer
public:
virtual int Advance(
    int target
) abstract
public:
virtual int Advance(
    int target
) abstract
Parameters
target
Type:   Online System Int32
See Also
DocIdSetIterator Class
DocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocID Method

DocIdSetIterator DocID Method Lucene.Net Class Library
Returns the following:
  • -1 or NO_MORE_DOCS if NextDoc or Advance(Int32) were not called yet.
  • NO_MORE_DOCS if the iterator has exhausted.
  • Otherwise it should return the doc ID it is currently on.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int DocID()
public abstract int DocID()
Public MustOverride Function DocID As Integer
Public MustOverride Function DocID As Integer
public:
virtual int DocID() abstract
public:
virtual int DocID() abstract
See Also
DocIdSetIterator Class
DocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextDoc Method

DocIdSetIterator NextDoc Method Lucene.Net Class Library
Advances to the next document in the set and returns the doc it is currently on, or NO_MORE_DOCS if there are no more docs in the set.
NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int NextDoc()
public abstract int NextDoc()
Public MustOverride Function NextDoc As Integer
Public MustOverride Function NextDoc As Integer
public:
virtual int NextDoc() abstract
public:
virtual int NextDoc() abstract
See Also
DocIdSetIterator Class
DocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoubleParser Interface

DoubleParser Interface Lucene.Net Class Library
Interface to parse doubles from document fields.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface DoubleParser : Parser
public interface DoubleParser : Parser
Public Interface DoubleParser _
    Inherits Parser
Public Interface DoubleParser _
    Inherits Parser
public interface class DoubleParser : Parser
public interface class DoubleParser : Parser
See Also
DoubleParser Members
Lucene.Net.Search Namespace
FieldCache GetDoubles(IndexReader, String, DoubleParser)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoubleParser Members

DoubleParser Members Lucene.Net Class Library

The DoubleParser type exposes the following members.
Methods
 | Name | Description
Public method | ParseDouble | Return an long representation of this field's value.
Back to Top
See Also
DoubleParser Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoubleParser Methods

DoubleParser Methods Lucene.Net Class Library
The DoubleParser type exposes the following members.
Methods
 | Name | Description
Public method | ParseDouble | Return an long representation of this field's value.
Back to Top
See Also
DoubleParser Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseDouble Method

DoubleParser ParseDouble Method Lucene.Net Class Library
Return an long representation of this field's value.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
double ParseDouble(
    string string_Renamed
)
double ParseDouble(
    string string_Renamed
)
Function ParseDouble ( _
    string_Renamed As String _
) As Double
Function ParseDouble ( _
    string_Renamed As String _
) As Double
double ParseDouble(
    String^ string_Renamed
)
double ParseDouble(
    String^ string_Renamed
)
Parameters
string_Renamed
Type:   Online System String
See Also
DoubleParser Interface
DoubleParser Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explanation Class

Explanation Class Lucene.Net Class Library
Expert: Describes the score computation for document and query.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Explanation
Lucene.Net.Search ComplexExplanation

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class Explanation
[SerializableAttribute]
public class Explanation
<SerializableAttribute> _
Public Class Explanation
<SerializableAttribute> _
Public Class Explanation
[SerializableAttribute]
public ref class Explanation
[SerializableAttribute]
public ref class Explanation
See Also
Explanation Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explanation Members

Explanation Members Lucene.Net Class Library

The Explanation type exposes the following members.
Constructors
 | Name | Description
Public method | Explanation | Initializes a new instance of the Explanation class
Public method | Explanation(Single, String) | Initializes a new instance of the Explanation class
Back to Top
Methods
 | Name | Description
Public method | AddDetail | Adds a sub-node to this explanation node.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDetails | The sub-nodes of this explanation node.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToHtml | Render an explanation as HTML.
Public method | ToString | Render an explanation as text. (Overrides Online Object ToString .)
Protected method | ToString(Int32) |
Back to Top
Properties
 | Name | Description
Public property | Description | A description of this explanation node.
Public property | IsMatch | Indicates whether or not this Explanation models a good match. By default, an Explanation represents a "match" if the value is positive.
Protected property | Summary | A short one line summary which should contain all high level information about this Explanation, without the "Details"
Public property | Value | The value assigned to this explanation node.
Back to Top
See Also
Explanation Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explanation Constructor

Explanation Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Explanation | Initializes a new instance of the Explanation class
Public method | Explanation(Single, String) | Initializes a new instance of the Explanation class
Back to Top
See Also
Explanation Class
Explanation Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explanation Constructor

Explanation Constructor Lucene.Net Class Library
Initializes a new instance of the Explanation class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Explanation()
public Explanation()
Public Sub New
Public Sub New
public:
Explanation()
public:
Explanation()
See Also
Explanation Class
Explanation Members
Explanation Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explanation Constructor (Single, String)

Explanation Constructor (Single, String) Lucene.Net Class Library
Initializes a new instance of the Explanation class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Explanation(
    float value,
    string description
)
public Explanation(
    float value,
    string description
)
Public Sub New ( _
    value As Single, _
    description As String _
)
Public Sub New ( _
    value As Single, _
    description As String _
)
public:
Explanation(
    float value,
    String^ description
)
public:
Explanation(
    float value,
    String^ description
)
Parameters
value
Type:   Online System Single
description
Type:   Online System String
See Also
Explanation Class
Explanation Members
Explanation Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explanation Methods

Explanation Methods Lucene.Net Class Library
The Explanation type exposes the following members.
Methods
 | Name | Description
Public method | AddDetail | Adds a sub-node to this explanation node.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDetails | The sub-nodes of this explanation node.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToHtml | Render an explanation as HTML.
Public method | ToString | Render an explanation as text. (Overrides Online Object ToString .)
Protected method | ToString(Int32) |
Back to Top
See Also
Explanation Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddDetail Method

Explanation AddDetail Method Lucene.Net Class Library
Adds a sub-node to this explanation node.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AddDetail(
    Explanation detail
)
public virtual void AddDetail(
    Explanation detail
)
Public Overridable Sub AddDetail ( _
    detail As Explanation _
)
Public Overridable Sub AddDetail ( _
    detail As Explanation _
)
public:
virtual void AddDetail(
    Explanation^ detail
)
public:
virtual void AddDetail(
    Explanation^ detail
)
Parameters
detail
Type: Lucene.Net.Search Explanation
See Also
Explanation Class
Explanation Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetDetails Method

Explanation GetDetails Method Lucene.Net Class Library
The sub-nodes of this explanation node.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Explanation[] GetDetails()
public virtual Explanation[] GetDetails()
Public Overridable Function GetDetails As Explanation()
Public Overridable Function GetDetails As Explanation()
public:
virtual array<Explanation^>^ GetDetails()
public:
virtual array<Explanation^>^ GetDetails()
See Also
Explanation Class
Explanation Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToHtml Method

Explanation ToHtml Method Lucene.Net Class Library
Render an explanation as HTML.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string ToHtml()
public virtual string ToHtml()
Public Overridable Function ToHtml As String
Public Overridable Function ToHtml As String
public:
virtual String^ ToHtml()
public:
virtual String^ ToHtml()
See Also
Explanation Class
Explanation Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

Explanation ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Render an explanation as text. (Overrides Online Object ToString .)
Protected method | ToString(Int32) |
Back to Top
See Also
Explanation Class
Explanation Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

Explanation ToString Method Lucene.Net Class Library
Render an explanation as text.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
Explanation Class
Explanation Members
ToString Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (Int32)

Explanation ToString Method (Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string ToString(
    int depth
)
protected virtual string ToString(
    int depth
)
Protected Overridable Function ToString ( _
    depth As Integer _
) As String
Protected Overridable Function ToString ( _
    depth As Integer _
) As String
protected:
virtual String^ ToString(
    int depth
)
protected:
virtual String^ ToString(
    int depth
)
Parameters
depth
Type:   Online System Int32
See Also
Explanation Class
Explanation Members
ToString Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explanation Properties

Explanation Properties Lucene.Net Class Library
The Explanation type exposes the following members.
Properties
 | Name | Description
Public property | Description | A description of this explanation node.
Public property | IsMatch | Indicates whether or not this Explanation models a good match. By default, an Explanation represents a "match" if the value is positive.
Protected property | Summary | A short one line summary which should contain all high level information about this Explanation, without the "Details"
Public property | Value | The value assigned to this explanation node.
Back to Top
See Also
Explanation Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Description Property

Explanation Description Property Lucene.Net Class Library
A description of this explanation node.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Description { get; set; }
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
See Also
Explanation Class
Explanation Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsMatch Property

Explanation IsMatch Property Lucene.Net Class Library
Indicates whether or not this Explanation models a good match.

By default, an Explanation represents a "match" if the value is positive.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsMatch { get; }
public virtual bool IsMatch { get; }
Public Overridable ReadOnly Property IsMatch As Boolean
    Get
Public Overridable ReadOnly Property IsMatch As Boolean
    Get
public:
virtual property bool IsMatch {
    bool get ();
}
public:
virtual property bool IsMatch {
    bool get ();
}
See Also
Explanation Class
Explanation Members
Lucene.Net.Search Namespace
Explanation Value
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Summary Property

Explanation Summary Property Lucene.Net Class Library
A short one line summary which should contain all high level information about this Explanation, without the "Details"

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string Summary { get; }
protected virtual string Summary { get; }
Protected Overridable ReadOnly Property Summary As String
    Get
Protected Overridable ReadOnly Property Summary As String
    Get
protected:
virtual property String^ Summary {
    String^ get ();
}
protected:
virtual property String^ Summary {
    String^ get ();
}
See Also
Explanation Class
Explanation Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Value Property

Explanation Value Property Lucene.Net Class Library
The value assigned to this explanation node.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual float Value { get; set; }
public virtual float Value { get; set; }
Public Overridable Property Value As Single
    Get
    Set
Public Overridable Property Value As Single
    Get
    Set
public:
virtual property float Value {
    float get ();
    void set (float value);
}
public:
virtual property float Value {
    float get ();
    void set (float value);
}
See Also
Explanation Class
Explanation Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explanation.IDFExplanation Class

Explanation IDFExplanation Class Lucene.Net Class Library
Small Util class used to pass both an idf factor as well as an explanation for that factor. This class will likely be held on a Weight, so be aware before storing any large or un-serializable fields.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Explanation IDFExplanation

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class IDFExplanation
[SerializableAttribute]
public abstract class IDFExplanation
<SerializableAttribute> _
Public MustInherit Class IDFExplanation
<SerializableAttribute> _
Public MustInherit Class IDFExplanation
[SerializableAttribute]
public ref class IDFExplanation abstract
[SerializableAttribute]
public ref class IDFExplanation abstract
See Also
Explanation IDFExplanation Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explanation.IDFExplanation Members

Explanation IDFExplanation Members Lucene.Net Class Library

Expert: Describes the score computation for document and query.

The Explanation IDFExplanation type exposes the following members.
Constructors
 | Name | Description
Protected method | Explanation IDFExplanation | Initializes a new instance of the Explanation IDFExplanation class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | This should be calculated lazily if possible.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Idf |
Back to Top
See Also
Explanation IDFExplanation Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explanation.IDFExplanation Constructor

Explanation IDFExplanation Constructor Lucene.Net Class Library
Initializes a new instance of the Explanation IDFExplanation class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IDFExplanation()
protected IDFExplanation()
Protected Sub New
Protected Sub New
protected:
IDFExplanation()
protected:
IDFExplanation()
See Also
Explanation IDFExplanation Class
Explanation IDFExplanation Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explanation.IDFExplanation Methods

Explanation IDFExplanation Methods Lucene.Net Class Library
The Explanation IDFExplanation type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | This should be calculated lazily if possible.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Explanation IDFExplanation Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method

Explanation IDFExplanation Explain Method Lucene.Net Class Library
This should be calculated lazily if possible.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string Explain()
public abstract string Explain()
Public MustOverride Function Explain As String
Public MustOverride Function Explain As String
public:
virtual String^ Explain() abstract
public:
virtual String^ Explain() abstract
Return Value
 the explanation for the idf factor.

See Also
Explanation IDFExplanation Class
Explanation IDFExplanation Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explanation.IDFExplanation Properties

Explanation IDFExplanation Properties Lucene.Net Class Library
The Explanation IDFExplanation type exposes the following members.
Properties
 | Name | Description
Public property | Idf |
Back to Top
See Also
Explanation IDFExplanation Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Idf Property

Explanation IDFExplanation Idf Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract float Idf { get; }
public abstract float Idf { get; }
Public MustOverride ReadOnly Property Idf As Single
    Get
Public MustOverride ReadOnly Property Idf As Single
    Get
public:
virtual property float Idf {
    float get () abstract;
}
public:
virtual property float Idf {
    float get () abstract;
}
Field Value
 the idf factor
See Also
Explanation IDFExplanation Class
Explanation IDFExplanation Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCache Interface

FieldCache Interface Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface FieldCache
public interface FieldCache
Public Interface FieldCache
Public Interface FieldCache
public interface class FieldCache
public interface class FieldCache
See Also
FieldCache Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCache Members

FieldCache Members Lucene.Net Class Library

The FieldCache type exposes the following members.
Methods
 | Name | Description
Public method | GetBytes(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as a single byte and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetBytes(IndexReader, String, ByteParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as bytes and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetCacheEntries | EXPERT: Generates an array of CacheEntry objects representing all items currently in the FieldCache. NOTE: These CacheEntry objects maintain a strong refrence to the Cached Values. Maintaining refrences to a CacheEntry the IndexReader associated with it has garbage collected will prevent the Value itself from being garbage collected when the Cache drops the WeakRefrence. EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.
Public method | GetDoubles(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as integers and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetDoubles(IndexReader, String, DoubleParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as doubles and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetFloats(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as floats and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetFloats(IndexReader, String, FloatParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as floats and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetInts(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as integers and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetInts(IndexReader, String, IntParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as integers and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetLongs(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as longs and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetLongs(IndexReader, String, LongParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as longs and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetShorts(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as shorts and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetShorts(IndexReader, String, ShortParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as shorts and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetStringIndex | Checks the internal cache for an appropriate entry, and if none is found reads the term values in field and returns an array of them in natural order, along with an array telling which element in the term array each document uses.
Public method | GetStrings | Checks the internal cache for an appropriate entry, and if none is found, reads the term values in field and returns an array of size reader.MaxDoc containing the value each document has in the given field.
Public method | Purge | Expert: drops all cache entries associated with this reader. NOTE: this reader must precisely match the reader that the cache entry is keyed on. If you pass a top-level reader, it usually will have no effect as Lucene now caches at the segment reader level.
Public method | PurgeAllCaches | EXPERT: Instructs the FieldCache to forcibly expunge all entries from the underlying caches. This is intended only to be used for test methods as a way to ensure a known base state of the Cache (with out needing to rely on GC to free WeakReferences). It should not be relied on for "Cache maintenance" in general application code. EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.
Back to Top
Properties
 | Name | Description
Public property | InfoStream | Gets or sets the InfoStream for this FieldCache. If non-null, FieldCacheImpl will warn whenever entries are created that are not sane according to FieldCacheSanityChecker.
Back to Top
See Also
FieldCache Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCache Methods

FieldCache Methods Lucene.Net Class Library
The FieldCache type exposes the following members.
Methods
 | Name | Description
Public method | GetBytes(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as a single byte and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetBytes(IndexReader, String, ByteParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as bytes and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetCacheEntries | EXPERT: Generates an array of CacheEntry objects representing all items currently in the FieldCache. NOTE: These CacheEntry objects maintain a strong refrence to the Cached Values. Maintaining refrences to a CacheEntry the IndexReader associated with it has garbage collected will prevent the Value itself from being garbage collected when the Cache drops the WeakRefrence. EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.
Public method | GetDoubles(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as integers and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetDoubles(IndexReader, String, DoubleParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as doubles and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetFloats(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as floats and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetFloats(IndexReader, String, FloatParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as floats and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetInts(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as integers and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetInts(IndexReader, String, IntParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as integers and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetLongs(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as longs and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetLongs(IndexReader, String, LongParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as longs and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetShorts(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as shorts and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetShorts(IndexReader, String, ShortParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as shorts and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetStringIndex | Checks the internal cache for an appropriate entry, and if none is found reads the term values in field and returns an array of them in natural order, along with an array telling which element in the term array each document uses.
Public method | GetStrings | Checks the internal cache for an appropriate entry, and if none is found, reads the term values in field and returns an array of size reader.MaxDoc containing the value each document has in the given field.
Public method | Purge | Expert: drops all cache entries associated with this reader. NOTE: this reader must precisely match the reader that the cache entry is keyed on. If you pass a top-level reader, it usually will have no effect as Lucene now caches at the segment reader level.
Public method | PurgeAllCaches | EXPERT: Instructs the FieldCache to forcibly expunge all entries from the underlying caches. This is intended only to be used for test methods as a way to ensure a known base state of the Cache (with out needing to rely on GC to free WeakReferences). It should not be relied on for "Cache maintenance" in general application code. EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.
Back to Top
See Also
FieldCache Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBytes Method

FieldCache GetBytes Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetBytes(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as a single byte and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetBytes(IndexReader, String, ByteParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as bytes and returns an array of size reader.MaxDoc of the value each document has in the given field.
Back to Top
See Also
FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBytes Method (IndexReader, String)

FieldCache GetBytes Method (IndexReader, String) Lucene.Net Class Library
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as a single byte and returns an array of size reader.MaxDoc of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
sbyte[] GetBytes(
    IndexReader reader,
    string field
)
sbyte[] GetBytes(
    IndexReader reader,
    string field
)
Function GetBytes ( _
    reader As IndexReader, _
    field As String _
) As SByte()
Function GetBytes ( _
    reader As IndexReader, _
    field As String _
) As SByte()
array<signed char>^ GetBytes(
    IndexReader^ reader,
    String^ field
)
array<signed char>^ GetBytes(
    IndexReader^ reader,
    String^ field
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
 Used to get field values.

field
Type:   Online System String
  Which field contains the single byte values.

Return Value
 The values in the given field for each document.

See Also
FieldCache Interface
FieldCache Members
GetBytes Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBytes Method (IndexReader, String, ByteParser)

FieldCache GetBytes Method (IndexReader, String, ByteParser) Lucene.Net Class Library
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as bytes and returns an array of size reader.MaxDoc of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
sbyte[] GetBytes(
    IndexReader reader,
    string field,
    ByteParser parser
)
sbyte[] GetBytes(
    IndexReader reader,
    string field,
    ByteParser parser
)
Function GetBytes ( _
    reader As IndexReader, _
    field As String, _
    parser As ByteParser _
) As SByte()
Function GetBytes ( _
    reader As IndexReader, _
    field As String, _
    parser As ByteParser _
) As SByte()
array<signed char>^ GetBytes(
    IndexReader^ reader,
    String^ field,
    ByteParser^ parser
)
array<signed char>^ GetBytes(
    IndexReader^ reader,
    String^ field,
    ByteParser^ parser
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
 Used to get field values.

field
Type:   Online System String
  Which field contains the bytes.

parser
Type: Lucene.Net.Search ByteParser
 Computes byte for string values.

Return Value
 The values in the given field for each document.

See Also
FieldCache Interface
FieldCache Members
GetBytes Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCacheEntries Method

FieldCache GetCacheEntries Method Lucene.Net Class Library
EXPERT: Generates an array of CacheEntry objects representing all items currently in the FieldCache.

NOTE: These CacheEntry objects maintain a strong refrence to the Cached Values. Maintaining refrences to a CacheEntry the IndexReader associated with it has garbage collected will prevent the Value itself from being garbage collected when the Cache drops the WeakRefrence.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
CacheEntry[] GetCacheEntries()
CacheEntry[] GetCacheEntries()
Function GetCacheEntries As CacheEntry()
Function GetCacheEntries As CacheEntry()
array<CacheEntry^>^ GetCacheEntries()
array<CacheEntry^>^ GetCacheEntries()
See Also
FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetDoubles Method

FieldCache GetDoubles Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetDoubles(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as integers and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetDoubles(IndexReader, String, DoubleParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as doubles and returns an array of size reader.MaxDoc of the value each document has in the given field.
Back to Top
See Also
FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetDoubles Method (IndexReader, String)

FieldCache GetDoubles Method (IndexReader, String) Lucene.Net Class Library
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as integers and returns an array of size reader.MaxDoc of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
double[] GetDoubles(
    IndexReader reader,
    string field
)
double[] GetDoubles(
    IndexReader reader,
    string field
)
Function GetDoubles ( _
    reader As IndexReader, _
    field As String _
) As Double()
Function GetDoubles ( _
    reader As IndexReader, _
    field As String _
) As Double()
array<double>^ GetDoubles(
    IndexReader^ reader,
    String^ field
)
array<double>^ GetDoubles(
    IndexReader^ reader,
    String^ field
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
Used to get field values.

field
Type:   Online System String
 Which field contains the doubles.

Return Value
 The values in the given field for each document.

See Also
FieldCache Interface
FieldCache Members
GetDoubles Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetDoubles Method (IndexReader, String, DoubleParser)

FieldCache GetDoubles Method (IndexReader, String, DoubleParser) Lucene.Net Class Library
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as doubles and returns an array of size reader.MaxDoc of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
double[] GetDoubles(
    IndexReader reader,
    string field,
    DoubleParser parser
)
double[] GetDoubles(
    IndexReader reader,
    string field,
    DoubleParser parser
)
Function GetDoubles ( _
    reader As IndexReader, _
    field As String, _
    parser As DoubleParser _
) As Double()
Function GetDoubles ( _
    reader As IndexReader, _
    field As String, _
    parser As DoubleParser _
) As Double()
array<double>^ GetDoubles(
    IndexReader^ reader,
    String^ field,
    DoubleParser^ parser
)
array<double>^ GetDoubles(
    IndexReader^ reader,
    String^ field,
    DoubleParser^ parser
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
Used to get field values.

field
Type:   Online System String
 Which field contains the doubles.

parser
Type: Lucene.Net.Search DoubleParser
Computes integer for string values.

Return Value
 The values in the given field for each document.

See Also
FieldCache Interface
FieldCache Members
GetDoubles Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFloats Method

FieldCache GetFloats Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetFloats(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as floats and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetFloats(IndexReader, String, FloatParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as floats and returns an array of size reader.MaxDoc of the value each document has in the given field.
Back to Top
See Also
FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFloats Method (IndexReader, String)

FieldCache GetFloats Method (IndexReader, String) Lucene.Net Class Library
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as floats and returns an array of size reader.MaxDoc of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
float[] GetFloats(
    IndexReader reader,
    string field
)
float[] GetFloats(
    IndexReader reader,
    string field
)
Function GetFloats ( _
    reader As IndexReader, _
    field As String _
) As Single()
Function GetFloats ( _
    reader As IndexReader, _
    field As String _
) As Single()
array<float>^ GetFloats(
    IndexReader^ reader,
    String^ field
)
array<float>^ GetFloats(
    IndexReader^ reader,
    String^ field
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
 Used to get field values.

field
Type:   Online System String
  Which field contains the floats.

Return Value
 The values in the given field for each document.

See Also
FieldCache Interface
FieldCache Members
GetFloats Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFloats Method (IndexReader, String, FloatParser)

FieldCache GetFloats Method (IndexReader, String, FloatParser) Lucene.Net Class Library
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as floats and returns an array of size reader.MaxDoc of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
float[] GetFloats(
    IndexReader reader,
    string field,
    FloatParser parser
)
float[] GetFloats(
    IndexReader reader,
    string field,
    FloatParser parser
)
Function GetFloats ( _
    reader As IndexReader, _
    field As String, _
    parser As FloatParser _
) As Single()
Function GetFloats ( _
    reader As IndexReader, _
    field As String, _
    parser As FloatParser _
) As Single()
array<float>^ GetFloats(
    IndexReader^ reader,
    String^ field,
    FloatParser^ parser
)
array<float>^ GetFloats(
    IndexReader^ reader,
    String^ field,
    FloatParser^ parser
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
 Used to get field values.

field
Type:   Online System String
  Which field contains the floats.

parser
Type: Lucene.Net.Search FloatParser
 Computes float for string values.

Return Value
 The values in the given field for each document.

See Also
FieldCache Interface
FieldCache Members
GetFloats Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetInts Method

FieldCache GetInts Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetInts(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as integers and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetInts(IndexReader, String, IntParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as integers and returns an array of size reader.MaxDoc of the value each document has in the given field.
Back to Top
See Also
FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetInts Method (IndexReader, String)

FieldCache GetInts Method (IndexReader, String) Lucene.Net Class Library
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as integers and returns an array of size reader.MaxDoc of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int[] GetInts(
    IndexReader reader,
    string field
)
int[] GetInts(
    IndexReader reader,
    string field
)
Function GetInts ( _
    reader As IndexReader, _
    field As String _
) As Integer()
Function GetInts ( _
    reader As IndexReader, _
    field As String _
) As Integer()
array<int>^ GetInts(
    IndexReader^ reader,
    String^ field
)
array<int>^ GetInts(
    IndexReader^ reader,
    String^ field
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
 Used to get field values.

field
Type:   Online System String
  Which field contains the integers.

Return Value
 The values in the given field for each document.

See Also
FieldCache Interface
FieldCache Members
GetInts Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetInts Method (IndexReader, String, IntParser)

FieldCache GetInts Method (IndexReader, String, IntParser) Lucene.Net Class Library
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as integers and returns an array of size reader.MaxDoc of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int[] GetInts(
    IndexReader reader,
    string field,
    IntParser parser
)
int[] GetInts(
    IndexReader reader,
    string field,
    IntParser parser
)
Function GetInts ( _
    reader As IndexReader, _
    field As String, _
    parser As IntParser _
) As Integer()
Function GetInts ( _
    reader As IndexReader, _
    field As String, _
    parser As IntParser _
) As Integer()
array<int>^ GetInts(
    IndexReader^ reader,
    String^ field,
    IntParser^ parser
)
array<int>^ GetInts(
    IndexReader^ reader,
    String^ field,
    IntParser^ parser
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
 Used to get field values.

field
Type:   Online System String
  Which field contains the integers.

parser
Type: Lucene.Net.Search IntParser
 Computes integer for string values.

Return Value
 The values in the given field for each document.

See Also
FieldCache Interface
FieldCache Members
GetInts Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLongs Method

FieldCache GetLongs Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetLongs(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as longs and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetLongs(IndexReader, String, LongParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as longs and returns an array of size reader.MaxDoc of the value each document has in the given field.
Back to Top
See Also
FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLongs Method (IndexReader, String)

FieldCache GetLongs Method (IndexReader, String) Lucene.Net Class Library
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as longs and returns an array of size reader.MaxDoc of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long[] GetLongs(
    IndexReader reader,
    string field
)
long[] GetLongs(
    IndexReader reader,
    string field
)
Function GetLongs ( _
    reader As IndexReader, _
    field As String _
) As Long()
Function GetLongs ( _
    reader As IndexReader, _
    field As String _
) As Long()
array<long long>^ GetLongs(
    IndexReader^ reader,
    String^ field
)
array<long long>^ GetLongs(
    IndexReader^ reader,
    String^ field
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
Used to get field values.

field
Type:   Online System String
 Which field contains the longs.

Return Value
 The values in the given field for each document.

See Also
FieldCache Interface
FieldCache Members
GetLongs Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLongs Method (IndexReader, String, LongParser)

FieldCache GetLongs Method (IndexReader, String, LongParser) Lucene.Net Class Library
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as longs and returns an array of size reader.MaxDoc of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long[] GetLongs(
    IndexReader reader,
    string field,
    LongParser parser
)
long[] GetLongs(
    IndexReader reader,
    string field,
    LongParser parser
)
Function GetLongs ( _
    reader As IndexReader, _
    field As String, _
    parser As LongParser _
) As Long()
Function GetLongs ( _
    reader As IndexReader, _
    field As String, _
    parser As LongParser _
) As Long()
array<long long>^ GetLongs(
    IndexReader^ reader,
    String^ field,
    LongParser^ parser
)
array<long long>^ GetLongs(
    IndexReader^ reader,
    String^ field,
    LongParser^ parser
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
Used to get field values.

field
Type:   Online System String
 Which field contains the longs.

parser
Type: Lucene.Net.Search LongParser
Computes integer for string values.

Return Value
 The values in the given field for each document.

See Also
FieldCache Interface
FieldCache Members
GetLongs Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetShorts Method

FieldCache GetShorts Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetShorts(IndexReader, String) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as shorts and returns an array of size reader.MaxDoc of the value each document has in the given field.
Public method | GetShorts(IndexReader, String, ShortParser) | Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as shorts and returns an array of size reader.MaxDoc of the value each document has in the given field.
Back to Top
See Also
FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetShorts Method (IndexReader, String)

FieldCache GetShorts Method (IndexReader, String) Lucene.Net Class Library
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as shorts and returns an array of size reader.MaxDoc of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
short[] GetShorts(
    IndexReader reader,
    string field
)
short[] GetShorts(
    IndexReader reader,
    string field
)
Function GetShorts ( _
    reader As IndexReader, _
    field As String _
) As Short()
Function GetShorts ( _
    reader As IndexReader, _
    field As String _
) As Short()
array<short>^ GetShorts(
    IndexReader^ reader,
    String^ field
)
array<short>^ GetShorts(
    IndexReader^ reader,
    String^ field
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
 Used to get field values.

field
Type:   Online System String
  Which field contains the shorts.

Return Value
 The values in the given field for each document.

See Also
FieldCache Interface
FieldCache Members
GetShorts Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetShorts Method (IndexReader, String, ShortParser)

FieldCache GetShorts Method (IndexReader, String, ShortParser) Lucene.Net Class Library
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in field as shorts and returns an array of size reader.MaxDoc of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
short[] GetShorts(
    IndexReader reader,
    string field,
    ShortParser parser
)
short[] GetShorts(
    IndexReader reader,
    string field,
    ShortParser parser
)
Function GetShorts ( _
    reader As IndexReader, _
    field As String, _
    parser As ShortParser _
) As Short()
Function GetShorts ( _
    reader As IndexReader, _
    field As String, _
    parser As ShortParser _
) As Short()
array<short>^ GetShorts(
    IndexReader^ reader,
    String^ field,
    ShortParser^ parser
)
array<short>^ GetShorts(
    IndexReader^ reader,
    String^ field,
    ShortParser^ parser
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
 Used to get field values.

field
Type:   Online System String
  Which field contains the shorts.

parser
Type: Lucene.Net.Search ShortParser
 Computes short for string values.

Return Value
 The values in the given field for each document.

See Also
FieldCache Interface
FieldCache Members
GetShorts Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetStringIndex Method

FieldCache GetStringIndex Method Lucene.Net Class Library
Checks the internal cache for an appropriate entry, and if none is found reads the term values in field and returns an array of them in natural order, along with an array telling which element in the term array each document uses.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
StringIndex GetStringIndex(
    IndexReader reader,
    string field
)
StringIndex GetStringIndex(
    IndexReader reader,
    string field
)
Function GetStringIndex ( _
    reader As IndexReader, _
    field As String _
) As StringIndex
Function GetStringIndex ( _
    reader As IndexReader, _
    field As String _
) As StringIndex
StringIndex^ GetStringIndex(
    IndexReader^ reader,
    String^ field
)
StringIndex^ GetStringIndex(
    IndexReader^ reader,
    String^ field
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
 Used to get field values.

field
Type:   Online System String
  Which field contains the strings.

Return Value
 Array of terms and index into the array for each document.

See Also
FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetStrings Method

FieldCache GetStrings Method Lucene.Net Class Library
Checks the internal cache for an appropriate entry, and if none is found, reads the term values in field and returns an array of size reader.MaxDoc containing the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string[] GetStrings(
    IndexReader reader,
    string field
)
string[] GetStrings(
    IndexReader reader,
    string field
)
Function GetStrings ( _
    reader As IndexReader, _
    field As String _
) As String()
Function GetStrings ( _
    reader As IndexReader, _
    field As String _
) As String()
array<String^>^ GetStrings(
    IndexReader^ reader,
    String^ field
)
array<String^>^ GetStrings(
    IndexReader^ reader,
    String^ field
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
 Used to get field values.

field
Type:   Online System String
  Which field contains the strings.

Return Value
 The values in the given field for each document.

See Also
FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Purge Method

FieldCache Purge Method Lucene.Net Class Library
Expert: drops all cache entries associated with this reader. NOTE: this reader must precisely match the reader that the cache entry is keyed on. If you pass a top-level reader, it usually will have no effect as Lucene now caches at the segment reader level.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Purge(
    IndexReader r
)
void Purge(
    IndexReader r
)
Sub Purge ( _
    r As IndexReader _
)
Sub Purge ( _
    r As IndexReader _
)
void Purge(
    IndexReader^ r
)
void Purge(
    IndexReader^ r
)
Parameters
r
Type: Lucene.Net.Index IndexReader
See Also
FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PurgeAllCaches Method

FieldCache PurgeAllCaches Method Lucene.Net Class Library

EXPERT: Instructs the FieldCache to forcibly expunge all entries from the underlying caches. This is intended only to be used for test methods as a way to ensure a known base state of the Cache (with out needing to rely on GC to free WeakReferences). It should not be relied on for "Cache maintenance" in general application code.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void PurgeAllCaches()
void PurgeAllCaches()
Sub PurgeAllCaches
Sub PurgeAllCaches
void PurgeAllCaches()
void PurgeAllCaches()
See Also
FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCache Properties

FieldCache Properties Lucene.Net Class Library
The FieldCache type exposes the following members.
Properties
 | Name | Description
Public property | InfoStream | Gets or sets the InfoStream for this FieldCache. If non-null, FieldCacheImpl will warn whenever entries are created that are not sane according to FieldCacheSanityChecker.
Back to Top
See Also
FieldCache Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


InfoStream Property

FieldCache InfoStream Property Lucene.Net Class Library
Gets or sets the InfoStream for this FieldCache.

If non-null, FieldCacheImpl will warn whenever entries are created that are not sane according to FieldCacheSanityChecker.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
StreamWriter InfoStream { get; set; }
StreamWriter InfoStream { get; set; }
Property InfoStream As StreamWriter
    Get
    Set
Property InfoStream As StreamWriter
    Get
    Set
property StreamWriter^ InfoStream {
    StreamWriter^ get ();
    void set (StreamWriter^ value);
}
property StreamWriter^ InfoStream {
    StreamWriter^ get ();
    void set (StreamWriter^ value);
}
See Also
FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCache_Fields Structure

FieldCache_Fields Structure Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct FieldCache_Fields
public struct FieldCache_Fields
Public Structure FieldCache_Fields
Public Structure FieldCache_Fields
public value class FieldCache_Fields
public value class FieldCache_Fields
See Also
FieldCache_Fields Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCache_Fields Members

FieldCache_Fields Members Lucene.Net Class Library

The FieldCache_Fields type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Fields
Name | Description
DEFAULT | Expert: The cache used internally by sorting and range query classes.
DEFAULT_BYTE_PARSER | The default parser for byte values, which are encoded by Online ToString
DEFAULT_DOUBLE_PARSER | The default parser for double values, which are encoded by Online ToString
DEFAULT_FLOAT_PARSER | The default parser for float values, which are encoded by Online ToString
DEFAULT_INT_PARSER | The default parser for int values, which are encoded by Online ToString
DEFAULT_LONG_PARSER | The default parser for long values, which are encoded by Online ToString
DEFAULT_SHORT_PARSER | The default parser for short values, which are encoded by Online ToString
NUMERIC_UTILS_DOUBLE_PARSER | A parser instance for double values encoded with NumericUtils, e.g. when indexed via NumericField/NumericTokenStream.
NUMERIC_UTILS_FLOAT_PARSER | A parser instance for float values encoded with NumericUtils, e.g. when indexed via NumericField/NumericTokenStream.
NUMERIC_UTILS_INT_PARSER | A parser instance for int values encoded by IntToPrefixCoded(Int32), e.g. when indexed via NumericField/NumericTokenStream.
NUMERIC_UTILS_LONG_PARSER | A parser instance for long values encoded by LongToPrefixCoded(Int64), e.g. when indexed via NumericField/NumericTokenStream.
STRING_INDEX | Indicator for StringIndex values in the cache.
Back to Top
See Also
FieldCache_Fields Structure
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCache_Fields Fields

FieldCache_Fields Fields Lucene.Net Class Library
The FieldCache_Fields type exposes the following members.
Fields
Name | Description
DEFAULT | Expert: The cache used internally by sorting and range query classes.
DEFAULT_BYTE_PARSER | The default parser for byte values, which are encoded by Online ToString
DEFAULT_DOUBLE_PARSER | The default parser for double values, which are encoded by Online ToString
DEFAULT_FLOAT_PARSER | The default parser for float values, which are encoded by Online ToString
DEFAULT_INT_PARSER | The default parser for int values, which are encoded by Online ToString
DEFAULT_LONG_PARSER | The default parser for long values, which are encoded by Online ToString
DEFAULT_SHORT_PARSER | The default parser for short values, which are encoded by Online ToString
NUMERIC_UTILS_DOUBLE_PARSER | A parser instance for double values encoded with NumericUtils, e.g. when indexed via NumericField/NumericTokenStream.
NUMERIC_UTILS_FLOAT_PARSER | A parser instance for float values encoded with NumericUtils, e.g. when indexed via NumericField/NumericTokenStream.
NUMERIC_UTILS_INT_PARSER | A parser instance for int values encoded by IntToPrefixCoded(Int32), e.g. when indexed via NumericField/NumericTokenStream.
NUMERIC_UTILS_LONG_PARSER | A parser instance for long values encoded by LongToPrefixCoded(Int64), e.g. when indexed via NumericField/NumericTokenStream.
STRING_INDEX | Indicator for StringIndex values in the cache.
Back to Top
See Also
FieldCache_Fields Structure
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT Field

FieldCache_Fields DEFAULT Field Lucene.Net Class Library
Expert: The cache used internally by sorting and range query classes.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly FieldCache DEFAULT
public static readonly FieldCache DEFAULT
Public Shared ReadOnly DEFAULT As FieldCache
Public Shared ReadOnly DEFAULT As FieldCache
public:
static initonly FieldCache^ DEFAULT
public:
static initonly FieldCache^ DEFAULT
See Also
FieldCache_Fields Structure
FieldCache_Fields Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_BYTE_PARSER Field

FieldCache_Fields DEFAULT_BYTE_PARSER Field Lucene.Net Class Library
The default parser for byte values, which are encoded by Online ToString

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ByteParser DEFAULT_BYTE_PARSER
public static readonly ByteParser DEFAULT_BYTE_PARSER
Public Shared ReadOnly DEFAULT_BYTE_PARSER As ByteParser
Public Shared ReadOnly DEFAULT_BYTE_PARSER As ByteParser
public:
static initonly ByteParser^ DEFAULT_BYTE_PARSER
public:
static initonly ByteParser^ DEFAULT_BYTE_PARSER
See Also
FieldCache_Fields Structure
FieldCache_Fields Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_DOUBLE_PARSER Field

FieldCache_Fields DEFAULT_DOUBLE_PARSER Field Lucene.Net Class Library
The default parser for double values, which are encoded by Online ToString

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly DoubleParser DEFAULT_DOUBLE_PARSER
public static readonly DoubleParser DEFAULT_DOUBLE_PARSER
Public Shared ReadOnly DEFAULT_DOUBLE_PARSER As DoubleParser
Public Shared ReadOnly DEFAULT_DOUBLE_PARSER As DoubleParser
public:
static initonly DoubleParser^ DEFAULT_DOUBLE_PARSER
public:
static initonly DoubleParser^ DEFAULT_DOUBLE_PARSER
See Also
FieldCache_Fields Structure
FieldCache_Fields Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_FLOAT_PARSER Field

FieldCache_Fields DEFAULT_FLOAT_PARSER Field Lucene.Net Class Library
The default parser for float values, which are encoded by Online ToString

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly FloatParser DEFAULT_FLOAT_PARSER
public static readonly FloatParser DEFAULT_FLOAT_PARSER
Public Shared ReadOnly DEFAULT_FLOAT_PARSER As FloatParser
Public Shared ReadOnly DEFAULT_FLOAT_PARSER As FloatParser
public:
static initonly FloatParser^ DEFAULT_FLOAT_PARSER
public:
static initonly FloatParser^ DEFAULT_FLOAT_PARSER
See Also
FieldCache_Fields Structure
FieldCache_Fields Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_INT_PARSER Field

FieldCache_Fields DEFAULT_INT_PARSER Field Lucene.Net Class Library
The default parser for int values, which are encoded by Online ToString

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IntParser DEFAULT_INT_PARSER
public static readonly IntParser DEFAULT_INT_PARSER
Public Shared ReadOnly DEFAULT_INT_PARSER As IntParser
Public Shared ReadOnly DEFAULT_INT_PARSER As IntParser
public:
static initonly IntParser^ DEFAULT_INT_PARSER
public:
static initonly IntParser^ DEFAULT_INT_PARSER
See Also
FieldCache_Fields Structure
FieldCache_Fields Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_LONG_PARSER Field

FieldCache_Fields DEFAULT_LONG_PARSER Field Lucene.Net Class Library
The default parser for long values, which are encoded by Online ToString

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly LongParser DEFAULT_LONG_PARSER
public static readonly LongParser DEFAULT_LONG_PARSER
Public Shared ReadOnly DEFAULT_LONG_PARSER As LongParser
Public Shared ReadOnly DEFAULT_LONG_PARSER As LongParser
public:
static initonly LongParser^ DEFAULT_LONG_PARSER
public:
static initonly LongParser^ DEFAULT_LONG_PARSER
See Also
FieldCache_Fields Structure
FieldCache_Fields Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_SHORT_PARSER Field

FieldCache_Fields DEFAULT_SHORT_PARSER Field Lucene.Net Class Library
The default parser for short values, which are encoded by Online ToString

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ShortParser DEFAULT_SHORT_PARSER
public static readonly ShortParser DEFAULT_SHORT_PARSER
Public Shared ReadOnly DEFAULT_SHORT_PARSER As ShortParser
Public Shared ReadOnly DEFAULT_SHORT_PARSER As ShortParser
public:
static initonly ShortParser^ DEFAULT_SHORT_PARSER
public:
static initonly ShortParser^ DEFAULT_SHORT_PARSER
See Also
FieldCache_Fields Structure
FieldCache_Fields Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NUMERIC_UTILS_DOUBLE_PARSER Field

FieldCache_Fields NUMERIC_UTILS_DOUBLE_PARSER Field Lucene.Net Class Library
A parser instance for double values encoded with NumericUtils, e.g. when indexed via NumericField/NumericTokenStream.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly DoubleParser NUMERIC_UTILS_DOUBLE_PARSER
public static readonly DoubleParser NUMERIC_UTILS_DOUBLE_PARSER
Public Shared ReadOnly NUMERIC_UTILS_DOUBLE_PARSER As DoubleParser
Public Shared ReadOnly NUMERIC_UTILS_DOUBLE_PARSER As DoubleParser
public:
static initonly DoubleParser^ NUMERIC_UTILS_DOUBLE_PARSER
public:
static initonly DoubleParser^ NUMERIC_UTILS_DOUBLE_PARSER
See Also
FieldCache_Fields Structure
FieldCache_Fields Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NUMERIC_UTILS_FLOAT_PARSER Field

FieldCache_Fields NUMERIC_UTILS_FLOAT_PARSER Field Lucene.Net Class Library
A parser instance for float values encoded with NumericUtils, e.g. when indexed via NumericField/NumericTokenStream.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly FloatParser NUMERIC_UTILS_FLOAT_PARSER
public static readonly FloatParser NUMERIC_UTILS_FLOAT_PARSER
Public Shared ReadOnly NUMERIC_UTILS_FLOAT_PARSER As FloatParser
Public Shared ReadOnly NUMERIC_UTILS_FLOAT_PARSER As FloatParser
public:
static initonly FloatParser^ NUMERIC_UTILS_FLOAT_PARSER
public:
static initonly FloatParser^ NUMERIC_UTILS_FLOAT_PARSER
See Also
FieldCache_Fields Structure
FieldCache_Fields Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NUMERIC_UTILS_INT_PARSER Field

FieldCache_Fields NUMERIC_UTILS_INT_PARSER Field Lucene.Net Class Library
A parser instance for int values encoded by IntToPrefixCoded(Int32), e.g. when indexed via NumericField/NumericTokenStream.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IntParser NUMERIC_UTILS_INT_PARSER
public static readonly IntParser NUMERIC_UTILS_INT_PARSER
Public Shared ReadOnly NUMERIC_UTILS_INT_PARSER As IntParser
Public Shared ReadOnly NUMERIC_UTILS_INT_PARSER As IntParser
public:
static initonly IntParser^ NUMERIC_UTILS_INT_PARSER
public:
static initonly IntParser^ NUMERIC_UTILS_INT_PARSER
See Also
FieldCache_Fields Structure
FieldCache_Fields Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NUMERIC_UTILS_LONG_PARSER Field

FieldCache_Fields NUMERIC_UTILS_LONG_PARSER Field Lucene.Net Class Library
A parser instance for long values encoded by LongToPrefixCoded(Int64), e.g. when indexed via NumericField/NumericTokenStream.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly LongParser NUMERIC_UTILS_LONG_PARSER
public static readonly LongParser NUMERIC_UTILS_LONG_PARSER
Public Shared ReadOnly NUMERIC_UTILS_LONG_PARSER As LongParser
Public Shared ReadOnly NUMERIC_UTILS_LONG_PARSER As LongParser
public:
static initonly LongParser^ NUMERIC_UTILS_LONG_PARSER
public:
static initonly LongParser^ NUMERIC_UTILS_LONG_PARSER
See Also
FieldCache_Fields Structure
FieldCache_Fields Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


STRING_INDEX Field

FieldCache_Fields STRING_INDEX Field Lucene.Net Class Library
Indicator for StringIndex values in the cache.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly int STRING_INDEX
public static readonly int STRING_INDEX
Public Shared ReadOnly STRING_INDEX As Integer
Public Shared ReadOnly STRING_INDEX As Integer
public:
static initonly int STRING_INDEX
public:
static initonly int STRING_INDEX
See Also
FieldCache_Fields Structure
FieldCache_Fields Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCache_Fields Methods

FieldCache_Fields Methods Lucene.Net Class Library
The FieldCache_Fields type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
See Also
FieldCache_Fields Structure
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheRangeFilter Class

FieldCacheRangeFilter Class Lucene.Net Class Library
A range filter built on top of a cached single term field (in FieldCache).

FieldCacheRangeFilter builds a single cache for the field the first time it is used. Each subsequent FieldCacheRangeFilter on the same field then reuses this cache, even if the range itself changes.

This means that FieldCacheRangeFilter is much faster (sometimes more than 100x as fast) as building a TermRangeFilter if using a NewStringRange(String, String, String, Boolean, Boolean). However, if the range never changes it is slower (around 2x as slow) than building a CachingWrapperFilter on top of a single TermRangeFilter. For numeric data types, this filter may be significantly faster than NumericRangeFilter T . Furthermore, it does not need the numeric values encoded by NumericField. But it has the problem that it only works with exact one value/document (see below).

As with all FieldCache based functionality, FieldCacheRangeFilter is only valid for fields which exact one term for each document (except for NewStringRange(String, String, String, Boolean, Boolean) where 0 terms are also allowed). Due to a restriction of FieldCache, for numeric ranges all terms that do not have a numeric value, 0 is assumed.

Thus it works on dates, prices and other single value fields but will not work on regular text fields. It is preferable to use a NOT_ANALYZED field to ensure that there is only a single term.

This class does not have an constructor, use one of the static factory methods available, that create a correct instance for different data types supported by FieldCache.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FieldCacheRangeFilter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class FieldCacheRangeFilter
public static class FieldCacheRangeFilter
Public NotInheritable Class FieldCacheRangeFilter
Public NotInheritable Class FieldCacheRangeFilter
public ref class FieldCacheRangeFilter abstract sealed
public ref class FieldCacheRangeFilter abstract sealed
See Also
FieldCacheRangeFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheRangeFilter Members

FieldCacheRangeFilter Members Lucene.Net Class Library

The FieldCacheRangeFilter type exposes the following members.
Methods
Name | Description
NewByteRange(String, Nullable SByte , Nullable SByte , Boolean, Boolean) | Creates a numeric range filter using GetBytes(IndexReader, String). This works with all byte fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewByteRange(String, ByteParser, Nullable SByte , Nullable SByte , Boolean, Boolean) | Creates a numeric range filter using GetBytes(IndexReader, String, ByteParser). This works with all byte fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewDoubleRange(String, Nullable Double , Nullable Double , Boolean, Boolean) | Creates a numeric range query using GetDoubles(IndexReader, String). This works with all double fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewDoubleRange(String, DoubleParser, Nullable Double , Nullable Double , Boolean, Boolean) | Creates a numeric range query using GetDoubles(IndexReader, String, DoubleParser). This works with all double fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewFloatRange(String, Nullable Single , Nullable Single , Boolean, Boolean) | Creates a numeric range query using GetFloats(IndexReader, String). This works with all float fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewFloatRange(String, FloatParser, Nullable Single , Nullable Single , Boolean, Boolean) | Creates a numeric range query using GetFloats(IndexReader, String, FloatParser). This works with all float fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewIntRange(String, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Creates a numeric range query using GetInts(IndexReader, String). This works with all int fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewIntRange(String, IntParser, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Creates a numeric range query using GetInts(IndexReader, String, IntParser). This works with all int fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewLongRange(String, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Creates a numeric range query using GetLongs(IndexReader, String). This works with all long fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewLongRange(String, LongParser, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Creates a numeric range query using GetLongs(IndexReader, String, LongParser). This works with all long fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewShortRange(String, Nullable Int16 , Nullable Int16 , Boolean, Boolean) | Creates a numeric range query using GetShorts(IndexReader, String). This works with all short fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewShortRange(String, ShortParser, Nullable Int16 , Nullable Int16 , Boolean, Boolean) | Creates a numeric range query using GetShorts(IndexReader, String, ShortParser). This works with all short fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewStringRange | Creates a string range filter using GetStringIndex(IndexReader, String). This works with all fields containing zero or one term in the field. The range can be half-open by setting one of the values to null.
Back to Top
See Also
FieldCacheRangeFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheRangeFilter Methods

FieldCacheRangeFilter Methods Lucene.Net Class Library
The FieldCacheRangeFilter type exposes the following members.
Methods
Name | Description
NewByteRange(String, Nullable SByte , Nullable SByte , Boolean, Boolean) | Creates a numeric range filter using GetBytes(IndexReader, String). This works with all byte fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewByteRange(String, ByteParser, Nullable SByte , Nullable SByte , Boolean, Boolean) | Creates a numeric range filter using GetBytes(IndexReader, String, ByteParser). This works with all byte fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewDoubleRange(String, Nullable Double , Nullable Double , Boolean, Boolean) | Creates a numeric range query using GetDoubles(IndexReader, String). This works with all double fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewDoubleRange(String, DoubleParser, Nullable Double , Nullable Double , Boolean, Boolean) | Creates a numeric range query using GetDoubles(IndexReader, String, DoubleParser). This works with all double fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewFloatRange(String, Nullable Single , Nullable Single , Boolean, Boolean) | Creates a numeric range query using GetFloats(IndexReader, String). This works with all float fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewFloatRange(String, FloatParser, Nullable Single , Nullable Single , Boolean, Boolean) | Creates a numeric range query using GetFloats(IndexReader, String, FloatParser). This works with all float fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewIntRange(String, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Creates a numeric range query using GetInts(IndexReader, String). This works with all int fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewIntRange(String, IntParser, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Creates a numeric range query using GetInts(IndexReader, String, IntParser). This works with all int fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewLongRange(String, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Creates a numeric range query using GetLongs(IndexReader, String). This works with all long fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewLongRange(String, LongParser, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Creates a numeric range query using GetLongs(IndexReader, String, LongParser). This works with all long fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewShortRange(String, Nullable Int16 , Nullable Int16 , Boolean, Boolean) | Creates a numeric range query using GetShorts(IndexReader, String). This works with all short fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewShortRange(String, ShortParser, Nullable Int16 , Nullable Int16 , Boolean, Boolean) | Creates a numeric range query using GetShorts(IndexReader, String, ShortParser). This works with all short fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewStringRange | Creates a string range filter using GetStringIndex(IndexReader, String). This works with all fields containing zero or one term in the field. The range can be half-open by setting one of the values to null.
Back to Top
See Also
FieldCacheRangeFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewByteRange Method

FieldCacheRangeFilter NewByteRange Method Lucene.Net Class Library
Overload List
Name | Description
NewByteRange(String, Nullable SByte , Nullable SByte , Boolean, Boolean) | Creates a numeric range filter using GetBytes(IndexReader, String). This works with all byte fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewByteRange(String, ByteParser, Nullable SByte , Nullable SByte , Boolean, Boolean) | Creates a numeric range filter using GetBytes(IndexReader, String, ByteParser). This works with all byte fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
Back to Top
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewByteRange Method (String, Nullable(SByte), Nullable(SByte), Boolean, Boolean)

FieldCacheRangeFilter NewByteRange Method (String, Nullable SByte , Nullable SByte , Boolean, Boolean) Lucene.Net Class Library
Creates a numeric range filter using GetBytes(IndexReader, String). This works with all byte fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldCacheRangeFilter<Nullable<sbyte>> NewByteRange(
    string field,
    Nullable<sbyte> lowerVal,
    Nullable<sbyte> upperVal,
    bool includeLower,
    bool includeUpper
)
public static FieldCacheRangeFilter<Nullable<sbyte>> NewByteRange(
    string field,
    Nullable<sbyte> lowerVal,
    Nullable<sbyte> upperVal,
    bool includeLower,
    bool includeUpper
)
Public Shared Function NewByteRange ( _
    field As String, _
    lowerVal As Nullable(Of SByte), _
    upperVal As Nullable(Of SByte), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of SByte))
Public Shared Function NewByteRange ( _
    field As String, _
    lowerVal As Nullable(Of SByte), _
    upperVal As Nullable(Of SByte), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of SByte))
public:
static FieldCacheRangeFilter<Nullable<signed char>>^ NewByteRange(
    String^ field,
    Nullable<signed char> lowerVal,
    Nullable<signed char> upperVal,
    bool includeLower,
    bool includeUpper
)
public:
static FieldCacheRangeFilter<Nullable<signed char>>^ NewByteRange(
    String^ field,
    Nullable<signed char> lowerVal,
    Nullable<signed char> upperVal,
    bool includeLower,
    bool includeUpper
)
Parameters
field
Type:   Online System String
lowerVal
Type:   Online System Nullable    Online SByte
upperVal
Type:   Online System Nullable    Online SByte
includeLower
Type:   Online System Boolean
includeUpper
Type:   Online System Boolean
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
NewByteRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewByteRange Method (String, ByteParser, Nullable(SByte), Nullable(SByte), Boolean, Boolean)

FieldCacheRangeFilter NewByteRange Method (String, ByteParser, Nullable SByte , Nullable SByte , Boolean, Boolean) Lucene.Net Class Library
Creates a numeric range filter using GetBytes(IndexReader, String, ByteParser). This works with all byte fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldCacheRangeFilter<Nullable<sbyte>> NewByteRange(
    string field,
    ByteParser parser,
    Nullable<sbyte> lowerVal,
    Nullable<sbyte> upperVal,
    bool includeLower,
    bool includeUpper
)
public static FieldCacheRangeFilter<Nullable<sbyte>> NewByteRange(
    string field,
    ByteParser parser,
    Nullable<sbyte> lowerVal,
    Nullable<sbyte> upperVal,
    bool includeLower,
    bool includeUpper
)
Public Shared Function NewByteRange ( _
    field As String, _
    parser As ByteParser, _
    lowerVal As Nullable(Of SByte), _
    upperVal As Nullable(Of SByte), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of SByte))
Public Shared Function NewByteRange ( _
    field As String, _
    parser As ByteParser, _
    lowerVal As Nullable(Of SByte), _
    upperVal As Nullable(Of SByte), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of SByte))
public:
static FieldCacheRangeFilter<Nullable<signed char>>^ NewByteRange(
    String^ field,
    ByteParser^ parser,
    Nullable<signed char> lowerVal,
    Nullable<signed char> upperVal,
    bool includeLower,
    bool includeUpper
)
public:
static FieldCacheRangeFilter<Nullable<signed char>>^ NewByteRange(
    String^ field,
    ByteParser^ parser,
    Nullable<signed char> lowerVal,
    Nullable<signed char> upperVal,
    bool includeLower,
    bool includeUpper
)
Parameters
field
Type:   Online System String
parser
Type: Lucene.Net.Search ByteParser
lowerVal
Type:   Online System Nullable    Online SByte
upperVal
Type:   Online System Nullable    Online SByte
includeLower
Type:   Online System Boolean
includeUpper
Type:   Online System Boolean
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
NewByteRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewDoubleRange Method

FieldCacheRangeFilter NewDoubleRange Method Lucene.Net Class Library
Overload List
Name | Description
NewDoubleRange(String, Nullable Double , Nullable Double , Boolean, Boolean) | Creates a numeric range query using GetDoubles(IndexReader, String). This works with all double fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewDoubleRange(String, DoubleParser, Nullable Double , Nullable Double , Boolean, Boolean) | Creates a numeric range query using GetDoubles(IndexReader, String, DoubleParser). This works with all double fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
Back to Top
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewDoubleRange Method (String, Nullable(Double), Nullable(Double), Boolean, Boolean)

FieldCacheRangeFilter NewDoubleRange Method (String, Nullable Double , Nullable Double , Boolean, Boolean) Lucene.Net Class Library
Creates a numeric range query using GetDoubles(IndexReader, String). This works with all double fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldCacheRangeFilter<Nullable<double>> NewDoubleRange(
    string field,
    Nullable<double> lowerVal,
    Nullable<double> upperVal,
    bool includeLower,
    bool includeUpper
)
public static FieldCacheRangeFilter<Nullable<double>> NewDoubleRange(
    string field,
    Nullable<double> lowerVal,
    Nullable<double> upperVal,
    bool includeLower,
    bool includeUpper
)
Public Shared Function NewDoubleRange ( _
    field As String, _
    lowerVal As Nullable(Of Double), _
    upperVal As Nullable(Of Double), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Double))
Public Shared Function NewDoubleRange ( _
    field As String, _
    lowerVal As Nullable(Of Double), _
    upperVal As Nullable(Of Double), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Double))
public:
static FieldCacheRangeFilter<Nullable<double>>^ NewDoubleRange(
    String^ field,
    Nullable<double> lowerVal,
    Nullable<double> upperVal,
    bool includeLower,
    bool includeUpper
)
public:
static FieldCacheRangeFilter<Nullable<double>>^ NewDoubleRange(
    String^ field,
    Nullable<double> lowerVal,
    Nullable<double> upperVal,
    bool includeLower,
    bool includeUpper
)
Parameters
field
Type:   Online System String
lowerVal
Type:   Online System Nullable    Online Double
upperVal
Type:   Online System Nullable    Online Double
includeLower
Type:   Online System Boolean
includeUpper
Type:   Online System Boolean
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
NewDoubleRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewDoubleRange Method (String, DoubleParser, Nullable(Double), Nullable(Double), Boolean, Boolean)

FieldCacheRangeFilter NewDoubleRange Method (String, DoubleParser, Nullable Double , Nullable Double , Boolean, Boolean) Lucene.Net Class Library
Creates a numeric range query using GetDoubles(IndexReader, String, DoubleParser). This works with all double fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldCacheRangeFilter<Nullable<double>> NewDoubleRange(
    string field,
    DoubleParser parser,
    Nullable<double> lowerVal,
    Nullable<double> upperVal,
    bool includeLower,
    bool includeUpper
)
public static FieldCacheRangeFilter<Nullable<double>> NewDoubleRange(
    string field,
    DoubleParser parser,
    Nullable<double> lowerVal,
    Nullable<double> upperVal,
    bool includeLower,
    bool includeUpper
)
Public Shared Function NewDoubleRange ( _
    field As String, _
    parser As DoubleParser, _
    lowerVal As Nullable(Of Double), _
    upperVal As Nullable(Of Double), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Double))
Public Shared Function NewDoubleRange ( _
    field As String, _
    parser As DoubleParser, _
    lowerVal As Nullable(Of Double), _
    upperVal As Nullable(Of Double), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Double))
public:
static FieldCacheRangeFilter<Nullable<double>>^ NewDoubleRange(
    String^ field,
    DoubleParser^ parser,
    Nullable<double> lowerVal,
    Nullable<double> upperVal,
    bool includeLower,
    bool includeUpper
)
public:
static FieldCacheRangeFilter<Nullable<double>>^ NewDoubleRange(
    String^ field,
    DoubleParser^ parser,
    Nullable<double> lowerVal,
    Nullable<double> upperVal,
    bool includeLower,
    bool includeUpper
)
Parameters
field
Type:   Online System String
parser
Type: Lucene.Net.Search DoubleParser
lowerVal
Type:   Online System Nullable    Online Double
upperVal
Type:   Online System Nullable    Online Double
includeLower
Type:   Online System Boolean
includeUpper
Type:   Online System Boolean
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
NewDoubleRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewFloatRange Method

FieldCacheRangeFilter NewFloatRange Method Lucene.Net Class Library
Overload List
Name | Description
NewFloatRange(String, Nullable Single , Nullable Single , Boolean, Boolean) | Creates a numeric range query using GetFloats(IndexReader, String). This works with all float fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewFloatRange(String, FloatParser, Nullable Single , Nullable Single , Boolean, Boolean) | Creates a numeric range query using GetFloats(IndexReader, String, FloatParser). This works with all float fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
Back to Top
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewFloatRange Method (String, Nullable(Single), Nullable(Single), Boolean, Boolean)

FieldCacheRangeFilter NewFloatRange Method (String, Nullable Single , Nullable Single , Boolean, Boolean) Lucene.Net Class Library
Creates a numeric range query using GetFloats(IndexReader, String). This works with all float fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldCacheRangeFilter<Nullable<float>> NewFloatRange(
    string field,
    Nullable<float> lowerVal,
    Nullable<float> upperVal,
    bool includeLower,
    bool includeUpper
)
public static FieldCacheRangeFilter<Nullable<float>> NewFloatRange(
    string field,
    Nullable<float> lowerVal,
    Nullable<float> upperVal,
    bool includeLower,
    bool includeUpper
)
Public Shared Function NewFloatRange ( _
    field As String, _
    lowerVal As Nullable(Of Single), _
    upperVal As Nullable(Of Single), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Single))
Public Shared Function NewFloatRange ( _
    field As String, _
    lowerVal As Nullable(Of Single), _
    upperVal As Nullable(Of Single), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Single))
public:
static FieldCacheRangeFilter<Nullable<float>>^ NewFloatRange(
    String^ field,
    Nullable<float> lowerVal,
    Nullable<float> upperVal,
    bool includeLower,
    bool includeUpper
)
public:
static FieldCacheRangeFilter<Nullable<float>>^ NewFloatRange(
    String^ field,
    Nullable<float> lowerVal,
    Nullable<float> upperVal,
    bool includeLower,
    bool includeUpper
)
Parameters
field
Type:   Online System String
lowerVal
Type:   Online System Nullable    Online Single
upperVal
Type:   Online System Nullable    Online Single
includeLower
Type:   Online System Boolean
includeUpper
Type:   Online System Boolean
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
NewFloatRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewFloatRange Method (String, FloatParser, Nullable(Single), Nullable(Single), Boolean, Boolean)

FieldCacheRangeFilter NewFloatRange Method (String, FloatParser, Nullable Single , Nullable Single , Boolean, Boolean) Lucene.Net Class Library
Creates a numeric range query using GetFloats(IndexReader, String, FloatParser). This works with all float fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldCacheRangeFilter<Nullable<float>> NewFloatRange(
    string field,
    FloatParser parser,
    Nullable<float> lowerVal,
    Nullable<float> upperVal,
    bool includeLower,
    bool includeUpper
)
public static FieldCacheRangeFilter<Nullable<float>> NewFloatRange(
    string field,
    FloatParser parser,
    Nullable<float> lowerVal,
    Nullable<float> upperVal,
    bool includeLower,
    bool includeUpper
)
Public Shared Function NewFloatRange ( _
    field As String, _
    parser As FloatParser, _
    lowerVal As Nullable(Of Single), _
    upperVal As Nullable(Of Single), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Single))
Public Shared Function NewFloatRange ( _
    field As String, _
    parser As FloatParser, _
    lowerVal As Nullable(Of Single), _
    upperVal As Nullable(Of Single), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Single))
public:
static FieldCacheRangeFilter<Nullable<float>>^ NewFloatRange(
    String^ field,
    FloatParser^ parser,
    Nullable<float> lowerVal,
    Nullable<float> upperVal,
    bool includeLower,
    bool includeUpper
)
public:
static FieldCacheRangeFilter<Nullable<float>>^ NewFloatRange(
    String^ field,
    FloatParser^ parser,
    Nullable<float> lowerVal,
    Nullable<float> upperVal,
    bool includeLower,
    bool includeUpper
)
Parameters
field
Type:   Online System String
parser
Type: Lucene.Net.Search FloatParser
lowerVal
Type:   Online System Nullable    Online Single
upperVal
Type:   Online System Nullable    Online Single
includeLower
Type:   Online System Boolean
includeUpper
Type:   Online System Boolean
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
NewFloatRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewIntRange Method

FieldCacheRangeFilter NewIntRange Method Lucene.Net Class Library
Overload List
Name | Description
NewIntRange(String, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Creates a numeric range query using GetInts(IndexReader, String). This works with all int fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewIntRange(String, IntParser, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Creates a numeric range query using GetInts(IndexReader, String, IntParser). This works with all int fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
Back to Top
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewIntRange Method (String, Nullable(Int32), Nullable(Int32), Boolean, Boolean)

FieldCacheRangeFilter NewIntRange Method (String, Nullable Int32 , Nullable Int32 , Boolean, Boolean) Lucene.Net Class Library
Creates a numeric range query using GetInts(IndexReader, String). This works with all int fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldCacheRangeFilter<Nullable<int>> NewIntRange(
    string field,
    Nullable<int> lowerVal,
    Nullable<int> upperVal,
    bool includeLower,
    bool includeUpper
)
public static FieldCacheRangeFilter<Nullable<int>> NewIntRange(
    string field,
    Nullable<int> lowerVal,
    Nullable<int> upperVal,
    bool includeLower,
    bool includeUpper
)
Public Shared Function NewIntRange ( _
    field As String, _
    lowerVal As Nullable(Of Integer), _
    upperVal As Nullable(Of Integer), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Integer))
Public Shared Function NewIntRange ( _
    field As String, _
    lowerVal As Nullable(Of Integer), _
    upperVal As Nullable(Of Integer), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Integer))
public:
static FieldCacheRangeFilter<Nullable<int>>^ NewIntRange(
    String^ field,
    Nullable<int> lowerVal,
    Nullable<int> upperVal,
    bool includeLower,
    bool includeUpper
)
public:
static FieldCacheRangeFilter<Nullable<int>>^ NewIntRange(
    String^ field,
    Nullable<int> lowerVal,
    Nullable<int> upperVal,
    bool includeLower,
    bool includeUpper
)
Parameters
field
Type:   Online System String
lowerVal
Type:   Online System Nullable    Online Int32
upperVal
Type:   Online System Nullable    Online Int32
includeLower
Type:   Online System Boolean
includeUpper
Type:   Online System Boolean
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
NewIntRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewIntRange Method (String, IntParser, Nullable(Int32), Nullable(Int32), Boolean, Boolean)

FieldCacheRangeFilter NewIntRange Method (String, IntParser, Nullable Int32 , Nullable Int32 , Boolean, Boolean) Lucene.Net Class Library
Creates a numeric range query using GetInts(IndexReader, String, IntParser). This works with all int fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldCacheRangeFilter<Nullable<int>> NewIntRange(
    string field,
    IntParser parser,
    Nullable<int> lowerVal,
    Nullable<int> upperVal,
    bool includeLower,
    bool includeUpper
)
public static FieldCacheRangeFilter<Nullable<int>> NewIntRange(
    string field,
    IntParser parser,
    Nullable<int> lowerVal,
    Nullable<int> upperVal,
    bool includeLower,
    bool includeUpper
)
Public Shared Function NewIntRange ( _
    field As String, _
    parser As IntParser, _
    lowerVal As Nullable(Of Integer), _
    upperVal As Nullable(Of Integer), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Integer))
Public Shared Function NewIntRange ( _
    field As String, _
    parser As IntParser, _
    lowerVal As Nullable(Of Integer), _
    upperVal As Nullable(Of Integer), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Integer))
public:
static FieldCacheRangeFilter<Nullable<int>>^ NewIntRange(
    String^ field,
    IntParser^ parser,
    Nullable<int> lowerVal,
    Nullable<int> upperVal,
    bool includeLower,
    bool includeUpper
)
public:
static FieldCacheRangeFilter<Nullable<int>>^ NewIntRange(
    String^ field,
    IntParser^ parser,
    Nullable<int> lowerVal,
    Nullable<int> upperVal,
    bool includeLower,
    bool includeUpper
)
Parameters
field
Type:   Online System String
parser
Type: Lucene.Net.Search IntParser
lowerVal
Type:   Online System Nullable    Online Int32
upperVal
Type:   Online System Nullable    Online Int32
includeLower
Type:   Online System Boolean
includeUpper
Type:   Online System Boolean
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
NewIntRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewLongRange Method

FieldCacheRangeFilter NewLongRange Method Lucene.Net Class Library
Overload List
Name | Description
NewLongRange(String, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Creates a numeric range query using GetLongs(IndexReader, String). This works with all long fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewLongRange(String, LongParser, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Creates a numeric range query using GetLongs(IndexReader, String, LongParser). This works with all long fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
Back to Top
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewLongRange Method (String, Nullable(Int64), Nullable(Int64), Boolean, Boolean)

FieldCacheRangeFilter NewLongRange Method (String, Nullable Int64 , Nullable Int64 , Boolean, Boolean) Lucene.Net Class Library
Creates a numeric range query using GetLongs(IndexReader, String). This works with all long fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldCacheRangeFilter<Nullable<long>> NewLongRange(
    string field,
    Nullable<long> lowerVal,
    Nullable<long> upperVal,
    bool includeLower,
    bool includeUpper
)
public static FieldCacheRangeFilter<Nullable<long>> NewLongRange(
    string field,
    Nullable<long> lowerVal,
    Nullable<long> upperVal,
    bool includeLower,
    bool includeUpper
)
Public Shared Function NewLongRange ( _
    field As String, _
    lowerVal As Nullable(Of Long), _
    upperVal As Nullable(Of Long), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Long))
Public Shared Function NewLongRange ( _
    field As String, _
    lowerVal As Nullable(Of Long), _
    upperVal As Nullable(Of Long), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Long))
public:
static FieldCacheRangeFilter<Nullable<long long>>^ NewLongRange(
    String^ field,
    Nullable<long long> lowerVal,
    Nullable<long long> upperVal,
    bool includeLower,
    bool includeUpper
)
public:
static FieldCacheRangeFilter<Nullable<long long>>^ NewLongRange(
    String^ field,
    Nullable<long long> lowerVal,
    Nullable<long long> upperVal,
    bool includeLower,
    bool includeUpper
)
Parameters
field
Type:   Online System String
lowerVal
Type:   Online System Nullable    Online Int64
upperVal
Type:   Online System Nullable    Online Int64
includeLower
Type:   Online System Boolean
includeUpper
Type:   Online System Boolean
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
NewLongRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewLongRange Method (String, LongParser, Nullable(Int64), Nullable(Int64), Boolean, Boolean)

FieldCacheRangeFilter NewLongRange Method (String, LongParser, Nullable Int64 , Nullable Int64 , Boolean, Boolean) Lucene.Net Class Library
Creates a numeric range query using GetLongs(IndexReader, String, LongParser). This works with all long fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldCacheRangeFilter<Nullable<long>> NewLongRange(
    string field,
    LongParser parser,
    Nullable<long> lowerVal,
    Nullable<long> upperVal,
    bool includeLower,
    bool includeUpper
)
public static FieldCacheRangeFilter<Nullable<long>> NewLongRange(
    string field,
    LongParser parser,
    Nullable<long> lowerVal,
    Nullable<long> upperVal,
    bool includeLower,
    bool includeUpper
)
Public Shared Function NewLongRange ( _
    field As String, _
    parser As LongParser, _
    lowerVal As Nullable(Of Long), _
    upperVal As Nullable(Of Long), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Long))
Public Shared Function NewLongRange ( _
    field As String, _
    parser As LongParser, _
    lowerVal As Nullable(Of Long), _
    upperVal As Nullable(Of Long), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Long))
public:
static FieldCacheRangeFilter<Nullable<long long>>^ NewLongRange(
    String^ field,
    LongParser^ parser,
    Nullable<long long> lowerVal,
    Nullable<long long> upperVal,
    bool includeLower,
    bool includeUpper
)
public:
static FieldCacheRangeFilter<Nullable<long long>>^ NewLongRange(
    String^ field,
    LongParser^ parser,
    Nullable<long long> lowerVal,
    Nullable<long long> upperVal,
    bool includeLower,
    bool includeUpper
)
Parameters
field
Type:   Online System String
parser
Type: Lucene.Net.Search LongParser
lowerVal
Type:   Online System Nullable    Online Int64
upperVal
Type:   Online System Nullable    Online Int64
includeLower
Type:   Online System Boolean
includeUpper
Type:   Online System Boolean
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
NewLongRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewShortRange Method

FieldCacheRangeFilter NewShortRange Method Lucene.Net Class Library
Overload List
Name | Description
NewShortRange(String, Nullable Int16 , Nullable Int16 , Boolean, Boolean) | Creates a numeric range query using GetShorts(IndexReader, String). This works with all short fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
NewShortRange(String, ShortParser, Nullable Int16 , Nullable Int16 , Boolean, Boolean) | Creates a numeric range query using GetShorts(IndexReader, String, ShortParser). This works with all short fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.
Back to Top
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewShortRange Method (String, Nullable(Int16), Nullable(Int16), Boolean, Boolean)

FieldCacheRangeFilter NewShortRange Method (String, Nullable Int16 , Nullable Int16 , Boolean, Boolean) Lucene.Net Class Library
Creates a numeric range query using GetShorts(IndexReader, String). This works with all short fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldCacheRangeFilter<Nullable<short>> NewShortRange(
    string field,
    Nullable<short> lowerVal,
    Nullable<short> upperVal,
    bool includeLower,
    bool includeUpper
)
public static FieldCacheRangeFilter<Nullable<short>> NewShortRange(
    string field,
    Nullable<short> lowerVal,
    Nullable<short> upperVal,
    bool includeLower,
    bool includeUpper
)
Public Shared Function NewShortRange ( _
    field As String, _
    lowerVal As Nullable(Of Short), _
    upperVal As Nullable(Of Short), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Short))
Public Shared Function NewShortRange ( _
    field As String, _
    lowerVal As Nullable(Of Short), _
    upperVal As Nullable(Of Short), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Short))
public:
static FieldCacheRangeFilter<Nullable<short>>^ NewShortRange(
    String^ field,
    Nullable<short> lowerVal,
    Nullable<short> upperVal,
    bool includeLower,
    bool includeUpper
)
public:
static FieldCacheRangeFilter<Nullable<short>>^ NewShortRange(
    String^ field,
    Nullable<short> lowerVal,
    Nullable<short> upperVal,
    bool includeLower,
    bool includeUpper
)
Parameters
field
Type:   Online System String
lowerVal
Type:   Online System Nullable    Online Int16
upperVal
Type:   Online System Nullable    Online Int16
includeLower
Type:   Online System Boolean
includeUpper
Type:   Online System Boolean
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
NewShortRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewShortRange Method (String, ShortParser, Nullable(Int16), Nullable(Int16), Boolean, Boolean)

FieldCacheRangeFilter NewShortRange Method (String, ShortParser, Nullable Int16 , Nullable Int16 , Boolean, Boolean) Lucene.Net Class Library
Creates a numeric range query using GetShorts(IndexReader, String, ShortParser). This works with all short fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to null.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldCacheRangeFilter<Nullable<short>> NewShortRange(
    string field,
    ShortParser parser,
    Nullable<short> lowerVal,
    Nullable<short> upperVal,
    bool includeLower,
    bool includeUpper
)
public static FieldCacheRangeFilter<Nullable<short>> NewShortRange(
    string field,
    ShortParser parser,
    Nullable<short> lowerVal,
    Nullable<short> upperVal,
    bool includeLower,
    bool includeUpper
)
Public Shared Function NewShortRange ( _
    field As String, _
    parser As ShortParser, _
    lowerVal As Nullable(Of Short), _
    upperVal As Nullable(Of Short), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Short))
Public Shared Function NewShortRange ( _
    field As String, _
    parser As ShortParser, _
    lowerVal As Nullable(Of Short), _
    upperVal As Nullable(Of Short), _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of Nullable(Of Short))
public:
static FieldCacheRangeFilter<Nullable<short>>^ NewShortRange(
    String^ field,
    ShortParser^ parser,
    Nullable<short> lowerVal,
    Nullable<short> upperVal,
    bool includeLower,
    bool includeUpper
)
public:
static FieldCacheRangeFilter<Nullable<short>>^ NewShortRange(
    String^ field,
    ShortParser^ parser,
    Nullable<short> lowerVal,
    Nullable<short> upperVal,
    bool includeLower,
    bool includeUpper
)
Parameters
field
Type:   Online System String
parser
Type: Lucene.Net.Search ShortParser
lowerVal
Type:   Online System Nullable    Online Int16
upperVal
Type:   Online System Nullable    Online Int16
includeLower
Type:   Online System Boolean
includeUpper
Type:   Online System Boolean
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
NewShortRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewStringRange Method

FieldCacheRangeFilter NewStringRange Method Lucene.Net Class Library
Creates a string range filter using GetStringIndex(IndexReader, String). This works with all fields containing zero or one term in the field. The range can be half-open by setting one of the values to null.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldCacheRangeFilter<string> NewStringRange(
    string field,
    string lowerVal,
    string upperVal,
    bool includeLower,
    bool includeUpper
)
public static FieldCacheRangeFilter<string> NewStringRange(
    string field,
    string lowerVal,
    string upperVal,
    bool includeLower,
    bool includeUpper
)
Public Shared Function NewStringRange ( _
    field As String, _
    lowerVal As String, _
    upperVal As String, _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of String)
Public Shared Function NewStringRange ( _
    field As String, _
    lowerVal As String, _
    upperVal As String, _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter(Of String)
public:
static FieldCacheRangeFilter<String^>^ NewStringRange(
    String^ field,
    String^ lowerVal,
    String^ upperVal,
    bool includeLower,
    bool includeUpper
)
public:
static FieldCacheRangeFilter<String^>^ NewStringRange(
    String^ field,
    String^ lowerVal,
    String^ upperVal,
    bool includeLower,
    bool includeUpper
)
Parameters
field
Type:   Online System String
lowerVal
Type:   Online System String
upperVal
Type:   Online System String
includeLower
Type:   Online System Boolean
includeUpper
Type:   Online System Boolean
See Also
FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheRangeFilter(T) Class

FieldCacheRangeFilter T Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Filter
Lucene.Net.Search FieldCacheRangeFilter T

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class FieldCacheRangeFilter<T> : Filter
[SerializableAttribute]
public abstract class FieldCacheRangeFilter<T> : Filter
<SerializableAttribute> _
Public MustInherit Class FieldCacheRangeFilter(Of T) _
    Inherits Filter
<SerializableAttribute> _
Public MustInherit Class FieldCacheRangeFilter(Of T) _
    Inherits Filter
[SerializableAttribute]
generic<typename T>
public ref class FieldCacheRangeFilter abstract : public Filter
[SerializableAttribute]
generic<typename T>
public ref class FieldCacheRangeFilter abstract : public Filter
Type Parameters
T
See Also
FieldCacheRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheRangeFilter(T) Members

FieldCacheRangeFilter T Members Lucene.Net Class Library

The FieldCacheRangeFilter T type exposes the following members.
Constructors
 | Name | Description
Protected method | FieldCacheRangeFilter T | Initializes a new instance of the FieldCacheRangeFilter T class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | This method is implemented for each data type (Overrides Filter GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | GetField | Returns the field name for this filter
Public property | IncludesLower | Returns true if the lower endpoint is inclusive
Public property | IncludesUpper | Returns true if the upper endpoint is inclusive
Public property | LowerValue | Returns the lower value of the range filter
Public property | Parser |
Public property | UpperValue | Returns the upper value of this range filter
Back to Top
See Also
FieldCacheRangeFilter T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheRangeFilter(T) Constructor

FieldCacheRangeFilter T Constructor Lucene.Net Class Library
Initializes a new instance of the FieldCacheRangeFilter T class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FieldCacheRangeFilter(
    string field,
    Parser parser,
    T lowerVal,
    T upperVal,
    bool includeLower,
    bool includeUpper
)
protected FieldCacheRangeFilter(
    string field,
    Parser parser,
    T lowerVal,
    T upperVal,
    bool includeLower,
    bool includeUpper
)
Protected Sub New ( _
    field As String, _
    parser As Parser, _
    lowerVal As T, _
    upperVal As T, _
    includeLower As Boolean, _
    includeUpper As Boolean _
)
Protected Sub New ( _
    field As String, _
    parser As Parser, _
    lowerVal As T, _
    upperVal As T, _
    includeLower As Boolean, _
    includeUpper As Boolean _
)
protected:
FieldCacheRangeFilter(
    String^ field,
    Parser^ parser,
    T lowerVal,
    T upperVal,
    bool includeLower,
    bool includeUpper
)
protected:
FieldCacheRangeFilter(
    String^ field,
    Parser^ parser,
    T lowerVal,
    T upperVal,
    bool includeLower,
    bool includeUpper
)
Parameters
field
Type:   Online System String
parser
Type: Lucene.Net.Search Parser
lowerVal
Type: T
upperVal
Type: T
includeLower
Type:   Online System Boolean
includeUpper
Type:   Online System Boolean
See Also
FieldCacheRangeFilter T  Class
FieldCacheRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheRangeFilter(T) Methods

FieldCacheRangeFilter T Methods Lucene.Net Class Library
The FieldCacheRangeFilter T type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | This method is implemented for each data type (Overrides Filter GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
FieldCacheRangeFilter T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

FieldCacheRangeFilter T Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
FieldCacheRangeFilter T  Class
FieldCacheRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetDocIdSet Method

FieldCacheRangeFilter T GetDocIdSet Method Lucene.Net Class Library
This method is implemented for each data type

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract DocIdSet GetDocIdSet(
    IndexReader reader
)
public abstract DocIdSet GetDocIdSet(
    IndexReader reader
)
Public MustOverride Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Public MustOverride Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) abstract override
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) abstract override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
FieldCacheRangeFilter T  Class
FieldCacheRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

FieldCacheRangeFilter T GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
FieldCacheRangeFilter T  Class
FieldCacheRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

FieldCacheRangeFilter T ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
FieldCacheRangeFilter T  Class
FieldCacheRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheRangeFilter(T) Properties

FieldCacheRangeFilter T Properties Lucene.Net Class Library
The FieldCacheRangeFilter T type exposes the following members.
Properties
 | Name | Description
Public property | GetField | Returns the field name for this filter
Public property | IncludesLower | Returns true if the lower endpoint is inclusive
Public property | IncludesUpper | Returns true if the upper endpoint is inclusive
Public property | LowerValue | Returns the lower value of the range filter
Public property | Parser |
Public property | UpperValue | Returns the upper value of this range filter
Back to Top
See Also
FieldCacheRangeFilter T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetField Property

FieldCacheRangeFilter T GetField Property Lucene.Net Class Library
Returns the field name for this filter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetField { get; }
public string GetField { get; }
Public ReadOnly Property GetField As String
    Get
Public ReadOnly Property GetField As String
    Get
public:
property String^ GetField {
    String^ get ();
}
public:
property String^ GetField {
    String^ get ();
}
See Also
FieldCacheRangeFilter T  Class
FieldCacheRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncludesLower Property

FieldCacheRangeFilter T IncludesLower Property Lucene.Net Class Library
Returns true if the lower endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IncludesLower { get; }
public bool IncludesLower { get; }
Public ReadOnly Property IncludesLower As Boolean
    Get
Public ReadOnly Property IncludesLower As Boolean
    Get
public:
property bool IncludesLower {
    bool get ();
}
public:
property bool IncludesLower {
    bool get ();
}
See Also
FieldCacheRangeFilter T  Class
FieldCacheRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncludesUpper Property

FieldCacheRangeFilter T IncludesUpper Property Lucene.Net Class Library
Returns true if the upper endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IncludesUpper { get; }
public bool IncludesUpper { get; }
Public ReadOnly Property IncludesUpper As Boolean
    Get
Public ReadOnly Property IncludesUpper As Boolean
    Get
public:
property bool IncludesUpper {
    bool get ();
}
public:
property bool IncludesUpper {
    bool get ();
}
See Also
FieldCacheRangeFilter T  Class
FieldCacheRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerValue Property

FieldCacheRangeFilter T LowerValue Property Lucene.Net Class Library
Returns the lower value of the range filter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T LowerValue { get; }
public T LowerValue { get; }
Public ReadOnly Property LowerValue As T
    Get
Public ReadOnly Property LowerValue As T
    Get
public:
property T LowerValue {
    T get ();
}
public:
property T LowerValue {
    T get ();
}
See Also
FieldCacheRangeFilter T  Class
FieldCacheRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Parser Property

FieldCacheRangeFilter T Parser Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Parser Parser { get; }
public Parser Parser { get; }
Public ReadOnly Property Parser As Parser
    Get
Public ReadOnly Property Parser As Parser
    Get
public:
property Parser^ Parser {
    Parser^ get ();
}
public:
property Parser^ Parser {
    Parser^ get ();
}
See Also
FieldCacheRangeFilter T  Class
FieldCacheRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UpperValue Property

FieldCacheRangeFilter T UpperValue Property Lucene.Net Class Library
Returns the upper value of this range filter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T UpperValue { get; }
public T UpperValue { get; }
Public ReadOnly Property UpperValue As T
    Get
Public ReadOnly Property UpperValue As T
    Get
public:
property T UpperValue {
    T get ();
}
public:
property T UpperValue {
    T get ();
}
See Also
FieldCacheRangeFilter T  Class
FieldCacheRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheTermsFilter Class

FieldCacheTermsFilter Class Lucene.Net Class Library
A Filter that only accepts documents whose single term value in the specified field is contained in the provided set of allowed terms.

This is the same functionality as TermsFilter (from contrib/queries), except this filter requires that the field contains only a single term for all documents. Because of drastically different implementations, they also have different performance characteristics, as described below.

The first invocation of this filter on a given field will be slower, since a StringIndex must be created. Subsequent invocations using the same field will re-use this cache. However, as with all functionality based on FieldCache, persistent RAM is consumed to hold the cache, and is not freed until the IndexReader is closed. In contrast, TermsFilter has no persistent RAM consumption.

With each search, this filter translates the specified set of Terms into a private OpenBitSet keyed by term number per unique IndexReader (normally one reader per segment). Then, during matching, the term number for each docID is retrieved from the cache and then checked for inclusion using the OpenBitSet. Since all testing is done using RAM resident data structures, performance should be very fast, most likely fast enough to not require further caching of the DocIdSet for each possible combination of terms. However, because docIDs are simply scanned linearly, an index with a great many small documents may find this linear scan too costly.

In contrast, TermsFilter builds up an OpenBitSet, keyed by docID, every time it's created, by enumerating through all matching docs using TermDocs to seek and scan through each term's docID list. While there is no linear scan of all docIDs, besides the allocation of the underlying array in the OpenBitSet, this approach requires a number of "disk seeks" in proportion to the number of terms, which can be exceptionally costly when there are cache misses in the OS's IO cache.

Generally, this filter will be slower on the first invocation for a given field, but subsequent invocations, even if you change the allowed set of Terms, should be faster than TermsFilter, especially as the number of Terms being matched increases. If you are matching only a very small number of terms, and those terms in turn match a very small number of documents, TermsFilter may perform faster.

Which filter is best is very application dependent.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Filter
Lucene.Net.Search FieldCacheTermsFilter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FieldCacheTermsFilter : Filter
[SerializableAttribute]
public class FieldCacheTermsFilter : Filter
<SerializableAttribute> _
Public Class FieldCacheTermsFilter _
    Inherits Filter
<SerializableAttribute> _
Public Class FieldCacheTermsFilter _
    Inherits Filter
[SerializableAttribute]
public ref class FieldCacheTermsFilter : public Filter
[SerializableAttribute]
public ref class FieldCacheTermsFilter : public Filter
See Also
FieldCacheTermsFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheTermsFilter Members

FieldCacheTermsFilter Members Lucene.Net Class Library

The FieldCacheTermsFilter type exposes the following members.
Constructors
 | Name | Description
Public method | FieldCacheTermsFilter | Initializes a new instance of the FieldCacheTermsFilter class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Overrides Filter GetDocIdSet(IndexReader).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | FieldCache |
Back to Top
See Also
FieldCacheTermsFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheTermsFilter Constructor

FieldCacheTermsFilter Constructor Lucene.Net Class Library
Initializes a new instance of the FieldCacheTermsFilter class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldCacheTermsFilter(
    string field,
    params string[] terms
)
public FieldCacheTermsFilter(
    string field,
    params string[] terms
)
Public Sub New ( _
    field As String, _
    ParamArray terms As String() _
)
Public Sub New ( _
    field As String, _
    ParamArray terms As String() _
)
public:
FieldCacheTermsFilter(
    String^ field,
    ... array<String^>^ terms
)
public:
FieldCacheTermsFilter(
    String^ field,
    ... array<String^>^ terms
)
Parameters
field
Type:   Online System String
terms
Type:    Online System String
See Also
FieldCacheTermsFilter Class
FieldCacheTermsFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheTermsFilter Methods

FieldCacheTermsFilter Methods Lucene.Net Class Library
The FieldCacheTermsFilter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Overrides Filter GetDocIdSet(IndexReader).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldCacheTermsFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetDocIdSet Method

FieldCacheTermsFilter GetDocIdSet Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
FieldCacheTermsFilter Class
FieldCacheTermsFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheTermsFilter Properties

FieldCacheTermsFilter Properties Lucene.Net Class Library
The FieldCacheTermsFilter type exposes the following members.
Properties
 | Name | Description
Public property | FieldCache |
Back to Top
See Also
FieldCacheTermsFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCache Property

FieldCacheTermsFilter FieldCache Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual FieldCache FieldCache { get; }
public virtual FieldCache FieldCache { get; }
Public Overridable ReadOnly Property FieldCache As FieldCache
    Get
Public Overridable ReadOnly Property FieldCache As FieldCache
    Get
public:
virtual property FieldCache^ FieldCache {
    FieldCache^ get ();
}
public:
virtual property FieldCache^ FieldCache {
    FieldCache^ get ();
}
See Also
FieldCacheTermsFilter Class
FieldCacheTermsFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet Class

FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSet
Lucene.Net.Search FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal class FieldCacheTermsFilterDocIdSet : DocIdSet
protected internal class FieldCacheTermsFilterDocIdSet : DocIdSet
Protected Friend Class FieldCacheTermsFilterDocIdSet _
    Inherits DocIdSet
Protected Friend Class FieldCacheTermsFilterDocIdSet _
    Inherits DocIdSet
protected public ref class FieldCacheTermsFilterDocIdSet : public DocIdSet
protected public ref class FieldCacheTermsFilterDocIdSet : public DocIdSet
See Also
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet Members

FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Members Lucene.Net Class Library

A Filter that only accepts documents whose single term value in the specified field is contained in the provided set of allowed terms.

This is the same functionality as TermsFilter (from contrib/queries), except this filter requires that the field contains only a single term for all documents. Because of drastically different implementations, they also have different performance characteristics, as described below.

The first invocation of this filter on a given field will be slower, since a StringIndex must be created. Subsequent invocations using the same field will re-use this cache. However, as with all functionality based on FieldCache, persistent RAM is consumed to hold the cache, and is not freed until the IndexReader is closed. In contrast, TermsFilter has no persistent RAM consumption.

With each search, this filter translates the specified set of Terms into a private OpenBitSet keyed by term number per unique IndexReader (normally one reader per segment). Then, during matching, the term number for each docID is retrieved from the cache and then checked for inclusion using the OpenBitSet. Since all testing is done using RAM resident data structures, performance should be very fast, most likely fast enough to not require further caching of the DocIdSet for each possible combination of terms. However, because docIDs are simply scanned linearly, an index with a great many small documents may find this linear scan too costly.

In contrast, TermsFilter builds up an OpenBitSet, keyed by docID, every time it's created, by enumerating through all matching docs using TermDocs to seek and scan through each term's docID list. While there is no linear scan of all docIDs, besides the allocation of the underlying array in the OpenBitSet, this approach requires a number of "disk seeks" in proportion to the number of terms, which can be exceptionally costly when there are cache misses in the OS's IO cache.

Generally, this filter will be slower on the first invocation for a given field, but subsequent invocations, even if you change the allowed set of Terms, should be faster than TermsFilter, especially as the number of Terms being matched increases. If you are matching only a very small number of terms, and those terms in turn match a very small number of documents, TermsFilter may perform faster.

Which filter is best is very application dependent.

The FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet type exposes the following members.
Constructors
 | Name | Description
Public method | FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet | Initializes a new instance of the FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Iterator | (Overrides DocIdSet Iterator .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | IsCacheable | This DocIdSet implementation is cacheable. (Overrides DocIdSet IsCacheable.)
Back to Top
See Also
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet Constructor

FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Constructor Lucene.Net Class Library
Initializes a new instance of the FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldCacheTermsFilterDocIdSet(
    FieldCacheTermsFilter enclosingInstance,
    StringIndex fcsi
)
public FieldCacheTermsFilterDocIdSet(
    FieldCacheTermsFilter enclosingInstance,
    StringIndex fcsi
)
Public Sub New ( _
    enclosingInstance As FieldCacheTermsFilter, _
    fcsi As StringIndex _
)
Public Sub New ( _
    enclosingInstance As FieldCacheTermsFilter, _
    fcsi As StringIndex _
)
public:
FieldCacheTermsFilterDocIdSet(
    FieldCacheTermsFilter^ enclosingInstance,
    StringIndex^ fcsi
)
public:
FieldCacheTermsFilterDocIdSet(
    FieldCacheTermsFilter^ enclosingInstance,
    StringIndex^ fcsi
)
Parameters
enclosingInstance
Type: Lucene.Net.Search FieldCacheTermsFilter
fcsi
Type: Lucene.Net.Search StringIndex
See Also
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Class
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet Methods

FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Methods Lucene.Net Class Library
The FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Iterator | (Overrides DocIdSet Iterator .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Iterator Method

FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Iterator Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocIdSetIterator Iterator()
public override DocIdSetIterator Iterator()
Public Overrides Function Iterator As DocIdSetIterator
Public Overrides Function Iterator As DocIdSetIterator
public:
virtual DocIdSetIterator^ Iterator() override
public:
virtual DocIdSetIterator^ Iterator() override
See Also
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Class
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet Properties

FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Properties Lucene.Net Class Library
The FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet type exposes the following members.
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | IsCacheable | This DocIdSet implementation is cacheable. (Overrides DocIdSet IsCacheable.)
Back to Top
See Also
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Enclosing_Instance Property

FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Enclosing_Instance Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldCacheTermsFilter Enclosing_Instance { get; }
public FieldCacheTermsFilter Enclosing_Instance { get; }
Public ReadOnly Property Enclosing_Instance As FieldCacheTermsFilter
    Get
Public ReadOnly Property Enclosing_Instance As FieldCacheTermsFilter
    Get
public:
property FieldCacheTermsFilter^ Enclosing_Instance {
    FieldCacheTermsFilter^ get ();
}
public:
property FieldCacheTermsFilter^ Enclosing_Instance {
    FieldCacheTermsFilter^ get ();
}
See Also
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Class
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsCacheable Property

FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet IsCacheable Property Lucene.Net Class Library
This DocIdSet implementation is cacheable.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsCacheable { get; }
public override bool IsCacheable { get; }
Public Overrides ReadOnly Property IsCacheable As Boolean
    Get
Public Overrides ReadOnly Property IsCacheable As Boolean
    Get
public:
virtual property bool IsCacheable {
    bool get () override;
}
public:
virtual property bool IsCacheable {
    bool get () override;
}
See Also
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Class
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator Class

FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSetIterator
Lucene.Net.Search FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal class FieldCacheTermsFilterDocIdSetIterator : DocIdSetIterator
protected internal class FieldCacheTermsFilterDocIdSetIterator : DocIdSetIterator
Protected Friend Class FieldCacheTermsFilterDocIdSetIterator _
    Inherits DocIdSetIterator
Protected Friend Class FieldCacheTermsFilterDocIdSetIterator _
    Inherits DocIdSetIterator
protected public ref class FieldCacheTermsFilterDocIdSetIterator : public DocIdSetIterator
protected public ref class FieldCacheTermsFilterDocIdSetIterator : public DocIdSetIterator
See Also
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator Members

FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Members Lucene.Net Class Library

The FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator type exposes the following members.
Constructors
 | Name | Description
Public method | FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator | Initializes a new instance of the FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator class
Back to Top
Methods
 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Overrides DocIdSetIterator NextDoc .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Enclosing_Instance |
Back to Top
See Also
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator Constructor

FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Constructor Lucene.Net Class Library
Initializes a new instance of the FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldCacheTermsFilterDocIdSetIterator(
    FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet enclosingInstance
)
public FieldCacheTermsFilterDocIdSetIterator(
    FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet enclosingInstance
)
Public Sub New ( _
    enclosingInstance As FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet _
)
Public Sub New ( _
    enclosingInstance As FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet _
)
public:
FieldCacheTermsFilterDocIdSetIterator(
    FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet^ enclosingInstance
)
public:
FieldCacheTermsFilterDocIdSetIterator(
    FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet^ enclosingInstance
)
Parameters
enclosingInstance
Type: Lucene.Net.Search FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet
See Also
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Class
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator Methods

FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Methods Lucene.Net Class Library
The FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator type exposes the following members.
Methods
 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Overrides DocIdSetIterator NextDoc .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Advance Method

FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Advance Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Advance(
    int target
)
public override int Advance(
    int target
)
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
public:
virtual int Advance(
    int target
) override
public:
virtual int Advance(
    int target
) override
Parameters
target
Type:   Online System Int32
See Also
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Class
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocID Method

FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator DocID Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocID()
public override int DocID()
Public Overrides Function DocID As Integer
Public Overrides Function DocID As Integer
public:
virtual int DocID() override
public:
virtual int DocID() override
See Also
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Class
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextDoc Method

FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator NextDoc Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int NextDoc()
public override int NextDoc()
Public Overrides Function NextDoc As Integer
Public Overrides Function NextDoc As Integer
public:
virtual int NextDoc() override
public:
virtual int NextDoc() override
See Also
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Class
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator Properties

FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Properties Lucene.Net Class Library
The FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator type exposes the following members.
Properties
 | Name | Description
Public property | Enclosing_Instance |
Back to Top
See Also
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Enclosing_Instance Property

FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Enclosing_Instance Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Enclosing_Instance { get; }
public FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Enclosing_Instance { get; }
Public ReadOnly Property Enclosing_Instance As FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet
    Get
Public ReadOnly Property Enclosing_Instance As FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet
    Get
public:
property FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet^ Enclosing_Instance {
    FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet^ get ();
}
public:
property FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet^ Enclosing_Instance {
    FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet^ get ();
}
See Also
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Class
FieldCacheTermsFilter FieldCacheTermsFilterDocIdSet FieldCacheTermsFilterDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator Class

FieldComparator Class Lucene.Net Class Library
Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with TopFieldCollector . The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with FieldValueHitQueue as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The FieldComparator is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • Compare(Int32, Int32) Compare a hit at 'slot a' with hit 'slot b'.
  • SetBottom(Int32) This method is called by FieldValueHitQueue to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • CompareBottom(Int32) Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • Copy(Int32, Int32) Installs a new hit into the priority queue. The FieldValueHitQueue calls this method when a new hit is competitive.
  • SetNextReader(IndexReader, Int32) Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the FieldCache.
  • Item Int32 Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate fields when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FieldComparator
Lucene.Net.Search FieldComparator ByteComparator
Lucene.Net.Search FieldComparator DocComparator
Lucene.Net.Search FieldComparator DoubleComparator
Lucene.Net.Search FieldComparator FloatComparator
Lucene.Net.Search FieldComparator IntComparator
Lucene.Net.Search FieldComparator LongComparator
Lucene.Net.Search FieldComparator RelevanceComparator
Lucene.Net.Search FieldComparator ShortComparator
Lucene.Net.Search FieldComparator StringComparatorLocale
Lucene.Net.Search FieldComparator StringOrdValComparator
Lucene.Net.Search FieldComparator StringValComparator

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class FieldComparator
public abstract class FieldComparator
Public MustInherit Class FieldComparator
Public MustInherit Class FieldComparator
public ref class FieldComparator abstract
public ref class FieldComparator abstract
See Also
FieldComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator Members

FieldComparator Members Lucene.Net Class Library

The FieldComparator type exposes the following members.
Constructors
 | Name | Description
Protected method | FieldComparator | Initializes a new instance of the FieldComparator class
Back to Top
Methods
 | Name | Description
 | BinarySearch( String , String) |
 | BinarySearch( String , String, Int32, Int32) |
Public method | Compare | Compare hit at slot1 with hit at slot2.
Public method | CompareBottom | Compare the bottom of the queue with doc. This will only invoked after setBottom has been called. This should return the same result as Compare(Int32, Int32) } as if bottom were slot1 and the new document were slot 2. For a search that hits many results, this method will be the hotspot (invoked by far the most frequently).
Public method | Copy | This method is called when a new hit is competitive. You should copy any state associated with this document that will be required for future comparisons, into the specified slot.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | Set the bottom slot, ie the "weakest" (sorted last) entry in the queue. When CompareBottom(Int32) is called, you should compare against this slot. This will always be called before CompareBottom(Int32).
Public method | SetNextReader | Set a new Reader. All doc correspond to the current Reader.
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | Return the actual value in the slot.
Back to Top
See Also
FieldComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator Constructor

FieldComparator Constructor Lucene.Net Class Library
Initializes a new instance of the FieldComparator class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FieldComparator()
protected FieldComparator()
Protected Sub New
Protected Sub New
protected:
FieldComparator()
protected:
FieldComparator()
See Also
FieldComparator Class
FieldComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator Methods

FieldComparator Methods Lucene.Net Class Library
The FieldComparator type exposes the following members.
Methods
 | Name | Description
 | BinarySearch( String , String) |
 | BinarySearch( String , String, Int32, Int32) |
Public method | Compare | Compare hit at slot1 with hit at slot2.
Public method | CompareBottom | Compare the bottom of the queue with doc. This will only invoked after setBottom has been called. This should return the same result as Compare(Int32, Int32) } as if bottom were slot1 and the new document were slot 2. For a search that hits many results, this method will be the hotspot (invoked by far the most frequently).
Public method | Copy | This method is called when a new hit is competitive. You should copy any state associated with this document that will be required for future comparisons, into the specified slot.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | Set the bottom slot, ie the "weakest" (sorted last) entry in the queue. When CompareBottom(Int32) is called, you should compare against this slot. This will always be called before CompareBottom(Int32).
Public method | SetNextReader | Set a new Reader. All doc correspond to the current Reader.
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BinarySearch Method

FieldComparator BinarySearch Method Lucene.Net Class Library
Overload List
Name | Description
BinarySearch( String , String) |
BinarySearch( String , String, Int32, Int32) |
Back to Top
See Also
FieldComparator Class
FieldComparator Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BinarySearch Method (String[], String)

FieldComparator BinarySearch Method ( String , String) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static int BinarySearch(
    string[] a,
    string key
)
protected static int BinarySearch(
    string[] a,
    string key
)
Protected Shared Function BinarySearch ( _
    a As String(), _
    key As String _
) As Integer
Protected Shared Function BinarySearch ( _
    a As String(), _
    key As String _
) As Integer
protected:
static int BinarySearch(
    array<String^>^ a,
    String^ key
)
protected:
static int BinarySearch(
    array<String^>^ a,
    String^ key
)
Parameters
a
Type:    Online System String
key
Type:   Online System String
See Also
FieldComparator Class
FieldComparator Members
BinarySearch Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BinarySearch Method (String[], String, Int32, Int32)

FieldComparator BinarySearch Method ( String , String, Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static int BinarySearch(
    string[] a,
    string key,
    int low,
    int high
)
protected static int BinarySearch(
    string[] a,
    string key,
    int low,
    int high
)
Protected Shared Function BinarySearch ( _
    a As String(), _
    key As String, _
    low As Integer, _
    high As Integer _
) As Integer
Protected Shared Function BinarySearch ( _
    a As String(), _
    key As String, _
    low As Integer, _
    high As Integer _
) As Integer
protected:
static int BinarySearch(
    array<String^>^ a,
    String^ key,
    int low,
    int high
)
protected:
static int BinarySearch(
    array<String^>^ a,
    String^ key,
    int low,
    int high
)
Parameters
a
Type:    Online System String
key
Type:   Online System String
low
Type:   Online System Int32
high
Type:   Online System Int32
See Also
FieldComparator Class
FieldComparator Members
BinarySearch Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Method

FieldComparator Compare Method Lucene.Net Class Library
Compare hit at slot1 with hit at slot2.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int Compare(
    int slot1,
    int slot2
)
public abstract int Compare(
    int slot1,
    int slot2
)
Public MustOverride Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Public MustOverride Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
public:
virtual int Compare(
    int slot1,
    int slot2
) abstract
public:
virtual int Compare(
    int slot1,
    int slot2
) abstract
Parameters
slot1
Type:   Online System Int32
first slot to compare

slot2
Type:   Online System Int32
second slot to compare

Return Value
 any N < 0 if slot2's value is sorted after
            slot1, any N > 0 if the slot2's value is sorted before
            slot1 and 0 if they are equal

See Also
FieldComparator Class
FieldComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompareBottom Method

FieldComparator CompareBottom Method Lucene.Net Class Library
Compare the bottom of the queue with doc. This will only invoked after setBottom has been called. This should return the same result as Compare(Int32, Int32) } as if bottom were slot1 and the new document were slot 2.

For a search that hits many results, this method will be the hotspot (invoked by far the most frequently).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int CompareBottom(
    int doc
)
public abstract int CompareBottom(
    int doc
)
Public MustOverride Function CompareBottom ( _
    doc As Integer _
) As Integer
Public MustOverride Function CompareBottom ( _
    doc As Integer _
) As Integer
public:
virtual int CompareBottom(
    int doc
) abstract
public:
virtual int CompareBottom(
    int doc
) abstract
Parameters
doc
Type:   Online System Int32
that was hit

Return Value
 any N < 0 if the doc's value is sorted after
             the bottom entry (not competitive), any N > 0 if the
             doc's value is sorted before the bottom entry and 0 if
             they are equal.

See Also
FieldComparator Class
FieldComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Copy Method

FieldComparator Copy Method Lucene.Net Class Library
This method is called when a new hit is competitive. You should copy any state associated with this document that will be required for future comparisons, into the specified slot.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Copy(
    int slot,
    int doc
)
public abstract void Copy(
    int slot,
    int doc
)
Public MustOverride Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Public MustOverride Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
public:
virtual void Copy(
    int slot,
    int doc
) abstract
public:
virtual void Copy(
    int slot,
    int doc
) abstract
Parameters
slot
Type:   Online System Int32
which slot to copy the hit to

doc
Type:   Online System Int32
docID relative to current reader

See Also
FieldComparator Class
FieldComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetBottom Method

FieldComparator SetBottom Method Lucene.Net Class Library
Set the bottom slot, ie the "weakest" (sorted last) entry in the queue. When CompareBottom(Int32) is called, you should compare against this slot. This will always be called before CompareBottom(Int32).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void SetBottom(
    int slot
)
public abstract void SetBottom(
    int slot
)
Public MustOverride Sub SetBottom ( _
    slot As Integer _
)
Public MustOverride Sub SetBottom ( _
    slot As Integer _
)
public:
virtual void SetBottom(
    int slot
) abstract
public:
virtual void SetBottom(
    int slot
) abstract
Parameters
slot
Type:   Online System Int32
the currently weakest (sorted last) slot in the queue

See Also
FieldComparator Class
FieldComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNextReader Method

FieldComparator SetNextReader Method Lucene.Net Class Library
Set a new Reader. All doc correspond to the current Reader.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void SetNextReader(
    IndexReader reader,
    int docBase
)
public abstract void SetNextReader(
    IndexReader reader,
    int docBase
)
Public MustOverride Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Public MustOverride Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) abstract
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) abstract
Parameters
reader
Type: Lucene.Net.Index IndexReader
current reader

docBase
Type:   Online System Int32
docBase of this reader

See Also
FieldComparator Class
FieldComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetScorer Method

FieldComparator SetScorer Method Lucene.Net Class Library
Sets the Scorer to use in case a document's score is needed.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetScorer(
    Scorer scorer
)
public virtual void SetScorer(
    Scorer scorer
)
Public Overridable Sub SetScorer ( _
    scorer As Scorer _
)
Public Overridable Sub SetScorer ( _
    scorer As Scorer _
)
public:
virtual void SetScorer(
    Scorer^ scorer
)
public:
virtual void SetScorer(
    Scorer^ scorer
)
Parameters
scorer
Type: Lucene.Net.Search Scorer
Scorer instance that you should use to
            obtain the current hit's score, if necessary.

See Also
FieldComparator Class
FieldComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator Properties

FieldComparator Properties Lucene.Net Class Library
The FieldComparator type exposes the following members.
Properties
 | Name | Description
Public property | Item | Return the actual value in the slot.
Back to Top
See Also
FieldComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Item Property

FieldComparator Item Property Lucene.Net Class Library
Return the actual value in the slot.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract IComparable this[
    int slot
] { get; }
public abstract IComparable this[
    int slot
] { get; }
Public MustOverride ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
Public MustOverride ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) abstract;
}
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) abstract;
}
Parameters
slot
Type:   Online System Int32
the value

Return Value
 value in this slot upgraded to Comparable

See Also
FieldComparator Class
FieldComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.ByteComparator Class

FieldComparator ByteComparator Class Lucene.Net Class Library
Parses field's values as byte (using GetBytes(IndexReader, String) and sorts by ascending value
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FieldComparator
Lucene.Net.Search FieldComparator ByteComparator

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ByteComparator : FieldComparator
public sealed class ByteComparator : FieldComparator
Public NotInheritable Class ByteComparator _
    Inherits FieldComparator
Public NotInheritable Class ByteComparator _
    Inherits FieldComparator
public ref class ByteComparator sealed : public FieldComparator
public ref class ByteComparator sealed : public FieldComparator
See Also
FieldComparator ByteComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.ByteComparator Members

FieldComparator ByteComparator Members Lucene.Net Class Library

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with TopFieldCollector . The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with FieldValueHitQueue as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The FieldComparator is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • Compare(Int32, Int32) Compare a hit at 'slot a' with hit 'slot b'.
  • SetBottom(Int32) This method is called by FieldValueHitQueue to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • CompareBottom(Int32) Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • Copy(Int32, Int32) Installs a new hit into the priority queue. The FieldValueHitQueue calls this method when a new hit is competitive.
  • SetNextReader(IndexReader, Int32) Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the FieldCache.
  • Item Int32 Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate fields when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator ByteComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator ByteComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.ByteComparator Methods

FieldComparator ByteComparator Methods Lucene.Net Class Library
The FieldComparator ByteComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldComparator ByteComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Method

FieldComparator ByteComparator Compare Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Compare(
    int slot1,
    int slot2
)
public override int Compare(
    int slot1,
    int slot2
)
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
public:
virtual int Compare(
    int slot1,
    int slot2
) override
public:
virtual int Compare(
    int slot1,
    int slot2
) override
Parameters
slot1
Type:   Online System Int32
slot2
Type:   Online System Int32
See Also
FieldComparator ByteComparator Class
FieldComparator ByteComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompareBottom Method

FieldComparator ByteComparator CompareBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int CompareBottom(
    int doc
)
public override int CompareBottom(
    int doc
)
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
public:
virtual int CompareBottom(
    int doc
) override
public:
virtual int CompareBottom(
    int doc
) override
Parameters
doc
Type:   Online System Int32
See Also
FieldComparator ByteComparator Class
FieldComparator ByteComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Copy Method

FieldComparator ByteComparator Copy Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Copy(
    int slot,
    int doc
)
public override void Copy(
    int slot,
    int doc
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
public:
virtual void Copy(
    int slot,
    int doc
) override
public:
virtual void Copy(
    int slot,
    int doc
) override
Parameters
slot
Type:   Online System Int32
doc
Type:   Online System Int32
See Also
FieldComparator ByteComparator Class
FieldComparator ByteComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetBottom Method

FieldComparator ByteComparator SetBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetBottom(
    int bottom
)
public override void SetBottom(
    int bottom
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
public:
virtual void SetBottom(
    int bottom
) override
public:
virtual void SetBottom(
    int bottom
) override
Parameters
bottom
Type:   Online System Int32
See Also
FieldComparator ByteComparator Class
FieldComparator ByteComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNextReader Method

FieldComparator ByteComparator SetNextReader Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
docBase
Type:   Online System Int32
See Also
FieldComparator ByteComparator Class
FieldComparator ByteComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.ByteComparator Properties

FieldComparator ByteComparator Properties Lucene.Net Class Library
The FieldComparator ByteComparator type exposes the following members.
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator ByteComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Item Property

FieldComparator ByteComparator Item Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IComparable this[
    int slot
] { get; }
public override IComparable this[
    int slot
] { get; }
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
Parameters
slot
Type:   Online System Int32
See Also
FieldComparator ByteComparator Class
FieldComparator ByteComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.DocComparator Class

FieldComparator DocComparator Class Lucene.Net Class Library
Sorts by ascending docID
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FieldComparator
Lucene.Net.Search FieldComparator DocComparator

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class DocComparator : FieldComparator
public sealed class DocComparator : FieldComparator
Public NotInheritable Class DocComparator _
    Inherits FieldComparator
Public NotInheritable Class DocComparator _
    Inherits FieldComparator
public ref class DocComparator sealed : public FieldComparator
public ref class DocComparator sealed : public FieldComparator
See Also
FieldComparator DocComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.DocComparator Members

FieldComparator DocComparator Members Lucene.Net Class Library

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with TopFieldCollector . The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with FieldValueHitQueue as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The FieldComparator is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • Compare(Int32, Int32) Compare a hit at 'slot a' with hit 'slot b'.
  • SetBottom(Int32) This method is called by FieldValueHitQueue to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • CompareBottom(Int32) Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • Copy(Int32, Int32) Installs a new hit into the priority queue. The FieldValueHitQueue calls this method when a new hit is competitive.
  • SetNextReader(IndexReader, Int32) Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the FieldCache.
  • Item Int32 Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate fields when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator DocComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator DocComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.DocComparator Methods

FieldComparator DocComparator Methods Lucene.Net Class Library
The FieldComparator DocComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldComparator DocComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Method

FieldComparator DocComparator Compare Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Compare(
    int slot1,
    int slot2
)
public override int Compare(
    int slot1,
    int slot2
)
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
public:
virtual int Compare(
    int slot1,
    int slot2
) override
public:
virtual int Compare(
    int slot1,
    int slot2
) override
Parameters
slot1
Type:   Online System Int32
slot2
Type:   Online System Int32
See Also
FieldComparator DocComparator Class
FieldComparator DocComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompareBottom Method

FieldComparator DocComparator CompareBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int CompareBottom(
    int doc
)
public override int CompareBottom(
    int doc
)
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
public:
virtual int CompareBottom(
    int doc
) override
public:
virtual int CompareBottom(
    int doc
) override
Parameters
doc
Type:   Online System Int32
See Also
FieldComparator DocComparator Class
FieldComparator DocComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Copy Method

FieldComparator DocComparator Copy Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Copy(
    int slot,
    int doc
)
public override void Copy(
    int slot,
    int doc
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
public:
virtual void Copy(
    int slot,
    int doc
) override
public:
virtual void Copy(
    int slot,
    int doc
) override
Parameters
slot
Type:   Online System Int32
doc
Type:   Online System Int32
See Also
FieldComparator DocComparator Class
FieldComparator DocComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetBottom Method

FieldComparator DocComparator SetBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetBottom(
    int bottom
)
public override void SetBottom(
    int bottom
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
public:
virtual void SetBottom(
    int bottom
) override
public:
virtual void SetBottom(
    int bottom
) override
Parameters
bottom
Type:   Online System Int32
See Also
FieldComparator DocComparator Class
FieldComparator DocComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNextReader Method

FieldComparator DocComparator SetNextReader Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
docBase
Type:   Online System Int32
See Also
FieldComparator DocComparator Class
FieldComparator DocComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.DocComparator Properties

FieldComparator DocComparator Properties Lucene.Net Class Library
The FieldComparator DocComparator type exposes the following members.
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator DocComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Item Property

FieldComparator DocComparator Item Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IComparable this[
    int slot
] { get; }
public override IComparable this[
    int slot
] { get; }
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
Parameters
slot
Type:   Online System Int32
See Also
FieldComparator DocComparator Class
FieldComparator DocComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.DoubleComparator Class

FieldComparator DoubleComparator Class Lucene.Net Class Library
Parses field's values as double (using GetDoubles(IndexReader, String) and sorts by ascending value
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FieldComparator
Lucene.Net.Search FieldComparator DoubleComparator

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class DoubleComparator : FieldComparator
public sealed class DoubleComparator : FieldComparator
Public NotInheritable Class DoubleComparator _
    Inherits FieldComparator
Public NotInheritable Class DoubleComparator _
    Inherits FieldComparator
public ref class DoubleComparator sealed : public FieldComparator
public ref class DoubleComparator sealed : public FieldComparator
See Also
FieldComparator DoubleComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.DoubleComparator Members

FieldComparator DoubleComparator Members Lucene.Net Class Library

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with TopFieldCollector . The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with FieldValueHitQueue as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The FieldComparator is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • Compare(Int32, Int32) Compare a hit at 'slot a' with hit 'slot b'.
  • SetBottom(Int32) This method is called by FieldValueHitQueue to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • CompareBottom(Int32) Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • Copy(Int32, Int32) Installs a new hit into the priority queue. The FieldValueHitQueue calls this method when a new hit is competitive.
  • SetNextReader(IndexReader, Int32) Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the FieldCache.
  • Item Int32 Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate fields when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator DoubleComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator DoubleComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.DoubleComparator Methods

FieldComparator DoubleComparator Methods Lucene.Net Class Library
The FieldComparator DoubleComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldComparator DoubleComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Method

FieldComparator DoubleComparator Compare Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Compare(
    int slot1,
    int slot2
)
public override int Compare(
    int slot1,
    int slot2
)
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
public:
virtual int Compare(
    int slot1,
    int slot2
) override
public:
virtual int Compare(
    int slot1,
    int slot2
) override
Parameters
slot1
Type:   Online System Int32
slot2
Type:   Online System Int32
See Also
FieldComparator DoubleComparator Class
FieldComparator DoubleComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompareBottom Method

FieldComparator DoubleComparator CompareBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int CompareBottom(
    int doc
)
public override int CompareBottom(
    int doc
)
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
public:
virtual int CompareBottom(
    int doc
) override
public:
virtual int CompareBottom(
    int doc
) override
Parameters
doc
Type:   Online System Int32
See Also
FieldComparator DoubleComparator Class
FieldComparator DoubleComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Copy Method

FieldComparator DoubleComparator Copy Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Copy(
    int slot,
    int doc
)
public override void Copy(
    int slot,
    int doc
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
public:
virtual void Copy(
    int slot,
    int doc
) override
public:
virtual void Copy(
    int slot,
    int doc
) override
Parameters
slot
Type:   Online System Int32
doc
Type:   Online System Int32
See Also
FieldComparator DoubleComparator Class
FieldComparator DoubleComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetBottom Method

FieldComparator DoubleComparator SetBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetBottom(
    int bottom
)
public override void SetBottom(
    int bottom
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
public:
virtual void SetBottom(
    int bottom
) override
public:
virtual void SetBottom(
    int bottom
) override
Parameters
bottom
Type:   Online System Int32
See Also
FieldComparator DoubleComparator Class
FieldComparator DoubleComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNextReader Method

FieldComparator DoubleComparator SetNextReader Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
docBase
Type:   Online System Int32
See Also
FieldComparator DoubleComparator Class
FieldComparator DoubleComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.DoubleComparator Properties

FieldComparator DoubleComparator Properties Lucene.Net Class Library
The FieldComparator DoubleComparator type exposes the following members.
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator DoubleComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Item Property

FieldComparator DoubleComparator Item Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IComparable this[
    int slot
] { get; }
public override IComparable this[
    int slot
] { get; }
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
Parameters
slot
Type:   Online System Int32
See Also
FieldComparator DoubleComparator Class
FieldComparator DoubleComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.FloatComparator Class

FieldComparator FloatComparator Class Lucene.Net Class Library
Parses field's values as float (using GetFloats(IndexReader, String) and sorts by ascending value
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FieldComparator
Lucene.Net.Search FieldComparator FloatComparator

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class FloatComparator : FieldComparator
public sealed class FloatComparator : FieldComparator
Public NotInheritable Class FloatComparator _
    Inherits FieldComparator
Public NotInheritable Class FloatComparator _
    Inherits FieldComparator
public ref class FloatComparator sealed : public FieldComparator
public ref class FloatComparator sealed : public FieldComparator
See Also
FieldComparator FloatComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.FloatComparator Members

FieldComparator FloatComparator Members Lucene.Net Class Library

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with TopFieldCollector . The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with FieldValueHitQueue as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The FieldComparator is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • Compare(Int32, Int32) Compare a hit at 'slot a' with hit 'slot b'.
  • SetBottom(Int32) This method is called by FieldValueHitQueue to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • CompareBottom(Int32) Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • Copy(Int32, Int32) Installs a new hit into the priority queue. The FieldValueHitQueue calls this method when a new hit is competitive.
  • SetNextReader(IndexReader, Int32) Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the FieldCache.
  • Item Int32 Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate fields when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator FloatComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator FloatComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.FloatComparator Methods

FieldComparator FloatComparator Methods Lucene.Net Class Library
The FieldComparator FloatComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldComparator FloatComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Method

FieldComparator FloatComparator Compare Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Compare(
    int slot1,
    int slot2
)
public override int Compare(
    int slot1,
    int slot2
)
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
public:
virtual int Compare(
    int slot1,
    int slot2
) override
public:
virtual int Compare(
    int slot1,
    int slot2
) override
Parameters
slot1
Type:   Online System Int32
slot2
Type:   Online System Int32
See Also
FieldComparator FloatComparator Class
FieldComparator FloatComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompareBottom Method

FieldComparator FloatComparator CompareBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int CompareBottom(
    int doc
)
public override int CompareBottom(
    int doc
)
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
public:
virtual int CompareBottom(
    int doc
) override
public:
virtual int CompareBottom(
    int doc
) override
Parameters
doc
Type:   Online System Int32
See Also
FieldComparator FloatComparator Class
FieldComparator FloatComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Copy Method

FieldComparator FloatComparator Copy Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Copy(
    int slot,
    int doc
)
public override void Copy(
    int slot,
    int doc
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
public:
virtual void Copy(
    int slot,
    int doc
) override
public:
virtual void Copy(
    int slot,
    int doc
) override
Parameters
slot
Type:   Online System Int32
doc
Type:   Online System Int32
See Also
FieldComparator FloatComparator Class
FieldComparator FloatComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetBottom Method

FieldComparator FloatComparator SetBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetBottom(
    int bottom
)
public override void SetBottom(
    int bottom
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
public:
virtual void SetBottom(
    int bottom
) override
public:
virtual void SetBottom(
    int bottom
) override
Parameters
bottom
Type:   Online System Int32
See Also
FieldComparator FloatComparator Class
FieldComparator FloatComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNextReader Method

FieldComparator FloatComparator SetNextReader Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
docBase
Type:   Online System Int32
See Also
FieldComparator FloatComparator Class
FieldComparator FloatComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.FloatComparator Properties

FieldComparator FloatComparator Properties Lucene.Net Class Library
The FieldComparator FloatComparator type exposes the following members.
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator FloatComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Item Property

FieldComparator FloatComparator Item Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IComparable this[
    int slot
] { get; }
public override IComparable this[
    int slot
] { get; }
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
Parameters
slot
Type:   Online System Int32
See Also
FieldComparator FloatComparator Class
FieldComparator FloatComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.IntComparator Class

FieldComparator IntComparator Class Lucene.Net Class Library
Parses field's values as int (using GetInts(IndexReader, String) and sorts by ascending value
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FieldComparator
Lucene.Net.Search FieldComparator IntComparator

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class IntComparator : FieldComparator
public sealed class IntComparator : FieldComparator
Public NotInheritable Class IntComparator _
    Inherits FieldComparator
Public NotInheritable Class IntComparator _
    Inherits FieldComparator
public ref class IntComparator sealed : public FieldComparator
public ref class IntComparator sealed : public FieldComparator
See Also
FieldComparator IntComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.IntComparator Members

FieldComparator IntComparator Members Lucene.Net Class Library

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with TopFieldCollector . The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with FieldValueHitQueue as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The FieldComparator is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • Compare(Int32, Int32) Compare a hit at 'slot a' with hit 'slot b'.
  • SetBottom(Int32) This method is called by FieldValueHitQueue to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • CompareBottom(Int32) Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • Copy(Int32, Int32) Installs a new hit into the priority queue. The FieldValueHitQueue calls this method when a new hit is competitive.
  • SetNextReader(IndexReader, Int32) Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the FieldCache.
  • Item Int32 Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate fields when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator IntComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator IntComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.IntComparator Methods

FieldComparator IntComparator Methods Lucene.Net Class Library
The FieldComparator IntComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldComparator IntComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Method

FieldComparator IntComparator Compare Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Compare(
    int slot1,
    int slot2
)
public override int Compare(
    int slot1,
    int slot2
)
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
public:
virtual int Compare(
    int slot1,
    int slot2
) override
public:
virtual int Compare(
    int slot1,
    int slot2
) override
Parameters
slot1
Type:   Online System Int32
slot2
Type:   Online System Int32
See Also
FieldComparator IntComparator Class
FieldComparator IntComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompareBottom Method

FieldComparator IntComparator CompareBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int CompareBottom(
    int doc
)
public override int CompareBottom(
    int doc
)
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
public:
virtual int CompareBottom(
    int doc
) override
public:
virtual int CompareBottom(
    int doc
) override
Parameters
doc
Type:   Online System Int32
See Also
FieldComparator IntComparator Class
FieldComparator IntComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Copy Method

FieldComparator IntComparator Copy Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Copy(
    int slot,
    int doc
)
public override void Copy(
    int slot,
    int doc
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
public:
virtual void Copy(
    int slot,
    int doc
) override
public:
virtual void Copy(
    int slot,
    int doc
) override
Parameters
slot
Type:   Online System Int32
doc
Type:   Online System Int32
See Also
FieldComparator IntComparator Class
FieldComparator IntComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetBottom Method

FieldComparator IntComparator SetBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetBottom(
    int bottom
)
public override void SetBottom(
    int bottom
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
public:
virtual void SetBottom(
    int bottom
) override
public:
virtual void SetBottom(
    int bottom
) override
Parameters
bottom
Type:   Online System Int32
See Also
FieldComparator IntComparator Class
FieldComparator IntComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNextReader Method

FieldComparator IntComparator SetNextReader Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
docBase
Type:   Online System Int32
See Also
FieldComparator IntComparator Class
FieldComparator IntComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.IntComparator Properties

FieldComparator IntComparator Properties Lucene.Net Class Library
The FieldComparator IntComparator type exposes the following members.
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator IntComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Item Property

FieldComparator IntComparator Item Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IComparable this[
    int slot
] { get; }
public override IComparable this[
    int slot
] { get; }
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
Parameters
slot
Type:   Online System Int32
See Also
FieldComparator IntComparator Class
FieldComparator IntComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.LongComparator Class

FieldComparator LongComparator Class Lucene.Net Class Library
Parses field's values as long (using GetLongs(IndexReader, String) and sorts by ascending value
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FieldComparator
Lucene.Net.Search FieldComparator LongComparator

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LongComparator : FieldComparator
public sealed class LongComparator : FieldComparator
Public NotInheritable Class LongComparator _
    Inherits FieldComparator
Public NotInheritable Class LongComparator _
    Inherits FieldComparator
public ref class LongComparator sealed : public FieldComparator
public ref class LongComparator sealed : public FieldComparator
See Also
FieldComparator LongComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.LongComparator Members

FieldComparator LongComparator Members Lucene.Net Class Library

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with TopFieldCollector . The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with FieldValueHitQueue as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The FieldComparator is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • Compare(Int32, Int32) Compare a hit at 'slot a' with hit 'slot b'.
  • SetBottom(Int32) This method is called by FieldValueHitQueue to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • CompareBottom(Int32) Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • Copy(Int32, Int32) Installs a new hit into the priority queue. The FieldValueHitQueue calls this method when a new hit is competitive.
  • SetNextReader(IndexReader, Int32) Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the FieldCache.
  • Item Int32 Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate fields when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator LongComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator LongComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.LongComparator Methods

FieldComparator LongComparator Methods Lucene.Net Class Library
The FieldComparator LongComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldComparator LongComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Method

FieldComparator LongComparator Compare Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Compare(
    int slot1,
    int slot2
)
public override int Compare(
    int slot1,
    int slot2
)
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
public:
virtual int Compare(
    int slot1,
    int slot2
) override
public:
virtual int Compare(
    int slot1,
    int slot2
) override
Parameters
slot1
Type:   Online System Int32
slot2
Type:   Online System Int32
See Also
FieldComparator LongComparator Class
FieldComparator LongComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompareBottom Method

FieldComparator LongComparator CompareBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int CompareBottom(
    int doc
)
public override int CompareBottom(
    int doc
)
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
public:
virtual int CompareBottom(
    int doc
) override
public:
virtual int CompareBottom(
    int doc
) override
Parameters
doc
Type:   Online System Int32
See Also
FieldComparator LongComparator Class
FieldComparator LongComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Copy Method

FieldComparator LongComparator Copy Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Copy(
    int slot,
    int doc
)
public override void Copy(
    int slot,
    int doc
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
public:
virtual void Copy(
    int slot,
    int doc
) override
public:
virtual void Copy(
    int slot,
    int doc
) override
Parameters
slot
Type:   Online System Int32
doc
Type:   Online System Int32
See Also
FieldComparator LongComparator Class
FieldComparator LongComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetBottom Method

FieldComparator LongComparator SetBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetBottom(
    int bottom
)
public override void SetBottom(
    int bottom
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
public:
virtual void SetBottom(
    int bottom
) override
public:
virtual void SetBottom(
    int bottom
) override
Parameters
bottom
Type:   Online System Int32
See Also
FieldComparator LongComparator Class
FieldComparator LongComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNextReader Method

FieldComparator LongComparator SetNextReader Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
docBase
Type:   Online System Int32
See Also
FieldComparator LongComparator Class
FieldComparator LongComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.LongComparator Properties

FieldComparator LongComparator Properties Lucene.Net Class Library
The FieldComparator LongComparator type exposes the following members.
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator LongComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Item Property

FieldComparator LongComparator Item Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IComparable this[
    int slot
] { get; }
public override IComparable this[
    int slot
] { get; }
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
Parameters
slot
Type:   Online System Int32
See Also
FieldComparator LongComparator Class
FieldComparator LongComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.RelevanceComparator Class

FieldComparator RelevanceComparator Class Lucene.Net Class Library
Sorts by descending relevance. NOTE: if you are sorting only by descending relevance and then secondarily by ascending docID, peformance is faster using TopScoreDocCollector directly (which Search(Query, Int32) uses when no Sort is specified).
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FieldComparator
Lucene.Net.Search FieldComparator RelevanceComparator

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class RelevanceComparator : FieldComparator
public sealed class RelevanceComparator : FieldComparator
Public NotInheritable Class RelevanceComparator _
    Inherits FieldComparator
Public NotInheritable Class RelevanceComparator _
    Inherits FieldComparator
public ref class RelevanceComparator sealed : public FieldComparator
public ref class RelevanceComparator sealed : public FieldComparator
See Also
FieldComparator RelevanceComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.RelevanceComparator Members

FieldComparator RelevanceComparator Members Lucene.Net Class Library

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with TopFieldCollector . The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with FieldValueHitQueue as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The FieldComparator is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • Compare(Int32, Int32) Compare a hit at 'slot a' with hit 'slot b'.
  • SetBottom(Int32) This method is called by FieldValueHitQueue to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • CompareBottom(Int32) Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • Copy(Int32, Int32) Installs a new hit into the priority queue. The FieldValueHitQueue calls this method when a new hit is competitive.
  • SetNextReader(IndexReader, Int32) Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the FieldCache.
  • Item Int32 Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate fields when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator RelevanceComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | (Overrides FieldComparator SetScorer(Scorer).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator RelevanceComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.RelevanceComparator Methods

FieldComparator RelevanceComparator Methods Lucene.Net Class Library
The FieldComparator RelevanceComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | (Overrides FieldComparator SetScorer(Scorer).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldComparator RelevanceComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Method

FieldComparator RelevanceComparator Compare Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Compare(
    int slot1,
    int slot2
)
public override int Compare(
    int slot1,
    int slot2
)
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
public:
virtual int Compare(
    int slot1,
    int slot2
) override
public:
virtual int Compare(
    int slot1,
    int slot2
) override
Parameters
slot1
Type:   Online System Int32
slot2
Type:   Online System Int32
See Also
FieldComparator RelevanceComparator Class
FieldComparator RelevanceComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompareBottom Method

FieldComparator RelevanceComparator CompareBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int CompareBottom(
    int doc
)
public override int CompareBottom(
    int doc
)
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
public:
virtual int CompareBottom(
    int doc
) override
public:
virtual int CompareBottom(
    int doc
) override
Parameters
doc
Type:   Online System Int32
See Also
FieldComparator RelevanceComparator Class
FieldComparator RelevanceComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Copy Method

FieldComparator RelevanceComparator Copy Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Copy(
    int slot,
    int doc
)
public override void Copy(
    int slot,
    int doc
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
public:
virtual void Copy(
    int slot,
    int doc
) override
public:
virtual void Copy(
    int slot,
    int doc
) override
Parameters
slot
Type:   Online System Int32
doc
Type:   Online System Int32
See Also
FieldComparator RelevanceComparator Class
FieldComparator RelevanceComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetBottom Method

FieldComparator RelevanceComparator SetBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetBottom(
    int bottom
)
public override void SetBottom(
    int bottom
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
public:
virtual void SetBottom(
    int bottom
) override
public:
virtual void SetBottom(
    int bottom
) override
Parameters
bottom
Type:   Online System Int32
See Also
FieldComparator RelevanceComparator Class
FieldComparator RelevanceComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNextReader Method

FieldComparator RelevanceComparator SetNextReader Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
docBase
Type:   Online System Int32
See Also
FieldComparator RelevanceComparator Class
FieldComparator RelevanceComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetScorer Method

FieldComparator RelevanceComparator SetScorer Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetScorer(
    Scorer scorer
)
public override void SetScorer(
    Scorer scorer
)
Public Overrides Sub SetScorer ( _
    scorer As Scorer _
)
Public Overrides Sub SetScorer ( _
    scorer As Scorer _
)
public:
virtual void SetScorer(
    Scorer^ scorer
) override
public:
virtual void SetScorer(
    Scorer^ scorer
) override
Parameters
scorer
Type: Lucene.Net.Search Scorer
See Also
FieldComparator RelevanceComparator Class
FieldComparator RelevanceComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.RelevanceComparator Properties

FieldComparator RelevanceComparator Properties Lucene.Net Class Library
The FieldComparator RelevanceComparator type exposes the following members.
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator RelevanceComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Item Property

FieldComparator RelevanceComparator Item Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IComparable this[
    int slot
] { get; }
public override IComparable this[
    int slot
] { get; }
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
Parameters
slot
Type:   Online System Int32
See Also
FieldComparator RelevanceComparator Class
FieldComparator RelevanceComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.ShortComparator Class

FieldComparator ShortComparator Class Lucene.Net Class Library
Parses field's values as short (using GetShorts(IndexReader, String)) and sorts by ascending value
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FieldComparator
Lucene.Net.Search FieldComparator ShortComparator

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ShortComparator : FieldComparator
public sealed class ShortComparator : FieldComparator
Public NotInheritable Class ShortComparator _
    Inherits FieldComparator
Public NotInheritable Class ShortComparator _
    Inherits FieldComparator
public ref class ShortComparator sealed : public FieldComparator
public ref class ShortComparator sealed : public FieldComparator
See Also
FieldComparator ShortComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.ShortComparator Members

FieldComparator ShortComparator Members Lucene.Net Class Library

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with TopFieldCollector . The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with FieldValueHitQueue as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The FieldComparator is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • Compare(Int32, Int32) Compare a hit at 'slot a' with hit 'slot b'.
  • SetBottom(Int32) This method is called by FieldValueHitQueue to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • CompareBottom(Int32) Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • Copy(Int32, Int32) Installs a new hit into the priority queue. The FieldValueHitQueue calls this method when a new hit is competitive.
  • SetNextReader(IndexReader, Int32) Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the FieldCache.
  • Item Int32 Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate fields when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator ShortComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator ShortComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.ShortComparator Methods

FieldComparator ShortComparator Methods Lucene.Net Class Library
The FieldComparator ShortComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldComparator ShortComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Method

FieldComparator ShortComparator Compare Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Compare(
    int slot1,
    int slot2
)
public override int Compare(
    int slot1,
    int slot2
)
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
public:
virtual int Compare(
    int slot1,
    int slot2
) override
public:
virtual int Compare(
    int slot1,
    int slot2
) override
Parameters
slot1
Type:   Online System Int32
slot2
Type:   Online System Int32
See Also
FieldComparator ShortComparator Class
FieldComparator ShortComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompareBottom Method

FieldComparator ShortComparator CompareBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int CompareBottom(
    int doc
)
public override int CompareBottom(
    int doc
)
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
public:
virtual int CompareBottom(
    int doc
) override
public:
virtual int CompareBottom(
    int doc
) override
Parameters
doc
Type:   Online System Int32
See Also
FieldComparator ShortComparator Class
FieldComparator ShortComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Copy Method

FieldComparator ShortComparator Copy Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Copy(
    int slot,
    int doc
)
public override void Copy(
    int slot,
    int doc
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
public:
virtual void Copy(
    int slot,
    int doc
) override
public:
virtual void Copy(
    int slot,
    int doc
) override
Parameters
slot
Type:   Online System Int32
doc
Type:   Online System Int32
See Also
FieldComparator ShortComparator Class
FieldComparator ShortComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetBottom Method

FieldComparator ShortComparator SetBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetBottom(
    int bottom
)
public override void SetBottom(
    int bottom
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
public:
virtual void SetBottom(
    int bottom
) override
public:
virtual void SetBottom(
    int bottom
) override
Parameters
bottom
Type:   Online System Int32
See Also
FieldComparator ShortComparator Class
FieldComparator ShortComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNextReader Method

FieldComparator ShortComparator SetNextReader Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
docBase
Type:   Online System Int32
See Also
FieldComparator ShortComparator Class
FieldComparator ShortComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.ShortComparator Properties

FieldComparator ShortComparator Properties Lucene.Net Class Library
The FieldComparator ShortComparator type exposes the following members.
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator ShortComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Item Property

FieldComparator ShortComparator Item Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IComparable this[
    int slot
] { get; }
public override IComparable this[
    int slot
] { get; }
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
Parameters
slot
Type:   Online System Int32
See Also
FieldComparator ShortComparator Class
FieldComparator ShortComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.StringComparatorLocale Class

FieldComparator StringComparatorLocale Class Lucene.Net Class Library
Sorts by a field's value using the Collator for a given Locale.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FieldComparator
Lucene.Net.Search FieldComparator StringComparatorLocale

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class StringComparatorLocale : FieldComparator
public sealed class StringComparatorLocale : FieldComparator
Public NotInheritable Class StringComparatorLocale _
    Inherits FieldComparator
Public NotInheritable Class StringComparatorLocale _
    Inherits FieldComparator
public ref class StringComparatorLocale sealed : public FieldComparator
public ref class StringComparatorLocale sealed : public FieldComparator
See Also
FieldComparator StringComparatorLocale Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.StringComparatorLocale Members

FieldComparator StringComparatorLocale Members Lucene.Net Class Library

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with TopFieldCollector . The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with FieldValueHitQueue as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The FieldComparator is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • Compare(Int32, Int32) Compare a hit at 'slot a' with hit 'slot b'.
  • SetBottom(Int32) This method is called by FieldValueHitQueue to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • CompareBottom(Int32) Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • Copy(Int32, Int32) Installs a new hit into the priority queue. The FieldValueHitQueue calls this method when a new hit is competitive.
  • SetNextReader(IndexReader, Int32) Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the FieldCache.
  • Item Int32 Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate fields when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator StringComparatorLocale type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator StringComparatorLocale Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.StringComparatorLocale Methods

FieldComparator StringComparatorLocale Methods Lucene.Net Class Library
The FieldComparator StringComparatorLocale type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldComparator StringComparatorLocale Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Method

FieldComparator StringComparatorLocale Compare Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Compare(
    int slot1,
    int slot2
)
public override int Compare(
    int slot1,
    int slot2
)
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
public:
virtual int Compare(
    int slot1,
    int slot2
) override
public:
virtual int Compare(
    int slot1,
    int slot2
) override
Parameters
slot1
Type:   Online System Int32
slot2
Type:   Online System Int32
See Also
FieldComparator StringComparatorLocale Class
FieldComparator StringComparatorLocale Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompareBottom Method

FieldComparator StringComparatorLocale CompareBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int CompareBottom(
    int doc
)
public override int CompareBottom(
    int doc
)
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
public:
virtual int CompareBottom(
    int doc
) override
public:
virtual int CompareBottom(
    int doc
) override
Parameters
doc
Type:   Online System Int32
See Also
FieldComparator StringComparatorLocale Class
FieldComparator StringComparatorLocale Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Copy Method

FieldComparator StringComparatorLocale Copy Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Copy(
    int slot,
    int doc
)
public override void Copy(
    int slot,
    int doc
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
public:
virtual void Copy(
    int slot,
    int doc
) override
public:
virtual void Copy(
    int slot,
    int doc
) override
Parameters
slot
Type:   Online System Int32
doc
Type:   Online System Int32
See Also
FieldComparator StringComparatorLocale Class
FieldComparator StringComparatorLocale Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetBottom Method

FieldComparator StringComparatorLocale SetBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetBottom(
    int bottom
)
public override void SetBottom(
    int bottom
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
public:
virtual void SetBottom(
    int bottom
) override
public:
virtual void SetBottom(
    int bottom
) override
Parameters
bottom
Type:   Online System Int32
See Also
FieldComparator StringComparatorLocale Class
FieldComparator StringComparatorLocale Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNextReader Method

FieldComparator StringComparatorLocale SetNextReader Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
docBase
Type:   Online System Int32
See Also
FieldComparator StringComparatorLocale Class
FieldComparator StringComparatorLocale Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.StringComparatorLocale Properties

FieldComparator StringComparatorLocale Properties Lucene.Net Class Library
The FieldComparator StringComparatorLocale type exposes the following members.
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator StringComparatorLocale Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Item Property

FieldComparator StringComparatorLocale Item Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IComparable this[
    int slot
] { get; }
public override IComparable this[
    int slot
] { get; }
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
Parameters
slot
Type:   Online System Int32
See Also
FieldComparator StringComparatorLocale Class
FieldComparator StringComparatorLocale Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.StringOrdValComparator Class

FieldComparator StringOrdValComparator Class Lucene.Net Class Library
Sorts by field's natural String sort order, using ordinals. This is functionally equivalent to FieldComparator StringValComparator , but it first resolves the string to their relative ordinal positions (using the index returned by GetStringIndex(IndexReader, String)), and does most comparisons using the ordinals. For medium to large results, this comparator will be much faster than FieldComparator StringValComparator. For very small result sets it may be slower.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FieldComparator
Lucene.Net.Search FieldComparator StringOrdValComparator

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class StringOrdValComparator : FieldComparator
public sealed class StringOrdValComparator : FieldComparator
Public NotInheritable Class StringOrdValComparator _
    Inherits FieldComparator
Public NotInheritable Class StringOrdValComparator _
    Inherits FieldComparator
public ref class StringOrdValComparator sealed : public FieldComparator
public ref class StringOrdValComparator sealed : public FieldComparator
See Also
FieldComparator StringOrdValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.StringOrdValComparator Members

FieldComparator StringOrdValComparator Members Lucene.Net Class Library

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with TopFieldCollector . The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with FieldValueHitQueue as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The FieldComparator is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • Compare(Int32, Int32) Compare a hit at 'slot a' with hit 'slot b'.
  • SetBottom(Int32) This method is called by FieldValueHitQueue to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • CompareBottom(Int32) Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • Copy(Int32, Int32) Installs a new hit into the priority queue. The FieldValueHitQueue calls this method when a new hit is competitive.
  • SetNextReader(IndexReader, Int32) Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the FieldCache.
  • Item Int32 Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate fields when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator StringOrdValComparator type exposes the following members.
Constructors
 | Name | Description
Public method | FieldComparator StringOrdValComparator | Initializes a new instance of the FieldComparator StringOrdValComparator class
Back to Top
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | BottomSlot |
Public property | Field |
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator StringOrdValComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.StringOrdValComparator Constructor

FieldComparator StringOrdValComparator Constructor Lucene.Net Class Library
Initializes a new instance of the FieldComparator StringOrdValComparator class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StringOrdValComparator(
    int numHits,
    string field,
    int sortPos,
    bool reversed
)
public StringOrdValComparator(
    int numHits,
    string field,
    int sortPos,
    bool reversed
)
Public Sub New ( _
    numHits As Integer, _
    field As String, _
    sortPos As Integer, _
    reversed As Boolean _
)
Public Sub New ( _
    numHits As Integer, _
    field As String, _
    sortPos As Integer, _
    reversed As Boolean _
)
public:
StringOrdValComparator(
    int numHits,
    String^ field,
    int sortPos,
    bool reversed
)
public:
StringOrdValComparator(
    int numHits,
    String^ field,
    int sortPos,
    bool reversed
)
Parameters
numHits
Type:   Online System Int32
field
Type:   Online System String
sortPos
Type:   Online System Int32
reversed
Type:   Online System Boolean
See Also
FieldComparator StringOrdValComparator Class
FieldComparator StringOrdValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.StringOrdValComparator Methods

FieldComparator StringOrdValComparator Methods Lucene.Net Class Library
The FieldComparator StringOrdValComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldComparator StringOrdValComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Method

FieldComparator StringOrdValComparator Compare Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Compare(
    int slot1,
    int slot2
)
public override int Compare(
    int slot1,
    int slot2
)
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
public:
virtual int Compare(
    int slot1,
    int slot2
) override
public:
virtual int Compare(
    int slot1,
    int slot2
) override
Parameters
slot1
Type:   Online System Int32
slot2
Type:   Online System Int32
See Also
FieldComparator StringOrdValComparator Class
FieldComparator StringOrdValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompareBottom Method

FieldComparator StringOrdValComparator CompareBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int CompareBottom(
    int doc
)
public override int CompareBottom(
    int doc
)
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
public:
virtual int CompareBottom(
    int doc
) override
public:
virtual int CompareBottom(
    int doc
) override
Parameters
doc
Type:   Online System Int32
See Also
FieldComparator StringOrdValComparator Class
FieldComparator StringOrdValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Copy Method

FieldComparator StringOrdValComparator Copy Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Copy(
    int slot,
    int doc
)
public override void Copy(
    int slot,
    int doc
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
public:
virtual void Copy(
    int slot,
    int doc
) override
public:
virtual void Copy(
    int slot,
    int doc
) override
Parameters
slot
Type:   Online System Int32
doc
Type:   Online System Int32
See Also
FieldComparator StringOrdValComparator Class
FieldComparator StringOrdValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetValues Method

FieldComparator StringOrdValComparator GetValues Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string[] GetValues()
public string[] GetValues()
Public Function GetValues As String()
Public Function GetValues As String()
public:
array<String^>^ GetValues()
public:
array<String^>^ GetValues()
See Also
FieldComparator StringOrdValComparator Class
FieldComparator StringOrdValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetBottom Method

FieldComparator StringOrdValComparator SetBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetBottom(
    int bottom
)
public override void SetBottom(
    int bottom
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
public:
virtual void SetBottom(
    int bottom
) override
public:
virtual void SetBottom(
    int bottom
) override
Parameters
bottom
Type:   Online System Int32
See Also
FieldComparator StringOrdValComparator Class
FieldComparator StringOrdValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNextReader Method

FieldComparator StringOrdValComparator SetNextReader Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
docBase
Type:   Online System Int32
See Also
FieldComparator StringOrdValComparator Class
FieldComparator StringOrdValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.StringOrdValComparator Properties

FieldComparator StringOrdValComparator Properties Lucene.Net Class Library
The FieldComparator StringOrdValComparator type exposes the following members.
Properties
 | Name | Description
Public property | BottomSlot |
Public property | Field |
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator StringOrdValComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BottomSlot Property

FieldComparator StringOrdValComparator BottomSlot Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int BottomSlot { get; }
public int BottomSlot { get; }
Public ReadOnly Property BottomSlot As Integer
    Get
Public ReadOnly Property BottomSlot As Integer
    Get
public:
property int BottomSlot {
    int get ();
}
public:
property int BottomSlot {
    int get ();
}
See Also
FieldComparator StringOrdValComparator Class
FieldComparator StringOrdValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

FieldComparator StringOrdValComparator Field Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Field { get; }
public string Field { get; }
Public ReadOnly Property Field As String
    Get
Public ReadOnly Property Field As String
    Get
public:
property String^ Field {
    String^ get ();
}
public:
property String^ Field {
    String^ get ();
}
See Also
FieldComparator StringOrdValComparator Class
FieldComparator StringOrdValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Item Property

FieldComparator StringOrdValComparator Item Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IComparable this[
    int slot
] { get; }
public override IComparable this[
    int slot
] { get; }
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
Parameters
slot
Type:   Online System Int32
See Also
FieldComparator StringOrdValComparator Class
FieldComparator StringOrdValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.StringValComparator Class

FieldComparator StringValComparator Class Lucene.Net Class Library
Sorts by field's natural String sort order. All comparisons are done using String.compareTo, which is slow for medium to large result sets but possibly very fast for very small results sets.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FieldComparator
Lucene.Net.Search FieldComparator StringValComparator

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class StringValComparator : FieldComparator
public sealed class StringValComparator : FieldComparator
Public NotInheritable Class StringValComparator _
    Inherits FieldComparator
Public NotInheritable Class StringValComparator _
    Inherits FieldComparator
public ref class StringValComparator sealed : public FieldComparator
public ref class StringValComparator sealed : public FieldComparator
See Also
FieldComparator StringValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.StringValComparator Members

FieldComparator StringValComparator Members Lucene.Net Class Library

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with TopFieldCollector . The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with FieldValueHitQueue as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The FieldComparator is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • Compare(Int32, Int32) Compare a hit at 'slot a' with hit 'slot b'.
  • SetBottom(Int32) This method is called by FieldValueHitQueue to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • CompareBottom(Int32) Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • Copy(Int32, Int32) Installs a new hit into the priority queue. The FieldValueHitQueue calls this method when a new hit is competitive.
  • SetNextReader(IndexReader, Int32) Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the FieldCache.
  • Item Int32 Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate fields when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator StringValComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator StringValComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.StringValComparator Methods

FieldComparator StringValComparator Methods Lucene.Net Class Library
The FieldComparator StringValComparator type exposes the following members.
Methods
 | Name | Description
Public method | Compare | (Overrides FieldComparator Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator Copy(Int32, Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetBottom | (Overrides FieldComparator SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldComparator StringValComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Method

FieldComparator StringValComparator Compare Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Compare(
    int slot1,
    int slot2
)
public override int Compare(
    int slot1,
    int slot2
)
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
public:
virtual int Compare(
    int slot1,
    int slot2
) override
public:
virtual int Compare(
    int slot1,
    int slot2
) override
Parameters
slot1
Type:   Online System Int32
slot2
Type:   Online System Int32
See Also
FieldComparator StringValComparator Class
FieldComparator StringValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompareBottom Method

FieldComparator StringValComparator CompareBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int CompareBottom(
    int doc
)
public override int CompareBottom(
    int doc
)
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
public:
virtual int CompareBottom(
    int doc
) override
public:
virtual int CompareBottom(
    int doc
) override
Parameters
doc
Type:   Online System Int32
See Also
FieldComparator StringValComparator Class
FieldComparator StringValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Copy Method

FieldComparator StringValComparator Copy Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Copy(
    int slot,
    int doc
)
public override void Copy(
    int slot,
    int doc
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
public:
virtual void Copy(
    int slot,
    int doc
) override
public:
virtual void Copy(
    int slot,
    int doc
) override
Parameters
slot
Type:   Online System Int32
doc
Type:   Online System Int32
See Also
FieldComparator StringValComparator Class
FieldComparator StringValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetBottom Method

FieldComparator StringValComparator SetBottom Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetBottom(
    int bottom
)
public override void SetBottom(
    int bottom
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
public:
virtual void SetBottom(
    int bottom
) override
public:
virtual void SetBottom(
    int bottom
) override
Parameters
bottom
Type:   Online System Int32
See Also
FieldComparator StringValComparator Class
FieldComparator StringValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNextReader Method

FieldComparator StringValComparator SetNextReader Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
docBase
Type:   Online System Int32
See Also
FieldComparator StringValComparator Class
FieldComparator StringValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparator.StringValComparator Properties

FieldComparator StringValComparator Properties Lucene.Net Class Library
The FieldComparator StringValComparator type exposes the following members.
Properties
 | Name | Description
Public property | Item | (Overrides FieldComparator Item Int32 .)
Back to Top
See Also
FieldComparator StringValComparator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Item Property

FieldComparator StringValComparator Item Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IComparable this[
    int slot
] { get; }
public override IComparable this[
    int slot
] { get; }
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
Public Overrides ReadOnly Default Property Item ( _
    slot As Integer _
) As IComparable
    Get
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
public:
virtual property IComparable^ default[int slot] {
    IComparable^ get (int slot) override;
}
Parameters
slot
Type:   Online System Int32
See Also
FieldComparator StringValComparator Class
FieldComparator StringValComparator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparatorSource Class

FieldComparatorSource Class Lucene.Net Class Library
Provides a FieldComparator for custom field sorting. NOTE: This API is experimental and might change in incompatible ways in the next release.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FieldComparatorSource

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class FieldComparatorSource
[SerializableAttribute]
public abstract class FieldComparatorSource
<SerializableAttribute> _
Public MustInherit Class FieldComparatorSource
<SerializableAttribute> _
Public MustInherit Class FieldComparatorSource
[SerializableAttribute]
public ref class FieldComparatorSource abstract
[SerializableAttribute]
public ref class FieldComparatorSource abstract
See Also
FieldComparatorSource Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparatorSource Members

FieldComparatorSource Members Lucene.Net Class Library

The FieldComparatorSource type exposes the following members.
Constructors
 | Name | Description
Protected method | FieldComparatorSource | Initializes a new instance of the FieldComparatorSource class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NewComparator | Creates a comparator for the field in the given index.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldComparatorSource Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparatorSource Constructor

FieldComparatorSource Constructor Lucene.Net Class Library
Initializes a new instance of the FieldComparatorSource class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FieldComparatorSource()
protected FieldComparatorSource()
Protected Sub New
Protected Sub New
protected:
FieldComparatorSource()
protected:
FieldComparatorSource()
See Also
FieldComparatorSource Class
FieldComparatorSource Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldComparatorSource Methods

FieldComparatorSource Methods Lucene.Net Class Library
The FieldComparatorSource type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NewComparator | Creates a comparator for the field in the given index.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldComparatorSource Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewComparator Method

FieldComparatorSource NewComparator Method Lucene.Net Class Library
Creates a comparator for the field in the given index.
If an error occurs reading the index.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract FieldComparator NewComparator(
    string fieldname,
    int numHits,
    int sortPos,
    bool reversed
)
public abstract FieldComparator NewComparator(
    string fieldname,
    int numHits,
    int sortPos,
    bool reversed
)
Public MustOverride Function NewComparator ( _
    fieldname As String, _
    numHits As Integer, _
    sortPos As Integer, _
    reversed As Boolean _
) As FieldComparator
Public MustOverride Function NewComparator ( _
    fieldname As String, _
    numHits As Integer, _
    sortPos As Integer, _
    reversed As Boolean _
) As FieldComparator
public:
virtual FieldComparator^ NewComparator(
    String^ fieldname,
    int numHits,
    int sortPos,
    bool reversed
) abstract
public:
virtual FieldComparator^ NewComparator(
    String^ fieldname,
    int numHits,
    int sortPos,
    bool reversed
) abstract
Parameters
fieldname
Type:   Online System String
Name of the field to create comparator for.

numHits
Type:   Online System Int32
sortPos
Type:   Online System Int32
reversed
Type:   Online System Boolean
Return Value
 FieldComparator.

See Also
FieldComparatorSource Class
FieldComparatorSource Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldDoc Class

FieldDoc Class Lucene.Net Class Library
Expert: A ScoreDoc which also contains information about how to sort the referenced document. In addition to the document number and score, this object contains an array of values for the document from the field(s) used to sort. For example, if the sort criteria was to sort by fields "a", "b" then "c", the fields object array will have three elements, corresponding respectively to the term values for the document in fields "a", "b" and "c". The class of each element in the array will be either Integer, Float or String depending on the type of values in the terms of each field.

Created: Feb 11, 2004 1:23:38 PM
Inheritance Hierarchy
Online System Object
Lucene.Net.Search ScoreDoc
Lucene.Net.Search FieldDoc

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FieldDoc : ScoreDoc
[SerializableAttribute]
public class FieldDoc : ScoreDoc
<SerializableAttribute> _
Public Class FieldDoc _
    Inherits ScoreDoc
<SerializableAttribute> _
Public Class FieldDoc _
    Inherits ScoreDoc
[SerializableAttribute]
public ref class FieldDoc : public ScoreDoc
[SerializableAttribute]
public ref class FieldDoc : public ScoreDoc
See Also
FieldDoc Members
Lucene.Net.Search Namespace
Lucene.Net.Search ScoreDoc
Lucene.Net.Search TopFieldDocs
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldDoc Members

FieldDoc Members Lucene.Net Class Library

The FieldDoc type exposes the following members.
Constructors
 | Name | Description
Public method | FieldDoc(Int32, Single) | Expert: Creates one of these objects with empty sort information.
Public method | FieldDoc(Int32, Single, IComparable ) | Expert: Creates one of these objects with the given sort information.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides ScoreDoc ToString .)
Back to Top
Fields
 | Name | Description
Public field | fields | Expert: The values which are used to sort the referenced document. The order of these will match the original sort criteria given by a Sort object. Each Object will be either an Integer, Float or String, depending on the type of values in the terms of the original field.
Back to Top
Properties
 | Name | Description
Public property | Doc | Expert: A hit document's number. (Inherited from ScoreDoc.)
Public property | Score | Expert: The score of this document for the query. (Inherited from ScoreDoc.)
Back to Top
See Also
FieldDoc Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldDoc Constructor

FieldDoc Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | FieldDoc(Int32, Single) | Expert: Creates one of these objects with empty sort information.
Public method | FieldDoc(Int32, Single, IComparable ) | Expert: Creates one of these objects with the given sort information.
Back to Top
See Also
FieldDoc Class
FieldDoc Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldDoc Constructor (Int32, Single)

FieldDoc Constructor (Int32, Single) Lucene.Net Class Library
Expert: Creates one of these objects with empty sort information.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldDoc(
    int doc,
    float score
)
public FieldDoc(
    int doc,
    float score
)
Public Sub New ( _
    doc As Integer, _
    score As Single _
)
Public Sub New ( _
    doc As Integer, _
    score As Single _
)
public:
FieldDoc(
    int doc,
    float score
)
public:
FieldDoc(
    int doc,
    float score
)
Parameters
doc
Type:   Online System Int32
score
Type:   Online System Single
See Also
FieldDoc Class
FieldDoc Members
FieldDoc Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldDoc Constructor (Int32, Single, IComparable[])

FieldDoc Constructor (Int32, Single, IComparable ) Lucene.Net Class Library
Expert: Creates one of these objects with the given sort information.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldDoc(
    int doc,
    float score,
    IComparable[] fields
)
public FieldDoc(
    int doc,
    float score,
    IComparable[] fields
)
Public Sub New ( _
    doc As Integer, _
    score As Single, _
    fields As IComparable() _
)
Public Sub New ( _
    doc As Integer, _
    score As Single, _
    fields As IComparable() _
)
public:
FieldDoc(
    int doc,
    float score,
    array<IComparable^>^ fields
)
public:
FieldDoc(
    int doc,
    float score,
    array<IComparable^>^ fields
)
Parameters
doc
Type:   Online System Int32
score
Type:   Online System Single
fields
Type:    Online System IComparable
See Also
FieldDoc Class
FieldDoc Members
FieldDoc Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldDoc Fields

FieldDoc Fields Lucene.Net Class Library
The FieldDoc type exposes the following members.
Fields
 | Name | Description
Public field | fields | Expert: The values which are used to sort the referenced document. The order of these will match the original sort criteria given by a Sort object. Each Object will be either an Integer, Float or String, depending on the type of values in the terms of the original field.
Back to Top
See Also
FieldDoc Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


fields Field

FieldDoc fields Field Lucene.Net Class Library
Expert: The values which are used to sort the referenced document. The order of these will match the original sort criteria given by a Sort object. Each Object will be either an Integer, Float or String, depending on the type of values in the terms of the original field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
public IComparable[] fields
[NonSerializedAttribute]
public IComparable[] fields
<NonSerializedAttribute> _
Public fields As IComparable()
<NonSerializedAttribute> _
Public fields As IComparable()
public:
[NonSerializedAttribute]
array<IComparable^>^ fields
public:
[NonSerializedAttribute]
array<IComparable^>^ fields
See Also
FieldDoc Class
FieldDoc Members
Lucene.Net.Search Namespace
Lucene.Net.Search Sort
Searcher Search(Query, Filter, Int32, Sort)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldDoc Methods

FieldDoc Methods Lucene.Net Class Library
The FieldDoc type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides ScoreDoc ToString .)
Back to Top
See Also
FieldDoc Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

FieldDoc ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
FieldDoc Class
FieldDoc Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldDoc Properties

FieldDoc Properties Lucene.Net Class Library
The FieldDoc type exposes the following members.
Properties
 | Name | Description
Public property | Doc | Expert: A hit document's number. (Inherited from ScoreDoc.)
Public property | Score | Expert: The score of this document for the query. (Inherited from ScoreDoc.)
Back to Top
See Also
FieldDoc Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldValueHitQueue Class

FieldValueHitQueue Class Lucene.Net Class Library
Expert: A hit queue for sorting by hits by terms in more than one field. Uses FieldCache.DEFAULT for maintaining internal term lookup tables. NOTE: This API is experimental and might change in incompatible ways in the next release.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util PriorityQueue FieldValueHitQueue Entry
Lucene.Net.Search FieldValueHitQueue

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class FieldValueHitQueue : PriorityQueue<FieldValueHitQueue..::..Entry>
public abstract class FieldValueHitQueue : PriorityQueue<FieldValueHitQueue..::..Entry>
Public MustInherit Class FieldValueHitQueue _
    Inherits PriorityQueue(Of FieldValueHitQueue..::..Entry)
Public MustInherit Class FieldValueHitQueue _
    Inherits PriorityQueue(Of FieldValueHitQueue..::..Entry)
public ref class FieldValueHitQueue abstract : public PriorityQueue<FieldValueHitQueue..::..Entry^>
public ref class FieldValueHitQueue abstract : public PriorityQueue<FieldValueHitQueue..::..Entry^>
See Also
FieldValueHitQueue Members
Lucene.Net.Search Namespace
Searcher Search(Query, Filter, Int32, Sort)
Lucene.Net.Search FieldCache
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldValueHitQueue Members

FieldValueHitQueue Members Lucene.Net Class Library

The FieldValueHitQueue type exposes the following members.
Methods
Name | Description
Public method Add
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an Online IndexOutOfRangeException is thrown.
(Inherited from PriorityQueue T .)
Public method Clear
Removes all entries from the PriorityQueue.
(Inherited from PriorityQueue T .)
Create
Creates a hit queue sorted by the given list of fields.

NOTE: The instances returned by this method pre-allocate a full array of length numHits.
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Initialize
Subclass constructors must call this.
(Inherited from PriorityQueue T .)
Public method InsertWithOverflow
Adds an Object to a PriorityQueue in log(size) time. It returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
(Inherited from PriorityQueue T .)
Public method | LessThan | (Overrides PriorityQueue T LessThan(T, T).)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Pop
Removes and returns the least element of the PriorityQueue in log(size) time.
(Inherited from PriorityQueue T .)
Public method Size
Returns the number of elements currently stored in the PriorityQueue.
(Inherited from PriorityQueue T .)
Public method Top
Returns the least element of the PriorityQueue in constant time.
(Inherited from PriorityQueue T .)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Public method UpdateTop
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
View Colorized Copy to Clipboard Print
pq.top().change();
pq.updateTop();
pq.top().change();
pq.updateTop();
View Colorized Copy to Clipboard Print
o = pq.pop();
o.change();
pq.push(o);
o = pq.pop();
o.change();
pq.push(o);
instead of
(Inherited from PriorityQueue T .)
Back to Top
Fields
 | Name | Description
Protected field | comparators |
Protected field | fields | Stores the sort criteria being used.
Protected field | heap | (Inherited from PriorityQueue T .)
Protected field | reverseMul |
Back to Top
Properties
Name Description
Protected property SentinelObject
This method can be overridden by extending classes to return a sentinel object which will be used by Initialize(Int32) to fill the queue, so that the code which uses that queue can always assume it's full and only change the top without attempting to insert any new object.
Those sentinel values should always compare worse than any non-sentinel value (i.e., LessThan(T, T) should always favor the non-sentinel values).
By default, this method returns false, which means the queue will not be filled with sentinel values. Otherwise, the value returned will be used to pre-populate the queue. Adds sentinel values to the queue.
If this method is extended to return a non-null value, then the following usage pattern is recommended:
View Colorized Copy to Clipboard Print
// extends getSentinelObject() to return a non-null value.
PriorityQueue<MyObject> pq = new MyQueue<MyObject>(numHits);
// save the 'top' element, which is guaranteed to not be null.
MyObject pqTop = pq.top();
<...>
// now in order to add a new element, which is 'better' than top (after
// you've verified it is better), it is as simple as:
pqTop.change().
pqTop = pq.updateTop();
// extends getSentinelObject() to return a non-null value.
PriorityQueue<MyObject> pq = new MyQueue<MyObject>(numHits);
// save the 'top' element, which is guaranteed to not be null.
MyObject pqTop = pq.top();
<...>
// now in order to add a new element, which is 'better' than top (after
// you've verified it is better), it is as simple as:
pqTop.change().
pqTop = pq.updateTop();
NOTE: if this method returns a non-null value, it will be called by Initialize(Int32) Size times, relying on a new object to be returned and will not check if it's null again. Therefore you should ensure any call to this method creates a new instance and behaves consistently, e.g., it cannot return null if it previously returned non-null.
(Inherited from PriorityQueue T .)
Back to Top
See Also
FieldValueHitQueue Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldValueHitQueue Fields

FieldValueHitQueue Fields Lucene.Net Class Library
The FieldValueHitQueue type exposes the following members.
Fields
 | Name | Description
Protected field | comparators |
Protected field | fields | Stores the sort criteria being used.
Protected field | heap | (Inherited from PriorityQueue T .)
Protected field | reverseMul |
Back to Top
See Also
FieldValueHitQueue Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


comparators Field

FieldValueHitQueue comparators Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FieldComparator[] comparators
protected FieldComparator[] comparators
Protected comparators As FieldComparator()
Protected comparators As FieldComparator()
protected:
array<FieldComparator^>^ comparators
protected:
array<FieldComparator^>^ comparators
See Also
FieldValueHitQueue Class
FieldValueHitQueue Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


fields Field

FieldValueHitQueue fields Field Lucene.Net Class Library
Stores the sort criteria being used.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SortField[] fields
protected SortField[] fields
Protected fields As SortField()
Protected fields As SortField()
protected:
array<SortField^>^ fields
protected:
array<SortField^>^ fields
See Also
FieldValueHitQueue Class
FieldValueHitQueue Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


reverseMul Field

FieldValueHitQueue reverseMul Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int[] reverseMul
protected int[] reverseMul
Protected reverseMul As Integer()
Protected reverseMul As Integer()
protected:
array<int>^ reverseMul
protected:
array<int>^ reverseMul
See Also
FieldValueHitQueue Class
FieldValueHitQueue Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldValueHitQueue Methods

FieldValueHitQueue Methods Lucene.Net Class Library
The FieldValueHitQueue type exposes the following members.
Methods
Name | Description
Public method Add
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an Online IndexOutOfRangeException is thrown.
(Inherited from PriorityQueue T .)
Public method Clear
Removes all entries from the PriorityQueue.
(Inherited from PriorityQueue T .)
Create
Creates a hit queue sorted by the given list of fields.

NOTE: The instances returned by this method pre-allocate a full array of length numHits.
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Initialize
Subclass constructors must call this.
(Inherited from PriorityQueue T .)
Public method InsertWithOverflow
Adds an Object to a PriorityQueue in log(size) time. It returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
(Inherited from PriorityQueue T .)
Public method | LessThan | (Overrides PriorityQueue T LessThan(T, T).)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Pop
Removes and returns the least element of the PriorityQueue in log(size) time.
(Inherited from PriorityQueue T .)
Public method Size
Returns the number of elements currently stored in the PriorityQueue.
(Inherited from PriorityQueue T .)
Public method Top
Returns the least element of the PriorityQueue in constant time.
(Inherited from PriorityQueue T .)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Public method UpdateTop
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
View Colorized Copy to Clipboard Print
pq.top().change();
pq.updateTop();
pq.top().change();
pq.updateTop();
View Colorized Copy to Clipboard Print
o = pq.pop();
o.change();
pq.push(o);
o = pq.pop();
o.change();
pq.push(o);
instead of
(Inherited from PriorityQueue T .)
Back to Top
See Also
FieldValueHitQueue Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Create Method

FieldValueHitQueue Create Method Lucene.Net Class Library
Creates a hit queue sorted by the given list of fields.

NOTE: The instances returned by this method pre-allocate a full array of length numHits.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldValueHitQueue Create(
    SortField[] fields,
    int size
)
public static FieldValueHitQueue Create(
    SortField[] fields,
    int size
)
Public Shared Function Create ( _
    fields As SortField(), _
    size As Integer _
) As FieldValueHitQueue
Public Shared Function Create ( _
    fields As SortField(), _
    size As Integer _
) As FieldValueHitQueue
public:
static FieldValueHitQueue^ Create(
    array<SortField^>^ fields,
    int size
)
public:
static FieldValueHitQueue^ Create(
    array<SortField^>^ fields,
    int size
)
Parameters
fields
Type:  Lucene.Net.Search SortField
SortField array we are sorting by in priority order (highest
            priority first); cannot be null or empty

size
Type:   Online System Int32
The number of hits to retain. Must be greater than zero.

See Also
FieldValueHitQueue Class
FieldValueHitQueue Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LessThan Method

FieldValueHitQueue LessThan Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool LessThan(
    FieldValueHitQueue..::..Entry a,
    FieldValueHitQueue..::..Entry b
)
public abstract bool LessThan(
    FieldValueHitQueue..::..Entry a,
    FieldValueHitQueue..::..Entry b
)
Public MustOverride Function LessThan ( _
    a As FieldValueHitQueue..::..Entry, _
    b As FieldValueHitQueue..::..Entry _
) As Boolean
Public MustOverride Function LessThan ( _
    a As FieldValueHitQueue..::..Entry, _
    b As FieldValueHitQueue..::..Entry _
) As Boolean
public:
virtual bool LessThan(
    FieldValueHitQueue..::..Entry^ a,
    FieldValueHitQueue..::..Entry^ b
) abstract override
public:
virtual bool LessThan(
    FieldValueHitQueue..::..Entry^ a,
    FieldValueHitQueue..::..Entry^ b
) abstract override
Parameters
a
Type: Lucene.Net.Search FieldValueHitQueue Entry
b
Type: Lucene.Net.Search FieldValueHitQueue Entry
See Also
FieldValueHitQueue Class
FieldValueHitQueue Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldValueHitQueue Properties

FieldValueHitQueue Properties Lucene.Net Class Library
The FieldValueHitQueue type exposes the following members.
Properties
Name Description
Protected property SentinelObject
This method can be overridden by extending classes to return a sentinel object which will be used by Initialize(Int32) to fill the queue, so that the code which uses that queue can always assume it's full and only change the top without attempting to insert any new object.
Those sentinel values should always compare worse than any non-sentinel value (i.e., LessThan(T, T) should always favor the non-sentinel values).
By default, this method returns false, which means the queue will not be filled with sentinel values. Otherwise, the value returned will be used to pre-populate the queue. Adds sentinel values to the queue.
If this method is extended to return a non-null value, then the following usage pattern is recommended:
View Colorized Copy to Clipboard Print
// extends getSentinelObject() to return a non-null value.
PriorityQueue<MyObject> pq = new MyQueue<MyObject>(numHits);
// save the 'top' element, which is guaranteed to not be null.
MyObject pqTop = pq.top();
<...>
// now in order to add a new element, which is 'better' than top (after
// you've verified it is better), it is as simple as:
pqTop.change().
pqTop = pq.updateTop();
// extends getSentinelObject() to return a non-null value.
PriorityQueue<MyObject> pq = new MyQueue<MyObject>(numHits);
// save the 'top' element, which is guaranteed to not be null.
MyObject pqTop = pq.top();
<...>
// now in order to add a new element, which is 'better' than top (after
// you've verified it is better), it is as simple as:
pqTop.change().
pqTop = pq.updateTop();
NOTE: if this method returns a non-null value, it will be called by Initialize(Int32) Size times, relying on a new object to be returned and will not check if it's null again. Therefore you should ensure any call to this method creates a new instance and behaves consistently, e.g., it cannot return null if it previously returned non-null.
(Inherited from PriorityQueue T .)
Back to Top
See Also
FieldValueHitQueue Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldValueHitQueue.Entry Class

FieldValueHitQueue Entry Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search ScoreDoc
Lucene.Net.Search FieldValueHitQueue Entry

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Entry : ScoreDoc
public sealed class Entry : ScoreDoc
Public NotInheritable Class Entry _
    Inherits ScoreDoc
Public NotInheritable Class Entry _
    Inherits ScoreDoc
public ref class Entry sealed : public ScoreDoc
public ref class Entry sealed : public ScoreDoc
See Also
FieldValueHitQueue Entry Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldValueHitQueue.Entry Members

FieldValueHitQueue Entry Members Lucene.Net Class Library

Expert: A hit queue for sorting by hits by terms in more than one field. Uses FieldCache.DEFAULT for maintaining internal term lookup tables. NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldValueHitQueue Entry type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides ScoreDoc ToString .)
Back to Top
Properties
 | Name | Description
Public property | Doc | Expert: A hit document's number. (Inherited from ScoreDoc.)
Public property | Score | Expert: The score of this document for the query. (Inherited from ScoreDoc.)
Back to Top
See Also
FieldValueHitQueue Entry Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldValueHitQueue.Entry Methods

FieldValueHitQueue Entry Methods Lucene.Net Class Library
The FieldValueHitQueue Entry type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides ScoreDoc ToString .)
Back to Top
See Also
FieldValueHitQueue Entry Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

FieldValueHitQueue Entry ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
FieldValueHitQueue Entry Class
FieldValueHitQueue Entry Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldValueHitQueue.Entry Properties

FieldValueHitQueue Entry Properties Lucene.Net Class Library
The FieldValueHitQueue Entry type exposes the following members.
Properties
 | Name | Description
Public property | Doc | Expert: A hit document's number. (Inherited from ScoreDoc.)
Public property | Score | Expert: The score of this document for the query. (Inherited from ScoreDoc.)
Back to Top
See Also
FieldValueHitQueue Entry Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Filter Class

Filter Class Lucene.Net Class Library
Abstract base class for restricting which documents may be returned during searching.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Filter
Lucene.Net.Search CachingWrapperFilter
Lucene.Net.Search FieldCacheRangeFilter T
Lucene.Net.Search FieldCacheTermsFilter
Lucene.Net.Search MultiTermQueryWrapperFilter T
Lucene.Net.Search QueryWrapperFilter
Lucene.Net.Search SpanFilter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class Filter
[SerializableAttribute]
public abstract class Filter
<SerializableAttribute> _
Public MustInherit Class Filter
<SerializableAttribute> _
Public MustInherit Class Filter
[SerializableAttribute]
public ref class Filter abstract
[SerializableAttribute]
public ref class Filter abstract
See Also
Filter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Filter Members

Filter Members Lucene.Net Class Library

The Filter type exposes the following members.
Constructors
 | Name | Description
Protected method | Filter | Initializes a new instance of the Filter class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | Creates a DocIdSet enumerating the documents that should be permitted in search results. NOTE: null can be returned if no documents are accepted by this Filter. Note: This method will be called once per segment in the index during searching. The returned DocIdSet must refer to document IDs for that segment, not for the top-level reader.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Filter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Filter Constructor

Filter Constructor Lucene.Net Class Library
Initializes a new instance of the Filter class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Filter()
protected Filter()
Protected Sub New
Protected Sub New
protected:
Filter()
protected:
Filter()
See Also
Filter Class
Filter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Filter Methods

Filter Methods Lucene.Net Class Library
The Filter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | Creates a DocIdSet enumerating the documents that should be permitted in search results. NOTE: null can be returned if no documents are accepted by this Filter. Note: This method will be called once per segment in the index during searching. The returned DocIdSet must refer to document IDs for that segment, not for the top-level reader.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Filter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetDocIdSet Method

Filter GetDocIdSet Method Lucene.Net Class Library

Creates a DocIdSet enumerating the documents that should be permitted in search results. NOTE: null can be returned if no documents are accepted by this Filter.

Note: This method will be called once per segment in the index during searching. The returned DocIdSet must refer to document IDs for that segment, not for the top-level reader.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract DocIdSet GetDocIdSet(
    IndexReader reader
)
public abstract DocIdSet GetDocIdSet(
    IndexReader reader
)
Public MustOverride Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Public MustOverride Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) abstract
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) abstract
Parameters
reader
Type: Lucene.Net.Index IndexReader

             A IndexReader instance opened on the index currently
             searched on. Note, it is likely that the provided reader does not
             represent the whole underlying index i.e. if the index has more than
             one segment the given reader only represents a single segment.

Return Value
 a DocIdSet that provides the documents which should be permitted or
             prohibited in search results. NOTE: null can be returned if
             no documents will be accepted by this Filter.

See Also
Filter Class
Filter Members
Lucene.Net.Search Namespace
Lucene.Net.Util DocIdBitSet
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredDocIdSet Class

FilteredDocIdSet Class Lucene.Net Class Library
Abstract decorator class for a DocIdSet implementation that provides on-demand filtering/validation mechanism on a given DocIdSet.

Technically, this same functionality could be achieved with ChainedFilter (under contrib/misc), however the benefit of this class is it never materializes the full bitset for the filter. Instead, the Match(Int32) method is invoked on-demand, per docID visited during searching. If you know few docIDs will be visited, and the logic behind Match(Int32) is relatively costly, this may be a better way to filter than ChainedFilter.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSet
Lucene.Net.Search FilteredDocIdSet

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class FilteredDocIdSet : DocIdSet
public abstract class FilteredDocIdSet : DocIdSet
Public MustInherit Class FilteredDocIdSet _
    Inherits DocIdSet
Public MustInherit Class FilteredDocIdSet _
    Inherits DocIdSet
public ref class FilteredDocIdSet abstract : public DocIdSet
public ref class FilteredDocIdSet abstract : public DocIdSet
See Also
FilteredDocIdSet Members
Lucene.Net.Search Namespace
Lucene.Net.Search DocIdSet
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredDocIdSet Members

FilteredDocIdSet Members Lucene.Net Class Library

The FilteredDocIdSet type exposes the following members.
Constructors
 | Name | Description
Protected method | FilteredDocIdSet | Constructor.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Iterator | Implementation of the contract to build a DocIdSetIterator. (Overrides DocIdSet Iterator .)
Public method | Match | Validation method to determine whether a docid should be in the result set.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | IsCacheable | This DocIdSet implementation is cacheable if the inner set is cacheable. (Overrides DocIdSet IsCacheable.)
Back to Top
See Also
FilteredDocIdSet Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredDocIdSet Constructor

FilteredDocIdSet Constructor Lucene.Net Class Library
Constructor.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FilteredDocIdSet(
    DocIdSet innerSet
)
protected FilteredDocIdSet(
    DocIdSet innerSet
)
Protected Sub New ( _
    innerSet As DocIdSet _
)
Protected Sub New ( _
    innerSet As DocIdSet _
)
protected:
FilteredDocIdSet(
    DocIdSet^ innerSet
)
protected:
FilteredDocIdSet(
    DocIdSet^ innerSet
)
Parameters
innerSet
Type: Lucene.Net.Search DocIdSet
Underlying DocIdSet

See Also
FilteredDocIdSet Class
FilteredDocIdSet Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredDocIdSet Methods

FilteredDocIdSet Methods Lucene.Net Class Library
The FilteredDocIdSet type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Iterator | Implementation of the contract to build a DocIdSetIterator. (Overrides DocIdSet Iterator .)
Public method | Match | Validation method to determine whether a docid should be in the result set.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FilteredDocIdSet Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Iterator Method

FilteredDocIdSet Iterator Method Lucene.Net Class Library
Implementation of the contract to build a DocIdSetIterator.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocIdSetIterator Iterator()
public override DocIdSetIterator Iterator()
Public Overrides Function Iterator As DocIdSetIterator
Public Overrides Function Iterator As DocIdSetIterator
public:
virtual DocIdSetIterator^ Iterator() override
public:
virtual DocIdSetIterator^ Iterator() override
See Also
FilteredDocIdSet Class
FilteredDocIdSet Members
Lucene.Net.Search Namespace
Lucene.Net.Search DocIdSetIterator
Lucene.Net.Search FilteredDocIdSetIterator
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Match Method

FilteredDocIdSet Match Method Lucene.Net Class Library
Validation method to determine whether a docid should be in the result set.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool Match(
    int docid
)
public abstract bool Match(
    int docid
)
Public MustOverride Function Match ( _
    docid As Integer _
) As Boolean
Public MustOverride Function Match ( _
    docid As Integer _
) As Boolean
public:
virtual bool Match(
    int docid
) abstract
public:
virtual bool Match(
    int docid
) abstract
Parameters
docid
Type:   Online System Int32
docid to be tested

Return Value
 true if input docid should be in the result set, false otherwise.

See Also
FilteredDocIdSet Class
FilteredDocIdSet Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredDocIdSet Properties

FilteredDocIdSet Properties Lucene.Net Class Library
The FilteredDocIdSet type exposes the following members.
Properties
 | Name | Description
Public property | IsCacheable | This DocIdSet implementation is cacheable if the inner set is cacheable. (Overrides DocIdSet IsCacheable.)
Back to Top
See Also
FilteredDocIdSet Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsCacheable Property

FilteredDocIdSet IsCacheable Property Lucene.Net Class Library
This DocIdSet implementation is cacheable if the inner set is cacheable.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsCacheable { get; }
public override bool IsCacheable { get; }
Public Overrides ReadOnly Property IsCacheable As Boolean
    Get
Public Overrides ReadOnly Property IsCacheable As Boolean
    Get
public:
virtual property bool IsCacheable {
    bool get () override;
}
public:
virtual property bool IsCacheable {
    bool get () override;
}
See Also
FilteredDocIdSet Class
FilteredDocIdSet Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredDocIdSetIterator Class

FilteredDocIdSetIterator Class Lucene.Net Class Library
Abstract decorator class of a DocIdSetIterator implementation that provides on-demand filter/validation mechanism on an underlying DocIdSetIterator. See FilteredDocIdSet .
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSetIterator
Lucene.Net.Search FilteredDocIdSetIterator

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class FilteredDocIdSetIterator : DocIdSetIterator
public abstract class FilteredDocIdSetIterator : DocIdSetIterator
Public MustInherit Class FilteredDocIdSetIterator _
    Inherits DocIdSetIterator
Public MustInherit Class FilteredDocIdSetIterator _
    Inherits DocIdSetIterator
public ref class FilteredDocIdSetIterator abstract : public DocIdSetIterator
public ref class FilteredDocIdSetIterator abstract : public DocIdSetIterator
See Also
FilteredDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredDocIdSetIterator Members

FilteredDocIdSetIterator Members Lucene.Net Class Library

The FilteredDocIdSetIterator type exposes the following members.
Constructors
 | Name | Description
Protected method | FilteredDocIdSetIterator | Constructor.
Back to Top
Methods
 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match | Validation method to determine whether a docid should be in the result set.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Overrides DocIdSetIterator NextDoc .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | internalInnerIter |
Back to Top
See Also
FilteredDocIdSetIterator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredDocIdSetIterator Constructor

FilteredDocIdSetIterator Constructor Lucene.Net Class Library
Constructor.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FilteredDocIdSetIterator(
    DocIdSetIterator innerIter
)
protected FilteredDocIdSetIterator(
    DocIdSetIterator innerIter
)
Protected Sub New ( _
    innerIter As DocIdSetIterator _
)
Protected Sub New ( _
    innerIter As DocIdSetIterator _
)
protected:
FilteredDocIdSetIterator(
    DocIdSetIterator^ innerIter
)
protected:
FilteredDocIdSetIterator(
    DocIdSetIterator^ innerIter
)
Parameters
innerIter
Type: Lucene.Net.Search DocIdSetIterator
Underlying DocIdSetIterator.

See Also
FilteredDocIdSetIterator Class
FilteredDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredDocIdSetIterator Fields

FilteredDocIdSetIterator Fields Lucene.Net Class Library
The FilteredDocIdSetIterator type exposes the following members.
Fields
 | Name | Description
Protected field | internalInnerIter |
Back to Top
See Also
FilteredDocIdSetIterator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalInnerIter Field

FilteredDocIdSetIterator internalInnerIter Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DocIdSetIterator internalInnerIter
protected DocIdSetIterator internalInnerIter
Protected internalInnerIter As DocIdSetIterator
Protected internalInnerIter As DocIdSetIterator
protected:
DocIdSetIterator^ internalInnerIter
protected:
DocIdSetIterator^ internalInnerIter
See Also
FilteredDocIdSetIterator Class
FilteredDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredDocIdSetIterator Methods

FilteredDocIdSetIterator Methods Lucene.Net Class Library
The FilteredDocIdSetIterator type exposes the following members.
Methods
 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match | Validation method to determine whether a docid should be in the result set.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Overrides DocIdSetIterator NextDoc .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FilteredDocIdSetIterator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Advance Method

FilteredDocIdSetIterator Advance Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Advance(
    int target
)
public override int Advance(
    int target
)
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
public:
virtual int Advance(
    int target
) override
public:
virtual int Advance(
    int target
) override
Parameters
target
Type:   Online System Int32
See Also
FilteredDocIdSetIterator Class
FilteredDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocID Method

FilteredDocIdSetIterator DocID Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocID()
public override int DocID()
Public Overrides Function DocID As Integer
Public Overrides Function DocID As Integer
public:
virtual int DocID() override
public:
virtual int DocID() override
See Also
FilteredDocIdSetIterator Class
FilteredDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Match Method

FilteredDocIdSetIterator Match Method Lucene.Net Class Library
Validation method to determine whether a docid should be in the result set.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool Match(
    int doc
)
public abstract bool Match(
    int doc
)
Public MustOverride Function Match ( _
    doc As Integer _
) As Boolean
Public MustOverride Function Match ( _
    doc As Integer _
) As Boolean
public:
virtual bool Match(
    int doc
) abstract
public:
virtual bool Match(
    int doc
) abstract
Parameters
doc
Type:   Online System Int32
docid to be tested

Return Value
 true if input docid should be in the result set, false otherwise.

See Also
FilteredDocIdSetIterator Class
FilteredDocIdSetIterator Members
Lucene.Net.Search Namespace
FilteredDocIdSetIterator FilteredDocIdSetIterator(DocIdSetIterator)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextDoc Method

FilteredDocIdSetIterator NextDoc Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int NextDoc()
public override int NextDoc()
Public Overrides Function NextDoc As Integer
Public Overrides Function NextDoc As Integer
public:
virtual int NextDoc() override
public:
virtual int NextDoc() override
See Also
FilteredDocIdSetIterator Class
FilteredDocIdSetIterator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredQuery Class

FilteredQuery Class Lucene.Net Class Library
A query that applies a filter to the results of another query.

Note: the bits are retrieved from the filter each time this query is used in a search - use a CachingWrapperFilter to avoid regenerating the bits every time.

Created: Apr 20, 2004 8:58:29 AM
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search FilteredQuery

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FilteredQuery : Query
[SerializableAttribute]
public class FilteredQuery : Query
<SerializableAttribute> _
Public Class FilteredQuery _
    Inherits Query
<SerializableAttribute> _
Public Class FilteredQuery _
    Inherits Query
[SerializableAttribute]
public ref class FilteredQuery : public Query
[SerializableAttribute]
public ref class FilteredQuery : public Query
See Also
FilteredQuery Members
Lucene.Net.Search Namespace
Lucene.Net.Search CachingWrapperFilter
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredQuery Members

FilteredQuery Members Lucene.Net Class Library

The FilteredQuery type exposes the following members.
Constructors
 | Name | Description
Public method | FilteredQuery | Constructs a new query which applies a filter to the results of the original query. Filter.getDocIdSet() will be called every time this query is used in a search.
Back to Top
Methods
 | Name | Description
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | Returns a Weight that applies the filter to the enclosed query's Weight. This is accomplished by overriding the Scorer returned by the Weight. (Overrides Query CreateWeight(Searcher).)
Public method | Equals | Returns true iff o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | Rewrites the wrapped query. (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Filter |
Public property | Query |
Back to Top
See Also
FilteredQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredQuery Constructor

FilteredQuery Constructor Lucene.Net Class Library
Constructs a new query which applies a filter to the results of the original query. Filter.getDocIdSet() will be called every time this query is used in a search.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FilteredQuery(
    Query query,
    Filter filter
)
public FilteredQuery(
    Query query,
    Filter filter
)
Public Sub New ( _
    query As Query, _
    filter As Filter _
)
Public Sub New ( _
    query As Query, _
    filter As Filter _
)
public:
FilteredQuery(
    Query^ query,
    Filter^ filter
)
public:
FilteredQuery(
    Query^ query,
    Filter^ filter
)
Parameters
query
Type: Lucene.Net.Search Query
 Query to be filtered, cannot be null.

filter
Type: Lucene.Net.Search Filter
Filter to apply to query results, cannot be null.

See Also
FilteredQuery Class
FilteredQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredQuery Methods

FilteredQuery Methods Lucene.Net Class Library
The FilteredQuery type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | Returns a Weight that applies the filter to the enclosed query's Weight. This is accomplished by overriding the Scorer returned by the Weight. (Overrides Query CreateWeight(Searcher).)
Public method | Equals | Returns true iff o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | Rewrites the wrapped query. (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
FilteredQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateWeight Method

FilteredQuery CreateWeight Method Lucene.Net Class Library
Returns a Weight that applies the filter to the enclosed query's Weight. This is accomplished by overriding the Scorer returned by the Weight.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Weight CreateWeight(
    Searcher searcher
)
public override Weight CreateWeight(
    Searcher searcher
)
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
FilteredQuery Class
FilteredQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

FilteredQuery Equals Method Lucene.Net Class Library
Returns true iff o is equal to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
FilteredQuery Class
FilteredQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExtractTerms Method

FilteredQuery ExtractTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ExtractTerms(
    ISet<Term> terms
)
public override void ExtractTerms(
    ISet<Term> terms
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
Parameters
terms
Type:   Online System.Collections.Generic ISet  Term
See Also
FilteredQuery Class
FilteredQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

FilteredQuery GetHashCode Method Lucene.Net Class Library
Returns a hash code value for this object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
FilteredQuery Class
FilteredQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

FilteredQuery Rewrite Method Lucene.Net Class Library
Rewrites the wrapped query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    IndexReader reader
)
public override Query Rewrite(
    IndexReader reader
)
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
FilteredQuery Class
FilteredQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

FilteredQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Back to Top
See Also
FilteredQuery Class
FilteredQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

FilteredQuery ToString Method (String) Lucene.Net Class Library
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string s
)
public override string ToString(
    string s
)
Public Overrides Function ToString ( _
    s As String _
) As String
Public Overrides Function ToString ( _
    s As String _
) As String
public:
virtual String^ ToString(
    String^ s
) override
public:
virtual String^ ToString(
    String^ s
) override
Parameters
s
Type:   Online System String
See Also
FilteredQuery Class
FilteredQuery Members
ToString Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredQuery Properties

FilteredQuery Properties Lucene.Net Class Library
The FilteredQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Filter |
Public property | Query |
Back to Top
See Also
FilteredQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Filter Property

FilteredQuery Filter Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Filter Filter { get; }
public virtual Filter Filter { get; }
Public Overridable ReadOnly Property Filter As Filter
    Get
Public Overridable ReadOnly Property Filter As Filter
    Get
public:
virtual property Filter^ Filter {
    Filter^ get ();
}
public:
virtual property Filter^ Filter {
    Filter^ get ();
}
See Also
FilteredQuery Class
FilteredQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Query Property

FilteredQuery Query Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Query Query { get; }
public virtual Query Query { get; }
Public Overridable ReadOnly Property Query As Query
    Get
Public Overridable ReadOnly Property Query As Query
    Get
public:
virtual property Query^ Query {
    Query^ get ();
}
public:
virtual property Query^ Query {
    Query^ get ();
}
See Also
FilteredQuery Class
FilteredQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredTermEnum Class

FilteredTermEnum Class Lucene.Net Class Library
Abstract class for enumerating a subset of all terms.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index TermEnum
Lucene.Net.Search FilteredTermEnum
Lucene.Net.Search FuzzyTermEnum
Lucene.Net.Search PrefixTermEnum
Lucene.Net.Search SingleTermEnum
Lucene.Net.Search TermRangeTermEnum
Lucene.Net.Search WildcardTermEnum

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class FilteredTermEnum : TermEnum
public abstract class FilteredTermEnum : TermEnum
Public MustInherit Class FilteredTermEnum _
    Inherits TermEnum
Public MustInherit Class FilteredTermEnum _
    Inherits TermEnum
public ref class FilteredTermEnum abstract : public TermEnum
public ref class FilteredTermEnum abstract : public TermEnum
See Also
FilteredTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredTermEnum Members

FilteredTermEnum Members Lucene.Net Class Library

The FilteredTermEnum type exposes the following members.
Constructors
 | Name | Description
Protected method | FilteredTermEnum | Initializes a new instance of the FilteredTermEnum class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Public method | Difference | Equality measure on the term
Public method | Dispose | Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FilteredTermEnum and optionally releases the managed resources (Overrides TermEnum Dispose(Boolean).)
Public method | DocFreq | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated. (Overrides TermEnum DocFreq .)
Public method | EndEnum | Indicates the end of the enumeration has been reached
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | Increments the enumeration to the next element. True if one exists. (Overrides TermEnum Next .)
Protected method | SetEnum | use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term.
Protected method | TermCompare | Equality compare on the term
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use SetEnum(TermEnum)
Protected field | currentTerm | the current term
Back to Top
Properties
 | Name | Description
Public property | Term | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated. (Overrides TermEnum Term.)
Back to Top
See Also
FilteredTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredTermEnum Constructor

FilteredTermEnum Constructor Lucene.Net Class Library
Initializes a new instance of the FilteredTermEnum class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FilteredTermEnum()
protected FilteredTermEnum()
Protected Sub New
Protected Sub New
protected:
FilteredTermEnum()
protected:
FilteredTermEnum()
See Also
FilteredTermEnum Class
FilteredTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredTermEnum Fields

FilteredTermEnum Fields Lucene.Net Class Library
The FilteredTermEnum type exposes the following members.
Fields
 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use SetEnum(TermEnum)
Protected field | currentTerm | the current term
Back to Top
See Also
FilteredTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


actualEnum Field

FilteredTermEnum actualEnum Field Lucene.Net Class Library
the delegate enum - to set this member use SetEnum(TermEnum)

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TermEnum actualEnum
protected TermEnum actualEnum
Protected actualEnum As TermEnum
Protected actualEnum As TermEnum
protected:
TermEnum^ actualEnum
protected:
TermEnum^ actualEnum
See Also
FilteredTermEnum Class
FilteredTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


currentTerm Field

FilteredTermEnum currentTerm Field Lucene.Net Class Library
the current term

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Term currentTerm
protected Term currentTerm
Protected currentTerm As Term
Protected currentTerm As Term
protected:
Term^ currentTerm
protected:
Term^ currentTerm
See Also
FilteredTermEnum Class
FilteredTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredTermEnum Methods

FilteredTermEnum Methods Lucene.Net Class Library
The FilteredTermEnum type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Public method | Difference | Equality measure on the term
Public method | Dispose | Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Protected method | Dispose(Boolean) | (Overrides TermEnum Dispose(Boolean).)
Public method | DocFreq | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated. (Overrides TermEnum DocFreq .)
Public method | EndEnum | Indicates the end of the enumeration has been reached
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | Increments the enumeration to the next element. True if one exists. (Overrides TermEnum Next .)
Protected method | SetEnum | use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term.
Protected method | TermCompare | Equality compare on the term
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FilteredTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Difference Method

FilteredTermEnum Difference Method Lucene.Net Class Library
Equality measure on the term

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract float Difference()
public abstract float Difference()
Public MustOverride Function Difference As Single
Public MustOverride Function Difference As Single
public:
virtual float Difference() abstract
public:
virtual float Difference() abstract
See Also
FilteredTermEnum Class
FilteredTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

FilteredTermEnum Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FilteredTermEnum and optionally releases the managed resources (Overrides TermEnum Dispose(Boolean).)
Back to Top
See Also
FilteredTermEnum Class
FilteredTermEnum Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

FilteredTermEnum Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the FilteredTermEnum and optionally releases the managed resources

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
FilteredTermEnum Class
FilteredTermEnum Members
Dispose Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocFreq Method

FilteredTermEnum DocFreq Method Lucene.Net Class Library
Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocFreq()
public override int DocFreq()
Public Overrides Function DocFreq As Integer
Public Overrides Function DocFreq As Integer
public:
virtual int DocFreq() override
public:
virtual int DocFreq() override
See Also
FilteredTermEnum Class
FilteredTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EndEnum Method

FilteredTermEnum EndEnum Method Lucene.Net Class Library
Indicates the end of the enumeration has been reached

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool EndEnum()
public abstract bool EndEnum()
Public MustOverride Function EndEnum As Boolean
Public MustOverride Function EndEnum As Boolean
public:
virtual bool EndEnum() abstract
public:
virtual bool EndEnum() abstract
See Also
FilteredTermEnum Class
FilteredTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Next Method

FilteredTermEnum Next Method Lucene.Net Class Library
Increments the enumeration to the next element. True if one exists.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Next()
public override bool Next()
Public Overrides Function Next As Boolean
Public Overrides Function Next As Boolean
public:
virtual bool Next() override
public:
virtual bool Next() override
See Also
FilteredTermEnum Class
FilteredTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetEnum Method

FilteredTermEnum SetEnum Method Lucene.Net Class Library
use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void SetEnum(
    TermEnum actualEnum
)
protected virtual void SetEnum(
    TermEnum actualEnum
)
Protected Overridable Sub SetEnum ( _
    actualEnum As TermEnum _
)
Protected Overridable Sub SetEnum ( _
    actualEnum As TermEnum _
)
protected:
virtual void SetEnum(
    TermEnum^ actualEnum
)
protected:
virtual void SetEnum(
    TermEnum^ actualEnum
)
Parameters
actualEnum
Type: Lucene.Net.Index TermEnum
See Also
FilteredTermEnum Class
FilteredTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermCompare Method

FilteredTermEnum TermCompare Method Lucene.Net Class Library
Equality compare on the term

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract bool TermCompare(
    Term term
)
protected abstract bool TermCompare(
    Term term
)
Protected MustOverride Function TermCompare ( _
    term As Term _
) As Boolean
Protected MustOverride Function TermCompare ( _
    term As Term _
) As Boolean
protected:
virtual bool TermCompare(
    Term^ term
) abstract
protected:
virtual bool TermCompare(
    Term^ term
) abstract
Parameters
term
Type: Lucene.Net.Index Term
See Also
FilteredTermEnum Class
FilteredTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilteredTermEnum Properties

FilteredTermEnum Properties Lucene.Net Class Library
The FilteredTermEnum type exposes the following members.
Properties
 | Name | Description
Public property | Term | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated. (Overrides TermEnum Term.)
Back to Top
See Also
FilteredTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Property

FilteredTermEnum Term Property Lucene.Net Class Library
Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Term Term { get; }
public override Term Term { get; }
Public Overrides ReadOnly Property Term As Term
    Get
Public Overrides ReadOnly Property Term As Term
    Get
public:
virtual property Term^ Term {
    Term^ get () override;
}
public:
virtual property Term^ Term {
    Term^ get () override;
}
See Also
FilteredTermEnum Class
FilteredTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterManager Class

FilterManager Class Lucene.Net Class Library
Filter caching singleton. It can be used to save filters locally for reuse. This class makes it possble to cache Filters even when using RMI, as it keeps the cache on the seaercher side of the RMI connection. Also could be used as a persistent storage for any filter as long as the filter provides a proper hashCode(), as that is used as the key in the cache. The cache is periodically cleaned up from a separate thread to ensure the cache doesn't exceed the maximum size.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FilterManager

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FilterManager
public class FilterManager
Public Class FilterManager
Public Class FilterManager
public ref class FilterManager
public ref class FilterManager
See Also
FilterManager Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterManager Members

FilterManager Members Lucene.Net Class Library

The FilterManager type exposes the following members.
Constructors
 | Name | Description
Protected method | FilterManager | Sets up the FilterManager singleton.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetFilter | Returns the cached version of the filter. Allows the caller to pass up a small filter but this will keep a persistent version around and allow the caching filter to do its job.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetCacheSize | Sets the max size that cache should reach before it is cleaned up
Public method | SetCleanThreadSleepTime | Sets the cache cleaning frequency in milliseconds.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | cache | The cache itself
Protected field | cacheCleanSize | Maximum allowed cache size
Protected field | cleanSleepTime | Cache cleaning frequency
 | DEFAULT_CACHE_CLEAN_SIZE | The default maximum number of Filters in the cache
 | DEFAULT_CACHE_SLEEP_TIME | The default frequency of cache clenup
Protected field | internalFilterCleaner | Cache cleaner that runs in a separate thread
 | manager |
Back to Top
Properties
Name | Description
Instance |
Back to Top
See Also
FilterManager Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterManager Constructor

FilterManager Constructor Lucene.Net Class Library
Sets up the FilterManager singleton.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FilterManager()
protected FilterManager()
Protected Sub New
Protected Sub New
protected:
FilterManager()
protected:
FilterManager()
See Also
FilterManager Class
FilterManager Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterManager Fields

FilterManager Fields Lucene.Net Class Library
The FilterManager type exposes the following members.
Fields
 | Name | Description
Protected field | cache | The cache itself
Protected field | cacheCleanSize | Maximum allowed cache size
Protected field | cleanSleepTime | Cache cleaning frequency
 | DEFAULT_CACHE_CLEAN_SIZE | The default maximum number of Filters in the cache
 | DEFAULT_CACHE_SLEEP_TIME | The default frequency of cache clenup
Protected field | internalFilterCleaner | Cache cleaner that runs in a separate thread
 | manager |
Back to Top
See Also
FilterManager Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


cache Field

FilterManager cache Field Lucene.Net Class Library
The cache itself

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IDictionary<int, FilterManager..::..FilterItem> cache
protected IDictionary<int, FilterManager..::..FilterItem> cache
Protected cache As IDictionary(Of Integer, FilterManager..::..FilterItem)
Protected cache As IDictionary(Of Integer, FilterManager..::..FilterItem)
protected:
IDictionary<int, FilterManager..::..FilterItem^>^ cache
protected:
IDictionary<int, FilterManager..::..FilterItem^>^ cache
See Also
FilterManager Class
FilterManager Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


cacheCleanSize Field

FilterManager cacheCleanSize Field Lucene.Net Class Library
Maximum allowed cache size

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int cacheCleanSize
protected int cacheCleanSize
Protected cacheCleanSize As Integer
Protected cacheCleanSize As Integer
protected:
int cacheCleanSize
protected:
int cacheCleanSize
See Also
FilterManager Class
FilterManager Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


cleanSleepTime Field

FilterManager cleanSleepTime Field Lucene.Net Class Library
Cache cleaning frequency

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected long cleanSleepTime
protected long cleanSleepTime
Protected cleanSleepTime As Long
Protected cleanSleepTime As Long
protected:
long long cleanSleepTime
protected:
long long cleanSleepTime
See Also
FilterManager Class
FilterManager Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_CACHE_CLEAN_SIZE Field

FilterManager DEFAULT_CACHE_CLEAN_SIZE Field Lucene.Net Class Library
The default maximum number of Filters in the cache

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int DEFAULT_CACHE_CLEAN_SIZE
protected const int DEFAULT_CACHE_CLEAN_SIZE
Protected Const DEFAULT_CACHE_CLEAN_SIZE As Integer
Protected Const DEFAULT_CACHE_CLEAN_SIZE As Integer
protected:
literal int DEFAULT_CACHE_CLEAN_SIZE
protected:
literal int DEFAULT_CACHE_CLEAN_SIZE
See Also
FilterManager Class
FilterManager Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_CACHE_SLEEP_TIME Field

FilterManager DEFAULT_CACHE_SLEEP_TIME Field Lucene.Net Class Library
The default frequency of cache clenup

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const long DEFAULT_CACHE_SLEEP_TIME
protected const long DEFAULT_CACHE_SLEEP_TIME
Protected Const DEFAULT_CACHE_SLEEP_TIME As Long
Protected Const DEFAULT_CACHE_SLEEP_TIME As Long
protected:
literal long long DEFAULT_CACHE_SLEEP_TIME
protected:
literal long long DEFAULT_CACHE_SLEEP_TIME
See Also
FilterManager Class
FilterManager Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalFilterCleaner Field

FilterManager internalFilterCleaner Field Lucene.Net Class Library
Cache cleaner that runs in a separate thread

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FilterManager..::..FilterCleaner internalFilterCleaner
protected FilterManager..::..FilterCleaner internalFilterCleaner
Protected internalFilterCleaner As FilterManager..::..FilterCleaner
Protected internalFilterCleaner As FilterManager..::..FilterCleaner
protected:
FilterManager..::..FilterCleaner^ internalFilterCleaner
protected:
FilterManager..::..FilterCleaner^ internalFilterCleaner
See Also
FilterManager Class
FilterManager Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


manager Field

FilterManager manager Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static FilterManager manager
protected static FilterManager manager
Protected Shared manager As FilterManager
Protected Shared manager As FilterManager
protected:
static FilterManager^ manager
protected:
static FilterManager^ manager
See Also
FilterManager Class
FilterManager Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterManager Methods

FilterManager Methods Lucene.Net Class Library
The FilterManager type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetFilter | Returns the cached version of the filter. Allows the caller to pass up a small filter but this will keep a persistent version around and allow the caching filter to do its job.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetCacheSize | Sets the max size that cache should reach before it is cleaned up
Public method | SetCleanThreadSleepTime | Sets the cache cleaning frequency in milliseconds.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FilterManager Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFilter Method

FilterManager GetFilter Method Lucene.Net Class Library
Returns the cached version of the filter. Allows the caller to pass up a small filter but this will keep a persistent version around and allow the caching filter to do its job.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Filter GetFilter(
    Filter filter
)
public virtual Filter GetFilter(
    Filter filter
)
Public Overridable Function GetFilter ( _
    filter As Filter _
) As Filter
Public Overridable Function GetFilter ( _
    filter As Filter _
) As Filter
public:
virtual Filter^ GetFilter(
    Filter^ filter
)
public:
virtual Filter^ GetFilter(
    Filter^ filter
)
Parameters
filter
Type: Lucene.Net.Search Filter
The input filter

Return Value
 The cached version of the filter

See Also
FilterManager Class
FilterManager Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetCacheSize Method

FilterManager SetCacheSize Method Lucene.Net Class Library
Sets the max size that cache should reach before it is cleaned up

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetCacheSize(
    int value
)
public virtual void SetCacheSize(
    int value
)
Public Overridable Sub SetCacheSize ( _
    value As Integer _
)
Public Overridable Sub SetCacheSize ( _
    value As Integer _
)
public:
virtual void SetCacheSize(
    int value
)
public:
virtual void SetCacheSize(
    int value
)
Parameters
value
Type:   Online System Int32
 maximum allowed cache size
See Also
FilterManager Class
FilterManager Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetCleanThreadSleepTime Method

FilterManager SetCleanThreadSleepTime Method Lucene.Net Class Library
Sets the cache cleaning frequency in milliseconds.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetCleanThreadSleepTime(
    long value
)
public virtual void SetCleanThreadSleepTime(
    long value
)
Public Overridable Sub SetCleanThreadSleepTime ( _
    value As Long _
)
Public Overridable Sub SetCleanThreadSleepTime ( _
    value As Long _
)
public:
virtual void SetCleanThreadSleepTime(
    long long value
)
public:
virtual void SetCleanThreadSleepTime(
    long long value
)
Parameters
value
Type:   Online System Int64
 cleaning frequency in millioseconds
See Also
FilterManager Class
FilterManager Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterManager Properties

FilterManager Properties Lucene.Net Class Library
The FilterManager type exposes the following members.
Properties
Name | Description
Instance |
Back to Top
See Also
FilterManager Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Instance Property

FilterManager Instance Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FilterManager Instance { get; }
public static FilterManager Instance { get; }
Public Shared ReadOnly Property Instance As FilterManager
    Get
Public Shared ReadOnly Property Instance As FilterManager
    Get
public:
static property FilterManager^ Instance {
    FilterManager^ get ();
}
public:
static property FilterManager^ Instance {
    FilterManager^ get ();
}
See Also
FilterManager Class
FilterManager Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterManager.FilterCleaner Class

FilterManager FilterCleaner Class Lucene.Net Class Library
Keeps the cache from getting too big. If we were using Java 1.5, we could use LinkedHashMap and we would not need this thread to clean out the cache. The SortedSet sortedFilterItems is used only to sort the items from the cache, so when it's time to clean up we have the TreeSet sort the FilterItems by timestamp. Removes 1.5 * the numbers of items to make the cache smaller. For example: If cache clean size is 10, and the cache is at 15, we would remove (15 - 10) * 1.5 = 7.5 round up to 8. This way we clean the cache a bit more, and avoid having the cache cleaner having to do it frequently.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FilterManager FilterCleaner

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal class FilterCleaner : IThreadRunnable
protected internal class FilterCleaner : IThreadRunnable
Protected Friend Class FilterCleaner _
    Implements IThreadRunnable
Protected Friend Class FilterCleaner _
    Implements IThreadRunnable
protected public ref class FilterCleaner : IThreadRunnable
protected public ref class FilterCleaner : IThreadRunnable
See Also
FilterManager FilterCleaner Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterManager.FilterCleaner Members

FilterManager FilterCleaner Members Lucene.Net Class Library

Filter caching singleton. It can be used to save filters locally for reuse. This class makes it possble to cache Filters even when using RMI, as it keeps the cache on the seaercher side of the RMI connection. Also could be used as a persistent storage for any filter as long as the filter provides a proper hashCode(), as that is used as the key in the cache. The cache is periodically cleaned up from a separate thread to ensure the cache doesn't exceed the maximum size.

The FilterManager FilterCleaner type exposes the following members.
Constructors
 | Name | Description
Public method | FilterManager FilterCleaner | Initializes a new instance of the FilterManager FilterCleaner class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Run |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FilterManager FilterCleaner Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterManager.FilterCleaner Constructor

FilterManager FilterCleaner Constructor Lucene.Net Class Library
Initializes a new instance of the FilterManager FilterCleaner class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FilterCleaner(
    FilterManager enclosingInstance
)
public FilterCleaner(
    FilterManager enclosingInstance
)
Public Sub New ( _
    enclosingInstance As FilterManager _
)
Public Sub New ( _
    enclosingInstance As FilterManager _
)
public:
FilterCleaner(
    FilterManager^ enclosingInstance
)
public:
FilterCleaner(
    FilterManager^ enclosingInstance
)
Parameters
enclosingInstance
Type: Lucene.Net.Search FilterManager
See Also
FilterManager FilterCleaner Class
FilterManager FilterCleaner Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterManager.FilterCleaner Methods

FilterManager FilterCleaner Methods Lucene.Net Class Library
The FilterManager FilterCleaner type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Run |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FilterManager FilterCleaner Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Run Method

FilterManager FilterCleaner Run Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Run()
public virtual void Run()
Public Overridable Sub Run
Public Overridable Sub Run
public:
virtual void Run()
public:
virtual void Run()
Implements
IThreadRunnable Run
See Also
FilterManager FilterCleaner Class
FilterManager FilterCleaner Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterManager.FilterItem Class

FilterManager FilterItem Class Lucene.Net Class Library
Holds the filter and the last time the filter was used, to make LRU-based cache cleaning possible. TODO: Clean this up when we switch to Java 1.5
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FilterManager FilterItem

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal class FilterItem
protected internal class FilterItem
Protected Friend Class FilterItem
Protected Friend Class FilterItem
protected public ref class FilterItem
protected public ref class FilterItem
See Also
FilterManager FilterItem Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterManager.FilterItem Members

FilterManager FilterItem Members Lucene.Net Class Library

Filter caching singleton. It can be used to save filters locally for reuse. This class makes it possble to cache Filters even when using RMI, as it keeps the cache on the seaercher side of the RMI connection. Also could be used as a persistent storage for any filter as long as the filter provides a proper hashCode(), as that is used as the key in the cache. The cache is periodically cleaned up from a separate thread to ensure the cache doesn't exceed the maximum size.

The FilterManager FilterItem type exposes the following members.
Constructors
 | Name | Description
Public method | FilterManager FilterItem | Initializes a new instance of the FilterManager FilterItem class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Public field | filter |
Public field | timestamp |
Back to Top
See Also
FilterManager FilterItem Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterManager.FilterItem Constructor

FilterManager FilterItem Constructor Lucene.Net Class Library
Initializes a new instance of the FilterManager FilterItem class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FilterItem(
    Filter filter
)
public FilterItem(
    Filter filter
)
Public Sub New ( _
    filter As Filter _
)
Public Sub New ( _
    filter As Filter _
)
public:
FilterItem(
    Filter^ filter
)
public:
FilterItem(
    Filter^ filter
)
Parameters
filter
Type: Lucene.Net.Search Filter
See Also
FilterManager FilterItem Class
FilterManager FilterItem Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterManager.FilterItem Fields

FilterManager FilterItem Fields Lucene.Net Class Library
The FilterManager FilterItem type exposes the following members.
Fields
 | Name | Description
Public field | filter |
Public field | timestamp |
Back to Top
See Also
FilterManager FilterItem Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


filter Field

FilterManager FilterItem filter Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Filter filter
public Filter filter
Public filter As Filter
Public filter As Filter
public:
Filter^ filter
public:
Filter^ filter
See Also
FilterManager FilterItem Class
FilterManager FilterItem Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


timestamp Field

FilterManager FilterItem timestamp Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long timestamp
public long timestamp
Public timestamp As Long
Public timestamp As Long
public:
long long timestamp
public:
long long timestamp
See Also
FilterManager FilterItem Class
FilterManager FilterItem Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilterManager.FilterItem Methods

FilterManager FilterItem Methods Lucene.Net Class Library
The FilterManager FilterItem type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FilterManager FilterItem Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FloatParser Interface

FloatParser Interface Lucene.Net Class Library
Interface to parse floats from document fields.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface FloatParser : Parser
public interface FloatParser : Parser
Public Interface FloatParser _
    Inherits Parser
Public Interface FloatParser _
    Inherits Parser
public interface class FloatParser : Parser
public interface class FloatParser : Parser
See Also
FloatParser Members
Lucene.Net.Search Namespace
FieldCache GetFloats(IndexReader, String, FloatParser)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FloatParser Members

FloatParser Members Lucene.Net Class Library

The FloatParser type exposes the following members.
Methods
 | Name | Description
Public method | ParseFloat | Return an float representation of this field's value.
Back to Top
See Also
FloatParser Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FloatParser Methods

FloatParser Methods Lucene.Net Class Library
The FloatParser type exposes the following members.
Methods
 | Name | Description
Public method | ParseFloat | Return an float representation of this field's value.
Back to Top
See Also
FloatParser Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseFloat Method

FloatParser ParseFloat Method Lucene.Net Class Library
Return an float representation of this field's value.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
float ParseFloat(
    string string_Renamed
)
float ParseFloat(
    string string_Renamed
)
Function ParseFloat ( _
    string_Renamed As String _
) As Single
Function ParseFloat ( _
    string_Renamed As String _
) As Single
float ParseFloat(
    String^ string_Renamed
)
float ParseFloat(
    String^ string_Renamed
)
Parameters
string_Renamed
Type:   Online System String
See Also
FloatParser Interface
FloatParser Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyQuery Class

FuzzyQuery Class Lucene.Net Class Library
Implements the fuzzy search query. The similarity measurement is based on the Levenshtein (edit distance) algorithm. Warning: this query is not very scalable with its default prefix length of 0 - in this case, *every* term will be enumerated and cause an edit score calculation.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search MultiTermQuery
Lucene.Net.Search FuzzyQuery

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FuzzyQuery : MultiTermQuery
[SerializableAttribute]
public class FuzzyQuery : MultiTermQuery
<SerializableAttribute> _
Public Class FuzzyQuery _
    Inherits MultiTermQuery
<SerializableAttribute> _
Public Class FuzzyQuery _
    Inherits MultiTermQuery
[SerializableAttribute]
public ref class FuzzyQuery : public MultiTermQuery
[SerializableAttribute]
public ref class FuzzyQuery : public MultiTermQuery
See Also
FuzzyQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyQuery Members

FuzzyQuery Members Lucene.Net Class Library

The FuzzyQuery type exposes the following members.
Constructors
 | Name | Description
Public method | FuzzyQuery(Term) | Calls FuzzyQuery(term, 0.5f, 0).
Public method | FuzzyQuery(Term, Single) | Calls FuzzyQuery(term, minimumSimilarity, 0).
Public method | FuzzyQuery(Term, Single, Int32) | Create a new FuzzyQuery that will match terms with a similarity of at least minimumSimilarity to term. If a prefixLength > 0 is specified, a common prefix of that length is also required.
Back to Top
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the query/filter. (Inherited from MultiTermQuery.)
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | Expert: Constructs an appropriate Weight implementation for this query. Only implemented by primitive queries, which re-write to themselves. (Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery Equals(Object).)
Public method | ExtractTerms | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its rewritten form. (Inherited from Query.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetEnum | (Overrides MultiTermQuery GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides MultiTermQuery Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Fields
 | Name | Description
 | defaultMinSimilarity |
 | defaultPrefixLength |
Protected field | internalRewriteMethod | (Inherited from MultiTermQuery.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | MinSimilarity | Returns the minimum similarity that is required for this query to match.
Public property | PrefixLength | Returns the non-fuzzy prefix length. This is the number of characters at the start of a term that must be identical (not fuzzy) to the query term if the query is to match that term.
Public property | RewriteMethod | (Overrides MultiTermQuery RewriteMethod.)
Public property | Term | Returns the pattern term.
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers. (Inherited from MultiTermQuery.)
Back to Top
See Also
FuzzyQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyQuery Constructor

FuzzyQuery Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | FuzzyQuery(Term) | Calls FuzzyQuery(term, 0.5f, 0).
Public method | FuzzyQuery(Term, Single) | Calls FuzzyQuery(term, minimumSimilarity, 0).
Public method | FuzzyQuery(Term, Single, Int32) | Create a new FuzzyQuery that will match terms with a similarity of at least minimumSimilarity to term. If a prefixLength > 0 is specified, a common prefix of that length is also required.
Back to Top
See Also
FuzzyQuery Class
FuzzyQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyQuery Constructor (Term)

FuzzyQuery Constructor (Term) Lucene.Net Class Library
Calls FuzzyQuery(term, 0.5f, 0).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FuzzyQuery(
    Term term
)
public FuzzyQuery(
    Term term
)
Public Sub New ( _
    term As Term _
)
Public Sub New ( _
    term As Term _
)
public:
FuzzyQuery(
    Term^ term
)
public:
FuzzyQuery(
    Term^ term
)
Parameters
term
Type: Lucene.Net.Index Term
See Also
FuzzyQuery Class
FuzzyQuery Members
FuzzyQuery Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyQuery Constructor (Term, Single)

FuzzyQuery Constructor (Term, Single) Lucene.Net Class Library
Calls FuzzyQuery(term, minimumSimilarity, 0).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FuzzyQuery(
    Term term,
    float minimumSimilarity
)
public FuzzyQuery(
    Term term,
    float minimumSimilarity
)
Public Sub New ( _
    term As Term, _
    minimumSimilarity As Single _
)
Public Sub New ( _
    term As Term, _
    minimumSimilarity As Single _
)
public:
FuzzyQuery(
    Term^ term,
    float minimumSimilarity
)
public:
FuzzyQuery(
    Term^ term,
    float minimumSimilarity
)
Parameters
term
Type: Lucene.Net.Index Term
minimumSimilarity
Type:   Online System Single
See Also
FuzzyQuery Class
FuzzyQuery Members
FuzzyQuery Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyQuery Constructor (Term, Single, Int32)

FuzzyQuery Constructor (Term, Single, Int32) Lucene.Net Class Library
Create a new FuzzyQuery that will match terms with a similarity of at least minimumSimilarity to term. If a prefixLength > 0 is specified, a common prefix of that length is also required.
or if prefixLength < 0

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FuzzyQuery(
    Term term,
    float minimumSimilarity,
    int prefixLength
)
public FuzzyQuery(
    Term term,
    float minimumSimilarity,
    int prefixLength
)
Public Sub New ( _
    term As Term, _
    minimumSimilarity As Single, _
    prefixLength As Integer _
)
Public Sub New ( _
    term As Term, _
    minimumSimilarity As Single, _
    prefixLength As Integer _
)
public:
FuzzyQuery(
    Term^ term,
    float minimumSimilarity,
    int prefixLength
)
public:
FuzzyQuery(
    Term^ term,
    float minimumSimilarity,
    int prefixLength
)
Parameters
term
Type: Lucene.Net.Index Term
the term to search for

minimumSimilarity
Type:   Online System Single
a value between 0 and 1 to set the required similarity
            between the query term and the matching terms. For example, for a
            minimumSimilarity of 0.5 a term of the same length
            as the query term is considered similar to the query term if the edit distance
            between both terms is less than length(term)*0.5
prefixLength
Type:   Online System Int32
length of common (non-fuzzy) prefix

See Also
FuzzyQuery Class
FuzzyQuery Members
FuzzyQuery Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyQuery Fields

FuzzyQuery Fields Lucene.Net Class Library
The FuzzyQuery type exposes the following members.
Fields
 | Name | Description
 | defaultMinSimilarity |
 | defaultPrefixLength |
Protected field | internalRewriteMethod | (Inherited from MultiTermQuery.)
Back to Top
See Also
FuzzyQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


defaultMinSimilarity Field

FuzzyQuery defaultMinSimilarity Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const float defaultMinSimilarity
public const float defaultMinSimilarity
Public Const defaultMinSimilarity As Single
Public Const defaultMinSimilarity As Single
public:
literal float defaultMinSimilarity
public:
literal float defaultMinSimilarity
See Also
FuzzyQuery Class
FuzzyQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


defaultPrefixLength Field

FuzzyQuery defaultPrefixLength Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int defaultPrefixLength
public const int defaultPrefixLength
Public Const defaultPrefixLength As Integer
Public Const defaultPrefixLength As Integer
public:
literal int defaultPrefixLength
public:
literal int defaultPrefixLength
See Also
FuzzyQuery Class
FuzzyQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyQuery Methods

FuzzyQuery Methods Lucene.Net Class Library
The FuzzyQuery type exposes the following members.
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the query/filter. (Inherited from MultiTermQuery.)
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | Expert: Constructs an appropriate Weight implementation for this query. Only implemented by primitive queries, which re-write to themselves. (Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery Equals(Object).)
Public method | ExtractTerms | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its rewritten form. (Inherited from Query.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetEnum | (Overrides MultiTermQuery GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides MultiTermQuery Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
FuzzyQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

FuzzyQuery Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
FuzzyQuery Class
FuzzyQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetEnum Method

FuzzyQuery GetEnum Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override FilteredTermEnum GetEnum(
    IndexReader reader
)
protected override FilteredTermEnum GetEnum(
    IndexReader reader
)
Protected Overrides Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
Protected Overrides Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
protected:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) override
protected:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
FuzzyQuery Class
FuzzyQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

FuzzyQuery GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
FuzzyQuery Class
FuzzyQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

FuzzyQuery Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    IndexReader reader
)
public override Query Rewrite(
    IndexReader reader
)
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
FuzzyQuery Class
FuzzyQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

FuzzyQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Back to Top
See Also
FuzzyQuery Class
FuzzyQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

FuzzyQuery ToString Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
FuzzyQuery Class
FuzzyQuery Members
ToString Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyQuery Properties

FuzzyQuery Properties Lucene.Net Class Library
The FuzzyQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | MinSimilarity | Returns the minimum similarity that is required for this query to match.
Public property | PrefixLength | Returns the non-fuzzy prefix length. This is the number of characters at the start of a term that must be identical (not fuzzy) to the query term if the query is to match that term.
Public property | RewriteMethod | (Overrides MultiTermQuery RewriteMethod.)
Public property | Term | Returns the pattern term.
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers. (Inherited from MultiTermQuery.)
Back to Top
See Also
FuzzyQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MinSimilarity Property

FuzzyQuery MinSimilarity Property Lucene.Net Class Library
Returns the minimum similarity that is required for this query to match.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual float MinSimilarity { get; }
public virtual float MinSimilarity { get; }
Public Overridable ReadOnly Property MinSimilarity As Single
    Get
Public Overridable ReadOnly Property MinSimilarity As Single
    Get
public:
virtual property float MinSimilarity {
    float get ();
}
public:
virtual property float MinSimilarity {
    float get ();
}
Field Value
 float value between 0.0 and 1.0
See Also
FuzzyQuery Class
FuzzyQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixLength Property

FuzzyQuery PrefixLength Property Lucene.Net Class Library
Returns the non-fuzzy prefix length. This is the number of characters at the start of a term that must be identical (not fuzzy) to the query term if the query is to match that term.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int PrefixLength { get; }
public virtual int PrefixLength { get; }
Public Overridable ReadOnly Property PrefixLength As Integer
    Get
Public Overridable ReadOnly Property PrefixLength As Integer
    Get
public:
virtual property int PrefixLength {
    int get ();
}
public:
virtual property int PrefixLength {
    int get ();
}
See Also
FuzzyQuery Class
FuzzyQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RewriteMethod Property

FuzzyQuery RewriteMethod Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override RewriteMethod RewriteMethod { set; }
public override RewriteMethod RewriteMethod { set; }
Public Overrides WriteOnly Property RewriteMethod As RewriteMethod
    Set
Public Overrides WriteOnly Property RewriteMethod As RewriteMethod
    Set
public:
virtual property RewriteMethod^ RewriteMethod {
    void set (RewriteMethod^ value) override;
}
public:
virtual property RewriteMethod^ RewriteMethod {
    void set (RewriteMethod^ value) override;
}
See Also
FuzzyQuery Class
FuzzyQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Property

FuzzyQuery Term Property Lucene.Net Class Library
Returns the pattern term.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Term Term { get; protected internal set; }
public Term Term { get; protected internal set; }
Public Property Term As Term
    Get
    Protected Friend Set
Public Property Term As Term
    Get
    Protected Friend Set
public:
property Term^ Term {
    Term^ get ();
    protected public: void set (Term^ value);
}
public:
property Term^ Term {
    Term^ get ();
    protected public: void set (Term^ value);
}
See Also
FuzzyQuery Class
FuzzyQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyQuery.ScoreTerm Class

FuzzyQuery ScoreTerm Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search FuzzyQuery ScoreTerm

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal class ScoreTerm : IComparable<FuzzyQuery..::..ScoreTerm>
protected internal class ScoreTerm : IComparable<FuzzyQuery..::..ScoreTerm>
Protected Friend Class ScoreTerm _
    Implements IComparable(Of FuzzyQuery..::..ScoreTerm)
Protected Friend Class ScoreTerm _
    Implements IComparable(Of FuzzyQuery..::..ScoreTerm)
protected public ref class ScoreTerm : IComparable<FuzzyQuery..::..ScoreTerm^>
protected public ref class ScoreTerm : IComparable<FuzzyQuery..::..ScoreTerm^>
See Also
FuzzyQuery ScoreTerm Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyQuery.ScoreTerm Members

FuzzyQuery ScoreTerm Members Lucene.Net Class Library

Implements the fuzzy search query. The similarity measurement is based on the Levenshtein (edit distance) algorithm. Warning: this query is not very scalable with its default prefix length of 0 - in this case, *every* term will be enumerated and cause an edit score calculation.

The FuzzyQuery ScoreTerm type exposes the following members.
Constructors
 | Name | Description
Public method | FuzzyQuery ScoreTerm | Initializes a new instance of the FuzzyQuery ScoreTerm class
Back to Top
Methods
 | Name | Description
Public method | CompareTo |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Public field | score |
Public field | term |
Back to Top
See Also
FuzzyQuery ScoreTerm Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyQuery.ScoreTerm Constructor

FuzzyQuery ScoreTerm Constructor Lucene.Net Class Library
Initializes a new instance of the FuzzyQuery ScoreTerm class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ScoreTerm()
public ScoreTerm()
Public Sub New
Public Sub New
public:
ScoreTerm()
public:
ScoreTerm()
See Also
FuzzyQuery ScoreTerm Class
FuzzyQuery ScoreTerm Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyQuery.ScoreTerm Fields

FuzzyQuery ScoreTerm Fields Lucene.Net Class Library
The FuzzyQuery ScoreTerm type exposes the following members.
Fields
 | Name | Description
Public field | score |
Public field | term |
Back to Top
See Also
FuzzyQuery ScoreTerm Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


score Field

FuzzyQuery ScoreTerm score Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float score
public float score
Public score As Single
Public score As Single
public:
float score
public:
float score
See Also
FuzzyQuery ScoreTerm Class
FuzzyQuery ScoreTerm Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


term Field

FuzzyQuery ScoreTerm term Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Term term
public Term term
Public term As Term
Public term As Term
public:
Term^ term
public:
Term^ term
See Also
FuzzyQuery ScoreTerm Class
FuzzyQuery ScoreTerm Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyQuery.ScoreTerm Methods

FuzzyQuery ScoreTerm Methods Lucene.Net Class Library
The FuzzyQuery ScoreTerm type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FuzzyQuery ScoreTerm Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompareTo Method

FuzzyQuery ScoreTerm CompareTo Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    FuzzyQuery..::..ScoreTerm other
)
public int CompareTo(
    FuzzyQuery..::..ScoreTerm other
)
Public Function CompareTo ( _
    other As FuzzyQuery..::..ScoreTerm _
) As Integer
Public Function CompareTo ( _
    other As FuzzyQuery..::..ScoreTerm _
) As Integer
public:
virtual int CompareTo(
    FuzzyQuery..::..ScoreTerm^ other
) sealed
public:
virtual int CompareTo(
    FuzzyQuery..::..ScoreTerm^ other
) sealed
Parameters
other
Type: Lucene.Net.Search FuzzyQuery ScoreTerm
See Also
FuzzyQuery ScoreTerm Class
FuzzyQuery ScoreTerm Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyTermEnum Class

FuzzyTermEnum Class Lucene.Net Class Library
Subclass of FilteredTermEnum for enumerating all terms that are similiar to the specified filter term.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index TermEnum
Lucene.Net.Search FilteredTermEnum
Lucene.Net.Search FuzzyTermEnum

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class FuzzyTermEnum : FilteredTermEnum
public sealed class FuzzyTermEnum : FilteredTermEnum
Public NotInheritable Class FuzzyTermEnum _
    Inherits FilteredTermEnum
Public NotInheritable Class FuzzyTermEnum _
    Inherits FilteredTermEnum
public ref class FuzzyTermEnum sealed : public FilteredTermEnum
public ref class FuzzyTermEnum sealed : public FilteredTermEnum
See Also
FuzzyTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyTermEnum Members

FuzzyTermEnum Members Lucene.Net Class Library

The FuzzyTermEnum type exposes the following members.
Constructors
 | Name | Description
Public method | FuzzyTermEnum(IndexReader, Term) | Creates a FuzzyTermEnum with an empty prefix and a minSimilarity of 0.5f. After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.
Public method | FuzzyTermEnum(IndexReader, Term, Single) | Creates a FuzzyTermEnum with an empty prefix. After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.
Public method | FuzzyTermEnum(IndexReader, Term, Single, Int32) | Constructor for enumeration of all terms from specified reader which share a prefix of length prefixLength with term and which have a fuzzy similarity > minSimilarity. After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Public method | Difference | (Overrides FilteredTermEnum Difference .)
Public method | Dispose | Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FuzzyTermEnum and optionally releases the managed resources (Overrides FilteredTermEnum Dispose(Boolean).)
Public method | DocFreq | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum EndEnum .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | Increments the enumeration to the next element. True if one exists. (Inherited from FilteredTermEnum.)
Protected method | SetEnum | use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term. (Inherited from FilteredTermEnum.)
Protected method | TermCompare | The termCompare method in FuzzyTermEnum uses Levenshtein distance to calculate the distance between the given term and the comparing term. (Overrides FilteredTermEnum TermCompare(Term).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use SetEnum(TermEnum) (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)
Back to Top
Properties
 | Name | Description
Public property | Term | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Back to Top
See Also
FuzzyTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyTermEnum Constructor

FuzzyTermEnum Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | FuzzyTermEnum(IndexReader, Term) | Creates a FuzzyTermEnum with an empty prefix and a minSimilarity of 0.5f. After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.
Public method | FuzzyTermEnum(IndexReader, Term, Single) | Creates a FuzzyTermEnum with an empty prefix. After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.
Public method | FuzzyTermEnum(IndexReader, Term, Single, Int32) | Constructor for enumeration of all terms from specified reader which share a prefix of length prefixLength with term and which have a fuzzy similarity > minSimilarity. After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.
Back to Top
See Also
FuzzyTermEnum Class
FuzzyTermEnum Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyTermEnum Constructor (IndexReader, Term)

FuzzyTermEnum Constructor (IndexReader, Term) Lucene.Net Class Library
Creates a FuzzyTermEnum with an empty prefix and a minSimilarity of 0.5f.

After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FuzzyTermEnum(
    IndexReader reader,
    Term term
)
public FuzzyTermEnum(
    IndexReader reader,
    Term term
)
Public Sub New ( _
    reader As IndexReader, _
    term As Term _
)
Public Sub New ( _
    reader As IndexReader, _
    term As Term _
)
public:
FuzzyTermEnum(
    IndexReader^ reader,
    Term^ term
)
public:
FuzzyTermEnum(
    IndexReader^ reader,
    Term^ term
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
term
Type: Lucene.Net.Index Term
See Also
FuzzyTermEnum Class
FuzzyTermEnum Members
FuzzyTermEnum Overload
Lucene.Net.Search Namespace
FuzzyTermEnum FuzzyTermEnum(IndexReader, Term, Single, Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyTermEnum Constructor (IndexReader, Term, Single)

FuzzyTermEnum Constructor (IndexReader, Term, Single) Lucene.Net Class Library
Creates a FuzzyTermEnum with an empty prefix.

After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FuzzyTermEnum(
    IndexReader reader,
    Term term,
    float minSimilarity
)
public FuzzyTermEnum(
    IndexReader reader,
    Term term,
    float minSimilarity
)
Public Sub New ( _
    reader As IndexReader, _
    term As Term, _
    minSimilarity As Single _
)
Public Sub New ( _
    reader As IndexReader, _
    term As Term, _
    minSimilarity As Single _
)
public:
FuzzyTermEnum(
    IndexReader^ reader,
    Term^ term,
    float minSimilarity
)
public:
FuzzyTermEnum(
    IndexReader^ reader,
    Term^ term,
    float minSimilarity
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
term
Type: Lucene.Net.Index Term
minSimilarity
Type:   Online System Single
See Also
FuzzyTermEnum Class
FuzzyTermEnum Members
FuzzyTermEnum Overload
Lucene.Net.Search Namespace
FuzzyTermEnum FuzzyTermEnum(IndexReader, Term, Single, Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyTermEnum Constructor (IndexReader, Term, Single, Int32)

FuzzyTermEnum Constructor (IndexReader, Term, Single, Int32) Lucene.Net Class Library
Constructor for enumeration of all terms from specified reader which share a prefix of length prefixLength with term and which have a fuzzy similarity > minSimilarity.

After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FuzzyTermEnum(
    IndexReader reader,
    Term term,
    float minSimilarity,
    int prefixLength
)
public FuzzyTermEnum(
    IndexReader reader,
    Term term,
    float minSimilarity,
    int prefixLength
)
Public Sub New ( _
    reader As IndexReader, _
    term As Term, _
    minSimilarity As Single, _
    prefixLength As Integer _
)
Public Sub New ( _
    reader As IndexReader, _
    term As Term, _
    minSimilarity As Single, _
    prefixLength As Integer _
)
public:
FuzzyTermEnum(
    IndexReader^ reader,
    Term^ term,
    float minSimilarity,
    int prefixLength
)
public:
FuzzyTermEnum(
    IndexReader^ reader,
    Term^ term,
    float minSimilarity,
    int prefixLength
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
Delivers terms.

term
Type: Lucene.Net.Index Term
Pattern term.

minSimilarity
Type:   Online System Single
Minimum required similarity for terms from the reader. Default value is 0.5f.

prefixLength
Type:   Online System Int32
Length of required common prefix. Default value is 0.

See Also
FuzzyTermEnum Class
FuzzyTermEnum Members
FuzzyTermEnum Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyTermEnum Fields

FuzzyTermEnum Fields Lucene.Net Class Library
The FuzzyTermEnum type exposes the following members.
Fields
 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use SetEnum(TermEnum) (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)
Back to Top
See Also
FuzzyTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyTermEnum Methods

FuzzyTermEnum Methods Lucene.Net Class Library
The FuzzyTermEnum type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Public method | Difference | (Overrides FilteredTermEnum Difference .)
Public method | Dispose | Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Protected method | Dispose(Boolean) | (Overrides FilteredTermEnum Dispose(Boolean).)
Public method | DocFreq | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum EndEnum .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | Increments the enumeration to the next element. True if one exists. (Inherited from FilteredTermEnum.)
Protected method | SetEnum | use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term. (Inherited from FilteredTermEnum.)
Protected method | TermCompare | The termCompare method in FuzzyTermEnum uses Levenshtein distance to calculate the distance between the given term and the comparing term. (Overrides FilteredTermEnum TermCompare(Term).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FuzzyTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Difference Method

FuzzyTermEnum Difference Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Difference()
public override float Difference()
Public Overrides Function Difference As Single
Public Overrides Function Difference As Single
public:
virtual float Difference() override
public:
virtual float Difference() override
See Also
FuzzyTermEnum Class
FuzzyTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

FuzzyTermEnum Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FuzzyTermEnum and optionally releases the managed resources (Overrides FilteredTermEnum Dispose(Boolean).)
Back to Top
See Also
FuzzyTermEnum Class
FuzzyTermEnum Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

FuzzyTermEnum Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the FuzzyTermEnum and optionally releases the managed resources

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
FuzzyTermEnum Class
FuzzyTermEnum Members
Dispose Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EndEnum Method

FuzzyTermEnum EndEnum Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool EndEnum()
public override bool EndEnum()
Public Overrides Function EndEnum As Boolean
Public Overrides Function EndEnum As Boolean
public:
virtual bool EndEnum() override
public:
virtual bool EndEnum() override
See Also
FuzzyTermEnum Class
FuzzyTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermCompare Method

FuzzyTermEnum TermCompare Method Lucene.Net Class Library
The termCompare method in FuzzyTermEnum uses Levenshtein distance to calculate the distance between the given term and the comparing term.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool TermCompare(
    Term term
)
protected override bool TermCompare(
    Term term
)
Protected Overrides Function TermCompare ( _
    term As Term _
) As Boolean
Protected Overrides Function TermCompare ( _
    term As Term _
) As Boolean
protected:
virtual bool TermCompare(
    Term^ term
) override
protected:
virtual bool TermCompare(
    Term^ term
) override
Parameters
term
Type: Lucene.Net.Index Term
See Also
FuzzyTermEnum Class
FuzzyTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FuzzyTermEnum Properties

FuzzyTermEnum Properties Lucene.Net Class Library
The FuzzyTermEnum type exposes the following members.
Properties
 | Name | Description
Public property | Term | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Back to Top
See Also
FuzzyTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HitQueue Class

HitQueue Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Util PriorityQueue ScoreDoc
Lucene.Net.Search HitQueue

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class HitQueue : PriorityQueue<ScoreDoc>
public sealed class HitQueue : PriorityQueue<ScoreDoc>
Public NotInheritable Class HitQueue _
    Inherits PriorityQueue(Of ScoreDoc)
Public NotInheritable Class HitQueue _
    Inherits PriorityQueue(Of ScoreDoc)
public ref class HitQueue sealed : public PriorityQueue<ScoreDoc^>
public ref class HitQueue sealed : public PriorityQueue<ScoreDoc^>
See Also
HitQueue Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HitQueue Members

HitQueue Members Lucene.Net Class Library

The HitQueue type exposes the following members.
Constructors
Name Description
Public method HitQueue
Creates a new instance with size elements. If prePopulate is set to true, the queue will pre-populate itself with sentinel objects and set its Size to size. In that case, you should not rely on Size to get the number of actual elements that were added to the queue, but keep track yourself.
NOTE: in case prePopulate is true, you should pop elements from the queue using the following code example:
View Colorized Copy to Clipboard Print
PriorityQueue pq = new HitQueue(10, true); // pre-populate.
ScoreDoc top = pq.top();

// Add/Update one element.
top.score = 1.0f;
top.doc = 0;
top = (ScoreDoc) pq.updateTop();
int totalHits = 1;

// Now pop only the elements that were *truly* inserted.
// First, pop all the sentinel elements (there are pq.size() - totalHits).
for (int i = pq.size() - totalHits; i > 0; i--) pq.pop();

// Now pop the truly added elements.
ScoreDoc[] results = new ScoreDoc[totalHits];
for (int i = totalHits - 1; i >= 0; i--) {
results[i] = (ScoreDoc) pq.pop();
}
PriorityQueue pq = new HitQueue(10, true); // pre-populate.
ScoreDoc top = pq.top();

// Add/Update one element.
top.score = 1.0f;
top.doc = 0;
top = (ScoreDoc) pq.updateTop();
int totalHits = 1;

// Now pop only the elements that were *truly* inserted.
// First, pop all the sentinel elements (there are pq.size() - totalHits).
for (int i = pq.size() - totalHits; i > 0; i--) pq.pop();

// Now pop the truly added elements.
ScoreDoc[] results = new ScoreDoc[totalHits];
for (int i = totalHits - 1; i >= 0; i--) {
results[i] = (ScoreDoc) pq.pop();
}

NOTE: This class pre-allocate a full array of length size.
Back to Top
Methods
Name | Description
Public method Add
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an Online IndexOutOfRangeException is thrown.
(Inherited from PriorityQueue T .)
Public method Clear
Removes all entries from the PriorityQueue.
(Inherited from PriorityQueue T .)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Initialize
Subclass constructors must call this.
(Inherited from PriorityQueue T .)
Public method InsertWithOverflow
Adds an Object to a PriorityQueue in log(size) time. It returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
(Inherited from PriorityQueue T .)
Public method | LessThan | (Overrides PriorityQueue T LessThan(T, T).)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Pop
Removes and returns the least element of the PriorityQueue in log(size) time.
(Inherited from PriorityQueue T .)
Public method Size
Returns the number of elements currently stored in the PriorityQueue.
(Inherited from PriorityQueue T .)
Public method Top
Returns the least element of the PriorityQueue in constant time.
(Inherited from PriorityQueue T .)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Public method UpdateTop
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
View Colorized Copy to Clipboard Print
pq.top().change();
pq.updateTop();
pq.top().change();
pq.updateTop();
View Colorized Copy to Clipboard Print
o = pq.pop();
o.change();
pq.push(o);
o = pq.pop();
o.change();
pq.push(o);
instead of
(Inherited from PriorityQueue T .)
Back to Top
Fields
 | Name | Description
Protected field | heap | (Inherited from PriorityQueue T .)
Back to Top
Properties
 | Name | Description
Protected property | SentinelObject | (Overrides PriorityQueue T SentinelObject.)
Back to Top
See Also
HitQueue Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HitQueue Constructor

HitQueue Constructor Lucene.Net Class Library
Creates a new instance with size elements. If prePopulate is set to true, the queue will pre-populate itself with sentinel objects and set its Size to size. In that case, you should not rely on Size to get the number of actual elements that were added to the queue, but keep track yourself.
NOTE: in case prePopulate is true, you should pop elements from the queue using the following code example:
View Colorized Copy to Clipboard Print
PriorityQueue pq = new HitQueue(10, true); // pre-populate.
ScoreDoc top = pq.top();

// Add/Update one element.
top.score = 1.0f;
top.doc = 0;
top = (ScoreDoc) pq.updateTop();
int totalHits = 1;

// Now pop only the elements that were *truly* inserted.
// First, pop all the sentinel elements (there are pq.size() - totalHits).
for (int i = pq.size() - totalHits; i > 0; i--) pq.pop();

// Now pop the truly added elements.
ScoreDoc[] results = new ScoreDoc[totalHits];
for (int i = totalHits - 1; i >= 0; i--) {
results[i] = (ScoreDoc) pq.pop();
}
PriorityQueue pq = new HitQueue(10, true); // pre-populate.
ScoreDoc top = pq.top();

// Add/Update one element.
top.score = 1.0f;
top.doc = 0;
top = (ScoreDoc) pq.updateTop();
int totalHits = 1;

// Now pop only the elements that were *truly* inserted.
// First, pop all the sentinel elements (there are pq.size() - totalHits).
for (int i = pq.size() - totalHits; i > 0; i--) pq.pop();

// Now pop the truly added elements.
ScoreDoc[] results = new ScoreDoc[totalHits];
for (int i = totalHits - 1; i >= 0; i--) {
results[i] = (ScoreDoc) pq.pop();
}

NOTE: This class pre-allocate a full array of length size.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HitQueue(
    int size,
    bool prePopulate
)
public HitQueue(
    int size,
    bool prePopulate
)
Public Sub New ( _
    size As Integer, _
    prePopulate As Boolean _
)
Public Sub New ( _
    size As Integer, _
    prePopulate As Boolean _
)
public:
HitQueue(
    int size,
    bool prePopulate
)
public:
HitQueue(
    int size,
    bool prePopulate
)
Parameters
size
Type:   Online System Int32
the requested size of this queue.

prePopulate
Type:   Online System Boolean
specifies whether to pre-populate the queue with sentinel values.

See Also
HitQueue Class
HitQueue Members
Lucene.Net.Search Namespace
HitQueue SentinelObject
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HitQueue Fields

HitQueue Fields Lucene.Net Class Library
The HitQueue type exposes the following members.
Fields
 | Name | Description
Protected field | heap | (Inherited from PriorityQueue T .)
Back to Top
See Also
HitQueue Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HitQueue Methods

HitQueue Methods Lucene.Net Class Library
The HitQueue type exposes the following members.
Methods
Name | Description
Public method Add
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an Online IndexOutOfRangeException is thrown.
(Inherited from PriorityQueue T .)
Public method Clear
Removes all entries from the PriorityQueue.
(Inherited from PriorityQueue T .)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Initialize
Subclass constructors must call this.
(Inherited from PriorityQueue T .)
Public method InsertWithOverflow
Adds an Object to a PriorityQueue in log(size) time. It returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
(Inherited from PriorityQueue T .)
Public method | LessThan | (Overrides PriorityQueue T LessThan(T, T).)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Pop
Removes and returns the least element of the PriorityQueue in log(size) time.
(Inherited from PriorityQueue T .)
Public method Size
Returns the number of elements currently stored in the PriorityQueue.
(Inherited from PriorityQueue T .)
Public method Top
Returns the least element of the PriorityQueue in constant time.
(Inherited from PriorityQueue T .)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Public method UpdateTop
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
View Colorized Copy to Clipboard Print
pq.top().change();
pq.updateTop();
pq.top().change();
pq.updateTop();
View Colorized Copy to Clipboard Print
o = pq.pop();
o.change();
pq.push(o);
o = pq.pop();
o.change();
pq.push(o);
instead of
(Inherited from PriorityQueue T .)
Back to Top
See Also
HitQueue Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LessThan Method

HitQueue LessThan Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool LessThan(
    ScoreDoc hitA,
    ScoreDoc hitB
)
public override bool LessThan(
    ScoreDoc hitA,
    ScoreDoc hitB
)
Public Overrides Function LessThan ( _
    hitA As ScoreDoc, _
    hitB As ScoreDoc _
) As Boolean
Public Overrides Function LessThan ( _
    hitA As ScoreDoc, _
    hitB As ScoreDoc _
) As Boolean
public:
virtual bool LessThan(
    ScoreDoc^ hitA,
    ScoreDoc^ hitB
) override
public:
virtual bool LessThan(
    ScoreDoc^ hitA,
    ScoreDoc^ hitB
) override
Parameters
hitA
Type: Lucene.Net.Search ScoreDoc
hitB
Type: Lucene.Net.Search ScoreDoc
See Also
HitQueue Class
HitQueue Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HitQueue Properties

HitQueue Properties Lucene.Net Class Library
The HitQueue type exposes the following members.
Properties
 | Name | Description
Protected property | SentinelObject | (Overrides PriorityQueue T SentinelObject.)
Back to Top
See Also
HitQueue Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SentinelObject Property

HitQueue SentinelObject Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override ScoreDoc SentinelObject { get; }
protected override ScoreDoc SentinelObject { get; }
Protected Overrides ReadOnly Property SentinelObject As ScoreDoc
    Get
Protected Overrides ReadOnly Property SentinelObject As ScoreDoc
    Get
protected:
virtual property ScoreDoc^ SentinelObject {
    ScoreDoc^ get () override;
}
protected:
virtual property ScoreDoc^ SentinelObject {
    ScoreDoc^ get () override;
}
See Also
HitQueue Class
HitQueue Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexSearcher Class

IndexSearcher Class Lucene.Net Class Library
Implements search over a single IndexReader.

Applications usually need only call the inherited Search(Query, Int32) or Search(Query, Filter, Int32) methods. For performance reasons it is recommended to open only one IndexSearcher and use it for all of your searches.

NOTE: IndexSearcher instances are completely thread safe, meaning multiple threads can call any of its methods, concurrently. If your application requires external synchronization, you should not synchronize on the IndexSearcher instance; use your own (non-Lucene) objects instead.

Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Lucene.Net.Search Searcher
Lucene.Net.Search IndexSearcher

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class IndexSearcher : Searcher
[SerializableAttribute]
public class IndexSearcher : Searcher
<SerializableAttribute> _
Public Class IndexSearcher _
    Inherits Searcher
<SerializableAttribute> _
Public Class IndexSearcher _
    Inherits Searcher
[SerializableAttribute]
public ref class IndexSearcher : public Searcher
[SerializableAttribute]
public ref class IndexSearcher : public Searcher
See Also
IndexSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexSearcher Members

IndexSearcher Members Lucene.Net Class Library

The IndexSearcher type exposes the following members.
Constructors
 | Name | Description
Public method | IndexSearcher(Directory) | Creates a searcher searching the index in the named directory, with readOnly=true
Public method | IndexSearcher(IndexReader) | Creates a searcher searching the provided index Note that the underlying IndexReader is not closed, if IndexSearcher was constructed with IndexSearcher(IndexReader r). If the IndexReader was supplied implicitly by specifying a directory, then the IndexReader gets closed.
Public method | IndexSearcher(Directory, Boolean) | Creates a searcher searching the index in the named directory. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the underlying IndexReader.
Public method | IndexSearcher(IndexReader, IndexReader , Int32 ) | Expert: directly specify the reader, subReaders and their DocID starts NOTE: This API is experimental and might change in incompatible ways in the next release
Back to Top
Methods
Name | Description
Public method | Close | Obsolete. (Inherited from Searcher.)
Public method Online CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from Online MarshalByRefObject.)
Public method CreateWeight
creates a weight for query
(Inherited from Searcher.)
Public method | Dispose | (Inherited from Searcher.)
Protected method Dispose(Boolean)
Releases the unmanaged resources used by the IndexSearcher and optionally releases the managed resources
(Overrides Searcher Dispose(Boolean).)
Public method | Doc(Int32) | (Overrides Searcher Doc(Int32).)
Public method | Doc(Int32, FieldSelector) | (Overrides Searcher Doc(Int32, FieldSelector).)
Public method | DocFreq | (Overrides Searcher DocFreq(Term).)
Public method | DocFreqs | (Inherited from Searcher.)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Public method Explain(Query, Int32)
Returns an Explanation that describes how doc scored against query.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.
(Inherited from Searcher.)
Public method | Explain(Weight, Int32) | (Overrides Searcher Explain(Weight, Int32).)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Protected method | GatherSubReaders
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from Online MarshalByRefObject.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method Online InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from Online MarshalByRefObject.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Protected method Online MemberwiseClone(Boolean)
Creates a shallow copy of the current Online MarshalByRefObject object.
(Inherited from Online MarshalByRefObject.)
Public method | Rewrite | (Overrides Searcher Rewrite(Query).)
Public method Search(Query, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32) ) is usually more efficient, as it skips non-high-scoring hits.

Note: The score passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top n hits for query.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Filter, Int32)) is usually more efficient, as it skips non-high-scoring hits.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top n hits for query, applying filter if non-null.
(Inherited from Searcher.)
Public method | Search(Weight, Filter, Collector) | (Overrides Searcher Search(Weight, Filter, Collector).)
Public method | Search(Weight, Filter, Int32) | (Overrides Searcher Search(Weight, Filter, Int32).)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top n hits for query, applying filter if non-null, and sorting the hits by the criteria in sort.

NOTE: this does not compute scores by default; use SetDefaultFieldSortScoring(Boolean, Boolean) to enable scoring.
(Inherited from Searcher.)
Public method | Search(Weight, Filter, Int32, Sort) | (Overrides Searcher Search(Weight, Filter, Int32, Sort).)
Public method Search(Weight, Filter, Int32, Sort, Boolean)
Just like Search(Weight, Filter, Int32, Sort), but you choose whether or not the fields in the returned FieldDoc instances should be set by specifying fillFields.

NOTE: this does not compute scores by default. If you need scores, create a TopFieldCollector instance by calling Create(Sort, Int32, Boolean, Boolean, Boolean, Boolean) and then pass that to Search(Weight, Filter, Collector).

Public method SetDefaultFieldSortScoring
By default, no scores are computed when sorting by field (using Search(Query, Filter, Int32, Sort)). You can change that, per IndexSearcher instance, by calling this method. Note that this will incur a CPU cost.
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | IndexReader | Return the IndexReader this searches.
Public property | MaxDoc | (Overrides Searcher MaxDoc.)
Public property | reader_ForNUnit |
Public property | Similarity | Expert: Gets or Sets the Similarity implementation used by this Searcher. (Inherited from Searcher.)
Back to Top
See Also
IndexSearcher Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexSearcher Constructor

IndexSearcher Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | IndexSearcher(Directory) | Creates a searcher searching the index in the named directory, with readOnly=true
Public method | IndexSearcher(IndexReader) | Creates a searcher searching the provided index Note that the underlying IndexReader is not closed, if IndexSearcher was constructed with IndexSearcher(IndexReader r). If the IndexReader was supplied implicitly by specifying a directory, then the IndexReader gets closed.
Public method | IndexSearcher(Directory, Boolean) | Creates a searcher searching the index in the named directory. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the underlying IndexReader.
Public method | IndexSearcher(IndexReader, IndexReader , Int32 ) | Expert: directly specify the reader, subReaders and their DocID starts NOTE: This API is experimental and might change in incompatible ways in the next release
Back to Top
See Also
IndexSearcher Class
IndexSearcher Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexSearcher Constructor (Directory)

IndexSearcher Constructor (Directory) Lucene.Net Class Library
Creates a searcher searching the index in the named directory, with readOnly=true

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexSearcher(
    Directory path
)
public IndexSearcher(
    Directory path
)
Public Sub New ( _
    path As Directory _
)
Public Sub New ( _
    path As Directory _
)
public:
IndexSearcher(
    Directory^ path
)
public:
IndexSearcher(
    Directory^ path
)
Parameters
path
Type: Lucene.Net.Store Directory
See Also
IndexSearcher Class
IndexSearcher Members
IndexSearcher Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexSearcher Constructor (IndexReader)

IndexSearcher Constructor (IndexReader) Lucene.Net Class Library
Creates a searcher searching the provided index

Note that the underlying IndexReader is not closed, if IndexSearcher was constructed with IndexSearcher(IndexReader r). If the IndexReader was supplied implicitly by specifying a directory, then the IndexReader gets closed.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexSearcher(
    IndexReader r
)
public IndexSearcher(
    IndexReader r
)
Public Sub New ( _
    r As IndexReader _
)
Public Sub New ( _
    r As IndexReader _
)
public:
IndexSearcher(
    IndexReader^ r
)
public:
IndexSearcher(
    IndexReader^ r
)
Parameters
r
Type: Lucene.Net.Index IndexReader
See Also
IndexSearcher Class
IndexSearcher Members
IndexSearcher Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexSearcher Constructor (Directory, Boolean)

IndexSearcher Constructor (Directory, Boolean) Lucene.Net Class Library
Creates a searcher searching the index in the named directory. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the underlying IndexReader.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexSearcher(
    Directory path,
    bool readOnly
)
public IndexSearcher(
    Directory path,
    bool readOnly
)
Public Sub New ( _
    path As Directory, _
    readOnly As Boolean _
)
Public Sub New ( _
    path As Directory, _
    readOnly As Boolean _
)
public:
IndexSearcher(
    Directory^ path,
    bool readOnly
)
public:
IndexSearcher(
    Directory^ path,
    bool readOnly
)
Parameters
path
Type: Lucene.Net.Store Directory
directory where IndexReader will be opened

readOnly
Type:   Online System Boolean
if true, the underlying IndexReader
            will be opened readOnly

See Also
IndexSearcher Class
IndexSearcher Members
IndexSearcher Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexSearcher Constructor (IndexReader, IndexReader[], Int32[])

IndexSearcher Constructor (IndexReader, IndexReader , Int32 ) Lucene.Net Class Library
Expert: directly specify the reader, subReaders and their DocID starts

NOTE: This API is experimental and might change in incompatible ways in the next release

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexSearcher(
    IndexReader reader,
    IndexReader[] subReaders,
    int[] docStarts
)
public IndexSearcher(
    IndexReader reader,
    IndexReader[] subReaders,
    int[] docStarts
)
Public Sub New ( _
    reader As IndexReader, _
    subReaders As IndexReader(), _
    docStarts As Integer() _
)
Public Sub New ( _
    reader As IndexReader, _
    subReaders As IndexReader(), _
    docStarts As Integer() _
)
public:
IndexSearcher(
    IndexReader^ reader,
    array<IndexReader^>^ subReaders,
    array<int>^ docStarts
)
public:
IndexSearcher(
    IndexReader^ reader,
    array<IndexReader^>^ subReaders,
    array<int>^ docStarts
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
subReaders
Type:  Lucene.Net.Index IndexReader
docStarts
Type:    Online System Int32
See Also
IndexSearcher Class
IndexSearcher Members
IndexSearcher Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexSearcher Methods

IndexSearcher Methods Lucene.Net Class Library
The IndexSearcher type exposes the following members.
Methods
Name | Description
Public method | Close | Obsolete. (Inherited from Searcher.)
Public method Online CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from Online MarshalByRefObject.)
Public method CreateWeight
creates a weight for query
(Inherited from Searcher.)
Public method | Dispose | (Inherited from Searcher.)
Protected method | Dispose(Boolean) | (Overrides Searcher Dispose(Boolean).)
Public method | Doc(Int32) | (Overrides Searcher Doc(Int32).)
Public method | Doc(Int32, FieldSelector) | (Overrides Searcher Doc(Int32, FieldSelector).)
Public method | DocFreq | (Overrides Searcher DocFreq(Term).)
Public method | DocFreqs | (Inherited from Searcher.)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Public method Explain(Query, Int32)
Returns an Explanation that describes how doc scored against query.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.
(Inherited from Searcher.)
Public method | Explain(Weight, Int32) | (Overrides Searcher Explain(Weight, Int32).)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Protected method | GatherSubReaders
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from Online MarshalByRefObject.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method Online InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from Online MarshalByRefObject.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Protected method Online MemberwiseClone(Boolean)
Creates a shallow copy of the current Online MarshalByRefObject object.
(Inherited from Online MarshalByRefObject.)
Public method | Rewrite | (Overrides Searcher Rewrite(Query).)
Public method Search(Query, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32) ) is usually more efficient, as it skips non-high-scoring hits.

Note: The score passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top n hits for query.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Filter, Int32)) is usually more efficient, as it skips non-high-scoring hits.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top n hits for query, applying filter if non-null.
(Inherited from Searcher.)
Public method | Search(Weight, Filter, Collector) | (Overrides Searcher Search(Weight, Filter, Collector).)
Public method | Search(Weight, Filter, Int32) | (Overrides Searcher Search(Weight, Filter, Int32).)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top n hits for query, applying filter if non-null, and sorting the hits by the criteria in sort.

NOTE: this does not compute scores by default; use SetDefaultFieldSortScoring(Boolean, Boolean) to enable scoring.
(Inherited from Searcher.)
Public method | Search(Weight, Filter, Int32, Sort) | (Overrides Searcher Search(Weight, Filter, Int32, Sort).)
Public method Search(Weight, Filter, Int32, Sort, Boolean)
Just like Search(Weight, Filter, Int32, Sort), but you choose whether or not the fields in the returned FieldDoc instances should be set by specifying fillFields.

NOTE: this does not compute scores by default. If you need scores, create a TopFieldCollector instance by calling Create(Sort, Int32, Boolean, Boolean, Boolean, Boolean) and then pass that to Search(Weight, Filter, Collector).

Public method SetDefaultFieldSortScoring
By default, no scores are computed when sorting by field (using Search(Query, Filter, Int32, Sort)). You can change that, per IndexSearcher instance, by calling this method. Note that this will incur a CPU cost.
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
See Also
IndexSearcher Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

IndexSearcher Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | (Inherited from Searcher.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the IndexSearcher and optionally releases the managed resources (Overrides Searcher Dispose(Boolean).)
Back to Top
See Also
IndexSearcher Class
IndexSearcher Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

IndexSearcher Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the IndexSearcher and optionally releases the managed resources

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
IndexSearcher Class
IndexSearcher Members
Dispose Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Method

IndexSearcher Doc Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Doc(Int32) | (Overrides Searcher Doc(Int32).)
Public method | Doc(Int32, FieldSelector) | (Overrides Searcher Doc(Int32, FieldSelector).)
Back to Top
See Also
IndexSearcher Class
IndexSearcher Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Method (Int32)

IndexSearcher Doc Method (Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Document Doc(
    int i
)
public override Document Doc(
    int i
)
Public Overrides Function Doc ( _
    i As Integer _
) As Document
Public Overrides Function Doc ( _
    i As Integer _
) As Document
public:
virtual Document^ Doc(
    int i
) override
public:
virtual Document^ Doc(
    int i
) override
Parameters
i
Type:   Online System Int32
Implements
Searchable Doc(Int32)
See Also
IndexSearcher Class
IndexSearcher Members
Doc Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Method (Int32, FieldSelector)

IndexSearcher Doc Method (Int32, FieldSelector) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Document Doc(
    int i,
    FieldSelector fieldSelector
)
public override Document Doc(
    int i,
    FieldSelector fieldSelector
)
Public Overrides Function Doc ( _
    i As Integer, _
    fieldSelector As FieldSelector _
) As Document
Public Overrides Function Doc ( _
    i As Integer, _
    fieldSelector As FieldSelector _
) As Document
public:
virtual Document^ Doc(
    int i,
    FieldSelector^ fieldSelector
) override
public:
virtual Document^ Doc(
    int i,
    FieldSelector^ fieldSelector
) override
Parameters
i
Type:   Online System Int32
fieldSelector
Type: Lucene.Net.Documents FieldSelector
Implements
Searchable Doc(Int32, FieldSelector)
See Also
IndexSearcher Class
IndexSearcher Members
Doc Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocFreq Method

IndexSearcher DocFreq Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocFreq(
    Term term
)
public override int DocFreq(
    Term term
)
Public Overrides Function DocFreq ( _
    term As Term _
) As Integer
Public Overrides Function DocFreq ( _
    term As Term _
) As Integer
public:
virtual int DocFreq(
    Term^ term
) override
public:
virtual int DocFreq(
    Term^ term
) override
Parameters
term
Type: Lucene.Net.Index Term
Implements
Searchable DocFreq(Term)
See Also
IndexSearcher Class
IndexSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method

IndexSearcher Explain Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Explain(Query, Int32) | Returns an Explanation that describes how doc scored against query. This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index. (Inherited from Searcher.)
Public method | Explain(Weight, Int32) | (Overrides Searcher Explain(Weight, Int32).)
Back to Top
See Also
IndexSearcher Class
IndexSearcher Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method (Weight, Int32)

IndexSearcher Explain Method (Weight, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Explanation Explain(
    Weight weight,
    int doc
)
public override Explanation Explain(
    Weight weight,
    int doc
)
Public Overrides Function Explain ( _
    weight As Weight, _
    doc As Integer _
) As Explanation
Public Overrides Function Explain ( _
    weight As Weight, _
    doc As Integer _
) As Explanation
public:
virtual Explanation^ Explain(
    Weight^ weight,
    int doc
) override
public:
virtual Explanation^ Explain(
    Weight^ weight,
    int doc
) override
Parameters
weight
Type: Lucene.Net.Search Weight
doc
Type:   Online System Int32
Implements
Searchable Explain(Weight, Int32)
See Also
IndexSearcher Class
IndexSearcher Members
Explain Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GatherSubReaders Method

IndexSearcher GatherSubReaders Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void GatherSubReaders(
    IList<IndexReader> allSubReaders,
    IndexReader r
)
protected virtual void GatherSubReaders(
    IList<IndexReader> allSubReaders,
    IndexReader r
)
Protected Overridable Sub GatherSubReaders ( _
    allSubReaders As IList(Of IndexReader), _
    r As IndexReader _
)
Protected Overridable Sub GatherSubReaders ( _
    allSubReaders As IList(Of IndexReader), _
    r As IndexReader _
)
protected:
virtual void GatherSubReaders(
    IList<IndexReader^>^ allSubReaders,
    IndexReader^ r
)
protected:
virtual void GatherSubReaders(
    IList<IndexReader^>^ allSubReaders,
    IndexReader^ r
)
Parameters
allSubReaders
Type:   Online System.Collections.Generic IList  IndexReader
r
Type: Lucene.Net.Index IndexReader
See Also
IndexSearcher Class
IndexSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

IndexSearcher Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    Query original
)
public override Query Rewrite(
    Query original
)
Public Overrides Function Rewrite ( _
    original As Query _
) As Query
Public Overrides Function Rewrite ( _
    original As Query _
) As Query
public:
virtual Query^ Rewrite(
    Query^ original
) override
public:
virtual Query^ Rewrite(
    Query^ original
) override
Parameters
original
Type: Lucene.Net.Search Query
Implements
Searchable Rewrite(Query)
See Also
IndexSearcher Class
IndexSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method

IndexSearcher Search Method Lucene.Net Class Library
Overload List
Name | Description
Public method Search(Query, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32) ) is usually more efficient, as it skips non-high-scoring hits.

Note: The score passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top n hits for query.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Filter, Int32)) is usually more efficient, as it skips non-high-scoring hits.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top n hits for query, applying filter if non-null.
(Inherited from Searcher.)
Public method | Search(Weight, Filter, Collector) | (Overrides Searcher Search(Weight, Filter, Collector).)
Public method | Search(Weight, Filter, Int32) | (Overrides Searcher Search(Weight, Filter, Int32).)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top n hits for query, applying filter if non-null, and sorting the hits by the criteria in sort.

NOTE: this does not compute scores by default; use SetDefaultFieldSortScoring(Boolean, Boolean) to enable scoring.
(Inherited from Searcher.)
Public method | Search(Weight, Filter, Int32, Sort) | (Overrides Searcher Search(Weight, Filter, Int32, Sort).)
Public method Search(Weight, Filter, Int32, Sort, Boolean)
Just like Search(Weight, Filter, Int32, Sort), but you choose whether or not the fields in the returned FieldDoc instances should be set by specifying fillFields.

NOTE: this does not compute scores by default. If you need scores, create a TopFieldCollector instance by calling Create(Sort, Int32, Boolean, Boolean, Boolean, Boolean) and then pass that to Search(Weight, Filter, Collector).

Back to Top
See Also
IndexSearcher Class
IndexSearcher Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Weight, Filter, Collector)

IndexSearcher Search Method (Weight, Filter, Collector) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Search(
    Weight weight,
    Filter filter,
    Collector collector
)
public override void Search(
    Weight weight,
    Filter filter,
    Collector collector
)
Public Overrides Sub Search ( _
    weight As Weight, _
    filter As Filter, _
    collector As Collector _
)
Public Overrides Sub Search ( _
    weight As Weight, _
    filter As Filter, _
    collector As Collector _
)
public:
virtual void Search(
    Weight^ weight,
    Filter^ filter,
    Collector^ collector
) override
public:
virtual void Search(
    Weight^ weight,
    Filter^ filter,
    Collector^ collector
) override
Parameters
weight
Type: Lucene.Net.Search Weight
filter
Type: Lucene.Net.Search Filter
collector
Type: Lucene.Net.Search Collector
Implements
Searchable Search(Weight, Filter, Collector)
See Also
IndexSearcher Class
IndexSearcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Weight, Filter, Int32)

IndexSearcher Search Method (Weight, Filter, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TopDocs Search(
    Weight weight,
    Filter filter,
    int nDocs
)
public override TopDocs Search(
    Weight weight,
    Filter filter,
    int nDocs
)
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer _
) As TopDocs
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer _
) As TopDocs
public:
virtual TopDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs
) override
public:
virtual TopDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs
) override
Parameters
weight
Type: Lucene.Net.Search Weight
filter
Type: Lucene.Net.Search Filter
nDocs
Type:   Online System Int32
Implements
Searchable Search(Weight, Filter, Int32)
See Also
IndexSearcher Class
IndexSearcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Weight, Filter, Int32, Sort)

IndexSearcher Search Method (Weight, Filter, Int32, Sort) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int nDocs,
    Sort sort
)
public override TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int nDocs,
    Sort sort
)
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer, _
    sort As Sort _
) As TopFieldDocs
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer, _
    sort As Sort _
) As TopFieldDocs
public:
virtual TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs,
    Sort^ sort
) override
public:
virtual TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs,
    Sort^ sort
) override
Parameters
weight
Type: Lucene.Net.Search Weight
filter
Type: Lucene.Net.Search Filter
nDocs
Type:   Online System Int32
sort
Type: Lucene.Net.Search Sort
Implements
Searchable Search(Weight, Filter, Int32, Sort)
See Also
IndexSearcher Class
IndexSearcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Weight, Filter, Int32, Sort, Boolean)

IndexSearcher Search Method (Weight, Filter, Int32, Sort, Boolean) Lucene.Net Class Library
Just like Search(Weight, Filter, Int32, Sort), but you choose whether or not the fields in the returned FieldDoc instances should be set by specifying fillFields.

NOTE: this does not compute scores by default. If you need scores, create a TopFieldCollector instance by calling Create(Sort, Int32, Boolean, Boolean, Boolean, Boolean) and then pass that to Search(Weight, Filter, Collector).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int nDocs,
    Sort sort,
    bool fillFields
)
public virtual TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int nDocs,
    Sort sort,
    bool fillFields
)
Public Overridable Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer, _
    sort As Sort, _
    fillFields As Boolean _
) As TopFieldDocs
Public Overridable Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer, _
    sort As Sort, _
    fillFields As Boolean _
) As TopFieldDocs
public:
virtual TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs,
    Sort^ sort,
    bool fillFields
)
public:
virtual TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs,
    Sort^ sort,
    bool fillFields
)
Parameters
weight
Type: Lucene.Net.Search Weight
filter
Type: Lucene.Net.Search Filter
nDocs
Type:   Online System Int32
sort
Type: Lucene.Net.Search Sort
fillFields
Type:   Online System Boolean
See Also
IndexSearcher Class
IndexSearcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetDefaultFieldSortScoring Method

IndexSearcher SetDefaultFieldSortScoring Method Lucene.Net Class Library
By default, no scores are computed when sorting by field (using Search(Query, Filter, Int32, Sort)). You can change that, per IndexSearcher instance, by calling this method. Note that this will incur a CPU cost.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetDefaultFieldSortScoring(
    bool doTrackScores,
    bool doMaxScore
)
public virtual void SetDefaultFieldSortScoring(
    bool doTrackScores,
    bool doMaxScore
)
Public Overridable Sub SetDefaultFieldSortScoring ( _
    doTrackScores As Boolean, _
    doMaxScore As Boolean _
)
Public Overridable Sub SetDefaultFieldSortScoring ( _
    doTrackScores As Boolean, _
    doMaxScore As Boolean _
)
public:
virtual void SetDefaultFieldSortScoring(
    bool doTrackScores,
    bool doMaxScore
)
public:
virtual void SetDefaultFieldSortScoring(
    bool doTrackScores,
    bool doMaxScore
)
Parameters
doTrackScores
Type:   Online System Boolean
If true, then scores are returned for every matching document
            in TopFieldDocs.

doMaxScore
Type:   Online System Boolean
If true, then the max score for all matching docs is computed.

See Also
IndexSearcher Class
IndexSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexSearcher Properties

IndexSearcher Properties Lucene.Net Class Library
The IndexSearcher type exposes the following members.
Properties
 | Name | Description
Public property | IndexReader | Return the IndexReader this searches.
Public property | MaxDoc | (Overrides Searcher MaxDoc.)
Public property | reader_ForNUnit |
Public property | Similarity | Expert: Gets or Sets the Similarity implementation used by this Searcher. (Inherited from Searcher.)
Back to Top
See Also
IndexSearcher Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexReader Property

IndexSearcher IndexReader Property Lucene.Net Class Library
Return the IndexReader this searches.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IndexReader IndexReader { get; }
public virtual IndexReader IndexReader { get; }
Public Overridable ReadOnly Property IndexReader As IndexReader
    Get
Public Overridable ReadOnly Property IndexReader As IndexReader
    Get
public:
virtual property IndexReader^ IndexReader {
    IndexReader^ get ();
}
public:
virtual property IndexReader^ IndexReader {
    IndexReader^ get ();
}
See Also
IndexSearcher Class
IndexSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxDoc Property

IndexSearcher MaxDoc Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int MaxDoc { get; }
public override int MaxDoc { get; }
Public Overrides ReadOnly Property MaxDoc As Integer
    Get
Public Overrides ReadOnly Property MaxDoc As Integer
    Get
public:
virtual property int MaxDoc {
    int get () override;
}
public:
virtual property int MaxDoc {
    int get () override;
}
Implements
Searchable MaxDoc
See Also
IndexSearcher Class
IndexSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


reader_ForNUnit Property

IndexSearcher reader_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexReader reader_ForNUnit { get; }
public IndexReader reader_ForNUnit { get; }
Public ReadOnly Property reader_ForNUnit As IndexReader
    Get
Public ReadOnly Property reader_ForNUnit As IndexReader
    Get
public:
property IndexReader^ reader_ForNUnit {
    IndexReader^ get ();
}
public:
property IndexReader^ reader_ForNUnit {
    IndexReader^ get ();
}
See Also
IndexSearcher Class
IndexSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IntParser Interface

IntParser Interface Lucene.Net Class Library
Interface to parse ints from document fields.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IntParser : Parser
public interface IntParser : Parser
Public Interface IntParser _
    Inherits Parser
Public Interface IntParser _
    Inherits Parser
public interface class IntParser : Parser
public interface class IntParser : Parser
See Also
IntParser Members
Lucene.Net.Search Namespace
FieldCache GetInts(IndexReader, String, IntParser)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IntParser Members

IntParser Members Lucene.Net Class Library

The IntParser type exposes the following members.
Methods
 | Name | Description
Public method | ParseInt | Return an integer representation of this field's value.
Back to Top
See Also
IntParser Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IntParser Methods

IntParser Methods Lucene.Net Class Library
The IntParser type exposes the following members.
Methods
 | Name | Description
Public method | ParseInt | Return an integer representation of this field's value.
Back to Top
See Also
IntParser Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseInt Method

IntParser ParseInt Method Lucene.Net Class Library
Return an integer representation of this field's value.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ParseInt(
    string string_Renamed
)
int ParseInt(
    string string_Renamed
)
Function ParseInt ( _
    string_Renamed As String _
) As Integer
Function ParseInt ( _
    string_Renamed As String _
) As Integer
int ParseInt(
    String^ string_Renamed
)
int ParseInt(
    String^ string_Renamed
)
Parameters
string_Renamed
Type:   Online System String
See Also
IntParser Interface
IntParser Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LongParser Interface

LongParser Interface Lucene.Net Class Library
Interface to parse long from document fields.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface LongParser : Parser
public interface LongParser : Parser
Public Interface LongParser _
    Inherits Parser
Public Interface LongParser _
    Inherits Parser
public interface class LongParser : Parser
public interface class LongParser : Parser
See Also
LongParser Members
Lucene.Net.Search Namespace
FieldCache GetLongs(IndexReader, String, LongParser)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LongParser Members

LongParser Members Lucene.Net Class Library

The LongParser type exposes the following members.
Methods
 | Name | Description
Public method | ParseLong | Return an long representation of this field's value.
Back to Top
See Also
LongParser Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LongParser Methods

LongParser Methods Lucene.Net Class Library
The LongParser type exposes the following members.
Methods
 | Name | Description
Public method | ParseLong | Return an long representation of this field's value.
Back to Top
See Also
LongParser Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseLong Method

LongParser ParseLong Method Lucene.Net Class Library
Return an long representation of this field's value.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long ParseLong(
    string string_Renamed
)
long ParseLong(
    string string_Renamed
)
Function ParseLong ( _
    string_Renamed As String _
) As Long
Function ParseLong ( _
    string_Renamed As String _
) As Long
long long ParseLong(
    String^ string_Renamed
)
long long ParseLong(
    String^ string_Renamed
)
Parameters
string_Renamed
Type:   Online System String
See Also
LongParser Interface
LongParser Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MatchAllDocsQuery Class

MatchAllDocsQuery Class Lucene.Net Class Library
A query that matches all documents.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search MatchAllDocsQuery

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MatchAllDocsQuery : Query
[SerializableAttribute]
public class MatchAllDocsQuery : Query
<SerializableAttribute> _
Public Class MatchAllDocsQuery _
    Inherits Query
<SerializableAttribute> _
Public Class MatchAllDocsQuery _
    Inherits Query
[SerializableAttribute]
public ref class MatchAllDocsQuery : public Query
[SerializableAttribute]
public ref class MatchAllDocsQuery : public Query
See Also
MatchAllDocsQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MatchAllDocsQuery Members

MatchAllDocsQuery Members Lucene.Net Class Library

The MatchAllDocsQuery type exposes the following members.
Constructors
 | Name | Description
Public method | MatchAllDocsQuery | Initializes a new instance of the MatchAllDocsQuery class
Public method | MatchAllDocsQuery(String) | Initializes a new instance of the MatchAllDocsQuery class
Back to Top
Methods
 | Name | Description
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys. (Inherited from Query.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Back to Top
See Also
MatchAllDocsQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MatchAllDocsQuery Constructor

MatchAllDocsQuery Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | MatchAllDocsQuery | Initializes a new instance of the MatchAllDocsQuery class
Public method | MatchAllDocsQuery(String) | Initializes a new instance of the MatchAllDocsQuery class
Back to Top
See Also
MatchAllDocsQuery Class
MatchAllDocsQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MatchAllDocsQuery Constructor

MatchAllDocsQuery Constructor Lucene.Net Class Library
Initializes a new instance of the MatchAllDocsQuery class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MatchAllDocsQuery()
public MatchAllDocsQuery()
Public Sub New
Public Sub New
public:
MatchAllDocsQuery()
public:
MatchAllDocsQuery()
See Also
MatchAllDocsQuery Class
MatchAllDocsQuery Members
MatchAllDocsQuery Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MatchAllDocsQuery Constructor (String)

MatchAllDocsQuery Constructor (String) Lucene.Net Class Library
Initializes a new instance of the MatchAllDocsQuery class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MatchAllDocsQuery(
    string normsField
)
public MatchAllDocsQuery(
    string normsField
)
Public Sub New ( _
    normsField As String _
)
Public Sub New ( _
    normsField As String _
)
public:
MatchAllDocsQuery(
    String^ normsField
)
public:
MatchAllDocsQuery(
    String^ normsField
)
Parameters
normsField
Type:   Online System String
Field used for normalization factor (document boost). Null if nothing.

See Also
MatchAllDocsQuery Class
MatchAllDocsQuery Members
MatchAllDocsQuery Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MatchAllDocsQuery Methods

MatchAllDocsQuery Methods Lucene.Net Class Library
The MatchAllDocsQuery type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys. (Inherited from Query.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
MatchAllDocsQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateWeight Method

MatchAllDocsQuery CreateWeight Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Weight CreateWeight(
    Searcher searcher
)
public override Weight CreateWeight(
    Searcher searcher
)
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
MatchAllDocsQuery Class
MatchAllDocsQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

MatchAllDocsQuery Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
MatchAllDocsQuery Class
MatchAllDocsQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExtractTerms Method

MatchAllDocsQuery ExtractTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ExtractTerms(
    ISet<Term> terms
)
public override void ExtractTerms(
    ISet<Term> terms
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
Parameters
terms
Type:   Online System.Collections.Generic ISet  Term
See Also
MatchAllDocsQuery Class
MatchAllDocsQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

MatchAllDocsQuery GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
MatchAllDocsQuery Class
MatchAllDocsQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

MatchAllDocsQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Back to Top
See Also
MatchAllDocsQuery Class
MatchAllDocsQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

MatchAllDocsQuery ToString Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
MatchAllDocsQuery Class
MatchAllDocsQuery Members
ToString Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MatchAllDocsQuery Properties

MatchAllDocsQuery Properties Lucene.Net Class Library
The MatchAllDocsQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Back to Top
See Also
MatchAllDocsQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiPhraseQuery Class

MultiPhraseQuery Class Lucene.Net Class Library
MultiPhraseQuery is a generalized version of PhraseQuery, with an added method Add( Term ). To use this class, to search for the phrase "Microsoft app*" first use add(Term) on the term "Microsoft", then find all terms that have "app" as prefix using IndexReader.terms(Term), and use MultiPhraseQuery.add(Term[] terms) to add them to the query.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search MultiPhraseQuery

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MultiPhraseQuery : Query
[SerializableAttribute]
public class MultiPhraseQuery : Query
<SerializableAttribute> _
Public Class MultiPhraseQuery _
    Inherits Query
<SerializableAttribute> _
Public Class MultiPhraseQuery _
    Inherits Query
[SerializableAttribute]
public ref class MultiPhraseQuery : public Query
[SerializableAttribute]
public ref class MultiPhraseQuery : public Query
See Also
MultiPhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiPhraseQuery Members

MultiPhraseQuery Members Lucene.Net Class Library

The MultiPhraseQuery type exposes the following members.
Constructors
 | Name | Description
Public method | MultiPhraseQuery | Initializes a new instance of the MultiPhraseQuery class
Back to Top
Methods
 | Name | Description
Public method | Add(Term) | Add a single term at the next position in the phrase.
Public method | Add( Term ) | Add multiple terms at the next position in the phrase. Any of the terms may match.
Public method | Add( Term , Int32) | Allows to specify the relative position of terms within the phrase.
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | Returns true if o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Query GetHashCode .)
Public method | GetPositions | Returns the relative positions of terms in this phrase.
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetTermArrays | Returns a List<Term[]> of the terms in the multiphrase. Do not modify the List or its contents.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
 | TermEquals |
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Slop | Gets or sets the phrase slop for this query.
Back to Top
See Also
MultiPhraseQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiPhraseQuery Constructor

MultiPhraseQuery Constructor Lucene.Net Class Library
Initializes a new instance of the MultiPhraseQuery class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MultiPhraseQuery()
public MultiPhraseQuery()
Public Sub New
Public Sub New
public:
MultiPhraseQuery()
public:
MultiPhraseQuery()
See Also
MultiPhraseQuery Class
MultiPhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiPhraseQuery Methods

MultiPhraseQuery Methods Lucene.Net Class Library
The MultiPhraseQuery type exposes the following members.
Methods
 | Name | Description
Public method | Add(Term) | Add a single term at the next position in the phrase.
Public method | Add( Term ) | Add multiple terms at the next position in the phrase. Any of the terms may match.
Public method | Add( Term , Int32) | Allows to specify the relative position of terms within the phrase.
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | Returns true if o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Query GetHashCode .)
Public method | GetPositions | Returns the relative positions of terms in this phrase.
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetTermArrays | Returns a List<Term[]> of the terms in the multiphrase. Do not modify the List or its contents.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
 | TermEquals |
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
MultiPhraseQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method

MultiPhraseQuery Add Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Add(Term) | Add a single term at the next position in the phrase.
Public method | Add( Term ) | Add multiple terms at the next position in the phrase. Any of the terms may match.
Public method | Add( Term , Int32) | Allows to specify the relative position of terms within the phrase.
Back to Top
See Also
MultiPhraseQuery Class
MultiPhraseQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (Term)

MultiPhraseQuery Add Method (Term) Lucene.Net Class Library
Add a single term at the next position in the phrase.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Add(
    Term term
)
public virtual void Add(
    Term term
)
Public Overridable Sub Add ( _
    term As Term _
)
Public Overridable Sub Add ( _
    term As Term _
)
public:
virtual void Add(
    Term^ term
)
public:
virtual void Add(
    Term^ term
)
Parameters
term
Type: Lucene.Net.Index Term
See Also
MultiPhraseQuery Class
MultiPhraseQuery Members
Add Overload
Lucene.Net.Search Namespace
PhraseQuery Add(Term)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (Term[])

MultiPhraseQuery Add Method ( Term ) Lucene.Net Class Library
Add multiple terms at the next position in the phrase. Any of the terms may match.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Add(
    Term[] terms
)
public virtual void Add(
    Term[] terms
)
Public Overridable Sub Add ( _
    terms As Term() _
)
Public Overridable Sub Add ( _
    terms As Term() _
)
public:
virtual void Add(
    array<Term^>^ terms
)
public:
virtual void Add(
    array<Term^>^ terms
)
Parameters
terms
Type:  Lucene.Net.Index Term
See Also
MultiPhraseQuery Class
MultiPhraseQuery Members
Add Overload
Lucene.Net.Search Namespace
PhraseQuery Add(Term)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (Term[], Int32)

MultiPhraseQuery Add Method ( Term , Int32) Lucene.Net Class Library
Allows to specify the relative position of terms within the phrase.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Add(
    Term[] terms,
    int position
)
public virtual void Add(
    Term[] terms,
    int position
)
Public Overridable Sub Add ( _
    terms As Term(), _
    position As Integer _
)
Public Overridable Sub Add ( _
    terms As Term(), _
    position As Integer _
)
public:
virtual void Add(
    array<Term^>^ terms,
    int position
)
public:
virtual void Add(
    array<Term^>^ terms,
    int position
)
Parameters
terms
Type:  Lucene.Net.Index Term
position
Type:   Online System Int32
See Also
MultiPhraseQuery Class
MultiPhraseQuery Members
Add Overload
Lucene.Net.Search Namespace
PhraseQuery Add(Term, Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateWeight Method

MultiPhraseQuery CreateWeight Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Weight CreateWeight(
    Searcher searcher
)
public override Weight CreateWeight(
    Searcher searcher
)
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
MultiPhraseQuery Class
MultiPhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

MultiPhraseQuery Equals Method Lucene.Net Class Library
Returns true if o is equal to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
MultiPhraseQuery Class
MultiPhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExtractTerms Method

MultiPhraseQuery ExtractTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ExtractTerms(
    ISet<Term> terms
)
public override void ExtractTerms(
    ISet<Term> terms
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
Parameters
terms
Type:   Online System.Collections.Generic ISet  Term
See Also
MultiPhraseQuery Class
MultiPhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

MultiPhraseQuery GetHashCode Method Lucene.Net Class Library
Returns a hash code value for this object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
MultiPhraseQuery Class
MultiPhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPositions Method

MultiPhraseQuery GetPositions Method Lucene.Net Class Library
Returns the relative positions of terms in this phrase.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int[] GetPositions()
public virtual int[] GetPositions()
Public Overridable Function GetPositions As Integer()
Public Overridable Function GetPositions As Integer()
public:
virtual array<int>^ GetPositions()
public:
virtual array<int>^ GetPositions()
See Also
MultiPhraseQuery Class
MultiPhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermArrays Method

MultiPhraseQuery GetTermArrays Method Lucene.Net Class Library
Returns a List<Term[]> of the terms in the multiphrase. Do not modify the List or its contents.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IList<Term[]> GetTermArrays()
public virtual IList<Term[]> GetTermArrays()
Public Overridable Function GetTermArrays As IList(Of Term())
Public Overridable Function GetTermArrays As IList(Of Term())
public:
virtual IList<array<Term^>^>^ GetTermArrays()
public:
virtual IList<array<Term^>^>^ GetTermArrays()
See Also
MultiPhraseQuery Class
MultiPhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

MultiPhraseQuery Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    IndexReader reader
)
public override Query Rewrite(
    IndexReader reader
)
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
MultiPhraseQuery Class
MultiPhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermEquals Method

MultiPhraseQuery TermEquals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TermEquals(
    Array array1,
    Array array2
)
public static bool TermEquals(
    Array array1,
    Array array2
)
Public Shared Function TermEquals ( _
    array1 As Array, _
    array2 As Array _
) As Boolean
Public Shared Function TermEquals ( _
    array1 As Array, _
    array2 As Array _
) As Boolean
public:
static bool TermEquals(
    Array^ array1,
    Array^ array2
)
public:
static bool TermEquals(
    Array^ array1,
    Array^ array2
)
Parameters
array1
Type:   Online System Array
array2
Type:   Online System Array
See Also
MultiPhraseQuery Class
MultiPhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

MultiPhraseQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Back to Top
See Also
MultiPhraseQuery Class
MultiPhraseQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

MultiPhraseQuery ToString Method (String) Lucene.Net Class Library
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string f
)
public override string ToString(
    string f
)
Public Overrides Function ToString ( _
    f As String _
) As String
Public Overrides Function ToString ( _
    f As String _
) As String
public:
virtual String^ ToString(
    String^ f
) override
public:
virtual String^ ToString(
    String^ f
) override
Parameters
f
Type:   Online System String
See Also
MultiPhraseQuery Class
MultiPhraseQuery Members
ToString Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiPhraseQuery Properties

MultiPhraseQuery Properties Lucene.Net Class Library
The MultiPhraseQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Slop | Gets or sets the phrase slop for this query.
Back to Top
See Also
MultiPhraseQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Slop Property

MultiPhraseQuery Slop Property Lucene.Net Class Library
Gets or sets the phrase slop for this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Slop { get; set; }
public virtual int Slop { get; set; }
Public Overridable Property Slop As Integer
    Get
    Set
Public Overridable Property Slop As Integer
    Get
    Set
public:
virtual property int Slop {
    int get ();
    void set (int value);
}
public:
virtual property int Slop {
    int get ();
    void set (int value);
}
See Also
MultiPhraseQuery Class
MultiPhraseQuery Members
Lucene.Net.Search Namespace
PhraseQuery Slop
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiSearcher Class

MultiSearcher Class Lucene.Net Class Library
Implements search over a set of Searchables.

Applications usually need only call the inherited Search(Query, Int32) or Search(Query, Filter, Int32) methods.
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Lucene.Net.Search Searcher
Lucene.Net.Search MultiSearcher
Lucene.Net.Search ParallelMultiSearcher

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MultiSearcher : Searcher
public class MultiSearcher : Searcher
Public Class MultiSearcher _
    Inherits Searcher
Public Class MultiSearcher _
    Inherits Searcher
public ref class MultiSearcher : public Searcher
public ref class MultiSearcher : public Searcher
See Also
MultiSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiSearcher Members

MultiSearcher Members Lucene.Net Class Library

The MultiSearcher type exposes the following members.
Constructors
 | Name | Description
Public method | MultiSearcher | Creates a searcher which searches searchers.
Back to Top
Methods
Name | Description
Public method | Close | Obsolete. (Inherited from Searcher.)
Public method Online CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from Online MarshalByRefObject.)
Public method CreateWeight
Create weight in multiple index scenario. Distributed query processing is done in the following steps: 1. rewrite query 2. extract necessary terms 3. collect dfs for these terms from the Searchables 4. create query weight using aggregate dfs. 5. distribute that weight to Searchables 6. merge results Steps 1-4 are done here, 5+6 in the search() methods
(Overrides Searcher CreateWeight(Query).)
Public method | Dispose | (Inherited from Searcher.)
Protected method Dispose(Boolean)
Releases the unmanaged resources used by the MultiSearcher and optionally releases the managed resources
(Overrides Searcher Dispose(Boolean).)
Public method | Doc(Int32) | (Overrides Searcher Doc(Int32).)
Public method | Doc(Int32, FieldSelector) | (Overrides Searcher Doc(Int32, FieldSelector).)
Public method | DocFreq | (Overrides Searcher DocFreq(Term).)
Public method | DocFreqs | (Inherited from Searcher.)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Public method Explain(Query, Int32)
Returns an Explanation that describes how doc scored against query.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.
(Inherited from Searcher.)
Public method | Explain(Weight, Int32) | (Overrides Searcher Explain(Weight, Int32).)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from Online MarshalByRefObject.)
Public method GetSearchables
Return the array of Searchables this searches.
Protected method | GetStarts
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method Online InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from Online MarshalByRefObject.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Protected method Online MemberwiseClone(Boolean)
Creates a shallow copy of the current Online MarshalByRefObject object.
(Inherited from Online MarshalByRefObject.)
Public method | Rewrite | (Overrides Searcher Rewrite(Query).)
Public method Search(Query, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32) ) is usually more efficient, as it skips non-high-scoring hits.

Note: The score passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top n hits for query.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Filter, Int32)) is usually more efficient, as it skips non-high-scoring hits.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top n hits for query, applying filter if non-null.
(Inherited from Searcher.)
Public method Search(Weight, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32)) is usually more efficient, as it skips non-high-scoring hits.
(Overrides Searcher Search(Weight, Filter, Collector).)
Public method | Search(Weight, Filter, Int32) | (Overrides Searcher Search(Weight, Filter, Int32).)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top n hits for query, applying filter if non-null, and sorting the hits by the criteria in sort.

NOTE: this does not compute scores by default; use SetDefaultFieldSortScoring(Boolean, Boolean) to enable scoring.
(Inherited from Searcher.)
Public method | Search(Weight, Filter, Int32, Sort) | (Overrides Searcher Search(Weight, Filter, Int32, Sort).)
Public method SubDoc
Returns the document number of document n within its sub-index.
Public method SubSearcher
Returns index of the searcher for document n in the array used to construct this searcher.
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | MaxDoc | (Overrides Searcher MaxDoc.)
Public property | Similarity | Expert: Gets or Sets the Similarity implementation used by this Searcher. (Inherited from Searcher.)
Back to Top
See Also
MultiSearcher Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiSearcher Constructor

MultiSearcher Constructor Lucene.Net Class Library
Creates a searcher which searches searchers.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MultiSearcher(
    params Searchable[] searchables
)
public MultiSearcher(
    params Searchable[] searchables
)
Public Sub New ( _
    ParamArray searchables As Searchable() _
)
Public Sub New ( _
    ParamArray searchables As Searchable() _
)
public:
MultiSearcher(
    ... array<Searchable^>^ searchables
)
public:
MultiSearcher(
    ... array<Searchable^>^ searchables
)
Parameters
searchables
Type:  Lucene.Net.Search Searchable
See Also
MultiSearcher Class
MultiSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiSearcher Methods

MultiSearcher Methods Lucene.Net Class Library
The MultiSearcher type exposes the following members.
Methods
Name | Description
Public method | Close | Obsolete. (Inherited from Searcher.)
Public method Online CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from Online MarshalByRefObject.)
Public method CreateWeight
Create weight in multiple index scenario. Distributed query processing is done in the following steps: 1. rewrite query 2. extract necessary terms 3. collect dfs for these terms from the Searchables 4. create query weight using aggregate dfs. 5. distribute that weight to Searchables 6. merge results Steps 1-4 are done here, 5+6 in the search() methods
(Overrides Searcher CreateWeight(Query).)
Public method | Dispose | (Inherited from Searcher.)
Protected method | Dispose(Boolean) | (Overrides Searcher Dispose(Boolean).)
Public method | Doc(Int32) | (Overrides Searcher Doc(Int32).)
Public method | Doc(Int32, FieldSelector) | (Overrides Searcher Doc(Int32, FieldSelector).)
Public method | DocFreq | (Overrides Searcher DocFreq(Term).)
Public method | DocFreqs | (Inherited from Searcher.)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Public method Explain(Query, Int32)
Returns an Explanation that describes how doc scored against query.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.
(Inherited from Searcher.)
Public method | Explain(Weight, Int32) | (Overrides Searcher Explain(Weight, Int32).)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from Online MarshalByRefObject.)
Public method GetSearchables
Return the array of Searchables this searches.
Protected method | GetStarts
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method Online InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from Online MarshalByRefObject.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Protected method Online MemberwiseClone(Boolean)
Creates a shallow copy of the current Online MarshalByRefObject object.
(Inherited from Online MarshalByRefObject.)
Public method | Rewrite | (Overrides Searcher Rewrite(Query).)
Public method Search(Query, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32) ) is usually more efficient, as it skips non-high-scoring hits.

Note: The score passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top n hits for query.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Filter, Int32)) is usually more efficient, as it skips non-high-scoring hits.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top n hits for query, applying filter if non-null.
(Inherited from Searcher.)
Public method Search(Weight, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32)) is usually more efficient, as it skips non-high-scoring hits.
(Overrides Searcher Search(Weight, Filter, Collector).)
Public method | Search(Weight, Filter, Int32) | (Overrides Searcher Search(Weight, Filter, Int32).)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top n hits for query, applying filter if non-null, and sorting the hits by the criteria in sort.

NOTE: this does not compute scores by default; use SetDefaultFieldSortScoring(Boolean, Boolean) to enable scoring.
(Inherited from Searcher.)
Public method | Search(Weight, Filter, Int32, Sort) | (Overrides Searcher Search(Weight, Filter, Int32, Sort).)
Public method SubDoc
Returns the document number of document n within its sub-index.
Public method SubSearcher
Returns index of the searcher for document n in the array used to construct this searcher.
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
See Also
MultiSearcher Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateWeight Method

MultiSearcher CreateWeight Method Lucene.Net Class Library
Create weight in multiple index scenario. Distributed query processing is done in the following steps: 1. rewrite query 2. extract necessary terms 3. collect dfs for these terms from the Searchables 4. create query weight using aggregate dfs. 5. distribute that weight to Searchables 6. merge results Steps 1-4 are done here, 5+6 in the search() methods

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Weight CreateWeight(
    Query original
)
public override Weight CreateWeight(
    Query original
)
Public Overrides Function CreateWeight ( _
    original As Query _
) As Weight
Public Overrides Function CreateWeight ( _
    original As Query _
) As Weight
public:
virtual Weight^ CreateWeight(
    Query^ original
) override
public:
virtual Weight^ CreateWeight(
    Query^ original
) override
Parameters
original
Type: Lucene.Net.Search Query
Return Value
 rewritten queries

See Also
MultiSearcher Class
MultiSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

MultiSearcher Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | (Inherited from Searcher.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the MultiSearcher and optionally releases the managed resources (Overrides Searcher Dispose(Boolean).)
Back to Top
See Also
MultiSearcher Class
MultiSearcher Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

MultiSearcher Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the MultiSearcher and optionally releases the managed resources

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
MultiSearcher Class
MultiSearcher Members
Dispose Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Method

MultiSearcher Doc Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Doc(Int32) | (Overrides Searcher Doc(Int32).)
Public method | Doc(Int32, FieldSelector) | (Overrides Searcher Doc(Int32, FieldSelector).)
Back to Top
See Also
MultiSearcher Class
MultiSearcher Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Method (Int32)

MultiSearcher Doc Method (Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Document Doc(
    int n
)
public override Document Doc(
    int n
)
Public Overrides Function Doc ( _
    n As Integer _
) As Document
Public Overrides Function Doc ( _
    n As Integer _
) As Document
public:
virtual Document^ Doc(
    int n
) override
public:
virtual Document^ Doc(
    int n
) override
Parameters
n
Type:   Online System Int32
Implements
Searchable Doc(Int32)
See Also
MultiSearcher Class
MultiSearcher Members
Doc Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Method (Int32, FieldSelector)

MultiSearcher Doc Method (Int32, FieldSelector) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Document Doc(
    int n,
    FieldSelector fieldSelector
)
public override Document Doc(
    int n,
    FieldSelector fieldSelector
)
Public Overrides Function Doc ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Public Overrides Function Doc ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
public:
virtual Document^ Doc(
    int n,
    FieldSelector^ fieldSelector
) override
public:
virtual Document^ Doc(
    int n,
    FieldSelector^ fieldSelector
) override
Parameters
n
Type:   Online System Int32
fieldSelector
Type: Lucene.Net.Documents FieldSelector
Implements
Searchable Doc(Int32, FieldSelector)
See Also
MultiSearcher Class
MultiSearcher Members
Doc Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocFreq Method

MultiSearcher DocFreq Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocFreq(
    Term term
)
public override int DocFreq(
    Term term
)
Public Overrides Function DocFreq ( _
    term As Term _
) As Integer
Public Overrides Function DocFreq ( _
    term As Term _
) As Integer
public:
virtual int DocFreq(
    Term^ term
) override
public:
virtual int DocFreq(
    Term^ term
) override
Parameters
term
Type: Lucene.Net.Index Term
Implements
Searchable DocFreq(Term)
See Also
MultiSearcher Class
MultiSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method

MultiSearcher Explain Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Explain(Query, Int32) | Returns an Explanation that describes how doc scored against query. This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index. (Inherited from Searcher.)
Public method | Explain(Weight, Int32) | (Overrides Searcher Explain(Weight, Int32).)
Back to Top
See Also
MultiSearcher Class
MultiSearcher Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method (Weight, Int32)

MultiSearcher Explain Method (Weight, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Explanation Explain(
    Weight weight,
    int doc
)
public override Explanation Explain(
    Weight weight,
    int doc
)
Public Overrides Function Explain ( _
    weight As Weight, _
    doc As Integer _
) As Explanation
Public Overrides Function Explain ( _
    weight As Weight, _
    doc As Integer _
) As Explanation
public:
virtual Explanation^ Explain(
    Weight^ weight,
    int doc
) override
public:
virtual Explanation^ Explain(
    Weight^ weight,
    int doc
) override
Parameters
weight
Type: Lucene.Net.Search Weight
doc
Type:   Online System Int32
Implements
Searchable Explain(Weight, Int32)
See Also
MultiSearcher Class
MultiSearcher Members
Explain Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSearchables Method

MultiSearcher GetSearchables Method Lucene.Net Class Library
Return the array of Searchables this searches.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Searchable[] GetSearchables()
public virtual Searchable[] GetSearchables()
Public Overridable Function GetSearchables As Searchable()
Public Overridable Function GetSearchables As Searchable()
public:
virtual array<Searchable^>^ GetSearchables()
public:
virtual array<Searchable^>^ GetSearchables()
See Also
MultiSearcher Class
MultiSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetStarts Method

MultiSearcher GetStarts Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual int[] GetStarts()
protected virtual int[] GetStarts()
Protected Overridable Function GetStarts As Integer()
Protected Overridable Function GetStarts As Integer()
protected:
virtual array<int>^ GetStarts()
protected:
virtual array<int>^ GetStarts()
See Also
MultiSearcher Class
MultiSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

MultiSearcher Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    Query original
)
public override Query Rewrite(
    Query original
)
Public Overrides Function Rewrite ( _
    original As Query _
) As Query
Public Overrides Function Rewrite ( _
    original As Query _
) As Query
public:
virtual Query^ Rewrite(
    Query^ original
) override
public:
virtual Query^ Rewrite(
    Query^ original
) override
Parameters
original
Type: Lucene.Net.Search Query
Implements
Searchable Rewrite(Query)
See Also
MultiSearcher Class
MultiSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method

MultiSearcher Search Method Lucene.Net Class Library
Overload List
Name | Description
Public method Search(Query, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32) ) is usually more efficient, as it skips non-high-scoring hits.

Note: The score passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top n hits for query.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Filter, Int32)) is usually more efficient, as it skips non-high-scoring hits.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top n hits for query, applying filter if non-null.
(Inherited from Searcher.)
Public method Search(Weight, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32)) is usually more efficient, as it skips non-high-scoring hits.
(Overrides Searcher Search(Weight, Filter, Collector).)
Public method | Search(Weight, Filter, Int32) | (Overrides Searcher Search(Weight, Filter, Int32).)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top n hits for query, applying filter if non-null, and sorting the hits by the criteria in sort.

NOTE: this does not compute scores by default; use SetDefaultFieldSortScoring(Boolean, Boolean) to enable scoring.
(Inherited from Searcher.)
Public method | Search(Weight, Filter, Int32, Sort) | (Overrides Searcher Search(Weight, Filter, Int32, Sort).)
Back to Top
See Also
MultiSearcher Class
MultiSearcher Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Weight, Filter, Collector)

MultiSearcher Search Method (Weight, Filter, Collector) Lucene.Net Class Library
Lower-level search API.

Collect(Int32) is called for every document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32)) is usually more efficient, as it skips non-high-scoring hits.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Search(
    Weight weight,
    Filter filter,
    Collector collector
)
public override void Search(
    Weight weight,
    Filter filter,
    Collector collector
)
Public Overrides Sub Search ( _
    weight As Weight, _
    filter As Filter, _
    collector As Collector _
)
Public Overrides Sub Search ( _
    weight As Weight, _
    filter As Filter, _
    collector As Collector _
)
public:
virtual void Search(
    Weight^ weight,
    Filter^ filter,
    Collector^ collector
) override
public:
virtual void Search(
    Weight^ weight,
    Filter^ filter,
    Collector^ collector
) override
Parameters
weight
Type: Lucene.Net.Search Weight
to match documents

filter
Type: Lucene.Net.Search Filter
if non-null, used to permit documents to be collected.

collector
Type: Lucene.Net.Search Collector
to receive hits

Implements
Searchable Search(Weight, Filter, Collector)
See Also
MultiSearcher Class
MultiSearcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Weight, Filter, Int32)

MultiSearcher Search Method (Weight, Filter, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TopDocs Search(
    Weight weight,
    Filter filter,
    int nDocs
)
public override TopDocs Search(
    Weight weight,
    Filter filter,
    int nDocs
)
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer _
) As TopDocs
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer _
) As TopDocs
public:
virtual TopDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs
) override
public:
virtual TopDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs
) override
Parameters
weight
Type: Lucene.Net.Search Weight
filter
Type: Lucene.Net.Search Filter
nDocs
Type:   Online System Int32
Implements
Searchable Search(Weight, Filter, Int32)
See Also
MultiSearcher Class
MultiSearcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Weight, Filter, Int32, Sort)

MultiSearcher Search Method (Weight, Filter, Int32, Sort) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int n,
    Sort sort
)
public override TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int n,
    Sort sort
)
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    n As Integer, _
    sort As Sort _
) As TopFieldDocs
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    n As Integer, _
    sort As Sort _
) As TopFieldDocs
public:
virtual TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int n,
    Sort^ sort
) override
public:
virtual TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int n,
    Sort^ sort
) override
Parameters
weight
Type: Lucene.Net.Search Weight
filter
Type: Lucene.Net.Search Filter
n
Type:   Online System Int32
sort
Type: Lucene.Net.Search Sort
Implements
Searchable Search(Weight, Filter, Int32, Sort)
See Also
MultiSearcher Class
MultiSearcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SubDoc Method

MultiSearcher SubDoc Method Lucene.Net Class Library
Returns the document number of document n within its sub-index.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int SubDoc(
    int n
)
public virtual int SubDoc(
    int n
)
Public Overridable Function SubDoc ( _
    n As Integer _
) As Integer
Public Overridable Function SubDoc ( _
    n As Integer _
) As Integer
public:
virtual int SubDoc(
    int n
)
public:
virtual int SubDoc(
    int n
)
Parameters
n
Type:   Online System Int32
See Also
MultiSearcher Class
MultiSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SubSearcher Method

MultiSearcher SubSearcher Method Lucene.Net Class Library
Returns index of the searcher for document n in the array used to construct this searcher.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int SubSearcher(
    int n
)
public virtual int SubSearcher(
    int n
)
Public Overridable Function SubSearcher ( _
    n As Integer _
) As Integer
Public Overridable Function SubSearcher ( _
    n As Integer _
) As Integer
public:
virtual int SubSearcher(
    int n
)
public:
virtual int SubSearcher(
    int n
)
Parameters
n
Type:   Online System Int32
See Also
MultiSearcher Class
MultiSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiSearcher Properties

MultiSearcher Properties Lucene.Net Class Library
The MultiSearcher type exposes the following members.
Properties
 | Name | Description
Public property | MaxDoc | (Overrides Searcher MaxDoc.)
Public property | Similarity | Expert: Gets or Sets the Similarity implementation used by this Searcher. (Inherited from Searcher.)
Back to Top
See Also
MultiSearcher Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxDoc Property

MultiSearcher MaxDoc Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int MaxDoc { get; }
public override int MaxDoc { get; }
Public Overrides ReadOnly Property MaxDoc As Integer
    Get
Public Overrides ReadOnly Property MaxDoc As Integer
    Get
public:
virtual property int MaxDoc {
    int get () override;
}
public:
virtual property int MaxDoc {
    int get () override;
}
Implements
Searchable MaxDoc
See Also
MultiSearcher Class
MultiSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQuery Class

MultiTermQuery Class Lucene.Net Class Library
An abstract Query that matches documents containing a subset of terms provided by a FilteredTermEnum enumeration.

This query cannot be used directly; you must subclass it and define GetEnum(IndexReader) to provide a FilteredTermEnum that iterates through the terms to be matched.

NOTE: if RewriteMethod is either CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE or SCORING_BOOLEAN_QUERY_REWRITE , you may encounter a BooleanQuery TooManyClauses exception during searching, which happens when the number of terms to be searched exceeds MaxClauseCount . Setting RewriteMethod to CONSTANT_SCORE_FILTER_REWRITE prevents this.

The recommended rewrite method is CONSTANT_SCORE_AUTO_REWRITE_DEFAULT : it doesn't spend CPU computing unhelpful scores, and it tries to pick the most performant rewrite method given the query. Note that QueryParser produces MultiTermQueries using CONSTANT_SCORE_AUTO_REWRITE_DEFAULT by default.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search MultiTermQuery
Lucene.Net.Search FuzzyQuery
Lucene.Net.Search NumericRangeQuery T
Lucene.Net.Search PrefixQuery
Lucene.Net.Search TermRangeQuery
Lucene.Net.Search WildcardQuery

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class MultiTermQuery : Query
[SerializableAttribute]
public abstract class MultiTermQuery : Query
<SerializableAttribute> _
Public MustInherit Class MultiTermQuery _
    Inherits Query
<SerializableAttribute> _
Public MustInherit Class MultiTermQuery _
    Inherits Query
[SerializableAttribute]
public ref class MultiTermQuery abstract : public Query
[SerializableAttribute]
public ref class MultiTermQuery abstract : public Query
See Also
MultiTermQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQuery Members

MultiTermQuery Members Lucene.Net Class Library

The MultiTermQuery type exposes the following members.
Constructors
 | Name | Description
Protected method | MultiTermQuery | Constructs a query matching terms that cannot be represented with a single Term.
Back to Top
Methods
Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.
(Inherited from Query.)
Public method | Equals | (Overrides Query Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its rewritten form.
(Inherited from Query.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Protected method GetEnum
Construct the enumeration to be used, expanding the pattern term.
Public method | GetHashCode | (Overrides Query GetHashCode .)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method | IncTotalNumberOfTerms
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method ToString
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a query to a string, with field assumed to be the default field and omitted.

The representation used is one that is supposed to be readable by QueryParser. However, there are the following limitations:
  • If the query was created by the parser, the printed representation may not be exactly what was parsed. For example, characters that need to be escaped will be represented without the required backslash.
  • Some of the more complicated queries (e.g. span queries) don't have a representation that can be parsed by QueryParser.
(Inherited from Query.)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)
Back to Top
Fields
 | Name | Description
 | CONSTANT_SCORE_AUTO_REWRITE_DEFAULT | Read-only default instance of MultiTermQuery ConstantScoreAutoRewrite , with TermCountCutoff set to DEFAULT_TERM_COUNT_CUTOFF and DocCountPercent set to DEFAULT_DOC_COUNT_PERCENT . Note that you cannot alter the configuration of this instance; you'll need to create a private instance instead.
 | CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE | Like SCORING_BOOLEAN_QUERY_REWRITE except scores are not computed. Instead, each matching document receives a constant score equal to the query's boost. NOTE: This rewrite method will hit BooleanQuery TooManyClauses if the number of terms exceeds MaxClauseCount.
 | CONSTANT_SCORE_FILTER_REWRITE | A rewrite method that first creates a private Filter, by visiting each term in sequence and marking all docs for that term. Matching documents are assigned a constant score equal to the query's boost. This method is faster than the BooleanQuery rewrite methods when the number of matched terms or matched documents is non-trivial. Also, it will never hit an errant BooleanQuery TooManyClauses exception.
Protected field | internalRewriteMethod |
 | SCORING_BOOLEAN_QUERY_REWRITE | A rewrite method that first translates each term into SHOULD clause in a BooleanQuery, and keeps the scores as computed by the query. Note that typically such scores are meaningless to the user, and require non-trivial CPU to compute, so it's almost always better to use CONSTANT_SCORE_AUTO_REWRITE_DEFAULT instead. NOTE: This rewrite method will hit BooleanQuery TooManyClauses if the number of terms exceeds MaxClauseCount.
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | RewriteMethod | Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of RewriteMethod.
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.
Back to Top
See Also
MultiTermQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQuery Constructor

MultiTermQuery Constructor Lucene.Net Class Library
Constructs a query matching terms that cannot be represented with a single Term.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MultiTermQuery()
protected MultiTermQuery()
Protected Sub New
Protected Sub New
protected:
MultiTermQuery()
protected:
MultiTermQuery()
See Also
MultiTermQuery Class
MultiTermQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQuery Fields

MultiTermQuery Fields Lucene.Net Class Library
The MultiTermQuery type exposes the following members.
Fields
 | Name | Description
 | CONSTANT_SCORE_AUTO_REWRITE_DEFAULT | Read-only default instance of MultiTermQuery ConstantScoreAutoRewrite , with TermCountCutoff set to DEFAULT_TERM_COUNT_CUTOFF and DocCountPercent set to DEFAULT_DOC_COUNT_PERCENT . Note that you cannot alter the configuration of this instance; you'll need to create a private instance instead.
 | CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE | Like SCORING_BOOLEAN_QUERY_REWRITE except scores are not computed. Instead, each matching document receives a constant score equal to the query's boost. NOTE: This rewrite method will hit BooleanQuery TooManyClauses if the number of terms exceeds MaxClauseCount.
 | CONSTANT_SCORE_FILTER_REWRITE | A rewrite method that first creates a private Filter, by visiting each term in sequence and marking all docs for that term. Matching documents are assigned a constant score equal to the query's boost. This method is faster than the BooleanQuery rewrite methods when the number of matched terms or matched documents is non-trivial. Also, it will never hit an errant BooleanQuery TooManyClauses exception.
Protected field | internalRewriteMethod |
 | SCORING_BOOLEAN_QUERY_REWRITE | A rewrite method that first translates each term into SHOULD clause in a BooleanQuery, and keeps the scores as computed by the query. Note that typically such scores are meaningless to the user, and require non-trivial CPU to compute, so it's almost always better to use CONSTANT_SCORE_AUTO_REWRITE_DEFAULT instead. NOTE: This rewrite method will hit BooleanQuery TooManyClauses if the number of terms exceeds MaxClauseCount.
Back to Top
See Also
MultiTermQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CONSTANT_SCORE_AUTO_REWRITE_DEFAULT Field

MultiTermQuery CONSTANT_SCORE_AUTO_REWRITE_DEFAULT Field Lucene.Net Class Library
Read-only default instance of MultiTermQuery ConstantScoreAutoRewrite , with TermCountCutoff set to DEFAULT_TERM_COUNT_CUTOFF and DocCountPercent set to DEFAULT_DOC_COUNT_PERCENT . Note that you cannot alter the configuration of this instance; you'll need to create a private instance instead.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly RewriteMethod CONSTANT_SCORE_AUTO_REWRITE_DEFAULT
public static readonly RewriteMethod CONSTANT_SCORE_AUTO_REWRITE_DEFAULT
Public Shared ReadOnly CONSTANT_SCORE_AUTO_REWRITE_DEFAULT As RewriteMethod
Public Shared ReadOnly CONSTANT_SCORE_AUTO_REWRITE_DEFAULT As RewriteMethod
public:
static initonly RewriteMethod^ CONSTANT_SCORE_AUTO_REWRITE_DEFAULT
public:
static initonly RewriteMethod^ CONSTANT_SCORE_AUTO_REWRITE_DEFAULT
See Also
MultiTermQuery Class
MultiTermQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE Field

MultiTermQuery CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE Field Lucene.Net Class Library
Like SCORING_BOOLEAN_QUERY_REWRITE except scores are not computed. Instead, each matching document receives a constant score equal to the query's boost.

NOTE: This rewrite method will hit BooleanQuery TooManyClauses if the number of terms exceeds MaxClauseCount.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly RewriteMethod CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE
public static readonly RewriteMethod CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE
Public Shared ReadOnly CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE As RewriteMethod
Public Shared ReadOnly CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE As RewriteMethod
public:
static initonly RewriteMethod^ CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE
public:
static initonly RewriteMethod^ CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE
See Also
MultiTermQuery Class
MultiTermQuery Members
Lucene.Net.Search Namespace
MultiTermQuery RewriteMethod
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CONSTANT_SCORE_FILTER_REWRITE Field

MultiTermQuery CONSTANT_SCORE_FILTER_REWRITE Field Lucene.Net Class Library
A rewrite method that first creates a private Filter, by visiting each term in sequence and marking all docs for that term. Matching documents are assigned a constant score equal to the query's boost.

This method is faster than the BooleanQuery rewrite methods when the number of matched terms or matched documents is non-trivial. Also, it will never hit an errant BooleanQuery TooManyClauses exception.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly RewriteMethod CONSTANT_SCORE_FILTER_REWRITE
public static readonly RewriteMethod CONSTANT_SCORE_FILTER_REWRITE
Public Shared ReadOnly CONSTANT_SCORE_FILTER_REWRITE As RewriteMethod
Public Shared ReadOnly CONSTANT_SCORE_FILTER_REWRITE As RewriteMethod
public:
static initonly RewriteMethod^ CONSTANT_SCORE_FILTER_REWRITE
public:
static initonly RewriteMethod^ CONSTANT_SCORE_FILTER_REWRITE
See Also
MultiTermQuery Class
MultiTermQuery Members
Lucene.Net.Search Namespace
MultiTermQuery RewriteMethod
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalRewriteMethod Field

MultiTermQuery internalRewriteMethod Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected RewriteMethod internalRewriteMethod
protected RewriteMethod internalRewriteMethod
Protected internalRewriteMethod As RewriteMethod
Protected internalRewriteMethod As RewriteMethod
protected:
RewriteMethod^ internalRewriteMethod
protected:
RewriteMethod^ internalRewriteMethod
See Also
MultiTermQuery Class
MultiTermQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SCORING_BOOLEAN_QUERY_REWRITE Field

MultiTermQuery SCORING_BOOLEAN_QUERY_REWRITE Field Lucene.Net Class Library
A rewrite method that first translates each term into SHOULD clause in a BooleanQuery, and keeps the scores as computed by the query. Note that typically such scores are meaningless to the user, and require non-trivial CPU to compute, so it's almost always better to use CONSTANT_SCORE_AUTO_REWRITE_DEFAULT instead.

NOTE: This rewrite method will hit BooleanQuery TooManyClauses if the number of terms exceeds MaxClauseCount.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly RewriteMethod SCORING_BOOLEAN_QUERY_REWRITE
public static readonly RewriteMethod SCORING_BOOLEAN_QUERY_REWRITE
Public Shared ReadOnly SCORING_BOOLEAN_QUERY_REWRITE As RewriteMethod
Public Shared ReadOnly SCORING_BOOLEAN_QUERY_REWRITE As RewriteMethod
public:
static initonly RewriteMethod^ SCORING_BOOLEAN_QUERY_REWRITE
public:
static initonly RewriteMethod^ SCORING_BOOLEAN_QUERY_REWRITE
See Also
MultiTermQuery Class
MultiTermQuery Members
Lucene.Net.Search Namespace
MultiTermQuery RewriteMethod
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQuery Methods

MultiTermQuery Methods Lucene.Net Class Library
The MultiTermQuery type exposes the following members.
Methods
Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.
(Inherited from Query.)
Public method | Equals | (Overrides Query Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its rewritten form.
(Inherited from Query.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Protected method GetEnum
Construct the enumeration to be used, expanding the pattern term.
Public method | GetHashCode | (Overrides Query GetHashCode .)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method | IncTotalNumberOfTerms
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method ToString
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a query to a string, with field assumed to be the default field and omitted.

The representation used is one that is supposed to be readable by QueryParser. However, there are the following limitations:
  • If the query was created by the parser, the printed representation may not be exactly what was parsed. For example, characters that need to be escaped will be represented without the required backslash.
  • Some of the more complicated queries (e.g. span queries) don't have a representation that can be parsed by QueryParser.
(Inherited from Query.)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)
Back to Top
See Also
MultiTermQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ClearTotalNumberOfTerms Method

MultiTermQuery ClearTotalNumberOfTerms Method Lucene.Net Class Library
Expert: Resets the counting of unique terms. Do this before executing the query/filter.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ClearTotalNumberOfTerms()
public virtual void ClearTotalNumberOfTerms()
Public Overridable Sub ClearTotalNumberOfTerms
Public Overridable Sub ClearTotalNumberOfTerms
public:
virtual void ClearTotalNumberOfTerms()
public:
virtual void ClearTotalNumberOfTerms()
See Also
MultiTermQuery Class
MultiTermQuery Members
Lucene.Net.Search Namespace
MultiTermQuery TotalNumberOfTerms
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

MultiTermQuery Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
MultiTermQuery Class
MultiTermQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetEnum Method

MultiTermQuery GetEnum Method Lucene.Net Class Library
Construct the enumeration to be used, expanding the pattern term.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract FilteredTermEnum GetEnum(
    IndexReader reader
)
protected abstract FilteredTermEnum GetEnum(
    IndexReader reader
)
Protected MustOverride Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
Protected MustOverride Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
protected:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) abstract
protected:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) abstract
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
MultiTermQuery Class
MultiTermQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

MultiTermQuery GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
MultiTermQuery Class
MultiTermQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncTotalNumberOfTerms Method

MultiTermQuery IncTotalNumberOfTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void IncTotalNumberOfTerms(
    int inc
)
protected virtual void IncTotalNumberOfTerms(
    int inc
)
Protected Overridable Sub IncTotalNumberOfTerms ( _
    inc As Integer _
)
Protected Overridable Sub IncTotalNumberOfTerms ( _
    inc As Integer _
)
protected:
virtual void IncTotalNumberOfTerms(
    int inc
)
protected:
virtual void IncTotalNumberOfTerms(
    int inc
)
Parameters
inc
Type:   Online System Int32
See Also
MultiTermQuery Class
MultiTermQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

MultiTermQuery Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    IndexReader reader
)
public override Query Rewrite(
    IndexReader reader
)
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
MultiTermQuery Class
MultiTermQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQuery Properties

MultiTermQuery Properties Lucene.Net Class Library
The MultiTermQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | RewriteMethod | Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of RewriteMethod.
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.
Back to Top
See Also
MultiTermQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RewriteMethod Property

MultiTermQuery RewriteMethod Property Lucene.Net Class Library
Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of RewriteMethod.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual RewriteMethod RewriteMethod { get; set; }
public virtual RewriteMethod RewriteMethod { get; set; }
Public Overridable Property RewriteMethod As RewriteMethod
    Get
    Set
Public Overridable Property RewriteMethod As RewriteMethod
    Get
    Set
public:
virtual property RewriteMethod^ RewriteMethod {
    RewriteMethod^ get ();
    void set (RewriteMethod^ value);
}
public:
virtual property RewriteMethod^ RewriteMethod {
    RewriteMethod^ get ();
    void set (RewriteMethod^ value);
}
See Also
MultiTermQuery Class
MultiTermQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TotalNumberOfTerms Property

MultiTermQuery TotalNumberOfTerms Property Lucene.Net Class Library
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms .

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int TotalNumberOfTerms { get; }
public virtual int TotalNumberOfTerms { get; }
Public Overridable ReadOnly Property TotalNumberOfTerms As Integer
    Get
Public Overridable ReadOnly Property TotalNumberOfTerms As Integer
    Get
public:
virtual property int TotalNumberOfTerms {
    int get ();
}
public:
virtual property int TotalNumberOfTerms {
    int get ();
}
See Also
MultiTermQuery Class
MultiTermQuery Members
Lucene.Net.Search Namespace
MultiTermQuery ClearTotalNumberOfTerms
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQuery.AnonymousClassConstantScoreAutoRewrite Class

MultiTermQuery AnonymousClassConstantScoreAutoRewrite Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search RewriteMethod
Lucene.Net.Search MultiTermQuery ConstantScoreAutoRewrite
Lucene.Net.Search MultiTermQuery AnonymousClassConstantScoreAutoRewrite

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class AnonymousClassConstantScoreAutoRewrite : MultiTermQuery..::..ConstantScoreAutoRewrite
[SerializableAttribute]
public class AnonymousClassConstantScoreAutoRewrite : MultiTermQuery..::..ConstantScoreAutoRewrite
<SerializableAttribute> _
Public Class AnonymousClassConstantScoreAutoRewrite _
    Inherits MultiTermQuery..::..ConstantScoreAutoRewrite
<SerializableAttribute> _
Public Class AnonymousClassConstantScoreAutoRewrite _
    Inherits MultiTermQuery..::..ConstantScoreAutoRewrite
[SerializableAttribute]
public ref class AnonymousClassConstantScoreAutoRewrite : public MultiTermQuery..::..ConstantScoreAutoRewrite
[SerializableAttribute]
public ref class AnonymousClassConstantScoreAutoRewrite : public MultiTermQuery..::..ConstantScoreAutoRewrite
See Also
MultiTermQuery AnonymousClassConstantScoreAutoRewrite Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQuery.AnonymousClassConstantScoreAutoRewrite Members

MultiTermQuery AnonymousClassConstantScoreAutoRewrite Members Lucene.Net Class Library

An abstract Query that matches documents containing a subset of terms provided by a FilteredTermEnum enumeration.

This query cannot be used directly; you must subclass it and define GetEnum(IndexReader) to provide a FilteredTermEnum that iterates through the terms to be matched.

NOTE: if RewriteMethod is either CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE or SCORING_BOOLEAN_QUERY_REWRITE , you may encounter a BooleanQuery TooManyClauses exception during searching, which happens when the number of terms to be searched exceeds MaxClauseCount . Setting RewriteMethod to CONSTANT_SCORE_FILTER_REWRITE prevents this.

The recommended rewrite method is CONSTANT_SCORE_AUTO_REWRITE_DEFAULT : it doesn't spend CPU computing unhelpful scores, and it tries to pick the most performant rewrite method given the query. Note that QueryParser produces MultiTermQueries using CONSTANT_SCORE_AUTO_REWRITE_DEFAULT by default.

The MultiTermQuery AnonymousClassConstantScoreAutoRewrite type exposes the following members.
Constructors
 | Name | Description
Public method | MultiTermQuery AnonymousClassConstantScoreAutoRewrite | Initializes a new instance of the MultiTermQuery AnonymousClassConstantScoreAutoRewrite class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Inherited from MultiTermQuery ConstantScoreAutoRewrite.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Inherited from MultiTermQuery ConstantScoreAutoRewrite.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadResolve |
Public method | Rewrite | (Inherited from MultiTermQuery ConstantScoreAutoRewrite.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | DocCountPercent | (Overrides MultiTermQuery ConstantScoreAutoRewrite DocCountPercent.)
Public property | TermCountCutoff | (Overrides MultiTermQuery ConstantScoreAutoRewrite TermCountCutoff.)
Back to Top
See Also
MultiTermQuery AnonymousClassConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQuery.AnonymousClassConstantScoreAutoRewrite Constructor

MultiTermQuery AnonymousClassConstantScoreAutoRewrite Constructor Lucene.Net Class Library
Initializes a new instance of the MultiTermQuery AnonymousClassConstantScoreAutoRewrite class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AnonymousClassConstantScoreAutoRewrite()
public AnonymousClassConstantScoreAutoRewrite()
Public Sub New
Public Sub New
public:
AnonymousClassConstantScoreAutoRewrite()
public:
AnonymousClassConstantScoreAutoRewrite()
See Also
MultiTermQuery AnonymousClassConstantScoreAutoRewrite Class
MultiTermQuery AnonymousClassConstantScoreAutoRewrite Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQuery.AnonymousClassConstantScoreAutoRewrite Methods

MultiTermQuery AnonymousClassConstantScoreAutoRewrite Methods Lucene.Net Class Library
The MultiTermQuery AnonymousClassConstantScoreAutoRewrite type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Inherited from MultiTermQuery ConstantScoreAutoRewrite.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Inherited from MultiTermQuery ConstantScoreAutoRewrite.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadResolve |
Public method | Rewrite | (Inherited from MultiTermQuery ConstantScoreAutoRewrite.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MultiTermQuery AnonymousClassConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadResolve Method

MultiTermQuery AnonymousClassConstantScoreAutoRewrite ReadResolve Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Object ReadResolve()
protected virtual Object ReadResolve()
Protected Overridable Function ReadResolve As Object
Protected Overridable Function ReadResolve As Object
protected:
virtual Object^ ReadResolve()
protected:
virtual Object^ ReadResolve()
See Also
MultiTermQuery AnonymousClassConstantScoreAutoRewrite Class
MultiTermQuery AnonymousClassConstantScoreAutoRewrite Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQuery.AnonymousClassConstantScoreAutoRewrite Properties

MultiTermQuery AnonymousClassConstantScoreAutoRewrite Properties Lucene.Net Class Library
The MultiTermQuery AnonymousClassConstantScoreAutoRewrite type exposes the following members.
Properties
 | Name | Description
Public property | DocCountPercent | (Overrides MultiTermQuery ConstantScoreAutoRewrite DocCountPercent.)
Public property | TermCountCutoff | (Overrides MultiTermQuery ConstantScoreAutoRewrite TermCountCutoff.)
Back to Top
See Also
MultiTermQuery AnonymousClassConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocCountPercent Property

MultiTermQuery AnonymousClassConstantScoreAutoRewrite DocCountPercent Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override double DocCountPercent { set; }
public override double DocCountPercent { set; }
Public Overrides WriteOnly Property DocCountPercent As Double
    Set
Public Overrides WriteOnly Property DocCountPercent As Double
    Set
public:
virtual property double DocCountPercent {
    void set (double value) override;
}
public:
virtual property double DocCountPercent {
    void set (double value) override;
}
See Also
MultiTermQuery AnonymousClassConstantScoreAutoRewrite Class
MultiTermQuery AnonymousClassConstantScoreAutoRewrite Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermCountCutoff Property

MultiTermQuery AnonymousClassConstantScoreAutoRewrite TermCountCutoff Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int TermCountCutoff { set; }
public override int TermCountCutoff { set; }
Public Overrides WriteOnly Property TermCountCutoff As Integer
    Set
Public Overrides WriteOnly Property TermCountCutoff As Integer
    Set
public:
virtual property int TermCountCutoff {
    void set (int value) override;
}
public:
virtual property int TermCountCutoff {
    void set (int value) override;
}
See Also
MultiTermQuery AnonymousClassConstantScoreAutoRewrite Class
MultiTermQuery AnonymousClassConstantScoreAutoRewrite Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQuery.ConstantScoreAutoRewrite Class

MultiTermQuery ConstantScoreAutoRewrite Class Lucene.Net Class Library
A rewrite method that tries to pick the best constant-score rewrite method based on term and document counts from the query. If both the number of terms and documents is small enough, then CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE is used. Otherwise, CONSTANT_SCORE_FILTER_REWRITE is used.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search RewriteMethod
Lucene.Net.Search MultiTermQuery ConstantScoreAutoRewrite
Lucene.Net.Search MultiTermQuery AnonymousClassConstantScoreAutoRewrite

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ConstantScoreAutoRewrite : RewriteMethod
[SerializableAttribute]
public class ConstantScoreAutoRewrite : RewriteMethod
<SerializableAttribute> _
Public Class ConstantScoreAutoRewrite _
    Inherits RewriteMethod
<SerializableAttribute> _
Public Class ConstantScoreAutoRewrite _
    Inherits RewriteMethod
[SerializableAttribute]
public ref class ConstantScoreAutoRewrite : public RewriteMethod
[SerializableAttribute]
public ref class ConstantScoreAutoRewrite : public RewriteMethod
See Also
MultiTermQuery ConstantScoreAutoRewrite Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQuery.ConstantScoreAutoRewrite Members

MultiTermQuery ConstantScoreAutoRewrite Members Lucene.Net Class Library

An abstract Query that matches documents containing a subset of terms provided by a FilteredTermEnum enumeration.

This query cannot be used directly; you must subclass it and define GetEnum(IndexReader) to provide a FilteredTermEnum that iterates through the terms to be matched.

NOTE: if RewriteMethod is either CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE or SCORING_BOOLEAN_QUERY_REWRITE , you may encounter a BooleanQuery TooManyClauses exception during searching, which happens when the number of terms to be searched exceeds MaxClauseCount . Setting RewriteMethod to CONSTANT_SCORE_FILTER_REWRITE prevents this.

The recommended rewrite method is CONSTANT_SCORE_AUTO_REWRITE_DEFAULT : it doesn't spend CPU computing unhelpful scores, and it tries to pick the most performant rewrite method given the query. Note that QueryParser produces MultiTermQueries using CONSTANT_SCORE_AUTO_REWRITE_DEFAULT by default.

The MultiTermQuery ConstantScoreAutoRewrite type exposes the following members.
Constructors
 | Name | Description
Public method | MultiTermQuery ConstantScoreAutoRewrite | Initializes a new instance of the MultiTermQuery ConstantScoreAutoRewrite class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides RewriteMethod Rewrite(IndexReader, MultiTermQuery).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
DEFAULT_DOC_COUNT_PERCENT |
DEFAULT_TERM_COUNT_CUTOFF |
Back to Top
Properties
 | Name | Description
Public property | DocCountPercent | If the number of documents to be visited in the postings exceeds this specified percentage of the MaxDoc for the index, then CONSTANT_SCORE_FILTER_REWRITE is used.
Public property | TermCountCutoff | If the number of terms in this query is equal to or larger than this setting then CONSTANT_SCORE_FILTER_REWRITE is used.
Back to Top
See Also
MultiTermQuery ConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQuery.ConstantScoreAutoRewrite Constructor

MultiTermQuery ConstantScoreAutoRewrite Constructor Lucene.Net Class Library
Initializes a new instance of the MultiTermQuery ConstantScoreAutoRewrite class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConstantScoreAutoRewrite()
public ConstantScoreAutoRewrite()
Public Sub New
Public Sub New
public:
ConstantScoreAutoRewrite()
public:
ConstantScoreAutoRewrite()
See Also
MultiTermQuery ConstantScoreAutoRewrite Class
MultiTermQuery ConstantScoreAutoRewrite Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQuery.ConstantScoreAutoRewrite Fields

MultiTermQuery ConstantScoreAutoRewrite Fields Lucene.Net Class Library
The MultiTermQuery ConstantScoreAutoRewrite type exposes the following members.
Fields
Name | Description
DEFAULT_DOC_COUNT_PERCENT |
DEFAULT_TERM_COUNT_CUTOFF |
Back to Top
See Also
MultiTermQuery ConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_DOC_COUNT_PERCENT Field

MultiTermQuery ConstantScoreAutoRewrite DEFAULT_DOC_COUNT_PERCENT Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double DEFAULT_DOC_COUNT_PERCENT
public static double DEFAULT_DOC_COUNT_PERCENT
Public Shared DEFAULT_DOC_COUNT_PERCENT As Double
Public Shared DEFAULT_DOC_COUNT_PERCENT As Double
public:
static double DEFAULT_DOC_COUNT_PERCENT
public:
static double DEFAULT_DOC_COUNT_PERCENT
See Also
MultiTermQuery ConstantScoreAutoRewrite Class
MultiTermQuery ConstantScoreAutoRewrite Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_TERM_COUNT_CUTOFF Field

MultiTermQuery ConstantScoreAutoRewrite DEFAULT_TERM_COUNT_CUTOFF Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int DEFAULT_TERM_COUNT_CUTOFF
public static int DEFAULT_TERM_COUNT_CUTOFF
Public Shared DEFAULT_TERM_COUNT_CUTOFF As Integer
Public Shared DEFAULT_TERM_COUNT_CUTOFF As Integer
public:
static int DEFAULT_TERM_COUNT_CUTOFF
public:
static int DEFAULT_TERM_COUNT_CUTOFF
See Also
MultiTermQuery ConstantScoreAutoRewrite Class
MultiTermQuery ConstantScoreAutoRewrite Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQuery.ConstantScoreAutoRewrite Methods

MultiTermQuery ConstantScoreAutoRewrite Methods Lucene.Net Class Library
The MultiTermQuery ConstantScoreAutoRewrite type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides RewriteMethod Rewrite(IndexReader, MultiTermQuery).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MultiTermQuery ConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

MultiTermQuery ConstantScoreAutoRewrite Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
MultiTermQuery ConstantScoreAutoRewrite Class
MultiTermQuery ConstantScoreAutoRewrite Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

MultiTermQuery ConstantScoreAutoRewrite GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
MultiTermQuery ConstantScoreAutoRewrite Class
MultiTermQuery ConstantScoreAutoRewrite Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

MultiTermQuery ConstantScoreAutoRewrite Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    IndexReader reader,
    MultiTermQuery query
)
public override Query Rewrite(
    IndexReader reader,
    MultiTermQuery query
)
Public Overrides Function Rewrite ( _
    reader As IndexReader, _
    query As MultiTermQuery _
) As Query
Public Overrides Function Rewrite ( _
    reader As IndexReader, _
    query As MultiTermQuery _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader,
    MultiTermQuery^ query
) override
public:
virtual Query^ Rewrite(
    IndexReader^ reader,
    MultiTermQuery^ query
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
query
Type: Lucene.Net.Search MultiTermQuery
See Also
MultiTermQuery ConstantScoreAutoRewrite Class
MultiTermQuery ConstantScoreAutoRewrite Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQuery.ConstantScoreAutoRewrite Properties

MultiTermQuery ConstantScoreAutoRewrite Properties Lucene.Net Class Library
The MultiTermQuery ConstantScoreAutoRewrite type exposes the following members.
Properties
 | Name | Description
Public property | DocCountPercent | If the number of documents to be visited in the postings exceeds this specified percentage of the MaxDoc for the index, then CONSTANT_SCORE_FILTER_REWRITE is used.
Public property | TermCountCutoff | If the number of terms in this query is equal to or larger than this setting then CONSTANT_SCORE_FILTER_REWRITE is used.
Back to Top
See Also
MultiTermQuery ConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocCountPercent Property

MultiTermQuery ConstantScoreAutoRewrite DocCountPercent Property Lucene.Net Class Library
If the number of documents to be visited in the postings exceeds this specified percentage of the MaxDoc for the index, then CONSTANT_SCORE_FILTER_REWRITE is used.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual double DocCountPercent { get; set; }
public virtual double DocCountPercent { get; set; }
Public Overridable Property DocCountPercent As Double
    Get
    Set
Public Overridable Property DocCountPercent As Double
    Get
    Set
public:
virtual property double DocCountPercent {
    double get ();
    void set (double value);
}
public:
virtual property double DocCountPercent {
    double get ();
    void set (double value);
}
Field Value
 0.0 to 100.0
See Also
MultiTermQuery ConstantScoreAutoRewrite Class
MultiTermQuery ConstantScoreAutoRewrite Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermCountCutoff Property

MultiTermQuery ConstantScoreAutoRewrite TermCountCutoff Property Lucene.Net Class Library
If the number of terms in this query is equal to or larger than this setting then CONSTANT_SCORE_FILTER_REWRITE is used.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int TermCountCutoff { get; set; }
public virtual int TermCountCutoff { get; set; }
Public Overridable Property TermCountCutoff As Integer
    Get
    Set
Public Overridable Property TermCountCutoff As Integer
    Get
    Set
public:
virtual property int TermCountCutoff {
    int get ();
    void set (int value);
}
public:
virtual property int TermCountCutoff {
    int get ();
    void set (int value);
}
See Also
MultiTermQuery ConstantScoreAutoRewrite Class
MultiTermQuery ConstantScoreAutoRewrite Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQueryWrapperFilter(T) Class

MultiTermQueryWrapperFilter T Class Lucene.Net Class Library
A wrapper for MultiTermQuery, that exposes its functionality as a Filter.

MultiTermQueryWrapperFilter is not designed to be used by itself. Normally you subclass it to provide a Filter counterpart for a MultiTermQuery subclass.

For example, TermRangeFilter and PrefixFilter extend MultiTermQueryWrapperFilter. This class also provides the functionality behind CONSTANT_SCORE_FILTER_REWRITE; this is why it is not abstract.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Filter
Lucene.Net.Search MultiTermQueryWrapperFilter T
Lucene.Net.Search NumericRangeFilter T
Lucene.Net.Search PrefixFilter
Lucene.Net.Search TermRangeFilter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MultiTermQueryWrapperFilter<T> : Filter
where T : MultiTermQuery
[SerializableAttribute]
public class MultiTermQueryWrapperFilter<T> : Filter
where T : MultiTermQuery
<SerializableAttribute> _
Public Class MultiTermQueryWrapperFilter(Of T As MultiTermQuery) _
    Inherits Filter
<SerializableAttribute> _
Public Class MultiTermQueryWrapperFilter(Of T As MultiTermQuery) _
    Inherits Filter
[SerializableAttribute]
generic<typename T>
where T : MultiTermQuery
public ref class MultiTermQueryWrapperFilter : public Filter
[SerializableAttribute]
generic<typename T>
where T : MultiTermQuery
public ref class MultiTermQueryWrapperFilter : public Filter
Type Parameters
T
See Also
MultiTermQueryWrapperFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQueryWrapperFilter(T) Members

MultiTermQueryWrapperFilter T Members Lucene.Net Class Library

The MultiTermQueryWrapperFilter T type exposes the following members.
Constructors
 | Name | Description
Protected method | MultiTermQueryWrapperFilter T | Wrap a MultiTermQuery as a Filter.
Back to Top
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the filter.
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Overrides Filter GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Fields
 | Name | Description
Protected field | query |
Back to Top
Properties
 | Name | Description
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms .
Back to Top
See Also
MultiTermQueryWrapperFilter T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQueryWrapperFilter(T) Constructor

MultiTermQueryWrapperFilter T Constructor Lucene.Net Class Library
Wrap a MultiTermQuery as a Filter.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MultiTermQueryWrapperFilter(
    T query
)
protected MultiTermQueryWrapperFilter(
    T query
)
Protected Sub New ( _
    query As T _
)
Protected Sub New ( _
    query As T _
)
protected:
MultiTermQueryWrapperFilter(
    T query
)
protected:
MultiTermQueryWrapperFilter(
    T query
)
Parameters
query
Type: T
See Also
MultiTermQueryWrapperFilter T  Class
MultiTermQueryWrapperFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQueryWrapperFilter(T) Fields

MultiTermQueryWrapperFilter T Fields Lucene.Net Class Library
The MultiTermQueryWrapperFilter T type exposes the following members.
Fields
 | Name | Description
Protected field | query |
Back to Top
See Also
MultiTermQueryWrapperFilter T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


query Field

MultiTermQueryWrapperFilter T query Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected T query
protected T query
Protected query As T
Protected query As T
protected:
T query
protected:
T query
See Also
MultiTermQueryWrapperFilter T  Class
MultiTermQueryWrapperFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQueryWrapperFilter(T) Methods

MultiTermQueryWrapperFilter T Methods Lucene.Net Class Library
The MultiTermQueryWrapperFilter T type exposes the following members.
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the filter.
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Overrides Filter GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
MultiTermQueryWrapperFilter T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ClearTotalNumberOfTerms Method

MultiTermQueryWrapperFilter T ClearTotalNumberOfTerms Method Lucene.Net Class Library
Expert: Resets the counting of unique terms. Do this before executing the filter.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ClearTotalNumberOfTerms()
public virtual void ClearTotalNumberOfTerms()
Public Overridable Sub ClearTotalNumberOfTerms
Public Overridable Sub ClearTotalNumberOfTerms
public:
virtual void ClearTotalNumberOfTerms()
public:
virtual void ClearTotalNumberOfTerms()
See Also
MultiTermQueryWrapperFilter T  Class
MultiTermQueryWrapperFilter T  Members
Lucene.Net.Search Namespace
MultiTermQueryWrapperFilter T  TotalNumberOfTerms
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

MultiTermQueryWrapperFilter T Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
MultiTermQueryWrapperFilter T  Class
MultiTermQueryWrapperFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetDocIdSet Method

MultiTermQueryWrapperFilter T GetDocIdSet Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
MultiTermQueryWrapperFilter T  Class
MultiTermQueryWrapperFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

MultiTermQueryWrapperFilter T GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
MultiTermQueryWrapperFilter T  Class
MultiTermQueryWrapperFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

MultiTermQueryWrapperFilter T ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
MultiTermQueryWrapperFilter T  Class
MultiTermQueryWrapperFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MultiTermQueryWrapperFilter(T) Properties

MultiTermQueryWrapperFilter T Properties Lucene.Net Class Library
The MultiTermQueryWrapperFilter T type exposes the following members.
Properties
 | Name | Description
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms .
Back to Top
See Also
MultiTermQueryWrapperFilter T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TotalNumberOfTerms Property

MultiTermQueryWrapperFilter T TotalNumberOfTerms Property Lucene.Net Class Library
Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms .

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int TotalNumberOfTerms { get; }
public virtual int TotalNumberOfTerms { get; }
Public Overridable ReadOnly Property TotalNumberOfTerms As Integer
    Get
Public Overridable ReadOnly Property TotalNumberOfTerms As Integer
    Get
public:
virtual property int TotalNumberOfTerms {
    int get ();
}
public:
virtual property int TotalNumberOfTerms {
    int get ();
}
See Also
MultiTermQueryWrapperFilter T  Class
MultiTermQueryWrapperFilter T  Members
Lucene.Net.Search Namespace
MultiTermQueryWrapperFilter T  ClearTotalNumberOfTerms
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericRangeFilter Class

NumericRangeFilter Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search NumericRangeFilter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class NumericRangeFilter
public static class NumericRangeFilter
Public NotInheritable Class NumericRangeFilter
Public NotInheritable Class NumericRangeFilter
public ref class NumericRangeFilter abstract sealed
public ref class NumericRangeFilter abstract sealed
See Also
NumericRangeFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericRangeFilter Members

NumericRangeFilter Members Lucene.Net Class Library

Methods
Name | Description
NewDoubleRange(String, Nullable Double , Nullable Double , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that queries a double range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewDoubleRange(String, Int32, Nullable Double , Nullable Double , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that filters a double range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Nullable Single , Nullable Single , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that queries a float range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Int32, Nullable Single , Nullable Single , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that filters a float range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that queries a int range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, Int32, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that filters a int range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that queries a long range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, Int32, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that filters a long range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
Back to Top
See Also
NumericRangeFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericRangeFilter Methods

NumericRangeFilter Methods Lucene.Net Class Library
Methods
Name | Description
NewDoubleRange(String, Nullable Double , Nullable Double , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that queries a double range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewDoubleRange(String, Int32, Nullable Double , Nullable Double , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that filters a double range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Nullable Single , Nullable Single , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that queries a float range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Int32, Nullable Single , Nullable Single , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that filters a float range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that queries a int range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, Int32, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that filters a int range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that queries a long range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, Int32, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that filters a long range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
Back to Top
See Also
NumericRangeFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewDoubleRange Method

NumericRangeFilter NewDoubleRange Method Lucene.Net Class Library
Overload List
Name | Description
NewDoubleRange(String, Nullable Double , Nullable Double , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that queries a double range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewDoubleRange(String, Int32, Nullable Double , Nullable Double , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that filters a double range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
Back to Top
See Also
NumericRangeFilter Class
NumericRangeFilter Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewDoubleRange Method (String, Nullable(Double), Nullable(Double), Boolean, Boolean)

NumericRangeFilter NewDoubleRange Method (String, Nullable Double , Nullable Double , Boolean, Boolean) Lucene.Net Class Library
Factory that creates a NumericRangeFilter, that queries a double range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NumericRangeFilter<double> NewDoubleRange(
    string field,
    Nullable<double> min,
    Nullable<double> max,
    bool minInclusive,
    bool maxInclusive
)
public static NumericRangeFilter<double> NewDoubleRange(
    string field,
    Nullable<double> min,
    Nullable<double> max,
    bool minInclusive,
    bool maxInclusive
)
Public Shared Function NewDoubleRange ( _
    field As String, _
    min As Nullable(Of Double), _
    max As Nullable(Of Double), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter(Of Double)
Public Shared Function NewDoubleRange ( _
    field As String, _
    min As Nullable(Of Double), _
    max As Nullable(Of Double), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter(Of Double)
public:
static NumericRangeFilter<double>^ NewDoubleRange(
    String^ field,
    Nullable<double> min,
    Nullable<double> max,
    bool minInclusive,
    bool maxInclusive
)
public:
static NumericRangeFilter<double>^ NewDoubleRange(
    String^ field,
    Nullable<double> min,
    Nullable<double> max,
    bool minInclusive,
    bool maxInclusive
)
Parameters
field
Type:   Online System String
min
Type:   Online System Nullable    Online Double
max
Type:   Online System Nullable    Online Double
minInclusive
Type:   Online System Boolean
maxInclusive
Type:   Online System Boolean
See Also
NumericRangeFilter Class
NumericRangeFilter Members
NewDoubleRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewDoubleRange Method (String, Int32, Nullable(Double), Nullable(Double), Boolean, Boolean)

NumericRangeFilter NewDoubleRange Method (String, Int32, Nullable Double , Nullable Double , Boolean, Boolean) Lucene.Net Class Library
Factory that creates a NumericRangeFilter, that filters a double range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NumericRangeFilter<double> NewDoubleRange(
    string field,
    int precisionStep,
    Nullable<double> min,
    Nullable<double> max,
    bool minInclusive,
    bool maxInclusive
)
public static NumericRangeFilter<double> NewDoubleRange(
    string field,
    int precisionStep,
    Nullable<double> min,
    Nullable<double> max,
    bool minInclusive,
    bool maxInclusive
)
Public Shared Function NewDoubleRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Nullable(Of Double), _
    max As Nullable(Of Double), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter(Of Double)
Public Shared Function NewDoubleRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Nullable(Of Double), _
    max As Nullable(Of Double), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter(Of Double)
public:
static NumericRangeFilter<double>^ NewDoubleRange(
    String^ field,
    int precisionStep,
    Nullable<double> min,
    Nullable<double> max,
    bool minInclusive,
    bool maxInclusive
)
public:
static NumericRangeFilter<double>^ NewDoubleRange(
    String^ field,
    int precisionStep,
    Nullable<double> min,
    Nullable<double> max,
    bool minInclusive,
    bool maxInclusive
)
Parameters
field
Type:   Online System String
precisionStep
Type:   Online System Int32
min
Type:   Online System Nullable    Online Double
max
Type:   Online System Nullable    Online Double
minInclusive
Type:   Online System Boolean
maxInclusive
Type:   Online System Boolean
See Also
NumericRangeFilter Class
NumericRangeFilter Members
NewDoubleRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewFloatRange Method

NumericRangeFilter NewFloatRange Method Lucene.Net Class Library
Overload List
Name | Description
NewFloatRange(String, Nullable Single , Nullable Single , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that queries a float range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Int32, Nullable Single , Nullable Single , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that filters a float range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
Back to Top
See Also
NumericRangeFilter Class
NumericRangeFilter Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewFloatRange Method (String, Nullable(Single), Nullable(Single), Boolean, Boolean)

NumericRangeFilter NewFloatRange Method (String, Nullable Single , Nullable Single , Boolean, Boolean) Lucene.Net Class Library
Factory that creates a NumericRangeFilter, that queries a float range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NumericRangeFilter<float> NewFloatRange(
    string field,
    Nullable<float> min,
    Nullable<float> max,
    bool minInclusive,
    bool maxInclusive
)
public static NumericRangeFilter<float> NewFloatRange(
    string field,
    Nullable<float> min,
    Nullable<float> max,
    bool minInclusive,
    bool maxInclusive
)
Public Shared Function NewFloatRange ( _
    field As String, _
    min As Nullable(Of Single), _
    max As Nullable(Of Single), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter(Of Single)
Public Shared Function NewFloatRange ( _
    field As String, _
    min As Nullable(Of Single), _
    max As Nullable(Of Single), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter(Of Single)
public:
static NumericRangeFilter<float>^ NewFloatRange(
    String^ field,
    Nullable<float> min,
    Nullable<float> max,
    bool minInclusive,
    bool maxInclusive
)
public:
static NumericRangeFilter<float>^ NewFloatRange(
    String^ field,
    Nullable<float> min,
    Nullable<float> max,
    bool minInclusive,
    bool maxInclusive
)
Parameters
field
Type:   Online System String
min
Type:   Online System Nullable    Online Single
max
Type:   Online System Nullable    Online Single
minInclusive
Type:   Online System Boolean
maxInclusive
Type:   Online System Boolean
See Also
NumericRangeFilter Class
NumericRangeFilter Members
NewFloatRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewFloatRange Method (String, Int32, Nullable(Single), Nullable(Single), Boolean, Boolean)

NumericRangeFilter NewFloatRange Method (String, Int32, Nullable Single , Nullable Single , Boolean, Boolean) Lucene.Net Class Library
Factory that creates a NumericRangeFilter, that filters a float range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NumericRangeFilter<float> NewFloatRange(
    string field,
    int precisionStep,
    Nullable<float> min,
    Nullable<float> max,
    bool minInclusive,
    bool maxInclusive
)
public static NumericRangeFilter<float> NewFloatRange(
    string field,
    int precisionStep,
    Nullable<float> min,
    Nullable<float> max,
    bool minInclusive,
    bool maxInclusive
)
Public Shared Function NewFloatRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Nullable(Of Single), _
    max As Nullable(Of Single), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter(Of Single)
Public Shared Function NewFloatRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Nullable(Of Single), _
    max As Nullable(Of Single), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter(Of Single)
public:
static NumericRangeFilter<float>^ NewFloatRange(
    String^ field,
    int precisionStep,
    Nullable<float> min,
    Nullable<float> max,
    bool minInclusive,
    bool maxInclusive
)
public:
static NumericRangeFilter<float>^ NewFloatRange(
    String^ field,
    int precisionStep,
    Nullable<float> min,
    Nullable<float> max,
    bool minInclusive,
    bool maxInclusive
)
Parameters
field
Type:   Online System String
precisionStep
Type:   Online System Int32
min
Type:   Online System Nullable    Online Single
max
Type:   Online System Nullable    Online Single
minInclusive
Type:   Online System Boolean
maxInclusive
Type:   Online System Boolean
See Also
NumericRangeFilter Class
NumericRangeFilter Members
NewFloatRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewIntRange Method

NumericRangeFilter NewIntRange Method Lucene.Net Class Library
Overload List
Name | Description
NewIntRange(String, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that queries a int range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, Int32, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that filters a int range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
Back to Top
See Also
NumericRangeFilter Class
NumericRangeFilter Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewIntRange Method (String, Nullable(Int32), Nullable(Int32), Boolean, Boolean)

NumericRangeFilter NewIntRange Method (String, Nullable Int32 , Nullable Int32 , Boolean, Boolean) Lucene.Net Class Library
Factory that creates a NumericRangeFilter, that queries a int range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NumericRangeFilter<int> NewIntRange(
    string field,
    Nullable<int> min,
    Nullable<int> max,
    bool minInclusive,
    bool maxInclusive
)
public static NumericRangeFilter<int> NewIntRange(
    string field,
    Nullable<int> min,
    Nullable<int> max,
    bool minInclusive,
    bool maxInclusive
)
Public Shared Function NewIntRange ( _
    field As String, _
    min As Nullable(Of Integer), _
    max As Nullable(Of Integer), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter(Of Integer)
Public Shared Function NewIntRange ( _
    field As String, _
    min As Nullable(Of Integer), _
    max As Nullable(Of Integer), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter(Of Integer)
public:
static NumericRangeFilter<int>^ NewIntRange(
    String^ field,
    Nullable<int> min,
    Nullable<int> max,
    bool minInclusive,
    bool maxInclusive
)
public:
static NumericRangeFilter<int>^ NewIntRange(
    String^ field,
    Nullable<int> min,
    Nullable<int> max,
    bool minInclusive,
    bool maxInclusive
)
Parameters
field
Type:   Online System String
min
Type:   Online System Nullable    Online Int32
max
Type:   Online System Nullable    Online Int32
minInclusive
Type:   Online System Boolean
maxInclusive
Type:   Online System Boolean
See Also
NumericRangeFilter Class
NumericRangeFilter Members
NewIntRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewIntRange Method (String, Int32, Nullable(Int32), Nullable(Int32), Boolean, Boolean)

NumericRangeFilter NewIntRange Method (String, Int32, Nullable Int32 , Nullable Int32 , Boolean, Boolean) Lucene.Net Class Library
Factory that creates a NumericRangeFilter, that filters a int range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NumericRangeFilter<int> NewIntRange(
    string field,
    int precisionStep,
    Nullable<int> min,
    Nullable<int> max,
    bool minInclusive,
    bool maxInclusive
)
public static NumericRangeFilter<int> NewIntRange(
    string field,
    int precisionStep,
    Nullable<int> min,
    Nullable<int> max,
    bool minInclusive,
    bool maxInclusive
)
Public Shared Function NewIntRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Nullable(Of Integer), _
    max As Nullable(Of Integer), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter(Of Integer)
Public Shared Function NewIntRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Nullable(Of Integer), _
    max As Nullable(Of Integer), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter(Of Integer)
public:
static NumericRangeFilter<int>^ NewIntRange(
    String^ field,
    int precisionStep,
    Nullable<int> min,
    Nullable<int> max,
    bool minInclusive,
    bool maxInclusive
)
public:
static NumericRangeFilter<int>^ NewIntRange(
    String^ field,
    int precisionStep,
    Nullable<int> min,
    Nullable<int> max,
    bool minInclusive,
    bool maxInclusive
)
Parameters
field
Type:   Online System String
precisionStep
Type:   Online System Int32
min
Type:   Online System Nullable    Online Int32
max
Type:   Online System Nullable    Online Int32
minInclusive
Type:   Online System Boolean
maxInclusive
Type:   Online System Boolean
See Also
NumericRangeFilter Class
NumericRangeFilter Members
NewIntRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewLongRange Method

NumericRangeFilter NewLongRange Method Lucene.Net Class Library
Overload List
Name | Description
NewLongRange(String, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that queries a long range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, Int32, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Factory that creates a NumericRangeFilter, that filters a long range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
Back to Top
See Also
NumericRangeFilter Class
NumericRangeFilter Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewLongRange Method (String, Nullable(Int64), Nullable(Int64), Boolean, Boolean)

NumericRangeFilter NewLongRange Method (String, Nullable Int64 , Nullable Int64 , Boolean, Boolean) Lucene.Net Class Library
Factory that creates a NumericRangeFilter, that queries a long range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NumericRangeFilter<long> NewLongRange(
    string field,
    Nullable<long> min,
    Nullable<long> max,
    bool minInclusive,
    bool maxInclusive
)
public static NumericRangeFilter<long> NewLongRange(
    string field,
    Nullable<long> min,
    Nullable<long> max,
    bool minInclusive,
    bool maxInclusive
)
Public Shared Function NewLongRange ( _
    field As String, _
    min As Nullable(Of Long), _
    max As Nullable(Of Long), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter(Of Long)
Public Shared Function NewLongRange ( _
    field As String, _
    min As Nullable(Of Long), _
    max As Nullable(Of Long), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter(Of Long)
public:
static NumericRangeFilter<long long>^ NewLongRange(
    String^ field,
    Nullable<long long> min,
    Nullable<long long> max,
    bool minInclusive,
    bool maxInclusive
)
public:
static NumericRangeFilter<long long>^ NewLongRange(
    String^ field,
    Nullable<long long> min,
    Nullable<long long> max,
    bool minInclusive,
    bool maxInclusive
)
Parameters
field
Type:   Online System String
min
Type:   Online System Nullable    Online Int64
max
Type:   Online System Nullable    Online Int64
minInclusive
Type:   Online System Boolean
maxInclusive
Type:   Online System Boolean
See Also
NumericRangeFilter Class
NumericRangeFilter Members
NewLongRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewLongRange Method (String, Int32, Nullable(Int64), Nullable(Int64), Boolean, Boolean)

NumericRangeFilter NewLongRange Method (String, Int32, Nullable Int64 , Nullable Int64 , Boolean, Boolean) Lucene.Net Class Library
Factory that creates a NumericRangeFilter, that filters a long range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NumericRangeFilter<long> NewLongRange(
    string field,
    int precisionStep,
    Nullable<long> min,
    Nullable<long> max,
    bool minInclusive,
    bool maxInclusive
)
public static NumericRangeFilter<long> NewLongRange(
    string field,
    int precisionStep,
    Nullable<long> min,
    Nullable<long> max,
    bool minInclusive,
    bool maxInclusive
)
Public Shared Function NewLongRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Nullable(Of Long), _
    max As Nullable(Of Long), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter(Of Long)
Public Shared Function NewLongRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Nullable(Of Long), _
    max As Nullable(Of Long), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter(Of Long)
public:
static NumericRangeFilter<long long>^ NewLongRange(
    String^ field,
    int precisionStep,
    Nullable<long long> min,
    Nullable<long long> max,
    bool minInclusive,
    bool maxInclusive
)
public:
static NumericRangeFilter<long long>^ NewLongRange(
    String^ field,
    int precisionStep,
    Nullable<long long> min,
    Nullable<long long> max,
    bool minInclusive,
    bool maxInclusive
)
Parameters
field
Type:   Online System String
precisionStep
Type:   Online System Int32
min
Type:   Online System Nullable    Online Int64
max
Type:   Online System Nullable    Online Int64
minInclusive
Type:   Online System Boolean
maxInclusive
Type:   Online System Boolean
See Also
NumericRangeFilter Class
NumericRangeFilter Members
NewLongRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericRangeFilter(T) Class

NumericRangeFilter T Class Lucene.Net Class Library
A Filter that only accepts numeric values within a specified range. To use this, you must first index the numeric values using NumericField (expert: NumericTokenStream ).

You create a new NumericRangeFilter with the static factory methods, eg:
View Colorized Copy to Clipboard Print
Filter f = NumericRangeFilter.newFloatRange("weight",
            new Float(0.3f), new Float(0.10f),
            true, true);
Filter f = NumericRangeFilter.newFloatRange("weight",
            new Float(0.3f), new Float(0.10f),
            true, true);
accepts all documents whose float valued "weight" field ranges from 0.3 to 0.10, inclusive. See NumericRangeQuery T for details on how Lucene indexes and searches numeric valued fields.

NOTE: This API is experimental and might change in incompatible ways in the next release.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Filter
Lucene.Net.Search MultiTermQueryWrapperFilter NumericRangeQuery T
Lucene.Net.Search NumericRangeFilter T

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class NumericRangeFilter<T> : MultiTermQueryWrapperFilter<NumericRangeQuery<T>>
where T : struct, new(), IComparable<T>
[SerializableAttribute]
public sealed class NumericRangeFilter<T> : MultiTermQueryWrapperFilter<NumericRangeQuery<T>>
where T : struct, new(), IComparable<T>
<SerializableAttribute> _
Public NotInheritable Class NumericRangeFilter(Of T As {Structure, New, IComparable(Of T)}) _
    Inherits MultiTermQueryWrapperFilter(Of NumericRangeQuery(Of T))
<SerializableAttribute> _
Public NotInheritable Class NumericRangeFilter(Of T As {Structure, New, IComparable(Of T)}) _
    Inherits MultiTermQueryWrapperFilter(Of NumericRangeQuery(Of T))
[SerializableAttribute]
generic<typename T>
where T : value class, gcnew(), IComparable<T>
public ref class NumericRangeFilter sealed : public MultiTermQueryWrapperFilter<NumericRangeQuery<T>^>
[SerializableAttribute]
generic<typename T>
where T : value class, gcnew(), IComparable<T>
public ref class NumericRangeFilter sealed : public MultiTermQueryWrapperFilter<NumericRangeQuery<T>^>
Type Parameters
T
See Also
NumericRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericRangeFilter(T) Members

NumericRangeFilter T Members Lucene.Net Class Library

The NumericRangeFilter T type exposes the following members.
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the filter. (Inherited from MultiTermQueryWrapperFilter T .)
Public method | Equals | (Inherited from MultiTermQueryWrapperFilter T .)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Inherited from MultiTermQueryWrapperFilter T .)
Public method | GetHashCode | (Inherited from MultiTermQueryWrapperFilter T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from MultiTermQueryWrapperFilter T .)
Back to Top
Fields
 | Name | Description
Protected field | query | (Inherited from MultiTermQueryWrapperFilter T .)
Back to Top
Properties
 | Name | Description
Public property | Field | Returns the field name for this filter
Public property | IncludesMax | Returns true if the upper endpoint is inclusive
Public property | IncludesMin | Returns true if the lower endpoint is inclusive
Public property | Max | Returns the upper value of this range filter
Public property | Min | Returns the lower value of this range filter
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . (Inherited from MultiTermQueryWrapperFilter T .)
Back to Top
See Also
NumericRangeFilter T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericRangeFilter(T) Fields

NumericRangeFilter T Fields Lucene.Net Class Library
The NumericRangeFilter T type exposes the following members.
Fields
 | Name | Description
Protected field | query | (Inherited from MultiTermQueryWrapperFilter T .)
Back to Top
See Also
NumericRangeFilter T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericRangeFilter(T) Methods

NumericRangeFilter T Methods Lucene.Net Class Library
The NumericRangeFilter T type exposes the following members.
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the filter. (Inherited from MultiTermQueryWrapperFilter T .)
Public method | Equals | (Inherited from MultiTermQueryWrapperFilter T .)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Inherited from MultiTermQueryWrapperFilter T .)
Public method | GetHashCode | (Inherited from MultiTermQueryWrapperFilter T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from MultiTermQueryWrapperFilter T .)
Back to Top
See Also
NumericRangeFilter T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericRangeFilter(T) Properties

NumericRangeFilter T Properties Lucene.Net Class Library
The NumericRangeFilter T type exposes the following members.
Properties
 | Name | Description
Public property | Field | Returns the field name for this filter
Public property | IncludesMax | Returns true if the upper endpoint is inclusive
Public property | IncludesMin | Returns true if the lower endpoint is inclusive
Public property | Max | Returns the upper value of this range filter
Public property | Min | Returns the lower value of this range filter
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . (Inherited from MultiTermQueryWrapperFilter T .)
Back to Top
See Also
NumericRangeFilter T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

NumericRangeFilter T Field Property Lucene.Net Class Library
Returns the field name for this filter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Field { get; }
public string Field { get; }
Public ReadOnly Property Field As String
    Get
Public ReadOnly Property Field As String
    Get
public:
property String^ Field {
    String^ get ();
}
public:
property String^ Field {
    String^ get ();
}
See Also
NumericRangeFilter T  Class
NumericRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncludesMax Property

NumericRangeFilter T IncludesMax Property Lucene.Net Class Library
Returns true if the upper endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IncludesMax { get; }
public bool IncludesMax { get; }
Public ReadOnly Property IncludesMax As Boolean
    Get
Public ReadOnly Property IncludesMax As Boolean
    Get
public:
property bool IncludesMax {
    bool get ();
}
public:
property bool IncludesMax {
    bool get ();
}
See Also
NumericRangeFilter T  Class
NumericRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncludesMin Property

NumericRangeFilter T IncludesMin Property Lucene.Net Class Library
Returns true if the lower endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IncludesMin { get; }
public bool IncludesMin { get; }
Public ReadOnly Property IncludesMin As Boolean
    Get
Public ReadOnly Property IncludesMin As Boolean
    Get
public:
property bool IncludesMin {
    bool get ();
}
public:
property bool IncludesMin {
    bool get ();
}
See Also
NumericRangeFilter T  Class
NumericRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Max Property

NumericRangeFilter T Max Property Lucene.Net Class Library
Returns the upper value of this range filter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<T> Max { get; }
public Nullable<T> Max { get; }
Public ReadOnly Property Max As Nullable(Of T)
    Get
Public ReadOnly Property Max As Nullable(Of T)
    Get
public:
property Nullable<T> Max {
    Nullable<T> get ();
}
public:
property Nullable<T> Max {
    Nullable<T> get ();
}
See Also
NumericRangeFilter T  Class
NumericRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Min Property

NumericRangeFilter T Min Property Lucene.Net Class Library
Returns the lower value of this range filter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<T> Min { get; }
public Nullable<T> Min { get; }
Public ReadOnly Property Min As Nullable(Of T)
    Get
Public ReadOnly Property Min As Nullable(Of T)
    Get
public:
property Nullable<T> Min {
    Nullable<T> get ();
}
public:
property Nullable<T> Min {
    Nullable<T> get ();
}
See Also
NumericRangeFilter T  Class
NumericRangeFilter T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericRangeQuery Class

NumericRangeQuery Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search NumericRangeQuery

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class NumericRangeQuery
public static class NumericRangeQuery
Public NotInheritable Class NumericRangeQuery
Public NotInheritable Class NumericRangeQuery
public ref class NumericRangeQuery abstract sealed
public ref class NumericRangeQuery abstract sealed
See Also
NumericRangeQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericRangeQuery Members

NumericRangeQuery Members Lucene.Net Class Library

Methods
Name | Description
NewDoubleRange(String, Nullable Double , Nullable Double , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a double range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewDoubleRange(String, Int32, Nullable Double , Nullable Double , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a double range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Nullable Single , Nullable Single , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a float range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Int32, Nullable Single , Nullable Single , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a float range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a int range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, Int32, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a int range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a long range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, Int32, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a long range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
Back to Top
See Also
NumericRangeQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericRangeQuery Methods

NumericRangeQuery Methods Lucene.Net Class Library
Methods
Name | Description
NewDoubleRange(String, Nullable Double , Nullable Double , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a double range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewDoubleRange(String, Int32, Nullable Double , Nullable Double , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a double range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Nullable Single , Nullable Single , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a float range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Int32, Nullable Single , Nullable Single , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a float range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a int range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, Int32, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a int range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a long range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, Int32, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a long range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
Back to Top
See Also
NumericRangeQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewDoubleRange Method

NumericRangeQuery NewDoubleRange Method Lucene.Net Class Library
Overload List
Name | Description
NewDoubleRange(String, Nullable Double , Nullable Double , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a double range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewDoubleRange(String, Int32, Nullable Double , Nullable Double , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a double range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
Back to Top
See Also
NumericRangeQuery Class
NumericRangeQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewDoubleRange Method (String, Nullable(Double), Nullable(Double), Boolean, Boolean)

NumericRangeQuery NewDoubleRange Method (String, Nullable Double , Nullable Double , Boolean, Boolean) Lucene.Net Class Library
Factory that creates a NumericRangeQuery, that queries a double range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NumericRangeQuery<double> NewDoubleRange(
    string field,
    Nullable<double> min,
    Nullable<double> max,
    bool minInclusive,
    bool maxInclusive
)
public static NumericRangeQuery<double> NewDoubleRange(
    string field,
    Nullable<double> min,
    Nullable<double> max,
    bool minInclusive,
    bool maxInclusive
)
Public Shared Function NewDoubleRange ( _
    field As String, _
    min As Nullable(Of Double), _
    max As Nullable(Of Double), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery(Of Double)
Public Shared Function NewDoubleRange ( _
    field As String, _
    min As Nullable(Of Double), _
    max As Nullable(Of Double), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery(Of Double)
public:
static NumericRangeQuery<double>^ NewDoubleRange(
    String^ field,
    Nullable<double> min,
    Nullable<double> max,
    bool minInclusive,
    bool maxInclusive
)
public:
static NumericRangeQuery<double>^ NewDoubleRange(
    String^ field,
    Nullable<double> min,
    Nullable<double> max,
    bool minInclusive,
    bool maxInclusive
)
Parameters
field
Type:   Online System String
min
Type:   Online System Nullable    Online Double
max
Type:   Online System Nullable    Online Double
minInclusive
Type:   Online System Boolean
maxInclusive
Type:   Online System Boolean
See Also
NumericRangeQuery Class
NumericRangeQuery Members
NewDoubleRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewDoubleRange Method (String, Int32, Nullable(Double), Nullable(Double), Boolean, Boolean)

NumericRangeQuery NewDoubleRange Method (String, Int32, Nullable Double , Nullable Double , Boolean, Boolean) Lucene.Net Class Library
Factory that creates a NumericRangeQuery, that queries a double range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NumericRangeQuery<double> NewDoubleRange(
    string field,
    int precisionStep,
    Nullable<double> min,
    Nullable<double> max,
    bool minInclusive,
    bool maxInclusive
)
public static NumericRangeQuery<double> NewDoubleRange(
    string field,
    int precisionStep,
    Nullable<double> min,
    Nullable<double> max,
    bool minInclusive,
    bool maxInclusive
)
Public Shared Function NewDoubleRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Nullable(Of Double), _
    max As Nullable(Of Double), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery(Of Double)
Public Shared Function NewDoubleRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Nullable(Of Double), _
    max As Nullable(Of Double), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery(Of Double)
public:
static NumericRangeQuery<double>^ NewDoubleRange(
    String^ field,
    int precisionStep,
    Nullable<double> min,
    Nullable<double> max,
    bool minInclusive,
    bool maxInclusive
)
public:
static NumericRangeQuery<double>^ NewDoubleRange(
    String^ field,
    int precisionStep,
    Nullable<double> min,
    Nullable<double> max,
    bool minInclusive,
    bool maxInclusive
)
Parameters
field
Type:   Online System String
precisionStep
Type:   Online System Int32
min
Type:   Online System Nullable    Online Double
max
Type:   Online System Nullable    Online Double
minInclusive
Type:   Online System Boolean
maxInclusive
Type:   Online System Boolean
See Also
NumericRangeQuery Class
NumericRangeQuery Members
NewDoubleRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewFloatRange Method

NumericRangeQuery NewFloatRange Method Lucene.Net Class Library
Overload List
Name | Description
NewFloatRange(String, Nullable Single , Nullable Single , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a float range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Int32, Nullable Single , Nullable Single , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a float range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
Back to Top
See Also
NumericRangeQuery Class
NumericRangeQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewFloatRange Method (String, Nullable(Single), Nullable(Single), Boolean, Boolean)

NumericRangeQuery NewFloatRange Method (String, Nullable Single , Nullable Single , Boolean, Boolean) Lucene.Net Class Library
Factory that creates a NumericRangeQuery, that queries a float range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NumericRangeQuery<float> NewFloatRange(
    string field,
    Nullable<float> min,
    Nullable<float> max,
    bool minInclusive,
    bool maxInclusive
)
public static NumericRangeQuery<float> NewFloatRange(
    string field,
    Nullable<float> min,
    Nullable<float> max,
    bool minInclusive,
    bool maxInclusive
)
Public Shared Function NewFloatRange ( _
    field As String, _
    min As Nullable(Of Single), _
    max As Nullable(Of Single), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery(Of Single)
Public Shared Function NewFloatRange ( _
    field As String, _
    min As Nullable(Of Single), _
    max As Nullable(Of Single), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery(Of Single)
public:
static NumericRangeQuery<float>^ NewFloatRange(
    String^ field,
    Nullable<float> min,
    Nullable<float> max,
    bool minInclusive,
    bool maxInclusive
)
public:
static NumericRangeQuery<float>^ NewFloatRange(
    String^ field,
    Nullable<float> min,
    Nullable<float> max,
    bool minInclusive,
    bool maxInclusive
)
Parameters
field
Type:   Online System String
min
Type:   Online System Nullable    Online Single
max
Type:   Online System Nullable    Online Single
minInclusive
Type:   Online System Boolean
maxInclusive
Type:   Online System Boolean
See Also
NumericRangeQuery Class
NumericRangeQuery Members
NewFloatRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewFloatRange Method (String, Int32, Nullable(Single), Nullable(Single), Boolean, Boolean)

NumericRangeQuery NewFloatRange Method (String, Int32, Nullable Single , Nullable Single , Boolean, Boolean) Lucene.Net Class Library
Factory that creates a NumericRangeQuery, that queries a float range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NumericRangeQuery<float> NewFloatRange(
    string field,
    int precisionStep,
    Nullable<float> min,
    Nullable<float> max,
    bool minInclusive,
    bool maxInclusive
)
public static NumericRangeQuery<float> NewFloatRange(
    string field,
    int precisionStep,
    Nullable<float> min,
    Nullable<float> max,
    bool minInclusive,
    bool maxInclusive
)
Public Shared Function NewFloatRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Nullable(Of Single), _
    max As Nullable(Of Single), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery(Of Single)
Public Shared Function NewFloatRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Nullable(Of Single), _
    max As Nullable(Of Single), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery(Of Single)
public:
static NumericRangeQuery<float>^ NewFloatRange(
    String^ field,
    int precisionStep,
    Nullable<float> min,
    Nullable<float> max,
    bool minInclusive,
    bool maxInclusive
)
public:
static NumericRangeQuery<float>^ NewFloatRange(
    String^ field,
    int precisionStep,
    Nullable<float> min,
    Nullable<float> max,
    bool minInclusive,
    bool maxInclusive
)
Parameters
field
Type:   Online System String
precisionStep
Type:   Online System Int32
min
Type:   Online System Nullable    Online Single
max
Type:   Online System Nullable    Online Single
minInclusive
Type:   Online System Boolean
maxInclusive
Type:   Online System Boolean
See Also
NumericRangeQuery Class
NumericRangeQuery Members
NewFloatRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewIntRange Method

NumericRangeQuery NewIntRange Method Lucene.Net Class Library
Overload List
Name | Description
NewIntRange(String, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a int range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, Int32, Nullable Int32 , Nullable Int32 , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a int range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
Back to Top
See Also
NumericRangeQuery Class
NumericRangeQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewIntRange Method (String, Nullable(Int32), Nullable(Int32), Boolean, Boolean)

NumericRangeQuery NewIntRange Method (String, Nullable Int32 , Nullable Int32 , Boolean, Boolean) Lucene.Net Class Library
Factory that creates a NumericRangeQuery, that queries a int range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NumericRangeQuery<int> NewIntRange(
    string field,
    Nullable<int> min,
    Nullable<int> max,
    bool minInclusive,
    bool maxInclusive
)
public static NumericRangeQuery<int> NewIntRange(
    string field,
    Nullable<int> min,
    Nullable<int> max,
    bool minInclusive,
    bool maxInclusive
)
Public Shared Function NewIntRange ( _
    field As String, _
    min As Nullable(Of Integer), _
    max As Nullable(Of Integer), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery(Of Integer)
Public Shared Function NewIntRange ( _
    field As String, _
    min As Nullable(Of Integer), _
    max As Nullable(Of Integer), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery(Of Integer)
public:
static NumericRangeQuery<int>^ NewIntRange(
    String^ field,
    Nullable<int> min,
    Nullable<int> max,
    bool minInclusive,
    bool maxInclusive
)
public:
static NumericRangeQuery<int>^ NewIntRange(
    String^ field,
    Nullable<int> min,
    Nullable<int> max,
    bool minInclusive,
    bool maxInclusive
)
Parameters
field
Type:   Online System String
min
Type:   Online System Nullable    Online Int32
max
Type:   Online System Nullable    Online Int32
minInclusive
Type:   Online System Boolean
maxInclusive
Type:   Online System Boolean
See Also
NumericRangeQuery Class
NumericRangeQuery Members
NewIntRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewIntRange Method (String, Int32, Nullable(Int32), Nullable(Int32), Boolean, Boolean)

NumericRangeQuery NewIntRange Method (String, Int32, Nullable Int32 , Nullable Int32 , Boolean, Boolean) Lucene.Net Class Library
Factory that creates a NumericRangeQuery, that queries a int range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NumericRangeQuery<int> NewIntRange(
    string field,
    int precisionStep,
    Nullable<int> min,
    Nullable<int> max,
    bool minInclusive,
    bool maxInclusive
)
public static NumericRangeQuery<int> NewIntRange(
    string field,
    int precisionStep,
    Nullable<int> min,
    Nullable<int> max,
    bool minInclusive,
    bool maxInclusive
)
Public Shared Function NewIntRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Nullable(Of Integer), _
    max As Nullable(Of Integer), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery(Of Integer)
Public Shared Function NewIntRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Nullable(Of Integer), _
    max As Nullable(Of Integer), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery(Of Integer)
public:
static NumericRangeQuery<int>^ NewIntRange(
    String^ field,
    int precisionStep,
    Nullable<int> min,
    Nullable<int> max,
    bool minInclusive,
    bool maxInclusive
)
public:
static NumericRangeQuery<int>^ NewIntRange(
    String^ field,
    int precisionStep,
    Nullable<int> min,
    Nullable<int> max,
    bool minInclusive,
    bool maxInclusive
)
Parameters
field
Type:   Online System String
precisionStep
Type:   Online System Int32
min
Type:   Online System Nullable    Online Int32
max
Type:   Online System Nullable    Online Int32
minInclusive
Type:   Online System Boolean
maxInclusive
Type:   Online System Boolean
See Also
NumericRangeQuery Class
NumericRangeQuery Members
NewIntRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewLongRange Method

NumericRangeQuery NewLongRange Method Lucene.Net Class Library
Overload List
Name | Description
NewLongRange(String, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a long range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, Int32, Nullable Int64 , Nullable Int64 , Boolean, Boolean) | Factory that creates a NumericRangeQuery, that queries a long range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
Back to Top
See Also
NumericRangeQuery Class
NumericRangeQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewLongRange Method (String, Nullable(Int64), Nullable(Int64), Boolean, Boolean)

NumericRangeQuery NewLongRange Method (String, Nullable Int64 , Nullable Int64 , Boolean, Boolean) Lucene.Net Class Library
Factory that creates a NumericRangeQuery, that queries a long range using the default precisionStep PRECISION_STEP_DEFAULT (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NumericRangeQuery<long> NewLongRange(
    string field,
    Nullable<long> min,
    Nullable<long> max,
    bool minInclusive,
    bool maxInclusive
)
public static NumericRangeQuery<long> NewLongRange(
    string field,
    Nullable<long> min,
    Nullable<long> max,
    bool minInclusive,
    bool maxInclusive
)
Public Shared Function NewLongRange ( _
    field As String, _
    min As Nullable(Of Long), _
    max As Nullable(Of Long), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery(Of Long)
Public Shared Function NewLongRange ( _
    field As String, _
    min As Nullable(Of Long), _
    max As Nullable(Of Long), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery(Of Long)
public:
static NumericRangeQuery<long long>^ NewLongRange(
    String^ field,
    Nullable<long long> min,
    Nullable<long long> max,
    bool minInclusive,
    bool maxInclusive
)
public:
static NumericRangeQuery<long long>^ NewLongRange(
    String^ field,
    Nullable<long long> min,
    Nullable<long long> max,
    bool minInclusive,
    bool maxInclusive
)
Parameters
field
Type:   Online System String
min
Type:   Online System Nullable    Online Int64
max
Type:   Online System Nullable    Online Int64
minInclusive
Type:   Online System Boolean
maxInclusive
Type:   Online System Boolean
See Also
NumericRangeQuery Class
NumericRangeQuery Members
NewLongRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewLongRange Method (String, Int32, Nullable(Int64), Nullable(Int64), Boolean, Boolean)

NumericRangeQuery NewLongRange Method (String, Int32, Nullable Int64 , Nullable Int64 , Boolean, Boolean) Lucene.Net Class Library
Factory that creates a NumericRangeQuery, that queries a long range using the given precisionStep. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to null. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NumericRangeQuery<long> NewLongRange(
    string field,
    int precisionStep,
    Nullable<long> min,
    Nullable<long> max,
    bool minInclusive,
    bool maxInclusive
)
public static NumericRangeQuery<long> NewLongRange(
    string field,
    int precisionStep,
    Nullable<long> min,
    Nullable<long> max,
    bool minInclusive,
    bool maxInclusive
)
Public Shared Function NewLongRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Nullable(Of Long), _
    max As Nullable(Of Long), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery(Of Long)
Public Shared Function NewLongRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Nullable(Of Long), _
    max As Nullable(Of Long), _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery(Of Long)
public:
static NumericRangeQuery<long long>^ NewLongRange(
    String^ field,
    int precisionStep,
    Nullable<long long> min,
    Nullable<long long> max,
    bool minInclusive,
    bool maxInclusive
)
public:
static NumericRangeQuery<long long>^ NewLongRange(
    String^ field,
    int precisionStep,
    Nullable<long long> min,
    Nullable<long long> max,
    bool minInclusive,
    bool maxInclusive
)
Parameters
field
Type:   Online System String
precisionStep
Type:   Online System Int32
min
Type:   Online System Nullable    Online Int64
max
Type:   Online System Nullable    Online Int64
minInclusive
Type:   Online System Boolean
maxInclusive
Type:   Online System Boolean
See Also
NumericRangeQuery Class
NumericRangeQuery Members
NewLongRange Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericRangeQuery(T) Class

NumericRangeQuery T Class Lucene.Net Class Library

A Query that matches numeric values within a specified range. To use this, you must first index the numeric values using NumericField (expert: NumericTokenStream ). If your terms are instead textual, you should use TermRangeQuery. NumericRangeFilter T is the filter equivalent of this query.

You create a new NumericRangeQuery with the static factory methods, eg:
View Colorized Copy to Clipboard Print
Query q = NumericRangeQuery.newFloatRange("weight",
new Float(0.3f), new Float(0.10f),
true, true);
Query q = NumericRangeQuery.newFloatRange("weight",
new Float(0.3f), new Float(0.10f),
true, true);
matches all documents whose float valued "weight" field ranges from 0.3 to 0.10, inclusive.

The performance of NumericRangeQuery is much better than the corresponding TermRangeQuery because the number of terms that must be searched is usually far fewer, thanks to trie indexing, described below.

You can optionally specify a precisionStep when creating this query. This is necessary if you've changed this configuration from its default (4) during indexing. Lower values consume more disk space but speed up searching. Suitable values are between 1 and 8. A good starting point to test is 4, which is the default value for all Numeric* classes. See below for details.

This query defaults to CONSTANT_SCORE_AUTO_REWRITE_DEFAULT for 32 bit (int/float) ranges with precisionStep <8 and 64 bit (long/double) ranges with precisionStep <6. Otherwise it uses CONSTANT_SCORE_FILTER_REWRITE as the number of terms is likely to be high. With precision steps of <4, this query can be run with one of the BooleanQuery rewrite methods without changing BooleanQuery's default max clause count.

NOTE: This API is experimental and might change in incompatible ways in the next release.

How it works

See the publication about Online panFMP, where this algorithm was described (referred to as TrieRangeQuery):
Schindler, U, Diepenbroek, M, 2008. Generic XML-based Framework for Metadata Portals. Computers & Geosciences 34 (12), 1947-1955. Online doi:10.1016/j.cageo.2008.02.023

A quote from this paper: Because Apache Lucene is a full-text search engine and not a conventional database, it cannot handle numerical ranges (e.g., field value is inside user defined bounds, even dates are numerical values). We have developed an extension to Apache Lucene that stores the numerical values in a special string-encoded format with variable precision (all numerical values like doubles, longs, floats, and ints are converted to lexicographic sortable string representations and stored with different precisions (for a more detailed description of how the values are stored, see NumericUtils). A range is then divided recursively into multiple intervals for searching: The center of the range is searched only with the lowest possible precision in the trie, while the boundaries are matched more exactly. This reduces the number of terms dramatically.

For the variant that stores long values in 8 different precisions (each reduced by 8 bits) that uses a lowest precision of 1 byte, the index contains only a maximum of 256 distinct values in the lowest precision. Overall, a range could consist of a theoretical maximum of 7*255*2 + 255 = 3825 distinct terms (when there is a term for every distinct value of an 8-byte-number in the index and the range covers almost all of them; a maximum of 255 distinct values is used because it would always be possible to reduce the full 256 values to one term with degraded precision). In practice, we have seen up to 300 terms in most cases (index with 500,000 metadata records and a uniform value distribution).

Precision Step

You can choose any precisionStep when encoding values. Lower step values mean more precisions and so more terms in index (and index gets larger). On the other hand, the maximum number of terms to match reduces, which optimized query speed. The formula to calculate the maximum term count is:
View Colorized Copy to Clipboard Print
n = [ (bitsPerValue/precisionStep - 1) * (2^precisionStep - 1 ) * 2 ] + (2^precisionStep - 1 )
n = [ (bitsPerValue/precisionStep - 1) * (2^precisionStep - 1 ) * 2 ] + (2^precisionStep - 1 )

(this formula is only correct, when bitsPerValue/precisionStep is an integer; in other cases, the value must be rounded up and the last summand must contain the modulo of the division as precision step). For longs stored using a precision step of 4, n = 15*15*2 + 15 = 465, and for a precision step of 2, n = 31*3*2 + 3 = 189. But the faster search speed is reduced by more seeking in the term enum of the index. Because of this, the ideal precisionStep value can only be found out by testing. Important: You can index with a lower precision step value and test search speed using a multiple of the original step value.

Good values for precisionStep are depending on usage and data type:
  • The default for all data types is 4, which is used, when no precisionStep is given.
  • Ideal value in most cases for 64 bit data types (long, double) is 6 or 8.
  • Ideal value in most cases for 32 bit data types (int, float) is 4.
  • Steps >64 for long/double and >32 for int/float produces one token per value in the index and querying is as slow as a conventional TermRangeQuery. But it can be used to produce fields, that are solely used for sorting (in this case simply use Online MaxValue as precisionStep). Using NumericFields for sorting is ideal, because building the field cache is much faster than with text-only numbers. Sorting is also possible with range query optimized fields using one of the above precisionSteps.

Comparisons of the different types of RangeQueries on an index with about 500,000 docs showed that TermRangeQuery in boolean rewrite mode (with raised BooleanQuery clause count) took about 30-40 secs to complete, TermRangeQuery in constant score filter rewrite mode took 5 secs and executing this class took <100ms to complete (on an Opteron64 machine, Java 1.5, 8 bit precision step). This query type was developed for a geographic portal, where the performance for e.g. bounding boxes or exact date/time stamps is important.

Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search MultiTermQuery
Lucene.Net.Search NumericRangeQuery T

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class NumericRangeQuery<T> : MultiTermQuery
where T : struct, new(), IComparable<T>
[SerializableAttribute]
public sealed class NumericRangeQuery<T> : MultiTermQuery
where T : struct, new(), IComparable<T>
<SerializableAttribute> _
Public NotInheritable Class NumericRangeQuery(Of T As {Structure, New, IComparable(Of T)}) _
    Inherits MultiTermQuery
<SerializableAttribute> _
Public NotInheritable Class NumericRangeQuery(Of T As {Structure, New, IComparable(Of T)}) _
    Inherits MultiTermQuery
[SerializableAttribute]
generic<typename T>
where T : value class, gcnew(), IComparable<T>
public ref class NumericRangeQuery sealed : public MultiTermQuery
[SerializableAttribute]
generic<typename T>
where T : value class, gcnew(), IComparable<T>
public ref class NumericRangeQuery sealed : public MultiTermQuery
Type Parameters
T
See Also
NumericRangeQuery T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericRangeQuery(T) Members

NumericRangeQuery T Members Lucene.Net Class Library

The NumericRangeQuery T type exposes the following members.
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the query/filter. (Inherited from MultiTermQuery.)
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | Expert: Constructs an appropriate Weight implementation for this query. Only implemented by primitive queries, which re-write to themselves. (Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery Equals(Object).)
Public method | ExtractTerms | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its rewritten form. (Inherited from Query.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetEnum | (Overrides MultiTermQuery GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Inherited from MultiTermQuery.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Fields
 | Name | Description
Protected field | internalRewriteMethod | (Inherited from MultiTermQuery.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Field | Returns the field name for this query
Public property | IncludesMax | Returns true if the upper endpoint is inclusive
Public property | IncludesMin | Returns true if the lower endpoint is inclusive
Public property | Max | Returns the upper value of this range query
Public property | Min | Returns the lower value of this range query
Public property | RewriteMethod | Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of RewriteMethod. (Inherited from MultiTermQuery.)
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers. (Inherited from MultiTermQuery.)
Back to Top
See Also
NumericRangeQuery T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericRangeQuery(T) Fields

NumericRangeQuery T Fields Lucene.Net Class Library
The NumericRangeQuery T type exposes the following members.
Fields
 | Name | Description
Protected field | internalRewriteMethod | (Inherited from MultiTermQuery.)
Back to Top
See Also
NumericRangeQuery T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericRangeQuery(T) Methods

NumericRangeQuery T Methods Lucene.Net Class Library
The NumericRangeQuery T type exposes the following members.
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the query/filter. (Inherited from MultiTermQuery.)
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | Expert: Constructs an appropriate Weight implementation for this query. Only implemented by primitive queries, which re-write to themselves. (Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery Equals(Object).)
Public method | ExtractTerms | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its rewritten form. (Inherited from Query.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetEnum | (Overrides MultiTermQuery GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Inherited from MultiTermQuery.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
NumericRangeQuery T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

NumericRangeQuery T Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
NumericRangeQuery T  Class
NumericRangeQuery T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetEnum Method

NumericRangeQuery T GetEnum Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override FilteredTermEnum GetEnum(
    IndexReader reader
)
protected override FilteredTermEnum GetEnum(
    IndexReader reader
)
Protected Overrides Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
Protected Overrides Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
protected:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) override
protected:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
NumericRangeQuery T  Class
NumericRangeQuery T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

NumericRangeQuery T GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
NumericRangeQuery T  Class
NumericRangeQuery T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

NumericRangeQuery T ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Back to Top
See Also
NumericRangeQuery T Class
NumericRangeQuery T Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

NumericRangeQuery T ToString Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
NumericRangeQuery T  Class
NumericRangeQuery T  Members
ToString Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericRangeQuery(T) Properties

NumericRangeQuery T Properties Lucene.Net Class Library
The NumericRangeQuery T type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Field | Returns the field name for this query
Public property | IncludesMax | Returns true if the upper endpoint is inclusive
Public property | IncludesMin | Returns true if the lower endpoint is inclusive
Public property | Max | Returns the upper value of this range query
Public property | Min | Returns the lower value of this range query
Public property | RewriteMethod | Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of RewriteMethod. (Inherited from MultiTermQuery.)
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers. (Inherited from MultiTermQuery.)
Back to Top
See Also
NumericRangeQuery T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

NumericRangeQuery T Field Property Lucene.Net Class Library
Returns the field name for this query

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Field { get; }
public string Field { get; }
Public ReadOnly Property Field As String
    Get
Public ReadOnly Property Field As String
    Get
public:
property String^ Field {
    String^ get ();
}
public:
property String^ Field {
    String^ get ();
}
See Also
NumericRangeQuery T  Class
NumericRangeQuery T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncludesMax Property

NumericRangeQuery T IncludesMax Property Lucene.Net Class Library
Returns true if the upper endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IncludesMax { get; }
public bool IncludesMax { get; }
Public ReadOnly Property IncludesMax As Boolean
    Get
Public ReadOnly Property IncludesMax As Boolean
    Get
public:
property bool IncludesMax {
    bool get ();
}
public:
property bool IncludesMax {
    bool get ();
}
See Also
NumericRangeQuery T  Class
NumericRangeQuery T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncludesMin Property

NumericRangeQuery T IncludesMin Property Lucene.Net Class Library
Returns true if the lower endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IncludesMin { get; }
public bool IncludesMin { get; }
Public ReadOnly Property IncludesMin As Boolean
    Get
Public ReadOnly Property IncludesMin As Boolean
    Get
public:
property bool IncludesMin {
    bool get ();
}
public:
property bool IncludesMin {
    bool get ();
}
See Also
NumericRangeQuery T  Class
NumericRangeQuery T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Max Property

NumericRangeQuery T Max Property Lucene.Net Class Library
Returns the upper value of this range query

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<T> Max { get; }
public Nullable<T> Max { get; }
Public ReadOnly Property Max As Nullable(Of T)
    Get
Public ReadOnly Property Max As Nullable(Of T)
    Get
public:
property Nullable<T> Max {
    Nullable<T> get ();
}
public:
property Nullable<T> Max {
    Nullable<T> get ();
}
See Also
NumericRangeQuery T  Class
NumericRangeQuery T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Min Property

NumericRangeQuery T Min Property Lucene.Net Class Library
Returns the lower value of this range query

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<T> Min { get; }
public Nullable<T> Min { get; }
Public ReadOnly Property Min As Nullable(Of T)
    Get
Public ReadOnly Property Min As Nullable(Of T)
    Get
public:
property Nullable<T> Min {
    Nullable<T> get ();
}
public:
property Nullable<T> Min {
    Nullable<T> get ();
}
See Also
NumericRangeQuery T  Class
NumericRangeQuery T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Occur Enumeration

Occur Enumeration Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Occur
public enum Occur
Public Enumeration Occur
Public Enumeration Occur
public enum class Occur
public enum class Occur
Members
Member name | Value | Description
MUST | 0 |
SHOULD | 1 |
MUST_NOT | 2 |
See Also
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OccurExtensions Class

OccurExtensions Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search OccurExtensions

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class OccurExtensions
public static class OccurExtensions
<ExtensionAttribute> _
Public NotInheritable Class OccurExtensions
<ExtensionAttribute> _
Public NotInheritable Class OccurExtensions
[ExtensionAttribute]
public ref class OccurExtensions abstract sealed
[ExtensionAttribute]
public ref class OccurExtensions abstract sealed
See Also
OccurExtensions Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OccurExtensions Members

OccurExtensions Members Lucene.Net Class Library

The OccurExtensions type exposes the following members.
Methods
Name | Description
ToString |
Back to Top
See Also
OccurExtensions Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OccurExtensions Methods

OccurExtensions Methods Lucene.Net Class Library
The OccurExtensions type exposes the following members.
Methods
Name | Description
ToString |
Back to Top
See Also
OccurExtensions Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

OccurExtensions ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToString(
    this Occur occur
)
public static string ToString(
    this Occur occur
)
<ExtensionAttribute> _
Public Shared Function ToString ( _
    occur As Occur _
) As String
<ExtensionAttribute> _
Public Shared Function ToString ( _
    occur As Occur _
) As String
public:
[ExtensionAttribute]
static String^ ToString(
    Occur occur
)
public:
[ExtensionAttribute]
static String^ ToString(
    Occur occur
)
Parameters
occur
Type: Lucene.Net.Search Occur
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type Occur. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
OccurExtensions Class
OccurExtensions Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParallelMultiSearcher Class

ParallelMultiSearcher Class Lucene.Net Class Library
Implements parallel search over a set of Searchables.

Applications usually need only call the inherited Search(Query, Int32) or Search(Query, Filter, Int32) methods.
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Lucene.Net.Search Searcher
Lucene.Net.Search MultiSearcher
Lucene.Net.Search ParallelMultiSearcher

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ParallelMultiSearcher : MultiSearcher
public class ParallelMultiSearcher : MultiSearcher
Public Class ParallelMultiSearcher _
    Inherits MultiSearcher
Public Class ParallelMultiSearcher _
    Inherits MultiSearcher
public ref class ParallelMultiSearcher : public MultiSearcher
public ref class ParallelMultiSearcher : public MultiSearcher
See Also
ParallelMultiSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParallelMultiSearcher Members

ParallelMultiSearcher Members Lucene.Net Class Library

The ParallelMultiSearcher type exposes the following members.
Constructors
 | Name | Description
Public method | ParallelMultiSearcher | Creates a Searchable which searches searchables.
Back to Top
Methods
Name | Description
Public method | Close | Obsolete. (Inherited from Searcher.)
Public method Online CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from Online MarshalByRefObject.)
Public method CreateWeight
Create weight in multiple index scenario. Distributed query processing is done in the following steps: 1. rewrite query 2. extract necessary terms 3. collect dfs for these terms from the Searchables 4. create query weight using aggregate dfs. 5. distribute that weight to Searchables 6. merge results Steps 1-4 are done here, 5+6 in the search() methods
(Inherited from MultiSearcher.)
Public method | Dispose | (Inherited from Searcher.)
Protected method | Dispose(Boolean) | (Inherited from MultiSearcher.)
Public method | Doc(Int32) | (Inherited from MultiSearcher.)
Public method | Doc(Int32, FieldSelector) | (Inherited from MultiSearcher.)
Public method DocFreq
Executes each Searchable's docFreq() in its own thread and waits for each search to complete and merge the results back together.
(Overrides MultiSearcher DocFreq(Term).)
Public method | DocFreqs | (Inherited from Searcher.)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Public method Explain(Query, Int32)
Returns an Explanation that describes how doc scored against query.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.
(Inherited from Searcher.)
Public method | Explain(Weight, Int32) | (Inherited from MultiSearcher.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from Online MarshalByRefObject.)
Public method GetSearchables
Return the array of Searchables this searches.
(Inherited from MultiSearcher.)
Protected method | GetStarts | (Inherited from MultiSearcher.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method Online InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from Online MarshalByRefObject.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Protected method Online MemberwiseClone(Boolean)
Creates a shallow copy of the current Online MarshalByRefObject object.
(Inherited from Online MarshalByRefObject.)
Public method | Rewrite | (Inherited from MultiSearcher.)
Public method Search(Query, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32) ) is usually more efficient, as it skips non-high-scoring hits.

Note: The score passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top n hits for query.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Filter, Int32)) is usually more efficient, as it skips non-high-scoring hits.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top n hits for query, applying filter if non-null.
(Inherited from Searcher.)
Public method Search(Weight, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32)) is usually more efficient, as it skips non-high-scoring hits.

This method cannot be parallelized, because Collector supports no concurrent access.
(Overrides MultiSearcher Search(Weight, Filter, Collector).)
Public method Search(Weight, Filter, Int32)
A search implementation which executes each Searchable in its own thread and waits for each search to complete and merge the results back together.
(Overrides MultiSearcher Search(Weight, Filter, Int32).)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top n hits for query, applying filter if non-null, and sorting the hits by the criteria in sort.

NOTE: this does not compute scores by default; use SetDefaultFieldSortScoring(Boolean, Boolean) to enable scoring.
(Inherited from Searcher.)
Public method Search(Weight, Filter, Int32, Sort)
A search implementation allowing sorting which spans a new thread for each Searchable, waits for each search to complete and merges the results back together.
(Overrides MultiSearcher Search(Weight, Filter, Int32, Sort).)
Public method SubDoc
Returns the document number of document n within its sub-index.
(Inherited from MultiSearcher.)
Public method SubSearcher
Returns index of the searcher for document n in the array used to construct this searcher.
(Inherited from MultiSearcher.)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | MaxDoc | (Inherited from MultiSearcher.)
Public property | Similarity | Expert: Gets or Sets the Similarity implementation used by this Searcher. (Inherited from Searcher.)
Back to Top
See Also
ParallelMultiSearcher Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParallelMultiSearcher Constructor

ParallelMultiSearcher Constructor Lucene.Net Class Library
Creates a Searchable which searches searchables.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ParallelMultiSearcher(
    params Searchable[] searchables
)
public ParallelMultiSearcher(
    params Searchable[] searchables
)
Public Sub New ( _
    ParamArray searchables As Searchable() _
)
Public Sub New ( _
    ParamArray searchables As Searchable() _
)
public:
ParallelMultiSearcher(
    ... array<Searchable^>^ searchables
)
public:
ParallelMultiSearcher(
    ... array<Searchable^>^ searchables
)
Parameters
searchables
Type:  Lucene.Net.Search Searchable
See Also
ParallelMultiSearcher Class
ParallelMultiSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParallelMultiSearcher Methods

ParallelMultiSearcher Methods Lucene.Net Class Library
The ParallelMultiSearcher type exposes the following members.
Methods
Name | Description
Public method | Close | Obsolete. (Inherited from Searcher.)
Public method Online CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from Online MarshalByRefObject.)
Public method CreateWeight
Create weight in multiple index scenario. Distributed query processing is done in the following steps: 1. rewrite query 2. extract necessary terms 3. collect dfs for these terms from the Searchables 4. create query weight using aggregate dfs. 5. distribute that weight to Searchables 6. merge results Steps 1-4 are done here, 5+6 in the search() methods
(Inherited from MultiSearcher.)
Public method | Dispose | (Inherited from Searcher.)
Protected method | Dispose(Boolean) | (Inherited from MultiSearcher.)
Public method | Doc(Int32) | (Inherited from MultiSearcher.)
Public method | Doc(Int32, FieldSelector) | (Inherited from MultiSearcher.)
Public method DocFreq
Executes each Searchable's docFreq() in its own thread and waits for each search to complete and merge the results back together.
(Overrides MultiSearcher DocFreq(Term).)
Public method | DocFreqs | (Inherited from Searcher.)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Public method Explain(Query, Int32)
Returns an Explanation that describes how doc scored against query.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.
(Inherited from Searcher.)
Public method | Explain(Weight, Int32) | (Inherited from MultiSearcher.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from Online MarshalByRefObject.)
Public method GetSearchables
Return the array of Searchables this searches.
(Inherited from MultiSearcher.)
Protected method | GetStarts | (Inherited from MultiSearcher.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method Online InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from Online MarshalByRefObject.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Protected method Online MemberwiseClone(Boolean)
Creates a shallow copy of the current Online MarshalByRefObject object.
(Inherited from Online MarshalByRefObject.)
Public method | Rewrite | (Inherited from MultiSearcher.)
Public method Search(Query, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32) ) is usually more efficient, as it skips non-high-scoring hits.

Note: The score passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top n hits for query.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Filter, Int32)) is usually more efficient, as it skips non-high-scoring hits.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top n hits for query, applying filter if non-null.
(Inherited from Searcher.)
Public method Search(Weight, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32)) is usually more efficient, as it skips non-high-scoring hits.

This method cannot be parallelized, because Collector supports no concurrent access.
(Overrides MultiSearcher Search(Weight, Filter, Collector).)
Public method Search(Weight, Filter, Int32)
A search implementation which executes each Searchable in its own thread and waits for each search to complete and merge the results back together.
(Overrides MultiSearcher Search(Weight, Filter, Int32).)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top n hits for query, applying filter if non-null, and sorting the hits by the criteria in sort.

NOTE: this does not compute scores by default; use SetDefaultFieldSortScoring(Boolean, Boolean) to enable scoring.
(Inherited from Searcher.)
Public method Search(Weight, Filter, Int32, Sort)
A search implementation allowing sorting which spans a new thread for each Searchable, waits for each search to complete and merges the results back together.
(Overrides MultiSearcher Search(Weight, Filter, Int32, Sort).)
Public method SubDoc
Returns the document number of document n within its sub-index.
(Inherited from MultiSearcher.)
Public method SubSearcher
Returns index of the searcher for document n in the array used to construct this searcher.
(Inherited from MultiSearcher.)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
See Also
ParallelMultiSearcher Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocFreq Method

ParallelMultiSearcher DocFreq Method Lucene.Net Class Library
Executes each Searchable's docFreq() in its own thread and waits for each search to complete and merge the results back together.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocFreq(
    Term term
)
public override int DocFreq(
    Term term
)
Public Overrides Function DocFreq ( _
    term As Term _
) As Integer
Public Overrides Function DocFreq ( _
    term As Term _
) As Integer
public:
virtual int DocFreq(
    Term^ term
) override
public:
virtual int DocFreq(
    Term^ term
) override
Parameters
term
Type: Lucene.Net.Index Term
Implements
Searchable DocFreq(Term)
See Also
ParallelMultiSearcher Class
ParallelMultiSearcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method

ParallelMultiSearcher Search Method Lucene.Net Class Library
Overload List
Name Description
Public method Search(Query, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32) ) is usually more efficient, as it skips non-high-scoring hits.

Note: The score passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top n hits for query.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Filter, Int32)) is usually more efficient, as it skips non-high-scoring hits.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top n hits for query, applying filter if non-null.
(Inherited from Searcher.)
Public method Search(Weight, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32)) is usually more efficient, as it skips non-high-scoring hits.

This method cannot be parallelized, because Collector supports no concurrent access.
(Overrides MultiSearcher Search(Weight, Filter, Collector).)
Public method Search(Weight, Filter, Int32)
A search implementation which executes each Searchable in its own thread and waits for each search to complete and merge the results back together.
(Overrides MultiSearcher Search(Weight, Filter, Int32).)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top n hits for query, applying filter if non-null, and sorting the hits by the criteria in sort.

NOTE: this does not compute scores by default; use SetDefaultFieldSortScoring(Boolean, Boolean) to enable scoring.
(Inherited from Searcher.)
Public method Search(Weight, Filter, Int32, Sort)
A search implementation allowing sorting which spans a new thread for each Searchable, waits for each search to complete and merges the results back together.
(Overrides MultiSearcher Search(Weight, Filter, Int32, Sort).)
Back to Top
See Also
ParallelMultiSearcher Class
ParallelMultiSearcher Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Weight, Filter, Collector)

ParallelMultiSearcher Search Method (Weight, Filter, Collector) Lucene.Net Class Library
Lower-level search API.

Collect(Int32) is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32)) is usually more efficient, as it skips non-high-scoring hits.

This method cannot be parallelized, because Collector supports no concurrent access.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Search(
    Weight weight,
    Filter filter,
    Collector collector
)
public override void Search(
    Weight weight,
    Filter filter,
    Collector collector
)
Public Overrides Sub Search ( _
    weight As Weight, _
    filter As Filter, _
    collector As Collector _
)
Public Overrides Sub Search ( _
    weight As Weight, _
    filter As Filter, _
    collector As Collector _
)
public:
virtual void Search(
    Weight^ weight,
    Filter^ filter,
    Collector^ collector
) override
public:
virtual void Search(
    Weight^ weight,
    Filter^ filter,
    Collector^ collector
) override
Parameters
weight
Type: Lucene.Net.Search Weight
to match documents

filter
Type: Lucene.Net.Search Filter
if non-null, a bitset used to eliminate some documents

collector
Type: Lucene.Net.Search Collector
to receive hits

            TODO: parallelize this one too

Implements
Searchable Search(Weight, Filter, Collector)
See Also
ParallelMultiSearcher Class
ParallelMultiSearcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Weight, Filter, Int32)

ParallelMultiSearcher Search Method (Weight, Filter, Int32) Lucene.Net Class Library
A search implementation which executes each Searchable in its own thread and waits for each search to complete and merge the results back together.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TopDocs Search(
    Weight weight,
    Filter filter,
    int nDocs
)
public override TopDocs Search(
    Weight weight,
    Filter filter,
    int nDocs
)
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer _
) As TopDocs
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer _
) As TopDocs
public:
virtual TopDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs
) override
public:
virtual TopDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs
) override
Parameters
weight
Type: Lucene.Net.Search Weight
filter
Type: Lucene.Net.Search Filter
nDocs
Type:   Online System Int32
Implements
Searchable Search(Weight, Filter, Int32)
See Also
ParallelMultiSearcher Class
ParallelMultiSearcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Weight, Filter, Int32, Sort)

ParallelMultiSearcher Search Method (Weight, Filter, Int32, Sort) Lucene.Net Class Library
A search implementation allowing sorting which spans a new thread for each Searchable, waits for each search to complete and merges the results back together.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int nDocs,
    Sort sort
)
public override TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int nDocs,
    Sort sort
)
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer, _
    sort As Sort _
) As TopFieldDocs
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer, _
    sort As Sort _
) As TopFieldDocs
public:
virtual TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs,
    Sort^ sort
) override
public:
virtual TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs,
    Sort^ sort
) override
Parameters
weight
Type: Lucene.Net.Search Weight
filter
Type: Lucene.Net.Search Filter
nDocs
Type:   Online System Int32
sort
Type: Lucene.Net.Search Sort
Implements
Searchable Search(Weight, Filter, Int32, Sort)
See Also
ParallelMultiSearcher Class
ParallelMultiSearcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParallelMultiSearcher Properties

ParallelMultiSearcher Properties Lucene.Net Class Library
The ParallelMultiSearcher type exposes the following members.
Properties
 | Name | Description
Public property | MaxDoc | (Inherited from MultiSearcher.)
Public property | Similarity | Expert: Gets or Sets the Similarity implementation used by this Searcher. (Inherited from Searcher.)
Back to Top
See Also
ParallelMultiSearcher Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Parser Interface

Parser Interface Lucene.Net Class Library
Marker interface as super-interface to all parsers. It is used to specify a custom parser to SortField(String, Parser).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface Parser
public interface Parser
Public Interface Parser
Public Interface Parser
public interface class Parser
public interface class Parser
See Also
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PhraseQuery Class

PhraseQuery Class Lucene.Net Class Library
A Query that matches documents containing a particular sequence of terms. A PhraseQuery is built by QueryParser for input like "new york".

This query may be combined with other terms or queries with a BooleanQuery.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search PhraseQuery

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PhraseQuery : Query
[SerializableAttribute]
public class PhraseQuery : Query
<SerializableAttribute> _
Public Class PhraseQuery _
    Inherits Query
<SerializableAttribute> _
Public Class PhraseQuery _
    Inherits Query
[SerializableAttribute]
public ref class PhraseQuery : public Query
[SerializableAttribute]
public ref class PhraseQuery : public Query
See Also
PhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PhraseQuery Members

PhraseQuery Members Lucene.Net Class Library

The PhraseQuery type exposes the following members.
Constructors
 | Name | Description
Public method | PhraseQuery | Constructs an empty phrase query.
Back to Top
Methods
 | Name | Description
Public method | Add(Term) | Adds a term to the end of the query phrase. The relative position of the term is the one immediately after the last term added.
Public method | Add(Term, Int32) | Adds a term to the end of the query phrase. The relative position of the term within the phrase is specified explicitly. This allows e.g. phrases with more than one term at the same position or phrases with gaps (e.g. in connection with stopwords).
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | Returns true iff o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Query GetHashCode .)
Public method | GetPositions | Returns the relative positions of terms in this phrase.
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetTerms | Returns the set of terms in this phrase.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys. (Inherited from Query.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Slop | Sets the number of other words permitted between words in query phrase. If zero, then this is an exact phrase search. For larger values this works like a WITHIN or NEAR operator. The slop is in fact an edit-distance, where the units correspond to moves of terms in the query phrase out of position. For example, to switch the order of two words requires two moves (the first move places the words atop one another), so to permit re-orderings of phrases, the slop must be at least two. More exact matches are scored higher than sloppier matches, thus search results are sorted by exactness. The slop is zero by default, requiring exact matches.
Back to Top
See Also
PhraseQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PhraseQuery Constructor

PhraseQuery Constructor Lucene.Net Class Library
Constructs an empty phrase query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PhraseQuery()
public PhraseQuery()
Public Sub New
Public Sub New
public:
PhraseQuery()
public:
PhraseQuery()
See Also
PhraseQuery Class
PhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PhraseQuery Methods

PhraseQuery Methods Lucene.Net Class Library
The PhraseQuery type exposes the following members.
Methods
 | Name | Description
Public method | Add(Term) | Adds a term to the end of the query phrase. The relative position of the term is the one immediately after the last term added.
Public method | Add(Term, Int32) | Adds a term to the end of the query phrase. The relative position of the term within the phrase is specified explicitly. This allows e.g. phrases with more than one term at the same position or phrases with gaps (e.g. in connection with stopwords).
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | Returns true iff o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Query GetHashCode .)
Public method | GetPositions | Returns the relative positions of terms in this phrase.
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetTerms | Returns the set of terms in this phrase.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys. (Inherited from Query.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
PhraseQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method

PhraseQuery Add Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Add(Term) | Adds a term to the end of the query phrase. The relative position of the term is the one immediately after the last term added.
Public method | Add(Term, Int32) | Adds a term to the end of the query phrase. The relative position of the term within the phrase is specified explicitly. This allows e.g. phrases with more than one term at the same position or phrases with gaps (e.g. in connection with stopwords).
Back to Top
See Also
PhraseQuery Class
PhraseQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (Term)

PhraseQuery Add Method (Term) Lucene.Net Class Library
Adds a term to the end of the query phrase. The relative position of the term is the one immediately after the last term added.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Add(
    Term term
)
public virtual void Add(
    Term term
)
Public Overridable Sub Add ( _
    term As Term _
)
Public Overridable Sub Add ( _
    term As Term _
)
public:
virtual void Add(
    Term^ term
)
public:
virtual void Add(
    Term^ term
)
Parameters
term
Type: Lucene.Net.Index Term
See Also
PhraseQuery Class
PhraseQuery Members
Add Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method (Term, Int32)

PhraseQuery Add Method (Term, Int32) Lucene.Net Class Library
Adds a term to the end of the query phrase. The relative position of the term within the phrase is specified explicitly. This allows e.g. phrases with more than one term at the same position or phrases with gaps (e.g. in connection with stopwords).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Add(
    Term term,
    int position
)
public virtual void Add(
    Term term,
    int position
)
Public Overridable Sub Add ( _
    term As Term, _
    position As Integer _
)
Public Overridable Sub Add ( _
    term As Term, _
    position As Integer _
)
public:
virtual void Add(
    Term^ term,
    int position
)
public:
virtual void Add(
    Term^ term,
    int position
)
Parameters
term
Type: Lucene.Net.Index Term
position
Type:   Online System Int32
See Also
PhraseQuery Class
PhraseQuery Members
Add Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateWeight Method

PhraseQuery CreateWeight Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Weight CreateWeight(
    Searcher searcher
)
public override Weight CreateWeight(
    Searcher searcher
)
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
PhraseQuery Class
PhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

PhraseQuery Equals Method Lucene.Net Class Library
Returns true iff o is equal to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
PhraseQuery Class
PhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExtractTerms Method

PhraseQuery ExtractTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ExtractTerms(
    ISet<Term> queryTerms
)
public override void ExtractTerms(
    ISet<Term> queryTerms
)
Public Overrides Sub ExtractTerms ( _
    queryTerms As ISet(Of Term) _
)
Public Overrides Sub ExtractTerms ( _
    queryTerms As ISet(Of Term) _
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ queryTerms
) override
public:
virtual void ExtractTerms(
    ISet<Term^>^ queryTerms
) override
Parameters
queryTerms
Type:   Online System.Collections.Generic ISet  Term
See Also
PhraseQuery Class
PhraseQuery Members
Lucene.Net.Search Namespace
Query ExtractTerms(ISet Term )
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

PhraseQuery GetHashCode Method Lucene.Net Class Library
Returns a hash code value for this object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
PhraseQuery Class
PhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPositions Method

PhraseQuery GetPositions Method Lucene.Net Class Library
Returns the relative positions of terms in this phrase.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int[] GetPositions()
public virtual int[] GetPositions()
Public Overridable Function GetPositions As Integer()
Public Overridable Function GetPositions As Integer()
public:
virtual array<int>^ GetPositions()
public:
virtual array<int>^ GetPositions()
See Also
PhraseQuery Class
PhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTerms Method

PhraseQuery GetTerms Method Lucene.Net Class Library
Returns the set of terms in this phrase.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Term[] GetTerms()
public virtual Term[] GetTerms()
Public Overridable Function GetTerms As Term()
Public Overridable Function GetTerms As Term()
public:
virtual array<Term^>^ GetTerms()
public:
virtual array<Term^>^ GetTerms()
See Also
PhraseQuery Class
PhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

PhraseQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Back to Top
See Also
PhraseQuery Class
PhraseQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

PhraseQuery ToString Method (String) Lucene.Net Class Library
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string f
)
public override string ToString(
    string f
)
Public Overrides Function ToString ( _
    f As String _
) As String
Public Overrides Function ToString ( _
    f As String _
) As String
public:
virtual String^ ToString(
    String^ f
) override
public:
virtual String^ ToString(
    String^ f
) override
Parameters
f
Type:   Online System String
See Also
PhraseQuery Class
PhraseQuery Members
ToString Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PhraseQuery Properties

PhraseQuery Properties Lucene.Net Class Library
The PhraseQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Slop | Sets the number of other words permitted between words in query phrase. If zero, then this is an exact phrase search. For larger values this works like a WITHIN or NEAR operator. The slop is in fact an edit-distance, where the units correspond to moves of terms in the query phrase out of position. For example, to switch the order of two words requires two moves (the first move places the words atop one another), so to permit re-orderings of phrases, the slop must be at least two. More exact matches are scored higher than sloppier matches, thus search results are sorted by exactness. The slop is zero by default, requiring exact matches.
Back to Top
See Also
PhraseQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Slop Property

PhraseQuery Slop Property Lucene.Net Class Library
Sets the number of other words permitted between words in query phrase. If zero, then this is an exact phrase search. For larger values this works like a WITHIN or NEAR operator.

The slop is in fact an edit-distance, where the units correspond to moves of terms in the query phrase out of position. For example, to switch the order of two words requires two moves (the first move places the words atop one another), so to permit re-orderings of phrases, the slop must be at least two.

More exact matches are scored higher than sloppier matches, thus search results are sorted by exactness.

The slop is zero by default, requiring exact matches.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Slop { get; set; }
public virtual int Slop { get; set; }
Public Overridable Property Slop As Integer
    Get
    Set
Public Overridable Property Slop As Integer
    Get
    Set
public:
virtual property int Slop {
    int get ();
    void set (int value);
}
public:
virtual property int Slop {
    int get ();
    void set (int value);
}
See Also
PhraseQuery Class
PhraseQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositiveScoresOnlyCollector Class

PositiveScoresOnlyCollector Class Lucene.Net Class Library
A Collector implementation which wraps another Collector and makes sure only documents with scores > 0 are collected.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Collector
Lucene.Net.Search PositiveScoresOnlyCollector

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PositiveScoresOnlyCollector : Collector
public class PositiveScoresOnlyCollector : Collector
Public Class PositiveScoresOnlyCollector _
    Inherits Collector
Public Class PositiveScoresOnlyCollector _
    Inherits Collector
public ref class PositiveScoresOnlyCollector : public Collector
public ref class PositiveScoresOnlyCollector : public Collector
See Also
PositiveScoresOnlyCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositiveScoresOnlyCollector Members

PositiveScoresOnlyCollector Members Lucene.Net Class Library

The PositiveScoresOnlyCollector type exposes the following members.
Constructors
 | Name | Description
Public method | PositiveScoresOnlyCollector | Initializes a new instance of the PositiveScoresOnlyCollector class
Back to Top
Methods
 | Name | Description
Public method | Collect | (Overrides Collector Collect(Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetNextReader | (Overrides Collector SetNextReader(IndexReader, Int32).)
Public method | SetScorer | (Overrides Collector SetScorer(Scorer).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | AcceptsDocsOutOfOrder | (Overrides Collector AcceptsDocsOutOfOrder.)
Back to Top
See Also
PositiveScoresOnlyCollector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositiveScoresOnlyCollector Constructor

PositiveScoresOnlyCollector Constructor Lucene.Net Class Library
Initializes a new instance of the PositiveScoresOnlyCollector class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PositiveScoresOnlyCollector(
    Collector c
)
public PositiveScoresOnlyCollector(
    Collector c
)
Public Sub New ( _
    c As Collector _
)
Public Sub New ( _
    c As Collector _
)
public:
PositiveScoresOnlyCollector(
    Collector^ c
)
public:
PositiveScoresOnlyCollector(
    Collector^ c
)
Parameters
c
Type: Lucene.Net.Search Collector
See Also
PositiveScoresOnlyCollector Class
PositiveScoresOnlyCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositiveScoresOnlyCollector Methods

PositiveScoresOnlyCollector Methods Lucene.Net Class Library
The PositiveScoresOnlyCollector type exposes the following members.
Methods
 | Name | Description
Public method | Collect | (Overrides Collector Collect(Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetNextReader | (Overrides Collector SetNextReader(IndexReader, Int32).)
Public method | SetScorer | (Overrides Collector SetScorer(Scorer).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PositiveScoresOnlyCollector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Collect Method

PositiveScoresOnlyCollector Collect Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Collect(
    int doc
)
public override void Collect(
    int doc
)
Public Overrides Sub Collect ( _
    doc As Integer _
)
Public Overrides Sub Collect ( _
    doc As Integer _
)
public:
virtual void Collect(
    int doc
) override
public:
virtual void Collect(
    int doc
) override
Parameters
doc
Type:   Online System Int32
See Also
PositiveScoresOnlyCollector Class
PositiveScoresOnlyCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNextReader Method

PositiveScoresOnlyCollector SetNextReader Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
docBase
Type:   Online System Int32
See Also
PositiveScoresOnlyCollector Class
PositiveScoresOnlyCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetScorer Method

PositiveScoresOnlyCollector SetScorer Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetScorer(
    Scorer scorer
)
public override void SetScorer(
    Scorer scorer
)
Public Overrides Sub SetScorer ( _
    scorer As Scorer _
)
Public Overrides Sub SetScorer ( _
    scorer As Scorer _
)
public:
virtual void SetScorer(
    Scorer^ scorer
) override
public:
virtual void SetScorer(
    Scorer^ scorer
) override
Parameters
scorer
Type: Lucene.Net.Search Scorer
See Also
PositiveScoresOnlyCollector Class
PositiveScoresOnlyCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PositiveScoresOnlyCollector Properties

PositiveScoresOnlyCollector Properties Lucene.Net Class Library
The PositiveScoresOnlyCollector type exposes the following members.
Properties
 | Name | Description
Public property | AcceptsDocsOutOfOrder | (Overrides Collector AcceptsDocsOutOfOrder.)
Back to Top
See Also
PositiveScoresOnlyCollector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AcceptsDocsOutOfOrder Property

PositiveScoresOnlyCollector AcceptsDocsOutOfOrder Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool AcceptsDocsOutOfOrder { get; }
public override bool AcceptsDocsOutOfOrder { get; }
Public Overrides ReadOnly Property AcceptsDocsOutOfOrder As Boolean
    Get
Public Overrides ReadOnly Property AcceptsDocsOutOfOrder As Boolean
    Get
public:
virtual property bool AcceptsDocsOutOfOrder {
    bool get () override;
}
public:
virtual property bool AcceptsDocsOutOfOrder {
    bool get () override;
}
See Also
PositiveScoresOnlyCollector Class
PositiveScoresOnlyCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixFilter Class

PrefixFilter Class Lucene.Net Class Library
A Filter that restricts search results to values that have a matching prefix in a given field.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Filter
Lucene.Net.Search MultiTermQueryWrapperFilter PrefixQuery
Lucene.Net.Search PrefixFilter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PrefixFilter : MultiTermQueryWrapperFilter<PrefixQuery>
[SerializableAttribute]
public class PrefixFilter : MultiTermQueryWrapperFilter<PrefixQuery>
<SerializableAttribute> _
Public Class PrefixFilter _
    Inherits MultiTermQueryWrapperFilter(Of PrefixQuery)
<SerializableAttribute> _
Public Class PrefixFilter _
    Inherits MultiTermQueryWrapperFilter(Of PrefixQuery)
[SerializableAttribute]
public ref class PrefixFilter : public MultiTermQueryWrapperFilter<PrefixQuery^>
[SerializableAttribute]
public ref class PrefixFilter : public MultiTermQueryWrapperFilter<PrefixQuery^>
See Also
PrefixFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixFilter Members

PrefixFilter Members Lucene.Net Class Library

The PrefixFilter type exposes the following members.
Constructors
 | Name | Description
Public method | PrefixFilter | Initializes a new instance of the PrefixFilter class
Back to Top
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the filter. (Inherited from MultiTermQueryWrapperFilter T .)
Public method | Equals | (Inherited from MultiTermQueryWrapperFilter T .)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Inherited from MultiTermQueryWrapperFilter T .)
Public method | GetHashCode | (Inherited from MultiTermQueryWrapperFilter T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Prints a user-readable version of this query. (Overrides MultiTermQueryWrapperFilter T ToString .)
Back to Top
Fields
 | Name | Description
Protected field | query | (Inherited from MultiTermQueryWrapperFilter T .)
Back to Top
Properties
 | Name | Description
Public property | Prefix |
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . (Inherited from MultiTermQueryWrapperFilter T .)
Back to Top
See Also
PrefixFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixFilter Constructor

PrefixFilter Constructor Lucene.Net Class Library
Initializes a new instance of the PrefixFilter class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PrefixFilter(
    Term prefix
)
public PrefixFilter(
    Term prefix
)
Public Sub New ( _
    prefix As Term _
)
Public Sub New ( _
    prefix As Term _
)
public:
PrefixFilter(
    Term^ prefix
)
public:
PrefixFilter(
    Term^ prefix
)
Parameters
prefix
Type: Lucene.Net.Index Term
See Also
PrefixFilter Class
PrefixFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixFilter Fields

PrefixFilter Fields Lucene.Net Class Library
The PrefixFilter type exposes the following members.
Fields
 | Name | Description
Protected field | query | (Inherited from MultiTermQueryWrapperFilter T .)
Back to Top
See Also
PrefixFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixFilter Methods

PrefixFilter Methods Lucene.Net Class Library
The PrefixFilter type exposes the following members.
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the filter. (Inherited from MultiTermQueryWrapperFilter T .)
Public method | Equals | (Inherited from MultiTermQueryWrapperFilter T .)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Inherited from MultiTermQueryWrapperFilter T .)
Public method | GetHashCode | (Inherited from MultiTermQueryWrapperFilter T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Prints a user-readable version of this query. (Overrides MultiTermQueryWrapperFilter T ToString .)
Back to Top
See Also
PrefixFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

PrefixFilter ToString Method Lucene.Net Class Library
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
PrefixFilter Class
PrefixFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixFilter Properties

PrefixFilter Properties Lucene.Net Class Library
The PrefixFilter type exposes the following members.
Properties
 | Name | Description
Public property | Prefix |
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . (Inherited from MultiTermQueryWrapperFilter T .)
Back to Top
See Also
PrefixFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Prefix Property

PrefixFilter Prefix Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Term Prefix { get; }
public virtual Term Prefix { get; }
Public Overridable ReadOnly Property Prefix As Term
    Get
Public Overridable ReadOnly Property Prefix As Term
    Get
public:
virtual property Term^ Prefix {
    Term^ get ();
}
public:
virtual property Term^ Prefix {
    Term^ get ();
}
See Also
PrefixFilter Class
PrefixFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixQuery Class

PrefixQuery Class Lucene.Net Class Library
A Query that matches documents containing terms with a specified prefix. A PrefixQuery is built by QueryParser for input like app*.

This query uses the CONSTANT_SCORE_AUTO_REWRITE_DEFAULT rewrite method.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search MultiTermQuery
Lucene.Net.Search PrefixQuery

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PrefixQuery : MultiTermQuery
[SerializableAttribute]
public class PrefixQuery : MultiTermQuery
<SerializableAttribute> _
Public Class PrefixQuery _
    Inherits MultiTermQuery
<SerializableAttribute> _
Public Class PrefixQuery _
    Inherits MultiTermQuery
[SerializableAttribute]
public ref class PrefixQuery : public MultiTermQuery
[SerializableAttribute]
public ref class PrefixQuery : public MultiTermQuery
See Also
PrefixQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixQuery Members

PrefixQuery Members Lucene.Net Class Library

The PrefixQuery type exposes the following members.
Constructors
 | Name | Description
Public method | PrefixQuery | Constructs a query for terms starting with prefix.
Back to Top
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the query/filter. (Inherited from MultiTermQuery.)
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | Expert: Constructs an appropriate Weight implementation for this query. Only implemented by primitive queries, which re-write to themselves. (Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery Equals(Object).)
Public method | ExtractTerms | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its rewritten form. (Inherited from Query.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetEnum | (Overrides MultiTermQuery GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Inherited from MultiTermQuery.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Fields
 | Name | Description
Protected field | internalRewriteMethod | (Inherited from MultiTermQuery.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Prefix | Returns the prefix of this query.
Public property | RewriteMethod | Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of RewriteMethod. (Inherited from MultiTermQuery.)
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers. (Inherited from MultiTermQuery.)
Back to Top
See Also
PrefixQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixQuery Constructor

PrefixQuery Constructor Lucene.Net Class Library
Constructs a query for terms starting with prefix.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PrefixQuery(
    Term prefix
)
public PrefixQuery(
    Term prefix
)
Public Sub New ( _
    prefix As Term _
)
Public Sub New ( _
    prefix As Term _
)
public:
PrefixQuery(
    Term^ prefix
)
public:
PrefixQuery(
    Term^ prefix
)
Parameters
prefix
Type: Lucene.Net.Index Term
See Also
PrefixQuery Class
PrefixQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixQuery Fields

PrefixQuery Fields Lucene.Net Class Library
The PrefixQuery type exposes the following members.
Fields
 | Name | Description
Protected field | internalRewriteMethod | (Inherited from MultiTermQuery.)
Back to Top
See Also
PrefixQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixQuery Methods

PrefixQuery Methods Lucene.Net Class Library
The PrefixQuery type exposes the following members.
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the query/filter. (Inherited from MultiTermQuery.)
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | Expert: Constructs an appropriate Weight implementation for this query. Only implemented by primitive queries, which re-write to themselves. (Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery Equals(Object).)
Public method | ExtractTerms | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its rewritten form. (Inherited from Query.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetEnum | (Overrides MultiTermQuery GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Inherited from MultiTermQuery.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
PrefixQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

PrefixQuery Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
PrefixQuery Class
PrefixQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetEnum Method

PrefixQuery GetEnum Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override FilteredTermEnum GetEnum(
    IndexReader reader
)
protected override FilteredTermEnum GetEnum(
    IndexReader reader
)
Protected Overrides Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
Protected Overrides Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
protected:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) override
protected:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
PrefixQuery Class
PrefixQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

PrefixQuery GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
PrefixQuery Class
PrefixQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

PrefixQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Back to Top
See Also
PrefixQuery Class
PrefixQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

PrefixQuery ToString Method (String) Lucene.Net Class Library
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
PrefixQuery Class
PrefixQuery Members
ToString Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixQuery Properties

PrefixQuery Properties Lucene.Net Class Library
The PrefixQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Prefix | Returns the prefix of this query.
Public property | RewriteMethod | Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of RewriteMethod. (Inherited from MultiTermQuery.)
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers. (Inherited from MultiTermQuery.)
Back to Top
See Also
PrefixQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Prefix Property

PrefixQuery Prefix Property Lucene.Net Class Library
Returns the prefix of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Term Prefix { get; }
public virtual Term Prefix { get; }
Public Overridable ReadOnly Property Prefix As Term
    Get
Public Overridable ReadOnly Property Prefix As Term
    Get
public:
virtual property Term^ Prefix {
    Term^ get ();
}
public:
virtual property Term^ Prefix {
    Term^ get ();
}
See Also
PrefixQuery Class
PrefixQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixTermEnum Class

PrefixTermEnum Class Lucene.Net Class Library
Subclass of FilteredTermEnum for enumerating all terms that match the specified prefix filter term.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index TermEnum
Lucene.Net.Search FilteredTermEnum
Lucene.Net.Search PrefixTermEnum

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PrefixTermEnum : FilteredTermEnum
public class PrefixTermEnum : FilteredTermEnum
Public Class PrefixTermEnum _
    Inherits FilteredTermEnum
Public Class PrefixTermEnum _
    Inherits FilteredTermEnum
public ref class PrefixTermEnum : public FilteredTermEnum
public ref class PrefixTermEnum : public FilteredTermEnum
See Also
PrefixTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixTermEnum Members

PrefixTermEnum Members Lucene.Net Class Library

The PrefixTermEnum type exposes the following members.
Constructors
 | Name | Description
Public method | PrefixTermEnum | Initializes a new instance of the PrefixTermEnum class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Public method | Difference | (Overrides FilteredTermEnum Difference .)
Public method | Dispose | Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Protected method | Dispose(Boolean) | (Inherited from FilteredTermEnum.)
Public method | DocFreq | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum EndEnum .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | Increments the enumeration to the next element. True if one exists. (Inherited from FilteredTermEnum.)
Protected method | SetEnum | use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term. (Inherited from FilteredTermEnum.)
Protected method | TermCompare | (Overrides FilteredTermEnum TermCompare(Term).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use SetEnum(TermEnum) (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)
Back to Top
Properties
 | Name | Description
Protected property | PrefixTerm |
Public property | Term | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Back to Top
See Also
PrefixTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixTermEnum Constructor

PrefixTermEnum Constructor Lucene.Net Class Library
Initializes a new instance of the PrefixTermEnum class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PrefixTermEnum(
    IndexReader reader,
    Term prefix
)
public PrefixTermEnum(
    IndexReader reader,
    Term prefix
)
Public Sub New ( _
    reader As IndexReader, _
    prefix As Term _
)
Public Sub New ( _
    reader As IndexReader, _
    prefix As Term _
)
public:
PrefixTermEnum(
    IndexReader^ reader,
    Term^ prefix
)
public:
PrefixTermEnum(
    IndexReader^ reader,
    Term^ prefix
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
prefix
Type: Lucene.Net.Index Term
See Also
PrefixTermEnum Class
PrefixTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixTermEnum Fields

PrefixTermEnum Fields Lucene.Net Class Library
The PrefixTermEnum type exposes the following members.
Fields
 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use SetEnum(TermEnum) (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)
Back to Top
See Also
PrefixTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixTermEnum Methods

PrefixTermEnum Methods Lucene.Net Class Library
The PrefixTermEnum type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Public method | Difference | (Overrides FilteredTermEnum Difference .)
Public method | Dispose | Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Protected method | Dispose(Boolean) | (Inherited from FilteredTermEnum.)
Public method | DocFreq | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum EndEnum .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | Increments the enumeration to the next element. True if one exists. (Inherited from FilteredTermEnum.)
Protected method | SetEnum | use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term. (Inherited from FilteredTermEnum.)
Protected method | TermCompare | (Overrides FilteredTermEnum TermCompare(Term).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PrefixTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Difference Method

PrefixTermEnum Difference Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Difference()
public override float Difference()
Public Overrides Function Difference As Single
Public Overrides Function Difference As Single
public:
virtual float Difference() override
public:
virtual float Difference() override
See Also
PrefixTermEnum Class
PrefixTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EndEnum Method

PrefixTermEnum EndEnum Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool EndEnum()
public override bool EndEnum()
Public Overrides Function EndEnum As Boolean
Public Overrides Function EndEnum As Boolean
public:
virtual bool EndEnum() override
public:
virtual bool EndEnum() override
See Also
PrefixTermEnum Class
PrefixTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermCompare Method

PrefixTermEnum TermCompare Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool TermCompare(
    Term term
)
protected override bool TermCompare(
    Term term
)
Protected Overrides Function TermCompare ( _
    term As Term _
) As Boolean
Protected Overrides Function TermCompare ( _
    term As Term _
) As Boolean
protected:
virtual bool TermCompare(
    Term^ term
) override
protected:
virtual bool TermCompare(
    Term^ term
) override
Parameters
term
Type: Lucene.Net.Index Term
See Also
PrefixTermEnum Class
PrefixTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixTermEnum Properties

PrefixTermEnum Properties Lucene.Net Class Library
The PrefixTermEnum type exposes the following members.
Properties
 | Name | Description
Protected property | PrefixTerm |
Public property | Term | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Back to Top
See Also
PrefixTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixTerm Property

PrefixTermEnum PrefixTerm Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Term PrefixTerm { get; }
protected virtual Term PrefixTerm { get; }
Protected Overridable ReadOnly Property PrefixTerm As Term
    Get
Protected Overridable ReadOnly Property PrefixTerm As Term
    Get
protected:
virtual property Term^ PrefixTerm {
    Term^ get ();
}
protected:
virtual property Term^ PrefixTerm {
    Term^ get ();
}
See Also
PrefixTermEnum Class
PrefixTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Query Class

Query Class Lucene.Net Class Library
The abstract base class for queries.

Instantiable subclasses are:
  • TermQuery
  • MultiTermQuery
  • BooleanQuery
  • WildcardQuery
  • PhraseQuery
  • PrefixQuery
  • MultiPhraseQuery
  • FuzzyQuery
  • TermRangeQuery
  • NumericRangeQuery T
  • SpanQuery

A parser for queries is contained in:
  • QueryParser
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search BooleanQuery
Lucene.Net.Search ConstantScoreQuery
Lucene.Net.Search DisjunctionMaxQuery
Lucene.Net.Search FilteredQuery
Lucene.Net.Search.Function CustomScoreQuery
Lucene.Net.Search.Function ValueSourceQuery
Lucene.Net.Search MatchAllDocsQuery
Lucene.Net.Search MultiPhraseQuery
Lucene.Net.Search MultiTermQuery
Lucene.Net.Search PhraseQuery
Lucene.Net.Search.Spans SpanQuery
Lucene.Net.Search TermQuery

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class Query : ICloneable
[SerializableAttribute]
public abstract class Query : ICloneable
<SerializableAttribute> _
Public MustInherit Class Query _
    Implements ICloneable
<SerializableAttribute> _
Public MustInherit Class Query _
    Implements ICloneable
[SerializableAttribute]
public ref class Query abstract : ICloneable
[SerializableAttribute]
public ref class Query abstract : ICloneable
See Also
Query Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Query Members

Query Members Lucene.Net Class Library

The Query type exposes the following members.
Constructors
 | Name | Description
Protected method | Query | Initializes a new instance of the Query class
Back to Top
Methods
Name | Description
Public method Clone
Returns a clone of this query.
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.
Public method | Equals | (Overrides Online Object Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its rewritten form.
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
MergeBooleanQueries
Expert: merges the clauses of a set of BooleanQuery's into a single BooleanQuery.

A utility for use by Combine( Query ) implementations.
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
Public method ToString
Prints a query to a string.
(Overrides Online Object ToString .)
Public method ToString(String)
Prints a query to a string, with field assumed to be the default field and omitted.

The representation used is one that is supposed to be readable by QueryParser. However, there are the following limitations:
  • If the query was created by the parser, the printed representation may not be exactly what was parsed. For example, characters that need to be escaped will be represented without the required backslash.
  • Some of the more complicated queries (e.g. span queries) don't have a representation that can be parsed by QueryParser.
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default.
Back to Top
See Also
Query Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Query Constructor

Query Constructor Lucene.Net Class Library
Initializes a new instance of the Query class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Query()
protected Query()
Protected Sub New
Protected Sub New
protected:
Query()
protected:
Query()
See Also
Query Class
Query Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Query Methods

Query Methods Lucene.Net Class Library
The Query type exposes the following members.
Methods
Name | Description
Public method Clone
Returns a clone of this query.
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.
Public method | Equals | (Overrides Online Object Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its rewritten form.
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
MergeBooleanQueries
Expert: merges the clauses of a set of BooleanQuery's into a single BooleanQuery.

A utility for use by Combine( Query ) implementations.
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
Public method ToString
Prints a query to a string.
(Overrides Online Object ToString .)
Public method ToString(String)
Prints a query to a string, with field assumed to be the default field and omitted.

The representation used is one that is supposed to be readable by QueryParser. However, there are the following limitations:
  • If the query was created by the parser, the printed representation may not be exactly what was parsed. For example, characters that need to be escaped will be represented without the required backslash.
  • Some of the more complicated queries (e.g. span queries) don't have a representation that can be parsed by QueryParser.
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
Back to Top
See Also
Query Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

Query Clone Method Lucene.Net Class Library
Returns a clone of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object Clone()
public virtual Object Clone()
Public Overridable Function Clone As Object
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
public:
virtual Object^ Clone()
Implements
  Online ICloneable Clone
See Also
Query Class
Query Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Combine Method

Query Combine Method Lucene.Net Class Library
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Query Combine(
    Query[] queries
)
public virtual Query Combine(
    Query[] queries
)
Public Overridable Function Combine ( _
    queries As Query() _
) As Query
Public Overridable Function Combine ( _
    queries As Query() _
) As Query
public:
virtual Query^ Combine(
    array<Query^>^ queries
)
public:
virtual Query^ Combine(
    array<Query^>^ queries
)
Parameters
queries
Type:  Lucene.Net.Search Query
See Also
Query Class
Query Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateWeight Method

Query CreateWeight Method Lucene.Net Class Library
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Weight CreateWeight(
    Searcher searcher
)
public virtual Weight CreateWeight(
    Searcher searcher
)
Public Overridable Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Public Overridable Function CreateWeight ( _
    searcher As Searcher _
) As Weight
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
)
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
)
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
Query Class
Query Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

Query Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
Query Class
Query Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExtractTerms Method

Query ExtractTerms Method Lucene.Net Class Library
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its rewritten form.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ExtractTerms(
    ISet<Term> terms
)
public virtual void ExtractTerms(
    ISet<Term> terms
)
Public Overridable Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
Public Overridable Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
)
Parameters
terms
Type:   Online System.Collections.Generic ISet  Term
See Also
Query Class
Query Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

Query GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
Query Class
Query Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSimilarity Method

Query GetSimilarity Method Lucene.Net Class Library
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Similarity GetSimilarity(
    Searcher searcher
)
public virtual Similarity GetSimilarity(
    Searcher searcher
)
Public Overridable Function GetSimilarity ( _
    searcher As Searcher _
) As Similarity
Public Overridable Function GetSimilarity ( _
    searcher As Searcher _
) As Similarity
public:
virtual Similarity^ GetSimilarity(
    Searcher^ searcher
)
public:
virtual Similarity^ GetSimilarity(
    Searcher^ searcher
)
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
Query Class
Query Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergeBooleanQueries Method

Query MergeBooleanQueries Method Lucene.Net Class Library
Expert: merges the clauses of a set of BooleanQuery's into a single BooleanQuery.

A utility for use by Combine( Query ) implementations.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Query MergeBooleanQueries(
    params BooleanQuery[] queries
)
public static Query MergeBooleanQueries(
    params BooleanQuery[] queries
)
Public Shared Function MergeBooleanQueries ( _
    ParamArray queries As BooleanQuery() _
) As Query
Public Shared Function MergeBooleanQueries ( _
    ParamArray queries As BooleanQuery() _
) As Query
public:
static Query^ MergeBooleanQueries(
    ... array<BooleanQuery^>^ queries
)
public:
static Query^ MergeBooleanQueries(
    ... array<BooleanQuery^>^ queries
)
Parameters
queries
Type:  Lucene.Net.Search BooleanQuery
See Also
Query Class
Query Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

Query Rewrite Method Lucene.Net Class Library
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Query Rewrite(
    IndexReader reader
)
public virtual Query Rewrite(
    IndexReader reader
)
Public Overridable Function Rewrite ( _
    reader As IndexReader _
) As Query
Public Overridable Function Rewrite ( _
    reader As IndexReader _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader
)
public:
virtual Query^ Rewrite(
    IndexReader^ reader
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
Query Class
Query Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

Query ToString Method Lucene.Net Class Library
Overload List
Name Description
Public method ToString
Prints a query to a string.
(Overrides Online Object ToString .)
Public method ToString(String)
Prints a query to a string, with field assumed to be the default field and omitted.

The representation used is one that is supposed to be readable by QueryParser. However, there are the following limitations:
  • If the query was created by the parser, the printed representation may not be exactly what was parsed. For example, characters that need to be escaped will be represented without the required backslash.
  • Some of the more complicated queries (e.g. span queries) don't have a representation that can be parsed by QueryParser.
Back to Top
See Also
Query Class
Query Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

Query ToString Method Lucene.Net Class Library
Prints a query to a string.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
Query Class
Query Members
ToString Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

Query ToString Method (String) Lucene.Net Class Library
Prints a query to a string, with field assumed to be the default field and omitted.

The representation used is one that is supposed to be readable by QueryParser. However, there are the following limitations:
  • If the query was created by the parser, the printed representation may not be exactly what was parsed. For example, characters that need to be escaped will be represented without the required backslash.
  • Some of the more complicated queries (e.g. span queries) don't have a representation that can be parsed by QueryParser.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string ToString(
    string field
)
public abstract string ToString(
    string field
)
Public MustOverride Function ToString ( _
    field As String _
) As String
Public MustOverride Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) abstract
public:
virtual String^ ToString(
    String^ field
) abstract
Parameters
field
Type:   Online System String
See Also
Query Class
Query Members
ToString Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Weight Method

Query Weight Method Lucene.Net Class Library
Expert: Constructs and initializes a Weight for a top-level query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Weight Weight(
    Searcher searcher
)
public virtual Weight Weight(
    Searcher searcher
)
Public Overridable Function Weight ( _
    searcher As Searcher _
) As Weight
Public Overridable Function Weight ( _
    searcher As Searcher _
) As Weight
public:
virtual Weight^ Weight(
    Searcher^ searcher
)
public:
virtual Weight^ Weight(
    Searcher^ searcher
)
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
Query Class
Query Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Query Properties

Query Properties Lucene.Net Class Library
The Query type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default.
Back to Top
See Also
Query Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Boost Property

Query Boost Property Lucene.Net Class Library
Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual float Boost { get; set; }
public virtual float Boost { get; set; }
Public Overridable Property Boost As Single
    Get
    Set
Public Overridable Property Boost As Single
    Get
    Set
public:
virtual property float Boost {
    float get ();
    void set (float value);
}
public:
virtual property float Boost {
    float get ();
    void set (float value);
}
See Also
Query Class
Query Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryTermVector Class

QueryTermVector Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search QueryTermVector

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class QueryTermVector : ITermFreqVector
public class QueryTermVector : ITermFreqVector
Public Class QueryTermVector _
    Implements ITermFreqVector
Public Class QueryTermVector _
    Implements ITermFreqVector
public ref class QueryTermVector : ITermFreqVector
public ref class QueryTermVector : ITermFreqVector
See Also
QueryTermVector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryTermVector Members

QueryTermVector Members Lucene.Net Class Library

The QueryTermVector type exposes the following members.
Constructors
 | Name | Description
Public method | QueryTermVector( String ) | Initializes a new instance of the QueryTermVector class
Public method | QueryTermVector(String, Analyzer) | Initializes a new instance of the QueryTermVector class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetTermFrequencies |
Public method | GetTerms |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexesOf |
Public method | IndexOf |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | Field |
Public property | Size |
Back to Top
See Also
QueryTermVector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryTermVector Constructor

QueryTermVector Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | QueryTermVector( String ) | Initializes a new instance of the QueryTermVector class
Public method | QueryTermVector(String, Analyzer) | Initializes a new instance of the QueryTermVector class
Back to Top
See Also
QueryTermVector Class
QueryTermVector Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryTermVector Constructor (String[])

QueryTermVector Constructor ( String ) Lucene.Net Class Library
Initializes a new instance of the QueryTermVector class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QueryTermVector(
    string[] queryTerms
)
public QueryTermVector(
    string[] queryTerms
)
Public Sub New ( _
    queryTerms As String() _
)
Public Sub New ( _
    queryTerms As String() _
)
public:
QueryTermVector(
    array<String^>^ queryTerms
)
public:
QueryTermVector(
    array<String^>^ queryTerms
)
Parameters
queryTerms
Type:    Online System String
The original list of terms from the query, can contain duplicates

See Also
QueryTermVector Class
QueryTermVector Members
QueryTermVector Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryTermVector Constructor (String, Analyzer)

QueryTermVector Constructor (String, Analyzer) Lucene.Net Class Library
Initializes a new instance of the QueryTermVector class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QueryTermVector(
    string queryString,
    Analyzer analyzer
)
public QueryTermVector(
    string queryString,
    Analyzer analyzer
)
Public Sub New ( _
    queryString As String, _
    analyzer As Analyzer _
)
Public Sub New ( _
    queryString As String, _
    analyzer As Analyzer _
)
public:
QueryTermVector(
    String^ queryString,
    Analyzer^ analyzer
)
public:
QueryTermVector(
    String^ queryString,
    Analyzer^ analyzer
)
Parameters
queryString
Type:   Online System String
analyzer
Type: Lucene.Net.Analysis Analyzer
See Also
QueryTermVector Class
QueryTermVector Members
QueryTermVector Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryTermVector Methods

QueryTermVector Methods Lucene.Net Class Library
The QueryTermVector type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetTermFrequencies |
Public method | GetTerms |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexesOf |
Public method | IndexOf |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
QueryTermVector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTermFrequencies Method

QueryTermVector GetTermFrequencies Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int[] GetTermFrequencies()
public virtual int[] GetTermFrequencies()
Public Overridable Function GetTermFrequencies As Integer()
Public Overridable Function GetTermFrequencies As Integer()
public:
virtual array<int>^ GetTermFrequencies()
public:
virtual array<int>^ GetTermFrequencies()
Implements
ITermFreqVector GetTermFrequencies
See Also
QueryTermVector Class
QueryTermVector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetTerms Method

QueryTermVector GetTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string[] GetTerms()
public virtual string[] GetTerms()
Public Overridable Function GetTerms As String()
Public Overridable Function GetTerms As String()
public:
virtual array<String^>^ GetTerms()
public:
virtual array<String^>^ GetTerms()
Implements
ITermFreqVector GetTerms
See Also
QueryTermVector Class
QueryTermVector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexesOf Method

QueryTermVector IndexesOf Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int[] IndexesOf(
    string[] terms,
    int start,
    int len
)
public virtual int[] IndexesOf(
    string[] terms,
    int start,
    int len
)
Public Overridable Function IndexesOf ( _
    terms As String(), _
    start As Integer, _
    len As Integer _
) As Integer()
Public Overridable Function IndexesOf ( _
    terms As String(), _
    start As Integer, _
    len As Integer _
) As Integer()
public:
virtual array<int>^ IndexesOf(
    array<String^>^ terms,
    int start,
    int len
)
public:
virtual array<int>^ IndexesOf(
    array<String^>^ terms,
    int start,
    int len
)
Parameters
terms
Type:    Online System String
start
Type:   Online System Int32
len
Type:   Online System Int32
Implements
ITermFreqVector IndexesOf( String , Int32, Int32)
See Also
QueryTermVector Class
QueryTermVector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexOf Method

QueryTermVector IndexOf Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int IndexOf(
    string term
)
public virtual int IndexOf(
    string term
)
Public Overridable Function IndexOf ( _
    term As String _
) As Integer
Public Overridable Function IndexOf ( _
    term As String _
) As Integer
public:
virtual int IndexOf(
    String^ term
)
public:
virtual int IndexOf(
    String^ term
)
Parameters
term
Type:   Online System String
Implements
ITermFreqVector IndexOf(String)
See Also
QueryTermVector Class
QueryTermVector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

QueryTermVector ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
QueryTermVector Class
QueryTermVector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryTermVector Properties

QueryTermVector Properties Lucene.Net Class Library
The QueryTermVector type exposes the following members.
Properties
 | Name | Description
Public property | Field |
Public property | Size |
Back to Top
See Also
QueryTermVector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

QueryTermVector Field Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Field { get; }
public virtual string Field { get; }
Public Overridable ReadOnly Property Field As String
    Get
Public Overridable ReadOnly Property Field As String
    Get
public:
virtual property String^ Field {
    String^ get ();
}
public:
virtual property String^ Field {
    String^ get ();
}
Implements
ITermFreqVector Field
See Also
QueryTermVector Class
QueryTermVector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Size Property

QueryTermVector Size Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Size { get; }
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
public:
virtual property int Size {
    int get ();
}
Implements
ITermFreqVector Size
See Also
QueryTermVector Class
QueryTermVector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryWrapperFilter Class

QueryWrapperFilter Class Lucene.Net Class Library
Constrains search results to only match those which also match a provided query.

This could be used, for example, with a TermRangeQuery on a suitably formatted date field to implement date filtering. One could re-use a single QueryFilter that matches, e.g., only documents modified within the last week. The QueryFilter and TermRangeQuery would only need to be reconstructed once per day.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Filter
Lucene.Net.Search QueryWrapperFilter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class QueryWrapperFilter : Filter
[SerializableAttribute]
public class QueryWrapperFilter : Filter
<SerializableAttribute> _
Public Class QueryWrapperFilter _
    Inherits Filter
<SerializableAttribute> _
Public Class QueryWrapperFilter _
    Inherits Filter
[SerializableAttribute]
public ref class QueryWrapperFilter : public Filter
[SerializableAttribute]
public ref class QueryWrapperFilter : public Filter
See Also
QueryWrapperFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryWrapperFilter Members

QueryWrapperFilter Members Lucene.Net Class Library

The QueryWrapperFilter type exposes the following members.
Constructors
 | Name | Description
Public method | QueryWrapperFilter | Constructs a filter which only matches documents matching query.
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Overrides Filter GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
QueryWrapperFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryWrapperFilter Constructor

QueryWrapperFilter Constructor Lucene.Net Class Library
Constructs a filter which only matches documents matching query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QueryWrapperFilter(
    Query query
)
public QueryWrapperFilter(
    Query query
)
Public Sub New ( _
    query As Query _
)
Public Sub New ( _
    query As Query _
)
public:
QueryWrapperFilter(
    Query^ query
)
public:
QueryWrapperFilter(
    Query^ query
)
Parameters
query
Type: Lucene.Net.Search Query
See Also
QueryWrapperFilter Class
QueryWrapperFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryWrapperFilter Methods

QueryWrapperFilter Methods Lucene.Net Class Library
The QueryWrapperFilter type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Overrides Filter GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
QueryWrapperFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

QueryWrapperFilter Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
QueryWrapperFilter Class
QueryWrapperFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetDocIdSet Method

QueryWrapperFilter GetDocIdSet Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
QueryWrapperFilter Class
QueryWrapperFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

QueryWrapperFilter GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
QueryWrapperFilter Class
QueryWrapperFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

QueryWrapperFilter ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
QueryWrapperFilter Class
QueryWrapperFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RewriteMethod Class

RewriteMethod Class Lucene.Net Class Library
Abstract class that defines how the query is rewritten.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search RewriteMethod
Lucene.Net.Search MultiTermQuery ConstantScoreAutoRewrite

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class RewriteMethod
[SerializableAttribute]
public abstract class RewriteMethod
<SerializableAttribute> _
Public MustInherit Class RewriteMethod
<SerializableAttribute> _
Public MustInherit Class RewriteMethod
[SerializableAttribute]
public ref class RewriteMethod abstract
[SerializableAttribute]
public ref class RewriteMethod abstract
See Also
RewriteMethod Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RewriteMethod Members

RewriteMethod Members Lucene.Net Class Library

The RewriteMethod type exposes the following members.
Constructors
 | Name | Description
Protected method | RewriteMethod | Initializes a new instance of the RewriteMethod class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RewriteMethod Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RewriteMethod Constructor

RewriteMethod Constructor Lucene.Net Class Library
Initializes a new instance of the RewriteMethod class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected RewriteMethod()
protected RewriteMethod()
Protected Sub New
Protected Sub New
protected:
RewriteMethod()
protected:
RewriteMethod()
See Also
RewriteMethod Class
RewriteMethod Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RewriteMethod Methods

RewriteMethod Methods Lucene.Net Class Library
The RewriteMethod type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RewriteMethod Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

RewriteMethod Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Query Rewrite(
    IndexReader reader,
    MultiTermQuery query
)
public abstract Query Rewrite(
    IndexReader reader,
    MultiTermQuery query
)
Public MustOverride Function Rewrite ( _
    reader As IndexReader, _
    query As MultiTermQuery _
) As Query
Public MustOverride Function Rewrite ( _
    reader As IndexReader, _
    query As MultiTermQuery _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader,
    MultiTermQuery^ query
) abstract
public:
virtual Query^ Rewrite(
    IndexReader^ reader,
    MultiTermQuery^ query
) abstract
Parameters
reader
Type: Lucene.Net.Index IndexReader
query
Type: Lucene.Net.Search MultiTermQuery
See Also
RewriteMethod Class
RewriteMethod Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ScoreCachingWrappingScorer Class

ScoreCachingWrappingScorer Class Lucene.Net Class Library
A Scorer which wraps another scorer and caches the score of the current document. Successive calls to Score will return the same result and will not invoke the wrapped Scorer's score() method, unless the current document has changed.
This class might be useful due to the changes done to the Collector interface, in which the score is not computed for a document by default, only if the collector requests it. Some collectors may need to use the score in several places, however all they have in hand is a Scorer object, and might end up computing the score of a document more than once.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSetIterator
Lucene.Net.Search Scorer
Lucene.Net.Search ScoreCachingWrappingScorer

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ScoreCachingWrappingScorer : Scorer
public class ScoreCachingWrappingScorer : Scorer
Public Class ScoreCachingWrappingScorer _
    Inherits Scorer
Public Class ScoreCachingWrappingScorer _
    Inherits Scorer
public ref class ScoreCachingWrappingScorer : public Scorer
public ref class ScoreCachingWrappingScorer : public Scorer
See Also
ScoreCachingWrappingScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ScoreCachingWrappingScorer Members

ScoreCachingWrappingScorer Members Lucene.Net Class Library

The ScoreCachingWrappingScorer type exposes the following members.
Constructors
 | Name | Description
Public method | ScoreCachingWrappingScorer | Creates a new instance by wrapping the given scorer.
Back to Top
Methods
 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Overrides DocIdSetIterator NextDoc .)
Public method | Score | (Overrides Scorer Score .)
Public method | Score(Collector) | (Overrides Scorer Score(Collector).)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer Score(Collector, Int32, Int32).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Similarity | (Overrides Scorer Similarity.)
Back to Top
See Also
ScoreCachingWrappingScorer Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ScoreCachingWrappingScorer Constructor

ScoreCachingWrappingScorer Constructor Lucene.Net Class Library
Creates a new instance by wrapping the given scorer.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ScoreCachingWrappingScorer(
    Scorer scorer
)
public ScoreCachingWrappingScorer(
    Scorer scorer
)
Public Sub New ( _
    scorer As Scorer _
)
Public Sub New ( _
    scorer As Scorer _
)
public:
ScoreCachingWrappingScorer(
    Scorer^ scorer
)
public:
ScoreCachingWrappingScorer(
    Scorer^ scorer
)
Parameters
scorer
Type: Lucene.Net.Search Scorer
See Also
ScoreCachingWrappingScorer Class
ScoreCachingWrappingScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ScoreCachingWrappingScorer Methods

ScoreCachingWrappingScorer Methods Lucene.Net Class Library
The ScoreCachingWrappingScorer type exposes the following members.
Methods
 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Overrides DocIdSetIterator NextDoc .)
Public method | Score | (Overrides Scorer Score .)
Public method | Score(Collector) | (Overrides Scorer Score(Collector).)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer Score(Collector, Int32, Int32).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ScoreCachingWrappingScorer Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Advance Method

ScoreCachingWrappingScorer Advance Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Advance(
    int target
)
public override int Advance(
    int target
)
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
public:
virtual int Advance(
    int target
) override
public:
virtual int Advance(
    int target
) override
Parameters
target
Type:   Online System Int32
See Also
ScoreCachingWrappingScorer Class
ScoreCachingWrappingScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocID Method

ScoreCachingWrappingScorer DocID Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocID()
public override int DocID()
Public Overrides Function DocID As Integer
Public Overrides Function DocID As Integer
public:
virtual int DocID() override
public:
virtual int DocID() override
See Also
ScoreCachingWrappingScorer Class
ScoreCachingWrappingScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextDoc Method

ScoreCachingWrappingScorer NextDoc Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int NextDoc()
public override int NextDoc()
Public Overrides Function NextDoc As Integer
Public Overrides Function NextDoc As Integer
public:
virtual int NextDoc() override
public:
virtual int NextDoc() override
See Also
ScoreCachingWrappingScorer Class
ScoreCachingWrappingScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method

ScoreCachingWrappingScorer Score Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Score | (Overrides Scorer Score .)
Public method | Score(Collector) | (Overrides Scorer Score(Collector).)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer Score(Collector, Int32, Int32).)
Back to Top
See Also
ScoreCachingWrappingScorer Class
ScoreCachingWrappingScorer Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method

ScoreCachingWrappingScorer Score Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Score()
public override float Score()
Public Overrides Function Score As Single
Public Overrides Function Score As Single
public:
virtual float Score() override
public:
virtual float Score() override
See Also
ScoreCachingWrappingScorer Class
ScoreCachingWrappingScorer Members
Score Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method (Collector)

ScoreCachingWrappingScorer Score Method (Collector) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Score(
    Collector collector
)
public override void Score(
    Collector collector
)
Public Overrides Sub Score ( _
    collector As Collector _
)
Public Overrides Sub Score ( _
    collector As Collector _
)
public:
virtual void Score(
    Collector^ collector
) override
public:
virtual void Score(
    Collector^ collector
) override
Parameters
collector
Type: Lucene.Net.Search Collector
See Also
ScoreCachingWrappingScorer Class
ScoreCachingWrappingScorer Members
Score Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method (Collector, Int32, Int32)

ScoreCachingWrappingScorer Score Method (Collector, Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Score(
    Collector collector,
    int max,
    int firstDocID
)
public override bool Score(
    Collector collector,
    int max,
    int firstDocID
)
Public Overrides Function Score ( _
    collector As Collector, _
    max As Integer, _
    firstDocID As Integer _
) As Boolean
Public Overrides Function Score ( _
    collector As Collector, _
    max As Integer, _
    firstDocID As Integer _
) As Boolean
public:
virtual bool Score(
    Collector^ collector,
    int max,
    int firstDocID
) override
public:
virtual bool Score(
    Collector^ collector,
    int max,
    int firstDocID
) override
Parameters
collector
Type: Lucene.Net.Search Collector
max
Type:   Online System Int32
firstDocID
Type:   Online System Int32
See Also
ScoreCachingWrappingScorer Class
ScoreCachingWrappingScorer Members
Score Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ScoreCachingWrappingScorer Properties

ScoreCachingWrappingScorer Properties Lucene.Net Class Library
The ScoreCachingWrappingScorer type exposes the following members.
Properties
 | Name | Description
Public property | Similarity | (Overrides Scorer Similarity.)
Back to Top
See Also
ScoreCachingWrappingScorer Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Similarity Property

ScoreCachingWrappingScorer Similarity Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Similarity Similarity { get; }
public override Similarity Similarity { get; }
Public Overrides ReadOnly Property Similarity As Similarity
    Get
Public Overrides ReadOnly Property Similarity As Similarity
    Get
public:
virtual property Similarity^ Similarity {
    Similarity^ get () override;
}
public:
virtual property Similarity^ Similarity {
    Similarity^ get () override;
}
See Also
ScoreCachingWrappingScorer Class
ScoreCachingWrappingScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ScoreDoc Class

ScoreDoc Class Lucene.Net Class Library
Expert: Returned by low-level search implementations.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search ScoreDoc
Lucene.Net.Search FieldDoc
Lucene.Net.Search FieldValueHitQueue Entry

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ScoreDoc
[SerializableAttribute]
public class ScoreDoc
<SerializableAttribute> _
Public Class ScoreDoc
<SerializableAttribute> _
Public Class ScoreDoc
[SerializableAttribute]
public ref class ScoreDoc
[SerializableAttribute]
public ref class ScoreDoc
See Also
ScoreDoc Members
Lucene.Net.Search Namespace
Lucene.Net.Search TopDocs
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ScoreDoc Members

ScoreDoc Members Lucene.Net Class Library

The ScoreDoc type exposes the following members.
Constructors
 | Name | Description
Public method | ScoreDoc | Expert: Constructs a ScoreDoc.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | Doc | Expert: A hit document's number.
Public property | Score | Expert: The score of this document for the query.
Back to Top
See Also
ScoreDoc Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ScoreDoc Constructor

ScoreDoc Constructor Lucene.Net Class Library
Expert: Constructs a ScoreDoc.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ScoreDoc(
    int doc,
    float score
)
public ScoreDoc(
    int doc,
    float score
)
Public Sub New ( _
    doc As Integer, _
    score As Single _
)
Public Sub New ( _
    doc As Integer, _
    score As Single _
)
public:
ScoreDoc(
    int doc,
    float score
)
public:
ScoreDoc(
    int doc,
    float score
)
Parameters
doc
Type:   Online System Int32
score
Type:   Online System Single
See Also
ScoreDoc Class
ScoreDoc Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ScoreDoc Methods

ScoreDoc Methods Lucene.Net Class Library
The ScoreDoc type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
ScoreDoc Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

ScoreDoc ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
ScoreDoc Class
ScoreDoc Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ScoreDoc Properties

ScoreDoc Properties Lucene.Net Class Library
The ScoreDoc type exposes the following members.
Properties
 | Name | Description
Public property | Doc | Expert: A hit document's number.
Public property | Score | Expert: The score of this document for the query.
Back to Top
See Also
ScoreDoc Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Property

ScoreDoc Doc Property Lucene.Net Class Library
Expert: A hit document's number.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Doc { get; set; }
public int Doc { get; set; }
Public Property Doc As Integer
    Get
    Set
Public Property Doc As Integer
    Get
    Set
public:
property int Doc {
    int get ();
    void set (int value);
}
public:
property int Doc {
    int get ();
    void set (int value);
}
See Also
ScoreDoc Class
ScoreDoc Members
Lucene.Net.Search Namespace
Searcher Doc(Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Property

ScoreDoc Score Property Lucene.Net Class Library
Expert: The score of this document for the query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Score { get; set; }
public float Score { get; set; }
Public Property Score As Single
    Get
    Set
Public Property Score As Single
    Get
    Set
public:
property float Score {
    float get ();
    void set (float value);
}
public:
property float Score {
    float get ();
    void set (float value);
}
See Also
ScoreDoc Class
ScoreDoc Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Scorer Class

Scorer Class Lucene.Net Class Library
Expert: Common scoring functionality for different types of queries.

A Scorer iterates over documents matching a query in increasing order of doc Id.

Document scores are computed using a given Similarity implementation.

NOTE: The values Float.Nan, Float.NEGATIVE_INFINITY and Float.POSITIVE_INFINITY are not valid scores. Certain collectors (eg TopScoreDocCollector ) will not properly collect hits with these scores.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSetIterator
Lucene.Net.Search Scorer
Lucene.Net.Search BooleanScorer
Lucene.Net.Search ConstantScoreQuery ConstantScorer
Lucene.Net.Search ScoreCachingWrappingScorer
Lucene.Net.Search.Spans SpanScorer
Lucene.Net.Search TermScorer

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Scorer : DocIdSetIterator
public abstract class Scorer : DocIdSetIterator
Public MustInherit Class Scorer _
    Inherits DocIdSetIterator
Public MustInherit Class Scorer _
    Inherits DocIdSetIterator
public ref class Scorer abstract : public DocIdSetIterator
public ref class Scorer abstract : public DocIdSetIterator
See Also
Scorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Scorer Members

Scorer Members Lucene.Net Class Library

The Scorer type exposes the following members.
Constructors
 | Name | Description
Protected method | Scorer | Constructs a Scorer.
Back to Top
Methods
Name Description
Public method Advance
Advances to the first beyond the current whose document number is greater than or equal to target. Returns the current document number or NO_MORE_DOCS if there are no more docs in the set.

Behaves as if written:
View Colorized Copy to Clipboard Print
int advance(int target) {
    int doc;
    while ((doc = nextDoc()) < target) {
    }
    return doc;
}
int advance(int target) {
    int doc;
    while ((doc = nextDoc()) < target) {
    }
    return doc;
}
Some implementations are considerably more efficient than that.

NOTE: certain implemenations may return a different value (each time) if called several times in a row with the same target.

NOTE: this method may be called with NO_MORE_DOCS for efficiency by some Scorers. If your implementation cannot efficiently determine that it should exhaust, it is recommended that you check for that value in each call to this method.

NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.

(Inherited from DocIdSetIterator.)
Public method DocID
Returns the following:
  • -1 or NO_MORE_DOCS if NextDoc or Advance(Int32) were not called yet.
  • NO_MORE_DOCS if the iterator has exhausted.
  • Otherwise it should return the doc ID it is currently on.

(Inherited from DocIdSetIterator.)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method NextDoc
Advances to the next document in the set and returns the doc it is currently on, or NO_MORE_DOCS if there are no more docs in the set.
NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.
(Inherited from DocIdSetIterator.)
Public method Score
Returns the score of the current document matching the query. Initially invalid, until NextDoc or Advance(Int32) is called the first time, or when called from within Collect(Int32).
Public method Score(Collector)
Scores and collects all matching documents.
Public method Score(Collector, Int32, Int32)
Expert: Collects matching documents in a range. Hook for optimization. Note, firstDocID is added to ensure that NextDoc was called before this method.
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Similarity | Returns the Similarity implementation used by this scorer.
Back to Top
See Also
Scorer Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Scorer Constructor

Scorer Constructor Lucene.Net Class Library
Constructs a Scorer.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Scorer(
    Similarity similarity
)
protected Scorer(
    Similarity similarity
)
Protected Sub New ( _
    similarity As Similarity _
)
Protected Sub New ( _
    similarity As Similarity _
)
protected:
Scorer(
    Similarity^ similarity
)
protected:
Scorer(
    Similarity^ similarity
)
Parameters
similarity
Type: Lucene.Net.Search Similarity
The Similarity implementation used by this scorer.

See Also
Scorer Class
Scorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Scorer Methods

Scorer Methods Lucene.Net Class Library
The Scorer type exposes the following members.
Methods
Name Description
Public method Advance
Advances to the first beyond the current whose document number is greater than or equal to target. Returns the current document number or NO_MORE_DOCS if there are no more docs in the set.

Behaves as if written:
View Colorized Copy to Clipboard Print
int advance(int target) {
    int doc;
    while ((doc = nextDoc()) < target) {
    }
    return doc;
}
int advance(int target) {
    int doc;
    while ((doc = nextDoc()) < target) {
    }
    return doc;
}
Some implementations are considerably more efficient than that.

NOTE: certain implemenations may return a different value (each time) if called several times in a row with the same target.

NOTE: this method may be called with NO_MORE_DOCS for efficiency by some Scorers. If your implementation cannot efficiently determine that it should exhaust, it is recommended that you check for that value in each call to this method.

NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.

(Inherited from DocIdSetIterator.)
Public method DocID
Returns the following:
  • -1 or NO_MORE_DOCS if NextDoc or Advance(Int32) were not called yet.
  • NO_MORE_DOCS if the iterator has exhausted.
  • Otherwise it should return the doc ID it is currently on.

(Inherited from DocIdSetIterator.)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method NextDoc
Advances to the next document in the set and returns the doc it is currently on, or NO_MORE_DOCS if there are no more docs in the set.
NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.
(Inherited from DocIdSetIterator.)
Public method Score
Returns the score of the current document matching the query. Initially invalid, until NextDoc or Advance(Int32) is called the first time, or when called from within Collect(Int32).
Public method Score(Collector)
Scores and collects all matching documents.
Public method Score(Collector, Int32, Int32)
Expert: Collects matching documents in a range. Hook for optimization. Note, firstDocID is added to ensure that NextDoc was called before this method.
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
See Also
Scorer Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method

Scorer Score Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Score | Returns the score of the current document matching the query. Initially invalid, until NextDoc or Advance(Int32) is called the first time, or when called from within Collect(Int32).
Public method | Score(Collector) | Scores and collects all matching documents.
Public method | Score(Collector, Int32, Int32) | Expert: Collects matching documents in a range. Hook for optimization. Note, firstDocID is added to ensure that NextDoc was called before this method.
Back to Top
See Also
Scorer Class
Scorer Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method

Scorer Score Method Lucene.Net Class Library
Returns the score of the current document matching the query. Initially invalid, until NextDoc or Advance(Int32) is called the first time, or when called from within Collect(Int32).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract float Score()
public abstract float Score()
Public MustOverride Function Score As Single
Public MustOverride Function Score As Single
public:
virtual float Score() abstract
public:
virtual float Score() abstract
See Also
Scorer Class
Scorer Members
Score Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method (Collector)

Scorer Score Method (Collector) Lucene.Net Class Library
Scores and collects all matching documents.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Score(
    Collector collector
)
public virtual void Score(
    Collector collector
)
Public Overridable Sub Score ( _
    collector As Collector _
)
Public Overridable Sub Score ( _
    collector As Collector _
)
public:
virtual void Score(
    Collector^ collector
)
public:
virtual void Score(
    Collector^ collector
)
Parameters
collector
Type: Lucene.Net.Search Collector
The collector to which all matching documents are passed.

See Also
Scorer Class
Scorer Members
Score Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method (Collector, Int32, Int32)

Scorer Score Method (Collector, Int32, Int32) Lucene.Net Class Library
Expert: Collects matching documents in a range. Hook for optimization. Note, firstDocID is added to ensure that NextDoc was called before this method.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Score(
    Collector collector,
    int max,
    int firstDocID
)
public virtual bool Score(
    Collector collector,
    int max,
    int firstDocID
)
Public Overridable Function Score ( _
    collector As Collector, _
    max As Integer, _
    firstDocID As Integer _
) As Boolean
Public Overridable Function Score ( _
    collector As Collector, _
    max As Integer, _
    firstDocID As Integer _
) As Boolean
public:
virtual bool Score(
    Collector^ collector,
    int max,
    int firstDocID
)
public:
virtual bool Score(
    Collector^ collector,
    int max,
    int firstDocID
)
Parameters
collector
Type: Lucene.Net.Search Collector
The collector to which all matching documents are passed.

max
Type:   Online System Int32
Do not score documents past this.

firstDocID
Type:   Online System Int32

            The first document ID (ensures NextDoc  is called before
            this method.

Return Value
 true if more matching documents may remain.

See Also
Scorer Class
Scorer Members
Score Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Scorer Properties

Scorer Properties Lucene.Net Class Library
The Scorer type exposes the following members.
Properties
 | Name | Description
Public property | Similarity | Returns the Similarity implementation used by this scorer.
Back to Top
See Also
Scorer Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Similarity Property

Scorer Similarity Property Lucene.Net Class Library
Returns the Similarity implementation used by this scorer.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Similarity Similarity { get; }
public virtual Similarity Similarity { get; }
Public Overridable ReadOnly Property Similarity As Similarity
    Get
Public Overridable ReadOnly Property Similarity As Similarity
    Get
public:
virtual property Similarity^ Similarity {
    Similarity^ get ();
}
public:
virtual property Similarity^ Similarity {
    Similarity^ get ();
}
See Also
Scorer Class
Scorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Searchable Interface

Searchable Interface Lucene.Net Class Library
The interface for search implementations.

Searchable is the abstract network protocol for searching. Implementations provide search over a single index, over multiple indices, and over indices on remote servers.

Queries, filters and sort criteria are designed to be compact so that they may be efficiently passed to a remote index, with only the top-scoring hits being returned, rather than every matching hit. NOTE: this interface is kept public for convenience. Since it is not expected to be implemented directly, it may be changed unexpectedly between releases.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface Searchable : IDisposable
public interface Searchable : IDisposable
Public Interface Searchable _
    Inherits IDisposable
Public Interface Searchable _
    Inherits IDisposable
public interface class Searchable : IDisposable
public interface class Searchable : IDisposable
See Also
Searchable Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Searchable Members

Searchable Members Lucene.Net Class Library

The Searchable type exposes the following members.
Methods
Name Description
Public method Close
Frees resources associated with this Searcher. Be careful not to call this method while you are still using objects that reference this searchable
Public method Online Dispose
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
(Inherited from Online IDisposable.)
Public method Doc(Int32)
Expert: Returns the stored fields of document i.
Public method Doc(Int32, FieldSelector)
Get the Documentat the nth position. The FieldSelector may be used to determine what Fields to load and how they should be loaded. NOTE: If the underlying Reader (more specifically, the underlying FieldsReader) is closed before the lazy Field is loaded an exception may be thrown. If you want the value of a lazy Field to be available after closing you must explicitly load it or fetch the Document again with a new loader.
Public method DocFreq
Expert: Returns the number of documents containing term. Called by search code to compute term weights.
Public method DocFreqs
Expert: For each term in the terms array, calculates the number of documents containing term. Returns an array with these document frequencies. Used to minimize number of remote calls.
Public method Explain
Expert: low-level implementation method Returns an Explanation that describes how doc scored against weight.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

Applications should call Explain(Query, Int32).
Public method Rewrite
Expert: called to re-write queries into primitive queries.
Public method Search(Weight, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32)) is usually more efficient, as it skips non-high-scoring hits.
Public method Search(Weight, Filter, Int32)
Expert: Low-level search implementation. Finds the top n hits for query, applying filter if non-null.

Applications should usually call Search(Query, Int32) or Search(Query, Filter, Int32) instead.
Public method Search(Weight, Filter, Int32, Sort)
Expert: Low-level search implementation with arbitrary sorting. Finds the top n hits for query, applying filter if non-null, and sorting the hits by the criteria in sort.

Applications should usually call Search(Query, Filter, Int32, Sort) instead.
Back to Top
Properties
 | Name | Description
Public property | MaxDoc | Expert: Returns one greater than the largest possible document number. Called by search code to compute term weights.
Back to Top
See Also
Searchable Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Searchable Methods

Searchable Methods Lucene.Net Class Library
The Searchable type exposes the following members.
Methods
Name Description
Public method Close
Frees resources associated with this Searcher. Be careful not to call this method while you are still using objects that reference this searchable
Public method Online Dispose
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
(Inherited from Online IDisposable.)
Public method Doc(Int32)
Expert: Returns the stored fields of document i.
Public method Doc(Int32, FieldSelector)
Get the Documentat the nth position. The FieldSelector may be used to determine what Fields to load and how they should be loaded. NOTE: If the underlying Reader (more specifically, the underlying FieldsReader) is closed before the lazy Field is loaded an exception may be thrown. If you want the value of a lazy Field to be available after closing you must explicitly load it or fetch the Document again with a new loader.
Public method DocFreq
Expert: Returns the number of documents containing term. Called by search code to compute term weights.
Public method DocFreqs
Expert: For each term in the terms array, calculates the number of documents containing term. Returns an array with these document frequencies. Used to minimize number of remote calls.
Public method Explain
Expert: low-level implementation method Returns an Explanation that describes how doc scored against weight.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

Applications should call Explain(Query, Int32).
Public method Rewrite
Expert: called to re-write queries into primitive queries.
Public method Search(Weight, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32)) is usually more efficient, as it skips non-high-scoring hits.
Public method Search(Weight, Filter, Int32)
Expert: Low-level search implementation. Finds the top n hits for query, applying filter if non-null.

Applications should usually call Search(Query, Int32) or Search(Query, Filter, Int32) instead.
Public method Search(Weight, Filter, Int32, Sort)
Expert: Low-level search implementation with arbitrary sorting. Finds the top n hits for query, applying filter if non-null, and sorting the hits by the criteria in sort.

Applications should usually call Search(Query, Filter, Int32, Sort) instead.
Back to Top
See Also
Searchable Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

Searchable Close Method Lucene.Net Class Library
Frees resources associated with this Searcher. Be careful not to call this method while you are still using objects that reference this searchable

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Close()
void Close()
Sub Close
Sub Close
void Close()
void Close()
See Also
Searchable Interface
Searchable Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Method

Searchable Doc Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Doc(Int32) | Expert: Returns the stored fields of document i.
Public method | Doc(Int32, FieldSelector) | Get the Documentat the nth position. The FieldSelector may be used to determine what Fields to load and how they should be loaded. NOTE: If the underlying Reader (more specifically, the underlying FieldsReader) is closed before the lazy Field is loaded an exception may be thrown. If you want the value of a lazy Field to be available after closing you must explicitly load it or fetch the Document again with a new loader.
Back to Top
See Also
Searchable Interface
Searchable Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Method (Int32)

Searchable Doc Method (Int32) Lucene.Net Class Library
Expert: Returns the stored fields of document i.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Document Doc(
    int i
)
Document Doc(
    int i
)
Function Doc ( _
    i As Integer _
) As Document
Function Doc ( _
    i As Integer _
) As Document
Document^ Doc(
    int i
)
Document^ Doc(
    int i
)
Parameters
i
Type:   Online System Int32
See Also
Searchable Interface
Searchable Members
Doc Overload
Lucene.Net.Search Namespace
IndexReader Document(Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Method (Int32, FieldSelector)

Searchable Doc Method (Int32, FieldSelector) Lucene.Net Class Library
Get the Documentat the nth position. The FieldSelector may be used to determine what Fields to load and how they should be loaded. NOTE: If the underlying Reader (more specifically, the underlying FieldsReader) is closed before the lazy Field is loaded an exception may be thrown. If you want the value of a lazy Field to be available after closing you must explicitly load it or fetch the Document again with a new loader.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Document Doc(
    int n,
    FieldSelector fieldSelector
)
Document Doc(
    int n,
    FieldSelector fieldSelector
)
Function Doc ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Function Doc ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Document^ Doc(
    int n,
    FieldSelector^ fieldSelector
)
Document^ Doc(
    int n,
    FieldSelector^ fieldSelector
)
Parameters
n
Type:   Online System Int32
Get the document at the nth position

fieldSelector
Type: Lucene.Net.Documents FieldSelector
The FieldSelector to use to determine what Fields should be loaded on the Document.  May be null, in which case all Fields will be loaded.

Return Value
 The stored fields of the Document at the nth position

See Also
Searchable Interface
Searchable Members
Doc Overload
Lucene.Net.Search Namespace
IndexReader Document(Int32, FieldSelector)
Lucene.Net.Documents IFieldable
Lucene.Net.Documents FieldSelector
Lucene.Net.Documents SetBasedFieldSelector
Lucene.Net.Documents LoadFirstFieldSelector
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocFreq Method

Searchable DocFreq Method Lucene.Net Class Library
Expert: Returns the number of documents containing term. Called by search code to compute term weights.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int DocFreq(
    Term term
)
int DocFreq(
    Term term
)
Function DocFreq ( _
    term As Term _
) As Integer
Function DocFreq ( _
    term As Term _
) As Integer
int DocFreq(
    Term^ term
)
int DocFreq(
    Term^ term
)
Parameters
term
Type: Lucene.Net.Index Term
See Also
Searchable Interface
Searchable Members
Lucene.Net.Search Namespace
IndexReader DocFreq(Term)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocFreqs Method

Searchable DocFreqs Method Lucene.Net Class Library
Expert: For each term in the terms array, calculates the number of documents containing term. Returns an array with these document frequencies. Used to minimize number of remote calls.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int[] DocFreqs(
    Term[] terms
)
int[] DocFreqs(
    Term[] terms
)
Function DocFreqs ( _
    terms As Term() _
) As Integer()
Function DocFreqs ( _
    terms As Term() _
) As Integer()
array<int>^ DocFreqs(
    array<Term^>^ terms
)
array<int>^ DocFreqs(
    array<Term^>^ terms
)
Parameters
terms
Type:  Lucene.Net.Index Term
See Also
Searchable Interface
Searchable Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method

Searchable Explain Method Lucene.Net Class Library
Expert: low-level implementation method Returns an Explanation that describes how doc scored against weight.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

Applications should call Explain(Query, Int32).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Explanation Explain(
    Weight weight,
    int doc
)
Explanation Explain(
    Weight weight,
    int doc
)
Function Explain ( _
    weight As Weight, _
    doc As Integer _
) As Explanation
Function Explain ( _
    weight As Weight, _
    doc As Integer _
) As Explanation
Explanation^ Explain(
    Weight^ weight,
    int doc
)
Explanation^ Explain(
    Weight^ weight,
    int doc
)
Parameters
weight
Type: Lucene.Net.Search Weight
doc
Type:   Online System Int32
See Also
Searchable Interface
Searchable Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

Searchable Rewrite Method Lucene.Net Class Library
Expert: called to re-write queries into primitive queries.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Query Rewrite(
    Query query
)
Query Rewrite(
    Query query
)
Function Rewrite ( _
    query As Query _
) As Query
Function Rewrite ( _
    query As Query _
) As Query
Query^ Rewrite(
    Query^ query
)
Query^ Rewrite(
    Query^ query
)
Parameters
query
Type: Lucene.Net.Search Query
See Also
Searchable Interface
Searchable Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method

Searchable Search Method Lucene.Net Class Library
Overload List
Name Description
Public method Search(Weight, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32)) is usually more efficient, as it skips non-high-scoring hits.
Public method Search(Weight, Filter, Int32)
Expert: Low-level search implementation. Finds the top n hits for query, applying filter if non-null.

Applications should usually call Search(Query, Int32) or Search(Query, Filter, Int32) instead.
Public method Search(Weight, Filter, Int32, Sort)
Expert: Low-level search implementation with arbitrary sorting. Finds the top n hits for query, applying filter if non-null, and sorting the hits by the criteria in sort.

Applications should usually call Search(Query, Filter, Int32, Sort) instead.
Back to Top
See Also
Searchable Interface
Searchable Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Weight, Filter, Collector)

Searchable Search Method (Weight, Filter, Collector) Lucene.Net Class Library
Lower-level search API.

Collect(Int32) is called for every document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32)) is usually more efficient, as it skips non-high-scoring hits.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Search(
    Weight weight,
    Filter filter,
    Collector collector
)
void Search(
    Weight weight,
    Filter filter,
    Collector collector
)
Sub Search ( _
    weight As Weight, _
    filter As Filter, _
    collector As Collector _
)
Sub Search ( _
    weight As Weight, _
    filter As Filter, _
    collector As Collector _
)
void Search(
    Weight^ weight,
    Filter^ filter,
    Collector^ collector
)
void Search(
    Weight^ weight,
    Filter^ filter,
    Collector^ collector
)
Parameters
weight
Type: Lucene.Net.Search Weight
to match documents

filter
Type: Lucene.Net.Search Filter
if non-null, used to permit documents to be collected.

collector
Type: Lucene.Net.Search Collector
to receive hits

See Also
Searchable Interface
Searchable Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Weight, Filter, Int32)

Searchable Search Method (Weight, Filter, Int32) Lucene.Net Class Library
Expert: Low-level search implementation. Finds the top n hits for query, applying filter if non-null.

Applications should usually call Search(Query, Int32) or Search(Query, Filter, Int32) instead.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TopDocs Search(
    Weight weight,
    Filter filter,
    int n
)
TopDocs Search(
    Weight weight,
    Filter filter,
    int n
)
Function Search ( _
    weight As Weight, _
    filter As Filter, _
    n As Integer _
) As TopDocs
Function Search ( _
    weight As Weight, _
    filter As Filter, _
    n As Integer _
) As TopDocs
TopDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int n
)
TopDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int n
)
Parameters
weight
Type: Lucene.Net.Search Weight
filter
Type: Lucene.Net.Search Filter
n
Type:   Online System Int32
See Also
Searchable Interface
Searchable Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Weight, Filter, Int32, Sort)

Searchable Search Method (Weight, Filter, Int32, Sort) Lucene.Net Class Library
Expert: Low-level search implementation with arbitrary sorting. Finds the top n hits for query, applying filter if non-null, and sorting the hits by the criteria in sort.

Applications should usually call Search(Query, Filter, Int32, Sort) instead.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int n,
    Sort sort
)
TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int n,
    Sort sort
)
Function Search ( _
    weight As Weight, _
    filter As Filter, _
    n As Integer, _
    sort As Sort _
) As TopFieldDocs
Function Search ( _
    weight As Weight, _
    filter As Filter, _
    n As Integer, _
    sort As Sort _
) As TopFieldDocs
TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int n,
    Sort^ sort
)
TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int n,
    Sort^ sort
)
Parameters
weight
Type: Lucene.Net.Search Weight
filter
Type: Lucene.Net.Search Filter
n
Type:   Online System Int32
sort
Type: Lucene.Net.Search Sort
See Also
Searchable Interface
Searchable Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Searchable Properties

Searchable Properties Lucene.Net Class Library
The Searchable type exposes the following members.
Properties
 | Name | Description
Public property | MaxDoc | Expert: Returns one greater than the largest possible document number. Called by search code to compute term weights.
Back to Top
See Also
Searchable Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxDoc Property

Searchable MaxDoc Property Lucene.Net Class Library
Expert: Returns one greater than the largest possible document number. Called by search code to compute term weights.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int MaxDoc { get; }
int MaxDoc { get; }
ReadOnly Property MaxDoc As Integer
    Get
ReadOnly Property MaxDoc As Integer
    Get
property int MaxDoc {
    int get ();
}
property int MaxDoc {
    int get ();
}
See Also
Searchable Interface
Searchable Members
Lucene.Net.Search Namespace
IndexReader MaxDoc
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Searcher Class

Searcher Class Lucene.Net Class Library
An abstract base class for search implementations. Implements the main search methods.

Note that you can only access hits from a Searcher as long as it is not yet closed, otherwise an IOException will be thrown.
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Lucene.Net.Search Searcher
Lucene.Net.Search IndexSearcher
Lucene.Net.Search MultiSearcher

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Searcher : MarshalByRefObject,
    Searchable, IDisposable
public abstract class Searcher : MarshalByRefObject,
    Searchable, IDisposable
Public MustInherit Class Searcher _
    Inherits MarshalByRefObject _
    Implements Searchable, IDisposable
Public MustInherit Class Searcher _
    Inherits MarshalByRefObject _
    Implements Searchable, IDisposable
public ref class Searcher abstract : public MarshalByRefObject,
    Searchable, IDisposable
public ref class Searcher abstract : public MarshalByRefObject,
    Searchable, IDisposable
See Also
Searcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Searcher Members

Searcher Members Lucene.Net Class Library

The Searcher type exposes the following members.
Constructors
 | Name | Description
Protected method | Searcher | Initializes a new instance of the Searcher class
Back to Top
Methods
Name | Description
Public method | Close | Obsolete.
Public method Online CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from Online MarshalByRefObject.)
Public method CreateWeight
creates a weight for query
Public method Dispose
Releases all resources used by the Searcher
Protected method Dispose(Boolean)
Releases the unmanaged resources used by the Searcher and optionally releases the managed resources
Public method | Doc(Int32)
Public method | Doc(Int32, FieldSelector)
Public method | DocFreq
Public method | DocFreqs
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Public method Explain(Query, Int32)
Returns an Explanation that describes how doc scored against query.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.
Public method | Explain(Weight, Int32)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from Online MarshalByRefObject.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method Online InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from Online MarshalByRefObject.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Protected method Online MemberwiseClone(Boolean)
Creates a shallow copy of the current Online MarshalByRefObject object.
(Inherited from Online MarshalByRefObject.)
Public method | Rewrite
Public method Search(Query, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32) ) is usually more efficient, as it skips non-high-scoring hits.

Note: The score passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
Public method Search(Query, Int32)
Finds the top n hits for query.
Public method Search(Query, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Filter, Int32)) is usually more efficient, as it skips non-high-scoring hits.
Public method Search(Query, Filter, Int32)
Finds the top n hits for query, applying filter if non-null.
Public method | Search(Weight, Filter, Collector)
Public method | Search(Weight, Filter, Int32)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top n hits for query, applying filter if non-null, and sorting the hits by the criteria in sort.

NOTE: this does not compute scores by default; use SetDefaultFieldSortScoring(Boolean, Boolean) to enable scoring.
Public method | Search(Weight, Filter, Int32, Sort)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | MaxDoc |
Public property | Similarity | Expert: Gets or Sets the Similarity implementation used by this Searcher.
Back to Top
See Also
Searcher Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Searcher Constructor

Searcher Constructor Lucene.Net Class Library
Initializes a new instance of the Searcher class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Searcher()
protected Searcher()
Protected Sub New
Protected Sub New
protected:
Searcher()
protected:
Searcher()
See Also
Searcher Class
Searcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Searcher Methods

Searcher Methods Lucene.Net Class Library
The Searcher type exposes the following members.
Methods
Name | Description
Public method | Close | Obsolete.
Public method Online CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from Online MarshalByRefObject.)
Public method CreateWeight
creates a weight for query
Public method | Dispose
Protected method | Dispose(Boolean)
Public method | Doc(Int32)
Public method | Doc(Int32, FieldSelector)
Public method | DocFreq
Public method | DocFreqs
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Public method Explain(Query, Int32)
Returns an Explanation that describes how doc scored against query.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.
Public method | Explain(Weight, Int32)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from Online MarshalByRefObject.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method Online InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from Online MarshalByRefObject.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Protected method Online MemberwiseClone(Boolean)
Creates a shallow copy of the current Online MarshalByRefObject object.
(Inherited from Online MarshalByRefObject.)
Public method | Rewrite
Public method Search(Query, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32) ) is usually more efficient, as it skips non-high-scoring hits.

Note: The score passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
Public method Search(Query, Int32)
Finds the top n hits for query.
Public method Search(Query, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Filter, Int32)) is usually more efficient, as it skips non-high-scoring hits.
Public method Search(Query, Filter, Int32)
Finds the top n hits for query, applying filter if non-null.
Public method | Search(Weight, Filter, Collector)
Public method | Search(Weight, Filter, Int32)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top n hits for query, applying filter if non-null, and sorting the hits by the criteria in sort.

NOTE: this does not compute scores by default; use SetDefaultFieldSortScoring(Boolean, Boolean) to enable scoring.
Public method | Search(Weight, Filter, Int32, Sort)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
See Also
Searcher Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

Searcher Close Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
virtual void Close() sealed
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
virtual void Close() sealed
Implements
Searchable Close
See Also
Searcher Class
Searcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateWeight Method

Searcher CreateWeight Method Lucene.Net Class Library
creates a weight for query

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Weight CreateWeight(
    Query query
)
public virtual Weight CreateWeight(
    Query query
)
Public Overridable Function CreateWeight ( _
    query As Query _
) As Weight
Public Overridable Function CreateWeight ( _
    query As Query _
) As Weight
public:
virtual Weight^ CreateWeight(
    Query^ query
)
public:
virtual Weight^ CreateWeight(
    Query^ query
)
Parameters
query
Type: Lucene.Net.Search Query
Return Value
 new weight

See Also
Searcher Class
Searcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

Searcher Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Searcher
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Searcher and optionally releases the managed resources
Back to Top
See Also
Searcher Class
Searcher Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

Searcher Dispose Method Lucene.Net Class Library
Releases all resources used by the Searcher

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
Searcher Class
Searcher Members
Dispose Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

Searcher Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the Searcher and optionally releases the managed resources

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void Dispose(
    bool disposing
)
protected abstract void Dispose(
    bool disposing
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) abstract
protected:
virtual void Dispose(
    bool disposing
) abstract
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
Searcher Class
Searcher Members
Dispose Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Method

Searcher Doc Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Doc(Int32) |
Public method | Doc(Int32, FieldSelector) |
Back to Top
See Also
Searcher Class
Searcher Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Method (Int32)

Searcher Doc Method (Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Document Doc(
    int i
)
public abstract Document Doc(
    int i
)
Public MustOverride Function Doc ( _
    i As Integer _
) As Document
Public MustOverride Function Doc ( _
    i As Integer _
) As Document
public:
virtual Document^ Doc(
    int i
) abstract
public:
virtual Document^ Doc(
    int i
) abstract
Parameters
i
Type:   Online System Int32
Implements
Searchable Doc(Int32)
See Also
Searcher Class
Searcher Members
Doc Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Method (Int32, FieldSelector)

Searcher Doc Method (Int32, FieldSelector) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Document Doc(
    int docid,
    FieldSelector fieldSelector
)
public abstract Document Doc(
    int docid,
    FieldSelector fieldSelector
)
Public MustOverride Function Doc ( _
    docid As Integer, _
    fieldSelector As FieldSelector _
) As Document
Public MustOverride Function Doc ( _
    docid As Integer, _
    fieldSelector As FieldSelector _
) As Document
public:
virtual Document^ Doc(
    int docid,
    FieldSelector^ fieldSelector
) abstract
public:
virtual Document^ Doc(
    int docid,
    FieldSelector^ fieldSelector
) abstract
Parameters
docid
Type:   Online System Int32
fieldSelector
Type: Lucene.Net.Documents FieldSelector
Implements
Searchable Doc(Int32, FieldSelector)
See Also
Searcher Class
Searcher Members
Doc Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocFreq Method

Searcher DocFreq Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int DocFreq(
    Term term
)
public abstract int DocFreq(
    Term term
)
Public MustOverride Function DocFreq ( _
    term As Term _
) As Integer
Public MustOverride Function DocFreq ( _
    term As Term _
) As Integer
public:
virtual int DocFreq(
    Term^ term
) abstract
public:
virtual int DocFreq(
    Term^ term
) abstract
Parameters
term
Type: Lucene.Net.Index Term
Implements
Searchable DocFreq(Term)
See Also
Searcher Class
Searcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocFreqs Method

Searcher DocFreqs Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int[] DocFreqs(
    Term[] terms
)
public virtual int[] DocFreqs(
    Term[] terms
)
Public Overridable Function DocFreqs ( _
    terms As Term() _
) As Integer()
Public Overridable Function DocFreqs ( _
    terms As Term() _
) As Integer()
public:
virtual array<int>^ DocFreqs(
    array<Term^>^ terms
)
public:
virtual array<int>^ DocFreqs(
    array<Term^>^ terms
)
Parameters
terms
Type:  Lucene.Net.Index Term
Implements
Searchable DocFreqs( Term )
See Also
Searcher Class
Searcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method

Searcher Explain Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Explain(Query, Int32) | Returns an Explanation that describes how doc scored against query. This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.
Public method | Explain(Weight, Int32) |
Back to Top
See Also
Searcher Class
Searcher Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method (Query, Int32)

Searcher Explain Method (Query, Int32) Lucene.Net Class Library
Returns an Explanation that describes how doc scored against query.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Explanation Explain(
    Query query,
    int doc
)
public virtual Explanation Explain(
    Query query,
    int doc
)
Public Overridable Function Explain ( _
    query As Query, _
    doc As Integer _
) As Explanation
Public Overridable Function Explain ( _
    query As Query, _
    doc As Integer _
) As Explanation
public:
virtual Explanation^ Explain(
    Query^ query,
    int doc
)
public:
virtual Explanation^ Explain(
    Query^ query,
    int doc
)
Parameters
query
Type: Lucene.Net.Search Query
doc
Type:   Online System Int32
See Also
Searcher Class
Searcher Members
Explain Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method (Weight, Int32)

Searcher Explain Method (Weight, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Explanation Explain(
    Weight weight,
    int doc
)
public abstract Explanation Explain(
    Weight weight,
    int doc
)
Public MustOverride Function Explain ( _
    weight As Weight, _
    doc As Integer _
) As Explanation
Public MustOverride Function Explain ( _
    weight As Weight, _
    doc As Integer _
) As Explanation
public:
virtual Explanation^ Explain(
    Weight^ weight,
    int doc
) abstract
public:
virtual Explanation^ Explain(
    Weight^ weight,
    int doc
) abstract
Parameters
weight
Type: Lucene.Net.Search Weight
doc
Type:   Online System Int32
Implements
Searchable Explain(Weight, Int32)
See Also
Searcher Class
Searcher Members
Explain Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

Searcher Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Query Rewrite(
    Query query
)
public abstract Query Rewrite(
    Query query
)
Public MustOverride Function Rewrite ( _
    query As Query _
) As Query
Public MustOverride Function Rewrite ( _
    query As Query _
) As Query
public:
virtual Query^ Rewrite(
    Query^ query
) abstract
public:
virtual Query^ Rewrite(
    Query^ query
) abstract
Parameters
query
Type: Lucene.Net.Search Query
Implements
Searchable Rewrite(Query)
See Also
Searcher Class
Searcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method

Searcher Search Method Lucene.Net Class Library
Overload List
Name | Description
Public method Search(Query, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32) ) is usually more efficient, as it skips non-high-scoring hits.

Note: The score passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
Public method Search(Query, Int32)
Finds the top n hits for query.
Public method Search(Query, Filter, Collector)
Lower-level search API.

Collect(Int32) is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Filter, Int32)) is usually more efficient, as it skips non-high-scoring hits.
Public method Search(Query, Filter, Int32)
Finds the top n hits for query, applying filter if non-null.
Public method | Search(Weight, Filter, Collector)
Public method | Search(Weight, Filter, Int32)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top n hits for query, applying filter if non-null, and sorting the hits by the criteria in sort.

NOTE: this does not compute scores by default; use SetDefaultFieldSortScoring(Boolean, Boolean) to enable scoring.
Public method | Search(Weight, Filter, Int32, Sort)
Back to Top
See Also
Searcher Class
Searcher Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Query, Collector)

Searcher Search Method (Query, Collector) Lucene.Net Class Library
Lower-level search API.

Collect(Int32) is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Int32) ) is usually more efficient, as it skips non-high-scoring hits.

Note: The score passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Search(
    Query query,
    Collector results
)
public virtual void Search(
    Query query,
    Collector results
)
Public Overridable Sub Search ( _
    query As Query, _
    results As Collector _
)
Public Overridable Sub Search ( _
    query As Query, _
    results As Collector _
)
public:
virtual void Search(
    Query^ query,
    Collector^ results
)
public:
virtual void Search(
    Query^ query,
    Collector^ results
)
Parameters
query
Type: Lucene.Net.Search Query
results
Type: Lucene.Net.Search Collector
See Also
Searcher Class
Searcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Query, Int32)

Searcher Search Method (Query, Int32) Lucene.Net Class Library
Finds the top n hits for query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual TopDocs Search(
    Query query,
    int n
)
public virtual TopDocs Search(
    Query query,
    int n
)
Public Overridable Function Search ( _
    query As Query, _
    n As Integer _
) As TopDocs
Public Overridable Function Search ( _
    query As Query, _
    n As Integer _
) As TopDocs
public:
virtual TopDocs^ Search(
    Query^ query,
    int n
)
public:
virtual TopDocs^ Search(
    Query^ query,
    int n
)
Parameters
query
Type: Lucene.Net.Search Query
n
Type:   Online System Int32
See Also
Searcher Class
Searcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Query, Filter, Collector)

Searcher Search Method (Query, Filter, Collector) Lucene.Net Class Library
Lower-level search API.

Collect(Int32) is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API (Search(Query, Filter, Int32)) is usually more efficient, as it skips non-high-scoring hits.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Search(
    Query query,
    Filter filter,
    Collector results
)
public virtual void Search(
    Query query,
    Filter filter,
    Collector results
)
Public Overridable Sub Search ( _
    query As Query, _
    filter As Filter, _
    results As Collector _
)
Public Overridable Sub Search ( _
    query As Query, _
    filter As Filter, _
    results As Collector _
)
public:
virtual void Search(
    Query^ query,
    Filter^ filter,
    Collector^ results
)
public:
virtual void Search(
    Query^ query,
    Filter^ filter,
    Collector^ results
)
Parameters
query
Type: Lucene.Net.Search Query
to match documents

filter
Type: Lucene.Net.Search Filter
if non-null, used to permit documents to be collected.

results
Type: Lucene.Net.Search Collector
to receive hits

See Also
Searcher Class
Searcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Query, Filter, Int32)

Searcher Search Method (Query, Filter, Int32) Lucene.Net Class Library
Finds the top n hits for query, applying filter if non-null.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual TopDocs Search(
    Query query,
    Filter filter,
    int n
)
public virtual TopDocs Search(
    Query query,
    Filter filter,
    int n
)
Public Overridable Function Search ( _
    query As Query, _
    filter As Filter, _
    n As Integer _
) As TopDocs
Public Overridable Function Search ( _
    query As Query, _
    filter As Filter, _
    n As Integer _
) As TopDocs
public:
virtual TopDocs^ Search(
    Query^ query,
    Filter^ filter,
    int n
)
public:
virtual TopDocs^ Search(
    Query^ query,
    Filter^ filter,
    int n
)
Parameters
query
Type: Lucene.Net.Search Query
filter
Type: Lucene.Net.Search Filter
n
Type:   Online System Int32
See Also
Searcher Class
Searcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Weight, Filter, Collector)

Searcher Search Method (Weight, Filter, Collector) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Search(
    Weight weight,
    Filter filter,
    Collector results
)
public abstract void Search(
    Weight weight,
    Filter filter,
    Collector results
)
Public MustOverride Sub Search ( _
    weight As Weight, _
    filter As Filter, _
    results As Collector _
)
Public MustOverride Sub Search ( _
    weight As Weight, _
    filter As Filter, _
    results As Collector _
)
public:
virtual void Search(
    Weight^ weight,
    Filter^ filter,
    Collector^ results
) abstract
public:
virtual void Search(
    Weight^ weight,
    Filter^ filter,
    Collector^ results
) abstract
Parameters
weight
Type: Lucene.Net.Search Weight
filter
Type: Lucene.Net.Search Filter
results
Type: Lucene.Net.Search Collector
Implements
Searchable Search(Weight, Filter, Collector)
See Also
Searcher Class
Searcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Weight, Filter, Int32)

Searcher Search Method (Weight, Filter, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract TopDocs Search(
    Weight weight,
    Filter filter,
    int n
)
public abstract TopDocs Search(
    Weight weight,
    Filter filter,
    int n
)
Public MustOverride Function Search ( _
    weight As Weight, _
    filter As Filter, _
    n As Integer _
) As TopDocs
Public MustOverride Function Search ( _
    weight As Weight, _
    filter As Filter, _
    n As Integer _
) As TopDocs
public:
virtual TopDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int n
) abstract
public:
virtual TopDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int n
) abstract
Parameters
weight
Type: Lucene.Net.Search Weight
filter
Type: Lucene.Net.Search Filter
n
Type:   Online System Int32
Implements
Searchable Search(Weight, Filter, Int32)
See Also
Searcher Class
Searcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Query, Filter, Int32, Sort)

Searcher Search Method (Query, Filter, Int32, Sort) Lucene.Net Class Library
Search implementation with arbitrary sorting. Finds the top n hits for query, applying filter if non-null, and sorting the hits by the criteria in sort.

NOTE: this does not compute scores by default; use SetDefaultFieldSortScoring(Boolean, Boolean) to enable scoring.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual TopFieldDocs Search(
    Query query,
    Filter filter,
    int n,
    Sort sort
)
public virtual TopFieldDocs Search(
    Query query,
    Filter filter,
    int n,
    Sort sort
)
Public Overridable Function Search ( _
    query As Query, _
    filter As Filter, _
    n As Integer, _
    sort As Sort _
) As TopFieldDocs
Public Overridable Function Search ( _
    query As Query, _
    filter As Filter, _
    n As Integer, _
    sort As Sort _
) As TopFieldDocs
public:
virtual TopFieldDocs^ Search(
    Query^ query,
    Filter^ filter,
    int n,
    Sort^ sort
)
public:
virtual TopFieldDocs^ Search(
    Query^ query,
    Filter^ filter,
    int n,
    Sort^ sort
)
Parameters
query
Type: Lucene.Net.Search Query
filter
Type: Lucene.Net.Search Filter
n
Type:   Online System Int32
sort
Type: Lucene.Net.Search Sort
See Also
Searcher Class
Searcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Search Method (Weight, Filter, Int32, Sort)

Searcher Search Method (Weight, Filter, Int32, Sort) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int n,
    Sort sort
)
public abstract TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int n,
    Sort sort
)
Public MustOverride Function Search ( _
    weight As Weight, _
    filter As Filter, _
    n As Integer, _
    sort As Sort _
) As TopFieldDocs
Public MustOverride Function Search ( _
    weight As Weight, _
    filter As Filter, _
    n As Integer, _
    sort As Sort _
) As TopFieldDocs
public:
virtual TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int n,
    Sort^ sort
) abstract
public:
virtual TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int n,
    Sort^ sort
) abstract
Parameters
weight
Type: Lucene.Net.Search Weight
filter
Type: Lucene.Net.Search Filter
n
Type:   Online System Int32
sort
Type: Lucene.Net.Search Sort
Implements
Searchable Search(Weight, Filter, Int32, Sort)
See Also
Searcher Class
Searcher Members
Search Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Searcher Properties

Searcher Properties Lucene.Net Class Library
The Searcher type exposes the following members.
Properties
 | Name | Description
Public property | MaxDoc |
Public property | Similarity | Expert: Gets or Sets the Similarity implementation used by this Searcher.
Back to Top
See Also
Searcher Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxDoc Property

Searcher MaxDoc Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int MaxDoc { get; }
public abstract int MaxDoc { get; }
Public MustOverride ReadOnly Property MaxDoc As Integer
    Get
Public MustOverride ReadOnly Property MaxDoc As Integer
    Get
public:
virtual property int MaxDoc {
    int get () abstract;
}
public:
virtual property int MaxDoc {
    int get () abstract;
}
Implements
Searchable MaxDoc
See Also
Searcher Class
Searcher Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Similarity Property

Searcher Similarity Property Lucene.Net Class Library
Expert: Gets or Sets the Similarity implementation used by this Searcher.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Similarity Similarity { get; set; }
public virtual Similarity Similarity { get; set; }
Public Overridable Property Similarity As Similarity
    Get
    Set
Public Overridable Property Similarity As Similarity
    Get
    Set
public:
virtual property Similarity^ Similarity {
    Similarity^ get ();
    void set (Similarity^ value);
}
public:
virtual property Similarity^ Similarity {
    Similarity^ get ();
    void set (Similarity^ value);
}
See Also
Searcher Class
Searcher Members
Lucene.Net.Search Namespace
Similarity Default
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ShortParser Interface

ShortParser Interface Lucene.Net Class Library
Interface to parse shorts from document fields.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ShortParser : Parser
public interface ShortParser : Parser
Public Interface ShortParser _
    Inherits Parser
Public Interface ShortParser _
    Inherits Parser
public interface class ShortParser : Parser
public interface class ShortParser : Parser
See Also
ShortParser Members
Lucene.Net.Search Namespace
FieldCache GetShorts(IndexReader, String, ShortParser)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ShortParser Members

ShortParser Members Lucene.Net Class Library

The ShortParser type exposes the following members.
Methods
 | Name | Description
Public method | ParseShort | Return a short representation of this field's value.
Back to Top
See Also
ShortParser Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ShortParser Methods

ShortParser Methods Lucene.Net Class Library
The ShortParser type exposes the following members.
Methods
 | Name | Description
Public method | ParseShort | Return a short representation of this field's value.
Back to Top
See Also
ShortParser Interface
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseShort Method

ShortParser ParseShort Method Lucene.Net Class Library
Return a short representation of this field's value.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
short ParseShort(
    string string_Renamed
)
short ParseShort(
    string string_Renamed
)
Function ParseShort ( _
    string_Renamed As String _
) As Short
Function ParseShort ( _
    string_Renamed As String _
) As Short
short ParseShort(
    String^ string_Renamed
)
short ParseShort(
    String^ string_Renamed
)
Parameters
string_Renamed
Type:   Online System String
See Also
ShortParser Interface
ShortParser Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Similarity Class

Similarity Class Lucene.Net Class Library
Expert: Scoring API.

Subclasses implement search scoring.

The score of query q for document d correlates to the cosine-distance or dot-product between document and query vectors in a Online Vector Space Model (VSM) of Information Retrieval. A document whose vector is closer to the query vector in that model is scored higher. The score is computed as follows:

score(q,d) = coord(q,d) · queryNorm(q) · | ∑ | (tf(t in d) · idf(t)2 · t.Boost · norm(t,d))
 | t in q |

where
  • tf(t in d) correlates to the term's frequency, defined as the number of times term t appears in the currently scored document d. Documents that have more occurrences of a given term receive a higher score. The default computation for tf(t in d) in DefaultSimilarity is:

    tf(t in d) = frequency½

  • idf(t) stands for Inverse Document Frequency. This value correlates to the inverse of docFreq (the number of documents in which the term t appears). This means rarer terms give higher contribution to the total score. The default computation for idf(t) in DefaultSimilarity is:

    idf(t) = 1 + log (
    numDocs
    –––––––––
    docFreq+1
            )

  • coord(q,d) is a score factor based on how many of the query terms are found in the specified document. Typically, a document that contains more of the query's terms will receive a higher score than another document with fewer query terms. This is a search time factor computed in coord(q,d) by the Similarity in effect at search time.

  • queryNorm(q) is a normalizing factor used to make scores between queries comparable. This factor does not affect document ranking (since all ranked documents are multiplied by the same factor), but rather just attempts to make scores from different queries (or even different indexes) comparable. This is a search time factor computed by the Similarity in effect at search time. The default computation in DefaultSimilarity is:

    queryNorm(q) = queryNorm(sumOfSquaredWeights) =
    1
    ––––––––––––––
    sumOfSquaredWeights½

    The sum of squared weights (of the query terms) is computed by the query Weight object. For example, a boolean query computes this value as:

    GetSumOfSquaredWeights = q.Boost 2 · ∑ (idf(t) · t.Boost) 2
    t in q

  • t.Boost is a search time boost of term t in the query q as specified in the query text (see query syntax), or as set by application calls to Boost. Notice that there is really no direct API for accessing a boost of one term in a multi term query, but rather multi terms are represented in a query as multi TermQuery objects, and so the boost of a term in the query is accessible by calling the sub-query Boost.

  • norm(t,d) encapsulates a few (indexing time) boost and length factors:
    • Document boost - set by calling doc.Boost before adding the document to the index.
    • Field boost - set by calling field.Boost before adding the field to a document.
    • LengthNorm(field) - computed when the document is added to the index in accordance with the number of tokens of this field in the document, so that shorter fields contribute more to the score. LengthNorm is computed by the Similarity class in effect at indexing.

    When a document is added to the index, all the above factors are multiplied. If the document has multiple fields with the same name, all their boosts are multiplied together:

    norm(t,d) = doc.Boost · LengthNorm(field) · ∏ field.Boost
    field f in d named as t

    However the resulted norm value is encoded as a single byte before being stored. At search time, the norm byte value is read from the index directory and decoded back to a float norm value. This encoding/decoding, while reducing index size, comes with the price of precision loss - it is not guaranteed that decode(encode(x)) = x. For instance, decode(encode(0.89)) = 0.75. Also notice that search time is too late to modify this norm part of scoring, e.g. by using a different Similarity for search.

Inheritance Hierarchy
Online System Object
Lucene.Net.Search Similarity
Lucene.Net.Search DefaultSimilarity
Lucene.Net.Search SimilarityDelegator

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class Similarity
[SerializableAttribute]
public abstract class Similarity
<SerializableAttribute> _
Public MustInherit Class Similarity
<SerializableAttribute> _
Public MustInherit Class Similarity
[SerializableAttribute]
public ref class Similarity abstract
[SerializableAttribute]
public ref class Similarity abstract
See Also
Similarity Members
Lucene.Net.Search Namespace
Similarity Default
IndexWriter Similarity
Searcher Similarity
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Similarity Members

Similarity Members Lucene.Net Class Library

The Similarity type exposes the following members.
Constructors
 | Name | Description
Protected method | Similarity | Initializes a new instance of the Similarity class
Back to Top
Methods
Name Description
Public method ComputeNorm
Compute the normalization value for a field, given the accumulated state of term processing for this field (see FieldInvertState).

Implementations should calculate a float value based on the field state and then return that value.

For backward compatibility this method by default calls LengthNorm(String, Int32) passing Length as the second argument, and then multiplies this value by Boost.

WARNING: This API is new and experimental and may suddenly change.

Public method Coord
Computes a score factor based on the fraction of all query terms that a document contains. This value is multiplied into scores.

The presence of a large portion of the query terms indicates a better match with the query, so implementations of this method usually return larger values when the ratio between these parameters is large and smaller values when the ratio between them is small.
DecodeNorm
Decodes a normalization factor stored in an index.
EncodeNorm
Encodes a normalization factor for storage in an index.

The encoding uses a three-bit mantissa, a five-bit exponent, and the zero-exponent point at 15, thus representing values from around 7x10^9 to 2x10^-9 with about one significant decimal digit of accuracy. Zero is also represented. Negative numbers are rounded up to zero. Values too large to represent are rounded down to the largest representable value. Positive values too small to represent are rounded up to the smallest positive representable value.
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
GetNormDecoder
Returns a table for decoding normalization bytes.
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method Idf
Computes a score factor based on a term's document frequency (the number of documents which contain the term). This value is multiplied by the Tf(Int32) factor for each term in the query and these products are then summed to form the initial score for a document.

Terms that occur in fewer documents are better indicators of topic, so implementations of this method usually return larger values for rare terms, and smaller values for common terms.
Public method IdfExplain(Term, Searcher)
Computes a score factor for a simple term and returns an explanation for that score factor.

The default implementation uses:
View Colorized Copy to Clipboard Print
idf(searcher.docFreq(term), searcher.MaxDoc);
idf(searcher.docFreq(term), searcher.MaxDoc);
Note that MaxDoc is used instead of NumDocs because it is proportional to DocFreq(Term) , i.e., when one is inaccurate, so is the other, and in the same direction.
Public method IdfExplain(ICollection Term , Searcher)
Computes a score factor for a phrase.

The default implementation sums the idf factor for each term in the phrase.
Public method LengthNorm
Computes the normalization value for a field given the total number of terms contained in a field. These values, together with field boosts, are stored in an index and multipled into scores for hits on each field by the search code.

Matches in longer fields are less precise, so implementations of this method usually return smaller values when numTokens is large, and larger values when numTokens is small.

Note that the return values are computed under AddDocument(Document) and then stored using EncodeNorm(Single). Thus they have limited precision, and documents must be re-indexed if this method is altered.
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method QueryNorm
Computes the normalization value for a query given the sum of the squared weights of each of the query terms. This value is then multipled into the weight of each query term.

This does not affect ranking, but rather just attempts to make scores from different queries comparable.
Public method ScorePayload
Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array.

The default implementation returns 1.
Public method SloppyFreq
Computes the amount of a sloppy phrase match, based on an edit distance. This value is summed for each sloppy phrase match in a document to form the frequency that is passed to Tf(Single).

A phrase match with a small edit distance to a document passage more closely matches the document, so implementations of this method usually return larger values when the edit distance is small and smaller values when it is large.
Public method Tf(Int32)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the Idf(Int32, Int32) factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when freq is large, and smaller values when freq is small.

The default implementation calls Tf(Single).
Public method Tf(Single)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the Idf(Int32, Int32) factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when freq is large, and smaller values when freq is small.
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
Fields
Name | Description
NO_DOC_ID_PROVIDED |
Back to Top
Properties
Name | Description
Default | Gets or sets the default Similarity implementation used by indexing and search code. This is initially an instance of DefaultSimilarity.
Back to Top
See Also
Similarity Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Similarity Constructor

Similarity Constructor Lucene.Net Class Library
Initializes a new instance of the Similarity class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Similarity()
protected Similarity()
Protected Sub New
Protected Sub New
protected:
Similarity()
protected:
Similarity()
See Also
Similarity Class
Similarity Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Similarity Fields

Similarity Fields Lucene.Net Class Library
The Similarity type exposes the following members.
Fields
Name | Description
NO_DOC_ID_PROVIDED |
Back to Top
See Also
Similarity Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NO_DOC_ID_PROVIDED Field

Similarity NO_DOC_ID_PROVIDED Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int NO_DOC_ID_PROVIDED
public const int NO_DOC_ID_PROVIDED
Public Const NO_DOC_ID_PROVIDED As Integer
Public Const NO_DOC_ID_PROVIDED As Integer
public:
literal int NO_DOC_ID_PROVIDED
public:
literal int NO_DOC_ID_PROVIDED
See Also
Similarity Class
Similarity Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Similarity Methods

Similarity Methods Lucene.Net Class Library
The Similarity type exposes the following members.
Methods
Name Description
Public method ComputeNorm
Compute the normalization value for a field, given the accumulated state of term processing for this field (see FieldInvertState).

Implementations should calculate a float value based on the field state and then return that value.

For backward compatibility this method by default calls LengthNorm(String, Int32) passing Length as the second argument, and then multiplies this value by Boost.

WARNING: This API is new and experimental and may suddenly change.

Public method Coord
Computes a score factor based on the fraction of all query terms that a document contains. This value is multiplied into scores.

The presence of a large portion of the query terms indicates a better match with the query, so implementations of this method usually return larger values when the ratio between these parameters is large and smaller values when the ratio between them is small.
DecodeNorm
Decodes a normalization factor stored in an index.
EncodeNorm
Encodes a normalization factor for storage in an index.

The encoding uses a three-bit mantissa, a five-bit exponent, and the zero-exponent point at 15, thus representing values from around 7x10^9 to 2x10^-9 with about one significant decimal digit of accuracy. Zero is also represented. Negative numbers are rounded up to zero. Values too large to represent are rounded down to the largest representable value. Positive values too small to represent are rounded up to the smallest positive representable value.
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
GetNormDecoder
Returns a table for decoding normalization bytes.
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method Idf
Computes a score factor based on a term's document frequency (the number of documents which contain the term). This value is multiplied by the Tf(Int32) factor for each term in the query and these products are then summed to form the initial score for a document.

Terms that occur in fewer documents are better indicators of topic, so implementations of this method usually return larger values for rare terms, and smaller values for common terms.
Public method IdfExplain(Term, Searcher)
Computes a score factor for a simple term and returns an explanation for that score factor.

The default implementation uses:
View Colorized Copy to Clipboard Print
idf(searcher.docFreq(term), searcher.MaxDoc);
idf(searcher.docFreq(term), searcher.MaxDoc);
Note that MaxDoc is used instead of NumDocs because it is proportional to DocFreq(Term) , i.e., when one is inaccurate, so is the other, and in the same direction.
Public method IdfExplain(ICollection Term , Searcher)
Computes a score factor for a phrase.

The default implementation sums the idf factor for each term in the phrase.
Public method LengthNorm
Computes the normalization value for a field given the total number of terms contained in a field. These values, together with field boosts, are stored in an index and multipled into scores for hits on each field by the search code.

Matches in longer fields are less precise, so implementations of this method usually return smaller values when numTokens is large, and larger values when numTokens is small.

Note that the return values are computed under AddDocument(Document) and then stored using EncodeNorm(Single). Thus they have limited precision, and documents must be re-indexed if this method is altered.
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method QueryNorm
Computes the normalization value for a query given the sum of the squared weights of each of the query terms. This value is then multipled into the weight of each query term.

This does not affect ranking, but rather just attempts to make scores from different queries comparable.
Public method ScorePayload
Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array.

The default implementation returns 1.
Public method SloppyFreq
Computes the amount of a sloppy phrase match, based on an edit distance. This value is summed for each sloppy phrase match in a document to form the frequency that is passed to Tf(Single).

A phrase match with a small edit distance to a document passage more closely matches the document, so implementations of this method usually return larger values when the edit distance is small and smaller values when it is large.
Public method Tf(Int32)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the Idf(Int32, Int32) factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when freq is large, and smaller values when freq is small.

The default implementation calls Tf(Single).
Public method Tf(Single)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the Idf(Int32, Int32) factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when freq is large, and smaller values when freq is small.
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
See Also
Similarity Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ComputeNorm Method

Similarity ComputeNorm Method Lucene.Net Class Library
Compute the normalization value for a field, given the accumulated state of term processing for this field (see FieldInvertState).

Implementations should calculate a float value based on the field state and then return that value.

For backward compatibility this method by default calls LengthNorm(String, Int32) passing Length as the second argument, and then multiplies this value by Boost.

WARNING: This API is new and experimental and may suddenly change.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual float ComputeNorm(
    string field,
    FieldInvertState state
)
public virtual float ComputeNorm(
    string field,
    FieldInvertState state
)
Public Overridable Function ComputeNorm ( _
    field As String, _
    state As FieldInvertState _
) As Single
Public Overridable Function ComputeNorm ( _
    field As String, _
    state As FieldInvertState _
) As Single
public:
virtual float ComputeNorm(
    String^ field,
    FieldInvertState^ state
)
public:
virtual float ComputeNorm(
    String^ field,
    FieldInvertState^ state
)
Parameters
field
Type:   Online System String
field name

state
Type: Lucene.Net.Index FieldInvertState
current processing state for this field

Return Value
 the calculated float norm

See Also
Similarity Class
Similarity Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Coord Method

Similarity Coord Method Lucene.Net Class Library
Computes a score factor based on the fraction of all query terms that a document contains. This value is multiplied into scores.

The presence of a large portion of the query terms indicates a better match with the query, so implementations of this method usually return larger values when the ratio between these parameters is large and smaller values when the ratio between them is small.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract float Coord(
    int overlap,
    int maxOverlap
)
public abstract float Coord(
    int overlap,
    int maxOverlap
)
Public MustOverride Function Coord ( _
    overlap As Integer, _
    maxOverlap As Integer _
) As Single
Public MustOverride Function Coord ( _
    overlap As Integer, _
    maxOverlap As Integer _
) As Single
public:
virtual float Coord(
    int overlap,
    int maxOverlap
) abstract
public:
virtual float Coord(
    int overlap,
    int maxOverlap
) abstract
Parameters
overlap
Type:   Online System Int32
the number of query terms matched in the document

maxOverlap
Type:   Online System Int32
the total number of terms in the query

Return Value
 a score factor based on term overlap with the query

See Also
Similarity Class
Similarity Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DecodeNorm Method

Similarity DecodeNorm Method Lucene.Net Class Library
Decodes a normalization factor stored in an index.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static float DecodeNorm(
    byte b
)
public static float DecodeNorm(
    byte b
)
Public Shared Function DecodeNorm ( _
    b As Byte _
) As Single
Public Shared Function DecodeNorm ( _
    b As Byte _
) As Single
public:
static float DecodeNorm(
    unsigned char b
)
public:
static float DecodeNorm(
    unsigned char b
)
Parameters
b
Type:   Online System Byte
See Also
Similarity Class
Similarity Members
Lucene.Net.Search Namespace
Similarity EncodeNorm(Single)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EncodeNorm Method

Similarity EncodeNorm Method Lucene.Net Class Library
Encodes a normalization factor for storage in an index.

The encoding uses a three-bit mantissa, a five-bit exponent, and the zero-exponent point at 15, thus representing values from around 7x10^9 to 2x10^-9 with about one significant decimal digit of accuracy. Zero is also represented. Negative numbers are rounded up to zero. Values too large to represent are rounded down to the largest representable value. Positive values too small to represent are rounded up to the smallest positive representable value.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte EncodeNorm(
    float f
)
public static byte EncodeNorm(
    float f
)
Public Shared Function EncodeNorm ( _
    f As Single _
) As Byte
Public Shared Function EncodeNorm ( _
    f As Single _
) As Byte
public:
static unsigned char EncodeNorm(
    float f
)
public:
static unsigned char EncodeNorm(
    float f
)
Parameters
f
Type:   Online System Single
See Also
Similarity Class
Similarity Members
Lucene.Net.Search Namespace
AbstractField Boost
Lucene.Net.Util SmallFloat
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetNormDecoder Method

Similarity GetNormDecoder Method Lucene.Net Class Library
Returns a table for decoding normalization bytes.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static float[] GetNormDecoder()
public static float[] GetNormDecoder()
Public Shared Function GetNormDecoder As Single()
Public Shared Function GetNormDecoder As Single()
public:
static array<float>^ GetNormDecoder()
public:
static array<float>^ GetNormDecoder()
See Also
Similarity Class
Similarity Members
Lucene.Net.Search Namespace
Similarity EncodeNorm(Single)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Idf Method

Similarity Idf Method Lucene.Net Class Library
Computes a score factor based on a term's document frequency (the number of documents which contain the term). This value is multiplied by the Tf(Int32) factor for each term in the query and these products are then summed to form the initial score for a document.

Terms that occur in fewer documents are better indicators of topic, so implementations of this method usually return larger values for rare terms, and smaller values for common terms.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract float Idf(
    int docFreq,
    int numDocs
)
public abstract float Idf(
    int docFreq,
    int numDocs
)
Public MustOverride Function Idf ( _
    docFreq As Integer, _
    numDocs As Integer _
) As Single
Public MustOverride Function Idf ( _
    docFreq As Integer, _
    numDocs As Integer _
) As Single
public:
virtual float Idf(
    int docFreq,
    int numDocs
) abstract
public:
virtual float Idf(
    int docFreq,
    int numDocs
) abstract
Parameters
docFreq
Type:   Online System Int32
the number of documents which contain the term

numDocs
Type:   Online System Int32
the total number of documents in the collection

Return Value
 a score factor based on the term's document frequency

See Also
Similarity Class
Similarity Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IdfExplain Method

Similarity IdfExplain Method Lucene.Net Class Library
Overload List
Name Description
Public method IdfExplain(Term, Searcher)
Computes a score factor for a simple term and returns an explanation for that score factor.

The default implementation uses:
View Colorized Copy to Clipboard Print
idf(searcher.docFreq(term), searcher.MaxDoc);
idf(searcher.docFreq(term), searcher.MaxDoc);
Note that MaxDoc is used instead of NumDocs because it is proportional to DocFreq(Term) , i.e., when one is inaccurate, so is the other, and in the same direction.
Public method IdfExplain(ICollection Term , Searcher)
Computes a score factor for a phrase.

The default implementation sums the idf factor for each term in the phrase.
Back to Top
See Also
Similarity Class
Similarity Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IdfExplain Method (Term, Searcher)

Similarity IdfExplain Method (Term, Searcher) Lucene.Net Class Library
Computes a score factor for a simple term and returns an explanation for that score factor.

The default implementation uses:
View Colorized Copy to Clipboard Print
idf(searcher.docFreq(term), searcher.MaxDoc);
idf(searcher.docFreq(term), searcher.MaxDoc);
Note that MaxDoc is used instead of NumDocs because it is proportional to DocFreq(Term) , i.e., when one is inaccurate, so is the other, and in the same direction.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Explanation..::..IDFExplanation IdfExplain(
    Term term,
    Searcher searcher
)
public virtual Explanation..::..IDFExplanation IdfExplain(
    Term term,
    Searcher searcher
)
Public Overridable Function IdfExplain ( _
    term As Term, _
    searcher As Searcher _
) As Explanation..::..IDFExplanation
Public Overridable Function IdfExplain ( _
    term As Term, _
    searcher As Searcher _
) As Explanation..::..IDFExplanation
public:
virtual Explanation..::..IDFExplanation^ IdfExplain(
    Term^ term,
    Searcher^ searcher
)
public:
virtual Explanation..::..IDFExplanation^ IdfExplain(
    Term^ term,
    Searcher^ searcher
)
Parameters
term
Type: Lucene.Net.Index Term
the term in question

searcher
Type: Lucene.Net.Search Searcher
the document collection being searched

Return Value
 an IDFExplain object that includes both an idf score factor
            and an explanation for the term.

See Also
Similarity Class
Similarity Members
IdfExplain Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IdfExplain Method (ICollection(Term), Searcher)

Similarity IdfExplain Method (ICollection Term , Searcher) Lucene.Net Class Library
Computes a score factor for a phrase.

The default implementation sums the idf factor for each term in the phrase.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Explanation..::..IDFExplanation IdfExplain(
    ICollection<Term> terms,
    Searcher searcher
)
public virtual Explanation..::..IDFExplanation IdfExplain(
    ICollection<Term> terms,
    Searcher searcher
)
Public Overridable Function IdfExplain ( _
    terms As ICollection(Of Term), _
    searcher As Searcher _
) As Explanation..::..IDFExplanation
Public Overridable Function IdfExplain ( _
    terms As ICollection(Of Term), _
    searcher As Searcher _
) As Explanation..::..IDFExplanation
public:
virtual Explanation..::..IDFExplanation^ IdfExplain(
    ICollection<Term^>^ terms,
    Searcher^ searcher
)
public:
virtual Explanation..::..IDFExplanation^ IdfExplain(
    ICollection<Term^>^ terms,
    Searcher^ searcher
)
Parameters
terms
Type:   Online System.Collections.Generic ICollection  Term
the terms in the phrase

searcher
Type: Lucene.Net.Search Searcher
the document collection being searched

Return Value
 an IDFExplain object that includes both an idf
            score factor for the phrase and an explanation
            for each term.

See Also
Similarity Class
Similarity Members
IdfExplain Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LengthNorm Method

Similarity LengthNorm Method Lucene.Net Class Library
Computes the normalization value for a field given the total number of terms contained in a field. These values, together with field boosts, are stored in an index and multipled into scores for hits on each field by the search code.

Matches in longer fields are less precise, so implementations of this method usually return smaller values when numTokens is large, and larger values when numTokens is small.

Note that the return values are computed under AddDocument(Document) and then stored using EncodeNorm(Single). Thus they have limited precision, and documents must be re-indexed if this method is altered.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract float LengthNorm(
    string fieldName,
    int numTokens
)
public abstract float LengthNorm(
    string fieldName,
    int numTokens
)
Public MustOverride Function LengthNorm ( _
    fieldName As String, _
    numTokens As Integer _
) As Single
Public MustOverride Function LengthNorm ( _
    fieldName As String, _
    numTokens As Integer _
) As Single
public:
virtual float LengthNorm(
    String^ fieldName,
    int numTokens
) abstract
public:
virtual float LengthNorm(
    String^ fieldName,
    int numTokens
) abstract
Parameters
fieldName
Type:   Online System String
the name of the field

numTokens
Type:   Online System Int32
the total number of tokens contained in fields named
            fieldName of doc.

Return Value
 a normalization factor for hits on this field of this document

See Also
Similarity Class
Similarity Members
Lucene.Net.Search Namespace
AbstractField Boost
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryNorm Method

Similarity QueryNorm Method Lucene.Net Class Library
Computes the normalization value for a query given the sum of the squared weights of each of the query terms. This value is then multipled into the weight of each query term.

This does not affect ranking, but rather just attempts to make scores from different queries comparable.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract float QueryNorm(
    float sumOfSquaredWeights
)
public abstract float QueryNorm(
    float sumOfSquaredWeights
)
Public MustOverride Function QueryNorm ( _
    sumOfSquaredWeights As Single _
) As Single
Public MustOverride Function QueryNorm ( _
    sumOfSquaredWeights As Single _
) As Single
public:
virtual float QueryNorm(
    float sumOfSquaredWeights
) abstract
public:
virtual float QueryNorm(
    float sumOfSquaredWeights
) abstract
Parameters
sumOfSquaredWeights
Type:   Online System Single
the sum of the squares of query term weights

Return Value
 a normalization factor for query weights

See Also
Similarity Class
Similarity Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ScorePayload Method

Similarity ScorePayload Method Lucene.Net Class Library
Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array.

The default implementation returns 1.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual float ScorePayload(
    int docId,
    string fieldName,
    int start,
    int end,
    byte[] payload,
    int offset,
    int length
)
public virtual float ScorePayload(
    int docId,
    string fieldName,
    int start,
    int end,
    byte[] payload,
    int offset,
    int length
)
Public Overridable Function ScorePayload ( _
    docId As Integer, _
    fieldName As String, _
    start As Integer, _
    end As Integer, _
    payload As Byte(), _
    offset As Integer, _
    length As Integer _
) As Single
Public Overridable Function ScorePayload ( _
    docId As Integer, _
    fieldName As String, _
    start As Integer, _
    end As Integer, _
    payload As Byte(), _
    offset As Integer, _
    length As Integer _
) As Single
public:
virtual float ScorePayload(
    int docId,
    String^ fieldName,
    int start,
    int end,
    array<unsigned char>^ payload,
    int offset,
    int length
)
public:
virtual float ScorePayload(
    int docId,
    String^ fieldName,
    int start,
    int end,
    array<unsigned char>^ payload,
    int offset,
    int length
)
Parameters
docId
Type:   Online System Int32
The docId currently being scored.  If this value is NO_DOC_ID_PROVIDED, then it should be assumed that the PayloadQuery implementation does not provide document information

fieldName
Type:   Online System String
The fieldName of the term this payload belongs to

start
Type:   Online System Int32
The start position of the payload

end
Type:   Online System Int32
The end position of the payload

payload
Type:    Online System Byte
The payload byte array to be scored

offset
Type:   Online System Int32
The offset into the payload array

length
Type:   Online System Int32
The length in the array

Return Value
 An implementation dependent float to be used as a scoring factor

See Also
Similarity Class
Similarity Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SloppyFreq Method

Similarity SloppyFreq Method Lucene.Net Class Library
Computes the amount of a sloppy phrase match, based on an edit distance. This value is summed for each sloppy phrase match in a document to form the frequency that is passed to Tf(Single).

A phrase match with a small edit distance to a document passage more closely matches the document, so implementations of this method usually return larger values when the edit distance is small and smaller values when it is large.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract float SloppyFreq(
    int distance
)
public abstract float SloppyFreq(
    int distance
)
Public MustOverride Function SloppyFreq ( _
    distance As Integer _
) As Single
Public MustOverride Function SloppyFreq ( _
    distance As Integer _
) As Single
public:
virtual float SloppyFreq(
    int distance
) abstract
public:
virtual float SloppyFreq(
    int distance
) abstract
Parameters
distance
Type:   Online System Int32
the edit distance of this sloppy phrase match
Return Value
 the frequency increment for this match
See Also
Similarity Class
Similarity Members
Lucene.Net.Search Namespace
PhraseQuery Slop
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tf Method

Similarity Tf Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Tf(Int32) | Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the Idf(Int32, Int32) factor for each term in the query and these products are then summed to form the initial score for a document. Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when freq is large, and smaller values when freq is small. The default implementation calls Tf(Single).
Public method | Tf(Single) | Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the Idf(Int32, Int32) factor for each term in the query and these products are then summed to form the initial score for a document. Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when freq is large, and smaller values when freq is small.
Back to Top
See Also
Similarity Class
Similarity Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tf Method (Int32)

Similarity Tf Method (Int32) Lucene.Net Class Library
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the Idf(Int32, Int32) factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when freq is large, and smaller values when freq is small.

The default implementation calls Tf(Single).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual float Tf(
    int freq
)
public virtual float Tf(
    int freq
)
Public Overridable Function Tf ( _
    freq As Integer _
) As Single
Public Overridable Function Tf ( _
    freq As Integer _
) As Single
public:
virtual float Tf(
    int freq
)
public:
virtual float Tf(
    int freq
)
Parameters
freq
Type:   Online System Int32
the frequency of a term within a document

Return Value
 a score factor based on a term's within-document frequency

See Also
Similarity Class
Similarity Members
Tf Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tf Method (Single)

Similarity Tf Method (Single) Lucene.Net Class Library
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the Idf(Int32, Int32) factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when freq is large, and smaller values when freq is small.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract float Tf(
    float freq
)
public abstract float Tf(
    float freq
)
Public MustOverride Function Tf ( _
    freq As Single _
) As Single
Public MustOverride Function Tf ( _
    freq As Single _
) As Single
public:
virtual float Tf(
    float freq
) abstract
public:
virtual float Tf(
    float freq
) abstract
Parameters
freq
Type:   Online System Single
the frequency of a term within a document

Return Value
 a score factor based on a term's within-document frequency

See Also
Similarity Class
Similarity Members
Tf Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Similarity Properties

Similarity Properties Lucene.Net Class Library
The Similarity type exposes the following members.
Properties
Name | Description
Default | Gets or sets the default Similarity implementation used by indexing and search code. This is initially an instance of DefaultSimilarity.
Back to Top
See Also
Similarity Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Default Property

Similarity Default Property Lucene.Net Class Library
Gets or sets the default Similarity implementation used by indexing and search code.

This is initially an instance of DefaultSimilarity.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Similarity Default { get; set; }
public static Similarity Default { get; set; }
Public Shared Property Default As Similarity
    Get
    Set
Public Shared Property Default As Similarity
    Get
    Set
public:
static property Similarity^ Default {
    Similarity^ get ();
    void set (Similarity^ value);
}
public:
static property Similarity^ Default {
    Similarity^ get ();
    void set (Similarity^ value);
}
See Also
Similarity Class
Similarity Members
Lucene.Net.Search Namespace
Searcher Similarity
IndexWriter SetSimilarity(Similarity)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimilarityDelegator Class

SimilarityDelegator Class Lucene.Net Class Library
Expert: Delegating scoring implementation. Useful in GetSimilarity(Searcher) implementations, to override only certain methods of a Searcher's Similiarty implementation..
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Similarity
Lucene.Net.Search SimilarityDelegator

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SimilarityDelegator : Similarity
[SerializableAttribute]
public class SimilarityDelegator : Similarity
<SerializableAttribute> _
Public Class SimilarityDelegator _
    Inherits Similarity
<SerializableAttribute> _
Public Class SimilarityDelegator _
    Inherits Similarity
[SerializableAttribute]
public ref class SimilarityDelegator : public Similarity
[SerializableAttribute]
public ref class SimilarityDelegator : public Similarity
See Also
SimilarityDelegator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimilarityDelegator Members

SimilarityDelegator Members Lucene.Net Class Library

The SimilarityDelegator type exposes the following members.
Constructors
 | Name | Description
Public method | SimilarityDelegator | Construct a Similarity that delegates all methods to another.
Back to Top
Methods
Name | Description
Public method | ComputeNorm | (Overrides Similarity ComputeNorm(String, FieldInvertState).)
Public method | Coord | (Overrides Similarity Coord(Int32, Int32).)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method | Idf | (Overrides Similarity Idf(Int32, Int32).)
Public method IdfExplain(Term, Searcher)
Computes a score factor for a simple term and returns an explanation for that score factor.

The default implementation uses:
View Colorized Copy to Clipboard Print
idf(searcher.docFreq(term), searcher.MaxDoc);
idf(searcher.docFreq(term), searcher.MaxDoc);
Note that MaxDoc is used instead of NumDocs because it is proportional to DocFreq(Term) , i.e., when one is inaccurate, so is the other, and in the same direction.
(Inherited from Similarity.)
Public method IdfExplain(ICollection Term , Searcher)
Computes a score factor for a phrase.

The default implementation sums the idf factor for each term in the phrase.
(Inherited from Similarity.)
Public method | LengthNorm | (Overrides Similarity LengthNorm(String, Int32).)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method | QueryNorm | (Overrides Similarity QueryNorm(Single).)
Public method | ScorePayload | (Overrides Similarity ScorePayload(Int32, String, Int32, Int32, Byte , Int32, Int32).)
Public method | SloppyFreq | (Overrides Similarity SloppyFreq(Int32).)
Public method Tf(Int32)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the Idf(Int32, Int32) factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when freq is large, and smaller values when freq is small.

The default implementation calls Tf(Single).
(Inherited from Similarity.)
Public method | Tf(Single) | (Overrides Similarity Tf(Single).)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
See Also
SimilarityDelegator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimilarityDelegator Constructor

SimilarityDelegator Constructor Lucene.Net Class Library
Construct a Similarity that delegates all methods to another.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SimilarityDelegator(
    Similarity delegee
)
public SimilarityDelegator(
    Similarity delegee
)
Public Sub New ( _
    delegee As Similarity _
)
Public Sub New ( _
    delegee As Similarity _
)
public:
SimilarityDelegator(
    Similarity^ delegee
)
public:
SimilarityDelegator(
    Similarity^ delegee
)
Parameters
delegee
Type: Lucene.Net.Search Similarity
the Similarity implementation to delegate to
See Also
SimilarityDelegator Class
SimilarityDelegator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimilarityDelegator Methods

SimilarityDelegator Methods Lucene.Net Class Library
The SimilarityDelegator type exposes the following members.
Methods
Name | Description
Public method | ComputeNorm | (Overrides Similarity ComputeNorm(String, FieldInvertState).)
Public method | Coord | (Overrides Similarity Coord(Int32, Int32).)
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method | Idf | (Overrides Similarity Idf(Int32, Int32).)
Public method IdfExplain(Term, Searcher)
Computes a score factor for a simple term and returns an explanation for that score factor.

The default implementation uses:
View Colorized Copy to Clipboard Print
idf(searcher.docFreq(term), searcher.MaxDoc);
idf(searcher.docFreq(term), searcher.MaxDoc);
Note that MaxDoc is used instead of NumDocs because it is proportional to DocFreq(Term) , i.e., when one is inaccurate, so is the other, and in the same direction.
(Inherited from Similarity.)
Public method IdfExplain(ICollection Term , Searcher)
Computes a score factor for a phrase.

The default implementation sums the idf factor for each term in the phrase.
(Inherited from Similarity.)
Public method | LengthNorm | (Overrides Similarity LengthNorm(String, Int32).)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method | QueryNorm | (Overrides Similarity QueryNorm(Single).)
Public method | ScorePayload | (Overrides Similarity ScorePayload(Int32, String, Int32, Int32, Byte , Int32, Int32).)
Public method | SloppyFreq | (Overrides Similarity SloppyFreq(Int32).)
Public method Tf(Int32)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the Idf(Int32, Int32) factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when freq is large, and smaller values when freq is small.

The default implementation calls Tf(Single).
(Inherited from Similarity.)
Public method | Tf(Single) | (Overrides Similarity Tf(Single).)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
See Also
SimilarityDelegator Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ComputeNorm Method

SimilarityDelegator ComputeNorm Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float ComputeNorm(
    string fieldName,
    FieldInvertState state
)
public override float ComputeNorm(
    string fieldName,
    FieldInvertState state
)
Public Overrides Function ComputeNorm ( _
    fieldName As String, _
    state As FieldInvertState _
) As Single
Public Overrides Function ComputeNorm ( _
    fieldName As String, _
    state As FieldInvertState _
) As Single
public:
virtual float ComputeNorm(
    String^ fieldName,
    FieldInvertState^ state
) override
public:
virtual float ComputeNorm(
    String^ fieldName,
    FieldInvertState^ state
) override
Parameters
fieldName
Type:   Online System String
state
Type: Lucene.Net.Index FieldInvertState
See Also
SimilarityDelegator Class
SimilarityDelegator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Coord Method

SimilarityDelegator Coord Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Coord(
    int overlap,
    int maxOverlap
)
public override float Coord(
    int overlap,
    int maxOverlap
)
Public Overrides Function Coord ( _
    overlap As Integer, _
    maxOverlap As Integer _
) As Single
Public Overrides Function Coord ( _
    overlap As Integer, _
    maxOverlap As Integer _
) As Single
public:
virtual float Coord(
    int overlap,
    int maxOverlap
) override
public:
virtual float Coord(
    int overlap,
    int maxOverlap
) override
Parameters
overlap
Type:   Online System Int32
maxOverlap
Type:   Online System Int32
See Also
SimilarityDelegator Class
SimilarityDelegator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Idf Method

SimilarityDelegator Idf Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Idf(
    int docFreq,
    int numDocs
)
public override float Idf(
    int docFreq,
    int numDocs
)
Public Overrides Function Idf ( _
    docFreq As Integer, _
    numDocs As Integer _
) As Single
Public Overrides Function Idf ( _
    docFreq As Integer, _
    numDocs As Integer _
) As Single
public:
virtual float Idf(
    int docFreq,
    int numDocs
) override
public:
virtual float Idf(
    int docFreq,
    int numDocs
) override
Parameters
docFreq
Type:   Online System Int32
numDocs
Type:   Online System Int32
See Also
SimilarityDelegator Class
SimilarityDelegator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LengthNorm Method

SimilarityDelegator LengthNorm Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float LengthNorm(
    string fieldName,
    int numTerms
)
public override float LengthNorm(
    string fieldName,
    int numTerms
)
Public Overrides Function LengthNorm ( _
    fieldName As String, _
    numTerms As Integer _
) As Single
Public Overrides Function LengthNorm ( _
    fieldName As String, _
    numTerms As Integer _
) As Single
public:
virtual float LengthNorm(
    String^ fieldName,
    int numTerms
) override
public:
virtual float LengthNorm(
    String^ fieldName,
    int numTerms
) override
Parameters
fieldName
Type:   Online System String
numTerms
Type:   Online System Int32
See Also
SimilarityDelegator Class
SimilarityDelegator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QueryNorm Method

SimilarityDelegator QueryNorm Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float QueryNorm(
    float sumOfSquaredWeights
)
public override float QueryNorm(
    float sumOfSquaredWeights
)
Public Overrides Function QueryNorm ( _
    sumOfSquaredWeights As Single _
) As Single
Public Overrides Function QueryNorm ( _
    sumOfSquaredWeights As Single _
) As Single
public:
virtual float QueryNorm(
    float sumOfSquaredWeights
) override
public:
virtual float QueryNorm(
    float sumOfSquaredWeights
) override
Parameters
sumOfSquaredWeights
Type:   Online System Single
See Also
SimilarityDelegator Class
SimilarityDelegator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ScorePayload Method

SimilarityDelegator ScorePayload Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float ScorePayload(
    int docId,
    string fieldName,
    int start,
    int end,
    byte[] payload,
    int offset,
    int length
)
public override float ScorePayload(
    int docId,
    string fieldName,
    int start,
    int end,
    byte[] payload,
    int offset,
    int length
)
Public Overrides Function ScorePayload ( _
    docId As Integer, _
    fieldName As String, _
    start As Integer, _
    end As Integer, _
    payload As Byte(), _
    offset As Integer, _
    length As Integer _
) As Single
Public Overrides Function ScorePayload ( _
    docId As Integer, _
    fieldName As String, _
    start As Integer, _
    end As Integer, _
    payload As Byte(), _
    offset As Integer, _
    length As Integer _
) As Single
public:
virtual float ScorePayload(
    int docId,
    String^ fieldName,
    int start,
    int end,
    array<unsigned char>^ payload,
    int offset,
    int length
) override
public:
virtual float ScorePayload(
    int docId,
    String^ fieldName,
    int start,
    int end,
    array<unsigned char>^ payload,
    int offset,
    int length
) override
Parameters
docId
Type:   Online System Int32
fieldName
Type:   Online System String
start
Type:   Online System Int32
end
Type:   Online System Int32
payload
Type:    Online System Byte
offset
Type:   Online System Int32
length
Type:   Online System Int32
See Also
SimilarityDelegator Class
SimilarityDelegator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SloppyFreq Method

SimilarityDelegator SloppyFreq Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float SloppyFreq(
    int distance
)
public override float SloppyFreq(
    int distance
)
Public Overrides Function SloppyFreq ( _
    distance As Integer _
) As Single
Public Overrides Function SloppyFreq ( _
    distance As Integer _
) As Single
public:
virtual float SloppyFreq(
    int distance
) override
public:
virtual float SloppyFreq(
    int distance
) override
Parameters
distance
Type:   Online System Int32
See Also
SimilarityDelegator Class
SimilarityDelegator Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tf Method

SimilarityDelegator Tf Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Tf(Int32) | Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the Idf(Int32, Int32) factor for each term in the query and these products are then summed to form the initial score for a document. Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when freq is large, and smaller values when freq is small. The default implementation calls Tf(Single). (Inherited from Similarity.)
Public method | Tf(Single) | (Overrides Similarity Tf(Single).)
Back to Top
See Also
SimilarityDelegator Class
SimilarityDelegator Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Tf Method (Single)

SimilarityDelegator Tf Method (Single) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Tf(
    float freq
)
public override float Tf(
    float freq
)
Public Overrides Function Tf ( _
    freq As Single _
) As Single
Public Overrides Function Tf ( _
    freq As Single _
) As Single
public:
virtual float Tf(
    float freq
) override
public:
virtual float Tf(
    float freq
) override
Parameters
freq
Type:   Online System Single
See Also
SimilarityDelegator Class
SimilarityDelegator Members
Tf Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SingleTermEnum Class

SingleTermEnum Class Lucene.Net Class Library
Subclass of FilteredTermEnum for enumerating a single term.

This can be used by MultiTermQuerys that need only visit one term, but want to preserve MultiTermQuery semantics such as RewriteMethod.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index TermEnum
Lucene.Net.Search FilteredTermEnum
Lucene.Net.Search SingleTermEnum

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SingleTermEnum : FilteredTermEnum
public class SingleTermEnum : FilteredTermEnum
Public Class SingleTermEnum _
    Inherits FilteredTermEnum
Public Class SingleTermEnum _
    Inherits FilteredTermEnum
public ref class SingleTermEnum : public FilteredTermEnum
public ref class SingleTermEnum : public FilteredTermEnum
See Also
SingleTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SingleTermEnum Members

SingleTermEnum Members Lucene.Net Class Library

The SingleTermEnum type exposes the following members.
Constructors
 | Name | Description
Public method | SingleTermEnum | Creates a new SingleTermEnum. After calling the constructor the enumeration is already pointing to the term, if it exists.
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Public method | Difference | (Overrides FilteredTermEnum Difference .)
Public method | Dispose | Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Protected method | Dispose(Boolean) | (Inherited from FilteredTermEnum.)
Public method | DocFreq | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum EndEnum .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | Increments the enumeration to the next element. True if one exists. (Inherited from FilteredTermEnum.)
Protected method | SetEnum | use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term. (Inherited from FilteredTermEnum.)
Protected method | TermCompare | (Overrides FilteredTermEnum TermCompare(Term).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use SetEnum(TermEnum) (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)
Back to Top
Properties
 | Name | Description
Public property | Term | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Back to Top
See Also
SingleTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SingleTermEnum Constructor

SingleTermEnum Constructor Lucene.Net Class Library
Creates a new SingleTermEnum.

After calling the constructor the enumeration is already pointing to the term, if it exists.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SingleTermEnum(
    IndexReader reader,
    Term singleTerm
)
public SingleTermEnum(
    IndexReader reader,
    Term singleTerm
)
Public Sub New ( _
    reader As IndexReader, _
    singleTerm As Term _
)
Public Sub New ( _
    reader As IndexReader, _
    singleTerm As Term _
)
public:
SingleTermEnum(
    IndexReader^ reader,
    Term^ singleTerm
)
public:
SingleTermEnum(
    IndexReader^ reader,
    Term^ singleTerm
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
singleTerm
Type: Lucene.Net.Index Term
See Also
SingleTermEnum Class
SingleTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SingleTermEnum Fields

SingleTermEnum Fields Lucene.Net Class Library
The SingleTermEnum type exposes the following members.
Fields
 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use SetEnum(TermEnum) (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)
Back to Top
See Also
SingleTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SingleTermEnum Methods

SingleTermEnum Methods Lucene.Net Class Library
The SingleTermEnum type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Public method | Difference | (Overrides FilteredTermEnum Difference .)
Public method | Dispose | Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Protected method | Dispose(Boolean) | (Inherited from FilteredTermEnum.)
Public method | DocFreq | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum EndEnum .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | Increments the enumeration to the next element. True if one exists. (Inherited from FilteredTermEnum.)
Protected method | SetEnum | use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term. (Inherited from FilteredTermEnum.)
Protected method | TermCompare | (Overrides FilteredTermEnum TermCompare(Term).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SingleTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Difference Method

SingleTermEnum Difference Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Difference()
public override float Difference()
Public Overrides Function Difference As Single
Public Overrides Function Difference As Single
public:
virtual float Difference() override
public:
virtual float Difference() override
See Also
SingleTermEnum Class
SingleTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EndEnum Method

SingleTermEnum EndEnum Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool EndEnum()
public override bool EndEnum()
Public Overrides Function EndEnum As Boolean
Public Overrides Function EndEnum As Boolean
public:
virtual bool EndEnum() override
public:
virtual bool EndEnum() override
See Also
SingleTermEnum Class
SingleTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermCompare Method

SingleTermEnum TermCompare Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool TermCompare(
    Term term
)
protected override bool TermCompare(
    Term term
)
Protected Overrides Function TermCompare ( _
    term As Term _
) As Boolean
Protected Overrides Function TermCompare ( _
    term As Term _
) As Boolean
protected:
virtual bool TermCompare(
    Term^ term
) override
protected:
virtual bool TermCompare(
    Term^ term
) override
Parameters
term
Type: Lucene.Net.Index Term
See Also
SingleTermEnum Class
SingleTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SingleTermEnum Properties

SingleTermEnum Properties Lucene.Net Class Library
The SingleTermEnum type exposes the following members.
Properties
 | Name | Description
Public property | Term | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Back to Top
See Also
SingleTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Sort Class

Sort Class Lucene.Net Class Library
Encapsulates sort criteria for returned hits.

The fields used to determine sort order must be carefully chosen. Documents must contain a single term in such a field, and the value of the term should indicate the document's relative position in a given sort order. The field must be indexed, but should not be tokenized, and does not need to be stored (unless you happen to want it back with the rest of your document data). In other words:

document.add (new Field ("byNumber", Integer.toString(x), Field.Store.NO, Field.Index.NOT_ANALYZED));

Valid Types of Values

There are four possible kinds of term values which may be put into sorting fields: Integers, Longs, Floats, or Strings. Unless SortField objects are specified, the type of value in the field is determined by parsing the first term in the field.

Integer term values should contain only digits and an optional preceding negative sign. Values must be base 10 and in the range Integer.MIN_VALUE and Integer.MAX_VALUE inclusive. Documents which should appear first in the sort should have low value integers, later documents high values (i.e. the documents should be numbered 1..n where 1 is the first and n the last).

Long term values should contain only digits and an optional preceding negative sign. Values must be base 10 and in the range Long.MIN_VALUE and Long.MAX_VALUE inclusive. Documents which should appear first in the sort should have low value integers, later documents high values.

Float term values should conform to values accepted by Online Parse(String) (except that NaN and Infinity are not supported). Documents which should appear first in the sort should have low values, later documents high values.

String term values can contain any valid String, but should not be tokenized. The values are sorted according to their Online natural order. Note that using this type of term value has higher memory requirements than the other two types.

Object Reuse

One of these objects can be used multiple times and the sort order changed between usages.

This class is thread safe.

Memory Usage

Sorting uses of caches of term values maintained by the internal HitQueue(s). The cache is static and contains an integer or float array of length IndexReader.MaxDoc for each field name for which a sort is performed. In other words, the size of the cache in bytes is:

4 * IndexReader.MaxDoc * (# of different fields actually used to sort)

For String fields, the cache is larger: in addition to the above array, the value of every term in the field is kept in memory. If there are many unique terms in the field, this could be quite large.

Note that the size of the cache is not affected by how many fields are in the index and might be used to sort - only by the ones actually used to sort a result set.

Created: Feb 12, 2004 10:53:57 AM
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Sort

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class Sort
[SerializableAttribute]
public class Sort
<SerializableAttribute> _
Public Class Sort
<SerializableAttribute> _
Public Class Sort
[SerializableAttribute]
public ref class Sort
[SerializableAttribute]
public ref class Sort
See Also
Sort Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Sort Members

Sort Members Lucene.Net Class Library

The Sort type exposes the following members.
Constructors
 | Name | Description
Public method | Sort | Sorts by computed relevance. This is the same sort criteria as calling Search(Query, Int32)without a sort criteria, only with slightly more overhead.
Public method | Sort(SortField) | Sorts by the criteria in the given SortField.
Public method | Sort( SortField ) | Sorts in succession by the criteria in each SortField.
Back to Top
Methods
 | Name | Description
Public method | Equals | Returns true if o is equal to this. (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Online Object GetHashCode .)
Public method | GetSort | Representation of the sort criteria.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetSort(SortField) | Sets the sort to the given criteria.
Public method | SetSort( SortField ) | Sets the sort to the given criteria in succession.
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Fields
Name | Description
INDEXORDER | Represents sorting by index order.
RELEVANCE | Represents sorting by computed relevance. Using this sort criteria returns the same results as calling Search(Query, Int32)Searcher#search()without a sort criteria, only with slightly more overhead.
Back to Top
See Also
Sort Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Sort Constructor

Sort Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Sort | Sorts by computed relevance. This is the same sort criteria as calling Search(Query, Int32)without a sort criteria, only with slightly more overhead.
Public method | Sort(SortField) | Sorts by the criteria in the given SortField.
Public method | Sort( SortField ) | Sorts in succession by the criteria in each SortField.
Back to Top
See Also
Sort Class
Sort Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Sort Constructor

Sort Constructor Lucene.Net Class Library
Sorts by computed relevance. This is the same sort criteria as calling Search(Query, Int32)without a sort criteria, only with slightly more overhead.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Sort()
public Sort()
Public Sub New
Public Sub New
public:
Sort()
public:
Sort()
See Also
Sort Class
Sort Members
Sort Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Sort Constructor (SortField)

Sort Constructor (SortField) Lucene.Net Class Library
Sorts by the criteria in the given SortField.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Sort(
    SortField field
)
public Sort(
    SortField field
)
Public Sub New ( _
    field As SortField _
)
Public Sub New ( _
    field As SortField _
)
public:
Sort(
    SortField^ field
)
public:
Sort(
    SortField^ field
)
Parameters
field
Type: Lucene.Net.Search SortField
See Also
Sort Class
Sort Members
Sort Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Sort Constructor (SortField[])

Sort Constructor ( SortField ) Lucene.Net Class Library
Sorts in succession by the criteria in each SortField.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Sort(
    params SortField[] fields
)
public Sort(
    params SortField[] fields
)
Public Sub New ( _
    ParamArray fields As SortField() _
)
Public Sub New ( _
    ParamArray fields As SortField() _
)
public:
Sort(
    ... array<SortField^>^ fields
)
public:
Sort(
    ... array<SortField^>^ fields
)
Parameters
fields
Type:  Lucene.Net.Search SortField
See Also
Sort Class
Sort Members
Sort Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Sort Fields

Sort Fields Lucene.Net Class Library
The Sort type exposes the following members.
Fields
Name | Description
INDEXORDER | Represents sorting by index order.
RELEVANCE | Represents sorting by computed relevance. Using this sort criteria returns the same results as calling Search(Query, Int32)Searcher#search()without a sort criteria, only with slightly more overhead.
Back to Top
See Also
Sort Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


INDEXORDER Field

Sort INDEXORDER Field Lucene.Net Class Library
Represents sorting by index order.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Sort INDEXORDER
public static readonly Sort INDEXORDER
Public Shared ReadOnly INDEXORDER As Sort
Public Shared ReadOnly INDEXORDER As Sort
public:
static initonly Sort^ INDEXORDER
public:
static initonly Sort^ INDEXORDER
See Also
Sort Class
Sort Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RELEVANCE Field

Sort RELEVANCE Field Lucene.Net Class Library
Represents sorting by computed relevance. Using this sort criteria returns the same results as calling Search(Query, Int32)Searcher#search()without a sort criteria, only with slightly more overhead.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Sort RELEVANCE
public static readonly Sort RELEVANCE
Public Shared ReadOnly RELEVANCE As Sort
Public Shared ReadOnly RELEVANCE As Sort
public:
static initonly Sort^ RELEVANCE
public:
static initonly Sort^ RELEVANCE
See Also
Sort Class
Sort Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Sort Methods

Sort Methods Lucene.Net Class Library
The Sort type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Returns true if o is equal to this. (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Online Object GetHashCode .)
Public method | GetSort | Representation of the sort criteria.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetSort(SortField) | Sets the sort to the given criteria.
Public method | SetSort( SortField ) | Sets the sort to the given criteria in succession.
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
Sort Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

Sort Equals Method Lucene.Net Class Library
Returns true if o is equal to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
Sort Class
Sort Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

Sort GetHashCode Method Lucene.Net Class Library
Returns a hash code value for this object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
Sort Class
Sort Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSort Method

Sort GetSort Method Lucene.Net Class Library
Representation of the sort criteria.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual SortField[] GetSort()
public virtual SortField[] GetSort()
Public Overridable Function GetSort As SortField()
Public Overridable Function GetSort As SortField()
public:
virtual array<SortField^>^ GetSort()
public:
virtual array<SortField^>^ GetSort()
Return Value
 Array of SortField objects used in this sort criteria

See Also
Sort Class
Sort Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetSort Method

Sort SetSort Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | SetSort(SortField) | Sets the sort to the given criteria.
Public method | SetSort( SortField ) | Sets the sort to the given criteria in succession.
Back to Top
See Also
Sort Class
Sort Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetSort Method (SortField)

Sort SetSort Method (SortField) Lucene.Net Class Library
Sets the sort to the given criteria.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetSort(
    SortField field
)
public virtual void SetSort(
    SortField field
)
Public Overridable Sub SetSort ( _
    field As SortField _
)
Public Overridable Sub SetSort ( _
    field As SortField _
)
public:
virtual void SetSort(
    SortField^ field
)
public:
virtual void SetSort(
    SortField^ field
)
Parameters
field
Type: Lucene.Net.Search SortField
See Also
Sort Class
Sort Members
SetSort Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetSort Method (SortField[])

Sort SetSort Method ( SortField ) Lucene.Net Class Library
Sets the sort to the given criteria in succession.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetSort(
    params SortField[] fields
)
public virtual void SetSort(
    params SortField[] fields
)
Public Overridable Sub SetSort ( _
    ParamArray fields As SortField() _
)
Public Overridable Sub SetSort ( _
    ParamArray fields As SortField() _
)
public:
virtual void SetSort(
    ... array<SortField^>^ fields
)
public:
virtual void SetSort(
    ... array<SortField^>^ fields
)
Parameters
fields
Type:  Lucene.Net.Search SortField
See Also
Sort Class
Sort Members
SetSort Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

Sort ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
Sort Class
Sort Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortField Class

SortField Class Lucene.Net Class Library
Stores information about how to sort documents by terms in an individual field. Fields must be indexed in order to sort by them.

Created: Feb 11, 2004 1:25:29 PM
Inheritance Hierarchy
Online System Object
Lucene.Net.Search SortField

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SortField
[SerializableAttribute]
public class SortField
<SerializableAttribute> _
Public Class SortField
<SerializableAttribute> _
Public Class SortField
[SerializableAttribute]
public ref class SortField
[SerializableAttribute]
public ref class SortField
See Also
SortField Members
Lucene.Net.Search Namespace
Lucene.Net.Search Sort
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortField Members

SortField Members Lucene.Net Class Library

The SortField type exposes the following members.
Constructors
 | Name | Description
Public method | SortField(String, FieldComparatorSource) | Creates a sort with a custom comparison function.
Public method | SortField(String, Parser) | Creates a sort by terms in the given field, parsed to numeric values using a custom Parser.
Public method | SortField(String, CultureInfo) | Creates a sort by terms in the given field sorted according to the given locale.
Public method | SortField(String, Int32) | Creates a sort by terms in the given field with the type of term values explicitly given.
Public method | SortField(String, FieldComparatorSource, Boolean) | Creates a sort, possibly in reverse, with a custom comparison function.
Public method | SortField(String, Parser, Boolean) | Creates a sort, possibly in reverse, by terms in the given field, parsed to numeric values using a custom Parser.
Public method | SortField(String, CultureInfo, Boolean) | Creates a sort, possibly in reverse, by terms in the given field sorted according to the given locale.
Public method | SortField(String, Int32, Boolean) | Creates a sort, possibly in reverse, by terms in the given field with the type of term values explicitly given.
Back to Top
Methods
 | Name | Description
Public method | Equals | Returns true if o is equal to this. If a FieldComparatorSource or Parser was provided, it must properly implement equals (unless a singleton is always used). (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetComparator | Returns the FieldComparator to use for sorting. NOTE: This API is experimental and might change in incompatible ways in the next release.
Public method | GetHashCode | Returns true if o is equal to this. If a FieldComparatorSource (deprecated) or Parser was provided, it must properly implement hashCode (unless a singleton is always used). (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Fields
Name | Description
BYTE | Sort using term values as encoded Bytes. Sort values are Byte and lower values are at the front.
CUSTOM | Sort using a custom Comparator. Sort values are any Comparable and sorting is done according to natural order.
DOC | Sort by document number (index order). Sort values are Integer and lower values are at the front.
DOUBLE | Sort using term values as encoded Doubles. Sort values are Double and lower values are at the front.
FIELD_DOC | Represents sorting by document number (index order).
FIELD_SCORE | Represents sorting by document score (relevancy).
FLOAT | Sort using term values as encoded Floats. Sort values are Float and lower values are at the front.
INT | Sort using term values as encoded Integers. Sort values are Integer and lower values are at the front.
LONG | Sort using term values as encoded Longs. Sort values are Long and lower values are at the front.
SCORE | Sort by document score (relevancy). Sort values are Float and higher values are at the front.
SHORT | Sort using term values as encoded Shorts. Sort values are Short and lower values are at the front.
STRING | Sort using term values as Strings. Sort values are String and lower values are at the front.
STRING_VAL | Sort using term values as Strings, but comparing by value (using String.compareTo) for all comparisons. This is typically slower than STRING, which uses ordinals to do the sorting.
Back to Top
Properties
 | Name | Description
Public property | ComparatorSource | Returns the FieldComparatorSource used for custom sorting
Public property | Field | Returns the name of the field. Could return null if the sort is by SCORE or DOC.
Public property | Locale | Returns the Locale by which term values are interpreted. May return null if no Locale was specified.
Public property | Parser | Returns the instance of a FieldCache parser that fits to the given sort type. May return null if no parser was specified. Sorting is using the default parser then.
Public property | Reverse | Returns whether the sort should be reversed.
Public property | Type | Returns the type of contents in the field.
Back to Top
See Also
SortField Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortField Constructor

SortField Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | SortField(String, FieldComparatorSource) | Creates a sort with a custom comparison function.
Public method | SortField(String, Parser) | Creates a sort by terms in the given field, parsed to numeric values using a custom Parser.
Public method | SortField(String, CultureInfo) | Creates a sort by terms in the given field sorted according to the given locale.
Public method | SortField(String, Int32) | Creates a sort by terms in the given field with the type of term values explicitly given.
Public method | SortField(String, FieldComparatorSource, Boolean) | Creates a sort, possibly in reverse, with a custom comparison function.
Public method | SortField(String, Parser, Boolean) | Creates a sort, possibly in reverse, by terms in the given field, parsed to numeric values using a custom Parser.
Public method | SortField(String, CultureInfo, Boolean) | Creates a sort, possibly in reverse, by terms in the given field sorted according to the given locale.
Public method | SortField(String, Int32, Boolean) | Creates a sort, possibly in reverse, by terms in the given field with the type of term values explicitly given.
Back to Top
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortField Constructor (String, FieldComparatorSource)

SortField Constructor (String, FieldComparatorSource) Lucene.Net Class Library
Creates a sort with a custom comparison function.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortField(
    string field,
    FieldComparatorSource comparator
)
public SortField(
    string field,
    FieldComparatorSource comparator
)
Public Sub New ( _
    field As String, _
    comparator As FieldComparatorSource _
)
Public Sub New ( _
    field As String, _
    comparator As FieldComparatorSource _
)
public:
SortField(
    String^ field,
    FieldComparatorSource^ comparator
)
public:
SortField(
    String^ field,
    FieldComparatorSource^ comparator
)
Parameters
field
Type:   Online System String
Name of field to sort by; cannot be null.

comparator
Type: Lucene.Net.Search FieldComparatorSource
Returns a comparator for sorting hits.

See Also
SortField Class
SortField Members
SortField Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortField Constructor (String, Parser)

SortField Constructor (String, Parser) Lucene.Net Class Library
Creates a sort by terms in the given field, parsed to numeric values using a custom Parser.
subclass an existing numeric parser, or field is null

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortField(
    string field,
    Parser parser
)
public SortField(
    string field,
    Parser parser
)
Public Sub New ( _
    field As String, _
    parser As Parser _
)
Public Sub New ( _
    field As String, _
    parser As Parser _
)
public:
SortField(
    String^ field,
    Parser^ parser
)
public:
SortField(
    String^ field,
    Parser^ parser
)
Parameters
field
Type:   Online System String
 Name of field to sort by.  Must not be null.

parser
Type: Lucene.Net.Search Parser
Instance of a Parser,
            which must subclass one of the existing numeric
            parsers from FieldCache. Sort type is inferred
            by testing which numeric parser the parser subclasses.

See Also
SortField Class
SortField Members
SortField Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortField Constructor (String, CultureInfo)

SortField Constructor (String, CultureInfo) Lucene.Net Class Library
Creates a sort by terms in the given field sorted according to the given locale.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortField(
    string field,
    CultureInfo locale
)
public SortField(
    string field,
    CultureInfo locale
)
Public Sub New ( _
    field As String, _
    locale As CultureInfo _
)
Public Sub New ( _
    field As String, _
    locale As CultureInfo _
)
public:
SortField(
    String^ field,
    CultureInfo^ locale
)
public:
SortField(
    String^ field,
    CultureInfo^ locale
)
Parameters
field
Type:   Online System String
 Name of field to sort by, cannot be null.

locale
Type:   Online System.Globalization CultureInfo
Locale of values in the field.

See Also
SortField Class
SortField Members
SortField Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortField Constructor (String, Int32)

SortField Constructor (String, Int32) Lucene.Net Class Library
Creates a sort by terms in the given field with the type of term values explicitly given.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortField(
    string field,
    int type
)
public SortField(
    string field,
    int type
)
Public Sub New ( _
    field As String, _
    type As Integer _
)
Public Sub New ( _
    field As String, _
    type As Integer _
)
public:
SortField(
    String^ field,
    int type
)
public:
SortField(
    String^ field,
    int type
)
Parameters
field
Type:   Online System String
 Name of field to sort by.  Can be null if
            type is SCORE or DOC.

type
Type:   Online System Int32
  Type of values in the terms.

See Also
SortField Class
SortField Members
SortField Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortField Constructor (String, FieldComparatorSource, Boolean)

SortField Constructor (String, FieldComparatorSource, Boolean) Lucene.Net Class Library
Creates a sort, possibly in reverse, with a custom comparison function.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortField(
    string field,
    FieldComparatorSource comparator,
    bool reverse
)
public SortField(
    string field,
    FieldComparatorSource comparator,
    bool reverse
)
Public Sub New ( _
    field As String, _
    comparator As FieldComparatorSource, _
    reverse As Boolean _
)
Public Sub New ( _
    field As String, _
    comparator As FieldComparatorSource, _
    reverse As Boolean _
)
public:
SortField(
    String^ field,
    FieldComparatorSource^ comparator,
    bool reverse
)
public:
SortField(
    String^ field,
    FieldComparatorSource^ comparator,
    bool reverse
)
Parameters
field
Type:   Online System String
Name of field to sort by; cannot be null.

comparator
Type: Lucene.Net.Search FieldComparatorSource
Returns a comparator for sorting hits.

reverse
Type:   Online System Boolean
True if natural order should be reversed.

See Also
SortField Class
SortField Members
SortField Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortField Constructor (String, Parser, Boolean)

SortField Constructor (String, Parser, Boolean) Lucene.Net Class Library
Creates a sort, possibly in reverse, by terms in the given field, parsed to numeric values using a custom Parser.
subclass an existing numeric parser, or field is null

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortField(
    string field,
    Parser parser,
    bool reverse
)
public SortField(
    string field,
    Parser parser,
    bool reverse
)
Public Sub New ( _
    field As String, _
    parser As Parser, _
    reverse As Boolean _
)
Public Sub New ( _
    field As String, _
    parser As Parser, _
    reverse As Boolean _
)
public:
SortField(
    String^ field,
    Parser^ parser,
    bool reverse
)
public:
SortField(
    String^ field,
    Parser^ parser,
    bool reverse
)
Parameters
field
Type:   Online System String
 Name of field to sort by.  Must not be null.

parser
Type: Lucene.Net.Search Parser
Instance of a Parser,
            which must subclass one of the existing numeric
            parsers from FieldCache. Sort type is inferred
            by testing which numeric parser the parser subclasses.

reverse
Type:   Online System Boolean
True if natural order should be reversed.

See Also
SortField Class
SortField Members
SortField Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortField Constructor (String, CultureInfo, Boolean)

SortField Constructor (String, CultureInfo, Boolean) Lucene.Net Class Library
Creates a sort, possibly in reverse, by terms in the given field sorted according to the given locale.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortField(
    string field,
    CultureInfo locale,
    bool reverse
)
public SortField(
    string field,
    CultureInfo locale,
    bool reverse
)
Public Sub New ( _
    field As String, _
    locale As CultureInfo, _
    reverse As Boolean _
)
Public Sub New ( _
    field As String, _
    locale As CultureInfo, _
    reverse As Boolean _
)
public:
SortField(
    String^ field,
    CultureInfo^ locale,
    bool reverse
)
public:
SortField(
    String^ field,
    CultureInfo^ locale,
    bool reverse
)
Parameters
field
Type:   Online System String
 Name of field to sort by, cannot be null.

locale
Type:   Online System.Globalization CultureInfo
Locale of values in the field.

reverse
Type:   Online System Boolean
See Also
SortField Class
SortField Members
SortField Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortField Constructor (String, Int32, Boolean)

SortField Constructor (String, Int32, Boolean) Lucene.Net Class Library
Creates a sort, possibly in reverse, by terms in the given field with the type of term values explicitly given.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortField(
    string field,
    int type,
    bool reverse
)
public SortField(
    string field,
    int type,
    bool reverse
)
Public Sub New ( _
    field As String, _
    type As Integer, _
    reverse As Boolean _
)
Public Sub New ( _
    field As String, _
    type As Integer, _
    reverse As Boolean _
)
public:
SortField(
    String^ field,
    int type,
    bool reverse
)
public:
SortField(
    String^ field,
    int type,
    bool reverse
)
Parameters
field
Type:   Online System String
 Name of field to sort by.  Can be null if
            type is SCORE or DOC.

type
Type:   Online System Int32
  Type of values in the terms.

reverse
Type:   Online System Boolean
True if natural order should be reversed.

See Also
SortField Class
SortField Members
SortField Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortField Fields

SortField Fields Lucene.Net Class Library
The SortField type exposes the following members.
Fields
Name | Description
BYTE | Sort using term values as encoded Bytes. Sort values are Byte and lower values are at the front.
CUSTOM | Sort using a custom Comparator. Sort values are any Comparable and sorting is done according to natural order.
DOC | Sort by document number (index order). Sort values are Integer and lower values are at the front.
DOUBLE | Sort using term values as encoded Doubles. Sort values are Double and lower values are at the front.
FIELD_DOC | Represents sorting by document number (index order).
FIELD_SCORE | Represents sorting by document score (relevancy).
FLOAT | Sort using term values as encoded Floats. Sort values are Float and lower values are at the front.
INT | Sort using term values as encoded Integers. Sort values are Integer and lower values are at the front.
LONG | Sort using term values as encoded Longs. Sort values are Long and lower values are at the front.
SCORE | Sort by document score (relevancy). Sort values are Float and higher values are at the front.
SHORT | Sort using term values as encoded Shorts. Sort values are Short and lower values are at the front.
STRING | Sort using term values as Strings. Sort values are String and lower values are at the front.
STRING_VAL | Sort using term values as Strings, but comparing by value (using String.compareTo) for all comparisons. This is typically slower than STRING, which uses ordinals to do the sorting.
Back to Top
See Also
SortField Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BYTE Field

SortField BYTE Field Lucene.Net Class Library
Sort using term values as encoded Bytes. Sort values are Byte and lower values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int BYTE
public const int BYTE
Public Const BYTE As Integer
Public Const BYTE As Integer
public:
literal int BYTE
public:
literal int BYTE
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CUSTOM Field

SortField CUSTOM Field Lucene.Net Class Library
Sort using a custom Comparator. Sort values are any Comparable and sorting is done according to natural order.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int CUSTOM
public const int CUSTOM
Public Const CUSTOM As Integer
Public Const CUSTOM As Integer
public:
literal int CUSTOM
public:
literal int CUSTOM
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DOC Field

SortField DOC Field Lucene.Net Class Library
Sort by document number (index order). Sort values are Integer and lower values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DOC
public const int DOC
Public Const DOC As Integer
Public Const DOC As Integer
public:
literal int DOC
public:
literal int DOC
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DOUBLE Field

SortField DOUBLE Field Lucene.Net Class Library
Sort using term values as encoded Doubles. Sort values are Double and lower values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DOUBLE
public const int DOUBLE
Public Const DOUBLE As Integer
Public Const DOUBLE As Integer
public:
literal int DOUBLE
public:
literal int DOUBLE
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FIELD_DOC Field

SortField FIELD_DOC Field Lucene.Net Class Library
Represents sorting by document number (index order).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly SortField FIELD_DOC
public static readonly SortField FIELD_DOC
Public Shared ReadOnly FIELD_DOC As SortField
Public Shared ReadOnly FIELD_DOC As SortField
public:
static initonly SortField^ FIELD_DOC
public:
static initonly SortField^ FIELD_DOC
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FIELD_SCORE Field

SortField FIELD_SCORE Field Lucene.Net Class Library
Represents sorting by document score (relevancy).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly SortField FIELD_SCORE
public static readonly SortField FIELD_SCORE
Public Shared ReadOnly FIELD_SCORE As SortField
Public Shared ReadOnly FIELD_SCORE As SortField
public:
static initonly SortField^ FIELD_SCORE
public:
static initonly SortField^ FIELD_SCORE
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FLOAT Field

SortField FLOAT Field Lucene.Net Class Library
Sort using term values as encoded Floats. Sort values are Float and lower values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int FLOAT
public const int FLOAT
Public Const FLOAT As Integer
Public Const FLOAT As Integer
public:
literal int FLOAT
public:
literal int FLOAT
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


INT Field

SortField INT Field Lucene.Net Class Library
Sort using term values as encoded Integers. Sort values are Integer and lower values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int INT
public const int INT
Public Const INT As Integer
Public Const INT As Integer
public:
literal int INT
public:
literal int INT
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LONG Field

SortField LONG Field Lucene.Net Class Library
Sort using term values as encoded Longs. Sort values are Long and lower values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int LONG
public const int LONG
Public Const LONG As Integer
Public Const LONG As Integer
public:
literal int LONG
public:
literal int LONG
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SCORE Field

SortField SCORE Field Lucene.Net Class Library
Sort by document score (relevancy). Sort values are Float and higher values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int SCORE
public const int SCORE
Public Const SCORE As Integer
Public Const SCORE As Integer
public:
literal int SCORE
public:
literal int SCORE
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SHORT Field

SortField SHORT Field Lucene.Net Class Library
Sort using term values as encoded Shorts. Sort values are Short and lower values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int SHORT
public const int SHORT
Public Const SHORT As Integer
Public Const SHORT As Integer
public:
literal int SHORT
public:
literal int SHORT
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


STRING Field

SortField STRING Field Lucene.Net Class Library
Sort using term values as Strings. Sort values are String and lower values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int STRING
public const int STRING
Public Const STRING As Integer
Public Const STRING As Integer
public:
literal int STRING
public:
literal int STRING
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


STRING_VAL Field

SortField STRING_VAL Field Lucene.Net Class Library
Sort using term values as Strings, but comparing by value (using String.compareTo) for all comparisons. This is typically slower than STRING, which uses ordinals to do the sorting.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int STRING_VAL
public const int STRING_VAL
Public Const STRING_VAL As Integer
Public Const STRING_VAL As Integer
public:
literal int STRING_VAL
public:
literal int STRING_VAL
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortField Methods

SortField Methods Lucene.Net Class Library
The SortField type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Returns true if o is equal to this. If a FieldComparatorSource or Parser was provided, it must properly implement equals (unless a singleton is always used). (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetComparator | Returns the FieldComparator to use for sorting. NOTE: This API is experimental and might change in incompatible ways in the next release.
Public method | GetHashCode | Returns true if o is equal to this. If a FieldComparatorSource (deprecated) or Parser was provided, it must properly implement hashCode (unless a singleton is always used). (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
SortField Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

SortField Equals Method Lucene.Net Class Library
Returns true if o is equal to this. If a FieldComparatorSource or Parser was provided, it must properly implement equals (unless a singleton is always used).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetComparator Method

SortField GetComparator Method Lucene.Net Class Library
Returns the FieldComparator to use for sorting. NOTE: This API is experimental and might change in incompatible ways in the next release.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual FieldComparator GetComparator(
    int numHits,
    int sortPos
)
public virtual FieldComparator GetComparator(
    int numHits,
    int sortPos
)
Public Overridable Function GetComparator ( _
    numHits As Integer, _
    sortPos As Integer _
) As FieldComparator
Public Overridable Function GetComparator ( _
    numHits As Integer, _
    sortPos As Integer _
) As FieldComparator
public:
virtual FieldComparator^ GetComparator(
    int numHits,
    int sortPos
)
public:
virtual FieldComparator^ GetComparator(
    int numHits,
    int sortPos
)
Parameters
numHits
Type:   Online System Int32
number of top hits the queue will store

sortPos
Type:   Online System Int32
position of this SortField within Sort
            .  The comparator is primary if sortPos==0,
             secondary if sortPos==1, etc.  Some comparators can
             optimize themselves when they are the primary sort.

Return Value
FieldComparator to use when sorting

See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

SortField GetHashCode Method Lucene.Net Class Library
Returns true if o is equal to this. If a FieldComparatorSource (deprecated) or Parser was provided, it must properly implement hashCode (unless a singleton is always used).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

SortField ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortField Properties

SortField Properties Lucene.Net Class Library
The SortField type exposes the following members.
Properties
 | Name | Description
Public property | ComparatorSource | Returns the FieldComparatorSource used for custom sorting
Public property | Field | Returns the name of the field. Could return null if the sort is by SCORE or DOC.
Public property | Locale | Returns the Locale by which term values are interpreted. May return null if no Locale was specified.
Public property | Parser | Returns the instance of a FieldCache parser that fits to the given sort type. May return null if no parser was specified. Sorting is using the default parser then.
Public property | Reverse | Returns whether the sort should be reversed.
Public property | Type | Returns the type of contents in the field.
Back to Top
See Also
SortField Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ComparatorSource Property

SortField ComparatorSource Property Lucene.Net Class Library
Returns the FieldComparatorSource used for custom sorting

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual FieldComparatorSource ComparatorSource { get; }
public virtual FieldComparatorSource ComparatorSource { get; }
Public Overridable ReadOnly Property ComparatorSource As FieldComparatorSource
    Get
Public Overridable ReadOnly Property ComparatorSource As FieldComparatorSource
    Get
public:
virtual property FieldComparatorSource^ ComparatorSource {
    FieldComparatorSource^ get ();
}
public:
virtual property FieldComparatorSource^ ComparatorSource {
    FieldComparatorSource^ get ();
}
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

SortField Field Property Lucene.Net Class Library
Returns the name of the field. Could return null if the sort is by SCORE or DOC.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Field { get; }
public virtual string Field { get; }
Public Overridable ReadOnly Property Field As String
    Get
Public Overridable ReadOnly Property Field As String
    Get
public:
virtual property String^ Field {
    String^ get ();
}
public:
virtual property String^ Field {
    String^ get ();
}
Field Value
 Name of field, possibly <c>null</c>.
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Locale Property

SortField Locale Property Lucene.Net Class Library
Returns the Locale by which term values are interpreted. May return null if no Locale was specified.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual CultureInfo Locale { get; }
public virtual CultureInfo Locale { get; }
Public Overridable ReadOnly Property Locale As CultureInfo
    Get
Public Overridable ReadOnly Property Locale As CultureInfo
    Get
public:
virtual property CultureInfo^ Locale {
    CultureInfo^ get ();
}
public:
virtual property CultureInfo^ Locale {
    CultureInfo^ get ();
}
Field Value
 Locale, or <c>null</c>.
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Parser Property

SortField Parser Property Lucene.Net Class Library
Returns the instance of a FieldCache parser that fits to the given sort type. May return null if no parser was specified. Sorting is using the default parser then.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Parser Parser { get; }
public virtual Parser Parser { get; }
Public Overridable ReadOnly Property Parser As Parser
    Get
Public Overridable ReadOnly Property Parser As Parser
    Get
public:
virtual property Parser^ Parser {
    Parser^ get ();
}
public:
virtual property Parser^ Parser {
    Parser^ get ();
}
Field Value
 An instance of a <see cref="FieldCache" /> parser, or <c>null</c>.
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reverse Property

SortField Reverse Property Lucene.Net Class Library
Returns whether the sort should be reversed.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Reverse { get; }
public virtual bool Reverse { get; }
Public Overridable ReadOnly Property Reverse As Boolean
    Get
Public Overridable ReadOnly Property Reverse As Boolean
    Get
public:
virtual property bool Reverse {
    bool get ();
}
public:
virtual property bool Reverse {
    bool get ();
}
Field Value
 True if natural order should be reversed.
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Type Property

SortField Type Property Lucene.Net Class Library
Returns the type of contents in the field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Type { get; }
public virtual int Type { get; }
Public Overridable ReadOnly Property Type As Integer
    Get
Public Overridable ReadOnly Property Type As Integer
    Get
public:
virtual property int Type {
    int get ();
}
public:
virtual property int Type {
    int get ();
}
Field Value
 One of the constants SCORE, DOC, STRING, INT or FLOAT.
See Also
SortField Class
SortField Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilter Class

SpanFilter Class Lucene.Net Class Library
Abstract base class providing a mechanism to restrict searches to a subset of an index and also maintains and returns position information. This is useful if you want to compare the positions from a SpanQuery with the positions of items in a filter. For instance, if you had a SpanFilter that marked all the occurrences of the word "foo" in documents, and then you entered a new SpanQuery containing bar, you could not only filter by the word foo, but you could then compare position information for post processing.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Filter
Lucene.Net.Search SpanFilter
Lucene.Net.Search CachingSpanFilter
Lucene.Net.Search SpanQueryFilter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class SpanFilter : Filter
[SerializableAttribute]
public abstract class SpanFilter : Filter
<SerializableAttribute> _
Public MustInherit Class SpanFilter _
    Inherits Filter
<SerializableAttribute> _
Public MustInherit Class SpanFilter _
    Inherits Filter
[SerializableAttribute]
public ref class SpanFilter abstract : public Filter
[SerializableAttribute]
public ref class SpanFilter abstract : public Filter
See Also
SpanFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilter Members

SpanFilter Members Lucene.Net Class Library

The SpanFilter type exposes the following members.
Constructors
 | Name | Description
Protected method | SpanFilter | Initializes a new instance of the SpanFilter class
Back to Top
Methods
 | Name | Description
Public method | BitSpans | Returns a SpanFilterResult with true for documents which should be permitted in search results, and false for those that should not and Spans for where the true docs match.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | Creates a DocIdSet enumerating the documents that should be permitted in search results. NOTE: null can be returned if no documents are accepted by this Filter. Note: This method will be called once per segment in the index during searching. The returned DocIdSet must refer to document IDs for that segment, not for the top-level reader. (Inherited from Filter.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SpanFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilter Constructor

SpanFilter Constructor Lucene.Net Class Library
Initializes a new instance of the SpanFilter class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SpanFilter()
protected SpanFilter()
Protected Sub New
Protected Sub New
protected:
SpanFilter()
protected:
SpanFilter()
See Also
SpanFilter Class
SpanFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilter Methods

SpanFilter Methods Lucene.Net Class Library
The SpanFilter type exposes the following members.
Methods
 | Name | Description
Public method | BitSpans | Returns a SpanFilterResult with true for documents which should be permitted in search results, and false for those that should not and Spans for where the true docs match.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | Creates a DocIdSet enumerating the documents that should be permitted in search results. NOTE: null can be returned if no documents are accepted by this Filter. Note: This method will be called once per segment in the index during searching. The returned DocIdSet must refer to document IDs for that segment, not for the top-level reader. (Inherited from Filter.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SpanFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitSpans Method

SpanFilter BitSpans Method Lucene.Net Class Library
Returns a SpanFilterResult with true for documents which should be permitted in search results, and false for those that should not and Spans for where the true docs match.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract SpanFilterResult BitSpans(
    IndexReader reader
)
public abstract SpanFilterResult BitSpans(
    IndexReader reader
)
Public MustOverride Function BitSpans ( _
    reader As IndexReader _
) As SpanFilterResult
Public MustOverride Function BitSpans ( _
    reader As IndexReader _
) As SpanFilterResult
public:
virtual SpanFilterResult^ BitSpans(
    IndexReader^ reader
) abstract
public:
virtual SpanFilterResult^ BitSpans(
    IndexReader^ reader
) abstract
Parameters
reader
Type: Lucene.Net.Index IndexReader
The IndexReader to load position and DocIdSet information from

Return Value
 A SpanFilterResult
See Also
SpanFilter Class
SpanFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilterResult Class

SpanFilterResult Class Lucene.Net Class Library
The results of a SpanQueryFilter. Wraps the BitSet and the position information from the SpanQuery

NOTE: This API is still experimental and subject to change.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search SpanFilterResult

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SpanFilterResult
public class SpanFilterResult
Public Class SpanFilterResult
Public Class SpanFilterResult
public ref class SpanFilterResult
public ref class SpanFilterResult
See Also
SpanFilterResult Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilterResult Members

SpanFilterResult Members Lucene.Net Class Library

The SpanFilterResult type exposes the following members.
Constructors
 | Name | Description
Public method | SpanFilterResult | Initializes a new instance of the SpanFilterResult class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | DocIdSet | Returns the docIdSet
Public property | Positions | The first entry in the array corresponds to the first "on" bit. Entries are increasing by document order
Back to Top
See Also
SpanFilterResult Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilterResult Constructor

SpanFilterResult Constructor Lucene.Net Class Library
Initializes a new instance of the SpanFilterResult class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SpanFilterResult(
    DocIdSet docIdSet,
    IList<SpanFilterResult..::..PositionInfo> positions
)
public SpanFilterResult(
    DocIdSet docIdSet,
    IList<SpanFilterResult..::..PositionInfo> positions
)
Public Sub New ( _
    docIdSet As DocIdSet, _
    positions As IList(Of SpanFilterResult..::..PositionInfo) _
)
Public Sub New ( _
    docIdSet As DocIdSet, _
    positions As IList(Of SpanFilterResult..::..PositionInfo) _
)
public:
SpanFilterResult(
    DocIdSet^ docIdSet,
    IList<SpanFilterResult..::..PositionInfo^>^ positions
)
public:
SpanFilterResult(
    DocIdSet^ docIdSet,
    IList<SpanFilterResult..::..PositionInfo^>^ positions
)
Parameters
docIdSet
Type: Lucene.Net.Search DocIdSet
The DocIdSet for the Filter

positions
Type:   Online System.Collections.Generic IList  SpanFilterResult PositionInfo
A List of SpanFilterResult PositionInfo objects

See Also
SpanFilterResult Class
SpanFilterResult Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilterResult Methods

SpanFilterResult Methods Lucene.Net Class Library
The SpanFilterResult type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SpanFilterResult Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilterResult Properties

SpanFilterResult Properties Lucene.Net Class Library
The SpanFilterResult type exposes the following members.
Properties
 | Name | Description
Public property | DocIdSet | Returns the docIdSet
Public property | Positions | The first entry in the array corresponds to the first "on" bit. Entries are increasing by document order
Back to Top
See Also
SpanFilterResult Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdSet Property

SpanFilterResult DocIdSet Property Lucene.Net Class Library
Returns the docIdSet

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual DocIdSet DocIdSet { get; }
public virtual DocIdSet DocIdSet { get; }
Public Overridable ReadOnly Property DocIdSet As DocIdSet
    Get
Public Overridable ReadOnly Property DocIdSet As DocIdSet
    Get
public:
virtual property DocIdSet^ DocIdSet {
    DocIdSet^ get ();
}
public:
virtual property DocIdSet^ DocIdSet {
    DocIdSet^ get ();
}
See Also
SpanFilterResult Class
SpanFilterResult Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Positions Property

SpanFilterResult Positions Property Lucene.Net Class Library
The first entry in the array corresponds to the first "on" bit. Entries are increasing by document order

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IList<SpanFilterResult..::..PositionInfo> Positions { get; }
public virtual IList<SpanFilterResult..::..PositionInfo> Positions { get; }
Public Overridable ReadOnly Property Positions As IList(Of SpanFilterResult..::..PositionInfo)
    Get
Public Overridable ReadOnly Property Positions As IList(Of SpanFilterResult..::..PositionInfo)
    Get
public:
virtual property IList<SpanFilterResult..::..PositionInfo^>^ Positions {
    IList<SpanFilterResult..::..PositionInfo^>^ get ();
}
public:
virtual property IList<SpanFilterResult..::..PositionInfo^>^ Positions {
    IList<SpanFilterResult..::..PositionInfo^>^ get ();
}
Field Value
 A List of PositionInfo objects
See Also
SpanFilterResult Class
SpanFilterResult Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilterResult.PositionInfo Class

SpanFilterResult PositionInfo Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search SpanFilterResult PositionInfo

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PositionInfo
public class PositionInfo
Public Class PositionInfo
Public Class PositionInfo
public ref class PositionInfo
public ref class PositionInfo
See Also
SpanFilterResult PositionInfo Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilterResult.PositionInfo Members

SpanFilterResult PositionInfo Members Lucene.Net Class Library

The results of a SpanQueryFilter. Wraps the BitSet and the position information from the SpanQuery

NOTE: This API is still experimental and subject to change.

The SpanFilterResult PositionInfo type exposes the following members.
Constructors
 | Name | Description
Public method | SpanFilterResult PositionInfo | Initializes a new instance of the SpanFilterResult PositionInfo class
Back to Top
Methods
 | Name | Description
Public method | AddPosition |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Doc |
Public property | Positions |
Back to Top
See Also
SpanFilterResult PositionInfo Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilterResult.PositionInfo Constructor

SpanFilterResult PositionInfo Constructor Lucene.Net Class Library
Initializes a new instance of the SpanFilterResult PositionInfo class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PositionInfo(
    int doc
)
public PositionInfo(
    int doc
)
Public Sub New ( _
    doc As Integer _
)
Public Sub New ( _
    doc As Integer _
)
public:
PositionInfo(
    int doc
)
public:
PositionInfo(
    int doc
)
Parameters
doc
Type:   Online System Int32
See Also
SpanFilterResult PositionInfo Class
SpanFilterResult PositionInfo Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilterResult.PositionInfo Methods

SpanFilterResult PositionInfo Methods Lucene.Net Class Library
The SpanFilterResult PositionInfo type exposes the following members.
Methods
 | Name | Description
Public method | AddPosition |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SpanFilterResult PositionInfo Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddPosition Method

SpanFilterResult PositionInfo AddPosition Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AddPosition(
    int start,
    int end
)
public virtual void AddPosition(
    int start,
    int end
)
Public Overridable Sub AddPosition ( _
    start As Integer, _
    end As Integer _
)
Public Overridable Sub AddPosition ( _
    start As Integer, _
    end As Integer _
)
public:
virtual void AddPosition(
    int start,
    int end
)
public:
virtual void AddPosition(
    int start,
    int end
)
Parameters
start
Type:   Online System Int32
end
Type:   Online System Int32
See Also
SpanFilterResult PositionInfo Class
SpanFilterResult PositionInfo Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilterResult.PositionInfo Properties

SpanFilterResult PositionInfo Properties Lucene.Net Class Library
The SpanFilterResult PositionInfo type exposes the following members.
Properties
 | Name | Description
Public property | Doc |
Public property | Positions |
Back to Top
See Also
SpanFilterResult PositionInfo Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Property

SpanFilterResult PositionInfo Doc Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Doc { get; }
public virtual int Doc { get; }
Public Overridable ReadOnly Property Doc As Integer
    Get
Public Overridable ReadOnly Property Doc As Integer
    Get
public:
virtual property int Doc {
    int get ();
}
public:
virtual property int Doc {
    int get ();
}
See Also
SpanFilterResult PositionInfo Class
SpanFilterResult PositionInfo Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Positions Property

SpanFilterResult PositionInfo Positions Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IList<SpanFilterResult..::..StartEnd> Positions { get; }
public virtual IList<SpanFilterResult..::..StartEnd> Positions { get; }
Public Overridable ReadOnly Property Positions As IList(Of SpanFilterResult..::..StartEnd)
    Get
Public Overridable ReadOnly Property Positions As IList(Of SpanFilterResult..::..StartEnd)
    Get
public:
virtual property IList<SpanFilterResult..::..StartEnd^>^ Positions {
    IList<SpanFilterResult..::..StartEnd^>^ get ();
}
public:
virtual property IList<SpanFilterResult..::..StartEnd^>^ Positions {
    IList<SpanFilterResult..::..StartEnd^>^ get ();
}
Field Value
 A List of <see cref="Lucene.Net.Search.SpanFilterResult.StartEnd" /> objects
See Also
SpanFilterResult PositionInfo Class
SpanFilterResult PositionInfo Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilterResult.StartEnd Class

SpanFilterResult StartEnd Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search SpanFilterResult StartEnd

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class StartEnd
public class StartEnd
Public Class StartEnd
Public Class StartEnd
public ref class StartEnd
public ref class StartEnd
See Also
SpanFilterResult StartEnd Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilterResult.StartEnd Members

SpanFilterResult StartEnd Members Lucene.Net Class Library

The results of a SpanQueryFilter. Wraps the BitSet and the position information from the SpanQuery

NOTE: This API is still experimental and subject to change.

The SpanFilterResult StartEnd type exposes the following members.
Constructors
 | Name | Description
Public method | SpanFilterResult StartEnd | Initializes a new instance of the SpanFilterResult StartEnd class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | End |
Public property | Start | The Start position
Back to Top
See Also
SpanFilterResult StartEnd Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilterResult.StartEnd Constructor

SpanFilterResult StartEnd Constructor Lucene.Net Class Library
Initializes a new instance of the SpanFilterResult StartEnd class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StartEnd(
    int start,
    int end
)
public StartEnd(
    int start,
    int end
)
Public Sub New ( _
    start As Integer, _
    end As Integer _
)
Public Sub New ( _
    start As Integer, _
    end As Integer _
)
public:
StartEnd(
    int start,
    int end
)
public:
StartEnd(
    int start,
    int end
)
Parameters
start
Type:   Online System Int32
end
Type:   Online System Int32
See Also
SpanFilterResult StartEnd Class
SpanFilterResult StartEnd Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilterResult.StartEnd Methods

SpanFilterResult StartEnd Methods Lucene.Net Class Library
The SpanFilterResult StartEnd type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SpanFilterResult StartEnd Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFilterResult.StartEnd Properties

SpanFilterResult StartEnd Properties Lucene.Net Class Library
The SpanFilterResult StartEnd type exposes the following members.
Properties
 | Name | Description
Public property | End |
Public property | Start | The Start position
Back to Top
See Also
SpanFilterResult StartEnd Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


End Property

SpanFilterResult StartEnd End Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int End { get; }
public virtual int End { get; }
Public Overridable ReadOnly Property End As Integer
    Get
Public Overridable ReadOnly Property End As Integer
    Get
public:
virtual property int End {
    int get ();
}
public:
virtual property int End {
    int get ();
}
Field Value
 The end position of this match
See Also
SpanFilterResult StartEnd Class
SpanFilterResult StartEnd Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Start Property

SpanFilterResult StartEnd Start Property Lucene.Net Class Library
The Start position

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Start { get; }
public virtual int Start { get; }
Public Overridable ReadOnly Property Start As Integer
    Get
Public Overridable ReadOnly Property Start As Integer
    Get
public:
virtual property int Start {
    int get ();
}
public:
virtual property int Start {
    int get ();
}
Field Value
 The start position of this match
See Also
SpanFilterResult StartEnd Class
SpanFilterResult StartEnd Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanQueryFilter Class

SpanQueryFilter Class Lucene.Net Class Library
Constrains search results to only match those which also match a provided query. Also provides position information about where each document matches at the cost of extra space compared with the QueryWrapperFilter. There is an added cost to this above what is stored in a QueryWrapperFilter. Namely, the position information for each matching document is stored.

This filter does not cache. See the CachingSpanFilter for a wrapper that caches.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Filter
Lucene.Net.Search SpanFilter
Lucene.Net.Search SpanQueryFilter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SpanQueryFilter : SpanFilter
[SerializableAttribute]
public class SpanQueryFilter : SpanFilter
<SerializableAttribute> _
Public Class SpanQueryFilter _
    Inherits SpanFilter
<SerializableAttribute> _
Public Class SpanQueryFilter _
    Inherits SpanFilter
[SerializableAttribute]
public ref class SpanQueryFilter : public SpanFilter
[SerializableAttribute]
public ref class SpanQueryFilter : public SpanFilter
See Also
SpanQueryFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanQueryFilter Members

SpanQueryFilter Members Lucene.Net Class Library

The SpanQueryFilter type exposes the following members.
Constructors
 | Name | Description
Protected method | SpanQueryFilter | Initializes a new instance of the SpanQueryFilter class
Public method | SpanQueryFilter(SpanQuery) | Constructs a filter which only matches documents matching query.
Back to Top
Methods
 | Name | Description
Public method | BitSpans | (Overrides SpanFilter BitSpans(IndexReader).)
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Overrides Filter GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Fields
 | Name | Description
Protected field | internalQuery |
Back to Top
Properties
 | Name | Description
Public property | Query |
Back to Top
See Also
SpanQueryFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanQueryFilter Constructor

SpanQueryFilter Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Protected method | SpanQueryFilter | Initializes a new instance of the SpanQueryFilter class
Public method | SpanQueryFilter(SpanQuery) | Constructs a filter which only matches documents matching query.
Back to Top
See Also
SpanQueryFilter Class
SpanQueryFilter Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanQueryFilter Constructor

SpanQueryFilter Constructor Lucene.Net Class Library
Initializes a new instance of the SpanQueryFilter class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SpanQueryFilter()
protected SpanQueryFilter()
Protected Sub New
Protected Sub New
protected:
SpanQueryFilter()
protected:
SpanQueryFilter()
See Also
SpanQueryFilter Class
SpanQueryFilter Members
SpanQueryFilter Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanQueryFilter Constructor (SpanQuery)

SpanQueryFilter Constructor (SpanQuery) Lucene.Net Class Library
Constructs a filter which only matches documents matching query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SpanQueryFilter(
    SpanQuery query
)
public SpanQueryFilter(
    SpanQuery query
)
Public Sub New ( _
    query As SpanQuery _
)
Public Sub New ( _
    query As SpanQuery _
)
public:
SpanQueryFilter(
    SpanQuery^ query
)
public:
SpanQueryFilter(
    SpanQuery^ query
)
Parameters
query
Type: Lucene.Net.Search.Spans SpanQuery
The SpanQuery to use as the basis for the Filter.

See Also
SpanQueryFilter Class
SpanQueryFilter Members
SpanQueryFilter Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanQueryFilter Fields

SpanQueryFilter Fields Lucene.Net Class Library
The SpanQueryFilter type exposes the following members.
Fields
 | Name | Description
Protected field | internalQuery |
Back to Top
See Also
SpanQueryFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalQuery Field

SpanQueryFilter internalQuery Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SpanQuery internalQuery
protected SpanQuery internalQuery
Protected internalQuery As SpanQuery
Protected internalQuery As SpanQuery
protected:
SpanQuery^ internalQuery
protected:
SpanQuery^ internalQuery
See Also
SpanQueryFilter Class
SpanQueryFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanQueryFilter Methods

SpanQueryFilter Methods Lucene.Net Class Library
The SpanQueryFilter type exposes the following members.
Methods
 | Name | Description
Public method | BitSpans | (Overrides SpanFilter BitSpans(IndexReader).)
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Overrides Filter GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
SpanQueryFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitSpans Method

SpanQueryFilter BitSpans Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override SpanFilterResult BitSpans(
    IndexReader reader
)
public override SpanFilterResult BitSpans(
    IndexReader reader
)
Public Overrides Function BitSpans ( _
    reader As IndexReader _
) As SpanFilterResult
Public Overrides Function BitSpans ( _
    reader As IndexReader _
) As SpanFilterResult
public:
virtual SpanFilterResult^ BitSpans(
    IndexReader^ reader
) override
public:
virtual SpanFilterResult^ BitSpans(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
SpanQueryFilter Class
SpanQueryFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

SpanQueryFilter Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
SpanQueryFilter Class
SpanQueryFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetDocIdSet Method

SpanQueryFilter GetDocIdSet Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
SpanQueryFilter Class
SpanQueryFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

SpanQueryFilter GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
SpanQueryFilter Class
SpanQueryFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

SpanQueryFilter ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
SpanQueryFilter Class
SpanQueryFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanQueryFilter Properties

SpanQueryFilter Properties Lucene.Net Class Library
The SpanQueryFilter type exposes the following members.
Properties
 | Name | Description
Public property | Query |
Back to Top
See Also
SpanQueryFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Query Property

SpanQueryFilter Query Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual SpanQuery Query { get; }
public virtual SpanQuery Query { get; }
Public Overridable ReadOnly Property Query As SpanQuery
    Get
Public Overridable ReadOnly Property Query As SpanQuery
    Get
public:
virtual property SpanQuery^ Query {
    SpanQuery^ get ();
}
public:
virtual property SpanQuery^ Query {
    SpanQuery^ get ();
}
See Also
SpanQueryFilter Class
SpanQueryFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringIndex Class

StringIndex Class Lucene.Net Class Library
Expert: Stores term text values and document ordering data.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search StringIndex

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class StringIndex
public class StringIndex
Public Class StringIndex
Public Class StringIndex
public ref class StringIndex
public ref class StringIndex
See Also
StringIndex Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringIndex Members

StringIndex Members Lucene.Net Class Library

The StringIndex type exposes the following members.
Constructors
 | Name | Description
Public method | StringIndex | Creates one of these objects
Back to Top
Methods
 | Name | Description
Public method | BinarySearchLookup |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Public field | lookup | All the term values, in natural order.
Public field | order | For each document, an index into the lookup array.
Back to Top
See Also
StringIndex Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringIndex Constructor

StringIndex Constructor Lucene.Net Class Library
Creates one of these objects

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StringIndex(
    int[] values,
    string[] lookup
)
public StringIndex(
    int[] values,
    string[] lookup
)
Public Sub New ( _
    values As Integer(), _
    lookup As String() _
)
Public Sub New ( _
    values As Integer(), _
    lookup As String() _
)
public:
StringIndex(
    array<int>^ values,
    array<String^>^ lookup
)
public:
StringIndex(
    array<int>^ values,
    array<String^>^ lookup
)
Parameters
values
Type:    Online System Int32
lookup
Type:    Online System String
See Also
StringIndex Class
StringIndex Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringIndex Fields

StringIndex Fields Lucene.Net Class Library
The StringIndex type exposes the following members.
Fields
 | Name | Description
Public field | lookup | All the term values, in natural order.
Public field | order | For each document, an index into the lookup array.
Back to Top
See Also
StringIndex Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


lookup Field

StringIndex lookup Field Lucene.Net Class Library
All the term values, in natural order.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string[] lookup
public string[] lookup
Public lookup As String()
Public lookup As String()
public:
array<String^>^ lookup
public:
array<String^>^ lookup
See Also
StringIndex Class
StringIndex Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


order Field

StringIndex order Field Lucene.Net Class Library
For each document, an index into the lookup array.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int[] order
public int[] order
Public order As Integer()
Public order As Integer()
public:
array<int>^ order
public:
array<int>^ order
See Also
StringIndex Class
StringIndex Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringIndex Methods

StringIndex Methods Lucene.Net Class Library
The StringIndex type exposes the following members.
Methods
 | Name | Description
Public method | BinarySearchLookup |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
StringIndex Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BinarySearchLookup Method

StringIndex BinarySearchLookup Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int BinarySearchLookup(
    string key
)
public virtual int BinarySearchLookup(
    string key
)
Public Overridable Function BinarySearchLookup ( _
    key As String _
) As Integer
Public Overridable Function BinarySearchLookup ( _
    key As String _
) As Integer
public:
virtual int BinarySearchLookup(
    String^ key
)
public:
virtual int BinarySearchLookup(
    String^ key
)
Parameters
key
Type:   Online System String
See Also
StringIndex Class
StringIndex Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermQuery Class

TermQuery Class Lucene.Net Class Library
A Query that matches documents containing a term. This may be combined with other terms with a BooleanQuery.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search TermQuery

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TermQuery : Query
[SerializableAttribute]
public class TermQuery : Query
<SerializableAttribute> _
Public Class TermQuery _
    Inherits Query
<SerializableAttribute> _
Public Class TermQuery _
    Inherits Query
[SerializableAttribute]
public ref class TermQuery : public Query
[SerializableAttribute]
public ref class TermQuery : public Query
See Also
TermQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermQuery Members

TermQuery Members Lucene.Net Class Library

The TermQuery type exposes the following members.
Constructors
 | Name | Description
Public method | TermQuery | Constructs a query for the term t.
Back to Top
Methods
 | Name | Description
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | Returns true iff o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys. (Inherited from Query.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Term | Returns the term of this query.
Back to Top
See Also
TermQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermQuery Constructor

TermQuery Constructor Lucene.Net Class Library
Constructs a query for the term t.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TermQuery(
    Term t
)
public TermQuery(
    Term t
)
Public Sub New ( _
    t As Term _
)
Public Sub New ( _
    t As Term _
)
public:
TermQuery(
    Term^ t
)
public:
TermQuery(
    Term^ t
)
Parameters
t
Type: Lucene.Net.Index Term
See Also
TermQuery Class
TermQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermQuery Methods

TermQuery Methods Lucene.Net Class Library
The TermQuery type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | Returns true iff o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys. (Inherited from Query.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
TermQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateWeight Method

TermQuery CreateWeight Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Weight CreateWeight(
    Searcher searcher
)
public override Weight CreateWeight(
    Searcher searcher
)
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
TermQuery Class
TermQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

TermQuery Equals Method Lucene.Net Class Library
Returns true iff o is equal to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
TermQuery Class
TermQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExtractTerms Method

TermQuery ExtractTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ExtractTerms(
    ISet<Term> terms
)
public override void ExtractTerms(
    ISet<Term> terms
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
Parameters
terms
Type:   Online System.Collections.Generic ISet  Term
See Also
TermQuery Class
TermQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

TermQuery GetHashCode Method Lucene.Net Class Library
Returns a hash code value for this object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
TermQuery Class
TermQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

TermQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Back to Top
See Also
TermQuery Class
TermQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

TermQuery ToString Method (String) Lucene.Net Class Library
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
TermQuery Class
TermQuery Members
ToString Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermQuery Properties

TermQuery Properties Lucene.Net Class Library
The TermQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Term | Returns the term of this query.
Back to Top
See Also
TermQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Property

TermQuery Term Property Lucene.Net Class Library
Returns the term of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Term Term { get; }
public virtual Term Term { get; }
Public Overridable ReadOnly Property Term As Term
    Get
Public Overridable ReadOnly Property Term As Term
    Get
public:
virtual property Term^ Term {
    Term^ get ();
}
public:
virtual property Term^ Term {
    Term^ get ();
}
See Also
TermQuery Class
TermQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeFilter Class

TermRangeFilter Class Lucene.Net Class Library
A Filter that restricts search results to a range of values in a given field.

This filter matches the documents looking for terms that fall into the supplied range according to Online CompareTo(String). It is not intended for numerical ranges, use NumericRangeFilter T instead.

If you construct a large number of range filters with different ranges but on the same field, FieldCacheRangeFilter may have significantly better performance.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Filter
Lucene.Net.Search MultiTermQueryWrapperFilter TermRangeQuery
Lucene.Net.Search TermRangeFilter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TermRangeFilter : MultiTermQueryWrapperFilter<TermRangeQuery>
[SerializableAttribute]
public class TermRangeFilter : MultiTermQueryWrapperFilter<TermRangeQuery>
<SerializableAttribute> _
Public Class TermRangeFilter _
    Inherits MultiTermQueryWrapperFilter(Of TermRangeQuery)
<SerializableAttribute> _
Public Class TermRangeFilter _
    Inherits MultiTermQueryWrapperFilter(Of TermRangeQuery)
[SerializableAttribute]
public ref class TermRangeFilter : public MultiTermQueryWrapperFilter<TermRangeQuery^>
[SerializableAttribute]
public ref class TermRangeFilter : public MultiTermQueryWrapperFilter<TermRangeQuery^>
See Also
TermRangeFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeFilter Members

TermRangeFilter Members Lucene.Net Class Library

The TermRangeFilter type exposes the following members.
Constructors
 | Name | Description
Public method | TermRangeFilter(String, String, String, Boolean, Boolean) | lowerTerm is null and includeLower is true (similar for upperTerm and includeUpper)
Public method | TermRangeFilter(String, String, String, Boolean, Boolean, CompareInfo) | WARNING: Using this constructor and supplying a non-null value in the collator parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.
Back to Top
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the filter. (Inherited from MultiTermQueryWrapperFilter T .)
Public method | Equals | (Inherited from MultiTermQueryWrapperFilter T .)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Inherited from MultiTermQueryWrapperFilter T .)
Public method | GetHashCode | (Inherited from MultiTermQueryWrapperFilter T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Less | Constructs a filter for field fieldName matching less than or equal to upperTerm.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | More | Constructs a filter for field fieldName matching greater than or equal to lowerTerm.
Public method | ToString | (Inherited from MultiTermQueryWrapperFilter T .)
Back to Top
Fields
 | Name | Description
Protected field | query | (Inherited from MultiTermQueryWrapperFilter T .)
Back to Top
Properties
 | Name | Description
Public property | Collator | Returns the collator used to determine range inclusion, if any.
Public property | Field | Returns the field name for this filter
Public property | IncludesLower | Returns true if the lower endpoint is inclusive
Public property | IncludesUpper | Returns true if the upper endpoint is inclusive
Public property | LowerTerm | Returns the lower value of this range filter
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . (Inherited from MultiTermQueryWrapperFilter T .)
Public property | UpperTerm | Returns the upper value of this range filter
Back to Top
See Also
TermRangeFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeFilter Constructor

TermRangeFilter Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TermRangeFilter(String, String, String, Boolean, Boolean) | lowerTerm is null and includeLower is true (similar for upperTerm and includeUpper)
Public method | TermRangeFilter(String, String, String, Boolean, Boolean, CompareInfo) | WARNING: Using this constructor and supplying a non-null value in the collator parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.
Back to Top
See Also
TermRangeFilter Class
TermRangeFilter Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeFilter Constructor (String, String, String, Boolean, Boolean)

TermRangeFilter Constructor (String, String, String, Boolean, Boolean) Lucene.Net Class Library
lowerTerm is null and includeLower is true (similar for upperTerm and includeUpper)

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TermRangeFilter(
    string fieldName,
    string lowerTerm,
    string upperTerm,
    bool includeLower,
    bool includeUpper
)
public TermRangeFilter(
    string fieldName,
    string lowerTerm,
    string upperTerm,
    bool includeLower,
    bool includeUpper
)
Public Sub New ( _
    fieldName As String, _
    lowerTerm As String, _
    upperTerm As String, _
    includeLower As Boolean, _
    includeUpper As Boolean _
)
Public Sub New ( _
    fieldName As String, _
    lowerTerm As String, _
    upperTerm As String, _
    includeLower As Boolean, _
    includeUpper As Boolean _
)
public:
TermRangeFilter(
    String^ fieldName,
    String^ lowerTerm,
    String^ upperTerm,
    bool includeLower,
    bool includeUpper
)
public:
TermRangeFilter(
    String^ fieldName,
    String^ lowerTerm,
    String^ upperTerm,
    bool includeLower,
    bool includeUpper
)
Parameters
fieldName
Type:   Online System String
The field this range applies to

lowerTerm
Type:   Online System String
The lower bound on this range

upperTerm
Type:   Online System String
The upper bound on this range

includeLower
Type:   Online System Boolean
Does this range include the lower bound?

includeUpper
Type:   Online System Boolean
Does this range include the upper bound?

See Also
TermRangeFilter Class
TermRangeFilter Members
TermRangeFilter Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeFilter Constructor (String, String, String, Boolean, Boolean, CompareInfo)

TermRangeFilter Constructor (String, String, String, Boolean, Boolean, CompareInfo) Lucene.Net Class Library
WARNING: Using this constructor and supplying a non-null value in the collator parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.
lowerTerm is null and includeLower is true (similar for upperTerm and includeUpper)

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TermRangeFilter(
    string fieldName,
    string lowerTerm,
    string upperTerm,
    bool includeLower,
    bool includeUpper,
    CompareInfo collator
)
public TermRangeFilter(
    string fieldName,
    string lowerTerm,
    string upperTerm,
    bool includeLower,
    bool includeUpper,
    CompareInfo collator
)
Public Sub New ( _
    fieldName As String, _
    lowerTerm As String, _
    upperTerm As String, _
    includeLower As Boolean, _
    includeUpper As Boolean, _
    collator As CompareInfo _
)
Public Sub New ( _
    fieldName As String, _
    lowerTerm As String, _
    upperTerm As String, _
    includeLower As Boolean, _
    includeUpper As Boolean, _
    collator As CompareInfo _
)
public:
TermRangeFilter(
    String^ fieldName,
    String^ lowerTerm,
    String^ upperTerm,
    bool includeLower,
    bool includeUpper,
    CompareInfo^ collator
)
public:
TermRangeFilter(
    String^ fieldName,
    String^ lowerTerm,
    String^ upperTerm,
    bool includeLower,
    bool includeUpper,
    CompareInfo^ collator
)
Parameters
fieldName
Type:   Online System String
lowerTerm
Type:   Online System String
The lower bound on this range

upperTerm
Type:   Online System String
The upper bound on this range

includeLower
Type:   Online System Boolean
Does this range include the lower bound?

includeUpper
Type:   Online System Boolean
Does this range include the upper bound?

collator
Type:   Online System.Globalization CompareInfo
The collator to use when determining range inclusion; set
            to null to use Unicode code point ordering instead of collation.

See Also
TermRangeFilter Class
TermRangeFilter Members
TermRangeFilter Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeFilter Fields

TermRangeFilter Fields Lucene.Net Class Library
The TermRangeFilter type exposes the following members.
Fields
 | Name | Description
Protected field | query | (Inherited from MultiTermQueryWrapperFilter T .)
Back to Top
See Also
TermRangeFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeFilter Methods

TermRangeFilter Methods Lucene.Net Class Library
The TermRangeFilter type exposes the following members.
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the filter. (Inherited from MultiTermQueryWrapperFilter T .)
Public method | Equals | (Inherited from MultiTermQueryWrapperFilter T .)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDocIdSet | (Inherited from MultiTermQueryWrapperFilter T .)
Public method | GetHashCode | (Inherited from MultiTermQueryWrapperFilter T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Less | Constructs a filter for field fieldName matching less than or equal to upperTerm.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | More | Constructs a filter for field fieldName matching greater than or equal to lowerTerm.
Public method | ToString | (Inherited from MultiTermQueryWrapperFilter T .)
Back to Top
See Also
TermRangeFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Less Method

TermRangeFilter Less Method Lucene.Net Class Library
Constructs a filter for field fieldName matching less than or equal to upperTerm.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TermRangeFilter Less(
    string fieldName,
    string upperTerm
)
public static TermRangeFilter Less(
    string fieldName,
    string upperTerm
)
Public Shared Function Less ( _
    fieldName As String, _
    upperTerm As String _
) As TermRangeFilter
Public Shared Function Less ( _
    fieldName As String, _
    upperTerm As String _
) As TermRangeFilter
public:
static TermRangeFilter^ Less(
    String^ fieldName,
    String^ upperTerm
)
public:
static TermRangeFilter^ Less(
    String^ fieldName,
    String^ upperTerm
)
Parameters
fieldName
Type:   Online System String
upperTerm
Type:   Online System String
See Also
TermRangeFilter Class
TermRangeFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


More Method

TermRangeFilter More Method Lucene.Net Class Library
Constructs a filter for field fieldName matching greater than or equal to lowerTerm.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TermRangeFilter More(
    string fieldName,
    string lowerTerm
)
public static TermRangeFilter More(
    string fieldName,
    string lowerTerm
)
Public Shared Function More ( _
    fieldName As String, _
    lowerTerm As String _
) As TermRangeFilter
Public Shared Function More ( _
    fieldName As String, _
    lowerTerm As String _
) As TermRangeFilter
public:
static TermRangeFilter^ More(
    String^ fieldName,
    String^ lowerTerm
)
public:
static TermRangeFilter^ More(
    String^ fieldName,
    String^ lowerTerm
)
Parameters
fieldName
Type:   Online System String
lowerTerm
Type:   Online System String
See Also
TermRangeFilter Class
TermRangeFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeFilter Properties

TermRangeFilter Properties Lucene.Net Class Library
The TermRangeFilter type exposes the following members.
Properties
 | Name | Description
Public property | Collator | Returns the collator used to determine range inclusion, if any.
Public property | Field | Returns the field name for this filter
Public property | IncludesLower | Returns true if the lower endpoint is inclusive
Public property | IncludesUpper | Returns true if the upper endpoint is inclusive
Public property | LowerTerm | Returns the lower value of this range filter
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . (Inherited from MultiTermQueryWrapperFilter T .)
Public property | UpperTerm | Returns the upper value of this range filter
Back to Top
See Also
TermRangeFilter Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Collator Property

TermRangeFilter Collator Property Lucene.Net Class Library
Returns the collator used to determine range inclusion, if any.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual CompareInfo Collator { get; }
public virtual CompareInfo Collator { get; }
Public Overridable ReadOnly Property Collator As CompareInfo
    Get
Public Overridable ReadOnly Property Collator As CompareInfo
    Get
public:
virtual property CompareInfo^ Collator {
    CompareInfo^ get ();
}
public:
virtual property CompareInfo^ Collator {
    CompareInfo^ get ();
}
See Also
TermRangeFilter Class
TermRangeFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

TermRangeFilter Field Property Lucene.Net Class Library
Returns the field name for this filter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Field { get; }
public virtual string Field { get; }
Public Overridable ReadOnly Property Field As String
    Get
Public Overridable ReadOnly Property Field As String
    Get
public:
virtual property String^ Field {
    String^ get ();
}
public:
virtual property String^ Field {
    String^ get ();
}
See Also
TermRangeFilter Class
TermRangeFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncludesLower Property

TermRangeFilter IncludesLower Property Lucene.Net Class Library
Returns true if the lower endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IncludesLower { get; }
public virtual bool IncludesLower { get; }
Public Overridable ReadOnly Property IncludesLower As Boolean
    Get
Public Overridable ReadOnly Property IncludesLower As Boolean
    Get
public:
virtual property bool IncludesLower {
    bool get ();
}
public:
virtual property bool IncludesLower {
    bool get ();
}
See Also
TermRangeFilter Class
TermRangeFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncludesUpper Property

TermRangeFilter IncludesUpper Property Lucene.Net Class Library
Returns true if the upper endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IncludesUpper { get; }
public virtual bool IncludesUpper { get; }
Public Overridable ReadOnly Property IncludesUpper As Boolean
    Get
Public Overridable ReadOnly Property IncludesUpper As Boolean
    Get
public:
virtual property bool IncludesUpper {
    bool get ();
}
public:
virtual property bool IncludesUpper {
    bool get ();
}
See Also
TermRangeFilter Class
TermRangeFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerTerm Property

TermRangeFilter LowerTerm Property Lucene.Net Class Library
Returns the lower value of this range filter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string LowerTerm { get; }
public virtual string LowerTerm { get; }
Public Overridable ReadOnly Property LowerTerm As String
    Get
Public Overridable ReadOnly Property LowerTerm As String
    Get
public:
virtual property String^ LowerTerm {
    String^ get ();
}
public:
virtual property String^ LowerTerm {
    String^ get ();
}
See Also
TermRangeFilter Class
TermRangeFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UpperTerm Property

TermRangeFilter UpperTerm Property Lucene.Net Class Library
Returns the upper value of this range filter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string UpperTerm { get; }
public virtual string UpperTerm { get; }
Public Overridable ReadOnly Property UpperTerm As String
    Get
Public Overridable ReadOnly Property UpperTerm As String
    Get
public:
virtual property String^ UpperTerm {
    String^ get ();
}
public:
virtual property String^ UpperTerm {
    String^ get ();
}
See Also
TermRangeFilter Class
TermRangeFilter Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeQuery Class

TermRangeQuery Class Lucene.Net Class Library
A Query that matches documents within an exclusive range of terms.

This query matches the documents looking for terms that fall into the supplied range according to Online CompareTo(String). It is not intended for numerical ranges, use NumericRangeQuery T instead.

This query uses the CONSTANT_SCORE_AUTO_REWRITE_DEFAULT rewrite method.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search MultiTermQuery
Lucene.Net.Search TermRangeQuery

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TermRangeQuery : MultiTermQuery
[SerializableAttribute]
public class TermRangeQuery : MultiTermQuery
<SerializableAttribute> _
Public Class TermRangeQuery _
    Inherits MultiTermQuery
<SerializableAttribute> _
Public Class TermRangeQuery _
    Inherits MultiTermQuery
[SerializableAttribute]
public ref class TermRangeQuery : public MultiTermQuery
[SerializableAttribute]
public ref class TermRangeQuery : public MultiTermQuery
See Also
TermRangeQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeQuery Members

TermRangeQuery Members Lucene.Net Class Library

The TermRangeQuery type exposes the following members.
Constructors
 | Name | Description
Public method | TermRangeQuery(String, String, String, Boolean, Boolean) | Constructs a query selecting all terms greater/equal than lowerTerm but less/equal than upperTerm. If an endpoint is null, it is said to be "open". Either or both endpoints may be open. Open endpoints may not be exclusive (you can't select all but the first or last term without explicitly specifying the term to exclude.)
Public method | TermRangeQuery(String, String, String, Boolean, Boolean, CompareInfo) | Constructs a query selecting all terms greater/equal than lowerTerm but less/equal than upperTerm. If an endpoint is null, it is said to be "open". Either or both endpoints may be open. Open endpoints may not be exclusive (you can't select all but the first or last term without explicitly specifying the term to exclude.) If collator is not null, it will be used to decide whether index terms are within the given range, rather than using the Unicode code point order in which index terms are stored. WARNING: Using this constructor and supplying a non-null value in the collator parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.
Back to Top
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the query/filter. (Inherited from MultiTermQuery.)
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | Expert: Constructs an appropriate Weight implementation for this query. Only implemented by primitive queries, which re-write to themselves. (Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery Equals(Object).)
Public method | ExtractTerms | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its rewritten form. (Inherited from Query.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetEnum | (Overrides MultiTermQuery GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Inherited from MultiTermQuery.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Fields
 | Name | Description
Protected field | internalRewriteMethod | (Inherited from MultiTermQuery.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Collator | Returns the collator used to determine range inclusion, if any.
Public property | Field | Returns the field name for this query
Public property | IncludesLower | Returns true if the lower endpoint is inclusive
Public property | IncludesUpper | Returns true if the upper endpoint is inclusive
Public property | LowerTerm | Returns the lower value of this range query
Public property | RewriteMethod | Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of RewriteMethod. (Inherited from MultiTermQuery.)
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers. (Inherited from MultiTermQuery.)
Public property | UpperTerm | Returns the upper value of this range query
Back to Top
See Also
TermRangeQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeQuery Constructor

TermRangeQuery Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TermRangeQuery(String, String, String, Boolean, Boolean) | Constructs a query selecting all terms greater/equal than lowerTerm but less/equal than upperTerm. If an endpoint is null, it is said to be "open". Either or both endpoints may be open. Open endpoints may not be exclusive (you can't select all but the first or last term without explicitly specifying the term to exclude.)
Public method | TermRangeQuery(String, String, String, Boolean, Boolean, CompareInfo) | Constructs a query selecting all terms greater/equal than lowerTerm but less/equal than upperTerm. If an endpoint is null, it is said to be "open". Either or both endpoints may be open. Open endpoints may not be exclusive (you can't select all but the first or last term without explicitly specifying the term to exclude.) If collator is not null, it will be used to decide whether index terms are within the given range, rather than using the Unicode code point order in which index terms are stored. WARNING: Using this constructor and supplying a non-null value in the collator parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.
Back to Top
See Also
TermRangeQuery Class
TermRangeQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeQuery Constructor (String, String, String, Boolean, Boolean)

TermRangeQuery Constructor (String, String, String, Boolean, Boolean) Lucene.Net Class Library
Constructs a query selecting all terms greater/equal than lowerTerm but less/equal than upperTerm.

If an endpoint is null, it is said to be "open". Either or both endpoints may be open. Open endpoints may not be exclusive (you can't select all but the first or last term without explicitly specifying the term to exclude.)

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TermRangeQuery(
    string field,
    string lowerTerm,
    string upperTerm,
    bool includeLower,
    bool includeUpper
)
public TermRangeQuery(
    string field,
    string lowerTerm,
    string upperTerm,
    bool includeLower,
    bool includeUpper
)
Public Sub New ( _
    field As String, _
    lowerTerm As String, _
    upperTerm As String, _
    includeLower As Boolean, _
    includeUpper As Boolean _
)
Public Sub New ( _
    field As String, _
    lowerTerm As String, _
    upperTerm As String, _
    includeLower As Boolean, _
    includeUpper As Boolean _
)
public:
TermRangeQuery(
    String^ field,
    String^ lowerTerm,
    String^ upperTerm,
    bool includeLower,
    bool includeUpper
)
public:
TermRangeQuery(
    String^ field,
    String^ lowerTerm,
    String^ upperTerm,
    bool includeLower,
    bool includeUpper
)
Parameters
field
Type:   Online System String
The field that holds both lower and upper terms.

lowerTerm
Type:   Online System String
The term text at the lower end of the range

upperTerm
Type:   Online System String
The term text at the upper end of the range

includeLower
Type:   Online System Boolean
If true, the lowerTerm is
            included in the range.

includeUpper
Type:   Online System Boolean
If true, the upperTerm is
            included in the range.

See Also
TermRangeQuery Class
TermRangeQuery Members
TermRangeQuery Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeQuery Constructor (String, String, String, Boolean, Boolean, CompareInfo)

TermRangeQuery Constructor (String, String, String, Boolean, Boolean, CompareInfo) Lucene.Net Class Library
Constructs a query selecting all terms greater/equal than lowerTerm but less/equal than upperTerm.

If an endpoint is null, it is said to be "open". Either or both endpoints may be open. Open endpoints may not be exclusive (you can't select all but the first or last term without explicitly specifying the term to exclude.)

If collator is not null, it will be used to decide whether index terms are within the given range, rather than using the Unicode code point order in which index terms are stored.

WARNING: Using this constructor and supplying a non-null value in the collator parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TermRangeQuery(
    string field,
    string lowerTerm,
    string upperTerm,
    bool includeLower,
    bool includeUpper,
    CompareInfo collator
)
public TermRangeQuery(
    string field,
    string lowerTerm,
    string upperTerm,
    bool includeLower,
    bool includeUpper,
    CompareInfo collator
)
Public Sub New ( _
    field As String, _
    lowerTerm As String, _
    upperTerm As String, _
    includeLower As Boolean, _
    includeUpper As Boolean, _
    collator As CompareInfo _
)
Public Sub New ( _
    field As String, _
    lowerTerm As String, _
    upperTerm As String, _
    includeLower As Boolean, _
    includeUpper As Boolean, _
    collator As CompareInfo _
)
public:
TermRangeQuery(
    String^ field,
    String^ lowerTerm,
    String^ upperTerm,
    bool includeLower,
    bool includeUpper,
    CompareInfo^ collator
)
public:
TermRangeQuery(
    String^ field,
    String^ lowerTerm,
    String^ upperTerm,
    bool includeLower,
    bool includeUpper,
    CompareInfo^ collator
)
Parameters
field
Type:   Online System String
lowerTerm
Type:   Online System String
The Term text at the lower end of the range

upperTerm
Type:   Online System String
The Term text at the upper end of the range

includeLower
Type:   Online System Boolean
If true, the lowerTerm is
            included in the range.

includeUpper
Type:   Online System Boolean
If true, the upperTerm is
            included in the range.

collator
Type:   Online System.Globalization CompareInfo
The collator to use to collate index Terms, to determine
            their membership in the range bounded by lowerTerm and
            upperTerm.

See Also
TermRangeQuery Class
TermRangeQuery Members
TermRangeQuery Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeQuery Fields

TermRangeQuery Fields Lucene.Net Class Library
The TermRangeQuery type exposes the following members.
Fields
 | Name | Description
Protected field | internalRewriteMethod | (Inherited from MultiTermQuery.)
Back to Top
See Also
TermRangeQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeQuery Methods

TermRangeQuery Methods Lucene.Net Class Library
The TermRangeQuery type exposes the following members.
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the query/filter. (Inherited from MultiTermQuery.)
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | Expert: Constructs an appropriate Weight implementation for this query. Only implemented by primitive queries, which re-write to themselves. (Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery Equals(Object).)
Public method | ExtractTerms | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its rewritten form. (Inherited from Query.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetEnum | (Overrides MultiTermQuery GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Inherited from MultiTermQuery.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
TermRangeQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

TermRangeQuery Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
TermRangeQuery Class
TermRangeQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetEnum Method

TermRangeQuery GetEnum Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override FilteredTermEnum GetEnum(
    IndexReader reader
)
protected override FilteredTermEnum GetEnum(
    IndexReader reader
)
Protected Overrides Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
Protected Overrides Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
protected:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) override
protected:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
TermRangeQuery Class
TermRangeQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

TermRangeQuery GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
TermRangeQuery Class
TermRangeQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

TermRangeQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Back to Top
See Also
TermRangeQuery Class
TermRangeQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

TermRangeQuery ToString Method (String) Lucene.Net Class Library
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
TermRangeQuery Class
TermRangeQuery Members
ToString Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeQuery Properties

TermRangeQuery Properties Lucene.Net Class Library
The TermRangeQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Collator | Returns the collator used to determine range inclusion, if any.
Public property | Field | Returns the field name for this query
Public property | IncludesLower | Returns true if the lower endpoint is inclusive
Public property | IncludesUpper | Returns true if the upper endpoint is inclusive
Public property | LowerTerm | Returns the lower value of this range query
Public property | RewriteMethod | Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of RewriteMethod. (Inherited from MultiTermQuery.)
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers. (Inherited from MultiTermQuery.)
Public property | UpperTerm | Returns the upper value of this range query
Back to Top
See Also
TermRangeQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Collator Property

TermRangeQuery Collator Property Lucene.Net Class Library
Returns the collator used to determine range inclusion, if any.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual CompareInfo Collator { get; }
public virtual CompareInfo Collator { get; }
Public Overridable ReadOnly Property Collator As CompareInfo
    Get
Public Overridable ReadOnly Property Collator As CompareInfo
    Get
public:
virtual property CompareInfo^ Collator {
    CompareInfo^ get ();
}
public:
virtual property CompareInfo^ Collator {
    CompareInfo^ get ();
}
See Also
TermRangeQuery Class
TermRangeQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

TermRangeQuery Field Property Lucene.Net Class Library
Returns the field name for this query

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Field { get; }
public virtual string Field { get; }
Public Overridable ReadOnly Property Field As String
    Get
Public Overridable ReadOnly Property Field As String
    Get
public:
virtual property String^ Field {
    String^ get ();
}
public:
virtual property String^ Field {
    String^ get ();
}
See Also
TermRangeQuery Class
TermRangeQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncludesLower Property

TermRangeQuery IncludesLower Property Lucene.Net Class Library
Returns true if the lower endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IncludesLower { get; }
public virtual bool IncludesLower { get; }
Public Overridable ReadOnly Property IncludesLower As Boolean
    Get
Public Overridable ReadOnly Property IncludesLower As Boolean
    Get
public:
virtual property bool IncludesLower {
    bool get ();
}
public:
virtual property bool IncludesLower {
    bool get ();
}
See Also
TermRangeQuery Class
TermRangeQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IncludesUpper Property

TermRangeQuery IncludesUpper Property Lucene.Net Class Library
Returns true if the upper endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IncludesUpper { get; }
public virtual bool IncludesUpper { get; }
Public Overridable ReadOnly Property IncludesUpper As Boolean
    Get
Public Overridable ReadOnly Property IncludesUpper As Boolean
    Get
public:
virtual property bool IncludesUpper {
    bool get ();
}
public:
virtual property bool IncludesUpper {
    bool get ();
}
See Also
TermRangeQuery Class
TermRangeQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LowerTerm Property

TermRangeQuery LowerTerm Property Lucene.Net Class Library
Returns the lower value of this range query

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string LowerTerm { get; }
public virtual string LowerTerm { get; }
Public Overridable ReadOnly Property LowerTerm As String
    Get
Public Overridable ReadOnly Property LowerTerm As String
    Get
public:
virtual property String^ LowerTerm {
    String^ get ();
}
public:
virtual property String^ LowerTerm {
    String^ get ();
}
See Also
TermRangeQuery Class
TermRangeQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UpperTerm Property

TermRangeQuery UpperTerm Property Lucene.Net Class Library
Returns the upper value of this range query

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string UpperTerm { get; }
public virtual string UpperTerm { get; }
Public Overridable ReadOnly Property UpperTerm As String
    Get
Public Overridable ReadOnly Property UpperTerm As String
    Get
public:
virtual property String^ UpperTerm {
    String^ get ();
}
public:
virtual property String^ UpperTerm {
    String^ get ();
}
See Also
TermRangeQuery Class
TermRangeQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeTermEnum Class

TermRangeTermEnum Class Lucene.Net Class Library
Subclass of FilteredTermEnum for enumerating all terms that match the specified range parameters.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index TermEnum
Lucene.Net.Search FilteredTermEnum
Lucene.Net.Search TermRangeTermEnum

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TermRangeTermEnum : FilteredTermEnum
public class TermRangeTermEnum : FilteredTermEnum
Public Class TermRangeTermEnum _
    Inherits FilteredTermEnum
Public Class TermRangeTermEnum _
    Inherits FilteredTermEnum
public ref class TermRangeTermEnum : public FilteredTermEnum
public ref class TermRangeTermEnum : public FilteredTermEnum
See Also
TermRangeTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeTermEnum Members

TermRangeTermEnum Members Lucene.Net Class Library

The TermRangeTermEnum type exposes the following members.
Constructors
 | Name | Description
Public method | TermRangeTermEnum | Enumerates all terms greater/equal than lowerTerm but less/equal than upperTerm. If an endpoint is null, it is said to be "open". Either or both endpoints may be open. Open endpoints may not be exclusive (you can't select all but the first or last term without explicitly specifying the term to exclude.)
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Public method | Difference | (Overrides FilteredTermEnum Difference .)
Public method | Dispose | Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Protected method | Dispose(Boolean) | (Inherited from FilteredTermEnum.)
Public method | DocFreq | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum EndEnum .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | Increments the enumeration to the next element. True if one exists. (Inherited from FilteredTermEnum.)
Protected method | SetEnum | use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term. (Inherited from FilteredTermEnum.)
Protected method | TermCompare | (Overrides FilteredTermEnum TermCompare(Term).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use SetEnum(TermEnum) (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)
Back to Top
Properties
 | Name | Description
Public property | Term | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Back to Top
See Also
TermRangeTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeTermEnum Constructor

TermRangeTermEnum Constructor Lucene.Net Class Library
Enumerates all terms greater/equal than lowerTerm but less/equal than upperTerm. If an endpoint is null, it is said to be "open". Either or both endpoints may be open. Open endpoints may not be exclusive (you can't select all but the first or last term without explicitly specifying the term to exclude.)

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TermRangeTermEnum(
    IndexReader reader,
    string field,
    string lowerTermText,
    string upperTermText,
    bool includeLower,
    bool includeUpper,
    CompareInfo collator
)
public TermRangeTermEnum(
    IndexReader reader,
    string field,
    string lowerTermText,
    string upperTermText,
    bool includeLower,
    bool includeUpper,
    CompareInfo collator
)
Public Sub New ( _
    reader As IndexReader, _
    field As String, _
    lowerTermText As String, _
    upperTermText As String, _
    includeLower As Boolean, _
    includeUpper As Boolean, _
    collator As CompareInfo _
)
Public Sub New ( _
    reader As IndexReader, _
    field As String, _
    lowerTermText As String, _
    upperTermText As String, _
    includeLower As Boolean, _
    includeUpper As Boolean, _
    collator As CompareInfo _
)
public:
TermRangeTermEnum(
    IndexReader^ reader,
    String^ field,
    String^ lowerTermText,
    String^ upperTermText,
    bool includeLower,
    bool includeUpper,
    CompareInfo^ collator
)
public:
TermRangeTermEnum(
    IndexReader^ reader,
    String^ field,
    String^ lowerTermText,
    String^ upperTermText,
    bool includeLower,
    bool includeUpper,
    CompareInfo^ collator
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
field
Type:   Online System String
An interned field that holds both lower and upper terms.

lowerTermText
Type:   Online System String
The term text at the lower end of the range

upperTermText
Type:   Online System String
The term text at the upper end of the range

includeLower
Type:   Online System Boolean
If true, the lowerTerm is included in the range.

includeUpper
Type:   Online System Boolean
If true, the upperTerm is included in the range.

collator
Type:   Online System.Globalization CompareInfo
The collator to use to collate index Terms, to determine their
            membership in the range bounded by lowerTerm and
            upperTerm.

See Also
TermRangeTermEnum Class
TermRangeTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeTermEnum Fields

TermRangeTermEnum Fields Lucene.Net Class Library
The TermRangeTermEnum type exposes the following members.
Fields
 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use SetEnum(TermEnum) (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)
Back to Top
See Also
TermRangeTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeTermEnum Methods

TermRangeTermEnum Methods Lucene.Net Class Library
The TermRangeTermEnum type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Public method | Difference | (Overrides FilteredTermEnum Difference .)
Public method | Dispose | Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Protected method | Dispose(Boolean) | (Inherited from FilteredTermEnum.)
Public method | DocFreq | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum EndEnum .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | Increments the enumeration to the next element. True if one exists. (Inherited from FilteredTermEnum.)
Protected method | SetEnum | use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term. (Inherited from FilteredTermEnum.)
Protected method | TermCompare | (Overrides FilteredTermEnum TermCompare(Term).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TermRangeTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Difference Method

TermRangeTermEnum Difference Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Difference()
public override float Difference()
Public Overrides Function Difference As Single
Public Overrides Function Difference As Single
public:
virtual float Difference() override
public:
virtual float Difference() override
See Also
TermRangeTermEnum Class
TermRangeTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EndEnum Method

TermRangeTermEnum EndEnum Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool EndEnum()
public override bool EndEnum()
Public Overrides Function EndEnum As Boolean
Public Overrides Function EndEnum As Boolean
public:
virtual bool EndEnum() override
public:
virtual bool EndEnum() override
See Also
TermRangeTermEnum Class
TermRangeTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermCompare Method

TermRangeTermEnum TermCompare Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool TermCompare(
    Term term
)
protected override bool TermCompare(
    Term term
)
Protected Overrides Function TermCompare ( _
    term As Term _
) As Boolean
Protected Overrides Function TermCompare ( _
    term As Term _
) As Boolean
protected:
virtual bool TermCompare(
    Term^ term
) override
protected:
virtual bool TermCompare(
    Term^ term
) override
Parameters
term
Type: Lucene.Net.Index Term
See Also
TermRangeTermEnum Class
TermRangeTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermRangeTermEnum Properties

TermRangeTermEnum Properties Lucene.Net Class Library
The TermRangeTermEnum type exposes the following members.
Properties
 | Name | Description
Public property | Term | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Back to Top
See Also
TermRangeTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermScorer Class

TermScorer Class Lucene.Net Class Library
Expert: A Scorer for documents matching a Term.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSetIterator
Lucene.Net.Search Scorer
Lucene.Net.Search TermScorer

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class TermScorer : Scorer
public sealed class TermScorer : Scorer
Public NotInheritable Class TermScorer _
    Inherits Scorer
Public NotInheritable Class TermScorer _
    Inherits Scorer
public ref class TermScorer sealed : public Scorer
public ref class TermScorer sealed : public Scorer
See Also
TermScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermScorer Members

TermScorer Members Lucene.Net Class Library

The TermScorer type exposes the following members.
Constructors
 | Name | Description
Public method | TermScorer | Construct a TermScorer.
Back to Top
Methods
 | Name | Description
Public method | Advance | Advances to the first match beyond the current whose document number is greater than or equal to a given target. The implementation uses SkipTo(Int32). (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | Advances to the next document matching the query. The iterator over the matching documents is buffered using Read( Int32 , Int32 ). (Overrides DocIdSetIterator NextDoc .)
Public method | Score | (Overrides Scorer Score .)
Public method | Score(Collector) | (Overrides Scorer Score(Collector).)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer Score(Collector, Int32, Int32).)
Public method | ToString | Returns a string representation of this TermScorer. (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | Similarity | Returns the Similarity implementation used by this scorer. (Inherited from Scorer.)
Back to Top
See Also
TermScorer Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermScorer Constructor

TermScorer Constructor Lucene.Net Class Library
Construct a TermScorer.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TermScorer(
    Weight weight,
    TermDocs td,
    Similarity similarity,
    byte[] norms
)
public TermScorer(
    Weight weight,
    TermDocs td,
    Similarity similarity,
    byte[] norms
)
Public Sub New ( _
    weight As Weight, _
    td As TermDocs, _
    similarity As Similarity, _
    norms As Byte() _
)
Public Sub New ( _
    weight As Weight, _
    td As TermDocs, _
    similarity As Similarity, _
    norms As Byte() _
)
public:
TermScorer(
    Weight^ weight,
    TermDocs^ td,
    Similarity^ similarity,
    array<unsigned char>^ norms
)
public:
TermScorer(
    Weight^ weight,
    TermDocs^ td,
    Similarity^ similarity,
    array<unsigned char>^ norms
)
Parameters
weight
Type: Lucene.Net.Search Weight
The weight of the Term in the query.

td
Type: Lucene.Net.Index TermDocs
An iterator over the documents matching the Term.

similarity
Type: Lucene.Net.Search Similarity
The Similarity implementation to be used for score
            computations.

norms
Type:    Online System Byte
The field norms of the document fields for the Term.

See Also
TermScorer Class
TermScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermScorer Methods

TermScorer Methods Lucene.Net Class Library
The TermScorer type exposes the following members.
Methods
 | Name | Description
Public method | Advance | Advances to the first match beyond the current whose document number is greater than or equal to a given target. The implementation uses SkipTo(Int32). (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | Advances to the next document matching the query. The iterator over the matching documents is buffered using Read( Int32 , Int32 ). (Overrides DocIdSetIterator NextDoc .)
Public method | Score | (Overrides Scorer Score .)
Public method | Score(Collector) | (Overrides Scorer Score(Collector).)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer Score(Collector, Int32, Int32).)
Public method | ToString | Returns a string representation of this TermScorer. (Overrides Online Object ToString .)
Back to Top
See Also
TermScorer Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Advance Method

TermScorer Advance Method Lucene.Net Class Library
Advances to the first match beyond the current whose document number is greater than or equal to a given target.
The implementation uses SkipTo(Int32).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Advance(
    int target
)
public override int Advance(
    int target
)
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
public:
virtual int Advance(
    int target
) override
public:
virtual int Advance(
    int target
) override
Parameters
target
Type:   Online System Int32
The target document number.

Return Value
 the matching document or -1 if none exist.

See Also
TermScorer Class
TermScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocID Method

TermScorer DocID Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocID()
public override int DocID()
Public Overrides Function DocID As Integer
Public Overrides Function DocID As Integer
public:
virtual int DocID() override
public:
virtual int DocID() override
See Also
TermScorer Class
TermScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextDoc Method

TermScorer NextDoc Method Lucene.Net Class Library
Advances to the next document matching the query.
The iterator over the matching documents is buffered using Read( Int32 , Int32 ).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int NextDoc()
public override int NextDoc()
Public Overrides Function NextDoc As Integer
Public Overrides Function NextDoc As Integer
public:
virtual int NextDoc() override
public:
virtual int NextDoc() override
Return Value
 the document matching the query or -1 if there are no more documents.

See Also
TermScorer Class
TermScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method

TermScorer Score Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Score | (Overrides Scorer Score .)
Public method | Score(Collector) | (Overrides Scorer Score(Collector).)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer Score(Collector, Int32, Int32).)
Back to Top
See Also
TermScorer Class
TermScorer Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method

TermScorer Score Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Score()
public override float Score()
Public Overrides Function Score As Single
Public Overrides Function Score As Single
public:
virtual float Score() override
public:
virtual float Score() override
See Also
TermScorer Class
TermScorer Members
Score Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method (Collector)

TermScorer Score Method (Collector) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Score(
    Collector c
)
public override void Score(
    Collector c
)
Public Overrides Sub Score ( _
    c As Collector _
)
Public Overrides Sub Score ( _
    c As Collector _
)
public:
virtual void Score(
    Collector^ c
) override
public:
virtual void Score(
    Collector^ c
) override
Parameters
c
Type: Lucene.Net.Search Collector
See Also
TermScorer Class
TermScorer Members
Score Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method (Collector, Int32, Int32)

TermScorer Score Method (Collector, Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Score(
    Collector c,
    int end,
    int firstDocID
)
public override bool Score(
    Collector c,
    int end,
    int firstDocID
)
Public Overrides Function Score ( _
    c As Collector, _
    end As Integer, _
    firstDocID As Integer _
) As Boolean
Public Overrides Function Score ( _
    c As Collector, _
    end As Integer, _
    firstDocID As Integer _
) As Boolean
public:
virtual bool Score(
    Collector^ c,
    int end,
    int firstDocID
) override
public:
virtual bool Score(
    Collector^ c,
    int end,
    int firstDocID
) override
Parameters
c
Type: Lucene.Net.Search Collector
end
Type:   Online System Int32
firstDocID
Type:   Online System Int32
See Also
TermScorer Class
TermScorer Members
Score Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

TermScorer ToString Method Lucene.Net Class Library
Returns a string representation of this TermScorer.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
TermScorer Class
TermScorer Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermScorer Properties

TermScorer Properties Lucene.Net Class Library
The TermScorer type exposes the following members.
Properties
 | Name | Description
Public property | Similarity | Returns the Similarity implementation used by this scorer. (Inherited from Scorer.)
Back to Top
See Also
TermScorer Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TimeLimitingCollector Class

TimeLimitingCollector Class Lucene.Net Class Library
The TimeLimitingCollector is used to timeout search requests that take longer than the maximum allowed search time limit. After this time is exceeded, the search thread is stopped by throwing a TimeLimitingCollector TimeExceededException.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Collector
Lucene.Net.Search TimeLimitingCollector

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TimeLimitingCollector : Collector
public class TimeLimitingCollector : Collector
Public Class TimeLimitingCollector _
    Inherits Collector
Public Class TimeLimitingCollector _
    Inherits Collector
public ref class TimeLimitingCollector : public Collector
public ref class TimeLimitingCollector : public Collector
See Also
TimeLimitingCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TimeLimitingCollector Members

TimeLimitingCollector Members Lucene.Net Class Library

The TimeLimitingCollector type exposes the following members.
Constructors
 | Name | Description
Public method | TimeLimitingCollector | Create a TimeLimitedCollector wrapper over another Collector with a specified timeout.
Back to Top
Methods
 | Name | Description
Public method | Collect | Calls Collect(Int32) on the decorated Collector unless the allowed time has passed, in which case it throws an exception. (Overrides Collector Collect(Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetNextReader | (Overrides Collector SetNextReader(IndexReader, Int32).)
Public method | SetScorer | (Overrides Collector SetScorer(Scorer).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Public field | DEFAULT_GREEDY | Default for IsGreedy.
 | DEFAULT_RESOLUTION | Default timer resolution.
Back to Top
Properties
Name | Description
Public property | AcceptsDocsOutOfOrder | (Overrides Collector AcceptsDocsOutOfOrder.)
Public property IsGreedy
Checks if this time limited collector is greedy in collecting the last hit. A non greedy collector, upon a timeout, would throw a TimeLimitingCollector TimeExceededException without allowing the wrapped collector to collect current doc. A greedy one would first allow the wrapped hit collector to collect current doc and only then throw a TimeLimitingCollector TimeExceededException.
Resolution
Gets or sets the timer resolution. The default timer resolution is 20 milliseconds. This means that a search required to take no longer than 800 milliseconds may be stopped after 780 to 820 milliseconds.
Note that:
  • Finer (smaller) resolution is more accurate but less efficient.
  • Setting resolution to less than 5 milliseconds will be silently modified to 5 milliseconds.
  • Setting resolution smaller than current resolution might take effect only after current resolution. (Assume current resolution of 20 milliseconds is modified to 5 milliseconds, then it can take up to 20 milliseconds for the change to have effect.
Back to Top
See Also
TimeLimitingCollector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TimeLimitingCollector Constructor

TimeLimitingCollector Constructor Lucene.Net Class Library
Create a TimeLimitedCollector wrapper over another Collector with a specified timeout.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeLimitingCollector(
    Collector collector,
    long timeAllowed
)
public TimeLimitingCollector(
    Collector collector,
    long timeAllowed
)
Public Sub New ( _
    collector As Collector, _
    timeAllowed As Long _
)
Public Sub New ( _
    collector As Collector, _
    timeAllowed As Long _
)
public:
TimeLimitingCollector(
    Collector^ collector,
    long long timeAllowed
)
public:
TimeLimitingCollector(
    Collector^ collector,
    long long timeAllowed
)
Parameters
collector
Type: Lucene.Net.Search Collector
the wrapped Collector
timeAllowed
Type:   Online System Int64
max time allowed for collecting hits after which TimeLimitingCollector TimeExceededException is thrown

See Also
TimeLimitingCollector Class
TimeLimitingCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TimeLimitingCollector Fields

TimeLimitingCollector Fields Lucene.Net Class Library
The TimeLimitingCollector type exposes the following members.
Fields
 | Name | Description
Public field | DEFAULT_GREEDY | Default for IsGreedy.
 | DEFAULT_RESOLUTION | Default timer resolution.
Back to Top
See Also
TimeLimitingCollector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_GREEDY Field

TimeLimitingCollector DEFAULT_GREEDY Field Lucene.Net Class Library
Default for IsGreedy.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DEFAULT_GREEDY
public bool DEFAULT_GREEDY
Public DEFAULT_GREEDY As Boolean
Public DEFAULT_GREEDY As Boolean
public:
bool DEFAULT_GREEDY
public:
bool DEFAULT_GREEDY
See Also
TimeLimitingCollector Class
TimeLimitingCollector Members
Lucene.Net.Search Namespace
TimeLimitingCollector IsGreedy
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_RESOLUTION Field

TimeLimitingCollector DEFAULT_RESOLUTION Field Lucene.Net Class Library
Default timer resolution.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_RESOLUTION
public const int DEFAULT_RESOLUTION
Public Const DEFAULT_RESOLUTION As Integer
Public Const DEFAULT_RESOLUTION As Integer
public:
literal int DEFAULT_RESOLUTION
public:
literal int DEFAULT_RESOLUTION
See Also
TimeLimitingCollector Class
TimeLimitingCollector Members
Lucene.Net.Search Namespace
TimeLimitingCollector Resolution
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TimeLimitingCollector Methods

TimeLimitingCollector Methods Lucene.Net Class Library
The TimeLimitingCollector type exposes the following members.
Methods
 | Name | Description
Public method | Collect | Calls Collect(Int32) on the decorated Collector unless the allowed time has passed, in which case it throws an exception. (Overrides Collector Collect(Int32).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetNextReader | (Overrides Collector SetNextReader(IndexReader, Int32).)
Public method | SetScorer | (Overrides Collector SetScorer(Scorer).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TimeLimitingCollector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Collect Method

TimeLimitingCollector Collect Method Lucene.Net Class Library
Calls Collect(Int32) on the decorated Collector unless the allowed time has passed, in which case it throws an exception.
if the time allowed has exceeded.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Collect(
    int doc
)
public override void Collect(
    int doc
)
Public Overrides Sub Collect ( _
    doc As Integer _
)
Public Overrides Sub Collect ( _
    doc As Integer _
)
public:
virtual void Collect(
    int doc
) override
public:
virtual void Collect(
    int doc
) override
Parameters
doc
Type:   Online System Int32
See Also
TimeLimitingCollector Class
TimeLimitingCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNextReader Method

TimeLimitingCollector SetNextReader Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetNextReader(
    IndexReader reader,
    int base_Renamed
)
public override void SetNextReader(
    IndexReader reader,
    int base_Renamed
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    base_Renamed As Integer _
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    base_Renamed As Integer _
)
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int base_Renamed
) override
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int base_Renamed
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
base_Renamed
Type:   Online System Int32
See Also
TimeLimitingCollector Class
TimeLimitingCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetScorer Method

TimeLimitingCollector SetScorer Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetScorer(
    Scorer scorer
)
public override void SetScorer(
    Scorer scorer
)
Public Overrides Sub SetScorer ( _
    scorer As Scorer _
)
Public Overrides Sub SetScorer ( _
    scorer As Scorer _
)
public:
virtual void SetScorer(
    Scorer^ scorer
) override
public:
virtual void SetScorer(
    Scorer^ scorer
) override
Parameters
scorer
Type: Lucene.Net.Search Scorer
See Also
TimeLimitingCollector Class
TimeLimitingCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TimeLimitingCollector Properties

TimeLimitingCollector Properties Lucene.Net Class Library
The TimeLimitingCollector type exposes the following members.
Properties
Name | Description
Public property | AcceptsDocsOutOfOrder | (Overrides Collector AcceptsDocsOutOfOrder.)
Public property IsGreedy
Checks if this time limited collector is greedy in collecting the last hit. A non greedy collector, upon a timeout, would throw a TimeLimitingCollector TimeExceededException without allowing the wrapped collector to collect current doc. A greedy one would first allow the wrapped hit collector to collect current doc and only then throw a TimeLimitingCollector TimeExceededException.
Resolution
Gets or sets the timer resolution. The default timer resolution is 20 milliseconds. This means that a search required to take no longer than 800 milliseconds may be stopped after 780 to 820 milliseconds.
Note that:
  • Finer (smaller) resolution is more accurate but less efficient.
  • Setting resolution to less than 5 milliseconds will be silently modified to 5 milliseconds.
  • Setting resolution smaller than current resolution might take effect only after current resolution. (Assume current resolution of 20 milliseconds is modified to 5 milliseconds, then it can take up to 20 milliseconds for the change to have effect.
Back to Top
See Also
TimeLimitingCollector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AcceptsDocsOutOfOrder Property

TimeLimitingCollector AcceptsDocsOutOfOrder Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool AcceptsDocsOutOfOrder { get; }
public override bool AcceptsDocsOutOfOrder { get; }
Public Overrides ReadOnly Property AcceptsDocsOutOfOrder As Boolean
    Get
Public Overrides ReadOnly Property AcceptsDocsOutOfOrder As Boolean
    Get
public:
virtual property bool AcceptsDocsOutOfOrder {
    bool get () override;
}
public:
virtual property bool AcceptsDocsOutOfOrder {
    bool get () override;
}
See Also
TimeLimitingCollector Class
TimeLimitingCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsGreedy Property

TimeLimitingCollector IsGreedy Property Lucene.Net Class Library
Checks if this time limited collector is greedy in collecting the last hit. A non greedy collector, upon a timeout, would throw a TimeLimitingCollector TimeExceededException without allowing the wrapped collector to collect current doc. A greedy one would first allow the wrapped hit collector to collect current doc and only then throw a TimeLimitingCollector TimeExceededException.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsGreedy { get; set; }
public virtual bool IsGreedy { get; set; }
Public Overridable Property IsGreedy As Boolean
    Get
    Set
Public Overridable Property IsGreedy As Boolean
    Get
    Set
public:
virtual property bool IsGreedy {
    bool get ();
    void set (bool value);
}
public:
virtual property bool IsGreedy {
    bool get ();
    void set (bool value);
}
See Also
TimeLimitingCollector Class
TimeLimitingCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Resolution Property

TimeLimitingCollector Resolution Property Lucene.Net Class Library
Gets or sets the timer resolution. The default timer resolution is 20 milliseconds. This means that a search required to take no longer than 800 milliseconds may be stopped after 780 to 820 milliseconds.
Note that:
  • Finer (smaller) resolution is more accurate but less efficient.
  • Setting resolution to less than 5 milliseconds will be silently modified to 5 milliseconds.
  • Setting resolution smaller than current resolution might take effect only after current resolution. (Assume current resolution of 20 milliseconds is modified to 5 milliseconds, then it can take up to 20 milliseconds for the change to have effect.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long Resolution { get; set; }
public static long Resolution { get; set; }
Public Shared Property Resolution As Long
    Get
    Set
Public Shared Property Resolution As Long
    Get
    Set
public:
static property long long Resolution {
    long long get ();
    void set (long long value);
}
public:
static property long long Resolution {
    long long get ();
    void set (long long value);
}
See Also
TimeLimitingCollector Class
TimeLimitingCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TimeLimitingCollector.TimeExceededException Class

TimeLimitingCollector TimeExceededException Class Lucene.Net Class Library
Thrown when elapsed search time exceeds allowed search time.
Inheritance Hierarchy
Online System Object
Online System Exception
Online System SystemException
Lucene.Net.Search TimeLimitingCollector TimeExceededException

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TimeExceededException : SystemException
[SerializableAttribute]
public class TimeExceededException : SystemException
<SerializableAttribute> _
Public Class TimeExceededException _
    Inherits SystemException
<SerializableAttribute> _
Public Class TimeExceededException _
    Inherits SystemException
[SerializableAttribute]
public ref class TimeExceededException : public SystemException
[SerializableAttribute]
public ref class TimeExceededException : public SystemException
See Also
TimeLimitingCollector TimeExceededException Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TimeLimitingCollector.TimeExceededException Members

TimeLimitingCollector TimeExceededException Members Lucene.Net Class Library

The TimeLimitingCollector is used to timeout search requests that take longer than the maximum allowed search time limit. After this time is exceeded, the search thread is stopped by throwing a TimeLimitingCollector TimeExceededException.

The TimeLimitingCollector TimeExceededException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | LastDocCollected | Returns last doc(absolute doc id) that was collected when the search time exceeded.
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Public property | TimeAllowed | Returns allowed time (milliseconds).
Public property | TimeElapsed | Returns elapsed time (milliseconds).
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
TimeLimitingCollector TimeExceededException Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TimeLimitingCollector.TimeExceededException Methods

TimeLimitingCollector TimeExceededException Methods Lucene.Net Class Library
The TimeLimitingCollector TimeExceededException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
TimeLimitingCollector TimeExceededException Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TimeLimitingCollector.TimeExceededException Properties

TimeLimitingCollector TimeExceededException Properties Lucene.Net Class Library
The TimeLimitingCollector TimeExceededException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | LastDocCollected | Returns last doc(absolute doc id) that was collected when the search time exceeded.
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Public property | TimeAllowed | Returns allowed time (milliseconds).
Public property | TimeElapsed | Returns elapsed time (milliseconds).
Back to Top
See Also
TimeLimitingCollector TimeExceededException Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LastDocCollected Property

TimeLimitingCollector TimeExceededException LastDocCollected Property Lucene.Net Class Library
Returns last doc(absolute doc id) that was collected when the search time exceeded.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int LastDocCollected { get; }
public virtual int LastDocCollected { get; }
Public Overridable ReadOnly Property LastDocCollected As Integer
    Get
Public Overridable ReadOnly Property LastDocCollected As Integer
    Get
public:
virtual property int LastDocCollected {
    int get ();
}
public:
virtual property int LastDocCollected {
    int get ();
}
See Also
TimeLimitingCollector TimeExceededException Class
TimeLimitingCollector TimeExceededException Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TimeAllowed Property

TimeLimitingCollector TimeExceededException TimeAllowed Property Lucene.Net Class Library
Returns allowed time (milliseconds).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long TimeAllowed { get; }
public virtual long TimeAllowed { get; }
Public Overridable ReadOnly Property TimeAllowed As Long
    Get
Public Overridable ReadOnly Property TimeAllowed As Long
    Get
public:
virtual property long long TimeAllowed {
    long long get ();
}
public:
virtual property long long TimeAllowed {
    long long get ();
}
See Also
TimeLimitingCollector TimeExceededException Class
TimeLimitingCollector TimeExceededException Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TimeElapsed Property

TimeLimitingCollector TimeExceededException TimeElapsed Property Lucene.Net Class Library
Returns elapsed time (milliseconds).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long TimeElapsed { get; }
public virtual long TimeElapsed { get; }
Public Overridable ReadOnly Property TimeElapsed As Long
    Get
Public Overridable ReadOnly Property TimeElapsed As Long
    Get
public:
virtual property long long TimeElapsed {
    long long get ();
}
public:
virtual property long long TimeElapsed {
    long long get ();
}
See Also
TimeLimitingCollector TimeExceededException Class
TimeLimitingCollector TimeExceededException Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TimeLimitingCollector.TimeExceededException Events

TimeLimitingCollector TimeExceededException Events Lucene.Net Class Library
The TimeLimitingCollector TimeExceededException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
TimeLimitingCollector TimeExceededException Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopDocs Class

TopDocs Class Lucene.Net Class Library
Represents hits returned by Search(Query, Filter, Int32) and Search(Query, Int32)
Inheritance Hierarchy
Online System Object
Lucene.Net.Search TopDocs
Lucene.Net.Search TopFieldDocs

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TopDocs
[SerializableAttribute]
public class TopDocs
<SerializableAttribute> _
Public Class TopDocs
<SerializableAttribute> _
Public Class TopDocs
[SerializableAttribute]
public ref class TopDocs
[SerializableAttribute]
public ref class TopDocs
See Also
TopDocs Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopDocs Members

TopDocs Members Lucene.Net Class Library

The TopDocs type exposes the following members.
Constructors
 | Name | Description
Public method | TopDocs | Initializes a new instance of the TopDocs class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | MaxScore | Gets or sets the maximum score value encountered, needed for normalizing. Note that in case scores are not tracked, this returns Online NaN.
Public property | ScoreDocs | The top hits for the query.
Public property | TotalHits | The total number of hits for the query.
Back to Top
See Also
TopDocs Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopDocs Constructor

TopDocs Constructor Lucene.Net Class Library
Initializes a new instance of the TopDocs class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TopDocs(
    int totalHits,
    ScoreDoc[] scoreDocs,
    float maxScore
)
public TopDocs(
    int totalHits,
    ScoreDoc[] scoreDocs,
    float maxScore
)
Public Sub New ( _
    totalHits As Integer, _
    scoreDocs As ScoreDoc(), _
    maxScore As Single _
)
Public Sub New ( _
    totalHits As Integer, _
    scoreDocs As ScoreDoc(), _
    maxScore As Single _
)
public:
TopDocs(
    int totalHits,
    array<ScoreDoc^>^ scoreDocs,
    float maxScore
)
public:
TopDocs(
    int totalHits,
    array<ScoreDoc^>^ scoreDocs,
    float maxScore
)
Parameters
totalHits
Type:   Online System Int32
scoreDocs
Type:  Lucene.Net.Search ScoreDoc
maxScore
Type:   Online System Single
See Also
TopDocs Class
TopDocs Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopDocs Methods

TopDocs Methods Lucene.Net Class Library
The TopDocs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TopDocs Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopDocs Properties

TopDocs Properties Lucene.Net Class Library
The TopDocs type exposes the following members.
Properties
 | Name | Description
Public property | MaxScore | Gets or sets the maximum score value encountered, needed for normalizing. Note that in case scores are not tracked, this returns Online NaN.
Public property | ScoreDocs | The top hits for the query.
Public property | TotalHits | The total number of hits for the query.
Back to Top
See Also
TopDocs Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxScore Property

TopDocs MaxScore Property Lucene.Net Class Library
Gets or sets the maximum score value encountered, needed for normalizing. Note that in case scores are not tracked, this returns Online NaN.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float MaxScore { get; set; }
public float MaxScore { get; set; }
Public Property MaxScore As Single
    Get
    Set
Public Property MaxScore As Single
    Get
    Set
public:
property float MaxScore {
    float get ();
    void set (float value);
}
public:
property float MaxScore {
    float get ();
    void set (float value);
}
See Also
TopDocs Class
TopDocs Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ScoreDocs Property

TopDocs ScoreDocs Property Lucene.Net Class Library
The top hits for the query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ScoreDoc[] ScoreDocs { get; set; }
public ScoreDoc[] ScoreDocs { get; set; }
Public Property ScoreDocs As ScoreDoc()
    Get
    Set
Public Property ScoreDocs As ScoreDoc()
    Get
    Set
public:
property array<ScoreDoc^>^ ScoreDocs {
    array<ScoreDoc^>^ get ();
    void set (array<ScoreDoc^>^ value);
}
public:
property array<ScoreDoc^>^ ScoreDocs {
    array<ScoreDoc^>^ get ();
    void set (array<ScoreDoc^>^ value);
}
See Also
TopDocs Class
TopDocs Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TotalHits Property

TopDocs TotalHits Property Lucene.Net Class Library
The total number of hits for the query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int TotalHits { get; set; }
public int TotalHits { get; set; }
Public Property TotalHits As Integer
    Get
    Set
Public Property TotalHits As Integer
    Get
    Set
public:
property int TotalHits {
    int get ();
    void set (int value);
}
public:
property int TotalHits {
    int get ();
    void set (int value);
}
See Also
TopDocs Class
TopDocs Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopDocsCollector(T) Class

TopDocsCollector T Class Lucene.Net Class Library
A base class for all collectors that return a TopDocs output. This collector allows easy extension by providing a single constructor which accepts a PriorityQueue T as well as protected members for that priority queue and a counter of the number of total hits.
Extending classes can override TopDocs(Int32, Int32) and TotalHits in order to provide their own implementation.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Collector
Lucene.Net.Search TopDocsCollector T
Lucene.Net.Search TopFieldCollector
Lucene.Net.Search TopScoreDocCollector

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class TopDocsCollector<T> : Collector
where T : ScoreDoc
public abstract class TopDocsCollector<T> : Collector
where T : ScoreDoc
Public MustInherit Class TopDocsCollector(Of T As ScoreDoc) _
    Inherits Collector
Public MustInherit Class TopDocsCollector(Of T As ScoreDoc) _
    Inherits Collector
generic<typename T>
where T : ScoreDoc
public ref class TopDocsCollector abstract : public Collector
generic<typename T>
where T : ScoreDoc
public ref class TopDocsCollector abstract : public Collector
Type Parameters
T
See Also
TopDocsCollector T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopDocsCollector(T) Members

TopDocsCollector T Members Lucene.Net Class Library

The TopDocsCollector T type exposes the following members.
Constructors
 | Name | Description
Protected method | TopDocsCollector T | Initializes a new instance of the TopDocsCollector T class
Back to Top
Methods
 | Name | Description
Public method | Collect | Called once for every document matching a query, with the unbased document number. Note: This is called in an inner search loop. For good search performance, implementations of this method should not call Doc(Int32) or Document(Int32) on every hit. Doing so can slow searches by an order of magnitude or more. (Inherited from Collector.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NewTopDocs | Returns a TopDocs instance containing the given results. If results is null it means there are no results to return, either because there were 0 calls to collect() or because the arguments to topDocs were invalid.
Protected method | PopulateResults | Populates the results array with the ScoreDoc instaces. This can be overridden in case a different ScoreDoc type should be returned.
Public method | SetNextReader | Called before collecting from each IndexReader. All doc ids in Collect(Int32) will correspond to reader. Add docBase to the current IndexReaders internal document id to re-base ids in Collect(Int32). (Inherited from Collector.)
Public method | SetScorer | Called before successive calls to Collect(Int32). Implementations that need the score of the current document (passed-in to Collect(Int32)), should save the passed-in Scorer and call scorer.score() when needed. (Inherited from Collector.)
Public method | TopDocs | Returns the top docs that were collected by this collector.
Public method | TopDocs(Int32) | Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned. This method is convenient to call if the application allways asks for the last results, starting from the last 'page'. NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different start, you should call TopDocs and work with the returned TopDocs object, which will contain all the results this search execution collected.
Public method | TopDocs(Int32, Int32) | Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned. This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany. NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call TopDocs and work with the returned TopDocs object, which will contain all the results this search execution collected.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
 | EMPTY_TOPDOCS |
Protected field | internalTotalHits | The total number of documents that the collector encountered.
Protected field | pq | The priority queue which holds the top documents. Note that different implementations of PriorityQueue give different meaning to 'top documents'. HitQueue for example aggregates the top scoring documents, while other PQ implementations may hold documents sorted by other criteria.
Back to Top
Properties
 | Name | Description
Public property | AcceptsDocsOutOfOrder | Return true if this collector does not require the matching docIDs to be delivered in int sort order (smallest to largest) to Collect(Int32). Most Lucene Query implementations will visit matching docIDs in order. However, some queries (currently limited to certain cases of BooleanQuery) can achieve faster searching if the Collector allows them to deliver the docIDs out of order. Many collectors don't mind getting docIDs out of order, so it's important to return true here. (Inherited from Collector.)
Public property | TotalHits | The total number of documents that matched this query.
Back to Top
See Also
TopDocsCollector T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopDocsCollector(T) Constructor

TopDocsCollector T Constructor Lucene.Net Class Library
Initializes a new instance of the TopDocsCollector T class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TopDocsCollector(
    PriorityQueue<T> pq
)
protected TopDocsCollector(
    PriorityQueue<T> pq
)
Protected Sub New ( _
    pq As PriorityQueue(Of T) _
)
Protected Sub New ( _
    pq As PriorityQueue(Of T) _
)
protected:
TopDocsCollector(
    PriorityQueue<T>^ pq
)
protected:
TopDocsCollector(
    PriorityQueue<T>^ pq
)
Parameters
pq
Type: Lucene.Net.Util PriorityQueue  T
See Also
TopDocsCollector T  Class
TopDocsCollector T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopDocsCollector(T) Fields

TopDocsCollector T Fields Lucene.Net Class Library
The TopDocsCollector T type exposes the following members.
Fields
 | Name | Description
 | EMPTY_TOPDOCS |
Protected field | internalTotalHits | The total number of documents that the collector encountered.
Protected field | pq | The priority queue which holds the top documents. Note that different implementations of PriorityQueue give different meaning to 'top documents'. HitQueue for example aggregates the top scoring documents, while other PQ implementations may hold documents sorted by other criteria.
Back to Top
See Also
TopDocsCollector T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EMPTY_TOPDOCS Field

TopDocsCollector T EMPTY_TOPDOCS Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static readonly TopDocs EMPTY_TOPDOCS
protected static readonly TopDocs EMPTY_TOPDOCS
Protected Shared ReadOnly EMPTY_TOPDOCS As TopDocs
Protected Shared ReadOnly EMPTY_TOPDOCS As TopDocs
protected:
static initonly TopDocs^ EMPTY_TOPDOCS
protected:
static initonly TopDocs^ EMPTY_TOPDOCS
See Also
TopDocsCollector T  Class
TopDocsCollector T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalTotalHits Field

TopDocsCollector T internalTotalHits Field Lucene.Net Class Library
The total number of documents that the collector encountered.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int internalTotalHits
protected int internalTotalHits
Protected internalTotalHits As Integer
Protected internalTotalHits As Integer
protected:
int internalTotalHits
protected:
int internalTotalHits
See Also
TopDocsCollector T  Class
TopDocsCollector T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


pq Field

TopDocsCollector T pq Field Lucene.Net Class Library
The priority queue which holds the top documents. Note that different implementations of PriorityQueue give different meaning to 'top documents'. HitQueue for example aggregates the top scoring documents, while other PQ implementations may hold documents sorted by other criteria.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PriorityQueue<T> pq
protected PriorityQueue<T> pq
Protected pq As PriorityQueue(Of T)
Protected pq As PriorityQueue(Of T)
protected:
PriorityQueue<T>^ pq
protected:
PriorityQueue<T>^ pq
See Also
TopDocsCollector T  Class
TopDocsCollector T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopDocsCollector(T) Methods

TopDocsCollector T Methods Lucene.Net Class Library
The TopDocsCollector T type exposes the following members.
Methods
 | Name | Description
Public method | Collect | Called once for every document matching a query, with the unbased document number. Note: This is called in an inner search loop. For good search performance, implementations of this method should not call Doc(Int32) or Document(Int32) on every hit. Doing so can slow searches by an order of magnitude or more. (Inherited from Collector.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NewTopDocs | Returns a TopDocs instance containing the given results. If results is null it means there are no results to return, either because there were 0 calls to collect() or because the arguments to topDocs were invalid.
Protected method | PopulateResults | Populates the results array with the ScoreDoc instaces. This can be overridden in case a different ScoreDoc type should be returned.
Public method | SetNextReader | Called before collecting from each IndexReader. All doc ids in Collect(Int32) will correspond to reader. Add docBase to the current IndexReaders internal document id to re-base ids in Collect(Int32). (Inherited from Collector.)
Public method | SetScorer | Called before successive calls to Collect(Int32). Implementations that need the score of the current document (passed-in to Collect(Int32)), should save the passed-in Scorer and call scorer.score() when needed. (Inherited from Collector.)
Public method | TopDocs | Returns the top docs that were collected by this collector.
Public method | TopDocs(Int32) | Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned. This method is convenient to call if the application allways asks for the last results, starting from the last 'page'. NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different start, you should call TopDocs and work with the returned TopDocs object, which will contain all the results this search execution collected.
Public method | TopDocs(Int32, Int32) | Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned. This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany. NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call TopDocs and work with the returned TopDocs object, which will contain all the results this search execution collected.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TopDocsCollector T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewTopDocs Method

TopDocsCollector T NewTopDocs Method Lucene.Net Class Library
Returns a TopDocs instance containing the given results. If results is null it means there are no results to return, either because there were 0 calls to collect() or because the arguments to topDocs were invalid.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual TopDocs NewTopDocs(
    ScoreDoc[] results,
    int start
)
public virtual TopDocs NewTopDocs(
    ScoreDoc[] results,
    int start
)
Public Overridable Function NewTopDocs ( _
    results As ScoreDoc(), _
    start As Integer _
) As TopDocs
Public Overridable Function NewTopDocs ( _
    results As ScoreDoc(), _
    start As Integer _
) As TopDocs
public:
virtual TopDocs^ NewTopDocs(
    array<ScoreDoc^>^ results,
    int start
)
public:
virtual TopDocs^ NewTopDocs(
    array<ScoreDoc^>^ results,
    int start
)
Parameters
results
Type:  Lucene.Net.Search ScoreDoc
start
Type:   Online System Int32
See Also
TopDocsCollector T  Class
TopDocsCollector T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PopulateResults Method

TopDocsCollector T PopulateResults Method Lucene.Net Class Library
Populates the results array with the ScoreDoc instaces. This can be overridden in case a different ScoreDoc type should be returned.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void PopulateResults(
    ScoreDoc[] results,
    int howMany
)
protected virtual void PopulateResults(
    ScoreDoc[] results,
    int howMany
)
Protected Overridable Sub PopulateResults ( _
    results As ScoreDoc(), _
    howMany As Integer _
)
Protected Overridable Sub PopulateResults ( _
    results As ScoreDoc(), _
    howMany As Integer _
)
protected:
virtual void PopulateResults(
    array<ScoreDoc^>^ results,
    int howMany
)
protected:
virtual void PopulateResults(
    array<ScoreDoc^>^ results,
    int howMany
)
Parameters
results
Type:  Lucene.Net.Search ScoreDoc
howMany
Type:   Online System Int32
See Also
TopDocsCollector T  Class
TopDocsCollector T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopDocs Method

TopDocsCollector T TopDocs Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | TopDocs | Returns the top docs that were collected by this collector.
Public method | TopDocs(Int32) | Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned. This method is convenient to call if the application allways asks for the last results, starting from the last 'page'. NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different start, you should call TopDocs and work with the returned TopDocs object, which will contain all the results this search execution collected.
Public method | TopDocs(Int32, Int32) | Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned. This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany. NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call TopDocs and work with the returned TopDocs object, which will contain all the results this search execution collected.
Back to Top
See Also
TopDocsCollector T Class
TopDocsCollector T Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopDocs Method

TopDocsCollector T TopDocs Method Lucene.Net Class Library
Returns the top docs that were collected by this collector.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TopDocs TopDocs()
public TopDocs TopDocs()
Public Function TopDocs As TopDocs
Public Function TopDocs As TopDocs
public:
TopDocs^ TopDocs()
public:
TopDocs^ TopDocs()
See Also
TopDocsCollector T  Class
TopDocsCollector T  Members
TopDocs Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopDocs Method (Int32)

TopDocsCollector T TopDocs Method (Int32) Lucene.Net Class Library
Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned.
This method is convenient to call if the application allways asks for the last results, starting from the last 'page'.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different start, you should call TopDocs and work with the returned TopDocs object, which will contain all the results this search execution collected.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TopDocs TopDocs(
    int start
)
public TopDocs TopDocs(
    int start
)
Public Function TopDocs ( _
    start As Integer _
) As TopDocs
Public Function TopDocs ( _
    start As Integer _
) As TopDocs
public:
TopDocs^ TopDocs(
    int start
)
public:
TopDocs^ TopDocs(
    int start
)
Parameters
start
Type:   Online System Int32
See Also
TopDocsCollector T  Class
TopDocsCollector T  Members
TopDocs Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopDocs Method (Int32, Int32)

TopDocsCollector T TopDocs Method (Int32, Int32) Lucene.Net Class Library
Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned.
This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call TopDocs and work with the returned TopDocs object, which will contain all the results this search execution collected.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TopDocs TopDocs(
    int start,
    int howMany
)
public TopDocs TopDocs(
    int start,
    int howMany
)
Public Function TopDocs ( _
    start As Integer, _
    howMany As Integer _
) As TopDocs
Public Function TopDocs ( _
    start As Integer, _
    howMany As Integer _
) As TopDocs
public:
TopDocs^ TopDocs(
    int start,
    int howMany
)
public:
TopDocs^ TopDocs(
    int start,
    int howMany
)
Parameters
start
Type:   Online System Int32
howMany
Type:   Online System Int32
See Also
TopDocsCollector T  Class
TopDocsCollector T  Members
TopDocs Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopDocsCollector(T) Properties

TopDocsCollector T Properties Lucene.Net Class Library
The TopDocsCollector T type exposes the following members.
Properties
 | Name | Description
Public property | AcceptsDocsOutOfOrder | Return true if this collector does not require the matching docIDs to be delivered in int sort order (smallest to largest) to Collect(Int32). Most Lucene Query implementations will visit matching docIDs in order. However, some queries (currently limited to certain cases of BooleanQuery) can achieve faster searching if the Collector allows them to deliver the docIDs out of order. Many collectors don't mind getting docIDs out of order, so it's important to return true here. (Inherited from Collector.)
Public property | TotalHits | The total number of documents that matched this query.
Back to Top
See Also
TopDocsCollector T Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TotalHits Property

TopDocsCollector T TotalHits Property Lucene.Net Class Library
The total number of documents that matched this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int TotalHits { get; }
public virtual int TotalHits { get; }
Public Overridable ReadOnly Property TotalHits As Integer
    Get
Public Overridable ReadOnly Property TotalHits As Integer
    Get
public:
virtual property int TotalHits {
    int get ();
}
public:
virtual property int TotalHits {
    int get ();
}
See Also
TopDocsCollector T  Class
TopDocsCollector T  Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopFieldCollector Class

TopFieldCollector Class Lucene.Net Class Library
A Collector that sorts by SortField using FieldComparators.

See the Create(Sort, Int32, Boolean, Boolean, Boolean, Boolean) method for instantiating a TopFieldCollector.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Inheritance Hierarchy
Online System Object
Lucene.Net.Search Collector
Lucene.Net.Search TopDocsCollector FieldValueHitQueue Entry
Lucene.Net.Search TopFieldCollector

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class TopFieldCollector : TopDocsCollector<FieldValueHitQueue..::..Entry>
public abstract class TopFieldCollector : TopDocsCollector<FieldValueHitQueue..::..Entry>
Public MustInherit Class TopFieldCollector _
    Inherits TopDocsCollector(Of FieldValueHitQueue..::..Entry)
Public MustInherit Class TopFieldCollector _
    Inherits TopDocsCollector(Of FieldValueHitQueue..::..Entry)
public ref class TopFieldCollector abstract : public TopDocsCollector<FieldValueHitQueue..::..Entry^>
public ref class TopFieldCollector abstract : public TopDocsCollector<FieldValueHitQueue..::..Entry^>
See Also
TopFieldCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopFieldCollector Members

TopFieldCollector Members Lucene.Net Class Library

The TopFieldCollector type exposes the following members.
Methods
 | Name | Description
Public method | Collect | Called once for every document matching a query, with the unbased document number. Note: This is called in an inner search loop. For good search performance, implementations of this method should not call Doc(Int32) or Document(Int32) on every hit. Doing so can slow searches by an order of magnitude or more. (Inherited from Collector.)
 | Create | Creates a new TopFieldCollector from the given arguments. NOTE: The instances returned by this method pre-allocate a full array of length numHits.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NewTopDocs | (Overrides TopDocsCollector T NewTopDocs( ScoreDoc , Int32).)
Protected method | PopulateResults | (Overrides TopDocsCollector T PopulateResults( ScoreDoc , Int32).)
Public method | SetNextReader | Called before collecting from each IndexReader. All doc ids in Collect(Int32) will correspond to reader. Add docBase to the current IndexReaders internal document id to re-base ids in Collect(Int32). (Inherited from Collector.)
Public method | SetScorer | Called before successive calls to Collect(Int32). Implementations that need the score of the current document (passed-in to Collect(Int32)), should save the passed-in Scorer and call scorer.score() when needed. (Inherited from Collector.)
Public method | TopDocs | Returns the top docs that were collected by this collector. (Inherited from TopDocsCollector T .)
Public method | TopDocs(Int32) | Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned. This method is convenient to call if the application allways asks for the last results, starting from the last 'page'. NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different start, you should call TopDocs and work with the returned TopDocs object, which will contain all the results this search execution collected. (Inherited from TopDocsCollector T .)
Public method | TopDocs(Int32, Int32) | Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned. This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany. NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call TopDocs and work with the returned TopDocs object, which will contain all the results this search execution collected. (Inherited from TopDocsCollector T .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | internalTotalHits | The total number of documents that the collector encountered. (Inherited from TopDocsCollector T .)
Protected field | pq | The priority queue which holds the top documents. Note that different implementations of PriorityQueue give different meaning to 'top documents'. HitQueue for example aggregates the top scoring documents, while other PQ implementations may hold documents sorted by other criteria. (Inherited from TopDocsCollector T .)
Back to Top
Properties
 | Name | Description
Public property | AcceptsDocsOutOfOrder | (Overrides Collector AcceptsDocsOutOfOrder.)
Public property | TotalHits | The total number of documents that matched this query. (Inherited from TopDocsCollector T .)
Back to Top
See Also
TopFieldCollector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopFieldCollector Fields

TopFieldCollector Fields Lucene.Net Class Library
The TopFieldCollector type exposes the following members.
Fields
 | Name | Description
Protected field | internalTotalHits | The total number of documents that the collector encountered. (Inherited from TopDocsCollector T .)
Protected field | pq | The priority queue which holds the top documents. Note that different implementations of PriorityQueue give different meaning to 'top documents'. HitQueue for example aggregates the top scoring documents, while other PQ implementations may hold documents sorted by other criteria. (Inherited from TopDocsCollector T .)
Back to Top
See Also
TopFieldCollector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopFieldCollector Methods

TopFieldCollector Methods Lucene.Net Class Library
The TopFieldCollector type exposes the following members.
Methods
 | Name | Description
Public method | Collect | Called once for every document matching a query, with the unbased document number. Note: This is called in an inner search loop. For good search performance, implementations of this method should not call Doc(Int32) or Document(Int32) on every hit. Doing so can slow searches by an order of magnitude or more. (Inherited from Collector.)
 | Create | Creates a new TopFieldCollector from the given arguments. NOTE: The instances returned by this method pre-allocate a full array of length numHits.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NewTopDocs | (Overrides TopDocsCollector T NewTopDocs( ScoreDoc , Int32).)
Protected method | PopulateResults | (Overrides TopDocsCollector T PopulateResults( ScoreDoc , Int32).)
Public method | SetNextReader | Called before collecting from each IndexReader. All doc ids in Collect(Int32) will correspond to reader. Add docBase to the current IndexReaders internal document id to re-base ids in Collect(Int32). (Inherited from Collector.)
Public method | SetScorer | Called before successive calls to Collect(Int32). Implementations that need the score of the current document (passed-in to Collect(Int32)), should save the passed-in Scorer and call scorer.score() when needed. (Inherited from Collector.)
Public method | TopDocs | Returns the top docs that were collected by this collector. (Inherited from TopDocsCollector T .)
Public method | TopDocs(Int32) | Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned. This method is convenient to call if the application allways asks for the last results, starting from the last 'page'. NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different start, you should call TopDocs and work with the returned TopDocs object, which will contain all the results this search execution collected. (Inherited from TopDocsCollector T .)
Public method | TopDocs(Int32, Int32) | Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned. This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany. NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call TopDocs and work with the returned TopDocs object, which will contain all the results this search execution collected. (Inherited from TopDocsCollector T .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TopFieldCollector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Create Method

TopFieldCollector Create Method Lucene.Net Class Library
Creates a new TopFieldCollector from the given arguments.

NOTE: The instances returned by this method pre-allocate a full array of length numHits.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TopFieldCollector Create(
    Sort sort,
    int numHits,
    bool fillFields,
    bool trackDocScores,
    bool trackMaxScore,
    bool docsScoredInOrder
)
public static TopFieldCollector Create(
    Sort sort,
    int numHits,
    bool fillFields,
    bool trackDocScores,
    bool trackMaxScore,
    bool docsScoredInOrder
)
Public Shared Function Create ( _
    sort As Sort, _
    numHits As Integer, _
    fillFields As Boolean, _
    trackDocScores As Boolean, _
    trackMaxScore As Boolean, _
    docsScoredInOrder As Boolean _
) As TopFieldCollector
Public Shared Function Create ( _
    sort As Sort, _
    numHits As Integer, _
    fillFields As Boolean, _
    trackDocScores As Boolean, _
    trackMaxScore As Boolean, _
    docsScoredInOrder As Boolean _
) As TopFieldCollector
public:
static TopFieldCollector^ Create(
    Sort^ sort,
    int numHits,
    bool fillFields,
    bool trackDocScores,
    bool trackMaxScore,
    bool docsScoredInOrder
)
public:
static TopFieldCollector^ Create(
    Sort^ sort,
    int numHits,
    bool fillFields,
    bool trackDocScores,
    bool trackMaxScore,
    bool docsScoredInOrder
)
Parameters
sort
Type: Lucene.Net.Search Sort
the sort criteria (SortFields).

numHits
Type:   Online System Int32
the number of results to collect.

fillFields
Type:   Online System Boolean
specifies whether the actual field values should be returned on
            the results (FieldDoc).

trackDocScores
Type:   Online System Boolean
specifies whether document scores should be tracked and set on the
            results. Note that if set to false, then the results' scores will
            be set to Float.NaN. Setting this to true affects performance, as
            it incurs the score computation on each competitive result.
            Therefore if document scores are not required by the application,
            it is recommended to set it to false.

trackMaxScore
Type:   Online System Boolean
specifies whether the query's maxScore should be tracked and set
            on the resulting TopDocs. Note that if set to false,
            MaxScore returns Float.NaN. Setting this to
            true affects performance as it incurs the score computation on
            each result. Also, setting this true automatically sets
            trackDocScores to true as well.

docsScoredInOrder
Type:   Online System Boolean
specifies whether documents are scored in doc Id order or not by
            the given Scorer in SetScorer(Scorer).

Return Value
 a TopFieldCollector instance which will sort the results by
            the sort criteria.

See Also
TopFieldCollector Class
TopFieldCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewTopDocs Method

TopFieldCollector NewTopDocs Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TopDocs NewTopDocs(
    ScoreDoc[] results,
    int start
)
public override TopDocs NewTopDocs(
    ScoreDoc[] results,
    int start
)
Public Overrides Function NewTopDocs ( _
    results As ScoreDoc(), _
    start As Integer _
) As TopDocs
Public Overrides Function NewTopDocs ( _
    results As ScoreDoc(), _
    start As Integer _
) As TopDocs
public:
virtual TopDocs^ NewTopDocs(
    array<ScoreDoc^>^ results,
    int start
) override
public:
virtual TopDocs^ NewTopDocs(
    array<ScoreDoc^>^ results,
    int start
) override
Parameters
results
Type:  Lucene.Net.Search ScoreDoc
start
Type:   Online System Int32
See Also
TopFieldCollector Class
TopFieldCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PopulateResults Method

TopFieldCollector PopulateResults Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void PopulateResults(
    ScoreDoc[] results,
    int howMany
)
protected override void PopulateResults(
    ScoreDoc[] results,
    int howMany
)
Protected Overrides Sub PopulateResults ( _
    results As ScoreDoc(), _
    howMany As Integer _
)
Protected Overrides Sub PopulateResults ( _
    results As ScoreDoc(), _
    howMany As Integer _
)
protected:
virtual void PopulateResults(
    array<ScoreDoc^>^ results,
    int howMany
) override
protected:
virtual void PopulateResults(
    array<ScoreDoc^>^ results,
    int howMany
) override
Parameters
results
Type:  Lucene.Net.Search ScoreDoc
howMany
Type:   Online System Int32
See Also
TopFieldCollector Class
TopFieldCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopFieldCollector Properties

TopFieldCollector Properties Lucene.Net Class Library
The TopFieldCollector type exposes the following members.
Properties
 | Name | Description
Public property | AcceptsDocsOutOfOrder | (Overrides Collector AcceptsDocsOutOfOrder.)
Public property | TotalHits | The total number of documents that matched this query. (Inherited from TopDocsCollector T .)
Back to Top
See Also
TopFieldCollector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AcceptsDocsOutOfOrder Property

TopFieldCollector AcceptsDocsOutOfOrder Property Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool AcceptsDocsOutOfOrder { get; }
public override bool AcceptsDocsOutOfOrder { get; }
Public Overrides ReadOnly Property AcceptsDocsOutOfOrder As Boolean
    Get
Public Overrides ReadOnly Property AcceptsDocsOutOfOrder As Boolean
    Get
public:
virtual property bool AcceptsDocsOutOfOrder {
    bool get () override;
}
public:
virtual property bool AcceptsDocsOutOfOrder {
    bool get () override;
}
See Also
TopFieldCollector Class
TopFieldCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopFieldDocs Class

TopFieldDocs Class Lucene.Net Class Library
Represents hits returned by Search(Query, Filter, Int32, Sort).
Inheritance Hierarchy
Online System Object
Lucene.Net.Search TopDocs
Lucene.Net.Search TopFieldDocs

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TopFieldDocs : TopDocs
[SerializableAttribute]
public class TopFieldDocs : TopDocs
<SerializableAttribute> _
Public Class TopFieldDocs _
    Inherits TopDocs
<SerializableAttribute> _
Public Class TopFieldDocs _
    Inherits TopDocs
[SerializableAttribute]
public ref class TopFieldDocs : public TopDocs
[SerializableAttribute]
public ref class TopFieldDocs : public TopDocs
See Also
TopFieldDocs Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopFieldDocs Members

TopFieldDocs Members Lucene.Net Class Library

The TopFieldDocs type exposes the following members.
Constructors
 | Name | Description
Public method | TopFieldDocs | Creates one of these objects.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Public field | fields | The fields which were used to sort results by.
Back to Top
Properties
 | Name | Description
Public property | MaxScore | Gets or sets the maximum score value encountered, needed for normalizing. Note that in case scores are not tracked, this returns Online NaN. (Inherited from TopDocs.)
Public property | ScoreDocs | The top hits for the query. (Inherited from TopDocs.)
Public property | TotalHits | The total number of hits for the query. (Inherited from TopDocs.)
Back to Top
See Also
TopFieldDocs Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopFieldDocs Constructor

TopFieldDocs Constructor Lucene.Net Class Library
Creates one of these objects.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TopFieldDocs(
    int totalHits,
    ScoreDoc[] scoreDocs,
    SortField[] fields,
    float maxScore
)
public TopFieldDocs(
    int totalHits,
    ScoreDoc[] scoreDocs,
    SortField[] fields,
    float maxScore
)
Public Sub New ( _
    totalHits As Integer, _
    scoreDocs As ScoreDoc(), _
    fields As SortField(), _
    maxScore As Single _
)
Public Sub New ( _
    totalHits As Integer, _
    scoreDocs As ScoreDoc(), _
    fields As SortField(), _
    maxScore As Single _
)
public:
TopFieldDocs(
    int totalHits,
    array<ScoreDoc^>^ scoreDocs,
    array<SortField^>^ fields,
    float maxScore
)
public:
TopFieldDocs(
    int totalHits,
    array<ScoreDoc^>^ scoreDocs,
    array<SortField^>^ fields,
    float maxScore
)
Parameters
totalHits
Type:   Online System Int32
 Total number of hits for the query.

scoreDocs
Type:  Lucene.Net.Search ScoreDoc
 The top hits for the query.

fields
Type:  Lucene.Net.Search SortField
    The sort criteria used to find the top hits.

maxScore
Type:   Online System Single
  The maximum score encountered.

See Also
TopFieldDocs Class
TopFieldDocs Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopFieldDocs Fields

TopFieldDocs Fields Lucene.Net Class Library
The TopFieldDocs type exposes the following members.
Fields
 | Name | Description
Public field | fields | The fields which were used to sort results by.
Back to Top
See Also
TopFieldDocs Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


fields Field

TopFieldDocs fields Field Lucene.Net Class Library
The fields which were used to sort results by.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortField[] fields
public SortField[] fields
Public fields As SortField()
Public fields As SortField()
public:
array<SortField^>^ fields
public:
array<SortField^>^ fields
See Also
TopFieldDocs Class
TopFieldDocs Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopFieldDocs Methods

TopFieldDocs Methods Lucene.Net Class Library
The TopFieldDocs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TopFieldDocs Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopFieldDocs Properties

TopFieldDocs Properties Lucene.Net Class Library
The TopFieldDocs type exposes the following members.
Properties
 | Name | Description
Public property | MaxScore | Gets or sets the maximum score value encountered, needed for normalizing. Note that in case scores are not tracked, this returns Online NaN. (Inherited from TopDocs.)
Public property | ScoreDocs | The top hits for the query. (Inherited from TopDocs.)
Public property | TotalHits | The total number of hits for the query. (Inherited from TopDocs.)
Back to Top
See Also
TopFieldDocs Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopScoreDocCollector Class

TopScoreDocCollector Class Lucene.Net Class Library
A Collector implementation that collects the top-scoring hits, returning them as a TopDocs. This is used by IndexSearcher to implement TopDocs-based search. Hits are sorted by score descending and then (when the scores are tied) docID ascending. When you create an instance of this collector you should know in advance whether documents are going to be collected in doc Id order or not.

NOTE: The values Online NaN and Online NegativeInfinity are not valid scores. This collector will not properly collect hits with such scores.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Collector
Lucene.Net.Search TopDocsCollector ScoreDoc
Lucene.Net.Search TopScoreDocCollector

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class TopScoreDocCollector : TopDocsCollector<ScoreDoc>
public abstract class TopScoreDocCollector : TopDocsCollector<ScoreDoc>
Public MustInherit Class TopScoreDocCollector _
    Inherits TopDocsCollector(Of ScoreDoc)
Public MustInherit Class TopScoreDocCollector _
    Inherits TopDocsCollector(Of ScoreDoc)
public ref class TopScoreDocCollector abstract : public TopDocsCollector<ScoreDoc^>
public ref class TopScoreDocCollector abstract : public TopDocsCollector<ScoreDoc^>
See Also
TopScoreDocCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopScoreDocCollector Members

TopScoreDocCollector Members Lucene.Net Class Library

The TopScoreDocCollector type exposes the following members.
Methods
 | Name | Description
Public method | Collect | Called once for every document matching a query, with the unbased document number. Note: This is called in an inner search loop. For good search performance, implementations of this method should not call Doc(Int32) or Document(Int32) on every hit. Doing so can slow searches by an order of magnitude or more. (Inherited from Collector.)
 | Create | Creates a new TopScoreDocCollector given the number of hits to collect and whether documents are scored in order by the input Scorer to SetScorer(Scorer). NOTE: The instances returned by this method pre-allocate a full array of length numHits, and fill the array with sentinel objects.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NewTopDocs | (Overrides TopDocsCollector T NewTopDocs( ScoreDoc , Int32).)
Protected method | PopulateResults | Populates the results array with the ScoreDoc instaces. This can be overridden in case a different ScoreDoc type should be returned. (Inherited from TopDocsCollector T .)
Public method | SetNextReader | (Overrides Collector SetNextReader(IndexReader, Int32).)
Public method | SetScorer | (Overrides Collector SetScorer(Scorer).)
Public method | TopDocs | Returns the top docs that were collected by this collector. (Inherited from TopDocsCollector T .)
Public method | TopDocs(Int32) | Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned. This method is convenient to call if the application allways asks for the last results, starting from the last 'page'. NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different start, you should call TopDocs and work with the returned TopDocs object, which will contain all the results this search execution collected. (Inherited from TopDocsCollector T .)
Public method | TopDocs(Int32, Int32) | Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned. This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany. NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call TopDocs and work with the returned TopDocs object, which will contain all the results this search execution collected. (Inherited from TopDocsCollector T .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | internalTotalHits | The total number of documents that the collector encountered. (Inherited from TopDocsCollector T .)
Protected field | pq | The priority queue which holds the top documents. Note that different implementations of PriorityQueue give different meaning to 'top documents'. HitQueue for example aggregates the top scoring documents, while other PQ implementations may hold documents sorted by other criteria. (Inherited from TopDocsCollector T .)
Back to Top
Properties
 | Name | Description
Public property | AcceptsDocsOutOfOrder | Return true if this collector does not require the matching docIDs to be delivered in int sort order (smallest to largest) to Collect(Int32). Most Lucene Query implementations will visit matching docIDs in order. However, some queries (currently limited to certain cases of BooleanQuery) can achieve faster searching if the Collector allows them to deliver the docIDs out of order. Many collectors don't mind getting docIDs out of order, so it's important to return true here. (Inherited from Collector.)
Public property | TotalHits | The total number of documents that matched this query. (Inherited from TopDocsCollector T .)
Back to Top
See Also
TopScoreDocCollector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopScoreDocCollector Fields

TopScoreDocCollector Fields Lucene.Net Class Library
The TopScoreDocCollector type exposes the following members.
Fields
 | Name | Description
Protected field | internalTotalHits | The total number of documents that the collector encountered. (Inherited from TopDocsCollector T .)
Protected field | pq | The priority queue which holds the top documents. Note that different implementations of PriorityQueue give different meaning to 'top documents'. HitQueue for example aggregates the top scoring documents, while other PQ implementations may hold documents sorted by other criteria. (Inherited from TopDocsCollector T .)
Back to Top
See Also
TopScoreDocCollector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopScoreDocCollector Methods

TopScoreDocCollector Methods Lucene.Net Class Library
The TopScoreDocCollector type exposes the following members.
Methods
 | Name | Description
Public method | Collect | Called once for every document matching a query, with the unbased document number. Note: This is called in an inner search loop. For good search performance, implementations of this method should not call Doc(Int32) or Document(Int32) on every hit. Doing so can slow searches by an order of magnitude or more. (Inherited from Collector.)
 | Create | Creates a new TopScoreDocCollector given the number of hits to collect and whether documents are scored in order by the input Scorer to SetScorer(Scorer). NOTE: The instances returned by this method pre-allocate a full array of length numHits, and fill the array with sentinel objects.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NewTopDocs | (Overrides TopDocsCollector T NewTopDocs( ScoreDoc , Int32).)
Protected method | PopulateResults | Populates the results array with the ScoreDoc instaces. This can be overridden in case a different ScoreDoc type should be returned. (Inherited from TopDocsCollector T .)
Public method | SetNextReader | (Overrides Collector SetNextReader(IndexReader, Int32).)
Public method | SetScorer | (Overrides Collector SetScorer(Scorer).)
Public method | TopDocs | Returns the top docs that were collected by this collector. (Inherited from TopDocsCollector T .)
Public method | TopDocs(Int32) | Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned. This method is convenient to call if the application allways asks for the last results, starting from the last 'page'. NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different start, you should call TopDocs and work with the returned TopDocs object, which will contain all the results this search execution collected. (Inherited from TopDocsCollector T .)
Public method | TopDocs(Int32, Int32) | Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned. This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany. NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call TopDocs and work with the returned TopDocs object, which will contain all the results this search execution collected. (Inherited from TopDocsCollector T .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TopScoreDocCollector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Create Method

TopScoreDocCollector Create Method Lucene.Net Class Library
Creates a new TopScoreDocCollector given the number of hits to collect and whether documents are scored in order by the input Scorer to SetScorer(Scorer).

NOTE: The instances returned by this method pre-allocate a full array of length numHits, and fill the array with sentinel objects.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TopScoreDocCollector Create(
    int numHits,
    bool docsScoredInOrder
)
public static TopScoreDocCollector Create(
    int numHits,
    bool docsScoredInOrder
)
Public Shared Function Create ( _
    numHits As Integer, _
    docsScoredInOrder As Boolean _
) As TopScoreDocCollector
Public Shared Function Create ( _
    numHits As Integer, _
    docsScoredInOrder As Boolean _
) As TopScoreDocCollector
public:
static TopScoreDocCollector^ Create(
    int numHits,
    bool docsScoredInOrder
)
public:
static TopScoreDocCollector^ Create(
    int numHits,
    bool docsScoredInOrder
)
Parameters
numHits
Type:   Online System Int32
docsScoredInOrder
Type:   Online System Boolean
See Also
TopScoreDocCollector Class
TopScoreDocCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewTopDocs Method

TopScoreDocCollector NewTopDocs Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TopDocs NewTopDocs(
    ScoreDoc[] results,
    int start
)
public override TopDocs NewTopDocs(
    ScoreDoc[] results,
    int start
)
Public Overrides Function NewTopDocs ( _
    results As ScoreDoc(), _
    start As Integer _
) As TopDocs
Public Overrides Function NewTopDocs ( _
    results As ScoreDoc(), _
    start As Integer _
) As TopDocs
public:
virtual TopDocs^ NewTopDocs(
    array<ScoreDoc^>^ results,
    int start
) override
public:
virtual TopDocs^ NewTopDocs(
    array<ScoreDoc^>^ results,
    int start
) override
Parameters
results
Type:  Lucene.Net.Search ScoreDoc
start
Type:   Online System Int32
See Also
TopScoreDocCollector Class
TopScoreDocCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetNextReader Method

TopScoreDocCollector SetNextReader Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetNextReader(
    IndexReader reader,
    int base_Renamed
)
public override void SetNextReader(
    IndexReader reader,
    int base_Renamed
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    base_Renamed As Integer _
)
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    base_Renamed As Integer _
)
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int base_Renamed
) override
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int base_Renamed
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
base_Renamed
Type:   Online System Int32
See Also
TopScoreDocCollector Class
TopScoreDocCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetScorer Method

TopScoreDocCollector SetScorer Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetScorer(
    Scorer scorer
)
public override void SetScorer(
    Scorer scorer
)
Public Overrides Sub SetScorer ( _
    scorer As Scorer _
)
Public Overrides Sub SetScorer ( _
    scorer As Scorer _
)
public:
virtual void SetScorer(
    Scorer^ scorer
) override
public:
virtual void SetScorer(
    Scorer^ scorer
) override
Parameters
scorer
Type: Lucene.Net.Search Scorer
See Also
TopScoreDocCollector Class
TopScoreDocCollector Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopScoreDocCollector Properties

TopScoreDocCollector Properties Lucene.Net Class Library
The TopScoreDocCollector type exposes the following members.
Properties
 | Name | Description
Public property | AcceptsDocsOutOfOrder | Return true if this collector does not require the matching docIDs to be delivered in int sort order (smallest to largest) to Collect(Int32). Most Lucene Query implementations will visit matching docIDs in order. However, some queries (currently limited to certain cases of BooleanQuery) can achieve faster searching if the Collector allows them to deliver the docIDs out of order. Many collectors don't mind getting docIDs out of order, so it's important to return true here. (Inherited from Collector.)
Public property | TotalHits | The total number of documents that matched this query. (Inherited from TopDocsCollector T .)
Back to Top
See Also
TopScoreDocCollector Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Weight Class

Weight Class Lucene.Net Class Library
Expert: Calculate query weights and build query scorers.

The purpose of Weight is to ensure searching does not modify a Query, so that a Query instance can be reused.
Searcher dependent state of the query should reside in the Weight.
IndexReader dependent state should reside in the Scorer(IndexReader, Boolean, Boolean).

A Weight is used in the following way:
  • A Weight is constructed by a top-level query, given a Searcher (CreateWeight(Searcher)).
  • The GetSumOfSquaredWeights method is called on the Weight to compute the query normalization factor QueryNorm(Single) of the query clauses contained in the query.
  • The query normalization factor is passed to Normalize(Single). At this point the weighting is complete.
  • A Scorer is constructed by Scorer(IndexReader, Boolean, Boolean).
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Weight
Lucene.Net.Search BooleanQuery BooleanWeight
Lucene.Net.Search ConstantScoreQuery ConstantWeight
Lucene.Net.Search DisjunctionMaxQuery DisjunctionMaxWeight
Lucene.Net.Search.Spans SpanWeight

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class Weight
[SerializableAttribute]
public abstract class Weight
<SerializableAttribute> _
Public MustInherit Class Weight
<SerializableAttribute> _
Public MustInherit Class Weight
[SerializableAttribute]
public ref class Weight abstract
[SerializableAttribute]
public ref class Weight abstract
See Also
Weight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Weight Members

Weight Members Lucene.Net Class Library

The Weight type exposes the following members.
Constructors
 | Name | Description
Protected method | Weight | Initializes a new instance of the Weight class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | An explanation of the score computation for the named document.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetScoresDocsOutOfOrder | Returns true iff this implementation scores docs only out of order. This method is used in conjunction with Collector's AcceptsDocsOutOfOrder and Scorer(IndexReader, Boolean, Boolean) to create a matching Scorer(IndexReader, Boolean, Boolean) instance for a given Collector, or vice versa. NOTE: the default implementation returns false, i.e. the Scorer scores documents in-order.
Public method | GetSumOfSquaredWeights | The sum of squared weights of contained query clauses.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Normalize | Assigns the query normalization factor to this.
Public method | Scorer | Returns a Scorer(IndexReader, Boolean, Boolean) which scores documents in/out-of order according to scoreDocsInOrder. NOTE: even if scoreDocsInOrder is false, it is recommended to check whether the returned Scorer indeed scores documents out of order (i.e., call GetScoresDocsOutOfOrder ), as some Scorer implementations will always return documents in-order. NOTE: null can be returned if no documents will be scored by this query.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Query | The query that this concerns.
Public property | Value | The weight for this query.
Back to Top
See Also
Weight Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Weight Constructor

Weight Constructor Lucene.Net Class Library
Initializes a new instance of the Weight class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Weight()
protected Weight()
Protected Sub New
Protected Sub New
protected:
Weight()
protected:
Weight()
See Also
Weight Class
Weight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Weight Methods

Weight Methods Lucene.Net Class Library
The Weight type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | An explanation of the score computation for the named document.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetScoresDocsOutOfOrder | Returns true iff this implementation scores docs only out of order. This method is used in conjunction with Collector's AcceptsDocsOutOfOrder and Scorer(IndexReader, Boolean, Boolean) to create a matching Scorer(IndexReader, Boolean, Boolean) instance for a given Collector, or vice versa. NOTE: the default implementation returns false, i.e. the Scorer scores documents in-order.
Public method | GetSumOfSquaredWeights | The sum of squared weights of contained query clauses.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Normalize | Assigns the query normalization factor to this.
Public method | Scorer | Returns a Scorer(IndexReader, Boolean, Boolean) which scores documents in/out-of order according to scoreDocsInOrder. NOTE: even if scoreDocsInOrder is false, it is recommended to check whether the returned Scorer indeed scores documents out of order (i.e., call GetScoresDocsOutOfOrder ), as some Scorer implementations will always return documents in-order. NOTE: null can be returned if no documents will be scored by this query.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Weight Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method

Weight Explain Method Lucene.Net Class Library
An explanation of the score computation for the named document.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Explanation Explain(
    IndexReader reader,
    int doc
)
public abstract Explanation Explain(
    IndexReader reader,
    int doc
)
Public MustOverride Function Explain ( _
    reader As IndexReader, _
    doc As Integer _
) As Explanation
Public MustOverride Function Explain ( _
    reader As IndexReader, _
    doc As Integer _
) As Explanation
public:
virtual Explanation^ Explain(
    IndexReader^ reader,
    int doc
) abstract
public:
virtual Explanation^ Explain(
    IndexReader^ reader,
    int doc
) abstract
Parameters
reader
Type: Lucene.Net.Index IndexReader
sub-reader containing the give doc

doc
Type:   Online System Int32
Return Value
 an Explanation for the score

See Also
Weight Class
Weight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetScoresDocsOutOfOrder Method

Weight GetScoresDocsOutOfOrder Method Lucene.Net Class Library
Returns true iff this implementation scores docs only out of order. This method is used in conjunction with Collector's AcceptsDocsOutOfOrder and Scorer(IndexReader, Boolean, Boolean) to create a matching Scorer(IndexReader, Boolean, Boolean) instance for a given Collector, or vice versa.

NOTE: the default implementation returns false, i.e. the Scorer scores documents in-order.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool GetScoresDocsOutOfOrder()
public virtual bool GetScoresDocsOutOfOrder()
Public Overridable Function GetScoresDocsOutOfOrder As Boolean
Public Overridable Function GetScoresDocsOutOfOrder As Boolean
public:
virtual bool GetScoresDocsOutOfOrder()
public:
virtual bool GetScoresDocsOutOfOrder()
See Also
Weight Class
Weight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSumOfSquaredWeights Method

Weight GetSumOfSquaredWeights Method Lucene.Net Class Library
The sum of squared weights of contained query clauses.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract float GetSumOfSquaredWeights()
public abstract float GetSumOfSquaredWeights()
Public MustOverride Function GetSumOfSquaredWeights As Single
Public MustOverride Function GetSumOfSquaredWeights As Single
public:
virtual float GetSumOfSquaredWeights() abstract
public:
virtual float GetSumOfSquaredWeights() abstract
See Also
Weight Class
Weight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Normalize Method

Weight Normalize Method Lucene.Net Class Library
Assigns the query normalization factor to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Normalize(
    float norm
)
public abstract void Normalize(
    float norm
)
Public MustOverride Sub Normalize ( _
    norm As Single _
)
Public MustOverride Sub Normalize ( _
    norm As Single _
)
public:
virtual void Normalize(
    float norm
) abstract
public:
virtual void Normalize(
    float norm
) abstract
Parameters
norm
Type:   Online System Single
See Also
Weight Class
Weight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Scorer Method

Weight Scorer Method Lucene.Net Class Library
Returns a Scorer(IndexReader, Boolean, Boolean) which scores documents in/out-of order according to scoreDocsInOrder.

NOTE: even if scoreDocsInOrder is false, it is recommended to check whether the returned Scorer indeed scores documents out of order (i.e., call GetScoresDocsOutOfOrder ), as some Scorer implementations will always return documents in-order.
NOTE: null can be returned if no documents will be scored by this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
public abstract Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
Public MustOverride Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
Public MustOverride Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) abstract
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) abstract
Parameters
reader
Type: Lucene.Net.Index IndexReader

            the IndexReader for which to return the Scorer.

scoreDocsInOrder
Type:   Online System Boolean
specifies whether in-order scoring of documents is required. Note
            that if set to false (i.e., out-of-order scoring is required),
            this method can return whatever scoring mode it supports, as every
            in-order scorer is also an out-of-order one. However, an
            out-of-order scorer may not support NextDoc
            and/or Advance(Int32), therefore it is recommended to
            request an in-order scorer if use of these methods is required.

topScorer
Type:   Online System Boolean

            if true, Score(Collector) will be called; if false,
            NextDoc  and/or Advance(Int32) will
            be called.

Return Value
 a Scorer(IndexReader, Boolean, Boolean) which scores documents in/out-of order.

See Also
Weight Class
Weight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Weight Properties

Weight Properties Lucene.Net Class Library
The Weight type exposes the following members.
Properties
 | Name | Description
Public property | Query | The query that this concerns.
Public property | Value | The weight for this query.
Back to Top
See Also
Weight Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Query Property

Weight Query Property Lucene.Net Class Library
The query that this concerns.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Query Query { get; }
public abstract Query Query { get; }
Public MustOverride ReadOnly Property Query As Query
    Get
Public MustOverride ReadOnly Property Query As Query
    Get
public:
virtual property Query^ Query {
    Query^ get () abstract;
}
public:
virtual property Query^ Query {
    Query^ get () abstract;
}
See Also
Weight Class
Weight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Value Property

Weight Value Property Lucene.Net Class Library
The weight for this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract float Value { get; }
public abstract float Value { get; }
Public MustOverride ReadOnly Property Value As Single
    Get
Public MustOverride ReadOnly Property Value As Single
    Get
public:
virtual property float Value {
    float get () abstract;
}
public:
virtual property float Value {
    float get () abstract;
}
See Also
Weight Class
Weight Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WildcardQuery Class

WildcardQuery Class Lucene.Net Class Library
Implements the wildcard search query. Supported wildcards are *, which matches any character sequence (including the empty one), and ?, which matches any single character. Note this query can be slow, as it needs to iterate over many terms. In order to prevent extremely slow WildcardQueries, a Wildcard term should not start with one of the wildcards * or ?.

This query uses the CONSTANT_SCORE_AUTO_REWRITE_DEFAULT rewrite method.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search MultiTermQuery
Lucene.Net.Search WildcardQuery

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class WildcardQuery : MultiTermQuery
[SerializableAttribute]
public class WildcardQuery : MultiTermQuery
<SerializableAttribute> _
Public Class WildcardQuery _
    Inherits MultiTermQuery
<SerializableAttribute> _
Public Class WildcardQuery _
    Inherits MultiTermQuery
[SerializableAttribute]
public ref class WildcardQuery : public MultiTermQuery
[SerializableAttribute]
public ref class WildcardQuery : public MultiTermQuery
See Also
WildcardQuery Members
Lucene.Net.Search Namespace
Lucene.Net.Search WildcardTermEnum
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WildcardQuery Members

WildcardQuery Members Lucene.Net Class Library

The WildcardQuery type exposes the following members.
Constructors
 | Name | Description
Public method | WildcardQuery | Initializes a new instance of the WildcardQuery class
Back to Top
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the query/filter. (Inherited from MultiTermQuery.)
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | Expert: Constructs an appropriate Weight implementation for this query. Only implemented by primitive queries, which re-write to themselves. (Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery Equals(Object).)
Public method | ExtractTerms | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its rewritten form. (Inherited from Query.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetEnum | (Overrides MultiTermQuery GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides MultiTermQuery Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Fields
 | Name | Description
Protected field | internalRewriteMethod | (Inherited from MultiTermQuery.)
Protected field | internalTerm |
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | RewriteMethod | Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of RewriteMethod. (Inherited from MultiTermQuery.)
Public property | Term | Returns the pattern term.
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers. (Inherited from MultiTermQuery.)
Back to Top
See Also
WildcardQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WildcardQuery Constructor

WildcardQuery Constructor Lucene.Net Class Library
Initializes a new instance of the WildcardQuery class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WildcardQuery(
    Term term
)
public WildcardQuery(
    Term term
)
Public Sub New ( _
    term As Term _
)
Public Sub New ( _
    term As Term _
)
public:
WildcardQuery(
    Term^ term
)
public:
WildcardQuery(
    Term^ term
)
Parameters
term
Type: Lucene.Net.Index Term
See Also
WildcardQuery Class
WildcardQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WildcardQuery Fields

WildcardQuery Fields Lucene.Net Class Library
The WildcardQuery type exposes the following members.
Fields
 | Name | Description
Protected field | internalRewriteMethod | (Inherited from MultiTermQuery.)
Protected field | internalTerm |
Back to Top
See Also
WildcardQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalTerm Field

WildcardQuery internalTerm Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Term internalTerm
protected Term internalTerm
Protected internalTerm As Term
Protected internalTerm As Term
protected:
Term^ internalTerm
protected:
Term^ internalTerm
See Also
WildcardQuery Class
WildcardQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WildcardQuery Methods

WildcardQuery Methods Lucene.Net Class Library
The WildcardQuery type exposes the following members.
Methods
 | Name | Description
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the query/filter. (Inherited from MultiTermQuery.)
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | Expert: Constructs an appropriate Weight implementation for this query. Only implemented by primitive queries, which re-write to themselves. (Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery Equals(Object).)
Public method | ExtractTerms | Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its rewritten form. (Inherited from Query.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetEnum | (Overrides MultiTermQuery GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides MultiTermQuery Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
WildcardQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

WildcardQuery Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
WildcardQuery Class
WildcardQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetEnum Method

WildcardQuery GetEnum Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override FilteredTermEnum GetEnum(
    IndexReader reader
)
protected override FilteredTermEnum GetEnum(
    IndexReader reader
)
Protected Overrides Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
Protected Overrides Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
protected:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) override
protected:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
WildcardQuery Class
WildcardQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

WildcardQuery GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
WildcardQuery Class
WildcardQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

WildcardQuery Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    IndexReader reader
)
public override Query Rewrite(
    IndexReader reader
)
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
WildcardQuery Class
WildcardQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

WildcardQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query ToString(String).)
Back to Top
See Also
WildcardQuery Class
WildcardQuery Members
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

WildcardQuery ToString Method (String) Lucene.Net Class Library
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
WildcardQuery Class
WildcardQuery Members
ToString Overload
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WildcardQuery Properties

WildcardQuery Properties Lucene.Net Class Library
The WildcardQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | RewriteMethod | Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of RewriteMethod. (Inherited from MultiTermQuery.)
Public property | Term | Returns the pattern term.
Public property | TotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with ClearTotalNumberOfTerms . On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers. (Inherited from MultiTermQuery.)
Back to Top
See Also
WildcardQuery Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Property

WildcardQuery Term Property Lucene.Net Class Library
Returns the pattern term.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Term Term { get; }
public Term Term { get; }
Public ReadOnly Property Term As Term
    Get
Public ReadOnly Property Term As Term
    Get
public:
property Term^ Term {
    Term^ get ();
}
public:
property Term^ Term {
    Term^ get ();
}
See Also
WildcardQuery Class
WildcardQuery Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WildcardTermEnum Class

WildcardTermEnum Class Lucene.Net Class Library
Subclass of FilteredTermEnum for enumerating all terms that match the specified wildcard filter term.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.
Inheritance Hierarchy
Online System Object
Lucene.Net.Index TermEnum
Lucene.Net.Search FilteredTermEnum
Lucene.Net.Search WildcardTermEnum

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class WildcardTermEnum : FilteredTermEnum
public class WildcardTermEnum : FilteredTermEnum
Public Class WildcardTermEnum _
    Inherits FilteredTermEnum
Public Class WildcardTermEnum _
    Inherits FilteredTermEnum
public ref class WildcardTermEnum : public FilteredTermEnum
public ref class WildcardTermEnum : public FilteredTermEnum
See Also
WildcardTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WildcardTermEnum Members

WildcardTermEnum Members Lucene.Net Class Library

The WildcardTermEnum type exposes the following members.
Constructors
 | Name | Description
Public method | WildcardTermEnum | Creates a new WildcardTermEnum. After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Public method | Difference | (Overrides FilteredTermEnum Difference .)
Public method | Dispose | Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Protected method | Dispose(Boolean) | (Inherited from FilteredTermEnum.)
Public method | DocFreq | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum EndEnum .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | Increments the enumeration to the next element. True if one exists. (Inherited from FilteredTermEnum.)
Protected method | SetEnum | use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term. (Inherited from FilteredTermEnum.)
Protected method | TermCompare | (Overrides FilteredTermEnum TermCompare(Term).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
 | WildcardEquals | Determines if a word matches a wildcard pattern. Work released by Granta Design Ltd after originally being done on company time.
Back to Top
Fields
 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use SetEnum(TermEnum) (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)
 | WILDCARD_CHAR |
 | WILDCARD_STRING | ***************************************** String equality with support for wildcards ******************************************
Back to Top
Properties
 | Name | Description
Public property | Term | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Back to Top
See Also
WildcardTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WildcardTermEnum Constructor

WildcardTermEnum Constructor Lucene.Net Class Library
Creates a new WildcardTermEnum.

After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WildcardTermEnum(
    IndexReader reader,
    Term term
)
public WildcardTermEnum(
    IndexReader reader,
    Term term
)
Public Sub New ( _
    reader As IndexReader, _
    term As Term _
)
Public Sub New ( _
    reader As IndexReader, _
    term As Term _
)
public:
WildcardTermEnum(
    IndexReader^ reader,
    Term^ term
)
public:
WildcardTermEnum(
    IndexReader^ reader,
    Term^ term
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
term
Type: Lucene.Net.Index Term
See Also
WildcardTermEnum Class
WildcardTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WildcardTermEnum Fields

WildcardTermEnum Fields Lucene.Net Class Library
The WildcardTermEnum type exposes the following members.
Fields
 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use SetEnum(TermEnum) (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)
 | WILDCARD_CHAR |
 | WILDCARD_STRING | ***************************************** String equality with support for wildcards ******************************************
Back to Top
See Also
WildcardTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WILDCARD_CHAR Field

WildcardTermEnum WILDCARD_CHAR Field Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char WILDCARD_CHAR
public const char WILDCARD_CHAR
Public Const WILDCARD_CHAR As Char
Public Const WILDCARD_CHAR As Char
public:
literal wchar_t WILDCARD_CHAR
public:
literal wchar_t WILDCARD_CHAR
See Also
WildcardTermEnum Class
WildcardTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WILDCARD_STRING Field

WildcardTermEnum WILDCARD_STRING Field Lucene.Net Class Library
***************************************** String equality with support for wildcards ******************************************

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char WILDCARD_STRING
public const char WILDCARD_STRING
Public Const WILDCARD_STRING As Char
Public Const WILDCARD_STRING As Char
public:
literal wchar_t WILDCARD_STRING
public:
literal wchar_t WILDCARD_STRING
See Also
WildcardTermEnum Class
WildcardTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WildcardTermEnum Methods

WildcardTermEnum Methods Lucene.Net Class Library
The WildcardTermEnum type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Public method | Difference | (Overrides FilteredTermEnum Difference .)
Public method | Dispose | Closes the enumeration to further activity, freeing resources. (Inherited from TermEnum.)
Protected method | Dispose(Boolean) | (Inherited from FilteredTermEnum.)
Public method | DocFreq | Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum EndEnum .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | Increments the enumeration to the next element. True if one exists. (Inherited from FilteredTermEnum.)
Protected method | SetEnum | use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term. (Inherited from FilteredTermEnum.)
Protected method | TermCompare | (Overrides FilteredTermEnum TermCompare(Term).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
 | WildcardEquals | Determines if a word matches a wildcard pattern. Work released by Granta Design Ltd after originally being done on company time.
Back to Top
See Also
WildcardTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Difference Method

WildcardTermEnum Difference Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Difference()
public override float Difference()
Public Overrides Function Difference As Single
Public Overrides Function Difference As Single
public:
virtual float Difference() override
public:
virtual float Difference() override
See Also
WildcardTermEnum Class
WildcardTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EndEnum Method

WildcardTermEnum EndEnum Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool EndEnum()
public override bool EndEnum()
Public Overrides Function EndEnum As Boolean
Public Overrides Function EndEnum As Boolean
public:
virtual bool EndEnum() override
public:
virtual bool EndEnum() override
See Also
WildcardTermEnum Class
WildcardTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermCompare Method

WildcardTermEnum TermCompare Method Lucene.Net Class Library

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool TermCompare(
    Term term
)
protected override bool TermCompare(
    Term term
)
Protected Overrides Function TermCompare ( _
    term As Term _
) As Boolean
Protected Overrides Function TermCompare ( _
    term As Term _
) As Boolean
protected:
virtual bool TermCompare(
    Term^ term
) override
protected:
virtual bool TermCompare(
    Term^ term
) override
Parameters
term
Type: Lucene.Net.Index Term
See Also
WildcardTermEnum Class
WildcardTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WildcardEquals Method

WildcardTermEnum WildcardEquals Method Lucene.Net Class Library
Determines if a word matches a wildcard pattern. Work released by Granta Design Ltd after originally being done on company time.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool WildcardEquals(
    string pattern,
    int patternIdx,
    string string_Renamed,
    int stringIdx
)
public static bool WildcardEquals(
    string pattern,
    int patternIdx,
    string string_Renamed,
    int stringIdx
)
Public Shared Function WildcardEquals ( _
    pattern As String, _
    patternIdx As Integer, _
    string_Renamed As String, _
    stringIdx As Integer _
) As Boolean
Public Shared Function WildcardEquals ( _
    pattern As String, _
    patternIdx As Integer, _
    string_Renamed As String, _
    stringIdx As Integer _
) As Boolean
public:
static bool WildcardEquals(
    String^ pattern,
    int patternIdx,
    String^ string_Renamed,
    int stringIdx
)
public:
static bool WildcardEquals(
    String^ pattern,
    int patternIdx,
    String^ string_Renamed,
    int stringIdx
)
Parameters
pattern
Type:   Online System String
patternIdx
Type:   Online System Int32
string_Renamed
Type:   Online System String
stringIdx
Type:   Online System Int32
See Also
WildcardTermEnum Class
WildcardTermEnum Members
Lucene.Net.Search Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WildcardTermEnum Properties

WildcardTermEnum Properties Lucene.Net Class Library
The WildcardTermEnum type exposes the following members.
Properties
 | Name | Description
Public property | Term | Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated. (Inherited from FilteredTermEnum.)
Back to Top
See Also
WildcardTermEnum Class
Lucene.Net.Search Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lucene.Net.Search.Function Namespace

Lucene.Net.Search.Function Namespace Lucene.Net Class Library
Classes
Class Description
Public class ByteFieldSource
Expert: obtains single byte field values from the FieldCache using getBytes() and makes those values available as other numeric types, casting as needed.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Public class CustomScoreProvider
An instance of this subclass should be returned by GetCustomScoreProvider(IndexReader), if you want to modify the custom score calculation of a CustomScoreQuery.

Since Lucene 2.9, queries operate on each segment of an Index separately, so overriding the similar (now deprecated) methods in CustomScoreQuery is no longer suitable, as the supplied doc ID is per-segment and without knowledge of the IndexReader you cannot access the document or FieldCache.

@lucene.experimental @since 2.9.2
Public class CustomScoreQuery
Query that sets document score as a programmatic function of several (sub) scores:
  • the score of its subQuery (any query)
  • (optional) the score of its ValueSourceQuery (or queries). For most simple/convenient use cases this query is likely to be a FieldScoreQuery
Subclasses can modify the computation by overriding GetCustomScoreProvider(IndexReader).

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Public class DocValues
Expert: represents field values as different types. Normally created via a ValueSuorce for a particular field and reader.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Public class FieldCacheSource
Expert: A base class for ValueSource implementations that retrieve values for a single field from the FieldCache.

Fields used herein nust be indexed (doesn't matter if these fields are stored or not).

It is assumed that each such indexed field is untokenized, or at least has a single token in a document. For documents with multiple tokens of the same field, behavior is undefined (It is likely that current code would use the value of one of these tokens, but this is not guaranteed).

Document with no tokens in this field are assigned the Zero value.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

NOTE: with the switch in 2.9 to segment-based searching, if GetValues(IndexReader) is invoked with a composite (multi-segment) reader, this can easily cause double RAM usage for the values in the FieldCache. It's best to switch your application to pass only atomic (single segment) readers to this API.

Public class FieldScoreQuery
A query that scores each document as the value of the numeric input field.

The query matches all documents, and scores each document according to the numeric value of that field.

It is assumed, and expected, that:
  • The field used here is indexed, and has exactly one token in every scored document.
  • Best if this field is un_tokenized.
  • That token is parsable to the selected type.

Combining this query in a FunctionQuery allows much freedom in affecting document scores. Note, that with this freedom comes responsibility: it is more than likely that the default Lucene scoring is superior in quality to scoring modified as explained here. However, in some cases, and certainly for research experiments, this capability may turn useful.

When contructing this query, select the appropriate type. That type should match the data stored in the field. So in fact the "right" type should be selected before indexing. Type selection has effect on the RAM usage:
  • BYTE consumes 1 * maxDocs bytes.
  • SHORT consumes 2 * maxDocs bytes.
  • INT consumes 4 * maxDocs bytes.
  • FLOAT consumes 8 * maxDocs bytes.

Caching: Values for the numeric field are loaded once and cached in memory for further use with the same IndexReader. To take advantage of this, it is extremely important to reuse index-readers or index-searchers, otherwise, for instance if for each query a new index reader is opened, large penalties would be paid for loading the field values into memory over and over again!

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Public class FieldScoreQuery Type
Type of score field, indicating how field values are interpreted/parsed.

The type selected at search search time should match the data stored in the field. Different types have different RAM requirements:
  • BYTE consumes 1 * maxDocs bytes.
  • SHORT consumes 2 * maxDocs bytes.
  • INT consumes 4 * maxDocs bytes.
  • FLOAT consumes 8 * maxDocs bytes.
Public class FloatFieldSource
Expert: obtains float field values from the FieldCache using getFloats() and makes those values available as other numeric types, casting as needed.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Public class IntFieldSource
Expert: obtains int field values from the FieldCache using getInts() and makes those values available as other numeric types, casting as needed.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Public class OrdFieldSource
Expert: obtains the ordinal of the field value from the default Lucene Fieldcache using getStringIndex().

The native lucene index order is used to assign an ordinal value for each field value.

Field values (terms) are lexicographically ordered by unicode value, and numbered starting at 1.

Example:
If there were only three field values: "apple","banana","pear"
then ord("apple")=1, ord("banana")=2, ord("pear")=3

WARNING: ord() depends on the position in an index and can thus change when other documents are inserted or deleted, or if a MultiSearcher is used.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

NOTE: with the switch in 2.9 to segment-based searching, if GetValues(IndexReader) is invoked with a composite (multi-segment) reader, this can easily cause double RAM usage for the values in the FieldCache. It's best to switch your application to pass only atomic (single segment) readers to this API.

Public class ReverseOrdFieldSource
Expert: obtains the ordinal of the field value from the default Lucene FieldCache using getStringIndex() and reverses the order.

The native lucene index order is used to assign an ordinal value for each field value.

Field values (terms) are lexicographically ordered by unicode value, and numbered starting at 1.
Example of reverse ordinal (rord):
If there were only three field values: "apple","banana","pear"
then rord("apple")=3, rord("banana")=2, ord("pear")=1

WARNING: rord() depends on the position in an index and can thus change when other documents are inserted or deleted, or if a MultiSearcher is used.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

NOTE: with the switch in 2.9 to segment-based searching, if GetValues(IndexReader) is invoked with a composite (multi-segment) reader, this can easily cause double RAM usage for the values in the FieldCache. It's best to switch your application to pass only atomic (single segment) readers to this API.

Public class ShortFieldSource
Expert: obtains short field values from the FieldCache using getShorts() and makes those values available as other numeric types, casting as needed.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Public class ValueSource
Expert: source of values for basic function queries.

At its default/simplest form, values - one per doc - are used as the score of that doc.

Values are instantiated as DocValues for a particular reader.

ValueSource implementations differ in RAM requirements: it would always be a factor of the number of documents, but for each document the number of bytes can be 1, 2, 4, or 8.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Public class ValueSourceQuery
Expert: A Query that sets the scores of document to the values obtained from a ValueSource.

This query provides a score for each and every undeleted document in the index.

The value source can be based on a (cached) value of an indexed field, but it can also be based on an external source, e.g. values read from an external database.

Score is set as: Score(doc,query) = query.getBoost()2 * valueSource(doc).

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteFieldSource Class

ByteFieldSource Class Lucene.Net Class Library
Expert: obtains single byte field values from the FieldCache using getBytes() and makes those values available as other numeric types, casting as needed.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Function ValueSource
Lucene.Net.Search.Function FieldCacheSource
Lucene.Net.Search.Function ByteFieldSource

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ByteFieldSource : FieldCacheSource
[SerializableAttribute]
public class ByteFieldSource : FieldCacheSource
<SerializableAttribute> _
Public Class ByteFieldSource _
    Inherits FieldCacheSource
<SerializableAttribute> _
Public Class ByteFieldSource _
    Inherits FieldCacheSource
[SerializableAttribute]
public ref class ByteFieldSource : public FieldCacheSource
[SerializableAttribute]
public ref class ByteFieldSource : public FieldCacheSource
See Also
ByteFieldSource Members
Lucene.Net.Search.Function Namespace
 for requirements"
            on the field.

            NOTE: with the switch in 2.9 to segment-based
            searching, if  is invoked with a
            composite (multi-segment) reader, this can easily cause
            double RAM usage for the values in the FieldCache.  It's
            best to switch your application to pass only atomic
            (single segment) readers to this API.
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteFieldSource Members

ByteFieldSource Members Lucene.Net Class Library

The ByteFieldSource type exposes the following members.
Constructors
 | Name | Description
Public method | ByteFieldSource(String) | Create a cached byte field source with default string-to-byte parser.
Public method | ByteFieldSource(String, ByteParser) | Create a cached byte field source with a specific string-to-byte parser.
Back to Top
Methods
 | Name | Description
Public method | CachedFieldSourceEquals | (Overrides FieldCacheSource CachedFieldSourceEquals(FieldCacheSource).)
Public method | CachedFieldSourceHashCode | (Overrides FieldCacheSource CachedFieldSourceHashCode .)
Public method | Description | (Overrides FieldCacheSource Description .)
Public method | Equals | (Inherited from FieldCacheSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetCachedFieldValues | (Overrides FieldCacheSource GetCachedFieldValues(FieldCache, String, IndexReader).)
Public method | GetHashCode | (Inherited from FieldCacheSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | (Inherited from FieldCacheSource.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from ValueSource.)
Back to Top
See Also
ByteFieldSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteFieldSource Constructor

ByteFieldSource Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ByteFieldSource(String) | Create a cached byte field source with default string-to-byte parser.
Public method | ByteFieldSource(String, ByteParser) | Create a cached byte field source with a specific string-to-byte parser.
Back to Top
See Also
ByteFieldSource Class
ByteFieldSource Members
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteFieldSource Constructor (String)

ByteFieldSource Constructor (String) Lucene.Net Class Library
Create a cached byte field source with default string-to-byte parser.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ByteFieldSource(
    string field
)
public ByteFieldSource(
    string field
)
Public Sub New ( _
    field As String _
)
Public Sub New ( _
    field As String _
)
public:
ByteFieldSource(
    String^ field
)
public:
ByteFieldSource(
    String^ field
)
Parameters
field
Type:   Online System String
See Also
ByteFieldSource Class
ByteFieldSource Members
ByteFieldSource Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteFieldSource Constructor (String, ByteParser)

ByteFieldSource Constructor (String, ByteParser) Lucene.Net Class Library
Create a cached byte field source with a specific string-to-byte parser.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ByteFieldSource(
    string field,
    ByteParser parser
)
public ByteFieldSource(
    string field,
    ByteParser parser
)
Public Sub New ( _
    field As String, _
    parser As ByteParser _
)
Public Sub New ( _
    field As String, _
    parser As ByteParser _
)
public:
ByteFieldSource(
    String^ field,
    ByteParser^ parser
)
public:
ByteFieldSource(
    String^ field,
    ByteParser^ parser
)
Parameters
field
Type:   Online System String
parser
Type: Lucene.Net.Search ByteParser
See Also
ByteFieldSource Class
ByteFieldSource Members
ByteFieldSource Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteFieldSource Methods

ByteFieldSource Methods Lucene.Net Class Library
The ByteFieldSource type exposes the following members.
Methods
 | Name | Description
Public method | CachedFieldSourceEquals | (Overrides FieldCacheSource CachedFieldSourceEquals(FieldCacheSource).)
Public method | CachedFieldSourceHashCode | (Overrides FieldCacheSource CachedFieldSourceHashCode .)
Public method | Description | (Overrides FieldCacheSource Description .)
Public method | Equals | (Inherited from FieldCacheSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetCachedFieldValues | (Overrides FieldCacheSource GetCachedFieldValues(FieldCache, String, IndexReader).)
Public method | GetHashCode | (Inherited from FieldCacheSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | (Inherited from FieldCacheSource.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from ValueSource.)
Back to Top
See Also
ByteFieldSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachedFieldSourceEquals Method

ByteFieldSource CachedFieldSourceEquals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CachedFieldSourceEquals(
    FieldCacheSource o
)
public override bool CachedFieldSourceEquals(
    FieldCacheSource o
)
Public Overrides Function CachedFieldSourceEquals ( _
    o As FieldCacheSource _
) As Boolean
Public Overrides Function CachedFieldSourceEquals ( _
    o As FieldCacheSource _
) As Boolean
public:
virtual bool CachedFieldSourceEquals(
    FieldCacheSource^ o
) override
public:
virtual bool CachedFieldSourceEquals(
    FieldCacheSource^ o
) override
Parameters
o
Type: Lucene.Net.Search.Function FieldCacheSource
See Also
ByteFieldSource Class
ByteFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachedFieldSourceHashCode Method

ByteFieldSource CachedFieldSourceHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int CachedFieldSourceHashCode()
public override int CachedFieldSourceHashCode()
Public Overrides Function CachedFieldSourceHashCode As Integer
Public Overrides Function CachedFieldSourceHashCode As Integer
public:
virtual int CachedFieldSourceHashCode() override
public:
virtual int CachedFieldSourceHashCode() override
See Also
ByteFieldSource Class
ByteFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Description Method

ByteFieldSource Description Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description()
public override string Description()
Public Overrides Function Description As String
Public Overrides Function Description As String
public:
virtual String^ Description() override
public:
virtual String^ Description() override
See Also
ByteFieldSource Class
ByteFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCachedFieldValues Method

ByteFieldSource GetCachedFieldValues Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocValues GetCachedFieldValues(
    FieldCache cache,
    string field,
    IndexReader reader
)
public override DocValues GetCachedFieldValues(
    FieldCache cache,
    string field,
    IndexReader reader
)
Public Overrides Function GetCachedFieldValues ( _
    cache As FieldCache, _
    field As String, _
    reader As IndexReader _
) As DocValues
Public Overrides Function GetCachedFieldValues ( _
    cache As FieldCache, _
    field As String, _
    reader As IndexReader _
) As DocValues
public:
virtual DocValues^ GetCachedFieldValues(
    FieldCache^ cache,
    String^ field,
    IndexReader^ reader
) override
public:
virtual DocValues^ GetCachedFieldValues(
    FieldCache^ cache,
    String^ field,
    IndexReader^ reader
) override
Parameters
cache
Type: Lucene.Net.Search FieldCache
field
Type:   Online System String
reader
Type: Lucene.Net.Index IndexReader
See Also
ByteFieldSource Class
ByteFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScoreProvider Class

CustomScoreProvider Class Lucene.Net Class Library
An instance of this subclass should be returned by GetCustomScoreProvider(IndexReader), if you want to modify the custom score calculation of a CustomScoreQuery.

Since Lucene 2.9, queries operate on each segment of an Index separately, so overriding the similar (now deprecated) methods in CustomScoreQuery is no longer suitable, as the supplied doc ID is per-segment and without knowledge of the IndexReader you cannot access the document or FieldCache.

@lucene.experimental @since 2.9.2
Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Function CustomScoreProvider

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CustomScoreProvider
public class CustomScoreProvider
Public Class CustomScoreProvider
Public Class CustomScoreProvider
public ref class CustomScoreProvider
public ref class CustomScoreProvider
See Also
CustomScoreProvider Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScoreProvider Members

CustomScoreProvider Members Lucene.Net Class Library

The CustomScoreProvider type exposes the following members.
Constructors
 | Name | Description
Public method | CustomScoreProvider | Creates a new instance of the provider class for the given IndexReader.
Back to Top
Methods
Name Description
Public method CustomExplain(Int32, Explanation, Explanation)
Explain the custom score. Whenever overriding CustomScore(Int32, Single, Single), this method should also be overridden to provide the correct explanation for the part of the custom scoring.
Public method CustomExplain(Int32, Explanation, Explanation )
Explain the custom score. Whenever overriding CustomScore(Int32, Single, Single ), this method should also be overridden to provide the correct explanation for the part of the custom scoring.
Public method CustomScore(Int32, Single, Single)
Compute a custom score by the subQuery score and the ValueSourceQuery score.

Subclasses can override this method to modify the custom score.

If your custom scoring is different than the default herein you should override at least one of the two customScore() methods. If the number of ValueSourceQueries is always < 2 it is sufficient to override this customScore() method, which is simpler.

The default computation herein is a multiplication of the two scores:
                ModifiedScore = subQueryScore * valSrcScore
Public method CustomScore(Int32, Single, Single )
* Compute a custom score by the subQuery score and a number of ValueSourceQuery scores.

Subclasses can override this method to modify the custom score.

If your custom scoring is different than the default herein you should override at least one of the two customScore() methods. If the number of ValueSourceQueries is always < 2 it is sufficient to override the other CustomScore() method, which is simpler.

The default computation herein is a multiplication of given scores:
                ModifiedScore = valSrcScore * valSrcScores[0] * valSrcScores[1] * ...
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | reader |
Back to Top
See Also
CustomScoreProvider Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScoreProvider Constructor

CustomScoreProvider Constructor Lucene.Net Class Library
Creates a new instance of the provider class for the given IndexReader.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CustomScoreProvider(
    IndexReader reader
)
public CustomScoreProvider(
    IndexReader reader
)
Public Sub New ( _
    reader As IndexReader _
)
Public Sub New ( _
    reader As IndexReader _
)
public:
CustomScoreProvider(
    IndexReader^ reader
)
public:
CustomScoreProvider(
    IndexReader^ reader
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
CustomScoreProvider Class
CustomScoreProvider Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScoreProvider Fields

CustomScoreProvider Fields Lucene.Net Class Library
The CustomScoreProvider type exposes the following members.
Fields
 | Name | Description
Protected field | reader |
Back to Top
See Also
CustomScoreProvider Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


reader Field

CustomScoreProvider reader Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IndexReader reader
protected IndexReader reader
Protected reader As IndexReader
Protected reader As IndexReader
protected:
IndexReader^ reader
protected:
IndexReader^ reader
See Also
CustomScoreProvider Class
CustomScoreProvider Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScoreProvider Methods

CustomScoreProvider Methods Lucene.Net Class Library
The CustomScoreProvider type exposes the following members.
Methods
Name Description
Public method CustomExplain(Int32, Explanation, Explanation)
Explain the custom score. Whenever overriding CustomScore(Int32, Single, Single), this method should also be overridden to provide the correct explanation for the part of the custom scoring.
Public method CustomExplain(Int32, Explanation, Explanation )
Explain the custom score. Whenever overriding CustomScore(Int32, Single, Single ), this method should also be overridden to provide the correct explanation for the part of the custom scoring.
Public method CustomScore(Int32, Single, Single)
Compute a custom score by the subQuery score and the ValueSourceQuery score.

Subclasses can override this method to modify the custom score.

If your custom scoring is different than the default herein you should override at least one of the two customScore() methods. If the number of ValueSourceQueries is always < 2 it is sufficient to override this customScore() method, which is simpler.

The default computation herein is a multiplication of the two scores:
                ModifiedScore = subQueryScore * valSrcScore
Public method CustomScore(Int32, Single, Single )
* Compute a custom score by the subQuery score and a number of ValueSourceQuery scores.

Subclasses can override this method to modify the custom score.

If your custom scoring is different than the default herein you should override at least one of the two customScore() methods. If the number of ValueSourceQueries is always < 2 it is sufficient to override the other CustomScore() method, which is simpler.

The default computation herein is a multiplication of given scores:
                ModifiedScore = valSrcScore * valSrcScores[0] * valSrcScores[1] * ...
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
See Also
CustomScoreProvider Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomExplain Method

CustomScoreProvider CustomExplain Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | CustomExplain(Int32, Explanation, Explanation) | Explain the custom score. Whenever overriding CustomScore(Int32, Single, Single), this method should also be overridden to provide the correct explanation for the part of the custom scoring.
Public method | CustomExplain(Int32, Explanation, Explanation ) | Explain the custom score. Whenever overriding CustomScore(Int32, Single, Single ), this method should also be overridden to provide the correct explanation for the part of the custom scoring.
Back to Top
See Also
CustomScoreProvider Class
CustomScoreProvider Members
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomExplain Method (Int32, Explanation, Explanation)

CustomScoreProvider CustomExplain Method (Int32, Explanation, Explanation) Lucene.Net Class Library
Explain the custom score. Whenever overriding CustomScore(Int32, Single, Single), this method should also be overridden to provide the correct explanation for the part of the custom scoring.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Explanation CustomExplain(
    int doc,
    Explanation subQueryExpl,
    Explanation valSrcExpl
)
public virtual Explanation CustomExplain(
    int doc,
    Explanation subQueryExpl,
    Explanation valSrcExpl
)
Public Overridable Function CustomExplain ( _
    doc As Integer, _
    subQueryExpl As Explanation, _
    valSrcExpl As Explanation _
) As Explanation
Public Overridable Function CustomExplain ( _
    doc As Integer, _
    subQueryExpl As Explanation, _
    valSrcExpl As Explanation _
) As Explanation
public:
virtual Explanation^ CustomExplain(
    int doc,
    Explanation^ subQueryExpl,
    Explanation^ valSrcExpl
)
public:
virtual Explanation^ CustomExplain(
    int doc,
    Explanation^ subQueryExpl,
    Explanation^ valSrcExpl
)
Parameters
doc
Type:   Online System Int32
doc being explained
subQueryExpl
Type: Lucene.Net.Search Explanation
explanation for the sub-query part
valSrcExpl
Type: Lucene.Net.Search Explanation
explanation for the value source part
Return Value
an explanation for the custom score
See Also
CustomScoreProvider Class
CustomScoreProvider Members
CustomExplain Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomExplain Method (Int32, Explanation, Explanation[])

CustomScoreProvider CustomExplain Method (Int32, Explanation, Explanation ) Lucene.Net Class Library
Explain the custom score. Whenever overriding CustomScore(Int32, Single, Single ), this method should also be overridden to provide the correct explanation for the part of the custom scoring.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Explanation CustomExplain(
    int doc,
    Explanation subQueryExpl,
    Explanation[] valSrcExpls
)
public virtual Explanation CustomExplain(
    int doc,
    Explanation subQueryExpl,
    Explanation[] valSrcExpls
)
Public Overridable Function CustomExplain ( _
    doc As Integer, _
    subQueryExpl As Explanation, _
    valSrcExpls As Explanation() _
) As Explanation
Public Overridable Function CustomExplain ( _
    doc As Integer, _
    subQueryExpl As Explanation, _
    valSrcExpls As Explanation() _
) As Explanation
public:
virtual Explanation^ CustomExplain(
    int doc,
    Explanation^ subQueryExpl,
    array<Explanation^>^ valSrcExpls
)
public:
virtual Explanation^ CustomExplain(
    int doc,
    Explanation^ subQueryExpl,
    array<Explanation^>^ valSrcExpls
)
Parameters
doc
Type:   Online System Int32
doc being explained
subQueryExpl
Type: Lucene.Net.Search Explanation
explanation for the sub-query part
valSrcExpls
Type:  Lucene.Net.Search Explanation
explanation for the value source part
Return Value
an explanation for the custom score
See Also
CustomScoreProvider Class
CustomScoreProvider Members
CustomExplain Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScore Method

CustomScoreProvider CustomScore Method Lucene.Net Class Library
Overload List
Name Description
Public method CustomScore(Int32, Single, Single)
Compute a custom score by the subQuery score and the ValueSourceQuery score.

Subclasses can override this method to modify the custom score.

If your custom scoring is different than the default herein you should override at least one of the two customScore() methods. If the number of ValueSourceQueries is always < 2 it is sufficient to override this customScore() method, which is simpler.

The default computation herein is a multiplication of the two scores:
                ModifiedScore = subQueryScore * valSrcScore
Public method CustomScore(Int32, Single, Single )
* Compute a custom score by the subQuery score and a number of ValueSourceQuery scores.

Subclasses can override this method to modify the custom score.

If your custom scoring is different than the default herein you should override at least one of the two customScore() methods. If the number of ValueSourceQueries is always < 2 it is sufficient to override the other CustomScore() method, which is simpler.

The default computation herein is a multiplication of given scores:
                ModifiedScore = valSrcScore * valSrcScores[0] * valSrcScores[1] * ...
Back to Top
See Also
CustomScoreProvider Class
CustomScoreProvider Members
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScore Method (Int32, Single, Single)

CustomScoreProvider CustomScore Method (Int32, Single, Single) Lucene.Net Class Library
Compute a custom score by the subQuery score and the ValueSourceQuery score.

Subclasses can override this method to modify the custom score.

If your custom scoring is different than the default herein you should override at least one of the two customScore() methods. If the number of ValueSourceQueries is always < 2 it is sufficient to override this customScore() method, which is simpler.

The default computation herein is a multiplication of the two scores:
                ModifiedScore = subQueryScore * valSrcScore

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual float CustomScore(
    int doc,
    float subQueryScore,
    float valSrcScore
)
public virtual float CustomScore(
    int doc,
    float subQueryScore,
    float valSrcScore
)
Public Overridable Function CustomScore ( _
    doc As Integer, _
    subQueryScore As Single, _
    valSrcScore As Single _
) As Single
Public Overridable Function CustomScore ( _
    doc As Integer, _
    subQueryScore As Single, _
    valSrcScore As Single _
) As Single
public:
virtual float CustomScore(
    int doc,
    float subQueryScore,
    float valSrcScore
)
public:
virtual float CustomScore(
    int doc,
    float subQueryScore,
    float valSrcScore
)
Parameters
doc
Type:   Online System Int32
id of scored doc
subQueryScore
Type:   Online System Single
score of that doc by the subQuery
valSrcScore
Type:   Online System Single
score of that doc by the ValueSourceQuery
Return Value
custom score
See Also
CustomScoreProvider Class
CustomScoreProvider Members
CustomScore Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScore Method (Int32, Single, Single[])

CustomScoreProvider CustomScore Method (Int32, Single, Single ) Lucene.Net Class Library
* Compute a custom score by the subQuery score and a number of ValueSourceQuery scores.

Subclasses can override this method to modify the custom score.

If your custom scoring is different than the default herein you should override at least one of the two customScore() methods. If the number of ValueSourceQueries is always < 2 it is sufficient to override the other CustomScore() method, which is simpler.

The default computation herein is a multiplication of given scores:
                ModifiedScore = valSrcScore * valSrcScores[0] * valSrcScores[1] * ...

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual float CustomScore(
    int doc,
    float subQueryScore,
    float[] valSrcScores
)
public virtual float CustomScore(
    int doc,
    float subQueryScore,
    float[] valSrcScores
)
Public Overridable Function CustomScore ( _
    doc As Integer, _
    subQueryScore As Single, _
    valSrcScores As Single() _
) As Single
Public Overridable Function CustomScore ( _
    doc As Integer, _
    subQueryScore As Single, _
    valSrcScores As Single() _
) As Single
public:
virtual float CustomScore(
    int doc,
    float subQueryScore,
    array<float>^ valSrcScores
)
public:
virtual float CustomScore(
    int doc,
    float subQueryScore,
    array<float>^ valSrcScores
)
Parameters
doc
Type:   Online System Int32
id of scored doc
subQueryScore
Type:   Online System Single
score of that doc by the subQuery
valSrcScores
Type:    Online System Single
scores of that doc by the ValueSourceQuery
Return Value
custom score
See Also
CustomScoreProvider Class
CustomScoreProvider Members
CustomScore Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScoreQuery Class

CustomScoreQuery Class Lucene.Net Class Library
Query that sets document score as a programmatic function of several (sub) scores:
  • the score of its subQuery (any query)
  • (optional) the score of its ValueSourceQuery (or queries). For most simple/convenient use cases this query is likely to be a FieldScoreQuery
Subclasses can modify the computation by overriding GetCustomScoreProvider(IndexReader).

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search.Function CustomScoreQuery

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CustomScoreQuery : Query,
    ICloneable
[SerializableAttribute]
public class CustomScoreQuery : Query,
    ICloneable
<SerializableAttribute> _
Public Class CustomScoreQuery _
    Inherits Query _
    Implements ICloneable
<SerializableAttribute> _
Public Class CustomScoreQuery _
    Inherits Query _
    Implements ICloneable
[SerializableAttribute]
public ref class CustomScoreQuery : public Query,
    ICloneable
[SerializableAttribute]
public ref class CustomScoreQuery : public Query,
    ICloneable
See Also
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScoreQuery Members

CustomScoreQuery Members Lucene.Net Class Library

The CustomScoreQuery type exposes the following members.
Constructors
 | Name | Description
Public method | CustomScoreQuery(Query) | Create a CustomScoreQuery over input subQuery.
Public method | CustomScoreQuery(Query, ValueSourceQuery) | Create a CustomScoreQuery over input subQuery and a ValueSourceQuery.
Public method | CustomScoreQuery(Query, ValueSourceQuery ) | Create a CustomScoreQuery over input subQuery and a ValueSourceQuery.
Back to Top
Methods
 | Name | Description
Public method | Clone | (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | CustomExplain(Int32, Explanation, Explanation) | Obsolete. Explain the custom score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override GetCustomScoreProvider(IndexReader) and return a subclass of CustomScoreProvider for the given IndexReader.
Public method | CustomExplain(Int32, Explanation, Explanation ) | Obsolete. Explain the custom score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override GetCustomScoreProvider(IndexReader) and return a subclass of CustomScoreProvider for the given IndexReader.
Public method | CustomScore(Int32, Single, Single) | Obsolete. Compute a custom score by the subQuery score and the ValueSourceQuery score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override GetCustomScoreProvider(IndexReader) and return a subclass of CustomScoreProvider for the given IndexReader.
Public method | CustomScore(Int32, Single, Single ) | Obsolete. Compute a custom score by the subQuery score and a number of ValueSourceQuery scores. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override GetCustomScoreProvider(IndexReader) and return a subclass of CustomScoreProvider for the given IndexReader. see CustomScoreProvider#customScore(int,float,float[])
Public method | Equals | Returns true if o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetCustomScoreProvider | Returns a CustomScoreProvider that calculates the custom scores for the given IndexReader. The default implementation returns a default implementation as specified in the docs of CustomScoreProvider.
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsStrict | Checks if this is strict custom scoring. In strict custom scoring, the ValueSource part does not participate in weight normalization. This may be useful when one wants full control over how scores are modified, and does not care about normalizing by the ValueSource part. One particular case where this is useful if for testing this query. Note: only has effect when the ValueSource part is not null.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Name | A short name of this query, used in ToString(String).
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | SetStrict | Set the strict mode of this query.
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Back to Top
See Also
CustomScoreQuery Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScoreQuery Constructor

CustomScoreQuery Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | CustomScoreQuery(Query) | Create a CustomScoreQuery over input subQuery.
Public method | CustomScoreQuery(Query, ValueSourceQuery) | Create a CustomScoreQuery over input subQuery and a ValueSourceQuery.
Public method | CustomScoreQuery(Query, ValueSourceQuery ) | Create a CustomScoreQuery over input subQuery and a ValueSourceQuery.
Back to Top
See Also
CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScoreQuery Constructor (Query)

CustomScoreQuery Constructor (Query) Lucene.Net Class Library
Create a CustomScoreQuery over input subQuery.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CustomScoreQuery(
    Query subQuery
)
public CustomScoreQuery(
    Query subQuery
)
Public Sub New ( _
    subQuery As Query _
)
Public Sub New ( _
    subQuery As Query _
)
public:
CustomScoreQuery(
    Query^ subQuery
)
public:
CustomScoreQuery(
    Query^ subQuery
)
Parameters
subQuery
Type: Lucene.Net.Search Query
the sub query whose scored is being customed. Must not be null.

See Also
CustomScoreQuery Class
CustomScoreQuery Members
CustomScoreQuery Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScoreQuery Constructor (Query, ValueSourceQuery)

CustomScoreQuery Constructor (Query, ValueSourceQuery) Lucene.Net Class Library
Create a CustomScoreQuery over input subQuery and a ValueSourceQuery.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CustomScoreQuery(
    Query subQuery,
    ValueSourceQuery valSrcQuery
)
public CustomScoreQuery(
    Query subQuery,
    ValueSourceQuery valSrcQuery
)
Public Sub New ( _
    subQuery As Query, _
    valSrcQuery As ValueSourceQuery _
)
Public Sub New ( _
    subQuery As Query, _
    valSrcQuery As ValueSourceQuery _
)
public:
CustomScoreQuery(
    Query^ subQuery,
    ValueSourceQuery^ valSrcQuery
)
public:
CustomScoreQuery(
    Query^ subQuery,
    ValueSourceQuery^ valSrcQuery
)
Parameters
subQuery
Type: Lucene.Net.Search Query
the sub query whose score is being customed. Must not be null.

valSrcQuery
Type: Lucene.Net.Search.Function ValueSourceQuery
a value source query whose scores are used in the custom score
            computation. For most simple/convineient use case this would be a
            FieldScoreQuery.
            This parameter is optional - it can be null or even an empty array.

See Also
CustomScoreQuery Class
CustomScoreQuery Members
CustomScoreQuery Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScoreQuery Constructor (Query, ValueSourceQuery[])

CustomScoreQuery Constructor (Query, ValueSourceQuery ) Lucene.Net Class Library
Create a CustomScoreQuery over input subQuery and a ValueSourceQuery.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CustomScoreQuery(
    Query subQuery,
    params ValueSourceQuery[] valSrcQueries
)
public CustomScoreQuery(
    Query subQuery,
    params ValueSourceQuery[] valSrcQueries
)
Public Sub New ( _
    subQuery As Query, _
    ParamArray valSrcQueries As ValueSourceQuery() _
)
Public Sub New ( _
    subQuery As Query, _
    ParamArray valSrcQueries As ValueSourceQuery() _
)
public:
CustomScoreQuery(
    Query^ subQuery,
    ... array<ValueSourceQuery^>^ valSrcQueries
)
public:
CustomScoreQuery(
    Query^ subQuery,
    ... array<ValueSourceQuery^>^ valSrcQueries
)
Parameters
subQuery
Type: Lucene.Net.Search Query
the sub query whose score is being customized. Must not be null.

valSrcQueries
Type:  Lucene.Net.Search.Function ValueSourceQuery
value source queries whose scores are used in the custom score
            computation. For most simple/convenient use case these would be
            FieldScoreQueries.
            This parameter is optional - it can be null or even an empty array.

See Also
CustomScoreQuery Class
CustomScoreQuery Members
CustomScoreQuery Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScoreQuery Methods

CustomScoreQuery Methods Lucene.Net Class Library
The CustomScoreQuery type exposes the following members.
Methods
 | Name | Description
Public method | Clone | (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | CustomExplain(Int32, Explanation, Explanation) | Obsolete. Explain the custom score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override GetCustomScoreProvider(IndexReader) and return a subclass of CustomScoreProvider for the given IndexReader.
Public method | CustomExplain(Int32, Explanation, Explanation ) | Obsolete. Explain the custom score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override GetCustomScoreProvider(IndexReader) and return a subclass of CustomScoreProvider for the given IndexReader.
Public method | CustomScore(Int32, Single, Single) | Obsolete. Compute a custom score by the subQuery score and the ValueSourceQuery score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override GetCustomScoreProvider(IndexReader) and return a subclass of CustomScoreProvider for the given IndexReader.
Public method | CustomScore(Int32, Single, Single ) | Obsolete. Compute a custom score by the subQuery score and a number of ValueSourceQuery scores. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override GetCustomScoreProvider(IndexReader) and return a subclass of CustomScoreProvider for the given IndexReader. see CustomScoreProvider#customScore(int,float,float[])
Public method | Equals | Returns true if o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetCustomScoreProvider | Returns a CustomScoreProvider that calculates the custom scores for the given IndexReader. The default implementation returns a default implementation as specified in the docs of CustomScoreProvider.
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsStrict | Checks if this is strict custom scoring. In strict custom scoring, the ValueSource part does not participate in weight normalization. This may be useful when one wants full control over how scores are modified, and does not care about normalizing by the ValueSource part. One particular case where this is useful if for testing this query. Note: only has effect when the ValueSource part is not null.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Name | A short name of this query, used in ToString(String).
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | SetStrict | Set the strict mode of this query.
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
CustomScoreQuery Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

CustomScoreQuery Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateWeight Method

CustomScoreQuery CreateWeight Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Weight CreateWeight(
    Searcher searcher
)
public override Weight CreateWeight(
    Searcher searcher
)
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomExplain Method

CustomScoreQuery CustomExplain Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | CustomExplain(Int32, Explanation, Explanation) | Obsolete. Explain the custom score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override GetCustomScoreProvider(IndexReader) and return a subclass of CustomScoreProvider for the given IndexReader.
Public method | CustomExplain(Int32, Explanation, Explanation ) | Obsolete. Explain the custom score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override GetCustomScoreProvider(IndexReader) and return a subclass of CustomScoreProvider for the given IndexReader.
Back to Top
See Also
CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomExplain Method (Int32, Explanation, Explanation)

CustomScoreQuery CustomExplain Method (Int32, Explanation, Explanation) Lucene.Net Class Library
Explain the custom score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override GetCustomScoreProvider(IndexReader) and return a subclass of CustomScoreProvider for the given IndexReader.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Will be removed in Lucene 3.1")]
public virtual Explanation CustomExplain(
    int doc,
    Explanation subQueryExpl,
    Explanation valSrcExpl
)
[ObsoleteAttribute("Will be removed in Lucene 3.1")]
public virtual Explanation CustomExplain(
    int doc,
    Explanation subQueryExpl,
    Explanation valSrcExpl
)
<ObsoleteAttribute("Will be removed in Lucene 3.1")> _
Public Overridable Function CustomExplain ( _
    doc As Integer, _
    subQueryExpl As Explanation, _
    valSrcExpl As Explanation _
) As Explanation
<ObsoleteAttribute("Will be removed in Lucene 3.1")> _
Public Overridable Function CustomExplain ( _
    doc As Integer, _
    subQueryExpl As Explanation, _
    valSrcExpl As Explanation _
) As Explanation
public:
[ObsoleteAttribute(L"Will be removed in Lucene 3.1")]
virtual Explanation^ CustomExplain(
    int doc,
    Explanation^ subQueryExpl,
    Explanation^ valSrcExpl
)
public:
[ObsoleteAttribute(L"Will be removed in Lucene 3.1")]
virtual Explanation^ CustomExplain(
    int doc,
    Explanation^ subQueryExpl,
    Explanation^ valSrcExpl
)
Parameters
doc
Type:   Online System Int32
subQueryExpl
Type: Lucene.Net.Search Explanation
valSrcExpl
Type: Lucene.Net.Search Explanation
See Also
CustomScoreQuery Class
CustomScoreQuery Members
CustomExplain Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomExplain Method (Int32, Explanation, Explanation[])

CustomScoreQuery CustomExplain Method (Int32, Explanation, Explanation ) Lucene.Net Class Library
Explain the custom score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override GetCustomScoreProvider(IndexReader) and return a subclass of CustomScoreProvider for the given IndexReader.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Will be removed in Lucene 3.1")]
public virtual Explanation CustomExplain(
    int doc,
    Explanation subQueryExpl,
    Explanation[] valSrcExpls
)
[ObsoleteAttribute("Will be removed in Lucene 3.1")]
public virtual Explanation CustomExplain(
    int doc,
    Explanation subQueryExpl,
    Explanation[] valSrcExpls
)
<ObsoleteAttribute("Will be removed in Lucene 3.1")> _
Public Overridable Function CustomExplain ( _
    doc As Integer, _
    subQueryExpl As Explanation, _
    valSrcExpls As Explanation() _
) As Explanation
<ObsoleteAttribute("Will be removed in Lucene 3.1")> _
Public Overridable Function CustomExplain ( _
    doc As Integer, _
    subQueryExpl As Explanation, _
    valSrcExpls As Explanation() _
) As Explanation
public:
[ObsoleteAttribute(L"Will be removed in Lucene 3.1")]
virtual Explanation^ CustomExplain(
    int doc,
    Explanation^ subQueryExpl,
    array<Explanation^>^ valSrcExpls
)
public:
[ObsoleteAttribute(L"Will be removed in Lucene 3.1")]
virtual Explanation^ CustomExplain(
    int doc,
    Explanation^ subQueryExpl,
    array<Explanation^>^ valSrcExpls
)
Parameters
doc
Type:   Online System Int32
subQueryExpl
Type: Lucene.Net.Search Explanation
valSrcExpls
Type:  Lucene.Net.Search Explanation
See Also
CustomScoreQuery Class
CustomScoreQuery Members
CustomExplain Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScore Method

CustomScoreQuery CustomScore Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | CustomScore(Int32, Single, Single) | Obsolete. Compute a custom score by the subQuery score and the ValueSourceQuery score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override GetCustomScoreProvider(IndexReader) and return a subclass of CustomScoreProvider for the given IndexReader.
Public method | CustomScore(Int32, Single, Single ) | Obsolete. Compute a custom score by the subQuery score and a number of ValueSourceQuery scores. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override GetCustomScoreProvider(IndexReader) and return a subclass of CustomScoreProvider for the given IndexReader. see CustomScoreProvider#customScore(int,float,float[])
Back to Top
See Also
CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScore Method (Int32, Single, Single)

CustomScoreQuery CustomScore Method (Int32, Single, Single) Lucene.Net Class Library
Compute a custom score by the subQuery score and the ValueSourceQuery score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override GetCustomScoreProvider(IndexReader) and return a subclass of CustomScoreProvider for the given IndexReader.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Will be removed in Lucene 3.1")]
public virtual float CustomScore(
    int doc,
    float subQueryScore,
    float valSrcScore
)
[ObsoleteAttribute("Will be removed in Lucene 3.1")]
public virtual float CustomScore(
    int doc,
    float subQueryScore,
    float valSrcScore
)
<ObsoleteAttribute("Will be removed in Lucene 3.1")> _
Public Overridable Function CustomScore ( _
    doc As Integer, _
    subQueryScore As Single, _
    valSrcScore As Single _
) As Single
<ObsoleteAttribute("Will be removed in Lucene 3.1")> _
Public Overridable Function CustomScore ( _
    doc As Integer, _
    subQueryScore As Single, _
    valSrcScore As Single _
) As Single
public:
[ObsoleteAttribute(L"Will be removed in Lucene 3.1")]
virtual float CustomScore(
    int doc,
    float subQueryScore,
    float valSrcScore
)
public:
[ObsoleteAttribute(L"Will be removed in Lucene 3.1")]
virtual float CustomScore(
    int doc,
    float subQueryScore,
    float valSrcScore
)
Parameters
doc
Type:   Online System Int32
subQueryScore
Type:   Online System Single
valSrcScore
Type:   Online System Single
See Also
CustomScoreQuery Class
CustomScoreQuery Members
CustomScore Overload
Lucene.Net.Search.Function Namespace
CustomScoreProvider CustomScore(Int32, Single, Single)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScore Method (Int32, Single, Single[])

CustomScoreQuery CustomScore Method (Int32, Single, Single ) Lucene.Net Class Library
Compute a custom score by the subQuery score and a number of ValueSourceQuery scores. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override GetCustomScoreProvider(IndexReader) and return a subclass of CustomScoreProvider for the given IndexReader. see CustomScoreProvider#customScore(int,float,float[])

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Will be removed in Lucene 3.1")]
public virtual float CustomScore(
    int doc,
    float subQueryScore,
    float[] valSrcScores
)
[ObsoleteAttribute("Will be removed in Lucene 3.1")]
public virtual float CustomScore(
    int doc,
    float subQueryScore,
    float[] valSrcScores
)
<ObsoleteAttribute("Will be removed in Lucene 3.1")> _
Public Overridable Function CustomScore ( _
    doc As Integer, _
    subQueryScore As Single, _
    valSrcScores As Single() _
) As Single
<ObsoleteAttribute("Will be removed in Lucene 3.1")> _
Public Overridable Function CustomScore ( _
    doc As Integer, _
    subQueryScore As Single, _
    valSrcScores As Single() _
) As Single
public:
[ObsoleteAttribute(L"Will be removed in Lucene 3.1")]
virtual float CustomScore(
    int doc,
    float subQueryScore,
    array<float>^ valSrcScores
)
public:
[ObsoleteAttribute(L"Will be removed in Lucene 3.1")]
virtual float CustomScore(
    int doc,
    float subQueryScore,
    array<float>^ valSrcScores
)
Parameters
doc
Type:   Online System Int32
subQueryScore
Type:   Online System Single
valSrcScores
Type:    Online System Single
See Also
CustomScoreQuery Class
CustomScoreQuery Members
CustomScore Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

CustomScoreQuery Equals Method Lucene.Net Class Library
Returns true if o is equal to this.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExtractTerms Method

CustomScoreQuery ExtractTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ExtractTerms(
    ISet<Term> terms
)
public override void ExtractTerms(
    ISet<Term> terms
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
Parameters
terms
Type:   Online System.Collections.Generic ISet  Term
See Also
CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCustomScoreProvider Method

CustomScoreQuery GetCustomScoreProvider Method Lucene.Net Class Library
Returns a CustomScoreProvider that calculates the custom scores for the given IndexReader. The default implementation returns a default implementation as specified in the docs of CustomScoreProvider.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual CustomScoreProvider GetCustomScoreProvider(
    IndexReader reader
)
protected virtual CustomScoreProvider GetCustomScoreProvider(
    IndexReader reader
)
Protected Overridable Function GetCustomScoreProvider ( _
    reader As IndexReader _
) As CustomScoreProvider
Protected Overridable Function GetCustomScoreProvider ( _
    reader As IndexReader _
) As CustomScoreProvider
protected:
virtual CustomScoreProvider^ GetCustomScoreProvider(
    IndexReader^ reader
)
protected:
virtual CustomScoreProvider^ GetCustomScoreProvider(
    IndexReader^ reader
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

CustomScoreQuery GetHashCode Method Lucene.Net Class Library
Returns a hash code value for this object.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsStrict Method

CustomScoreQuery IsStrict Method Lucene.Net Class Library
Checks if this is strict custom scoring. In strict custom scoring, the ValueSource part does not participate in weight normalization. This may be useful when one wants full control over how scores are modified, and does not care about normalizing by the ValueSource part. One particular case where this is useful if for testing this query.

Note: only has effect when the ValueSource part is not null.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsStrict()
public virtual bool IsStrict()
Public Overridable Function IsStrict As Boolean
Public Overridable Function IsStrict As Boolean
public:
virtual bool IsStrict()
public:
virtual bool IsStrict()
See Also
CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Name Method

CustomScoreQuery Name Method Lucene.Net Class Library
A short name of this query, used in ToString(String).

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Name()
public virtual string Name()
Public Overridable Function Name As String
Public Overridable Function Name As String
public:
virtual String^ Name()
public:
virtual String^ Name()
See Also
CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

CustomScoreQuery Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    IndexReader reader
)
public override Query Rewrite(
    IndexReader reader
)
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetStrict Method

CustomScoreQuery SetStrict Method Lucene.Net Class Library
Set the strict mode of this query.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetStrict(
    bool strict
)
public virtual void SetStrict(
    bool strict
)
Public Overridable Sub SetStrict ( _
    strict As Boolean _
)
Public Overridable Sub SetStrict ( _
    strict As Boolean _
)
public:
virtual void SetStrict(
    bool strict
)
public:
virtual void SetStrict(
    bool strict
)
Parameters
strict
Type:   Online System Boolean
The strict mode to set.

See Also
CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace
CustomScoreQuery IsStrict
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

CustomScoreQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Back to Top
See Also
CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

CustomScoreQuery ToString Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
CustomScoreQuery Class
CustomScoreQuery Members
ToString Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CustomScoreQuery Properties

CustomScoreQuery Properties Lucene.Net Class Library
The CustomScoreQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Back to Top
See Also
CustomScoreQuery Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocValues Class

DocValues Class Lucene.Net Class Library
Expert: represents field values as different types. Normally created via a ValueSuorce for a particular field and reader.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Function DocValues

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class DocValues
public abstract class DocValues
Public MustInherit Class DocValues
Public MustInherit Class DocValues
public ref class DocValues abstract
public ref class DocValues abstract
See Also
DocValues Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocValues Members

DocValues Members Lucene.Net Class Library

The DocValues type exposes the following members.
Constructors
 | Name | Description
Protected method | DocValues | Initializes a new instance of the DocValues class
Back to Top
Methods
 | Name | Description
Public method | DoubleVal | Return doc value as a double. Optional: DocValues implementation can (but don't have to) override this method.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | Explain the scoring value for the input doc.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FloatVal | Return doc value as a float. Mandatory: every DocValues implementation must implement at least this method.
Public method | GetAverageValue | Returns the average of all values or Float.NaN if this DocValues instance does not contain any value. * This operation is optional
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetMaxValue | Returns the maximum of all values or Float.NaN if this DocValues instance does not contain any value. This operation is optional
Public method | GetMinValue | Returns the minimum of all values or Float.NaN if this DocValues instance does not contain any value. This operation is optional
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IntVal | Return doc value as an int. Optional: DocValues implementation can (but don't have to) override this method.
Public method | LongVal | Return doc value as a long. Optional: DocValues implementation can (but don't have to) override this method.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | StrVal | Return doc value as a string. Optional: DocValues implementation can (but don't have to) override this method.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | ToString(Int32) | Return a string representation of a doc value, as reuired for Explanations.
Back to Top
Properties
Name Description
Protected property InnerArray
Expert: for test purposes only, return the inner array of values, or null if not applicable.

Allows tests to verify that loaded values are:
  • indeed cached/reused.
  • stored in the expected size/type (byte/short/int/float).
Note: implementations of DocValues must override this method for these test elements to be tested, Otherwise the test would not fail, just print a warning.
Back to Top
See Also
DocValues Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocValues Constructor

DocValues Constructor Lucene.Net Class Library
Initializes a new instance of the DocValues class

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DocValues()
protected DocValues()
Protected Sub New
Protected Sub New
protected:
DocValues()
protected:
DocValues()
See Also
DocValues Class
DocValues Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocValues Methods

DocValues Methods Lucene.Net Class Library
The DocValues type exposes the following members.
Methods
 | Name | Description
Public method | DoubleVal | Return doc value as a double. Optional: DocValues implementation can (but don't have to) override this method.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | Explain the scoring value for the input doc.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FloatVal | Return doc value as a float. Mandatory: every DocValues implementation must implement at least this method.
Public method | GetAverageValue | Returns the average of all values or Float.NaN if this DocValues instance does not contain any value. * This operation is optional
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetMaxValue | Returns the maximum of all values or Float.NaN if this DocValues instance does not contain any value. This operation is optional
Public method | GetMinValue | Returns the minimum of all values or Float.NaN if this DocValues instance does not contain any value. This operation is optional
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IntVal | Return doc value as an int. Optional: DocValues implementation can (but don't have to) override this method.
Public method | LongVal | Return doc value as a long. Optional: DocValues implementation can (but don't have to) override this method.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | StrVal | Return doc value as a string. Optional: DocValues implementation can (but don't have to) override this method.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | ToString(Int32) | Return a string representation of a doc value, as reuired for Explanations.
Back to Top
See Also
DocValues Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoubleVal Method

DocValues DoubleVal Method Lucene.Net Class Library
Return doc value as a double.

Optional: DocValues implementation can (but don't have to) override this method.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual double DoubleVal(
    int doc
)
public virtual double DoubleVal(
    int doc
)
Public Overridable Function DoubleVal ( _
    doc As Integer _
) As Double
Public Overridable Function DoubleVal ( _
    doc As Integer _
) As Double
public:
virtual double DoubleVal(
    int doc
)
public:
virtual double DoubleVal(
    int doc
)
Parameters
doc
Type:   Online System Int32
document whose double value is requested.

See Also
DocValues Class
DocValues Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method

DocValues Explain Method Lucene.Net Class Library
Explain the scoring value for the input doc.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Explanation Explain(
    int doc
)
public virtual Explanation Explain(
    int doc
)
Public Overridable Function Explain ( _
    doc As Integer _
) As Explanation
Public Overridable Function Explain ( _
    doc As Integer _
) As Explanation
public:
virtual Explanation^ Explain(
    int doc
)
public:
virtual Explanation^ Explain(
    int doc
)
Parameters
doc
Type:   Online System Int32
See Also
DocValues Class
DocValues Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FloatVal Method

DocValues FloatVal Method Lucene.Net Class Library
Return doc value as a float.

Mandatory: every DocValues implementation must implement at least this method.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract float FloatVal(
    int doc
)
public abstract float FloatVal(
    int doc
)
Public MustOverride Function FloatVal ( _
    doc As Integer _
) As Single
Public MustOverride Function FloatVal ( _
    doc As Integer _
) As Single
public:
virtual float FloatVal(
    int doc
) abstract
public:
virtual float FloatVal(
    int doc
) abstract
Parameters
doc
Type:   Online System Int32
document whose float value is requested.

See Also
DocValues Class
DocValues Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetAverageValue Method

DocValues GetAverageValue Method Lucene.Net Class Library
Returns the average of all values or Float.NaN if this DocValues instance does not contain any value. *

This operation is optional

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual float GetAverageValue()
public virtual float GetAverageValue()
Public Overridable Function GetAverageValue As Single
Public Overridable Function GetAverageValue As Single
public:
virtual float GetAverageValue()
public:
virtual float GetAverageValue()
Return Value
 the average of all values or Float.NaN if this
            DocValues instance does not contain any value

See Also
DocValues Class
DocValues Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetMaxValue Method

DocValues GetMaxValue Method Lucene.Net Class Library
Returns the maximum of all values or Float.NaN if this DocValues instance does not contain any value.

This operation is optional

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual float GetMaxValue()
public virtual float GetMaxValue()
Public Overridable Function GetMaxValue As Single
Public Overridable Function GetMaxValue As Single
public:
virtual float GetMaxValue()
public:
virtual float GetMaxValue()
Return Value
 the maximum of all values or Float.NaN if this
            DocValues instance does not contain any value.

See Also
DocValues Class
DocValues Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetMinValue Method

DocValues GetMinValue Method Lucene.Net Class Library
Returns the minimum of all values or Float.NaN if this DocValues instance does not contain any value.

This operation is optional

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual float GetMinValue()
public virtual float GetMinValue()
Public Overridable Function GetMinValue As Single
Public Overridable Function GetMinValue As Single
public:
virtual float GetMinValue()
public:
virtual float GetMinValue()
Return Value
 the minimum of all values or Float.NaN if this
            DocValues instance does not contain any value.

See Also
DocValues Class
DocValues Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IntVal Method

DocValues IntVal Method Lucene.Net Class Library
Return doc value as an int.

Optional: DocValues implementation can (but don't have to) override this method.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int IntVal(
    int doc
)
public virtual int IntVal(
    int doc
)
Public Overridable Function IntVal ( _
    doc As Integer _
) As Integer
Public Overridable Function IntVal ( _
    doc As Integer _
) As Integer
public:
virtual int IntVal(
    int doc
)
public:
virtual int IntVal(
    int doc
)
Parameters
doc
Type:   Online System Int32
document whose int value is requested.

See Also
DocValues Class
DocValues Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LongVal Method

DocValues LongVal Method Lucene.Net Class Library
Return doc value as a long.

Optional: DocValues implementation can (but don't have to) override this method.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long LongVal(
    int doc
)
public virtual long LongVal(
    int doc
)
Public Overridable Function LongVal ( _
    doc As Integer _
) As Long
Public Overridable Function LongVal ( _
    doc As Integer _
) As Long
public:
virtual long long LongVal(
    int doc
)
public:
virtual long long LongVal(
    int doc
)
Parameters
doc
Type:   Online System Int32
document whose long value is requested.

See Also
DocValues Class
DocValues Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StrVal Method

DocValues StrVal Method Lucene.Net Class Library
Return doc value as a string.

Optional: DocValues implementation can (but don't have to) override this method.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string StrVal(
    int doc
)
public virtual string StrVal(
    int doc
)
Public Overridable Function StrVal ( _
    doc As Integer _
) As String
Public Overridable Function StrVal ( _
    doc As Integer _
) As String
public:
virtual String^ StrVal(
    int doc
)
public:
virtual String^ StrVal(
    int doc
)
Parameters
doc
Type:   Online System Int32
document whose string value is requested.

See Also
DocValues Class
DocValues Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

DocValues ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | ToString(Int32) | Return a string representation of a doc value, as reuired for Explanations.
Back to Top
See Also
DocValues Class
DocValues Members
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (Int32)

DocValues ToString Method (Int32) Lucene.Net Class Library
Return a string representation of a doc value, as reuired for Explanations.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string ToString(
    int doc
)
public abstract string ToString(
    int doc
)
Public MustOverride Function ToString ( _
    doc As Integer _
) As String
Public MustOverride Function ToString ( _
    doc As Integer _
) As String
public:
virtual String^ ToString(
    int doc
) abstract
public:
virtual String^ ToString(
    int doc
) abstract
Parameters
doc
Type:   Online System Int32
See Also
DocValues Class
DocValues Members
ToString Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocValues Properties

DocValues Properties Lucene.Net Class Library
The DocValues type exposes the following members.
Properties
Name Description
Protected property InnerArray
Expert: for test purposes only, return the inner array of values, or null if not applicable.

Allows tests to verify that loaded values are:
  • indeed cached/reused.
  • stored in the expected size/type (byte/short/int/float).
Note: implementations of DocValues must override this method for these test elements to be tested, Otherwise the test would not fail, just print a warning.
Back to Top
See Also
DocValues Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


InnerArray Property

DocValues InnerArray Property Lucene.Net Class Library
Expert: for test purposes only, return the inner array of values, or null if not applicable.

Allows tests to verify that loaded values are:
  • indeed cached/reused.
  • stored in the expected size/type (byte/short/int/float).
Note: implementations of DocValues must override this method for these test elements to be tested, Otherwise the test would not fail, just print a warning.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Object InnerArray { get; }
protected virtual Object InnerArray { get; }
Protected Overridable ReadOnly Property InnerArray As Object
    Get
Protected Overridable ReadOnly Property InnerArray As Object
    Get
protected:
virtual property Object^ InnerArray {
    Object^ get ();
}
protected:
virtual property Object^ InnerArray {
    Object^ get ();
}
See Also
DocValues Class
DocValues Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheSource Class

FieldCacheSource Class Lucene.Net Class Library
Expert: A base class for ValueSource implementations that retrieve values for a single field from the FieldCache.

Fields used herein nust be indexed (doesn't matter if these fields are stored or not).

It is assumed that each such indexed field is untokenized, or at least has a single token in a document. For documents with multiple tokens of the same field, behavior is undefined (It is likely that current code would use the value of one of these tokens, but this is not guaranteed).

Document with no tokens in this field are assigned the Zero value.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

NOTE: with the switch in 2.9 to segment-based searching, if GetValues(IndexReader) is invoked with a composite (multi-segment) reader, this can easily cause double RAM usage for the values in the FieldCache. It's best to switch your application to pass only atomic (single segment) readers to this API.

Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Function ValueSource
Lucene.Net.Search.Function FieldCacheSource
Lucene.Net.Search.Function ByteFieldSource
Lucene.Net.Search.Function FloatFieldSource
Lucene.Net.Search.Function IntFieldSource
Lucene.Net.Search.Function ShortFieldSource

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class FieldCacheSource : ValueSource
[SerializableAttribute]
public abstract class FieldCacheSource : ValueSource
<SerializableAttribute> _
Public MustInherit Class FieldCacheSource _
    Inherits ValueSource
<SerializableAttribute> _
Public MustInherit Class FieldCacheSource _
    Inherits ValueSource
[SerializableAttribute]
public ref class FieldCacheSource abstract : public ValueSource
[SerializableAttribute]
public ref class FieldCacheSource abstract : public ValueSource
See Also
FieldCacheSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheSource Members

FieldCacheSource Members Lucene.Net Class Library

The FieldCacheSource type exposes the following members.
Constructors
 | Name | Description
Protected method | FieldCacheSource | Create a cached field source for the input field.
Back to Top
Methods
 | Name | Description
Public method | CachedFieldSourceEquals | Check if equals to another FieldCacheSource, already knowing that cache and field are equal.
Public method | CachedFieldSourceHashCode | Return a hash code of a FieldCacheSource, without the hash-codes of the field and the cache (those are taken care of elsewhere).
Public method | Description | (Overrides ValueSource Description .)
Public method | Equals | (Overrides ValueSource Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetCachedFieldValues | Return cached DocValues for input field and reader.
Public method | GetHashCode | (Overrides ValueSource GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | (Overrides ValueSource GetValues(IndexReader).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from ValueSource.)
Back to Top
See Also
FieldCacheSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheSource Constructor

FieldCacheSource Constructor Lucene.Net Class Library
Create a cached field source for the input field.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FieldCacheSource(
    string field
)
protected FieldCacheSource(
    string field
)
Protected Sub New ( _
    field As String _
)
Protected Sub New ( _
    field As String _
)
protected:
FieldCacheSource(
    String^ field
)
protected:
FieldCacheSource(
    String^ field
)
Parameters
field
Type:   Online System String
See Also
FieldCacheSource Class
FieldCacheSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheSource Methods

FieldCacheSource Methods Lucene.Net Class Library
The FieldCacheSource type exposes the following members.
Methods
 | Name | Description
Public method | CachedFieldSourceEquals | Check if equals to another FieldCacheSource, already knowing that cache and field are equal.
Public method | CachedFieldSourceHashCode | Return a hash code of a FieldCacheSource, without the hash-codes of the field and the cache (those are taken care of elsewhere).
Public method | Description | (Overrides ValueSource Description .)
Public method | Equals | (Overrides ValueSource Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetCachedFieldValues | Return cached DocValues for input field and reader.
Public method | GetHashCode | (Overrides ValueSource GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | (Overrides ValueSource GetValues(IndexReader).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from ValueSource.)
Back to Top
See Also
FieldCacheSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachedFieldSourceEquals Method

FieldCacheSource CachedFieldSourceEquals Method Lucene.Net Class Library
Check if equals to another FieldCacheSource, already knowing that cache and field are equal.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool CachedFieldSourceEquals(
    FieldCacheSource other
)
public abstract bool CachedFieldSourceEquals(
    FieldCacheSource other
)
Public MustOverride Function CachedFieldSourceEquals ( _
    other As FieldCacheSource _
) As Boolean
Public MustOverride Function CachedFieldSourceEquals ( _
    other As FieldCacheSource _
) As Boolean
public:
virtual bool CachedFieldSourceEquals(
    FieldCacheSource^ other
) abstract
public:
virtual bool CachedFieldSourceEquals(
    FieldCacheSource^ other
) abstract
Parameters
other
Type: Lucene.Net.Search.Function FieldCacheSource
See Also
FieldCacheSource Class
FieldCacheSource Members
Lucene.Net.Search.Function Namespace
  Online Object Equals(Object)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachedFieldSourceHashCode Method

FieldCacheSource CachedFieldSourceHashCode Method Lucene.Net Class Library
Return a hash code of a FieldCacheSource, without the hash-codes of the field and the cache (those are taken care of elsewhere).

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int CachedFieldSourceHashCode()
public abstract int CachedFieldSourceHashCode()
Public MustOverride Function CachedFieldSourceHashCode As Integer
Public MustOverride Function CachedFieldSourceHashCode As Integer
public:
virtual int CachedFieldSourceHashCode() abstract
public:
virtual int CachedFieldSourceHashCode() abstract
See Also
FieldCacheSource Class
FieldCacheSource Members
Lucene.Net.Search.Function Namespace
  Online Object GetHashCode
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Description Method

FieldCacheSource Description Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description()
public override string Description()
Public Overrides Function Description As String
Public Overrides Function Description As String
public:
virtual String^ Description() override
public:
virtual String^ Description() override
See Also
FieldCacheSource Class
FieldCacheSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

FieldCacheSource Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
FieldCacheSource Class
FieldCacheSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCachedFieldValues Method

FieldCacheSource GetCachedFieldValues Method Lucene.Net Class Library
Return cached DocValues for input field and reader.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract DocValues GetCachedFieldValues(
    FieldCache cache,
    string field,
    IndexReader reader
)
public abstract DocValues GetCachedFieldValues(
    FieldCache cache,
    string field,
    IndexReader reader
)
Public MustOverride Function GetCachedFieldValues ( _
    cache As FieldCache, _
    field As String, _
    reader As IndexReader _
) As DocValues
Public MustOverride Function GetCachedFieldValues ( _
    cache As FieldCache, _
    field As String, _
    reader As IndexReader _
) As DocValues
public:
virtual DocValues^ GetCachedFieldValues(
    FieldCache^ cache,
    String^ field,
    IndexReader^ reader
) abstract
public:
virtual DocValues^ GetCachedFieldValues(
    FieldCache^ cache,
    String^ field,
    IndexReader^ reader
) abstract
Parameters
cache
Type: Lucene.Net.Search FieldCache
FieldCache so that values of a field are loaded once per reader (RAM allowing)

field
Type:   Online System String
Field for which values are required.

reader
Type: Lucene.Net.Index IndexReader
See Also
FieldCacheSource Class
FieldCacheSource Members
Lucene.Net.Search.Function Namespace
Lucene.Net.Search.Function ValueSource
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

FieldCacheSource GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
FieldCacheSource Class
FieldCacheSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetValues Method

FieldCacheSource GetValues Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocValues GetValues(
    IndexReader reader
)
public override DocValues GetValues(
    IndexReader reader
)
Public Overrides Function GetValues ( _
    reader As IndexReader _
) As DocValues
Public Overrides Function GetValues ( _
    reader As IndexReader _
) As DocValues
public:
virtual DocValues^ GetValues(
    IndexReader^ reader
) override
public:
virtual DocValues^ GetValues(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
FieldCacheSource Class
FieldCacheSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldScoreQuery Class

FieldScoreQuery Class Lucene.Net Class Library
A query that scores each document as the value of the numeric input field.

The query matches all documents, and scores each document according to the numeric value of that field.

It is assumed, and expected, that:
  • The field used here is indexed, and has exactly one token in every scored document.
  • Best if this field is un_tokenized.
  • That token is parsable to the selected type.

Combining this query in a FunctionQuery allows much freedom in affecting document scores. Note, that with this freedom comes responsibility: it is more than likely that the default Lucene scoring is superior in quality to scoring modified as explained here. However, in some cases, and certainly for research experiments, this capability may turn useful.

When contructing this query, select the appropriate type. That type should match the data stored in the field. So in fact the "right" type should be selected before indexing. Type selection has effect on the RAM usage:
  • BYTE consumes 1 * maxDocs bytes.
  • SHORT consumes 2 * maxDocs bytes.
  • INT consumes 4 * maxDocs bytes.
  • FLOAT consumes 8 * maxDocs bytes.

Caching: Values for the numeric field are loaded once and cached in memory for further use with the same IndexReader. To take advantage of this, it is extremely important to reuse index-readers or index-searchers, otherwise, for instance if for each query a new index reader is opened, large penalties would be paid for loading the field values into memory over and over again!

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search.Function ValueSourceQuery
Lucene.Net.Search.Function FieldScoreQuery

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FieldScoreQuery : ValueSourceQuery
[SerializableAttribute]
public class FieldScoreQuery : ValueSourceQuery
<SerializableAttribute> _
Public Class FieldScoreQuery _
    Inherits ValueSourceQuery
<SerializableAttribute> _
Public Class FieldScoreQuery _
    Inherits ValueSourceQuery
[SerializableAttribute]
public ref class FieldScoreQuery : public ValueSourceQuery
[SerializableAttribute]
public ref class FieldScoreQuery : public ValueSourceQuery
See Also
FieldScoreQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldScoreQuery Members

FieldScoreQuery Members Lucene.Net Class Library

The FieldScoreQuery type exposes the following members.
Constructors
 | Name | Description
Public method | FieldScoreQuery | Create a FieldScoreQuery - a query that scores each document as the value of the numeric input field. The type param tells how to parse the field string values into a numeric score value.
Back to Top
Methods
 | Name | Description
Public method | Clone | (Inherited from ValueSourceQuery.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Inherited from ValueSourceQuery.)
Public method | Equals | Returns true if o is equal to this. (Inherited from ValueSourceQuery.)
Public method | ExtractTerms | (Inherited from ValueSourceQuery.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Inherited from ValueSourceQuery.)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Inherited from ValueSourceQuery.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Inherited from ValueSourceQuery.)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Back to Top
See Also
FieldScoreQuery Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldScoreQuery Constructor

FieldScoreQuery Constructor Lucene.Net Class Library
Create a FieldScoreQuery - a query that scores each document as the value of the numeric input field.

The type param tells how to parse the field string values into a numeric score value.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldScoreQuery(
    string field,
    FieldScoreQuery..::..Type type
)
public FieldScoreQuery(
    string field,
    FieldScoreQuery..::..Type type
)
Public Sub New ( _
    field As String, _
    type As FieldScoreQuery..::..Type _
)
Public Sub New ( _
    field As String, _
    type As FieldScoreQuery..::..Type _
)
public:
FieldScoreQuery(
    String^ field,
    FieldScoreQuery..::..Type^ type
)
public:
FieldScoreQuery(
    String^ field,
    FieldScoreQuery..::..Type^ type
)
Parameters
field
Type:   Online System String
the numeric field to be used.

type
Type: Lucene.Net.Search.Function FieldScoreQuery Type
the type of the field: either
            BYTE, SHORT, INT, or FLOAT.

See Also
FieldScoreQuery Class
FieldScoreQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldScoreQuery Methods

FieldScoreQuery Methods Lucene.Net Class Library
The FieldScoreQuery type exposes the following members.
Methods
 | Name | Description
Public method | Clone | (Inherited from ValueSourceQuery.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Inherited from ValueSourceQuery.)
Public method | Equals | Returns true if o is equal to this. (Inherited from ValueSourceQuery.)
Public method | ExtractTerms | (Inherited from ValueSourceQuery.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Inherited from ValueSourceQuery.)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Inherited from ValueSourceQuery.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Inherited from ValueSourceQuery.)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
FieldScoreQuery Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldScoreQuery Properties

FieldScoreQuery Properties Lucene.Net Class Library
The FieldScoreQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Back to Top
See Also
FieldScoreQuery Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldScoreQuery.Type Class

FieldScoreQuery Type Class Lucene.Net Class Library
Type of score field, indicating how field values are interpreted/parsed.

The type selected at search search time should match the data stored in the field. Different types have different RAM requirements:
  • BYTE consumes 1 * maxDocs bytes.
  • SHORT consumes 2 * maxDocs bytes.
  • INT consumes 4 * maxDocs bytes.
  • FLOAT consumes 8 * maxDocs bytes.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Function FieldScoreQuery Type

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Type
public class Type
Public Class Type
Public Class Type
public ref class Type
public ref class Type
See Also
FieldScoreQuery Type Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldScoreQuery.Type Members

FieldScoreQuery Type Members Lucene.Net Class Library

A query that scores each document as the value of the numeric input field.

The query matches all documents, and scores each document according to the numeric value of that field.

It is assumed, and expected, that:
  • The field used here is indexed, and has exactly one token in every scored document.
  • Best if this field is un_tokenized.
  • That token is parsable to the selected type.

Combining this query in a FunctionQuery allows much freedom in affecting document scores. Note, that with this freedom comes responsibility: it is more than likely that the default Lucene scoring is superior in quality to scoring modified as explained here. However, in some cases, and certainly for research experiments, this capability may turn useful.

When contructing this query, select the appropriate type. That type should match the data stored in the field. So in fact the "right" type should be selected before indexing. Type selection has effect on the RAM usage:
  • BYTE consumes 1 * maxDocs bytes.
  • SHORT consumes 2 * maxDocs bytes.
  • INT consumes 4 * maxDocs bytes.
  • FLOAT consumes 8 * maxDocs bytes.

Caching: Values for the numeric field are loaded once and cached in memory for further use with the same IndexReader. To take advantage of this, it is extremely important to reuse index-readers or index-searchers, otherwise, for instance if for each query a new index reader is opened, large penalties would be paid for loading the field values into memory over and over again!

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

The FieldScoreQuery Type type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Fields
Name | Description
BYTE | field values are interpreted as numeric byte values.
FLOAT | field values are interpreted as numeric float values.
INT | field values are interpreted as numeric int values.
SHORT | field values are interpreted as numeric short values.
Back to Top
See Also
FieldScoreQuery Type Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldScoreQuery.Type Fields

FieldScoreQuery Type Fields Lucene.Net Class Library
The FieldScoreQuery Type type exposes the following members.
Fields
Name | Description
BYTE | field values are interpreted as numeric byte values.
FLOAT | field values are interpreted as numeric float values.
INT | field values are interpreted as numeric int values.
SHORT | field values are interpreted as numeric short values.
Back to Top
See Also
FieldScoreQuery Type Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BYTE Field

FieldScoreQuery Type BYTE Field Lucene.Net Class Library
field values are interpreted as numeric byte values.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly FieldScoreQuery..::..Type BYTE
public static readonly FieldScoreQuery..::..Type BYTE
Public Shared ReadOnly BYTE As FieldScoreQuery..::..Type
Public Shared ReadOnly BYTE As FieldScoreQuery..::..Type
public:
static initonly FieldScoreQuery..::..Type^ BYTE
public:
static initonly FieldScoreQuery..::..Type^ BYTE
See Also
FieldScoreQuery Type Class
FieldScoreQuery Type Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FLOAT Field

FieldScoreQuery Type FLOAT Field Lucene.Net Class Library
field values are interpreted as numeric float values.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly FieldScoreQuery..::..Type FLOAT
public static readonly FieldScoreQuery..::..Type FLOAT
Public Shared ReadOnly FLOAT As FieldScoreQuery..::..Type
Public Shared ReadOnly FLOAT As FieldScoreQuery..::..Type
public:
static initonly FieldScoreQuery..::..Type^ FLOAT
public:
static initonly FieldScoreQuery..::..Type^ FLOAT
See Also
FieldScoreQuery Type Class
FieldScoreQuery Type Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


INT Field

FieldScoreQuery Type INT Field Lucene.Net Class Library
field values are interpreted as numeric int values.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly FieldScoreQuery..::..Type INT
public static readonly FieldScoreQuery..::..Type INT
Public Shared ReadOnly INT As FieldScoreQuery..::..Type
Public Shared ReadOnly INT As FieldScoreQuery..::..Type
public:
static initonly FieldScoreQuery..::..Type^ INT
public:
static initonly FieldScoreQuery..::..Type^ INT
See Also
FieldScoreQuery Type Class
FieldScoreQuery Type Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SHORT Field

FieldScoreQuery Type SHORT Field Lucene.Net Class Library
field values are interpreted as numeric short values.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly FieldScoreQuery..::..Type SHORT
public static readonly FieldScoreQuery..::..Type SHORT
Public Shared ReadOnly SHORT As FieldScoreQuery..::..Type
Public Shared ReadOnly SHORT As FieldScoreQuery..::..Type
public:
static initonly FieldScoreQuery..::..Type^ SHORT
public:
static initonly FieldScoreQuery..::..Type^ SHORT
See Also
FieldScoreQuery Type Class
FieldScoreQuery Type Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldScoreQuery.Type Methods

FieldScoreQuery Type Methods Lucene.Net Class Library
The FieldScoreQuery Type type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
FieldScoreQuery Type Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

FieldScoreQuery Type ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
FieldScoreQuery Type Class
FieldScoreQuery Type Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FloatFieldSource Class

FloatFieldSource Class Lucene.Net Class Library
Expert: obtains float field values from the FieldCache using getFloats() and makes those values available as other numeric types, casting as needed.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Function ValueSource
Lucene.Net.Search.Function FieldCacheSource
Lucene.Net.Search.Function FloatFieldSource

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FloatFieldSource : FieldCacheSource
[SerializableAttribute]
public class FloatFieldSource : FieldCacheSource
<SerializableAttribute> _
Public Class FloatFieldSource _
    Inherits FieldCacheSource
<SerializableAttribute> _
Public Class FloatFieldSource _
    Inherits FieldCacheSource
[SerializableAttribute]
public ref class FloatFieldSource : public FieldCacheSource
[SerializableAttribute]
public ref class FloatFieldSource : public FieldCacheSource
See Also
FloatFieldSource Members
Lucene.Net.Search.Function Namespace
 for requirements"
            on the field.

            NOTE: with the switch in 2.9 to segment-based
            searching, if  is invoked with a
            composite (multi-segment) reader, this can easily cause
            double RAM usage for the values in the FieldCache.  It's
            best to switch your application to pass only atomic
            (single segment) readers to this API.
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FloatFieldSource Members

FloatFieldSource Members Lucene.Net Class Library

The FloatFieldSource type exposes the following members.
Constructors
 | Name | Description
Public method | FloatFieldSource(String) | Create a cached float field source with default string-to-float parser.
Public method | FloatFieldSource(String, FloatParser) | Create a cached float field source with a specific string-to-float parser.
Back to Top
Methods
 | Name | Description
Public method | CachedFieldSourceEquals | (Overrides FieldCacheSource CachedFieldSourceEquals(FieldCacheSource).)
Public method | CachedFieldSourceHashCode | (Overrides FieldCacheSource CachedFieldSourceHashCode .)
Public method | Description | (Overrides FieldCacheSource Description .)
Public method | Equals | (Inherited from FieldCacheSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetCachedFieldValues | (Overrides FieldCacheSource GetCachedFieldValues(FieldCache, String, IndexReader).)
Public method | GetHashCode | (Inherited from FieldCacheSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | (Inherited from FieldCacheSource.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from ValueSource.)
Back to Top
See Also
FloatFieldSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FloatFieldSource Constructor

FloatFieldSource Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | FloatFieldSource(String) | Create a cached float field source with default string-to-float parser.
Public method | FloatFieldSource(String, FloatParser) | Create a cached float field source with a specific string-to-float parser.
Back to Top
See Also
FloatFieldSource Class
FloatFieldSource Members
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FloatFieldSource Constructor (String)

FloatFieldSource Constructor (String) Lucene.Net Class Library
Create a cached float field source with default string-to-float parser.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FloatFieldSource(
    string field
)
public FloatFieldSource(
    string field
)
Public Sub New ( _
    field As String _
)
Public Sub New ( _
    field As String _
)
public:
FloatFieldSource(
    String^ field
)
public:
FloatFieldSource(
    String^ field
)
Parameters
field
Type:   Online System String
See Also
FloatFieldSource Class
FloatFieldSource Members
FloatFieldSource Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FloatFieldSource Constructor (String, FloatParser)

FloatFieldSource Constructor (String, FloatParser) Lucene.Net Class Library
Create a cached float field source with a specific string-to-float parser.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FloatFieldSource(
    string field,
    FloatParser parser
)
public FloatFieldSource(
    string field,
    FloatParser parser
)
Public Sub New ( _
    field As String, _
    parser As FloatParser _
)
Public Sub New ( _
    field As String, _
    parser As FloatParser _
)
public:
FloatFieldSource(
    String^ field,
    FloatParser^ parser
)
public:
FloatFieldSource(
    String^ field,
    FloatParser^ parser
)
Parameters
field
Type:   Online System String
parser
Type: Lucene.Net.Search FloatParser
See Also
FloatFieldSource Class
FloatFieldSource Members
FloatFieldSource Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FloatFieldSource Methods

FloatFieldSource Methods Lucene.Net Class Library
The FloatFieldSource type exposes the following members.
Methods
 | Name | Description
Public method | CachedFieldSourceEquals | (Overrides FieldCacheSource CachedFieldSourceEquals(FieldCacheSource).)
Public method | CachedFieldSourceHashCode | (Overrides FieldCacheSource CachedFieldSourceHashCode .)
Public method | Description | (Overrides FieldCacheSource Description .)
Public method | Equals | (Inherited from FieldCacheSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetCachedFieldValues | (Overrides FieldCacheSource GetCachedFieldValues(FieldCache, String, IndexReader).)
Public method | GetHashCode | (Inherited from FieldCacheSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | (Inherited from FieldCacheSource.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from ValueSource.)
Back to Top
See Also
FloatFieldSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachedFieldSourceEquals Method

FloatFieldSource CachedFieldSourceEquals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CachedFieldSourceEquals(
    FieldCacheSource o
)
public override bool CachedFieldSourceEquals(
    FieldCacheSource o
)
Public Overrides Function CachedFieldSourceEquals ( _
    o As FieldCacheSource _
) As Boolean
Public Overrides Function CachedFieldSourceEquals ( _
    o As FieldCacheSource _
) As Boolean
public:
virtual bool CachedFieldSourceEquals(
    FieldCacheSource^ o
) override
public:
virtual bool CachedFieldSourceEquals(
    FieldCacheSource^ o
) override
Parameters
o
Type: Lucene.Net.Search.Function FieldCacheSource
See Also
FloatFieldSource Class
FloatFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachedFieldSourceHashCode Method

FloatFieldSource CachedFieldSourceHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int CachedFieldSourceHashCode()
public override int CachedFieldSourceHashCode()
Public Overrides Function CachedFieldSourceHashCode As Integer
Public Overrides Function CachedFieldSourceHashCode As Integer
public:
virtual int CachedFieldSourceHashCode() override
public:
virtual int CachedFieldSourceHashCode() override
See Also
FloatFieldSource Class
FloatFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Description Method

FloatFieldSource Description Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description()
public override string Description()
Public Overrides Function Description As String
Public Overrides Function Description As String
public:
virtual String^ Description() override
public:
virtual String^ Description() override
See Also
FloatFieldSource Class
FloatFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCachedFieldValues Method

FloatFieldSource GetCachedFieldValues Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocValues GetCachedFieldValues(
    FieldCache cache,
    string field,
    IndexReader reader
)
public override DocValues GetCachedFieldValues(
    FieldCache cache,
    string field,
    IndexReader reader
)
Public Overrides Function GetCachedFieldValues ( _
    cache As FieldCache, _
    field As String, _
    reader As IndexReader _
) As DocValues
Public Overrides Function GetCachedFieldValues ( _
    cache As FieldCache, _
    field As String, _
    reader As IndexReader _
) As DocValues
public:
virtual DocValues^ GetCachedFieldValues(
    FieldCache^ cache,
    String^ field,
    IndexReader^ reader
) override
public:
virtual DocValues^ GetCachedFieldValues(
    FieldCache^ cache,
    String^ field,
    IndexReader^ reader
) override
Parameters
cache
Type: Lucene.Net.Search FieldCache
field
Type:   Online System String
reader
Type: Lucene.Net.Index IndexReader
See Also
FloatFieldSource Class
FloatFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IntFieldSource Class

IntFieldSource Class Lucene.Net Class Library
Expert: obtains int field values from the FieldCache using getInts() and makes those values available as other numeric types, casting as needed.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Function ValueSource
Lucene.Net.Search.Function FieldCacheSource
Lucene.Net.Search.Function IntFieldSource

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class IntFieldSource : FieldCacheSource
[SerializableAttribute]
public class IntFieldSource : FieldCacheSource
<SerializableAttribute> _
Public Class IntFieldSource _
    Inherits FieldCacheSource
<SerializableAttribute> _
Public Class IntFieldSource _
    Inherits FieldCacheSource
[SerializableAttribute]
public ref class IntFieldSource : public FieldCacheSource
[SerializableAttribute]
public ref class IntFieldSource : public FieldCacheSource
See Also
IntFieldSource Members
Lucene.Net.Search.Function Namespace
 for requirements
            on the field.

            NOTE: with the switch in 2.9 to segment-based
            searching, if  is invoked with a
            composite (multi-segment) reader, this can easily cause
            double RAM usage for the values in the FieldCache.  It's
            best to switch your application to pass only atomic
            (single segment) readers to this API.
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IntFieldSource Members

IntFieldSource Members Lucene.Net Class Library

The IntFieldSource type exposes the following members.
Constructors
 | Name | Description
Public method | IntFieldSource(String) | Create a cached int field source with default string-to-int parser.
Public method | IntFieldSource(String, IntParser) | Create a cached int field source with a specific string-to-int parser.
Back to Top
Methods
 | Name | Description
Public method | CachedFieldSourceEquals | (Overrides FieldCacheSource CachedFieldSourceEquals(FieldCacheSource).)
Public method | CachedFieldSourceHashCode | (Overrides FieldCacheSource CachedFieldSourceHashCode .)
Public method | Description | (Overrides FieldCacheSource Description .)
Public method | Equals | (Inherited from FieldCacheSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetCachedFieldValues | (Overrides FieldCacheSource GetCachedFieldValues(FieldCache, String, IndexReader).)
Public method | GetHashCode | (Inherited from FieldCacheSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | (Inherited from FieldCacheSource.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from ValueSource.)
Back to Top
See Also
IntFieldSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IntFieldSource Constructor

IntFieldSource Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | IntFieldSource(String) | Create a cached int field source with default string-to-int parser.
Public method | IntFieldSource(String, IntParser) | Create a cached int field source with a specific string-to-int parser.
Back to Top
See Also
IntFieldSource Class
IntFieldSource Members
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IntFieldSource Constructor (String)

IntFieldSource Constructor (String) Lucene.Net Class Library
Create a cached int field source with default string-to-int parser.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IntFieldSource(
    string field
)
public IntFieldSource(
    string field
)
Public Sub New ( _
    field As String _
)
Public Sub New ( _
    field As String _
)
public:
IntFieldSource(
    String^ field
)
public:
IntFieldSource(
    String^ field
)
Parameters
field
Type:   Online System String
See Also
IntFieldSource Class
IntFieldSource Members
IntFieldSource Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IntFieldSource Constructor (String, IntParser)

IntFieldSource Constructor (String, IntParser) Lucene.Net Class Library
Create a cached int field source with a specific string-to-int parser.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IntFieldSource(
    string field,
    IntParser parser
)
public IntFieldSource(
    string field,
    IntParser parser
)
Public Sub New ( _
    field As String, _
    parser As IntParser _
)
Public Sub New ( _
    field As String, _
    parser As IntParser _
)
public:
IntFieldSource(
    String^ field,
    IntParser^ parser
)
public:
IntFieldSource(
    String^ field,
    IntParser^ parser
)
Parameters
field
Type:   Online System String
parser
Type: Lucene.Net.Search IntParser
See Also
IntFieldSource Class
IntFieldSource Members
IntFieldSource Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IntFieldSource Methods

IntFieldSource Methods Lucene.Net Class Library
The IntFieldSource type exposes the following members.
Methods
 | Name | Description
Public method | CachedFieldSourceEquals | (Overrides FieldCacheSource CachedFieldSourceEquals(FieldCacheSource).)
Public method | CachedFieldSourceHashCode | (Overrides FieldCacheSource CachedFieldSourceHashCode .)
Public method | Description | (Overrides FieldCacheSource Description .)
Public method | Equals | (Inherited from FieldCacheSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetCachedFieldValues | (Overrides FieldCacheSource GetCachedFieldValues(FieldCache, String, IndexReader).)
Public method | GetHashCode | (Inherited from FieldCacheSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | (Inherited from FieldCacheSource.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from ValueSource.)
Back to Top
See Also
IntFieldSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachedFieldSourceEquals Method

IntFieldSource CachedFieldSourceEquals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CachedFieldSourceEquals(
    FieldCacheSource o
)
public override bool CachedFieldSourceEquals(
    FieldCacheSource o
)
Public Overrides Function CachedFieldSourceEquals ( _
    o As FieldCacheSource _
) As Boolean
Public Overrides Function CachedFieldSourceEquals ( _
    o As FieldCacheSource _
) As Boolean
public:
virtual bool CachedFieldSourceEquals(
    FieldCacheSource^ o
) override
public:
virtual bool CachedFieldSourceEquals(
    FieldCacheSource^ o
) override
Parameters
o
Type: Lucene.Net.Search.Function FieldCacheSource
See Also
IntFieldSource Class
IntFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachedFieldSourceHashCode Method

IntFieldSource CachedFieldSourceHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int CachedFieldSourceHashCode()
public override int CachedFieldSourceHashCode()
Public Overrides Function CachedFieldSourceHashCode As Integer
Public Overrides Function CachedFieldSourceHashCode As Integer
public:
virtual int CachedFieldSourceHashCode() override
public:
virtual int CachedFieldSourceHashCode() override
See Also
IntFieldSource Class
IntFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Description Method

IntFieldSource Description Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description()
public override string Description()
Public Overrides Function Description As String
Public Overrides Function Description As String
public:
virtual String^ Description() override
public:
virtual String^ Description() override
See Also
IntFieldSource Class
IntFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCachedFieldValues Method

IntFieldSource GetCachedFieldValues Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocValues GetCachedFieldValues(
    FieldCache cache,
    string field,
    IndexReader reader
)
public override DocValues GetCachedFieldValues(
    FieldCache cache,
    string field,
    IndexReader reader
)
Public Overrides Function GetCachedFieldValues ( _
    cache As FieldCache, _
    field As String, _
    reader As IndexReader _
) As DocValues
Public Overrides Function GetCachedFieldValues ( _
    cache As FieldCache, _
    field As String, _
    reader As IndexReader _
) As DocValues
public:
virtual DocValues^ GetCachedFieldValues(
    FieldCache^ cache,
    String^ field,
    IndexReader^ reader
) override
public:
virtual DocValues^ GetCachedFieldValues(
    FieldCache^ cache,
    String^ field,
    IndexReader^ reader
) override
Parameters
cache
Type: Lucene.Net.Search FieldCache
field
Type:   Online System String
reader
Type: Lucene.Net.Index IndexReader
See Also
IntFieldSource Class
IntFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OrdFieldSource Class

OrdFieldSource Class Lucene.Net Class Library
Expert: obtains the ordinal of the field value from the default Lucene Fieldcache using getStringIndex().

The native lucene index order is used to assign an ordinal value for each field value.

Field values (terms) are lexicographically ordered by unicode value, and numbered starting at 1.

Example:
If there were only three field values: "apple","banana","pear"
then ord("apple")=1, ord("banana")=2, ord("pear")=3

WARNING: ord() depends on the position in an index and can thus change when other documents are inserted or deleted, or if a MultiSearcher is used.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

NOTE: with the switch in 2.9 to segment-based searching, if GetValues(IndexReader) is invoked with a composite (multi-segment) reader, this can easily cause double RAM usage for the values in the FieldCache. It's best to switch your application to pass only atomic (single segment) readers to this API.

Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Function ValueSource
Lucene.Net.Search.Function OrdFieldSource

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class OrdFieldSource : ValueSource
[SerializableAttribute]
public class OrdFieldSource : ValueSource
<SerializableAttribute> _
Public Class OrdFieldSource _
    Inherits ValueSource
<SerializableAttribute> _
Public Class OrdFieldSource _
    Inherits ValueSource
[SerializableAttribute]
public ref class OrdFieldSource : public ValueSource
[SerializableAttribute]
public ref class OrdFieldSource : public ValueSource
See Also
OrdFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OrdFieldSource Members

OrdFieldSource Members Lucene.Net Class Library

The OrdFieldSource type exposes the following members.
Constructors
 | Name | Description
Public method | OrdFieldSource | Constructor for a certain field.
Back to Top
Methods
 | Name | Description
Public method | Description | (Overrides ValueSource Description .)
Public method | Equals | (Overrides ValueSource Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides ValueSource GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | (Overrides ValueSource GetValues(IndexReader).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from ValueSource.)
Back to Top
Fields
 | Name | Description
Protected field | field |
Back to Top
See Also
OrdFieldSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OrdFieldSource Constructor

OrdFieldSource Constructor Lucene.Net Class Library
Constructor for a certain field.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrdFieldSource(
    string field
)
public OrdFieldSource(
    string field
)
Public Sub New ( _
    field As String _
)
Public Sub New ( _
    field As String _
)
public:
OrdFieldSource(
    String^ field
)
public:
OrdFieldSource(
    String^ field
)
Parameters
field
Type:   Online System String
field whose values order is used.

See Also
OrdFieldSource Class
OrdFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OrdFieldSource Fields

OrdFieldSource Fields Lucene.Net Class Library
The OrdFieldSource type exposes the following members.
Fields
 | Name | Description
Protected field | field |
Back to Top
See Also
OrdFieldSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


field Field

OrdFieldSource field Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string field
protected string field
Protected field As String
Protected field As String
protected:
String^ field
protected:
String^ field
See Also
OrdFieldSource Class
OrdFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OrdFieldSource Methods

OrdFieldSource Methods Lucene.Net Class Library
The OrdFieldSource type exposes the following members.
Methods
 | Name | Description
Public method | Description | (Overrides ValueSource Description .)
Public method | Equals | (Overrides ValueSource Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides ValueSource GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | (Overrides ValueSource GetValues(IndexReader).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from ValueSource.)
Back to Top
See Also
OrdFieldSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Description Method

OrdFieldSource Description Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description()
public override string Description()
Public Overrides Function Description As String
Public Overrides Function Description As String
public:
virtual String^ Description() override
public:
virtual String^ Description() override
See Also
OrdFieldSource Class
OrdFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

OrdFieldSource Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
OrdFieldSource Class
OrdFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

OrdFieldSource GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
OrdFieldSource Class
OrdFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetValues Method

OrdFieldSource GetValues Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocValues GetValues(
    IndexReader reader
)
public override DocValues GetValues(
    IndexReader reader
)
Public Overrides Function GetValues ( _
    reader As IndexReader _
) As DocValues
Public Overrides Function GetValues ( _
    reader As IndexReader _
) As DocValues
public:
virtual DocValues^ GetValues(
    IndexReader^ reader
) override
public:
virtual DocValues^ GetValues(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
OrdFieldSource Class
OrdFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReverseOrdFieldSource Class

ReverseOrdFieldSource Class Lucene.Net Class Library
Expert: obtains the ordinal of the field value from the default Lucene FieldCache using getStringIndex() and reverses the order.

The native lucene index order is used to assign an ordinal value for each field value.

Field values (terms) are lexicographically ordered by unicode value, and numbered starting at 1.
Example of reverse ordinal (rord):
If there were only three field values: "apple","banana","pear"
then rord("apple")=3, rord("banana")=2, ord("pear")=1

WARNING: rord() depends on the position in an index and can thus change when other documents are inserted or deleted, or if a MultiSearcher is used.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

NOTE: with the switch in 2.9 to segment-based searching, if GetValues(IndexReader) is invoked with a composite (multi-segment) reader, this can easily cause double RAM usage for the values in the FieldCache. It's best to switch your application to pass only atomic (single segment) readers to this API.

Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Function ValueSource
Lucene.Net.Search.Function ReverseOrdFieldSource

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ReverseOrdFieldSource : ValueSource
[SerializableAttribute]
public class ReverseOrdFieldSource : ValueSource
<SerializableAttribute> _
Public Class ReverseOrdFieldSource _
    Inherits ValueSource
<SerializableAttribute> _
Public Class ReverseOrdFieldSource _
    Inherits ValueSource
[SerializableAttribute]
public ref class ReverseOrdFieldSource : public ValueSource
[SerializableAttribute]
public ref class ReverseOrdFieldSource : public ValueSource
See Also
ReverseOrdFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReverseOrdFieldSource Members

ReverseOrdFieldSource Members Lucene.Net Class Library

The ReverseOrdFieldSource type exposes the following members.
Constructors
 | Name | Description
Public method | ReverseOrdFieldSource | Contructor for a certain field.
Back to Top
Methods
 | Name | Description
Public method | Description | (Overrides ValueSource Description .)
Public method | Equals | (Overrides ValueSource Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides ValueSource GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | (Overrides ValueSource GetValues(IndexReader).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from ValueSource.)
Back to Top
Fields
 | Name | Description
Public field | field |
Back to Top
See Also
ReverseOrdFieldSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReverseOrdFieldSource Constructor

ReverseOrdFieldSource Constructor Lucene.Net Class Library
Contructor for a certain field.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReverseOrdFieldSource(
    string field
)
public ReverseOrdFieldSource(
    string field
)
Public Sub New ( _
    field As String _
)
Public Sub New ( _
    field As String _
)
public:
ReverseOrdFieldSource(
    String^ field
)
public:
ReverseOrdFieldSource(
    String^ field
)
Parameters
field
Type:   Online System String
field whose values reverse order is used.

See Also
ReverseOrdFieldSource Class
ReverseOrdFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReverseOrdFieldSource Fields

ReverseOrdFieldSource Fields Lucene.Net Class Library
The ReverseOrdFieldSource type exposes the following members.
Fields
 | Name | Description
Public field | field |
Back to Top
See Also
ReverseOrdFieldSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


field Field

ReverseOrdFieldSource field Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string field
public string field
Public field As String
Public field As String
public:
String^ field
public:
String^ field
See Also
ReverseOrdFieldSource Class
ReverseOrdFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReverseOrdFieldSource Methods

ReverseOrdFieldSource Methods Lucene.Net Class Library
The ReverseOrdFieldSource type exposes the following members.
Methods
 | Name | Description
Public method | Description | (Overrides ValueSource Description .)
Public method | Equals | (Overrides ValueSource Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides ValueSource GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | (Overrides ValueSource GetValues(IndexReader).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from ValueSource.)
Back to Top
See Also
ReverseOrdFieldSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Description Method

ReverseOrdFieldSource Description Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description()
public override string Description()
Public Overrides Function Description As String
Public Overrides Function Description As String
public:
virtual String^ Description() override
public:
virtual String^ Description() override
See Also
ReverseOrdFieldSource Class
ReverseOrdFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

ReverseOrdFieldSource Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
ReverseOrdFieldSource Class
ReverseOrdFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

ReverseOrdFieldSource GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
ReverseOrdFieldSource Class
ReverseOrdFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetValues Method

ReverseOrdFieldSource GetValues Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocValues GetValues(
    IndexReader reader
)
public override DocValues GetValues(
    IndexReader reader
)
Public Overrides Function GetValues ( _
    reader As IndexReader _
) As DocValues
Public Overrides Function GetValues ( _
    reader As IndexReader _
) As DocValues
public:
virtual DocValues^ GetValues(
    IndexReader^ reader
) override
public:
virtual DocValues^ GetValues(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
ReverseOrdFieldSource Class
ReverseOrdFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ShortFieldSource Class

ShortFieldSource Class Lucene.Net Class Library
Expert: obtains short field values from the FieldCache using getShorts() and makes those values available as other numeric types, casting as needed.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Function ValueSource
Lucene.Net.Search.Function FieldCacheSource
Lucene.Net.Search.Function ShortFieldSource

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ShortFieldSource : FieldCacheSource
[SerializableAttribute]
public class ShortFieldSource : FieldCacheSource
<SerializableAttribute> _
Public Class ShortFieldSource _
    Inherits FieldCacheSource
<SerializableAttribute> _
Public Class ShortFieldSource _
    Inherits FieldCacheSource
[SerializableAttribute]
public ref class ShortFieldSource : public FieldCacheSource
[SerializableAttribute]
public ref class ShortFieldSource : public FieldCacheSource
See Also
ShortFieldSource Members
Lucene.Net.Search.Function Namespace
 for requirements
            on the field.

            NOTE: with the switch in 2.9 to segment-based
            searching, if  is invoked with a
            composite (multi-segment) reader, this can easily cause
            double RAM usage for the values in the FieldCache.  It's
            best to switch your application to pass only atomic
            (single segment) readers to this API.
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ShortFieldSource Members

ShortFieldSource Members Lucene.Net Class Library

The ShortFieldSource type exposes the following members.
Constructors
 | Name | Description
Public method | ShortFieldSource(String) | Create a cached short field source with default string-to-short parser.
Public method | ShortFieldSource(String, ShortParser) | Create a cached short field source with a specific string-to-short parser.
Back to Top
Methods
 | Name | Description
Public method | CachedFieldSourceEquals | (Overrides FieldCacheSource CachedFieldSourceEquals(FieldCacheSource).)
Public method | CachedFieldSourceHashCode | (Overrides FieldCacheSource CachedFieldSourceHashCode .)
Public method | Description | (Overrides FieldCacheSource Description .)
Public method | Equals | (Inherited from FieldCacheSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetCachedFieldValues | (Overrides FieldCacheSource GetCachedFieldValues(FieldCache, String, IndexReader).)
Public method | GetHashCode | (Inherited from FieldCacheSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | (Inherited from FieldCacheSource.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from ValueSource.)
Back to Top
See Also
ShortFieldSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ShortFieldSource Constructor

ShortFieldSource Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ShortFieldSource(String) | Create a cached short field source with default string-to-short parser.
Public method | ShortFieldSource(String, ShortParser) | Create a cached short field source with a specific string-to-short parser.
Back to Top
See Also
ShortFieldSource Class
ShortFieldSource Members
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ShortFieldSource Constructor (String)

ShortFieldSource Constructor (String) Lucene.Net Class Library
Create a cached short field source with default string-to-short parser.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ShortFieldSource(
    string field
)
public ShortFieldSource(
    string field
)
Public Sub New ( _
    field As String _
)
Public Sub New ( _
    field As String _
)
public:
ShortFieldSource(
    String^ field
)
public:
ShortFieldSource(
    String^ field
)
Parameters
field
Type:   Online System String
See Also
ShortFieldSource Class
ShortFieldSource Members
ShortFieldSource Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ShortFieldSource Constructor (String, ShortParser)

ShortFieldSource Constructor (String, ShortParser) Lucene.Net Class Library
Create a cached short field source with a specific string-to-short parser.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ShortFieldSource(
    string field,
    ShortParser parser
)
public ShortFieldSource(
    string field,
    ShortParser parser
)
Public Sub New ( _
    field As String, _
    parser As ShortParser _
)
Public Sub New ( _
    field As String, _
    parser As ShortParser _
)
public:
ShortFieldSource(
    String^ field,
    ShortParser^ parser
)
public:
ShortFieldSource(
    String^ field,
    ShortParser^ parser
)
Parameters
field
Type:   Online System String
parser
Type: Lucene.Net.Search ShortParser
See Also
ShortFieldSource Class
ShortFieldSource Members
ShortFieldSource Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ShortFieldSource Methods

ShortFieldSource Methods Lucene.Net Class Library
The ShortFieldSource type exposes the following members.
Methods
 | Name | Description
Public method | CachedFieldSourceEquals | (Overrides FieldCacheSource CachedFieldSourceEquals(FieldCacheSource).)
Public method | CachedFieldSourceHashCode | (Overrides FieldCacheSource CachedFieldSourceHashCode .)
Public method | Description | (Overrides FieldCacheSource Description .)
Public method | Equals | (Inherited from FieldCacheSource.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetCachedFieldValues | (Overrides FieldCacheSource GetCachedFieldValues(FieldCache, String, IndexReader).)
Public method | GetHashCode | (Inherited from FieldCacheSource.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | (Inherited from FieldCacheSource.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from ValueSource.)
Back to Top
See Also
ShortFieldSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachedFieldSourceEquals Method

ShortFieldSource CachedFieldSourceEquals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CachedFieldSourceEquals(
    FieldCacheSource o
)
public override bool CachedFieldSourceEquals(
    FieldCacheSource o
)
Public Overrides Function CachedFieldSourceEquals ( _
    o As FieldCacheSource _
) As Boolean
Public Overrides Function CachedFieldSourceEquals ( _
    o As FieldCacheSource _
) As Boolean
public:
virtual bool CachedFieldSourceEquals(
    FieldCacheSource^ o
) override
public:
virtual bool CachedFieldSourceEquals(
    FieldCacheSource^ o
) override
Parameters
o
Type: Lucene.Net.Search.Function FieldCacheSource
See Also
ShortFieldSource Class
ShortFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CachedFieldSourceHashCode Method

ShortFieldSource CachedFieldSourceHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int CachedFieldSourceHashCode()
public override int CachedFieldSourceHashCode()
Public Overrides Function CachedFieldSourceHashCode As Integer
Public Overrides Function CachedFieldSourceHashCode As Integer
public:
virtual int CachedFieldSourceHashCode() override
public:
virtual int CachedFieldSourceHashCode() override
See Also
ShortFieldSource Class
ShortFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Description Method

ShortFieldSource Description Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description()
public override string Description()
Public Overrides Function Description As String
Public Overrides Function Description As String
public:
virtual String^ Description() override
public:
virtual String^ Description() override
See Also
ShortFieldSource Class
ShortFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCachedFieldValues Method

ShortFieldSource GetCachedFieldValues Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocValues GetCachedFieldValues(
    FieldCache cache,
    string field,
    IndexReader reader
)
public override DocValues GetCachedFieldValues(
    FieldCache cache,
    string field,
    IndexReader reader
)
Public Overrides Function GetCachedFieldValues ( _
    cache As FieldCache, _
    field As String, _
    reader As IndexReader _
) As DocValues
Public Overrides Function GetCachedFieldValues ( _
    cache As FieldCache, _
    field As String, _
    reader As IndexReader _
) As DocValues
public:
virtual DocValues^ GetCachedFieldValues(
    FieldCache^ cache,
    String^ field,
    IndexReader^ reader
) override
public:
virtual DocValues^ GetCachedFieldValues(
    FieldCache^ cache,
    String^ field,
    IndexReader^ reader
) override
Parameters
cache
Type: Lucene.Net.Search FieldCache
field
Type:   Online System String
reader
Type: Lucene.Net.Index IndexReader
See Also
ShortFieldSource Class
ShortFieldSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ValueSource Class

ValueSource Class Lucene.Net Class Library
Expert: source of values for basic function queries.

At its default/simplest form, values - one per doc - are used as the score of that doc.

Values are instantiated as DocValues for a particular reader.

ValueSource implementations differ in RAM requirements: it would always be a factor of the number of documents, but for each document the number of bytes can be 1, 2, 4, or 8.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Function ValueSource
Lucene.Net.Search.Function FieldCacheSource
Lucene.Net.Search.Function OrdFieldSource
Lucene.Net.Search.Function ReverseOrdFieldSource

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class ValueSource
[SerializableAttribute]
public abstract class ValueSource
<SerializableAttribute> _
Public MustInherit Class ValueSource
<SerializableAttribute> _
Public MustInherit Class ValueSource
[SerializableAttribute]
public ref class ValueSource abstract
[SerializableAttribute]
public ref class ValueSource abstract
See Also
ValueSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ValueSource Members

ValueSource Members Lucene.Net Class Library

The ValueSource type exposes the following members.
Constructors
 | Name | Description
Protected method | ValueSource | Initializes a new instance of the ValueSource class
Back to Top
Methods
 | Name | Description
Public method | Description | description of field, used in explain()
Public method | Equals | Needed for possible caching of query results - used by Equals(Object). (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Needed for possible caching of query results - used by GetHashCode . (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | Return the DocValues used by the function query.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
ValueSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ValueSource Constructor

ValueSource Constructor Lucene.Net Class Library
Initializes a new instance of the ValueSource class

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ValueSource()
protected ValueSource()
Protected Sub New
Protected Sub New
protected:
ValueSource()
protected:
ValueSource()
See Also
ValueSource Class
ValueSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ValueSource Methods

ValueSource Methods Lucene.Net Class Library
The ValueSource type exposes the following members.
Methods
 | Name | Description
Public method | Description | description of field, used in explain()
Public method | Equals | Needed for possible caching of query results - used by Equals(Object). (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Needed for possible caching of query results - used by GetHashCode . (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValues | Return the DocValues used by the function query.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
ValueSource Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Description Method

ValueSource Description Method Lucene.Net Class Library
description of field, used in explain()

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string Description()
public abstract string Description()
Public MustOverride Function Description As String
Public MustOverride Function Description As String
public:
virtual String^ Description() abstract
public:
virtual String^ Description() abstract
See Also
ValueSource Class
ValueSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

ValueSource Equals Method Lucene.Net Class Library
Needed for possible caching of query results - used by Equals(Object).

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool Equals(
    Object o
)
public abstract bool Equals(
    Object o
)
Public MustOverride Function Equals ( _
    o As Object _
) As Boolean
Public MustOverride Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) abstract override
public:
virtual bool Equals(
    Object^ o
) abstract override
Parameters
o
Type:   Online System Object
See Also
ValueSource Class
ValueSource Members
Lucene.Net.Search.Function Namespace
  Online Object Equals(Object)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

ValueSource GetHashCode Method Lucene.Net Class Library
Needed for possible caching of query results - used by GetHashCode .

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int GetHashCode()
public abstract int GetHashCode()
Public MustOverride Function GetHashCode As Integer
Public MustOverride Function GetHashCode As Integer
public:
virtual int GetHashCode() abstract override
public:
virtual int GetHashCode() abstract override
See Also
ValueSource Class
ValueSource Members
Lucene.Net.Search.Function Namespace
  Online Object GetHashCode
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetValues Method

ValueSource GetValues Method Lucene.Net Class Library
Return the DocValues used by the function query.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract DocValues GetValues(
    IndexReader reader
)
public abstract DocValues GetValues(
    IndexReader reader
)
Public MustOverride Function GetValues ( _
    reader As IndexReader _
) As DocValues
Public MustOverride Function GetValues ( _
    reader As IndexReader _
) As DocValues
public:
virtual DocValues^ GetValues(
    IndexReader^ reader
) abstract
public:
virtual DocValues^ GetValues(
    IndexReader^ reader
) abstract
Parameters
reader
Type: Lucene.Net.Index IndexReader
the IndexReader used to read these values.
            If any caching is involved, that caching would also be IndexReader based.

See Also
ValueSource Class
ValueSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

ValueSource ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
ValueSource Class
ValueSource Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ValueSourceQuery Class

ValueSourceQuery Class Lucene.Net Class Library
Expert: A Query that sets the scores of document to the values obtained from a ValueSource.

This query provides a score for each and every undeleted document in the index.

The value source can be based on a (cached) value of an indexed field, but it can also be based on an external source, e.g. values read from an external database.

Score is set as: Score(doc,query) = query.getBoost()2 * valueSource(doc).

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search.Function ValueSourceQuery
Lucene.Net.Search.Function FieldScoreQuery

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ValueSourceQuery : Query
[SerializableAttribute]
public class ValueSourceQuery : Query
<SerializableAttribute> _
Public Class ValueSourceQuery _
    Inherits Query
<SerializableAttribute> _
Public Class ValueSourceQuery _
    Inherits Query
[SerializableAttribute]
public ref class ValueSourceQuery : public Query
[SerializableAttribute]
public ref class ValueSourceQuery : public Query
See Also
ValueSourceQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ValueSourceQuery Members

ValueSourceQuery Members Lucene.Net Class Library

The ValueSourceQuery type exposes the following members.
Constructors
 | Name | Description
Public method | ValueSourceQuery | Create a value source query
Back to Top
Methods
 | Name | Description
Public method | Clone | (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | Returns true if o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Back to Top
See Also
ValueSourceQuery Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ValueSourceQuery Constructor

ValueSourceQuery Constructor Lucene.Net Class Library
Create a value source query

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ValueSourceQuery(
    ValueSource valSrc
)
public ValueSourceQuery(
    ValueSource valSrc
)
Public Sub New ( _
    valSrc As ValueSource _
)
Public Sub New ( _
    valSrc As ValueSource _
)
public:
ValueSourceQuery(
    ValueSource^ valSrc
)
public:
ValueSourceQuery(
    ValueSource^ valSrc
)
Parameters
valSrc
Type: Lucene.Net.Search.Function ValueSource
provides the values defines the function to be used for scoring

See Also
ValueSourceQuery Class
ValueSourceQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ValueSourceQuery Methods

ValueSourceQuery Methods Lucene.Net Class Library
The ValueSourceQuery type exposes the following members.
Methods
 | Name | Description
Public method | Clone | (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | Returns true if o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code value for this object. (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
ValueSourceQuery Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

ValueSourceQuery Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
See Also
ValueSourceQuery Class
ValueSourceQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateWeight Method

ValueSourceQuery CreateWeight Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Weight CreateWeight(
    Searcher searcher
)
public override Weight CreateWeight(
    Searcher searcher
)
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
ValueSourceQuery Class
ValueSourceQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

ValueSourceQuery Equals Method Lucene.Net Class Library
Returns true if o is equal to this.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
ValueSourceQuery Class
ValueSourceQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExtractTerms Method

ValueSourceQuery ExtractTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ExtractTerms(
    ISet<Term> terms
)
public override void ExtractTerms(
    ISet<Term> terms
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
Parameters
terms
Type:   Online System.Collections.Generic ISet  Term
See Also
ValueSourceQuery Class
ValueSourceQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

ValueSourceQuery GetHashCode Method Lucene.Net Class Library
Returns a hash code value for this object.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
ValueSourceQuery Class
ValueSourceQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

ValueSourceQuery Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    IndexReader reader
)
public override Query Rewrite(
    IndexReader reader
)
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
ValueSourceQuery Class
ValueSourceQuery Members
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

ValueSourceQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Back to Top
See Also
ValueSourceQuery Class
ValueSourceQuery Members
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

ValueSourceQuery ToString Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
ValueSourceQuery Class
ValueSourceQuery Members
ToString Overload
Lucene.Net.Search.Function Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ValueSourceQuery Properties

ValueSourceQuery Properties Lucene.Net Class Library
The ValueSourceQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Back to Top
See Also
ValueSourceQuery Class
Lucene.Net.Search.Function Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lucene.Net.Search.Payloads Namespace

Lucene.Net.Search.Payloads Namespace Lucene.Net Class Library
Classes
 | Class | Description
Public class | AveragePayloadFunction | Calculate the final score as the average score of all payloads seen. Is thread safe and completely reusable.
Public class | MaxPayloadFunction | Returns the maximum payload score seen, else 1 if there are no payloads on the doc. Is thread safe and completely reusable.
Public class | MinPayloadFunction | Calculates the minimum payload seen
Public class | PayloadFunction | An abstract class that defines a way for Payload*Query instances to transform the cumulative effects of payload scores for a document.
Public class | PayloadNearQuery | This class is very similar to SpanNearQuery except that it factors in the value of the payloads located at each of the positions where the TermSpans occurs. In order to take advantage of this, you must override ScorePayload(Int32, String, Int32, Int32, Byte , Int32, Int32) which returns 1 by default. Payload scores are aggregated using a pluggable PayloadFunction.
Public class | PayloadNearQuery PayloadNearSpanScorer |
Public class | PayloadNearQuery PayloadNearSpanWeight |
Public class | PayloadSpanUtil | Experimental class to get set of payloads for most standard Lucene queries. Operates like Highlighter - IndexReader should only contain doc of interest, best to use MemoryIndex. WARNING: The status of the Payloads feature is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Public class | PayloadTermQuery | This class is very similar to SpanTermQuery except that it factors in the value of the payload located at each of the positions where the Term occurs. In order to take advantage of this, you must override ScorePayload(Int32, String, Int32, Int32, Byte , Int32, Int32) which returns 1 by default. Payload scores are aggregated using a pluggable PayloadFunction.
Protected class | PayloadTermQuery PayloadTermWeight |
Protected class | PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer |

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AveragePayloadFunction Class

AveragePayloadFunction Class Lucene.Net Class Library
Calculate the final score as the average score of all payloads seen.

Is thread safe and completely reusable.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Payloads PayloadFunction
Lucene.Net.Search.Payloads AveragePayloadFunction

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class AveragePayloadFunction : PayloadFunction
[SerializableAttribute]
public class AveragePayloadFunction : PayloadFunction
<SerializableAttribute> _
Public Class AveragePayloadFunction _
    Inherits PayloadFunction
<SerializableAttribute> _
Public Class AveragePayloadFunction _
    Inherits PayloadFunction
[SerializableAttribute]
public ref class AveragePayloadFunction : public PayloadFunction
[SerializableAttribute]
public ref class AveragePayloadFunction : public PayloadFunction
See Also
AveragePayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AveragePayloadFunction Members

AveragePayloadFunction Members Lucene.Net Class Library

The AveragePayloadFunction type exposes the following members.
Constructors
 | Name | Description
Public method | AveragePayloadFunction | Initializes a new instance of the AveragePayloadFunction class
Back to Top
Methods
 | Name | Description
Public method | CurrentScore | (Overrides PayloadFunction CurrentScore(Int32, String, Int32, Int32, Int32, Single, Single).)
Public method | DocScore | (Overrides PayloadFunction DocScore(Int32, String, Int32, Single).)
Public method | Equals | (Overrides PayloadFunction Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides PayloadFunction GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AveragePayloadFunction Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AveragePayloadFunction Constructor

AveragePayloadFunction Constructor Lucene.Net Class Library
Initializes a new instance of the AveragePayloadFunction class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AveragePayloadFunction()
public AveragePayloadFunction()
Public Sub New
Public Sub New
public:
AveragePayloadFunction()
public:
AveragePayloadFunction()
See Also
AveragePayloadFunction Class
AveragePayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AveragePayloadFunction Methods

AveragePayloadFunction Methods Lucene.Net Class Library
The AveragePayloadFunction type exposes the following members.
Methods
 | Name | Description
Public method | CurrentScore | (Overrides PayloadFunction CurrentScore(Int32, String, Int32, Int32, Int32, Single, Single).)
Public method | DocScore | (Overrides PayloadFunction DocScore(Int32, String, Int32, Single).)
Public method | Equals | (Overrides PayloadFunction Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides PayloadFunction GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AveragePayloadFunction Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CurrentScore Method

AveragePayloadFunction CurrentScore Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float CurrentScore(
    int docId,
    string field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
)
public override float CurrentScore(
    int docId,
    string field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
)
Public Overrides Function CurrentScore ( _
    docId As Integer, _
    field As String, _
    start As Integer, _
    end As Integer, _
    numPayloadsSeen As Integer, _
    currentScore As Single, _
    currentPayloadScore As Single _
) As Single
Public Overrides Function CurrentScore ( _
    docId As Integer, _
    field As String, _
    start As Integer, _
    end As Integer, _
    numPayloadsSeen As Integer, _
    currentScore As Single, _
    currentPayloadScore As Single _
) As Single
public:
virtual float CurrentScore(
    int docId,
    String^ field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
) override
public:
virtual float CurrentScore(
    int docId,
    String^ field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
) override
Parameters
docId
Type:   Online System Int32
field
Type:   Online System String
start
Type:   Online System Int32
end
Type:   Online System Int32
numPayloadsSeen
Type:   Online System Int32
currentScore
Type:   Online System Single
currentPayloadScore
Type:   Online System Single
See Also
AveragePayloadFunction Class
AveragePayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocScore Method

AveragePayloadFunction DocScore Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float DocScore(
    int docId,
    string field,
    int numPayloadsSeen,
    float payloadScore
)
public override float DocScore(
    int docId,
    string field,
    int numPayloadsSeen,
    float payloadScore
)
Public Overrides Function DocScore ( _
    docId As Integer, _
    field As String, _
    numPayloadsSeen As Integer, _
    payloadScore As Single _
) As Single
Public Overrides Function DocScore ( _
    docId As Integer, _
    field As String, _
    numPayloadsSeen As Integer, _
    payloadScore As Single _
) As Single
public:
virtual float DocScore(
    int docId,
    String^ field,
    int numPayloadsSeen,
    float payloadScore
) override
public:
virtual float DocScore(
    int docId,
    String^ field,
    int numPayloadsSeen,
    float payloadScore
) override
Parameters
docId
Type:   Online System Int32
field
Type:   Online System String
numPayloadsSeen
Type:   Online System Int32
payloadScore
Type:   Online System Single
See Also
AveragePayloadFunction Class
AveragePayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

AveragePayloadFunction Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
AveragePayloadFunction Class
AveragePayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

AveragePayloadFunction GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
AveragePayloadFunction Class
AveragePayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxPayloadFunction Class

MaxPayloadFunction Class Lucene.Net Class Library
Returns the maximum payload score seen, else 1 if there are no payloads on the doc.

Is thread safe and completely reusable.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Payloads PayloadFunction
Lucene.Net.Search.Payloads MaxPayloadFunction

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MaxPayloadFunction : PayloadFunction
[SerializableAttribute]
public class MaxPayloadFunction : PayloadFunction
<SerializableAttribute> _
Public Class MaxPayloadFunction _
    Inherits PayloadFunction
<SerializableAttribute> _
Public Class MaxPayloadFunction _
    Inherits PayloadFunction
[SerializableAttribute]
public ref class MaxPayloadFunction : public PayloadFunction
[SerializableAttribute]
public ref class MaxPayloadFunction : public PayloadFunction
See Also
MaxPayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxPayloadFunction Members

MaxPayloadFunction Members Lucene.Net Class Library

The MaxPayloadFunction type exposes the following members.
Constructors
 | Name | Description
Public method | MaxPayloadFunction | Initializes a new instance of the MaxPayloadFunction class
Back to Top
Methods
 | Name | Description
Public method | CurrentScore | (Overrides PayloadFunction CurrentScore(Int32, String, Int32, Int32, Int32, Single, Single).)
Public method | DocScore | (Overrides PayloadFunction DocScore(Int32, String, Int32, Single).)
Public method | Equals | (Overrides PayloadFunction Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides PayloadFunction GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MaxPayloadFunction Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxPayloadFunction Constructor

MaxPayloadFunction Constructor Lucene.Net Class Library
Initializes a new instance of the MaxPayloadFunction class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MaxPayloadFunction()
public MaxPayloadFunction()
Public Sub New
Public Sub New
public:
MaxPayloadFunction()
public:
MaxPayloadFunction()
See Also
MaxPayloadFunction Class
MaxPayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxPayloadFunction Methods

MaxPayloadFunction Methods Lucene.Net Class Library
The MaxPayloadFunction type exposes the following members.
Methods
 | Name | Description
Public method | CurrentScore | (Overrides PayloadFunction CurrentScore(Int32, String, Int32, Int32, Int32, Single, Single).)
Public method | DocScore | (Overrides PayloadFunction DocScore(Int32, String, Int32, Single).)
Public method | Equals | (Overrides PayloadFunction Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides PayloadFunction GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MaxPayloadFunction Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CurrentScore Method

MaxPayloadFunction CurrentScore Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float CurrentScore(
    int docId,
    string field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
)
public override float CurrentScore(
    int docId,
    string field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
)
Public Overrides Function CurrentScore ( _
    docId As Integer, _
    field As String, _
    start As Integer, _
    end As Integer, _
    numPayloadsSeen As Integer, _
    currentScore As Single, _
    currentPayloadScore As Single _
) As Single
Public Overrides Function CurrentScore ( _
    docId As Integer, _
    field As String, _
    start As Integer, _
    end As Integer, _
    numPayloadsSeen As Integer, _
    currentScore As Single, _
    currentPayloadScore As Single _
) As Single
public:
virtual float CurrentScore(
    int docId,
    String^ field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
) override
public:
virtual float CurrentScore(
    int docId,
    String^ field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
) override
Parameters
docId
Type:   Online System Int32
field
Type:   Online System String
start
Type:   Online System Int32
end
Type:   Online System Int32
numPayloadsSeen
Type:   Online System Int32
currentScore
Type:   Online System Single
currentPayloadScore
Type:   Online System Single
See Also
MaxPayloadFunction Class
MaxPayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocScore Method

MaxPayloadFunction DocScore Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float DocScore(
    int docId,
    string field,
    int numPayloadsSeen,
    float payloadScore
)
public override float DocScore(
    int docId,
    string field,
    int numPayloadsSeen,
    float payloadScore
)
Public Overrides Function DocScore ( _
    docId As Integer, _
    field As String, _
    numPayloadsSeen As Integer, _
    payloadScore As Single _
) As Single
Public Overrides Function DocScore ( _
    docId As Integer, _
    field As String, _
    numPayloadsSeen As Integer, _
    payloadScore As Single _
) As Single
public:
virtual float DocScore(
    int docId,
    String^ field,
    int numPayloadsSeen,
    float payloadScore
) override
public:
virtual float DocScore(
    int docId,
    String^ field,
    int numPayloadsSeen,
    float payloadScore
) override
Parameters
docId
Type:   Online System Int32
field
Type:   Online System String
numPayloadsSeen
Type:   Online System Int32
payloadScore
Type:   Online System Single
See Also
MaxPayloadFunction Class
MaxPayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

MaxPayloadFunction Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
MaxPayloadFunction Class
MaxPayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

MaxPayloadFunction GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
MaxPayloadFunction Class
MaxPayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MinPayloadFunction Class

MinPayloadFunction Class Lucene.Net Class Library
Calculates the minimum payload seen
Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Payloads PayloadFunction
Lucene.Net.Search.Payloads MinPayloadFunction

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MinPayloadFunction : PayloadFunction
[SerializableAttribute]
public class MinPayloadFunction : PayloadFunction
<SerializableAttribute> _
Public Class MinPayloadFunction _
    Inherits PayloadFunction
<SerializableAttribute> _
Public Class MinPayloadFunction _
    Inherits PayloadFunction
[SerializableAttribute]
public ref class MinPayloadFunction : public PayloadFunction
[SerializableAttribute]
public ref class MinPayloadFunction : public PayloadFunction
See Also
MinPayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MinPayloadFunction Members

MinPayloadFunction Members Lucene.Net Class Library

The MinPayloadFunction type exposes the following members.
Constructors
 | Name | Description
Public method | MinPayloadFunction | Initializes a new instance of the MinPayloadFunction class
Back to Top
Methods
 | Name | Description
Public method | CurrentScore | (Overrides PayloadFunction CurrentScore(Int32, String, Int32, Int32, Int32, Single, Single).)
Public method | DocScore | (Overrides PayloadFunction DocScore(Int32, String, Int32, Single).)
Public method | Equals | (Overrides PayloadFunction Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides PayloadFunction GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MinPayloadFunction Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MinPayloadFunction Constructor

MinPayloadFunction Constructor Lucene.Net Class Library
Initializes a new instance of the MinPayloadFunction class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MinPayloadFunction()
public MinPayloadFunction()
Public Sub New
Public Sub New
public:
MinPayloadFunction()
public:
MinPayloadFunction()
See Also
MinPayloadFunction Class
MinPayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MinPayloadFunction Methods

MinPayloadFunction Methods Lucene.Net Class Library
The MinPayloadFunction type exposes the following members.
Methods
 | Name | Description
Public method | CurrentScore | (Overrides PayloadFunction CurrentScore(Int32, String, Int32, Int32, Int32, Single, Single).)
Public method | DocScore | (Overrides PayloadFunction DocScore(Int32, String, Int32, Single).)
Public method | Equals | (Overrides PayloadFunction Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides PayloadFunction GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MinPayloadFunction Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CurrentScore Method

MinPayloadFunction CurrentScore Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float CurrentScore(
    int docId,
    string field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
)
public override float CurrentScore(
    int docId,
    string field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
)
Public Overrides Function CurrentScore ( _
    docId As Integer, _
    field As String, _
    start As Integer, _
    end As Integer, _
    numPayloadsSeen As Integer, _
    currentScore As Single, _
    currentPayloadScore As Single _
) As Single
Public Overrides Function CurrentScore ( _
    docId As Integer, _
    field As String, _
    start As Integer, _
    end As Integer, _
    numPayloadsSeen As Integer, _
    currentScore As Single, _
    currentPayloadScore As Single _
) As Single
public:
virtual float CurrentScore(
    int docId,
    String^ field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
) override
public:
virtual float CurrentScore(
    int docId,
    String^ field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
) override
Parameters
docId
Type:   Online System Int32
field
Type:   Online System String
start
Type:   Online System Int32
end
Type:   Online System Int32
numPayloadsSeen
Type:   Online System Int32
currentScore
Type:   Online System Single
currentPayloadScore
Type:   Online System Single
See Also
MinPayloadFunction Class
MinPayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocScore Method

MinPayloadFunction DocScore Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float DocScore(
    int docId,
    string field,
    int numPayloadsSeen,
    float payloadScore
)
public override float DocScore(
    int docId,
    string field,
    int numPayloadsSeen,
    float payloadScore
)
Public Overrides Function DocScore ( _
    docId As Integer, _
    field As String, _
    numPayloadsSeen As Integer, _
    payloadScore As Single _
) As Single
Public Overrides Function DocScore ( _
    docId As Integer, _
    field As String, _
    numPayloadsSeen As Integer, _
    payloadScore As Single _
) As Single
public:
virtual float DocScore(
    int docId,
    String^ field,
    int numPayloadsSeen,
    float payloadScore
) override
public:
virtual float DocScore(
    int docId,
    String^ field,
    int numPayloadsSeen,
    float payloadScore
) override
Parameters
docId
Type:   Online System Int32
field
Type:   Online System String
numPayloadsSeen
Type:   Online System Int32
payloadScore
Type:   Online System Single
See Also
MinPayloadFunction Class
MinPayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

MinPayloadFunction Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
MinPayloadFunction Class
MinPayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

MinPayloadFunction GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
MinPayloadFunction Class
MinPayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadFunction Class

PayloadFunction Class Lucene.Net Class Library
An abstract class that defines a way for Payload*Query instances to transform the cumulative effects of payload scores for a document.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Payloads PayloadFunction
Lucene.Net.Search.Payloads AveragePayloadFunction
Lucene.Net.Search.Payloads MaxPayloadFunction
Lucene.Net.Search.Payloads MinPayloadFunction

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class PayloadFunction
[SerializableAttribute]
public abstract class PayloadFunction
<SerializableAttribute> _
Public MustInherit Class PayloadFunction
<SerializableAttribute> _
Public MustInherit Class PayloadFunction
[SerializableAttribute]
public ref class PayloadFunction abstract
[SerializableAttribute]
public ref class PayloadFunction abstract
See Also
PayloadFunction Members
Lucene.Net.Search.Payloads Namespace
 for more information

            This class and its derivations are experimental and subject to change

Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadFunction Members

PayloadFunction Members Lucene.Net Class Library

The PayloadFunction type exposes the following members.
Constructors
 | Name | Description
Protected method | PayloadFunction | Initializes a new instance of the PayloadFunction class
Back to Top
Methods
 | Name | Description
Public method | CurrentScore | Calculate the score up to this point for this doc and field
Public method | DocScore | Calculate the final score for all the payloads seen so far for this doc/field
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PayloadFunction Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadFunction Constructor

PayloadFunction Constructor Lucene.Net Class Library
Initializes a new instance of the PayloadFunction class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PayloadFunction()
protected PayloadFunction()
Protected Sub New
Protected Sub New
protected:
PayloadFunction()
protected:
PayloadFunction()
See Also
PayloadFunction Class
PayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadFunction Methods

PayloadFunction Methods Lucene.Net Class Library
The PayloadFunction type exposes the following members.
Methods
 | Name | Description
Public method | CurrentScore | Calculate the score up to this point for this doc and field
Public method | DocScore | Calculate the final score for all the payloads seen so far for this doc/field
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PayloadFunction Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CurrentScore Method

PayloadFunction CurrentScore Method Lucene.Net Class Library
Calculate the score up to this point for this doc and field

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract float CurrentScore(
    int docId,
    string field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
)
public abstract float CurrentScore(
    int docId,
    string field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
)
Public MustOverride Function CurrentScore ( _
    docId As Integer, _
    field As String, _
    start As Integer, _
    end As Integer, _
    numPayloadsSeen As Integer, _
    currentScore As Single, _
    currentPayloadScore As Single _
) As Single
Public MustOverride Function CurrentScore ( _
    docId As Integer, _
    field As String, _
    start As Integer, _
    end As Integer, _
    numPayloadsSeen As Integer, _
    currentScore As Single, _
    currentPayloadScore As Single _
) As Single
public:
virtual float CurrentScore(
    int docId,
    String^ field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
) abstract
public:
virtual float CurrentScore(
    int docId,
    String^ field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
) abstract
Parameters
docId
Type:   Online System Int32
The current doc

field
Type:   Online System String
The field

start
Type:   Online System Int32
The start position of the matching Span

end
Type:   Online System Int32
The end position of the matching Span

numPayloadsSeen
Type:   Online System Int32
The number of payloads seen so far

currentScore
Type:   Online System Single
The current score so far

currentPayloadScore
Type:   Online System Single
The score for the current payload

Return Value
 The new current Score

See Also
PayloadFunction Class
PayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Lucene.Net.Search.Spans Spans
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocScore Method

PayloadFunction DocScore Method Lucene.Net Class Library
Calculate the final score for all the payloads seen so far for this doc/field

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract float DocScore(
    int docId,
    string field,
    int numPayloadsSeen,
    float payloadScore
)
public abstract float DocScore(
    int docId,
    string field,
    int numPayloadsSeen,
    float payloadScore
)
Public MustOverride Function DocScore ( _
    docId As Integer, _
    field As String, _
    numPayloadsSeen As Integer, _
    payloadScore As Single _
) As Single
Public MustOverride Function DocScore ( _
    docId As Integer, _
    field As String, _
    numPayloadsSeen As Integer, _
    payloadScore As Single _
) As Single
public:
virtual float DocScore(
    int docId,
    String^ field,
    int numPayloadsSeen,
    float payloadScore
) abstract
public:
virtual float DocScore(
    int docId,
    String^ field,
    int numPayloadsSeen,
    float payloadScore
) abstract
Parameters
docId
Type:   Online System Int32
The current doc

field
Type:   Online System String
The current field

numPayloadsSeen
Type:   Online System Int32
The total number of payloads seen on this document

payloadScore
Type:   Online System Single
The raw score for those payloads

Return Value
 The final score for the payloads

See Also
PayloadFunction Class
PayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

PayloadFunction Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool Equals(
    Object o
)
public abstract bool Equals(
    Object o
)
Public MustOverride Function Equals ( _
    o As Object _
) As Boolean
Public MustOverride Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) abstract override
public:
virtual bool Equals(
    Object^ o
) abstract override
Parameters
o
Type:   Online System Object
See Also
PayloadFunction Class
PayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

PayloadFunction GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int GetHashCode()
public abstract int GetHashCode()
Public MustOverride Function GetHashCode As Integer
Public MustOverride Function GetHashCode As Integer
public:
virtual int GetHashCode() abstract override
public:
virtual int GetHashCode() abstract override
See Also
PayloadFunction Class
PayloadFunction Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery Class

PayloadNearQuery Class Lucene.Net Class Library
This class is very similar to SpanNearQuery except that it factors in the value of the payloads located at each of the positions where the TermSpans occurs.

In order to take advantage of this, you must override ScorePayload(Int32, String, Int32, Int32, Byte , Int32, Int32) which returns 1 by default.

Payload scores are aggregated using a pluggable PayloadFunction.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search.Spans SpanQuery
Lucene.Net.Search.Spans SpanNearQuery
Lucene.Net.Search.Payloads PayloadNearQuery

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PayloadNearQuery : SpanNearQuery,
    ICloneable
[SerializableAttribute]
public class PayloadNearQuery : SpanNearQuery,
    ICloneable
<SerializableAttribute> _
Public Class PayloadNearQuery _
    Inherits SpanNearQuery _
    Implements ICloneable
<SerializableAttribute> _
Public Class PayloadNearQuery _
    Inherits SpanNearQuery _
    Implements ICloneable
[SerializableAttribute]
public ref class PayloadNearQuery : public SpanNearQuery,
    ICloneable
[SerializableAttribute]
public ref class PayloadNearQuery : public SpanNearQuery,
    ICloneable
See Also
PayloadNearQuery Members
Lucene.Net.Search.Payloads Namespace
Similarity ScorePayload(Int32, String, Int32, Int32,  Byte , Int32, Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery Members

PayloadNearQuery Members Lucene.Net Class Library

The PayloadNearQuery type exposes the following members.
Constructors
 | Name | Description
Public method | PayloadNearQuery( SpanQuery , Int32, Boolean) | Initializes a new instance of the PayloadNearQuery class
Public method | PayloadNearQuery( SpanQuery , Int32, Boolean, PayloadFunction) | Initializes a new instance of the PayloadNearQuery class
Back to Top
Methods
 | Name | Description
Public method | Clone | (Overrides SpanNearQuery Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides SpanQuery CreateWeight(Searcher).)
Public method | Equals | (Overrides SpanNearQuery Equals(Object).)
Public method | ExtractTerms | (Inherited from SpanNearQuery.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClauses | Return the clauses whose spans are matched. (Inherited from SpanNearQuery.)
Public method | GetHashCode | (Overrides SpanNearQuery GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetSpans | (Inherited from SpanNearQuery.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Inherited from SpanNearQuery.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides SpanNearQuery ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Fields
 | Name | Description
Protected field | clauses | (Inherited from SpanNearQuery.)
Protected field | fieldName |
Protected field | function |
Protected field | inOrder | (Inherited from SpanNearQuery.)
Protected field | internalField | (Inherited from SpanNearQuery.)
Protected field | internalSlop | (Inherited from SpanNearQuery.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Field | (Inherited from SpanNearQuery.)
Public property | IsInOrder | Return true if matches are required to be in-order. (Inherited from SpanNearQuery.)
Public property | Slop | Return the maximum number of intervening unmatched positions permitted. (Inherited from SpanNearQuery.)
Back to Top
See Also
PayloadNearQuery Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery Constructor

PayloadNearQuery Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | PayloadNearQuery( SpanQuery , Int32, Boolean) | Initializes a new instance of the PayloadNearQuery class
Public method | PayloadNearQuery( SpanQuery , Int32, Boolean, PayloadFunction) | Initializes a new instance of the PayloadNearQuery class
Back to Top
See Also
PayloadNearQuery Class
PayloadNearQuery Members
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery Constructor (SpanQuery[], Int32, Boolean)

PayloadNearQuery Constructor ( SpanQuery , Int32, Boolean) Lucene.Net Class Library
Initializes a new instance of the PayloadNearQuery class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PayloadNearQuery(
    SpanQuery[] clauses,
    int slop,
    bool inOrder
)
public PayloadNearQuery(
    SpanQuery[] clauses,
    int slop,
    bool inOrder
)
Public Sub New ( _
    clauses As SpanQuery(), _
    slop As Integer, _
    inOrder As Boolean _
)
Public Sub New ( _
    clauses As SpanQuery(), _
    slop As Integer, _
    inOrder As Boolean _
)
public:
PayloadNearQuery(
    array<SpanQuery^>^ clauses,
    int slop,
    bool inOrder
)
public:
PayloadNearQuery(
    array<SpanQuery^>^ clauses,
    int slop,
    bool inOrder
)
Parameters
clauses
Type:  Lucene.Net.Search.Spans SpanQuery
slop
Type:   Online System Int32
inOrder
Type:   Online System Boolean
See Also
PayloadNearQuery Class
PayloadNearQuery Members
PayloadNearQuery Overload
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery Constructor (SpanQuery[], Int32, Boolean, PayloadFunction)

PayloadNearQuery Constructor ( SpanQuery , Int32, Boolean, PayloadFunction) Lucene.Net Class Library
Initializes a new instance of the PayloadNearQuery class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PayloadNearQuery(
    SpanQuery[] clauses,
    int slop,
    bool inOrder,
    PayloadFunction function
)
public PayloadNearQuery(
    SpanQuery[] clauses,
    int slop,
    bool inOrder,
    PayloadFunction function
)
Public Sub New ( _
    clauses As SpanQuery(), _
    slop As Integer, _
    inOrder As Boolean, _
    function As PayloadFunction _
)
Public Sub New ( _
    clauses As SpanQuery(), _
    slop As Integer, _
    inOrder As Boolean, _
    function As PayloadFunction _
)
public:
PayloadNearQuery(
    array<SpanQuery^>^ clauses,
    int slop,
    bool inOrder,
    PayloadFunction^ function
)
public:
PayloadNearQuery(
    array<SpanQuery^>^ clauses,
    int slop,
    bool inOrder,
    PayloadFunction^ function
)
Parameters
clauses
Type:  Lucene.Net.Search.Spans SpanQuery
slop
Type:   Online System Int32
inOrder
Type:   Online System Boolean
function
Type: Lucene.Net.Search.Payloads PayloadFunction
See Also
PayloadNearQuery Class
PayloadNearQuery Members
PayloadNearQuery Overload
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery Fields

PayloadNearQuery Fields Lucene.Net Class Library
The PayloadNearQuery type exposes the following members.
Fields
 | Name | Description
Protected field | clauses | (Inherited from SpanNearQuery.)
Protected field | fieldName |
Protected field | function |
Protected field | inOrder | (Inherited from SpanNearQuery.)
Protected field | internalField | (Inherited from SpanNearQuery.)
Protected field | internalSlop | (Inherited from SpanNearQuery.)
Back to Top
See Also
PayloadNearQuery Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


fieldName Field

PayloadNearQuery fieldName Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string fieldName
protected string fieldName
Protected fieldName As String
Protected fieldName As String
protected:
String^ fieldName
protected:
String^ fieldName
See Also
PayloadNearQuery Class
PayloadNearQuery Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


function Field

PayloadNearQuery function Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PayloadFunction function
protected PayloadFunction function
Protected function As PayloadFunction
Protected function As PayloadFunction
protected:
PayloadFunction^ function
protected:
PayloadFunction^ function
See Also
PayloadNearQuery Class
PayloadNearQuery Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery Methods

PayloadNearQuery Methods Lucene.Net Class Library
The PayloadNearQuery type exposes the following members.
Methods
 | Name | Description
Public method | Clone | (Overrides SpanNearQuery Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides SpanQuery CreateWeight(Searcher).)
Public method | Equals | (Overrides SpanNearQuery Equals(Object).)
Public method | ExtractTerms | (Inherited from SpanNearQuery.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClauses | Return the clauses whose spans are matched. (Inherited from SpanNearQuery.)
Public method | GetHashCode | (Overrides SpanNearQuery GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetSpans | (Inherited from SpanNearQuery.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Inherited from SpanNearQuery.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides SpanNearQuery ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
PayloadNearQuery Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

PayloadNearQuery Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
  Online ICloneable Clone
See Also
PayloadNearQuery Class
PayloadNearQuery Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateWeight Method

PayloadNearQuery CreateWeight Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Weight CreateWeight(
    Searcher searcher
)
public override Weight CreateWeight(
    Searcher searcher
)
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
PayloadNearQuery Class
PayloadNearQuery Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

PayloadNearQuery Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
PayloadNearQuery Class
PayloadNearQuery Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

PayloadNearQuery GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
PayloadNearQuery Class
PayloadNearQuery Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

PayloadNearQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides SpanNearQuery ToString(String).)
Back to Top
See Also
PayloadNearQuery Class
PayloadNearQuery Members
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

PayloadNearQuery ToString Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
PayloadNearQuery Class
PayloadNearQuery Members
ToString Overload
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery Properties

PayloadNearQuery Properties Lucene.Net Class Library
The PayloadNearQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Field | (Inherited from SpanNearQuery.)
Public property | IsInOrder | Return true if matches are required to be in-order. (Inherited from SpanNearQuery.)
Public property | Slop | Return the maximum number of intervening unmatched positions permitted. (Inherited from SpanNearQuery.)
Back to Top
See Also
PayloadNearQuery Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery.PayloadNearSpanScorer Class

PayloadNearQuery PayloadNearSpanScorer Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSetIterator
Lucene.Net.Search Scorer
Lucene.Net.Search.Spans SpanScorer
Lucene.Net.Search.Payloads PayloadNearQuery PayloadNearSpanScorer

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PayloadNearSpanScorer : SpanScorer
public class PayloadNearSpanScorer : SpanScorer
Public Class PayloadNearSpanScorer _
    Inherits SpanScorer
Public Class PayloadNearSpanScorer _
    Inherits SpanScorer
public ref class PayloadNearSpanScorer : public SpanScorer
public ref class PayloadNearSpanScorer : public SpanScorer
See Also
PayloadNearQuery PayloadNearSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery.PayloadNearSpanScorer Members

PayloadNearQuery PayloadNearSpanScorer Members Lucene.Net Class Library

This class is very similar to SpanNearQuery except that it factors in the value of the payloads located at each of the positions where the TermSpans occurs.

In order to take advantage of this, you must override ScorePayload(Int32, String, Int32, Int32, Byte , Int32, Int32) which returns 1 by default.

Payload scores are aggregated using a pluggable PayloadFunction.

The PayloadNearQuery PayloadNearSpanScorer type exposes the following members.
Constructors
 | Name | Description
Protected method | PayloadNearQuery PayloadNearSpanScorer | Initializes a new instance of the PayloadNearQuery PayloadNearSpanScorer class
Back to Top
Methods
 | Name | Description
Public method | Advance | (Inherited from SpanScorer.)
Public method | DocID | (Inherited from SpanScorer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Explain | (Overrides SpanScorer Explain(Int32).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPayloads |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Inherited from SpanScorer.)
Protected method | ProcessPayloads | By default, uses the PayloadFunction to score the payloads, but can be overridden to do other things.
Public method | Score | (Overrides SpanScorer Score .)
Public method | Score(Collector) | Scores and collects all matching documents. (Inherited from Scorer.)
Public method | Score(Collector, Int32, Int32) | Expert: Collects matching documents in a range. Hook for optimization. Note, firstDocID is added to ensure that NextDoc was called before this method. (Inherited from Scorer.)
Public method | SetFreqCurrentDoc | (Overrides SpanScorer SetFreqCurrentDoc .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | doc | (Inherited from SpanScorer.)
Protected field | freq | (Inherited from SpanScorer.)
Protected field | more | (Inherited from SpanScorer.)
Protected field | norms | (Inherited from SpanScorer.)
Protected field | payloadScore |
Protected field | spans | (Inherited from SpanScorer.)
Protected field | value_Renamed | (Inherited from SpanScorer.)
Protected field | weight | (Inherited from SpanScorer.)
Back to Top
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Similarity | Returns the Similarity implementation used by this scorer. (Inherited from Scorer.)
Back to Top
See Also
PayloadNearQuery PayloadNearSpanScorer Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery.PayloadNearSpanScorer Constructor

PayloadNearQuery PayloadNearSpanScorer Constructor Lucene.Net Class Library
Initializes a new instance of the PayloadNearQuery PayloadNearSpanScorer class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PayloadNearSpanScorer(
    PayloadNearQuery enclosingInstance,
    Spans spans,
    Weight weight,
    Similarity similarity,
    byte[] norms
)
protected PayloadNearSpanScorer(
    PayloadNearQuery enclosingInstance,
    Spans spans,
    Weight weight,
    Similarity similarity,
    byte[] norms
)
Protected Sub New ( _
    enclosingInstance As PayloadNearQuery, _
    spans As Spans, _
    weight As Weight, _
    similarity As Similarity, _
    norms As Byte() _
)
Protected Sub New ( _
    enclosingInstance As PayloadNearQuery, _
    spans As Spans, _
    weight As Weight, _
    similarity As Similarity, _
    norms As Byte() _
)
protected:
PayloadNearSpanScorer(
    PayloadNearQuery^ enclosingInstance,
    Spans^ spans,
    Weight^ weight,
    Similarity^ similarity,
    array<unsigned char>^ norms
)
protected:
PayloadNearSpanScorer(
    PayloadNearQuery^ enclosingInstance,
    Spans^ spans,
    Weight^ weight,
    Similarity^ similarity,
    array<unsigned char>^ norms
)
Parameters
enclosingInstance
Type: Lucene.Net.Search.Payloads PayloadNearQuery
spans
Type: Lucene.Net.Search.Spans Spans
weight
Type: Lucene.Net.Search Weight
similarity
Type: Lucene.Net.Search Similarity
norms
Type:    Online System Byte
See Also
PayloadNearQuery PayloadNearSpanScorer Class
PayloadNearQuery PayloadNearSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery.PayloadNearSpanScorer Fields

PayloadNearQuery PayloadNearSpanScorer Fields Lucene.Net Class Library
The PayloadNearQuery PayloadNearSpanScorer type exposes the following members.
Fields
 | Name | Description
Protected field | doc | (Inherited from SpanScorer.)
Protected field | freq | (Inherited from SpanScorer.)
Protected field | more | (Inherited from SpanScorer.)
Protected field | norms | (Inherited from SpanScorer.)
Protected field | payloadScore |
Protected field | spans | (Inherited from SpanScorer.)
Protected field | value_Renamed | (Inherited from SpanScorer.)
Protected field | weight | (Inherited from SpanScorer.)
Back to Top
See Also
PayloadNearQuery PayloadNearSpanScorer Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


payloadScore Field

PayloadNearQuery PayloadNearSpanScorer payloadScore Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected float payloadScore
protected float payloadScore
Protected payloadScore As Single
Protected payloadScore As Single
protected:
float payloadScore
protected:
float payloadScore
See Also
PayloadNearQuery PayloadNearSpanScorer Class
PayloadNearQuery PayloadNearSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery.PayloadNearSpanScorer Methods

PayloadNearQuery PayloadNearSpanScorer Methods Lucene.Net Class Library
The PayloadNearQuery PayloadNearSpanScorer type exposes the following members.
Methods
 | Name | Description
Public method | Advance | (Inherited from SpanScorer.)
Public method | DocID | (Inherited from SpanScorer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Explain | (Overrides SpanScorer Explain(Int32).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPayloads |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Inherited from SpanScorer.)
Protected method | ProcessPayloads | By default, uses the PayloadFunction to score the payloads, but can be overridden to do other things.
Public method | Score | (Overrides SpanScorer Score .)
Public method | Score(Collector) | Scores and collects all matching documents. (Inherited from Scorer.)
Public method | Score(Collector, Int32, Int32) | Expert: Collects matching documents in a range. Hook for optimization. Note, firstDocID is added to ensure that NextDoc was called before this method. (Inherited from Scorer.)
Public method | SetFreqCurrentDoc | (Overrides SpanScorer SetFreqCurrentDoc .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PayloadNearQuery PayloadNearSpanScorer Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method

PayloadNearQuery PayloadNearSpanScorer Explain Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Explanation Explain(
    int doc
)
protected override Explanation Explain(
    int doc
)
Protected Overrides Function Explain ( _
    doc As Integer _
) As Explanation
Protected Overrides Function Explain ( _
    doc As Integer _
) As Explanation
protected:
virtual Explanation^ Explain(
    int doc
) override
protected:
virtual Explanation^ Explain(
    int doc
) override
Parameters
doc
Type:   Online System Int32
See Also
PayloadNearQuery PayloadNearSpanScorer Class
PayloadNearQuery PayloadNearSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPayloads Method

PayloadNearQuery PayloadNearSpanScorer GetPayloads Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void GetPayloads(
    Spans[] subSpans
)
public virtual void GetPayloads(
    Spans[] subSpans
)
Public Overridable Sub GetPayloads ( _
    subSpans As Spans() _
)
Public Overridable Sub GetPayloads ( _
    subSpans As Spans() _
)
public:
virtual void GetPayloads(
    array<Spans^>^ subSpans
)
public:
virtual void GetPayloads(
    array<Spans^>^ subSpans
)
Parameters
subSpans
Type:  Lucene.Net.Search.Spans Spans
See Also
PayloadNearQuery PayloadNearSpanScorer Class
PayloadNearQuery PayloadNearSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ProcessPayloads Method

PayloadNearQuery PayloadNearSpanScorer ProcessPayloads Method Lucene.Net Class Library
By default, uses the PayloadFunction to score the payloads, but can be overridden to do other things.

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void ProcessPayloads(
    ICollection<byte[]> payLoads,
    int start,
    int end
)
protected virtual void ProcessPayloads(
    ICollection<byte[]> payLoads,
    int start,
    int end
)
Protected Overridable Sub ProcessPayloads ( _
    payLoads As ICollection(Of Byte()), _
    start As Integer, _
    end As Integer _
)
Protected Overridable Sub ProcessPayloads ( _
    payLoads As ICollection(Of Byte()), _
    start As Integer, _
    end As Integer _
)
protected:
virtual void ProcessPayloads(
    ICollection<array<unsigned char>^>^ payLoads,
    int start,
    int end
)
protected:
virtual void ProcessPayloads(
    ICollection<array<unsigned char>^>^ payLoads,
    int start,
    int end
)
Parameters
payLoads
Type:   Online System.Collections.Generic ICollection     Online Byte
The payloads

start
Type:   Online System Int32
The start position of the span being scored

end
Type:   Online System Int32
The end position of the span being scored

See Also
PayloadNearQuery PayloadNearSpanScorer Class
PayloadNearQuery PayloadNearSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Lucene.Net.Search.Spans
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method

PayloadNearQuery PayloadNearSpanScorer Score Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Score | (Overrides SpanScorer Score .)
Public method | Score(Collector) | Scores and collects all matching documents. (Inherited from Scorer.)
Public method | Score(Collector, Int32, Int32) | Expert: Collects matching documents in a range. Hook for optimization. Note, firstDocID is added to ensure that NextDoc was called before this method. (Inherited from Scorer.)
Back to Top
See Also
PayloadNearQuery PayloadNearSpanScorer Class
PayloadNearQuery PayloadNearSpanScorer Members
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method

PayloadNearQuery PayloadNearSpanScorer Score Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Score()
public override float Score()
Public Overrides Function Score As Single
Public Overrides Function Score As Single
public:
virtual float Score() override
public:
virtual float Score() override
See Also
PayloadNearQuery PayloadNearSpanScorer Class
PayloadNearQuery PayloadNearSpanScorer Members
Score Overload
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetFreqCurrentDoc Method

PayloadNearQuery PayloadNearSpanScorer SetFreqCurrentDoc Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool SetFreqCurrentDoc()
public override bool SetFreqCurrentDoc()
Public Overrides Function SetFreqCurrentDoc As Boolean
Public Overrides Function SetFreqCurrentDoc As Boolean
public:
virtual bool SetFreqCurrentDoc() override
public:
virtual bool SetFreqCurrentDoc() override
See Also
PayloadNearQuery PayloadNearSpanScorer Class
PayloadNearQuery PayloadNearSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery.PayloadNearSpanScorer Properties

PayloadNearQuery PayloadNearSpanScorer Properties Lucene.Net Class Library
The PayloadNearQuery PayloadNearSpanScorer type exposes the following members.
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Similarity | Returns the Similarity implementation used by this scorer. (Inherited from Scorer.)
Back to Top
See Also
PayloadNearQuery PayloadNearSpanScorer Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Enclosing_Instance Property

PayloadNearQuery PayloadNearSpanScorer Enclosing_Instance Property Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PayloadNearQuery Enclosing_Instance { get; }
public PayloadNearQuery Enclosing_Instance { get; }
Public ReadOnly Property Enclosing_Instance As PayloadNearQuery
    Get
Public ReadOnly Property Enclosing_Instance As PayloadNearQuery
    Get
public:
property PayloadNearQuery^ Enclosing_Instance {
    PayloadNearQuery^ get ();
}
public:
property PayloadNearQuery^ Enclosing_Instance {
    PayloadNearQuery^ get ();
}
See Also
PayloadNearQuery PayloadNearSpanScorer Class
PayloadNearQuery PayloadNearSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery.PayloadNearSpanWeight Class

PayloadNearQuery PayloadNearSpanWeight Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Weight
Lucene.Net.Search.Spans SpanWeight
Lucene.Net.Search.Payloads PayloadNearQuery PayloadNearSpanWeight

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PayloadNearSpanWeight : SpanWeight
[SerializableAttribute]
public class PayloadNearSpanWeight : SpanWeight
<SerializableAttribute> _
Public Class PayloadNearSpanWeight _
    Inherits SpanWeight
<SerializableAttribute> _
Public Class PayloadNearSpanWeight _
    Inherits SpanWeight
[SerializableAttribute]
public ref class PayloadNearSpanWeight : public SpanWeight
[SerializableAttribute]
public ref class PayloadNearSpanWeight : public SpanWeight
See Also
PayloadNearQuery PayloadNearSpanWeight Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery.PayloadNearSpanWeight Members

PayloadNearQuery PayloadNearSpanWeight Members Lucene.Net Class Library

This class is very similar to SpanNearQuery except that it factors in the value of the payloads located at each of the positions where the TermSpans occurs.

In order to take advantage of this, you must override ScorePayload(Int32, String, Int32, Int32, Byte , Int32, Int32) which returns 1 by default.

Payload scores are aggregated using a pluggable PayloadFunction.

The PayloadNearQuery PayloadNearSpanWeight type exposes the following members.
Constructors
 | Name | Description
Public method | PayloadNearQuery PayloadNearSpanWeight | Initializes a new instance of the PayloadNearQuery PayloadNearSpanWeight class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | (Inherited from SpanWeight.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetScoresDocsOutOfOrder | Returns true iff this implementation scores docs only out of order. This method is used in conjunction with Collector's AcceptsDocsOutOfOrder and Scorer(IndexReader, Boolean, Boolean) to create a matching Scorer(IndexReader, Boolean, Boolean) instance for a given Collector, or vice versa. NOTE: the default implementation returns false, i.e. the Scorer scores documents in-order. (Inherited from Weight.)
Public method | GetSumOfSquaredWeights | (Inherited from SpanWeight.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Normalize | (Inherited from SpanWeight.)
Public method | Scorer | (Overrides SpanWeight Scorer(IndexReader, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | idf | (Inherited from SpanWeight.)
Protected field | internalQuery | (Inherited from SpanWeight.)
Protected field | queryNorm | (Inherited from SpanWeight.)
Protected field | queryWeight | (Inherited from SpanWeight.)
Protected field | similarity | (Inherited from SpanWeight.)
Protected field | terms | (Inherited from SpanWeight.)
Protected field | value_Renamed | (Inherited from SpanWeight.)
Back to Top
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Query | (Inherited from SpanWeight.)
Public property | Value | (Inherited from SpanWeight.)
Back to Top
See Also
PayloadNearQuery PayloadNearSpanWeight Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery.PayloadNearSpanWeight Constructor

PayloadNearQuery PayloadNearSpanWeight Constructor Lucene.Net Class Library
Initializes a new instance of the PayloadNearQuery PayloadNearSpanWeight class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PayloadNearSpanWeight(
    PayloadNearQuery enclosingInstance,
    SpanQuery query,
    Searcher searcher
)
public PayloadNearSpanWeight(
    PayloadNearQuery enclosingInstance,
    SpanQuery query,
    Searcher searcher
)
Public Sub New ( _
    enclosingInstance As PayloadNearQuery, _
    query As SpanQuery, _
    searcher As Searcher _
)
Public Sub New ( _
    enclosingInstance As PayloadNearQuery, _
    query As SpanQuery, _
    searcher As Searcher _
)
public:
PayloadNearSpanWeight(
    PayloadNearQuery^ enclosingInstance,
    SpanQuery^ query,
    Searcher^ searcher
)
public:
PayloadNearSpanWeight(
    PayloadNearQuery^ enclosingInstance,
    SpanQuery^ query,
    Searcher^ searcher
)
Parameters
enclosingInstance
Type: Lucene.Net.Search.Payloads PayloadNearQuery
query
Type: Lucene.Net.Search.Spans SpanQuery
searcher
Type: Lucene.Net.Search Searcher
See Also
PayloadNearQuery PayloadNearSpanWeight Class
PayloadNearQuery PayloadNearSpanWeight Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery.PayloadNearSpanWeight Fields

PayloadNearQuery PayloadNearSpanWeight Fields Lucene.Net Class Library
The PayloadNearQuery PayloadNearSpanWeight type exposes the following members.
Fields
 | Name | Description
Protected field | idf | (Inherited from SpanWeight.)
Protected field | internalQuery | (Inherited from SpanWeight.)
Protected field | queryNorm | (Inherited from SpanWeight.)
Protected field | queryWeight | (Inherited from SpanWeight.)
Protected field | similarity | (Inherited from SpanWeight.)
Protected field | terms | (Inherited from SpanWeight.)
Protected field | value_Renamed | (Inherited from SpanWeight.)
Back to Top
See Also
PayloadNearQuery PayloadNearSpanWeight Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery.PayloadNearSpanWeight Methods

PayloadNearQuery PayloadNearSpanWeight Methods Lucene.Net Class Library
The PayloadNearQuery PayloadNearSpanWeight type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | (Inherited from SpanWeight.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetScoresDocsOutOfOrder | Returns true iff this implementation scores docs only out of order. This method is used in conjunction with Collector's AcceptsDocsOutOfOrder and Scorer(IndexReader, Boolean, Boolean) to create a matching Scorer(IndexReader, Boolean, Boolean) instance for a given Collector, or vice versa. NOTE: the default implementation returns false, i.e. the Scorer scores documents in-order. (Inherited from Weight.)
Public method | GetSumOfSquaredWeights | (Inherited from SpanWeight.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Normalize | (Inherited from SpanWeight.)
Public method | Scorer | (Overrides SpanWeight Scorer(IndexReader, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PayloadNearQuery PayloadNearSpanWeight Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Scorer Method

PayloadNearQuery PayloadNearSpanWeight Scorer Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
scoreDocsInOrder
Type:   Online System Boolean
topScorer
Type:   Online System Boolean
See Also
PayloadNearQuery PayloadNearSpanWeight Class
PayloadNearQuery PayloadNearSpanWeight Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadNearQuery.PayloadNearSpanWeight Properties

PayloadNearQuery PayloadNearSpanWeight Properties Lucene.Net Class Library
The PayloadNearQuery PayloadNearSpanWeight type exposes the following members.
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Query | (Inherited from SpanWeight.)
Public property | Value | (Inherited from SpanWeight.)
Back to Top
See Also
PayloadNearQuery PayloadNearSpanWeight Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Enclosing_Instance Property

PayloadNearQuery PayloadNearSpanWeight Enclosing_Instance Property Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PayloadNearQuery Enclosing_Instance { get; }
public PayloadNearQuery Enclosing_Instance { get; }
Public ReadOnly Property Enclosing_Instance As PayloadNearQuery
    Get
Public ReadOnly Property Enclosing_Instance As PayloadNearQuery
    Get
public:
property PayloadNearQuery^ Enclosing_Instance {
    PayloadNearQuery^ get ();
}
public:
property PayloadNearQuery^ Enclosing_Instance {
    PayloadNearQuery^ get ();
}
See Also
PayloadNearQuery PayloadNearSpanWeight Class
PayloadNearQuery PayloadNearSpanWeight Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadSpanUtil Class

PayloadSpanUtil Class Lucene.Net Class Library
Experimental class to get set of payloads for most standard Lucene queries. Operates like Highlighter - IndexReader should only contain doc of interest, best to use MemoryIndex.

WARNING: The status of the Payloads feature is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Payloads PayloadSpanUtil

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PayloadSpanUtil
public class PayloadSpanUtil
Public Class PayloadSpanUtil
Public Class PayloadSpanUtil
public ref class PayloadSpanUtil
public ref class PayloadSpanUtil
See Also
PayloadSpanUtil Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadSpanUtil Members

PayloadSpanUtil Members Lucene.Net Class Library

The PayloadSpanUtil type exposes the following members.
Constructors
 | Name | Description
Public method | PayloadSpanUtil | Initializes a new instance of the PayloadSpanUtil class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPayloadsForQuery | Query should be rewritten for wild/fuzzy support.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PayloadSpanUtil Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadSpanUtil Constructor

PayloadSpanUtil Constructor Lucene.Net Class Library
Initializes a new instance of the PayloadSpanUtil class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PayloadSpanUtil(
    IndexReader reader
)
public PayloadSpanUtil(
    IndexReader reader
)
Public Sub New ( _
    reader As IndexReader _
)
Public Sub New ( _
    reader As IndexReader _
)
public:
PayloadSpanUtil(
    IndexReader^ reader
)
public:
PayloadSpanUtil(
    IndexReader^ reader
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
that contains doc with payloads to extract

See Also
PayloadSpanUtil Class
PayloadSpanUtil Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadSpanUtil Methods

PayloadSpanUtil Methods Lucene.Net Class Library
The PayloadSpanUtil type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPayloadsForQuery | Query should be rewritten for wild/fuzzy support.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PayloadSpanUtil Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPayloadsForQuery Method

PayloadSpanUtil GetPayloadsForQuery Method Lucene.Net Class Library
Query should be rewritten for wild/fuzzy support.

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual ICollection<byte[]> GetPayloadsForQuery(
    Query query
)
public virtual ICollection<byte[]> GetPayloadsForQuery(
    Query query
)
Public Overridable Function GetPayloadsForQuery ( _
    query As Query _
) As ICollection(Of Byte())
Public Overridable Function GetPayloadsForQuery ( _
    query As Query _
) As ICollection(Of Byte())
public:
virtual ICollection<array<unsigned char>^>^ GetPayloadsForQuery(
    Query^ query
)
public:
virtual ICollection<array<unsigned char>^>^ GetPayloadsForQuery(
    Query^ query
)
Parameters
query
Type: Lucene.Net.Search Query
Return Value
 payloads Collection

See Also
PayloadSpanUtil Class
PayloadSpanUtil Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery Class

PayloadTermQuery Class Lucene.Net Class Library
This class is very similar to SpanTermQuery except that it factors in the value of the payload located at each of the positions where the Term occurs.

In order to take advantage of this, you must override ScorePayload(Int32, String, Int32, Int32, Byte , Int32, Int32) which returns 1 by default.

Payload scores are aggregated using a pluggable PayloadFunction.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search.Spans SpanQuery
Lucene.Net.Search.Spans SpanTermQuery
Lucene.Net.Search.Payloads PayloadTermQuery

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PayloadTermQuery : SpanTermQuery
[SerializableAttribute]
public class PayloadTermQuery : SpanTermQuery
<SerializableAttribute> _
Public Class PayloadTermQuery _
    Inherits SpanTermQuery
<SerializableAttribute> _
Public Class PayloadTermQuery _
    Inherits SpanTermQuery
[SerializableAttribute]
public ref class PayloadTermQuery : public SpanTermQuery
[SerializableAttribute]
public ref class PayloadTermQuery : public SpanTermQuery
See Also
PayloadTermQuery Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery Members

PayloadTermQuery Members Lucene.Net Class Library

The PayloadTermQuery type exposes the following members.
Constructors
 | Name | Description
Public method | PayloadTermQuery(Term, PayloadFunction) | Initializes a new instance of the PayloadTermQuery class
Public method | PayloadTermQuery(Term, PayloadFunction, Boolean) | Initializes a new instance of the PayloadTermQuery class
Back to Top
Methods
 | Name | Description
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides SpanQuery CreateWeight(Searcher).)
Public method | Equals | (Overrides SpanTermQuery Equals(Object).)
Public method | ExtractTerms | (Inherited from SpanTermQuery.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides SpanTermQuery GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetSpans | (Inherited from SpanTermQuery.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys. (Inherited from Query.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Inherited from SpanTermQuery.)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Fields
 | Name | Description
Protected field | function |
Protected field | internalTerm | (Inherited from SpanTermQuery.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Field | (Inherited from SpanTermQuery.)
Public property | Term | Return the term whose spans are matched. (Inherited from SpanTermQuery.)
Back to Top
See Also
PayloadTermQuery Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery Constructor

PayloadTermQuery Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | PayloadTermQuery(Term, PayloadFunction) | Initializes a new instance of the PayloadTermQuery class
Public method | PayloadTermQuery(Term, PayloadFunction, Boolean) | Initializes a new instance of the PayloadTermQuery class
Back to Top
See Also
PayloadTermQuery Class
PayloadTermQuery Members
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery Constructor (Term, PayloadFunction)

PayloadTermQuery Constructor (Term, PayloadFunction) Lucene.Net Class Library
Initializes a new instance of the PayloadTermQuery class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PayloadTermQuery(
    Term term,
    PayloadFunction function
)
public PayloadTermQuery(
    Term term,
    PayloadFunction function
)
Public Sub New ( _
    term As Term, _
    function As PayloadFunction _
)
Public Sub New ( _
    term As Term, _
    function As PayloadFunction _
)
public:
PayloadTermQuery(
    Term^ term,
    PayloadFunction^ function
)
public:
PayloadTermQuery(
    Term^ term,
    PayloadFunction^ function
)
Parameters
term
Type: Lucene.Net.Index Term
function
Type: Lucene.Net.Search.Payloads PayloadFunction
See Also
PayloadTermQuery Class
PayloadTermQuery Members
PayloadTermQuery Overload
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery Constructor (Term, PayloadFunction, Boolean)

PayloadTermQuery Constructor (Term, PayloadFunction, Boolean) Lucene.Net Class Library
Initializes a new instance of the PayloadTermQuery class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PayloadTermQuery(
    Term term,
    PayloadFunction function,
    bool includeSpanScore
)
public PayloadTermQuery(
    Term term,
    PayloadFunction function,
    bool includeSpanScore
)
Public Sub New ( _
    term As Term, _
    function As PayloadFunction, _
    includeSpanScore As Boolean _
)
Public Sub New ( _
    term As Term, _
    function As PayloadFunction, _
    includeSpanScore As Boolean _
)
public:
PayloadTermQuery(
    Term^ term,
    PayloadFunction^ function,
    bool includeSpanScore
)
public:
PayloadTermQuery(
    Term^ term,
    PayloadFunction^ function,
    bool includeSpanScore
)
Parameters
term
Type: Lucene.Net.Index Term
function
Type: Lucene.Net.Search.Payloads PayloadFunction
includeSpanScore
Type:   Online System Boolean
See Also
PayloadTermQuery Class
PayloadTermQuery Members
PayloadTermQuery Overload
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery Fields

PayloadTermQuery Fields Lucene.Net Class Library
The PayloadTermQuery type exposes the following members.
Fields
 | Name | Description
Protected field | function |
Protected field | internalTerm | (Inherited from SpanTermQuery.)
Back to Top
See Also
PayloadTermQuery Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


function Field

PayloadTermQuery function Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PayloadFunction function
protected PayloadFunction function
Protected function As PayloadFunction
Protected function As PayloadFunction
protected:
PayloadFunction^ function
protected:
PayloadFunction^ function
See Also
PayloadTermQuery Class
PayloadTermQuery Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery Methods

PayloadTermQuery Methods Lucene.Net Class Library
The PayloadTermQuery type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides SpanQuery CreateWeight(Searcher).)
Public method | Equals | (Overrides SpanTermQuery Equals(Object).)
Public method | ExtractTerms | (Inherited from SpanTermQuery.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides SpanTermQuery GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetSpans | (Inherited from SpanTermQuery.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys. (Inherited from Query.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Inherited from SpanTermQuery.)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
PayloadTermQuery Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateWeight Method

PayloadTermQuery CreateWeight Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Weight CreateWeight(
    Searcher searcher
)
public override Weight CreateWeight(
    Searcher searcher
)
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
PayloadTermQuery Class
PayloadTermQuery Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

PayloadTermQuery Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
PayloadTermQuery Class
PayloadTermQuery Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

PayloadTermQuery GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
PayloadTermQuery Class
PayloadTermQuery Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery Properties

PayloadTermQuery Properties Lucene.Net Class Library
The PayloadTermQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Field | (Inherited from SpanTermQuery.)
Public property | Term | Return the term whose spans are matched. (Inherited from SpanTermQuery.)
Back to Top
See Also
PayloadTermQuery Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery.PayloadTermWeight Class

PayloadTermQuery PayloadTermWeight Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Weight
Lucene.Net.Search.Spans SpanWeight
Lucene.Net.Search.Payloads PayloadTermQuery PayloadTermWeight

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
protected internal class PayloadTermWeight : SpanWeight
[SerializableAttribute]
protected internal class PayloadTermWeight : SpanWeight
<SerializableAttribute> _
Protected Friend Class PayloadTermWeight _
    Inherits SpanWeight
<SerializableAttribute> _
Protected Friend Class PayloadTermWeight _
    Inherits SpanWeight
[SerializableAttribute]
protected public ref class PayloadTermWeight : public SpanWeight
[SerializableAttribute]
protected public ref class PayloadTermWeight : public SpanWeight
See Also
PayloadTermQuery PayloadTermWeight Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery.PayloadTermWeight Members

PayloadTermQuery PayloadTermWeight Members Lucene.Net Class Library

This class is very similar to SpanTermQuery except that it factors in the value of the payload located at each of the positions where the Term occurs.

In order to take advantage of this, you must override ScorePayload(Int32, String, Int32, Int32, Byte , Int32, Int32) which returns 1 by default.

Payload scores are aggregated using a pluggable PayloadFunction.

The PayloadTermQuery PayloadTermWeight type exposes the following members.
Constructors
 | Name | Description
Public method | PayloadTermQuery PayloadTermWeight | Initializes a new instance of the PayloadTermQuery PayloadTermWeight class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | (Inherited from SpanWeight.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetScoresDocsOutOfOrder | Returns true iff this implementation scores docs only out of order. This method is used in conjunction with Collector's AcceptsDocsOutOfOrder and Scorer(IndexReader, Boolean, Boolean) to create a matching Scorer(IndexReader, Boolean, Boolean) instance for a given Collector, or vice versa. NOTE: the default implementation returns false, i.e. the Scorer scores documents in-order. (Inherited from Weight.)
Public method | GetSumOfSquaredWeights | (Inherited from SpanWeight.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Normalize | (Inherited from SpanWeight.)
Public method | Scorer | (Overrides SpanWeight Scorer(IndexReader, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | idf | (Inherited from SpanWeight.)
Protected field | internalQuery | (Inherited from SpanWeight.)
Protected field | queryNorm | (Inherited from SpanWeight.)
Protected field | queryWeight | (Inherited from SpanWeight.)
Protected field | similarity | (Inherited from SpanWeight.)
Protected field | terms | (Inherited from SpanWeight.)
Protected field | value_Renamed | (Inherited from SpanWeight.)
Back to Top
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Query | (Inherited from SpanWeight.)
Public property | Value | (Inherited from SpanWeight.)
Back to Top
See Also
PayloadTermQuery PayloadTermWeight Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery.PayloadTermWeight Constructor

PayloadTermQuery PayloadTermWeight Constructor Lucene.Net Class Library
Initializes a new instance of the PayloadTermQuery PayloadTermWeight class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PayloadTermWeight(
    PayloadTermQuery enclosingInstance,
    PayloadTermQuery query,
    Searcher searcher
)
public PayloadTermWeight(
    PayloadTermQuery enclosingInstance,
    PayloadTermQuery query,
    Searcher searcher
)
Public Sub New ( _
    enclosingInstance As PayloadTermQuery, _
    query As PayloadTermQuery, _
    searcher As Searcher _
)
Public Sub New ( _
    enclosingInstance As PayloadTermQuery, _
    query As PayloadTermQuery, _
    searcher As Searcher _
)
public:
PayloadTermWeight(
    PayloadTermQuery^ enclosingInstance,
    PayloadTermQuery^ query,
    Searcher^ searcher
)
public:
PayloadTermWeight(
    PayloadTermQuery^ enclosingInstance,
    PayloadTermQuery^ query,
    Searcher^ searcher
)
Parameters
enclosingInstance
Type: Lucene.Net.Search.Payloads PayloadTermQuery
query
Type: Lucene.Net.Search.Payloads PayloadTermQuery
searcher
Type: Lucene.Net.Search Searcher
See Also
PayloadTermQuery PayloadTermWeight Class
PayloadTermQuery PayloadTermWeight Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery.PayloadTermWeight Fields

PayloadTermQuery PayloadTermWeight Fields Lucene.Net Class Library
The PayloadTermQuery PayloadTermWeight type exposes the following members.
Fields
 | Name | Description
Protected field | idf | (Inherited from SpanWeight.)
Protected field | internalQuery | (Inherited from SpanWeight.)
Protected field | queryNorm | (Inherited from SpanWeight.)
Protected field | queryWeight | (Inherited from SpanWeight.)
Protected field | similarity | (Inherited from SpanWeight.)
Protected field | terms | (Inherited from SpanWeight.)
Protected field | value_Renamed | (Inherited from SpanWeight.)
Back to Top
See Also
PayloadTermQuery PayloadTermWeight Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery.PayloadTermWeight Methods

PayloadTermQuery PayloadTermWeight Methods Lucene.Net Class Library
The PayloadTermQuery PayloadTermWeight type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | (Inherited from SpanWeight.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetScoresDocsOutOfOrder | Returns true iff this implementation scores docs only out of order. This method is used in conjunction with Collector's AcceptsDocsOutOfOrder and Scorer(IndexReader, Boolean, Boolean) to create a matching Scorer(IndexReader, Boolean, Boolean) instance for a given Collector, or vice versa. NOTE: the default implementation returns false, i.e. the Scorer scores documents in-order. (Inherited from Weight.)
Public method | GetSumOfSquaredWeights | (Inherited from SpanWeight.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Normalize | (Inherited from SpanWeight.)
Public method | Scorer | (Overrides SpanWeight Scorer(IndexReader, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PayloadTermQuery PayloadTermWeight Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Scorer Method

PayloadTermQuery PayloadTermWeight Scorer Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
scoreDocsInOrder
Type:   Online System Boolean
topScorer
Type:   Online System Boolean
See Also
PayloadTermQuery PayloadTermWeight Class
PayloadTermQuery PayloadTermWeight Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery.PayloadTermWeight Properties

PayloadTermQuery PayloadTermWeight Properties Lucene.Net Class Library
The PayloadTermQuery PayloadTermWeight type exposes the following members.
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Query | (Inherited from SpanWeight.)
Public property | Value | (Inherited from SpanWeight.)
Back to Top
See Also
PayloadTermQuery PayloadTermWeight Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Enclosing_Instance Property

PayloadTermQuery PayloadTermWeight Enclosing_Instance Property Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PayloadTermQuery Enclosing_Instance { get; }
public PayloadTermQuery Enclosing_Instance { get; }
Public ReadOnly Property Enclosing_Instance As PayloadTermQuery
    Get
Public ReadOnly Property Enclosing_Instance As PayloadTermQuery
    Get
public:
property PayloadTermQuery^ Enclosing_Instance {
    PayloadTermQuery^ get ();
}
public:
property PayloadTermQuery^ Enclosing_Instance {
    PayloadTermQuery^ get ();
}
See Also
PayloadTermQuery PayloadTermWeight Class
PayloadTermQuery PayloadTermWeight Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer Class

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSetIterator
Lucene.Net.Search Scorer
Lucene.Net.Search.Spans SpanScorer
Lucene.Net.Search.Payloads PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal class PayloadTermSpanScorer : SpanScorer
protected internal class PayloadTermSpanScorer : SpanScorer
Protected Friend Class PayloadTermSpanScorer _
    Inherits SpanScorer
Protected Friend Class PayloadTermSpanScorer _
    Inherits SpanScorer
protected public ref class PayloadTermSpanScorer : public SpanScorer
protected public ref class PayloadTermSpanScorer : public SpanScorer
See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer Members

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Members Lucene.Net Class Library

The PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer type exposes the following members.
Constructors
 | Name | Description
Public method | PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer | Initializes a new instance of the PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer class
Back to Top
Methods
 | Name | Description
Public method | Advance | (Inherited from SpanScorer.)
Public method | DocID | (Inherited from SpanScorer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Explain | (Overrides SpanScorer Explain(Int32).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Protected method | GetPayloadScore | The score for the payload
Protected method | GetSpanScore | Returns the SpanScorer score only. Should not be overriden without good cause!
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Inherited from SpanScorer.)
Protected method | ProcessPayload |
Public method | Score | (Overrides SpanScorer Score .)
Public method | Score(Collector) | Scores and collects all matching documents. (Inherited from Scorer.)
Public method | Score(Collector, Int32, Int32) | Expert: Collects matching documents in a range. Hook for optimization. Note, firstDocID is added to ensure that NextDoc was called before this method. (Inherited from Scorer.)
Public method | SetFreqCurrentDoc | (Overrides SpanScorer SetFreqCurrentDoc .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | doc | (Inherited from SpanScorer.)
Protected field | freq | (Inherited from SpanScorer.)
Protected field | more | (Inherited from SpanScorer.)
Protected field | norms | (Inherited from SpanScorer.)
Protected field | payload |
Protected field | payloadScore |
Protected field | payloadsSeen |
Protected field | positions |
Protected field | spans | (Inherited from SpanScorer.)
Protected field | value_Renamed | (Inherited from SpanScorer.)
Protected field | weight | (Inherited from SpanScorer.)
Back to Top
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Similarity | Returns the Similarity implementation used by this scorer. (Inherited from Scorer.)
Back to Top
See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer Constructor

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Constructor Lucene.Net Class Library
Initializes a new instance of the PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PayloadTermSpanScorer(
    PayloadTermQuery..::..PayloadTermWeight enclosingInstance,
    TermSpans spans,
    Weight weight,
    Similarity similarity,
    byte[] norms
)
public PayloadTermSpanScorer(
    PayloadTermQuery..::..PayloadTermWeight enclosingInstance,
    TermSpans spans,
    Weight weight,
    Similarity similarity,
    byte[] norms
)
Public Sub New ( _
    enclosingInstance As PayloadTermQuery..::..PayloadTermWeight, _
    spans As TermSpans, _
    weight As Weight, _
    similarity As Similarity, _
    norms As Byte() _
)
Public Sub New ( _
    enclosingInstance As PayloadTermQuery..::..PayloadTermWeight, _
    spans As TermSpans, _
    weight As Weight, _
    similarity As Similarity, _
    norms As Byte() _
)
public:
PayloadTermSpanScorer(
    PayloadTermQuery..::..PayloadTermWeight^ enclosingInstance,
    TermSpans^ spans,
    Weight^ weight,
    Similarity^ similarity,
    array<unsigned char>^ norms
)
public:
PayloadTermSpanScorer(
    PayloadTermQuery..::..PayloadTermWeight^ enclosingInstance,
    TermSpans^ spans,
    Weight^ weight,
    Similarity^ similarity,
    array<unsigned char>^ norms
)
Parameters
enclosingInstance
Type: Lucene.Net.Search.Payloads PayloadTermQuery PayloadTermWeight
spans
Type: Lucene.Net.Search.Spans TermSpans
weight
Type: Lucene.Net.Search Weight
similarity
Type: Lucene.Net.Search Similarity
norms
Type:    Online System Byte
See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer Fields

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Fields Lucene.Net Class Library
The PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer type exposes the following members.
Fields
 | Name | Description
Protected field | doc | (Inherited from SpanScorer.)
Protected field | freq | (Inherited from SpanScorer.)
Protected field | more | (Inherited from SpanScorer.)
Protected field | norms | (Inherited from SpanScorer.)
Protected field | payload |
Protected field | payloadScore |
Protected field | payloadsSeen |
Protected field | positions |
Protected field | spans | (Inherited from SpanScorer.)
Protected field | value_Renamed | (Inherited from SpanScorer.)
Protected field | weight | (Inherited from SpanScorer.)
Back to Top
See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


payload Field

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer payload Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected byte[] payload
protected byte[] payload
Protected payload As Byte()
Protected payload As Byte()
protected:
array<unsigned char>^ payload
protected:
array<unsigned char>^ payload
See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


payloadScore Field

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer payloadScore Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected float payloadScore
protected float payloadScore
Protected payloadScore As Single
Protected payloadScore As Single
protected:
float payloadScore
protected:
float payloadScore
See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


payloadsSeen Field

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer payloadsSeen Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int payloadsSeen
protected int payloadsSeen
Protected payloadsSeen As Integer
Protected payloadsSeen As Integer
protected:
int payloadsSeen
protected:
int payloadsSeen
See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


positions Field

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer positions Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TermPositions positions
protected TermPositions positions
Protected positions As TermPositions
Protected positions As TermPositions
protected:
TermPositions^ positions
protected:
TermPositions^ positions
See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer Methods

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Methods Lucene.Net Class Library
The PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer type exposes the following members.
Methods
 | Name | Description
Public method | Advance | (Inherited from SpanScorer.)
Public method | DocID | (Inherited from SpanScorer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Explain | (Overrides SpanScorer Explain(Int32).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Protected method | GetPayloadScore | The score for the payload
Protected method | GetSpanScore | Returns the SpanScorer score only. Should not be overriden without good cause!
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Inherited from SpanScorer.)
Protected method | ProcessPayload |
Public method | Score | (Overrides SpanScorer Score .)
Public method | Score(Collector) | Scores and collects all matching documents. (Inherited from Scorer.)
Public method | Score(Collector, Int32, Int32) | Expert: Collects matching documents in a range. Hook for optimization. Note, firstDocID is added to ensure that NextDoc was called before this method. (Inherited from Scorer.)
Public method | SetFreqCurrentDoc | (Overrides SpanScorer SetFreqCurrentDoc .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Explain Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Explanation Explain(
    int doc
)
protected override Explanation Explain(
    int doc
)
Protected Overrides Function Explain ( _
    doc As Integer _
) As Explanation
Protected Overrides Function Explain ( _
    doc As Integer _
) As Explanation
protected:
virtual Explanation^ Explain(
    int doc
) override
protected:
virtual Explanation^ Explain(
    int doc
) override
Parameters
doc
Type:   Online System Int32
See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPayloadScore Method

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer GetPayloadScore Method Lucene.Net Class Library
The score for the payload

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual float GetPayloadScore()
protected virtual float GetPayloadScore()
Protected Overridable Function GetPayloadScore As Single
Protected Overridable Function GetPayloadScore As Single
protected:
virtual float GetPayloadScore()
protected:
virtual float GetPayloadScore()
Return Value
 The score, as calculated by
            DocScore(Int32, String, Int32, Single)
See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSpanScore Method

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer GetSpanScore Method Lucene.Net Class Library
Returns the SpanScorer score only.

Should not be overriden without good cause!

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual float GetSpanScore()
protected virtual float GetSpanScore()
Protected Overridable Function GetSpanScore As Single
Protected Overridable Function GetSpanScore As Single
protected:
virtual float GetSpanScore()
protected:
virtual float GetSpanScore()
Return Value
 the score for just the Span part w/o the payload

See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Members
Lucene.Net.Search.Payloads Namespace
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Score
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ProcessPayload Method

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer ProcessPayload Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void ProcessPayload(
    Similarity similarity
)
protected virtual void ProcessPayload(
    Similarity similarity
)
Protected Overridable Sub ProcessPayload ( _
    similarity As Similarity _
)
Protected Overridable Sub ProcessPayload ( _
    similarity As Similarity _
)
protected:
virtual void ProcessPayload(
    Similarity^ similarity
)
protected:
virtual void ProcessPayload(
    Similarity^ similarity
)
Parameters
similarity
Type: Lucene.Net.Search Similarity
See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Score Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Score | (Overrides SpanScorer Score .)
Public method | Score(Collector) | Scores and collects all matching documents. (Inherited from Scorer.)
Public method | Score(Collector, Int32, Int32) | Expert: Collects matching documents in a range. Hook for optimization. Note, firstDocID is added to ensure that NextDoc was called before this method. (Inherited from Scorer.)
Back to Top
See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Members
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Score Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Score()
public override float Score()
Public Overrides Function Score As Single
Public Overrides Function Score As Single
public:
virtual float Score() override
public:
virtual float Score() override
Return Value
GetSpanScore  * GetPayloadScore
See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Members
Score Overload
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetFreqCurrentDoc Method

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer SetFreqCurrentDoc Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool SetFreqCurrentDoc()
public override bool SetFreqCurrentDoc()
Public Overrides Function SetFreqCurrentDoc As Boolean
Public Overrides Function SetFreqCurrentDoc As Boolean
public:
virtual bool SetFreqCurrentDoc() override
public:
virtual bool SetFreqCurrentDoc() override
See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer Properties

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Properties Lucene.Net Class Library
The PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer type exposes the following members.
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | Similarity | Returns the Similarity implementation used by this scorer. (Inherited from Scorer.)
Back to Top
See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Enclosing_Instance Property

PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Enclosing_Instance Property Lucene.Net Class Library

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PayloadTermQuery..::..PayloadTermWeight Enclosing_Instance { get; }
public PayloadTermQuery..::..PayloadTermWeight Enclosing_Instance { get; }
Public ReadOnly Property Enclosing_Instance As PayloadTermQuery..::..PayloadTermWeight
    Get
Public ReadOnly Property Enclosing_Instance As PayloadTermQuery..::..PayloadTermWeight
    Get
public:
property PayloadTermQuery..::..PayloadTermWeight^ Enclosing_Instance {
    PayloadTermQuery..::..PayloadTermWeight^ get ();
}
public:
property PayloadTermQuery..::..PayloadTermWeight^ Enclosing_Instance {
    PayloadTermQuery..::..PayloadTermWeight^ get ();
}
See Also
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Class
PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer Members
Lucene.Net.Search.Payloads Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lucene.Net.Search.Spans Namespace

Lucene.Net.Search.Spans Namespace Lucene.Net Class Library
Classes
Class Description
Public class FieldMaskingSpanQuery

Wrapper to allow SpanQuery objects participate in composite single-field SpanQueries by 'lying' about their search field. That is, the masked SpanQuery will function as normal, but Field simply hands back the value supplied in this class's constructor.

This can be used to support Queries like SpanNearQuery or SpanOrQuery across different fields, which is not ordinarily permitted.

This can be useful for denormalized relational data: for example, when indexing a document with conceptually many 'children':

            teacherid: 1
            studentfirstname: james
            studentsurname: jones

            teacherid: 2
            studenfirstname: james
            studentsurname: smith
            studentfirstname: sally
            studentsurname: jones

a SpanNearQuery with a slop of 0 can be applied across two SpanTermQuery objects as follows:
View Colorized Copy to Clipboard Print
SpanQuery q1  = new SpanTermQuery(new Term("studentfirstname", "james"));
SpanQuery q2  = new SpanTermQuery(new Term("studentsurname", "jones"));
SpanQuery q2m new FieldMaskingSpanQuery(q2, "studentfirstname");
Query q = new SpanNearQuery(new SpanQuery[]{q1, q2m}, -1, false);
SpanQuery q1  = new SpanTermQuery(new Term("studentfirstname", "james"));
SpanQuery q2  = new SpanTermQuery(new Term("studentsurname", "jones"));
SpanQuery q2m new FieldMaskingSpanQuery(q2, "studentfirstname");
Query q = new SpanNearQuery(new SpanQuery[]{q1, q2m}, -1, false);
to search for 'studentfirstname:james studentsurname:jones' and find teacherid 1 without matching teacherid 2 (which has a 'james' in position 0 and 'jones' in position 1).

Note: as Field returns the masked field, scoring will be done using the norms of the field name supplied. This may lead to unexpected scoring behaviour.

Public class NearSpansOrdered
A Spans that is formed from the ordered subspans of a SpanNearQuery where the subspans do not overlap and have a maximum slop between them.

The formed spans only contains minimum slop matches.
The matching slop is computed from the distance(s) between the non overlapping matching Spans.
Successive matches are always formed from the successive Spans of the SpanNearQuery.

The formed spans may contain overlaps when the slop is at least 1. For example, when querying using t1 t2 t3 with slop at least 1, the fragment: t1 t2 t1 t3 t2 t3 matches twice: t1 t2 .. t3 t1 .. t2 t3 Expert: Only public for subclassing. Most implementations should not need this class
Public class NearSpansUnordered
Similar to NearSpansOrdered, but for the unordered case. Expert: Only public for subclassing. Most implementations should not need this class
Public class SpanFirstQuery
Matches spans near the beginning of a field.
Public class SpanNearQuery
Matches spans which are near one another. One can specify slop, the maximum number of intervening unmatched positions, as well as whether matches are required to be in-order.
Public class SpanNotQuery
Removes matches which overlap with another SpanQuery.
Public class SpanOrQuery
Matches the union of its clauses.
Public class SpanQuery
Base class for span-based queries.
Public class Spans
Expert: an enumeration of span matches. Used to implement span searching. Each span represents a range of term positions within a document. Matches are enumerated in order, by increasing document number, within that by increasing start position and finally by increasing end position.
Public class SpanScorer
Public for extension only.
Public class SpanTermQuery
Matches spans containing a term.
Public class SpanWeight
Expert-only. Public for use by other weight implementations
Public class TermSpans
Expert: Public for extension only

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldMaskingSpanQuery Class

FieldMaskingSpanQuery Class Lucene.Net Class Library

Wrapper to allow SpanQuery objects participate in composite single-field SpanQueries by 'lying' about their search field. That is, the masked SpanQuery will function as normal, but Field simply hands back the value supplied in this class's constructor.

This can be used to support Queries like SpanNearQuery or SpanOrQuery across different fields, which is not ordinarily permitted.

This can be useful for denormalized relational data: for example, when indexing a document with conceptually many 'children':

            teacherid: 1
            studentfirstname: james
            studentsurname: jones

            teacherid: 2
            studenfirstname: james
            studentsurname: smith
            studentfirstname: sally
            studentsurname: jones

a SpanNearQuery with a slop of 0 can be applied across two SpanTermQuery objects as follows:
View Colorized Copy to Clipboard Print
SpanQuery q1  = new SpanTermQuery(new Term("studentfirstname", "james"));
SpanQuery q2  = new SpanTermQuery(new Term("studentsurname", "jones"));
SpanQuery q2m new FieldMaskingSpanQuery(q2, "studentfirstname");
Query q = new SpanNearQuery(new SpanQuery[]{q1, q2m}, -1, false);
SpanQuery q1  = new SpanTermQuery(new Term("studentfirstname", "james"));
SpanQuery q2  = new SpanTermQuery(new Term("studentsurname", "jones"));
SpanQuery q2m new FieldMaskingSpanQuery(q2, "studentfirstname");
Query q = new SpanNearQuery(new SpanQuery[]{q1, q2m}, -1, false);
to search for 'studentfirstname:james studentsurname:jones' and find teacherid 1 without matching teacherid 2 (which has a 'james' in position 0 and 'jones' in position 1).

Note: as Field returns the masked field, scoring will be done using the norms of the field name supplied. This may lead to unexpected scoring behaviour.

Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search.Spans SpanQuery
Lucene.Net.Search.Spans FieldMaskingSpanQuery

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FieldMaskingSpanQuery : SpanQuery
[SerializableAttribute]
public class FieldMaskingSpanQuery : SpanQuery
<SerializableAttribute> _
Public Class FieldMaskingSpanQuery _
    Inherits SpanQuery
<SerializableAttribute> _
Public Class FieldMaskingSpanQuery _
    Inherits SpanQuery
[SerializableAttribute]
public ref class FieldMaskingSpanQuery : public SpanQuery
[SerializableAttribute]
public ref class FieldMaskingSpanQuery : public SpanQuery
See Also
FieldMaskingSpanQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldMaskingSpanQuery Members

FieldMaskingSpanQuery Members Lucene.Net Class Library

The FieldMaskingSpanQuery type exposes the following members.
Constructors
 | Name | Description
Public method | FieldMaskingSpanQuery | Initializes a new instance of the FieldMaskingSpanQuery class
Back to Top
Methods
 | Name | Description
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides SpanQuery CreateWeight(Searcher).)
Public method | Equals | (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Query GetHashCode .)
Public method | GetSimilarity | (Overrides Query GetSimilarity(Searcher).)
Public method | GetSpans | (Overrides SpanQuery GetSpans(IndexReader).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Field | (Overrides SpanQuery Field.)
Public property | MaskedQuery |
Back to Top
See Also
FieldMaskingSpanQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldMaskingSpanQuery Constructor

FieldMaskingSpanQuery Constructor Lucene.Net Class Library
Initializes a new instance of the FieldMaskingSpanQuery class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldMaskingSpanQuery(
    SpanQuery maskedQuery,
    string maskedField
)
public FieldMaskingSpanQuery(
    SpanQuery maskedQuery,
    string maskedField
)
Public Sub New ( _
    maskedQuery As SpanQuery, _
    maskedField As String _
)
Public Sub New ( _
    maskedQuery As SpanQuery, _
    maskedField As String _
)
public:
FieldMaskingSpanQuery(
    SpanQuery^ maskedQuery,
    String^ maskedField
)
public:
FieldMaskingSpanQuery(
    SpanQuery^ maskedQuery,
    String^ maskedField
)
Parameters
maskedQuery
Type: Lucene.Net.Search.Spans SpanQuery
maskedField
Type:   Online System String
See Also
FieldMaskingSpanQuery Class
FieldMaskingSpanQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldMaskingSpanQuery Methods

FieldMaskingSpanQuery Methods Lucene.Net Class Library
The FieldMaskingSpanQuery type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Overrides SpanQuery CreateWeight(Searcher).)
Public method | Equals | (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Query GetHashCode .)
Public method | GetSimilarity | (Overrides Query GetSimilarity(Searcher).)
Public method | GetSpans | (Overrides SpanQuery GetSpans(IndexReader).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
FieldMaskingSpanQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateWeight Method

FieldMaskingSpanQuery CreateWeight Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Weight CreateWeight(
    Searcher searcher
)
public override Weight CreateWeight(
    Searcher searcher
)
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
FieldMaskingSpanQuery Class
FieldMaskingSpanQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

FieldMaskingSpanQuery Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
FieldMaskingSpanQuery Class
FieldMaskingSpanQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExtractTerms Method

FieldMaskingSpanQuery ExtractTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ExtractTerms(
    ISet<Term> terms
)
public override void ExtractTerms(
    ISet<Term> terms
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
Parameters
terms
Type:   Online System.Collections.Generic ISet  Term
See Also
FieldMaskingSpanQuery Class
FieldMaskingSpanQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

FieldMaskingSpanQuery GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
FieldMaskingSpanQuery Class
FieldMaskingSpanQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSimilarity Method

FieldMaskingSpanQuery GetSimilarity Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Similarity GetSimilarity(
    Searcher searcher
)
public override Similarity GetSimilarity(
    Searcher searcher
)
Public Overrides Function GetSimilarity ( _
    searcher As Searcher _
) As Similarity
Public Overrides Function GetSimilarity ( _
    searcher As Searcher _
) As Similarity
public:
virtual Similarity^ GetSimilarity(
    Searcher^ searcher
) override
public:
virtual Similarity^ GetSimilarity(
    Searcher^ searcher
) override
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
FieldMaskingSpanQuery Class
FieldMaskingSpanQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSpans Method

FieldMaskingSpanQuery GetSpans Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Spans GetSpans(
    IndexReader reader
)
public override Spans GetSpans(
    IndexReader reader
)
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
FieldMaskingSpanQuery Class
FieldMaskingSpanQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

FieldMaskingSpanQuery Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    IndexReader reader
)
public override Query Rewrite(
    IndexReader reader
)
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
FieldMaskingSpanQuery Class
FieldMaskingSpanQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

FieldMaskingSpanQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Back to Top
See Also
FieldMaskingSpanQuery Class
FieldMaskingSpanQuery Members
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

FieldMaskingSpanQuery ToString Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
FieldMaskingSpanQuery Class
FieldMaskingSpanQuery Members
ToString Overload
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldMaskingSpanQuery Properties

FieldMaskingSpanQuery Properties Lucene.Net Class Library
The FieldMaskingSpanQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Field | (Overrides SpanQuery Field.)
Public property | MaskedQuery |
Back to Top
See Also
FieldMaskingSpanQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

FieldMaskingSpanQuery Field Property Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Field { get; }
public override string Field { get; }
Public Overrides ReadOnly Property Field As String
    Get
Public Overrides ReadOnly Property Field As String
    Get
public:
virtual property String^ Field {
    String^ get () override;
}
public:
virtual property String^ Field {
    String^ get () override;
}
See Also
FieldMaskingSpanQuery Class
FieldMaskingSpanQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaskedQuery Property

FieldMaskingSpanQuery MaskedQuery Property Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual SpanQuery MaskedQuery { get; }
public virtual SpanQuery MaskedQuery { get; }
Public Overridable ReadOnly Property MaskedQuery As SpanQuery
    Get
Public Overridable ReadOnly Property MaskedQuery As SpanQuery
    Get
public:
virtual property SpanQuery^ MaskedQuery {
    SpanQuery^ get ();
}
public:
virtual property SpanQuery^ MaskedQuery {
    SpanQuery^ get ();
}
See Also
FieldMaskingSpanQuery Class
FieldMaskingSpanQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NearSpansOrdered Class

NearSpansOrdered Class Lucene.Net Class Library
A Spans that is formed from the ordered subspans of a SpanNearQuery where the subspans do not overlap and have a maximum slop between them.

The formed spans only contains minimum slop matches.
The matching slop is computed from the distance(s) between the non overlapping matching Spans.
Successive matches are always formed from the successive Spans of the SpanNearQuery.

The formed spans may contain overlaps when the slop is at least 1. For example, when querying using t1 t2 t3 with slop at least 1, the fragment: t1 t2 t1 t3 t2 t3 matches twice: t1 t2 .. t3 t1 .. t2 t3 Expert: Only public for subclassing. Most implementations should not need this class
Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Spans Spans
Lucene.Net.Search.Spans NearSpansOrdered

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NearSpansOrdered : Spans
public class NearSpansOrdered : Spans
Public Class NearSpansOrdered _
    Inherits Spans
Public Class NearSpansOrdered _
    Inherits Spans
public ref class NearSpansOrdered : public Spans
public ref class NearSpansOrdered : public Spans
See Also
NearSpansOrdered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NearSpansOrdered Members

NearSpansOrdered Members Lucene.Net Class Library

The NearSpansOrdered type exposes the following members.
Constructors
 | Name | Description
Public method | NearSpansOrdered(SpanNearQuery, IndexReader) | Initializes a new instance of the NearSpansOrdered class
Public method | NearSpansOrdered(SpanNearQuery, IndexReader, Boolean) | Initializes a new instance of the NearSpansOrdered class
Back to Top
Methods
 | Name | Description
Public method | Doc | (Overrides Spans Doc .)
Public method | End | (Overrides Spans End .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPayload | (Overrides Spans GetPayload .)
Public method | GetSubSpans |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsPayloadAvailable | (Overrides Spans IsPayloadAvailable .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | (Overrides Spans Next .)
Public method | SkipTo | (Overrides Spans SkipTo(Int32).)
Public method | Start | (Overrides Spans Start .)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
NearSpansOrdered Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NearSpansOrdered Constructor

NearSpansOrdered Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | NearSpansOrdered(SpanNearQuery, IndexReader) | Initializes a new instance of the NearSpansOrdered class
Public method | NearSpansOrdered(SpanNearQuery, IndexReader, Boolean) | Initializes a new instance of the NearSpansOrdered class
Back to Top
See Also
NearSpansOrdered Class
NearSpansOrdered Members
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NearSpansOrdered Constructor (SpanNearQuery, IndexReader)

NearSpansOrdered Constructor (SpanNearQuery, IndexReader) Lucene.Net Class Library
Initializes a new instance of the NearSpansOrdered class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NearSpansOrdered(
    SpanNearQuery spanNearQuery,
    IndexReader reader
)
public NearSpansOrdered(
    SpanNearQuery spanNearQuery,
    IndexReader reader
)
Public Sub New ( _
    spanNearQuery As SpanNearQuery, _
    reader As IndexReader _
)
Public Sub New ( _
    spanNearQuery As SpanNearQuery, _
    reader As IndexReader _
)
public:
NearSpansOrdered(
    SpanNearQuery^ spanNearQuery,
    IndexReader^ reader
)
public:
NearSpansOrdered(
    SpanNearQuery^ spanNearQuery,
    IndexReader^ reader
)
Parameters
spanNearQuery
Type: Lucene.Net.Search.Spans SpanNearQuery
reader
Type: Lucene.Net.Index IndexReader
See Also
NearSpansOrdered Class
NearSpansOrdered Members
NearSpansOrdered Overload
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NearSpansOrdered Constructor (SpanNearQuery, IndexReader, Boolean)

NearSpansOrdered Constructor (SpanNearQuery, IndexReader, Boolean) Lucene.Net Class Library
Initializes a new instance of the NearSpansOrdered class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NearSpansOrdered(
    SpanNearQuery spanNearQuery,
    IndexReader reader,
    bool collectPayloads
)
public NearSpansOrdered(
    SpanNearQuery spanNearQuery,
    IndexReader reader,
    bool collectPayloads
)
Public Sub New ( _
    spanNearQuery As SpanNearQuery, _
    reader As IndexReader, _
    collectPayloads As Boolean _
)
Public Sub New ( _
    spanNearQuery As SpanNearQuery, _
    reader As IndexReader, _
    collectPayloads As Boolean _
)
public:
NearSpansOrdered(
    SpanNearQuery^ spanNearQuery,
    IndexReader^ reader,
    bool collectPayloads
)
public:
NearSpansOrdered(
    SpanNearQuery^ spanNearQuery,
    IndexReader^ reader,
    bool collectPayloads
)
Parameters
spanNearQuery
Type: Lucene.Net.Search.Spans SpanNearQuery
reader
Type: Lucene.Net.Index IndexReader
collectPayloads
Type:   Online System Boolean
See Also
NearSpansOrdered Class
NearSpansOrdered Members
NearSpansOrdered Overload
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NearSpansOrdered Methods

NearSpansOrdered Methods Lucene.Net Class Library
The NearSpansOrdered type exposes the following members.
Methods
 | Name | Description
Public method | Doc | (Overrides Spans Doc .)
Public method | End | (Overrides Spans End .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPayload | (Overrides Spans GetPayload .)
Public method | GetSubSpans |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsPayloadAvailable | (Overrides Spans IsPayloadAvailable .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | (Overrides Spans Next .)
Public method | SkipTo | (Overrides Spans SkipTo(Int32).)
Public method | Start | (Overrides Spans Start .)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
NearSpansOrdered Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Method

NearSpansOrdered Doc Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Doc()
public override int Doc()
Public Overrides Function Doc As Integer
Public Overrides Function Doc As Integer
public:
virtual int Doc() override
public:
virtual int Doc() override
See Also
NearSpansOrdered Class
NearSpansOrdered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


End Method

NearSpansOrdered End Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int End()
public override int End()
Public Overrides Function End As Integer
Public Overrides Function End As Integer
public:
virtual int End() override
public:
virtual int End() override
See Also
NearSpansOrdered Class
NearSpansOrdered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPayload Method

NearSpansOrdered GetPayload Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ICollection<byte[]> GetPayload()
public override ICollection<byte[]> GetPayload()
Public Overrides Function GetPayload As ICollection(Of Byte())
Public Overrides Function GetPayload As ICollection(Of Byte())
public:
virtual ICollection<array<unsigned char>^>^ GetPayload() override
public:
virtual ICollection<array<unsigned char>^>^ GetPayload() override
See Also
NearSpansOrdered Class
NearSpansOrdered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSubSpans Method

NearSpansOrdered GetSubSpans Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Spans[] GetSubSpans()
public virtual Spans[] GetSubSpans()
Public Overridable Function GetSubSpans As Spans()
Public Overridable Function GetSubSpans As Spans()
public:
virtual array<Spans^>^ GetSubSpans()
public:
virtual array<Spans^>^ GetSubSpans()
See Also
NearSpansOrdered Class
NearSpansOrdered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsPayloadAvailable Method

NearSpansOrdered IsPayloadAvailable Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsPayloadAvailable()
public override bool IsPayloadAvailable()
Public Overrides Function IsPayloadAvailable As Boolean
Public Overrides Function IsPayloadAvailable As Boolean
public:
virtual bool IsPayloadAvailable() override
public:
virtual bool IsPayloadAvailable() override
See Also
NearSpansOrdered Class
NearSpansOrdered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Next Method

NearSpansOrdered Next Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Next()
public override bool Next()
Public Overrides Function Next As Boolean
Public Overrides Function Next As Boolean
public:
virtual bool Next() override
public:
virtual bool Next() override
See Also
NearSpansOrdered Class
NearSpansOrdered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SkipTo Method

NearSpansOrdered SkipTo Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool SkipTo(
    int target
)
public override bool SkipTo(
    int target
)
Public Overrides Function SkipTo ( _
    target As Integer _
) As Boolean
Public Overrides Function SkipTo ( _
    target As Integer _
) As Boolean
public:
virtual bool SkipTo(
    int target
) override
public:
virtual bool SkipTo(
    int target
) override
Parameters
target
Type:   Online System Int32
See Also
NearSpansOrdered Class
NearSpansOrdered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Start Method

NearSpansOrdered Start Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Start()
public override int Start()
Public Overrides Function Start As Integer
Public Overrides Function Start As Integer
public:
virtual int Start() override
public:
virtual int Start() override
See Also
NearSpansOrdered Class
NearSpansOrdered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

NearSpansOrdered ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
NearSpansOrdered Class
NearSpansOrdered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NearSpansUnordered Class

NearSpansUnordered Class Lucene.Net Class Library
Similar to NearSpansOrdered, but for the unordered case. Expert: Only public for subclassing. Most implementations should not need this class
Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Spans Spans
Lucene.Net.Search.Spans NearSpansUnordered

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NearSpansUnordered : Spans
public class NearSpansUnordered : Spans
Public Class NearSpansUnordered _
    Inherits Spans
Public Class NearSpansUnordered _
    Inherits Spans
public ref class NearSpansUnordered : public Spans
public ref class NearSpansUnordered : public Spans
See Also
NearSpansUnordered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NearSpansUnordered Members

NearSpansUnordered Members Lucene.Net Class Library

The NearSpansUnordered type exposes the following members.
Constructors
 | Name | Description
Public method | NearSpansUnordered | Initializes a new instance of the NearSpansUnordered class
Back to Top
Methods
 | Name | Description
Public method | Doc | (Overrides Spans Doc .)
Public method | End | (Overrides Spans End .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPayload | WARNING: The List is not necessarily in order of the the positions (Overrides Spans GetPayload .)
Public method | GetSubSpans |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsPayloadAvailable | (Overrides Spans IsPayloadAvailable .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | (Overrides Spans Next .)
Public method | SkipTo | (Overrides Spans SkipTo(Int32).)
Public method | Start | (Overrides Spans Start .)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
NearSpansUnordered Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NearSpansUnordered Constructor

NearSpansUnordered Constructor Lucene.Net Class Library
Initializes a new instance of the NearSpansUnordered class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NearSpansUnordered(
    SpanNearQuery query,
    IndexReader reader
)
public NearSpansUnordered(
    SpanNearQuery query,
    IndexReader reader
)
Public Sub New ( _
    query As SpanNearQuery, _
    reader As IndexReader _
)
Public Sub New ( _
    query As SpanNearQuery, _
    reader As IndexReader _
)
public:
NearSpansUnordered(
    SpanNearQuery^ query,
    IndexReader^ reader
)
public:
NearSpansUnordered(
    SpanNearQuery^ query,
    IndexReader^ reader
)
Parameters
query
Type: Lucene.Net.Search.Spans SpanNearQuery
reader
Type: Lucene.Net.Index IndexReader
See Also
NearSpansUnordered Class
NearSpansUnordered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NearSpansUnordered Methods

NearSpansUnordered Methods Lucene.Net Class Library
The NearSpansUnordered type exposes the following members.
Methods
 | Name | Description
Public method | Doc | (Overrides Spans Doc .)
Public method | End | (Overrides Spans End .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPayload | WARNING: The List is not necessarily in order of the the positions (Overrides Spans GetPayload .)
Public method | GetSubSpans |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsPayloadAvailable | (Overrides Spans IsPayloadAvailable .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | (Overrides Spans Next .)
Public method | SkipTo | (Overrides Spans SkipTo(Int32).)
Public method | Start | (Overrides Spans Start .)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
NearSpansUnordered Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Method

NearSpansUnordered Doc Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Doc()
public override int Doc()
Public Overrides Function Doc As Integer
Public Overrides Function Doc As Integer
public:
virtual int Doc() override
public:
virtual int Doc() override
See Also
NearSpansUnordered Class
NearSpansUnordered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


End Method

NearSpansUnordered End Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int End()
public override int End()
Public Overrides Function End As Integer
Public Overrides Function End As Integer
public:
virtual int End() override
public:
virtual int End() override
See Also
NearSpansUnordered Class
NearSpansUnordered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPayload Method

NearSpansUnordered GetPayload Method Lucene.Net Class Library
WARNING: The List is not necessarily in order of the the positions

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ICollection<byte[]> GetPayload()
public override ICollection<byte[]> GetPayload()
Public Overrides Function GetPayload As ICollection(Of Byte())
Public Overrides Function GetPayload As ICollection(Of Byte())
public:
virtual ICollection<array<unsigned char>^>^ GetPayload() override
public:
virtual ICollection<array<unsigned char>^>^ GetPayload() override
Return Value
 Collection of &lt;c&gt;byte[]&lt;/c&gt; payloads
See Also
NearSpansUnordered Class
NearSpansUnordered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSubSpans Method

NearSpansUnordered GetSubSpans Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Spans[] GetSubSpans()
public virtual Spans[] GetSubSpans()
Public Overridable Function GetSubSpans As Spans()
Public Overridable Function GetSubSpans As Spans()
public:
virtual array<Spans^>^ GetSubSpans()
public:
virtual array<Spans^>^ GetSubSpans()
See Also
NearSpansUnordered Class
NearSpansUnordered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsPayloadAvailable Method

NearSpansUnordered IsPayloadAvailable Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsPayloadAvailable()
public override bool IsPayloadAvailable()
Public Overrides Function IsPayloadAvailable As Boolean
Public Overrides Function IsPayloadAvailable As Boolean
public:
virtual bool IsPayloadAvailable() override
public:
virtual bool IsPayloadAvailable() override
See Also
NearSpansUnordered Class
NearSpansUnordered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Next Method

NearSpansUnordered Next Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Next()
public override bool Next()
Public Overrides Function Next As Boolean
Public Overrides Function Next As Boolean
public:
virtual bool Next() override
public:
virtual bool Next() override
See Also
NearSpansUnordered Class
NearSpansUnordered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SkipTo Method

NearSpansUnordered SkipTo Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool SkipTo(
    int target
)
public override bool SkipTo(
    int target
)
Public Overrides Function SkipTo ( _
    target As Integer _
) As Boolean
Public Overrides Function SkipTo ( _
    target As Integer _
) As Boolean
public:
virtual bool SkipTo(
    int target
) override
public:
virtual bool SkipTo(
    int target
) override
Parameters
target
Type:   Online System Int32
See Also
NearSpansUnordered Class
NearSpansUnordered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Start Method

NearSpansUnordered Start Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Start()
public override int Start()
Public Overrides Function Start As Integer
Public Overrides Function Start As Integer
public:
virtual int Start() override
public:
virtual int Start() override
See Also
NearSpansUnordered Class
NearSpansUnordered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

NearSpansUnordered ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
NearSpansUnordered Class
NearSpansUnordered Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFirstQuery Class

SpanFirstQuery Class Lucene.Net Class Library
Matches spans near the beginning of a field.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search.Spans SpanQuery
Lucene.Net.Search.Spans SpanFirstQuery

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SpanFirstQuery : SpanQuery,
    ICloneable
[SerializableAttribute]
public class SpanFirstQuery : SpanQuery,
    ICloneable
<SerializableAttribute> _
Public Class SpanFirstQuery _
    Inherits SpanQuery _
    Implements ICloneable
<SerializableAttribute> _
Public Class SpanFirstQuery _
    Inherits SpanQuery _
    Implements ICloneable
[SerializableAttribute]
public ref class SpanFirstQuery : public SpanQuery,
    ICloneable
[SerializableAttribute]
public ref class SpanFirstQuery : public SpanQuery,
    ICloneable
See Also
SpanFirstQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFirstQuery Members

SpanFirstQuery Members Lucene.Net Class Library

The SpanFirstQuery type exposes the following members.
Constructors
 | Name | Description
Public method | SpanFirstQuery | Construct a SpanFirstQuery matching spans in match whose end position is less than or equal to end.
Back to Top
Methods
 | Name | Description
Public method | Clone | (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method | Equals | (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery GetSpans(IndexReader).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | End | Return the maximum end position permitted in a match.
Public property | Field | (Overrides SpanQuery Field.)
Public property | Match | Return the SpanQuery whose matches are filtered.
Back to Top
See Also
SpanFirstQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFirstQuery Constructor

SpanFirstQuery Constructor Lucene.Net Class Library
Construct a SpanFirstQuery matching spans in match whose end position is less than or equal to end.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SpanFirstQuery(
    SpanQuery match,
    int end
)
public SpanFirstQuery(
    SpanQuery match,
    int end
)
Public Sub New ( _
    match As SpanQuery, _
    end As Integer _
)
Public Sub New ( _
    match As SpanQuery, _
    end As Integer _
)
public:
SpanFirstQuery(
    SpanQuery^ match,
    int end
)
public:
SpanFirstQuery(
    SpanQuery^ match,
    int end
)
Parameters
match
Type: Lucene.Net.Search.Spans SpanQuery
end
Type:   Online System Int32
See Also
SpanFirstQuery Class
SpanFirstQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFirstQuery Methods

SpanFirstQuery Methods Lucene.Net Class Library
The SpanFirstQuery type exposes the following members.
Methods
 | Name | Description
Public method | Clone | (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method | Equals | (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery GetSpans(IndexReader).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
SpanFirstQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

SpanFirstQuery Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
SpanFirstQuery Class
SpanFirstQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

SpanFirstQuery Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
SpanFirstQuery Class
SpanFirstQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExtractTerms Method

SpanFirstQuery ExtractTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ExtractTerms(
    ISet<Term> terms
)
public override void ExtractTerms(
    ISet<Term> terms
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
Parameters
terms
Type:   Online System.Collections.Generic ISet  Term
See Also
SpanFirstQuery Class
SpanFirstQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

SpanFirstQuery GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
SpanFirstQuery Class
SpanFirstQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSpans Method

SpanFirstQuery GetSpans Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Spans GetSpans(
    IndexReader reader
)
public override Spans GetSpans(
    IndexReader reader
)
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
SpanFirstQuery Class
SpanFirstQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

SpanFirstQuery Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    IndexReader reader
)
public override Query Rewrite(
    IndexReader reader
)
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
SpanFirstQuery Class
SpanFirstQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

SpanFirstQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Back to Top
See Also
SpanFirstQuery Class
SpanFirstQuery Members
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

SpanFirstQuery ToString Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
SpanFirstQuery Class
SpanFirstQuery Members
ToString Overload
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanFirstQuery Properties

SpanFirstQuery Properties Lucene.Net Class Library
The SpanFirstQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | End | Return the maximum end position permitted in a match.
Public property | Field | (Overrides SpanQuery Field.)
Public property | Match | Return the SpanQuery whose matches are filtered.
Back to Top
See Also
SpanFirstQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


End Property

SpanFirstQuery End Property Lucene.Net Class Library
Return the maximum end position permitted in a match.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int End { get; }
public virtual int End { get; }
Public Overridable ReadOnly Property End As Integer
    Get
Public Overridable ReadOnly Property End As Integer
    Get
public:
virtual property int End {
    int get ();
}
public:
virtual property int End {
    int get ();
}
See Also
SpanFirstQuery Class
SpanFirstQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

SpanFirstQuery Field Property Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Field { get; }
public override string Field { get; }
Public Overrides ReadOnly Property Field As String
    Get
Public Overrides ReadOnly Property Field As String
    Get
public:
virtual property String^ Field {
    String^ get () override;
}
public:
virtual property String^ Field {
    String^ get () override;
}
See Also
SpanFirstQuery Class
SpanFirstQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Match Property

SpanFirstQuery Match Property Lucene.Net Class Library
Return the SpanQuery whose matches are filtered.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual SpanQuery Match { get; }
public virtual SpanQuery Match { get; }
Public Overridable ReadOnly Property Match As SpanQuery
    Get
Public Overridable ReadOnly Property Match As SpanQuery
    Get
public:
virtual property SpanQuery^ Match {
    SpanQuery^ get ();
}
public:
virtual property SpanQuery^ Match {
    SpanQuery^ get ();
}
See Also
SpanFirstQuery Class
SpanFirstQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanNearQuery Class

SpanNearQuery Class Lucene.Net Class Library
Matches spans which are near one another. One can specify slop, the maximum number of intervening unmatched positions, as well as whether matches are required to be in-order.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search.Spans SpanQuery
Lucene.Net.Search.Spans SpanNearQuery
Lucene.Net.Search.Payloads PayloadNearQuery

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SpanNearQuery : SpanQuery,
    ICloneable
[SerializableAttribute]
public class SpanNearQuery : SpanQuery,
    ICloneable
<SerializableAttribute> _
Public Class SpanNearQuery _
    Inherits SpanQuery _
    Implements ICloneable
<SerializableAttribute> _
Public Class SpanNearQuery _
    Inherits SpanQuery _
    Implements ICloneable
[SerializableAttribute]
public ref class SpanNearQuery : public SpanQuery,
    ICloneable
[SerializableAttribute]
public ref class SpanNearQuery : public SpanQuery,
    ICloneable
See Also
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanNearQuery Members

SpanNearQuery Members Lucene.Net Class Library

The SpanNearQuery type exposes the following members.
Constructors
 | Name | Description
Public method | SpanNearQuery( SpanQuery , Int32, Boolean) | Construct a SpanNearQuery. Matches spans matching a span from each clause, with up to slop total unmatched positions between them. * When inOrder is true, the spans from each clause must be * ordered as in clauses.
Public method | SpanNearQuery( SpanQuery , Int32, Boolean, Boolean) | Initializes a new instance of the SpanNearQuery class
Back to Top
Methods
 | Name | Description
Public method | Clone | (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method | Equals | Returns true iff o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClauses | Return the clauses whose spans are matched.
Public method | GetHashCode | (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery GetSpans(IndexReader).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Fields
 | Name | Description
Protected field | clauses |
Protected field | inOrder |
Protected field | internalField |
Protected field | internalSlop |
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Field | (Overrides SpanQuery Field.)
Public property | IsInOrder | Return true if matches are required to be in-order.
Public property | Slop | Return the maximum number of intervening unmatched positions permitted.
Back to Top
See Also
SpanNearQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanNearQuery Constructor

SpanNearQuery Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | SpanNearQuery( SpanQuery , Int32, Boolean) | Construct a SpanNearQuery. Matches spans matching a span from each clause, with up to slop total unmatched positions between them. * When inOrder is true, the spans from each clause must be * ordered as in clauses.
Public method | SpanNearQuery( SpanQuery , Int32, Boolean, Boolean) | Initializes a new instance of the SpanNearQuery class
Back to Top
See Also
SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanNearQuery Constructor (SpanQuery[], Int32, Boolean)

SpanNearQuery Constructor ( SpanQuery , Int32, Boolean) Lucene.Net Class Library
Construct a SpanNearQuery. Matches spans matching a span from each clause, with up to slop total unmatched positions between them. * When inOrder is true, the spans from each clause must be * ordered as in clauses.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SpanNearQuery(
    SpanQuery[] clauses,
    int slop,
    bool inOrder
)
public SpanNearQuery(
    SpanQuery[] clauses,
    int slop,
    bool inOrder
)
Public Sub New ( _
    clauses As SpanQuery(), _
    slop As Integer, _
    inOrder As Boolean _
)
Public Sub New ( _
    clauses As SpanQuery(), _
    slop As Integer, _
    inOrder As Boolean _
)
public:
SpanNearQuery(
    array<SpanQuery^>^ clauses,
    int slop,
    bool inOrder
)
public:
SpanNearQuery(
    array<SpanQuery^>^ clauses,
    int slop,
    bool inOrder
)
Parameters
clauses
Type:  Lucene.Net.Search.Spans SpanQuery
slop
Type:   Online System Int32
inOrder
Type:   Online System Boolean
See Also
SpanNearQuery Class
SpanNearQuery Members
SpanNearQuery Overload
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanNearQuery Constructor (SpanQuery[], Int32, Boolean, Boolean)

SpanNearQuery Constructor ( SpanQuery , Int32, Boolean, Boolean) Lucene.Net Class Library
Initializes a new instance of the SpanNearQuery class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SpanNearQuery(
    SpanQuery[] clauses,
    int slop,
    bool inOrder,
    bool collectPayloads
)
public SpanNearQuery(
    SpanQuery[] clauses,
    int slop,
    bool inOrder,
    bool collectPayloads
)
Public Sub New ( _
    clauses As SpanQuery(), _
    slop As Integer, _
    inOrder As Boolean, _
    collectPayloads As Boolean _
)
Public Sub New ( _
    clauses As SpanQuery(), _
    slop As Integer, _
    inOrder As Boolean, _
    collectPayloads As Boolean _
)
public:
SpanNearQuery(
    array<SpanQuery^>^ clauses,
    int slop,
    bool inOrder,
    bool collectPayloads
)
public:
SpanNearQuery(
    array<SpanQuery^>^ clauses,
    int slop,
    bool inOrder,
    bool collectPayloads
)
Parameters
clauses
Type:  Lucene.Net.Search.Spans SpanQuery
slop
Type:   Online System Int32
inOrder
Type:   Online System Boolean
collectPayloads
Type:   Online System Boolean
See Also
SpanNearQuery Class
SpanNearQuery Members
SpanNearQuery Overload
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanNearQuery Fields

SpanNearQuery Fields Lucene.Net Class Library
The SpanNearQuery type exposes the following members.
Fields
 | Name | Description
Protected field | clauses |
Protected field | inOrder |
Protected field | internalField |
Protected field | internalSlop |
Back to Top
See Also
SpanNearQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


clauses Field

SpanNearQuery clauses Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IList<SpanQuery> clauses
protected IList<SpanQuery> clauses
Protected clauses As IList(Of SpanQuery)
Protected clauses As IList(Of SpanQuery)
protected:
IList<SpanQuery^>^ clauses
protected:
IList<SpanQuery^>^ clauses
See Also
SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


inOrder Field

SpanNearQuery inOrder Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool inOrder
protected bool inOrder
Protected inOrder As Boolean
Protected inOrder As Boolean
protected:
bool inOrder
protected:
bool inOrder
See Also
SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalField Field

SpanNearQuery internalField Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string internalField
protected string internalField
Protected internalField As String
Protected internalField As String
protected:
String^ internalField
protected:
String^ internalField
See Also
SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalSlop Field

SpanNearQuery internalSlop Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int internalSlop
protected int internalSlop
Protected internalSlop As Integer
Protected internalSlop As Integer
protected:
int internalSlop
protected:
int internalSlop
See Also
SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanNearQuery Methods

SpanNearQuery Methods Lucene.Net Class Library
The SpanNearQuery type exposes the following members.
Methods
 | Name | Description
Public method | Clone | (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method | Equals | Returns true iff o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClauses | Return the clauses whose spans are matched.
Public method | GetHashCode | (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery GetSpans(IndexReader).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
SpanNearQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

SpanNearQuery Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

SpanNearQuery Equals Method Lucene.Net Class Library
Returns true iff o is equal to this.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExtractTerms Method

SpanNearQuery ExtractTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ExtractTerms(
    ISet<Term> terms
)
public override void ExtractTerms(
    ISet<Term> terms
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
Parameters
terms
Type:   Online System.Collections.Generic ISet  Term
See Also
SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetClauses Method

SpanNearQuery GetClauses Method Lucene.Net Class Library
Return the clauses whose spans are matched.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual SpanQuery[] GetClauses()
public virtual SpanQuery[] GetClauses()
Public Overridable Function GetClauses As SpanQuery()
Public Overridable Function GetClauses As SpanQuery()
public:
virtual array<SpanQuery^>^ GetClauses()
public:
virtual array<SpanQuery^>^ GetClauses()
See Also
SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

SpanNearQuery GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSpans Method

SpanNearQuery GetSpans Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Spans GetSpans(
    IndexReader reader
)
public override Spans GetSpans(
    IndexReader reader
)
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

SpanNearQuery Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    IndexReader reader
)
public override Query Rewrite(
    IndexReader reader
)
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

SpanNearQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Back to Top
See Also
SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

SpanNearQuery ToString Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
SpanNearQuery Class
SpanNearQuery Members
ToString Overload
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanNearQuery Properties

SpanNearQuery Properties Lucene.Net Class Library
The SpanNearQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Field | (Overrides SpanQuery Field.)
Public property | IsInOrder | Return true if matches are required to be in-order.
Public property | Slop | Return the maximum number of intervening unmatched positions permitted.
Back to Top
See Also
SpanNearQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

SpanNearQuery Field Property Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Field { get; }
public override string Field { get; }
Public Overrides ReadOnly Property Field As String
    Get
Public Overrides ReadOnly Property Field As String
    Get
public:
virtual property String^ Field {
    String^ get () override;
}
public:
virtual property String^ Field {
    String^ get () override;
}
See Also
SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsInOrder Property

SpanNearQuery IsInOrder Property Lucene.Net Class Library
Return true if matches are required to be in-order.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsInOrder { get; }
public virtual bool IsInOrder { get; }
Public Overridable ReadOnly Property IsInOrder As Boolean
    Get
Public Overridable ReadOnly Property IsInOrder As Boolean
    Get
public:
virtual property bool IsInOrder {
    bool get ();
}
public:
virtual property bool IsInOrder {
    bool get ();
}
See Also
SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Slop Property

SpanNearQuery Slop Property Lucene.Net Class Library
Return the maximum number of intervening unmatched positions permitted.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Slop { get; }
public virtual int Slop { get; }
Public Overridable ReadOnly Property Slop As Integer
    Get
Public Overridable ReadOnly Property Slop As Integer
    Get
public:
virtual property int Slop {
    int get ();
}
public:
virtual property int Slop {
    int get ();
}
See Also
SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanNotQuery Class

SpanNotQuery Class Lucene.Net Class Library
Removes matches which overlap with another SpanQuery.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search.Spans SpanQuery
Lucene.Net.Search.Spans SpanNotQuery

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SpanNotQuery : SpanQuery,
    ICloneable
[SerializableAttribute]
public class SpanNotQuery : SpanQuery,
    ICloneable
<SerializableAttribute> _
Public Class SpanNotQuery _
    Inherits SpanQuery _
    Implements ICloneable
<SerializableAttribute> _
Public Class SpanNotQuery _
    Inherits SpanQuery _
    Implements ICloneable
[SerializableAttribute]
public ref class SpanNotQuery : public SpanQuery,
    ICloneable
[SerializableAttribute]
public ref class SpanNotQuery : public SpanQuery,
    ICloneable
See Also
SpanNotQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanNotQuery Members

SpanNotQuery Members Lucene.Net Class Library

The SpanNotQuery type exposes the following members.
Constructors
 | Name | Description
Public method | SpanNotQuery | Construct a SpanNotQuery matching spans from include which have no overlap with spans from exclude.
Back to Top
Methods
 | Name | Description
Public method | Clone | (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method | Equals | Returns true iff o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery GetSpans(IndexReader).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Exclude | Return the SpanQuery whose matches must not overlap those returned.
Public property | Field | (Overrides SpanQuery Field.)
Public property | Include | Return the SpanQuery whose matches are filtered.
Back to Top
See Also
SpanNotQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanNotQuery Constructor

SpanNotQuery Constructor Lucene.Net Class Library
Construct a SpanNotQuery matching spans from include which have no overlap with spans from exclude.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SpanNotQuery(
    SpanQuery include,
    SpanQuery exclude
)
public SpanNotQuery(
    SpanQuery include,
    SpanQuery exclude
)
Public Sub New ( _
    include As SpanQuery, _
    exclude As SpanQuery _
)
Public Sub New ( _
    include As SpanQuery, _
    exclude As SpanQuery _
)
public:
SpanNotQuery(
    SpanQuery^ include,
    SpanQuery^ exclude
)
public:
SpanNotQuery(
    SpanQuery^ include,
    SpanQuery^ exclude
)
Parameters
include
Type: Lucene.Net.Search.Spans SpanQuery
exclude
Type: Lucene.Net.Search.Spans SpanQuery
See Also
SpanNotQuery Class
SpanNotQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanNotQuery Methods

SpanNotQuery Methods Lucene.Net Class Library
The SpanNotQuery type exposes the following members.
Methods
 | Name | Description
Public method | Clone | (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method | Equals | Returns true iff o is equal to this. (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery GetSpans(IndexReader).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
SpanNotQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

SpanNotQuery Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
SpanNotQuery Class
SpanNotQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

SpanNotQuery Equals Method Lucene.Net Class Library
Returns true iff o is equal to this.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
SpanNotQuery Class
SpanNotQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExtractTerms Method

SpanNotQuery ExtractTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ExtractTerms(
    ISet<Term> terms
)
public override void ExtractTerms(
    ISet<Term> terms
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
Parameters
terms
Type:   Online System.Collections.Generic ISet  Term
See Also
SpanNotQuery Class
SpanNotQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

SpanNotQuery GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
SpanNotQuery Class
SpanNotQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSpans Method

SpanNotQuery GetSpans Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Spans GetSpans(
    IndexReader reader
)
public override Spans GetSpans(
    IndexReader reader
)
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
SpanNotQuery Class
SpanNotQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

SpanNotQuery Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    IndexReader reader
)
public override Query Rewrite(
    IndexReader reader
)
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
SpanNotQuery Class
SpanNotQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

SpanNotQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Back to Top
See Also
SpanNotQuery Class
SpanNotQuery Members
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

SpanNotQuery ToString Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
SpanNotQuery Class
SpanNotQuery Members
ToString Overload
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanNotQuery Properties

SpanNotQuery Properties Lucene.Net Class Library
The SpanNotQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Exclude | Return the SpanQuery whose matches must not overlap those returned.
Public property | Field | (Overrides SpanQuery Field.)
Public property | Include | Return the SpanQuery whose matches are filtered.
Back to Top
See Also
SpanNotQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Exclude Property

SpanNotQuery Exclude Property Lucene.Net Class Library
Return the SpanQuery whose matches must not overlap those returned.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual SpanQuery Exclude { get; }
public virtual SpanQuery Exclude { get; }
Public Overridable ReadOnly Property Exclude As SpanQuery
    Get
Public Overridable ReadOnly Property Exclude As SpanQuery
    Get
public:
virtual property SpanQuery^ Exclude {
    SpanQuery^ get ();
}
public:
virtual property SpanQuery^ Exclude {
    SpanQuery^ get ();
}
See Also
SpanNotQuery Class
SpanNotQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

SpanNotQuery Field Property Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Field { get; }
public override string Field { get; }
Public Overrides ReadOnly Property Field As String
    Get
Public Overrides ReadOnly Property Field As String
    Get
public:
virtual property String^ Field {
    String^ get () override;
}
public:
virtual property String^ Field {
    String^ get () override;
}
See Also
SpanNotQuery Class
SpanNotQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Include Property

SpanNotQuery Include Property Lucene.Net Class Library
Return the SpanQuery whose matches are filtered.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual SpanQuery Include { get; }
public virtual SpanQuery Include { get; }
Public Overridable ReadOnly Property Include As SpanQuery
    Get
Public Overridable ReadOnly Property Include As SpanQuery
    Get
public:
virtual property SpanQuery^ Include {
    SpanQuery^ get ();
}
public:
virtual property SpanQuery^ Include {
    SpanQuery^ get ();
}
See Also
SpanNotQuery Class
SpanNotQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanOrQuery Class

SpanOrQuery Class Lucene.Net Class Library
Matches the union of its clauses.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search.Spans SpanQuery
Lucene.Net.Search.Spans SpanOrQuery

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SpanOrQuery : SpanQuery,
    ICloneable
[SerializableAttribute]
public class SpanOrQuery : SpanQuery,
    ICloneable
<SerializableAttribute> _
Public Class SpanOrQuery _
    Inherits SpanQuery _
    Implements ICloneable
<SerializableAttribute> _
Public Class SpanOrQuery _
    Inherits SpanQuery _
    Implements ICloneable
[SerializableAttribute]
public ref class SpanOrQuery : public SpanQuery,
    ICloneable
[SerializableAttribute]
public ref class SpanOrQuery : public SpanQuery,
    ICloneable
See Also
SpanOrQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanOrQuery Members

SpanOrQuery Members Lucene.Net Class Library

The SpanOrQuery type exposes the following members.
Constructors
 | Name | Description
Public method | SpanOrQuery | Construct a SpanOrQuery merging the provided clauses.
Back to Top
Methods
 | Name | Description
Public method | Clone | (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method | Equals | (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClauses | Return the clauses whose spans are matched.
Public method | GetHashCode | (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery GetSpans(IndexReader).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Field | (Overrides SpanQuery Field.)
Back to Top
See Also
SpanOrQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanOrQuery Constructor

SpanOrQuery Constructor Lucene.Net Class Library
Construct a SpanOrQuery merging the provided clauses.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SpanOrQuery(
    params SpanQuery[] clauses
)
public SpanOrQuery(
    params SpanQuery[] clauses
)
Public Sub New ( _
    ParamArray clauses As SpanQuery() _
)
Public Sub New ( _
    ParamArray clauses As SpanQuery() _
)
public:
SpanOrQuery(
    ... array<SpanQuery^>^ clauses
)
public:
SpanOrQuery(
    ... array<SpanQuery^>^ clauses
)
Parameters
clauses
Type:  Lucene.Net.Search.Spans SpanQuery
See Also
SpanOrQuery Class
SpanOrQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanOrQuery Methods

SpanOrQuery Methods Lucene.Net Class Library
The SpanOrQuery type exposes the following members.
Methods
 | Name | Description
Public method | Clone | (Overrides Query Clone .)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method | Equals | (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClauses | Return the clauses whose spans are matched.
Public method | GetHashCode | (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery GetSpans(IndexReader).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | (Overrides Query Rewrite(IndexReader).)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
SpanOrQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

SpanOrQuery Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
SpanOrQuery Class
SpanOrQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

SpanOrQuery Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
SpanOrQuery Class
SpanOrQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExtractTerms Method

SpanOrQuery ExtractTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ExtractTerms(
    ISet<Term> terms
)
public override void ExtractTerms(
    ISet<Term> terms
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
Parameters
terms
Type:   Online System.Collections.Generic ISet  Term
See Also
SpanOrQuery Class
SpanOrQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetClauses Method

SpanOrQuery GetClauses Method Lucene.Net Class Library
Return the clauses whose spans are matched.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual SpanQuery[] GetClauses()
public virtual SpanQuery[] GetClauses()
Public Overridable Function GetClauses As SpanQuery()
Public Overridable Function GetClauses As SpanQuery()
public:
virtual array<SpanQuery^>^ GetClauses()
public:
virtual array<SpanQuery^>^ GetClauses()
See Also
SpanOrQuery Class
SpanOrQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

SpanOrQuery GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
SpanOrQuery Class
SpanOrQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSpans Method

SpanOrQuery GetSpans Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Spans GetSpans(
    IndexReader reader
)
public override Spans GetSpans(
    IndexReader reader
)
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
SpanOrQuery Class
SpanOrQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Rewrite Method

SpanOrQuery Rewrite Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Rewrite(
    IndexReader reader
)
public override Query Rewrite(
    IndexReader reader
)
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
SpanOrQuery Class
SpanOrQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

SpanOrQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Back to Top
See Also
SpanOrQuery Class
SpanOrQuery Members
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

SpanOrQuery ToString Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
SpanOrQuery Class
SpanOrQuery Members
ToString Overload
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanOrQuery Properties

SpanOrQuery Properties Lucene.Net Class Library
The SpanOrQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Field | (Overrides SpanQuery Field.)
Back to Top
See Also
SpanOrQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

SpanOrQuery Field Property Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Field { get; }
public override string Field { get; }
Public Overrides ReadOnly Property Field As String
    Get
Public Overrides ReadOnly Property Field As String
    Get
public:
virtual property String^ Field {
    String^ get () override;
}
public:
virtual property String^ Field {
    String^ get () override;
}
See Also
SpanOrQuery Class
SpanOrQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanQuery Class

SpanQuery Class Lucene.Net Class Library
Base class for span-based queries.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search.Spans SpanQuery
Lucene.Net.Search.Spans FieldMaskingSpanQuery
Lucene.Net.Search.Spans SpanFirstQuery
Lucene.Net.Search.Spans SpanNearQuery
Lucene.Net.Search.Spans SpanNotQuery
Lucene.Net.Search.Spans SpanOrQuery
Lucene.Net.Search.Spans SpanTermQuery

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class SpanQuery : Query
[SerializableAttribute]
public abstract class SpanQuery : Query
<SerializableAttribute> _
Public MustInherit Class SpanQuery _
    Inherits Query
<SerializableAttribute> _
Public MustInherit Class SpanQuery _
    Inherits Query
[SerializableAttribute]
public ref class SpanQuery abstract : public Query
[SerializableAttribute]
public ref class SpanQuery abstract : public Query
See Also
SpanQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanQuery Members

SpanQuery Members Lucene.Net Class Library

The SpanQuery type exposes the following members.
Constructors
 | Name | Description
Protected method | SpanQuery | Initializes a new instance of the SpanQuery class
Back to Top
Methods
Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | (Inherited from Query.)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its rewritten form.
(Inherited from Query.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method | GetHashCode | (Inherited from Query.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetSpans
Expert: Returns the matches for this query in an index. Used internally to search for spans.
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
(Inherited from Query.)
Public method ToString
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a query to a string, with field assumed to be the default field and omitted.

The representation used is one that is supposed to be readable by QueryParser. However, there are the following limitations:
  • If the query was created by the parser, the printed representation may not be exactly what was parsed. For example, characters that need to be escaped will be represented without the required backslash.
  • Some of the more complicated queries (e.g. span queries) don't have a representation that can be parsed by QueryParser.
(Inherited from Query.)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Field | Returns the name of the field matched by this query.
Back to Top
See Also
SpanQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanQuery Constructor

SpanQuery Constructor Lucene.Net Class Library
Initializes a new instance of the SpanQuery class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SpanQuery()
protected SpanQuery()
Protected Sub New
Protected Sub New
protected:
SpanQuery()
protected:
SpanQuery()
See Also
SpanQuery Class
SpanQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanQuery Methods

SpanQuery Methods Lucene.Net Class Library
The SpanQuery type exposes the following members.
Methods
Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query CreateWeight(Searcher).)
Public method | Equals | (Inherited from Query.)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its rewritten form.
(Inherited from Query.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method | GetHashCode | (Inherited from Query.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetSpans
Expert: Returns the matches for this query in an index. Used internally to search for spans.
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
(Inherited from Query.)
Public method ToString
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a query to a string, with field assumed to be the default field and omitted.

The representation used is one that is supposed to be readable by QueryParser. However, there are the following limitations:
  • If the query was created by the parser, the printed representation may not be exactly what was parsed. For example, characters that need to be escaped will be represented without the required backslash.
  • Some of the more complicated queries (e.g. span queries) don't have a representation that can be parsed by QueryParser.
(Inherited from Query.)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)
Back to Top
See Also
SpanQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateWeight Method

SpanQuery CreateWeight Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Weight CreateWeight(
    Searcher searcher
)
public override Weight CreateWeight(
    Searcher searcher
)
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override
Parameters
searcher
Type: Lucene.Net.Search Searcher
See Also
SpanQuery Class
SpanQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSpans Method

SpanQuery GetSpans Method Lucene.Net Class Library
Expert: Returns the matches for this query in an index. Used internally to search for spans.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Spans GetSpans(
    IndexReader reader
)
public abstract Spans GetSpans(
    IndexReader reader
)
Public MustOverride Function GetSpans ( _
    reader As IndexReader _
) As Spans
Public MustOverride Function GetSpans ( _
    reader As IndexReader _
) As Spans
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) abstract
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) abstract
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
SpanQuery Class
SpanQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanQuery Properties

SpanQuery Properties Lucene.Net Class Library
The SpanQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Field | Returns the name of the field matched by this query.
Back to Top
See Also
SpanQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

SpanQuery Field Property Lucene.Net Class Library
Returns the name of the field matched by this query.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string Field { get; }
public abstract string Field { get; }
Public MustOverride ReadOnly Property Field As String
    Get
Public MustOverride ReadOnly Property Field As String
    Get
public:
virtual property String^ Field {
    String^ get () abstract;
}
public:
virtual property String^ Field {
    String^ get () abstract;
}
See Also
SpanQuery Class
SpanQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Spans Class

Spans Class Lucene.Net Class Library
Expert: an enumeration of span matches. Used to implement span searching. Each span represents a range of term positions within a document. Matches are enumerated in order, by increasing document number, within that by increasing start position and finally by increasing end position.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Spans Spans
Lucene.Net.Search.Spans NearSpansOrdered
Lucene.Net.Search.Spans NearSpansUnordered
Lucene.Net.Search.Spans TermSpans

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Spans
public abstract class Spans
Public MustInherit Class Spans
Public MustInherit Class Spans
public ref class Spans abstract
public ref class Spans abstract
See Also
Spans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Spans Members

Spans Members Lucene.Net Class Library

The Spans type exposes the following members.
Constructors
 | Name | Description
Protected method | Spans | Initializes a new instance of the Spans class
Back to Top
Methods
Name Description
Public method Doc
Returns the document number of the current match. Initially invalid.
Public method End
Returns the end position of the current match. Initially invalid.
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method GetPayload
Returns the payload data for the current span. This is invalid until Next is called for the first time. This method must not be called more than once after each call of Next . However, most payloads are loaded lazily, so if the payload data for the current position is not needed, this method may not be called at all for performance reasons. An ordered SpanQuery does not lazy load, so if you have payloads in your index and you do not want ordered SpanNearQuerys to collect payloads, you can disable collection with a constructor option.
Note that the return type is a collection, thus the ordering should not be relied upon.

WARNING: The status of the Payloads feature is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method IsPayloadAvailable
Checks if a payload can be loaded at this position.

Payloads can only be loaded once per call to Next .
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Next
Move to the next match, returning true iff any such exists.
Public method SkipTo
Skips to the first match beyond the current, whose document number is greater than or equal to target.

Returns true iff there is such a match.

Behaves as if written:
View Colorized Copy to Clipboard Print
boolean skipTo(int target) {
do {
if (!next())
return false;
} while (target > doc());
return true;
}
boolean skipTo(int target) {
do {
if (!next())
return false;
} while (target > doc());
return true;
}
Most implementations are considerably more efficient than that.
Public method Start
Returns the start position of the current match. Initially invalid.
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
See Also
Spans Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Spans Constructor

Spans Constructor Lucene.Net Class Library
Initializes a new instance of the Spans class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Spans()
protected Spans()
Protected Sub New
Protected Sub New
protected:
Spans()
protected:
Spans()
See Also
Spans Class
Spans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Spans Methods

Spans Methods Lucene.Net Class Library
The Spans type exposes the following members.
Methods
Name Description
Public method Doc
Returns the document number of the current match. Initially invalid.
Public method End
Returns the end position of the current match. Initially invalid.
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method GetPayload
Returns the payload data for the current span. This is invalid until Next is called for the first time. This method must not be called more than once after each call of Next . However, most payloads are loaded lazily, so if the payload data for the current position is not needed, this method may not be called at all for performance reasons. An ordered SpanQuery does not lazy load, so if you have payloads in your index and you do not want ordered SpanNearQuerys to collect payloads, you can disable collection with a constructor option.
Note that the return type is a collection, thus the ordering should not be relied upon.

WARNING: The status of the Payloads feature is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Public method IsPayloadAvailable
Checks if a payload can be loaded at this position.

Payloads can only be loaded once per call to Next .
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Next
Move to the next match, returning true iff any such exists.
Public method SkipTo
Skips to the first match beyond the current, whose document number is greater than or equal to target.

Returns true iff there is such a match.

Behaves as if written:
View Colorized Copy to Clipboard Print
boolean skipTo(int target) {
do {
if (!next())
return false;
} while (target > doc());
return true;
}
boolean skipTo(int target) {
do {
if (!next())
return false;
} while (target > doc());
return true;
}
Most implementations are considerably more efficient than that.
Public method Start
Returns the start position of the current match. Initially invalid.
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Back to Top
See Also
Spans Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Method

Spans Doc Method Lucene.Net Class Library
Returns the document number of the current match. Initially invalid.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int Doc()
public abstract int Doc()
Public MustOverride Function Doc As Integer
Public MustOverride Function Doc As Integer
public:
virtual int Doc() abstract
public:
virtual int Doc() abstract
See Also
Spans Class
Spans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


End Method

Spans End Method Lucene.Net Class Library
Returns the end position of the current match. Initially invalid.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int End()
public abstract int End()
Public MustOverride Function End As Integer
Public MustOverride Function End As Integer
public:
virtual int End() abstract
public:
virtual int End() abstract
See Also
Spans Class
Spans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPayload Method

Spans GetPayload Method Lucene.Net Class Library
Returns the payload data for the current span. This is invalid until Next is called for the first time. This method must not be called more than once after each call of Next . However, most payloads are loaded lazily, so if the payload data for the current position is not needed, this method may not be called at all for performance reasons. An ordered SpanQuery does not lazy load, so if you have payloads in your index and you do not want ordered SpanNearQuerys to collect payloads, you can disable collection with a constructor option.
Note that the return type is a collection, thus the ordering should not be relied upon.

WARNING: The status of the Payloads feature is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract ICollection<byte[]> GetPayload()
public abstract ICollection<byte[]> GetPayload()
Public MustOverride Function GetPayload As ICollection(Of Byte())
Public MustOverride Function GetPayload As ICollection(Of Byte())
public:
virtual ICollection<array<unsigned char>^>^ GetPayload() abstract
public:
virtual ICollection<array<unsigned char>^>^ GetPayload() abstract
Return Value
 a List of byte arrays containing the data of this payload, otherwise null if isPayloadAvailable is false
See Also
Spans Class
Spans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsPayloadAvailable Method

Spans IsPayloadAvailable Method Lucene.Net Class Library
Checks if a payload can be loaded at this position.

Payloads can only be loaded once per call to Next .

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool IsPayloadAvailable()
public abstract bool IsPayloadAvailable()
Public MustOverride Function IsPayloadAvailable As Boolean
Public MustOverride Function IsPayloadAvailable As Boolean
public:
virtual bool IsPayloadAvailable() abstract
public:
virtual bool IsPayloadAvailable() abstract
Return Value
 true if there is a payload available at this position that can be loaded
See Also
Spans Class
Spans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Next Method

Spans Next Method Lucene.Net Class Library
Move to the next match, returning true iff any such exists.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool Next()
public abstract bool Next()
Public MustOverride Function Next As Boolean
Public MustOverride Function Next As Boolean
public:
virtual bool Next() abstract
public:
virtual bool Next() abstract
See Also
Spans Class
Spans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SkipTo Method

Spans SkipTo Method Lucene.Net Class Library
Skips to the first match beyond the current, whose document number is greater than or equal to target.

Returns true iff there is such a match.

Behaves as if written:
View Colorized Copy to Clipboard Print
boolean skipTo(int target) {
do {
if (!next())
return false;
} while (target > doc());
return true;
}
boolean skipTo(int target) {
do {
if (!next())
return false;
} while (target > doc());
return true;
}
Most implementations are considerably more efficient than that.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool SkipTo(
    int target
)
public abstract bool SkipTo(
    int target
)
Public MustOverride Function SkipTo ( _
    target As Integer _
) As Boolean
Public MustOverride Function SkipTo ( _
    target As Integer _
) As Boolean
public:
virtual bool SkipTo(
    int target
) abstract
public:
virtual bool SkipTo(
    int target
) abstract
Parameters
target
Type:   Online System Int32
See Also
Spans Class
Spans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Start Method

Spans Start Method Lucene.Net Class Library
Returns the start position of the current match. Initially invalid.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int Start()
public abstract int Start()
Public MustOverride Function Start As Integer
Public MustOverride Function Start As Integer
public:
virtual int Start() abstract
public:
virtual int Start() abstract
See Also
Spans Class
Spans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanScorer Class

SpanScorer Class Lucene.Net Class Library
Public for extension only.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSetIterator
Lucene.Net.Search Scorer
Lucene.Net.Search.Spans SpanScorer
Lucene.Net.Search.Payloads PayloadNearQuery PayloadNearSpanScorer
Lucene.Net.Search.Payloads PayloadTermQuery PayloadTermWeight PayloadTermSpanScorer

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SpanScorer : Scorer
public class SpanScorer : Scorer
Public Class SpanScorer _
    Inherits Scorer
Public Class SpanScorer _
    Inherits Scorer
public ref class SpanScorer : public Scorer
public ref class SpanScorer : public Scorer
See Also
SpanScorer Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanScorer Members

SpanScorer Members Lucene.Net Class Library

The SpanScorer type exposes the following members.
Constructors
 | Name | Description
Protected method | SpanScorer | Initializes a new instance of the SpanScorer class
Back to Top
Methods
 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Explain | This method is no longer an official member of Scorer but it is needed by SpanWeight to build an explanation.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Overrides DocIdSetIterator NextDoc .)
Public method | Score | (Overrides Scorer Score .)
Public method | Score(Collector) | Scores and collects all matching documents. (Inherited from Scorer.)
Public method | Score(Collector, Int32, Int32) | Expert: Collects matching documents in a range. Hook for optimization. Note, firstDocID is added to ensure that NextDoc was called before this method. (Inherited from Scorer.)
Public method | SetFreqCurrentDoc |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | doc |
Protected field | freq |
Protected field | more |
Protected field | norms |
Protected field | spans |
Protected field | value_Renamed |
Protected field | weight |
Back to Top
Properties
 | Name | Description
Public property | Similarity | Returns the Similarity implementation used by this scorer. (Inherited from Scorer.)
Back to Top
See Also
SpanScorer Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanScorer Constructor

SpanScorer Constructor Lucene.Net Class Library
Initializes a new instance of the SpanScorer class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SpanScorer(
    Spans spans,
    Weight weight,
    Similarity similarity,
    byte[] norms
)
protected SpanScorer(
    Spans spans,
    Weight weight,
    Similarity similarity,
    byte[] norms
)
Protected Sub New ( _
    spans As Spans, _
    weight As Weight, _
    similarity As Similarity, _
    norms As Byte() _
)
Protected Sub New ( _
    spans As Spans, _
    weight As Weight, _
    similarity As Similarity, _
    norms As Byte() _
)
protected:
SpanScorer(
    Spans^ spans,
    Weight^ weight,
    Similarity^ similarity,
    array<unsigned char>^ norms
)
protected:
SpanScorer(
    Spans^ spans,
    Weight^ weight,
    Similarity^ similarity,
    array<unsigned char>^ norms
)
Parameters
spans
Type: Lucene.Net.Search.Spans Spans
weight
Type: Lucene.Net.Search Weight
similarity
Type: Lucene.Net.Search Similarity
norms
Type:    Online System Byte
See Also
SpanScorer Class
SpanScorer Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanScorer Fields

SpanScorer Fields Lucene.Net Class Library
The SpanScorer type exposes the following members.
Fields
 | Name | Description
Protected field | doc |
Protected field | freq |
Protected field | more |
Protected field | norms |
Protected field | spans |
Protected field | value_Renamed |
Protected field | weight |
Back to Top
See Also
SpanScorer Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


doc Field

SpanScorer doc Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int doc
protected int doc
Protected doc As Integer
Protected doc As Integer
protected:
int doc
protected:
int doc
See Also
SpanScorer Class
SpanScorer Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


freq Field

SpanScorer freq Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected float freq
protected float freq
Protected freq As Single
Protected freq As Single
protected:
float freq
protected:
float freq
See Also
SpanScorer Class
SpanScorer Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


more Field

SpanScorer more Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool more
protected bool more
Protected more As Boolean
Protected more As Boolean
protected:
bool more
protected:
bool more
See Also
SpanScorer Class
SpanScorer Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


norms Field

SpanScorer norms Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected byte[] norms
protected byte[] norms
Protected norms As Byte()
Protected norms As Byte()
protected:
array<unsigned char>^ norms
protected:
array<unsigned char>^ norms
See Also
SpanScorer Class
SpanScorer Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


spans Field

SpanScorer spans Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Spans spans
protected Spans spans
Protected spans As Spans
Protected spans As Spans
protected:
Spans^ spans
protected:
Spans^ spans
See Also
SpanScorer Class
SpanScorer Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


value_Renamed Field

SpanScorer value_Renamed Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected float value_Renamed
protected float value_Renamed
Protected value_Renamed As Single
Protected value_Renamed As Single
protected:
float value_Renamed
protected:
float value_Renamed
See Also
SpanScorer Class
SpanScorer Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


weight Field

SpanScorer weight Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Weight weight
protected Weight weight
Protected weight As Weight
Protected weight As Weight
protected:
Weight^ weight
protected:
Weight^ weight
See Also
SpanScorer Class
SpanScorer Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanScorer Methods

SpanScorer Methods Lucene.Net Class Library
The SpanScorer type exposes the following members.
Methods
 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Explain | This method is no longer an official member of Scorer but it is needed by SpanWeight to build an explanation.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Overrides DocIdSetIterator NextDoc .)
Public method | Score | (Overrides Scorer Score .)
Public method | Score(Collector) | Scores and collects all matching documents. (Inherited from Scorer.)
Public method | Score(Collector, Int32, Int32) | Expert: Collects matching documents in a range. Hook for optimization. Note, firstDocID is added to ensure that NextDoc was called before this method. (Inherited from Scorer.)
Public method | SetFreqCurrentDoc |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SpanScorer Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Advance Method

SpanScorer Advance Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Advance(
    int target
)
public override int Advance(
    int target
)
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
public:
virtual int Advance(
    int target
) override
public:
virtual int Advance(
    int target
) override
Parameters
target
Type:   Online System Int32
See Also
SpanScorer Class
SpanScorer Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocID Method

SpanScorer DocID Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocID()
public override int DocID()
Public Overrides Function DocID As Integer
Public Overrides Function DocID As Integer
public:
virtual int DocID() override
public:
virtual int DocID() override
See Also
SpanScorer Class
SpanScorer Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method

SpanScorer Explain Method Lucene.Net Class Library
This method is no longer an official member of Scorer but it is needed by SpanWeight to build an explanation.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Explanation Explain(
    int doc
)
protected virtual Explanation Explain(
    int doc
)
Protected Overridable Function Explain ( _
    doc As Integer _
) As Explanation
Protected Overridable Function Explain ( _
    doc As Integer _
) As Explanation
protected:
virtual Explanation^ Explain(
    int doc
)
protected:
virtual Explanation^ Explain(
    int doc
)
Parameters
doc
Type:   Online System Int32
See Also
SpanScorer Class
SpanScorer Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextDoc Method

SpanScorer NextDoc Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int NextDoc()
public override int NextDoc()
Public Overrides Function NextDoc As Integer
Public Overrides Function NextDoc As Integer
public:
virtual int NextDoc() override
public:
virtual int NextDoc() override
See Also
SpanScorer Class
SpanScorer Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method

SpanScorer Score Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Score | (Overrides Scorer Score .)
Public method | Score(Collector) | Scores and collects all matching documents. (Inherited from Scorer.)
Public method | Score(Collector, Int32, Int32) | Expert: Collects matching documents in a range. Hook for optimization. Note, firstDocID is added to ensure that NextDoc was called before this method. (Inherited from Scorer.)
Back to Top
See Also
SpanScorer Class
SpanScorer Members
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Score Method

SpanScorer Score Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Score()
public override float Score()
Public Overrides Function Score As Single
Public Overrides Function Score As Single
public:
virtual float Score() override
public:
virtual float Score() override
See Also
SpanScorer Class
SpanScorer Members
Score Overload
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetFreqCurrentDoc Method

SpanScorer SetFreqCurrentDoc Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool SetFreqCurrentDoc()
public virtual bool SetFreqCurrentDoc()
Public Overridable Function SetFreqCurrentDoc As Boolean
Public Overridable Function SetFreqCurrentDoc As Boolean
public:
virtual bool SetFreqCurrentDoc()
public:
virtual bool SetFreqCurrentDoc()
See Also
SpanScorer Class
SpanScorer Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanScorer Properties

SpanScorer Properties Lucene.Net Class Library
The SpanScorer type exposes the following members.
Properties
 | Name | Description
Public property | Similarity | Returns the Similarity implementation used by this scorer. (Inherited from Scorer.)
Back to Top
See Also
SpanScorer Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanTermQuery Class

SpanTermQuery Class Lucene.Net Class Library
Matches spans containing a term.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Query
Lucene.Net.Search.Spans SpanQuery
Lucene.Net.Search.Spans SpanTermQuery
Lucene.Net.Search.Payloads PayloadTermQuery

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SpanTermQuery : SpanQuery
[SerializableAttribute]
public class SpanTermQuery : SpanQuery
<SerializableAttribute> _
Public Class SpanTermQuery _
    Inherits SpanQuery
<SerializableAttribute> _
Public Class SpanTermQuery _
    Inherits SpanQuery
[SerializableAttribute]
public ref class SpanTermQuery : public SpanQuery
[SerializableAttribute]
public ref class SpanTermQuery : public SpanQuery
See Also
SpanTermQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanTermQuery Members

SpanTermQuery Members Lucene.Net Class Library

The SpanTermQuery type exposes the following members.
Constructors
 | Name | Description
Public method | SpanTermQuery | Construct a SpanTermQuery matching the named term's spans.
Back to Top
Methods
 | Name | Description
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method | Equals | (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery GetSpans(IndexReader).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys. (Inherited from Query.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
Fields
 | Name | Description
Protected field | internalTerm |
Back to Top
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Field | (Overrides SpanQuery Field.)
Public property | Term | Return the term whose spans are matched.
Back to Top
See Also
SpanTermQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanTermQuery Constructor

SpanTermQuery Constructor Lucene.Net Class Library
Construct a SpanTermQuery matching the named term's spans.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SpanTermQuery(
    Term term
)
public SpanTermQuery(
    Term term
)
Public Sub New ( _
    term As Term _
)
Public Sub New ( _
    term As Term _
)
public:
SpanTermQuery(
    Term^ term
)
public:
SpanTermQuery(
    Term^ term
)
Parameters
term
Type: Lucene.Net.Index Term
See Also
SpanTermQuery Class
SpanTermQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanTermQuery Fields

SpanTermQuery Fields Lucene.Net Class Library
The SpanTermQuery type exposes the following members.
Fields
 | Name | Description
Protected field | internalTerm |
Back to Top
See Also
SpanTermQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalTerm Field

SpanTermQuery internalTerm Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Term internalTerm
protected Term internalTerm
Protected internalTerm As Term
Protected internalTerm As Term
protected:
Term^ internalTerm
protected:
Term^ internalTerm
See Also
SpanTermQuery Class
SpanTermQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanTermQuery Methods

SpanTermQuery Methods Lucene.Net Class Library
The SpanTermQuery type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Returns a clone of this query. (Inherited from Query.)
Public method | Combine | Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries. (Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method | Equals | (Overrides Query Equals(Object).)
Public method | ExtractTerms | (Overrides Query ExtractTerms(ISet Term ).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Query GetHashCode .)
Public method | GetSimilarity | Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned. (Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery GetSpans(IndexReader).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rewrite | Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys. (Inherited from Query.)
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Public method | Weight | Expert: Constructs and initializes a Weight for a top-level query. (Inherited from Query.)
Back to Top
See Also
SpanTermQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

SpanTermQuery Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
SpanTermQuery Class
SpanTermQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExtractTerms Method

SpanTermQuery ExtractTerms Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ExtractTerms(
    ISet<Term> terms
)
public override void ExtractTerms(
    ISet<Term> terms
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
Public Overrides Sub ExtractTerms ( _
    terms As ISet(Of Term) _
)
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
public:
virtual void ExtractTerms(
    ISet<Term^>^ terms
) override
Parameters
terms
Type:   Online System.Collections.Generic ISet  Term
See Also
SpanTermQuery Class
SpanTermQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

SpanTermQuery GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
SpanTermQuery Class
SpanTermQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSpans Method

SpanTermQuery GetSpans Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Spans GetSpans(
    IndexReader reader
)
public override Spans GetSpans(
    IndexReader reader
)
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
See Also
SpanTermQuery Class
SpanTermQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

SpanTermQuery ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ToString | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query ToString(String).)
Back to Top
See Also
SpanTermQuery Class
SpanTermQuery Members
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (String)

SpanTermQuery ToString Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString(
    string field
)
public override string ToString(
    string field
)
Public Overrides Function ToString ( _
    field As String _
) As String
Public Overrides Function ToString ( _
    field As String _
) As String
public:
virtual String^ ToString(
    String^ field
) override
public:
virtual String^ ToString(
    String^ field
) override
Parameters
field
Type:   Online System String
See Also
SpanTermQuery Class
SpanTermQuery Members
ToString Overload
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanTermQuery Properties

SpanTermQuery Properties Lucene.Net Class Library
The SpanTermQuery type exposes the following members.
Properties
 | Name | Description
Public property | Boost | Gets or sets the boost for this query clause to b. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by b. The boost is 1.0 by default. (Inherited from Query.)
Public property | Field | (Overrides SpanQuery Field.)
Public property | Term | Return the term whose spans are matched.
Back to Top
See Also
SpanTermQuery Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Field Property

SpanTermQuery Field Property Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Field { get; }
public override string Field { get; }
Public Overrides ReadOnly Property Field As String
    Get
Public Overrides ReadOnly Property Field As String
    Get
public:
virtual property String^ Field {
    String^ get () override;
}
public:
virtual property String^ Field {
    String^ get () override;
}
See Also
SpanTermQuery Class
SpanTermQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Term Property

SpanTermQuery Term Property Lucene.Net Class Library
Return the term whose spans are matched.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Term Term { get; }
public virtual Term Term { get; }
Public Overridable ReadOnly Property Term As Term
    Get
Public Overridable ReadOnly Property Term As Term
    Get
public:
virtual property Term^ Term {
    Term^ get ();
}
public:
virtual property Term^ Term {
    Term^ get ();
}
See Also
SpanTermQuery Class
SpanTermQuery Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanWeight Class

SpanWeight Class Lucene.Net Class Library
Expert-only. Public for use by other weight implementations
Inheritance Hierarchy
Online System Object
Lucene.Net.Search Weight
Lucene.Net.Search.Spans SpanWeight
Lucene.Net.Search.Payloads PayloadNearQuery PayloadNearSpanWeight
Lucene.Net.Search.Payloads PayloadTermQuery PayloadTermWeight

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SpanWeight : Weight
[SerializableAttribute]
public class SpanWeight : Weight
<SerializableAttribute> _
Public Class SpanWeight _
    Inherits Weight
<SerializableAttribute> _
Public Class SpanWeight _
    Inherits Weight
[SerializableAttribute]
public ref class SpanWeight : public Weight
[SerializableAttribute]
public ref class SpanWeight : public Weight
See Also
SpanWeight Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanWeight Members

SpanWeight Members Lucene.Net Class Library

The SpanWeight type exposes the following members.
Constructors
 | Name | Description
Public method | SpanWeight | Initializes a new instance of the SpanWeight class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | (Overrides Weight Explain(IndexReader, Int32).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetScoresDocsOutOfOrder | Returns true iff this implementation scores docs only out of order. This method is used in conjunction with Collector's AcceptsDocsOutOfOrder and Scorer(IndexReader, Boolean, Boolean) to create a matching Scorer(IndexReader, Boolean, Boolean) instance for a given Collector, or vice versa. NOTE: the default implementation returns false, i.e. the Scorer scores documents in-order. (Inherited from Weight.)
Public method | GetSumOfSquaredWeights | (Overrides Weight GetSumOfSquaredWeights .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Normalize | (Overrides Weight Normalize(Single).)
Public method | Scorer | (Overrides Weight Scorer(IndexReader, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | idf |
Protected field | internalQuery |
Protected field | queryNorm |
Protected field | queryWeight |
Protected field | similarity |
Protected field | terms |
Protected field | value_Renamed |
Back to Top
Properties
 | Name | Description
Public property | Query | (Overrides Weight Query.)
Public property | Value | (Overrides Weight Value.)
Back to Top
See Also
SpanWeight Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanWeight Constructor

SpanWeight Constructor Lucene.Net Class Library
Initializes a new instance of the SpanWeight class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SpanWeight(
    SpanQuery query,
    Searcher searcher
)
public SpanWeight(
    SpanQuery query,
    Searcher searcher
)
Public Sub New ( _
    query As SpanQuery, _
    searcher As Searcher _
)
Public Sub New ( _
    query As SpanQuery, _
    searcher As Searcher _
)
public:
SpanWeight(
    SpanQuery^ query,
    Searcher^ searcher
)
public:
SpanWeight(
    SpanQuery^ query,
    Searcher^ searcher
)
Parameters
query
Type: Lucene.Net.Search.Spans SpanQuery
searcher
Type: Lucene.Net.Search Searcher
See Also
SpanWeight Class
SpanWeight Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanWeight Fields

SpanWeight Fields Lucene.Net Class Library
The SpanWeight type exposes the following members.
Fields
 | Name | Description
Protected field | idf |
Protected field | internalQuery |
Protected field | queryNorm |
Protected field | queryWeight |
Protected field | similarity |
Protected field | terms |
Protected field | value_Renamed |
Back to Top
See Also
SpanWeight Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


idf Field

SpanWeight idf Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected float idf
protected float idf
Protected idf As Single
Protected idf As Single
protected:
float idf
protected:
float idf
See Also
SpanWeight Class
SpanWeight Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalQuery Field

SpanWeight internalQuery Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SpanQuery internalQuery
protected SpanQuery internalQuery
Protected internalQuery As SpanQuery
Protected internalQuery As SpanQuery
protected:
SpanQuery^ internalQuery
protected:
SpanQuery^ internalQuery
See Also
SpanWeight Class
SpanWeight Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


queryNorm Field

SpanWeight queryNorm Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected float queryNorm
protected float queryNorm
Protected queryNorm As Single
Protected queryNorm As Single
protected:
float queryNorm
protected:
float queryNorm
See Also
SpanWeight Class
SpanWeight Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


queryWeight Field

SpanWeight queryWeight Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected float queryWeight
protected float queryWeight
Protected queryWeight As Single
Protected queryWeight As Single
protected:
float queryWeight
protected:
float queryWeight
See Also
SpanWeight Class
SpanWeight Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


similarity Field

SpanWeight similarity Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Similarity similarity
protected Similarity similarity
Protected similarity As Similarity
Protected similarity As Similarity
protected:
Similarity^ similarity
protected:
Similarity^ similarity
See Also
SpanWeight Class
SpanWeight Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


terms Field

SpanWeight terms Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ISet<Term> terms
protected ISet<Term> terms
Protected terms As ISet(Of Term)
Protected terms As ISet(Of Term)
protected:
ISet<Term^>^ terms
protected:
ISet<Term^>^ terms
See Also
SpanWeight Class
SpanWeight Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


value_Renamed Field

SpanWeight value_Renamed Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected float value_Renamed
protected float value_Renamed
Protected value_Renamed As Single
Protected value_Renamed As Single
protected:
float value_Renamed
protected:
float value_Renamed
See Also
SpanWeight Class
SpanWeight Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanWeight Methods

SpanWeight Methods Lucene.Net Class Library
The SpanWeight type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Explain | (Overrides Weight Explain(IndexReader, Int32).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetScoresDocsOutOfOrder | Returns true iff this implementation scores docs only out of order. This method is used in conjunction with Collector's AcceptsDocsOutOfOrder and Scorer(IndexReader, Boolean, Boolean) to create a matching Scorer(IndexReader, Boolean, Boolean) instance for a given Collector, or vice versa. NOTE: the default implementation returns false, i.e. the Scorer scores documents in-order. (Inherited from Weight.)
Public method | GetSumOfSquaredWeights | (Overrides Weight GetSumOfSquaredWeights .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Normalize | (Overrides Weight Normalize(Single).)
Public method | Scorer | (Overrides Weight Scorer(IndexReader, Boolean, Boolean).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SpanWeight Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Explain Method

SpanWeight Explain Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Explanation Explain(
    IndexReader reader,
    int doc
)
public override Explanation Explain(
    IndexReader reader,
    int doc
)
Public Overrides Function Explain ( _
    reader As IndexReader, _
    doc As Integer _
) As Explanation
Public Overrides Function Explain ( _
    reader As IndexReader, _
    doc As Integer _
) As Explanation
public:
virtual Explanation^ Explain(
    IndexReader^ reader,
    int doc
) override
public:
virtual Explanation^ Explain(
    IndexReader^ reader,
    int doc
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
doc
Type:   Online System Int32
See Also
SpanWeight Class
SpanWeight Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetSumOfSquaredWeights Method

SpanWeight GetSumOfSquaredWeights Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float GetSumOfSquaredWeights()
public override float GetSumOfSquaredWeights()
Public Overrides Function GetSumOfSquaredWeights As Single
Public Overrides Function GetSumOfSquaredWeights As Single
public:
virtual float GetSumOfSquaredWeights() override
public:
virtual float GetSumOfSquaredWeights() override
See Also
SpanWeight Class
SpanWeight Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Normalize Method

SpanWeight Normalize Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Normalize(
    float queryNorm
)
public override void Normalize(
    float queryNorm
)
Public Overrides Sub Normalize ( _
    queryNorm As Single _
)
Public Overrides Sub Normalize ( _
    queryNorm As Single _
)
public:
virtual void Normalize(
    float queryNorm
) override
public:
virtual void Normalize(
    float queryNorm
) override
Parameters
queryNorm
Type:   Online System Single
See Also
SpanWeight Class
SpanWeight Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Scorer Method

SpanWeight Scorer Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override
Parameters
reader
Type: Lucene.Net.Index IndexReader
scoreDocsInOrder
Type:   Online System Boolean
topScorer
Type:   Online System Boolean
See Also
SpanWeight Class
SpanWeight Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SpanWeight Properties

SpanWeight Properties Lucene.Net Class Library
The SpanWeight type exposes the following members.
Properties
 | Name | Description
Public property | Query | (Overrides Weight Query.)
Public property | Value | (Overrides Weight Value.)
Back to Top
See Also
SpanWeight Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Query Property

SpanWeight Query Property Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Query Query { get; }
public override Query Query { get; }
Public Overrides ReadOnly Property Query As Query
    Get
Public Overrides ReadOnly Property Query As Query
    Get
public:
virtual property Query^ Query {
    Query^ get () override;
}
public:
virtual property Query^ Query {
    Query^ get () override;
}
See Also
SpanWeight Class
SpanWeight Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Value Property

SpanWeight Value Property Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float Value { get; }
public override float Value { get; }
Public Overrides ReadOnly Property Value As Single
    Get
Public Overrides ReadOnly Property Value As Single
    Get
public:
virtual property float Value {
    float get () override;
}
public:
virtual property float Value {
    float get () override;
}
See Also
SpanWeight Class
SpanWeight Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermSpans Class

TermSpans Class Lucene.Net Class Library
Expert: Public for extension only
Inheritance Hierarchy
Online System Object
Lucene.Net.Search.Spans Spans
Lucene.Net.Search.Spans TermSpans

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TermSpans : Spans
public class TermSpans : Spans
Public Class TermSpans _
    Inherits Spans
Public Class TermSpans _
    Inherits Spans
public ref class TermSpans : public Spans
public ref class TermSpans : public Spans
See Also
TermSpans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermSpans Members

TermSpans Members Lucene.Net Class Library

The TermSpans type exposes the following members.
Constructors
 | Name | Description
Public method | TermSpans | Initializes a new instance of the TermSpans class
Back to Top
Methods
 | Name | Description
Public method | Doc | (Overrides Spans Doc .)
Public method | End | (Overrides Spans End .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPayload | (Overrides Spans GetPayload .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsPayloadAvailable | (Overrides Spans IsPayloadAvailable .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | (Overrides Spans Next .)
Public method | SkipTo | (Overrides Spans SkipTo(Int32).)
Public method | Start | (Overrides Spans Start .)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Fields
 | Name | Description
Protected field | count |
Protected field | freq |
Protected field | internalDoc |
Protected field | internalPositions |
Protected field | position |
Protected field | term |
Back to Top
Properties
 | Name | Description
Public property | Positions |
Back to Top
See Also
TermSpans Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermSpans Constructor

TermSpans Constructor Lucene.Net Class Library
Initializes a new instance of the TermSpans class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TermSpans(
    TermPositions positions,
    Term term
)
public TermSpans(
    TermPositions positions,
    Term term
)
Public Sub New ( _
    positions As TermPositions, _
    term As Term _
)
Public Sub New ( _
    positions As TermPositions, _
    term As Term _
)
public:
TermSpans(
    TermPositions^ positions,
    Term^ term
)
public:
TermSpans(
    TermPositions^ positions,
    Term^ term
)
Parameters
positions
Type: Lucene.Net.Index TermPositions
term
Type: Lucene.Net.Index Term
See Also
TermSpans Class
TermSpans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermSpans Fields

TermSpans Fields Lucene.Net Class Library
The TermSpans type exposes the following members.
Fields
 | Name | Description
Protected field | count |
Protected field | freq |
Protected field | internalDoc |
Protected field | internalPositions |
Protected field | position |
Protected field | term |
Back to Top
See Also
TermSpans Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


count Field

TermSpans count Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int count
protected int count
Protected count As Integer
Protected count As Integer
protected:
int count
protected:
int count
See Also
TermSpans Class
TermSpans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


freq Field

TermSpans freq Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int freq
protected int freq
Protected freq As Integer
Protected freq As Integer
protected:
int freq
protected:
int freq
See Also
TermSpans Class
TermSpans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalDoc Field

TermSpans internalDoc Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int internalDoc
protected int internalDoc
Protected internalDoc As Integer
Protected internalDoc As Integer
protected:
int internalDoc
protected:
int internalDoc
See Also
TermSpans Class
TermSpans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalPositions Field

TermSpans internalPositions Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TermPositions internalPositions
protected TermPositions internalPositions
Protected internalPositions As TermPositions
Protected internalPositions As TermPositions
protected:
TermPositions^ internalPositions
protected:
TermPositions^ internalPositions
See Also
TermSpans Class
TermSpans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


position Field

TermSpans position Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int position
protected int position
Protected position As Integer
Protected position As Integer
protected:
int position
protected:
int position
See Also
TermSpans Class
TermSpans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


term Field

TermSpans term Field Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Term term
protected Term term
Protected term As Term
Protected term As Term
protected:
Term^ term
protected:
Term^ term
See Also
TermSpans Class
TermSpans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermSpans Methods

TermSpans Methods Lucene.Net Class Library
The TermSpans type exposes the following members.
Methods
 | Name | Description
Public method | Doc | (Overrides Spans Doc .)
Public method | End | (Overrides Spans End .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPayload | (Overrides Spans GetPayload .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsPayloadAvailable | (Overrides Spans IsPayloadAvailable .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Next | (Overrides Spans Next .)
Public method | SkipTo | (Overrides Spans SkipTo(Int32).)
Public method | Start | (Overrides Spans Start .)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
TermSpans Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Doc Method

TermSpans Doc Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Doc()
public override int Doc()
Public Overrides Function Doc As Integer
Public Overrides Function Doc As Integer
public:
virtual int Doc() override
public:
virtual int Doc() override
See Also
TermSpans Class
TermSpans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


End Method

TermSpans End Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int End()
public override int End()
Public Overrides Function End As Integer
Public Overrides Function End As Integer
public:
virtual int End() override
public:
virtual int End() override
See Also
TermSpans Class
TermSpans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPayload Method

TermSpans GetPayload Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ICollection<byte[]> GetPayload()
public override ICollection<byte[]> GetPayload()
Public Overrides Function GetPayload As ICollection(Of Byte())
Public Overrides Function GetPayload As ICollection(Of Byte())
public:
virtual ICollection<array<unsigned char>^>^ GetPayload() override
public:
virtual ICollection<array<unsigned char>^>^ GetPayload() override
See Also
TermSpans Class
TermSpans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsPayloadAvailable Method

TermSpans IsPayloadAvailable Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsPayloadAvailable()
public override bool IsPayloadAvailable()
Public Overrides Function IsPayloadAvailable As Boolean
Public Overrides Function IsPayloadAvailable As Boolean
public:
virtual bool IsPayloadAvailable() override
public:
virtual bool IsPayloadAvailable() override
See Also
TermSpans Class
TermSpans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Next Method

TermSpans Next Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Next()
public override bool Next()
Public Overrides Function Next As Boolean
Public Overrides Function Next As Boolean
public:
virtual bool Next() override
public:
virtual bool Next() override
See Also
TermSpans Class
TermSpans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SkipTo Method

TermSpans SkipTo Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool SkipTo(
    int target
)
public override bool SkipTo(
    int target
)
Public Overrides Function SkipTo ( _
    target As Integer _
) As Boolean
Public Overrides Function SkipTo ( _
    target As Integer _
) As Boolean
public:
virtual bool SkipTo(
    int target
) override
public:
virtual bool SkipTo(
    int target
) override
Parameters
target
Type:   Online System Int32
See Also
TermSpans Class
TermSpans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Start Method

TermSpans Start Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Start()
public override int Start()
Public Overrides Function Start As Integer
Public Overrides Function Start As Integer
public:
virtual int Start() override
public:
virtual int Start() override
See Also
TermSpans Class
TermSpans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

TermSpans ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
TermSpans Class
TermSpans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TermSpans Properties

TermSpans Properties Lucene.Net Class Library
The TermSpans type exposes the following members.
Properties
 | Name | Description
Public property | Positions |
Back to Top
See Also
TermSpans Class
Lucene.Net.Search.Spans Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Positions Property

TermSpans Positions Property Lucene.Net Class Library

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual TermPositions Positions { get; }
public virtual TermPositions Positions { get; }
Public Overridable ReadOnly Property Positions As TermPositions
    Get
Public Overridable ReadOnly Property Positions As TermPositions
    Get
public:
virtual property TermPositions^ Positions {
    TermPositions^ get ();
}
public:
virtual property TermPositions^ Positions {
    TermPositions^ get ();
}
See Also
TermSpans Class
TermSpans Members
Lucene.Net.Search.Spans Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lucene.Net.Store Namespace

Lucene.Net.Store Namespace Lucene.Net Class Library
Classes
Class | Description
Public class AlreadyClosedException
This exception is thrown when there is an attempt to access something that has already been closed.
Public class BufferedIndexInput
Base implementation class for buffered IndexInput.
Public class BufferedIndexOutput
Base implementation class for buffered IndexOutput.
Public class ChecksumIndexInput
Writes bytes through to a primary IndexOutput, computing checksum as it goes. Note that you cannot use seek().
Public class ChecksumIndexOutput
Writes bytes through to a primary IndexOutput, computing checksum. Note that you cannot use seek().
Public class Directory
A Directory is a flat list of files. Files may be written once, when they are created. Once a file is created it may only be opened for read, or deleted. Random access is permitted both when reading and writing.

Java's i/o APIs not used directly, but rather all i/o is through this API. This permits things such as: implementation of RAM-based indices; implementation indices stored in a database, via JDBC; implementation of an index as a single file; Directory locking is implemented by an instance of LockFactory , and can be changed for each Directory instance using SetLockFactory(LockFactory).
Public class FileSwitchDirectory
Expert: A Directory instance that switches files between two other Directory instances.

Files with the specified extensions are placed in the primary directory; others are placed in the secondary directory. The provided Set must not change once passed to this class, and must allow multiple threads to call contains at once.

NOTE: this API is new and experimental and is subject to suddenly change in the next release.
Public class FSDirectory
Base class for Directory implementations that store index files in the file system. There are currently three core subclasses:
  • SimpleFSDirectory is a straightforward implementation using java.io.RandomAccessFile. However, it has poor concurrent performance (multiple threads will bottleneck) as it synchronizes when multiple threads read from the same file.
  • NIOFSDirectory uses java.nio's FileChannel's positional io when reading to avoid synchronization when reading from the same file. Unfortunately, due to a Windows-only Online Sun JRE bug this is a poor choice for Windows, but on all other platforms this is the preferred choice. Applications using Online Interrupt or Future#cancel(boolean) (on Java 1.5) should use SimpleFSDirectory instead. See NIOFSDirectory java doc for details. MMapDirectory uses memory-mapped IO when reading. This is a good choice if you have plenty of virtual memory relative to your index size, eg if you are running on a 64 bit JRE, or you are running on a 32 bit JRE but your index sizes are small enough to fit into the virtual memory space. Java has currently the limitation of not being able to unmap files from user code. The files are unmapped, when GC releases the byte buffers. Due to Online this bug in Sun's JRE, MMapDirectory's Close is unable to close the underlying OS file handle. Only when GC finally collects the underlying objects, which could be quite some time later, will the file handle be closed. This will consume additional transient disk usage: on Windows, attempts to delete or overwrite the files will result in an exception; on other platforms, which typically have a "delete on last close" semantics, while such operations will succeed, the bytes are still consuming space on disk. For many applications this limitation is not a problem (e.g. if you have plenty of disk space, and you don't rely on overwriting files on Windows) but it's still an important limitation to be aware of. This class supplies a (possibly dangerous) workaround mentioned in the bug report, which may fail on non-Sun JVMs. Applications using Online Interrupt or Future#cancel(boolean) (on Java 1.5) should use SimpleFSDirectory instead. See MMapDirectory java doc for details.
Unfortunately, because of system peculiarities, there is no single overall best implementation. Therefore, we've added the Open(DirectoryInfo) method, to allow Lucene to choose the best FSDirectory implementation given your environment, and the known limitations of each implementation. For users who have no reason to prefer a specific implementation, it's best to simply use Open(DirectoryInfo) . For all others, you should instantiate the desired implementation directly.

The locking implementation is by default NativeFSLockFactory , but can be changed by passing in a custom LockFactory instance.
Public class FSLockFactory
Base class for file system based locking implementation.
Public class IndexInput
Abstract base class for input from a file in a Directory. A random-access input stream. Used for all Lucene index input operations.
Public class IndexOutput
Abstract base class for output to a file in a Directory. A random-access output stream. Used for all Lucene index output operations.
Public class Lock
An interprocess mutex lock.

Typical use might look like:
View Colorized Copy to Clipboard Print
new Lock.With(directory.makeLock("my.lock")) {
public Object doBody() {
<i>... code to execute while locked ...</i>
}
}.run();
new Lock.With(directory.makeLock("my.lock")) {
public Object doBody() {
<i>... code to execute while locked ...</i>
}
}.run();
Public class Lock With
Utility class for executing code with exclusive access.
Public class LockFactory

Base class for Locking implementation. Directory uses instances of this class to implement locking.

Note that there are some useful tools to verify that your LockFactory is working correctly: VerifyingLockFactory , LockStressTest, LockVerifyServer .

Public class LockObtainFailedException
This exception is thrown when the write.lock could not be acquired. This happens when a writer tries to open an index that another writer already has open.
Public class LockReleaseFailedException
This exception is thrown when the write.lock could not be released.
Public class LockStressTest
Simple standalone tool that forever acquires & releases a lock using a specific LockFactory. Run without any args to see usage.
Public class LockVerifyServer
Simple standalone server that must be running when you use VerifyingLockFactory. This server simply verifies at most one process holds the lock at a time. Run without any args to see usage.
Public class MMapDirectory
File-based Directory implementation that uses mmap for reading, and SimpleFSDirectory SimpleFSIndexOutput for writing.

NOTE: memory mapping uses up a portion of the virtual memory address space in your process equal to the size of the file being mapped. Before using this class, be sure your have plenty of virtual address space, e.g. by using a 64 bit JRE, or a 32 bit JRE with indexes that are guaranteed to fit within the address space. On 32 bit platforms also consult MaxChunkSize if you have problems with mmap failing because of fragmented address space. If you get an OutOfMemoryException, it is recommened to reduce the chunk size, until it works.

Due to Online this bug in Sun's JRE, MMapDirectory's Close is unable to close the underlying OS file handle. Only when GC finally collects the underlying objects, which could be quite some time later, will the file handle be closed.

This will consume additional transient disk usage: on Windows, attempts to delete or overwrite the files will result in an exception; on other platforms, which typically have a "delete on last close" semantics, while such operations will succeed, the bytes are still consuming space on disk. For many applications this limitation is not a problem (e.g. if you have plenty of disk space, and you don't rely on overwriting files on Windows) but it's still an important limitation to be aware of.

This class supplies the workaround mentioned in the bug report (disabled by default, see UseUnmap), which may fail on non-Sun JVMs. It forcefully unmaps the buffer on close by using an undocumented internal cleanup functionality. UNMAP_SUPPORTED is true, if the workaround can be enabled (with no guarantees).
Protected class | MMapDirectory MultiMMapIndexInput
Public class NativeFSLockFactory

Implements LockFactory using native OS file locks. Note that because this LockFactory relies on java.nio.* APIs for locking, any problems with those APIs will cause locking to fail. Specifically, on certain NFS environments the java.nio.* locks will fail (the lock can incorrectly be double acquired) whereas SimpleFSLockFactory worked perfectly in those same environments. For NFS based access to an index, it's recommended that you try SimpleFSLockFactory first and work around the one limitation that a lock file could be left when the JVM exits abnormally.

The primary benefit of NativeFSLockFactory is that lock files will be properly removed (by the OS) if the JVM has an abnormal exit.

Note that, unlike SimpleFSLockFactory, the existence of leftover lock files in the filesystem on exiting the JVM is fine because the OS will free the locks held against these files even though the files still remain.

If you suspect that this or any other LockFactory is not working properly in your environment, you can easily test it by using VerifyingLockFactory, LockVerifyServer and LockStressTest.

Public class NIOFSDirectory
Not implemented. Waiting for volunteers.
Public class NIOFSDirectory NIOFSIndexInput
Not implemented. Waiting for volunteers.
Public class NoLockFactory
Use this LockFactory to disable locking entirely. Only one instance of this lock is created. You should call Instance to get the instance.
Public class NoSuchDirectoryException
This exception is thrown when you try to list a non-existent directory.
Public class RAMDirectory
A memory-resident Directory implementation. Locking implementation is by default the SingleInstanceLockFactory but can be changed with SetLockFactory(LockFactory).
Public class | RAMFile
Public class RAMInputStream
A memory-resident IndexInput implementation.
Public class RAMOutputStream
A memory-resident IndexOutput implementation.

For lucene internal use.

Public class SimpleFSDirectory
A straightforward implementation of FSDirectory using java.io.RandomAccessFile. However, this class has poor concurrent performance (multiple threads will bottleneck) as it synchronizes when multiple threads read from the same file. It's usually better to use NIOFSDirectory or MMapDirectory instead.
Protected class | SimpleFSDirectory SimpleFSIndexInput
Protected class | SimpleFSDirectory SimpleFSIndexInput Descriptor
Public class | SimpleFSDirectory SimpleFSIndexOutput
Public class SimpleFSLockFactory

Implements LockFactory using Online Create .

NOTE: the Online javadocs for File.createNewFile contain a vague yet spooky warning about not using the API for file locking. This warning was added due to Online this bug, and in fact the only known problem with using this API for locking is that the Lucene write lock may not be released when the JVM exits abnormally.

When this happens, a LockObtainFailedException is hit when trying to create a writer, in which case you need to explicitly clear the lock file first. You can either manually remove the file, or use the Unlock(Directory) API. But, first be certain that no writer is in fact writing to the index otherwise you can easily corrupt your index.

If you suspect that this or any other LockFactory is not working properly in your environment, you can easily test it by using VerifyingLockFactory, LockVerifyServer and LockStressTest.

Public class SingleInstanceLockFactory
Implements LockFactory for a single in-process instance, meaning all locking will take place through this one instance. Only use this LockFactory when you are certain all IndexReaders and IndexWriters for a given index are running against a single shared in-process Directory instance. This is currently the default locking for RAMDirectory.
Public class VerifyingLockFactory
A LockFactory that wraps another LockFactory and verifies that each lock obtain/release is "correct" (never results in two processes holding the lock at the same time). It does this by contacting an external server (LockVerifyServer) to assert that at most one process holds the lock at a time. To use this, you should also run LockVerifyServer on the host & port matching what you pass to the constructor.

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AlreadyClosedException Class

AlreadyClosedException Class Lucene.Net Class Library
This exception is thrown when there is an attempt to access something that has already been closed.
Inheritance Hierarchy
Online System Object
Online System Exception
Online System SystemException
Lucene.Net.Store AlreadyClosedException

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class AlreadyClosedException : SystemException
[SerializableAttribute]
public class AlreadyClosedException : SystemException
<SerializableAttribute> _
Public Class AlreadyClosedException _
    Inherits SystemException
<SerializableAttribute> _
Public Class AlreadyClosedException _
    Inherits SystemException
[SerializableAttribute]
public ref class AlreadyClosedException : public SystemException
[SerializableAttribute]
public ref class AlreadyClosedException : public SystemException
See Also
AlreadyClosedException Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AlreadyClosedException Members

AlreadyClosedException Members Lucene.Net Class Library

The AlreadyClosedException type exposes the following members.
Constructors
 | Name | Description
Public method | AlreadyClosedException | Initializes a new instance of the AlreadyClosedException class
Public method | AlreadyClosedException(String) | Initializes a new instance of the AlreadyClosedException class
Protected method | AlreadyClosedException(SerializationInfo, StreamingContext) | Initializes a new instance of the AlreadyClosedException class
Public method | AlreadyClosedException(String, Exception) | Initializes a new instance of the AlreadyClosedException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
AlreadyClosedException Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AlreadyClosedException Constructor

AlreadyClosedException Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | AlreadyClosedException | Initializes a new instance of the AlreadyClosedException class
Public method | AlreadyClosedException(String) | Initializes a new instance of the AlreadyClosedException class
Protected method | AlreadyClosedException(SerializationInfo, StreamingContext) | Initializes a new instance of the AlreadyClosedException class
Public method | AlreadyClosedException(String, Exception) | Initializes a new instance of the AlreadyClosedException class
Back to Top
See Also
AlreadyClosedException Class
AlreadyClosedException Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AlreadyClosedException Constructor

AlreadyClosedException Constructor Lucene.Net Class Library
Initializes a new instance of the AlreadyClosedException class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AlreadyClosedException()
public AlreadyClosedException()
Public Sub New
Public Sub New
public:
AlreadyClosedException()
public:
AlreadyClosedException()
See Also
AlreadyClosedException Class
AlreadyClosedException Members
AlreadyClosedException Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AlreadyClosedException Constructor (String)

AlreadyClosedException Constructor (String) Lucene.Net Class Library
Initializes a new instance of the AlreadyClosedException class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AlreadyClosedException(
    string message
)
public AlreadyClosedException(
    string message
)
Public Sub New ( _
    message As String _
)
Public Sub New ( _
    message As String _
)
public:
AlreadyClosedException(
    String^ message
)
public:
AlreadyClosedException(
    String^ message
)
Parameters
message
Type:   Online System String
See Also
AlreadyClosedException Class
AlreadyClosedException Members
AlreadyClosedException Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AlreadyClosedException Constructor (SerializationInfo, StreamingContext)

AlreadyClosedException Constructor (SerializationInfo, StreamingContext) Lucene.Net Class Library
Initializes a new instance of the AlreadyClosedException class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected AlreadyClosedException(
    SerializationInfo info,
    StreamingContext context
)
protected AlreadyClosedException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
AlreadyClosedException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
AlreadyClosedException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info
Type:   Online System.Runtime.Serialization SerializationInfo
context
Type:   Online System.Runtime.Serialization StreamingContext
See Also
AlreadyClosedException Class
AlreadyClosedException Members
AlreadyClosedException Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AlreadyClosedException Constructor (String, Exception)

AlreadyClosedException Constructor (String, Exception) Lucene.Net Class Library
Initializes a new instance of the AlreadyClosedException class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AlreadyClosedException(
    string message,
    Exception inner
)
public AlreadyClosedException(
    string message,
    Exception inner
)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
public:
AlreadyClosedException(
    String^ message,
    Exception^ inner
)
public:
AlreadyClosedException(
    String^ message,
    Exception^ inner
)
Parameters
message
Type:   Online System String
inner
Type:   Online System Exception
See Also
AlreadyClosedException Class
AlreadyClosedException Members
AlreadyClosedException Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AlreadyClosedException Methods

AlreadyClosedException Methods Lucene.Net Class Library
The AlreadyClosedException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
AlreadyClosedException Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AlreadyClosedException Properties

AlreadyClosedException Properties Lucene.Net Class Library
The AlreadyClosedException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
AlreadyClosedException Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AlreadyClosedException Events

AlreadyClosedException Events Lucene.Net Class Library
The AlreadyClosedException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
AlreadyClosedException Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BufferedIndexInput Class

BufferedIndexInput Class Lucene.Net Class Library
Base implementation class for buffered IndexInput.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store IndexInput
Lucene.Net.Store BufferedIndexInput
Lucene.Net.Index CompoundFileReader CSIndexInput
Lucene.Net.Store SimpleFSDirectory SimpleFSIndexInput

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class BufferedIndexInput : IndexInput,
    ICloneable
public abstract class BufferedIndexInput : IndexInput,
    ICloneable
Public MustInherit Class BufferedIndexInput _
    Inherits IndexInput _
    Implements ICloneable
Public MustInherit Class BufferedIndexInput _
    Inherits IndexInput _
    Implements ICloneable
public ref class BufferedIndexInput abstract : public IndexInput,
    ICloneable
public ref class BufferedIndexInput abstract : public IndexInput,
    ICloneable
See Also
BufferedIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BufferedIndexInput Members

BufferedIndexInput Members Lucene.Net Class Library

The BufferedIndexInput type exposes the following members.
Constructors
 | Name | Description
Protected method | BufferedIndexInput | Initializes a new instance of the BufferedIndexInput class
Protected method | BufferedIndexInput(Int32) | Inits BufferedIndexInput with a specific bufferSize
Back to Top
Methods
 | Name | Description
Public method | Clone | (Overrides IndexInput Clone .)
Public method | Close | Obsolete. (Inherited from IndexInput.)
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | (Inherited from IndexInput.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Length | The number of bytes in the file. (Inherited from IndexInput.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | NewBuffer |
Public method | ReadByte | (Overrides IndexInput ReadByte .)
Public method | ReadBytes( Byte , Int32, Int32) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32).)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32, Boolean).)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadInternal | Expert: implements buffer refill. Reads bytes from the current position in the input.
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput Seek(Int64).)
Public method | SeekInternal | Expert: implements seek. Sets current position in this file, where the next ReadInternal( Byte , Int32, Int32) will occur.
Public method | SetBufferSize | Change the buffer size used by this IndexInput
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to ReadChars( Char , Int32, Int32) but does not do any conversion operations on the bytes it is reading in. It still has to invoke ReadByte just as ReadChars( Char , Int32, Int32) does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | buffer |
 | BUFFER_SIZE | Default buffer size
Back to Top
Properties
 | Name | Description
Public property | BufferSize |
Public property | FilePointer | (Overrides IndexInput FilePointer.)
Back to Top
See Also
BufferedIndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BufferedIndexInput Constructor

BufferedIndexInput Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Protected method | BufferedIndexInput | Initializes a new instance of the BufferedIndexInput class
Protected method | BufferedIndexInput(Int32) | Inits BufferedIndexInput with a specific bufferSize
Back to Top
See Also
BufferedIndexInput Class
BufferedIndexInput Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BufferedIndexInput Constructor

BufferedIndexInput Constructor Lucene.Net Class Library
Initializes a new instance of the BufferedIndexInput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected BufferedIndexInput()
protected BufferedIndexInput()
Protected Sub New
Protected Sub New
protected:
BufferedIndexInput()
protected:
BufferedIndexInput()
See Also
BufferedIndexInput Class
BufferedIndexInput Members
BufferedIndexInput Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BufferedIndexInput Constructor (Int32)

BufferedIndexInput Constructor (Int32) Lucene.Net Class Library
Inits BufferedIndexInput with a specific bufferSize

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected BufferedIndexInput(
    int bufferSize
)
protected BufferedIndexInput(
    int bufferSize
)
Protected Sub New ( _
    bufferSize As Integer _
)
Protected Sub New ( _
    bufferSize As Integer _
)
protected:
BufferedIndexInput(
    int bufferSize
)
protected:
BufferedIndexInput(
    int bufferSize
)
Parameters
bufferSize
Type:   Online System Int32
See Also
BufferedIndexInput Class
BufferedIndexInput Members
BufferedIndexInput Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BufferedIndexInput Fields

BufferedIndexInput Fields Lucene.Net Class Library
The BufferedIndexInput type exposes the following members.
Fields
 | Name | Description
Protected field | buffer |
 | BUFFER_SIZE | Default buffer size
Back to Top
See Also
BufferedIndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


buffer Field

BufferedIndexInput buffer Field Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected byte[] buffer
protected byte[] buffer
Protected buffer As Byte()
Protected buffer As Byte()
protected:
array<unsigned char>^ buffer
protected:
array<unsigned char>^ buffer
See Also
BufferedIndexInput Class
BufferedIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BUFFER_SIZE Field

BufferedIndexInput BUFFER_SIZE Field Lucene.Net Class Library
Default buffer size

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int BUFFER_SIZE
public const int BUFFER_SIZE
Public Const BUFFER_SIZE As Integer
Public Const BUFFER_SIZE As Integer
public:
literal int BUFFER_SIZE
public:
literal int BUFFER_SIZE
See Also
BufferedIndexInput Class
BufferedIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BufferedIndexInput Methods

BufferedIndexInput Methods Lucene.Net Class Library
The BufferedIndexInput type exposes the following members.
Methods
 | Name | Description
Public method | Clone | (Overrides IndexInput Clone .)
Public method | Close | Obsolete. (Inherited from IndexInput.)
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | (Inherited from IndexInput.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Length | The number of bytes in the file. (Inherited from IndexInput.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | NewBuffer |
Public method | ReadByte | (Overrides IndexInput ReadByte .)
Public method | ReadBytes( Byte , Int32, Int32) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32).)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32, Boolean).)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadInternal | Expert: implements buffer refill. Reads bytes from the current position in the input.
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput Seek(Int64).)
Public method | SeekInternal | Expert: implements seek. Sets current position in this file, where the next ReadInternal( Byte , Int32, Int32) will occur.
Public method | SetBufferSize | Change the buffer size used by this IndexInput
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to ReadChars( Char , Int32, Int32) but does not do any conversion operations on the bytes it is reading in. It still has to invoke ReadByte just as ReadChars( Char , Int32, Int32) does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
BufferedIndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

BufferedIndexInput Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
BufferedIndexInput Class
BufferedIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewBuffer Method

BufferedIndexInput NewBuffer Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void NewBuffer(
    byte[] newBuffer
)
protected virtual void NewBuffer(
    byte[] newBuffer
)
Protected Overridable Sub NewBuffer ( _
    newBuffer As Byte() _
)
Protected Overridable Sub NewBuffer ( _
    newBuffer As Byte() _
)
protected:
virtual void NewBuffer(
    array<unsigned char>^ newBuffer
)
protected:
virtual void NewBuffer(
    array<unsigned char>^ newBuffer
)
Parameters
newBuffer
Type:    Online System Byte
See Also
BufferedIndexInput Class
BufferedIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadByte Method

BufferedIndexInput ReadByte Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override byte ReadByte()
public override byte ReadByte()
Public Overrides Function ReadByte As Byte
Public Overrides Function ReadByte As Byte
public:
virtual unsigned char ReadByte() override
public:
virtual unsigned char ReadByte() override
See Also
BufferedIndexInput Class
BufferedIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadBytes Method

BufferedIndexInput ReadBytes Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ReadBytes( Byte , Int32, Int32) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32).)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32, Boolean).)
Back to Top
See Also
BufferedIndexInput Class
BufferedIndexInput Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadBytes Method (Byte[], Int32, Int32)

BufferedIndexInput ReadBytes Method ( Byte , Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ReadBytes(
    byte[] b,
    int offset,
    int len
)
public override void ReadBytes(
    byte[] b,
    int offset,
    int len
)
Public Overrides Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Public Overrides Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) override
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) override
Parameters
b
Type:    Online System Byte
offset
Type:   Online System Int32
len
Type:   Online System Int32
See Also
BufferedIndexInput Class
BufferedIndexInput Members
ReadBytes Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadBytes Method (Byte[], Int32, Int32, Boolean)

BufferedIndexInput ReadBytes Method ( Byte , Int32, Int32, Boolean) Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ReadBytes(
    byte[] b,
    int offset,
    int len,
    bool useBuffer
)
public override void ReadBytes(
    byte[] b,
    int offset,
    int len,
    bool useBuffer
)
Public Overrides Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer, _
    useBuffer As Boolean _
)
Public Overrides Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer, _
    useBuffer As Boolean _
)
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len,
    bool useBuffer
) override
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len,
    bool useBuffer
) override
Parameters
b
Type:    Online System Byte
offset
Type:   Online System Int32
len
Type:   Online System Int32
useBuffer
Type:   Online System Boolean
See Also
BufferedIndexInput Class
BufferedIndexInput Members
ReadBytes Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadInternal Method

BufferedIndexInput ReadInternal Method Lucene.Net Class Library
Expert: implements buffer refill. Reads bytes from the current position in the input.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void ReadInternal(
    byte[] b,
    int offset,
    int length
)
public abstract void ReadInternal(
    byte[] b,
    int offset,
    int length
)
Public MustOverride Sub ReadInternal ( _
    b As Byte(), _
    offset As Integer, _
    length As Integer _
)
Public MustOverride Sub ReadInternal ( _
    b As Byte(), _
    offset As Integer, _
    length As Integer _
)
public:
virtual void ReadInternal(
    array<unsigned char>^ b,
    int offset,
    int length
) abstract
public:
virtual void ReadInternal(
    array<unsigned char>^ b,
    int offset,
    int length
) abstract
Parameters
b
Type:    Online System Byte
the array to read bytes into

offset
Type:   Online System Int32
the offset in the array to start storing bytes

length
Type:   Online System Int32
the number of bytes to read

See Also
BufferedIndexInput Class
BufferedIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method

BufferedIndexInput Seek Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Seek(
    long pos
)
public override void Seek(
    long pos
)
Public Overrides Sub Seek ( _
    pos As Long _
)
Public Overrides Sub Seek ( _
    pos As Long _
)
public:
virtual void Seek(
    long long pos
) override
public:
virtual void Seek(
    long long pos
) override
Parameters
pos
Type:   Online System Int64
See Also
BufferedIndexInput Class
BufferedIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SeekInternal Method

BufferedIndexInput SeekInternal Method Lucene.Net Class Library
Expert: implements seek. Sets current position in this file, where the next ReadInternal( Byte , Int32, Int32) will occur.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void SeekInternal(
    long pos
)
public abstract void SeekInternal(
    long pos
)
Public MustOverride Sub SeekInternal ( _
    pos As Long _
)
Public MustOverride Sub SeekInternal ( _
    pos As Long _
)
public:
virtual void SeekInternal(
    long long pos
) abstract
public:
virtual void SeekInternal(
    long long pos
) abstract
Parameters
pos
Type:   Online System Int64
See Also
BufferedIndexInput Class
BufferedIndexInput Members
Lucene.Net.Store Namespace
BufferedIndexInput ReadInternal( Byte , Int32, Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetBufferSize Method

BufferedIndexInput SetBufferSize Method Lucene.Net Class Library
Change the buffer size used by this IndexInput

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetBufferSize(
    int newSize
)
public virtual void SetBufferSize(
    int newSize
)
Public Overridable Sub SetBufferSize ( _
    newSize As Integer _
)
Public Overridable Sub SetBufferSize ( _
    newSize As Integer _
)
public:
virtual void SetBufferSize(
    int newSize
)
public:
virtual void SetBufferSize(
    int newSize
)
Parameters
newSize
Type:   Online System Int32
See Also
BufferedIndexInput Class
BufferedIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BufferedIndexInput Properties

BufferedIndexInput Properties Lucene.Net Class Library
The BufferedIndexInput type exposes the following members.
Properties
 | Name | Description
Public property | BufferSize |
Public property | FilePointer | (Overrides IndexInput FilePointer.)
Back to Top
See Also
BufferedIndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BufferSize Property

BufferedIndexInput BufferSize Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int BufferSize { get; }
public virtual int BufferSize { get; }
Public Overridable ReadOnly Property BufferSize As Integer
    Get
Public Overridable ReadOnly Property BufferSize As Integer
    Get
public:
virtual property int BufferSize {
    int get ();
}
public:
virtual property int BufferSize {
    int get ();
}
See Also
BufferedIndexInput Class
BufferedIndexInput Members
Lucene.Net.Store Namespace
BufferedIndexInput SetBufferSize(Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilePointer Property

BufferedIndexInput FilePointer Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long FilePointer { get; }
public override long FilePointer { get; }
Public Overrides ReadOnly Property FilePointer As Long
    Get
Public Overrides ReadOnly Property FilePointer As Long
    Get
public:
virtual property long long FilePointer {
    long long get () override;
}
public:
virtual property long long FilePointer {
    long long get () override;
}
See Also
BufferedIndexInput Class
BufferedIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BufferedIndexOutput Class

BufferedIndexOutput Class Lucene.Net Class Library
Base implementation class for buffered IndexOutput.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store IndexOutput
Lucene.Net.Store BufferedIndexOutput
Lucene.Net.Store SimpleFSDirectory SimpleFSIndexOutput

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class BufferedIndexOutput : IndexOutput
public abstract class BufferedIndexOutput : IndexOutput
Public MustInherit Class BufferedIndexOutput _
    Inherits IndexOutput
Public MustInherit Class BufferedIndexOutput _
    Inherits IndexOutput
public ref class BufferedIndexOutput abstract : public IndexOutput
public ref class BufferedIndexOutput abstract : public IndexOutput
See Also
BufferedIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BufferedIndexOutput Members

BufferedIndexOutput Members Lucene.Net Class Library

The BufferedIndexOutput type exposes the following members.
Constructors
 | Name | Description
Protected method | BufferedIndexOutput | Initializes a new instance of the BufferedIndexOutput class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Closes this stream to further operations. (Inherited from IndexOutput.)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Dispose | Closes this stream to further operations. (Inherited from IndexOutput.)
Protected method | Dispose(Boolean) | Closes this stream to further operations. (Overrides IndexOutput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | Forces any buffered output to be written. (Overrides IndexOutput Flush .)
Public method | FlushBuffer | Expert: implements buffer write. Writes bytes at the current position in the output.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Seek | Sets current position in this file, where the next write will occur. (Overrides IndexOutput Seek(Int64).)
Public method | SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for (Inherited from IndexOutput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteByte | Writes a single byte. (Overrides IndexOutput WriteByte(Byte).)
Public method | WriteBytes( Byte , Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes( Byte , Int32, Int32) | Writes an array of bytes. (Overrides IndexOutput WriteBytes( Byte , Int32, Int32).)
Public method | WriteChars( Char , Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Back to Top
Properties
 | Name | Description
Public property | FilePointer | Returns the current position in this file, where the next write will occur. (Overrides IndexOutput FilePointer.)
Public property | Length | The number of bytes in the file. (Overrides IndexOutput Length.)
Back to Top
See Also
BufferedIndexOutput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BufferedIndexOutput Constructor

BufferedIndexOutput Constructor Lucene.Net Class Library
Initializes a new instance of the BufferedIndexOutput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected BufferedIndexOutput()
protected BufferedIndexOutput()
Protected Sub New
Protected Sub New
protected:
BufferedIndexOutput()
protected:
BufferedIndexOutput()
See Also
BufferedIndexOutput Class
BufferedIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BufferedIndexOutput Methods

BufferedIndexOutput Methods Lucene.Net Class Library
The BufferedIndexOutput type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Closes this stream to further operations. (Inherited from IndexOutput.)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Dispose | Closes this stream to further operations. (Inherited from IndexOutput.)
Protected method | Dispose(Boolean) | Closes this stream to further operations. (Overrides IndexOutput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | Forces any buffered output to be written. (Overrides IndexOutput Flush .)
Public method | FlushBuffer | Expert: implements buffer write. Writes bytes at the current position in the output.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Seek | Sets current position in this file, where the next write will occur. (Overrides IndexOutput Seek(Int64).)
Public method | SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for (Inherited from IndexOutput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteByte | Writes a single byte. (Overrides IndexOutput WriteByte(Byte).)
Public method | WriteBytes( Byte , Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes( Byte , Int32, Int32) | Writes an array of bytes. (Overrides IndexOutput WriteBytes( Byte , Int32, Int32).)
Public method | WriteChars( Char , Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Back to Top
See Also
BufferedIndexOutput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

BufferedIndexOutput Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes this stream to further operations. (Inherited from IndexOutput.)
Protected method | Dispose(Boolean) | Closes this stream to further operations. (Overrides IndexOutput Dispose(Boolean).)
Back to Top
See Also
BufferedIndexOutput Class
BufferedIndexOutput Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

BufferedIndexOutput Dispose Method (Boolean) Lucene.Net Class Library
Closes this stream to further operations.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
BufferedIndexOutput Class
BufferedIndexOutput Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Flush Method

BufferedIndexOutput Flush Method Lucene.Net Class Library
Forces any buffered output to be written.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Flush()
public override void Flush()
Public Overrides Sub Flush
Public Overrides Sub Flush
public:
virtual void Flush() override
public:
virtual void Flush() override
See Also
BufferedIndexOutput Class
BufferedIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FlushBuffer Method

BufferedIndexOutput FlushBuffer Method Lucene.Net Class Library
Expert: implements buffer write. Writes bytes at the current position in the output.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void FlushBuffer(
    byte[] b,
    int offset,
    int len
)
public abstract void FlushBuffer(
    byte[] b,
    int offset,
    int len
)
Public MustOverride Sub FlushBuffer ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Public MustOverride Sub FlushBuffer ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
public:
virtual void FlushBuffer(
    array<unsigned char>^ b,
    int offset,
    int len
) abstract
public:
virtual void FlushBuffer(
    array<unsigned char>^ b,
    int offset,
    int len
) abstract
Parameters
b
Type:    Online System Byte
the bytes to write

offset
Type:   Online System Int32
the offset in the byte array

len
Type:   Online System Int32
the number of bytes to write

See Also
BufferedIndexOutput Class
BufferedIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method

BufferedIndexOutput Seek Method Lucene.Net Class Library
Sets current position in this file, where the next write will occur.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Seek(
    long pos
)
public override void Seek(
    long pos
)
Public Overrides Sub Seek ( _
    pos As Long _
)
Public Overrides Sub Seek ( _
    pos As Long _
)
public:
virtual void Seek(
    long long pos
) override
public:
virtual void Seek(
    long long pos
) override
Parameters
pos
Type:   Online System Int64
See Also
BufferedIndexOutput Class
BufferedIndexOutput Members
Lucene.Net.Store Namespace
BufferedIndexOutput FilePointer
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteByte Method

BufferedIndexOutput WriteByte Method Lucene.Net Class Library
Writes a single byte.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void WriteByte(
    byte b
)
public override void WriteByte(
    byte b
)
Public Overrides Sub WriteByte ( _
    b As Byte _
)
Public Overrides Sub WriteByte ( _
    b As Byte _
)
public:
virtual void WriteByte(
    unsigned char b
) override
public:
virtual void WriteByte(
    unsigned char b
) override
Parameters
b
Type:   Online System Byte
See Also
BufferedIndexOutput Class
BufferedIndexOutput Members
Lucene.Net.Store Namespace
IndexInput ReadByte
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteBytes Method

BufferedIndexOutput WriteBytes Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | WriteBytes( Byte , Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes( Byte , Int32, Int32) | Writes an array of bytes. (Overrides IndexOutput WriteBytes( Byte , Int32, Int32).)
Back to Top
See Also
BufferedIndexOutput Class
BufferedIndexOutput Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteBytes Method (Byte[], Int32, Int32)

BufferedIndexOutput WriteBytes Method ( Byte , Int32, Int32) Lucene.Net Class Library
Writes an array of bytes.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void WriteBytes(
    byte[] b,
    int offset,
    int length
)
public override void WriteBytes(
    byte[] b,
    int offset,
    int length
)
Public Overrides Sub WriteBytes ( _
    b As Byte(), _
    offset As Integer, _
    length As Integer _
)
Public Overrides Sub WriteBytes ( _
    b As Byte(), _
    offset As Integer, _
    length As Integer _
)
public:
virtual void WriteBytes(
    array<unsigned char>^ b,
    int offset,
    int length
) override
public:
virtual void WriteBytes(
    array<unsigned char>^ b,
    int offset,
    int length
) override
Parameters
b
Type:    Online System Byte
the bytes to write

offset
Type:   Online System Int32
length
Type:   Online System Int32
the number of bytes to write

See Also
BufferedIndexOutput Class
BufferedIndexOutput Members
WriteBytes Overload
Lucene.Net.Store Namespace
IndexInput ReadBytes( Byte , Int32, Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BufferedIndexOutput Properties

BufferedIndexOutput Properties Lucene.Net Class Library
The BufferedIndexOutput type exposes the following members.
Properties
 | Name | Description
Public property | FilePointer | Returns the current position in this file, where the next write will occur. (Overrides IndexOutput FilePointer.)
Public property | Length | The number of bytes in the file. (Overrides IndexOutput Length.)
Back to Top
See Also
BufferedIndexOutput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilePointer Property

BufferedIndexOutput FilePointer Property Lucene.Net Class Library
Returns the current position in this file, where the next write will occur.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long FilePointer { get; }
public override long FilePointer { get; }
Public Overrides ReadOnly Property FilePointer As Long
    Get
Public Overrides ReadOnly Property FilePointer As Long
    Get
public:
virtual property long long FilePointer {
    long long get () override;
}
public:
virtual property long long FilePointer {
    long long get () override;
}
See Also
BufferedIndexOutput Class
BufferedIndexOutput Members
Lucene.Net.Store Namespace
BufferedIndexOutput Seek(Int64)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Length Property

BufferedIndexOutput Length Property Lucene.Net Class Library
The number of bytes in the file.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract long Length { get; }
public abstract long Length { get; }
Public MustOverride ReadOnly Property Length As Long
    Get
Public MustOverride ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () abstract override;
}
public:
virtual property long long Length {
    long long get () abstract override;
}
See Also
BufferedIndexOutput Class
BufferedIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ChecksumIndexInput Class

ChecksumIndexInput Class Lucene.Net Class Library
Writes bytes through to a primary IndexOutput, computing checksum as it goes. Note that you cannot use seek().
Inheritance Hierarchy
Online System Object
Lucene.Net.Store IndexInput
Lucene.Net.Store ChecksumIndexInput

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ChecksumIndexInput : IndexInput
public class ChecksumIndexInput : IndexInput
Public Class ChecksumIndexInput _
    Inherits IndexInput
Public Class ChecksumIndexInput _
    Inherits IndexInput
public ref class ChecksumIndexInput : public IndexInput
public ref class ChecksumIndexInput : public IndexInput
See Also
ChecksumIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ChecksumIndexInput Members

ChecksumIndexInput Members Lucene.Net Class Library

The ChecksumIndexInput type exposes the following members.
Constructors
 | Name | Description
Public method | ChecksumIndexInput | Initializes a new instance of the ChecksumIndexInput class
Back to Top
Methods
 | Name | Description
Public method | Clone | Returns a clone of this stream. Clones of a stream access the same data, and are positioned at the same point as the stream they were cloned from. Expert: Subclasses must ensure that clones may be positioned at different points in the input from each other and from the stream they were cloned from. (Inherited from IndexInput.)
Public method | Close | Obsolete. (Inherited from IndexInput.)
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ChecksumIndexInput and optionally releases the managed resources (Overrides IndexInput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Length | (Overrides IndexInput Length .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadByte | (Overrides IndexInput ReadByte .)
Public method | ReadBytes( Byte , Int32, Int32) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32).)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only BufferedIndexInput respects this parameter. (Inherited from IndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput Seek(Int64).)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to ReadChars( Char , Int32, Int32) but does not do any conversion operations on the bytes it is reading in. It still has to invoke ReadByte just as ReadChars( Char , Int32, Int32) does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Checksum |
Public property | FilePointer | (Overrides IndexInput FilePointer.)
Back to Top
See Also
ChecksumIndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ChecksumIndexInput Constructor

ChecksumIndexInput Constructor Lucene.Net Class Library
Initializes a new instance of the ChecksumIndexInput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ChecksumIndexInput(
    IndexInput main
)
public ChecksumIndexInput(
    IndexInput main
)
Public Sub New ( _
    main As IndexInput _
)
Public Sub New ( _
    main As IndexInput _
)
public:
ChecksumIndexInput(
    IndexInput^ main
)
public:
ChecksumIndexInput(
    IndexInput^ main
)
Parameters
main
Type: Lucene.Net.Store IndexInput
See Also
ChecksumIndexInput Class
ChecksumIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ChecksumIndexInput Methods

ChecksumIndexInput Methods Lucene.Net Class Library
The ChecksumIndexInput type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Returns a clone of this stream. Clones of a stream access the same data, and are positioned at the same point as the stream they were cloned from. Expert: Subclasses must ensure that clones may be positioned at different points in the input from each other and from the stream they were cloned from. (Inherited from IndexInput.)
Public method | Close | Obsolete. (Inherited from IndexInput.)
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | (Overrides IndexInput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Length | (Overrides IndexInput Length .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadByte | (Overrides IndexInput ReadByte .)
Public method | ReadBytes( Byte , Int32, Int32) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32).)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only BufferedIndexInput respects this parameter. (Inherited from IndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput Seek(Int64).)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to ReadChars( Char , Int32, Int32) but does not do any conversion operations on the bytes it is reading in. It still has to invoke ReadByte just as ReadChars( Char , Int32, Int32) does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ChecksumIndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

ChecksumIndexInput Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ChecksumIndexInput and optionally releases the managed resources (Overrides IndexInput Dispose(Boolean).)
Back to Top
See Also
ChecksumIndexInput Class
ChecksumIndexInput Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

ChecksumIndexInput Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the ChecksumIndexInput and optionally releases the managed resources

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
ChecksumIndexInput Class
ChecksumIndexInput Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Length Method

ChecksumIndexInput Length Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Length()
public override long Length()
Public Overrides Function Length As Long
Public Overrides Function Length As Long
public:
virtual long long Length() override
public:
virtual long long Length() override
See Also
ChecksumIndexInput Class
ChecksumIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadByte Method

ChecksumIndexInput ReadByte Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override byte ReadByte()
public override byte ReadByte()
Public Overrides Function ReadByte As Byte
Public Overrides Function ReadByte As Byte
public:
virtual unsigned char ReadByte() override
public:
virtual unsigned char ReadByte() override
See Also
ChecksumIndexInput Class
ChecksumIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadBytes Method

ChecksumIndexInput ReadBytes Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ReadBytes( Byte , Int32, Int32) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32).)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only BufferedIndexInput respects this parameter. (Inherited from IndexInput.)
Back to Top
See Also
ChecksumIndexInput Class
ChecksumIndexInput Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadBytes Method (Byte[], Int32, Int32)

ChecksumIndexInput ReadBytes Method ( Byte , Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ReadBytes(
    byte[] b,
    int offset,
    int len
)
public override void ReadBytes(
    byte[] b,
    int offset,
    int len
)
Public Overrides Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Public Overrides Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) override
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) override
Parameters
b
Type:    Online System Byte
offset
Type:   Online System Int32
len
Type:   Online System Int32
See Also
ChecksumIndexInput Class
ChecksumIndexInput Members
ReadBytes Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method

ChecksumIndexInput Seek Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Seek(
    long pos
)
public override void Seek(
    long pos
)
Public Overrides Sub Seek ( _
    pos As Long _
)
Public Overrides Sub Seek ( _
    pos As Long _
)
public:
virtual void Seek(
    long long pos
) override
public:
virtual void Seek(
    long long pos
) override
Parameters
pos
Type:   Online System Int64
See Also
ChecksumIndexInput Class
ChecksumIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ChecksumIndexInput Properties

ChecksumIndexInput Properties Lucene.Net Class Library
The ChecksumIndexInput type exposes the following members.
Properties
 | Name | Description
Public property | Checksum |
Public property | FilePointer | (Overrides IndexInput FilePointer.)
Back to Top
See Also
ChecksumIndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Checksum Property

ChecksumIndexInput Checksum Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long Checksum { get; }
public virtual long Checksum { get; }
Public Overridable ReadOnly Property Checksum As Long
    Get
Public Overridable ReadOnly Property Checksum As Long
    Get
public:
virtual property long long Checksum {
    long long get ();
}
public:
virtual property long long Checksum {
    long long get ();
}
See Also
ChecksumIndexInput Class
ChecksumIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilePointer Property

ChecksumIndexInput FilePointer Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long FilePointer { get; }
public override long FilePointer { get; }
Public Overrides ReadOnly Property FilePointer As Long
    Get
Public Overrides ReadOnly Property FilePointer As Long
    Get
public:
virtual property long long FilePointer {
    long long get () override;
}
public:
virtual property long long FilePointer {
    long long get () override;
}
See Also
ChecksumIndexInput Class
ChecksumIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ChecksumIndexOutput Class

ChecksumIndexOutput Class Lucene.Net Class Library
Writes bytes through to a primary IndexOutput, computing checksum. Note that you cannot use seek().
Inheritance Hierarchy
Online System Object
Lucene.Net.Store IndexOutput
Lucene.Net.Store ChecksumIndexOutput

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ChecksumIndexOutput : IndexOutput
public class ChecksumIndexOutput : IndexOutput
Public Class ChecksumIndexOutput _
    Inherits IndexOutput
Public Class ChecksumIndexOutput _
    Inherits IndexOutput
public ref class ChecksumIndexOutput : public IndexOutput
public ref class ChecksumIndexOutput : public IndexOutput
See Also
ChecksumIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ChecksumIndexOutput Members

ChecksumIndexOutput Members Lucene.Net Class Library

The ChecksumIndexOutput type exposes the following members.
Constructors
 | Name | Description
Public method | ChecksumIndexOutput | Initializes a new instance of the ChecksumIndexOutput class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Closes this stream to further operations. (Inherited from IndexOutput.)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Dispose | Closes this stream to further operations. (Inherited from IndexOutput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ChecksumIndexOutput and optionally releases the managed resources (Overrides IndexOutput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FinishCommit | See PrepareCommit
Public method | Flush | (Overrides IndexOutput Flush .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PrepareCommit | Starts but does not complete the commit of this file (= writing of the final checksum at the end). After this is called must call FinishCommit and the Dispose(Boolean) to complete the commit.
Public method | Seek | (Overrides IndexOutput Seek(Int64).)
Public method | SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for (Inherited from IndexOutput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteByte | (Overrides IndexOutput WriteByte(Byte).)
Public method | WriteBytes( Byte , Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes( Byte , Int32, Int32) | (Overrides IndexOutput WriteBytes( Byte , Int32, Int32).)
Public method | WriteChars( Char , Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Back to Top
Properties
 | Name | Description
Public property | Checksum |
Public property | FilePointer | (Overrides IndexOutput FilePointer.)
Public property | Length | (Overrides IndexOutput Length.)
Back to Top
See Also
ChecksumIndexOutput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ChecksumIndexOutput Constructor

ChecksumIndexOutput Constructor Lucene.Net Class Library
Initializes a new instance of the ChecksumIndexOutput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ChecksumIndexOutput(
    IndexOutput main
)
public ChecksumIndexOutput(
    IndexOutput main
)
Public Sub New ( _
    main As IndexOutput _
)
Public Sub New ( _
    main As IndexOutput _
)
public:
ChecksumIndexOutput(
    IndexOutput^ main
)
public:
ChecksumIndexOutput(
    IndexOutput^ main
)
Parameters
main
Type: Lucene.Net.Store IndexOutput
See Also
ChecksumIndexOutput Class
ChecksumIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ChecksumIndexOutput Methods

ChecksumIndexOutput Methods Lucene.Net Class Library
The ChecksumIndexOutput type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Closes this stream to further operations. (Inherited from IndexOutput.)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Dispose | Closes this stream to further operations. (Inherited from IndexOutput.)
Protected method | Dispose(Boolean) | (Overrides IndexOutput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FinishCommit | See PrepareCommit
Public method | Flush | (Overrides IndexOutput Flush .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PrepareCommit | Starts but does not complete the commit of this file (= writing of the final checksum at the end). After this is called must call FinishCommit and the Dispose(Boolean) to complete the commit.
Public method | Seek | (Overrides IndexOutput Seek(Int64).)
Public method | SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for (Inherited from IndexOutput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteByte | (Overrides IndexOutput WriteByte(Byte).)
Public method | WriteBytes( Byte , Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes( Byte , Int32, Int32) | (Overrides IndexOutput WriteBytes( Byte , Int32, Int32).)
Public method | WriteChars( Char , Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Back to Top
See Also
ChecksumIndexOutput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

ChecksumIndexOutput Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes this stream to further operations. (Inherited from IndexOutput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ChecksumIndexOutput and optionally releases the managed resources (Overrides IndexOutput Dispose(Boolean).)
Back to Top
See Also
ChecksumIndexOutput Class
ChecksumIndexOutput Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

ChecksumIndexOutput Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the ChecksumIndexOutput and optionally releases the managed resources

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
ChecksumIndexOutput Class
ChecksumIndexOutput Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FinishCommit Method

ChecksumIndexOutput FinishCommit Method Lucene.Net Class Library
See PrepareCommit

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void FinishCommit()
public virtual void FinishCommit()
Public Overridable Sub FinishCommit
Public Overridable Sub FinishCommit
public:
virtual void FinishCommit()
public:
virtual void FinishCommit()
See Also
ChecksumIndexOutput Class
ChecksumIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Flush Method

ChecksumIndexOutput Flush Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Flush()
public override void Flush()
Public Overrides Sub Flush
Public Overrides Sub Flush
public:
virtual void Flush() override
public:
virtual void Flush() override
See Also
ChecksumIndexOutput Class
ChecksumIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrepareCommit Method

ChecksumIndexOutput PrepareCommit Method Lucene.Net Class Library
Starts but does not complete the commit of this file (= writing of the final checksum at the end). After this is called must call FinishCommit and the Dispose(Boolean) to complete the commit.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void PrepareCommit()
public virtual void PrepareCommit()
Public Overridable Sub PrepareCommit
Public Overridable Sub PrepareCommit
public:
virtual void PrepareCommit()
public:
virtual void PrepareCommit()
See Also
ChecksumIndexOutput Class
ChecksumIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method

ChecksumIndexOutput Seek Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Seek(
    long pos
)
public override void Seek(
    long pos
)
Public Overrides Sub Seek ( _
    pos As Long _
)
Public Overrides Sub Seek ( _
    pos As Long _
)
public:
virtual void Seek(
    long long pos
) override
public:
virtual void Seek(
    long long pos
) override
Parameters
pos
Type:   Online System Int64
See Also
ChecksumIndexOutput Class
ChecksumIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteByte Method

ChecksumIndexOutput WriteByte Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void WriteByte(
    byte b
)
public override void WriteByte(
    byte b
)
Public Overrides Sub WriteByte ( _
    b As Byte _
)
Public Overrides Sub WriteByte ( _
    b As Byte _
)
public:
virtual void WriteByte(
    unsigned char b
) override
public:
virtual void WriteByte(
    unsigned char b
) override
Parameters
b
Type:   Online System Byte
See Also
ChecksumIndexOutput Class
ChecksumIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteBytes Method

ChecksumIndexOutput WriteBytes Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | WriteBytes( Byte , Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes( Byte , Int32, Int32) | (Overrides IndexOutput WriteBytes( Byte , Int32, Int32).)
Back to Top
See Also
ChecksumIndexOutput Class
ChecksumIndexOutput Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteBytes Method (Byte[], Int32, Int32)

ChecksumIndexOutput WriteBytes Method ( Byte , Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void WriteBytes(
    byte[] b,
    int offset,
    int length
)
public override void WriteBytes(
    byte[] b,
    int offset,
    int length
)
Public Overrides Sub WriteBytes ( _
    b As Byte(), _
    offset As Integer, _
    length As Integer _
)
Public Overrides Sub WriteBytes ( _
    b As Byte(), _
    offset As Integer, _
    length As Integer _
)
public:
virtual void WriteBytes(
    array<unsigned char>^ b,
    int offset,
    int length
) override
public:
virtual void WriteBytes(
    array<unsigned char>^ b,
    int offset,
    int length
) override
Parameters
b
Type:    Online System Byte
offset
Type:   Online System Int32
length
Type:   Online System Int32
See Also
ChecksumIndexOutput Class
ChecksumIndexOutput Members
WriteBytes Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ChecksumIndexOutput Properties

ChecksumIndexOutput Properties Lucene.Net Class Library
The ChecksumIndexOutput type exposes the following members.
Properties
 | Name | Description
Public property | Checksum |
Public property | FilePointer | (Overrides IndexOutput FilePointer.)
Public property | Length | (Overrides IndexOutput Length.)
Back to Top
See Also
ChecksumIndexOutput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Checksum Property

ChecksumIndexOutput Checksum Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long Checksum { get; }
public virtual long Checksum { get; }
Public Overridable ReadOnly Property Checksum As Long
    Get
Public Overridable ReadOnly Property Checksum As Long
    Get
public:
virtual property long long Checksum {
    long long get ();
}
public:
virtual property long long Checksum {
    long long get ();
}
See Also
ChecksumIndexOutput Class
ChecksumIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilePointer Property

ChecksumIndexOutput FilePointer Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long FilePointer { get; }
public override long FilePointer { get; }
Public Overrides ReadOnly Property FilePointer As Long
    Get
Public Overrides ReadOnly Property FilePointer As Long
    Get
public:
virtual property long long FilePointer {
    long long get () override;
}
public:
virtual property long long FilePointer {
    long long get () override;
}
See Also
ChecksumIndexOutput Class
ChecksumIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Length Property

ChecksumIndexOutput Length Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Length { get; }
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
Public Overrides ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override;
}
public:
virtual property long long Length {
    long long get () override;
}
See Also
ChecksumIndexOutput Class
ChecksumIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Directory Class

Directory Class Lucene.Net Class Library
A Directory is a flat list of files. Files may be written once, when they are created. Once a file is created it may only be opened for read, or deleted. Random access is permitted both when reading and writing.

Java's i/o APIs not used directly, but rather all i/o is through this API. This permits things such as: implementation of RAM-based indices; implementation indices stored in a database, via JDBC; implementation of an index as a single file; Directory locking is implemented by an instance of LockFactory , and can be changed for each Directory instance using SetLockFactory(LockFactory).
Inheritance Hierarchy
Online System Object
Lucene.Net.Store Directory
Lucene.Net.Index CompoundFileReader
Lucene.Net.Store FileSwitchDirectory
Lucene.Net.Store FSDirectory
Lucene.Net.Store RAMDirectory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class Directory : IDisposable
[SerializableAttribute]
public abstract class Directory : IDisposable
<SerializableAttribute> _
Public MustInherit Class Directory _
    Implements IDisposable
<SerializableAttribute> _
Public MustInherit Class Directory _
    Implements IDisposable
[SerializableAttribute]
public ref class Directory abstract : IDisposable
[SerializableAttribute]
public ref class Directory abstract : IDisposable
See Also
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Directory Members

Directory Members Lucene.Net Class Library

The Directory type exposes the following members.
Constructors
 | Name | Description
Protected method | Directory | Initializes a new instance of the Directory class
Back to Top
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Public method | Close | Obsolete.
 | Copy | Copy contents of a directory src to a directory dest. If a file in src already exists in dest then the one in dest will be blindly overwritten. NOTE: the source directory cannot change while this method is running. Otherwise the results are undefined and you could easily hit a FileNotFoundException. NOTE: this method only copies files that look like index files (ie, have extensions matching the known extensions of index files).
Public method | CreateOutput | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
Public method | DeleteFile | Removes an existing file in the directory.
Public method | Dispose | Closes the store.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Directory and optionally releases the managed resources
Public method | EnsureOpen |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FileExists | Returns true iff a file with the given name exists.
Public method | FileLength | Returns the length of a file in the directory.
Public method | FileModified | Returns the time the named file was last modified.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLockId | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | ListAll | Returns an array of strings, one for each file in the directory.
Public method | MakeLock | Construct a Lock.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenInput(String) | Returns a stream reading an existing file.
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are FSDirectory and CompoundFileReader .
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).
Public method | Sync | Ensure that any writes to this file are moved to stable storage. Lucene uses this to properly commit changes to the index, to prevent a machine/OS crash from corrupting the index.
Public method | ToString | (Overrides Online Object ToString .)
Public method | TouchFile | Set the modified time of an existing file to now.
Back to Top
Fields
 | Name | Description
Protected field | interalLockFactory | Holds the LockFactory instance (implements locking for this Directory instance).
Protected field | isOpen |
Back to Top
Properties
 | Name | Description
Public property | isOpen_ForNUnit |
Public property | LockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.
Back to Top
See Also
Directory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Directory Constructor

Directory Constructor Lucene.Net Class Library
Initializes a new instance of the Directory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Directory()
protected Directory()
Protected Sub New
Protected Sub New
protected:
Directory()
protected:
Directory()
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Directory Fields

Directory Fields Lucene.Net Class Library
The Directory type exposes the following members.
Fields
 | Name | Description
Protected field | interalLockFactory | Holds the LockFactory instance (implements locking for this Directory instance).
Protected field | isOpen |
Back to Top
See Also
Directory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


interalLockFactory Field

Directory interalLockFactory Field Lucene.Net Class Library
Holds the LockFactory instance (implements locking for this Directory instance).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
protected LockFactory interalLockFactory
[NonSerializedAttribute]
protected LockFactory interalLockFactory
<NonSerializedAttribute> _
Protected interalLockFactory As LockFactory
<NonSerializedAttribute> _
Protected interalLockFactory As LockFactory
protected:
[NonSerializedAttribute]
LockFactory^ interalLockFactory
protected:
[NonSerializedAttribute]
LockFactory^ interalLockFactory
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


isOpen Field

Directory isOpen Field Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool isOpen
protected bool isOpen
Protected isOpen As Boolean
Protected isOpen As Boolean
protected:
bool isOpen
protected:
bool isOpen
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Directory Methods

Directory Methods Lucene.Net Class Library
The Directory type exposes the following members.
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Public method | Close | Obsolete.
 | Copy | Copy contents of a directory src to a directory dest. If a file in src already exists in dest then the one in dest will be blindly overwritten. NOTE: the source directory cannot change while this method is running. Otherwise the results are undefined and you could easily hit a FileNotFoundException. NOTE: this method only copies files that look like index files (ie, have extensions matching the known extensions of index files).
Public method | CreateOutput | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
Public method | DeleteFile | Removes an existing file in the directory.
Public method | Dispose | Closes the store.
Protected method | Dispose(Boolean) |
Public method | EnsureOpen |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FileExists | Returns true iff a file with the given name exists.
Public method | FileLength | Returns the length of a file in the directory.
Public method | FileModified | Returns the time the named file was last modified.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLockId | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | ListAll | Returns an array of strings, one for each file in the directory.
Public method | MakeLock | Construct a Lock.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenInput(String) | Returns a stream reading an existing file.
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are FSDirectory and CompoundFileReader .
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).
Public method | Sync | Ensure that any writes to this file are moved to stable storage. Lucene uses this to properly commit changes to the index, to prevent a machine/OS crash from corrupting the index.
Public method | ToString | (Overrides Online Object ToString .)
Public method | TouchFile | Set the modified time of an existing file to now.
Back to Top
See Also
Directory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ClearLock Method

Directory ClearLock Method Lucene.Net Class Library
Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ClearLock(
    string name
)
public virtual void ClearLock(
    string name
)
Public Overridable Sub ClearLock ( _
    name As String _
)
Public Overridable Sub ClearLock ( _
    name As String _
)
public:
virtual void ClearLock(
    String^ name
)
public:
virtual void ClearLock(
    String^ name
)
Parameters
name
Type:   Online System String
name of the lock to be cleared.

See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

Directory Close Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Copy Method

Directory Copy Method Lucene.Net Class Library
Copy contents of a directory src to a directory dest. If a file in src already exists in dest then the one in dest will be blindly overwritten.

NOTE: the source directory cannot change while this method is running. Otherwise the results are undefined and you could easily hit a FileNotFoundException.

NOTE: this method only copies files that look like index files (ie, have extensions matching the known extensions of index files).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Copy(
    Directory src,
    Directory dest,
    bool closeDirSrc
)
public static void Copy(
    Directory src,
    Directory dest,
    bool closeDirSrc
)
Public Shared Sub Copy ( _
    src As Directory, _
    dest As Directory, _
    closeDirSrc As Boolean _
)
Public Shared Sub Copy ( _
    src As Directory, _
    dest As Directory, _
    closeDirSrc As Boolean _
)
public:
static void Copy(
    Directory^ src,
    Directory^ dest,
    bool closeDirSrc
)
public:
static void Copy(
    Directory^ src,
    Directory^ dest,
    bool closeDirSrc
)
Parameters
src
Type: Lucene.Net.Store Directory
source directory

dest
Type: Lucene.Net.Store Directory
destination directory

closeDirSrc
Type:   Online System Boolean
if true, call Close  method on source directory

See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateOutput Method

Directory CreateOutput Method Lucene.Net Class Library
Creates a new, empty file in the directory with the given name. Returns a stream writing this file.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract IndexOutput CreateOutput(
    string name
)
public abstract IndexOutput CreateOutput(
    string name
)
Public MustOverride Function CreateOutput ( _
    name As String _
) As IndexOutput
Public MustOverride Function CreateOutput ( _
    name As String _
) As IndexOutput
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) abstract
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) abstract
Parameters
name
Type:   Online System String
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DeleteFile Method

Directory DeleteFile Method Lucene.Net Class Library
Removes an existing file in the directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void DeleteFile(
    string name
)
public abstract void DeleteFile(
    string name
)
Public MustOverride Sub DeleteFile ( _
    name As String _
)
Public MustOverride Sub DeleteFile ( _
    name As String _
)
public:
virtual void DeleteFile(
    String^ name
) abstract
public:
virtual void DeleteFile(
    String^ name
) abstract
Parameters
name
Type:   Online System String
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

Directory Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes the store.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Directory and optionally releases the managed resources
Back to Top
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

Directory Dispose Method Lucene.Net Class Library
Closes the store.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
Directory Class
Directory Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

Directory Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the Directory and optionally releases the managed resources

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void Dispose(
    bool disposing
)
protected abstract void Dispose(
    bool disposing
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) abstract
protected:
virtual void Dispose(
    bool disposing
) abstract
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
Directory Class
Directory Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EnsureOpen Method

Directory EnsureOpen Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void EnsureOpen()
public void EnsureOpen()
Public Sub EnsureOpen
Public Sub EnsureOpen
public:
void EnsureOpen()
public:
void EnsureOpen()
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileExists Method

Directory FileExists Method Lucene.Net Class Library
Returns true iff a file with the given name exists.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool FileExists(
    string name
)
public abstract bool FileExists(
    string name
)
Public MustOverride Function FileExists ( _
    name As String _
) As Boolean
Public MustOverride Function FileExists ( _
    name As String _
) As Boolean
public:
virtual bool FileExists(
    String^ name
) abstract
public:
virtual bool FileExists(
    String^ name
) abstract
Parameters
name
Type:   Online System String
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileLength Method

Directory FileLength Method Lucene.Net Class Library
Returns the length of a file in the directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract long FileLength(
    string name
)
public abstract long FileLength(
    string name
)
Public MustOverride Function FileLength ( _
    name As String _
) As Long
Public MustOverride Function FileLength ( _
    name As String _
) As Long
public:
virtual long long FileLength(
    String^ name
) abstract
public:
virtual long long FileLength(
    String^ name
) abstract
Parameters
name
Type:   Online System String
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileModified Method

Directory FileModified Method Lucene.Net Class Library
Returns the time the named file was last modified.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract long FileModified(
    string name
)
public abstract long FileModified(
    string name
)
Public MustOverride Function FileModified ( _
    name As String _
) As Long
Public MustOverride Function FileModified ( _
    name As String _
) As Long
public:
virtual long long FileModified(
    String^ name
) abstract
public:
virtual long long FileModified(
    String^ name
) abstract
Parameters
name
Type:   Online System String
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLockId Method

Directory GetLockId Method Lucene.Net Class Library
Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string GetLockId()
public virtual string GetLockId()
Public Overridable Function GetLockId As String
Public Overridable Function GetLockId As String
public:
virtual String^ GetLockId()
public:
virtual String^ GetLockId()
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ListAll Method

Directory ListAll Method Lucene.Net Class Library
Returns an array of strings, one for each file in the directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string[] ListAll()
public abstract string[] ListAll()
Public MustOverride Function ListAll As String()
Public MustOverride Function ListAll As String()
public:
virtual array<String^>^ ListAll() abstract
public:
virtual array<String^>^ ListAll() abstract
Exceptions
Exception | Condition
Online System.IO IOException |
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MakeLock Method

Directory MakeLock Method Lucene.Net Class Library
Construct a Lock.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Lock MakeLock(
    string name
)
public virtual Lock MakeLock(
    string name
)
Public Overridable Function MakeLock ( _
    name As String _
) As Lock
Public Overridable Function MakeLock ( _
    name As String _
) As Lock
public:
virtual Lock^ MakeLock(
    String^ name
)
public:
virtual Lock^ MakeLock(
    String^ name
)
Parameters
name
Type:   Online System String
the name of the lock file

See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenInput Method

Directory OpenInput Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | OpenInput(String) | Returns a stream reading an existing file.
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are FSDirectory and CompoundFileReader .
Back to Top
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenInput Method (String)

Directory OpenInput Method (String) Lucene.Net Class Library
Returns a stream reading an existing file.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract IndexInput OpenInput(
    string name
)
public abstract IndexInput OpenInput(
    string name
)
Public MustOverride Function OpenInput ( _
    name As String _
) As IndexInput
Public MustOverride Function OpenInput ( _
    name As String _
) As IndexInput
public:
virtual IndexInput^ OpenInput(
    String^ name
) abstract
public:
virtual IndexInput^ OpenInput(
    String^ name
) abstract
Parameters
name
Type:   Online System String
See Also
Directory Class
Directory Members
OpenInput Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenInput Method (String, Int32)

Directory OpenInput Method (String, Int32) Lucene.Net Class Library
Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are FSDirectory and CompoundFileReader .

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IndexInput OpenInput(
    string name,
    int bufferSize
)
public virtual IndexInput OpenInput(
    string name,
    int bufferSize
)
Public Overridable Function OpenInput ( _
    name As String, _
    bufferSize As Integer _
) As IndexInput
Public Overridable Function OpenInput ( _
    name As String, _
    bufferSize As Integer _
) As IndexInput
public:
virtual IndexInput^ OpenInput(
    String^ name,
    int bufferSize
)
public:
virtual IndexInput^ OpenInput(
    String^ name,
    int bufferSize
)
Parameters
name
Type:   Online System String
bufferSize
Type:   Online System Int32
See Also
Directory Class
Directory Members
OpenInput Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetLockFactory Method

Directory SetLockFactory Method Lucene.Net Class Library
Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetLockFactory(
    LockFactory lockFactory
)
public virtual void SetLockFactory(
    LockFactory lockFactory
)
Public Overridable Sub SetLockFactory ( _
    lockFactory As LockFactory _
)
Public Overridable Sub SetLockFactory ( _
    lockFactory As LockFactory _
)
public:
virtual void SetLockFactory(
    LockFactory^ lockFactory
)
public:
virtual void SetLockFactory(
    LockFactory^ lockFactory
)
Parameters
lockFactory
Type: Lucene.Net.Store LockFactory
instance of LockFactory.

See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Sync Method

Directory Sync Method Lucene.Net Class Library
Ensure that any writes to this file are moved to stable storage. Lucene uses this to properly commit changes to the index, to prevent a machine/OS crash from corrupting the index.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Sync(
    string name
)
public virtual void Sync(
    string name
)
Public Overridable Sub Sync ( _
    name As String _
)
Public Overridable Sub Sync ( _
    name As String _
)
public:
virtual void Sync(
    String^ name
)
public:
virtual void Sync(
    String^ name
)
Parameters
name
Type:   Online System String
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

Directory ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TouchFile Method

Directory TouchFile Method Lucene.Net Class Library
Set the modified time of an existing file to now.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void TouchFile(
    string name
)
public abstract void TouchFile(
    string name
)
Public MustOverride Sub TouchFile ( _
    name As String _
)
Public MustOverride Sub TouchFile ( _
    name As String _
)
public:
virtual void TouchFile(
    String^ name
) abstract
public:
virtual void TouchFile(
    String^ name
) abstract
Parameters
name
Type:   Online System String
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Directory Properties

Directory Properties Lucene.Net Class Library
The Directory type exposes the following members.
Properties
 | Name | Description
Public property | isOpen_ForNUnit |
Public property | LockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.
Back to Top
See Also
Directory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


isOpen_ForNUnit Property

Directory isOpen_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool isOpen_ForNUnit { get; }
public bool isOpen_ForNUnit { get; }
Public ReadOnly Property isOpen_ForNUnit As Boolean
    Get
Public ReadOnly Property isOpen_ForNUnit As Boolean
    Get
public:
property bool isOpen_ForNUnit {
    bool get ();
}
public:
property bool isOpen_ForNUnit {
    bool get ();
}
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockFactory Property

Directory LockFactory Property Lucene.Net Class Library
Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual LockFactory LockFactory { get; }
public virtual LockFactory LockFactory { get; }
Public Overridable ReadOnly Property LockFactory As LockFactory
    Get
Public Overridable ReadOnly Property LockFactory As LockFactory
    Get
public:
virtual property LockFactory^ LockFactory {
    LockFactory^ get ();
}
public:
virtual property LockFactory^ LockFactory {
    LockFactory^ get ();
}
See Also
Directory Class
Directory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileSwitchDirectory Class

FileSwitchDirectory Class Lucene.Net Class Library
Expert: A Directory instance that switches files between two other Directory instances.

Files with the specified extensions are placed in the primary directory; others are placed in the secondary directory. The provided Set must not change once passed to this class, and must allow multiple threads to call contains at once.

NOTE: this API is new and experimental and is subject to suddenly change in the next release.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store Directory
Lucene.Net.Store FileSwitchDirectory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FileSwitchDirectory : Directory
public class FileSwitchDirectory : Directory
Public Class FileSwitchDirectory _
    Inherits Directory
Public Class FileSwitchDirectory _
    Inherits Directory
public ref class FileSwitchDirectory : public Directory
public ref class FileSwitchDirectory : public Directory
See Also
FileSwitchDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileSwitchDirectory Members

FileSwitchDirectory Members Lucene.Net Class Library

The FileSwitchDirectory type exposes the following members.
Constructors
 | Name | Description
Public method | FileSwitchDirectory | Initializes a new instance of the FileSwitchDirectory class
Back to Top
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Obsolete. (Inherited from Directory.)
Public method | CreateOutput | (Overrides Directory CreateOutput(String).)
Public method | DeleteFile | (Overrides Directory DeleteFile(String).)
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FileSwitchDirectory and optionally releases the managed resources (Overrides Directory Dispose(Boolean).)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FileExists | (Overrides Directory FileExists(String).)
Public method | FileLength | (Overrides Directory FileLength(String).)
Public method | FileModified | (Overrides Directory FileModified(String).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetExtension | Utility method to return a file's extension.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLockId | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index. (Inherited from Directory.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | ListAll | (Overrides Directory ListAll .)
Public method | MakeLock | Construct a Lock. (Inherited from Directory.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenInput(String) | (Overrides Directory OpenInput(String).)
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are FSDirectory and CompoundFileReader . (Inherited from Directory.)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | Sync | (Overrides Directory Sync(String).)
Public method | ToString | (Inherited from Directory.)
Public method | TouchFile | (Overrides Directory TouchFile(String).)
Back to Top
Fields
 | Name | Description
Protected field | interalLockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)
Protected field | isOpen | (Inherited from Directory.)
Back to Top
Properties
 | Name | Description
Public property | isOpen_ForNUnit | (Inherited from Directory.)
Public property | LockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public property | PrimaryDir | Return the primary directory
Public property | SecondaryDir | Return the secondary directory
Back to Top
See Also
FileSwitchDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileSwitchDirectory Constructor

FileSwitchDirectory Constructor Lucene.Net Class Library
Initializes a new instance of the FileSwitchDirectory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSwitchDirectory(
    HashSet<string> primaryExtensions,
    Directory primaryDir,
    Directory secondaryDir,
    bool doClose
)
public FileSwitchDirectory(
    HashSet<string> primaryExtensions,
    Directory primaryDir,
    Directory secondaryDir,
    bool doClose
)
Public Sub New ( _
    primaryExtensions As HashSet(Of String), _
    primaryDir As Directory, _
    secondaryDir As Directory, _
    doClose As Boolean _
)
Public Sub New ( _
    primaryExtensions As HashSet(Of String), _
    primaryDir As Directory, _
    secondaryDir As Directory, _
    doClose As Boolean _
)
public:
FileSwitchDirectory(
    HashSet<String^>^ primaryExtensions,
    Directory^ primaryDir,
    Directory^ secondaryDir,
    bool doClose
)
public:
FileSwitchDirectory(
    HashSet<String^>^ primaryExtensions,
    Directory^ primaryDir,
    Directory^ secondaryDir,
    bool doClose
)
Parameters
primaryExtensions
Type:   Online System.Collections.Generic HashSet    Online String
primaryDir
Type: Lucene.Net.Store Directory
secondaryDir
Type: Lucene.Net.Store Directory
doClose
Type:   Online System Boolean
See Also
FileSwitchDirectory Class
FileSwitchDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileSwitchDirectory Fields

FileSwitchDirectory Fields Lucene.Net Class Library
The FileSwitchDirectory type exposes the following members.
Fields
 | Name | Description
Protected field | interalLockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)
Protected field | isOpen | (Inherited from Directory.)
Back to Top
See Also
FileSwitchDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileSwitchDirectory Methods

FileSwitchDirectory Methods Lucene.Net Class Library
The FileSwitchDirectory type exposes the following members.
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Obsolete. (Inherited from Directory.)
Public method | CreateOutput | (Overrides Directory CreateOutput(String).)
Public method | DeleteFile | (Overrides Directory DeleteFile(String).)
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | (Overrides Directory Dispose(Boolean).)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FileExists | (Overrides Directory FileExists(String).)
Public method | FileLength | (Overrides Directory FileLength(String).)
Public method | FileModified | (Overrides Directory FileModified(String).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetExtension | Utility method to return a file's extension.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLockId | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index. (Inherited from Directory.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | ListAll | (Overrides Directory ListAll .)
Public method | MakeLock | Construct a Lock. (Inherited from Directory.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenInput(String) | (Overrides Directory OpenInput(String).)
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are FSDirectory and CompoundFileReader . (Inherited from Directory.)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | Sync | (Overrides Directory Sync(String).)
Public method | ToString | (Inherited from Directory.)
Public method | TouchFile | (Overrides Directory TouchFile(String).)
Back to Top
See Also
FileSwitchDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateOutput Method

FileSwitchDirectory CreateOutput Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexOutput CreateOutput(
    string name
)
public override IndexOutput CreateOutput(
    string name
)
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
FileSwitchDirectory Class
FileSwitchDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DeleteFile Method

FileSwitchDirectory DeleteFile Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void DeleteFile(
    string name
)
public override void DeleteFile(
    string name
)
Public Overrides Sub DeleteFile ( _
    name As String _
)
Public Overrides Sub DeleteFile ( _
    name As String _
)
public:
virtual void DeleteFile(
    String^ name
) override
public:
virtual void DeleteFile(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
FileSwitchDirectory Class
FileSwitchDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

FileSwitchDirectory Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FileSwitchDirectory and optionally releases the managed resources (Overrides Directory Dispose(Boolean).)
Back to Top
See Also
FileSwitchDirectory Class
FileSwitchDirectory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

FileSwitchDirectory Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the FileSwitchDirectory and optionally releases the managed resources

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
FileSwitchDirectory Class
FileSwitchDirectory Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileExists Method

FileSwitchDirectory FileExists Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool FileExists(
    string name
)
public override bool FileExists(
    string name
)
Public Overrides Function FileExists ( _
    name As String _
) As Boolean
Public Overrides Function FileExists ( _
    name As String _
) As Boolean
public:
virtual bool FileExists(
    String^ name
) override
public:
virtual bool FileExists(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
FileSwitchDirectory Class
FileSwitchDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileLength Method

FileSwitchDirectory FileLength Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long FileLength(
    string name
)
public override long FileLength(
    string name
)
Public Overrides Function FileLength ( _
    name As String _
) As Long
Public Overrides Function FileLength ( _
    name As String _
) As Long
public:
virtual long long FileLength(
    String^ name
) override
public:
virtual long long FileLength(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
FileSwitchDirectory Class
FileSwitchDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileModified Method

FileSwitchDirectory FileModified Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long FileModified(
    string name
)
public override long FileModified(
    string name
)
Public Overrides Function FileModified ( _
    name As String _
) As Long
Public Overrides Function FileModified ( _
    name As String _
) As Long
public:
virtual long long FileModified(
    String^ name
) override
public:
virtual long long FileModified(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
FileSwitchDirectory Class
FileSwitchDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetExtension Method

FileSwitchDirectory GetExtension Method Lucene.Net Class Library
Utility method to return a file's extension.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetExtension(
    string name
)
public static string GetExtension(
    string name
)
Public Shared Function GetExtension ( _
    name As String _
) As String
Public Shared Function GetExtension ( _
    name As String _
) As String
public:
static String^ GetExtension(
    String^ name
)
public:
static String^ GetExtension(
    String^ name
)
Parameters
name
Type:   Online System String
See Also
FileSwitchDirectory Class
FileSwitchDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ListAll Method

FileSwitchDirectory ListAll Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string[] ListAll()
public override string[] ListAll()
Public Overrides Function ListAll As String()
Public Overrides Function ListAll As String()
public:
virtual array<String^>^ ListAll() override
public:
virtual array<String^>^ ListAll() override
See Also
FileSwitchDirectory Class
FileSwitchDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenInput Method

FileSwitchDirectory OpenInput Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | OpenInput(String) | (Overrides Directory OpenInput(String).)
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are FSDirectory and CompoundFileReader . (Inherited from Directory.)
Back to Top
See Also
FileSwitchDirectory Class
FileSwitchDirectory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenInput Method (String)

FileSwitchDirectory OpenInput Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexInput OpenInput(
    string name
)
public override IndexInput OpenInput(
    string name
)
Public Overrides Function OpenInput ( _
    name As String _
) As IndexInput
Public Overrides Function OpenInput ( _
    name As String _
) As IndexInput
public:
virtual IndexInput^ OpenInput(
    String^ name
) override
public:
virtual IndexInput^ OpenInput(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
FileSwitchDirectory Class
FileSwitchDirectory Members
OpenInput Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Sync Method

FileSwitchDirectory Sync Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Sync(
    string name
)
public override void Sync(
    string name
)
Public Overrides Sub Sync ( _
    name As String _
)
Public Overrides Sub Sync ( _
    name As String _
)
public:
virtual void Sync(
    String^ name
) override
public:
virtual void Sync(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
FileSwitchDirectory Class
FileSwitchDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TouchFile Method

FileSwitchDirectory TouchFile Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void TouchFile(
    string name
)
public override void TouchFile(
    string name
)
Public Overrides Sub TouchFile ( _
    name As String _
)
Public Overrides Sub TouchFile ( _
    name As String _
)
public:
virtual void TouchFile(
    String^ name
) override
public:
virtual void TouchFile(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
FileSwitchDirectory Class
FileSwitchDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileSwitchDirectory Properties

FileSwitchDirectory Properties Lucene.Net Class Library
The FileSwitchDirectory type exposes the following members.
Properties
 | Name | Description
Public property | isOpen_ForNUnit | (Inherited from Directory.)
Public property | LockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public property | PrimaryDir | Return the primary directory
Public property | SecondaryDir | Return the secondary directory
Back to Top
See Also
FileSwitchDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrimaryDir Property

FileSwitchDirectory PrimaryDir Property Lucene.Net Class Library
Return the primary directory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Directory PrimaryDir { get; }
public virtual Directory PrimaryDir { get; }
Public Overridable ReadOnly Property PrimaryDir As Directory
    Get
Public Overridable ReadOnly Property PrimaryDir As Directory
    Get
public:
virtual property Directory^ PrimaryDir {
    Directory^ get ();
}
public:
virtual property Directory^ PrimaryDir {
    Directory^ get ();
}
See Also
FileSwitchDirectory Class
FileSwitchDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SecondaryDir Property

FileSwitchDirectory SecondaryDir Property Lucene.Net Class Library
Return the secondary directory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Directory SecondaryDir { get; }
public virtual Directory SecondaryDir { get; }
Public Overridable ReadOnly Property SecondaryDir As Directory
    Get
Public Overridable ReadOnly Property SecondaryDir As Directory
    Get
public:
virtual property Directory^ SecondaryDir {
    Directory^ get ();
}
public:
virtual property Directory^ SecondaryDir {
    Directory^ get ();
}
See Also
FileSwitchDirectory Class
FileSwitchDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FSDirectory Class

FSDirectory Class Lucene.Net Class Library
Base class for Directory implementations that store index files in the file system. There are currently three core subclasses:
  • SimpleFSDirectory is a straightforward implementation using java.io.RandomAccessFile. However, it has poor concurrent performance (multiple threads will bottleneck) as it synchronizes when multiple threads read from the same file.
  • NIOFSDirectory uses java.nio's FileChannel's positional io when reading to avoid synchronization when reading from the same file. Unfortunately, due to a Windows-only Online Sun JRE bug this is a poor choice for Windows, but on all other platforms this is the preferred choice. Applications using Online Interrupt or Future#cancel(boolean) (on Java 1.5) should use SimpleFSDirectory instead. See NIOFSDirectory java doc for details. MMapDirectory uses memory-mapped IO when reading. This is a good choice if you have plenty of virtual memory relative to your index size, eg if you are running on a 64 bit JRE, or you are running on a 32 bit JRE but your index sizes are small enough to fit into the virtual memory space. Java has currently the limitation of not being able to unmap files from user code. The files are unmapped, when GC releases the byte buffers. Due to Online this bug in Sun's JRE, MMapDirectory's Close is unable to close the underlying OS file handle. Only when GC finally collects the underlying objects, which could be quite some time later, will the file handle be closed. This will consume additional transient disk usage: on Windows, attempts to delete or overwrite the files will result in an exception; on other platforms, which typically have a "delete on last close" semantics, while such operations will succeed, the bytes are still consuming space on disk. For many applications this limitation is not a problem (e.g. if you have plenty of disk space, and you don't rely on overwriting files on Windows) but it's still an important limitation to be aware of. This class supplies a (possibly dangerous) workaround mentioned in the bug report, which may fail on non-Sun JVMs. Applications using Online Interrupt or Future#cancel(boolean) (on Java 1.5) should use SimpleFSDirectory instead. See MMapDirectory java doc for details.
Unfortunately, because of system peculiarities, there is no single overall best implementation. Therefore, we've added the Open(DirectoryInfo) method, to allow Lucene to choose the best FSDirectory implementation given your environment, and the known limitations of each implementation. For users who have no reason to prefer a specific implementation, it's best to simply use Open(DirectoryInfo) . For all others, you should instantiate the desired implementation directly.

The locking implementation is by default NativeFSLockFactory , but can be changed by passing in a custom LockFactory instance.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store Directory
Lucene.Net.Store FSDirectory
Lucene.Net.Store MMapDirectory
Lucene.Net.Store NIOFSDirectory
Lucene.Net.Store SimpleFSDirectory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class FSDirectory : Directory
public abstract class FSDirectory : Directory
Public MustInherit Class FSDirectory _
    Inherits Directory
Public MustInherit Class FSDirectory _
    Inherits Directory
public ref class FSDirectory abstract : public Directory
public ref class FSDirectory abstract : public Directory
See Also
FSDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FSDirectory Members

FSDirectory Members Lucene.Net Class Library

The FSDirectory type exposes the following members.
Constructors
 | Name | Description
Protected method | FSDirectory | Create a new FSDirectory for the named location (ctor for subclasses).
Back to Top
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Obsolete. (Inherited from Directory.)
Public method | CreateOutput | Creates a new, empty file in the directory with the given name. Returns a stream writing this file. (Inherited from Directory.)
Public method | DeleteFile | Removes an existing file in the directory. (Overrides Directory DeleteFile(String).)
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FSDirectory and optionally releases the managed resources (Overrides Directory Dispose(Boolean).)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Overrides Directory FileExists(String).)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Overrides Directory FileLength(String).)
Public method | FileModified(String) | Returns the time the named file was last modified. (Overrides Directory FileModified(String).)
 | FileModified(FileInfo, String) | Returns the time the named file was last modified.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLockId | (Overrides Directory GetLockId .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InitOutput | Initializes the directory to create a new file with the given name. This method should be used in CreateOutput(String).
Public method | ListAll | Lists all files (not subdirectories) in the directory. (Overrides Directory ListAll .)
 | ListAll(DirectoryInfo) | Lists all files (not subdirectories) in the directory. This method never returns null (throws Online IOException instead).
Public method | MakeLock | Construct a Lock. (Inherited from Directory.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Open(DirectoryInfo) | Creates an FSDirectory instance, trying to pick the best implementation given the current environment. The directory returned uses the NativeFSLockFactory. Currently this returns SimpleFSDirectory as NIOFSDirectory is currently not supported. NOTE: this method may suddenly change which implementation is returned from release to release, in the event that higher performance defaults become possible; if the precise implementation is important to your application, please instantiate it directly, instead. On 64 bit systems, it may also good to return MMapDirectory, but this is disabled because of officially missing unmap support in Java. For optimal performance you should consider using this implementation on 64 bit JVMs. See above
 | Open(String) | Creates an FSDirectory instance, trying to pick the best implementation given the current environment. The directory returned uses the NativeFSLockFactory. Currently this returns SimpleFSDirectory as NIOFSDirectory is currently not supported. NOTE: this method may suddenly change which implementation is returned from release to release, in the event that higher performance defaults become possible; if the precise implementation is important to your application, please instantiate it directly, instead. On 64 bit systems, it may also good to return MMapDirectory, but this is disabled because of officially missing unmap support in Java. For optimal performance you should consider using this implementation on 64 bit JVMs. See above
 | Open(DirectoryInfo, LockFactory) | Just like Open(DirectoryInfo), but allows you to also specify a custom LockFactory.
Public method | OpenInput(String) | (Overrides Directory OpenInput(String).)
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are FSDirectory and CompoundFileReader . (Inherited from Directory.)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | Sync | (Overrides Directory Sync(String).)
Public method | ToString | For debug output. (Overrides Directory ToString .)
Public method | TouchFile | Set the modified time of an existing file to now. (Overrides Directory TouchFile(String).)
Back to Top
Fields
 | Name | Description
 | DEFAULT_READ_CHUNK_SIZE | Default read chunk size. This is a conditional default: on 32bit JVMs, it defaults to 100 MB. On 64bit JVMs, it's Integer.MAX_VALUE.
Protected field | interalLockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)
Protected field | internalDirectory | The underlying filesystem directory
Protected field | isOpen | (Inherited from Directory.)
Back to Top
Properties
 | Name | Description
Public property | Directory |
Public property | isOpen_ForNUnit | (Inherited from Directory.)
Public property | LockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public property | ReadChunkSize | The maximum number of bytes to read at once from the underlying file during ReadBytes( Byte , Int32, Int32).
Back to Top
See Also
FSDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FSDirectory Constructor

FSDirectory Constructor Lucene.Net Class Library
Create a new FSDirectory for the named location (ctor for subclasses).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FSDirectory(
    DirectoryInfo path,
    LockFactory lockFactory
)
protected FSDirectory(
    DirectoryInfo path,
    LockFactory lockFactory
)
Protected Sub New ( _
    path As DirectoryInfo, _
    lockFactory As LockFactory _
)
Protected Sub New ( _
    path As DirectoryInfo, _
    lockFactory As LockFactory _
)
protected:
FSDirectory(
    DirectoryInfo^ path,
    LockFactory^ lockFactory
)
protected:
FSDirectory(
    DirectoryInfo^ path,
    LockFactory^ lockFactory
)
Parameters
path
Type:   Online System.IO DirectoryInfo
the path of the directory

lockFactory
Type: Lucene.Net.Store LockFactory
the lock factory to use, or null for the default
            (NativeFSLockFactory);

See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FSDirectory Fields

FSDirectory Fields Lucene.Net Class Library
The FSDirectory type exposes the following members.
Fields
 | Name | Description
 | DEFAULT_READ_CHUNK_SIZE | Default read chunk size. This is a conditional default: on 32bit JVMs, it defaults to 100 MB. On 64bit JVMs, it's Integer.MAX_VALUE.
Protected field | interalLockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)
Protected field | internalDirectory | The underlying filesystem directory
Protected field | isOpen | (Inherited from Directory.)
Back to Top
See Also
FSDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_READ_CHUNK_SIZE Field

FSDirectory DEFAULT_READ_CHUNK_SIZE Field Lucene.Net Class Library
Default read chunk size. This is a conditional default: on 32bit JVMs, it defaults to 100 MB. On 64bit JVMs, it's Integer.MAX_VALUE.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly int DEFAULT_READ_CHUNK_SIZE
public static readonly int DEFAULT_READ_CHUNK_SIZE
Public Shared ReadOnly DEFAULT_READ_CHUNK_SIZE As Integer
Public Shared ReadOnly DEFAULT_READ_CHUNK_SIZE As Integer
public:
static initonly int DEFAULT_READ_CHUNK_SIZE
public:
static initonly int DEFAULT_READ_CHUNK_SIZE
See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace
FSDirectory ReadChunkSize
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalDirectory Field

FSDirectory internalDirectory Field Lucene.Net Class Library
The underlying filesystem directory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DirectoryInfo internalDirectory
protected DirectoryInfo internalDirectory
Protected internalDirectory As DirectoryInfo
Protected internalDirectory As DirectoryInfo
protected:
DirectoryInfo^ internalDirectory
protected:
DirectoryInfo^ internalDirectory
See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FSDirectory Methods

FSDirectory Methods Lucene.Net Class Library
The FSDirectory type exposes the following members.
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Obsolete. (Inherited from Directory.)
Public method | CreateOutput | Creates a new, empty file in the directory with the given name. Returns a stream writing this file. (Inherited from Directory.)
Public method | DeleteFile | Removes an existing file in the directory. (Overrides Directory DeleteFile(String).)
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | (Overrides Directory Dispose(Boolean).)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Overrides Directory FileExists(String).)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Overrides Directory FileLength(String).)
Public method | FileModified(String) | Returns the time the named file was last modified. (Overrides Directory FileModified(String).)
 | FileModified(FileInfo, String) | Returns the time the named file was last modified.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLockId | (Overrides Directory GetLockId .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InitOutput | Initializes the directory to create a new file with the given name. This method should be used in CreateOutput(String).
Public method | ListAll | Lists all files (not subdirectories) in the directory. (Overrides Directory ListAll .)
 | ListAll(DirectoryInfo) | Lists all files (not subdirectories) in the directory. This method never returns null (throws Online IOException instead).
Public method | MakeLock | Construct a Lock. (Inherited from Directory.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Open(DirectoryInfo) | Creates an FSDirectory instance, trying to pick the best implementation given the current environment. The directory returned uses the NativeFSLockFactory. Currently this returns SimpleFSDirectory as NIOFSDirectory is currently not supported. NOTE: this method may suddenly change which implementation is returned from release to release, in the event that higher performance defaults become possible; if the precise implementation is important to your application, please instantiate it directly, instead. On 64 bit systems, it may also good to return MMapDirectory, but this is disabled because of officially missing unmap support in Java. For optimal performance you should consider using this implementation on 64 bit JVMs. See above
 | Open(String) | Creates an FSDirectory instance, trying to pick the best implementation given the current environment. The directory returned uses the NativeFSLockFactory. Currently this returns SimpleFSDirectory as NIOFSDirectory is currently not supported. NOTE: this method may suddenly change which implementation is returned from release to release, in the event that higher performance defaults become possible; if the precise implementation is important to your application, please instantiate it directly, instead. On 64 bit systems, it may also good to return MMapDirectory, but this is disabled because of officially missing unmap support in Java. For optimal performance you should consider using this implementation on 64 bit JVMs. See above
 | Open(DirectoryInfo, LockFactory) | Just like Open(DirectoryInfo), but allows you to also specify a custom LockFactory.
Public method | OpenInput(String) | (Overrides Directory OpenInput(String).)
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are FSDirectory and CompoundFileReader . (Inherited from Directory.)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | Sync | (Overrides Directory Sync(String).)
Public method | ToString | For debug output. (Overrides Directory ToString .)
Public method | TouchFile | Set the modified time of an existing file to now. (Overrides Directory TouchFile(String).)
Back to Top
See Also
FSDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DeleteFile Method

FSDirectory DeleteFile Method Lucene.Net Class Library
Removes an existing file in the directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void DeleteFile(
    string name
)
public override void DeleteFile(
    string name
)
Public Overrides Sub DeleteFile ( _
    name As String _
)
Public Overrides Sub DeleteFile ( _
    name As String _
)
public:
virtual void DeleteFile(
    String^ name
) override
public:
virtual void DeleteFile(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

FSDirectory Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FSDirectory and optionally releases the managed resources (Overrides Directory Dispose(Boolean).)
Back to Top
See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

FSDirectory Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the FSDirectory and optionally releases the managed resources

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
FSDirectory Class
FSDirectory Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileExists Method

FSDirectory FileExists Method Lucene.Net Class Library
Returns true iff a file with the given name exists.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool FileExists(
    string name
)
public override bool FileExists(
    string name
)
Public Overrides Function FileExists ( _
    name As String _
) As Boolean
Public Overrides Function FileExists ( _
    name As String _
) As Boolean
public:
virtual bool FileExists(
    String^ name
) override
public:
virtual bool FileExists(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileLength Method

FSDirectory FileLength Method Lucene.Net Class Library
Returns the length in bytes of a file in the directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long FileLength(
    string name
)
public override long FileLength(
    string name
)
Public Overrides Function FileLength ( _
    name As String _
) As Long
Public Overrides Function FileLength ( _
    name As String _
) As Long
public:
virtual long long FileLength(
    String^ name
) override
public:
virtual long long FileLength(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileModified Method

FSDirectory FileModified Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | FileModified(String) | Returns the time the named file was last modified. (Overrides Directory FileModified(String).)
 | FileModified(FileInfo, String) | Returns the time the named file was last modified.
Back to Top
See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileModified Method (String)

FSDirectory FileModified Method (String) Lucene.Net Class Library
Returns the time the named file was last modified.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long FileModified(
    string name
)
public override long FileModified(
    string name
)
Public Overrides Function FileModified ( _
    name As String _
) As Long
Public Overrides Function FileModified ( _
    name As String _
) As Long
public:
virtual long long FileModified(
    String^ name
) override
public:
virtual long long FileModified(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
FSDirectory Class
FSDirectory Members
FileModified Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileModified Method (FileInfo, String)

FSDirectory FileModified Method (FileInfo, String) Lucene.Net Class Library
Returns the time the named file was last modified.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long FileModified(
    FileInfo directory,
    string name
)
public static long FileModified(
    FileInfo directory,
    string name
)
Public Shared Function FileModified ( _
    directory As FileInfo, _
    name As String _
) As Long
Public Shared Function FileModified ( _
    directory As FileInfo, _
    name As String _
) As Long
public:
static long long FileModified(
    FileInfo^ directory,
    String^ name
)
public:
static long long FileModified(
    FileInfo^ directory,
    String^ name
)
Parameters
directory
Type:   Online System.IO FileInfo
name
Type:   Online System String
See Also
FSDirectory Class
FSDirectory Members
FileModified Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLockId Method

FSDirectory GetLockId Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetLockId()
public override string GetLockId()
Public Overrides Function GetLockId As String
Public Overrides Function GetLockId As String
public:
virtual String^ GetLockId() override
public:
virtual String^ GetLockId() override
See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


InitOutput Method

FSDirectory InitOutput Method Lucene.Net Class Library
Initializes the directory to create a new file with the given name. This method should be used in CreateOutput(String).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void InitOutput(
    string name
)
protected void InitOutput(
    string name
)
Protected Sub InitOutput ( _
    name As String _
)
Protected Sub InitOutput ( _
    name As String _
)
protected:
void InitOutput(
    String^ name
)
protected:
void InitOutput(
    String^ name
)
Parameters
name
Type:   Online System String
See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ListAll Method

FSDirectory ListAll Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ListAll | Lists all files (not subdirectories) in the directory. (Overrides Directory ListAll .)
 | ListAll(DirectoryInfo) | Lists all files (not subdirectories) in the directory. This method never returns null (throws Online IOException instead).
Back to Top
See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ListAll Method

FSDirectory ListAll Method Lucene.Net Class Library
Lists all files (not subdirectories) in the directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string[] ListAll()
public override string[] ListAll()
Public Overrides Function ListAll As String()
Public Overrides Function ListAll As String()
public:
virtual array<String^>^ ListAll() override
public:
virtual array<String^>^ ListAll() override
See Also
FSDirectory Class
FSDirectory Members
ListAll Overload
Lucene.Net.Store Namespace
FSDirectory ListAll(DirectoryInfo)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ListAll Method (DirectoryInfo)

FSDirectory ListAll Method (DirectoryInfo) Lucene.Net Class Library
Lists all files (not subdirectories) in the directory. This method never returns null (throws Online IOException instead).
does not exist, or does exist but is not a directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string[] ListAll(
    DirectoryInfo dir
)
public static string[] ListAll(
    DirectoryInfo dir
)
Public Shared Function ListAll ( _
    dir As DirectoryInfo _
) As String()
Public Shared Function ListAll ( _
    dir As DirectoryInfo _
) As String()
public:
static array<String^>^ ListAll(
    DirectoryInfo^ dir
)
public:
static array<String^>^ ListAll(
    DirectoryInfo^ dir
)
Parameters
dir
Type:   Online System.IO DirectoryInfo
See Also
FSDirectory Class
FSDirectory Members
ListAll Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Open Method

FSDirectory Open Method Lucene.Net Class Library
Overload List
Name | Description
Open(DirectoryInfo) | Creates an FSDirectory instance, trying to pick the best implementation given the current environment. The directory returned uses the NativeFSLockFactory. Currently this returns SimpleFSDirectory as NIOFSDirectory is currently not supported. NOTE: this method may suddenly change which implementation is returned from release to release, in the event that higher performance defaults become possible; if the precise implementation is important to your application, please instantiate it directly, instead. On 64 bit systems, it may also good to return MMapDirectory, but this is disabled because of officially missing unmap support in Java. For optimal performance you should consider using this implementation on 64 bit JVMs. See above
Open(String) | Creates an FSDirectory instance, trying to pick the best implementation given the current environment. The directory returned uses the NativeFSLockFactory. Currently this returns SimpleFSDirectory as NIOFSDirectory is currently not supported. NOTE: this method may suddenly change which implementation is returned from release to release, in the event that higher performance defaults become possible; if the precise implementation is important to your application, please instantiate it directly, instead. On 64 bit systems, it may also good to return MMapDirectory, but this is disabled because of officially missing unmap support in Java. For optimal performance you should consider using this implementation on 64 bit JVMs. See above
Open(DirectoryInfo, LockFactory) | Just like Open(DirectoryInfo), but allows you to also specify a custom LockFactory.
Back to Top
See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Open Method (DirectoryInfo)

FSDirectory Open Method (DirectoryInfo) Lucene.Net Class Library
Creates an FSDirectory instance, trying to pick the best implementation given the current environment. The directory returned uses the NativeFSLockFactory.

Currently this returns SimpleFSDirectory as NIOFSDirectory is currently not supported.

NOTE: this method may suddenly change which implementation is returned from release to release, in the event that higher performance defaults become possible; if the precise implementation is important to your application, please instantiate it directly, instead. On 64 bit systems, it may also good to return MMapDirectory, but this is disabled because of officially missing unmap support in Java. For optimal performance you should consider using this implementation on 64 bit JVMs.

See above

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSDirectory Open(
    DirectoryInfo path
)
public static FSDirectory Open(
    DirectoryInfo path
)
Public Shared Function Open ( _
    path As DirectoryInfo _
) As FSDirectory
Public Shared Function Open ( _
    path As DirectoryInfo _
) As FSDirectory
public:
static FSDirectory^ Open(
    DirectoryInfo^ path
)
public:
static FSDirectory^ Open(
    DirectoryInfo^ path
)
Parameters
path
Type:   Online System.IO DirectoryInfo
See Also
FSDirectory Class
FSDirectory Members
Open Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Open Method (String)

FSDirectory Open Method (String) Lucene.Net Class Library
Creates an FSDirectory instance, trying to pick the best implementation given the current environment. The directory returned uses the NativeFSLockFactory.

Currently this returns SimpleFSDirectory as NIOFSDirectory is currently not supported.

NOTE: this method may suddenly change which implementation is returned from release to release, in the event that higher performance defaults become possible; if the precise implementation is important to your application, please instantiate it directly, instead. On 64 bit systems, it may also good to return MMapDirectory, but this is disabled because of officially missing unmap support in Java. For optimal performance you should consider using this implementation on 64 bit JVMs.

See above

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSDirectory Open(
    string path
)
public static FSDirectory Open(
    string path
)
Public Shared Function Open ( _
    path As String _
) As FSDirectory
Public Shared Function Open ( _
    path As String _
) As FSDirectory
public:
static FSDirectory^ Open(
    String^ path
)
public:
static FSDirectory^ Open(
    String^ path
)
Parameters
path
Type:   Online System String
See Also
FSDirectory Class
FSDirectory Members
Open Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Open Method (DirectoryInfo, LockFactory)

FSDirectory Open Method (DirectoryInfo, LockFactory) Lucene.Net Class Library
Just like Open(DirectoryInfo), but allows you to also specify a custom LockFactory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSDirectory Open(
    DirectoryInfo path,
    LockFactory lockFactory
)
public static FSDirectory Open(
    DirectoryInfo path,
    LockFactory lockFactory
)
Public Shared Function Open ( _
    path As DirectoryInfo, _
    lockFactory As LockFactory _
) As FSDirectory
Public Shared Function Open ( _
    path As DirectoryInfo, _
    lockFactory As LockFactory _
) As FSDirectory
public:
static FSDirectory^ Open(
    DirectoryInfo^ path,
    LockFactory^ lockFactory
)
public:
static FSDirectory^ Open(
    DirectoryInfo^ path,
    LockFactory^ lockFactory
)
Parameters
path
Type:   Online System.IO DirectoryInfo
lockFactory
Type: Lucene.Net.Store LockFactory
See Also
FSDirectory Class
FSDirectory Members
Open Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenInput Method

FSDirectory OpenInput Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | OpenInput(String) | (Overrides Directory OpenInput(String).)
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are FSDirectory and CompoundFileReader . (Inherited from Directory.)
Back to Top
See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenInput Method (String)

FSDirectory OpenInput Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexInput OpenInput(
    string name
)
public override IndexInput OpenInput(
    string name
)
Public Overrides Function OpenInput ( _
    name As String _
) As IndexInput
Public Overrides Function OpenInput ( _
    name As String _
) As IndexInput
public:
virtual IndexInput^ OpenInput(
    String^ name
) override
public:
virtual IndexInput^ OpenInput(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
FSDirectory Class
FSDirectory Members
OpenInput Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Sync Method

FSDirectory Sync Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Sync(
    string name
)
public override void Sync(
    string name
)
Public Overrides Sub Sync ( _
    name As String _
)
Public Overrides Sub Sync ( _
    name As String _
)
public:
virtual void Sync(
    String^ name
) override
public:
virtual void Sync(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

FSDirectory ToString Method Lucene.Net Class Library
For debug output.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TouchFile Method

FSDirectory TouchFile Method Lucene.Net Class Library
Set the modified time of an existing file to now.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void TouchFile(
    string name
)
public override void TouchFile(
    string name
)
Public Overrides Sub TouchFile ( _
    name As String _
)
Public Overrides Sub TouchFile ( _
    name As String _
)
public:
virtual void TouchFile(
    String^ name
) override
public:
virtual void TouchFile(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FSDirectory Properties

FSDirectory Properties Lucene.Net Class Library
The FSDirectory type exposes the following members.
Properties
 | Name | Description
Public property | Directory |
Public property | isOpen_ForNUnit | (Inherited from Directory.)
Public property | LockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public property | ReadChunkSize | The maximum number of bytes to read at once from the underlying file during ReadBytes( Byte , Int32, Int32).
Back to Top
See Also
FSDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Directory Property

FSDirectory Directory Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual DirectoryInfo Directory { get; }
public virtual DirectoryInfo Directory { get; }
Public Overridable ReadOnly Property Directory As DirectoryInfo
    Get
Public Overridable ReadOnly Property Directory As DirectoryInfo
    Get
public:
virtual property DirectoryInfo^ Directory {
    DirectoryInfo^ get ();
}
public:
virtual property DirectoryInfo^ Directory {
    DirectoryInfo^ get ();
}
See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadChunkSize Property

FSDirectory ReadChunkSize Property Lucene.Net Class Library
The maximum number of bytes to read at once from the underlying file during ReadBytes( Byte , Int32, Int32).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ReadChunkSize { get; set; }
public int ReadChunkSize { get; set; }
Public Property ReadChunkSize As Integer
    Get
    Set
Public Property ReadChunkSize As Integer
    Get
    Set
public:
property int ReadChunkSize {
    int get ();
    void set (int value);
}
public:
property int ReadChunkSize {
    int get ();
    void set (int value);
}
See Also
FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace
FSDirectory ReadChunkSize
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FSLockFactory Class

FSLockFactory Class Lucene.Net Class Library
Base class for file system based locking implementation.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store LockFactory
Lucene.Net.Store FSLockFactory
Lucene.Net.Store NativeFSLockFactory
Lucene.Net.Store SimpleFSLockFactory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class FSLockFactory : LockFactory
public abstract class FSLockFactory : LockFactory
Public MustInherit Class FSLockFactory _
    Inherits LockFactory
Public MustInherit Class FSLockFactory _
    Inherits LockFactory
public ref class FSLockFactory abstract : public LockFactory
public ref class FSLockFactory abstract : public LockFactory
See Also
FSLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FSLockFactory Members

FSLockFactory Members Lucene.Net Class Library

The FSLockFactory type exposes the following members.
Constructors
 | Name | Description
Protected method | FSLockFactory | Initializes a new instance of the FSLockFactory class
Back to Top
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from LockFactory.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLock | Return a new Lock instance identified by lockName. (Inherited from LockFactory.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | internalLockDir | Directory for the lock files.
Protected field | internalLockPrefix | (Inherited from LockFactory.)
Back to Top
Properties
 | Name | Description
Public property | LockDir | Gets the lock directory. Subclasses can use this to set the lock directory. This method can be only called once to initialize the lock directory. It is used by FSDirectory to set the lock directory to itsself. Subclasses can also use this method to set the directory in the constructor.
Public property | LockPrefix | Gets or sets the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Back to Top
See Also
FSLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FSLockFactory Constructor

FSLockFactory Constructor Lucene.Net Class Library
Initializes a new instance of the FSLockFactory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FSLockFactory()
protected FSLockFactory()
Protected Sub New
Protected Sub New
protected:
FSLockFactory()
protected:
FSLockFactory()
See Also
FSLockFactory Class
FSLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FSLockFactory Fields

FSLockFactory Fields Lucene.Net Class Library
The FSLockFactory type exposes the following members.
Fields
 | Name | Description
Protected field | internalLockDir | Directory for the lock files.
Protected field | internalLockPrefix | (Inherited from LockFactory.)
Back to Top
See Also
FSLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalLockDir Field

FSLockFactory internalLockDir Field Lucene.Net Class Library
Directory for the lock files.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DirectoryInfo internalLockDir
protected DirectoryInfo internalLockDir
Protected internalLockDir As DirectoryInfo
Protected internalLockDir As DirectoryInfo
protected:
DirectoryInfo^ internalLockDir
protected:
DirectoryInfo^ internalLockDir
See Also
FSLockFactory Class
FSLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FSLockFactory Methods

FSLockFactory Methods Lucene.Net Class Library
The FSLockFactory type exposes the following members.
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from LockFactory.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLock | Return a new Lock instance identified by lockName. (Inherited from LockFactory.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FSLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FSLockFactory Properties

FSLockFactory Properties Lucene.Net Class Library
The FSLockFactory type exposes the following members.
Properties
 | Name | Description
Public property | LockDir | Gets the lock directory. Subclasses can use this to set the lock directory. This method can be only called once to initialize the lock directory. It is used by FSDirectory to set the lock directory to itsself. Subclasses can also use this method to set the directory in the constructor.
Public property | LockPrefix | Gets or sets the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Back to Top
See Also
FSLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockDir Property

FSLockFactory LockDir Property Lucene.Net Class Library
Gets the lock directory.

Subclasses can use this to set the lock directory. This method can be only called once to initialize the lock directory. It is used by FSDirectory to set the lock directory to itsself. Subclasses can also use this method to set the directory in the constructor.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual DirectoryInfo LockDir { get; protected internal set; }
public virtual DirectoryInfo LockDir { get; protected internal set; }
Public Overridable Property LockDir As DirectoryInfo
    Get
    Protected Friend Set
Public Overridable Property LockDir As DirectoryInfo
    Get
    Protected Friend Set
public:
virtual property DirectoryInfo^ LockDir {
    DirectoryInfo^ get ();
    protected public: void set (DirectoryInfo^ value);
}
public:
virtual property DirectoryInfo^ LockDir {
    DirectoryInfo^ get ();
    protected public: void set (DirectoryInfo^ value);
}
See Also
FSLockFactory Class
FSLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexInput Class

IndexInput Class Lucene.Net Class Library
Abstract base class for input from a file in a Directory. A random-access input stream. Used for all Lucene index input operations.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store IndexInput
Lucene.Net.Index ByteSliceReader
Lucene.Net.Store BufferedIndexInput
Lucene.Net.Store ChecksumIndexInput
Lucene.Net.Store MMapDirectory MultiMMapIndexInput
Lucene.Net.Store RAMInputStream

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class IndexInput : ICloneable,
    IDisposable
public abstract class IndexInput : ICloneable,
    IDisposable
Public MustInherit Class IndexInput _
    Implements ICloneable, IDisposable
Public MustInherit Class IndexInput _
    Implements ICloneable, IDisposable
public ref class IndexInput abstract : ICloneable,
    IDisposable
public ref class IndexInput abstract : ICloneable,
    IDisposable
See Also
IndexInput Members
Lucene.Net.Store Namespace
Lucene.Net.Store Directory
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexInput Members

IndexInput Members Lucene.Net Class Library

The IndexInput type exposes the following members.
Constructors
 | Name | Description
Protected method | IndexInput | Initializes a new instance of the IndexInput class
Back to Top
Methods
 | Name | Description
Public method | Clone | Returns a clone of this stream. Clones of a stream access the same data, and are positioned at the same point as the stream they were cloned from. Expert: Subclasses must ensure that clones may be positioned at different points in the input from each other and from the stream they were cloned from.
Public method | Close | Obsolete.
Public method | Dispose | Closes the stream to futher operations.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the IndexInput and optionally releases the managed resources
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Length | The number of bytes in the file.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadByte | Reads and returns a single byte.
Public method | ReadBytes( Byte , Int32, Int32) | Reads a specified number of bytes into an array at the specified offset.
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only BufferedIndexInput respects this parameter.
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
Public method | ReadInt | Reads four bytes and returns an int.
Public method | ReadLong | Reads eight bytes and returns a long.
Public method | ReadString | Reads a string.
Public method | ReadStringStringMap |
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Public method | Seek | Sets current position in this file, where the next read will occur.
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details.
Public method | SkipChars | Obsolete. Expert Similar to ReadChars( Char , Int32, Int32) but does not do any conversion operations on the bytes it is reading in. It still has to invoke ReadByte just as ReadChars( Char , Int32, Int32) does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | FilePointer | Returns the current position in this file, where the next read will occur.
Back to Top
See Also
IndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexInput Constructor

IndexInput Constructor Lucene.Net Class Library
Initializes a new instance of the IndexInput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IndexInput()
protected IndexInput()
Protected Sub New
Protected Sub New
protected:
IndexInput()
protected:
IndexInput()
See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexInput Methods

IndexInput Methods Lucene.Net Class Library
The IndexInput type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Returns a clone of this stream. Clones of a stream access the same data, and are positioned at the same point as the stream they were cloned from. Expert: Subclasses must ensure that clones may be positioned at different points in the input from each other and from the stream they were cloned from.
Public method | Close | Obsolete.
Public method | Dispose | Closes the stream to futher operations.
Protected method | Dispose(Boolean) |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Length | The number of bytes in the file.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadByte | Reads and returns a single byte.
Public method | ReadBytes( Byte , Int32, Int32) | Reads a specified number of bytes into an array at the specified offset.
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only BufferedIndexInput respects this parameter.
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
Public method | ReadInt | Reads four bytes and returns an int.
Public method | ReadLong | Reads eight bytes and returns a long.
Public method | ReadString | Reads a string.
Public method | ReadStringStringMap |
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Public method | Seek | Sets current position in this file, where the next read will occur.
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details.
Public method | SkipChars | Obsolete. Expert Similar to ReadChars( Char , Int32, Int32) but does not do any conversion operations on the bytes it is reading in. It still has to invoke ReadByte just as ReadChars( Char , Int32, Int32) does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
IndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

IndexInput Clone Method Lucene.Net Class Library
Returns a clone of this stream.

Clones of a stream access the same data, and are positioned at the same point as the stream they were cloned from.

Expert: Subclasses must ensure that clones may be positioned at different points in the input from each other and from the stream they were cloned from.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object Clone()
public virtual Object Clone()
Public Overridable Function Clone As Object
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
public:
virtual Object^ Clone()
Implements
  Online ICloneable Clone
See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

IndexInput Close Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Dispose() instead.")]
public void Close()
[ObsoleteAttribute("Use Dispose() instead.")]
public void Close()
<ObsoleteAttribute("Use Dispose() instead.")> _
Public Sub Close
<ObsoleteAttribute("Use Dispose() instead.")> _
Public Sub Close
public:
[ObsoleteAttribute(L"Use Dispose() instead.")]
void Close()
public:
[ObsoleteAttribute(L"Use Dispose() instead.")]
void Close()
See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

IndexInput Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes the stream to futher operations.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the IndexInput and optionally releases the managed resources
Back to Top
See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

IndexInput Dispose Method Lucene.Net Class Library
Closes the stream to futher operations.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
IndexInput Class
IndexInput Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

IndexInput Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the IndexInput and optionally releases the managed resources

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void Dispose(
    bool disposing
)
protected abstract void Dispose(
    bool disposing
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) abstract
protected:
virtual void Dispose(
    bool disposing
) abstract
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
IndexInput Class
IndexInput Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Length Method

IndexInput Length Method Lucene.Net Class Library
The number of bytes in the file.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract long Length()
public abstract long Length()
Public MustOverride Function Length As Long
Public MustOverride Function Length As Long
public:
virtual long long Length() abstract
public:
virtual long long Length() abstract
See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadByte Method

IndexInput ReadByte Method Lucene.Net Class Library
Reads and returns a single byte.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract byte ReadByte()
public abstract byte ReadByte()
Public MustOverride Function ReadByte As Byte
Public MustOverride Function ReadByte As Byte
public:
virtual unsigned char ReadByte() abstract
public:
virtual unsigned char ReadByte() abstract
See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace
IndexOutput WriteByte(Byte)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadBytes Method

IndexInput ReadBytes Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ReadBytes( Byte , Int32, Int32) | Reads a specified number of bytes into an array at the specified offset.
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only BufferedIndexInput respects this parameter.
Back to Top
See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadBytes Method (Byte[], Int32, Int32)

IndexInput ReadBytes Method ( Byte , Int32, Int32) Lucene.Net Class Library
Reads a specified number of bytes into an array at the specified offset.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void ReadBytes(
    byte[] b,
    int offset,
    int len
)
public abstract void ReadBytes(
    byte[] b,
    int offset,
    int len
)
Public MustOverride Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Public MustOverride Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) abstract
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) abstract
Parameters
b
Type:    Online System Byte
the array to read bytes into

offset
Type:   Online System Int32
the offset in the array to start storing bytes

len
Type:   Online System Int32
the number of bytes to read

See Also
IndexInput Class
IndexInput Members
ReadBytes Overload
Lucene.Net.Store Namespace
IndexOutput WriteBytes( Byte , Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadBytes Method (Byte[], Int32, Int32, Boolean)

IndexInput ReadBytes Method ( Byte , Int32, Int32, Boolean) Lucene.Net Class Library
Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only BufferedIndexInput respects this parameter.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ReadBytes(
    byte[] b,
    int offset,
    int len,
    bool useBuffer
)
public virtual void ReadBytes(
    byte[] b,
    int offset,
    int len,
    bool useBuffer
)
Public Overridable Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer, _
    useBuffer As Boolean _
)
Public Overridable Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer, _
    useBuffer As Boolean _
)
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len,
    bool useBuffer
)
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len,
    bool useBuffer
)
Parameters
b
Type:    Online System Byte
the array to read bytes into

offset
Type:   Online System Int32
the offset in the array to start storing bytes

len
Type:   Online System Int32
the number of bytes to read

useBuffer
Type:   Online System Boolean
set to false if the caller will handle
            buffering.

See Also
IndexInput Class
IndexInput Members
ReadBytes Overload
Lucene.Net.Store Namespace
IndexOutput WriteBytes( Byte , Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadChars Method

IndexInput ReadChars Method Lucene.Net Class Library
Reads Lucene's old "modified UTF-8" encoded characters into an array.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("-- please use ReadString or ReadBytes instead, and construct the string from those utf8 bytes")]
public virtual void ReadChars(
    char[] buffer,
    int start,
    int length
)
[ObsoleteAttribute("-- please use ReadString or ReadBytes instead, and construct the string from those utf8 bytes")]
public virtual void ReadChars(
    char[] buffer,
    int start,
    int length
)
<ObsoleteAttribute("-- please use ReadString or ReadBytes instead, and construct the string from those utf8 bytes")> _
Public Overridable Sub ReadChars ( _
    buffer As Char(), _
    start As Integer, _
    length As Integer _
)
<ObsoleteAttribute("-- please use ReadString or ReadBytes instead, and construct the string from those utf8 bytes")> _
Public Overridable Sub ReadChars ( _
    buffer As Char(), _
    start As Integer, _
    length As Integer _
)
public:
[ObsoleteAttribute(L"-- please use ReadString or ReadBytes instead, and construct the string from those utf8 bytes")]
virtual void ReadChars(
    array<wchar_t>^ buffer,
    int start,
    int length
)
public:
[ObsoleteAttribute(L"-- please use ReadString or ReadBytes instead, and construct the string from those utf8 bytes")]
virtual void ReadChars(
    array<wchar_t>^ buffer,
    int start,
    int length
)
Parameters
buffer
Type:    Online System Char
the array to read characters into

start
Type:   Online System Int32
the offset in the array to start storing characters

length
Type:   Online System Int32
the number of characters to read

See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace
IndexOutput WriteChars(String, Int32, Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadInt Method

IndexInput ReadInt Method Lucene.Net Class Library
Reads four bytes and returns an int.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int ReadInt()
public virtual int ReadInt()
Public Overridable Function ReadInt As Integer
Public Overridable Function ReadInt As Integer
public:
virtual int ReadInt()
public:
virtual int ReadInt()
See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace
IndexOutput WriteInt(Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadLong Method

IndexInput ReadLong Method Lucene.Net Class Library
Reads eight bytes and returns a long.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long ReadLong()
public virtual long ReadLong()
Public Overridable Function ReadLong As Long
Public Overridable Function ReadLong As Long
public:
virtual long long ReadLong()
public:
virtual long long ReadLong()
See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace
IndexOutput WriteLong(Int64)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadString Method

IndexInput ReadString Method Lucene.Net Class Library
Reads a string.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string ReadString()
public virtual string ReadString()
Public Overridable Function ReadString As String
Public Overridable Function ReadString As String
public:
virtual String^ ReadString()
public:
virtual String^ ReadString()
See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace
IndexOutput WriteString(String)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadStringStringMap Method

IndexInput ReadStringStringMap Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IDictionary<string, string> ReadStringStringMap()
public virtual IDictionary<string, string> ReadStringStringMap()
Public Overridable Function ReadStringStringMap As IDictionary(Of String, String)
Public Overridable Function ReadStringStringMap As IDictionary(Of String, String)
public:
virtual IDictionary<String^, String^>^ ReadStringStringMap()
public:
virtual IDictionary<String^, String^>^ ReadStringStringMap()
See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadVInt Method

IndexInput ReadVInt Method Lucene.Net Class Library
Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int ReadVInt()
public virtual int ReadVInt()
Public Overridable Function ReadVInt As Integer
Public Overridable Function ReadVInt As Integer
public:
virtual int ReadVInt()
public:
virtual int ReadVInt()
See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace
IndexOutput WriteVInt(Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadVLong Method

IndexInput ReadVLong Method Lucene.Net Class Library
Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long ReadVLong()
public virtual long ReadVLong()
Public Overridable Function ReadVLong As Long
Public Overridable Function ReadVLong As Long
public:
virtual long long ReadVLong()
public:
virtual long long ReadVLong()
See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method

IndexInput Seek Method Lucene.Net Class Library
Sets current position in this file, where the next read will occur.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Seek(
    long pos
)
public abstract void Seek(
    long pos
)
Public MustOverride Sub Seek ( _
    pos As Long _
)
Public MustOverride Sub Seek ( _
    pos As Long _
)
public:
virtual void Seek(
    long long pos
) abstract
public:
virtual void Seek(
    long long pos
) abstract
Parameters
pos
Type:   Online System Int64
See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace
IndexInput FilePointer
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetModifiedUTF8StringsMode Method

IndexInput SetModifiedUTF8StringsMode Method Lucene.Net Class Library
Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetModifiedUTF8StringsMode()
public virtual void SetModifiedUTF8StringsMode()
Public Overridable Sub SetModifiedUTF8StringsMode
Public Overridable Sub SetModifiedUTF8StringsMode
public:
virtual void SetModifiedUTF8StringsMode()
public:
virtual void SetModifiedUTF8StringsMode()
See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SkipChars Method

IndexInput SkipChars Method Lucene.Net Class Library
Expert Similar to ReadChars( Char , Int32, Int32) but does not do any conversion operations on the bytes it is reading in. It still has to invoke ReadByte just as ReadChars( Char , Int32, Int32) does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("this method operates on old "modified utf8" encoded strings")]
public virtual void SkipChars(
    int length
)
[ObsoleteAttribute("this method operates on old "modified utf8" encoded strings")]
public virtual void SkipChars(
    int length
)
<ObsoleteAttribute("this method operates on old "modified utf8" encoded strings")> _
Public Overridable Sub SkipChars ( _
    length As Integer _
)
<ObsoleteAttribute("this method operates on old "modified utf8" encoded strings")> _
Public Overridable Sub SkipChars ( _
    length As Integer _
)
public:
[ObsoleteAttribute(L"this method operates on old "modified utf8" encoded strings")]
virtual void SkipChars(
    int length
)
public:
[ObsoleteAttribute(L"this method operates on old "modified utf8" encoded strings")]
virtual void SkipChars(
    int length
)
Parameters
length
Type:   Online System Int32
The number of chars to read

See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexInput Properties

IndexInput Properties Lucene.Net Class Library
The IndexInput type exposes the following members.
Properties
 | Name | Description
Public property | FilePointer | Returns the current position in this file, where the next read will occur.
Back to Top
See Also
IndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilePointer Property

IndexInput FilePointer Property Lucene.Net Class Library
Returns the current position in this file, where the next read will occur.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract long FilePointer { get; }
public abstract long FilePointer { get; }
Public MustOverride ReadOnly Property FilePointer As Long
    Get
Public MustOverride ReadOnly Property FilePointer As Long
    Get
public:
virtual property long long FilePointer {
    long long get () abstract;
}
public:
virtual property long long FilePointer {
    long long get () abstract;
}
See Also
IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace
IndexInput Seek(Int64)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexOutput Class

IndexOutput Class Lucene.Net Class Library
Abstract base class for output to a file in a Directory. A random-access output stream. Used for all Lucene index output operations.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store IndexOutput
Lucene.Net.Store BufferedIndexOutput
Lucene.Net.Store ChecksumIndexOutput
Lucene.Net.Store RAMOutputStream

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class IndexOutput : IDisposable
public abstract class IndexOutput : IDisposable
Public MustInherit Class IndexOutput _
    Implements IDisposable
Public MustInherit Class IndexOutput _
    Implements IDisposable
public ref class IndexOutput abstract : IDisposable
public ref class IndexOutput abstract : IDisposable
See Also
IndexOutput Members
Lucene.Net.Store Namespace
Lucene.Net.Store Directory
Lucene.Net.Store IndexInput
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexOutput Members

IndexOutput Members Lucene.Net Class Library

The IndexOutput type exposes the following members.
Constructors
 | Name | Description
Protected method | IndexOutput | Initializes a new instance of the IndexOutput class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Closes this stream to further operations.
Public method | CopyBytes | Copy numBytes bytes from input to ourself.
Public method | Dispose | Closes this stream to further operations.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the IndexOutput and optionally releases the managed resources
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | Forces any buffered output to be written.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Seek | Sets current position in this file, where the next write will occur.
Public method | SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteByte | Writes a single byte.
Public method | WriteBytes( Byte , Int32) | Writes an array of bytes.
Public method | WriteBytes( Byte , Int32, Int32) | Writes an array of bytes.
Public method | WriteChars( Char , Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes).
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes).
Public method | WriteInt | Writes an int as four bytes.
Public method | WriteLong | Writes a long as eight bytes.
Public method | WriteString | Writes a string.
Public method | WriteStringStringMap |
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Back to Top
Properties
 | Name | Description
Public property | FilePointer | Returns the current position in this file, where the next write will occur.
Public property | Length | The number of bytes in the file.
Back to Top
See Also
IndexOutput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexOutput Constructor

IndexOutput Constructor Lucene.Net Class Library
Initializes a new instance of the IndexOutput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IndexOutput()
protected IndexOutput()
Protected Sub New
Protected Sub New
protected:
IndexOutput()
protected:
IndexOutput()
See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexOutput Methods

IndexOutput Methods Lucene.Net Class Library
The IndexOutput type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Closes this stream to further operations.
Public method | CopyBytes | Copy numBytes bytes from input to ourself.
Public method | Dispose | Closes this stream to further operations.
Protected method | Dispose(Boolean) |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | Forces any buffered output to be written.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Seek | Sets current position in this file, where the next write will occur.
Public method | SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteByte | Writes a single byte.
Public method | WriteBytes( Byte , Int32) | Writes an array of bytes.
Public method | WriteBytes( Byte , Int32, Int32) | Writes an array of bytes.
Public method | WriteChars( Char , Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes).
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes).
Public method | WriteInt | Writes an int as four bytes.
Public method | WriteLong | Writes a long as eight bytes.
Public method | WriteString | Writes a string.
Public method | WriteStringStringMap |
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Back to Top
See Also
IndexOutput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

IndexOutput Close Method Lucene.Net Class Library
Closes this stream to further operations.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Dispose() instead.")]
public void Close()
[ObsoleteAttribute("Use Dispose() instead.")]
public void Close()
<ObsoleteAttribute("Use Dispose() instead.")> _
Public Sub Close
<ObsoleteAttribute("Use Dispose() instead.")> _
Public Sub Close
public:
[ObsoleteAttribute(L"Use Dispose() instead.")]
void Close()
public:
[ObsoleteAttribute(L"Use Dispose() instead.")]
void Close()
See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CopyBytes Method

IndexOutput CopyBytes Method Lucene.Net Class Library
Copy numBytes bytes from input to ourself.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void CopyBytes(
    IndexInput input,
    long numBytes
)
public virtual void CopyBytes(
    IndexInput input,
    long numBytes
)
Public Overridable Sub CopyBytes ( _
    input As IndexInput, _
    numBytes As Long _
)
Public Overridable Sub CopyBytes ( _
    input As IndexInput, _
    numBytes As Long _
)
public:
virtual void CopyBytes(
    IndexInput^ input,
    long long numBytes
)
public:
virtual void CopyBytes(
    IndexInput^ input,
    long long numBytes
)
Parameters
input
Type: Lucene.Net.Store IndexInput
numBytes
Type:   Online System Int64
See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

IndexOutput Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes this stream to further operations.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the IndexOutput and optionally releases the managed resources
Back to Top
See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

IndexOutput Dispose Method Lucene.Net Class Library
Closes this stream to further operations.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
IndexOutput Class
IndexOutput Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

IndexOutput Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the IndexOutput and optionally releases the managed resources

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void Dispose(
    bool disposing
)
protected abstract void Dispose(
    bool disposing
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) abstract
protected:
virtual void Dispose(
    bool disposing
) abstract
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
IndexOutput Class
IndexOutput Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Flush Method

IndexOutput Flush Method Lucene.Net Class Library
Forces any buffered output to be written.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Flush()
public abstract void Flush()
Public MustOverride Sub Flush
Public MustOverride Sub Flush
public:
virtual void Flush() abstract
public:
virtual void Flush() abstract
See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method

IndexOutput Seek Method Lucene.Net Class Library
Sets current position in this file, where the next write will occur.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Seek(
    long pos
)
public abstract void Seek(
    long pos
)
Public MustOverride Sub Seek ( _
    pos As Long _
)
Public MustOverride Sub Seek ( _
    pos As Long _
)
public:
virtual void Seek(
    long long pos
) abstract
public:
virtual void Seek(
    long long pos
) abstract
Parameters
pos
Type:   Online System Int64
See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace
IndexOutput FilePointer
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetLength Method

IndexOutput SetLength Method Lucene.Net Class Library
Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetLength(
    long length
)
public virtual void SetLength(
    long length
)
Public Overridable Sub SetLength ( _
    length As Long _
)
Public Overridable Sub SetLength ( _
    length As Long _
)
public:
virtual void SetLength(
    long long length
)
public:
virtual void SetLength(
    long long length
)
Parameters
length
Type:   Online System Int64
file length

See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace
 can use this to inform the
            underlying IO system to pre-allocate the file to the
            specified size.  If the length is longer than the
            current file length, the bytes added to the file are
            undefined.  Otherwise the file is truncated.

Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteByte Method

IndexOutput WriteByte Method Lucene.Net Class Library
Writes a single byte.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void WriteByte(
    byte b
)
public abstract void WriteByte(
    byte b
)
Public MustOverride Sub WriteByte ( _
    b As Byte _
)
Public MustOverride Sub WriteByte ( _
    b As Byte _
)
public:
virtual void WriteByte(
    unsigned char b
) abstract
public:
virtual void WriteByte(
    unsigned char b
) abstract
Parameters
b
Type:   Online System Byte
See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace
IndexInput ReadByte
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteBytes Method

IndexOutput WriteBytes Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | WriteBytes( Byte , Int32) | Writes an array of bytes.
Public method | WriteBytes( Byte , Int32, Int32) | Writes an array of bytes.
Back to Top
See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteBytes Method (Byte[], Int32)

IndexOutput WriteBytes Method ( Byte , Int32) Lucene.Net Class Library
Writes an array of bytes.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void WriteBytes(
    byte[] b,
    int length
)
public virtual void WriteBytes(
    byte[] b,
    int length
)
Public Overridable Sub WriteBytes ( _
    b As Byte(), _
    length As Integer _
)
Public Overridable Sub WriteBytes ( _
    b As Byte(), _
    length As Integer _
)
public:
virtual void WriteBytes(
    array<unsigned char>^ b,
    int length
)
public:
virtual void WriteBytes(
    array<unsigned char>^ b,
    int length
)
Parameters
b
Type:    Online System Byte
the bytes to write

length
Type:   Online System Int32
the number of bytes to write

See Also
IndexOutput Class
IndexOutput Members
WriteBytes Overload
Lucene.Net.Store Namespace
IndexInput ReadBytes( Byte , Int32, Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteBytes Method (Byte[], Int32, Int32)

IndexOutput WriteBytes Method ( Byte , Int32, Int32) Lucene.Net Class Library
Writes an array of bytes.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void WriteBytes(
    byte[] b,
    int offset,
    int length
)
public abstract void WriteBytes(
    byte[] b,
    int offset,
    int length
)
Public MustOverride Sub WriteBytes ( _
    b As Byte(), _
    offset As Integer, _
    length As Integer _
)
Public MustOverride Sub WriteBytes ( _
    b As Byte(), _
    offset As Integer, _
    length As Integer _
)
public:
virtual void WriteBytes(
    array<unsigned char>^ b,
    int offset,
    int length
) abstract
public:
virtual void WriteBytes(
    array<unsigned char>^ b,
    int offset,
    int length
) abstract
Parameters
b
Type:    Online System Byte
the bytes to write

offset
Type:   Online System Int32
the offset in the byte array

length
Type:   Online System Int32
the number of bytes to write

See Also
IndexOutput Class
IndexOutput Members
WriteBytes Overload
Lucene.Net.Store Namespace
IndexInput ReadBytes( Byte , Int32, Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteChars Method

IndexOutput WriteChars Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | WriteChars( Char , Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes).
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes).
Back to Top
See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteChars Method (Char[], Int32, Int32)

IndexOutput WriteChars Method ( Char , Int32, Int32) Lucene.Net Class Library
Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("-- please pre-convert to utf8 bytes instead or use WriteString")]
public virtual void WriteChars(
    char[] s,
    int start,
    int length
)
[ObsoleteAttribute("-- please pre-convert to utf8 bytes instead or use WriteString")]
public virtual void WriteChars(
    char[] s,
    int start,
    int length
)
<ObsoleteAttribute("-- please pre-convert to utf8 bytes instead or use WriteString")> _
Public Overridable Sub WriteChars ( _
    s As Char(), _
    start As Integer, _
    length As Integer _
)
<ObsoleteAttribute("-- please pre-convert to utf8 bytes instead or use WriteString")> _
Public Overridable Sub WriteChars ( _
    s As Char(), _
    start As Integer, _
    length As Integer _
)
public:
[ObsoleteAttribute(L"-- please pre-convert to utf8 bytes instead or use WriteString")]
virtual void WriteChars(
    array<wchar_t>^ s,
    int start,
    int length
)
public:
[ObsoleteAttribute(L"-- please pre-convert to utf8 bytes instead or use WriteString")]
virtual void WriteChars(
    array<wchar_t>^ s,
    int start,
    int length
)
Parameters
s
Type:    Online System Char
the source of the characters

start
Type:   Online System Int32
the first character in the sequence

length
Type:   Online System Int32
the number of characters in the sequence

See Also
IndexOutput Class
IndexOutput Members
WriteChars Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteChars Method (String, Int32, Int32)

IndexOutput WriteChars Method (String, Int32, Int32) Lucene.Net Class Library
Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("-- please pre-convert to utf8 bytes instead or use WriteString")]
public virtual void WriteChars(
    string s,
    int start,
    int length
)
[ObsoleteAttribute("-- please pre-convert to utf8 bytes instead or use WriteString")]
public virtual void WriteChars(
    string s,
    int start,
    int length
)
<ObsoleteAttribute("-- please pre-convert to utf8 bytes instead or use WriteString")> _
Public Overridable Sub WriteChars ( _
    s As String, _
    start As Integer, _
    length As Integer _
)
<ObsoleteAttribute("-- please pre-convert to utf8 bytes instead or use WriteString")> _
Public Overridable Sub WriteChars ( _
    s As String, _
    start As Integer, _
    length As Integer _
)
public:
[ObsoleteAttribute(L"-- please pre-convert to utf8 bytes instead or use WriteString")]
virtual void WriteChars(
    String^ s,
    int start,
    int length
)
public:
[ObsoleteAttribute(L"-- please pre-convert to utf8 bytes instead or use WriteString")]
virtual void WriteChars(
    String^ s,
    int start,
    int length
)
Parameters
s
Type:   Online System String
the source of the characters

start
Type:   Online System Int32
the first character in the sequence

length
Type:   Online System Int32
the number of characters in the sequence

See Also
IndexOutput Class
IndexOutput Members
WriteChars Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteInt Method

IndexOutput WriteInt Method Lucene.Net Class Library
Writes an int as four bytes.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void WriteInt(
    int i
)
public virtual void WriteInt(
    int i
)
Public Overridable Sub WriteInt ( _
    i As Integer _
)
Public Overridable Sub WriteInt ( _
    i As Integer _
)
public:
virtual void WriteInt(
    int i
)
public:
virtual void WriteInt(
    int i
)
Parameters
i
Type:   Online System Int32
See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace
IndexInput ReadInt
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteLong Method

IndexOutput WriteLong Method Lucene.Net Class Library
Writes a long as eight bytes.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void WriteLong(
    long i
)
public virtual void WriteLong(
    long i
)
Public Overridable Sub WriteLong ( _
    i As Long _
)
Public Overridable Sub WriteLong ( _
    i As Long _
)
public:
virtual void WriteLong(
    long long i
)
public:
virtual void WriteLong(
    long long i
)
Parameters
i
Type:   Online System Int64
See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace
IndexInput ReadLong
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteString Method

IndexOutput WriteString Method Lucene.Net Class Library
Writes a string.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void WriteString(
    string s
)
public virtual void WriteString(
    string s
)
Public Overridable Sub WriteString ( _
    s As String _
)
Public Overridable Sub WriteString ( _
    s As String _
)
public:
virtual void WriteString(
    String^ s
)
public:
virtual void WriteString(
    String^ s
)
Parameters
s
Type:   Online System String
See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace
IndexInput ReadString
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteStringStringMap Method

IndexOutput WriteStringStringMap Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void WriteStringStringMap(
    IDictionary<string, string> map
)
public virtual void WriteStringStringMap(
    IDictionary<string, string> map
)
Public Overridable Sub WriteStringStringMap ( _
    map As IDictionary(Of String, String) _
)
Public Overridable Sub WriteStringStringMap ( _
    map As IDictionary(Of String, String) _
)
public:
virtual void WriteStringStringMap(
    IDictionary<String^, String^>^ map
)
public:
virtual void WriteStringStringMap(
    IDictionary<String^, String^>^ map
)
Parameters
map
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteVInt Method

IndexOutput WriteVInt Method Lucene.Net Class Library
Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void WriteVInt(
    int i
)
public virtual void WriteVInt(
    int i
)
Public Overridable Sub WriteVInt ( _
    i As Integer _
)
Public Overridable Sub WriteVInt ( _
    i As Integer _
)
public:
virtual void WriteVInt(
    int i
)
public:
virtual void WriteVInt(
    int i
)
Parameters
i
Type:   Online System Int32
See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace
IndexInput ReadVInt
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteVLong Method

IndexOutput WriteVLong Method Lucene.Net Class Library
Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void WriteVLong(
    long i
)
public virtual void WriteVLong(
    long i
)
Public Overridable Sub WriteVLong ( _
    i As Long _
)
Public Overridable Sub WriteVLong ( _
    i As Long _
)
public:
virtual void WriteVLong(
    long long i
)
public:
virtual void WriteVLong(
    long long i
)
Parameters
i
Type:   Online System Int64
See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace
IndexInput ReadVLong
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexOutput Properties

IndexOutput Properties Lucene.Net Class Library
The IndexOutput type exposes the following members.
Properties
 | Name | Description
Public property | FilePointer | Returns the current position in this file, where the next write will occur.
Public property | Length | The number of bytes in the file.
Back to Top
See Also
IndexOutput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilePointer Property

IndexOutput FilePointer Property Lucene.Net Class Library
Returns the current position in this file, where the next write will occur.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract long FilePointer { get; }
public abstract long FilePointer { get; }
Public MustOverride ReadOnly Property FilePointer As Long
    Get
Public MustOverride ReadOnly Property FilePointer As Long
    Get
public:
virtual property long long FilePointer {
    long long get () abstract;
}
public:
virtual property long long FilePointer {
    long long get () abstract;
}
See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace
IndexOutput Seek(Int64)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Length Property

IndexOutput Length Property Lucene.Net Class Library
The number of bytes in the file.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract long Length { get; }
public abstract long Length { get; }
Public MustOverride ReadOnly Property Length As Long
    Get
Public MustOverride ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () abstract;
}
public:
virtual property long long Length {
    long long get () abstract;
}
See Also
IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lock Class

Lock Class Lucene.Net Class Library
An interprocess mutex lock.

Typical use might look like:
View Colorized Copy to Clipboard Print
new Lock.With(directory.makeLock("my.lock")) {
public Object doBody() {
<i>... code to execute while locked ...</i>
}
}.run();
new Lock.With(directory.makeLock("my.lock")) {
public Object doBody() {
<i>... code to execute while locked ...</i>
}
}.run();
Inheritance Hierarchy
Online System Object
Lucene.Net.Store Lock

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Lock
public abstract class Lock
Public MustInherit Class Lock
Public MustInherit Class Lock
public ref class Lock abstract
public ref class Lock abstract
See Also
Lock Members
Lucene.Net.Store Namespace
Directory MakeLock(String)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lock Members

Lock Members Lucene.Net Class Library

The Lock type exposes the following members.
Constructors
 | Name | Description
Protected method | Lock | Initializes a new instance of the Lock class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsLocked | Returns true if the resource is currently locked. Note that one must still call Obtain before using the resource.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Obtain | Attempts to obtain exclusive access and immediately return upon success or failure.
Public method | Obtain(Int64) | Attempts to obtain an exclusive lock within amount of time given. Polls once per LOCK_POLL_INTERVAL (currently 1000) milliseconds until lockWaitTimeout is passed.
Public method | Release | Releases exclusive access.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | failureReason | If a lock obtain called, this failureReason may be set with the "root cause" Exception as to why the lock was not obtained.
 | LOCK_OBTAIN_WAIT_FOREVER | Pass this value to Obtain(Int64) to try forever to obtain the lock.
 | LOCK_POLL_INTERVAL | How long Obtain(Int64) waits, in milliseconds, in between attempts to acquire the lock.
Back to Top
See Also
Lock Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lock Constructor

Lock Constructor Lucene.Net Class Library
Initializes a new instance of the Lock class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Lock()
protected Lock()
Protected Sub New
Protected Sub New
protected:
Lock()
protected:
Lock()
See Also
Lock Class
Lock Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lock Fields

Lock Fields Lucene.Net Class Library
The Lock type exposes the following members.
Fields
 | Name | Description
Protected field | failureReason | If a lock obtain called, this failureReason may be set with the "root cause" Exception as to why the lock was not obtained.
 | LOCK_OBTAIN_WAIT_FOREVER | Pass this value to Obtain(Int64) to try forever to obtain the lock.
 | LOCK_POLL_INTERVAL | How long Obtain(Int64) waits, in milliseconds, in between attempts to acquire the lock.
Back to Top
See Also
Lock Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


failureReason Field

Lock failureReason Field Lucene.Net Class Library
If a lock obtain called, this failureReason may be set with the "root cause" Exception as to why the lock was not obtained.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Exception failureReason
protected Exception failureReason
Protected failureReason As Exception
Protected failureReason As Exception
protected:
Exception^ failureReason
protected:
Exception^ failureReason
See Also
Lock Class
Lock Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LOCK_OBTAIN_WAIT_FOREVER Field

Lock LOCK_OBTAIN_WAIT_FOREVER Field Lucene.Net Class Library
Pass this value to Obtain(Int64) to try forever to obtain the lock.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const long LOCK_OBTAIN_WAIT_FOREVER
public const long LOCK_OBTAIN_WAIT_FOREVER
Public Const LOCK_OBTAIN_WAIT_FOREVER As Long
Public Const LOCK_OBTAIN_WAIT_FOREVER As Long
public:
literal long long LOCK_OBTAIN_WAIT_FOREVER
public:
literal long long LOCK_OBTAIN_WAIT_FOREVER
See Also
Lock Class
Lock Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LOCK_POLL_INTERVAL Field

Lock LOCK_POLL_INTERVAL Field Lucene.Net Class Library
How long Obtain(Int64) waits, in milliseconds, in between attempts to acquire the lock.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long LOCK_POLL_INTERVAL
public static long LOCK_POLL_INTERVAL
Public Shared LOCK_POLL_INTERVAL As Long
Public Shared LOCK_POLL_INTERVAL As Long
public:
static long long LOCK_POLL_INTERVAL
public:
static long long LOCK_POLL_INTERVAL
See Also
Lock Class
Lock Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lock Methods

Lock Methods Lucene.Net Class Library
The Lock type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsLocked | Returns true if the resource is currently locked. Note that one must still call Obtain before using the resource.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Obtain | Attempts to obtain exclusive access and immediately return upon success or failure.
Public method | Obtain(Int64) | Attempts to obtain an exclusive lock within amount of time given. Polls once per LOCK_POLL_INTERVAL (currently 1000) milliseconds until lockWaitTimeout is passed.
Public method | Release | Releases exclusive access.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Lock Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsLocked Method

Lock IsLocked Method Lucene.Net Class Library
Returns true if the resource is currently locked. Note that one must still call Obtain before using the resource.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool IsLocked()
public abstract bool IsLocked()
Public MustOverride Function IsLocked As Boolean
Public MustOverride Function IsLocked As Boolean
public:
virtual bool IsLocked() abstract
public:
virtual bool IsLocked() abstract
See Also
Lock Class
Lock Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Obtain Method

Lock Obtain Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Obtain | Attempts to obtain exclusive access and immediately return upon success or failure.
Public method | Obtain(Int64) | Attempts to obtain an exclusive lock within amount of time given. Polls once per LOCK_POLL_INTERVAL (currently 1000) milliseconds until lockWaitTimeout is passed.
Back to Top
See Also
Lock Class
Lock Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Obtain Method

Lock Obtain Method Lucene.Net Class Library
Attempts to obtain exclusive access and immediately return upon success or failure.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool Obtain()
public abstract bool Obtain()
Public MustOverride Function Obtain As Boolean
Public MustOverride Function Obtain As Boolean
public:
virtual bool Obtain() abstract
public:
virtual bool Obtain() abstract
Return Value
 true iff exclusive access is obtained

See Also
Lock Class
Lock Members
Obtain Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Obtain Method (Int64)

Lock Obtain Method (Int64) Lucene.Net Class Library
Attempts to obtain an exclusive lock within amount of time given. Polls once per LOCK_POLL_INTERVAL (currently 1000) milliseconds until lockWaitTimeout is passed.
out of bounds

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Obtain(
    long lockWaitTimeout
)
public virtual bool Obtain(
    long lockWaitTimeout
)
Public Overridable Function Obtain ( _
    lockWaitTimeout As Long _
) As Boolean
Public Overridable Function Obtain ( _
    lockWaitTimeout As Long _
) As Boolean
public:
virtual bool Obtain(
    long long lockWaitTimeout
)
public:
virtual bool Obtain(
    long long lockWaitTimeout
)
Parameters
lockWaitTimeout
Type:   Online System Int64
length of time to wait in
            milliseconds or LOCK_OBTAIN_WAIT_FOREVER
            to retry forever

Return Value
 true if lock was obtained

See Also
Lock Class
Lock Members
Obtain Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Release Method

Lock Release Method Lucene.Net Class Library
Releases exclusive access.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Release()
public abstract void Release()
Public MustOverride Sub Release
Public MustOverride Sub Release
public:
virtual void Release() abstract
public:
virtual void Release() abstract
See Also
Lock Class
Lock Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lock.With Class

Lock With Class Lucene.Net Class Library
Utility class for executing code with exclusive access.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store Lock With

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class With
public abstract class With
Public MustInherit Class With
Public MustInherit Class With
public ref class With abstract
public ref class With abstract
See Also
Lock With Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lock.With Members

Lock With Members Lucene.Net Class Library

An interprocess mutex lock.

Typical use might look like:
View Colorized Copy to Clipboard Print
new Lock.With(directory.makeLock("my.lock")) {
public Object doBody() {
<i>... code to execute while locked ...</i>
}
}.run();
new Lock.With(directory.makeLock("my.lock")) {
public Object doBody() {
<i>... code to execute while locked ...</i>
}
}.run();

The Lock With type exposes the following members.
Constructors
 | Name | Description
Protected method | Lock With | Constructs an executor that will grab the named lock.
Back to Top
Methods
 | Name | Description
Protected method | DoBody | Code to execute with exclusive access.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | run | Calls DoBody while lock is obtained. Blocks if lock cannot be obtained immediately. Retries to obtain lock once per second until it is obtained, or until it has tried ten times. Lock is released when DoBody exits.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Lock With Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lock.With Constructor

Lock With Constructor Lucene.Net Class Library
Constructs an executor that will grab the named lock.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected With(
    Lock lock_Renamed,
    long lockWaitTimeout
)
protected With(
    Lock lock_Renamed,
    long lockWaitTimeout
)
Protected Sub New ( _
    lock_Renamed As Lock, _
    lockWaitTimeout As Long _
)
Protected Sub New ( _
    lock_Renamed As Lock, _
    lockWaitTimeout As Long _
)
protected:
With(
    Lock^ lock_Renamed,
    long long lockWaitTimeout
)
protected:
With(
    Lock^ lock_Renamed,
    long long lockWaitTimeout
)
Parameters
lock_Renamed
Type: Lucene.Net.Store Lock
lockWaitTimeout
Type:   Online System Int64
See Also
Lock With Class
Lock With Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lock.With Methods

Lock With Methods Lucene.Net Class Library
The Lock With type exposes the following members.
Methods
 | Name | Description
Protected method | DoBody | Code to execute with exclusive access.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | run | Calls DoBody while lock is obtained. Blocks if lock cannot be obtained immediately. Retries to obtain lock once per second until it is obtained, or until it has tried ten times. Lock is released when DoBody exits.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Lock With Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoBody Method

Lock With DoBody Method Lucene.Net Class Library
Code to execute with exclusive access.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract Object DoBody()
protected abstract Object DoBody()
Protected MustOverride Function DoBody As Object
Protected MustOverride Function DoBody As Object
protected:
virtual Object^ DoBody() abstract
protected:
virtual Object^ DoBody() abstract
See Also
Lock With Class
Lock With Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


run Method

Lock With run Method Lucene.Net Class Library
Calls DoBody while lock is obtained. Blocks if lock cannot be obtained immediately. Retries to obtain lock once per second until it is obtained, or until it has tried ten times. Lock is released when DoBody exits.
be obtained

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object run()
public virtual Object run()
Public Overridable Function run As Object
Public Overridable Function run As Object
public:
virtual Object^ run()
public:
virtual Object^ run()
See Also
Lock With Class
Lock With Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockFactory Class

LockFactory Class Lucene.Net Class Library

Base class for Locking implementation. Directory uses instances of this class to implement locking.

Note that there are some useful tools to verify that your LockFactory is working correctly: VerifyingLockFactory , LockStressTest, LockVerifyServer .

Inheritance Hierarchy
Online System Object
Lucene.Net.Store LockFactory
Lucene.Net.Store FSLockFactory
Lucene.Net.Store NoLockFactory
Lucene.Net.Store SingleInstanceLockFactory
Lucene.Net.Store VerifyingLockFactory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class LockFactory
public abstract class LockFactory
Public MustInherit Class LockFactory
Public MustInherit Class LockFactory
public ref class LockFactory abstract
public ref class LockFactory abstract
See Also
LockFactory Members
Lucene.Net.Store Namespace
Lucene.Net.Store LockVerifyServer
Lucene.Net.Store LockStressTest
Lucene.Net.Store VerifyingLockFactory
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockFactory Members

LockFactory Members Lucene.Net Class Library

The LockFactory type exposes the following members.
Constructors
 | Name | Description
Protected method | LockFactory | Initializes a new instance of the LockFactory class
Back to Top
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLock | Return a new Lock instance identified by lockName.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | internalLockPrefix |
Back to Top
Properties
 | Name | Description
Public property | LockPrefix | Gets or sets the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.
Back to Top
See Also
LockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockFactory Constructor

LockFactory Constructor Lucene.Net Class Library
Initializes a new instance of the LockFactory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LockFactory()
protected LockFactory()
Protected Sub New
Protected Sub New
protected:
LockFactory()
protected:
LockFactory()
See Also
LockFactory Class
LockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockFactory Fields

LockFactory Fields Lucene.Net Class Library
The LockFactory type exposes the following members.
Fields
 | Name | Description
Protected field | internalLockPrefix |
Back to Top
See Also
LockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalLockPrefix Field

LockFactory internalLockPrefix Field Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string internalLockPrefix
protected string internalLockPrefix
Protected internalLockPrefix As String
Protected internalLockPrefix As String
protected:
String^ internalLockPrefix
protected:
String^ internalLockPrefix
See Also
LockFactory Class
LockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockFactory Methods

LockFactory Methods Lucene.Net Class Library
The LockFactory type exposes the following members.
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLock | Return a new Lock instance identified by lockName.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ClearLock Method

LockFactory ClearLock Method Lucene.Net Class Library
Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void ClearLock(
    string lockName
)
public abstract void ClearLock(
    string lockName
)
Public MustOverride Sub ClearLock ( _
    lockName As String _
)
Public MustOverride Sub ClearLock ( _
    lockName As String _
)
public:
virtual void ClearLock(
    String^ lockName
) abstract
public:
virtual void ClearLock(
    String^ lockName
) abstract
Parameters
lockName
Type:   Online System String
name of the lock to be cleared.

See Also
LockFactory Class
LockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MakeLock Method

LockFactory MakeLock Method Lucene.Net Class Library
Return a new Lock instance identified by lockName.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Lock MakeLock(
    string lockName
)
public abstract Lock MakeLock(
    string lockName
)
Public MustOverride Function MakeLock ( _
    lockName As String _
) As Lock
Public MustOverride Function MakeLock ( _
    lockName As String _
) As Lock
public:
virtual Lock^ MakeLock(
    String^ lockName
) abstract
public:
virtual Lock^ MakeLock(
    String^ lockName
) abstract
Parameters
lockName
Type:   Online System String
name of the lock to be created.

See Also
LockFactory Class
LockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockFactory Properties

LockFactory Properties Lucene.Net Class Library
The LockFactory type exposes the following members.
Properties
 | Name | Description
Public property | LockPrefix | Gets or sets the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.
Back to Top
See Also
LockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockPrefix Property

LockFactory LockPrefix Property Lucene.Net Class Library
Gets or sets the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string LockPrefix { get; set; }
public virtual string LockPrefix { get; set; }
Public Overridable Property LockPrefix As String
    Get
    Set
Public Overridable Property LockPrefix As String
    Get
    Set
public:
virtual property String^ LockPrefix {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ LockPrefix {
    String^ get ();
    void set (String^ value);
}
See Also
LockFactory Class
LockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockObtainFailedException Class

LockObtainFailedException Class Lucene.Net Class Library
This exception is thrown when the write.lock could not be acquired. This happens when a writer tries to open an index that another writer already has open.
Inheritance Hierarchy
Online System Object
Online System Exception
Online System SystemException
Online System.IO IOException
Lucene.Net.Store LockObtainFailedException

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class LockObtainFailedException : IOException
[SerializableAttribute]
public class LockObtainFailedException : IOException
<SerializableAttribute> _
Public Class LockObtainFailedException _
    Inherits IOException
<SerializableAttribute> _
Public Class LockObtainFailedException _
    Inherits IOException
[SerializableAttribute]
public ref class LockObtainFailedException : public IOException
[SerializableAttribute]
public ref class LockObtainFailedException : public IOException
See Also
LockObtainFailedException Members
Lucene.Net.Store Namespace
Lock Obtain(Int64)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockObtainFailedException Members

LockObtainFailedException Members Lucene.Net Class Library

The LockObtainFailedException type exposes the following members.
Constructors
 | Name | Description
Public method | LockObtainFailedException(String) | Initializes a new instance of the LockObtainFailedException class
Public method | LockObtainFailedException(String, Exception) | Initializes a new instance of the LockObtainFailedException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
LockObtainFailedException Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockObtainFailedException Constructor

LockObtainFailedException Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | LockObtainFailedException(String) | Initializes a new instance of the LockObtainFailedException class
Public method | LockObtainFailedException(String, Exception) | Initializes a new instance of the LockObtainFailedException class
Back to Top
See Also
LockObtainFailedException Class
LockObtainFailedException Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockObtainFailedException Constructor (String)

LockObtainFailedException Constructor (String) Lucene.Net Class Library
Initializes a new instance of the LockObtainFailedException class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LockObtainFailedException(
    string message
)
public LockObtainFailedException(
    string message
)
Public Sub New ( _
    message As String _
)
Public Sub New ( _
    message As String _
)
public:
LockObtainFailedException(
    String^ message
)
public:
LockObtainFailedException(
    String^ message
)
Parameters
message
Type:   Online System String
See Also
LockObtainFailedException Class
LockObtainFailedException Members
LockObtainFailedException Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockObtainFailedException Constructor (String, Exception)

LockObtainFailedException Constructor (String, Exception) Lucene.Net Class Library
Initializes a new instance of the LockObtainFailedException class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LockObtainFailedException(
    string message,
    Exception ex
)
public LockObtainFailedException(
    string message,
    Exception ex
)
Public Sub New ( _
    message As String, _
    ex As Exception _
)
Public Sub New ( _
    message As String, _
    ex As Exception _
)
public:
LockObtainFailedException(
    String^ message,
    Exception^ ex
)
public:
LockObtainFailedException(
    String^ message,
    Exception^ ex
)
Parameters
message
Type:   Online System String
ex
Type:   Online System Exception
See Also
LockObtainFailedException Class
LockObtainFailedException Members
LockObtainFailedException Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockObtainFailedException Methods

LockObtainFailedException Methods Lucene.Net Class Library
The LockObtainFailedException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
LockObtainFailedException Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockObtainFailedException Properties

LockObtainFailedException Properties Lucene.Net Class Library
The LockObtainFailedException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
LockObtainFailedException Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockObtainFailedException Events

LockObtainFailedException Events Lucene.Net Class Library
The LockObtainFailedException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
LockObtainFailedException Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockReleaseFailedException Class

LockReleaseFailedException Class Lucene.Net Class Library
This exception is thrown when the write.lock could not be released.
Inheritance Hierarchy
Online System Object
Online System Exception
Online System SystemException
Online System.IO IOException
Lucene.Net.Store LockReleaseFailedException

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class LockReleaseFailedException : IOException
[SerializableAttribute]
public class LockReleaseFailedException : IOException
<SerializableAttribute> _
Public Class LockReleaseFailedException _
    Inherits IOException
<SerializableAttribute> _
Public Class LockReleaseFailedException _
    Inherits IOException
[SerializableAttribute]
public ref class LockReleaseFailedException : public IOException
[SerializableAttribute]
public ref class LockReleaseFailedException : public IOException
See Also
LockReleaseFailedException Members
Lucene.Net.Store Namespace
Lock Release
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockReleaseFailedException Members

LockReleaseFailedException Members Lucene.Net Class Library

The LockReleaseFailedException type exposes the following members.
Constructors
 | Name | Description
Public method | LockReleaseFailedException | Initializes a new instance of the LockReleaseFailedException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
LockReleaseFailedException Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockReleaseFailedException Constructor

LockReleaseFailedException Constructor Lucene.Net Class Library
Initializes a new instance of the LockReleaseFailedException class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LockReleaseFailedException(
    string message
)
public LockReleaseFailedException(
    string message
)
Public Sub New ( _
    message As String _
)
Public Sub New ( _
    message As String _
)
public:
LockReleaseFailedException(
    String^ message
)
public:
LockReleaseFailedException(
    String^ message
)
Parameters
message
Type:   Online System String
See Also
LockReleaseFailedException Class
LockReleaseFailedException Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockReleaseFailedException Methods

LockReleaseFailedException Methods Lucene.Net Class Library
The LockReleaseFailedException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
LockReleaseFailedException Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockReleaseFailedException Properties

LockReleaseFailedException Properties Lucene.Net Class Library
The LockReleaseFailedException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
LockReleaseFailedException Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockReleaseFailedException Events

LockReleaseFailedException Events Lucene.Net Class Library
The LockReleaseFailedException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
LockReleaseFailedException Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockStressTest Class

LockStressTest Class Lucene.Net Class Library
Simple standalone tool that forever acquires & releases a lock using a specific LockFactory. Run without any args to see usage.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store LockStressTest

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LockStressTest
public class LockStressTest
Public Class LockStressTest
Public Class LockStressTest
public ref class LockStressTest
public ref class LockStressTest
See Also
LockStressTest Members
Lucene.Net.Store Namespace
Lucene.Net.Store VerifyingLockFactory
Lucene.Net.Store LockVerifyServer
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockStressTest Members

LockStressTest Members Lucene.Net Class Library

The LockStressTest type exposes the following members.
Constructors
 | Name | Description
Public method | LockStressTest | Initializes a new instance of the LockStressTest class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Main |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LockStressTest Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockStressTest Constructor

LockStressTest Constructor Lucene.Net Class Library
Initializes a new instance of the LockStressTest class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LockStressTest()
public LockStressTest()
Public Sub New
Public Sub New
public:
LockStressTest()
public:
LockStressTest()
See Also
LockStressTest Class
LockStressTest Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockStressTest Methods

LockStressTest Methods Lucene.Net Class Library
The LockStressTest type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Main |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LockStressTest Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Main Method

LockStressTest Main Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[STAThreadAttribute]
public static void Main(
    string[] args
)
[STAThreadAttribute]
public static void Main(
    string[] args
)
<STAThreadAttribute> _
Public Shared Sub Main ( _
    args As String() _
)
<STAThreadAttribute> _
Public Shared Sub Main ( _
    args As String() _
)
public:
[STAThreadAttribute]
static void Main(
    array<String^>^ args
)
public:
[STAThreadAttribute]
static void Main(
    array<String^>^ args
)
Parameters
args
Type:    Online System String
See Also
LockStressTest Class
LockStressTest Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockVerifyServer Class

LockVerifyServer Class Lucene.Net Class Library
Simple standalone server that must be running when you use VerifyingLockFactory. This server simply verifies at most one process holds the lock at a time. Run without any args to see usage.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store LockVerifyServer

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LockVerifyServer
public class LockVerifyServer
Public Class LockVerifyServer
Public Class LockVerifyServer
public ref class LockVerifyServer
public ref class LockVerifyServer
See Also
LockVerifyServer Members
Lucene.Net.Store Namespace
Lucene.Net.Store VerifyingLockFactory
Lucene.Net.Store LockStressTest
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockVerifyServer Members

LockVerifyServer Members Lucene.Net Class Library

The LockVerifyServer type exposes the following members.
Constructors
 | Name | Description
Public method | LockVerifyServer | Initializes a new instance of the LockVerifyServer class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Main |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LockVerifyServer Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockVerifyServer Constructor

LockVerifyServer Constructor Lucene.Net Class Library
Initializes a new instance of the LockVerifyServer class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LockVerifyServer()
public LockVerifyServer()
Public Sub New
Public Sub New
public:
LockVerifyServer()
public:
LockVerifyServer()
See Also
LockVerifyServer Class
LockVerifyServer Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LockVerifyServer Methods

LockVerifyServer Methods Lucene.Net Class Library
The LockVerifyServer type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Main |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
LockVerifyServer Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Main Method

LockVerifyServer Main Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[STAThreadAttribute]
public static void Main(
    string[] args
)
[STAThreadAttribute]
public static void Main(
    string[] args
)
<STAThreadAttribute> _
Public Shared Sub Main ( _
    args As String() _
)
<STAThreadAttribute> _
Public Shared Sub Main ( _
    args As String() _
)
public:
[STAThreadAttribute]
static void Main(
    array<String^>^ args
)
public:
[STAThreadAttribute]
static void Main(
    array<String^>^ args
)
Parameters
args
Type:    Online System String
See Also
LockVerifyServer Class
LockVerifyServer Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MMapDirectory Class

MMapDirectory Class Lucene.Net Class Library
File-based Directory implementation that uses mmap for reading, and SimpleFSDirectory SimpleFSIndexOutput for writing.

NOTE: memory mapping uses up a portion of the virtual memory address space in your process equal to the size of the file being mapped. Before using this class, be sure your have plenty of virtual address space, e.g. by using a 64 bit JRE, or a 32 bit JRE with indexes that are guaranteed to fit within the address space. On 32 bit platforms also consult MaxChunkSize if you have problems with mmap failing because of fragmented address space. If you get an OutOfMemoryException, it is recommened to reduce the chunk size, until it works.

Due to Online this bug in Sun's JRE, MMapDirectory's Close is unable to close the underlying OS file handle. Only when GC finally collects the underlying objects, which could be quite some time later, will the file handle be closed.

This will consume additional transient disk usage: on Windows, attempts to delete or overwrite the files will result in an exception; on other platforms, which typically have a "delete on last close" semantics, while such operations will succeed, the bytes are still consuming space on disk. For many applications this limitation is not a problem (e.g. if you have plenty of disk space, and you don't rely on overwriting files on Windows) but it's still an important limitation to be aware of.

This class supplies the workaround mentioned in the bug report (disabled by default, see UseUnmap), which may fail on non-Sun JVMs. It forcefully unmaps the buffer on close by using an undocumented internal cleanup functionality. UNMAP_SUPPORTED is true, if the workaround can be enabled (with no guarantees).
Inheritance Hierarchy
Online System Object
Lucene.Net.Store Directory
Lucene.Net.Store FSDirectory
Lucene.Net.Store MMapDirectory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MMapDirectory : FSDirectory
public class MMapDirectory : FSDirectory
Public Class MMapDirectory _
    Inherits FSDirectory
Public Class MMapDirectory _
    Inherits FSDirectory
public ref class MMapDirectory : public FSDirectory
public ref class MMapDirectory : public FSDirectory
See Also
MMapDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MMapDirectory Members

MMapDirectory Members Lucene.Net Class Library

The MMapDirectory type exposes the following members.
Constructors
 | Name | Description
Public method | MMapDirectory(DirectoryInfo) | Create a new MMapDirectory for the named location and the default lock factory.
Public method | MMapDirectory(DirectoryInfo, LockFactory) | Create a new MMapDirectory for the named location.
Back to Top
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Obsolete. (Inherited from Directory.)
Public method | CreateOutput | Creates an IndexOutput for the file with the given name. (Overrides Directory CreateOutput(String).)
Public method | DeleteFile | Removes an existing file in the directory. (Inherited from FSDirectory.)
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | (Inherited from FSDirectory.)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Inherited from FSDirectory.)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Inherited from FSDirectory.)
Public method | FileModified(String) | Returns the time the named file was last modified. (Inherited from FSDirectory.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLockId | (Inherited from FSDirectory.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InitOutput | Initializes the directory to create a new file with the given name. This method should be used in CreateOutput(String). (Inherited from FSDirectory.)
Public method | ListAll | Lists all files (not subdirectories) in the directory. (Inherited from FSDirectory.)
Public method | MakeLock | Construct a Lock. (Inherited from Directory.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenInput(String) | (Inherited from FSDirectory.)
Public method | OpenInput(String, Int32) | Creates an IndexInput for the file with the given name. (Overrides Directory OpenInput(String, Int32).)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | Sync | (Inherited from FSDirectory.)
Public method | ToString | For debug output. (Inherited from FSDirectory.)
Public method | TouchFile | Set the modified time of an existing file to now. (Inherited from FSDirectory.)
Back to Top
Fields
 | Name | Description
Protected field | interalLockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)
Protected field | internalDirectory | The underlying filesystem directory (Inherited from FSDirectory.)
Protected field | isOpen | (Inherited from Directory.)
 | UNMAP_SUPPORTED | true, if this platform supports unmapping mmaped files.
Back to Top
Properties
 | Name | Description
Public property | Directory | (Inherited from FSDirectory.)
Public property | isOpen_ForNUnit | (Inherited from Directory.)
Public property | LockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public property | MaxChunkSize | Gets or sets the maximum chunk size (default is Online MaxValue for 64 bit JVMs and 256 MiBytes for 32 bit JVMs) used for memory mapping. Especially on 32 bit platform, the address space can be very fragmented, so large index files cannot be mapped. Using a lower chunk size makes the directory implementation a little bit slower (as the correct chunk must be resolved on each seek) but the chance is higher that mmap does not fail. On 64 bit Java platforms, this parameter should always be Online MaxValue, as the adress space is big enough.
Public property | ReadChunkSize | The maximum number of bytes to read at once from the underlying file during ReadBytes( Byte , Int32, Int32). (Inherited from FSDirectory.)
Public property | UseUnmap | Enables or disables the workaround for unmapping the buffers from address space after closing IndexInput, that is mentioned in the bug report. This hack may fail on non-Sun JVMs. It forcefully unmaps the buffer on close by using an undocumented internal cleanup functionality. NOTE: Enabling this is completely unsupported by Java and may lead to JVM crashs if IndexInput is closed while another thread is still accessing it (SIGSEGV).
Back to Top
See Also
MMapDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MMapDirectory Constructor

MMapDirectory Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | MMapDirectory(DirectoryInfo) | Create a new MMapDirectory for the named location and the default lock factory.
Public method | MMapDirectory(DirectoryInfo, LockFactory) | Create a new MMapDirectory for the named location.
Back to Top
See Also
MMapDirectory Class
MMapDirectory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MMapDirectory Constructor (DirectoryInfo)

MMapDirectory Constructor (DirectoryInfo) Lucene.Net Class Library
Create a new MMapDirectory for the named location and the default lock factory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MMapDirectory(
    DirectoryInfo path
)
public MMapDirectory(
    DirectoryInfo path
)
Public Sub New ( _
    path As DirectoryInfo _
)
Public Sub New ( _
    path As DirectoryInfo _
)
public:
MMapDirectory(
    DirectoryInfo^ path
)
public:
MMapDirectory(
    DirectoryInfo^ path
)
Parameters
path
Type:   Online System.IO DirectoryInfo
the path of the directory

See Also
MMapDirectory Class
MMapDirectory Members
MMapDirectory Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MMapDirectory Constructor (DirectoryInfo, LockFactory)

MMapDirectory Constructor (DirectoryInfo, LockFactory) Lucene.Net Class Library
Create a new MMapDirectory for the named location.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MMapDirectory(
    DirectoryInfo path,
    LockFactory lockFactory
)
public MMapDirectory(
    DirectoryInfo path,
    LockFactory lockFactory
)
Public Sub New ( _
    path As DirectoryInfo, _
    lockFactory As LockFactory _
)
Public Sub New ( _
    path As DirectoryInfo, _
    lockFactory As LockFactory _
)
public:
MMapDirectory(
    DirectoryInfo^ path,
    LockFactory^ lockFactory
)
public:
MMapDirectory(
    DirectoryInfo^ path,
    LockFactory^ lockFactory
)
Parameters
path
Type:   Online System.IO DirectoryInfo
the path of the directory

lockFactory
Type: Lucene.Net.Store LockFactory
the lock factory to use, or null for the default.

See Also
MMapDirectory Class
MMapDirectory Members
MMapDirectory Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MMapDirectory Fields

MMapDirectory Fields Lucene.Net Class Library
The MMapDirectory type exposes the following members.
Fields
 | Name | Description
Protected field | interalLockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)
Protected field | internalDirectory | The underlying filesystem directory (Inherited from FSDirectory.)
Protected field | isOpen | (Inherited from Directory.)
 | UNMAP_SUPPORTED | true, if this platform supports unmapping mmaped files.
Back to Top
See Also
MMapDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UNMAP_SUPPORTED Field

MMapDirectory UNMAP_SUPPORTED Field Lucene.Net Class Library
true, if this platform supports unmapping mmaped files.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool UNMAP_SUPPORTED
public static bool UNMAP_SUPPORTED
Public Shared UNMAP_SUPPORTED As Boolean
Public Shared UNMAP_SUPPORTED As Boolean
public:
static bool UNMAP_SUPPORTED
public:
static bool UNMAP_SUPPORTED
See Also
MMapDirectory Class
MMapDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MMapDirectory Methods

MMapDirectory Methods Lucene.Net Class Library
The MMapDirectory type exposes the following members.
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Obsolete. (Inherited from Directory.)
Public method | CreateOutput | Creates an IndexOutput for the file with the given name. (Overrides Directory CreateOutput(String).)
Public method | DeleteFile | Removes an existing file in the directory. (Inherited from FSDirectory.)
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | (Inherited from FSDirectory.)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Inherited from FSDirectory.)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Inherited from FSDirectory.)
Public method | FileModified(String) | Returns the time the named file was last modified. (Inherited from FSDirectory.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLockId | (Inherited from FSDirectory.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InitOutput | Initializes the directory to create a new file with the given name. This method should be used in CreateOutput(String). (Inherited from FSDirectory.)
Public method | ListAll | Lists all files (not subdirectories) in the directory. (Inherited from FSDirectory.)
Public method | MakeLock | Construct a Lock. (Inherited from Directory.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenInput(String) | (Inherited from FSDirectory.)
Public method | OpenInput(String, Int32) | Creates an IndexInput for the file with the given name. (Overrides Directory OpenInput(String, Int32).)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | Sync | (Inherited from FSDirectory.)
Public method | ToString | For debug output. (Inherited from FSDirectory.)
Public method | TouchFile | Set the modified time of an existing file to now. (Inherited from FSDirectory.)
Back to Top
See Also
MMapDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateOutput Method

MMapDirectory CreateOutput Method Lucene.Net Class Library
Creates an IndexOutput for the file with the given name.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexOutput CreateOutput(
    string name
)
public override IndexOutput CreateOutput(
    string name
)
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
MMapDirectory Class
MMapDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenInput Method

MMapDirectory OpenInput Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | OpenInput(String) | (Inherited from FSDirectory.)
Public method | OpenInput(String, Int32) | Creates an IndexInput for the file with the given name. (Overrides Directory OpenInput(String, Int32).)
Back to Top
See Also
MMapDirectory Class
MMapDirectory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenInput Method (String, Int32)

MMapDirectory OpenInput Method (String, Int32) Lucene.Net Class Library
Creates an IndexInput for the file with the given name.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexInput OpenInput(
    string name,
    int bufferSize
)
public override IndexInput OpenInput(
    string name,
    int bufferSize
)
Public Overrides Function OpenInput ( _
    name As String, _
    bufferSize As Integer _
) As IndexInput
Public Overrides Function OpenInput ( _
    name As String, _
    bufferSize As Integer _
) As IndexInput
public:
virtual IndexInput^ OpenInput(
    String^ name,
    int bufferSize
) override
public:
virtual IndexInput^ OpenInput(
    String^ name,
    int bufferSize
) override
Parameters
name
Type:   Online System String
bufferSize
Type:   Online System Int32
See Also
MMapDirectory Class
MMapDirectory Members
OpenInput Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MMapDirectory Properties

MMapDirectory Properties Lucene.Net Class Library
The MMapDirectory type exposes the following members.
Properties
 | Name | Description
Public property | Directory | (Inherited from FSDirectory.)
Public property | isOpen_ForNUnit | (Inherited from Directory.)
Public property | LockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public property | MaxChunkSize | Gets or sets the maximum chunk size (default is Online MaxValue for 64 bit JVMs and 256 MiBytes for 32 bit JVMs) used for memory mapping. Especially on 32 bit platform, the address space can be very fragmented, so large index files cannot be mapped. Using a lower chunk size makes the directory implementation a little bit slower (as the correct chunk must be resolved on each seek) but the chance is higher that mmap does not fail. On 64 bit Java platforms, this parameter should always be Online MaxValue, as the adress space is big enough.
Public property | ReadChunkSize | The maximum number of bytes to read at once from the underlying file during ReadBytes( Byte , Int32, Int32). (Inherited from FSDirectory.)
Public property | UseUnmap | Enables or disables the workaround for unmapping the buffers from address space after closing IndexInput, that is mentioned in the bug report. This hack may fail on non-Sun JVMs. It forcefully unmaps the buffer on close by using an undocumented internal cleanup functionality. NOTE: Enabling this is completely unsupported by Java and may lead to JVM crashs if IndexInput is closed while another thread is still accessing it (SIGSEGV).
Back to Top
See Also
MMapDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MaxChunkSize Property

MMapDirectory MaxChunkSize Property Lucene.Net Class Library
Gets or sets the maximum chunk size (default is Online MaxValue for 64 bit JVMs and 256 MiBytes for 32 bit JVMs) used for memory mapping. Especially on 32 bit platform, the address space can be very fragmented, so large index files cannot be mapped. Using a lower chunk size makes the directory implementation a little bit slower (as the correct chunk must be resolved on each seek) but the chance is higher that mmap does not fail. On 64 bit Java platforms, this parameter should always be Online MaxValue, as the adress space is big enough.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int MaxChunkSize { get; set; }
public virtual int MaxChunkSize { get; set; }
Public Overridable Property MaxChunkSize As Integer
    Get
    Set
Public Overridable Property MaxChunkSize As Integer
    Get
    Set
public:
virtual property int MaxChunkSize {
    int get ();
    void set (int value);
}
public:
virtual property int MaxChunkSize {
    int get ();
    void set (int value);
}
See Also
MMapDirectory Class
MMapDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UseUnmap Property

MMapDirectory UseUnmap Property Lucene.Net Class Library
Enables or disables the workaround for unmapping the buffers from address space after closing IndexInput, that is mentioned in the bug report. This hack may fail on non-Sun JVMs. It forcefully unmaps the buffer on close by using an undocumented internal cleanup functionality.

NOTE: Enabling this is completely unsupported by Java and may lead to JVM crashs if IndexInput is closed while another thread is still accessing it (SIGSEGV).
is false and the workaround cannot be enabled.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool UseUnmap { get; set; }
public virtual bool UseUnmap { get; set; }
Public Overridable Property UseUnmap As Boolean
    Get
    Set
Public Overridable Property UseUnmap As Boolean
    Get
    Set
public:
virtual property bool UseUnmap {
    bool get ();
    void set (bool value);
}
public:
virtual property bool UseUnmap {
    bool get ();
    void set (bool value);
}
See Also
MMapDirectory Class
MMapDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MMapDirectory.MultiMMapIndexInput Class

MMapDirectory MultiMMapIndexInput Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Store IndexInput
Lucene.Net.Store MMapDirectory MultiMMapIndexInput

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal class MultiMMapIndexInput : IndexInput,
    ICloneable
protected internal class MultiMMapIndexInput : IndexInput,
    ICloneable
Protected Friend Class MultiMMapIndexInput _
    Inherits IndexInput _
    Implements ICloneable
Protected Friend Class MultiMMapIndexInput _
    Inherits IndexInput _
    Implements ICloneable
protected public ref class MultiMMapIndexInput : public IndexInput,
    ICloneable
protected public ref class MultiMMapIndexInput : public IndexInput,
    ICloneable
See Also
MMapDirectory MultiMMapIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MMapDirectory.MultiMMapIndexInput Members

MMapDirectory MultiMMapIndexInput Members Lucene.Net Class Library

File-based Directory implementation that uses mmap for reading, and SimpleFSDirectory SimpleFSIndexOutput for writing.

NOTE: memory mapping uses up a portion of the virtual memory address space in your process equal to the size of the file being mapped. Before using this class, be sure your have plenty of virtual address space, e.g. by using a 64 bit JRE, or a 32 bit JRE with indexes that are guaranteed to fit within the address space. On 32 bit platforms also consult MaxChunkSize if you have problems with mmap failing because of fragmented address space. If you get an OutOfMemoryException, it is recommened to reduce the chunk size, until it works.

Due to Online this bug in Sun's JRE, MMapDirectory's Close is unable to close the underlying OS file handle. Only when GC finally collects the underlying objects, which could be quite some time later, will the file handle be closed.

This will consume additional transient disk usage: on Windows, attempts to delete or overwrite the files will result in an exception; on other platforms, which typically have a "delete on last close" semantics, while such operations will succeed, the bytes are still consuming space on disk. For many applications this limitation is not a problem (e.g. if you have plenty of disk space, and you don't rely on overwriting files on Windows) but it's still an important limitation to be aware of.

This class supplies the workaround mentioned in the bug report (disabled by default, see UseUnmap), which may fail on non-Sun JVMs. It forcefully unmaps the buffer on close by using an undocumented internal cleanup functionality. UNMAP_SUPPORTED is true, if the workaround can be enabled (with no guarantees).

The MMapDirectory MultiMMapIndexInput type exposes the following members.
Constructors
 | Name | Description
Public method | MMapDirectory MultiMMapIndexInput | Initializes a new instance of the MMapDirectory MultiMMapIndexInput class
Back to Top
Methods
 | Name | Description
Public method | Clone | (Overrides IndexInput Clone .)
Public method | Close | Obsolete. (Inherited from IndexInput.)
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the MMapDirectory MultiMMapIndexInput and optionally releases the managed resources (Overrides IndexInput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Length | (Overrides IndexInput Length .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadByte | (Overrides IndexInput ReadByte .)
Public method | ReadBytes( Byte , Int32, Int32) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32).)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only BufferedIndexInput respects this parameter. (Inherited from IndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput Seek(Int64).)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to ReadChars( Char , Int32, Int32) but does not do any conversion operations on the bytes it is reading in. It still has to invoke ReadByte just as ReadChars( Char , Int32, Int32) does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | FilePointer | (Overrides IndexInput FilePointer.)
Back to Top
See Also
MMapDirectory MultiMMapIndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MMapDirectory.MultiMMapIndexInput Constructor

MMapDirectory MultiMMapIndexInput Constructor Lucene.Net Class Library
Initializes a new instance of the MMapDirectory MultiMMapIndexInput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MultiMMapIndexInput(
    MMapDirectory enclosingInstance,
    FileStream raf,
    int maxBufSize
)
public MultiMMapIndexInput(
    MMapDirectory enclosingInstance,
    FileStream raf,
    int maxBufSize
)
Public Sub New ( _
    enclosingInstance As MMapDirectory, _
    raf As FileStream, _
    maxBufSize As Integer _
)
Public Sub New ( _
    enclosingInstance As MMapDirectory, _
    raf As FileStream, _
    maxBufSize As Integer _
)
public:
MultiMMapIndexInput(
    MMapDirectory^ enclosingInstance,
    FileStream^ raf,
    int maxBufSize
)
public:
MultiMMapIndexInput(
    MMapDirectory^ enclosingInstance,
    FileStream^ raf,
    int maxBufSize
)
Parameters
enclosingInstance
Type: Lucene.Net.Store MMapDirectory
raf
Type:   Online System.IO FileStream
maxBufSize
Type:   Online System Int32
See Also
MMapDirectory MultiMMapIndexInput Class
MMapDirectory MultiMMapIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MMapDirectory.MultiMMapIndexInput Methods

MMapDirectory MultiMMapIndexInput Methods Lucene.Net Class Library
The MMapDirectory MultiMMapIndexInput type exposes the following members.
Methods
 | Name | Description
Public method | Clone | (Overrides IndexInput Clone .)
Public method | Close | Obsolete. (Inherited from IndexInput.)
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | (Overrides IndexInput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Length | (Overrides IndexInput Length .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadByte | (Overrides IndexInput ReadByte .)
Public method | ReadBytes( Byte , Int32, Int32) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32).)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only BufferedIndexInput respects this parameter. (Inherited from IndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput Seek(Int64).)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to ReadChars( Char , Int32, Int32) but does not do any conversion operations on the bytes it is reading in. It still has to invoke ReadByte just as ReadChars( Char , Int32, Int32) does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MMapDirectory MultiMMapIndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

MMapDirectory MultiMMapIndexInput Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
MMapDirectory MultiMMapIndexInput Class
MMapDirectory MultiMMapIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

MMapDirectory MultiMMapIndexInput Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the MMapDirectory MultiMMapIndexInput and optionally releases the managed resources (Overrides IndexInput Dispose(Boolean).)
Back to Top
See Also
MMapDirectory MultiMMapIndexInput Class
MMapDirectory MultiMMapIndexInput Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

MMapDirectory MultiMMapIndexInput Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the MMapDirectory MultiMMapIndexInput and optionally releases the managed resources

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
MMapDirectory MultiMMapIndexInput Class
MMapDirectory MultiMMapIndexInput Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Length Method

MMapDirectory MultiMMapIndexInput Length Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Length()
public override long Length()
Public Overrides Function Length As Long
Public Overrides Function Length As Long
public:
virtual long long Length() override
public:
virtual long long Length() override
See Also
MMapDirectory MultiMMapIndexInput Class
MMapDirectory MultiMMapIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadByte Method

MMapDirectory MultiMMapIndexInput ReadByte Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override byte ReadByte()
public override byte ReadByte()
Public Overrides Function ReadByte As Byte
Public Overrides Function ReadByte As Byte
public:
virtual unsigned char ReadByte() override
public:
virtual unsigned char ReadByte() override
See Also
MMapDirectory MultiMMapIndexInput Class
MMapDirectory MultiMMapIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadBytes Method

MMapDirectory MultiMMapIndexInput ReadBytes Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ReadBytes( Byte , Int32, Int32) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32).)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only BufferedIndexInput respects this parameter. (Inherited from IndexInput.)
Back to Top
See Also
MMapDirectory MultiMMapIndexInput Class
MMapDirectory MultiMMapIndexInput Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadBytes Method (Byte[], Int32, Int32)

MMapDirectory MultiMMapIndexInput ReadBytes Method ( Byte , Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ReadBytes(
    byte[] b,
    int offset,
    int len
)
public override void ReadBytes(
    byte[] b,
    int offset,
    int len
)
Public Overrides Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Public Overrides Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) override
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) override
Parameters
b
Type:    Online System Byte
offset
Type:   Online System Int32
len
Type:   Online System Int32
See Also
MMapDirectory MultiMMapIndexInput Class
MMapDirectory MultiMMapIndexInput Members
ReadBytes Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method

MMapDirectory MultiMMapIndexInput Seek Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Seek(
    long pos
)
public override void Seek(
    long pos
)
Public Overrides Sub Seek ( _
    pos As Long _
)
Public Overrides Sub Seek ( _
    pos As Long _
)
public:
virtual void Seek(
    long long pos
) override
public:
virtual void Seek(
    long long pos
) override
Parameters
pos
Type:   Online System Int64
See Also
MMapDirectory MultiMMapIndexInput Class
MMapDirectory MultiMMapIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MMapDirectory.MultiMMapIndexInput Properties

MMapDirectory MultiMMapIndexInput Properties Lucene.Net Class Library
The MMapDirectory MultiMMapIndexInput type exposes the following members.
Properties
 | Name | Description
Public property | Enclosing_Instance |
Public property | FilePointer | (Overrides IndexInput FilePointer.)
Back to Top
See Also
MMapDirectory MultiMMapIndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Enclosing_Instance Property

MMapDirectory MultiMMapIndexInput Enclosing_Instance Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MMapDirectory Enclosing_Instance { get; }
public MMapDirectory Enclosing_Instance { get; }
Public ReadOnly Property Enclosing_Instance As MMapDirectory
    Get
Public ReadOnly Property Enclosing_Instance As MMapDirectory
    Get
public:
property MMapDirectory^ Enclosing_Instance {
    MMapDirectory^ get ();
}
public:
property MMapDirectory^ Enclosing_Instance {
    MMapDirectory^ get ();
}
See Also
MMapDirectory MultiMMapIndexInput Class
MMapDirectory MultiMMapIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilePointer Property

MMapDirectory MultiMMapIndexInput FilePointer Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long FilePointer { get; }
public override long FilePointer { get; }
Public Overrides ReadOnly Property FilePointer As Long
    Get
Public Overrides ReadOnly Property FilePointer As Long
    Get
public:
virtual property long long FilePointer {
    long long get () override;
}
public:
virtual property long long FilePointer {
    long long get () override;
}
See Also
MMapDirectory MultiMMapIndexInput Class
MMapDirectory MultiMMapIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NativeFSLockFactory Class

NativeFSLockFactory Class Lucene.Net Class Library

Implements LockFactory using native OS file locks. Note that because this LockFactory relies on java.nio.* APIs for locking, any problems with those APIs will cause locking to fail. Specifically, on certain NFS environments the java.nio.* locks will fail (the lock can incorrectly be double acquired) whereas SimpleFSLockFactory worked perfectly in those same environments. For NFS based access to an index, it's recommended that you try SimpleFSLockFactory first and work around the one limitation that a lock file could be left when the JVM exits abnormally.

The primary benefit of NativeFSLockFactory is that lock files will be properly removed (by the OS) if the JVM has an abnormal exit.

Note that, unlike SimpleFSLockFactory, the existence of leftover lock files in the filesystem on exiting the JVM is fine because the OS will free the locks held against these files even though the files still remain.

If you suspect that this or any other LockFactory is not working properly in your environment, you can easily test it by using VerifyingLockFactory, LockVerifyServer and LockStressTest.

Inheritance Hierarchy
Online System Object
Lucene.Net.Store LockFactory
Lucene.Net.Store FSLockFactory
Lucene.Net.Store NativeFSLockFactory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NativeFSLockFactory : FSLockFactory
public class NativeFSLockFactory : FSLockFactory
Public Class NativeFSLockFactory _
    Inherits FSLockFactory
Public Class NativeFSLockFactory _
    Inherits FSLockFactory
public ref class NativeFSLockFactory : public FSLockFactory
public ref class NativeFSLockFactory : public FSLockFactory
See Also
NativeFSLockFactory Members
Lucene.Net.Store Namespace
Lucene.Net.Store LockFactory
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NativeFSLockFactory Members

NativeFSLockFactory Members Lucene.Net Class Library

The NativeFSLockFactory type exposes the following members.
Constructors
 | Name | Description
Public method | NativeFSLockFactory | Create a NativeFSLockFactory instance, with null (unset) lock directory. When you pass this factory to a FSDirectory subclass, the lock directory is automatically set to the directory itsself. Be sure to create one instance for each directory your create!
Public method | NativeFSLockFactory(DirectoryInfo) | Create a NativeFSLockFactory instance, storing lock files into the specified lockDir:
Public method | NativeFSLockFactory(String) | Create a NativeFSLockFactory instance, storing lock files into the specified lockDirName:
Back to Top
Methods
 | Name | Description
Public method | ClearLock | (Overrides LockFactory ClearLock(String).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLock | (Overrides LockFactory MakeLock(String).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | internalLockDir | Directory for the lock files. (Inherited from FSLockFactory.)
Protected field | internalLockPrefix | (Inherited from LockFactory.)
Back to Top
Properties
 | Name | Description
Public property | LockDir | Gets the lock directory. Subclasses can use this to set the lock directory. This method can be only called once to initialize the lock directory. It is used by FSDirectory to set the lock directory to itsself. Subclasses can also use this method to set the directory in the constructor. (Inherited from FSLockFactory.)
Public property | LockPrefix | Gets or sets the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Back to Top
See Also
NativeFSLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NativeFSLockFactory Constructor

NativeFSLockFactory Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | NativeFSLockFactory | Create a NativeFSLockFactory instance, with null (unset) lock directory. When you pass this factory to a FSDirectory subclass, the lock directory is automatically set to the directory itsself. Be sure to create one instance for each directory your create!
Public method | NativeFSLockFactory(DirectoryInfo) | Create a NativeFSLockFactory instance, storing lock files into the specified lockDir:
Public method | NativeFSLockFactory(String) | Create a NativeFSLockFactory instance, storing lock files into the specified lockDirName:
Back to Top
See Also
NativeFSLockFactory Class
NativeFSLockFactory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NativeFSLockFactory Constructor

NativeFSLockFactory Constructor Lucene.Net Class Library
Create a NativeFSLockFactory instance, with null (unset) lock directory. When you pass this factory to a FSDirectory subclass, the lock directory is automatically set to the directory itsself. Be sure to create one instance for each directory your create!

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NativeFSLockFactory()
public NativeFSLockFactory()
Public Sub New
Public Sub New
public:
NativeFSLockFactory()
public:
NativeFSLockFactory()
See Also
NativeFSLockFactory Class
NativeFSLockFactory Members
NativeFSLockFactory Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NativeFSLockFactory Constructor (DirectoryInfo)

NativeFSLockFactory Constructor (DirectoryInfo) Lucene.Net Class Library
Create a NativeFSLockFactory instance, storing lock files into the specified lockDir:

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NativeFSLockFactory(
    DirectoryInfo lockDir
)
public NativeFSLockFactory(
    DirectoryInfo lockDir
)
Public Sub New ( _
    lockDir As DirectoryInfo _
)
Public Sub New ( _
    lockDir As DirectoryInfo _
)
public:
NativeFSLockFactory(
    DirectoryInfo^ lockDir
)
public:
NativeFSLockFactory(
    DirectoryInfo^ lockDir
)
Parameters
lockDir
Type:   Online System.IO DirectoryInfo
where lock files are created.

See Also
NativeFSLockFactory Class
NativeFSLockFactory Members
NativeFSLockFactory Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NativeFSLockFactory Constructor (String)

NativeFSLockFactory Constructor (String) Lucene.Net Class Library
Create a NativeFSLockFactory instance, storing lock files into the specified lockDirName:

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NativeFSLockFactory(
    string lockDirName
)
public NativeFSLockFactory(
    string lockDirName
)
Public Sub New ( _
    lockDirName As String _
)
Public Sub New ( _
    lockDirName As String _
)
public:
NativeFSLockFactory(
    String^ lockDirName
)
public:
NativeFSLockFactory(
    String^ lockDirName
)
Parameters
lockDirName
Type:   Online System String
where lock files are created.

See Also
NativeFSLockFactory Class
NativeFSLockFactory Members
NativeFSLockFactory Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NativeFSLockFactory Fields

NativeFSLockFactory Fields Lucene.Net Class Library
The NativeFSLockFactory type exposes the following members.
Fields
 | Name | Description
Protected field | internalLockDir | Directory for the lock files. (Inherited from FSLockFactory.)
Protected field | internalLockPrefix | (Inherited from LockFactory.)
Back to Top
See Also
NativeFSLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NativeFSLockFactory Methods

NativeFSLockFactory Methods Lucene.Net Class Library
The NativeFSLockFactory type exposes the following members.
Methods
 | Name | Description
Public method | ClearLock | (Overrides LockFactory ClearLock(String).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLock | (Overrides LockFactory MakeLock(String).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NativeFSLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ClearLock Method

NativeFSLockFactory ClearLock Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ClearLock(
    string lockName
)
public override void ClearLock(
    string lockName
)
Public Overrides Sub ClearLock ( _
    lockName As String _
)
Public Overrides Sub ClearLock ( _
    lockName As String _
)
public:
virtual void ClearLock(
    String^ lockName
) override
public:
virtual void ClearLock(
    String^ lockName
) override
Parameters
lockName
Type:   Online System String
See Also
NativeFSLockFactory Class
NativeFSLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MakeLock Method

NativeFSLockFactory MakeLock Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Lock MakeLock(
    string lockName
)
public override Lock MakeLock(
    string lockName
)
Public Overrides Function MakeLock ( _
    lockName As String _
) As Lock
Public Overrides Function MakeLock ( _
    lockName As String _
) As Lock
public:
virtual Lock^ MakeLock(
    String^ lockName
) override
public:
virtual Lock^ MakeLock(
    String^ lockName
) override
Parameters
lockName
Type:   Online System String
See Also
NativeFSLockFactory Class
NativeFSLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NativeFSLockFactory Properties

NativeFSLockFactory Properties Lucene.Net Class Library
The NativeFSLockFactory type exposes the following members.
Properties
 | Name | Description
Public property | LockDir | Gets the lock directory. Subclasses can use this to set the lock directory. This method can be only called once to initialize the lock directory. It is used by FSDirectory to set the lock directory to itsself. Subclasses can also use this method to set the directory in the constructor. (Inherited from FSLockFactory.)
Public property | LockPrefix | Gets or sets the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Back to Top
See Also
NativeFSLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NIOFSDirectory Class

NIOFSDirectory Class Lucene.Net Class Library
Not implemented. Waiting for volunteers.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store Directory
Lucene.Net.Store FSDirectory
Lucene.Net.Store NIOFSDirectory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NIOFSDirectory : FSDirectory
public class NIOFSDirectory : FSDirectory
Public Class NIOFSDirectory _
    Inherits FSDirectory
Public Class NIOFSDirectory _
    Inherits FSDirectory
public ref class NIOFSDirectory : public FSDirectory
public ref class NIOFSDirectory : public FSDirectory
See Also
NIOFSDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NIOFSDirectory Members

NIOFSDirectory Members Lucene.Net Class Library

The NIOFSDirectory type exposes the following members.
Constructors
 | Name | Description
Public method | NIOFSDirectory | Initializes a new instance of the NIOFSDirectory class
Back to Top
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Obsolete. (Inherited from Directory.)
Public method | CreateOutput | (Overrides Directory CreateOutput(String).)
Public method | DeleteFile | Removes an existing file in the directory. (Inherited from FSDirectory.)
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | (Inherited from FSDirectory.)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Inherited from FSDirectory.)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Inherited from FSDirectory.)
Public method | FileModified(String) | Returns the time the named file was last modified. (Inherited from FSDirectory.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLockId | (Inherited from FSDirectory.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InitOutput | Initializes the directory to create a new file with the given name. This method should be used in CreateOutput(String). (Inherited from FSDirectory.)
Public method | ListAll | Lists all files (not subdirectories) in the directory. (Inherited from FSDirectory.)
Public method | MakeLock | Construct a Lock. (Inherited from Directory.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenInput(String) | (Inherited from FSDirectory.)
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are FSDirectory and CompoundFileReader . (Inherited from Directory.)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | Sync | (Inherited from FSDirectory.)
Public method | ToString | For debug output. (Inherited from FSDirectory.)
Public method | TouchFile | Set the modified time of an existing file to now. (Inherited from FSDirectory.)
Back to Top
Fields
 | Name | Description
Protected field | interalLockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)
Protected field | internalDirectory | The underlying filesystem directory (Inherited from FSDirectory.)
Protected field | isOpen | (Inherited from Directory.)
Back to Top
Properties
 | Name | Description
Public property | Directory | (Inherited from FSDirectory.)
Public property | isOpen_ForNUnit | (Inherited from Directory.)
Public property | LockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public property | ReadChunkSize | The maximum number of bytes to read at once from the underlying file during ReadBytes( Byte , Int32, Int32). (Inherited from FSDirectory.)
Back to Top
See Also
NIOFSDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NIOFSDirectory Constructor

NIOFSDirectory Constructor Lucene.Net Class Library
Initializes a new instance of the NIOFSDirectory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NIOFSDirectory(
    DirectoryInfo dir,
    LockFactory lockFactory
)
public NIOFSDirectory(
    DirectoryInfo dir,
    LockFactory lockFactory
)
Public Sub New ( _
    dir As DirectoryInfo, _
    lockFactory As LockFactory _
)
Public Sub New ( _
    dir As DirectoryInfo, _
    lockFactory As LockFactory _
)
public:
NIOFSDirectory(
    DirectoryInfo^ dir,
    LockFactory^ lockFactory
)
public:
NIOFSDirectory(
    DirectoryInfo^ dir,
    LockFactory^ lockFactory
)
Parameters
dir
Type:   Online System.IO DirectoryInfo
lockFactory
Type: Lucene.Net.Store LockFactory
See Also
NIOFSDirectory Class
NIOFSDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NIOFSDirectory Fields

NIOFSDirectory Fields Lucene.Net Class Library
The NIOFSDirectory type exposes the following members.
Fields
 | Name | Description
Protected field | interalLockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)
Protected field | internalDirectory | The underlying filesystem directory (Inherited from FSDirectory.)
Protected field | isOpen | (Inherited from Directory.)
Back to Top
See Also
NIOFSDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NIOFSDirectory Methods

NIOFSDirectory Methods Lucene.Net Class Library
The NIOFSDirectory type exposes the following members.
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Obsolete. (Inherited from Directory.)
Public method | CreateOutput | (Overrides Directory CreateOutput(String).)
Public method | DeleteFile | Removes an existing file in the directory. (Inherited from FSDirectory.)
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | (Inherited from FSDirectory.)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Inherited from FSDirectory.)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Inherited from FSDirectory.)
Public method | FileModified(String) | Returns the time the named file was last modified. (Inherited from FSDirectory.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLockId | (Inherited from FSDirectory.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InitOutput | Initializes the directory to create a new file with the given name. This method should be used in CreateOutput(String). (Inherited from FSDirectory.)
Public method | ListAll | Lists all files (not subdirectories) in the directory. (Inherited from FSDirectory.)
Public method | MakeLock | Construct a Lock. (Inherited from Directory.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenInput(String) | (Inherited from FSDirectory.)
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are FSDirectory and CompoundFileReader . (Inherited from Directory.)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | Sync | (Inherited from FSDirectory.)
Public method | ToString | For debug output. (Inherited from FSDirectory.)
Public method | TouchFile | Set the modified time of an existing file to now. (Inherited from FSDirectory.)
Back to Top
See Also
NIOFSDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateOutput Method

NIOFSDirectory CreateOutput Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexOutput CreateOutput(
    string name
)
public override IndexOutput CreateOutput(
    string name
)
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
NIOFSDirectory Class
NIOFSDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NIOFSDirectory Properties

NIOFSDirectory Properties Lucene.Net Class Library
The NIOFSDirectory type exposes the following members.
Properties
 | Name | Description
Public property | Directory | (Inherited from FSDirectory.)
Public property | isOpen_ForNUnit | (Inherited from Directory.)
Public property | LockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public property | ReadChunkSize | The maximum number of bytes to read at once from the underlying file during ReadBytes( Byte , Int32, Int32). (Inherited from FSDirectory.)
Back to Top
See Also
NIOFSDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NIOFSDirectory.NIOFSIndexInput Class

NIOFSDirectory NIOFSIndexInput Class Lucene.Net Class Library
Not implemented. Waiting for volunteers.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store NIOFSDirectory NIOFSIndexInput

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NIOFSIndexInput
public class NIOFSIndexInput
Public Class NIOFSIndexInput
Public Class NIOFSIndexInput
public ref class NIOFSIndexInput
public ref class NIOFSIndexInput
See Also
NIOFSDirectory NIOFSIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NIOFSDirectory.NIOFSIndexInput Members

NIOFSDirectory NIOFSIndexInput Members Lucene.Net Class Library

Not implemented. Waiting for volunteers.

The NIOFSDirectory NIOFSIndexInput type exposes the following members.
Constructors
 | Name | Description
Public method | NIOFSDirectory NIOFSIndexInput | Initializes a new instance of the NIOFSDirectory NIOFSIndexInput class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NIOFSDirectory NIOFSIndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NIOFSDirectory.NIOFSIndexInput Constructor

NIOFSDirectory NIOFSIndexInput Constructor Lucene.Net Class Library
Initializes a new instance of the NIOFSDirectory NIOFSIndexInput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NIOFSIndexInput()
public NIOFSIndexInput()
Public Sub New
Public Sub New
public:
NIOFSIndexInput()
public:
NIOFSIndexInput()
See Also
NIOFSDirectory NIOFSIndexInput Class
NIOFSDirectory NIOFSIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NIOFSDirectory.NIOFSIndexInput Methods

NIOFSDirectory NIOFSIndexInput Methods Lucene.Net Class Library
The NIOFSDirectory NIOFSIndexInput type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NIOFSDirectory NIOFSIndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NoLockFactory Class

NoLockFactory Class Lucene.Net Class Library
Use this LockFactory to disable locking entirely. Only one instance of this lock is created. You should call Instance to get the instance.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store LockFactory
Lucene.Net.Store NoLockFactory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NoLockFactory : LockFactory
public class NoLockFactory : LockFactory
Public Class NoLockFactory _
    Inherits LockFactory
Public Class NoLockFactory _
    Inherits LockFactory
public ref class NoLockFactory : public LockFactory
public ref class NoLockFactory : public LockFactory
See Also
NoLockFactory Members
Lucene.Net.Store Namespace
Lucene.Net.Store LockFactory
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NoLockFactory Members

NoLockFactory Members Lucene.Net Class Library

The NoLockFactory type exposes the following members.
Constructors
 | Name | Description
Public method | NoLockFactory | Initializes a new instance of the NoLockFactory class
Back to Top
Methods
 | Name | Description
Public method | ClearLock | (Overrides LockFactory ClearLock(String).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLock | (Overrides LockFactory MakeLock(String).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | internalLockPrefix | (Inherited from LockFactory.)
Back to Top
Properties
 | Name | Description
 | Instance |
Public property | LockPrefix | Gets or sets the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Back to Top
See Also
NoLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NoLockFactory Constructor

NoLockFactory Constructor Lucene.Net Class Library
Initializes a new instance of the NoLockFactory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NoLockFactory()
public NoLockFactory()
Public Sub New
Public Sub New
public:
NoLockFactory()
public:
NoLockFactory()
See Also
NoLockFactory Class
NoLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NoLockFactory Fields

NoLockFactory Fields Lucene.Net Class Library
The NoLockFactory type exposes the following members.
Fields
 | Name | Description
Protected field | internalLockPrefix | (Inherited from LockFactory.)
Back to Top
See Also
NoLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NoLockFactory Methods

NoLockFactory Methods Lucene.Net Class Library
The NoLockFactory type exposes the following members.
Methods
 | Name | Description
Public method | ClearLock | (Overrides LockFactory ClearLock(String).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLock | (Overrides LockFactory MakeLock(String).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NoLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ClearLock Method

NoLockFactory ClearLock Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ClearLock(
    string lockName
)
public override void ClearLock(
    string lockName
)
Public Overrides Sub ClearLock ( _
    lockName As String _
)
Public Overrides Sub ClearLock ( _
    lockName As String _
)
public:
virtual void ClearLock(
    String^ lockName
) override
public:
virtual void ClearLock(
    String^ lockName
) override
Parameters
lockName
Type:   Online System String
See Also
NoLockFactory Class
NoLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MakeLock Method

NoLockFactory MakeLock Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Lock MakeLock(
    string lockName
)
public override Lock MakeLock(
    string lockName
)
Public Overrides Function MakeLock ( _
    lockName As String _
) As Lock
Public Overrides Function MakeLock ( _
    lockName As String _
) As Lock
public:
virtual Lock^ MakeLock(
    String^ lockName
) override
public:
virtual Lock^ MakeLock(
    String^ lockName
) override
Parameters
lockName
Type:   Online System String
See Also
NoLockFactory Class
NoLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NoLockFactory Properties

NoLockFactory Properties Lucene.Net Class Library
The NoLockFactory type exposes the following members.
Properties
 | Name | Description
 | Instance |
Public property | LockPrefix | Gets or sets the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Back to Top
See Also
NoLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Instance Property

NoLockFactory Instance Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NoLockFactory Instance { get; }
public static NoLockFactory Instance { get; }
Public Shared ReadOnly Property Instance As NoLockFactory
    Get
Public Shared ReadOnly Property Instance As NoLockFactory
    Get
public:
static property NoLockFactory^ Instance {
    NoLockFactory^ get ();
}
public:
static property NoLockFactory^ Instance {
    NoLockFactory^ get ();
}
See Also
NoLockFactory Class
NoLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NoSuchDirectoryException Class

NoSuchDirectoryException Class Lucene.Net Class Library
This exception is thrown when you try to list a non-existent directory.
Inheritance Hierarchy
Online System Object
Online System Exception
Online System SystemException
Online System.IO IOException
Online System.IO FileNotFoundException
Lucene.Net.Store NoSuchDirectoryException

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class NoSuchDirectoryException : FileNotFoundException
[SerializableAttribute]
public class NoSuchDirectoryException : FileNotFoundException
<SerializableAttribute> _
Public Class NoSuchDirectoryException _
    Inherits FileNotFoundException
<SerializableAttribute> _
Public Class NoSuchDirectoryException _
    Inherits FileNotFoundException
[SerializableAttribute]
public ref class NoSuchDirectoryException : public FileNotFoundException
[SerializableAttribute]
public ref class NoSuchDirectoryException : public FileNotFoundException
See Also
NoSuchDirectoryException Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NoSuchDirectoryException Members

NoSuchDirectoryException Members Lucene.Net Class Library

The NoSuchDirectoryException type exposes the following members.
Constructors
 | Name | Description
Public method | NoSuchDirectoryException | Initializes a new instance of the NoSuchDirectoryException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | Sets the Online SerializationInfo object with the file name and additional exception information. (Inherited from Online FileNotFoundException.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified name of this exception and possibly the error message, the name of the inner exception, and the stack trace. (Inherited from Online FileNotFoundException.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online FileName | Gets the name of the file that cannot be found. (Inherited from Online FileNotFoundException.)
Public property | Online FusionLog | Gets the log file that describes why loading of an assembly failed. (Inherited from Online FileNotFoundException.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets the error message that explains the reason for the exception. (Inherited from Online FileNotFoundException.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
NoSuchDirectoryException Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NoSuchDirectoryException Constructor

NoSuchDirectoryException Constructor Lucene.Net Class Library
Initializes a new instance of the NoSuchDirectoryException class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NoSuchDirectoryException(
    string message
)
public NoSuchDirectoryException(
    string message
)
Public Sub New ( _
    message As String _
)
Public Sub New ( _
    message As String _
)
public:
NoSuchDirectoryException(
    String^ message
)
public:
NoSuchDirectoryException(
    String^ message
)
Parameters
message
Type:   Online System String
See Also
NoSuchDirectoryException Class
NoSuchDirectoryException Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NoSuchDirectoryException Methods

NoSuchDirectoryException Methods Lucene.Net Class Library
The NoSuchDirectoryException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | Sets the Online SerializationInfo object with the file name and additional exception information. (Inherited from Online FileNotFoundException.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified name of this exception and possibly the error message, the name of the inner exception, and the stack trace. (Inherited from Online FileNotFoundException.)
Back to Top
See Also
NoSuchDirectoryException Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NoSuchDirectoryException Properties

NoSuchDirectoryException Properties Lucene.Net Class Library
The NoSuchDirectoryException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online FileName | Gets the name of the file that cannot be found. (Inherited from Online FileNotFoundException.)
Public property | Online FusionLog | Gets the log file that describes why loading of an assembly failed. (Inherited from Online FileNotFoundException.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets the error message that explains the reason for the exception. (Inherited from Online FileNotFoundException.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
NoSuchDirectoryException Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NoSuchDirectoryException Events

NoSuchDirectoryException Events Lucene.Net Class Library
The NoSuchDirectoryException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
NoSuchDirectoryException Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMDirectory Class

RAMDirectory Class Lucene.Net Class Library
A memory-resident Directory implementation. Locking implementation is by default the SingleInstanceLockFactory but can be changed with SetLockFactory(LockFactory).
Inheritance Hierarchy
Online System Object
Lucene.Net.Store Directory
Lucene.Net.Store RAMDirectory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class RAMDirectory : Directory
[SerializableAttribute]
public class RAMDirectory : Directory
<SerializableAttribute> _
Public Class RAMDirectory _
    Inherits Directory
<SerializableAttribute> _
Public Class RAMDirectory _
    Inherits Directory
[SerializableAttribute]
public ref class RAMDirectory : public Directory
[SerializableAttribute]
public ref class RAMDirectory : public Directory
See Also
RAMDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMDirectory Members

RAMDirectory Members Lucene.Net Class Library

The RAMDirectory type exposes the following members.
Constructors
 | Name | Description
Public method | RAMDirectory | Constructs an empty Directory.
Public method | RAMDirectory(Directory) | Creates a new RAMDirectory instance from a different Directory implementation. This can be used to load a disk-based index into memory. This should be used only with indices that can fit into memory. Note that the resulting RAMDirectory instance is fully independent from the original Directory (it is a complete copy). Any subsequent changes to the original Directory will not be visible in the RAMDirectory instance.
Back to Top
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Obsolete. (Inherited from Directory.)
Public method | CreateOutput | Creates a new, empty file in the directory with the given name. Returns a stream writing this file. (Overrides Directory CreateOutput(String).)
Public method | DeleteFile | Removes an existing file in the directory. (Overrides Directory DeleteFile(String).)
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | Closes the store to future operations, releasing associated memory. (Overrides Directory Dispose(Boolean).)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FileExists | Returns true iff the named file exists in this directory. (Overrides Directory FileExists(String).)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Overrides Directory FileLength(String).)
Public method | FileModified | Returns the time the named file was last modified. (Overrides Directory FileModified(String).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLockId | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index. (Inherited from Directory.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | ListAll | (Overrides Directory ListAll .)
Public method | MakeLock | Construct a Lock. (Inherited from Directory.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenInput(String) | Returns a stream reading an existing file. (Overrides Directory OpenInput(String).)
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are FSDirectory and CompoundFileReader . (Inherited from Directory.)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | SizeInBytes | Return total size in bytes of all files in this directory. This is currently quantized to RAMOutputStream.BUFFER_SIZE.
Public method | Sync | Ensure that any writes to this file are moved to stable storage. Lucene uses this to properly commit changes to the index, to prevent a machine/OS crash from corrupting the index. (Inherited from Directory.)
Public method | ToString | (Inherited from Directory.)
Public method | TouchFile | Set the modified time of an existing file to now. (Overrides Directory TouchFile(String).)
Back to Top
Fields
 | Name | Description
Protected field | fileMap |
Protected field | interalLockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)
Protected field | internalSizeInBytes |
Protected field | isOpen | (Inherited from Directory.)
Back to Top
Properties
 | Name | Description
Public property | isOpen_ForNUnit | (Inherited from Directory.)
Public property | LockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Back to Top
See Also
RAMDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMDirectory Constructor

RAMDirectory Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | RAMDirectory | Constructs an empty Directory.
Public method | RAMDirectory(Directory) | Creates a new RAMDirectory instance from a different Directory implementation. This can be used to load a disk-based index into memory. This should be used only with indices that can fit into memory. Note that the resulting RAMDirectory instance is fully independent from the original Directory (it is a complete copy). Any subsequent changes to the original Directory will not be visible in the RAMDirectory instance.
Back to Top
See Also
RAMDirectory Class
RAMDirectory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMDirectory Constructor

RAMDirectory Constructor Lucene.Net Class Library
Constructs an empty Directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RAMDirectory()
public RAMDirectory()
Public Sub New
Public Sub New
public:
RAMDirectory()
public:
RAMDirectory()
See Also
RAMDirectory Class
RAMDirectory Members
RAMDirectory Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMDirectory Constructor (Directory)

RAMDirectory Constructor (Directory) Lucene.Net Class Library
Creates a new RAMDirectory instance from a different Directory implementation. This can be used to load a disk-based index into memory.

This should be used only with indices that can fit into memory.

Note that the resulting RAMDirectory instance is fully independent from the original Directory (it is a complete copy). Any subsequent changes to the original Directory will not be visible in the RAMDirectory instance.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RAMDirectory(
    Directory dir
)
public RAMDirectory(
    Directory dir
)
Public Sub New ( _
    dir As Directory _
)
Public Sub New ( _
    dir As Directory _
)
public:
RAMDirectory(
    Directory^ dir
)
public:
RAMDirectory(
    Directory^ dir
)
Parameters
dir
Type: Lucene.Net.Store Directory
a Directory value

Exceptions
Exception | Condition
Online System.IO IOException | if an error occurs
See Also
RAMDirectory Class
RAMDirectory Members
RAMDirectory Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMDirectory Fields

RAMDirectory Fields Lucene.Net Class Library
The RAMDirectory type exposes the following members.
Fields
 | Name | Description
Protected field | fileMap |
Protected field | interalLockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)
Protected field | internalSizeInBytes |
Protected field | isOpen | (Inherited from Directory.)
Back to Top
See Also
RAMDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


fileMap Field

RAMDirectory fileMap Field Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected HashMap<string, RAMFile> fileMap
protected HashMap<string, RAMFile> fileMap
Protected fileMap As HashMap(Of String, RAMFile)
Protected fileMap As HashMap(Of String, RAMFile)
protected:
HashMap<String^, RAMFile^>^ fileMap
protected:
HashMap<String^, RAMFile^>^ fileMap
See Also
RAMDirectory Class
RAMDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalSizeInBytes Field

RAMDirectory internalSizeInBytes Field Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected long internalSizeInBytes
protected long internalSizeInBytes
Protected internalSizeInBytes As Long
Protected internalSizeInBytes As Long
protected:
long long internalSizeInBytes
protected:
long long internalSizeInBytes
See Also
RAMDirectory Class
RAMDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMDirectory Methods

RAMDirectory Methods Lucene.Net Class Library
The RAMDirectory type exposes the following members.
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Obsolete. (Inherited from Directory.)
Public method | CreateOutput | Creates a new, empty file in the directory with the given name. Returns a stream writing this file. (Overrides Directory CreateOutput(String).)
Public method | DeleteFile | Removes an existing file in the directory. (Overrides Directory DeleteFile(String).)
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | Closes the store to future operations, releasing associated memory. (Overrides Directory Dispose(Boolean).)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FileExists | Returns true iff the named file exists in this directory. (Overrides Directory FileExists(String).)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Overrides Directory FileLength(String).)
Public method | FileModified | Returns the time the named file was last modified. (Overrides Directory FileModified(String).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLockId | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index. (Inherited from Directory.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | ListAll | (Overrides Directory ListAll .)
Public method | MakeLock | Construct a Lock. (Inherited from Directory.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenInput(String) | Returns a stream reading an existing file. (Overrides Directory OpenInput(String).)
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are FSDirectory and CompoundFileReader . (Inherited from Directory.)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | SizeInBytes | Return total size in bytes of all files in this directory. This is currently quantized to RAMOutputStream.BUFFER_SIZE.
Public method | Sync | Ensure that any writes to this file are moved to stable storage. Lucene uses this to properly commit changes to the index, to prevent a machine/OS crash from corrupting the index. (Inherited from Directory.)
Public method | ToString | (Inherited from Directory.)
Public method | TouchFile | Set the modified time of an existing file to now. (Overrides Directory TouchFile(String).)
Back to Top
See Also
RAMDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateOutput Method

RAMDirectory CreateOutput Method Lucene.Net Class Library
Creates a new, empty file in the directory with the given name. Returns a stream writing this file.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexOutput CreateOutput(
    string name
)
public override IndexOutput CreateOutput(
    string name
)
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
RAMDirectory Class
RAMDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DeleteFile Method

RAMDirectory DeleteFile Method Lucene.Net Class Library
Removes an existing file in the directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void DeleteFile(
    string name
)
public override void DeleteFile(
    string name
)
Public Overrides Sub DeleteFile ( _
    name As String _
)
Public Overrides Sub DeleteFile ( _
    name As String _
)
public:
virtual void DeleteFile(
    String^ name
) override
public:
virtual void DeleteFile(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
RAMDirectory Class
RAMDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

RAMDirectory Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | Closes the store to future operations, releasing associated memory. (Overrides Directory Dispose(Boolean).)
Back to Top
See Also
RAMDirectory Class
RAMDirectory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

RAMDirectory Dispose Method (Boolean) Lucene.Net Class Library
Closes the store to future operations, releasing associated memory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
RAMDirectory Class
RAMDirectory Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileExists Method

RAMDirectory FileExists Method Lucene.Net Class Library
Returns true iff the named file exists in this directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool FileExists(
    string name
)
public override bool FileExists(
    string name
)
Public Overrides Function FileExists ( _
    name As String _
) As Boolean
Public Overrides Function FileExists ( _
    name As String _
) As Boolean
public:
virtual bool FileExists(
    String^ name
) override
public:
virtual bool FileExists(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
RAMDirectory Class
RAMDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileLength Method

RAMDirectory FileLength Method Lucene.Net Class Library
Returns the length in bytes of a file in the directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long FileLength(
    string name
)
public override long FileLength(
    string name
)
Public Overrides Function FileLength ( _
    name As String _
) As Long
Public Overrides Function FileLength ( _
    name As String _
) As Long
public:
virtual long long FileLength(
    String^ name
) override
public:
virtual long long FileLength(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
RAMDirectory Class
RAMDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileModified Method

RAMDirectory FileModified Method Lucene.Net Class Library
Returns the time the named file was last modified.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long FileModified(
    string name
)
public override long FileModified(
    string name
)
Public Overrides Function FileModified ( _
    name As String _
) As Long
Public Overrides Function FileModified ( _
    name As String _
) As Long
public:
virtual long long FileModified(
    String^ name
) override
public:
virtual long long FileModified(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
RAMDirectory Class
RAMDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ListAll Method

RAMDirectory ListAll Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string[] ListAll()
public override string[] ListAll()
Public Overrides Function ListAll As String()
Public Overrides Function ListAll As String()
public:
virtual array<String^>^ ListAll() override
public:
virtual array<String^>^ ListAll() override
See Also
RAMDirectory Class
RAMDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenInput Method

RAMDirectory OpenInput Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | OpenInput(String) | Returns a stream reading an existing file. (Overrides Directory OpenInput(String).)
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are FSDirectory and CompoundFileReader . (Inherited from Directory.)
Back to Top
See Also
RAMDirectory Class
RAMDirectory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenInput Method (String)

RAMDirectory OpenInput Method (String) Lucene.Net Class Library
Returns a stream reading an existing file.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexInput OpenInput(
    string name
)
public override IndexInput OpenInput(
    string name
)
Public Overrides Function OpenInput ( _
    name As String _
) As IndexInput
Public Overrides Function OpenInput ( _
    name As String _
) As IndexInput
public:
virtual IndexInput^ OpenInput(
    String^ name
) override
public:
virtual IndexInput^ OpenInput(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
RAMDirectory Class
RAMDirectory Members
OpenInput Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SizeInBytes Method

RAMDirectory SizeInBytes Method Lucene.Net Class Library
Return total size in bytes of all files in this directory. This is currently quantized to RAMOutputStream.BUFFER_SIZE.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long SizeInBytes()
public long SizeInBytes()
Public Function SizeInBytes As Long
Public Function SizeInBytes As Long
public:
long long SizeInBytes()
public:
long long SizeInBytes()
See Also
RAMDirectory Class
RAMDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TouchFile Method

RAMDirectory TouchFile Method Lucene.Net Class Library
Set the modified time of an existing file to now.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void TouchFile(
    string name
)
public override void TouchFile(
    string name
)
Public Overrides Sub TouchFile ( _
    name As String _
)
Public Overrides Sub TouchFile ( _
    name As String _
)
public:
virtual void TouchFile(
    String^ name
) override
public:
virtual void TouchFile(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
RAMDirectory Class
RAMDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMDirectory Properties

RAMDirectory Properties Lucene.Net Class Library
The RAMDirectory type exposes the following members.
Properties
 | Name | Description
Public property | isOpen_ForNUnit | (Inherited from Directory.)
Public property | LockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Back to Top
See Also
RAMDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMFile Class

RAMFile Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Store RAMFile

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class RAMFile
[SerializableAttribute]
public class RAMFile
<SerializableAttribute> _
Public Class RAMFile
<SerializableAttribute> _
Public Class RAMFile
[SerializableAttribute]
public ref class RAMFile
[SerializableAttribute]
public ref class RAMFile
See Also
RAMFile Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMFile Members

RAMFile Members Lucene.Net Class Library

The RAMFile type exposes the following members.
Constructors
 | Name | Description
Public method | RAMFile | Initializes a new instance of the RAMFile class
Public method | RAMFile(RAMDirectory) | Initializes a new instance of the RAMFile class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBuffer |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NewBuffer | Expert: allocate a new buffer. Subclasses can allocate differently.
Public method | NumBuffers |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | buffers |
Back to Top
Properties
 | Name | Description
Public property | SizeInBytes |
Back to Top
See Also
RAMFile Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMFile Constructor

RAMFile Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | RAMFile | Initializes a new instance of the RAMFile class
Public method | RAMFile(RAMDirectory) | Initializes a new instance of the RAMFile class
Back to Top
See Also
RAMFile Class
RAMFile Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMFile Constructor

RAMFile Constructor Lucene.Net Class Library
Initializes a new instance of the RAMFile class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RAMFile()
public RAMFile()
Public Sub New
Public Sub New
public:
RAMFile()
public:
RAMFile()
See Also
RAMFile Class
RAMFile Members
RAMFile Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMFile Constructor (RAMDirectory)

RAMFile Constructor (RAMDirectory) Lucene.Net Class Library
Initializes a new instance of the RAMFile class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RAMFile(
    RAMDirectory directory
)
public RAMFile(
    RAMDirectory directory
)
Public Sub New ( _
    directory As RAMDirectory _
)
Public Sub New ( _
    directory As RAMDirectory _
)
public:
RAMFile(
    RAMDirectory^ directory
)
public:
RAMFile(
    RAMDirectory^ directory
)
Parameters
directory
Type: Lucene.Net.Store RAMDirectory
See Also
RAMFile Class
RAMFile Members
RAMFile Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMFile Fields

RAMFile Fields Lucene.Net Class Library
The RAMFile type exposes the following members.
Fields
 | Name | Description
Protected field | buffers |
Back to Top
See Also
RAMFile Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


buffers Field

RAMFile buffers Field Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected List<byte[]> buffers
protected List<byte[]> buffers
Protected buffers As List(Of Byte())
Protected buffers As List(Of Byte())
protected:
List<array<unsigned char>^>^ buffers
protected:
List<array<unsigned char>^>^ buffers
See Also
RAMFile Class
RAMFile Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMFile Methods

RAMFile Methods Lucene.Net Class Library
The RAMFile type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBuffer |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NewBuffer | Expert: allocate a new buffer. Subclasses can allocate differently.
Public method | NumBuffers |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RAMFile Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBuffer Method

RAMFile GetBuffer Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] GetBuffer(
    int index
)
public byte[] GetBuffer(
    int index
)
Public Function GetBuffer ( _
    index As Integer _
) As Byte()
Public Function GetBuffer ( _
    index As Integer _
) As Byte()
public:
array<unsigned char>^ GetBuffer(
    int index
)
public:
array<unsigned char>^ GetBuffer(
    int index
)
Parameters
index
Type:   Online System Int32
See Also
RAMFile Class
RAMFile Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NewBuffer Method

RAMFile NewBuffer Method Lucene.Net Class Library
Expert: allocate a new buffer. Subclasses can allocate differently.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual byte[] NewBuffer(
    int size
)
public virtual byte[] NewBuffer(
    int size
)
Public Overridable Function NewBuffer ( _
    size As Integer _
) As Byte()
Public Overridable Function NewBuffer ( _
    size As Integer _
) As Byte()
public:
virtual array<unsigned char>^ NewBuffer(
    int size
)
public:
virtual array<unsigned char>^ NewBuffer(
    int size
)
Parameters
size
Type:   Online System Int32
size of allocated buffer.

Return Value
 allocated buffer.

See Also
RAMFile Class
RAMFile Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumBuffers Method

RAMFile NumBuffers Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int NumBuffers()
public int NumBuffers()
Public Function NumBuffers As Integer
Public Function NumBuffers As Integer
public:
int NumBuffers()
public:
int NumBuffers()
See Also
RAMFile Class
RAMFile Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMFile Properties

RAMFile Properties Lucene.Net Class Library
The RAMFile type exposes the following members.
Properties
 | Name | Description
Public property | SizeInBytes |
Back to Top
See Also
RAMFile Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SizeInBytes Property

RAMFile SizeInBytes Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long SizeInBytes { get; }
public virtual long SizeInBytes { get; }
Public Overridable ReadOnly Property SizeInBytes As Long
    Get
Public Overridable ReadOnly Property SizeInBytes As Long
    Get
public:
virtual property long long SizeInBytes {
    long long get ();
}
public:
virtual property long long SizeInBytes {
    long long get ();
}
See Also
RAMFile Class
RAMFile Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMInputStream Class

RAMInputStream Class Lucene.Net Class Library
A memory-resident IndexInput implementation.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store IndexInput
Lucene.Net.Store RAMInputStream

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RAMInputStream : IndexInput
public class RAMInputStream : IndexInput
Public Class RAMInputStream _
    Inherits IndexInput
Public Class RAMInputStream _
    Inherits IndexInput
public ref class RAMInputStream : public IndexInput
public ref class RAMInputStream : public IndexInput
See Also
RAMInputStream Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMInputStream Members

RAMInputStream Members Lucene.Net Class Library

The RAMInputStream type exposes the following members.
Constructors
 | Name | Description
Public method | RAMInputStream | Initializes a new instance of the RAMInputStream class
Back to Top
Methods
 | Name | Description
Public method | Clone | Returns a clone of this stream. Clones of a stream access the same data, and are positioned at the same point as the stream they were cloned from. Expert: Subclasses must ensure that clones may be positioned at different points in the input from each other and from the stream they were cloned from. (Inherited from IndexInput.)
Public method | Close | Obsolete. (Inherited from IndexInput.)
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the RAMInputStream and optionally releases the managed resources (Overrides IndexInput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Length | (Overrides IndexInput Length .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadByte | (Overrides IndexInput ReadByte .)
Public method | ReadBytes( Byte , Int32, Int32) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32).)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only BufferedIndexInput respects this parameter. (Inherited from IndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput Seek(Int64).)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to ReadChars( Char , Int32, Int32) but does not do any conversion operations on the bytes it is reading in. It still has to invoke ReadByte just as ReadChars( Char , Int32, Int32) does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | FilePointer | (Overrides IndexInput FilePointer.)
Back to Top
See Also
RAMInputStream Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMInputStream Constructor

RAMInputStream Constructor Lucene.Net Class Library
Initializes a new instance of the RAMInputStream class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RAMInputStream(
    RAMFile f
)
public RAMInputStream(
    RAMFile f
)
Public Sub New ( _
    f As RAMFile _
)
Public Sub New ( _
    f As RAMFile _
)
public:
RAMInputStream(
    RAMFile^ f
)
public:
RAMInputStream(
    RAMFile^ f
)
Parameters
f
Type: Lucene.Net.Store RAMFile
See Also
RAMInputStream Class
RAMInputStream Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMInputStream Methods

RAMInputStream Methods Lucene.Net Class Library
The RAMInputStream type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Returns a clone of this stream. Clones of a stream access the same data, and are positioned at the same point as the stream they were cloned from. Expert: Subclasses must ensure that clones may be positioned at different points in the input from each other and from the stream they were cloned from. (Inherited from IndexInput.)
Public method | Close | Obsolete. (Inherited from IndexInput.)
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | (Overrides IndexInput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Length | (Overrides IndexInput Length .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadByte | (Overrides IndexInput ReadByte .)
Public method | ReadBytes( Byte , Int32, Int32) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32).)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only BufferedIndexInput respects this parameter. (Inherited from IndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput Seek(Int64).)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to ReadChars( Char , Int32, Int32) but does not do any conversion operations on the bytes it is reading in. It still has to invoke ReadByte just as ReadChars( Char , Int32, Int32) does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RAMInputStream Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

RAMInputStream Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the RAMInputStream and optionally releases the managed resources (Overrides IndexInput Dispose(Boolean).)
Back to Top
See Also
RAMInputStream Class
RAMInputStream Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

RAMInputStream Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the RAMInputStream and optionally releases the managed resources

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
RAMInputStream Class
RAMInputStream Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Length Method

RAMInputStream Length Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Length()
public override long Length()
Public Overrides Function Length As Long
Public Overrides Function Length As Long
public:
virtual long long Length() override
public:
virtual long long Length() override
See Also
RAMInputStream Class
RAMInputStream Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadByte Method

RAMInputStream ReadByte Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override byte ReadByte()
public override byte ReadByte()
Public Overrides Function ReadByte As Byte
Public Overrides Function ReadByte As Byte
public:
virtual unsigned char ReadByte() override
public:
virtual unsigned char ReadByte() override
See Also
RAMInputStream Class
RAMInputStream Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadBytes Method

RAMInputStream ReadBytes Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ReadBytes( Byte , Int32, Int32) | (Overrides IndexInput ReadBytes( Byte , Int32, Int32).)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only BufferedIndexInput respects this parameter. (Inherited from IndexInput.)
Back to Top
See Also
RAMInputStream Class
RAMInputStream Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadBytes Method (Byte[], Int32, Int32)

RAMInputStream ReadBytes Method ( Byte , Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ReadBytes(
    byte[] b,
    int offset,
    int len
)
public override void ReadBytes(
    byte[] b,
    int offset,
    int len
)
Public Overrides Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Public Overrides Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) override
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) override
Parameters
b
Type:    Online System Byte
offset
Type:   Online System Int32
len
Type:   Online System Int32
See Also
RAMInputStream Class
RAMInputStream Members
ReadBytes Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method

RAMInputStream Seek Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Seek(
    long pos
)
public override void Seek(
    long pos
)
Public Overrides Sub Seek ( _
    pos As Long _
)
Public Overrides Sub Seek ( _
    pos As Long _
)
public:
virtual void Seek(
    long long pos
) override
public:
virtual void Seek(
    long long pos
) override
Parameters
pos
Type:   Online System Int64
See Also
RAMInputStream Class
RAMInputStream Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMInputStream Properties

RAMInputStream Properties Lucene.Net Class Library
The RAMInputStream type exposes the following members.
Properties
 | Name | Description
Public property | FilePointer | (Overrides IndexInput FilePointer.)
Back to Top
See Also
RAMInputStream Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilePointer Property

RAMInputStream FilePointer Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long FilePointer { get; }
public override long FilePointer { get; }
Public Overrides ReadOnly Property FilePointer As Long
    Get
Public Overrides ReadOnly Property FilePointer As Long
    Get
public:
virtual property long long FilePointer {
    long long get () override;
}
public:
virtual property long long FilePointer {
    long long get () override;
}
See Also
RAMInputStream Class
RAMInputStream Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMOutputStream Class

RAMOutputStream Class Lucene.Net Class Library
A memory-resident IndexOutput implementation.

For lucene internal use.

Inheritance Hierarchy
Online System Object
Lucene.Net.Store IndexOutput
Lucene.Net.Store RAMOutputStream

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RAMOutputStream : IndexOutput
public class RAMOutputStream : IndexOutput
Public Class RAMOutputStream _
    Inherits IndexOutput
Public Class RAMOutputStream _
    Inherits IndexOutput
public ref class RAMOutputStream : public IndexOutput
public ref class RAMOutputStream : public IndexOutput
See Also
RAMOutputStream Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMOutputStream Members

RAMOutputStream Members Lucene.Net Class Library

The RAMOutputStream type exposes the following members.
Constructors
 | Name | Description
Public method | RAMOutputStream | Construct an empty output buffer.
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Closes this stream to further operations. (Inherited from IndexOutput.)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Dispose | Closes this stream to further operations. (Inherited from IndexOutput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the RAMOutputStream and optionally releases the managed resources (Overrides IndexOutput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Overrides IndexOutput Flush .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Resets this to an empty buffer.
Public method | Seek | (Overrides IndexOutput Seek(Int64).)
Public method | SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for (Inherited from IndexOutput.)
Public method | SizeInBytes | Returns byte usage of all buffers.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteByte | (Overrides IndexOutput WriteByte(Byte).)
Public method | WriteBytes( Byte , Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes( Byte , Int32, Int32) | (Overrides IndexOutput WriteBytes( Byte , Int32, Int32).)
Public method | WriteChars( Char , Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteTo | Copy the current contents of this buffer to the named output.
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Back to Top
Properties
 | Name | Description
Public property | FilePointer | (Overrides IndexOutput FilePointer.)
Public property | Length | (Overrides IndexOutput Length.)
Back to Top
See Also
RAMOutputStream Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMOutputStream Constructor

RAMOutputStream Constructor Lucene.Net Class Library
Construct an empty output buffer.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RAMOutputStream()
public RAMOutputStream()
Public Sub New
Public Sub New
public:
RAMOutputStream()
public:
RAMOutputStream()
See Also
RAMOutputStream Class
RAMOutputStream Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMOutputStream Methods

RAMOutputStream Methods Lucene.Net Class Library
The RAMOutputStream type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Closes this stream to further operations. (Inherited from IndexOutput.)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Dispose | Closes this stream to further operations. (Inherited from IndexOutput.)
Protected method | Dispose(Boolean) | (Overrides IndexOutput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Overrides IndexOutput Flush .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset | Resets this to an empty buffer.
Public method | Seek | (Overrides IndexOutput Seek(Int64).)
Public method | SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for (Inherited from IndexOutput.)
Public method | SizeInBytes | Returns byte usage of all buffers.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteByte | (Overrides IndexOutput WriteByte(Byte).)
Public method | WriteBytes( Byte , Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes( Byte , Int32, Int32) | (Overrides IndexOutput WriteBytes( Byte , Int32, Int32).)
Public method | WriteChars( Char , Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteTo | Copy the current contents of this buffer to the named output.
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Back to Top
See Also
RAMOutputStream Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

RAMOutputStream Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes this stream to further operations. (Inherited from IndexOutput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the RAMOutputStream and optionally releases the managed resources (Overrides IndexOutput Dispose(Boolean).)
Back to Top
See Also
RAMOutputStream Class
RAMOutputStream Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

RAMOutputStream Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the RAMOutputStream and optionally releases the managed resources

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
RAMOutputStream Class
RAMOutputStream Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Flush Method

RAMOutputStream Flush Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Flush()
public override void Flush()
Public Overrides Sub Flush
Public Overrides Sub Flush
public:
virtual void Flush() override
public:
virtual void Flush() override
See Also
RAMOutputStream Class
RAMOutputStream Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method

RAMOutputStream Reset Method Lucene.Net Class Library
Resets this to an empty buffer.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Reset()
public virtual void Reset()
Public Overridable Sub Reset
Public Overridable Sub Reset
public:
virtual void Reset()
public:
virtual void Reset()
See Also
RAMOutputStream Class
RAMOutputStream Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method

RAMOutputStream Seek Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Seek(
    long pos
)
public override void Seek(
    long pos
)
Public Overrides Sub Seek ( _
    pos As Long _
)
Public Overrides Sub Seek ( _
    pos As Long _
)
public:
virtual void Seek(
    long long pos
) override
public:
virtual void Seek(
    long long pos
) override
Parameters
pos
Type:   Online System Int64
See Also
RAMOutputStream Class
RAMOutputStream Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SizeInBytes Method

RAMOutputStream SizeInBytes Method Lucene.Net Class Library
Returns byte usage of all buffers.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long SizeInBytes()
public virtual long SizeInBytes()
Public Overridable Function SizeInBytes As Long
Public Overridable Function SizeInBytes As Long
public:
virtual long long SizeInBytes()
public:
virtual long long SizeInBytes()
See Also
RAMOutputStream Class
RAMOutputStream Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteByte Method

RAMOutputStream WriteByte Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void WriteByte(
    byte b
)
public override void WriteByte(
    byte b
)
Public Overrides Sub WriteByte ( _
    b As Byte _
)
Public Overrides Sub WriteByte ( _
    b As Byte _
)
public:
virtual void WriteByte(
    unsigned char b
) override
public:
virtual void WriteByte(
    unsigned char b
) override
Parameters
b
Type:   Online System Byte
See Also
RAMOutputStream Class
RAMOutputStream Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteBytes Method

RAMOutputStream WriteBytes Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | WriteBytes( Byte , Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes( Byte , Int32, Int32) | (Overrides IndexOutput WriteBytes( Byte , Int32, Int32).)
Back to Top
See Also
RAMOutputStream Class
RAMOutputStream Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteBytes Method (Byte[], Int32, Int32)

RAMOutputStream WriteBytes Method ( Byte , Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void WriteBytes(
    byte[] b,
    int offset,
    int len
)
public override void WriteBytes(
    byte[] b,
    int offset,
    int len
)
Public Overrides Sub WriteBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Public Overrides Sub WriteBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
public:
virtual void WriteBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) override
public:
virtual void WriteBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) override
Parameters
b
Type:    Online System Byte
offset
Type:   Online System Int32
len
Type:   Online System Int32
See Also
RAMOutputStream Class
RAMOutputStream Members
WriteBytes Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WriteTo Method

RAMOutputStream WriteTo Method Lucene.Net Class Library
Copy the current contents of this buffer to the named output.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void WriteTo(
    IndexOutput out_Renamed
)
public virtual void WriteTo(
    IndexOutput out_Renamed
)
Public Overridable Sub WriteTo ( _
    out_Renamed As IndexOutput _
)
Public Overridable Sub WriteTo ( _
    out_Renamed As IndexOutput _
)
public:
virtual void WriteTo(
    IndexOutput^ out_Renamed
)
public:
virtual void WriteTo(
    IndexOutput^ out_Renamed
)
Parameters
out_Renamed
Type: Lucene.Net.Store IndexOutput
See Also
RAMOutputStream Class
RAMOutputStream Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RAMOutputStream Properties

RAMOutputStream Properties Lucene.Net Class Library
The RAMOutputStream type exposes the following members.
Properties
 | Name | Description
Public property | FilePointer | (Overrides IndexOutput FilePointer.)
Public property | Length | (Overrides IndexOutput Length.)
Back to Top
See Also
RAMOutputStream Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FilePointer Property

RAMOutputStream FilePointer Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long FilePointer { get; }
public override long FilePointer { get; }
Public Overrides ReadOnly Property FilePointer As Long
    Get
Public Overrides ReadOnly Property FilePointer As Long
    Get
public:
virtual property long long FilePointer {
    long long get () override;
}
public:
virtual property long long FilePointer {
    long long get () override;
}
See Also
RAMOutputStream Class
RAMOutputStream Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Length Property

RAMOutputStream Length Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Length { get; }
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
Public Overrides ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override;
}
public:
virtual property long long Length {
    long long get () override;
}
See Also
RAMOutputStream Class
RAMOutputStream Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory Class

SimpleFSDirectory Class Lucene.Net Class Library
A straightforward implementation of FSDirectory using java.io.RandomAccessFile. However, this class has poor concurrent performance (multiple threads will bottleneck) as it synchronizes when multiple threads read from the same file. It's usually better to use NIOFSDirectory or MMapDirectory instead.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store Directory
Lucene.Net.Store FSDirectory
Lucene.Net.Store SimpleFSDirectory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SimpleFSDirectory : FSDirectory
public class SimpleFSDirectory : FSDirectory
Public Class SimpleFSDirectory _
    Inherits FSDirectory
Public Class SimpleFSDirectory _
    Inherits FSDirectory
public ref class SimpleFSDirectory : public FSDirectory
public ref class SimpleFSDirectory : public FSDirectory
See Also
SimpleFSDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory Members

SimpleFSDirectory Members Lucene.Net Class Library

The SimpleFSDirectory type exposes the following members.
Constructors
 | Name | Description
Public method | SimpleFSDirectory(DirectoryInfo) | Create a new SimpleFSDirectory for the named location and the default lock factory.
Public method | SimpleFSDirectory(DirectoryInfo, LockFactory) | Create a new SimpleFSDirectory for the named location.
Back to Top
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Obsolete. (Inherited from Directory.)
Public method | CreateOutput | Creates an IndexOutput for the file with the given name. (Overrides Directory CreateOutput(String).)
Public method | DeleteFile | Removes an existing file in the directory. (Inherited from FSDirectory.)
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | (Inherited from FSDirectory.)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Inherited from FSDirectory.)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Inherited from FSDirectory.)
Public method | FileModified(String) | Returns the time the named file was last modified. (Inherited from FSDirectory.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLockId | (Inherited from FSDirectory.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InitOutput | Initializes the directory to create a new file with the given name. This method should be used in CreateOutput(String). (Inherited from FSDirectory.)
Public method | ListAll | Lists all files (not subdirectories) in the directory. (Inherited from FSDirectory.)
Public method | MakeLock | Construct a Lock. (Inherited from Directory.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenInput(String) | (Inherited from FSDirectory.)
Public method | OpenInput(String, Int32) | Creates an IndexInput for the file with the given name. (Overrides Directory OpenInput(String, Int32).)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | Sync | (Inherited from FSDirectory.)
Public method | ToString | For debug output. (Inherited from FSDirectory.)
Public method | TouchFile | Set the modified time of an existing file to now. (Inherited from FSDirectory.)
Back to Top
Fields
 | Name | Description
Protected field | interalLockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)
Protected field | internalDirectory | The underlying filesystem directory (Inherited from FSDirectory.)
Protected field | isOpen | (Inherited from Directory.)
Back to Top
Properties
 | Name | Description
Public property | Directory | (Inherited from FSDirectory.)
Public property | isOpen_ForNUnit | (Inherited from Directory.)
Public property | LockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public property | ReadChunkSize | The maximum number of bytes to read at once from the underlying file during ReadBytes( Byte , Int32, Int32). (Inherited from FSDirectory.)
Back to Top
See Also
SimpleFSDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory Constructor

SimpleFSDirectory Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | SimpleFSDirectory(DirectoryInfo) | Create a new SimpleFSDirectory for the named location and the default lock factory.
Public method | SimpleFSDirectory(DirectoryInfo, LockFactory) | Create a new SimpleFSDirectory for the named location.
Back to Top
See Also
SimpleFSDirectory Class
SimpleFSDirectory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory Constructor (DirectoryInfo)

SimpleFSDirectory Constructor (DirectoryInfo) Lucene.Net Class Library
Create a new SimpleFSDirectory for the named location and the default lock factory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SimpleFSDirectory(
    DirectoryInfo path
)
public SimpleFSDirectory(
    DirectoryInfo path
)
Public Sub New ( _
    path As DirectoryInfo _
)
Public Sub New ( _
    path As DirectoryInfo _
)
public:
SimpleFSDirectory(
    DirectoryInfo^ path
)
public:
SimpleFSDirectory(
    DirectoryInfo^ path
)
Parameters
path
Type:   Online System.IO DirectoryInfo
the path of the directory

See Also
SimpleFSDirectory Class
SimpleFSDirectory Members
SimpleFSDirectory Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory Constructor (DirectoryInfo, LockFactory)

SimpleFSDirectory Constructor (DirectoryInfo, LockFactory) Lucene.Net Class Library
Create a new SimpleFSDirectory for the named location.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SimpleFSDirectory(
    DirectoryInfo path,
    LockFactory lockFactory
)
public SimpleFSDirectory(
    DirectoryInfo path,
    LockFactory lockFactory
)
Public Sub New ( _
    path As DirectoryInfo, _
    lockFactory As LockFactory _
)
Public Sub New ( _
    path As DirectoryInfo, _
    lockFactory As LockFactory _
)
public:
SimpleFSDirectory(
    DirectoryInfo^ path,
    LockFactory^ lockFactory
)
public:
SimpleFSDirectory(
    DirectoryInfo^ path,
    LockFactory^ lockFactory
)
Parameters
path
Type:   Online System.IO DirectoryInfo
the path of the directory

lockFactory
Type: Lucene.Net.Store LockFactory
the lock factory to use, or null for the default.

See Also
SimpleFSDirectory Class
SimpleFSDirectory Members
SimpleFSDirectory Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory Fields

SimpleFSDirectory Fields Lucene.Net Class Library
The SimpleFSDirectory type exposes the following members.
Fields
 | Name | Description
Protected field | interalLockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)
Protected field | internalDirectory | The underlying filesystem directory (Inherited from FSDirectory.)
Protected field | isOpen | (Inherited from Directory.)
Back to Top
See Also
SimpleFSDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory Methods

SimpleFSDirectory Methods Lucene.Net Class Library
The SimpleFSDirectory type exposes the following members.
Methods
 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Obsolete. (Inherited from Directory.)
Public method | CreateOutput | Creates an IndexOutput for the file with the given name. (Overrides Directory CreateOutput(String).)
Public method | DeleteFile | Removes an existing file in the directory. (Inherited from FSDirectory.)
Public method | Dispose | Closes the store. (Inherited from Directory.)
Protected method | Dispose(Boolean) | (Inherited from FSDirectory.)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Inherited from FSDirectory.)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Inherited from FSDirectory.)
Public method | FileModified(String) | Returns the time the named file was last modified. (Inherited from FSDirectory.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetLockId | (Inherited from FSDirectory.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InitOutput | Initializes the directory to create a new file with the given name. This method should be used in CreateOutput(String). (Inherited from FSDirectory.)
Public method | ListAll | Lists all files (not subdirectories) in the directory. (Inherited from FSDirectory.)
Public method | MakeLock | Construct a Lock. (Inherited from Directory.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenInput(String) | (Inherited from FSDirectory.)
Public method | OpenInput(String, Int32) | Creates an IndexInput for the file with the given name. (Overrides Directory OpenInput(String, Int32).)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | Sync | (Inherited from FSDirectory.)
Public method | ToString | For debug output. (Inherited from FSDirectory.)
Public method | TouchFile | Set the modified time of an existing file to now. (Inherited from FSDirectory.)
Back to Top
See Also
SimpleFSDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateOutput Method

SimpleFSDirectory CreateOutput Method Lucene.Net Class Library
Creates an IndexOutput for the file with the given name.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexOutput CreateOutput(
    string name
)
public override IndexOutput CreateOutput(
    string name
)
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override
Parameters
name
Type:   Online System String
See Also
SimpleFSDirectory Class
SimpleFSDirectory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenInput Method

SimpleFSDirectory OpenInput Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | OpenInput(String) | (Inherited from FSDirectory.)
Public method | OpenInput(String, Int32) | Creates an IndexInput for the file with the given name. (Overrides Directory OpenInput(String, Int32).)
Back to Top
See Also
SimpleFSDirectory Class
SimpleFSDirectory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenInput Method (String, Int32)

SimpleFSDirectory OpenInput Method (String, Int32) Lucene.Net Class Library
Creates an IndexInput for the file with the given name.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IndexInput OpenInput(
    string name,
    int bufferSize
)
public override IndexInput OpenInput(
    string name,
    int bufferSize
)
Public Overrides Function OpenInput ( _
    name As String, _
    bufferSize As Integer _
) As IndexInput
Public Overrides Function OpenInput ( _
    name As String, _
    bufferSize As Integer _
) As IndexInput
public:
virtual IndexInput^ OpenInput(
    String^ name,
    int bufferSize
) override
public:
virtual IndexInput^ OpenInput(
    String^ name,
    int bufferSize
) override
Parameters
name
Type:   Online System String
bufferSize
Type:   Online System Int32
See Also
SimpleFSDirectory Class
SimpleFSDirectory Members
OpenInput Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory Properties

SimpleFSDirectory Properties Lucene.Net Class Library
The SimpleFSDirectory type exposes the following members.
Properties
 | Name | Description
Public property | Directory | (Inherited from FSDirectory.)
Public property | isOpen_ForNUnit | (Inherited from Directory.)
Public property | LockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public property | ReadChunkSize | The maximum number of bytes to read at once from the underlying file during ReadBytes( Byte , Int32, Int32). (Inherited from FSDirectory.)
Back to Top
See Also
SimpleFSDirectory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory.SimpleFSIndexInput Class

SimpleFSDirectory SimpleFSIndexInput Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Store IndexInput
Lucene.Net.Store BufferedIndexInput
Lucene.Net.Store SimpleFSDirectory SimpleFSIndexInput

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal class SimpleFSIndexInput : BufferedIndexInput
protected internal class SimpleFSIndexInput : BufferedIndexInput
Protected Friend Class SimpleFSIndexInput _
    Inherits BufferedIndexInput
Protected Friend Class SimpleFSIndexInput _
    Inherits BufferedIndexInput
protected public ref class SimpleFSIndexInput : public BufferedIndexInput
protected public ref class SimpleFSIndexInput : public BufferedIndexInput
See Also
SimpleFSDirectory SimpleFSIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory.SimpleFSIndexInput Members

SimpleFSDirectory SimpleFSIndexInput Members Lucene.Net Class Library

A straightforward implementation of FSDirectory using java.io.RandomAccessFile. However, this class has poor concurrent performance (multiple threads will bottleneck) as it synchronizes when multiple threads read from the same file. It's usually better to use NIOFSDirectory or MMapDirectory instead.

The SimpleFSDirectory SimpleFSIndexInput type exposes the following members.
Constructors
 | Name | Description
Public method | SimpleFSDirectory SimpleFSIndexInput | Initializes a new instance of the SimpleFSDirectory SimpleFSIndexInput class
Back to Top
Methods
 | Name | Description
Public method | Clone | (Overrides BufferedIndexInput Clone .)
Public method | Close | Obsolete. (Inherited from IndexInput.)
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SimpleFSDirectory SimpleFSIndexInput and optionally releases the managed resources (Overrides IndexInput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsFDValid | Method used for testing. Returns true if the underlying file descriptor is valid.
Public method | Length | (Overrides IndexInput Length .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | NewBuffer | (Inherited from BufferedIndexInput.)
Public method | ReadByte | (Inherited from BufferedIndexInput.)
Public method | ReadBytes( Byte , Int32, Int32) | (Inherited from BufferedIndexInput.)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | (Inherited from BufferedIndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadInternal | IndexInput methods (Overrides BufferedIndexInput ReadInternal( Byte , Int32, Int32).)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Inherited from BufferedIndexInput.)
Public method | SeekInternal | (Overrides BufferedIndexInput SeekInternal(Int64).)
Public method | SetBufferSize | Change the buffer size used by this IndexInput (Inherited from BufferedIndexInput.)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to ReadChars( Char , Int32, Int32) but does not do any conversion operations on the bytes it is reading in. It still has to invoke ReadByte just as ReadChars( Char , Int32, Int32) does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | buffer | (Inherited from BufferedIndexInput.)
Protected field | chunkSize |
Protected field | file |
Back to Top
Properties
 | Name | Description
Public property | BufferSize | (Inherited from BufferedIndexInput.)
Public property | FilePointer | (Inherited from BufferedIndexInput.)
Public property | isClone_ForNUnit |
Back to Top
See Also
SimpleFSDirectory SimpleFSIndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory.SimpleFSIndexInput Constructor

SimpleFSDirectory SimpleFSIndexInput Constructor Lucene.Net Class Library
Initializes a new instance of the SimpleFSDirectory SimpleFSIndexInput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SimpleFSIndexInput(
    FileInfo path,
    int bufferSize,
    int chunkSize
)
public SimpleFSIndexInput(
    FileInfo path,
    int bufferSize,
    int chunkSize
)
Public Sub New ( _
    path As FileInfo, _
    bufferSize As Integer, _
    chunkSize As Integer _
)
Public Sub New ( _
    path As FileInfo, _
    bufferSize As Integer, _
    chunkSize As Integer _
)
public:
SimpleFSIndexInput(
    FileInfo^ path,
    int bufferSize,
    int chunkSize
)
public:
SimpleFSIndexInput(
    FileInfo^ path,
    int bufferSize,
    int chunkSize
)
Parameters
path
Type:   Online System.IO FileInfo
bufferSize
Type:   Online System Int32
chunkSize
Type:   Online System Int32
See Also
SimpleFSDirectory SimpleFSIndexInput Class
SimpleFSDirectory SimpleFSIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory.SimpleFSIndexInput Fields

SimpleFSDirectory SimpleFSIndexInput Fields Lucene.Net Class Library
The SimpleFSDirectory SimpleFSIndexInput type exposes the following members.
Fields
 | Name | Description
Protected field | buffer | (Inherited from BufferedIndexInput.)
Protected field | chunkSize |
Protected field | file |
Back to Top
See Also
SimpleFSDirectory SimpleFSIndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


chunkSize Field

SimpleFSDirectory SimpleFSIndexInput chunkSize Field Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int chunkSize
protected int chunkSize
Protected chunkSize As Integer
Protected chunkSize As Integer
protected:
int chunkSize
protected:
int chunkSize
See Also
SimpleFSDirectory SimpleFSIndexInput Class
SimpleFSDirectory SimpleFSIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


file Field

SimpleFSDirectory SimpleFSIndexInput file Field Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor file
protected SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor file
Protected file As SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor
Protected file As SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor
protected:
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor^ file
protected:
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor^ file
See Also
SimpleFSDirectory SimpleFSIndexInput Class
SimpleFSDirectory SimpleFSIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory.SimpleFSIndexInput Methods

SimpleFSDirectory SimpleFSIndexInput Methods Lucene.Net Class Library
The SimpleFSDirectory SimpleFSIndexInput type exposes the following members.
Methods
 | Name | Description
Public method | Clone | (Overrides BufferedIndexInput Clone .)
Public method | Close | Obsolete. (Inherited from IndexInput.)
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | (Overrides IndexInput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsFDValid | Method used for testing. Returns true if the underlying file descriptor is valid.
Public method | Length | (Overrides IndexInput Length .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | NewBuffer | (Inherited from BufferedIndexInput.)
Public method | ReadByte | (Inherited from BufferedIndexInput.)
Public method | ReadBytes( Byte , Int32, Int32) | (Inherited from BufferedIndexInput.)
Public method | ReadBytes( Byte , Int32, Int32, Boolean) | (Inherited from BufferedIndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadInternal | IndexInput methods (Overrides BufferedIndexInput ReadInternal( Byte , Int32, Int32).)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Inherited from BufferedIndexInput.)
Public method | SeekInternal | (Overrides BufferedIndexInput SeekInternal(Int64).)
Public method | SetBufferSize | Change the buffer size used by this IndexInput (Inherited from BufferedIndexInput.)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to ReadChars( Char , Int32, Int32) but does not do any conversion operations on the bytes it is reading in. It still has to invoke ReadByte just as ReadChars( Char , Int32, Int32) does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SimpleFSDirectory SimpleFSIndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

SimpleFSDirectory SimpleFSIndexInput Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Clone()
public override Object Clone()
Public Overrides Function Clone As Object
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
public:
virtual Object^ Clone() override
Implements
  Online ICloneable Clone
  Online ICloneable Clone
See Also
SimpleFSDirectory SimpleFSIndexInput Class
SimpleFSDirectory SimpleFSIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

SimpleFSDirectory SimpleFSIndexInput Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes the stream to futher operations. (Inherited from IndexInput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SimpleFSDirectory SimpleFSIndexInput and optionally releases the managed resources (Overrides IndexInput Dispose(Boolean).)
Back to Top
See Also
SimpleFSDirectory SimpleFSIndexInput Class
SimpleFSDirectory SimpleFSIndexInput Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

SimpleFSDirectory SimpleFSIndexInput Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the SimpleFSDirectory SimpleFSIndexInput and optionally releases the managed resources

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
SimpleFSDirectory SimpleFSIndexInput Class
SimpleFSDirectory SimpleFSIndexInput Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsFDValid Method

SimpleFSDirectory SimpleFSIndexInput IsFDValid Method Lucene.Net Class Library
Method used for testing. Returns true if the underlying file descriptor is valid.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsFDValid()
public virtual bool IsFDValid()
Public Overridable Function IsFDValid As Boolean
Public Overridable Function IsFDValid As Boolean
public:
virtual bool IsFDValid()
public:
virtual bool IsFDValid()
See Also
SimpleFSDirectory SimpleFSIndexInput Class
SimpleFSDirectory SimpleFSIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Length Method

SimpleFSDirectory SimpleFSIndexInput Length Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Length()
public override long Length()
Public Overrides Function Length As Long
Public Overrides Function Length As Long
public:
virtual long long Length() override
public:
virtual long long Length() override
See Also
SimpleFSDirectory SimpleFSIndexInput Class
SimpleFSDirectory SimpleFSIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReadInternal Method

SimpleFSDirectory SimpleFSIndexInput ReadInternal Method Lucene.Net Class Library
IndexInput methods

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ReadInternal(
    byte[] b,
    int offset,
    int len
)
public override void ReadInternal(
    byte[] b,
    int offset,
    int len
)
Public Overrides Sub ReadInternal ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Public Overrides Sub ReadInternal ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
public:
virtual void ReadInternal(
    array<unsigned char>^ b,
    int offset,
    int len
) override
public:
virtual void ReadInternal(
    array<unsigned char>^ b,
    int offset,
    int len
) override
Parameters
b
Type:    Online System Byte
offset
Type:   Online System Int32
len
Type:   Online System Int32
See Also
SimpleFSDirectory SimpleFSIndexInput Class
SimpleFSDirectory SimpleFSIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SeekInternal Method

SimpleFSDirectory SimpleFSIndexInput SeekInternal Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SeekInternal(
    long position
)
public override void SeekInternal(
    long position
)
Public Overrides Sub SeekInternal ( _
    position As Long _
)
Public Overrides Sub SeekInternal ( _
    position As Long _
)
public:
virtual void SeekInternal(
    long long position
) override
public:
virtual void SeekInternal(
    long long position
) override
Parameters
position
Type:   Online System Int64
See Also
SimpleFSDirectory SimpleFSIndexInput Class
SimpleFSDirectory SimpleFSIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory.SimpleFSIndexInput Properties

SimpleFSDirectory SimpleFSIndexInput Properties Lucene.Net Class Library
The SimpleFSDirectory SimpleFSIndexInput type exposes the following members.
Properties
 | Name | Description
Public property | BufferSize | (Inherited from BufferedIndexInput.)
Public property | FilePointer | (Inherited from BufferedIndexInput.)
Public property | isClone_ForNUnit |
Back to Top
See Also
SimpleFSDirectory SimpleFSIndexInput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


isClone_ForNUnit Property

SimpleFSDirectory SimpleFSIndexInput isClone_ForNUnit Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool isClone_ForNUnit { get; }
public bool isClone_ForNUnit { get; }
Public ReadOnly Property isClone_ForNUnit As Boolean
    Get
Public ReadOnly Property isClone_ForNUnit As Boolean
    Get
public:
property bool isClone_ForNUnit {
    bool get ();
}
public:
property bool isClone_ForNUnit {
    bool get ();
}
See Also
SimpleFSDirectory SimpleFSIndexInput Class
SimpleFSDirectory SimpleFSIndexInput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory.SimpleFSIndexInput.Descriptor Class

SimpleFSDirectory SimpleFSIndexInput Descriptor Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Online System.IO BinaryReader
Lucene.Net.Store SimpleFSDirectory SimpleFSIndexInput Descriptor

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal class Descriptor : BinaryReader
protected internal class Descriptor : BinaryReader
Protected Friend Class Descriptor _
    Inherits BinaryReader
Protected Friend Class Descriptor _
    Inherits BinaryReader
protected public ref class Descriptor : public BinaryReader
protected public ref class Descriptor : public BinaryReader
See Also
SimpleFSDirectory SimpleFSIndexInput Descriptor Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory.SimpleFSIndexInput.Descriptor Members

SimpleFSDirectory SimpleFSIndexInput Descriptor Members Lucene.Net Class Library

The SimpleFSDirectory SimpleFSIndexInput Descriptor type exposes the following members.
Constructors
 | Name | Description
Public method | SimpleFSDirectory SimpleFSIndexInput Descriptor | Initializes a new instance of the SimpleFSDirectory SimpleFSIndexInput Descriptor class
Back to Top
Methods
 | Name | Description
Public method | Online Close | Closes the current reader and the underlying stream. (Inherited from Online BinaryReader.)
Public method | Online Dispose | Releases all resources used by the current instance of the Online BinaryReader class. (Inherited from Online BinaryReader.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SimpleFSDirectory SimpleFSIndexInput Descriptor and optionally releases the managed resources (Overrides Online BinaryReader Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online FillBuffer | Fills the internal buffer with the specified number of bytes read from the stream. (Inherited from Online BinaryReader.)
Protected method | Finalize | (Overrides Online Object Finalize .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online PeekChar | Returns the next available character and does not advance the byte or character position. (Inherited from Online BinaryReader.)
Public method | Online Read | Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from Online BinaryReader.)
Public method | Online Read( Char , Int32, Int32) | Reads the specified number of characters from the stream, starting from a specified point in the character array. (Inherited from Online BinaryReader.)
Public method | Online Read( Byte , Int32, Int32) | Reads the specified number of bytes from the stream, starting from a specified point in the byte array. (Inherited from Online BinaryReader.)
Protected method | Online Read7BitEncodedInt | Reads in a 32-bit integer in compressed format. (Inherited from Online BinaryReader.)
Public method | Online ReadBoolean | Reads a Boolean value from the current stream and advances the current position of the stream by one byte. (Inherited from Online BinaryReader.)
Public method | Online ReadByte | Reads the next byte from the current stream and advances the current position of the stream by one byte. (Inherited from Online BinaryReader.)
Public method | Online ReadBytes | Reads the specified number of bytes from the current stream into a byte array and advances the current position by that number of bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadChar | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from Online BinaryReader.)
Public method | Online ReadChars | Reads the specified number of characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream. (Inherited from Online BinaryReader.)
Public method | Online ReadDecimal | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadDouble | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadInt16 | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadInt32 | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadInt64 | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadSByte | Reads a signed byte from this stream and advances the current position of the stream by one byte. (Inherited from Online BinaryReader.)
Public method | Online ReadSingle | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadString | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time. (Inherited from Online BinaryReader.)
Public method | Online ReadUInt16 | Reads a 2-byte unsigned integer from the current stream using little-endian encoding and advances the position of the stream by two bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadUInt32 | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadUInt64 | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes. (Inherited from Online BinaryReader.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | isOpen |
Back to Top
Properties
 | Name | Description
Public property | Online BaseStream | Exposes access to the underlying stream of the Online BinaryReader. (Inherited from Online BinaryReader.)
Back to Top
See Also
SimpleFSDirectory SimpleFSIndexInput Descriptor Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory.SimpleFSIndexInput.Descriptor Constructor

SimpleFSDirectory SimpleFSIndexInput Descriptor Constructor Lucene.Net Class Library
Initializes a new instance of the SimpleFSDirectory SimpleFSIndexInput Descriptor class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Descriptor(
    FileInfo file,
    FileAccess mode
)
public Descriptor(
    FileInfo file,
    FileAccess mode
)
Public Sub New ( _
    file As FileInfo, _
    mode As FileAccess _
)
Public Sub New ( _
    file As FileInfo, _
    mode As FileAccess _
)
public:
Descriptor(
    FileInfo^ file,
    FileAccess mode
)
public:
Descriptor(
    FileInfo^ file,
    FileAccess mode
)
Parameters
file
Type:   Online System.IO FileInfo
mode
Type:   Online System.IO FileAccess
See Also
SimpleFSDirectory SimpleFSIndexInput Descriptor Class
SimpleFSDirectory SimpleFSIndexInput Descriptor Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory.SimpleFSIndexInput.Descriptor Fields

SimpleFSDirectory SimpleFSIndexInput Descriptor Fields Lucene.Net Class Library
The SimpleFSDirectory SimpleFSIndexInput Descriptor type exposes the following members.
Fields
 | Name | Description
Protected field | isOpen |
Back to Top
See Also
SimpleFSDirectory SimpleFSIndexInput Descriptor Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


isOpen Field

SimpleFSDirectory SimpleFSIndexInput Descriptor isOpen Field Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool isOpen
protected bool isOpen
Protected isOpen As Boolean
Protected isOpen As Boolean
protected:
bool isOpen
protected:
bool isOpen
See Also
SimpleFSDirectory SimpleFSIndexInput Descriptor Class
SimpleFSDirectory SimpleFSIndexInput Descriptor Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory.SimpleFSIndexInput.Descriptor Methods

SimpleFSDirectory SimpleFSIndexInput Descriptor Methods Lucene.Net Class Library
The SimpleFSDirectory SimpleFSIndexInput Descriptor type exposes the following members.
Methods
 | Name | Description
Public method | Online Close | Closes the current reader and the underlying stream. (Inherited from Online BinaryReader.)
Public method | Online Dispose | Releases all resources used by the current instance of the Online BinaryReader class. (Inherited from Online BinaryReader.)
Protected method | Dispose(Boolean) | (Overrides Online BinaryReader Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online FillBuffer | Fills the internal buffer with the specified number of bytes read from the stream. (Inherited from Online BinaryReader.)
Protected method | Finalize | (Overrides Online Object Finalize .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online PeekChar | Returns the next available character and does not advance the byte or character position. (Inherited from Online BinaryReader.)
Public method | Online Read | Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from Online BinaryReader.)
Public method | Online Read( Char , Int32, Int32) | Reads the specified number of characters from the stream, starting from a specified point in the character array. (Inherited from Online BinaryReader.)
Public method | Online Read( Byte , Int32, Int32) | Reads the specified number of bytes from the stream, starting from a specified point in the byte array. (Inherited from Online BinaryReader.)
Protected method | Online Read7BitEncodedInt | Reads in a 32-bit integer in compressed format. (Inherited from Online BinaryReader.)
Public method | Online ReadBoolean | Reads a Boolean value from the current stream and advances the current position of the stream by one byte. (Inherited from Online BinaryReader.)
Public method | Online ReadByte | Reads the next byte from the current stream and advances the current position of the stream by one byte. (Inherited from Online BinaryReader.)
Public method | Online ReadBytes | Reads the specified number of bytes from the current stream into a byte array and advances the current position by that number of bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadChar | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from Online BinaryReader.)
Public method | Online ReadChars | Reads the specified number of characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream. (Inherited from Online BinaryReader.)
Public method | Online ReadDecimal | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadDouble | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadInt16 | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadInt32 | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadInt64 | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadSByte | Reads a signed byte from this stream and advances the current position of the stream by one byte. (Inherited from Online BinaryReader.)
Public method | Online ReadSingle | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadString | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time. (Inherited from Online BinaryReader.)
Public method | Online ReadUInt16 | Reads a 2-byte unsigned integer from the current stream using little-endian encoding and advances the position of the stream by two bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadUInt32 | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes. (Inherited from Online BinaryReader.)
Public method | Online ReadUInt64 | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes. (Inherited from Online BinaryReader.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SimpleFSDirectory SimpleFSIndexInput Descriptor Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

SimpleFSDirectory SimpleFSIndexInput Descriptor Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Online Dispose | Releases all resources used by the current instance of the Online BinaryReader class. (Inherited from Online BinaryReader.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SimpleFSDirectory SimpleFSIndexInput Descriptor and optionally releases the managed resources (Overrides Online BinaryReader Dispose(Boolean).)
Back to Top
See Also
SimpleFSDirectory SimpleFSIndexInput Descriptor Class
SimpleFSDirectory SimpleFSIndexInput Descriptor Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

SimpleFSDirectory SimpleFSIndexInput Descriptor Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the SimpleFSDirectory SimpleFSIndexInput Descriptor and optionally releases the managed resources

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
SimpleFSDirectory SimpleFSIndexInput Descriptor Class
SimpleFSDirectory SimpleFSIndexInput Descriptor Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Finalize Method

SimpleFSDirectory SimpleFSIndexInput Descriptor Finalize Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Finalize()
protected override void Finalize()
Protected Overrides Sub Finalize
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override
protected:
virtual void Finalize() override
See Also
SimpleFSDirectory SimpleFSIndexInput Descriptor Class
SimpleFSDirectory SimpleFSIndexInput Descriptor Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory.SimpleFSIndexInput.Descriptor Properties

SimpleFSDirectory SimpleFSIndexInput Descriptor Properties Lucene.Net Class Library
The SimpleFSDirectory SimpleFSIndexInput Descriptor type exposes the following members.
Properties
 | Name | Description
Public property | Online BaseStream | Exposes access to the underlying stream of the Online BinaryReader. (Inherited from Online BinaryReader.)
Back to Top
See Also
SimpleFSDirectory SimpleFSIndexInput Descriptor Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory.SimpleFSIndexOutput Class

SimpleFSDirectory SimpleFSIndexOutput Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Store IndexOutput
Lucene.Net.Store BufferedIndexOutput
Lucene.Net.Store SimpleFSDirectory SimpleFSIndexOutput

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SimpleFSIndexOutput : BufferedIndexOutput
public class SimpleFSIndexOutput : BufferedIndexOutput
Public Class SimpleFSIndexOutput _
    Inherits BufferedIndexOutput
Public Class SimpleFSIndexOutput _
    Inherits BufferedIndexOutput
public ref class SimpleFSIndexOutput : public BufferedIndexOutput
public ref class SimpleFSIndexOutput : public BufferedIndexOutput
See Also
SimpleFSDirectory SimpleFSIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory.SimpleFSIndexOutput Members

SimpleFSDirectory SimpleFSIndexOutput Members Lucene.Net Class Library

A straightforward implementation of FSDirectory using java.io.RandomAccessFile. However, this class has poor concurrent performance (multiple threads will bottleneck) as it synchronizes when multiple threads read from the same file. It's usually better to use NIOFSDirectory or MMapDirectory instead.

The SimpleFSDirectory SimpleFSIndexOutput type exposes the following members.
Constructors
 | Name | Description
Public method | SimpleFSDirectory SimpleFSIndexOutput | Initializes a new instance of the SimpleFSDirectory SimpleFSIndexOutput class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Closes this stream to further operations. (Inherited from IndexOutput.)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Dispose | Closes this stream to further operations. (Inherited from IndexOutput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SimpleFSDirectory SimpleFSIndexOutput and optionally releases the managed resources (Overrides BufferedIndexOutput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | Forces any buffered output to be written. (Inherited from BufferedIndexOutput.)
Public method | FlushBuffer | output methods: (Overrides BufferedIndexOutput FlushBuffer( Byte , Int32, Int32).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Seek | Random-access methods (Overrides BufferedIndexOutput Seek(Int64).)
Public method | SetLength | (Overrides IndexOutput SetLength(Int64).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteByte | Writes a single byte. (Inherited from BufferedIndexOutput.)
Public method | WriteBytes( Byte , Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes( Byte , Int32, Int32) | Writes an array of bytes. (Inherited from BufferedIndexOutput.)
Public method | WriteChars( Char , Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Back to Top
Properties
 | Name | Description
Public property | FilePointer | Returns the current position in this file, where the next write will occur. (Inherited from BufferedIndexOutput.)
Public property | Length | (Overrides BufferedIndexOutput Length.)
Back to Top
See Also
SimpleFSDirectory SimpleFSIndexOutput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory.SimpleFSIndexOutput Constructor

SimpleFSDirectory SimpleFSIndexOutput Constructor Lucene.Net Class Library
Initializes a new instance of the SimpleFSDirectory SimpleFSIndexOutput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SimpleFSIndexOutput(
    FileInfo path
)
public SimpleFSIndexOutput(
    FileInfo path
)
Public Sub New ( _
    path As FileInfo _
)
Public Sub New ( _
    path As FileInfo _
)
public:
SimpleFSIndexOutput(
    FileInfo^ path
)
public:
SimpleFSIndexOutput(
    FileInfo^ path
)
Parameters
path
Type:   Online System.IO FileInfo
See Also
SimpleFSDirectory SimpleFSIndexOutput Class
SimpleFSDirectory SimpleFSIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory.SimpleFSIndexOutput Methods

SimpleFSDirectory SimpleFSIndexOutput Methods Lucene.Net Class Library
The SimpleFSDirectory SimpleFSIndexOutput type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Closes this stream to further operations. (Inherited from IndexOutput.)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Dispose | Closes this stream to further operations. (Inherited from IndexOutput.)
Protected method | Dispose(Boolean) | (Overrides BufferedIndexOutput Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | Forces any buffered output to be written. (Inherited from BufferedIndexOutput.)
Public method | FlushBuffer | output methods: (Overrides BufferedIndexOutput FlushBuffer( Byte , Int32, Int32).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Seek | Random-access methods (Overrides BufferedIndexOutput Seek(Int64).)
Public method | SetLength | (Overrides IndexOutput SetLength(Int64).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteByte | Writes a single byte. (Inherited from BufferedIndexOutput.)
Public method | WriteBytes( Byte , Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes( Byte , Int32, Int32) | Writes an array of bytes. (Inherited from BufferedIndexOutput.)
Public method | WriteChars( Char , Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Back to Top
See Also
SimpleFSDirectory SimpleFSIndexOutput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

SimpleFSDirectory SimpleFSIndexOutput Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Closes this stream to further operations. (Inherited from IndexOutput.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SimpleFSDirectory SimpleFSIndexOutput and optionally releases the managed resources (Overrides BufferedIndexOutput Dispose(Boolean).)
Back to Top
See Also
SimpleFSDirectory SimpleFSIndexOutput Class
SimpleFSDirectory SimpleFSIndexOutput Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

SimpleFSDirectory SimpleFSIndexOutput Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the SimpleFSDirectory SimpleFSIndexOutput and optionally releases the managed resources

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
SimpleFSDirectory SimpleFSIndexOutput Class
SimpleFSDirectory SimpleFSIndexOutput Members
Dispose Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FlushBuffer Method

SimpleFSDirectory SimpleFSIndexOutput FlushBuffer Method Lucene.Net Class Library
output methods:

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void FlushBuffer(
    byte[] b,
    int offset,
    int size
)
public override void FlushBuffer(
    byte[] b,
    int offset,
    int size
)
Public Overrides Sub FlushBuffer ( _
    b As Byte(), _
    offset As Integer, _
    size As Integer _
)
Public Overrides Sub FlushBuffer ( _
    b As Byte(), _
    offset As Integer, _
    size As Integer _
)
public:
virtual void FlushBuffer(
    array<unsigned char>^ b,
    int offset,
    int size
) override
public:
virtual void FlushBuffer(
    array<unsigned char>^ b,
    int offset,
    int size
) override
Parameters
b
Type:    Online System Byte
offset
Type:   Online System Int32
size
Type:   Online System Int32
See Also
SimpleFSDirectory SimpleFSIndexOutput Class
SimpleFSDirectory SimpleFSIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Seek Method

SimpleFSDirectory SimpleFSIndexOutput Seek Method Lucene.Net Class Library
Random-access methods

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Seek(
    long pos
)
public override void Seek(
    long pos
)
Public Overrides Sub Seek ( _
    pos As Long _
)
Public Overrides Sub Seek ( _
    pos As Long _
)
public:
virtual void Seek(
    long long pos
) override
public:
virtual void Seek(
    long long pos
) override
Parameters
pos
Type:   Online System Int64
See Also
SimpleFSDirectory SimpleFSIndexOutput Class
SimpleFSDirectory SimpleFSIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetLength Method

SimpleFSDirectory SimpleFSIndexOutput SetLength Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetLength(
    long length
)
public override void SetLength(
    long length
)
Public Overrides Sub SetLength ( _
    length As Long _
)
Public Overrides Sub SetLength ( _
    length As Long _
)
public:
virtual void SetLength(
    long long length
) override
public:
virtual void SetLength(
    long long length
) override
Parameters
length
Type:   Online System Int64
See Also
SimpleFSDirectory SimpleFSIndexOutput Class
SimpleFSDirectory SimpleFSIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSDirectory.SimpleFSIndexOutput Properties

SimpleFSDirectory SimpleFSIndexOutput Properties Lucene.Net Class Library
The SimpleFSDirectory SimpleFSIndexOutput type exposes the following members.
Properties
 | Name | Description
Public property | FilePointer | Returns the current position in this file, where the next write will occur. (Inherited from BufferedIndexOutput.)
Public property | Length | (Overrides BufferedIndexOutput Length.)
Back to Top
See Also
SimpleFSDirectory SimpleFSIndexOutput Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Length Property

SimpleFSDirectory SimpleFSIndexOutput Length Property Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Length { get; }
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
Public Overrides ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override;
}
public:
virtual property long long Length {
    long long get () override;
}
See Also
SimpleFSDirectory SimpleFSIndexOutput Class
SimpleFSDirectory SimpleFSIndexOutput Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSLockFactory Class

SimpleFSLockFactory Class Lucene.Net Class Library

Implements LockFactory using Online Create .

NOTE: the Online javadocs for File.createNewFile contain a vague yet spooky warning about not using the API for file locking. This warning was added due to Online this bug, and in fact the only known problem with using this API for locking is that the Lucene write lock may not be released when the JVM exits abnormally.

When this happens, a LockObtainFailedException is hit when trying to create a writer, in which case you need to explicitly clear the lock file first. You can either manually remove the file, or use the Unlock(Directory) API. But, first be certain that no writer is in fact writing to the index otherwise you can easily corrupt your index.

If you suspect that this or any other LockFactory is not working properly in your environment, you can easily test it by using VerifyingLockFactory, LockVerifyServer and LockStressTest.

Inheritance Hierarchy
Online System Object
Lucene.Net.Store LockFactory
Lucene.Net.Store FSLockFactory
Lucene.Net.Store SimpleFSLockFactory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SimpleFSLockFactory : FSLockFactory
public class SimpleFSLockFactory : FSLockFactory
Public Class SimpleFSLockFactory _
    Inherits FSLockFactory
Public Class SimpleFSLockFactory _
    Inherits FSLockFactory
public ref class SimpleFSLockFactory : public FSLockFactory
public ref class SimpleFSLockFactory : public FSLockFactory
See Also
SimpleFSLockFactory Members
Lucene.Net.Store Namespace
Lucene.Net.Store LockFactory
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSLockFactory Members

SimpleFSLockFactory Members Lucene.Net Class Library

The SimpleFSLockFactory type exposes the following members.
Constructors
 | Name | Description
Public method | SimpleFSLockFactory | Create a SimpleFSLockFactory instance, with null (unset) lock directory. When you pass this factory to a FSDirectory subclass, the lock directory is automatically set to the directory itsself. Be sure to create one instance for each directory your create!
Public method | SimpleFSLockFactory(DirectoryInfo) | Instantiate using the provided directory (as a File instance).
Public method | SimpleFSLockFactory(String) | Instantiate using the provided directory name (String).
Back to Top
Methods
 | Name | Description
Public method | ClearLock | (Overrides LockFactory ClearLock(String).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLock | (Overrides LockFactory MakeLock(String).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | internalLockDir | Directory for the lock files. (Inherited from FSLockFactory.)
Protected field | internalLockPrefix | (Inherited from LockFactory.)
Back to Top
Properties
 | Name | Description
Public property | LockDir | Gets the lock directory. Subclasses can use this to set the lock directory. This method can be only called once to initialize the lock directory. It is used by FSDirectory to set the lock directory to itsself. Subclasses can also use this method to set the directory in the constructor. (Inherited from FSLockFactory.)
Public property | LockPrefix | Gets or sets the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Back to Top
See Also
SimpleFSLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSLockFactory Constructor

SimpleFSLockFactory Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | SimpleFSLockFactory | Create a SimpleFSLockFactory instance, with null (unset) lock directory. When you pass this factory to a FSDirectory subclass, the lock directory is automatically set to the directory itsself. Be sure to create one instance for each directory your create!
Public method | SimpleFSLockFactory(DirectoryInfo) | Instantiate using the provided directory (as a File instance).
Public method | SimpleFSLockFactory(String) | Instantiate using the provided directory name (String).
Back to Top
See Also
SimpleFSLockFactory Class
SimpleFSLockFactory Members
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSLockFactory Constructor

SimpleFSLockFactory Constructor Lucene.Net Class Library
Create a SimpleFSLockFactory instance, with null (unset) lock directory. When you pass this factory to a FSDirectory subclass, the lock directory is automatically set to the directory itsself. Be sure to create one instance for each directory your create!

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SimpleFSLockFactory()
public SimpleFSLockFactory()
Public Sub New
Public Sub New
public:
SimpleFSLockFactory()
public:
SimpleFSLockFactory()
See Also
SimpleFSLockFactory Class
SimpleFSLockFactory Members
SimpleFSLockFactory Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSLockFactory Constructor (DirectoryInfo)

SimpleFSLockFactory Constructor (DirectoryInfo) Lucene.Net Class Library
Instantiate using the provided directory (as a File instance).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SimpleFSLockFactory(
    DirectoryInfo lockDir
)
public SimpleFSLockFactory(
    DirectoryInfo lockDir
)
Public Sub New ( _
    lockDir As DirectoryInfo _
)
Public Sub New ( _
    lockDir As DirectoryInfo _
)
public:
SimpleFSLockFactory(
    DirectoryInfo^ lockDir
)
public:
SimpleFSLockFactory(
    DirectoryInfo^ lockDir
)
Parameters
lockDir
Type:   Online System.IO DirectoryInfo
where lock files should be created.

See Also
SimpleFSLockFactory Class
SimpleFSLockFactory Members
SimpleFSLockFactory Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSLockFactory Constructor (String)

SimpleFSLockFactory Constructor (String) Lucene.Net Class Library
Instantiate using the provided directory name (String).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SimpleFSLockFactory(
    string lockDirName
)
public SimpleFSLockFactory(
    string lockDirName
)
Public Sub New ( _
    lockDirName As String _
)
Public Sub New ( _
    lockDirName As String _
)
public:
SimpleFSLockFactory(
    String^ lockDirName
)
public:
SimpleFSLockFactory(
    String^ lockDirName
)
Parameters
lockDirName
Type:   Online System String
where lock files should be created.

See Also
SimpleFSLockFactory Class
SimpleFSLockFactory Members
SimpleFSLockFactory Overload
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSLockFactory Fields

SimpleFSLockFactory Fields Lucene.Net Class Library
The SimpleFSLockFactory type exposes the following members.
Fields
 | Name | Description
Protected field | internalLockDir | Directory for the lock files. (Inherited from FSLockFactory.)
Protected field | internalLockPrefix | (Inherited from LockFactory.)
Back to Top
See Also
SimpleFSLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSLockFactory Methods

SimpleFSLockFactory Methods Lucene.Net Class Library
The SimpleFSLockFactory type exposes the following members.
Methods
 | Name | Description
Public method | ClearLock | (Overrides LockFactory ClearLock(String).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLock | (Overrides LockFactory MakeLock(String).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SimpleFSLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ClearLock Method

SimpleFSLockFactory ClearLock Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ClearLock(
    string lockName
)
public override void ClearLock(
    string lockName
)
Public Overrides Sub ClearLock ( _
    lockName As String _
)
Public Overrides Sub ClearLock ( _
    lockName As String _
)
public:
virtual void ClearLock(
    String^ lockName
) override
public:
virtual void ClearLock(
    String^ lockName
) override
Parameters
lockName
Type:   Online System String
See Also
SimpleFSLockFactory Class
SimpleFSLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MakeLock Method

SimpleFSLockFactory MakeLock Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Lock MakeLock(
    string lockName
)
public override Lock MakeLock(
    string lockName
)
Public Overrides Function MakeLock ( _
    lockName As String _
) As Lock
Public Overrides Function MakeLock ( _
    lockName As String _
) As Lock
public:
virtual Lock^ MakeLock(
    String^ lockName
) override
public:
virtual Lock^ MakeLock(
    String^ lockName
) override
Parameters
lockName
Type:   Online System String
See Also
SimpleFSLockFactory Class
SimpleFSLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleFSLockFactory Properties

SimpleFSLockFactory Properties Lucene.Net Class Library
The SimpleFSLockFactory type exposes the following members.
Properties
 | Name | Description
Public property | LockDir | Gets the lock directory. Subclasses can use this to set the lock directory. This method can be only called once to initialize the lock directory. It is used by FSDirectory to set the lock directory to itsself. Subclasses can also use this method to set the directory in the constructor. (Inherited from FSLockFactory.)
Public property | LockPrefix | Gets or sets the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Back to Top
See Also
SimpleFSLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SingleInstanceLockFactory Class

SingleInstanceLockFactory Class Lucene.Net Class Library
Implements LockFactory for a single in-process instance, meaning all locking will take place through this one instance. Only use this LockFactory when you are certain all IndexReaders and IndexWriters for a given index are running against a single shared in-process Directory instance. This is currently the default locking for RAMDirectory.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store LockFactory
Lucene.Net.Store SingleInstanceLockFactory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SingleInstanceLockFactory : LockFactory
public class SingleInstanceLockFactory : LockFactory
Public Class SingleInstanceLockFactory _
    Inherits LockFactory
Public Class SingleInstanceLockFactory _
    Inherits LockFactory
public ref class SingleInstanceLockFactory : public LockFactory
public ref class SingleInstanceLockFactory : public LockFactory
See Also
SingleInstanceLockFactory Members
Lucene.Net.Store Namespace
Lucene.Net.Store LockFactory
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SingleInstanceLockFactory Members

SingleInstanceLockFactory Members Lucene.Net Class Library

The SingleInstanceLockFactory type exposes the following members.
Constructors
 | Name | Description
Public method | SingleInstanceLockFactory | Initializes a new instance of the SingleInstanceLockFactory class
Back to Top
Methods
 | Name | Description
Public method | ClearLock | (Overrides LockFactory ClearLock(String).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLock | (Overrides LockFactory MakeLock(String).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | internalLockPrefix | (Inherited from LockFactory.)
Back to Top
Properties
 | Name | Description
Public property | LockPrefix | Gets or sets the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Back to Top
See Also
SingleInstanceLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SingleInstanceLockFactory Constructor

SingleInstanceLockFactory Constructor Lucene.Net Class Library
Initializes a new instance of the SingleInstanceLockFactory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SingleInstanceLockFactory()
public SingleInstanceLockFactory()
Public Sub New
Public Sub New
public:
SingleInstanceLockFactory()
public:
SingleInstanceLockFactory()
See Also
SingleInstanceLockFactory Class
SingleInstanceLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SingleInstanceLockFactory Fields

SingleInstanceLockFactory Fields Lucene.Net Class Library
The SingleInstanceLockFactory type exposes the following members.
Fields
 | Name | Description
Protected field | internalLockPrefix | (Inherited from LockFactory.)
Back to Top
See Also
SingleInstanceLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SingleInstanceLockFactory Methods

SingleInstanceLockFactory Methods Lucene.Net Class Library
The SingleInstanceLockFactory type exposes the following members.
Methods
 | Name | Description
Public method | ClearLock | (Overrides LockFactory ClearLock(String).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLock | (Overrides LockFactory MakeLock(String).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SingleInstanceLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ClearLock Method

SingleInstanceLockFactory ClearLock Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ClearLock(
    string lockName
)
public override void ClearLock(
    string lockName
)
Public Overrides Sub ClearLock ( _
    lockName As String _
)
Public Overrides Sub ClearLock ( _
    lockName As String _
)
public:
virtual void ClearLock(
    String^ lockName
) override
public:
virtual void ClearLock(
    String^ lockName
) override
Parameters
lockName
Type:   Online System String
See Also
SingleInstanceLockFactory Class
SingleInstanceLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MakeLock Method

SingleInstanceLockFactory MakeLock Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Lock MakeLock(
    string lockName
)
public override Lock MakeLock(
    string lockName
)
Public Overrides Function MakeLock ( _
    lockName As String _
) As Lock
Public Overrides Function MakeLock ( _
    lockName As String _
) As Lock
public:
virtual Lock^ MakeLock(
    String^ lockName
) override
public:
virtual Lock^ MakeLock(
    String^ lockName
) override
Parameters
lockName
Type:   Online System String
See Also
SingleInstanceLockFactory Class
SingleInstanceLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SingleInstanceLockFactory Properties

SingleInstanceLockFactory Properties Lucene.Net Class Library
The SingleInstanceLockFactory type exposes the following members.
Properties
 | Name | Description
Public property | LockPrefix | Gets or sets the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Back to Top
See Also
SingleInstanceLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


VerifyingLockFactory Class

VerifyingLockFactory Class Lucene.Net Class Library
A LockFactory that wraps another LockFactory and verifies that each lock obtain/release is "correct" (never results in two processes holding the lock at the same time). It does this by contacting an external server (LockVerifyServer) to assert that at most one process holds the lock at a time. To use this, you should also run LockVerifyServer on the host & port matching what you pass to the constructor.
Inheritance Hierarchy
Online System Object
Lucene.Net.Store LockFactory
Lucene.Net.Store VerifyingLockFactory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class VerifyingLockFactory : LockFactory
public class VerifyingLockFactory : LockFactory
Public Class VerifyingLockFactory _
    Inherits LockFactory
Public Class VerifyingLockFactory _
    Inherits LockFactory
public ref class VerifyingLockFactory : public LockFactory
public ref class VerifyingLockFactory : public LockFactory
See Also
VerifyingLockFactory Members
Lucene.Net.Store Namespace
Lucene.Net.Store LockVerifyServer
Lucene.Net.Store LockStressTest
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


VerifyingLockFactory Members

VerifyingLockFactory Members Lucene.Net Class Library

The VerifyingLockFactory type exposes the following members.
Constructors
 | Name | Description
Public method | VerifyingLockFactory | Initializes a new instance of the VerifyingLockFactory class
Back to Top
Methods
 | Name | Description
Public method | ClearLock | (Overrides LockFactory ClearLock(String).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLock | (Overrides LockFactory MakeLock(String).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Protected field | internalLockPrefix | (Inherited from LockFactory.)
Back to Top
Properties
 | Name | Description
Public property | LockPrefix | Gets or sets the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Back to Top
See Also
VerifyingLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


VerifyingLockFactory Constructor

VerifyingLockFactory Constructor Lucene.Net Class Library
Initializes a new instance of the VerifyingLockFactory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public VerifyingLockFactory(
    sbyte id,
    LockFactory lf,
    string host,
    int port
)
public VerifyingLockFactory(
    sbyte id,
    LockFactory lf,
    string host,
    int port
)
Public Sub New ( _
    id As SByte, _
    lf As LockFactory, _
    host As String, _
    port As Integer _
)
Public Sub New ( _
    id As SByte, _
    lf As LockFactory, _
    host As String, _
    port As Integer _
)
public:
VerifyingLockFactory(
    signed char id,
    LockFactory^ lf,
    String^ host,
    int port
)
public:
VerifyingLockFactory(
    signed char id,
    LockFactory^ lf,
    String^ host,
    int port
)
Parameters
id
Type:   Online System SByte
should be a unique id across all clients

lf
Type: Lucene.Net.Store LockFactory
the LockFactory that we are testing

host
Type:   Online System String
host or IP where LockVerifyServer
            is running

port
Type:   Online System Int32
the port LockVerifyServer is
            listening on

See Also
VerifyingLockFactory Class
VerifyingLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


VerifyingLockFactory Fields

VerifyingLockFactory Fields Lucene.Net Class Library
The VerifyingLockFactory type exposes the following members.
Fields
 | Name | Description
Protected field | internalLockPrefix | (Inherited from LockFactory.)
Back to Top
See Also
VerifyingLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


VerifyingLockFactory Methods

VerifyingLockFactory Methods Lucene.Net Class Library
The VerifyingLockFactory type exposes the following members.
Methods
 | Name | Description
Public method | ClearLock | (Overrides LockFactory ClearLock(String).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLock | (Overrides LockFactory MakeLock(String).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
VerifyingLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ClearLock Method

VerifyingLockFactory ClearLock Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ClearLock(
    string lockName
)
public override void ClearLock(
    string lockName
)
Public Overrides Sub ClearLock ( _
    lockName As String _
)
Public Overrides Sub ClearLock ( _
    lockName As String _
)
public:
virtual void ClearLock(
    String^ lockName
) override
public:
virtual void ClearLock(
    String^ lockName
) override
Parameters
lockName
Type:   Online System String
See Also
VerifyingLockFactory Class
VerifyingLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MakeLock Method

VerifyingLockFactory MakeLock Method Lucene.Net Class Library

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Lock MakeLock(
    string lockName
)
public override Lock MakeLock(
    string lockName
)
Public Overrides Function MakeLock ( _
    lockName As String _
) As Lock
Public Overrides Function MakeLock ( _
    lockName As String _
) As Lock
public:
virtual Lock^ MakeLock(
    String^ lockName
) override
public:
virtual Lock^ MakeLock(
    String^ lockName
) override
Parameters
lockName
Type:   Online System String
See Also
VerifyingLockFactory Class
VerifyingLockFactory Members
Lucene.Net.Store Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


VerifyingLockFactory Properties

VerifyingLockFactory Properties Lucene.Net Class Library
The VerifyingLockFactory type exposes the following members.
Properties
 | Name | Description
Public property | LockPrefix | Gets or sets the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Back to Top
See Also
VerifyingLockFactory Class
Lucene.Net.Store Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lucene.Net.Support Namespace

Lucene.Net.Support Namespace Lucene.Net Class Library
Classes
Class | Description
Public class AppSettings
Public class BitSetSupport
This class provides supporting methods of java.util.BitSet that are not present in System.Collections.BitArray.
Public class | BuildType
Public class Character
Mimics Java's Character class.
Public class CloseableThreadLocalProfiler
For Debuging purposes.
Public class CollectionsHelper
Support class used to handle Hashtable addition, which does a check first to make sure the added item is unique in the hash.
Public class Compare
Summary description for TestSupportClass.
Public class | CRC32
Public class | Cryptography
Public class | Deflater
Public class Double
Public class EquatableList T
Represents a strongly typed list of objects that can be accessed by index. Provides methods to search, sort, and manipulate lists. Also provides functionality to compare lists against each other through an implementations of Online IEquatable T .
Public class FileSupport
Represents the methods to support some operations over files.
Public class HashMap TKey, TValue
A C# emulation of the Online Java Hashmap

A Online Dictionary TKey, TValue is a close equivalent to the Java Hashmap. One difference java implementation of the class is that the Hashmap supports both null keys and values, where the C# Dictionary only supports null values not keys. Also, V Get(TKey) method in Java returns null if the key doesn't exist, instead of throwing an exception. This implementation doesn't throw an exception when a key doesn't exist, it will return null. This class is slower than using a Online Dictionary TKey, TValue , because of extra checks that have to be done on each access, to check for null.

NOTE: This class works best with nullable types. default(T) is returned when a key doesn't exist in the collection (this being similar to how Java returns null). Therefore, if the expected behavior of the java code is to execute code based on if the key exists, when the key is an integer type, it will return 0 instead of null.

Consider also implementing IDictionary, IEnumerable, and ICollection like Online Dictionary TKey, TValue does, so HashMap can be used in substituted in place for the same interfaces it implements.
Public class | Inflater
Public class Number
A simple class for number conversions.
Public class OS
Provides platform infos.
Public class | SharpZipLib
Public class Single
Public class | TextSupport
Public class ThreadClass
Support class used to handle threads
Public class ThreadLock
Abstract base class that provides a synchronization interface for derived lock types
Public class | WeakDictionary TKey, TValue
Interfaces
 | Interface | Description
Public interface | IChecksum | Contains conversion support elements such as classes, interfaces and static methods.
Public interface | IThreadRunnable | This interface should be implemented by any class whose instances are intended to be executed by a thread.

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AppSettings Class

AppSettings Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Support AppSettings

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AppSettings
public class AppSettings
Public Class AppSettings
Public Class AppSettings
public ref class AppSettings
public ref class AppSettings
See Also
AppSettings Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AppSettings Members

AppSettings Members Lucene.Net Class Library

The AppSettings type exposes the following members.
Constructors
 | Name | Description
Public method | AppSettings | Initializes a new instance of the AppSettings class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | Get(String, Boolean) |
 | Get(String, Int32) |
 | Get(String, Int64) |
 | Get(String, String) |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Set(String, Boolean) |
 | Set(String, Int32) |
 | Set(String, Int64) |
 | Set(String, String) |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AppSettings Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AppSettings Constructor

AppSettings Constructor Lucene.Net Class Library
Initializes a new instance of the AppSettings class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AppSettings()
public AppSettings()
Public Sub New
Public Sub New
public:
AppSettings()
public:
AppSettings()
See Also
AppSettings Class
AppSettings Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AppSettings Methods

AppSettings Methods Lucene.Net Class Library
The AppSettings type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | Get(String, Boolean) |
 | Get(String, Int32) |
 | Get(String, Int64) |
 | Get(String, String) |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Set(String, Boolean) |
 | Set(String, Int32) |
 | Set(String, Int64) |
 | Set(String, String) |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AppSettings Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method

AppSettings Get Method Lucene.Net Class Library
Overload List
Name | Description
Get(String, Boolean) |
Get(String, Int32) |
Get(String, Int64) |
Get(String, String) |
Back to Top
See Also
AppSettings Class
AppSettings Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method (String, Boolean)

AppSettings Get Method (String, Boolean) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool Get(
    string key,
    bool defValue
)
public static bool Get(
    string key,
    bool defValue
)
Public Shared Function Get ( _
    key As String, _
    defValue As Boolean _
) As Boolean
Public Shared Function Get ( _
    key As String, _
    defValue As Boolean _
) As Boolean
public:
static bool Get(
    String^ key,
    bool defValue
)
public:
static bool Get(
    String^ key,
    bool defValue
)
Parameters
key
Type:   Online System String
defValue
Type:   Online System Boolean
See Also
AppSettings Class
AppSettings Members
Get Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method (String, Int32)

AppSettings Get Method (String, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Get(
    string key,
    int defValue
)
public static int Get(
    string key,
    int defValue
)
Public Shared Function Get ( _
    key As String, _
    defValue As Integer _
) As Integer
Public Shared Function Get ( _
    key As String, _
    defValue As Integer _
) As Integer
public:
static int Get(
    String^ key,
    int defValue
)
public:
static int Get(
    String^ key,
    int defValue
)
Parameters
key
Type:   Online System String
defValue
Type:   Online System Int32
Return Value
See Also
AppSettings Class
AppSettings Members
Get Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method (String, Int64)

AppSettings Get Method (String, Int64) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long Get(
    string key,
    long defValue
)
public static long Get(
    string key,
    long defValue
)
Public Shared Function Get ( _
    key As String, _
    defValue As Long _
) As Long
Public Shared Function Get ( _
    key As String, _
    defValue As Long _
) As Long
public:
static long long Get(
    String^ key,
    long long defValue
)
public:
static long long Get(
    String^ key,
    long long defValue
)
Parameters
key
Type:   Online System String
defValue
Type:   Online System Int64
Return Value
See Also
AppSettings Class
AppSettings Members
Get Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method (String, String)

AppSettings Get Method (String, String) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Get(
    string key,
    string defValue
)
public static string Get(
    string key,
    string defValue
)
Public Shared Function Get ( _
    key As String, _
    defValue As String _
) As String
Public Shared Function Get ( _
    key As String, _
    defValue As String _
) As String
public:
static String^ Get(
    String^ key,
    String^ defValue
)
public:
static String^ Get(
    String^ key,
    String^ defValue
)
Parameters
key
Type:   Online System String
defValue
Type:   Online System String
Return Value
See Also
AppSettings Class
AppSettings Members
Get Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Set Method

AppSettings Set Method Lucene.Net Class Library
Overload List
Name | Description
Set(String, Boolean) |
Set(String, Int32) |
Set(String, Int64) |
Set(String, String) |
Back to Top
See Also
AppSettings Class
AppSettings Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Set Method (String, Boolean)

AppSettings Set Method (String, Boolean) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Set(
    string key,
    bool defValue
)
public static void Set(
    string key,
    bool defValue
)
Public Shared Sub Set ( _
    key As String, _
    defValue As Boolean _
)
Public Shared Sub Set ( _
    key As String, _
    defValue As Boolean _
)
public:
static void Set(
    String^ key,
    bool defValue
)
public:
static void Set(
    String^ key,
    bool defValue
)
Parameters
key
Type:   Online System String
defValue
Type:   Online System Boolean
See Also
AppSettings Class
AppSettings Members
Set Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Set Method (String, Int32)

AppSettings Set Method (String, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Set(
    string key,
    int defValue
)
public static void Set(
    string key,
    int defValue
)
Public Shared Sub Set ( _
    key As String, _
    defValue As Integer _
)
Public Shared Sub Set ( _
    key As String, _
    defValue As Integer _
)
public:
static void Set(
    String^ key,
    int defValue
)
public:
static void Set(
    String^ key,
    int defValue
)
Parameters
key
Type:   Online System String
defValue
Type:   Online System Int32
See Also
AppSettings Class
AppSettings Members
Set Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Set Method (String, Int64)

AppSettings Set Method (String, Int64) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Set(
    string key,
    long defValue
)
public static void Set(
    string key,
    long defValue
)
Public Shared Sub Set ( _
    key As String, _
    defValue As Long _
)
Public Shared Sub Set ( _
    key As String, _
    defValue As Long _
)
public:
static void Set(
    String^ key,
    long long defValue
)
public:
static void Set(
    String^ key,
    long long defValue
)
Parameters
key
Type:   Online System String
defValue
Type:   Online System Int64
See Also
AppSettings Class
AppSettings Members
Set Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Set Method (String, String)

AppSettings Set Method (String, String) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Set(
    string key,
    string defValue
)
public static void Set(
    string key,
    string defValue
)
Public Shared Sub Set ( _
    key As String, _
    defValue As String _
)
Public Shared Sub Set ( _
    key As String, _
    defValue As String _
)
public:
static void Set(
    String^ key,
    String^ defValue
)
public:
static void Set(
    String^ key,
    String^ defValue
)
Parameters
key
Type:   Online System String
defValue
Type:   Online System String
See Also
AppSettings Class
AppSettings Members
Set Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitSetSupport Class

BitSetSupport Class Lucene.Net Class Library
This class provides supporting methods of java.util.BitSet that are not present in System.Collections.BitArray.
Inheritance Hierarchy
Online System Object
Lucene.Net.Support BitSetSupport

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class BitSetSupport
public class BitSetSupport
Public Class BitSetSupport
Public Class BitSetSupport
public ref class BitSetSupport
public ref class BitSetSupport
See Also
BitSetSupport Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitSetSupport Members

BitSetSupport Members Lucene.Net Class Library

The BitSetSupport type exposes the following members.
Constructors
 | Name | Description
Public method | BitSetSupport | Initializes a new instance of the BitSetSupport class
Back to Top
Methods
 | Name | Description
 | Cardinality | Returns the number of bits set to true in this BitSet.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | NextClearBit | Returns the next un-set bit at or after index, or -1 if no such bit exists.
 | NextSetBit | Returns the next set bit at or after index, or -1 if no such bit exists.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
BitSetSupport Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitSetSupport Constructor

BitSetSupport Constructor Lucene.Net Class Library
Initializes a new instance of the BitSetSupport class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BitSetSupport()
public BitSetSupport()
Public Sub New
Public Sub New
public:
BitSetSupport()
public:
BitSetSupport()
See Also
BitSetSupport Class
BitSetSupport Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitSetSupport Methods

BitSetSupport Methods Lucene.Net Class Library
The BitSetSupport type exposes the following members.
Methods
 | Name | Description
 | Cardinality | Returns the number of bits set to true in this BitSet.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | NextClearBit | Returns the next un-set bit at or after index, or -1 if no such bit exists.
 | NextSetBit | Returns the next set bit at or after index, or -1 if no such bit exists.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
BitSetSupport Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Cardinality Method

BitSetSupport Cardinality Method Lucene.Net Class Library
Returns the number of bits set to true in this BitSet.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Cardinality(
    BitArray bits
)
public static int Cardinality(
    BitArray bits
)
Public Shared Function Cardinality ( _
    bits As BitArray _
) As Integer
Public Shared Function Cardinality ( _
    bits As BitArray _
) As Integer
public:
static int Cardinality(
    BitArray^ bits
)
public:
static int Cardinality(
    BitArray^ bits
)
Parameters
bits
Type:   Online System.Collections BitArray
The BitArray object.
Return Value
The number of bits set to true in this BitSet.
See Also
BitSetSupport Class
BitSetSupport Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextClearBit Method

BitSetSupport NextClearBit Method Lucene.Net Class Library
Returns the next un-set bit at or after index, or -1 if no such bit exists.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int NextClearBit(
    BitArray bitArray,
    int index
)
public static int NextClearBit(
    BitArray bitArray,
    int index
)
Public Shared Function NextClearBit ( _
    bitArray As BitArray, _
    index As Integer _
) As Integer
Public Shared Function NextClearBit ( _
    bitArray As BitArray, _
    index As Integer _
) As Integer
public:
static int NextClearBit(
    BitArray^ bitArray,
    int index
)
public:
static int NextClearBit(
    BitArray^ bitArray,
    int index
)
Parameters
bitArray
Type:   Online System.Collections BitArray
index
Type:   Online System Int32
the index of bit array at which to start checking
Return Value
the next set bit or -1
See Also
BitSetSupport Class
BitSetSupport Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextSetBit Method

BitSetSupport NextSetBit Method Lucene.Net Class Library
Returns the next set bit at or after index, or -1 if no such bit exists.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int NextSetBit(
    BitArray bitArray,
    int index
)
public static int NextSetBit(
    BitArray bitArray,
    int index
)
Public Shared Function NextSetBit ( _
    bitArray As BitArray, _
    index As Integer _
) As Integer
Public Shared Function NextSetBit ( _
    bitArray As BitArray, _
    index As Integer _
) As Integer
public:
static int NextSetBit(
    BitArray^ bitArray,
    int index
)
public:
static int NextSetBit(
    BitArray^ bitArray,
    int index
)
Parameters
bitArray
Type:   Online System.Collections BitArray
index
Type:   Online System Int32
the index of bit array at which to start checking
Return Value
the next set bit or -1
See Also
BitSetSupport Class
BitSetSupport Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BuildType Class

BuildType Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Support BuildType

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class BuildType
public class BuildType
Public Class BuildType
Public Class BuildType
public ref class BuildType
public ref class BuildType
See Also
BuildType Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BuildType Members

BuildType Members Lucene.Net Class Library

The BuildType type exposes the following members.
Constructors
 | Name | Description
Public method | BuildType | Initializes a new instance of the BuildType class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Debug |
Back to Top
See Also
BuildType Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BuildType Constructor

BuildType Constructor Lucene.Net Class Library
Initializes a new instance of the BuildType class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BuildType()
public BuildType()
Public Sub New
Public Sub New
public:
BuildType()
public:
BuildType()
See Also
BuildType Class
BuildType Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BuildType Fields

BuildType Fields Lucene.Net Class Library
The BuildType type exposes the following members.
Fields
Name | Description
Debug |
Back to Top
See Also
BuildType Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Debug Field

BuildType Debug Field Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool Debug
public static bool Debug
Public Shared Debug As Boolean
Public Shared Debug As Boolean
public:
static bool Debug
public:
static bool Debug
See Also
BuildType Class
BuildType Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BuildType Methods

BuildType Methods Lucene.Net Class Library
The BuildType type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
BuildType Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Character Class

Character Class Lucene.Net Class Library
Mimics Java's Character class.
Inheritance Hierarchy
Online System Object
Lucene.Net.Support Character

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Character
public class Character
Public Class Character
Public Class Character
public ref class Character
public ref class Character
See Also
Character Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Character Members

Character Members Lucene.Net Class Library

The Character type exposes the following members.
Constructors
 | Name | Description
Public method | Character | Initializes a new instance of the Character class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | ForDigit |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
Name | Description
MAX_RADIX |
MIN_RADIX |
Back to Top
See Also
Character Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Character Constructor

Character Constructor Lucene.Net Class Library
Initializes a new instance of the Character class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Character()
public Character()
Public Sub New
Public Sub New
public:
Character()
public:
Character()
See Also
Character Class
Character Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Character Methods

Character Methods Lucene.Net Class Library
The Character type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | ForDigit |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Character Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ForDigit Method

Character ForDigit Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static char ForDigit(
    int digit,
    int radix
)
public static char ForDigit(
    int digit,
    int radix
)
Public Shared Function ForDigit ( _
    digit As Integer, _
    radix As Integer _
) As Char
Public Shared Function ForDigit ( _
    digit As Integer, _
    radix As Integer _
) As Char
public:
static wchar_t ForDigit(
    int digit,
    int radix
)
public:
static wchar_t ForDigit(
    int digit,
    int radix
)
Parameters
digit
Type:   Online System Int32
radix
Type:   Online System Int32
Return Value
See Also
Character Class
Character Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Character Properties

Character Properties Lucene.Net Class Library
The Character type exposes the following members.
Properties
Name | Description
MAX_RADIX |
MIN_RADIX |
Back to Top
See Also
Character Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MAX_RADIX Property

Character MAX_RADIX Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int MAX_RADIX { get; }
public static int MAX_RADIX { get; }
Public Shared ReadOnly Property MAX_RADIX As Integer
    Get
Public Shared ReadOnly Property MAX_RADIX As Integer
    Get
public:
static property int MAX_RADIX {
    int get ();
}
public:
static property int MAX_RADIX {
    int get ();
}
See Also
Character Class
Character Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MIN_RADIX Property

Character MIN_RADIX Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int MIN_RADIX { get; }
public static int MIN_RADIX { get; }
Public Shared ReadOnly Property MIN_RADIX As Integer
    Get
Public Shared ReadOnly Property MIN_RADIX As Integer
    Get
public:
static property int MIN_RADIX {
    int get ();
}
public:
static property int MIN_RADIX {
    int get ();
}
See Also
Character Class
Character Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CloseableThreadLocalProfiler Class

CloseableThreadLocalProfiler Class Lucene.Net Class Library
For Debuging purposes.
Inheritance Hierarchy
Online System Object
Lucene.Net.Support CloseableThreadLocalProfiler

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CloseableThreadLocalProfiler
public class CloseableThreadLocalProfiler
Public Class CloseableThreadLocalProfiler
Public Class CloseableThreadLocalProfiler
public ref class CloseableThreadLocalProfiler
public ref class CloseableThreadLocalProfiler
See Also
CloseableThreadLocalProfiler Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CloseableThreadLocalProfiler Members

CloseableThreadLocalProfiler Members Lucene.Net Class Library

The CloseableThreadLocalProfiler type exposes the following members.
Constructors
 | Name | Description
Public method | CloseableThreadLocalProfiler | Initializes a new instance of the CloseableThreadLocalProfiler class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
Instances |
Back to Top
Properties
Name | Description
EnableCloseableThreadLocalProfiler |
Back to Top
See Also
CloseableThreadLocalProfiler Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CloseableThreadLocalProfiler Constructor

CloseableThreadLocalProfiler Constructor Lucene.Net Class Library
Initializes a new instance of the CloseableThreadLocalProfiler class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CloseableThreadLocalProfiler()
public CloseableThreadLocalProfiler()
Public Sub New
Public Sub New
public:
CloseableThreadLocalProfiler()
public:
CloseableThreadLocalProfiler()
See Also
CloseableThreadLocalProfiler Class
CloseableThreadLocalProfiler Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CloseableThreadLocalProfiler Fields

CloseableThreadLocalProfiler Fields Lucene.Net Class Library
The CloseableThreadLocalProfiler type exposes the following members.
Fields
Name | Description
Instances |
Back to Top
See Also
CloseableThreadLocalProfiler Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Instances Field

CloseableThreadLocalProfiler Instances Field Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static List<WeakReference> Instances
public static List<WeakReference> Instances
Public Shared Instances As List(Of WeakReference)
Public Shared Instances As List(Of WeakReference)
public:
static List<WeakReference^>^ Instances
public:
static List<WeakReference^>^ Instances
See Also
CloseableThreadLocalProfiler Class
CloseableThreadLocalProfiler Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CloseableThreadLocalProfiler Methods

CloseableThreadLocalProfiler Methods Lucene.Net Class Library
The CloseableThreadLocalProfiler type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CloseableThreadLocalProfiler Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CloseableThreadLocalProfiler Properties

CloseableThreadLocalProfiler Properties Lucene.Net Class Library
The CloseableThreadLocalProfiler type exposes the following members.
Properties
Name | Description
EnableCloseableThreadLocalProfiler |
Back to Top
See Also
CloseableThreadLocalProfiler Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EnableCloseableThreadLocalProfiler Property

CloseableThreadLocalProfiler EnableCloseableThreadLocalProfiler Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool EnableCloseableThreadLocalProfiler { get; set; }
public static bool EnableCloseableThreadLocalProfiler { get; set; }
Public Shared Property EnableCloseableThreadLocalProfiler As Boolean
    Get
    Set
Public Shared Property EnableCloseableThreadLocalProfiler As Boolean
    Get
    Set
public:
static property bool EnableCloseableThreadLocalProfiler {
    bool get ();
    void set (bool value);
}
public:
static property bool EnableCloseableThreadLocalProfiler {
    bool get ();
    void set (bool value);
}
See Also
CloseableThreadLocalProfiler Class
CloseableThreadLocalProfiler Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CollectionsHelper Class

CollectionsHelper Class Lucene.Net Class Library
Support class used to handle Hashtable addition, which does a check first to make sure the added item is unique in the hash.
Inheritance Hierarchy
Online System Object
Lucene.Net.Support CollectionsHelper

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CollectionsHelper
public class CollectionsHelper
Public Class CollectionsHelper
Public Class CollectionsHelper
public ref class CollectionsHelper
public ref class CollectionsHelper
See Also
CollectionsHelper Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CollectionsHelper Members

CollectionsHelper Members Lucene.Net Class Library

The CollectionsHelper type exposes the following members.
Constructors
 | Name | Description
Public method | CollectionsHelper | Initializes a new instance of the CollectionsHelper class
Back to Top
Methods
 | Name | Description
 | Add |
 | AddAll(IDictionary String, String , ICollection String ) |
 | AddAll(Hashtable, ICollection) |
 | AddAllIfNotContains(IDictionary String, String , ICollection String ) |
 | AddAllIfNotContains(Hashtable, ICollection) |
 | AddAllIfNotContains(Hashtable, IList) |
 | AddIfNotContains(ArrayList, Object) |
 | AddIfNotContains(Hashtable, Object) |
 | CollectionToString(IDictionary String, String ) |
 | CollectionToString(ICollection) | Converts the specified collection to its string representation.
 | CompareStringArrays | Compares two string arrays for equality.
 | Contains(ICollection String , String) |
 | Contains(ICollection, Object) |
Public method | Online Equals(Object) | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
 | Equals(Array, Array) | Compares the entire members of one array whith the other one.
 | Fill(Array, Object) | Fills the array with an specific value.
 | Fill(Array, Int32, Int32, Object) | Fills the array with an specific value from an specific index to an specific index.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Sort | Sorts an IList collections
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CollectionsHelper Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CollectionsHelper Constructor

CollectionsHelper Constructor Lucene.Net Class Library
Initializes a new instance of the CollectionsHelper class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CollectionsHelper()
public CollectionsHelper()
Public Sub New
Public Sub New
public:
CollectionsHelper()
public:
CollectionsHelper()
See Also
CollectionsHelper Class
CollectionsHelper Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CollectionsHelper Methods

CollectionsHelper Methods Lucene.Net Class Library
The CollectionsHelper type exposes the following members.
Methods
 | Name | Description
 | Add |
 | AddAll(IDictionary String, String , ICollection String ) |
 | AddAll(Hashtable, ICollection) |
 | AddAllIfNotContains(IDictionary String, String , ICollection String ) |
 | AddAllIfNotContains(Hashtable, ICollection) |
 | AddAllIfNotContains(Hashtable, IList) |
 | AddIfNotContains(ArrayList, Object) |
 | AddIfNotContains(Hashtable, Object) |
 | CollectionToString(IDictionary String, String ) |
 | CollectionToString(ICollection) | Converts the specified collection to its string representation.
 | CompareStringArrays | Compares two string arrays for equality.
 | Contains(ICollection String , String) |
 | Contains(ICollection, Object) |
Public method | Online Equals(Object) | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
 | Equals(Array, Array) | Compares the entire members of one array whith the other one.
 | Fill(Array, Object) | Fills the array with an specific value.
 | Fill(Array, Int32, Int32, Object) | Fills the array with an specific value from an specific index to an specific index.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Sort | Sorts an IList collections
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CollectionsHelper Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method

CollectionsHelper Add Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Add(
    Hashtable hashtable,
    Object item
)
public static void Add(
    Hashtable hashtable,
    Object item
)
Public Shared Sub Add ( _
    hashtable As Hashtable, _
    item As Object _
)
Public Shared Sub Add ( _
    hashtable As Hashtable, _
    item As Object _
)
public:
static void Add(
    Hashtable^ hashtable,
    Object^ item
)
public:
static void Add(
    Hashtable^ hashtable,
    Object^ item
)
Parameters
hashtable
Type:   Online System.Collections Hashtable
item
Type:   Online System Object
See Also
CollectionsHelper Class
CollectionsHelper Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddAll Method

CollectionsHelper AddAll Method Lucene.Net Class Library
Overload List
Name | Description
AddAll(IDictionary String, String , ICollection String ) |
AddAll(Hashtable, ICollection) |
Back to Top
See Also
CollectionsHelper Class
CollectionsHelper Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddAll Method (IDictionary(String, String), ICollection(String))

CollectionsHelper AddAll Method (IDictionary String, String , ICollection String ) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AddAll(
    IDictionary<string, string> hashtable,
    ICollection<string> items
)
public static void AddAll(
    IDictionary<string, string> hashtable,
    ICollection<string> items
)
Public Shared Sub AddAll ( _
    hashtable As IDictionary(Of String, String), _
    items As ICollection(Of String) _
)
Public Shared Sub AddAll ( _
    hashtable As IDictionary(Of String, String), _
    items As ICollection(Of String) _
)
public:
static void AddAll(
    IDictionary<String^, String^>^ hashtable,
    ICollection<String^>^ items
)
public:
static void AddAll(
    IDictionary<String^, String^>^ hashtable,
    ICollection<String^>^ items
)
Parameters
hashtable
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
items
Type:   Online System.Collections.Generic ICollection    Online String
See Also
CollectionsHelper Class
CollectionsHelper Members
AddAll Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddAll Method (Hashtable, ICollection)

CollectionsHelper AddAll Method (Hashtable, ICollection) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AddAll(
    Hashtable hashtable,
    ICollection items
)
public static void AddAll(
    Hashtable hashtable,
    ICollection items
)
Public Shared Sub AddAll ( _
    hashtable As Hashtable, _
    items As ICollection _
)
Public Shared Sub AddAll ( _
    hashtable As Hashtable, _
    items As ICollection _
)
public:
static void AddAll(
    Hashtable^ hashtable,
    ICollection^ items
)
public:
static void AddAll(
    Hashtable^ hashtable,
    ICollection^ items
)
Parameters
hashtable
Type:   Online System.Collections Hashtable
items
Type:   Online System.Collections ICollection
See Also
CollectionsHelper Class
CollectionsHelper Members
AddAll Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddAllIfNotContains Method

CollectionsHelper AddAllIfNotContains Method Lucene.Net Class Library
Overload List
Name | Description
AddAllIfNotContains(IDictionary String, String , ICollection String ) |
AddAllIfNotContains(Hashtable, ICollection) |
AddAllIfNotContains(Hashtable, IList) |
Back to Top
See Also
CollectionsHelper Class
CollectionsHelper Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddAllIfNotContains Method (IDictionary(String, String), ICollection(String))

CollectionsHelper AddAllIfNotContains Method (IDictionary String, String , ICollection String ) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AddAllIfNotContains(
    IDictionary<string, string> hashtable,
    ICollection<string> items
)
public static void AddAllIfNotContains(
    IDictionary<string, string> hashtable,
    ICollection<string> items
)
Public Shared Sub AddAllIfNotContains ( _
    hashtable As IDictionary(Of String, String), _
    items As ICollection(Of String) _
)
Public Shared Sub AddAllIfNotContains ( _
    hashtable As IDictionary(Of String, String), _
    items As ICollection(Of String) _
)
public:
static void AddAllIfNotContains(
    IDictionary<String^, String^>^ hashtable,
    ICollection<String^>^ items
)
public:
static void AddAllIfNotContains(
    IDictionary<String^, String^>^ hashtable,
    ICollection<String^>^ items
)
Parameters
hashtable
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
items
Type:   Online System.Collections.Generic ICollection    Online String
See Also
CollectionsHelper Class
CollectionsHelper Members
AddAllIfNotContains Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddAllIfNotContains Method (Hashtable, ICollection)

CollectionsHelper AddAllIfNotContains Method (Hashtable, ICollection) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AddAllIfNotContains(
    Hashtable hashtable,
    ICollection items
)
public static void AddAllIfNotContains(
    Hashtable hashtable,
    ICollection items
)
Public Shared Sub AddAllIfNotContains ( _
    hashtable As Hashtable, _
    items As ICollection _
)
Public Shared Sub AddAllIfNotContains ( _
    hashtable As Hashtable, _
    items As ICollection _
)
public:
static void AddAllIfNotContains(
    Hashtable^ hashtable,
    ICollection^ items
)
public:
static void AddAllIfNotContains(
    Hashtable^ hashtable,
    ICollection^ items
)
Parameters
hashtable
Type:   Online System.Collections Hashtable
items
Type:   Online System.Collections ICollection
See Also
CollectionsHelper Class
CollectionsHelper Members
AddAllIfNotContains Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddAllIfNotContains Method (Hashtable, IList)

CollectionsHelper AddAllIfNotContains Method (Hashtable, IList) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AddAllIfNotContains(
    Hashtable hashtable,
    IList items
)
public static void AddAllIfNotContains(
    Hashtable hashtable,
    IList items
)
Public Shared Sub AddAllIfNotContains ( _
    hashtable As Hashtable, _
    items As IList _
)
Public Shared Sub AddAllIfNotContains ( _
    hashtable As Hashtable, _
    items As IList _
)
public:
static void AddAllIfNotContains(
    Hashtable^ hashtable,
    IList^ items
)
public:
static void AddAllIfNotContains(
    Hashtable^ hashtable,
    IList^ items
)
Parameters
hashtable
Type:   Online System.Collections Hashtable
items
Type:   Online System.Collections IList
See Also
CollectionsHelper Class
CollectionsHelper Members
AddAllIfNotContains Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddIfNotContains Method

CollectionsHelper AddIfNotContains Method Lucene.Net Class Library
Overload List
Name | Description
AddIfNotContains(ArrayList, Object) |
AddIfNotContains(Hashtable, Object) |
Back to Top
See Also
CollectionsHelper Class
CollectionsHelper Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddIfNotContains Method (ArrayList, Object)

CollectionsHelper AddIfNotContains Method (ArrayList, Object) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AddIfNotContains(
    ArrayList hashtable,
    Object item
)
public static void AddIfNotContains(
    ArrayList hashtable,
    Object item
)
Public Shared Sub AddIfNotContains ( _
    hashtable As ArrayList, _
    item As Object _
)
Public Shared Sub AddIfNotContains ( _
    hashtable As ArrayList, _
    item As Object _
)
public:
static void AddIfNotContains(
    ArrayList^ hashtable,
    Object^ item
)
public:
static void AddIfNotContains(
    ArrayList^ hashtable,
    Object^ item
)
Parameters
hashtable
Type:   Online System.Collections ArrayList
item
Type:   Online System Object
See Also
CollectionsHelper Class
CollectionsHelper Members
AddIfNotContains Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddIfNotContains Method (Hashtable, Object)

CollectionsHelper AddIfNotContains Method (Hashtable, Object) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AddIfNotContains(
    Hashtable hashtable,
    Object item
)
public static void AddIfNotContains(
    Hashtable hashtable,
    Object item
)
Public Shared Sub AddIfNotContains ( _
    hashtable As Hashtable, _
    item As Object _
)
Public Shared Sub AddIfNotContains ( _
    hashtable As Hashtable, _
    item As Object _
)
public:
static void AddIfNotContains(
    Hashtable^ hashtable,
    Object^ item
)
public:
static void AddIfNotContains(
    Hashtable^ hashtable,
    Object^ item
)
Parameters
hashtable
Type:   Online System.Collections Hashtable
item
Type:   Online System Object
See Also
CollectionsHelper Class
CollectionsHelper Members
AddIfNotContains Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CollectionToString Method

CollectionsHelper CollectionToString Method Lucene.Net Class Library
Overload List
Name | Description
CollectionToString(IDictionary String, String ) |
CollectionToString(ICollection) | Converts the specified collection to its string representation.
Back to Top
See Also
CollectionsHelper Class
CollectionsHelper Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CollectionToString Method (IDictionary(String, String))

CollectionsHelper CollectionToString Method (IDictionary String, String ) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string CollectionToString(
    IDictionary<string, string> c
)
public static string CollectionToString(
    IDictionary<string, string> c
)
Public Shared Function CollectionToString ( _
    c As IDictionary(Of String, String) _
) As String
Public Shared Function CollectionToString ( _
    c As IDictionary(Of String, String) _
) As String
public:
static String^ CollectionToString(
    IDictionary<String^, String^>^ c
)
public:
static String^ CollectionToString(
    IDictionary<String^, String^>^ c
)
Parameters
c
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
See Also
CollectionsHelper Class
CollectionsHelper Members
CollectionToString Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CollectionToString Method (ICollection)

CollectionsHelper CollectionToString Method (ICollection) Lucene.Net Class Library
Converts the specified collection to its string representation.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string CollectionToString(
    ICollection c
)
public static string CollectionToString(
    ICollection c
)
Public Shared Function CollectionToString ( _
    c As ICollection _
) As String
Public Shared Function CollectionToString ( _
    c As ICollection _
) As String
public:
static String^ CollectionToString(
    ICollection^ c
)
public:
static String^ CollectionToString(
    ICollection^ c
)
Parameters
c
Type:   Online System.Collections ICollection
The collection to convert to string.
Return Value
A string representation of the specified collection.
See Also
CollectionsHelper Class
CollectionsHelper Members
CollectionToString Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompareStringArrays Method

CollectionsHelper CompareStringArrays Method Lucene.Net Class Library
Compares two string arrays for equality.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool CompareStringArrays(
    string[] l1,
    string[] l2
)
public static bool CompareStringArrays(
    string[] l1,
    string[] l2
)
Public Shared Function CompareStringArrays ( _
    l1 As String(), _
    l2 As String() _
) As Boolean
Public Shared Function CompareStringArrays ( _
    l1 As String(), _
    l2 As String() _
) As Boolean
public:
static bool CompareStringArrays(
    array<String^>^ l1,
    array<String^>^ l2
)
public:
static bool CompareStringArrays(
    array<String^>^ l1,
    array<String^>^ l2
)
Parameters
l1
Type:    Online System String
First string array list to compare
l2
Type:    Online System String
Second string array list to compare
Return Value
true if the strings are equal in both arrays, false otherwise
See Also
CollectionsHelper Class
CollectionsHelper Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Contains Method

CollectionsHelper Contains Method Lucene.Net Class Library
Overload List
Name | Description
Contains(ICollection String , String) |
Contains(ICollection, Object) |
Back to Top
See Also
CollectionsHelper Class
CollectionsHelper Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Contains Method (ICollection(String), String)

CollectionsHelper Contains Method (ICollection String , String) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool Contains(
    ICollection<string> col,
    string item
)
public static bool Contains(
    ICollection<string> col,
    string item
)
Public Shared Function Contains ( _
    col As ICollection(Of String), _
    item As String _
) As Boolean
Public Shared Function Contains ( _
    col As ICollection(Of String), _
    item As String _
) As Boolean
public:
static bool Contains(
    ICollection<String^>^ col,
    String^ item
)
public:
static bool Contains(
    ICollection<String^>^ col,
    String^ item
)
Parameters
col
Type:   Online System.Collections.Generic ICollection    Online String
item
Type:   Online System String
See Also
CollectionsHelper Class
CollectionsHelper Members
Contains Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Contains Method (ICollection, Object)

CollectionsHelper Contains Method (ICollection, Object) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool Contains(
    ICollection col,
    Object item
)
public static bool Contains(
    ICollection col,
    Object item
)
Public Shared Function Contains ( _
    col As ICollection, _
    item As Object _
) As Boolean
Public Shared Function Contains ( _
    col As ICollection, _
    item As Object _
) As Boolean
public:
static bool Contains(
    ICollection^ col,
    Object^ item
)
public:
static bool Contains(
    ICollection^ col,
    Object^ item
)
Parameters
col
Type:   Online System.Collections ICollection
item
Type:   Online System Object
See Also
CollectionsHelper Class
CollectionsHelper Members
Contains Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

CollectionsHelper Equals Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Online Equals(Object) | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
 | Equals(Array, Array) | Compares the entire members of one array whith the other one.
Back to Top
See Also
CollectionsHelper Class
CollectionsHelper Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method (Array, Array)

CollectionsHelper Equals Method (Array, Array) Lucene.Net Class Library
Compares the entire members of one array whith the other one.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool Equals(
    Array array1,
    Array array2
)
public static bool Equals(
    Array array1,
    Array array2
)
Public Shared Function Equals ( _
    array1 As Array, _
    array2 As Array _
) As Boolean
Public Shared Function Equals ( _
    array1 As Array, _
    array2 As Array _
) As Boolean
public:
static bool Equals(
    Array^ array1,
    Array^ array2
)
public:
static bool Equals(
    Array^ array1,
    Array^ array2
)
Parameters
array1
Type:   Online System Array
The array to be compared.
array2
Type:   Online System Array
The array to be compared with.
Return Value
Returns true if the two specified arrays of Objects are equal
            to one another. The two arrays are considered equal if both arrays
            contain the same number of elements, and all corresponding pairs of
            elements in the two arrays are equal. Two objects e1 and e2 are
            considered equal if (e1==null ? e2==null : e1.equals(e2)). In other
            words, the two arrays are equal if they contain the same elements in
            the same order. Also, two array references are considered equal if
            both are null.
See Also
CollectionsHelper Class
CollectionsHelper Members
Equals Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Fill Method

CollectionsHelper Fill Method Lucene.Net Class Library
Overload List
Name | Description
Fill(Array, Object) | Fills the array with an specific value.
Fill(Array, Int32, Int32, Object) | Fills the array with an specific value from an specific index to an specific index.
Back to Top
See Also
CollectionsHelper Class
CollectionsHelper Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Fill Method (Array, Object)

CollectionsHelper Fill Method (Array, Object) Lucene.Net Class Library
Fills the array with an specific value.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Fill(
    Array array,
    Object val
)
public static void Fill(
    Array array,
    Object val
)
Public Shared Sub Fill ( _
    array As Array, _
    val As Object _
)
Public Shared Sub Fill ( _
    array As Array, _
    val As Object _
)
public:
static void Fill(
    Array^ array,
    Object^ val
)
public:
static void Fill(
    Array^ array,
    Object^ val
)
Parameters
array
Type:   Online System Array
The array to be filled.
val
Type:   Online System Object
The value to fill the array with.
See Also
CollectionsHelper Class
CollectionsHelper Members
Fill Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Fill Method (Array, Int32, Int32, Object)

CollectionsHelper Fill Method (Array, Int32, Int32, Object) Lucene.Net Class Library
Fills the array with an specific value from an specific index to an specific index.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Fill(
    Array array,
    int fromindex,
    int toindex,
    Object val
)
public static void Fill(
    Array array,
    int fromindex,
    int toindex,
    Object val
)
Public Shared Sub Fill ( _
    array As Array, _
    fromindex As Integer, _
    toindex As Integer, _
    val As Object _
)
Public Shared Sub Fill ( _
    array As Array, _
    fromindex As Integer, _
    toindex As Integer, _
    val As Object _
)
public:
static void Fill(
    Array^ array,
    int fromindex,
    int toindex,
    Object^ val
)
public:
static void Fill(
    Array^ array,
    int fromindex,
    int toindex,
    Object^ val
)
Parameters
array
Type:   Online System Array
The array to be filled.
fromindex
Type:   Online System Int32
The first index to be filled.
toindex
Type:   Online System Int32
The last index to be filled.
val
Type:   Online System Object
The value to fill the array with.
See Also
CollectionsHelper Class
CollectionsHelper Members
Fill Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Sort Method

CollectionsHelper Sort Method Lucene.Net Class Library
Sorts an IList collections

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Sort(
    IList list,
    IComparer Comparator
)
public static void Sort(
    IList list,
    IComparer Comparator
)
Public Shared Sub Sort ( _
    list As IList, _
    Comparator As IComparer _
)
Public Shared Sub Sort ( _
    list As IList, _
    Comparator As IComparer _
)
public:
static void Sort(
    IList^ list,
    IComparer^ Comparator
)
public:
static void Sort(
    IList^ list,
    IComparer^ Comparator
)
Parameters
list
Type:   Online System.Collections IList
The System.Collections.IList instance that will be sorted
Comparator
Type:   Online System.Collections IComparer
The Comparator criteria, null to use natural comparator.
See Also
CollectionsHelper Class
CollectionsHelper Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Class

Compare Class Lucene.Net Class Library
Summary description for TestSupportClass.
Inheritance Hierarchy
Online System Object
Lucene.Net.Support Compare

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Compare
public class Compare
Public Class Compare
Public Class Compare
public ref class Compare
public ref class Compare
See Also
Compare Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Members

Compare Members Lucene.Net Class Library

The Compare type exposes the following members.
Constructors
 | Name | Description
Public method | Compare | Initializes a new instance of the Compare class
Back to Top
Methods
 | Name | Description
 | CompareTermArrays | Compares two Term arrays for equality.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Compare Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Constructor

Compare Constructor Lucene.Net Class Library
Initializes a new instance of the Compare class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Compare()
public Compare()
Public Sub New
Public Sub New
public:
Compare()
public:
Compare()
See Also
Compare Class
Compare Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Methods

Compare Methods Lucene.Net Class Library
The Compare type exposes the following members.
Methods
 | Name | Description
 | CompareTermArrays | Compares two Term arrays for equality.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Compare Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CompareTermArrays Method

Compare CompareTermArrays Method Lucene.Net Class Library
Compares two Term arrays for equality.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool CompareTermArrays(
    Term[] t1,
    Term[] t2
)
public static bool CompareTermArrays(
    Term[] t1,
    Term[] t2
)
Public Shared Function CompareTermArrays ( _
    t1 As Term(), _
    t2 As Term() _
) As Boolean
Public Shared Function CompareTermArrays ( _
    t1 As Term(), _
    t2 As Term() _
) As Boolean
public:
static bool CompareTermArrays(
    array<Term^>^ t1,
    array<Term^>^ t2
)
public:
static bool CompareTermArrays(
    array<Term^>^ t1,
    array<Term^>^ t2
)
Parameters
t1
Type:  Lucene.Net.Index Term
First Term array to compare
t2
Type:  Lucene.Net.Index Term
Second Term array to compare
Return Value
true if the Terms are equal in both arrays, false otherwise
See Also
Compare Class
Compare Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CRC32 Class

CRC32 Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Support CRC32

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CRC32 : IChecksum
public class CRC32 : IChecksum
Public Class CRC32 _
    Implements IChecksum
Public Class CRC32 _
    Implements IChecksum
public ref class CRC32 : IChecksum
public ref class CRC32 : IChecksum
See Also
CRC32 Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CRC32 Members

CRC32 Members Lucene.Net Class Library

The CRC32 type exposes the following members.
Constructors
 | Name | Description
Public method | CRC32 | Initializes a new instance of the CRC32 class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Update( Byte ) |
Public method | Update(Int32) |
Public method | Update( Byte , Int32, Int32) |
Back to Top
Properties
 | Name | Description
Public property | Value |
Back to Top
See Also
CRC32 Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CRC32 Constructor

CRC32 Constructor Lucene.Net Class Library
Initializes a new instance of the CRC32 class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRC32()
public CRC32()
Public Sub New
Public Sub New
public:
CRC32()
public:
CRC32()
See Also
CRC32 Class
CRC32 Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CRC32 Methods

CRC32 Methods Lucene.Net Class Library
The CRC32 type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Reset |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Update( Byte ) |
Public method | Update(Int32) |
Public method | Update( Byte , Int32, Int32) |
Back to Top
See Also
CRC32 Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method

CRC32 Reset Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset()
public void Reset()
Public Sub Reset
Public Sub Reset
public:
virtual void Reset() sealed
public:
virtual void Reset() sealed
Implements
IChecksum Reset
See Also
CRC32 Class
CRC32 Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Update Method

CRC32 Update Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Update( Byte ) |
Public method | Update(Int32) |
Public method | Update( Byte , Int32, Int32) |
Back to Top
See Also
CRC32 Class
CRC32 Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Update Method (Byte[])

CRC32 Update Method ( Byte ) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Update(
    byte[] buf
)
public void Update(
    byte[] buf
)
Public Sub Update ( _
    buf As Byte() _
)
Public Sub Update ( _
    buf As Byte() _
)
public:
virtual void Update(
    array<unsigned char>^ buf
) sealed
public:
virtual void Update(
    array<unsigned char>^ buf
) sealed
Parameters
buf
Type:    Online System Byte
Implements
IChecksum Update( Byte )
See Also
CRC32 Class
CRC32 Members
Update Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Update Method (Int32)

CRC32 Update Method (Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Update(
    int bval
)
public void Update(
    int bval
)
Public Sub Update ( _
    bval As Integer _
)
Public Sub Update ( _
    bval As Integer _
)
public:
virtual void Update(
    int bval
) sealed
public:
virtual void Update(
    int bval
) sealed
Parameters
bval
Type:   Online System Int32
Implements
IChecksum Update(Int32)
See Also
CRC32 Class
CRC32 Members
Update Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Update Method (Byte[], Int32, Int32)

CRC32 Update Method ( Byte , Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Update(
    byte[] buf,
    int off,
    int len
)
public void Update(
    byte[] buf,
    int off,
    int len
)
Public Sub Update ( _
    buf As Byte(), _
    off As Integer, _
    len As Integer _
)
Public Sub Update ( _
    buf As Byte(), _
    off As Integer, _
    len As Integer _
)
public:
virtual void Update(
    array<unsigned char>^ buf,
    int off,
    int len
) sealed
public:
virtual void Update(
    array<unsigned char>^ buf,
    int off,
    int len
) sealed
Parameters
buf
Type:    Online System Byte
off
Type:   Online System Int32
len
Type:   Online System Int32
Implements
IChecksum Update( Byte , Int32, Int32)
See Also
CRC32 Class
CRC32 Members
Update Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CRC32 Properties

CRC32 Properties Lucene.Net Class Library
The CRC32 type exposes the following members.
Properties
 | Name | Description
Public property | Value |
Back to Top
See Also
CRC32 Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Value Property

CRC32 Value Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long Value { get; }
public long Value { get; }
Public ReadOnly Property Value As Long
    Get
Public ReadOnly Property Value As Long
    Get
public:
virtual property long long Value {
    long long get () sealed;
}
public:
virtual property long long Value {
    long long get () sealed;
}
Implements
IChecksum Value
See Also
CRC32 Class
CRC32 Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Cryptography Class

Cryptography Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Support Cryptography

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class Cryptography
public static class Cryptography
Public NotInheritable Class Cryptography
Public NotInheritable Class Cryptography
public ref class Cryptography abstract sealed
public ref class Cryptography abstract sealed
See Also
Cryptography Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Cryptography Members

Cryptography Members Lucene.Net Class Library

The Cryptography type exposes the following members.
Fields
Name | Description
FIPSCompliant |
Back to Top
Properties
Name | Description
HashAlgorithm |
Back to Top
See Also
Cryptography Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Cryptography Fields

Cryptography Fields Lucene.Net Class Library
The Cryptography type exposes the following members.
Fields
Name | Description
FIPSCompliant |
Back to Top
See Also
Cryptography Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FIPSCompliant Field

Cryptography FIPSCompliant Field Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool FIPSCompliant
public static bool FIPSCompliant
Public Shared FIPSCompliant As Boolean
Public Shared FIPSCompliant As Boolean
public:
static bool FIPSCompliant
public:
static bool FIPSCompliant
See Also
Cryptography Class
Cryptography Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Cryptography Properties

Cryptography Properties Lucene.Net Class Library
The Cryptography type exposes the following members.
Properties
Name | Description
HashAlgorithm |
Back to Top
See Also
Cryptography Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HashAlgorithm Property

Cryptography HashAlgorithm Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static HashAlgorithm HashAlgorithm { get; }
public static HashAlgorithm HashAlgorithm { get; }
Public Shared ReadOnly Property HashAlgorithm As HashAlgorithm
    Get
Public Shared ReadOnly Property HashAlgorithm As HashAlgorithm
    Get
public:
static property HashAlgorithm^ HashAlgorithm {
    HashAlgorithm^ get ();
}
public:
static property HashAlgorithm^ HashAlgorithm {
    HashAlgorithm^ get ();
}
See Also
Cryptography Class
Cryptography Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Deflater Class

Deflater Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Support Deflater

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Deflater
public class Deflater
Public Class Deflater
Public Class Deflater
public ref class Deflater
public ref class Deflater
See Also
Deflater Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Deflater Members

Deflater Members Lucene.Net Class Library

The Deflater type exposes the following members.
Methods
 | Name | Description
Public method | Deflate |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Finish |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetInput |
Public method | SetLevel |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
BEST_COMPRESSION |
Back to Top
Properties
 | Name | Description
Public property | IsFinished |
Back to Top
See Also
Deflater Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Deflater Fields

Deflater Fields Lucene.Net Class Library
The Deflater type exposes the following members.
Fields
Name | Description
BEST_COMPRESSION |
Back to Top
See Also
Deflater Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BEST_COMPRESSION Field

Deflater BEST_COMPRESSION Field Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int BEST_COMPRESSION
public const int BEST_COMPRESSION
Public Const BEST_COMPRESSION As Integer
Public Const BEST_COMPRESSION As Integer
public:
literal int BEST_COMPRESSION
public:
literal int BEST_COMPRESSION
See Also
Deflater Class
Deflater Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Deflater Methods

Deflater Methods Lucene.Net Class Library
The Deflater type exposes the following members.
Methods
 | Name | Description
Public method | Deflate |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Finish |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetInput |
Public method | SetLevel |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Deflater Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Deflate Method

Deflater Deflate Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Deflate(
    byte[] output
)
public int Deflate(
    byte[] output
)
Public Function Deflate ( _
    output As Byte() _
) As Integer
Public Function Deflate ( _
    output As Byte() _
) As Integer
public:
int Deflate(
    array<unsigned char>^ output
)
public:
int Deflate(
    array<unsigned char>^ output
)
Parameters
output
Type:    Online System Byte
See Also
Deflater Class
Deflater Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Finish Method

Deflater Finish Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Finish()
public void Finish()
Public Sub Finish
Public Sub Finish
public:
void Finish()
public:
void Finish()
See Also
Deflater Class
Deflater Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetInput Method

Deflater SetInput Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetInput(
    byte[] input,
    int offset,
    int count
)
public void SetInput(
    byte[] input,
    int offset,
    int count
)
Public Sub SetInput ( _
    input As Byte(), _
    offset As Integer, _
    count As Integer _
)
Public Sub SetInput ( _
    input As Byte(), _
    offset As Integer, _
    count As Integer _
)
public:
void SetInput(
    array<unsigned char>^ input,
    int offset,
    int count
)
public:
void SetInput(
    array<unsigned char>^ input,
    int offset,
    int count
)
Parameters
input
Type:    Online System Byte
offset
Type:   Online System Int32
count
Type:   Online System Int32
See Also
Deflater Class
Deflater Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetLevel Method

Deflater SetLevel Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetLevel(
    int level
)
public void SetLevel(
    int level
)
Public Sub SetLevel ( _
    level As Integer _
)
Public Sub SetLevel ( _
    level As Integer _
)
public:
void SetLevel(
    int level
)
public:
void SetLevel(
    int level
)
Parameters
level
Type:   Online System Int32
See Also
Deflater Class
Deflater Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Deflater Properties

Deflater Properties Lucene.Net Class Library
The Deflater type exposes the following members.
Properties
 | Name | Description
Public property | IsFinished |
Back to Top
See Also
Deflater Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsFinished Property

Deflater IsFinished Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsFinished { get; }
public bool IsFinished { get; }
Public ReadOnly Property IsFinished As Boolean
    Get
Public ReadOnly Property IsFinished As Boolean
    Get
public:
property bool IsFinished {
    bool get ();
}
public:
property bool IsFinished {
    bool get ();
}
See Also
Deflater Class
Deflater Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Double Class

Double Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Support Double

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Double
public class Double
Public Class Double
Public Class Double
public ref class Double
public ref class Double
See Also
Double Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Double Members

Double Members Lucene.Net Class Library

The Double type exposes the following members.
Constructors
 | Name | Description
Public method | Double | Initializes a new instance of the Double class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Parse |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Double Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Double Constructor

Double Constructor Lucene.Net Class Library
Initializes a new instance of the Double class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Double()
public Double()
Public Sub New
Public Sub New
public:
Double()
public:
Double()
See Also
Double Class
Double Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Double Methods

Double Methods Lucene.Net Class Library
The Double type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Parse |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Double Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Parse Method

Double Parse Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double Parse(
    string s
)
public static double Parse(
    string s
)
Public Shared Function Parse ( _
    s As String _
) As Double
Public Shared Function Parse ( _
    s As String _
) As Double
public:
static double Parse(
    String^ s
)
public:
static double Parse(
    String^ s
)
Parameters
s
Type:   Online System String
See Also
Double Class
Double Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EquatableList(T) Class

EquatableList T Class Lucene.Net Class Library
Represents a strongly typed list of objects that can be accessed by index. Provides methods to search, sort, and manipulate lists. Also provides functionality to compare lists against each other through an implementations of Online IEquatable T .
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List T
Lucene.Net.Support EquatableList T

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class EquatableList<T> : List<T>,
    IEquatable<IEnumerable<T>>, ICloneable
[SerializableAttribute]
public class EquatableList<T> : List<T>,
    IEquatable<IEnumerable<T>>, ICloneable
<SerializableAttribute> _
Public Class EquatableList(Of T) _
    Inherits List(Of T) _
    Implements IEquatable(Of IEnumerable(Of T)), ICloneable
<SerializableAttribute> _
Public Class EquatableList(Of T) _
    Inherits List(Of T) _
    Implements IEquatable(Of IEnumerable(Of T)), ICloneable
[SerializableAttribute]
generic<typename T>
public ref class EquatableList : public List<T>,
    IEquatable<IEnumerable<T>^>, ICloneable
[SerializableAttribute]
generic<typename T>
public ref class EquatableList : public List<T>,
    IEquatable<IEnumerable<T>^>, ICloneable
Type Parameters
T
The type of elements in the list.
See Also
EquatableList T  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EquatableList(T) Members

EquatableList T Members Lucene.Net Class Library

The EquatableList T type exposes the following members.
Constructors
 | Name | Description
Public method | EquatableList T | Initializes a new instance of the EquatableList T class that is empty and has the default initial capacity.
Public method | EquatableList T (IEnumerable T ) | Initializes a new instance of the EquatableList T class that contains elements copied from the specified collection and has sufficient capacity to accommodate the number of elements copied.
Public method | EquatableList T (Int32) | Initializes a new instance of the EquatableList T class that is empty and has the specified initial capacity.
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List T .)
Public method | Online AddRange(IEnumerable T ) | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List T .)
Public method | AddRange(ICollection) | Adds a range of objects represented by the Online ICollection implementation.
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List T .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List T .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List T .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List T .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List T .)
Public method | Clone | Clones the EquatableList T .
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List T .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List T .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List T .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List T .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List T .)
Public method | Equals(IEnumerable T ) | Compares this sequence to another Online IEnumerable T implementation, returning true if they are equal, false otherwise.
Public method | Equals(Object) | Compares this object for equality against other. (Overrides Online Object Equals(Object).)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List T .)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List T .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List T .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List T .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List T .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List T .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List T .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List T .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List T .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List T .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List T .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List T .)
Public method | GetHashCode | Gets the hash code for the list. (Overrides Online Object GetHashCode .)
 | GetHashCode(IEnumerable T ) | Gets the hash code for the list.
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List T .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List T .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List T .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List T .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List T .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List T .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List T .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List T .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List T .)
Public method | Online RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from Online List T .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List T .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List T .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List T .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List T .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List T .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List T .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List T .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List T .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List T .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List T .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List T .)
Back to Top
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List T .)
Public property | Online Count | Gets the number of elements actually contained in the Online List T . (Inherited from Online List T .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List T .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | Online IList Add | Adds an item to the Online IList. (Inherited from Online List T .)
Explicit interface implemetation | Online IList Contains | Determines whether the Online IList contains a specific value. (Inherited from Online List T .)
Explicit interface implemetation | Online ICollection CopyTo | Copies the elements of the Online ICollection to an Online Array, starting at a particular Online Array index. (Inherited from Online List T .)
Explicit interface implemetation | Online IEnumerable T GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online List T .)
Explicit interface implemetation | Online IEnumerable GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online List T .)
Explicit interface implemetation | Online IList IndexOf | Determines the index of a specific item in the Online IList. (Inherited from Online List T .)
Explicit interface implemetation | Online IList Insert | Inserts an item to the Online IList at the specified index. (Inherited from Online List T .)
Explicit interface implemetation | Online IList IsFixedSize | Gets a value indicating whether the Online IList has a fixed size. (Inherited from Online List T .)
Explicit interface implemetation | Online ICollection T IsReadOnly | Gets a value indicating whether the Online ICollection T is read-only. (Inherited from Online List T .)
Explicit interface implemetation | Online IList IsReadOnly | Gets a value indicating whether the Online IList is read-only. (Inherited from Online List T .)
Explicit interface implemetation | Online ICollection IsSynchronized | Gets a value indicating whether access to the Online ICollection is synchronized (thread safe). (Inherited from Online List T .)
Explicit interface implemetation | Online IList Item | Gets or sets the element at the specified index. (Inherited from Online List T .)
Explicit interface implemetation | Online IList Remove | Removes the first occurrence of a specific object from the Online IList. (Inherited from Online List T .)
Explicit interface implemetation | Online ICollection SyncRoot | Gets an object that can be used to synchronize access to the Online ICollection. (Inherited from Online List T .)
Back to Top
See Also
EquatableList T Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EquatableList(T) Constructor

EquatableList T Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | EquatableList T | Initializes a new instance of the EquatableList T class that is empty and has the default initial capacity.
Public method | EquatableList T (IEnumerable T ) | Initializes a new instance of the EquatableList T class that contains elements copied from the specified collection and has sufficient capacity to accommodate the number of elements copied.
Public method | EquatableList T (Int32) | Initializes a new instance of the EquatableList T class that is empty and has the specified initial capacity.
Back to Top
See Also
EquatableList T Class
EquatableList T Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EquatableList(T) Constructor

EquatableList T Constructor Lucene.Net Class Library
Initializes a new instance of the EquatableList T class that is empty and has the default initial capacity.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EquatableList()
public EquatableList()
Public Sub New
Public Sub New
public:
EquatableList()
public:
EquatableList()
See Also
EquatableList T  Class
EquatableList T  Members
EquatableList T  Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EquatableList(T) Constructor (IEnumerable(T))

EquatableList T Constructor (IEnumerable T ) Lucene.Net Class Library
Initializes a new instance of the EquatableList T class that contains elements copied from the specified collection and has sufficient capacity to accommodate the number of elements copied.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EquatableList(
    IEnumerable<T> collection
)
public EquatableList(
    IEnumerable<T> collection
)
Public Sub New ( _
    collection As IEnumerable(Of T) _
)
Public Sub New ( _
    collection As IEnumerable(Of T) _
)
public:
EquatableList(
    IEnumerable<T>^ collection
)
public:
EquatableList(
    IEnumerable<T>^ collection
)
Parameters
collection
Type:   Online System.Collections.Generic IEnumerable  T
The collection whose elements are copied to the new list.
See Also
EquatableList T  Class
EquatableList T  Members
EquatableList T  Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EquatableList(T) Constructor (Int32)

EquatableList T Constructor (Int32) Lucene.Net Class Library
Initializes a new instance of the EquatableList T class that is empty and has the specified initial capacity.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EquatableList(
    int capacity
)
public EquatableList(
    int capacity
)
Public Sub New ( _
    capacity As Integer _
)
Public Sub New ( _
    capacity As Integer _
)
public:
EquatableList(
    int capacity
)
public:
EquatableList(
    int capacity
)
Parameters
capacity
Type:   Online System Int32
The number of elements that the new list can initially store.
See Also
EquatableList T  Class
EquatableList T  Members
EquatableList T  Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EquatableList(T) Methods

EquatableList T Methods Lucene.Net Class Library
The EquatableList T type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List T .)
Public method | Online AddRange(IEnumerable T ) | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List T .)
Public method | AddRange(ICollection) | Adds a range of objects represented by the Online ICollection implementation.
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List T .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List T .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List T .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List T .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List T .)
Public method | Clone | Clones the EquatableList T .
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List T .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List T .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List T .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List T .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List T .)
Public method | Equals(IEnumerable T ) | Compares this sequence to another Online IEnumerable T implementation, returning true if they are equal, false otherwise.
Public method | Equals(Object) | Compares this object for equality against other. (Overrides Online Object Equals(Object).)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List T .)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List T .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List T .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List T .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List T .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List T .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List T .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List T .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List T .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List T .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List T .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List T .)
Public method | GetHashCode | Gets the hash code for the list. (Overrides Online Object GetHashCode .)
 | GetHashCode(IEnumerable T ) | Gets the hash code for the list.
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List T .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List T .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List T .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List T .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List T .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List T .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List T .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List T .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List T .)
Public method | Online RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from Online List T .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List T .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List T .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List T .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List T .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List T .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List T .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List T .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List T .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List T .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List T .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List T .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | Online IList Add | Adds an item to the Online IList. (Inherited from Online List T .)
Explicit interface implemetation | Online IList Contains | Determines whether the Online IList contains a specific value. (Inherited from Online List T .)
Explicit interface implemetation | Online ICollection CopyTo | Copies the elements of the Online ICollection to an Online Array, starting at a particular Online Array index. (Inherited from Online List T .)
Explicit interface implemetation | Online IEnumerable T GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online List T .)
Explicit interface implemetation | Online IEnumerable GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online List T .)
Explicit interface implemetation | Online IList IndexOf | Determines the index of a specific item in the Online IList. (Inherited from Online List T .)
Explicit interface implemetation | Online IList Insert | Inserts an item to the Online IList at the specified index. (Inherited from Online List T .)
Explicit interface implemetation | Online IList Remove | Removes the first occurrence of a specific object from the Online IList. (Inherited from Online List T .)
Back to Top
See Also
EquatableList T Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddRange Method

EquatableList T AddRange Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Online AddRange(IEnumerable T ) | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List T .)
Public method | AddRange(ICollection) | Adds a range of objects represented by the Online ICollection implementation.
Back to Top
See Also
EquatableList T Class
EquatableList T Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddRange Method (ICollection)

EquatableList T AddRange Method (ICollection) Lucene.Net Class Library
Adds a range of objects represented by the Online ICollection implementation.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddRange(
    ICollection c
)
public void AddRange(
    ICollection c
)
Public Sub AddRange ( _
    c As ICollection _
)
Public Sub AddRange ( _
    c As ICollection _
)
public:
void AddRange(
    ICollection^ c
)
public:
void AddRange(
    ICollection^ c
)
Parameters
c
Type:   Online System.Collections ICollection
The   Online ICollection
            implementation to add to this list.
See Also
EquatableList T  Class
EquatableList T  Members
AddRange Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

EquatableList T Clone Method Lucene.Net Class Library
Clones the EquatableList T .

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Clone()
public Object Clone()
Public Function Clone As Object
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
public:
virtual Object^ Clone() sealed
Return Value
A new shallow clone of this
            EquatableList T .
Implements
  Online ICloneable Clone
Remarks
This is a shallow clone.
See Also
EquatableList T  Class
EquatableList T  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

EquatableList T Equals Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Equals(IEnumerable T ) | Compares this sequence to another Online IEnumerable T implementation, returning true if they are equal, false otherwise.
Public method | Equals(Object) | Compares this object for equality against other. (Overrides Online Object Equals(Object).)
Back to Top
See Also
EquatableList T Class
EquatableList T Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method (IEnumerable(T))

EquatableList T Equals Method (IEnumerable T ) Lucene.Net Class Library
Compares this sequence to another Online IEnumerable T implementation, returning true if they are equal, false otherwise.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    IEnumerable<T> other
)
public bool Equals(
    IEnumerable<T> other
)
Public Function Equals ( _
    other As IEnumerable(Of T) _
) As Boolean
Public Function Equals ( _
    other As IEnumerable(Of T) _
) As Boolean
public:
virtual bool Equals(
    IEnumerable<T>^ other
) sealed
public:
virtual bool Equals(
    IEnumerable<T>^ other
) sealed
Parameters
other
Type:   Online System.Collections.Generic IEnumerable  T
The other   Online IEnumerable T  implementation
            to compare against.
Return Value
True if the sequence in other
            is the same as this one.
Implements
  Online IEquatable T  Equals(T)
See Also
EquatableList T  Class
EquatableList T  Members
Equals Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method (Object)

EquatableList T Equals Method (Object) Lucene.Net Class Library
Compares this object for equality against other.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
The other object to compare this object against.
Return Value
True if this object and obj are equal, false
            otherwise.
See Also
EquatableList T  Class
EquatableList T  Members
Equals Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

EquatableList T GetHashCode Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetHashCode | Gets the hash code for the list. (Overrides Online Object GetHashCode .)
 | GetHashCode(IEnumerable T ) | Gets the hash code for the list.
Back to Top
See Also
EquatableList T Class
EquatableList T Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

EquatableList T GetHashCode Method Lucene.Net Class Library
Gets the hash code for the list.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
Return Value
The hash code value.
See Also
EquatableList T  Class
EquatableList T  Members
GetHashCode Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method (IEnumerable(T))

EquatableList T GetHashCode Method (IEnumerable T ) Lucene.Net Class Library
Gets the hash code for the list.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GetHashCode(
    IEnumerable<T> source
)
public static int GetHashCode(
    IEnumerable<T> source
)
Public Shared Function GetHashCode ( _
    source As IEnumerable(Of T) _
) As Integer
Public Shared Function GetHashCode ( _
    source As IEnumerable(Of T) _
) As Integer
public:
static int GetHashCode(
    IEnumerable<T>^ source
)
public:
static int GetHashCode(
    IEnumerable<T>^ source
)
Parameters
source
Type:   Online System.Collections.Generic IEnumerable  T
The   Online IEnumerable T
            implementation which will have all the contents hashed.
Return Value
The hash code value.
See Also
EquatableList T  Class
EquatableList T  Members
GetHashCode Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EquatableList(T) Properties

EquatableList T Properties Lucene.Net Class Library
The EquatableList T type exposes the following members.
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List T .)
Public property | Online Count | Gets the number of elements actually contained in the Online List T . (Inherited from Online List T .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List T .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | Online IList IsFixedSize | Gets a value indicating whether the Online IList has a fixed size. (Inherited from Online List T .)
Explicit interface implemetation | Online ICollection T IsReadOnly | Gets a value indicating whether the Online ICollection T is read-only. (Inherited from Online List T .)
Explicit interface implemetation | Online IList IsReadOnly | Gets a value indicating whether the Online IList is read-only. (Inherited from Online List T .)
Explicit interface implemetation | Online ICollection IsSynchronized | Gets a value indicating whether access to the Online ICollection is synchronized (thread safe). (Inherited from Online List T .)
Explicit interface implemetation | Online IList Item | Gets or sets the element at the specified index. (Inherited from Online List T .)
Explicit interface implemetation | Online ICollection SyncRoot | Gets an object that can be used to synchronize access to the Online ICollection. (Inherited from Online List T .)
Back to Top
See Also
EquatableList T Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileSupport Class

FileSupport Class Lucene.Net Class Library
Represents the methods to support some operations over files.
Inheritance Hierarchy
Online System Object
Lucene.Net.Support FileSupport

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FileSupport
public class FileSupport
Public Class FileSupport
Public Class FileSupport
public ref class FileSupport
public ref class FileSupport
See Also
FileSupport Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileSupport Members

FileSupport Members Lucene.Net Class Library

The FileSupport type exposes the following members.
Constructors
 | Name | Description
Public method | FileSupport | Initializes a new instance of the FileSupport class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetFiles(DirectoryInfo) |
 | GetFiles(FileInfo) | Returns an array of abstract pathnames representing the files and directories of the specified path.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
 | GetLuceneIndexFiles | Returns a list of files in a give directory.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Sync | Flushes the specified file stream. Ensures that all buffered data is actually written to the file system.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FileSupport Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileSupport Constructor

FileSupport Constructor Lucene.Net Class Library
Initializes a new instance of the FileSupport class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSupport()
public FileSupport()
Public Sub New
Public Sub New
public:
FileSupport()
public:
FileSupport()
See Also
FileSupport Class
FileSupport Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FileSupport Methods

FileSupport Methods Lucene.Net Class Library
The FileSupport type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetFiles(DirectoryInfo) |
 | GetFiles(FileInfo) | Returns an array of abstract pathnames representing the files and directories of the specified path.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
 | GetLuceneIndexFiles | Returns a list of files in a give directory.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Sync | Flushes the specified file stream. Ensures that all buffered data is actually written to the file system.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FileSupport Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFiles Method

FileSupport GetFiles Method Lucene.Net Class Library
Overload List
Name | Description
GetFiles(DirectoryInfo) |
GetFiles(FileInfo) | Returns an array of abstract pathnames representing the files and directories of the specified path.
Back to Top
See Also
FileSupport Class
FileSupport Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFiles Method (DirectoryInfo)

FileSupport GetFiles Method (DirectoryInfo) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FileInfo[] GetFiles(
    DirectoryInfo path
)
public static FileInfo[] GetFiles(
    DirectoryInfo path
)
Public Shared Function GetFiles ( _
    path As DirectoryInfo _
) As FileInfo()
Public Shared Function GetFiles ( _
    path As DirectoryInfo _
) As FileInfo()
public:
static array<FileInfo^>^ GetFiles(
    DirectoryInfo^ path
)
public:
static array<FileInfo^>^ GetFiles(
    DirectoryInfo^ path
)
Parameters
path
Type:   Online System.IO DirectoryInfo
See Also
FileSupport Class
FileSupport Members
GetFiles Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetFiles Method (FileInfo)

FileSupport GetFiles Method (FileInfo) Lucene.Net Class Library
Returns an array of abstract pathnames representing the files and directories of the specified path.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FileInfo[] GetFiles(
    FileInfo path
)
public static FileInfo[] GetFiles(
    FileInfo path
)
Public Shared Function GetFiles ( _
    path As FileInfo _
) As FileInfo()
Public Shared Function GetFiles ( _
    path As FileInfo _
) As FileInfo()
public:
static array<FileInfo^>^ GetFiles(
    FileInfo^ path
)
public:
static array<FileInfo^>^ GetFiles(
    FileInfo^ path
)
Parameters
path
Type:   Online System.IO FileInfo
The abstract pathname to list it childs.
Return Value
An array of abstract pathnames childs of the path specified or null if the path is not a directory
See Also
FileSupport Class
FileSupport Members
GetFiles Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetLuceneIndexFiles Method

FileSupport GetLuceneIndexFiles Method Lucene.Net Class Library
Returns a list of files in a give directory.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string[] GetLuceneIndexFiles(
    string fullName,
    IndexFileNameFilter indexFileNameFilter
)
public static string[] GetLuceneIndexFiles(
    string fullName,
    IndexFileNameFilter indexFileNameFilter
)
Public Shared Function GetLuceneIndexFiles ( _
    fullName As String, _
    indexFileNameFilter As IndexFileNameFilter _
) As String()
Public Shared Function GetLuceneIndexFiles ( _
    fullName As String, _
    indexFileNameFilter As IndexFileNameFilter _
) As String()
public:
static array<String^>^ GetLuceneIndexFiles(
    String^ fullName,
    IndexFileNameFilter^ indexFileNameFilter
)
public:
static array<String^>^ GetLuceneIndexFiles(
    String^ fullName,
    IndexFileNameFilter^ indexFileNameFilter
)
Parameters
fullName
Type:   Online System String
The full path name to the directory.
indexFileNameFilter
Type: Lucene.Net.Index IndexFileNameFilter
Return Value
An array containing the files.
See Also
FileSupport Class
FileSupport Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Sync Method

FileSupport Sync Method Lucene.Net Class Library
Flushes the specified file stream. Ensures that all buffered data is actually written to the file system.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Sync(
    FileStream fileStream
)
public static void Sync(
    FileStream fileStream
)
Public Shared Sub Sync ( _
    fileStream As FileStream _
)
Public Shared Sub Sync ( _
    fileStream As FileStream _
)
public:
static void Sync(
    FileStream^ fileStream
)
public:
static void Sync(
    FileStream^ fileStream
)
Parameters
fileStream
Type:   Online System.IO FileStream
The file stream.
See Also
FileSupport Class
FileSupport Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HashMap(TKey, TValue) Class

HashMap TKey, TValue Class Lucene.Net Class Library
A C# emulation of the Online Java Hashmap

A Online Dictionary TKey, TValue is a close equivalent to the Java Hashmap. One difference java implementation of the class is that the Hashmap supports both null keys and values, where the C# Dictionary only supports null values not keys. Also, V Get(TKey) method in Java returns null if the key doesn't exist, instead of throwing an exception. This implementation doesn't throw an exception when a key doesn't exist, it will return null. This class is slower than using a Online Dictionary TKey, TValue , because of extra checks that have to be done on each access, to check for null.

NOTE: This class works best with nullable types. default(T) is returned when a key doesn't exist in the collection (this being similar to how Java returns null). Therefore, if the expected behavior of the java code is to execute code based on if the key exists, when the key is an integer type, it will return 0 instead of null.

Consider also implementing IDictionary, IEnumerable, and ICollection like Online Dictionary TKey, TValue does, so HashMap can be used in substituted in place for the same interfaces it implements.
Inheritance Hierarchy
Online System Object
Lucene.Net.Support HashMap TKey, TValue

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class HashMap<TKey, TValue> : IDictionary<TKey, TValue>,
    ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>,
    IEnumerable
[SerializableAttribute]
public class HashMap<TKey, TValue> : IDictionary<TKey, TValue>,
    ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>,
    IEnumerable
<SerializableAttribute> _
Public Class HashMap(Of TKey, TValue) _
    Implements IDictionary(Of TKey, TValue), ICollection(Of KeyValuePair(Of TKey, TValue)),  _
    IEnumerable(Of KeyValuePair(Of TKey, TValue)), IEnumerable
<SerializableAttribute> _
Public Class HashMap(Of TKey, TValue) _
    Implements IDictionary(Of TKey, TValue), ICollection(Of KeyValuePair(Of TKey, TValue)),  _
    IEnumerable(Of KeyValuePair(Of TKey, TValue)), IEnumerable
[SerializableAttribute]
generic<typename TKey, typename TValue>
public ref class HashMap : IDictionary<TKey, TValue>,
    ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>,
    IEnumerable
[SerializableAttribute]
generic<typename TKey, typename TValue>
public ref class HashMap : IDictionary<TKey, TValue>,
    ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>,
    IEnumerable
Type Parameters
TKey
The type of keys in the dictionary
TValue
The type of values in the dictionary
See Also
HashMap TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HashMap(TKey, TValue) Members

HashMap TKey, TValue Members Lucene.Net Class Library

The HashMap TKey, TValue type exposes the following members.
Constructors
 | Name | Description
Public method | HashMap TKey, TValue | Initializes a new instance of the HashMap TKey, TValue class
Public method | HashMap TKey, TValue (IEnumerable KeyValuePair TKey, TValue ) | Initializes a new instance of the HashMap TKey, TValue class
Public method | HashMap TKey, TValue (IEqualityComparer TKey ) | Initializes a new instance of the HashMap TKey, TValue class
Public method | HashMap TKey, TValue (Int32) | Initializes a new instance of the HashMap TKey, TValue class
Public method | HashMap TKey, TValue (Int32, IEqualityComparer TKey ) | Initializes a new instance of the HashMap TKey, TValue class
Back to Top
Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | ContainsKey |
Public method | ContainsValue |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove(KeyValuePair TKey, TValue ) |
Public method | Remove(TKey) |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | TryGetValue |
Back to Top
Properties
 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Public property | Keys |
Public property | Values |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue Add | Adds an item to the Online ICollection T .
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue Contains | Determines whether the Online ICollection T contains a specific value.
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue CopyTo | Copies the elements of the Online ICollection T to an Online Array, starting at a particular Online Array index.
Explicit interface implemetation | IEnumerable GetEnumerator | Returns an enumerator that iterates through a collection.
Back to Top
See Also
HashMap TKey, TValue Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HashMap(TKey, TValue) Constructor

HashMap TKey, TValue Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | HashMap TKey, TValue | Initializes a new instance of the HashMap TKey, TValue class
Public method | HashMap TKey, TValue (IEnumerable KeyValuePair TKey, TValue ) | Initializes a new instance of the HashMap TKey, TValue class
Public method | HashMap TKey, TValue (IEqualityComparer TKey ) | Initializes a new instance of the HashMap TKey, TValue class
Public method | HashMap TKey, TValue (Int32) | Initializes a new instance of the HashMap TKey, TValue class
Public method | HashMap TKey, TValue (Int32, IEqualityComparer TKey ) | Initializes a new instance of the HashMap TKey, TValue class
Back to Top
See Also
HashMap TKey, TValue Class
HashMap TKey, TValue Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HashMap(TKey, TValue) Constructor

HashMap TKey, TValue Constructor Lucene.Net Class Library
Initializes a new instance of the HashMap TKey, TValue class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HashMap()
public HashMap()
Public Sub New
Public Sub New
public:
HashMap()
public:
HashMap()
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
HashMap TKey, TValue  Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HashMap(TKey, TValue) Constructor (IEnumerable(KeyValuePair(TKey, TValue)))

HashMap TKey, TValue Constructor (IEnumerable KeyValuePair TKey, TValue ) Lucene.Net Class Library
Initializes a new instance of the HashMap TKey, TValue class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HashMap(
    IEnumerable<KeyValuePair<TKey, TValue>> other
)
public HashMap(
    IEnumerable<KeyValuePair<TKey, TValue>> other
)
Public Sub New ( _
    other As IEnumerable(Of KeyValuePair(Of TKey, TValue)) _
)
Public Sub New ( _
    other As IEnumerable(Of KeyValuePair(Of TKey, TValue)) _
)
public:
HashMap(
    IEnumerable<KeyValuePair<TKey, TValue>>^ other
)
public:
HashMap(
    IEnumerable<KeyValuePair<TKey, TValue>>^ other
)
Parameters
other
Type:   Online System.Collections.Generic IEnumerable    Online KeyValuePair  TKey, TValue
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
HashMap TKey, TValue  Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HashMap(TKey, TValue) Constructor (IEqualityComparer(TKey))

HashMap TKey, TValue Constructor (IEqualityComparer TKey ) Lucene.Net Class Library
Initializes a new instance of the HashMap TKey, TValue class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HashMap(
    IEqualityComparer<TKey> comparer
)
public HashMap(
    IEqualityComparer<TKey> comparer
)
Public Sub New ( _
    comparer As IEqualityComparer(Of TKey) _
)
Public Sub New ( _
    comparer As IEqualityComparer(Of TKey) _
)
public:
HashMap(
    IEqualityComparer<TKey>^ comparer
)
public:
HashMap(
    IEqualityComparer<TKey>^ comparer
)
Parameters
comparer
Type:   Online System.Collections.Generic IEqualityComparer  TKey
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
HashMap TKey, TValue  Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HashMap(TKey, TValue) Constructor (Int32)

HashMap TKey, TValue Constructor (Int32) Lucene.Net Class Library
Initializes a new instance of the HashMap TKey, TValue class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HashMap(
    int initialCapacity
)
public HashMap(
    int initialCapacity
)
Public Sub New ( _
    initialCapacity As Integer _
)
Public Sub New ( _
    initialCapacity As Integer _
)
public:
HashMap(
    int initialCapacity
)
public:
HashMap(
    int initialCapacity
)
Parameters
initialCapacity
Type:   Online System Int32
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
HashMap TKey, TValue  Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HashMap(TKey, TValue) Constructor (Int32, IEqualityComparer(TKey))

HashMap TKey, TValue Constructor (Int32, IEqualityComparer TKey ) Lucene.Net Class Library
Initializes a new instance of the HashMap TKey, TValue class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HashMap(
    int initialCapacity,
    IEqualityComparer<TKey> comparer
)
public HashMap(
    int initialCapacity,
    IEqualityComparer<TKey> comparer
)
Public Sub New ( _
    initialCapacity As Integer, _
    comparer As IEqualityComparer(Of TKey) _
)
Public Sub New ( _
    initialCapacity As Integer, _
    comparer As IEqualityComparer(Of TKey) _
)
public:
HashMap(
    int initialCapacity,
    IEqualityComparer<TKey>^ comparer
)
public:
HashMap(
    int initialCapacity,
    IEqualityComparer<TKey>^ comparer
)
Parameters
initialCapacity
Type:   Online System Int32
comparer
Type:   Online System.Collections.Generic IEqualityComparer  TKey
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
HashMap TKey, TValue  Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HashMap(TKey, TValue) Methods

HashMap TKey, TValue Methods Lucene.Net Class Library
The HashMap TKey, TValue type exposes the following members.
Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | ContainsKey |
Public method | ContainsValue |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove(KeyValuePair TKey, TValue ) |
Public method | Remove(TKey) |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | TryGetValue |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue Add | Adds an item to the Online ICollection T .
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue Contains | Determines whether the Online ICollection T contains a specific value.
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue CopyTo | Copies the elements of the Online ICollection T to an Online Array, starting at a particular Online Array index.
Explicit interface implemetation | IEnumerable GetEnumerator | Returns an enumerator that iterates through a collection.
Back to Top
See Also
HashMap TKey, TValue Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ICollection(KeyValuePair(TKey, TValue)).Add Method

HashMap TKey, TValue ICollection KeyValuePair TKey, TValue Add Method Lucene.Net Class Library
Adds an item to the Online ICollection T .

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ICollection<KeyValuePair<TKey, TValue>>.Add(
    KeyValuePair<TKey, TValue> item
)
void ICollection<KeyValuePair<TKey, TValue>>.Add(
    KeyValuePair<TKey, TValue> item
)
Private Sub Add ( _
    item As KeyValuePair(Of TKey, TValue) _
) Implements ICollection(Of KeyValuePair(Of TKey, TValue)).Add
Private Sub Add ( _
    item As KeyValuePair(Of TKey, TValue) _
) Implements ICollection(Of KeyValuePair(Of TKey, TValue)).Add
private:
virtual void Add(
    KeyValuePair<TKey, TValue> item
) sealed = ICollection<KeyValuePair<TKey, TValue>>::Add
private:
virtual void Add(
    KeyValuePair<TKey, TValue> item
) sealed = ICollection<KeyValuePair<TKey, TValue>>::Add
Parameters
item
Type:   Online System.Collections.Generic KeyValuePair  TKey, TValue
The object to add to the   Online ICollection T .
Implements
  Online ICollection T  Add(T)
Exceptions
Exception | Condition
Online System NotSupportedException | The Online ICollection T is read-only.
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ICollection(KeyValuePair(TKey, TValue)).Contains Method

HashMap TKey, TValue ICollection KeyValuePair TKey, TValue Contains Method Lucene.Net Class Library
Determines whether the Online ICollection T contains a specific value.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ICollection<KeyValuePair<TKey, TValue>>.Contains(
    KeyValuePair<TKey, TValue> item
)
bool ICollection<KeyValuePair<TKey, TValue>>.Contains(
    KeyValuePair<TKey, TValue> item
)
Private Function Contains ( _
    item As KeyValuePair(Of TKey, TValue) _
) As Boolean Implements ICollection(Of KeyValuePair(Of TKey, TValue)).Contains
Private Function Contains ( _
    item As KeyValuePair(Of TKey, TValue) _
) As Boolean Implements ICollection(Of KeyValuePair(Of TKey, TValue)).Contains
private:
virtual bool Contains(
    KeyValuePair<TKey, TValue> item
) sealed = ICollection<KeyValuePair<TKey, TValue>>::Contains
private:
virtual bool Contains(
    KeyValuePair<TKey, TValue> item
) sealed = ICollection<KeyValuePair<TKey, TValue>>::Contains
Parameters
item
Type:   Online System.Collections.Generic KeyValuePair  TKey, TValue
The object to locate in the   Online ICollection T .
Return Value
true if item is found in the   Online ICollection T ; otherwise, false.
Implements
  Online ICollection T  Contains(T)
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ICollection(KeyValuePair(TKey, TValue)).CopyTo Method

HashMap TKey, TValue ICollection KeyValuePair TKey, TValue CopyTo Method Lucene.Net Class Library
Copies the elements of the Online ICollection T to an Online Array, starting at a particular Online Array index.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ICollection<KeyValuePair<TKey, TValue>>.CopyTo(
    KeyValuePair<TKey, TValue>[] array,
    int arrayIndex
)
void ICollection<KeyValuePair<TKey, TValue>>.CopyTo(
    KeyValuePair<TKey, TValue>[] array,
    int arrayIndex
)
Private Sub CopyTo ( _
    array As KeyValuePair(Of TKey, TValue)(), _
    arrayIndex As Integer _
) Implements ICollection(Of KeyValuePair(Of TKey, TValue)).CopyTo
Private Sub CopyTo ( _
    array As KeyValuePair(Of TKey, TValue)(), _
    arrayIndex As Integer _
) Implements ICollection(Of KeyValuePair(Of TKey, TValue)).CopyTo
private:
virtual void CopyTo(
    array<KeyValuePair<TKey, TValue>>^ array,
    int arrayIndex
) sealed = ICollection<KeyValuePair<TKey, TValue>>::CopyTo
private:
virtual void CopyTo(
    array<KeyValuePair<TKey, TValue>>^ array,
    int arrayIndex
) sealed = ICollection<KeyValuePair<TKey, TValue>>::CopyTo
Parameters
array
Type:    Online System.Collections.Generic KeyValuePair  TKey, TValue
The one-dimensional   Online Array that is the destination of the elements copied from   Online ICollection T . The   Online Array must have zero-based indexing.
arrayIndex
Type:   Online System Int32
The zero-based index in array at which copying begins.
Implements
  Online ICollection T  CopyTo( T , Int32)
Exceptions
Exception | Condition
Online System ArgumentNullException | array is null.
Online System ArgumentOutOfRangeException | arrayIndex is less than 0.
Online System ArgumentException | array is multidimensional.-or-The number of elements in the source Online ICollection T is greater than the available space from arrayIndex to the end of the destination array.-or-Type T cannot be cast automatically to the type of the destination array.
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IEnumerable.GetEnumerator Method

HashMap TKey, TValue IEnumerable GetEnumerator Method Lucene.Net Class Library
Returns an enumerator that iterates through a collection.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
Return Value
An   Online IEnumerator object that can be used to iterate through the collection.
Implements
  Online IEnumerable GetEnumerator
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method

HashMap TKey, TValue Add Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Add(
    TKey key,
    TValue value
)
public virtual void Add(
    TKey key,
    TValue value
)
Public Overridable Sub Add ( _
    key As TKey, _
    value As TValue _
)
Public Overridable Sub Add ( _
    key As TKey, _
    value As TValue _
)
public:
virtual void Add(
    TKey key,
    TValue value
)
public:
virtual void Add(
    TKey key,
    TValue value
)
Parameters
key
Type: TKey
value
Type: TValue
Implements
  Online IDictionary TKey, TValue  Add(TKey, TValue)
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method

HashMap TKey, TValue Clear Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
virtual void Clear() sealed
public:
virtual void Clear() sealed
Implements
  Online ICollection T  Clear
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ContainsKey Method

HashMap TKey, TValue ContainsKey Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ContainsKey(
    TKey key
)
public bool ContainsKey(
    TKey key
)
Public Function ContainsKey ( _
    key As TKey _
) As Boolean
Public Function ContainsKey ( _
    key As TKey _
) As Boolean
public:
virtual bool ContainsKey(
    TKey key
) sealed
public:
virtual bool ContainsKey(
    TKey key
) sealed
Parameters
key
Type: TKey
Implements
  Online IDictionary TKey, TValue  ContainsKey(TKey)
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ContainsValue Method

HashMap TKey, TValue ContainsValue Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ContainsValue(
    TValue value
)
public bool ContainsValue(
    TValue value
)
Public Function ContainsValue ( _
    value As TValue _
) As Boolean
Public Function ContainsValue ( _
    value As TValue _
) As Boolean
public:
bool ContainsValue(
    TValue value
)
public:
bool ContainsValue(
    TValue value
)
Parameters
value
Type: TValue
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetEnumerator Method

HashMap TKey, TValue GetEnumerator Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<KeyValuePair<TKey, TValue>> GetEnumerator()
public IEnumerator<KeyValuePair<TKey, TValue>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of TKey, TValue))
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of TKey, TValue))
public:
virtual IEnumerator<KeyValuePair<TKey, TValue>>^ GetEnumerator() sealed
public:
virtual IEnumerator<KeyValuePair<TKey, TValue>>^ GetEnumerator() sealed
Implements
  Online IEnumerable T  GetEnumerator
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Remove Method

HashMap TKey, TValue Remove Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Remove(KeyValuePair TKey, TValue ) |
Public method | Remove(TKey) |
Back to Top
See Also
HashMap TKey, TValue Class
HashMap TKey, TValue Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Remove Method (KeyValuePair(TKey, TValue))

HashMap TKey, TValue Remove Method (KeyValuePair TKey, TValue ) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Remove(
    KeyValuePair<TKey, TValue> item
)
public bool Remove(
    KeyValuePair<TKey, TValue> item
)
Public Function Remove ( _
    item As KeyValuePair(Of TKey, TValue) _
) As Boolean
Public Function Remove ( _
    item As KeyValuePair(Of TKey, TValue) _
) As Boolean
public:
virtual bool Remove(
    KeyValuePair<TKey, TValue> item
) sealed
public:
virtual bool Remove(
    KeyValuePair<TKey, TValue> item
) sealed
Parameters
item
Type:   Online System.Collections.Generic KeyValuePair  TKey, TValue
Implements
  Online ICollection T  Remove(T)
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
Remove Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Remove Method (TKey)

HashMap TKey, TValue Remove Method (TKey) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Remove(
    TKey key
)
public bool Remove(
    TKey key
)
Public Function Remove ( _
    key As TKey _
) As Boolean
Public Function Remove ( _
    key As TKey _
) As Boolean
public:
virtual bool Remove(
    TKey key
) sealed
public:
virtual bool Remove(
    TKey key
) sealed
Parameters
key
Type: TKey
Implements
  Online IDictionary TKey, TValue  Remove(TKey)
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
Remove Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TryGetValue Method

HashMap TKey, TValue TryGetValue Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryGetValue(
    TKey key,
    out TValue value
)
public bool TryGetValue(
    TKey key,
    out TValue value
)
Public Function TryGetValue ( _
    key As TKey, _
    <OutAttribute> ByRef value As TValue _
) As Boolean
Public Function TryGetValue ( _
    key As TKey, _
    <OutAttribute> ByRef value As TValue _
) As Boolean
public:
virtual bool TryGetValue(
    TKey key,
    [OutAttribute] TValue% value
) sealed
public:
virtual bool TryGetValue(
    TKey key,
    [OutAttribute] TValue% value
) sealed
Parameters
key
Type: TKey
value
Type: TValue
Implements
  Online IDictionary TKey, TValue  TryGetValue(TKey, TValue )
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HashMap(TKey, TValue) Properties

HashMap TKey, TValue Properties Lucene.Net Class Library
The HashMap TKey, TValue type exposes the following members.
Properties
 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Public property | Keys |
Public property | Values |
Back to Top
See Also
HashMap TKey, TValue Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Count Property

HashMap TKey, TValue Count Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
public:
virtual property int Count {
    int get () sealed;
}
Implements
  Online ICollection T  Count
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsReadOnly Property

HashMap TKey, TValue IsReadOnly Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsReadOnly { get; }
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
Implements
  Online ICollection T  IsReadOnly
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Item Property

HashMap TKey, TValue Item Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TValue this[
    TKey key
] { get; set; }
public TValue this[
    TKey key
] { get; set; }
Public Default Property Item ( _
    key As TKey _
) As TValue
    Get
    Set
Public Default Property Item ( _
    key As TKey _
) As TValue
    Get
    Set
public:
virtual property TValue default[TKey key] {
    TValue get (TKey key) sealed;
    void set (TKey key, TValue value) sealed;
}
public:
virtual property TValue default[TKey key] {
    TValue get (TKey key) sealed;
    void set (TKey key, TValue value) sealed;
}
Parameters
key
Type: TKey
Implements
  Online IDictionary TKey, TValue  Item TKey
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Keys Property

HashMap TKey, TValue Keys Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<TKey> Keys { get; }
public ICollection<TKey> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of TKey)
    Get
Public ReadOnly Property Keys As ICollection(Of TKey)
    Get
public:
virtual property ICollection<TKey>^ Keys {
    ICollection<TKey>^ get () sealed;
}
public:
virtual property ICollection<TKey>^ Keys {
    ICollection<TKey>^ get () sealed;
}
Implements
  Online IDictionary TKey, TValue  Keys
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Values Property

HashMap TKey, TValue Values Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<TValue> Values { get; }
public ICollection<TValue> Values { get; }
Public ReadOnly Property Values As ICollection(Of TValue)
    Get
Public ReadOnly Property Values As ICollection(Of TValue)
    Get
public:
virtual property ICollection<TValue>^ Values {
    ICollection<TValue>^ get () sealed;
}
public:
virtual property ICollection<TValue>^ Values {
    ICollection<TValue>^ get () sealed;
}
Implements
  Online IDictionary TKey, TValue  Values
See Also
HashMap TKey, TValue  Class
HashMap TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IChecksum Interface

IChecksum Interface Lucene.Net Class Library
Contains conversion support elements such as classes, interfaces and static methods.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IChecksum
public interface IChecksum
Public Interface IChecksum
Public Interface IChecksum
public interface class IChecksum
public interface class IChecksum
See Also
IChecksum Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IChecksum Members

IChecksum Members Lucene.Net Class Library

The IChecksum type exposes the following members.
Methods
 | Name | Description
Public method | Reset |
Public method | Update( Byte ) |
Public method | Update(Int32) |
Public method | Update( Byte , Int32, Int32) |
Back to Top
Properties
 | Name | Description
Public property | Value |
Back to Top
See Also
IChecksum Interface
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IChecksum Methods

IChecksum Methods Lucene.Net Class Library
The IChecksum type exposes the following members.
Methods
 | Name | Description
Public method | Reset |
Public method | Update( Byte ) |
Public method | Update(Int32) |
Public method | Update( Byte , Int32, Int32) |
Back to Top
See Also
IChecksum Interface
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Reset Method

IChecksum Reset Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Reset()
void Reset()
Sub Reset
Sub Reset
void Reset()
void Reset()
See Also
IChecksum Interface
IChecksum Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Update Method

IChecksum Update Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Update( Byte ) |
Public method | Update(Int32) |
Public method | Update( Byte , Int32, Int32) |
Back to Top
See Also
IChecksum Interface
IChecksum Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Update Method (Byte[])

IChecksum Update Method ( Byte ) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Update(
    byte[] b
)
void Update(
    byte[] b
)
Sub Update ( _
    b As Byte() _
)
Sub Update ( _
    b As Byte() _
)
void Update(
    array<unsigned char>^ b
)
void Update(
    array<unsigned char>^ b
)
Parameters
b
Type:    Online System Byte
See Also
IChecksum Interface
IChecksum Members
Update Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Update Method (Int32)

IChecksum Update Method (Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Update(
    int b
)
void Update(
    int b
)
Sub Update ( _
    b As Integer _
)
Sub Update ( _
    b As Integer _
)
void Update(
    int b
)
void Update(
    int b
)
Parameters
b
Type:   Online System Int32
See Also
IChecksum Interface
IChecksum Members
Update Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Update Method (Byte[], Int32, Int32)

IChecksum Update Method ( Byte , Int32, Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Update(
    byte[] b,
    int offset,
    int length
)
void Update(
    byte[] b,
    int offset,
    int length
)
Sub Update ( _
    b As Byte(), _
    offset As Integer, _
    length As Integer _
)
Sub Update ( _
    b As Byte(), _
    offset As Integer, _
    length As Integer _
)
void Update(
    array<unsigned char>^ b,
    int offset,
    int length
)
void Update(
    array<unsigned char>^ b,
    int offset,
    int length
)
Parameters
b
Type:    Online System Byte
offset
Type:   Online System Int32
length
Type:   Online System Int32
See Also
IChecksum Interface
IChecksum Members
Update Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IChecksum Properties

IChecksum Properties Lucene.Net Class Library
The IChecksum type exposes the following members.
Properties
 | Name | Description
Public property | Value |
Back to Top
See Also
IChecksum Interface
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Value Property

IChecksum Value Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long Value { get; }
long Value { get; }
ReadOnly Property Value As Long
    Get
ReadOnly Property Value As Long
    Get
property long long Value {
    long long get ();
}
property long long Value {
    long long get ();
}
See Also
IChecksum Interface
IChecksum Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Inflater Class

Inflater Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Support Inflater

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Inflater
public class Inflater
Public Class Inflater
Public Class Inflater
public ref class Inflater
public ref class Inflater
See Also
Inflater Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Inflater Members

Inflater Members Lucene.Net Class Library

The Inflater type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Inflate |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetInput |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | IsFinished |
Back to Top
See Also
Inflater Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Inflater Methods

Inflater Methods Lucene.Net Class Library
The Inflater type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Inflate |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetInput |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Inflater Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Inflate Method

Inflater Inflate Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Inflate(
    byte[] buffer
)
public int Inflate(
    byte[] buffer
)
Public Function Inflate ( _
    buffer As Byte() _
) As Integer
Public Function Inflate ( _
    buffer As Byte() _
) As Integer
public:
int Inflate(
    array<unsigned char>^ buffer
)
public:
int Inflate(
    array<unsigned char>^ buffer
)
Parameters
buffer
Type:    Online System Byte
See Also
Inflater Class
Inflater Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetInput Method

Inflater SetInput Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetInput(
    byte[] buffer
)
public void SetInput(
    byte[] buffer
)
Public Sub SetInput ( _
    buffer As Byte() _
)
Public Sub SetInput ( _
    buffer As Byte() _
)
public:
void SetInput(
    array<unsigned char>^ buffer
)
public:
void SetInput(
    array<unsigned char>^ buffer
)
Parameters
buffer
Type:    Online System Byte
See Also
Inflater Class
Inflater Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Inflater Properties

Inflater Properties Lucene.Net Class Library
The Inflater type exposes the following members.
Properties
 | Name | Description
Public property | IsFinished |
Back to Top
See Also
Inflater Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsFinished Property

Inflater IsFinished Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsFinished { get; }
public bool IsFinished { get; }
Public ReadOnly Property IsFinished As Boolean
    Get
Public ReadOnly Property IsFinished As Boolean
    Get
public:
property bool IsFinished {
    bool get ();
}
public:
property bool IsFinished {
    bool get ();
}
See Also
Inflater Class
Inflater Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IThreadRunnable Interface

IThreadRunnable Interface Lucene.Net Class Library
This interface should be implemented by any class whose instances are intended to be executed by a thread.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IThreadRunnable
public interface IThreadRunnable
Public Interface IThreadRunnable
Public Interface IThreadRunnable
public interface class IThreadRunnable
public interface class IThreadRunnable
See Also
IThreadRunnable Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IThreadRunnable Members

IThreadRunnable Members Lucene.Net Class Library

The IThreadRunnable type exposes the following members.
Methods
 | Name | Description
Public method | Run | This method has to be implemented in order that starting of the thread causes the object's run method to be called in that separately executing thread.
Back to Top
See Also
IThreadRunnable Interface
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IThreadRunnable Methods

IThreadRunnable Methods Lucene.Net Class Library
The IThreadRunnable type exposes the following members.
Methods
 | Name | Description
Public method | Run | This method has to be implemented in order that starting of the thread causes the object's run method to be called in that separately executing thread.
Back to Top
See Also
IThreadRunnable Interface
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Run Method

IThreadRunnable Run Method Lucene.Net Class Library
This method has to be implemented in order that starting of the thread causes the object's run method to be called in that separately executing thread.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Run()
void Run()
Sub Run
Sub Run
void Run()
void Run()
See Also
IThreadRunnable Interface
IThreadRunnable Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Number Class

Number Class Lucene.Net Class Library
A simple class for number conversions.
Inheritance Hierarchy
Online System Object
Lucene.Net.Support Number

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Number
public class Number
Public Class Number
Public Class Number
public ref class Number
public ref class Number
See Also
Number Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Number Members

Number Members Lucene.Net Class Library

The Number type exposes the following members.
Constructors
 | Name | Description
Public method | Number | Initializes a new instance of the Number class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | NextSetBit | Returns the index of the first bit that is set to true that occurs on or after the specified starting index. If no such bit exists then -1 is returned.
 | Parse | Parses a number in the specified radix.
 | ToInt64 | Converts a System.String number to long.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
 | ToString(Int64) | Converts a number to System.String.
 | ToString(Single) | Converts a number to System.String.
 | ToString(Int64, Int32) | Converts a number to System.String in the specified radix.
 | URShift(Int32, Int32) | Performs an unsigned bitwise right shift with the specified number
 | URShift(Int64, Int32) | Performs an unsigned bitwise right shift with the specified number
Back to Top
Fields
Name | Description
MAX_RADIX | Max radix value.
MIN_RADIX | Min radix value.
Back to Top
See Also
Number Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Number Constructor

Number Constructor Lucene.Net Class Library
Initializes a new instance of the Number class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Number()
public Number()
Public Sub New
Public Sub New
public:
Number()
public:
Number()
See Also
Number Class
Number Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Number Fields

Number Fields Lucene.Net Class Library
The Number type exposes the following members.
Fields
Name | Description
MAX_RADIX | Max radix value.
MIN_RADIX | Min radix value.
Back to Top
See Also
Number Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MAX_RADIX Field

Number MAX_RADIX Field Lucene.Net Class Library
Max radix value.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_RADIX
public const int MAX_RADIX
Public Const MAX_RADIX As Integer
Public Const MAX_RADIX As Integer
public:
literal int MAX_RADIX
public:
literal int MAX_RADIX
See Also
Number Class
Number Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MIN_RADIX Field

Number MIN_RADIX Field Lucene.Net Class Library
Min radix value.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MIN_RADIX
public const int MIN_RADIX
Public Const MIN_RADIX As Integer
Public Const MIN_RADIX As Integer
public:
literal int MIN_RADIX
public:
literal int MIN_RADIX
See Also
Number Class
Number Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Number Methods

Number Methods Lucene.Net Class Library
The Number type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | NextSetBit | Returns the index of the first bit that is set to true that occurs on or after the specified starting index. If no such bit exists then -1 is returned.
 | Parse | Parses a number in the specified radix.
 | ToInt64 | Converts a System.String number to long.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
 | ToString(Int64) | Converts a number to System.String.
 | ToString(Single) | Converts a number to System.String.
 | ToString(Int64, Int32) | Converts a number to System.String in the specified radix.
 | URShift(Int32, Int32) | Performs an unsigned bitwise right shift with the specified number
 | URShift(Int64, Int32) | Performs an unsigned bitwise right shift with the specified number
Back to Top
See Also
Number Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextSetBit Method

Number NextSetBit Method Lucene.Net Class Library
Returns the index of the first bit that is set to true that occurs on or after the specified starting index. If no such bit exists then -1 is returned.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int NextSetBit(
    BitArray bits,
    int fromIndex
)
public static int NextSetBit(
    BitArray bits,
    int fromIndex
)
Public Shared Function NextSetBit ( _
    bits As BitArray, _
    fromIndex As Integer _
) As Integer
Public Shared Function NextSetBit ( _
    bits As BitArray, _
    fromIndex As Integer _
) As Integer
public:
static int NextSetBit(
    BitArray^ bits,
    int fromIndex
)
public:
static int NextSetBit(
    BitArray^ bits,
    int fromIndex
)
Parameters
bits
Type:   Online System.Collections BitArray
The BitArray object.
fromIndex
Type:   Online System Int32
The index to start checking from (inclusive).
Return Value
The index of the next set bit.
See Also
Number Class
Number Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Parse Method

Number Parse Method Lucene.Net Class Library
Parses a number in the specified radix.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long Parse(
    string s,
    int radix
)
public static long Parse(
    string s,
    int radix
)
Public Shared Function Parse ( _
    s As String, _
    radix As Integer _
) As Long
Public Shared Function Parse ( _
    s As String, _
    radix As Integer _
) As Long
public:
static long long Parse(
    String^ s,
    int radix
)
public:
static long long Parse(
    String^ s,
    int radix
)
Parameters
s
Type:   Online System String
An input System.String.
radix
Type:   Online System Int32
A radix.
Return Value
The parsed number in the specified radix.
See Also
Number Class
Number Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToInt64 Method

Number ToInt64 Method Lucene.Net Class Library
Converts a System.String number to long.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long ToInt64(
    string s
)
public static long ToInt64(
    string s
)
Public Shared Function ToInt64 ( _
    s As String _
) As Long
Public Shared Function ToInt64 ( _
    s As String _
) As Long
public:
static long long ToInt64(
    String^ s
)
public:
static long long ToInt64(
    String^ s
)
Parameters
s
Type:   Online System String
Return Value
See Also
Number Class
Number Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

Number ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
 | ToString(Int64) | Converts a number to System.String.
 | ToString(Single) | Converts a number to System.String.
 | ToString(Int64, Int32) | Converts a number to System.String in the specified radix.
Back to Top
See Also
Number Class
Number Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (Int64)

Number ToString Method (Int64) Lucene.Net Class Library
Converts a number to System.String.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToString(
    long number
)
public static string ToString(
    long number
)
Public Shared Function ToString ( _
    number As Long _
) As String
Public Shared Function ToString ( _
    number As Long _
) As String
public:
static String^ ToString(
    long long number
)
public:
static String^ ToString(
    long long number
)
Parameters
number
Type:   Online System Int64
Return Value
See Also
Number Class
Number Members
ToString Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (Single)

Number ToString Method (Single) Lucene.Net Class Library
Converts a number to System.String.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToString(
    float f
)
public static string ToString(
    float f
)
Public Shared Function ToString ( _
    f As Single _
) As String
Public Shared Function ToString ( _
    f As Single _
) As String
public:
static String^ ToString(
    float f
)
public:
static String^ ToString(
    float f
)
Parameters
f
Type:   Online System Single
Return Value
See Also
Number Class
Number Members
ToString Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (Int64, Int32)

Number ToString Method (Int64, Int32) Lucene.Net Class Library
Converts a number to System.String in the specified radix.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToString(
    long i,
    int radix
)
public static string ToString(
    long i,
    int radix
)
Public Shared Function ToString ( _
    i As Long, _
    radix As Integer _
) As String
Public Shared Function ToString ( _
    i As Long, _
    radix As Integer _
) As String
public:
static String^ ToString(
    long long i,
    int radix
)
public:
static String^ ToString(
    long long i,
    int radix
)
Parameters
i
Type:   Online System Int64
A number to be converted.
radix
Type:   Online System Int32
A radix.
Return Value
A System.String representation of the number in the specified redix.
See Also
Number Class
Number Members
ToString Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


URShift Method

Number URShift Method Lucene.Net Class Library
Overload List
Name | Description
URShift(Int32, Int32) | Performs an unsigned bitwise right shift with the specified number
URShift(Int64, Int32) | Performs an unsigned bitwise right shift with the specified number
Back to Top
See Also
Number Class
Number Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


URShift Method (Int32, Int32)

Number URShift Method (Int32, Int32) Lucene.Net Class Library
Performs an unsigned bitwise right shift with the specified number

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int URShift(
    int number,
    int bits
)
public static int URShift(
    int number,
    int bits
)
Public Shared Function URShift ( _
    number As Integer, _
    bits As Integer _
) As Integer
Public Shared Function URShift ( _
    number As Integer, _
    bits As Integer _
) As Integer
public:
static int URShift(
    int number,
    int bits
)
public:
static int URShift(
    int number,
    int bits
)
Parameters
number
Type:   Online System Int32
Number to operate on
bits
Type:   Online System Int32
Ammount of bits to shift
Return Value
The resulting number from the shift operation
See Also
Number Class
Number Members
URShift Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


URShift Method (Int64, Int32)

Number URShift Method (Int64, Int32) Lucene.Net Class Library
Performs an unsigned bitwise right shift with the specified number

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long URShift(
    long number,
    int bits
)
public static long URShift(
    long number,
    int bits
)
Public Shared Function URShift ( _
    number As Long, _
    bits As Integer _
) As Long
Public Shared Function URShift ( _
    number As Long, _
    bits As Integer _
) As Long
public:
static long long URShift(
    long long number,
    int bits
)
public:
static long long URShift(
    long long number,
    int bits
)
Parameters
number
Type:   Online System Int64
Number to operate on
bits
Type:   Online System Int32
Ammount of bits to shift
Return Value
The resulting number from the shift operation
See Also
Number Class
Number Members
URShift Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OS Class

OS Class Lucene.Net Class Library
Provides platform infos.
Inheritance Hierarchy
Online System Object
Lucene.Net.Support OS

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class OS
public class OS
Public Class OS
Public Class OS
public ref class OS
public ref class OS
See Also
OS Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OS Members

OS Members Lucene.Net Class Library

The OS type exposes the following members.
Constructors
 | Name | Description
Public method | OS | Initializes a new instance of the OS class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
Name | Description
IsUnix | Whether we run under a Unix platform.
IsWindows | Whether we run under a supported Windows platform.
Back to Top
See Also
OS Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OS Constructor

OS Constructor Lucene.Net Class Library
Initializes a new instance of the OS class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OS()
public OS()
Public Sub New
Public Sub New
public:
OS()
public:
OS()
See Also
OS Class
OS Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OS Methods

OS Methods Lucene.Net Class Library
The OS type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
OS Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OS Properties

OS Properties Lucene.Net Class Library
The OS type exposes the following members.
Properties
Name | Description
IsUnix | Whether we run under a Unix platform.
IsWindows | Whether we run under a supported Windows platform.
Back to Top
See Also
OS Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsUnix Property

OS IsUnix Property Lucene.Net Class Library
Whether we run under a Unix platform.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsUnix { get; }
public static bool IsUnix { get; }
Public Shared ReadOnly Property IsUnix As Boolean
    Get
Public Shared ReadOnly Property IsUnix As Boolean
    Get
public:
static property bool IsUnix {
    bool get ();
}
public:
static property bool IsUnix {
    bool get ();
}
See Also
OS Class
OS Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsWindows Property

OS IsWindows Property Lucene.Net Class Library
Whether we run under a supported Windows platform.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsWindows { get; }
public static bool IsWindows { get; }
Public Shared ReadOnly Property IsWindows As Boolean
    Get
Public Shared ReadOnly Property IsWindows As Boolean
    Get
public:
static property bool IsWindows {
    bool get ();
}
public:
static property bool IsWindows {
    bool get ();
}
See Also
OS Class
OS Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SharpZipLib Class

SharpZipLib Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Support SharpZipLib

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SharpZipLib
public class SharpZipLib
Public Class SharpZipLib
Public Class SharpZipLib
public ref class SharpZipLib
public ref class SharpZipLib
See Also
SharpZipLib Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SharpZipLib Members

SharpZipLib Members Lucene.Net Class Library

The SharpZipLib type exposes the following members.
Constructors
 | Name | Description
Public method | SharpZipLib | Initializes a new instance of the SharpZipLib class
Back to Top
Methods
 | Name | Description
 | CreateDeflater |
 | CreateInflater |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SharpZipLib Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SharpZipLib Constructor

SharpZipLib Constructor Lucene.Net Class Library
Initializes a new instance of the SharpZipLib class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SharpZipLib()
public SharpZipLib()
Public Sub New
Public Sub New
public:
SharpZipLib()
public:
SharpZipLib()
See Also
SharpZipLib Class
SharpZipLib Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SharpZipLib Methods

SharpZipLib Methods Lucene.Net Class Library
The SharpZipLib type exposes the following members.
Methods
 | Name | Description
 | CreateDeflater |
 | CreateInflater |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SharpZipLib Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateDeflater Method

SharpZipLib CreateDeflater Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Deflater CreateDeflater()
public static Deflater CreateDeflater()
Public Shared Function CreateDeflater As Deflater
Public Shared Function CreateDeflater As Deflater
public:
static Deflater^ CreateDeflater()
public:
static Deflater^ CreateDeflater()
See Also
SharpZipLib Class
SharpZipLib Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateInflater Method

SharpZipLib CreateInflater Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Inflater CreateInflater()
public static Inflater CreateInflater()
Public Shared Function CreateInflater As Inflater
Public Shared Function CreateInflater As Inflater
public:
static Inflater^ CreateInflater()
public:
static Inflater^ CreateInflater()
See Also
SharpZipLib Class
SharpZipLib Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Single Class

Single Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Support Single

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Single
public class Single
Public Class Single
Public Class Single
public ref class Single
public ref class Single
See Also
Single Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Single Members

Single Members Lucene.Net Class Library

The Single type exposes the following members.
Constructors
 | Name | Description
Public method | Single | Initializes a new instance of the Single class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | FloatToIntBits |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | IntBitsToFloat |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Parse(String) |
 | Parse(String, NumberStyles) |
 | Parse(String, IFormatProvider) |
 | Parse(String, NumberStyles, IFormatProvider) |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
 | ToString(Single) |
 | ToString(Single, String) |
 | TryParse |
Back to Top
See Also
Single Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Single Constructor

Single Constructor Lucene.Net Class Library
Initializes a new instance of the Single class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Single()
public Single()
Public Sub New
Public Sub New
public:
Single()
public:
Single()
See Also
Single Class
Single Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Single Methods

Single Methods Lucene.Net Class Library
The Single type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | FloatToIntBits |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | IntBitsToFloat |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Parse(String) |
 | Parse(String, NumberStyles) |
 | Parse(String, IFormatProvider) |
 | Parse(String, NumberStyles, IFormatProvider) |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
 | ToString(Single) |
 | ToString(Single, String) |
 | TryParse |
Back to Top
See Also
Single Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FloatToIntBits Method

Single FloatToIntBits Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int FloatToIntBits(
    float value
)
public static int FloatToIntBits(
    float value
)
Public Shared Function FloatToIntBits ( _
    value As Single _
) As Integer
Public Shared Function FloatToIntBits ( _
    value As Single _
) As Integer
public:
static int FloatToIntBits(
    float value
)
public:
static int FloatToIntBits(
    float value
)
Parameters
value
Type:   Online System Single
See Also
Single Class
Single Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IntBitsToFloat Method

Single IntBitsToFloat Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static float IntBitsToFloat(
    int value
)
public static float IntBitsToFloat(
    int value
)
Public Shared Function IntBitsToFloat ( _
    value As Integer _
) As Single
Public Shared Function IntBitsToFloat ( _
    value As Integer _
) As Single
public:
static float IntBitsToFloat(
    int value
)
public:
static float IntBitsToFloat(
    int value
)
Parameters
value
Type:   Online System Int32
See Also
Single Class
Single Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Parse Method

Single Parse Method Lucene.Net Class Library
Overload List
Name | Description
Parse(String) |
Parse(String, NumberStyles) |
Parse(String, IFormatProvider) |
Parse(String, NumberStyles, IFormatProvider) |
Back to Top
See Also
Single Class
Single Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Parse Method (String)

Single Parse Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static float Parse(
    string s
)
public static float Parse(
    string s
)
Public Shared Function Parse ( _
    s As String _
) As Single
Public Shared Function Parse ( _
    s As String _
) As Single
public:
static float Parse(
    String^ s
)
public:
static float Parse(
    String^ s
)
Parameters
s
Type:   Online System String
Return Value
See Also
Single Class
Single Members
Parse Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Parse Method (String, NumberStyles)

Single Parse Method (String, NumberStyles) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static float Parse(
    string s,
    NumberStyles style
)
public static float Parse(
    string s,
    NumberStyles style
)
Public Shared Function Parse ( _
    s As String, _
    style As NumberStyles _
) As Single
Public Shared Function Parse ( _
    s As String, _
    style As NumberStyles _
) As Single
public:
static float Parse(
    String^ s,
    NumberStyles style
)
public:
static float Parse(
    String^ s,
    NumberStyles style
)
Parameters
s
Type:   Online System String
style
Type:   Online System.Globalization NumberStyles
Return Value
See Also
Single Class
Single Members
Parse Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Parse Method (String, IFormatProvider)

Single Parse Method (String, IFormatProvider) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static float Parse(
    string s,
    IFormatProvider provider
)
public static float Parse(
    string s,
    IFormatProvider provider
)
Public Shared Function Parse ( _
    s As String, _
    provider As IFormatProvider _
) As Single
Public Shared Function Parse ( _
    s As String, _
    provider As IFormatProvider _
) As Single
public:
static float Parse(
    String^ s,
    IFormatProvider^ provider
)
public:
static float Parse(
    String^ s,
    IFormatProvider^ provider
)
Parameters
s
Type:   Online System String
provider
Type:   Online System IFormatProvider
Return Value
See Also
Single Class
Single Members
Parse Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Parse Method (String, NumberStyles, IFormatProvider)

Single Parse Method (String, NumberStyles, IFormatProvider) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static float Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
public static float Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Public Shared Function Parse ( _
    s As String, _
    style As NumberStyles, _
    provider As IFormatProvider _
) As Single
Public Shared Function Parse ( _
    s As String, _
    style As NumberStyles, _
    provider As IFormatProvider _
) As Single
public:
static float Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)
public:
static float Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)
Parameters
s
Type:   Online System String
style
Type:   Online System.Globalization NumberStyles
provider
Type:   Online System IFormatProvider
Return Value
See Also
Single Class
Single Members
Parse Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

Single ToString Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
 | ToString(Single) |
 | ToString(Single, String) |
Back to Top
See Also
Single Class
Single Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (Single)

Single ToString Method (Single) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToString(
    float f
)
public static string ToString(
    float f
)
Public Shared Function ToString ( _
    f As Single _
) As String
Public Shared Function ToString ( _
    f As Single _
) As String
public:
static String^ ToString(
    float f
)
public:
static String^ ToString(
    float f
)
Parameters
f
Type:   Online System Single
Return Value
See Also
Single Class
Single Members
ToString Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method (Single, String)

Single ToString Method (Single, String) Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToString(
    float f,
    string format
)
public static string ToString(
    float f,
    string format
)
Public Shared Function ToString ( _
    f As Single, _
    format As String _
) As String
Public Shared Function ToString ( _
    f As Single, _
    format As String _
) As String
public:
static String^ ToString(
    float f,
    String^ format
)
public:
static String^ ToString(
    float f,
    String^ format
)
Parameters
f
Type:   Online System Single
format
Type:   Online System String
Return Value
See Also
Single Class
Single Members
ToString Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TryParse Method

Single TryParse Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryParse(
    string s,
    out float f
)
public static bool TryParse(
    string s,
    out float f
)
Public Shared Function TryParse ( _
    s As String, _
    <OutAttribute> ByRef f As Single _
) As Boolean
Public Shared Function TryParse ( _
    s As String, _
    <OutAttribute> ByRef f As Single _
) As Boolean
public:
static bool TryParse(
    String^ s,
    [OutAttribute] float% f
)
public:
static bool TryParse(
    String^ s,
    [OutAttribute] float% f
)
Parameters
s
Type:   Online System String
f
Type:   Online System Single
See Also
Single Class
Single Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TextSupport Class

TextSupport Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Support TextSupport

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TextSupport
public class TextSupport
Public Class TextSupport
Public Class TextSupport
public ref class TextSupport
public ref class TextSupport
See Also
TextSupport Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TextSupport Members

TextSupport Members Lucene.Net Class Library

The TextSupport type exposes the following members.
Constructors
 | Name | Description
Public method | TextSupport | Initializes a new instance of the TextSupport class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetCharsFromString | Copies an array of chars obtained from a String into a specified array of chars
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TextSupport Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TextSupport Constructor

TextSupport Constructor Lucene.Net Class Library
Initializes a new instance of the TextSupport class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TextSupport()
public TextSupport()
Public Sub New
Public Sub New
public:
TextSupport()
public:
TextSupport()
See Also
TextSupport Class
TextSupport Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TextSupport Methods

TextSupport Methods Lucene.Net Class Library
The TextSupport type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetCharsFromString | Copies an array of chars obtained from a String into a specified array of chars
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
TextSupport Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCharsFromString Method

TextSupport GetCharsFromString Method Lucene.Net Class Library
Copies an array of chars obtained from a String into a specified array of chars

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void GetCharsFromString(
    string sourceString,
    int sourceStart,
    int sourceEnd,
    char[] destinationArray,
    int destinationStart
)
public static void GetCharsFromString(
    string sourceString,
    int sourceStart,
    int sourceEnd,
    char[] destinationArray,
    int destinationStart
)
Public Shared Sub GetCharsFromString ( _
    sourceString As String, _
    sourceStart As Integer, _
    sourceEnd As Integer, _
    destinationArray As Char(), _
    destinationStart As Integer _
)
Public Shared Sub GetCharsFromString ( _
    sourceString As String, _
    sourceStart As Integer, _
    sourceEnd As Integer, _
    destinationArray As Char(), _
    destinationStart As Integer _
)
public:
static void GetCharsFromString(
    String^ sourceString,
    int sourceStart,
    int sourceEnd,
    array<wchar_t>^ destinationArray,
    int destinationStart
)
public:
static void GetCharsFromString(
    String^ sourceString,
    int sourceStart,
    int sourceEnd,
    array<wchar_t>^ destinationArray,
    int destinationStart
)
Parameters
sourceString
Type:   Online System String
The String to get the chars from
sourceStart
Type:   Online System Int32
Position of the String to start getting the chars
sourceEnd
Type:   Online System Int32
Position of the String to end getting the chars
destinationArray
Type:    Online System Char
Array to return the chars
destinationStart
Type:   Online System Int32
Position of the destination array of chars to start storing the chars
Return Value
An array of chars
See Also
TextSupport Class
TextSupport Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ThreadClass Class

ThreadClass Class Lucene.Net Class Library
Support class used to handle threads
Inheritance Hierarchy
Online System Object
Lucene.Net.Support ThreadClass
Lucene.Net.Index ConcurrentMergeScheduler MergeThread

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ThreadClass : IThreadRunnable
public class ThreadClass : IThreadRunnable
Public Class ThreadClass _
    Implements IThreadRunnable
Public Class ThreadClass _
    Implements IThreadRunnable
public ref class ThreadClass : IThreadRunnable
public ref class ThreadClass : IThreadRunnable
See Also
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ThreadClass Members

ThreadClass Members Lucene.Net Class Library

The ThreadClass type exposes the following members.
Constructors
 | Name | Description
Public method | ThreadClass | Initializes a new instance of the ThreadClass class
Public method | ThreadClass(String) | Initializes a new instance of the Thread class.
Public method | ThreadClass(ThreadStart) | Initializes a new instance of the Thread class.
Public method | ThreadClass(ThreadStart, String) | Initializes a new instance of the Thread class.
Back to Top
Methods
 | Name | Description
Public method | Abort | Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread
Public method | Abort(Object) | Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread while also providing exception information about the thread termination. Calling this method usually terminates the thread.
 | Current | Gets the currently running thread
 | CurrentThread |
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Interrupt | Interrupts a thread that is in the WaitSleepJoin thread state
Public method | Join | Blocks the calling thread until a thread terminates
Public method | Join(Int64) | Blocks the calling thread until a thread terminates or the specified time elapses
Public method | Join(Int64, Int32) | Blocks the calling thread until a thread terminates or the specified time elapses
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Resume | Resumes a thread that has been suspended
Public method | Run | This method has no functionality unless the method is overridden
Public method | SetDaemon |
 | Sleep |
Public method | Start | Causes the operating system to change the state of the current thread instance to ThreadState.Running
Public method | Suspend | Suspends the thread, if the thread is already suspended it has no effect
Public method | ToString | Obtain a String that represents the current object (Overrides Online Object ToString .)
Back to Top
Operators
Name | Description
Equality |
Inequality |
Back to Top
Properties
 | Name | Description
Public property | Instance | Gets the current thread instance
Public property | IsAlive | Gets a value indicating the execution status of the current thread
Public property | IsBackground | Gets or sets a value indicating whether or not a thread is a background thread.
Public property | Name | Gets or sets the name of the thread
Public property | Priority | Gets or sets a value indicating the scheduling priority of a thread
Back to Top
See Also
ThreadClass Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ThreadClass Constructor

ThreadClass Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | ThreadClass | Initializes a new instance of the ThreadClass class
Public method | ThreadClass(String) | Initializes a new instance of the Thread class.
Public method | ThreadClass(ThreadStart) | Initializes a new instance of the Thread class.
Public method | ThreadClass(ThreadStart, String) | Initializes a new instance of the Thread class.
Back to Top
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ThreadClass Constructor

ThreadClass Constructor Lucene.Net Class Library
Initializes a new instance of the ThreadClass class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ThreadClass()
public ThreadClass()
Public Sub New
Public Sub New
public:
ThreadClass()
public:
ThreadClass()
See Also
ThreadClass Class
ThreadClass Members
ThreadClass Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ThreadClass Constructor (String)

ThreadClass Constructor (String) Lucene.Net Class Library
Initializes a new instance of the Thread class.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ThreadClass(
    string Name
)
public ThreadClass(
    string Name
)
Public Sub New ( _
    Name As String _
)
Public Sub New ( _
    Name As String _
)
public:
ThreadClass(
    String^ Name
)
public:
ThreadClass(
    String^ Name
)
Parameters
Name
Type:   Online System String
The name of the thread
See Also
ThreadClass Class
ThreadClass Members
ThreadClass Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ThreadClass Constructor (ThreadStart)

ThreadClass Constructor (ThreadStart) Lucene.Net Class Library
Initializes a new instance of the Thread class.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ThreadClass(
    ThreadStart Start
)
public ThreadClass(
    ThreadStart Start
)
Public Sub New ( _
    Start As ThreadStart _
)
Public Sub New ( _
    Start As ThreadStart _
)
public:
ThreadClass(
    ThreadStart^ Start
)
public:
ThreadClass(
    ThreadStart^ Start
)
Parameters
Start
Type:   Online System.Threading ThreadStart
A ThreadStart delegate that references the methods to be invoked when this thread begins executing
See Also
ThreadClass Class
ThreadClass Members
ThreadClass Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ThreadClass Constructor (ThreadStart, String)

ThreadClass Constructor (ThreadStart, String) Lucene.Net Class Library
Initializes a new instance of the Thread class.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ThreadClass(
    ThreadStart Start,
    string Name
)
public ThreadClass(
    ThreadStart Start,
    string Name
)
Public Sub New ( _
    Start As ThreadStart, _
    Name As String _
)
Public Sub New ( _
    Start As ThreadStart, _
    Name As String _
)
public:
ThreadClass(
    ThreadStart^ Start,
    String^ Name
)
public:
ThreadClass(
    ThreadStart^ Start,
    String^ Name
)
Parameters
Start
Type:   Online System.Threading ThreadStart
A ThreadStart delegate that references the methods to be invoked when this thread begins executing
Name
Type:   Online System String
The name of the thread
See Also
ThreadClass Class
ThreadClass Members
ThreadClass Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ThreadClass Methods

ThreadClass Methods Lucene.Net Class Library
The ThreadClass type exposes the following members.
Methods
 | Name | Description
Public method | Abort | Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread
Public method | Abort(Object) | Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread while also providing exception information about the thread termination. Calling this method usually terminates the thread.
 | Current | Gets the currently running thread
 | CurrentThread |
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Interrupt | Interrupts a thread that is in the WaitSleepJoin thread state
Public method | Join | Blocks the calling thread until a thread terminates
Public method | Join(Int64) | Blocks the calling thread until a thread terminates or the specified time elapses
Public method | Join(Int64, Int32) | Blocks the calling thread until a thread terminates or the specified time elapses
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Resume | Resumes a thread that has been suspended
Public method | Run | This method has no functionality unless the method is overridden
Public method | SetDaemon |
 | Sleep |
Public method | Start | Causes the operating system to change the state of the current thread instance to ThreadState.Running
Public method | Suspend | Suspends the thread, if the thread is already suspended it has no effect
Public method | ToString | Obtain a String that represents the current object (Overrides Online Object ToString .)
Back to Top
See Also
ThreadClass Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Abort Method

ThreadClass Abort Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Abort | Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread
Public method | Abort(Object) | Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread while also providing exception information about the thread termination. Calling this method usually terminates the thread.
Back to Top
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Abort Method

ThreadClass Abort Method Lucene.Net Class Library
Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Abort()
public void Abort()
Public Sub Abort
Public Sub Abort
public:
void Abort()
public:
void Abort()
See Also
ThreadClass Class
ThreadClass Members
Abort Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Abort Method (Object)

ThreadClass Abort Method (Object) Lucene.Net Class Library
Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread while also providing exception information about the thread termination. Calling this method usually terminates the thread.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Abort(
    Object stateInfo
)
public void Abort(
    Object stateInfo
)
Public Sub Abort ( _
    stateInfo As Object _
)
Public Sub Abort ( _
    stateInfo As Object _
)
public:
void Abort(
    Object^ stateInfo
)
public:
void Abort(
    Object^ stateInfo
)
Parameters
stateInfo
Type:   Online System Object
An object that contains application-specific information, such as state, which can be used by the thread being aborted
See Also
ThreadClass Class
ThreadClass Members
Abort Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Current Method

ThreadClass Current Method Lucene.Net Class Library
Gets the currently running thread

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ThreadClass Current()
public static ThreadClass Current()
Public Shared Function Current As ThreadClass
Public Shared Function Current As ThreadClass
public:
static ThreadClass^ Current()
public:
static ThreadClass^ Current()
Return Value
The currently running thread
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CurrentThread Method

ThreadClass CurrentThread Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ThreadClass CurrentThread()
public static ThreadClass CurrentThread()
Public Shared Function CurrentThread As ThreadClass
Public Shared Function CurrentThread As ThreadClass
public:
static ThreadClass^ CurrentThread()
public:
static ThreadClass^ CurrentThread()
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

ThreadClass Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

ThreadClass GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Interrupt Method

ThreadClass Interrupt Method Lucene.Net Class Library
Interrupts a thread that is in the WaitSleepJoin thread state

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Interrupt()
public virtual void Interrupt()
Public Overridable Sub Interrupt
Public Overridable Sub Interrupt
public:
virtual void Interrupt()
public:
virtual void Interrupt()
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Join Method

ThreadClass Join Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Join | Blocks the calling thread until a thread terminates
Public method | Join(Int64) | Blocks the calling thread until a thread terminates or the specified time elapses
Public method | Join(Int64, Int32) | Blocks the calling thread until a thread terminates or the specified time elapses
Back to Top
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Join Method

ThreadClass Join Method Lucene.Net Class Library
Blocks the calling thread until a thread terminates

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Join()
public void Join()
Public Sub Join
Public Sub Join
public:
void Join()
public:
void Join()
See Also
ThreadClass Class
ThreadClass Members
Join Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Join Method (Int64)

ThreadClass Join Method (Int64) Lucene.Net Class Library
Blocks the calling thread until a thread terminates or the specified time elapses

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Join(
    long MiliSeconds
)
public void Join(
    long MiliSeconds
)
Public Sub Join ( _
    MiliSeconds As Long _
)
Public Sub Join ( _
    MiliSeconds As Long _
)
public:
void Join(
    long long MiliSeconds
)
public:
void Join(
    long long MiliSeconds
)
Parameters
MiliSeconds
Type:   Online System Int64
Time of wait in milliseconds
See Also
ThreadClass Class
ThreadClass Members
Join Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Join Method (Int64, Int32)

ThreadClass Join Method (Int64, Int32) Lucene.Net Class Library
Blocks the calling thread until a thread terminates or the specified time elapses

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Join(
    long MiliSeconds,
    int NanoSeconds
)
public void Join(
    long MiliSeconds,
    int NanoSeconds
)
Public Sub Join ( _
    MiliSeconds As Long, _
    NanoSeconds As Integer _
)
Public Sub Join ( _
    MiliSeconds As Long, _
    NanoSeconds As Integer _
)
public:
void Join(
    long long MiliSeconds,
    int NanoSeconds
)
public:
void Join(
    long long MiliSeconds,
    int NanoSeconds
)
Parameters
MiliSeconds
Type:   Online System Int64
Time of wait in milliseconds
NanoSeconds
Type:   Online System Int32
Time of wait in nanoseconds
See Also
ThreadClass Class
ThreadClass Members
Join Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Resume Method

ThreadClass Resume Method Lucene.Net Class Library
Resumes a thread that has been suspended

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Resume()
public void Resume()
Public Sub Resume
Public Sub Resume
public:
void Resume()
public:
void Resume()
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Run Method

ThreadClass Run Method Lucene.Net Class Library
This method has no functionality unless the method is overridden

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Run()
public virtual void Run()
Public Overridable Sub Run
Public Overridable Sub Run
public:
virtual void Run()
public:
virtual void Run()
Implements
IThreadRunnable Run
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetDaemon Method

ThreadClass SetDaemon Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetDaemon(
    bool isDaemon
)
public void SetDaemon(
    bool isDaemon
)
Public Sub SetDaemon ( _
    isDaemon As Boolean _
)
Public Sub SetDaemon ( _
    isDaemon As Boolean _
)
public:
void SetDaemon(
    bool isDaemon
)
public:
void SetDaemon(
    bool isDaemon
)
Parameters
isDaemon
Type:   Online System Boolean
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Sleep Method

ThreadClass Sleep Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Sleep(
    long ms
)
public static void Sleep(
    long ms
)
Public Shared Sub Sleep ( _
    ms As Long _
)
Public Shared Sub Sleep ( _
    ms As Long _
)
public:
static void Sleep(
    long long ms
)
public:
static void Sleep(
    long long ms
)
Parameters
ms
Type:   Online System Int64
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Start Method

ThreadClass Start Method Lucene.Net Class Library
Causes the operating system to change the state of the current thread instance to ThreadState.Running

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Start()
public virtual void Start()
Public Overridable Sub Start
Public Overridable Sub Start
public:
virtual void Start()
public:
virtual void Start()
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Suspend Method

ThreadClass Suspend Method Lucene.Net Class Library
Suspends the thread, if the thread is already suspended it has no effect

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Suspend()
public void Suspend()
Public Sub Suspend
Public Sub Suspend
public:
void Suspend()
public:
void Suspend()
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

ThreadClass ToString Method Lucene.Net Class Library
Obtain a String that represents the current object

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
Return Value
A String that represents the current object
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ThreadClass Operators

ThreadClass Operators Lucene.Net Class Library
The ThreadClass type exposes the following members.
Operators
Name | Description
Equality |
Inequality |
Back to Top
See Also
ThreadClass Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equality Operator

ThreadClass Equality Operator Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ThreadClass t1,
    Object t2
)
public static bool operator ==(
    ThreadClass t1,
    Object t2
)
Public Shared Operator = ( _
    t1 As ThreadClass, _
    t2 As Object _
) As Boolean
Public Shared Operator = ( _
    t1 As ThreadClass, _
    t2 As Object _
) As Boolean
public:
static bool operator ==(
    ThreadClass^ t1,
    Object^ t2
)
public:
static bool operator ==(
    ThreadClass^ t1,
    Object^ t2
)
Parameters
t1
Type: Lucene.Net.Support ThreadClass
t2
Type:   Online System Object
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Inequality Operator

ThreadClass Inequality Operator Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ThreadClass t1,
    Object t2
)
public static bool operator !=(
    ThreadClass t1,
    Object t2
)
Public Shared Operator <> ( _
    t1 As ThreadClass, _
    t2 As Object _
) As Boolean
Public Shared Operator <> ( _
    t1 As ThreadClass, _
    t2 As Object _
) As Boolean
public:
static bool operator !=(
    ThreadClass^ t1,
    Object^ t2
)
public:
static bool operator !=(
    ThreadClass^ t1,
    Object^ t2
)
Parameters
t1
Type: Lucene.Net.Support ThreadClass
t2
Type:   Online System Object
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ThreadClass Properties

ThreadClass Properties Lucene.Net Class Library
The ThreadClass type exposes the following members.
Properties
 | Name | Description
Public property | Instance | Gets the current thread instance
Public property | IsAlive | Gets a value indicating the execution status of the current thread
Public property | IsBackground | Gets or sets a value indicating whether or not a thread is a background thread.
Public property | Name | Gets or sets the name of the thread
Public property | Priority | Gets or sets a value indicating the scheduling priority of a thread
Back to Top
See Also
ThreadClass Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Instance Property

ThreadClass Instance Property Lucene.Net Class Library
Gets the current thread instance

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Thread Instance { get; set; }
public Thread Instance { get; set; }
Public Property Instance As Thread
    Get
    Set
Public Property Instance As Thread
    Get
    Set
public:
property Thread^ Instance {
    Thread^ get ();
    void set (Thread^ value);
}
public:
property Thread^ Instance {
    Thread^ get ();
    void set (Thread^ value);
}
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsAlive Property

ThreadClass IsAlive Property Lucene.Net Class Library
Gets a value indicating the execution status of the current thread

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsAlive { get; }
public bool IsAlive { get; }
Public ReadOnly Property IsAlive As Boolean
    Get
Public ReadOnly Property IsAlive As Boolean
    Get
public:
property bool IsAlive {
    bool get ();
}
public:
property bool IsAlive {
    bool get ();
}
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsBackground Property

ThreadClass IsBackground Property Lucene.Net Class Library
Gets or sets a value indicating whether or not a thread is a background thread.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsBackground { get; set; }
public bool IsBackground { get; set; }
Public Property IsBackground As Boolean
    Get
    Set
Public Property IsBackground As Boolean
    Get
    Set
public:
property bool IsBackground {
    bool get ();
    void set (bool value);
}
public:
property bool IsBackground {
    bool get ();
    void set (bool value);
}
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Name Property

ThreadClass Name Property Lucene.Net Class Library
Gets or sets the name of the thread

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Public Property Name As String
    Get
    Set
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Priority Property

ThreadClass Priority Property Lucene.Net Class Library
Gets or sets a value indicating the scheduling priority of a thread

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ThreadPriority Priority { get; set; }
public ThreadPriority Priority { get; set; }
Public Property Priority As ThreadPriority
    Get
    Set
Public Property Priority As ThreadPriority
    Get
    Set
public:
property ThreadPriority Priority {
    ThreadPriority get ();
    void set (ThreadPriority value);
}
public:
property ThreadPriority Priority {
    ThreadPriority get ();
    void set (ThreadPriority value);
}
See Also
ThreadClass Class
ThreadClass Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ThreadLock Class

ThreadLock Class Lucene.Net Class Library
Abstract base class that provides a synchronization interface for derived lock types
Inheritance Hierarchy
Online System Object
Lucene.Net.Support ThreadLock

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ThreadLock
public abstract class ThreadLock
Public MustInherit Class ThreadLock
Public MustInherit Class ThreadLock
public ref class ThreadLock abstract
public ref class ThreadLock abstract
See Also
ThreadLock Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ThreadLock Members

ThreadLock Members Lucene.Net Class Library

The ThreadLock type exposes the following members.
Constructors
 | Name | Description
Protected method | ThreadLock | Initializes a new instance of the ThreadLock class
Back to Top
Methods
 | Name | Description
Public method | Enter |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Exit |
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
Name | Description
MonitorLock | Wrapper class for the Monitor Enter/Exit methods using the ThreadLock interface
NullLock | A ThreadLock class that actually does no locking Used in ParallelMultiSearcher/MultiSearcher
Back to Top
See Also
ThreadLock Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ThreadLock Constructor

ThreadLock Constructor Lucene.Net Class Library
Initializes a new instance of the ThreadLock class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ThreadLock()
protected ThreadLock()
Protected Sub New
Protected Sub New
protected:
ThreadLock()
protected:
ThreadLock()
See Also
ThreadLock Class
ThreadLock Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ThreadLock Methods

ThreadLock Methods Lucene.Net Class Library
The ThreadLock type exposes the following members.
Methods
 | Name | Description
Public method | Enter |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Exit |
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ThreadLock Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Enter Method

ThreadLock Enter Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Enter(
    Object obj
)
public abstract void Enter(
    Object obj
)
Public MustOverride Sub Enter ( _
    obj As Object _
)
Public MustOverride Sub Enter ( _
    obj As Object _
)
public:
virtual void Enter(
    Object^ obj
) abstract
public:
virtual void Enter(
    Object^ obj
) abstract
Parameters
obj
Type:   Online System Object
See Also
ThreadLock Class
ThreadLock Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Exit Method

ThreadLock Exit Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Exit(
    Object obj
)
public abstract void Exit(
    Object obj
)
Public MustOverride Sub Exit ( _
    obj As Object _
)
Public MustOverride Sub Exit ( _
    obj As Object _
)
public:
virtual void Exit(
    Object^ obj
) abstract
public:
virtual void Exit(
    Object^ obj
) abstract
Parameters
obj
Type:   Online System Object
See Also
ThreadLock Class
ThreadLock Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ThreadLock Properties

ThreadLock Properties Lucene.Net Class Library
The ThreadLock type exposes the following members.
Properties
Name | Description
MonitorLock | Wrapper class for the Monitor Enter/Exit methods using the ThreadLock interface
NullLock | A ThreadLock class that actually does no locking Used in ParallelMultiSearcher/MultiSearcher
Back to Top
See Also
ThreadLock Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MonitorLock Property

ThreadLock MonitorLock Property Lucene.Net Class Library
Wrapper class for the Monitor Enter/Exit methods using the ThreadLock interface

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ThreadLock MonitorLock { get; }
public static ThreadLock MonitorLock { get; }
Public Shared ReadOnly Property MonitorLock As ThreadLock
    Get
Public Shared ReadOnly Property MonitorLock As ThreadLock
    Get
public:
static property ThreadLock^ MonitorLock {
    ThreadLock^ get ();
}
public:
static property ThreadLock^ MonitorLock {
    ThreadLock^ get ();
}
See Also
ThreadLock Class
ThreadLock Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NullLock Property

ThreadLock NullLock Property Lucene.Net Class Library
A ThreadLock class that actually does no locking Used in ParallelMultiSearcher/MultiSearcher

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ThreadLock NullLock { get; }
public static ThreadLock NullLock { get; }
Public Shared ReadOnly Property NullLock As ThreadLock
    Get
Public Shared ReadOnly Property NullLock As ThreadLock
    Get
public:
static property ThreadLock^ NullLock {
    ThreadLock^ get ();
}
public:
static property ThreadLock^ NullLock {
    ThreadLock^ get ();
}
See Also
ThreadLock Class
ThreadLock Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WeakDictionary(TKey, TValue) Class

WeakDictionary TKey, TValue Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Support WeakDictionary TKey, TValue

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class WeakDictionary<TKey, TValue> : IDictionary<TKey, TValue>,
    ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>,
    IEnumerable
public sealed class WeakDictionary<TKey, TValue> : IDictionary<TKey, TValue>,
    ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>,
    IEnumerable
Public NotInheritable Class WeakDictionary(Of TKey, TValue) _
    Implements IDictionary(Of TKey, TValue), ICollection(Of KeyValuePair(Of TKey, TValue)),  _
    IEnumerable(Of KeyValuePair(Of TKey, TValue)), IEnumerable
Public NotInheritable Class WeakDictionary(Of TKey, TValue) _
    Implements IDictionary(Of TKey, TValue), ICollection(Of KeyValuePair(Of TKey, TValue)),  _
    IEnumerable(Of KeyValuePair(Of TKey, TValue)), IEnumerable
generic<typename TKey, typename TValue>
public ref class WeakDictionary sealed : IDictionary<TKey, TValue>,
    ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>,
    IEnumerable
generic<typename TKey, typename TValue>
public ref class WeakDictionary sealed : IDictionary<TKey, TValue>,
    ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>,
    IEnumerable
Type Parameters
TKey
TValue
See Also
WeakDictionary TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WeakDictionary(TKey, TValue) Members

WeakDictionary TKey, TValue Members Lucene.Net Class Library

The WeakDictionary TKey, TValue type exposes the following members.
Constructors
 | Name | Description
Public method | WeakDictionary TKey, TValue | Initializes a new instance of the WeakDictionary TKey, TValue class
Public method | WeakDictionary TKey, TValue (IEnumerable KeyValuePair TKey, TValue ) | Initializes a new instance of the WeakDictionary TKey, TValue class
Public method | WeakDictionary TKey, TValue (Int32) | Initializes a new instance of the WeakDictionary TKey, TValue class
Back to Top
Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | ContainsKey |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | TryGetValue |
Back to Top
Properties
 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Public property | Keys |
Public property | Values |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue Add | Adds an item to the Online ICollection T .
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue Contains | Determines whether the Online ICollection T contains a specific value.
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue CopyTo | Copies the elements of the Online ICollection T to an Online Array, starting at a particular Online Array index.
Explicit interface implemetation | IEnumerable GetEnumerator | Returns an enumerator that iterates through a collection.
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue Remove | Removes the first occurrence of a specific object from the Online ICollection T .
Back to Top
See Also
WeakDictionary TKey, TValue Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WeakDictionary(TKey, TValue) Constructor

WeakDictionary TKey, TValue Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | WeakDictionary TKey, TValue | Initializes a new instance of the WeakDictionary TKey, TValue class
Public method | WeakDictionary TKey, TValue (IEnumerable KeyValuePair TKey, TValue ) | Initializes a new instance of the WeakDictionary TKey, TValue class
Public method | WeakDictionary TKey, TValue (Int32) | Initializes a new instance of the WeakDictionary TKey, TValue class
Back to Top
See Also
WeakDictionary TKey, TValue Class
WeakDictionary TKey, TValue Members
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WeakDictionary(TKey, TValue) Constructor

WeakDictionary TKey, TValue Constructor Lucene.Net Class Library
Initializes a new instance of the WeakDictionary TKey, TValue class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WeakDictionary()
public WeakDictionary()
Public Sub New
Public Sub New
public:
WeakDictionary()
public:
WeakDictionary()
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
WeakDictionary TKey, TValue  Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WeakDictionary(TKey, TValue) Constructor (IEnumerable(KeyValuePair(TKey, TValue)))

WeakDictionary TKey, TValue Constructor (IEnumerable KeyValuePair TKey, TValue ) Lucene.Net Class Library
Initializes a new instance of the WeakDictionary TKey, TValue class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WeakDictionary(
    IEnumerable<KeyValuePair<TKey, TValue>> otherDictionary
)
public WeakDictionary(
    IEnumerable<KeyValuePair<TKey, TValue>> otherDictionary
)
Public Sub New ( _
    otherDictionary As IEnumerable(Of KeyValuePair(Of TKey, TValue)) _
)
Public Sub New ( _
    otherDictionary As IEnumerable(Of KeyValuePair(Of TKey, TValue)) _
)
public:
WeakDictionary(
    IEnumerable<KeyValuePair<TKey, TValue>>^ otherDictionary
)
public:
WeakDictionary(
    IEnumerable<KeyValuePair<TKey, TValue>>^ otherDictionary
)
Parameters
otherDictionary
Type:   Online System.Collections.Generic IEnumerable    Online KeyValuePair  TKey, TValue
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
WeakDictionary TKey, TValue  Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WeakDictionary(TKey, TValue) Constructor (Int32)

WeakDictionary TKey, TValue Constructor (Int32) Lucene.Net Class Library
Initializes a new instance of the WeakDictionary TKey, TValue class

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WeakDictionary(
    int initialCapacity
)
public WeakDictionary(
    int initialCapacity
)
Public Sub New ( _
    initialCapacity As Integer _
)
Public Sub New ( _
    initialCapacity As Integer _
)
public:
WeakDictionary(
    int initialCapacity
)
public:
WeakDictionary(
    int initialCapacity
)
Parameters
initialCapacity
Type:   Online System Int32
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
WeakDictionary TKey, TValue  Overload
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WeakDictionary(TKey, TValue) Methods

WeakDictionary TKey, TValue Methods Lucene.Net Class Library
The WeakDictionary TKey, TValue type exposes the following members.
Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | ContainsKey |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | TryGetValue |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue Add | Adds an item to the Online ICollection T .
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue Contains | Determines whether the Online ICollection T contains a specific value.
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue CopyTo | Copies the elements of the Online ICollection T to an Online Array, starting at a particular Online Array index.
Explicit interface implemetation | IEnumerable GetEnumerator | Returns an enumerator that iterates through a collection.
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue Remove | Removes the first occurrence of a specific object from the Online ICollection T .
Back to Top
See Also
WeakDictionary TKey, TValue Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ICollection(KeyValuePair(TKey, TValue)).Add Method

WeakDictionary TKey, TValue ICollection KeyValuePair TKey, TValue Add Method Lucene.Net Class Library
Adds an item to the Online ICollection T .

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ICollection<KeyValuePair<TKey, TValue>>.Add(
    KeyValuePair<TKey, TValue> item
)
void ICollection<KeyValuePair<TKey, TValue>>.Add(
    KeyValuePair<TKey, TValue> item
)
Private Sub Add ( _
    item As KeyValuePair(Of TKey, TValue) _
) Implements ICollection(Of KeyValuePair(Of TKey, TValue)).Add
Private Sub Add ( _
    item As KeyValuePair(Of TKey, TValue) _
) Implements ICollection(Of KeyValuePair(Of TKey, TValue)).Add
private:
virtual void Add(
    KeyValuePair<TKey, TValue> item
) sealed = ICollection<KeyValuePair<TKey, TValue>>::Add
private:
virtual void Add(
    KeyValuePair<TKey, TValue> item
) sealed = ICollection<KeyValuePair<TKey, TValue>>::Add
Parameters
item
Type:   Online System.Collections.Generic KeyValuePair  TKey, TValue
The object to add to the   Online ICollection T .
Implements
  Online ICollection T  Add(T)
Exceptions
Exception | Condition
Online System NotSupportedException | The Online ICollection T is read-only.
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ICollection(KeyValuePair(TKey, TValue)).Contains Method

WeakDictionary TKey, TValue ICollection KeyValuePair TKey, TValue Contains Method Lucene.Net Class Library
Determines whether the Online ICollection T contains a specific value.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ICollection<KeyValuePair<TKey, TValue>>.Contains(
    KeyValuePair<TKey, TValue> item
)
bool ICollection<KeyValuePair<TKey, TValue>>.Contains(
    KeyValuePair<TKey, TValue> item
)
Private Function Contains ( _
    item As KeyValuePair(Of TKey, TValue) _
) As Boolean Implements ICollection(Of KeyValuePair(Of TKey, TValue)).Contains
Private Function Contains ( _
    item As KeyValuePair(Of TKey, TValue) _
) As Boolean Implements ICollection(Of KeyValuePair(Of TKey, TValue)).Contains
private:
virtual bool Contains(
    KeyValuePair<TKey, TValue> item
) sealed = ICollection<KeyValuePair<TKey, TValue>>::Contains
private:
virtual bool Contains(
    KeyValuePair<TKey, TValue> item
) sealed = ICollection<KeyValuePair<TKey, TValue>>::Contains
Parameters
item
Type:   Online System.Collections.Generic KeyValuePair  TKey, TValue
The object to locate in the   Online ICollection T .
Return Value
true if item is found in the   Online ICollection T ; otherwise, false.
Implements
  Online ICollection T  Contains(T)
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ICollection(KeyValuePair(TKey, TValue)).CopyTo Method

WeakDictionary TKey, TValue ICollection KeyValuePair TKey, TValue CopyTo Method Lucene.Net Class Library
Copies the elements of the Online ICollection T to an Online Array, starting at a particular Online Array index.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ICollection<KeyValuePair<TKey, TValue>>.CopyTo(
    KeyValuePair<TKey, TValue>[] array,
    int arrayIndex
)
void ICollection<KeyValuePair<TKey, TValue>>.CopyTo(
    KeyValuePair<TKey, TValue>[] array,
    int arrayIndex
)
Private Sub CopyTo ( _
    array As KeyValuePair(Of TKey, TValue)(), _
    arrayIndex As Integer _
) Implements ICollection(Of KeyValuePair(Of TKey, TValue)).CopyTo
Private Sub CopyTo ( _
    array As KeyValuePair(Of TKey, TValue)(), _
    arrayIndex As Integer _
) Implements ICollection(Of KeyValuePair(Of TKey, TValue)).CopyTo
private:
virtual void CopyTo(
    array<KeyValuePair<TKey, TValue>>^ array,
    int arrayIndex
) sealed = ICollection<KeyValuePair<TKey, TValue>>::CopyTo
private:
virtual void CopyTo(
    array<KeyValuePair<TKey, TValue>>^ array,
    int arrayIndex
) sealed = ICollection<KeyValuePair<TKey, TValue>>::CopyTo
Parameters
array
Type:    Online System.Collections.Generic KeyValuePair  TKey, TValue
The one-dimensional   Online Array that is the destination of the elements copied from   Online ICollection T . The   Online Array must have zero-based indexing.
arrayIndex
Type:   Online System Int32
The zero-based index in array at which copying begins.
Implements
  Online ICollection T  CopyTo( T , Int32)
Exceptions
Exception | Condition
Online System ArgumentNullException | array is null.
Online System ArgumentOutOfRangeException | arrayIndex is less than 0.
Online System ArgumentException | array is multidimensional.-or-The number of elements in the source Online ICollection T is greater than the available space from arrayIndex to the end of the destination array.-or-Type T cannot be cast automatically to the type of the destination array.
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IEnumerable.GetEnumerator Method

WeakDictionary TKey, TValue IEnumerable GetEnumerator Method Lucene.Net Class Library
Returns an enumerator that iterates through a collection.

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
Return Value
An   Online IEnumerator object that can be used to iterate through the collection.
Implements
  Online IEnumerable GetEnumerator
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ICollection(KeyValuePair(TKey, TValue)).Remove Method

WeakDictionary TKey, TValue ICollection KeyValuePair TKey, TValue Remove Method Lucene.Net Class Library
Removes the first occurrence of a specific object from the Online ICollection T .

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ICollection<KeyValuePair<TKey, TValue>>.Remove(
    KeyValuePair<TKey, TValue> item
)
bool ICollection<KeyValuePair<TKey, TValue>>.Remove(
    KeyValuePair<TKey, TValue> item
)
Private Function Remove ( _
    item As KeyValuePair(Of TKey, TValue) _
) As Boolean Implements ICollection(Of KeyValuePair(Of TKey, TValue)).Remove
Private Function Remove ( _
    item As KeyValuePair(Of TKey, TValue) _
) As Boolean Implements ICollection(Of KeyValuePair(Of TKey, TValue)).Remove
private:
virtual bool Remove(
    KeyValuePair<TKey, TValue> item
) sealed = ICollection<KeyValuePair<TKey, TValue>>::Remove
private:
virtual bool Remove(
    KeyValuePair<TKey, TValue> item
) sealed = ICollection<KeyValuePair<TKey, TValue>>::Remove
Parameters
item
Type:   Online System.Collections.Generic KeyValuePair  TKey, TValue
The object to remove from the   Online ICollection T .
Return Value
true if item was successfully removed from the   Online ICollection T ; otherwise, false. This method also returns false if item is not found in the original   Online ICollection T .
Implements
  Online ICollection T  Remove(T)
Exceptions
Exception | Condition
Online System NotSupportedException | The Online ICollection T is read-only.
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method

WeakDictionary TKey, TValue Add Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    TKey key,
    TValue value
)
public void Add(
    TKey key,
    TValue value
)
Public Sub Add ( _
    key As TKey, _
    value As TValue _
)
Public Sub Add ( _
    key As TKey, _
    value As TValue _
)
public:
virtual void Add(
    TKey key,
    TValue value
) sealed
public:
virtual void Add(
    TKey key,
    TValue value
) sealed
Parameters
key
Type: TKey
value
Type: TValue
Implements
  Online IDictionary TKey, TValue  Add(TKey, TValue)
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method

WeakDictionary TKey, TValue Clear Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
virtual void Clear() sealed
public:
virtual void Clear() sealed
Implements
  Online ICollection T  Clear
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ContainsKey Method

WeakDictionary TKey, TValue ContainsKey Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ContainsKey(
    TKey key
)
public bool ContainsKey(
    TKey key
)
Public Function ContainsKey ( _
    key As TKey _
) As Boolean
Public Function ContainsKey ( _
    key As TKey _
) As Boolean
public:
virtual bool ContainsKey(
    TKey key
) sealed
public:
virtual bool ContainsKey(
    TKey key
) sealed
Parameters
key
Type: TKey
Implements
  Online IDictionary TKey, TValue  ContainsKey(TKey)
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetEnumerator Method

WeakDictionary TKey, TValue GetEnumerator Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<KeyValuePair<TKey, TValue>> GetEnumerator()
public IEnumerator<KeyValuePair<TKey, TValue>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of TKey, TValue))
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of TKey, TValue))
public:
virtual IEnumerator<KeyValuePair<TKey, TValue>>^ GetEnumerator() sealed
public:
virtual IEnumerator<KeyValuePair<TKey, TValue>>^ GetEnumerator() sealed
Implements
  Online IEnumerable T  GetEnumerator
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Remove Method

WeakDictionary TKey, TValue Remove Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Remove(
    TKey key
)
public bool Remove(
    TKey key
)
Public Function Remove ( _
    key As TKey _
) As Boolean
Public Function Remove ( _
    key As TKey _
) As Boolean
public:
virtual bool Remove(
    TKey key
) sealed
public:
virtual bool Remove(
    TKey key
) sealed
Parameters
key
Type: TKey
Implements
  Online IDictionary TKey, TValue  Remove(TKey)
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TryGetValue Method

WeakDictionary TKey, TValue TryGetValue Method Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryGetValue(
    TKey key,
    out TValue value
)
public bool TryGetValue(
    TKey key,
    out TValue value
)
Public Function TryGetValue ( _
    key As TKey, _
    <OutAttribute> ByRef value As TValue _
) As Boolean
Public Function TryGetValue ( _
    key As TKey, _
    <OutAttribute> ByRef value As TValue _
) As Boolean
public:
virtual bool TryGetValue(
    TKey key,
    [OutAttribute] TValue% value
) sealed
public:
virtual bool TryGetValue(
    TKey key,
    [OutAttribute] TValue% value
) sealed
Parameters
key
Type: TKey
value
Type: TValue
Implements
  Online IDictionary TKey, TValue  TryGetValue(TKey, TValue )
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WeakDictionary(TKey, TValue) Properties

WeakDictionary TKey, TValue Properties Lucene.Net Class Library
The WeakDictionary TKey, TValue type exposes the following members.
Properties
 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Public property | Keys |
Public property | Values |
Back to Top
See Also
WeakDictionary TKey, TValue Class
Lucene.Net.Support Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Count Property

WeakDictionary TKey, TValue Count Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
public:
virtual property int Count {
    int get () sealed;
}
Implements
  Online ICollection T  Count
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsReadOnly Property

WeakDictionary TKey, TValue IsReadOnly Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsReadOnly { get; }
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
Implements
  Online ICollection T  IsReadOnly
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Item Property

WeakDictionary TKey, TValue Item Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TValue this[
    TKey key
] { get; set; }
public TValue this[
    TKey key
] { get; set; }
Public Default Property Item ( _
    key As TKey _
) As TValue
    Get
    Set
Public Default Property Item ( _
    key As TKey _
) As TValue
    Get
    Set
public:
virtual property TValue default[TKey key] {
    TValue get (TKey key) sealed;
    void set (TKey key, TValue value) sealed;
}
public:
virtual property TValue default[TKey key] {
    TValue get (TKey key) sealed;
    void set (TKey key, TValue value) sealed;
}
Parameters
key
Type: TKey
Implements
  Online IDictionary TKey, TValue  Item TKey
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Keys Property

WeakDictionary TKey, TValue Keys Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<TKey> Keys { get; }
public ICollection<TKey> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of TKey)
    Get
Public ReadOnly Property Keys As ICollection(Of TKey)
    Get
public:
virtual property ICollection<TKey>^ Keys {
    ICollection<TKey>^ get () sealed;
}
public:
virtual property ICollection<TKey>^ Keys {
    ICollection<TKey>^ get () sealed;
}
Implements
  Online IDictionary TKey, TValue  Keys
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Values Property

WeakDictionary TKey, TValue Values Property Lucene.Net Class Library

Namespace: Lucene.Net.Support
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<TValue> Values { get; }
public ICollection<TValue> Values { get; }
Public ReadOnly Property Values As ICollection(Of TValue)
    Get
Public ReadOnly Property Values As ICollection(Of TValue)
    Get
public:
virtual property ICollection<TValue>^ Values {
    ICollection<TValue>^ get () sealed;
}
public:
virtual property ICollection<TValue>^ Values {
    ICollection<TValue>^ get () sealed;
}
Implements
  Online IDictionary TKey, TValue  Values
See Also
WeakDictionary TKey, TValue  Class
WeakDictionary TKey, TValue  Members
Lucene.Net.Support Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lucene.Net.Support.Compatibility Namespace

Lucene.Net.Support.Compatibility Namespace Lucene.Net Class Library
Classes
 | Class | Description
Public class | SetFactory |

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetFactory Class

SetFactory Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Support.Compatibility SetFactory

Namespace: Lucene.Net.Support.Compatibility
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class SetFactory
public static class SetFactory
Public NotInheritable Class SetFactory
Public NotInheritable Class SetFactory
public ref class SetFactory abstract sealed
public ref class SetFactory abstract sealed
See Also
SetFactory Members
Lucene.Net.Support.Compatibility Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetFactory Members

SetFactory Members Lucene.Net Class Library

Methods
Name | Description
CreateHashSet T |
CreateHashSet T (IEnumerable T ) |
Back to Top
See Also
SetFactory Class
Lucene.Net.Support.Compatibility Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetFactory Methods

SetFactory Methods Lucene.Net Class Library
Methods
Name | Description
CreateHashSet T |
CreateHashSet T (IEnumerable T ) |
Back to Top
See Also
SetFactory Class
Lucene.Net.Support.Compatibility Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateHashSet Method

SetFactory CreateHashSet Method Lucene.Net Class Library
Overload List
Name | Description
CreateHashSet T |
CreateHashSet T (IEnumerable T ) |
Back to Top
See Also
SetFactory Class
SetFactory Members
Lucene.Net.Support.Compatibility Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateHashSet(T) Method

SetFactory CreateHashSet T Method Lucene.Net Class Library

Namespace: Lucene.Net.Support.Compatibility
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ISet<T> CreateHashSet<T>()
public static ISet<T> CreateHashSet<T>()
Public Shared Function CreateHashSet(Of T) As ISet(Of T)
Public Shared Function CreateHashSet(Of T) As ISet(Of T)
public:
generic<typename T>
static ISet<T>^ CreateHashSet()
public:
generic<typename T>
static ISet<T>^ CreateHashSet()
Type Parameters
T
See Also
SetFactory Class
SetFactory Members
CreateHashSet Overload
Lucene.Net.Support.Compatibility Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateHashSet(T) Method (IEnumerable(T))

SetFactory CreateHashSet T Method (IEnumerable T ) Lucene.Net Class Library

Namespace: Lucene.Net.Support.Compatibility
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ISet<T> CreateHashSet<T>(
    IEnumerable<T> other
)
public static ISet<T> CreateHashSet<T>(
    IEnumerable<T> other
)
Public Shared Function CreateHashSet(Of T) ( _
    other As IEnumerable(Of T) _
) As ISet(Of T)
Public Shared Function CreateHashSet(Of T) ( _
    other As IEnumerable(Of T) _
) As ISet(Of T)
public:
generic<typename T>
static ISet<T>^ CreateHashSet(
    IEnumerable<T>^ other
)
public:
generic<typename T>
static ISet<T>^ CreateHashSet(
    IEnumerable<T>^ other
)
Parameters
other
Type:   Online System.Collections.Generic IEnumerable  T
Type Parameters
T
See Also
SetFactory Class
SetFactory Members
CreateHashSet Overload
Lucene.Net.Support.Compatibility Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lucene.Net.Util Namespace

Lucene.Net.Util Namespace Lucene.Net Class Library
Classes
Class | Description
Public class ArrayUtil
Methods for manipulating arrays.
Public class Attribute
Base class for Attributes that can be added to a AttributeSource.

Attributes are used to add data in a dynamic, yet type-safe way to a source of usually streamed objects, e. g. a TokenStream.
Public class AttributeSource
An AttributeSource contains a list of different Attributes, and methods to add and get them. There can only be a single instance of an attribute in the same AttributeSource instance. This is ensured by passing in the actual type of the Attribute (Class<Attribute>) to the AddAttribute T , which then checks if an instance of that type is already present. If yes, it returns the instance, otherwise it creates a new instance and returns it.
Public class AttributeSource AttributeFactory
An AttributeFactory creates instances of Attributes.
Public class AttributeSource State
This class holds the state of an AttributeSource.
Public class AverageGuessMemoryModel
An average, best guess, MemoryModel that should work okay on most systems.
Public class BitUtil
A variety of high efficiencly bit twiddling routines.
Public class BitVector
Optimized implementation of a vector of bits. This is more-or-less like java.util.BitSet, but also includes the following:
  • a count() method, which efficiently computes the number of one bits;
  • optimized read from and write to disk;
  • inlinable get() method;
  • store and load, as bit set or d-gaps, depending on sparseness;
Public class CloseableThreadLocal T
Java's builtin ThreadLocal has a serious flaw: it can take an arbitrarily long amount of time to dereference the things you had stored in it, even once the ThreadLocal instance itself is no longer referenced. This is because there is single, master map stored for each thread, which all ThreadLocals share, and that master map only periodically purges "stale" entries. While not technically a memory leak, because eventually the memory will be reclaimed, it can take a long time and you can easily hit OutOfMemoryError because from the GC's standpoint the stale entries are not reclaimaible. This class works around that, by only enrolling WeakReference values into the ThreadLocal, and separately holding a hard reference to each stored value. When you call Close , these hard references are cleared and then GC is freely able to reclaim space by objects stored in it.
Public class Constants
Some useful constants.
Public class DocIdBitSet
Simple DocIdSet and DocIdSetIterator backed by a BitSet
Public class FieldCacheSanityChecker
Provides methods for sanity checking that entries in the FieldCache are not wasteful or inconsistent.

Lucene 2.9 Introduced numerous enhancements into how the FieldCache is used by the low levels of Lucene searching (for Sorting and ValueSourceQueries) to improve both the speed for Sorting, as well as reopening of IndexReaders. But these changes have shifted the usage of FieldCache from "top level" IndexReaders (frequently a MultiReader or DirectoryReader) down to the leaf level SegmentReaders. As a result, existing applications that directly access the FieldCache may find RAM usage increase significantly when upgrading to 2.9 or Later. This class provides an API for these applications (or their Unit tests) to check at run time if the FieldCache contains "insane" usages of the FieldCache.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

Public class FieldCacheSanityChecker Insanity
Simple container for a collection of related CacheEntry objects that in conjunction with eachother represent some "insane" usage of the FieldCache.
Public class FieldCacheSanityChecker InsanityType
An Enumaration of the differnet types of "insane" behavior that may be detected in a FieldCache.
Public class IdentityDictionary TKey, TValue
A class that mimics Java's IdentityHashMap in that it determines object equality solely on ReferenceEquals rather than (possibly overloaded) object.Equals(). NOTE: Java's documentation on IdentityHashMap says that it also uses ReferenceEquals on it's Values as well. This class does not follow this behavior
Public class IndexableBinaryStringTools
Provides support for converting byte sequences to Strings and back again. The resulting Strings preserve the original byte sequences' sort order. The Strings are constructed using a Base 8000h encoding of the original binary data - each char of an encoded String represents a 15-bit chunk from the byte sequence. Base 8000h was chosen because it allows for all lower 15 bits of char to be used without restriction; the surrogate range [U+D8000-U+DFFF] does not represent valid chars, and would require complicated handling to avoid them and allow use of char's high bit. Although unset bits are used as padding in the final char, the original byte sequence could contain trailing bytes with no set bits (null bytes): padding is indistinguishable from valid information. To overcome this problem, a char is appended, indicating the number of encoded bytes in the final content char. This class's operations are defined over CharBuffers and ByteBuffers, to allow for wrapped arrays to be reused, reducing memory allocation costs for repeated operations. Note that this class calls array() and arrayOffset() on the CharBuffers and ByteBuffers it uses, so only wrapped arrays may be used. This class interprets the arrayOffset() and limit() values returned by its input buffers as beginning and end+1 positions on the wrapped array, resprectively; similarly, on the output buffer, arrayOffset() is the first position written to, and limit() is set to one past the final output array position.
Public class MapOfSets TKey, TValue
Helper class for keeping Listss of Objects associated with keys. WARNING: THIS CLASS IS NOT THREAD SAFE
Public class MemoryModel
Returns primitive memory sizes for estimating RAM usage.
Public class NumericUtils
This is a helper class to generate prefix-encoded representations for numerical values and supplies converters to represent float/double values as sortable integers/longs.

To quickly execute range queries in Apache Lucene, a range is divided recursively into multiple intervals for searching: The center of the range is searched only with the lowest possible precision in the trie, while the boundaries are matched more exactly. This reduces the number of terms dramatically.

This class generates terms to achive this: First the numerical integer values need to be converted to strings. For that integer values (32 bit or 64 bit) are made unsigned and the bits are converted to ASCII chars with each 7 bit. The resulting string is sortable like the original integer value. Each value is also prefixed (in the first char) by the shift value (number of bits removed) used during encoding.

To also index floating point numbers, this class supplies two methods to convert them to integer values by changing their bit layout: DoubleToSortableLong(Double), FloatToSortableInt(Single). You will have no precision loss by converting floating point numbers to integers and back (only that the integer form is not usable). Other data types like dates can easily converted to longs or ints (e.g. date to long: Online DateTime).

For easy usage, the trie algorithm is implemented for indexing inside NumericTokenStream that can index int, long, float, and double. For querying, NumericRangeQuery T and NumericRangeFilter T implement the query part for the same data types.

This class can also be used, to generate lexicographically sortable (according Online CompareTo(String)) representations of numeric data types for other usages (e.g. sorting).

NOTE: This API is experimental and might change in incompatible ways in the next release.
Public class NumericUtils IntRangeBuilder
Expert: Callback for SplitIntRange(NumericUtils IntRangeBuilder, Int32, Int32, Int32). You need to overwrite only one of the methods.

NOTE: This is a very low-level interface, the method signatures may change in later versions.
Public class NumericUtils LongRangeBuilder
Expert: Callback for SplitLongRange(NumericUtils LongRangeBuilder, Int32, Int64, Int64). You need to overwrite only one of the methods.

NOTE: This is a very low-level interface, the method signatures may change in later versions.
Public class OpenBitSet
An "open" BitSet implementation that allows direct access to the array of words storing the bits.

Unlike java.util.bitset, the fact that bits are packed into an array of longs is part of the interface. This allows efficient implementation of other algorithms by someone other than the author. It also allows one to efficiently implement alternate serialization or interchange formats.

OpenBitSet is faster than java.util.BitSet in most operations and *much* faster at calculating cardinality of sets and results of set operations. It can also handle sets of larger cardinality (up to 64 * 2**32-1)

The goals of OpenBitSet are the fastest implementation possible, and maximum code reuse. Extra safety and encapsulation may always be built on top, but if that's built in, the cost can never be removed (and hence people re-implement their own version in order to get better performance). If you want a "safe", totally encapsulated (and slower and limited) BitSet class, use java.util.BitSet.

Performance Results

Test system: Pentium 4, Sun Java 1.5_06 -server -Xbatch -Xmx64M
BitSet size = 1,000,000
Results are java.util.BitSet time divided by OpenBitSet time.
 | cardinality | intersect_count | union | nextSetBit | get | iterator
50% full | 3.36 | 3.96 | 1.44 | 1.46 | 1.99 | 1.58
1% full | 3.31 | 3.90 |  | 1.04 |  | 0.99

Test system: AMD Opteron, 64 bit linux, Sun Java 1.5_06 -server -Xbatch -Xmx64M
BitSet size = 1,000,000
Results are java.util.BitSet time divided by OpenBitSet time.
 | cardinality | intersect_count | union | nextSetBit | get | iterator
50% full | 2.50 | 3.50 | 1.00 | 1.03 | 1.12 | 1.25
1% full | 2.51 | 3.49 |  | 1.00 |  | 1.02
Public class | OpenBitSetDISI
Public class OpenBitSetIterator
An iterator to iterate over set bits in an OpenBitSet. This is faster than nextSetBit() for iterating over the complete set of bits, especially when the density of the bits set is high.
Public class PriorityQueue T
A PriorityQueue maintains a partial ordering of its elements such that the least element can always be found in constant time. Put()'s and pop()'s require log(size) time.

NOTE: This class pre-allocates a full array of length maxSize+1, in Initialize(Int32).
Public class RamUsageEstimator
Estimates the size of a given Object using a given MemoryModel for primitive size information. Resource Usage: Internally uses a Map to temporally hold a reference to every object seen. If checkIntered, all Strings checked will be interned, but those that were not already interned will be released for GC when the estimate is complete.
Public class ReaderUtil
Common util methods for dealing with IndexReaders.
Public class ScorerDocQueue
A ScorerDocQueue maintains a partial ordering of its Scorers such that the least Scorer can always be found in constant time. Put()'s and pop()'s require log(size) time. The ordering is by Scorer.doc().
Public class SimpleStringInterner
Simple lockless and memory barrier free String intern cache that is guaranteed to return the same String instance as String.intern() does.
Public class SmallFloat
Floating point numbers smaller than 32 bits.
Public class SortedVIntList
Stores and iterate on sorted integers in compressed form in RAM.
The code for compressing the differences between ascending integers was borrowed from IndexInput and IndexOutput.

NOTE: this class assumes the stored integers are doc Ids (hence why it extends DocIdSet). Therefore its Iterator assumes NO_MORE_DOCS can be used as sentinel. If you intent to use this value, then make sure it's not used during search flow.
Public class SorterTemplate
Borrowed from Cglib. Allows custom swap so that two arrays can be sorted at the same time.
Public class StringHelper
Methods for manipulating strings.
Public class StringInterner
Subclasses of StringInterner are required to return the same single String object for all equal strings. Depending on the implementation, this may not be the same object returned as String.intern(). This StringInterner base class simply delegates to String.intern().
Public class ToStringUtils
Helper methods to ease implementing Online ToString .
Public class UnicodeUtil
Class to encode java's UTF16 char[] into UTF8 byte[] without always allocating a new byte[] as String.getBytes("UTF-8") does.

WARNING: This API is a new and experimental and may suddenly change.

Public class | UnicodeUtil UTF16Result
Public class | UnicodeUtil UTF8Result
Public class | VersionEnumExtensions
Interfaces
 | Interface | Description
Public interface | IAttribute | Base interface for attributes.
Enumerations
 | Enumeration | Description
Public enumeration | Version | Use by certain classes to match version compatibility across releases of Lucene. WARNING: When changing the version parameter that you supply to components in Lucene, do not simply change the version at search-time, but instead also adjust your indexing code to match, and re-index.

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ArrayUtil Class

ArrayUtil Class Lucene.Net Class Library
Methods for manipulating arrays.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util ArrayUtil

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ArrayUtil
public sealed class ArrayUtil
Public NotInheritable Class ArrayUtil
Public NotInheritable Class ArrayUtil
public ref class ArrayUtil sealed
public ref class ArrayUtil sealed
See Also
ArrayUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ArrayUtil Members

ArrayUtil Members Lucene.Net Class Library

The ArrayUtil type exposes the following members.
Constructors
 | Name | Description
Public method | ArrayUtil | Initializes a new instance of the ArrayUtil class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
 | GetNextSize |
 | GetShrinkSize |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Grow( Byte ) |
 | Grow( Int32 ) |
 | Grow( Int64 ) |
 | Grow( Byte , Int32) |
 | Grow( Int32 , Int32) |
 | Grow( Int64 , Int32) |
 | HashCode( Byte , Int32, Int32) | Returns hash of chars in range start (inclusive) to end (inclusive)
 | HashCode( Char , Int32, Int32) | Returns hash of chars in range start (inclusive) to end (inclusive)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ParseInt( Char ) | Parses the string argument as if it was an int value and returns the result. Throws NumberFormatException if the string does not represent an int quantity.
 | ParseInt( Char , Int32, Int32) | Parses a char array into an int.
 | ParseInt( Char , Int32, Int32, Int32) | Parses the string argument as if it was an int value and returns the result. Throws NumberFormatException if the string does not represent an int quantity. The second argument specifies the radix to use when parsing the value.
 | Shrink( Byte , Int32) |
 | Shrink( Int32 , Int32) |
 | Shrink( Int64 , Int32) |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ArrayUtil Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ArrayUtil Constructor

ArrayUtil Constructor Lucene.Net Class Library
Initializes a new instance of the ArrayUtil class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ArrayUtil()
public ArrayUtil()
Public Sub New
Public Sub New
public:
ArrayUtil()
public:
ArrayUtil()
See Also
ArrayUtil Class
ArrayUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ArrayUtil Methods

ArrayUtil Methods Lucene.Net Class Library
The ArrayUtil type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
 | GetNextSize |
 | GetShrinkSize |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Grow( Byte ) |
 | Grow( Int32 ) |
 | Grow( Int64 ) |
 | Grow( Byte , Int32) |
 | Grow( Int32 , Int32) |
 | Grow( Int64 , Int32) |
 | HashCode( Byte , Int32, Int32) | Returns hash of chars in range start (inclusive) to end (inclusive)
 | HashCode( Char , Int32, Int32) | Returns hash of chars in range start (inclusive) to end (inclusive)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ParseInt( Char ) | Parses the string argument as if it was an int value and returns the result. Throws NumberFormatException if the string does not represent an int quantity.
 | ParseInt( Char , Int32, Int32) | Parses a char array into an int.
 | ParseInt( Char , Int32, Int32, Int32) | Parses the string argument as if it was an int value and returns the result. Throws NumberFormatException if the string does not represent an int quantity. The second argument specifies the radix to use when parsing the value.
 | Shrink( Byte , Int32) |
 | Shrink( Int32 , Int32) |
 | Shrink( Int64 , Int32) |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ArrayUtil Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetNextSize Method

ArrayUtil GetNextSize Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GetNextSize(
    int targetSize
)
public static int GetNextSize(
    int targetSize
)
Public Shared Function GetNextSize ( _
    targetSize As Integer _
) As Integer
Public Shared Function GetNextSize ( _
    targetSize As Integer _
) As Integer
public:
static int GetNextSize(
    int targetSize
)
public:
static int GetNextSize(
    int targetSize
)
Parameters
targetSize
Type:   Online System Int32
See Also
ArrayUtil Class
ArrayUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetShrinkSize Method

ArrayUtil GetShrinkSize Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GetShrinkSize(
    int currentSize,
    int targetSize
)
public static int GetShrinkSize(
    int currentSize,
    int targetSize
)
Public Shared Function GetShrinkSize ( _
    currentSize As Integer, _
    targetSize As Integer _
) As Integer
Public Shared Function GetShrinkSize ( _
    currentSize As Integer, _
    targetSize As Integer _
) As Integer
public:
static int GetShrinkSize(
    int currentSize,
    int targetSize
)
public:
static int GetShrinkSize(
    int currentSize,
    int targetSize
)
Parameters
currentSize
Type:   Online System Int32
targetSize
Type:   Online System Int32
See Also
ArrayUtil Class
ArrayUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Grow Method

ArrayUtil Grow Method Lucene.Net Class Library
Overload List
Name | Description
Grow( Byte ) |
Grow( Int32 ) |
Grow( Int64 ) |
Grow( Byte , Int32) |
Grow( Int32 , Int32) |
Grow( Int64 , Int32) |
Back to Top
See Also
ArrayUtil Class
ArrayUtil Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Grow Method (Byte[])

ArrayUtil Grow Method ( Byte ) Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] Grow(
    byte[] array
)
public static byte[] Grow(
    byte[] array
)
Public Shared Function Grow ( _
    array As Byte() _
) As Byte()
Public Shared Function Grow ( _
    array As Byte() _
) As Byte()
public:
static array<unsigned char>^ Grow(
    array<unsigned char>^ array
)
public:
static array<unsigned char>^ Grow(
    array<unsigned char>^ array
)
Parameters
array
Type:    Online System Byte
See Also
ArrayUtil Class
ArrayUtil Members
Grow Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Grow Method (Int32[])

ArrayUtil Grow Method ( Int32 ) Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int[] Grow(
    int[] array
)
public static int[] Grow(
    int[] array
)
Public Shared Function Grow ( _
    array As Integer() _
) As Integer()
Public Shared Function Grow ( _
    array As Integer() _
) As Integer()
public:
static array<int>^ Grow(
    array<int>^ array
)
public:
static array<int>^ Grow(
    array<int>^ array
)
Parameters
array
Type:    Online System Int32
See Also
ArrayUtil Class
ArrayUtil Members
Grow Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Grow Method (Int64[])

ArrayUtil Grow Method ( Int64 ) Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long[] Grow(
    long[] array
)
public static long[] Grow(
    long[] array
)
Public Shared Function Grow ( _
    array As Long() _
) As Long()
Public Shared Function Grow ( _
    array As Long() _
) As Long()
public:
static array<long long>^ Grow(
    array<long long>^ array
)
public:
static array<long long>^ Grow(
    array<long long>^ array
)
Parameters
array
Type:    Online System Int64
See Also
ArrayUtil Class
ArrayUtil Members
Grow Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Grow Method (Byte[], Int32)

ArrayUtil Grow Method ( Byte , Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] Grow(
    byte[] array,
    int minSize
)
public static byte[] Grow(
    byte[] array,
    int minSize
)
Public Shared Function Grow ( _
    array As Byte(), _
    minSize As Integer _
) As Byte()
Public Shared Function Grow ( _
    array As Byte(), _
    minSize As Integer _
) As Byte()
public:
static array<unsigned char>^ Grow(
    array<unsigned char>^ array,
    int minSize
)
public:
static array<unsigned char>^ Grow(
    array<unsigned char>^ array,
    int minSize
)
Parameters
array
Type:    Online System Byte
minSize
Type:   Online System Int32
See Also
ArrayUtil Class
ArrayUtil Members
Grow Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Grow Method (Int32[], Int32)

ArrayUtil Grow Method ( Int32 , Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int[] Grow(
    int[] array,
    int minSize
)
public static int[] Grow(
    int[] array,
    int minSize
)
Public Shared Function Grow ( _
    array As Integer(), _
    minSize As Integer _
) As Integer()
Public Shared Function Grow ( _
    array As Integer(), _
    minSize As Integer _
) As Integer()
public:
static array<int>^ Grow(
    array<int>^ array,
    int minSize
)
public:
static array<int>^ Grow(
    array<int>^ array,
    int minSize
)
Parameters
array
Type:    Online System Int32
minSize
Type:   Online System Int32
See Also
ArrayUtil Class
ArrayUtil Members
Grow Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Grow Method (Int64[], Int32)

ArrayUtil Grow Method ( Int64 , Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long[] Grow(
    long[] array,
    int minSize
)
public static long[] Grow(
    long[] array,
    int minSize
)
Public Shared Function Grow ( _
    array As Long(), _
    minSize As Integer _
) As Long()
Public Shared Function Grow ( _
    array As Long(), _
    minSize As Integer _
) As Long()
public:
static array<long long>^ Grow(
    array<long long>^ array,
    int minSize
)
public:
static array<long long>^ Grow(
    array<long long>^ array,
    int minSize
)
Parameters
array
Type:    Online System Int64
minSize
Type:   Online System Int32
See Also
ArrayUtil Class
ArrayUtil Members
Grow Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HashCode Method

ArrayUtil HashCode Method Lucene.Net Class Library
Overload List
Name | Description
HashCode( Byte , Int32, Int32) | Returns hash of chars in range start (inclusive) to end (inclusive)
HashCode( Char , Int32, Int32) | Returns hash of chars in range start (inclusive) to end (inclusive)
Back to Top
See Also
ArrayUtil Class
ArrayUtil Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HashCode Method (Byte[], Int32, Int32)

ArrayUtil HashCode Method ( Byte , Int32, Int32) Lucene.Net Class Library
Returns hash of chars in range start (inclusive) to end (inclusive)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int HashCode(
    byte[] array,
    int start,
    int end
)
public static int HashCode(
    byte[] array,
    int start,
    int end
)
Public Shared Function HashCode ( _
    array As Byte(), _
    start As Integer, _
    end As Integer _
) As Integer
Public Shared Function HashCode ( _
    array As Byte(), _
    start As Integer, _
    end As Integer _
) As Integer
public:
static int HashCode(
    array<unsigned char>^ array,
    int start,
    int end
)
public:
static int HashCode(
    array<unsigned char>^ array,
    int start,
    int end
)
Parameters
array
Type:    Online System Byte
start
Type:   Online System Int32
end
Type:   Online System Int32
See Also
ArrayUtil Class
ArrayUtil Members
HashCode Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HashCode Method (Char[], Int32, Int32)

ArrayUtil HashCode Method ( Char , Int32, Int32) Lucene.Net Class Library
Returns hash of chars in range start (inclusive) to end (inclusive)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int HashCode(
    char[] array,
    int start,
    int end
)
public static int HashCode(
    char[] array,
    int start,
    int end
)
Public Shared Function HashCode ( _
    array As Char(), _
    start As Integer, _
    end As Integer _
) As Integer
Public Shared Function HashCode ( _
    array As Char(), _
    start As Integer, _
    end As Integer _
) As Integer
public:
static int HashCode(
    array<wchar_t>^ array,
    int start,
    int end
)
public:
static int HashCode(
    array<wchar_t>^ array,
    int start,
    int end
)
Parameters
array
Type:    Online System Char
start
Type:   Online System Int32
end
Type:   Online System Int32
See Also
ArrayUtil Class
ArrayUtil Members
HashCode Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseInt Method

ArrayUtil ParseInt Method Lucene.Net Class Library
Overload List
Name | Description
ParseInt( Char ) | Parses the string argument as if it was an int value and returns the result. Throws NumberFormatException if the string does not represent an int quantity.
ParseInt( Char , Int32, Int32) | Parses a char array into an int.
ParseInt( Char , Int32, Int32, Int32) | Parses the string argument as if it was an int value and returns the result. Throws NumberFormatException if the string does not represent an int quantity. The second argument specifies the radix to use when parsing the value.
Back to Top
See Also
ArrayUtil Class
ArrayUtil Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseInt Method (Char[])

ArrayUtil ParseInt Method ( Char ) Lucene.Net Class Library
Parses the string argument as if it was an int value and returns the result. Throws NumberFormatException if the string does not represent an int quantity.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int ParseInt(
    char[] chars
)
public static int ParseInt(
    char[] chars
)
Public Shared Function ParseInt ( _
    chars As Char() _
) As Integer
Public Shared Function ParseInt ( _
    chars As Char() _
) As Integer
public:
static int ParseInt(
    array<wchar_t>^ chars
)
public:
static int ParseInt(
    array<wchar_t>^ chars
)
Parameters
chars
Type:    Online System Char
a string representation of an int quantity.

Return Value
 int the value represented by the argument

See Also
ArrayUtil Class
ArrayUtil Members
ParseInt Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseInt Method (Char[], Int32, Int32)

ArrayUtil ParseInt Method ( Char , Int32, Int32) Lucene.Net Class Library
Parses a char array into an int.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int ParseInt(
    char[] chars,
    int offset,
    int len
)
public static int ParseInt(
    char[] chars,
    int offset,
    int len
)
Public Shared Function ParseInt ( _
    chars As Char(), _
    offset As Integer, _
    len As Integer _
) As Integer
Public Shared Function ParseInt ( _
    chars As Char(), _
    offset As Integer, _
    len As Integer _
) As Integer
public:
static int ParseInt(
    array<wchar_t>^ chars,
    int offset,
    int len
)
public:
static int ParseInt(
    array<wchar_t>^ chars,
    int offset,
    int len
)
Parameters
chars
Type:    Online System Char
the character array

offset
Type:   Online System Int32
The offset into the array

len
Type:   Online System Int32
The length

Return Value
 the int

See Also
ArrayUtil Class
ArrayUtil Members
ParseInt Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ParseInt Method (Char[], Int32, Int32, Int32)

ArrayUtil ParseInt Method ( Char , Int32, Int32, Int32) Lucene.Net Class Library
Parses the string argument as if it was an int value and returns the result. Throws NumberFormatException if the string does not represent an int quantity. The second argument specifies the radix to use when parsing the value.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int ParseInt(
    char[] chars,
    int offset,
    int len,
    int radix
)
public static int ParseInt(
    char[] chars,
    int offset,
    int len,
    int radix
)
Public Shared Function ParseInt ( _
    chars As Char(), _
    offset As Integer, _
    len As Integer, _
    radix As Integer _
) As Integer
Public Shared Function ParseInt ( _
    chars As Char(), _
    offset As Integer, _
    len As Integer, _
    radix As Integer _
) As Integer
public:
static int ParseInt(
    array<wchar_t>^ chars,
    int offset,
    int len,
    int radix
)
public:
static int ParseInt(
    array<wchar_t>^ chars,
    int offset,
    int len,
    int radix
)
Parameters
chars
Type:    Online System Char
a string representation of an int quantity.

offset
Type:   Online System Int32
len
Type:   Online System Int32
radix
Type:   Online System Int32
the base to use for conversion.

Return Value
 int the value represented by the argument

See Also
ArrayUtil Class
ArrayUtil Members
ParseInt Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Shrink Method

ArrayUtil Shrink Method Lucene.Net Class Library
Overload List
Name | Description
Shrink( Byte , Int32) |
Shrink( Int32 , Int32) |
Shrink( Int64 , Int32) |
Back to Top
See Also
ArrayUtil Class
ArrayUtil Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Shrink Method (Byte[], Int32)

ArrayUtil Shrink Method ( Byte , Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] Shrink(
    byte[] array,
    int targetSize
)
public static byte[] Shrink(
    byte[] array,
    int targetSize
)
Public Shared Function Shrink ( _
    array As Byte(), _
    targetSize As Integer _
) As Byte()
Public Shared Function Shrink ( _
    array As Byte(), _
    targetSize As Integer _
) As Byte()
public:
static array<unsigned char>^ Shrink(
    array<unsigned char>^ array,
    int targetSize
)
public:
static array<unsigned char>^ Shrink(
    array<unsigned char>^ array,
    int targetSize
)
Parameters
array
Type:    Online System Byte
targetSize
Type:   Online System Int32
See Also
ArrayUtil Class
ArrayUtil Members
Shrink Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Shrink Method (Int32[], Int32)

ArrayUtil Shrink Method ( Int32 , Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int[] Shrink(
    int[] array,
    int targetSize
)
public static int[] Shrink(
    int[] array,
    int targetSize
)
Public Shared Function Shrink ( _
    array As Integer(), _
    targetSize As Integer _
) As Integer()
Public Shared Function Shrink ( _
    array As Integer(), _
    targetSize As Integer _
) As Integer()
public:
static array<int>^ Shrink(
    array<int>^ array,
    int targetSize
)
public:
static array<int>^ Shrink(
    array<int>^ array,
    int targetSize
)
Parameters
array
Type:    Online System Int32
targetSize
Type:   Online System Int32
See Also
ArrayUtil Class
ArrayUtil Members
Shrink Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Shrink Method (Int64[], Int32)

ArrayUtil Shrink Method ( Int64 , Int32) Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long[] Shrink(
    long[] array,
    int targetSize
)
public static long[] Shrink(
    long[] array,
    int targetSize
)
Public Shared Function Shrink ( _
    array As Long(), _
    targetSize As Integer _
) As Long()
Public Shared Function Shrink ( _
    array As Long(), _
    targetSize As Integer _
) As Long()
public:
static array<long long>^ Shrink(
    array<long long>^ array,
    int targetSize
)
public:
static array<long long>^ Shrink(
    array<long long>^ array,
    int targetSize
)
Parameters
array
Type:    Online System Int64
targetSize
Type:   Online System Int32
See Also
ArrayUtil Class
ArrayUtil Members
Shrink Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Attribute Class

Attribute Class Lucene.Net Class Library
Base class for Attributes that can be added to a AttributeSource.

Attributes are used to add data in a dynamic, yet type-safe way to a source of usually streamed objects, e. g. a TokenStream.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util Attribute
Lucene.Net.Analysis Token
Lucene.Net.Analysis.Tokenattributes FlagsAttribute
Lucene.Net.Analysis.Tokenattributes OffsetAttribute
Lucene.Net.Analysis.Tokenattributes PayloadAttribute
Lucene.Net.Analysis.Tokenattributes PositionIncrementAttribute
Lucene.Net.Analysis.Tokenattributes TermAttribute
Lucene.Net.Analysis.Tokenattributes TypeAttribute

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class Attribute : ICloneable,
    IAttribute
[SerializableAttribute]
public abstract class Attribute : ICloneable,
    IAttribute
<SerializableAttribute> _
Public MustInherit Class Attribute _
    Implements ICloneable, IAttribute
<SerializableAttribute> _
Public MustInherit Class Attribute _
    Implements ICloneable, IAttribute
[SerializableAttribute]
public ref class Attribute abstract : ICloneable,
    IAttribute
[SerializableAttribute]
public ref class Attribute abstract : ICloneable,
    IAttribute
See Also
Attribute Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Attribute Members

Attribute Members Lucene.Net Class Library

The Attribute type exposes the following members.
Constructors
 | Name | Description
Protected method | Attribute | Initializes a new instance of the Attribute class
Back to Top
Methods
Name Description
Public method Clear
Clears the values in this AttributeImpl and resets it to its default value. If this implementation implements more than one Attribute interface it clears all.
Public method Clone
Shallow clone. Subclasses must override this if they need to clone any members deeply,
Public method CopyTo
Copies the values from this Attribute into the passed-in target attribute. The target implementation must support all the Attributes this implementation supports.
Public method Equals
All values used for computation of GetHashCode should be checked here for equality. see also Online Equals(Object)
(Overrides Online Object Equals(Object).)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method GetHashCode
Subclasses must implement this method and should compute a hashCode similar to this:
View Colorized Copy to Clipboard Print
public int hashCode() {
int code = startOffset;
code = code * 31 + endOffset;
return code;
}
public int hashCode() {
int code = startOffset;
code = code * 31 + endOffset;
return code;
}
see also Equals(Object)
(Overrides Online Object GetHashCode .)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
View Colorized Copy to Clipboard Print
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
This method may be overridden by subclasses.
(Overrides Online Object ToString .)
Back to Top
See Also
Attribute Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Attribute Constructor

Attribute Constructor Lucene.Net Class Library
Initializes a new instance of the Attribute class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Attribute()
protected Attribute()
Protected Sub New
Protected Sub New
protected:
Attribute()
protected:
Attribute()
See Also
Attribute Class
Attribute Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Attribute Methods

Attribute Methods Lucene.Net Class Library
The Attribute type exposes the following members.
Methods
Name Description
Public method Clear
Clears the values in this AttributeImpl and resets it to its default value. If this implementation implements more than one Attribute interface it clears all.
Public method Clone
Shallow clone. Subclasses must override this if they need to clone any members deeply,
Public method CopyTo
Copies the values from this Attribute into the passed-in target attribute. The target implementation must support all the Attributes this implementation supports.
Public method Equals
All values used for computation of GetHashCode should be checked here for equality. see also Online Equals(Object)
(Overrides Online Object Equals(Object).)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method GetHashCode
Subclasses must implement this method and should compute a hashCode similar to this:
View Colorized Copy to Clipboard Print
public int hashCode() {
int code = startOffset;
code = code * 31 + endOffset;
return code;
}
public int hashCode() {
int code = startOffset;
code = code * 31 + endOffset;
return code;
}
see also Equals(Object)
(Overrides Online Object GetHashCode .)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
View Colorized Copy to Clipboard Print
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
This method may be overridden by subclasses.
(Overrides Online Object ToString .)
Back to Top
See Also
Attribute Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method

Attribute Clear Method Lucene.Net Class Library
Clears the values in this AttributeImpl and resets it to its default value. If this implementation implements more than one Attribute interface it clears all.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Clear()
public abstract void Clear()
Public MustOverride Sub Clear
Public MustOverride Sub Clear
public:
virtual void Clear() abstract
public:
virtual void Clear() abstract
See Also
Attribute Class
Attribute Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

Attribute Clone Method Lucene.Net Class Library
Shallow clone. Subclasses must override this if they need to clone any members deeply,

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object Clone()
public virtual Object Clone()
Public Overridable Function Clone As Object
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
public:
virtual Object^ Clone()
Implements
  Online ICloneable Clone
See Also
Attribute Class
Attribute Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CopyTo Method

Attribute CopyTo Method Lucene.Net Class Library
Copies the values from this Attribute into the passed-in target attribute. The target implementation must support all the Attributes this implementation supports.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void CopyTo(
    Attribute target
)
public abstract void CopyTo(
    Attribute target
)
Public MustOverride Sub CopyTo ( _
    target As Attribute _
)
Public MustOverride Sub CopyTo ( _
    target As Attribute _
)
public:
virtual void CopyTo(
    Attribute^ target
) abstract
public:
virtual void CopyTo(
    Attribute^ target
) abstract
Parameters
target
Type: Lucene.Net.Util Attribute
See Also
Attribute Class
Attribute Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

Attribute Equals Method Lucene.Net Class Library
All values used for computation of GetHashCode should be checked here for equality. see also Online Equals(Object)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool Equals(
    Object other
)
public abstract bool Equals(
    Object other
)
Public MustOverride Function Equals ( _
    other As Object _
) As Boolean
Public MustOverride Function Equals ( _
    other As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ other
) abstract override
public:
virtual bool Equals(
    Object^ other
) abstract override
Parameters
other
Type:   Online System Object
See Also
Attribute Class
Attribute Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

Attribute GetHashCode Method Lucene.Net Class Library
Subclasses must implement this method and should compute a hashCode similar to this:
View Colorized Copy to Clipboard Print
public int hashCode() {
int code = startOffset;
code = code * 31 + endOffset;
return code;
}
public int hashCode() {
int code = startOffset;
code = code * 31 + endOffset;
return code;
}
see also Equals(Object)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int GetHashCode()
public abstract int GetHashCode()
Public MustOverride Function GetHashCode As Integer
Public MustOverride Function GetHashCode As Integer
public:
virtual int GetHashCode() abstract override
public:
virtual int GetHashCode() abstract override
See Also
Attribute Class
Attribute Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

Attribute ToString Method Lucene.Net Class Library
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
View Colorized Copy to Clipboard Print
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
public String toString() {
return "start=" + startOffset + ",end=" + endOffset;
}
This method may be overridden by subclasses.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
Attribute Class
Attribute Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource Class

AttributeSource Class Lucene.Net Class Library
An AttributeSource contains a list of different Attributes, and methods to add and get them. There can only be a single instance of an attribute in the same AttributeSource instance. This is ensured by passing in the actual type of the Attribute (Class<Attribute>) to the AddAttribute T , which then checks if an instance of that type is already present. If yes, it returns the instance, otherwise it creates a new instance and returns it.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource
Lucene.Net.Analysis TokenStream

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AttributeSource
public class AttributeSource
Public Class AttributeSource
Public Class AttributeSource
public ref class AttributeSource
public ref class AttributeSource
See Also
AttributeSource Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource Members

AttributeSource Members Lucene.Net Class Library

The AttributeSource type exposes the following members.
Constructors
 | Name | Description
Public method | AttributeSource | An AttributeSource using the default attribute factory DEFAULT_ATTRIBUTE_FACTORY.
Public method | AttributeSource(AttributeSource) | An AttributeSource that uses the same attributes as the supplied one.
Public method | AttributeSource(AttributeSource AttributeFactory) | An AttributeSource using the supplied AttributeSource AttributeFactory for creating new IAttribute instances.
Back to Top
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned.
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource.
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation.
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource))
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator()
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream.
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory.
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes
Back to Top
See Also
AttributeSource Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource Constructor

AttributeSource Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | AttributeSource | An AttributeSource using the default attribute factory DEFAULT_ATTRIBUTE_FACTORY.
Public method | AttributeSource(AttributeSource) | An AttributeSource that uses the same attributes as the supplied one.
Public method | AttributeSource(AttributeSource AttributeFactory) | An AttributeSource using the supplied AttributeSource AttributeFactory for creating new IAttribute instances.
Back to Top
See Also
AttributeSource Class
AttributeSource Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource Constructor

AttributeSource Constructor Lucene.Net Class Library
An AttributeSource using the default attribute factory DEFAULT_ATTRIBUTE_FACTORY.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AttributeSource()
public AttributeSource()
Public Sub New
Public Sub New
public:
AttributeSource()
public:
AttributeSource()
See Also
AttributeSource Class
AttributeSource Members
AttributeSource Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource Constructor (AttributeSource)

AttributeSource Constructor (AttributeSource) Lucene.Net Class Library
An AttributeSource that uses the same attributes as the supplied one.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AttributeSource(
    AttributeSource input
)
public AttributeSource(
    AttributeSource input
)
Public Sub New ( _
    input As AttributeSource _
)
Public Sub New ( _
    input As AttributeSource _
)
public:
AttributeSource(
    AttributeSource^ input
)
public:
AttributeSource(
    AttributeSource^ input
)
Parameters
input
Type: Lucene.Net.Util AttributeSource
See Also
AttributeSource Class
AttributeSource Members
AttributeSource Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource Constructor (AttributeSource.AttributeFactory)

AttributeSource Constructor (AttributeSource AttributeFactory) Lucene.Net Class Library
An AttributeSource using the supplied AttributeSource AttributeFactory for creating new IAttribute instances.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AttributeSource(
    AttributeSource..::..AttributeFactory factory
)
public AttributeSource(
    AttributeSource..::..AttributeFactory factory
)
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory _
)
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory _
)
public:
AttributeSource(
    AttributeSource..::..AttributeFactory^ factory
)
public:
AttributeSource(
    AttributeSource..::..AttributeFactory^ factory
)
Parameters
factory
Type: Lucene.Net.Util AttributeSource AttributeFactory
See Also
AttributeSource Class
AttributeSource Members
AttributeSource Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource Methods

AttributeSource Methods Lucene.Net Class Library
The AttributeSource type exposes the following members.
Methods
 | Name | Description
Public method | AddAttribute T | The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned.
Public method | AddAttributeImpl | Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces. Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory
Public method | CaptureState | Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource.
Public method | ClearAttributes | Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation.
Public method | CloneAttributes | Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource))
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource
Public method | GetAttributeImplsIterator | Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator()
Public method | GetAttributeTypesIterator | Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasAttribute T | The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RestoreState | Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream.
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
AttributeSource Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddAttribute(T) Method

AttributeSource AddAttribute T Method Lucene.Net Class Library
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual T AddAttribute<T>()
where T : IAttribute
public virtual T AddAttribute<T>()
where T : IAttribute
Public Overridable Function AddAttribute(Of T As IAttribute) As T
Public Overridable Function AddAttribute(Of T As IAttribute) As T
public:
generic<typename T>
where T : IAttribute
virtual T AddAttribute()
public:
generic<typename T>
where T : IAttribute
virtual T AddAttribute()
Type Parameters
T
See Also
AttributeSource Class
AttributeSource Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddAttributeImpl Method

AttributeSource AddAttributeImpl Method Lucene.Net Class Library
Expert: Adds a custom AttributeImpl instance with one or more Attribute interfaces.

Please note: It is not guaranteed, that att is added to the AttributeSource, because the provided attributes may already exist. You should always retrieve the wanted attributes using GetAttribute T after adding with this method and cast to your class. The recommended way to use custom implementations is using an AttributeSource AttributeFactory

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AddAttributeImpl(
    Attribute att
)
public virtual void AddAttributeImpl(
    Attribute att
)
Public Overridable Sub AddAttributeImpl ( _
    att As Attribute _
)
Public Overridable Sub AddAttributeImpl ( _
    att As Attribute _
)
public:
virtual void AddAttributeImpl(
    Attribute^ att
)
public:
virtual void AddAttributeImpl(
    Attribute^ att
)
Parameters
att
Type: Lucene.Net.Util Attribute
See Also
AttributeSource Class
AttributeSource Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CaptureState Method

AttributeSource CaptureState Method Lucene.Net Class Library
Captures the state of all Attributes. The return value can be passed to RestoreState(AttributeSource State) to restore the state of this or another AttributeSource.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual AttributeSource..::..State CaptureState()
public virtual AttributeSource..::..State CaptureState()
Public Overridable Function CaptureState As AttributeSource..::..State
Public Overridable Function CaptureState As AttributeSource..::..State
public:
virtual AttributeSource..::..State^ CaptureState()
public:
virtual AttributeSource..::..State^ CaptureState()
See Also
AttributeSource Class
AttributeSource Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ClearAttributes Method

AttributeSource ClearAttributes Method Lucene.Net Class Library
Resets all Attributes in this AttributeSource by calling Clear on each Attribute implementation.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ClearAttributes()
public virtual void ClearAttributes()
Public Overridable Sub ClearAttributes
Public Overridable Sub ClearAttributes
public:
virtual void ClearAttributes()
public:
virtual void ClearAttributes()
See Also
AttributeSource Class
AttributeSource Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CloneAttributes Method

AttributeSource CloneAttributes Method Lucene.Net Class Library
Performs a clone of all Attribute instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using AttributeSource(AttributeSource))

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual AttributeSource CloneAttributes()
public virtual AttributeSource CloneAttributes()
Public Overridable Function CloneAttributes As AttributeSource
Public Overridable Function CloneAttributes As AttributeSource
public:
virtual AttributeSource^ CloneAttributes()
public:
virtual AttributeSource^ CloneAttributes()
See Also
AttributeSource Class
AttributeSource Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

AttributeSource Equals Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
See Also
AttributeSource Class
AttributeSource Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetAttribute(T) Method

AttributeSource GetAttribute T Method Lucene.Net Class Library
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual T GetAttribute<T>()
where T : IAttribute
public virtual T GetAttribute<T>()
where T : IAttribute
Public Overridable Function GetAttribute(Of T As IAttribute) As T
Public Overridable Function GetAttribute(Of T As IAttribute) As T
public:
generic<typename T>
where T : IAttribute
virtual T GetAttribute()
public:
generic<typename T>
where T : IAttribute
virtual T GetAttribute()
Type Parameters
T
See Also
AttributeSource Class
AttributeSource Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetAttributeImplsIterator Method

AttributeSource GetAttributeImplsIterator Method Lucene.Net Class Library
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that GetAttributeTypesIterator , if one instance implements more than one Attribute interface. Signature for Java 1.5: public Iterator<AttributeImpl> getAttributeImplsIterator()

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerable<Attribute> GetAttributeImplsIterator()
public virtual IEnumerable<Attribute> GetAttributeImplsIterator()
Public Overridable Function GetAttributeImplsIterator As IEnumerable(Of Attribute)
Public Overridable Function GetAttributeImplsIterator As IEnumerable(Of Attribute)
public:
virtual IEnumerable<Attribute^>^ GetAttributeImplsIterator()
public:
virtual IEnumerable<Attribute^>^ GetAttributeImplsIterator()
See Also
AttributeSource Class
AttributeSource Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetAttributeTypesIterator Method

AttributeSource GetAttributeTypesIterator Method Lucene.Net Class Library
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5: public Iterator<Class<? extends Attribute>> getAttributeClassesIterator() Note that this return value is different from Java in that it enumerates over the values and not the keys

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerable<Type> GetAttributeTypesIterator()
public virtual IEnumerable<Type> GetAttributeTypesIterator()
Public Overridable Function GetAttributeTypesIterator As IEnumerable(Of Type)
Public Overridable Function GetAttributeTypesIterator As IEnumerable(Of Type)
public:
virtual IEnumerable<Type^>^ GetAttributeTypesIterator()
public:
virtual IEnumerable<Type^>^ GetAttributeTypesIterator()
See Also
AttributeSource Class
AttributeSource Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

AttributeSource GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
AttributeSource Class
AttributeSource Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasAttribute(T) Method

AttributeSource HasAttribute T Method Lucene.Net Class Library
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool HasAttribute<T>()
where T : IAttribute
public virtual bool HasAttribute<T>()
where T : IAttribute
Public Overridable Function HasAttribute(Of T As IAttribute) As Boolean
Public Overridable Function HasAttribute(Of T As IAttribute) As Boolean
public:
generic<typename T>
where T : IAttribute
virtual bool HasAttribute()
public:
generic<typename T>
where T : IAttribute
virtual bool HasAttribute()
Type Parameters
T
See Also
AttributeSource Class
AttributeSource Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RestoreState Method

AttributeSource RestoreState Method Lucene.Net Class Library
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call ClearAttributes on the targetStream.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void RestoreState(
    AttributeSource..::..State state
)
public virtual void RestoreState(
    AttributeSource..::..State state
)
Public Overridable Sub RestoreState ( _
    state As AttributeSource..::..State _
)
Public Overridable Sub RestoreState ( _
    state As AttributeSource..::..State _
)
public:
virtual void RestoreState(
    AttributeSource..::..State^ state
)
public:
virtual void RestoreState(
    AttributeSource..::..State^ state
)
Parameters
state
Type: Lucene.Net.Util AttributeSource State
See Also
AttributeSource Class
AttributeSource Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

AttributeSource ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
AttributeSource Class
AttributeSource Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource Properties

AttributeSource Properties Lucene.Net Class Library
The AttributeSource type exposes the following members.
Properties
 | Name | Description
Public property | Factory | Returns the used AttributeFactory.
Public property | HasAttributes | Returns true, iff this AttributeSource has any attributes
Back to Top
See Also
AttributeSource Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Factory Property

AttributeSource Factory Property Lucene.Net Class Library
Returns the used AttributeFactory.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual AttributeSource..::..AttributeFactory Factory { get; }
public virtual AttributeSource..::..AttributeFactory Factory { get; }
Public Overridable ReadOnly Property Factory As AttributeSource..::..AttributeFactory
    Get
Public Overridable ReadOnly Property Factory As AttributeSource..::..AttributeFactory
    Get
public:
virtual property AttributeSource..::..AttributeFactory^ Factory {
    AttributeSource..::..AttributeFactory^ get ();
}
public:
virtual property AttributeSource..::..AttributeFactory^ Factory {
    AttributeSource..::..AttributeFactory^ get ();
}
See Also
AttributeSource Class
AttributeSource Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HasAttributes Property

AttributeSource HasAttributes Property Lucene.Net Class Library
Returns true, iff this AttributeSource has any attributes

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool HasAttributes { get; }
public virtual bool HasAttributes { get; }
Public Overridable ReadOnly Property HasAttributes As Boolean
    Get
Public Overridable ReadOnly Property HasAttributes As Boolean
    Get
public:
virtual property bool HasAttributes {
    bool get ();
}
public:
virtual property bool HasAttributes {
    bool get ();
}
See Also
AttributeSource Class
AttributeSource Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource.AttributeFactory Class

AttributeSource AttributeFactory Class Lucene.Net Class Library
An AttributeFactory creates instances of Attributes.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource AttributeFactory
Lucene.Net.Analysis Token TokenAttributeFactory

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class AttributeFactory
public abstract class AttributeFactory
Public MustInherit Class AttributeFactory
Public MustInherit Class AttributeFactory
public ref class AttributeFactory abstract
public ref class AttributeFactory abstract
See Also
AttributeSource AttributeFactory Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource.AttributeFactory Members

AttributeSource AttributeFactory Members Lucene.Net Class Library

An AttributeSource contains a list of different Attributes, and methods to add and get them. There can only be a single instance of an attribute in the same AttributeSource instance. This is ensured by passing in the actual type of the Attribute (Class<Attribute>) to the AddAttribute T , which then checks if an instance of that type is already present. If yes, it returns the instance, otherwise it creates a new instance and returns it.

The AttributeSource AttributeFactory type exposes the following members.
Constructors
 | Name | Description
Protected method | AttributeSource AttributeFactory | Initializes a new instance of the AttributeSource AttributeFactory class
Back to Top
Methods
 | Name | Description
Public method | CreateAttributeInstance T | returns an Attribute for the supplied IAttribute interface class.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
DEFAULT_ATTRIBUTE_FACTORY | This is the default factory that creates Attributes using the class name of the supplied IAttribute interface class by appending Impl to it.
Back to Top
See Also
AttributeSource AttributeFactory Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource.AttributeFactory Constructor

AttributeSource AttributeFactory Constructor Lucene.Net Class Library
Initializes a new instance of the AttributeSource AttributeFactory class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected AttributeFactory()
protected AttributeFactory()
Protected Sub New
Protected Sub New
protected:
AttributeFactory()
protected:
AttributeFactory()
See Also
AttributeSource AttributeFactory Class
AttributeSource AttributeFactory Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource.AttributeFactory Fields

AttributeSource AttributeFactory Fields Lucene.Net Class Library
The AttributeSource AttributeFactory type exposes the following members.
Fields
Name | Description
DEFAULT_ATTRIBUTE_FACTORY | This is the default factory that creates Attributes using the class name of the supplied IAttribute interface class by appending Impl to it.
Back to Top
See Also
AttributeSource AttributeFactory Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DEFAULT_ATTRIBUTE_FACTORY Field

AttributeSource AttributeFactory DEFAULT_ATTRIBUTE_FACTORY Field Lucene.Net Class Library
This is the default factory that creates Attributes using the class name of the supplied IAttribute interface class by appending Impl to it.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly AttributeSource..::..AttributeFactory DEFAULT_ATTRIBUTE_FACTORY
public static readonly AttributeSource..::..AttributeFactory DEFAULT_ATTRIBUTE_FACTORY
Public Shared ReadOnly DEFAULT_ATTRIBUTE_FACTORY As AttributeSource..::..AttributeFactory
Public Shared ReadOnly DEFAULT_ATTRIBUTE_FACTORY As AttributeSource..::..AttributeFactory
public:
static initonly AttributeSource..::..AttributeFactory^ DEFAULT_ATTRIBUTE_FACTORY
public:
static initonly AttributeSource..::..AttributeFactory^ DEFAULT_ATTRIBUTE_FACTORY
See Also
AttributeSource AttributeFactory Class
AttributeSource AttributeFactory Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource.AttributeFactory Methods

AttributeSource AttributeFactory Methods Lucene.Net Class Library
The AttributeSource AttributeFactory type exposes the following members.
Methods
 | Name | Description
Public method | CreateAttributeInstance T | returns an Attribute for the supplied IAttribute interface class.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AttributeSource AttributeFactory Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CreateAttributeInstance(T) Method

AttributeSource AttributeFactory CreateAttributeInstance T Method Lucene.Net Class Library
returns an Attribute for the supplied IAttribute interface class.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Attribute CreateAttributeInstance<T>()
where T : IAttribute
public abstract Attribute CreateAttributeInstance<T>()
where T : IAttribute
Public MustOverride Function CreateAttributeInstance(Of T As IAttribute) As Attribute
Public MustOverride Function CreateAttributeInstance(Of T As IAttribute) As Attribute
public:
generic<typename T>
where T : IAttribute
virtual Attribute^ CreateAttributeInstance() abstract
public:
generic<typename T>
where T : IAttribute
virtual Attribute^ CreateAttributeInstance() abstract
Type Parameters
T
See Also
AttributeSource AttributeFactory Class
AttributeSource AttributeFactory Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource.State Class

AttributeSource State Class Lucene.Net Class Library
This class holds the state of an AttributeSource.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util AttributeSource State

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class State : ICloneable
public sealed class State : ICloneable
Public NotInheritable Class State _
    Implements ICloneable
Public NotInheritable Class State _
    Implements ICloneable
public ref class State sealed : ICloneable
public ref class State sealed : ICloneable
See Also
AttributeSource State Members
Lucene.Net.Util Namespace
AttributeSource CaptureState
AttributeSource RestoreState(AttributeSource State)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource.State Members

AttributeSource State Members Lucene.Net Class Library

An AttributeSource contains a list of different Attributes, and methods to add and get them. There can only be a single instance of an attribute in the same AttributeSource instance. This is ensured by passing in the actual type of the Attribute (Class<Attribute>) to the AddAttribute T , which then checks if an instance of that type is already present. If yes, it returns the instance, otherwise it creates a new instance and returns it.

The AttributeSource State type exposes the following members.
Constructors
 | Name | Description
Public method | AttributeSource State | Initializes a new instance of the AttributeSource State class
Back to Top
Methods
 | Name | Description
Public method | Clone |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AttributeSource State Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource.State Constructor

AttributeSource State Constructor Lucene.Net Class Library
Initializes a new instance of the AttributeSource State class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public State()
public State()
Public Sub New
Public Sub New
public:
State()
public:
State()
See Also
AttributeSource State Class
AttributeSource State Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AttributeSource.State Methods

AttributeSource State Methods Lucene.Net Class Library
The AttributeSource State type exposes the following members.
Methods
 | Name | Description
Public method | Clone |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AttributeSource State Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

AttributeSource State Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Clone()
public Object Clone()
Public Function Clone As Object
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
public:
virtual Object^ Clone() sealed
Implements
  Online ICloneable Clone
See Also
AttributeSource State Class
AttributeSource State Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AverageGuessMemoryModel Class

AverageGuessMemoryModel Class Lucene.Net Class Library
An average, best guess, MemoryModel that should work okay on most systems.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util MemoryModel
Lucene.Net.Util AverageGuessMemoryModel

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AverageGuessMemoryModel : MemoryModel
public class AverageGuessMemoryModel : MemoryModel
Public Class AverageGuessMemoryModel _
    Inherits MemoryModel
Public Class AverageGuessMemoryModel _
    Inherits MemoryModel
public ref class AverageGuessMemoryModel : public MemoryModel
public ref class AverageGuessMemoryModel : public MemoryModel
See Also
AverageGuessMemoryModel Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AverageGuessMemoryModel Members

AverageGuessMemoryModel Members Lucene.Net Class Library

The AverageGuessMemoryModel type exposes the following members.
Constructors
 | Name | Description
Public method | AverageGuessMemoryModel | Initializes a new instance of the AverageGuessMemoryModel class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPrimitiveSize | (Overrides MemoryModel GetPrimitiveSize(Type).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ArraySize | (Overrides MemoryModel ArraySize.)
Public property | ClassSize | (Overrides MemoryModel ClassSize.)
Public property | ReferenceSize | (Overrides MemoryModel ReferenceSize.)
Back to Top
See Also
AverageGuessMemoryModel Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AverageGuessMemoryModel Constructor

AverageGuessMemoryModel Constructor Lucene.Net Class Library
Initializes a new instance of the AverageGuessMemoryModel class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AverageGuessMemoryModel()
public AverageGuessMemoryModel()
Public Sub New
Public Sub New
public:
AverageGuessMemoryModel()
public:
AverageGuessMemoryModel()
See Also
AverageGuessMemoryModel Class
AverageGuessMemoryModel Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AverageGuessMemoryModel Methods

AverageGuessMemoryModel Methods Lucene.Net Class Library
The AverageGuessMemoryModel type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPrimitiveSize | (Overrides MemoryModel GetPrimitiveSize(Type).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
AverageGuessMemoryModel Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPrimitiveSize Method

AverageGuessMemoryModel GetPrimitiveSize Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetPrimitiveSize(
    Type clazz
)
public override int GetPrimitiveSize(
    Type clazz
)
Public Overrides Function GetPrimitiveSize ( _
    clazz As Type _
) As Integer
Public Overrides Function GetPrimitiveSize ( _
    clazz As Type _
) As Integer
public:
virtual int GetPrimitiveSize(
    Type^ clazz
) override
public:
virtual int GetPrimitiveSize(
    Type^ clazz
) override
Parameters
clazz
Type:   Online System Type
See Also
AverageGuessMemoryModel Class
AverageGuessMemoryModel Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AverageGuessMemoryModel Properties

AverageGuessMemoryModel Properties Lucene.Net Class Library
The AverageGuessMemoryModel type exposes the following members.
Properties
 | Name | Description
Public property | ArraySize | (Overrides MemoryModel ArraySize.)
Public property | ClassSize | (Overrides MemoryModel ClassSize.)
Public property | ReferenceSize | (Overrides MemoryModel ReferenceSize.)
Back to Top
See Also
AverageGuessMemoryModel Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ArraySize Property

AverageGuessMemoryModel ArraySize Property Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int ArraySize { get; }
public override int ArraySize { get; }
Public Overrides ReadOnly Property ArraySize As Integer
    Get
Public Overrides ReadOnly Property ArraySize As Integer
    Get
public:
virtual property int ArraySize {
    int get () override;
}
public:
virtual property int ArraySize {
    int get () override;
}
See Also
AverageGuessMemoryModel Class
AverageGuessMemoryModel Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ClassSize Property

AverageGuessMemoryModel ClassSize Property Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int ClassSize { get; }
public override int ClassSize { get; }
Public Overrides ReadOnly Property ClassSize As Integer
    Get
Public Overrides ReadOnly Property ClassSize As Integer
    Get
public:
virtual property int ClassSize {
    int get () override;
}
public:
virtual property int ClassSize {
    int get () override;
}
See Also
AverageGuessMemoryModel Class
AverageGuessMemoryModel Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReferenceSize Property

AverageGuessMemoryModel ReferenceSize Property Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int ReferenceSize { get; }
public override int ReferenceSize { get; }
Public Overrides ReadOnly Property ReferenceSize As Integer
    Get
Public Overrides ReadOnly Property ReferenceSize As Integer
    Get
public:
virtual property int ReferenceSize {
    int get () override;
}
public:
virtual property int ReferenceSize {
    int get () override;
}
See Also
AverageGuessMemoryModel Class
AverageGuessMemoryModel Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitUtil Class

BitUtil Class Lucene.Net Class Library
A variety of high efficiencly bit twiddling routines.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util BitUtil

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class BitUtil
public class BitUtil
Public Class BitUtil
Public Class BitUtil
public ref class BitUtil
public ref class BitUtil
See Also
BitUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitUtil Members

BitUtil Members Lucene.Net Class Library

The BitUtil type exposes the following members.
Constructors
 | Name | Description
Public method | BitUtil | Initializes a new instance of the BitUtil class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | IsPowerOfTwo(Int32) | returns true if v is a power of two or zero
 | IsPowerOfTwo(Int64) | returns true if v is a power of two or zero
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | NextHighestPowerOfTwo(Int32) | returns the next highest power of two, or the current value if it's already a power of two or zero
 | NextHighestPowerOfTwo(Int64) | returns the next highest power of two, or the current value if it's already a power of two or zero
 | Ntz(Int32) | Returns number of trailing zeros in a 32 bit int value.
 | Ntz(Int64) | Returns number of trailing zeros in a 64 bit long value.
 | Ntz2 | returns 0 based index of first set bit (only works for x!=0) This is an alternate implementation of ntz()
 | Ntz3 | returns 0 based index of first set bit This is an alternate implementation of ntz()
 | Pop | Returns the number of bits set in the long
 | Pop_andnot | Returns the popcount or cardinality of A & ~B Neither array is modified.
 | Pop_array | Returns the number of set bits in an array of longs.
 | Pop_intersect | Returns the popcount or cardinality of the two sets after an intersection. Neither array is modified.
 | Pop_union | Returns the popcount or cardinality of the union of two sets. Neither array is modified.
 | Pop_xor |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
ntzTable | table of number of trailing zeros in a byte
Back to Top
See Also
BitUtil Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitUtil Constructor

BitUtil Constructor Lucene.Net Class Library
Initializes a new instance of the BitUtil class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BitUtil()
public BitUtil()
Public Sub New
Public Sub New
public:
BitUtil()
public:
BitUtil()
See Also
BitUtil Class
BitUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitUtil Fields

BitUtil Fields Lucene.Net Class Library
The BitUtil type exposes the following members.
Fields
Name | Description
ntzTable | table of number of trailing zeros in a byte
Back to Top
See Also
BitUtil Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ntzTable Field

BitUtil ntzTable Field Lucene.Net Class Library
table of number of trailing zeros in a byte

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly byte[] ntzTable
public static readonly byte[] ntzTable
Public Shared ReadOnly ntzTable As Byte()
Public Shared ReadOnly ntzTable As Byte()
public:
static initonly array<unsigned char>^ ntzTable
public:
static initonly array<unsigned char>^ ntzTable
See Also
BitUtil Class
BitUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitUtil Methods

BitUtil Methods Lucene.Net Class Library
The BitUtil type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | IsPowerOfTwo(Int32) | returns true if v is a power of two or zero
 | IsPowerOfTwo(Int64) | returns true if v is a power of two or zero
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | NextHighestPowerOfTwo(Int32) | returns the next highest power of two, or the current value if it's already a power of two or zero
 | NextHighestPowerOfTwo(Int64) | returns the next highest power of two, or the current value if it's already a power of two or zero
 | Ntz(Int32) | Returns number of trailing zeros in a 32 bit int value.
 | Ntz(Int64) | Returns number of trailing zeros in a 64 bit long value.
 | Ntz2 | returns 0 based index of first set bit (only works for x!=0) This is an alternate implementation of ntz()
 | Ntz3 | returns 0 based index of first set bit This is an alternate implementation of ntz()
 | Pop | Returns the number of bits set in the long
 | Pop_andnot | Returns the popcount or cardinality of A & ~B Neither array is modified.
 | Pop_array | Returns the number of set bits in an array of longs.
 | Pop_intersect | Returns the popcount or cardinality of the two sets after an intersection. Neither array is modified.
 | Pop_union | Returns the popcount or cardinality of the union of two sets. Neither array is modified.
 | Pop_xor |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
BitUtil Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsPowerOfTwo Method

BitUtil IsPowerOfTwo Method Lucene.Net Class Library
Overload List
Name | Description
IsPowerOfTwo(Int32) | returns true if v is a power of two or zero
IsPowerOfTwo(Int64) | returns true if v is a power of two or zero
Back to Top
See Also
BitUtil Class
BitUtil Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsPowerOfTwo Method (Int32)

BitUtil IsPowerOfTwo Method (Int32) Lucene.Net Class Library
returns true if v is a power of two or zero

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsPowerOfTwo(
    int v
)
public static bool IsPowerOfTwo(
    int v
)
Public Shared Function IsPowerOfTwo ( _
    v As Integer _
) As Boolean
Public Shared Function IsPowerOfTwo ( _
    v As Integer _
) As Boolean
public:
static bool IsPowerOfTwo(
    int v
)
public:
static bool IsPowerOfTwo(
    int v
)
Parameters
v
Type:   Online System Int32
See Also
BitUtil Class
BitUtil Members
IsPowerOfTwo Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsPowerOfTwo Method (Int64)

BitUtil IsPowerOfTwo Method (Int64) Lucene.Net Class Library
returns true if v is a power of two or zero

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsPowerOfTwo(
    long v
)
public static bool IsPowerOfTwo(
    long v
)
Public Shared Function IsPowerOfTwo ( _
    v As Long _
) As Boolean
Public Shared Function IsPowerOfTwo ( _
    v As Long _
) As Boolean
public:
static bool IsPowerOfTwo(
    long long v
)
public:
static bool IsPowerOfTwo(
    long long v
)
Parameters
v
Type:   Online System Int64
See Also
BitUtil Class
BitUtil Members
IsPowerOfTwo Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextHighestPowerOfTwo Method

BitUtil NextHighestPowerOfTwo Method Lucene.Net Class Library
Overload List
Name | Description
NextHighestPowerOfTwo(Int32) | returns the next highest power of two, or the current value if it's already a power of two or zero
NextHighestPowerOfTwo(Int64) | returns the next highest power of two, or the current value if it's already a power of two or zero
Back to Top
See Also
BitUtil Class
BitUtil Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextHighestPowerOfTwo Method (Int32)

BitUtil NextHighestPowerOfTwo Method (Int32) Lucene.Net Class Library
returns the next highest power of two, or the current value if it's already a power of two or zero

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int NextHighestPowerOfTwo(
    int v
)
public static int NextHighestPowerOfTwo(
    int v
)
Public Shared Function NextHighestPowerOfTwo ( _
    v As Integer _
) As Integer
Public Shared Function NextHighestPowerOfTwo ( _
    v As Integer _
) As Integer
public:
static int NextHighestPowerOfTwo(
    int v
)
public:
static int NextHighestPowerOfTwo(
    int v
)
Parameters
v
Type:   Online System Int32
See Also
BitUtil Class
BitUtil Members
NextHighestPowerOfTwo Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextHighestPowerOfTwo Method (Int64)

BitUtil NextHighestPowerOfTwo Method (Int64) Lucene.Net Class Library
returns the next highest power of two, or the current value if it's already a power of two or zero

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long NextHighestPowerOfTwo(
    long v
)
public static long NextHighestPowerOfTwo(
    long v
)
Public Shared Function NextHighestPowerOfTwo ( _
    v As Long _
) As Long
Public Shared Function NextHighestPowerOfTwo ( _
    v As Long _
) As Long
public:
static long long NextHighestPowerOfTwo(
    long long v
)
public:
static long long NextHighestPowerOfTwo(
    long long v
)
Parameters
v
Type:   Online System Int64
See Also
BitUtil Class
BitUtil Members
NextHighestPowerOfTwo Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Ntz Method

BitUtil Ntz Method Lucene.Net Class Library
Overload List
Name | Description
Ntz(Int32) | Returns number of trailing zeros in a 32 bit int value.
Ntz(Int64) | Returns number of trailing zeros in a 64 bit long value.
Back to Top
See Also
BitUtil Class
BitUtil Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Ntz Method (Int32)

BitUtil Ntz Method (Int32) Lucene.Net Class Library
Returns number of trailing zeros in a 32 bit int value.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Ntz(
    int val
)
public static int Ntz(
    int val
)
Public Shared Function Ntz ( _
    val As Integer _
) As Integer
Public Shared Function Ntz ( _
    val As Integer _
) As Integer
public:
static int Ntz(
    int val
)
public:
static int Ntz(
    int val
)
Parameters
val
Type:   Online System Int32
See Also
BitUtil Class
BitUtil Members
Ntz Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Ntz Method (Int64)

BitUtil Ntz Method (Int64) Lucene.Net Class Library
Returns number of trailing zeros in a 64 bit long value.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Ntz(
    long val
)
public static int Ntz(
    long val
)
Public Shared Function Ntz ( _
    val As Long _
) As Integer
Public Shared Function Ntz ( _
    val As Long _
) As Integer
public:
static int Ntz(
    long long val
)
public:
static int Ntz(
    long long val
)
Parameters
val
Type:   Online System Int64
See Also
BitUtil Class
BitUtil Members
Ntz Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Ntz2 Method

BitUtil Ntz2 Method Lucene.Net Class Library
returns 0 based index of first set bit (only works for x!=0)
This is an alternate implementation of ntz()

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Ntz2(
    long x
)
public static int Ntz2(
    long x
)
Public Shared Function Ntz2 ( _
    x As Long _
) As Integer
Public Shared Function Ntz2 ( _
    x As Long _
) As Integer
public:
static int Ntz2(
    long long x
)
public:
static int Ntz2(
    long long x
)
Parameters
x
Type:   Online System Int64
See Also
BitUtil Class
BitUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Ntz3 Method

BitUtil Ntz3 Method Lucene.Net Class Library
returns 0 based index of first set bit
This is an alternate implementation of ntz()

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Ntz3(
    long x
)
public static int Ntz3(
    long x
)
Public Shared Function Ntz3 ( _
    x As Long _
) As Integer
Public Shared Function Ntz3 ( _
    x As Long _
) As Integer
public:
static int Ntz3(
    long long x
)
public:
static int Ntz3(
    long long x
)
Parameters
x
Type:   Online System Int64
See Also
BitUtil Class
BitUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Pop Method

BitUtil Pop Method Lucene.Net Class Library
Returns the number of bits set in the long

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Pop(
    long x
)
public static int Pop(
    long x
)
Public Shared Function Pop ( _
    x As Long _
) As Integer
Public Shared Function Pop ( _
    x As Long _
) As Integer
public:
static int Pop(
    long long x
)
public:
static int Pop(
    long long x
)
Parameters
x
Type:   Online System Int64
See Also
BitUtil Class
BitUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Pop_andnot Method

BitUtil Pop_andnot Method Lucene.Net Class Library
Returns the popcount or cardinality of A & ~B Neither array is modified.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long Pop_andnot(
    long[] A,
    long[] B,
    int wordOffset,
    int numWords
)
public static long Pop_andnot(
    long[] A,
    long[] B,
    int wordOffset,
    int numWords
)
Public Shared Function Pop_andnot ( _
    A As Long(), _
    B As Long(), _
    wordOffset As Integer, _
    numWords As Integer _
) As Long
Public Shared Function Pop_andnot ( _
    A As Long(), _
    B As Long(), _
    wordOffset As Integer, _
    numWords As Integer _
) As Long
public:
static long long Pop_andnot(
    array<long long>^ A,
    array<long long>^ B,
    int wordOffset,
    int numWords
)
public:
static long long Pop_andnot(
    array<long long>^ A,
    array<long long>^ B,
    int wordOffset,
    int numWords
)
Parameters
A
Type:    Online System Int64
B
Type:    Online System Int64
wordOffset
Type:   Online System Int32
numWords
Type:   Online System Int32
See Also
BitUtil Class
BitUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Pop_array Method

BitUtil Pop_array Method Lucene.Net Class Library
Returns the number of set bits in an array of longs.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long Pop_array(
    long[] A,
    int wordOffset,
    int numWords
)
public static long Pop_array(
    long[] A,
    int wordOffset,
    int numWords
)
Public Shared Function Pop_array ( _
    A As Long(), _
    wordOffset As Integer, _
    numWords As Integer _
) As Long
Public Shared Function Pop_array ( _
    A As Long(), _
    wordOffset As Integer, _
    numWords As Integer _
) As Long
public:
static long long Pop_array(
    array<long long>^ A,
    int wordOffset,
    int numWords
)
public:
static long long Pop_array(
    array<long long>^ A,
    int wordOffset,
    int numWords
)
Parameters
A
Type:    Online System Int64
wordOffset
Type:   Online System Int32
numWords
Type:   Online System Int32
See Also
BitUtil Class
BitUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Pop_intersect Method

BitUtil Pop_intersect Method Lucene.Net Class Library
Returns the popcount or cardinality of the two sets after an intersection. Neither array is modified.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long Pop_intersect(
    long[] A,
    long[] B,
    int wordOffset,
    int numWords
)
public static long Pop_intersect(
    long[] A,
    long[] B,
    int wordOffset,
    int numWords
)
Public Shared Function Pop_intersect ( _
    A As Long(), _
    B As Long(), _
    wordOffset As Integer, _
    numWords As Integer _
) As Long
Public Shared Function Pop_intersect ( _
    A As Long(), _
    B As Long(), _
    wordOffset As Integer, _
    numWords As Integer _
) As Long
public:
static long long Pop_intersect(
    array<long long>^ A,
    array<long long>^ B,
    int wordOffset,
    int numWords
)
public:
static long long Pop_intersect(
    array<long long>^ A,
    array<long long>^ B,
    int wordOffset,
    int numWords
)
Parameters
A
Type:    Online System Int64
B
Type:    Online System Int64
wordOffset
Type:   Online System Int32
numWords
Type:   Online System Int32
See Also
BitUtil Class
BitUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Pop_union Method

BitUtil Pop_union Method Lucene.Net Class Library
Returns the popcount or cardinality of the union of two sets. Neither array is modified.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long Pop_union(
    long[] A,
    long[] B,
    int wordOffset,
    int numWords
)
public static long Pop_union(
    long[] A,
    long[] B,
    int wordOffset,
    int numWords
)
Public Shared Function Pop_union ( _
    A As Long(), _
    B As Long(), _
    wordOffset As Integer, _
    numWords As Integer _
) As Long
Public Shared Function Pop_union ( _
    A As Long(), _
    B As Long(), _
    wordOffset As Integer, _
    numWords As Integer _
) As Long
public:
static long long Pop_union(
    array<long long>^ A,
    array<long long>^ B,
    int wordOffset,
    int numWords
)
public:
static long long Pop_union(
    array<long long>^ A,
    array<long long>^ B,
    int wordOffset,
    int numWords
)
Parameters
A
Type:    Online System Int64
B
Type:    Online System Int64
wordOffset
Type:   Online System Int32
numWords
Type:   Online System Int32
See Also
BitUtil Class
BitUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Pop_xor Method

BitUtil Pop_xor Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long Pop_xor(
    long[] A,
    long[] B,
    int wordOffset,
    int numWords
)
public static long Pop_xor(
    long[] A,
    long[] B,
    int wordOffset,
    int numWords
)
Public Shared Function Pop_xor ( _
    A As Long(), _
    B As Long(), _
    wordOffset As Integer, _
    numWords As Integer _
) As Long
Public Shared Function Pop_xor ( _
    A As Long(), _
    B As Long(), _
    wordOffset As Integer, _
    numWords As Integer _
) As Long
public:
static long long Pop_xor(
    array<long long>^ A,
    array<long long>^ B,
    int wordOffset,
    int numWords
)
public:
static long long Pop_xor(
    array<long long>^ A,
    array<long long>^ B,
    int wordOffset,
    int numWords
)
Parameters
A
Type:    Online System Int64
B
Type:    Online System Int64
wordOffset
Type:   Online System Int32
numWords
Type:   Online System Int32
See Also
BitUtil Class
BitUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitVector Class

BitVector Class Lucene.Net Class Library
Optimized implementation of a vector of bits. This is more-or-less like java.util.BitSet, but also includes the following:
  • a count() method, which efficiently computes the number of one bits;
  • optimized read from and write to disk;
  • inlinable get() method;
  • store and load, as bit set or d-gaps, depending on sparseness;
Inheritance Hierarchy
Online System Object
Lucene.Net.Util BitVector

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BitVector : ICloneable
public sealed class BitVector : ICloneable
Public NotInheritable Class BitVector _
    Implements ICloneable
Public NotInheritable Class BitVector _
    Implements ICloneable
public ref class BitVector sealed : ICloneable
public ref class BitVector sealed : ICloneable
See Also
BitVector Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitVector Members

BitVector Members Lucene.Net Class Library

The BitVector type exposes the following members.
Constructors
 | Name | Description
Public method | BitVector(Int32) | Constructs a vector capable of holding n bits.
Public method | BitVector(Directory, String) | Constructs a bit vector from the file name in Directory d, as written by the Write(Directory, String) method.
Back to Top
Methods
 | Name | Description
Public method | Clear | Sets the value of bit to zero.
Public method | Clone |
Public method | Count | Returns the total number of one bits in this vector. This is efficiently computed and cached, so that, if the vector is not changed, no recomputation is done for repeated calls.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | Returns true if bit is one and false if it is zero.
Public method | GetAndSet | Sets the value of bit to true, and returns true if bit was already set
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetRecomputedCount | For testing
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Set | Sets the value of bit to one.
Public method | Size | Returns the number of bits in this vector. This is also one greater than the number of the largest valid bit number.
Public method | Subset | Retrieve a subset of this BitVector.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Write | Writes this vector to the file name in Directory d, in a format that can be read by the constructor BitVector(Directory, String).
Back to Top
See Also
BitVector Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitVector Constructor

BitVector Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | BitVector(Int32) | Constructs a vector capable of holding n bits.
Public method | BitVector(Directory, String) | Constructs a bit vector from the file name in Directory d, as written by the Write(Directory, String) method.
Back to Top
See Also
BitVector Class
BitVector Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitVector Constructor (Int32)

BitVector Constructor (Int32) Lucene.Net Class Library
Constructs a vector capable of holding n bits.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BitVector(
    int n
)
public BitVector(
    int n
)
Public Sub New ( _
    n As Integer _
)
Public Sub New ( _
    n As Integer _
)
public:
BitVector(
    int n
)
public:
BitVector(
    int n
)
Parameters
n
Type:   Online System Int32
See Also
BitVector Class
BitVector Members
BitVector Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitVector Constructor (Directory, String)

BitVector Constructor (Directory, String) Lucene.Net Class Library
Constructs a bit vector from the file name in Directory d, as written by the Write(Directory, String) method.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BitVector(
    Directory d,
    string name
)
public BitVector(
    Directory d,
    string name
)
Public Sub New ( _
    d As Directory, _
    name As String _
)
Public Sub New ( _
    d As Directory, _
    name As String _
)
public:
BitVector(
    Directory^ d,
    String^ name
)
public:
BitVector(
    Directory^ d,
    String^ name
)
Parameters
d
Type: Lucene.Net.Store Directory
name
Type:   Online System String
See Also
BitVector Class
BitVector Members
BitVector Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitVector Methods

BitVector Methods Lucene.Net Class Library
The BitVector type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Sets the value of bit to zero.
Public method | Clone |
Public method | Count | Returns the total number of one bits in this vector. This is efficiently computed and cached, so that, if the vector is not changed, no recomputation is done for repeated calls.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | Returns true if bit is one and false if it is zero.
Public method | GetAndSet | Sets the value of bit to true, and returns true if bit was already set
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetRecomputedCount | For testing
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Set | Sets the value of bit to one.
Public method | Size | Returns the number of bits in this vector. This is also one greater than the number of the largest valid bit number.
Public method | Subset | Retrieve a subset of this BitVector.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Write | Writes this vector to the file name in Directory d, in a format that can be read by the constructor BitVector(Directory, String).
Back to Top
See Also
BitVector Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method

BitVector Clear Method Lucene.Net Class Library
Sets the value of bit to zero.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear(
    int bit
)
public void Clear(
    int bit
)
Public Sub Clear ( _
    bit As Integer _
)
Public Sub Clear ( _
    bit As Integer _
)
public:
void Clear(
    int bit
)
public:
void Clear(
    int bit
)
Parameters
bit
Type:   Online System Int32
See Also
BitVector Class
BitVector Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

BitVector Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Clone()
public Object Clone()
Public Function Clone As Object
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
public:
virtual Object^ Clone() sealed
Implements
  Online ICloneable Clone
See Also
BitVector Class
BitVector Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Count Method

BitVector Count Method Lucene.Net Class Library
Returns the total number of one bits in this vector. This is efficiently computed and cached, so that, if the vector is not changed, no recomputation is done for repeated calls.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count()
public int Count()
Public Function Count As Integer
Public Function Count As Integer
public:
int Count()
public:
int Count()
See Also
BitVector Class
BitVector Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method

BitVector Get Method Lucene.Net Class Library
Returns true if bit is one and false if it is zero.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Get(
    int bit
)
public bool Get(
    int bit
)
Public Function Get ( _
    bit As Integer _
) As Boolean
Public Function Get ( _
    bit As Integer _
) As Boolean
public:
bool Get(
    int bit
)
public:
bool Get(
    int bit
)
Parameters
bit
Type:   Online System Int32
See Also
BitVector Class
BitVector Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetAndSet Method

BitVector GetAndSet Method Lucene.Net Class Library
Sets the value of bit to true, and returns true if bit was already set

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool GetAndSet(
    int bit
)
public bool GetAndSet(
    int bit
)
Public Function GetAndSet ( _
    bit As Integer _
) As Boolean
Public Function GetAndSet ( _
    bit As Integer _
) As Boolean
public:
bool GetAndSet(
    int bit
)
public:
bool GetAndSet(
    int bit
)
Parameters
bit
Type:   Online System Int32
See Also
BitVector Class
BitVector Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetRecomputedCount Method

BitVector GetRecomputedCount Method Lucene.Net Class Library
For testing

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int GetRecomputedCount()
public int GetRecomputedCount()
Public Function GetRecomputedCount As Integer
Public Function GetRecomputedCount As Integer
public:
int GetRecomputedCount()
public:
int GetRecomputedCount()
See Also
BitVector Class
BitVector Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Set Method

BitVector Set Method Lucene.Net Class Library
Sets the value of bit to one.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Set(
    int bit
)
public void Set(
    int bit
)
Public Sub Set ( _
    bit As Integer _
)
Public Sub Set ( _
    bit As Integer _
)
public:
void Set(
    int bit
)
public:
void Set(
    int bit
)
Parameters
bit
Type:   Online System Int32
See Also
BitVector Class
BitVector Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Size Method

BitVector Size Method Lucene.Net Class Library
Returns the number of bits in this vector. This is also one greater than the number of the largest valid bit number.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Size()
public int Size()
Public Function Size As Integer
Public Function Size As Integer
public:
int Size()
public:
int Size()
See Also
BitVector Class
BitVector Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Subset Method

BitVector Subset Method Lucene.Net Class Library
Retrieve a subset of this BitVector.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BitVector Subset(
    int start,
    int end
)
public BitVector Subset(
    int start,
    int end
)
Public Function Subset ( _
    start As Integer, _
    end As Integer _
) As BitVector
Public Function Subset ( _
    start As Integer, _
    end As Integer _
) As BitVector
public:
BitVector^ Subset(
    int start,
    int end
)
public:
BitVector^ Subset(
    int start,
    int end
)
Parameters
start
Type:   Online System Int32
starting index, inclusive

end
Type:   Online System Int32
ending index, exclusive

Return Value
 subset

See Also
BitVector Class
BitVector Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Write Method

BitVector Write Method Lucene.Net Class Library
Writes this vector to the file name in Directory d, in a format that can be read by the constructor BitVector(Directory, String).

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    Directory d,
    string name
)
public void Write(
    Directory d,
    string name
)
Public Sub Write ( _
    d As Directory, _
    name As String _
)
Public Sub Write ( _
    d As Directory, _
    name As String _
)
public:
void Write(
    Directory^ d,
    String^ name
)
public:
void Write(
    Directory^ d,
    String^ name
)
Parameters
d
Type: Lucene.Net.Store Directory
name
Type:   Online System String
See Also
BitVector Class
BitVector Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CloseableThreadLocal(T) Class

CloseableThreadLocal T Class Lucene.Net Class Library
Java's builtin ThreadLocal has a serious flaw: it can take an arbitrarily long amount of time to dereference the things you had stored in it, even once the ThreadLocal instance itself is no longer referenced. This is because there is single, master map stored for each thread, which all ThreadLocals share, and that master map only periodically purges "stale" entries. While not technically a memory leak, because eventually the memory will be reclaimed, it can take a long time and you can easily hit OutOfMemoryError because from the GC's standpoint the stale entries are not reclaimaible. This class works around that, by only enrolling WeakReference values into the ThreadLocal, and separately holding a hard reference to each stored value. When you call Close , these hard references are cleared and then GC is freely able to reclaim space by objects stored in it.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util CloseableThreadLocal T

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CloseableThreadLocal<T> : IDisposable
where T : class
public class CloseableThreadLocal<T> : IDisposable
where T : class
Public Class CloseableThreadLocal(Of T As Class) _
    Implements IDisposable
Public Class CloseableThreadLocal(Of T As Class) _
    Implements IDisposable
generic<typename T>
where T : ref class
public ref class CloseableThreadLocal : IDisposable
generic<typename T>
where T : ref class
public ref class CloseableThreadLocal : IDisposable
Type Parameters
T
See Also
CloseableThreadLocal T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CloseableThreadLocal(T) Members

CloseableThreadLocal T Members Lucene.Net Class Library

The CloseableThreadLocal T type exposes the following members.
Constructors
 | Name | Description
Public method | CloseableThreadLocal T | Initializes a new instance of the CloseableThreadLocal T class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete.
Public method | Dispose | Releases all resources used by the CloseableThreadLocal T
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CloseableThreadLocal T and optionally releases the managed resources
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | InitialValue |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Set |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CloseableThreadLocal T Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CloseableThreadLocal(T) Constructor

CloseableThreadLocal T Constructor Lucene.Net Class Library
Initializes a new instance of the CloseableThreadLocal T class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CloseableThreadLocal()
public CloseableThreadLocal()
Public Sub New
Public Sub New
public:
CloseableThreadLocal()
public:
CloseableThreadLocal()
See Also
CloseableThreadLocal T  Class
CloseableThreadLocal T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CloseableThreadLocal(T) Methods

CloseableThreadLocal T Methods Lucene.Net Class Library
The CloseableThreadLocal T type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete.
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get |
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | InitialValue |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Set |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CloseableThreadLocal T Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

CloseableThreadLocal T Close Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Dispose() instead")]
public virtual void Close()
[ObsoleteAttribute("Use Dispose() instead")]
public virtual void Close()
<ObsoleteAttribute("Use Dispose() instead")> _
Public Overridable Sub Close
<ObsoleteAttribute("Use Dispose() instead")> _
Public Overridable Sub Close
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
virtual void Close()
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
virtual void Close()
See Also
CloseableThreadLocal T  Class
CloseableThreadLocal T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

CloseableThreadLocal T Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the CloseableThreadLocal T
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CloseableThreadLocal T and optionally releases the managed resources
Back to Top
See Also
CloseableThreadLocal T Class
CloseableThreadLocal T Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

CloseableThreadLocal T Dispose Method Lucene.Net Class Library
Releases all resources used by the CloseableThreadLocal T

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
CloseableThreadLocal T  Class
CloseableThreadLocal T  Members
Dispose Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

CloseableThreadLocal T Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the CloseableThreadLocal T and optionally releases the managed resources

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void Dispose(
    bool disposing
)
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
)
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
CloseableThreadLocal T  Class
CloseableThreadLocal T  Members
Dispose Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method

CloseableThreadLocal T Get Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual T Get()
public virtual T Get()
Public Overridable Function Get As T
Public Overridable Function Get As T
public:
virtual T Get()
public:
virtual T Get()
See Also
CloseableThreadLocal T  Class
CloseableThreadLocal T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


InitialValue Method

CloseableThreadLocal T InitialValue Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual T InitialValue()
public virtual T InitialValue()
Public Overridable Function InitialValue As T
Public Overridable Function InitialValue As T
public:
virtual T InitialValue()
public:
virtual T InitialValue()
See Also
CloseableThreadLocal T  Class
CloseableThreadLocal T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Set Method

CloseableThreadLocal T Set Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Set(
    T object
)
public virtual void Set(
    T object
)
Public Overridable Sub Set ( _
    object As T _
)
Public Overridable Sub Set ( _
    object As T _
)
public:
virtual void Set(
    T object
)
public:
virtual void Set(
    T object
)
Parameters
object
Type: T
See Also
CloseableThreadLocal T  Class
CloseableThreadLocal T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Constants Class

Constants Class Lucene.Net Class Library
Some useful constants.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util Constants

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Constants
public sealed class Constants
Public NotInheritable Class Constants
Public NotInheritable Class Constants
public ref class Constants sealed
public ref class Constants sealed
See Also
Constants Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Constants Members

Constants Members Lucene.Net Class Library

The Constants type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
JAVA_1_1 | True iff this is Java version 1.1.
JAVA_1_2 | True iff this is Java version 1.2.
JAVA_1_3 | True iff this is Java version 1.3.
JAVA_VENDOR |
JAVA_VERSION | The value of System.getProperty("java.version"). *
JRE_IS_64BIT |
LINUX | True iff running on Linux.
LUCENE_MAIN_VERSION |
LUCENE_VERSION |
OS_ARCH |
OS_NAME | The value of System.getProperty("os.name"). *
OS_VERSION |
SUN_OS | True iff running on SunOS.
WINDOWS | True iff running on Windows.
Back to Top
See Also
Constants Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Constants Fields

Constants Fields Lucene.Net Class Library
The Constants type exposes the following members.
Fields
Name | Description
JAVA_1_1 | True iff this is Java version 1.1.
JAVA_1_2 | True iff this is Java version 1.2.
JAVA_1_3 | True iff this is Java version 1.3.
JAVA_VENDOR |
JAVA_VERSION | The value of System.getProperty("java.version"). *
JRE_IS_64BIT |
LINUX | True iff running on Linux.
LUCENE_MAIN_VERSION |
LUCENE_VERSION |
OS_ARCH |
OS_NAME | The value of System.getProperty("os.name"). *
OS_VERSION |
SUN_OS | True iff running on SunOS.
WINDOWS | True iff running on Windows.
Back to Top
See Also
Constants Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


JAVA_1_1 Field

Constants JAVA_1_1 Field Lucene.Net Class Library
True iff this is Java version 1.1.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly bool JAVA_1_1
public static readonly bool JAVA_1_1
Public Shared ReadOnly JAVA_1_1 As Boolean
Public Shared ReadOnly JAVA_1_1 As Boolean
public:
static initonly bool JAVA_1_1
public:
static initonly bool JAVA_1_1
See Also
Constants Class
Constants Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


JAVA_1_2 Field

Constants JAVA_1_2 Field Lucene.Net Class Library
True iff this is Java version 1.2.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly bool JAVA_1_2
public static readonly bool JAVA_1_2
Public Shared ReadOnly JAVA_1_2 As Boolean
Public Shared ReadOnly JAVA_1_2 As Boolean
public:
static initonly bool JAVA_1_2
public:
static initonly bool JAVA_1_2
See Also
Constants Class
Constants Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


JAVA_1_3 Field

Constants JAVA_1_3 Field Lucene.Net Class Library
True iff this is Java version 1.3.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly bool JAVA_1_3
public static readonly bool JAVA_1_3
Public Shared ReadOnly JAVA_1_3 As Boolean
Public Shared ReadOnly JAVA_1_3 As Boolean
public:
static initonly bool JAVA_1_3
public:
static initonly bool JAVA_1_3
See Also
Constants Class
Constants Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


JAVA_VENDOR Field

Constants JAVA_VENDOR Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string JAVA_VENDOR
public static readonly string JAVA_VENDOR
Public Shared ReadOnly JAVA_VENDOR As String
Public Shared ReadOnly JAVA_VENDOR As String
public:
static initonly String^ JAVA_VENDOR
public:
static initonly String^ JAVA_VENDOR
See Also
Constants Class
Constants Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


JAVA_VERSION Field

Constants JAVA_VERSION Field Lucene.Net Class Library
The value of System.getProperty("java.version"). *

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string JAVA_VERSION
public static readonly string JAVA_VERSION
Public Shared ReadOnly JAVA_VERSION As String
Public Shared ReadOnly JAVA_VERSION As String
public:
static initonly String^ JAVA_VERSION
public:
static initonly String^ JAVA_VERSION
See Also
Constants Class
Constants Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


JRE_IS_64BIT Field

Constants JRE_IS_64BIT Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool JRE_IS_64BIT
public static bool JRE_IS_64BIT
Public Shared JRE_IS_64BIT As Boolean
Public Shared JRE_IS_64BIT As Boolean
public:
static bool JRE_IS_64BIT
public:
static bool JRE_IS_64BIT
See Also
Constants Class
Constants Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LINUX Field

Constants LINUX Field Lucene.Net Class Library
True iff running on Linux.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly bool LINUX
public static readonly bool LINUX
Public Shared ReadOnly LINUX As Boolean
Public Shared ReadOnly LINUX As Boolean
public:
static initonly bool LINUX
public:
static initonly bool LINUX
See Also
Constants Class
Constants Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LUCENE_MAIN_VERSION Field

Constants LUCENE_MAIN_VERSION Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string LUCENE_MAIN_VERSION
public static readonly string LUCENE_MAIN_VERSION
Public Shared ReadOnly LUCENE_MAIN_VERSION As String
Public Shared ReadOnly LUCENE_MAIN_VERSION As String
public:
static initonly String^ LUCENE_MAIN_VERSION
public:
static initonly String^ LUCENE_MAIN_VERSION
See Also
Constants Class
Constants Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LUCENE_VERSION Field

Constants LUCENE_VERSION Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string LUCENE_VERSION
public static string LUCENE_VERSION
Public Shared LUCENE_VERSION As String
Public Shared LUCENE_VERSION As String
public:
static String^ LUCENE_VERSION
public:
static String^ LUCENE_VERSION
See Also
Constants Class
Constants Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OS_ARCH Field

Constants OS_ARCH Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string OS_ARCH
public static readonly string OS_ARCH
Public Shared ReadOnly OS_ARCH As String
Public Shared ReadOnly OS_ARCH As String
public:
static initonly String^ OS_ARCH
public:
static initonly String^ OS_ARCH
See Also
Constants Class
Constants Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OS_NAME Field

Constants OS_NAME Field Lucene.Net Class Library
The value of System.getProperty("os.name"). *

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string OS_NAME
public static readonly string OS_NAME
Public Shared ReadOnly OS_NAME As String
Public Shared ReadOnly OS_NAME As String
public:
static initonly String^ OS_NAME
public:
static initonly String^ OS_NAME
See Also
Constants Class
Constants Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OS_VERSION Field

Constants OS_VERSION Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string OS_VERSION
public static readonly string OS_VERSION
Public Shared ReadOnly OS_VERSION As String
Public Shared ReadOnly OS_VERSION As String
public:
static initonly String^ OS_VERSION
public:
static initonly String^ OS_VERSION
See Also
Constants Class
Constants Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SUN_OS Field

Constants SUN_OS Field Lucene.Net Class Library
True iff running on SunOS.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly bool SUN_OS
public static readonly bool SUN_OS
Public Shared ReadOnly SUN_OS As Boolean
Public Shared ReadOnly SUN_OS As Boolean
public:
static initonly bool SUN_OS
public:
static initonly bool SUN_OS
See Also
Constants Class
Constants Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


WINDOWS Field

Constants WINDOWS Field Lucene.Net Class Library
True iff running on Windows.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly bool WINDOWS
public static readonly bool WINDOWS
Public Shared ReadOnly WINDOWS As Boolean
Public Shared ReadOnly WINDOWS As Boolean
public:
static initonly bool WINDOWS
public:
static initonly bool WINDOWS
See Also
Constants Class
Constants Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Constants Methods

Constants Methods Lucene.Net Class Library
The Constants type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Constants Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdBitSet Class

DocIdBitSet Class Lucene.Net Class Library
Simple DocIdSet and DocIdSetIterator backed by a BitSet
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSet
Lucene.Net.Util DocIdBitSet

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DocIdBitSet : DocIdSet
public class DocIdBitSet : DocIdSet
Public Class DocIdBitSet _
    Inherits DocIdSet
Public Class DocIdBitSet _
    Inherits DocIdSet
public ref class DocIdBitSet : public DocIdSet
public ref class DocIdBitSet : public DocIdSet
See Also
DocIdBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdBitSet Members

DocIdBitSet Members Lucene.Net Class Library

The DocIdBitSet type exposes the following members.
Constructors
 | Name | Description
Public method | DocIdBitSet | Initializes a new instance of the DocIdBitSet class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Iterator | (Overrides DocIdSet Iterator .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | BitSet | Returns the underlying BitSet.
Public property | IsCacheable | This DocIdSet implementation is cacheable. (Overrides DocIdSet IsCacheable.)
Back to Top
See Also
DocIdBitSet Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdBitSet Constructor

DocIdBitSet Constructor Lucene.Net Class Library
Initializes a new instance of the DocIdBitSet class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DocIdBitSet(
    BitArray bitSet
)
public DocIdBitSet(
    BitArray bitSet
)
Public Sub New ( _
    bitSet As BitArray _
)
Public Sub New ( _
    bitSet As BitArray _
)
public:
DocIdBitSet(
    BitArray^ bitSet
)
public:
DocIdBitSet(
    BitArray^ bitSet
)
Parameters
bitSet
Type:   Online System.Collections BitArray
See Also
DocIdBitSet Class
DocIdBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdBitSet Methods

DocIdBitSet Methods Lucene.Net Class Library
The DocIdBitSet type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Iterator | (Overrides DocIdSet Iterator .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
DocIdBitSet Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Iterator Method

DocIdBitSet Iterator Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocIdSetIterator Iterator()
public override DocIdSetIterator Iterator()
Public Overrides Function Iterator As DocIdSetIterator
Public Overrides Function Iterator As DocIdSetIterator
public:
virtual DocIdSetIterator^ Iterator() override
public:
virtual DocIdSetIterator^ Iterator() override
See Also
DocIdBitSet Class
DocIdBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocIdBitSet Properties

DocIdBitSet Properties Lucene.Net Class Library
The DocIdBitSet type exposes the following members.
Properties
 | Name | Description
Public property | BitSet | Returns the underlying BitSet.
Public property | IsCacheable | This DocIdSet implementation is cacheable. (Overrides DocIdSet IsCacheable.)
Back to Top
See Also
DocIdBitSet Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BitSet Property

DocIdBitSet BitSet Property Lucene.Net Class Library
Returns the underlying BitSet.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual BitArray BitSet { get; }
public virtual BitArray BitSet { get; }
Public Overridable ReadOnly Property BitSet As BitArray
    Get
Public Overridable ReadOnly Property BitSet As BitArray
    Get
public:
virtual property BitArray^ BitSet {
    BitArray^ get ();
}
public:
virtual property BitArray^ BitSet {
    BitArray^ get ();
}
See Also
DocIdBitSet Class
DocIdBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsCacheable Property

DocIdBitSet IsCacheable Property Lucene.Net Class Library
This DocIdSet implementation is cacheable.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsCacheable { get; }
public override bool IsCacheable { get; }
Public Overrides ReadOnly Property IsCacheable As Boolean
    Get
Public Overrides ReadOnly Property IsCacheable As Boolean
    Get
public:
virtual property bool IsCacheable {
    bool get () override;
}
public:
virtual property bool IsCacheable {
    bool get () override;
}
See Also
DocIdBitSet Class
DocIdBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheSanityChecker Class

FieldCacheSanityChecker Class Lucene.Net Class Library
Provides methods for sanity checking that entries in the FieldCache are not wasteful or inconsistent.

Lucene 2.9 Introduced numerous enhancements into how the FieldCache is used by the low levels of Lucene searching (for Sorting and ValueSourceQueries) to improve both the speed for Sorting, as well as reopening of IndexReaders. But these changes have shifted the usage of FieldCache from "top level" IndexReaders (frequently a MultiReader or DirectoryReader) down to the leaf level SegmentReaders. As a result, existing applications that directly access the FieldCache may find RAM usage increase significantly when upgrading to 2.9 or Later. This class provides an API for these applications (or their Unit tests) to check at run time if the FieldCache contains "insane" usages of the FieldCache.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

Inheritance Hierarchy
Online System Object
Lucene.Net.Util FieldCacheSanityChecker

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class FieldCacheSanityChecker
public sealed class FieldCacheSanityChecker
Public NotInheritable Class FieldCacheSanityChecker
Public NotInheritable Class FieldCacheSanityChecker
public ref class FieldCacheSanityChecker sealed
public ref class FieldCacheSanityChecker sealed
See Also
FieldCacheSanityChecker Members
Lucene.Net.Util Namespace
Lucene.Net.Search FieldCache
Lucene.Net.Util FieldCacheSanityChecker Insanity
Lucene.Net.Util FieldCacheSanityChecker InsanityType
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheSanityChecker Members

FieldCacheSanityChecker Members Lucene.Net Class Library

The FieldCacheSanityChecker type exposes the following members.
Constructors
 | Name | Description
Public method | FieldCacheSanityChecker | Initializes a new instance of the FieldCacheSanityChecker class
Back to Top
Methods
 | Name | Description
Public method | Check | Tests a CacheEntry[] for indication of "insane" cache usage. NOTE:FieldCache CreationPlaceholder objects are ignored. (:TODO: is this a bad idea? are we masking a real problem?)
 | CheckSanity( CacheEntry ) | Quick and dirty convenience method that instantiates an instance with "good defaults" and uses it to test the CacheEntrys
 | CheckSanity(FieldCache) | Quick and dirty convenience method
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetRamUsageEstimator | If set, will be used to estimate size for all CacheEntry objects dealt with.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldCacheSanityChecker Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheSanityChecker Constructor

FieldCacheSanityChecker Constructor Lucene.Net Class Library
Initializes a new instance of the FieldCacheSanityChecker class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldCacheSanityChecker()
public FieldCacheSanityChecker()
Public Sub New
Public Sub New
public:
FieldCacheSanityChecker()
public:
FieldCacheSanityChecker()
See Also
FieldCacheSanityChecker Class
FieldCacheSanityChecker Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheSanityChecker Methods

FieldCacheSanityChecker Methods Lucene.Net Class Library
The FieldCacheSanityChecker type exposes the following members.
Methods
 | Name | Description
Public method | Check | Tests a CacheEntry[] for indication of "insane" cache usage. NOTE:FieldCache CreationPlaceholder objects are ignored. (:TODO: is this a bad idea? are we masking a real problem?)
 | CheckSanity( CacheEntry ) | Quick and dirty convenience method that instantiates an instance with "good defaults" and uses it to test the CacheEntrys
 | CheckSanity(FieldCache) | Quick and dirty convenience method
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetRamUsageEstimator | If set, will be used to estimate size for all CacheEntry objects dealt with.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
FieldCacheSanityChecker Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Check Method

FieldCacheSanityChecker Check Method Lucene.Net Class Library
Tests a CacheEntry[] for indication of "insane" cache usage.

NOTE:FieldCache CreationPlaceholder objects are ignored. (:TODO: is this a bad idea? are we masking a real problem?)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldCacheSanityChecker..::..Insanity[] Check(
    params CacheEntry[] cacheEntries
)
public FieldCacheSanityChecker..::..Insanity[] Check(
    params CacheEntry[] cacheEntries
)
Public Function Check ( _
    ParamArray cacheEntries As CacheEntry() _
) As FieldCacheSanityChecker..::..Insanity()
Public Function Check ( _
    ParamArray cacheEntries As CacheEntry() _
) As FieldCacheSanityChecker..::..Insanity()
public:
array<FieldCacheSanityChecker..::..Insanity^>^ Check(
    ... array<CacheEntry^>^ cacheEntries
)
public:
array<FieldCacheSanityChecker..::..Insanity^>^ Check(
    ... array<CacheEntry^>^ cacheEntries
)
Parameters
cacheEntries
Type:  Lucene.Net.Search CacheEntry
See Also
FieldCacheSanityChecker Class
FieldCacheSanityChecker Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckSanity Method

FieldCacheSanityChecker CheckSanity Method Lucene.Net Class Library
Overload List
Name | Description
CheckSanity( CacheEntry ) | Quick and dirty convenience method that instantiates an instance with "good defaults" and uses it to test the CacheEntrys
CheckSanity(FieldCache) | Quick and dirty convenience method
Back to Top
See Also
FieldCacheSanityChecker Class
FieldCacheSanityChecker Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckSanity Method (CacheEntry[])

FieldCacheSanityChecker CheckSanity Method ( CacheEntry ) Lucene.Net Class Library
Quick and dirty convenience method that instantiates an instance with "good defaults" and uses it to test the CacheEntrys

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldCacheSanityChecker..::..Insanity[] CheckSanity(
    params CacheEntry[] cacheEntries
)
public static FieldCacheSanityChecker..::..Insanity[] CheckSanity(
    params CacheEntry[] cacheEntries
)
Public Shared Function CheckSanity ( _
    ParamArray cacheEntries As CacheEntry() _
) As FieldCacheSanityChecker..::..Insanity()
Public Shared Function CheckSanity ( _
    ParamArray cacheEntries As CacheEntry() _
) As FieldCacheSanityChecker..::..Insanity()
public:
static array<FieldCacheSanityChecker..::..Insanity^>^ CheckSanity(
    ... array<CacheEntry^>^ cacheEntries
)
public:
static array<FieldCacheSanityChecker..::..Insanity^>^ CheckSanity(
    ... array<CacheEntry^>^ cacheEntries
)
Parameters
cacheEntries
Type:  Lucene.Net.Search CacheEntry
See Also
FieldCacheSanityChecker Class
FieldCacheSanityChecker Members
CheckSanity Overload
Lucene.Net.Util Namespace
FieldCacheSanityChecker Check( CacheEntry )
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CheckSanity Method (FieldCache)

FieldCacheSanityChecker CheckSanity Method (FieldCache) Lucene.Net Class Library
Quick and dirty convenience method

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldCacheSanityChecker..::..Insanity[] CheckSanity(
    FieldCache cache
)
public static FieldCacheSanityChecker..::..Insanity[] CheckSanity(
    FieldCache cache
)
Public Shared Function CheckSanity ( _
    cache As FieldCache _
) As FieldCacheSanityChecker..::..Insanity()
Public Shared Function CheckSanity ( _
    cache As FieldCache _
) As FieldCacheSanityChecker..::..Insanity()
public:
static array<FieldCacheSanityChecker..::..Insanity^>^ CheckSanity(
    FieldCache^ cache
)
public:
static array<FieldCacheSanityChecker..::..Insanity^>^ CheckSanity(
    FieldCache^ cache
)
Parameters
cache
Type: Lucene.Net.Search FieldCache
See Also
FieldCacheSanityChecker Class
FieldCacheSanityChecker Members
CheckSanity Overload
Lucene.Net.Util Namespace
FieldCacheSanityChecker Check( CacheEntry )
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetRamUsageEstimator Method

FieldCacheSanityChecker SetRamUsageEstimator Method Lucene.Net Class Library
If set, will be used to estimate size for all CacheEntry objects dealt with.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetRamUsageEstimator(
    RamUsageEstimator r
)
public void SetRamUsageEstimator(
    RamUsageEstimator r
)
Public Sub SetRamUsageEstimator ( _
    r As RamUsageEstimator _
)
Public Sub SetRamUsageEstimator ( _
    r As RamUsageEstimator _
)
public:
void SetRamUsageEstimator(
    RamUsageEstimator^ r
)
public:
void SetRamUsageEstimator(
    RamUsageEstimator^ r
)
Parameters
r
Type: Lucene.Net.Util RamUsageEstimator
See Also
FieldCacheSanityChecker Class
FieldCacheSanityChecker Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheSanityChecker.Insanity Class

FieldCacheSanityChecker Insanity Class Lucene.Net Class Library
Simple container for a collection of related CacheEntry objects that in conjunction with eachother represent some "insane" usage of the FieldCache.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util FieldCacheSanityChecker Insanity

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Insanity
public sealed class Insanity
Public NotInheritable Class Insanity
Public NotInheritable Class Insanity
public ref class Insanity sealed
public ref class Insanity sealed
See Also
FieldCacheSanityChecker Insanity Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheSanityChecker.Insanity Members

FieldCacheSanityChecker Insanity Members Lucene.Net Class Library

Provides methods for sanity checking that entries in the FieldCache are not wasteful or inconsistent.

Lucene 2.9 Introduced numerous enhancements into how the FieldCache is used by the low levels of Lucene searching (for Sorting and ValueSourceQueries) to improve both the speed for Sorting, as well as reopening of IndexReaders. But these changes have shifted the usage of FieldCache from "top level" IndexReaders (frequently a MultiReader or DirectoryReader) down to the leaf level SegmentReaders. As a result, existing applications that directly access the FieldCache may find RAM usage increase significantly when upgrading to 2.9 or Later. This class provides an API for these applications (or their Unit tests) to check at run time if the FieldCache contains "insane" usages of the FieldCache.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

The FieldCacheSanityChecker Insanity type exposes the following members.
Constructors
 | Name | Description
Public method | FieldCacheSanityChecker Insanity | Initializes a new instance of the FieldCacheSanityChecker Insanity class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetCacheEntries | CacheEntry objects which suggest a problem
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Multi-Line representation of this Insanity object, starting with the Type and Msg, followed by each CacheEntry.toString() on it's own line prefaced by a tab character (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | Msg | Description of hte insane behavior
Public property | Type | Type of insane behavior this object represents
Back to Top
See Also
FieldCacheSanityChecker Insanity Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheSanityChecker.Insanity Constructor

FieldCacheSanityChecker Insanity Constructor Lucene.Net Class Library
Initializes a new instance of the FieldCacheSanityChecker Insanity class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Insanity(
    FieldCacheSanityChecker..::..InsanityType type,
    string msg,
    params CacheEntry[] entries
)
public Insanity(
    FieldCacheSanityChecker..::..InsanityType type,
    string msg,
    params CacheEntry[] entries
)
Public Sub New ( _
    type As FieldCacheSanityChecker..::..InsanityType, _
    msg As String, _
    ParamArray entries As CacheEntry() _
)
Public Sub New ( _
    type As FieldCacheSanityChecker..::..InsanityType, _
    msg As String, _
    ParamArray entries As CacheEntry() _
)
public:
Insanity(
    FieldCacheSanityChecker..::..InsanityType^ type,
    String^ msg,
    ... array<CacheEntry^>^ entries
)
public:
Insanity(
    FieldCacheSanityChecker..::..InsanityType^ type,
    String^ msg,
    ... array<CacheEntry^>^ entries
)
Parameters
type
Type: Lucene.Net.Util FieldCacheSanityChecker InsanityType
msg
Type:   Online System String
entries
Type:  Lucene.Net.Search CacheEntry
See Also
FieldCacheSanityChecker Insanity Class
FieldCacheSanityChecker Insanity Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheSanityChecker.Insanity Methods

FieldCacheSanityChecker Insanity Methods Lucene.Net Class Library
The FieldCacheSanityChecker Insanity type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetCacheEntries | CacheEntry objects which suggest a problem
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Multi-Line representation of this Insanity object, starting with the Type and Msg, followed by each CacheEntry.toString() on it's own line prefaced by a tab character (Overrides Online Object ToString .)
Back to Top
See Also
FieldCacheSanityChecker Insanity Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetCacheEntries Method

FieldCacheSanityChecker Insanity GetCacheEntries Method Lucene.Net Class Library
CacheEntry objects which suggest a problem

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CacheEntry[] GetCacheEntries()
public CacheEntry[] GetCacheEntries()
Public Function GetCacheEntries As CacheEntry()
Public Function GetCacheEntries As CacheEntry()
public:
array<CacheEntry^>^ GetCacheEntries()
public:
array<CacheEntry^>^ GetCacheEntries()
See Also
FieldCacheSanityChecker Insanity Class
FieldCacheSanityChecker Insanity Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

FieldCacheSanityChecker Insanity ToString Method Lucene.Net Class Library
Multi-Line representation of this Insanity object, starting with the Type and Msg, followed by each CacheEntry.toString() on it's own line prefaced by a tab character

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
FieldCacheSanityChecker Insanity Class
FieldCacheSanityChecker Insanity Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheSanityChecker.Insanity Properties

FieldCacheSanityChecker Insanity Properties Lucene.Net Class Library
The FieldCacheSanityChecker Insanity type exposes the following members.
Properties
 | Name | Description
Public property | Msg | Description of hte insane behavior
Public property | Type | Type of insane behavior this object represents
Back to Top
See Also
FieldCacheSanityChecker Insanity Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Msg Property

FieldCacheSanityChecker Insanity Msg Property Lucene.Net Class Library
Description of hte insane behavior

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Msg { get; }
public string Msg { get; }
Public ReadOnly Property Msg As String
    Get
Public ReadOnly Property Msg As String
    Get
public:
property String^ Msg {
    String^ get ();
}
public:
property String^ Msg {
    String^ get ();
}
See Also
FieldCacheSanityChecker Insanity Class
FieldCacheSanityChecker Insanity Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Type Property

FieldCacheSanityChecker Insanity Type Property Lucene.Net Class Library
Type of insane behavior this object represents

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldCacheSanityChecker..::..InsanityType Type { get; }
public FieldCacheSanityChecker..::..InsanityType Type { get; }
Public ReadOnly Property Type As FieldCacheSanityChecker..::..InsanityType
    Get
Public ReadOnly Property Type As FieldCacheSanityChecker..::..InsanityType
    Get
public:
property FieldCacheSanityChecker..::..InsanityType^ Type {
    FieldCacheSanityChecker..::..InsanityType^ get ();
}
public:
property FieldCacheSanityChecker..::..InsanityType^ Type {
    FieldCacheSanityChecker..::..InsanityType^ get ();
}
See Also
FieldCacheSanityChecker Insanity Class
FieldCacheSanityChecker Insanity Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheSanityChecker.InsanityType Class

FieldCacheSanityChecker InsanityType Class Lucene.Net Class Library
An Enumaration of the differnet types of "insane" behavior that may be detected in a FieldCache.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util FieldCacheSanityChecker InsanityType

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class InsanityType
public sealed class InsanityType
Public NotInheritable Class InsanityType
Public NotInheritable Class InsanityType
public ref class InsanityType sealed
public ref class InsanityType sealed
See Also
FieldCacheSanityChecker InsanityType Members
Lucene.Net.Util Namespace
FieldCacheSanityChecker InsanityType SUBREADER
FieldCacheSanityChecker InsanityType VALUEMISMATCH
FieldCacheSanityChecker InsanityType EXPECTED
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheSanityChecker.InsanityType Members

FieldCacheSanityChecker InsanityType Members Lucene.Net Class Library

Provides methods for sanity checking that entries in the FieldCache are not wasteful or inconsistent.

Lucene 2.9 Introduced numerous enhancements into how the FieldCache is used by the low levels of Lucene searching (for Sorting and ValueSourceQueries) to improve both the speed for Sorting, as well as reopening of IndexReaders. But these changes have shifted the usage of FieldCache from "top level" IndexReaders (frequently a MultiReader or DirectoryReader) down to the leaf level SegmentReaders. As a result, existing applications that directly access the FieldCache may find RAM usage increase significantly when upgrading to 2.9 or Later. This class provides an API for these applications (or their Unit tests) to check at run time if the FieldCache contains "insane" usages of the FieldCache.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

The FieldCacheSanityChecker InsanityType type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Fields
Name | Description
EXPECTED | Indicates an expected bit of "insanity". This may be useful for clients that wish to preserve/log information about insane usage but indicate that it was expected.
SUBREADER | Indicates an overlap in cache usage on a given field in sub/super readers.
VALUEMISMATCH | Indicates entries have the same reader+fieldname but different cached values. This can happen if different datatypes, or parsers are used -- and while it's not necessarily a bug it's typically an indication of a possible problem. PNOTE: Only the reader, fieldname, and cached value are actually tested -- if two cache entries have different parsers or datatypes but the cached values are the same Object (== not just equal()) this method does not consider that a red flag. This allows for subtle variations in the way a Parser is specified (null vs DEFAULT_LONG_PARSER, etc...)
Back to Top
See Also
FieldCacheSanityChecker InsanityType Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheSanityChecker.InsanityType Fields

FieldCacheSanityChecker InsanityType Fields Lucene.Net Class Library
The FieldCacheSanityChecker InsanityType type exposes the following members.
Fields
Name | Description
EXPECTED | Indicates an expected bit of "insanity". This may be useful for clients that wish to preserve/log information about insane usage but indicate that it was expected.
SUBREADER | Indicates an overlap in cache usage on a given field in sub/super readers.
VALUEMISMATCH | Indicates entries have the same reader+fieldname but different cached values. This can happen if different datatypes, or parsers are used -- and while it's not necessarily a bug it's typically an indication of a possible problem. PNOTE: Only the reader, fieldname, and cached value are actually tested -- if two cache entries have different parsers or datatypes but the cached values are the same Object (== not just equal()) this method does not consider that a red flag. This allows for subtle variations in the way a Parser is specified (null vs DEFAULT_LONG_PARSER, etc...)
Back to Top
See Also
FieldCacheSanityChecker InsanityType Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EXPECTED Field

FieldCacheSanityChecker InsanityType EXPECTED Field Lucene.Net Class Library
Indicates an expected bit of "insanity". This may be useful for clients that wish to preserve/log information about insane usage but indicate that it was expected.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly FieldCacheSanityChecker..::..InsanityType EXPECTED
public static readonly FieldCacheSanityChecker..::..InsanityType EXPECTED
Public Shared ReadOnly EXPECTED As FieldCacheSanityChecker..::..InsanityType
Public Shared ReadOnly EXPECTED As FieldCacheSanityChecker..::..InsanityType
public:
static initonly FieldCacheSanityChecker..::..InsanityType^ EXPECTED
public:
static initonly FieldCacheSanityChecker..::..InsanityType^ EXPECTED
See Also
FieldCacheSanityChecker InsanityType Class
FieldCacheSanityChecker InsanityType Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SUBREADER Field

FieldCacheSanityChecker InsanityType SUBREADER Field Lucene.Net Class Library
Indicates an overlap in cache usage on a given field in sub/super readers.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly FieldCacheSanityChecker..::..InsanityType SUBREADER
public static readonly FieldCacheSanityChecker..::..InsanityType SUBREADER
Public Shared ReadOnly SUBREADER As FieldCacheSanityChecker..::..InsanityType
Public Shared ReadOnly SUBREADER As FieldCacheSanityChecker..::..InsanityType
public:
static initonly FieldCacheSanityChecker..::..InsanityType^ SUBREADER
public:
static initonly FieldCacheSanityChecker..::..InsanityType^ SUBREADER
See Also
FieldCacheSanityChecker InsanityType Class
FieldCacheSanityChecker InsanityType Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


VALUEMISMATCH Field

FieldCacheSanityChecker InsanityType VALUEMISMATCH Field Lucene.Net Class Library

Indicates entries have the same reader+fieldname but different cached values. This can happen if different datatypes, or parsers are used -- and while it's not necessarily a bug it's typically an indication of a possible problem.

PNOTE: Only the reader, fieldname, and cached value are actually tested -- if two cache entries have different parsers or datatypes but the cached values are the same Object (== not just equal()) this method does not consider that a red flag. This allows for subtle variations in the way a Parser is specified (null vs DEFAULT_LONG_PARSER, etc...)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly FieldCacheSanityChecker..::..InsanityType VALUEMISMATCH
public static readonly FieldCacheSanityChecker..::..InsanityType VALUEMISMATCH
Public Shared ReadOnly VALUEMISMATCH As FieldCacheSanityChecker..::..InsanityType
Public Shared ReadOnly VALUEMISMATCH As FieldCacheSanityChecker..::..InsanityType
public:
static initonly FieldCacheSanityChecker..::..InsanityType^ VALUEMISMATCH
public:
static initonly FieldCacheSanityChecker..::..InsanityType^ VALUEMISMATCH
See Also
FieldCacheSanityChecker InsanityType Class
FieldCacheSanityChecker InsanityType Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FieldCacheSanityChecker.InsanityType Methods

FieldCacheSanityChecker InsanityType Methods Lucene.Net Class Library
The FieldCacheSanityChecker InsanityType type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
See Also
FieldCacheSanityChecker InsanityType Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToString Method

FieldCacheSanityChecker InsanityType ToString Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
See Also
FieldCacheSanityChecker InsanityType Class
FieldCacheSanityChecker InsanityType Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IAttribute Interface

IAttribute Interface Lucene.Net Class Library
Base interface for attributes.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IAttribute
public interface IAttribute
Public Interface IAttribute
Public Interface IAttribute
public interface class IAttribute
public interface class IAttribute
See Also
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IdentityDictionary(TKey, TValue) Class

IdentityDictionary TKey, TValue Class Lucene.Net Class Library
A class that mimics Java's IdentityHashMap in that it determines object equality solely on ReferenceEquals rather than (possibly overloaded) object.Equals(). NOTE: Java's documentation on IdentityHashMap says that it also uses ReferenceEquals on it's Values as well. This class does not follow this behavior
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic Dictionary TKey, TValue
Lucene.Net.Util IdentityDictionary TKey, TValue

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class IdentityDictionary<TKey, TValue> : Dictionary<TKey, TValue>
public class IdentityDictionary<TKey, TValue> : Dictionary<TKey, TValue>
Public Class IdentityDictionary(Of TKey, TValue) _
    Inherits Dictionary(Of TKey, TValue)
Public Class IdentityDictionary(Of TKey, TValue) _
    Inherits Dictionary(Of TKey, TValue)
generic<typename TKey, typename TValue>
public ref class IdentityDictionary : public Dictionary<TKey, TValue>
generic<typename TKey, typename TValue>
public ref class IdentityDictionary : public Dictionary<TKey, TValue>
Type Parameters
TKey
The type of the keys in the dictionary
TValue
The type of the values in the dictionary
See Also
IdentityDictionary TKey, TValue  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IdentityDictionary(TKey, TValue) Members

IdentityDictionary TKey, TValue Members Lucene.Net Class Library

The IdentityDictionary TKey, TValue type exposes the following members.
Constructors
 | Name | Description
Public method | IdentityDictionary TKey, TValue | Initializes a new instance of the IdentityDictionary TKey, TValue class
Public method | IdentityDictionary TKey, TValue (IDictionary TKey, TValue ) | Initializes a new instance of the IdentityDictionary TKey, TValue class
Public method | IdentityDictionary TKey, TValue (Int32) | Initializes a new instance of the IdentityDictionary TKey, TValue class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds the specified key and value to the dictionary. (Inherited from Online Dictionary TKey, TValue .)
Public method | Online Clear | Removes all keys and values from the Online Dictionary TKey, TValue . (Inherited from Online Dictionary TKey, TValue .)
Public method | Online ContainsKey | Determines whether the Online Dictionary TKey, TValue contains the specified key. (Inherited from Online Dictionary TKey, TValue .)
Public method | Online ContainsValue | Determines whether the Online Dictionary TKey, TValue contains a specific value. (Inherited from Online Dictionary TKey, TValue .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online Dictionary TKey, TValue . (Inherited from Online Dictionary TKey, TValue .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary TKey, TValue .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary TKey, TValue .)
Public method | Online Remove | Removes the value with the specified key from the Online Dictionary TKey, TValue . (Inherited from Online Dictionary TKey, TValue .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Online TryGetValue | Gets the value associated with the specified key. (Inherited from Online Dictionary TKey, TValue .)
Back to Top
Properties
 | Name | Description
Public property | Online Comparer | Gets the Online IEqualityComparer T that is used to determine equality of keys for the dictionary. (Inherited from Online Dictionary TKey, TValue .)
Public property | Online Count | Gets the number of key/value pairs contained in the Online Dictionary TKey, TValue . (Inherited from Online Dictionary TKey, TValue .)
Public property | Online Item | Gets or sets the value associated with the specified key. (Inherited from Online Dictionary TKey, TValue .)
Public property | Online Keys | Gets a collection containing the keys in the Online Dictionary TKey, TValue . (Inherited from Online Dictionary TKey, TValue .)
Public property | Online Values | Gets a collection containing the values in the Online Dictionary TKey, TValue . (Inherited from Online Dictionary TKey, TValue .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue Add | (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary Add | Adds the specified key and value to the dictionary. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue Contains | (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary Contains | Determines whether the Online IDictionary contains an element with the specified key. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue CopyTo | (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online ICollection CopyTo | Copies the elements of the Online ICollection T to an array, starting at the specified array index. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | IEnumerable KeyValuePair TKey, TValue GetEnumerator | (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IEnumerable GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary GetEnumerator | Returns an Online IDictionaryEnumerator for the Online IDictionary. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary IsFixedSize | Gets a value indicating whether the Online IDictionary has a fixed size. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue IsReadOnly | (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary IsReadOnly | Gets a value indicating whether the Online IDictionary is read-only. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online ICollection IsSynchronized | Gets a value indicating whether access to the Online ICollection is synchronized (thread safe). (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary Item | Gets or sets the value with the specified key. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary TKey, TValue Keys | Gets an Online ICollection T containing the keys of the Online IDictionary TKey, TValue . (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary Keys | Gets an Online ICollection containing the keys of the Online IDictionary. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | ICollection KeyValuePair TKey, TValue Remove | (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary Remove | Removes the element with the specified key from the Online IDictionary. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online ICollection SyncRoot | Gets an object that can be used to synchronize access to the Online ICollection. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary TKey, TValue Values | Gets an Online ICollection T containing the values in the Online IDictionary TKey, TValue . (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary Values | Gets an Online ICollection containing the values in the Online IDictionary. (Inherited from Online Dictionary TKey, TValue .)
Back to Top
See Also
IdentityDictionary TKey, TValue Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IdentityDictionary(TKey, TValue) Constructor

IdentityDictionary TKey, TValue Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | IdentityDictionary TKey, TValue | Initializes a new instance of the IdentityDictionary TKey, TValue class
Public method | IdentityDictionary TKey, TValue (IDictionary TKey, TValue ) | Initializes a new instance of the IdentityDictionary TKey, TValue class
Public method | IdentityDictionary TKey, TValue (Int32) | Initializes a new instance of the IdentityDictionary TKey, TValue class
Back to Top
See Also
IdentityDictionary TKey, TValue Class
IdentityDictionary TKey, TValue Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IdentityDictionary(TKey, TValue) Constructor

IdentityDictionary TKey, TValue Constructor Lucene.Net Class Library
Initializes a new instance of the IdentityDictionary TKey, TValue class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IdentityDictionary()
public IdentityDictionary()
Public Sub New
Public Sub New
public:
IdentityDictionary()
public:
IdentityDictionary()
See Also
IdentityDictionary TKey, TValue  Class
IdentityDictionary TKey, TValue  Members
IdentityDictionary TKey, TValue  Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IdentityDictionary(TKey, TValue) Constructor (IDictionary(TKey, TValue))

IdentityDictionary TKey, TValue Constructor (IDictionary TKey, TValue ) Lucene.Net Class Library
Initializes a new instance of the IdentityDictionary TKey, TValue class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IdentityDictionary(
    IDictionary<TKey, TValue> other
)
public IdentityDictionary(
    IDictionary<TKey, TValue> other
)
Public Sub New ( _
    other As IDictionary(Of TKey, TValue) _
)
Public Sub New ( _
    other As IDictionary(Of TKey, TValue) _
)
public:
IdentityDictionary(
    IDictionary<TKey, TValue>^ other
)
public:
IdentityDictionary(
    IDictionary<TKey, TValue>^ other
)
Parameters
other
Type:   Online System.Collections.Generic IDictionary  TKey, TValue
See Also
IdentityDictionary TKey, TValue  Class
IdentityDictionary TKey, TValue  Members
IdentityDictionary TKey, TValue  Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IdentityDictionary(TKey, TValue) Constructor (Int32)

IdentityDictionary TKey, TValue Constructor (Int32) Lucene.Net Class Library
Initializes a new instance of the IdentityDictionary TKey, TValue class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IdentityDictionary(
    int capacity
)
public IdentityDictionary(
    int capacity
)
Public Sub New ( _
    capacity As Integer _
)
Public Sub New ( _
    capacity As Integer _
)
public:
IdentityDictionary(
    int capacity
)
public:
IdentityDictionary(
    int capacity
)
Parameters
capacity
Type:   Online System Int32
See Also
IdentityDictionary TKey, TValue  Class
IdentityDictionary TKey, TValue  Members
IdentityDictionary TKey, TValue  Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IdentityDictionary(TKey, TValue) Methods

IdentityDictionary TKey, TValue Methods Lucene.Net Class Library
The IdentityDictionary TKey, TValue type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds the specified key and value to the dictionary. (Inherited from Online Dictionary TKey, TValue .)
Public method | Online Clear | Removes all keys and values from the Online Dictionary TKey, TValue . (Inherited from Online Dictionary TKey, TValue .)
Public method | Online ContainsKey | Determines whether the Online Dictionary TKey, TValue contains the specified key. (Inherited from Online Dictionary TKey, TValue .)
Public method | Online ContainsValue | Determines whether the Online Dictionary TKey, TValue contains a specific value. (Inherited from Online Dictionary TKey, TValue .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online Dictionary TKey, TValue . (Inherited from Online Dictionary TKey, TValue .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary TKey, TValue .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary TKey, TValue .)
Public method | Online Remove | Removes the value with the specified key from the Online Dictionary TKey, TValue . (Inherited from Online Dictionary TKey, TValue .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Online TryGetValue | Gets the value associated with the specified key. (Inherited from Online Dictionary TKey, TValue .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | Online ICollection KeyValuePair TKey, TValue Add | (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary Add | Adds the specified key and value to the dictionary. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online ICollection KeyValuePair TKey, TValue Contains | (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary Contains | Determines whether the Online IDictionary contains an element with the specified key. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online ICollection KeyValuePair TKey, TValue CopyTo | (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online ICollection CopyTo | Copies the elements of the Online ICollection T to an array, starting at the specified array index. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IEnumerable KeyValuePair TKey, TValue GetEnumerator | (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IEnumerable GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary GetEnumerator | Returns an Online IDictionaryEnumerator for the Online IDictionary. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online ICollection KeyValuePair TKey, TValue Remove | (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary Remove | Removes the element with the specified key from the Online IDictionary. (Inherited from Online Dictionary TKey, TValue .)
Back to Top
See Also
IdentityDictionary TKey, TValue Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IdentityDictionary(TKey, TValue) Properties

IdentityDictionary TKey, TValue Properties Lucene.Net Class Library
The IdentityDictionary TKey, TValue type exposes the following members.
Properties
 | Name | Description
Public property | Online Comparer | Gets the Online IEqualityComparer T that is used to determine equality of keys for the dictionary. (Inherited from Online Dictionary TKey, TValue .)
Public property | Online Count | Gets the number of key/value pairs contained in the Online Dictionary TKey, TValue . (Inherited from Online Dictionary TKey, TValue .)
Public property | Online Item | Gets or sets the value associated with the specified key. (Inherited from Online Dictionary TKey, TValue .)
Public property | Online Keys | Gets a collection containing the keys in the Online Dictionary TKey, TValue . (Inherited from Online Dictionary TKey, TValue .)
Public property | Online Values | Gets a collection containing the values in the Online Dictionary TKey, TValue . (Inherited from Online Dictionary TKey, TValue .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | Online IDictionary IsFixedSize | Gets a value indicating whether the Online IDictionary has a fixed size. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online ICollection KeyValuePair TKey, TValue IsReadOnly | (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary IsReadOnly | Gets a value indicating whether the Online IDictionary is read-only. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online ICollection IsSynchronized | Gets a value indicating whether access to the Online ICollection is synchronized (thread safe). (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary Item | Gets or sets the value with the specified key. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary TKey, TValue Keys | Gets an Online ICollection T containing the keys of the Online IDictionary TKey, TValue . (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary Keys | Gets an Online ICollection containing the keys of the Online IDictionary. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online ICollection SyncRoot | Gets an object that can be used to synchronize access to the Online ICollection. (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary TKey, TValue Values | Gets an Online ICollection T containing the values in the Online IDictionary TKey, TValue . (Inherited from Online Dictionary TKey, TValue .)
Explicit interface implemetation | Online IDictionary Values | Gets an Online ICollection containing the values in the Online IDictionary. (Inherited from Online Dictionary TKey, TValue .)
Back to Top
See Also
IdentityDictionary TKey, TValue Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexableBinaryStringTools Class

IndexableBinaryStringTools Class Lucene.Net Class Library
Provides support for converting byte sequences to Strings and back again. The resulting Strings preserve the original byte sequences' sort order. The Strings are constructed using a Base 8000h encoding of the original binary data - each char of an encoded String represents a 15-bit chunk from the byte sequence. Base 8000h was chosen because it allows for all lower 15 bits of char to be used without restriction; the surrogate range [U+D8000-U+DFFF] does not represent valid chars, and would require complicated handling to avoid them and allow use of char's high bit. Although unset bits are used as padding in the final char, the original byte sequence could contain trailing bytes with no set bits (null bytes): padding is indistinguishable from valid information. To overcome this problem, a char is appended, indicating the number of encoded bytes in the final content char. This class's operations are defined over CharBuffers and ByteBuffers, to allow for wrapped arrays to be reused, reducing memory allocation costs for repeated operations. Note that this class calls array() and arrayOffset() on the CharBuffers and ByteBuffers it uses, so only wrapped arrays may be used. This class interprets the arrayOffset() and limit() values returned by its input buffers as beginning and end+1 positions on the wrapped array, resprectively; similarly, on the output buffer, arrayOffset() is the first position written to, and limit() is set to one past the final output array position.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util IndexableBinaryStringTools

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class IndexableBinaryStringTools
public class IndexableBinaryStringTools
Public Class IndexableBinaryStringTools
Public Class IndexableBinaryStringTools
public ref class IndexableBinaryStringTools
public ref class IndexableBinaryStringTools
See Also
IndexableBinaryStringTools Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexableBinaryStringTools Members

IndexableBinaryStringTools Members Lucene.Net Class Library

The IndexableBinaryStringTools type exposes the following members.
Methods
 | Name | Description
 | Decode(List Char ) | Decodes the given char sequence, which must have been encoded by Encode(List Byte ) or Encode(List Byte , List Char ).
 | Decode(List Char , List Byte ) | Decodes the input char sequence into the output byte sequence. Before calling this method, ensure that the output ByteBuffer has sufficient capacity by calling GetDecodedLength(List Char ).
 | Encode(List Byte ) | Encodes the input byte sequence.
 | Encode(List Byte , List Char ) | Encodes the input byte sequence into the output char sequence. Before calling this method, ensure that the output CharBuffer has sufficient capacity by calling GetEncodedLength(List Byte ).
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetDecodedLength | Returns the number of bytes required to decode the given char sequence.
 | GetEncodedLength | Returns the number of chars required to encode the given byte sequence.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
IndexableBinaryStringTools Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IndexableBinaryStringTools Methods

IndexableBinaryStringTools Methods Lucene.Net Class Library
The IndexableBinaryStringTools type exposes the following members.
Methods
 | Name | Description
 | Decode(List Char ) | Decodes the given char sequence, which must have been encoded by Encode(List Byte ) or Encode(List Byte , List Char ).
 | Decode(List Char , List Byte ) | Decodes the input char sequence into the output byte sequence. Before calling this method, ensure that the output ByteBuffer has sufficient capacity by calling GetDecodedLength(List Char ).
 | Encode(List Byte ) | Encodes the input byte sequence.
 | Encode(List Byte , List Char ) | Encodes the input byte sequence into the output char sequence. Before calling this method, ensure that the output CharBuffer has sufficient capacity by calling GetEncodedLength(List Byte ).
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetDecodedLength | Returns the number of bytes required to decode the given char sequence.
 | GetEncodedLength | Returns the number of chars required to encode the given byte sequence.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
IndexableBinaryStringTools Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Decode Method

IndexableBinaryStringTools Decode Method Lucene.Net Class Library
Overload List
Name | Description
Decode(List Char ) | Decodes the given char sequence, which must have been encoded by Encode(List Byte ) or Encode(List Byte , List Char ).
Decode(List Char , List Byte ) | Decodes the input char sequence into the output byte sequence. Before calling this method, ensure that the output ByteBuffer has sufficient capacity by calling GetDecodedLength(List Char ).
Back to Top
See Also
IndexableBinaryStringTools Class
IndexableBinaryStringTools Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Decode Method (List(Char))

IndexableBinaryStringTools Decode Method (List Char ) Lucene.Net Class Library
Decodes the given char sequence, which must have been encoded by Encode(List Byte ) or Encode(List Byte , List Char ).
array

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static List<byte> Decode(
    List<char> input
)
public static List<byte> Decode(
    List<char> input
)
Public Shared Function Decode ( _
    input As List(Of Char) _
) As List(Of Byte)
Public Shared Function Decode ( _
    input As List(Of Char) _
) As List(Of Byte)
public:
static List<unsigned char>^ Decode(
    List<wchar_t>^ input
)
public:
static List<unsigned char>^ Decode(
    List<wchar_t>^ input
)
Parameters
input
Type:   Online System.Collections.Generic List    Online Char
The char sequence to decode

Return Value
 A byte sequence containing the decoding result.  The limit
            is set to one past the position of the final char.

See Also
IndexableBinaryStringTools Class
IndexableBinaryStringTools Members
Decode Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Decode Method (List(Char), List(Byte))

IndexableBinaryStringTools Decode Method (List Char , List Byte ) Lucene.Net Class Library
Decodes the input char sequence into the output byte sequence. Before calling this method, ensure that the output ByteBuffer has sufficient capacity by calling GetDecodedLength(List Char ).
is not backed by an array

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Decode(
    List<char> input,
    List<byte> output
)
public static void Decode(
    List<char> input,
    List<byte> output
)
Public Shared Sub Decode ( _
    input As List(Of Char), _
    output As List(Of Byte) _
)
Public Shared Sub Decode ( _
    input As List(Of Char), _
    output As List(Of Byte) _
)
public:
static void Decode(
    List<wchar_t>^ input,
    List<unsigned char>^ output
)
public:
static void Decode(
    List<wchar_t>^ input,
    List<unsigned char>^ output
)
Parameters
input
Type:   Online System.Collections.Generic List    Online Char
The char sequence to decode

output
Type:   Online System.Collections.Generic List    Online Byte
Where the byte sequence decoding result will go.  The limit
            is set to one past the position of the final char.

See Also
IndexableBinaryStringTools Class
IndexableBinaryStringTools Members
Decode Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Encode Method

IndexableBinaryStringTools Encode Method Lucene.Net Class Library
Overload List
Name | Description
Encode(List Byte ) | Encodes the input byte sequence.
Encode(List Byte , List Char ) | Encodes the input byte sequence into the output char sequence. Before calling this method, ensure that the output CharBuffer has sufficient capacity by calling GetEncodedLength(List Byte ).
Back to Top
See Also
IndexableBinaryStringTools Class
IndexableBinaryStringTools Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Encode Method (List(Byte))

IndexableBinaryStringTools Encode Method (List Byte ) Lucene.Net Class Library
Encodes the input byte sequence.
array

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static List<char> Encode(
    List<byte> input
)
public static List<char> Encode(
    List<byte> input
)
Public Shared Function Encode ( _
    input As List(Of Byte) _
) As List(Of Char)
Public Shared Function Encode ( _
    input As List(Of Byte) _
) As List(Of Char)
public:
static List<wchar_t>^ Encode(
    List<unsigned char>^ input
)
public:
static List<wchar_t>^ Encode(
    List<unsigned char>^ input
)
Parameters
input
Type:   Online System.Collections.Generic List    Online Byte
The byte sequence to encode

Return Value
 A char sequence containing the encoding result.  The limit is set
            to one past the position of the final char.

See Also
IndexableBinaryStringTools Class
IndexableBinaryStringTools Members
Encode Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Encode Method (List(Byte), List(Char))

IndexableBinaryStringTools Encode Method (List Byte , List Char ) Lucene.Net Class Library
Encodes the input byte sequence into the output char sequence. Before calling this method, ensure that the output CharBuffer has sufficient capacity by calling GetEncodedLength(List Byte ).
is not backed by an array

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Encode(
    List<byte> input,
    List<char> output
)
public static void Encode(
    List<byte> input,
    List<char> output
)
Public Shared Sub Encode ( _
    input As List(Of Byte), _
    output As List(Of Char) _
)
Public Shared Sub Encode ( _
    input As List(Of Byte), _
    output As List(Of Char) _
)
public:
static void Encode(
    List<unsigned char>^ input,
    List<wchar_t>^ output
)
public:
static void Encode(
    List<unsigned char>^ input,
    List<wchar_t>^ output
)
Parameters
input
Type:   Online System.Collections.Generic List    Online Byte
The byte sequence to encode

output
Type:   Online System.Collections.Generic List    Online Char
Where the char sequence encoding result will go.  The limit
            is set to one past the position of the final char.

See Also
IndexableBinaryStringTools Class
IndexableBinaryStringTools Members
Encode Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetDecodedLength Method

IndexableBinaryStringTools GetDecodedLength Method Lucene.Net Class Library
Returns the number of bytes required to decode the given char sequence.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GetDecodedLength(
    List<char> encoded
)
public static int GetDecodedLength(
    List<char> encoded
)
Public Shared Function GetDecodedLength ( _
    encoded As List(Of Char) _
) As Integer
Public Shared Function GetDecodedLength ( _
    encoded As List(Of Char) _
) As Integer
public:
static int GetDecodedLength(
    List<wchar_t>^ encoded
)
public:
static int GetDecodedLength(
    List<wchar_t>^ encoded
)
Parameters
encoded
Type:   Online System.Collections.Generic List    Online Char
The char sequence to be encoded.  Must be backed by an array.

Return Value
 The number of bytes required to decode the given char sequence

See Also
IndexableBinaryStringTools Class
IndexableBinaryStringTools Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetEncodedLength Method

IndexableBinaryStringTools GetEncodedLength Method Lucene.Net Class Library
Returns the number of chars required to encode the given byte sequence.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GetEncodedLength(
    List<byte> original
)
public static int GetEncodedLength(
    List<byte> original
)
Public Shared Function GetEncodedLength ( _
    original As List(Of Byte) _
) As Integer
Public Shared Function GetEncodedLength ( _
    original As List(Of Byte) _
) As Integer
public:
static int GetEncodedLength(
    List<unsigned char>^ original
)
public:
static int GetEncodedLength(
    List<unsigned char>^ original
)
Parameters
original
Type:   Online System.Collections.Generic List    Online Byte
The byte sequence to be encoded.  Must be backed by an array.

Return Value
 The number of chars required to encode the given byte sequence

See Also
IndexableBinaryStringTools Class
IndexableBinaryStringTools Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MapOfSets(TKey, TValue) Class

MapOfSets TKey, TValue Class Lucene.Net Class Library
Helper class for keeping Listss of Objects associated with keys. WARNING: THIS CLASS IS NOT THREAD SAFE
Inheritance Hierarchy
Online System Object
Lucene.Net.Util MapOfSets TKey, TValue

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MapOfSets<TKey, TValue>
public class MapOfSets<TKey, TValue>
Public Class MapOfSets(Of TKey, TValue)
Public Class MapOfSets(Of TKey, TValue)
generic<typename TKey, typename TValue>
public ref class MapOfSets
generic<typename TKey, typename TValue>
public ref class MapOfSets
Type Parameters
TKey
TValue
See Also
MapOfSets TKey, TValue  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MapOfSets(TKey, TValue) Members

MapOfSets TKey, TValue Members Lucene.Net Class Library

The MapOfSets TKey, TValue type exposes the following members.
Constructors
 | Name | Description
Public method | MapOfSets TKey, TValue | Initializes a new instance of the MapOfSets TKey, TValue class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Put | Adds val to the Set associated with key in the Map. If key is not already in the map, a new Set will first be created.
Public method | PutAll | Adds multiple vals to the Set associated with key in the Map. If key is not already in the map, a new Set will first be created.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Map |
Back to Top
See Also
MapOfSets TKey, TValue Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MapOfSets(TKey, TValue) Constructor

MapOfSets TKey, TValue Constructor Lucene.Net Class Library
Initializes a new instance of the MapOfSets TKey, TValue class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MapOfSets(
    IDictionary<TKey, HashSet<TValue>> m
)
public MapOfSets(
    IDictionary<TKey, HashSet<TValue>> m
)
Public Sub New ( _
    m As IDictionary(Of TKey, HashSet(Of TValue)) _
)
Public Sub New ( _
    m As IDictionary(Of TKey, HashSet(Of TValue)) _
)
public:
MapOfSets(
    IDictionary<TKey, HashSet<TValue>^>^ m
)
public:
MapOfSets(
    IDictionary<TKey, HashSet<TValue>^>^ m
)
Parameters
m
Type:   Online System.Collections.Generic IDictionary  TKey,   Online HashSet  TValue
the backing store for this object

See Also
MapOfSets TKey, TValue  Class
MapOfSets TKey, TValue  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MapOfSets(TKey, TValue) Methods

MapOfSets TKey, TValue Methods Lucene.Net Class Library
The MapOfSets TKey, TValue type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Put | Adds val to the Set associated with key in the Map. If key is not already in the map, a new Set will first be created.
Public method | PutAll | Adds multiple vals to the Set associated with key in the Map. If key is not already in the map, a new Set will first be created.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MapOfSets TKey, TValue Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Put Method

MapOfSets TKey, TValue Put Method Lucene.Net Class Library
Adds val to the Set associated with key in the Map. If key is not already in the map, a new Set will first be created.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Put(
    TKey key,
    TValue val
)
public virtual int Put(
    TKey key,
    TValue val
)
Public Overridable Function Put ( _
    key As TKey, _
    val As TValue _
) As Integer
Public Overridable Function Put ( _
    key As TKey, _
    val As TValue _
) As Integer
public:
virtual int Put(
    TKey key,
    TValue val
)
public:
virtual int Put(
    TKey key,
    TValue val
)
Parameters
key
Type: TKey
val
Type: TValue
Return Value
 the size of the Set associated with key once val is added to it.

See Also
MapOfSets TKey, TValue  Class
MapOfSets TKey, TValue  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PutAll Method

MapOfSets TKey, TValue PutAll Method Lucene.Net Class Library
Adds multiple vals to the Set associated with key in the Map. If key is not already in the map, a new Set will first be created.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int PutAll(
    TKey key,
    IEnumerable<TValue> vals
)
public virtual int PutAll(
    TKey key,
    IEnumerable<TValue> vals
)
Public Overridable Function PutAll ( _
    key As TKey, _
    vals As IEnumerable(Of TValue) _
) As Integer
Public Overridable Function PutAll ( _
    key As TKey, _
    vals As IEnumerable(Of TValue) _
) As Integer
public:
virtual int PutAll(
    TKey key,
    IEnumerable<TValue>^ vals
)
public:
virtual int PutAll(
    TKey key,
    IEnumerable<TValue>^ vals
)
Parameters
key
Type: TKey
vals
Type:   Online System.Collections.Generic IEnumerable  TValue
Return Value
 the size of the Set associated with key once val is added to it.

See Also
MapOfSets TKey, TValue  Class
MapOfSets TKey, TValue  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MapOfSets(TKey, TValue) Properties

MapOfSets TKey, TValue Properties Lucene.Net Class Library
The MapOfSets TKey, TValue type exposes the following members.
Properties
 | Name | Description
Public property | Map |
Back to Top
See Also
MapOfSets TKey, TValue Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Map Property

MapOfSets TKey, TValue Map Property Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IDictionary<TKey, HashSet<TValue>> Map { get; }
public virtual IDictionary<TKey, HashSet<TValue>> Map { get; }
Public Overridable ReadOnly Property Map As IDictionary(Of TKey, HashSet(Of TValue))
    Get
Public Overridable ReadOnly Property Map As IDictionary(Of TKey, HashSet(Of TValue))
    Get
public:
virtual property IDictionary<TKey, HashSet<TValue>^>^ Map {
    IDictionary<TKey, HashSet<TValue>^>^ get ();
}
public:
virtual property IDictionary<TKey, HashSet<TValue>^>^ Map {
    IDictionary<TKey, HashSet<TValue>^>^ get ();
}
Field Value
 direct access to the map backing this object.
See Also
MapOfSets TKey, TValue  Class
MapOfSets TKey, TValue  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MemoryModel Class

MemoryModel Class Lucene.Net Class Library
Returns primitive memory sizes for estimating RAM usage.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util MemoryModel
Lucene.Net.Util AverageGuessMemoryModel

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class MemoryModel
public abstract class MemoryModel
Public MustInherit Class MemoryModel
Public MustInherit Class MemoryModel
public ref class MemoryModel abstract
public ref class MemoryModel abstract
See Also
MemoryModel Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MemoryModel Members

MemoryModel Members Lucene.Net Class Library

The MemoryModel type exposes the following members.
Constructors
 | Name | Description
Protected method | MemoryModel | Initializes a new instance of the MemoryModel class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPrimitiveSize |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ArraySize |
Public property | ClassSize |
Public property | ReferenceSize |
Back to Top
See Also
MemoryModel Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MemoryModel Constructor

MemoryModel Constructor Lucene.Net Class Library
Initializes a new instance of the MemoryModel class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MemoryModel()
protected MemoryModel()
Protected Sub New
Protected Sub New
protected:
MemoryModel()
protected:
MemoryModel()
See Also
MemoryModel Class
MemoryModel Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MemoryModel Methods

MemoryModel Methods Lucene.Net Class Library
The MemoryModel type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetPrimitiveSize |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MemoryModel Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetPrimitiveSize Method

MemoryModel GetPrimitiveSize Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int GetPrimitiveSize(
    Type clazz
)
public abstract int GetPrimitiveSize(
    Type clazz
)
Public MustOverride Function GetPrimitiveSize ( _
    clazz As Type _
) As Integer
Public MustOverride Function GetPrimitiveSize ( _
    clazz As Type _
) As Integer
public:
virtual int GetPrimitiveSize(
    Type^ clazz
) abstract
public:
virtual int GetPrimitiveSize(
    Type^ clazz
) abstract
Parameters
clazz
Type:   Online System Type
a primitive Class - bool, byte, char, short, long, float,
            short, double, int

Return Value
 the size in bytes of given primitive Class

See Also
MemoryModel Class
MemoryModel Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MemoryModel Properties

MemoryModel Properties Lucene.Net Class Library
The MemoryModel type exposes the following members.
Properties
 | Name | Description
Public property | ArraySize |
Public property | ClassSize |
Public property | ReferenceSize |
Back to Top
See Also
MemoryModel Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ArraySize Property

MemoryModel ArraySize Property Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int ArraySize { get; }
public abstract int ArraySize { get; }
Public MustOverride ReadOnly Property ArraySize As Integer
    Get
Public MustOverride ReadOnly Property ArraySize As Integer
    Get
public:
virtual property int ArraySize {
    int get () abstract;
}
public:
virtual property int ArraySize {
    int get () abstract;
}
Field Value
 size of array beyond contents
See Also
MemoryModel Class
MemoryModel Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ClassSize Property

MemoryModel ClassSize Property Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int ClassSize { get; }
public abstract int ClassSize { get; }
Public MustOverride ReadOnly Property ClassSize As Integer
    Get
Public MustOverride ReadOnly Property ClassSize As Integer
    Get
public:
virtual property int ClassSize {
    int get () abstract;
}
public:
virtual property int ClassSize {
    int get () abstract;
}
Field Value
 Class size overhead
See Also
MemoryModel Class
MemoryModel Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReferenceSize Property

MemoryModel ReferenceSize Property Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int ReferenceSize { get; }
public abstract int ReferenceSize { get; }
Public MustOverride ReadOnly Property ReferenceSize As Integer
    Get
Public MustOverride ReadOnly Property ReferenceSize As Integer
    Get
public:
virtual property int ReferenceSize {
    int get () abstract;
}
public:
virtual property int ReferenceSize {
    int get () abstract;
}
Field Value
 size of reference
See Also
MemoryModel Class
MemoryModel Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericUtils Class

NumericUtils Class Lucene.Net Class Library
This is a helper class to generate prefix-encoded representations for numerical values and supplies converters to represent float/double values as sortable integers/longs.

To quickly execute range queries in Apache Lucene, a range is divided recursively into multiple intervals for searching: The center of the range is searched only with the lowest possible precision in the trie, while the boundaries are matched more exactly. This reduces the number of terms dramatically.

This class generates terms to achive this: First the numerical integer values need to be converted to strings. For that integer values (32 bit or 64 bit) are made unsigned and the bits are converted to ASCII chars with each 7 bit. The resulting string is sortable like the original integer value. Each value is also prefixed (in the first char) by the shift value (number of bits removed) used during encoding.

To also index floating point numbers, this class supplies two methods to convert them to integer values by changing their bit layout: DoubleToSortableLong(Double), FloatToSortableInt(Single). You will have no precision loss by converting floating point numbers to integers and back (only that the integer form is not usable). Other data types like dates can easily converted to longs or ints (e.g. date to long: Online DateTime).

For easy usage, the trie algorithm is implemented for indexing inside NumericTokenStream that can index int, long, float, and double. For querying, NumericRangeQuery T and NumericRangeFilter T implement the query part for the same data types.

This class can also be used, to generate lexicographically sortable (according Online CompareTo(String)) representations of numeric data types for other usages (e.g. sorting).

NOTE: This API is experimental and might change in incompatible ways in the next release.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util NumericUtils

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NumericUtils
public sealed class NumericUtils
Public NotInheritable Class NumericUtils
Public NotInheritable Class NumericUtils
public ref class NumericUtils sealed
public ref class NumericUtils sealed
See Also
NumericUtils Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericUtils Members

NumericUtils Members Lucene.Net Class Library

The NumericUtils type exposes the following members.
Methods
 | Name | Description
 | DoubleToPrefixCoded | Convenience method: this just returns: longToPrefixCoded(doubleToSortableLong(val))
 | DoubleToSortableLong | Converts a double value to a sortable signed long. The value is converted by getting their IEEE 754 floating-point "double format" bit layout and then some bits are swapped, to be able to compare the result as long. By this the precision is not reduced, but the value can easily used as a long.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | FloatToPrefixCoded | Convenience method: this just returns: intToPrefixCoded(floatToSortableInt(val))
 | FloatToSortableInt | Converts a float value to a sortable signed int. The value is converted by getting their IEEE 754 floating-point "float format" bit layout and then some bits are swapped, to be able to compare the result as int. By this the precision is not reduced, but the value can easily used as an int.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | IntToPrefixCoded(Int32) | This is a convenience method, that returns prefix coded bits of an int without reducing the precision. It can be used to store the full precision value as a stored field in index. To decode, use PrefixCodedToInt(String).
 | IntToPrefixCoded(Int32, Int32) | Expert: Returns prefix coded bits after reducing the precision by shift bits. This is method is used by NumericUtils IntRangeBuilder.
 | IntToPrefixCoded(Int32, Int32, Char ) | Expert: Returns prefix coded bits after reducing the precision by shift bits. This is method is used by NumericTokenStream.
 | LongToPrefixCoded(Int64) | This is a convenience method, that returns prefix coded bits of a long without reducing the precision. It can be used to store the full precision value as a stored field in index. To decode, use PrefixCodedToLong(String).
 | LongToPrefixCoded(Int64, Int32) | Expert: Returns prefix coded bits after reducing the precision by shift bits. This is method is used by NumericUtils LongRangeBuilder.
 | LongToPrefixCoded(Int64, Int32, Char ) | Expert: Returns prefix coded bits after reducing the precision by shift bits. This is method is used by NumericTokenStream.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | PrefixCodedToDouble | Convenience method: this just returns: sortableLongToDouble(prefixCodedToLong(val))
 | PrefixCodedToFloat | Convenience method: this just returns: sortableIntToFloat(prefixCodedToInt(val))
 | PrefixCodedToInt | Returns an int from prefixCoded characters. Rightmost bits will be zero for lower precision codes. This method can be used to decode e.g. a stored field.
 | PrefixCodedToLong | Returns a long from prefixCoded characters. Rightmost bits will be zero for lower precision codes. This method can be used to decode e.g. a stored field.
 | SortableIntToFloat | Converts a sortable int back to a float.
 | SortableLongToDouble | Converts a sortable long back to a double.
 | SplitIntRange | Expert: Splits an int range recursively. You may implement a builder that adds clauses to a BooleanQuery for each call to its AddRange(String, String) method. This method is used by NumericRangeQuery T .
 | SplitLongRange | Expert: Splits a long range recursively. You may implement a builder that adds clauses to a BooleanQuery for each call to its AddRange(String, String) method. This method is used by NumericRangeQuery T .
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
BUF_SIZE_INT | Expert: The maximum term length (used for char[] buffer size) for encoding int values.
BUF_SIZE_LONG | Expert: The maximum term length (used for char[] buffer size) for encoding long values.
PRECISION_STEP_DEFAULT | The default precision step used by NumericField, NumericTokenStream, NumericRangeQuery T , and NumericRangeFilter T as default
SHIFT_START_INT | Expert: Integers are stored at lower precision by shifting off lower bits. The shift count is stored as SHIFT_START_INT+shift in the first character
SHIFT_START_LONG | Expert: Longs are stored at lower precision by shifting off lower bits. The shift count is stored as SHIFT_START_LONG+shift in the first character
Back to Top
See Also
NumericUtils Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericUtils Fields

NumericUtils Fields Lucene.Net Class Library
The NumericUtils type exposes the following members.
Fields
Name | Description
BUF_SIZE_INT | Expert: The maximum term length (used for char[] buffer size) for encoding int values.
BUF_SIZE_LONG | Expert: The maximum term length (used for char[] buffer size) for encoding long values.
PRECISION_STEP_DEFAULT | The default precision step used by NumericField, NumericTokenStream, NumericRangeQuery T , and NumericRangeFilter T as default
SHIFT_START_INT | Expert: Integers are stored at lower precision by shifting off lower bits. The shift count is stored as SHIFT_START_INT+shift in the first character
SHIFT_START_LONG | Expert: Longs are stored at lower precision by shifting off lower bits. The shift count is stored as SHIFT_START_LONG+shift in the first character
Back to Top
See Also
NumericUtils Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BUF_SIZE_INT Field

NumericUtils BUF_SIZE_INT Field Lucene.Net Class Library
Expert: The maximum term length (used for char[] buffer size) for encoding int values.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int BUF_SIZE_INT
public const int BUF_SIZE_INT
Public Const BUF_SIZE_INT As Integer
Public Const BUF_SIZE_INT As Integer
public:
literal int BUF_SIZE_INT
public:
literal int BUF_SIZE_INT
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace
NumericUtils IntToPrefixCoded(Int32, Int32,  Char )
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BUF_SIZE_LONG Field

NumericUtils BUF_SIZE_LONG Field Lucene.Net Class Library
Expert: The maximum term length (used for char[] buffer size) for encoding long values.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int BUF_SIZE_LONG
public const int BUF_SIZE_LONG
Public Const BUF_SIZE_LONG As Integer
Public Const BUF_SIZE_LONG As Integer
public:
literal int BUF_SIZE_LONG
public:
literal int BUF_SIZE_LONG
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace
NumericUtils LongToPrefixCoded(Int64, Int32,  Char )
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PRECISION_STEP_DEFAULT Field

NumericUtils PRECISION_STEP_DEFAULT Field Lucene.Net Class Library
The default precision step used by NumericField, NumericTokenStream, NumericRangeQuery T , and NumericRangeFilter T as default

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int PRECISION_STEP_DEFAULT
public const int PRECISION_STEP_DEFAULT
Public Const PRECISION_STEP_DEFAULT As Integer
Public Const PRECISION_STEP_DEFAULT As Integer
public:
literal int PRECISION_STEP_DEFAULT
public:
literal int PRECISION_STEP_DEFAULT
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SHIFT_START_INT Field

NumericUtils SHIFT_START_INT Field Lucene.Net Class Library
Expert: Integers are stored at lower precision by shifting off lower bits. The shift count is stored as SHIFT_START_INT+shift in the first character

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static char SHIFT_START_INT
public static char SHIFT_START_INT
Public Shared SHIFT_START_INT As Char
Public Shared SHIFT_START_INT As Char
public:
static wchar_t SHIFT_START_INT
public:
static wchar_t SHIFT_START_INT
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SHIFT_START_LONG Field

NumericUtils SHIFT_START_LONG Field Lucene.Net Class Library
Expert: Longs are stored at lower precision by shifting off lower bits. The shift count is stored as SHIFT_START_LONG+shift in the first character

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static char SHIFT_START_LONG
public static char SHIFT_START_LONG
Public Shared SHIFT_START_LONG As Char
Public Shared SHIFT_START_LONG As Char
public:
static wchar_t SHIFT_START_LONG
public:
static wchar_t SHIFT_START_LONG
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericUtils Methods

NumericUtils Methods Lucene.Net Class Library
The NumericUtils type exposes the following members.
Methods
 | Name | Description
 | DoubleToPrefixCoded | Convenience method: this just returns: longToPrefixCoded(doubleToSortableLong(val))
 | DoubleToSortableLong | Converts a double value to a sortable signed long. The value is converted by getting their IEEE 754 floating-point "double format" bit layout and then some bits are swapped, to be able to compare the result as long. By this the precision is not reduced, but the value can easily used as a long.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | FloatToPrefixCoded | Convenience method: this just returns: intToPrefixCoded(floatToSortableInt(val))
 | FloatToSortableInt | Converts a float value to a sortable signed int. The value is converted by getting their IEEE 754 floating-point "float format" bit layout and then some bits are swapped, to be able to compare the result as int. By this the precision is not reduced, but the value can easily used as an int.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | IntToPrefixCoded(Int32) | This is a convenience method, that returns prefix coded bits of an int without reducing the precision. It can be used to store the full precision value as a stored field in index. To decode, use PrefixCodedToInt(String).
 | IntToPrefixCoded(Int32, Int32) | Expert: Returns prefix coded bits after reducing the precision by shift bits. This is method is used by NumericUtils IntRangeBuilder.
 | IntToPrefixCoded(Int32, Int32, Char ) | Expert: Returns prefix coded bits after reducing the precision by shift bits. This is method is used by NumericTokenStream.
 | LongToPrefixCoded(Int64) | This is a convenience method, that returns prefix coded bits of a long without reducing the precision. It can be used to store the full precision value as a stored field in index. To decode, use PrefixCodedToLong(String).
 | LongToPrefixCoded(Int64, Int32) | Expert: Returns prefix coded bits after reducing the precision by shift bits. This is method is used by NumericUtils LongRangeBuilder.
 | LongToPrefixCoded(Int64, Int32, Char ) | Expert: Returns prefix coded bits after reducing the precision by shift bits. This is method is used by NumericTokenStream.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | PrefixCodedToDouble | Convenience method: this just returns: sortableLongToDouble(prefixCodedToLong(val))
 | PrefixCodedToFloat | Convenience method: this just returns: sortableIntToFloat(prefixCodedToInt(val))
 | PrefixCodedToInt | Returns an int from prefixCoded characters. Rightmost bits will be zero for lower precision codes. This method can be used to decode e.g. a stored field.
 | PrefixCodedToLong | Returns a long from prefixCoded characters. Rightmost bits will be zero for lower precision codes. This method can be used to decode e.g. a stored field.
 | SortableIntToFloat | Converts a sortable int back to a float.
 | SortableLongToDouble | Converts a sortable long back to a double.
 | SplitIntRange | Expert: Splits an int range recursively. You may implement a builder that adds clauses to a BooleanQuery for each call to its AddRange(String, String) method. This method is used by NumericRangeQuery T .
 | SplitLongRange | Expert: Splits a long range recursively. You may implement a builder that adds clauses to a BooleanQuery for each call to its AddRange(String, String) method. This method is used by NumericRangeQuery T .
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NumericUtils Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoubleToPrefixCoded Method

NumericUtils DoubleToPrefixCoded Method Lucene.Net Class Library
Convenience method: this just returns: longToPrefixCoded(doubleToSortableLong(val))

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string DoubleToPrefixCoded(
    double val
)
public static string DoubleToPrefixCoded(
    double val
)
Public Shared Function DoubleToPrefixCoded ( _
    val As Double _
) As String
Public Shared Function DoubleToPrefixCoded ( _
    val As Double _
) As String
public:
static String^ DoubleToPrefixCoded(
    double val
)
public:
static String^ DoubleToPrefixCoded(
    double val
)
Parameters
val
Type:   Online System Double
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DoubleToSortableLong Method

NumericUtils DoubleToSortableLong Method Lucene.Net Class Library
Converts a double value to a sortable signed long. The value is converted by getting their IEEE 754 floating-point "double format" bit layout and then some bits are swapped, to be able to compare the result as long. By this the precision is not reduced, but the value can easily used as a long.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long DoubleToSortableLong(
    double val
)
public static long DoubleToSortableLong(
    double val
)
Public Shared Function DoubleToSortableLong ( _
    val As Double _
) As Long
Public Shared Function DoubleToSortableLong ( _
    val As Double _
) As Long
public:
static long long DoubleToSortableLong(
    double val
)
public:
static long long DoubleToSortableLong(
    double val
)
Parameters
val
Type:   Online System Double
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace
NumericUtils SortableLongToDouble(Int64)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FloatToPrefixCoded Method

NumericUtils FloatToPrefixCoded Method Lucene.Net Class Library
Convenience method: this just returns: intToPrefixCoded(floatToSortableInt(val))

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string FloatToPrefixCoded(
    float val
)
public static string FloatToPrefixCoded(
    float val
)
Public Shared Function FloatToPrefixCoded ( _
    val As Single _
) As String
Public Shared Function FloatToPrefixCoded ( _
    val As Single _
) As String
public:
static String^ FloatToPrefixCoded(
    float val
)
public:
static String^ FloatToPrefixCoded(
    float val
)
Parameters
val
Type:   Online System Single
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FloatToSortableInt Method

NumericUtils FloatToSortableInt Method Lucene.Net Class Library
Converts a float value to a sortable signed int. The value is converted by getting their IEEE 754 floating-point "float format" bit layout and then some bits are swapped, to be able to compare the result as int. By this the precision is not reduced, but the value can easily used as an int.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int FloatToSortableInt(
    float val
)
public static int FloatToSortableInt(
    float val
)
Public Shared Function FloatToSortableInt ( _
    val As Single _
) As Integer
Public Shared Function FloatToSortableInt ( _
    val As Single _
) As Integer
public:
static int FloatToSortableInt(
    float val
)
public:
static int FloatToSortableInt(
    float val
)
Parameters
val
Type:   Online System Single
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace
NumericUtils SortableIntToFloat(Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IntToPrefixCoded Method

NumericUtils IntToPrefixCoded Method Lucene.Net Class Library
Overload List
Name | Description
IntToPrefixCoded(Int32) | This is a convenience method, that returns prefix coded bits of an int without reducing the precision. It can be used to store the full precision value as a stored field in index. To decode, use PrefixCodedToInt(String).
IntToPrefixCoded(Int32, Int32) | Expert: Returns prefix coded bits after reducing the precision by shift bits. This is method is used by NumericUtils IntRangeBuilder.
IntToPrefixCoded(Int32, Int32, Char ) | Expert: Returns prefix coded bits after reducing the precision by shift bits. This is method is used by NumericTokenStream.
Back to Top
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IntToPrefixCoded Method (Int32)

NumericUtils IntToPrefixCoded Method (Int32) Lucene.Net Class Library
This is a convenience method, that returns prefix coded bits of an int without reducing the precision. It can be used to store the full precision value as a stored field in index.

To decode, use PrefixCodedToInt(String).

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string IntToPrefixCoded(
    int val
)
public static string IntToPrefixCoded(
    int val
)
Public Shared Function IntToPrefixCoded ( _
    val As Integer _
) As String
Public Shared Function IntToPrefixCoded ( _
    val As Integer _
) As String
public:
static String^ IntToPrefixCoded(
    int val
)
public:
static String^ IntToPrefixCoded(
    int val
)
Parameters
val
Type:   Online System Int32
See Also
NumericUtils Class
NumericUtils Members
IntToPrefixCoded Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IntToPrefixCoded Method (Int32, Int32)

NumericUtils IntToPrefixCoded Method (Int32, Int32) Lucene.Net Class Library
Expert: Returns prefix coded bits after reducing the precision by shift bits. This is method is used by NumericUtils IntRangeBuilder.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string IntToPrefixCoded(
    int val,
    int shift
)
public static string IntToPrefixCoded(
    int val,
    int shift
)
Public Shared Function IntToPrefixCoded ( _
    val As Integer, _
    shift As Integer _
) As String
Public Shared Function IntToPrefixCoded ( _
    val As Integer, _
    shift As Integer _
) As String
public:
static String^ IntToPrefixCoded(
    int val,
    int shift
)
public:
static String^ IntToPrefixCoded(
    int val,
    int shift
)
Parameters
val
Type:   Online System Int32
the numeric value

shift
Type:   Online System Int32
how many bits to strip from the right

See Also
NumericUtils Class
NumericUtils Members
IntToPrefixCoded Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IntToPrefixCoded Method (Int32, Int32, Char[])

NumericUtils IntToPrefixCoded Method (Int32, Int32, Char ) Lucene.Net Class Library
Expert: Returns prefix coded bits after reducing the precision by shift bits. This is method is used by NumericTokenStream.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int IntToPrefixCoded(
    int val,
    int shift,
    char[] buffer
)
public static int IntToPrefixCoded(
    int val,
    int shift,
    char[] buffer
)
Public Shared Function IntToPrefixCoded ( _
    val As Integer, _
    shift As Integer, _
    buffer As Char() _
) As Integer
Public Shared Function IntToPrefixCoded ( _
    val As Integer, _
    shift As Integer, _
    buffer As Char() _
) As Integer
public:
static int IntToPrefixCoded(
    int val,
    int shift,
    array<wchar_t>^ buffer
)
public:
static int IntToPrefixCoded(
    int val,
    int shift,
    array<wchar_t>^ buffer
)
Parameters
val
Type:   Online System Int32
the numeric value

shift
Type:   Online System Int32
how many bits to strip from the right

buffer
Type:    Online System Char
that will contain the encoded chars, must be at least of BUF_SIZE_INT
            length

Return Value
 number of chars written to buffer

See Also
NumericUtils Class
NumericUtils Members
IntToPrefixCoded Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LongToPrefixCoded Method

NumericUtils LongToPrefixCoded Method Lucene.Net Class Library
Overload List
Name | Description
LongToPrefixCoded(Int64) | This is a convenience method, that returns prefix coded bits of a long without reducing the precision. It can be used to store the full precision value as a stored field in index. To decode, use PrefixCodedToLong(String).
LongToPrefixCoded(Int64, Int32) | Expert: Returns prefix coded bits after reducing the precision by shift bits. This is method is used by NumericUtils LongRangeBuilder.
LongToPrefixCoded(Int64, Int32, Char ) | Expert: Returns prefix coded bits after reducing the precision by shift bits. This is method is used by NumericTokenStream.
Back to Top
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LongToPrefixCoded Method (Int64)

NumericUtils LongToPrefixCoded Method (Int64) Lucene.Net Class Library
This is a convenience method, that returns prefix coded bits of a long without reducing the precision. It can be used to store the full precision value as a stored field in index.

To decode, use PrefixCodedToLong(String).

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string LongToPrefixCoded(
    long val
)
public static string LongToPrefixCoded(
    long val
)
Public Shared Function LongToPrefixCoded ( _
    val As Long _
) As String
Public Shared Function LongToPrefixCoded ( _
    val As Long _
) As String
public:
static String^ LongToPrefixCoded(
    long long val
)
public:
static String^ LongToPrefixCoded(
    long long val
)
Parameters
val
Type:   Online System Int64
See Also
NumericUtils Class
NumericUtils Members
LongToPrefixCoded Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LongToPrefixCoded Method (Int64, Int32)

NumericUtils LongToPrefixCoded Method (Int64, Int32) Lucene.Net Class Library
Expert: Returns prefix coded bits after reducing the precision by shift bits. This is method is used by NumericUtils LongRangeBuilder.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string LongToPrefixCoded(
    long val,
    int shift
)
public static string LongToPrefixCoded(
    long val,
    int shift
)
Public Shared Function LongToPrefixCoded ( _
    val As Long, _
    shift As Integer _
) As String
Public Shared Function LongToPrefixCoded ( _
    val As Long, _
    shift As Integer _
) As String
public:
static String^ LongToPrefixCoded(
    long long val,
    int shift
)
public:
static String^ LongToPrefixCoded(
    long long val,
    int shift
)
Parameters
val
Type:   Online System Int64
the numeric value

shift
Type:   Online System Int32
how many bits to strip from the right

See Also
NumericUtils Class
NumericUtils Members
LongToPrefixCoded Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LongToPrefixCoded Method (Int64, Int32, Char[])

NumericUtils LongToPrefixCoded Method (Int64, Int32, Char ) Lucene.Net Class Library
Expert: Returns prefix coded bits after reducing the precision by shift bits. This is method is used by NumericTokenStream.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int LongToPrefixCoded(
    long val,
    int shift,
    char[] buffer
)
public static int LongToPrefixCoded(
    long val,
    int shift,
    char[] buffer
)
Public Shared Function LongToPrefixCoded ( _
    val As Long, _
    shift As Integer, _
    buffer As Char() _
) As Integer
Public Shared Function LongToPrefixCoded ( _
    val As Long, _
    shift As Integer, _
    buffer As Char() _
) As Integer
public:
static int LongToPrefixCoded(
    long long val,
    int shift,
    array<wchar_t>^ buffer
)
public:
static int LongToPrefixCoded(
    long long val,
    int shift,
    array<wchar_t>^ buffer
)
Parameters
val
Type:   Online System Int64
the numeric value

shift
Type:   Online System Int32
how many bits to strip from the right

buffer
Type:    Online System Char
that will contain the encoded chars, must be at least of BUF_SIZE_LONG
            length

Return Value
 number of chars written to buffer

See Also
NumericUtils Class
NumericUtils Members
LongToPrefixCoded Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixCodedToDouble Method

NumericUtils PrefixCodedToDouble Method Lucene.Net Class Library
Convenience method: this just returns: sortableLongToDouble(prefixCodedToLong(val))

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double PrefixCodedToDouble(
    string val
)
public static double PrefixCodedToDouble(
    string val
)
Public Shared Function PrefixCodedToDouble ( _
    val As String _
) As Double
Public Shared Function PrefixCodedToDouble ( _
    val As String _
) As Double
public:
static double PrefixCodedToDouble(
    String^ val
)
public:
static double PrefixCodedToDouble(
    String^ val
)
Parameters
val
Type:   Online System String
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixCodedToFloat Method

NumericUtils PrefixCodedToFloat Method Lucene.Net Class Library
Convenience method: this just returns: sortableIntToFloat(prefixCodedToInt(val))

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static float PrefixCodedToFloat(
    string val
)
public static float PrefixCodedToFloat(
    string val
)
Public Shared Function PrefixCodedToFloat ( _
    val As String _
) As Single
Public Shared Function PrefixCodedToFloat ( _
    val As String _
) As Single
public:
static float PrefixCodedToFloat(
    String^ val
)
public:
static float PrefixCodedToFloat(
    String^ val
)
Parameters
val
Type:   Online System String
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixCodedToInt Method

NumericUtils PrefixCodedToInt Method Lucene.Net Class Library
Returns an int from prefixCoded characters. Rightmost bits will be zero for lower precision codes. This method can be used to decode e.g. a stored field.
not correctly prefix encoded.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int PrefixCodedToInt(
    string prefixCoded
)
public static int PrefixCodedToInt(
    string prefixCoded
)
Public Shared Function PrefixCodedToInt ( _
    prefixCoded As String _
) As Integer
Public Shared Function PrefixCodedToInt ( _
    prefixCoded As String _
) As Integer
public:
static int PrefixCodedToInt(
    String^ prefixCoded
)
public:
static int PrefixCodedToInt(
    String^ prefixCoded
)
Parameters
prefixCoded
Type:   Online System String
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace
NumericUtils IntToPrefixCoded(Int32)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PrefixCodedToLong Method

NumericUtils PrefixCodedToLong Method Lucene.Net Class Library
Returns a long from prefixCoded characters. Rightmost bits will be zero for lower precision codes. This method can be used to decode e.g. a stored field.
not correctly prefix encoded.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long PrefixCodedToLong(
    string prefixCoded
)
public static long PrefixCodedToLong(
    string prefixCoded
)
Public Shared Function PrefixCodedToLong ( _
    prefixCoded As String _
) As Long
Public Shared Function PrefixCodedToLong ( _
    prefixCoded As String _
) As Long
public:
static long long PrefixCodedToLong(
    String^ prefixCoded
)
public:
static long long PrefixCodedToLong(
    String^ prefixCoded
)
Parameters
prefixCoded
Type:   Online System String
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace
NumericUtils LongToPrefixCoded(Int64)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortableIntToFloat Method

NumericUtils SortableIntToFloat Method Lucene.Net Class Library
Converts a sortable int back to a float.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static float SortableIntToFloat(
    int val
)
public static float SortableIntToFloat(
    int val
)
Public Shared Function SortableIntToFloat ( _
    val As Integer _
) As Single
Public Shared Function SortableIntToFloat ( _
    val As Integer _
) As Single
public:
static float SortableIntToFloat(
    int val
)
public:
static float SortableIntToFloat(
    int val
)
Parameters
val
Type:   Online System Int32
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace
NumericUtils FloatToSortableInt(Single)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortableLongToDouble Method

NumericUtils SortableLongToDouble Method Lucene.Net Class Library
Converts a sortable long back to a double.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double SortableLongToDouble(
    long val
)
public static double SortableLongToDouble(
    long val
)
Public Shared Function SortableLongToDouble ( _
    val As Long _
) As Double
Public Shared Function SortableLongToDouble ( _
    val As Long _
) As Double
public:
static double SortableLongToDouble(
    long long val
)
public:
static double SortableLongToDouble(
    long long val
)
Parameters
val
Type:   Online System Int64
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace
NumericUtils DoubleToSortableLong(Double)
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SplitIntRange Method

NumericUtils SplitIntRange Method Lucene.Net Class Library
Expert: Splits an int range recursively. You may implement a builder that adds clauses to a BooleanQuery for each call to its AddRange(String, String) method.

This method is used by NumericRangeQuery T .

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void SplitIntRange(
    NumericUtils..::..IntRangeBuilder builder,
    int precisionStep,
    int minBound,
    int maxBound
)
public static void SplitIntRange(
    NumericUtils..::..IntRangeBuilder builder,
    int precisionStep,
    int minBound,
    int maxBound
)
Public Shared Sub SplitIntRange ( _
    builder As NumericUtils..::..IntRangeBuilder, _
    precisionStep As Integer, _
    minBound As Integer, _
    maxBound As Integer _
)
Public Shared Sub SplitIntRange ( _
    builder As NumericUtils..::..IntRangeBuilder, _
    precisionStep As Integer, _
    minBound As Integer, _
    maxBound As Integer _
)
public:
static void SplitIntRange(
    NumericUtils..::..IntRangeBuilder^ builder,
    int precisionStep,
    int minBound,
    int maxBound
)
public:
static void SplitIntRange(
    NumericUtils..::..IntRangeBuilder^ builder,
    int precisionStep,
    int minBound,
    int maxBound
)
Parameters
builder
Type: Lucene.Net.Util NumericUtils IntRangeBuilder
precisionStep
Type:   Online System Int32
minBound
Type:   Online System Int32
maxBound
Type:   Online System Int32
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SplitLongRange Method

NumericUtils SplitLongRange Method Lucene.Net Class Library
Expert: Splits a long range recursively. You may implement a builder that adds clauses to a BooleanQuery for each call to its AddRange(String, String) method.

This method is used by NumericRangeQuery T .

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void SplitLongRange(
    NumericUtils..::..LongRangeBuilder builder,
    int precisionStep,
    long minBound,
    long maxBound
)
public static void SplitLongRange(
    NumericUtils..::..LongRangeBuilder builder,
    int precisionStep,
    long minBound,
    long maxBound
)
Public Shared Sub SplitLongRange ( _
    builder As NumericUtils..::..LongRangeBuilder, _
    precisionStep As Integer, _
    minBound As Long, _
    maxBound As Long _
)
Public Shared Sub SplitLongRange ( _
    builder As NumericUtils..::..LongRangeBuilder, _
    precisionStep As Integer, _
    minBound As Long, _
    maxBound As Long _
)
public:
static void SplitLongRange(
    NumericUtils..::..LongRangeBuilder^ builder,
    int precisionStep,
    long long minBound,
    long long maxBound
)
public:
static void SplitLongRange(
    NumericUtils..::..LongRangeBuilder^ builder,
    int precisionStep,
    long long minBound,
    long long maxBound
)
Parameters
builder
Type: Lucene.Net.Util NumericUtils LongRangeBuilder
precisionStep
Type:   Online System Int32
minBound
Type:   Online System Int64
maxBound
Type:   Online System Int64
See Also
NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericUtils.IntRangeBuilder Class

NumericUtils IntRangeBuilder Class Lucene.Net Class Library
Expert: Callback for SplitIntRange(NumericUtils IntRangeBuilder, Int32, Int32, Int32). You need to overwrite only one of the methods.

NOTE: This is a very low-level interface, the method signatures may change in later versions.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util NumericUtils IntRangeBuilder

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class IntRangeBuilder
public abstract class IntRangeBuilder
Public MustInherit Class IntRangeBuilder
Public MustInherit Class IntRangeBuilder
public ref class IntRangeBuilder abstract
public ref class IntRangeBuilder abstract
See Also
NumericUtils IntRangeBuilder Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericUtils.IntRangeBuilder Members

NumericUtils IntRangeBuilder Members Lucene.Net Class Library

This is a helper class to generate prefix-encoded representations for numerical values and supplies converters to represent float/double values as sortable integers/longs.

To quickly execute range queries in Apache Lucene, a range is divided recursively into multiple intervals for searching: The center of the range is searched only with the lowest possible precision in the trie, while the boundaries are matched more exactly. This reduces the number of terms dramatically.

This class generates terms to achive this: First the numerical integer values need to be converted to strings. For that integer values (32 bit or 64 bit) are made unsigned and the bits are converted to ASCII chars with each 7 bit. The resulting string is sortable like the original integer value. Each value is also prefixed (in the first char) by the shift value (number of bits removed) used during encoding.

To also index floating point numbers, this class supplies two methods to convert them to integer values by changing their bit layout: DoubleToSortableLong(Double), FloatToSortableInt(Single). You will have no precision loss by converting floating point numbers to integers and back (only that the integer form is not usable). Other data types like dates can easily converted to longs or ints (e.g. date to long: Online DateTime).

For easy usage, the trie algorithm is implemented for indexing inside NumericTokenStream that can index int, long, float, and double. For querying, NumericRangeQuery T and NumericRangeFilter T implement the query part for the same data types.

This class can also be used, to generate lexicographically sortable (according Online CompareTo(String)) representations of numeric data types for other usages (e.g. sorting).

NOTE: This API is experimental and might change in incompatible ways in the next release.

The NumericUtils IntRangeBuilder type exposes the following members.
Constructors
 | Name | Description
Protected method | NumericUtils IntRangeBuilder | Initializes a new instance of the NumericUtils IntRangeBuilder class
Back to Top
Methods
 | Name | Description
Public method | AddRange(String, String) | Overwrite this method, if you like to receive the already prefix encoded range bounds. You can directly build classical range (inclusive) queries from them.
Public method | AddRange(Int32, Int32, Int32) | Overwrite this method, if you like to receive the raw int range bounds. You can use this for e.g. debugging purposes (print out range bounds).
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NumericUtils IntRangeBuilder Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericUtils.IntRangeBuilder Constructor

NumericUtils IntRangeBuilder Constructor Lucene.Net Class Library
Initializes a new instance of the NumericUtils IntRangeBuilder class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IntRangeBuilder()
protected IntRangeBuilder()
Protected Sub New
Protected Sub New
protected:
IntRangeBuilder()
protected:
IntRangeBuilder()
See Also
NumericUtils IntRangeBuilder Class
NumericUtils IntRangeBuilder Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericUtils.IntRangeBuilder Methods

NumericUtils IntRangeBuilder Methods Lucene.Net Class Library
The NumericUtils IntRangeBuilder type exposes the following members.
Methods
 | Name | Description
Public method | AddRange(String, String) | Overwrite this method, if you like to receive the already prefix encoded range bounds. You can directly build classical range (inclusive) queries from them.
Public method | AddRange(Int32, Int32, Int32) | Overwrite this method, if you like to receive the raw int range bounds. You can use this for e.g. debugging purposes (print out range bounds).
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NumericUtils IntRangeBuilder Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddRange Method

NumericUtils IntRangeBuilder AddRange Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | AddRange(String, String) | Overwrite this method, if you like to receive the already prefix encoded range bounds. You can directly build classical range (inclusive) queries from them.
Public method | AddRange(Int32, Int32, Int32) | Overwrite this method, if you like to receive the raw int range bounds. You can use this for e.g. debugging purposes (print out range bounds).
Back to Top
See Also
NumericUtils IntRangeBuilder Class
NumericUtils IntRangeBuilder Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddRange Method (String, String)

NumericUtils IntRangeBuilder AddRange Method (String, String) Lucene.Net Class Library
Overwrite this method, if you like to receive the already prefix encoded range bounds. You can directly build classical range (inclusive) queries from them.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AddRange(
    string minPrefixCoded,
    string maxPrefixCoded
)
public virtual void AddRange(
    string minPrefixCoded,
    string maxPrefixCoded
)
Public Overridable Sub AddRange ( _
    minPrefixCoded As String, _
    maxPrefixCoded As String _
)
Public Overridable Sub AddRange ( _
    minPrefixCoded As String, _
    maxPrefixCoded As String _
)
public:
virtual void AddRange(
    String^ minPrefixCoded,
    String^ maxPrefixCoded
)
public:
virtual void AddRange(
    String^ minPrefixCoded,
    String^ maxPrefixCoded
)
Parameters
minPrefixCoded
Type:   Online System String
maxPrefixCoded
Type:   Online System String
See Also
NumericUtils IntRangeBuilder Class
NumericUtils IntRangeBuilder Members
AddRange Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddRange Method (Int32, Int32, Int32)

NumericUtils IntRangeBuilder AddRange Method (Int32, Int32, Int32) Lucene.Net Class Library
Overwrite this method, if you like to receive the raw int range bounds. You can use this for e.g. debugging purposes (print out range bounds).

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AddRange(
    int min,
    int max,
    int shift
)
public virtual void AddRange(
    int min,
    int max,
    int shift
)
Public Overridable Sub AddRange ( _
    min As Integer, _
    max As Integer, _
    shift As Integer _
)
Public Overridable Sub AddRange ( _
    min As Integer, _
    max As Integer, _
    shift As Integer _
)
public:
virtual void AddRange(
    int min,
    int max,
    int shift
)
public:
virtual void AddRange(
    int min,
    int max,
    int shift
)
Parameters
min
Type:   Online System Int32
max
Type:   Online System Int32
shift
Type:   Online System Int32
See Also
NumericUtils IntRangeBuilder Class
NumericUtils IntRangeBuilder Members
AddRange Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericUtils.LongRangeBuilder Class

NumericUtils LongRangeBuilder Class Lucene.Net Class Library
Expert: Callback for SplitLongRange(NumericUtils LongRangeBuilder, Int32, Int64, Int64). You need to overwrite only one of the methods.

NOTE: This is a very low-level interface, the method signatures may change in later versions.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util NumericUtils LongRangeBuilder

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class LongRangeBuilder
public abstract class LongRangeBuilder
Public MustInherit Class LongRangeBuilder
Public MustInherit Class LongRangeBuilder
public ref class LongRangeBuilder abstract
public ref class LongRangeBuilder abstract
See Also
NumericUtils LongRangeBuilder Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericUtils.LongRangeBuilder Members

NumericUtils LongRangeBuilder Members Lucene.Net Class Library

This is a helper class to generate prefix-encoded representations for numerical values and supplies converters to represent float/double values as sortable integers/longs.

To quickly execute range queries in Apache Lucene, a range is divided recursively into multiple intervals for searching: The center of the range is searched only with the lowest possible precision in the trie, while the boundaries are matched more exactly. This reduces the number of terms dramatically.

This class generates terms to achive this: First the numerical integer values need to be converted to strings. For that integer values (32 bit or 64 bit) are made unsigned and the bits are converted to ASCII chars with each 7 bit. The resulting string is sortable like the original integer value. Each value is also prefixed (in the first char) by the shift value (number of bits removed) used during encoding.

To also index floating point numbers, this class supplies two methods to convert them to integer values by changing their bit layout: DoubleToSortableLong(Double), FloatToSortableInt(Single). You will have no precision loss by converting floating point numbers to integers and back (only that the integer form is not usable). Other data types like dates can easily converted to longs or ints (e.g. date to long: Online DateTime).

For easy usage, the trie algorithm is implemented for indexing inside NumericTokenStream that can index int, long, float, and double. For querying, NumericRangeQuery T and NumericRangeFilter T implement the query part for the same data types.

This class can also be used, to generate lexicographically sortable (according Online CompareTo(String)) representations of numeric data types for other usages (e.g. sorting).

NOTE: This API is experimental and might change in incompatible ways in the next release.

The NumericUtils LongRangeBuilder type exposes the following members.
Constructors
 | Name | Description
Protected method | NumericUtils LongRangeBuilder | Initializes a new instance of the NumericUtils LongRangeBuilder class
Back to Top
Methods
 | Name | Description
Public method | AddRange(String, String) | Overwrite this method, if you like to receive the already prefix encoded range bounds. You can directly build classical (inclusive) range queries from them.
Public method | AddRange(Int64, Int64, Int32) | Overwrite this method, if you like to receive the raw long range bounds. You can use this for e.g. debugging purposes (print out range bounds).
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NumericUtils LongRangeBuilder Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericUtils.LongRangeBuilder Constructor

NumericUtils LongRangeBuilder Constructor Lucene.Net Class Library
Initializes a new instance of the NumericUtils LongRangeBuilder class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LongRangeBuilder()
protected LongRangeBuilder()
Protected Sub New
Protected Sub New
protected:
LongRangeBuilder()
protected:
LongRangeBuilder()
See Also
NumericUtils LongRangeBuilder Class
NumericUtils LongRangeBuilder Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumericUtils.LongRangeBuilder Methods

NumericUtils LongRangeBuilder Methods Lucene.Net Class Library
The NumericUtils LongRangeBuilder type exposes the following members.
Methods
 | Name | Description
Public method | AddRange(String, String) | Overwrite this method, if you like to receive the already prefix encoded range bounds. You can directly build classical (inclusive) range queries from them.
Public method | AddRange(Int64, Int64, Int32) | Overwrite this method, if you like to receive the raw long range bounds. You can use this for e.g. debugging purposes (print out range bounds).
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
NumericUtils LongRangeBuilder Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddRange Method

NumericUtils LongRangeBuilder AddRange Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | AddRange(String, String) | Overwrite this method, if you like to receive the already prefix encoded range bounds. You can directly build classical (inclusive) range queries from them.
Public method | AddRange(Int64, Int64, Int32) | Overwrite this method, if you like to receive the raw long range bounds. You can use this for e.g. debugging purposes (print out range bounds).
Back to Top
See Also
NumericUtils LongRangeBuilder Class
NumericUtils LongRangeBuilder Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddRange Method (String, String)

NumericUtils LongRangeBuilder AddRange Method (String, String) Lucene.Net Class Library
Overwrite this method, if you like to receive the already prefix encoded range bounds. You can directly build classical (inclusive) range queries from them.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AddRange(
    string minPrefixCoded,
    string maxPrefixCoded
)
public virtual void AddRange(
    string minPrefixCoded,
    string maxPrefixCoded
)
Public Overridable Sub AddRange ( _
    minPrefixCoded As String, _
    maxPrefixCoded As String _
)
Public Overridable Sub AddRange ( _
    minPrefixCoded As String, _
    maxPrefixCoded As String _
)
public:
virtual void AddRange(
    String^ minPrefixCoded,
    String^ maxPrefixCoded
)
public:
virtual void AddRange(
    String^ minPrefixCoded,
    String^ maxPrefixCoded
)
Parameters
minPrefixCoded
Type:   Online System String
maxPrefixCoded
Type:   Online System String
See Also
NumericUtils LongRangeBuilder Class
NumericUtils LongRangeBuilder Members
AddRange Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AddRange Method (Int64, Int64, Int32)

NumericUtils LongRangeBuilder AddRange Method (Int64, Int64, Int32) Lucene.Net Class Library
Overwrite this method, if you like to receive the raw long range bounds. You can use this for e.g. debugging purposes (print out range bounds).

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AddRange(
    long min,
    long max,
    int shift
)
public virtual void AddRange(
    long min,
    long max,
    int shift
)
Public Overridable Sub AddRange ( _
    min As Long, _
    max As Long, _
    shift As Integer _
)
Public Overridable Sub AddRange ( _
    min As Long, _
    max As Long, _
    shift As Integer _
)
public:
virtual void AddRange(
    long long min,
    long long max,
    int shift
)
public:
virtual void AddRange(
    long long min,
    long long max,
    int shift
)
Parameters
min
Type:   Online System Int64
max
Type:   Online System Int64
shift
Type:   Online System Int32
See Also
NumericUtils LongRangeBuilder Class
NumericUtils LongRangeBuilder Members
AddRange Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSet Class

OpenBitSet Class Lucene.Net Class Library
An "open" BitSet implementation that allows direct access to the array of words storing the bits.

Unlike java.util.bitset, the fact that bits are packed into an array of longs is part of the interface. This allows efficient implementation of other algorithms by someone other than the author. It also allows one to efficiently implement alternate serialization or interchange formats.

OpenBitSet is faster than java.util.BitSet in most operations and *much* faster at calculating cardinality of sets and results of set operations. It can also handle sets of larger cardinality (up to 64 * 2**32-1)

The goals of OpenBitSet are the fastest implementation possible, and maximum code reuse. Extra safety and encapsulation may always be built on top, but if that's built in, the cost can never be removed (and hence people re-implement their own version in order to get better performance). If you want a "safe", totally encapsulated (and slower and limited) BitSet class, use java.util.BitSet.

Performance Results

Test system: Pentium 4, Sun Java 1.5_06 -server -Xbatch -Xmx64M
BitSet size = 1,000,000
Results are java.util.BitSet time divided by OpenBitSet time.
 | cardinality | intersect_count | union | nextSetBit | get | iterator
50% full | 3.36 | 3.96 | 1.44 | 1.46 | 1.99 | 1.58
1% full | 3.31 | 3.90 |  | 1.04 |  | 0.99

Test system: AMD Opteron, 64 bit linux, Sun Java 1.5_06 -server -Xbatch -Xmx64M
BitSet size = 1,000,000
Results are java.util.BitSet time divided by OpenBitSet time.
 | cardinality | intersect_count | union | nextSetBit | get | iterator
50% full | 2.50 | 3.50 | 1.00 | 1.03 | 1.12 | 1.25
1% full | 2.51 | 3.49 |  | 1.00 |  | 1.02
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSet
Lucene.Net.Util OpenBitSet
Lucene.Net.Util OpenBitSetDISI

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class OpenBitSet : DocIdSet, ICloneable
[SerializableAttribute]
public class OpenBitSet : DocIdSet, ICloneable
<SerializableAttribute> _
Public Class OpenBitSet _
    Inherits DocIdSet _
    Implements ICloneable
<SerializableAttribute> _
Public Class OpenBitSet _
    Inherits DocIdSet _
    Implements ICloneable
[SerializableAttribute]
public ref class OpenBitSet : public DocIdSet,
    ICloneable
[SerializableAttribute]
public ref class OpenBitSet : public DocIdSet,
    ICloneable
See Also
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSet Members

OpenBitSet Members Lucene.Net Class Library

The OpenBitSet type exposes the following members.
Constructors
 | Name | Description
Public method | OpenBitSet | Initializes a new instance of the OpenBitSet class
Public method | OpenBitSet(Int64) | Constructs an OpenBitSet large enough to hold numBits.
Public method | OpenBitSet( Int64 , Int32) | Constructs an OpenBitSet from an existing long[]. The first 64 bits are in long[0], with bit index 0 at the least significant bit, and bit index 63 at the most significant. Given a bit index, the word containing it is long[index/64], and it is at bit number index%64 within that word. numWords are the number of elements in the array that contain set bits (non-zero longs). numWords should be <= bits.length, and any existing words in the array at position >= numWords should be zero.
Back to Top
Methods
 | Name | Description
Public method | And |
Public method | AndNot |
 | AndNotCount | Returns the popcount or cardinality of "a and not b" or "intersection(a, not(b))". Neither set is modified.
 | Bits2words | returns the number of 64 bit words it would take to hold numBits
Public method | Capacity | Returns the current capacity in bits (1 greater than the index of the last bit)
Public method | Cardinality |
Public method | Clear(Int64) | clears a bit, allowing access beyond the current set size without changing the size.
Public method | Clear(Int32, Int32) | Clears a range of bits. Clearing past the end does not change the size of the set.
Public method | Clear(Int64, Int64) | Clears a range of bits. Clearing past the end does not change the size of the set.
Public method | Clone |
Public method | EnsureCapacity | Ensure that the long[] is big enough to hold numBits, expanding it if necessary. getNumWords() is unchanged by this call.
Public method | EnsureCapacityWords | Expand the long[] with the size given as a number of words (64 bit longs). getNumWords() is unchanged by this call.
Public method | Equals | returns true if both sets have the same bits set (Overrides Online Object Equals(Object).)
Protected method | ExpandingWordNum |
Public method | FastClear(Int32) | clears a bit. The index should be less than the OpenBitSet size.
Public method | FastClear(Int64) | clears a bit. The index should be less than the OpenBitSet size.
Public method | FastFlip(Int32) | flips a bit. The index should be less than the OpenBitSet size.
Public method | FastFlip(Int64) | flips a bit. The index should be less than the OpenBitSet size.
Public method | FastGet(Int32) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size
Public method | FastGet(Int64) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size.
Public method | FastSet(Int32) | Sets the bit at the specified index. The index should be less than the OpenBitSet size.
Public method | FastSet(Int64) | Sets the bit at the specified index. The index should be less than the OpenBitSet size.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flip(Int64) | flips a bit, expanding the set size if necessary
Public method | Flip(Int64, Int64) | Flips a range of bits, expanding the set size if necessary
Public method | FlipAndGet(Int32) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size.
Public method | FlipAndGet(Int64) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size.
Public method | Get(Int32) | Returns true or false for the specified bit index.
Public method | Get(Int64) | Returns true or false for the specified bit index
Public method | GetAndSet(Int32) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size.
Public method | GetAndSet(Int64) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size.
Public method | GetBit | returns 1 if the bit is set, 0 if not. The index should be less than the OpenBitSet size
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Intersect | this = this AND other
 | IntersectionCount | Returns the popcount or cardinality of the intersection of the two sets. Neither set is modified.
Public method | Intersects | returns true if the sets have any elements in common
Public method | IsEmpty | Returns true if there are no set bits
Public method | Iterator | (Overrides DocIdSet Iterator .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextSetBit(Int32) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits.
Public method | NextSetBit(Int64) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits.
Public method | Or |
Public method | Remove | Remove all elements set in other. this = this AND_NOT other
Public method | Set(Int64) | sets a bit, expanding the set size if necessary
Public method | Set(Int64, Int64) | Sets a range of bits, expanding the set size if necessary
Public method | Size | Returns the current capacity of this set. Included for compatibility. This is *not* equal to Cardinality
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | TrimTrailingZeros | Lowers numWords, the number of words in use, by checking for trailing zero words.
Public method | Union | this = this OR other
 | UnionCount | Returns the popcount or cardinality of the union of the two sets. Neither set is modified.
Public method | Xor | this = this XOR other
 | XorCount | Returns the popcount or cardinality of the exclusive-or of the two sets. Neither set is modified.
Back to Top
Fields
 | Name | Description
Protected field | internalbits |
Protected field | wlen |
Back to Top
Properties
 | Name | Description
Public property | Bits | Expert: Gets or sets the long[] storing the bits
Public property | IsCacheable | This DocIdSet implementation is cacheable. (Overrides DocIdSet IsCacheable.)
Public property | NumWords | Expert: gets or sets the number of longs in the array that are in use
Back to Top
See Also
OpenBitSet Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSet Constructor

OpenBitSet Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | OpenBitSet | Initializes a new instance of the OpenBitSet class
Public method | OpenBitSet(Int64) | Constructs an OpenBitSet large enough to hold numBits.
Public method | OpenBitSet( Int64 , Int32) | Constructs an OpenBitSet from an existing long[]. The first 64 bits are in long[0], with bit index 0 at the least significant bit, and bit index 63 at the most significant. Given a bit index, the word containing it is long[index/64], and it is at bit number index%64 within that word. numWords are the number of elements in the array that contain set bits (non-zero longs). numWords should be <= bits.length, and any existing words in the array at position >= numWords should be zero.
Back to Top
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSet Constructor

OpenBitSet Constructor Lucene.Net Class Library
Initializes a new instance of the OpenBitSet class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OpenBitSet()
public OpenBitSet()
Public Sub New
Public Sub New
public:
OpenBitSet()
public:
OpenBitSet()
See Also
OpenBitSet Class
OpenBitSet Members
OpenBitSet Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSet Constructor (Int64)

OpenBitSet Constructor (Int64) Lucene.Net Class Library
Constructs an OpenBitSet large enough to hold numBits.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OpenBitSet(
    long numBits
)
public OpenBitSet(
    long numBits
)
Public Sub New ( _
    numBits As Long _
)
Public Sub New ( _
    numBits As Long _
)
public:
OpenBitSet(
    long long numBits
)
public:
OpenBitSet(
    long long numBits
)
Parameters
numBits
Type:   Online System Int64
See Also
OpenBitSet Class
OpenBitSet Members
OpenBitSet Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSet Constructor (Int64[], Int32)

OpenBitSet Constructor ( Int64 , Int32) Lucene.Net Class Library
Constructs an OpenBitSet from an existing long[].
The first 64 bits are in long[0], with bit index 0 at the least significant bit, and bit index 63 at the most significant. Given a bit index, the word containing it is long[index/64], and it is at bit number index%64 within that word.

numWords are the number of elements in the array that contain set bits (non-zero longs). numWords should be <= bits.length, and any existing words in the array at position >= numWords should be zero.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OpenBitSet(
    long[] bits,
    int numWords
)
public OpenBitSet(
    long[] bits,
    int numWords
)
Public Sub New ( _
    bits As Long(), _
    numWords As Integer _
)
Public Sub New ( _
    bits As Long(), _
    numWords As Integer _
)
public:
OpenBitSet(
    array<long long>^ bits,
    int numWords
)
public:
OpenBitSet(
    array<long long>^ bits,
    int numWords
)
Parameters
bits
Type:    Online System Int64
numWords
Type:   Online System Int32
See Also
OpenBitSet Class
OpenBitSet Members
OpenBitSet Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSet Fields

OpenBitSet Fields Lucene.Net Class Library
The OpenBitSet type exposes the following members.
Fields
 | Name | Description
Protected field | internalbits |
Protected field | wlen |
Back to Top
See Also
OpenBitSet Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


internalbits Field

OpenBitSet internalbits Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected long[] internalbits
protected long[] internalbits
Protected internalbits As Long()
Protected internalbits As Long()
protected:
array<long long>^ internalbits
protected:
array<long long>^ internalbits
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


wlen Field

OpenBitSet wlen Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int wlen
protected int wlen
Protected wlen As Integer
Protected wlen As Integer
protected:
int wlen
protected:
int wlen
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSet Methods

OpenBitSet Methods Lucene.Net Class Library
The OpenBitSet type exposes the following members.
Methods
 | Name | Description
Public method | And |
Public method | AndNot |
 | AndNotCount | Returns the popcount or cardinality of "a and not b" or "intersection(a, not(b))". Neither set is modified.
 | Bits2words | returns the number of 64 bit words it would take to hold numBits
Public method | Capacity | Returns the current capacity in bits (1 greater than the index of the last bit)
Public method | Cardinality |
Public method | Clear(Int64) | clears a bit, allowing access beyond the current set size without changing the size.
Public method | Clear(Int32, Int32) | Clears a range of bits. Clearing past the end does not change the size of the set.
Public method | Clear(Int64, Int64) | Clears a range of bits. Clearing past the end does not change the size of the set.
Public method | Clone |
Public method | EnsureCapacity | Ensure that the long[] is big enough to hold numBits, expanding it if necessary. getNumWords() is unchanged by this call.
Public method | EnsureCapacityWords | Expand the long[] with the size given as a number of words (64 bit longs). getNumWords() is unchanged by this call.
Public method | Equals | returns true if both sets have the same bits set (Overrides Online Object Equals(Object).)
Protected method | ExpandingWordNum |
Public method | FastClear(Int32) | clears a bit. The index should be less than the OpenBitSet size.
Public method | FastClear(Int64) | clears a bit. The index should be less than the OpenBitSet size.
Public method | FastFlip(Int32) | flips a bit. The index should be less than the OpenBitSet size.
Public method | FastFlip(Int64) | flips a bit. The index should be less than the OpenBitSet size.
Public method | FastGet(Int32) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size
Public method | FastGet(Int64) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size.
Public method | FastSet(Int32) | Sets the bit at the specified index. The index should be less than the OpenBitSet size.
Public method | FastSet(Int64) | Sets the bit at the specified index. The index should be less than the OpenBitSet size.
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flip(Int64) | flips a bit, expanding the set size if necessary
Public method | Flip(Int64, Int64) | Flips a range of bits, expanding the set size if necessary
Public method | FlipAndGet(Int32) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size.
Public method | FlipAndGet(Int64) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size.
Public method | Get(Int32) | Returns true or false for the specified bit index.
Public method | Get(Int64) | Returns true or false for the specified bit index
Public method | GetAndSet(Int32) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size.
Public method | GetAndSet(Int64) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size.
Public method | GetBit | returns 1 if the bit is set, 0 if not. The index should be less than the OpenBitSet size
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Intersect | this = this AND other
 | IntersectionCount | Returns the popcount or cardinality of the intersection of the two sets. Neither set is modified.
Public method | Intersects | returns true if the sets have any elements in common
Public method | IsEmpty | Returns true if there are no set bits
Public method | Iterator | (Overrides DocIdSet Iterator .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextSetBit(Int32) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits.
Public method | NextSetBit(Int64) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits.
Public method | Or |
Public method | Remove | Remove all elements set in other. this = this AND_NOT other
Public method | Set(Int64) | sets a bit, expanding the set size if necessary
Public method | Set(Int64, Int64) | Sets a range of bits, expanding the set size if necessary
Public method | Size | Returns the current capacity of this set. Included for compatibility. This is *not* equal to Cardinality
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | TrimTrailingZeros | Lowers numWords, the number of words in use, by checking for trailing zero words.
Public method | Union | this = this OR other
 | UnionCount | Returns the popcount or cardinality of the union of the two sets. Neither set is modified.
Public method | Xor | this = this XOR other
 | XorCount | Returns the popcount or cardinality of the exclusive-or of the two sets. Neither set is modified.
Back to Top
See Also
OpenBitSet Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


And Method

OpenBitSet And Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void And(
    OpenBitSet other
)
public virtual void And(
    OpenBitSet other
)
Public Overridable Sub And ( _
    other As OpenBitSet _
)
Public Overridable Sub And ( _
    other As OpenBitSet _
)
public:
virtual void And(
    OpenBitSet^ other
)
public:
virtual void And(
    OpenBitSet^ other
)
Parameters
other
Type: Lucene.Net.Util OpenBitSet
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AndNot Method

OpenBitSet AndNot Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AndNot(
    OpenBitSet other
)
public virtual void AndNot(
    OpenBitSet other
)
Public Overridable Sub AndNot ( _
    other As OpenBitSet _
)
Public Overridable Sub AndNot ( _
    other As OpenBitSet _
)
public:
virtual void AndNot(
    OpenBitSet^ other
)
public:
virtual void AndNot(
    OpenBitSet^ other
)
Parameters
other
Type: Lucene.Net.Util OpenBitSet
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AndNotCount Method

OpenBitSet AndNotCount Method Lucene.Net Class Library
Returns the popcount or cardinality of "a and not b" or "intersection(a, not(b))". Neither set is modified.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long AndNotCount(
    OpenBitSet a,
    OpenBitSet b
)
public static long AndNotCount(
    OpenBitSet a,
    OpenBitSet b
)
Public Shared Function AndNotCount ( _
    a As OpenBitSet, _
    b As OpenBitSet _
) As Long
Public Shared Function AndNotCount ( _
    a As OpenBitSet, _
    b As OpenBitSet _
) As Long
public:
static long long AndNotCount(
    OpenBitSet^ a,
    OpenBitSet^ b
)
public:
static long long AndNotCount(
    OpenBitSet^ a,
    OpenBitSet^ b
)
Parameters
a
Type: Lucene.Net.Util OpenBitSet
b
Type: Lucene.Net.Util OpenBitSet
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Bits2words Method

OpenBitSet Bits2words Method Lucene.Net Class Library
returns the number of 64 bit words it would take to hold numBits

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Bits2words(
    long numBits
)
public static int Bits2words(
    long numBits
)
Public Shared Function Bits2words ( _
    numBits As Long _
) As Integer
Public Shared Function Bits2words ( _
    numBits As Long _
) As Integer
public:
static int Bits2words(
    long long numBits
)
public:
static int Bits2words(
    long long numBits
)
Parameters
numBits
Type:   Online System Int64
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Capacity Method

OpenBitSet Capacity Method Lucene.Net Class Library
Returns the current capacity in bits (1 greater than the index of the last bit)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long Capacity()
public virtual long Capacity()
Public Overridable Function Capacity As Long
Public Overridable Function Capacity As Long
public:
virtual long long Capacity()
public:
virtual long long Capacity()
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Cardinality Method

OpenBitSet Cardinality Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long Cardinality()
public virtual long Cardinality()
Public Overridable Function Cardinality As Long
Public Overridable Function Cardinality As Long
public:
virtual long long Cardinality()
public:
virtual long long Cardinality()
Return Value
 the number of set bits

See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method

OpenBitSet Clear Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Clear(Int64) | clears a bit, allowing access beyond the current set size without changing the size.
Public method | Clear(Int32, Int32) | Clears a range of bits. Clearing past the end does not change the size of the set.
Public method | Clear(Int64, Int64) | Clears a range of bits. Clearing past the end does not change the size of the set.
Back to Top
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method (Int64)

OpenBitSet Clear Method (Int64) Lucene.Net Class Library
clears a bit, allowing access beyond the current set size without changing the size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Clear(
    long index
)
public virtual void Clear(
    long index
)
Public Overridable Sub Clear ( _
    index As Long _
)
Public Overridable Sub Clear ( _
    index As Long _
)
public:
virtual void Clear(
    long long index
)
public:
virtual void Clear(
    long long index
)
Parameters
index
Type:   Online System Int64
See Also
OpenBitSet Class
OpenBitSet Members
Clear Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method (Int32, Int32)

OpenBitSet Clear Method (Int32, Int32) Lucene.Net Class Library
Clears a range of bits. Clearing past the end does not change the size of the set.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Clear(
    int startIndex,
    int endIndex
)
public virtual void Clear(
    int startIndex,
    int endIndex
)
Public Overridable Sub Clear ( _
    startIndex As Integer, _
    endIndex As Integer _
)
Public Overridable Sub Clear ( _
    startIndex As Integer, _
    endIndex As Integer _
)
public:
virtual void Clear(
    int startIndex,
    int endIndex
)
public:
virtual void Clear(
    int startIndex,
    int endIndex
)
Parameters
startIndex
Type:   Online System Int32
lower index

endIndex
Type:   Online System Int32
one-past the last bit to clear

See Also
OpenBitSet Class
OpenBitSet Members
Clear Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method (Int64, Int64)

OpenBitSet Clear Method (Int64, Int64) Lucene.Net Class Library
Clears a range of bits. Clearing past the end does not change the size of the set.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Clear(
    long startIndex,
    long endIndex
)
public virtual void Clear(
    long startIndex,
    long endIndex
)
Public Overridable Sub Clear ( _
    startIndex As Long, _
    endIndex As Long _
)
Public Overridable Sub Clear ( _
    startIndex As Long, _
    endIndex As Long _
)
public:
virtual void Clear(
    long long startIndex,
    long long endIndex
)
public:
virtual void Clear(
    long long startIndex,
    long long endIndex
)
Parameters
startIndex
Type:   Online System Int64
lower index

endIndex
Type:   Online System Int64
one-past the last bit to clear

See Also
OpenBitSet Class
OpenBitSet Members
Clear Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clone Method

OpenBitSet Clone Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object Clone()
public virtual Object Clone()
Public Overridable Function Clone As Object
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
public:
virtual Object^ Clone()
Implements
  Online ICloneable Clone
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EnsureCapacity Method

OpenBitSet EnsureCapacity Method Lucene.Net Class Library
Ensure that the long[] is big enough to hold numBits, expanding it if necessary. getNumWords() is unchanged by this call.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void EnsureCapacity(
    long numBits
)
public virtual void EnsureCapacity(
    long numBits
)
Public Overridable Sub EnsureCapacity ( _
    numBits As Long _
)
Public Overridable Sub EnsureCapacity ( _
    numBits As Long _
)
public:
virtual void EnsureCapacity(
    long long numBits
)
public:
virtual void EnsureCapacity(
    long long numBits
)
Parameters
numBits
Type:   Online System Int64
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EnsureCapacityWords Method

OpenBitSet EnsureCapacityWords Method Lucene.Net Class Library
Expand the long[] with the size given as a number of words (64 bit longs). getNumWords() is unchanged by this call.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void EnsureCapacityWords(
    int numWords
)
public virtual void EnsureCapacityWords(
    int numWords
)
Public Overridable Sub EnsureCapacityWords ( _
    numWords As Integer _
)
Public Overridable Sub EnsureCapacityWords ( _
    numWords As Integer _
)
public:
virtual void EnsureCapacityWords(
    int numWords
)
public:
virtual void EnsureCapacityWords(
    int numWords
)
Parameters
numWords
Type:   Online System Int32
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Equals Method

OpenBitSet Equals Method Lucene.Net Class Library
returns true if both sets have the same bits set

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
Parameters
o
Type:   Online System Object
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ExpandingWordNum Method

OpenBitSet ExpandingWordNum Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual int ExpandingWordNum(
    long index
)
protected virtual int ExpandingWordNum(
    long index
)
Protected Overridable Function ExpandingWordNum ( _
    index As Long _
) As Integer
Protected Overridable Function ExpandingWordNum ( _
    index As Long _
) As Integer
protected:
virtual int ExpandingWordNum(
    long long index
)
protected:
virtual int ExpandingWordNum(
    long long index
)
Parameters
index
Type:   Online System Int64
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FastClear Method

OpenBitSet FastClear Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | FastClear(Int32) | clears a bit. The index should be less than the OpenBitSet size.
Public method | FastClear(Int64) | clears a bit. The index should be less than the OpenBitSet size.
Back to Top
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FastClear Method (Int32)

OpenBitSet FastClear Method (Int32) Lucene.Net Class Library
clears a bit. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void FastClear(
    int index
)
public virtual void FastClear(
    int index
)
Public Overridable Sub FastClear ( _
    index As Integer _
)
Public Overridable Sub FastClear ( _
    index As Integer _
)
public:
virtual void FastClear(
    int index
)
public:
virtual void FastClear(
    int index
)
Parameters
index
Type:   Online System Int32
See Also
OpenBitSet Class
OpenBitSet Members
FastClear Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FastClear Method (Int64)

OpenBitSet FastClear Method (Int64) Lucene.Net Class Library
clears a bit. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void FastClear(
    long index
)
public virtual void FastClear(
    long index
)
Public Overridable Sub FastClear ( _
    index As Long _
)
Public Overridable Sub FastClear ( _
    index As Long _
)
public:
virtual void FastClear(
    long long index
)
public:
virtual void FastClear(
    long long index
)
Parameters
index
Type:   Online System Int64
See Also
OpenBitSet Class
OpenBitSet Members
FastClear Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FastFlip Method

OpenBitSet FastFlip Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | FastFlip(Int32) | flips a bit. The index should be less than the OpenBitSet size.
Public method | FastFlip(Int64) | flips a bit. The index should be less than the OpenBitSet size.
Back to Top
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FastFlip Method (Int32)

OpenBitSet FastFlip Method (Int32) Lucene.Net Class Library
flips a bit. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void FastFlip(
    int index
)
public virtual void FastFlip(
    int index
)
Public Overridable Sub FastFlip ( _
    index As Integer _
)
Public Overridable Sub FastFlip ( _
    index As Integer _
)
public:
virtual void FastFlip(
    int index
)
public:
virtual void FastFlip(
    int index
)
Parameters
index
Type:   Online System Int32
See Also
OpenBitSet Class
OpenBitSet Members
FastFlip Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FastFlip Method (Int64)

OpenBitSet FastFlip Method (Int64) Lucene.Net Class Library
flips a bit. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void FastFlip(
    long index
)
public virtual void FastFlip(
    long index
)
Public Overridable Sub FastFlip ( _
    index As Long _
)
Public Overridable Sub FastFlip ( _
    index As Long _
)
public:
virtual void FastFlip(
    long long index
)
public:
virtual void FastFlip(
    long long index
)
Parameters
index
Type:   Online System Int64
See Also
OpenBitSet Class
OpenBitSet Members
FastFlip Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FastGet Method

OpenBitSet FastGet Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | FastGet(Int32) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size
Public method | FastGet(Int64) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size.
Back to Top
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FastGet Method (Int32)

OpenBitSet FastGet Method (Int32) Lucene.Net Class Library
Returns true or false for the specified bit index. The index should be less than the OpenBitSet size

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool FastGet(
    int index
)
public virtual bool FastGet(
    int index
)
Public Overridable Function FastGet ( _
    index As Integer _
) As Boolean
Public Overridable Function FastGet ( _
    index As Integer _
) As Boolean
public:
virtual bool FastGet(
    int index
)
public:
virtual bool FastGet(
    int index
)
Parameters
index
Type:   Online System Int32
See Also
OpenBitSet Class
OpenBitSet Members
FastGet Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FastGet Method (Int64)

OpenBitSet FastGet Method (Int64) Lucene.Net Class Library
Returns true or false for the specified bit index. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool FastGet(
    long index
)
public virtual bool FastGet(
    long index
)
Public Overridable Function FastGet ( _
    index As Long _
) As Boolean
Public Overridable Function FastGet ( _
    index As Long _
) As Boolean
public:
virtual bool FastGet(
    long long index
)
public:
virtual bool FastGet(
    long long index
)
Parameters
index
Type:   Online System Int64
See Also
OpenBitSet Class
OpenBitSet Members
FastGet Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FastSet Method

OpenBitSet FastSet Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | FastSet(Int32) | Sets the bit at the specified index. The index should be less than the OpenBitSet size.
Public method | FastSet(Int64) | Sets the bit at the specified index. The index should be less than the OpenBitSet size.
Back to Top
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FastSet Method (Int32)

OpenBitSet FastSet Method (Int32) Lucene.Net Class Library
Sets the bit at the specified index. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void FastSet(
    int index
)
public virtual void FastSet(
    int index
)
Public Overridable Sub FastSet ( _
    index As Integer _
)
Public Overridable Sub FastSet ( _
    index As Integer _
)
public:
virtual void FastSet(
    int index
)
public:
virtual void FastSet(
    int index
)
Parameters
index
Type:   Online System Int32
See Also
OpenBitSet Class
OpenBitSet Members
FastSet Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FastSet Method (Int64)

OpenBitSet FastSet Method (Int64) Lucene.Net Class Library
Sets the bit at the specified index. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void FastSet(
    long index
)
public virtual void FastSet(
    long index
)
Public Overridable Sub FastSet ( _
    index As Long _
)
Public Overridable Sub FastSet ( _
    index As Long _
)
public:
virtual void FastSet(
    long long index
)
public:
virtual void FastSet(
    long long index
)
Parameters
index
Type:   Online System Int64
See Also
OpenBitSet Class
OpenBitSet Members
FastSet Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Flip Method

OpenBitSet Flip Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Flip(Int64) | flips a bit, expanding the set size if necessary
Public method | Flip(Int64, Int64) | Flips a range of bits, expanding the set size if necessary
Back to Top
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Flip Method (Int64)

OpenBitSet Flip Method (Int64) Lucene.Net Class Library
flips a bit, expanding the set size if necessary

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Flip(
    long index
)
public virtual void Flip(
    long index
)
Public Overridable Sub Flip ( _
    index As Long _
)
Public Overridable Sub Flip ( _
    index As Long _
)
public:
virtual void Flip(
    long long index
)
public:
virtual void Flip(
    long long index
)
Parameters
index
Type:   Online System Int64
See Also
OpenBitSet Class
OpenBitSet Members
Flip Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Flip Method (Int64, Int64)

OpenBitSet Flip Method (Int64, Int64) Lucene.Net Class Library
Flips a range of bits, expanding the set size if necessary

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Flip(
    long startIndex,
    long endIndex
)
public virtual void Flip(
    long startIndex,
    long endIndex
)
Public Overridable Sub Flip ( _
    startIndex As Long, _
    endIndex As Long _
)
Public Overridable Sub Flip ( _
    startIndex As Long, _
    endIndex As Long _
)
public:
virtual void Flip(
    long long startIndex,
    long long endIndex
)
public:
virtual void Flip(
    long long startIndex,
    long long endIndex
)
Parameters
startIndex
Type:   Online System Int64
lower index

endIndex
Type:   Online System Int64
one-past the last bit to flip

See Also
OpenBitSet Class
OpenBitSet Members
Flip Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FlipAndGet Method

OpenBitSet FlipAndGet Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | FlipAndGet(Int32) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size.
Public method | FlipAndGet(Int64) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size.
Back to Top
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FlipAndGet Method (Int32)

OpenBitSet FlipAndGet Method (Int32) Lucene.Net Class Library
flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool FlipAndGet(
    int index
)
public virtual bool FlipAndGet(
    int index
)
Public Overridable Function FlipAndGet ( _
    index As Integer _
) As Boolean
Public Overridable Function FlipAndGet ( _
    index As Integer _
) As Boolean
public:
virtual bool FlipAndGet(
    int index
)
public:
virtual bool FlipAndGet(
    int index
)
Parameters
index
Type:   Online System Int32
See Also
OpenBitSet Class
OpenBitSet Members
FlipAndGet Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FlipAndGet Method (Int64)

OpenBitSet FlipAndGet Method (Int64) Lucene.Net Class Library
flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool FlipAndGet(
    long index
)
public virtual bool FlipAndGet(
    long index
)
Public Overridable Function FlipAndGet ( _
    index As Long _
) As Boolean
Public Overridable Function FlipAndGet ( _
    index As Long _
) As Boolean
public:
virtual bool FlipAndGet(
    long long index
)
public:
virtual bool FlipAndGet(
    long long index
)
Parameters
index
Type:   Online System Int64
See Also
OpenBitSet Class
OpenBitSet Members
FlipAndGet Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method

OpenBitSet Get Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Get(Int32) | Returns true or false for the specified bit index.
Public method | Get(Int64) | Returns true or false for the specified bit index
Back to Top
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method (Int32)

OpenBitSet Get Method (Int32) Lucene.Net Class Library
Returns true or false for the specified bit index.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Get(
    int index
)
public virtual bool Get(
    int index
)
Public Overridable Function Get ( _
    index As Integer _
) As Boolean
Public Overridable Function Get ( _
    index As Integer _
) As Boolean
public:
virtual bool Get(
    int index
)
public:
virtual bool Get(
    int index
)
Parameters
index
Type:   Online System Int32
See Also
OpenBitSet Class
OpenBitSet Members
Get Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method (Int64)

OpenBitSet Get Method (Int64) Lucene.Net Class Library
Returns true or false for the specified bit index

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Get(
    long index
)
public virtual bool Get(
    long index
)
Public Overridable Function Get ( _
    index As Long _
) As Boolean
Public Overridable Function Get ( _
    index As Long _
) As Boolean
public:
virtual bool Get(
    long long index
)
public:
virtual bool Get(
    long long index
)
Parameters
index
Type:   Online System Int64
See Also
OpenBitSet Class
OpenBitSet Members
Get Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetAndSet Method

OpenBitSet GetAndSet Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | GetAndSet(Int32) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size.
Public method | GetAndSet(Int64) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size.
Back to Top
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetAndSet Method (Int32)

OpenBitSet GetAndSet Method (Int32) Lucene.Net Class Library
Sets a bit and returns the previous value. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool GetAndSet(
    int index
)
public virtual bool GetAndSet(
    int index
)
Public Overridable Function GetAndSet ( _
    index As Integer _
) As Boolean
Public Overridable Function GetAndSet ( _
    index As Integer _
) As Boolean
public:
virtual bool GetAndSet(
    int index
)
public:
virtual bool GetAndSet(
    int index
)
Parameters
index
Type:   Online System Int32
See Also
OpenBitSet Class
OpenBitSet Members
GetAndSet Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetAndSet Method (Int64)

OpenBitSet GetAndSet Method (Int64) Lucene.Net Class Library
Sets a bit and returns the previous value. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool GetAndSet(
    long index
)
public virtual bool GetAndSet(
    long index
)
Public Overridable Function GetAndSet ( _
    index As Long _
) As Boolean
Public Overridable Function GetAndSet ( _
    index As Long _
) As Boolean
public:
virtual bool GetAndSet(
    long long index
)
public:
virtual bool GetAndSet(
    long long index
)
Parameters
index
Type:   Online System Int64
See Also
OpenBitSet Class
OpenBitSet Members
GetAndSet Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetBit Method

OpenBitSet GetBit Method Lucene.Net Class Library
returns 1 if the bit is set, 0 if not. The index should be less than the OpenBitSet size

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int GetBit(
    int index
)
public virtual int GetBit(
    int index
)
Public Overridable Function GetBit ( _
    index As Integer _
) As Integer
Public Overridable Function GetBit ( _
    index As Integer _
) As Integer
public:
virtual int GetBit(
    int index
)
public:
virtual int GetBit(
    int index
)
Parameters
index
Type:   Online System Int32
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GetHashCode Method

OpenBitSet GetHashCode Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Intersect Method

OpenBitSet Intersect Method Lucene.Net Class Library
this = this AND other

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Intersect(
    OpenBitSet other
)
public virtual void Intersect(
    OpenBitSet other
)
Public Overridable Sub Intersect ( _
    other As OpenBitSet _
)
Public Overridable Sub Intersect ( _
    other As OpenBitSet _
)
public:
virtual void Intersect(
    OpenBitSet^ other
)
public:
virtual void Intersect(
    OpenBitSet^ other
)
Parameters
other
Type: Lucene.Net.Util OpenBitSet
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IntersectionCount Method

OpenBitSet IntersectionCount Method Lucene.Net Class Library
Returns the popcount or cardinality of the intersection of the two sets. Neither set is modified.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long IntersectionCount(
    OpenBitSet a,
    OpenBitSet b
)
public static long IntersectionCount(
    OpenBitSet a,
    OpenBitSet b
)
Public Shared Function IntersectionCount ( _
    a As OpenBitSet, _
    b As OpenBitSet _
) As Long
Public Shared Function IntersectionCount ( _
    a As OpenBitSet, _
    b As OpenBitSet _
) As Long
public:
static long long IntersectionCount(
    OpenBitSet^ a,
    OpenBitSet^ b
)
public:
static long long IntersectionCount(
    OpenBitSet^ a,
    OpenBitSet^ b
)
Parameters
a
Type: Lucene.Net.Util OpenBitSet
b
Type: Lucene.Net.Util OpenBitSet
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Intersects Method

OpenBitSet Intersects Method Lucene.Net Class Library
returns true if the sets have any elements in common

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Intersects(
    OpenBitSet other
)
public virtual bool Intersects(
    OpenBitSet other
)
Public Overridable Function Intersects ( _
    other As OpenBitSet _
) As Boolean
Public Overridable Function Intersects ( _
    other As OpenBitSet _
) As Boolean
public:
virtual bool Intersects(
    OpenBitSet^ other
)
public:
virtual bool Intersects(
    OpenBitSet^ other
)
Parameters
other
Type: Lucene.Net.Util OpenBitSet
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsEmpty Method

OpenBitSet IsEmpty Method Lucene.Net Class Library
Returns true if there are no set bits

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsEmpty()
public virtual bool IsEmpty()
Public Overridable Function IsEmpty As Boolean
Public Overridable Function IsEmpty As Boolean
public:
virtual bool IsEmpty()
public:
virtual bool IsEmpty()
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Iterator Method

OpenBitSet Iterator Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocIdSetIterator Iterator()
public override DocIdSetIterator Iterator()
Public Overrides Function Iterator As DocIdSetIterator
Public Overrides Function Iterator As DocIdSetIterator
public:
virtual DocIdSetIterator^ Iterator() override
public:
virtual DocIdSetIterator^ Iterator() override
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextSetBit Method

OpenBitSet NextSetBit Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | NextSetBit(Int32) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits.
Public method | NextSetBit(Int64) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits.
Back to Top
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextSetBit Method (Int32)

OpenBitSet NextSetBit Method (Int32) Lucene.Net Class Library
Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int NextSetBit(
    int index
)
public virtual int NextSetBit(
    int index
)
Public Overridable Function NextSetBit ( _
    index As Integer _
) As Integer
Public Overridable Function NextSetBit ( _
    index As Integer _
) As Integer
public:
virtual int NextSetBit(
    int index
)
public:
virtual int NextSetBit(
    int index
)
Parameters
index
Type:   Online System Int32
See Also
OpenBitSet Class
OpenBitSet Members
NextSetBit Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextSetBit Method (Int64)

OpenBitSet NextSetBit Method (Int64) Lucene.Net Class Library
Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long NextSetBit(
    long index
)
public virtual long NextSetBit(
    long index
)
Public Overridable Function NextSetBit ( _
    index As Long _
) As Long
Public Overridable Function NextSetBit ( _
    index As Long _
) As Long
public:
virtual long long NextSetBit(
    long long index
)
public:
virtual long long NextSetBit(
    long long index
)
Parameters
index
Type:   Online System Int64
See Also
OpenBitSet Class
OpenBitSet Members
NextSetBit Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Or Method

OpenBitSet Or Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Or(
    OpenBitSet other
)
public virtual void Or(
    OpenBitSet other
)
Public Overridable Sub Or ( _
    other As OpenBitSet _
)
Public Overridable Sub Or ( _
    other As OpenBitSet _
)
public:
virtual void Or(
    OpenBitSet^ other
)
public:
virtual void Or(
    OpenBitSet^ other
)
Parameters
other
Type: Lucene.Net.Util OpenBitSet
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Remove Method

OpenBitSet Remove Method Lucene.Net Class Library
Remove all elements set in other. this = this AND_NOT other

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Remove(
    OpenBitSet other
)
public virtual void Remove(
    OpenBitSet other
)
Public Overridable Sub Remove ( _
    other As OpenBitSet _
)
Public Overridable Sub Remove ( _
    other As OpenBitSet _
)
public:
virtual void Remove(
    OpenBitSet^ other
)
public:
virtual void Remove(
    OpenBitSet^ other
)
Parameters
other
Type: Lucene.Net.Util OpenBitSet
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Set Method

OpenBitSet Set Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Set(Int64) | sets a bit, expanding the set size if necessary
Public method | Set(Int64, Int64) | Sets a range of bits, expanding the set size if necessary
Back to Top
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Set Method (Int64)

OpenBitSet Set Method (Int64) Lucene.Net Class Library
sets a bit, expanding the set size if necessary

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Set(
    long index
)
public virtual void Set(
    long index
)
Public Overridable Sub Set ( _
    index As Long _
)
Public Overridable Sub Set ( _
    index As Long _
)
public:
virtual void Set(
    long long index
)
public:
virtual void Set(
    long long index
)
Parameters
index
Type:   Online System Int64
See Also
OpenBitSet Class
OpenBitSet Members
Set Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Set Method (Int64, Int64)

OpenBitSet Set Method (Int64, Int64) Lucene.Net Class Library
Sets a range of bits, expanding the set size if necessary

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Set(
    long startIndex,
    long endIndex
)
public virtual void Set(
    long startIndex,
    long endIndex
)
Public Overridable Sub Set ( _
    startIndex As Long, _
    endIndex As Long _
)
Public Overridable Sub Set ( _
    startIndex As Long, _
    endIndex As Long _
)
public:
virtual void Set(
    long long startIndex,
    long long endIndex
)
public:
virtual void Set(
    long long startIndex,
    long long endIndex
)
Parameters
startIndex
Type:   Online System Int64
lower index

endIndex
Type:   Online System Int64
one-past the last bit to set

See Also
OpenBitSet Class
OpenBitSet Members
Set Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Size Method

OpenBitSet Size Method Lucene.Net Class Library
Returns the current capacity of this set. Included for compatibility. This is *not* equal to Cardinality

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long Size()
public virtual long Size()
Public Overridable Function Size As Long
Public Overridable Function Size As Long
public:
virtual long long Size()
public:
virtual long long Size()
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TrimTrailingZeros Method

OpenBitSet TrimTrailingZeros Method Lucene.Net Class Library
Lowers numWords, the number of words in use, by checking for trailing zero words.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void TrimTrailingZeros()
public virtual void TrimTrailingZeros()
Public Overridable Sub TrimTrailingZeros
Public Overridable Sub TrimTrailingZeros
public:
virtual void TrimTrailingZeros()
public:
virtual void TrimTrailingZeros()
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Union Method

OpenBitSet Union Method Lucene.Net Class Library
this = this OR other

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Union(
    OpenBitSet other
)
public virtual void Union(
    OpenBitSet other
)
Public Overridable Sub Union ( _
    other As OpenBitSet _
)
Public Overridable Sub Union ( _
    other As OpenBitSet _
)
public:
virtual void Union(
    OpenBitSet^ other
)
public:
virtual void Union(
    OpenBitSet^ other
)
Parameters
other
Type: Lucene.Net.Util OpenBitSet
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UnionCount Method

OpenBitSet UnionCount Method Lucene.Net Class Library
Returns the popcount or cardinality of the union of the two sets. Neither set is modified.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long UnionCount(
    OpenBitSet a,
    OpenBitSet b
)
public static long UnionCount(
    OpenBitSet a,
    OpenBitSet b
)
Public Shared Function UnionCount ( _
    a As OpenBitSet, _
    b As OpenBitSet _
) As Long
Public Shared Function UnionCount ( _
    a As OpenBitSet, _
    b As OpenBitSet _
) As Long
public:
static long long UnionCount(
    OpenBitSet^ a,
    OpenBitSet^ b
)
public:
static long long UnionCount(
    OpenBitSet^ a,
    OpenBitSet^ b
)
Parameters
a
Type: Lucene.Net.Util OpenBitSet
b
Type: Lucene.Net.Util OpenBitSet
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Xor Method

OpenBitSet Xor Method Lucene.Net Class Library
this = this XOR other

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Xor(
    OpenBitSet other
)
public virtual void Xor(
    OpenBitSet other
)
Public Overridable Sub Xor ( _
    other As OpenBitSet _
)
Public Overridable Sub Xor ( _
    other As OpenBitSet _
)
public:
virtual void Xor(
    OpenBitSet^ other
)
public:
virtual void Xor(
    OpenBitSet^ other
)
Parameters
other
Type: Lucene.Net.Util OpenBitSet
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


XorCount Method

OpenBitSet XorCount Method Lucene.Net Class Library
Returns the popcount or cardinality of the exclusive-or of the two sets. Neither set is modified.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long XorCount(
    OpenBitSet a,
    OpenBitSet b
)
public static long XorCount(
    OpenBitSet a,
    OpenBitSet b
)
Public Shared Function XorCount ( _
    a As OpenBitSet, _
    b As OpenBitSet _
) As Long
Public Shared Function XorCount ( _
    a As OpenBitSet, _
    b As OpenBitSet _
) As Long
public:
static long long XorCount(
    OpenBitSet^ a,
    OpenBitSet^ b
)
public:
static long long XorCount(
    OpenBitSet^ a,
    OpenBitSet^ b
)
Parameters
a
Type: Lucene.Net.Util OpenBitSet
b
Type: Lucene.Net.Util OpenBitSet
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSet Properties

OpenBitSet Properties Lucene.Net Class Library
The OpenBitSet type exposes the following members.
Properties
 | Name | Description
Public property | Bits | Expert: Gets or sets the long[] storing the bits
Public property | IsCacheable | This DocIdSet implementation is cacheable. (Overrides DocIdSet IsCacheable.)
Public property | NumWords | Expert: gets or sets the number of longs in the array that are in use
Back to Top
See Also
OpenBitSet Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Bits Property

OpenBitSet Bits Property Lucene.Net Class Library
Expert: Gets or sets the long[] storing the bits

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long[] Bits { get; set; }
public virtual long[] Bits { get; set; }
Public Overridable Property Bits As Long()
    Get
    Set
Public Overridable Property Bits As Long()
    Get
    Set
public:
virtual property array<long long>^ Bits {
    array<long long>^ get ();
    void set (array<long long>^ value);
}
public:
virtual property array<long long>^ Bits {
    array<long long>^ get ();
    void set (array<long long>^ value);
}
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsCacheable Property

OpenBitSet IsCacheable Property Lucene.Net Class Library
This DocIdSet implementation is cacheable.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsCacheable { get; }
public override bool IsCacheable { get; }
Public Overrides ReadOnly Property IsCacheable As Boolean
    Get
Public Overrides ReadOnly Property IsCacheable As Boolean
    Get
public:
virtual property bool IsCacheable {
    bool get () override;
}
public:
virtual property bool IsCacheable {
    bool get () override;
}
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NumWords Property

OpenBitSet NumWords Property Lucene.Net Class Library
Expert: gets or sets the number of longs in the array that are in use

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int NumWords { get; set; }
public virtual int NumWords { get; set; }
Public Overridable Property NumWords As Integer
    Get
    Set
Public Overridable Property NumWords As Integer
    Get
    Set
public:
virtual property int NumWords {
    int get ();
    void set (int value);
}
public:
virtual property int NumWords {
    int get ();
    void set (int value);
}
See Also
OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSetDISI Class

OpenBitSetDISI Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSet
Lucene.Net.Util OpenBitSet
Lucene.Net.Util OpenBitSetDISI

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class OpenBitSetDISI : OpenBitSet
[SerializableAttribute]
public class OpenBitSetDISI : OpenBitSet
<SerializableAttribute> _
Public Class OpenBitSetDISI _
    Inherits OpenBitSet
<SerializableAttribute> _
Public Class OpenBitSetDISI _
    Inherits OpenBitSet
[SerializableAttribute]
public ref class OpenBitSetDISI : public OpenBitSet
[SerializableAttribute]
public ref class OpenBitSetDISI : public OpenBitSet
See Also
OpenBitSetDISI Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSetDISI Members

OpenBitSetDISI Members Lucene.Net Class Library

The OpenBitSetDISI type exposes the following members.
Constructors
 | Name | Description
Public method | OpenBitSetDISI(Int32) | Construct an OpenBitSetDISI with no bits set, and a given maximum size one larger than the largest doc id for which a bit may ever be set on this OpenBitSetDISI.
Public method | OpenBitSetDISI(DocIdSetIterator, Int32) | Construct an OpenBitSetDISI with its bits set from the doc ids of the given DocIdSetIterator. Also give a maximum size one larger than the largest doc id for which a bit may ever be set on this OpenBitSetDISI.
Back to Top
Methods
 | Name | Description
Public method | And | (Inherited from OpenBitSet.)
Public method | AndNot | (Inherited from OpenBitSet.)
Public method | Capacity | Returns the current capacity in bits (1 greater than the index of the last bit) (Inherited from OpenBitSet.)
Public method | Cardinality | (Inherited from OpenBitSet.)
Public method | Clear(Int64) | clears a bit, allowing access beyond the current set size without changing the size. (Inherited from OpenBitSet.)
Public method | Clear(Int32, Int32) | Clears a range of bits. Clearing past the end does not change the size of the set. (Inherited from OpenBitSet.)
Public method | Clear(Int64, Int64) | Clears a range of bits. Clearing past the end does not change the size of the set. (Inherited from OpenBitSet.)
Public method | Clone | (Inherited from OpenBitSet.)
Public method | EnsureCapacity | Ensure that the long[] is big enough to hold numBits, expanding it if necessary. getNumWords() is unchanged by this call. (Inherited from OpenBitSet.)
Public method | EnsureCapacityWords | Expand the long[] with the size given as a number of words (64 bit longs). getNumWords() is unchanged by this call. (Inherited from OpenBitSet.)
Public method | Equals | returns true if both sets have the same bits set (Inherited from OpenBitSet.)
Protected method | ExpandingWordNum | (Inherited from OpenBitSet.)
Public method | FastClear(Int32) | clears a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastClear(Int64) | clears a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastFlip(Int32) | flips a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastFlip(Int64) | flips a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastGet(Int32) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size (Inherited from OpenBitSet.)
Public method | FastGet(Int64) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastSet(Int32) | Sets the bit at the specified index. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastSet(Int64) | Sets the bit at the specified index. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flip(Int64) | flips a bit, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | Flip(Int64, Int64) | Flips a range of bits, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | FlipAndGet(Int32) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FlipAndGet(Int64) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | Get(Int32) | Returns true or false for the specified bit index. (Inherited from OpenBitSet.)
Public method | Get(Int64) | Returns true or false for the specified bit index (Inherited from OpenBitSet.)
Public method | GetAndSet(Int32) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | GetAndSet(Int64) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | GetBit | returns 1 if the bit is set, 0 if not. The index should be less than the OpenBitSet size (Inherited from OpenBitSet.)
Public method | GetHashCode | (Inherited from OpenBitSet.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | InPlaceAnd | Perform an inplace AND with the doc ids from a given DocIdSetIterator, leaving only the bits set for which the doc ids are in common. These doc ids should be smaller than the maximum size passed to the constructor.
Public method | InPlaceNot | Perform an inplace NOT with the doc ids from a given DocIdSetIterator, clearing all the bits for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.
Public method | InPlaceOr | Perform an inplace OR with the doc ids from a given DocIdSetIterator, setting the bit for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.
Public method | InPlaceXor | Perform an inplace XOR with the doc ids from a given DocIdSetIterator, flipping all the bits for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.
Public method | Intersect | this = this AND other (Inherited from OpenBitSet.)
Public method | Intersects | returns true if the sets have any elements in common (Inherited from OpenBitSet.)
Public method | IsEmpty | Returns true if there are no set bits (Inherited from OpenBitSet.)
Public method | Iterator | (Inherited from OpenBitSet.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextSetBit(Int32) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits. (Inherited from OpenBitSet.)
Public method | NextSetBit(Int64) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits. (Inherited from OpenBitSet.)
Public method | Or | (Inherited from OpenBitSet.)
Public method | Remove | Remove all elements set in other. this = this AND_NOT other (Inherited from OpenBitSet.)
Public method | Set(Int64) | sets a bit, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | Set(Int64, Int64) | Sets a range of bits, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | Size | Returns the current capacity of this set. Included for compatibility. This is *not* equal to Cardinality (Inherited from OpenBitSet.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | TrimTrailingZeros | Lowers numWords, the number of words in use, by checking for trailing zero words. (Inherited from OpenBitSet.)
Public method | Union | this = this OR other (Inherited from OpenBitSet.)
Public method | Xor | this = this XOR other (Inherited from OpenBitSet.)
Back to Top
Fields
 | Name | Description
Protected field | internalbits | (Inherited from OpenBitSet.)
Protected field | wlen | (Inherited from OpenBitSet.)
Back to Top
Properties
 | Name | Description
Public property | Bits | Expert: Gets or sets the long[] storing the bits (Inherited from OpenBitSet.)
Public property | IsCacheable | This DocIdSet implementation is cacheable. (Inherited from OpenBitSet.)
Public property | NumWords | Expert: gets or sets the number of longs in the array that are in use (Inherited from OpenBitSet.)
Back to Top
See Also
OpenBitSetDISI Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSetDISI Constructor

OpenBitSetDISI Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | OpenBitSetDISI(Int32) | Construct an OpenBitSetDISI with no bits set, and a given maximum size one larger than the largest doc id for which a bit may ever be set on this OpenBitSetDISI.
Public method | OpenBitSetDISI(DocIdSetIterator, Int32) | Construct an OpenBitSetDISI with its bits set from the doc ids of the given DocIdSetIterator. Also give a maximum size one larger than the largest doc id for which a bit may ever be set on this OpenBitSetDISI.
Back to Top
See Also
OpenBitSetDISI Class
OpenBitSetDISI Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSetDISI Constructor (Int32)

OpenBitSetDISI Constructor (Int32) Lucene.Net Class Library
Construct an OpenBitSetDISI with no bits set, and a given maximum size one larger than the largest doc id for which a bit may ever be set on this OpenBitSetDISI.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OpenBitSetDISI(
    int maxSize
)
public OpenBitSetDISI(
    int maxSize
)
Public Sub New ( _
    maxSize As Integer _
)
Public Sub New ( _
    maxSize As Integer _
)
public:
OpenBitSetDISI(
    int maxSize
)
public:
OpenBitSetDISI(
    int maxSize
)
Parameters
maxSize
Type:   Online System Int32
See Also
OpenBitSetDISI Class
OpenBitSetDISI Members
OpenBitSetDISI Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSetDISI Constructor (DocIdSetIterator, Int32)

OpenBitSetDISI Constructor (DocIdSetIterator, Int32) Lucene.Net Class Library
Construct an OpenBitSetDISI with its bits set from the doc ids of the given DocIdSetIterator. Also give a maximum size one larger than the largest doc id for which a bit may ever be set on this OpenBitSetDISI.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OpenBitSetDISI(
    DocIdSetIterator disi,
    int maxSize
)
public OpenBitSetDISI(
    DocIdSetIterator disi,
    int maxSize
)
Public Sub New ( _
    disi As DocIdSetIterator, _
    maxSize As Integer _
)
Public Sub New ( _
    disi As DocIdSetIterator, _
    maxSize As Integer _
)
public:
OpenBitSetDISI(
    DocIdSetIterator^ disi,
    int maxSize
)
public:
OpenBitSetDISI(
    DocIdSetIterator^ disi,
    int maxSize
)
Parameters
disi
Type: Lucene.Net.Search DocIdSetIterator
maxSize
Type:   Online System Int32
See Also
OpenBitSetDISI Class
OpenBitSetDISI Members
OpenBitSetDISI Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSetDISI Fields

OpenBitSetDISI Fields Lucene.Net Class Library
The OpenBitSetDISI type exposes the following members.
Fields
 | Name | Description
Protected field | internalbits | (Inherited from OpenBitSet.)
Protected field | wlen | (Inherited from OpenBitSet.)
Back to Top
See Also
OpenBitSetDISI Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSetDISI Methods

OpenBitSetDISI Methods Lucene.Net Class Library
The OpenBitSetDISI type exposes the following members.
Methods
 | Name | Description
Public method | And | (Inherited from OpenBitSet.)
Public method | AndNot | (Inherited from OpenBitSet.)
Public method | Capacity | Returns the current capacity in bits (1 greater than the index of the last bit) (Inherited from OpenBitSet.)
Public method | Cardinality | (Inherited from OpenBitSet.)
Public method | Clear(Int64) | clears a bit, allowing access beyond the current set size without changing the size. (Inherited from OpenBitSet.)
Public method | Clear(Int32, Int32) | Clears a range of bits. Clearing past the end does not change the size of the set. (Inherited from OpenBitSet.)
Public method | Clear(Int64, Int64) | Clears a range of bits. Clearing past the end does not change the size of the set. (Inherited from OpenBitSet.)
Public method | Clone | (Inherited from OpenBitSet.)
Public method | EnsureCapacity | Ensure that the long[] is big enough to hold numBits, expanding it if necessary. getNumWords() is unchanged by this call. (Inherited from OpenBitSet.)
Public method | EnsureCapacityWords | Expand the long[] with the size given as a number of words (64 bit longs). getNumWords() is unchanged by this call. (Inherited from OpenBitSet.)
Public method | Equals | returns true if both sets have the same bits set (Inherited from OpenBitSet.)
Protected method | ExpandingWordNum | (Inherited from OpenBitSet.)
Public method | FastClear(Int32) | clears a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastClear(Int64) | clears a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastFlip(Int32) | flips a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastFlip(Int64) | flips a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastGet(Int32) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size (Inherited from OpenBitSet.)
Public method | FastGet(Int64) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastSet(Int32) | Sets the bit at the specified index. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastSet(Int64) | Sets the bit at the specified index. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flip(Int64) | flips a bit, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | Flip(Int64, Int64) | Flips a range of bits, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | FlipAndGet(Int32) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FlipAndGet(Int64) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | Get(Int32) | Returns true or false for the specified bit index. (Inherited from OpenBitSet.)
Public method | Get(Int64) | Returns true or false for the specified bit index (Inherited from OpenBitSet.)
Public method | GetAndSet(Int32) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | GetAndSet(Int64) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | GetBit | returns 1 if the bit is set, 0 if not. The index should be less than the OpenBitSet size (Inherited from OpenBitSet.)
Public method | GetHashCode | (Inherited from OpenBitSet.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | InPlaceAnd | Perform an inplace AND with the doc ids from a given DocIdSetIterator, leaving only the bits set for which the doc ids are in common. These doc ids should be smaller than the maximum size passed to the constructor.
Public method | InPlaceNot | Perform an inplace NOT with the doc ids from a given DocIdSetIterator, clearing all the bits for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.
Public method | InPlaceOr | Perform an inplace OR with the doc ids from a given DocIdSetIterator, setting the bit for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.
Public method | InPlaceXor | Perform an inplace XOR with the doc ids from a given DocIdSetIterator, flipping all the bits for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.
Public method | Intersect | this = this AND other (Inherited from OpenBitSet.)
Public method | Intersects | returns true if the sets have any elements in common (Inherited from OpenBitSet.)
Public method | IsEmpty | Returns true if there are no set bits (Inherited from OpenBitSet.)
Public method | Iterator | (Inherited from OpenBitSet.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextSetBit(Int32) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits. (Inherited from OpenBitSet.)
Public method | NextSetBit(Int64) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits. (Inherited from OpenBitSet.)
Public method | Or | (Inherited from OpenBitSet.)
Public method | Remove | Remove all elements set in other. this = this AND_NOT other (Inherited from OpenBitSet.)
Public method | Set(Int64) | sets a bit, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | Set(Int64, Int64) | Sets a range of bits, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | Size | Returns the current capacity of this set. Included for compatibility. This is *not* equal to Cardinality (Inherited from OpenBitSet.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | TrimTrailingZeros | Lowers numWords, the number of words in use, by checking for trailing zero words. (Inherited from OpenBitSet.)
Public method | Union | this = this OR other (Inherited from OpenBitSet.)
Public method | Xor | this = this XOR other (Inherited from OpenBitSet.)
Back to Top
See Also
OpenBitSetDISI Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


InPlaceAnd Method

OpenBitSetDISI InPlaceAnd Method Lucene.Net Class Library
Perform an inplace AND with the doc ids from a given DocIdSetIterator, leaving only the bits set for which the doc ids are in common. These doc ids should be smaller than the maximum size passed to the constructor.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void InPlaceAnd(
    DocIdSetIterator disi
)
public virtual void InPlaceAnd(
    DocIdSetIterator disi
)
Public Overridable Sub InPlaceAnd ( _
    disi As DocIdSetIterator _
)
Public Overridable Sub InPlaceAnd ( _
    disi As DocIdSetIterator _
)
public:
virtual void InPlaceAnd(
    DocIdSetIterator^ disi
)
public:
virtual void InPlaceAnd(
    DocIdSetIterator^ disi
)
Parameters
disi
Type: Lucene.Net.Search DocIdSetIterator
See Also
OpenBitSetDISI Class
OpenBitSetDISI Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


InPlaceNot Method

OpenBitSetDISI InPlaceNot Method Lucene.Net Class Library
Perform an inplace NOT with the doc ids from a given DocIdSetIterator, clearing all the bits for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void InPlaceNot(
    DocIdSetIterator disi
)
public virtual void InPlaceNot(
    DocIdSetIterator disi
)
Public Overridable Sub InPlaceNot ( _
    disi As DocIdSetIterator _
)
Public Overridable Sub InPlaceNot ( _
    disi As DocIdSetIterator _
)
public:
virtual void InPlaceNot(
    DocIdSetIterator^ disi
)
public:
virtual void InPlaceNot(
    DocIdSetIterator^ disi
)
Parameters
disi
Type: Lucene.Net.Search DocIdSetIterator
See Also
OpenBitSetDISI Class
OpenBitSetDISI Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


InPlaceOr Method

OpenBitSetDISI InPlaceOr Method Lucene.Net Class Library
Perform an inplace OR with the doc ids from a given DocIdSetIterator, setting the bit for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void InPlaceOr(
    DocIdSetIterator disi
)
public virtual void InPlaceOr(
    DocIdSetIterator disi
)
Public Overridable Sub InPlaceOr ( _
    disi As DocIdSetIterator _
)
Public Overridable Sub InPlaceOr ( _
    disi As DocIdSetIterator _
)
public:
virtual void InPlaceOr(
    DocIdSetIterator^ disi
)
public:
virtual void InPlaceOr(
    DocIdSetIterator^ disi
)
Parameters
disi
Type: Lucene.Net.Search DocIdSetIterator
See Also
OpenBitSetDISI Class
OpenBitSetDISI Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


InPlaceXor Method

OpenBitSetDISI InPlaceXor Method Lucene.Net Class Library
Perform an inplace XOR with the doc ids from a given DocIdSetIterator, flipping all the bits for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void InPlaceXor(
    DocIdSetIterator disi
)
public virtual void InPlaceXor(
    DocIdSetIterator disi
)
Public Overridable Sub InPlaceXor ( _
    disi As DocIdSetIterator _
)
Public Overridable Sub InPlaceXor ( _
    disi As DocIdSetIterator _
)
public:
virtual void InPlaceXor(
    DocIdSetIterator^ disi
)
public:
virtual void InPlaceXor(
    DocIdSetIterator^ disi
)
Parameters
disi
Type: Lucene.Net.Search DocIdSetIterator
See Also
OpenBitSetDISI Class
OpenBitSetDISI Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSetDISI Properties

OpenBitSetDISI Properties Lucene.Net Class Library
The OpenBitSetDISI type exposes the following members.
Properties
 | Name | Description
Public property | Bits | Expert: Gets or sets the long[] storing the bits (Inherited from OpenBitSet.)
Public property | IsCacheable | This DocIdSet implementation is cacheable. (Inherited from OpenBitSet.)
Public property | NumWords | Expert: gets or sets the number of longs in the array that are in use (Inherited from OpenBitSet.)
Back to Top
See Also
OpenBitSetDISI Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSetIterator Class

OpenBitSetIterator Class Lucene.Net Class Library
An iterator to iterate over set bits in an OpenBitSet. This is faster than nextSetBit() for iterating over the complete set of bits, especially when the density of the bits set is high.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSetIterator
Lucene.Net.Util OpenBitSetIterator

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class OpenBitSetIterator : DocIdSetIterator
public class OpenBitSetIterator : DocIdSetIterator
Public Class OpenBitSetIterator _
    Inherits DocIdSetIterator
Public Class OpenBitSetIterator _
    Inherits DocIdSetIterator
public ref class OpenBitSetIterator : public DocIdSetIterator
public ref class OpenBitSetIterator : public DocIdSetIterator
See Also
OpenBitSetIterator Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSetIterator Members

OpenBitSetIterator Members Lucene.Net Class Library

The OpenBitSetIterator type exposes the following members.
Constructors
 | Name | Description
Public method | OpenBitSetIterator(OpenBitSet) | Initializes a new instance of the OpenBitSetIterator class
Public method | OpenBitSetIterator( Int64 , Int32) | Initializes a new instance of the OpenBitSetIterator class
Back to Top
Methods
 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Overrides DocIdSetIterator NextDoc .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
OpenBitSetIterator Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSetIterator Constructor

OpenBitSetIterator Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | OpenBitSetIterator(OpenBitSet) | Initializes a new instance of the OpenBitSetIterator class
Public method | OpenBitSetIterator( Int64 , Int32) | Initializes a new instance of the OpenBitSetIterator class
Back to Top
See Also
OpenBitSetIterator Class
OpenBitSetIterator Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSetIterator Constructor (OpenBitSet)

OpenBitSetIterator Constructor (OpenBitSet) Lucene.Net Class Library
Initializes a new instance of the OpenBitSetIterator class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OpenBitSetIterator(
    OpenBitSet obs
)
public OpenBitSetIterator(
    OpenBitSet obs
)
Public Sub New ( _
    obs As OpenBitSet _
)
Public Sub New ( _
    obs As OpenBitSet _
)
public:
OpenBitSetIterator(
    OpenBitSet^ obs
)
public:
OpenBitSetIterator(
    OpenBitSet^ obs
)
Parameters
obs
Type: Lucene.Net.Util OpenBitSet
See Also
OpenBitSetIterator Class
OpenBitSetIterator Members
OpenBitSetIterator Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSetIterator Constructor (Int64[], Int32)

OpenBitSetIterator Constructor ( Int64 , Int32) Lucene.Net Class Library
Initializes a new instance of the OpenBitSetIterator class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OpenBitSetIterator(
    long[] bits,
    int numWords
)
public OpenBitSetIterator(
    long[] bits,
    int numWords
)
Public Sub New ( _
    bits As Long(), _
    numWords As Integer _
)
Public Sub New ( _
    bits As Long(), _
    numWords As Integer _
)
public:
OpenBitSetIterator(
    array<long long>^ bits,
    int numWords
)
public:
OpenBitSetIterator(
    array<long long>^ bits,
    int numWords
)
Parameters
bits
Type:    Online System Int64
numWords
Type:   Online System Int32
See Also
OpenBitSetIterator Class
OpenBitSetIterator Members
OpenBitSetIterator Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OpenBitSetIterator Methods

OpenBitSetIterator Methods Lucene.Net Class Library
The OpenBitSetIterator type exposes the following members.
Methods
 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator Advance(Int32).)
Public method | DocID | (Overrides DocIdSetIterator DocID .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextDoc | (Overrides DocIdSetIterator NextDoc .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
OpenBitSetIterator Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Advance Method

OpenBitSetIterator Advance Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Advance(
    int target
)
public override int Advance(
    int target
)
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
public:
virtual int Advance(
    int target
) override
public:
virtual int Advance(
    int target
) override
Parameters
target
Type:   Online System Int32
See Also
OpenBitSetIterator Class
OpenBitSetIterator Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


DocID Method

OpenBitSetIterator DocID Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DocID()
public override int DocID()
Public Overrides Function DocID As Integer
Public Overrides Function DocID As Integer
public:
virtual int DocID() override
public:
virtual int DocID() override
See Also
OpenBitSetIterator Class
OpenBitSetIterator Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


NextDoc Method

OpenBitSetIterator NextDoc Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int NextDoc()
public override int NextDoc()
Public Overrides Function NextDoc As Integer
Public Overrides Function NextDoc As Integer
public:
virtual int NextDoc() override
public:
virtual int NextDoc() override
See Also
OpenBitSetIterator Class
OpenBitSetIterator Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PriorityQueue(T) Class

PriorityQueue T Class Lucene.Net Class Library
A PriorityQueue maintains a partial ordering of its elements such that the least element can always be found in constant time. Put()'s and pop()'s require log(size) time.

NOTE: This class pre-allocates a full array of length maxSize+1, in Initialize(Int32).
Inheritance Hierarchy
Online System Object
Lucene.Net.Util PriorityQueue T
Lucene.Net.Search FieldValueHitQueue
Lucene.Net.Search HitQueue

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class PriorityQueue<T>
public abstract class PriorityQueue<T>
Public MustInherit Class PriorityQueue(Of T)
Public MustInherit Class PriorityQueue(Of T)
generic<typename T>
public ref class PriorityQueue abstract
generic<typename T>
public ref class PriorityQueue abstract
Type Parameters
T
See Also
PriorityQueue T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PriorityQueue(T) Members

PriorityQueue T Members Lucene.Net Class Library

The PriorityQueue T type exposes the following members.
Constructors
 | Name | Description
Protected method | PriorityQueue T | Initializes a new instance of the PriorityQueue T class
Back to Top
Methods
Name Description
Public method Add
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an Online IndexOutOfRangeException is thrown.
Public method Clear
Removes all entries from the PriorityQueue.
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Initialize
Subclass constructors must call this.
Public method InsertWithOverflow
Adds an Object to a PriorityQueue in log(size) time. It returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
Public method LessThan
Determines the ordering of objects in this priority queue. Subclasses must define this one method.
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Pop
Removes and returns the least element of the PriorityQueue in log(size) time.
Public method Size
Returns the number of elements currently stored in the PriorityQueue.
Public method Top
Returns the least element of the PriorityQueue in constant time.
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Public method UpdateTop
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
View Colorized Copy to Clipboard Print
pq.top().change();
pq.updateTop();
pq.top().change();
pq.updateTop();
View Colorized Copy to Clipboard Print
o = pq.pop();
o.change();
pq.push(o);
o = pq.pop();
o.change();
pq.push(o);
instead of
Back to Top
Fields
 | Name | Description
Protected field | heap |
Back to Top
Properties
Name Description
Protected property SentinelObject
This method can be overridden by extending classes to return a sentinel object which will be used by Initialize(Int32) to fill the queue, so that the code which uses that queue can always assume it's full and only change the top without attempting to insert any new object.
Those sentinel values should always compare worse than any non-sentinel value (i.e., LessThan(T, T) should always favor the non-sentinel values).
By default, this method returns false, which means the queue will not be filled with sentinel values. Otherwise, the value returned will be used to pre-populate the queue. Adds sentinel values to the queue.
If this method is extended to return a non-null value, then the following usage pattern is recommended:
View Colorized Copy to Clipboard Print
// extends getSentinelObject() to return a non-null value.
PriorityQueue<MyObject> pq = new MyQueue<MyObject>(numHits);
// save the 'top' element, which is guaranteed to not be null.
MyObject pqTop = pq.top();
<...>
// now in order to add a new element, which is 'better' than top (after
// you've verified it is better), it is as simple as:
pqTop.change().
pqTop = pq.updateTop();
// extends getSentinelObject() to return a non-null value.
PriorityQueue<MyObject> pq = new MyQueue<MyObject>(numHits);
// save the 'top' element, which is guaranteed to not be null.
MyObject pqTop = pq.top();
<...>
// now in order to add a new element, which is 'better' than top (after
// you've verified it is better), it is as simple as:
pqTop.change().
pqTop = pq.updateTop();
NOTE: if this method returns a non-null value, it will be called by Initialize(Int32) Size times, relying on a new object to be returned and will not check if it's null again. Therefore you should ensure any call to this method creates a new instance and behaves consistently, e.g., it cannot return null if it previously returned non-null.
Back to Top
See Also
PriorityQueue T Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PriorityQueue(T) Constructor

PriorityQueue T Constructor Lucene.Net Class Library
Initializes a new instance of the PriorityQueue T class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PriorityQueue()
protected PriorityQueue()
Protected Sub New
Protected Sub New
protected:
PriorityQueue()
protected:
PriorityQueue()
See Also
PriorityQueue T  Class
PriorityQueue T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PriorityQueue(T) Fields

PriorityQueue T Fields Lucene.Net Class Library
The PriorityQueue T type exposes the following members.
Fields
 | Name | Description
Protected field | heap |
Back to Top
See Also
PriorityQueue T Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


heap Field

PriorityQueue T heap Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected T[] heap
protected T[] heap
Protected heap As T()
Protected heap As T()
protected:
array<T>^ heap
protected:
array<T>^ heap
See Also
PriorityQueue T  Class
PriorityQueue T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PriorityQueue(T) Methods

PriorityQueue T Methods Lucene.Net Class Library
The PriorityQueue T type exposes the following members.
Methods
Name Description
Public method Add
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an Online IndexOutOfRangeException is thrown.
Public method Clear
Removes all entries from the PriorityQueue.
Public method Online Equals
Determines whether the specified Online Object is equal to the current Online Object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection.
(Inherited from Online Object.)
Public method Online GetHashCode
Serves as a hash function for a particular type.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Initialize
Subclass constructors must call this.
Public method InsertWithOverflow
Adds an Object to a PriorityQueue in log(size) time. It returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
Public method LessThan
Determines the ordering of objects in this priority queue. Subclasses must define this one method.
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method Pop
Removes and returns the least element of the PriorityQueue in log(size) time.
Public method Size
Returns the number of elements currently stored in the PriorityQueue.
Public method Top
Returns the least element of the PriorityQueue in constant time.
Public method Online ToString
Returns a Online String that represents the current Online Object.
(Inherited from Online Object.)
Public method UpdateTop
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
View Colorized Copy to Clipboard Print
pq.top().change();
pq.updateTop();
pq.top().change();
pq.updateTop();
View Colorized Copy to Clipboard Print
o = pq.pop();
o.change();
pq.push(o);
o = pq.pop();
o.change();
pq.push(o);
instead of
Back to Top
See Also
PriorityQueue T Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Add Method

PriorityQueue T Add Method Lucene.Net Class Library
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an Online IndexOutOfRangeException is thrown.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T Add(
    T element
)
public T Add(
    T element
)
Public Function Add ( _
    element As T _
) As T
Public Function Add ( _
    element As T _
) As T
public:
T Add(
    T element
)
public:
T Add(
    T element
)
Parameters
element
Type: T
Return Value
 the new 'top' element in the queue.

See Also
PriorityQueue T  Class
PriorityQueue T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method

PriorityQueue T Clear Method Lucene.Net Class Library
Removes all entries from the PriorityQueue.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
See Also
PriorityQueue T  Class
PriorityQueue T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Initialize Method

PriorityQueue T Initialize Method Lucene.Net Class Library
Subclass constructors must call this.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void Initialize(
    int maxSize
)
protected void Initialize(
    int maxSize
)
Protected Sub Initialize ( _
    maxSize As Integer _
)
Protected Sub Initialize ( _
    maxSize As Integer _
)
protected:
void Initialize(
    int maxSize
)
protected:
void Initialize(
    int maxSize
)
Parameters
maxSize
Type:   Online System Int32
See Also
PriorityQueue T  Class
PriorityQueue T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


InsertWithOverflow Method

PriorityQueue T InsertWithOverflow Method Lucene.Net Class Library
Adds an Object to a PriorityQueue in log(size) time. It returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual T InsertWithOverflow(
    T element
)
public virtual T InsertWithOverflow(
    T element
)
Public Overridable Function InsertWithOverflow ( _
    element As T _
) As T
Public Overridable Function InsertWithOverflow ( _
    element As T _
) As T
public:
virtual T InsertWithOverflow(
    T element
)
public:
virtual T InsertWithOverflow(
    T element
)
Parameters
element
Type: T
See Also
PriorityQueue T  Class
PriorityQueue T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


LessThan Method

PriorityQueue T LessThan Method Lucene.Net Class Library
Determines the ordering of objects in this priority queue. Subclasses must define this one method.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool LessThan(
    T a,
    T b
)
public abstract bool LessThan(
    T a,
    T b
)
Public MustOverride Function LessThan ( _
    a As T, _
    b As T _
) As Boolean
Public MustOverride Function LessThan ( _
    a As T, _
    b As T _
) As Boolean
public:
virtual bool LessThan(
    T a,
    T b
) abstract
public:
virtual bool LessThan(
    T a,
    T b
) abstract
Parameters
a
Type: T
b
Type: T
See Also
PriorityQueue T  Class
PriorityQueue T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Pop Method

PriorityQueue T Pop Method Lucene.Net Class Library
Removes and returns the least element of the PriorityQueue in log(size) time.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T Pop()
public T Pop()
Public Function Pop As T
Public Function Pop As T
public:
T Pop()
public:
T Pop()
See Also
PriorityQueue T  Class
PriorityQueue T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Size Method

PriorityQueue T Size Method Lucene.Net Class Library
Returns the number of elements currently stored in the PriorityQueue.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Size()
public int Size()
Public Function Size As Integer
Public Function Size As Integer
public:
int Size()
public:
int Size()
See Also
PriorityQueue T  Class
PriorityQueue T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Top Method

PriorityQueue T Top Method Lucene.Net Class Library
Returns the least element of the PriorityQueue in constant time.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T Top()
public T Top()
Public Function Top As T
Public Function Top As T
public:
T Top()
public:
T Top()
See Also
PriorityQueue T  Class
PriorityQueue T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UpdateTop Method

PriorityQueue T UpdateTop Method Lucene.Net Class Library
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
View Colorized Copy to Clipboard Print
pq.top().change();
pq.updateTop();
pq.top().change();
pq.updateTop();
instead of
View Colorized Copy to Clipboard Print
o = pq.pop();
o.change();
pq.push(o);
o = pq.pop();
o.change();
pq.push(o);

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T UpdateTop()
public T UpdateTop()
Public Function UpdateTop As T
Public Function UpdateTop As T
public:
T UpdateTop()
public:
T UpdateTop()
Return Value
 the new 'top' element.
See Also
PriorityQueue T  Class
PriorityQueue T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


PriorityQueue(T) Properties

PriorityQueue T Properties Lucene.Net Class Library
The PriorityQueue T type exposes the following members.
Properties
Name Description
Protected property SentinelObject
This method can be overridden by extending classes to return a sentinel object which will be used by Initialize(Int32) to fill the queue, so that the code which uses that queue can always assume it's full and only change the top without attempting to insert any new object.
Those sentinel values should always compare worse than any non-sentinel value (i.e., LessThan(T, T) should always favor the non-sentinel values).
By default, this method returns false, which means the queue will not be filled with sentinel values. Otherwise, the value returned will be used to pre-populate the queue. Adds sentinel values to the queue.
If this method is extended to return a non-null value, then the following usage pattern is recommended:
View Colorized Copy to Clipboard Print
// extends getSentinelObject() to return a non-null value.
PriorityQueue<MyObject> pq = new MyQueue<MyObject>(numHits);
// save the 'top' element, which is guaranteed to not be null.
MyObject pqTop = pq.top();
<...>
// now in order to add a new element, which is 'better' than top (after
// you've verified it is better), it is as simple as:
pqTop.change().
pqTop = pq.updateTop();
// extends getSentinelObject() to return a non-null value.
PriorityQueue<MyObject> pq = new MyQueue<MyObject>(numHits);
// save the 'top' element, which is guaranteed to not be null.
MyObject pqTop = pq.top();
<...>
// now in order to add a new element, which is 'better' than top (after
// you've verified it is better), it is as simple as:
pqTop.change().
pqTop = pq.updateTop();
NOTE: if this method returns a non-null value, it will be called by Initialize(Int32) Size times, relying on a new object to be returned and will not check if it's null again. Therefore you should ensure any call to this method creates a new instance and behaves consistently, e.g., it cannot return null if it previously returned non-null.
Back to Top
See Also
PriorityQueue T Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SentinelObject Property

PriorityQueue T SentinelObject Property Lucene.Net Class Library
This method can be overridden by extending classes to return a sentinel object which will be used by Initialize(Int32) to fill the queue, so that the code which uses that queue can always assume it's full and only change the top without attempting to insert any new object.
Those sentinel values should always compare worse than any non-sentinel value (i.e., LessThan(T, T) should always favor the non-sentinel values).
By default, this method returns false, which means the queue will not be filled with sentinel values. Otherwise, the value returned will be used to pre-populate the queue. Adds sentinel values to the queue.
If this method is extended to return a non-null value, then the following usage pattern is recommended:
View Colorized Copy to Clipboard Print
// extends getSentinelObject() to return a non-null value.
PriorityQueue<MyObject> pq = new MyQueue<MyObject>(numHits);
// save the 'top' element, which is guaranteed to not be null.
MyObject pqTop = pq.top();
<...>
// now in order to add a new element, which is 'better' than top (after
// you've verified it is better), it is as simple as:
pqTop.change().
pqTop = pq.updateTop();
// extends getSentinelObject() to return a non-null value.
PriorityQueue<MyObject> pq = new MyQueue<MyObject>(numHits);
// save the 'top' element, which is guaranteed to not be null.
MyObject pqTop = pq.top();
<...>
// now in order to add a new element, which is 'better' than top (after
// you've verified it is better), it is as simple as:
pqTop.change().
pqTop = pq.updateTop();
NOTE: if this method returns a non-null value, it will be called by Initialize(Int32) Size times, relying on a new object to be returned and will not check if it's null again. Therefore you should ensure any call to this method creates a new instance and behaves consistently, e.g., it cannot return null if it previously returned non-null.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual T SentinelObject { get; }
protected virtual T SentinelObject { get; }
Protected Overridable ReadOnly Property SentinelObject As T
    Get
Protected Overridable ReadOnly Property SentinelObject As T
    Get
protected:
virtual property T SentinelObject {
    T get ();
}
protected:
virtual property T SentinelObject {
    T get ();
}
Field Value
 the sentinel object to use to pre-populate the queue, or null if sentinel objects are not supported.
See Also
PriorityQueue T  Class
PriorityQueue T  Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RamUsageEstimator Class

RamUsageEstimator Class Lucene.Net Class Library
Estimates the size of a given Object using a given MemoryModel for primitive size information. Resource Usage: Internally uses a Map to temporally hold a reference to every object seen. If checkIntered, all Strings checked will be interned, but those that were not already interned will be released for GC when the estimate is complete.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util RamUsageEstimator

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class RamUsageEstimator
public sealed class RamUsageEstimator
Public NotInheritable Class RamUsageEstimator
Public NotInheritable Class RamUsageEstimator
public ref class RamUsageEstimator sealed
public ref class RamUsageEstimator sealed
See Also
RamUsageEstimator Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RamUsageEstimator Members

RamUsageEstimator Members Lucene.Net Class Library

The RamUsageEstimator type exposes the following members.
Constructors
 | Name | Description
Public method | RamUsageEstimator | Constructs this object with an AverageGuessMemoryModel and checkInterned = true.
Public method | RamUsageEstimator(Boolean) | Initializes a new instance of the RamUsageEstimator class
Public method | RamUsageEstimator(MemoryModel) | Initializes a new instance of the RamUsageEstimator class
Public method | RamUsageEstimator(MemoryModel, Boolean) | Initializes a new instance of the RamUsageEstimator class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | EstimateRamUsage |
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | HumanReadableUnits | Return good default units based on byte size.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RamUsageEstimator Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RamUsageEstimator Constructor

RamUsageEstimator Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | RamUsageEstimator | Constructs this object with an AverageGuessMemoryModel and checkInterned = true.
Public method | RamUsageEstimator(Boolean) | Initializes a new instance of the RamUsageEstimator class
Public method | RamUsageEstimator(MemoryModel) | Initializes a new instance of the RamUsageEstimator class
Public method | RamUsageEstimator(MemoryModel, Boolean) | Initializes a new instance of the RamUsageEstimator class
Back to Top
See Also
RamUsageEstimator Class
RamUsageEstimator Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RamUsageEstimator Constructor

RamUsageEstimator Constructor Lucene.Net Class Library
Constructs this object with an AverageGuessMemoryModel and checkInterned = true.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RamUsageEstimator()
public RamUsageEstimator()
Public Sub New
Public Sub New
public:
RamUsageEstimator()
public:
RamUsageEstimator()
See Also
RamUsageEstimator Class
RamUsageEstimator Members
RamUsageEstimator Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RamUsageEstimator Constructor (Boolean)

RamUsageEstimator Constructor (Boolean) Lucene.Net Class Library
Initializes a new instance of the RamUsageEstimator class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RamUsageEstimator(
    bool checkInterned
)
public RamUsageEstimator(
    bool checkInterned
)
Public Sub New ( _
    checkInterned As Boolean _
)
Public Sub New ( _
    checkInterned As Boolean _
)
public:
RamUsageEstimator(
    bool checkInterned
)
public:
RamUsageEstimator(
    bool checkInterned
)
Parameters
checkInterned
Type:   Online System Boolean
check if Strings are interned and don't add to size
            if they are. Defaults to true but if you know the objects you are checking
            won't likely contain many interned Strings, it will be faster to turn off
            intern checking.

See Also
RamUsageEstimator Class
RamUsageEstimator Members
RamUsageEstimator Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RamUsageEstimator Constructor (MemoryModel)

RamUsageEstimator Constructor (MemoryModel) Lucene.Net Class Library
Initializes a new instance of the RamUsageEstimator class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RamUsageEstimator(
    MemoryModel memoryModel
)
public RamUsageEstimator(
    MemoryModel memoryModel
)
Public Sub New ( _
    memoryModel As MemoryModel _
)
Public Sub New ( _
    memoryModel As MemoryModel _
)
public:
RamUsageEstimator(
    MemoryModel^ memoryModel
)
public:
RamUsageEstimator(
    MemoryModel^ memoryModel
)
Parameters
memoryModel
Type: Lucene.Net.Util MemoryModel
MemoryModel to use for primitive object sizes.

See Also
RamUsageEstimator Class
RamUsageEstimator Members
RamUsageEstimator Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RamUsageEstimator Constructor (MemoryModel, Boolean)

RamUsageEstimator Constructor (MemoryModel, Boolean) Lucene.Net Class Library
Initializes a new instance of the RamUsageEstimator class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RamUsageEstimator(
    MemoryModel memoryModel,
    bool checkInterned
)
public RamUsageEstimator(
    MemoryModel memoryModel,
    bool checkInterned
)
Public Sub New ( _
    memoryModel As MemoryModel, _
    checkInterned As Boolean _
)
Public Sub New ( _
    memoryModel As MemoryModel, _
    checkInterned As Boolean _
)
public:
RamUsageEstimator(
    MemoryModel^ memoryModel,
    bool checkInterned
)
public:
RamUsageEstimator(
    MemoryModel^ memoryModel,
    bool checkInterned
)
Parameters
memoryModel
Type: Lucene.Net.Util MemoryModel
MemoryModel to use for primitive object sizes.

checkInterned
Type:   Online System Boolean
check if Strings are interned and don't add to size
            if they are. Defaults to true but if you know the objects you are checking
            won't likely contain many interned Strings, it will be faster to turn off
            intern checking.

See Also
RamUsageEstimator Class
RamUsageEstimator Members
RamUsageEstimator Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


RamUsageEstimator Methods

RamUsageEstimator Methods Lucene.Net Class Library
The RamUsageEstimator type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | EstimateRamUsage |
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | HumanReadableUnits | Return good default units based on byte size.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
RamUsageEstimator Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


EstimateRamUsage Method

RamUsageEstimator EstimateRamUsage Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long EstimateRamUsage(
    Object obj
)
public long EstimateRamUsage(
    Object obj
)
Public Function EstimateRamUsage ( _
    obj As Object _
) As Long
Public Function EstimateRamUsage ( _
    obj As Object _
) As Long
public:
long long EstimateRamUsage(
    Object^ obj
)
public:
long long EstimateRamUsage(
    Object^ obj
)
Parameters
obj
Type:   Online System Object
See Also
RamUsageEstimator Class
RamUsageEstimator Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


HumanReadableUnits Method

RamUsageEstimator HumanReadableUnits Method Lucene.Net Class Library
Return good default units based on byte size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string HumanReadableUnits(
    long bytes,
    IFormatProvider df
)
public static string HumanReadableUnits(
    long bytes,
    IFormatProvider df
)
Public Shared Function HumanReadableUnits ( _
    bytes As Long, _
    df As IFormatProvider _
) As String
Public Shared Function HumanReadableUnits ( _
    bytes As Long, _
    df As IFormatProvider _
) As String
public:
static String^ HumanReadableUnits(
    long long bytes,
    IFormatProvider^ df
)
public:
static String^ HumanReadableUnits(
    long long bytes,
    IFormatProvider^ df
)
Parameters
bytes
Type:   Online System Int64
df
Type:   Online System IFormatProvider
See Also
RamUsageEstimator Class
RamUsageEstimator Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReaderUtil Class

ReaderUtil Class Lucene.Net Class Library
Common util methods for dealing with IndexReaders.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util ReaderUtil

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ReaderUtil
public class ReaderUtil
Public Class ReaderUtil
Public Class ReaderUtil
public ref class ReaderUtil
public ref class ReaderUtil
See Also
ReaderUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReaderUtil Members

ReaderUtil Members Lucene.Net Class Library

The ReaderUtil type exposes the following members.
Constructors
 | Name | Description
Public method | ReaderUtil | Initializes a new instance of the ReaderUtil class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GatherSubReaders | Gathers sub-readers from reader into a List.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | SubIndex | Returns index of the searcher/reader for document n in the array used to construct this searcher/reader.
 | SubReader(Int32, IndexReader) | Returns sub IndexReader that contains the given document id.
 | SubReader(IndexReader, Int32) | Returns sub-reader subIndex from reader.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ReaderUtil Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReaderUtil Constructor

ReaderUtil Constructor Lucene.Net Class Library
Initializes a new instance of the ReaderUtil class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReaderUtil()
public ReaderUtil()
Public Sub New
Public Sub New
public:
ReaderUtil()
public:
ReaderUtil()
See Also
ReaderUtil Class
ReaderUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ReaderUtil Methods

ReaderUtil Methods Lucene.Net Class Library
The ReaderUtil type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GatherSubReaders | Gathers sub-readers from reader into a List.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | SubIndex | Returns index of the searcher/reader for document n in the array used to construct this searcher/reader.
 | SubReader(Int32, IndexReader) | Returns sub IndexReader that contains the given document id.
 | SubReader(IndexReader, Int32) | Returns sub-reader subIndex from reader.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ReaderUtil Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


GatherSubReaders Method

ReaderUtil GatherSubReaders Method Lucene.Net Class Library
Gathers sub-readers from reader into a List.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void GatherSubReaders(
    IList<IndexReader> allSubReaders,
    IndexReader reader
)
public static void GatherSubReaders(
    IList<IndexReader> allSubReaders,
    IndexReader reader
)
Public Shared Sub GatherSubReaders ( _
    allSubReaders As IList(Of IndexReader), _
    reader As IndexReader _
)
Public Shared Sub GatherSubReaders ( _
    allSubReaders As IList(Of IndexReader), _
    reader As IndexReader _
)
public:
static void GatherSubReaders(
    IList<IndexReader^>^ allSubReaders,
    IndexReader^ reader
)
public:
static void GatherSubReaders(
    IList<IndexReader^>^ allSubReaders,
    IndexReader^ reader
)
Parameters
allSubReaders
Type:   Online System.Collections.Generic IList  IndexReader
reader
Type: Lucene.Net.Index IndexReader
See Also
ReaderUtil Class
ReaderUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SubIndex Method

ReaderUtil SubIndex Method Lucene.Net Class Library
Returns index of the searcher/reader for document n in the array used to construct this searcher/reader.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int SubIndex(
    int n,
    int[] docStarts
)
public static int SubIndex(
    int n,
    int[] docStarts
)
Public Shared Function SubIndex ( _
    n As Integer, _
    docStarts As Integer() _
) As Integer
Public Shared Function SubIndex ( _
    n As Integer, _
    docStarts As Integer() _
) As Integer
public:
static int SubIndex(
    int n,
    array<int>^ docStarts
)
public:
static int SubIndex(
    int n,
    array<int>^ docStarts
)
Parameters
n
Type:   Online System Int32
docStarts
Type:    Online System Int32
See Also
ReaderUtil Class
ReaderUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SubReader Method

ReaderUtil SubReader Method Lucene.Net Class Library
Overload List
Name | Description
SubReader(Int32, IndexReader) | Returns sub IndexReader that contains the given document id.
SubReader(IndexReader, Int32) | Returns sub-reader subIndex from reader.
Back to Top
See Also
ReaderUtil Class
ReaderUtil Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SubReader Method (Int32, IndexReader)

ReaderUtil SubReader Method (Int32, IndexReader) Lucene.Net Class Library
Returns sub IndexReader that contains the given document id.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IndexReader SubReader(
    int doc,
    IndexReader reader
)
public static IndexReader SubReader(
    int doc,
    IndexReader reader
)
Public Shared Function SubReader ( _
    doc As Integer, _
    reader As IndexReader _
) As IndexReader
Public Shared Function SubReader ( _
    doc As Integer, _
    reader As IndexReader _
) As IndexReader
public:
static IndexReader^ SubReader(
    int doc,
    IndexReader^ reader
)
public:
static IndexReader^ SubReader(
    int doc,
    IndexReader^ reader
)
Parameters
doc
Type:   Online System Int32
id of document

reader
Type: Lucene.Net.Index IndexReader
parent reader

Return Value
 sub reader of parent which contains the specified doc id

See Also
ReaderUtil Class
ReaderUtil Members
SubReader Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SubReader Method (IndexReader, Int32)

ReaderUtil SubReader Method (IndexReader, Int32) Lucene.Net Class Library
Returns sub-reader subIndex from reader.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IndexReader SubReader(
    IndexReader reader,
    int subIndex
)
public static IndexReader SubReader(
    IndexReader reader,
    int subIndex
)
Public Shared Function SubReader ( _
    reader As IndexReader, _
    subIndex As Integer _
) As IndexReader
Public Shared Function SubReader ( _
    reader As IndexReader, _
    subIndex As Integer _
) As IndexReader
public:
static IndexReader^ SubReader(
    IndexReader^ reader,
    int subIndex
)
public:
static IndexReader^ SubReader(
    IndexReader^ reader,
    int subIndex
)
Parameters
reader
Type: Lucene.Net.Index IndexReader
parent reader

subIndex
Type:   Online System Int32
index of desired sub reader

Return Value
 the subreader at subINdex

See Also
ReaderUtil Class
ReaderUtil Members
SubReader Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ScorerDocQueue Class

ScorerDocQueue Class Lucene.Net Class Library
A ScorerDocQueue maintains a partial ordering of its Scorers such that the least Scorer can always be found in constant time. Put()'s and pop()'s require log(size) time. The ordering is by Scorer.doc().
Inheritance Hierarchy
Online System Object
Lucene.Net.Util ScorerDocQueue

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ScorerDocQueue
public class ScorerDocQueue
Public Class ScorerDocQueue
Public Class ScorerDocQueue
public ref class ScorerDocQueue
public ref class ScorerDocQueue
See Also
ScorerDocQueue Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ScorerDocQueue Members

ScorerDocQueue Members Lucene.Net Class Library

The ScorerDocQueue type exposes the following members.
Constructors
 | Name | Description
Public method | ScorerDocQueue | Create a ScorerDocQueue with a maximum size.
Back to Top
Methods
 | Name | Description
Public method | AdjustTop | Should be called when the scorer at top changes doc() value. Still log(n) worst case, but it's at least twice as fast to { pq.top().change(); pq.adjustTop(); } instead of { o = pq.pop(); o.change(); pq.push(o); }
Public method | Clear | Removes all entries from the ScorerDocQueue.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Insert | Adds a Scorer to the ScorerDocQueue in log(size) time if either the ScorerDocQueue is not full, or not lessThan(scorer, top()).
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Pop | Removes and returns the least scorer of the ScorerDocQueue in log(size) time. Should not be used when the queue is empty.
Public method | Put | Adds a Scorer to a ScorerDocQueue in log(size) time. If one tries to add more Scorers than maxSize a RuntimeException (ArrayIndexOutOfBound) is thrown.
Public method | Size | Returns the number of scorers currently stored in the ScorerDocQueue.
Public method | Top | Returns the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.
Public method | TopDoc | Returns document number of the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.
Public method | TopNextAndAdjustElsePop |
Public method | TopScore |
Public method | TopSkipToAndAdjustElsePop |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ScorerDocQueue Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ScorerDocQueue Constructor

ScorerDocQueue Constructor Lucene.Net Class Library
Create a ScorerDocQueue with a maximum size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ScorerDocQueue(
    int maxSize
)
public ScorerDocQueue(
    int maxSize
)
Public Sub New ( _
    maxSize As Integer _
)
Public Sub New ( _
    maxSize As Integer _
)
public:
ScorerDocQueue(
    int maxSize
)
public:
ScorerDocQueue(
    int maxSize
)
Parameters
maxSize
Type:   Online System Int32
See Also
ScorerDocQueue Class
ScorerDocQueue Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ScorerDocQueue Methods

ScorerDocQueue Methods Lucene.Net Class Library
The ScorerDocQueue type exposes the following members.
Methods
 | Name | Description
Public method | AdjustTop | Should be called when the scorer at top changes doc() value. Still log(n) worst case, but it's at least twice as fast to { pq.top().change(); pq.adjustTop(); } instead of { o = pq.pop(); o.change(); pq.push(o); }
Public method | Clear | Removes all entries from the ScorerDocQueue.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Insert | Adds a Scorer to the ScorerDocQueue in log(size) time if either the ScorerDocQueue is not full, or not lessThan(scorer, top()).
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Pop | Removes and returns the least scorer of the ScorerDocQueue in log(size) time. Should not be used when the queue is empty.
Public method | Put | Adds a Scorer to a ScorerDocQueue in log(size) time. If one tries to add more Scorers than maxSize a RuntimeException (ArrayIndexOutOfBound) is thrown.
Public method | Size | Returns the number of scorers currently stored in the ScorerDocQueue.
Public method | Top | Returns the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.
Public method | TopDoc | Returns document number of the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.
Public method | TopNextAndAdjustElsePop |
Public method | TopScore |
Public method | TopSkipToAndAdjustElsePop |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ScorerDocQueue Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


AdjustTop Method

ScorerDocQueue AdjustTop Method Lucene.Net Class Library
Should be called when the scorer at top changes doc() value. Still log(n) worst case, but it's at least twice as fast to { pq.top().change(); pq.adjustTop(); } instead of { o = pq.pop(); o.change(); pq.push(o); }

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AdjustTop()
public void AdjustTop()
Public Sub AdjustTop
Public Sub AdjustTop
public:
void AdjustTop()
public:
void AdjustTop()
See Also
ScorerDocQueue Class
ScorerDocQueue Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Clear Method

ScorerDocQueue Clear Method Lucene.Net Class Library
Removes all entries from the ScorerDocQueue.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
See Also
ScorerDocQueue Class
ScorerDocQueue Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Insert Method

ScorerDocQueue Insert Method Lucene.Net Class Library
Adds a Scorer to the ScorerDocQueue in log(size) time if either the ScorerDocQueue is not full, or not lessThan(scorer, top()).

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Insert(
    Scorer scorer
)
public virtual bool Insert(
    Scorer scorer
)
Public Overridable Function Insert ( _
    scorer As Scorer _
) As Boolean
Public Overridable Function Insert ( _
    scorer As Scorer _
) As Boolean
public:
virtual bool Insert(
    Scorer^ scorer
)
public:
virtual bool Insert(
    Scorer^ scorer
)
Parameters
scorer
Type: Lucene.Net.Search Scorer
Return Value
 true if scorer is added, false otherwise.

See Also
ScorerDocQueue Class
ScorerDocQueue Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Pop Method

ScorerDocQueue Pop Method Lucene.Net Class Library
Removes and returns the least scorer of the ScorerDocQueue in log(size) time. Should not be used when the queue is empty.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Scorer Pop()
public Scorer Pop()
Public Function Pop As Scorer
Public Function Pop As Scorer
public:
Scorer^ Pop()
public:
Scorer^ Pop()
See Also
ScorerDocQueue Class
ScorerDocQueue Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Put Method

ScorerDocQueue Put Method Lucene.Net Class Library
Adds a Scorer to a ScorerDocQueue in log(size) time. If one tries to add more Scorers than maxSize a RuntimeException (ArrayIndexOutOfBound) is thrown.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Put(
    Scorer scorer
)
public void Put(
    Scorer scorer
)
Public Sub Put ( _
    scorer As Scorer _
)
Public Sub Put ( _
    scorer As Scorer _
)
public:
void Put(
    Scorer^ scorer
)
public:
void Put(
    Scorer^ scorer
)
Parameters
scorer
Type: Lucene.Net.Search Scorer
See Also
ScorerDocQueue Class
ScorerDocQueue Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Size Method

ScorerDocQueue Size Method Lucene.Net Class Library
Returns the number of scorers currently stored in the ScorerDocQueue.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Size()
public int Size()
Public Function Size As Integer
Public Function Size As Integer
public:
int Size()
public:
int Size()
See Also
ScorerDocQueue Class
ScorerDocQueue Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Top Method

ScorerDocQueue Top Method Lucene.Net Class Library
Returns the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Scorer Top()
public Scorer Top()
Public Function Top As Scorer
Public Function Top As Scorer
public:
Scorer^ Top()
public:
Scorer^ Top()
See Also
ScorerDocQueue Class
ScorerDocQueue Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopDoc Method

ScorerDocQueue TopDoc Method Lucene.Net Class Library
Returns document number of the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int TopDoc()
public int TopDoc()
Public Function TopDoc As Integer
Public Function TopDoc As Integer
public:
int TopDoc()
public:
int TopDoc()
See Also
ScorerDocQueue Class
ScorerDocQueue Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopNextAndAdjustElsePop Method

ScorerDocQueue TopNextAndAdjustElsePop Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TopNextAndAdjustElsePop()
public bool TopNextAndAdjustElsePop()
Public Function TopNextAndAdjustElsePop As Boolean
Public Function TopNextAndAdjustElsePop As Boolean
public:
bool TopNextAndAdjustElsePop()
public:
bool TopNextAndAdjustElsePop()
See Also
ScorerDocQueue Class
ScorerDocQueue Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopScore Method

ScorerDocQueue TopScore Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float TopScore()
public float TopScore()
Public Function TopScore As Single
Public Function TopScore As Single
public:
float TopScore()
public:
float TopScore()
See Also
ScorerDocQueue Class
ScorerDocQueue Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


TopSkipToAndAdjustElsePop Method

ScorerDocQueue TopSkipToAndAdjustElsePop Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TopSkipToAndAdjustElsePop(
    int target
)
public bool TopSkipToAndAdjustElsePop(
    int target
)
Public Function TopSkipToAndAdjustElsePop ( _
    target As Integer _
) As Boolean
Public Function TopSkipToAndAdjustElsePop ( _
    target As Integer _
) As Boolean
public:
bool TopSkipToAndAdjustElsePop(
    int target
)
public:
bool TopSkipToAndAdjustElsePop(
    int target
)
Parameters
target
Type:   Online System Int32
See Also
ScorerDocQueue Class
ScorerDocQueue Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleStringInterner Class

SimpleStringInterner Class Lucene.Net Class Library
Simple lockless and memory barrier free String intern cache that is guaranteed to return the same String instance as String.intern() does.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util StringInterner
Lucene.Net.Util SimpleStringInterner

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SimpleStringInterner : StringInterner
public class SimpleStringInterner : StringInterner
Public Class SimpleStringInterner _
    Inherits StringInterner
Public Class SimpleStringInterner _
    Inherits StringInterner
public ref class SimpleStringInterner : public StringInterner
public ref class SimpleStringInterner : public StringInterner
See Also
SimpleStringInterner Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleStringInterner Members

SimpleStringInterner Members Lucene.Net Class Library

The SimpleStringInterner type exposes the following members.
Constructors
 | Name | Description
Public method | SimpleStringInterner | Initializes a new instance of the SimpleStringInterner class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Intern(String) | (Overrides StringInterner Intern(String).)
Public method | Intern( Char , Int32, Int32) | Returns a single object instance for each equal string. (Inherited from StringInterner.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SimpleStringInterner Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleStringInterner Constructor

SimpleStringInterner Constructor Lucene.Net Class Library
Initializes a new instance of the SimpleStringInterner class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SimpleStringInterner(
    int tableSize,
    int maxChainLength
)
public SimpleStringInterner(
    int tableSize,
    int maxChainLength
)
Public Sub New ( _
    tableSize As Integer, _
    maxChainLength As Integer _
)
Public Sub New ( _
    tableSize As Integer, _
    maxChainLength As Integer _
)
public:
SimpleStringInterner(
    int tableSize,
    int maxChainLength
)
public:
SimpleStringInterner(
    int tableSize,
    int maxChainLength
)
Parameters
tableSize
Type:   Online System Int32
 Size of the hash table, should be a power of two.

maxChainLength
Type:   Online System Int32
 Maximum length of each bucket, after which the oldest item inserted is dropped.

See Also
SimpleStringInterner Class
SimpleStringInterner Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleStringInterner Methods

SimpleStringInterner Methods Lucene.Net Class Library
The SimpleStringInterner type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Intern(String) | (Overrides StringInterner Intern(String).)
Public method | Intern( Char , Int32, Int32) | Returns a single object instance for each equal string. (Inherited from StringInterner.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SimpleStringInterner Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Intern Method

SimpleStringInterner Intern Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Intern(String) | (Overrides StringInterner Intern(String).)
Public method | Intern( Char , Int32, Int32) | Returns a single object instance for each equal string. (Inherited from StringInterner.)
Back to Top
See Also
SimpleStringInterner Class
SimpleStringInterner Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Intern Method (String)

SimpleStringInterner Intern Method (String) Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Intern(
    string s
)
public override string Intern(
    string s
)
Public Overrides Function Intern ( _
    s As String _
) As String
Public Overrides Function Intern ( _
    s As String _
) As String
public:
virtual String^ Intern(
    String^ s
) override
public:
virtual String^ Intern(
    String^ s
) override
Parameters
s
Type:   Online System String
See Also
SimpleStringInterner Class
SimpleStringInterner Members
Intern Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SmallFloat Class

SmallFloat Class Lucene.Net Class Library
Floating point numbers smaller than 32 bits.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util SmallFloat

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SmallFloat
public class SmallFloat
Public Class SmallFloat
Public Class SmallFloat
public ref class SmallFloat
public ref class SmallFloat
See Also
SmallFloat Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SmallFloat Members

SmallFloat Members Lucene.Net Class Library

The SmallFloat type exposes the following members.
Constructors
 | Name | Description
Public method | SmallFloat | Initializes a new instance of the SmallFloat class
Back to Top
Methods
 | Name | Description
 | Byte315ToFloat | byteToFloat(b, mantissaBits=3, zeroExponent=15)
 | Byte52ToFloat | byteToFloat(b, mantissaBits=5, zeroExponent=2)
 | ByteToFloat | Converts an 8 bit float to a 32 bit float.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | FloatToByte | Converts a 32 bit float to an 8 bit float. Values less than zero are all mapped to zero. Values are truncated (rounded down) to the nearest 8 bit value. Values between zero and the smallest representable value are rounded up.
 | FloatToByte315 | floatToByte(b, mantissaBits=3, zeroExponent=15) smallest non-zero value = 5.820766E-10 largest value = 7.5161928E9 epsilon = 0.125
 | FloatToByte52 | floatToByte(b, mantissaBits=5, zeroExponent=2) smallest nonzero value = 0.033203125 largest value = 1984.0 epsilon = 0.03125
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SmallFloat Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SmallFloat Constructor

SmallFloat Constructor Lucene.Net Class Library
Initializes a new instance of the SmallFloat class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SmallFloat()
public SmallFloat()
Public Sub New
Public Sub New
public:
SmallFloat()
public:
SmallFloat()
See Also
SmallFloat Class
SmallFloat Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SmallFloat Methods

SmallFloat Methods Lucene.Net Class Library
The SmallFloat type exposes the following members.
Methods
 | Name | Description
 | Byte315ToFloat | byteToFloat(b, mantissaBits=3, zeroExponent=15)
 | Byte52ToFloat | byteToFloat(b, mantissaBits=5, zeroExponent=2)
 | ByteToFloat | Converts an 8 bit float to a 32 bit float.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | FloatToByte | Converts a 32 bit float to an 8 bit float. Values less than zero are all mapped to zero. Values are truncated (rounded down) to the nearest 8 bit value. Values between zero and the smallest representable value are rounded up.
 | FloatToByte315 | floatToByte(b, mantissaBits=3, zeroExponent=15) smallest non-zero value = 5.820766E-10 largest value = 7.5161928E9 epsilon = 0.125
 | FloatToByte52 | floatToByte(b, mantissaBits=5, zeroExponent=2) smallest nonzero value = 0.033203125 largest value = 1984.0 epsilon = 0.03125
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SmallFloat Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Byte315ToFloat Method

SmallFloat Byte315ToFloat Method Lucene.Net Class Library
byteToFloat(b, mantissaBits=3, zeroExponent=15)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static float Byte315ToFloat(
    byte b
)
public static float Byte315ToFloat(
    byte b
)
Public Shared Function Byte315ToFloat ( _
    b As Byte _
) As Single
Public Shared Function Byte315ToFloat ( _
    b As Byte _
) As Single
public:
static float Byte315ToFloat(
    unsigned char b
)
public:
static float Byte315ToFloat(
    unsigned char b
)
Parameters
b
Type:   Online System Byte
See Also
SmallFloat Class
SmallFloat Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Byte52ToFloat Method

SmallFloat Byte52ToFloat Method Lucene.Net Class Library
byteToFloat(b, mantissaBits=5, zeroExponent=2)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static float Byte52ToFloat(
    byte b
)
public static float Byte52ToFloat(
    byte b
)
Public Shared Function Byte52ToFloat ( _
    b As Byte _
) As Single
Public Shared Function Byte52ToFloat ( _
    b As Byte _
) As Single
public:
static float Byte52ToFloat(
    unsigned char b
)
public:
static float Byte52ToFloat(
    unsigned char b
)
Parameters
b
Type:   Online System Byte
See Also
SmallFloat Class
SmallFloat Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteToFloat Method

SmallFloat ByteToFloat Method Lucene.Net Class Library
Converts an 8 bit float to a 32 bit float.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static float ByteToFloat(
    byte b,
    int numMantissaBits,
    int zeroExp
)
public static float ByteToFloat(
    byte b,
    int numMantissaBits,
    int zeroExp
)
Public Shared Function ByteToFloat ( _
    b As Byte, _
    numMantissaBits As Integer, _
    zeroExp As Integer _
) As Single
Public Shared Function ByteToFloat ( _
    b As Byte, _
    numMantissaBits As Integer, _
    zeroExp As Integer _
) As Single
public:
static float ByteToFloat(
    unsigned char b,
    int numMantissaBits,
    int zeroExp
)
public:
static float ByteToFloat(
    unsigned char b,
    int numMantissaBits,
    int zeroExp
)
Parameters
b
Type:   Online System Byte
numMantissaBits
Type:   Online System Int32
zeroExp
Type:   Online System Int32
See Also
SmallFloat Class
SmallFloat Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FloatToByte Method

SmallFloat FloatToByte Method Lucene.Net Class Library
Converts a 32 bit float to an 8 bit float.
Values less than zero are all mapped to zero.
Values are truncated (rounded down) to the nearest 8 bit value.
Values between zero and the smallest representable value are rounded up.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static sbyte FloatToByte(
    float f,
    int numMantissaBits,
    int zeroExp
)
public static sbyte FloatToByte(
    float f,
    int numMantissaBits,
    int zeroExp
)
Public Shared Function FloatToByte ( _
    f As Single, _
    numMantissaBits As Integer, _
    zeroExp As Integer _
) As SByte
Public Shared Function FloatToByte ( _
    f As Single, _
    numMantissaBits As Integer, _
    zeroExp As Integer _
) As SByte
public:
static signed char FloatToByte(
    float f,
    int numMantissaBits,
    int zeroExp
)
public:
static signed char FloatToByte(
    float f,
    int numMantissaBits,
    int zeroExp
)
Parameters
f
Type:   Online System Single
the 32 bit float to be converted to an 8 bit float (byte)

numMantissaBits
Type:   Online System Int32
the number of mantissa bits to use in the byte, with the remainder to be used in the exponent

zeroExp
Type:   Online System Int32
the zero-point in the range of exponent values

Return Value
 the 8 bit float representation

See Also
SmallFloat Class
SmallFloat Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FloatToByte315 Method

SmallFloat FloatToByte315 Method Lucene.Net Class Library
floatToByte(b, mantissaBits=3, zeroExponent=15)
smallest non-zero value = 5.820766E-10
largest value = 7.5161928E9
epsilon = 0.125

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static sbyte FloatToByte315(
    float f
)
public static sbyte FloatToByte315(
    float f
)
Public Shared Function FloatToByte315 ( _
    f As Single _
) As SByte
Public Shared Function FloatToByte315 ( _
    f As Single _
) As SByte
public:
static signed char FloatToByte315(
    float f
)
public:
static signed char FloatToByte315(
    float f
)
Parameters
f
Type:   Online System Single
See Also
SmallFloat Class
SmallFloat Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


FloatToByte52 Method

SmallFloat FloatToByte52 Method Lucene.Net Class Library
floatToByte(b, mantissaBits=5, zeroExponent=2)
smallest nonzero value = 0.033203125
largest value = 1984.0
epsilon = 0.03125

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static sbyte FloatToByte52(
    float f
)
public static sbyte FloatToByte52(
    float f
)
Public Shared Function FloatToByte52 ( _
    f As Single _
) As SByte
Public Shared Function FloatToByte52 ( _
    f As Single _
) As SByte
public:
static signed char FloatToByte52(
    float f
)
public:
static signed char FloatToByte52(
    float f
)
Parameters
f
Type:   Online System Single
See Also
SmallFloat Class
SmallFloat Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedVIntList Class

SortedVIntList Class Lucene.Net Class Library
Stores and iterate on sorted integers in compressed form in RAM.
The code for compressing the differences between ascending integers was borrowed from IndexInput and IndexOutput.

NOTE: this class assumes the stored integers are doc Ids (hence why it extends DocIdSet). Therefore its Iterator assumes NO_MORE_DOCS can be used as sentinel. If you intent to use this value, then make sure it's not used during search flow.
Inheritance Hierarchy
Online System Object
Lucene.Net.Search DocIdSet
Lucene.Net.Util SortedVIntList

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SortedVIntList : DocIdSet
public class SortedVIntList : DocIdSet
Public Class SortedVIntList _
    Inherits DocIdSet
Public Class SortedVIntList _
    Inherits DocIdSet
public ref class SortedVIntList : public DocIdSet
public ref class SortedVIntList : public DocIdSet
See Also
SortedVIntList Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedVIntList Members

SortedVIntList Members Lucene.Net Class Library

The SortedVIntList type exposes the following members.
Constructors
 | Name | Description
Public method | SortedVIntList(BitArray) | Create a SortedVIntList from a BitSet.
Public method | SortedVIntList( Int32 ) | Create a SortedVIntList from all elements of an array of integers.
Public method | SortedVIntList(DocIdSetIterator) | Create a SortedVIntList.
Public method | SortedVIntList(OpenBitSet) | Create a SortedVIntList from an OpenBitSet.
Public method | SortedVIntList( Int32 , Int32) | Create a SortedVIntList from an array of integers.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Iterator | (Overrides DocIdSet Iterator .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | ByteSize |
Public property | IsCacheable | This DocIdSet implementation is cacheable. (Overrides DocIdSet IsCacheable.)
Public property | Size |
Back to Top
See Also
SortedVIntList Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedVIntList Constructor

SortedVIntList Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | SortedVIntList(BitArray) | Create a SortedVIntList from a BitSet.
Public method | SortedVIntList( Int32 ) | Create a SortedVIntList from all elements of an array of integers.
Public method | SortedVIntList(DocIdSetIterator) | Create a SortedVIntList.
Public method | SortedVIntList(OpenBitSet) | Create a SortedVIntList from an OpenBitSet.
Public method | SortedVIntList( Int32 , Int32) | Create a SortedVIntList from an array of integers.
Back to Top
See Also
SortedVIntList Class
SortedVIntList Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedVIntList Constructor (BitArray)

SortedVIntList Constructor (BitArray) Lucene.Net Class Library
Create a SortedVIntList from a BitSet.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortedVIntList(
    BitArray bits
)
public SortedVIntList(
    BitArray bits
)
Public Sub New ( _
    bits As BitArray _
)
Public Sub New ( _
    bits As BitArray _
)
public:
SortedVIntList(
    BitArray^ bits
)
public:
SortedVIntList(
    BitArray^ bits
)
Parameters
bits
Type:   Online System.Collections BitArray
 A bit set representing a set of integers.

See Also
SortedVIntList Class
SortedVIntList Members
SortedVIntList Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedVIntList Constructor (Int32[])

SortedVIntList Constructor ( Int32 ) Lucene.Net Class Library
Create a SortedVIntList from all elements of an array of integers.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortedVIntList(
    params int[] sortedInts
)
public SortedVIntList(
    params int[] sortedInts
)
Public Sub New ( _
    ParamArray sortedInts As Integer() _
)
Public Sub New ( _
    ParamArray sortedInts As Integer() _
)
public:
SortedVIntList(
    ... array<int>^ sortedInts
)
public:
SortedVIntList(
    ... array<int>^ sortedInts
)
Parameters
sortedInts
Type:    Online System Int32
 A sorted array of non negative integers.

See Also
SortedVIntList Class
SortedVIntList Members
SortedVIntList Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedVIntList Constructor (DocIdSetIterator)

SortedVIntList Constructor (DocIdSetIterator) Lucene.Net Class Library
Create a SortedVIntList.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortedVIntList(
    DocIdSetIterator docIdSetIterator
)
public SortedVIntList(
    DocIdSetIterator docIdSetIterator
)
Public Sub New ( _
    docIdSetIterator As DocIdSetIterator _
)
Public Sub New ( _
    docIdSetIterator As DocIdSetIterator _
)
public:
SortedVIntList(
    DocIdSetIterator^ docIdSetIterator
)
public:
SortedVIntList(
    DocIdSetIterator^ docIdSetIterator
)
Parameters
docIdSetIterator
Type: Lucene.Net.Search DocIdSetIterator
 An iterator providing document numbers as a set of integers.
            This DocIdSetIterator is iterated completely when this constructor
            is called and it must provide the integers in non
            decreasing order.

See Also
SortedVIntList Class
SortedVIntList Members
SortedVIntList Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedVIntList Constructor (OpenBitSet)

SortedVIntList Constructor (OpenBitSet) Lucene.Net Class Library
Create a SortedVIntList from an OpenBitSet.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortedVIntList(
    OpenBitSet bits
)
public SortedVIntList(
    OpenBitSet bits
)
Public Sub New ( _
    bits As OpenBitSet _
)
Public Sub New ( _
    bits As OpenBitSet _
)
public:
SortedVIntList(
    OpenBitSet^ bits
)
public:
SortedVIntList(
    OpenBitSet^ bits
)
Parameters
bits
Type: Lucene.Net.Util OpenBitSet
 A bit set representing a set of integers.

See Also
SortedVIntList Class
SortedVIntList Members
SortedVIntList Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedVIntList Constructor (Int32[], Int32)

SortedVIntList Constructor ( Int32 , Int32) Lucene.Net Class Library
Create a SortedVIntList from an array of integers.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortedVIntList(
    int[] sortedInts,
    int inputSize
)
public SortedVIntList(
    int[] sortedInts,
    int inputSize
)
Public Sub New ( _
    sortedInts As Integer(), _
    inputSize As Integer _
)
Public Sub New ( _
    sortedInts As Integer(), _
    inputSize As Integer _
)
public:
SortedVIntList(
    array<int>^ sortedInts,
    int inputSize
)
public:
SortedVIntList(
    array<int>^ sortedInts,
    int inputSize
)
Parameters
sortedInts
Type:    Online System Int32
 An array of sorted non negative integers.

inputSize
Type:   Online System Int32
  The number of integers to be used from the array.

See Also
SortedVIntList Class
SortedVIntList Members
SortedVIntList Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedVIntList Methods

SortedVIntList Methods Lucene.Net Class Library
The SortedVIntList type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Iterator | (Overrides DocIdSet Iterator .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SortedVIntList Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Iterator Method

SortedVIntList Iterator Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DocIdSetIterator Iterator()
public override DocIdSetIterator Iterator()
Public Overrides Function Iterator As DocIdSetIterator
Public Overrides Function Iterator As DocIdSetIterator
public:
virtual DocIdSetIterator^ Iterator() override
public:
virtual DocIdSetIterator^ Iterator() override
Return Value
    An iterator over the sorted integers.

See Also
SortedVIntList Class
SortedVIntList Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SortedVIntList Properties

SortedVIntList Properties Lucene.Net Class Library
The SortedVIntList type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize |
Public property | IsCacheable | This DocIdSet implementation is cacheable. (Overrides DocIdSet IsCacheable.)
Public property | Size |
Back to Top
See Also
SortedVIntList Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ByteSize Property

SortedVIntList ByteSize Property Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int ByteSize { get; }
public virtual int ByteSize { get; }
Public Overridable ReadOnly Property ByteSize As Integer
    Get
Public Overridable ReadOnly Property ByteSize As Integer
    Get
public:
virtual property int ByteSize {
    int get ();
}
public:
virtual property int ByteSize {
    int get ();
}
Field Value
 The size of the byte array storing the compressed sorted integers.
See Also
SortedVIntList Class
SortedVIntList Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


IsCacheable Property

SortedVIntList IsCacheable Property Lucene.Net Class Library
This DocIdSet implementation is cacheable.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsCacheable { get; }
public override bool IsCacheable { get; }
Public Overrides ReadOnly Property IsCacheable As Boolean
    Get
Public Overrides ReadOnly Property IsCacheable As Boolean
    Get
public:
virtual property bool IsCacheable {
    bool get () override;
}
public:
virtual property bool IsCacheable {
    bool get () override;
}
See Also
SortedVIntList Class
SortedVIntList Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Size Property

SortedVIntList Size Property Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Size { get; }
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
public:
virtual property int Size {
    int get ();
}
Field Value
 The total number of sorted integers.
See Also
SortedVIntList Class
SortedVIntList Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SorterTemplate Class

SorterTemplate Class Lucene.Net Class Library
Borrowed from Cglib. Allows custom swap so that two arrays can be sorted at the same time.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util SorterTemplate

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class SorterTemplate
public abstract class SorterTemplate
Public MustInherit Class SorterTemplate
Public MustInherit Class SorterTemplate
public ref class SorterTemplate abstract
public ref class SorterTemplate abstract
See Also
SorterTemplate Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SorterTemplate Members

SorterTemplate Members Lucene.Net Class Library

The SorterTemplate type exposes the following members.
Constructors
 | Name | Description
Protected method | SorterTemplate | Initializes a new instance of the SorterTemplate class
Back to Top
Methods
 | Name | Description
Protected method | Compare |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | MergeSort |
Public method | QuickSort |
Protected method | Swap |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SorterTemplate Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SorterTemplate Constructor

SorterTemplate Constructor Lucene.Net Class Library
Initializes a new instance of the SorterTemplate class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SorterTemplate()
protected SorterTemplate()
Protected Sub New
Protected Sub New
protected:
SorterTemplate()
protected:
SorterTemplate()
See Also
SorterTemplate Class
SorterTemplate Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SorterTemplate Methods

SorterTemplate Methods Lucene.Net Class Library
The SorterTemplate type exposes the following members.
Methods
 | Name | Description
Protected method | Compare |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | MergeSort |
Public method | QuickSort |
Protected method | Swap |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SorterTemplate Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Compare Method

SorterTemplate Compare Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract int Compare(
    int i,
    int j
)
protected abstract int Compare(
    int i,
    int j
)
Protected MustOverride Function Compare ( _
    i As Integer, _
    j As Integer _
) As Integer
Protected MustOverride Function Compare ( _
    i As Integer, _
    j As Integer _
) As Integer
protected:
virtual int Compare(
    int i,
    int j
) abstract
protected:
virtual int Compare(
    int i,
    int j
) abstract
Parameters
i
Type:   Online System Int32
j
Type:   Online System Int32
See Also
SorterTemplate Class
SorterTemplate Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


MergeSort Method

SorterTemplate MergeSort Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void MergeSort(
    int lo,
    int hi
)
protected virtual void MergeSort(
    int lo,
    int hi
)
Protected Overridable Sub MergeSort ( _
    lo As Integer, _
    hi As Integer _
)
Protected Overridable Sub MergeSort ( _
    lo As Integer, _
    hi As Integer _
)
protected:
virtual void MergeSort(
    int lo,
    int hi
)
protected:
virtual void MergeSort(
    int lo,
    int hi
)
Parameters
lo
Type:   Online System Int32
hi
Type:   Online System Int32
See Also
SorterTemplate Class
SorterTemplate Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


QuickSort Method

SorterTemplate QuickSort Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void QuickSort(
    int lo,
    int hi
)
public virtual void QuickSort(
    int lo,
    int hi
)
Public Overridable Sub QuickSort ( _
    lo As Integer, _
    hi As Integer _
)
Public Overridable Sub QuickSort ( _
    lo As Integer, _
    hi As Integer _
)
public:
virtual void QuickSort(
    int lo,
    int hi
)
public:
virtual void QuickSort(
    int lo,
    int hi
)
Parameters
lo
Type:   Online System Int32
hi
Type:   Online System Int32
See Also
SorterTemplate Class
SorterTemplate Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Swap Method

SorterTemplate Swap Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void Swap(
    int i,
    int j
)
protected abstract void Swap(
    int i,
    int j
)
Protected MustOverride Sub Swap ( _
    i As Integer, _
    j As Integer _
)
Protected MustOverride Sub Swap ( _
    i As Integer, _
    j As Integer _
)
protected:
virtual void Swap(
    int i,
    int j
) abstract
protected:
virtual void Swap(
    int i,
    int j
) abstract
Parameters
i
Type:   Online System Int32
j
Type:   Online System Int32
See Also
SorterTemplate Class
SorterTemplate Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringHelper Class

StringHelper Class Lucene.Net Class Library
Methods for manipulating strings.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util StringHelper

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class StringHelper
public abstract class StringHelper
Public MustInherit Class StringHelper
Public MustInherit Class StringHelper
public ref class StringHelper abstract
public ref class StringHelper abstract
See Also
StringHelper Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringHelper Members

StringHelper Members Lucene.Net Class Library

The StringHelper type exposes the following members.
Methods
 | Name | Description
 | BytesDifference | Compares two byte[] arrays, element by element, and returns the number of elements common to both arrays.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Intern | Return the same string object for all equal strings
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | StringDifference | Compares two strings, character by character, and returns the first position where the two strings differ from one another.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
Name | Description
interner | Expert: The StringInterner implementation used by Lucene. This shouldn't be changed to an incompatible implementation after other Lucene APIs have been used.
Back to Top
See Also
StringHelper Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringHelper Fields

StringHelper Fields Lucene.Net Class Library
The StringHelper type exposes the following members.
Fields
Name | Description
interner | Expert: The StringInterner implementation used by Lucene. This shouldn't be changed to an incompatible implementation after other Lucene APIs have been used.
Back to Top
See Also
StringHelper Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


interner Field

StringHelper interner Field Lucene.Net Class Library
Expert: The StringInterner implementation used by Lucene. This shouldn't be changed to an incompatible implementation after other Lucene APIs have been used.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static StringInterner interner
public static StringInterner interner
Public Shared interner As StringInterner
Public Shared interner As StringInterner
public:
static StringInterner^ interner
public:
static StringInterner^ interner
See Also
StringHelper Class
StringHelper Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringHelper Methods

StringHelper Methods Lucene.Net Class Library
The StringHelper type exposes the following members.
Methods
 | Name | Description
 | BytesDifference | Compares two byte[] arrays, element by element, and returns the number of elements common to both arrays.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Intern | Return the same string object for all equal strings
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | StringDifference | Compares two strings, character by character, and returns the first position where the two strings differ from one another.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
StringHelper Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


BytesDifference Method

StringHelper BytesDifference Method Lucene.Net Class Library
Compares two byte[] arrays, element by element, and returns the number of elements common to both arrays.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int BytesDifference(
    byte[] bytes1,
    int len1,
    byte[] bytes2,
    int len2
)
public static int BytesDifference(
    byte[] bytes1,
    int len1,
    byte[] bytes2,
    int len2
)
Public Shared Function BytesDifference ( _
    bytes1 As Byte(), _
    len1 As Integer, _
    bytes2 As Byte(), _
    len2 As Integer _
) As Integer
Public Shared Function BytesDifference ( _
    bytes1 As Byte(), _
    len1 As Integer, _
    bytes2 As Byte(), _
    len2 As Integer _
) As Integer
public:
static int BytesDifference(
    array<unsigned char>^ bytes1,
    int len1,
    array<unsigned char>^ bytes2,
    int len2
)
public:
static int BytesDifference(
    array<unsigned char>^ bytes1,
    int len1,
    array<unsigned char>^ bytes2,
    int len2
)
Parameters
bytes1
Type:    Online System Byte
The first byte[] to compare

len1
Type:   Online System Int32
bytes2
Type:    Online System Byte
The second byte[] to compare

len2
Type:   Online System Int32
Return Value
 The number of common elements.

See Also
StringHelper Class
StringHelper Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Intern Method

StringHelper Intern Method Lucene.Net Class Library
Return the same string object for all equal strings

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Intern(
    string s
)
public static string Intern(
    string s
)
Public Shared Function Intern ( _
    s As String _
) As String
Public Shared Function Intern ( _
    s As String _
) As String
public:
static String^ Intern(
    String^ s
)
public:
static String^ Intern(
    String^ s
)
Parameters
s
Type:   Online System String
See Also
StringHelper Class
StringHelper Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringDifference Method

StringHelper StringDifference Method Lucene.Net Class Library
Compares two strings, character by character, and returns the first position where the two strings differ from one another.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int StringDifference(
    string s1,
    string s2
)
public static int StringDifference(
    string s1,
    string s2
)
Public Shared Function StringDifference ( _
    s1 As String, _
    s2 As String _
) As Integer
Public Shared Function StringDifference ( _
    s1 As String, _
    s2 As String _
) As Integer
public:
static int StringDifference(
    String^ s1,
    String^ s2
)
public:
static int StringDifference(
    String^ s1,
    String^ s2
)
Parameters
s1
Type:   Online System String
The first string to compare

s2
Type:   Online System String
The second string to compare

Return Value
 The first position where the two strings differ.

See Also
StringHelper Class
StringHelper Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringInterner Class

StringInterner Class Lucene.Net Class Library
Subclasses of StringInterner are required to return the same single String object for all equal strings. Depending on the implementation, this may not be the same object returned as String.intern(). This StringInterner base class simply delegates to String.intern().
Inheritance Hierarchy
Online System Object
Lucene.Net.Util StringInterner
Lucene.Net.Util SimpleStringInterner

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class StringInterner
public class StringInterner
Public Class StringInterner
Public Class StringInterner
public ref class StringInterner
public ref class StringInterner
See Also
StringInterner Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringInterner Members

StringInterner Members Lucene.Net Class Library

The StringInterner type exposes the following members.
Constructors
 | Name | Description
Public method | StringInterner | Initializes a new instance of the StringInterner class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Intern(String) | Returns a single object instance for each equal string.
Public method | Intern( Char , Int32, Int32) | Returns a single object instance for each equal string.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
StringInterner Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringInterner Constructor

StringInterner Constructor Lucene.Net Class Library
Initializes a new instance of the StringInterner class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StringInterner()
public StringInterner()
Public Sub New
Public Sub New
public:
StringInterner()
public:
StringInterner()
See Also
StringInterner Class
StringInterner Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


StringInterner Methods

StringInterner Methods Lucene.Net Class Library
The StringInterner type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Intern(String) | Returns a single object instance for each equal string.
Public method | Intern( Char , Int32, Int32) | Returns a single object instance for each equal string.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
StringInterner Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Intern Method

StringInterner Intern Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Intern(String) | Returns a single object instance for each equal string.
Public method | Intern( Char , Int32, Int32) | Returns a single object instance for each equal string.
Back to Top
See Also
StringInterner Class
StringInterner Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Intern Method (String)

StringInterner Intern Method (String) Lucene.Net Class Library
Returns a single object instance for each equal string.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Intern(
    string s
)
public virtual string Intern(
    string s
)
Public Overridable Function Intern ( _
    s As String _
) As String
Public Overridable Function Intern ( _
    s As String _
) As String
public:
virtual String^ Intern(
    String^ s
)
public:
virtual String^ Intern(
    String^ s
)
Parameters
s
Type:   Online System String
See Also
StringInterner Class
StringInterner Members
Intern Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Intern Method (Char[], Int32, Int32)

StringInterner Intern Method ( Char , Int32, Int32) Lucene.Net Class Library
Returns a single object instance for each equal string.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Intern(
    char[] arr,
    int offset,
    int len
)
public virtual string Intern(
    char[] arr,
    int offset,
    int len
)
Public Overridable Function Intern ( _
    arr As Char(), _
    offset As Integer, _
    len As Integer _
) As String
Public Overridable Function Intern ( _
    arr As Char(), _
    offset As Integer, _
    len As Integer _
) As String
public:
virtual String^ Intern(
    array<wchar_t>^ arr,
    int offset,
    int len
)
public:
virtual String^ Intern(
    array<wchar_t>^ arr,
    int offset,
    int len
)
Parameters
arr
Type:    Online System Char
offset
Type:   Online System Int32
len
Type:   Online System Int32
See Also
StringInterner Class
StringInterner Members
Intern Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToStringUtils Class

ToStringUtils Class Lucene.Net Class Library
Helper methods to ease implementing Online ToString .
Inheritance Hierarchy
Online System Object
Lucene.Net.Util ToStringUtils

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ToStringUtils
public class ToStringUtils
Public Class ToStringUtils
Public Class ToStringUtils
public ref class ToStringUtils
public ref class ToStringUtils
See Also
ToStringUtils Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToStringUtils Members

ToStringUtils Members Lucene.Net Class Library

The ToStringUtils type exposes the following members.
Constructors
 | Name | Description
Public method | ToStringUtils | Initializes a new instance of the ToStringUtils class
Back to Top
Methods
 | Name | Description
 | Boost | for printing boost only if not 1.0
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ToStringUtils Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToStringUtils Constructor

ToStringUtils Constructor Lucene.Net Class Library
Initializes a new instance of the ToStringUtils class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ToStringUtils()
public ToStringUtils()
Public Sub New
Public Sub New
public:
ToStringUtils()
public:
ToStringUtils()
See Also
ToStringUtils Class
ToStringUtils Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ToStringUtils Methods

ToStringUtils Methods Lucene.Net Class Library
The ToStringUtils type exposes the following members.
Methods
 | Name | Description
 | Boost | for printing boost only if not 1.0
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
ToStringUtils Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Boost Method

ToStringUtils Boost Method Lucene.Net Class Library
for printing boost only if not 1.0

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Boost(
    float boost
)
public static string Boost(
    float boost
)
Public Shared Function Boost ( _
    boost As Single _
) As String
Public Shared Function Boost ( _
    boost As Single _
) As String
public:
static String^ Boost(
    float boost
)
public:
static String^ Boost(
    float boost
)
Parameters
boost
Type:   Online System Single
See Also
ToStringUtils Class
ToStringUtils Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UnicodeUtil Class

UnicodeUtil Class Lucene.Net Class Library
Class to encode java's UTF16 char[] into UTF8 byte[] without always allocating a new byte[] as String.getBytes("UTF-8") does.

WARNING: This API is a new and experimental and may suddenly change.

Inheritance Hierarchy
Online System Object
Lucene.Net.Util UnicodeUtil

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class UnicodeUtil
public static class UnicodeUtil
Public NotInheritable Class UnicodeUtil
Public NotInheritable Class UnicodeUtil
public ref class UnicodeUtil abstract sealed
public ref class UnicodeUtil abstract sealed
See Also
UnicodeUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UnicodeUtil Members

UnicodeUtil Members Lucene.Net Class Library

The UnicodeUtil type exposes the following members.
Methods
Name | Description
UTF16toUTF8( Char , Int32, UnicodeUtil UTF8Result) | Encode characters from a char[] source, starting at offset and stopping when the character 0xffff is seen. Returns the number of bytes written to bytesOut.
UTF16toUTF8( Char , Int32, Int32, UnicodeUtil UTF8Result) | Encode characters from a char[] source, starting at offset for length chars. Returns the number of bytes written to bytesOut.
UTF16toUTF8(String, Int32, Int32, UnicodeUtil UTF8Result) | Encode characters from this String, starting at offset for length characters. Returns the number of bytes written to bytesOut.
UTF8toUTF16 | Convert UTF8 bytes into UTF16 characters. If offset is non-zero, conversion starts at that starting point in utf8, re-using the results from the previous call up until offset.
Back to Top
Fields
Name | Description
UNI_REPLACEMENT_CHAR |
UNI_SUR_HIGH_END |
UNI_SUR_HIGH_START |
UNI_SUR_LOW_END |
UNI_SUR_LOW_START |
Back to Top
See Also
UnicodeUtil Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UnicodeUtil Fields

UnicodeUtil Fields Lucene.Net Class Library
The UnicodeUtil type exposes the following members.
Fields
Name | Description
UNI_REPLACEMENT_CHAR |
UNI_SUR_HIGH_END |
UNI_SUR_HIGH_START |
UNI_SUR_LOW_END |
UNI_SUR_LOW_START |
Back to Top
See Also
UnicodeUtil Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UNI_REPLACEMENT_CHAR Field

UnicodeUtil UNI_REPLACEMENT_CHAR Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int UNI_REPLACEMENT_CHAR
public const int UNI_REPLACEMENT_CHAR
Public Const UNI_REPLACEMENT_CHAR As Integer
Public Const UNI_REPLACEMENT_CHAR As Integer
public:
literal int UNI_REPLACEMENT_CHAR
public:
literal int UNI_REPLACEMENT_CHAR
See Also
UnicodeUtil Class
UnicodeUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UNI_SUR_HIGH_END Field

UnicodeUtil UNI_SUR_HIGH_END Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int UNI_SUR_HIGH_END
public const int UNI_SUR_HIGH_END
Public Const UNI_SUR_HIGH_END As Integer
Public Const UNI_SUR_HIGH_END As Integer
public:
literal int UNI_SUR_HIGH_END
public:
literal int UNI_SUR_HIGH_END
See Also
UnicodeUtil Class
UnicodeUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UNI_SUR_HIGH_START Field

UnicodeUtil UNI_SUR_HIGH_START Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int UNI_SUR_HIGH_START
public const int UNI_SUR_HIGH_START
Public Const UNI_SUR_HIGH_START As Integer
Public Const UNI_SUR_HIGH_START As Integer
public:
literal int UNI_SUR_HIGH_START
public:
literal int UNI_SUR_HIGH_START
See Also
UnicodeUtil Class
UnicodeUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UNI_SUR_LOW_END Field

UnicodeUtil UNI_SUR_LOW_END Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int UNI_SUR_LOW_END
public const int UNI_SUR_LOW_END
Public Const UNI_SUR_LOW_END As Integer
Public Const UNI_SUR_LOW_END As Integer
public:
literal int UNI_SUR_LOW_END
public:
literal int UNI_SUR_LOW_END
See Also
UnicodeUtil Class
UnicodeUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UNI_SUR_LOW_START Field

UnicodeUtil UNI_SUR_LOW_START Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int UNI_SUR_LOW_START
public const int UNI_SUR_LOW_START
Public Const UNI_SUR_LOW_START As Integer
Public Const UNI_SUR_LOW_START As Integer
public:
literal int UNI_SUR_LOW_START
public:
literal int UNI_SUR_LOW_START
See Also
UnicodeUtil Class
UnicodeUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UnicodeUtil Methods

UnicodeUtil Methods Lucene.Net Class Library
The UnicodeUtil type exposes the following members.
Methods
Name | Description
UTF16toUTF8( Char , Int32, UnicodeUtil UTF8Result) | Encode characters from a char[] source, starting at offset and stopping when the character 0xffff is seen. Returns the number of bytes written to bytesOut.
UTF16toUTF8( Char , Int32, Int32, UnicodeUtil UTF8Result) | Encode characters from a char[] source, starting at offset for length chars. Returns the number of bytes written to bytesOut.
UTF16toUTF8(String, Int32, Int32, UnicodeUtil UTF8Result) | Encode characters from this String, starting at offset for length characters. Returns the number of bytes written to bytesOut.
UTF8toUTF16 | Convert UTF8 bytes into UTF16 characters. If offset is non-zero, conversion starts at that starting point in utf8, re-using the results from the previous call up until offset.
Back to Top
See Also
UnicodeUtil Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UTF16toUTF8 Method

UnicodeUtil UTF16toUTF8 Method Lucene.Net Class Library
Overload List
Name | Description
UTF16toUTF8( Char , Int32, UnicodeUtil UTF8Result) | Encode characters from a char[] source, starting at offset and stopping when the character 0xffff is seen. Returns the number of bytes written to bytesOut.
UTF16toUTF8( Char , Int32, Int32, UnicodeUtil UTF8Result) | Encode characters from a char[] source, starting at offset for length chars. Returns the number of bytes written to bytesOut.
UTF16toUTF8(String, Int32, Int32, UnicodeUtil UTF8Result) | Encode characters from this String, starting at offset for length characters. Returns the number of bytes written to bytesOut.
Back to Top
See Also
UnicodeUtil Class
UnicodeUtil Members
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UTF16toUTF8 Method (Char[], Int32, UnicodeUtil.UTF8Result)

UnicodeUtil UTF16toUTF8 Method ( Char , Int32, UnicodeUtil UTF8Result) Lucene.Net Class Library
Encode characters from a char[] source, starting at offset and stopping when the character 0xffff is seen. Returns the number of bytes written to bytesOut.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void UTF16toUTF8(
    char[] source,
    int offset,
    UnicodeUtil..::..UTF8Result result
)
public static void UTF16toUTF8(
    char[] source,
    int offset,
    UnicodeUtil..::..UTF8Result result
)
Public Shared Sub UTF16toUTF8 ( _
    source As Char(), _
    offset As Integer, _
    result As UnicodeUtil..::..UTF8Result _
)
Public Shared Sub UTF16toUTF8 ( _
    source As Char(), _
    offset As Integer, _
    result As UnicodeUtil..::..UTF8Result _
)
public:
static void UTF16toUTF8(
    array<wchar_t>^ source,
    int offset,
    UnicodeUtil..::..UTF8Result^ result
)
public:
static void UTF16toUTF8(
    array<wchar_t>^ source,
    int offset,
    UnicodeUtil..::..UTF8Result^ result
)
Parameters
source
Type:    Online System Char
offset
Type:   Online System Int32
result
Type: Lucene.Net.Util UnicodeUtil UTF8Result
See Also
UnicodeUtil Class
UnicodeUtil Members
UTF16toUTF8 Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UTF16toUTF8 Method (Char[], Int32, Int32, UnicodeUtil.UTF8Result)

UnicodeUtil UTF16toUTF8 Method ( Char , Int32, Int32, UnicodeUtil UTF8Result) Lucene.Net Class Library
Encode characters from a char[] source, starting at offset for length chars. Returns the number of bytes written to bytesOut.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void UTF16toUTF8(
    char[] source,
    int offset,
    int length,
    UnicodeUtil..::..UTF8Result result
)
public static void UTF16toUTF8(
    char[] source,
    int offset,
    int length,
    UnicodeUtil..::..UTF8Result result
)
Public Shared Sub UTF16toUTF8 ( _
    source As Char(), _
    offset As Integer, _
    length As Integer, _
    result As UnicodeUtil..::..UTF8Result _
)
Public Shared Sub UTF16toUTF8 ( _
    source As Char(), _
    offset As Integer, _
    length As Integer, _
    result As UnicodeUtil..::..UTF8Result _
)
public:
static void UTF16toUTF8(
    array<wchar_t>^ source,
    int offset,
    int length,
    UnicodeUtil..::..UTF8Result^ result
)
public:
static void UTF16toUTF8(
    array<wchar_t>^ source,
    int offset,
    int length,
    UnicodeUtil..::..UTF8Result^ result
)
Parameters
source
Type:    Online System Char
offset
Type:   Online System Int32
length
Type:   Online System Int32
result
Type: Lucene.Net.Util UnicodeUtil UTF8Result
See Also
UnicodeUtil Class
UnicodeUtil Members
UTF16toUTF8 Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UTF16toUTF8 Method (String, Int32, Int32, UnicodeUtil.UTF8Result)

UnicodeUtil UTF16toUTF8 Method (String, Int32, Int32, UnicodeUtil UTF8Result) Lucene.Net Class Library
Encode characters from this String, starting at offset for length characters. Returns the number of bytes written to bytesOut.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void UTF16toUTF8(
    string s,
    int offset,
    int length,
    UnicodeUtil..::..UTF8Result result
)
public static void UTF16toUTF8(
    string s,
    int offset,
    int length,
    UnicodeUtil..::..UTF8Result result
)
Public Shared Sub UTF16toUTF8 ( _
    s As String, _
    offset As Integer, _
    length As Integer, _
    result As UnicodeUtil..::..UTF8Result _
)
Public Shared Sub UTF16toUTF8 ( _
    s As String, _
    offset As Integer, _
    length As Integer, _
    result As UnicodeUtil..::..UTF8Result _
)
public:
static void UTF16toUTF8(
    String^ s,
    int offset,
    int length,
    UnicodeUtil..::..UTF8Result^ result
)
public:
static void UTF16toUTF8(
    String^ s,
    int offset,
    int length,
    UnicodeUtil..::..UTF8Result^ result
)
Parameters
s
Type:   Online System String
offset
Type:   Online System Int32
length
Type:   Online System Int32
result
Type: Lucene.Net.Util UnicodeUtil UTF8Result
See Also
UnicodeUtil Class
UnicodeUtil Members
UTF16toUTF8 Overload
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UTF8toUTF16 Method

UnicodeUtil UTF8toUTF16 Method Lucene.Net Class Library
Convert UTF8 bytes into UTF16 characters. If offset is non-zero, conversion starts at that starting point in utf8, re-using the results from the previous call up until offset.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void UTF8toUTF16(
    byte[] utf8,
    int offset,
    int length,
    UnicodeUtil..::..UTF16Result result
)
public static void UTF8toUTF16(
    byte[] utf8,
    int offset,
    int length,
    UnicodeUtil..::..UTF16Result result
)
Public Shared Sub UTF8toUTF16 ( _
    utf8 As Byte(), _
    offset As Integer, _
    length As Integer, _
    result As UnicodeUtil..::..UTF16Result _
)
Public Shared Sub UTF8toUTF16 ( _
    utf8 As Byte(), _
    offset As Integer, _
    length As Integer, _
    result As UnicodeUtil..::..UTF16Result _
)
public:
static void UTF8toUTF16(
    array<unsigned char>^ utf8,
    int offset,
    int length,
    UnicodeUtil..::..UTF16Result^ result
)
public:
static void UTF8toUTF16(
    array<unsigned char>^ utf8,
    int offset,
    int length,
    UnicodeUtil..::..UTF16Result^ result
)
Parameters
utf8
Type:    Online System Byte
offset
Type:   Online System Int32
length
Type:   Online System Int32
result
Type: Lucene.Net.Util UnicodeUtil UTF16Result
See Also
UnicodeUtil Class
UnicodeUtil Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UnicodeUtil.UTF16Result Class

UnicodeUtil UTF16Result Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Util UnicodeUtil UTF16Result

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class UTF16Result
public sealed class UTF16Result
Public NotInheritable Class UTF16Result
Public NotInheritable Class UTF16Result
public ref class UTF16Result sealed
public ref class UTF16Result sealed
See Also
UnicodeUtil UTF16Result Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UnicodeUtil.UTF16Result Members

UnicodeUtil UTF16Result Members Lucene.Net Class Library

Class to encode java's UTF16 char[] into UTF8 byte[] without always allocating a new byte[] as String.getBytes("UTF-8") does.

WARNING: This API is a new and experimental and may suddenly change.

The UnicodeUtil UTF16Result type exposes the following members.
Constructors
 | Name | Description
Public method | UnicodeUtil UTF16Result | Initializes a new instance of the UnicodeUtil UTF16Result class
Back to Top
Methods
 | Name | Description
Public method | CopyText |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetLength |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Public field | length |
Public field | offsets |
Public field | result |
Back to Top
See Also
UnicodeUtil UTF16Result Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UnicodeUtil.UTF16Result Constructor

UnicodeUtil UTF16Result Constructor Lucene.Net Class Library
Initializes a new instance of the UnicodeUtil UTF16Result class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UTF16Result()
public UTF16Result()
Public Sub New
Public Sub New
public:
UTF16Result()
public:
UTF16Result()
See Also
UnicodeUtil UTF16Result Class
UnicodeUtil UTF16Result Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UnicodeUtil.UTF16Result Fields

UnicodeUtil UTF16Result Fields Lucene.Net Class Library
The UnicodeUtil UTF16Result type exposes the following members.
Fields
 | Name | Description
Public field | length |
Public field | offsets |
Public field | result |
Back to Top
See Also
UnicodeUtil UTF16Result Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


length Field

UnicodeUtil UTF16Result length Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int length
public int length
Public length As Integer
Public length As Integer
public:
int length
public:
int length
See Also
UnicodeUtil UTF16Result Class
UnicodeUtil UTF16Result Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


offsets Field

UnicodeUtil UTF16Result offsets Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int[] offsets
public int[] offsets
Public offsets As Integer()
Public offsets As Integer()
public:
array<int>^ offsets
public:
array<int>^ offsets
See Also
UnicodeUtil UTF16Result Class
UnicodeUtil UTF16Result Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


result Field

UnicodeUtil UTF16Result result Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char[] result
public char[] result
Public result As Char()
Public result As Char()
public:
array<wchar_t>^ result
public:
array<wchar_t>^ result
See Also
UnicodeUtil UTF16Result Class
UnicodeUtil UTF16Result Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UnicodeUtil.UTF16Result Methods

UnicodeUtil UTF16Result Methods Lucene.Net Class Library
The UnicodeUtil UTF16Result type exposes the following members.
Methods
 | Name | Description
Public method | CopyText |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetLength |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
UnicodeUtil UTF16Result Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


CopyText Method

UnicodeUtil UTF16Result CopyText Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CopyText(
    UnicodeUtil..::..UTF16Result other
)
public void CopyText(
    UnicodeUtil..::..UTF16Result other
)
Public Sub CopyText ( _
    other As UnicodeUtil..::..UTF16Result _
)
Public Sub CopyText ( _
    other As UnicodeUtil..::..UTF16Result _
)
public:
void CopyText(
    UnicodeUtil..::..UTF16Result^ other
)
public:
void CopyText(
    UnicodeUtil..::..UTF16Result^ other
)
Parameters
other
Type: Lucene.Net.Util UnicodeUtil UTF16Result
See Also
UnicodeUtil UTF16Result Class
UnicodeUtil UTF16Result Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetLength Method

UnicodeUtil UTF16Result SetLength Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetLength(
    int newLength
)
public void SetLength(
    int newLength
)
Public Sub SetLength ( _
    newLength As Integer _
)
Public Sub SetLength ( _
    newLength As Integer _
)
public:
void SetLength(
    int newLength
)
public:
void SetLength(
    int newLength
)
Parameters
newLength
Type:   Online System Int32
See Also
UnicodeUtil UTF16Result Class
UnicodeUtil UTF16Result Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UnicodeUtil.UTF8Result Class

UnicodeUtil UTF8Result Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Util UnicodeUtil UTF8Result

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class UTF8Result
public sealed class UTF8Result
Public NotInheritable Class UTF8Result
Public NotInheritable Class UTF8Result
public ref class UTF8Result sealed
public ref class UTF8Result sealed
See Also
UnicodeUtil UTF8Result Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UnicodeUtil.UTF8Result Members

UnicodeUtil UTF8Result Members Lucene.Net Class Library

Class to encode java's UTF16 char[] into UTF8 byte[] without always allocating a new byte[] as String.getBytes("UTF-8") does.

WARNING: This API is a new and experimental and may suddenly change.

The UnicodeUtil UTF8Result type exposes the following members.
Constructors
 | Name | Description
Public method | UnicodeUtil UTF8Result | Initializes a new instance of the UnicodeUtil UTF8Result class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetLength |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Public field | length |
Public field | result |
Back to Top
See Also
UnicodeUtil UTF8Result Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UnicodeUtil.UTF8Result Constructor

UnicodeUtil UTF8Result Constructor Lucene.Net Class Library
Initializes a new instance of the UnicodeUtil UTF8Result class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UTF8Result()
public UTF8Result()
Public Sub New
Public Sub New
public:
UTF8Result()
public:
UTF8Result()
See Also
UnicodeUtil UTF8Result Class
UnicodeUtil UTF8Result Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UnicodeUtil.UTF8Result Fields

UnicodeUtil UTF8Result Fields Lucene.Net Class Library
The UnicodeUtil UTF8Result type exposes the following members.
Fields
 | Name | Description
Public field | length |
Public field | result |
Back to Top
See Also
UnicodeUtil UTF8Result Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


length Field

UnicodeUtil UTF8Result length Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int length
public int length
Public length As Integer
Public length As Integer
public:
int length
public:
int length
See Also
UnicodeUtil UTF8Result Class
UnicodeUtil UTF8Result Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


result Field

UnicodeUtil UTF8Result result Field Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] result
public byte[] result
Public result As Byte()
Public result As Byte()
public:
array<unsigned char>^ result
public:
array<unsigned char>^ result
See Also
UnicodeUtil UTF8Result Class
UnicodeUtil UTF8Result Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


UnicodeUtil.UTF8Result Methods

UnicodeUtil UTF8Result Methods Lucene.Net Class Library
The UnicodeUtil UTF8Result type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetLength |
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
UnicodeUtil UTF8Result Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SetLength Method

UnicodeUtil UTF8Result SetLength Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetLength(
    int newLength
)
public void SetLength(
    int newLength
)
Public Sub SetLength ( _
    newLength As Integer _
)
Public Sub SetLength ( _
    newLength As Integer _
)
public:
void SetLength(
    int newLength
)
public:
void SetLength(
    int newLength
)
Parameters
newLength
Type:   Online System Int32
See Also
UnicodeUtil UTF8Result Class
UnicodeUtil UTF8Result Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Version Enumeration

Version Enumeration Lucene.Net Class Library
Use by certain classes to match version compatibility across releases of Lucene.

WARNING: When changing the version parameter that you supply to components in Lucene, do not simply change the version at search-time, but instead also adjust your indexing code to match, and re-index.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Version
public enum Version
Public Enumeration Version
Public Enumeration Version
public enum class Version
public enum class Version
Members
Member name | Value | Description
LUCENE_20 | 0 | Match settings and bugs in Lucene's 2.0 release.
LUCENE_21 | 1 | Match settings and bugs in Lucene's 2.1 release.
LUCENE_22 | 2 | Match settings and bugs in Lucene's 2.2 release.
LUCENE_23 | 3 | Match settings and bugs in Lucene's 2.3 release.
LUCENE_24 | 4 | Match settings and bugs in Lucene's 2.4 release.
LUCENE_29 | 5 | Match settings and bugs in Lucene's 2.9 release.
LUCENE_30 | 6 | Match settings and bugs in Lucene's 3.0 release. Use this to get the latest and greatest settings, bug fixes, etc, for Lucene.
LUCENE_CURRENT | 7 | Obsolete. WARNING: if you use this setting, and then upgrade to a newer release of Lucene, sizable changes may happen. If precise back compatibility is important then you should instead explicitly specify an actual version. If you use this constant then you may need to re-index all of your documents when upgrading Lucene, as the way text is indexed may have changed. Additionally, you may need to re-test your entire application to ensure it behaves as expected, as some defaults may have changed and may break functionality in your application.
See Also
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


VersionEnumExtensions Class

VersionEnumExtensions Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Util VersionEnumExtensions

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class VersionEnumExtensions
public static class VersionEnumExtensions
<ExtensionAttribute> _
Public NotInheritable Class VersionEnumExtensions
<ExtensionAttribute> _
Public NotInheritable Class VersionEnumExtensions
[ExtensionAttribute]
public ref class VersionEnumExtensions abstract sealed
[ExtensionAttribute]
public ref class VersionEnumExtensions abstract sealed
See Also
VersionEnumExtensions Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


VersionEnumExtensions Members

VersionEnumExtensions Members Lucene.Net Class Library

The VersionEnumExtensions type exposes the following members.
Methods
Name | Description
OnOrAfter |
Back to Top
See Also
VersionEnumExtensions Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


VersionEnumExtensions Methods

VersionEnumExtensions Methods Lucene.Net Class Library
The VersionEnumExtensions type exposes the following members.
Methods
Name | Description
OnOrAfter |
Back to Top
See Also
VersionEnumExtensions Class
Lucene.Net.Util Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


OnOrAfter Method

VersionEnumExtensions OnOrAfter Method Lucene.Net Class Library

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool OnOrAfter(
    this Version first,
    Version other
)
public static bool OnOrAfter(
    this Version first,
    Version other
)
<ExtensionAttribute> _
Public Shared Function OnOrAfter ( _
    first As Version, _
    other As Version _
) As Boolean
<ExtensionAttribute> _
Public Shared Function OnOrAfter ( _
    first As Version, _
    other As Version _
) As Boolean
public:
[ExtensionAttribute]
static bool OnOrAfter(
    Version first,
    Version other
)
public:
[ExtensionAttribute]
static bool OnOrAfter(
    Version first,
    Version other
)
Parameters
first
Type: Lucene.Net.Util Version
other
Type: Lucene.Net.Util Version
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type Version. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
VersionEnumExtensions Class
VersionEnumExtensions Members
Lucene.Net.Util Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Lucene.Net.Util.Cache Namespace

Lucene.Net.Util.Cache Namespace Lucene.Net Class Library
Classes
 | Class | Description
Public class | Cache TKey, TValue | Base class for cache implementations.
Public class | SimpleLRUCache TKey, TValue |
Public class | SimpleMapCache TKey, TValue | Simple cache implementation that uses a HashMap to store (key, value) pairs. This cache is not synchronized, use SynchronizedCache(Cache TKey, TValue ) if needed.

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Cache(TKey, TValue) Class

Cache TKey, TValue Class Lucene.Net Class Library
Base class for cache implementations.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util.Cache Cache TKey, TValue
Lucene.Net.Util.Cache SimpleMapCache TKey, TValue

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Cache<TKey, TValue> : IDisposable
public abstract class Cache<TKey, TValue> : IDisposable
Public MustInherit Class Cache(Of TKey, TValue) _
    Implements IDisposable
Public MustInherit Class Cache(Of TKey, TValue) _
    Implements IDisposable
generic<typename TKey, typename TValue>
public ref class Cache abstract : IDisposable
generic<typename TKey, typename TValue>
public ref class Cache abstract : IDisposable
Type Parameters
TKey
TValue
See Also
Cache TKey, TValue  Members
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Cache(TKey, TValue) Members

Cache TKey, TValue Members Lucene.Net Class Library

The Cache TKey, TValue type exposes the following members.
Constructors
 | Name | Description
Protected method | Cache TKey, TValue | Initializes a new instance of the Cache TKey, TValue class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the cache.
Public method | ContainsKey | Returns whether the given key is in this cache.
Public method | Dispose | Releases all resources used by the Cache TKey, TValue
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Cache TKey, TValue and optionally releases the managed resources
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | Returns the value for the given key.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Put | Puts a (key, value)-pair into the cache.
 | SynchronizedCache | Returns a thread-safe cache backed by the specified cache. In order to guarantee thread-safety, all access to the backed cache must be accomplished through the returned cache.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Cache TKey, TValue Class
Lucene.Net.Util.Cache Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Cache(TKey, TValue) Constructor

Cache TKey, TValue Constructor Lucene.Net Class Library
Initializes a new instance of the Cache TKey, TValue class

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Cache()
protected Cache()
Protected Sub New
Protected Sub New
protected:
Cache()
protected:
Cache()
See Also
Cache TKey, TValue  Class
Cache TKey, TValue  Members
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Cache(TKey, TValue) Methods

Cache TKey, TValue Methods Lucene.Net Class Library
The Cache TKey, TValue type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the cache.
Public method | ContainsKey | Returns whether the given key is in this cache.
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | Returns the value for the given key.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Put | Puts a (key, value)-pair into the cache.
 | SynchronizedCache | Returns a thread-safe cache backed by the specified cache. In order to guarantee thread-safety, all access to the backed cache must be accomplished through the returned cache.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Cache TKey, TValue Class
Lucene.Net.Util.Cache Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Close Method

Cache TKey, TValue Close Method Lucene.Net Class Library
Closes the cache.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
[ObsoleteAttribute("Use Dispose() instead")]
public void Close()
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
<ObsoleteAttribute("Use Dispose() instead")> _
Public Sub Close
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
public:
[ObsoleteAttribute(L"Use Dispose() instead")]
void Close()
See Also
Cache TKey, TValue  Class
Cache TKey, TValue  Members
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ContainsKey Method

Cache TKey, TValue ContainsKey Method Lucene.Net Class Library
Returns whether the given key is in this cache.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool ContainsKey(
    Object key
)
public abstract bool ContainsKey(
    Object key
)
Public MustOverride Function ContainsKey ( _
    key As Object _
) As Boolean
Public MustOverride Function ContainsKey ( _
    key As Object _
) As Boolean
public:
virtual bool ContainsKey(
    Object^ key
) abstract
public:
virtual bool ContainsKey(
    Object^ key
) abstract
Parameters
key
Type:   Online System Object
See Also
Cache TKey, TValue  Class
Cache TKey, TValue  Members
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

Cache TKey, TValue Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Cache TKey, TValue
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Cache TKey, TValue and optionally releases the managed resources
Back to Top
See Also
Cache TKey, TValue Class
Cache TKey, TValue Members
Lucene.Net.Util.Cache Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

Cache TKey, TValue Dispose Method Lucene.Net Class Library
Releases all resources used by the Cache TKey, TValue

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
Implements
  Online IDisposable Dispose
See Also
Cache TKey, TValue  Class
Cache TKey, TValue  Members
Dispose Overload
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

Cache TKey, TValue Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the Cache TKey, TValue and optionally releases the managed resources

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void Dispose(
    bool disposing
)
protected abstract void Dispose(
    bool disposing
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
Protected MustOverride Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) abstract
protected:
virtual void Dispose(
    bool disposing
) abstract
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
Cache TKey, TValue  Class
Cache TKey, TValue  Members
Dispose Overload
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method

Cache TKey, TValue Get Method Lucene.Net Class Library
Returns the value for the given key.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract TValue Get(
    Object key
)
public abstract TValue Get(
    Object key
)
Public MustOverride Function Get ( _
    key As Object _
) As TValue
Public MustOverride Function Get ( _
    key As Object _
) As TValue
public:
virtual TValue Get(
    Object^ key
) abstract
public:
virtual TValue Get(
    Object^ key
) abstract
Parameters
key
Type:   Online System Object
See Also
Cache TKey, TValue  Class
Cache TKey, TValue  Members
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Put Method

Cache TKey, TValue Put Method Lucene.Net Class Library
Puts a (key, value)-pair into the cache.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Put(
    TKey key,
    TValue value_Renamed
)
public abstract void Put(
    TKey key,
    TValue value_Renamed
)
Public MustOverride Sub Put ( _
    key As TKey, _
    value_Renamed As TValue _
)
Public MustOverride Sub Put ( _
    key As TKey, _
    value_Renamed As TValue _
)
public:
virtual void Put(
    TKey key,
    TValue value_Renamed
) abstract
public:
virtual void Put(
    TKey key,
    TValue value_Renamed
) abstract
Parameters
key
Type: TKey
value_Renamed
Type: TValue
See Also
Cache TKey, TValue  Class
Cache TKey, TValue  Members
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SynchronizedCache Method

Cache TKey, TValue SynchronizedCache Method Lucene.Net Class Library
Returns a thread-safe cache backed by the specified cache. In order to guarantee thread-safety, all access to the backed cache must be accomplished through the returned cache.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Cache<TKey, TValue> SynchronizedCache(
    Cache<TKey, TValue> cache
)
public static Cache<TKey, TValue> SynchronizedCache(
    Cache<TKey, TValue> cache
)
Public Shared Function SynchronizedCache ( _
    cache As Cache(Of TKey, TValue) _
) As Cache(Of TKey, TValue)
Public Shared Function SynchronizedCache ( _
    cache As Cache(Of TKey, TValue) _
) As Cache(Of TKey, TValue)
public:
static Cache<TKey, TValue>^ SynchronizedCache(
    Cache<TKey, TValue>^ cache
)
public:
static Cache<TKey, TValue>^ SynchronizedCache(
    Cache<TKey, TValue>^ cache
)
Parameters
cache
Type: Lucene.Net.Util.Cache Cache  TKey, TValue
See Also
Cache TKey, TValue  Class
Cache TKey, TValue  Members
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleLRUCache(TKey, TValue) Class

SimpleLRUCache TKey, TValue Class Lucene.Net Class Library
Inheritance Hierarchy
Online System Object
Lucene.Net.Util.Cache Cache TKey, TValue
Lucene.Net.Util.Cache SimpleMapCache TKey, TValue
Lucene.Net.Util.Cache SimpleLRUCache TKey, TValue

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SimpleLRUCache<TKey, TValue> : SimpleMapCache<TKey, TValue>
public class SimpleLRUCache<TKey, TValue> : SimpleMapCache<TKey, TValue>
Public Class SimpleLRUCache(Of TKey, TValue) _
    Inherits SimpleMapCache(Of TKey, TValue)
Public Class SimpleLRUCache(Of TKey, TValue) _
    Inherits SimpleMapCache(Of TKey, TValue)
generic<typename TKey, typename TValue>
public ref class SimpleLRUCache : public SimpleMapCache<TKey, TValue>
generic<typename TKey, typename TValue>
public ref class SimpleLRUCache : public SimpleMapCache<TKey, TValue>
Type Parameters
TKey
TValue
See Also
SimpleLRUCache TKey, TValue  Members
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleLRUCache(TKey, TValue) Members

SimpleLRUCache TKey, TValue Members Lucene.Net Class Library

The SimpleLRUCache TKey, TValue type exposes the following members.
Constructors
 | Name | Description
Public method | SimpleLRUCache TKey, TValue | Initializes a new instance of the SimpleLRUCache TKey, TValue class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the cache. (Inherited from Cache TKey, TValue .)
Public method | ContainsKey | (Inherited from SimpleMapCache TKey, TValue .)
Public method | Dispose | (Inherited from Cache TKey, TValue .)
Protected method | Dispose(Boolean) | (Inherited from SimpleMapCache TKey, TValue .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | (Overrides SimpleMapCache TKey, TValue Get(Object).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | KeySet | Returns a Set containing all keys in this cache. (Inherited from SimpleMapCache TKey, TValue .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Put | (Overrides SimpleMapCache TKey, TValue Put(TKey, TValue).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SimpleLRUCache TKey, TValue Class
Lucene.Net.Util.Cache Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleLRUCache(TKey, TValue) Constructor

SimpleLRUCache TKey, TValue Constructor Lucene.Net Class Library
Initializes a new instance of the SimpleLRUCache TKey, TValue class

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SimpleLRUCache(
    int Capacity
)
public SimpleLRUCache(
    int Capacity
)
Public Sub New ( _
    Capacity As Integer _
)
Public Sub New ( _
    Capacity As Integer _
)
public:
SimpleLRUCache(
    int Capacity
)
public:
SimpleLRUCache(
    int Capacity
)
Parameters
Capacity
Type:   Online System Int32
See Also
SimpleLRUCache TKey, TValue  Class
SimpleLRUCache TKey, TValue  Members
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleLRUCache(TKey, TValue) Methods

SimpleLRUCache TKey, TValue Methods Lucene.Net Class Library
The SimpleLRUCache TKey, TValue type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the cache. (Inherited from Cache TKey, TValue .)
Public method | ContainsKey | (Inherited from SimpleMapCache TKey, TValue .)
Public method | Dispose | (Inherited from Cache TKey, TValue .)
Protected method | Dispose(Boolean) | (Inherited from SimpleMapCache TKey, TValue .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | (Overrides SimpleMapCache TKey, TValue Get(Object).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | KeySet | Returns a Set containing all keys in this cache. (Inherited from SimpleMapCache TKey, TValue .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Put | (Overrides SimpleMapCache TKey, TValue Put(TKey, TValue).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SimpleLRUCache TKey, TValue Class
Lucene.Net.Util.Cache Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method

SimpleLRUCache TKey, TValue Get Method Lucene.Net Class Library

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TValue Get(
    Object Key
)
public override TValue Get(
    Object Key
)
Public Overrides Function Get ( _
    Key As Object _
) As TValue
Public Overrides Function Get ( _
    Key As Object _
) As TValue
public:
virtual TValue Get(
    Object^ Key
) override
public:
virtual TValue Get(
    Object^ Key
) override
Parameters
Key
Type:   Online System Object
See Also
SimpleLRUCache TKey, TValue  Class
SimpleLRUCache TKey, TValue  Members
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Put Method

SimpleLRUCache TKey, TValue Put Method Lucene.Net Class Library

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Put(
    TKey Key,
    TValue Value
)
public override void Put(
    TKey Key,
    TValue Value
)
Public Overrides Sub Put ( _
    Key As TKey, _
    Value As TValue _
)
Public Overrides Sub Put ( _
    Key As TKey, _
    Value As TValue _
)
public:
virtual void Put(
    TKey Key,
    TValue Value
) override
public:
virtual void Put(
    TKey Key,
    TValue Value
) override
Parameters
Key
Type: TKey
Value
Type: TValue
See Also
SimpleLRUCache TKey, TValue  Class
SimpleLRUCache TKey, TValue  Members
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleMapCache(TKey, TValue) Class

SimpleMapCache TKey, TValue Class Lucene.Net Class Library
Simple cache implementation that uses a HashMap to store (key, value) pairs. This cache is not synchronized, use SynchronizedCache(Cache TKey, TValue ) if needed.
Inheritance Hierarchy
Online System Object
Lucene.Net.Util.Cache Cache TKey, TValue
Lucene.Net.Util.Cache SimpleMapCache TKey, TValue
Lucene.Net.Util.Cache SimpleLRUCache TKey, TValue

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SimpleMapCache<TKey, TValue> : Cache<TKey, TValue>
public class SimpleMapCache<TKey, TValue> : Cache<TKey, TValue>
Public Class SimpleMapCache(Of TKey, TValue) _
    Inherits Cache(Of TKey, TValue)
Public Class SimpleMapCache(Of TKey, TValue) _
    Inherits Cache(Of TKey, TValue)
generic<typename TKey, typename TValue>
public ref class SimpleMapCache : public Cache<TKey, TValue>
generic<typename TKey, typename TValue>
public ref class SimpleMapCache : public Cache<TKey, TValue>
Type Parameters
TKey
TValue
See Also
SimpleMapCache TKey, TValue  Members
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleMapCache(TKey, TValue) Members

SimpleMapCache TKey, TValue Members Lucene.Net Class Library

The SimpleMapCache TKey, TValue type exposes the following members.
Constructors
 | Name | Description
Public method | SimpleMapCache TKey, TValue | Initializes a new instance of the SimpleMapCache TKey, TValue class
Public method | SimpleMapCache TKey, TValue (Dictionary TKey, TValue ) | Initializes a new instance of the SimpleMapCache TKey, TValue class
Back to Top
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the cache. (Inherited from Cache TKey, TValue .)
Public method | ContainsKey | (Overrides Cache TKey, TValue ContainsKey(Object).)
Public method | Dispose | (Inherited from Cache TKey, TValue .)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SimpleMapCache TKey, TValue and optionally releases the managed resources (Overrides Cache TKey, TValue Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | (Overrides Cache TKey, TValue Get(Object).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | KeySet | Returns a Set containing all keys in this cache.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Put | (Overrides Cache TKey, TValue Put(TKey, TValue).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SimpleMapCache TKey, TValue Class
Lucene.Net.Util.Cache Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleMapCache(TKey, TValue) Constructor

SimpleMapCache TKey, TValue Constructor Lucene.Net Class Library
Overload List
 | Name | Description
Public method | SimpleMapCache TKey, TValue | Initializes a new instance of the SimpleMapCache TKey, TValue class
Public method | SimpleMapCache TKey, TValue (Dictionary TKey, TValue ) | Initializes a new instance of the SimpleMapCache TKey, TValue class
Back to Top
See Also
SimpleMapCache TKey, TValue Class
SimpleMapCache TKey, TValue Members
Lucene.Net.Util.Cache Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleMapCache(TKey, TValue) Constructor

SimpleMapCache TKey, TValue Constructor Lucene.Net Class Library
Initializes a new instance of the SimpleMapCache TKey, TValue class

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SimpleMapCache()
public SimpleMapCache()
Public Sub New
Public Sub New
public:
SimpleMapCache()
public:
SimpleMapCache()
See Also
SimpleMapCache TKey, TValue  Class
SimpleMapCache TKey, TValue  Members
SimpleMapCache TKey, TValue  Overload
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleMapCache(TKey, TValue) Constructor (Dictionary(TKey, TValue))

SimpleMapCache TKey, TValue Constructor (Dictionary TKey, TValue ) Lucene.Net Class Library
Initializes a new instance of the SimpleMapCache TKey, TValue class

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SimpleMapCache(
    Dictionary<TKey, TValue> map
)
public SimpleMapCache(
    Dictionary<TKey, TValue> map
)
Public Sub New ( _
    map As Dictionary(Of TKey, TValue) _
)
Public Sub New ( _
    map As Dictionary(Of TKey, TValue) _
)
public:
SimpleMapCache(
    Dictionary<TKey, TValue>^ map
)
public:
SimpleMapCache(
    Dictionary<TKey, TValue>^ map
)
Parameters
map
Type:   Online System.Collections.Generic Dictionary  TKey, TValue
See Also
SimpleMapCache TKey, TValue  Class
SimpleMapCache TKey, TValue  Members
SimpleMapCache TKey, TValue  Overload
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


SimpleMapCache(TKey, TValue) Methods

SimpleMapCache TKey, TValue Methods Lucene.Net Class Library
The SimpleMapCache TKey, TValue type exposes the following members.
Methods
 | Name | Description
Public method | Close | Obsolete. Closes the cache. (Inherited from Cache TKey, TValue .)
Public method | ContainsKey | (Overrides Cache TKey, TValue ContainsKey(Object).)
Public method | Dispose | (Inherited from Cache TKey, TValue .)
Protected method | Dispose(Boolean) | (Overrides Cache TKey, TValue Dispose(Boolean).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | (Overrides Cache TKey, TValue Get(Object).)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | KeySet | Returns a Set containing all keys in this cache.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Put | (Overrides Cache TKey, TValue Put(TKey, TValue).)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
SimpleMapCache TKey, TValue Class
Lucene.Net.Util.Cache Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


ContainsKey Method

SimpleMapCache TKey, TValue ContainsKey Method Lucene.Net Class Library

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool ContainsKey(
    Object key
)
public override bool ContainsKey(
    Object key
)
Public Overrides Function ContainsKey ( _
    key As Object _
) As Boolean
Public Overrides Function ContainsKey ( _
    key As Object _
) As Boolean
public:
virtual bool ContainsKey(
    Object^ key
) override
public:
virtual bool ContainsKey(
    Object^ key
) override
Parameters
key
Type:   Online System Object
See Also
SimpleMapCache TKey, TValue  Class
SimpleMapCache TKey, TValue  Members
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method

SimpleMapCache TKey, TValue Dispose Method Lucene.Net Class Library
Overload List
 | Name | Description
Public method | Dispose | (Inherited from Cache TKey, TValue .)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SimpleMapCache TKey, TValue and optionally releases the managed resources (Overrides Cache TKey, TValue Dispose(Boolean).)
Back to Top
See Also
SimpleMapCache TKey, TValue Class
SimpleMapCache TKey, TValue Members
Lucene.Net.Util.Cache Namespace

Copyright 2013 The Apache Software Foundation. Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.

Online Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Dispose Method (Boolean)

SimpleMapCache TKey, TValue Dispose Method (Boolean) Lucene.Net Class Library
Releases the unmanaged resources used by the SimpleMapCache TKey, TValue and optionally releases the managed resources

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing
Type:   Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
SimpleMapCache TKey, TValue  Class
SimpleMapCache TKey, TValue  Members
Dispose Overload
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Get Method

SimpleMapCache TKey, TValue Get Method Lucene.Net Class Library

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TValue Get(
    Object key
)
public override TValue Get(
    Object key
)
Public Overrides Function Get ( _
    key As Object _
) As TValue
Public Overrides Function Get ( _
    key As Object _
) As TValue
public:
virtual TValue Get(
    Object^ key
) override
public:
virtual TValue Get(
    Object^ key
) override
Parameters
key
Type:   Online System Object
See Also
SimpleMapCache TKey, TValue  Class
SimpleMapCache TKey, TValue  Members
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


KeySet Method

SimpleMapCache TKey, TValue KeySet Method Lucene.Net Class Library
Returns a Set containing all keys in this cache.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual HashSet<TKey> KeySet()
public virtual HashSet<TKey> KeySet()
Public Overridable Function KeySet As HashSet(Of TKey)
Public Overridable Function KeySet As HashSet(Of TKey)
public:
virtual HashSet<TKey>^ KeySet()
public:
virtual HashSet<TKey>^ KeySet()
See Also
SimpleMapCache TKey, TValue  Class
SimpleMapCache TKey, TValue  Members
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)


Put Method

SimpleMapCache TKey, TValue Put Method Lucene.Net Class Library

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 3.0.3.0
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Put(
    TKey key,
    TValue value_Renamed
)
public override void Put(
    TKey key,
    TValue value_Renamed
)
Public Overrides Sub Put ( _
    key As TKey, _
    value_Renamed As TValue _
)
Public Overrides Sub Put ( _
    key As TKey, _
    value_Renamed As TValue _
)
public:
virtual void Put(
    TKey key,
    TValue value_Renamed
) override
public:
virtual void Put(
    TKey key,
    TValue value_Renamed
) override
Parameters
key
Type: TKey
value_Renamed
Type: TValue
See Also
SimpleMapCache TKey, TValue  Class
SimpleMapCache TKey, TValue  Members
Lucene.Net.Util.Cache Namespace
Copyright 2013 The Apache Software Foundation.  Apache Lucene.Net, Lucene.Net, Apache, the Apache feather logo, and the Apache Lucene.Net project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
  Online
                        Licensed under the Apache License, Version 2.0. (http://www.apache.org/licenses/LICENSE-2.0)